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Working environment

Overview
The FrameMaker working philosophy differs significantly from the habits acquired with text processors such as MS Word. But FrameMaker is the “tool
of the trade” for long and long living documents.
The working environment is not as fancy as that of
office applications, but provides all you need for
your work. It can be customised, although not to the
extent of other Windows applications, because FM is
a work horse and can not be dolled up like a dog's
dinner.
There are numerous add-ons (Application Programming Interface clients) from third party vendors, because FM concentrates ‘on the core business’ of the
application.
FrameMaker 8 contains the standard interface and
the structured interface (to work on structured documents). This compendium is only about the standard interface.
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Working with FrameMaker
My way towards
FrameMaker

Until the beginning of the 1990’s the author (Klaus Daube)
worked for about 20 years on IBM mainframes. We were lacking methods and applications to process documents. Not letters and memos of short life time, but handbooks about long
living software and the services of a computing centre.
IBM had such a system at hand (DCF - Document Composition
Facility), but it was a resource hog and was not user friendly
at all. We also did not have the printers it supported. We knew
about Donald Knuth’s TEX system, but did not have a UNIX
system to run it. After discussions with IBM to make their system more useful for us we decided to develop our own system
(Susi). Unfortunately we could not complete our work, because
the company was closed. At that time we already were able to
produce all our manuals with Susi and print on PostScript
printers (At that time IBM did not have an idea about PostScript and its advantages for font handling).
At my next employer (1992) I became responsible for a small
group of people documenting software with MS Word. I tried
to automate many things by macros and templates. But for
the long documents Word was not stable at all and we lost
much time1). Then I discovered FrameMaker. In those times it
was version 3 (see History of FrameMaker). Immediately I fell
in love with this application, because it supported nearly all
the ideas we had developed for Susi. Eventhough tables were
supported only rudimentary, our efficiency grew significantly.
After forced change to self employment (1994) I developed
my skills in FrameMaker further and started to give classes at
the ETH in Zurich for people writing theses. And of course all
documentation work done as a free lances was produced in
FrameMaker2). With FrameMaker it is easy to keep deadlines!

Paul Findon writes in
March 2005

FrameMaker is the premier authoring and publishing application for long, structured technical documents such as books
and instruction manuals. Seventeen years since it was first
released, yet still nothing comes remotely close.
Frame Technology, cofounded by Steve Kirsch, Charles Corfield, David Murray, and Vickie Blakeslee in 1986, released
FrameMaker Version 1.3 in 1988. Kevin Lynch created the Mac
version. The Windows version came later. Its main competitor
at that time was Interleaf. Adobe acquired Frame Technology
and FrameMaker in 1995.
FrameMaker is a fantastic application that does exactly what
it says on the box - long documents - no more, no less. It's
perfect for technical documents and books of between 1 and
10,000 pages, although I also use it for letters, newsletters,
CD/DVD insert artwork, faxes, and so on. It's used by publishing professionals around the world. Boeing used it to document the 777 - imagine how many thousands of pages that
1
2
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Word was developed for short living documents and even in it’s 2007 version does not support long living items and consistent style in an adequate manner.
Some attempts to work with MS Word (on customer request) failed lamentably - even with the help of experts.
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required. One of its major strengths was the fact that it is was
available for Mac, Windows, and UNIX3), so documents can
easily be shared (no other application supports Mac, Windows, and UNIX). Software developers, engineers, and scientists could use FrameMaker on their UNIX workstation in the
office, then take their Frame documents home and continue
working on their Macs. And this wasn't just 95% cross-platform compatibility. It was 100% compatibility! I remember
being impressed every time I opened a NeXT FrameMaker file
on the Mac - flawless.
FrameMaker supported hypertext long before the World Wide
Web, and tables, cross-references, character formats, variables, PDF, SGML, XML, and so on. In the '90s, you could easily
spot a document made in FrameMaker because it contained
tables and cross-references. In contrast, manuals made in
PageMaker stood out because of their lack of cross-references. Then there's the equation editor, multilingual support,
including double-byte (Japanese, Chinese, Korean), footnotes,
and conditional text.
FrameMaker is fast and reliable - one of the few applications
that doesn't suffer from bloat - crashes are virtually noneexistent, as is document corruption (PageMaker and Word
users know all about that). Unlike page-layout applications,
tables and graphics are anchored to, and flow with the text,
so adding new text at the beginning of a document doesn't
cause them to slip out of place.

Basic philosophy

While You can work with FrameMaker the same ‘wild’ way as
in a text processing software, the intended method of working uses a layout template comprising format names for all
required text elements (headings, body text, lists etc.), highlights, tables and cross reference templates.
The free-style (or style-free) method is adequate for memos,
letters etc. with short lifetime. Most work done with FrameMaker lives for several years 4) and is updated in this time frequently.

D

Every FrameMaker document contains all information about
layout and styles and hence can be the template for other
documents. Styles are collected in catalogues and the import
of styles (based on their names) from another FrameMaker
document is a fundamental principle. Thus the change of
appearance, or change of product names etc. does not take
hours but minutes.
Structured documentation goes even further: you do not deal
with paragraphs any more but with elements. All formatting
is based on rules. Hence content and structure is strictly separated from formatting. This compendium does not deal with
this method, which is increasingly supported in the newer
FrameMaker version. Look for the keyword DITA!

3

4

1–3

There is no Mac version after FM 7.0, mainly because the market share of
Macintosh is far smaller than that of Windows. Since Mac OS X on Intel
based machines there are virtual environments (e.g. Parallels) to run a
Windows version of FM on the same hardware.
Keep in mind that technical documentation must be maintained as long
as the product lives – and this may be more than 15 years.

What’s new in FrameMaker 8

What’s new in FrameMaker 8
See also www.daube.ch/docu/fmhist00.html

Unicode text

The main feature FrameMaker 8 brought to its users (and
which prompted great enthusiasm) is the capability to handle
Unicode characters. FrameMaker no more is restricted to the
small number of languages which can be handled by the FM
internal character set (see Frame Roman code table on
page A-6).
The development team at Adobe India did a great job, in that
both the old ‘system’ and the new capabilities can live side by
side. This affects not only entered text, but also all text
entered into dialogues. Of course, to fully exploit the capabilities of Unicode you need to use adequate fonts. For example,
PostScript fonts (Type 1) are completely out, because they
support only a limited character set.

Platforms

FrameMaker version 7.0 (2002) was the last one available for
the Macintosh with OS 9. FrameMaker 8 runs only on Windows
2000, XP and Vista™ and on Sun Solaris™ 8, 9, or 10. Other
UNIX flavours and older Windows versions are not supported,
although FrameMaker may run under some circumstances.

Document handling

Tracking edited text on page 13-9 introduces a feature known
from text processing. Added, deleted or changed text can be
highlighted and the changes can be accepted or rejected.

Conditional text

The definition of conditions has been significantly enhanced
by means of boolean logic. This allows to handle a greater
number of conditions with ease. See Conditional text on
page 13-13

Import of text and
graphics

The text import filters have been enhanced and adapted to
new formats, especially for MS Office 2007 applications. For
graphics the import of Flash as well as for Acrobat 3D has
been added. File paths can be URLs (such as http://
www.daube.ch/navbar-z.png).

PDF output

Save to PDF has become absolutely reliable and the generated
PDF can contain Flash or 3D objects. Bookmarks are now
using Unicode.

Languages

Dictionaries for spell checking are available for additional
languages (see Supported languages on page 2-13). However no
thesauri were added for the additional languages.

HTML output

The companion software WebWorks Publisher is no more part
of the delivery. Hence only the internal “Save as HTML” and
the new “Save as XML” are available. See Generate HTML and
XML on page 12-1. Within TCS2 RoboHelp takes over.

Structured FrameMaker

The functionality of structured FrameMaker has been significantly enhanced with support of DITA and round-trip XML
which saves all FM specific objects. This is not covered in this
compendium.

1–4
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Starting FrameMaker in standard mode
Beginning with FrameMaker 7 two interfaces are available:
 Standard (unstructured)
2011-05-11

 Structured (with SGML techniques)
To check the current interface, select File > Preferences >
General and look at the bottom of the dialouge. If “Structured
FrameMaker” is listed in the drop down list Product Interface, change to standard FrameMaker:
1 Select FrameMaker in the drop down list.
2 Close FrameMaker and start again.
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FrameMaker workspace
The FrameMaker window contains both fix areas and items
the visibility of which can be toggled on and off (*):
1 Menu bar

1

2 Button bar with 4
‘pages’

2

3

3 Quick Formatting Bar

4

5

4 Drop down list paragraph catalogue

6

5 Tabs for open documents and books.

10

6 Buttons for floating
palettes
7 Status area
8 Page number area
9 Zoom and Page buttons
10 Open palette Paragraph
catalogue

D

7

8

9

Plug-ins may install additional items in the menu bar, such as
‘FrameScript’ displayed here.
Toggle visibility of the button bar (2) and Quick Formatting
Bar (3, 4) with menu View > Quick Access Bar and > Formatting Bar.
Indication of modified
formats

The status area (6) displays information from the current
selection or cursor location: flow, paragraph format and character format. An asterisk (*) preceding a format name indicates local overrides (change relative to the information in the
catalogues).

Indication of changes

The page information (4) displays the current page number
and total number of pages. An asterisk appears after the sec-
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ond number if changes to the saved version have been
applied. After saving the * disappears and the diskette icon in
the left area of (2) is greyed out.
Change zoom factor

Non printing items in
display area

Change the zoom factor to the next lower value with the z
button and to the next larger value with the Z button.
Toggle visibility of the following items with View > xxx.
Borders

are associated with the cell borders of tables, text
frames, graphic frames and anchored frames.

Text Symbolsindicate end-of-paragraph and other situations.
See Control characters in the text on page 1-19.
Rulers

are not that helpful in FrameMaker, because they
align with the paper edge, not the text edge.

Grid Lines align to the top left corner of their container. With
nested frames you may see different areas.

Preferences for FM session
In FrameMaker preferences are „levelled“: Some are global to
the FrameMaker installation, others are valid throughout a
session and many are set in a document.

Preferences for the
current FrameMaker
session
Set the program preferences with File > Preferences > General:
p Set Automatic Backup on Save if you want to keep a copy
of the original state of the documents (before you started
editing them).
p Automatic Save every (5) Minutes is a good insurance
against system crashes. FrameMaker saves very fast! FrameMaker is very stable – this feature is rarely needed.
p Show file translation errors will display found errors
when opening files (e.g. from other platforms).
p Greek Screen Text displays text smaller than the given
size as gray box to save processing time.
p Since FM 7.2 the warnings about clearing the Undo History
can be specified.
p Cross-Platform File Naming must select the ‘most restrictive’ among the platforms for which the files are used (Unix
8 Mac 8 Windows). Windows is least restrictive.
p Save FrameImage with Imported Graphic saves a special
vector form of the graphic with the document. This speeds
up the display of imported graphics, because the filter is
only activated for modified source files.
p Network File Locking is a must for files residing on a LAN.
Otherwise the file can be opened independently.
p Remember Missing Font Names is a must for cross-platform working if not all fonts are available on all platforms.
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Preferences for the current document

Modify list of zoom
factors

The list of zoom factors can be set for the current session:
click on the drop down list and select Set...
In dialogue Zoom Menu Options set the values to your
desire. Default settings are taken from the frame.ini file. The
value range is 25... 1600%.
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You may modify the list of default values in the maker.ini
file. See Zoom factors on page A-31.

Set units of measure

You may also wish to set the units of measure. These are
defaults for entering values in various dialogues, for example
the Paragraph Designer or the Table Designer.

Preferences for the current document
Although these options may be individual for a document, it
is advisable to at least keep them constant for a project (or
FrameMaker book).

Text options
E:\FM-course\handout\working.fm

With Format > Document... > Text options you set properties
of the current document:
p Smart quotes translates ordinary quotes ("a", ’a’) during
keyboard input to typographic quotes (“a”, ‘a’). These
forms depend on the UI language and can only be set in
maker.ini. Hence they are actually pertinent to the FrameMaker installation. See Smart quotes on page A-32.
p Smart Spaces reduce multiple spaces (
) during keyboard input to at most one space to keep the text neat.
p Allow Line Breaks After special symbols allow automatic
hyphenation of words containing these special characters.
You enter these characters either directly (—) or via it’s
meta-notation (\m). See Special characters in dialogue boxes
on page A-4)
p You may wish to set special properties for Superscript,
Subscript and Small Caps (German: Kapitälchen). For this
compendium the size of super/subscript is set to 70% and
the offset for superscript is 30%. The standard settings
require a larger line spacing (> 120% of type size).

D

Note:

Set view options

For a more complete list of document properties see Document
Properties on page 3-15.
The method of displaying pages (facing, horizontal scroll etc.)
is a property of the document. Set this option with View >
Options... according to your needs.
Setting Variable provides a good automatism: for small
enough zoom factors pages are arranged in blocks. If two
pages fit into the display area, they are facing.
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Preferences of other scope
Installation specific
settings

Preferences can be set in the maker.ini file located in the
home-directory of FrameMaker. See Modifications to maker.ini
on page A-32 for recommended changes.





User specific settings

File locations (e.g. dictionaries)
Font mapping
Pen widths, dash patterns
Smart quote characters

Since version 7 FM stores User specific settings in
%appdata%\Adobe\FrameMaker\n.n (for example: C:\Documents
and Settings\Klaus\Application
Data\Adobe\FrameMaker\8.0)
To get a fresh copy of the $HOME\maker.ini you need to delete
the file in %appdata%.

Program inherent
defaults

There are a number of defaults, which can only be adapted by
plug-ins. Examples for these are:
 Type and placement of anchored frame when inserting an
image, including the margin to the image.
 Default ¶-format for new text frames.
 Number of default page sizes and their properties (e.g.
margins).

Navigate in documents
Go to specific page

p Click into the page number area. In the dialogue Go to
Page enter the desired page number and Go.
p You may want to jump back to the page where you have
left the cursor in the text: select the appropriate option
button.
To go back to where you jumped from enter ESC, v, P (English FM).
The information to this section is from Shlomo Perets.
For the numerous keyboard shortcuts see Help, appendix B on
“Navigating through documents”. For example:

To last page

Esc, p, l (lowercase L); Alt+PgDn; Shift and click the Next Page
button (see FrameMaker workspace on page 1-5; Zoom and
Page Buttons)

Go back

The go back after a jump or hyperjump, use ESC, v, P (in same
document only).

Outline view not
available

FrameMaker does not offer an outline view to get an overview
of the headings in a document. However, you can use the
cross-reference mechanism as a workaround.
Using a special Table of Contents you might come very close
to the needed function. See Simulate an outline view on
page A-30.
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Navigate in documents
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Special > Cross Reference opens the dialogue where can see
the headings (even all paragraph types) from the current or
other open documents):
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Select the desired document and get an overview of the main
headings. Then you can directly jump to that heading by
clicking the Go to Source button.

Follow cross references

If you have placed cross references in the text already (see
Cross-references on page 7-6), you can ALT+click on them to
follow this link. ESC, v, P to come back works only within the
same document.

Return to insertion point

Pg up/down does not reset the insertion point. After paging
to a particular location you may get back to the page with the
insertion point with the < or 8 key.

Mark special locations

To find special locations you may set up and apply a character format with a hinting name (such as z-tobe-checked). All
properties are “As is” to not modify the appearance. See Character styles on page 3-13 for how to set up such a format.
To find such marked locations, select Character Tag in the
Find/Change dialogue and enter the name of the format (for
example z-tobe-checked) into the field.
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You may also use special markers to identify a location. For
example, define a marker type comment-terminology and
insert it where terminology has to be checked. To find these
locations, select Marker of Type: in the Find/Change dialogue and type the name of your marker (commentterminology) into the field.
See Identify locations on page 7-10.
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Customising FrameMaker
Due to its platform concept, FrameMaker does not exploit the
GUIs to their limits. Hence customisation is not a task for the
end-user, but for programming experts. Customisable are:
 The menus and their contents, the tool bars (see Modified
tool bars on page 1-21)
 The size of the default page (which is the really empty one)
 Minimum styles (paragraph, character, table) for new documents are located in a special template.

Sample templates
FrameMaker comes with a number of sample templates
 Report, Book, Letter, Resumee and Conditional Text.
 In the English version layout is based on the 8.5" × 11"
paper (called Letter).

To use a sample template

p File > New > Document…
p Use button Explore Standard Templates.
p From the appearing list select a template

p To create an empty document from the template, click Create
p To display a sample layout, click Show Sample
p Close the last FrameMaker instance (Standard Templates),
which you do not need any more.
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Help and documentation

Help and documentation
International versus US FrameMaker
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At the installation of FrameMaker you are asked whether to
install the US version or the International English version. The
differences are:
US-version
Language of User interface

International English
US-english (color, not colour)

Paper size of templates

Letter

A4

Language in ¶ formats of
predefined templates

US English

UK English

For working with the International English version it is good
practice to set the default language appropriately. See Default
language in ¶ and f designer on page A-32.
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FrameMaker Help
In the help menu you find two entries for Help: Help Topics
(can also be invoked by F1) and Complete FrameMaker Help.

Help Topics

This is the offline (local) version of Help. Version 6 of Framemaker introduced the platform dependent help system. Version 7 provides HTML help files which are opened in your
default browser. FrameMaker 8 resorts to the platform specific format FrameMaker.chm (compiled HTML help):
 The help system includes all of the information in the
Adobe FrameMaker 8.0 User Guide plus keyboard short-cuts,
full-colour illustrations, and more detailed information
about some procedures.

D

 You can not search for symbols, such as $ or #. For example searching for $1 finds all occurrences of the figure 1…
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Help and documentation

Complete FrameMaker
Help

This links to www.adobe.com/support/documentation. Under
User Guide you can select LiveDocs or PDF.
With PDF you get the complete user guide (same text as the
offline help), which can be searched in the PDF manner.
LiveDocs of some Adobe products use wiki like interface.

Under Browse you can select other Adobe products where you
want to search (for example, Acrobat Pro or DreamWeaver).
Here you can search for $1 (finding “Header/Footer $1”), but
other special symbols (for example, # ¶ ®) may not provide
useful results.

Documentation
Adobe documentation

 Same manual for all platforms and for both user interfaces.
Since FM-8 the manual is no more part of the delivery. You
need to order it separately from Adobe Shop.
 Quick Reference Card.
 Online-manuals for special themes. These are no more referenced in the Help menu. They are located in the $FMHOME/
OnlineManuals directory. 5)

Third party
documentation

 Ute Mitschke, Adobe FrameMaker. Das Praxisbuch für
Profis - ab Version 8. Addison Wesley ISBN-13: 978-3-82732695-9; 512 Seiten (Softcover); CD-ROM PC
 Klaus Krüger, Adobe FrameMaker 8, Dokumente
formatieren, PDF Dateien generieren, XML verarbeiten.
Springer Verlag, ISBN-13: 978-3-540-77904-9; 297 Seiten
(Hardcover)
While all documentation for FrameMaker 7 is still valid, it
misses new features.
 Sarah S. O'Keefe and Sheila A. Loring, with Terry Smith and
Lydia K. Wong: Publishing Fundamentals: Unstructured
FrameMaker 8. ISBN 9780970473349.
 Jürgen Gulbins, Angelika Obermayr, Karl Obermayr:
Desktop Publishing mit FrameMaker 6 & 7 [4. aufl. Springer
5
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$FMHOME is the symbolic name for the installation directory of FrameMaker. This may be, for example, H:\adobe\FrameMaker.8en

Documentation

2003], ISBN 3-540-44216-2. www.framebuch.de
Das buch wendet sich an anwender von Mac OS, Unix und
Windows. Es bietet eine grundlage für die arbeit mit
FrameMaker und gibt tips und hinweise aus der praxis. Es
vermittelt grundlagen zur typographie, zum einsatz und druck
von farbe, zur online-zusammenarbeit mit WebDAV, sowie zur
ausgabe mit PDF, HTML und XML.
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 Ute Mitschke und Bernhard Schulze: FrameMaker 6+7; In
der Praxis anwenden und beherrschen; mit CD-ROM;
broschiert - 560 seiten [Addison-Wesley 2002]
ISBN 3-8273-1736-3.
Das buch zielt gerade auch auf professionelle anwender und
deckt neben satz/layout und der erstellung von
dokumentvorlagen auch den bereich databased publishing/
cross media sowie den plattformunabhängigen datenaustausch
mit SGML/XML ab.
 Sarah S. O‘Keefe and Sheila A. Losing: FrameMaker 7, The
complete Reference; [Mc Graw Hill Osborne 2002, ISBN 007-222361-8 (about 850 pages).
The authoritative resource on FrameMaker 7. Master the myriad features and complex interface of FrameMaker 7, and
implement complex multichannel publishing solutions. This
book helps you understand and master FM’s many features to
increase your productivity and improve your published documents. Learn to create and manipulate text, control page layout, and construct books – plus advanced techniques including
hypertext, modular text, and working with XML, SGML, DTDs,
and element definition documents.
 … and many more, see for example, www.amazon.com with
the keyword framemaker. However, from the above mentioned books Klaus Daube knows the authors personally.

Training videos

All of Scriptorium's FrameMaker 7 training materials are
available for free at wiki.scriptorium.com.
Shlomo Perets from MicroType.com offers web-based training
courses in a series of 1h sessions.
Markus Bollenbach created a DVD with 9h video instruction
(in German) about FrameMaker 8.

Mailing lists
US-mailing list

Send Framers mailing list submissions to

D

framers@lists.frameusers.com

To subscribe or unsubscribe via the World Wide Web, visit
http://lists.frameusers.com/mailman/listinfo/framers

or, via email, send a message with subject or body 'help' to
framers-request@lists.frameusers.com

You can reach the person managing the list at
framers-owner@lists.frameusers.com

German mailing list

Webform for enrolment:
http://tipps.frame-user.de/seiten/maillisten/frametalk-form.mgi
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Elements of the work space
Palettes and catalogues
Tool palette

The Tool palette is located to the top right of a document window.
Display the Paragraph catalog (see Catalogues on page 1-14)
or use menu Format > Paragraphs > Catalog
Display the Character catalog (see Catalogues on page 1-14)
or use menu Format > Characters > Catalog
Display the Graphics Tool palette (see Graphic objects on
page 1-18)
Display Formula Palette (Palette overview on page 11-6)
Display the History Palette. See Command History palette on
page 20.
If the ¶ and the f buttons are missing, but others are visible,
FrameMaker is run in structured mode. To switch to standard
mode, see Starting FrameMaker in standard mode on page 1-5.

Catalogues

The table catalogue is displayed with Table > Table
Designer… and then opening the tab Basic and pulling down
the list Table Tag.
Paragraph catalogue

Character catalogue

Table catalog

History Palette (since FM 7.2)

Other catalogues are visible only via special functions, e.g.:
Colour

View > Color > Definitions and in the Tools Palette

Cross-refsSpecial > Cross-Reference… Format
Table-rulesTable > Custom Ruling Shading > Edit Ruling Style
Variables Special > Variable…
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move left 1pt

move right 1pt

align top

align centre vert.

align bottom

align left

align centre horiz.

align right

rotate clockwise

rotate anticlockw.

solid line

dashed line

select table

go to top left cell

add row below

add column right

cut row / column

top align in cell

centre align in cell

bottom align in cell

straddle / unstraddle

shrink wrap cells

custom rules/shades

move down 1pt

select column

select body cells

move up 1pt

Edit tables

select row
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Gravity

Snap

Object property

Resize

Mirror left/right

Flip up/down

Unsmooth

Smooth

Reshape

Distribute

insert Table

insert Footnote

insert anchored fr.

Spell check

Find / change

to Upper case

Initial capitals

to Lower case

Decrease size 1pt

Increase size 1pt

Underlined

Italic

Bold

Plain text
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Common commands and
Quick Formatting Bar

to Back

to Front

Ungroup

Group
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Quick access bar (tool bar)

Quick access bar (tool bar)
Since FM 7.2 the basic tool bar includes Redo, Import File,
Object Properties, Toggle View Only, Insert Symbols and First
Page, Last page as well as Find Next.

FrameMaker 8 brought some modernisation of the toolbar
icons and introduced tabs for easy access to open documents
(CTRL+TAB still works also to switch between documents).

Edit text

Graphic commands

Edit graphics

Elements of the work space

Menu structure
Document menus

1 – 16
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Menu structure

Book only:
Zoom
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Elements of the work space

Book menus

Graphic objects
Graphic objects are defined and inserted with the tools palette. this palette opens from the Triangle button to the right
of the FrameMaker main window.

Intelligent cursor (depending on object)
Line
Rectangle
Open polygon
Closed polygon
Create text frame

Cursor for graphic objects
Arc (circle, ellipse)
Rectangle with rounded corners
Circle, ellipse
Freehand-line, spline
One-line text

Create graphic frame
Define area fill colour

Apply area fill colour

Define line fill colour

Apply line fill colour

Define line width
Define line-end type
Define line type
Define colour
Define tint
Define overprint type
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Apply line width
Apply line-end type
Apply line type
Apply colour
Apply tint
Apply overprint type

Control characters in the text

Control characters in the text
Display of these symbols is controlled by View > Text Symbols. These symbols do not appear on output or in files.

§

End of text flow / end of table This symbol can not be deleted.
cell

¶

End of paragraph (‚contains‘
the style definition)

Typing Enter or Return terminates a
paragraph and ‘opens’ a new one.

1

Tabulation symbol

See details at Tabulation on page 2-7

2

New line (hard return)

Type SHIFT+Return for hard return

3

Non-breaking space

Type CTRL+space for this symbol

5

Optional hyphen

Indicates a location at which a word can
be hyphenated if necessary

4

Suppress automatic hyphena- Place this symbol at the beginning of a
tion
word for better clarity

6

Marker (index, cross reference,...)

Place markers preferably at the beginning of a paragraph. Do not spread them
in words.

7

Anchor (table, frame)

Place anchors preferably at the end of a
paragraph

I

Formula aligned manually

See Align formulas on page 11-7

Table 1: Control characters in the text

For searching/replacing special characters see Special characters in dialogue boxes on page A-4. Structured FrameMaker
uses additional symbols.
Note:

D
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The special symbols have no width (exception: the nonbreaking space) and you may need special techniques to handle
them. See Non-width characters on page A-8).
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In this compendium text symbols are displayed with a special
font, if they are needed to understand the situation.

Elements of the work space

Multiple Undo and Redo
Version 7.2 brings this new feature. If there is no action available for Undo or Redo in the current document, the corresponding menu items and tool bar buttons are greyed.
The command history is available through the Edit menu and
context menus. The command history is kept separately for
each document.
The following commands can not be undone:
 Commands that do not change the content, such as copying text, moving the cursor, go to another page.
 Commands that affect an external file (such as Spell
Checker commands that update the user dictionary).
 Change All in Find/Change.
Saving a document (with Save, Save As, or autosave) clears
the undo history for that document. There are various actions
which can not be undone. This is indicated with a warning
message or an indication in the dialogue.
As in previous releases, cursor movement and object selection actions are not undoable, but when a previous state is
restored, it includes the original cursor location and object
selection state.
Commands that affect an external file (such as Spell Checker
commands that update the user dictionary) are not undoable.

Command History palette

This palette allows you to select a specific action to undo or
redo. The command history is shown only for the active document.
In the command History palette, the most recent command is
highlighted. Commands listed above the most recent can not
be undone. Commands listed below the most recent are redoable, and are marked with an asterisk (*).
You can undo and redo actions only in the order in which
they were originally performed. When you select a command
to undo, all later commands (which have been affected by the
selected action) are also undone. FrameMaker also moves the
selected command and all succeeding commands to the Redo
list. Similarly, redoing a command moves it and later commands back to the Undo list.
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Extensions by API clients

Extensions by API clients
Some functions supported by plug-ins became ordinary
FrameMaker functions in later releases (for example, some
book functions).FrameMaker add-ins come in two flavours:
 API clients are ‘self-contained’ Dynamically Linked Libraries (*.dll). They integrate themselves into the menus.
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 FrameScripts are scripts which are run by the API FrameScript. The scripts are text files (sometimes ‘compiled’).
Although these plug-ins can integrate into the menus.
ITL www.itl.eu offers a large number of FrameScripts “[i]frame” which can be ordered as separate packages. There is
also a large number of free scripts available.
Script (macro) language
Extensive script
collection
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AutoText

Index tools
Outline display
Note:

RTF and HTML from MIF
Great tool box

Modified tool bars

The full featured macro language FrameScript has access to
all FM command: www.framescript.com
Rick Quatro provides FrameScripts for many tasks. Very good
scrips (also free ones) are from itl in Munic. Especially the
InstallScriptsInFolder is an essential tool to manage scripts.
This plug-in from Silicon Prairie Software allows to define a
set of text or graphic items and insert them into any FM document by a menu selection or keyboard short cut. Items
include styled text, plain text, graphics, anchored frames, and
tables.
Silicon Prairie Software:www.kagi.com/spsoftware/
Outline display of document similar to the capabilities of
FrameMaker + SGML: www.sandybrook.com. For
Sandybrook Software: while Enhance can be installed onto
FrameMaker 8, it is not supported. Users have reported application instability when running Enhance on FM8.
Export of FM (MIF) to Word RTF, HTML and winhelp with
mif2go by www.omsys.com
Systec tool box: www.systec-gmbh.com/toolbox. not only
extends Framemaker, but also Acrobat and Adobe Reader.
www.microtype.com provides a tool bar with many functional
additions (for displays of 1024 pixel width).
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For example, the Quick Formatting Bar is extended by drop
down lists for Character Catalogue and Font. The standard
button bar is ‘folded’ into two long items, easing the access
significantly. Very useful commands are added, for example
F4 to repeat a paragraph formatting.

Database of plug-ins

Scott Prentice maintains a database of FrameMaker (and
Word) tools at www.leximation.com.
Lin Sim’s List of FrameMaker Utilities and plugins was
updated 2009-05.

1 – 21

Structured documents

Structured documents
Structured documents do not deal with paragraphs and highlights, but with elements and attributes. Behind the elements
there may be rules so that you will not be allowed to place
headings in succession without intervening text.
The rules are based on a document structure and hence can
give advice what elements are valid in a particular position in
the document.

Open structured document in standard FrameMaker
When opening a structured document in unstructured mode,
you are warned with a Document is Structured message.
p You may view the document with no further consequences.
p If you choose to Open for Editing, any structure information is lost in the document.
p You may, however, Cancel the opening, switch FrameMaker
into structured mode (seeStarting FrameMaker in standard
mode on page 1-5) and edit the file correctly.
p Undo is not supported for structured books (FM 7.2)
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FIle handling

FIle handling
Common file hanlding like open and save use the standard
Windows features and dialogues.

Opening files
2011-05-11

FrameMaker can open the following types of files:
 FrameMaker files (*.fm)
 FrameMaker book files (*.book).
 FrameMaker Interchange Format (*.mif).
 Other types, such as text (*.txt) or spread sheets (e.g. *.xls)
require user intervention to provide more detailed information.
This file format essentially is a text file. Until FM-7 it is 7-bit
ASCI coded. Starting with FM-8 it is UTF-8 coded. Hence MIF-8
(and later) files must be handled with Unicode capable text
editors.
The header (first line) of a MIF file indicates the level and the
creating program:
<MIFFile 7.00> # Generated by FrameMaker 8.0p236

Any FameMaker version can open any MIF version. However,
the interpretation fails, if FM<8 opens a MIF>7, because with
FM-8 the coding of MIF has changed.

Unknown file types

Opening special fiel types, such as RFT-DCA (an IBM format)
gives you the opportunity to confirm that format (or select a
more appropriate) with the following dialogue:

D

E:\FM-course\handout\working.fm

FrameMaker Interchange
Format

Depending on the selected (confirmed) file type you get an
addtional dialogue for specific information, for example:
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Text file

interpretation of code and lines

Excel

directyl interpreted, no add. dialogue

PageMaker

directly interpreted, no add. dialogue

PowerPoint

text is extracted, no add. dialogue

RTF

directly interpreted, no add. dialogue

FIle handling

In some cases you may need to guess the file properties.
Check the correct interpretion of the file by FM visually.
Text files

When opening a text file you get a dialogue stating “unknown
file type” with the assumed type (in this case Text) selected:

A text file can be interpreted as single lines or paragraphs or
even a table. And since Windows files do not bear all necessary attributes, you need to select the proper coding in the
additional dialogue.

Files created on Windows are coded in ANSI (Windows) or in
UTF-8 (which can be determined). Other encodings are used, if
the file was copied or downloaded from another operating
system.

Reopen last saved
version

With File > Revert to Saved you get the last saved version.
This lets you abando the changes you made since then.

Importing files
Importing a file inserts it at the current cursor location. In
FrameMaker this is called an inset. Depending on the nature
of the file (FrameMaker, text, spread sheet, graphic) more
detailed actions are required.
With File > Import > File you get the main dialouge to select
the file. The list of files is narrowed by selecting the desired
file type. Only graphic file types and MIF are listed:
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Saving files

MIF

If the file covers a complete FrameMaker document, you are
reqested to define the flow from which to import. See Text
insets on page 13-18.
Incomplete documents may also be imported. See Import MIF
snippets on page A-33.
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Graphic files
Other file types

See Importing graphics on page 6-2.
For other types (than graphic and MIF) you need to select the
filter All Files (*.*) in the dialogue. After Import you get
the dialogue “Unknown File Type”. See Unknown file types on
page 1-23.
See also Text insets on page 13-18.

Saving files
Automatic saving

Especially after updates of the application it is advisable for a
certain time, to automatically save every n minutes. In case of
a problem with the new versin You are on the safe side.
See Preferences for the current FrameMaker session on page 1-6.
It is always possible to save in the previous version. For example, in FM-8 you can Save As FrameMaker version 7:

D

Save for old FM versions

Note:

Keep in mind that FrameMaker 8 introduces Unicode. Hence
saving as Document 7.0 or MIF 7.0 will loose the information
about characters which are not in the FM-7 character encoding
(e.g. any none-latin characters).
See also Frame Roman code table on page A-6.
If you need to save for an older version of FrameMaker (e.g.
for FM 6 (out of FM 8), save as MIF.
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FIle handling

When this file is opened in the older application, any newer
features are filtered out (you get a lot of messages in the
FrameMaker log file).

Save as PDF

In contrast to printing to PDF a shorter process is used which
in certain cases fails to create a proper PDF. However, personally I did not encounter this problem in FM-8 in three years.
See more details at Save as PDF on page 10-4 or the alternative
method Standard process with Distiller on page 10-5.

Save as XML

See Save as XML on page 12-5.
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Printing

Printing
The print dialogue of FrameMaker provides a number of
options, of which not all may be familiar to you.
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Note:

Be aware that settings in FM dialogues are kept between calls
(and cleared only for a new FM session) . You may be sureprised to get 20 copies of a chapter, if your last print job was
20 copies of a single-page flyer … Hence alsways check all
options.
In File > Print or File > Print Book you specify standard
items, such as Page Range, and whether you want to print all
or just the even (odd) pages.
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Since some of the options have duplicates in modern print
dialogues, you may wish to select the Printer first and set its
options appropriately.
Printer

Select the desired printer. Depending on
the printer you may need to set up its
options (e.g. whether B/W or colour, duplex
or simplex, poster printing etc.) in a subsequent dialogue.

Collate

Select this option, if you have specified
Copies > 1 and want that the pages are collated, before copy 2 is printed. If this
option is not set, then you may need to
assembe the copy sets manually.

Last sheet first

This option starts printing with the last
sheet, then the previous etc.

Skip blank pages For a draft it may be useful to skip empty
page, which may occur at the end of chapters or elsewhere.
Spot Color as B/W Setting this option prints spot colours as
black or white. Normally colours are converted to shades of gray by a monochrome
printer.
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Printing

Printing
The print dialogue of FraMaker provides a number of options,
which may not all be familiar to you.

Since some of the options have duplicates in modern print
dialogues, you may wish to select the Printer first and set its
options appropriately.

Registration (crop) marks

Thumbnail Rows This option prints multiple document
pages on one paper page. This is useful to
create handouts with margin for notes.

D

0-09-21

In File > Print or File > Print Book you specify standard
items, such as Page Range, and whether you want to print all
or just the even (odd) pages.

Registration MarksSetting this option requires to print to a
lager paper than specified in the document.
This applies also when Printer = Adobe PDF
(paper size to be set in Printer Properties
> Layout > Advanced).

Thumbnail print
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Copies

After printing this value is kept in the
dalogue. Watchthe number in your next
printing job!

Scale

Scale the document on the paper. Only full
percentages (not 33.33%, but 33%).

Print to File

Activate this option when printing a PostScript file with the Adbe PDF printer. You
may change the proposed file name and
path (for example to the “watched input
folder” of Distiller).

Printing

Save Book As

This option is present only when printing
from a book file.
Select Single File for generation of PostScript for distilling. Only in this mode correct bookmarks and hyperjumps can be
created.
Selecting Separate File for each Document
creates multiple PostScript files.

Separation Setup is necessary only, if you want to produce
plates for offset printing (or the like). In
Set Print Separations move all colours to
the right with Shift+ --> and then move
Black, Cyan, Magenta and Yellow to the left
for a standard setting.
However, all spot colours to be printed
must also be on the left side.
Gen. Acrobat Data Check this when printing to Adobe PDF.
There is no use with hardcopy printers.
You may set these properties with Format
> Document > PDF Setup.

Special duplex printing

You may wish to print duplex (on both sides), even if the
printer at hand does not provide this option (or it can not
handle the same paper weight as in simplex printing).
First print the odd-numbered pages, the turn the paper over
in the printer, and print the even-numbered pages. Depending
on how your printer produces pages, you may need to select
Last Sheet First before the second run, because turning the
paper over in the printer may reverse the page order. An
experiment with 4 pages only can clarify the situation.

Print to PDF

See Standard process with Distiller on page 10-5
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Text handling

Overview
FrameMaker provides good capabilities to handle
text. Due to its intended use of formatting large
documents, some functions go beyond what is
known from text processing packages.
Hyphenation dictionaries can be set up for a document or a complete project. In addition, each document can contain a local dictionary.

Contents
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Text handling

Text handling
FrameMaker versions up to version 7.2 can handle text of the
latin script with a rich set of accented characters. Due to the
limitations of an 8-bit code the number of distinct characters
is not sufficient even for the European languages. In particular support of the Eastern European languages (in US parlance
Central Europe) is lacking. But even for the Northern European languages some characters are missing.

Entering Unicode text
FrameMaker 8 can handle Unicode text. It accepts Unicode
characters not only in text, but also in dialog boxes. While it
is easy to type Greek on a Greek keyboard on a Greek Windows, it is difficult to enter such characters (a few ones to fix
a text) on an English or Swiss keyboard. Various methods are
available for this.
Note:

Be aware that Unicode characters can be displayed correctly
only with a font that supports these characters. This compendium uses Lucida Sans Unicode for such display.
See also Keyboard input on page A-2 ff for additional help.
Depending on the amount of text you need to enter you may
choose different methods. Most texts you may get already in
the foreign language (for example, back from a translator).

Windows Character Map

 Get the character map with Start > Programs >
Accessories > System Programs > Character Map or
more directly with WIN+R, charmap, ENTER.

 Define the font in which you want to enter the character(s).
 Select the Unicode sub range (for example Greek and Coptic) to find the needed characters.

2–2

Entering Unicode text

 Click on the characters) which accumulate in the field
Characters to copy.
 Select the characters and copy them to the clipboard. Paste
them in FrameMaker.

Virtual keyboard
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 In Windows establish a locale for the desired language
(Control Panel > Regional and Language Options >
Languages > Details > Add).
 Select the desired language (for example: Greek) and click
OK. The selected language is included in the Installed services list.
 Leave this panel with OK and select the tab Regional
Options.
 Choose the language you selected in the Default input language list.
 Click Apply and then click OK to save the settings and
close the Regional and Language Options dialog box. The
Language bar or the Input Method Editor (IME) will appear
in the system tray of your computer.

E:\FM-course\handout\texthandling.fm

 Select the desired language from the Language bar to
directly enter foreign characters with the keyboard.
 User the virtual keyboard as an aid (Start > Programs >
Accessories > Accessibility > On-Screen Keyboard).

 You may enter characters either by typing on your real keyboard or by clicking on the virtual keyboard: For example,
type d for the δ and SHIFT+d for the Δ.

itl OWP palette
D

This FrameMaker plug-in is part of the [i]-frame script collection, module “Translation Pack”.
 Open the palette with ESC,o,p and select the language.
 With a click on the needed character(s) you enter them into
the FrameMaker document at the cursor location.
This plug-in provides additional functions. For example, with
a character selected, type CTRL+y to get code information:
Besides the selection from 34 languages and several code
pages you can also access symbols from the Wingdings fonts
or set up other front sources.

2–3

Text handling

BabelMap

BabelMap not only is a comfortable replacement for the Windows character map. It also offers various information about
the unicode standard. Using a so called Combined Fonts it can
display all characters of the current Unicode standard.
[BabelStone Andrew West]

PopChar

PopChar waits in the system tray to be activated by a hot-key.
In many applications it determine the current font and provides only available characters. It can be configured extensively. [Ergonis Software GmbH]

2–4
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Expand your view
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AutoHotkey script

For the most used characters I have set up an AutoHotkey
script. Unfortunately AHK does not support Unicode in its
script texts, but allows to handle Unicode characters.
The “Hotstrings” are invoked by a trigger character. Since I’m
working with a Swiss keyboard, the § key (top left) comes in
handy. To get an Ohm symbol, I type §ohm and get Ω.
With many scripts running I may get left over §’s.

Search/Replace dialogue

If you know the Unicode of a needed character, you may enter
it into the text via the Search/Replace dialogue.
p Place the cursor where you need the character and open
FInd/Replace with CTRL+F.
p Leave the Search field empty and enter the code into the
replace field, for example \u0394 for an upper case Delta
and click Change: Δ

Expand your view

D

Grown up with the latin script you may encounter new worlds
with the capabilities of Unicode and even the new powers of
FrameMaker. New challenges may irritate you, for example:

Shapes of characters
differ in roman and italic
style
Latin script
Cyrillic script

While in the latin script only few characters change their
shape (very moderately) from roman to italic style, there may
be more drastic changes in other scripts.

a a, f f, g, g
г г, д д, и и, п п, т т, ц ц, ш ш, щ щ

At the first view you might be tempted to assume the italic
cyrillic font is damaged … Italic style means “derived from
handwriting” and not just ‘slanted’, Hence in the German language this style is called cursive, meaning flowing, connected.
Obviously these forms where first in many scripts.
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Text handling

Text manipulation
Keyboard shortcuts

There are many keyboard commands to select words, paragraphs, sentences and lines. Consult Help Appendix B for
“Keyboard shortcuts for”.

Move text around

There is no drag-and-drop function in FrameMaker. To move
text use cut and paste instead.

Move insertion point

The following commands move the insertion point from the
current location to …
Begin of word

CTRL+<

End of word

CTRL+8

Begin of line

HOME

End of line

END

Begin of sentence CTRL+HOME
End of sentence

CTRL+END

Begin of paragr.

CTRL+:

End of paragraph CTRL+>
Note:

Selecting text

Begin and End is the real begin and end of an item, including
any (probably invisible) markers and anchors.
The same methods as in other text processing software are
used in FrameMaker, but keyboard shortcuts may be different:

Note:

Select text of same
property around cursor

Word

Double click on the word or drag the mouse
across the word.
CTRL+SHIFT+8
CTRL+SHIFT+<

to end of line

SHIFT+END

to start of line

SHIFT+HOME

There is no means to select a word including its trailing space.
You need to use the mouse or SHIFT+ARROW to extend the
selection.
Character format ESC, h, F
Condition

ESC, h, C

Transpose characters

Click between characters and then type CTRL+F9

Change case of word

Lower case

CTRL+ALT+l (lower case L)

Upper case

CTRL+ALT+u

Initial caps

CTRL+ALT+c

After this operation the cursor is moved to the next word, so
you can easily apply a case to a series of words.

Delete text

To line end

CTRL+SHIFT+DEL

To word end

CTRL+DEL

Back to end of previous word: CTRL+BACKSP

2–6

Copy and paste

Selecting paragraphs

p Triple clicking in a paragraph selects it including its style
definition (which is ‘attached’ to the terminating paragraph
mark (¶).

Select contents only

p See Paste plain text on page 2-7.

Line and page breaks

Line breaks and page breaks can not be avoided in all cases by
using an elaborate paragraph catalogue:
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 Line breaks are entered by CTRL+ENTER.
 Page breaks are not entered into text. If a paragraph must
appear on the next page, apply the attribute with Special >
Page Break…See Pagination on page 3-6.

Copy and paste
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Paste plain text

Sometimes you want to get rid of all formatting and other
properties stored with the text in the clip-board. Then you
need to use Edit > Paste Special... and select Text from the
menu 6).
An ESC sequence is not available for this function, but you
may use SHIFT+CTRL+v, t, k (where k is the Enter/Return key)
as a fast access to the menu selection.

Copy format of one
paragraph to another

To copy just the format specifications of a paragraph,
1 Have your cursor in the source paragraph and use Edit >
Copy Special > Paragraph Format
2 Place the cursor in the target paragraph and Paste.

Alternative clipboard

FrameMaker comprises a second “clipboard” which allows you
copy and paste without disturbing the contents of the ordinary clipboard (Note: there is no real copy with this method).

Fast copy and paste

Cut text:

Select text, then Edit > Clear

Restore source:

CTRL+y

Paste text:

at the target location CTRL+y

 Place the cursor at the target location

D

 Hold down ALT while you select (with the mouse) the
source text.
 As soon as you release ALT the text will be pasted to the
target location.
Note:

This is not a drag-n-drop Windows method!

Tabulation
FrameMaker uses absolute tabbing, whereas most text processors use relative tabbing. Hence you always need the same
6

2–7

With an appropriate setting of the clipboard priorities you may automate
this for non-FM files. See Paste prefers text on page A-32.
To paste just plain text within FrameMaker a number of utilities are available, for example PureText or HovText or AutoHotkey scripts.

Text handling

number of TABs to reach a certain position, whether they can
actually perform or not (see lines 1 to 3 in the example
below).
Ruler and tab positions

Example

The ruler which FrameMaker provides starts at the page edge
rather than the text frame and hence is not helpful to position tabs correctly.
The lines in the picture contain tabs stops at 2, 4, 6 and 8 cm.
The layout of the page defines a left margin of 2 cm, room for
side headings is 5.6 and the gap is 0.6 cm. Hence the first tabmark appears on 2 + 6.2 +2 = 10.2 cm on the ruler.

these are 2 TABs

Tabs in continuation
lines
Superfluous TAB
characters
Note:

In the second and next lines of a paragraph TAB positions are
only performed, if the TAB characters really exist in the text.
(see lines 3 and 4 in the example above.
If there are no tab positions for a TAB character to perform,
they are ignored. This contrasts to MS Word where a paragraph always contains invisible default positions.
Rounding errors may require a slightly smaller position of a
right adjusted TAB (width of the text frame minus 0.05mm).

Support typographic rules
Smart spaces

‘Smart spaces’ (Format > Document > Text Options) does
not remove superfluous spaces when importing text files. It
works only for keyboard input.

Smart quotes

‘Smart Quotes’ are also set in Format > Document > Text
Options. If set, entering a single quote or double quote with
the keyboard changes them to typographic quotes according to the setting in the maker.ini file. See Smart quotes on
page A-32. Unfortunately there is no connection to the Language property of a paragraph.
To enter straight quotes (e.g. the inch symbol) when Smart
Quotes are active, you need special ESC sequences (see Keyboard input on page A-2.
Note:

Example

Micro typography

If you change the settings for Smart Quotes in the maker.ini
file (for example, from the English to the French form) and
then open a document which uses smart quotes, existing quotes
are left in the old style, but newly entered ones get the new
style!
English style “smart quotes” and after switching to french
style: «newly entered ones».
FrameMaker does not provide optical justification and
hyphenation is not optimised in a paragraph as with TEX or
InDesign.
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Local formatting with the ruler

Local formatting with the ruler
The ruler at the top of the FrameMaker window is handy for
quick and dirty formatting. This method is not recommended
for longer and long living texts. It should be used only to set
up prototypes of paragraphs for entering them in the paragraph catalogue.
2011-05-11

1 If the ruler is not visible, activate it with View > Rulers. If
the formatting bar is not visible, activate it with View >
Formatting Bar.
2 Place the cursor in the paragraph you want to format or
select a number of paragraphs to be formatted.
Left

Center

Right

Decimal Tab

Handle for indenting the
first line of the paragraph
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Handle for indenting the
other lines in the paragraph.

4 With the lower indent handle you set the ‘hanging indent’
for lines 2 to n of a paragraph (for lists etc.).
5 To specify a tab position, select the appropriate tab type
(left, right,…) in the left area of the formatting bar and
click into the ruler area below the numbers.
6 Double click on the TAB position to get a dialogue to
change the properties (type of tabulation, exact position
etc.)

TAB position

Object manipulation
Selecting tables and parts
of

Select a table

A table is an independent object (not part of the surrounding
text). A table is anchored at a certain place in surrounding
text, although it may appear quite distant to the anchoring
location.
p Hold the CTRL key and triple click into a cell or...
p Select the table anchor (see Select a non-width character (or
narrow characters) on page A-8

Select a column
Select a row
Select an area of cells
D

3 With the upper indent handle adjust the left (and the right)
indent of the first line of the paragraph.

Selecting a text frame

p Hold the CTRL key and double click into the middle part of
a cell
p Hold the CTRL key and double click into the far left or far
right of a cell
p Drag with mouse across the desired cells.
A text frame is the container of the text and is a graphic
object. Hence it can only be grabbed with holding the CTRL
key down while clicking on its edge (the cursor becomes a
hollow arrow tip)

Note:
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Be careful not to move the mouse during the CTRL+click.
CTRL+Click+move creates a copy of the object (see Ghost
objects on page A-17).

Find and change

Find and change
There is no Cancel button in this dialogue and the standard
location of the Cancel button is occupied by the most dangerous function: Change All. To leave the dialogue click on the X
top right:

Since the backslash is used for special notations in dialogue
boxes (see below), it must be doubled to search it literally. To
search for D:\QM_Handbuch you must enter D:\\QM_Handbuch.
Note:

Find and change does not enter text insets (see page 13 - 18).

Find/Change with pattern matching
Especially for cleaning imported text it is convenient to
search for a pattern. See Wildcard characters for Find dialogue
on page A-3:

Examples
Remove manual
numbering of
paragraphs.

This works also on already numbered paragraphs (FM-autonumber-format <n+>\t).

Remove empty
paragraphs

Note:

7

2 – 10

Find Text

^[0-9].\t

Use Wildcards

ON

Change

<empty>

Find Text

\p\p

Use Wildcards

ON

Change

\p

7)

Always be very careful in using Change All. The ‘empty’ paragraph may contain a Table anchor or a Frame anchor which
will also be selected!

This finds only one figure. To find two figures, extend the pattern to [09][0-9] or [0-9]* (but this will find anything after the first figure).

Replace text with copied text or a variable

Replace text with copied text or a variable
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In this context variables are just a special form of text.
To replace text by content of the clipboard

To replace text by a variable:

Copy the text to be used in replacement to the clipboard.

Copy the text you are replacing to the clipboard.
Set up the variable definition (see User variables on page 7-2).

In Find/Replace specify the text to be searched for in the
Find field and select By Pasting form the list Change.

In Find/Replace paste the copied text into the Find field
and select By Pasting form the list Change.

Specify where to Look in: Book, etc.

Specify where to Look in: Book, etc. Go back to the document
where the text is still selected. Replace it with the variable, then
copy the variable into the paste buffer.

With Find/Replace find the first/next occurrence of the text With Find/Replace find the first/next occurrence of the text
and replace it by pasting the variable from the paste buffer
and replace it by pasting the variable from the paste buffer
(CTRL+V).
(CTRL+V).

Note:

Do not click into the document window when the found text is
highlighted. You will loose the selection and can not paste.
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Find arbitrary objects
FrameMaker allows to find nearly any object (Cross Reference, Marker, …). Explore the Find scroll-down list!

Find and change character formats
If –for example – you have imported a Word document and
should now replace the direct formatting bold of all affected
items with character format 2highlight, do the following:
1 Select the first string which is bold.
2 Apply the default character format (F8, Enter) to remove
the bold appearance.
3 Apply the character format 2highlight (F8, 2h… Enter).
4 Select from the menu Edit > Copy Special … > Character
Format (ALT+F8).
5 In the Find/Change dialogue set Find list to Character
Format… and set all check boxes to As Is (click them once
or twice to display a grey tic mark); set all properties other
than Weight to As Is. In Weight select bold.

D

6 In the Find/Change dialogue set Change list to By Pasting.
7 With Change & Find apply the character format to the current item and look up the next. Repeat this step as often as
necessary. 2
Note:

2 – 11

Be aware of the fact that FM’s As Is mechanism takes the currently active values. Hence replacing the bold format in a
heading (e.g. 14pt Arial) may put that text portion into 10pt
Times (if you started in ordinary text with these attributes).

Find and change

Find and change paragraph formats
If –for example – you have imported a Word document and
should now change some of the Normal paragraphs to format
special, do the following:
1 Select the first Normal paragraph which should be changed.
2 Open the paragraph designer (CTRL+m) to get the paragraph tag of this paragraph and copy the name from the
field Paragraph Tag to the clipboard8).
3 Apply the paragraph format special (F9, sp… Enter).
4 Select from the menu Edit > Copy Special… > Paragraph
Format (ALT+F9).
5 In the Find/Change dialogue set Find list to Paragraph
Tag: and paste the name from the clipboard into the entry
field.
6 In the Find/Change dialogue set the Change list to By
Pasting.
7 With Change & Find apply the paragraph format to the
current item and look up the next. Repeat this step as often
as necessary.
Note:

8

2 – 12

For globally changing a paragraph tag name, see Renaming a
paragraph format on page 3-10.

While this seems to be overkill for paragraph format Normal it is less error prone for names like wxfFaxNum , because FM style names are case
sensitive.

Hyphenation and spell checking

Hyphenation and spell checking
Spell checking is not performed in the following objects:
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 Text insets (see Text insets on page 13-18).
 Automatically inserted text, such as variables, auto numbers, cross references, variables or file information.
 Other types of pages then the current one. While in body
pages, neither master pages nor reference pages are
checked.
 Text with currently hidden conditions (see Conditional text
on page 13-13)

Supported languages

D
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Dictionaries for hyphenation and spell checking are available
for the following languages. Newly supported languages are
highlighted in bold

2 – 13

File name or
extension

Language

Language name as presented in dialogues

brt

British English

UK English

brz

Brazilian Portuguese

Português do Brasil

bul

Bulgarian

булгарски

cfr

Canadian French

Canadian Français

ctl

Catalan

Catalá

cze

Czech

čeština

dan

Danish

Dansk

dtn

Dutch (new spelling(

Netherlands (nieuw)

dut

Dutch

Netherlands

eng

US English

US English

est

Estonian

Eesti

fin

Finnish

Suomi

frn

French

Français

gmn

German (new spelling)

Deutsch (neu)

gre

Greek

Ελληνικα

grm

German (old spelling)

Deutsch

hrv

Croatian

Hrvatski

hun

Hungarian

magyar

itl

Italian

Italiano

lav

Latvian

latviešu

lit

Lithuanian

lietuvi

nrw

Norwegian

Norsk

nyn

Norwegian (new)

Ny Norsk

pol

Polish

Polski

prt

Portuguese

Português

rum

Romanian

Română

rus

Russian

русский

sgn

Swiss German (new spelling)

Schweizerdeutsch (neu)

sgr

Swiss German (old spelling)

Schweizerdeutsch

Hyphenation and spell checking

File name or
extension

Language

Language name as presented in dialogues

slo

Slovenian

Slovenščina

slv

Slovak

Slovenčina

spn

Spanish

Español

swd

Swedish

Svenska

tur

Turkish
Chinese

Türkçe
a

Korean, Japanese, Traditional
Chinese, Simplified Chinese

a. This requires a ‘Chinese’ operating system.

Dictionaries
Types of dictionaries

FrameMaker supports four dictionary types, which are
searched in the following order:

Site dictionary

The site dictionary, normally it is set to Read Only to be maintained by a service department. The location of this dictionary can only be set in maker.ini.

Document dictionary

The document dictionary is located in the document and can
be maintained only via the MIF format of the file. This dictionary is filled with the Allow in Document function. You
remove a word from this dictionary by Unlearn after typing
the word without hyphenation.

Personal dictionary

The project or personal dictionary normally is maintained by
the project owner and hence can be written to with the Learn
button. To use this dictionary, specify the path with the
method described in Set up and use a project dictionary on
page 2-15.

Note:
Language dictionary

The setting of a project or personal dictionary (in the dictionary options) lasts for the current FrameMaker session only!
The language dictionaries are provided by FrameMaker.
All but the language dictionaries do not have an indication of
language. When collecting entries from various documents
the languages may be mixed.

Using two private
dictionariesg

For certain projects it may be desirable to use two different
‘private’ dictionaries, one for language-1 (e.g. english) and one
for language-2 (e.g. german).
This can be achieved by setting up the site dictionary for language-1 and the user dictionary for language-2. However, the
Learn command will update only the user dictionary.
maker.ini in the user area

9)

may then be set up as follows:

[Files]
SiteDictionary=D:\_DOC-STD\Frame\ddd-de.dct
UserDictionary=D:\_DOC-STD\Frame\ddd_en.dct

9

Since FM 7.2 a copy of maker.ini from the installation directory is stored
in the user area, for example: C:\Documents and Settings\Klaus

Daube\Application Data\Adobe\FrameMaker\8.0\maker.ini

2 – 14

Dictionaries

Format of dictionary
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The site dictionary as well as the project or personal dictionaries (e.g. user.dct) are plain text files.

Property

FM version until 7.2

FM 8 onwards

Coding

FM internal coding.
See Frame Roman code
table on page A-6

UTF-8

Max entry

31 characters including hy63 characters including hyphenation points. Coded char- phenation points (minus sign)
acters (e.g. \x80 for Ä) count
as 1

Example file <Maker Dictionary 2.0> <Maker Dictionary 3.0>
-\x86ber-g\x8ange
\x80nderun-gen
\x86ber-pr\x9f-fung
Abtrag-arms
Pro-gram-mier-men\x9f

Über-gänge
Änderun-gen
Über-prü-fung
Abtrag-arms
Pro-gram-mier-menü

E:\FM-course\handout\texthandling.fm

You may wish to remove unreasonable hyphenation points. Be
aware that all languages are collected in the same file. Words
starting with - are not hyphenated.

Set up and use a project
dictionary

1 Edit > Spelling Checker
2 Select Dictionaries. The current dictionary is displayed at
the bottom of the dialogue.
3 Activate Personal Dictionary and select Change
Dictionary from the drop-down list, OK.
4 For a new (or existing) project dictionary, define the appropriate path and file name (extension dct) and click Use.
The default location for dictionaries is $HOME\dict\. You
need admin rights to place these files anywhere. When you
place the dictionary on a network, be aware that FM
crashes, if the file is not available.
5 Back in the Spelling Checker dialogue: Start Checking or
leave the dialogue (X). The settings are active during the
current FrameMaker session.
6 The current dictionary is indicated at the bottom of the
dialogue Dictionary Functions.

D

7 With Learn you add entries to the current personal dictionary. With Allow in Document you add entries to the document internal dictionary. Use this for very special words.

Collecting unknown
words

It is useful to collect unknown words in a project dictionary
in advance in these cases:
 In German words can be combined to a nearly unlimited
repertoire and hence these combined words may be
hyphenated at unwanted places.
 The special field covered by the text is not covered by the
standard dictionary at all: chemistry, legal, medicine etc.
There are, however some limitation to the user dictionaries or
site dictionaries (see Format of dictionary on page 2-15):
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 The dictionary entries can not be longer than 31 characters
including the hyphenation dashes. Hence may need to concentrate on few hyphenation points.
 Only about 2000 entries can be collected. Unfortunately
there is no mechanism to combine flexed words into one
entry (which is done in the standard dictionaries).
1 To collect the unknown words of a FrameMaker book, start
in the first relevant chapter (e.g. to leave out the TOC) and
activate Check: Book.
2 Click on Options… to open the dialogue Dictionary
Functions.
3 Activate Write all Unknown Words to File…and click OK.
4 In the dialogue Store Spell Checking Results in File: navigate to the desired directory and enter the desired file
name with the file extension dct.
5 You get feedback about the written entries:

6 Inspect the file and correct it:
<MakerDictionary 3.0>
Ac-it-vate
-Dachgiebel
Fram-Mak-er
-Mehrfach–Drehbänke
Nix-on
pour-quoi
-rien
sie-he

contents of file after
correction

wrong word 8 delete line
incorrect hyphenation
Wrong spelling 8 correct it
incorrect hyphenation
do not hyphenate
Do not hyphenate

<MakerDictionary 3.0>
Dach-giebel
Frame-Maker
Mehr-fach-Dreh-bänke
-Nixon
pour-quoi
-rien
-siehe

7 To use this dictionary follow Set up and use a project dictionary on page 2-15

Spelling options

To avoid spell checking of certain situations, consult the
Options… in the main dialogue.
To avoid checking of technical terms (M4×12, 12.5 µMol, µA
etc.), define the special characters (symbols) in Ignore >
Words containing: .×µ (only the period is default).
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Spell checking odds

Spell checking odds
Spelling is not checked, if the text is …
 defined through a dialog box, such as auto numbers, cross
references, variables or file information.
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 on other page type then the current one. When in body
pages, then text on master pages or text on reference pages
is not checked. You need to switch to those page types.
 Text in currently hidden conditions.
 Text insets are not checked. Set up a ‘utility book’ with all
the insets and then spell check these files.
 Superscripted or subscripted text. Also vertically micro
positioned text (see Micro positioning of characters on
page 3-19) is not checked either.

Known bugs



10)Repeated

words are not found if they are separated by a
line end or if just capitalisation is different (“Master master Master” is not found).
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 Missing spaces between ordinary text and variables or
cross references is not reported.
 The option “Find extras spaces” does not find a series of
spaces larger than 2. The same is true for repeated characters. For example xx or ?? are reported as repeated, xxx or
??? are not.
 None-breaking hyphens are not treated as hyphens, they
are reported as miss-spelling.

D

 Some concatenated words are not found in error (in German and Dutch).

10 These bugs are reported by Shlomo Perets
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Hyphenation
Note:

General remarks

FrameMaker behaves differently than MS Word - also concerning hyphenation.
 Automatic hyphenation is a paragraph property. With a
character format “no language” even portions of paragraphs can be excluded from spell checking and hyphenation.
 Hyphenation can be selectively disabled with a character
format specifying language ‘None’.
 Manual hyphenation (with discretionary/optional hyphen,
suppress hyphenation) is active only in paragraphs with
the attribute Hyphenate set.
 For special terminology consider collecting the words in a
file and creating a ‘project dictionary’ with appropriate
hyphenation points.

Change hyphenation of a
word

1 Edit > Spelling Checker
2 Enter the word for which the hyphenation is to be changed.
3 Select Show Word’s Hyphenation
4 Clear all hyphenation points (-) which you do not want.

5 Avoid hyphenation of a word with a preceding minus sign.
6 Learn (store in the personal or project dictionary).
7 To unlearn a word, type it into the field without hyphenation and click Unlearn.

Avoid hyphenation

To avoid the hyphenation of a word, (e.g. a product name),
1 Place the cursor in front of the word
2 Enter ESC, n, s (English FM) or ESC, k, t (German FM).

Optional hyphenation

1 Place the cursor in the word, where you want to provide
optional hyphenation
2 Enter CTRL+minus

Note:

Optional hyphen is not
honoured?
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Suppression of hyphenation takes precedence over optional
hyphenation points.
If the optional hyphenation is not honoured, check the
number of successively hyphenated lines in the paragraph

Hyphenation

2011-05-11

designer: Advanced properties: max # adjacent. The standard
value is 2 to avoid ‘ladders’.

Non breaking space

To keep words or characters together and protect them from
hyphenation use the non breaking space (CTRL+space).

Non breaking hyphen

To avoid hyphen in a compound word (such as end-user), use
the non-breaking hyphen ESC, -, h (English FrameMaker) or
ESC, -, w (German version).

None breaking symbols

You can switch off the hyphenation after specific symbols in
the dialogue Format > Document > Text Options by removing these symbols from the list Allow Line breaks after (the
slash is normally the first symbol there).
If you both need a breaking and a non breaking slash, provide
a variable (e.g. named slash) with the definition “\/” (without
the quotes. Use this variable as non-breaking slash.
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Apply new hyphenation
to existing document

1 Edit > Spelling Checker
2 Select Dictionaries
3 Select Re-hyphenate Document, click OK.

To hyphenate or not to
hyphenate

Be aware of the influence of non breaking symbols to the following word: it depends!
Type of symbols non breaking

Breaking and
nonbreakable slash

normal

non-breaking space after the arrow
(justified paragraphs)

see
8 Dachgiebel

auch siehe auch 8 Dachgiebel

non-breaking hyphen between words

Mehrfach-Drehbänke Mehrfach-Drehbänke

Although there is a symbol in the Symbol font for solidus (/),
this should not be used in ordinary text alternating to the
standard solidus of all fonts (/). The appearance differs: //.
Hence you need a trick to have both breaking and non-breaking slashes in a text.
 In Format > Documents > Text Options… remove the /
from the list of Allow Line Breaks after, but insert at the
start (not elsewhere) of this list: \st or \x14 for thin space.
 If you want a breaking /, just use the symbol from standard font.

D

 Where you need nonbreakable /, surround it with thin
space (ESC, blank, t) or in German FM (ESC, s, t). This will
disturb only few typographers, but not ordinary readers.
This is a sample text using this method: hecate/iovis will not
be broken, but hecate / iovis can be broken at the thin spaces
before and after the /.
Note:
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This idea may conflict with other uses of thin space though,
because the special spaces are non breaking, if not in the mentioned list.

Hyphenation and spell checking

Other dictionary functions
Edit > Spelling Checker … > Dictionaries …

Personal dictionary

Set to None

Signal FM that no personal dictionary
exists. Only the other types are available.

Write to File

Write the personal dictionary to another
file.

Merge from File

Amend the personal dictionary

Change DictionarySwitch to another dictionary. To start a new
personal dictionary, see Set up and use a
project dictionary on page 2-15.

Document dictionary

Clear

Clear the document dictionary to start
afresh.

Write to File

Export the current document dictionary.

Merge from File

Amend the document dictionary.

Write all unknown Words
to File

See Collecting unknown words on page 2-15

Clear automatic
corrections

Remove all automatic corrections from the current document.

Mark all paragraphs for
rechecking

Set this option after you have changed the dictionary to be
certain to check everything against the new dictionary.

Rehyphenate document

Redo the automatic hyphenation – especially after changing a
dictionary.
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Spell checking

Spell checking
Start spell checking at the beginning of the document with
Edit > Spelling Checker > Start Checking.
Spell checking and hyphenation use the same dictionary.
 FrameMaker starts the checking at the current cursor location and wraps to the beginning of the file.
2011-05-11

 If there are ‘errors’, which are ignored, the wrapping may
go on and on. Hence watch the vertical scrolling bar.
 Spell check does not ‘dive into’ text insets – these are independent files which must be checked separately.

Spell Check options

The options for the spell checker are set with Edit > Spelling
Checker > Options…
Option

Checks for example

Comments
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Find
Repeated words

this and and that

Unusual hyphenation

un-usual, re-initialise

Unusual capitalisation

TheSis, wronG

Two in a row

Richard Nixon ??

Straight quotes

"welcome back friends"

??? will pass

Extra spaces

and so on

e.g. from importing text

Spaces before/after

( rien ), pourquoi ?

French typography requires
these spaces

Ignore

D

Note:
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Single character words

Just a bunch of if’s

All UPPERCASE words

USB bus

Words containing …

123.9

Roman numerals

see page vii

Words with digits

Lotus123

ignore the period

The settings are saved in the frame.ini file and hence are
available across FrameMaker sessions.

Thesaurus

Thesaurus
With Edit > Thesaurus … synonyms for the currently
selected word can be found. By following the chain of words
(click on a synonym) you may even explore the meaning of a
word.

To replace the selected word in the text with the current word
in the thesaurus, click Replace.
If you want to look up a word in another language, use Look
Up … to select the language from the list.
The thesaurus function is available for the following languages:















Danish
Dutch
English US
English, British
French
French, Canadian
German
German, new spelling
Italian
Norwegian
Spanish
Swedish
Swiss German
Swiss German, new spelling

To see the history of words you have looked up, click on the
small triangle to the right of the current word. You can go to
one of these words by clicking in the pop-up on it.
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French typography

French typography
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French typographic rules are not uniform across the francophone countries. Also some newspapers do not follow it
strictly. Online publications even use much more relaxed
rules and you may even find company specific rules. Hence
this section can just note the most common items. For your
benefit I provide the French nomenclature also in this section.

Space

The word espace is feminine: une espace.
L’espace insécable (non breaking space) is used in many punctuation cases. It is entered by Ctrl+space. In this section this
symbol is visualised by 3.
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Punctuation

Two cases are distinguished: handling of simple symbols
(comma – la virgule, period – le point, ellipsis – les points de
suspension) and the handling of double symbols (colon – les
deux-points, semicolon – le point-virgule, exclamation mark –
le point d'exclamation, question mark – le point d'interrogation).
The rule is: simple symbols – simple space, double symbols –
double space. Canadian French does not use the space before
: ? and !. Examples:
Oui3? Non3! Voyez donc3: c'est ainsi3; ça ne se discute pas. Une
virgule, un point. La suite... au prochain paragraphe.
French quality typography uses une espace fine insécable, a
non breakable thin space (` `) for these applications. The thin
space (\u2009) can be entered with Esc, blank, t.

Quotation marks

Quotation marks are called guillemets irrespective of their
form. However, the standard quotation marks in French are
chevron shaped: « and ». The quotation is first surrounded by
non breaking spaces and then by the quotation marks:
On consultera les ouvrages suivants3: «3La typographie pour
les nuls3» et «3Typographie avancée3».
Second level quotation use the guillemets à l’anglaise without
additional space:
«3L'ouvreuse m’a dit3: “Donnez-moi votre ticket.” Je le lui ai
donné.3».

D

En Suisse, pour les citations de deuxième rang, on utilise parfois des guillemets français simples3: «3citation de 1 er rang
contenant une ‹3citation de 2 e rang3›3».
Quoting foreign languages use the guillements à l’anglaise,
but without the inner spaces.
Note:

Dashes

Unfortunately FrameMaker has no automatism to enter the
additional spaces when entering punctuation or french quotation marks. In many text processing program (such as MS
Word) the spaces are inserted automatically if the language is
set to French. A utility like Spell Catcher X is of great help.
In this area differences between classic French typography
and current typography or even differences between authors
can be observed.
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French typography

Composite word use the n-dash (as usual in other languages
also). No spaces are around these:
C'est-à-dire que... Où est-il3? Y a-t-il un arc-en-ciel3?
Hyphenation dashes use the short dash, le tiret court (minus
sign on the keyboard). It follows immediately to the last character in the broken line (as usual).
Incisions use the n-dash (tiret moyen), which is connected to
the incision phrase by a non breaking space:
Le brave homme – 3pas si brave que ça, il faut le dire 3– ne dit
rien.
In dialogues the m-dash (tiret long) is used. It is connected to
the phrase by a non breaking space:
—3Ça va 3? —3Oui, et toi 3? —3Oui, et toi 3?

Titles

The second to last character of abbreviated titles is displayed
in superscript:
Mlle - Mme - M mes - M. (et non Mr) - MM. - M e (maître) - M gr (monseigneur)

Units

There is a space between the numeric value and the unit. To
avoid separation this should be a non breaking space (as
usual):
1,33cm. 13000 3000,00 3F. 20,6 3%. Un appareil photo qui permet
une durée d'exposition de 1/2000 3 s. Une carte au 1/253000
[pas d'unité].

Uppercase accented
letters

You are strongly recommended to use accents also on upper
case letters:
ÉLÈVES EN PLEIN AIR ou ÉLEVÉS EN PLEIN AIR 3?

Enumeration

As with good old English the suffixes are displayed in superscript:
On écrira 1er, 1 re, 2 e...
Note:

Latin expressions

Watch the difference in gender: 1 er is masculine, 1 re is feminine.
Especially in scientific publications you find latin expressions, which should not be used in French:

References

Latin

English

French

e.g. (exempli gratia)

for example

p. ex. (par example)

et alii, et al.

and others

et co-auteurs, et coll., etc.

id est, i.e.

that is

c’est-à-dire, c.-à-d.

versus, vs

against, in contrast to

contre, « - »

Jacques André, Petites leçons de typographie. Version 1990—
PDF du 18 février 2009
Règles de typographie française
Mémento de typographie anglaise à l’usage de rédacteurs
francophones
Comparatif des différents codes typographiques francophones
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Styles

Overview
In this chapter properties of paragraph and character styles are discussed. The hierarchical numbering
of paragraphs is vital for technical and scientific
publications.
Importing styles or elements of style from other
documents eases the set up of consistent layout and
design. This is a key feature of FrameMaker.

Contents
Names for styles ..................................................... 2
Paragraph styles ..................................................... 3
Character styles .................................................... 13
Import formats from another document ................. 15
Special formatting ................................................ 18

Names for styles

Names for styles
Paragraph and character formats, table formats, cross reference forms and so on are named. Choose names carefully as
they live longer than you imagine!

Name by function

Style names based on the function can be learned easier and
are better suited for structured documents. Naming by
appearance is a reminiscence of layouters and typographers.
We are talking about document processing here:

Name with abbreviation

Name based on appearance

Name based on function

24pt-Garamond-bold

1heading

left-2cm-right-2cm-italic

citation

hanging-indent-bullet

lb-bulleted-list

10pt-Times

body

5rows-left-adjusted

invoice

Table with frame and fancy head

full-statistics

Paragraph formats can be applied to an object with keyboard
short-cuts:
 F8, characterformat, Enter
 F9, paragraphformat, Enter
 Names may be shortened to the relevant length.
For this reason it is important to use names which differentiate in the first characters:
First shot

Efficient

Keys

Heading 1

1heading

F9, 1

Heading 2

2heading

F9, 2

Wide list

lw-list-wide

F9, lw

Checklist

lc-checklist

F9, lc

Wide table with horizontal lines

zlw-wide-line

F9, zlw

Highlight bold

2highlight

F8, 2

Using lower case characters distinguishes the user defined
styles from the FrameMaker supplied styles, which always
start with an upper case character.

Special names

Name items which are not used by the author of a text completely different, for example, precede the names by z. The
will sort at the end of the list of styles. Items in this category
are used on layout pages (master pages) or as ‘hidden features’:

Dangerous characters in
style names

3–2

Name

Usage

z-anchor

automatically applied as follow on ¶

z-footer

layout

z-header

layout

Do not use blanks, umlauts, brackets [ ], angle brackets < >
and the $-sign in style names (paragraph, character) – these
may interfere with special constructs such as in cross-references and damage HTML export.

Paragraph styles

Paragraph styles
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Using style names for paragraphs, character sequences and
tables (rather than local formatting) gives you these advantages:
 The appearance of a document can be changed ‘in the last
minute’.
 The appearance of all documents in a book can be changed
with ‘the snip of a finger’ (importing styles from any document).
Note:

Upper- and lower case is relevant in style names (Heading and
heading are not the same).

Properties of paragraphs and text

Properties of lines and
paragraphs
line height
Space above
Indent First
Indent Left

Space below

D

E:\FM-course\handout\styles.fm

To set up paragraph and character styles you need to understand various properties of text elements. The terminology
varies between text processing applications, but the concepts
are comparable.
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These are some lines before the paragraph
demonstrating various paragraph
Properties.
 This is the paragraph of a
list to demonstrate the indentation properties for the
sake of better understanding.
This paragraph uses Indent First, which
is common in prose texts.
In technical texts paragraphs are formatted
as blocks, that is without indentation of
the first line, but with Space Before.

Line spacing

Indent Right

text frame

Paragraph styles

Properties of type

In the font properties for a paragraph and in the definition of
character formats a number of modifications to the original
font appearance can be set:

Property

Meaning

Example
value

Angle

Character shapes are either slanted (‘mechani- regular
cally’ tilted: oblique, slanted, italicised) or de- italic
signed for a pleasing appearance (italic)
slanted

The upright form is called roman,
the designed tilted form is italics
(kursive), whereas slanted etc. has no
specific shapes (e.g.) for f or g.

Weight

Thickness of the strokes forming a character
regular,
shape. Various names are in use. Only few fonts bold
provide more than just bold.
semibold

This is the regular form. and here
comes bold.

Variation

Some fonts provide narrow or wide forms or
other variations. Condensed is a designed
form, Narrow is a ‘mechanical’ deformation.

Spread

Additional space between characters in% of em- 0%
space (German: geviert)
3%

regular
This is Lucida Sans. Here comes Lucida
condensed Sans Narrow.
narrow

20%
Stretch

The character shapes are stretched graphically 100%
160%

This text is not spread at all (set tight)
This text is spread a little bit
This text is spread heavily
This text is not stretched at all
This is really stretched

Individual character pairs are arranged closer Without
than their bounding box defines. This creates
With
better appearance for certain character pairs in
large sizes

AV-Medium Yoga

Manual kerning is not recommended. It can
work only on the characters of one line.

AV-Medium Yoga

Underline

This text decoration should be used only to visualise conditional text (added text) – it is not a
good emphasis

Overline

This may be useful for certain mathematical
stuff

Strike through This text decoration is predestined to visualise
the text condition ‘deleted’

Manually

use these only
for indication
of changes

Pair kern

Example presentation

AV-Medium Yoga

Underlining cuts through the
descenders, numeric underlining
does not; double may be awful.
Here is over lining applied.
Well, this was here, and that’s here
now.

This character format will be removed by
Format > Document > Change Bars >
Clear all

On the side of the text frame you see
a vertical bar indicating this character format

Superscript

These character formats are widely used for
formula like text pieces

A superscript 2) has various uses, for
example in cross-reference formats

Subscript

More linespacing may
be needed

Change bar

Subscripts may be needed in chemical notations, such as H 2SO4

Small caps

In German this is called Kapitälchen. The
FrameMaker form is a mechanical modification.
Real Small Caps are specially designed forms.

SMALL CAPS (KAPITÄLCHEN) ARE WIDELY
USED FOR PRESENTATION OF P RODUCT
N AMES, O PUS NAMES OR IN HEADINGS.

Uppercase

Thesis text decoration s do not physically
change the text (the buttons AB and ab do so).
You can find the unmodified text with the Find/
Change dialogue an ‘Consider Case’ active.

HELLO, THIS SHALL BE ALL UPPER
CASE – CAN YOU READ IT EASILY?

Shades of gray are useful in any printing process. Colour is good for electronic distribution
(PDF, Web) and costs a lot in real printing.

Use shades of gray for

Lowercase
Colour

this is all lower case although typed
with caps lock on

large

font sizes, for exam-

ple in headings. This creates a more
uniform gray value of the page.
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Define a paragraph style name

Define a paragraph style name
Basic properties

p Place the cursor in a paragraph the style of which you want
to develop (and store in the catalogue).
p Open the Paragraph Designer (Format > Paragraphs >
Designer).

2011-05-11

p In the field Paragraph Tag enter the name of the paragraph style to be created.
p In the drop down list Commands select New Format.
p In the Dialogue New Format activate both Store in Catalogue and Apply to Selection (this to gives you a visual
hint about the developing format of the paragraph).
p Define the Basic Properties of the paragraph style, then
click Update All to apply the set properties to the current
paragraph and store them in the catalogue.
p Switch to the next category, set the desired properties and
click Update All.

E:\FM-course\handout\styles.fm

Set up paragraph properties
Basic properties

Left indentation is also called ‘hanging indent’, since used for
lists (see page 7). You must also define a tab position at the
same distance as the left indent (for lists).
Normally only Space Above is set. Only special cases require
both above and below. FrameMaker takes the larger value, if
both are defined in following paragraphs.
Concerning justified versus left adjusted text see To justify or
not to justify on page B-3.
If you expect many footnote references, consider line spacing
1.5
At least for headings define the format of the next paragraph.
This will be applied to the next ¶ after an Enter at the current
paragraph.

Font properties
p Define the name of the paragraph style (if you want to
define a new style).
D

p Set the properties in a specific property area (Basic, Default
Font, Pagination etc.)
p For test purpose (visual check of appearance) you may wish
to just apply the settings to the current paragraph with
Apply.
p Store the settings in the catalogue as well as apply them to
the current paragraph with Update All.
Concerning the role of type face see Serif versus sans serif on
page B-3ff.
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Paragraph styles

Pagination
Start on Top of Page if you need to have a page break before
the paragraph. In multi column layout consider start Top of
Column for headings etc.
For headings always set Keep with Next Paragraph to avoid
dangling headings at the bottom of a page.
When tweaking a layout it may be necessary to set Widow/
Orphan lines to 1 or a greater number.
For figure titles below an anchored frame you may wish to set
Keep with previous Paragraph to hold it together with the
anchoring paragraph.

Pagination
A Across all Columns and
Side Heads

The Pagination properties define the arrangement of paragraphs. Running text always is “In Column”. For headings you
will need variations:
A) Hecate Latonae Filia, soror Apollinis.

C Side Head, alignment First
Baseline

Est tricopor et
triceps, magicarum
artium magistra ac
fascinationum

D In Column

B) Noctu triviis nec hoverei

E Run-In Head, Default
punctuation “.3”

vel prope sepulcra
et ubi loca sunt
caedibus

contaminata
sinistra.

Latonae filia, soror
Apollinis. Est trico
por et triceps, mag
icarum artium mo
magistra actual.

Apollinis. Est trico
et triceps,
magicarum
artiumra.

B Across all columns

Watch the interruption of the
text area by a heading.

C) Hec est Iovi

D) Fasinosa del
mortioriti
Praeses, cinctra
latrantium
num contaminata.
Latonae filia, soror

Alternative method for
page break

praeses, cinctra
latrantium canum
turma.

E) Turma. noctu
stans in triviis vel
prope sepulcra et
ubi loca sunt
caedibus
contaminata.
Latonae filia, soror
Apollinis. Est trico

Having a heading style without and one with page break, for
example, 1heading and 1np-newpage will normally call for two
styles in the TOC: 1headingTOC and 1np-newpageTOC (see Table
of contents on page 9-3).
To avoid this effect you may define a paragraph format npanew-page-after, probably derived from Body, but with 999pt
Space After.
You may wish to set the font in this paragraph to something
obscure (e.g. a script face) to avoid accidently using it for
text. You may also wish to set lines pacing to a very low value
(e.g. 3pt, approx. 1mm).
[2009-06-24 Fred Ridder: docudoc, hotmail, com]
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Set up paragraph properties

Numbering
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You need the Numbering property category for numbered
lists, bulleted lists and items such as the notes in this chapter.
For example, bulleted and numbered lists use the following
setup:
n1_numbered_1st <n=1>
nx-numbered_next<n+>
lb-bulleted
\b\t
note
Note:\t

Numbering elements
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< =0> Reset counter,
no display
<=0> Set counter, display
<r=7> Set counter, display vii
<>
Place holder in scheme
<n>
Display counter arabic
<n+> Increment and display
\b
Bullet symbol
\t
TAB character

Note:

Numbered lists

The display of the counter depends on the character used in
the construct: n (1, 2, 4), r (i, ii, iv), R (I, II, IV), a (a, b, d), A (A,
B, D).
Hierarchical numbering for heading is more elaborate and is
explained on page page 11.
To highlight the numbering (or the constant text as for the
note), you must define a character format first. You can not
select fonts.
Normally the numbering Position is at the “Start of Paragraph”, but for formulas etc. it is desirable to set this to “End
of Paragraph”.
When hiding the counter by the leading blank you must leave
out the counter format character: Not < n=3> but < =3>.
Numbered lists are normally not bound to the hierarchy of
headings (see Numbering on page 7). If numbered lists are
bound to the heading scheme, than the lists must be treated
similar to the table or figure. In this case, more rows and columns are added to the matrix.

Note:

Bulleted lists

The footnote numbering is completely out of the game for
numbered paragraphs (see Footnotes on page 7-12).
A bulleted list is a special form a numbered list. The number
degrades to a constant symbol. A standard bullet (centered
dot) is available in every text font, hence it is provides as a
building block (\b) in the dialogue.

D

To get more fancy bullets, you need to define a character format for ‘switching the font’ (see Setting up a character style on
page 13) and replace the \b building block with the corresponding character. For example to get a list bulleted with ,
you need to ‘switch to’ Dingbats or Wingdings and enter v (see
Symbols and dingbats on page A-5).
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Paragraph styles

Advanced
On the Advanced property sheet you define typographic
details as well as graphic Frames attached to the paragraph
(above or below). These graphic frames are located on the reference pages (see Graphic elements on reference pages on
page 26).
With the settings of Word Spacing you define, how much the
word space can be compressed or expanded for justified text.
Do not check the box “Allow Automatic Letter Spacing” - this
creates very bad typography.
Note:

You can not attach a graphic element behind the paragraph
(e.g. to create a shaded background). You may achieve the
desired effect with a table of only one cell.

Table Cell
These properties become only relevant if the paragraph is
used in a table (table heading, body or bottom cells).
For each cell margin you can specify
 From Table Format, Plus a value (relative setting), or
 Custom (absolute setting).
Use Custom to define the complete margin around the paragraph ignoring the margin which is set in the Table Designer.
Cell Margins from
the Table designer

This is the paragraph in the table
cell with the properties from the
paragraph designer.

Cell Margins from
the Paragraph designer.

Align the paragraph within the table cell (top, bottom, middle)
with this property sheet.
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Setting only one property in ¶ or ƒ catalogue

Setting only one property in ¶ or ƒ catalogue
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You may need to set one property for all entries in the catalogue. For example, the language or the default font (if it is
really the same in all styles!)

Set the language in all
paragraph catalogue
entries

1 Open the paragraph designer (menu Format > Paragraphs
> Designer or CTRL+M)
2 Open the appropriate tab (Default Font)
3 In the Commands drop down list select Set Window to As
Is or type SHIFT+F8.
4 In the Language field set the desired language (e.g.
Schweizerdeutsch)
5 In the Commands drop down list select Global Update
Options… and set the radio buttons Default Font Properties
only (the name of the current tab) and All Paragraphs and
Catalogue Entries
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6 Click Update.

Setting up a group of paragraph styles
To set up a group of paragraph styles the following method is
recommended (but check out your personal preferences):
p In a new document, delete all entries in the catalogue.
Name this document according to its purpose, for example:
parastyles.fm
p For each style enter a paragraph on which you can see how
the style develops. Start the paragraph text with the name
of the style you want to develop on this paragraph. Provide
at least two lines in a paragraph to see the indentations.
p Apply the style names to the paragraphs according to the
procedure described in Names for styles on page 2.
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p Set the Property sheets in the Paragraph Designer to the
first category of properties (Basic).
-

-

Set the properties according to the needs for this paragraph style and Update All (both the selected paragraph
and the catalogue).
Work through all paragraphs with a distinct property
sheet of the paragraph designer.

p Then change to the next property sheet for all paragraphs.
Note:

3–9

The Paragraph Designer displays the format name of the current paragraph (where the cursor is in). Hence it is convenient
to work with already named paragraphs.

Paragraph styles

Renaming a paragraph format
Use this operation with care because all paragraphs of a particular style name (including the catalogue) are changed! Generally this is correct for cleaning up an imported Word
document):
1 Select a paragraph with the style name to be changed (e.g.
from “Eingerückt” to “lb-bulleted”.
2 In Paragraph Designer (Format > Paragraphs >
Designer...) change the displayed ¶-name to the desired.
Clicking on Update all will prompt you to accept the
change.

Merging paragraph formats
Assume, for example, you have the following paragraph
styles: 2heading, 2Heading, 2HEADING (for example, due to
input from other documents). The ‘only valid one’ is
2heading.
You merge them together by renaming
2Heading to 2heading
2HEADING to 2heading
Paragraphs with the changed names will display an * in the
information area on the screen (lower left corner). This indicates local overrides, which should be removed:
1 Select one of the changed paragraphs.
2 In the Paragraph designer (Format > Paragraphs >
Designer...), click Update all. You will be prompted to dismiss the overrides: click Remove Overrides.

Replace paragraph format in document or book
To replace a paragraph format (say: fromThis) by another one
(say toThat) in a document or book:
1 Set the insertion point into a paragraph that uses the
desired format (toThat)
2 Edit > Copy Special… > Paragraph Format. The desired
format is now in the clipboard.
3 In the Find/Change dialogue set the Find list to Paragraph
Tag: and enter the name of the unwanted style (fromThis)
into the field.
4 Set the Change list to By Pasting
5 You might want to do one or two replaces individually to
make sure this gives you what you want, but you can then
do a “change all” for the document or book.
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Hierarchical numbering

Hierarchical numbering
 Dependencies in numbering (e.g. all headings) require the
use of a sequence name (e.g. H:). Independent numbering
such as the numbered lists, do not need a sequence name.
However, if you have two interspersed numbered lists,
these must use labelled sequences to be distinguished (see
example below).

3
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 Blanks ( ) are relevant within the angle brackets! A blank
denotes ‘no display’ for the numbering item.
 The numbering items consist both of a counter and a format for display. Once the format is set (using n, R, a etc.)
the setting of the counter (=x) must not use the n again
(except for the real display of the initial value (see below
the scheme for the numbered lists).

E:\FM-course\handout\styles.fm

Example numbering
scheme

In the following example scheme the table and the figure numbering should restart at the main heading (level 1). Heading
levels ‘inherit’ the number from the higher level.

Format-name

Seq.
label

1heading

H:

2heading

Prefix

Numbering flow
1head

2head

3head

table

figure

<n+>

< =0>

< =0>

< =0>

< =0>\t

H:

<n>.

<n+>

3heading

H:

<n>.

<n>.

tt_table_title

H:

Table

<n>.

< >

ftn-fig-title-numbered

H:

Figure <n>

3

3
<3=0>
<n+>
<3>
<3>

3
<3>

3
<3>
<3>
<n+>
<3>

3
<3>\t
<3>\t
<3>\t

<n+>\t

This scheme is used for preparing the entries into the dialog
field of the paragraph designer, tab Numbering. For 3heading
you enter there, for example (leaving out all the informal
space in the above table, but observing the required space):
H:<n>.<n>.<n+>< >< >

Note:

Interspersed lists

Be careful with the arrangement non-syntactical element (such
as the TAB or the periods or the word Table). They may interfere with the numbering when accessing the numbering information in cross-references etc. See Building blocks $paranum
and $paranumonly on page 7-5.

D

Simple set up with no reset:
Example

Format name

Numbering scheme

1 outer list, first

x-outlist

k:<n+>\t

x-innerlist

l:<n+>\t

2 outer list, second
1 inner list, first
2 inner list, second
3 outer list, third
Later use of this paragraph format will continue the numbering, because there is no ‘reset’ as in the hierarchical scheme:
4 outer list, just here
3 inner list, another item
Hence you should set up a scheme also for these cases.
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Line break in autonumber
There is no building block \n to force the paragraph text to
the next line. However, you can set up the autonumber string
as follows (watch the ordinary space at the end of the string):
T:Test3<n+>\t3

In the basic properties of this paragraph style you define a
tab position corresponding to the width of the text frame
(minus “one” character):

Frame-width = 11.8 cm; TAB position = 11.7 cm
Start paragraph text with a nonbreaking space

It is essential to start the paragraph text (what you type) with
a nonbreaking space for this construct.
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Character styles

Character styles
Hecata iovis et illis gurgenta
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format-1

format-2
This part is
local formatting
(no f-format)

Upper- and lower case is relevant in style names (dingbats and
Dingbats are not the same).
Character styles are used to:





highlight portions of a paragraph
format the autonumber part of a paragraph
format elements in a cross-reference or variable
format the graphic text created with the Text Line tool

Note:

Only the last applied character format is stored. Previously
applied character formats become ‘local formatting’ 8 See figure at left.

Note:

Local text formatting with Format > Font, Format > Size or
Format > Style or with the buttons from the formatting bar
(View > Formatting Bar) can not be used in paragraph numbering, variables and cross references. This ‘local’ formatting
is not preserved when saving the file as HTML. ‘Local’ formatting is generally not recommended for long living documents.
Concerning the role of type face see Serif versus sans serif on
page B-3ff.

Setting up a character style
The name of a character style should provide a hint about its
purpose, not its appearance: 1-highlight, footnote-reference,…
Note:

The properties which can be set for a character format are the
same as on tab Font in the Paragraph Designer (see Properties
of type on page 3-4).
p Select a text portion (a word or phrase) which can display
the definition of the style.
p Open the Character Designer (Format > Characters >
Designer).
p In the field Character Tag enter the name of the style to be
created.
p In the drop down list Commands select New Format.

D

p In the Dialog New Format activate both Store in Catalogue
and Apply to Selection (this to gives you a visual hint
about the developing format).
p If you want the character format to add properties to the
selection rather set the full range of properties, set all
properties to as is by selecting Set Window to As Is from
the Commands drop down list or with SHIFT+F8.
Note:

This ‘Set Window to As Is’ is needed, for example, for a format
just changing the font, but not the size or anything else.
p Set the desired properties of the character format.
p Define the character format both in the catalogue as well as
set the properties in the selection with Update All.
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Character styles

Renaming a character format
Use this operation with care because all text sequences with a
particular style (including the catalogue and hence also cross
references etc.) are changed! Generally this is correct for
cleaning up an imported Word document):
1 Select a character sequence with the style name to be
changed (e.g. from “italic” to “1-highlight”.
2 In Character Designer (Format > characters > Designer...)
change the displayed f-name to the desired. Clicking on
Update all will prompt you to accept the change.
Note:

Be aware that only the name of the last applied character format is retained (see beginning of this section).

Replace character format in document or book
To replace a character format (say: fromThis) by another one
(say toThat) in a document or book:
1 Select a piece of text that uses the character format toThat
2 Edit > Copy Special… > Character Format. The desired
format is now in the clipboard.
3 In the Find/Change dialogue set the Find list to Character
Tag: and enter the name of the unwanted style (FromThis)
into the field.
4 Set the Change list to By Pasting
5 You might want to do one or two replaces individually to
make sure this gives you what you want, but you can then
do a “change all” for the document or book.

Character styles in building blocks
In the context of cross-references, the <$paratext> building
block ignores all character formatting present in the
extracted paragraph text (including case formatting), except
superscript, subscript and font family properties.
This applies also to the Running Header/Footer system variables which contain this construct.
This differs from the use of <$paratext> in generated files,
where FrameMaker retains all character formatting if it is the
result of a character tag (untagged font properties are not
retained).
[FrameMaker Building Blocks: Cross-Reference Formats,
http://www.microtype.com/resources/BBxref.pdf]
Example
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To have the italics property visible in the cross-reference, you
have to use a different font name which activates the italic –
inspect your font list and see whether you have a suitable
font which also has “Italic” or “Oblique” as part of the font
name and use in the character format with this definition.

Import formats from another document

Import formats from another document
Warnings concerning format imports
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To import the below mentioned categories of document properties separately, use the plug-in ImportFormatsSpecial from
Carmen Publishing.
See also Contents of format categories on page 3-16.

Document Properties

Be aware that the category Document Properties contains
very diverse item. See the column Document properties in the
table Contents of format categories on page 3-16.

Variable Definitions

Both System Variables and User Variables are imported. This
may override specific settings from a template.

Running Heading/
Footers

While their use is defined in the category Page Layouts, their
definition is located in category Variables. Appearance may
be affected by Character Formats.

Cross-reference formats
and Variables

These are often affected by Character Formats, hence an
import of changed Character Formats may be necessary.

Importing Format categories
Import formats from
another document

p Open the source document
p Open the target document.
p In the target document: File > Import > Format
p Select the source document in the drop down list
p Use the Deselect All button if you want to set only few categories.
p Activate the elements of the document you want to import.
To import layout with changed definitions for Running
Heading / Footing, you must select both Layout Pages and
Variables.
p Click Import

D

p Save the target document.

Importing Page Layouts

When importing master pages the property Room for Side
Heads is not imported, because this is a property of the text
flow.
Hence after importing the master pages it may be necessary
to set this attribute once on the body pages of each target
document.
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Import formats from another document

Contents of format categories

Change bar (revision bar) properties

Math defin.

Conditional
text settings

cross-Reference
formats

Variable define.

Reference pages

Document prop.

Color define.

Table formats

Page Layouts

Paragraph formats

Item to be imported

Character formats

It is not obvious which document properties are located in
which format category.

X

Character catalogue

X

Colour catalogue

X

Colour views (for separation)

X

Condition types, Condignly text formats

X

Content definition for TOC, index etc.

X

Cross-reference formats

X

Custom marker definitions

X

Custom math elements from Math reference
page

X

Document view, grid and snap properties

X

Footnote properties, numbering, layout

X

Layout

X

X

Marker type names

X

Math font definition and sizes

X

Numbering of chapter, pages, paragraphs, footnotes, table-footnotes

X

Page size, pagination, master page usage

X

Paragraph “Frame above/below” graphics
Paragraph catalogue

X
X

PDF setup, document information

X

Print separations settings

X

Rubi text properties

X

Ruling styles in tables

X

Running Header/Footer formats

X

Spell check options

X

System variable definitions

X

Table catalogue

X

Text options (smart …, super/subscript)

X

User variable definitions

X

View and lock (document/palette)

Note:

3 – 16

X

If you need to import only part of a category, for example, just
the user variables, you need a special plug-in (ImportFormatsSpecial from Carmen Publishing).

Removing style overrides

Import formats into book
files

When in a book file, all properties for the documents, such as
paragraph styles, master pages, cross reference formats etc.
can be imported and distributed to all files in the book.
1 Open the book file
2 Select the files to be updated.

2011-05-11

3 In the Import Formats dialogue specify the file from which
you want to import. This file need not be part of the book,
but it must be open.
To import layout with changed definitions for Running Heading / Footing, you must select both Layout Pages and Variables.
4 Specify (check the boxes) which properties you want to
import and distribute.
5 If you want to remove local overrides, check the appropriate boxes.
6 Click Import.
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Note:

Import only part of a
format category

The files of the book must be open, if your files use currently
unavailable fonts and graphics (because this requires user
intervention).
To import just some of the needed formats (e.g. paragraph
formats for headers only) you need an intermediate document.
 Set up an empty document.
 Import the paragraph/character/table styles.
 Delete all styles you don’t need (in the paragraph and/or
character catalogue or Table designer).
 Save the file with a distinct name (imports are not possible
from unsaved files).
 Open the target document and import the desired style elements from the intermediate document.

Removing style overrides
To remove all (that is also those applied intentionally!) style
overrides, you must re-import the catalogue from a reference
document, such as a template.
D

Be careful in selecting the items you want to import. To
remove overrides from paragraph formats only, check only
Paragraph Formats and leave all other option unchecked.
During import check the box Other Format/Layout Overrides. You may also wish to check Remove Manual Page
Breaks.
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Special formatting

Special formatting
Paragraph with background
Paragraph in table cell

A well known method is to use a one-cell table with or without ruling and cell shading:
This is the paragraph in the text cell, which is shaded and
has outside ruling. You may want to set up a special table
format for this, for example parashade.

Anchored frame at the
paragraph

If you do not need a fill but only a frame for the paragraph,
this might be a solution for You. Anchor a frame with the following properties at the end of the paragraph: outside text
frame, right adjusted. Adapt height, width, distance above
baseline to your needs. Distance to text frame normally is the
negative width of the frame or column.

This is the paragraph under the frame
Note:

Editing the paragraph

The anchored frame is in foreground, hence you can not edit
the contents with the mouse. On top of page both the paragraph and the frame are aligned with the layout frame. Hence
the relative position of frame and paragraph will change.
1 Place the cursor in the previous or next paragraph.
2 Use the appropriate arrow key to move the cursor into the
overlaid paragraph.
3 Edit the text (using SHIFT+arrow keys for selections)

Overlapping paragraphs

Two paragraph types are used to create this effect:
1 xb is empty and provides the background
Space above=8 pt; below=--22 pt; line spacing=0, fixed; font
size = 2pt; frame below = styles-hbox (width: 118mm,
height: 10mm; next paragraph = xb-text;
2 xb-text contains the text to be highlighted:
Space above=-22 pt; below=0; line spacing=24pt, fixed; font
size = 18 pt; no frames below; next paragraph = body.
This is the normally empty paragraph with format xb

Paragraph xb-text
This is body - the space above is not honoured in this case.
The space comes from the larger line spacing of xb-text.
Nasty side effects

 The text in xb-text is often hidden behind the frame
graphic as soon as you edit text in a paragraph outside of
xb-text. You need to refresh the screen to see the text
again.
 Paragraph (body) after the text paragraph (xb-text) must
be in the same column (e.g. can not be a side heading) - or
the text in xb-text becomes invisible.
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Text fragments with background

Text fragments with background
Note:

Equation with string

See also Examples of rubi usage on page 13-29.
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Place an equation (most time the smallest size is adequate)
and insert the desired text as string (enter " followed by the
text and terminate text with ENTER. Then shrink wrap the formula and apply the desired border or fill attributes to the
frame.
Here comes the formula text: just as small as possible . This might
require some tweaking of the vertical position to align the
text to the baseline of the paragraph. You may need to use a
larger zoom value to be able to place the text cursor inside.
As with all graphic objects, frame fill and border can only be
of same colour. You can apply character formats to the text,
however it will not be displayed in the status area.
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Anchored frame with text
line

Here is an anchored frame “at insertion point” (same as
generated with formula). Character formats are recommended
(and displayed in the status area). It is a little bit tedious to
adjust the baseline, but editing the contents is easy.

Micro positioning of characters
To display the name of Donald Knuth’s famous document
composition tool TEX correctly, the E should be lowered (and
moved under the T, but in the same size as the T and X.
If you try to do this with an subscripted E, you need first to
increase its font size, because the subscripting functions not
only lowers the position, but also decreases the font size.

This is not TEX.
The method of choice however is this:
p Select the character to be moved (E)
p With the ALT key held down tap the > key as often as necessary.
p You may need to move following characters (X.) also.

D

Set a high zoom factor to have small increments. A zoom factor of 353 increments by 0.1mm.
See Move objects by small amounts on page 6-16.
Although this method can also be used to move characters
horizontally it should be used only at the beginning or end of
word, because the position of the word may not be handled
correctly afterwards.

AV-overkerned.
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Tables

Overview
Tables are anchored objects which flow with the
text. The many properties a FrameMaker table can
bear make this construct very flexible.
Tables with special properties are used for ‘nontable’ purpose, such as headings with shaded background or titled graphics.
Tables can be rotated as a whole to provide many
columns. Standard FrameMaker allows only to sort
the items in tables. With plug-ins other actions can
be performed in tables.

Contents
Table properties ..................................................... 2
Handling table items ............................................... 3
Set up table properties ............................................ 4
Special table positions .......................................... 10
Set up a table template ......................................... 11
Importing tables ................................................... 12
Special operations ................................................ 13
Nested tables ....................................................... 20

Table properties

Table properties
In the diagram hereafter the table area is lightly shaded to
display the complete object “table”.
The table anchor is here:7

“Space above”
(Table designer).

Table 1: Table title (¶ format tn-tab-title-numbered)

“Gap” (Title Position)
(Table designer).

Heading cells

Column ruling

Head

Head

Body cells (¶ format tm-table-middle)

Body Row ruling
A footnote reference

Separators

a

straddled cells

Cell margin (Table designer)
This cell is very large to show the
margins and surrounding areas

Cell margin from ¶ designer,
“Table Cell” properties.
Outside ruling

Footing cells

Space defined by box
on Reference page.
Space below”
(Table designer)

Foot

Foot

a. This is a table footnote (¶ format ztf-table-footnote)

This is the next paragraph after the table, the ordinary text
outside the table which is a special object.

Table alignment is relative to the paragraph with the anchor
(be aware of side heads...)
Note:

In FrameMaker all cells of a column have the same width.

Properties in the table catalogue
When using an existing table to create a table template, the
following properties are stored in the catalogue:
 All properties which can be set in the table designer (position, cell-margins, regular ruling and shading, title position).
 Properties from the sample table:
-

number of rows for table heading, body and footing
number of columns, width of each column
paragraph format in the first row (of table heading, body
and footing) for each column.

The following properties are not kept in the table catalogue:
 Straddling of cells.
 Individual ruling and/or shading.
 Other paragraph formats than specified above.
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Handling table items

Handling table items
Inserting tables
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Tables are anchored objects similar to anchored frames. You
can select the whole table by selecting the anchor.
To insert a table

1 Place the cursor where you want to place the table anchor.
To have a better overview use an empty paragraph (but this
may create to much empty space).
2 Insert the table with Table > Insert Table …
3 Select the format from the drop down list Table Tags
4 Specify the number of rows and columns for the table. You
may wish to start with few rows only.
5 Specify the number of heading and footing rows. Most time
you will have zero footing rows. Click Insert.

D
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Note:

You can not transform ordinary table rows to heading- or footing rows after the table is inserted into the text. You can, however, add heading and footing to an existing table and then
transfer content form body rows as required.
6 Adjust the width of the columns to your desire.
7 You may wish to remove the table title (if the template
table comprises one). You need the Table Designer for this
(see Basic table properties on page 4).

Selecting table items and other operations
Select a table

 Hold the CTRL key and triple click into a cell or …
 Select the table anchor (see Select a non-width character (or
narrow characters) on page A-8

Select a column

Hold CTRL and double click into the middle part of a cell

Select a row

Hold CTRL and double click into the far left or far right of a
cell

Select an area of cells

Drag with mouse across the desired cells.

Find the anchor of a table

Place the cursor in the table, then type ESC, t, I (upper case i).
This moves the cursor just behind the anchor point (7).

Copy / cut and paste cells

When pasting cells the number of cells to be pasted to need
not be equal to the copied or cut cells. The copied cells are
repeated to a larger amount of paste cells (a, b, c 8 a, b, c, a,
b) or discarded or a smaller amount (a, b, c 8 a, b).

Insert a table row

Insert a table row below the current one with CTRL+ENTER.
Use Table > Add Rows or Columns … for more than one
item.

4–3

Set up table properties

Set up table properties
Table properties are set up with the table designer (Table >
Table Designer or CTRL+t)

Basic table properties

For cell margins see also Table
Cell on page 3-8.

Indents
Space

Indents specify the amount of space to the left and right of
the table within the text frame. Normally this is zero.
Space above defines the space between the line with the
anchor point and the upper edge of the table (or when the
table title is above) the table title.
Space below defines the space below the table (or any table
footnotes) and the next text paragraph.

Alignment
Start

This defines the alignment of the table relative to the anchoring point.
Start defines whether the table should start at specific location (Top of column etc.) or just after the anchor line (Anywhere). With Float the table can move to the next page and
text appearing logically after the table is moved between the
anchor point and the table.
See also Special table positions on page 4-10

Numbering

This defines the flow of numbering:

Row First

Title position

Column First

This may be above or below the title. You can also set “no
Title”.
The Gap defines the space between the table title and the
table body.

Orphan rows

4–4

This value defines, how many rows at least must be placed. If
these rows do not fit on the current page, the table is moved
to the next page.

Set up table properties

Default cell margins

For paragraphs without any additional setting of cell margins
(see Table Cell on page 3-8) this defines the margins around
the paragraph in the table cell: Table ruling.
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Cell Margins from
the Table designer

This is the paragraph in the table
cell with the properties from the
paragraph designer.

Cell Margins from
the Paragraph designer.

Default cell margins may cut off accents in rows, if Cell Margin Top is to small (relative to font size). Font size is 24pt in
the following table rows.

Â

Ã

Ä

Å

Æ

Cell Margin is 0pt in the first row (above),
6pt in the second row (below)
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Â
Table ruling

Ã

Ä

Å

Æ

With this dialogue only properties for regular patterns (n-th
line, n-th row etc.) can be set.
This table is left indented by 0.5 cm and uses special ruling to
group rows (every 2nd row).
Heading row(s)
The line above is the separator between body and heading

Cell

Body ruling is set to “Every 2nd”, Others: none
The non-shaded area is the body of the table
This is another row in this table
The line below is the separator between body and footing

Footing row(s)

Table shading

With this property sheet only regular patterns can be set (n-th
line, n-th row etc.).
The Fill values (White, 3%, 10% etc.) do not fill with shades,
but with patterns (see Border and Fill patterns on page 6-22)

D

When using shades be aware of the multiplicative effect of fill
and colour: 50% fill of a colour which is defined as 20% black
results in a 10% shade of gray.
Colours are defined in View > Color > Definitions … (see Colours on page 6-22).
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Set up table properties

Custom ruling and shading
Additional properties for individual rows, columns and cells
are defined with Table > Custom Ruling and Shading.
Specify either ruling or shading or both with the appropriate
check boxes.
When using shades be aware of the multiplicative effect of fill
and colour: 50% fill of a colour which is defined as 20% black
results in a 10% shade of gray.
Colours are defined in View > Color > Definitions…
Beware of the ‘reverse logic’ to remove ruling or shading:
You need to check all elements which you want to clear and
then use the selection None from the Apply Ruling Style list.

Reassign original table ruling and shading
Apply custom ruling

Apply the custom ruling with Table > Custom Ruling and
Shading. For example, remove the ruling from the inner cells
with style None:

Reassign the original
ruling

1 Select the same cells as for the custom ruling/shading or
(if appropriate) the whole table.
2 In Table > Custom Ruling and Shading set To Selection
(Top, … Right) and ‘Inside Borders’ (Row, Column).
3 From the drop down list Apply Ruling Style select From
Table.
4 Check Custom Cell Ruling, uncheck Custom Cell Shading
5 Click Apply

Re-assign the original
shading

1 Perform steps 1 to 3 from before
4 Check Custom Cell Shading, uncheck Custom Cell Ruling
5 Click Apply

Reset to catalogued table
properties

1 Set all check boxes
2 In the drop-down lists select From Table
3 Click Apply
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Table ruling peculiarities

Table ruling peculiarities
The size of a table or cell is the skeleton (···) on which the
ruling is applied. A container text frame (- - -) with the table
anchor does not crop the table, but the anchored frame (outer
container with the full line) does. The table below has 3mm
ruling and its width is the same as the frame width (115mm).
2011-05-11

Table anchor7
skeleton (partially)
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The outside ruling left and right is cropped to the skeleton by
the outer container.

Define line styles for tables
Line styles used in tables (fine, bold, double etc.) are set with
Table > Custom Ruling & Shading, button Edit Ruling Style.
When changing the name of a style only rulings in the current
document are affected. When importing table styles to
another document, the changed name will become an additional name in the target document.
Provide meaningful names. It may be useful to add the line
width to the name – but this creates problems if you need to
change the properties of the line style.
It is not possible to create dashed lines or other broken
forms. Use the Tint attribute to apply a fill percentage of a
colour (50%) to the line.
With scripting the patterns used prior to FM 8 are still available (see Border and Fill patterns on page 6-22). For example, to
define the style broken-1 [Michael Müller-Hillebrand 2011-03]:

D

Set lvObj = ActiveDoc.FirstRulingFmtInDoc;
Loop While(lvObj)
If (lvObj.Name = 'broken-1')
Set lvObj.Pen = 11; // values 8...14 for ‘dashed’
Display lvObj.Properties;
EndIf
Set lvObj = lvObj.NextRulingFmtInDoc;
EndLoop
3 pt wide lines with lvObj.Pen=
8 9 10 11 12 13 14

In MIF the pattern can also be set:
<Ruling
<RulingTag `broken-1'>
…
<RulingPen 11>
<RulingLines 1>
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Modify column widths
The handles of a selected group of cells are always to the
right of the selection.

Adjust column width with
mouse

 Set a reasonable grid spacing (e.g. 0.1 cm) in View >
Options
 Set Graphics > Snap to activate the grid for your work
 Select the column you want to adjust (e.g. CTRL+click into
the middle of a cell), then drag a handle.
 To move a border between two columns (widen one column
and narrow the other), select the left column and
ALT+drag a handle.

Note:

To adjust to widths defined by the grid spacing you must start
with the left most column and work to the right - or you may
get crude values.

Set column width
1 Select the column(s) to be resized.
2 Right click to get the context menu or select Table >
Resize Columns …
3 Choose the appropriate method to size the column and
enter the required measure.
To set the width to match the widest paragraph or frame in
the selected cells, use the last option and enter a maximum
width.

Copy column widths

To copy a column width from table-1 to table-2:
1 In table-1 click in the column whose width you want to
copy
2 Choose Edit > Copy Special > Table Column Width.
3 Click in the column in table-2 which will receive the new
width. Click Paste.
4 For all columns in a table you will need to repeat steps 1 to
3 for each column.

4–8

Functions in tables

Functions in tables
Sort by columns and
rows
1 Place the cursor in the table.
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2 With menu or context menu Table > Sort … open the dialogue.
3 If you have selected only part of the body cells, you may
click on the button Select All Body Rows to select the whole
table.
4 If the table does not have heading rows with content, then
you need to set up the sort by row number.
5 When sorting by column, you do not have title information.
6 Click the Sort button.
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Note:
Bypass sort problem

A Table sort deletes all cross reference markers from the
cells. And there is no undo for the sort!
To overcome this problem edit all cross reference markers in
the table to get a different type and re-edit them back after
the sort.
1 Specify a user marker type (for example, wasxref)

D

2 Edit the CrossRef markers in the table by changing the
name Marker Type:

3 Sort the table.
4 Edit all wasxref markers back to CrossRef.

Calculations in tables

FrameMaker does not provide calculations in tables. This can
be performed by’plug-ins’:
 FrameScript by Elmsoft ( http://www.framescript.com/) is a
full blown macro language which knows all FrameMaker
commands. See Extensions by API clients on page 1-21.
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Special table positions

Special table positions
Table at top of page
To get a table at the top of a page,
1 Select the table (place cursor anywhere into the table)
2 Activate the table designer (Table > Table Designer)
3 Set Start to Top of Page
This will move the table to the next page and display it on
top. The anchor of the table is left at the current paragraph.

Table at top of first page
p Insert the table at the first paragraph of the first page
p For the paragraph set Space Below to -font size (e.g. -14pt)
p For the table set Space Above to -font size of the paragraph
(e.g. -14pt)
Paragraph

This coloured area is the text frame with the table located topmost.

Floating text around table
A table with attribute Float allows text from behind the table
to flow between the anchor line and the table start:
Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceses, cinctra latrantium canum
turma; noctu stans in triviis vel
prope sepulcra et ubi loca sunt
caedibus contaminata.
Paragraph with table anchor7
This text was typed behind the
table, but flowed before it as soon
as the table became the attribute
Float. Text which does not fit in
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First

Next

first

This table has the attribute Float and the first
row does not fit onto the
first page.

second

Hence

third

viis vel prope sepulcra et

front of the table, will continue
behind it, as this example clearly
demonstates in this two column
text flow.

Set up a table template

Set up a table template
Any table in a document can be used for a table template.

To define a table
template from an
existing table

Set up the table as desired for your purpose:
Widths of columns, paragraph format in the columns, heading
and footing rows, regular ruling and shading etc.
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#

Work type

h

CHF

The first item on this invoice
Next item on this invoice
Last item in this table

Table 2:
Keep in mind that certain properties (custom ruling and/or
shading, straddling of cells – often used in headers – are not
kept in the table catalogue.
1 Place the cursor in the table.
2 In the table designer (CTRL+T) set the table tag (the name
of the table template), for example Invoice.

D
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Invoice

3 Select Commands: New Format.
4 Activate Store in Catalogue; click Create.

Sophisticated table templates
For frequent use of sophisticated table layouts the mechanism of the table catalogue is not sufficient (straddles cells,
custom shading/ruling, various paragraph formats).
It is useful to collect such items for copy and paste in a special document belonging to the project. The plug-in Auto-Text
from Silicon Prairie Software is very handy for this.
In der Gemeinde wohnhafte Schüler/innen 2002/2003
Vorschule (Kindergarten)
16
Primarstufe
108
Sekundarstufe I (inkl. Gymn. U.-Stufe)
44
Ausbildungsniveau Wohnbevölkerung ab 15 Jahren (2000)
Obligatorische Schule
25,6
%
Berufsausbildung
41,1
%
Maturitätsschule, Lehrerausbildung
4,9
%
10,0
%
Höhere Berufsausbildung
Fachhochschule, Universität
3,6
%
Andere, keine, keine Angaben
14,8
%

Samples from the
Statistical Yearbooks of
the Canton of Lucerne

Total
Jahr

Öffentlicher Auftraggeber (ohne Unterhaltsarbeiten)
Total

Davon
Bund
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Davon
Kanton

Gmden

Hochbau

Tiefbau

1984

2,4

4,3

2,4

10.5

2,6

9,9

-2,7

1985

5,0

-1,6

-16,9

-9,2

13,7

-6,7

5,6

1986

7,2

7,4

-2,4

0,9

15,5

11.6

2,3

1987

-0,8

4,9

4,2

3,8

5,6

10,9

-3,1

Importing tables

Importing tables
Import from prepared text
 Each table row corresponds to a line in the text file.
 Table cells are separated by TAB characters.
Beispiel einer zeile 1 nächste zelle 1 dritte zelle
Zweite zeile mit der 1 2. zelle 1 und der dritten zelle

1 File > Import > File... select Copy into Document.
2 In Unknown File type select Text; click Convert.
3 In the next dialogue (Import text by copy) select Convert to
Table
4 Select the desired table format (e.g. Wide-h-rules) and activate Leave Heading Rows empty. Convert!
Date / time

Operation

Reason

Action

Wed 98-07-01 15:10:30

Restart (inst)

I don‘t like that colour scheme Restart
mentioned in FrameUsers

Wed 98-07-01 16:13:44

Restart (inst)

DDD icon in shell32.dll
replacing Windows icon

Shut down

p The table heading is empty, so you need to fill in appropriate text.
p You will need to adapt the column widths.
p You may want to adapt the cell format with paragraph formats.

Import from Excel
Import complete table
(file)
Note:

1 Import the file by Copy with File > Import > File and select
the appropriate Excel format (“Excel” is for versions > 5).
If you import by Reference you do not have a chance to apply
proper formatting.
2 Set the appropriate formatting options for the import:
-

with. Re-format using current Document Formats you
get the paragraphs in format Body* (local formatting)
With Reformat as Plain Text the format is that of the
paragraph where you import to.

3 Select the imported (tabbed) paragraphs and convert them
to a table with Table > Convert to Table…

Import part of table

1 In Excel select the table area and copy to the clipboard.
2 In FrameMaker use Edit > Paste Special…
Paste Special: text

Paste Special RTF

You get a number of tabbed paragraphs, which you convert to a table.

You get an anchored table, to which
you apply the appropriate table format.

3 Select an appropriate Table format and format the rows/
the table according to the needs.
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Special operations

Special operations
Merge tables
1 Save your work to have a backup for this operation.
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2 Copy all the body rows from the second table (do not select
the heading rows).
Select the same number of columns as you have in the target table!
3 Click inside the first cell of the last row of the first table
and click Paste.
4 At this point Frame pops up a Paste Rows dialogue asking
where to paste the rows. and choose Insert Below Current
Row.
5 Select the second table and delete it.
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Split a table vertically
FrameMaker does not have a command to split tables between
rows or columns.

Method A

To split a (source) table into two tables at a row boundary (see
also Method B on page 4-14):
Heading row(s)
Wed 98-07-01 15:10:30

Restart (inst)

Wed 98-07-01 16:13:44

Restart (inst)

1 Save your work to have a backup for this operation.
2 Select the body rows to be used in the source table and
copy them to the buffer. Paste this table fragment to the
location of the second table part. A Table anchor with the
table fragment appears.
This is another row in this table - split above this row
The line below is the separator between body and footing

D

3 Place the cursor into the first row of the new table and
insert the desired number of heading rows (Table > Add
Rows or Columns…). Specify the number of header rows
to be added and choose To Heading from the drop down
list. Click Add.
This is another row in this table - split above this row

4 Copy the heading rows from the source table and paste
them into the empty heading rows in the second table (set
Replace Current Rows in the Paste Rows dialogue).
5 If the source table has Footing rows handle them similar to
the heading rows.
6 Select the copied body rows in the source table and delete
them.
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Special operations

Method B

If you need to insert some rows of different widths into a
table, you need to ‘split’ the table manually, before you can
insert table C in between (see Split a table vertically on
page 4-13 for another method):
1 Make a copy of your table (A 8 B)
2 Remove the superfluous body rows at the end of A
3 Remove the superfluous body rows at the beginning of B
4 Anchor table A, then C, then B with the above mentioned
spaces before or after.

Split wide table horizontally
A

B

C

D

A

B

C

D

E

F

G

H

1
2

E

1

1

2

2

F

G

H

Arrange the split table on facing pages. For tables longer than
a page you will also need vertical splitting.

Page break within table row
FrameMaker does not split a row of a table across pages (text
frames, actually). If you have cells where the content is larger
than can fit on a page (in the text frame height) you will get
strange effects:
 The cell contents flows outside the text frame
 If even larger, the cell extends to the end of the paper
where it is cut off.
Solution
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Create a new row (or rows), manage the cell's content manually so you fit what you desire on a page, and let Frame manage the placement of rows on pages. You can apply custom
ruling and/or shading properties as needed to affect the
appearance of the cells.

Fix appearance of table title

Fix appearance of table title
The table title (¶ format ttn-table-title-numbered) may
expand over the right edge of a table.
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Table 3: This is just a long table title to demonstrate
the effect on this centred table

Column 1

2

3

Some contents

Some contents

some contents

Something

Nothing

Each

To make the heading as wide as the table itself, use one of the
following methods:
1 Add an anchored frame to the title to limit the space in the
title area.
2 Constrain the title width by an additional title paragraph.
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3 Use additional header rows for the title area.

Anchored frame in title
area

At the end of the title add an anchored frame with property
“Run into Paragraph” and an alignment fitting the purpose
(filled with gray in this demonstration).
Table 4: This is just a long table title to demonstrate the effect of
the anchored frame

Column 1

2

3

Some contents

Some contents

some contents

Something

Nothing

Each

The alignment of the anchored frame may be “side farther
from binding” rather than “right” to adapt automatically to
the location of the table. You may need some experimenting
for your particular situation.
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Centred paragraph
constrains the title width

If the first paragraph in the title is centred, it will constrain
the whole title to the width of the table. You could have a
tiny, blank, centred paragraph in each title just above your
normal, left-aligned title. [Rick Quatro, 2006-10].
This paragraph is centred
Table 5: This is the real table title
paragraph, it is left adjusted

Column 1

2

3

Some contents

Some contents

some contents

Something

Nothing

Each

Centred paragraph in title
Table title shaded for demonstration only to see the effect
The table is left aligned.

Whether this is a bug or a feature is not known to the gurus.
Note:
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Cross references to the table title still possible.

Special operations

Title in header rows

1 Add a row on top of the heading rows.
2 Straddle all cells in this row
3 Insert the table title (using the correct ¶-format of table
titles) into this row.
4 Space below is not active in cells with only one paragraph,
hence you may wish to define and add a paragraph z6pt
(line spacing 6pt fixed). A line break would show up in a
“list of tables”.
5 Remove any ruling on the top and sides of this row; also
remove any shading to fit the appearance of standard
tables.
6 Set table property “No Title”.
The table then looks like this:
Table 6: This is just a long table
title to demonstrate the effect

Note:

Both table and title
centred

Column 1

2

3

Some contents

Some contents

some contents

Something

Nothing

Everything

Although the table title function is not used here, a cross reference to the title is possible thanks to the paragraph format.
If you want both the table centred in the text frame and also
the table title be centred:
1 Define the table alignment to be centred
2 Define the table title ¶ format to be centred:
This is the body text with the table anchor at the end of this
paragraph.
Table 7: This table title has attribute centred, so it will fill the entire
width of the text frame.

This table is centred
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Some contents

Some contents

some contents

Something

Nothing

Each

Rotate table cells

Rotate table cells
You can rotate only in increments of 90°. Rotate selected table
cells with Graphics > Rotate or use the buttons
.

Line breaking in rotated
cells

ing cell

body cell sixth
6
headbody cell 12

ing cell

body cell fifth
5
headbody cell 11

ing cell

third
heading cell

body cell fourth
4
head-

body cell 7
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Table row definition:
min: 0 max: 4cm

body cell 10

Table row definition:
min: 0 max: 1.5cm

Automatic
line
breaking is
possible

second heading
cell

Since the line length is in the direction of the row height, line
breaking will take place only in ‘constricted’ rows. As long as
no row height is defined, a default applies – and this is very
large: 35.56 cm (14").

With the default row height
it seems that there is no
automatic line breaking.
This is, however not true.
It’s the (large) default row
height which gives this impression.

body cell head1
ing cell
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You may select the whole table – this will not rotate the table,
but all cells in the table.

Rotated tables
To get a rotated table you must rotate the text frame which
contains the table. Just rotating the table will only rotate the
cells in it (see Rotate table cells on page 4-17).

Create a rotated master
page

This method creates a landscape text area in which the table
can be edited as usual, because the table is not rotated.
1 In View > Master Pages use Special > Add Master Page:
use a master page which provides the desired heading and
footing, for example ‘left’ and modify the page as needed.
See Master pages for rotated tables on page 5-31
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2 Apply this master page to any desired page with Format >
Page Layout > Master Page Usage.
3 To automate the process see Assign master pages automatically on page 5-32.
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Special operations

Repeated row headers
FrameMaker automatically repeats column headers on successive pages of a table. To get repeated column headers, use the
following procedure:
1 Set up a rotated text frame (use a special master page).
2 Create the table within this text frame and rotate all cells
in the other direction.

Row 1
was far
right

es

länger

warten.

brunnen
rand,

Row 2

war

noch

zu

vom

Row 3

froschkönig leid,

Der
Row 4
was the
leftmost

prinzessin er

endgültig die

hüpfte

Table 8: Table with row headers

Paragraph with table anchor

3 Now the heading rows appear to be heading columns.

Develop large tables
Using an ancillary large document may be handy to find out
the appropriate layout of large tables:
 Set up a large document, for example in A3 portrait (42cm
wide, 29.7cm high)
 Develop your table in this document using your standard
paragraph formats (import them into this document).
 After work the table may be to large to fit even into a
rotated frame of an A4 portrait.
 To check whether the table will fit into the target document, place a vertical line at the desired location from the
left. Then start with the tweaking:
-

-
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Reduce the font size of your paragraphs in the table. Do
not use smaller sizes than 7pt for sans serif fonts (such as
Arial or Helvetica) or 8pt for serif fonts (such as Times).
Reduce the width of certain or all columns
As a last resort consider splitting the table horizontally.
In this case you will need to repeat at least the leftmost
column in the second table. See Split wide table horizontally on page 4-14

Tables with varying column widths

Tables with varying column widths
In a FrameMaker table all cells of a column have the same
width. Straddled (combined) cells of fine granularity may
allow to ‘display’ different widths (see Simulated nested table
on page 4-20).
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Another method combines two or even more tables

7:

A
A
C
C
B
B

 The first table (A) has 5 columns, the second table (C) has 7
and the third table (B) again has 5 columns. The Anchor
position of all of these tables is at the end of the paragraph
before the table (symbolized by 7 in that paragraph).
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 The first (A) and second (C) table have Space Below of 0.
 The second (C) and third (B) table have Space Above of 0.
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 To select each anchor individually (for A, B or C) you need
a special technique (see Select a non-width character (or narrow characters) on page A-8).
You may wish to select a distinct table by CTRL+tripleclick into one of its cells (see Handling table items on
page 3).
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Nested tables

Nested tables
It is not directly possible to nest tables, that is, to place
another table within a cell of a table. Two additional wrappers
are required:
 Within the table cell an anchored frame must be placed
 Within the anchored frame a text frame is opened
 Within the text frame anything can be placed (text, table,
anchored frame etc.)

Nested tables

Note:

Simulated nested table
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If the elements are highly nested (no space around the inner
element of a nest) it will be very difficult to select and change
them.
With straddles in a fine grained table you can simulate a table
in a table. This example started with an 6 x 6 table. This fine
grain is only left in the centre area. The greyed cells are straddled:

Page layout

Overview
This chapter describes the ‘layers’ of a FrameMaker
document: body pages, master pages and reference
pages.
The building blocks of layout are text frames and
graphic frames. The text frames on the master pages are of two types: background frames (for headers
and footers) and the foreground frames which receive the user input. Graphic frames are also used
on the reference pages.
Any FrameMaker document can be a template to
create new documents. The behaviour (un-named
copy) of a standard template is just determined by
the location of the file.

Contents
Layout terminology ................................................. 2
Layout mechanisms ................................................ 3
Columns, text flows and side headings .................... 6
Set up master pages ............................................... 7
Frame types ......................................................... 11
Graphic elements on Reference Page ...................... 16
Running headers and footers ................................. 17
Special layouts ..................................................... 21
Templates ............................................................ 24
Sample template ................................................... 29
Handling master pages ......................................... 32

Page layout

Layout terminology
Typography has a 500 year history and hence some terms
may sound old-fashioned. Some have their roots in latin.
Header (kopf)
Homunculus

Maximilian prima vista

Hector

Lupus
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Maximilian
secondo

Hector canis est Iovis et
Latonae filia, soror
Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac
fascinationum. Rosa
planta est.

Rosa planta est.
Maximilian canis est Iovis
et Latonae filia, soror
Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac
fascinationum.

Lupus animalis est cinctra
latrantium canum turma;
noctu stans in triviis vel
prope sepulcra et ubi loca
sunt caedibus
contaminata. vel illum
dolore eu feugiat nulla
facilisis at vero eros et
accumsan nulla facilisis at
vero eros et accumsan

16 - 6

Homunculus
Lupus animalis est cinctra
latrantium canum turma;
noctu stans in triviis vel
prope sepulcra et ubi loca
sunt caedibus
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16 - 7

Side heading (marginalie)

Running heading (lebender
kolumnentitel)
Text frame (satzspiegel umfasst
auch den kolumnentitel, nicht
aber die paginierung)
Heading across
all columns and
side headings
Heading
(überschrift) in
text column
Footer (fuss)
Pagination
(paginierung, seiten-numerierung)

Text frame: position on page
and size define margins

Top margin (kopfsteg)
Inner margin (bundsteg)
Outer margin (aussen-steg)

Background frame (contents defined in master
page)

Bottom margin (fuss-steg)
See also Columns versus text flows on page 5-6

Structure of a FrameMaker document
A FrameMaker document contains three levels of information:
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Body pages

In these pages the running text is placed
with tables and graphics anchored in the
text.

Master pages

These pages define the layout which is
used in the body pages. There is always a
masturbate Right. A Left page is present
for documents defined to be double sided.

Reference pages

These pages contain graphic elements for
attachment to paragraphs as well as rules
about construction a table of contents, an
index or other generated documents.

Layout mechanisms

Layout mechanisms
Page types
body pages
connected
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connected

Title
Page

Heading

Heading

Heading

Writing into
connected
text frames
automaticall
y continues
on the next

page and
requests
new empty
pages from
the Right/

Left set of
masterpages
Other
masterpages
such as Title
must be

Footing

Footing

Footing

automatically assigned

Heading

Footing

Footing

Left

Footnote

<$paratext> <$pagenum>
<$paratext> <$pagenum>
<$paratext> <$pagenum>

Long line

openObjectId <$relfilename>:<$ObjectType> <$ObjectId>

Right

master pages

Heading

Heading

Footing
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manually assigned

Title

connected

Rotated
reference pages
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Graphic-1

Reference

TOC

 Body pages are the main working area for entering and
editing text, graphics etc.
 Heading/footing frames can not be changed on the body
pages 8 use different master pages.
 Reference pages serve various purposes: rules for building
TOC or Index, graphic elements, rules for arbitrary lists
etc.
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Page layout

Flows and frames
The paper (page)

This a flow A
This text flow extends from
this text frame to the one on
the right – these text frames
are connected.
vires humus fallo 25deu
Anetn bisre freun carmi avire
ingen umque miher muner
veris adest duner veris adest
iteru quevi escit billo isput
tatqu aliqu diams bipos
itopu 50sta Isant oscul bifid
mquec cumen berra etmii
pyren nsomn anoct reern
oncit quqar anofe ventm
hipec oramo uetfu orets
nitus sacer tusag teliu ipsev
75tvi Eonei elaur plica oscri
eseli sipse enitu ammih
mensl quidi aptat rinar uacae
ierqu vagas ubesc rpore ibere
perqu umbra perqu antra
erorp netra 100at mihif
napat ntint riora intui urque
nimus otoqu cagat rolym

oecfu iunto ulosa tarac
ecame suidt mande onatd
stent spiri usore idpar sep
pretu tempu rev tenov sindu
turqu brevt elliu repar tiuve
tamia queso utage udulc
vires humus 150eu uAnetn5

Anchored frame,
flows with text
Graphic text - no para
styles, only character
styles.

Header frame bound
to page
Text frame(s) connected) bound to
page

T

Header frames are not visible on the body pages - can not be grabbed

Anchored ( )
frames float with the
text

bisre freun is adest nihi
multi culti malenka dolce.
Graphic frame
bound to page

Text frame
in a graphic
frame with
paragraph

Text frame within
graphic frame

Text frame on page

This is flow B
ueso utage udulc vires humus fallo 25deu Anetn bisre freun
carmi avire ingen umque miher muner veris adest duner veris
adest iteru quevi escit billo isput tatqu tmii pyren nsomn
anoct reern oncit quqar anofe ventm hipec oramo uetfu orets
nitus sacer tusag teliu ipsev 75tvi oscri eseli sipse enitu
ammih mensl quidi aptat rinar uacanetra 100at mihif napat
ntint riora intui urque nimus otoqu cagat rolym oecfu iunto
ulosa tarac ecame suidt man

Footer frames are not visible on the body pages - can not be grabbed

Footer frame bound
to page

Text frames are connected together to form one text flow.
To connect text frames:
Format > Customize layout > Connect text frames

5–4

Layout mechanisms

Master page usage
Body pages

Chapter 2:
The title is vital
2011-05-11

A
B

The title is vital

Was sind Pferdestärken?

Was sind Pferdestärken?
Um die Leistung zu bestimmen, die Dampfmaschine
haben sollte, liess der
schlaue Brauer sein stärkstes
Pferd acht Stunden am Pumpwerk arbeiten. Das arme Tier
wurde mit der Peitsche angetrieben und fast zu Tode
gequält. Unter grösster Kraftanstrengung gelang es dem
Pferd, in acht Stunden rund
zwei Millionen Kilogramm
Wasser in die Höhe zu pumpen. Aus der Höhe, um die
Wassermenge gehoben

wurde und der Anzahl Stunden ergab sich dann, dass
das Pferd in jeder Sekunde
etwa 70 Kilogramm Wasser 1
Meter hoch gefördert hatte.
Der Brauer stellte dementsprechend James Watt die
Bedingung, die Dampfmaschine müsse in jeder
Sekunde finde-stets 70 Kilogramm Wasser 1 Meter hoch
pumpen.

A

A

Chapter 2
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Master pages

References in same document
Running H/F 2

Running H/F 1

Background text frame
for Running header/
footer

Chapter 2:

Text frame with named
text flow (editable in
body page)

Rotated background
text frame

Background text frame
for Running header/
footer

Running H/F 3

Left

D

Title

Right

Text flow

Paragraph format

Comments

A (connected)

Heading1 etc.

Main text flow

A (connected)

Chapter-title

Title area

B (unconnected)

Overview

Can not be reached by cross-references

Table 1: Text flow properties in a chapter

Area for chapter title: either small to let only the chapter title
go in (and text automatically flows to next page) or “space
below” is larger than height of frame.
Key point: same flow tag (A) as the body text!

Assignment of master
pages

For ordinary pages the master pages Right and Left are
assigned automatically. Other master pages are assigned with
Format > Page Layout > Master Page Usage...
To assign master page automatically based on a paragraph
format see Assign master pages automatically on page 5-32.
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Page layout

Columns, text flows and side headings
Columns versus text flows
Lorem ipsum dolor
sit amet,
consectetuer
adipiscing elit, sed
diam nonummy
nibh euismod
tincidunt ut laoreet
dolore magna
aliquam erat
volutpat. Ut wisi
enim ad minim
veniam, quis
nostrud exerci
tation ullamcorper
suscipit lobortis
nisl ut aliquip ex ea
commodo
consequat. Duis
autem vel eum
iriure dolor in
hendrerit in
vulputate velit esse
molestie consequat,
vel illum dolore eu

feugiat nulla
facilisis at vero eros
et accumsan et
iusto odio
dignissim qui
blandit praesent
luptatum zzril
delenit augue duis
dolore te feugait
nulla facilisi. Et tam
neque pecun modut
est neque nonor et
imper ned libidig
met, consectetur
adipiscing elit, sed
ut labore et dolore
magna aliquam
makes one wonder
who would ever
width
readcolumn
this stuff?
Bis
nostrud
exercitation ullam
mmodo consequet.
Duis aute in specs.

1 text flow with
2 columns
A text frame always
contains one text
flow (which may be
split into columns)
1 text frame
2 text frames

A

B

Hectic est Iovis et
Latonae filia,
soror Apollinis.
Est tricopor et
triceps,
magicarum artium
magistra ac
fascinationum
praeses, cinctra
latrantium canum
turma; noctu
stans in triviis vel
prope sepulcra et
ubi loca sunt
caedibus
contaminata.

Hecate est Iovis et
Latonae filia,
soror Apollinis.
Est tricopor et
triceps,
magicarum artium
magistra ac
fascinationum
praeses, cinctra
latrantium canum
turma; noctu
stans in triviis vel
prope sepulcra et
ubi loca sunt
caedibus
contaminata.

2 text flows
with 1 column

Side heads
Hector

Hector canis est Iovis et
Latonae filia, soror
Apollinis. Est tricopor et
triceps, magicarum
artium magistra ac
fascinationum. Rosa
planta est.

Lupus

Lupus animalis est cinctra
latrantium canum turma;
noctu stans in triviis vel
prope sepulcra et ubi loca
sunt caedibus
contaminata. vel illum
dolore eu feugiat nulla
facilisis at vero eros et
accumsan nulla facilisis at
vero eros et accumsan

Side head area (D: marginalien-spalte)
gap

5–6

1 text flow with
1 column and
side head area

1 text flow with
2 columns and
side head area

Hector

Hector canis
est Iovis et
Latonae filia,
soror
Apollinis. Est
tricopor et
triceps,
magicarum
artium magistra ac
fascinationu
m Duis

Lupus

Lupus
ubi loca sunt
animalis est contaminata
latrantium
.
canum
turma; noctu
stans in
triviis vel
prope
sepulcra et

dolor in
hendrerit
in
vulputate
velit esse
molestie
consequa
t, vel
illum
dolore eu
feugiat
nulla
autem vel facilisis at
eum iriure vero eros

Set up master pages

Set up master pages

2011-05-11

A standard master page (e.g. those named Left and Right)
contain a header frame, a body frame and a footer frame.
Althugh all three are text frames, only the body frame uses a
flow name.

Modify the Left and/or Right master pages
Even if you start with a new empty document, there are two
master pages already defined: Left and Right. Even if you have
specified single side pagination in Format > Page Layout >
Pagination…, a Left master page exists. It is just not displayed.
Hence for the setup or change of the R/L master pages you
are recommend to set pagination to double sided.
These two pages contain already three textframes:
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 The header frame is a background frame
 The body frame has a flow A defined and autoconnect
property.
 The footer frame is also a background frame

Modify the pages

You can do the following with these already existing pages:
p Resize all frames according to a set paper size (Format >
Page Layout > Page Size…)
p Chance paragraph formats used in the frames, add paragraphs in the enlarged header and/or footer frames.
p Specify additional or less content in the header and footer
frames
p Add graphic elements to the header and/or footer frame or
just on the page (e.g. a logo).

D

p Add additional frames, such as in the spine or outer margin, for example for document status and security. You
may wish to use variables for this information.

5–7
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Set up a new (addtional) master page
1 Change the document view with View > Master Pages
2 Insert a new page with Special > Add Master Page …
3 You are asked for a name. The names Left and Right are
already used. To change the appearance of these pages just
open them.
4 Define wether you want to start with an empty page or with
a copy of an existing master page. Click Add.
5 You create new frames with the graphic tool
left to the A tool.

which is

When inserting a text frame on a master page, you are
asked wether you want to insert a background frame
(header, footer) or a frame for text on the body page.
The background frame does not get a flow name, while the
flow name for the body text frame is essential. Normally
this flow name is A.
6 Named flows normally are autoconnected (especially flow
A). Set up the other flow properties with Graphics > Object
Properties. See Text Frames on page 5-11 for more details.
7 In the header and footer frames define the contents. See
Running headers and footers on page 5-17.
Note:

Example master page
Legal-stuff

A master page must contain at least one named flow. If the
standard flow is A, then any master page which shall be used
(assigned to body pages) with this flow must contain at least
one text frame with flow name A.
This example comprises from top to bottom the following elements:
Nr

Running H/F 1

This is in flow A - the text will not appear on the body page.

Type

Purpose, contents

1

Background text frame

Header. Definition of running header

2

Graphic line and graphic

Separator. Line and blob

Body text frame

Flow A, limited heights, same properties as flow
A has everywhere (side heads, autoconnect, etc.)

Background text frame

Legal text. This MP shall be applied to the last
page of a chapter or document. This may be
done manually or automatically. See Assign master pages automatically on page 5-32.

Graphic line and graphic

Separator. Line and blob

Background text frame

Footer. In this example only the chapter number
and the page number is inserted

3

4

Sample legal text for the end of each chapter (keep in mind: this does not apply to this particular document  the use of the FrameMaker 8 compendium is free):

Copyright notice
© TheCompany 2009
All rights reserved. Reproduction in whole or in part is prohibited without the prior written
consent of the copyright owner. The information presented in this document does not form
part of any quotation or contract, is believed to be accurate and reliable and may be changed
without notice. No liability will be accepted by the publisher for any consequence of its use.
Publication thereof does not convey nor imply any license under patent or other industrial or
intellectual property rights. TheCompany assumes no responsibility or liability whatsoever for
any failure or unexpected operation resulting from misuse, neglect improper installation,
repair or improper handling or unusual physical or electrical stress including, but not limited
to, exposure to parameters beyond the specified maximum ratings or operation outside the
specified range.

5

TheCompany PRODUCTS ARE NOT DESIGNED, INTENDED, AUTHORIZED OR WARRANTED TO
BE SUITABLE FOR USE IN LIFE-SUPPORT APPLICATIONS, DEVICES OR SYSTEMS OR OTHER CRITICAL APPLICATIONS. INCLUSION OF TheCompany PRODUCTS IN SUCH APPLICATIONS IS
UNDERSTOOD TO BE UNDERTAKEN SOLELY AT THE CUSTOMERS OWN RISK. Should a customer purchase or use TheCompany products for any such unauthorized application, the customer shall indemnify and hold TheCompany and its officers, employees, subsidiaries,
affiliates, and distributors harmless against all claims, costs damages and attorney fees which
could arise.

6

Contact information
TheCompany, Somewhere Boulevard 212, CH-1234 Nowhere
Phone: ++99 123 45 67, FAX: ++99 123 45 68
web: www.thecompany.com, e-mail: info@thecompany.com

1#
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Set up master pages

Assign master pages to body pages
See also Assign master pages automatically on page 5-32.
Left/Right master pages are automatically assigned with
growing text. To insert (for example at the beginning of the
text) another master page, you may decide between:

2011-05-11

1 Change the assigned master page of a particulare body
page.
2 Insert a page the flow of which is connected to the current
flow. The flow of the page must be manually connected to
the existing flow.
3 Insert an unconnected master page which does not influence the flow in the already existent pages.

Change assigned master
page

To change the assigned master page of a particular body
page, use Format > Page Layout > Master Page Usage…
p The current page is already mentioned at Current Page.
p Select the master page you wish to use. To regain the common R/L pattern select Right/Left.
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p You may apply a particular master page to a sequence of
pages with the respective entry fields.
p You may also change a currently assigned master page (to a
sequence of body pages) with the last check box and select
the master page to be assigned in the drop down list.
For example, to assign the master page Last to the last page
of the document, set the dialogue to what is shown in the
screen shot.
If this Last master page contains a flow A with attribute Autoconnect, text may flow into this page also.
If you assign a master page, for example to the first page of
the document, which does not contain an autoconnnected
flow A, then

Insert additional page

To insert a new page which uses a master page with a text
flow, use Special > Add Disconnected Pages…

D

Since these pages may not be connected due to a mismatch in
flow names, you get the following message:

If the page (which is more normal the case) contains a connectable flow, you can now connect the flows.

Connect flow

After insertion of the page you may connect the (matching)
flow to the rest of the document. For this operation you may

5–9
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wish to use a small zoom factors to see the pages to be connected side by side on the screen:

Any flow

Flow A

Flow A

To connect flow A on the newly inserted page with the same
flow on the already existing pages
1 Select the flow on the new page (left in picture)
2 Select the flow in the existing pages (right in picture). Don’t
worry that the left selection will disappear.
3 With Format > Customize Layout > Connect Text Frames
the two frames are connected.
4 The text from the existing page (right) will flow back into
the frame on the new page (left). You will need to insert
headings and/or adjust other formatting to the paragraphs
on the new page.
Note:

Master page with
background only

You may get a message if the flow is already connected or if
you will create a circular connection.
If you insert a master page which does not contain a named
flow (just background information), you will get a warning:

You can not create cross references to the text on this body
page.

5 – 10

Frame types

2011-05-11

Frame types
Frames are ‘the name of the game’ – a main concept of FrameMaker. Frames enclose other objects. On the raw paper you
can place graphic objects, such as text frames or graphic
frames or rectangles. A text frame contains text which can
contain anchor points for anchored objects, such as tables or
anchored frames. Within an anchored frame any graphic
object can be placed. Graphic objects have no anchor.

Text Frames
Normally you use text frames on master pages. Text frames
can, however, also be used as graphic elements. In this case
the text frame is located inside an anchored frame which
floats with the surrounding text:
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Insert a text frame

Insert a text frame with the tool
from the Graphic Tool Palette by dragging the mouse. This tool is not the largest tool in
the middle of Palette! You can set the number of columns and
the gap between the columns after releasing the mouse.
After inserting, more attributes are set with Graphics >
Object Properties… or button
. The most important properties are about the text flow: tag name and auto connection.

Flow tag (flow name)

The main flow on master pages normally is named A. The
name can be any upper or lower case character. Cross references operate only within, not across named flows. You can
not reference an item in flow B from flow A.
A text frames within an anchored frame gets no flow name
initially. Text frames placed in master pages are background
frames with no flow name by default.

Auto connection
A text flow with a flow name (flow tag) automatically gets the
property auto connect ON. This is the standard for text
frames on the master pages where you want this automatism
to happen. If this property is not set, you will not get additional pages automatically for more text.
D

Note:

When switching from Master Page view to Body Page view, in
rare occasions this attribute Auto connect may be lost and you
need to re-apply it while on the Body Page.

Side heads
If you want to specify headings or other text to appear in a
side head area, specify the needed properties in Graphics >
Object Properties… or button
. In the document you are
reading the values are as displayed in the image.
See also Pagination on page 3-6 for the various heading styles
possible in FrameMaker.
Note:

5 – 11

The flag Room for Side Heads is a property of the text flow.
Hence it is not imported with the master pages. It may be nec-

Page layout

essary to set this attribute again after switching to body page
display.

Multiple columns
To specify multiple columns for a text frame (or change the
initial setting) use Graphics > Object Properties… or button
.
If you also have specified Room For Side Heads the columns
are established in the rest of the text frame. This may create
too narrow columns (see).Columns versus text flows on page 5-6

Border and fill of text
frame
Apply a border:

p Select the text frame
p Apply a line with the graphic tool Apply Pen Style

Fill the frame with
colour:

Example of text frames in
anchored frame

p Select the text frame
p Fill the frame with the graphic tool Apply Fill Style
The following anchored frame has a border
This is text within a text
frame
This text frame was created with the graphic
tool Text Frame.
Frame
In this text frame all
paragraph formats,
character formats and
table formats can be
used as in the main text
frame.

Note:

This is another text
frame within the same
anchored frame.
This has no border but
is filled with ‘paper’ colour (border and fill can
only have the same colour in FrameMaker)

The topmost line of text in a frame may extend beyond the
boundary of the frame depending of the font metrics (enlarge
the above image to see the effect). In particular, accents
always extend to the outer area. See also Default cell margins
on page 4-5.

Anchored frames
Anchoring position

Depending on the anchoring position, additional parameters
can be set.
Cropped If set the frame is cropped by the outer container.
Most time this outer container is the text frame
with the anchor.
Floating

Set this option to allow text lines after the anchor
to sneak before the frame, which is placed on the
next page if its size requires.

In the following diagrams the bordered rectangle is the text
frame with the text flow containing the anchored frame (the
outer container).
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Frame types

Below current line

Alignment of the frame left, centre and right
Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
iviis
turma; noctu stans in tr

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
iviis
turma; noctu stans in tr

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
iviis
turma; noctu stans in tr

vel prope sepulcra et ubi loca sunt
caedibus contaminata. Hecate est
Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra

vel prope sepulcra et ubi loca sunt
caedibus contaminata. Hecate est
Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra

vel prope sepulcra et ubi loca sunt
caedibus contaminata. Hecate est
Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra
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7

At top of column

7

Alignment of the frame left, centre and right

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
iviis
turma; noctu stans in tr
vel prope sepulcra et ubi loca sunt
caedibus contaminata. Hecate est
Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra

At bottom of column

Alignment of the frame left, centre and right
Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
iviis
turma; noctu stans in tr
vel prope sepulcra et ubi loca sunt
caedibus contaminata. Hecate est
Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra
et ubi loca sunt caedibus

7

7

Distance above baseline varying
Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
turma; noctu stans in

tr

7

0 cm

iviis vel prope

sepulcra et ubi loca sunt caedibus
contaminata. Hecate est Iovis et
Latonae filia, soror Apollinis. Est
tricopor et triceps, magicarum
artium magistra ac fascinationum
praeses, cinctra latrantium canum
turma; noctu stans in triviis vel

Outside column

7

7

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
iviis
turma; noctu stans in tr
vel prope sepulcra et ubi loca sunt
caedibus contaminata. Hecate est
Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra
et ubi loca sunt caedibus

At insertion point

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
iviis
turma; noctu stans in tr
vel prope sepulcra et ubi loca sunt
caedibus contaminata. Hecate est
Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
iviis
turma; noctu stans in tr
vel prope sepulcra et ubi loca sunt
caedibus contaminata. Hecate est
Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra

7
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Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
turma; noctu stans in
iviis vel prope
tr
sepulcra et ubi loca sunt caedibus
contaminata. Hecate est Iovis et
Latonae filia, soror Apollinis. Est
tricopor et triceps, magicarum
artium magistra ac fascinationum
praeses, cinctra latrantium canum
turma; noctu stans in triviis vel
prope sepulcra et ubi loca sunt
caedibus contaminata.

7

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
iviis
turma; noctu stans in tr
vel prope sepulcra et ubi loca sunt
caedibus contaminata. Hecate est
Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra
et ubi loca sunt caedibus

7

Distance above =
-0.5 cm
Frame can be
moved with mouse
only vertically.
Left example: ¶
has flexible line
height.

Distance above baseline varying, also distance to text frame

D

Hecate est Iovis et
Latonae filia, soror
Apollinis

0 cm
minata.
Heca
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Est tricopor et
triceps, magicarum
artium magistra ac
fascinationum
praeses, cinctra
latrantium canum
turma; noctu stans
iviis vel
in tr
prope sepulcra et
ubi loca sunt
caedibus conta

7

te est Iovis et
Latonae filia, soror
Apollinis. Est
tricopor et triceps,
magicarum artium
magistra ac

Hecate est Iovis et
Latonae filia, soror
Apollinis

Est tricopor et
triceps, magicarum
artium magistra ac
fascinationum
praeses, cinctra
latrantium canum
turma; noctu stans
iviis vel
in tr
prope sepulcra et
ubi loca sunt
caedibus
contaminata. Hecate
est Iovis et Latonae
filia, soror Apollinis.
Est tricopor et
triceps, magicarum
artium magistra ac

7

Distance above =
-0.5 cm; distance
to text frame = 0.3
cm
Frame can be
moved with mouse
in 2 directions.
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Outside text frame

Distance above baseline varying, also distance to text frame
Hecate est Iovis et
Latonae filia, soror
Apollinis

Hecate est Iovis et
Latonae filia, soror

Est tricopor et
triceps, magicarum
artium magistra ac
fascinationum
praeses, cinctra
latrantium canum
turma; noctu stans
iviis vel
in tr
prope sepulcra et
ubi loca sunt
caedibus conta

Apollinis

Hecate est Iovis et
Latonae filia, soror
Apollinis. Est
tricopor et triceps,
magicarum artium
magistra ac

contami

7

0 cm

minata.

Run into paragraph

Est tricopor et
triceps, magicarum
artium magistra ac
fascinationum
praeses, cinctra
latrantium canum
turma; noctu stans
iviis vel
in tr
prope sepulcra et
ubi loca sunt
caedibus

7

nata. Hecate est
Iovis et Latonae filia,
soror Apollinis. Est
tricopor et triceps,
magicarum artium
magistra ac

Distance above:
-0.5 cm; distance
to text frame = 0.3
cm
Frame can be
moved with mouse
in 2 directions.

Distance above baseline varying, also distance to text frame
Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
turma; noctu stans in triviis vel
prope sepulcra et ubi loca sunt
caedibus conta

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et
triceps, magicarum artium
magistra ac fascinationum
praeses, cinctra latrantium canum
turma; noct stans in trviis vel
prope sepulcra et ubi loca sunt
caedibus contami nata.

Hecate est
Iovis et Latonae
filia, soror
Apollinis. Est
tricopor et triceps,
magicarum artium
magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra
et ubi loca sunt caedibus

iHecate est
Iovis et Latonae
filia, soror
Apollinis. Est
tricopor et triceps,
magicarum artium
magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu
stans in triviis vel prope sepulcra
et ubi loca sunt caedibus

7

Note:

7

Gap (distance to text) = 4pt.
Alignment can be:





Side farther from binding
Side closer to binding
Left
Right

The anchors (7) are visible here by using a special font.

Manipulating frames
Selecting frame

CTRL+click on the border of the frame or change cursor to a
hollow triangle on the graphic tool bar (see Tool palette on
page 1-14).
Note:

Do not move the mouse when CTL-clicking. You will create a
duplicate of the object! (see Ghost objects on page A-17).
Be aware, that you can not select text with the cursor for
selecting objects! You need to change the cursor back for text
editing work.

Resizing frame

A selected frame displays 8 handles on which it can be
resized in one or two dimensions. You can also resize
anchored frames numerically with Special > Anchored Frame
or any type of frame with Graphics > Object Properties.

Moving anchored frame

If an anchored frame has numbered values for positioning
attributes, such as Distance above Baseline, the frame can be
moved with the mouse in the corresponding direction. In this
case it can also be moved in small increments with an
ALT+arrow key.

5 – 14

Frame types

Graphic frames

2011-05-11

Graphic frames are just containers for other graphic objects
and allow to crop these at the frame border. These frames are
placed directly on the page – not floating in the text. If the
graphic frame is created inside a text frame, it lays above the
text. If it is created starting outside a text frame (e.g. close to
the page border) it lays behind the text.
Use graphic frames only on master pages, reference pages or
within anchored frames.

Insert a graphic frame

You insert a graphic frame with the (largest) tool from the
middle of the Tool Palette
by dragging the mouse.
The coloured area underneath this and the following paragraphs is a graphic frame, filled, moved to background, no
run around (Graphics > Runaround properties). Such a
frame does not flow with the text – it may end up on the
wrong page.

E:\FM-course\handout\layout.fm

Note:

If you copy (or cut) the graphic frame and paste it to an other
page with a cursor position, it becomes an anchored frame.
You need to click outside the text frame before pasting to position the frame on the paper.

D

Graphic frames in background can not be selected the normal
way. You need to open a selecting rectangle from outside the
main text frame (see Concealed objects on page A-17).
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Page layout

Graphic elements on Reference Page
The main purpose of graphics on reference frames are their
use in the paragraph specification Frame Above/Below (see
Advanced on page 3-8).
See Special formatting on page 3-18 for background colour and
or framing of paragraphs.
When inserting a graphic frame on a reference page, you must
provide a name for the frame.
On the reference frame of this document (Reference) the following items are defined (truncated to the right). The graphic
frames are shaded here for visibility only.:

zfn-footnote

ztf-table-footnote

Single Line

Double Line

ze-editors-note

Note:

See the ztf-table-footnote frame here. It is empty, hence defines
only space for the distance between table bottom and the table
footnote.

Graphics on Reference Pages
Especially in templates to be used for multiple documents it
is useful to have the needed graphic elements available within
the template. Hence they are placed on the Reference page
and referred to on master pages and body pages.
However, copied graphics may significantly blow up the document size (see Referenced versus copied graphics on page 6-7.
In many cases it is possible to replace such logos by a traced
graphic (a FrameMaker graphic) and text. See Replacing image
logo on page 6-19.
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Running headers and footers

Running headers and footers
Running headers and footers pick up contents from the current page or one of the previous pages.
The information to be placed is defined by system variables
which are only available on master pages. For a complete list
see Building blocks for system variables on page 7-4.
2011-05-11

FrameMaker provides 12 system variables for running headers or footers for reference to paragraphs or to markers.
Other system variables provide numbering properties and
date and time information.

Insert a system variable
To insert a system variable into the text frame on the master
page:
p Special > Variable…

E:\FM-course\handout\layout.fm

p Select the appropriate variable and modify its presentation
according to your needs.

Numbering pages

D

You can insert the following pagination information of the
current document:
Purpose

Format of variable

Example of use (format)

Current page number (represented as #)

<$curpagenum>

Last page number in file

<$lastpagenum>

Page <$curpagenum> of
<$lastpagenum>

Chapter number

<$chapnum>

Chapter <$chapnum>

Volume number

<$volnum>

Volume <$volnum>

The display of these numbers depend on the settings in Format > Document > Numbering.
The correct values displayed in the body pages depend on the
proper updating of the numbering. See Set up numbering of
chapter files on page 8-7.
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Reference to headings
The most common contents of headers are references to
headings in the text. From a paragraph you can get the numbering information and/or the text.
Purpose

Format of variable

Example of use

text of referenced paragraph type

<$paratext[paratype]>

<$paratext[2heading]>

numbering of referenced paragraph type

<$paranum[paratype]>
counter value of reference paragraph type <$paranumonly[paratype]>

Second level 2 heading

Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor
et triceps, magicarum artium magistra ac fascinationum
praeses, cinctra latrantium canum turma; noctu stans in triviis vel prope sepulcra et ubi loca sunt caedibus contaminata.

Et tam neque pecun modut est neque nonor et imper ned libidig met, consectetur adipiscing elit, sed ut labore et dolore
magna aliquam makes one wonder who would ever read this
stuff? Bis nostrudesse cillum dolore eu fugiat nulla pariatur.
At vver eos et accusam dignissum qui blandit est prae

First evel 2 heading
E:\FM-course\insets\runningHF-1.fm

Level 1 heading on page 1

2

R

Third level 2 heading

L

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed
diam nonummy nibh euismod tincidunt ut laoreet dolore
magna aliquam erat volutpat. Ut wisi enim ad minim veniam,
quis nostrud exerci tation ullamcorper suscipit lobortis nisl
ut aliquip ex ea commodo consequat. Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat, vel illum dolore eu feugiat nulla facilisis at vero eros et
accumsan et iusto odio dignissim qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi.

Officia deserunt mollit anim id est laborum Et harumd dereud
facilis est er expedit distinct. Nam liber te conscient to factor
tum poen legum odioque civiuda et tam. Neque pecun modut
est neque nonor et imper ned libidig met, consectetur adipiscing elit, sed ut labore et dolore magna aliquam is nostrud
exercitation ullam mmodo consequet. Duis aute in voluptate
velit esse cillum dolore eu fugiat nulla pariatur. At vver eos et
accusam dignissum qui blandit est praesent. Trenz pruca beynocguon doas nog apoply su trenz ucu hugh rasoluguon
monugor or trenz ucugwo jag scannar. Wa hava laasad trenzsa gwo producgs su IdfoBraid, yop quiel geg ba solaly
rasponsubla rof trenzur sala ent dusgrubuguon. Offoctivo

Level 1 heading on page 1

4

maku noga wipont trenzsa schengos ent kaap zux copy
wipont trenz kipg naar mixent phona.

Third level 2 heading

Left page: Running H/F 1=
<$paratext[1heading]>

Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor
et triceps, magicarum artium magistra ac fascinationum
praeses, cinctra latrantium canum turma; noctu stans in triviis vel prope sepulcra et ubi loca sunt caedibus contaminata.

3

immoriatoly, hawrgasi pwicos asi sirucor.Thas sirutciun
applios tyu thuso itoms ghusoconsequet. Duis aute in voluptate velit esse cillum dolore eu fugiat nulla pariatur. At vver
eos et accusam dignissum qui blandit est praesent. Trenz
pruca beynocguon doas nog apoply su trenz u

2006-08-25

1

Level 1 heading on page 1
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2006-08-25

First evel 2 heading

<$paranum[th-table-head]>
<$paranumonly[th-table-head ]>

Right page: Running H/F 2 =
<$paratext[2heading]>

R

L

pwicos gosi sirucor in mixent gosi sirucor ic mixent ples cak
ontisi sowios uf Zerm hawr rwivos. Unte af phen neige pheings atoot Prexs eis phat eit sakem eit vory gast te Plok peish
ba useing phen roxas. Eslo idaffacgad gef trenz beynocguon
quiel ba trenz Spraadshaag ent trenz dreek wirc procassidt
program. Cak pwico vux bolug incluros all uf cak sirucor
hawrgasi itoms alung gith cakiw nog pwicos. Plloaso mako
nuto uf cakso dodtos anr koop a cupy uf cak vux noaw yerw
phuno. Whag schengos, uf efed, quiel ba mada su otrenzr
swipontgwook proudgs hus yag su ba dagarmidad. Plasa

Cak pwico siructiun ruos nust apoply tyu cak UCU sisulutiun
munityuw uw cak UCU-TGU jot scannow. Trens roxas eis ti
Plokeing quert loppe eis yop prexs. Piy opher hawers, eit yaggles orn ti sumbloat alohe plok. Su havo loasor cakso tgu
pwuructs tyu InfuBwain, ghu gill nug bo suloly sispunsiblo
fuw cakiw salo anr ristwibutiun. Hei muk neme eis loppe.
Treas em wankeing ont sime ploked peish rof phen sumbloat
syug si phat phey gavet peish ta paPlokeing quert loppe eis
yop prexs. Piy opher hawers, eit yaggles orn ti sumbloat alohe
plok. Su havo loasor cakso tgu pwuructs tyu.

Fourth level 2 heading
Lorem ipsum dolor sit amet, consectetaur adipisicing elit, sed
do eiusmod tempor incididunt ut labore et dolore magna alig
bo suloly sispunsiblo fuw cakiw salo anr ristwibutiun. Hei
muk neme eis loppe. Treas em wankeing ont sime ploked
peish r

Reference to alternative heading
There are cases where you need to set up a list of ¶-formats
for reference. Assume the left page should always display
information from a 1heading, 2heading or 3heading, whichever is closest to the reference: The proper format for this is:
<$paratext[1heading,2heading,3heading]>
If on the current page a 1heading is found, it is placed in the
running header. If not, FM searches for a 2heading on the current page and then for a 3heading. If none of these is found
on the current page, the previous page is inspected etc.

First evel 2 heading
E:\FM-course\insets\runningHF-2.fm

Second level 2 heading

2

Second level 2 heading

Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor
et triceps, magicarum artium magistra ac fascinationum
praeses, cinctra latrantium canum turma; noctu stans in triviis vel prope sepulcra et ubi loca sunt caedibus contaminata.

R

Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor
et triceps, magicarum artium magistra ac fascinationum
praeses, cinctra latrantium canum turma; noctu stans in triviis vel prope sepulcra et ubi loca sunt caedibus contaminata.

Et tam neque pecun modut est neque nonor et imper ned libidig met, consectetur adipiscing elit, sed ut labore et dolore
magna aliquam makes one wonder who would ever read this
stuff? Bis nostrudesse cillum dolore eu fugiat nulla pariatur.
At vver eos et accusam dignissum qui blandit est prae

Left page: Running H/F 1=
<$paratext[1heading,
2heading]>

L

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed
diam nonummy nibh euismod tincidunt ut laoreet dolore
magna aliquam erat volutpat. Ut wisi enim ad minim veniam,
quis nostrud exerci tation ullamcorper suscipit lobortis nisl
ut aliquip ex ea commodo consequat. Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat, vel illum dolore eu feugiat nulla facilisis at vero eros et
accumsan et iusto odio dignissim qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi.

Note:
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Officia deserunt mollit anim id est laborum Et harumd dereud
facilis est er expedit distinct. Nam liber te conscient to factor
tum poen legum odioque civiuda et tam. Neque pecun modut
est neque nonor et imper ned libercitation ullam mmodo consequet. Duis aute in voluptateos et accusam dignissum qui
blandit est praesent. Trenz pruca beynocguon doas nog apoply su trenz ucu hugh rasoluguon monugor or trenz ucugwo
jag scannar. Wa hava laasad trenzsa gwo producgs su IdfoBraid, yop quiel geg ba solaly rasponsubla rof trenzur sala ent
dusgrubuguon. Offoctivo

Third level 2 heading

3

Fourth level 2 heading

4

immoriatoly, hawrgasi pwicos asi sirucor.Thas sirutciun
applios tyu thuso itoms ghusoconsequet. Duis aute in voluptate velit esse cillum dolore eu fugiat nulla pariatur. At vver
eos et accusam dignissum qui blandit est praesent. Trenz
pruca beynocguon doas nog apoply su trenz u

2006-08-25

1

Level 1 heading on page 1

swipontgwook proudgs hus yag su ba dagarmidad. Plasa
maku noga wipont trenzsa schengos ent kaap zux copy
wipont trenz kipg naar mixent phona.

Third level 2 heading
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2006-08-25

Level 1 heading on page 1

Right page: Running H/F 2 =
<$paratext[2heading,
1heading]>

R

pwicos gosi sirucor in mixent gosi sirucor ic mixent ples cak
ontisi sowios uf Zerm hawr rwivos. Unte af phen neige pheings atoot Prexs eis phat eit sakem eit vory gast te Plok peish
ba useing phen roxas. Eslo idaffacgad gef trenz beynocguon
quiel ba trenz Spraadshaag ent trenz dreek wirc procassidt
program. Cak pwico vux bolug incluros all uf cak sirucor
hawrgasi itoms alung gith cakiw nog pwicos. Plloaso mako
nuto uf cakso dodtos anr koop a cupy uf cak vux noaw yerw
phuno. Whag schengos, uf efed, quiel ba mada su otrenzr

L

Cak pwico siructiun ruos nust apoply tyu cak UCU sisulutiun
munityuw uw cak UCU-TGU jot scannow. Trens roxas eis ti
Plokeing quert loppe eis yop prexs. Piy opher hawers, eit yaggles orn ti sumbloat alohe plok. Su havo loasor cakso tgu
pwuructs tyu InfuBwain, ghu gill nug bo suloly sispunsiblo
fuw cakiw salo anr ristwibutiun. Hei muk neme eis loppe.
Treas em wankeing ont sime ploked peish rof phen sumbloat
syug si phat phey gavet peish ta paPlokeing quert loppe eis
yop prexs. Piy opher hawers, eit yaggles orn ti sumbloat alohe
plok. Su havo loasor cakso tgu pwuructs tyu.

Fourth level 2 heading
Lorem ipsum dolor sit amet, consectetaur adipisicing elit, sed
do eiusmod tempor incididunt ut labore et dolore magna alig
bo suloly sispunsiblo fuw cakiw salo anr ristwibutiun. Hei
muk neme eis loppe. Treas em wankeing ont sime ploked
peish r

Character styles may not completely be transferred to the running heading. See Character styles in building blocks on
page 3-14.

Running headers and footers

References to special markers

2011-05-11

In some cases the needed information is not directly available
in headings or other paragraphs. For example the heading
texts may be too long. In scholarly text headings may contain
author names or special numbering, which shall not be transferred into the running headers/footers. Then the required
text is set up in markers on the pages to be referred to.
Running H/F

Format of variable

Example of use

Running H/F 3 (default format)

<$marker1>

Set up the marker text with a short version
of a heading

Running H/F 4 (default format)

<$marker2>

Put additional information into the marker,
which is not in the text

The text to be used in the header/footer is defined in a
marker with name Header/Footer $1 or Header/Footer $2

FrameMaker provides a host of system variables for date and
time information. For the complete list see Building blocks for
system variables on page 7-4.
Note:

User variables can not be set up with building blocks from system variables (for example, have a user variable iso-date
with the format yyyy-mm-dd). For such cases you need to modify the format of an existing system variable providing the
needed information (e.g. Current Date (Short)).

Graphic element on master pages
Especailly in headers and footers logos and the like are used.
If they are amported by reference, the size of the file does not
increase. But if the graphic is imported by copy, the size
increases significantly. See Referenced versus copied graphics
on page 6-7.

D
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Date and time

5 – 19

Page layout

Dictionary style headers
For long indexes and glossaries you may use dictionary style
headers: the first occurring index word on the left hand page
and the last occurring index word on the right page. This can
be achieved by the following Running H/F definitions:
Page
Left
Right

a

In an index

In a glossary

<$paratext[GroupTitlesIX]>

<$paratext[glossary-heading]>

<$paratext[+,GroupTitlesIX]>

<$paratext[+,glossary-heading]>

a. Watch the + sign preceding the tag name. This tells FM to look for the last rather than first occurrence.

y Einfriedung

288

Einfriedung, die räumliche Begrenzung
einer Grundstücksfläche mit einem Zaun,
einer Mauer oder Buschwerk. Unterschieden wird zwischen offener Einfriedung
(zum Beispiel Maschendrahtzaun) und geschlossener Einfriedung (zum Beispiel
Mauer).

y Französischer Balkon

First, die höchste Linie, an der die Dachflächen zusammenlaufen.

289
First
First

Geschlossene Einfriedungen
Offene Einfriedung

Firstlaterne, eine Æ Dachaufbaute, welche rittlings auf dem First sitzt. Häufig ist
sie seitlich mit Fenstern versehen.

Erker, nach den gängigen Begriffen der
Bautechnik ein von der Hauptfassade frei
auskragender Bauteil (vgl. RB 1985
Nr. 114). Im Gegensatz zu einem Æ Balkon
ist ein Erker eingekleidet. Nach der Praxis
(RB 1985 Nr. 114) wird bei Erkern und
ähnlichen Vorsprüngen ein Mindestabstand
von einem Meter über dem gestalteten Terrain verlangt. Setzt sich der Erker bis in die
Dachfläche fort spricht man von einem Æ
Dacherker.

Flachdach, ein Æ Dach mit einer Neigung
von weniger als 10° (vgl. BEZ 1996
Nr. 30).

Familienwohnung, eine Wohnung, die dem Aufenthalt einer Familie dienen kann, aber
nicht muss. Als Familienwohnung gilt eine Wohnung von vier und mehr Zimmern (§ 49a
PBG). Die Bau- und Zonenordnung kann für Familienwohnungen einen Ausnützungsbonus gewähren.
Fenster, eine Öffnung in der Mauer oder
im Dach (Æ Dachfenster) zur Belichtung
und Belüftung von Innenräumen. Die Anordnung und Gestaltung der Fenster bestimmt wesentlich die Erscheinung eines
Gebäudes.

Französischer Balkon, eine
Zwischenform von Fenster und Tür. Das hochrechtekkige Fenster reicht bis oder fast bis zum
Boden. Aus Sicherheitsgründen ist der untere Teil des Fensters fix oder mit einem
Gitter abgesichert. Der französische Balkon
kragt im Gegensatz zum normalen Æ Balkon nicht vor die Fassade.

Fensterfläche, die Fläche, welche für die ausreichende Belichtung eines Raumes vorgeschrieben ist. Für Wohn- und Schlafräume hat sie wenigstens einen Zehntel der Bodenfläche zu betragen (§ 302 PBG). Die Fensterfläche wird im Licht gemessen. Massgebend
ist die Fensteröffnung im Rohbau (so genanntes Rohlichtmass).

The glossary heading is defined as run-in paragraph in this
example. Hence it does not create a line break and the next
paragraph (glossary entry) follows on the same line.
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Special layouts

Special layouts
Newsletter
For newsletters and the like you want to have various text
areas to fill in. You may use for this purpose:

D
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 Distinct text frames with independent flow names. This is
useful to start a story on page 1 and finish it on page 2
while other stories are also on page 1. The two pieces must
be connected together:
Text in frame 1 with
low name A (or no
low name at all)

Text in frame 2 with
flow name A (or also
no flow name) . The
frames 1 and 2 are
connected.

Start on
page 1 in
rame I
which is
connected to
rame II

This is
frame III

This is
frame II

This is
frame IV
The first para
must “start
on top of column” or it
will just flow
…

 Various text frames with the same flow (A or none), connected in an arbitrary order.
Einen
so heißen
Sommer, wie
nun vor
hundert
Jahren, hat
es seitdem
nicht wieder
gegeben.
Kein Grün
dicke
Wiesenbauer
stand
breitspurig
in der
Torfahrt
seines
stattlichen

Connecting text frames

fast war zu
sehen;
zahmes und
wildes Getier
lag
Hauses und
rauchte im
Schweiße
seines
Angesichts
aus seinem
großen
Meerschaum
kopfe. Dabei
schaute er
schmunzeln
d einem

verschmachtet auf
den Feldern.
Es war an
einem Vormittag.
Die Dorfstraßen
standen leer; wer
nur konnte, war ins
Innerste der Häuser
geflüchtet; selbst
die Dorfkläffer
hatten sich
verkrochen. Nur der

1 Select the first text frame
2 Select the second text frame (the first may become unselected, but this does not harm)
3 Connect the frames with Format > Customize Layout >
Connect Text frames. Text will overflow automatically
from the first to the second frame.
4 Repeat this for all the frames to be connected. 1 8 2, 2 8 3,
384…
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Two languages in parallel
To have two languages (or other purpose of two different
flows) on facing pages, you need to set up a ‘pass through’
frame on the opposite pages, starting on page 2.
Note:

For page 1 normally a different master page is used. You
should also use different format names for the paragraphs of
the two languages, e.g. be-body-english and bg-body-german.
For clarity in the following picture flow A is filled with red
and flow B is filled with blue.

Der froschkönig
w
war es nun endgültig leid, noch
länger auf die Flow B
Flow A
prinzessin zu
warten. Ärgerlich hüpfte er
vom brunnenrand, zumal eine
dicke fliege sein
interesse

The frog king was
not amused at all
about the behaviour of the princess
and decided not to
wait any longer for
her. This was really disgusting what
the princess did to
him! He could not

eckte. Übel hatte u n
ihm die prinzessin mitgespielt!
Flow B
Daß ihm das
Flow A
passieren
musste! Öfter
als sonst verkroch er sich
von nun an in
die brunnenkresse und sin-

nderstand why she
reacted this way.
More often than
usual he retreted in
the watercress and
contemplated
about his life.

As you can see, the small ‘pass through’ text frame catches at
least one character from the flow. This happens even if you
make this frame as small as possible (0.125" high, 1mm wide
or use the mouse to squeeze it down to zero)11).
To overcome this, you need to move the word dropping into
the ‘pass through’ frame to the next normal frame of the
same flow. You do so by inserting a paragraph break just
before this word and again in the ‘pass through’ frame:
Der froschkönig
war es nun endgültig leid, noch
länger auf die Flow B
Flow A
prinzessin zu
warten. Ärgerlich hüpfte er
vom brunnenrand, zumal eine
dicke fliege sein
interesse

The frog king was
not amused at all
about the behaviour of the princess
and decided not to
wait any longer for
her. It was really
disgusting
what
the princess did to
him! He could not

weckte. Übel
hatte ihm die
prinzessin mitFlow B
gespielt! Daß
Flow A
ihm das passieren musste!
Öfter als sonst
verkroch er sich
von nun an in
die brunnenkresse und

understand why
she reacted this
way.
More often than
usual he retreated
in the watercress
and contemplated
about his life.

Make this fix only after the text has settled.
To remove the empty paragraphs for changing the text,
search with wildcards for \p\p in the two flows and replace it
with nothing.
It is good practice to use a special paragraph format for the
empty paragraph in the ‘pass through’ frame. It may have an
attribute “start on top of column”.

11 Whether this is a bug or not is not clear.
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Mirrored side head alignment
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With mirrored arrangement of the side head area on left and
right pages it is desireable to have also the alignment of the
side heads themselves mirrored:

Unfortunately this can be achieved only with add-ons (plug-in,
script):
 Free [i]-frame FrameScript script Align Side Heads from itl.

D

 Function Left / Right Alignment in the plug-in Toolbox for
Framemaker from Sqidds (formerly Systec). This function
is also available in Finalyser for FrameMaker 10.

5 – 23

Page layout

Templates
Templates organise and define layout and appearance of document types such as manuals, book chapters or theses.
A template is an ordinary FrameMaker file and may contain
explanatory text. Any FrameMaker document can act as a template.

Sample templates
FrameMaker comes with a number of pre-defined templates
which are located in the FrameMaker installation directory
($HOME\Templates), which is defined in maker.ini (See Template path on page A-31).
 The templates are grouped into the areas, for example,
Book, Business, Outlines, Reports or Special.
 In the English version layout items are in inches. In the
other languages the unit is metric.

To use a pre defined template

p File > New
p Open a folder with the desired type of template (e.g. Business)
p Select the desired template, New.
p You get a copy of the file with the name untitled.fm,
which you save to the desired location with an appropriate
name.

Organising templates
You may store your home grown templates in a subdirectory
of the FrameMaker installation (e.g. $HOME\Templates\c-std)
to benefit from a common location. They will however not
show up in the template browser (See To use a sample template
on page 1-10).
Another method to get only copies from the template file is to
store it in a company widely known location (e.g. D:\DOCSTD\Frame) and apply the file attribute ReadOnly to them.

Template information

It is good practice to note purpose and properties of a template in the template document itself to find this information
in any document created from this template:
 In the document meta-data (File > File Info… > Keywords:
D+DD-template A4-de.fm version 2.0 (april 2008)
 Special reference page named Template-Information.
There can be plenty of text on such a page which must not
be used for other purpose in the document.
 Hyperlink from a cross-reference in a text frame on a reference page. This can be to any document on your system or
even the web. Hence you can refer to a complete template
documentation (see Hyperlinks on page 7-19).
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Set up a template
To set up a new template, for example for a report or script,
these approaches are possible:
 Set up from scratch (empty document)
 Use existing document as a starter
2011-05-11

 Use a FrameMaker template as a starter
Be aware that you should have one template for each language in which text is written. Language is an attribute of paragraphs (and character formats).
In any case it is good practice, not to start directly in the
Application, but to set up a plan. Get hold of any relevant
company standard. Consider the Interdependencies of template
items on page 28.
p Decide on the fonts to be used. In technical documentation
the following is an established rule:

E:\FM-course\handout\layout.fm

-

Body text, lists and footnotes are serif type
Headings, tables, header and footer are sans serif
Tables and table footnotes are narrow sans serif
Code examples use a monospaced font

p Sketch the layout with all measures. Think about special
pages, such as Preliminaries, Title and Last for a chapter,
rotated pages (e.g. Wide-left and Wide-right) for extra wide
tables etc.).
Look carefully on the purpose of the template to set up the
names of styles, variables etc. Specify pagination. Define
the contents of header and footer, maybe also a field in the
spine.
If you provide rotated pages, consider automatic assignment according to Assign master pages automatically on
page 32.
p Set up a table of all desired paragraph formats (including
…TOC, …IX etc. and character formats with at least the
general and main detail properties (font, size, weight,
indents, type of pagination …).

D

It is good practice to name items used in the layout or just
by automatism (footnotes) z-xxxx to sort them at the bottom of the catalogues.
p Set up the numbering scheme for the headings, table titles
etc.
p Define the required character formats. Consider their
usage in cross reference formats, auto-numbering, variables.
p Define the general purpose table formats: placement, column widths, title placement, ruling/shading, ¶-formats in
the cells, cell margins etc. Include table formats to be used
for figures (boiler plate tables are better for this purpose).
p Define the various ‘small things’ which also belong to the
document properties:
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-

Use a FrameMaker
template

colours
cross reference formats
conditions
variables (user, system - for example date appearance)
ruling-styles for tables
graphics for the reference pages
appearance of change bars
document view, grid and snap properties, text options
(table) footnote properties and numbering,
PDF setup, document information
Special markers

p In File > New > Document click Explore Standard Templates to get sample presentations. 12)
p Select the appropriate template, e.g. Report, Numeric. To
get an impression of the template, click Show Example.
p Select the desired template, click Create.
p Personalise the template according to Use an existing document.

Use an existing document

Even a new document created by File > New > Document >
Portrait or > Landscape contains basic ¶, f, T styles, cross
reference formats etc. Hence the procedure to set up a template is the same as from an existing document. Only the
number of items already defined may differ significantly.
p Check all catalogues (paragraph, the character, table) and
all other definitions (colour, cross reference, conditions,
ruling styles for tables etc.). Delete entries which are not
needed.
p Add any generally useful definitions to the style categories
mentioned before.
p Check whether you need global changes to the paragraph
catalogue or the character catalogue, such as changing the
language.
p If your document is single sided, switch it to double sided
layout to see also the master page Left.
p Make any desired changes to the master pages. You may
wish to remove un-needed special pages or add such pages.
p Check the reference pages for un-needed pages. You may
for example find a page IVZ and a page TOC which both
define stuff for the table of contents. IVZ is used in a German environment, TOC for an English environment (FrameMaker version). Check both for completeness and similar
contents or remove the un-needed one.
p The same applies to the reference pages used for index:
IDX in the German and IX in the English environment.
p You may wish to remove the HTML reference pages altogether.

12 None of these templates might serve you, bit some may give you ideas.
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p Check the standard reference page whether it contains all
the graphics you reference in the ‘Frame above’ or ‘Frame
below’ attributes of paragraphs and for footnote separators.
You may wish to add graphics used in warning notes etc. If
copied into the template, insert them in the needed size to
avoid waste of file space.
2011-05-11

p Check out and modify/delete or add all the small items
mentioned in Set up a template on page 25.
p Clean out any text on the body pages, or better: describe all
formats with examples and specify its use. It may be
cleared before use whenever you use this template document.
p Save the document at an appropriate place, e.g. at …\docstandards\frame\.

D
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p Save this file with an descriptive name at an appropriate
place (e.g. as …\doc-standards\frame\report-general.fm).
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Interdependencies of template items
Many features of layout and style are related, they depend on
each other. The following scheme is based on Sarah O’Keefe’s
book FrameMaker 7: The Complete Reference.

Cond. text page

Graphic object

Table tags

Colour definitions

Ruling styles

Paragraph tags

PDF settings

Cross reference
formats

Math definitions

Character tags

Reference pages

Markers

Variable definitions
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Master pages

Sample template

Sample template
The following is based on the layout of this compendium.

Master page Left
2011-05-11

Layout (master page)
Header text frame:
 Type background
 Top=1cm,
Height=0.4 cm,
Left=2 cm,
Width=18 cm
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Main text frame:

§

18 cm

2
5.6 cm

0.6 cm

11.8 cm

 Top: 2 cm, L=2 cm,
W=18 cm, H=26 cm
 Flow A, auto connected
 Side head: room
5.6 cm, gap 0.6 cm

Footer text frame:
 Type background
 Top=28.6, H=0.4,
L=2, W=18.

Header frame:

¶-format z-header
Contents Running H/F 1; format=<$paratext[1heading]>

D

Contents of footer frame

¶-format z-footer
Contents D (f-format: DDD-symbols); TAB
System variable Chapter Number, “ - “;
System variable Variable Current Page #; TAB
System variable Filename long;
System variable Modification date short (in ISO format)

Master page right
Layout

Mirrored to Left

Header frame

¶-format z-header
Contents Running H/F 2; format=<$paratext[2heading]>

Footer frame

Same as on page Left.
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Excerpt from a paragraph catalogue

bodytext

3heading

11pt

1.5

1.5

bodytext

body

5.5pt

n1_numbered_1st

5.5pt

0.5

0.5

nx_numb...

nx_numbered_next

5.5pt

0.5

0.5

lb_bulleted_list

5.5pt

0.5

0.5

tt_table_title

12pt

4pt

Footnote

4pt

in col.
side head

no

14

0.5

0.5

11

yes

0.5

\b\t

In column

no

bold

12

<n=1>\t
<n+>\t

10

tl_table_list

18

14
Helvetica-narrow

4pt

Palatino

2.5

th_table_head
tc_table_cell

across all
…

Numbering
(for headings
only provisional)

1.5

keep with next

1.5

24

Numbering.

yes

24pt

pagination

2heading

weight

bodytext

Pagination

bold

1.5

size [pt]

1.5

font

page

Helvetica

1heading

space above

next paragraph

Default Font

tab L [cm]

Paragraph format
name

indent left [cm]

Basic properties

\b\t

9

Excerpt from a character catalogue
Format name

font

size

weight

angle

language

1highlight

as is

as is

as is

italic

as is

2highlight

as is

as is

bold

as is

as is

computer

Letter Gothic

as is

as is

as is

none

name

Helvetica Narrow

12pt

bold

normal

none

bullets

Zapf Dingbats

as is

as is

as is

none
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Master pages for rotated tables

2 Rotate page with Format >
Customize Layout >
Rotate page clockwise/
counter clockwise.
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3 Rotate central text frame
back. The heading/footing area will remain
rotated.

Text is oriented this way and tables are
placed normally7
here you can edit the table similar to the text

Heading area is rotated

1 Create master page in portrait mode (e.g. copy from
Right) and name it appropriately (e.g. Rotatedright)

Footing area is rotated
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Rotated tables are not rotated themselves but located in a
rotated text frame. For adequate handling (e.g. for Assign master pages automatically on page 32) it is best to create both a
right and a left rotated page:

Hecate est Iovis et Latonae filia, soror
Apollinis. Est tricopor et triceps,
magicarum artium magistra ac
fascinationum praeses, cinctra
latrantium canum turma; noctu stans in
triviis vel prope sepulcra et ubi taminata.

If for some reason you keep the master page in portrait mode
and just rotate the inner text frame, you can not directly edit
a table anchored in this text frame:

D

As soon as you place the cursor in
the table it will be selected – no
editing is possible in a rotated
table:7

Heading area is oriented normally

Footing area is oriented normally
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Handling master pages
Assign master pages automatically
FrameMaker allows to assign master pages depending on one
or more paragraph formats on a page.
This is handy for automatic assignment of rotated pages for
large tables.
Note:

The triggering paragraph can not be within a nested text
frame (within an anchored frame) or a table. Hence the only
reasonable trigger for rotating tables is the tag of an anchor
paragraph.

Master page mapping table
If this table does not exist, it will be created by Format >
Page Layout > Apply Master Pages … The mapping table will
appear on reference page MasterPageMaps and has this
appearance:
UnstructMasterPageMaps
Book Update (Yes or No): Yes

Paragraph Tag
Name

Right-Handed Master Left-Handed Master
Page (or Single-Sided Page
Master Page)

Range Indicator (Sin- Comments
gle, Span pages, Until
changed)

dtr-doctitle-right

Title

Single

The first chapter page

zi-imprint

Last

Single

No header/footer

rt-rotate-table

Rotated-right

Span pages

Wide multi-page tables

Rotated-left

Having set up the table on the reference page,
1 When you are done, choose View > Body Pages.
2 Make the appropriate document window or book window
active. If a book window is active, select the documents you
want to affect.
3 Choose Format > Page Layout > Apply Master Pages, and
then click Yes to override manually applied master pages.
FrameMaker searches each body page for the first occurrence
of any paragraph tag specified in the Master Page Maps table.
When it finds text containing the specified paragraph tag, it
applies the specified master page.

Range indicators
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Single

to apply the master page only to the body
page on which each paragraph tag appears

Span pages

Master pages are applied to the entire span
of pages to which the paragraph tag is
applied.

Until changed

Master pages are applied to all pages, until
the next body page with a different paragraph tag listed in the mapping table is
encountered.

Blank

Equivalent to Single.

Handling master pages

Reorder master pages
To reorder custom master pages [Help]:
1 Open a master page, and then choose Format > Page Layout > Reorder Custom Master Pages.
2 Select a master page in the Custom Master Pages list, and
move them with the Move Up or Move Down button.
2011-05-11

3 Repeat step 2 as often as necessary to achieve the order
you want.
4 Click Set. If you were previously viewing a custom master
page, note that a different master page may now be visible.

Different pages sizes
For large tables or large pictures (think of a panorama) you
want to have a different page size amidst a document.
You can not set up master pages of different page sizes.
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If you need different page sizes within a document, you may
split the document into various files. Sub-documents may
have different pages sizes.

1

2

3

document-a.fm

4

5

6

document-b.fm

7

8

9

10

document-c.fm

The files of such a construct are put together in a FrameMaker book, which allows for proper numbering.

Printing

For printing the parts must be printed separately, probably
on different printer hardware.

PDF creation

When creating a PDF form this FM-book you get the large
pages cropped, because the page size is part of the PDF setup.

D

If you explicitly specify the large page size then the smaller
parts are placed on large paper.
Hence also for the PDF generation you need to create separate
parts, which can be combined to a single PDF with Acrobat.
However, when printing this combined PDF as a whole the
larger parts are reduced to fit or cropped etc. depending on
your set up.
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Graphics

Overview
FrameMaker provides a set of graphic tools which
are sufficient for most purposes in technical texts.
For sophisticated applications, such as marketing
brochures, these tools are not sufficient and imported graphics are used. FrameMaker support a
great number of graphic formats.
The graphic tools of FrameMaker were not developed further at the point when specialised applications became available even on UNIX.
For diagrams D+DD provide clip-art of high precision (both scales and grids).

Contents
Importing graphics ................................................. 2
Figures in FrameMaker ............................................ 9
Large pictures ...................................................... 11
Graphics with FrameMaker tools ............................ 12
Graphic elements on reference pages ..................... 26
Arbitrary guiding lines .......................................... 27
3D - objects ......................................................... 28
Flash objects ........................................................ 29

Graphics

Importing graphics
The kind of graphic formats FrameMaker can handle depends
on the installation of the filters.

Supported graphic formats
Vector data formats

The following filters for vector data are available in a complete installation of FrameMaker:

Autocad drawings

Both DWG and DXF files can be imported. Be aware that such
drawings may be very large and hence scaled down to a black
blob. It is also common that such files will have very thin
lines after imported due to the scaling.
Normally it is necessary to prepare CAD drawings in the CAD
application.

Computer Graphics
Metafile
Corel Draw
Encapsulated PostScript

CGM files can be imported properly.
FrameMaker can import CDR graphics only up to version 7.
Corel Draw 8 files create a filter error.
EPS is an outdated format. It may be black and white as well
as full colour. FrameMaker handles PDF much better than EPS.
If no preview image is included in the file, FrameMaker displays a gray box of appropriate size. To see the image, you
need to print on a PostScript printer or create a PDF.
On a non-PostScript printer you will get only the preview
image (if present) which in most cases is of very low resolution. FM looks only for the colour definitions into the EPS.

Frame Vector

HP Graphics Language
Micrografx Drawing

FMV is a FrameMaker internal formats which is created on
request (File > Preferences > General: Save FrameImage
with imported graphic) when documents containing copied
(not referenced) images are saved. How the picture itself can
be saved is unclear.
HPGL is sometimes used by CAD applications as output for
specific HP printers.
Some DRW files create filter errors.

Portable Document
Format (PDF)

PDF is supported better than eps. From a multi page PDF you
can import any selectable page. See Preparing PDF on
page 6-5.

Scalable Vector
Graphics

SVG is especially designed for the web. In FM8 it seems to be
imported correctly.

Windows MetaFile
Word Perfect Graphics

WMF may contain both vector and raster data. EMF (Enhanced
Metafile) is also imported correctly in FM8..
WPG files are meta files and may contain both vectors and
bitaps.

Raster data
CCITT G4

6–2

This is a FAX file format and can be generated by a FAX driver
or received via FAX software. It is only black and white. FM8
reads G4 files without error, but the image is just a gray area.

Importing graphics

2011-05-11

Device Independent
Bitmap

The format DIB exists only on Windows. It contains information about its original size and resolution. This format is
widely used for screen shots.

Frame Image

FRMI is a FrameMaker internal format which is created on
request (File > Preferences > General) when documents containing copied (not referenced) images are saved. How the picture itself can be saved is unclear.

GEM Raster

GEM raster – also known as IMG – is from Digital Research, for
example used by DR Paint or Publishers Paintbrush. GEM
stands for Graphical Environment Manager.

Graphic Interchange
Format

GIF is a proprietary format13). It uses at most 256 indexed colours and may carry transparency. GIF is not an adequate format for photographs.

IBM PC Paintbrush

PCX files are very old and specific for DOS and Windows.
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JPEG

J-peg compression is lossy. You may set the compression to
none. JPEG was developed for photographs. It is not a good
choice for images with coloured areas (illustrations).

JP2, J2K, JP2

Lossy and lossless Jpeg 2000 raster image. JPC is JPEG 2000
compressed. JPX is JPEG eXtended. Raster image in JPEG 2000
format with proprietary extensions

MacPaint

This raster format MAC supports full colour. As the name suggests, it was native to the Macintosh environment.

Photoshop

PSD and PTS are recognised file types, PHO files can not be
handled.

Portable Network
Graphics

PNG is a non proprietary format supporting transparency. It
was developed for the Web. For two problems with format see
Huge number of colours and Image in PDF cropped on page A-24.

Quickdraw Pict

PCT files have their roots on the Macintosh.

Sun Raster

RAS exists on Unix systems of Sun, but can also be read on
Windows.

Tagged Image Format

FrameMaker can handle both uncompressed and compressed
TIFF (with LZW). Most flavours of TIFF (black and white, greyscale, colour) are supported by FrameMaker.

Windows Bitmap

BMP is Microsoft-proprietary raster image file format. It uses 3
bytes per pixel to contain the full range of colours. Hence the
files are huge.

x-Windows Dump

XWD files are native to UNIX, but can also be read on Windows.
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ZSoft PCX

PCX files are created by the programs of the ZSoft Paintbrush
family.

Animations

From these files only a placeholder is displayed in the FM document. In a generated PDF their life is back.
U3D

Universal 3D. A vector image format for 3D images which can
be ported to PDF. In the PDF the rendered object can be
zoomed, move, turned etc. See 3D - objects on page 6-28.

MOV

Quicktime movie.

SWF

Adobe Flash. See Flash objects on page 6-29

13 Developed by CompuServe, another company (UNISYS) claimed patent
rights during 2000 or so. At least since 2003 the patents are free.

6–3

Graphics

Recommended graphic format
Recommended formats are highlighted in bold. Use formats
in the shaded area only for web-graphics.
Nature of image
Options

Note:

Photograph

Line drawing

Drawing with
coloured areas
(screenshots)

No compression

jpg, pdf, tif

eps, pdf, svg

eps, pdf, svg

Lossless compression

jpg, jp2, gif, png

gif, png, tif

gif, png, tif

Lossy compression

jpg, png

-jpg, jp2

-jpg, jp2

png graphics with 8bit pixel depth (256 indexed colours) will fill
the colour catalogue with a huge number of colours named RGB
xxx,xxx,xxx Although you can eleminate these definitions by
“MIF washing”, these colours are back after opening the file
again… Hence always use “full colour”, “Millions of colours” or
the like (problem solved in FM-9).

Preparing graphics for import
It is good practice to leave out legends and other text or figures from the graphic. This can be overlayed in the FM document and consistent size of a font is not a problem at all. If
the document must be translated, text within graphics would
require that the translator must work in the graphics application.

RGB or CMYK

On a television monitor or a computer terminal you coloured
light is mixed to create a distinct shade of a colour. The colours are red, green and blue (RGB). Black is complete absence
of any colour and white is the the mixture of the maximum
value of these colours. Colours are mixed by adding: green +
red = yellow; blue + red = magenta.
When printing the colours are reflective. A colour appearing
yellow absorbs all but the yellow colour from the white light
shining on the object. If an object reflects all light, it appears
to be white, if it does not reflect any light it appears black. To
create any colour the base colours are cyan, yellow and
magenta. Since mixing all together even in maximum saturation does not create a relly black impression, black is printed
as a fourth colour. Hence this colour model is called CMYK (K
for blacK). Colours are mixed by subtraction: Mixing yellow
and cyan creates a green impression, mixing yellow and
magenta creates a red impression.
Since FrameMaker 8 the creation of a composite PDF is no
more a problem. Before FM 8 output for a print shop needed
to be an already seprated PDF.

Colour fidelity

In all cases the perception of colour depends on the light
emitted by either the screen or shining on the coloured
object. Hence only a so called calibrated environment can
maintina colour consistency during the process from scan/
photographi via screen to print. For technical documentation
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Importing graphics

the colour fidelity is not that important, hence the tools are
not calibrated.

2011-05-11

The conversion between the two colour models is basically a
mathematical process which can be performed in Acrobat.
Certain conditions such as monitor type, paper type or light
colour are considered with colour profiles. These considerations are important for printing catalogues of paintings etc.
but not for technical documentation.

Vector graphics

Vector graphics provide the same quality of lines in all scales.
To maintain a consistent appearance of line thicknesses and
font sizes it is good practice to create the graphics in the size
they are needed in the documet (or in double size).

Preparing PDF

A PDF may serve as a grapics library, since FrameMaker can
import each page separately. Each of these pages can be of
different size too. The onsceen presentation scales nicely.
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PDF does not contain a bounding box, but a document size
per page. Hence it may be useful to crop a large page to a
small image on it (e.g. in Acrobat), before importing in FM.
Since cropping does not reduce the file size (everything is still
there), it may be useful (especially for CAD drawings) to edit
the PDF in Illustrator or an equivalent. For example, copy the
relevant part into a new document and create a PDF from it.

Images

Images are graphics where every picture element (pixel) may
have a different colour. It can easily be understood that a
slanted straigt line always will contain steps, even in high resolution images. For technical pictures distinction of elements
is key and edges of objects must not be blurred.
This leads to the demand of a certain resolution for a given
size in the document. It is also essential not to use very lossy
compression (< 20%) for technical pictures. For pictures of
natural object the compression can be much higher (< 70%)
whithout loosing too much image quality.
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Compression versus
quality

In Photoshop the compression can not be set directly. The
quality of the image is set in steps 0 to 12 (0: lowest quality,
highest compression). In other programs you can set a compression factor numerically.
Since data from digital cameras are already compressed
(except if you take RAW data), you should not apply further
compression to a picture to be saved after cropping etc. Use
“original quality” or “no compression” to save such an image
in jpg or jp2 (Jpeg 2000).

Avoid hidden
operations

6–5

To avoid additional (hidden) operations on images it is good
practice to prepare them outside of FrameMaker in the disired
size (e.g. 50×100mm, 150dpi). Always keep a copy of the original picture. The resolution of the image is only relevant for
printing, not for online display. Keep is between 150 and 300
dpi to allow for single-source-publishing.

Graphics

Problems with imported graphics
To resolve problems with imported graphics, check this:
p Do you have the proper filter (input interpreter) installed?
p Does the file conform to the ‘de facto standard’ pertinent
to the file format (there are various flavours of DXF, WMF,
TIFF, etc. around)?
p May the file be corrupted (for example, by a download)?
p Can you get a different format from the source?

Importing graphics
FrameMaker can copy or reference graphics not only on the
local computer (including its network), but also from the
Internet by specifying an URL (http://sample.com/
image.jpg).
To import a graphic:

p Place the cursor where you want the graphic to appear.
p File > Import > File
p Look for the path and the desired graphic and choose
Import by Reference.
p Click Import.
p If FrameMaker can not determine the graphics format and
hence can not select an appropriate graphics import filter,
the Unknown File type dialogue is displayed.
Select the appropriate file type and import the file with
Convert.
The list in the dialogue provides a mixture of file type names
(e.g. Portable Network Graphics) and file extension (e.g.
HPGL).

Note:

If you have not installed all filters, you might not find the
appropriate file type in the list - in this case you need to convert the file in a graphics application.

Importing raster graphics
p If you have selected a bitmap graphic, set up the resolution
for the desired size (dialogue Import Graphics Scaling).
p To Fit in Selected Rectangle a rectangle must be selected,
not a graphic frame or the anchored frame! The rectangle
will be replaced by the graphic.
p For all other selections an anchored frame containing the
graphic will be inserted with the following properties:
-

Placement Below current Line, centred
Centred
Cropped (if the image is too large, it will be cropped)
Margins of 1/12" = 6 pt (2.12 mm) around the image

Note: These defaults can be changed to something more useful
only with a special plug-in.
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Importing graphics

Importing vector
graphics

p If you have selected a vector graphic, the graphic will be
imported directly into an anchored frame (with the same
properties as for a raster graphic).
p When importing an SVG (Scalable Vector Graphic), the
Unknown Filetype dialogue is presented, even though
FrameMaker has recognised the correct format. Confirm
with Convert. For SVG you get an additional dialogue:
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p In Import SVG
-

-

Import graphic into
frame

either set the desired DPI raster quality in the drop
down list. The current DPI for the graphic is displayed as
default.
or set the specific dimensions from the drop down lists
SVG width and SVG height. This may distort the image.

When you import a raster graphic into a selected (anchored)
frame, you may need to calculate a fitting resolution. In Custom dpi the last used value is provided, not a newly calculated value.
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Referenced versus copied graphics
If you import images directly into the document by copy (not
by reference) or simply use the paste command to place the
images into frames, the file size of the document is increased
signifacntly, because two objects are inserted:
-

The imported image in its native format (e.g. png or tif)
A frame internal object, FrameVector or FrameImage.

The Frame internal format is not compressed and hence may
be huge compared to the imported image file.
With a special setup in maker.ini the enlargement may be
reduced, but not completely prevented. See Reduce impact of
import by copy on page C-20

Printing coloured images

D

When printing coloured images on a standard laser printer or
other black-and-white printer you get different results due to





Preserve colour in PDF

different mapping of colours to gray scale
different printer resolutions
different types of printers
This is also true for PostScript printers.

If you do not have a colour PostScript printer and want to create colourful PDFs, you must use the printer driver of Acrobat
Distiller (FIle > Printer Setup and select Acrobat Distiller) 14).

Note:

Adobe recommends to always use the Distiller Printer for PDF.

14 Printing a PostScript file and then distilling is the method until FM 6 and
Acrobat 5. With later versions you can Save as PDF which automatically
uses the Distiller Printer (since Acrobat 6 called Adobe PDF).
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Scaling objects
p Change the size and position of a selected graphic with the
mouse (hold down the SHIFT key to constrain to proportional scaling).
-

You see the current width and heights in the status bar
on the bottom left corner of the document window.
If View > Rulers is set, current width and height are indicated on the ruler, for example the top ruler

p Use Graphic > Object Properties for proportional scaling
in percent (Scaling > Percent, click Set)
p You can also set the dimensions (and position) explicitly in
this dialogue.
p To change the resolution (DPI) of a bit mapped graphic, use
Graphic > Object Properties and use the Set DPI button. A
higher resolution will reduce the image size, a lower resolution will increase the image size.
Note: This function is not available after scaling with the
mouse.
See also Scale an object on page 6-18.
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Figures in FrameMaker

Figures in FrameMaker
See also Figures with legends on page B-19.

Anchored frame with title paragraph
2011-05-11

There is no title attribute for anchored frames. You place the
figure title in a separate paragraph before or after the
anchored frame.
If you want to have the title above the figure you use this paragraph as anchoring paragraph.
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Title above frame

Figure 1: Frame is with border to see its extent. The anchor for the
frame is here 7.

Space below for the title paragraph is not used for the distance to the frame, but placed below the frame.Hence you
may wish to place the graphic within the frame with a top
margin.
Do not set the Floating flag for the anchored frame. If this flag
is set, the frame will be separated from the anchor paragraph
if space below the paragraph is to small for the frame.

Title below frame

In this case it is good practice to define an empty paragraph
for the anchor, for example fa-figure-anchor with a small
line spacing. In the example hereafter some text makes this
paragraph visible.

D

7 this is the anchor paragraph - with the anchor at the beginning of the line.

Figure 2: Panorama to the south seen from Sattel in kanton Schwyz,
location Unterlutzi.

To keep the title together with the frame (anchor) define Keep
with Previous Pgf in the pagination properties of the title.
For the distance between frame and figure title:
 either define Space Below Pgf for the anchoring ¶,
 or define Space Above Pgf for the title paragraph.
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Figure in table
Placing figures in tabes provides great flexibility with respect
to background, framing, titles and legends.
 Place the image in an anchored frame.
 Place the anchored frame in a table cell, anchored at a paragraph with run-in property (otherwise you get additional
room at the top of the cell).
 Define cell margins according to the needs.

Setting up a figure table

The table figure-table is set up with just one cell and the following properties:
Cell margins

all 0

Alignment

left

Start

anywhere

Title position

below table

Ruling

none

Shading

none

The paragraph format to display the area of the table (shaded
in the sample below) in the cell is body. It is used only to
place the anchor. The paragraph format for the table title is
fn-fig-heading-numbered.

Using the figure table

After inserting the image (with File > Import > File) you need
to adjust the properties of the anchored frame for...
7The format of this paragraph (body) should have 0 values
for all items in the Tab “Table Cell”. Otherwise you get additional space around the anchored frame (normally without
border).
Based on this method you may wish to use a 3-column table:
Column1 = width of side head area; column 2: gap between
side head and main text; column 3: as wide as the text area.

Figure 3: The eye of a model (created by an artist, no photo).

Anchoring type = Run into Paragraph; Alignment = Left
You may also wish to change the properties of the image to...
Top left position = 0 and adjust the size of the anchored
frame manually...
You may wish to speed up your work by copying and pasting
prepared tables and then replacing the images.
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Large pictures

Large pictures
Pictures may be larger than the text frame. It may also be necessary that they ‘bleed’, that is, run over the paper size. A
special case are pictures running over two facing pages.
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It is always possible to place a picture ‘directly on the paper’,
that is, not in an anchored frame:

Froschkönig

Daß ihm das passieren
musste!
Öfter als sonst
verkroch er sich von
nun an in die
brunnenkresse und
sinnierte über den
kleinen grünen
steinfresser.

Der froschkönig war es
nun endgültig leid,
noch länger auf die
prinzessin zu warten.
Ärgerlich hüpfte er
vom brunnenrand,
zumal eine dicke fliege
sein interesse weckte.
Übel hatte ihm die
prinzessin mitgespielt!
-6-

-81 Create a master page named empty which does not contain
a text frame. In the dialogue Add Master page … select
Empty for Initial Page Layout.
2 Insert a disconnected page (Special > Add Disconnected
Pages …) at the desired location and apply the master page
empty to this page.
3 The text flow runs around this page.
4 This disconnected page stays on its location (e.g. page 8 in
the file) if text is added or removed before this page.

Picture across facing pages

D

Since all objects are cropped at the paper edges, you need to
place a picture extending over facing pages twice.
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Der froschkönig war es
nun endgültig leid,
noch länger auf die
prinzessin zu warten.
Ärgerlich hüpfte er

Daß ihm das passieren
musste!
Öfter als sonst
verkroch er sich von
nun an in die brunnen-

vom brunnenrand,
zumal eine dicke fliege
sein interesse weckte.
Übel hatte ihm die
prinzessin mitgespielt!

kresse und sinnierte
über den kleinen
grünen steinfresser.

Text
frames autocennected.
Graphic
frames

Graphics

Graphics with FrameMaker tools
Many technical drawings, schemes etc. can be done completely with FrameMaker tools:
Data

1 1 0 1 0 0 0 1 0 1 1 1 1 1 0 1

Clock

Frame
line active
Signal

line idle
9-bit delimiter

useful frame data

8-bit check sequence
end delimiter

Select graphic elements
Normally you just click with the cursor on a graphic element
to select it. To select more than one element (e.g. for grouping) use SHIFT+click for the second to nth element.
In rare cases it may be necessary to CTRL+click on the first
element. Be aware that moving the mouse during the click will
create a copy of the element, not just select it!
For special operations the following ESC sequences may be
useful:
Function

Key-seq.

Select the first graphic element (on the page)

ESC, o, F

Select the next drawn object (may be a group)

ESC, o, n

Expand the object selection (add objects to selection)

ESC, o, e

Tool bars for graphic work

Prepare the environment
Defaults for these
properties can be
defined in the file
maker.ini (see Set
reasonable defaults for
your work on page A-31)

 Set a reasonable grid spacing (e.g. 0.1 cm) in View >
Options
 Set Graphics > Snap (
work.

) to activate the grid for your

 With Graphics > Gravity (
) set on, an object attracts
the pointer (cursor) as you draw, resize or reshape a nearby
object. Gravity has no effect to moved objects. The gravity
is a property of the contour and the corners of an object.
Its ‘range’ does not depend on the zoom level.
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Graphic objects

2011-05-11

The graphics palette defines graphic objects as well as properties for graphic objects. You may set the properties before
you create an object or apply the properties to selected
objects.

Intelligent cursor (depending on object)
Line
Open polygon
Rectangle
Circle, ellipse

Text frame

Cursor for graphic objects
Arc (circle, ellipse)
Freehand-line, spline
Rectangle with rounded corners
Closed polygon
Text line

Graphic frame
Define area fill pattern

Apply area fill pattern

Define line fill patten

Apply line fill pattern
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Define line width
Define line-end type
Define line type
Define colour
Define tint
Define overprint type

Apply line width
Apply line-end type
Apply line type
Apply colour
Apply tint
Apply overprint type

Procedures
Define line width

Clicking th button Define Line Width (
) opens a dialogue,
in which you can select the already defined widhts. The
selected width is then indicated in the right (
) apply button
in pts.
To apply a line width to an object, you click on the Apply button.

D

To define line widths select Set… in the dialogue Line Width
and enter the desired values. If no unit (e.g. mm) is provided,
pts are assumed:

At Set the units are converted to pts for (rounded) display in
the Apply button.
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Define line ends

Clicking th button Define Line Ends (
) opens a dialogue, in
which you can select the already defined styles. The selected
style is then indicated in the right (
) apply button.
To apply a line style to an object, you click on the Apply button.
To define a line style select Set… in the dialogue Line Ends
and select the desired style. :

The Cap Style influences the appearance at large line widths.
In these cases you may set the Round option.
For defining a custom style see To define a blob line tip on
page 6-21.

Define line type

Clicking th button Define Line Type (
) opens a dialogue,
in which you can select the already defined styles. The
selected style is then indicated in the right (
) apply button.
To apply a line style to an object, you click on the Apply button.
To define a line style select Set… in the dialogue Dashed Line
Options and select the desired style:

The pattern of line/gap groups and names of the styles is
defined in the maker.ini file. See Dash patterns on page A-31.
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Set numeric values for
object properties

Tint or fill pattern

Overprint

Angle

Border/line w.

Scaling

dpi

File

Facet

x

x

x

x

x

x

x

x

x

x

Graphic object (ellipse, polygon etc.)

-

x

x

x

x

x

x

x

Anchored frame

x

x

x

x

x

x

x

x

Graphic frame

-

x

x

x

x

x

x

x

Text frame

-

x

x

x

x

x

x

x

Graphic frame on
reference page

-

x

x

x

x

x

x

x

x

x

Name

Colour

x

Column prop.

Location

-

Flow settings

Size

Imported graphic

Object type

Pick up properties
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Object attribute.
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To set numeric values (e.g. for position, height, width), use
Graphics > Object Properties or button
. Which properties can be set depend on the object:

x

To pick up properties from an object and transfer it to the
properties in the graphics palette, select the source object
and enter ESC, g, O (letter O).15)

Group and ungroup items

Use Graphics > Group to group various selected
items.
Use Graphics > Ungroup to ungroup selected
items. You can ungroup as long as the button is not
greyed.
It is good practice to group all objects in a frame to avoid
accidentally moving them. Do not just group the whole bunch
of objects, but set up subgroups which belong together etc.

Align objects

Select the objects to be aligned first and set the ‘master’ with
the last selection. Then apply Graphics > Align to get a dialogue to specify the desired alignment or use the appropriate
buttons
.

D

If you have only object selected for alignment, it will be
aligned on its container (e.g. anchored frame).

Move objects by small
increments

At zoom factor 100% these buttons (or ALT+arrow) move the
selected object (characters, graphic object) by 1 pt at 100%. At
a zoom factor of 253% the nudge is 0.1mm.
SHIFT+ALT+arrow moves by 6 nudges

Distribute objects

16)

With Graphics > Distribute or button you get a
dialogue to specify the distribution (horizontal/
vertical, equidistant centred/edges, specific edge
gap).

15 With Shalom Perets’ Express Customisation Kit installed you get this
function on the context-menu (right click).
16 Attention. SHIFT+ALT may switch the Windows Locale!
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Define visibility

Move selected items to the front or back of other
objects with Graphics > Bring to Front / Send to
Back.

Connect lines

Gravity ON: Lines with reasonably close end points
can be combined to one object with Graphics >
Join. Drawing new elements close to existing ones
snaps the new element to the existing one.

Modify shapes

Depending on the selected graphic the function
Graphics > Reshape does:
 Convert an arc from 1/4 circle or 1/4 ellipse to any angle.
Use Graphics > Object Properties to set the value numerically.
 Activate the handles of a polyline, polygon or spline to be
able to:

polyline

control point

handle point

-

smoothed = spline

-

reshape the polyline or spline by dragging a handle
(square).
reshape the curvature by dragging a control point
(round).
add a handle point by control-clicking on the line.
remove a handle by control-clicking on the handle.

 Change the number of sides for regular polygons.

Regular polygons

To create regular polygons (3 … n), start with a circle, ellipse,
square or rectangle and reshape it to an arbitrary number of
sides with Graphics > Set # Sides. You may also set the angle
of the base line.

Freehand lines

Use the polygon tool from the tools palette to set up the skeleton of a line (polyline).
With Graphic > Smooth convert it to a smooth line.
For adjusting the shape it may be useful to get the
polygon again with Graphic > Unsmooth.
Watch the different positions of the handle points in polygon
mode and smooth mode (see figure above).

Move objects by small
amounts

To move selected objects use ALT+arrow or the buttons
depicting helicopters. The amount moved depends on the
zoom factor. At 100% you move by 1 DTP-point17) (with
ALT+SHIFT+arrow18) 6 DTP-points). Set the zoom factor to
353 to move 0.1mm per nudge with ALT-arrow.

Rotate objects

With these buttons you rotate the object by the
amount defined in View > Options > Snap: Rotate
(e.g. 15°). Using Graphics > Rotate allows you to
define any angle. Cells in a table are rotated b y 90°
increments only.
17 1 DTP point = 1/72 inch = 0.3528 mm
18 Since the left ALT+SHIFT is the toggle between input locales in Windows
you may end up with a different keyboard setting, for example typing z
inserts a y. Check Control Panel > Regional Options > Input Locales. If
there is more than one entry, you may encounter this problem …
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With the mouse you can rotate an object also: use ALT while
you move a handle (the cursor arrow gets an additional small
double arrow to indicate the function). Watch the rotation
angle in the status bar.

2011-05-11

Flip upside-down and
right-left

Use Graphics > Flip Up/Down or Flip Left/Right
for this action.

Mirror objects

To mirror an object create a duplicate and flip this duplicate
to your needs.

Measuring things

Measure any object or any distance on the page by drawing a
selection rectangle either around the object(s) or around the
space you want to measure.
Hold down CTRL+SHIFT at the beginning to assure nothing is
selected.

object 1

selection
rectangle

object 2

Measuring objects

To measure an object, simply select it and get the properties
with Graphics > Object Properties. For example for object 2
in the diagram above you get:

Alignment and snap
details

The properties width and height of graphic object are measured in the middle of the contour line (skeleton). Hence alignment and snap appear on this virtual line:

D
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You see the width and heights in the units of the document of
the selection rectangle to bottom left of the status area:

Object handles

Apply current line style
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If you have defined a line style (colour, pen width)
you can use the buttons to apply either a solid or a
dashed line to the selected object.

Graphics

Scale an object

Graphics > Scale … or the button lets you scale
any graphics object. Either Scale proportionally or
set the dimensions explicitly:

You can also use Graphics > Object Properties to scale or
resize an object. There you have the option to scale by setting
a resolution (dpi) for pixel images (see Scaling objects on
page 6-8).

Set object attributes

Object attributes are used in special export situations for
anchored frames (Object Properties > Object Attributes):
Alternate text

This is exported only from structured documents to HTML, XML, SGML and tagged PDF.
It is displayed in the same sense as ALT
text in HTML.

Actual text

This is exported only to tagged PDF. The
information is intended for Screen Readers
to describe the contents of the anchored
frame. See Tags on page 10-6.

Attributes

With Add new attributes are specified
according to the definition in Name and
Definition.
A selected attribute name can be Edited
with Change or removed from the list of
Defined Attributes with Delete.

Use Set to assign the settings to the anchored frame.
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Tracing a graphic
If it becomes necessary to make changes to a graphic, but it is
only available as a bit map you may want to trace the graphic
(rebuild it with the FrameMaker graphic tools). Of course the
method described here can also be performed in a graphic
applicattion, such as Adobe Illustrator.
2011-05-11

1 Insert an anchored frame where you want to place the
graphic.
2 Click outside the text frame and import the graphic. The
graphic will appear “on the paper”, not within the frame.
3 To move and/or scale the graphic keep it selected. If it is
unselected by some reason, open a selection rectangle
(drag the mouse) starting outside the text frame.
4 Select the anchored frame and rebuild the graphic. Since
the background graphic is not within the frame you will
not accidently select it. To distinguish the new graphic
from the background you may wish to use a colour (which
you change eventually).
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5 Finally remove the background graphic and adjust the new
graphic.
This trace is not yet complete. The new drawing uses snap.

Replacing image logo
D

Logos are mostly placed on master pages to appear on every
body page. To be able to distribute the template to other
branches of a company the graphic is not referenced, but copied into the file. Sometimes multiple master pages are used.
Together this leads to huge template files. (see Referenced versus copied graphics on page 6-7).
To reduce the file size drastically, the following method can
be used:
1 If the logo contains text, ask the graphic artist for the
specifaction and replace the graphic-text with real text in
the appropriate font.
2 If the logo contains a drawing, replace the bit map with a
traced image.
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Example logo

The ‘original file’ is used here in a resolution of 128 dpi which
gives a width of about 66mm.

Although this png is only 5.3 kB in size, a FrameMaker file
increases its size by 65 kB when this graphic is imported by
copy. Assume 6 master pages with this logo: the file size
encreases by 0.4 MB. Well, on disk this is not an issue, but if
you send some documents with this by e-mail …

Analysis and rebuild of
the logo

 The background colour is a light grey (RGB 75/75/75 %)
 The scripts seems to be an elongated version of Arial or
Arial bold. This can be found with overlaying the logo with
a text line and using a character format to play with.
 With some experimenting it turns out that the script uses
(in the used size, not the original logo file) 27.5pt Arial
bold with 148% spread:

deleatur
 For tracing the image use a closed polygon and smooth it.
To get the shape use as few as possible anchor points and
then tweek the spline handles. Use a very large zoom factor
and a very small pen size for this work.

Doing this work in a separate FM document with a large
logo image gives better results and makes work easier.
 Put together the graphic looks similar to the original:

deleatur
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Special graphic objects
Rectangles with rounded
corners
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To change the radius of the corner with Graphics >
Object Properties or the button.

Special arrow tips

To point to elements in photographs etc. you might want to
have some blob at the end of a line - not an arrow pointing to
the element.

To define a blob line tip

p Open the graphic tools palette
p Click on the Arrow tool and select Set…
p In the dialogue Line End Options
-

Activate the Custom option
Enter the values 135, 45 and 8pt into the value fields.
Click Set.

p From now on your arrows will be rhomboid blobs as displayed here
for a line with double arrows.

Note:

Iconic images within text

These special arrow settings disappear at the end of your
FrameMaker session, they can not be saved.
In line icons (e.g.
)are placed in an anchored frame At
Insertion Point with some negative “Distance above Baseline”. To get the frame just around the image (with no margin), use the function Shrink Wrap Equation (ESC, m, p).

D

You select the frame by clicking on the border and select the
image by clicking in the middle of this ‘icon’.
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Border and Fill patterns
The colour (or pen pattern) of the border and the colour (or
fill pattern) of the interior area of an object can only be the
same.
The fill patterns and pen patterns are a reminiscence from
the early FrameMaker times, whereas colour and tint are
newer concepts.
 To apply real colour (and tint) you need to select the fill
pattern black (pattern 0)
 To leave the object transparent, select the fill pattern
None.
Colour
Tint

pattern 7
pattern 0

There is only limited use of the other patterns provided. This
example uses pattern 9 on a 2mm wide line.

Colours
With the button Set Colour you open the list of defined colours (
). the selection then is filled into the Apply button to
the right ( ).
FrameMaker 8 provides 16 predefined colours (FM 7 only the
first 8). In the picture these are framed:

To get the rest
of the colours,
drag the small
triangle downwards.
More colours and special gray levels are defined with View >
Colour > Definitions… A number of colour libraries (e.g. Pantone) are available.
For example, to define a colour needed for guiding lines,
specify a strangely looking colour and name it GuidingLine.
This colour will be listed in the Table Designer > Shading
and in the Graphic Tools palette:
For commercial printing (offset) and special colour combinations you may want to define whether the colour should be
overprinted or knocked out.

Overprint versus
Knock Out

When one colour object overlaps another, FrameMaker normally knocks out the overlapped portion so that it does not
print in a color separation. This requires accurate registration, that is positioning of the two separations.

Overprint
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Knocked out (with bad registration)
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To avoid gaps (blinks) between the contours of the two
objects, you can select Overprint in the dialogue of the button Define Overprint Type (
) for the upper object. The
selected method is applied to any object with the Apply button to the right ( ).
The overprint method can also be used to combine light colours: the lower shines through the upper. This effect, however can not be seen in FrameMaker on the screen and not on
an office laser printer which does not use separations,
although different colours are applied.

Shading

Shading is the process of applying tint to a colour. Be aware
of the fact, that a tint of 10% applied to a color which is
defined as 40% black results as 4% black!
With button Define Tint (
) you open a dialogue from which
you can select the desired value which then is listed in the
right Apply button. With the Apply button ( ) the tint is
applied to the selected object.
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You can define other values then listed, by selecting Other…
and entering a value (no decimals are possible):

Table Designer > Shading > Fill provides only a limited set
of shades (tints). For arbitrary shading use 100% fill in the
table and a defined colour (e.g. 40% black).

Clip art
FrameMaker comes with a set of clip art, which may be useful.
These drawings are all done with FrameMaker tools. Hence
you can modify them within FrameMaker.

D

Example clips

In FrameMaker > 6.0 there is no mention of the clip art files in
Help or in the manual 19). The files, however, are still there:

19 With Microtype’s customisation kit you get access back in the
type menu.
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The names of the clip art files in $FMHOME/clipart give a hint
about their contents:
arrows.fm
balloons.fm
clipart.book
dingbats.fm
electronic.fm

Own clip art

flowchart.fm
hardware.fm
icons.fm
maps.fm
officelayout.fm

people.fm
symbols.fm
transport.fm

It may be a good idea to collect arbitrary shapes for your
projects also in the clip-art library. Just set up appropriate
FrameMaker documents (carefully select the name of the file)
and put it into the clip art directory.
If you use only a limited set of clip art elements you may look
at the plug-in AutoText (see Extensions by API clients on
page 1-21).

Clip art for diagrams
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If you want to draw scales and diagrams in FrameMaker, you
may benefit from www.daube.ch/docu/fmaker09.html. An
example using logarithmic scales can be seen at Arbitrary
guiding lines on page 6-27.
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Importing from other applications
See also Importing methods on page C-2.
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Origin

The export function of Origin creates unreliable PostScript
(eps). To fix the problem,
 Export eps from Origin (or less favourable emf)
 Import this eps to Adobe Illustrator (or probably Macromedia Freehand)
 Export from Adobe Illustrator a conforming eps.

Excel

To import a graphic from Excel into FrameMaker:
1 In Excel select the graphic (chart)
2 SHIFT-Edit > Copy picture…
3 In the Copy Picture (CTRL+Copy) dialogue select as shown
when printed to get best results

Graphic objects

When you just copy and paste a graphic from another application, you get an embedded object (OLE). If you double-click on
the graphic, the creating application is opened.
Do not use this method for documents you distribute.
Arbeitsbereich

Positionsmessgerät

A

0

B

1

0

C

0

1

Arbeitsseite

Ballenvorlage

THEVISION
SHIELD

Updates to such files may fail with “Cannot invoke OLE
server”, because you may not have the specific application on
your machine. It is not possible to find out in FrameMaker
with which application the graphic was created.

D
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4 In FrameMaker use Edit > Paste Special… and select wmf.
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Graphic elements on reference pages
Graphic elements on the reference pages can be used for
 Frame above or below a paragraph
 Copy and paste to any location in the document on the
body pages.
Note:

General elements

Although the source of the graphic is a reference page, the
placed graphics are real copies, not referenced graphics.
The following elements are always present in a FrameMaker
(original) template:





To create a graphic
element for a paragraph

Footnote (defining the separator line and space)
Table Footnote (defining the separator line and space)
Single Line (for use in frame above/below)
Double Line (for use in frame above/below)

p Switch to the Reference Pages (View > Reference Pages)
p Create a graphic frame with the corresponding graphic
tool.
p You are requested to enter a name into the dialogue Frame
Name. Provide a name describing the graphic you want to
place into the frame.
p Set the same name atop the frame with the graphic tool
Draw a Text Line. For FrameMaker the text is irrelevant,
but for the human reader it should be equal to the name of
the frame.
p Place the desired graphics into the frame:

meandered line

Note:

The size of the graphic frame defines the white space around
the graphic when it is used above or below a paragraph. If you
will use it for both purposes, centre the graphic vertically.

Defining defaults for the environment
In the file maker.ini a number of defaults can be defined.
Unfortunately arrow tips can not be defined there. Hence any
special definitions are lost at close of the FrameMaker session.
Settings are located in various sections (windows parlance).
See Set reasonable defaults for your work on page A-31.
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Arbitrary guiding lines

Arbitrary guiding lines
For some work both the Snap (to virtual grid) and the Gravity
(snap to adjacent object) is not sufficient. You need arbitrary
guidelines to snap on or to find the desired position.
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1 In View > Color > Define… specify a special colour for
your guidelines, for example Graphic_construction. Use a
colour such as magenta or pink which clearly separates
from the real colours of your drawing.

E:\FM-course\handout\graphics.fm

2 In View > Color > Views… make the colour visible:

3 All your construction and guide lines shall use this colour:

D

4 For printing and saving as PDF hide the guide lines with
View > Color > Views…
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3D - objects
With Adobe PDF version 1.6 (Acrobat 7, released mid 2005) it
became possible to include 3D geometries in PDF documents.
These files must of format U3D (Universal 3-D).
You insert the U3D objects as any graphic into an anchored
frame.
Note:

The object may be cropped by the anchored frame. If done so,
the displayed object will overlap the surroundings in the PDF,
because it is rendered in its inherent size (see Object Properties)
In FrameMaker only the following properties can be set, if the
object is selected (Graphics > 3D Menu):
 Default view (if views are already defined)
 Rendering mode (e.g. wire frame, solid)
 Background colour
 Lighting scheme (such as Bright lights, Head lamp)
When saved as PDF more operations become available in the
object. The U3D objects are preserved in the XML round trip.

Example 3D object

This text will be overlapped by the displayed object in PDF.

This text will be overlapped by the displayed object in PDF:

Setting views

The U3D object you import into a document can contain predefined views. You can change the view set for the object; the
selected view is rendered when the document is saved.
When you convert this FrameMaker document to a PDF, all
predefined views of the U3D object are available in the PDF.
The last view that you selected in the document before saving
becomes the default view in the PDF.
1 Select an U3D object.
2 Select Graphics > 3D Menu > Show Existing Views, and
then choose a view from the list that appears in the dialog
box.
3 Click OK.
The object is displayed (and printed) in the selected view.
Note:
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If you save the document as a PDF, all views of the U3D objects
will be available in the converted document.

Flash objects

Flash objects
You can create documents with SWF files, such as Adobe Captivate® movies. The SWF object is preserved in the XML roundtrip.
When importing Flash objects, the first frame is displayed in
the anchored frame. Very often the graphic is a start button.
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If the first frame is blank, then the anchored frame appears
blank, but you can select the object.:
Display in FrameMaker

The Flash object

During import you can set the object size by defining a resolution. Many flash object (such as this one) include margin in
their presentation and hence do not fill the given space in the
anchored frame completely.

Export to PDF

Flash objects are only exported to PDF if the preferences say
so in File > Preferences > General. If the check box is
checked, then no Flash will be exported to the PDF, only a bitmap image will be there.

Import by reference

Import by copy

Display problem

If the file was imported by reference in FrameMaker, a doubleclick on the image will play the Flash file in a separate Adobe
Flash Player window. The Flash Player however, must be
installed …
If the file was copied into the document, a bitmap image of
the first frame is displayed. Click the frame to activate the
SWF file.

D

If you have the Flash player v10 installed and also Acrobat 7
then you can not start the flash movie. With this Flash player
and Acrobat 8 the display is correct.
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References

Overview
FrameMaker provides a rich set of reference mechanisms: variables, cross-references, footnotes and
markers.
Bibliography is not directly handled by FrameMaker,
but with Endnote the special notions can be generated and integrated into the FrameMaker document.
Hypertext is not handled in this chapter.
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Variables

Variables
 Variables can be set up from building blocks.
 Emphasis can only be introduced with character formats,
not with direct formatting.
Note:

User variables

Because the names of the building blocks of system variables
are localised, you may get problems when changing the UI language during the development of a document (the Running
Heading / Footing definitions in layout are also variables).
This warning applies also to the building blocks of cross-references
 User variables can only contain ordinary text and references to character formats. User variables do not have
access to the building blocks of system variables.
It is, for example, not possible to define a user variable
iso-date with the format yyyy-mm-dd. For such cases you
need to modify the format of an existing system variable
providing the needed information. See Edit system variable
on page 7-3.

Insert a variable

It is, for example, not possible to define a user variable ISOdate with the format <$year>-<$monthnum01><$daynum01>. If you need such variable contents, you must
sacrifice a system variable (for example, a short date).
 Availability of system variables depends on context (body
page, master page). For example, Current Page Number is
available only on master pages.
 Depending on the system variable itself the set of building
blocks differ (you can not set up a file name with date).
To insert a variable:
p Place the cursor at the desired location
p Select Special > Variable...
p Select the variable from the given list in the dialogue.
p Click Insert

Convert a variable to
ordinary text

If you need to abandon a variable in the text and convert it to
ordinary, editable text
p Double click on the variable in the text. This opens the dialogue Variable.
p Click Convert to Text. You are prompted whether you
really want to...

Import variable
definitions from another
document
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Follow the instructions to Import formats from another document on page 3-15. With only the ‘Variables’ box checked.
To import only user variables, import a MIF snippet. See
Import MIF snippets on page A-33. Or use the plug-in ImportFormatSpecial from Carmen Publishing.

Variables

Specifying variable
contents

Set up the contents of your variables to be used as flexible as
possible:
 Avoid plural or inflections.
 Avoid punctuation (this may vary depending on usage)
 Avoid prefixes or suffixes which may narrow the scope.
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Since you can not nest variables, you may need to set up variable building blocks, which are combined with ordinary text
in the document. For example, in the text “The Precision Dosing Pump GP-98ML” there could be two variables:
Product-short
Precision Dosing Pump
Product-type
GP-98ML

Character formats and
Building blocks
Note:
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Line break in variable

Character formats can be used in system- and user variables
and cross-references. The special format <Default ¶ Font>
can be replaced by </>.
Character formats are active only until the end of the variable.
Hence <Default ¶ font> is implicit at the end of the variable.
The sequence \r inserts a line break (hard return).
Real building blocks (see page 4) are only available in system
variables.

Create / edit user
variable

To create a new variable:
p Select Special > Variable...
p Click Create Variable. You will notice that you get the dialogue for user variables. You can not create additional system variables.
p Define the name of the variable. This may contain blanks.
p Set up the contents of the variable from text and emphasis
notations. You do not have access to the building blocks of
system variables.
p Click Add. You may wish to define another variable.
p Click Done to go back to the Insert Variable dialogue.
p Click Done or Insert.
Note:

Edit system variable

If you need access to the building blocks of the system variables, you must edit an existing system variable to serve your
needs.

D

You will need to edit system variables for
 Variables which need access to the building blocks of system variables (see ISO date above).
 Running headers and footers
 Adapt the format of system variables to company standards (for example, the file name in the page footers).
You edit system variables in the same manner as user variables. You just have more choices for the building blocks.
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Building blocks for system variables
The variables are grouped by purpose. You can not use any of
the building blocks in any system-variable. Building blocks
for the japanese calender are not listed.
Purpose

English FrameMaker

German FrameMaker

Current page number

<$curpagenum>

<$AktSeiteNum>

Page count

<$lastpagenum>

<$LetzteSeiteNum>

Volume Number

<$volnum>

<$BandNum>

Chapter Number

<$chapnum>

<$KapNum>

File name with full path

<$fullfilename>

<$DateinameLang>

File name

<$filename>

<$Dateiname>

Current table-page

<$tbssheetnum>

<$TabSeiteNr>

Number of table pages

<$tblsheetcount>

<$TabSeiteZählen>

<$marker1>

<$Marke1>

<$marker2>

<$Marke2>

Text of the paragraph tag

<$paratext[tag]> a b

Number of the paragraph tag

<$paranum[tag]>

Counter value of paragraph tag

<$paranumonly[tag]>

Tagname of paragraph

<$AbsText[AbsTyp]

a b

<$AbsNum[AbsatzTyp]>
a b

<$paratag[paratype]>

a b

<$AbsNumExkl[AbsatzTyp]>
<$AbsTyp[AbsatzTyp]>

a b

Page number of previous paragraph

<$pagenum[tag]>

Name of condition type on page.

<$condtag[hitag,..,lowtag,nomatch]>

<$BedTyp[Typ1,...,Typn,Sonst]>

Seconds

<$second>

<$Sekunde>

Seconds with leading zeros

<$second00>

<$Sekunde00>

Minutes

<$minute>

<$Minute>

Minutes with leading zeros

<$minute00>

<$Minute00>

Hours from 1 to 12

<$hour>

<$Stunde>

Hours 1 - 12 with leading zeros

<$hour01

<$Stunde00>

Hours 1 -24

<$hour24

<$Stunde24>

am or pm

<$ampm>

<$ampm>

AM or PM

<$AMPM>

<$AMPM>

Day number

<$daynum>

<$TagNum>

Day number with leading zeros

<$daynum01>

<$TagNum01>

Day name (full length)

<$dayname>

<$TagName>

Day name abbreviated

<$shortdayname>

<$TagNameKurz>

Month number

<$monthnum>

<$MonatNum>

Month number with leading zeros

<$monthnum01>

<$MonatNum01>

Month name (full length)

<$monthname>

<$MonatName>

Month name abbreviated

<$shortmonthname>

<$MonatNameKurz>

Year with 4 figures

<$year>

<$Jahr>

Year with 2 figures

<$shortyear>

<$JahrKurz>

Character format of the paragraph

<$Default Para Font> or </>

<Absatz Standardschrift>

Character format name

<name>

<name>

a. This refers to the tag-name (paratype) of the paragraph preceeding the one referenced by paratype.
See Cross-reference to subsections on page 8 for usage example.
b. To refer for the last (rather than first) occurrence of a tag name on a page, place +, in front of the tag name.
For example <$paratext(+,lg-glossary)> . This lets you build dictionary-style headers or footers etc.
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Scope of system variables

Scope of system variables
All system- and user variables are available on master pages.
On body pages and reference pages all user variables are
available, but not all system variables:
Body/
Reference

Default definition (english FM)

Current Page #

no

<$curpagenum>

Page Count

yes

<$lastpagenum>

Current Date (Long)

yes

<$daynum> <$monthname> <$year>

Current Date (Short)

yes

<$daynum>/<$monthnum>/<$shortyear>

Creation Date (Long)

yes

<$daynum> <$monthname> <$year> <$hour>:<$minute00> <$ampm>

Creation Date (Short)

yes

<$daynum>/<$monthnum>/<$shortyear>

Filename (Long)

yes

<$daynum> <$monthname> <$year>

Filename (Short)

yes

<$daynum>/<$monthnum>/<$shortyear>

Table Continuation

yes

<$fullfilename>

Table Sheet

yes

<$filename>

Volume Number

yes

(Continued)

Chapter Number

yes

(Sheet <$tblsheetnum> of <$tblsheetcount>)

Running H/F 1

no

<$paratext[Title]>

Running H/F 2

no

<$paratext[Heading1]>

Running H/F 3

no

<$marker1>

Running H/F 4

no

<$marker2>

Running H/F 5 … 12

no

<$paratext[paratag]>

User variable

yes

Building blocks $paranum and $paranumonly
$paranum

This building block delivers the complete numbering, that is
both constant text and counters.

$paranumonly

This building block delivers the text from the first counter to
the last counter, which may include constant text.

D
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System variable
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Numbering scheme

$paranum

$paranumonly

H:<n>.<n>.<n+>< >:

11.9.3:

11.9.3

H:Table <n>.< >< ><n+>:

Table 5.3:

5.3

C:(<n+>< =0>)

(17)

17

C:(<n+>)< =0>

(17)

17)

Cross-references

Cross-references
Restriction

6Cross references from one text flow to another are not possible. You can not have a text flow C on the title page with a
nice chapter number and have it referenced from the layout
pages or the text in flow A.

Source of a reference

 Any paragraph may be the source of a cross-reference.
 In addition, special markers can be set to define a source.
Note:

Cross references to another file contain the file path. Hence the
reference will be broken, if you move the file to another directory. If you need this move, save the file in the book dialogue to
the new location.

Cross-reference to any paragraph
1 Place the cursor where you want to insert the cross-reference (reference location) and select Special > Cross-Reference …
2 For a cross-reference to another file select that file from
the list of documents.
3 In Source type select Paragraphs as source location.
4 Select the desired paragraph type in the left hand list.
5 Select the desired paragraph in the right hand list.
6 Select the proper format for the cross-reference from the
Format list. You might need to create a proper format with
click on Edit Format.
7 Click Insert. will insert the cross-reference.

Cross-reference to marker
Insert a cross-reference
marker

1 Place the cursor where you want to define the source location (marker)
2 Insert the marker with Special > Marker...
Marker type= Cross-Reference
3 Define the name (text) of the marker. Be aware that in long
document you will need some logic to find the correct
markers later.
4 Click New Marker.
5 The Marker dialogue stays open, so you can go to the next
location in the document...

Hint
Note:
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To use existing text to appear in the marker text: select the
text while the marker dialogue is open or will be opened.
The marker text can not be referenced. There is no such building block as <$markertext>! You can only refer to the page
where the marker is located, or to the <$paratext> where the
marker is (but this can be done without placing a marker first).

Cross-reference to marker

See Cross-reference to marker text on page 7-7 for an alternative.

Define a reference to a
cross-reference marker

p The source file (where to point to) must be open.
p Place the cursor where you want to insert the cross-reference (reference location).
p Special > Cross-Reference …
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p For a cross-reference to another file select that file from
the list of documents.
p Source type = Cross-reference Markers
p Select the desired marker in the right hand list.
p Select the proper format for the cross-reference from the
Format list. You might need to create a proper format with
click on Edit Format.
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p Click Insert will insert the cross-reference.

Marker type Header/
Footer

The content of markers of type Header/footer $1 and
Header/Footer $2 is available on master pages only. The system variables <$marker1> and <$marker2> insert the marker
contents.

Cross-reference to
marker text

A cross reference can not display the contents of a marker.
However, a hyperlink can serve this purpose:
1 At the source location (where to point to) specify a named
destination:
-

in Special > Hypertext select command Specify Named
Destination.
Enter a significant name after the blank after newlink
Click New Hypertext Marker

2 You may wish to indicate the source location by some
means, for example, a keyword, which you also use in the
reference location. This may be highlights by any means to
recognise it.
3 At the ‘reference location’ insert a hyperlink:
-

D

Example reference
location

in Special > Hypertext select command Jump to Named
Destination.
Enter the name of the destination after the blank after
gotolink

See the word 6Cross references, which is highlighted there.
The location of the hypertext marker is indicated by this symbol: 6
For details of these constructs see Types of hyperlinks on
page 7-20.
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Cross-references

Cross-reference to subsections
A cross-reference to a subsection often needs to identify the
section that contains it. For example, a cross-reference to a
subheading might identify the main heading under which it is
found, as in the following:
See Date and time in Running headers and footers. The first item
is the source paragraph and the second item (after “in”) is the
main heading under which the source paragraph appears:
<1-highlight><$paratext></> in <1-highlight>
<$paratext[1heading]></>

See Building blocks for system variables on page 4for more definitions of this kind.

Cross-reference to other file
To reference sources outside the current file may wish to
include the chapter number in the references format, for
example “see Cross-references on page 7-6”.
Of course you need files with the chapter number defined
(Format > Document > Numbering > Chapter or via the book
set up) or you get the default number (1).
Reference format

<1-highlight><$paratext></> on page\ <$chapnum><$pagenum>

Editing cross-references
 To edit the appearance (format) of a cross-reference, double click on it to enter the dialogue Cross-Reference. Click
on Edit …
 To change the source of the cross-reference, delete the
cross-reference and insert a new one.
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Format of cross-references

Format of cross-references
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Set up the format of cross-references to be used as flexible as
possible:




Example formats:

Try to avoid plural or inflections.
Avoid punctuation
Avoid introductions which may vary
Try to avoid language dependent parts

<1-highlight><$paratext></> on page\ <$chapnum><$pagenum>

Produces: Format of cross-references on page 7-9:
<1-highlight><$paranum><$paratext></> (<$pagenum>)

Produces: Table 1: Building blocks for system variables on page 4

E:\FM-course\handout\references.fm

Avoid language
dependency

The last example includes a language dependent part, which
is part of the automatic numbering of the table. To avoid this,
 either abbreviate the word Table to Tab. in the autonumber
(which fits at least English, French, German and Italian);
 or abandon this prefix word completely. Then start the reference in the text with the appropriate language:
See Building blocks for system variables on page 4.
<1-highlight><$paranumonly> <$paratext></> on page\
<$pagenum>

Note:

Character styles may not completely be transferred to the
cross reference. See Character styles in building blocks on
page 3-14.

Note:

From multiple character formats (e.g. <bold><italic>.) only
the first one is kept in book updates. See Peculiarities of book
updates on page 8-15.

Complex xref format
typed text building block building block

typed text

building block

building block

<jumps>see <TitleProps><$paratext><jumps> on page\ <$paranumonly[H1]>\+<$pagenum>

D

character format building blocks
(e.g. setting weight, colour)
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building block

non-breaking
space

non-breaking
hyphen

Arbitrary markers

Arbitrary markers
Standard markers are used for various purposes:
 define index entries (see Index creation on page 9-9)
 define sources for cross references (seeCross-reference to
marker on page 7-6)
 Define text to be used in running headers and/or footers
other than text appearing in headings or other paragraphs.
See References to special markers on page 5-19
 define hypertext and links. See Hyperlinks on page 7-19

Text for indexes and lists

A standard index collects information from markers of type
index. You may, however have various indexes in parallel:
 index of authors (use marker type Author)
 index of equations (use marker type Equation)
 index of glossary entries (use marker type Glossary)
 index of subjects (use marker type Subject)
See Document specific lists on page 9-20

Identify locations

To identify locations of special interest you may wish to
define your own marker type, for example Terminology. This
may allow you to place this marker where terminology is
unclear and in the same instance to collect ideas in a list of
this marker or even an index.
To define a maker type Terminology,
1 Open the Marker dialogue with Special > Marker …
2 In Marker Type select Edit …
3 In the dialogue Edit Custom Marker Type enter the name
of the new marker type: Terminology and click Add.

4 Now this marker type is in the list and you can insert it
where you need.
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Update references

Update references
To update references in the current file, open Edit > Update
References and activate the appropriate check boxes and
then click Update.
You may automate certain function by selecting from Commands:
2011-05-11

 Suppress automatic updating: Specify which references
shall not be automatically updated when the file is opened
or the book containing the current file is updated.
 Update unresolved Cross-References: A dialogue appears,
which allows to fix unresolved cross-references in all open
files.

Update unresolved cross-references
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With this command the current file is scanned for cross references. The upper scroll list contains all (originally used) source
files.

1 Select one of the files (≠ Current) listed in the top scroll list.
D

2 If the text below the box notes > 0 Unresolved CrossReferences in File, find the file with the source location
by means of the File list in the lower part of the dialogue
and Open it.
3 If FrameMaker can't perform the update, select a different
source file and try again.
4 Repeat steps 1 … 3 for each of the files in the top list.
If FrameMaker fails with all proposed new source files:
1 Edit > Find/Change, select Unresolved Cross-Reference
2 If found, delete the reference and set up a correct one.
3 Repeat Find/correct/file select, until all has been corrected

7 – 11

Footnotes

Footnotes
Footnotes consist of three elements:
1 The footnote reference which is placed in the running
text: 20)
2 The footnote text formatted according to a specific ¶ format (default: Footnote and TableFootnote).
3 A placeholder frame between the text area and the topmost
footnote of that page (or under a table).

Footnotes in text

Footnotes in text can be numbered in various ways. The numbering may start on each page anew or continue within a
chapter or book.
For text footnotes the place holder frame normally contains a
line (see bottom of this page).

Footnotes in tables

The same rules apply as for the footnotes in text. The default
style name, however is TableFootnote, and hence there is
another graphic frame on the reference pages with this name.
For table footnotes the place holder frame normally is empty,
but may also contain a line for unruled tables.

End notes

Endnotes are footnotes which are collected at the end of a
chapter or document. FrameMaker can not handle these. However, ordinary footnotes may be converted to end notes by
appropriate API’s or plug-ins as well as FrameScripts.

Insert a footnote
To place a footnote,
1 Place the cursor at the text location where the footnote reference shall appear.
2 Select Special > Footnote and write the footnote text into
the new footnote paragraph.
Text footnotes are always placed at the bottom of the current
page (if space allows). Table footnotes are collected after the
table.
Note:

You can not arrange the footnotes of a chapter at the end of a
chapter (or file). For this you need to install an appropriate API
(see Extensions by API clients on page 1-21).

Note:

If a text footnote is referenced close to the end of a page (for
example, in the last paragraph) then the footnote may be
placed on the next page.

20 Sample footnote to demonstrate the elements comprising this construct
and to display the appearance: ¶ format is zfn-footnote; numbering is arabic, continuing in each chapter. The separator is the green line above.
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Appearance of footnotes

Appearance of footnotes
The following items must have the same name:
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 The style name in the Footnote Properties dialogue
 The style name in the paragraph catalogue
 The name of the graphic frame on the reference page.

Paragraph format for
footnotes

 Do not specify automatic numbering in these styles! It will
interfere with the special numbering process of footnotes.
 Specify TAB positions if you define TABs (\t) in the Prefix
or Suffix elements prepended or appended to the footnote
text. Also a hanging indent may be needed.
 The separation line is not defined by the ‘Frame above’
property of the paragraph style (see Separation line or space
on page 14).

Format of the footnote
reference

 The format name and the number format of the reference
and the note is defined in Format > Document > Footnote
Properties...
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 You can only define constant text for the prefix and suffix
in the footnote format (e.g. opening and closing brackets).
-

You can not use system variables or user defined variables in the prefix or suffix field.
You can not use character formats in the prefix or suffix
field.

 You may wish to define the maximum height of space for
text footnotes (per column). The default is 4" (10cm).
 The style of the footnote numbering (arabic, …) and
whether text footnotes shall start numbering on each page
or continue numbering again is defined on Format > Document > Numbering > Footnote and > Table Footnote.
 Format Custom allows to define a series of symbols
(default: * † ‡) which must not be separated by spaces.
They must be from the text font. If the font in the body and
in the Footnote paragraph is a Unicode font, then the list of
characters in the Numbering dialogue may also contain
characters such as ※ or ⁂. In the dialogue however they
may show up as ‘unknown character’, e.g. as @.

D

For more footnotes than symbols in this list the symbols
are repeated in the footnote reference and the footnote
numbreing ( * † ‡ ** †† …)
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Footnotes

Separation line or space

The separation line (or just space) is defined on the reference
page named Reference by a graphic frame named Footnote
respectively TableFootnote:

The text lines are just for the human reader.

Additional reference to a footnote
To refer to an already existing footnote you must place an
ordinary cross-reference.
The reference should indicate the page number where the
footnote can be found (see the next section).

Reference to footnotes in other chapters
To reference a footnote in another (than the current) chapter
or file, you need a special cross-reference format providing
both the page number (and/or the chapter number) and the
footnote number.
To be able to format it similar as a footnote reference (superscripting) you need an appropriate character format (e.g.
super). The complete cross-reference format may look like
one of these:
<super><$paranumonly[Footnote]> on page\3<$pagenum></>
<super><$paranumonly[Footnote]> on page\3<$chapnum><$pagenum></>

Footnotes in book files
Footnotes at the end of a
book
Solution
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There is no feature in FrameMaker to collect footnotes from
various files and present them at the end of a FrameMaker
book in a particular chapter (or at the end of the last chapter).
Collect all notes in a file (use a paragraph format, such as xnote), and refer to them with an ordinary cross-reference of
an appropriate format (e.g. <super><$paranumonly[x-note]></>

Footnotes and text columns

Footnotes across books
To number the footnotes across the all (or certain) chapters
of a book:
If you already have a book file, see Footnote number on
page 8-9. Otherwise do the following:
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1 In the first file of the sequence set the numbering properties in Format > Document > Footnote Properties > Numbering: The First Footnote # gets the initial number
(normally 1). Set also the desired number format of the
footnote (e.g. arabic).
2 Check whether the footnote format is correct in Format >
Document > Footnote Properties…
3 In all other files of the sequence, set the numbering properties in Format > Document > Footnote Properties>
Numbering set First Footnote Number to Continue Numbering from Previous Footnote in Book.
Check whether the footnote format is correct in Format >
Document > Footnote Properties…
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Note:

The numbering will be correct only after you have set up a
book from the files you have prepared.

Footnotes and text columns
There is only one ¶ format for text footnotes available. Hence
you must decide between the appearance.
In the first example the footnotes are “In column”. The footnote from the title becomes the last one and its text extends
across all columns as the title does
.

This title is across all columns 1
This is just text in the column and
uses a footnote reference in this
left column 2.

D

Hecate est Iovis et Latonae filia,
soror Apollinis. Est tricopor et

triceps, magicarum artium magistra ac caedibus contaminata.
This footnote reference is in the
right column 3.

2.

This footnote is referenced in the
left column

3.

Footnote referenced in the right
column

1.

This footnote is refenced in the title. Since it spans all columns, the footnote
will so also.

If in the above example you enlarge the vertical space by
enlarging the text frame, the footnote of the title will temporarily (until the next save or save as PDF) stay in column.
In the second example the footnotes are “Across all columns”.
The footnote from the title becomes the first one.
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Footnotes

This title is across all columns 1
This is just text in the column
and uses a footnote reference
in this left column 2.
1.
2.
3.

This footnote reference is in
the right column 3.

This footnote is refenced in the title
This footnote is referenced in the left column
Footnote referenced in the right column

Editing footnotes
 To move a footnote reference, select it, then cut it to the
clipboard buffer and insert it (paste) it at the new location.
 To change the reference appearance (e.g. from numbered to
symbol), Format > Document > Footnote Properties and
modify the number format (prefix and suffix) to your
needs.
Note:

Modifications of the format of footnotes applies to all footnotes
in the document!
 To change the appearance of the footnote, modify its paragraph format.
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Special footnote numbering
We want to have footnotes looking like this:
7 | 12

The numbering shall contain both he chapter
number and a sequence number.
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This can be achieved only by completely forgetting the footnote numbering process and working with anchored frames
containing the footnote and a cross reference to the footnote.
1 At the first occurrence of such a footnote, define an
anchored frame with type At Bottom of Column
. Size it
to be able to contain the footnotes of the current page.
2 In the anchored frame place a separator line and a text
frame
for the footnote text.
3 Specify a paragraph format for the special footnotes, for
example xfn-xtra-footnote with the following numbering
property: f:<$chapnum> | <n+>\t
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4 Place the first footnote text.
5 Before the anchor point insert a cross reference to the footnote. The cross reference format used is xfn (but of course
may be anything you like). It should create an appearance
similar to ordinary footnote references (superscripted).
7 | 1)7
6 Adjust the size of the inner text frame as well as the outer
anchored frame to fit the text after you have placed all
footnotes from this page.

Second and more
footnotes on the same
page

If you need a second or third footnote on the same page, proceed as follows:
7 Enlarge the inner and out frames at the bottom to what you
probably need and add the desired number of paragraphs
which number automatically.
8 Place the references at the desired locations into the text.
Be aware that you can have only one anchored frame of type
“At bottom of column”. Here the second footnote ref: 7 | 2.

D

And for the sake of demonstration at the end of this paragraph a third footnote on this page 7 | 3.

Footnote on successive
pages

On each page where you need special footnotes the first of
these needs an anchored frame. Of course this anchor may be
anywhere on the page, but it is good practice to place it at the
first footnote reference.
1 Copy the anchored frame to the location of this first footnote reference.
2 Modify the text in the inner text frame.
3 Insert the cross reference to the footnote text.
7 | 1 This is the first special footnote on this page. I just comprises
some text to form a paragraph.
7 | 2 This is the second special footnote.
7 | 3 And this is the third one. The current chapter number is 5. Footnote numbering has no influence here.
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Side notes or marginalia
For various purposes side notes are better than footnotes
which require the reader to go to the bottom of the page or
even another page and back to the place where he stopped
reading the normal text.
Side notes avoid this similar to properly arranged pictures.
This side note uses the paragraph
format sidenote. The text of the
side note appears before the next
paragraph in the main text area.
Side notes use smaller font sizes
than the ordinary text. It is good
practice to make it similar to footnote appearance. For me sans
serif looks better for this purpose.

Using a paragraph format sidenote with the main property
“pagination: in side head area” provides the following:

As long as the items in the main
text flow only use the text column, no gap exists. But successive elements in the side head
area may create gaps, as seen
here due to the heading 3 below.

This is a short text with the side note. Watch the gap to the
next heading level 3, which in this compendium uses the side
head area.

Anchored frame

Side notes may be put into anchored frames. In this example
the anchor is at the beginning of this paragraph.

For this type of side note the
anchored frame contains a text
frame (this shaded area) which
holds the side note. The text
frame is smaller than the
anchored frame to avoid the text
clinching to the border.
Watch the space on the right
side. It contains several empty
paragraphs (visualised by leading -).
For a new side note set copy/
paste for the whole construct.

Side notes should not be
long
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 No reference within the main text on the right side is
needed normally. You may add this by numbering the side
note and refer to it with a cross reference in the main text.
 Numbering can be applied simply by numbering property.
 If the side note becomes higher than the referring text on
the right side then there will be a gap in the main text in
case of an element which is either in the side head area or
across side head area and columns.

 This method is useful, if you want to frame the side notes
in the same way as you frame pictures.
 Layout becomes more difficult, because the frame does not
automatically push down other elements in the side head
area as the previous method. You must insert empty paragraphs in the main text area. In this example
Keep in mind that side notes should not fill up the side head
area, especially if the side head area is also used for minor
headings as in this compendium.

Hyperlinks

Hyperlinks
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Milestones on the way to hypertext as we know it from the
worldwide web are:






Vannevar Bush and his "Memex" (1945)
Douglas C. Engelbart with "Augment" (starting 1963)
Ted Nelson with project "Xanadu" (starting 1965)
Arno Schmid’s novel "Zettels Traum" (1970)
Find a good German summary here.

Hypertext in FrameMaker
Since version 3 FrameMaker supports hypertext in various
forms:
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 Cross references provide live links during creation of documents. These are converted to hyperlinks in HTML and
PDF.
 Any generated file (such as the Table Of Contents, or
Index) can automatically get cross references to their
source information. See Hypertext links on page 9-2
 Hyperlinks are active if the document is converted to HTML
(see Generate HTML and XML on page 12-1).
 Hyperlinks are active if the document is converted to PDF
(see Refining the PDF output on page 10-13)
 Specific hypertext markers can refer to other documents or
URLs on the web.

Active area

The active area (where you can click on) is defined by the text
until the character format changes. You may also define sensitive images or areas. See the manual for this technique.

Insert hyperlink
p Select the hot spot text and highlight it with a character
format

D

p In Special > Hypertext select the appropriate type of link.
For a web-links this is “Go to URL”.
p The URL must be typed completely (may contain blanks):
message URL http://www.daube.ch/docu/fmaker00.html

Note:

Format hyperlink text

Case of command and blank after command is relevant. If
backslashes are used (e.g. in Windows paths), they must be
doubled when preceding certain characters (f, i, n, o, s). Better
yet is to replace all back slashes of paths with forward slashes.
It is good practice to highlight the hyperlink with a special
character format such as hyperlink. Please avoid underscoring in documents - its really looks bad:
This is a link to my FrameMaker stuff. Text outside hot spot.
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Types of hyperlinks
FrameMaker supports a number hyperlink types. For example,
the Equations palette is a FrameMaker document with lots of
hyperlinks. The following table is just an excerpt:
Note:

In file paths or URLs the backslash is not valid. The solidus
(normal slash) must be used. For pathnames see Links to documents and applications on page 20.

Hyperlinks which convert
to PDF
Command (drop down list) a
Alert

c

Alert with title

d

Open document
(same type as source: fm or pdf)

Syntax

Example b

alert text

alert Time for lunch now!

alerttitle title:text

alerttitle Hello - I’m the
title:This is in the first line
and this ...

openlink path

openlink D:/System_ddd/Systemdoc/Syshw.fm

Open document with associated appli- message openfile path
cation

openfile D:/System_ddd/

Go to URL

message URL url

message URL http://
www.daube.ch/docu/fmaker00.html

Specify named destination

newlink name

newlink here_we_go

Jump to named destination

gotolink name

gotolink ref_crossrefs

DDDcontrol.ini

a. For restrictions in conversion to PDF see Refining the PDF output on page 10-13. For details on some commands see Hyperlinks: goto versus open on page C-16.
b. Not all examples may work in your environment...
c. In PDF this will be a text note, the title will not be presented as such, but stay within the text.
d. The title is terminated with a colon. A carriage return in the text is inserted as \x0d – It will be replaced by
a blank when you display the marker again and you will have to re-insert it.

Hyperlinks valid only in
FM

Most of these hyperlinks can be transferred into an adaequate
function in PDF by means of MicroType’s “TimeSavers”.

Command (drop down list) a

Syntax

Example

Button matrix

matrix nrows ncolumns

The vertical toolbar is built
of such a matrix.

flowname
Launch Windows application

message Winexec

application
path[,windowstate]

Start the Windows calculator
(C:\WINDOWS\System32\calc.exe)

Open file as new document (template) opennew filename

Open with this document’s
styles (opennew layout.fm)

Popup menu
popup
(works only in FrameMakerView mode) textflow_on_refpage
Popup Menu Sample
Variables6
Cross references6
Update references6
Footnotes6
Hyperlinks6
Bibliographies6

popup popup1
The marker in the textflow contains a hypertext
command gotolink xxx with xxx being the
name in a hypertext marker newlink xxx at
the location to be jumped to with the menu.

a. For restrictions in conversion to PDF see Refining the PDF output on page 10-13. For details on some commands see Hyperlinks: goto versus open on page C-16.
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Links to documents and applications

Links to documents and applications
With links to documents the associated program will be
started to view the document:
Open file in text editor

2011-05-11

Display directory with
explorer
Play sound
Path relative to current
document

Start an application

message openfile D:/System_ddd/…/FM6-ini-mods.txt
message openfile C:/WINNT/Fonts/ATMFolder/
message openfile D:/System_ddd/sounds/5tones_up.wav

sub-folder:

message URL folder/file.ext

same folder

message URL file.ext

parallel folder

message URL ../folder/file.ext

1 level above

message URL ../../folder/file.ext

An application can be started directly:
message system H:/Utilities/SearchReplace/SR32.EXE
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Setting up a button matrix
The vertical toolbar is a good example of a button matrix. The
mechanism uses several elements (graphics are copied!):
Body page

Master page graphic1

Graphics are copied

matrix 3 2 Align

Text frame contains hypertext marker

Reference page Graphics2

Flow Align (The last line is for
the human reader only)

D

 On the body pages are text frames which contain only one
hypertext marker referring to the matrix of commands on
the reference page by flow name. The graphics ‘just shine
trhough’ from the master page.
 On the master pages the graphics are arranged. They are
just ‘on the paper’, not in frames
 The flows with the command matrices are distributed on
the various reference pages.

Commands

These are either hypertext commands (e.g. previouspage,
nextpage or popup LineBreaks) or commands defined in the
system (fcodes xxx) or in the various cfg files (e.g. xxx from
yyy).
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Bibliographies
Bibliographies are an essential element in scientific publications. The format of the bibliographic data as well as the form
of references varies. Each institution may have its own habits
and publishers add to the variations.
While everything can be set up in plain text, this section aims
at formats which provide hypertext links from the reference
to the bibliographic data. This goal may limit the formats.
Hypertext links are preserved in the document if transformed
to PDF or HTML. In this section these links are highlighted
with character format hypertext.
You find further methods to create bibliographies at Bibliography on page B-22.

Numbered bibliography
A simple form of references use only the numbers of the bibliographic data, which basically are numbered lists.

References

A reference uses the cross reference format <$paranum> to get
the number including the brackets and <$paranumonly> to get
just the numeric part for multiple entries.
The second form is more universal, but requires you to enter
the brackets manually: single [3] or multiple [1, 2].

Bibliographic data

Essential properties of
paragraph format

[1]

Daube, K., Aufbau des OBRZ Runtime Systems, in
Technisch-wissenschaftliches Rechnen am MVS System.
1989, OBRZ AG: Zürich. Handbuch 400.50.10.

[2]

LaBonté, A. A New Data Type for National Language?
in SEAS Anniversary Meeting. 1989. Amsterdam, The
Netherlands: SHARE European Association.

[3]

Garneau, D., ed. National Language Support Reference
Manual. January 10, 1990 ed. National language
Information Design Guide, ed. IBM. Vol. 2. 1990, IBM
National Language Technical Centre: Toronto, CDN.

The paragraph format for the bibliographic data in this example is lit-ref-numbered with the main properties: Auto numbering sequence: “L:[<n+>]\t”.
You may rearrange the paragraphs to get a sorted list and
then update the references with Edit > Update References:
all Cross References.
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Name and year in references

Name and year in references

2011-05-11

If you need independent access to the names and publication
years to combine references, you need to set up paragraphs
for each element. To stack the (logical) paragraphs in one
physical paragraph you define the stacked ones as Run-in
Headings. (format lit-short in this example).
This method provides a sequential list of data items (name,
year, name, year, …) in the cross-reference dialogue. Strangely
enough the first entry in the list is the second paragraph of
the specified format…

References

The cross reference format in the following examples is
<hypertext><$paratext></> and refers to paragraphs of format lit-short.
The issue of character coding in electronic data processing
was addressed quite aggressively by Daube in 1989 and again
in 1990.
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Bibliographic data

Daube 1989

generated TAB

Daube, Klaus, 'Text and Code - A Dragons
Pond.' Proceedings of the 30. G.U.I.D.E.
conference in Basel. G.U.I.D.E. Headquarters,
1989.
Comparing the human habits of gesture and miming
with codes in data processing shows a severe gap in
understanding coding mechanisms. This is the source
of many problems related to national language
support in data processing applications. This text
also is available in French, kindly translated by
Ministère des Communications du Québec, St. Foy,
Canada,

X-ref. markers
paragraph bibliography
paragraphs “lit-short”
Daube 1990

Daube, Klaus, National Language Support in
SUSI, OBRZ AG, Handbuch 410
(Dokumentverarbeitung mit SUSI), Kapitel
410.20.35. Zürich 1990.

D

The text formatter SUSI supports code page switching
(also within a file. A piece of text also may have the
attribute language, to which hyphenation is bound.
National keyboards can be used. The code page used
internally is based on code page 037, the character
set supports most Western and Eastern European
languages.

Essential properties of
paragraph formats

lit-short

Pagination: Run-in Head with default punctuation “ ”.

bibliography

Pagination: anywhere; auto numbering
sequence: “\t”; Left indent: 3 cm; tab position: 3 cm.

Sorting the bibliographic data
To sort the bibliographic data in lists (paragraphs), either
 move the paragraphs by cut and paste, or
 use the [i]-frame script Sort Paragraph section.
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Reference and bibliographic entry
Thomas M. Reuter (tomreuter@compuserve.com) communicated the following method: Use two paragraph formats for
the bibliographic data (e.g. B1 for the part to be referenced
and B2 for the full bibliographic data).
Paragraphs B1 (reference texts) must not print, hence they
use a special colour which is defined ‘not to print’ (View >
Color > Views…). In the example below this colour is named
Bibliographie.

References

Set up a cross reference to use it with the specially prepared
coloured entries (paragraph format B1). Some examples are:
<$paratext>
<$aranum> <$paratext> (page <$pagenum>)

With these definitions you can create references in line, such
as the mentioning of Marty et al without any fuss. You can
also refer to the completely numbered item as in this example: [2] Th. Reuter, FrameMaker (page 24).
You can extend this method to use more than one concealable
short entry (variants of B1 paragraphs). Be aware of identification problems in the cross reference dialogue.

Bibliographic data

[1]
[1]
[2]
[2]

Essential properties of
paragraph formats

Colour views

Marty et al
Marty Ch., R. Philipona and C. Frohlich, 1999: Probleme
mit Bibliographien in Framemaker, Journal of
FrameMaker, Nr. 43, 256-268.
Th. Reuter, FrameMaker
Reuter, Thomas M., 1999: Das Buch zu FrameMaker.
SmartBooks Kilchberg. ISBN 3-908488-28-1

B1

Next paragraph: B2; colour: Bibliographie; Keep
with next; auto numbering sequence: “B:[<n+>]\t”.

B2

Next paragraph: B1; no keep; auto numbering
sequence: “B:[<n>]\t”.

The file with the bibliographic data needs special settings for
the colour views (View > Color > Views…):
 When working with the bibliography you need to see the
text and use view 1.
 For printing you must hide the coloured entries using
view 2.

7 – 24

Table of bibliographic data

Table of bibliographic data
Since tables can be sorted, it would be nice to use them for
bibliographies in place of the above mentioned lists.
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However, sort destroys any markers in tables. This bug exists
since we can sort tables (FM 5.5). Hence a special procedure is
required:
Bug needs special
procedure

 Set up the table with the bibliographic data. Use a distinct
¶-format for the reference data (e.g. lit-short2).
 Sort the table before you set up any cross references.
 Insert the cross references at the desired places. To ease
this, use a special notation in the running text to find the
places where you want to insert the cross references (e.g.
“[[engelbrecht 88”).

Example running text

While [[Blum 2000 and [[Engelbrecht clearly describe the
problem, [[Helm 1990 just tinkers around and does not provide any reasonable discussion of the problem.

After inserting the
references

While Blum et al, 2000 and Engelbrecht, E.G., 1998 clearly
describe the problem, Helm, J. L.,1990 just tinkers around
and does not provide any reasonable discussion of the Thin
Tree Syndrome.

Blum et al, Blum, L., Bajaj, P., Gass, J., Poulikakos, D., 2000, “Pollutant Formation
of a 20 kW Domestic Gas Burner Operated at Partial Premixing Mode”,
2000
Proceedings of Second European Conference on Small Burner
Technology and Heating Equipment (ECSBT 2), Germany.

Engelbrec Engelbrecht, E.G., 1998, “Modelling of Premixed Combustion in a Gas
Turbine”, PhD Thesis, Cranfield University, England.
ht, E.G.,
1998

D
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 If you need to update the table, insert new items at the
alphabetic location and do not sort the table any more!
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Helm, J.
L.,1990

Helm, J. L.,1990, Energy Production, Consumption and
Consequences, National Academy Press, Washington, USA.

N. N.,
1998

N. N., 1998, ELCO Energiesysteme AG, Betriebsanleitung Gasbrenner
Low-NOx, Vilters.

N. N.,
2000

N. N., 2000, Japanese Advanced Environmental Equipment, Global
Environment Centre Foundation, Japan, http://nett21.unep.or.jp/
JSIM_DATA/JSIM13.html.

Bibliography with EndNote

Bibliography with EndNote
EndNote (www.endnote.com) is one of the most used applications to maintain bibliographic data bases and generate bibliographies in scientific works.
The product is widely used for dissertations, theses and scientific publications of all kinds. EndNote is available for Windows and Mac OS. It is well integrated with MS Word by means
of macros and DDE (Dynamic Data Exchange).

Cooperation with FrameMaker
Advantages using
EndNote

Although bibliographies can easily be created in FrameMaker
by means of cross reference, EndNote provides the following
advantages:
 Maintenance of a bibliographic database for several works.
 The database can be filled with data from various sources
including the Internet.
 Generated references and citations can adhere to a large
number of output formats (most publications require special formatting).

Drawbacks of EndNote

Over the time the various EndNote releases have changed
their behaviour significantly, in particular with relation to
FrameMaker:
EndNote
Version

Cooperation
Handling non-Word files

Word

FM

5 (2001-09) Scans MIF and RTF, handles non-ASCI characters
not correctly

+++

++

6 (2002-06) No scan of RTF or MIF possible – purely a Word
thing

+++

0

7 (2003)

Scan of RTF possible, but not MIF

+++

+

8 (2004)

New data base format to support UNICODE; only
working with Word, No MIF support

++++

+

Only EndNote versions 1 … 5 provided the function Scan Document in mif. Version 6 does not support any scan and starting with version 7 scanning RTF is back which allows to work
with most text processors and provides some possibilities for
FrameMaker.
From version 8 on the Unicode support in EndNote hinders
direct handling of the temporary references in FrameMaker,
because FrameMaker is not Unicode compliant.

Using EndNote’s RTF scan
facility

It may seem reasonable to export the FrameMaker document
as RTF, then scan and modify it by EndNote and finally import
the RTF again into FrameMaker. Some problems are:
 Anchored frames get new attributes (at insertion) with all
previous content as one image.
 Layout and formats must be re-applied.
 Cross references become useless, must be rebuilt.
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Process overview

Solution with
D+DD utility

D+DD has developed the utility FM+EN which controls the
collaboration between FrameMaker, Word and EndNote.
Manipulations in the paste buffer overcome the code difference between EndNote (Unicode) and FrameMaker (Mac
Roman).

Process overview
2011-05-11

The utility FM+EN controls the data flow between the three
involved programs:

FM+EN
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FM temporary citations

Müller et al
[[Müller, 1925
#13]] developed an open
issue on this
and hence …

Word

1

[[Müller, 1925 #13]]{#13}
[[Müller, 1925 #13]]{#13}
[[Müller, 1925 #13]]{#13}
[[Bartels, 1981 #14]]{#14}
[[Müller, 1925 #13]]{#13}
[[Daube, 1989 #6]]{#6}
[[LaBontÃ©, 1989 #11]]{#11}
[[LaBontÃ©, 1989 #11]]{#11}
[[LaBontÃ©, 1990 #8]]{#8}
[[Garneau, 1990 #12]]{#12}
[[xxx xxx xxx]]{#}

FM Bibliography resolved

Word

2

[[Müller, 1925 #13]][1]
[[Müller, 1925 #13]][1]
[[Müller, 1925 #13]][1]
[[Bartels, 1981 #14]][2]
[[Müller, 1925 #13]][1]
[[Daube, 1989 #6]][3]
[[LaBontÃ©, 1989 #11]][4]
[[LaBontÃ©, 1989 #11]][4]
[[LaBontÃ©, 1990 #8]][5]
[[Garneau, 1990 #12]][6]
[[xxx xxx xxx]]{#}
1.
Müller, P.D.H., De
viris illustribus. 9 ed.
1925, Hannover: Carl Meyer
(Gustav Prior). 155.

Bibliography

2.
Bartels, K., Veni
vidi vici. 5 ed. Lebendige
Antike. 1981, Zürich: Artemis
Verlag. 88.

Bibliographic
database

Process details

EndNote

3

Müller et al [1]
developed an
open issue on
this and hence
…

Bibliography
[1] Müller, …
[2] Bartels, …

Output
formats

Temporary citations are copied from EndNote and pasted into
the FrameMaker document. However, not CTRL+v is used for
pasting, but the new command CTRL+y provided by FM+EN.
This command transforms the Unicode references to FrameMaker-digestible references.

D

Step 1

The temporary citations are collected in FrameMaker and
written into an MS Word file. Two forms are written to avoid
problems during resolving the references in EndNote:
 The long form which is present in FrameMaker, for example [[Müller, 1925 #13]]
 The short form containing only the necessary information
for EndNote to resolve the reference, for example {#13}.
[[Müller, 1925 #13]]{#13}¶

Step 2

EndNote scans this Word file (in rtf = Rich Text Format)
based on the current bibliographic database and the selected
output format. The result is a new rtf file containing both the
formatted references and the generated bibliography:

Step 3

The first part of the rtf file from step 3 now contains formatted references to the right:
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Bibliography with EndNote

[[Müller, 1925 #13]][1]
[[Bartels, 1981 #14]][2]
[[xxx xxx xxx]]{#}

With this data the temporary references in the FrameMaker
file are searched and replaced by the formatted form.
The second part of the new file contains the generated bibliography:
1.
2.

Müller, P.D.H., De viris illustribus. 9 ed. 1925…
Bartels, K., Veni vidi vici. 5 ed. Lebendige…

The user must copy this bibliography to an appropriate place
in the FrameMaker document or book and format it.
Note:

You must use Paste Special and select RTF to maintain the
local character formatting from Word.

Note:

The following is an excerpt from the separate documentation
about the utility FM+EN. See the D+DD website for details.

Utility FM+EN
After start of the utility FM+EN you will get an icon in the system tray. For the insertion of the temporary citations the utility provides the “hot key” CTRL+y for the special paste
operation.

Inserting a citation

1 In EndNote select the Citation in the Database view and
copy it to the clipboard (CTRL+c).

2 Switch to FrameMaker and place the cursor in the document where you want to place the citation.
3 Paste the temporary citation from the clipboard (CTRL+y).
The inserted temporary citation has the format
[[LaBonté, 1989 #11]].
Note:

For pasting the same temporary citation a second (or more)
time use CTRL+SHIFT+y or CTRL +v.
You will run the process steps only after all (or most) of the
temporary citations are inserted in the document or the documents of a book.

Operating the utility

Right clicking on the utility icon in the system tray opens the
following menu:
About

Provides a panel with program information and a disclaimer.

Program Setup

It is essential to define the UI languages of the involved programs before you execute the process steps. Other settings –
such as working slowly or create footnotes from bibliographic
references – are optional.

Change References and
build Bibliography

The three steps of the process are run in sequence. Follow the
instructions provided by popup-messages.

Documentation
Suspend Hotkeys
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Display the PDF with the full documentation.
If for any reason you need in an application the key CTRL+y
you can suspend the key function from FM+EN and later reactivate it.

Bibliography in a FrameMaker book

Exit

Close the utility. You may use the PAUSE key for this.

Final Work

The completion of the process is displayed by a dialogue
which reminds you to copy the generated bibliography into
the FrameMaker document.
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Note:

EndNote uses local formatting in the text (not Character formats) and puts the numbering in the text. For different formatting (e.g. automatic numbering by FrameMaker) you need to
edit the text.

1.

Müller, P.D.H., De viris illustribus. 9 ed. 1925,
Hannover: Carl Meyer (Gustav Prior). 155.

2.

Bartels, K., Veni vidi vici. 5 ed. Lebendige
Antike. 1981, Zürich: Artemis Verlag. 88.

3.

Daube, K. Text and Code - A Dragons Pond. in
G.U.I.D.E. Conference. 1989. Basel,
Switzerland: GUIDE.

Bibliography in a FrameMaker book
If the utility is started in a FrameMaker book, it automatically
collects and changes the citations in all files of the book.
1 Open all files of the book and handle messages concerning
“missing fonts” or “missing graphics” accordingly.
2 Go to the book window and start FM+EN. The document
windows will be maximised to get correct window titles.
3 Place the generated bibliography in a separate chapter or at
a place of your desire.

Bibliography in footnotes
A special form of bibliography places the bibliographic references in footnotes. The citation in the text is just the footnote
reference. For example:

D

Hecate est Iovis et Latonae filia 21), soror Apollinis. Est
tricopor et triceps, magicarum artium magistra ac
fascinationum praeses, cinctra latrantium canum 22);
noctu stans in triviis vel prope sepulcra et ubi loca sunt.
To achieve this, you create a footnote and insert the temporary citation in the footnotes. FM+EN will replace the temporary citation with the bibliographic reference. You need to
specify this in the setup.

21 LaBonté, A. A New Data Type for National Language? in SEAS Anniversary
Meeting. 1989. Amsterdam, The Netherlands: SHARE European
Association.
22 Garneau, D., ed. National Language Support Reference Manual. January
10, 1990 ed. National language Information Design Guide, ed. IBM. Vol. 2.
1990, IBM National Language Technical Centre: Toronto, CDN.
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Bibliography with EndNote
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FrameMaker books

Overview
A FrameMaker book merely is a logical concept to
handle a set of files. The main purpose of books is
to automate the generation of Table of Contents, Index and the pagination process as well as the cross
references.
Chapters in a book can consist of more than one
file.
All files in a book can receive formats (style elements) from any document at once. This is a great
feature of FrameMaker.

Contents
General remarks on books ...................................... 2
Handling book items ............................................... 3
Numbering documents ............................................ 7
Master books ....................................................... 11
Combining Two Books ........................................... 12
Book error log ...................................................... 13
Migration from FrameMaker 5.x ............................. 16

General remarks on books

General remarks on books
FM books versus large single document
Task, feature

One single large document

FrameMaker book

Authoring

Only one author at a time.

Each chapter file can be edited independently.

Access to information

Open document multiply (2 nd to n th open is Independant access to individual parts
display only).
(chapters).

Save time

Depends on the size of the file and the
number of insets (graphics, text insets).

Only the changed chapters need to be
saved.

No structure view at all.

Book is the ‘list of chapters’.

Structural overview

a

Numbering features

Paragraph numbering and page number
Numbering may continue or restart in
can only be sequential through whole file. each chapter. Additional building blocks
for volume and chapter number.

Numbering display

The whole file has one numbering presen- Each file can have a different numbering
tation: e.g. page number is arabic.
presentation (e.g. roman for page
number in preliminaries or index).

Change order of information

Cut and paste even for chapters.

Drag and drop chapters (files) in book
window. Cut and paste within a chapter
file.

Redundancy

Parts of the text need to be copied into
other files. Text insets can avoid this.

Chapter files can be part of other books.
Text insets are used for ‘smaller’
pieces.

Layout

Continuous pages (right/left) must have
same number of columns. Unconnected
pages may have different layout.

In each file the number of columns can
be different: 1 column with side head in
base part; 2 columns for TOC, 3 columns for index.

Additional information

The file is what it is.

Non-FM files can be added to the book
for ease of reference (and opening them
by its native application)

Structured documents

The whole file is either structured or unstructured.

A document in a FrameMaker book can
either be unstructured or a single, complete element.

Organisational

Special information only form this one file. To obtain special information (e.g. list
of imported graphics) a book can be set
up from arbitrary fm-files (don’t need to
belong to the same subject or project).

a. For a ‘structure view’ see Simulate an outline view on page A-30.
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Handling book items

Handling book items
 Either you start a new book without having any clue which
files you want to put in (see Start a book on page 8-5).
 Or you start from an already existing file (see Start a book
on page 8-5).
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 The sequence of files in the book determines the chapter
numbers (and other numbering). See Numbering documents
on page 8-7.
 Generated files get the name from the current book, for
example, booknameTOC.fm.

Functions in the book window
The files in the book window use different icons:
 Book (1)

1

 Standard file (2)

E:\FM-course\handout\book.fm

3

 Generated file (3)

2

The area (4) at the bottom of the book window provides the
following information:
 Number of pages of the selected chapter. If more than one
file is selected, this is a list of ranges. To see all, maximise
the book window.
 An asterisk indicated that the file has changed since last
save.
The icons to the bottom right (5) provide functions on the
entries in the book window:
Icon

Toggle the display of the file name or heading text. The displayed text is the
content of the first paragraph of the main flow.
If the chapter title paragraph is in a separate frame rather than the main
text flow, you'll never see it in the book window. See Page types on
page 5-3: If the flow in the text frame on the title page is not auto connected to the main flow on the Left/Right master pages then you will see the
first paragraph of page 2 in the book window.
Be aware that the first paragraph may just be the chapter number as in this
compendium.

5

Update all files in the book (Edit > Update Book …). This updates
the numbering, cross references and (re-)generates TOC, Index, etc.

D

4

Function

Add a file to the book (Add > Files …). You get an Open dialogue to
select files. If the book has been saved the file names are displayed with
their relative position to the book. In a new book (not yet saved) absolute
paths are displayed (see page 6)
Remove the selected file(s) from the book. The files themselves are
not deleted.
Undo the last operation. Be aware that saving the book empties the undo
buffer.
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Handling book items

Manage book files
After changing the order of files or deletion of files it may be
necessary to change numbering properties and/or pagination
of book files.
To get correct numbering, cross references and generated
files (TOC, Index etc.) it is necessary to update the book.

File selection

 To select all files in the book use CTRL+A.
 To select a contiguous group of files, select the first file
and then SHIFT+click on the last file of the group.
 To select arbitrary files, select the first file and then add
more files by CTRL-clicking on the additional files.
Note:

Just selecting the book (the first line in the list) does not select
anything!

Open a file or activate an
already open file

 Double-click on the file name, or
 Select the file and click Enter.

Re-order book files

Select a file and move it with the mouse to the desired location in the book list. The are no keyboard actions for this
function.

Rename file

For this operation it may be necessary to switch the display to
Display File Names.
 Select it and change its name with Edit > Rename File, or
 Select the file, then click on the file name to become editable.
Before renaming a file FM saves the file with the old name and
then updates all references of the renamed file.
Note:

Delete file

Do not rename a file with the file manager, if this file is used in
a book. You will need to set up the book again.
 Select the file and click the
button, or
 Select the file and type DEL key.

Note:

You do not get a chance to confirm the deletion, but you can
undo the deletion. Not the file itself is deleted, just the pointer.

Book wide functions
Search / Replace

When issuing an Edit > Search/Replace from the book window, the search starts in the file which is selected in the book
window. The search automatically continues to the next file in
the book and wraps to the first file etc.
If you change anything in a file, the search/replace loops
within this file until you did not change anything in the file.

Spell checking

When issuing an Edit > Check spelling…from the book window, the check starts in the file which is selected in the book
window. The check automatically continues to the next file in
the book and wraps to the first file etc.
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Menu items related to the book window

Menu items related to the book window
File menu:

For the book window some menu items change (see figure).
You get access to all files in the book (for open, close or save),
if you hold the SHIFT key while selecting menu File.
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When in a document file (x.fm) holding the SHIFT key while
selecting the menu File lets you close or save all open files.

Edit menu

If a book window exists in the current FrameMaker session,
the following dialogues get an additional option button Book
to allow processing in all files of the book. The
Edit > Spelling checker.…gets the Book radio button enabled
and selected.

D
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Find/Change… gets the Look in Book radio button enabled
and selected.
Additional items in Edit
menu

Context menu
(right mouse button)

Rename File, Delete File from Book and Update Book… are
only present for an active book window.
When you have selected a file in the book window, the context
menu provides the following functions (ignoring obvious ones
here):
Undo Drag/Drop You have changed the order of the files
with drag and drop. This will be undone.
Redo Drag/Drop

The previous drag and drop is redone.

Numbering…

Provides the numbering properties for the
file (see Set up numbering of chapter files on
page 8-7).

Pagination…

Provides the pagination properties for the
file (similar to Format > Page Layout >
Pagination)

Set up xxx

xxx is the type of a generated file (Table of
Contents, Index, etc.). Use this to define the
properties of the currently selected file.

Add files to the book
Start a book
p File > New > Book starts a new book. If an FM-file is open,
you are asked whether you want this file to be in the book.
In this case the book gets the name from this file (e.g.
maintenance.book)
p You may now add files to the book (see later). They may be
in any directory.
p In the Save as... provide a reasonable name for the book,
for example, microkeratome.book.
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Handling book items

Add a chapter (file) to the
book
1 In the book window use Add > File… to get a standard file
list.
2 Select the desired file from the file list and click Add. The
file will be placed below the currently selected file in the
book.
3 You may wish to move the file to another location in the
book. Just drag it with the mouse up or down (no keyboard
function available).
A Windows peculiarity

Add a generated file to
the book

If you select more than one file in the Add dialogue, then they
are inserted in the book in reverse order of your selection. Select
from last to first, and you will need to move only one file in
the book.
FrameMaker can generate table of contents, indexes, lists of
markers or paragraphs etc. This information is used in appendices or prefaces of real books or long documents.
Use the Add menu to add generated files to the book. This
menu is only visible if the book file is active. Select the
desired type of file:
Table of Contents…In the next dialogue specify the properties
of the Table of Contents (see Table of contents on page 9-3).
List of

The sub menu gives you a list of list types.
These lists are based on marker types or
paragraph styles (see Arbitrary lists on
page 9-17.

Standard Index… In the next dialogue specify the properties
of the Index (see Index creation on
page 9-9).
Index of

Gives you the choice of predefined indexes
in a sub menu.

To add a generated file to the book,
1 Select the type of file from the Add menu (and probably
using a sub menu)
2 If a detail dialogue pops up, either use the presented
defaults (may be changed later) or set the properties now.
3 Back in the book window you may wish to change the location of the file in the book.
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Numbering documents

Numbering documents
Overview
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The following example demonstrates the numbering capabilities with FrameMaker. Normally the numbering properties of
the various files are set from within the book window.
The settings are transferred into the individual files.
These properties are set in the book window for each file with Format > Document > Numbering
booknameTOC

introduction

main stuff-1

main stuff-2

file name (example.)

0

continue numbering
(8 1)

continue numbering
(8 2)

same as previous file
(8 2)

Chapter numbering

restart
format= roman

restart
format= numeric

continue

continue

restart

restart

continue

continue

E:\FM-course\handout\book.fm

TOC

Hecata....... 2-5
Lorem........ 2-7
Foxes........2-31

i

Chapter

1

Chapter

2

Lorem ipsum dolor
Lorem ipsum dolor
sit amet,
Hecate est Iovis et
Malenka
munkis
consectetuer
Latonae filia, soror
domodossola
adipiscing elit, sed
sit amet,Est
consectetuer
Apollinis.
tricopor
inkuration
mea gurki
<$chapnum>
- <$curpagenum>
diam nonummy nibh
adipiscing elit, sed
et triceps, nos a lo in
doppoeuismod
figuratione en
diam nonummy nibh
particolo
ms.
stria fides bene no.
euismod
tincidunt ut

1-1
laoreet

2 - 1 ut laoreet
tincidunt
2-2
2-2

1-2
c)

Master page

Page numbering
Paragraph numb.

Foxes
Lorem dolor sit amet,
adipiscing elit, sed
diam euismod
tincidunt
laoreet
Lorem ut
ipsum
dolor
maximu
vesuvius
sit amet,
Lorem
ipsum dolor
tanebre
consectetuer
sitsolo.
amet,
adipiscing
elit, sed
consectetuer
diamadipiscing
nonummyelit,
nibhsed
euismod
2diam
- 31
nonummy nibh
2 - 32tincidunt ut
euismod
2 - 32
laoreet
2 - 33
2 - 33

Page numbering on Master page
a) System variable Chapter Number (<$chapnum>)
b) System variable Current Page # (<$curpagenum>)
b)

a)

D

1-#

c) Format of page number is set in Format > Document > Numbering (page # style) in the document
or from the book.

Set up numbering of chapter files
A FrameMaker document holds a set of numbering properties:
 Paragraph numbering (see details in Hierarchical numbering
on page 3-11).
 Page number (used in layout)
 Chapter number (new in FM 6)
 Volume number (new in FM 6)
 Numbering of the standard footnotes
 Numbering of the table footnotes
These properties apply to text files as well as to generated
files.

8–7

Numbering documents

Set up a numbering
scheme

If your book has more than just a few files it is useful to set
up a table of the properties:

appendix

content

preliminary.

File

Vol.

Chapter

1

0

1

roman

restart

1

booknameTOC

same

same

continue

roman

restart1

continue

introduction

same

same

continue

roman

restart.

continue

planning-1

same

next

1

arabic

restart.

continue

planning-2

same

same

continue

arabic

continue

continue

planning-3

same

same

continue

arabic

continue

continue

working-1

same

next.

continue

arabic

continue

continue

working-2

same

same

continue

arabic

continue

continue

working-3

same

same

continue

arabic

continue

continue

diagrams

next

next

1

A

restart.

continue

same

same

continue

next

continue

continue

title

drawings

Page number

Paragraph Footnotes

Apply the numbering properties
For the files in the book apply the properties book by file:
1 Select the file
2 Either use the context menu and select Numbering or use
menu Format > Document > Numbering.

Volume number

Set the volume number according to your file structure:
In 1st file of vol. 1 Set the Volume # to 1 and select an appropriate format (I, II, III or A, B, C etc.)
In next file of vol. Set Use Same Number as Previous File.
In 1st file of vol. x Set Continue Numbering from Previous
File in Book.
Read from File

Chapter number

This takes the number as specified in the
document file with Format > Document >
Numbering.

Set the chapter number according to your book structure:
In 1st file of ch. 1

Set the Chapter # to 1 and select an appropriate format (1, 2, 3 or i, ii, iii etc.)

In 1st file of ch. x Set Continue Numbering from Previous
File in Book.
In next file of ch. x Set Use Same Number as Previous File.
Read from File
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This takes the number as specified in the
document file with Format > Document >
Numbering.

Apply the numbering properties

Page number

Set the page number according to your book structure:
In 1st file of ch. 1

Set First Page # to 1 and select an appropriate format (1, 2, 3 or i, ii, iii etc.)
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In 1 st file of ch. x For continuous page numbers set Continue
Numbering from Previous File in Book
For numbering scheme x-p set the number
to 1.

Paragraph number

In cont. files

Set Continue Numbering from Previous
File in Book.

Read from File

This takes the number as specified in the
document file with Format > Document >
Numbering.

Set the paragraph numbering according to your book structure:
In 1st file of ch. 1

Set Restart Paragraph Numbering.

E:\FM-course\handout\book.fm

In 1 st file of ch. x For continuous page numbers set Continue
Numbering from Previous File in Book
For numbering scheme x-p set the number
to 1.

Footnote number

In cont. files

Set Continue Numbering from Previous
File in Book.

Read from File

This takes the number as specified in the
document file with Format > Document >
Numbering.

Set the footnote numbering according to your desire:
In 1st file of ch. 1

Set First Footnote # to 1 and select an
appropriate format (1, 2, 3 or i, ii, iii etc.)

In other files

For continuous footnote numbering across
the book set Continue Numbering from
Previous File in Book.

To start with 1 on each page, set Start Over on Each Page.
Read from File

Table footnote

This takes the number as specified in the
document file with Format > Document >
Numbering.
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Set the numbering properties for footnotes in tables according to your desire:
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Format

Select an appropriate format (1, 2, 3 or i, ii,
iii etc.)

Read from File

This takes the number format as specified
in the document file with Format > Document > Footnote Properties…

Numbering documents

Update cross references and numbering
Neither the chapter numbers (or other paragraph numbering)
nor cross-chapter references are current, until the chapter
files are connected by a book.

To update the numbering
and the references

1 Open the book file
2 Select the files to be updated. If you select the top line with
the book name all files will be processed.
3 Click the update button (

) or use Edit > Update Book…

4 In the dialogue Update Book move all files which you want
to re-generate (TOC, index etc.) into the left pane. Move
everything else to the right. You may have nothing in the
left pane – Then only the numbering and cross references
will be updated.
5 Click the Update button. All cross references, paragraph
numbers and (if applicable) generated files are updated
now.
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Master books

Master books
Since FrameMaker version 6 it is possible to create master
books. Keep in mind that a FrameMaker book is just a logical
collection of files, in the case of a master book the collection
of FrameMaker book files.
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In a master book, only the following actions are possible:
 Add a book file to the master book
 Remove a book file from the master book
 Open a book file
Create a master book

To create a master book, just create a book file with File >
New > Book and save it with an appropriate name, e.g.
master.book.
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When adding files to the book with the icon (
) or with
menu Add > Files you get a message about non-document
files:

Activate Skip Non Document Format Messages to avoid this dialogue for future imports of book files.
The book files within the master book are represented with a
book icon:

Use this master book to open the individual book files and get
access to the document files in these book files:

D

Access to document
files

Source
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Combining Two Books

Combining Two Books
By Bright Path Solutions [www.travelthepath.com]
Bright Path Solutions use this technique when making custom
training books, as it allows them to easily pull topics from
different classes without browsing for them.
1 Open your first book and – if desired – save it as a new
name (such as, xyzcustomclass.book).
2 Then, open the second book and “tile” or resize the open
books so you can see them side-by-side.
3 In the second book, highlight the range of files you wish to
move into the first, custom book. (To highlight, click to
select the first file desired and shift-click to select the last
file desired.)
4 Click down on the highlighted range and hold down the
mouse button. Drag the files from the second book into the
first book and drop them where desired by releasing the
mouse button. (A small horizontal line appears to show
you the drop location and moves as you move.)
5 Close the second book without saving.
6 Save the first, custom book. Adjust the file settings if
desired and Update to adjust your table of contents and
page numbering.
You now have a custom book with topics/chapters combined
from two book files.

Numbering chapters with text
Volumes and chapters in a book may be numbered not only
arabic or roman, but also as text. This comes in handy to
specify part titles and the like:
1 In the Numbering Properties dialogue in the book, set the
Volume # Format for the file in question to Text and put
the entire part title (number and text) in the Volume # field.
So, for instance, the Volume # field in your Part 1 file
would contain:
Part 1: Part Title

2 Then, define the autonumber of your part title paragraphs
as <$volnum>. Your part title paragraphs can then be empty
paragraphs, with the title text as part of the autonumber.
Source
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Book error log

Book error log
When updating a book, errors are collected in a file called
Book Error log - bokname.book. This file…
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 can not be saved - it exists only during the current FrameMaker session. If you want to proceed tomorrow with the
clean-up, select all items (CTRL+A) and copy them to a text
editor window (or into a frame maker document).
 contains hyperlinks as you know them from the Web (blue
text with underline).
 is cumulated during a FrameMaker session, if you do not
delete (close) it between book functions.
It is good practice to work off all problems which are
reported in this log, then delete (close) the log and update the
book again.
Some of the errors reported would need your intervention or
decision. Hence the book update will not be complete until
you have handled these situations (e.g. missing fonts).

Sample report

Book Error Report

E:\FM-course\handout\book.fm

E:\FM-course\handout_60\course00.book
October 21, 2000 6:46:36 pm
E:\FM-course\handout_60\design.fm
Print setting for color Black is inconsistent.
Print setting for color Cyan is inconsistent.
E:\FM-course\handout_60\graphics.fm
Unresolved Cross-Reference to import_apps.fm
E:\FM-course\handout_60\references.fm
Unresolved Cross-Reference to book.fm

Update of file xxx is not possible

D

When updating the files in a book, FrameMaker can not react
on the error messages such as
 Font xxx missing and hence substituted by yyy for this session. See Font issues on page A-25.
 Language abc missing (dictionary not installed).
Remedy

1 Open all files in the book with SHIFT+File > Open All Files
in Book.
2 Respond to the error messages.
3 Perform the desired book operation, such as import format.
4 Close all files in the book with SHIFT+File > Close all files
in book.
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Book error log

Inconsistent settings
Inconsistent colour
settings

For handling inconsistent colours see Inconsistent colour on
page A-23

Inconsistent conditional
text settings

A particular condition tag is set to be shown in one file and to
be not shown (hidden) in another. This is an informal message and need not to be cleared – if the settings are what you
want.
To get rid of this error at the update of a book,
p Select all files in the book
p In View > Show/Hide Conditional Text set the settings
you need
You may wish to eliminate any conditions by Show All.

Inconsistent numbering
properties

This indicates that the numbering set within a file differs to
the settings in the book file. To correct this:
p Check the numbering for each file in the book

Import and distribute document properties
Import formats and
distribute to all files of
book

1 Open the book file
2 Select the files to be updated (see image). If you select the
top line with the book name all files will be processed.
3 Continue with the procedure described at Import formats
into book files on page 3-17.

Import and distribute
only part of a format
category

To import just some of the needed formats (e.g. paragraph
formats for headers only) you need an intermediate document.
The procedure is described at Import only part of a format category on page 3-17.
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Printing books
You may print all files (File > Print Book…) or only a selection from the book window (File > Print Selected Files…).
When printing a book to file (for example, a PostScript file for
later distilling to a PDF), you have the choice to
 Create a single file for the whole book (Single Print Job)
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 Create a separate file for each document file (Separate
Print Job for Each Document).
You need to select Single Print Job for creation of a PDF of
the whole book. Only in this mode correct bookmarks and
hyperjumps can be created.
For other ingredients to create a PDF see Standard process with
Distiller on page 10-5.

Peculiarities of book updates

<Blue><Bold>Appendix <$paranum>> <Italic><$paratext></>

However, the book's Generate/Update function ignores the
first one (in the example: Blue).
Workaround

Create a single character format (for example, Link) that has
all the properties you need, and modify the cross-reference
format accordingly.
<Link>Appendix <$paranum>> <Italic><$paratext></>

[2008-12-05 Shlomo Perets]
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Cross references documents may use various character formats, for example,
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Migration from FrameMaker 5.x
In files created with FrameMaker earlier than version 6 you
will encounter cross references on the master pages referring
to the first page with a chapter number. This is due to the
lack of the system variables Chapter number and
Volume number.
Opening the old book in FrameMaker 6 or higher updates
master pages (if it can). FrameMaker will convert the book and
all files to the new level. FM saves the old files with a .backup
extension and tries to convert file internals. You may end up
with a large error log.
Of course you will need to adjust the layouts etc. yourself.

No more prefixes

Use <$chapnum> in the generating pattern on the reference
page for the page number in TOC etc.

Before FM-6

<$paratext>

<$pagenum>

<$paratext> ............................................ <$pagenum>
<$paratext> ....................................... <$pagenum>
<$paratext> ................................... <$pagenum>
In addition specification of prefixes in the set up for
generated files was necessary to carry over chapter numbers
etc.
New since FM-6

<$paratext>

<$chapnum>

<$paratext> ......................<$chapnum> - <$pagenum>
<$paratext> .................<$chapnum> - <$pagenum>
<$paratext> .............<$chapnum> - <$pagenum>
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Generated documents

Overview
The Table of Contents (or TOC) is generated from a
file or files of a book (or a set of).
An index can be generated from a file or files of a
book (or a set of) by collecting the information from
the index markers.
Lists of tables, graphics, formulas etc. can also be
built from the paragraph properties. Such lists can
help during the production process or be part of the
final book.
Once the content of such documents is generated,
the format can be adapted and the generation pattern can be changed.
The mechanism of index generation can also be
used to generate parts lists and the like.

Contents
Hypertext links ....................................................... 2
Table of contents .................................................... 3
Index creation ........................................................ 9
Arbitrary lists ....................................................... 17
Building blocks on reference pages ........................ 22
Adding text to generated document ....................... 23
Working in a multilingual environment ................... 24

Hypertext links

Hypertext links
In all generated files (Table of Contents, Index, List of authors
and the like) FrameMaker can automatically insert hypertext
links to the source location. These hypertext links
 ease the development of the document with the various
revision cycles, homogenization headings, correction of
index entries etc.
 are automatically transformed into hyperjumps in PDF and
links in HTML
To get the hypertext
links

Check the box Generate Hypertext Links in the Setup for the
TOC or index etc.

Use the hypertext links
in FrameMaker

Holding CTRL+ALT while moving over the TOC or index lines
(or other places with the links) changes the cursor into a
pointing hand to indicate a hyperjump.
To jump just click now.

Note:

Cross references act also as hypertext links.

Note:

In generated files imported “by reference” into another document the hyperjumps do not work, because there is no text
which can be accessed directly. For working hyperjumps the
generated document must be imported “by copy” - this
requires a new copy after each update.
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Table of contents

Table of contents
 The table of contents (TOC) must be started as a generated
file (do not set up a file and then try to generate the TOC
into it).
 Document comprising a book may be closed to generate
the TOC from them. The book file, however must be open.
2011-05-11

 You can generate a TOC from a single chapter file also.
 The format of the generated file can be influenced by setting up proper paragraph styles and master pages in the
template for the chapter files.

Generate TOC from a file
1 Enter the document from which you want to generate the
TOC and select Special > Table of Contents…
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2 You are prompted whether to set up a TOC as part of a new
book or as an independent file. Click Yes.
3 In the dialogue Set Up Table of Contents move the paragraph styles, which should appear in the TOC, to the left.

Note:

You can move all items from one side to the other by holding
SHIFT while clicking on the arrow button.

D

4 You may wish to generate hypertext links: click the selection box.
5 Click Set. A new file named documentnameTOC.fm is created with default presentation of the TOC.
If your document file contains definitions for xxxTOC paragraphs, these will be used and the generated TOC may look
already quite well. See Format of the generated TOC on
page 6 for further refinement of the TOC.
6 Save the file. Do not change the name of this file!
7 You must update this TOC file after changes in the original
document file: in the document file follow steps 1 to 6
from above. Since you already have a TOC file from step 6,
this will be used for the re-generation.
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Generation process
Text document

Raw generation of TOC

Hecate est Iovis

A

Hecate est lovis 22
Latonae filia 22
Apollinis 22

et Latonae filia, soror Apollinis. Est
tricopor et triceps, magicarum artium.

Latonae filia

soror Apollinis. Est tricopor et
triceps, magicarum artium magistra
ac fascinationum praeses,.

Reference page

openObjectId
<$relfilename>:<$ObjectType>
<$ObjectId>

Apollinis

D

Est tricopor et triceps, magicarum
artium magistra ac fascinationum
praeses, cinctra latrantium canum.
22

<$paratext> <$pagenum>
<$paratext> <$pagenum>

docname.fm

¶ formats in text 8 formats in TOC

1heading
2heading

C

docnameTOC.fm
B

1headingTOC
2headingTOC

1 For the TOC file [A] ¶-formats and layout
pages are copied from the book or current
document file.

Format of TOC adapted

2 For each ¶-format defined in the TOC setup a
¶-format named xxxTOC with default properties is created in the TOC file [B].

Hecate est lovis ...................................... 22

3 A TOC reference page [C] is created (or copied
also) which contains the (default) definitions
[D]. These also get the ¶-formats xxxTOC.

Apollinis ................................................ 22

4 For each ¶-format defined in the TOC setup a
line for the TOC is generated based on the
pattern defined by [D].
5 To refine the layout of the TOC, you modify
the ¶-formats xxxTOC in the TOC file [E] and/
or the generating pattern, for example, set a
TAB between the text and the page number [F]
To avoid spell checking of a TOC set the language in the ¶ format to none.
6 Changes in the generation patterns require an
Update Book cycle to create the new contents.
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E

Latonae filia ........................................... 22

Reference page

openObjectId
<$relfilename>:<$ObjectType>
<$ObjectId>
<$paratext>1<$pagenum>
<$paratext>1<$pagenum>

F

docnameTOC.fm

Generate TOC for a book

Generate TOC for a book
1 Enter the book file for which you want to generate the TOC
and select the file before/after you want to place the TOC.
2 Select File > Add > Table Of Contents.

4 In the dialogue Set Up Table of Contents move the paragraph styles, which should appear in the TOC, to the left.

Note:

You can move all items from one side to the other by holding
SHIFT while clicking on the arrow button.
5 You may wish to generate hypertext links: click the selection box.
6 Click Set. A new file named booknameTOC.fm is created
with default presentation of the TOC.

If your book file contains paragraph formats for xxxTOC,
these will be used and the generated TOC may look already
quite well. The book gets these definitions at the time the
book is set up from a document file.

D
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3 Define where you want to add the generated file into the
book (only the selected file is in the drop down list).

For further refinement of the TOC see Format of the generated TOC on page 6.
7 Save the file. Do not change the name of this file!
8 After changes in document files of the book you must
update this TOC file with Edit > Update Book…: Assure
that the TOC file is listed under “Generate”. See Update
cross references and numbering on page 8-10 for more
details.

9–5

Table of contents

Format of the generated TOC
1 Open the TOC file
-

-

The layout you see is the same as the document from
which the TOC was generated.
The names of the paragraph formats for the TOC entries
are built from the original paragraph style names (e.g.
1heading, 2heading) with the appendix TOC:
1headingTOC, 2headingTOC.
On the reference page named TOC you will find the following lines. These are the generating patterns for the
TOC entries (the first line is needed for the hypertext
links).

openObjectId <$relfilename>:<$ObjectType> <$ObjectId>
<$paratext> <$pagenum>
<$paratext> <$pagenum>

-

Although second to last lines have the same content,
these lines are formatted differently using the style
names 1headingTOC and 2headingTOC (as an example).

2 Format these xxxTOC lines according to your needs (tabulation, leaders for the tabs, font size etc. and update the
paragraph catalogue with the settings.
To avoid spell checking of a TOC set the language in the ¶
format to none.
Note:

Whether an underline character in Custom Leader creates a
solid line or not depends on the font.

Adapt the formatting of the TOC entries
We use the line with style 1headingTOC as an example here.
1 Insert a tab between the two elements:
<$paratext>1<$pagenum>

2 In the paragraph designer set a right aligned tab as far as
possible and apply a dot leader. You may also wish to
indent the paragraph depending on the level of entry.
3 If you wish to include the paragraph number in the TOC
entry, add the element <$paranumonly> to the start of the
line:
<$paranumonly>3<$paratext>1<$pagenum>

This paragraph number is available, even if in the text document the paragraph number is invisible (colour white).
4 Save the changed document
The next time you generate the TOC, the new formatting will
be used

<$paratext>

Example of properly
formatted entries on
reference page TOC

<$chapnum>

<$paratext> ......................<$chapnum> - <$pagenum>
<$paratext> .................<$chapnum> - <$pagenum>
<$paratext> .............<$chapnum> - <$pagenum>

9–6

Include table of contents in document

Prepare for entries which
are longer than a line in
the TOC

The text of the TOC entry will extend beyond the right tab
position, and the TAB will not be performed. Hence you need
to restrict the width of the text frame to the same width as
the TAB position.
This text frame is wider than
the position of the right tab:
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Long entry in the table of
contents ............... 17
Another entry........ 23
Note:
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Tabbing in long lines

This text frame is as wide as
the position of the right tab:
Long entry in the table of
contents..........................17
Another entry ..................23

Rounding errors may require a slightly smaller (-0.05mm) TAB
position than the width of the text frame.
Long TOC (or Index or …) entries may not create the correct
tabbing in the second (or last) line of an entry. One TAB character is used to reach the TAB position in the first line. A second TAB is needed to reach the TAB position in the second
line.
Only one TAB char in the
REF page:

Two TAB chars in the REF
page:

<$paratext>1<$pagenum>

<$paratext>11<$pagenum>

Long entry in the table of
content 17
Another entry.................. 23

Long entry in the table of
content ...........................17
Another entry ..................23

Handling this problem is a side effect of the [i]-frame script
Insert/Update DocToc.

Include table of contents in document
The TOC file generated from a text document (also that of a
complete book) can be referenced from any file including the
one it was generated from.
To get a ‘chapter-TOC’ you create a TOC from the chapter and
then import it to the document. You need to repeat the process to get correct page numbers.
Of course, a plug-in, such as the [i]-frame script Insert/UPdate
DocToc is an elegant solution for this demand.

Generate the TOC
D

1 Generate the TOC according to the method described earlier.
2 You may move the generated file to a different location (to
another directory, for example:
E:\FrameMaker\Course\sample\foilsTOC.fm. Do this only
as the last stage!
Note:

FrameMaker always generates a file into the same directory as
the source file, hence you will get a new file at the old place,
which does not use your fancy formatting. Even importing the
formatting from the ‘old’ file will not help, as the properties
from the reference pages are needed during the generation.
3 At the desired place in the main document import the TOC
document by reference with the settings Body Text flow,
Retain Source’s formatting and Update automatically.
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4 As demonstrated in TOC Imported to nested text frame on
page 8, the TOC may be imported also into text flows
inside an anchored frame to get special appearance.

Update the TOC

1 Double click on the TOC
2 Click Update Now.

TOC imported to the
current flow

Table of contents ..................................................... 1
Generate TOC from a file ...................................... 1
Format the generated TOC ........................................ 3
Standard formatting for the TOC entries ............... 3
Table of contents within a text document .................. 4
TOC imported to the current flow ......................... 4
TOC Imported to nested text frame....................... 5

TOC Imported to nested
text frame

Be aware that tabulation needs room - A two column text
frame within the anchored frame will be too narrow in the
case here.
Table of contents ...................................................... 1
Generate TOC from a file ...................................... 1

Text frame

Format the generated TOC ........................................ 3
Standard formatting for the TOC entries ................ 3
Table of contents within a text document ................... 4
TOC imported to the current flow.......................... 4
TOC Imported to nested text frame ....................... 5

xxx
TOC and current
document have different
layout

Anchored frame

When importing form a file with different layout characteristics of the imported text flow, either
 use the formatting of the target flow. You may need to create new paragraph formats in the target document.
 or use the formatting of the source document. In this case
you may need to adapt the paragraph formats in the source
document.

Example

The source document is a TOC using no side head area in the
layout. The target document (such as this compendium) uses
a layout with side head area. If you want the imported TOC to
use the full the line length (as it is in the source document),
you must define the paragraph formats xxxTOC (either in the
source or the target document) with the pagination property:
“across all columns and side heads”.
Without this setting the source document will use only the
column width (as this paragraph does) and the tabulation may
not be honoured.
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Index creation

Index creation
For a good index you need …
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Experience

You need a lot of experience to create a good index for a general document. FrameMaker can only provide the mechanics,
not the intellectual capacity…
Be prepared to accept ‘holes’ in your index: the fantasy of the
reader only rarely matches that of the author.

Time

 A good index can only be created by many iterations.
 Rules about generating the index must be adapted regularly according to the nature of the document and the readership.
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 FrameMaker APIs allow to speed the creation of an index,
but also these can not provide intelligence.

Quick and dirty index
A quick and dirty index can be constructed from an alphabetical list of paragraphs. Use heading paragraphs (including
table headings, table titles, figure titles).

Create an alphabetic list

Select Special > List of > Paragraphs (alphabetical)…
p If the file is part of a book, you get a prompt. Click Yes.
p In the dialogue Set up Alphabetical Paragraph List move
the desired paragraph types from the right pane to the left
pane.
p Click Set to generate the file named documentAPL.
p For the intended purpose - just list the stuff - you will not
need to format the list similar to what you will do with a
TOC.

Anchor head

In the book select either the first or the last file to place the
generated file properly.
Select Add > List of > Paragraphs (alphabetical)…

D

p In the dialogue Set up Alphabetical Paragraph List move
the desired paragraph types from the right pane to the left
pane.
p Select also, whether you want to place the generated file
before or after the currently selected one.
p Click Add to generate the file named booknameAPL.
p For the intended purpose - just list the stuff - you will not
need to format the list similar to what you will do with a
TOC.
Note:
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In a book you can not have two alphabetical lists with different
paragraph types listed, because they would get the same
name.

Index creation

Rules for keywords
 Choose keywords carefully. Include words which do not
appear in the document, but describe the concepts behind
existing words (so that readers can find ‘grouping words’.
In most cases you will need two types of keywords: objects
and actions which are applied to these objects.
 Keywords are always singular, nominative.
 Provide additional information to the keyword in parentheses, for example “contents (logically)” rather than logical
content. This continues the hierarchy of terms.
 Use highlighting in keywords only for specific purposes.
For example for subroutine names, program parameters.
 Do not forget to specify synonyms and antonyms.
 To define abbreviations you may use a form such as “PDF =
Portable Document Format”. Watch out for syntactic characters in special texts (see Special characters in index entries
on page 9-12).
 Do not abbreviate the main keyword in subentries. Keep the
audience in mind: technical documentation is often read by
non-native speakers (Greeks read English …). The following
is a bad example:
break
bicycle ~ (hydraulic)
truck ~ (pneumatic)

Both comprehension and translation for this stuff is cumbersome.

Define index entries
Index entries are markers of the type index.

Insert an index entry

1 Place the cursor at the desired point. Prefer the end of a
paragraph for the location! Translators will love You!
2 Special > Marker opens the dialogue Marker. The marker
type Index might be selected already. If not, select this
type from the drop down list.
3 If you have selected text, or do so while the Marker dialogue is open (it stays open), the selected text appears in
the box as Marker Text. The marker will be placed in front
of the selection.
4 Change the marker text to your desire and insert the
marker with New Marker.

Edit an index entry

p With Special > Marker open the dialogue.
p See Non-width characters on page A-8on how to select the
marker.
p The dialogue will get the marker text to be modified. The
button now reads Edit Marker.

9 – 10

Types of index entries

Types of index entries
Blanks may be arranged around the colon and the semicolon
which have syntactic meaning in the entries. These blanks do
not appear in the index display. Required blanks (e.g. to keep
words together) must be inserted as \3

Multi level entries

Multi level entries are separated by a colon (:). The following
example will create a main entry abrasion and a sub entry glacial.
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Blanks in index entries

abrasion:glacial
It is good practice to define the possible words for the top
level in advance.

Multiple entries in one
marker

Multiple entries within one marker are separated by a semicolon. This is for example useful to place all permutations of
multi level entries in one marker:
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character:delete;delete:character

Index entry spanning a
range of pages

If an index entry should span a range of pages, the entry must
be placed both on the start-page and on the end-page of the
range:
<$startrange>text of index entry
<$endrange>text of index entry

Page ranges are created automatically, if the same marker text
appears in index markers on successive pages.

Synonyms with no page
reference

Synonyms should not display a page number in the index. To
suppress the page number, add <$nopage> to the index entry:
<$nopage>Erosion. See Abrasion

If these entries are not placed at the end of the Index marker,
you need the following instruction to regain page numbering:
<$singlepage>Abrasion

Highlighting of index
entries

To apply highlighting, such as font changes, to an index
entry, only character formats can be applied. It is not possible
to use ‘local’ formatting with Format > Font etc.
<1highlight>special<Default Para Font> marker text

D

Note:

Highlight page numbers

The term <Default Para Font> can be abbreviated to </>.
To highlight the page number of a particular occurrence of a
key phrase, put the character format at the end of the marker
text (after a blank!):
fairy tales:The Frog King <bold>

This generates a secondary entry:
The Frog King 3, 5, 7

Without the blank the entry will be listed last: 3, 7, 5
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Special characters in
index entries

Since colon, semicolon, < and > are syntactic characters in
Index Marker entries, these characters must be ‘escaped’ for
literal use:
<1highlight>Income</> \> 100 millions
fruit\: vitamins for all
cucumbers\; beans\; cauliflower

You may use standard escaped symbols (see Special characters
in dialogue boxes on page A-4) and symbols from special fonts
by means of character formats:
\F = character (format)
including <ddd_symbols>8</> importing<$nopage>

These definitions create the following index entries:
ƒ = character (format) .......................17-2
including 8 importing

Force sort order

To force a word (e.g. with umlauts) or an entry with punctuation so sort similar to another, use this syntax:
Ägerter[aegerter]
0900 233 455[nine hundred]
\F = character (format)[*]<$nopage>

These definitions create the following order of index entries:
ƒ = character (format)
Ägerter ............................................13-5
Affeltranger .....................................13-4
0900 233 455 ..................................13-5
North pole .......................................17-2

See Index for scripture references on page 9-20 for an application of special sort order.

Index entries for
successive pages

Index entries for successive pages may use the appendix f
(folio) or ff (folia) to the page number:
Italian food ....................................... 13ff
Toscana ............................................. 17f

You need to set up two additional marker types index-f and
index-ff and use them in place of the standard Index marker
types. See Document specific lists on page 9-20.
When generating the index, you include these marker types in
the setup. This creates additional lines on the Reference page
IX (using the paragraph formats index-fIX and index-ffIX)
which you extend to the desired form:
Paragraph IndexIX

<$pagenum>

this is the standard entry

Paragraph index-fIX

<$pagenum>

8

<$pagenum>f

Paragraph index-ffIX

<$pagenum>

8

<$pagenum>ff

[Bernhard Schulze]
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Generating an index

Generating an index
Generate index from
current document

1 Special > Standard Index You are prompted whether to set
up an index as part of a new book or as an independent
file. Click Yes.
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2 In the dialogue Set Up Standard Index the appropriate
marker type is already selected.

3 Hypertext links are a great help and should be ON.
4 Click Set. A new file named name documentnameIX.fm is
created with default presentation of the Index.
If your document file contains definitions for xxxIX paragraphs, these will be used and the generated index may
look already quite well. See Format the generated index on
page 14 for further refinement of the index.
5 Save the file. Do not change the name of this file!
6 You must update this index file after changes in the original document file: in the document file follow steps 1 to 6
from above. Since you already have a index file from step 6,
this will be used for the re-generation.

D

Generate index from
book

Use Add > Standard Index. You are not prompted and continue with step 2 as above (the button will be labelled Add).

Layout of index
Multiple columns

Since index entries are normally shorter than heading texts a
layout with two or even three columns is recommended (See
Index on page 0-9.

Dictionary style headers

For a long index or glossary you may define special page
headers: The first occurring index word on the left hand page
and the last occurring index word on the right page. See Dictionary style headers on page 5-20 for details.
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Format the generated index
1 The layout of the abcIX file is the same as the document
from which the index was generated (in case you generated
the index from a book, the formatting comes from the document with which the book was created).
You may wish to change the layout in the master page IX
(for example, set up two columns).
2 The names of the paragraph formats for the index entries
are built from the levels of the entries: Level1IX, Level2IX.
GroupTitlesIX defines the ‘character headings’.
3 On the reference page named IX you will find the following
lines. The purpose of these lines can be determined from
their format names (here indicated to the left):
Add any spacing between index text and page-numbering
Replace separating character with … for cc-pp numbers
SeparatorsIX
Level1IX
Level2IX
GroupTitlesIX
SortOrderIX
IgnoreCharsIX
ActiveIX
IndexIX

1, 2–3
Define the position of the TAB (for the page number) in the
Level1IX
lines Level#IX. The TAB character to be generated must
Level2IX
be placed on the line with ¶-format IndexIX
Symbols[\];
Numerics[0];A;B;C;D;E;F;G;H;I;J;K;L;M;N;O;P;Q;R;S;T;U;V;W;X;Y;Z
<$symbols><$numerics><$alphabetics>
--–—3._”“
openObjectId <$relfilename>:<$ObjectType> <$ObjectId>
<$pagenum>

Add <$autorange> to automatically combine entries.
Enter any ‘prefixes’ to the page-number here (not in the Level#IX lines), if
you need one. In particular, insert the leading TAB here. For example you
may set up this line (format IndexIX) as:
1<$chapnum>\+<$pagenum>

4 The basic formatting concerns the index entries with the
paragraph formats LevelnIX. Format them according to
your needs (Paragraph Designer, click Update All)
5 You may also wish to change the appearance of the Group
Titles, in particular the Font and the Size, Space above,
Space below and probably apply a line before the paragraph.
6 You can combine entries under one group title with these
definitions in the GroupTitlesIX paragraph:
A-D[A];E-H[E];I-L[I];M-P[M];Q-T[Q];U-Z[X]

The symbols in brackets, such as [\] or [0] specify the sort
order for symbols and numbers. The same method is used
for the alphabetic character groups.
7 You may also wish to change the appearance of the page
number (insert a tab character in front of <$pagenum>. The
tab position, however, must be defined in the paragraph
format of the LevelxIX lines.
8 To avoid spell checking of index entries set the language in
the ¶ format to none for GroupTitlesIX and LevelnIX.
Note:
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Changes in the formatting become visible immediately in the
reference pages and in the body pages. Changes of the genera-

Format the generated index

tion template (e.g. the insertion of the TAB character in front of
the page number) become visible only after you have re-generated the index.

Sort order

Sort order is defined by the building blocks <$symbols>
<$numerics> <$alphabetics>. They are defined as follows. Note
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the grouping by blanks!

Note:

Change sort order

0 1 2 3 4 5 6 7 8 9

<$alphabetics>

AÁÀÂÄÃÅaáàâäãåª Bb CÇcç Dd EÉÈÊËeéèêë
Ffƒ Gg Hh IÍÌÎÏiíìîï Jj Kk Ll Mm NÑnñ
OÓÒÔÖÕØoóòôöõøº Pp Qq Rr Ss Tt
UÚÙÛÜuúùûü Vv Ww Xx YŸ yÿ Zz

<$symbols>

All other characters in ASCII order

The definitions must not contain line breaks. Let FM wrap the
lines (as in $alphabetics here).
You can exchange the order of the building block, e.g. to sort
symbols before the alphabetic characters.
To change the order within a building block, you must completely redefine the block.
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<$numerics>

 When replacing <$alphabetics> with individual characters,
separate the letter groups with a space.
Letter groups - for example, F f ƒ - are characters that are
sorted as if they were the same character, unless they are
the only characters that differ in the sorted text. In that
case, the first character in the string appears first.
 If you replace <$symbols> with individual characters, use a
backslash before the angle bracket symbols (\< and \>).
 To indicate that a letter pair should be sorted as a single
character, specify the letter pair between angle brackets (<
>) - for example, CÇcç<CH><Ch><ch>. In this example, all the
characters or letter pairs are in the same letter group (the
letter C). The letter pair CH is sorted after the letter C, and
uppercase letter pairs are sorted before lowercase letter
pairs.

Example definition for
SortOrderIX

<$symbols><$numerics>AÁÀÂÄÃaáàâäãª Bb CÇcç Dd
EÉÈÊËeéèêë Ffƒ Gg Hh IÍÌÎÏi íìîï Jj Kk Ll Mm NÑnñ
OÓÒÔÖÕoóòôöõº Pp Qq Rr Ss Tt UÚÙÛÜuúùûü Vv Ww Xx YŸ yÿ
Zz Åå Øø

More sort orders

The [i]-frame script Change Index Sort Order can set up
GroupTitelesIX and SortOrderIX for all FM-8 languages.
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Include index in document
Follow the rules defined for Include table of contents in document on page 9-7.

Index entry does not show up in index
The marker dialog always displays the last used marker type which may be something else than Index. Always check the
marker type before entering text for an index entry. You may
change the marker type and then click Edit Marker at any
time.
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Arbitrary lists

Arbitrary lists
Especially in scientific publications various lists are required,
for example, lists of:
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Lists

Authors
Formulae
Figures
Tables
Diagrams
Bibliographic references (see Bibliography with EndNote on
page 7-26).

Some of these lists can be generated without further work,
others need the insertion of markers into the text.
When FrameMaker generates these lists, it produces a file,
which later can be formatted to the desired needs and also be
imported to another document.
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These files can either be produced from the current document
or from a FrameMaker book.
Indices

In an index you can specify the sorting order, the grouping of
index characters etc. (in the appropriate reference page).

Note:

Lists do not allow to group similar entries into one with a list of
page numbers. If you want to avoid multiple entries of same
kind (e.g. three times the same author name with different
page numbers) you must use an index.

List of tables
Tables may bear a title, which is associated with paragraph
style (in this compendium: ttn-table-title-numbered).
Hence a list of all tables is a list of all paragraphs of the format(s) used for the table titles.
To generate the list of tables,

D

1 Open the book file (or the file from which you want to generate the list)
1 Special > Standard Index You are prompted whether to set
up an index as part of a new book or as an independent
file. Click Yes.
2 In the dialogue Set Up List of Tables move the appropriate
paragraph format(s) to the left. FrameMaker automatically
recognises a format TableTitle.
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Arbitrary lists

3 You may wish to generate hypertext links: click the selection box.
4 Click Set. A new file named name documentnameLOT.fm is
created with default presentation of the List.
If your document file contains definitions for xxxLOT paragraphs, these will be used and the generated index may
look already quite well. See Format of the generated TOC on
page 6 for further refinement of the index.
5 Save the file. Do not change the name of this file!
6 You must update this list file after changes in the original
document file: in the document file follow steps 1 to 6
from above. Since you already have a index file from step 6,
this will be used for the re-generation.
7 You may wish to adapt both the formatting in the generating pattern (on a reference page named LOT). See Format of
the generated TOC on page 6 or Format the generated index
on page 14 for details.
You can import the generated file (referenced or copy) into
the document:
Table 1: Control characters in the text ................................................................1 - 3
Table 2: Hierachical numbering...........................................................................4 - 6
Table 3: Snapshot from log of PC DDD-KLD ........................................................5 - 8
Table 4: ...........................................................................................................5 - 10
Table 5: The title can only be set in unrotated mode of the table ......................5 - 10
Table 6: Table with straddled cells ....................................................................5 - 13
Table 7: Building blocks for system variables ......................................................7 - 4
Table 1: Keyboard shortcuts (english and german FrameMaker) ..........................A - 2
Table 2: Special characters in dialogues ..............................................................A - 3
Table 3: Wildcard characters in Find dialogues ....................................................A - 3
Table 4: Insert special characters with CTRL+q....................................................A - 4
Table 7: Comparison between FrameMaker and Word for Windows .................... C - 3
Table 9: Imported from Excel and manually adapted.......................................... D - 8

Specials with these lists

Paragraph numbering may restart at 1. In this compendium
(book) the appendices start again with 1 (A) to allow for easy
insertion of additional chapters.
You may have empty paragraphs (see line with Table 4 above).
To fix this, go to that table and either fill in the title or
remove the title (it may have no significance).
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List of figures

List of figures
Since FrameMaker does not provide a native method to display figures with titles, tables are used for this purpose.
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Hence a list of figures is a list of tables of a specific paragraph format (e.g. ftn-fig-title-numbered).
With Special > List of > Figures you specify the paragraph
format(s) to be included. See Figures in FrameMaker on
page 6-9 for details how to set up and use such tables.

Index of authors
An index of authors in an index of markers of type Author. To
create this index:
1 Insert markers of type Author (Special > Marker) in the
documents at an author name (selected text will be copied
to the Marker dialogue).
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2 In the document or the book file add the generated index
with Special > Index of > Authors…

3 In dialogue Set up Author Index you move the type(s) of
markers to be included from the right pane to the left pane
(Author is already selected).
4 Click Set. A new file named name documentnameAIX.fm is
created with default presentation of the Index.

D

If your document file contains definitions for xxxAIX paragraphs, these will be used and the generated index may
look already quite well. See Format the generated index on
page 14 for further refinement of the index.
5 Save the file. Do not change the name of this file!
6 You must update this index file after changes in the original document file: in the document file follow steps 1 to 6
from above. Since you already have a index file from step 6,
this will be used for the re-generation.
7 You may wish to adapt both the formatting in the generating pattern (on a reference page named AIX). See Format of
the generated TOC on page 6 or Format the generated index
on page 9-14 for details.
You can import the generated file (referenced or copy) into
the document:
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Arbitrary lists

Gulbins...........................................................................4
Obermayr .......................................................................4
.ries GmbH .....................................................................5
Sandybrook Software ......................................................5
Thomas Glombik ............................................................5
Systec.............................................................................5

Index for scripture references
Sometimes you need to create an index order which is different from the titles or names at hand. For example, to set up
an index for a bible which is sorted according to the biblical
order rather than the names of the books.
This can be achieved by adding the sort order construct to the
index entries using a numbering scheme23): 2 figures for the
biblical book, 3 figures for the chapter and 3 figures for the
verse (all with leading zeroes):
Genesis 1, 1 [01001001]
Psalms 119:105 [19119105]
Hebrews 3:5 [54003005]

Thus these will appear in the order Genesis, Hebrews, Psalms
in the Index.
To make this practical, you could use FrameScript to read the
references in the markers and add the appropriate bracketed
text to the end of each marker. The script would contain a list
of the book names.
[based on Rick Quatro; rick, frameexpert, com]

Document specific lists
Assume you are describing a large archeological site. You may
wish to provide the reader special lists:
 Strati (layers of findings, thus epochs)
 Artefacts found (pottery, fibulae, weaponry etc.)
 Locations (house, place, garden, cemetery etc.)
 and so on.
To create these lists you need markers of appropriate type
(stratus, artefact, location) and insert them at the proper
place.
1 Define a new marker type with Special > Marker... and
select Edit... from the list of Markers.
2 In the dialogue Edit Custom Marker Type specify the
name of the new marker type (e.g. artefacts) and click
Add to add it to the list of markers.
3 Now you can use this marker type similar to the marker
types defined by FrameMaker.
See also Arbitrary markers on page 7-10.
23 The Bible comprises 24 books for Jews, 66 for Protestants, 73 for Catholics (including also the apocryphal (deuterocanonical books), and 78 for
most Orthodox Christians. The numbering order differs significantly.
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Parts list

Parts list
For parts lists and similar applications the following method
can be applied:
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0562.3775
0562.3321
Text frame

1 Place the numbers in text frames outside of the graphic or
photograph.
2 Use a special paragraph format for the part-numbers in the
graphics, for example part-number. This must be in the paragraph catalog.

E:\FM-course\handout\generated_docs.fm

3 Create an alphabetic list of these numbers with Special >
List Of > Paragraphs
4 In the dialogue Set Up Alphabetical Paragraph List specify the paragraph format, which you want to be listed (in
our example: part-number). Click Set
5 A file with the name documentAPL is created:
0562.3321 80
0562.3775 80
In the first part of this list (in this example it is just the first
line) all pages are listed on which the paragraph type could be
found. You may wish to remove these lines after generation
(if you remove the generating element - Level1APL - from the
reference page, it will be recreated at the next generation).
To format this file to your needs apply the same techniques
as described for formatting an index. The elements on the reference page APL indicate their meaning by their format
names.

Support your work with lists
D

To support your document development you may use the following lists:
 List of References: imported graphics to clean out all
unused stuff from the directories before you distribute.
 Alphabetic list of paragraphs (only headings) to get a starting point for an index.
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Building blocks on reference pages

Building blocks on reference pages
[www.microtype.com]
When setting up the generating template for an automatically
generated document, some restrictions apply to the building
blocks which can be used. It is, for example, not possible to
get the contents of a specific paragraph type with the building block <$paratext[paraname]>. Nothing will be generated.
Generally the building blocks which control index setup or
hypertext are not listed in this table:
Generated file

Default
suffix

Source

Order

Table of contents

TOC

paragraphs

collected

List of figures

LOF

paragraphs

collected

List of tables

LOT

paragraphs

collected

List of paragraphs

LOP

paragraphs

collected

Alphabetical list of ¶

APL

paragraphs

sorted

List of markers

LOM

markers

collected

Alphabetic list of markers

AML

markers

sorted

List of references

LOR

references

collected

Standard index

IX

markers

sorted

Author index

AIX

markers

sorted

Subject index

SIX

markers

sorted

Index of markers

IOM

markers

sorted

Index of references

IOR

references

sorted

Composite document

CMP

documents

merged

Summary (summary.fm)

-

changes

collected

Supported building blocks
specific to file

valid in all files

Lists
<$paratext>
<$paranum>
<$paranumonly>
<$paratag>

<$markertext>
<$referencename>
<$paratext>

Indexes

<$pagenum>
<$chapnum>
<$volnum>
<$relfilename>
<$fullfilename>
<characterformat>
</>

<$autorange>
<$nopage>
<$paratext>
<$autorange>

Document reports

Special remarks
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not applicable

<$paratext>

This retains forced line breaks (\n) and all
character formatting if these were applied
with character tags. Other character properties are not kept.

<$markertext>

The complete marker text is reproduced.
This includes special characters and indexspecific building blocks.

references

These include condition tags, external
cross-references, unresolved cross-references, imported graphics and text insets
(also unresolved). From font properties
only the first unique item on the page is
taken.

</>

short for <Default ¶ Font>

Adding text to generated document

Adding text to generated document
Sometimes short introductory text is required in generated
documents, such as:
 Scope of table of contents

2011-05-11

 Explanation of syntactical constructs in an index
Note:

The procedure is as
follows:

You can not start with text and then ‘add’ a generated list to a
document. You always must first generate the list into a new
document and then add the introductory text.
1 Generate the list or index
2 Locate the cursor at the very beginning
3 Enter text and format it accordingly

Note:
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Introduction to TOC

Do not touch the first generated line, you may destroy the ‘critical flag’!
You may wish to introduce the Table of Contents with some
remarks, as done in this compendium:
Please note: This compendium does not describe all features
of FrameMaker. You still may need to look into the help system. On the other side the author puts emphasis on tips
which are helpful for the creation and maintenance of documents both in the technical and scientific area.
Conventions used in this manual...................... 0 - 2
PDF version .................................................... 0 - 2

Introduction to index

You may wish to precede the generated text with some explanations and synonym definitions, as done in this compendium:
=
8
…

used to explain abbreviations.
at beginning of line: see also. Else: points to synonym.
repeats main keyword

Symbols
¶ = paragraph (format)
ƒ = character (format)

D

Headings in generated documents
Normally you can not use the standard heading formats in a
generated list, because they will be used to generate the list …
To format a heading with the appearance of, for example,
2heading, create a new paragraph format with the same properties, but name it 2heading-notoc and do not include this
name into the generation of (for example) the Table of Contents.
Note:

9 – 23

Do not name it -noTOC. This will confuse FrameMaker and the
heading will be removed each time you regenerate the file.
This is because all generated ¶-formats in a Table of Contents
end with the suffix TOC (with upper case characters). Instead
use a format name something-notoc.

Working in a multilingual environment

Working in a multilingual environment
You may come across the following situation:
 A documentation company using the French version of FM
has developed a template and created documentation in
various languages, for example, a maintenance manual.
Since they are ‘French’ the template uses style names such
as texte, titre-1 and titre-2. The table of contents file
is named xyzTDM.fm and the relevant style names are
titre-1TDM and titre-2TDM (TDM = Table De Matières, see
Name suffixes on page C-11).
 It is not a problem for you using the German version of FM
to maintain such a book and re-generate the table of contents. Everything works fine.
 But when you use this ‘French’ template for a new FM book,
you are not happy with the results when adding the table
of contents to the book. Although you set up the TOC file
with suffix TDM, the existing style names titre-1TDM and
titre-2TDM are not used by the process. Instead new style
names titre-1IVZ and titre-2IVZ (IVZ = InhaltsVerZeichnis) are defined.

How to get a correctly
formatted contents file
with the German
FrameMaker

1 In your TDM file on the reference pages set up an addtional
new page. If you already have a page TDM then call the new
page IVZ.
2 Copy everything from the TDM page to the new IVZ page.
Change the name of the text frame to IVZ.
3 Copy the first paragraph at the top of the IVZ page:
openObjectId <$relfilename>:<$ObjectType>
<$ObjectId> Insert it 3 more times. Assign them these paragraph names (watch the spelling!):
ActiveIVZ
AktivIVZ
ActiveTDM
AktivTDM

This way the contents file will always work, no matter,
whether someone renames a TDM file to IVZ or vice versa.
4 Copy alle headings with TDM and insert them below the TDM
headings. Rename the TDM in these paragraph formats to
IVZ.
5 Repeat this on the TDM page.
Now you have a contents file which you can always use no
matter whether FrameMaker would create contents files with
TDM or IVZ. Just put your contents file template into the same
folder of the book with its contents file. Then rename your
template to the name of the existing contents file (which you
have deleted). Update the book.
However, in my opinion FrameMaker should be able to do
such a mapping (TDM <-> IVZ <-> TOC) internally. Let's see what
we get in version 10. 24)
24 Reported by Dr. Winfried Reng on the Framer’s list 2009-11-23
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Generate Acrobat (PDF)

Overview
This chapter aims at Acrobat 8. However most of
the features described are also available in older
versions.
FrameMaker is well integrated with Acrobat. Bookmarks are automatically generated from specified
headings and you can set some document properties.

Contents
Introduction ........................................................... 2
Generate PDF from a FrameMaker document ............ 4
Acrobat Reader (Adobe Reader) ............................. 12
Refining the PDF output ........................................ 13
Modify the PDF file with Acrobat ............................ 15
Some problems with PDF files ................................ 17
Viewing 3D objects ............................................... 18

Introduction

Introduction
PDF (Portable Document Format) is considered as the universal format for exchange of formatted documents.
 PDF preserves the exact layout, including the fonts and
images.
 PDF can be printed to any device for which the user has a
printer driver.
 PDF allows security against unwanted modifications or
even printing.
 With the full Acrobat product, a PDF can be modified (text
lines, cropping pages, sticky notes, generation of thumbnail images of the pages, replacing pages, extracting pages,
exchanging images etc.).

PDF versus Postscript
PostScript is a procedural programming language which is
interpreted by a RIP (raster image processor) to generate the
contents of pages (lines, images, etc.). A PostScript file may
contain device specific commands, such as ‘select papertray’.
A PostScript file always must be handled (interpreted)
sequentially. There is no means to get just page 17 out of 29
pages, because the needed resources (e.g. a font) may be specified previously in the file.
PDF is an object oriented data format which provides direct
access to the pages. Pages are completely independent.
Resources are referenced and may be defined anywhere in the
file.
Since about 2003 more and more printers can handle PDF
directly and scanners can create PDF directly (via SW).

PDF depends on a target
The above is the principle and told you by Adobe marketing.
However, real life knows trouble and pitfalls:
 A PDF file is targeted to specific output channels (display
screen, web, office laser printer (B/W), high quality colour
laser printer, plate making process for offset printer etc.)
 Due to the immense number of possible combinations, well
tested sets are named (e.g. Jaeggi Digiprint). Acrobat comes
along with some names. But even these well tested sets are
not universal at all.
 Properties of printers (HW) and processes differ very much.
Hence it is common practice to stick to one print shop, get
his well proven PDF parameters and create the PDF with
these. Even though test prints are recommended.
 PDF is created using a number of parameters when setting
up the job options in the Acrobat Distiller. There are many
choices in each category (General, Compression, Fonts, Colour, Advanced) of options. For example:
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Predefined Job Options

Option category

Parameter

Internet (Jäggi)

Digital printing (Jäggi)

General:

Compatibility

Acrobat 4.0 (PDF 1.3)

Acrobat 4.0 (PDF 1.3)

Format

Optimise for fast Web view

-

Resolution

2400 dpi (will only be used in printing)

2400 dpi

Colour images

Bicubic downsampling to 72 dpi, automatic compression, low quality

Bicubic downsampling to 150 dpi, automatic compression, medium quality

Monochrome

Bicubic downsampling to 150 dpi,
CCITT group 4 compassion

Bicubic downsampling to 600 dpi,
CCITT group 4 compassion

embed all fonts; subset embedded
fonts below 35%

embed all fonts
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Compression

Fonts
Colour

Conversion

convert all to RGB

leave colours unchanged

Advanced

Options

Convert gradients to smooth shades.
Preserve overprint settings. Allow PS
file to override job options; process
DSC comments …

Convert gradients to smooth shades.
Preserve overprint settings. Allow PS
file to override job options. Save original JPEG images in PDF if possible.
process DSC comments …
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Predefined Job Options
Print shops may require you to use their job option if you
want your PDF to be printed on their equipment.

References
www.publisher.ch/
www.microtype.com/
www.prepress.ch/

Adobe Acrobat tips
Jaeggi Distiller settings

publisher is the Swiss journal for electronic publishing and
the publication of the Swiss User Group of Adobe products.
Shlomo Perets is a worldwide recognised expert in FrameMaker & PDF.
Mr. Jäggi is an EU wide recognised expert in PDF and provides
a good set of JobOptions for the Acrobat Distiller on his web
site.
http://www.adobe.com/products/tips/acrobat.html
http://www.prepress.ch/d/pdf/web/settings.html

Create user friendly PDF
D

Read in www.microtype.com/Hmmms.html about common
mistakes and omissions when generating PDF. Even files from
reputed companies lack usability.
Enjoy the human reader with a complete PDF – not just a simple text file.!
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Generate PDF from a FrameMaker document

Generate PDF from a FrameMaker document
When You have installed FrameMaker properly, you where
asked at installation time to install Acrobat also. I hope you
have done so and have available the Adobe PDF printer (formerly called Distiller Printer or Acrobat Printer) in Control
Panel > Printers and Faxes.
Note:

The generated PDF can be printed to any printer, not only to a
PostScript printer. Non-PostScript printers however may create
deviations from the original look. You print with the application Acrobat, Acrobat Reader (Adobe Reader) or similar.

Save as PDF
With FrameMaker 7 a reliable procedure to save PDF directly
is introduced. The standard process (generate PostScript file,
distil) is performed in the background invisible to the user.
Note:

Create PDF

Saving as PDF shall be Your standard method to create PDF
output from FrameMaker. Use the other method only as fall
back methods.
1 Use File > Save As PDF…
2 In dialogue PDF Setup specify the Acrobat job options and
all other necessary items according to Set up PDF properties
in FrameMaker on page 10-5.
3 Start the process with Set

Note:

Save for review

Do not Save as PDF to a diskette or small USB stick. The intermediate tps file will not fit onto it - and this intermediate file
can not be placed at another place as the final PDF file.
You may save to a hard disk and later move the generated PDF
to a diskette or USB stick.
If you have FrameMaker 8 installed as part of the Adobe Technical Publication Suite (and also Acrobat 8 or later installed)
then you can Save As PDF (Send for Review). After the generation of the PDF the file is opened in Acrobat and the Wizard
for Send by Email for Review is started.25).
p Select the PDF to be sent for review. You get a warning for
PDFs larger than 5 MB.
p Enter the e-mail addresses of the reviewers. You may open
the Windows Address book for this. They must at least
have Acrobat 6.0 or Adobe Reader 7.0 available to open/
read/comment the PDF.
p An invitation text (the e-mail text) is already defined. You
my wish to modify it.
p Click Send Invitation in the final step.

Note:

There is no mechanism to import the comments applied by the
reviewers into the PDF in FrameMaker 8. FM-9 has it!

25 It may be necessary to fill in some admin fields, such as name and organisation at the first run.
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Standard process with Distiller

Standard process with Distiller
The overall process to generate a PDF consists of these steps:
1 Set up the PDF properties in the FrameMaker document or
via the book for all files in the book.
2 Produce a PostScript file either from a single document or
from the complete FrameMaker book.
2011-05-11

3 Start the Acrobat Distiller and select the appropriate set of
job options (or specify your own).
4 Open the PS file in Distiller. The distiller starts the process.

Set up PDF properties in FrameMaker
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In Format > Document > PDF Setup... you set parameters
which are handed over to the distilling process in the PostScript file. Four categories of properties can be set by means
of tabs.
If you want the same settings in all files of a book, open the
book file and use File > Print Book… and there the button
PDF Setup.

Settings

In this pane you select the set of Distiller parameters (Joboptions) which are located in the Distiller installation directory. It may be desirable to create an own set of Joboptions.
See Modifying Distiller parameters on page 10-9.
p You also specify how the PDF document should open initially.
p The setting of Registration marks is only necessary if you
want to print on smaller paper and see crop marks to trim
the paper. This is similar in the Print dialogue.
p Further parameters normally need no change from the
already set values.

Bookmarks
In this pane you specify which items you want to have in the
Table of Contents for the left pane of Acrobat Adobe Reader.
D

p Define bookmarks from the heading levels with the <--- and
---> arrows. You can move all items from the left pane to
the right one (or vice versa), by holding SHIFT and clicking
the ---> (<---) button.
p Set the appropriate level of the bookmark with the << and
>> buttons.
p To have the bookmarks closed to the first level, enter 1
into the drop-down list Bookmarks expanded through
Level. Entering 0 to close to the top level works only for a
single document, not for a FrameMaker book.
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Generate PDF from a FrameMaker document

Tags
A tagged PDF file displays a logical document structure
according to your settings. This allows to re-format the PDF
file for alternate output devices such as screen readers. It
also allows to export the PDF correctly to RTF.
If you have set attributes for anchored frames (see Set object
attributes on page 6-18) this information is also carried over
to tagged PDF.
Either leave the box Generate Logical PDF Structure
unchecked, or set up the same structure as in category Bookmarks.

Links
Normally check Create Named Destination For All Paragraphs. (although unchecking this will create a smaller PDF
file).
This box must be checked if you want to create links from
other documents to this document in Acrobat.

Document Information

You may set file information for the book file or any document file. This information can be accessed by an XMP conforming application.
This information is saved within the FrameMaker file, but in a
standardised format. You can see it, for example, when opening the FrameMaker file in a text editor.
To define this information, select File > File Information… in
the book file (you need to select the top book file listed
explicitly) or any other file in the book or you are already
within a document file.
Author

Author(s) of document, including company

Title

Title of document

Subject

You may wish to add data here

Keywords

These become relevant if the PDF is combined with others on a CD for example.

Copyright

Place a copyright statement here.

Web Statement

A notice pertaining to the use of the document on the web, e.g. a disclaimer

Job Reference

Author’s affiliation

Marked

Select Yes for copyrighted document

In Acrobat or the Acrobat Reader you display this information
with File > Properties > Description.
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Generate the PostScript file

Generate the PostScript file
In File > Print or File > Print Book you specify standard
items, such as Page Range, and whether you want to print all
or just the even (odd) pages. Pay attention to the following
parameters:
Printer

Registration MarksSelect None.

2011-05-11
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Select the Adobe PDF printer.

Thumbnail Rows Do not check this (only useful on paper).
Copies

Set to 1 (or you get a mangled PDF).

Scale

Set to 100%.

Print to File

Click Check. You may change the proposed
file name and path.

Save Book As

Select Single File for generation of PostScript for distilling with Acrobat. Only in
this mode correct bookmarks and hyperjumps can be created.

Gen. Acrobat Data Check this. If not yet done, you may set
the properties with PDF Setup.
Note:

PostScript files may become very large (the 350 pages of this
compendium produce about 50 MB due to many screen shots.
Hence you may wish to print to your TEMP folder. The final
PDF to be printable on a desktop laser printer (600 dpi) is only
about 7.0 MB.

Distil the PostScript file
Acrobat Distiller “converts” the PS input to the PDF. The various parameters controlling the process are combined into
sets, which are plain ASCII files residing in the Acrobat Distiller directory (e.g. in H:\Adobe\Acrobat
8\Acrobat\Settings\).

Distiller setting

Acrobat-8 installs the following settings:

D

High Quality Print
Oversized Pages
PDFA1b 2005 CMYK
PDFA1b 2005 RGB
PDFX1a 2001
PDFX1a 2003
PDFX3 2002
PDFX3 2003
Press Quality
Smallest File Size
Standard

According to the Swiss PDF guru Jaeggi the Distiller settings
for version 7 are still valid for Distiller 8. These Joboptions
are more target-oriented (e.g. web, CD-ROM).
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Generate PDF from a FrameMaker document

Distil the PostScript file

Open Acrobat Distiller (you will have this on your system only
if you have installed the Acrobat application, not just the
Acrobat Reader - which is free).
1 Select the proper set of job options, e.g. High Quality Print
depending on your target. It may be desirable to create an
own set of Joboptions. See Modifying Distiller parameters on
page 10-9.
2 You may check the settings in Settings > Joboptions, especially to set security options, which can not be saved in
joboptions.
3 Select the PostScript file with File > Open and specify
where to save the PDF file.
4 As soon as you click Open the distilling process starts. The
PDF is generated into a temporary location and then moved
to the save directory. A log file is displayed and also saved
in the same directory:
Start Time: 2005-11-30 at 15:17:32
Source: acrobat.ps
Destination: G:\Filetype_examples\acrobat.pdf
Adobe PDF Settings: C:\Documents and Settings\All
Users\Documents\Adobe
PDF\Settings\J_Internet_D7P.joboptions
%%[ ProductName: Distiller ]%%
%%[Page: 1]%%
%%[LastPage]%%
Distill Time: 3 seconds (00:00:03)
**** End of Job ****

Note:

Security options

Be aware of the Distiller habit to keep its dialogue contents
between sessions! Always check the save location!
Security options must set in Distiller prior to distilling a file.
Hence the automatic process by FrameMaker does not allow
to set security options.
You may, however, apply security options to the generated
PDF by means of the Acrobat application. See Security settings
on page 10-15.
Password

Write it down and store the note in a safe
place if you set a password!

Permissions …

These check boxes can be set to prevent
printing of the file, changing content or
adding / changing notes using the Acrobat
application.

The encryption level is low for compatibility with Acrobat 3.
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Modifying Distiller parameters

Modifying Distiller parameters
Note:

This section is about Distiller 8.1
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The standard Distiller Joboptions may not be the optimum
for your case. If you prepare a PDF to be printed in a commercial print shop you may need to use their Joboptions – or they
will not guarantee proper printing of your job.
I you have prepared all your images already along the lines of
Preparing graphics for import on page 6-4 you preserve your
work by special settings.

Setting up new
Joboptions

In Distiller select the most fitting set of Joboptions (for example, Press Quality) and then Settings > Edit Adobe PDF Settings and save the file with a new name, e.g. TechDoc DDD.
In the description field enter text describing the options you
want to create.
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Category General

Check all other parameters whether they fit your needs.

D

Category Images

Since you have prepared all your images to the right size, they
should not be compressed again with a lossy method. Set the
values to these:
Colour Images
Grayscale Images
Monochrome Images

Category Fonts

Off

Compression

ZIP

Downsample

Off

Compression

ZIP

leave settings as is

Most time the values are already these:
Embed all fonts

10 – 9

Downsample

active

Subset embedded fonts

active

When embeding fails

Cancel job

Generate PDF from a FrameMaker document

Category Color
Adobe Colour Settings

Setings File

None

Color Management Policies Convert all colors to
CMYK
Document rednering intent Preserve

Device Dependent Data

Category Advanced

Leave as is (or ask your
print shop)

Preserve CMYK values for
calibrated CMYK colour
spaces

activate

Leave as is (or ask your print shop)

If you have graphics in either emf/wmf format or from a CAD
systems, you may wish to set the first parameter:
Options

Category Standards

Working Spaces

Convert smooth lines to
curves

activate

Save original JPEG images
in PDF if possible

de-activate

Leave the top selection to None.
Leaving the Settings dialogue with OK will save the new settings.
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Errors reported in the Acrobat log file

Errors reported in the Acrobat log file

2011-05-11

Missing fonts

If you have both PostScript fonts (Type 1) and TrueType fonts
(Type 3) installed, then the following setting may be essential
to find all fonts. For example, TimesRomanPST may not be
found.
In Acrobat Distiller > Settings > Font Locations Deactivate
Ignore TrueType versions of standard PostScript fonts.

Other problem

At the end of the log you may see error messages such as:
% [ Warning: The following Names in Name Tree Dests were
not defined ] %
G14.1026542
G15.1006357
G16.1005762
M9.17866.chaptertitle.1

Even though you have no undefined cross references in your
document(s) you may get these errors.
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MIF helps in most cases

Normally you can get rid of these problems by
1 Save the file creating the error as MIF, close file without
saving.
2 Open the MIF file and save it as ordinary FrameMaker file.

Severe problems need
fixes in the MIF files

Severe problems not disappearing with the method mentioned before need removal of items in the MIF file (expert
only!)
<ParaLine
<TextRectID 32>

<Marker
<MType 9>
<MTypeName `Cross-Ref'>
<MText `17866: chapter-title: 1'>
<MCurrPage `First'>
<Unique 1010926>
> # end of Marker

<<<------

> # end of ParaLine

D

The highlighted part (a dubious marker) must be removed.
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Acrobat Reader (Adobe Reader)

Acrobat Reader (Adobe Reader)
Acrobat reader (which is free at the Adobe Web site) displays
PDF files. The reader can be set up to integrate as plug-in into
a web-browser.
Since ISO 32000 is equivalent to Adobe's PDF 1.7 (Acrobat 8),
Adobe is not producing a PDF 1.8 Reference. The Adobe Supplement to ISO 32000, Base Version 1.7, Extension Level 3
describes Adobe's extensions and implementation notes for
Adobe Acrobat 9.0.

Acrobat Reader window

 In the left pane Bookmarks (table of contents) or Thumbnails (small page images) can be displayed.
 The right pane contains the document to be viewed.

Bookmarks

If you have set up the PDF properties in FrameMaker, you get
a complete structure of the headings similar to the tree in file
explorer.

Cross references

I you have cross-references in the document (X-ref markers in
FrameMaker), these are active (PDF is a hypermedia-format).
FrameMaker generated files (Table of Contents, Index etc.)
can contain live links, if you have specified so.

Web links

Web links (see Web links on page 13) are active in PDF, if you
set up the browser in Edit > Preferences > Internet in Acrobat Reader.

More functions

Acrobat Reader 8 allows to insert comments (if security settings of the document allow) and hence supports reviewing.
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Refining the PDF output

Refining the PDF output
Presentation formats
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It may be desirable to set up a different layout for the on-line
distribution (landscape orientation, A5)

Hypertext commands in FrameMaker
Not all FrameMaker hypertext commands have an adequate
function in Acrobat (see Types of hyperlinks on page 7-20):
Frame Hypertext commands

PDF equivalent

Remarks (menus refer to the Acrobat Reader)

alert, alerttitle

Note

The note is closed initially

exit

-

Use menu File > Exit

gotolink, gotolink firstpage, gotolinkfit- Reference
win, gotopage, nextpage, openlink, openlinkfitwin, openpage, previouspage

File name suffix FM will be changed to PDF

matrix (of buttons)

-

Replace with multiple references

message

-

Works only with Frame API clients

message system, message winexe

-

Replace with program launch

message URL

Weblink

May refer to any file type the browser can handle

newlink

named destination

OK since Acrobat 5

opennew

-

Acrobat can not create a new document

popup

-

Not possible in Acrobat 5

previouslink, previouslinkfitwin

-

Use menu View > Go Back

quit

-

Use menu File > Exit

quitall

-

Use menu Window > Close All

Web links
From PDF to an URL
To create a link (in)to a web-page, use the FrameMaker hypertext command Go to URL:
1 Select the text which should become the hotspot in the PDF
file. You may wish to specify a character format for this.

D

2 In Special > Hypertext select the command Open URL
3 At the cursor position (after a blank in the dialogue) type
the complete URL (including the protocol), e.g. http://
www.daube.ch/docu/fmaker00.html#printing
4 Click New Hypertext Marker.

From HTML to PDF

To jump from HTML directly to particular page of a PDF you
need to add the desired action after the # in the URL:

Named destination
Page

<a href="http://www.adobe.com/prodlist.pdf#DigitalImaging">
<a href="http://www.adobe.com/prodlist.pdf#page=72

See also Named destinations on page 10-14.
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Refining the PDF output

Article threads
Do not check this option in Format > Document > Acrobat
setup. Checking this option generates Acrobat articles in the
same sequence as the text frames. A text flow creates an
Acrobat article.

Named destinations
 For all cross references in FrameMaker (also those automatically generated in TOC or index) named destinations
are created in the PDF. These may look different at each
generation and hence are only of limited use for links into
the PDF.
 Use the Frame hypertext command newlink name for special destinations (e.g. within a page). However, the name
needed in a HTML href statement is that what you find via
the Acrobat View > Navigation Pane > Destinations function: Mnnn.yyy.newlink.name.
See also Named destinations in PDF on page C-16.

Thumbnail pages
Thumbnail pages are created on the fly by the Acrobat Reader
or Acrobat. Just click on the Pages icon in the navigation pane
of the Reader or Acrobat.

Optimising for Internet distribution
The following is only relevant, if you do not have version 8
JobOptions. In these the option is already set.
In the Distiller Settings > Edit Adobe PDF Settings > General
activate the option Optimise for fast Web view.
The method “Byte serving” allows the server to send pages of
the document out of order, according to the requests from
the browser. The user can click into the Table Of Contents as
soon as it is visible and jump to any page.
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Modify the PDF file with Acrobat

Modify the PDF file with Acrobat
For more sophisticated features, such as linking between various PDF documents, link to HTML files etc. you need deep
knowledge of the pdfmark statements which can be embedded
into the PostScript file by FrameMaker.

2011-05-11

Note:

Functions described in this section require the Acrobat tool, not
just the Acrobat Reader.

Crop pages
Sometimes it is necessary to produce the FrameMaker document on A4 paper with large margins. This does not look nice
in PDF.
To crop the pages to the desired presentation size,
1 Open the PDF file in Acrobat (not Acrobat Reader)
2 Got to the desired page if you want to crop only one page.
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3 Touch the crop tool
and open a rectangle on the page
by dragging the mouse.
4 Click the crop tool again and adjust the values in the crop
dialogue to your needs.
To crop all pages, select All in the Page Range.
5 Click OK to see the cropped page.

Export image as eps
Images can be exported from Acrobat in various formats. A
page can also be exported as eps.
Since FrameMaker now handles PDFs very well it is no more
necessary to export images or pages for use in FM as image.
It is, however, recommended to use only short (few pages) for
import into FM.

Security settings
D

Access rights can not be defined in the FrameMaker PDF
setup. This must be done in the distiller prior to distilling.
With the Save As PDF mechanism in FrameMaker this is not
possible, so you need to apply restrictions to a document
after generation of the PDF.
In Acrobat select File > Properties > Security and select
Password Security from the drop-down list.
Normally only editing or printing is restricted, not the access
to document itself (Open).
p Activate “Restrict editing …” and set the password.
p Select the proper allowance for printing
p Select the proper allowance for changes (comments)
p Activate “Enable copying …” if reasonable
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Modify the PDF file with Acrobat

Create fill-in form
If pages you create are forms it is friendly to the reader to
allow her or him to fill the form already in Acrobat or Adobe
Reader. If the user is urged to print and fill in manually he
can not send the filled form by e-mail (or it must be scanned
again).
With Acrobat Forms > Form Tools it is easy to overlay input
areas (in this case a dotted line) with an entry field.

Once you have dragged an area you can set properties with
the context menu Properties. The dialogues are really self
explanatory – and you know how to read Help…
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Some problems with PDF files

Some problems with PDF files
Colours in FrameMaker and PDF don’t match

2011-05-11

To make the online PDF files have the same colour as displayed in FrameMaker, follow the advice Match colours in
FrameMaker and PDF on page A-32.

Long ovals etc. warped
Problem

Shapes with round corners etc. look like drawn with a widenib pen and you’d changed the nib wangle halfway down the
side.

Reason

The problem is related to a new setting in Acrobat Distiller 7,
intended to reduce the file size of PDFs created from CAD
drawings.
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Remedy

In your Distiller joboptions in the Advanced TAB turn OFF
Convert smooth lines to curves
ON is default in “Standard” and “Smallest file size” - and in
most job options from other sources.
[Schlomo Perets, 2005-03-20]

Thin lines disappear in PDF
Problem

When creating a PDF for a high resolution printer thin lines
disappear in the output.

Reason

In PostScript it is possible to define hairlines. Hairline is simply the smallest line an output device is able to resolve. What
may look fine on a 300 dpi laser printer will likely disappear
at 2400 dpi.

Remedy

Make your thinnest lines at least 0.3 points (0.1 mm) and your
thinnest dotted rules at least 0.6 points (0.2 mm).
In various graphic programs (Illustrator, CAD applications)
there is no minimum default setting. Hence the graphic artist
must obey this rule.

D

If you can not re-create the graphic with appropriate line
widths, the program PStill may help: http://www.wizards.de/
~frank/pstill.html (2005: CHF 30).

Preparing files for printing
The following source gives useful advice:
http://www.adobe.com/products/postscript/pdfs/
workflow.pdf
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Viewing 3D objects

Viewing 3D objects
With Adobe PDF version 1.6 (released mid 2005) it became
possible to include 3D geometries in PDF documents. See 3D objects on page 6-28.
When selecting such an object, you get a special tool bar:

Rotate
Pan
Zoom
Measure
Select (what?)
Default view
Select defined view
Toggle model tree (an additional Acrobat window)
Pause / Run animation
Use perspective projection
Select rendering mode (e.g. solid, wire frame)
Select lightning (e.g. head lamp, bright lights)
Set background colour
Show cross section
Often there are additional buttons in the picture for Spinning
or Exploring (predefined movements)

Example files

thevirtualheart.org.
www.pdf3d.co.uk/gallery.php.

View overlaps
surroundings

If at the insertion of the graphic the container frame cropped
the 3D-object, then the displayed object will overlap the surrounding text.
The object is displayed in its inherent size - and the cropping
function of the anchored frame is not used.

10 – 18

Formulas (equations)

Overview
The FrameMaker formula (or equations) editor is a
powerful instrument. It does not create just a
graphic appearance of a formula but displays a
mathematical structure. Hence the handling differs
to most other formula editors.

Contents
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Special formatting of formulas ................................ 7
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Formulas (equations)

Formulas (equations)
A formula (or equation in FrameMaker terms) is a mathematical construct, not just a graphic (as for example, in MS Word).
Hence you must follow the inner logic of a formula to develop
it.
This script can not provide all the information from the manual. For extensive work with formulas please read the manual!

Selecting formulas and their elements
A formula is automatically placed into an anchored frame
(anchored at insertion point). The formula hereafter is placed
in an anchored frame of different properties to display some
features of a formula:
.

5–1
a =  ---------------- ⋅ b
 2 
 The framed rectangle is the anchored frame (anchored in
the preceding paragraph, alignment left)
 The light shaded area denotes the formula. Select the complete formula with CTRL-click. Then the formula can be
moved around within the anchored frame.
 Select an element of the formula (e.g. the square root symbol) with these methods:
-

Double click on the element.
Place the cursor in front of the element and type the
space-bar once.
Sweep the cursor over the element. The amount and
direction of movement while sweeping expands the
selection of the current formula construct.

 Expand the selection to the higher level construct with the
up-arrow or the space-bar.
 Narrow the selection to an inner element with the downarrow.
 To replace a construct, select it, type backspace to get the
question mark (which is selected). No you enter the new
term (or paste a selection).

Stand alone formulas (display formulas)
Example formula:
proportion of the
golden rectangle

A rectangle with proportions that from classical Greek times
has been thought optically pleasing. The relationship between
the larger side a and the shorter side b of the rectangle is as
follows:

5–1
a =  ---------------- ⋅ b
 2 
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In-line formulas

Insert a formula

1 Place the cursor in an empty paragraph with the basic
property “variable line spacing”.

2011-05-11

2 Open the Equation palette (

).

3 With the button Equations select the appropriate size for
the new equation (for example, New Medium Equation).
4 Select Operators in the Equations palette and start the formula with operator ? = ? (the first ? will be highlighted, so
that you can change it to “a”.
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vertical and horizontal list elements

In the keyboard short cuts
the exclamation mark
denotes the ESC character.
To unwrap a formula you
enter ESC, m, e.

superscripts, subscripts

times

potence, power

5 Select the second ? and replace it by operator square-root;
replace the ? under the root by “5”.
6 Select the square root and apply operator “? - ?”; replace
the new ? by “1”.
7 etc. - by now you should know how to work with this editor …
8 Finally shrink wrap the equation (select from the drop
down list Equations).

In-line formulas
D

An in-line formula is inserted in an ordinary paragraph,
rather than in a paragraph of its own. Most time you will need
to specify “no fixed line spacing” to give room to the formula:
It may be a trivial realization about the nature of success.
---------------------------- . Notice
Let’s try to put this into a formula:. success = expenditure
effort

the line spacing in this paragraph, which extends around the
formula and is ‘back to normal’ for the ordinary text here.
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Formulas (equations)

Keyboard input versus “mousing”
Keyboard input shall be demonstrated for our example formula

5–1
a =  ---------------- ⋅ b
 2 

Typing

:

Result
?

Insert large equation (frame). The highlighted
? is the ‘entry point’ of the formula.

a = ?

The new ‘entry point’ is the ? after the equal
sign.

ESC m l
a =
\sqrt
ENTER

Explanation

a =

5 space
space

Function names like sqrt, pwr, log etc. are
preceded by a backslash and terminated by
ENTER:

?

5

The ? is replaced by 5, the two spaces select
the 5, then the square root as a whole.

5–1

The “minus one” is attached to the selection,
not just to the last entry.

a =

- 1
a =
space
space
space /

5 – 1a = --------------?

The blanks select the 1, then -1, then the right
term. The slash creates a fraction bar below
this selection.

2 space
space b

5–1
a = ---------------- b
2

Selecting the right term provides the entry
point (?) to the right. A variable is displayed in
italics.

ESC m p

Shrink wrap the formula. Then apply “variable
line height” to the anchoring paragraph.

5 – 1- b
a = --------------2

3

In a condensed notation this is ( denotes a blank, ! denotes
Return/Enter, ordinary blanks just group the typed text):

33

ESC ml a= \sqrt! 5

-1

333 233

b ESC mp

See Keyboard input for formula elements on page 11-13 for a
complete list of keyboard short-cuts.

Numbered formulas
Set up a numbered paragraph format with the number
appearing at the end of the paragraph.

5–1
a = ---------------- b
2
Format name
Basic properties

(1)

For example fon-formula-numbered.
Line spacing must be variable (fixed not checked).
Space above and below becomes the space above and below
the formula frame, not just around the paragraph text.

Numbering property

11 – 4

F:Formula [<n+>]
Position “End of Paragraph”.

Reference to a numbered formula

Reference to a numbered formula
If you wish to reference a numbered formula, use a cross-reference style “paranum & page”, which might look like this:
<1-highlight><$paranum><$paratext></> on page
<$pagenum>
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Example reference

As you can see in (1) on page 4, …

Create formula in anchored frame
Formulas can be placed directly into an anchored frame:
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asech 5
sin x = 4 --------------------x

max

 sin x = 4 asech

5x

min

1 Select the frame
2 Select formula size from the Equations palette
3 Build the equation
4 CTRL-click on the formula to select it and move it around
5 Add any other elements to the anchored frame (for example, graphics). These may also be in the frame at first.
6 Alignment of complete formulas with Graphics > Align...
acts on the base line of the formula text (the base line of
the word “sin” above), not the bounding box of the formula.

Create formula in graphic frame

D

Graphic frames may also be containers of a formula. However,
a graphic frame does not float with the text – it is normally
just placed on the page (paper). The graphic frame can, however be placed within an anchored frame which in turn floats
with the text:
Anchored frame

Text frame
The formula to the right is just an
example in a graphic frame. It has no
other purpose than to be an example.

Graphic frame

max

 sin x = 4 asech

min
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5x

Formulas (equations)

Palette overview
For the Symbols and Operators palettes see page 4.
Large Symbols

Calculus

Matrix

Relations

Delimiters
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Special formatting of formulas

Special formatting of formulas
Resize a formula
When setting up a formula you must choose a size (small,
medium, large). To change this afterwards,
2011-05-11

1 Select the formula. It may be shrink wrapped or expanded.
2 Select Graphics > Object properties
3 Change the size attribute to your desire; click Set.
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Align formulas
Align formulas
graphically

Formulas can only be aligned if they are located in the same
frame. Hence you may start with a frame and add the formulas to it.
To align the formulas at their boundaries (bounding box)
treat the formulas as graphic elements:

asech b
sin x = 4 --------------------x

1 Select the equation (s) which you want to align.
2 Select the equation which will be the master for the alignment.

max

 sin x = 4 asech

3 Choose Graphics > Align and set the alignment to your
desire. You may wish to use a guiding line (see image).

5x

min

Align formulas along
special symbol

To align the formulas along a special point (e.g. the equal
sign):
1 Click into the first formula to set the alignment point. You
may move the alignment point with the left or right arrow.

D

2 Set the alignment point with the Equations palette Positioning > Left/Right > Set Manual or ESC, m, a, s.
3 Repeat the above sequence for all formulas in the frame
which you want to align.
4 To clear an alignment point, select the formula and enter
ESC, m, a, d (or choose from the Equations palette Clear
Manual).

asech b
sin x = 4 --------------------x
max

 sin x =

4

asech 5x

min

11 – 7

5 Select the formula (CTRL+click) with the most proper
alignment and choose Graphics > Object Properties.
6 Set the Alignment to Manual and set the left position to a
memorable value (2.544 8 2.5) or copy the formula to the
clipboard.

Special formatting of formulas

7 Select the next formula to be aligned, with Object Properties set Alignment to Manual and the left position to the
new/copied value.
8 Repeat the last operation for all formulas in the frame to
be aligned.

Break long formula into lines
To break a long formula
( 1 + x ) 8 = x 8 + 8x 7 + 28x 6 + 56x 5 + 70x 4 + 56x 3 + 28x 2 + 8x + 1

into

lines,

1 Place the cursor at the point where you want to break the
formula. This can not be between a string (entered with " ")
and an operator!

( 1 + x ) 8 = x 8 + 8x 7 +
28x 6 + 56x 5 + 70x 4 +
56x 3 + 28x 2 + 8x + 1

2 Enter a manual break with Equations palette Positioning >
Line Breaking > Set Manual or ESC, m, b, s.
3 To remove a manual line break, select the preceding and
succeeding elements also (e.g. 70x 4 + 56x 3 ) and apply ESC, m,
b, c or choose from the Equations palette Clear Manual.

Copy and paste formula elements
Formulas with ‘self repeating’ contents can be set up very
quickly with the keyboard:
ESCml
1/a+
enter 2 blanks to select the whole formula
copy
type ‘arrow right’ 3 times to select the ?
paste
type ‘arrow right’ 3+2 times to select the ?
paste
...
Select the last ? and replace it by \ldots (small L)

1
----------------------------------------------------1
a + -------------------------------------------1
a + ---------------------------------1
a + ------------------------1
a + --------------a+…

The formula may not be visible, since it is larger than the initially opened frame. Enlarge the frame to make the complete
formula visible, before you shrink wrap it with ESC m p.

Physical dimensions and other strings
Physical dimensions are just strings for the FrameMaker
Equation editor. They do not bear any mathematical property
and hence are not considered in evaluations.
To enter a string into a formula, start the string with a "
(straight quote) and terminate it with the Return key (k). You
see two double quotes ("") after entering the beginning
straight quote. These disappear as soon as you type the first
character of the string.
For example, for the first term of the following formula, enter
v"[m/sec]k . As soon as you close the string with the Return
key (k), the string is selected. To may just continue with the
equal sign.
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Diacritical marks

Vehicle speed:

s[m]
v[m/sec] = ------------t[sec]

(2)

You may not be satisfied with the space between the variable
and the physical dimension. You are tempted to increase this
space with positioning or spacing:

2011-05-11

Vehicle speed:

s [m]
v [m/sec] = ------------t [sec]

(3)

This method does not adjust the length of the fraction bar.

Enter space in formula
string

The method of choice is to enter a space as the first character
in the string:
Vehicle speed:

s [m]
v [m/sec] = --------------t [sec]

(4)

To enter a thin space, type ESC,3,t. To enter an n-space, type
ESC, n,t. The following formula uses n-spaces:
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Vehicle speed:
Note:

s [m]
v [m/sec] = ---------------t [sec]

(5)

It is very difficult to insert or even change this first blank after
you have closed the string! The best method is to remove the
string (select and delete) and create it again.

Adapt font for strings in
formula

To specify a specific appearance of the formula strings, open
Equation palette > Equations > Equation fonts… and enter a
character format for Strings. You can not enter a font name.
From the character format only the font property is used. The
size is determined by the formula size (large, medium, small).

Decimal comma

The equation editor does not honour the regional settings of
the operating system! Only some localised versions (e.g. German) can work with the decimal comma. However this works
only correct, if at the same time the number grouping symbol
is not a period.
If you need a decimal comma in the English version of FM you
need to enter the decimal part as a string: 17",5k to get 17,5.
If you enter just the comma as string, the number will be put
in parenthesis and the comma behind it: 17(5),

))

D

Diacritical marks
ã = v· xy

a = bcde
˜
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Two diacritical marks can be stacked one on top of the other.
More can be stacked only if the base elements are ‘grouped’.
The marks which can be elongated (based on a line) are
always the lower ones. Tilde, hat, bow and dot are always on
top of a line shape.
The following marks can be elongated to span more than one
base element: overbar, underbar, arrow, half-arrow. These can
be stacked according to the base elements.
The others are only placed centred above the spanned elements (see first formula in this topic). These forms are from a
font, whereas the lines are drawn as line graphics.

Special formatting of formulas

Remove a diacritical mark

To remove a diacritical mark, select the base element and
expand the selection to include the diacritics. Applying the
diacritical mark again will remove it (toggle the mark on/off).

Special diacritical marks

The capabilities of FrameMaker for handling diacritical marks
may not be sufficient for you, e.g. to place an elongated hat or
tilde above three elements:
You need a little bit of work to create such constructs:
1 Create an anchored frame (here filled with gray to display
it):

∂^ ∂ ~
uvw + uvw = 0
∂x
∂x

2 With the Graphic-Line tool from the graphics tools palette
(
) create the desired character (as an example, we use
the tilde): ~ . You will notice that this is a graphic object
with handles.
3 You can now elongate it by pulling the right handle:
~
4 Select the modified symbol (tilde) as a graphic object and
copy it into the formula frame:
-

Select the tilde
Copy the tilde to the paste buffer
Select the formula frame
Paste the tilde into the frame

5 Move the selected symbol (tilde) to the desired place with
the mouse or with CTRL+arrow.
Working tip

In the anchored frame you may set up a collection of
items: ~ ^ ∩ .
These symbols can only get character formats. If you need
symbols from a special font (such as the last one from the
Symbol font, you need to set up an appropriate character format.

Positioning, fine tuning presentation
You may not be satisfied with the space between math elements, the location of exponents and indices etc. Although
FrameMaker does a good job, math typesetters and TE X
experts may have their complaints. In these cases manual
work with micro positioning may be necessary.
Use the keys ALT+: etc. for fine movements.

Editing formulas
1 Unwrap the formula (ESC, m, e)
2 Place the cursor behind the element you want to edit
3 Select the element with Space bar
4 Modify the element (delete, replace, …)
5 Shrink wrap formula (esc, m, p)
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Common problems with formulas

Common problems with formulas
Formula overlaps surrounding paragraphs
The formula construct uses an anchored frame at insertion
point, which can only expand the paragraph height, if the paragraph has variable Line spacing.
2011-05-11

5–1
a =  ---------------- ⋅ b
 2 

This is the “formula paragraph”.

For paragraphs used as ‘anchors’ for formulas, the check box
for fixed Line Spacing must be unchecked.

Variables are not displayed in italic
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If the variables in a formula are not displayed in italics, you
have accidental removed the character format EquationVariables (English FM) or GlgVar (German FM).
Set up the format again with the properties: Angle = italic;
everything else As Is. The format must be in the character catalogue.

Fraction bar has not the desired length
Vehicle speed:

s [m]
v [m/sec] = ------------t [sec]

The fraction bar can get a correct length only if FrameMaker
knows about the length of the elements involved. If you use
micro-positioning or spacing, this is just an optical correction. To get correct results, see Enter space in formula string on
page 9.

Alternative fonts in formulas

D

The fonts used in the formulas are defined by character formats. Within a formula use the context menu Equation Fonts
… to display the dialogue for setting the font properties.
a

Category

Default

Modification needed …

Math Symbols

Symbol

tweaking maker.ini (and mathchar.cfg)

Functions

Default ¶ Font

any character format (font family used only)

Numbers

Default ¶ Font

any character format (font family used only)

Strings

Default ¶ Font

any character format (font family used only)

Variables

EquationVariables

any character format (style used only)

a. The notion “Default ¶ Font” actually refers to the “DefaultFamily” as
specified in maker.ini ! At D+DD this is set to Lucida Sans rather
than Times New Roman 8 see appearance of formulas here.

Possible font alternatives
for Math Symbols
Note:
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“Lucida New Math”, “Mathematical PI Std” or “Universal
Standard Greek with Math PI”.
Re-defining the fonts may require re-shrinking of all equations! The definition in mathchar.cfg needs some tedious work!

Evaluation

Evaluation
Numeric results
To evaluate an equation
(get numeric results)

5–1
a =  ---------------- ⋅ b
 2 

To evaluate a formula, for example

:

1 Select the equation inside its frame.
2 From the Equations palette choose Functions > Evaluation
> Number crunch

3 You get the following result:

a = 0.61803399 ⋅ b

4 At this stage you may undo the operation to see the algebraic notation again.

Symbolic evaluation
With Functions > Evaluations some expansions are available.
To apply an expansion, select the formula (or part of) and
then choose the function:
Addition > Add
Fractions
Division > Long Division

a--- + 2a
55ab + 84a------ + 7a
------ becomes 11a
--------- + 7a
------ and then --------------------------4 3 5b
12 5b
60b

Numerator and denominator must be polynomials for this
function. Select any x in
x 5 + 20x 4 + 160x 3 + 640x 2 + 1280x + 1024
-------------------------------------------------------------------------------------------------------x 2 + 8x + 16

tion:

and apply the func-

640x 2 + 1280x + 12x 4 + 144x 3 + 1024
x 3 + -------------------------------------------------------------------------------------------x 2 + 8x + 16

1280x + 48x 3 + 448x 2 + 1024
x 3 + 12x 2 + -----------------------------------------------------------------------x 2 + 8x + 16

Multiplication >
Multiply out
Evaluation > Evaluate

y = ( x + 4 ) 5 becomes
y = x 5 + 20x 4 + 160x 3 + 640x 2 + 1280x + 1024
( x + 4 ) 5 becomes ( x + 4 ) ( x + 4 ) ( x + 4 ) ( x + 4 ) ( x + 4 )

For even more mathematics see the manual.
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and then

Keyboard input for formula elements

Keyboard input for formula elements
Many maths elements and most functions can be entered via
the keyboard.
To enter a Backslash sequence, type Return to end the backslash sequence.
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2011-05-11

Most short-cuts are not localised, so they are valid both for
the English and German FrameMaker. The only exception is
the input of diacritical marks, which depends on the language.
Note:

On a Swiss keyboard some short cuts are not available (not
working). This is because some characters such as tilde are
only available as accents on ‘dead keys’.

Note:

Some of the sequences listed in the Help for the German FM
are wrong. The sequences given here are tested with Windows
NT4 and 2000 with a Swiss keyboard. Sequences in shaded
cells do not work at all. No correct key sequence could be found
for these.

Equations pop-up menu
Command

Short-cut

New Small Equation

Esc m s

New Medium Equation

Esc m m

New Large Equation

Esc m l (lc L)

Shrink-Wrap Equation

Esc m p

Unwrap Equation

Esc m e

Equation Sizes

Esc p e

Equation Fonts

Esc m f

Insert Math Element

Esc m i

Add Definition to Catalogue

Esc m c

Update Definition

Esc m U

Strings
D

Strings are single line comments in a formula. To enter them,
just start with a single or double apostrophe and enter the
text. Terminate with a Return (there is no terminating apostrophe).
Command

Short-cut

Start String

' or "

End String

Return

See example in Physical dimensions and other strings on page 8.

11 – 13

Keyboard input for formula elements

Symbols
Greek characters

11 – 14

Element

Short-cut

Backslash sequence

α

Control+Alt+a

\alpha

β

Control+Alt+b

\beta

Γ

Control+Alt+G

\Gamma

γ

Control+Alt+g

\gamma

Δ

Control+Alt+D

\Delta

δ

Control+Alt+d

\delta

ε

Control+Alt+e

\epsilon

ζ

Control+Alt+z

\zeta

η

Control+Alt+h

\eta

Θ

Control+Alt+Q

\Theta

θ

Control+Alt+q

\theta

ϑ

Control+Alt+J

\vartheta

ι

Control+Alt+i

\iota

κ

Control+Alt+k

\kappa

Λ

Control+Alt+L

\Lambda

λ

Control+Alt+l (lc L)

\lambda

μ

Control+Alt+m

\mu

ν

Control+Alt+n

\nu

Ξ

Control+Alt+X

\Xi

ξ

Control+Alt+x

\xi

Π

Control+Alt+P

\Pi

π

Control+Alt+p

\pi

ρ

Control+Alt+r

\rho

Σ

Control+Alt+S

\Sigma

σ

Control+Alt+s

\sigma

ς

Control+Alt+E

\varsigma

τ

Control+Alt+t

\tau

ϒ

Control+Alt+U

\Upsilon

υ

Control+Alt+u

\upsilon

Φ

Control+Alt+F

\Phi

φ

Control+Alt+f

\phi

ϕ

Control+Alt+j

\varphi

χ

Control+Alt+c

\chi

Ψ

Control+Alt+Y

\Psi

ψ

Control+Alt+y

\psi

Ω

Control+Alt+O

\Omega

ω

Control+Alt+o

\omega

ϖ

Control+Alt+I (uc i)

\varpi

∂

Control+Alt+7

\cpartial

Diacritical marks

2011-05-11

Other special symbols
Element

Short-cut

Backslash sequence

∞

Control+Alt+one

\infty

⊥

Control+Alt+2

\bot

…

Control+g period

\ldots (lowercase L)

ℵ

Control+Alt+3

\aleph

ℑ

Control+Alt+4

\Im

ℜ

Control+m $

\Re

℘

Control+Alt+5

\wp

∅

Control+Alt+zero

\emptyset

∇

Control+Alt+6

\nabla

°

Control+m )

\degree

′

Control+Alt+`

\prime

″

Control+m "

\pprime

Diacritical marks
E:\FM-course\handout\formulas.fm

Please note the remarks on page 13 concerning the shaded
areas!
Element

Short-cut (FM-E)

Short-cut (FM-D)

x'

` (grave)

` (Grave)

x̃

~ (tilde)

~ (Tilde)

x

Control+g hyphen
Esc m _ (underline)

Control+g hyphen

x

Control+Alt+V

Strg+Alt+V

x̂

Control+g ^

Strg+Alt+^

x·

period

Punkt

x
˜
x

Control+g ~ (tilde)

Strg+Alt+~ (tilde)

Control+g _ (underline)

Strg+g _ (underline)

Control+g right arrow

Strg+Alt+=

Control+g @

Strg+g @

x
)

x

D

a. Control+g right arrow works also in the German FM.
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a

Keyboard input for formula elements

Operators
Please note the remarks on page 13 concerning the shaded
areas!
Toggle format switches between the representation of fractions.
Element

Short-cut

Backslash sequence

?+?

plus

\plus

?-?

minus (after an operand)

?x?
?⋅?
?•?

Control+m * (asterisk)

\cross

Control+m . (period)

\cdot

Control+8

\bullet

Toggle Format

Control+T
Esc m T

?/?

Control+Alt+/

\fract

?÷?

Control+m /

\div

/

\over

?=?

=

\equal

=?

Control+g =

\uequal

Control+j

\jotdot

?,?

comma

\comma

?⊗?

Control+q D

\otimes

?⊕?

Control+q E

\oplus

?∧?

Control+q Y

\wedge

?∨?

Control+q Z

\vee

?∩?

Control+m i

\cap

?∪?

Control+m u

\cup

,?

Control+m , (comma)

\ucomma

;?

; (semicolon)

\semicolon

¬?

Control+m n

\neg

-?

Control+hyphen

\minus

−
+?

Control+m one

\mp

±?
∇?
∇??

Control+q one

\pm

Control+q Q

\grad

Δ?

Control+m Control+d

\change

?

Control+m x

\box

•?

Control+m o

\boxdot

?

Control+m 2

\box2

Control+m a

\forall

Control+m e

\exist

--?-

?

?

‡?

2

∀?
∃?
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Control+q Q
(and add operand)

Large symbols

Element

Short-cut

Backslash sequence

∴?

Control+m t

\therefore

?
?

Control+a, Esc m v l (lc L)

\atop

Control+m ; (semicolon),
Esc m h l (lc L)

\list

??

* (asterisk)

\times

|?|

Control+g | (bar)

\abs

?

? (superscript)

Esc m ^

?

? (subscript)

Esc m Control+_

2011-05-11

?

?
?

?

?

?

(superscript in front)

? (subscript in front)

Control+m _ (underline)

?

Control+r

?

Control+r
(and add operand)

? ×10

\sqrt

Control+E

\sn

? ? (exponent)
?†
?!

^

\power

Control+m d

\dagger

!

\fact

?

*

Control+m s

\ast

∠?

Control+q P

\angle

?

Large symbols
Use these short-cuts to type each element with only one operand. Then use Add Operand and Toggle Format as needed
Element or command

D
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Control+m Control+^
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Short-cut

Backslash sequence

?
∏?

Control+S

\sum

Control+P

\prod

?

Control+i

\int

° ?
∩?
∪?

Control+I (uc i)

\oint

Control+m I (uc i)

\bigcap

Control+m U

\bigcup

Add Operand

Control+N
Esc m n

Toggle Format

Control+T
Esc m T

Keyboard input for formula elements

Delimiters
Use Toggle Format to switch between the various types of
parentheses.
Apply Remove Parentheses only to the selection from which
you really want to remove the grouping. To remove only one
delimiter (and its mate), place the cursor right to the delimiter and type Delete.
Element or command

Short-cut

Backslash sequence

(?)

(

\id

[?]

[ (left bracket)

{?}

{ (left brace)

?

| (bar)

\substitution

 ?

Control+m <

\dangle

|?|

Control+g | (bar)

\abs

(?

Control+m (

\lparen

[?

Control+m [ (left bracket)

{?

Control+m { (left brace)

?

?

| (bar) (and add operand)

|?

Control+m k

\ket

||?||

Control+m | (bar)

\norm

?)

)

\rparen

?]

] (right bracket)

?}

} (right brace)

?
?

| (bar)
(and add two operands)
Control+m b

\bra

Control+q i

\ceil

(?,?)

Control+m N

\inprod

[?,?]

Control+m C

\cmut

{?,?}

Control+m A

\acmut

?

_ (underline)

\overline

?|?

Control+m B

\bket

Control+q k

\floor

 ?
 ?

Control+m h

\choice

}

?

Control+m D

\downbrace

Control+m P

\upbrace

?|

{

x
x

Toggle Format

Control+T
Esc m T

Remove Parenthe- Esc m r p
ses
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Relation

Relation

D
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Element

Short-cut

?<?

<

\lessthan

?>?

>

\greaterthan

?=?

=

\equal

?~?

Control+m ~ (tilde)

\sim

?⊂?

Control+q L

\subset

?⊃?

Control+q I (uc i)

\supset

?←?

Control+q comma

\leftarrow

?→?

Control+q period

\rightarrow

?↔?

Control+q plus

\lrarrow

?⊥?

Control+m r

\perp

?≤?

Control+g <

\leq

?≥?

Control+g >

\geq

?≡?

Control+q : (colon)

\equiv

?≈?

Control+q ; (semicolon)

\approx

?⊆?

Control+q J

\subseteq

?⊇?

Control+q M

\supseteq

?⇐?

Control+q \

\Leftarrow

??

Control+q ^

\Rightarrow

?⇔?

Control+q [

\LRarrow

? || ?

Control+m p

\parallel

? << ?

Control+q l (lc L)

\ll

? >> ?

Control+q g

\gg

?≠?

Control+q =

\notequal

?≅?

@

\cong

?∈?

Control+q N

\in

?∋?

Control+'

\ni

?∉?

Control+q O (uc o)

=?

Control+g =

\uequal

?⊄?

Control+q K

\notsubset

?∝?

Control+q 5

\propto

Table 2: Relational operators
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Backslash sequence

Keyboard input for formula elements

Calculus
Use the first two mentioned short-cuts to type large symbols
with only one operand. Then use Add Operand and Toggle
Format as needed.
Element or command

Short-cut

Backslash sequence

?

Control+i

\int

° ?

Control+I (uc i)

\oint

Add Operand

Control+N
Esc m n

Toggle Format

Control+T
Esc m T

d
d?
d?
d?
∂
∂?
∂?
∂?

Control+g t

Control+g T

Control+g p

Control+g t
(and add operand)

?

Control+g T
(and add operand)

?

Control+g p
(and add operand)

?

Control+g P
(and add operand)

d ?
d?
∂
∂?

∂ ?
∂?

\oppartial

Control+g P

?

d
d?

\optotal

δ?

Control+Alt+d

\var

∇?

Control+q Q

\grad

d?

Control+d

\diff

∇x?

Control+m c

\curl

∂?

Control+D

\partial

∇•?

Control+m v

\diver

Control+L

\lim

Control+m l (lc L)

\lap

lim ?
?

∇2?
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Matrices

Matrices
To insert a matrix of any size, first insert a 1 by 1 matrix.
Then add rows and columns one at a time. With the Equations
palette you have a selection of pre defined matrices available
Command

Short-cut

2011-05-11

Add/Remove Brackets

Control+T

Matrix Commands pop-up menu

Pre defined matrices in

Equations palette >Matrice

Create 1 x 1 Matrix

Esc x m

Add Row

Esc x r

Add Column

Esc x c
Control+C

Matrix Transpose

Esc x t

Matrix Algebra

Esc x a

Matrix Row Height pop-up menu
Toggle fixed/proportional

Esc m t r

Matrix Column Width pop-up menu

E:\FM-course\handout\formulas.fm

Toggle fixed/proportional

Esc m t c

Functions
For the functions (except for the general function and the
limit) you must have selected an appropriate portion of a formula.
Element / command

Short-cut

Backslash
sequence

? (?)

Control+f

\function

lim ?

Control+L

\lim

?

Addition pop-up menu
Add Fractions

ESC m a a

Order Sum

ESC m a o

Order Sum Reverse

ESC m a O (uc o)

D

Multiplication pop-up menu
Factor

ESC m u f

Factor Some

ESC m u F

Multiply Out

ESC m u m

Multiply Out Once

ESC m u M

Distribute

ESC m u d

Distribute Over Equality

ESC m u D

Division pop-up menu
Long Division

ESC m d l (lowercase L)

Remove Division

ESC m d d

Remove Division 1 Level

ESC m d D

Remove Negative Powers

ESC m d n

Remove Negative Powers 1 Level

ESC m d N

Evaluation pop-up menu

11 – 21

Keyboard input for formula elements

Element / command

Short-cut

Number Crunch

ESC m v n

Show All Digits

ESC m v . (period)

Evaluate

ESC m v e

Evaluate Substitution

ESC m v s

Evaluate Integrals

ESC m v i

Evaluate Derivatives

ESC m v d

Evaluate Derivatives 1 Level

ESC m v D

Backslash
sequence

Rules pop-up menu
Enter Rule

ESC m r e

Apply Rule

ESC m r a

Designate Dummy

ESC m r d

Other Rewrites pop-up menu
Simplify

ESC m o s

Simplify Some

ESC m o S

Isolate Term

ESC m o i

Expand First Term

ESC m o e

Expand All Terms

ESC m o E

Positioning and line breaking
The number of points shown in the following table is based
on a zoom setting of 100 percent.
Function

Short-cut

Micro positioning
Move up 1 point

Alt+up arrow

Move down 1 point

Alt+down arrow

Move left 1 point

Alt+left arrow

Move right 1 point

Alt+right arrow

Move up 6 points

Alt+Shift+up arrow

Move down 6 points

Alt+Shift+down arrow

Move left 6 points

Alt+Shift+left arrow

Move right 6 points

Alt+Shift+right arrow

Remove micro positioning

Alt+Home

Left/Right (Alignment) pop-up menu
Left

Esc m a l (lc L)

Centre

Esc m a c

Right

Esc m a r

Left of =

Esc m a plus

Command

Shortcut

Right of =

Esc m a =

Set Manual

Esc m a s

Clear Manual

Esc m a d

Reset Alignment

Esc m a R

Up/Down (Alignment) pop-up menu
Top
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Esc m a t

Navigating in a formula

Function

Short-cut

Baseline

Esc m a B

Bottom

Esc m a b

2011-05-11

Line Breaking pop-up menu
Set Manual

Esc m b s

Clear Manual

Esc m b c

Navigating in a formula
Select next prompt tabs through the entry fields of pop-up
dialogues.
Function

Short-cut

Moving the insertion point
Left

left arrow

Right

right arrow

From beside a fraction to the numerator down arrow
Select next prompt

Tab

Increase scope of selection

space

Select next element to the left

left arrow

Select next element to the right

right arrow

Moving math elements
Function

Short-cut

Moving math elements while retaining algebraic equivalency
Left

Shift+left arrow

Right

Shift+right arrow

Up

Shift+up arrow

Down

Shift+down arrow

To far left

Control+Alt+left arrow

To far right

Control+Alt+right arrow

Left into expression

Control+Shift+left arrow

Right into expression

Control+Shift+right arrow

Moving math elements without retaining algebraic equivalency

D
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Changing the selection
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Swap with element on left

Control+m Control+left arrow

Swap with element on right

Control+m Control+right arrow

Display comparison

Display comparison
Since Donald Knuth developed T EX in the late 1970s for type
setting mathematics the presentation of formulas with this
tool is the gauge for





Relative size of objects (exponents, indices etc.)
Extension of symbols for root, sum, product etc.
Extension of parentheses, brackets and braces
Positioning of attributes (boundaries, limits, etc.)

Keep in mind that the beauty in the eye of the beholder [Scottish
philosopher David Hume].
I do not have access to many systems, hence the following are
mainly copies from books and screen shots.
TEX

FrameMaker

σx =

1
--- 
n

n



i=1

2
Xi –

1
--- 
n

n

2
X i 
 
i=1



Mathtype

MS Word EQ Editor 3.0

Object embedded

σx =
MathCAD 11

MathML (Netscape 7.1)
with MIT fonts
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2
n

n



2
1 
1
n  X i − n   X i  
 i =1
 i =1  


Bitmap embedded

Export and import

Export and import
Exporting formulas
If you need to export formulas, for example, to Word, you use
the RTF1.6 filter.
2011-05-11

Sample formula to be exported

c =

(6)

a2 + b2

p Collect all required formulas in one FrameMaker document
with only minimal txt, for example only in the anchoring
paragraph.
p Use Save As… and select Microsoft RTF 1.6 as type
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p Open the generated RTF in Word. The formulas are pictures
which can be sized. They look quite nice, because they are
WMF which can contain vectors and fonts.

5
–
1
a = ---------------- b
2
Import formulas from TEX
University of Victoria, Canada researchers (Prof Nigel
Horspool) have developed a plug-in for FrameMaker version
5.5 or later on Windows which supports import and conversion of LaTeX documents.
Although provided on the site www.flintbox.com (search for
laimport) it’s quite challenging to get to the file. Hence I have
put it on my web server at www.daube.ch. You may wish to
read the PDF documentation.

D

Wolfgang Hugemann
reports about this tool

The filter imports text including formulas and event translates simple inline-formulas into text. The formulas look
quite nice as long as in T E X no special wished had been fulfilled.
Array equations create problems. Other problems arise when
you want to edit an imported equation. TEX does not build on
the mathematical structure but on the appearance structure.
Hence the equation in FM is just tinkered. The parentheses FM
would normally insert are suppressed by formatting.
Summary: The function is surprisingly good. Vis à vis the
import of formulas by LaTeX-eps (or PDF) the advantage is to
use the equation font of FrameMaker.
[2006-09-26] Wolfgang, Hugemann.de]
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Export and import
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Generate HTML and XML

Overview
HTML or XML can be generated from a FrameMaker
file or all files of a book
The transformation is controlled by tables on reference pages, which are set up by default with some
guessing by FrameMaker.
To get good transformation results these tables
must be adapted.
Both HTML and XML generation gets best results
when working with the Structured FrameMaker, because the transformation is fare more straight forward for structured documents.

Contents
Save as HTML ......................................................... 2
Save as XML ........................................................... 5

Save as HTML

Save as HTML
Note:

Both HTML and XML generation gets best results when working
with the Structured FrameMaker, because the transformation
is fare more straight forward for structured documents.
With File > Save as … and selecting HTML a FrameMaker
internal process is used to convert the document to HTML.

Note:

This process uses mapping tables on the reference tables
named HTML. Hence a template may provide a complete setup.
p To set up the mapping tables select File > Utility > HTML
setup
p If not all styles in the document are in the paragraph catalogue, you get prompts for all of those. You may decide not
to include them in the catalogue. Nevertheless they are
available for conversion to HTM.

p Follow these rules for a reasonable setup:
Paragraph type / Character type

Mapping to HTML element

Heading, table heading, table title

Heading (autolevel)

Ordinary paragraphs and the like, table Paragraph
cells (except lists in tables)
Citations

Block Quote

Glossary term

Data term

Glossary definition

Data Definition

Code examples

Pre formatted Text

Numbered and bulleted lists

List Item

Continuation paragraphs to lists

List Item (Continued)

Character formats for code, keyboard
input etc.

Code

Character formats for variables

Variable

Normal emphasis

Emphasis

Stronger emphasis

Strong Emphasis

anything you don’t like to appear in the Throw Away
HTML output.
Cross references

Select an appropriate substitution

p After this set up you may need to change heading levels in
the Heading table on the reference page Headings, because
the automatism is not that good.
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Definitions on the Reference Pages

p Set the options for graphics. The conversion of graphic formats is only applied to graphics, which are copied to
FrameMaker (not referenced) or FrameMaker vector graphics.
p Set the option Copy Files Imported by Reference if you
want all referenced graphics to appear in the same directory as the HTML file. These files are not converted.
2011-05-11

p Select Save as... and choose HTML from the Save as type…
pull down list.
p Define an appropriate file name (with extension html) and
wait some time.
p You may need tweaking of the generated mapping table on
the reference pages names HTML and Headings (see Heading table on page 12-3).
The generation (with some tweaking according to the rules
above and an adapted Headings table) gets useful results

E:\FM-course\handout\html.fm

Definitions on the Reference Pages
The tables are displayed here in there more or less original
appearance. I have only removed the Comment columns in
most cases.

Heading table

In most cases, this table need some adaptation, because
FrameMaker defines arbitrary heading levels

HTML Mapping table

As soon as you change a H* item to a distinct HTML heading
(for example, H3), this heading will disappear at the next
HTML generation from the Heading table displayed above.

HTML options table
Control

Value

Image Format

0001IMAGGIF

Comments
GIF

D

Copy Files Imported by Refer- N
ence
Export Encoding

ISO-8859-1

CSS Export Encoding

ISO-8859-1

System macros

These macros can be used to define special headers at the
entrance into an HTML page (see Code for a navigation bar on
page 4).

Cross reference macros

These are OK for most purposes and don’t need any changes.

General Macros

Have not yet figured out what can be done with these.

Character macros

This is a mapping of characters to HTML entities or ordinary
characters. You may need to add some special characters
here.
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Code for a navigation bar
To insert a navigation bar of the kind …
[First Page] [Previous Page] [Next Page] [Table of Contents] [Index]
… the following code should be used for macros StartOfDoc,
StartOfSubDoc, StartOfFirstSubDoc and StartOfLastSubDoc.
<H5>
<A
<A
<A
<A
<A
</H5>

HREF="$parentdoc">[First Page] </A>
HREF="$prevsubdoc">[Previous Page] </A>
HREF="$nextsubdoc">[Next Page] </A>
HREF="$FrameBookTOC.htm">[Table of Contents]<A>
HREF="$FrameBookIX]">[Index]</A>

Generated output
For each document (name.fm) a set of files is generated:
name.htm, name.css and name-nn.gif for all the pictures. Formulas and all contents in anchored frames are converted to
pictures. The default picture format can be changed from gif
to png.
Screenshots become awfully bad:

The picture comprises the full area of the anchored frame,
including white space (here reddish) around the image.

WebWorks Publisher
The Standard Edition of WebWorks Publisher from Quadralay
is no more included in the delivery of FrameMaker 8. The full
product WebWorks Publisher has changed its name: ePublisher:
ePublisher is a powerful online conversion PLATFORM that transforms FrameMaker, Word, and DITA-XML content into Web and
online help deliverable. The ePublisher solution comprises three
software components: Pro, Express, and AutoMap. Each component
plays a specific role in the ePublisher workflow.
See more on Quadralay.com

Mif2Go
This product from Omni Systems seems to be the fastest, easiest, and least expensive way to convert your FrameMaker
files for online Help, DITA, Word, and the Web. You can even
get a working copy for free, if you are unemployed!
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Save as XML
Note:

From the Help

Both HTML and XML generation gets best results when working
with the Structured FrameMaker. See Migrating from unstructured FrameMaker to structured FrameMaker on page 12-6.

2011-05-11

You can combine structured FrameMaker and XML in several
different ways. FrameMaker does not lock you into a single
workflow. Your options include the following:
 FrameMaker authoring with XML support. With this option,
you use FrameMaker as your main authoring tool. As
needed, you save your files from FrameMaker out to XML,
and then use that XML as needed. All content changes are
made in FrameMaker; when you need new XML files, you
save out to XML again.
 FrameMaker authoring with XML source files. With this
option, you use FrameMaker as your main authoring tool.
Your source files are XML. You open the XML files in FrameMaker, make changes, and save. When you save, your XML
source file is updated.
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 FrameMaker and XML authoring. With this option, you produce content in FrameMaker and in other XML tools. When
you are ready to publish to print, you combine the XML created outside FrameMaker with FrameMaker-based content,
and then produce your final print or PDF deliverable. This
workflow is useful in an environment with many occasional
content contributors. The content contributors may not
need a powerful publishing environment. Therefore, they
may choose to produce their content in a low-end XML editor, and then deliver the XML files to the FrameMakerbased publishing team. This workflow is also relevant if
you have XML generated from a database or another lineof-business application.

D

 XML authoring with FrameMaker publishing. With this option,
you work mainly in another XML authoring tool, and XML
content is produced by a database system or other line-ofbusiness application, or you are receiving XML from outside your organization. When content is finished, you produce print and PDF by bringing the XML into FrameMaker.
You might build a server-based application with FrameMaker Server to automate this process.

Save as XML

FM puts more emphasis on this. It is a separate menu item
File > Save as XML…
You just get a File save dialogue for the location of the target
files. Similar to the HTML process you get a set of files per
name.fm: name.htm, name.css and name-nn.gif for all the pictures.
The process uses a similar set of tables on reference pages as
the HTML process, but there is no direct user dialog to set up
and modify these tables. You may change the settings directly
in the reference tables.
FrameMaker generates them on the fly and you can afterwards change them (for further enhanced generations).
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Migrating from unstructured FrameMaker to structured
FrameMaker
(This text is from the Help files)
The transition from unstructured, paragraph-based authoring
to structured, element-based authoring can be challenging.
Authors must shift from the desktop publishing model to
working with a tree view of a document. Moving authors who
are familiar with unstructured FrameMaker into structured
FrameMaker reduces the learning curve.
Although the authoring experience changes, knowledge from
unstructured FrameMaker is helpful when working in the
structured environment. For example, authors still insert
cross-references with the Cross-Reference dialog box, but
instead of choosing paragraph tags and paragraph instances,
they choose elements and element instances.
If you are working in unstructured FrameMaker, it's likely
that your documents follow a template with minimal formatting overrides. This document consistency makes it easier to
convert to structured documents. If, however, authors create
content with no accountability for consistent, repeatable formatting, then document conversion will be a challenge. Most
authors in FrameMaker-based environments are accustomed
to following template rules, and that discipline makes the
transition to structured authoring easier
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Overview
In this chapter special and maybe rarely used functions of FrameMaker are presented.
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Document meta information
26)In

larger documentation projects it is naysayer to keep
information about the project and files close to the documentation – at best in the documentation itself.
FrameMaker offers a number of mechanisms to keep such
meta information:

Imprint page

It is good practice to present a minimum history information
to the reader at the beginning of the document. See Document
information on page 0-2. Other examples:
History

Margin information

R 1.4: Separate documentation for G-variant
R 1.3: Engineering changes [2003-10]
R 1.2: Engineering changes [2001-07]
R 1.1: Safety instructions amended; editorial
changes [2000-05]
R 1.0: First issue of manual [1999-03]

The inner margin is a good place for developer information,
such as complete file path and print date.
For loose leaf distribution the location of punch holes must
be observed. This compendium assumes 4 holes (3×80mm).

File Information

See Document Information on page 10-6.

User variables

Keep at least variables such as doc-version, revision-date,
revision-nr, even if not presented in the layout. You may
wish to use the plug-in Alert Tool which displays at document
open the contents of variable Alert.
These alerts can be used to provide reminders to writers
when they edit documents, or to alert writers that specific
documents shouldn't be updated.

User-defined markers

With distinctly names markers (e.g. ToBeDone) and contents of
the marker (e.g. “modify for the use of UniCode”) reminders
about specific edits can be placed for later revision cycles.

Conditional text

Conditions can show/hide extensive comments or prepared
revisions which are due in the future.

Reference pages

There may be a reference page named History which can contain a complete revision history of the document. Be aware
that format imports may copy this to other documents.

Placeholder text frames
on master pages

On master pages the text frame for text entry in the body
pages (normally flow A) can hold text. This text is not present
on the body pages. Hence a history roll can be established
even on the master page Right.

Template information

The template revision should be noted, for example in a variable tpl-version.

26 This section is based on an answer of Fred Ridder in lists.frameusers.com

13 – 2

v-08

Revision handling

Revision handling
FrameMaker is designed for long living documents. Hence
there are various tools available for the handling of revisions:
 Apply change bars in the margin
 Track text edits (addition, removal, change of text)
2011-05-11

 Compare ‘old’ and ‘new’ documents to get the difference
information
 Insert “point pages” after freezing pagination
Not related to any FM feature is the method to keep document
versions in distinct directories (compressed, e.g. as ZIP files).
At least a PDF version of the older document should be kept
to be able to re-activate text which had been deleted once in
the lifetime of the document.
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Applying changes
Normally there are two types of changes necessary for an
update of a document:
 Editorial changes, such as correcting spelling errors,
enhanced formatting, changes of layout etc.
 Substantial changes in the text due to changes in the pertinent product, change of product names, software versions,
new/changed/deleted functions etc.
It is good practice to make the editorial changes first and do
not make them visible by change bars etc. Only then the substantial changes are applied with the hints for the reader
what has changed.

Find differences in files
Although FrameMaker provides a function it has proven that
comparing two PDFs with Acrobat gives better results.
The FrameMaker function generates a new file with the differences. Additions and deletions are indicated by conditional
text (see Conditional text on page 13-13). Changed text is indicated with change bars.

D

p In the newer document select File > Utilities > Compare
Documents… and select the older (also open) file.
Specify whether you want a summary file only or also a
composite document. The latter is necessary to see all text.
p Specify the options for the presentation of the differences.
The necessary conditions use default settings, if you have
not changed them.
p Click Compare.

13 – 3

v-08

Revision handling

Summary file

Document Comparison Summary
Documents
NameModification Date
Newer Document:frosch-new.fm9 June 2009 3:51 pm
Older Document:frosch-old.fm9 June 2009 3:49 pm

Number of Changes

Type
InsertionsDeletionsChanges
Text Content 110

Flow A
Text Content Changes
Page Numbers
Composite

Older
1
“Übel hatte ihm die prinzessin ...”
1
“Das ist Daube’s ...”

Compound file

Newer

Change
1

Text
Deleted:

1

Inserted:

Der froschkönig war es nun endgültig leid, noch länger auf
die prinzessin zu warten. Ärgerlich hüpfte er vom brunnenrand, zumal eine dicke fliege sein interesse weckte.
Übel hatte ihm die prinzessin mitgespielt! Daß ihm das passieren musste!
Öfter als sonst verkroch er sich von nun an in die brunnenkresse und sinnierte über den kleinen grünen steinfresser.
Das ist Daube’s dummy text für nahezu alle lebenslagen, da
er umlaute enthält.

Result

The red-strike-through is deleted text (not present in the new
document), the green-underlined text is inserted (not present
in the old document). Both paragraphs also have change bars.
The comparison did not take notice of the changed character
format in the first paragraph.

13 – 4
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Change bars

2011-05-11

Change bars are a character property. Hence they can be
applied to paragraphs and parts of. As can be seen from the
following example, they are also applied to changes in tables.

< Change bar for changes in the table
to the right and for the text after the
table.
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Set up for the location of change bars is
“Side Farther from Page Edge”.
This does not depend on the pagination
setting “single/double sided”, The side
is determined by the margin of the text
frame to the paper. In the current layout
the inner margin is larger than the outer, hence the change bars are placed int
he inner margin.
Watch the two change bars for the left
and right text frames within the anchored frame 8

Column 1

Column 2

Der
froschkönig
war es nun
endgültig leid,
Übel hatte ihm
die prinzessin
mitgespielt!

noch länger auf Ärgerlich
die prinzessin hüpfte er vom
zu warten.
brunnenrand,
Daß ihm das
passieren
musste!

Column 3

Column 4

zumal eine
dicke fliege
sein interesse
weckte.
Öfter als sonst verkroch er sich
von nun an in die brunnenkresse
und sinnierte über den kleinen
grünen steinfresser.

However, changes within an anchored frame are indicated
within the frame – if space permits:

Text lines can not receive
a change bar.

Another text frame within
the anchored frame.

Öfter als sonst verkroch er sich von nun
an in die brunnenkresse und sinnierte
über den steinfresser.

Changes in formulas are not indicated. Only the insertion of a
new formula (frame) will be indicated (change of paragraph).

5 – 1 ⋅ b 2
a =  -------------- 2 

Set up change bars

D

With Format > Document > Change Bars… the properties of
change bars are defined:
Distance …

The distance to the text frame containing
the changed text.

Thickness

Thickness of the change bar.

Position

Left/Right of column; Side closer/farther to
Page Edge .

Colour

During development or for review you may
want to set a demonstrative colour such as
magenta.

Automatically … Switch the generation of change bars on
and off with this check box.
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Clear all …

Accept all changes (clear all change bars)
with this check box. There is no Undo for
this function!

Set

Click this button to activate the settings.

v-08

Change bars

Change bars in books

The properties dialogue is also available in a FrameMaker
book. Settings become active for all selected files in the book
window.

Find changes

To be able to find changes indicated by change bars it is best
to set up a character format (e.g. changed) with the sole property Change Bar and apply this format to the pertinent text.

Selectively apply/remove
change bars

You may wish to apply change bars independently of the
automatic application. You can do so for paragraphs or character sequences:
p To apply a change bar to a paragraph, open Paragraph
Designer > Default Font and check the box Change Bar.
Then click Apply.
p To apply a change bar for a sequence of characters, select
the text area and apply a character format specifying only
the application of change bars.
p To remove the bar from a paragraph or part of, select the
paragraph and apply the Default Font character format.

Note:

When copying paragraphs (or character sequences) with
change bars, you copy this property also!

Change bars for graphics
As stated earlier, only text in text frames get change bars. To
indicate changes in pictures, an additional anchored frame is
necessary which contains the change bar:
This is a text line with changes
The graphic has changed also

p Create an anchored frame Outside Text frame with Side
Farther from Binding (or closer depending on the settings
for the standard change bars). Set height to about 2 cm,
width to 0.5 cm and Distance above Baseline the same as
the height (2 cm). For this demonstration it is filled pink.
p Place a vertical line in this frame and (although you don’t
see its extension) give it the length of the page height. Colour and thickness should be the same as defined for the
Change bars.
p Keep this frame in an auxiliary document (see Boiler plate
elements on page B-14) for easy copy and paste.
p Copy this frame to the same paragraph as the anchor of the
frame with the graphic and adjust the height at the lower
end.
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Revision pages
27)

2011-05-11

Point pages (also called Revision Pages) got their name
from the page numbering scheme of inserted pages after the
original pagination has been frozen: 16, 17, 17.1, 17.2, 18 …

Although this feature is available in FM since version 3, its
documentation has been removed with version 6. This is
probably due to its disputed implementation.

FrameMaker method
Restrictions

p Revision pages (point pages) can only be inserted into documents with a single text flow and no body page overrides
of master page layouts.
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p If a document contains multipage tables or anchored
frames with the floating property, the freezing of the pagination may create unwanted results. Content after the last
table page is pushed onto a following page.
p Paragraphs crossing page boundaries will be divided into
two paragraphs when freezing the pagination. Unfreezing
ca not merge these parts to the original paragraph. Hence a
page crossing justified paragraph will get a flush left last
line in the first part of the split paragraph.
p Autonumbering is reset on each page.

Insert revision pages

To be able to insert revision pages, the current pagination
must be frozen:
1 In the document to be frozen, type ESC, p, z
2 Select the numbering scheme of the additional point-pages
to be inserted.
3 Freeze will make all pages independent (not connected).
4 Any inserted ‘disconnected page’ will get nnn.mm as page
number.

D

5 Adding content (overflowing into a new page) will create
point pages. Removing content will not repaginate existing
pages.
6 To change the numbering style of the point pages without
unfreezing the pages, type ESC, p, z and select the new
numbering style. Then click Set Page # Style.

Unfreezing pagination

After the revision pages have been printed, normally the document is consolidated with consistent pagination. For this
purpose the pagination is unfrozen:
1 Type ESC, p, z to display the Unfreeze Pagination dialogue.
2 Click Unfreeze
3 Text will reflow and pagination is back to normal.

27 FM-manual 5.0 page 25-7 ff; FrameMaker-4 for UNIX Solutions p. 129 f.
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Plugin PointPages
28)The

plugin PointPage from frameexpert.com is not publicly
advertised, because you strictly need to follow the instructions given for proper results.
The plugin avoids the drawbacks mentioned before (Restrictions on page 13-7). A different workflow is proposed:
1 Make sure you have a “snapshot” of the base document in
the form of a printed copy or PDF. This will serve as a reference for the pagination of the original document.
2 Make a copy of the base document that is ready for revisions.
3 Make edits and revisions to the document until you are
ready to release the revision.
4 Paginate the document so that page breaks of the original
content match those of the base document. Because of the
added content, the page numbers may not match the original document, but the page breaks should.
5 Freeze the pagination using the PointPages > Freeze Pagination command.
6 Use the PointPages > Convert commands to assign point
pages to the revised pages in the document.
7 If you are revising a book, repeat the above steps with each
document in the book that has revisions. Update cross-references and generated documents so that the point page
numbers appear where appropriate.

Note:

Additional functions

The documentation of the plugin provides more details to these
steps.
The plugin provides these additional functions:

Mark Current Page

Insert a PointPage marker on the current page. With Convert
Marked Pages to Point Pages, all pages with such markers
will be converted to point pages.

Delete All PointPage
Markers

Delete all of the PointPage markers in the document. This is
useful after you have unfrozen pagination to prepare a brand
new edition of your document.

Printing Point Pages

This is a separate plugin. It allows you to print point pages
and other changed pages in the active document or book.

Remove point pages

After a series of revisions, you may want to release a brand
new edition of your document without point pages. In other
words, you want to keep the revised content, but you want the
pages to number consecutively without point pages.

28 To the greatest part this text is from the plugin documentation.
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Tracking edited text

Tracking edited text

2011-05-11

The menu Special > Track Text Edits provides the same functions as the button bar via View > Track Text Edit Bar:

D
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Enable tracking

Select Special > Track Text Edits > Enable or click on

.

When tracking is enabled, then inserted or deleted or modified text is indicated by special conditions, such as
FM8_TRACK_CHANGES_ADDED. These conditions are not
listed in the Conditional Text tags.
The special conditions are displayed in the status area bottom
left of the window:

Note:

There are a number of text operations which are not tracked.
Generally, changes to formatting are not tracked. Some table
operations are also not tracked. See Help Revision Management > Track Edited Text.

Turn off tracking

Click the button
again or select Special > Track Text
Edits > Enable. Existing edits are not affected by this action
(they are neither accepted nor rejected).

Find changes

Either click the button
respectively
or select Special
> Track Text Edits > Preview Original > Show Next or
… Show Previous.

Preview the document

Before accepting or rejecting all edits it is good practice to
check the effect by previewing the document:
 Preview the final appearance (changes accepted) with a
click on
or select Special > Track Text Edits > Preview Final.
 Preview the original appearance (changes rejected) with a
click on
or select Special > Track Text Edits > Preview Original.
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Tracking edited text

Leave the preview mode by clicking on
Track Text Edits > Preview Off.

Accept/reject changes

or select Special >

For individual accepting or rejection select the pertinent text
edit and then click on the button
to accept or
to
reject the edit (or select the corresponding menu item).
To accept or reject all edits in the document click

or

(or select the corresponding menu item).
Note:

Save or publish
document

The regained text acquires formatting from the surrounding
text. Applied character formats are preserved.
If Preview mode is on, then the document is published or
saved according to the selected preview mode (Final or Original).
If Preview mode is off, then the result depends of the output
format:
Output format

Published or saved result

FM, XML

Both the status (e.g. tracking enabled) and the edits are kept.

PDF, Printer

Highlighting of the added and deleted text items are kept. The
edits are not interpreted as Acrobat Review comments.

HTML, RTF

Edits are accepted and then the document is published.

See also Save for review on page 10-4.
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List of effective pages
For technical documentation often the revised editions need a
list of the effectively changed pages (LEP).

2011-05-11

Normally, the front matter contains a list of the date on which
each page in the manual was last updated. Military and Aerospace manuals typically have hundreds of pages, and may go
through dozens of revisions that change only a few pages at a
time. Keeping track of everything is a big pain in the neck,
and it's one of the easiest places for an auditor to find a mistake.
[Clinton Owen, Senior Technical Writer, Crane Aerospace &
Electronics]
The required information depends. The following example is
from the Maldivian Civil Aviation Dept (repealed = removed).
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Civil Aviation Regulations

List of Effective pages

Part: Page No: Amdt No: Date

Part: Page No: Amdt No: Date

PART 1 Commencement & Interpretation

PART 4 -Aircraft Nationality and
registration marks
PART 5 Airworthiness of Aircraft

1.1
1.2
1.2.1
1.2.2
1.2.3

1-02
1-02
1-07
1-07
1-08

3rd Edition
3rd Edition
3rd Edition
3rd Edition
3rd Edition

May 2007
May 2007
May 2007
May 2007
May 2007

5.1
5.2
5.3

5-03 2nd Edition June
REPEALED
REPEALED

2002

The Hong Kong Aviation Dept. requires this format:

Page
Contents
Foreword
List of Effective Pages
Sub-section 1.1-2
Manual procedure

C P.1 to C P.6
F-1 to F-4
LE P.1 to LE P.4
1.1-2 P.1 to 1.1-2 P.2

Date
31 December 2004
1 July 2001
30 June 2006
31 July 2004

D

p Consider the text to be present in the LOEP. I decide on
revision number and page number only. For demonstration
I add on these two pages a revision date. Because the revision information of untouched pages must remain intact
this information can not come from variables – or you need
to set up variables rev0, rev1, … and place them.
p Place an unconnected text flow (name for example loep) on
the master pages. This must not be a background frame
without flow name. The size of the frame depends on the
contents it should get. In this chapter these frames are coloured.
p The only paragraph in the text frame has format (for example) xr-revision.
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p On the body pages insert on each page the revision text to
be listed in the LEP, for example: v-08 or (as on these two
facing pages: v-08 (2009-06).
p If the edits on the pages change the pagination, all entries
in the LOEP frame must be checked and appropriately
updated.
p From the document (or the book with all these documents)
create a list of paragraphs and select xr-revision. You
may wish to set the file suffix to LOEP to be able to create
other paragraph lists also.
p In the generated file adjust the reference page LOP (this
does not get the name LEOP as specified in the file suffix.
Also set up the generate paragraph format xr-revisionLOP
to your desire. For example, like this:
<$paratext> ...................<$chapnum>-<$pagenum>
p With the next generation of the LEOP you get it formatted:
v-08 ...................................... 13-2
v-08 ...................................... 13-3
v-08 ...................................... 13-4
v-08 ...................................... 13-5
v-08 ...................................... 13-6
v-08 ...................................... 13-7
v-08 (2009-06)....................... 13-8
v-08 (2009-06)....................... 13-9

v-07.................................... 13-10
v-07.................................... 13-11
v-07.................................... 13-12
v-07.................................... 13-13
v-07.................................... 13-14
v-07.................................... 13-15
v-07.................................... 13-16
v-07.................................... 13-17

Method of Clint Owen

My method relies on an extra text flow on each page. There is
room for just two lines; the page number and the date. As
long as there is only one date related paragraph tag and one
page number related paragraph tag on each page, it's easy
enough to create a List of Paragraphs which becomes the
LOEP. You can't do it on the master page, because you a need
a tag that can be uniquely associated with each page in the
book.

v-07 .................................... 13-18
v-07 .................................... 13-19
v-07 .................................... 13-20
v-07 .................................... 13-21
v-07 .................................... 13-22
v-07 .................................... 13-23
v-07 .................................... 13-24

I am still working on a complete explanation of how it works
and how to set it up.
[Owen, Clint <Clint.Owen, craneaerospace, com>]

Tool to generate a LEP

Silicon Prairie Software has a special tool to create a LOEP. It
is available for FrameMaker 6.x, 7.x, and 8.
The tool inserts special markers on each page based on a template. The marker contains information, when the page was
last updated. The generated list of these markers contains all
pages. So sort out only those of a particular revision level,
additional work is required.

13 – 12

v-07

Conditional text

Conditional text
Note:

Table columns (or individual cells in a table) cannot be made
conditional. Only whole table rows can be conditional.

2011-05-11

Application of conditional text
Organising and implementing conditional text may be difficult. However, in the following cases it may be worth the
effort:
Product levels
Development

Information which is not yet fixed can be hidden in the current release.

Review comments

Questions to the reviewer and the answers can be placed in
conditional text which may be hidden to print a clean draft.

Platform dependencies
Tutorials
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Standard, extended, professional may be the names for conditions in this case.

Delivery medium

Compare documents

In software descriptions it may be useful to tag with Windows, Mac and Unix.
For training manuals you may wish to have both the Student
part and the Instruction part in the same document.
Maintaining single source documents may require to handle
special portions for the CD release, the printed version and
the version for the web.
File > Utilities > Compare Documents … creates a new document with two conditions (inserted, deleted) relative to the
current document.

Keep it simple
 Although FrameMaker 8 allows to define more conditions
than with previous versions, avoid assigning multiple condition tags to the same information. FM8 gives you the
choice to define conditions based on other conditions by
logical expressions. See Display conditional text by logic on
page 13-16.
 Limit the number of conditions to the minimum. There is
only a limited set of styles to represent the condition,
although you can have many colours …

D

 Use distinct condition tag names which alphabetise well.
 If possible, tag entire paragraphs and not portions of paragraphs, such as sentences or even words.
 Define standards for spaces and punctuation consistently
(either always conditional or always non conditional).

Alternatives for conditional text
Variables
Custom markers

13 – 13

Company names, brands, product names and other short
pieces are better handled by variables.
Use custom markers for different types of indexed information.
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Note:
Chapters

Files

Be aware that hidden conditional text also hides all markers in
that text (e.g. cross reference sources, index markers).
Instead of applying conditions to whole chapters, create alternative books. To avoid conflicts between the generated documents (e.g. the TOC or index), define individual prefixes in
the book variants (e.g. TOC1 in the first book, TOC2 in the
second).
You may break down a particular chapter into files. Placing
the text inset referring to the file into a condition allows you
to maintain the file independently (see Text insets on
page 13-18).

Setting up conditions
Before applying conditions set up a scheme about the conditions you need. For example, a software manual may have
parts only relevant to operators and system programmers.
If you have portions only for beginners, you may face a ‘subtracting’ condition. The unconditional text is common to all
types of readers and hence may not contain all parts for
standard users. A possible scheme is this:
Conditional text to be included
Type of reader

std_user

operator

system

beginner

Beginners

not in

not in

not in

in

Standard user

in

not in

not in

not in

Operator

in

in

not in

not in

System programmer

in

not in

in

not in

IT may be appropriate to have graphics depending on conditions (the frame anchor has a condition) in different directories.
Use conditions in the text always in the same order, for example: std_user, beginner; operator, system.

Handle conditions
Presentation of
conditional text

The following text is in condition tag “Comment”.
This text is of condition “Comment”. This is very useful for
 editorial comments
 this is both Comment and Detail - colours are mixed
This is the last line with both the condition Comment and
Detail.
This paragraph is without any condition, the following paragraph is “Detail”:
This text has condition “Detail”. This is an example, how to
use conditional texts for variants of documents. Details are,
for example, only needed for a certain type of readers.
This paragraph is without any condition.
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Handle conditions

Define a new condition
To define a new condition tag (for example, operator):

2011-05-11

1 In Special > Conditional Text > Mange condition… and
click Add.
2 Provide the new name in the edit box and select an appropriate style and colour for the display (this style is not
used for printing!); Set! The condition is now listed in Manage Conditions dialogue.

Edit a condition tag

1 In Special > Conditional Text > Mange condition… and
click Edit.
2 You get the same dialogue as for adding a new condition
tag, where you can modify the settings. Then click Set.

Display the current
condition of a text

E:\FM-course\handout\specials.fm

1 Place the cursor in the appropriate text
2 Special > Conditional Text > Apply Conditional Text...
displays the dialogue Conditional Text. This dialogue can
stay open during work.
3 The radio button in Current Selection Is says whether the
text is unconditional or conditional. The lists display the
applicable conditions:
In
The current selection is in this condition
Not in The current selection is not in these conditions
As is The current selection contains both text which is in
a condition and text which is not.

Apply a condition
To apply conditions you will need to define the condition tags
and the appearance of the conditioned text:
1 Select the text which will receive the condition (for example
“comment”)

D

2 Special > Conditional Text > Apply Conditional Text... If
you do not see the desired condition tag in the “Not in:”
column, you must first set up this tag (see Define a new condition on page 15).
3 Set the current selection to Conditional (radio button) and
move the desired condition to the left column (“In:”) and
click Apply.

Remove conditions

1 Select the text you want to make unconditional
2 Select Special > Conditional Text > Apply Conditional
Text...
3 Activate the Unconditional radio button
4 Click Apply.

Copying conditions
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You can use Copy Special > Conditional Text Settings and
apply the condition(s) to a target selection by Paste.
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Conditional text

Display the conditional text
Hidden conditional text is represented by a maker symbol (6).
At the beginning of a line the left portion of the T-arm is
invisible (truncated by the boundary of the text frame).
Note:

If you delete a Conditional Text Marker you actually delete the
conditional text!
To display (and print) text with and/or without any condition,
the following steps are required:
1 Select Special > Conditional Text > Show/Hide Conditional Text.
2 To display (and print) everything, activate the radio button
Show All.
3 To display (and print) only certain condition texts,
-

move the conditions into the appropriate column (Show
or Hide).
Activate radio button Show as per Condition

4 Click Set
Note:

You may move all tags at once with SHIFT+click on an arrow.
The condition indicators (underlining, colour) are only visible
if Show Condition Indicators is checked.
Table rows are displayed checkered if the conditions display
contains underlining, over lining or strike through.

Display conditional text by logic
FrameMaker 8 allows to specify conditions based on logical
expressions.
Note:

No parentheses are possible in condition expressions.
1 Select Special > Conditional Text > Show/Hide Conditional Text.
2 Activate Show as per Expression
3 Click on Build Expression, which opens the second dialogue.
4 If in the right pane a definition already is displayed, click
Clear to start afresh.
5 To build the expression,
-

Select a condition tag in the left pane and click --> to
insert it in the right pane.
Click on AND, OR or NOT to set the logical operation
with the next condition tag (AND has precedence to OR)
Select the next condition tag

6 Click Set to define the condition. This is displayed in the
first dialogue.

Note:
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Between AND or OR and NOT no blank is allowed: ANDNOT.
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Display conditional text by logic

Examples

Tests are from Johannes Graubner (graubner, transcom.de).
We have defined 4 conditions, AAA, BBB, CCC and DDD and
applied them to texts, both single and in combinations ( AAA

+ BBB, AAA + CCC , AAA + BBB + DDD, AAA + CCC + DDD,
AAA + BBB + CCC , AAA + BBB + CCC + DDD , BBB + DDD,
CCC + DDD , BBB + CCC , AAA + DDD.
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AAA AND BBB

AAA AND BBB
OR AAA AND CCC

Published are texts with either condition AAA AND BBB or the
conditions AAA AND CCC. Other conditions applied to the
texts are irrelevant. 8 AND has precedence before OR.

BBB ANDNOT CCC

Published is all text with condition BBB (and probably other
conditions) as long as condition CCC is not present.

BBB ORNOT CCC

Every text not containing the condition CCC is published.
Exception: If the condition is BBB+CCC this text is also published.

AAA AND BBB AND CCC
OR AAA AND CCC
AAA ORNOT BBB
AND AAA

D
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Texts with condition AAA and BBB (alone or combined with
other conditions) are published. Texts with other conditions
are not published.8 The boolean expression is complete and
closed.
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Text with just AAA+BBB is not published. AND chains must be
completely fulfilled, but may be ‘overcrowded’.
Everything containing condition AAA is published. This is a
nonsense expression. ORNOT is not clear here.
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Text insets
Text insets are pieces of text imported by reference. These can
be
Sources of text insets

 A file processed by import filters (original ASCII text, MSWord doc etc.)
 A text flow from a FrameMaker document, which may be
the current document. In most cases the complete file (the
complete flow A) is imported.
 A text flow from a FrameMaker document which is in MIF
format.
Text insets can be arranged in a single file in different flows.
The flows may be located in reference pages and can have memorable names, for example warning_highvoltage,
warning_hotwater. In file text_inset.fm a flow A provides an
introduction and flow warn_1 is short flow with boiler plate
text.

Purpose

The purpose of text insets is to avoid duplicates of text. It is a
method of re-use. However, reuse is not free. You need to take
steps to be sure that content works in multiple locations or
contexts.
There is no mechanism in FrameMaker that provides information about where a piece of text is used. Hence it its good
practice to keep this information within the text inset:
 In a text frame on a reference page
 At the beginning of the text in conditional paragraphs (e.g.
condition = Comment)
 By support of a special script which pops up at open time

Organising text insets
To avoid to many open files it is good practice to assemble
text insets in a project specific file.
For each inset define a specific flow. Name them properly to
be able to distinguish them.
For ease of maintenance establish the flows on the body
pages of the specific document.
When defining text insets in a template, establish the flows on
reference pages. Also here the naming may help the user to
get the correct inset. Names may be arbitrary, such as
chapt_overview.
Since a flow may contain everything from text to anchored
frames and tables, the inset behaves a sub-document.

Updating insets

It is good practice to precede each inset flow with information where the inset is used.
If you have your inset flows in distinct files rather than all in
one file, make a book of these inset files to find them easily.
The files in the book can be in any location (different projects
etc.).
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Import text flow from a Frame document

Import text flow from a Frame document
1 Select File > Import > FIle …
2 Specify the proper file name in the File selection dialogue.
Choose Import by Reference. After clicking Import you
get the dialogue displayed here.

2011-05-11

3 Specify whether you want to import a flow from the body
pages or from the reference pages. The latter is necessary to
import from the current (host) document.
4 Select the proper text flow.
5 Choose the appropriate formatting option. Normally you
want to Retain Source Formatting (especially if the insets
use the same template as the host document).
6 Click Import.
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The imported text is placed at the current cursor location.
The paragraph format of the insert is derived from the first
paragraph format in the inset (here: chapt_overview.

Avoid re-formatting
When importing a text inset at the end of a paragraph, that
paragraph gets the format of the first paragraph in the inset.
Importing a text inset in front of a paragraph does not re-format that paragraph).
When using empty ‘anchoring paragraphs’, insert a required
blank prior to importing the text inset in front of that blank.
You may wish to use a special format for the anchoring paragraph (small size, …):
before importing 8
place the insertion
point (cursor) here

3¶
If you need to arrange text insets one after the other (modular
texts) you may wish to define the ‘anchoring paragraph’ as
Run-in-head which does not cause a line break at the end of
the paragraph. Do not fill the Default Punctuation field with
the non breaking space! This space must be in front.

Text inset with variables and references
D

Text insets imported by reference have some properties,
which must be considered when using them:
 Referenced texts can not be edited (obviously...)
 Formats (paragraph styles, table catalogue, character catalogue, cross-reference formats) stay local to the embedded
document and are not added to the embedding document.
 Variables from the inset are copied to the embedding document and hence can be updated there (or the surrounding
book).
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Updating text insets
Whenever a FrameMaker document is opened references to
other files (text inset, graphics) are updated. If this is not possible (for example, the file was moved or renamed), an error
message is issued. Use Edit > Find and find “Unresolved Text
Inset”.

Update particular text
inset
1 Double click into the text (this is selected and a dialogue
appears).
2 In Text Inset Properties click on Update Now.
3 If the inset can not be updated (moved, renamed) an error
message gives you a chance to search it yourself).

Update all references in
file
1 Edit > Update References...
2 Activate the appropriate check boxes.
3 Click Update.

Update everything in a
book

To update all references in a book,
1 Open the book file
2 Update external references with File > Generate/Update…
The process may halt in a particular file with “unresolved
xyz”. this may be a cross-reference or an inset or a graphic
file. In this case open that file and find the unresolved xyz.
If unresolved cross-references are in the master pages (for
example, a reference to a paragraph-number) this can not be
discovered easily. The book error log points only to the body
pages. You need to display the master pages and search for
the unresolved reference.

Note:
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As long as you have not cleared the problem, the generate/
update process will halt at the first error.
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Import examples

Import examples
For the sake of demonstration the text insets are underlaid
with a colour.

2011-05-11

Note:

In the following example the variable Filename [Long] with
the format <$fullfilename> is set from the container (as all
variables used in insets are). Hence the path noted the path of
the current document - and not that of the inset!

Text inset from flow
warn_1

This is a flow from file E:\FM-course\handout\specials.fm.

Danger du
mort

ACHTUNG! ALLES LOOKENSPEEPERS!
Das computermachine ist nicht fuer gefingerpoken und mittengrabben. Ist easy
schnappen der springenwerk, blowenfusen und poppencorken mit spitzensparken.
Ist nicht fuer gewerken bei das dlumpkopfen. Das rubbernecken sichtseeren keepen
das cotten-pickenen hans in das pockets muss;
Relaxen und vatchen blinkenlichten!!!
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This is a cross reference to the flow A in this inset: Target of xref from flow B in this inset on page 21. In PDF this crossreference will not become a hyperjump.
Here we are in the container document. The above (coloured)
text inset is inserted at the beginning of this paragraph. This
is a cross-reference into the inset, flow A: Inset from text flow A
on page 13-21. This will become a hyperjump in PDF:

Inset from text flow A

Variable set in the container. Cross reference to another
chapter in this book (in PDF this cross reference will not
become a hyperjump): Teamwork on page B-11. Please note
the special format which is local to this text inset.

Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor et triceps, magicarum artium
magistra ac fascinationum praeses, cinctra latrantium canum turma.

Target of x-ref from
flow B in this inset

D

This file (E:\FM-course\handout\specials.fm) is used as an
example of import by reference in various situations. Paragraph styles are the same as in the main document with the
exception of z_text-inset, which uses a script font for easy
recognition.

p Hecate est Iovis et Latonae filia, soror Apollinis. Est tricopor et triceps, magicarum artium
p vel prope sepulcra et ubi loca sunt caedibus contaminata.
Note:

Hecate est Iovis et Latonae filia, soror Apollinis. Cinctra latrantium canum turma; noctu stans in triviis vel prope sepulcra et
ubi loca sunt caedibus contaminata.
This is a cross reference from inset (flow B) to the container
document: Problems and pitfalls on page 13-22. It will not
become a hyperjump in PDF.
The text inset is inserted at the beginning of this line. Normally you will place an insert at the beginning of a paragraph
just containing a required blank.
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Problems and pitfalls
Cross references
Types of cross
references

Container C1
D

E
Inset I1

Container C2

A

C

F
Inset I2

B

Inset I3

Cross references which will not become live hyperjumps in
PDF, are presented with coloured background in this table.
Location of x-ref Source of x-ref

Example

Source (Source Type)

Container

Container (in
same book)

A

Paragraph

Container

Inset

B

X-ref marker

Inset

Same inset

C

Paragraph

Inset

Other inset

D

X-ref marker

Inset

own container

E

X-ref marker

Inset

other container

F

X-ref marker

When setting up a cross-reference in a text inset to a location
outside the text inset, you must always configure the x-ref to
point to a cross-reference marker in the reference container
file. You can not refer directly into another text inset.
To set up an xref to a location outside the text inset (either to
another text inset or to the container) you first create a crossreference marker at the destination/source (Special >
Marker, Marker Type: Cross-Ref, Marker Text: something
meaningful that identifies this location). That is, you must
not use the automatically generated markers to headings via
Special > Cross Reference…
If this source you just inserted is in a text inset, you need to
update it in its container (so the container “knows” about the
new marker). Then, when you select Special > Cross-Reference to insert the xref, set Document to the container document in which the text inset with the source marker resides,
and set Source Type to Cross-Reference Markers. In the list of
markers, find that meaningful marker text you entered for the
source marker.
Concerning PDF

Cross references within a text inset are not converted into live
links in PDF. One workaround is to produce a PDF as follows:
1 Open all files in the book, update the book, and save all
files.
2 “Flatten” all the text insets, that is, convert them all to text.
3 Save as (or print to) PDF.
4 Close all the files without saving.
Another workaround is to use Rick Quatro’s FrameScripts
ResolveInsetXRefs (to be licensed). The first script unlocks
the insets and saves their markers to a data base. Then it
updates the markers to point to the correct pages.
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Problems and pitfalls

Find and Replace

FM does not look into text insets when searching for a string
or an object. You must open the text inset file and search
there.

Spell checking

Since Find does not look into a text inset, spell check does
also not look into. You may use the following method to spell
check text insets:

2011-05-11

 Set up a (temporary) book with all the files used as text
insets.

D

E:\FM-course\handout\specials.fm

 Spell check in this book.
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Document structure
Structure aids the user
All natural objects inherit structure. Even rocks are structured. You don’t need to think about the atoms and molecules. Look a t a tree and its leaves, on crystals or live bodies.
Things without structure (amorphism), such as slime will
shudder us.

Purpose of structure

Structure is required for orientation. Assume a town without
street names and houses numbered by their building
sequence. Only an outside navigation system like Google
Earth will help you find the desired location.
Structure reflects the inner logic of things. Recognising an
uneven structure points to a deteriated logic. A misshaped
structure may point to a misshaped logic.
1
2
3
4
4.1
4.2
4.3
4.3.1
4.3.2
4.4
5
6
7
7.1
7.2

The left tree is really crooked. Items 1 … 3 may be combined
into one with sub levels (same probably for 5, 6and 7). Of
course in real life an ideal structure like the one to the right is
not always possible, but this is the direction to go.
A subject calling for a main topic must be as important to be
broken down into topics and subtopics. If it can not be broken down, then is not that important and belongs to a deeper
level.
Deeply nested structures do not serve the user, because our
comprehension ability is limited to 3 to 5 levels. Hence more
levels just disorient the reader. Fine grained information may
be put into a table or a list.

FrameMaker document
structure

FrameMaker documents are structured with the following
mechanisms:
 A book refers to chapters or parts of
 A chapter (or part of a chapter in a file) is broken down
into sections by means of headings (1heading, 2headings)
There is no control of the structure. You are free to place a
heading level 3 just after the chapter heading... Rigid control
over structure is maintained with the SGML mechanism available with the Structured Interface (Structured documents on
page 1-22).
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Checking structure

Heading levels

There is ample discussion about the adequate number of
heading levels in documents. In this compendium I stick to 3
levels and a forth level are the captions in the margin area.
Reid Gray [rgray, interactivesupercomputing, com] gave an
excellent comment on this issue for user documentation:
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Reid Gray

In general if your heading levels descend below three or four
in user documentation, you need to take a step back, analyse,
and rebalance. Nothing new here, just the old axiom “be nice
to your user...” You can apply the same principle to the navigation over enterprise web sites.
If you find yourself descending past three or four, redefine
your level 1 heads (perhaps a level 1 head gets removed and
two level 2s beneath it promoted). Do what makes sense.
Rebalance it. If you find yourself descending past four, five,
or six you might have a guide hiding within a guide. Break it
out.
An outline or book structure is like a decision tree or even a
binary tree. The more levels you force me to descend, the
higher my cost in 'look-up' latency, the harder it is for me to
recall the context or navigate back to the heading, and the
more painfully disoriented I become. If disorientation is a feature or adding levels is a requirement for your particular documentation (legal writing, city electrical codes, cell phone
billing statements, philosophical treatise), then you are okay
in descending as many levels as needed, just remember to
index or enumerate 'said' headings adequately so folks can
cite them at a later time from equally disorienting prose.
Another version of “be nice to your user” is “don't Hegel your
audience” (although even Hegel had a tendency to articulate
or 'piece' general concepts into threes).

Checking structure
A document should keep a logical structure which depends
on the subject the document is about. For example, the structure of a user manual for a machine is regulated by standards.
to judge the value of structure, look at a beautifully shaped
tree with its branches, twigs and leaves.

D

The physical structure of a document is reflected in the book
file. The logical structure can be seen in the Table of Contents
and some aspects can also be seen in the index.
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Check structure with TOC

Check structure with
index

In the enhanced structure we have a more even distribution of
lower levels, thanks the new category elements of the work
space:
Old structure

New structure

Working environment
Some discipline required.
Preferences
Customising FrameMaker
Control characters in the text
...
Palettes and catalogues
Tool palette
Catalogues.
Quick access bar (tool bar)
Menus and palettes
Graphic tools

Working environment
Starting FrameMaker in standard mode
FrameMaker work space
Some discipline required
Preferences
Navigate the document
Customising FrameMaker
Sample templates
Control characters in the text
Appearance of check boxes.
...
Elements of the work space
Palettes and catalogues
Quick access bar (tool bar)
Menus and palettes

For example, the index of this compendium first displayed
these entries:
editing
cross-reference ............................. 7-8
graphic shape ............................... 6-9

How about editing footnotes or formulas? Well, there was no
such subject in there until the index making process revealed
this defect.

Modifying structure
Re-arrange files within a
book

The files comprising a book are rearranged with File > Rearrange Files... while you are in a book file.
If you have broken chapters into several files, you may need
to adjust the settings for the files (numbering starting at 1 or
continue, prefixes for generated files etc.) with File > Setup
File.

Re-arrange information
within a file

The standard FrameMaker interface does not provide an outline view of the document. In Structured FrameMaker the document structure is “the name of the game”.
The powerful API (plug-in) “Enhance” from Sandybrook Software for Standard FrameMaker provides thee features:
 Define up to 10 structural levels (1heading, heading2, caption,...)
 Move entire levels or parts of
 Promote and demote levels or parts of
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Modifying structure

Note:

Simulate an outline view

While Enhance can be installed in FrameMaker 8, it is not supported. Users have reported application instability when running Enhance on FM8.
To have at least permanent overview of the document structure, see Simulate an outline view on page A-30.
Wheen moving text portions you will frequently update the
view (a Table of Contents).

D
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 Sort paragraphs alphabetically
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Rubi in latin scripts
Rubi (also spelled ruby) characters are small, annotative
glosses that can be placed above or to the right or above of a
Chinese character when writing logographic languages such
as Chinese or Japanese to show the pronunciation.
[en.wikipedia.org]
Rubi text
Oyamoji text

Handling rubi text was introduced in FrameMaker with the
first fully functional Japanese version (5.5) in 1997.

Entering Rubi
In the western FM installations the menu position Special >
Rubi is not available. However, the function is available with
escape sequences.
1 Select the characters above which you want to type rubi.
This selection must not contain a line break (¶ or 2 ).

2 Enter ESC, s, r and type the text to appear as rubi. If the
selected characters span two lines, they will be moved to
the second line.

3 To terminate the rubi string, type Carriage Return. The
cursor is now back to base line.
Note:

If the rubi collides with the preceding line of text, either set the
line spacing large enough to accommodate the rubi (at least
150% of the font size) or turn off fixed line spacing.

Rubi properties
You specify the appearance of the rubi text with the Rubi
properties (ESC, o, r). For latin scripts the “Other Oyamoji” is
relevant. Use the middle selection as indicated by the screen
shot.
The left column of options specifies the spacing of the rubi
characters (upper part). The right column of options specify
the spacing of the rubi base (lower part, Oyamoji).
Rubi Properties
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Appearance (constructed text)1

Examples of rubi usage

Appearance (constructed text)1
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Rubi Properties

Examples of rubi usage
Interlinear translation

The following text displays the english translation of a latin
text as rubi:
Epicurus

indeed

from

the souls

of men

tore out

by its roots

Epicurus vero ex animis hominum extraxit radicitus
religion

when

from the immortal gods

both

generosity

and

benevolence

religionem cum dis inmortalibus et opem et gratiam
he removed

For

sustulit.

Cum

nature

while

the

best

enim optimam

he says is god’s,

he denies

naturam dei dicat esse, negat
benevolence.

He removes the very thing which is

D

gratiam: tollit

id quod

and most excellent

and

most excellent

et

praestantissimam

this very thing

idem

most

to be

in god —

esse in deo

natural

to the best

maxime proprium est optimae

nature

For what [is]

better

or

what

praestantissimaeque naturae. Quid enim melius aut quid
more excellent

[than] goodness and

benevolence?

Of which [trait]

praestantius bonitate et beneficentia? Qua cum
god

lack

deum vultis,
dear to god,

you would make no one

neminem

no one

neither

god

not

were you to make

carere
man

deo nec deum nec hominem

loved by him

no one

cared for [by him].

Thus

carum, neminem ab eo amari, neminem diligi vultis. Ita
it turns out

fit

that

not only [are]

ut non modo

men [paid no attention]

homines

are paid no attention by each other.

inter se neglegantur.
On the Nature of the Gods

Cicero, De Natura Deorum, I.xliii.
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by gods

but

the very

gods

a deis sed ipsi dei

Rubi in latin scripts

Modify appearance with
character formats

Initially the rubi text has the same properties as the base text
– except that it is smaller according to the setting in Rubi
Properties.
It is possible to modify both the base text and the rubi text by
character formats:
Example
1highlight applied to rubi text

cinctra latrantium

Explanation
Rubi text with character format

a b c d e f g h i j k

canum turma
D

contaminata
the rubi text

Use rubi function to
frame text

Rubi text uses a character format which changes font.
This font even contains a logo.
The rubi function can be applied to an anchored frame at
insertion point

Since the rubi text can contain an anchored frame at insertion
point it is possible to frame the base text:
Do this

Result

Create an anchored frame at insertion point with the desired appearance. It must not be filled. Select it and copy
it to the paste buffer.
At a convenient place set up two successive nonbreaking
spaces. Surrounding characters are placed here for better
understanding the effects.

aaa33aaa
cursor

Select these two spaces and enter ESC, s, r to create the
rubi construct.
At the current cursor location paste the frame. Depending
on its Distance above Baseline it will be higher or lower relative to the base line (here it is -4pt).
Now you have a template for framed text.
To select the frame, place the text cursor in front of the
last character before it (it is not possible to place the text
cursor with the mouse just before the frame) and move it
with 8 just before the frame. Now hold down Shift while
you select the rubi construct with 8. Copy the construct
into the paste buffer.
Paste the construct where you need the framed text and
enter the text between the two nonbreaking spaces.

abc

Type

33

this key

def

for …

You need to have an empty frame which you copy around and
fill with the desired text, because in the rubi base text characters can only be added. Removing characters with Backspace
or Delete breaks up the rubi construct.

Use rubi function for
special underlining

This tip is from Peter (at knowhowpro.com) Gold.
Do this

Result

Select the text to be underlined and apply the Rubi property to it (ESC, s, r)
Insert the characters used for underlining (in this case a
sequence of periods). Too many periods will expand the
rubi box.
Select the rubi text and move it to the desired location
(ALT+>). Do not move the selection out of the rubi box!
Final appearance
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Code samples

Code samples
Especially when documenting software code samples are to be
presented. Some methods are presented here.

Running text
2011-05-11

This form may allow to use a text inset of the whole code file.
See Text insets on page 13-18 how to deal with these.
However, normally only code snippets are documented, not
the whole code file. So the text is manually copied from the
code file.
Code is normally presented in a paragraph style with fixed
pitch font. In this compendium two formats are used: enexample-narrow and ew-example-wide. Background shading
requires a text frame within an anchored frame:
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en-example-narrow
Loop, %whichDir%FrameLog_*.txt
{
FileDelete, %A_LoopFileFullPath%
nFMdels += 1
}
text = Logging%A_TAB%%nFMdels% FrameLog files deleted
from %whichDir%
GoSub, WriteToFile

Since at least one line is to long, the other format might be
better:

ew-example-wide

This example is just text, no frames around. The shading is a
separate graphic object on the page which of course does not
flow this the text and must be adjusted when layout changes.

D

Loop, %whichDir%FrameLog_*.txt
{
FileDelete, %A_LoopFileFullPath%
nFMdels += 1
}
text = Logging%A_TAB%%nFMdels% FrameLog files deleted from %whichDir%
GoSub, WriteToFile

Table
Tables are handy if the code shall be commented, for example
by a column with statement numbers or a column with the
comment.
Tables offer the possibility to shade the background of the
code easily. Define a table with no ruling, but shading. Only
one column is needed. A second column may serve for numbering the statements or lines for reference.
Place the code as ordinary paragraphs and convert them to
the table (one paragraph per row):
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Statement number in first
column

1 Loop, %whichDir%FrameLog_*.txt
{
2
FileDelete, %A_LoopFileFullPath%
3
nFMdels += 1
4
}
5
6 text = Logging%A_TAB%%nFMdels% FrameLog files
deleted from %whichDir%

7 GoSub, WriteToFile

Figure 4: Code snippet from WinStart.ahk
Note:

To preserve indentation TABs during conversion, use “treat
each paragraph as a cell” and add any other column later.

More comments in third
column
1 Loop, %whichDir%FrameLog_*.txt
{
2
FileDelete, %A_LoopFileFullPath%
3
nFMdels += 1
4
}
5
6 text = Logging%A_TAB%%nFMdels% FrameLog files
deleted from %whichDir%
7 GoSub, WriteToFile

Find all FrameLog files in directory

Count the deleted files
Compose message for log file
Append message to log file

Figure 5: Code snippet from WinStart.ahk with extensive comments

Syntax highlighted code
If your code need to show syntax highlighting, it may be necessary to create snapshots from the code editor or a comparable service on the net (e.g. GeSHi - Generic Syntax
Highlighter).
Snapshot from
program editor

Snapshot from GeSHi
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Hints and tips

Overview
This chapter provides some hints to speed up your
work.
Solving real or assumed problems gives you tips which
result from the daily work with FrameMaker. For experts they may seem obvious, but not so for beginners.
For a complete list of all FrameMaker commands
(for older versions both for the English, German and
even French FrameMaker) see
www.daube.ch/docu/fmaker08.html

Contents
Keyboard input ....................................................... 2
FrameMaker set up ................................................. 9
Solving real and assumed problems ....................... 11
Simulate an outline view ........................................ 30
Recommended setup of FM ................................... 31
Import MIF snippets .............................................. 33

Keyboard input

Keyboard input
Short-cuts
Nearly any FrameMaker function can be invoked from the keyboard. ESC sequences (for example, ESC, o, F) are independent of
platform, but depend on the User Interface (UI) language.
Short-cuts using special keys depend on platform and (often)
UI language.
Since FrameMaker 8 special characters can be entered as Unicode characters and hence some special input methods are no
more needed. See Entering Unicode text on page 2-2.
Purpose

English FM version (Win)

Deutsche FM version (Win)

F9, para_stylename, RET

F9, para_stylename, RET

Format characters <superscript>a.)

F8, char_stylename, RET

F8, char_stylename, RET

Select graphic object

CTRL+click on object

CTRL+click on object

Select 1st / next drawn object

ESC, o, F

ESC, o, F

Select next drawn object

ESC, o, n

ESC, o, n

Keep graphic tool

SHIFT+click the tool

SHIFT+click the tool

Properties of selected / current object

ALT+g, p

ALT+g, o

Open Paragraph designer

CTRL+m

CTRL+m

Open Character designer

CTRL+d

CTRL+d

Open Table designer

CTRL+t

CTRL+t

Repeat last character modification

ESC, c, c

ESC, z, w

Repeat last paragraph modification

ESC, j, j

ESC, A, W

suppress hyphenation

ESC,n,s (front of word)

ESC, k, t (am wort-anfang)

Format paragraph

a)

TAB in table cell

ESC, TAB

ESC, TAB

Select entire table

triple click in any cell

triple click in any cell

Select table column

Double click close to R/L border
of cell

Double click close to R/L border
of cell

Select table row

Double click in the middle of a cell Double click in the middle of a cell

Add row after current row in table

CTRL+RET

CTRL+RET

Go to anchor position (behind anchor)

ESC, t, SHIFT+i (cursor to be in
table)

ESC, t, w (cursor in tabelle)

Insert variable name <superscript>a.)

ESC, q, v, name, RET
CTRL+0, name, RET

ESC, k, v, name, RET
CTRL+0, name, RET

Refresh display

CTRL+l (lower case L)

CTRL+l (lower case L)

Hyperjump from references

ALT+CTRL+click on the reference

ALT+CTRL+click on the reference

Previous view (goback) in same file

ESC, v, P

ESC, v, v

Pick up graphic properties

ESC, g, O (upper case letter o)

ESC, g, O (upper cas letter o)

Lock / unlock document (view / edit)

ESC, F, l (lower case L), k

ESC, d, Y

ESC, o, S

ESC, o, S

ESC o, H

ESC o, H

Open silently
Heroic open

b)

c)

Unicode

Open without updating references

CTRL+click on the Open button in the Open dialogue

•(bullet) appearance strongly depends!

CTRL+q, % / ALT 0149

CTRL+q, % / ALT 0149

\u2022

† (dagger)

CTRL+q, SPACE

CTRL+q, SPACE

\u2020

‡ (double dagger)

CTRL+q, ‘ (grave accent)

CTRL+q, ‘ (grave accent)

\u2021

™ (trade mark)

CTRL+q,, *

CTRL+q, *

\u2122

A–2
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Wildcard characters for Find dialogue

Purpose

English FM version (Win)

Deutsche FM version (Win)

Unicode

© (copyright)

CTRL+q, )

CTRL+q,)

\u00a9

® (registered)

CTRL+q, (

CTRL+q, (

\u00ae

¶ (paragraph symbol)

CTRL+q, &

CTRL+q, &

\u00b6

§ (section symbol)

CTRL+q, $

CTRL+q, $

\u00a7

… (ellipsis)

CTRL+q, I (uppercase i)

CTRL+q, I (uppercase i)

\u2026

— m-dash

CTRL+q, Q / ALT 0151

CTRL+q, Q / ALT 0151

\u2014

– n-dash

CTRL+q, P / ALT 0150

CTRL+q, P / ALT 0150

\u2013

ESC, blank, m /
SHIFT+CTRL+blank

ESC, s, m / SHIFT+CTRL+leerstelle \u2003

` ` n-space (m/2)

ESC, blank, n / ALT+CTRL+blank

ESC, s, n / ALT+CTRL+leer

\u2002

` ` thin space (m/12)

ESC, blank, t

ESC, s, t

\u2009

numeric space

ESC,

ESC,

\u2007

` ` non breaking space (m/3.5)

ESC, blank, h / CTRL+blank

ESC, s, z / CTRL+leerstelle

nonbreakable hyphen

ESC, -, h

ESC, -, w

\u2011

optional hyphen

ESC,-, D / CTRL+minus

ESC, -, t / CTRL+minus

see NOTE

Straight single quote

ESC, CTRL+'

see NOTE

Straight double quote

ESC, " (SHIFT+2)

see NOTE

`

` m-space

3 ,1

3, 1

d)

\u00a0

a. Name can be abbreviated to significant length
b. Another (empty) document must be open. No messages concerning missing graphics or fonts etc. are issued. this is a milder form of open Heroic.There may be hidden problems with the file, so be carefully with
save.
c. Another (empty) document must be open. This bypasses all sorts of checks to 'force' a file to open. Even
damaged files can be opened most time. Before any changes save the file and reopen it normally.
d. The Unicode Thin Space ( \u2009) is 1/6 … 1/5 of an m space, the FM thin space is 1/12 and hence may be
euqivalent to a Unicode Hair Space (\u200a).

Note:

Do not use a Unicode character for these. These are FM-functions, not characters.

Wildcard characters for Find dialogue

D

Use Wildcard must be set ON

Matching

Wild-card char.

Zero or more characters (excluding spaces and
punctuation)

* (asterisk)

Any single character (excluding spaces and punctuation)

?

White space or punctuation

| (vertical bar)

Start of line

^

End of paragraph
End of flow, end of table cell, end of footnote

$
a)

\f or \x0b

any character from list xyz (or alphanumeric)

[abcd] or [a-zA-Z0-9]

any character except the listed

[^abcd]

brackets

\[ and \]

Special characters such as TAB or m-dash

See Special characters in
dialogue boxes on page A-4

a. Table cells and footnotes are flows of their own. Hence when searching in document containing tables and footnotes and tables, the end
of the main flow will not be found immediately!

To find a $ or ^ while searching with Wild cards use \$ or \^
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Example

Note:

To find manually numbered paragraphs (start the line with an
optional text, then a figure, followed by a period and a TAB
symbol), use this pattern: ^*[0-9].\t
There are no wildcard notations for the replacement text.

Special characters in dialogue boxes
Since FrameMaker 8 any Unicode character can be entered
into the dialogues (for example µ, † or ‡). See Entering Unicode
text on page 2-2.
However, many special characters are not available on the
keyboard. They can be entered with a meta notation \xxx (the
\ ‘escapes’ from the literal meaning of the character). These
meta-notations are independent of the UI language and
platform.
Desired character

Meta

hex

TAB

\t

forced return

Desired character

Meta

\x08

guillemet single left (‹)

\(

\u2039

\r

\x09

guillemet single right (›)

\)

\u203a

start of paragraph

\P

\P

guillemet double left («)

\u00ab

end of paragraph

\p

\0a

guillemet double right (»)

\u00bb

start of word

\<

quote base single (‚)

\, (comma)

\u201a

end of word

\>

quote base double („)

\g

\u201e

quote double left 66 (“)

\‘ (grave)

quote double right 99 (”)

\’ (s. quote) \xd3 \u201d

end of flow / end of table cell \f

Unicode

\x0b

Unicode

\xd2 \u201c

non breaking hyphen

\+

optional hyphen

\-

\x04 NOTE

quote single (’)

\" (d. quote) \x27 \u2019

suppress hyphenation

\_ (u.score)

\x05 NOTE

accent circumflex (ˆ)

\@

\u02c6

backslash

\\

accent grave (`)

\{

\u02cb

non breaking space

\

\x11 \u00a0

accent tilde (˜)

\~

\u02dc

numeric space

\s# or \#

\x10 \u2007

hungarian umlaut (˝)

\&

\u02dd

thin space

\st or \i

\x12 \u2009

registered (®)

3 (space)

\u2011

hex

\u005C

\xa8

\u00ae

n-space

\sn or \N

\x13 \u2002

copyright (©)

m-space

\sm or \M

\x14 \u2003

trademark (™)

\TM

n-dash

\=

\xd0 \u2013

ligature Œ

\OE

\u0152

m-dash

\m

\xd1 \u2014

ligature œ

\oe

\u0153

bullet (•)

\b

\xa5

\u2022

ß (sharp s)

\xa7

\u00df

dagger (†)

\d

\xa0

\u2020

Y-trema (Ÿ)

\Y:

\u0178

double dagger (‡)

\D

\xe0

\u2021

z-caron (ž)

\k

\u017e

ellipsis (…)

\e

\xc9

\u2026

Z-caron (Ž)

\.

\u017d

fraction, non breaking slash

\/ (slash)a)

florin (ƒ)

\F

\u0192

per thousand (‰)

\%

\u2030

\xa9

\u00a9

\xaa

\u2122

\xda

\u2044

a. This is taken from the Symbol font, hence does normally not match the body font

Note:
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Do not use a Unicode character for these. These are FM-functions, not characters.

Characters with diacritical marks etc.

Characters with diacritical marks etc.

2011-05-11

Text entry

A rich keyboard (e.g. the Swiss one) gives you direct access to
all accented characters (except those with ring). These can be
entered both in text and dialogue boxes by two methods.
For characters not on your keyboard, but contained in the
‘old’ FrameMaker character set, you may use Escape
sequences or CTRL+Q- sequences. See Frame Roman code table
on page A-6.

Select from context
menu

With microtype’s enhanced tool bar installed, you can select a
great number of special symbols from the context menu. No
foreign characters (such as Å) are provided though.

Other Unicode characters

For characters not contained in the Frame Roman code page
use the methods described at Entering Unicode text on
page 2-2.
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Right-to-left scripts
Scripts writing from right to left, such as arabic or hebrew are
not supported by FrameMaker. Also Indic scripts are not supported. The Asian version of FrameMaker supports certain
double-byte codes. Of course also a corresponding version of
Windows is required for this.

Symbols and dingbats
Symbols not belonging to an alphabet are collected in symbol
fonts (for example: Wingdings, Symbol, Zapf Dingbats,
Monotype Sorts, Mathematical PI).
There are numerous dingbats defined in the Unicode standard. However the fonts mentioned do not support the Unicode
standard and hence these symbols must be accessed by their
Windows code.

Use symbol in text

For example, you want to enter the symbol  into the text.
This symbol is found in the font Windings3 at the location of
the character Ê, which has the code CA = 202. Do the following:

D

Quick and dirty:
1 Copy the symbol from the Character Map into the text. This
enters the base character: Ê.
2 Apply the font Wingdings3 to the character: .
Using character styles:
1 Define a character format (e.g. wingies) using the font
Wingdings3.
2 Copy the symbol from the Character Map into the text. This
enters the base character: Ê.
3 Apply the font property by character format (e.g. wingies).

A–5

Keyboard input

Use symbol in variable
etc.

Using symbols from symbol and dingbats fonts is only possible in such dialogues which allow to define a character format: numbering of paragraphs, marker text, cross reference,
user variable.
For example, to use an  in an index marker as “see”:
changing <wingies>Ê</> finding and changing
changing <wingies>\xca</> finding and changing

Frame Roman code table
Until FM version 7.2 only characters based on the McRoman 29) code
table were available. In FM 8 this table comes into play only with
Save As Document 7.0 or MIF 7.0.
Notes about the code
table
Escape sequences

Characters in rows 80 and 90 are created with esc sequences,
e.g. to get a Å type ESC, *, A (3 key strokes).

CTRL-q sequence

Characters in rows a0 … f0 are created by CTRL+q, followed by
a character from the ASCII code page at a respective. location
(loc ascii = loc fm - 80 hex); e.g. to get a Þ type CTRL+q, W (2 keys).

fi fl

These characters are available only on the Mac (FM 7.x).Windows FM 7.x does not handle these.

Note:

Unicode ranges

none

Characters CTRL-q v … } are accents. For example CTRL-q v (ˆ)
and ^ are different characters.
In the Frame Roman code table characters from various Unicode ranges are present. These ranges are indicated by coloured background. For your convenience the Unicodes are
provided in the third line of a code row (e.g \u00d9).

Basic Latin

Latin-1 Supplement

Mathematical Op.

Spacing mod.

Latin Extended-A

Alphabetic presentation form

General Punctutation.

Currency symbols

Latin Extended-B

Letterlike symbols

29 The MacRoman character table contains a number of symbos (e.g. infinity, less-than, Sigma, etc.) which are not present in the FrameMaker character set. These codes occupy characters from the ISO-8859-1 set. See
Apple’s MacRoman character set (check also section Differences).
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Frame Roman code table
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00

01

02

03

04

05

00

descr. suppr
hyph hyph

10

num nonbr thin
en
em
nonbr
space space space space space hyph

20

blank

30
40
50
60
70

!
0 1
@ A
P Q
‘ a
p q

"
2
B
R
b
r

06

07

08

09

0a

0b

TAB

NL

para
end

flow
end

*
:
J
Z
j
z

+
;
K
[
k
{

# $ % & ’ ( )
3 4 5 6 7 8 9
C D E F G H I
S T U V W X Y
c d e f g h i
s t u v w x y

0c

0d

0e

0f

, - . /
< = > ?
L M N O
\ ] ^ _
l m n o
| } ~ DEL

Ä Å Ç É Ñ Ö Ü á à â ä ã å ç é è
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80

:A

*A

,C

’E

~N

:O

:U

’a

‘a

^a

:a

~a

*a

,c

’e

90

ê ë

í

ì

î

ï

ñ ó ò ô ö õ ú ù û ü

^e

’i

‘i

^i

:i

~n

’o

‘o

^o

:o

~o

’u

‘u

^u

:u

\u00ee

\u00ef

\u00f1

\u00f3

\u00f2

\u00f4

\u00f6

\u00f5

\u00fa

\u00f9

\u00f9

\u00fc

:e

\u00ea \u00eb \u00ed \u00ec

a0

†

°

blank

!

¢ £ § • ¶ ß ® © ™ ´ ¨
"

#

$

%

&

’

(

)

*

+

,

¦ Æ Ø
-

.

/

\u2020 \u00B0 \u00A2 \u00A3 \u00A7 \u2022 \u00B6 \u00DF \u00AE \u00A9 \u2122 \u00B4 \u00A8 \u00A6 \u00C6 \u00D8

× ± ð Š ¥ μ ¹
b0

0

1

2

3

4

5

6

²

³ ¼ ½ ª

º ¾ æ ø

7

8

<

9

:

;

=

>

\u00d7 \u00b1 \u00f0 \u0160 \u00a5 \u00b5 \u00b9 \u00b2 \u00b3 \u00bc \u00bd \u00aa \u00ba \u00be \u00e6

¿
c0

@
\u00bf

¡
A

d0

P

B

C

D

E

F

\u00a1 \u00ac \u00d0 \u0192 \u00dd \u00fd

Q

R

”

‘

’

S

T

U

e0

‘

a

H

I

V

J

q

L

M

N

W

X

\u00fe

\u00ff

Y

⁄

¤

‹

› fi

Z

[

\

]

\u0178 \u2044 \u00a4 \u2039 \u203a

O

fl

^

_

\ufb01

\ufb02

„ ‰ Â Ê Á Ë È

Í

Î

Ï

Ì Ó Ô

b

c

j

k

l

m

\u00ce

\u00cf

ring

°

cedilla

double
acute

{

|

}

d

e

f
\u00ca

g

h

i

\u00c1 \u00cb \u00c8 \u00cd

š Ò Ú Û Ù € ˆ ˜ ¯ ˘ Ž
p

K

‚

\u2021 \u00b7 \u201a \u201e \u2030 \u00c2

f0

G

\u00ab \u00bb \u2026 \u00de \u00c0 \u00c3 \u00d5 \u0152 \u0153

÷ Þ ÿ Ÿ

\u2013 \u2014 \u201c \u201d \u2018 \u2019 \u00f7

‡ ·

?
\u00f8

¬ Ð ƒ Ý ý « » … þ À Ã Õ Œ œ

– — “
D

‘e

\u00c4 \u00c5 \u00c7 \u00c9 \u00d1 \u00d6 \u00dc \u00e1 \u00e0 \u00e2 \u00e4 \u00e3 \u00e5 \u00e7 \u00e9 \u00e8

r

s

t

u

\u0161 \u00d2 \u00d2 \u00db \u00d9 \u20ac
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circum
flex

tilde

macron

breve

v

w

x

y

z

˞

n

o

\u00ec \u00d3 \u00d4

˝ ž
~

\u02c6 \u02dc \u02c9 \u02d8 \u017d \u02da \u00b8 \u02dd \u017e

undef
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Non-width characters
With View > Text Symbols active FrameMaker displays special symbols such as anchors, optional hyphens etc. This display must not disturb the layout – hence these characters
have no width.
No width characters can be stacked at a place – for example,
anchoring several tables at the same place. This makes it very
difficult, to select a distinct element, which is either the special character itself (e.g. optional hyphen) or the anchored
item. Even with 500% zoom factor you can not grab an individual anchor (if markers are not separated by blanks).

Select a non-width
character (or narrow
characters)

1 Place the cursor behind the last recognisable character or
the end of the paragraph (as in this diagram)
2 With the arrow left key move through the characters (in
this case, before the closing parenthesis)
3 Hold down shift key while moving with the arrow left key
over the anchor. This “extends the selection” (GUI term).
4 The anchored object becomes selected also. So you know,
whether you have selected the right stuff...

...( )§
T

This is any text with an anchor
for the following table just here
( )

T
T

3

2

1

...( )§
T

If you didn’t catch the right thing, release the shift key, move
back one character (in our case with the arrow right key) and
repeat step 3 for any anchor which may be present left to the
already found one.
Of course you can apply this procedure also from left to right.
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FrameMaker set up
General preferences
With File > Preferences > General you set the most used
preferences:
2011-05-11

Automatic backup or Save creates a backup file whenever
you open the file. This file is overwritten at the next open. If
you want to preserve versions, you need to rename the backups.
Automatic Save every nn Minutes does not hamper your
working speed, because a save takes only little time 30). Use
this option at least at the beginning of a new installation.
Show File Translation Errors is useful when opening files
from another platform, which might not fully conform to the
current platform.
Some actions clear the undo history and hence FM will issue
warning messages when these actions are performed.
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p To avoid these messages, uncheck Show warnings while
clearing history.
p To reduce the number of messages, check Show warnings
… and choose Once for every history clearing command.
Greek Screen Text means display as gray box rather than
text.
Monitor size should be left at Default. The value is used to
adjust the divisions on the rulers.
Save Frame Image with Imported Graphic is set, if your files
are exchanged between platforms and the native image format you import may not be available on the other platform.
Set Cross Platform File Naming to the most restrictive platform in your environment (Unix < MacIntosh < Windows).
Network File Locking should be set, if you work directly on
network files and others my try to open the file also. Avoid
corrupted files by checking this option. FrameMaker will create a file document.lck which is tested for existence at open.

D

Switch between unstructured (FrameMaker) and structured
(Structured FrameMaker) with the drop-down-box Product
Interface. You need to restart FrameMaker after a change.

Be aware of unavailable
fonts

Uncheck Remember Missing Font Names only for specific
situations.
If a document contains fonts which are not available on your
system and this option is not set then all unknown fonts are
replaced by Times New Roman 31) and the information concerning the original fonts used is lost.
See also Font issues on page A-25.

30 If the files are on a network, this option may cause delays in working.
31 Correctly: by the font defined in maker.ini , section Fonts , item
DefaultFamily . Hence it is possible to specify the default font.
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Workgroup preferences
To work with shared files located on WEBDAV servers, you
need to set up File > Workgroup > Workgroup Servers.
With File > Preferences > Workgroup you set preferences
relevant for collaborative work.

Please consult Help with keyword workgroup for further information.

Units of measure
www.cl.cam.ac.uk states:
The length of an inch
changed from 1/0.3937 cm
to 2.54 cm in 1959; the size
of a point did not. Consequently, the imperial 'size' of
a point changed from 1/72
inch to 1/72.27 inch. [Knuth
1984, The T EXbook, p. 58]
DTP point = PostScript point.
1 ATA pt (American Typefounders
Association) = 0.013837".
1 TE X pt = 1/72.27"

When entering just a numeric value into an entry field in a
dialogue, FrameMaker uses the default unit (which depends
on purpose). Hence for clarity always enter also the unit.
Unit

Enter into
dialogue

metric
Equivalent

Imperial
equivalent

Definition

cm

cm

10 mm

03937. inch

mm

mm

0.1 cm

0.03937 inch

inch

in, "

2.54 cm

1 inch

USA, UK

pica

pc, pi, pica

4.2175176 mm

1/6 inch

12 points (ATA)

DTP point

pt, point

0.35278 mm

1/72 = 0.0139 " 1/72 US inch

Didot point

dd

0.376 mm

1.07 pt

1/72 French inch

Cicero

cc, cicero

4.531 mm

12.84 pt

12 Didot point

FM uses internally a unit of 1/1000 inch (1 MIL) = 0.0254 mm.

Platform specific information
Macintosh

FrameMaker 7.0 was the last version running on a Macintosh
(System 9). Hence this compendium does not contain any specifics for the Mac flavour of FM any more.
You may find this information on my web site. There is also
specific information about how to run the Windows FM version
on the Intel Macs.

Unix

FrameMaker 8 is the last version running on Unix (only Sun
Solaris). You may find some information for working on UNIX
on my web site.
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Solving real and assumed problems
See also hints and tips on the web: www.daube.ch/docu/
fmaker00.html
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Method to find the cause
of problems

The general method to encircle problems is to bisect the document and check each halve.
By further narrowing down to one page and then to paragraphs, tables, graphics etc. you can find the culprit.

General problems
Warning: Undo behaviour

Since version 7.2 FrameMaker provides multiple undo. However there are still operations which can not be undone and
which therefore clear the undo-history. See this Adobe document
for details of the function.
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If Show warnings while clearing history in File > Preferences > General is set, these messages may be quite annoying.

Toolbar can not be
switched

If for some reason FrameMaker (at least versions 6…8) was
not installed with administrator rights, then the small triangles to switch between the 4 groups of the toolbar do not
work.

Until your system support has re-installed FM correctly you
may use the vertical tool bar, which actually is a palette. Activate the vertical tool bar with the button
.

Strange behaviour of
document

There are situations where FrameMaker seems to have lost all
its ‘sense’. What’s going on?
FrameMaker relies on the system services for storage management, and these are not very water tight. Hence you may get
situations which are the result of lost pointers or other garbage in storage.
Most of these situations can be fixed with the following:

D

p Save the file in MIF
p Close the document (do not save it)
p Open the MIF file
p Save the file again as FrameMaker (you may wish to use a
different name to the original one).
In most cases the file now behaves ‘normal’ again.
Note:

Spelling checker does not
check
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Since strange situations often happen after long work, it may
be helpful to restart windows at least once a day.
See Spell checking odds on page 2-17 for a list of locations,
where spell checker does not look into.

Solving real and assumed problems

Can not copy/paste text

Text selected from a text line (produced with graphic tool A)
can be copied to the clipboard, however:
 it can only be pasted into a text frame (like this one);
 it can not be pasted into dialogue boxes;
 it can not be pasted into another application.

Typed text is wrong

After working with graphics you may notice that your keyboard is switched to a different locale, for example from German to US (y and z exchanged, < instead of ; and so on).
When working with graphics you can move an object with
ALT+arrow to nudge it by 1 increment. You may also use
SHIFT+ALT+arrow to nudge it by 6 increments. This
SHIFT+ALT is the default setting to switch locales in Windows. It is of course only active if you have more than one
locales defined in Control Panel > Regional and Language
Options > Languages > Details. You may wish to change the
trigger key with Key Settings … to something else than left
ALT+SHIFT. Unfortunately the choices are meager.
You may also live with this behaviour and switch the locale
with SHIFT+ALT back if you notice wrong input. It may be
helpful to place an icon in the system try showing the current
locale.

Find does not find

The Find function looks into the following areas:
 All text flows in the current set of pages (e.g. body pages)
 Text lines created with the graphic tool A directly on the
body page (“on paper”).
Note:

Be aware that objects are searched in the order of creation.
This may create the impression that things are not searched!
The Find function does not look into the following areas:
 Text flows on other types of pages. When starting on the
Body pages, it does not look into master pages etc.
 Text insets. These are separate files and must be searched
separately. See Text insets on page 13-18.
 Text after a CR (\x0D) character (the search stops at these
characters). These CR may be residues from a Word import.
These characters can only be found when searching from
back to front of the document. They can be eliminated by
MIF washing.
The problem of searching words with interspearsed markers
has been solved in FM 8. Hence search for gruppe profibusdp is now successful:

Find and Change crashes
FrameMaker

Error in FrameMaker 832): Find/Change operations causes a
crash when more than 2499 items have to be changed.

32 At least until FM 8.0p273 (second patch)
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Workaround 1

Add the following line in the [Preferences] section in
maker.ini (see issue #1555297 in FrameMaker 8.0's
ReadMeFirst.html)
ClearHistorySpecial=On
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After adding this entry, the Undo history will be cleared when
a global Find/Change action is executed, and the global Find/
Change action cannot be undone.
Workaround 2

No reformatting possible

Solution

If the problems happens with a book, apply the find/change
in individual chapters or groups of chapters.
You can edit text in a paragraph, but you can not assign a paragraph format or character format. Obviously the paragraph
is locked (most times caused by erroneous converstion of a
text inset).
p Save the file as MIF
p In the MIF file search for <PgfLocked Yes>
p Change to <PgfLocked No>

D
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p Save the MIF file and open it in FM - the paragraph can now
be handled correctly.
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Display and layout issues
Document window can
not be accessed

When opening a document which has been maintained on a
system with dual monitors you may be unable to reach a dialogue (e.g. find/replace) or a palette. In this case you have
“parked” a palette or dialogue on the second monitor.
You do not need to go back to the system with the two monitors to fix the situation.
Edit the “personal” maker.ini file. This is located in Document and settings (for example C:\Documents and
Settings\Klaus Daube\Application
Data\Adobe\FrameMaker\8.0\maker.ini)
Reposition the windows by setting x/y coordinates (not width
and height) to 0.
[DialogLayout]
;
x
y
w
h
CCatalog=1535, 586, 136, 384
PCatalog=1673, 129, 136, 839
Hypertext=500, 120
CFormat=1397, 385
8 character designer

Useful Windows trick

To reposition a window, make it the active window by choosing its command from the menu (or by typing the keyboard
shortcut), then type Alt+space to activate the title bar menu,
and type M for Move.

Note:

Do not move your mouse! Experiment with holding down different arrow keys until the dialog box comes back into view.

UltraMon

If you control your dual monitors with UltraMon and temporarily have only one monitor active (but UltraMon started anyway), you may move a hidden window to the active monitor by
these operations:
1 Activate the window in question with its command or menu
2 Type ALT+space, arrow up, ENTER (This selects Move to
Other Monitor) - Do not use the mouse during this operation.

Display jumps back when
scrolling

This is a known bug since FM version 4 at least. The problem
is caused by graphics with property “run around” which
touches or overlaps a text frame (which may be on a master
page).
 FrameMaker 6.0 and above should have cleared this problem.
 Use the free plug-in RunaroundNone
(www.frameexpert.com) to remove the runaround property
from all graphics.

EPS looks awful on
screen

An eps may contain a preview image, which is displayed on
the screen. The resolution of this preview image can be set in
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most graphic applications. If not, a default of 72 dpi (dots to
the inch) is used. Compare the two screen images:
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72 dpi preview

300 dpi preview

If you need to position graphic elements (arrows, pointers)
precisely or to get an idea of small print on an imported eps,
you need to create it with a good preview picture. Just zooming into the image in FrameMaker does not do the job.
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Note:

EPS prints, but on screen
is only gray area

Much better handling is done if you first convert the eps to a
PDF (distilling the eps). It may be necessary to crop the PDF
page after creation.
What you see on the screen is just the preview image contained in the eps (the other part of the eps is the Encapsulated PostScript). However, an eps can be produced
(depending on the creation program):
 without any preview. Then of course FM can not display
anything but a gray area.
 with a preview not interpretable on the current OS. For
example, eps created on a Mac often contain a preview
image of the format pict – which in most cases can not be
viewed on a Windows machine. Again you see a gray area. If
created on UNIX, the preview may be in format xwd (X Window Dump).
 with a “standard” preview of format TIFF – but there are so
many variants of TIFF defined, that you may end up with
one indigestible on your system – and again you just see a
gray area.

Remedy

If you can not sort things our with the creator of the graphic
you may do this:

D

1 Print the page with the image to a PostScript file and create
a PDF from it. In FrameMaker you can directly create a PDF
(save as PDF) from a single page document.
2 Crop the page in Acrobat to the size of the image and
export as eps with preview.
3 Import the eps to FrameMaker.
Note:

More PDF problems

FrameMaker can handle PDF as graphics, so you do not need
to create an eps at all. The PDF may hold several pages which
can be addressed individually at import – the eps can hold only
one page.
For solutions to more PDF problems see Some problems with
PDF files on page 10-17.
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Destroyed file contents?

After some work (e.g. delete rows in tables, heavy editing of
text) your screen may look very strange:

Line not
visible

Artefact of
re-formatting

 line thicknesses are wrong
 lines are lost
 text lines are intermingled
 graphics are incomplete
 etc.
Don’t panic, force a screen refresh either with CTRL+l (lower
case L) or PageUp, then PageDown or other scrolling and do
not forget to enlarge the image (the line may simply ‘fall
between the pixels’ as in the depicted case).

Text can not be selected
You can not select text, as long as the cursor has the shape of
a hollow arrow. Wherever you click with this cursor, the
object (text frame) is selected (you see the handles of the
object) - not the contents (the text).
Check the tools palette for the cursor setting. It will look as
displayed in the image.
You must select the ‘intelligent’ type of cursor (left button
with the two cursor shapes on it).

Paragraph can not be
removed or changed

After deletion of text insets you may have a paragraph, e.g. at
the end of a chapter, that can not be removed, its format
changed or otherwise manipulated.
 Save the file as MIF, open MIF in a good text editor.
 Search for <PgfLocked Yes> and assure the correct paragraph by checking the text around it.
 Delete the MIF line and save the MIF, re-open in FM.
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Ghost objects
You can access any object (e.g. a text frame) with CTRL+click.
But you create a duplicate with CTRL+drag...
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Real duplicates

The current (selected) object is the duplicate which you can
delete. It is often possible to undo the duplication operation.
Additional table headers

Another type of ghost object is an additional table header on
subsequent table pages
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The original heading row

Original heading row

This is something you can not get rid of, but you can not select it!

Try to cure this situation by

The first table cell

the second table cell

and the next table cell

the fourth table cell

the last line in the table

the last cell in the table

 Switching to the master pages, to look whether there is
something wrong.
 Switching back to the body pages with Remove Overrides
activated.

Concealed objects

Sometimes you can just see the black handles during the
build-up of the screen. They are invisible when the screen is
complete

D

text
frame

Cursor opening the selection area
If you suspect invisible
objects,

p Start a selection rectangle outside the text frame and sweep
the suspected area.
p This will select the hidden objects (if there are any).
p Bring them to the foreground with Graphics > Bring to
Front
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Where is the text?

You have just imported a large text into a text frame, but the
frame does not contain all the text.

A thin solid line at the bottom of the text frame indicates that
there is more text then the frame can hold.
Enlarge the text frame or arrange for a connected text frame
with the same text flow name.

Can not see facing pages

You have reduced the zoom factor to a value with which
pages could be arrange face to face (for example, to check the
layout), but they do not:

What you see

This is, what you want to
see.
You may need a lower
zoom factor if rotated
pages are in the document.
The view of a document is saved in the file, hence you can
have a different view on each open document.
In View > Options… select Variable for Page Scrolling to get
the display of facing pages.

Optional (discretionary)
hyphen not working

You may see ample space at the end of a line and try to split
the first word in the next line – but the word is not hyphenated…
You have just hit a WYSIWYG problem: with standard installation FrameMaker displays fonts with font metrics for optimised presentation of shape – but what we need is optimised
placement similar to the placement of text in the printed
page. See Display character positions correctly on page 32 for a
suggestion.
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DisplayUsingPrinterMetrics=Off

Right tab not working

DisplayUsingPrinterMetrics=On

When setting up text frames the inside text may not behave as
expected. For example, a right tab might not be executed:
right tab position not reached in text frame

logo or other graphic too close to text frame
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Reason

Watch out for a graphic close to the text frame. The graphic
may have the (default) run-around property “Run around Contour” with a gap value > 0.
As soon as this kind of graphic is closer to the text frame
than the gap value (or the graphic overlaps the text frame),
the graphic will push text away.

Correction

Remove any overlap or influence of the graphic by:
 placing the graphic far away from the text frame (distance
> gap value), or
 setting the run-around property of the graphic to “Don’t
run around”, or
 Allowing “Run around Contour”, but setting the gap value
to zero.

Heading numbers are
wrong

In a single file document with sections and subsections are
correctly numbered 1, 1.1, 1.1.1 etc. However, rather than sections 3 and 4 I get 5 and 6 although the numbering in the
heading formats is as follows:
Heading1 S:<n+>.< =0>< =0>< =0>
Heading2 S:<n>.<n+>< =0>< =0>
Heading3 S:<n>.<n>.<n+>< =0>
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Correction

Autonumbering in FrameMaker is rock-solid. These problems
are always caused by intervening paragraphs that have unintended autonumber counters. To find these (without an
appropriate script):
p Insert the cursor into the first misnumbered heading (or
other misnumbered paragraph)
p Open the paragraph designer on tab Numbering and note
the numbering label (in this case S:).
p Move the cursor upwards through the paragraphs and
watch the Autonumber Format in the paragraph designer.
Do not move to fast to avoid overlooking paragraphs with
small font sizes!
p The culprit uses the same numbering label, but with incorrect numering pattern, such as S:<n+>
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For a scripted solution see FrameAutomation.com.

Table does not split at
desired row

A table can not split automatically at a certain row, if
 vertically straddled cells hold rows together. Look at all
columns to find overlaps of vertically straddles cells.
 the table attribute “start on next page” forces a table start.
 the attribute “float” keeps the first page together
 Rows are kept together with “keep with next” or “keep with
previous”.

Example for vertically
straddled cells

The bordered frame is the text frame simulating 2 pages containing the table
The heading of the table
Watch the vertically straddled
cells which block table rows.
The heading of the table

page x
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Vertically
straddled
cells

page x+1

Vertically
straddled
cells overlap those
in column
2

Importing and graphics

Importing and graphics
Problems with imported
graphics

Vendors of graphic software tend to modify ‘standard’ output
formats, which are needed to exchange graphics between
applications (DXF, EPS, TIFF, WMF, etc.).
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If you encounter problems with a FrameMaker document after
importing a graphic, at first blame the graphic or its creating
application. To fix the problem:
 Import the graphic to another application - does it create
problems also there?
 Get another version of the graphic.
 Get the graphic in a different format (jpg <8 jpg2)
 But: there may also be problems in the import filters …

Imported graphic is not
visible

If you import a graphic and it is not visible in the container
(page, anchored frame, graphic frame), you may just see a
white portion of it:
1 Select the container frame and with CTRL+a select all its
contents. You will not see the object handles inside the
now unselected container.
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2 If there is really no graphic in the container, all graphic
menu items (or buttons) are greyed out. You will re-import
the graphic.
3 Group the invisible selection just in case more than one
object is in the container.
4 Scale this contents down very much and Align Tops and L/
R Centers it in the container.
5 Now you should see the complete graphic, at least very
small. Grab a corner handle and enlarge the graphic to the
size of the container:
The graphic you are looking for

At import this area was visible

The size of the imported object

What is this?

D

6 Now you may see what (might have) happened:
In most cases a small object is included in the complete
graphic – especially if an eps was created from a CAD drawing
not all surrounding stuff might have been removed.
The small objects may even be far out of the paper on the
pasteboard of the drawing application (e.g. Illustrator). To
avoid this error, you should not select all before creating
the eps, but select only the desired items and then create the
eps.
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Full path of inserted
graphics

The object property dialogue does not display the full path of
an imported object, if the path name is too long:
G:\VeryLongFilenames\Level02\...\TheImage.png
E:\VeryLongFilenames\L...03\Level04\TheImage.png
..\..\Samples\Glossary...s\Graphics\TheImage.png

Relative paths are used only up to a certain level of directories. I have not yet found out what this level is. In the above
examples the path for the document containing the image is
E:\FM-specials\Tips\GraphicsFiguresEps\Path-ofgraphics.fm
Method one

Find out the full path name by 're-importing' - just opening
the import dialogue for the selected image. In the Import dialogue expand the Look in the drop down list to see the full
directory hierarchy.

Method two

If you have the extended Send to function implemented in
Windows, you may get the full path with the Send To Clipboard function on the selected file:

G:\VeryLongFilenames\Level02\Level03\Level04\Level05\Le
vel06\Level07\Level08\Level09\Level10\TheImage.png

If you don't find this useful tool anymore on the MS-site, here
is a copy of W95powertoy.zip. Unzip and right-click on
SENDTOX.INF and select Install. It works fine in Win NT4, W2K
and XP (although MS negates this).
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Colour issues
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Colours of imported
image looks strange

Images which were prepared for commercial colour printing
may look strange when imported to FrameMaker. They have
been set up in the CMYK (cyan, magenta, yellow, black) colour
model, while Windows displays this image converted to the
RGB (red, green, blue) colour model.
FrameMaker stores colours internally as CMYK values. When
printing in Windows these colours are converted to RGB values, which may change the appearance due to conversion
errors and inaccuracies.

Inconsistent colour

One of the most pertinent errors is the inconsistent definition
of colour in files. You can not get rid of this without major
work:

Import colour from correct document

1 Open a document from which you know that the colours
are OK
2 Open the document with incorrect colour definitions.

E:\FM-course\handout\tips.fm

3 Import only the colour definitions (File > Import > Formats…) from the clean source document.
4 This import is cumulative, that is, special colours in the
target document are not removed.
5 If the problem persists when updating the book with the
file in question, an imported graphic may be the culprit.
Start with an empty document

1 Set up an empty file with File > New > Document > Portrait
2 Delete all entries in the catalogues (paragraph, character),
the table designer, the cross-reference formats.
3 Import the desired formats from the file with the colour
error - but do not import the colour specifications!
4 If you really have a special colour set up, do it again.
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5 Select the text in the file with the error and paste it into the
new file. You may use Select All (CTRL+A) to get everything.
Note:

In many cases, however, this method import the error with the
selected text (and graphics included etc.)

Just live the annoyance

Ignoring the problem is only possible if you do not intend to
take this document to a commercial printer!

Imported graphics

Imported graphics can be the source of invalid colour definitions. To find the graphic which causes the problem,
 Remove one by one of the graphics and check for the problem. As soon the problem disappears, you have found the
graphic in error.
 The colour definition in the erroneous graphic can only be
handled in the application in which the graphic was created.
 If the problematic graphic is an eps (Encapsulated PostScript), a TIFF or JPEG the original application can not be
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determined by the graphic type. Only Your intelligence can
help here …

PDF colour does not
match FrameMaker
colour

Especially if a particular colour is defined by selecting from a
colour library (Pantone, etc.) the colour in the PDF will look
differently than you see it in the FrameMaker, although it may
print correctly from the PDF.
The reason for is a colour model change from CMYK to RGB.
In maker.ini set the following parameter:
GetLibraryColorRGBFromCMYK=None

Explanation

33)

This option in maker.ini allows control over the display and
printing of library colours (e.g., Pantone) in FrameMaker. The
default setting (Printing) is correct, but the display and print
color may be different from previous versions.
Most library colours contain a CMYK value and a RGB value.
The CMYK value is used for printing and the RGB value is
used for screen display.
There are 4 values which can be used with this option:

Image in PDF cropped

Printing&Screen

This is the FrameMaker 5.x behaviour. It
will display and print the converted RGB
value.

None

This is the FrameMaker 5.5 behaviour. It
will display and print the RGB value produced by the color library.

Printing

This is the default in FrameMaker since version 5.5.6. It will display the RGB value produced by the color library and print the
converted RGB.

Screen

This displays the converted RGB and prints
the RGB values from the library.

When importing large PNG files you may notice that at the bottom the graphic is cropped (inside the anchored frame. To
avoid this, do one of the following:
 Convert the graphic to PDF and import the PDF.
 Add white space (enlarge canvas) to the graphic.

Huge number of colours

You may notice a huge number of colours in your colour catalogue after importing graphics of format png (portable network graphic). These colours are named RGB nnn,nnn,nnn.
You should not delete these, but also not apply to any
objects, since these colours may get lost when the file is
saved as MIF (see www.microtype.com).

Note:

You get these colours only for 256-colour (8-bit) PNG files.
Hence use also for screen shots PNG with’millions of colours’.

33 [steve, schwedland.com; 2003-08-23 in http://www.freeframers.org/archive/03/msg00941.html], [http://kb.adobe.com/selfservice/viewContent.do?externalId=324220]
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Font issues
Font xxx missing

See also Be aware of unavailable fonts on page A-9
When opening a file, the following error message may occur:
Document named abc uses unavailable fonts.
To reformat the document using available fonts, click OK
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In the FrameMaker console window you see what has been
found and substituted:
The "Gugus" Font is not available.
"Times-Roman" will be used in this session.

Situation

Action
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The unknown fonts are important and they must not be substituted per- Cancel
manently by the FrameMaker default Times.
Activate File > Preferences > Remember missing Font
names. Now open the file again (you get the same message).

OK

The unavailable font is not essential or just a variation of Times.

OK

Whether the substitution is permanent or just in this session, depend on
the setting of File > Preferences > Remember missing Font
names
You want to get rid of the unavailable fonts in the document

Cancel

Activate File > Preferences > Remember missing Font
names. Now open the file again (you get the same message).

OK

Save the file; Deactivate File > Preferences > Remember
missing Font names

Note:

Where is the unavailable
font used?

If you can not get rid of the unavailable font by these measures, the font may be used in hidden places. See the following
sections for solutions to find them.
Before applying any corrections, make a copy of your document and work in this copy!
Start with the standard procedure: Use the Edit > Find/
Change dialogue to search for a Character Format. In the
character definitions dialogue set all but the font family name
to as is.

Note:

You need to search the body pages, the master pages and the
reference pages for the font and correct any use of it.

D

Known places of font usage which may not be found with
standard Find or Special > List of References … > Fonts are:
 Unused ¶- and character-formats which are in the catalogue.
 Straddled cells in a table hide the unused cells which may
contain paragraph formats or character formats no more in
the catalogue.
 Graphic text lines (created with the graphic tool A), even
empty ones (tool selected and then clicking but not writing
something). These empty objects can not be found by the
search function. At best use the FrameScript Script
DeleteEmptyTexlines from Michael Müller-Hillebrand. If
you do not have FrameScript available, you need to check
every anchored frame:
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-

Select the anchored frame, then select all objects with
CTRL+a.
If you get grouped objects, ungroup them until ungroup
is not possible anymore.
Check for empty objects and deselect them by holding
the shift-key while you click on such an object.
Group everything which is left selected
Select All again, deselect the grouped object. Only the
empty objects are selected now. Delete them.

 Objects originally placed in an anchored frame may
become hidden, if the frame is resized before the objects
were moved to the remaining area. To find these:
-

Select the anchored frame, then select all contents with
CTRL+a
Bring all object into vision by aligning them both horizontally and vertically to centre. Of course this destroys
the image, but lets you find all objects.

 Some text may be hidden by text conditions. This text can
not be found by the search function. So make everything
unconditional before you search for the font.
 Some text may be hidden by means of a non-printable or
non-visible colour (check the View > Color > Views)
 Markers may use character formats – but these you have
checked already, did you?
 Master pages and reference pages must be searched in
addition to the body pages. Also here you may find all
sorts of items using character formats or even local formatting. On the reference pages watch out for empty text
lines!
 Be aware that even for a single-sided document there is a
Left master page - switch the document to double sided to
see it.
 There may be a master page HiddenPage (or similar) to keep
all the conditional text which is set to be invisible.
 Paragraph and character catalogues in book files may use
old definitions. Hence generated files may present
unknown fonts. You can get rid of these only by newly setting up the book. Just importing formats into the book file
does not delete the old stuff, because Import Formats is
cumulative.
 Against common belief font usage in an eps or pdf are not
considered by FrameMaker. FrameMaker does not look into
these files.
Before applying any corrections, make a copy of your document and work in this copy!
See more on unavailable fonts on the outhor’s webite.
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Issues with generated documents
The entries in a Table of Contents (TOC) and similar lists are
built from the specified ¶ formats. The standard flow (A) is
scanned at first and only after that all other text flows (in
arbitrary text frames) are scanned.
The order of scanning these text frames is defined by their
order in the document, but after the main text frame.
This wrong order also appears in the bookmarks in a generated PDF of that document.

Persistent unresolved
cross references

Whenever you open a file that contains one or more cross-references, FrameMaker refreshes each of those references. If
the reference is to another location within the same file, the
refresh is straightforward unless the cross-reference truly is
unresolved due to a missing or hidden cross-reference
marker.
If the reference points to a location that is in another file that
is already open, the process is similarly straightforward. But
if the reference points to a location that is in a file that is not
already open, FrameMaker has to silently (without showing
anything on your screen) peek inside the target file to retrieve
the latest information for the reference. If that file has any
sort of problem that would throw a warning message during a
non-silent open (e.g. an unavailable fonts message), FrameMaker is unable to peek inside it and therefore cannot find
the marker it's looking for.
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TOC entries not in
correct order

It reports this failure to find the marker as an unresolved
cross-reference. If you start by manually opening the file with
the missing fonts issue, so that you can manually dismiss the
warning message, then you will not get an unresolved crossreference warning when you open the original file because
FrameMaker can now find the target marker when it updates
the cross-references.

D

[Fred Ridder, 2009-05-20]
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Solving real and assumed problems

Printing and presentation issues
Misalignment between
text and graphics

Sometimes graphic elements are needed as an overlay to the
text on the page (The U shaped line in the example below).
Messsystem Promag 53 (Kompakt-Ausführung)
Promag 53***-***********x
G = Foundation Fielbus, EEx i
K = Foundation Fielbus

To place the graphic correctly you will use a large zoom level.
However, the printed version may still be different and not
accurate.
To avoid this effect, change the maker.ini file according to
Display character positions correctly on page A-32.

Accents not displayed in
running header

Reason

The running header is overlapped by another graphic element
– in this case with the top text frame of the first header line.
In the figure below the text frames are visualised with a border.
top of frame 1
overlap
bottom of frame 2

Correction

Remove the overlap of the text frame, for example by replacing the two text frames by one of proper height containing
both header lines. The separating line must be moved to front.
line

EPS prints badly

If an eps looks pixeled (check with slanted lines) in the
printed output, the reason might be:
 inadequate printer driver (or wrong PPD for PS-printer)
 non-PostScript printer

Can not print A0 or
poster

If you try to print (or make a PDF) from a document of large
paper size, you may get only part of the page printed.
Although FM allows to define paper sizes up to 216×216
inches (5486×5486 mm), the process is limited by the maximum number of pixels in a row (width or heights of paper) to
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Network issues

32000 (exactly probably 2 15 = 32768). Hence paper size and
printer resolution are connected.

2011-05-11

The maximum printer resolution [dpi] for a given paper
extension = 32000/length [mm] * 25.4 [mm/inch] = 812.8/
length [m].
Length [mm]

Threshold resolution [dpi]

1000

813

1500

542

2000

406

2500

325

3000

271

On the other hand the maximum paper extension depends on
the printer resolution.
Paper format

Length [mm]

Threshold resolu-

A4

297

2736

A3

420

1935

A2

584

1392
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tion [dpi]

A1

840

967

A0

1169

695

See also daube.ch/docu/fmaker43.html.

Missing characters in
output

Due to old GDI-routines (Graphic Device Interface) called by
FM even in Windows XP the print output or PDF generation
may fail. You may miss characters and/or the positioning of
characters is weird.
Remedy to this problem may be:
 Stick to the Adobe PDF printer driver (formally called Distiller Printer).
 Reduce the number of active fonts to about 1500 to avoid
corruption of font cache file.
 Delete the font cache file FNTCACHE.DAT most likely in
C:\WINDOWS\system32\. It will be rebuilt.

D

 Size of virtual memory should not be below 1GB for real
work (on XP)
 Reduce either the paper size or the printer resolution (Tabloid size (17") with 2400 dpi regularly creates problems).
The error is related to Can not print A0 or poster on
page A-28.
See also lists.frameusers.com.
Note:

This problem has been fixed by MS around the beginning of
2008 for XP SP2.

Network issues
For problems with network, such as very slow read/write
access, no access at all or inability to save a file, see the
author’s website.
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Simulate an outline view

Simulate an outline view
Keyboard input
Short-cuts
Wildcard characters for Find dialogue
Special characters in dialogue
boxes
Characters with diacritical marks
etc.
Right-to-left scripts
Symbols and dingbats
Frame Roman code table
Non-width characters
FrameMaker set up
General preferences
Workgroup preferences
Units of measure
Platform specific information
Solving real and assumed problems
General problems
Display and layout issues
Importing and graphics
Colour issues
Font issues
Issues with generated documents
Printing and presentation issues
Simulate an outline view
Recommended setup of FM
Set reasonable default for your
work
Modifications to maker.ini
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The following method was developed by Peter Gold, Knowhow ProServices.
1 Create a TOC that extracts all the heading paragraph formats that you want in an outline. Be sure to check Make
Hypertext Links. The TOC can be for a single document or
a book.
2 Modify the *TOC paragraphs formats to indent the way you
want.
3 Format the TOC page to a narrow column, and a height
that's readable when zoomed to full-height on your screen.
4 Set the zoom to Fit Page to Text Frame.
5 Arrange your screen with the narrow outline frame next to
the document page frame.
6 Use Ctrl+Alt+Click on a heading in the TOC to move the
insertion point to that heading, so you can edit at that location.
7 Regenerate the TOC
Notes
 To make the links in the TOC active with a single click,
instead of with Ctrl+Alt+Click: convert the document to
“read only” with ESC, F, k (and make it editable again with
the same sequence).
 To reuse the outline TOC, save it to a new name. This is
handy if you've moved stuff and then need to restore the
original order.
 Save the “real” TOC with a new name, and save a copy of
the narrow outline TOC to a new name. When you want to
generate the real TOC, close the outline TOC and delete or
rename it, then open the real TOC, save it to the correct
name, and generate.

Recommended setup of FM

Recommended setup of FM
Starting with FM-7 the maker.ini file in $HOME is the template
for the active maker.ini stored in the user area:
%APPDATA%\Adobe\FrameMaker\version

%APPDATA% is the Windows symbolic name for the user data
area.
2011-05-11

Note:

You need to modify the user-specific maker.ini when experimenting with values. To get a fresh copy of maker.ini in the
user data area, delete the maker.ini there before starting
FrameMaker.

Set reasonable defaults for your work
Zoom factors

To get reasonable zoom factors in your session, adapt the
zoom factors to the screen size and resolution. The following
is for an 20" display. In section [Preferences]
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set to

Zoom=28, 36, 50, 74, 90, 125, 200, 353, 500, 1000

When zoomed to 353% a nudge (moving an object by
ALT+arrow key or
) moves by 0.1mm steps 34).

Dash patterns

The following setting provide finer patterns than the FM
default settings. In section [DashPatterns]
set

1=Dash, 8, 4
2=Hidden, 4
3=Longdash, 16, 8
4=Dot, 2, 4
5=Dash-Dot, 8, 4, 2, 4
6=Dash-Dot-Dot, 8, 4, 2, 4, 2, 4
7=Chain, 8, 4, 4, 4
8=Phantom, 20, 4, 4, 4, 4, 4

Line widths

The default line widths for graphics are rather coarse. In the
section [Preferences]

set (for example) to

PenWidths=0.28pt, 0.7pt, 1pt, 1.4pt

or (will display as values converted to pt)
PenWidths=0.1mm, 0.25mm, 0.35mm, 0.5mm

Snap and grid
D

Be aware, that some of these settings from the section
[Preferences] are overridden by document settings.
Snap=On
Gravity=Off
DefaultRulerCm=0.1cm
DefaultGridCm=1cm
DefaultSnapCm=0.1cm

Template path

If you want to get document templates from a special location, change in section [Directories]
from

TemplateDir=templates
34 A nudge is defined as 1pt at zoom factor 100. Hence a factor of 353 nudges by 0.1mm (1 pt = 25.4mm/72 = 0.3527 mm)
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Recommended setup of FM

Templates=templates

to (for example)

Smart quotes

TemplateDir=D:\_doc-std\Frame
Templates=D:\_doc-std\Frame\FM-templates

Define the proper typographic quotes for the main language
in your documents in section [Spelling]. You may wish to set
up the definitions in the following user friendly layout and
then set the language (here: Swiss):

; Smart Quote Characters - there must be no blanks between the 4 symbols
; The original definition of the French inner Quotes is wrong: \xd5\xd5\xc7\xc8
;
; SmartQuotes=\xd4\xd5\xd2\xd3
;English
‘ ’ “ ” u2018, u2019, u201C, u201D
; SmartQuotes=\xe2\xd4\xe3\xd2
;German
‚ ‘ „ “ u201A, u2018, u201E, u201C
; SmartQuotes=\xd2\xd3\xc7\xc8
;French
“ ” « » u201C, u201D, u00AB, u00BB
SmartQuotes=\xdc\xdd\xc7\xc8
;Swiss
‹ › « » u2039, u203A, u00AB, u00BB
; SmartQuotes=\xd5\xd5\xd3\xd3
;Swed/Finn ’ ’ ” ” u2019, u2019, u201D, u201D
; SmartQuotes=\xd4\xd5\xd2\xd3
;Italian
‘ ’ “ ” u2018, u2019, u201C, u201D

Modifications to maker.ini
Have FrameMaker closed when modifying maker.ini. It is also
good practice to keep a copy of the original file
(maker.ini.ori) and make remarks at the beginning of the
file about the changes, for example:
; 2004-10-12 default zoom factors changed to
;
Zoom=28, 36, 50, 74, 90, 125, 200, 353, 500, 1000
; 2006-02-08 Patch b144

Paste prefers text

The default for Paste (from none FM files with CTRL+v) may
create OLE connections (Object Linking and Embedding). To
paste contents rather than the object property, change in section [Preferences]:
from
to
Note:

ClipboardFormatsPriorities=FILE, OLE 2, EMF, META, DIB,
BMP, MIFW, MIF, RTF, UNICODE TEXT, TEXT
ClipboardFormatsPriorities=UNICODE TEXT, TEXT, RTF,
FILE, OLE 2, EMF, META, DIB, BMP, MIFW, MIF

ClipboardFormatsPriorities only affects pasting from the
Windows clipboard. It does not affect the paste operation for
content that is coming from a FrameMaker file.
To paste without formats within FrameMaker use Paste Special (CTRL+SHIFT+v) > Text. There are also utilities available
to strip formatting from the clipbaord.

Default language in ¶ and
f designer

In the first section [Frame] set (for example):

Display character
positions correctly

In section [Fonts] set:

Match colours in
FrameMaker and PDF

In section [Preferences] set:

Language=UKEnglish

DisplayUsingPrinterMetrics=On
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GetLibraryColorRGBFromCMYK=None

Import MIF snippets

Import MIF snippets
If you need to import only part of what is defined as a category in the Import Formats dialogue it is handy to use MIF
snippets. The MIF snippets are imported by copy (not by reference).

2011-05-11

MIF snippets are text files. For FM 7 and below they must be
coded in ANSI 7bit and use the special FM coding for characters not in this range. For example, an Ü is coded as \x86. See
Frame Roman code table on page A-6.
For FrameMaker 8 you set up a Unicode file. You can however
also use the \unnnn notation for special unicodes not available in your editor font. The \xnn notations of FM-7 are still
valid in this file.

MIF header

The first line in the MIF file defines the FrameMaker version.
A MIF 7 can be read by FM 8, but not vice versa.
<MIFFile 7.00> # Generated by FrameMaker 7.0p576
<MIFFile 7.00> # snippet defining user variables for x.

D
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Syntax specials

 Indentation is for the human reader and can be blanks or
tabs.
 Anything after a # in a line is comment.
 A string is introduced by the left pointing apostrophe
(grave accent) and terminated with the straight apostrophe.
 Symbols >, \, ‘ and ‘ must be escaped within strings by a
preceding \ . The symbol < may be escaped also, but need
not.

Import user variable(s)
<MIFFile 7.00> # user variables for example project
<VariableFormats
<VariableFormat
<VariableName `1-productname'>
<VariableDef `Information Mapping<superscript\>\xa8 </\>'>
> # end of VariableFormat
<VariableFormat
<VariableName `2-companyname'>
<VariableDef `ATEK'>
> # end of VariableFormat
<VariableFormat
<VariableName `3-docname'>
<VariableDef `User Guide'>
> # end of VariableFormat
> # end of VariableFormats
> # End of MIFFile

Note:

The notion \<superscript\>\xa8 </\> stands for literal
<super>®</>
A character format superscript is assumed to exist.
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Import MIF snippets
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Rules of thumb

Overview
In this chapter rules of thumb – methods developed
by experience – are collected.
Legibility of printed matter is based on century old
typographic tradition. Only recently these findings
could be justified by research. They lead to a
number of typographic rules.
Whereas FrameMaker provides the mechanics for
layout, the user must think about the purpose of his
design. Working in a team imposes rules which need
not be observed when working alone.
A section gives some ideas about various elements
present in scientific publications.

Contents
Form follows function ............................................. 2
Layout issues ......................................................... 9
Teamwork ............................................................ 11
Types of scientific publications ............................. 15
Elements of a publication ...................................... 17
Figures with legends ............................................. 19
Bibliography ......................................................... 22

Form follows function

Form follows function
Technical, scientific and legal matters are texts which we do
not read for pleasure. They are ‘must’ readings. Hence the
author and producer should do everything to enhance readability and comprehension.35).

Roots of some arcane habits
The main purpose of script is communication in time space.
The ideas of the writer should become interpretable or even
comprehensible by the reader who may look at the text even
after the death of the writer.
The development of type and writing during centuries lead to
certain rules known as “good typography” and good “writing
style”. The first of these rules refers to legibility, the second
to readability.
The invention of the type writer cut back the rich expressions
of printed type as they were developed since Guthemberg’s
times. This new device eased writing for many people, but was
limited in expression to one size of characters of fixed width.
The only possible emphasis was underlining - and, with some
effort - s p a c i n g the characters or bolding them by overtyping. In addition, it provided only a limited character set.
Many habits of layout, typing and writing (of office clerks or
none-typographers) are rooted in this limited device. At the
end of the 20th century there are still many people in Switzerland believing that German does not use upper case umlauts
or upper case French accented characters. Even in France
some people believe this.…
The typewriter might also have lead to the numbering of
headings to display structure and to refer to items elsewhere
in the document 36). With text processing software or even
Desk Top Publishing tools such as FrameMaker there is no
need to restrict oneself to the times of type writing: we can
use all the well established ‘standards’ of proven typography:
font, type size, italic and bold type for emphasis, live references, and so on.

Form follows function
37)

The basic principle of any design must be that it follows
the function of the subject:
 Although gothic chairs with their high back are very nice to
look at they are very uncomfortable for the same reason.

35 See also C. Wheildon, Type and Layout: Communicating or Just Making
Pretty Shapes: Worsley Press.Australia, 2005. ISBN 1875750223.
36 Well, in phone conversation it is more handy to refer to “17.5.3” than to
“The roots of arcane habits, probably on page B-2”.
37 The well-known phrase “form follows function” was first coined by sculptor Horatio Greenough. It was only after Lous Henri Sullivan adopted it that it became a mainstream aphorism.
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To justify or not to justify

 A technical manual using flourishing script and hand made
paper conveys the wrong message. It will not be considered
serious.

To justify or not to justify
My very pragmatic answer to this never ending discussion is:
 Use text justification in prose (belletristic) text, where the
look is supported by the colour and haptic choice of the
paper.
 Use flush left in technical and legal texts, where you can
not make the effort of painstakingly hyphenation and rearrangement of word to get a pleasing display.38)
One reason fro problematic hyphenation and therefore
unpleasing line layout in justified text is the use of automatic
hyphenation based on dictionaries. Especially the endless
combinations of words in German (composita) create either
large inter word spaces or hyphenation points which interrupt the reading flow.

E:\FM-course\handout\rulesofthumb.fm

2011-05-11

 Although in the old days of scrolls (biblia) the writing was
in the same direction as the extension of the parchment,
the line length was limited and precious space was sacrificed for ease of reading.

My major argument for unjustified text is the variance of textual elements in technical and scientific texts which are not
present in belletristic texts:






lists of all sorts
tables of various widths with or without titles
footnotes, marginal notes etc.
pictures with or without titles
formulas of any length

See also www.itcfonts.com

Serif versus sans serif
The discussion whether serif fonts (such as this type) or sans
serif fonts ( such as this) provide better legibility is as endless
as the discussion about justification.
D

Research on this issue 39) was done mostly in view of printed
matters only. Good character shapes for a screen with much
less resolution than any printer require different features
which ends up in specific designs 40). On the other hand our
reading capability highly depends on experience and routine.

38 T EX was the first system supporting a paragraph wide optimisation of hyphenation and justification. FrameMaker is in good company with text
processors optimising only within a line. Adobe InDesign is the first DTP
program implementing a similar approach.
39 See www.alexpoole.info
40 See for example www.wilsonweb.com
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Years ago children learnt to read and write the German Current Schrift41), but nowadays only few can read this type and
also have great difficulties with Fraktur (Black Letters).
My approach is to use sans serif for headings and in tables,
but to use serif type for the running text.

Legibility
Legibility is concerned with the fine details of typeface
design, and in an operational context this usually means the
ability to recognise individual letters or words. Readability
however concerns the optimum arrangement and layout of
whole bodies of text
It has turned out that some measures need different values
depending on the language: English has shorter words and
generally shorter sentences than German. This leads to different optimum settings in these languages.42)

Properties of legibility

The remarks give you an idea of good values of the property.

Line length

About 50 - 70 characters per line. With the rule of thumb to
have a 1 cm line length for 1 pt type size this yields 11 cm for
11pt type.

Size of type

Long words (german text) call for larger type (11 pt), In English 10 pt is a good reading size. Large pages (A3) need larger
type due to larger reading distance.
Use larger type for headings (14, 18, 24 pt), smaller type for
footnotes (8 - 9 pt).

Leading (space between
lines)

1/5 or 1/4 of type height seems to be optimal (10pt on 12pt).
In any case it must be larger than the space between words.

Space between
characters

3 - 5% spread in normal text. Standard font settings are to
tight. The higher value is needed for sans serif type (e.g. Helvetica: Illness vs Illness )

Space between words

Constant space (left aligned) is better than variable space
(justified). To avoid ‘rivers’ across the typed page careful
hyphenation must be applied to justified text.

Proportions of type

x-height about 2/3 of capital heights. Smaller values need
larger type size. Larger values need more leading. Low contrast (lines more or less equally thick). Normal (not heavy or
thin) serifs.

Alignment

Left adjusted text does not create holes (excessive word
space) as justified text might do.

Colour of type

Large type should not be in full black. Create a ‘constant level
of gray’ by colouring type larger than 14pt with 40% black.
41 See, www.geschichte-s-h.de
42 Our visual system focuses at an angle of about 6°. The spacial frequencies
for characters, words and lines of traditional type setting fit well to the
physiology of the human eye. See for example: Object spatial frequencies,
retinal spatial frequencies, noise and the efficiency of letter discrimination.
David H. Parish and George Sperling, in Vision Res. volume 31, number 6/
7, 1991.
The importance of phase in the spectra of digital type by Ghuozen Duan and
Robert A. Morris, UMASS Boston in Electronic Publishing, vol. 2, page 4759 (April 1989).
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Readability

Use real colour for special highlights (defined purpose) or
images.
White space around type create the impression of larger type.
10pt on 12pt it better legible than 11pt on 12.5pt. More than
3 indentation levels can not be memorised. Heavily nested
indentations also lead to very narrow text columns the purpose of which nobody can digest.

Typographic signals

Bullets, indentation and space visualise the structure of a
text. Avoid to many different signals: limit yourself to 3 types
of bullets and keep purpose constant.

Paper

The paper should be really opaque (standard copier paper of
80 g/m 2 lets type shine through), not glossy and not absolutely white (which strains the eyes).
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White space

D
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Readability
It is very difficult to catch readability or even comprehensibility in facts and figures. For legibility we have a long typographic tradition which only recently was verified by
cognitive science.
It is far more difficult to judge the semantics of text and
define ‘ease of reading’ in this area.

Properties for good
readability

The remarks give you an idea of good values of the property.
Much of this is based on recent findings of cognitive science.

Character of type

Character matches the content (Sans serif for technical, serif
for serious, flourishing and script for informal or enjoyable
text).

Size of vocabulary

The basic German vocabulary is about 3000 words. The more
words of the text are beyond this, the less it is understandable. Some technical texts use ‘controlled language’ for this
reason.

Abstraction level

Examples and comparisons to daily life are far more understandable than metaphors and abstractions.

Idiomatic words

Special slang, newly invented buzz words or special terms
(overuse of scientific terms) make it difficult to understand
the text.

Numbering

More than 3 numbering levels can not be memorised and do
not help in navigation. In most cases numbering of headings
is not necessary for navigation purpose, because variation in
type size give better clues on the structure.

References

Footnotes do not interrupt the reading flow as do in-line comments (in parentheses), because it is easy to skip them in first
reading.
Cross references to title text give a better clue than to title
numbers. Based on the title text the reader can decide
whether ‘to jump’ to another location or to continue reading.

Navigation aids

Technical and scientific texts need various access methods to
the content, because they are not read the same way as prose.
Table of contents present the overall structure, but should
not go beyond 3 levels. Present a detailed view in a substructure (e.g. in a chapter).
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An index must be as rich as possible because the fantasy of
the reader always differs from the knowledge of the writer.
Think of different indices for certain elements: people, works,
actions, time, area…
Placement of images

Keep descriptive text to the right of images. Although mirrored layout looks very nice in the first place, this violates the
relation of speech and image in our brain.

Grouping

Use white space and alignment to group items (e.g. in tables.
Avoid heavy ruling which is often default for US based DTP
systems.

Research on readability
This diagram is based on the authors experience with various
text sorts and tries to cope with the fact that reading ease is
only one side of the coin. The abstraction level and the size of
the vocabulary add another dimension to the subject.

Abstraction level

Personal experience with
readability

Legal and
Scientific
publications
NZZ
Marketing Technical manuals
material

Comics

Victor Hugo

Children books

80

Statistics of this text

60

40

20

Flesh reading ease RE

0

20

Silicon Prairie Software provides a FrameMaker plugin to calculate both text statistics and readability indexes. With this
we get the following figures for this chapter:
Paragraphs (p)

513

Sentences (s)

725

Words (w)

6 418

Characters (c)

31 109

Average s/p

1.4

Average w/s

8.9

Flesch RE

61.7 (60.0–70.0: easily understandable by
13- to 15-year old students)

Flesch-Kincaid Grade Level: 6.8 (8 should be understandable
by an average student in 8th grade –
usually around ages 13-14 in the USA)
Note:
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These measures do not account for the vocabulary though!

Research on readability

Research by Arend Mihm

The following diagram is based on research summarised in
Textverständlichkeit und gesellschaftliche Lesefähigkeit by Arend
Mihm in Linguistic und Didaktik, 1973.
The term reading ease (RE) was defined 1948 by Flesch and
derived from the measures wl (average word length in syllables) and sl (average sentence length in words) with the following formula 43), which he verified on an extensive set of
text samples read by a great number of people:
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RE = 206.835 - 84.6 • wl - 1.015 • sl

Mihm needed to adapt the figures found by Flesch for German
texts, because in this language both the average sentence
length and the average word length are larger than in English
(≈ +20%).

80

60

40

20

reading ease RE
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or d

R1 … R4 are reading
books for the secondary
school in Germany.

43 To high a precision demonstrates lack of knowledge on the subject is still a
valid insight from my studies at the School of Technology. Although we
have here an elaborate formula the input was presumably much less precise...
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Fonts used in this compendium
I started work on this document with the PostScript fonts Palatino for the running text, Helvetica for headings and Helvetica Narrow for tables.
The support of Type 1 (PostScript) fonts diminished over the
time and TT (TrueType) or OT (OpenType) became more
important because they naturally support a larger character
set up to Unicode.
The Lucida font family has been designed from the ground up
for on-screen legibility by Charles Bigelow44). Both serif and
sans serif fonts are in this family. Hence I decided to switch
to this font family with FrameMaker 7:
Lucida Bright

running text

Lucida Sans

headings

Lucida Sans Narrow tables, figure text
Lucida Console

code display45)

Lucida Unicode

for text pieces demonstrating Unicode
issues (various scripts in one font etc.)

Not all of these font faces are included in Windows XP, so I
bought the licenses for the missing ones.

Charles Bigelow, *1945

44 The author remembers Charles’ talk at one of the Protext conferences in
Dublin in the late 1980’s about his development of the Lucida font family, specifically about Lucida Fax.
The Design of Lucida®: an Integrated Family of Types for Electronic Literacy.
Proceedings of the International Conference “Text Processing and document manipulation”; University of Nottingham, 14-16 April 1986: Edited
by J.C. van Vliet. Cambridge University Press. ISBN 0 521 32592 7
45 Consolas from MS introduced with Windows Vista would be another
choice, as its character repertoire is larger and both the normal and the
bold version have the same character widths – so they line up in code examples.

B–8

Layout issues

Layout issues
Books
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Books are normally smaller than A4 and larger than A5. A
very common size is 17 x 24 cm (close to B5).
For books the inner margin is smaller than the outer margin.
This gives room to a browsing thumb and even handwritten
notes.

A4 loose leaf publications
For A4 publications the binding normally is inside. The classic 1/9 rule for margins creates much white space, because
this rule assumes no side headings.
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Margins
The classic rule for margins reduces the text area to 2/3 of
the paper size and adjust the margins to these values:
Margin

Relation

For A4 [cm]

for 17 x 24 [cm]

Top

1/9 of paper height

3.3

2.7

Bottom

2/9 of paper height

6.6

5.4

Inner

1/9 of paper width

2.3

1.9

Outer

2/9 of paper width

Text area

2/3 of dimension

4.6

3.8

14 x 19.8

11.3 x 16

Running headings are inside the text area, but the pagination
is outside.
These margins are good for text areas which are filled with
text. The margins are to large for layouts using side headings,
such as technical and scientific publications.

Layout with side heads

D

Layouts with side heads use about 1/3 of the text width for
the side heads and 2/3 for the common text. This creates a
proper line length for the ordinary text.
Margin

For A4 [cm]

for 17 x 24 [cm]

Top

2.0

1.5

Bottom

1.7

1.7

Inner

2.0

1.7

Outer

1.0

1.0

5.6; gap 0.6

4.0; gap 0.4

11.8

9.9

Room for side head
Line length

Both running headings and pagination are outside the text
area.

B–9

Layout issues

Mirrored layout

Although a mirrored layout (side heads always on the outer
side) look more pleasing on first sight, this confuses the relation between image and text for small images in the side head
area.
Use a mirrored layout for nice books, but not for technical
and scientific publications.

Running headers and footers
Running headier repeat the information from the headings on
the page.
The running header on the left page always repeats a higher
level heading (e.g. 1-heading) than the running header on the
right page (e.g. 2-heading).
Running footers with information from the page contents are
present, for example, in dictionary style layout.

Tables
Both technical and scientific publications use tables much
more than standard texts.

Layout rules for tables

 Both start and end of the table must be clearly visible and
distinguishable from the running text. A good method is to
have the heading row shaded (up to 10%) and the footing
row (or end of table) be indicated with a line.
 Group rows either with additional white space or ruling.
 Avoid to much ruling. Most ruling can be omitted when
proper alignment of the columns is used.
 Ruling defaults of US based DTP programs are to heavy for
European eyes. A thin rule uses 0.3 pt (and not 1 pt as in the
US).
 Both heading and footing rows must be repeated on each
page of a table which spans several pages. FrameMaker
does this automatically.
 Harmonize column width for tables which are not separated by much text. If each table uses different row proportions the page image becomes very cluttered.
 For very wide tables rotate the table (or the whole page)
counter clockwise. Care must be taken to text which is
rotated in the cells or the text area: it must stand normal in
the rotated page (an not top down!).
 Arrange table titles always at the same side (above or
below) or the tables. If you need a special table construct
for titled images (FrameMaker does not provide titled
anchored frames), arrange the title of tables above and the
title of images below.
 If no list of table titles is created, titles may be omitted,
because the tables are normally anchored in the text where
they belong to and the heading row gives enough information for the contents of the table.
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Teamwork
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Teamwork requires more working rules than working in solitude. The rules must be set up and observed by all team members. Of course it is best to have one person responsible to
manage the rules – the team responsible.

Team responsible
Tasks of the person responsible for the team work are:
 Collecting wishes concerning layout and styles
 Maintain the template directory
 Document the template (layout, catalogues)
 Keep the templates up to date
 Maintain a project dictionary

Directory structure for a project
You may wish to keep the files on a server with check-out/
check-in capabilities, such as a WEBDAV 46) server. See also
Workgroup preferences on page A-10. Consult Help with the
keyword webdav.

D
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 Distribute changes of the meta-documentation

As it is done often

What would be better

/project-directory
arbeiten_d.fm
arbeiten_dv7.fm
einführung_d.fm
firlefanz.tif
graphic1.xyz
graphicz.xyz
introduction_e.fm

/project-directory
/de
arbeiten.fm
einfuehrung.fm
handbuch.book
/graphics_d
firlefanz.tif
/de_v7
arbeiten_dv7.fm
/en
introduction.fm
working.fm
/graphics
graphic1.xyz
graphicz.xyz

 Do not use umlauts, blanks and other dangerous characters in file names (which may be valid on your current platform) – think about case dependency of file names!
 Do not use chapter numbers in the file names – the order
may change during the development of the document.
 Do not mix versions (and/or languages) in one directory.
 Keep graphics language independent. Place callouts etc.
not in the graphic, but overlay them in FrameMaker.
46 WEBDAV = Web Distributed Authoring and Versioning
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 Keep reference data (reports, sources, original text) in a
separate directory. This is especially necessary for scientific publications where You must warrant every citation!

Locking files in a network
FrameMaker creates a file name.lck for each document it
opens (name is the file name of the document). This lock document is placed in the same directory as the source file.
Even if you are not a single person working on any project,
keep this preference ON; is does not affect your work outside
a team:
File > Preferences: Network File locking.

Source code maintenance system
Extensive file control with access rights (e.g. read only) can
only be maintained with a source control system. The support
provided by FrameMaker is to weak in these cases.
With FrameMaker 7 Adobe has introduced a special form of
source code maintenance system: FrameServer. This supports
central distribution of files with check out - check in procedures.

Fonts in a mixed environment
 Always set File > Preferences... Remember missing font
names
 Minimise your trouble with commercial printing by embedding fonts completely into your PDFs.
Note:

If your print shop hop refuses to accept TrueType fonts in your
document, change the print shop! This one lives in the last century.
FrameMaker is one of the very few applications which supported font integrity between Macintosh, Windows and UNIX.
This is done by means of two tables in the maker.ini file. This
is tedious work even for experts, because fonts are handled
very differently on these platforms.
 Font mapping for Windows font names
 Unknown to known font mapping

Template library
FrameMaker treats any document as template when this is
located in a particular directory which is defined in the
maker.ini preferences.
When opening a template with File > New... a copy of the template file is created automatically.
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Style planning
See also Templates on page 5-24. For a team project, the planning of layout and style is even more important than for any
documentation project:
 Provide (at least during development of the document) the
following information on each page:
2011-05-11

-

full file name
date of modification

 Which styles for paragraphs and highlights are needed?
Use names, which allow easy recognition of the purpose
and not the appearance (1heading rather than Big Heading).
See also Names for styles on page 2
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 Think early about your numbering scheme for headings,
tables, figures, formulas, chapters etc.
Do you really need a numbering system in the time of live
cross references and hypertext? At which level do numbers
restart? Should tables and figures be numbered independently of headings?
 What types of tables are needed?
Set up a collection of wide and narrow tables and specify
their ruling and shading. Define tables by appearance only
for general styles. Be aware of the limitations of the table
catalogue (it does not keep all what you might wish).
 What layout will be needed for the pages?
FrameMaker support an ‘unlimited’ number of master
pages for a document. Do you need special graphical elements in the layout, such as lines above and below paragraphs? They will be placed in the reference pages of the
template.
 What formats for cross references will be needed?
FrameMaker starts with a set of these which may not be
what you need.
 If you plan to use the built in graphics tools, think about
line widths and arrow tips. User defined arrow tips can not
be kept between sessions!
 Can you place ‘canned text’ in variables?
Candidates are product names, company names, copyright
notes etc.
D

 Do we use project specific graphics only?
General graphics (e.g. clip art) may reside in locations
which are not available at the final stage of the document
(commercial printing...). You will need to copy them.
Maintaining consistent use of styles is one of the main issues
in document team work. FrameMaker support this with the
capability to import style and layout definitions from other
documents.
When initiated from a book file, the styles and layout definitions are imported to all files of the book.
It is therefore important to develop styles only in one files of
a project and propagate them via the book mechanism to all
files of the project.
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Local styles
Using local styles (such as bolding a word, giving a paragraph
an individual appearance) must be avoided as much as possible. In any case do not use styles which are not in the catalogue - there is little chance to find and maintain these text
elements!
If special styles are needed in a limited area of a project, use
named styles with the chapter-number in the style name. For
example, z1-figure-top. This would be a special style in
chapter 1. The z keeps the style separate to the others. This
method keeps things apart even if styles are accidentally
propagated to other chapters. and you know where they
belong to.

Maintain a style guide
Even for small projects it is good practice to have a list of all
styles available in one document. This displays the name of
the style and its appearance. Sophisticated style guides list all
properties of the style and where they must / may be used.

Simple style list

bodytext: Lorem ipsum dolor sit amet, consectetuer
adipiscing elit, sed diam nonummy nibh euismod tincidunt ut
laoreet dolore magna aliquam erat..
Q ln-narrow-list is used for definiiton lists with short
terms.Lorem ipsum dolor sit amet, .
Island

lw-wide-list is used for definition lists with longer
terms.Lorem ipsum dolor sit amet, consectetuer.

Popocatepetl

This is a 3heading

lww-verywide-list is used for very long
terms. Lorem ipsum dolor sit amet,

Character formats are 1highlight, 2highlight, computer, dddsymbols: 12345
name and dingbats: abcdefghijklmn

Boiler plate elements
Collect well thought out elements in a special document for
easy copy and paste. Such elements may be:
 Tables with sophisticated layout (straddled cells, special
ruling and/or shading)
 Figure tables with diverse arrangements of graphics or
photos.
 Special characters from exotic fonts
See Figures with legends on page 19 for examples.
The plug-in Autotext from Silicon Prairie Software is of great
help for canned text. It allows to define a set of text or
graphic items and insert them into any FM document by a
menu selection or keyboard short cut. Items include styled
text, plain text, graphics, anchored frames, and tables.
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Types of scientific publications

Types of scientific publications
Scripts

2011-05-11

IMHO scripts can be set up similar to the handouts presented
here. Very often more than one person works on such a paper
which will introduce style differences as well as different
method to achieve the same affect. Hence guidelines about
the formats, layout and methods are needed for this work.
Nevertheless from time to time a complete cleanup of such
documents is necessary.

Dissertation
A dissertation (at least at the ETH) consists of these parts:
Cover
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Preface

The cover repeats the front page
Page numbers in roman numerals
 Front page repeating the text of the cover
 Dedication and probably a motto 8citation)
 Acknowledgments

Preliminaries

Page numbers in roman numerals)
I

Table of contents

II Abbreviations
III Summary
IV Zusammenfassung
The contents

Arabic page numbers. The structure headings may vary, but
this is typical:
1 Introduction
2 Literature review
3 Experimental
4 Results and discussion
5 Conclusions

D

6 References

Paper for publication
Most publishers have their own rules how to present the various elements of the paper:
 Literature references are strictly regulated
 Format of images and file types are defined
 Drawings (line types, line widths etc.) provide only little
variation.
 Colours are welcome only for photographs, not in layout
 etc.

B – 15

Types of scientific publications

Templates for scientific texts
FrameMaker comes along with templates for outlines only:
Even the German version of FM contains US-style templates in
this area only.

Harvard outline

This outline provides 7 levels with ample indentation. In level
5 you have only half the page width available for text, in level
7 about 1/3!
The numbering is very mixed - it uses all styles from upper
case roman to lower case characters with parentheses.

Outline, Numeric

This outline supports six paragraph levels. The levels use arabic numbers and indentation.

Outline, Small

Use this template to create a simple outline that uses bullets
and dashes to indicate a paragraph’s level. 6 levels of paragraphs are supported.
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Elements of a publication

Elements of a publication
Before you start layout and format definitions it is good to
look at basic design and typographic principles, such as Form
follows function on page 2.

Layout

Layout very often is based on a book format or A5. This determines the amount of space available. In particular, side headings are not used much (in contrast to technical publications).
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Design

At the ETH in Zurich dissertations are laid out on A4 and for
printed publication reduced to A5.
Normally the title page and the first inner pages are highly
formalised. Hence you set up these pages independently of
the standard text, TOC and IX pages. Use master pages also
for these pages to be consistent in your work.

Body text

To cope with footnote references and small in line formulas it
is usual to have a wide line spacing. Use only few character
formats and explain their use at the beginning (e.g. after
Abbreviations: Typographic conventions)

Heading levels

Usually 3 heading levels are numbered and the fourth one is
not numbered. In an A5 layout the numbers run into the text
space. In A4 layout it is convenient to set the numbers outside the body area.
If tables, figures and formulas are not numbered independently from heading levels, you set up a matrix (see Hierarchical numbering on page 3-11) to get correct numbering.

Tables

Tables are numbered and in most cases the table title is
arranged above the table. Only few authors set the table with
different font than the body, although this gets tight in an A5
layout. Ruling is preferred over shading, because copies are
done easier in this case.
In Switzerland heavy ruling is unusual, in particular if you
print to a high resolution device. In most cases it is not necessary to place vertical rules, because the text boundaries themselves guide the eye.

Figures

Figures are numbered. The legend may extend to multiple
lines. Various forms have been found for this element.

D

For greater flexibility it is recommended to place callouts
(numbers, arrows etc.) not directly into the image, but overlay
the images with FrameMaker graphics. See Graphic overlays on
page B-21.
Small figures may be combined to clusters (e.g. 4 cells in a
table). See Figures with legends on page B-19 for examples.

Drawings

Drawings in figures are mostly done outside FrameMaker,
because very often these are graphics based on data.
Pay attention to line styles, fonts and font size. It is good
practice to create graphics in the needed size to avoid any
scaling (which damages the font size). Use the same fonts as
used in the document. Stick to one font-type (TrueType).
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Elements of a publication

For call outs the same remark as for figures applies.

Images

Images are mostly photographs. TIFF is not a good choice for
this form of images. JPG is more adequate. However, some
print shop insist on TIFF images.
When creating and storing images, do this in the highest possible resolution. When working in FrameMaker you can switch
off the display of images, which may cause large build-up
time for pages (View > Options: uncheck Graphics). Switch
the display of images on again for placing callouts etc.
When producing a PDF from your paper you adjust the parameters according to the publication process (see chapter 10).

Footnotes

These may or may not be used. Some people prefer to collect
the notes at the end in a separate chapter and handle them as
ordinary reference.

Bibliography

Whether to use a special tool such as EndNote (see Bibliography with EndNote on page 7-26) depends on the nature of your
references. If you can not relay on existing data bases there is
no use of EndNote. A simple table (see Bibliographies on
page 7-22) will do the job. See also Bibliography on page B-22.

Lists of authors etc.

Some publications require lists of





authors
tables
figures
etc.

FrameMaker gives you great support for these items (see Arbitrary lists on page 9-17).
But this is only possible if you follow a good scheme for paragraph formats, cross reference formats and character formats. Do not highlight locally or use ‘Word-style’ formatting
for paragraphs - this can not be accessed to generate lists.

Formulas

FrameMaker has a very good formula editor, although it needs
some skill to be handled well. Keep in mind that in FrameMaker a formula (or equation as Frame calls it) is a mathematical construct, not just an image (as for example in MS Word).
If you need to place a comment directly in the formula, use
the method described at Physical dimensions and other strings
on page 11-8.
If you have a very large number of formulas in another system (e.g. Maple) consider to import the formulas as images. In
this case use a high resolution to generate the image, because
in many cases you just get a bitmap.
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Figures with legends

Figures with legends
It is good practice to have a document with ‘boilerplate’ text
and other elements available. The following pages give you
some of the needed elements which you can copy.
See Boiler plate elements on page B-14 for methods how to deal
with reusable content.
2011-05-11

Note:

To be able to create a “list of figures” you need to have reasonable text in the figure heading. Hence it is not recommended to
have an empty figure heading and start immediately with
(probably numbered) legend items after the figure number.

Figure with title in side head room
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Here you see the standard method in technical documentation for callouts: numbers, which are explained in the legend.
Text in the figure is avoided to ease modification and translation.
To see the construction in FrameMaker, the table is outlined
with borders and the anchored frames are filled with gray.
Anchor symbols are displayed with a special font.
Figure 6:
C. F. Gauss on German bank
notes

7

2

1 Formula of normal distribution
2 The “bell curve”

1

Arrangement within text column
D

This type of figure table (2 table columns) uses only the area
of the text column

2
1
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7Figure 7:
C. F. Gauss on German bank
notes
1 Formula of normal distribution
2 The “bell curve”

Figures with legends

Figure cluster
To avoid separation of the image from the title row, set
Orphan Rows (Table designer, category Basic) to 2.
For large clusters of images this may not be sufficient: Set
Table > Row Format > Keep with next (or previous).

Images in distinct table
cells

7

7

Figure 8: With no figure legend at Figure 9: With figure legend
Figure legend for longer explanations of
all - just the figure title
the figure contents.

7

7

2
1
1
3

2

Figure 10: Using figure-legend

Figure 11: Legend text and list

1 Start of the mischief
2 Climax of the mischief
3 Back to normal again

This is the introductory text

1 The famous bell curve with the formula
2 Background image is taken from an
engraving of Nuremberg

The default numbering sequence in a table is Row first (as
seen above). You can change this in Table designer, Basic category.

Images combined in cell
1

2

Figure 12: Key developments by C.F. Gauss
1 The Gaussian normal distribution is one of the most common distribution functions,
especially in error theory. The function has many names, including de Moivre distribution.
2 Instrument for triangulation. A sophisticated form of a sextant.

Paragraph formats used
for the figures
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ftn-fig-title-numberedFigure title, sets legend number to 0.
ft-fig-text

Legend without numbering. Automatic follower of ftn-fig-title-numbered.

legx-legend-nx

Legend with numbering.

Graphic overlays

Graphic overlays
Collect prepared items in your boiler plate file. Here you see
also white arrows to be placed on dark images.

2011-05-11

Figure 13: Numbers and
arrows for image overlay

2

1

1 Arrows in the top row can be ungrouped and rotated when grabbed at the
tip
2 Combined arrows (black on white)
can not be rotated any more, hence
the proliferation of items.
3 For length adjustment of arrows:
ungroup and stretch arrow
4 After positioning, select the arrow,
the number and the circle and group
them

4
3

5

4

3
6

7

8

9

1
10
12

2
1

+

14

25

13
14

15
16

24
23

22

21 20 19

18

17
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You can select and change the number also in grouped state.
You just need to be able to select it with the mouse (zoom in
for easy working).

Fonts
If your print shop refuses your document because you use
TrueType fonts, change the print shop immediately. It lives in
the previous century. The TrueType font definitions were
jointly specified by Apple and Microsoft47) and finally led to
the OpenType font definition, which is a container format for
PostScript fonts and TrueType fonts.
Contact your favourite print shop as early as possible also to
get the preferred PDF job-options for generation of your PDF.
Always generate the PDF with complete fonts included (no
subsetting).

Special symbols
It may be cumbersome to enter special symbols in FrameMaker (see Symbols and dingbats on page A-5). So it is a good
idea to place also the rarely used in the boiler plate file, especially if they are located in an exotic font:

D

Symbol

ΩΣ•≤≥

D+DD Symbols

z ? " # $ % P ( Q

47 1990 Apple was tired about spending 30% of its revenues for font licenses to Adobe and hence developed the alternative together with Microsoft.
This bowed the neck of Adobe to reveal the Type 1 font definition.
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Bibliography
See also Bibliographies on page 7-22 and Bibliography with EndNote on page 7-26.

Visible reference items
To get access to the reference items [...] with the cross reference mechanism these items must be distinct paragraphs (see
also Bibliographies on page 7-22).

References in a table
[Daube 1989]

Daube, K., Aufbau des OBRZ Run time Systems, in
Technisch-wissenschaftliches Rechnen am MVS System.
1989, OBRZ AG: Zürich. p. Chapter 400.50.10.

[Garneau 1990]

Garneau, D., ed. National Language Support Reference
Manual. January 10, 1990 ed. National language
Information Design Guide, ed. IBM. Vol. 2. 1990, IBM
National Language Technical Centre: Toronto, CDN.

[LaBonté 1989]

LaBonté, A. A New Data Type for National Language? in
SEAS Anniversary Meeting. 1989. Amsterdam, The
Netherlands: SHARE European Association.

References in run-inparagraphs

[Daube 1989]: Daube, K., Aufbau des OBRZ Run time
Systems, in Technisch-wissenschaftliches Rechnen am MVS
System. 1989, OBRZ AG: Zürich. p. Chapter 400.50.10.
[Garneau 1990]: Garneau, D., ed. National Language Support
Reference Manual. January 10, 1990 ed. National language
Information Design Guide, ed. IBM. Vol. 2. 1990, IBM
National Language Technical Centre: Toronto, CDN.
[LaBonté 1989]: LaBonté, A. A New Data Type for National
Language? in SEAS Anniversary Meeting. 1989.
Amsterdam, The Netherlands: SHARE European
Association.

Invisible reference items
Some publications require that the bibliography does not contain the repeated references. For example, the bibliographic
list may contain:

Acree, T. E., Barnard, J. and Cunningham, D. G. 1984. A
procedure for the sensory analysis of gas chromatographic
effluents. Food Chemistry, 14: 273-286.
And the references should be [Acrre et al, 1984].
This can not be achieved by cross references to markers,
because there is no building block <$markertext> available in
body pages.
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Invisible reference items

Solution

The solution is to hide the reference item in the bibliography
list. The item is coloured with “invisible”.
Colour definition

1 In View > Color > Define… specify a special colour for
your reference items, for example invisible. Use a colour
such as magenta or pink which clearly separates from the
real colours of your document.

2011-05-11

2 In View > Color > Views… make the colour visible:
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Paragraph format

Use a distinct paragraph format for your reference items in
the bibliography table, for example, bib-ref. This format
uses the colour invisible.

Acree et al, 1984

Acree, T. E., Barnard, J. and Cunningham, D. G. 1984. A
procedure for the sensory analysis of gas
chromatographic effluents. Food Chemistry, 14: 273-286.

Grosch, 1993

Grosch, W. 1993. Detection of potent odorants in foods by
aroma extract dilution analysis. Trends in Food Science &
Technology, 4 (3): 68-73.

Karathanos et al, 1996

Karathanos, V. T., Kanellopoulos, N. K. and Belessiotis, V. G.
1996. Development of porous structure during air drying
of agricultural plant products. Journal of Food
Engineering, 29: 167-183.

References in the text

The text uses cross references to the reference items:
Extract dilution techniques, such as CHARM [Acree et al, 1984]
or AEDA [Grosch, 1993], provide means to even evaluate the
relevance and impact of a single compound within the entire
aroma profile.
For printing and saving as PDF hide the reference items with
View > Color > Views…

D

PDF creation and
printing

This does not affect the cross references, because the text is
not excluded from the document (as conditional text would
do).
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Miscellaneous

Overview
Plain text can be imported an formatted according
to some rules. In particular, it is possible to convert
a TAB delimited text to a table.
Importing objects from other applications uses a
filter mechanism, which is still not fully reliable for
Word documents and Excel tables. The reason might
be the ever changing format of MS office data.
A section provides general information about
FrameMaker and some internal mechanisms.

Contents
Importing methods ................................................. 2
Importing methods in detail .................................... 4
FrameMaker specifics .............................................. 9
File names ............................................................ 11
Document properties in MIF .................................. 12
Background information ........................................ 16
FrameMaker principles and philosophy .................. 22

Importing methods

Importing methods
FrameMaker offers various methods of importing text and
graphics. The most reasonable method depend on various factors:
Source documents

Importing method

Graphics and plain text in distinct files

Import filter

Text areas and graphics from Office applications.

Copy / Paste Special

Large amounts of Office text, multiple authors, Import plain text only. Get graphold (mingled up) documents
ics via PDF
Inline updating of tables/diagrams required

OLE import from Excel

Import filters
Note:

The purpose of filters is to maintain as much of the appearance of the source document as possible. This is not always the
goal of the user who wants to keep the FrameMaker document
clean.
With File > Import > File… FrameMaker activates import filters which are third party developments. Some file formats
are well defined and stable (eps, tiff, txt), but most are proprietary and not well defined. Word for example is not compatible with itself … On the other hand functions in one
application can not easily mapped to functions in another
application because of the different object model (e.g. frames
in Word versus. frames in FrameMaker).
Another obstacle are naming conventions or user definitions.
FrameMaker users are adept to the catalog concept and hence
use (in most cases) consistent naming for paragraph and
character formats. The great majority of MS Word users are
not aware of the capabilities of the product and hence use
Word as a heavily overpowered typewriter.

Note:

Importing from Word may 48) leave CR characters (\x0D) and
other illegal characters (e.g. \x01) in the file. These restrict an
FM search to the paragraph ending with CR. You can find these
characters only by searching backwards from the end of the
flow. Clean the file by saving as MIF, opening the MIF, saving
as FM,

Copy and paste
Copy fills the paste buffer with forms which are specific to
the creating application and the setup of which. When using
paste the target application will take a default format or you
specify which format to take by using paste special.
Note:

The FrameMaker default format for pasting from another
application inserts an OLE object from most Windows applications – in particular the Office applications. This behaviour
can be changed. See Modifications to maker.ini on page A-32.

48 This actually depends on the filter type and FM version.
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Object Linking and Embedding (OLE)

2011-05-11

Please remember that this setting does not influence the FM
internal copy and paste operation.

Using copy special (if available) fills the paste buffer with a
specific form (for example an image in tiff format or text in
rtf = Rich Text Format). In this case a paste will place only
this specific form.
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Paste special in
FrameMaker

Paste Special works both for items copied from FrameMaker
or another application
When pasting a graphic this might provide the formats BMP
(Bit Map), DIB (Device Independent Bitmap) or WMF (Windows
Meta File) or EMF (Enhanced Metafile).
When pasting a textual object, this might provide WMF, RTF
(Rich Text Format), Unicode or Text (plain text).

Object Linking and Embedding (OLE)
Object Linking and Embedding provides a link to the source
application. What you see on the screen and will be printed in
FrameMaker is an image of the application window.
Depending on the source of the object (same computer, other
machine) the image may be just a bitmap. When transferring
objects between Windows machines, the object seems to bear
a WMF (mixed vector and bitmap) image.

D

Note:

Insert an object

Avoid OLE when planning to use the document on various computers, for example, both on your workstation and your laptop,
send to a print shop. The receiver of the document both must
have access to the file and the same applications installed which is often not the case.
p Select the object in the source application (e.g. Excel) and
copy it to the clipboard.
p In FrameMaker paste it into an anchored frame (if you just
paste it to the current cursor location, a default frame is
created).
p When double clicking on the object, the original object window appears on the FrameMaker screen and the menus and
buttons are from the source application (Excel). The data
can be edited now.
p To close the application window click somewhere outside
the object window. Do not use File > Save or File > Close,
as this will close the FrameMaker document also.
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Importing methods in detail
Text in Source applications
Although the various filters which FrameMaker provide are of
high standard, they can not be accurate. Before you import,
consider these topics:
 Provide the author(s) a template using the same paragraph
and character styles as the final FrameMaker document.
 Since most MS Office users are not familiar with templates
even with education they will fall into old habits and use
individual markup. Hence You will need to clean the document in the source application. A set of macros may help
you especially for multiple input.
 Remove special formatting such as Word frames and
remove all graphics. Break down large documents into
manageable chunks.
 Use these cleaned documents for import to FrameMaker.
Note:

As a long time, highly skilled Word user, I know from experience that there is a mountain of invisible crap in the Word doc
– so my best advice is to not import the Word document at all!
[2009-07-12 by Alison Craig, ultrasonix, com]

Import plain text and format in FrameMaker
The safest – and in most cases fastest – method to import text
from other applications is to import just plain text and format it in FM “from scratch”:
p In the source application (for example, Word), save the file
as text only (do not set Insert line breaks!).
p In FrameMaker import this file to a location where the ¶
format is bodytext (if this is appropriate for most of the
text).
p Format the text: start with the headings, then lists. Convert
the paragraphs with tabs back to tables (with the appropriate table format). Finally apply all character formatting.

Clean the imported text

Bullet items and numbering present in the imported text is
handy to find them for formatting in FM. But they must be
removed from the input text, because FM inserts these items
according to the numbering property. In the following do not
use Change All even in so called obvious cases!

Remove numbering

Set up Find/Change with Wildcards ON and this find pattern:
[1-9].\t for single figures and [1-9][0-9].\t for two figure
numbers. Of course, the period may also be a) in certain
cases. The Change field is empty to delete the item.

Remove bullet symbol

If the bullet symbol is from the standard font, then it appears
as • However, if it comes from Wingdings or Dingbats etc,
then you see the base character in front of the list lines, these
may be é, U or everything else. Start your search pattern with
the first symbol coming along (Wildcards must be ON):
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Importing Word files (using filter)

[•]\t and extend as soon as you discover more of these:
[•é*8ç]\t

Table conversion

p Select all relevant lines (except the title paragraph) and
specify the appropriate number of heading rows for the
conversion.
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p Copy the title paragraph into the table title.
p Cells which were straddled in the source document must
be handled additionally.

Importing Word files (using filter)
Clean method

These rules are based on the work of
FredRidder@Dialogic.com.
1 In the first step remove all graphics, even if they are
imported by reference. Handle images completely separate
from text.
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2 Good adherence to the Word style sheet. Local format overrides are nothing but trouble. If necessary, write Word macros to enforce as much style conformance as possible
before attempting to import.
3 Remove as much “special” formatting as possible by redefining the Word styles in a special “export” template. In
particular, redefine any styles that have auto numbering or
bullets in Word so that you don't wind up with duplicate
tabs or bullet characters in your Frame files.
4 Ensure exact 1-to-1 correspondence between Word style
names and Frame style names. This allows you to import
content only from Word files, leaving all the formatting
stuff behind and redefining all the styles in Frame. This
sounds like the harder way of doing things, but it works
better in the long run because there are a number of format issues that are simply handled too differently in the
two tools allow direct translation. (One good example is
space before and space after paragraphs, which is additive
in Word but not in Frame.)
5 Remove any Word frames, that is, resolve them to ordinary
text before importing.
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6 Always import by using File > New to start a new Frame
document and then File > Import > File (by copy) to convert the Word content into Frame.
7 Always select the “Reformat Using Current Document's
Formats” option in the “Import Text Flow by Copy” dialogue to apply your clean Frame styles and leave all the
Word formatting behind.
8 Break large Word files into chapter-size or section-size
chunks before importing to Frame. One of the biggest reasons for migrating from Word to Frame is Frame's ability to
reliably build large books from smaller files, and the best
time to do the chunking is before importing into Frame
rather than after. In file importing, smaller is always better.
(Yes, I'm afraid that size does matter...).
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Alternative method

Depending on the quality of the Word formatting you may
also get good results with the following method.
1 Extract all graphics, especially the Word graphics to individual files for later use.
2 Start a fresh FM file from a template and import the Word
file by copy.
3 Be not surprised to find overlayed text, grey areas rather
than images, multiple tables anchord at the same location
etc.
4 Remove the most obvious bloat. It may be necessary to
temporarily ‘park’ tables and text chunks in a separate document to pull thing apart.
5 Apply the styles from the ¶ catalogue. Since Word has formatted everything locally (*-format in status line), you
need to apply the Default Character Format to the
selected paragraphs afterwards with F2.
6 Apply the character formats from your catalogue.
7 Replace inline-graphics with graphics imported by reference. You may need to format or adjust the existing
anchored Frames properly. The imported frames may be of
type “At Insertion Point” which requires different anchoring and positioning than “Below current Line” or “Run into
Paragraph”.
8 Apply the table formats and format the table contents
according to your template. The same note as in step 5
applies to the ¶ styles. It may be necessary to convert body
rows to heading rows and/or add heading rows and insert
text there. Do not forget the table title.
9 Establish the deatils, such as cross references or web-links
and generate a TOC if it was part of the document.
Note:

Carefully watch out for hidden elements, such as overlayed
frames and obscure items. Walk through all paragraphs and
check their format.

Graphics in source applications
Graphics in source applications (e.g. MS Word) may be OLE
objects, imported or copied external files or application specific graphics. You may need to handle them differently.

OLE objects

To get a distinct graphic rather then the OLE object, save the
graphic in the source application accordingly. See for example
Importing an Excel table on page C-7.

Copied into the document

Especially in Office applications most graphics which were
distinct files are imported by copy and hence have lost their
relation to the source. You do not have a clue about the original size or resolution in case of a bitmap.
1 In the source application Copy the image.
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Importing an Excel table

2 In FM use Edit > Paste Special and select the most appropriate format. If a a vector format is available (eps, wmf,
emf), use this (with preference to eps).

Linked to the document

To see whether a file is copied or linked (in Word), switch the
Field view On. A linked file is displayed as something like:
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{INCLUDEPICTURE "G:\\Graphics&images\\!temp\\test.wmf"
\* MERGEFORMAT \d}

Copy the referenced file ( G:\Graphics&images\!temp\test.wmf) to
an appropriate directory in your FrameMaker project and
import the file by reference in FrameMaker.

Application specific
graphics

To handle graphics created directly in the source application
(such as Word graphic or Word art) try to export the graphic
to a file in a common format (for example pdf).

Last resort

A universal method is to save the source document as pdf (or
print it using the Adobe PDF printer (formerly called Distiller
printer). Avoid to use PDFWriter if possible at all.
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1 Open the saved file in Acrobat (not just the Reader).
2 Find the first page with a graphic and extract it.
3 Crop the “pages from xyz” page to the size of the image.
4 Save the page as pdf with an appropriate name.
5 You may wish to clean out the PDF with an application such
as Illustrator (the elements outside of the cropped area
still exist, even logos and background images).
You may be surprised about the structure of such a graphic
file. Objects must be ungrouped, crop masks removed and
paths untied. Be careful with text objects. Each character
may be an object.
6 Import the pdf in FrameMaker.
Note:

With the utility Office Image Exporter you can get all graphics
at once (with names imagennn.eee). this utility works for PDF,
Word and Powerpoint files.
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Importing an Excel table
MS Excel (or FrameMaker) produced errors when importing
sparse arrays (not completely filled table areas). This error is
no more present since FrameMaker 6 and Excel 2000.
Note:

Import the whole or part
of an Excel table

Do not just import the Excel file! This will create a text inset
consisting of the whole workbook – which may contain numerous worksheets. This method, however, allows to update the
inset if the table source has changed. No formatting in FrameMaker is possible though.
1 In Excel select the table area to be copied.
2 Copy to the clipboard.
3 In FrameMaker use Edit > Paste Special… and select text.
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Importing methods in detail

4 Convert the tabbed paragraphs to a table with Table >
Convert to Table…
5 Select an appropriate Table format and format the rows
according to the needs.
Note:

If you use just Paste, you create an Object which is linked to
the Excel file, but this can not be formatted in FrameMaker.
This method however allows to update the table if the Excel file
changes.

Importing an Excel graphic
To import a graphic from Excel into FrameMaker:
1 In Excel select the graphic (chart)
2 SHIFT-Edit > Copy picture…

3 Select as shown when printed to get best results
4 In FrameMaker use Edit > Paste Special… and select wmf.

Importing a Powerpoint graphic
Note:

The utility Office Image Exporter may be of great help to
extract Powerpoint graphics in native or other picture format.
1 In PowerPoint select the graphic or graphic elements.
2 Copy to the clipboard
3 In FrameMaker Paste (a WMF will be pasted). With Paste Special you can select between WMF and DIB.

Note:
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Backgrounds will not be copied, because normally not selected.

FrameMaker specifics

FrameMaker specifics
Maker Interchange Format - MIF
Main features of this file format are:
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 Preserve the document structure
 Until FM-version 7 the file is 7-bit ASCII (“upper ASCII is
escaped). From FM-8 onwards the MIF file is UTF-8 coded.
 It is extensible (upward compatible)
Any FrameMaker version can import MIF. When opening an FM
6.x MIF in a 5.x Frame version, unknown items are skipped –
MIF is even downwards compatible!
Saving a file as MIF cleans out some ambiguities which still
accumulate with many changes in a document.

FrameMaker versus word processing and DTP
E:\FM-course\handout\miscellenaous.fm

Looking at the developments in document processing applications reveals various approaches (looking at the 1980’s):
 Quark Xpress emulated49) dedicated and complex typography equipment that required trained operators in print
houses.
 Aldus (later Adobe) PageMaker emulated a layout (pasteup) artist's workspace accessibly.
 MacWrite emulated a typewriter (magnetic-card operator
was still a profession).
 Microsoft Word emulated MacWrite with bells, whims, and
bugs.
 FrameMaker emulated dedicated technical or scientific
word-processing systems that served publishing professionals printing book-length documents.
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Any comparison between these applications must keep the
(originally intended) purpose and users in mind 50).
Word for Windows (6 … 8)

FrameMaker > 5.12

Platforms

Windows, Mac (not same functions)

Unix, Mac, Windows

User interface

Flexible and mostly intuitive, adaptable

Sometimes clumsy due to platform independence

Template

New document is copy; template can be New document is copy; updates docuupdated from document styles and mac- ment at any time (various aspects of docros. Name *.dot. Document can not be
ument). Any FM document is a template.
updated from template

Extensibility

Powerful macro language (many syntax
changes in early versions)

API client FrameScript and many other
specific API clients

Book functions

Master document (very unreliable); master document = Σ all documents

Well thought out; little automatism missing

Outline view

Full featured

API client Enhance

49 You may substitute the word emulated by “was inspired by”.
50 Many of these remarks are still valid for Word 2000 and even 2003
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FrameMaker specifics

Word for Windows (6 … 8)

FrameMaker > 5.12

Layout of pages

First, even, odd; header and footer area, Any number of master pages, even mixed
columns for body
orientation; any # of frames

Styles

Paragraph, character

Paragraph, character, table, lines

Side headings

Anchored frames (very unreliable)

Standard definitions

Tables

Heading not repeated; sorting and calcu- Heading repeated on pages; sort (FM
lations
5.5); calculations by API clients and
scripts

Variables

Fields, global variables in master document

System and user variables, may be formatted

Graphics (direct)

Located in hidden layer, positioning unreliable

Features sufficient for technical documents

Anchored frames

A very unreliable feature

The name of the game

Import graphics and text

Default: copy; paragraph and character
Default: reference; paragraph formatting;
formatting; update of references kills for- update keeps formatting (ref.)
matting

Language

Associated with paragraph or character format

Associated with paragraph or character format

Index

At any location (field)

Generated document, very flexible

Table Of Contents etc.

At any location (field), arbitrary lists pos- Generated document, very flexible, arbisible with some effort
trary lists with same functionality

Product history
You find a more or less complete history about the development of FrameMaker on the author’s web site on
www.daube.ch.

FrameMaker time line
Frame Technology
acquired by Adobe Inc.

Frame Technology founded by
Steve Kirsch, David Murray, Charles
Corfield and Vickie Blakeslee

FrameMaker and
+SGML merged into
one product

1985

1990
5

1995
330

475

2000

2005

10.0

9.0

8.0

7.2

7.1

7.0

6.0

5.5.6

5.5

5.12

5.0

4.0

3.0

2.0

1.0
1.3

0.6

Adobe India becomes responsible for FrameMaker

2010

2200
employees (~ 40 on FM R/D)
SUN Solaris only
only

employees (~ 1/3 on R/D)
Unix versions
Mac OS (until 9.x)
Windows versions

For some months a Linux Beta
implementation was available

FrameMaker icons

Application icons on Windows (original size 32×32 pixels)
3.0

4.0

5.0

5.5

6.0

7.0

8.0

9.0

10.0

The icons for version 3 to 5 are scanned from documents.
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File names

File names
document.fm

standard document name

document.fm. lck File of length 0 to lock additional open.
document. auto.fm autosave copy 8 File > Preferences
document. backup.fmbackup copy (before new edit starts)
2011-05-11

document. emg.fm emergency copy (some crashes)

E:\FM-course\handout\miscellenaous.fm

Name suffixes

document xxx.fm

generated file (for suffixes xxx see below)

document. book

generated book started with “document”

document. mif

Maker interchange format.

The following suffixes are default
Type of document

English

German

French

Table of contents

TOC

IVZ

TDM

Index

IX

SIX

IX

List of Figures, Tables

LOF, LOT

AVZ, TVZ

LDF, LDT

List of paragraphs, (alphabetical)

LOP (APL)

EAL (AEAL)

LDP (LAP)

List of Markers, (alphabetical)

LOM (AML)

ML (AML)

LDM (LAM)

LR

REF

List of References (text insets, images, LOR
fonts, unresolved x-refs etc.)

Standard Index, Index of Authors, Sub- IX, AIX,
SIX, AIX, TIX, IX, IXA,
jects, Markers, References
SIX, IOM, IOR MIX, RIX
IXT, IDM,
IREF
list of formats/ index of formats

Note:

LFT, IFT

FL, FIX

FOR, IFOR

The defaults for the suffices (TOC, IX etc.) depend on the UI
language. These can be changed when generating the files.
However, names of building blocks (for example, for system
variables) also depend on the UI language and can not be
changed.
On start of FrameMaker some files are created in the temporary directory (defined by the environment variable TMP), for
example FRM9A.tmp. These are removed at close of FM.

Crash files

If FrameMaker crashes with an error message, such as

D

Temporary files

a dump file is created in the $FMHOME directory:
h:\adobe\framemaker\en\FrameLog_99.11.05_09.44.39.txt

In other crash cases additionally the temp files are copied to
the $FMHOME directory, e.g. formulas.fm.2EB. You may need
these to send them to Adobe for error tracking.
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Document properties in MIF

Document properties in MIF
View only documents
Any document can be locked for view only (no editing possible) with the command ESC, F, l, k. This lock is permanent
and can not be unlocked, if the View Only statement is
present in the MIF file of this document (see Lock document
permanently on page 12).
Note:

Unlock document

To be able to edit this document further, always keep the MIF
version (text file) of the document to be able to remove the
View Only statement.
To unlock a view-only document, enter the sequence ESC, F, l,
k
Unlocking of a permanently locked document is not possible.

Save as View Only

With File > Save As … and selecting View Only x.x (*.fm) the
file can be saved as viewable only without applying the ESC
sequence.

Lock document permanently
The View Only MIF statements described in this section must
appear in a Document statement. These statements have no
effect in an unlocked (editable) document.
To disallow unlocking, open the MIF file and change the statement found in the <Document section:
<DViewOnly No>
<DViewOnly Yes>
<DViewOnlyNoOp 0xF00>

to
and add statement

The file is locked when opened in FrameMaker. However, the
document read from the disk by FrameMaker is still in text
format and can therefore be unlocked by someone with write
permissions to the MIF file by reversing the change.
Locked for everybody

1 Change the statement mentioned above to
<DViewOnly No ><DViewOnlyNoOp \0xF00 >
2 open the edited MIF file in FrameMaker, and
3 save the file in View Only format.
4 The following message appears:
This file cannot be opened for editing after you save it in ViewOnly format. Save a backup file in Normal (editable) format?
Yes No Cancel
5 If you select Yes, the file is immediately locked and cannot
be unlocked. The file is saved in binary format to disk, and
cannot be restored to an editable state.

Warning:
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There is no procedure for unlocking such a document (even
Adobe can not help in this case)! If the copy command is still
available for a document the contents of the document can be
pasted into another document.

Document control statements

Document control statements
You can use MIF statements to change the appearance and
behaviour of the document window in the following ways:
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Statement overview
a

Statement

Value

DViewOnly

No

document can be edited

Yes

document is view only

GotoBehavior

X-refs behave like gotolink

NotActive

Disable hypertext in X-refs

OpenBehavior

X-ref links behave like
openlink

DViewOnlyXRef

DViewOnlySelect

Yes
UserOnly

Disable highlighting
destination link

No

Disable selecting text
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DViewOnlyWinBorders Yes
No
DViewOnlyWinMenubar Yes

DViewOnlyWinPopup

Explanation

Display scroll bars
Suppress scroll bars
Display menu bar in Unix

No

Suppress menu-bar display
under Unix

Yes

Allow popup hypertex cmd

No

Disable popup hypertext cmd

DViewOnlyWinPalette No

file behaves as document

Yes

file behaves as palette

DViewOnlyNoOp

0x313

Disable cutting or clearing

DViewOnlyNoOp

0x322

Disable copying

DViewOnlyNoOp

0xF00

Disable unlocking the
document

a. Default for normal document is highlighted

Sources

Disable user actions

Dan Emory: FrameMaker Palettes [pdf on the net, 1999]
http://www.faqs.org/faqs/frame/faq/part2/
MIF reference Setting View Only document options
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You can disable specific commands in a View Only document.
For example, a hypertext author might disable copy and print
commands for sensitive documents.
To disable a command, you must supply the hex code, called
an fcode, that internally represents that command in a FrameMaker product. For example, you can disable printing, copying, and unlocking the document by supplying the following
statements:
<DViewOnlyNoOp 0x313> # Disable printing
<DViewOnlyNoOp 0x322> # Disable copying
<DViewOnlyNoOp 0xF00> # Disable unlocking the document

Warning:
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There is no procedure for unlocking such a document! If the
copy command is still available for a document the contents of
the document can be pasted into another document.

Document properties in MIF

Document window menu
bar

Suppress (No), Enable (Yes)
<DViewOnlyWinMenubar No>

This statement has no effect in the Windows version of a
FrameMaker product because those versions have an application menu bar rather than a document window menu bar.

Display of scroll bars and
border buttons

Suppress (No), Enable (Yes)

Selection in the document
window

Suppress (No), Enable (Yes)

<DViewOnlyWinBorders No>

<DViewOnlySelect No>

You can normally select text and objects in a locked document by Control-dragging in UNIX and Windows versions.
Specifying <DViewOnlySelect No> prevents all selection in a
locked document.

Context menus

Suppress (No), Enable (Yes)
<DViewOnlyWinPopup No>

This statement has no effect in Windows versions.
A document region pop-up menu is a menu activated by the
right mouse button. For example, in UNIX versions of a
FrameMaker product, the Maker menu and Viewer menus can
be accessed by pressing the right mouse button. If the DViewOnlyWinPopup statement has a value of No, the background
menu does not appear when the right mouse button is
clicked.

Make window behave as
palette

<DViewOnlyWinPalette Yes>

A palette window is a command window, such as the Equations palette, that exhibits special platform-dependent behaviour. In UNIX versions of FrameMaker products, a palette
window can only be dismissed; it cannot be closed to an icon.
In Windows versions, a palette floats outside the main application window and cannot be unlocked. To edit the palette,
you need to reset the DViewOnlyWinPalette statement to No
in the MIF file before opening it in a FrameMaker product.

Using active crossreferences

A locked document automatically has active cross-references.
An active cross-reference behaves like a hypertext gotolink
command; when the user clicks on a cross-reference, a FrameMaker product displays the link’s destination page. By
default, the destination page is shown in the same document
window as the link’s source.

Behaviour gotolink

You can use MIF statements to turn off active cross-references and to change the type of hypertext link that the crossreference emulates. (By default, cross-references emulate the
gotolink behaviour.)

Behaviour openlink

To make cross-references emulate the openlink command,
which displays the destination page in a new document window, use the following statement:
<DViewOnlyXRef OpenBehavior>
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Document control statements

Use this setting to allow users to see both the source page
and the destination page.

Disable active crossreferences

To turn off active cross-references, use the following statement:

Control with
DViewOnlySelect

Use this setting to emulate the behaviour of FrameMaker versions < 6. You can use the DViewOnlySelect statement to control whether active cross-references highlight the marker
associated with destination text.

D
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<DViewOnlyXRef NotActive>
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Value

Effect when clicking on a cross-reference

Yes

Highlight the marker associated with the destination text.

UserOnly

Default: No highlighting of the marker. However, the user can select text in the locked document.

No

No highlighting of the marker. The user cannot select text in the
locked document.

Background information

Background information
Hyperlinks: goto versus open
Question: When I follow a link to another file in the FM book,
it usually does not close the current file. Other times it does
close the current file. Is this a bug or a feature, and how do I
disable closing the current file?
Answer: FrameMaker hyperlinks have two variations: goto
and open.
The goto variation displays the target document in the current window (closing the currently-displayed file); the open
variation displays the target document in a new window, leaving the current document open.
The goto/open behaviour of hypertext markers generated
automatically (e.g. in TOC/IX) is controlled through the corresponding flow in the reference page, e.g.: openObjectId
<$relfilename>:<$ObjectType> <$ObjectId>
With respect to cross-references, the goto/open behaviour is
controlled internally by the DViewOnlyXRef property (see
Behaviour openlink on page C-14 and Disable active cross-references on page C-15). This can be set only in MIF or by a plugin.
If you type the Shift key when activating a link/cross-ref with
Ctrl+Alt/cross-ref (that is, Ctrl+Alt+Shift+click), the goto... is
interpreted as an open... action (and vice versa).
Notice that the goto/open variation only applies to links activated in FrameMaker, and is not carried over to PDF interactivity (where all links/cross-refs become “goto”. More info at
www.microtype.com, item 10.
[Shlomo Perets, 2008-12-29]

Named destinations in PDF
With standard settings in FrameMaker a huge number of
named destinations are created. They can be examined in
Acrobat 8, View > Navigation Panels select Destinations to
get a window with the open Tab Destinations. The destinations created by FrameMaker have specific names (n is the
number of the file in the FM book):
P.n

Page n (may not exist for every page)

Fn

First page of document n

Lnf

Last page of document n

Gn.o

Paragraph targets

In.o.p
En.name

Target of a structured ID cross reference (Element,
name= normalised ID)

Mn.o.newlink.namecross reference targets (o seems to be a
type)
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General items in maker.ini

General items in maker.ini
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Note:

Not all of the possible settings are explained here. See also
Recommended setup of FM on page A-31. Default values are
given aftre the = sign.

[Frame]
Version
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Language

8.0p277 means, version 8.0, patch 277. Patches save the
exchanged files in $HOME/backup_pnnn. The value is displayed
in Help > About FrameMaker.
This specifies the default language dictionary and the
default paragraph language. The initial setting is defined by
the installed product version (e.g. UKEnglish).
You can enter the name of one of the other languages available in FrameMaker, but you must have the dictionary for that
language installed for FrameMaker to work.

ProductInterface

FrameMaker or StructuredFrameMaker. If you delete maker.ini
in the user area (%APPDATA%) you are asked again which interface to be used.

[Reginfo]
RegNum

This is no more used in FM-8, hence 0

Asn

Application Serial Number from the CD-ROM. It is not used
the registration process, but the relevant information from
the Activation is kept in the online database of Adobe.

AskExit=Off

Determines whtehr to asks for confirmation before exiting.

[Preferences]
AutoSave=Off
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This section is primarily information for the curious person.
Do not tinker around with settings which you do not completely understand! You may encounter a FrameMaker crash
with wrong setting, although some false settings can be handled by FrameMaker.

The value for AutoSave is in minutes and determines how
often FrameMaker creates a backup file for the active file,
whether or not you have saved it.

ShowErrors=On

Determines wether error messages are displayed in the console window when they occur. This does not disable messages
from plug-ins.

ErrorFileName=consfile.txt

This specifies the name of the file that error messages are
written to if there is a system crash. If that happens, immediately make a copy of the consfile.txt file. This file will contain
important debugging information, which can help a Technical
Support engineer track down the problem.

GreekSize=7

The value specifies the point size at which displayed text is
grayed out.

UseSystemCursor=Off

This specifies whether FrameMaker will use its own cursors
for mouse actions such as Rotate or Drag.
OFF
ON
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FrameMaker uses its own cursors
FrameMaker uses the operating system cursor.

Background information

DefaultRulerxxx

These settings provide the default values for the tick marks
on the vertical and horizontal rulers in new documents. The
current setting is saved in the document.

DefaultGridxxx

These settings provide default values for spacing of the visible grid lines.

DefaultSnapxxx

Tehese settings provide default values for the spacing of the
(invisible) snap grid.

MonitorSize=Default

This setting specifies the size of your monitor so that the
documents and dimensions you see on the screen (such as for
margins and objects) are very close to their actual size.
Initially, MonitorSize is set to Default. If you want greater
precision in the measurements you see on the screen, fill in
the diagonal measure of your monitor: MonitorSize=17in

AutoMnemoniseMenus

This setting determines if mnemonic command shortcuts are
shown on menus.

StickyPopupThreshold=500

This setting controls how long (milli-seconds) you must hold
down the mouse button for pop-up menus, such as the Zoom
menu, to open.

ForceFileTypeChoices=Off

On forces the “unknown file type dialog”, even if the file type
is known to FM.

ReplaceCacheSize=200

Purpose unknown. Hands OFF!

RomanRanges

The values 0000-024F, 0400-052F, 0370-03FF, 2000-206F
define which Unicode characters are to be considered text
(and not symbols). This is essential for the wildcard search.

ConfigWarnKbdOverride=Off

If On, you will see warning messages when you load the customization file if it contains shortcut definitions for commands that already have shortcuts defined for them.

ConfigWarnKbdRedundant=Off

If On, you will see warning messages when you load the customization file if it contains redundant shortcut definitions.

UsePostscript=On

This setting determines whether FrameMaker uses built-in
methods of generating PostScript code instead of standard
Windows methods. If FM uses the built-in methods, it can
print faster and produce higher quality documents.
With OFF the Windows methods are used instead. In this case
FrameMaker prints the preview image of EPS graphics instead
of the PostScript image.

EPSLevelForPlacedPDF

This specifies the level of EPS to use for placed PDF images.
By default, FrameMaker prints imported PDF (Placed PDF) files
by converting them to Level 2 EPS files. Use this setting to
specify Level 1 or Level 2.

FMImage=Off

This entry controls whether a FrameImage facet is saved with
imported graphics by default.51)

GDIRasterizeKiloPixelLimit=8192

Purpose unknown. Hands OFF!

CrossPlatformFileNaming=Windows

This setting controls the file naming convention for files to be
saved. The default is Windows9x/2000/NT. The other choices
are UNIX, and Macintosh.

API=On

To start FrameMaker without the API (Application Program
Interface) clients listed in section [APIClients], set OFF.
51 IMHO this does not work correctly. Although set OFF, FrameVector facets
are present at the import by copy of any bitmap file.
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General items in maker.ini

ClipboardFormatsPriorities

This controls what format is used when you paste or when
you drop a file into an open document. See Modifications to
maker.ini on page A-32.
An item can be stored on the Clipboard with multiple formats. This entry specifies the order for the formats used to
paste Clipboard items. In this entry, priority in the list goes
from left (highest) to right (lowest). To give a format

E:\FM-course\handout\miscellenaous.fm
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higher priority, move it farther left in the list. The first format in the list which matches a format on the Clipboard
will be the format used to paste the item. For example, many
users move TEXT in front of RTF in order to preserve
line breaks and strip formatting when text is pasted from
browsers and other programs.
The FILE format instructs FrameMaker to check whether the
object being dropped or in the Clipboard is a file. If it is, the
file is opened; if the file is not in a recognized graphic format,
it is embedded as an OLE package. This precedence applies to
all items you paste from the Clipboard. You can override this
precedence for individual paste operations by using Edit >
Paste Special rather than Edit > Paste.
If you comment out this line (by starting it with a semicolon),
FrameMaker uses the first of the formats associated with the
Clipboard item. Depending on what kind of item is on the
Clipboard, the format can vary from one paste to the next.

New in FM-8
EnhancedToolBar=On
No3DInPDF=Off

Setting identical to File > Preferences > General setting of
“Don’t embed 3D model file in PDF”

NoFlashInPDF=Off

Setting identical to File > Preferences > General setting of
“Don’t embed Adobe Flash file in PDF”

AlwaysDownloadURL=Off

With ON referenced files imported by an URL are updated on
opening the document.

DontShowWelcomeScreen=off
TabbarStatus=On

D

Unknown purpose, no effect recognises on/off

Setting identical to File > Preferences > General setting of
“Don’t show Welcome Screen’.
Setting identical to View > Tabbed Bar.

hpWarning=0

Setting identical to File > Preferences > General setting of
“Show Warnings while cleaning History”. set=1, cleared=0.

ToolBarIniFile

Define an alternative toolbar ini file, for example
fminit\configui\FMToolbr.ini

[Files]

CustomDoc=
fminit\custom

This specifies the template for new custom documents. This
file also defines the standard paragraph etc. formats.

PageSizesFile

The indicated file (fminit\pagesize.cfg) contains the definition of page sizes.

ConfigCustomUIFile

This specifies the file that contains additional custom menus
or changes to existing menus or commands that you have
added. The default file for this setting is customui.cfg. A file
name must be present to avoid a crash. This entry is used by
the Enhanced Toolbar implementation.
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Background information

[DialogLayout]

You may use these definitions if you don’t get a view of a particular dialogue. This may happen, if it was on a second monitor, which is now more present. In such a case just set the
coordinates to 0, 0 to get them into the top left corner, from
where you can move them to another position.
You may also delete the maker.ini file in the user area
(%APPDATA%) to have FrameMaker refresh it from the master in
$HOME.
MakerWin

The values specify normal, minimized, and maximized positions. The first value determines which position to use; its
value is 1 for normal, 2 for minimized, or 3 for maximized.
The next six values are pairs of x and y offsets that specify
the different window positions; the first pair specify the minimized position, the second pair specify the maximized position, and the third pair specify the normal position. The last
two values are the normal window width and height.

Catalogues

The settings for the Paragraph Catalog and Character Catalog
(PCatalog and CCatalog) specify first an x and y value for the
location of the catalog. The x value specifies the offset in pixels from the left side of the screen. The y value specifies the
offset in pixels from the top of the screen. Optionally, the
width and height of the catalog, in pixels, appear after the x
and y values.

ECatalog
Others

This positions the Element Catalog. This is only available
when running FrameMaker in Structure mode.
The rest of the settings specify only an x and y value for the
left and top offset of the window or dialog box.

Reduce impact of import by copy
The bahaviour of FrameMaker when importing files, such as
graphics is specified in the section [Filters] of the
maker.ini file. For example, for the import of png files, you
find the following entry:
20="PNG " IMAG PNG FrameVector GFXImport "Portable Network Graphics" imagmark.dll
^.png

The elements of this entry are:
Text

Explanation

20

Just a number required by Windows

“PNG”

Format ID,

IMAG

A four-character maximum string that identifies the
vendor

PNG

Specific facet stored in document

FrameVector

General facet stored in document

GFXImport

Filter type: Graphics import

"Portable Network Graphics"

Description of the filter

imagmark.dll

Filter name in the Filters directory

^.png

Extension of the file handled by the filter

To reduce the impact of the copy, replace the FrameVector
term by DIB (Device Independent Bitmap) which uses compession methods.
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Special directories

Special directories
Some directories in the FM installation provide special treatment to the files in them.

$HOME\Templates

Files in this directory are opened as copies, that is with the
name Untitled.fm. This directory is defined in maker.ini as:

2011-05-11

TemplateDir=Templates

You may specify any other directory here to access your company templates, for example:
TemplateDir=D:\doc-std\Frame

To have still access to the FM-templates, copy the subdirectories from $HOME\Templates to your company directory.

$HOME\fminit\maker

Files in this directory are opened as locked, that is, can not be
edited. For example, the template browser (see To use a sample
template on page 1-10) is located here. This directory is
defined in maker.ini as

Note:

Do not change this setting! In this directory also menu.cfg is
located and this must not be moved to any other location.
It is unclear to me why the Equation palette is not in this
directory ($HOME\fminit\equation). Both the Template
browser and the Equation palette are FrameMaker documents
using advanced hypertext methods. Copying them to another
location and opening from there allows to edit them. Back in
the PaletteDir they are locked again.

D

E:\FM-course\handout\miscellenaous.fm

PaletteDir=fminit\maker
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FrameMaker principles and philosophy

FrameMaker principles and philosophy
FrameMaker development started in the UNIX environment,
from which the following principles originate:
1 Keep it small and simple, but allow for easy aggregation.
In UNIX general purpose utilities can be “concatenated” via
the standard input/output mechanism.
2 Names are case sensitive. The roots of this is the C language. Hence not only items in the file system, but also
most object-names handled by a program are case sensitive.

Impact on FrameMaker
1 Object names (names of paragraph formats etc.) are case
sensitive. A style name Body is not the same as body.
2 Various tasks are not handled in the core of FrameMaker
but in separate processes:
-

Tables
Sorting of tables
Formulas (Equations)
SGML structure

As a result of this the integration in some cases is not as
smooth as wanted by the user (e.g. table footnotes are handled independently of text footnotes).
3 Input to FrameMaker can be generated from other processes, hence the formatting process does not need user
interaction or user judgement.
This requires that text features (e.g. TABs) can be handled
without looking onto the screen. TABs are hence absolute,
not relative as in text processing software.
4 No macro language is built into FrameMaker. But since the
beginnings of FM automating was performed by processing
the MIF form of files. For example, Data Base Publishing
solutions generate MIF which is then formatted in FM.
In addition, since the beginnings the Frame Developer Kit
was available to build plug-ins on the various platforms.
Since about 1997 the script language FrameScript is available, which allows scripts to do nearly the same as FDK programming allows.
5 Since FrameMaker was ported to various platforms (UNIX 8
Mac 8 Windows) there was need for a common ground in
the user interface. Also hardware (cpu, RAM, screen) was
expensive in the beginning. Hence FM does not waste
resources and on the other side has not a tweaked GUI.
6 FM has no “hidden intelligence” as some largely used programs pretend. It does not work automatically in the background. You need to start such processes as updating the
page numbering or define TAB positions explicitly.
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