Adobe® FrameMaker® 8 Handbuch

Erste Schritte

Wenn Sie die neue Software noch nicht installiert haben, lesen Sie zunächst die Informationen zur Installation und anderen vorbereitenden Schritten. Nehmen Sie sich vor der Nutzung der Software einige Augenblicke Zeit und lesen Sie diese Übersicht über die Adobe® Help® und die vielen Ressourcen, die Benutzern zur Verfügung stehen. Sie haben Zugang zu Plug-Ins, Schablonen, Benutzercommunitys, Seminaren, Übungen, RSS-Feeds usw.


Erste Schritte / Installation

Anforderungen

Die vollständigen Systemanforderungen und Empfehlungen für Ihre Adobe-Software finden Sie in der Readme-Datei auf der Installations-CD.


Erste Schritte / Installation

Installieren der Software

    1. Schließen Sie alle anderen Adobe-Anwendungen auf dem Computer.

    2. Legen Sie den Installationsdatenträger in das CD-Laufwerk ein und folgen Sie den Anweisungen auf dem Bildschirm.

Hinweis: Weitere Informationen finden Sie in der Readme-Datei auf der Installations-CD.


Erste Schritte / Installation

Aktivieren der Software

Wenn Sie eine Einzelhandels-Einzelbenutzerlizenz für die Adobe-Software haben, werden Sie zum Aktivieren der Software aufgefordert. Dies ist ein einfacher, anonymer Vorgang, den Sie innerhalb von 30 Tagen nach erstmaliger Verwendung der Software durchführen müssen.

Weitere Informationen zur Produktaktivierung finden Sie in der Readme-Datei auf der Installations-CD oder auf der Adobe-Website unter www.adobe.com/go/activation_de.

    1. Wenn das Dialogfenster "Aktivierung" nicht bereits geöffnet ist, wählen Sie "Hilfe > Aktivieren".

    2. Folgen Sie den Anweisungen auf dem Bildschirm.

Hinweis: Wenn Sie die Software auf einem anderen Computer installieren wollen, müssen Sie sie zunächst auf dem eigenen Computer deaktivieren. Wählen Sie hierzu "Hilfe > Deaktivieren".


Erste Schritte / Installation

Registrieren

Registrieren Sie das Produkt, um Update-Benachrichtigungen und andere Serviceleistungen zu erhalten.

Befolgen Sie zur Registrierung die Anweisungen im Dialogfenster "Registrierung", das nach Installation und Aktivierung der Software geöffnet wird.

Wenn Sie die Produktregistrierung nicht sofort durchführen wollen, können Sie dies später jederzeit durch Auswahl von "Hilfe > Registrierung" nachholen.


Erste Schritte / Adobe-Hilfe

Hilferessourcen von Adobe

Die Dokumentation zu dieser Adobe-Software liegt in unterschiedlichen Formaten vor.

Hilfe im Produkt selbst und LiveDocs-Hilfe

Die in die Software integrierte Hilfe bietet Zugriff auf die gesamte Dokumentation und alle Anweisungen, die bei Auslieferung der Software verfügbar sind. Sie können über das Menü "Hilfe" in der Adobe-Software darauf zugreifen.

Die LiveDocs-Hilfe bietet den gleichen Inhalt wie die im Produkt verfügbare Hilfe, umfasst jedoch zusätzlich Updates und Links zu weiteren Lerninhalten im Internet. Für einige Produkte können Sie den Themen in der LiveDocs-Hilfe Kommentare hinzufügen. Die LiveDocs-Hilfe zu diesem Produkt finden Sie im Adobe Help Resource Center unter www.adobe.com/go/documentation_de.

Beide Varianten der Hilfe sind als Ausgangspunkt für den Zugriff auf zusätzliche Inhalte und Benutzercommunitys zu verstehen. Die vollständigste und aktuellste Version der Hilfe ist immer die im Internet zu findende Web-Hilfe.

PDF-Dokumentation

Die produktinterne Hilfe steht auch im PDF-Format zur Verfügung, die für das Ausdrucken optimiert ist. Möglicherweise werden auch andere Dokumente, beispielsweise Installationshandbücher oder Weißbücher, als PDF-Dateien bereitgestellt. Alle Dokumente, die im Ordner "OnlineManuals" in früheren Versionen von Adobe FrameMaker® verfügbar waren, sind auf der Adobe-Webseite zu finden.

Die vollständige PDF-Dokumentation ist im Adobe Help Resource Center unter www.adobe.com/go/documentation_de verfügbar.

Die mit der Software gelieferte PDF-Dokumentation finden Sie im Ordner "Documents" auf der Installations- oder Inhalts-CD.

Gedruckte Dokumentation

Gedruckte Versionen der in das Produkt integrierten Hilfe können im Adobe Store unter www.adobe.com/go/store_de erworben werden. Im Adobe Store finden Sie auch Bücher von Adobe-Partnern.

Eine gedruckte Version des Handbuchs "Erste Schritte" ist im Lieferumfang der Software enthalten.


Erste Schritte / Adobe-Hilfe

Kundendienst

Auf der Support-Website von Adobe unter www.adobe.com/support_de finden Sie Informationen zur Fehlerbehebung für Ihr Produkt und den kostenlosen und kostenpflichtigen technischen Kundendienst. Über den Schulungslink haben Sie Zugriff auf Adobe Press-Bücher, verschiedene Schulungsressourcen, Zertifizierungsprogramme für Adobe-Software und mehr.


Erste Schritte / Adobe-Hilfe

Downloads

Unter www.adobe.com/go/downloads_de erhalten Sie kostenlose Updates, Demoversionen und andere nützliche Software. Zusätzlich hält der Adobe Store (www.adobe.com/go/store_de) Tausende von Plug-Ins von Drittanbietern bereit, mit denen Sie beispielsweise Aufgaben automatisieren, Workflows anpassen und spezielle professionelle Effekte erstellen können.


Erste Schritte / Adobe-Hilfe

Adobe Labs

Auf der Adobe Labs®-Website können Sie neue und sich in der Entwicklung befindende Technologien und Produkte von Adobe erleben und testen.

Auf der Adobe Labs-Website stehen Ihnen u. a. folgende Ressourcen zur Verfügung:

    Vorabversionen von Softwareanwendungen und Technologien

    Codebeispiele und optimale Verfahren für schnelleres Lernen

    Frühe Versionen von Produkt- und technischer Dokumentation

    Foren, Wiki-basierte Inhalte und weitere gemeinschaftliche Ressourcen erleichtern Ihnen die Interaktion mit gleich gesinnten Entwicklern.

Adobe Labs unterstützt einen gemeinschaftlichen Prozess der Softwareentwicklung. In dieser Umgebung kann der Kunde schnell neue Produkte und Technologien produktiv nutzen. Adobe Labs ist außerdem ein Forum für frühzeitiges Feedback, das die Entwicklungsteams von Adobe nutzen, um Software zu erstellen, die die Anforderungen und Erwartungen der Anwendergemeinschaft erfüllt.

Adobe Labs finden Sie unter www.adobe.com/go/labs_de.


Erste Schritte / Adobe-Hilfe

Benutzercommunitys

Benutzercommunitys bieten Foren, Blogs und andere Möglichkeiten zur gemeinsamen Nutzung von Technologien, Werkzeugen und Informationen.

Die Benutzer können Fragen stellen und erfahren, wie andere ihre Software optimal nutzen. Foren, in denen sich Benutzer austauschen können, stehen in englischer, französischer, deutscher und japanischer Sprache zur Verfügung, und Blogs werden in einer Vielzahl von Sprachen veröffentlicht.

Unter www.adobe.com/de/communities können Sie an Foren und Blogs teilnehmen.


Erste Schritte / Neue Funktionen

Die wichtigsten Neuerungen von FrameMaker 8

Unicode-Unterstützung

Dank der Unterstützung des Unicode-Standards zur Textcodierung können Sie Inhalte in mehreren Sprachen erstellen. Alle Funktionen von FrameMaker, beispielsweise die Such- und Ersetzfunktion, Marken, Hypertext oder Katalogeinträge, unterstützen Unicode. Sie können Dokumente mit Unicode-Lesezeichen, -Tags, -Kommentaren usw. im PDF-Format exportieren. Außerdem haben Sie die Möglichkeit, Unicode-Inhalte aus anderen Anwendungen zu importieren oder in diese zu exportieren. Zusätzliche Wörterbücher unterstützen Sie beim Erstellen von Inhalten in mehreren Sprachen.

Verbesserte Funktionen für bedingten Text

Die folgenden Funktionen erleichtern die Arbeit mit Single-Source-Dokumenten:

    Verwaltung von Bedingungstypen über das neue Dialogfenster "Bedingungs-Tag verwalten"

    Hinzufügen neuer Bedingungstypen über das neue Dialogfenster "Bedingungs-Tag hinzufügen"

    Umbenennen von Bedingungstypen

    Definieren Sie eine neue Farbe für einen Bedingungstyp mithilfe der Schaltfläche "Neue Farbe" im Dialogfenster "Bedingungstyp ändern".

    Visuelle Unterscheidung von Text mit mehreren Bedingungstypen, da die Farbe des Textes von den ihm zugewiesenen Typen abhängt Weitere Informationen finden Sie unter Erscheinungsbild von Text mit mehreren Bedingungstypen.

    Erstellen Sie boolesche Ausdrücke mit komplexen Kombinationen von Bedingungstypen und booleschen Operatoren, um bedingte Ausgaben zu generieren.

Verbesserungen bei strukturiertem und XML-Authoring

Das strukturierte Authoring wurde wie folgt verbessert:

    Beim XML-Roundtripping bleiben XML-Kommentare nun als Marken erhalten. Systemvariablen und Verarbeitungsanweisungen (PIs) bleiben beim Roundtripping ebenfalls erhalten.

    Sie können die Elementformatierung von CSS in DTD importieren, sodass Sie die konsistente Formatierung über unterschiedliche XML-Anwendungen hinweg gewährleisten können. Die CSS-Datei kann im XML-Dokument referenziert oder manuell importiert werden. Es können mehrere CSS-Dateien der Reihe nach importiert werden, um eine mehrstufige Formatierung zu ermöglichen.

    Dank der Unterstützung für Single-Sourc-Workflows können Sie strukturierte Dokumente filtern. Die Single-Source-Workflows werden über andere XML-Anwendungen, die Attributwerte zum Filtern von XML-Dokumenten verwenden, hinweg beibehalten.

Filter nach Attribut

Sie können strukturierte Dokumente auf Basis von Attributwerten mithilfe komplexer boolescher Ausdrücke filtern. Außerdem haben Sie die Möglichkeit, mehrere Ausdrücke zu erstellen und zu speichern, um unterschiedliche Ausgaben zu generieren.

Verfolgen von Textänderungen

Sie können Textänderungen in Dokumenten verfolgen. Der hinzugefügte und entfernte Text wird markiert, sodass er leicht zu erkennen ist. Sie können durch die bearbeiteten Abschnitte navigieren und einzelne Änderungen akzeptieren oder verwerfen. Außerdem können Sie eine Vorschau des Dokuments anzeigen lassen, um dessen ursprünglichen oder endgültigen Zustand zu sehen. Die geänderten Informationen bleiben beim XML-Roundtripping beibehalten.

DITA-Anwendungspaket

Das integrierte DITA-Anwendungspaket und ein DITA-Menü unterstützen Sie beim DITA-Authoring. Sie können ein FrameMaker-Dokument direkt aus einer DITA Map erzeugen. Außerdem können Sie beim Authoring von DITA-Inhalten die Standardfunktionen von FrameMaker verwenden.

3D-Workflows (nur Windows®)

3D-Objekte (U3D-Format) können nur in FrameMaker 8-Dokumente eingefügt werden. Außerdem können Sie für das 3D-Objekt Parameter wie die Standardansicht, den Darstellungsmodus, die Hintergrundfarbe und das Beleuchtungsschema einstellen. Sie können das Dokument im PDF-Format mit aktiven 3D-Modellen veröffentlichen. Die 3D-Objekte werden beim XML-Roundtripping beibehalten.

Unterstützung für SWF-Dateien (nur Windows)

Sie können Dokumente mit SWF-Dateien (beispielsweise Adobe Captivate®-Filme) erstellen. Das SWF-Objekt wird beim XML-Roundtripping beibehalten.

Unterstützung für HTTP-Dateipfade (nur Windows)

Sie können einen HTTP-Pfad für den Import von Grafiken in ein Dokument (durch Kopieren oder Referenz) festlegen. Der HTTP-Pfad wird bei XML-Roundtrips beibehalten.

Erweiterte WebDAV-Unterstützung

Die WebDAV-Unterstützung wurde ausgeweitet, sodass nun das Authoring und die Bearbeitung von XML-Dateien auf dem WebDAV-Server (Web-based Distributed Authoring and Versioning) möglich sind.

Import von Office 2007-Inhalten (nur Windows)

Sie haben die Möglichkeit, Inhalte von Microsoft® Word® 2007 und Microsoft Excel® 2007 zu importieren.


Grundlagen in FrameMaker

Begrüßungsbildschirm

Arbeitsbereich

Strukturierter Arbeitsbereich

Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Strukturierte Dokumente

Arbeiten mit strukturierten FrameMaker-Dokumenten

Arbeiten mit unstrukturierten XML-Dokumenten

Bearbeiten von Text

Textformatierung

Mehrstufige Befehle "Rückgängig" und "Wiederholen"


Grundlagen in FrameMaker

Begrüßungsbildschirm

Standardmäßig wird der Begrüßungsbildschirm beim Öffnen von FrameMaker nur dann angezeigt, wenn auf Ihrem Computer Adobe Flash® Player installiert ist. Wenn Sie möchten, können Sie mithilfe folgender Schritte die Anzeige des Begrüßungsbildschirms verhindern.

So deaktivieren Sie die Anzeige des Begrüßungsbildschirms:

    1. Wählen Sie "Datei > Voreinstellungen > Allgemein".

Das Dialogfenster "Voreinstellungen" wird angezeigt.

    2. Wählen Sie die Option "Begrüßungsbildschirm nicht anzeigen", wenn Sie nicht möchten, dass dieses Dialogfenster beim Öffnen des Programms angezeigt wird.

    3. Klicken Sie auf "Zuweisen".

Der Begrüßungsbildschirm wird beim nächsten Öffnen von FrameMaker nicht mehr angezeigt.

Hinweis: Sie können auch im Begrüßungsbildschirm selbst die Option "Begrüßungsbildschirm nicht mehr anzeigen" auswählen.


Grundlagen in FrameMaker

Arbeitsbereich

Der Adobe FrameMaker-Arbeitsbereich umfasst sowohl strukturierte als auch nicht strukturierte Produktoberflächen. Ein Arbeitsbereich enthält ein Dokumentfenster mit formatiertem Inhalt oder das Fenster "Strukturansicht" mit dem Elementkatalog. Beim Arbeiten im nicht strukturierten Arbeitsbereich ist nur das Dokumentfenster verfügbar. In diesem Fenster wird der Dokumentinhalt so angezeigt, wie er als Ausdruck oder Online-Ausgabe erscheint. Beim Arbeiten im strukturierten Arbeitsbereich sind das Dokumentfenster und das Fenster "Strukturansicht" verfügbar. In diesen Fenstern können Elemente in einer gültigen Struktur angeordnet werden.

Wenn Sie die Anwendung zum ersten Mal öffnen, bietet FrameMaker die Möglichkeit, im unstrukturierten FrameMaker-Arbeitsbereich oder im strukturierten FrameMaker-Arbeitsbereich zu arbeiten. Sie können die verwendete Benutzeroberfläche ändern, indem Sie den entsprechenden Arbeitsbereich auswählen. Nachdem Sie den Arbeitsbereich ausgewählt haben, wird FrameMaker bei jedem nachfolgenden Starten der Anwendung im ausgewählten Modus aufgerufen. Hierbei wird der Strukturstatus des zu öffnenden Dokuments nicht berücksichtigt.

So wechseln Sie zwischen unstrukturiertem und strukturiertem Modus von FrameMaker:

    1. Wählen Sie "Datei > Voreinstellungen > Allgemein" (Windows) bzw. "Datei > Voreinstellungen" (UNIX®).

    2. Wählen Sie in der Liste "Produktoberfläche" die Option für FrameMaker oder strukturierter FrameMaker.

    3. Klicken Sie auf "Zuweisen". Sie werden aufgefordert, FrameMaker neu zu starten, damit die Voreinstellung wirksam wird.


Grundlagen in FrameMaker / Arbeitsbereich

Bestandteile des FrameMaker-Arbeitsbereichs

FrameMaker umfasst mehrere Bestandteile und Funktionen, die sowohl im strukturierten als auch im unstrukturierten Arbeitsbereich vorliegen.

Dokumentfenster

Beim Öffnen eines strukturierten oder unstrukturierten FrameMaker-Dokuments wird ein Dokumentfenster geöffnet. In diesem Fenster wird das Dokument angezeigt, wobei der Text formatiert ist, alle Grafiken und sonstige Elemente so wie im fertigen Dokument angeordnet sind und die gesamte Seite im Seitenlayout angezeigt wird. Wenn Sie mehrere Dokumente öffnen, erscheint jedes Dokument in einem eigenen Dokumentfenster.


Grundlagen in FrameMaker / Arbeitsbereich / Bestandteile des FrameMaker-Arbeitsbereichs

Anpassen der Dokumentanzeige im Dokumentfenster

Sie haben folgende Möglichkeiten, das Aussehen von Dokumentfenstern anzupassen:

    Vergrößern und verkleinern

    Ändern der Standardmaßeinheiten

    Ein- und Ausblenden der visuellen Hilfsmittel

    Ändern des Menübefehlssatzes

Vergrößern und verkleinern

Sie können größer zoomen, um mehr Details anzuzeigen, oder kleiner zoomen, um einen besseren Überblick über das Dokument zu erhalten. Das Aufklappmenü "Zoom" zeigt sowohl im Dokumentfenster als auch in der Strukturansicht für strukturierte Dokumente die aktuelle Zoom-Einstellung an.

A: Aufklappmenü "Zoom" B: Schaltfläche "Kleiner zoomen" C: Schaltfläche "Größer zoomen"

Sie können die Zoom-Einstellung eines oder mehrerer Dokumente in einem Buch ändern, indem Sie die betreffenden Dokumente im Buchfenster auswählen und einen Befehl aus dem Menü "Darstellung > Zoom" wählen. Die Befehle "Seite an Fenster anpassen", "Fenster an Seite anpassen" und "Fenster an Textrahmen anpassen" können jedoch nur für geöffnete Dokumente verwendet werden.

So ändern Sie die Zoom-Einstellung:

Führen Sie eine der folgenden Aktionen aus:

    Klicken Sie auf das Symbol "Größer zoomen", um Text und Objekte vergrößert darzustellen. FrameMaker stellt den Bereich der Seite, in dem sich die Einfügemarke oder ein markiertes Objekt befindet, vergrößert dar. Ist keine Einfügemarke oder Auswahl im Dokument vorhanden, vergrößert FrameMaker die Darstellung ausgehend von der Mitte der Seite.

    Um Text und Objekte verkleinert darzustellen, klicken Sie auf das Symbol "Kleiner zoomen".

    Wählen Sie einen Wert aus dem Aufklappmenü "Zoom", um Text und Objekte in einer bestimmten prozentualen Vergrößerung anzuzeigen.

    Wählen Sie "Seite an Fenster anpassen" im Aufklappmenü "Zoom", um die vollständige Seite im aktuellen Fenster anzuzeigen.

So passen Sie die Fenstergröße der Seitengröße an:

    Wählen Sie im Aufklappmenü "Zoom" die Option "Fenster an Seite anpassen". Wenn die Darstellungsoption "Gegenüberliegende Seiten" aktiviert ist, wird die Fenstergröße geändert, damit zwei Seiten nebeneinander passen.

So passen Sie die Fenstergröße der Größe des Textrahmens an:

    Wählen Sie im Aufklappmenü "Zoom" die Option "Text an Fensterrahmen anpassen".

So ändern Sie die verfügbaren Zoom-Einstellungen:

    1. Wählen Sie aus dem Aufklappmenü "Zoom" den Eintrag "Zuweisen".

    2. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie den Prozentsatz aus, den Sie ersetzen wollen und geben Sie den neuen Prozentsatz ein. Sie können jeden beliebigen Prozentsatz zwischen 25 % und 1600 % eingeben. Die Werte sind in aufsteigender Reihenfolge sortiert, sodass Sie Werte in alle Textfelder eingeben können.

    Um wieder zu den voreingestellten Prozentwerten zurückzukehren, klicken Sie auf "Standard".

Hinweis: Sie können die Standardeinstellungen der Zoom-Funktion individuell anpassen. Weitere Informationen hierzu finden Sie im online verfügbaren Handbuch "Anpassen von FrameMaker-Produkten" auf der folgenden Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.

    3. Klicken Sie auf "Zuweisen".

So ordnen Sie unter Windows dem Zoom-Faktor 100 % die Seitengröße zu:

    1. Wählen Sie "Datei > Voreinstellungen > Allgemein".

    2. Geben Sie unter "Bildschirmgröße" die Diagonale Ihres Bildschirms an und klicken Sie auf "OK".

Falls die Übereinstimmung der Anzeige am Bildschirm mit der gedruckten Darstellung nicht von grundlegender Bedeutung ist, können Sie die Einstellung im Aufklappmenü "Bildschirmgröße" auf "Vorgabe" belassen. Dadurch wird eine anwendungsübergreifende Kompatibilität gewährleistet. Dies ist besonders dann hilfreich, wenn Sie häufig in Dokumente eingebettete OLE-Objekte bearbeiten.


Grundlagen in FrameMaker / Arbeitsbereich / Bestandteile des FrameMaker-Arbeitsbereichs

Ändern der Standardmaßeinheiten

Einige Textfelder in Dialogfenstern erfordern eine Maßeinheit für den eingegebenen Wert, z. B. Punkt oder Zentimeter. Sie können eine Standardmaßeinheit für den Schriftgrad und den Zeilenabstand (Maßeinheit für den Schriftgrad) sowie für weitere Einheiten (Maßeinheiten für die Anzeige) festlegen. Die Standardmaßeinheit wird in Textfeldern rechts neben dem Wert angezeigt. Wenn Sie einen Wert ohne Maßeinheit eingeben, verwendet FrameMaker die Standardmaßeinheit.

So ändern Sie die Standardmaßeinheit:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Optionen".

    3. Geben Sie unter "Maßeinheit" und "Schriftgrade" eine Maßeinheit an und klicken Sie auf "Zuweisen".

So geben Sie andere Einheiten in ein Textfeld ein:

Geben Sie nach dem numerischen Wert eine der folgenden Abkürzungen für die gewünschte Maßeinheit ein:

    cm für Zentimeter

    mm für Millimeter

    " oder in für Zoll

    pc, pi oder pica für Pica

    pt oder point für Punkt

    dd für Didot

    cc oder cicero für Cicero

    Q für Q-Einheiten (bezieht sich nur auf Schriftgrad und Zeilenabstand ausschließlich für Japanisch)

Sobald Sie auf ein Befehlsfeld im Dialogfenster klicken, konvertiert FrameMaker den eingegebenen Wert in die Standardmaßeinheit.

Wenn beispielsweise die Standardmaßeinheit für Ihr Dokument "Pica" ist, und Sie einen Absatzeinzug von 2 cm festlegen wollen, geben Sie in das Textfeld für den ersten Einzug 2 cm ein. Sobald Sie auf "Zuweisen" klicken, wird der eingegebene Wert (2 cm) in den entsprechenden Pica-Wert umgerechnet.


Grundlagen in FrameMaker / Arbeitsbereich / Bestandteile des FrameMaker-Arbeitsbereichs

Ein- und Ausblenden der visuellen Hilfsmittel

Sie können verschiedene visuelle Hilfsmittel im Dokumentfenster ein- oder ausblenden. Die folgenden Hilfsmittel stehen Ihnen zur Verfügung:

    Begrenzungslinien um Textrahmen, Grafikrahmen und importierte Objekte

    Marken, Absatzende-Zeichen und andere Steuerzeichen im Textfluss

    Lineale am oberen und linken Rand des Fensters

Darüber hinaus können Sie ein Raster aus horizontalen und vertikalen Linien für das Zeichnen, Skalieren und Ausrichten von Grafiken einblenden. Weitere Informationen zu Raster finden Sie unter Verwenden von Rastern.

Die visuellen Hilfsmittel sind keine druckbaren Zeichen, daher ist es nicht erforderlich, diese vor dem Drucken auszublenden.

So blenden Sie optische Hilfsmittel ein oder aus:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Führen Sie folgende Schritte durch:

    Wählen Sie "Darstellung > Begrenzungslinien". (Wenn das Buchfenster aktiv ist, wählen Sie "Darstellung > Begrenzungslinien einblenden" bzw. "Darstellung > Begrenzungslinien ausblenden".)

    Um die Steuerzeichen ein- oder auszublenden, wählen Sie "Darstellung > Steuerzeichen". Folgende Steuerzeichen können in einem Dokumentfenster sichtbar sein:

    Um die Lineale ein- oder auszublenden, wählen Sie "Darstellung > Lineale".

    Steuerzeichen | Bedeutung
 | Absatzende
 | Textflussende und Zellenende in Tabellen
 | Tabulator
 | Verankerter Rahmen und Tabellenanker
 | Marke
 | Erzwungenes Zeilenende
 | Manueller Ausrichtungspunkt für eine Gleichung
 | Umbruchgeschütztes Leerzeichen
 | Wahlweiser Trennstrich
 | Trennunterdrückung

So ändern Sie die Raster- und Linealeinteilung:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Optionen".

    3. Wählen Sie eine neue Einstellung aus dem Aufklappmenü "Lineale" bzw. "Rasterlinien" und klicken Sie auf "Zuweisen".


Grundlagen in FrameMaker / Arbeitsbereich / Bestandteile des FrameMaker-Arbeitsbereichs

Ändern des Menübefehlssatzes

Sie können mit einem begrenzten Satz von Menübefehlen, so genannten Kurzmenüs, arbeiten. Kurzmenüs enthalten keine Befehle für Textformatierung, weiterhin fehlen einige Befehle für die Grafikbearbeitung und das Einfügen bestimmter Objekte wie z. B. Marken und Variablen.

Falls nicht alle der hier beschriebenen Menübefehle angezeigt werden, haben Sie eventuell die Kurzmenüs aktiviert.

Hinweis: Wenn Sie ein strukturiertes Dokument verwenden, hat Ihr Anwendungsentwickler unter Umständen die in den vollständigen Menüs verfügbaren Befehle geändert.

So zeigen Sie Kurzmenüs an:

    Wählen Sie "Darstellung > Menüs > Kurzmenüs".

So zeigen Sie wieder vollständige Menüs an:

    Wählen Sie "Darstellung > Menüs > Vollmenüs".

So passen Sie Menüs an Ihre Anforderungen an:

Weitere Informationen zum Hinzufügen, Verschieben und Entfernen von Menüs oder Befehlen finden Sie im Online-Handbuch Anpassen von FrameMaker-Produkten. Das Handbuch ist unter folgender Adobe-Website verfügbar: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.


Grundlagen in FrameMaker / Arbeitsbereich

Optionen zur Dateidarstellung

FrameMaker bietet eine neue Option, mit der Sie den Dateinamen im Titel des Dokumentfenster-Rahmens vor dem Pfad anzeigen lassen können. Dadurch ist der Dateiname auch bei einem langen Pfad immer sichtbar.

    Unter Windows enthält die Initialisierungsdatei maker.iniein neues Flag mit dem Namen DisplayFileLeafFirst. Wenn dessen Wert On ist, wird der Dateiname im Titel des Dokumenten- oder Buchfensters im Format Dateiname Pfadname angezeigt. Dieses Format wird auch für die Anzeige des Dateinamens im Dialogfenster mit allen geöffneten Dateien verwendet.
    Der Standardwert ist Off, die Zeile ist als Kommentar gekennzeichnet und der Dateiname wird wie bisher im Format Pfadname Dateiname angezeigt.

    Unter UNIX gibt es eine neue boolesche xresource mit dem Namen Maker.displayFileLeafFirst. Wenn deren Wert True ist, wird der Dateiname im Titel des Dokumenten- oder Buchfensters im Format Dateiname Pfadname angezeigt.
    Der Standardwert ist False und der Dateiname wird wie bisher im Format Pfadname Dateiname angezeigt.

Das Flag wirkt sich nicht darauf aus, wie der Stammname des Ordner- oder Verzeichnisbaums in einzelnen Dateinamen im Buchfenster angezeigt wird.


Grundlagen in FrameMaker / Arbeitsbereich

Blättern durch Dokumente im Dokumentfenster

Sie können Dokumente mithilfe der Steuerelemente in der Statuszeile durchblättern.

A: Symbol "Vorherige Seite" B. Symbol "Nächste Seite"

Darüber hinaus können Sie festlegen, wie FrameMaker die Seiten abrollt – von oben nach unten, von links nach rechts oder zwei Seiten gleichzeitig.

Wenn das Dokument, das Sie durchblättern, zu einem geöffneten Buch gehört, werden Sie von FrameMaker möglicherweise in einer Meldung gefragt, ob Sie das nächste oder vorherige Dokument im Buch öffnen wollen. Wenn Sie beispielsweise auf der ersten Seite eines Dokuments auf das Symbol "Vorherige Seite" klicken und im Meldungsfenster "Ja" wählen, wird das vorherige Dokument im Buch geöffnet. Die letzte Seite dieses Dokuments wird angezeigt.

So wechseln Sie zu einer anderen Seite:

Führen Sie eine der folgenden Aktionen aus:

    Um zur nächsten Seite zu gelangen, klicken Sie auf das Symbol "Nächste Seite".

    Um zur vorherigen Seite zu gelangen, klicken Sie auf das Symbol "Vorherige Seite".

    Um zur ersten Seite im Dokument zu gelangen, halten Sie die Umschalttaste gedrückt und klicken Sie auf das Symbol "Vorherige Seite".

    Um zur letzten Seite im Dokument zu gelangen, halten Sie die Umschalttaste gedrückt und klicken Sie auf das Symbol "Nächste Seite".

    Um zu einer bestimmten Seite oder einer Seite mit einer bestimmten Zeilennummer zu wechseln, klicken Sie in den Seitenstatus-Bereich, geben Sie die gewünschte Seite oder eine Zeilennummer ein und klicken Sie auf "Wechseln".

    Um zu der Seite mit der Einfügemarke zu gelangen, klicken Sie in den Seitenstatus-Bereich, dann auf "Seite mit Einfügemarke" und schließlich auf "Wechseln".

    Um schnell einen Überblick über die Seiten zu bekommen, durchblättern Sie das Dokument von oben nach unten.

Sie können auch in die Strukturansicht klicken oder dort eine Auswahl treffen, um die entsprechende Seite im Dokumentfenster anzuzeigen. Auf diese Weise gelangen Sie oft am schnellsten auf die gewünschte Seite. Weitere Informationen zur Strukturansicht finden Sie unter Strukturansichtsfenster.

So stellen Sie ein, wie Seiten durchblättert werden:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Optionen".

    3. Wählen Sie eine der folgenden Optionen aus dem Aufklappmenü "Blättern":

    Um Seiten von oben nach unten zu durchblättern (z. B. Seite 2 unter Seite 1), wählen Sie "Vertikal".

    Um Seiten von links nach rechts zu durchblättern (z. B. Seite 2 rechts neben Seite 1), wählen Sie "Horizontal".

    Um zwei nebeneinander liegende Seiten gleichzeitig abzurollen, wählen Sie "Gegenüberliegende Seiten".

    Um so viele Seiten abzurollen, wie von links nach rechts in das Fenster passen, wählen Sie "Variabel".

    4. Klicken Sie auf "Zuweisen".

So beschleunigen Sie die Seitenanzeige:

Führen Sie folgende Schritte durch:

    Öffnen Sie das Dokument und unterdrücken Sie dabei die Aktualisierung von importierten Grafiken, Querverweisen und Texteinschüben. (Wenn Sie ein Dokument ohne Aktualisierung von Querverweisen öffnen, beschleunigt dies den Öffnungsvorgang, kann aber die Anzeige der einzelnen Seiten verlangsamen.) Weitere Informationen finden Sie unter Öffnen von Dokumenten ohne Aktualisieren der Querverweise.

    Schalten Sie die Anzeige von Grafiken aus, indem Sie "Darstellung > Optionen" wählen, die Option "Grafiken" deaktivieren und auf "Zuweisen" klicken. Die Grafiken erscheinen dann auch nicht im Ausdruck.

    Stellen Sie Text in kleinem Schriftgrad als graue Balken dar, indem Sie "Datei > Voreinstellungen > Allgemein" wählen, einen Wert in das Textfeld "Text wird stilisiert, wenn kleiner als" eingeben und auf "Zuweisen" klicken. Wenn Text in Ihrem Dokument kleiner als in der hier festgelegten Größe angezeigt wird, erscheint dieser Text als grauer Balken am Bildschirm.


Grundlagen in FrameMaker / Arbeitsbereich

Verwendung der Kurzbefehle

Sie können folgende Kurzbefehle in einem strukturierten oder unstrukturierten Dokument verwenden:

    Tastaturbefehle für alle Befehle (Eine Liste dieser Kurzbefehle finden Sie in der Online-Hilfe.)

    Die QuickAccess-Leiste enthält verschiedene Befehle für das Arbeiten mit Dokumenten und die Bearbeitung von Text, Grafiken und Tabellen.

    Die Formatierungsleiste, welche Befehle zum Formatieren von Text enthält

    Die Leiste zum Verfolgen von Textänderungen, welche Befehlen zum Verfolgen, Annehmen und Ablehnen von Textänderungen enthält

    Kontextsensitive Aufklappmenüs mit Befehlen, die an der aktuellen Zeigerposition hilfreich sind.

Wichtig: Bei der Verwendung von strukturierten Dokumenten sollten Sie beachten, dass Kurzbefehle Ihre Dokumentstruktur auf die gleiche Weise beeinflussen wie die entsprechenden Menübefehle. Wenn Sie z. B. ein Element über ein Kontextmenü einfügen, ist das Element an der neuen Position eventuell nicht gültig. Wenn Sie mit einem QuickAccess-Befehl Text kursiv formatieren, werden eventuell die Formatregeln eines Elements überschrieben.

Sie haben die Möglichkeit, mehrere Dokumente in verschiedenen Registerkarten anzuzeigen. Wenn Sie im Menü "Darstellung" die Option "Leiste mit Registerkarten" wählen, werden Registerkarten für die offenen FrameMaker-Dokumentfenster angezeigt.

FrameMaker enthält auch eine Formatierungsleiste, um den Zeilenabstand und die Ausrichtung von Absätzen sowie deren Tabulatorstopps rasch zu ändern. Sie sollten die Formatierungsleiste nur in unstrukturierten Dokumenten verwenden, da diese Eigenschaften in strukturierten Dokumenten in der Regel durch Elemente vorgegeben sind. Weitere Informationen finden Sie unter Ändern von Text ohne Verwendung der Kataloge.

Hinweis: Wenn Sie Text auswählen, dem unterschiedliche Schrifttypen, -größen und Absatztypen zugewiesen wurden, werden in den Menüs "Absatzformat", "Schriftartname" und "Schriftgröße" der Formatierungsleiste leere Einträge angezeigt. Wenn Sie beispielsweise Text auswählen, der die Schriftgrößen 12 und 14 enthält, wird im Menü "Schriftgröße" ein leerer Eintrag angezeigt.

Verwendung der QuickAccess-Leiste

Sie können die QuickAccess-Leiste im Arbeitsbereich eingeblendet lassen und auf Befehle klicken, wenn Sie diese benötigen. Eine Liste der verfügbaren Befehle finden Sie in der Schnellreferenzkarte.

So zeigen Sie die QuickAccess-Leiste an:

    Wählen Sie "Darstellung > QuickAccess-Leiste".

So verwenden Sie die QuickAccess-Leiste:

Führen Sie einen der folgenden Schritte aus:

    Um einen Befehl aus der Leiste auszuwählen, klicken Sie auf das entsprechende Symbol.

    Um eine andere Befehlsgruppe zu wählen, klicken Sie auf die Leiste.

    Um zwischen vertikaler oder horizontaler Ausrichtung zu wechseln, klicken Sie auf die Leiste.

    Um Hilfe zu den Befehlen aufzurufen, klicken Sie auf die Leiste.

So schließen Sie die QuickAccess-Leiste:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Wählen Sie "Darstellung > QuickAccess-Leiste".

    (UNIX) Platzieren Sie den Mauszeiger auf der Leiste und drücken Sie Control+c.

Verwendung von Kontextmenüs

Die Kontextmenüs enthalten Befehle für das Objekt unter dem Zeiger, z. B. Text, eine Grafik, ausgewählte Zellen einer Tabelle oder das komplette Dokument (wenn sich der Zeiger auf dem Rand befindet).

So öffnen Sie ein Kontextmenü:

    Klicken Sie mit der rechten Maustaste.


Grundlagen in FrameMaker

Strukturierter Arbeitsbereich

Strukturierter Arbeitsbereich

Strukturansichtsfenster

Elementkatalog von strukturierten Dokumenten

Anpassen der Anzeige des strukturierten Arbeitsbereichs


Grundlagen in FrameMaker

Strukturierter Arbeitsbereich

Beim Arbeiten mit strukturierten Dokumenten verwenden Sie das Dokumentfenster und das Fenster "Strukturansicht" mit dem Elementkatalog. In diesen Fenstern können Elemente in einer gültigen Struktur angeordnet werden.

Inhalts- und Strukturinformationen

Um den strukturierten Arbeitsbereich verwenden zu können, müssen Sie sich in der strukturierten FrameMaker-Benutzeroberfläche befinden. Weitere Informationen zum Arbeiten im strukturierten Modus von FrameMaker finden Sie unter Arbeitsbereich.


Grundlagen in FrameMaker / Strukturierter Arbeitsbereich

Strukturansichtsfenster

Die Strukturansicht zeigt eine Elementhierarchie des Dokuments (oder des Textflusses innerhalb eines Dokuments) an, in dem sich die Einfügemarke oder die Auswahl befindet. In der Strukturansicht werden abgerundete Rechtecke zur Darstellung von Elementen und deren Beziehungen zueinander verwendet. Außerdem zeigt sie Fehler innerhalb der Dokumentstruktur an. In der Strukturansicht können Sie auch Attribute einblenden.

Das Dokumentfenster und die Strukturansicht können bearbeitet werden und spiegeln jeweils die im anderen Fenster vorgenommenen Änderungen wider. Sie können beide Ansichten nebeneinander öffnen, um sowohl den Inhalt als auch die Struktur verfolgen zu können. Wenn Sie in eine Ansicht klicken oder in einer Ansicht auswählen, wird in der anderen Ansicht an der entsprechenden Stelle eine Einfügemarke oder eine Auswahl angezeigt. Jegliche Änderungen spiegeln sich ebenfalls in der jeweils anderen Ansicht wider. Wenn Sie in einen unstrukturierten Textfluss in einem Dokumentfenster klicken oder darin eine Auswahl treffen, bleibt die Strukturansicht leer.

Hinweis: Bei Verwendung des UNIX-Fenstersystems OpenWindows kann die Fenstergröße der Strukturansicht nur geändert werden, wenn die Pushpin-Funktion aktiviert ist.

So zeigen Sie die Strukturansicht an:

    Klicken Sie auf das Symbol "Strukturansicht" in der oberen rechten Ecke des Dokumentfensters.

Die Bearbeitung von Text und anderen Inhalten erfolgt dann im Dokumentfenster. Sie können die Struktur eines Dokuments in beiden Darstellungen bearbeiten. In der Regel ist es jedoch einfacher, die Änderungen in der Strukturansicht vorzunehmen, da Sie hier die Elemente durch Ziehen und Ablegen der Rechtecke verschieben oder durch Auswählen anderweitig bearbeiten können.


Grundlagen in FrameMaker / Strukturierter Arbeitsbereich

Elementkatalog von strukturierten Dokumenten

Der Elementkatalog von strukturierten Dokumenten enthält eine Auflistung der an dieser Position gültigen Elemente und stellt Befehle zum Hinzufügen und Bearbeiten von Elementen bereit. Gegebenenfalls werden darin weitere Informationen zur aktuellen Position angezeigt, z. B. ob Text eingegeben werden kann.

Elementkatalog

So zeigen Sie den Elementkatalog an:

    Klicken Sie auf das Symbol "Elementkatalog" rechts oben im Dokumentfenster.

Die im Elementkatalog angezeigten Informationen beruhen auf den Inhaltsregeln in der Definition für das aktuelle Element, d. h. das Element, das die Einfügemarke oder Auswahl enthält. Die aktuelle Position ist die Position der Einfügemarke oder der Auswahl in diesem Element.

Der Elementkatalog ist anfänglich so voreingestellt, dass nur die für die aktuelle Position gültigen Elemente angezeigt werden. Sie können jedoch auch weitere Elemente anzeigen lassen, falls Sie mehr Flexibilität wünschen (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument).

Der Katalog ist leer, wenn Sie in einen unstrukturierten Textfluss klicken bzw. darin eine Auswahl treffen, wenn das Dokument keine Elementdefinitionen enthält, oder wenn an der aktuellen Position keine weiteren Elemente mehr erforderlich sind und keine optionalen Elemente verfügbar sind.

Der Elementkatalog verwendet die folgenden Symbole zur Kennzeichnung gültiger Elemente:

Dunkles Häkchen

Das Element ist an der aktuellen Position gültig. Das aktuelle (übergeordnete) Element bleibt bis zu dieser Position korrekt und vollständig, wenn Sie ein Element einfügen.

Pluszeichen (+)

Das Element ist ein Einschluss (nur SGML) im aktuellen Element und ist an der aktuellen Position gültig. Das Pluszeichen erscheint immer neben einem dunklen Häkchen. Einschlüsse sind nur in SGML-Dokumenten gültig und werden nicht in XML-Dokumenten angezeigt.

Obwohl Einschlüsse ebenso gültig sind wie die nur mit einem dunklen Häkchen gekennzeichneten Elemente, kann es unter Umständen günstiger sein, die Einschlüsse separat aufzulisten (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument). Wenn ein Dokument viele Einschlüsse hat, wird unter Umständen das Auffinden von anderen gültigen Elementen im Katalog erschwert.

Fragezeichen (?)

Das Element ist ein möglicher Ersatz für das Element direkt nach der Einfügemarke oder für die ausgewählten Elemente. Es ist an der aktuellen Position gültig, die ihm untergeordneten Elemente werden jedoch ungültig. Wenn Sie ein Element mit einem Fragezeichen einfügen, bleibt das aktuelle (übergeordnete) Element bis zu dieser Position vollständig und korrekt. Sie müssen jedoch Fehler nach dem neuen Element berichtigen.

Helles Häkchen

Das Element ist später im aktuellen Element gültig. Wenn Sie eines dieser Elemente einfügen, bleibt das aktuelle (übergeordnete) Element bis zu dieser Position zwar korrekt, wird jedoch unvollständig. Sie müssen zurückgehen und die fehlenden untergeordneten Elemente einfügen.

Kein Symbol

Wenn ein Element in einem Katalog kein Symbol aufweist, ist es an der aktuellen Position bzw. später im aktuellen Element nicht gültig. Es kann jedoch früher im aktuellen Element oder außerhalb des Elements gültig sein.

Überdies kann der Elementkatalog die folgenden Indikatoren enthalten, die weitere Informationen zur aktuellen Position bereitstellen:

<TEXT>

An dieser Stelle können Sie Text eingeben.

<NICHT DEFINIERT>

Das aktuelle Element ist im Dokument nicht definiert. Das Element wurde vermutlich aus einem Dokument mit anderen Elementdefinitionen kopiert. (Dieser Eintrag erscheint nicht, wenn der Katalog so eingestellt ist, dass alle Elemente angezeigt werden.)

<UNGÜLTIG>

Die Inhalte des aktuellen Elements sind ungültig. (Dieser Eintrag erscheint nicht, wenn der Katalog so eingestellt ist, dass alle Elemente angezeigt werden.)

Mithilfe der Optionen im Elementkatalog können Sie ein leeres Element einfügen, Inhalte in ein Element eingliedern und den Typ eines vorhandenen Elements ändern. Weitere Informationen zur Verwendung des Katalogs finden Sie unter Erläuterung von Elementen.


Grundlagen in FrameMaker / Strukturierter Arbeitsbereich

Anpassen der Anzeige des strukturierten Arbeitsbereichs

Sie können das Aussehen des FrameMaker-Arbeitsbereichs individuell anpassen, indem Sie in einem Dokumentfenster Elementgrenzen und andere Hilfsmittel einblenden, in der Strukturansicht die Attribute neuer Elemente einblenden und den Befehlssatz in der Menüleiste ändern.


Grundlagen in FrameMaker / Strukturierter Arbeitsbereich / Anpassen der Anzeige des strukturierten Arbeitsbereichs

Aus- und Einblenden von Elementen

Sie können ein Element und dessen nachfolgende Elemente in der Strukturansicht in einem einzigen Stapel darstellen. Dies hat keine Auswirkungen auf die Platzierung der Einfügemarke, die Elementinhalte oder die Art der Darstellung der Elemente im Dokumentfenster.

Ausgeblendete Elemente

Das Einblenden von Elementen bewirkt, dass alle Rechtecke erneut angezeigt werden.

Eingeblendete Elemente

Durch das Ausblenden von Elementen erhalten Sie einen besseren Überblick über die Dokumentstruktur und können die Elemente leichter verschieben. Es kann besonders hilfreich sein, lange Elementlisten und komplexe Prozeduren auszublenden.

Wenn ein Element untergeordnete Elemente aufweist, erscheint auf der rechten Seite des Elementrechtecks ein Plus- oder Minuszeichen:

    Ein Pluszeichen (+) wird angezeigt, wenn das Element als Stapel dargestellt ist, um darauf hinzuweisen, dass weitere Elementrechtecke ausgeblendet sind. Das Pluszeichen ist rot, wenn sich an einer Stelle im Element ungültiger Inhalt befindet.

    Ein Minuszeichen (-) wird angezeigt, wenn das Element eingeblendet ist.

So wird ein Element ein- oder ausgeblendet:

    Klicken Sie auf das Minuszeichen bzw. Pluszeichen links im Elementrechteck.

So blenden Sie ein Element mit seinen gleichrangigen Elementen ein oder aus:

    Halten Sie die Umschalttaste gedrückt und klicken Sie auf das Minuszeichen bzw. Pluszeichen links im Elementrechteck.


Grundlagen in FrameMaker / Strukturierter Arbeitsbereich / Anpassen der Anzeige des strukturierten Arbeitsbereichs

Ein- und Ausblenden von Attributen für ein Element

Ein Element kann Attribute aufweisen, die zusätzliche Informationen zum Element liefern. So kann ein Attribut zum Beispiel angeben, um welche Entwurfsversion es sich bei einem Element "Kapitel" handelt. Oder ein Attribut kann angeben, welche Vertraulichkeitsstufe eine Notiz hat. Weitere Informationen zur Verwendung von Attributen finden Sie unter Attribute für Elemente.

Es können alle Attribute eines Elements angezeigt werden, keine Attribute oder nur diejenigen Attribute, die erforderlich sind oder einen Wert aufweisen. Außerdem können Sie Attribute für alle neu in das Dokument eingefügten Elemente ein- oder ausblenden (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument).

Wenn ein Element Attribute aufweist, erscheint auf der rechten Seite des Elementrechtecks ein Plus- oder Minuszeichen:

    Ein Pluszeichen (+) wird angezeigt, wenn einige oder alle Attribute ausgeblendet sind, um darauf hinzuweisen, dass weitere Attribute angezeigt werden können.

    Ein Minuszeichen (-) wird angezeigt, wenn alle Attribute eingeblendet sind.

So blenden Sie Attribute für ein Element ein oder aus:

    Klicken Sie auf das Pluszeichen oder Minuszeichen auf der rechten Seite des Elementrechtecks.

Dadurch ergeben sich drei mögliche Ansichten. Durch Klicken auf ein Minuszeichen werden die Attribute ausgeblendet. Falls keine Attribute eingeblendet sind, werden durch Klicken auf das Pluszeichen Attribute angezeigt, die erforderlich sind oder einen Wert aufweisen. Falls einige Attribute bereits eingeblendet sind, werden durch Klicken auf das Pluszeichen alle Attribute angezeigt.

Klicken Sie auf das Minuszeichen rechts des Elements, um die Attribute auszublenden. Das Minuszeichen wird dadurch zu einem Pluszeichen. Klicken Sie auf das Pluszeichen, um die erforderlichen Attribute bzw. solche, die ein Attribut haben, einzublenden. Das Pluszeichen wird wieder zu einem Minuszeichen. Klicken Sie erneut auf das Minuszeichen, um alle Attribute einzublenden.

So blenden Sie Attribute für ein Element und alle gleichrangigen Elemente ein oder aus:

    Halten Sie die Umschalttaste gedrückt und klicken Sie auf das Pluszeichen oder Minuszeichen auf der rechten Seite des Elementrechtecks.


Grundlagen in FrameMaker / Strukturierter Arbeitsbereich / Anpassen der Anzeige des strukturierten Arbeitsbereichs

Ein- und Ausblenden von Elementgrenzen

Elementgrenzen markieren Anfang und Ende von einzelnen Elementen in einem Dokumentfenster. Es bietet sich an, mit eingeblendeten Elementgrenzen zu arbeiten. Dadurch sehen Sie nicht nur, wie die Inhalte eines Dokuments in dessen Elemente passen, sondern es erleichtert Ihnen auch, die Einfügemarke korrekt zu platzieren oder die richtige Auswahl zu treffen.

Meistens werden die Elementgrenzen als öffnende bzw. schließende eckige Klammern ([ ]) oder als zwei Felder mit einem Element-Tag angezeigt. Bei einigen Elementen (Grafik, Fußnoten, Tabellen und Gleichungen) kann die Elementposition jedoch nur durch ein Feld mit einem Element-Tag angezeigt werden. Tabellenteile wie Tabellentitel und Zellen zeigen selbst keine Elementgrenzen an. Dennoch werden Elementgrenzen innerhalb von Tabellenteilen eingeblendet.

Die Klammern und Tags von Elementen innerhalb anderer Elemente sind verschachtelt und zeigen so die Hierarchie an.

Hinweis: Die Klammern und Tags, die Elementgrenzen markieren, werden ausgedruckt und belegen Platz im Dokument. Es empfiehlt sich, diese Zeichen vor dem Drucken auszublenden, damit sie nicht ausgedruckt werden und das Dokumentlayout nicht durch die Elementgrenzen geändert wird.

So blenden Sie Elementgrenzen-Klammern ein oder aus:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Elementgrenzen". (Wenn das Buchfenster aktiv ist, wählen Sie "Darstellung > Elementgrenzen einblenden" bzw. "Darstellung > Elementgrenzen ausblenden".)

Die meisten Elementtypen weisen eine Startklammer ([) und eine Endeklammer (]) auf.

A: Abschnittelement B: Überschriftelement C: Absatzelement

So blenden Sie Elementgrenzen-Tags ein oder aus:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Elementgrenzen (mit Tags)". (Wenn das Buchfenster aktiv ist, wählen Sie "Darstellung > Elementgrenzen (mit Tags) einblenden" bzw. "Darstellung > Elementgrenzen (mit Tags) ausblenden".)

Die meisten Elementtypen weisen ein öffnendes und ein schließendes Begrenzungs-Tag auf. Einige Elemente wie Fußnoten haben kein Begrenzungs-Tag. Sie werden als einzelnes Tag angezeigt.

Tag-Elementgrenzen


Grundlagen in FrameMaker / Strukturierter Arbeitsbereich / Anpassen der Anzeige des strukturierten Arbeitsbereichs

Ein- und Ausblenden von Attributen für neue Elemente

Sie können die Attribute für ein neues Element in der Strukturansicht ein- oder ausblenden. Es können alle Attribute im Textfluss angezeigt werden, keine Attribute oder nur diejenigen Attribute, die erforderlich sind oder einen Wert aufweisen. Diese Einstellung gilt für neue Elemente, sobald sie eingegeben sind.

Darüber hinaus können Sie auch Attribute für ein bestimmtes Element ein- oder ausblenden (siehe Ein- und Ausblenden der visuellen Hilfsmittel).

So blenden Sie Attribute für neue Elemente ein oder aus:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Attributanzeige-Optionen", aktivieren Sie die gewünschte Option und klicken Sie auf "Zuweisen".


Grundlagen in FrameMaker / Strukturierter Arbeitsbereich / Anpassen der Anzeige des strukturierten Arbeitsbereichs

Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument

Wenn Sie Elemente einem strukturierten Dokument hinzufügen, möchten Sie vielleicht nur die Elemente einfügen, die an der aktuellen Position gültig sind. (Dies sind Elemente, die dunkle Häkchen, Fragezeichen und dunkle Häkchen mit Pluszeichen im Elementkatalog aufweisen.) Wenn Sie Elemente auf diese Weise hinzufügen, können Sie das Dokument von Anfang bis Ende bearbeiten und dabei sicher sein, dass die Struktur jederzeit gültig ist.

Vielleicht möchten Sie jedoch in manchen Fällen über mehr Elemente verfügen können. Für einige Dokumententwürfe etwa ist es ausreichend, die Struktur als Richtlinie zu verwenden, ohne eine vordefinierte Struktur streng einhalten zu müssen. In einem anderen Fall soll die Dokumentstruktur zwar berücksichtigt werden, doch verfügen Sie noch nicht über alle nötigen Informationen, um das Dokument komplett fertig zu stellen.

Die zusätzlich verfügbaren Elemente werden im Elementkatalog angezeigt und können über die Tastatur eingefügt werden. Sie können auch Einschlüsse nach anderen gültigen Elementen im Katalog auflisten.

Der Elementkatalog verwendet Symbole zur Kennzeichnung gültiger Elemente (siehe Elementkatalog von strukturierten Dokumenten). Wenn ungültige Elemente angezeigt werden, können Sie diese Symbole als Vorschlag für den Aufbau einer gültigen Struktur verwenden.

So ändern Sie den Anzeigebereich für verfügbare Elemente:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Element > Katalogeinstellungen". Wahlweise können Sie auch auf "Optionen" im Elementkatalog klicken.

    3. Wählen Sie unter "Anzeigen" eine der folgenden Optionen:

    Um nur Elemente anzuzeigen, die an der aktuellen Position gültig sind, wählen Sie "Gültige nachgeordnete Elemente (Standardreihenfolge)". Mit dieser Option können Sie ein Dokument komplett fertigstellen und Elemente in der richtigen Reihenfolge und Hierarchie einfügen.

    Um Elemente anzuzeigen, die an der aktuellen Position oder später im aktuellen Element gültig sind, wählen Sie "Gültige nachgeordnete Elemente (beliebige Reihenfolge)". Verwenden Sie diese Einstellung, wenn Sie ein gültiges Dokument aufbauen, jedoch nicht komplett fertigstellen möchten. Diese Einstellung empfiehlt sich besonders, wenn Sie nicht alle erforderlichen Informationen haben.

    Um Elemente anzuzeigen, die überall im aktuellen Element gültig sind, wählen Sie "Alle zugelassenen nachgeordneten Elemente". Diese Einstellung ermöglicht mehr Flexibilität beim Einfügen von Elementen. Sie können ungültige Elemente einfügen und die Fehler später berichtigen.

    Um alle für das Dokument definierten Elemente anzuzeigen, wählen Sie "Alle Elemente". Verwenden Sie diese Einstellung, wenn Sie kein gültiges Dokument erstellen, wenn Sie Flexibilität benötigen und Fehler später korrigieren, wenn Sie Inhalte in Elemente eingliedern oder wenn Sie sehen möchten, was an anderen Stellen im Dokument verfügbar ist.

    Um nur bestimmte, von Ihnen festgelegte Elemente anzuzeigen, wählen Sie "Spezielle Liste". Verwenden Sie diese Einstellung, um nur mit einem Teil der verfügbaren Elemente zu arbeiten, um Elemente in einer festen Reihenfolge anzuzeigen oder um mit einer statischen statt einer kontextsensitiven Liste zu arbeiten.

    4. Wenn Sie "Spezielle Liste" gewählt haben, klicken Sie auf "Bearbeiten" und erstellen bzw. ändern Sie eine Elementliste.

Um Element-Tags zwischen den Listen "Einblenden" und "Nicht einblenden" zu verschieben, klicken Sie auf die Pfeile oder doppelklicken Sie auf die Element-Tags. Wenn Sie alle Elemente von einer Liste in die andere verschieben möchten, halten Sie die Umschalttaste gedrückt und klicken Sie auf einen Pfeil. Klicken Sie auf "Nach oben" und "Nach unten", um die Elemente in der Liste "Einblenden" in der Reihenfolge anzuordnen, in der sie im Elementkatalog erscheinen sollen. Klicken Sie auf "Zuweisen", wenn die Liste Ihren Vorstellungen entspricht.

Hinweis: Eine angepasste Tag-Liste bleibt stets gleich, unabhängig davon, an welcher Position sich die Einfügemarke befindet. Daher sollten Sie genau überlegen, welche Tags Sie in die Liste aufnehmen. Der einzige Hinweis auf Gültigkeit ist ein Häkchen neben einem Tag.

    5. Um Einschlüsse im Elementkatalog getrennt aufzulisten, aktivieren Sie "Nach anderen gültigen Elementen auflisten".

Dadurch werden die Einschlüsse direkt nach den anderen gültigen Elementen gruppiert. Diese Einstellung empfiehlt sich bei einer großen Anzahl von Einschlüssen, die selten benötigt werden.

    6. Klicken Sie auf "Zuweisen".


Grundlagen in FrameMaker

Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Erstellen von Dokumenten

Erstellen von Dokumenten auf der Basis von Schablonen

Erstellen von Dokumenten auf der Grundlage einer leeren Seite

Öffnen von Dokumenten

Beim Öffnen von Dokumenten ggf. angezeigte Meldungen und Dialogfenster

Sichern von Dokumenten

Hinzufügen von Metadaten zu einem Dokument

Drucken von Dokumenten

Arbeiten mit Dateien auf unterschiedlichen Plattformen

Schließen von Dokumenten


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Erstellen von Dokumenten

Sie können ein Dokument mithilfe einer Schablone erstellen, die das Aussehen des Dokuments definieren. Sie können aber auch ausgehend von einem leeren Dokument (entsprechend einem weißen Blatt Papier) beginnen. Beim Erstellen eines Dokuments wird ein Dokumentfenster angezeigt. Weitere Informationen zum Dokumentfenster finden Sie unter Dokumentfenster.

In FrameMaker können strukturierte und unstrukturierte Dokumente erstellt werden. Strukturierte Dokumente sind für das Arbeiten im SGML- und XML-Format erforderlich und unstrukturierte Dokumente sind nicht für den Export in das SGML- oder XML-Format eingerichtet. Weitere Informationen zur Arbeit mit strukturierten Dokumenten finden Sie unter Arbeiten mit strukturierten FrameMaker-Dokumenten.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Erstellen von Dokumenten auf der Basis von Schablonen

Schablonen bilden die Grundlage des FrameMaker-spezifischen Ansatzes für die Veröffentlichung von Dokumenten. Durch sie werden alle Aspekte des Erscheinungsbildes eines Dokuments gesteuert und alle zusammengehörigen Seiten oder Dokumente einheitlich gehalten. Im Lieferumfang von FrameMaker sind Standardschablonen für Briefe, Notizen, Berichte, Infoblätter, Gliederungen, Bücher und grafische Darstellungen enthalten. Sie können jedoch jedes beliebige Dokument als Schablone verwenden. Wenn ein Dokument Text und Grafiken enthält, löschen Sie diese Inhalte und fügen einfach Ihre eigenen ein.

So erstellen Sie ein Dokument auf der Grundlage einer Schablone:

    1. Wählen Sie "Datei > Neu > Dokument". Unter UNIX können Sie auch im FrameMaker-Hauptfenster auf "Neu" klicken.

    2. Navigieren Sie zu dem Dokument (Standard- oder eigenes Dokument), das Sie als Schablone verwenden möchten. Wenn Sie eine der Standardschablonen im FrameMaker-Ordner "schabl" bzw. "Schablonen" verwenden wollen, im Dialogfenster "Neu" jedoch der Inhalt eines anderen Ordners angezeigt wird, wechseln Sie in den Ordner "schabl" bzw. "Schablonen" an einer der folgenden Positionen:

    (Windows) Der Ordner "FrameMaker8".

    (UNIX) Das Verzeichnis "fminit/Sprache/Schablonen" im Installationsverzeichnis von FrameMaker. (Ersetzen Sie Sprache im angegebenen Pfad durch den Namen der verwendeten Sprache, beispielsweise "usenglish" oder "ukenglish").

    3. Wählen Sie eine Schablone aus und klicken Sie auf "Neu" (Windows) oder auf "Anlegen" (UNIX). Das neue, unbenannte Dokument enthält die Formatierungen und Inhalte der Schablone.

Um Informationen zu den Standardschablonen anzuzeigen, wählen Sie "Datei > Neu > Dokument", klicken Sie auf "Standardschablonen durchsuchen" und wählen Sie eine Schablone in der Auswahlliste aus. Nach dem Betrachten der Informationen können Sie auf "Anlegen" klicken, um auf der Grundlage der ausgewählten Schablone ein leeres Dokument zu erstellen, oder auf "Beispiel", um ein Dokument mit Beispieltext und -grafiken anzuzeigen.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Erstellen von Dokumenten auf der Grundlage einer leeren Seite

Wenn Ihnen keine der Standardschablonen oder vorhandenen Dateien als Vorlage zusagt, können Sie ein leeres Dokument verwenden. Für ein leeres Dokument sind nur wenige grundlegende Formatierungen festgelegt. Formatierungen können übernommen oder geändert sowie neu erstellt werden.

Sie können für das in FrameMaker verwendete Dokument Hochformat, Querformat oder ein Spezialformat festlegen. Weitere Informationen finden Sie unter Ändern von Schablonen für leeres Papier und Textdateien.

So erstellen Sie ein Dokument auf der Grundlage einer leeren Seite:

    1. Wählen Sie "Datei > Neu > Dokument". Unter UNIX können Sie auch im FrameMaker-Hauptfenster auf "Neu" klicken.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie ein einspaltiges Standarddokument erstellen wollen, klicken Sie auf "Hochformat" oder "Querformat".

    Wenn Sie Papierformat, Seitenränder und Spaltenanzahl für ein Dokument definieren wollen, klicken Sie auf "Spezial".

    3. Führen Sie anschließend die folgenden Aktionen aus und klicken Sie dann auf "Anlegen".

    Wählen Sie ein vordefiniertes Papierformat oder geben Sie die Breite und die Höhe für die Seiten ein.

    Geben Sie die Anzahl der Spalten und einen Abstand ein. Der Abstand ist der Zwischenraum zwischen den Spalten.

    Geben Sie die ab Seitenrand gemessenen Werte für die Ränder ein.

    Wählen Sie eine Seitenumbruchsoption aus. Wenn Sie "Doppelseitig" wählen, bestimmen Sie mit "1. Seite rechts" oder "1. Seite links" im Aufklappmenü, mit welcher Seite ein Dokument beginnt.

    Wählen Sie die Maßeinheiten für das Dokument aus. Maßeinheiten sind die Einheiten, die in FrameMaker zur Messung der Abstände im Dokument verwendet werden. Diese Maßeinheiten werden in Dialogfenstern und in der Statuszeile des Dokumentfensters angezeigt. Weitere Informationen hierzu finden Sie unter Ändern der Standardmaßeinheiten.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Öffnen von Dokumenten

Neben FrameMaker-Dokumenten können Sie Textdateien, MIF-Dateien (Maker Interchange Format), MML-Dateien (Maker Markup Language) und XML- und SGML-Dokumente im strukturierten FrameMaker öffnen. Darüber hinaus können auch in anderen Anwendungen, z. B. Microsoft Word, erstellte Dateien geöffnet werden, wenn der erforderliche Filter installiert wurde. Beim Öffnen der Datei bleiben die meisten Formatierungen erhalten. Weitere Informationen zu Filtern finden Sie im Online-Handbuch Verwenden von Filtern.

Beim Öffnen eines Dokuments wird ein Dokumentfenster angezeigt.

So öffnen Sie eine Datei:

    1. Wählen Sie "Datei > Öffnen". Unter UNIX können Sie auch im FrameMaker-Hauptfenster auf "Öffnen" klicken.

    2. Suchen Sie das zu öffnende Dokument und klicken Sie auf "Öffnen". Falls FrameMaker vor dem Öffnen eine Warnmeldung oder ein Dialogfenster anzeigt, lesen Sie Beim Öffnen von Dokumenten ggf. angezeigte Meldungen und Dialogfenster.

Beim Öffnen eines Dokuments werden normalerweise durch Referenz importierte Grafiken, Texteinschübe, Querverweise und Systemvariablen (falls vorhanden) aktualisiert. Weitere Informationen dazu, wie die automatische Aktualisierung von Querverweisen verhindert wird, finden Sie unter Öffnen von Dokumenten ohne Aktualisieren der Querverweise und Unterdrücken der automatischen Aktualisierung der Querverweise.

Sie können mithilfe von Jokerzeichen (bzw. regulären Ausdrücken in UNIX) im Textfeld "Dateityp" die Anzeige im Dialogfenster "Öffnen" auf bestimmte Dateien beschränken. Wenn Sie beispielsweise *.neu eingeben, werden alle Ordner oder Dokumente mit der Erweiterung .neu angezeigt. Wenn Sie Kapitel? eingeben, werden alle Ordner oder Dokumente angezeigt, deren Name aus Kapitel und genau einem weiteren Zeichen besteht. Geben Sie * in das Textfeld ein, um wieder den gesamten Inhalt des Ordners anzuzeigen.

So öffnen Sie ein zuletzt geöffnetes Dokument:

    1. Die fünf zuletzt geöffneten Dateien werden unten im Menü "Datei" angezeigt.

    2. Wählen Sie die entsprechende Datei aus.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Beim Öffnen von Dokumenten ggf. angezeigte Meldungen und Dialogfenster

Wenn eines der folgenden Meldungs- oder Dialogfenster angezeigt wird, müssen Sie auf "OK" klicken oder weitere Informationen eingeben, bevor die Datei geöffnet werden kann.

Fehlende Schriften oder Schriftmetrikdaten

Wenn Sie auf "OK" klicken, werden die fehlenden Schriften durch neue ersetzt. Das kann dazu führen, dass sich die Zeilen- und Seitenumbrüche sowie die Breite der Textzeilen ändern (siehe Fehlerbehebung bei nicht vorhandenen Schriften).

Fehlende importierte Grafiken

Übergehen Sie die fehlende Grafikdatei oder geben Sie ihre neue Verzeichnisposition an (siehe Ermitteln fehlender Grafiken).

Fehlende Texteinschübe

Klicken Sie auf "OK", um die Datei zu öffnen. Sie können die Einschübe zu einem späteren Zeitpunkt bearbeiten (siehe Ermitteln der Quelle von ungelösten Texteinschüben).

Textdatei

Geben Sie an, wie die Textzeilen zu Absätzen konvertiert werden sollen. Weitere Informationen finden Sie unter Öffnen von Textdateien.

Ungelöste Querverweise

Klicken Sie auf "OK", um die Datei zu öffnen. Sie können die Querverweise später auflösen (siehe Auflösen von Querverweisen).

Unbekannter Dateityp

Wählen Sie einen Dateityp aus der Liste und klicken Sie auf "Konvertieren", um mit dem Öffnen des Dokuments fortzufahren.

Fehlerbehebung bei nicht vorhandenen Schriften

Gegebenenfalls wird ein Meldungsfenster mit dem Hinweis angezeigt, dass in dem zu öffnenden Dokument nicht verfügbare Schriften verwendet werden. Wenn Schriften nicht zur Verfügung stehen, kann dies verschiedene Gründe haben: das Dokument wurde auf einem anderen System bearbeitet, das über Schriften verfügt, die auf dem aktuellen System nicht installiert sind; die Schriftart wurde entfernt oder beschädigt; der Standarddrucker für Ihr System wurde geändert.

Wenn die Option "Namen fehlender Schriften speichern" im Dialogfenster "Voreinstellungen" aktiviert wird, bleiben die Namen nicht verfügbarer Schriften erhalten. Die Originalschriften werden in diesem Fall dann wieder angezeigt (auch wenn Sie ein Dokument mit Ersatzschriften öffnen), wenn Sie das Dokument auf einem System öffnen, auf dem die fehlenden Schriften installiert sind.

Zur Fehlerbehebung bei fehlenden Schriften können Sie folgendermaßen vorgehen:

Überprüfen Sie, ob Schriften beschädigt sind.

Stellen Sie fest, ob die in FrameMaker fehlenden Schriften auf Ihrem System installiert und in einer anderen Anwendung verfügbar sind. Wenn eine andere Anwendung auf die Schriften zugreifen kann, sind sie ggf. beschädigt. Installieren Sie die Schriften mithilfe der Originalmedien neu. Weitere Informationen zur Fehlerbehebung bei Problemen mit Schriften, zur Isolierung beschädigter Schriften oder Schriften-Ordner oder zur Neuinstallation von Typ 1-Schriften finden Sie auf der Website von Adobe.

Ordnen Sie fehlende Schriften neu zu.

Wenn die fehlenden Schriften nicht installiert bzw. nicht erneut installiert werden können, haben Sie die Möglichkeit, diese Schriften verfügbaren Schriftarten zuzuordnen, so dass das Meldungsfenster beim Öffnen des Dokuments nicht wieder angezeigt wird. Dazu deaktivieren Sie vor dem Öffnen der Datei im Dialogfenster "Voreinstellungen" die Option "Namen fehlender Schriften speichern". Bei dieser Vorgehensweise müssen Sie jedoch beachten, dass alle Informationen zu Originalschriften verloren gehen, auf die im Dokument verwiesen wird.

Ändern Sie den Drucker (nur Windows)

FrameMaker liest die im Druckertreiber gespeicherten Schriftinformationen. Dadurch werden die im Drucker gespeicherten Schriften in FrameMaker verfügbar. In bestimmten Fällen kann die Änderung des Standarddruckers die Verfügbarkeit einer oder mehrerer Schriften in FrameMaker beeinflussen.

Besorgen und installieren Sie die fehlenden Schriften.

Wenn Sie z. B. dieselben Dokumente wie ein Kollege bearbeiten und dazu dieselben Schriften verwenden möchten, sollten Sie den Kauf und die Installation einer Kopie dieser Schriften in Betracht ziehen.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Beim Öffnen von Dokumenten ggf. angezeigte Meldungen und Dialogfenster

Öffnen von Textdateien

Nur-Text-Dateien enthalten keine Grafiken oder Formatinformationen. Beim Öffnen einer Nur-Text-Datei müssen Sie möglicherweise bestätigen, dass es sich um eine Textdatei handelt.

So öffnen Sie eine Textdatei:

    1. Wählen Sie "Datei > Öffnen" aus und öffnen Sie eine .txt-Datei (siehe Öffnen von Dokumenten). Das Dialogfenster "Unbekannter Dateityp" wird angezeigt.

    2. Wählen Sie die Option "Text".

    3. Klicken Sie auf "Konvertieren". Das Dialogfenster "Textdatei einlesen" wird angezeigt.

    4. Wählen Sie eine der folgenden Optionen aus:

    Wenn Zeilenumbrüche nur bei Leerzeilen eingefügt werden sollen, wählen Sie "Zeilenenden einlesen als Zeilenumbrüche". Setzen Sie diese Option für absatzorientierte Textdateien ein, z. B. für Dateien, die Dokumenttext enthalten.

    Soll am Ende jeder Zeile ein Umbruch erfolgen, wählen Sie "Zeilenenden einlesen als Absatzenden". Diese Option eignet sich für zeilenorientierte Textdateien, z. B. für Dateien, die Computercode enthalten.

    Um Text in eine Tabelle zu konvertieren, wählen Sie "Text in Tabelle konvertieren". Verwenden Sie diese Option, wenn der Inhalt der Quelldatei aus Tabellen besteht.

    5. Wählen Sie das entsprechende Codierungsschema. Standardmäßig ist das japanische Codierungsschema ausgewählt.

    6. Klicken Sie auf "Einlesen". Der Text wird in einem mit einer speziellen Schablone erstellten Dokument angezeigt. Sie können diese Schablone ändern, um die Formatierung von Dokumenten anzupassen, die aus Textdateien erstellt werden (siehe Ändern von Schablonen für leeres Papier und Textdateien).

    7. Wenn Sie die Option "Text in Tabelle konvertieren" ausgewählt haben, wird das Dialogfenster "Zu Tabelle konvertieren" angezeigt.

    8. Wählen Sie die entsprechenden Optionen und klicken Sie auf "Konvertieren". Der Inhalt der Textdatei wird in eine Tabelle konvertiert und als FrameMaker-Dokument geöffnet.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Beim Öffnen von Dokumenten ggf. angezeigte Meldungen und Dialogfenster

Öffnen von Dokumenten, mit denen bereits gearbeitet wird

Sie können vermeiden, dass Sie Änderungen an Dokumenten vornehmen, die bereits von anderen Benutzern geöffnet wurden.

Bei jedem Öffnen eines Dokuments wird eine Sperrdatei (*.lck) erstellt. Diese Sperrdatei verhindert, dass andere Änderungen an der Datei vornehmen, an der Sie gerade arbeiten. Eine Sperrdatei befindet sich im selben Ordner wie das Originaldokument und wird beim Schließen des Dokuments entfernt.

Unter Windows kann das Sperren von Dateien deaktiviert werden. Weitere Informationen finden Sie unter Arbeiten mit Dateien auf unterschiedlichen Plattformen.

Wenn Sie versuchen, ein bereits geöffnetes Dokument aufzurufen und über Schreibzugriff auf das Dokument verfügen, wird ein Dialogfenster mit dem Namen des Dokuments, dem letzten Benutzer, dem Zeitpunkt der Verwendung und dem dabei verwendeten Computer angezeigt. Dasselbe Dialogfenster wird möglicherweise auch nach einem Systemabsturz angezeigt, wenn Sie ein Dokument öffnen, das Sie zuletzt verwendet haben.

So öffnen Sie ein Dokument, das bereits verwendet wird:

    1. Öffnen Sie die Datei (siehe Öffnen von Dokumenten).

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie die Datei lediglich ansehen, aber nicht ändern wollen, klicken Sie auf "Nur zum Lesen öffnen" und anschließend auf "Fortfahren". Das Dokument wird dann im Viewer-Format angezeigt.

    Wenn Sie eine Kopie der Datei bearbeiten wollen, klicken sie auf "Kopie für Bearbeitung öffnen" und anschließend auf "Fortfahren".

    Wenn Sie die Datei bearbeiten wollen und sich sicher sind, dass kein anderer Benutzer sie geöffnet hat, klicken Sie auf "Sperre zurücksetzen und öffnen" und anschließend auf "Fortfahren". Mit dieser Option werden nach einem Systemabsturz Dokumente geöffnet, die zur Zeit des Absturzes geöffnet waren.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Beim Öffnen von Dokumenten ggf. angezeigte Meldungen und Dialogfenster

Öffnen von in einer früheren FrameMaker-Version erstellten Dokumenten

Mit FrameMaker 8 können Sie .fm-Dateien öffnen, die mit FrameMaker 7 erstellt wurden. Wenn Sie jedoch .fm-Dateien öffnen wollen, die mit FrameMaker 6 oder früher erstellt wurden, müssen Sie sie als MIF-Dateien speichern. Sie können diese MIF-Dateien in FrameMaker 8 öffnen.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Beim Öffnen von Dokumenten ggf. angezeigte Meldungen und Dialogfenster

Öffnen von Dokumenten ohne Aktualisieren der Querverweise

Das Öffnen einer Datei nimmt möglicherweise viel Zeit in Anspruch, wenn sie viele Querverweise auf andere Dateien, große importierte Grafiken oder viele Texteinschübe enthält. Wenn Sie die Aktualisierung von importierten Grafiken, Querverweisen und Texteinschüben unterdrücken, können Sie Dokumente schneller öffnen. Bei dieser Methode müssen Sie jedoch beachten, dass FrameMaker Sie nicht über fehlende Dateien oder ungelöste Querverweise informiert. Aus diesem Grund sollten Sie Dokumente gelegentlich auf normale Weise öffnen.

So öffnen Sie Dokumente, ohne die Querverweise zu aktualisieren:

    1. Wählen Sie "Datei > Öffnen" und anschließend die zu öffnende Datei.

    2. Führen Sie eine der folgenden Aktionen aus:

    (Windows) Halten Sie die Strg-Taste gedrückt und klicken Sie auf "Öffnen".

    (UNIX) Halten Sie die Umschalttaste gedrückt und klicken Sie auf "Öffnen".

Wenn die Datei geöffnet ist, werden Grafiken in FrameMaker nach Bedarf seitenweise importiert und angezeigt. Sie können Querverweise und Texteinschübe mit "Bearbeiten > Referenzen aktualisieren" manuell aktualisieren. Wenn der Seitenaufbau zu langsam erfolgt, öffnen Sie das Dokument zur Beschleunigung des Vorgangs in der üblichen Weise erneut. Weitere Informationen zum schnelleren Öffnen finden Sie unter Anpassen der Dokumentanzeige im Dokumentfenster.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Beim Öffnen von Dokumenten ggf. angezeigte Meldungen und Dialogfenster

Öffnen von Dateien nach einem Systemabsturz

Nach einem Systemabsturz enthalten automatisch gespeicherte Dateien die zuletzt an der Datei vorgenommenen Änderungen. In folgenden Situationen werden Dateien automatisch gespeichert:

    Wenn im Dialogfenster "Voreinstellungen" die Option "Automatisch speichern" aktiviert wurde, werden in regelmäßigen Abständen automatisch gespeicherte Dateien (mit der Erweiterung .auto) erstellt.

    Wenn das System instabil wird, versucht FrameMaker eine Wiederherstellungsdatei (mit der Erweiterung .recover) anzulegen, die die letzten Änderungen enthält.

So öffnen Sie eine Datei nach einem Systemabsturz:

    1. Öffnen Sie die Datei, an der Sie zuletzt gearbeitet haben (siehe Öffnen von Dokumenten).

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn eine Wiederherstellungsdatei existiert, öffnen Sie diese nach entsprechender Aufforderung und prüfen, ob Ihre letzten Änderungen noch vorhanden sind. Ist das der Fall, sichern Sie die Wiederherstellungsdatei unter dem Namen, den das Dokument vor dem Systemausfall trug, und löschen die Wiederherstellungsdatei.

    Wenn keine Wiederherstellungsdatei vorhanden ist, öffnen Sie nach entsprechender Aufforderung die automatisch gesicherte Datei und speichern sie unter dem ursprünglichen Dateinamen. Die automatische Sicherungskopie enthält alle Änderungen bis zum Zeitpunkt der letzten automatischen Sicherung. Der Umfang der verlorenen Arbeit hängt von dem als Speicherintervall festgelegten Zeitraum und vom Zeitpunkt des Absturzes ab.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Sichern von Dokumenten

Dokumente können unter ihrem aktuellen Namen und Verzeichnis gespeichert werden. Sie können aber auch eine Kopie des Dokuments unter einem anderen Namen und in einem anderen Verzeichnis speichern. Sie können Dokumente in verschiedenen Formaten speichern: Hypertext Markup Language (HTML), Extensible Markup Language (XML) und Portable Document Format (PDF).

Wenn ein Dokument oder ein Buch gespeichert werden muss, wird im Seitenstatus-Bereich der Statuszeile ein Sternchen (*) angezeigt.

Ein Sternchen zeigt nicht gespeicherte Änderungen an.

Zeichen mit Akzent, Sonderzeichen oder andere Spezialzeichen sollten in Dateinamen vermieden werden. Andernfalls treten möglicherweise Probleme auf, wenn Sie die Datei unter einem anderen Betriebssystem öffnen.

So speichern Sie ein Dokument:

    1. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Datei > Sichern", um die aktuelle Version der Datei auf der Festplatte zu überschreiben.

    Um die Datei in einem anderen Ordner unter einem anderen Dateinamen zu sichern, wählen Sie "Datei > Sichern unter".

    2. Wenn Sie den Befehl "Sichern unter" wählen oder die Datei bisher noch nicht gespeichert wurde, geben Sie den neuen Dateinamen und das neue Verzeichnis an. Wenn Sie die Datei in einem anderen Format sichern möchten, wählen Sie dieses aus dem Aufklappmenü aus (siehe Formate, in denen Sie eine Datei speichern können).

    3. Klicken Sie auf "Sichern". Wenn Sie das Format "Nur Text" gewählt haben, müssen Sie angeben, wie Text und Tabellen im Dokument umgesetzt werden sollen (siehe Speichern von Dokumenten im Nur-Text-Format).

So speichern Sie ein Buch:

    1. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Datei > Buch sichern", um die aktuelle Version auf der Festplatte zu überschreiben.

    Um die Datei in einem anderen Ordner unter einem anderen Dateinamen zu speichern, wählen Sie "Datei > Buch sichern unter".

    2. Wenn Sie den Befehl "Buch sichern unter" wählen oder die Datei bisher noch nicht gespeichert wurde, geben Sie den neuen Dateinamen und das neue Verzeichnis ein.

Hinweis: Der Befehl "Buch sichern unter" speichert nur die Buchdatei und nicht die Dateien im Buch. Wenn das Buch in einem neuen Verzeichnis gespeichert wird, müssen die einzelnen Dateien immer separat geöffnet und gespeichert werden.

So speichern Sie alle geöffneten Dokumente:

Halten Sie die Umschalttaste gedrückt und wählen Sie "Datei > Geöffnete Dateien sichern".

So stellen Sie die letzte Sicherungsversion eines Dokuments wieder her:

Wählen Sie "Datei > Zurück zur gesicherten Version" und klicken Sie auf OK.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Sichern von Dokumenten

Formate, in denen Sie eine Datei speichern können

Mit dem Befehl "Sichern unter" können Sie Dateien in den folgenden Formaten speichern:

Dokument 8.0

Speichert FrameMaker 8-Dokumente oder -Bücher als Dokument oder Buch, das in FrameMaker 8 geöffnet und bearbeitet werden kann.

Nur Ansicht 8.0

Erzeugt ein Buch oder Dokument, das Benutzer öffnen, jedoch nicht bearbeiten können. Haben Sie versehentlich eine Datei im Viewer-Format gespeichert, können Sie den Schreibschutz aufheben, indem Sie Esc d Umschalttaste+y drücken. Anschließend können Sie das Dokument im Dokument- oder Buchformat speichern.

Dokument 7.0

Speichert FrameMaker 8-Dokumente oder -Bücher als 7.0-Dokument oder -Buch, das in FrameMaker 7.0 geöffnet und bearbeitet werden kann. Spezifische Einstellungen aus FrameMaker 8 werden in FrameMaker 7.0 ignoriert.

MIF 8.0

Erstellt eine Textdatei mit FrameMaker 8-Anweisungen, die den gesamten Text und alle Grafiken beschreiben. Damit das Originaldokument nicht überschrieben wird, muss die MIF-Datei unter einem anderen Namen gespeichert werden. (Sie können dem Dateinamen beispielsweise die Erweiterung .mif hinzufügen.) Weitere Informationen zu MIF finden Sie im Online-Handbuch MIF Reference.

MIF 7.0

Erstellt eine Textdatei mit FrameMaker 7.0-Anweisungen, die den gesamten Text und alle Grafiken beschreiben. Damit das Originaldokument nicht überschrieben wird, muss die MIF-Datei unter einem anderen Namen gespeichert werden. (Sie können dem Dateinamen beispielsweise die Erweiterung .mif hinzufügen.) Weitere Informationen zu MIF finden Sie im Online-Handbuch MIF Reference.

Nur Text

Erstellt eine Textdatei ohne Grafiken oder Formatierungsinformationen. Damit das Originaldokument nicht überschrieben wird, muss die Textdatei unter einem anderen Namen gespeichert werden. (Sie können dem Dateinamen beispielsweise die Erweiterung .text hinzufügen.) Weitere Informationen hierzu finden Sie unter Speichern von Dokumenten im Nur-Text-Format.

PDF

Erzeugt eine PDF-Datei (Portable Document Format), die mit Adobe Acrobat® und anderen Anwendungen betrachtet werden kann, die dieses Format unterstützen (siehe Überblick über Adobe PDF).

SGML

Erzeugt eine SGML-Datei mit den Inhalten, Elementen und Attributen Ihres Dokuments (siehe Öffnen und Speichern von strukturierten Dateien).

HTML

Erzeugt ein HTML-Dokument, das im World Wide Web betrachtet werden kann. Informationen zum Anpassen der Zuordnungen von Absatz- und Zeichentypen zu vordefinierten HTML-Elementen finden Sie unter Anpassen von HTML-Zuordnungen.

Hinweis: Wenn Sie ein strukturiertes FrameMaker-Dokument im HTML-Format speichern, werden alle gleichnamigen Attribute dem gleichen Wert zugeordnet, auch wenn die Attribute für verschiedene Elemente unterschiedliche Werte annehmen. Um für diese Attribute nach dem Export unterschiedliche Werte zu verwenden, bearbeiten Sie die Ergebnisdatei in einem Texteditor.

XML

Erzeugt ein Dokument im XML-Format (Extensible Markup Language), das zum Datenaustausch verwendet und im World Wide Web betrachtet werden kann. Weitere Informationen finden Sie unter Speichern eines strukturierten Dokuments im SGML- oder XML-Format.

Andere Dateiformate

Erstellt Dateien, die von anderen Anwendungen gelesen werden können. Sie können Dokumente z. B. im RTF-Format (Rich Text Format) speichern, das von vielen Textverarbeitungsprogrammen unterstützt wird. Möglich sind alle Formate, für die ein Exportfilter installiert ist. Die meisten Formatierungen bleiben erhalten, und Formate werden in der Regel in das entsprechende Format des Textverarbeitungsprogramms umgewandelt. Weitere Informationen finden Sie im Online-Handbuch Verwenden von Filtern und unter Verwenden von "Sichern unter" zum Export in andere Formate.

Hinweis: PostScript®-Dateien können mit dem Befehl "Drucken" gesichert werden (siehe Erstellen von PostScript-Dateien).


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Sichern von Dokumenten

Dateinamenerweiterungen für gesicherte Dateien (Windows)

Wenn Sie unter Windows eine Datei zum ersten Mal speichern, fügt FrameMaker automatisch die folgenden Dateinamenerweiterungen an: .fm für Dokumente, .book für Buchdateien und .mif für MIF-Dateien. Mit diesen Dateinamenerweiterungen werden die Dateien vom Betriebssystem Windows weiterhin als FrameMaker-Dateien erkannt.

Sollen diese Erweiterungen nicht an die gewählten Dateinamen angefügt werden, setzen Sie die Dateinamen in doppelte Anführungszeichen. Windows erkennt eine Datei ohne diese Dateinamenerweiterungen nicht als FrameMaker-Datei, aber Sie können die Datei immer noch in FrameMaker öffnen.

Wenn Sie eine Erweiterung zuweisen, die für eine andere Anwendung registriert ist (beispielsweise .doc), wird diese nicht durch eine FrameMaker-Erweiterung ersetzt.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Sichern von Dokumenten

Speichern von Dokumenten im Nur-Text-Format

Das Speichern eines Texts im Format "Nur Text" erzeugt eine Textdatei mit einer Textcodierung Ihrer Wahl: ANSI (Windows), ISO Latin-1 (UNIX) oder ASCII. (In japanischen Systemen kann auch JIS, Shift-JIS oder EUC verwendet werden. In anderen asiatischen Systemen können Codierungen für die unterstützten Sprachen verwendet werden.) Gespeichert wird nur einfacher Text (in Textrahmen und Tabellen); Grafiken, Bildbeschriftungen, Fußnoten und Formatierungsinformationen werden nicht gespeichert. Formatieren Sie gegebenenfalls Zeilenlängen und Trennungen neu, bevor Sie die Datei speichern (siehe Ändern von Einzügen und Ausrichtung und Ändern von Silbentrennung und Zeilenumbruch).

Wenn bestimmte Zeichen in der gewählten Textcodierung nicht verfügbar sind, werden sie in der Textdatei ersetzt. Wenn Sie beispielsweise ein Dokument im Format "Nur Text" mit ANSI- (Windows), ISO Latin-1- (UNIX) oder ASCII-Codierung speichern, werden Leerzeichen (einschließlich t-, n-, m- und numerischer Leerzeichen) zu normalen Leerzeichen konvertiert.

So speichern Sie ein Dokument im Format "Nur Text":

    1. Wählen Sie "Datei > Sichern unter".

    2. Geben Sie den Dateinamen und das Verzeichnis an und wählen Sie als Format "Nur Text".

    3. Klicken Sie auf "Sichern".

    4. Führen Sie eine der folgenden Aktionen aus:

    Soll jede Zeile als eigener Absatz interpretiert werden, wählen Sie "Am Ende jeder Zeile". Mit dieser Option werden die ursprünglichen Zeilenumbrüche und Leerzeilen einer Datei beibehalten. Daher eignet sie sich für zeilenorientierte Textdateien, z. B. für Dateien, die Computercode enthalten.

    Wenn zusammenhängende Zeilen als Absatz interpretiert werden und ein Absatzende nur für eine Leerzeile eingefügt werden soll, klicken Sie auf "Nur zwischen Absätzen". Setzen Sie diese Option für absatzorientierte Dateien ein, z. B. für Dateien, die Dokumenttext enthalten.

    5. Wenn Sie Tabellentext speichern wollen, wählen Sie "Text von Zellen übernehmen". Gehen Sie anschließend folgendermaßen vor:

    Legen Sie die Reihenfolge fest, in der die Tabellenzellen gespeichert werden sollen (zeilen- oder spaltenweise).

    Legen Sie mithilfe der Aufklappmenüs fest, ob die Tabellenzellen durch Tabulatoren oder Zeilenschaltungen voneinander getrennt werden sollen.

    6. Wenn die Textdatei auf einer Plattform mit einer anderen Textcodierung eingesetzt werden soll, wählen Sie die entsprechende Codierung im Aufklappmenü "Textcodierung".

    7. Klicken Sie auf "Sichern".


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Sichern von Dokumenten

Exportieren von XML aus unstrukturierten Dokumenten

Sie können sowohl strukturierte als auch unstrukturierte Dateien in XML exportieren. Die für den Export verwendete Zuordnung von Absatztypen in der FrameMaker-Quelldatei zu Elementen wird auf einer Referenzseite definiert. Die Exportfunktion erzeugt eine XML-Datei und eine entsprechende Stilvorlage (CSS), die mit dem Dokument verwendet werden kann.

Weitere Informationen zum Exportieren strukturierter Dokumente im XML-Format finden Sie unter Speichern eines strukturierten Dokuments im SGML- oder XML-Format.

So speichern Sie ein Dokument im XML-Format:

    1. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Datei > Als XML speichern".

    Wählen Sie "Datei > Sichern unter" aus und wählen Sie dann "XML" aus dem Aufklappmenü. Fügen Sie dem Dateinamen die Erweiterung .xml hinzu.

    2. Geben Sie einen Speicherort für die Datei an.

    3. Klicken Sie auf "Sichern".


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Sichern von Dokumenten

Automatisches Speichern und Erstellen von Sicherungskopien

FrameMaker kann automatisch Sicherungskopien Ihres Dokuments erzeugen und Ihre Arbeit speichern.

So stellen Sie die Optionen für automatisches Speichern ein:

    1. Führen Sie eine der folgenden Aktionen aus:

    (Windows) Wählen Sie "Datei > Voreinstellungen > Allgemein".

    (UNIX) Wählen Sie "Datei > Voreinstellungen".

    2. Führen Sie folgende Schritte durch:

    Um bei jedem Sicherungsvorgang eine Sicherungsdatei anzulegen, wählen Sie "Automatische Sicherungskopie anlegen". Damit wird vor dem Speichern der aktuellen Änderungen eine Kopie der Datei erstellt. Wenn bereits eine Sicherungsdatei existiert, wird sie durch die neue Sicherungsdatei überschrieben. (Die Dateinamen der Sicherungsdateien haben die Erweiterung .backup.)

    Um eine Datei in regelmäßigen Zeitabständen automatisch zu speichern, wählen Sie "Automatisch speichern" und geben den gewünschten Zeitraum (in Minuten) in das Textfeld ein. Bei diesem Verfahren wird regelmäßig eine Kopie der Datei gespeichert, ohne dass Sie "Datei > Sichern unter" wählen müssen. (Die Dateinamen automatisch gespeicherter Dateien haben die Erweiterung .auto.) Wenn Sie manuell speichern oder den Stand der letzten Sicherung mit dem Befehl "Zurück zur gesicherten Version" wiederherstellen, wird die automatisch gespeicherte Datei gelöscht.

    3. Klicken Sie auf "Zuweisen".


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Hinzufügen von Metadaten zu einem Dokument

FrameMaker enthält die integrierte XMP-Unterstützung (Extensible Metadata Platform). Metadaten oder Datei-Informationen sind ausführliche Information, die von einem Computer gesucht und verarbeitet werden können. Verwenden Sie diese, um Informationen zu den Inhalten eines Dokuments zu erstellen und Informationen zu einem Dokument zu bewahren, das in einer anderen Adobe-Anwendung geöffnet wird. Wenn Sie die Datei in ein PDF-Format exportieren, werden viele dieser Metadaten in Acrobat angezeigt.

Metadatentypen begleiten das Dokument und beschreiben dessen Inhalt. Durch Einbetten in Ihre Dokumente, ist es einfacher, die Dokumente zu verfolgen, zu verwalten und abzurufen.

Hinweis: Die Metadaten einer Buchdatei können die Metadaten einer Dokumentdatei überschreiben. Wenn das Dokument Bestandteil einer Buchdatei ist, können Sie die Buchdatei öffnen und das Dokument vor dem Hinzufügen der Metadaten auswählen.

So fügen Sie Metadaten zu einem Dokument hinzu:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Datei > Datei-Informationen".

    3. Geben Sie in das Textfeld neben einer oder allen Kategorien die gewünschten Informationen ein.

    4. Geben Sie unter "Markiert" für urheberrechtlich geschützte Dokumente "Ja" und für Dokumente, die ausdrücklich der Domäne "Öffentlich" angehören, "Nein" an. Wenn Sie sich nicht sicher sind, wählen Sie "Unbekannt".

    5. Klicken Sie auf "Zuweisen".


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Drucken von Dokumenten

Wenn Sie ein Dokument drucken, können Sie über Optionen festlegen, wie viele Exemplare und ob Schneide- und Registermarken gedruckt werden. Die verfügbaren Optionen hängen von der Plattform und vom verwendeten Drucker ab.

Wenn Sie mit strukturierten Dokumenten arbeiten, sind Elementgrenzen (Klammern oder Tags) druckbare Zeichen. Wenn Sie diese Grenzen im Dokumentfenster anzeigen, können sie vor dem Drucken ausgeblendet werden (siehe Ein- und Ausblenden von Elementgrenzen).

Hinweis: Für das PostScript-Drucken wird die Verwendung eines Level 2 PostScript-Ausgabegeräts (oder höher) empfohlen. Achten Sie darauf, bei solchen Geräten einen Druckertreiber und eine PPD zu verwenden.

Informationen zum Drucken eines aus mehreren Dokumenten bestehenden Buchs finden Sie unter Drucken von einem Buchfenster aus.

Wichtig: Wenn Sie im Dialogfenster "Darstellungsoptionen" die Anzeige von Grafiken deaktiviert haben, werden auch im gedruckten Dokument keine Grafiken angezeigt.

Hinweis: Die Druckfunktion unterstützt den Unicode-Standard zur Textcodierung.

So drucken Sie ein Dokument:

    1. Wählen Sie "Datei > Drucken".

    2. Geben Sie den Seitenbereich an, den Sie drucken möchten.

    3. Wählen Sie weitere Druckoptionen aus und klicken Sie auf "Drucken".

Wenn Sie unter UNIX die Druckeinstellungen eines Dokuments ändern möchten, das jedoch noch nicht gedruckt werden soll, nehmen Sie die Änderungen im Dialogfenster "Drucken" vor und klicken auf "Einstellungen sichern".


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Drucken von Dokumenten

Druckoptionen

Die folgenden Druckoptionen sind für alle Drucker verfügbar. Alle diese Optionen sind im Dialogfenster "Drucken" enthalten. Weitere Informationen zu zusätzlichen Optionen finden Sie in der Dokumentation zu Ihrem Drucker.

Hinweis: (Windows) FrameMaker-Produkte für Windows haben keinerlei Kontrolle über die Funktionen und Beschränkungen eines Druckertreibers. FrameMaker-Produkte unterstützen nur autorisierte Druckertreiber für die Windows-Version, auf der FrameMaker ausgeführt wird. Wenn Sie mit einem alten Druckertreiber arbeiten, ist es möglich, dass Grafiken und Zeichen verloren gehen oder Sie ein Dokument nicht öffnen können. Informationen zu aktuellen PostScript-Treibern finden Sie auf der Website von Adobe.

Exemplare

Um beim Drucken mehrerer Exemplare eines Dokuments ein vollständiges Exemplar zu drucken, bevor Sie die nächste Kopie drucken, wählen Sie "Exemplarweise". Das Drucken kann langsamer erfolgen, wenn "Exemplarweise" ausgewählt ist.

Doppelseitig drucken

Zum Drucken eines doppelseitigen Dokuments ohne Duplex-Drucker drucken Sie zunächst die ungeraden Seiten, drehen das Papier dann um und drucken die geraden Seiten. Abhängig davon, wie Ihr Drucker Seiten ausgibt, müssen Sie eventuell die Option "Umgekehrte Reihenfolge" aktivieren, bevor Sie auf die Schaltfläche "Drucken" klicken, da das Umdrehen des Papiers im Drucker die Seitenfolge umkehren könnte.

Seitenfolge ändern

Um die letzte Seite eines Dokuments zuerst zu drucken, aktivieren Sie die Option "Umgekehrte Reihenfolge".

Schneller drucken

Um ein Dokument schneller auszudrucken, aktivieren Sie die Option "Grafik mit niedriger Auflösung". Unter Windows werden importierte Bilder als graue Felder gedruckt. Unter UNIX werden sie mit einer niedrigeren Auflösung gedruckt.

Schneide- und Registermarken drucken

Um ein Dokument mit Schneide- und Registermarken zu drucken, wählen Sie eine entsprechende Option aus dem Aufklappmenü "Registermarken". In einigen Fällen können Sie die gedruckte Seite auch verkleinern, damit Schneide- und Registermarken auf die Seite passen.

Sie können zwischen "Normal"- und "Tombo"- (japanischen) Schneidemarken wählen.

Schneidemarken "Normal" und "Tombo"

Seiten verkleinert oder vergrößert drucken

Führen Sie einen der folgenden Schritte aus, um eine verkleinerte oder vergrößerte Seite zentriert zu drucken:

    Geben Sie in das Textfeld "Maßstab" einen Prozentwert ein.

Vorschaubilder drucken

Um Vorschaubilder zu drucken (kleine Abbildungen mehrerer Seiten auf einer Seite), geben Sie in die Vorschau-Textfelder Werte ein. Geben Sie in das Textfeld "Reihen" die Anzahl der Vorschaubilder ein, die auf der Seite von oben nach unten dargestellt werden sollen. Geben Sie in das Textfeld "Spalten" die Anzahl der Vorschaubilder ein, die von links nach rechts dargestellt werden sollen.

Vorschaubilder

Leere Seiten überspringen (Windows)

Wählen Sie "Leere Seiten überspringen", um das Drucken leerer Seiten zu verhindern.

Farben monochrom drucken

Um farbige Elemente (FrameMaker-Bilder und -Text) in Schwarz und Weiß anstatt in Graustufen auszudrucken, führen Sie einen der folgenden Schritte aus:

    (Windows) Aktivieren Sie die Option "Farbe in Schwarzweiß".

    (UNIX) Bearbeiten Sie den Anfang der Datei ps_prolog, die sich im Ordner $FMHOME/fminit befindet. Diese Datei enthält alle Anweisungen für das Ändern der Druckeinstellungen. Änderungen an dieser Datei treten sofort in Kraft. Wenn sich die Änderungen nicht auf andere Benutzer auswirken sollen, speichern Sie eine Kopie der Datei mit den Änderungen in Ihren fminit-Ordner (~/fminit/ps_prolog).

Papier manuell zuführen

Um das Dokument auf Papier zu drucken, das sich nicht im Papierfach des Druckers befindet, führen Sie einen der folgenden Schritte aus:

    (Windows) Wählen Sie "Datei > Druckereinrichtung". Wählen Sie "Manuelle Papierzufuhr" im Aufklappmenü "Quelle" und klicken Sie auf "OK".

    (UNIX) Aktivieren Sie die Option "Manuelle Papierzufuhr".

Hinweis: (Windows) Das FrameMaker-Dialogfenster "Dokument drucken" enthält Optionen, die auch im Dialogfenster "Eigenschaften" des Druckers angezeigt werden, z. B. die Anzahl der zu druckenden Kopien. Wenn Sie ein Dokument drucken, haben die Druckereinstellungen von FrameMaker Vorrang vor den Windows-Druckereinstellungen.

Papierformat ändern (UNIX)

Um das Dokument auf einem anderen Papierformat zu drucken, wählen Sie das entsprechende Format im Aufklappmenü "Papierformat" oder geben Sie die gewünschten Maße in die Textfelder "Breite" und "Höhe" ein. Da die eingegebenen Maße die physische Größe des Papiers im Papierfach des Druckers (unabhängig von der Ausrichtung des Dokuments) bezeichnen, sollte der Wert im Feld "Breite" immer der Breite des Papiers im Drucker entsprechen.

Wenn die Seiten Ihres Dokuments größer sind als das Papier, erscheint eine Warnmeldung. Wenn Sie das Dokument dennoch drucken, wird es beschnitten.

Schriften herunterladen (UNIX)

Wählen Sie die auf den Drucker herunterzuladenden Schriften im Aufklappmenü "Lateinische Schriften herunterladen" aus. Schriften, die sich bereits im Druckerspeicher oder auf einer mit dem Drucker verbundenen Festplatte befinden, müssen nicht heruntergeladen werden. Wenn beispielsweise die Standard 35-Schriften bereits auf dem Drucker vorhanden sind, wählen Sie "Alle außer Standard 35". Um das Unterteilen und Herunterladen von asiatischen Schriften zu ermöglichen, wählen Sie die Option "Asiatische Schriften herunterladen". Wenn Ihr Dokument TrueType-Schriften enthält und Sie einen PostScript Level 1-Drucker verwenden, wählen Sie die Option "TrueType als Typ 1 herunterladen".

Die Standard 35-Schriften (Variationen von Avant Garde, Bookman, Courier, Helvetica, Helvetica Narrow, New Century Schoolbook, Palatino, Symbol, Times, Zapf Chancery und Zapf Dingbats) werden mit den meisten PostScript-Druckern mitgeliefert.

Sie können die UNIX-Schriftkonfigurationsdatei (fontlist) bearbeiten, um die Optionen zum Herunterladen im Dialogfenster "Drucken" zu überschreiben.

Um eine Liste der auf einem PostScript-Drucker vorhandenen Schriften zu erhalten, drucken Sie das Skript printerfont.ps im Ordner $FMHOME/fminit/pstools.

Anderen Drucker verwenden (UNIX)

Um einen anderen Drucker zu verwenden, wählen Sie den Namen des entsprechenden Druckers im Aufklappmenü "Ziel". Sämtliche für Ihren Computer konfigurierten Drucker werden im Aufklappmenü angezeigt. Wenn ein Drucker nicht angezeigt wird oder Sie ein spezielles Druck-Skript verwenden (um beispielsweise ein Fax zu senden), wählen Sie "Anderer Drucker" aus dem Aufklappmenü. Geben Sie dann die entsprechenden Parameter in das angezeigte Textfeld ein.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten / Drucken von Dokumenten

Erstellen von PostScript-Dateien

Sie können eine Beschreibung für ein Dokument erzeugen, die als PostScript-Datei bezeichnet wird (auch Druckdatei genannt). Sie können eine PostScript-Datei verwenden, um das Dokument später auf einen PostScript-Drucker herunterzuladen oder an einen Dienstanbieter zum Setzen zu senden. Darüber hinaus können Sie eine Adobe PDF-Datei erstellen (siehe Aktivieren und Deaktivieren der Einbettung von SWF-Dateien in PDF-Dateien).

So erstellen Sie aus einem Dokument eine Druckdatei:

    1. Wählen Sie "Datei > Drucken".

    2. Führen Sie einen der folgenden Schritte aus und klicken Sie anschließend auf "Drucken":

    (Windows) Wählen Sie die Option "Ausgabe in Datei" und geben Sie im Textfeld den Pfad und den Dateinamen ein, oder klicken Sie auf "Durchsuchen", um einen Ordner und einen Dateinamen anzugeben.

    (UNIX) Wählen Sie die Option "PostScript-Datei" aus dem Aufklappmenü "Ziel" und geben Sie im Textfeld den Pfad und den Dateinamen ein, oder klicken Sie auf "Durchsuchen", um ein Verzeichnis und einen Dateinamen anzugeben.

Sie können auch eine .ps-Erweiterung für Ihre PostScript-Datei eingeben.

So erstellen Sie eine Druckdatei für ein Buch:

    1. Wählen Sie im Buchfenster "Datei > Buch drucken" oder wählen Sie die gewünschten Dokumente und dann "Datei > Ausgewählte Dateien drucken".

    2. Führen Sie einen der folgenden Schritte aus und klicken Sie anschließend auf "Drucken":

    (Windows) Wählen Sie die Option "Ausgabe in Datei" und geben Sie im Textfeld den Pfad und den Dateinamen ein, oder klicken Sie auf "Durchsuchen", um einen Ordner und einen Dateinamen anzugeben. Wählen Sie aus dem Aufklappmenü "Buch sichern unter" (oder "Ausgewählte Dateien sichern unter") die Option "Einzelne Datei". Klicken Sie anschließend auf "Drucken".

    (UNIX) Wählen Sie die Option "PostScript-Datei" aus dem Aufklappmenü "Ziel" und geben Sie im Textfeld den Pfad und den Dateinamen ein, oder klicken Sie auf "Durchsuchen", um ein Verzeichnis und einen Dateinamen anzugeben. Klicken Sie anschließend auf "Drucken".

So erstellen Sie für ein Buch eine Reihe separater Druckdateien:

    1. Wählen Sie im Buchfenster "Datei > Buch drucken" oder wählen Sie die gewünschten Dokumente und dann "Datei > Ausgewählte Dateien drucken".

    2. Führen Sie eine der folgenden Aktionen aus:

    (Windows) Wählen Sie die Option "Ausgabe in Datei" und geben Sie im Textfeld den Pfad und den Dateinamen ein, oder klicken Sie auf "Durchsuchen", um einen Ordner und einen Dateinamen anzugeben. Wählen Sie aus dem Aufklappmenü "Buch sichern unter" oder "Ausgewählte Dateien sichern unter" die Option "Einzelne Datei" oder "Separate Datei für jedes Dokument". Klicken Sie anschließend auf "Drucken".

    (UNIX) Wählen Sie "Eine PostScript-Datei je Dokument" aus dem Aufklappmenü "Ziel" und klicken Sie dann auf "Drucken".


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Arbeiten mit Dateien auf unterschiedlichen Plattformen

Durch Kompatibilitäts-Voreinstellungenen werden FrameMaker-Dateien auf verschiedenen Plattformen kompatibel. Weitere Informationen zur Kompatibilität verschiedener Plattformen und Netzwerke finden Sie im Online-Handbuch Arbeiten auf unterschiedlichen Plattformen, das sich im Ordner "handbch" bzw. "Online-Handbücher" befindet.

So ändern Sie die Kompatibilitäts-Voreinstellungen:

    1. Führen Sie eine der folgenden Aktionen aus:

    (Windows) Wählen Sie "Datei > Voreinstellungen > Allgemein".

    (UNIX) Wählen Sie "Datei > Voreinstellungen".

    2. Führen Sie folgende Schritte durch:

    Um die Namen nicht verfügbarer Schriften zu erhalten, wenn FrameMaker vorhandene Schriften ersetzt, aktivieren Sie die Option "Namen fehlender Schriften speichern". Die ursprünglichen Schriften erscheinen wieder, wenn Sie das Dokument auf einem System öffnen, in dem die fehlenden Schriften installiert sind. Weitere Informationen finden Sie unter Fehlerbehebung bei nicht vorhandenen Schriften.

    (Windows) Um Fehler anzuzeigen, die FrameMaker beim Öffnen von Dateien findet, aktivieren Sie die Option "Konvertierungsfehler anzeigen".

    (Windows) Wählen Sie eine Einstellung im Aufklappmenü "Systemübergreifend", um die Kompatibilität der Dateinamen zwischen verschiedenen Systemen zu gewährleisten.

    (Windows) Um einen Netzwerkbenutzer vor dem Öffnen und Bearbeiten eines bereits im Netzwerk geöffneten Dokuments zu warnen, aktivieren Sie die Option "Netzwerk-Dateikontrolle".

    (Windows) Um Bitmap-Grafiken, die über den Kopierbefehl importiert wurden, einen FrameImage-Typ hinzuzufügen, aktivieren Sie die Option "FrameImage mit importierten Grafiken speichern". Die Grafiken werden in ihrem eigenen Format und im FrameImage-Format gespeichert (ein Format, das auf allen Plattformen unterstützt wird). Wenn Sie das Dokument auf Rechnern oder Plattformen öffnen, die das Originalformat nicht unterstützen, wird die FrameImage-Kopie verwendet.

    3. Klicken Sie auf "Zuweisen". Die Einstellungen werden sofort wirksam.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten FrameMaker-Dokumenten

Schließen von Dokumenten

Sie können ein Dokument jederzeit schließen. Sie werden dann gefragt, ob Sie Ihre Änderungen speichern möchten. (In einem Dokument mit nicht gespeicherten Änderungen wird ein Sternchen im Seitenstatus-Bereich der Statuszeile angezeigt.)

Wurden beim Öffnen des Dokuments importierte Grafiken, Texteinschübe, Querverweise oder Systemvariablen aktualisiert, wird es als geändert gekennzeichnet (mit einem Sternchen in der Statuszeile). Da beim Drucken eines Dokuments Querverweise (falls vorhanden) aktualisiert werden, kann das Dokument nach dem Drucken als geändert markiert sein.

So schließen Sie ein Dokument:

    Wählen Sie "Datei > Schließen".

So schließen Sie alle geöffneten Dokumente:

    Halten Sie die Umschalttaste gedrückt und wählen Sie "Datei > Geöffnete Dateien schließen".


Grundlagen in FrameMaker

Arbeiten mit strukturierten FrameMaker-Dokumenten

Elemente in strukturierten Dokumenten

Hinzufügen von Elementen

Verbesserte Konvertierung in Strukturen

Einfügen von Elementen

Festlegen von Optionen für das Einfügen neuer Elemente

Bearbeiten von Elementen

Elementinhalt ausgliedern

Verschieben von Elementen

Kopieren von Elementen

Importieren von Elementdefinitionen

Entfernen von Elementen

Zuweisen von Attributwerten

Attributtypen

Kopieren von Attributwerten

Verbesserte Validierung von EDD-Attributen

Suchen von Elementen und Attributen


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Elemente in strukturierten Dokumenten

Sie können einem Dokument neue Elemente hinzufügen, um seine Struktur aufzubauen, und bestehende Elemente auf verschiedene Weise bearbeiten. Die strukturierte FrameMaker-Benutzeroberfläche unterstützt Sie beim Aufbau einer gültigen Dokumentstruktur.

Wenn Sie ein FrameMaker-Dokument durch Öffnen einer strukturierten Datei anlegen, müssen Sie keine neuen Elemente hinzufügen. Das Dokument enthält bereits Elemente, die aus dem strukturierten Markup generiert wurden. Sie können diese Elemente jedoch bearbeiten und neue Elemente hinzufügen, so als ob Sie das Dokument in FrameMaker erstellt hätten.

Erläuterung von Elementen

Um die Struktur eines Dokuments aufzubauen, können Sie dem Dokument entweder Elemente hinzufügen und diese dann mit Inhalt füllen oder vorhandenen Inhalt auswählen und in Elemente eingliedern.

Ein strukturiertes Dokument enthält Elementdefinitionen, die im Elementkatalog gespeichert sind. Anhand dieser Definitionen wird der zulässige Inhalt für jeden Elementtyp beschrieben, den das Dokument enthalten kann, sowie gegebenenfalls Attribute und Formate für die Elemente festgelegt. Wenn der Inhalt und Attribute aller Elemente in einem Dokument diese Anforderungen erfüllen, ist das Dokument gültig.

Gültiger Elementinhalt

Eine Elementdefinition enthält Inhaltsregeln, mit denen der zulässige Inhalt eines Elements festgelegt wird. So könnte die Definition eines Elements "Abschnitt" zum Beispiel festlegen, dass ein Abschnitt mit einem Element "Überschrift" beginnen muss, dann ein Absatzelement enthalten muss und danach eine beliebige Kombination aus Absatz-, Grafik- und anderen Abschnittselementen enthalten kann. Ein Absatzelement könnte Text und Querverweis-Elemente in beliebiger Reihenfolge zulassen.

Sie benötigen jedoch keine exakten Kenntnisse darüber, ob und an welcher Stelle der Inhalt der Elemente gültig ist. Verwenden Sie den Elementkatalog als Richtlinie. Er enthält eine Liste der Elemente, die an der aktuellen Position gültig sind, und gibt an, wann Text zulässig ist. (Gültige Elemente sind im Elementkatalog mit einem dunklen Häkchen gekennzeichnet.)

Gültiger Inhalt für die aktuelle Position

Zwei Kategorien von Elementen

Elemente lassen sich nach ihrem zulässigen Inhalt in zwei Hauptkategorien unterteilen:

    Ein Container-Element kann Text und/oder andere Elemente enthalten. Container-Elemente bilden die Struktur des Dokuments. Die meisten Elemente in einem typischen Dokument sind Container-Elemente, z. B. Überschriften, Absätze, Abschnitte und Tabellen. Diese Elemente werden in der Strukturansicht als Rechtecke mit abgerundeten Ecken dargestellt.

    Objektelemente bestehen aus einem einzigen Objekt, z. B. einer Marke, einem Querverweis, einer Systemvariablen, einer Gleichung oder einem verankerten Rahmen. In diese Elemente können Sie keinen Text eingeben und Sie können ihnen keine untergeordneten Elemente hinzufügen. Objektelemente werden in der Strukturansicht als Rechtecke ohne abgerundete Ecken dargestellt.

A: Rechtecke mit abgerundeten Ecken stellen Container-Elemente dar.
B: Objektelemente werden als Rechtecke ohne abgerundete Ecken dargestellt.

Ein Container-Element kann so definiert sein, dass es leer bleibt. Beispielsweise kann das Tabellendesign vorgeben, dass eine Zelle in einer Tabelle keinen Inhalt haben soll. Wenn ein Element als leer definiert wurde, lautet dessen Textausschnitt in der Strukturansicht <LEER>. Wenn ein Element nur Leerzeichen oder nicht ausdruckbare Zeichen wie Tabulatoren enthält, lautet dessen Ausschnitt <LEERRAUM>.

Attribute für Elemente

Ein Element kann Attribute enthalten, die Informationen zum Element liefern und nicht Teil des Elementinhalts sind. Sie können Attribute und ihre Werte in der Strukturansicht anzeigen.

Attribute sind optional, d. h. der Entwickler entscheidet, ob bzw. welche Attribute für ein Element definiert werden. Die Verwendung von Attributen in einem Dokument kann aus verschiedenen Gründen sinnvoll sein:

    Sie können mit Attributen die Formatierung von Elementen steuern. Das Attribut "Typ" könnte z. B. in einem Listenelement zwei mögliche Werte annehmen – "Auszeichnungspunkt" und "Nummeriert". Diese Werte legen fest, ob die Bestandteile der Liste mit Auszeichnungspunkten versehen oder nummeriert werden. Oder das Attribut "Präfix" in einem Element "Anmerkung" könnte am Anfang der Anmerkung Text, wie Wichtig, anzeigen.

Attribute können Formatierungsinformation liefern.

    Sie können mit Attributen beschreibende Informationen zu einem Element aufzeichnen. Das Attribut mit der Bezeichnung "Sicherheit" in einem Element "Notiz" könnte die Vertraulichkeitsstufe der Notiz beschreiben, z. B. "StrengGeheim". Ein Attributwert kann sogar die Art und Weise beeinflussen, wie eine Datei verarbeitet wird. So kann z. B. der Wert "StrengGeheim" eine benutzerdefinierte Routine auslösen, die das Element ausblendet, wenn das Dokument angezeigt wird.

    Sie können mit Attributen Quell- und Zielinformationen für Elemente speichern, in der Regel bei Querverweisen. So könnte z. B. ein Element "Abschnitt" über ein ID-Attribut verfügen, in dem ein einmaliger Wert gespeichert ist. Ein Querverweis-Element, das auf den Abschnitt verweist, enthält denselben Wert in einem Referenzattribut, um die Verbindung zwischen den Elementen aufrechtzuerhalten. Diese Verwendung von Attributen entspricht den strukturierten Anforderungen.

Normalerweise geben Sie die Werte für die Attribute ein oder bearbeiten sie, es sei denn, die Attribute sind als schreibgeschützt definiert. (ID-Attribute, die in Querverweisen verwendet werden, sind häufig schreibgeschützt und werden von FrameMaker generiert.)


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Hinzufügen von Elementen

Um einem Dokument ein Element hinzuzufügen, fügen Sie entweder ein leeres Element ein und füllen es mit Inhalt oder Sie gliedern bereits vorhandenen Inhalt in ein Element ein. Wenn für das Element Attribute definiert wurden, können Sie auch beim Hinzufügen Attributwerte festlegen.

Hinweis: Bevor Sie beginnen können, muss Ihr Dokument im Elementkatalog über Elementdefinitionen verfügen. Importieren Sie, falls notwendig, die Elementdefinitionen aus einer strukturierten Schablone (siehe Importieren von Elementdefinitionen).

Im Elementkatalog werden die Elemente aufgelistet, die an der aktuellen Position verfügbar sind. Sie können den Bereich der verfügbaren Elemente verändern, z. B. um Elemente anzuzeigen, die an der aktuellen Position ungültig sind (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument).

Fragen Sie Ihren Anwendungsentwickler nach einer Übersicht über den möglichen Inhalt für jedes Element. Diese Informationen können bei der Arbeit hilfreich sein.

Wenn Sie ein Element einfügen, werden Sie unter Umständen feststellen, dass Text oder andere Elemente zusammen mit dem Element eingefügt werden. Wenn Sie z. B. ein Element mit der Bezeichnung "Anmerkung" einfügen, könnte das Wort Anmerkung erscheinen, oder wenn Sie ein "Listenelement" einfügen, könnte ein untergeordnetes Listeneintrag-Element erscheinen. Anhand der Definition von Elementen wird festgelegt, ob Text oder untergeordnete Elemente automatisch eingefügt werden.

Hinweis: Elementnamen unterstützen den Unicode-Standard zur Textcodierung.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Hinzufügen von Elementen

Hinzufügen von Elementen zu einem leeren Dokument

Sie können einem leeren Dokument eine Struktur geben, indem Sie Elemente einzeln einfügen. Hierbei können Sie entweder konsequent alle Elemente in der richtigen Reihenfolge und hierarchischen Ordnung eingeben oder Sie achten mehr auf den Inhalt als auf die Struktur und führen dann später eine Prüfung und Fehlerbehebung durch.

So fügen Sie einem leeren Dokument Elemente hinzu:

    1. Wenn das Dokument keine Elementdefinition enthält, importieren Sie die Definition (siehe Importieren von Elementdefinitionen).

    2. Geben Sie den Bereich der verfügbaren Elemente an (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument).

    3. Fügen Sie Elemente aus dem Elementkatalog ein (siehe Hinzufügen von Elementen). Beginnen Sie beim Element der höchsten Ebene. Der Katalog zeigt Ihnen dann, welche Elemente Sie als Nächstes einfügen müssen.

    4. Geben Sie, falls erforderlich, Attributwerte ein (siehe Zuweisen von Attributwerten).

    5. Füllen Sie die Elemente mit Inhalt. Sie können Inhalt beim Einfügen der Elemente oder auch zu einem späteren Zeitpunkt hinzufügen.

Prüfen Sie das Dokument und korrigieren Sie eventuelle Fehler (siehe Überprüfen von Dokumenten).


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Hinzufügen von Elementen

Hinzufügen von Elementen zu einem Dokument mit Inhalt

Sie strukturieren ein nicht strukturiertes Dokument, indem Sie seinen Inhalt in eine Hierarchie von Elementen eingliedern. Durch die Konvertierung bleibt die Formatierung in Absätzen, Tabellen und allen Objekttypen (Querverweis, Marke, Grafik, Gleichung, Fußnote, Systemvariable, Rubi und Rubi-Gruppe) erhalten. (Wenn das Dokument über eine Konvertierungstabelle verfügt, können Sie die Struktur über die Konvertierungstabelle zuweisen, anstatt sie manuell einzufügen. Weitere Informationen hierzu finden Sie unter Hinzufügen von Struktur zu Dokumenten mithilfe von Konvertierungstabellen.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Verbesserte Konvertierung in Strukturen

Die Konvertierungsfunktion, mit der Sie unstrukturierte Dokumente strukturieren können, wurde auf verschiedene Arten verbessert:

    Das Stammelement kann jetzt in der Konvertierungstabelle angegeben und automatisch hinzugefügt werden, anstatt es wie bisher nach einer Konvertierung manuell hinzufügen zu müssen.
    Geben Sie "RE:RootElement" in der ersten Spalte der Konvertierungstabelle und den Namen des Stammelements in der zweiten Spalte an.

    Durch die Konvertierung bleibt die Formatierung in Absätzen, Tabellen und allen Objekttypen (Querverweis, Marke, Grafik, Gleichung, Fußnote, Systemvariable, Rubi und Rubi-Gruppe) jetzt erhalten.

Verwenden Sie vor der Konvertierung das FrameMaker-Dienstprogramm "Formate anlegen & zuweisen", um irreguläre Formate und nicht gekennzeichneten, formatierten Text in benannte Absatz- und Zeichenformate zu ändern, die in das strukturierte Dokument und das EDD weitergeleitet werden können.

Weitere Informationen zu Konvertierungstabellenangaben und zur Durchführung der Konvertierung finden Sie in Anhang A "Conversion Tables for Adding Structure to Documents" im Structure Application Developer’s Guide.

So fügen Sie einem Dokument mit Inhalt Elemente hinzu:

    1. Wenn das Dokument keine Elementdefinition enthält, importieren Sie die Definition (siehe Importieren von Elementdefinitionen).

    2. Geben Sie den Bereich der verfügbaren Elemente an (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument). Am besten verwenden Sie dazu die Option "Alle Elemente".

    3. Wählen Sie Inhalt aus und gliedern Sie ihn in Elemente des Elementkatalogs ein (siehe Hinzufügen von Elementen). Beginnen Sie auf der untersten Ebene und arbeiten Sie sich bis zur obersten Ebene vor.

    4. Geben Sie, falls erforderlich, Attributwerte ein (siehe Zuweisen von Attributwerten).

    5. Bestimmen Sie das Element "OhneTitel" zum gültigen Element der höchsten Ebene. Das Element "OhneTitel" wird als Element der höchsten Ebene erstellt, sobald Sie den ursprünglichen Inhalt eingliedern. Ändern Sie Elemente mit Standard-Tags (z. B. TABELLE) in gültige Elemente.

    6. Prüfen Sie das Dokument und korrigieren Sie eventuelle Fehler (siehe Überprüfen von Dokumenten).


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Einfügen von Elementen

Sie können ein leeres Element einfügen und es anschließend mit Inhalt füllen. Wenn Sie Elementgrenzen aktiviert haben und Elemente einfügen, werden zwei Elementgrenzen im Dokumentfenster und ein neues Elementrechteck in der Strukturansicht angezeigt.

Leere Elementgrenzen (links) und Elementrechteck des neuen Elements (rechts)

Wenn Sie das Dokument noch nicht vollständig geplant haben, kann es sinnvoll sein, zunächst nur Elemente höherer Ebenen, z. B. Abschnitt- und Überschriftelemente, einzufügen und diese Struktur dann als Gerüst für den Aufbau des Dokuments zu verwenden.

So fügen Sie ein Element über den Elementkatalog ein:

    1. Klicken Sie an der Stelle, an der Sie das Element einfügen möchten. Wenn Sie das Element zwischen anderen Elementen einfügen möchten, kann es unter Umständen einfacher sein, in der Strukturansicht zu arbeiten als im Dokumentfenster.

    2. Wählen Sie aus dem Elementkatalog ein Element-Tag aus und klicken Sie auf "Einfügen". Wenn nur ein Element im Katalog erscheint, klicken Sie einfach auf die Schaltfläche "Einfügen".

Sie können zum Einfügen eines Elements auch auf ein Element-Tag doppelklicken.

    3. Wenn das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für das Element ein und klicken auf "Element einfügen" (siehe Eingeben von Attributwerten beim Einfügen von Elementen).

Dieses Dialogfenster wird nur angezeigt, wenn das gewählte Element über Attribute verfügt und im Dialogfenster "Neue Elementoptionen" die Option für die Abfrage von Attributwerten beim Einfügen von Elementen aktiviert ist.

    4. Wenn Sie eine Marke, Grafik oder einen Querverweis einfügen, geben Sie im Dialogfenster zusätzliche Informationen zum Element an.

So fügen Sie ein Element über die Tastatur ein:

    1. Klicken Sie an der Stelle, an der Sie das Element einfügen möchten, und drücken Sie die Tastenkombination Strg+1 bzw. Control+1 (Eins).

    2. Geben Sie die ersten Buchstaben des Element-Tags ein, bis es in der Statusleiste des Dokumentfensters angezeigt wird. Die verfügbaren Elemente entsprechen den aktuell im Elementkatalog angezeigten Elementen.

Element-Tag

Sie können auch Kleinbuchstaben eingeben, um die Elemente, die mit den entsprechenden Buchstaben beginnen, vorwärts zu durchsuchen. Wenn Sie stattdessen Großbuchstaben eingeben, wird rückwärts gesucht. Sie können auch die Nach-Oben- bzw. Nach-Unten-Taste verwenden, um alle Elemente zu durchsuchen.

    3. Drücken Sie die Eingabetaste. Wenn Sie den Vorgang abbrechen möchten, drücken Sie Esc (Windows) oder Control+c (UNIX).


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Einfügen von Elementen

Einfügen von Elementen mit der Eingabetaste

In vielen Fällen können Sie Elemente durch Drücken der Eingabetaste einfügen. Jedes Mal, wenn Sie die Eingabetaste drücken, überprüft FrameMaker die Definition des aktuellen Elements in folgender Reihenfolge auf folgende Bedingungen und fügt möglicherweise ein untergeordnetes Element ein:

Ein gültiges Element

Wenn nur ein untergeordnetes Element an der aktuellen Position gültig ist, kann es durch Drücken der Eingabetaste eingefügt werden. Nach dem Hinzufügen eines Abschnitts kann z. B. eine Überschrift das einzige Element sein, das zulässig ist. Mit diesem Verfahren können auch sich wiederholende Elemente erstellt werden, wobei durch Drücken der Eingabetaste derselbe Elementtyp eingefügt wird. Haupttextabsätze und Listenelemente werden häufig als sich wiederholende Elemente definiert.

Mehrere gültige Elemente

Wenn mehrere Elemente gültig sind, wird durch Drücken der Eingabetaste der Namensbereich hervorgehoben, und Sie werden aufgefordert, ein Element-Tag einzugeben. Sie können mit der Eingabe des Tags beginnen, bis das gewünschte Tag erscheint, und dann die Eingabetaste drücken, um das Element einzufügen.

Ende eines Elements

Wenn sich die Einfügemarke am Ende eines Elements befindet und keine weiteren untergeordneten Elemente gültig sind, wird durch das Drücken der Eingabetaste nach vorausgehenden gültigen Elementen gesucht. Wenn ein gültiges Element gefunden wird, bewegt sich die Einfügemarke zum vorausgehenden Element, und das Element wird eingesetzt (wenn nur ein Element gültig ist) oder der Namensbereich wird hervorgehoben (wenn mehrere Elemente gültig sind).

Sonstige Bedingungen

Wenn keine der zuvor genannten Bedingungen zutrifft, hat das Drücken der Eingabetaste zur Folge, dass ein Signalton erzeugt wird und kein Element eingefügt wird.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Einfügen von Elementen

Vorhandenen Inhalt in Elemente eingliedern

Sie können Inhalt, der sich bereits in einem Dokument befindet, strukturieren, indem Sie den Inhalt in ein neues Element eingliedern. Bei dem Inhalt kann es sich um beliebige Dokumentteile handeln, einschließlich um andere Elemente.

Wenn Sie Inhalt in ein Element eingliedern, werden im Dokumentfenster zwei Elementgrenzen um den Inhalt angezeigt (wenn die Elementgrenzen eingeblendet sind) und in der Strukturansicht erscheint ein neues Elementrechteck. Der Inhalt des Elements wird entsprechend der Formatregeln des Elements formatiert.

Elementgrenze (links) und Elementrechteck des neuen Elements (rechts)

Hinweis: Sie können Inhalt nicht in Elemente eingliedern, die für Teile von Tabellen (z. B. Reihen und Zellen) vorgesehen sind. Sie können jedoch Text oder andere Elemente, die in einer Zelle oder einem anderen Tabellenteil enthalten sind, in ein Element eingliedern. Wenn Sie Text und Elemente zu einer Tabelle konvertieren möchten, sollten Sie den Befehl "Tabelle > Zu Tabelle konvertieren" wählen, anstatt den Inhalt in Elemente einzugliedern (siehe Konvertieren von Text zu Tabellen).

Nach dem Eingliedern eines Elements kann es erforderlich sein, das Dokument zu bearbeiten, um Strukturfehler zu berichtigen. Wenn Sie z. B. Absatzelemente in ein Abschnittelement eingliedern, das ein Überschriftelement erfordert, müssen Sie dieses einfügen. Hilfe zum Auffinden und Berichtigen von Fehlern in der Struktur finden Sie unter Suchen und Korrigieren von Fehlern.

So gliedern Sie Inhalt über den Elementkatalog in Elemente ein:

    1. Wählen Sie den Inhalt aus, den Sie in ein Element eingliedern möchten. Zum Auswählen von Text verwenden Sie das Dokumentfenster. Wenn Sie vollständige Elemente auswählen möchten, ist es möglicherweise einfacher, die Strukturansicht zu verwenden.

    2. Wählen Sie ein Element-Tag aus dem Elementkatalog und klicken Sie auf "Gliedern". Wenn nur ein Element im Katalog erscheint, klicken Sie einfach auf die Schaltfläche "Eingliedern".

Sie können auch auf ein Element-Tag doppelklicken, wenn Sie die Auswahl in ein Element eingliedern möchten.

    3. Wenn das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für das Element ein und klicken auf "Element einfügen" (siehe Eingeben von Attributwerten beim Einfügen von Elementen).

Dieses Dialogfenster erscheint nur, wenn das Element über Attribute verfügt und im Dialogfenster "Neue Elementoptionen" die Option für die Abfrage von Attributwerten beim Einfügen von Elementen aktiviert wurde (siehe Festlegen von Optionen für das Einfügen neuer Elemente).

So gliedern Sie ein Element über die Tastatur ein:

    1. Wählen Sie den Inhalt aus, den Sie in ein Element eingliedern möchten, und drücken Sie die Tastenkombination Strg+2 bzw. Control+2.

    2. Geben Sie die ersten Buchstaben des Element-Tags ein, bis es in der Statusleiste des Dokumentfensters angezeigt wird. Die verfügbaren Elemente entsprechen den aktuell im Elementkatalog angezeigten Elementen.

Element-Tag

Sie können auch Kleinbuchstaben eingeben, um die Elemente, die mit den entsprechenden Buchstaben beginnen, vorwärts zu durchsuchen. Wenn Sie stattdessen Großbuchstaben eingeben, wird rückwärts gesucht. Sie können auch die Nach-Oben- bzw. Nach-Unten-Taste verwenden, um alle Elemente zu durchsuchen.

    3. Drücken Sie die Eingabetaste. Wenn Sie den Vorgang abbrechen möchten, drücken Sie Esc (Windows) oder Control+c (UNIX).

Eingliedern von Elementen im gesamten Dokument

Sie können durch Eingliedern ein nicht strukturiertes Dokument strukturieren. (Einen Überblick über diesen Vorgang finden Sie unter Hinzufügen von Elementen zu einem Dokument mit Inhalt.) Am einfachsten gliedern Sie den Inhalt eines Dokuments in Elemente ein, indem Sie auf der untersten Ebene beginnen und sich, wie nachfolgend beschrieben, nach oben vorarbeiten:

    Arbeiten Sie am Anfang im Dokumentfenster und gliedern Sie Textbereiche, Systemvariablen und andere Absatzeinheiten ein. Ignorieren Sie Fehler, die in der Strukturansicht angezeigt werden. Die meisten Fehler werden korrigiert, wenn Sie die untersten Ebenen in übergeordnete Elemente eingliedern. Sie können anschließend die restlichen Fehler korrigieren.

    Dann gliedern Sie Absätze, Überschriften und andere Einheiten der Absatzebene in ihre Elemente ein.

    Am Schluss gliedern Sie in der Strukturansicht die Elemente ein, die Sie bereits in übergeordnete Elemente, wie z. B. Abschnitt- und Listenelemente, eingegliedert haben.

Wenn Sie feststellen, dass Sie die Auswahl ständig in dieselbe Art von Element eingliedern, können Sie den zuletzt im Elementkatalog ausgeführten Befehl wiederholen, indem Sie die Tastenkombination Esc e e drücken.

Wenn Sie das erste Element im Dokument eingliedern, ändert sich die Strukturansicht sofort und die folgende ungültige Standardstruktur wird angezeigt:

    Ein Element der höchsten Ebene mit dem Tag "OhneTitel" wird hinzugefügt, es sei denn, Sie beginnen die Eingliederung, indem Sie den Inhalt in ein gültiges Element der höchsten Ebene eingliedern. "OhneTitel" ist ein Platzhalter für Ihr gültiges Element der höchsten Ebene.

    Alle Tabellen werden strukturiert und erhalten Standard-Element-Tags wie TABELLE und REIHE.

    Objekte werden zu Elementen mit voreingestellten Tags, wie QUERVERW und GRAFIK und GLEICHUNG.

    Fußnoten werden zu FUSSNOTE.

    Rubi-Text wird zu den Elementen RUBI und RUBIGRP.

Hinweis: Variablen und Marken werden nicht zu strukturierten Objektelementen.

Sie können die Dokumentstruktur berichtigen, wenn Sie das Eingliedern von Elementen abgeschlossen haben.

Wenn Ihr Anwendungsentwickler eine Konvertierungstabelle für Ihr Dokument angelegt hat, können Sie diese Tabelle zum Eingliedern von Elementen im gesamten Dokument verwenden (siehe Hinzufügen von Struktur zu Dokumenten mithilfe von Konvertierungstabellen). Damit lassen sich Elemente wesentlich schneller eingliedern.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Festlegen von Optionen für das Einfügen neuer Elemente

Es gibt verschiedene Wege, um neue Elemente in ein Dokument einzufügen. Möglicherweise möchten Sie z. B. Attribute erst nach dem Einfügen von Elementen eingeben. Oder Sie finden es unter Umständen verwirrend, dass untergeordnete Elemente automatisch mit den Elementen eingefügt werden.

So legen Sie Optionen für das Hinzufügen neuer Elemente fest:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Element > Neue Elementoptionen".

    3. Legen Sie fest, wie Attributwerte angefordert werden sollen, wenn Sie neue Elemente hinzufügen:

    Um beim Hinzufügen der Elemente alle zur Verfügung stehenden Attributwerte einzugeben, wählen Sie "Attributwerte immer anfordern".

    Um beim Hinzufügen der Elemente nur die erforderlichen Attributwerte einzugeben, wählen Sie "Benötigte Attributwerte anfordern".

    Um die Attributwerte erst nach dem Einfügen der Elemente einzugeben, wählen Sie die Option "Benötigte Attributwerte nicht anfordern".

    4. Um FrameMaker zu gestatten, automatisch untergeordnete Elemente in neue Elemente einzufügen, wählen Sie "Automatisches Einfügen von untergeordneten Elementen zulassen".

Eine Elementdefinition kann eine Sequenz von untergeordneten Elementen, die eingefügt werden sollen, festlegen. Zum Beispiel könnte eine Liste eine "Einheit" enthalten, die zusammen mit der Liste eingefügt wird, und diese "Einheit" könnte wiederum einen "Absatz" enthalten.

    5. Klicken Sie auf "Zuweisen".

Um das Hinzufügen neuer Elemente zu beschleunigen, aktivieren Sie die Optionen "Benötigte Attributwerte nicht anfordern" und "Automatisches Einfügen von untergeordneten Elementen zulassen".


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Bearbeiten von Elementen

Es gibt mehrere Möglichkeiten, Dokumentstrukturen zu bearbeiten, z. B. durch Umstellen, Teilen und Zusammenfügen der Elemente sowie Ändern der Elementtypen.

Nach der Änderung eines Dokumentteils kann es erforderlich sein, das Dokument weiterzubearbeiten, um Inhaltsfehler zu berichtigen. Wenn Sie z. B. ein Abschnittelement in zwei Elemente aufteilen, müssen Sie eventuell ein Überschriftelement für den neuen Abschnitt hinzufügen. Verwenden Sie während der Bearbeitung die Strukturansicht als Hilfsmittel zum Suchen von Fehlern, oder prüfen Sie das Dokument, nachdem Sie die Bearbeitung beendet haben.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Bearbeiten von Elementen

Ändern von Elementtypen

Sie können ein vorhandenes Element in einen anderen Elementtyp umwandeln. Möglicherweise möchten Sie z. B. ein Absatzelement in ein Element "Überschrift" oder eine Reihe von Absatzelementen in Listeneintrag-Elemente umwandeln, um diese in ein Listenelement einzugliedern.

Es können jedoch nicht alle Elemente in einen anderen Elementtyp umgewandelt werden. Wenn Sie z. B. ein Absatzelement mit Text in ein Markenelement mit demselben Text umwandeln, ändert sich nur der Name des Elements, der Text wird jedoch nicht in Markentext umgewandelt.

Hinweis: Wenn Sie Inhalt in eine Tabelle umwandeln möchten, sollten Sie zur Konvertierung von Text den Befehl "Tabelle > Zu Tabelle konvertieren" verwenden, anstatt ein Element umzuwandeln (siehe Konvertieren von Text zu Tabellen).

So ändern Sie ein Element über den Elementkatalog:

    1. Wählen Sie das Element aus. Sie können mehrere Elemente auswählen, auch wenn sie nicht über dasselbe Tag verfügen. Alle Elemente werden in den neuen Elementtyp geändert. Die untergeordneten Elemente werden nicht geändert. Aufgrund der Änderung des übergeordneten Elements können sie jedoch ungültig werden.

    2. Wählen Sie ein Element-Tag aus dem Elementkatalog und klicken Sie auf "Ändern". In der Strukturansicht zeigt das Elementrechteck des Elements das neue Tag an und der Inhalt wird entsprechend der Formatregeln des neuen Elements formatiert. Die Attribute des Elements werden unter Umständen ungültig.

So ändern Sie ein Element über die Tastatur:

    1. Wählen Sie das Element aus und drücken Sie die Tastenkombination Strg+3 bzw. Control+3.

    2. Geben Sie die ersten Buchstaben des Tags für das neue Element ein, bis es in der Statusleiste des Dokumentfensters erscheint. Die verfügbaren Elemente entsprechen den aktuell im Elementkatalog angezeigten Elementen.

Element-Tag

Sie können auch Kleinbuchstaben eingeben, um die Elemente, die mit den entsprechenden Buchstaben beginnen, vorwärts zu durchsuchen. Wenn Sie stattdessen Großbuchstaben eingeben, wird rückwärts gesucht. Sie können auch die Nach-Oben- bzw. Nach-Unten-Taste verwenden, um alle Elemente zu durchsuchen.

    3. Drücken Sie die Eingabetaste. Sie können den Vorgang auch abbrechen, indem Sie in das Dokument klicken, ohne die Eingabetaste zu drücken.

Wählen Sie "Bearbeiten > Suchen/Ändern", um alle Exemplare eines mehrfach vorkommenden Elements auf einmal zu ändern (siehe Suchen von Elementen und Attributen). Wenn Sie z. B. neue Elementdefinitionen importiert haben, die ein Element mit der Bezeichnung "Absa" anstelle von "Absatz" verwenden, können Sie alle "Absatz"-Elemente zu "Absa"-Elementen ändern.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Bearbeiten von Elementen

Zusammenfügen von zwei oder mehr Elementen zu einem Element

Sie können zwei oder mehr Elemente zu einem einzigen Element zusammenfügen. Sie können beispielsweise zwei Abschnittelemente zu einem zusammenfügen. Beim Zusammenfügen wird der Inhalt des zweiten Elements (einschließlich aller untergeordneten Elemente) am Ende des ersten Elements eingefügt.

Zusammenfügen zweier Elemente "Abschnitt", vorher und nachher

Nach dem Zusammenfügen kann es erforderlich sein, das Dokument zu überarbeiten.

Hinweis: Wenn Sie Tabellenzellen zusammenfassen möchten, sollten Sie "Tabelle > Verbinden" verwenden, anstatt die Zellen zusammenzufügen (siehe Verbinden und Trennen von Zellen in strukturierten Tabellen). Andere Tabellenteile können nicht zusammengefasst werden.

So fügen Sie zwei oder mehr Elemente zu einem Element zusammen:

    1. Wählen Sie die Elemente aus, die Sie zusammenfügen möchten. Die Elemente können unterschiedlichen Typen angehören, müssen jedoch gleichrangig sein und in ihrem übergeordneten Element benachbart sein.

    2. Wählen Sie "Element > Einlesen".

Beim Zusammenfügen werden nur die Attribute des ersten Elements beibehalten.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Bearbeiten von Elementen

Teilen von Elementen

Sie können ein Element in zwei Elemente teilen, die dasselbe Tag haben und sich auf derselben Ebene befinden. Beispielsweise könnten Sie ein Abschnittelement in zwei teilen.

Teilen eines Elements "Abschnitt", vorher und nachher

Nach dem Teilen kann es erforderlich sein, das Dokument zu überarbeiten. Im vorherigen Beispiel würden Sie nach dem Teilen eine "Überschrift" für den neuen zweiten "Abschnitt" hinzufügen.

Hinweis: Sie können keine Elemente teilen, die Tabellenteile sind (z. B. Reihen oder Zellen).

So teilen Sie ein Element in zwei:

    1. Klicken Sie an der Stelle, an der Sie das Element teilen möchten. Der Inhalt nach der Einfügemarke wird in das neue Element eingefügt.

    2. Wählen Sie "Element > Teilen".

Das Aufteilen kann zu zwei Elementen mit identischen Attributen führen. Wenn das Originalattribut jedoch eine einmalige ID besitzt, verliert das zweite Element seinen ID-Wert.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Elementinhalt ausgliedern

Ausgliedern löscht ein Element, belässt aber seinen Inhalt an derselben Position im Dokument. Normalerweise gliedern Sie Elemente im Rahmen eines umfangreicheren Bearbeitungsprozesses aus. Wenn Sie beispielsweise planen, Listeneintrag-Elemente in Absatzelemente umzuwandeln, müssen Sie möglicherweise zuerst das übergeordnete Listenelement ausgliedern. Verwenden Sie dann "Bearbeiten > Suchen/Ändern", um die Listeneintrag-Elemente in Absatzelemente umzuwandeln.

Ausgliedern von Listeneintrag-Elementen, vorher und nachher

Nach dem Ausgliedern kann es erforderlich sein, das Dokument zu überarbeiten. In diesem Beispiel würden Sie die Listeneintrag-Elemente in gültige Elemente umwandeln oder erneut eingliedern.

Hinweis: Sie können Elemente, die Tabellenteile sind (z. B. Reihen oder Zellen), nicht ausgliedern.

So gliedern Sie Elementinhalt aus:

    1. Wählen Sie das Element mit dem Inhalt, den Sie ändern möchten. Wenn Sie z. B. Listeneintrag-Elemente in einer Liste ausgliedern, wählen Sie das Element "Liste".

    2. Wählen Sie "Element > Ausgliedern".


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Verschieben von Elementen

Sie können ein Element an eine andere Stelle im Dokument verschieben, indem Sie das Elementrechteck des Elements in der Strukturansicht mit der Maus ziehen. Wenn Sie ein Element verschieben, wird auch dessen Inhalt, einschließlich nachfolgender Elemente, verschoben. Dies beeinflusst nicht den Inhalt der Zwischenablage.

Wenn Sie ein Element mit vielen nachfolgenden Elementen verschieben, sollten Sie die Elemente vorher als Stapel darstellen (siehe Aus- und Einblenden von Elementen).

Sie können ein Element verschieben (auch in ein anderes Dokument), indem Sie es ausschneiden, in die Zwischenablage legen und dann einfügen. Wenn Sie ein Element aus einem anderen Dokument einfügen, ist es in Ihrem Dokument unter Umständen nicht definiert. Wenn Sie keine Definition für das Element einfügen möchten, ändern Sie es in ein gültiges Element. Elemente können nicht ausgeschnitten und in eine Buchdatei eingefügt werden.

So verschieben Sie ein Element durch Ziehen mit der Maus:

Ziehen Sie das Elementrechteck an die gewünschte Position. Während Sie ziehen, verändert sich der Mauszeiger in einen dunklen Doppelpfeil und ein Pfeil bewegt sich, um anzuzeigen, an welcher Stelle das Elementrechteck beim Loslassen der Maustaste eingefügt wird.

Verschieben des Elements "Liste", vorher und nachher

Wenn das Element an der vom Pfeil gezeigten Position gültig ist, wird im Rechteck ein Häkchen oder ein Fragezeichen angezeigt. Diese Symbole haben dieselbe Bedeutung wie im Elementkatalog (siehe Elementkatalog von strukturierten Dokumenten).

So verschieben Sie ein Element um eine Position:

Ziehen Sie das Rechteck des Elements etwas zur Seite oder nach oben bzw. nach unten. Wenn Sie nur kurz ziehen, ändert sich der Zeiger zu einem einfachen Pfeil. (Wenn Sie zu weit ziehen, ändert sich der Zeiger zu einem Doppelpfeil.)

Verschieben des Elements "Liste" um eine Position, vorher und nachher

Wenn Sie die Maustaste loslassen, verschiebt sich das Element um eine Position in der angezeigten Richtung, wie nachfolgend beschrieben:

    Wenn Sie ein Element nach oben verschieben, wird es direkt über und vor dem gleichrangigen Element platziert. Wenn Sie ein Element nach unten verschieben, wird es unter und nach dem gleichrangigen Element platziert.

    Wenn Sie ein Element nach links verschieben, wird es als untergeordnetes des zugehörigen übergeordneten Elements eingefügt. Wenn Sie ein Element nach rechts verschieben, wird es als untergeordnetes Element nach dem gleichrangigen Element eingefügt.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Kopieren von Elementen

Sie können die Strukturansicht verwenden, um eine Kopie eines vorhandenen Elements zu erstellen und die Kopie an einer neuen Position zu platzieren. Dies beeinflusst nicht den Inhalt der Zwischenablage.

Wenn Sie ein Element kopieren, wird dessen Inhalt ebenfalls kopiert. In der Regel werden die Elementattribute ebenfalls kopiert. Wenn Sie jedoch ein Element mit einem ID-Attribut duplizieren, wird der ID-Wert in der Kopie verworfen.

Falls Sie ein Element mit vielen nachfolgenden Elementen kopieren möchten, sollten Sie die Elemente vorher als Stapel darstellen (siehe Aus- und Einblenden von Elementen).

Sie können ein Element kopieren (auch in ein anderes Dokument), indem Sie es in die Zwischenablage platzieren und dann einfügen. Wenn Sie ein Element aus einem anderen Dokument einfügen, ist es in Ihrem Dokument unter Umständen nicht definiert. Wenn Sie keine Definition für das Element einfügen möchten, ändern Sie es in ein gültiges Element. Sie können Elemente in einer Buchdatei nicht kopieren und einfügen.

So kopieren Sie ein Element durch Ziehen mit der Maus:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Halten Sie die Alt-Taste gedrückt und ziehen Sie das Elementrechteck mit der Maus an die gewünschte Position.

    (UNIX) Halten Sie die Control-Taste gedrückt und ziehen Sie das Elementrechteck mit gedrückter mittlerer Maustaste an die gewünschte Position.

Beim Ziehen des Elementrechtecks verändert sich der Mauszeiger in einen Konturpfeil mit zwei Spitzen. Ein horizontaler Pfeil bewegt sich und zeigt die Position an, an der die Kopie eingefügt wird, wenn Sie die Maustaste loslassen.

Kopieren eines Elements "Liste", vorher und nachher

Wenn das Element an der vom Pfeil gezeigten Position gültig ist, wird im Rechteck ein Häkchen oder ein Fragezeichen angezeigt. Diese Symbole haben dieselbe Bedeutung wie im Elementkatalog (siehe Elementkatalog von strukturierten Dokumenten).


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Importieren von Elementdefinitionen

Die Elementdefinition eines Dokuments beschreibt zulässige Inhalte für jeden Elementtyp, wie Elemente formatiert werden und ob sie Attribute für die Speicherung zusätzlicher Informationen besitzen. Bevor Sie einem Dokument Elemente hinzufügen können, muss das Dokument über Elementdefinitionen in seinem Elementkatalog verfügen.

Wenn Sie nicht sicher sind, ob ein Dokument Elementdefinitionen enthält, öffnen Sie den Elementkatalog, und klicken Sie in den Textfluss. Wenn Sie im Katalog Elemente sehen, besitzt das Dokument Definitionen. Gegebenenfalls müssen Sie die Option "Alle Elemente" auswählen, damit die Elemente angezeigt werden. (Verwenden Sie den Befehl "Element > Verfügbare Elemente zuweisen").

Normalerweise importieren Sie Definitionen aus einer Schablone, der Entwickler kann Sie aber auch bitten, diese direkt aus dem EDD zu importieren.

So importieren Sie Elementdefinitionen:

    1. Öffnen Sie die Schablone oder das EDD mit den Elementdefinitionen. Die Schablone oder das EDD muss benannt und gesichert sein.

    2. Öffnen Sie das Dokument oder das Buch, das Sie aktualisieren möchten. Wenn ein Buchfenster aktiv ist, wählen Sie die zu aktualisierenden Dokumente aus.

    3. Wählen Sie im zu aktualisierenden Dokument oder Buch "Datei > Importieren > Elementdefinitionen".

    4. Wählen Sie im Aufklappmenü "Aus folgendem Dokument importieren" die Schablone oder das EDD aus. Das Menü listet alle geöffneten benannten Dokumente auf.

    5. Wenn Sie in dem Dokument spezielle Formatierungen und das Buch betreffende Änderungen rückgängig machen möchten, führen Sie die folgenden Schritte aus:

    Um irreguläre Formatzuweisungen zu entfernen, wählen Sie "Irreguläre Formatzuweisungen bei Aktualisierung entfernen". Verwenden Sie diese Einstellung, wenn Sie Text- oder Absatzänderungen an Elementen vorgenommen haben und nun wieder die Formatierung, wie sie in der Elementdefinition festgelegt ist, verwenden möchten. Beachten Sie auch hierzu die Hinweise im Abschnitt Irreguläre Formate.

    Wenn Sie Elementinformationen entfernen möchten, die aus einer Buchdatei abgeleitet wurden, wählen Sie "Bei Aktualisierung entfernen: Informationen aus Buch". Verwenden Sie diese Einstellung, wenn das Dokument Bestandteil eines Buchs war und nun ein Einzeldokument ist.

    6. Klicken Sie auf "Importieren". FrameMaker fügt die Definitionen in den Elementkatalog des Dokuments ein und ersetzt alle bereits vorhandenen Elementdefinitionen. Anschließend prüft es das Dokument, damit Fehler in der Strukturansicht angezeigt werden können, und wendet die Formatregeln aus den Elementdefinitionen wieder an.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Entfernen von Elementen

Sie können jedes Element, entweder mit oder ohne seinen Inhalt, entfernen. Beispielsweise könnten Sie ein Absatzelement und seinen Inhalt löschen; Sie könnten auch einen Abschnitt löschen, den Inhalt jedoch belassen, um ihn in ein anderes Element einzufügen.

Bei Elementen, die so definiert sind, dass sie Text oder andere Elemente enthalten (in der Strukturansicht als Rechtecke mit abgerundeten Ecken dargestellt), können Sie auch den Inhalt löschen und das leere Element im Dokument belassen. Dieses Verfahren ist jedoch bei Elementen, bei denen es sich um einzelne Objekte handelt (normale Rechtecke), nicht möglich. Da diese Elemente keinen Inhalt haben, muss das gesamte Element gelöscht werden.

So entfernen Sie ein Element und seinen Inhalt:

Wählen Sie das Element aus und drücken Sie die Entf-Taste.

So entfernen Sie ein Element ohne seinen Inhalt:

Wählen Sie das Element aus und wählen Sie "Element > Ausgliedern". Möglicherweise wird der Inhalt dem neuen Kontext entsprechend neu formatiert.

So entfernen Sie nur den Inhalt eines Elements:

Wählen Sie den Inhalt aus und drücken Sie die Entf-Taste. Einzelheiten zum Auswählen von Inhalt finden Sie unter Platzieren der Einfügemarke sowie unter Auswählen von Text.

So entfernen Sie ein Element und seinen Inhalt und ersetzen es durch ein anderes Element:

Wählen Sie das Element aus. Wählen Sie dann ein Ersatzelement aus dem Elementkatalog und klicken Sie auf "Einfügen". Ein neues leeres Element ersetzt das ausgewählte Element und seinen Inhalt.

Entfernen sämtlicher Elemente aus einem Dokument

Es kann vorkommen, dass Sie alle Elemente aus einem Dokument entfernen möchten, damit Sie das Dokument auf Absatz- und Zeichenformaten aufbauen können statt auf Elementen.

So entfernen Sie sämtliche Elemente aus einem Dokument:

Wählen Sie "Spezial > Struktur aus Textfluss entfernen". Wenn das Dokument weitere strukturierte Textflüsse enthält, wiederholen Sie diesen Befehl für jeden Textfluss.

FrameMaker entfernt alle Elemente aus dem aktuellen Textfluss. Wenn die Formatierung über Formatänderungslisten im Elementkatalog erstellt oder geändert wurde, werden die entfernten Elemente zu irregulären Formatzuweisungen im Dokument.

Hinweis: Sie können mit dem Befehl "Formate anlegen und zuweisen" benannte Formate für jede entfernte Elementvariante erstellen und im Katalog speichern.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Zuweisen von Attributwerten

Attribute enthalten zusätzliche Informationen zu einem Element, die nicht zusammen mit dem Dokumentinhalt angezeigt werden. Sie können Attribute und ihre Werte in der Strukturansicht anzeigen. (Einzelheiten zum Anzeigen von Attributen finden Sie unter Ein- und Ausblenden von Attributen für neue Elemente.)

Attribute in der Strukturansicht

Eine Attributdefinition gibt den Typ der zulässigen Werte an (z. B. Text oder numerisch) und kann eine Liste der möglichen Werte oder des zulässigen numerischen Bereichs enthalten.

Die Definition bestimmt auch, ob der Wert optional, erforderlich oder schreibgeschützt ist. Ferner kann sie einen Standardwert vorgeben. Wenn ein Attribut nicht schreibgeschützt ist, können Sie dem Attribut Werte zuweisen.

Wenn der aktuelle Wert eines Attributs nicht den Vorgaben in der Definition entspricht, ist das Attribut ungültig. Weitere Informationen zum Suchen und Beheben von Problemen mit Attributen finden Sie unter Suchen und Korrigieren von Fehlern.

Hinweis: Es kann unter Umständen von Vorteil sein, FrameMaker die Werte für ID- und Referenzattribute, die in Querverweisen verwendet werden, angeben zu lassen. (Diese Attribute sind in der Regel als schreibgeschützt definiert.)


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Zuweisen von Attributwerten

Eingeben von Attributwerten beim Einfügen von Elementen

Eventuell möchten Sie einige Attributwerte bereits eingeben, wenn Sie Elemente einfügen, insbesondere für erforderliche Attribute und für Attribute, die die Formatierung beeinflussen. Für optionale Attribute können die Werte zu einem späteren Zeitpunkt eingegeben werden.

Für einige Schrifteinstellungen, die in einem Elementdefinitionsdokument (EDD) verwendet werden, müssen bestimmte Maßeinheiten eingegeben werden. Wenn z. B. die Einstellung "Horizontaler Abstand" auf "Prozent eines m-Leerzeichens" gesetzt ist, erzeugt die Eingabe von 5pt einen Abstand von 5 m-Leerzeichen anstelle von 5 Punkt.

Verwenden Sie bei der Eingabe von Attributwerten keine Multibyte-Zeichen (asiatische Schriften). Diese Zeichen können möglicherweise nicht ordnungsgemäß in das SGML-Format exportiert werden, da Multibyte-Zeichen im SGML-Workflow nicht unterstützt werden.

Hinweis: Attributnamen unterstützen den Unicode-Standard zur Textcodierung.

So geben Sie Attributwerte beim Einfügen von Elementen ein:

    1. Stellen Sie sicher, dass die Attributwerte beim Einfügen von Elementen abgefragt werden (siehe Festlegen von Optionen für das Einfügen neuer Elemente).

    2. Fügen Sie das Element ein (siehe Einfügen von Elementen). Wenn Attribute für das Element definiert wurden, erscheint das Dialogfenster "Attribute für neues Element", in dem alle für das Element definierten Attribute (mit Ausnahme der schreibgeschützten) aufgelistet sind.

    3. Wählen Sie für jeden Attributwert, den Sie angeben möchten, das Attribut aus der Auswahlliste "Attributname". Geben Sie den Wert in das Textfeld "Attributwert" ein und klicken Sie auf "Wert zuweisen". Wenn ein Attribut erforderlich ist, müssen Sie einen Wert für das Element eingeben, damit es gültig wird.

Wenn ein Attribut über mehrere vordefinierte Werte verfügt, wählen Sie einen Wert aus dem Aufklappmenü "Attributwert" statt einen Wert einzugeben.

Aufklappmenü "Attributwert"

Welchen Wert Sie eingeben können, z. B. Text oder eine Zahl, wird durch den Typ des Attributs bestimmt. Einzelheiten zu Attributtypen finden Sie unter Attributtypen.

Im Dialogfenster wird unterhalb des Bereichs "Attributwert" eine Beschreibung des ausgewählten Attributs (sein Typ, ob ein Wert benötigt wird, usw.) angezeigt.

    4. Klicken Sie auf "Element einfügen".


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Zuweisen von Attributwerten

Eingeben oder Bearbeiten von Attributwerten für bereits im Dokument vorhandene Elemente

Wenn die Attribute nicht schreibgeschützt sind, können Sie Attributwerte für bereits im Dokument vorhandene Elemente eingeben und bearbeiten.

Wenn Sie anstelle des Wertes den Namen des Attributs ändern möchten, verwenden Sie "Bearbeiten > Suchen/Ändern" (siehe Ändern gefundener Elemente oder Attribute). Dies kann erforderlich sein, wenn Sie Elementdefinitionen importiert haben, in denen andere Attributnamen für dieselbe Bedeutung verwendet werden, z. B. "Sicherheit" anstelle von "Sicherheitsstufe". Der neue Attributname muss für das Element definiert werden.

So geben Sie einen Attributwert für ein vorhandenes Element ein oder bearbeiten ihn:

    1. Wählen Sie das Element mit dem Attributwert, den Sie ändern möchten.

Sie können mehrere Elemente des gleichen Typs auswählen und die Änderung auf alle anwenden. Die Elemente müssen nebeneinander liegen. Wenn z. B. mehrere aufeinander folgende Absatzelemente ein Attribut mit der Bezeichnung "Sicherheit" haben, können Sie den Wert dieses Attributs für alle Absatzelemente gleichzeitig ändern.

    2. Öffnen Sie das Dialogfenster "Attribute", indem Sie eine der folgenden Aktionen ausführen:

    Klicken Sie oben rechts im Dokumentfenster auf das Attributsymbol ( [image] ). Wenn Sie das Dialogfenster auf diese Weise öffnen, kann es zum Bearbeiten von Attributwerten für mehrere Elemente geöffnet bleiben.

    Doppelklicken Sie in der Strukturansicht auf einen Attributnamen oder -wert. Oder klicken Sie auf das Element, drücken Sie Strg+7 (Windows) bzw. Control+7 (UNIX), geben Sie den Namen des zu bearbeitenden Attributs ein und drücken Sie die Eingabetaste. Wenn das Dialogfenster auf diese Weise geöffnet wird, müssen Sie es nach der Bearbeitung der Attributwerte für das Element wieder schließen.

    3. Wählen Sie für jeden Attributwert, den Sie eingeben oder bearbeiten möchten, das Attribut aus der Auswahlliste "Attributname" aus, geben Sie den Wert im Textfeld "Attributwert" ein und klicken Sie auf "Wert zuweisen".

Wenn ein Attribut über mehrere vordefinierte Werte verfügt, wählen Sie einen Wert aus dem Aufklappmenü "Attributwert" statt einen Wert einzugeben.

    4. Wenn Sie das Dialogfenster "Attribute" durch Doppelklicken in der Strukturansicht oder durch Drücken von Strg+7 bzw. Control+7 geöffnet haben, klicken Sie auf "Zurück".

So entfernen Sie einen Attributwert:

Wählen Sie den Wert im Dialogfenster "Attribute" aus und klicken Sie auf "Wert löschen".

Mit "Bearbeiten > Suchen/Ändern" können Sie wiederholt auftretende Attributwerte in einem Element gleichzeitig bearbeiten (siehe Ändern gefundener Elemente oder Attribute).


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Attributtypen

Anhand des Typs des Attributs wird die Art der für das Attribut zulässigen Werte festgelegt. Für ein als Ganzzahl definiertes Attribut ist z. B. der Wert Version 1 ungültig, der Wert 1 ist dagegen gültig. Numerische Typen, wie Ganzzahl oder reelle Zahl, können außerdem durch ihre Attributdefinition auf einen vordefinierten Bereich beschränkt sein.

Binominalkoeffizient

Attribute mit einer Liste von vordefinierten Werten.

ID-Referenz

Ein Attribut mit einem Wert, der ein einmaliger ID-Wert von einem anderen Element ist. Es wird normalerweise für elementbasierte Querverweise verwendet.

ID-Referenzen

Attribute mit einem oder mehreren einmaligen ID-Werten aus einem anderen Element als Wert. (Der Entwickler kann dieses Attribut festlegen, wenn Sie in eine strukturierte Anwendung exportieren, die mehrere Werte als Quellinformationen verwendet.)

Ganzzahl

Attribute mit einem Ganzzahlwert (ohne Dezimalstellen). Gültige Ganzzahlen sind z. B. 22, -22 und +322. Es können Bereiche von Ganzzahlen definiert werden.

Ganzzahlen

Attribute mit einer oder mehreren Ganzzahlen als Wert. Geben Sie jede Zahl einzeln in das Textfeld "Attributwert" ein.

Reelle Zahl

Attribute, deren Wert eine reelle Zahl ist, die Dezimalstellen haben kann (der Wert kann auch in wissenschaftlicher Schreibweise ausgedrückt sein). Beispiele für gültige reelle Zahlen sind 2; 22,4; -0,22 und 2,3e-1. Eine reelle Zahl kann so definiert sein, dass sie in einem definierten Bereich liegt.

Reelle Zahlen

Attribute, deren Wert eine oder mehrere reelle Zahlen ist. Geben Sie jede Zahl einzeln in das Textfeld "Attributwert" ein.

Zeichenfolge

Attribute, deren Wert eine Zeichenfolge ist (Text).

Zeichenfolgen

Attribute, deren Wert eine oder mehrere Zeichenfolgen ist. Geben Sie jede Zeichenfolge auf einer eigenen Zeile im Textfeld "Attributwert" ein.

Einmalige ID

Attribute, deren Wert eine einmalige Zeichenfolge ist. Ein Element kann nur ein ID-Attribut haben (vom Typ "Einmalige ID" bzw. "Einmalige IDs"). Alle ID-Werte im Dokument oder Buch müssen einmalig sein. Ein Element mit dem Attribut "Einmalige ID" kann die Quelle eines Querverweises sein, der auf Elementen basiert.

Einmalige IDs

Attribute, deren Wert eine oder mehrere einmalige Zeichenfolge ist. Geben Sie jede Zeichenfolge auf einer eigenen Zeile im Textfeld "Attributwert" ein. (Der Entwickler kann dieses Attribut festlegen, wenn Sie in eine strukturierte Anwendung exportieren, die mehrere Werte als Quellinformationen verwendet.)


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Kopieren von Attributwerten

Mithilfe der Zwischenablage können Sie Attributwerte von einem Element in ein anderes kopieren. Wenn Sie Werte in ein Element einfügen, für das nicht die entsprechenden Attribute definiert sind, sind die Attribute ungültig. Damit elementbasierte Querverweise erhalten bleiben, werden ID-Attributwerte nicht eingefügt.

Wenn Sie ein Attribut aus einem anderen Dokument kopieren, ist es im aktuellen Dokument unter Umständen nicht definiert.

So kopieren Sie Attributwerte:

    1. Wählen Sie die Elemente mit den zu kopierenden Attributwerten aus und wählen Sie "Bearbeiten > Kopieren Spezial > Attributwerte". Alle dem Element zugewiesenen Attributwerte werden in die Zwischenablage kopiert.

    2. Wählen Sie ein anderes Element aus und wählen Sie "Bearbeiten > Einfügen".

So löschen Sie ein nicht definiertes Attribut, das aus einem anderen Dokument kopiert wurde:

Wählen Sie das Element mit dem nicht definierten Attribut aus, öffnen Sie das Dialogfenster "Attribute", markieren Sie das Attribut und klicken Sie auf "Attribut löschen". Im nächsten Dialogfenster entfernen Sie das Attribut für das aktuelle Element oder für alle Elemente, die dieses Attribut aufweisen.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Verbesserte Validierung von EDD-Attributen

In früheren Versionen von FrameMaker wurden bei der Validierung der Elemente in einem EDD keine Attribute in if-then-Klauseln validiert. Beispiel: Die möglichen Werte eines Attributs sind A oder B oder C und eine Kontextregel lautet If [attrval = "D"]. Dies wurde bisher beim Import der Elementdefinitionen nicht als Fehler gekennzeichnet. Jetzt wird es hingegen korrekt als ungültige Struktur angezeigt.

Ebenso, wenn bei den Textformatierungsregeln oder Präfix/Suffix-Regeln eines Elements Attributnamen in Bezugsdefinitionen verwendet werden, müssen der Attributname sowie Groß-/Kleinschreibung mit der Attributdefinition in der Definition des Elements übereinstimmen.

Wenn ein Attributwert auf den gleichen vorherigen Wert geändert wird, wird die Aktion nicht als Änderung gekennzeichnet. Dadurch verbessert sich die Leistung, da eine unnötige Wertüberprüfung entfällt.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten

Suchen von Elementen und Attributen

Sie können in einem strukturierten Dokument Elemente und Attribute suchen, um sie zu verfolgen oder schnell Änderungen daran vorzunehmen. Dies ist besonders hilfreich, wenn Sie dieselbe Änderung an Elementen oder Attributen vornehmen möchten, die mehrmals vorkommen.

Darüber hinaus können Sie in FrameMaker nach vielen anderen Einheiten, z. B. Zeichenfolgen, bestimmten Formaten, ungelösten Querverweisen und Objekten (wie verankerten Rahmen) suchen, die keine Elemente sind. Weitere Informationen finden Sie unter Suchen eines beliebigen Elements.

Hinweis: Die Funktion "Suchen/Ändern" unterstützt den Unicode-Standard zur Textcodierung.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Suchen von Elementen und Attributen

Suchen nach Element-Tags, Attributnamen und Attributwerten

Sie können nach Element-Tags, Attributnamen und Attributwerten einzeln suchen oder diese bei der Suche kombinieren. Sie können z. B. nach einem Element mit dem Tag "Liste" suchen, um alle Listenelemente zu finden. Sie können die Suche auch so eingrenzen, dass nur die Listenelemente gesucht werden, die ein Attribut "Sicherheit" mit dem Wert "Geheim" enthalten.

So suchen Sie nach einem Element-Tag, Attributnamen oder Attributwert:

    1. Wählen Sie "Bearbeiten> Suchen/Ändern".

    2. Wählen Sie aus dem Aufklappmenü "Suchen" die Option "Element".

    3. Wählen Sie die gewünschten Optionen im Dialogfenster "Element suchen".

Die Einstellungen können in vielen Kombinationen verwendet werden. Beispiele:

    Um alle Elemente zu finden, lassen Sie alle drei Textfelder leer.

    Um ein bestimmtes Element zu suchen, geben Sie den Namen eines Element-Tags ein, lassen jedoch die Textfelder "Attributname" und "Attributwert" leer.

    Um ein Element mit einem bestimmten Attribut zu suchen, geben Sie einen Attributnamen ein, lassen jedoch die Textfelder "Element-Tag" und "Attributwert" leer.

    Um alle Elemente mit einem bestimmten Attributwert zu suchen, geben Sie den Attributwert ein, lassen jedoch die Textfelder "Element-Tag" und "Attributname" leer.

    Um eine bestimmte Kombination aus Elementen und Attributen zu suchen, geben Sie den Namen eines Element-Tags ein und wählen einen Attributnamen.

    Um eine bestimmte Kombination aus Elementen und Attributwerten zu suchen, geben Sie den Namen eines Element-Tags ein und wählen einen Attributnamen und -wert. (Wenn das Attribut zum Typ "Binominalkoeffizient" gehört, geben Sie den Wert ein.)

    Um ein bestimmtes Element mit einem Attribut ohne Wert zu suchen, geben Sie ein Element-Tag ein, wählen einen Attributnamen und wählen <Kein Wert> aus dem Aufklappmenü "Attributwert".

Lassen Sie ein Textfeld leer, wenn Sie die Suche nicht einschränken möchten. Ein leeres Textfeld bewirkt dasselbe wie die Suche nach einem beliebigen Element oder die Auswahl <Beliebiges Attribut> oder <Beliebiger Wert>.

    4. Klicken Sie auf "Zuweisen".

    5. Aktivieren Sie im Dialogfenster "Suchen/Ändern" die Optionen "Groß-/Kleinschreibung beachten", "Ganzes Wort", "Jokerzeichen" oder "Rückwärts suchen".

    6. Klicken Sie auf "Suchen".

Hinweis: FrameMaker beginnt in der Regel an der Einfügemarke mit der Suche und setzt sie im gesamten Dokument fort. Bei Erreichen des Dokumentendes wird die Suche am Anfang des Dokuments fortgesetzt. Nach Durchsuchen des Haupttextflusses werden andere Textrahmen und Textzeilen durchsucht. Da die Suche Textfluss für Textfluss erfolgt, sieht es so aus, als würde sie im Dokument umherspringen.

So suchen Sie nach dem nächsten Vorkommen des Elements:

Klicken Sie im Dialogfenster "Suchen/Ändern" auf "Suchen" oder wählen Sie "Bearbeiten > Nächstes Auftreten suchen".

So kehren Sie die Suchrichtung um:

Aktivieren Sie im Dialogfenster "Suchen/Ändern" die Option "Rückwärts suchen" und klicken Sie auf "Suchen".

So brechen Sie eine Suche ab:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Drücken Sie Esc.

    (UNIX) Drücken Sie Control+c.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Suchen von Elementen und Attributen

Ändern gefundener Elemente oder Attribute

Nachdem Sie die Elemente, Attribute oder Attributwerte gefunden haben, können diese in andere Elemente, Attribute oder Attributwerte geändert werden. Sie können z. B. den Wert eines Attributs "Sicherheitsstufe" schnell und global von "Öffentlich" auf "StrengGeheim" setzen.

Wenn Sie Elemente in einem Dokument ändern, können Sie jedes Vorkommen eines Elements suchen und einzeln ändern. Sie können FrameMaker auch anweisen, die Änderung automatisch im gesamten Dokument vorzunehmen.

Wenn Sie Material aus einem anderen Dokument eingefügt oder neue Elementdefinitionen importiert haben, lässt sich der Befehl "Suchen/Ändern" als leistungsfähiges Bereinigungswerkzeug einsetzen, um Ihr Dokument wieder in seinen ordnungsgemäßen Zustand zu versetzen. Wenn Sie z. B. eine Tabelle aus einem nicht strukturierten Dokument einfügen, werden die Tabelle und ihre Teile mit ungültigen Standard-Element-Tags versehen. Sie können "Suchen/Ändern" verwenden, um z. B. das Element vom Typ "ZELLE" in Elemente vom Typ "TabellenZelle" umzuwandeln.

So ändern Sie ein gefundenes Element oder Attribut:

    1. Wählen Sie "Bearbeiten> Suchen/Ändern".

    2. Wählen Sie im Dialogfenster "Suchen/Ändern" im Aufklappmenü "Suchen" die Option "Element".

    3. Wählen Sie die gewünschten Optionen im Dialogfenster "Element suchen" und klicken Sie auf "Zuweisen". Wählen Sie dann im Dialogfenster "Suchen/Ändern" aus dem Aufklappmenü "Ändern" eine Option und geben Sie ein Ersatz-Tag oder einen Ersatzwert an.

Das Dialogfenster "Element suchen" und das Aufklappmenü "Ändern" werden zusammen eingesetzt. Einige Beispiele für Kombinationen, die Sie verwenden können:

    Um den Elementtyp zu ändern, geben Sie im Dialogfenster "Element suchen" ein Element-Tag ein, lassen jedoch "Attributname" und "Attributwert" leer. Wählen Sie dann aus dem Aufklappmenü "Ändern" die Option "Element-Tag zu" und geben Sie ein Element-Tag ein.

    Um den Attributtyp zu ändern, geben Sie einen Attributnamen ein, lassen jedoch "Element-Tag" und "Attributwert" leer. Wählen Sie dann "Attributname zu" und geben Sie einen Attributnamen ein, der für dieses Element definiert wurde.

    Um einen Attributwert zu ändern, geben Sie einen Attributwert ein, lassen jedoch "Attributname" und "Attributwert" leer. Wählen Sie dann "Attributwert zu" und geben Sie einen Wert ein.

    Um einem Attribut mit einem bestimmten Namen einen bestimmten Wert zuzuweisen, geben Sie einen Attributnamen ein, lassen jedoch "Element-Tag" und "Attributwert" leer. Wählen Sie dann "Attributwert zu" und geben Sie einen Wert ein.

    Um den Elementtyp eines bestimmten Elements mit einem bestimmten Attributwert zu ändern, geben Sie ein Element-Tag ein und wählen Sie einen Attributnamen und -wert. Wählen Sie dann aus dem Aufklappmenü "Ändern" die Option "Element-Tag zu" und geben Sie ein Element-Tag ein.

    Um einen Attributwert zu entfernen, geben Sie einen Attributwert ein, lassen jedoch "Element-Tag" und "Attributname" leer. Wählen Sie dann "Attributwert zu" und lassen Sie das Textfeld "Wählen" leer.

Wenn Sie versuchen, unzulässige Änderungen vorzunehmen (z. B. wenn Sie versuchen, ein Element-Tag zu entfernen), wird eine Warnmeldung angezeigt, die das Problem erläutert.

    4. Klicken Sie auf "Suchen".

    5. Wenn FrameMaker das Element oder Attribut findet, führen Sie eine der folgenden Aktionen aus:

    Um die Änderungen vorzunehmen, ohne nach weiteren vorkommenden Elementen desselben Typs zu suchen, klicken Sie auf "Ändern".

    Um die Änderung durchzuführen und die Suche nach einem weiteren Vorkommen des Wortes fortzusetzen, klicken Sie auf die Schaltfläche "Ändern & Suchen".

    Um alle vorkommenden Elemente zu ändern, geben Sie an, ob die Änderungen im gesamten Dokument oder nur in der aktuellen Auswahl vorgenommen werden sollen. Klicken Sie anschließend auf "Alles ändern".

Wichtig: Wenn Sie den Text global ändern, können die Änderungen nicht mit dem Befehl "Bearbeiten > Rückgängig" zurückgesetzt werden. Unter Umständen sollten Sie das Dokument speichern und anschließend den Text an den betreffenden Stellen manuell ändern. Wenn Sie sicher sind, dass die Änderungen genau Ihren Vorstellungen entsprechen, klicken Sie auf "Alles ändern".

So löschen Sie gefundene Elemente:

Wählen Sie aus dem Aufklappmenü "Ändern" die Option "In Text", lassen Sie das Textfeld "Ändern" leer und klicken Sie auf "Ändern". Sie können auch einfach die Entf-Taste drücken.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Suchen von Elementen und Attributen

Suchen und Korrigieren von Fehlern

Ein Fehler in einem strukturierten Textfluss kann entweder durch ein Strukturproblem entstehen, z. B. ein Element an einer ungültigen Stelle, oder durch ein ungültiges Attribut, z. B. ein Attribut mit einem fehlenden erforderlichen Wert. Die Elementdefinitionen verfügen über Inhaltsregeln und Attributinformationen, die beschreiben, was für das Dokument zulässig ist.

Sie können die Strukturansicht verwenden, um Fehler in Elementen und Attributen zu suchen. Wenn ein ausgeblendetes Element ungültigen Inhalt in seiner Struktur enthält, ist das Pluszeichen links vom Elementnamen rot. Sie können auch ein Dokument prüfen, um Fehler zu suchen. Nachdem Sie ermittelt haben, wo sich die Fehler befinden, können Sie den Elementkatalog und die Strukturansicht als Hilfsmittel bei der Fehlerkorrektur verwenden.

Wenn Sie Formatänderungen an Text in Elementen vorgenommen haben, erfüllen die Elemente möglicherweise nicht ihre Formatregeln. Informationen zum Entfernen irregulärer Formatzuweisungen finden Sie unter Entfernen von irregulären Formatregeln in strukturierten Dokumenten.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Suchen von Elementen und Attributen

Fehlersuche in der Strukturansicht

Wenn ein Element nicht den Inhaltsregeln und Attributbeschreibungen der Elementdefinitionen des Dokuments entspricht, wird dieser Fehler in der Strukturansicht angezeigt.

Fehlende Elemente

Wenn in einem Element ein oder mehrere untergeordnete Elemente fehlen, die laut Elementdefinition erforderlich sind, erscheint an der Stelle, an der sich das untergeordnete Element befinden sollte, ein rotes Quadrat auf der vertikalen Linie.

Mindestens ein erforderliches untergeordnetes Element fehlt.

Elemente an einer ungültigen Position

Wenn ein Element laut Inhaltsregeln an der aktuellen Position nicht zulässig ist, wird die daneben liegende vertikale Linie bis zum Ende des übergeordneten Elements gestrichelt dargestellt.

Das Element "Absatz" ist an dieser Position ungültig.

Nicht definierte Elemente

Wenn ein Element für das Dokument nicht definiert ist, ist das Elementrechteck rot. Dies kann auftreten, wenn Sie das Element aus einem anderen Dokument eingefügt haben.

Ungültige Attribute

Wenn ein Attribut einen ungültigen Wert hat oder nicht für das Dokument definiert ist, wird links neben dem Attributnamen ein rotes x angezeigt und der entsprechende Wert ist rot.

Das Attribut "EntwurfVersion" ist ungültig.

Fehlende erforderliche Attributwerte

Wenn ein Attribut keinen Wert hat, wird rechts neben dem Attributnamen <Kein Wert> angezeigt. Wenn für das Attribut ein Wert erforderlich ist, ist <Kein Wert> rot und links daneben wird ein rotes Quadrat angezeigt.

Dem Attribut "XrefLabel" fehlt ein erforderlicher Wert.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Suchen von Elementen und Attributen

Überprüfen von Dokumenten

Wenn FrameMaker ein Dokument prüft, wird nach Elementen gesucht, die nicht den Inhalts- und Attributregeln der Elementdefinitionen des Dokuments entsprechen. Wenn FrameMaker einen Fehler findet, wird das Element ausgewählt und der Fehler wird beschrieben.

Sie können das gesamte Dokument, den aktuellen Textfluss oder das aktuelle Element prüfen. Wenn Sie das aktuelle Element prüfen, überprüft FrameMaker nicht die nachfolgenden Elemente der untergeordneten Elemente des Elements. Wenn Sie z. B. im folgenden Beispiel das Element "Abschnitt" prüfen, stellt FrameMaker sicher, dass das Element "Überschrift", die beiden "Absatz"-Elemente und das Element "Liste" gültig sind. Die "Eintrag"-Elemente in der Liste werden jedoch nicht geprüft.

Nur die untergeordneten Elemente des Abschnitts werden geprüft.

Wenn das Dokument bedingten Text enthält, werden nur die angezeigten Versionen geprüft.

Sie können auch ein ganzes Buch mit allen dazugehörigen Dateien oder nur die Buchdatei oder nur das aktuelle Element in der Buchdatei überprüfen (siehe Prüfen von strukturierten Büchern).

So überprüfen Sie ein Dokument:

    1. Wählen Sie "Element> Prüfen".

    2. Aktivieren Sie die Option "Gesamtes Dokument", "Gesamtes Buch", "Aktueller Textfluss" oder "Aktuelles Element", um den Bereich für die Prüfung festzulegen.

    3. Um fehlende Elemente oder Attributwerte von der Suche auszuschließen, aktivieren Sie die Option "Fehlende Elemente ignorieren" oder "Fehlende Attributwerte ignorieren".

Wenn Sie diese Einstellungen wählen, überprüft FrameMaker nicht die Stellen, an denen erforderliche untergeordnete Elemente oder erforderliche Attributwerte fehlen. Sie können diese Einstellungen wählen, wenn Sie noch nicht versuchen, ein vollständiges Dokument aufzubauen.

    4. Klicken Sie auf "Starten".

FrameMaker beginnt die Überprüfung am Anfang des aktuellen Elements. Wenn Sie nur das aktuelle Element prüfen, wird das Element mit Einfügemarke bzw. das ausgewählte Element überprüft. Wenn mehrere Elemente ausgewählt sind, wird das erste Element der Auswahl überprüft.

    5. Wenn FrameMaker einen Fehler findet, klicken Sie erneut auf "Starten", sobald Sie mit der Überprüfung fortfahren können.

Im oberen Teil des Dialogfensters "Elementprüfung" wird das Tag des Elements und eine kurze Beschreibung des Problems angezeigt. (Unter Fehlermeldungen bei Prüfungen finden Sie Erläuterungen zu den möglichen Meldungen).

Element und Fehler identifiziert

Sie können den Fehler korrigieren, ignorieren oder auf "Als Spezialfall zulassen" klicken. Wenn Sie den Fehler als Sonderfall markieren, identifiziert FrameMaker den Fehler bei der nächsten Prüfung nicht.

    6. Wiederholen Sie Schritt 5, bis FrameMaker keine Fehler mehr findet.

Wenn FrameMaker das Ende des Dokuments erreicht, wird die Prüfung am Anfang des Dokuments fortgesetzt. Wenn FrameMaker das Ende eines Textflusses erreicht, wird die Prüfung beim nächsten Textfluss fortgesetzt.

Hinweis: Wenn FrameMaker beim Prüfen eines Buches feststellt, dass eine Datei im Buch über ungültigen Inhalt verfügt, wird Ihnen dies mitgeteilt. Eine detailliertere Evaluierung ist jedoch nur durch Öffnen und Prüfen der Datei möglich.

Beim Prüfen der Elemente in einem EDD werden die Attribute in if-then-Klauseln geprüft. Beispiel: Die möglichen Werte eines Attributs sind A oder B oder C und eine Kontextregel lautet If [attrval = "D"]. Dies wird als Fehler gekennzeichnet und als ungültige Struktur gemeldet, wenn die Elementdefinitionen importiert werden.

Ebenso, wenn bei den Textformatierungsregeln oder Präfix/Suffix-Regeln eines Elements Attributnamen in Bezugsdefinitionen verwendet werden, müssen der Attributname sowie Groß-/Kleinschreibung mit der Attributdefinition in der Definition des Elements übereinstimmen.

Wenn ein Attributwert auf den gleichen vorherigen Wert geändert wird, wird die Aktion nicht als Änderung gekennzeichnet. Dadurch verbessert sich die Leistung, da eine unnötige Wertüberprüfung entfällt.

So heben Sie alle Sonderfälle auf:

    1. Wählen Sie "Element > Prüfen".

    2. Klicken Sie auf "Spezialfälle löschen". FrameMaker löscht die Sonderfälle im Dokument, Textfluss oder Element, je nachdem, welcher Bereich im Dialogfenster gewählt wurde.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Suchen von Elementen und Attributen

Fehlermeldungen bei Prüfungen

Die folgenden Fehlermeldungen können oben im Dialogfenster "Elementprüfung" angezeigt werden. (In der Beschreibung steht Tag für ein Element-Tag, Name für einen Attributnamen und Wert für einen Attributwert.)

Aktueller Textfluss ist unstrukturiert

Der aktuelle Textfluss enthält keine Elemente.

Element ist nicht definiert

Das Element ist in dem Dokument nicht definiert. Möglicherweise haben Sie das Element aus einem anderen Dokument kopiert.

Fehlende(s) Element(e) vor Tag

Vor dem angegebenen Element fehlt mindestens ein erforderliches Element.

Am Ende wird mehr Inhalt benötigt

Mindestens ein zusätzliches untergeordnetes Element wird am Ende des aktuellen Elements benötigt.

Kein aktuelles Element

Es ist keine Einfügemarke oder Auswahl vorhanden. (Diese Meldung wird angezeigt, wenn für die Bereichsangabe "Aktuelles Element" gewählt wurde.)

Kein aktueller Textfluss

Es ist keine Einfügemarke oder Auswahl vorhanden. (Diese Meldung wird angezeigt, wenn für die Bereichsangabe "Aktueller Textfluss" gewählt wurde.)

Nicht Element der obersten Ebene

Das Element ist auf der höchsten Ebene im Dokument nicht zulässig.

<TEXT> in diesem Element nicht erlaubt

Das Element enthält Text, obwohl Text nicht zulässig ist.

<TEXT> ungültig an dieser Stelle

Das Element darf zwar Text enthalten, jedoch nicht an dieser Stelle.

Attribut Name verweist auf einen nicht definierten ID-Wert.

Das Attribut ist eine ID-Referenz und bezieht sich auf einen einmaligen ID-Wert, der im Dokument (oder im Buch, falls Sie ein Buch überprüfen) nicht vorhanden ist.

Attribut Name ist für dieses Element nicht definiert

Die Definition dieses Elements beinhaltet das Attribut Name nicht.

Dieses Element sollte ein Typ sein

Das Element hat einen falschen Typ (wobei Typ eine Grafik, Marke, Gleichung, Systemvariable oder ein Querverweis sein kann). Beispielsweise kann ein Querverweis-Element anstelle eines Querverweises Text enthalten.

Wert für Attribut Name muss Typ sein

Der Attributwert hat nicht den richtigen Typ für das Attribut.

Wert für das Attribut Name muss zwischen n und n liegen

Der numerische Wert des Attributs liegt außerhalb des festgelegten Bereichs.

Wert für Attribut Name gehört nicht zu den zugelassenen Auswahlmöglichkeiten

Der Wert für das Attribut muss einem der Werte aus dem Aufklappmenü für gültige Auswahlmöglichkeiten entsprechen.

Wert für Attribut Name muss einmalig sein

Ein einmaliger ID-Wert darf in allen Elementen eines Dokuments oder Buches nur einmal auftreten.

Für Attribut Name benötigter Wert

Das Attribut verfügt nicht über einen erforderlichen Wert.

Tag in diesem Zusammenhang ausgeschlossen

Das Element Tag ist aufgrund einer Ausschlussregel für das übergeordnete Element oder eines seiner vorausgehenden Elemente nicht zulässig.

Tag in diesem Element nicht erlaubt

Das Element Tag ist an keiner Position im übergeordneten Element zulässig.

Tag ungültig an dieser Stelle

Das Element Tag ist im übergeordneten Element zulässig, jedoch nicht an der aktuellen Position.


Grundlagen in FrameMaker / Arbeiten mit strukturierten FrameMaker-Dokumenten / Suchen von Elementen und Attributen

Korrigieren von Fehlern in Elementen

Nachdem Sie Fehler in Elementen und Attributen identifiziert haben, können Sie den Elementkatalog und die Strukturansicht als Hilfsmittel für die Korrektur verwenden.

So korrigieren Sie ein Element an einer ungültigen Position:

Verschieben Sie das Element an eine gültige Position (siehe Verschieben von Elementen) oder wandeln Sie es in ein an der aktuellen Position gültiges Element um (siehe Ändern von Elementtypen).

Sie können ein ungültiges Element auswählen. Wenn Sie eine Prüfung durchführen, wählt FrameMaker das Element für Sie aus. Wenn das Element ausgewählt ist, wird im Elementkatalog angezeigt, welche Elemente an dieser Position gültig sind.

Das Listeneintrag-Objekt ist an dieser Position gültig.

So korrigieren Sie eine Struktur, in der ein untergeordnetes Element fehlt:

Fügen Sie das erforderliche Element ein (siehe Einfügen von Elementen).

Sie können auf die Stelle klicken, an der ein Element fehlt. Wenn Sie eine Prüfung durchführen, platziert FrameMaker an dieser Stelle für Sie die Einfügemarke. Wenn sich die Einfügemarke an der Position befindet, an der das Element fehlt, werden die für diese Position gültigen Elemente im Elementkatalog angezeigt.

An dieser Position ist ein Element "Überschrift" erforderlich.

So korrigieren Sie ein Element mit ungültigem Inhalt (mit dem Textausschnitt <INHALT UNGÜLTIG>):

Ändern Sie den Elementtyp in einen Typ um, der diesen Inhalt zulässt (siehe Ändern von Elementtypen).

So korrigieren Sie ungültige Attributwerte:

Ändern Sie den Attributwert in einen für das Attribut gültigen Wert (siehe Eingeben oder Bearbeiten von Attributwerten für bereits im Dokument vorhandene Elemente).

So entfernen Sie nicht definierte Attribute:

Wählen Sie das Element mit dem nicht definierten Attribut aus, öffnen Sie das Dialogfenster "Attribute", markieren Sie das Attribut und klicken Sie auf "Attribut löschen". Im nächsten Dialogfenster entfernen Sie das Attribut für das aktuelle Element oder für alle Elemente, die dieses Attribut aufweisen.

So lösen Sie einen Querverweis mit einer ungültigen ID:

Wählen Sie den Querverweis aus, wählen Sie "Spezial > Querverweis" und wechseln Sie zu einer Quelle, die eine gültige ID enthält (siehe Verwalten von Querverweisen).


Grundlagen in FrameMaker

Strukturierte Dokumente

Die meisten Dokumente verfügen über eine implizite Struktur. Jeder Dokumenttyp besteht einschließlich seiner Inhalte aus logischen Einheiten, die in einer einheitlichen Reihenfolge und einer bestimmten Hierarchie dargestellt werden. In FrameMaker können Sie explizit mit der Dokumentstruktur arbeiten, indem Sie den Dokumentinhalt – also seine Abschnitte, Überschriften, Absätze, Abbildungen, Tabellen usw. – in als Elemente bezeichnete logische Einheiten organisieren. (Weitere Informationen hierzu finden Sie unter Erläuterung von Elementen.) Gemeinsam bilden die Elemente eine Hierarchie, die die Struktur repräsentiert.

Beispielsweise kann ein Element "Abschnitt" für einen Abschnitt eines Buches ein Element "Überschrift" mit Überschriftstext, ein Absatzelement mit Haupttext und ein Listenelement mit mehreren Listeneintrag-Elementen enthalten.

A: Abschnittselement, das den gesamten Inhalt im Abschnitt umfasst B: Überschriftelement C: Absatzelement D: Listenelement E: Listeneintrag-Elemente im Listenelement


Grundlagen in FrameMaker / Strukturierte Dokumente

Strukturierte Formate FrameMaker

Mithilfe von FrameMaker können Sie strukturierte Dokumente im SGML- und im XML-Format (einschließlich XHTML 1.0) importieren und exportieren. Nachdem Sie eine strukturierte Datei importiert haben, ist diese keine SGML- oder XML-Datei mehr, sondern ein strukturiertes FrameMaker-Dokument. Wenn das Dokument wieder sein ursprüngliches Format erhalten soll, speichern Sie es als SGML oder XML (siehe Speichern eines strukturierten Dokuments im SGML- oder XML-Format).

SGML

Standard Generalized Markup Language (SGML) ist der internationale Standard für alle Textauszeichnungssprachen für Datenaustausch und -speicherung.

SGML ist keine verfahrensorientierte, sondern eine beschreibende Textauszeichnungssprache. Das heißt, dass das Dokument von unterschiedlichen Systemen verarbeitet werden kann, von denen jedes unterschiedliche Verarbeitungsanweisungen in den jeweiligen Abschnitten ausführt. SGML-Dokumente können von einem zum anderen System (sowohl Hardware als auch Software) weitergegeben werden, ohne dass Daten verloren gehen.

SGML war die erste Sprache, die DTD (Document Type Definition) eingeführt hat, wodurch das Dokument durch seine Komponenten und Struktur formell definiert wird. Dokumente des gleichen Typs können überprüft und auf gleiche Weise verarbeitet werden.

Ein Dokument, das der DTD-Struktur entspricht, wird als gültig bezeichnet.

XML

Extensible Markup Language (XML) ist ein allgemeines Format für die Darstellung von strukturierten Informationen, vor allem für das Web. Wie HTML und SGML verlangt XML die Verwendung von Elementen und Struktur. XML unterscheidet sich darin von HTML, dass es erweiterbar ist und Benutzer spezielle Sätze von Element-Tags definieren können. XML ist eine Unterkategorie von SGML und kann im Wesentlichen zum gleichen Zweck wie SGML verwendet werden, jedoch ohne viele der komplexen SGML-Funktionen.

Sie können XML für die Speicherung von Daten in XML-Repositories verwenden, wodurch Sie Material leicht wieder verwenden, nach Text suchen, mit anderen Autoren zusammenarbeiten und Dokumente verwalten können. XML sowie vorlagengesteuerte Arbeitsabläufe in FrameMaker können für vielseitige Veröffentlichungszwecke verwendet werden.

Ein XML-Dokument, das der DTD-Struktur entspricht, wird als gültig bezeichnet. Ein XML-Dokument, das mit den Standard-XML-Spezifikationen übereinstimmende Tags verwendet, wird als wohlgeformt bezeichnet.

XHTML 1.0

Extensible HyperText Markup Language (XHTML) ist eine auf XML basierende Erweiterung von HTML, die für die Arbeit mit XML-basierten Anwendungen entwickelt wurde. Sie kann mit Standard-XML-Werkzeugen angezeigt, bearbeitet und geprüft werden. Die Verwendung von XHTML ist eine einfache Art der Migrierung von HTML zu XML, wobei die Kompatibilität in beide Richtungen gewahrt wird. Weitere Informationen zu HTML finden Sie unter HTML.


Grundlagen in FrameMaker / Strukturierte Dokumente

Strukturierte Schablonen

Eine Schablone ist ein Dokument, das Einstellungen verwendet, die Sie mehrfach verwenden können. Sie können aus einer Schablone ein neues Dokument erstellen, das sämtliche Einstellungen der Schablone besitzt, oder Sie können später bestimmte Einstellungen der Schablone importieren. FrameMaker-Schablonen versehen Ihre Dokumente mit Layout und Formatierung und legen ihre Strukturanforderungen fest. Im Lieferumfang des strukturierten FrameMaker sind strukturierte Schablonen für Briefe, Notizen, Faxe, Umschläge, Meldungen, Gliederungen, Infoblätter, Bücher, FAQs und Bücher mit nur einer Quelle enthalten.

In Schablonen können die folgenden Einstellungen gespeichert werden:

    Elementdefinitionen, die zulässige Inhalte, Attribute und Formate für Elemente festlegen

    Absatz-, Zeichen- und Tabellenformate, die in den Elementdefinitionen Formatinformationen verwenden

    Seitenlayouts, die die Anzahl und Position von Spalten auf Seiten, sowie Hintergrundelemente, wie laufende Kopfzeilen, festlegen

    Referenzseiten, auf denen wiederholt verwendete Grafik- und Formatinformationen gespeichert werden

    Als Platzhalter verwendete Variablen für von FrameMaker aktualisierten Text

    Formatinformationen für Querverweise, Gleichungen und bedingten Text

    Definitionen für Farben, die Text und Objekten zugewiesen werden können

    Für das gesamte Dokument gültige Einstellungen, einschließlich Fußnoteneinstellungen, spezielle Markentypen und Höhenausgleich für den Zeilenabstand

    Spezifikationen für kombinierte japanische und westliche Schriftarten (auf Systemen mit japanischen Spracheinstellungen)

Hinweis: Wenn Sie mit strukturierten Dateien arbeiten, wurden von dem Anwendungsentwickler möglicherweise spezielle Dokumente angelegt, die die Umwandlung aus der und in die strukturierte Anwendung steuern. Diese Dokumente können eine Schablone beinhalten, die strukturierte Dateien in FrameMaker formatiert. Diese Schablone wird automatisch angewendet, wenn Sie aus einer strukturierten Anwendung importieren.


Grundlagen in FrameMaker / Strukturierte Dokumente

Verwenden von strukturierten Dokumenten in FrameMaker

Im normalen Arbeitsablauf beginnen Sie die Arbeit mit einem strukturierten Dokument, indem Sie ein neues Dokument erstellen (meistens aus einer Schablone), oder indem Sie ein vorhandenes Dokument im strukturierten FrameMaker öffnen.

Ein strukturiertes Dokument enthält mehr als nur die von Ihnen eingefügten Elemente und Inhalte. Es kann auch gespeicherte Seitenlayouts, Kataloge mit Elementdefinitionen und Formaten sowie andere Einstellungen enthalten, die Ihre Arbeit erleichtern und beschleunigen. Diese Einstellungen stammen normalerweise aus der Dokumentschablone.

Eine Schablone bildet die Grundlage für neue Dokumente.


Grundlagen in FrameMaker / Strukturierte Dokumente / Verwenden von strukturierten Dokumenten in FrameMaker

Anlegen von Dokumenten auf der Basis strukturierter Schablonen

Wenn Sie aus einer strukturierten Schablone ein Dokument anlegen, ist das Dokument eine exakte Kopie der Schablone mit deren Elementdefinitionen und anderen Einstellungen sowie sämtlichen Inhalten.

In der Regel verwenden Sie eine spezielle Schablone, die Teil Ihrer Anwendung ist. FrameMaker wird jedoch auch mit einigen vordefinierten strukturierten Schablonen für Berichte, Grafiken und Gliederungen geliefert.

Wenn Sie in einer Schablone arbeiten, hilft Ihnen FrameMaker bei der Organisation von Elementen in einer gültigen Struktur und nimmt Formatierungen automatisch vor. Sie brauchen keine Kenntnisse der XML- oder SGML-Syntax zu besitzen, um XML- oder SGML-kompatible Dokumente zu erstellen.

Ihr Entwickler stellt eventuell eine Dokumentation über die Verwendung der Elemente bereit, die für die Anwendung definiert wurden. Wenn Sie ein unstrukturiertes Dokument anlegen möchten, verwenden Sie entweder eine unstrukturierte Schablone oder Sie beginnen mit einem neuen leeren Dokument. Weitere Informationen finden Sie unter Erstellen von Dokumenten.

So erstellen Sie ein Dokument auf der Grundlage einer strukturierten Schablone:

    1. Starten Sie FrameMaker im strukturierten Modus. Wenn FrameMaker noch nicht im strukturierten Modus ausgeführt wird, klicken Sie auf "Datei > Voreinstellungen > Allgemein", wählen unter "Produktoberfläche" die Option "Strukturierter FrameMaker", klicken auf "Zuweisen" und starten FrameMaker neu.

    2. Wählen Sie "Datei > Neu > Dokument". Unter UNIX können Sie auch im FrameMaker-Hauptfenster auf "Neu" klicken.

    3. Wechseln Sie zur gewünschten Schablone. Wenn Sie eine strukturierte Schablone des strukturierten FrameMaker verwenden möchten, finden Sie diese im Ordner "struktur" innerhalb des Ordners "schabl" (Windows), der sich in einem der folgenden Verzeichnisse befindet:

    (Windows) Der Ordner "FrameMaker8".

    (UNIX) Im Ordner "fminit/[Sprache]/schabl/struktur", der sich im FrameMaker-Installationsverzeichnis befindet ([Sprache] steht für die von Ihnen verwendete Sprache, z. B. Deutsch)

    4. Wählen Sie die Schablone aus und klicken Sie auf "Neu" (Windows) oder auf "Anlegen" (UNIX).

    5. Wenn die Schablone geöffnet wird, passen Sie die Größe des Dokumentfensters an, sodass die Seite vollständig angezeigt wird. Klicken Sie anschließend zum Öffnen der Strukturansicht, die die Strukturhierarchie anzeigt, auf die Schaltfläche "Strukturansicht" [image] in der oberen rechten Ecke des Dokumentfensters. Positionieren Sie die beiden Fenster so, dass Sie beide gleichzeitig sehen können. Klicken Sie zum Anzeigen des Elementkatalogs auf die Schaltfläche "Elementkatalog".

A: Schablone in einem Dokumentfenster B: Elementkatalog C: Strukturansicht

    6. Führen Sie einen der folgenden Schritte aus:

    Fügen Sie für alle erforderlichen und optionalen Elemente Text hinzu. Sie können Text hinzufügen, indem Sie zum Platzieren der Einfügemarke in das Dokumentfenster klicken (siehe Arbeiten mit Text in strukturierten Dokumenten und Eingeben von Text in ein strukturiertes Dokument).

    Fügen Sie neue Elemente aus dem Elementkatalog ein (siehe Hinzufügen von Elementen).

    Blenden Sie die Elemente in der Strukturansicht ein, indem Sie auf das + (Pluszeichen) auf der linken Seite der Elementrechtecke klicken. Blenden Sie sie aus, indem Sie auf das - (Minuszeichen) auf der linken Seite klicken (siehe Aus- und Einblenden von Elementen).

    Zeigen Sie die Attribute der Elemente an, indem Sie auf das + (Pluszeichen) auf der rechten Seite des Elementrechtecks klicken (siehe Ein- und Ausblenden von Attributen für ein Element).

    Ändern Sie die Elementattribute (siehe Zuweisen von Attributwerten).

    Ordnen Sie Elemente oder Abschnitte im Dokument neu an, oder strukturieren Sie sie um (siehe Verschieben von Elementen).

    Fügen Sie Querverweise hinzu (siehe Arbeiten mit Querverweisen in strukturierten Dokumenten).

    Bearbeiten Sie die aktuelle Struktur des Dokuments: Ändern Sie den Elementtyp, fügen Sie zwei Elemente zusammen, teilen Sie ein Element in zwei, oder gliedern Sie ein Element in ein neues übergeordnetes Element ein (siehe Bearbeiten von Elementen).

    Überprüfen Sie das Dokument auf eine gültige Struktur für den Export in XML oder SGML (siehe Suchen und Korrigieren von Fehlern).

    Speichern oder exportieren Sie das Dokument in XML oder SGML (siehe Speichern eines strukturierten Dokuments im SGML- oder XML-Format).


Grundlagen in FrameMaker / Strukturierte Dokumente / Verwenden von strukturierten Dokumenten in FrameMaker

Erstellen eines neuen strukturierten Dokuments

Wenn Sie ein strukturiertes Dokument neu erstellen möchten, stellen Sie sicher, dass Sie über ein EDD und eine Strukturanwendung verfügen (siehe Strukturierte Anwendungen). Sie können die mit FrameMaker gelieferte EDD-Datei und Beispiel-Strukturanwendung verwenden (siehe die Unterordner im Ordner "struktur") oder Ihre eigene Datei bzw. Anwendung erstellen. Informationen zur Erstellung einer strukturierten Anwendung und eines EDD finden Sie im "Structured Application Developer’s Guide", der sich im Unterordner "handbch" des FrameMaker 8-Ordners befindet.

So erstellen Sie ein neues strukturiertes Dokument:

    1. Starten Sie FrameMaker im strukturierten Modus.

    2. Wählen Sie "Datei > Neu > Dokument".

    3. Wählen Sie "Hochformat" oder "Querformat", um die Seitenausrichtung festzulegen.

    4. Öffnen Sie ein strukturiertes Dokument oder ein EDD, das die Elemente enthält, die Sie verwenden möchten, und importieren Sie anschließend Elemente in das neue Dokument (siehe Importieren von Elementdefinitionen).

    5. Fügen Sie dem Dokument Text und Elemente hinzu (siehe Hinzufügen von Elementen).

    6. Speichern Sie das Dokument als strukturiertes FrameMaker-Dokument oder in einem anderen gewünschten Format (siehe Speichern eines strukturierten Dokuments im SGML- oder XML-Format).


Grundlagen in FrameMaker / Strukturierte Dokumente

Öffnen und Speichern von strukturierten Dateien

Sie können in FrameMaker jede strukturierte Datei öffnen und verwenden, die über eine verknüpfte Anwendung verfügt. Die Inhalte, Elemente und Attribute der Datei bleiben erhalten und die Datei sieht aus wie ein reguläres FrameMaker-Dokument.

Mit dem strukturierten FrameMaker können Sie XML- und SGML-Dokumente öffnen. Nach der Bearbeitung der strukturierten Datei können Sie sie wieder in ihrem ursprünglichen Format, beispielsweise XML oder SGML, speichern. Alle Änderungen, die Sie an Inhalten, Elementen und Attributen vorgenommen haben, bleiben im Allgemeinen erhalten. (Fragen Sie Ihren Entwickler nach eventuellen Beschränkungen Ihrer Anwendung bei der Zuordnung zwischen strukturierten Dateien und FrameMaker.)

Strukturierte Anwendungen

Eine strukturierte Anwendung ist eine Sammlung von Dateien, die beschreibt, wie eine strukturierte Datei in FrameMaker verarbeitet werden soll. Die Anwendung verfügt in der Regel über ein DTD, in dem Elemente, Attribute und andere Objekte, wie Lese-/Schreibregeln und eine Importschablone definiert werden.

Damit Sie mit einer strukturierten Datei arbeiten können, muss eine Anwendung mit dieser Datei verknüpft sein. Normalerweise richtet ein Entwickler diese Anwendung für Sie ein und verknüpft sie mit den entsprechenden Dateien. Sie können die Anwendung beim Öffnen oder Speichern auch selbst auswählen oder sie ändern, während die Datei offen ist.

Wichtig: Verwenden Sie die für die Datei entworfene Anwendung. Sollten Sie nicht wissen, welche Anwendung Sie verwenden sollen, fragen Sie Ihren Anwendungsentwickler.

Sie können SGML- oder XML-Dateien auch ohne die Verwendung einer Anwendung öffnen, beispielsweise, wenn Sie die Datei nur durchsuchen möchten, oder wenn Sie nicht wissen, welche Anwendung Sie verwenden sollen, und die Anwendung später auswählen. Die Datei enthält zwar eine Struktur, aber nur allgemeine Formatierungen (mit dem gesamten Text in Standardabsätzen). Objekte wie Tabellen und Grafiken werden im Allgemeinen nicht importiert. Sie können in diesem Fall die Struktur und den Inhalt der Datei bearbeiten, möglicherweise ist es jedoch nicht möglich, sie erneut im strukturierten Format (XML oder SGML) zu speichern, da eventuell einige Zuordnungsinformationen nicht verfügbar sind.

SGML- oder XML-Dateien enthalten keine Angaben darüber, wie ihre Inhalte zu formatieren sind. Möglicherweise besitzt jedoch Ihre strukturierte Anwendung eine Schablone, durch die die Datei in FrameMaker formatiert wird. Wenn Sie eine Anwendung ohne Schablone verwenden, wird die Datei unter Verwendung von Standardformateinstellungen geöffnet.


Grundlagen in FrameMaker / Strukturierte Dokumente / Öffnen und Speichern von strukturierten Dateien

Öffnen von strukturierten Dateien

Sie können strukturierte Dateien wie alle anderen Arten von Dateien öffnen. Es wird ein neues FrameMaker-Dokument angezeigt, das alle Inhalte der strukturierten Datei enthält.

Wenn Sie die Strukturmarkierungen direkt betrachten oder bearbeiten möchten, können Sie die Datei als Text öffnen (siehe Öffnen von SGML-, XML-, MIF- und MML-Dateien als Textdateien).

Die Standard-Codierungseinstellungen zum Öffnen strukturierter Dateien sind ISO-8859-1 für SGML und UTF-8 für XML. Wenn die ursprünglichen Dateien abweichende Codierungseinstellungen besitzen, verwendet FrameMaker diese statt der Standardeinstellungen.

So öffnen Sie eine strukturierte Datei:

    1. Wählen Sie im strukturierten FrameMaker "Datei > Öffnen". In UNIX-Systemen können Sie auch im FrameMaker-Hauptfenster auf "Öffnen" klicken.

    2. Suchen Sie die zu öffnende Datei und klicken Sie auf "Öffnen". Wenn der Datei eine Anwendung zugewiesen wurde, wird das Dokument geöffnet und Sie können mit der Bearbeitung beginnen.

    3. Wenn das Dialogfenster "Strukturierte Anwendung verwenden" angezeigt wird, wählen Sie aus dem Aufklappmenü einen Anwendungsnamen und klicken Sie auf "Zuweisen": Führen Sie anschließend eine der folgenden Aktionen aus:

    Wählen Sie den Namen einer Anwendung, um der Datei eine Anwendung zuzuordnen.

    Um die Standardzuweisung und keine Lese-/Schreibregeln auszuwählen, wählen Sie <Keine Anwendung>. Diese Option können Sie beispielsweise verwenden, wenn Sie eine Datei nur durchsuchen und nicht speichern möchten.

Hinweis: Wenn Zeichen in einer XML-Originaldatei keine Zuordnungen in dem FrameMaker-Dokument besitzen, werden die Zeichen als unbekannt gekennzeichnet. Sie werden in FrameMaker nicht angezeigt, bleiben jedoch beim XML-Export erhalten.


Grundlagen in FrameMaker / Strukturierte Dokumente / Öffnen und Speichern von strukturierten Dateien

Konvertieren von strukturierten Dateien in das FrameMaker-Format, ohne sie zu öffnen

Sie können in FrameMaker mehrere strukturierte Dateien konvertieren, ohne sie zu öffnen. Die zu konvertierenden Dateien sollten entweder der einzige Inhalt eines einzelnen Ordners sein oder innerhalb eines Ordners eine einheitliche Dateinamenerweiterung besitzen und sie sollten alle der gleichen strukturierten Anwendung zugeordnet sein.

So konvertieren Sie strukturierte Dateien in das FrameMaker-Format:

    1. Wählen Sie "Strukturierungswerkzeuge > Dienstprogramme > Strukturierte Dokumente konvertieren".

    2. Wählen Sie im Aufklappmenü "Anwendung" eine Anwendung für die konvertierten Dateien.

    3. Geben Sie im Bereich "Strukturierte Eingabedokumente" Speicherort und Dateinamenerweiterung der ursprünglichen Dateien an. Wenn Sie nach dem Speicherort suchen müssen, klicken Sie auf die Schaltfläche "Durchsuchen" und suchen Sie die Datei.

Die Dateinamenerweiterung ist erforderlich. Sie können im Texteingabefeld "Suffix" ein Sternchen (*) eingeben, um alle Dateien im Ordner zu konvertieren.

    4. Geben Sie im Bereich "FrameMaker-Ausgabedateien" einen Speicherort und eine Dateinamenerweiterung für die FrameMaker-Dateien an. Wenn Sie nach dem Speicherort suchen müssen, klicken Sie auf die Schaltfläche "Durchsuchen" und suchen Sie die Datei.

Die Dateinamenerweiterung ist optional. Wenn Sie das Texteingabefeld "Suffix" leer lassen, tragen die konvertierten Dateien keine Dateinamenerweiterung. Wenn Sie * eingeben, erhalten die Dateien dieselbe Erweiterung wie die ursprünglichen strukturierten Dateien. Speichern Sie die strukturierten Dateien in einem anderen Ordner als die konvertierten Dateien, wenn Sie * verwenden.

    5. Um einen vorhandenen Stapel konvertierter Dateien im Ausgabeordner zu überschreiben, aktivieren Sie die Option "Überschreiben von bestehenden Dateien zulassen".

Wichtig: Verwenden Sie diese Option für das Überschreiben einer früheren Version konvertierter Dateien mit demselben Namen. Überschreiben Sie nicht die ursprünglichen strukturierten Dateien. Legen Sie die strukturierten Dateien entweder in einem separaten Ordner ab oder geben Sie ihnen eine andere Dateinamenerweiterung.

    6. Klicken Sie auf "Konvertieren".


Grundlagen in FrameMaker / Strukturierte Dokumente / Öffnen und Speichern von strukturierten Dateien

Ändern der zugeordneten strukturierten Anwendung

Wenn Sie eine strukturierte Datei öffnen, können Sie die mit ihr verbundene Anwendung ändern. Die neue Anwendung wird für die Datei verwendet, wenn die Datei das nächste Mal geöffnet oder als strukturiertes Dokument gespeichert wird.

Mit FrameMaker 8 können Sie ein strukturiertes Buch mit der DITA-Book- FM-Anwendung oder ein strukturiertes Dokument mit einer DITA-Map-FM- oder DITA-Topic-FM-Anwendung verknüpfen. Mit der DITA-Book- FM-Anwendung können Sie ein FrameMaker-Buch erstellen, das alle Dateien in einer geöffneten DITA Map (<dita>, <ditamap> oder <map>) umfasst. Die in dieser Anwendung verwendete EDD und strukturierte Schablone können für die Ausgabe eines gedruckten Dokuments oder einer PDF-Datei angepasst werden. Mit der DITA-Map-FM-Anwendung können Sie DITA Maps erstellen und bearbeiten (sowohl Dateien des Typs .map als auch .ditamap). Mit der DITA-Topic-FM-Anwendung können Sie die Informationstypen Topic, Konzept, Referenz oder Task autorisieren. Bei Bedarf kann das EDD und die strukturierte Schablone zur Bildschirmanzeige oder Topic-Prüfung angepasst werden.

Wichtig: Fragen Sie Ihren Entwickler, bevor Sie die Anwendung wechseln. Die besten Ergebnisse erzielen Sie, wenn Sie die Anwendung verwenden, die für Ihre Datei bestimmt ist.

Wenn Sie die Anwendung für mehrere Dateien ändern möchten, können Sie den Entwickler bitten, dies in einer Anwendungsdefinition festzulegen, sodass Sie dies nicht für jede Datei einzeln tun müssen.

So ändern Sie die zugeordnete strukturierte Anwendung:

    1. Klicken Sie in das zu ändernde Dokument.

    2. Wählen Sie "Strukturierungswerkzeuge > Strukturierte Anwendung zuweisen". Wählen Sie im Aufklappmenü den Namen der Anwendung und klicken Sie auf "Zuweisen".


Grundlagen in FrameMaker / Strukturierte Dokumente / Öffnen und Speichern von strukturierten Dateien

Konvertieren von strukturierten FrameMaker-Dokumenten in SGML oder XML

Sie können mehrere strukturierte Dokumente in SGML oder XML konvertieren, ohne jedes Dokument einzeln speichern zu müssen. Die zu konvertierenden Dateien sollten entweder der einzige Inhalt eines einzelnen Ordners sein oder innerhalb eines Ordners eine einheitliche Dateinamenerweiterung besitzen, und sie sollten alle der gleichen strukturierten Anwendung zugeordnet sein.

Informationen zum Öffnen von SGML oder XML als Text finden Sie unter Öffnen von SGML-, XML-, MIF- und MML-Dateien als Textdateien.

So speichern Sie FrameMaker-Dokumente in einem strukturierten Format:

    1. Wählen Sie "Strukturierungswerkzeuge > Dienstprogramme > Dokumente in strukturiertes Format konvertieren".

    2. Wählen Sie im Aufklappmenü "Anwendung" eine Anwendung für die konvertierten Dateien.

    3. Geben Sie im Bereich "FrameMaker-Eingabedateien" den Speicherort und die Dateinamenerweiterung der FrameMaker-Dateien an. Wenn Sie nach dem Speicherort suchen müssen, klicken Sie auf die Schaltfläche "Durchsuchen" und suchen Sie die Datei.

Die Dateinamenerweiterung ist erforderlich. Sie können im Texteingabefeld "Suffix" ein Sternchen (*) eingeben, um alle Dateien im Ordner zu konvertieren.

    4. Geben Sie im Bereich "Strukturierte Ausgabedokumente" einen Speicherort und eine Dateinamenerweiterung für die konvertierten Dateien an. Wenn Sie nach dem Speicherort suchen müssen, klicken Sie auf die Schaltfläche "Durchsuchen" und suchen Sie die Datei.

Die Dateinamenerweiterung ist optional. Wenn Sie das Texteingabefeld "Suffix" leer lassen, tragen die konvertierten Dateien keine Dateinamenerweiterung. Wenn Sie * eingeben, erhalten die Dateien dieselbe Erweiterung wie die FrameMaker-Dateien. Speichern Sie die FrameMaker-Dateien in einem anderen Ordner als die konvertierten Dateien, wenn Sie * verwenden.

    5. Um einen vorhandenen Stapel konvertierter Dateien im Ausgabeordner zu überschreiben, aktivieren Sie die Option "Überschreiben von bestehenden Dateien zulassen".

Wichtig: Verwenden Sie diese Option für das Überschreiben einer früheren Version konvertierter Dateien mit demselben Namen. Überschreiben Sie nicht die FrameMaker-Dateien. Legen Sie diese Dateien entweder in einem separaten Ordner ab oder geben Sie ihnen eine andere Dateinamenerweiterung.

    6. Klicken Sie auf "Konvertieren".


Grundlagen in FrameMaker / Strukturierte Dokumente / Öffnen und Speichern von strukturierten Dateien

Speichern eines strukturierten Dokuments im SGML- oder XML-Format

Sie können alle strukturierten FrameMaker-Dokumente als SGML oder XML speichern. Der Inhalt, die Elemente und die Attribute des Dokuments bleiben erhalten. Formatierungen gehen jedoch verloren. Sie können in einem anderen strukturierten Dokumenttyp als dem ursprünglichen (beispielsweise SGML oder XML) speichern. Möglicherweise treten jedoch auf Grund von Unterschieden in den DTDs Fehler auf.

Wenn Sie Unicode-Inhalt als XML-Datei speichern, gibt Adobe FrameMaker 8 die Codierung automatisch an. Standardmäßig verwendet Adobe FrameMaker 8 das UTF-8-Codierungsformat.

Bevor Sie ein Dokument im SGML- oder XML-Format speichern, sollten Sie es prüfen und alle Fehler in den Elementen und Attributen korrigieren (siehe Überprüfen von Dokumenten). Andernfalls könnten die Markierungen ungültig werden.

Achten Sie beim Speichern eines XML-Dokuments darauf, dass gültige XML-Elementnamen mit einem Buchstaben beginnen und nur alphanumerische Zeichen, Punkte oder Bindestriche enthalten. Leerzeichen, Unterstriche oder andere Zeichen in XML-Elementnamen sind ungültig und werden entweder zu einem Bindestrich (-) konvertiert oder erzeugen einen Fehler.

Kopfzeilen, Tabellen und Referenzseiten werden nicht exportiert, für die Namen der Standard-Tags werden einfach die Formatnamen verwendet

Die Standard-Codierungseinstellungen zum Exportieren strukturierter Dokumente sind ISO-8859-1 für SGML und UTF-8 für XML. Wenn das strukturierte Dokument eine importierte SGML- oder XML-Datei ist, verwendet FrameMaker die Codierungseinstellungen der Originaldatei anstatt der Standardeinstellungen.

So speichern Sie ein Dokument im SGML- oder XML-Format:

    1. Wählen Sie "Datei > Sichern unter".

    2. Geben Sie den Dateinamen und den Speicherort an. Sie können dem Dateinamen die entsprechende Erweiterung (wie .sgm oder .xml) hinzufügen.

    3. Wählen Sie im Aufklappmenü die Option "SGML" oder "XML" und klicken Sie auf "Sichern". Wenn dem Dokument eine Anwendung zugeordnet ist, wird es gespeichert.

    4. Wenn das Dialogfenster "Strukturierte Anwendung zuweisen" angezeigt wird, wählen Sie aus dem Aufklappmenü einen Anwendungsnamen und klicken Sie auf "Fortfahren". Führen Sie anschließend eine der folgenden Aktionen aus:

    Wählen Sie den Namen einer Anwendung, um dem Dokument eine Anwendung zuzuordnen.

    Um die Standardzuweisung und keine Lese-/Schreibregeln auszuwählen, wählen Sie <Keine Anwendung>.

Wenn FrameMaker beim Speichern eines Dokuments Fehler in der Struktur findet, listet das Programm die entsprechenden Fehlermeldungen in einer schreibgeschützten Fehlerprotokolldatei auf. Wenn sich die Meldung auf einen Fehler in dem FrameMaker-Dokument bezieht, wird sie mit dem Dokument verknüpft. Bei den meisten Fehlern können Sie auf die Meldung klicken, um zum Ort des Fehlers zu gelangen.

Importieren Sie Elementdefinitionen, wenn Sie das strukturierte Dokument öffnen (siehe Importieren von Elementdefinitionen). Vermutlich müssen Sie noch einige Korrekturen an ihren Strukturen vornehmen.


Grundlagen in FrameMaker / Strukturierte Dokumente

Importieren von Eigenschaften aus einer Schablone

Sie können Elementdefinitionen und andere Eigenschaften aus jedem FrameMaker-Dokument in Ihr Dokument importieren. Normalerweise ist dieses andere Dokument eine Schablone, die Sie nicht für die Erstellung des Dokuments verwendet haben. (Wenn Sie Ihr Dokument mit der entsprechenden Schablone erstellt haben, ist es nicht nötig, die Eigenschaften zu importieren. Das Dokument verfügt bereits über die erforderlichen Eigenschaften.)

Wenn die Dokumentschablone überarbeitet wurde, sollten Sie einen erneuten Import aus der Schablone durchführen, um Ihr Dokument zu aktualisieren.

Sie können Eigenschaften auch in alle Dateien eines Buches gleichzeitig importieren (siehe Importieren von Formaten in ein strukturiertes Buch).


Grundlagen in FrameMaker / Strukturierte Dokumente / Importieren von Eigenschaften aus einer Schablone

Importieren von Formaten

Sie können zahlreiche Formatinformationen importieren, einschließlich Seitenlayouts, Absatz- und Tabellenformaten, Variablen- und Farbdefinitionen sowie Einstellungen für bedingten Text.

So importieren Sie Formate:

    1. Öffnen Sie die Schablone mit den Formaten. Die Schablone muss benannt und gespeichert sein.

    2. Öffnen Sie das Dokument oder das Buch, das Sie aktualisieren möchten. Wenn ein Buchfenster aktiv ist, wählen Sie die zu aktualisierenden Dokumente aus.

    3. Wählen Sie im zu aktualisierenden Dokument oder Buch "Datei > Importieren > Formate".

    4. Wählen Sie die Schablone aus dem Aufklappmenü "Import aus Dokument". Das Menü listet alle geöffneten benannten Dokumente auf.

Sie können auch das aktuelle Dokument auswählen, um die Formate, die das Dokument bereits besitzt, erneut zuzuweisen. Dieses Schablone eignet sich besonders zum Entfernen von Formatänderungen, wie in Schritt 6 beschrieben.

    5. Wählen Sie die Einstellungen für "Importieren" und "Aktualisieren", die dem aktuellen Dokument zugewiesen werden sollen. Weitere Informationen zu den Einstellungen finden Sie unter Importieren von Formateinstellungen.

    Wenn Sie Querverweisformate, FrameMath-Definitionen oder Variablendefinitionen aktualisieren und eines dieser Elemente Zeichenformate verwendet, wählen Sie zusätzlich "Zeichenformate", sodass dem Dokument alle neuen Formate hinzugefügt werden.

    Wenn die HTML-Zuweisung verändert wurde, wählen Sie "Referenzseiten".

    6. Wenn Sie Formatänderungen entfernen möchten, die nicht in Katalogformaten gesichert sind, gehen Sie wie folgt vor:

    Um Seitenumbrüche, die nicht Teil eines Absatzformats sind, zu entfernen, wählen Sie "Manuelle Seitenumbrüche".

    Um irreguläre Zuweisungen aus Absätzen, Zeichen und dem Seitenlayout sowie der Tabellenformatierung zu entfernen, wählen Sie "Manuelle Format-/Layoutänderungen".

Wichtig: In den meisten Fällen sollten Sie die Option "Manuelle Format-/Layoutänderungen" in einem strukturierten Dokument nicht verwenden, da die Elementdefinitionen spezielle Formate verwenden könnten. Weitere Informationen hierzu finden Sie unter Irreguläre Formate.

    7. Klicken Sie auf "Importieren".


Grundlagen in FrameMaker / Strukturierte Dokumente / Importieren von Eigenschaften aus einer Schablone

Importieren von Formateinstellungen

Wenn Sie Formate importieren, fügt FrameMaker die neuen Informationen in das Dokument ein. Wenn Sie beispielsweise Tabellenformate importieren, werden die Formate dem Tabellenkatalog hinzugefügt. Wenn ein Format im Katalog bereits denselben Namen besitzt wie ein importiertes Format, ersetzt das importierte Format das ursprüngliche. Alle nicht überschriebenen Formate verbleiben jedoch im Katalog.

Absatzformate

Der Absatzformat-Katalog der Schablone wird in das Dokument eingelesen und alle Formate im Katalog werden neu auf das Dokument angewendet.

Zeichenformate

Der Zeichenformat-Katalog der Schablone wird in das Dokument eingelesen und alle Formate im Katalog werden neu auf das Dokument angewendet.

Seitenlayouts

Die Vorgabeseiten der Schablone werden in das Dokument eingelesen und Arbeitsseiten werden mit den Änderungen in den Vorgabeseiten aktualisiert. Wenn Schablone und Dokument eine Vorgabeseite gleichen Namens enthalten, ersetzt die Vorgabeseite aus der Schablone diejenige des Dokuments. FrameMaker kopiert die Einstellungen der Änderungsbalken, alle Einstellungen aus den Dialogfenstern "Format" und "Seitenumbruch" sowie die meisten Einstellungen aus dem Dialogfenster "Darstellungsoptionen".

Tabellenformate

Der Tabellenformat-Katalog der Schablone und die Lineaturstile werden in das Dokument eingelesen und alle Formate im Katalog werden neu auf das Dokument angewendet.

Farbdefinitionen

Die Farbdefinitionen und Farbauszüge der Schablone werden in das Dokument eingelesen.

Referenzseiten

Alle Referenzseiten der Schablone (außer FrameMath-Referenzseiten) werden in das Dokument eingelesen. Wenn sowohl die Schablone als auch das Dokument eine Referenzseite mit demselben Namen besitzen, ersetzt die Referenzseite der Schablone diejenige des Dokuments. Wählen Sie "FrameMath-Definitionen", um FrameMath-Referenzseiten zu importieren.

Dokumenteinstellungen

Die speziellen Markentypen und Fußnoteneinstellungen, Band-, Kapitel-, Seiten-, Absatz-, Fußnoten- und Tabellenfußnoten-Nummerierungen aus dem Dialogfenster "Nummerierungseinstellungen", die mit der Einstellung "Zeilenumbruch erlaubt nach" im Dialogfenster "Textoptionen" festgelegten Zeichen sowie die Einstellungen der Option "Höhenausgleich" im Dialogfenster "Zeilenlayout" werden aus der Schablone in das Dokument eingelesen. Auch die PDF-Einstellungen (zusätzlich zu den Lesezeicheneinstellungen) werden übernommen. In Systemen mit japanischen Spracheinstellungen werden auch die Rubi-Einstellungen und Kumihan-Regeln (japanische typografische Regeln) in das Dokument eingelesen.

Variablendefinitionen

Die Variablendefinitionen der Schablone werden in das Dokument eingelesen.

Querverweisformate

Die Querverweisformate der Schablone werden in das Dokument eingefügt und interne Querverweise werden aktualisiert.

Einstellungen für bedingten Text

Bedingungstypen und die Einstellungen für "Ein-/Ausblenden" der Schablone werden in das Dokument eingelesen.

FrameMath-Definitionen

Gleichungsgröße und -schrift, spezielle FrameMath-Elementdefinitionen und FrameMath-Referenzseiten werden in das Dokument kopiert. Falls beim Übertragen der Referenzseiten spezielle FrameMath-Elemente gelöscht werden, ersetzt FrameMaker die FrameMath-Elemente in Gleichungen durch den Namen des in Fragezeichen eingeschlossenen Elements.

Hinweis: In FrameMaker-Gleichungen bezieht sich der Begriff FrameMath-Element auf einen Teil eines Ausdrucks. Ein FrameMath-Element ist kein strukturelles Element.

Kombinierte Schriften

Auf Systemen mit japanischen Spracheinstellungen werden die Spezifikationen zusammengesetzter Schriften in das Dokument eingelesen.


Grundlagen in FrameMaker / Strukturierte Dokumente / Importieren von Eigenschaften aus einer Schablone

Irreguläre Formate

Textformatierungsinformationen für ein Dokument können aus Formatregeln in Elementdefinitionen sowie aus vordefinierten Katalogformaten stammen. Es ist in einem Dokument möglich, für beide Informationsquellen irreguläre Formate zu verwenden.

    Eine irreguläre Formatzuweisung ist eine Abweichung von den Formatregeln eines Textelements. Wenn die Regeln beispielsweise ein Absatzformat für ein Element festlegen und Sie ein anderes Format anwenden oder wenn die Regeln einen Text in einer Fettschrift definieren und Sie den Text in kursiv ändern, übergehen Sie die Formatregeln des Elements.

    Ein irreguläres Format ist eine Abweichung von einem Katalogformat für Text oder eine Tabelle. Beispielsweise kann ein Absatzformat die Schriftfamilie Times festlegen. Wenn Sie einige Textteile, die dieses Format verwenden, in die Schriftart Palatino ändern (ohne die Änderung im Format zu ändern), verwenden Sie ein irreguläres Format. Formatregeln verwenden häufig einige Katalogformate und zusätzlich nach Bedarf einige irreguläre Formate, um zahlreiche Formatvariationen zu erreichen.

Sie sollten in Ihren strukturierten Dokumenten im Allgemeinen keine irregulären Formate verwenden. Lassen Sie die Formatierung von Ihrem Dokument automatisch erledigen und ziehen Sie Ihren Anwendungsentwickler zu Rate, wenn Sie Formatierungseigenschaften ändern möchten.

Wenn sich in Ihrem Dokument irreguläre Formate befinden, können Sie sie alle gleichzeitig beim Importieren und Aktualisieren aus dem gesamten Dokument entfernen.

Wichtig: Wenn Sie beide Typen von irregulären Formaten aus einem Dokument entfernen müssen, importieren Sie die Formate und entfernen Sie die Spezialformate zuerst. Dann importieren Sie die Elementdefinitionen und entfernen die irregulären Formatzuweisungen. Das Entfernen der irregulären Formatzuweisungen an letzter Stelle stellt sicher, dass die Elemente weiter ihren Formatregeln entsprechen.


Grundlagen in FrameMaker / Strukturierte Dokumente

Hinzufügen von Struktur zu Dokumenten mithilfe von Konvertierungstabellen

Wenn ein Anwendungsentwickler eine Konvertierungstabelle für ein Dokument eingerichtet hat, können Sie die Tabelle dazu verwenden, den Inhalt von Elementen im gesamten Dokument in einem Schritt einzugliedern. Dies ist eine einfache Möglichkeit, ein unstrukturiertes Dokument mit Inhalten in ein strukturiertes Dokument zu verwandeln.

Wenn Sie die Konvertierungstabelle auf ein Dokument anwenden, werden Elemente von FrameMaker innerhalb des gesamten Dokuments verwendet, es wird jedoch keine Definition in den Elementkatalog eingefügt. Zu diesem Zweck müssen Sie nach wie vor die Elementdefinitionen importieren.

Vermutlich müssen Sie an Strukturen, die durch Konvertierungstabellen hinzugefügt wurden, einige Änderungen vornehmen. Weitere Informationen zum Prüfen und Bearbeiten strukturierter Dokumente finden Sie unter Überprüfen von Dokumenten und Bearbeiten von Elementen.

Konvertierungstabellen

Eine Konvertierungstabelle erkennt Inhaltstypen an ihren Absatz- und Zeichentypen und legt die Elemente für diese Inhalte fest. Ebenso kann sie übergeordnete Elemente festlegen. So könnte z. B. ein Absatz vom Typ "Haupttext" in ein Element vom Typ "Absatz" eingegliedert sein, und ein Element vom Typ "Überschrift" und die darauf folgenden Elemente vom Typ "Absatz" könnten in ein übergeordnetes Element vom Typ "Abschnitt" eingegliedert sein.

Hinweis: Die Funktion "Konvertierungstabellen" unterstützt den Unicode-Standard zur Textcodierung.

Da Konvertierungstabellen mit Absatz- und Zeichentypen arbeiten, sind sie sehr hilfreich, wenn diese Typen einheitlich im gesamten Dokument verwendet wurden.

Selbst wenn Absatz- und Zeichentypen im Dokument nicht konsistent sind, können Sie dennoch eine Konvertierungstabelle für die Formatierung von allgemeinen Inhalten wie z. B. Haupttextabsätzen verwenden. Formatieren Sie den Rest des Inhalts manuell (siehe Vorhandenen Inhalt in Elemente eingliedern).


Grundlagen in FrameMaker / Strukturierte Dokumente / Hinzufügen von Struktur zu Dokumenten mithilfe von Konvertierungstabellen

Anwenden einer Konvertierungstabelle auf ein Dokument oder Buch

Mithilfe einer Konvertierungstabelle können dem aktuellen Dokument oder dem Buch und seinen Dateien schnell Strukturen hinzugefügt werden. FrameMaker legt die strukturierte Version des Dokuments in einer neuen unbenannten Datei ab.

So wenden Sie eine Konvertierungstabelle auf ein Dokument an:

    1. Öffnen Sie das Dokument oder Buch, dem Struktur hinzugefügt werden soll, sowie die Datei mit der Konvertierungstabelle.

    2. Stellen Sie sicher, dass das Dokument nicht bereits strukturiert ist, indem Sie in den Haupttextfluss klicken und in der Strukturansicht nachsehen. Wenn die Ansicht leer ist, ist das Dokument unstrukturiert.

    3. Wählen Sie in dem Dokument, in das Sie eine Struktur einfügen möchten, die Optionen "Strukturierungswerkzeuge > Dienstprogramme > Aktuelles Dokument strukturieren" bzw. "Aktuelles Buch strukturieren".

    4. Wählen Sie im Aufklappmenü "Konvertierungstabellen-Dokument" die Datei mit der Konvertierungstabelle aus und klicken Sie auf "Zuweisen". FrameMaker wendet die Konvertierungstabelle auf das Dokument an.

Wenn FrameMaker Fehler in der Tabelle findet, wird in einem unbenannten Dokument ein Fehlerbericht erstellt. Bitten Sie Ihren Entwickler, die Fehler zu beheben, und wenden Sie die Tabelle erneut an.

    5. Speichern Sie die neu strukturierten Dokumente.

    6. Importieren Sie Elementdefinitionen in das Dokument (siehe Importieren von Elementdefinitionen). In den meisten Fällen werden Sie in der neuen Struktur Korrekturen und Feinabstimmungen vornehmen müssen.


Grundlagen in FrameMaker / Strukturierte Dokumente / Hinzufügen von Struktur zu Dokumenten mithilfe von Konvertierungstabellen

Anwenden einer Konvertierungstabelle auf eine Gruppe von Dokumenten

Sie können einem oder mehreren Dokumenten Struktur hinzufügen, ohne diese zu öffnen. Die Dokumente sollten entweder der einzige Inhalt eines einzelnen Ordners sein oder innerhalb eines Ordners eine einheitliche Dateinamenerweiterung besitzen.

Weitere Informationen zu Konvertierungstabellen finden Sie im Structured Application Developer’s Guide, der sich im Ordner "handbch" befindet.

So wenden Sie eine Konvertierungstabelle auf eine Gruppe von Dokumenten an:

    1. Öffnen Sie die Datei mit der Konvertierungstabelle.

    2. Wählen Sie "Strukturierungswerkzeuge > Dienstprogramme > Dokumente strukturieren".

    3. Wählen Sie im Aufklappmenü "Konvertierungstabellen-Dokument" die Datei mit der Konvertierungstabelle aus.

    4. Geben Sie im Bereich "Unstrukturierte Eingabedateien" den Speicherort und die Dateinamenerweiterung der Dokumente an, die Sie strukturieren möchten. Wenn Sie nach dem Speicherort suchen müssen, klicken Sie auf die Schaltfläche "Durchsuchen" und suchen Sie die Datei.

Anwenden einer Konvertierungstabelle auf eine Gruppe von Dokumenten

Die Dateinamenerweiterung ist optional. Wenn Sie das Texteingabefeld "Suffix" leer lassen, werden alle Dokumente in diesem Ordner strukturiert.

    5. Geben Sie im Bereich "Strukturierte Ausgabedateien" einen Speicherort für die strukturierten Versionen der Dokumente an. Wenn Sie nach dem Speicherort suchen müssen, klicken Sie auf die Schaltfläche "Durchsuchen" und suchen Sie die Datei.

    6. Um einen vorhandenen Stapel strukturierter Dateien im Ausgabeordner zu überschreiben, wählen Sie "Überschreiben von bestehenden Dateien erlauben".

    7. Klicken Sie auf die Schaltfläche "Struktur hinzufügen".


Grundlagen in FrameMaker

Arbeiten mit unstrukturierten XML-Dokumenten

Element Definition Document (EDD) und Document Type Definition (DTD)

Öffnen von SGML-, XML-, MIF- und MML-Dateien als Textdateien

Importieren von CSS-Elementstilen in eine EDD-Datei (Windows)

CSS-Export

XML-Namespaces


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten XML-Dokumenten

Element Definition Document (EDD) und Document Type Definition (DTD)

Elementdefinitionen werden in einem EDD (Element Definition Document) definiert, das normalerweise in die Schablone eingebettet ist. Das EDD enthält sowohl strukturelle Regeln für das Dokument (Document Type Definition bzw. DTD) als auch Stilregeln, die festlegen, wie bestimmte Elemente formatiert werden. Das EDD wird entweder vom Anwendungsentwickler aus einer vorhandenen DTD-Datei oder vollkommen neu erstellt. Weitere Informationen finden Sie im Structured Application Developer’s Guide, der sich im Ordner "handbch" befindet.

Alle strukturierten Dokumente in FrameMaker verwenden Elemente. Jedes Element verwendet einen Namen oder ein Tag, wie Abschnitt, Überschrift oder Liste. Die verfügbaren Element-Tags werden von der Elementdefinition des Dokuments festgelegt.

Sie können Elemente in einem strukturierten Dokument hinzufügen oder bearbeiten und auch auf konventionellere Weise mit dem Inhalt arbeiten. Strukturierte FrameMaker-Schablonen enthalten Definitionen aller Elemente, die sich im Dokument sowie im Seitenlayout und der Formatierung des Dokuments verwenden lassen. Weitere Informationen zum Arbeiten mit Elementen finden Sie unter Elemente in strukturierten Dokumenten.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten XML-Dokumenten

Öffnen von SGML-, XML-, MIF- und MML-Dateien als Textdateien

SGML, XML, MIF und MML sind Textformate. Sie können also als Textdateien geöffnet werden. SGML und XML sind strukturierte Dokumentformate, die den Inhalt eines Dokuments enthalten (die Formatierung ist in der Regel durch eine Schablone definiert, die Seitenlayout und Elementdefinitionen enthält). Weitere Informationen finden Sie unter Strukturierte Formate FrameMaker. Mit MIF können Informationen zwischen FrameMaker und anderen Anwendungen ausgetauscht werden. MML ist eine Auszeichnungssprache, die Sie mit einem beliebigen Texteditor zur Erstellung einfacher unstrukturierter FrameMaker-Dokumente verwenden können.

Wenn Sie eine SGML-, XML-, MIF- oder MML-Datei öffnen, wird sie normalerweise im FrameMaker-Format angezeigt. Unter bestimmten Umständen müssen Sie eine dieser Dateien als Text öffnen, um die Markierung anzuzeigen oder zu bearbeiten.

Markierungen in SGML-Dateien

So öffnen Sie eine SGML-, XML- oder MIF-Datei als Text:

    1. Wählen Sie "Datei > Öffnen" und anschließend die zu öffnende Datei.

    2. Führen Sie eine der folgenden Aktionen aus:

    (Windows) Halten Sie die Strg-Taste gedrückt und klicken Sie auf "Öffnen".

    (UNIX) Halten Sie die Umschalttaste gedrückt und klicken Sie auf "Öffnen".

    3. Wählen Sie im Dialogfenster "Textdatei einlesen" eine Option zum Einlesen der Datei aus und klicken Sie auf "Einlesen".


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten XML-Dokumenten

Importieren von CSS-Elementstilen in eine EDD-Datei (Windows)

Sie können die Elementformatierung von CSS in EDD importieren, sodass Sie eine konsistente Formatierung über unterschiedliche XML-Anwendungen hinweg sicherstellen können. Die CSS-Datei kann im XML-Dokument referenziert oder manuell importiert werden. Es können mehrere CSS-Dateien der Reihe nach importiert werden, um eine mehrstufige Formatierung zu ermöglichen.

Beim Importieren von Elementstilen behält FrameMaker die CSS-Kontextinformationen (Elementeigenschaft oder Selektor) bei und importiert sie in die entsprechenden EDD-Kontexte.

Hinweis: FrameMaker exportiert Stilinformationen lediglich auf Elementebene.

Außerdem können Sie mit strukturiertem FrameMaker die CSS2-Voreinstellungen in XML einrichten. Weitere Informationen finden Sie im Structured FrameMaker Developer's Guide, der sich im Ordner "Documents" befindet.

    1. Öffnen Sie die EDD-Datei im strukturierten FrameMaker.

    2. Wählen Sie "Strukturierungswerkzeuge > CSS-Stile importieren". Das Dialogfenster "CSS importieren" wird angezeigt.

    3. Wählen Sie eine CSS-Datei aus und klicken Sie auf "Öffnen".

    4. Wenn in dem Element der strukturierten Anwendung in der EDD-Datei kein Anwendungsname definiert ist, wird das Dialogfenster "Strukturierte Anwendung verwenden" angezeigt. Wählen Sie die Anwendung aus, die zum Erstellen der EDD-Datei verwendet wurde. Klicken Sie auf "Fortfahren".

Die CSS-Datei wird dann in die EDD-Datei importiert.

Hinweis: Enthält das EDD bereits Formatierungsregeln, werden die CSS-Eigenschaften an die vorhandenen Regeln angehängt. Wenn die CSS-Eigenschaften einige der vorhandenen Regeln überlappen, ersetzen die CSS-Eigenschaften die vorhandenen Regeln im EDD. Das EDD unterstützt nicht alle in CSS 2.0 definierten Eigenschaften und Selektoren. Wenn eine Eigenschaft oder ein Selektor in der CSS-Datei nicht einer entsprechenden EDD-Regel zugewiesen werden kann, wird diese Eigenschaft bzw. dieser Selektor ignoriert. Es wird jedoch keine Fehlermeldung angezeigt und kein Fehlerprotokoll erzeugt.

Nach dem Importieren der CSS-Stile können Sie Elementdefinitionen von dem EDD in eine Schablone importieren und die Schablone zum Öffnen einer XML-Datei verwenden.

Anstatt den CSS-Importvorgang zu verwenden, können Sie mit FrameMaker auch eine XML-Datei öffnen, der bereits CSS-Stile zugewiesen sind. Wenn Sie die XML-Datei öffnen, werden von FrameMaker die DTD- und CSS-Dateien gelesen und eine temporäre Schablone zum Öffnen der XML-Datei erzeugt.


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten XML-Dokumenten

CSS-Export

Sie können die in Ihrem Dokument verfügbaren XML-Stilinformationen für alle Elemente in eine EDD-Datei exportieren, indem Sie das CSS2-Format (Cascading Style Sheets 2) verwenden. Anschließend können Sie diese CSS-Stildefinitionen von der EDD-Datei in neue XML-Dateien importieren. Mithilfe von Cascading Style Sheets können Autoren XML-Dateien Stile (wie Schriftarten und Abstände) zuweisen. Das CSS2-Format ist ein W3C-Standard.

Wenn Sie den Befehl "CSS2 generieren" wählen, werden wohlgeformte strukturierte Dokumente anhand der Formatierungsinformationen im EDD, das dem Quelldokument zugewiesen ist, erstellt. FrameMaker exportiert Stilinformationen lediglich auf Elementebene. Wenn Sie beispielsweise einen Stil nur einem einzelnen Wort in dem Textelement zuweisen, wird diese Stilinstanz nicht exportiert.

Sie können in der XML-Anwendung CSS2-Einstellungen vornehmen. Beispielsweise können Sie festlegen, dass die CSS2-Datei automatisch beim Exportieren in XML erzeugt wird. Weitere Informationen finden Sie im Structured Application Developer's Guide, der sich im Ordner "handbch" befindet.

So exportieren Sie CSS für eine FrameMaker-XML-Datei:

    1. Öffnen Sie die Schablone oder das Dokument mit einem zugeordneten EDD im strukturierten FrameMaker.

    2. Wählen Sie "Strukturierungswerkzeuge >CSS2 generieren".


Grundlagen in FrameMaker / Arbeiten mit unstrukturierten XML-Dokumenten

XML-Namespaces

Ein XML-Namespace ist eine Sammlung von Namen bestimmter Elementtypen und Attribute in XML-Dokumenten. Der Wirkungsbereich eines Namespace reicht über das ihn enthaltende Dokument hinaus.

Da ein einzelnes XML-Dokument Elemente und Attribute enthalten kann, die von mehreren Software-Anwendungen verwendet werden können, können Sie Namespaces verwenden, um anzugeben, welche Elemente und Attribute von welcher Anwendung verwendet werden sollen. XML verarbeitende Software-Anwendungen verwenden Namespaces, um festzustellen, welche Tags und Attribute von ihnen verarbeitet werden sollen.

Namen von XML-Namespaces können als qualifizierte Namen verwendet werden, die einen Doppelpunkt enthalten, der den Namen in ein Namespace-Präfix und einen lokalen Teil unterteilt. Das einer Uniform Resource Identifier-Referenz (URI) zugeordnete Präfix legt den Namespace fest. Die Kombination des universell verwalteten URI-Namespace und des Dokument-Namespace bilden eine universell eindeutige Kennung.

Verwenden von XML-Namespaces in FrameMaker

FrameMaker unterstützt die Namespace-Verwendung für alle Elemente in einem XML-Dokument. Wenn Sie ein XML-Dokument mit Namespace-Informationen importieren, werden alle Namespace-Informationen beibehalten.

Mithilfe des Befehls "Namespaces" können Sie im strukturierten FrameMaker Namespaces in einem XML-Dokument anzeigen, bearbeiten, hinzufügen oder löschen. Sie können diesen Befehl auch dazu verwenden, die Präfix-Definition eines Element-Tags anzuzeigen und das Element auszuwählen, das das Präfix definiert.

Standardmäßig werden Namespaces in FrameMaker als Namespaces behandelt und im Dialogfenster "Namespaces" angezeigt. Sie können jedoch Namespaces in der Anwendung auch deaktivieren und sie stattdessen als Attribute behandeln, die in der Strukturansicht angezeigt werden.

So zeigen Sie Namespaces an oder bearbeiten sie:

    1. Öffnen Sie das Dokument im strukturierten Modus von FrameMaker.

    2. Wählen Sie in der Strukturansicht ein Element aus.

Hinweis: Elemente, die Namespaces enthalten, werden in der Strukturansicht mit einem Sternchen (*) neben ihrem Namen angezeigt.

    3. Wählen Sie "Element > Namespaces".

    4. Klicken Sie im Dialogfenster "Namespaces" auf "Definierendes Element auswählen", um die Namespaces für das gewählte Element in der Strukturansicht anzuzeigen.

    5. Nehmen Sie unter "Deklarierte Namespaces", "Präfix" oder "Pfad" die gewünschten Änderungen vor und klicken Sie anschließend auf "Hinzufügen", "Ändern" oder "Löschen". Wenn Sie die Änderungen nicht speichern möchten, schließen Sie das Dialogfenster, ohne auf eine Option zu klicken.


Grundlagen in FrameMaker

Bearbeiten von Text

Für das Bearbeiten von Text ist FrameMaker flexibel und einfach. Sie können Text hinzufügen oder löschen und Sie können ihn an eine andere Position kopieren oder verschieben.

FrameMaker umfasst die folgenden leistungsstarken Bearbeitungsfunktionen:

    den Befehl "Suchen/Ändern", der nicht nur Text findet, sondern unter anderem auch Zeichenformate, Absatzformate, verankerte Rahmen und Objekte, die dem Inhalt der Zwischenablage entsprechen,

    die Rechtschreibhilfe, die Orthografie- und häufige Schreibfehler (z. B. überflüssige Leerzeichen und wiederholte Wörter) findet und korrigiert,

    den Thesaurus, der Wörter definiert und Synonyme, Antonyme und verwandte Begriffe zur Auswahl bietet.

Hinweis: Die Funktionen "Suchen/Ändern", "Rechtschreibhilfe", "Wörterbuch" und "Thesaurus" unterstützen den Unicode-Standard zur Textcodierung.


Grundlagen in FrameMaker / Bearbeiten von Text

Platzieren der Einfügemarke

Die Einfügemarke kann durch Klicken mit der Maus an eine beliebige Textstelle im Dokumentfenster gesetzt werden. Sie kennzeichnet die Stelle, an der Sie Text eingeben oder bearbeiten. Wenn Sie auf ein spezielles Textelement wie z. B. einen Querverweis, eine Variable oder einen Texteinschub klicken, wird das gesamte Element ausgewählt.

Die Position der Einfügemarke bestimmt, welcher Absatz aktuell und damit Ziel der Formatierungsbefehle ist.

Lässt sich die Einfügemarke nicht in oder neben Text platzieren, handelt es sich wahrscheinlich um Hintergrundtext aus einer Vorgabeseite. Öffnen Sie in diesem Fall die betreffende Vorgabeseite, und setzen Sie die Einfügemarke an die entsprechende Textstelle (siehe Anzeigen von Vorgabeseiten). Es könnte sich auch um automatisch generierten Text (z. B. automatische Absatznummerierung oder Querverweise) oder um eine Wiederholung aus der vorhergehenden Seite handeln (z. B. Tabellentitel oder -überschriften).


Grundlagen in FrameMaker / Bearbeiten von Text

Eingeben und Bearbeiten von Text

Einzugebender Text wird in das Dokumentfenster geschrieben. Während Sie schreiben, fließt der Text in die nächste Zeile oder Spalte. Drücken Sie die Eingabetaste nur, wenn Sie einen neuen Absatz beginnen wollen. Sobald Sie das Ende einer Seite erreichen, fügt FrameMaker automatisch eine neue Seite hinzu. Sie können auch manuell einen Zeilen- oder Seitenumbruch an einer bestimmten Stelle einfügen. Entsprechende Informationen finden Sie unter Ändern von Silbentrennung und Zeilenumbruch oder Ändern von Seiten- und Spaltenumbruch.

Um den Abstand zwischen Absätzen anzupassen, drücken Sie nicht mehrmals die Eingabetaste, sondern ändern die betreffende Eigenschaft des Absatzformats. Weitere Informationen finden Sie unter Ändern von Abständen.

Außer den standardmäßigen Tastaturzeichen können Sie auch Auszeichnungspunkte, mathematische Symbole, Leerzeichen unterschiedlicher Breite, länderspezifische Zeichen und andere Sonderzeichen eingeben.

Zahlreiche Funktionen erleichtern Ihnen die Texteingabe. So fügt z. B. die Option "Anführungszeichen" bei der Eingabe eines geraden Anführungszeichens das entsprechende öffnende oder schließende Anführungszeichen ein. Die Option "Leerzeichenkontrolle" verhindert die Eingabe mehrerer aufeinander folgender Leerzeichen.


Grundlagen in FrameMaker / Bearbeiten von Text / Eingeben und Bearbeiten von Text

Verwendung von Tabulatoren

Beim Drücken der Tabulatortaste wird jedes Mal ein Tabulatorsymbol [image] in den Text eingefügt. Dieses Symbol wird nur im Bildschirm angezeigt (sofern Steuerzeichen eingeblendet sind). Im gedruckten Dokument ist es nicht sichtbar.

Wenn im aktuellen Absatz Tabulatorstopps gesetzt sind, versetzt FrameMaker die Einfügemarke und nachfolgenden Text bei jedem Drücken der Tabulatortaste um einen Tabulatorstopp. Wenn keine Tabulatorstopps definiert sind, zeigt das Drücken der Tabulatortaste keine Wirkung. Wenn Sie die Tabulatortaste häufiger drücken, als Tabulatorstopps vorhanden sind, überlagern sich die Tabulatorsymbole. Wenn Sie dem Absatz später weitere Tabulatorstopps hinzufügen, richtet FrameMaker den Text korrekt an ihnen aus.

FrameMaker verwendet, anstelle relativer, absolute Tabulatorstopps. Bei relativen Tabulatorstopps bewegt sich die Einfügemarke mit jedem Drücken der Tabulatortaste an den nächsten verfügbaren Tabulatorstopp. Bei absoluten Tabulatorstopps bewegt sich die Einfügemarke beim n-ten Drücken der Tabulatortaste an den n-ten Tabulatorstopp in einer Zeile. Falls sich dieser Stopp links von der Einfügemarke befindet, bewegt sich die Einfügemarke nicht.

Drücken Sie dreimal die Tabulatortaste, um die Einfügemarke an den dritten Tabulatorstopp zu verschieben.

Informationen zu den verschiedenen Tabulatortypen, die Sie in einem Absatz einrichten können, finden Sie unter Ändern von Tabulatorstopps.


Grundlagen in FrameMaker / Bearbeiten von Text / Eingeben und Bearbeiten von Text

Eingeben von Sonderzeichen

Sie können mithilfe von Tastenkombinationen Auszeichnungspunkte, Bindestriche, Leerzeichen unterschiedlicher Breite und akzentuierte Zeichen wie ç, ñ und á eingeben. Wenn die Schrift "Symbol" auf Ihrem System installiert ist, stehen Ihnen weitere Symbole zur Verfügung (z. B. " , \ und ). Auch die Schrift "Zapf Dingbats" (oder eine andere Symbolschrift) ermöglicht das Eingeben spezieller Symbole (z. B. s , n 3).

Sie können Auszeichnungspunkte und Bindestriche eingeben. Außerdem können Leerzeichen fester Breite eingegeben werden. Eine Liste der Zeichen in den Schriften "Symbol" und "Zapf Dingbats" sowie eine Liste akzentuierter Zeichen im Standardzeichensatz und Informationen zum Einfügen des Euro-Währungssymbols finden Sie im Online-Handbuch FrameMaker-Zeichensätze.

Hinweis: Manche Sonderzeichen werden in Dialogfenstern auf eine andere Art und Weise eingegeben oder angezeigt. Unter Windows geben Sie Zeichenfolgen ein, indem Sie mit einem umgekehrten Schrägstrich (\) beginnen. Eine Auflistung dieser Zeichenfolgen finden Sie unter Eingabe in Dialogfenstern. Unter UNIX werden diese Zeichenfolgen mit umgekehrtem Schrägstrich möglicherweise in Textfeldern angezeigt, selbst wenn Sie diese Zeichenfolgen nicht eingeben müssen.

So geben Sie ein Auszeichnungszeichen () ein:

Drücken Sie die Tastenkombination Strg+q Umschalttaste+%. Außerdem können Sie auch Meta+Punkt (UNIX) drücken.

So geben Sie einen m-Bindestrich (--) ein:

Drücken Sie die Tastenkombination Strg+q Umschalttaste+q.

So geben Sie einen n-Bindestrich (–) ein:

Drücken Sie die Tastenkombination Strg+q Umschalttaste+p.


Grundlagen in FrameMaker / Bearbeiten von Text / Eingeben und Bearbeiten von Text

Eingeben spezieller Leerzeichen

Durch Drücken der Leertaste wird ein proportionales Leerzeichen eingefügt (dessen Breite von den benachbarten Zeichen abhängt). Sie können auch spezielle Leerzeichen mit fester Breite einfügen, z. B. um den Abstand zwischen zwei Wörtern zu vergrößern. Wörter, die durch solche Leerzeichen getrennt sind, bleiben immer in einer Zeile zusammen.

Sie können folgende Typen spezieller Leerzeichen verwenden:

    Ein m-Leerzeichen hat eine mit dem Schriftgrad übereinstimmende Breite. Verwenden Sie z. B. eine 10-Punkt-Schrift, ist das m-Leerzeichen 10 Punkt breit.

    Ein n-Leerzeichen hat die halbe Breite des m-Leerzeichens.

    Numerische Leerzeichen haben die Breite des Zeichens Null (0) der aktuellen Schrift. Alle Ziffern weisen in der Regel die gleiche Breite auf. Daher eignet sich dieses Leerzeichen für die Ausrichtung von Zahlen in einer Spalte ohne Tabulatoren.

    Ein t-Leerzeichen hat 1/12 der Breite eines m-Leerzeichens. Sie werden oft verwendet, wenn ein schmaler Zwischenraum zwischen zwei Zeichen benötigt wird, z. B. zwischen einer Zahl und einer Maßeinheit, oder zwischen Zeichen, die zu nahe beieinander sind, z. B. /).

    Umbruchgeschützte Leerzeichen haben die Breite des Standardleerzeichens der aktuellen Schrift.

So geben Sie ein m-Leerzeichen ein:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Drücken Sie Esc s m oder Strg+Umschalttaste+Leertaste.

    (UNIX) Drücken Sie Esc s m.

So geben Sie ein n-Leerzeichen ein:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Drücken Sie Esc s n oder Alt+Strg+Leertaste.

    (UNIX) Drücken Sie Esc s n.

So geben Sie ein numerisches Leerzeichen ein:

    Drücken Sie Esc Leerzeichen 1 (eins).

So geben Sie ein t-Leerzeichen ein:

    Drücken Sie Esc Leerzeichen t.

So geben Sie ein umbruchgeschütztes Leerzeichen ein:

    Drücken Sie Strg+Leertaste (Windows) bzw. Control+Leertaste (UNIX).

Ein Symbol für umbruchgeschützte Leerzeichen ( [image] ) wird angezeigt, wenn die Steuerzeichen eingeblendet sind.


Grundlagen in FrameMaker / Bearbeiten von Text / Eingeben und Bearbeiten von Text

Verwendung von Leerzeichenkontrolle oder Anführungszeichen

Wenn die Option "Leerzeichenkontrolle" aktiviert ist, können Sie nicht mehrere aufeinander folgende proportionale Leerzeichen eingeben. Die Eingabe mehrerer Leerzeichen fester Breite ist jedoch möglich (siehe Eingeben spezieller Leerzeichen).

Ist die Option "Anführungszeichen" aktiviert, fügt FrameMaker automatisch die öffnenden oder schließenden Anführungszeichen ein, wenn Sie die Taste [image] , [image] , oder [image] drücken. Falls Sie gerade Anführungszeichen vorziehen, deaktivieren Sie die Option "Anführungszeichen". Sie können mithilfe von Tastenkombinationen auch typografische Anführungszeichen eingeben, wenn "Anführungszeichen" deaktiviert ist, oder gerade Anführungszeichen, wenn die Option aktiviert ist.

Die Option "Anführungszeichen" wird nicht für Text in Dialogfenstern verwendet. Weitere Informationen zum Eingeben von Anführungszeichen und Apostrophen in Dialogfenstern finden Sie im Online-Handbuch FrameMaker-Zeichensätze und in Eingabe in Dialogfenstern.

Hinweis: Weitere Informationen zum Anpassen von Anführungszeichen für andere Sprachen in Windows- oder UNIX-Systemen finden Sie im Online-Handbuch "Anpassen von FrameMaker-Produkten". Das Handbuch ist unter folgender Adobe-Website verfügbar: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.

So aktivieren und deaktivieren Sie "Leerzeichenkontrolle" und "Anführungszeichen":

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Textoptionen".

    3. Ändern Sie die Einstellung der Option "Leerzeichenkontrolle" oder "Anführungszeichen" und klicken Sie auf "Zuweisen". Wenn Sie "Anführungszeichen" aktivieren, ändert FrameMaker keine bereits im Dokument vorhandene Anführungszeichen. Vorhandene gerade Anführungszeichen und Apostrophe können Sie über die Rechtschreibhilfe (siehe Prüfen der Rechtschreibung) oder den Befehl "Suchen/Ändern" (siehe Suchen eines beliebigen Elements) ändern.

So geben Sie Anführungszeichen in Windows ein:

Führen Sie eine der folgenden Aktionen aus:

Eingabe | Mit "Anführungszeichen" | Ohne "Anführungszeichen"
 | Control+ | Control+
 | Esc |
 | Control+ | Control+
 | Control+q plus (+) | Control+q plus (+)
und | und | und
und | und | Alt+Strg+ [image] und Alt+Strg+

So geben Sie Anführungszeichen auf UNIX-Systemen ein:

Führen Sie eine der folgenden Aktionen aus:

Eingabe | Mit "Anführungszeichen" | Ohne "Anführungszeichen"
 | Control+ | Control+
 | Control+ |
 | Control+ | Control+
 | Control+q plus (+) | Control+q plus (+)
und | und | und
und | und | Meta+ [image] und Meta+


Grundlagen in FrameMaker / Bearbeiten von Text / Eingeben und Bearbeiten von Text

Eingeben spezieller Textelemente

Sie können außer Text auch spezielle Textelemente wie Querverweise, Fußnoten, Variablen und Marken einfügen. Durch Einfügen einer Variablen werden automatisch Datum, Uhrzeit, Seitenzahl, Dateiname oder benutzerdefinierter Text im Dokument platziert. Bei Änderungen aktualisiert FrameMaker die Variablen. Mithilfe von Marken können Listen und Indizes generiert und Hypertext-Befehle eingefügt werden.

So fügen Sie ein spezielles Textelement ein:

Wählen Sie im Menü "Spezial" den entsprechenden Befehl. Weitere Informationen finden Sie an folgenden Stellen:

    Informationen zu Querverweisen finden Sie unter Einfügen von Querverweisen.

    Informationen zu Fußnoten finden Sie unter Arbeiten mit Fußnoten.

    Informationen zu Variablen finden Sie unter Erläuterung von Variablen.

    Informationen zu Marken für generierte Listen und Indizes finden Sie unter Vorbereiten von Dokumenten für eine Markenliste und Erläuterung von Indizes.

    Informationen zu Marken für Hypertext-Befehle finden Sie unter Hypertext-Befehle einfügen.


Grundlagen in FrameMaker / Bearbeiten von Text

Auswählen von Text

Gewöhnlich wählen Sie Text aus, bevor Sie ihn bearbeiten oder das Format ändern (z. B. Schriftgrad oder -stil). Ausgewählter Text wird hervorgehoben.

Informationen zum Auswählen von Text in Tabellen finden Sie unter Eingeben und Auswählen von Text in Tabellen.

So wählen Sie Text aus:

Führen Sie eine der folgenden Aktionen aus:

    Um einen Textbereich auszuwählen, ziehen Sie den Zeiger über den Text (oder klicken Sie an das eine Ende des Bereichs und dann bei gedrückter Umschalttaste auf das andere Ende).

    Um ein Wort auszuwählen, doppelklicken Sie darauf.

    Um einen Absatz auszuwählen, klicken Sie dreimal in rascher Folge in den entsprechenden Absatz.

    Um den gesamten Text in einem Textfluss auszuwählen, klicken Sie in den Textfluss und wählen "Bearbeiten > Textfluss auswählen".

    Um eine vorhandene Auswahl zu verkürzen oder zu erweitern, klicken Sie mit gedrückter Umschalttaste auf den neuen Anfang oder das neue Ende der Auswahl.


Grundlagen in FrameMaker / Bearbeiten von Text / Auswählen von Text

Kopieren, Verschieben und Löschen von Text

Über die Befehle im Menü "Bearbeiten" können Sie Text mithilfe der Zwischenablage ausschneiden, kopieren und einfügen. Wenn Sie "Bearbeiten > Ausschneiden" oder "Bearbeiten > Kopieren" wählen, bleibt der ausgeschnittene bzw. kopierte Text so lange in der Zwischenablage, bis Sie erneut einen dieser Befehle wählen.

Der eingefügte Text behält seine Zeichenformatierung bei. Enthält er Absatzsymbole [image] , wird auch das betreffende Absatzformat eingefügt. Andernfalls erhält der Text das Format des Absatzes, in den er eingefügt wird.

Bedeutend schneller lässt sich Text ohne die Zwischenablage kopieren. Dazu müssen der Originaltext und die neue Position sichtbar sein und sich in demselben Dokument befinden. Verwenden Sie die Zwischenablage, wenn Sie Text mithilfe von Kopieren und Einfügen von einem Dokument in ein anderes verschieben möchten.

Hinweis: Wenn Text in ein neues Dokument eingefügt wird, bleiben die im Originaldokument zugewiesenen Zeichen- und Absatztypen erhalten. Die Typen des eingefügten Textes sind im neuen Dokument eventuell anders definiert. Wenn sich die Einfügemarke im eingefügten Text befindet und das aktuelle Dokument keine Typenentsprechungen aufweist, wird in der Statuszeile neben dem Typennamen ein Sternchen angezeigt.

So kopieren Sie Text schnell und ohne Zwischenablage:

Setzen Sie die Einfügemarke an die Stelle, an der Sie den kopierten Text einfügen wollen, und führen Sie eine der folgenden Aktionen durch:

    (Windows) Halten Sie die Alt-Taste gedrückt und wählen Sie den zu kopierenden Text aus.

    (UNIX) Halten Sie die Control-Taste gedrückt und wählen Sie mit der mittleren Maustaste den zu kopierenden Text aus.

So löschen oder ersetzen Sie Text:

Wählen Sie den Text aus und führen Sie eine der folgenden Aktionen durch:

    Um den Text zu löschen, drücken Sie die Entf-Taste. Sie können stattdessen auch "Bearbeiten > Löschen" wählen.

    Um den Text zu ersetzen, geben Sie den neuen Text ein.

Enthält der gelöschte oder ersetzte Text ein Absatzende und das Absatzsymbol, wird der verbleibende Rest des Absatzes mit dem nächsten Absatz zusammengeführt. Wenn das nicht beabsichtigt ist, wählen Sie sofort "Bearbeiten > Rückgängig". Wählen Sie dann den Text noch einmal aus (jedoch ohne das Absatzsymbol) und führen Sie die Operation erneut durch.

So löschen Sie eine Textseite:

Führen Sie eine der folgenden Aktionen aus:

    Soll die Seite zusammen mit dem enthaltenen Text gelöscht werden, wählen Sie "Spezial > Seiten löschen". Enthält die Seite eine Tabelle, die auf der nächsten Seite fortgesetzt wird, wird die gesamte Tabelle gelöscht.

    Soll nur der Text entfernt werden, wählen Sie ihn aus und drücken Entf.

Informationen zum Löschen leerer Seiten am Ende eines Dokuments finden Sie unter Hinzufügen und Löschen leerer Seiten.


Grundlagen in FrameMaker / Bearbeiten von Text

Eingabe von Rubi-Text für japanische Texte

Durch Rubi-Text (kleine Zeichen, die oberhalb anderer Zeichen angezeigt werden) wird in japanischen Dokumenten die Aussprache angegeben. Rubi-Text kann auch in deutschsprachigen Dokumenten verwendet werden.

A: Rubi-Text B: Oyamoji-Text

Wenn auf Ihrem System japanische oder englische Schriften installiert sind, bietet FrameMaker Befehle für Eingabe und Positionierung von Rubi. Informationen zum Anpassen der Größe, der Position und des Abstandes von Rubi-Text finden Sie unter Anpassen von Abstand in japanischen Dokumenten.

So geben Sie Rubi-Text ein:

    1. Wählen Sie die Zeichen aus, über denen Rubi-Text platziert werden soll. Die Auswahl darf kein Absatzsymbol [image] und kein Zeilenvorschubsymbol ( [image] ) enthalten.

    2. Wählen Sie "Spezial > Rubi" und geben Sie den Text ein. (Wird der Befehl "Rubi" nicht im Menü "Spezial" angezeigt, drücken Sie stattdessen Esc s r.) Der Rubi-Text wird über den ausgewählten Zeichen angezeigt. Erstreckt sich die Auswahl über zwei Zeilen, werden alle Zeichen in derselben Zeile angezeigt.

Hinweis: Hinweis: Kollidiert der Rubi-Text mit der vorhergehenden Textzeile, vergrößern Sie entweder den Zeilenabstand (mindestens 150 % der Schriftgröße) oder deaktivieren Sie den festen Zeilenabstand (siehe Anpassen des vertikalen Abstands).

    3. Um zur normalen Texteingabe zurückzukehren, klicken Sie in den Rubi-Text oder wählen Sie erneut "Spezial > Rubi".


Grundlagen in FrameMaker / Bearbeiten von Text

Suchen

Sie können außer nach Text auch nach den folgenden Elementen suchen:

Textformate und Typen

Zeichenformateinstellungen oder bestimmten Absatz- oder Zeichentypen. Im strukturierten FrameMaker wird gleich nach dem Text "Element" angezeigt. Hiermit können Sie einzeln oder gleichzeitig nach Elementtypen, Attributnamen und Attributwerten suchen.

Weitere Informationen zum Suchen und Ersetzen von Textformaten finden Sie unter Globales Zuweisen von Formaten zu Text.

Marken

Beliebige Marken, unabhängig von den jeweiligen Markentypen, bestimmte Markentypen oder Marken mit bestimmtem Markentext.

Querverweise

Beliebige Querverweise, unabhängig vom jeweiligen Format, Querverweise, die ein bestimmtes Format verwenden, oder ungelöste Querverweise. Letztere können von FrameMaker nicht aktualisiert werden. Bei einem ungelösten Querverweis wird der Markentext des Querverweises im Textfeld "Suchen" angezeigt.

Texteinschübe

Jeder Text kann durch Verweise importiert werden. Sie können auch nach ungelösten Texteinschüben, also nach Einschüben suchen, die nicht aus ihren jeweiligen Quellen aktualisiert werden können. Sie können jedoch nicht nach Grafikabonnenten oder durch OLE verknüpfte Objekte suchen. (Um OLE-Verknüpfungen in Windows aufzulisten, wählen Sie "Bearbeiten >Verknüpfungen".)

Variablen

Beliebige Variablen, unabhängig von ihren Namen, oder bestimmte Variablen.

Rubi

Beliebiger Rubi-Text, wenn japanische Schriften auf Ihrem System installiert sind.

Verankerte Rahmen

Sie können eine Grafik finden, indem Sie den verankerten Rahmen suchen, der die Grafik enthält. Grafiken in unverankerten Rahmen werden nicht gefunden.

Fußnoten

Beliebiger Text oder Tabellenfußnoten.

Tabellen

Beliebige Tabellen, unabhängig von den jeweiligen Tabellenformattypen oder Tabellen eines bestimmten Typs.

Bedingter Text

Beliebiger bedingter Text, Text eines bestimmten Bedingungstyps oder Text ohne Bedingung. FrameMaker kann nicht nach bedingten Tabellenzeilen oder verborgenem bedingten Text suchen.

Automatischer Trennstrich

Automatisch getrennte Wörter.

Text- und Zeichenformate aus Zwischenablage

Text, der exakt mit dem Inhalt der Zwischenablage übereinstimmt, einschließlich Groß-/ Kleinschreibung und Zeichenformatierung.

Durchsuchen eines Dokuments

Die Suche in einem Dokument beginnt FrameMaker an der Einfügemarke und setzt sie bis zum Ende des Dokuments fort. Es werden nur Seiten des Typs durchsucht, in dem sich auch die Einfügemarke befindet (z. B. nur Arbeits- oder nur Vorgabeseiten). Bei Erreichen des Dokumentendes setzt FrameMaker die Suche am Anfang fort. Zuerst wird der Haupttextfluss und dann der übrige Text im Dokument durchsucht. Da die Suche textflussweise und nicht seitenweise erfolgt, kann der Eindruck entstehen, dass FrameMaker bei der Suche im Dokument hin- und herspringt.

Durchsuchen eines ganzen Buches

Beim Durchsuchen eines ganzen Buches beginnt FrameMaker mit dem aktiven Dokument (bzw. dem ersten Dokument im Buch, falls das Buchfenster aktiv ist) und fährt fort, bis alle Dokumente im Buch durchsucht wurden. Wenn sich ein Dokument nicht öffnen lässt, wird es übergangen und Sie erhalten eine entsprechende Meldung im Buchfehlerprotokoll.

Hinweis: Beim Durchsuchen eines gesamtes Buchs ist es nicht möglich, die Vorgabe- oder Referenzseiten zu durchsuchen.

Weitere Informationen zum Einsatz von Funktionen, die das ganze Buch betreffen, finden Sie unter Verwenden von Befehlen, die sich auf das ganze Buch beziehen.


Grundlagen in FrameMaker / Bearbeiten von Text

Suchen eines beliebigen Elements

Sie können die Suche nach einem der oben genannten Elemente anpassen, indem Sie festlegen, dass die Groß-/Kleinschreibung beachtet, nach ganzen Wörtern gesucht oder Jokerzeichen verwendet werden sollen. Mithilfe von Jokerzeichen können Sie nach einem bestimmten Zeichenmuster und nach Text am Zeilenanfang oder -ende suchen.

Wenn FrameMaker ein Element findet, können Sie es ersetzen oder die Suche fortsetzen.

Sie können ein Element in der Auswahl, im Dokument oder im ganzen Buch suchen. Weitere Informationen zum Suchen in einem ganzen Buch finden Sie unter Durchsuchen eines ganzen Buches.

FrameMaker 8 verwendet das UTF-8-Codierungsformat. Daher verwenden alle Zeichen in einem FM- oder XML-Dokument, das Unicode-codierten Text enthält, Multibyte-Zeichen. Dies hat zur Folge, dass nur die im Suchfeld eingegebene Zeichenfolge zum Durchführen der Suche verwendet wird.

Sie können eine Suchzeichenfolge angeben, die einen Bereich von Zeichen enthält. Beispielsweise können Sie eine Zeichenfolge angeben, z. B. "[d-w]", um Text zwischen den Zeichen "d" und "w" zu suchen. Die Suche in einem Bereich kann jedoch nur für Unicode-Zeichen verwendet werden. Benutzer können nach allen Zeichen suchen, die zu BMP (Basic Multilingual Plane) gehören. Codepunkte für Unicode können ebenfalls für Suchen und Ersetzen verwendet werden. Geben Sie beispielsweise "\uXXXX" ein, um ein Zeichen mit dem Codepunkt "XXXX" zu suchen. Beispiel: Um nach dem Buchstaben "A" zu suchen, dessen Codepunkt "u+0041" ist, können Sie "\u0041" im Dialogfenster "Suchen/Ändern" eingeben.

Außerdem können Sie auch Jokerzeichen für die Suche nach Unicode-Text verwenden.

So suchen Sie nach einem beliebigen Element:

    1. Führen Sie eine der folgenden Aktionen aus:

    Um in einem Dokument zu suchen, klicken Sie an die Stelle, an der die Suche beginnen soll.

    Um eine Auswahl zu durchsuchen, wählen Sie den Text aus.

    Um ein vollständiges Buch zu durchsuchen, öffnen Sie das Buch oder ein Dokument des Buches.

    Um ein oder mehrere Dokumente im Buch zu durchsuchen, wählen Sie die Dokumente im Buchfenster aus.

    2. Wählen Sie "Bearbeiten > Suchen/Ändern".

    3. Geben Sie an, ob Sie das Buch, das Dokument oder die Auswahl durchsuchen möchten. Mithilfe der Option "Auswahl" können Sie den in einem Dokument ausgewählten Text durchsuchen bzw. die ausgewählten Dateien, wenn eine oder mehrere Buchdateien ausgewählt sind.

    4. Wählen Sie aus dem Aufklappmenü "Suchen" das Element, nach dem gesucht werden soll (siehe Suchen).

    5. Führen Sie eine der folgenden Aktionen aus:

    Bei Auswahl von "Text", "Absatztyp", "Zeichentyp", "Marke des Typs", "Markentext", "Querverweis des Formats", "Variablenname" oder "Tabellentyp" aus dem Aufklappmenü "Suchen" müssen Sie im benachbarten Textfeld das konkret gesuchte Element eingeben.

    Wenn Sie "Zeichenformat" oder "Bedingter Text" aus dem Aufklappmenü "Suchen" wählen, wird ein Dialogfenster geöffnet, in dem Sie weitere Informationen eingeben können. Informationen hierzu finden Sie unter Suchen nach Zeichenformateinstellungen und Suchen nach bedingtem Text.

    Wählen Sie einen anderen Eintrag im Menü "Suchen", überspringen Sie Schritt 6 und fahren Sie mit Schritt 7 fort.

    6. Wenn Sie Text in das Eingabefeld "Suchen" eingegeben haben, können Sie die Suche folgendermaßen anpassen:

    Um ein Textobjekt unabhängig von seiner Groß- und Kleinschreibung zu suchen, deaktivieren Sie die Option "Groß-/Kleinschreibung beachten". Wenn Sie z. B. im Textfeld "Suchen" das Wort MEIN eingeben und die Option "Groß-/Kleinschreibung beachten" aktiviert ist, wird das Wort Mein nicht gefunden. Wenn die Option "Groß-/Kleinschreibung beachten" deaktiviert ist, wird MEIN, Mein und mein gefunden.

    Um nach einer exakten Entsprechung eines Wortes zu suchen, geben Sie es in das Textfeld "Suchen" ein und aktivieren die Option "Ganzes Wort". Wenn Sie z. B. im Textfeld "Suchen" das Wort nummer eingeben und die Option "Ganzes Wort" aktivieren, wird das Wort Telefonnummer nicht gefunden.

    Um eine Zeichenfolge zu suchen, die Teil eines längeren Wortes oder mehrerer Wörter ist, deaktivieren Sie die Option "Ganzes Wort". Wenn Sie z. B. im Textfeld "Suchen" das Wort kalt eingeben und "Ganzes Wort" deaktivieren, werden Wörter wie kalte und erkalten sowie kalt gefunden.

    Um ein Element mithilfe von Jokerzeichen zu suchen, geben Sie in das Textfeld "Suchen" den Text und die Jokerzeichen ein und aktivieren die Option "Jokerzeichen". Wenn Sie im Textfeld "Suchen" z. B. Nummer[1-9] eingeben und "Jokerzeichen" aktivieren, wird jedes Auftreten des Wortes Nummer gefolgt von einer beliebigen Ziffer zwischen 1 und 9 gefunden. Weitere Informationen finden Sie unter Verwenden von Jokerzeichen bei der Suche.

Hinweis: In asiatischen Dokumenten mit Multibyte-Zeichen sind die eckigen Klammern [ ] nicht als Jokerzeichen verwendbar.

    7. Klicken Sie auf "Suchen". Wenn FrameMaker eine genaue Übereinstimmung findet, wird die betreffende Seite angezeigt und das Element ausgewählt.

Informationen dazu, wie FrameMaker ein Dokument oder ein Buch durchsucht, finden Sie unter Durchsuchen eines Dokuments oder Durchsuchen eines ganzen Buches.

So suchen Sie nach dem nächsten Auftreten eines Elements:

Klicken Sie im Dialogfenster "Suchen/Ändern" auf "Suchen" oder wählen Sie "Bearbeiten > Nächstes Auftreten suchen".

So kehren Sie die Suchrichtung um:

Aktivieren Sie im Dialogfenster "Suchen/Ändern" die Option "Rückwärts suchen" und klicken Sie auf "Suchen".

So brechen Sie eine Suche ab:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Drücken Sie Esc.

    (UNIX) Drücken Sie Control+c.


Grundlagen in FrameMaker / Bearbeiten von Text / Suchen eines beliebigen Elements

Eingeben von Text in das Feld "Suchen"

In das Textfeld "Suchen" können Sie beliebige Zeichen eingeben. Die folgenden Zeichen erfordern jedoch eine Sonderbehandlung:

    Um einen umgekehrten Schrägstrich (\) zu suchen, geben Sie zwei umgekehrte Schrägstriche (\\) in das Textfeld ein. Ein einzelner umgekehrter Schrägstrich gibt normalerweise ein Sonderzeichen an.

    Um bei aktivierter Option "Jokerzeichen" nach einem Jokerzeichen als normalem Zeichen zu suchen, stellen Sie ihm einen umgekehrten Schrägstrich voran. Um beispielsweise nach einem Sternchen zu suchen, geben Sie \* in das Textfeld "Suchen" ein.


Grundlagen in FrameMaker / Bearbeiten von Text / Suchen eines beliebigen Elements

Suchen nach Sonder- und Steuerzeichen

Sie können nach beliebigem Text suchen, einschließlich einzelnen Zeichen, Wortverbindungen und Sonderzeichen, die nicht auf der Tastatur vorhanden sind. Wenn Sie Sonderzeichen in ein Dialogfenster auf einem UNIX-System eingeben, werden diese evtl. als entsprechende Zeichenfolge mit vorangestelltem umgekehrten Schrägstrich (\) dargestellt. Unter Windows müssen Sie die mit dem umgekehrten Schrägstrich beginnende Zeichenfolge eingeben (siehe Überblick über die Eingabe in Dialogfenstern).

Verwenden von Jokerzeichen bei der Suche

Wenn im Dialogfenster "Suchen/Ändern" die Option "Jokerzeichen" aktiviert ist, können Sie folgende Jokerzeichen verwenden:

Suche | Vorgehensweise | Beispiel
Kein oder mehrere Zeichen (mit Ausnahme von Leer- und Interpunktionszeichen) | Geben Sie ein Sternchen (*) ein. | f*t findet Wörter wie fit und fett.
Beliebiges einzelnes Zeichen (mit Ausnahme von Leer- und Interpunktionszeichen) | Geben Sie ein Fragezeichen (?) ein. | f??t findet Wörter mit vier Buchstaben, die mit f beginnen und mit t enden (z. B. fast und fett).
Ein oder mehrere Leerzeichen und Interpunktionszeichen | Geben Sie einen vertikalen Strich (|) ein. | *alle| findet Wörter wie alle. und Falle?. Wenn die Option "Ganzes Wort" deaktiviert ist, wird auch Kralle. gefunden, jedoch nicht alles.
Ein beliebiges von mehreren Zeichen | Geben Sie die Zeichen in Klammern ( [ und ] ) ein. | [kms]ein findet kein, mein und sein. Wenn "Ganzes Wort" deaktiviert ist, wird auch gemein, wohlsein und keines gefunden.
Ein beliebiges Zeichen, außer den angegebenen Zeichen | Stellen Sie den Zeichen in Klammern ein Caret-Zeichen (^) voran. | [^kms]ein sucht nach dein, rein und fein, jedoch nicht nach kein, mein oder sein.
Anfang einer Zeile | Geben Sie ein Caret-Zeichen (^) ein. | ^f findet jedes Wort, das am Anfang einer Zeile mit f beginnt. Dieses Jokerzeichen lässt sich nicht zusammen mit der Option "Ganzes Wort" verwenden.
Ende einer Zeile | Geben Sie ein Dollarzeichen ($) ein. | f$ findet jedes Wort, das am Ende einer Zeile mit f endet. Dieses Jokerzeichen lässt sich nicht zusammen mit der Option "Ganzes Wort" verwenden.

Um nach nicht druckbaren Zeichen (z. B. Tabulator-, Absatz- oder Flussendesymbole) oder nach Positionen (z. B. Anfang eines Absatzes oder Wortes) zu suchen, verwenden Sie folgende Zeichenfolgen.

Suche | Geben Sie diese Zeichenfolge ein
Tabulator | \t
Erzwungenes Zeilenende | \r
Absatzende | \p (klein geschrieben)
Absatzanfang | \P (groß geschrieben)
Textflussende oder Zellenende in Tabellen | \f
Wortanfang | \<
Wortende | \>

Sie können z. B. mit "\P\p" (Absatzanfang mit nachfolgendem Absatzende) leere Absätze suchen.

Die meisten dieser Zeichenfolgen können sowohl beim Suchen als auch beim Ersetzen verwendet werden, um z. B. einen Zeilenvorschub durch ein Absatzende-Zeichen zu ersetzen. Sie können Zeichenfolgen jedoch nicht durch Textflussende, Absatzanfang, Wortanfang oder Wortende ersetzen.


Grundlagen in FrameMaker / Bearbeiten von Text / Suchen eines beliebigen Elements

Suchen nach Zeichenformateinstellungen

Sie können nach beliebigen Zeichenformateinstellungen suchen, z. B. nach Text in Kursivschrift. Für die Suche können Sie auch mehrere Eigenschaften angeben (z. B. Helvetica, 12 Punkt, fett).

Sie können auch Text mit bestimmten Einstellungen und übereinstimmender Groß-/Kleinschreibung suchen, z. B. das Wort London mit dem Schriftgrad 10 Punkt und in Kursivschrift. Mit diesen Angaben kann FrameMaker das Wort London nicht finden, wenn es einen anderen Schriftgrad aufweist, nicht Kursivschrift oder eine andere Groß-/Kleinschreibung verwendet.

Mithilfe der Suchoptionen "Absatztyp" und "Zeichentyp" können Sie auch einen bestimmten Absatz- oder Zeichentyp suchen.

So suchen Sie nach Zeichenformateinstellungen:

    1. Klicken Sie in einen Textbereich, der ähnliche (oder identische) Formateinstellungen wie der gesuchte Text aufweist.

    2. Wählen Sie im Dialogfenster "Suchen/Ändern" aus dem Aufklappmenü "Suchen" den Eintrag "Zeichenformat".

    3. Führen Sie eine der folgenden Aktionen aus:

    Soll nach den Formateinstellungen des aktuellen Textes gesucht werden, ändern Sie die Einstellungen nicht.

    Soll nach Text mit anderen Formateinstellungen gesucht werden, nehmen Sie die entsprechenden Änderungen vor.

    Sollen bei der Suche bestimmte Einstellungen nicht berücksichtigt werden, setzen Sie die entsprechenden Optionen auf "Beibehalten". Hierfür klicken Sie auf ein Markierungsfeld, bis es grau (Windows) oder abgedunkelt (UNIX) angezeigt wird, wählen die Option "Beibehalten" aus einem Aufklappmenü oder einer Auswahlliste oder löschen den Text aus einem Textfeld. Soll beispielsweise die Farbeinstellung des Textes nicht berücksichtigt werden, wählen Sie aus dem Aufklappmenü "Farbe" den Eintrag "Beibehalten".

    Sollen nur wenige Einstellungen bei der Suche beachtet werden, setzen Sie zuerst alle Einstellungen mit der Tastenkombination Strg+Umschalttaste+F8 (Windows) oder Umschalttaste+F8 (UNIX) auf"Beibehalten". Geben Sie nur die Einstellungen an, die Sie finden wollen.

    4. Klicken Sie auf "Zuweisen" und anschließend auf "Suchen".

Nachdem Sie die Änderungen im Dialogfenster "Suche nach Zeichenformat" vorgenommen haben, können Sie die Optionen auf das Format des aktuellen Textes zurücksetzen. Drücken Sie hierfür Strg+Umschalttaste+F9 (Windows) oder Umschalttaste+F9 (UNIX).

So suchen Sie nach bestimmten Text- und Zeichenformateinstellungen:

    1. Kopieren Sie den Text mit dem gewünschten Zeichenformat. Sie können dafür zwar beliebig viel Text kopieren, FrameMaker berücksichtigt aber nur die ersten 126 Zeichen aus der Zwischenablage.

    2. Wählen Sie im Dialogfenster "Suchen/Ändern" aus dem Aufklappmenü "Suchen" den Eintrag "Text & Zeichenformat aus Zwischenablage". Geben Sie den gesuchten Text nicht in das Textfeld "Suchen" ein.

    3. Klicken Sie auf "Suchen".


Grundlagen in FrameMaker / Bearbeiten von Text / Suchen eines beliebigen Elements

Suchen nach Marken

FrameMaker verwendet Marken für Querverweise, Indizes und andere Zwecke. Sie können nach Marken eines beliebigen Typs oder nach einem bestimmten Markentyp suchen. Wenn die Anzeige von Steuerzeichen aktiviert ist, werden Marken mit einem Symbol ( [image] ) gekennzeichnet.

FrameMaker kann auch nach Marken mit bestimmtem Markentext suchen.


Grundlagen in FrameMaker / Bearbeiten von Text / Suchen eines beliebigen Elements

So suchen Sie eine Marke:

    1. Öffnen Sie das Dialogfenster "Suchen/Ändern" und führen Sie eine der folgenden Aktionen durch:

    Um eine beliebige Marke im Dokument zu suchen, wählen Sie aus dem Aufklappmenü "Suchen" den Eintrag "Beliebige Marke" und lassen das Textfeld "Suchen" leer.

    Um einen bestimmten Markentyp zu suchen, wählen Sie aus dem Aufklappmenü "Suchen" den Eintrag "Marke des Typs" und geben den gewünschten Markentyp in das Textfeld "Suchen" ein.

    Soll eine Marke mit bestimmtem Text gesucht werden, wählen Sie aus dem Aufklappmenü "Suchen" den Eintrag "Markentext" und geben den Markentext in das Feld "Suchen" ein.

    2. Klicken Sie auf "Suchen". Ist das Dialogfenster "Marke" ("Spezial > Marke") geöffnet, wird hier der Text der gefundenen Marke angezeigt.

Wichtig: Soll der Text in einer gefundenen Marke ersetzt werden, bearbeiten Sie diesen im Dialogfenster "Marke". Wenn Sie das Dialogfenster "Suchen/Ändern" verwenden, wird statt des Textes die Marke ersetzt.


Grundlagen in FrameMaker / Bearbeiten von Text / Suchen eines beliebigen Elements

Suchen nach bedingtem Text

Sie können sichtbaren Text mit bestimmten Bedingungstypen suchen. Wenn FrameMaker sichtbaren bedingten Text findet, wird automatisch sämtlicher angrenzender Text ausgewählt, der diese Bedingungstypen verwendet.

FrameMaker kann bedingte Tabellenreihen nicht finden.

So suchen Sie bedingten Text:

    1. Vergewissern Sie sich, dass der Text mit den gesuchten Bedingungstypen sichtbar ist (siehe Ändern der Darstellung von Bedingungsdokumenten).

    2. Wählen Sie im Dialogfenster "Suchen/Ändern" aus dem Aufklappmenü "Suchen" den Eintrag "Bedingter Text". Das Dialogfenster "Suche nach bedingtem Text" wird angezeigt.

    3. Führen Sie folgende Schritte durch:

    Um Text mit einem bestimmten Bedingungstyp zu suchen, verschieben Sie den Bedingungstyp in die Liste "Mit".

    Um Text ohne einen bestimmten Bedingungstyp zu suchen, verschieben Sie den Typ in die Auswahlliste "Ohne".

    Soll der Bedingungstyp bei der Suche nicht berücksichtigt werden, verschieben Sie ihn in die Liste "Beibehalten".

    Um sämtlichen bedingten Text zu finden, verschieben Sie alle Typen in die Liste "Beibehalten".

    Um nicht bedingten Text zu finden, wählen Sie "Nicht bedingt" aus.

Hinweis: Zum Verschieben von Bedingungstypen aus einer Auswahlliste wählen Sie den Typ aus und klicken auf einen Pfeil. Sie können auch auf den Typ doppelklicken. Zum Verschieben aller Bedingungstypen aus einer Auswahlliste wählen Sie einen Typ in der Liste aus und klicken bei gedrückter Umschalttaste auf einen Pfeil.

    4. Klicken Sie auf "Zuweisen" und anschließend auf "Suchen".


Grundlagen in FrameMaker / Bearbeiten von Text / Suchen eines beliebigen Elements

Verwenden des Befehls "Suchen/Ändern" über die Tastatur

Sie können auch nach Elementen suchen, ohne die Maus zu verwenden. Sie öffnen mithilfe von Tastaturbefehlen das Dialogfenster "Einstellung der Suchparameter" (das die gleichen Optionen wie das Dialogfenster "Suchen/Ändern" enthält), aktivieren die verschiedenen Optionen und starten den Suchvorgang. Diese Tastaturbefehle sind vor allem in Makros nützlich, die das Suchen und Ersetzen automatisieren. Unter Windows können Sie mit Makroprogrammen von anderen Herstellern Makros erstellen, die mit FrameMaker arbeiten. Unter UNIX können Sie "Datei > Dienstprogramme > Makro" verwenden (siehe Verwenden von UNIX-Makros).

So verwenden Sie den Befehl "Suchen/Ändern" über die Tastatur:

    1. Drücken Sie in einem Dokumentfenster Esc b s.

    2. Nehmen Sie im Dialogfenster "Einstellung der Suchparameter" die gewünschten Eingaben vor und drücken Sie die Eingabetaste.

Verwenden Sie die Tastaturbefehle, um von Einstellung zu Einstellung zu wechseln und Optionen aus den Aufklappmenüs zu wählen. Eine Liste dieser Tastaturbefehle finden Sie in der Online-Hilfe.

    3. Um die Suche zu starten, führen Sie eine der folgenden Aktionen aus:

    (Windows) Drücken Sie Strg+Umschalttaste+f.

    (UNIX) Drücken Sie Meta+s.

    4. Wiederholen Sie Schritt 3, um eine erneute Suche zu starten.


Grundlagen in FrameMaker / Bearbeiten von Text / Suchen eines beliebigen Elements

Suchen nach Unicode-Zeichen

Sie können ein FrameMaker-Dokument nach allen Zeichen durchsuchen, die zum Unicode-Zeichensatz BMP (Basic Multilingual Plane) gehören, indem Sie Codepunkte für Unicode verwenden.

Um nach einem Zeichen mit dem Codepunkt XXXX zu suchen, müssen Sie die Suchzeichenfolge im Format \uXXXX angeben. Beispiel: Um nach dem Buchstaben "A" zu suchen, dessen Codepunkt "u+0041" ist, geben Sie die Zeichenfolge "\u0041" ein.

Außerdem können Sie auch nach einem Bereich von Unicode-Zeichen suchen. Beispiel: Durch die Suchzeichenfolge "[d-w]" werden alle Zeichen zwischen "d" und "w" gesucht. Unicode-Zeichen können auch zum Definieren von Bereichen verwendet werden, die in Unicode-Codepunkte umgewandelt werden. Die angegebenen Codepunkte müssen im BMP-Unicode-Zeichensatz vorhanden sein. Wenn Sie beispielsweise die Zeichenfolge "[á- ã]" angeben, sucht FrameMaker nach allen Zeichen zwischen dem Codepunkt 03B1 (ALPHA als Kleinbuchstabe) und dem Codepunkt 03B3 (GAMMA als Kleinbuchstabe).

Hinweis: Ein Codepunkt ist ein beliebiger Wert im Unicode-Codespace, der einem Bereich von Ganzzahlen von 0 bis 10FFFF16 entspricht. Dieser bestimmte Bereich für den Codespace wird nur im Unicode-Standard festgelegt. Andere Standards für Zeichencodierung können andere Codespaces verwenden.


Grundlagen in FrameMaker / Bearbeiten von Text / Suchen eines beliebigen Elements

Fehlerbehebung beim Suchen

Wenn ein Element nicht gefunden wird, von dem Sie sicher wissen, dass es vorhanden ist, überprüfen Sie das Dialogfenster "Suchen/Ändern" auf folgende Punkte:

    Ist der Text im Textfeld "Suchen" richtig geschrieben?

    Wurden zu viele oder zu wenige Leerzeichen eingegeben? Handelt es sich um den richtigen Typ von Leerzeichen? Bei Text mit Leerzeichen sucht FrameMaker nach Text mit der exakt identischen Anzahl und Position der Leerzeichen. Sie können spezielle Leerzeichen, z. B. m-Leerzeichen und t-Leerzeichen, ebenso wie normale Leerzeichen suchen.

    Verwenden Sie die richtigen Optionen? Ist z. B. die Option "Ganzes Wort" aktiviert, obwohl sie deaktiviert sein sollte?

    Ist der gesuchte Text sichtbar, wenn Sie in Ihrem Dokument bedingten Text verwenden?

    Befindet sich die Einfügemarke in einer Vorgabeseite, wenn Sie nach einem Element auf einer Vorgabeseite suchen?

    Stellen Sie sicher, dass im Dialogfenster "Suchen/Ändern" die Option "Buch" aktiviert ist, wenn Sie das ganze Buch durchsuchen möchten.


Grundlagen in FrameMaker / Bearbeiten von Text

Ändern gefundener Elemente

Nachdem Sie ein Element gefunden haben, können Sie es auf mehrere Arten ändern. Gewöhnlich suchen Sie nach Text und ersetzen ihn. Sie können aber auch das Zeichenformat ändern oder den Text durch den Inhalt der Zwischenablage ersetzen. Beispielsweise können Sie eine Variable in die Zwischenablage kopieren und dann jedes Auftreten eines bestimmten Wortes durch die Variable bzw. ein Wort durch eine Grafik in einem verankerten Rahmen ersetzen.

Sie können jedes Auftreten des Elements einzeln ändern oder FrameMaker anweisen, die Änderung im ganzen Dokument bzw. Buch oder in der gesamten Auswahl automatisch auszuführen.

So ändern Sie ein beliebiges Element:

    1. Geben Sie das gesuchte Element an, so wie es unter Suchen eines beliebigen Elements beschrieben ist.

    2. Öffnen Sie das Dialogfenster "Suchen/Ändern" und führen Sie eine der folgenden Aktionen durch:

    Um das gefundene Element durch Text zu ersetzen, aktivieren Sie die Option "In Text" und geben den Text in das Textfeld "Ändern" ein. Weitere Informationen hierzu finden Sie unter Ersetzen gefundener Elemente durch Text.

    Um Zeichenformateinstellungen des gefundenen Textes zu ändern, wählen Sie "Zeichenformat" und geben im anschließend angezeigten Dialogfenster die gewünschten Einstellungen ein. Weitere Informationen hierzu finden Sie unter Ändern der Zeichenformateinstellungen.

    Um den Inhalt der Zwischenablage für das gefundene Element zu verwenden, wählen Sie "Durch Einfügen" (Windows/UNIX). Wählen Sie anschließend das einzufügende Element aus und kopieren Sie es in die Zwischenablage.

    3. Klicken Sie auf "Suchen", um die erste Übereinstimmung zu suchen.

    4. Führen Sie eine der folgenden Aktionen aus:

    Soll nur das gefundene Element geändert, die Suche aber nicht fortgesetzt werden, klicken Sie auf "Ändern".

    Um die Suche fortzusetzen, ohne das gefundene Element zu ändern, klicken Sie auf "Suchen".

    Soll das gefundene Element geändert und die Suche fortgesetzt werden, klicken Sie auf "Ändern & Suchen".

    Um jedes Auftreten des Elements zu ändern, geben Sie den Bereich für die Änderung (Dokument, Buch oder aktuelle Auswahl) an und klicken Sie auf "Alles ändern". Eine Meldung teilt Ihnen die Anzahl der vorgenommenen Änderungen mit.

Wichtig: Beim automatischen Ändern aller Übereinstimmungen führt FrameMaker möglicherweise unbeabsichtigte Änderungen durch, z. B. wenn das gesuchte Wort Teil eines längeren Wortes ist (und "Ganzes Wort" deaktiviert ist). Diese Änderungen lassen sich nicht rückgängig machen. Sie sollten daher Ihr Dokument speichern und dann zunächst mit "Suchen" und "Ändern" mehrere gefundene Stellen ersetzen. Klicken Sie erst auf "Alles ändern", wenn Sie sicher sind, dass FrameMaker nur die gewünschten Änderungen durchführt.

Wenn Sie auf "Ändern" oder "Ändern & Suchen" klicken und kein Text im Dokument ausgewählt ist, nimmt FrameMaker die Änderung an der Position der Einfügemarke vor.

So löschen Sie ein gefundenes Element:

Wählen Sie im Dialogfenster "Suchen/Ändern" aus dem Aufklappmenü "Ändern" den Eintrag "In Text", lassen Sie das Textfeld "Ändern" leer und klicken Sie auf "Ändern". Sie können auch einfach die Entf-Taste drücken.


Grundlagen in FrameMaker / Bearbeiten von Text / Ändern gefundener Elemente

Ersetzen gefundener Elemente durch Text

Sie können jedes Element, das FrameMaker findet, durch Text ersetzen. So kann beispielsweise ein Wort durch ein anderes Wort oder eine Marke durch einen Satz ersetzt werden.

Soll die Groß-/Kleinschreibung beim Ersetzen berücksichtigt werden, können Sie mit der Option "Groß-/Kleinschreibung übernehmen" im Dialogfenster "Suchen/Ändern" festlegen, dass FrameMaker die Schreibweise des Originaltextes übernimmt. Wenn Sie diese Option aktivieren und in das Feld "Suchen" z. B. sie und du in das Feld "Ändern" eingeben, ersetzt FrameMaker sie durch du und Sie durch Du.

Sie können beliebigen Text eingeben, einschließlich Sonderzeichen, die sich nicht auf der Tastatur befinden (z. B. m-Leerzeichen und Absatzsymbole). Informationen zu diesen Zeichen finden Sie unter Eingeben von Sonderzeichen und Eingeben spezieller Leerzeichen. Eine Liste der Sonderzeichen finden Sie unter Überblick über die Eingabe in Dialogfenstern. Um einen umgekehrten Schrägstrich (\) in das Textfeld "Ändern" einzugeben, stellen Sie ihm einen zweiten umgekehrten Schrägstrich voran (\\).

Über das Dialogfenster "Suchen/Ändern" ist es nicht möglich, Markentext (z. B. einen Indexeintrag) zu ändern. Wenn der angegebene Markentext gefunden wird und Sie auf "Ändern" klicken, ersetzt FrameMaker die Marke (und nicht den Markentext) durch den Text im Feld "Ändern". Um den Markentext zu ändern, verwenden Sie den Befehl "Spezial > Marker" (siehe Bearbeiten und Löschen von Listeneinträgen).


Grundlagen in FrameMaker / Bearbeiten von Text / Ändern gefundener Elemente

Ändern der Zeichenformateinstellungen

Sie können die Zeichenformateinstellungen von beliebigem Text ändern, den FrameMaker findet. Sie können z. B. den Namen eines Produkts suchen und den Text in Kursivschrift ändern. Sie können auch sämtlichen Text suchen, der bestimmte Einstellungen aufweist, und dann die Einstellungen ändern.

So geben Sie die zu ändernden Zeichenformateinstellungen an:

    1. Führen Sie eine der folgenden Aktionen aus:

    Sollen mehrere Zeichenformateinstellungen geändert werden, klicken Sie in einen Textbereich, dessen Einstellungen dem gewünschten Zeichenformat ähneln.

    Um eine oder zwei Zeichenformateinstellungen zu ändern, klicken Sie in einen beliebigen Textabschnitt.

    2. Wählen Sie aus dem Aufklappmenü "Ändern" im Dialogfenster "Suchen/Ändern" den Eintrag "In Zeichenformat", geben Sie das gewünschte Zeichenformat an und klicken Sie auf "Zuweisen".

Soll eine Einstellung nicht für den gefundenen Text verwendet werden, setzen Sie sie auf "Beibehalten". Hierfür klicken Sie auf ein Markierungsfeld, bis es grau (Windows) oder abgedunkelt (UNIX) angezeigt wird, wählen die Option "Beibehalten" aus einem Aufklappmenü oder einer Auswahlliste oder löschen den Text aus einem Textfeld. Soll beispielsweise die Farbeinstellung des Textes nicht berücksichtigt werden, wählen Sie aus dem Aufklappmenü "Farbe" den Eintrag "Beibehalten". Wenn Sie alle Einstellungen auf "Beibehalten" einstellen wollen, drücken Sie Strg+Umschalttaste+F8 (Windows) oder Umschalttaste+F8 (UNIX).

Nachdem Sie die Änderungen im Dialogfenster "Ändern in Zeichenformat" vorgenommen haben, können Sie die Optionen auf das Format des aktuellen Textes zurücksetzen. Drücken Sie hierfür Strg+Umschalttaste+F9 (Windows) oder Umschalttaste+F9 (UNIX).


Grundlagen in FrameMaker / Bearbeiten von Text

Prüfen der Rechtschreibung

Die Rechtschreibhilfe in FrameMaker verwendet mehrere Wörterbücher, um Text auf Rechtschreibfehler zu prüfen. Bei einem unbekannten Wort zeigt die Rechtschreibhilfe neben der am nächsten liegenden Berichtigung noch andere Korrekturvorschläge an. Sie können einen Vorschlag auswählen, eigene Korrekturen eingeben oder das Wort unverändert lassen.

Die Rechtschreibhilfe findet Tipp- und Rechtschreibfehler. Sie können z. B. Wortwiederholungen, ungewöhnliche Bindestriche oder Groß-/Kleinschreibung, gerade Anführungszeichen (wenn typografische verwendet werden sollen) und zusätzliche Leerzeichen überprüfen.

Die Rechtschreibprüfung kann dabei auf die aktuelle Seite, das geöffnete Dokument, das ganze Buch oder die ausgewählten Dateien im Buch angewendet werden; sie erfolgt jedoch nur für Seiten des angezeigten Typs, z. B. Vorgabeseiten oder Arbeitsseiten.

Prüfen der Rechtschreibung in einem ganzen Buch

Bei der Rechtschreibprüfung in einem ganzen Buch beginnt FrameMaker mit dem aktiven Dokument (bzw. dem ersten Dokument im Buch, falls das Buchfenster aktiv ist) und fährt fort, bis alle Dokumente im Buch geprüft wurden. Wenn sich ein Dokument nicht öffnen lässt, wird es übergangen, und Sie erhalten eine entsprechende Meldung im Buchfehlerprotokoll. Bei einer Rechtschreibprüfung in einem ganzen Buch werden Vorgabe- oder Referenzseiten nicht berücksichtigt.

Weitere Informationen zum Einsatz von Funktionen, die das ganze Buch betreffen, finden Sie unter Verwenden von Befehlen, die sich auf das ganze Buch beziehen.


Grundlagen in FrameMaker / Bearbeiten von Text / Prüfen der Rechtschreibung

FrameMaker-Wörterbücher

Beim Prüfen eines Dokuments vergleicht FrameMaker jedes Wort mit den Einträgen in folgenden Wörterbüchern:

    Das Hauptwörterbuch enthält die Wörter eines Standardwörterbuches. Hinzufügen oder Löschen von Einträgen ist in diesem Wörterbuch nicht möglich.

    Das Standard-Gruppenwörterbuch enthält einige technische Begriffe. Sie können hier in Ihrer Firma oder Arbeitsgruppe verwendete Begriffe hinzufügen (z. B. Firmenname und Produktnamen). In Windows befindet sich das Gruppenwörterbuch normalerweise im FrameMaker-Verzeichnis "dict" in der Datei "site.dict". Auf UNIX-Systemen befindet sich das Wörterbuch in der Datei "$FMHOME/fminit/site.dict".

    Ihr persönliches Wörterbuch enthält Wörter, die Sie häufig verwenden. Da es in FrameMaker für die Rechtschreibprüfung aller Dokumente eingesetzt wird, sollten Sie es für Wörter verwenden, die weder dokument- noch gruppenspezifisch sind (z. B. Eigennamen). Sie können Wörter hinzufügen und entfernen. Sie können auch mehrere persönliche Wörterbücher anlegen und zwischen ihnen wechseln.

    Das Dokumentwörterbuch enthält Wörter für ein bestimmtes Dokument. FrameMaker verwendet dieses Wörterbuch unabhängig davon, wer das Dokument bearbeitet. Sie können in diesem Wörterbuch Wörter hinzufügen und löschen. Das Dokumentwörterbuch ist im Gegensatz zu den anderen Wörterbüchern Teil des Dokuments und keine eigene Datei.

Wenn Sie die Rechtschreibung eines ganzen Buches prüfen, werden Wörter, die Sie Ihrem persönlichen Wörterbuch hinzufügen, in allen Dokumenten des Buches berücksichtigt. In das Dokumentwörterbuch aufgenommene Wörter werden nur im aktuellen Dokument verwendet, nicht in den anderen Dokumenten des Buches. Informationen zum Zusammenführen Ihrer Dokumentwörterbücher finden Sie unter Verwalten des persönlichen Wörterbuchs und des Dokumentwörterbuchs.

In Adobe FrameMaker 8 sind die Wörterbücher, die Silbentrennung und der Thesaurus Unicode-aktiviert.

Neue Wörterbücher für die folgenden Sprachen wurden hinzugefügt: Bulgarisch, Estnisch, Griechisch, Kroatisch, Lettisch, Litauisch, Polnisch, Slowakisch, Slowenisch, Rumänisch, Russisch, Tschechisch, Türkisch, Ungarisch. Der Thesaurus ist für diese Sprachen jedoch nicht verfügbar.

Die vorhandenen Wörterbücher wurden für die folgenden Sprachen auf Version 11.0 von Proximity® aktualisiert: Brasilianisch (Thesaurus nicht verfügbar), Dänisch, Deutsch, Deutsch (Schweiz), Deutsch (Neue Rechtschreibung), Englisch (Großbritannien), Englisch (USA), Finnisch (Thesaurus nicht verfügbar), Französisch, Französisch (Kanada), Italienisch, Katalanisch (Thesaurus nicht verfügbar), Niederländisch, Niederländisch (Neue Rechtschreibung), Norwegisch, Nynorsk (Thesaurus nicht verfügbar), Portugiesisch (Thesaurus nicht verfügbar), Schwedisch und Spanisch.


Grundlagen in FrameMaker / Bearbeiten von Text / Prüfen der Rechtschreibung

Überprüfung auf Rechtschreib- und Tippfehler

Beim Prüfen eines Dokuments zeigt FrameMaker alle Wörter an, die sich nicht in einem der Wörterbücher befinden. Ist ein gemeldetes Wort richtig geschrieben, können Sie seine Schreibung bestätigen, indem Sie das Wort in Ihr persönliches oder in das Dokumentwörterbuch aufnehmen. Ist ein gemeldetes Wort falsch geschrieben, können Sie es berichtigen. FrameMaker bietet gewöhnlich mehrere Korrekturvorschläge an.

So prüfen und korrigieren Sie die Rechtschreibung:

    1. Wählen Sie "Bearbeiten > Rechtschreibhilfe".

    2. Führen Sie eine der folgenden Aktionen aus:

    Um das gesamte Dokument zu prüfen, klicken Sie in den Text und aktivieren im Dialogfenster "Rechtschreibhilfe" die Option "Dokument".

    Um eine Seite zu prüfen, klicken Sie in die Seite und aktivieren im Dialogfenster "Rechtschreibhilfe" die Option "Aktuelle Seite".

    Um ein vollständiges Buch zu prüfen, öffnen Sie das Buch oder ein Dokument des Buches und aktivieren im Dialogfenster "Rechtschreibhilfe" die Option "Buch". Weitere Informationen finden Sie unter Verwenden von Befehlen, die sich auf das ganze Buch beziehen.

    Soll nur bestimmter Text geprüft werden, wählen Sie ihn aus.

    Um ein Wort zu prüfen, setzen Sie die Einfügemarke in dieses Wort.

In den meisten Fällen soll die Rechtschreibprüfung des Textes auf den Arbeitsseiten durchgeführt werden. Wird eine Arbeitsseite nicht angezeigt, wählen Sie "Darstellung > Arbeitsseiten".

    3. Klicken Sie auf "Prüfung beginnen". Wenn Sie eine Textauswahl oder ein einzelnes Wort prüfen, klicken Sie bei gedrückter Umschalttaste auf "Prüfung beginnen".

FrameMaker beginnt die Rechtschreibprüfung an der Position der Einfügemarke. Wird ein unbekanntes Wort gefunden, wird es oben im Dialogfenster "Rechtschreibhilfe" angezeigt. Die Meldung links neben dem Textfeld (z. B. Falsch?) gibt an, warum das Wort angezeigt wird.

Hinweis: FrameMaker prüft nicht die Rechtschreibung von hoch- oder tiefgestelltem bzw. manuell mikropositioniertem Text (z. B. von Text mit einer manuellen Grundlinienverschiebung).

    4. Korrigieren oder bestätigen Sie die Schreibung wie folgt:

    Um ein falsch geschriebenes Wort zu korrigieren, vergewissern Sie sich, dass das Textfeld "Korrektur" das richtig geschriebene Wort enthält und klicken Sie auf "Korrigieren". Soll das vorgeschlagene Wort nicht verwendet werden, können Sie ein anderes Wort aus der Auswahlliste "Korrektur" wählen oder in das Textfeld "Korrektur" eingeben. Sie können auch die Einfügemarke in das Dokumentfenster setzen und dort das Wort richtig eingeben.

    Um einen Schreibfehler zu korrigieren (z. B. doppelt geschriebene Wörter wie und und), vergewissern Sie sich, dass das Textfeld "Korrektur" das richtig geschriebene Wort enthält, und klicken Sie auf "Korrigieren". FrameMaker zeigt nur einen Korrekturvorschlag für Tippfehler. Ist dieser nicht geeignet, können Sie den richtigen Text in das Textfeld "Korrektur" oder direkt in das Dokumentfenster eingeben.

Wenn FrameMaker einen potenziellen Fehler meldet, der jedoch ignoriert werden kann, deaktivieren Sie die entsprechende Option. Sie können z. B. verhindern, dass FrameMaker gerade Anführungszeichen als Fehler betrachtet. Weitere Informationen hierzu finden Sie unter Ändern der Optionen für die Rechtschreibhilfe.

    Um einem persönlichen Wörterbuch ein Wort hinzuzufügen, stellen Sie sicher, dass es neben "Falsch?" am oberen Rand des Dialogfensters "Rechtschreibhilfe" angezeigt wird, und klicken Sie auf "Aufnehmen".

    Um einem Dokumentwörterbuch ein Wort hinzuzufügen, stellen Sie sicher, dass es neben "Falsch?" am oberen Rand des Dialogfensters "Rechtschreibhilfe" angezeigt wird, und klicken Sie auf "Zulassen".

Hinweis: Wenn FrameMaker ein Wort mit Großbuchstaben in ein persönliches oder Dokumentwörterbuch aufnimmt und im Dialogfenster "Optionen für Rechtschreibhilfe" die Option "Unübliche Groß-/Kleinschreibung" aktiviert ist, werden alle anderen Schreibweisen des Wortes als Fehler angesehen. Wurde beispielsweise das Wort Trinidad hinzugefügt, werden die Schreibweisen TRINIDAD und trinidad als Fehler gemeldet. Wird jedoch trinidad in Kleinbuchstaben hinzugefügt, gelten alle anderen Schreibweisen des Worts als zulässig.

    5. Klicken Sie gegebenenfalls auf "Prüfung beginnen", um das nächste unbekannte Wort zu finden.

Beim Prüfen der Rechtschreibung in einem Buch fordert Sie eine Warnmeldung auf, das Dokument zu speichern, bevor Sie mit dem nächsten Dokument fortfahren. Nachdem das letzte Dokument im Buch geprüft wurde, wird die Meldung Rechtschreibung OK bzw. Rechtschreibprüfung beendet angezeigt.

So prüfen Sie die Rechtschreibung in Texteinschüben:

Öffnen Sie die Quelldatei des Texteinschubs und starten Sie die Prüfung.

So brechen Sie die Rechtschreibprüfung ab:

    (Windows) Drücken Sie Esc.

    (UNIX) Drücken Sie Control+c.


Grundlagen in FrameMaker / Bearbeiten von Text / Prüfen der Rechtschreibung

Automatisches Korrigieren von Rechtschreibfehlern

Sie können FrameMaker anweisen, alle Vorkommen von falsch geschriebenen Wörtern oder Schreibfehlern automatisch zu korrigieren. Der Fehler wird dann in keinem Dokument mehr angezeigt und muss nicht mehr korrigiert werden. FrameMaker berücksichtigt automatisch zu korrigierende Fehler, bis Sie das Programm beenden oder die Rechtschreibprüfung abbrechen.

Sie sollten einen Fehler nur dann automatisch korrigieren, wenn Sie genau wissen, welche Änderungen noch durchgeführt werden. Wenn Sie z. B. die Option "Automatische Korrektur" beim Ändern eines doppelt geschriebenen Wortes verwenden, ändert FrameMaker alle Wortwiederholungen, auch wenn einige richtig sind (z. B. die die). Sie sollten auch keine automatische Korrektur verwenden, wenn die Zuordnung nicht eindeutig ist (z. B. das falsch geschriebene haqt für die Wörter hast und hart).

So werden Rechtschreibfehler automatisch korrigiert:

    1. Wählen Sie "Bearbeiten > Rechtschreibhilfe" und klicken Sie auf "Prüfung beginnen".

    2. Wenn FrameMaker einen Fehler meldet, aktivieren Sie "Automatische Korrektur" und klicken auf "Korrigieren".

So beenden Sie die automatische Korrektur:

    1. Wählen Sie "Bearbeiten > Rechtschreibhilfe" und klicken Sie auf "Wörterbücher".

    2. Klicken Sie im Dialogfenster "Wörterbuchfunktionen" auf "Liste für automatische Korrekturen löschen" und dann auf "OK".


Grundlagen in FrameMaker / Bearbeiten von Text / Prüfen der Rechtschreibung

Ändern der Optionen für die Rechtschreibhilfe

Bei der Rechtschreibprüfung eines Dokuments ermittelt FrameMaker auch Fehler, die nicht die Rechtschreibung betreffen (z. B. Wortwiederholungen, überflüssige oder falsch gesetzte Leerzeichen oder unübliche Großschreibung). Sie können festlegen, welche Eingabefehler bei der Prüfung berücksichtigt werden.

Sie können die Rechtschreibprüfung auch so einschränken, dass FrameMaker bestimmte Wörter ignoriert. So können Sie z. B. Wörter mit Ziffern ausschließen.

So ändern Sie die Rechtschreibhilfeoptionen:

    1. Wählen Sie "Bearbeiten > Rechtschreibhilfe" und klicken Sie auf "Optionen".

    2. Führen Sie folgende Schritte durch:

    Geben Sie im Bereich "Suchen" die Schreibfehler an, die gemeldet werden sollen. Mit der Option "Unübliche Groß-/Kleinschreibung" können Sie beispielsweise nach Wörtern mit Großbuchstaben an den falschen Positionen suchen (z. B. GRün).

    Im Bereich "Ignorieren" können Sie angeben, welche Wörter bei der Prüfung ignoriert werden sollen. Wählen Sie beispielsweise "Wörter mit Ziffern", wenn Wörter nicht beachtet werden sollen, die Ziffern enthalten.

Denken Sie daran, dass durch das Ignorieren vieler Wörter die Wahrscheinlichkeit steigt, dass Ihr Dokument Fehler enthält. Wenn Sie beispielsweise festlegen, dass Wörter mit Punkten ignoriert werden, wird auch ein Satz übersprungen, der direkt nach einem Punkt beginnt.

    Mit "Standard" können Sie die Optionen auf ihre Standardwerte zurücksetzen. Wenn Sie unter Windows die Optionen der Rechtschreibhilfe ändern und FrameMaker beenden, ohne die Standardwerte wiederherzustellen, werden Ihre aktuellen Einstellungen als Standardoptionen verwendet.

    3. Klicken Sie auf "Zuweisen".


Grundlagen in FrameMaker / Bearbeiten von Text / Prüfen der Rechtschreibung

Erneute Prüfung nach dem Ändern von Wörterbuchoptionen

FrameMaker prüft gewöhnlich nur die Absätze erneut, die seit der letzten Prüfung bearbeitet wurden. Wenn Sie nach Prüfen eines Dokuments die Optionen ändern, sollten Sie FrameMaker auffordern, alle Absätze für erneute Prüfung zu markieren, und dann die Rechtschreibprüfung noch einmal durchführen.

Weitere Informationen zum Ändern der Wörterbuchoptionen finden Sie unter Verwalten von Wörterbüchern.

So markieren Sie alle Absätze für eine erneute Prüfung:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Bearbeiten > Rechtschreibhilfe". Wenn ein Buchfenster aktiv ist, wählen Sie "Auswahl" oder "Buch", um nur die ausgewählten Dateien bzw. das ganze Buch einzubeziehen.

    3. Klicken Sie auf "Wörterbücher".

    4. Wählen Sie "Alle Absätze für erneute Prüfung markieren" und klicken Sie auf "OK".


Grundlagen in FrameMaker / Bearbeiten von Text / Prüfen der Rechtschreibung

Überspringen von Text beim Prüfen der Rechtschreibung

Wenn FrameMaker bestimmte Textpassagen nicht prüfen soll, ändern Sie den Wert der Einstellung "Sprache" in "Keine" (siehe Prüfen der Rechtschreibung in verschiedenen Sprachen). So können Sie z. B. Absätze mit Computercode von der Prüfung ausnehmen.

Wenn Sie die Sprache des Textes auf "Keine" setzen, führt FrameMaker keine automatische Silbentrennung mehr durch.


Grundlagen in FrameMaker / Bearbeiten von Text / Prüfen der Rechtschreibung

Prüfen der Rechtschreibung in verschiedenen Sprachen

Jedem Text ist eine Sprache zugewiesen. Bei der Rechtschreibprüfung verwendet FrameMaker das Hauptwörterbuch der betreffenden Sprache. Durch Zuweisen einer anderen Sprache können Sie festlegen, in welcher Sprache die Rechtschreibung geprüft wird. In FrameMaker können Sie Benutzerwörterbüchern und persönlichen Wörterbüchern Unicode-codierte (UTF-8) Wörter hinzufügen.

Die FrameMaker-CD enthält Wörterbücher für alle unterstützten Sprachen. Bei der Standardinstallation unter Windows wird jedoch nur ein Wörterbuch in einer einzigen Sprache installiert.

Wenn Sie die Rechtschreibung eines Dokuments mit unterschiedlichen Sprachen prüfen, beachten Sie Folgendes:

    In einem asiatischen Dokument mit Zeichenschrift werden möglicherweise einige Sonderzeichen nicht in der Rechtschreibhilfe angezeigt, da sie sich in einem Dokument mit einer Buchstabenschrift befinden. Ein umgekehrter Schrägstrich wird z. B. als Yen-Symbol angezeigt und ein umbruchgeschützter Bindestrich erscheint als Leerzeichen.

    Stellen Sie in einem asiatischen Dokument mit lateinischen Buchstaben sicher, dass die Option "Anführungszeichen" im Dialogfenster "Rechtschreibhilfe" deaktiviert ist, damit die Rechtschreibhilfe nicht bei korrekt geschriebenen Wörtern anhält.

So ändern Sie die Sprache von Text in einem Dokument:

    Um die Sprache eines Absatzes oder aller Absätze in einem Dokument zu ändern, verwenden Sie auf der Registerkarte "Standardschrift" des Fensters "Absatzgestaltung" die Option "Sprache" (siehe Verwenden der Gestaltungsfenster zum Ändern von Schrifteinstellungen).

    Um die Sprache eines Textbereichs in einem Absatz oder einer Textzeile zu ändern, verwenden Sie die Option "Sprache" im Fenster "Zeichengestaltung" (siehe Verwenden der Gestaltungsfenster zum Ändern von Schrifteinstellungen).


Grundlagen in FrameMaker / Bearbeiten von Text

Steuern der Silbentrennung

Wenn Sie einem persönlichen Wörterbuch ein Wort hinzufügen, berechnet FrameMaker die Positionen, an denen es getrennt werden kann. Sagen Ihnen die vorgeschlagenen Trennpositionen nicht zu, können Sie sie vor dem Hinzufügen des Wortes ändern. Sie können auch festlegen, dass ein Wort immer oder nie getrennt wird. Sie könnten beispielsweise das Wort CD-ROM immer, jedoch Ihren Firmennamen nie trennen.

Wenn Sie die Trenneinstellungen ändern, sollten Sie im Dokument erneut eine Silbentrennung durchführen. Weitere Informationen zur Silbentrennung finden Sie unter Ändern von Silbentrennung und Zeilenumbruch.

Wenn eine genaue Steuerung der Silbentrennung erforderlich ist (z. B. bevor der Probeauszug eines Buches gedruckt wird), sollten Sie das gesamte Dokument nach automatisch eingefügten Trennstrichen durchsuchen. Wählen Sie hierfür im Dialogfenster "Suchen/Ändern" aus dem Aufklappmenü "Suchen" die Option "Automat. Trennstrich".

So zeigen Sie die Trennpositionen eines Wortes an:

Wählen Sie "Bearbeiten > Rechtschreibhilfe", geben Sie das gewünschte Wort in das Textfeld "Wort" ein und klicken Sie auf "Trennung anzeigen". Befindet sich das Wort im Hauptwörterbuch oder in Ihrem persönlichen Wörterbuch, zieht FrameMaker dieses zur Bestimmung der Trennpositionen heran. Enthält keines dieser Wörterbücher das Wort, berechnet FrameMaker die Trennpositionen.

So ändern Sie die Trennung eines Wortes:

    1. Zeigen Sie die Trennpositionen des Wortes an (siehe vorheriger Abschnitt).

    2. Ändern Sie die Silbentrennung, und klicken Sie auf "Aufnehmen". Sie können Trennstriche nach Bedarf hinzufügen und entfernen.

Neuerscheinung kann nicht als Neu-erscheinung getrennt werden.

So legen Sie fest, dass FrameMaker ein Wort nie trennt:

    1. Geben Sie das gewünschte Wort in das Textfeld "Korrektur" ein.

    2. Klicken Sie auf "Trennung anzeigen".

    3. Entfernen Sie alle Trennstriche aus dem Wort.

    4. Fügen Sie einen Trennstrich vor dem Wort hinzu.

    5. Klicken Sie auf "Aufnehmen".

Das Wort "Wort" kann nicht getrennt werden.

So führen Sie erneut eine automatische Silbentrennung für das gesamte Dokument durch:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Bearbeiten > Rechtschreibhilfe". Wenn ein Buchfenster aktiv ist, wählen Sie "Auswahl" oder "Buch", um nur die ausgewählten Dateien bzw. das ganze Buch einzubeziehen.

    3. Klicken Sie auf "Wörterbücher".

    4. Wählen Sie "Dokument neu trennen", "Ausgewählte Dateien im Buch neu trennen" bzw. "Alle Dateien im Buch neu trennen" und klicken Sie auf "OK".


Grundlagen in FrameMaker / Bearbeiten von Text

Verwalten von Wörterbüchern

Sie haben umfangreiche Steuerungsmöglichkeiten für das persönliche Wörterbuch, Dokumentwörterbuch und Gruppenwörterbuch. So können Sie z. B. Wörter hinzufügen und entfernen oder ihre Silbentrennung ändern. Sie können auch aus verschiedenen Wörterbüchern wählen oder Wörterbücher zusammenführen und löschen.

Verwalten des persönlichen Wörterbuchs und des Dokumentwörterbuchs

FrameMaker erstellt automatisch ein persönliches Wörterbuch für Sie und ein Dokumentwörterbuch für jedes der Dokumente. Sie können über die Rechtschreibhilfe Wörter in diesen Wörterbüchern hinzufügen und löschen oder die Wörterbücher direkt verwalten. Bei der direkten Arbeit mit einem Wörterbuch können Sie den Inhalt anzeigen und bearbeiten oder es mit einem anderen Wörterbuch zusammenführen. Sie können mehrere persönliche Wörterbücher erstellen und sie einzeln verwenden.

Wenn Sie ein persönliches Wörterbuch oder ein Dokumentwörterbuch ändern, sollten Sie alle Absätze für eine erneute Prüfung markieren, bevor Sie im Dokument eine erneute Rechtschreibprüfung durchführen. Anweisungen hierzu finden Sie unter Erneute Prüfung nach dem Ändern von Wörterbuchoptionen.

So löschen Sie ein Wort aus dem persönlichen Wörterbuch oder einem Dokumentwörterbuch:

Wählen Sie "Bearbeiten > Rechtschreibhilfe", geben Sie das betreffende Wort in das Textfeld "Korrektur" ein und klicken Sie auf "Streichen".

So löschen Sie den Inhalt des Dokumentwörterbuchs:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Bearbeiten > Rechtschreibhilfe". Wenn ein Buchfenster aktiv ist, wählen Sie "Auswahl" oder "Buch", um nur die ausgewählten Dateien bzw. das ganze Buch einzubeziehen.

    3. Klicken Sie auf "Wörterbücher".

    4. Wählen Sie aus dem Aufklappmenü "Dokumentwörterbuch" (oder "Dokumentwörterbücher") den Eintrag "Löschen" und klicken Sie auf "OK".

So löschen Sie ein persönliches Wörterbuch:

Löschen Sie die Datei, die das Wörterbuch enthält. (Sie können den Namen des Wörterbuchs ermitteln, indem Sie "Bearbeiten > Rechtschreibhilfe" wählen und auf "Wörterbücher" klicken. Der Name Ihres persönlichen Wörterbuchs wird im Dialogfenster "Wörterbuchfunktionen" angezeigt.)

So erstellen Sie ein weiteres persönliches Wörterbuch:

    1. Erstellen Sie ein Dokument mit den Wörtern (mit einem Trennstrich an jeder Trennposition). Geben Sie als erste Zeile <MakerDictionary 2.0> in das Dokument ein.

    2. Wählen Sie beim Speichern der Datei "Nur Text" und klicken Sie auf "Sichern". Klicken Sie dann auf "Nur zwischen Absätzen" und "Sichern".

So verwenden Sie ein anderes persönliches Wörterbuch:

    1. Wählen Sie "Bearbeiten > Rechtschreibhilfe" und klicken Sie auf "Wörterbücher". Der Name Ihres persönlichen Wörterbuchs wird im Dialogfenster "Wörterbuchfunktionen" angezeigt.

    2. Wählen Sie aus dem Aufklappmenü "Persönliches Wörterbuch" den Eintrag "Wörterbuch wechseln" und bestätigen Sie mit "OK".

    3. Geben Sie den Dateinamen des persönlichen Wörterbuchs an, das Sie verwenden wollen.

So prüfen Sie die Rechtschreibung eines Dokuments, ohne das persönliche Wörterbuch zu verwenden:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Bearbeiten > Rechtschreibhilfe". Wenn ein Buchfenster aktiv ist, wählen Sie "Auswahl" oder "Buch", um nur die ausgewählten Dateien bzw. das ganze Buch einzubeziehen.

    3. Klicken Sie auf "Wörterbücher".

    4. Wählen Sie aus dem Aufklappmenü "Persönliches Wörterbuch" die Option "Keines" und bestätigen Sie mit "OK".

So kopieren Sie den Inhalt eines Wörterbuchs in eine Datei:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Bearbeiten > Rechtschreibhilfe". Wenn ein Buchfenster aktiv ist, wählen Sie "Auswahl" oder "Buch", um nur die ausgewählten Dateien bzw. das ganze Buch einzubeziehen.

    3. Klicken Sie auf "Wörterbücher".

    4. Wählen Sie aus dem Aufklappmenü "Persönliches Wörterbuch" oder "Dokumentwörterbuch" die Option "In Datei schreiben" und bestätigen Sie mit "OK".

    5. Geben Sie die Datei an, in die Sie den Inhalt des Wörterbuchs kopieren wollen. Sie können die Datei anschließend bearbeiten und als neues Wörterbuch verwenden.

Wenn bei der Wahl dieses Befehls ein Buchfenster aktiv ist, werden die Dokumentwörterbücher in eine einzige Datei geschrieben.

So lesen Sie den Inhalt eines Wörterbuchs in das aktuelle persönliche oder Dokumentwörterbuch ein:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Bearbeiten > Rechtschreibhilfe". Wenn ein Buchfenster aktiv ist, wählen Sie "Auswahl" oder "Buch", um nur die ausgewählten Dateien bzw. das ganze Buch einzubeziehen.

    3. Klicken Sie auf "Wörterbücher".

    4. Wählen Sie aus dem Aufklappmenü "Persönliches Wörterbuch" oder "Dokumentwörterbuch" die Option "Aus Datei einlesen" und bestätigen Sie mit "OK".

    5. Geben Sie die Datei an, die in das aktuelle Wörterbuch eingelesen werden soll.

Mithilfe des Befehls "Aus Datei einlesen" können Sie ein einzelnes Wörterbuch in mehrere Buchdateien einlesen, damit alle Dateien im Buch dasselbe Wörterbuch besitzen.


Grundlagen in FrameMaker / Bearbeiten von Text / Verwalten von Wörterbüchern

Verwalten von Gruppenwörterbüchern

Sie können für jedes Ihrer Projekte ein anderes Gruppenwörterbuch angeben. Gruppenwörterbücher können auch direkt bearbeitet werden.

Wenn Sie FrameMaker in einer Arbeitsgruppe im Netzwerk verwenden, wird das Gruppenwörterbuch wahrscheinlich vom Systemadministrator gepflegt.

So geben Sie ein anderes Gruppenwörterbuch an:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Geben Sie das Wörterbuch in der Datei "marker.ini" an. Weitere Informationen hierzu finden Sie im online verfügbaren Handbuch Anpassen von FrameMaker-Produkten auf der folgenden Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.

    (UNIX) Bearbeiten Sie die Ressource Maker.siteDict. Weitere Informationen hierzu finden Sie im online verfügbaren Handbuch Anpassen von FrameMaker-Produkten auf der folgenden Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.


Grundlagen in FrameMaker / Bearbeiten von Text / Verwalten von Wörterbüchern

Bearbeiten von Wörterbuchdateien

Sie können den Inhalt Ihres persönlichen oder des Dokumentwörterbuchs ändern, indem Sie während der Rechtschreibprüfung im Dialogfenster "Rechtschreibhilfe" auf "Aufnehmen", "Zulassen" und "Streichen" klicken. Persönliche, Dokument- und Gruppenwörterbücher können auch direkt bearbeitet werden.

So bearbeiten Sie eine Wörterbuchdatei direkt:

    1. Wenn Sie ein persönliches oder Dokumentwörterbuch bearbeiten, verwenden Sie FrameMaker, um den Inhalt in eine externe Datei zu schreiben. Anweisungen hierzu finden Sie unter Verwalten des persönlichen Wörterbuchs und des Dokumentwörterbuchs.

    2. Ändern Sie die Datei. Wenn Sie ein Wörterbuch mithilfe von FrameMaker bearbeiten, gehen Sie folgendermaßen vor:

    Aktivieren Sie beim Öffnen der Datei im Dialogfenster "Textdatei einlesen" die Option "Zeilenenden als Absatzenden einlesen" und klicken Sie anschließend auf "Einlesen".

    Wählen Sie beim Speichern der Datei "Nur Text". Stellen Sie sicher, dass Sie den Dateinamen richtig angegeben haben, und klicken Sie auf "Sichern". Klicken Sie dann auf "Nur zwischen Absätzen" und "Sichern".

    3. Führen Sie die Datei mit einem anderen Wörterbuch zusammen. Anweisungen hierzu finden Sie unter Verwalten des persönlichen Wörterbuchs und des Dokumentwörterbuchs. Wenn Sie Wörter aus dem Wörterbuch entfernt haben, löschen Sie das Originalwörterbuch vor dem Einlesen in die Datei. Andernfalls verbleiben die gelöschten Einträge im Wörterbuch.


Grundlagen in FrameMaker / Bearbeiten von Text / Verwalten von Wörterbüchern

Hinzufügen unbekannter Wörter zu einem Wörterbuch

Enthält Ihr Dokument viele richtig geschriebene Wörter, die FrameMaker als unbekannt meldet, können Sie die Rechtschreibprüfung beschleunigen, indem Sie diese Wörter vor Beginn der Prüfung in ein Wörterbuch aufnehmen.

So fügen Sie einem Wörterbuch alle unbekannten Wörter hinzu:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Bearbeiten > Rechtschreibhilfe". Wenn ein Buchfenster aktiv ist, wählen Sie "Auswahl" oder "Buch", um nur die ausgewählten Dateien bzw. das ganze Buch einzubeziehen.

    3. Klicken Sie auf "Wörterbücher".

    4. Klicken Sie auf "Unbekannte Wörter in Datei aufzeichnen" und bestätigen Sie mit "OK".

    5. Geben Sie einen Namen für die Wörterbuchdatei ein und klicken Sie auf "OK" oder "Sichern". FrameMaker erstellt eine Wörterbuchdatei mit allen unbekannten Wörtern im Dokument. In die Datei werden keine Schreibfehler wie Wortwiederholungen oder überflüssige Leerzeichen aufgenommen.

    6. Bearbeiten Sie die Wörterbuchdatei mit einem Texteditor oder in FrameMaker (siehe Bearbeiten von Wörterbuchdateien). Entfernen Sie alle Wörter aus der Datei, die nicht in das Wörterbuch aufgenommen werden sollen (z. B. falsch geschriebene Wörter).

    7. Klicken Sie im Dialogfenster "Rechtschreibhilfe" auf "Wörterbücher".

    8. Wählen Sie aus dem Aufklappmenü "Persönliches Wörterbuch" oder "Dokumentwörterbuch" den Eintrag "Aus Datei einlesen" und bestätigen Sie mit "OK". Wenn die Wörter voraussichtlich in mehreren Dokumenten auftreten, sollten Sie sie in ein persönliches Wörterbuch einlesen oder mit allen Dateien in einem Buch zusammenführen.

    9. Benennen und speichern Sie die Wörterbuchdatei.


Grundlagen in FrameMaker / Bearbeiten von Text / Verwalten von Wörterbüchern

Hinzufügen von Komposita mit Bindestrichen zu Ihrem persönlichen Wörterbuch

Ihr Dokument kann auch zusammengesetzte Wörter (Komposita) enthalten, die durch Bindestriche verbunden sind (z. B. ein Begriff, der aus mehreren Wörtern besteht). Standardmäßig prüft FrameMaker die Rechtschreibung jedes einzelnen Wortes in einem solchen Kompositum, anstatt alle durch Bindestriche verbundenen Wörter als einen Begriff zu behandeln. So werden z. B. bei der Rechtschreibprüfung des Wortes Kfz-Papiere die Bestandteile Kfz und Papiere jeweils als einzelne Wörter geprüft. Durch Ändern der Standardeinstellungen können Sie zusammengesetzte Wörter als ein Wort prüfen und in Ihr persönliches Wörterbuch aufnehmen.

So fügen Sie Ihrem persönlichen Wörterbuch ein zusammengesetztes Wort hinzu:

    1. Wählen Sie "Bearbeiten > Rechtschreibhilfe" und klicken Sie auf "Optionen".

    2. Aktivieren Sie "Unübliche Trennung" und klicken Sie auf "Zuweisen". FrameMaker prüft dann durch Bindestriche verbundene Wörter als einen Begriff und nicht mehr als einzelne Wörter.

    3. Geben Sie in das Textfeld "Wort" im Dialogfenster "Rechtschreibhilfe" das zusammengesetzte Wort ein, das in Ihr persönliches Wörterbuch aufgenommen werden soll. Geben Sie am Wortanfang einen Bindestrich und vor jedem Bindestrich einen umgekehrten Schrägstrich (\) ein.

Um beispielsweise das Wort Kfz-Papiere hinzuzufügen, geben Sie -Kfz\-Papiere ein. Weitere Informationen zum Festlegen der Trennpunkte finden Sie unter Steuern der Silbentrennung.

    4. Klicken Sie auf "Aufnehmen".


Grundlagen in FrameMaker / Bearbeiten von Text

Verwenden des Thesaurus

Im Thesaurus können Sie Synonyme und ähnliche Begriffe für angegebene Wörter suchen. Wenn Sie z. B. das Wort Einbildung angeben, zeigt der FrameMaker-Thesaurus Synonyme wie Vorstellung und Täuschung sowie ähnliche Begriffe wie Bildung oder Fantasie an. Der Thesaurus ermöglicht Ihnen, einen geeigneteren Begriff für ein bereits im Dokument vorhandenes Wort oder ein einzufügendes Wort zu suchen. Sie können z. B. Einbildung durch eines seiner Synonyme, durch ein ähnliches Wort oder ein Antonym ersetzen.

Das Nachschlagen eines Wortes muss nicht bei den ersten angezeigten Begriffen enden. Sie können auch nach diesen Wörtern suchen und wiederum deren Synonyme, ähnliche Begriffe und Antonyme anzeigen. Sie können rasch zu jedem der zehn zuletzt nachgeschlagenen Wörter zurückkehren.


Grundlagen in FrameMaker / Bearbeiten von Text / Verwenden des Thesaurus

Nachschlagen von Wörtern

Beim Nachschlagen eines Wortes werden Informationen zu diesem Wort im Dialogfenster "Thesaurus" angezeigt.

Wenn nicht alle Informationen im Dialogfenster Platz finden, können Sie mit den Pfeilfeldern am unteren Fensterrand weitere Informationen anzeigen. FrameMaker zeigt Synonyme, Antonyme und ähnliche Begriffe an, deren Groß-/Kleinschreibung der des nachgeschlagenen Wortes entsprechen.

So schlagen Sie ein Wort nach, das im Dokumentfenster angezeigt wird:

Markieren Sie das Wort und wählen Sie "Bearbeiten > Thesaurus".

So schlagen Sie ein Wort nach, das nicht im Dokumentfenster angezeigt wird:

    1. Stellen Sie sicher, dass kein Text ausgewählt ist und wählen Sie "Bearbeiten > Thesaurus".

    2. Geben Sie das Wort ein und klicken Sie auf "Nachschlagen".

So schlagen Sie eine Wortverbindung nach:

    1. Stellen Sie sicher, dass kein Text ausgewählt ist, und wählen Sie "Bearbeiten > Thesaurus".

    2. Geben Sie die Wortverbindung (einschließlich Bindestriche) in das Dialogfenster "Thesaurus-Referenz" ein und klicken Sie auf "Nachschlagen".

Hinweis: Wenn Sie eine Wortverbindung durch Auswählen im Dokumentfenster angeben, schlägt FrameMaker nur das erste markierte Wort nach.

So schlagen Sie ein im Dialogfenster "Thesaurus" angezeigtes Synonym, Antonym oder ähnliches Wort nach:

Klicken Sie auf das Wort. Die Synonyme, ähnlichen Wörter und Antonyme werden in Fettschrift angezeigt.

So schlagen Sie ein Wort erneut nach:

Wählen Sie das gewünschte Wort aus dem Aufklappmenü "Wort" des Dialogfensters "Thesaurus". Dieses Menü listet die zehn zuletzt nachgeschlagenen Wörter auf.


Grundlagen in FrameMaker / Bearbeiten von Text / Verwenden des Thesaurus

Wählen einer Sprache

FrameMaker verwendet beim Nachschlagen die Sprache des aktuellen Textes. Ist kein Wort ausgewählt oder befindet sich die Einfügemarke nicht in einem Absatz, verwendet FrameMaker die Sprache, die Sie bei der Installation gewählt haben. Sie können die Standardsprache für neue Dokumente außer Kraft setzen, indem Sie Ihre eigene Schablone erstellen. Weitere Informationen hierzu finden Sie unter Ändern von Schablonen für leeres Papier und Textdateien.

Der Thesaurus für eine Sprache wird zusammen mit dem Wörterbuch installiert. Weitere Informationen hierzu finden Sie unter Prüfen der Rechtschreibung in verschiedenen Sprachen.

So geben Sie beim Nachschlagen eine andere Sprache an:

    1. Klicken Sie im Dialogfenster "Thesaurus" auf "Nachschlagen".

    2. Geben Sie das nachzuschlagende Wort ein, wählen Sie die gewünschte Sprache und klicken Sie auf "Nachschlagen".


Grundlagen in FrameMaker / Bearbeiten von Text / Verwenden des Thesaurus

Verwenden von Wörtern aus dem Thesaurus

Sie können Ihrem Dokument Wörter aus dem Dialogfenster "Thesaurus" hinzufügen oder Wörter ersetzen. Dabei können Sie entweder das nachgeschlagene Wort oder die in Fettschrift angezeigten Begriffe verwenden.

Wenn Sie ein Wort im Dokument durch ein Wort aus dem Dialogfenster "Thesaurus" ersetzen, wird jeweils nur das ausgewählte Wort ersetzt (nicht alle Wortentsprechungen). Sollen alle Übereinstimmungen des Wortes ersetzt werden, wählen Sie "Bearbeiten > Suchen/Ändern" (siehe Ändern gefundener Elemente).

So fügen Sie ein im Dialogfenster "Thesaurus" nachgeschlagenes Wort in ein Dokument ein:

    1. Führen Sie eine der folgenden Aktionen aus:

    Soll das Wort hinzugefügt werden, setzen Sie die Einfügemarke in das Dokument.

    Soll ein Wort im Dokument ersetzt werden, wählen Sie es aus.

    2. Klicken Sie auf "Ersetzen".

So fügen Sie ein Wort ein, das im Dialogfenster "Thesaurus" in Fettschrift angezeigt wird:

    1. Führen Sie eine der folgenden Aktionen aus:

    Soll das Wort hinzugefügt werden, setzen Sie die Einfügemarke in das Dokument.

    Soll ein Wort im Dokument ersetzt werden, wählen Sie es aus.

    2. Halten Sie im Dialogfenster "Thesaurus" die Strg- bzw. Control-Taste gedrückt, klicken Sie auf das Wort und wählen Sie "Ersetzen".


Grundlagen in FrameMaker / Bearbeiten von Text

Arbeiten mit Text in strukturierten Dokumenten

Die Arbeitsschritte zum Auswählen und Bearbeiten von Text in einem strukturierten Dokument unterscheiden sich vom Arbeiten mit unstrukturierten Dokumenten.


Grundlagen in FrameMaker / Bearbeiten von Text / Arbeiten mit Text in strukturierten Dokumenten

Platzieren der Einfügemarke in einem strukturierten Dokumentfenster

Sie können eine Einfügemarke an einer beliebigen Stelle des Textrahmens im Dokumentfenster einfügen. Die Einfügemarke wird dann auch an der entsprechenden Position in der Strukturansicht angezeigt.

Wenn Sie die Einfügemarke in der Textmitte platzieren möchten, müssen Sie statt in der Strukturansicht im Dokumentfenster arbeiten. In einigen Fällen, insbesondere wenn Sie die Einfügemarke am Anfang oder Ende eines Elements oder zwischen Elementen platzieren möchten, bietet es sich jedoch an, mit der Strukturansicht zu arbeiten.

Sie sollten mit eingeblendeten Elementgrenzen arbeiten, damit Sie den Anfang und das Ende der einzelnen Elemente sehen können (siehe Ein- und Ausblenden von Elementgrenzen). Überprüfen Sie anhand der Namensanzeige in der Statusleiste, ob Sie auf das gewünschte Element geklickt haben. Beachten Sie, dass in FrameMaker Elementgrenzen wie Zeichen behandelt werden. Wenn Sie Elementgrenzen aktivieren oder deaktivieren, wird das Dokument in FrameMaker neu formatiert.

So platzieren Sie die Einfügemarke im Text eines Elements:

Klicken Sie in den Text.

Wenn Sie an den Textanfang klicken, befindet sich links neben der dreieckigen Einfügemarke in der Strukturansicht ein Strich ( [image] ). Wenn Sie an das Textende klicken, erscheint rechts von der dreieckigen Einfügemarke ein Strich ( [image] ). Wenn Sie in die Textmitte klicken, ist die dreieckige Einfügemarke nicht ausgefüllt ( [image] ).

So platzieren Sie die Einfügemarke am Textanfang eines Elements:

Klicken Sie direkt rechts neben die Startklammer des Elements.

Einfügemarke am Textanfang

So platzieren Sie die Einfügemarke am Textende eines Elements:

Klicken Sie direkt links neben die Endklammer eines Elements.

Einfügemarke am Textende

So platzieren Sie die Einfügemarke zwischen zwei Elementen:

Klicken Sie zwischen die Endklammer des einen und die Startklammer des anderen Elements.

Einfügemarke zwischen zwei Elementen


Grundlagen in FrameMaker / Bearbeiten von Text / Arbeiten mit Text in strukturierten Dokumenten

Platzieren der Einfügemarke in der Strukturansicht

In der Strukturansicht können Sie die Einfügemarke am Textanfang bzw. Textende eines Elements oder zwischen zwei Elementen platzieren. Die Einfügemarke wird auch an der entsprechenden Position im Dokumentfenster angezeigt.

So platzieren Sie die Einfügemarke am Textanfang eines Elements:

Klicken Sie links neben den Textausschnitt oder in die erste Hälfte des Textausschnitts. Anschließend zeigt eine Linie links neben der dreieckigen Einfügemarke an, dass diese sich an einem Textanfang befindet.

Einfügemarke am Textanfang

So platzieren Sie die Einfügemarke am Textende eines Elements:

Klicken Sie rechts neben den Textausschnitt oder in die zweite Hälfte des Textausschnitts. Anschließend zeigt eine Linie rechts neben der dreieckigen Einfügemarke an, dass diese sich an einem Textende befindet.

Einfügemarke am Textende

So platzieren Sie die Einfügemarke zwischen zwei Elementen:

Klicken Sie zwischen den Rechtecken rechts neben die vertikale Linie, die die Elemente verbindet.

Einfügemarke zwischen zwei Elementen


Grundlagen in FrameMaker / Bearbeiten von Text / Arbeiten mit Text in strukturierten Dokumenten

Auswählen in einem strukturierten Dokumentfenster

In einem Dokumentfenster können Sie ganze Elemente sowie beliebige Teile des Dokumentinhalts auswählen. Eine entsprechende Auswahl spiegelt sich in der Strukturansicht wider.

Wenn ein Element über Inhalt verfügt, können Sie den gesamten Inhalt oder einen Teil davon auswählen, ohne das Element selbst auszuwählen. Wenn ein Element aus einem einzelnen Objekt, z. B. einer Grafik oder einem Querverweis, besteht, müssen Sie das gesamte Element auswählen.

Wenn Sie ein gesamtes Element auswählen, wird dessen Inhalt ebenfalls ausgewählt.

Sie sollten mit eingeblendeten Elementgrenzen arbeiten, damit Sie den Anfang und das Ende der einzelnen Elemente sehen können (siehe Ein- und Ausblenden von Elementgrenzen). Überprüfen Sie, ob nach dem Auswählen der Tag-Name des entsprechenden übergeordneten Elements in der Statuszeile angezeigt wird. Der Tag-Name erscheint nach dem Text unter "E:". Mithilfe des Tag-Namens können Sie überprüfen, ob Sie tatsächlich das gewünschte Element ausgewählt haben.

So wählen Sie Text in einem Element, nicht jedoch das Element selbst aus:

Ziehen Sie den Zeiger über den gewünschten Textbereich. Achten Sie darauf, den Zeiger nicht über die Elementgrenze hinweg zu ziehen, andernfalls wird das gesamte Element ausgewählt.

Ausgewählter Text

So wählen Sie ein Element aus:

Klicken Sie an beliebiger Stelle in das Element und ziehen Sie den Zeiger über eine der Elementgrenzen hinaus.

Ausgewähltes Element

So wählen Sie mehrere Elemente aus:

Ziehen Sie den Zeiger über die Elemente. FrameMaker wählt dabei jedes Element aus, über dessen Elementgrenzen Sie den Zeiger ziehen.


Grundlagen in FrameMaker / Bearbeiten von Text / Arbeiten mit Text in strukturierten Dokumenten

Auswählen in der Strukturansicht

Sie können in der Strukturansicht vollständige Elemente oder den Inhalt eines Elements auswählen. Eine entsprechende Auswahl spiegelt sich im Dokumentfenster wider.

Wenn ein Element über Inhalt verfügt, können Sie den gesamten Inhalt auswählen, ohne das Element selbst auszuwählen. Besteht ein Element aus einem einzelnen Objekt, z. B. einer Grafik oder einem Querverweis, wählen Sie das gesamte Element aus. (Elemente mit Inhalt werden als Rechtecke mit abgerundeten Ecken dargestellt. Elemente, die nur aus einem einzelnen Objekt bestehen, werden als normales Rechteck dargestellt.)

Wenn Sie ein gesamtes Element auswählen, wird dessen Inhalt ebenfalls ausgewählt.

So wählen Sie ein Element aus:

Klicken Sie in die Mitte des Rechtecks.

Ausgewähltes Abschnittelement und Inhalt

So wählen Sie mehrere Elemente aus:

Klicken Sie auf das erste Elementrechteck und klicken Sie bei gedrückter Umschalttaste auf die anderen Elementrechtecke.

Sie können auch den Zeiger rechts neben die vertikale Linie ziehen, die die Elemente verbindet. Beginnen Sie oberhalb des ersten Elements, das Sie auswählen möchten, und ziehen Sie den Zeiger nach unten bis zum letzten auszuwählenden Element.

So wählen Sie den Inhalt eines Elements aus, das keine nachfolgenden Elemente hat, ohne das Element selbst auszuwählen:

Doppelklicken Sie auf den Textausschnitt.

Ausgewählter Inhalt des Elements "Überschrift"

So wählen Sie den Inhalt eines Elements aus, das nachfolgende Elemente hat, ohne das Element selbst auszuwählen:

Doppelklicken Sie rechts neben die vertikale Verbindungslinie zur ersten Ebene der nachfolgenden Elemente.

Ausgewählter Inhalt des Elements "Abschnitt" einschließlich nachfolgender Elemente


Grundlagen in FrameMaker / Bearbeiten von Text / Arbeiten mit Text in strukturierten Dokumenten

Eingeben von Text in ein strukturiertes Dokument

Im Elementkatalog wird beschrieben, was das aktuelle Element enthalten kann. Immer wenn im Katalog <TEXT> angezeigt wird, können Sie Text eingeben.

Sie können Text an der aktuellen Position eingeben.

Während der Eingabe fließt der Text in die nächste Zeile oder Spalte, und FrameMaker erzeugt bei Bedarf automatisch neue Seiten.

Falls die Elemente entsprechend definiert wurden, fügt FrameMaker auch Text hinzu. Objektelemente in einer Liste können eine in FrameMaker automatisch generierte Nummerierung aufweisen und ein Abschnitt kann mit automatisch eingefügtem Mustertext beginnen. Sie können aber auch festlegen, dass einem Element in FrameMaker untergeordnete Elemente hinzugefügt werden.

So geben Sie Text ein:

    1. Platzieren Sie die Einfügemarke an der Stelle, an der Sie den Text eingeben möchten.

    2. Beginnen Sie mit der Eingabe. Drücken Sie erst auf die Eingabetaste, wenn Sie ein neues Element hinzufügen möchten (oder einen neuen Absatz in einem unstrukturierten Textfluss beginnen möchten).

Um die Texteingabe in einem anderen Element fortzusetzen, verschieben Sie die Einfügemarke zu dem anderen Element oder fügen ein neues Element ein. In einigen Fällen wird durch Drücken der Eingabetaste ein Element eingefügt (abhängig von der Definition der Elemente). Weitere Informationen finden Sie unter Einfügen von Elementen mit der Eingabetaste.


Grundlagen in FrameMaker / Bearbeiten von Text / Arbeiten mit Text in strukturierten Dokumenten

Eingeben von Rubi-Text in ein strukturiertes Dokument

Wenn auf Ihrem System japanische oder englische Schriften installiert sind, bietet FrameMaker Befehle zur Eingabe und Positionierung von Rubi (siehe Eingabe von Rubi-Text für japanische Texte).

Struktur einer Rubi-Gruppe

Ihre Anwendung enthält wahrscheinlich Elemente, die für die Eingabe von Rubi-Text definiert wurden, ein nachfolgendes Element für den Rubi-Text und ein Rubi-Gruppenelement für das Rubi-Element mit Oyamoji-Text.

Weitere Informationen zur die Eingabe von Rubi-Text ohne Verwendung von Elementen (normalerweise nur in einem unstrukturierten Textfluss) finden Sie unter Eingabe von Rubi-Text für japanische Texte.

So geben Sie Rubi-Text mit Elementen ein:

    1. Klicken Sie an die Position, an der der Rubi-Text angezeigt werden soll.

    2. Wählen Sie im Elementkatalog ein Rubi-Gruppenelement aus und klicken Sie auf "Einfügen". In der Strukturansicht werden für die Rubi-Struktur Elementrechtecke angezeigt.

    3. Wenn das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für das Element ein und klicken auf "Element einfügen" (siehe Einfügen von Elementen).

    4. Geben Sie den Oyamoji-Text ein. Drücken Sie bei der Eingabe dieses Textes nicht auf die Eingabetaste. Wird der Text über zwei Zeilen umbrochen, werden alle Zeichen in derselben Zeile angezeigt.

    5. Verschieben Sie die Einfügemarke zum nachfolgenden Rubi-Element und geben Sie den Rubi-Text ein.

So gliedern Sie Text, der zu Oyamoji-Text wird, in eine Rubi-Struktur ein:

    1. Wählen Sie den Text aus, der zu Oyamoji werden soll. Der Text darf kein Absatzsymbol [image] und kein Zeilenvorschubsymbol [image] enthalten. Wird der Text über zwei Zeilen umbrochen, wird er in einer Zeile angezeigt.

    2. Wählen Sie ein Rubi-Gruppenelement aus dem Elementkatalog aus und klicken Sie auf "Eingliedern". In der Strukturansicht werden für die Rubi-Struktur Elementrechtecke angezeigt.

Sie können auch den Befehl "Spezial > Rubi" verwenden, um eine Rubi-Gruppe einzugliedern. Wenn mehr als ein Rubi-Gruppenelement verfügbar ist, wählen Sie eines aus dem Aufklappmenü "Element-Tag" des angezeigten Dialogfensters aus.

    3. Wenn das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für das Element ein und klicken auf "Element einfügen" (siehe Einfügen von Elementen).

    4. Geben Sie den Rubi-Text ein.

So gliedern Sie Text in eine ungültige Rubi-Struktur ein:

Führen Sie eine der folgenden Aktionen aus:

    Um ein Rubi-Gruppenelement, das in einem anderen Teil des Dokuments gültig ist, einzugliedern, benutzen Sie die Einstellung "Alle Elemente", damit das Element überall verfügbar ist (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument). Wählen Sie dann den Text aus und gliedern Sie ihn in die Rubi-Gruppe ein.

    Um ein ungültiges Rubi-Gruppenelement mit dem Standard-Tag RUBIGRP einzugliedern, markieren Sie den Text und wählen den Befehl "Spezial > Rubi". (Eine Standard-Rubi-Gruppe wird erzeugt, wenn keine definierten Rubi-Gruppenelemente verfügbar sind.)

Wenn an der gewünschten Position kein Rubi-Gruppenelement verfügbar ist, können Sie eine ungültige Rubi-Struktur verwenden. Informieren Sie sich nach Einfügen des Elements bei Ihrem Entwickler darüber, wie sich das Element an dieser Position in ein gültiges Element umwandeln lässt.


Grundlagen in FrameMaker

Textformatierung

Sie können das Aussehen des Textes entweder mithilfe von vordefinierten Formaten (die normalerweise mehrere Einstellungen zugleich ändern) oder durch einzelne Änderungen an den Einstellungen anpassen.

Jedes Format besteht aus vielen Einstellungen. Wenn Sie ein Absatzformat verwenden, werden Einstellungen für Einzug, Ausrichtung, Schrift, automatische Nummerierung, Tabulatoren, Silbentrennung, Wortabstand usw. geändert. Wenn Sie für markierten Text in einem Absatz ein bestimmtes Zeichenformat verwenden, können Sie verschiedene Schrifteinstellungen ändern, ohne dass sich dies auf den Rest des Absatzes auswirkt.

Jeder Absatz verfügt über Einstellungen, die das Erscheinungsbild und die Position auf der Seite festlegen.

Textformateinstellungen umfassen auch die Einstellungen, mit denen Seitenumbrüche, nummerierte Listen und Listen mit Auszeichnungspunkten sowie verbundene, seitliche und Zwischenüberschriften erstellt werden.


Grundlagen in FrameMaker / Textformatierung

Allgemeines über Absatz- und Zeichenformate

Jedes Dokument hat zwei textbezogene Kataloge: einen Absatzformat-Katalog und einen Zeichenformat-Katalog. Diese auf einer gleitenden Platte erscheinenden Kataloge enthalten vordefinierte Formate.

Absatzformat-Katalog und Zeichenformat-Katalog

Das Zuweisen eines in einem Katalog enthaltenen Formats ist die einfachste Möglichkeit, das Erscheinungsbild des Textes zu ändern und sicherzustellen, dass Ihre Dokumente einheitlich formatiert sind. Diese Einheitlichkeit erleichtert späteres Ändern sowie das Konvertieren von Dokumenten in andere Formate, z. B. HTML.

Der Name eines Formats ist sein Typ. Die Einstellungen eines Formats einschließlich des Typs werden in speziellen Dialogfenstern definiert, den Gestaltungsfenstern.

Die Formate im Absatzformat-Katalog betreffen ganze Absätze, während die Formate im Zeichenformat-Katalog nur für markierten Text, in der Regel nur Teile eines Absatzes, gelten.


Grundlagen in FrameMaker / Textformatierung

Zuweisen von vordefinierten Formaten zu Text

Durch Zuweisen von vordefinierten Formaten aus dem Absatzformat- oder Zeichenformat-Katalog wird der Text den Formateinstellungen angepasst.

Das Absatzformat "Haupttext" wurde zugewiesen

Gleicher Text mit einem anderen Format

Durch Öffnen einer gleitenden Platte für Textformate, einem Katalog, können Sie leicht auf vordefinierte Formate zugreifen. Lassen Sie den Katalog neben Ihrem Dokument geöffnet. Sie brauchen dann nur auf den Namen eines Formats (dessen Typ) zu klicken, um es zuzuweisen.

Über einen besonderen Eintrag im Zeichenformat-Katalog kann die Standardschrift für Text wiederhergestellt werden. Die Standardschrift ist die für einen Absatz verwendete Schrift (Schriftgrad, Stil usw.), es sei denn, diese wird geändert.

Sie können auch das Katalogformat neu definieren und es jedem Text im Dokument zuweisen, der diesen Typ verwendet (siehe Definieren und Aktualisieren von Formaten).

So zeigen Sie einen Katalog an:

Führen Sie eine der folgenden Aktionen aus:

    Um den Absatzformat-Katalog zu öffnen, klicken Sie in der rechten oberen Ecke des Dokumentfensters auf [image] .

    Um den Zeichenformat-Katalog zu öffnen, klicken Sie in der rechten oberen Ecke des Dokumentfensters auf [image] .

So weisen Sie ein Absatz- oder Zeichenformat zu:

    1. Wählen Sie den Text, der verändert werden soll. Führen Sie dazu eine der folgenden Aktionen aus:

    Um Absätzen Änderungen zuzuweisen, klicken Sie in einen Absatz oder markieren mehrere Absätze.

    Um Zeichen (in der Regel Teilen von Absätzen) Änderungen zuzuweisen, markieren Sie beliebig viel Text. (Achten Sie darauf, dass Sie nicht den ganzen Absatz markieren, da in diesem Fall durch das zugewiesene Zeichenformat die Standardschrift des Absatzes geändert wird.)

    Um Zeichen Änderungen zuzuweisen, die Sie neu eingeben, klicken Sie in den Absatz, ohne Text zu markieren.

    2. Klicken Sie in einem Katalog auf ein Format, um dieses der Auswahl zuzuweisen. Im Namensbereich am linken Rand der Statuszeile wird daraufhin der neue Typ angezeigt. Eine Auswahl kann z. B. das Absatzformat "Haupttext" und das Zeichenformat "Betonung" haben.

Im Namensbereich des Bildschirms werden Zeichen- und Absatzformat angezeigt.

Um ein Format mit der Tastatur zuzuweisen, drücken Sie Strg+9 (Absatzformate) oder Strg+8 (Zeichenformate). Beginnen Sie dann an der Eingabeaufforderung in der Statuszeile den Namen des Formattyps einzugeben, bis der Name vollständig angezeigt wird. (Bei Eingabe von Kleinbuchstaben werden die Formate vorwärts, bei Eingabe von Großbuchstaben rückwärts durchsucht.) Sie können auch mithilfe der Nach-Oben- und Nach-Unten-Tasten durch die Formate blättern. Drücken Sie die Eingabetaste, um das Format zuzuweisen. Wenn Sie die Operation abbrechen möchten, klicken Sie in das Dokument, ohne die Eingabetaste zu drücken.

So stellen Sie die Standardschrift und die Standardeinstellungen für Absätze wieder her:

Markieren Sie den Text und klicken Sie im Zeichenformat-Katalog auf "Absatzstandardschrift" [image] . Wenn Sie beispielsweise einem Wort das Format "Betonung" zugewiesen haben und dieses Format dann doch nicht verwenden möchten, markieren Sie das betreffende Wort und wählen aus dem Zeichenformat-Katalog die Option "Absatzstandardschrift" [image] .


Grundlagen in FrameMaker / Textformatierung

Ändern von Text ohne Verwendung der Kataloge

Das Formatieren von Text geschieht in der Regel durch Zuweisen vordefinierter Formate aus dem Absatzformat- oder Zeichenformat-Katalog. Sie können jedoch auch die einzelnen Einstellungen für einen Absatz oder den Teil eines Absatzes ändern. Wenn das resultierende Format nicht mit dem entsprechenden vordefinierten Format im Katalog für diesen Text übereinstimmt, wird die Formatänderung als irreguläres Format dieses Katalogformats betrachtet. Weitere Informationen hierzu finden Sie unter Irreguläre Formate.

Für Änderungen an den einzelnen Einstellungen stehen Ihnen folgende Möglichkeiten zur Verfügung:

    Mithilfe des Dialogfensters "Absatzgestaltung" können Sie alle Formateinstellungen für Absätze ändern (siehe Irreguläre Formate).

    Mit dem Dialogfenster "Zeichengestaltung" oder den Befehlen im Menü "Format" ("Schrift", "Größe" bzw. "Grad" und "Stil") können Sie das Zeichenformat für den ausgewählten Text oder an der Einfügemarke ändern (siehe Ändern von Schrifteinstellungen). Viele der Schrifteinstellungen können auch mit der QuickAccess-Leiste festgelegt werden (siehe Verwendung der QuickAccess-Leiste).

    Sie können "Bearbeiten > Kopieren Spezial" und anschließend "Absatzformat" oder "Zeichenformat" wählen, um ein Format, einschließlich aller irregulären Formate, zu kopieren und an einer anderen Position einzufügen.

    Mit der Formatierungsleiste können Sie mehrere Absatzeinstellungen ändern und überschreiben.

Die Formatierungsleiste enthält Aufklappmenüs und Tabulatorsymbole, mit denen Sie Ausrichtung, Abstand und Tabulatoren einstellen können. Alle Änderungen werden sofort wirksam und das Textbild ändert sich entsprechend der neuen Einstellungen. Über die Formatierungsleiste vorgenommene Änderungen sind häufig irreguläre Formatzuweisungen der Formateinstellungen.

A: Ausrichtung und Abstand B: Tabulatorsymbole C: Aufklappmenü für Absatzformate

So zeigen Sie die Formatierungsleiste an oder blenden sie aus:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Wählen Sie "Darstellung > Formatierungsleiste".

    (UNIX) Wenn die Lineale nicht sichtbar sind, wählen Sie "Darstellung > Lineale" und klicken Sie anschließend auf den Umschalter für die Formatierungsleiste. Wenn Sie erneut auf den Umschalter klicken, wird die Leiste wieder ausgeblendet.


Grundlagen in FrameMaker / Textformatierung

Verwenden der Gestaltungsfenster

Es gibt zwei Dialogfenster zum Formatieren von Text: "Absatzgestaltung" und "Zeichengestaltung". Sie ermöglichen Ihnen das Erstellen und Ändern von Formaten.

Absatz- und Zeichengestaltung

Die Gestaltungsfenster enthalten mehrere Bereiche und Befehle für das Erstellen, Ändern und Überschreiben von Formaten. Das Dialogfenster "Absatzgestaltung" enthält mehrere Gruppen von Einstellungen, die jeweils einzeln angezeigt werden (in der Abbildung wird die Gruppe "Basis" angezeigt). Das Dialogfenster "Zeichengestaltung" enthält nur eine Gruppe.

Absatzgestaltung
A: (Windows) Klicken Sie auf eine Registerkarte, um die entsprechende Gruppe von Einstellungen anzuzeigen.
B: Wählen Sie im Aufklappmenü "Absatztyp" einen Eintrag, um die für dieses Format gespeicherten Einstellungen anzuzeigen.
C: Wählen Sie im Aufklappmenü "Einstellungen" einen Eintrag, um eine Gruppe von Einstellungen anzuzeigen.
D: Weisen Sie sämtliche Einstellungen in allen Einstellungsgruppen (einschließlich des Typs) dem Format des aktuellen Absatzes zu.
E: Aktualisieren Sie alle Absatzformate desselben Typs, einschließlich der im Absatzformat-Katalog gespeicherten Formate.
F. Wählen Sie Befehle zum Aktualisieren bestimmter Einstellungen des ausgewählten Absatzformats.
G: Zeigen Sie die Einstellungen der Gruppe an oder ändern Sie diese.

Hinweis: Absatz- und Zeichentypen unterstützen den Unicode-Standard zur Textcodierung.

So zeigen Sie ein Gestaltungsfenster an:

Führen Sie folgende Schritte durch:

    Um das Dialogfenster "Absatzgestaltung" zu öffnen, wählen Sie "Format > Absätze > Gestaltung".

    Um das Dialogfenster "Zeichengestaltung" zu öffnen, wählen Sie "Format > Zeichen > Gestaltung".

So verwenden Sie ein Gestaltungsfenster:

    1. Zeigen Sie im Dialogfenster "Zeichengestaltung" eine Gruppe Formatierungseinstellungen an, indem Sie sie aus dem Aufklappmenü "Einstellungen" wählen oder unter Windows auf eine Registerkarte klicken.

    2. Nehmen Sie die gewünschten Änderungen an den Einstellungen vor. Eine Übersicht der möglichen Änderungen finden Sie unter Irreguläre Formate.

    3. Klicken Sie auf "Der Auswahl zuweisen".

Hinweis: Klicken Sie auf "Der Auswahl zuweisen", wenn Sie das Format für den aktuellen Absatz überschreiben möchten. Klicken Sie nur dann auf "Alle aktualisieren", wenn Sie das Format global ändern (aktualisieren) möchten (siehe Definieren und Aktualisieren von Formaten beschrieben).

So setzen Sie die Einstellungen zurück, nachdem Sie in einem Gestaltungsfenster Änderungen vorgenommen haben:

Führen Sie eine der folgenden Aktionen aus:

    Um alle Einstellungen (einschließlich der irregulären Formatzuweisungen) entsprechend der aktuellen Auswahl zurückzusetzen, klicken Sie in den Text oder wählen Sie aus dem Aufklappmenü "Befehle" die Option "Einstellungen der Auswahl übernehmen".

    Um die Einstellungen entsprechend des gespeicherten Formats zurückzusetzen, wählen Sie das betreffende Format im Aufklappmenü "Typ". Führen Sie diesen Schritt auch aus, wenn das Format bereits im Textfeld "Typ" angezeigt wird.

Verwenden von "Beibehalten"

Der Wert "Beibehalten" kann in den Dialogfenstern "Absatzgestaltung", "Zeichengestaltung", "Tabellengestaltung" und in anderen Dialogfenstern in FrameMaker verwendet werden. Wenn Sie Einstellungen in einem Gestaltungsfenster auf "Beibehalten" setzen, werden Textfelder ohne Inhalt, Aufklappmenüs mit dem Eintrag "Beibehalten" und Markierungsfelder wie in der folgenden Abbildung angezeigt.

Markierungsfelder können aktiviert sein (Ein), deaktiviert (Aus) oder auf "Beibehalten" gesetzt sein. Eventuell müssen Sie zweimal auf ein Markierungsfeld klicken, um den gewünschten Zustand einzustellen.

Die Option "Beibehalten" wird folgendermaßen verwendet:

    "Beibehalten" kann bedeuten, dass die ausgewählten Elemente unterschiedliche Einstellungen haben. Wenn Sie beispielsweise einen linksbündig und einen rechtsbündig ausgerichteten Absatz auswählen, enthält das Aufklappmenü "Ausrichtung" den Eintrag "Beibehalten".

    Die Option "Beibehalten" ermöglicht es, in einem Gestaltungsfenster nur einen Teil der Einstellungen zu ändern. Um beispielsweise nur die Ausrichtung aller Überschriften von zentriert in linksbündig zu ändern, setzen Sie die restlichen Einstellungen auf "Beibehalten" und aktualisieren dann das Format aller Überschriften. Weitere Informationen hierzu finden Sie unter Definieren und Aktualisieren von Formaten.

    Mit der Option "Beibehalten" erstellte Zeichenformate geben an, welche Einstellungen beim Zuweisen des Formats nicht geändert werden. In diesem Fall wird die Einstellung "Beibehalten" als Teil des Zeichenformats gespeichert. Weitere Informationen hierzu finden Sie unter Definieren und Aktualisieren von Formaten.


Grundlagen in FrameMaker / Textformatierung / Verwenden der Gestaltungsfenster

Globales Zuweisen von Formaten zu Text

Möglicherweise möchten Sie gelegentlich ein Format global mehreren Absätzen Ihrer Wahl zuweisen. Sie könnten z. B. allen Absätzen des Typs "Überschrift2" den Typ "Überschrift1" zuweisen.

So weisen Sie ein Format in einem Text global zu:

    1. Um ein Format auf einen Text anzuwenden, der mehrere unterschiedliche Typen enthält, markieren Sie aufeinander folgende Absätze oder Textelemente, die diese Typen haben. Andernfalls überspringen Sie diesen Schritt (d. h., die Auswahl spielt keine Rolle).

    2. Öffnen Sie das Dialogfenster "Absatzgestaltung" oder "Zeichengestaltung" und wählen Sie das gewünschte Format aus dem Aufklappmenü "Absatztyp" oder "Zeichentyp".

    3. Wählen Sie im Aufklappmenü "Befehle" den Eintrag "Optionen für globale Aktualisierung".

    4. Führen Sie eine der folgenden Aktionen aus:

    Um den gesamten Text und alle Formate im Dokument zu aktualisieren, klicken Sie auf "Alle Absätze und Katalogeinträge" oder "Alle Zeichen und Katalogeinträge".

    Um den ausgewählten Text und alle Absätze oder Textstellen zu aktualisieren, die denselben Typ wie die ausgewählten Absätze haben, klicken Sie auf "Alle entsprechenden Typen in Auswahl".

    Wenn Formate eines bestimmten Typs aktualisiert werden sollen, wählen Sie den gewünschten Typ aus dem Aufklappmenü "Alle des Typs".

    5. Wenn Sie Absätzen einen anderen Typ zuweisen, klicken Sie im Bereich "Einstellungen der Absatzgestaltung verwenden" auf "Alle Einstellungen".

    6. Klicken Sie auf "Aktualisieren".


Grundlagen in FrameMaker / Textformatierung

Irreguläre Formate

Wenn ein Textformat so geändert wird, dass es nicht mehr mit dem vordefinierten Format des Textes übereinstimmt, spricht man von einem irregulären Format.

Irreguläre Formate werden in FrameMaker im Namensbereich und in der Formatierungsleiste im Aufklappmenü für Absatzformate mit einem Sternchen (*) gekennzeichnet.

Ein Sternchen zeigt ein irreguläres Format an.

Wenn Sie die Katalogformate verwenden, um ein Dokument einheitlich zu gestalten, sollten Sie auf irreguläre Formate verzichten. Weisen Sie daher Formate aus dem Katalog zu oder aktualisieren Sie das Katalogformat so, dass es dem aktuellen Text entspricht. Einzelheiten finden Sie unter Zuweisen von vordefinierten Formaten zu Text und Definieren und Aktualisieren von Formaten.

Wenn Sie schnell bearbeitbare und einmalige Dokumente formatieren, stellen die irregulären Formate kein Problem dar. Angenommen, Sie möchten einen bestimmten Haupttextabsatz als Titel einer Notiz verwenden, ohne ein neues Überschriftformat definieren und zuweisen zu müssen. Ändern Sie in einem solchen Fall einfach das Format des Absatzes, ohne das Katalogformat zu aktualisieren.

Beim späteren Aktualisieren des Katalogformats können Sie entscheiden, ob irreguläre Formate beibehalten werden sollen. Wenn Sie keine irregulären Formate verwenden, sondern separate Formate erstellen möchten, wählen Sie "Datei > Dienstprogramme > Formate anlegen & zuweisen" (siehe Umwandeln von irregulären Formaten in neue Formate).

Sie können viele Formateinstellungen ändern, z. B. Schrifteinstellungen, Einzug und Ausrichtung, Tabulatorstopps, Abstände, Zeilenumbruch und Trennung, Seitenumbruch, Grafiken in einem Absatzformat, Überschriften und automatische Nummerierung.

Hinweis: Wenn Sie das Schriftformat für einen Teil eines Absatzes ändern, wird dies nicht als irreguläres Format des Absatzes betrachtet. Ein Format wird nur als Spezialformat betrachtet, wenn das Format dem gesamten Absatz zugewiesen wird.


Grundlagen in FrameMaker / Textformatierung

Ändern von Schrifteinstellungen

Sie können mithilfe des Menüs "Format" und des Dialogfensters "Zeichengestaltung" Schriftfamilie, Schriftstil und Schriftgrad des ausgewählten Textes ändern. Im Dialogfenster "Absatzgestaltung" können Sie die Standardschrift-Einstellungen eines ganzen Absatzes festlegen. Welche Schriftfamilien und Stile verfügbar sind, hängt davon ab, welche Schriften installiert wurden.

Wenn Sie die Schrifteinstellungen für markierten Text ändern, werden diese Einstellungen beim späteren Aktualisieren der Einstellungen für den gesamten Absatz beibehalten.

Sie können die Schrifteinstellungen von Absatztext und von Text ändern, der mit dem Werkzeug "Textzeile" erstellt wurde.

Hinweis: (Windows) Verwenden Sie nicht die Schrift "Courier", wenn Adobe Type Manager® deaktiviert oder nicht installiert ist. Wenn Sie Courier ohne ATM einsetzen, wird die Schrift in FrameMaker-Produkten nicht korrekt angezeigt.


Grundlagen in FrameMaker / Textformatierung / Ändern von Schrifteinstellungen

Verwenden der Schriftbefehle des Menüs "Format"

Formatänderungen, die Sie mit den Befehlen des Menüs "Format" vornehmen, werden sofort wirksam. Sie gelten als irreguläre Formate, wenn sie nicht mit den Schrifteinstellungen in den vordefinierten Formaten übereinstimmen.

So ändern Sie Schrifteinstellungen mit den Befehlen im Menü "Format":

Führen Sie folgende Schritte durch:

    Wenn Sie eine andere Schriftfamilie verwenden möchten, wählen Sie zunächst "Format > Schrift" und anschließend die gewünschte Schriftfamilie aus der Liste.

    Um den Schriftgrad zu ändern, wählen Sie zunächst "Format > Grad" und anschließend den gewünschten Schriftgrad aus der Liste. Der Eintrag "Sonstige" ermöglicht die Eingabe eines nicht in der Liste aufgeführten Schriftgrads.

    Wenn Sie den Schriftstil ändern möchten, wählen Sie zunächst "Format > Stil" und anschließend den gewünschten Stil aus der Liste. Hier werden viele, jedoch nicht alle, Optionen der Gestaltungsfenster angezeigt. Mit dem Eintrag "Standardtext" können die anderen Stileinstellungen zurückgesetzt werden.

Hinweis: Auch wenn eine Schrift mehrere Stärken hat (z. B. Helvetica Condensed Bold und Helvetica Condensed Black), wird im Untermenü "Format > Stil" nur der Eintrag "Fett" angezeigt. Wenn Sie Text mit den anderen Schriftstärken anzeigen möchten, verwenden Sie stattdessen die Einstellungsgruppe "Standardschrift" im Dialogfenster "Absatzgestaltung" oder das Dialogfenster "Zeichengestaltung".


Grundlagen in FrameMaker / Textformatierung / Ändern von Schrifteinstellungen

Verwenden der Gestaltungsfenster zum Ändern von Schrifteinstellungen

Im Dialogfenster "Absatzgestaltung" können Sie die Standardschrift-Einstellungen für einen ganzen Absatz ändern. Um die Schrifteinstellungen bestimmter Textbereiche in einem Absatz zu ändern, verwenden Sie das Dialogfenster "Zeichengestaltung".

So ändern Sie eine Schrifteinstellung in einem Gestaltungsfenster:

    1. Führen Sie eine der folgenden Aktionen aus:

    Um die Standardschrift-Einstellungen eines ganzen Absatzes zu ändern, klicken Sie in den betreffenden Absatz. Wählen Sie dann "Format > Absätze > Gestaltung", um das Dialogfenster "Absatzgestaltung" zu öffnen, und wählen Sie im Aufklappmenü "Einstellungen" den Eintrag "Standardschrift".

    Um die Schrifteinstellungen für bestimmten Text in einem Absatz zu ändern, markieren Sie zunächst den Text und wählen Sie anschließend "Format > Zeichen > Gestaltung".

    Um die Schrifteinstellungen von Text zu ändern, den Sie in einem Absatz eingeben, klicken Sie in den Text und wählen Sie "Format > Zeichen > Gestaltung".

    2. Ändern Sie die Einstellungen im Gestaltungsfenster. Weitere Informationen hierzu finden Sie unter Verwenden der Gestaltungsfenster.

    3. Klicken Sie auf "Der Auswahl zuweisen".

Wenn einem Text in einem Gestaltungsfenster ein Groß-/Kleinschreibungsstil zugewiesen wird, ändert dies nur die Anzeige des Textes (klein geschriebener Text wird beispielsweise in Großbuchstaben angezeigt). Um den Text selbst dauerhaft zu ändern, verwenden Sie das Dialogfenster "Groß-/Kleinschreibung". Dort können Sie den ausgewählten Text durch Text in Großbuchstaben, Kleinbuchstaben oder mit großen Anfangsbuchstaben ersetzen. Zum Aufrufen dieses Dialogfensters drücken Sie Esc b Umschalttaste+g.


Grundlagen in FrameMaker / Textformatierung / Ändern von Schrifteinstellungen

Änderungen an Schrifteinstellungen in den Gestaltungsfenstern

Wahrscheinlich kennen Sie viele der Einstellungen bereits aus anderen Textverarbeitungsprogrammen. Einige sind jedoch möglicherweise neu für Sie. Die folgende Aufstellung enthält die Einstellungen, die Ihnen vielleicht noch nicht bekannt sind:

Numerisch unterstreichen

Wählen Sie die Option "Numerisch unterstreichen", um unabhängig von der Schriftart und der Größe des Zeichens nur einen Abstand und eine Stärke für eine Unterstreichung zu verwenden. Tabulatoren werden weder von der Option "Unterstreichen" noch "Numerisch unterstreichen" verändert. Sollen auch Tabulatoren unterstrichen werden, formatieren Sie den Tabulatorstopp so, dass ein umbruchgeschütztes Zeichen als Führungszeichen verwendet wird.

Numerisches und einfaches Unterstreichen

Änderungsbalken

Mit dieser Option können Sie neben dem Text einen Änderungsbalken anzeigen.

Farbe

Text kann in einer anderen Farbe angezeigt werden, indem Sie aus dem Aufklappmenü "Farbe" die gewünschte Farbe auswählen. Wenn Sie eigene Farben definiert haben, werden diese im Aufklappmenü angezeigt.

Abstand

Der Abstand zwischen den Zeichen kann vergrößert bzw. verkleinert werden, indem Sie in dieses Feld den entsprechenden Prozentwert eingeben. Der Wert wird in Prozent eines m-Leerzeichens angegeben. Der normale Abstand entspricht 0 %.

–10 % Abstand (oben), 0 % Abstand (zentriert), 10 % Abstand (unten)

Streckung

Mit diesem Wert können Sie die Breite der Zeichen festlegen.

Groß-/Kleinschreibung

Wählen Sie "Kapitälchen", wenn der Text in verkleinerten Großbuchstaben (Kapitälchen) angezeigt werden soll. Beispiel: Hinweis wird als Hinweis angezeigt.

Sprache

Sie können die dem Text zugewiesene Sprache ändern, indem Sie den gewünschten Eintrag aus dem Aufklappmenü "Sprache" wählen. Die gewählte Sprache hat sowohl Auswirkungen auf den Text in Systemvariablen als auch auf die Rechtschreibprüfung und die Silbentrennung. Wenn Sie den Wert "Keine" wählen, wird auch keine Rechtschreibprüfung für den markierten Text durchgeführt.

Unterschneiden

Aktivieren Sie die Option "Unterschneiden", um den Abstand zwischen zwei Zeichen in demselben Wort anzupassen. Die Option "Unterschneiden" aktiviert auch Ligaturen, z. B. fi und fl in gedruckten Dokumenten (Unter Windows werden diese Ligaturen jedoch nicht unterstützt). Die definierten Unterschneidungen und Ligaturen sind abhängig von der Schriftart. Unter UNIX können Sie Unterschneidungen anpassen (siehe Online-Handbuch Anpassen von FrameMaker-Produkten auf der Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf).

Aktivierte und deaktivierte Unterschneidungen

Tsume

Wenn Sie ein japanisches Zeichen näher an die angrenzenden Zeichen schieben möchten, wählen Sie Tsume. (Diese Option steht nur zur Verfügung, wenn Sie japanischen Text in Dokumenten und Dialogfenstern eingeben können.) Die Strecke, um die ein Zeichen mit veränderlicher Breite (wie eine Klammer) verschoben werden kann, ist abhängig von der Metrik für dieses Zeichen.


Grundlagen in FrameMaker / Textformatierung / Ändern von Schrifteinstellungen

Festlegen der Einstellungen für hochgestellten und tiefgestellten Text und für Kapitälchen

Änderungen der Einstellungen für tiefgestellten und hochgestellten Text (einschließlich Fußnotenverweise) und Kapitälchen wirken sich auf jeden derartigen Text im Dokument aus.

So geben Sie die Größe und die Form von Kapitälchen bzw. Größe, Form und Position von hochgestelltem oder tiefgestelltem Text an:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Textoptionen".

    3. Geben Sie Größe, Abstand und Streckung in Prozent an.

Beim Berechnen der Größe und des Abstands wird der von Ihnen eingegebene Prozentsatz in FrameMaker mit dem Schriftgrad der betreffenden Zeichen multipliziert. Wenn Sie beispielsweise für den Abstand für hochgestellten Text den Wert 40 % angeben, wird ein Zeichen mit 10 pt um 4 pt erhöht.

Die Prozentangabe für die Streckung entspricht dem Wert, um den die Zeichen verdichtet oder ausgeweitet werden. Weitere Informationen hierzu finden Sie unter Verdichten und Erweitern von Zeichen.

    4. Klicken Sie auf "Zuweisen".

Sie können die Position der hoch- und tiefgestellten Zeichen genau anpassen, indem Sie den betreffenden Text auswählen und dann mit der Tastenkombination Alt+Pfeiltasten (Windows) bzw. Control+Pfeiltasten (UNIX) nach oben bzw. unten verschieben.


Grundlagen in FrameMaker / Textformatierung

Verdichten und Erweitern von Zeichen

Durch das Strecken von Zeichen können Sie bestimmte Effekte erzielen.

Unveränderter Text (oben) und um 75 % verdichteter Text (unten)

So ändern Sie die Breite von Text:

    1. Führen Sie eine der folgenden Aktionen aus:

    Um die Breite eines ganzen Absatzes zu ändern, klicken Sie in den Absatz und wählen "Format > Absätze > Gestaltung". Anschließend wählen Sie aus dem Aufklappmenü "Einstellungen" den Eintrag "Standardschrift".

    Um die Breite von bestimmtem Text in einem Absatz zu ändern, markieren Sie den Text und wählen "Format > Zeichen > Gestaltung".

    2. Geben Sie in das Textfeld "Streckung" einen Prozentwert ein. Ein Wert von 100 % bedeutet, dass die Zeichenbreite den Schrifteinstellungen entspricht. Ein Wert unter 100 % verdichtet die Breite, während ein Wert über 100 % die Breite erweitert.

    3. Klicken Sie auf "Der Auswahl zuweisen".

In japanischen Dokumenten können Sie mit einem Wert, der größer als 100 ist, Heitai (horizontal gedehnte Zeichen) simulieren. Sie können einen Streckungswert unter 100 verwenden und den Schriftgrad für den Text maximieren, um Chotai (vertikal gestreckte Zeichen) zu simulieren.

So ändern Sie die Breite einer Textzeile durch Ziehen:

    1. Markieren Sie die Textzeile, die Sie ändern möchten. Sie können auch ein gruppiertes Objekt, das eine Textzeile enthält, wählen. (Achten Sie darauf, dass Sie eine Textzeile und nicht einen Textrahmen auswählen. Weitere Informationen zu Textzeilen finden Sie unter Grafiken und Text.

    2. Ziehen Sie einen der Auswahlpunkte, bis die Textzeile die gewünschte Breite hat. Wenn Sie einen Eckpunkt ziehen, werden Schriftgrad und Zeichenbreite geändert.


Grundlagen in FrameMaker / Textformatierung / Verdichten und Erweitern von Zeichen

Kombinierte Schriften mit japanischen und lateinischen Zeichen

Japanische Schriften enthalten außer dem vollständigen Satz der japanischen Silben auch einen Satz lateinischer Zeichen, um die Eingabe von nicht-japanischen Zeichen und Zahlen zu erleichtern. Sie können Ihre eigenen kombinierten Schriften definieren (unter einer kombinierten Schrift versteht man eine Schrift, in der eine bestimmte lateinische zusammen mit einer bestimmten japanischen Schrift verwendet wird). Sie können z. B. eine Schrift erstellen, die für japanische Zeichen Mincho verwendet, bei lateinischen Zeichen aber auf Palatino umschaltet.

Sollten Sie mit einem System arbeiten, das japanischen Text unterstützt und kombinierte Schriften als Teil einer Vorgabe enthält, sind diese automatisch verfügbar, sofern die angegebenen Schriften installiert sind. Wenn das System die Eingabe von japanischem Text in Dokumente und Dialogfenster unterstützt, werden die kombinierten Schriften zusammen mit den lateinischen und japanischen Schriften am Anfang der Schriftenlisten angezeigt.

FrameMaker unterstützt japanische Single-Byte-Katakana-Zeichen halber Breite in kombinierten Schriften.

Informationen zur Arbeit mit koreanischen und chinesischen Zeichen finden Sie im Online-Handbuch Chinesische und koreanische Schriften.

So erstellen oder ändern Sie eine kombinierte Schrift:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Kombinierte Schriften". (Dieser Befehl wird nur angezeigt, wenn Ihr System die Eingabe von japanischem Text in Dokumenten und Dialogfenstern unterstützt.)

    3. Führen Sie eine der folgenden Aktionen aus:

    Soll eine neue kombinierte Schrift erstellt werden, geben Sie einen Namen in das Textfeld "Name der kombinierten Schrift" ein.

    Wenn Sie eine andere kombinierte Schrift verwenden möchten, wählen Sie aus der Liste "Kombinierte Schriften" den gewünschten Namen aus.

    4. Führen Sie folgende Schritte durch:

    Wählen Sie unter "Text in asiatischen Schriften" aus dem Aufklappmenü mit den Schriftfamilien die gewünschte japanische Schrift.

    Wählen Sie unter "Text in lateinischer Schrift" aus dem Aufklappmenü mit den Schriftfamilien die gewünschte lateinische Schrift.

    Wenn Sie die relative Größe und den Grundlinienabstand des lateinischen Textes anpassen möchten, geben Sie die gewünschten Werte für die Einstellungen "Größe" und "Abstand" an. Größe und Abstand von Text in lateinischer Schrift werden als Prozentwerte des asiatischen Schriftgrads angegeben. Verwenden Sie einen negativen Abstand, um den Text unter die Grundlinie zu bewegen.

    5. Führen Sie eine der folgenden Aktionen aus:

    Um eine neue kombinierte Schrift zu erstellen, klicken Sie auf "Einfügen".

    Um das Bearbeiten der kombinierten Schrift abzuschließen, klicken Sie auf "Ändern".

    6. Klicken Sie auf "Fertig".

Hinweis: (Windows) Sie können die Einstellung "Fett und Kursiv zulassen" unter "Text in asiatischen Schriften" im Dialogfenster "Kombinierte Schriften bearbeiten" deaktivieren, damit beim Einstellen von Fett oder Kursiv für die lateinische Schrift nicht automatisch auch der asiatische Text fett oder kursiv gesetzt wird.

So kopieren Sie eine Gruppe kombinierter Schriften:

    Wählen Sie "Datei > Importieren > Formate" und wählen Sie "Kombinierte Schriften". Detaillierte Informationen zum Importieren von Formaten aus anderen Dokumenten finden Sie unter Importieren und Aktualisieren von Formaten.


Grundlagen in FrameMaker / Textformatierung

Ändern von Einzügen und Ausrichtung

Mit dem linken und rechten Einzug eines Absatzes können Sie die Position des linken und rechten Absatzrandes festlegen. Der Text wird an beiden Rändern (Blocksatz) oder an einem Rand (links- oder rechtsbündig) ausgerichtet.

Sie können besondere Effekte (z. B. einen hängenden Einzug) erzielen, indem Sie für die erste Zeile eines Absatzes einen anderen Einzug festlegen als für die restlichen Zeilen des Absatzes.

A: Einzug 1. Zeile B: Linker Einzug C: Rechter Einzug

Die Ausrichtung eines Absatzes bestimmt, wie dieser zwischen dem linken und dem rechten Einzug positioniert wird (nicht zwischen den Rändern der Textspalte).

A: Linksbündig B: Zentriert C: Rechtsbündig D: Blocksatz

So stellen Sie den Absatzeinzug mithilfe des Lineals ein:

    1. Klicken Sie in den Absatz, den Sie ausrichten möchten, oder wählen Sie die gewünschten Absätze aus.

    2. Ziehen Sie im Lineal das Einzugssymbol an die gewünschte Position.

A: Einzug 1. Zeile B: Linker Einzug C: Rechter Einzug

Wenn Sie einen Einzug an einer Linealmarkierung ausrichten möchten, aktivieren Sie das Magnetraster ("Grafik > Magnetraster"). Wenn Sie anschließend das Einzugssymbol mit der Maus ziehen, rastet es an Positionen des Magnetrasters ein.

So legen Sie den Absatzeinzug fest, indem Sie Werte eingeben:

    1. Klicken Sie in den Absatz, den Sie einrücken möchten, oder wählen Sie die gewünschten Absätze aus.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Basis" an. Geben Sie die gewünschten Einzüge in die Textfelder "1. Zeile", "Links" und "Rechts" ein und klicken Sie anschließend auf "Der Auswahl zuweisen". Für einen hängenden Einzug geben Sie beispielweise im Textfeld "1. Zeile" einen kleineren Wert als in "Links" an.

So legen Sie die Ausrichtung eines Absatzes fest:

    1. Klicken Sie in den Absatz, dessen Ausrichtung Sie festlegen möchten, oder wählen Sie die gewünschten Absätze aus.

    2. Führen Sie eine der folgenden Aktionen aus:

    Zeigen Sie die Formatierungsleiste an und wählen Sie im Aufklappmenü für die Ausrichtung den gewünschten Eintrag.

    Zeigen Sie die Einstellungsgruppe "Basis" im Dialogfenster "Absatzgestaltung" an, wählen Sie im Aufklappmenü "Ausrichtung" den gewünschten Eintrag und klicken Sie auf "Der Auswahl zuweisen".

Hinweis: Hinweis: Wenn Sie mit Umschalttaste+Eingabetaste oder Umschalttaste+Return-Taste einen erzwungenen Zeilenumbruch in einen Absatz im Blocksatz einfügen, wird der Blocksatz für die Zeile mit dem erzwungenen Umbruch aufgehoben.


Grundlagen in FrameMaker / Textformatierung

Ändern von Tabulatorstopps

Durch Tabulatorstopps kann Text an bestimmten Stellen ausgerichtet werden.

Das Ändern oder Erstellen eines Tabulatorstopps erfolgt in zwei Arbeitsschritten. Zunächst müssen Sie einen Tabulatorstopp definieren. Drücken Sie anschließend die Tabulatortaste in einem Dokument, um die Einfügemarke an den definierten Tabulatorstopp zu verschieben. Wenn Sie die Tab-Taste drücken und sich die Einfügemarke nicht bewegt, muss ein Tabulatorstopp definiert werden.

Für viele Absatzformate sind bereits Tabulatorstopps definiert. Sie können eine dieser vordefinierten Positionen anpassen, indem Sie das Format mithilfe der Formatierungsleiste oder des Dialogfensters "Absatzgestaltung" ändern.

Es gibt vier Arten von Tabulatorstopps: links, zentriert, rechts und dezimal.

A: Linksbündiger Tabulatorstopp B: Zentrierter Tabulatorstopp C: Rechtsbündiger Tabulatorstopp D: Dezimaler Tabulatorstopp

Sie können auch ein Zeichenmuster (Führungszeichen) angeben, das zwischen dem Tabulatorstopp und dem nachfolgenden Zeichen eingefügt wird. In der Regel werden hierfür Punkte verwendet. Sie können aber auch ein beliebiges Zeichen oder eine beliebige Reihe von Zeichen angeben. Tabulatorführungszeichen sind vor allem in Tabellen mit großen Leerräumen zwischen den Spalten hilfreich.

Tabulatorführungszeichen

Hinweis: Im Gegensatz zu Textverarbeitungsprogrammen verwendet FrameMaker absolute statt relative Tabulatorstopps. Bei relativen Tabulatorstopps bewegt sich die Einfügemarke mit jedem Drücken der Tabulatortaste an den nächsten verfügbaren Tabulatorstopp. Bei absoluten Tabulatorstopps bewegt sich die Einfügemarke beim n-ten Drücken der Tabulatortaste an den n-ten Tabulatorstopp in einer Zeile. Wenn kein entsprechender Tabulatorstopp definiert wurde, wird in FrameMaker keine Aktion durchgeführt (das Tabulatorsymbol überdeckt das aktuelle Zeichen).

Bei absoluten Tabulatorstopps verschieben Sie den Text (K2) mit drei Tabulatoren zum dritten Tabulatorstopp.

Bei relativen Tabulatoren kann ein- oder zweimaliges Betätigen der Tabulatortaste den Text zum dritten Tabulatorstopp bewegen.

So können Sie einen Tabulatorstopp mit der Formatierungsleiste hinzufügen, verschieben, bearbeiten oder löschen:

    1. Klicken Sie in einen Absatz oder wählen Sie mehrere Absätze aus. Zeigen Sie dann die Formatierungsleiste an. Wenn Sie mehrere Absätze auswählen, werden in der Formatierungsleiste nur die Tabulatorstopps angezeigt, die in allen ausgewählten Absätzen vorhanden sind.

    2. Führen Sie eine der folgenden Aktionen aus:

    Um einen Tabulatorstopp hinzuzufügen, ziehen Sie ein Tabulatorsymbol aus der Formatierungsleiste an die gewünschte Position unterhalb des oberen Lineals.

A: Links B: Zentriert C: Rechts D: Dezimal

    Wenn Sie einen Tabulatorstopp verschieben möchten, ziehen Sie ihn einfach an eine neue Position. Der Absatztext wird dann in FrameMaker entsprechend der neuen Position verschoben.

Um Tabulatorstopps an Linealmarkierungen auszurichten, aktivieren Sie das Magnetraster ("Grafik > Magnetraster"). Wenn Sie dann ein Tabulatorsymbol mit der Maus ziehen, rastet es an der entsprechenden Position ein.

    Sie können auch mehrere Tabulatorstopps in gleichmäßigen Abständen hinzufügen. Doppelklicken Sie zunächst im oberen Lineal auf den vorhandenen Tabulatorstopp, der dupliziert werden soll. Geben Sie dann den gewünschten Abstand zwischen den Stopps in das Textfeld "Wiederholintervall" ein und klicken Sie auf "Bearbeiten".

    Sie können einen Tabulatorstopp ändern, indem Sie auf ihn doppelklicken, seine neue Position in das Textfeld "Neue Position" eingeben und eine andere Ausrichtung wählen. (Die Position ist der Abstand zwischen dem linken Spaltenrand und dem Tabulatorstopp.) Klicken Sie dann auf "Bearbeiten". Sie können im Lineal auch einen neuen Tabulatorstopp auf einen vorhandenen ziehen, um diesen zu ersetzen.

    Um einen Tabulatorstopp zu löschen, ziehen Sie ihn nach unten aus dem Bereich des oberen Lineals.

    Wenn alle Tabulatorstopps gelöscht werden sollen, doppelklicken Sie auf einen beliebigen Stopp und wählen Sie anschließend "Alle löschen".

So können Sie mit dem Dialogfenster "Absatzgestaltung" einen Tabulatorstopp hinzufügen, bearbeiten oder löschen:

    1. Klicken Sie in den Absatz, den Sie ändern möchten, oder wählen Sie die gewünschten Absätze aus.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Basis" an.

    3. Führen Sie unter "Tabulatoren" eine der folgenden Aktionen aus:

    Um einen neuen Tabulatorstopp hinzuzufügen, doppelklicken Sie auf den Eintrag "Neuer Tabulator", nehmen Sie die gewünschten Einstellungen vor und klicken Sie auf "Fortfahren".

    Um einen Tabulatorstopp zu bearbeiten, doppelklicken Sie auf ihn, ändern Sie die Einstellungen und klicken Sie auf "Fortfahren".

    Um einen Tabulatorstopp zu löschen, doppelklicken Sie auf ihn und wählen Sie "Löschen".

    Wenn alle Tabulatorstopps gelöscht werden sollen, doppelklicken Sie auf einen beliebigen Stopp und wählen Sie anschließend "Alle löschen".

    4. Klicken Sie auf "Der Auswahl zuweisen".

So definieren Sie Führungszeichen für einen Tabulator:

    1. Doppelklicken Sie auf den Tabulatorstopp auf dem Lineal.

    2. Wählen Sie im Dialogfenster unter "Führungszeichen" eines der vordefinierten Führungszeichen oder geben Sie ein eigenes Zeichen ein.

    3. Klicken Sie auf "Bearbeiten".

So geben Sie ein Dezimalzeichen für Tabulatorstopps an:

    1. Doppelklicken Sie auf den Tabulatorstopp auf dem Lineal.

    2. Geben Sie unter "Ausrichtung" das Dezimalzeichen in das Textfeld "Ausrichten an" ein und klicken Sie auf "Bearbeiten". Für europäische Dezimalzahlen wird in der Regel ein Komma verwendet.


Grundlagen in FrameMaker / Textformatierung

Ändern von Abständen

Sie können den Abstand zwischen Absätzen und Linien (vertikaler Abstand) sowie zwischen Wörtern und Zeichen (horizontaler Abstand) festlegen. Abstandseinstellungen haben je nach Kontext verschiedene Bezeichnungen. So heißt der Abstand zwischen Zeichen oft Unterschneidung, das Anpassen des Buchstabenabstands in einer Zeile Verteilung und der Zeilenabstand in einem Absatz (gemessen von der Grundlinie der einen Zeile zur Grundlinie der nächsten) Durchschuss.


Grundlagen in FrameMaker / Textformatierung / Ändern von Abständen

Anpassen des vertikalen Abstands

Für den vertikalen Abstand eines Absatzes sind mehrere Einstellungen verantwortlich, wie in der folgenden Abbildung zu sehen ist.

A: Abstand über Absatz B: Abstand unter Absatz
C: Zeilenabstand

In einem mehrspaltigen Layout können Sie auch den vertikalen Abstand in Spalten anpassen, indem Sie die Höhe des Textes ausgleichen (vertikal ausrichten). Weitere Informationen hierzu finden Sie unter Höhenausgleich von Text bis zum Ende von Textrahmen.

So ändern Sie den Abstand über und unter einem Absatz:

    1. Klicken Sie in den Absatz, dessen Abstände Sie ändern möchten, oder wählen Sie die gewünschten Absätze aus.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Basis" an und geben Sie einen Wert in die Textfelder "Abstand: Oben" und "Abstand: Unten" ein. Sie können die gewünschten Werte auch aus den Aufklappmenüs wählen. Der Abstand zwischen zwei Absätzen wird durch die Einstellung "Abstand: Unten" des ersten Absatzes oder die Einstellung "Abstand: Oben" des zweiten Absatzes bestimmt (je nachdem, welcher Wert größer ist).

Befindet sich ein Absatz am Anfang einer Spalte, wird die Einstellung "Abstand: Oben" in FrameMaker ignoriert. Bei einem Absatz am Ende einer Spalte wird die Einstellung "Abstand: Unten" ignoriert.

Hinweis: Wenn unterhalb der aktuellen Zeile ein verankerter Rahmen platziert wird, dessen Ankersymbol sich in der letzten Zeile eines Absatzes befindet, erscheint der Bereich unter dem Absatz in der Regel zwischen dem Rahmen und dem nächsten Absatz. Wenn der Rahmen jedoch in einem verbundenen Absatz verankert ist, wird der Bereich unterhalb verworfen. Ist der Rahmen ein verbundener Rahmen, der jedoch nicht in einem verbundenen Absatz verankert ist, wird der darunter liegende Bereich zwischen dem Ankersymbol und dem Rahmen angezeigt.

Sie können den Abstand zwischen Absätzen angeben, indem Sie die entsprechenden Absätze markieren und in der Formatierungsleiste im Aufklappmenü für den Zeilenabstand den Eintrag "Abstand zwischen" wählen.

So ändern Sie den Abstand zwischen Textzeilen in einem Absatz:

    1. Klicken Sie in den Absatz, dessen Abstand zwischen Zeichen Sie ändern möchten, oder wählen Sie die gewünschten Absätze aus.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Basis" an. Wählen Sie anschließend aus dem Aufklappmenü "Zeilenabstand" einen Zeilenabstand oder geben Sie einen Wert in das Textfeld ein. (Sie können den Zeilenabstand auch mit dem entsprechenden Aufklappmenü in der Formatierungsleiste angeben.)

    3. Wenn der Zeilenabstand bei hoch-/tiefgestelltem Text, Rubi-Text und größeren Schriftgraden bei Bedarf vergrößert werden soll, deaktivieren Sie die Option "Fest".

Fester Zeilenabstand

Kein fester Zeilenabstand

    4. Klicken Sie auf "Der Auswahl zuweisen".


Grundlagen in FrameMaker / Textformatierung / Ändern von Abständen

Anpassen des horizontalen Abstands

Beim Füllen einer Textzeile wird der Abstand zwischen den Zeichen in FrameMaker entsprechend den Unterschneidungs- und Verteilungseinstellungen angepasst. Der Wortabstand basiert auf den folgenden Werten, die als Teil des Absatzformats gespeichert werden:

    Der minimale Abstand gibt den kleinsten zulässigen Wortabstand an.

    Der maximale Abstand gibt den größten zulässigen Wortabstand an, bevor FrameMaker versucht, eine Silbentrennung durchzuführen oder in Absätzen mit Blocksatz den Buchstabenabstand zu vergrößern.

    Der optimale Abstand ist der Abstand, den FrameMaker zu erreichen versucht.

Diese Werte werden in Prozent des Standardleerzeichens der Standardschrift des Absatzes angegeben. Werte unter 100 % führen zu einem kleineren, Werte über 100 % zu einem größeren Abstand.

Ein kleinerer Wortabstand ergibt eine Darstellung ähnlich wie beim Blocksatz.

Ein größerer Wortabstand ergibt einen ungleichmäßigeren rechten Rand.

So passen Sie den Abstand zwischen Wörtern an:

    1. Klicken Sie in den Absatz, dessen Abstand zwischen Zeichen Sie ändern möchten, oder wählen Sie die gewünschten Absätze aus.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Extra" an und geben Sie die Werte für den minimalen, maximalen und optimalen Wortabstand ein.

    3. Klicken Sie auf "Der Auswahl zuweisen".

Hinweis: Bei Textzeilen in einem Absatz mit Blocksatz kann der maximale Wortabstand überschritten werden, wenn in FrameMaker ein Wort nicht in eine Zeile passt und es nicht getrennt werden kann. Sie können dies verhindern, indem Sie unter "Wortabstand" mit der Option "Automatisch sperren" das automatische Vergrößern des Zeichenabstands aktivieren.

So weisen Sie den Zeichenabstand (Unterschneidung) zu:

Wählen Sie die Option "Unterschneiden" aus. Weitere Informationen hierzu finden Sie unter Änderungen an Schrifteinstellungen in den Gestaltungsfenstern.

So weisen Sie die Verteilung zu:

Ändern Sie den Zeichenabstand (Verteilung). Weitere Informationen hierzu finden Sie unter Änderungen an Schrifteinstellungen in den Gestaltungsfenstern.


Grundlagen in FrameMaker / Textformatierung

Anpassen von Abstand in japanischen Dokumenten

Wenn Ihr System Eingabe von japanischem Text in Dokumente und Dialogfenster unterstützt, können Sie die folgenden Abstandseinstellungen anpassen:

    Mit einer speziellen Einstellungsgruppe im Dialogfenster "Absatzgestaltung" können Sie bestimmte Aspekte des japanischen Zeichenabstands steuern.

    Sie können auch Größe, Abstand und Ausrichtung von Rubi-Text im gesamten Dokument ändern.

    Mit der Schrifteinstellung "Tsume" (siehe Anpassen von Größe, Platzierung und Abstand von Rubi-Text) können Sie den Abstand von japanischen Zeichen variabler Breite beeinflussen.

Diese Einstellungen können Bestandteil eines vordefinierten Formats sein, das Sie jedoch bei Bedarf für einzelne Absätze ändern können.

Informationen zur Arbeit mit koreanischen und chinesischen Zeichen finden Sie im Online-Handbuch Chinesische und koreanische Schriften.


Grundlagen in FrameMaker / Textformatierung / Anpassen von Abstand in japanischen Dokumenten

Anpassen des Abstands von Zeichen und Interpunktionszeichen

Sie können sowohl den Abstand zwischen japanischen und lateinischen als auch den Abstand zwischen japanischen Zeichen ändern.

So passen Sie den Abstand zwischen japanischen Zeichen an:

    1. Klicken Sie in den Absatz, dessen Abstand zwischen Zeichen Sie ändern möchten, oder wählen Sie die gewünschten Absätze aus.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe für asiatische Sprachen an. Diese Einstellungen sind nur verfügbar, wenn Ihr System die Eingabe von japanischem Text in Dokumente und Dialogfenster unterstützt.

    3. Führen Sie folgende Schritte durch:

    In der oberen Gruppe von Textfeldern können Sie den minimalen, maximalen und optimalen Abstand zwischen japanischen und lateinischen Zeichen angeben.

    In der unteren Gruppe von Textfeldern können Sie den minimalen, maximalen und optimalen Abstand zwischen japanischen Zeichen angeben.

    Legen Sie den Abstand zwischen den Zeichen und speziellen Interpunktionszeichen (Yakumono) fest, indem Sie einen Eintrag aus dem Aufklappmenü "Interpunktion" wählen. Bei "Komprimieren, falls erforderlich" wird der Abstand um Interpunktionszeichen nur verringert, wenn eine spezielle Behandlung von Interpunktionszeichen durchgeführt wird (Kinsoku Shori). "Nie komprimieren" legt fest, dass der Abstand um Interpunktionszeichen nicht angepasst wird. Mit "Immer komprimieren" können Sie festlegen, dass der Abstand um Interpunktionszeichen immer verringert wird.

    Damit japanischer Text so aussieht wie bei Verwendung einer Schriftart mit fester Zeichenbreite, müssen Sie "Nie komprimieren" im Aufklappmenü "Interpunktion" wählen und die Option "Tsume" (siehe Änderungen an Schrifteinstellungen in den Gestaltungsfenstern) deaktivieren.


Grundlagen in FrameMaker / Textformatierung / Anpassen von Abstand in japanischen Dokumenten

Anpassen von Größe, Platzierung und Abstand von Rubi-Text

Rubi-Text besteht aus kleinen Zeichen (in der Regel Kana), die oberhalb eines anderen Textes mit der Bezeichnung Oyamoji erscheinen. Sie können die Größe des Rubi-Textes steuern sowie Abstand und Ausrichtung bezüglich des darunter liegenden Oyamoji-Textes festlegen. Diese Einstellungen wirken sich auf den Rubi-Text im gesamten Dokument aus.

A: Rubi-Text B: Oyamoji-Text

So passen Sie Größe, Platzierung und Abstand von Rubi-Text an:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Rubi-Einstellungen". Dieser Befehl ist nur verfügbar, wenn Ihr System die Eingabe von japanischem Text in Dokumente und Dialogfenster unterstützt.

    3. Wählen Sie aus dem Aufklappmenü "Größe" einen Wert oder geben Sie den gewünschten Wert in das Textfeld ein. Der Wert kann in Prozent des Schriftgrades der Oyamoji-Zeichen (z. B. 50 %), als Schriftgrad (z. B. 8 pt) oder in einer beliebigen anderen Maßeinheit (einschließlich Q-Einheiten) angegeben werden.

    4. Führen Sie folgende Schritte durch:

    Damit Rubi-Text bei Bedarf Nicht-Oyamoji-Text überdecken kann, klicken Sie auf "Rubi über die Hiragana-Umgebung hängen lassen".

    Um Leerzeichen vor oder hinter Rubi-Text zu entfernen, wenn dieser sich am Anfang oder Ende einer Zeile befindet, klicken Sie auf "Alle Zeichen an Zeilengrenzen ausrichten".

    5. Klicken Sie auf eine Option unter "Rubi-Ausrichtung für japanische Oyamoji-Zeichen". In der Abbildungen im Dialogfenster wird angezeigt, welcher Abstand und welche Ausrichtung für den Rubi-Text verwendet wird, wenn er sich oberhalb von japanischen Zeichen befindet und wenn er länger oder kürzer als der darunter liegende japanische Text ist.

    6. Klicken Sie auf eine Option unter "Rubi-Ausrichtung für andere Oyamoji-Zeichen". In den Abbildungen im Dialogfenster wird angezeigt, welcher Abstand und welche Ausrichtung für den Rubi-Text verwendet wird, wenn dieser sich oberhalb von nicht-japanischem Text befindet und länger oder kürzer als der darunter liegende Text ist.

    7. Klicken Sie auf "Zuweisen".


Grundlagen in FrameMaker / Textformatierung

Ändern von Silbentrennung und Zeilenumbruch

Beim Trennen von Text in FrameMaker werden Wörter am Zeilenende so umbrochen, dass die Zeilen annähernd gleich lang sind. Die Silbentrennung kann Bestandteil des Absatzformats sein, das Sie jedoch bei Bedarf für einzelne Absätze ändern können.

Sie können nicht nur die automatische Silbentrennung verwenden, sondern auch Wörter manuell trennen und Zeilen manuell umbrechen.

Hinweis: Die Einstellungen für den Zeilenumbruch betreffen nur lateinischen Text. Sie können den Zeilenumbruch für japanischen Text ändern, indem Sie eine MIF-Schablone anpassen (siehe Online-Handbuch MIF Reference).

So ändern Sie die automatische Silbentrennung in Absätzen:

    1. Klicken Sie in den Absatz, dessen Silbentrennung Sie ändern möchten, oder wählen Sie die gewünschten Absätze aus.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Extra" an und führen Sie unter "Automatische Silbentrennung" folgende Aktionen durch:

    Wählen Sie "Trennen", um die automatische Trennung in FrameMaker zu aktivieren.

    Um die maximale Anzahl aufeinander folgender Zeilen anzugeben, die mit einem Trennstrich enden können, geben Sie den gewünschten Wert in das Textfeld "Untereinander" ein.

    Mit dem Textfeld "Kürzestes Wort" können Sie festlegen, wie viele Zeichen ein Wort mindestens enthalten muss, damit es getrennt werden kann.

    Sie können auch angeben, wie viele Zeichen vor und nach einem Trennstrich vorhanden sein müssen. Geben Sie die Werte in die Textfelder "Kürzestes Präfix" und "Kürzestes Suffix" ein.

    3. Klicken Sie auf "Der Auswahl zuweisen".

Wenn Sie verhindern möchten, dass das letzte Wort in einem Absatz getrennt wird, setzen Sie die maximale Anzahl aufeinander folgender Trennzeichen auf 0 oder wählen Sie im Dialogfenster "Zeichengestaltung" bei der Spracheinstellung für das betreffende Wort den Wert "Keine". (Wenn Sie den Wert "Keine" wählen, wird für dieses Wort jedoch auch keine Rechtschreibprüfung durchgeführt.)

So ändern Sie die Silbentrennung eines Wortes:

    1. Klicken Sie in das Wort, das Sie ändern möchten.

    2. Führen Sie folgende Schritte durch:

    Um einen wahlweisen Trennstrich (d. h. eine zulässige Trennposition) an der Einfügemarke einzufügen, drücken Sie Strg+Bindestrich (Windows) bzw. Control+Bindestrich (UNIX). Wenn die Anzeige von Steuerzeichen aktiviert ist, wird über dem Wort das entsprechende Trennstrichsymbol [image] angezeigt.

    Um festzulegen, dass das aktuelle Wort nicht getrennt werden darf, drücken Sie Esc n s. Daraufhin wird ein Trennunterdrückungssymbol ( [image] ) unter dem Wort angezeigt, wenn die Steuerzeichen aktiviert sind. In Dialogfenstern müssen Sie möglicherweise einen speziellen Code für dieses Symbol eingeben. Details dazu finden Sie unter Überblick über die Eingabe in Dialogfenstern.

    Um einen Trennstrich einzugeben, der sich nicht am Zeilenende befinden darf (d. h. einen umbruchgeschützten Trennstrich), drücken Sie Esc Bindestrich h. (In Dialogfenstern müssen Sie möglicherweise einen speziellen Code für dieses Symbol eingeben. Genauere Informationen dazu finden Sie unter Überblick über die Eingabe in Dialogfenstern.)

So können Sie einem Wort zulässige Trennpunkte hinzufügen oder sie daraus entfernen:

Verwenden Sie den Befehl "Rechtschreibhilfe". Weitere Informationen finden Sie unter Prüfen der Rechtschreibung.

So fügen Sie einen Zeilenumbruch ein:

Klicken Sie an der Stelle, an der Sie die Zeile umbrechen möchten, und drücken Sie Umschalttaste+Eingabetaste. Wenn die Anzeige von Steuerzeichen aktiviert ist, wird am Ende der Zeile das entsprechende Symbol [image] angezeigt.

So halten Sie zwei Wörter in einer Zeile zusammen:

Markieren Sie das Leerzeichen zwischen den beiden Wörtern und drücken Sie Strg+Leertaste (Windows) bzw. Control+Leertaste (UNIX). FrameMaker setzt das Symbol für das umbruchgeschützte Leerzeichen [image] zwischen die Wörter.

So geben Sie die Zeichen an, auf die ein Zeilenumbruch folgen kann:

Wählen Sie "Format > Dokument > Textoptionen", geben Sie die Zeichen in das Textfeld "Zeilenumbruch erlaubt nach" ein und klicken Sie auf "Zuweisen". Sie können beispielsweise den Schrägstrich aus der Liste entfernen, wenn Sie Formulierungen wie und/oder verwenden.


Grundlagen in FrameMaker / Textformatierung

Ändern von Seiten- und Spaltenumbruch

In FrameMaker wird Text entsprechend der Einstellungen in den Absatzformaten des Dokuments in Seiten umbrochen. Sie können jedoch das Format bestimmter Absätze bei Bedarf ändern. Die Einstellungen für Seitenumbruch in den Absatzformaten definieren die Seitenumbruchregeln eines Dokuments (dass z. B. nach einer Überschrift mindestens drei Textzeilen auf derselben Seite folgen müssen).

So steuern Sie, wo ein Absatz beginnt:

    1. Klicken Sie in den Absatz, den Sie ändern möchten.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Seitenumbruch" an und führen Sie folgende Aktionen aus:

    Wenn der Absatz am Anfang der nächsten Spalte, der nächsten Seite, der nächsten linken Seite oder der nächsten rechten Seite beginnen soll, wählen Sie aus dem Aufklappmenü "Beginn" den entsprechenden Eintrag.

    Wenn der Absatz an einer beliebigen Position beginnen darf, wählen Sie aus dem Aufklappmenü "Beginn" den Eintrag "Beliebig".

    Wenn der Absatz in derselben Spalte wie der nächste oder vorhergehende Absatz erscheinen soll, wählen Sie "Nächstem" oder "Vorherigem" oder beide Optionen. Diese Einstellungen halten das Ende des einen mit dem Anfang des anderen Absatzes zusammen (aber nicht notwendigerweise alle Zeilen). Mit der Einstellung "Absatzkontrolle" kann für jeden Absatz festgelegt werden, wie viele Zeilen zusammenbleiben sollen.

    Um die Anzahl der Zeilen festzulegen, die sich vereinzelt am Anfang oder Ende einer Spalte befinden können, verwenden Sie das Textfeld "Absatzkontrolle". Wenn alle Zeilen eines Absatzes in derselben Spalte zusammenbleiben sollen, geben Sie für die Einstellungen "Absatzkontrolle" einen hohen Wert ein (bis 100).

    3. Klicken Sie auf "Der Auswahl zuweisen".

Sie können den Wert der Einstellung "Beginn" auch mit dem Befehl "Spezial > Seitenumbruch" festlegen. Auch die auf diese Weise vorgenommenen Einstellungen ändern das Absatzformat (wie die Änderungen im Dialogfenster "Absatzgestaltung").


Grundlagen in FrameMaker / Textformatierung

Hinzufügen von Grafiken zu Absatzformaten

Ein Absatzformat kann eine Linie oder eine andere Grafik enthalten, die ober- bzw. unterhalb des Absatzes erscheint. Sie können das Format bestimmter Absätze bei Bedarf jedoch ändern. So kann beispielsweise unter allen Überschriften der obersten Ebene eine lange dünne Linie angezeigt werden.

Grafik oben

Grafik unten

So platzieren Sie eine Grafik ober- oder unterhalb eines Absatzes:

    1. Zeichnen oder importieren Sie die Grafik auf einer Referenzseite in einen Referenzrahmen oder verwenden Sie eine bereits vorhandene Grafik. Informationen zum Erstellen von Referenzrahmen finden Sie unter Verwenden von Referenzrahmen auf Referenzseiten.

    2. Klicken Sie in den Absatz, den Sie ändern möchten. Um eine Grafik über oder unter mehreren benachbarten Absätzen zu platzieren, wählen Sie die Absätze aus.

    3. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Extra" an und wählen Sie aus dem Aufklappmenü "Rahmen über ¶" oder "Rahmen unter ¶" den Namen eines Referenzrahmens. In den Aufklappmenüs werden alle Referenzrahmen angezeigt.

    4. Klicken Sie auf "Der Auswahl zuweisen".

Da mit den Einstellungen "Rahmen über ¶" und "Rahmen unter ¶" eine Grafik nicht rechts oder links neben einem Absatz platziert werden kann, können sie auch nicht dazu verwendet werden, ein Rechteck um den Text zu zeichnen. Sie können zu diesem Zweck jedoch eine einzellige Tabelle mit Umrandung verwenden.


Grundlagen in FrameMaker / Textformatierung

Festlegen von Formaten für nachfolgende Absätze

In gut durchdachten Schablonen werden Formate oft so verknüpft, dass ein bestimmtes Format in FrameMaker automatisch für den nachfolgenden Absatz (d. h. für den neuen Absatz, der durch Drücken der Eingabetaste erzeugt wird) verwendet wird. Sie können z. B. festlegen, dass auf das Format "Überschrift1" das Format "Haupttext" folgt, sodass der nächste Absatz automatisch den Typ "Haupttext" erhält, wenn Sie die Eingabetaste in einem Absatz im Format "Überschrift1" drücken. Wenn Sie die Eingabetaste drücken, wendet FrameMaker das Format des aktuellen Absatzes auf den neuen an.

So geben Sie ein Format für den nachfolgenden Absatz an:

    1. Klicken Sie in den Absatz.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Basis" an und wählen Sie aus dem Aufklappmenü "Typ nächster ¶" einen Typ aus. Dieser Typ wird in FrameMaker automatisch zugewiesen, wenn Sie durch Drücken der Eingabetaste einen neuen Absatz erzeugen.

    3. Klicken Sie auf "Der Auswahl zuweisen".


Grundlagen in FrameMaker / Textformatierung

Formatieren von Text als Überschrift

Absatzformate verfügen über Einstellungen, mit denen Sie die folgenden speziellen Überschriften erstellen können.

Seitliche Überschriften

Seitliche Überschriften befinden sich neben dem normalen Text und sind daher leicht zu erkennen und zu lesen. Sie werden in der Regel für Randbemerkungen und anderen Text verwendet, der außerhalb des Haupttextes angezeigt werden soll.

Seitliche Überschriften

Verbundene Überschriften

Überschriften erstrecken sich in einem mehrspaltigen Layout über die verschiedenen Spalten. Sie können auch beim raschen Überfliegen des Textes gut erkannt werden.

Verbundene Überschriften

Zwischenüberschriften

Zwischenüberschriften befinden sich zwar in derselben Zeile wie der normale Text, stellen aber eigene Absätze dar. Sie können daher Querverweise auf diese erstellen und sie in Inhaltsverzeichnissen, Kopfzeilen, Fußzeilen usw. verwenden.

Zwischenüberschriften

Überschriftenstile sind in den Absatzformaten eines Dokuments definiert. Dieses Format kann jedoch bei Bedarf für bestimmte Absätze geändert werden.


Grundlagen in FrameMaker / Textformatierung / Formatieren von Text als Überschrift

Erstellen einer seitlichen Überschrift

Wenn Sie in einem Dokument seitliche Überschriften verwenden möchten, müssen Sie zunächst im Layout einen Bereich für seitlichen Überschriften definieren. Dieser Bereich für seitliche Überschriften wird jeweils für den gesamten Textfluss eingerichtet. Sie können die Größe und Position des Bereichs in bestimmten Rahmen im Textfluss ändern. Sobald ein Bereich für seitliche Überschriften in einem Textfluss eingerichtet ist, verschiebt FrameMaker sofort alle nicht als seitliche Überschriften definierten Absätze in den Haupttextbereich.

Wenn eine seitliche Überschrift in einem mehrspaltigen Textrahmen erscheint, wird der vorhergehende Text gleichmäßig über die Spalten verteilt. Enthält eine Seite mehrere Textrahmen, verfügt jeder Textrahmen über einen eigenen Bereich für seitliche Überschriften.

Seitliche Überschriften in einem einzelnen mehrspaltigen Textrahmen (links) und in getrennten einspaltigen Textrahmen (rechts)

So definieren oder ändern Sie einen Bereich für seitliche Überschriften:

    1. Klicken Sie in den Textfluss, für den Sie einen Bereich für seitliche Überschriften einrichten möchten, oder klicken Sie in den Textrahmen mit dem zu ändernden Bereich.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn der Bereich für seitliche Überschriften für das ganze Dokument erstellt oder geändert werden soll, wählen Sie "Format > Seitenlayout > Spaltenlayout".

Hinweis: Nach Ausführen der oben genannten Aktion ändert sich die Position der Kopf-/Fußzeile.

    Um den Bereich für seitliche Überschriften eines einzelnen Textrahmens zu ändern, klicken Sie in den Textrahmen und wählen Sie "Format > Spezielles Layout > Spezieller Textrahmen".

    3. Aktivieren oder deaktivieren Sie "Platz für seitliche Überschrift". Diese Einstellung wird immer für den gesamten Textfluss verwendet, auch wenn Sie nur die Einstellungen für einen einzelnen Textrahmen ändern.

    4. Geben Sie die Breite des Bereichs für die seitliche Überschrift und den Abstand zum Haupttextbereich an. (Der Abstand zwischen der seitlichen Überschrift und dem vorhergehenden Absatz richtet sich nach der Einstellung "Abstand: Unten" des vorhergehenden Absatzes oder nach der Einstellung "Abstand: Oben" der seitlichen Überschrift, je nachdem, welcher Wert größer ist.)

    5. Geben Sie im Aufklappmenü "Seite" die gewünschte Position für die seitlichen Überschriften an.

So erstellen Sie eine seitliche Überschrift:

    1. Klicken Sie in den Absatz, den Sie ändern möchten.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Seitenumbruch" an, klicken Sie auf "Seitl. Überschrift - Ausrichtung" und wählen Sie aus dem Aufklappmenü "Seitl. Überschrift - Ausrichtung" die gewünschte Option.

Ausrichtung an erster Grundlinie

Ausrichtung an oberer Kante

Ausrichtung an letzter Grundlinie

    3. Klicken Sie auf "Der Auswahl zuweisen".


Grundlagen in FrameMaker / Textformatierung / Formatieren von Text als Überschrift

Erstellen von verbundenen Überschriften

Verbundene Überschriften erstrecken sich in einem mehrspaltigen Textrahmen über mehrere Spalten. Wenn sich ein Überschriftenabsatz über Spalten erstreckt, wird der Text oberhalb der Überschrift gleichmäßig über die Spalten verteilt.

So erstellen Sie eine verbundene Überschrift:

    1. Klicken Sie in den Absatz, den Sie ändern möchten.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Seitenumbruch" an und klicken Sie auf "Über alle Spalten" oder "Über alle Spalten und seitlichen Überschriften".

"Über alle Spalten" (links) und "Über alle Spalten und seitliche Überschriften" (rechts)

    3. Klicken Sie auf "Der Auswahl zuweisen".


Grundlagen in FrameMaker / Textformatierung / Formatieren von Text als Überschrift

Erstellen von Zwischenüberschriften

Da Zwischenüberschriften dieselben Randeinstellungen verwenden wie der normale Haupttext und sich in derselben Zeile befinden wie der normale Haupttext, werden sie in der Regel in einer anderen Schrift oder einer anderen Stärke angezeigt. Sie können auch durch Interpunktionszeichen vom nachfolgenden Text abgehoben werden. Wenn Sie nicht die Standardinterpunktion verwenden möchten, können Sie diese Einstellung in einzelnen Fällen ändern.

Alle Einstellungen sind im Absatzformat definiert, das Sie jedoch bei Bedarf für bestimmte Absätze ändern können.

Hinweis: Der Abstand zwischen der Zwischenüberschrift und dem vorhergehenden Absatz richtet sich nach der Einstellung "Abstand: Unten" des Absatzes oder nach der Einstellung "Abstand: Oben" der Überschrift, je nachdem, welcher Wert größer ist.

So erstellen oder ändern Sie eine Zwischenüberschrift:

    1. Klicken Sie in den Absatz, den Sie ändern möchten. Wenn es sich bei dem Absatz bereits um eine Zwischenüberschrift handelt, befindet er sich in derselben Zeile wie der nachfolgende Absatz. Achten Sie daher genau darauf, in welchen Absatz Sie klicken.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Seitenumbruch" an und klicken Sie auf "Zwischenüberschrift - Interpunktion". Geben Sie ggf. ein Interpunktionszeichen, ein Leerzeichen oder eine Kombination der beiden ein.

    3. Klicken Sie auf "Der Auswahl zuweisen".

    4. Zeigen Sie die Einstellungsgruppe "Standardschrift" an und ändern Sie die Schrift der Zwischenüberschrift, sodass sie sich, sofern Sie dies möchten, vom umgebenden Text abhebt.

    5. Klicken Sie auf "Der Auswahl zuweisen".

So ändern Sie die Interpunktionszeichen für eine Zwischenüberschrift:

Geben Sie nach der Zwischenüberschrift das gewünschte Interpunktionszeichen ein. FrameMaker ignoriert das im Textfeld "Zwischenüberschrift - Interpunktion" angegebene Interpunktionszeichen, behält aber die in den Standardwerten enthaltenen Sonderzeichen (einschließlich m- und n-Leerzeichen) bei. Wenn z. B. das Standardzeichen ein Punkt ist, können sie dies außer Kraft setzen, indem Sie einen Doppelpunkt am Ende der Zwischenüberschrift eingeben.


Grundlagen in FrameMaker / Textformatierung

Nummerierte Listen und Listen mit Auszeichnungspunkten

Sie erstellen nummerierte Listen und Listen mit Auszeichnungspunkten, indem Sie Absatzformate verwenden, in denen eine automatische Nummerierung definiert ist. Beim Hinzufügen von Absätzen mit automatischer Nummerierung werden diese in FrameMaker automatisch nummeriert; bereits vorhandene Absätze werden ggf. neu nummeriert.

Absätze mit automatischer Nummerierung werden in einem Textfluss durchgehend nummeriert. Wenn Ihr Dokument mehrere Textflüsse enthält, erfolgt die automatische Nummerierung in jedem Textfluss unabhängig von den anderen Textflüssen.

Die automatische Nummerierung wird mit der Einstellungsgruppe "Nummerierung" im Dialogfenster "Absatzgestaltung" durchgeführt. Ein Format der automatischen Nummerierung kann eine Serienbezeichnung, einen Zähler, Tabulatoren und beliebigen zusätzlichen Text enthalten.

Hinweis: Ein Format der automatischen Nummerierung muss keine Absatznummerierung beinhalten. Wenn das Format ohne Bausteine verwendet wird, können mit ihm auf einfache Weise automatischer Text oder Symbole eingefügt werden. So kann z. B. automatisch ein Auszeichnungspunkt oder das Wort Hinweis eingefügt werden.

Serienbezeichnung

Serienbezeichnungen geben verschiedene Arten von Nummerierungsserien in demselben Textfluss an. Wenn Sie beispielsweise Abbildungen unabhängig von Tabellen oder Überschriften nummerieren möchten, verwenden Sie einfach mehrere Serien. (Verschiedene Gruppen von Arbeitsschritten wären jedoch beispielsweise keine unterschiedlichen Serien.)

Tabellen- und Abbildungsnummern müssen jedoch zu derselben Serie gehören, um auf Abschnittsnummern zu basieren.

Zähler

Ein Zähler ist ein Platzhalter (Baustein), der in FrameMaker durch eine Ziffer oder einen Buchstaben ersetzt wird. So erhöht beispielsweise der Zähler <n+> die Absatznummer um 1. Ist der Absatz der zweite in einer Serie, wird <n+> in FrameMaker durch die Zahl 2 ersetzt. Sie können in einem Format auch mehrere Zähler verwenden. Genaue Informationen hierzu finden Sie unter Verwenden von Zählern in Formaten der automatischen Nummerierung.

Sie können in ein Format auch Bausteine für Kapitel <$chapnum> und Band <$volnum> einfügen. Weitere Informationen finden Sie unter Basieren der automatischen Nummerierung auf Kapitel- und Bandnummern.

Tabulatoren, Text und Interpunktion

Ein Format der automatischen Nummerierung kann auch Tabulatoren, Auszeichnungspunkte, Leerzeichen und Interpunktionszeichen enthalten.

Format der automatischen Nummerierung
A: Serienbezeichnung B: Text C: Zähler D: Tabulator

Nummerierte Liste

Sie können das Format der automatischen Nummerierung für bestimmte Absätze ändern oder ein eigenes Format erstellen.


Grundlagen in FrameMaker / Textformatierung

Formatieren von Text als nummerierte Liste

Sie erstellen eine nummerierte Liste, indem Sie Absatzformate der automatischen Nummerierung verwenden – in Form von speziellen Bausteinen, genannt Zähler.

Das Erstellen einer nummerierten Liste erfordert manchmal das Formatieren des ersten Elements in der Liste mit einem Absatzformat, das den Zähler auf 1 zurücksetzt. Anschließend können die weiteren Elemente mit einem anderen Format formatiert werden, mit dem der Zähler erhöht wird. So können Sie z. B. dem ersten Listenelement das Format "Schritt1" und allen weiteren Listenelementen das Format "SchrittNächster" zuweisen. Formate können auch so definiert werden, dass ein einzelnes Format auf alle Elemente einer nummerierten Liste angewendet werden kann. Dies wird bei der Gestaltung der Schablone definiert. Weitere Informationen zu diesem Thema finden Sie unter Zurücksetzen einer Serie.

So erstellen Sie eine nummerierte Liste:

    1. Markieren Sie die aufeinander folgenden Absätze, die automatisch nummeriert werden sollen. Um einen einzelnen Absatz in eine nummerierte Liste aufzunehmen, klicken Sie in den Absatz.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Nummerierung" an und geben Sie in das Textfeld "Format der automatischen Nummerierung" eine Serienbezeichnung ein, wenn in dem Dokument mehrere Nummerierungsserien verwendet werden sollen.

Eine Serienbezeichnung besteht aus einem einzelnen druckbaren Zeichen und einem Doppelpunkt (z. B. S:). Wenn eine Serienbezeichnung verwendet wird, muss sie am Anfang des Formats angegeben werden.

    3. Geben Sie den Rest des Formats der automatischen Nummerierung an. Geben Sie beliebigen Text ein, der bei dem Format der automatischen Nummerierung automatisch angezeigt werden soll. Tabulatoren und Zähler können mithilfe der Auswahlliste "Bausteine" angegeben werden. Wenn Sie einen Eintrag wählen, wird er an der Einfügemarke in das Textfeld "Format der automatischen Nummerierung" eingefügt. Weitere Informationen zu Zählern finden Sie unter Verwenden von Zählern in Formaten der automatischen Nummerierung.

Hinweis: Manche Zeichen, wie umbruchgeschützte Leerzeichen und m-Leerzeichen, müssen mithilfe spezieller Codes eingegeben werden. Weitere Informationen hierzu finden Sie unter Eingabe in Dialogfenstern.

    4. Wählen Sie aus der Auswahlliste "Zeichenformat" das Zeichenformat für die automatische Nummerierung. Wenn Sie kein Format angeben, wird die Zahl in der Standardschrift des Absatzes angezeigt.

    5. Wählen Sie aus dem Aufklappmenü "Position" die Position der Zahl. Bei der automatischen Nummerierung wird die Zahl selten am Absatzende angezeigt. Eine Ausnahme sind Gleichungsformate.

    6. Klicken Sie auf "Der Auswahl zuweisen".

    7. Wenn Sie in Schritt 3 einen Tabulator (\t) eingefügt haben, müssen Sie den zugehörigen Tabulatorstopp für das Absatzformat definieren. Weitere Informationen finden Sie unter Ändern von Tabulatorstopps.

So deaktivieren Sie die automatische Nummerierung für einen Absatz:

    1. Klicken Sie in eine nummerierte Liste und deaktivieren Sie im Dialogfenster "Absatzgestaltung" in der Einstellungsgruppe "Nummerierung" die Option "Format der automatischen Nummerierung". Sie müssen zweimal auf das Markierungsfeld klicken, um die Option zu deaktivieren, denn beim ersten Klicken wird der Wert in "Beibehalten" geändert.

    2. Klicken Sie auf "Der Auswahl zuweisen".


Grundlagen in FrameMaker / Textformatierung

Formatieren von Text als Liste mit Auszeichnungspunkten

Sie erstellen eine Liste mit Auszeichnungspunkten, indem Sie Absatzformate verwenden, die im Format der automatischen Nummerierung einen Auszeichnungspunkt enthalten.

Neben dem normalen Auszeichnungspunkt ( [image] ), der in allen Schriften vorhanden ist, können Sie alle Zeichen der installierten Schriften verwenden (einschließlich der Dingbat-Schriften wie "Zapf Dingbats"). Sie können z. B. als Auszeichnungssymbol ein Zapf Dingbats-Quadrat ( [image] ) angeben.

So erstellen Sie eine Liste mit Auszeichnungspunkten:

    1. Wählen Sie aufeinander folgende Absätze aus, die als Liste mit Auszeichnungspunkten angezeigt werden sollen. Um einen einzelnen Absatz in eine Liste aufzunehmen, klicken Sie in den Absatz.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Nummerierung" an und klicken Sie in der Auswahlliste "Bausteine" auf die Auszeichnungs- und Tabulatorsymbole (\b und \t).

    3. Klicken Sie auf "Der Auswahl zuweisen".

    4. Wenn Sie in Schritt 2 einen Tabulator (\t) eingefügt haben, müssen Sie den zugehörigen Tabulatorstopp für das Absatzformat definieren. Weitere Informationen finden Sie unter Ändern von Tabulatorstopps.

So entfernen Sie einen Auszeichnungspunkt aus einem Absatz:

    1. Klicken Sie in einer Liste mit Auszeichnungspunkten und deaktivieren Sie im Dialogfenster "Absatzgestaltung" in der Einstellungsgruppe "Nummerierung" die Option "Format der automatischen Nummerierung". Sie müssen zweimal auf das Markierungsfeld klicken, um die Option zu deaktivieren, denn beim ersten Klicken wird der Wert in "Beibehalten" geändert.

    2. Klicken Sie auf "Der Auswahl zuweisen".

So verwenden Sie ein spezielles Auszeichnungssymbol:

    1. Erstellen Sie ein Zeichenformat mit der Schrift, die das gewünschte Symbol enthält. Wenn beispielsweise "Zapf Dingbats" mit Schriftgrad 9 verwendet werden soll, erstellen Sie ein Zeichenformat mit dieser Schrift. Geben Sie dem Format einen beschreibenden Namen (z. B. AuszSchrift).

Weitere Informationen zum Erstellen von Zeichenformaten finden Sie unter Verwenden der Gestaltungsfenster zum Ändern von Schrifteinstellungen.

    2. Zeigen Sie im Dialogfenster "Absatzgestaltung" die Einstellungsgruppe "Nummerierung" an und geben Sie in das Textfeld "Format der automatischen Nummerierung" das dem Symbol entsprechende Zeichen ein (anstatt das Symbol aus der Liste "Bausteine" zu wählen).

Wenn Sie beispielsweise ein Zapf Dingbats-Quadrat verwenden möchten, geben Sie den Kleinbuchstaben n ein, der in dieser Schrift als [image] angezeigt wird. Das dem Symbol entsprechende Zeichen können Sie dem Zeichensatz der Schrift entnehmen (im Online-Handbuch FrameMaker-Zeichensätze finden Sie die Zeichensätze der Schriften "Symbol" und "Zapf Dingbats").

    3. Klicken Sie in der Auswahlliste "Bausteine" auf das Tabulatorsymbol (\t) oder geben Sie Leerzeichen ein.

Hinweis: Manche Zeichen, wie umbruchgeschützte Leerzeichen und m-Leerzeichen, müssen mithilfe spezieller Codes eingegeben werden. Weitere Informationen hierzu finden Sie unter Eingabe in Dialogfenstern.

    4. Klicken Sie in der Auswahlliste "Zeichenformat" auf das zuvor erstellte Format.

    5. Klicken Sie auf "Der Auswahl zuweisen".


Grundlagen in FrameMaker / Textformatierung

Verwenden von Zählern in Formaten der automatischen Nummerierung

Ein Zähler besteht aus spitzen Klammern (< >), in die ein Anzeigestil und ein Inkrementierungswert eingeschlossen sind.

A: Anzeigestil B: Inkrementierungswert

Hinweis: Die Funktion zur benutzerdefinierten automatischen Nummerierung unterstützt den Unicode-Standard zur Textcodierung.

Um den Anzeigestil anzugeben, verwenden Sie einen Zähler mit einem der folgenden Buchstaben.

Nummerierungsart | Verwenden
Numerisch (1, 2, 3, ...) | n
Römisch, klein (i, ii, iii, iv, ...) | r
Römisch, groß (I, II, III, IV, ...) | R
Alphabetisch, klein (a, b, c, ..., aa) | a
Alphabetisch, groß (A, B, C, ..., AA) | A

Um anzuzeigen, wie die Nummer erhöht wird, verwenden Sie einen Zähler mit einem Inkrementierungswert.

Funktion | Verwenden
Beibehalten des Wertes | <n>
Setzen des Wertes auf 1 oder auf eine beliebige Zahl, die Sie nach dem Gleichheitszeichen eingeben. | <n=1>
Erhöhen des Zählers um 1 | <n+>
Beibehalten des Wertes, ohne ihn anzuzeigen | < >
Zurücksetzen auf 0 (oder eine andere Zahl), ohne den Wert anzuzeigen | < =0>

Standardmäßig wird jeder Zähler mit 0 initialisiert. Sie können aber auch einen anderen Anfangswert angeben. Anschließend kann der aktuelle Wert des Zählers beibehalten, um 1 erhöht oder auf einen anderen Wert gesetzt werden. Verwenden Sie beispielsweise <n=1> in dem Format, das die Nummerierung am Anfang einer Gruppe von nummerierten Arbeitsschritten auf 1 zurücksetzt.

Wenn ein Wert beibehalten werden soll, ohne dass er angezeigt wird, geben Sie zwischen den spitzen Klammern ein Leerzeichen ein. Wenn Sie das Leerzeichen weglassen, werden die Klammern als Bestandteil des Formats der automatischen Nummerierung angezeigt.


Grundlagen in FrameMaker / Textformatierung / Verwenden von Zählern in Formaten der automatischen Nummerierung

Basieren der automatischen Nummerierung auf Kapitel- und Bandnummern

Sie können die Bausteine <$volnum> und <$chapnum> in Absatzformate einfügen. Die Band- und Kapitelnummern werden anhand der Einstellungen im Dialogfenster "Einstellungen für Nummerierung" definiert (siehe Festlegen der Nummerierung von Dokumenten und Seiten).

Beispiel | Nummerierungsformat
Band 3 Kapitel 3 | Band <$volnum> Kapitel <$chapnum>

In der folgenden Tabelle wird dargestellt, wie Sie den Kapitel-Baustein mit anderen Bausteinen kombinieren können.

Beispiel | Nummerierungsformat
Abschnitt 1.1 Abschnitt 1.1.1 Abbildung 1-1 Tabelle 1-1 | S:Abschnitt <$chapnum>.<n+><=0> S:Abschnitt <$chapnum>.<n>.<n+> F:Abbildung <$chapnum>-<n+> T:Tabelle <$chapnum>-<n+>


Grundlagen in FrameMaker / Textformatierung / Verwenden von Zählern in Formaten der automatischen Nummerierung

Basieren der automatischen Nummerierung auf Abschnittsnummern

Sie können für jede Art von Nummerierungsschema in einem Dokument eine andere Serie erstellen. So kann z. B. Überschriften, Abbildungen und Tabellen jeweils eine andere Serienbezeichnung zugewiesen werden. In diesem Fall wird jedoch davon ausgegangen, dass die Nummerierung, wie in der folgenden Tabelle, basierend auf Abschnittsnummern durchgeführt werden soll.

Abschnitt | Abbildung | Tabelle
Abschnitt 1 1.1 1.2 | Abbildung 1-1 Abbildung 1-2 | Tabelle 1-1 Tabelle 1-2
Abschnitt 2 2.1 2.2 | Abbildung 2-1 Abbildung 2-2 | Tabelle 2-1 Tabelle 2-2

Wenn Sie für Abschnitte, Abbildungen und Tabellen unterschiedliche Serien einrichten, kann FrameMaker den Abbildungs- und Tabellennummern nicht die Abschnittsnummern zugrunde legen. Um diese Art der Nummerierung durchzuführen, müssen Sie Formate der automatischen Nummerierung in einer einzigen Serie erstellen (mit der gleichen Serienbezeichnung für jedes Format). Die folgende Tabelle enthält die Formate der automatischen Nummerierung, die Sie definieren können. Die Darstellung erfolgt in tabellarischer Form, damit Sie die Position der Zähler in der Zeichenfolge deutlich erkennen können.

Die Position der Zähler bestimmt, wie sie erhöht werden

Absatzformat | Nummerierungsformat
AbschnTitel | H:Abschnitt | <$chapnum> | < =0> | < =0> | < =0>
Titel1 | H: | <$chapnum> | .<n+> | < > | < >
AbbTitel | H:Abbildung | <$chapnum> | < > | -<n+> | < >
TabTitel | H:Tabelle | <$chapnum> | < > | < > | -<n+>

Sobald ein Absatz des Typs "AbschnTitel" erscheint, erhöht sich die Abschnittsnummer um 1 und die verbleibenden Zählerwerte werden auf 0 zurückgesetzt. Die <n+> Zähler in den verbleibenden Formaten beziehen sich auf einen anderen Elementtyp (Überschriften, Abbildungen und Tabellen) und werden daher unabhängig voneinander erhöht.

Die Zähler < > verhindern, dass FrameMaker Werte auf null zurücksetzt.


Grundlagen in FrameMaker / Textformatierung / Verwenden von Zählern in Formaten der automatischen Nummerierung

Verwenden von mehreren Zählern in einem Format der automatischen Nummerierung

Ein Format der automatischen Nummerierung kann mehrere Zähler enthalten. Beispielsweise sind zwei Zähler für die Nummerierung von Abschnitten und Unterabschnitten möglich.

Zähler | Format | Anzeige
<$chapnum>.<n=0> | Titel1 | 1.0
<$chapnum>.<n+> | Titel2 | 1.1
<$chapnum>.<n+> | Titel2 | 1.2
<$chapnum>.<n=0> | Titel1 | 2.0

Die beiden Zähler mit ihrem jeweiligen Format werden unabhängig voneinander geführt. Die Position eines Zählers in der Zeichenfolge bestimmt, wie er angezeigt und erhöht wird. Beim Erhöhen eines Zählers legt FrameMaker den Wert im entsprechenden Zähler des vorhergehenden, automatisch nummerierten Absatzes im selben Textfluss zugrunde.

Das folgende Beispiel enthält mehrere Zähler in Abschnitts- und Unterabschnittstiteln. Der Zähler vor dem Punkt wird unabhängig vom Zähler nach dem Punkt erhöht.

Beispiel | Nummerierungsformat | Typ
1.0 Erste Schritte 1.1 Installation 1.2 Sicherung 2.0 Dateneingabe | <n+>.<n=0>\t <n>.<n+>\t <n>.<n+>\t <n+>.<n=0>\t | Titel1 Titel2 Titel2 Titel1

In dem folgenden Beispiel werden bis zu drei Zähler in einem Format verwendet.

Beispiel | Nummerierungsformat | Typ
1.0 Erste Schritte 1.1 Installation 1.2 Sicherung 1.2.1 Fehler 1.3 Dateneingabe | <n+>.<n=0>\t <n>.<n+>\t <n>.<n+>\t <n>.<n>.<n+>\t <n>.<n+>\t | Titel1 Titel2 Titel2 Titel3 Titel2

Das folgende Beispiel enthält Formate der automatischen Nummerierung im Gliederungsstil.

Beispiel | Nummerierungsformat | Typ
I Einführung A Installation B Sicherung II Dateneingabe A Datei öffnen B Datei speichern | <R+>< =0>\t < ><A+>\t < ><A+>\t <R+>< =0>\t < ><A+>\t < ><A+>\t | Titel1 Titel2 Titel2 Titel1 Titel2 Titel2

Die Nummerierung in der Überschrift Datei öffnen beginnt wieder mit A; der zweite Zähler des vorhergehenden Absatzformats setzt die Nummerierung auf null zurück (ohne dies anzuzeigen). <A+> erhöht den Zähler daher auf 1 (bzw. A, den ersten Buchstaben des Alphabets).

Der Zähler < > im Format des Absatzes "Titel2" behält den Wert des ersten Zählers bei, zeigt ihn aber nicht an. Befindet sich der Zähler < > nicht an dieser Position, bezieht sich <A+> im Format "Titel2" auf den ersten Zähler (nicht auf den zweiten). Dies führt in FrameMaker zu folgender Anzeige:

Format der automatischen Nummerierung im Gliederungsstil


Grundlagen in FrameMaker / Textformatierung / Verwenden von Zählern in Formaten der automatischen Nummerierung

Zurücksetzen einer Serie

Einige Nummerierungsserien (z. B. Listen mit nummerierten Arbeitsschritten) beginnen immer wieder bei 1. Sie können diese Serien auf zwei Arten zurücksetzen, wie in den folgenden beiden Beispielen gezeigt wird.

In dem ersten Beispiel wird gezeigt, wie Sie festlegen können, dass die Nummerierung einer Serie von vorn beginnt, indem Sie den Baustein <n=1> für den ersten Arbeitsschritt und den Baustein <n+> für nachfolgende Arbeitsschritte verwenden.

Beispiel | Nummerierungsformat | Typ
Schritt 1. Entpacken. Schritt 2. Speichern. Schritt 3. Installieren. Schritt 1. Datei speichern. | S:Schritt <n=1>.\t S:Schritt <n+>.\t S:Schritt <n+>.\t S:Schritt <n=1>.\t | Schritt1 SchrittNächster SchrittNächster Schritt1

In dem zweiten Beispiel wird eine weitere Möglichkeit dargestellt, wie Sie den Zähler so zurückzusetzen können, dass Sie kein eigenes Format verwenden müssen, wenn eine nummerierte Liste angefangen werden soll. Stattdessen verwendet der Absatz vor der Liste ein Format, das den Zähler zurücksetzt.

Beispiel | Nummerierungsformat | Typ
So installieren Sie die Software: Schritt 1. Entpacken. Schritt 2. Speichern. Schritt 3. Installieren. | S:< =0> S:Schritt <n+>.\t S:Schritt <n+>.\t S:Schritt <n+>.\t | SchrittAnfang Schritt Schritt Schritt

Der Zähler < =0> im Format "SchrittAnfang" setzt die Serie S auf null zurück, zeigt den Wert aber nicht an.

Wenn ein Zähler erhöht wird, werden alle nicht angegebenen Zähler der Serie, die sich rechts von diesem befinden, auf null zurückgesetzt. So sind beispielsweise die folgenden beiden Angaben identisch:
S:<n+>< =0>\t
S:<n+>\t


Grundlagen in FrameMaker / Textformatierung / Verwenden von Zählern in Formaten der automatischen Nummerierung

Verwenden japanischer Nummerierungsoptionen

Wenn Ihr System die Eingabe von japanischem Text in Dokumente und Dialogfenster unterstützt, können Sie in Formaten der automatischen Nummerierung die folgenden zusätzlichen Zähler verwenden.

Verwenden Sie diese Nummerierungsoptionen nur für japanischen Text und japanische Schriften.

Baustein | Bedeutung | Zeichensortierung
<zenkaku a> | Römisches Alphabet, Kleinbuchstaben fester Breite |
<zenkaku A> | Römisches Alphabet, Großbuchstaben fester Breite |
<zenkaku n> | Arabische Ziffern fester Breite |
<kanji kazu> | Kanji-Standardnummerierung, bei der zweistellige Zahlen aus den herkömmlichen Kanji-Zeichen für zehn, hundert usw. bestehen |
<kanji n> | Zahlen für Hausnummern, Telefonnummern, Postleitzahl usw., bei denen zweistellige Zahlen aus den Kanji-Zeichen für null bis neun bestehen |
<daiji> | Zahlen für kaufmännische Aufgaben, die aus den alten Kanji-Ziffern bestehen |
<hira gojuon> | Hiragana-Zeichen in der Standardreihenfolge |
<kata gojuon> | Katakana-Zeichen in der Standardreihenfolge |
<hira iroha> | Hiragana-Zeichen in der literalen Reihenfolge (selten) |
<kata iroha> | Katakana-Zeichen in der literalen Reihenfolge (selten) |


Grundlagen in FrameMaker / Textformatierung

Definieren und Aktualisieren von Formaten

Die vordefinierten Formateinstellungen (der im Absatzformat-Katalog und im Zeichenformat-Katalog gespeicherten Formate) bestimmter Textpassagen können geändert werden. Sie können mit diesen geänderten Einstellungen auch die gespeicherten Formate und somit den gesamten Text im Dokument, dem sie zugewiesen sind, neu definieren oder aktualisieren. Sie können beispielsweise in einem Dokument alle Absätze des Typs "Überschrift1" so aktualisieren, dass sie eine andere Schrift verwenden und von nun an als seitliche Überschriften angezeigt werden.

Beim Aktualisieren eines Formats können Sie alle Einstellungen oder nur eine bestimmte Einstellungsgruppe ändern. Sie können beispielsweise die Standardschriftfamilie aller Formate in einem Dokument ändern, ohne andere Einstellungen zu ändern.

Beim Ändern von Einstellungen in einem Gestaltungsfenster können Sie den Vorgang jederzeit abbrechen und die Einstellungen wieder auf die ursprünglichen Werte zurücksetzen, indem Sie einfach im Text klicken. Sie können dazu auch im Gestaltungsfenster aus dem Aufklappmenü "Befehle" die Option "Einstellungen der Auswahl übernehmen" wählen.

So aktualisieren Sie ein Absatzformat:

    1. Führen Sie eine der folgenden Aktionen aus:

    Um die Einstellungen eines Absatzes anzuzeigen (mit irregulären Formaten), klicken Sie in einen Absatz mit dem zu aktualisierenden Format und wählen Sie "Format > Absätze > Gestaltung".

    Um die Einstellungen eines im Katalog gespeicherten Absatzformats (d. h. ohne irreguläre Formate) anzuzeigen, wählen Sie "Format > Absätze > Gestaltung" und klicken Sie anschließend im Aufklappmenü "Absatztyp" auf das entsprechende Format.

    2. Ändern Sie die gewünschten Absatzeinstellungen.

    3. Klicken Sie auf "Alle aktualisieren".

Wenn die zu aktualisierenden Absätze irreguläre Formate aufweisen (d. h. wenn die Formate nicht mit den im Katalog gespeicherten Formaten übereinstimmen), werden Sie in einem Dialogfenster gefragt, ob die Formate entfernt werden sollen.

So aktualisieren Sie ein Absatzformat mithilfe der Formatierungsleiste:

Klicken Sie in den Absatz, dessen Format aktualisiert werden soll, und wählen Sie in der Formatierungsleiste aus dem Aufklappmenü für Absatzformate "Alle aktualisieren".

So aktualisieren Sie bestimmte Einstellungen eines Absatzformats:

    1. Um mehrere Formate zu aktualisieren, wählen Sie die aufeinander folgenden Absätze, die die zu ändernden Formate enthalten. Wenn Sie alle Absatzformate oder nur ein Format ändern möchten, fahren Sie mit dem nächsten Schritt fort.

    2. Wählen Sie "Format > Absätze > Gestaltung", zeigen Sie die gewünschte Einstellungsgruppe an und wählen Sie aus dem Aufklappmenü "Befehle" den Eintrag "Alle Einstellungen auf 'Beibehalten'". (Einstellungen mit dem Wert "Beibehalten" werden in FrameMaker nicht geändert.)

Wenn eine Einstellung den Wert "Beibehalten" hat, werden Textfelder leer, Markierungsfelder abgeblendet und Aufklappmenüs mit dem Eintrag "Beibehalten" angezeigt (siehe Verwenden von "Beibehalten").

    3. Ändern Sie nur die Einstellungen, die Sie aktualisieren möchten.

    4. Wählen Sie im Aufklappmenü "Befehle" den Eintrag "Optionen für globale Aktualisierung".

    5. Aktivieren Sie unter "Einstellungen der Absatzgestaltung verwenden" die aktuelle Einstellungsgruppe.

    6. Führen Sie eine der folgenden Aktionen aus:

    Um alle Formate im Dokument zu aktualisieren, aktivieren Sie die Option "Alle Absätze und Katalogeinträge".

    Um alle ausgewählten Absätze und alle Absätze desselben Typs zu aktualisieren, klicken Sie auf "Alle entsprechenden Typen in Auswahl".

    Wenn nur Formate eines bestimmten Typs aktualisiert werden sollen, aktivieren Sie die Option "Alle des Typs" und wählen aus dem Aufklappmenü den gewünschten Typ.

    7. Klicken Sie auf "Aktualisieren".

So aktualisieren Sie eine Eigenschaftsgruppe in einem Absatzformat:

    1. Geben Sie den Umfang der Änderungen an, die Sie vornehmen möchten, indem Sie einen der folgenden Schritte ausführen:

    Um ein Absatzformat oder alle Absatzformate im Dokument mit einer Einstellungsgruppe eines Absatzes zu aktualisieren, klicken Sie in diesen Absatz oder wählen Sie mehrere aufeinander folgende Absätze aus.

    Um mehrere, jedoch nicht alle Absatzformate zu aktualisieren, wählen Sie aufeinander folgende Absätze, die die zu aktualisierenden Formate enthalten.

    2. Wählen Sie "Format >Absätze > Gestaltung" und löschen Sie den Typ im Textfeld "Absatztyp", wenn das Feld nicht leer ist. Dadurch erhält das Textfeld den Wert "Beibehalten" und es wird verhindert, dass FrameMaker den Typ der zu aktualisierenden Formate ändert.

    3. Zeigen Sie die zu aktualisierende Einstellungsgruppe an und ändern Sie die Einstellungen nach Bedarf.

    4. Wählen Sie im Aufklappmenü "Befehle" den Eintrag "Optionen für globale Aktualisierung".

    5. Aktivieren Sie unter "Einstellungen der Absatzgestaltung verwenden" die aktuelle Einstellungsgruppe.

    6. Führen Sie eine der folgenden Aktionen aus:

    Um alle Formate im Dokument zu aktualisieren, klicken Sie auf "Alle Absätze und Katalogeinträge".

    Um alle ausgewählten Absätze und alle Absätze desselben Typs zu aktualisieren, klicken Sie auf "Alle entsprechenden Typen in Auswahl".

    Wenn nur Formate eines bestimmten Typs aktualisiert werden sollen, aktivieren Sie die Option "Alle des Typs" und wählen aus dem Aufklappmenü den gewünschten Typ.

    7. Klicken Sie auf "Aktualisieren".

So aktualisieren Sie ein Zeichenformat:

    1. Wählen Sie "Format > Zeichen > Gestaltung" und klicken Sie im Aufklappmenü "Zeichentyp" auf das zu ändernde Format.

    2. Ändern Sie die Einstellungen nach Bedarf. Bei vielen Zeichenformaten sind Einstellungen auf den Wert "Beibehalten" gesetzt. Ändern Sie diese Einstellungen nur, wenn sie im aktualisierten Format verwendet werden sollen.

    3. Klicken Sie auf "Alle aktualisieren".

Wenn die zu aktualisierenden Absätze irreguläre Formate aufweisen, werden Sie in einem Dialogfenster gefragt, ob diese Formate entfernt werden sollen.

So aktualisieren Sie bestimmte Einstellungen in Zeichenformaten:

    1. Um mehrere Formate zu aktualisieren, wählen Sie den Text mit den zu ändernden Zeichenformaten aus. Wenn Sie alle Zeichenformate oder nur ein Format ändern möchten, fahren Sie mit dem nächsten Schritt fort.

    2. Wählen Sie im Dialogfenster "Zeichengestaltung" aus dem Aufklappmenü "Befehle" den Eintrag "Alle Einstellungen auf 'Beibehalten'".

Wenn eine Einstellung den Wert "Beibehalten" hat, werden Textfelder leer, Markierungsfelder abgeblendet und Aufklappmenüs mit dem Eintrag "Beibehalten" angezeigt (siehe Verwenden von "Beibehalten").

    3. Ändern Sie nur die Einstellungen, die Sie aktualisieren möchten. (Bei der Aktualisierung der übrigen Formate werden Einstellungen mit dem Wert "Beibehalten" in FrameMaker nicht verändert.)

    4. Wählen Sie im Aufklappmenü "Befehle" den Eintrag "Optionen für globale Aktualisierung".

    5. Führen Sie eine der folgenden Aktionen aus:

    Um alle Zeichen im Dokument zu aktualisieren (einschließlich der Zeichen in Textzeilen, der Standardschrifteinstellungen aller Absatzformate und der Einstellungen aller Zeichenformate), klicken Sie auf "Alle Zeichen und Katalogeinträge".

    Um die ausgewählten Zeichen und alle Zeichen desselben Typs zu aktualisieren, klicken Sie auf "Alle entsprechenden Typen in Auswahl".

    Um Formate eines bestimmten Typs zu aktualisieren, wählen Sie aus dem Aufklappmenü einen Typ.

    6. Klicken Sie auf "Aktualisieren".

So aktualisieren Sie mehrere Formate gleichzeitig:

Importieren Sie mit dem Befehl "Datei > Importieren > Formate" Absatz- oder Zeichenformate aus einem anderen Dokument. Wenn Formate in beiden Dateien denselben Namen haben, wird das Format im Dokument von dem importierten Format überschrieben. Einzelheiten finden Sie unter Importieren und Aktualisieren von Formaten.


Grundlagen in FrameMaker / Textformatierung

Umbenennen und Löschen von Formaten

Beim Entwerfen einer Schablone müssen Sie ein Format möglicherweise umbenennen oder löschen. Sie müssen ein Format möglicherweise auch umbenennen, wenn Sie z. B. einen Katalog aus einer Schablone importieren möchten, ohne dass ein Format überschrieben wird.

Wenn Sie ein Format aus einem Katalog entfernen, wirkt sich dies nicht auf Absätze oder Zeichen aus, denen dieser Typ zuvor zugewiesen wurde. Die Absätze oder Zeichen haben in diesem Fall einfach ein Format, das nicht im Katalog enthalten ist. Wenn Sie das Format dieser Absätze oder Zeichen ändern möchten, weisen Sie ihnen einen anderen Typ zu (siehe Zuweisen von vordefinierten Formaten zu Text).

So benennen Sie ein Katalogformat um:

    1. Wählen Sie "Format > Absätze > Gestaltung" oder "Format > Zeichen > Gestaltung" und klicken Sie im Aufklappmenü "Absatztyp" bzw. "Zeichentyp" auf den gewünschten Eintrag.

Führen Sie diesen Schritt auch durch, wenn das Format bereits angezeigt wird. Sie stellen dadurch sicher, dass die Einstellungen keine irregulären Formate oder Beibehalten-Werte enthalten.

    2. Geben Sie in das Textfeld "Absatztyp" bzw. "Zeichentyp" einen neuen Namen ein und klicken Sie auf "Alle aktualisieren".

    3. Klicken Sie auf "OK".

So entfernen Sie ein Format aus einem Katalog:

    1. Öffnen Sie den Absatzformat-Katalog (klicken Sie in der rechten oberen Ecke des Dokumentfensters auf " [image] ") oder den Zeichenformat-Katalog (klicken Sie auf " [image] ").

    2. Klicken Sie auf "Löschen".

    3. Wählen Sie das gewünschte Format aus der Auswahlliste aus und klicken Sie auf "Löschen". Wiederholen Sie diese Schritte, um weitere Formate zu löschen.

    4. Klicken Sie auf "Fertig".

So entfernen Sie alle nicht verwendeten Formate aus einem Katalog:

    1. Öffnen Sie den Absatzformat-Katalog (klicken Sie in der rechten oberen Ecke des Dokumentfensters auf " [image] ") oder den Zeichenformat-Katalog (klicken Sie auf " [image] ").

    2. Klicken Sie auf "Löschen".

    3. Klicken Sie so oft auf "Löschen", bis alle Formate entfernt wurden, und wählen Sie anschließend "Zurück".

    4. Wählen Sie "Datei > Dienstprogramme > Formate anlegen und zuweisen" und klicken Sie auf "Fortfahren". Alle im Dokument verwendeten Absatz- und Zeichenformate werden dann wieder in den Katalog aufgenommen. Irreguläre Formate werden als neue, eigenständige Formate angezeigt. Weitere Informationen hierzu finden Sie unter Umwandeln von irregulären Formaten in neue Formate.

Hinweis: Damit nicht für jedes irreguläre Format in Ihrem Dokument Absätze erstellt werden müssen (z. B. könnten Sie 10 Haupttextabsätze erhalten), sollten Sie die Formate aus Ihrer Schablone importieren. Das Importieren von Formaten aus einer Schablone überschreibt alle Änderungen an Absatz- und Zeichentypen und es werden keine zusätzlichen Typen in Ihrem Dokument erstellt. Weitere Informationen zu diesem Thema finden Sie unter Importieren und Aktualisieren von Formaten


Grundlagen in FrameMaker / Textformatierung

Erstellen neuer Formate

Wenn Sie mit einer stabilen Schablone arbeiten, müssen Sie in der Regel kein neues Format erstellen. Wenn Sie jedoch eine neue Schablone entwerfen oder die verwendete Schablone unvollständig ist, müssen Sie möglicherweise neue Formate erstellen.

Die einfachste Möglichkeit, ein Format zu erstellen, besteht darin, die Einstellungen für ein bereits vorhandenes Format zu ändern. Um beispielsweise mehrere Überschriftsebenen zu erstellen, können Sie mit der ersten Ebene beginnen und anschließend beim Erstellen der weiteren Ebenen Schrift, Grad und Stil ändern.

Beachten Sie beim Benennen neuer Formate Folgendes:

    Verwenden Sie eine einheitliche Namenskonvention für ähnliche Arten von Absätzen und Textelementen in einem Absatz. Wenn Sie beispielsweise "Titel1" für Überschriften der ersten Ebene verwenden, sollten Sie den Überschriften der zweiten Ebene den Namen "Titel2" zuweisen.

    Formate, die Sie mit der Tastatur zuweisen (Strg+8 oder Strg+9), sollten Sie so benennen, dass die oft verwendeten Formate eindeutig sind oder zuerst in ihrer Buchstabengruppe erscheinen. Namen wie "H1 Titel2" oder "H2 Titel2" erleichtern einen schnellen Zugriff über die Tastatur.

    Geben Sie den Formaten einen Namen, der für Sie und andere Benutzer einfach zu merken, zu erkennen und einzugeben ist. Wenn Sie einen Typ nach seinem Verwendungszweck und nicht nach seiner Darstellung zuweisen (z. B. "Hervorhebung" anstelle von "Kursiv"), können Sie die Formateinstellungen ändern, ohne dass der Typ geändert werden muss.

    Achten Sie auf die Groß- und Kleinschreibung. Bei Formattypen wird zwischen Groß- und Kleinschreibung unterschieden. Haupttext ist nicht dasselbe wie haupttext. Miteinander in Beziehung stehende Typen sollten im Katalog untereinander angezeigt werden. Beispielsweise sollten "Haupt" und "HauptEinzug" untereinander angezeigt werden, "Haupt" und "EinzugHaupt" dagegen nicht.

    Wenn Sie sehr viele Formate definiert haben, können Sie umfangreiches Blättern in den Katalogen vermeiden, indem Sie den häufig verwendeten Formaten einen Punkt voranstellen, sodass diese im Katalog oben stehen. Dementsprechend können selten verwendete Formate an das Ende des Katalogs verschoben werden, indem ihnen ein z oder ein Tildezeichen (~) vorangestellt wird.

So erstellen Sie ein Absatzformat:

    1. Klicken Sie in einen Absatz mit einer ähnlichen Formatierung wie das zu erstellende Format. Achten Sie darauf, dass Sie nicht mehrere Absätze auswählen, damit keine Einstellungen auf "Beibehalten" gesetzt werden.

    2. Wählen Sie im Dialogfenster "Absatzgestaltung" aus dem Aufklappmenü "Befehle" den Eintrag "Neues Format" und geben Sie in das Textfeld "Typ" einen Namen für das neue Format ein.

    3. Damit Sie das neue Format aktualisieren oder mit dem Befehl "Datei > Importieren > Formate" in andere Dokumente kopieren können, müssen Sie die Option "In Katalog einfügen" aktivieren. Nicht in diesem Katalog gespeicherte Formate können nur durch Kopieren und Einfügen auf andere Absätze angewendet werden.

    4. Um das neue Format dem aktuellen Absatz zuzuweisen, wählen Sie "Der Auswahl zuweisen".

    5. Klicken Sie auf "Anlegen".

    6. Wenn Sie in Schritt 4 nicht die Option "Der Auswahl zuweisen" aktiviert haben, wählen Sie das neue Format aus dem Aufklappmenü "Absatztyp".

    7. Ändern Sie die gewünschten Einstellungen, z. B. Schrifteinstellungen, Einzug und Ausrichtung, Tabulatorstopps, Abstände, Zeilenumbruch und Trennung, Seitenumbruch, Grafiken in einem Absatzformat, Überschriften und automatische Nummerierung.

Setzen Sie keine der Einstellungen auf "Beibehalten". Bei Absatzformaten müssen für alle Einstellungen Werte festgelegt werden. Wenn nicht für jede Einstellung ein Wert angegeben ist, wird eine entsprechende Warnmeldung angezeigt. Ändern Sie dann alle auf "Beibehalten" gesetzten Einstellungen.

    8. Klicken Sie auf "Alle aktualisieren".

So erstellen Sie ein Zeichenformat:

    1. Wählen Sie im Dialogfenster "Zeichengestaltung" aus dem Aufklappmenü "Befehle" den Eintrag "Alle Einstellungen auf 'Beibehalten'". Einstellungen mit dem Wert "Beibehalten" werden nicht geändert, wenn Sie das Zeichenformat zuweisen. Wenn eine Einstellung den Wert "Beibehalten" hat, werden Textfelder leer, Markierungsfelder abgeblendet und Aufklappmenüs mit dem Eintrag "Beibehalten" angezeigt (siehe Verwenden von "Beibehalten").

    2. Ändern Sie nur die Einstellungen, die Sie in das Zeichenformat aufnehmen möchten. Informationen zum Ändern von Schrifteinstellungen finden Sie unter Ändern von Schrifteinstellungen.

    3. Wählen Sie aus dem Aufklappmenü "Befehle" den Eintrag "Neues Format" und geben Sie in das Textfeld "Typ" einen Namen für das neue Format ein.

    4. Aktivieren Sie die Option "In Katalog einfügen".

    5. Um das neue Format der aktuellen Auswahl zuzuweisen, aktivieren Sie die Option "Der Auswahl zuweisen".

    6. Klicken Sie auf "Anlegen".


Grundlagen in FrameMaker / Textformatierung

Formatieren von Text in strukturierten Dokumenten

Bei der Arbeit mit strukturierten Dokumenten können Sie Text hinzufügen, löschen, kopieren oder an eine andere Position verschieben und den Text auf jede beliebige Weise ändern. Sie können überarbeiteten Text auch durch Änderungsbalken kennzeichnen.

Wenn Sie Elementen Text hinzufügen, wird der Text automatisch formatiert. Sie müssen in der Regel in einem strukturierten Textfluss nicht mit Werkzeugen für die Textformatierung arbeiten.


Grundlagen in FrameMaker / Textformatierung / Formatieren von Text in strukturierten Dokumenten

Formatregeln und Katalogformate in strukturierten Dokumenten

Die Elementdefinitionen eines Dokuments enthalten in der Regel Formatregeln. Bei Elementen, die Text enthalten dürfen, können diese Regeln jeden Aspekt der Textformatierung beschreiben, einschließlich Schriftart, Schriftgröße und Schriftstil, Zeilenabstand und Einzüge, Absatzausrichtung sowie feinere Einstellungen wie Wortabstände und Silbentrennung.

Ein Dokument kann auch vordefinierte Katalogformate speichern, die als Absatzformate (für ganze Absätze) und Zeichenformate (für Textbereiche in Absätzen) bezeichnet werden. So wie die Elementdefinitionen stammen diese Formate aus einer Schablone. Die Formatregeln werden meist zusammen mit den Katalogformaten verwendet. Dies hängt davon ab, wie die Anwendung für Ihr Dokument eingerichtet wurde.

A: Formatiertes Überschriftelement B: Formatiertes Absatzelement

In den meisten Fällen arbeiten die Formatregel mit einigen wenigen Katalogformaten und geben Änderungen am Format je nach Bedarf an. Anhand der Regeln kann auch festgelegt sein, dass Elemente zumindest einige der Formatierungen von vorausgehenden Elementen übernehmen. Zum Beispiel könnte ein Absatzelement ein Katalogformat mit der Bezeichnung "Haupttext" verwenden. Die nachfolgenden Elemente des Absatzelements könnten "Haupttext" mit einigen Änderungen daraus übernehmen. Ein nachfolgendes Element "Betonung" könnte "Haupttext" mit zusätzlicher Kursivschrift verwenden.

Im Allgemeinen sollten Sie keine Formatänderungen an Text in einem Element vornehmen (beispielsweise eine andere Schrift anwenden), da Sie dabei möglicherweise einige Formatregeln überschreiben. Außerdem sollten Sie die Formate in Katalogen nicht verändern, insbesondere, wenn die Formatregeln in Ihrem Dokument weitergegeben werden. Die Änderung kann sich dann durch Elemente fortsetzen, die das Format übernehmen.

Ermöglichen Sie Elementen das Formatieren von Text in Dokumenten. Wenden Sie sich an Ihren Entwickler, wenn Sie die Formatierung ändern möchten.

In einem nicht strukturierten Dokument können Sie Text formatieren, indem Sie Katalogformate zuweisen oder Änderungen manuell vornehmen.


Grundlagen in FrameMaker / Textformatierung / Formatieren von Text in strukturierten Dokumenten

Kontextsensitive Formatregeln in strukturierten Dokumenten

Formatregeln sind manchmal kontextsensitiv und legen unterschiedliche Formatierungen fest, die von der jeweiligen Position oder einem Attributwert bestimmt werden. Ein Überschriftelement kann beispielsweise 14-Punkt-Text in nur Großbuchstaben enthalten, wenn es in einem Abschnitt erster Ebene erscheint, oder 12-Punkt-Text in einem Abschnitt zweiter Ebene.

A: Überschriftelement in einem Abschnitt der ersten Ebene
B: Überschriftelement in einem Abschnitt der zweiten Ebene

Objektelemente in einer Liste können mit Nummerierung angezeigt werden, wenn für das vorausgehende Listenelement der Attributtyp "Nummeriert" gewählt wurde, oder mit Auszeichnungspunkten, wenn der Typ "Auszeichnungspunkt" gewählt wurde.

Kontextsensitives Formatieren gliedert die Elemente in ein Bausteinsystem ein. Sie können denselben Elementtyp in verschiedene Ebenen der Dokumentenstruktur einfügen. Jeder Ebene wird die entsprechende Formatierung zugewiesen. Wenn Sie diese Elemente aus einer Ebene in eine andere verschieben, werden sie automatisch neu formatiert.


Grundlagen in FrameMaker / Textformatierung

Anzeigen der Elementhierarchie

Im Fenster "Elementkontext einblenden" können Sie die Hierarchie der Elemente in einem Dokument anzeigen. In diesem Fenster werden die ausgewählten Elemente und alle vorausgehenden Elemente bis hin zu den Stammelementen, sowie die Formatregeln aus dem Elementkatalog angezeigt, die den in der Hierarchie ausgewählten Elementen zugewiesen werden. Wenn das Dokument Teil eines strukturierten Buches ist bzw. war, fügt die Hierarchie Elemente über dem Stammelement des Dokuments bis hin zum Stammelement des Buches hinzu, selbst wenn das Buch gegenwärtig geöffnet ist. Verwenden Sie das Dialogfenster "Elementkontext einblenden", um den Satz der Formatierungsregeln anzuzeigen, die anstelle des Elements im aktuellen Kontext stehen. Wenn ein benanntes Zeichen- oder Absatzformat verwendet werden soll, können Sie das Gestaltungsfenster öffnen, um die Einzelheiten des benannten Formats zu überprüfen.

So öffnen Sie das Dialogfenster "Elementkontext einblenden":

    Wählen Sie "Strukturierungswerkzeuge > Elementkontext einblenden" aus.


Grundlagen in FrameMaker / Textformatierung

Entfernen von irregulären Formatregeln in strukturierten Dokumenten

Textformatierungsinformationen für ein Dokument können aus Formatregeln in Elementdefinitionen sowie aus vordefinierten Katalogformaten stammen.

Eine irreguläre Formatregel ist eine Änderung, die Sie an den Formatregeln eines Textelements vornehmen. Wenn Sie beispielsweise ein Absatzelement auswählen und die QuickAccess-Leiste verwenden, um den Text in Fettdruck darzustellen, überschreiben Sie unter Umständen die Formatregeln des Elements. Wenn Ihr Dokument über irreguläre Formatregeln verfügt, können Sie diese entfernen.

Wenn das aktuelle Element über eine irreguläre Formatregel verfügt, wird im Namensbereich der Statusleiste ein Sternchen neben dem Namen des Elements angezeigt.

Das Absatzelement hat eine irreguläre Formatregel.

So entfernen Sie irreguläre Formatregeln aus dem gesamten Dokument:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Datei > Importieren > Elementdefinitionen".

    3. Wählen Sie aus dem Aufklappmenü "Aus folgendem Dokument importieren" die Option "Aktuell".

    4. Aktivieren Sie die Option "Irreguläre Formatzuweisungen bei Aktualisierung entfernen" und klicken Sie auf "Importieren".

So entfernen Sie irreguläre Formatregeln in einem Element:

    1. Wählen Sie das Element in der Strukturansicht.

    2. Wählen Sie dasselbe Element im Elementkatalog aus und klicken Sie auf "Ändern". Hierdurch werden irreguläre Formate aus dem Element und all seinen nachfolgenden Elementen entfernt.

Um irreguläre Formatregeln schnell aus einem gesamten Dokument zu entfernen, entfernen Sie sie aus dem Element auf höchster Ebene.


Grundlagen in FrameMaker / Textformatierung / Entfernen von irregulären Formatregeln in strukturierten Dokumenten

Text mit Symbolschriften in strukturierten Dokumenten

FrameMaker entfernt keine irregulären Formatregeln, die ein gespeichertes Zeichenformat enthalten, das die Schrift "Symbol" oder "Zapf Dingbats" verwendet. Wenn sich z. B. in Ihrem Dokument Text mit dem Zeichenformat "MathBeispiel" befindet, das die Schriftart Symbol verwendet, bleibt diese Formatierung auch dann erhalten, wenn Sie irreguläre Formatregeln entfernen.

Damit wird verhindert, dass Sonderzeichen und Symbole verloren gehen. Um die irregulären Formate manuell zu entfernen, wählen Sie den Text aus, und wählen Sie "Format > Zeichen > Absatzstandardschrift".


Grundlagen in FrameMaker / Textformatierung / Entfernen von irregulären Formatregeln in strukturierten Dokumenten

Objektelemente in strukturierten Dokumenten

Elemente, die aus einem einzigen Objekt bestehen, z. B. Querverweise und Gleichungen, verfügen möglicherweise auch über Formatregeln. In diesen Fällen bieten die Regeln eine vorausgewählte Einstellung wie ein Querverweisformat oder eine Gleichungsgröße für neue Instanzen des Elements. Sie können diese Einstellung für ein Element ändern, aber die Änderung stellt keine irreguläre Formatregel dar. Ein erneutes Zuweisen der Formatregeln wirkt sich nicht auf diese Elemente aus.


Grundlagen in FrameMaker

Mehrstufige Befehle "Rückgängig" und "Wiederholen"

Die Funktion "Rückgängig" steht für eine größere Anzahl von Befehlen zur Verfügung und darüber hinaus können mehrere aufeinander folgende Vorgänge rückgängig und erneut rückgängig ("Wiederholen") gemacht werden.

Hinweis: Die Funktion "Rückgängig" wird für strukturierte Bücher nicht unterstützt.


Grundlagen in FrameMaker / Mehrstufige Befehle "Rückgängig" und "Wiederholen"

Befehle "Rückgängig" und "Wiederholen"

Auf der Symbolleiste wurde neben dem Symbol "Rückgängig" das Symbol "Wiederholen" eingefügt. Wenn Sie auf diese Schaltfläche klicken, wird die zuletzt rückgängig gemachte Aktion wiederholt:

Der Befehl "Wiederholen" steht auch im Menü "Bearbeiten" und in den Kontextmenüs unter dem Befehl "Rückgängig" zur Verfügung und zeigt dort den letzten Befehl im jeweiligen Dokument an, der wiederholt werden kann. Beispiel:

Wenn im aktuellen Dokument keine Aktion ausgeführt wurde, auf die der Befehl "Rückgängig" oder "Wiederholen" angewendet werden kann, werden die entsprechenden Menüelemente und Symbolleisten-Schaltflächen grau angezeigt.

Wurde im aktuellen Dokument hingegen mindestens eine Aktion ausgeführt, auf die der Befehl "Rückgängig" oder "Wiederholen" angewendet werden kann, wird unterhalb von "Wiederholen" das neue Element "Verlauf" aktiv. Dieses Element öffnet die Befehlspalette "Verlauf", in der Sie auch frühere Aktionen als die zuletzt durchgeführte sowie alle Folgeaktionen rückgängig machen und wiederholen können (siehe Befehlspalette "Verlauf").


Grundlagen in FrameMaker / Mehrstufige Befehle "Rückgängig" und "Wiederholen"

Befehlsverlauf auf Dokumentebene

FrameMaker verwaltet einen Verlauf von Befehlen, die rückgängig gemacht werden können, sodass Sie einen oder mehrere kürzlich durchgeführte Befehle rückgängig machen oder wiederholen können.

Auf den Befehlsverlauf können Sie über das Menü "Bearbeiten" und die Kontextmenüs zugreifen. Für jedes Dokument wird ein eigener Befehlsverlauf geführt, daher wirkt sich das Rückgängigmachen oder Wiederholen einer Aktion in einem Dokument nicht auf die entsprechende Funktion in anderen geöffneten Dokumenten aus.

Beim Speichern eines Dokuments (mit "Sichern", "Sichern unter" oder durch die automatische Dateisicherung) wird der Verlauf für die Befehle "Rückgängig" und "Wiederholen" dieses Dokuments gelöscht. Befehle, die sich nicht auf den Inhalt auswirken, beispielsweise das Kopieren von Text, können nicht rückgängig gemacht werden und beeinflussen den Befehlsverlauf nicht.

Cursorbewegungen und die Auswahl von Objekten können nicht rückgängig gemacht werden. Wenn jedoch ein früherer Zustand wiederhergestellt wird, wird dabei auch die ursprüngliche Cursorposition und Auswahl von Elementen wiederhergestellt.

Befehle, die externe Dateien einbeziehen (beispielsweise Befehle der Rechtschreibprüfung, die das Benutzerwörterbuch aktualisieren), können nicht rückgängig gemacht werden.

Eine vollständige Liste der Befehle, die rückgängig gemacht und wiederholt werden können, sowie der Befehle, die den Befehlsverlauf löschen, finden Sie unter Ausführbarkeit des Befehls "Rückgängig" für alle Befehle.


Grundlagen in FrameMaker / Mehrstufige Befehle "Rückgängig" und "Wiederholen" / Befehlsverlauf auf Dokumentebene

Befehlspalette "Verlauf"

In den Menüs "Bearbeiten > Rückgängig" und "Wiederholen" wird der zuletzt ausgeführte Befehl angezeigt. Über "Bearbeiten > Verlauf" oder den Tastaturbefehl Esc b Umschalttaste+v können Sie jedoch auf die neue Palette "Verlauf" zugreifen, die den vollständigen Befehlsverlauf enthält. In dieser Palette können Sie die gewünschte Aktion auswählen, die rückgängig gemacht oder wiederholt werden soll. Der Befehlsverlauf wird nur für das aktive Dokument angezeigt.

Der zuletzt ausgeführte Befehl wird in der Befehlspalette "Verlauf" hervorgehoben. Befehle, die oberhalb des zuletzt ausgeführten Befehls angezeigt werden, können rückgängig gemacht werden. Unterhalb des zuletzt ausgeführten Befehls aufgeführte Befehle können rückgängig gemacht werden. Sie sind mit einem Sternchen (*) gekennzeichnet.

Aktionen können nur in der Reihenfolge rückgängig gemacht und wiederholt werden, in der sie ursprünglich durchgeführt wurden. Wenn Sie einen Befehl rückgängig machen, werden alle nachfolgenden Befehle, die mit der ausgewählten Aktion zusammenhängen, ebenfalls rückgängig gemacht. Außerdem werden der ausgewählte Befehl und alle nachfolgenden Befehle in die Liste "Wiederholen" verschoben. Dementsprechend wird ein Befehl, der wiederholt wird, mit allen nachfolgenden Befehlen in die Liste "Rückgängig" verschoben.

Hier finden Sie ein Beispiel für einen Befehlsverlauf, in dem zuletzt der Befehl "Schrift ändern" ausgeführt wurde:

Verlauf "Rückgängig" | Verlauf "Wiederholen"
Schrift ändern Tabulator einfügen Einfügen Ausschneiden Eingabe |

Wenn Sie den Vorgang "Tabulator einfügen" rückgängig machen, wird dieser mit allen nachfolgenden Aktionen rückgängig gemacht und in die Liste "Wiederholen" verschoben:

Verlauf "Rückgängig" | Verlauf "Wiederholen"
Paste Ausschneiden Eingabe | Schrift ändern Tabulator einfügen

Eine neue Aktion, die das Dokument ändert, löscht den Befehlsverlauf für "Wiederholen":

Verlauf "Rückgängig" | Verlauf "Wiederholen"
Linie einfügen Einfügen Ausschneiden Eingabe |


Grundlagen in FrameMaker / Mehrstufige Befehle "Rückgängig" und "Wiederholen"

Ausführbarkeit des Befehls "Rückgängig" für alle Befehle

In der folgenden Tabelle werden Aktionen aufgeführt, die rückgängig gemacht und wiederholt werden können. Außerdem werden Vorgänge aufgeführt, die die Befehlsverläufe von "Rückgängig" und "Wiederholen" für ein Dokument bzw. alle Dokumente löschen.

Befehle, die rückgängig gemacht werden können

Die folgenden Befehle können rückgängig gemacht werden und werden in der Palette "Verlauf" angezeigt.

Die Befehle werden in der Tabelle mit dem Befehlsnamen und der Befehlsbezeichnung aus der Befehlskonfigurationsdatei aufgeführt (im Verzeichnis $FMHOME/fminit/configui). Außerdem wird die Zeichenfolge aufgeführt, die bei Ausführen des Befehls in der Befehlspalette "Verlauf" angezeigt wird.

Die Konfigurationsdateien haben die folgenden Bezeichnungen:

    (Windows) cmds.cfg, wincmds.cfg und mathcmds.cfg

    (UNIX) Commands, XCommands und MathCommands.

Befehl | Bezeichnung | Befehlspalette "Verlauf"
ParaPlacementBodyStraddle | Absatz verbindet Spalten | Absatz verbindet Spalten
ParaPlacementFullStraddle | Absatz verbindet Spalten u. seitl. Überschriften | Absatz verbindet Spalten u. seitl. Überschriften
ParaPlacementRunIn | Absatzpositionierung Zwischenüberschrift | Absatzpositionierung Zwischenüberschrift
ParaPlacementSidehead | Absatzpositionierung seitl. Überschrift | Absatzpositionierung seitl. Überschrift
ParaPlacementNormal | Absatzpositionierung Standard | Absatzpositionierung Standard
ViewBodyPages | Arbeitsseiten | Arbeitsseiten
ViewMasterPages | Vorgabeseiten | Vorgabeseiten
ViewReferencePages | Referenzseiten | Referenzseiten
Footnote | Footnote | Footnote
FootnoteProperties | Fußnoten... | Fußnoten...
LineLayout | Zeilenlayout | Zeilenlayout
ToggleSideheadsOnOff | Bereich für seitliche Überschrift ein-/ausschalten | Bereich für seitliche Überschrift ein-/ausschalten
RotatePage | Seite gegen Uhrzeigersinn drehen | Seite gegen Uhrzeigersinn drehen
RotatePageClockwise | Seite im Uhrzeigersinn drehen | Seite im Uhrzeigersinn drehen
RotatePageNormal | Drehung aufheben | Drehung aufheben
SplitTextFrame | Textrahmen teilen | Textrahmen teilen
CustomizeTextFrame | Spezieller Textrahmen | Spezieller Textrahmen
CutHead | Vorherigen abtrennen | Vorherigen abtrennen
CutTail | Nächsten abtrennen | Nächsten abtrennen
TableInsert | Tabelle einfügen | Tabelle einfügen
TableResizeColumns | Spaltenbreite ändern | Spaltenbreite ändern
TableRowFormat | Reihenformat | Reihenformat
TableStraddle | Verbinden | Verbinden
Unstraddle | Unstraddle | Unstraddle
TableConvert | Zu Absätzen konvertieren... | Zu Absätzen konvertieren
TableConvert | Zu Tabelle konvertieren... | Zu Tabelle konvertieren
TableAddRowsOrColumns | Reihen oder Spalten einfügen | Reihen oder Spalten einfügen
UnifyTableFormats | Tabellenformate vereinheitlichen | Tabellenformate vereinheitlichen
AddRowsAbove | Reihen oberhalb einfügen | Reihen oberhalb einfügen
AddRowsBelow | Reihen unterhalb einfügen | Reihen unterhalb einfügen
AddColumnsToLeft | Spalten links einfügen | Spalten links einfügen
AddColumnsToRight | Spalten rechts einfügen | Spalten rechts einfügen
ClearLeavingCellsEmpty | Zellinhalte löschen | Tabellenänderung
ClearRemovingCells | Zellen löschen | Tabellenänderung
TablePasteReplaceSelection | Auswahl ersetzen | Auswahl ersetzen
TablePasteBefore | Davor einsetzen | Davor einsetzen
TablePasteAfter | Danach einsetzen | Danach einsetzen
TableShrinkWrapColWidth | Spaltenbreite anpassen | Spaltenbreite anpassen
CharTabForTableCell | Tabulator für Zelle | Tabulator für Zelle
TBL_DESIGNKIT_APPLY |  | Tabellenänderung
TBL_DESIGNKIT_UPDATEOPTIONS |  | Tabellenänderung
TBL_DESIGNKIT_UPDATEALL |  | Tabellenänderung
TBL_DESIGNKIT_NEWFORMAT |  | Neues Tabellenformat
KBD_TBLFMT_DELETE |  | Tabellenformat löschen
InsertNewHypertext | Neuen Hypertext einfügen | Hypertext
CrossReference | Querverweis | CrossReference
InsertNewMarker | Marke einfügen | Marke
ConditionVisibility | Bedingten Text ein-/ausblenden | Bedingten Text ein-/ausblenden
ToggleCondUseFormatOverride | Irreguläre Bedingungsformate | Bedingungsformate ein-/ausblenden
QuickConditionalIn | Schnellaufruf Bedingt mit | Bedingter Text
QuickConditionalNotIn | Schnellaufruf Bedingt ohne | Bedingter Text
QuickConditionalUn | Schnellaufruf Nicht bedingt | Bedingter Text
ApplyConditionalText |  | Bedingter Text/Nicht bedingter Text
KBD_CONDEDIT |  | Bedingungstypänderung
CenterPara |  | Absatz/Objekte zentrieren
LeftPara |  | Absatz/Objekte links ausrichten
RightPara |  | Absatz/Objekte rechts ausrichten
FullyJustifyPara |  | Absatz/Objekte im Blocksatz
RepeatLastParaCommand |  | Letzten absatzbezogenen Befehl wiederholen
UnifyParas |  | Absätze vereinheitlichen
DecLineLeading1pt |  | Durchschuss um 1 pt verringern
IncLineLeading1pt |  | Durchschuss um 1 pt erhöhen
HyphenationOff |  | Trennung aus
HyphenationOn |  | Trennung ein
SingleSpaceParas |  | Einfacher Zeilenabstand
OneAndHalfSpaceParas |  | 1,5-facher Zeilenabstand
DoubleSpaceParas |  | Doppelter Zeilenabstand
SpaceBetweenParas |  | Abstand zwischen Absätzen...
CustomLineSpacingParas |  | Spezieller Zeilenabstand für Absätze...
ParaTopOfPage |  | Absatzbeginn am Seitenbeginn
ParaTopOfColumn |  | Absatzbeginn am Spaltenbeginn
ParaTopOfLeftPage |  | Absatzbeginn am Beginn einer linken Seite
ParaTopOfRightPage |  | Absatzbeginn am Beginn einer rechten Seite
ParaAnywhere |  | Absatzbeginn beliebig
SetLineSpaceFixed |  | Zeilenabstand fest
SetLineSpaceFloating |  | Zeilenabstand variabel
ParaNewFormat |  | Neues Absatzformat
ParaUpdateFormat |  | Absatzformat aktualisieren
<Andere Absatzgestaltung> |  | Absatzformat zuweisen
TabLeft |  | Linksbündiger Tabulator
TabCenter |  | Zentrierter Tabulator
TabRight |  | Rechtsbündiger Tabulator
TabDecimal |  | Dezimaltabulator
UpperCaseText | Ausgewählten Text ändern zu Versalien | Ausgewählten Text ändern zu Versalien
LowerCaseText | Ausgewählten Text ändern zu Kleinbuchstaben | Ausgewählten Text ändern zu Kleinbuchstaben
InitialCapsText | Ausgewählter Text mit großen Anfangsbuchstaben | Ausgewählter Text mit großen Anfangsbuchstaben
SetToLowerCase |  | Kleinbuchstaben
SetToInitialCap |  | Mit großen Anfangsbuchstaben
SetToUpperCase |  | Großbuchstaben
Groß-/Kleinschreibung |  | Groß-/Kleinschreibung
YankKillBuffer | Yank Kill Buffer | Paste
AlignTop | Oben ausrichten | Oben ausrichten
AlignMiddle | Vertikal zentrieren | Mitte
AlignBottom | Unten ausrichten | Unten ausrichten
ToggleGraphicsDisplay | Grafiken | Grafiken ein-/ausblenden
GraphicsFlipUpDown | Vertikal spiegeln | Vertikal spiegeln
GraphicsFlipLeftRight | Horizontal spiegeln | Horizontal spiegeln
RotateCounterclock90 | Um 90 Grad gegen Uhrzeigersinn drehen | Um 90 Grad gegen Uhrzeigersinn drehen
GraphicsScale | Skalieren | Skalieren
GraphicsSmooth | Glätten | Glätten
GraphicsUnsmooth | Glättung aufheben | Glättung aufheben
GraphicsReshape | Umformen | Umformen
GraphicsJoinCurves | Verbinden | Verbinden
GraphicsSetNumSides | Seitenanzahl | Seitenanzahl
GraphicsBringToFront | Nach vorne | Nach vorne
GraphicsSendToBack | Nach hinten | Nach hinten
GraphicsGroup | Gruppieren | Gruppieren
GraphicsUngroup | Gruppierung aufheben | Gruppierung aufheben
GraphicsAlign | Ausrichten | Ausrichten
GraphicsDistribute | Verteilen | Verteilen
RotateClockwise90 | Um 90 Grad im Uhrzeigersinn drehen | Um 90 Grad im Uhrzeigersinn drehen
GraphicsObjProps | Objekteinstellungen | Objekteinstellungen
RotateGfxClockwise |  | Im Uhrzeigersinn drehen
RotateGfxCounterClock |  | Gegen den Uhrzeigersinn drehen
GraphicsRotate | Drehen | Drehen
RotateAgain | Erneut drehen | Erneut drehen
RotateToNatural | Standard-Ausrichtung wiederherstellen | Standard-Ausrichtung wiederherstellen
RotateToPrevious | Drehung wiederherstellen | Drehung wiederherstellen
ResetNatural | Standard-Ausrichtung festlegen | Standard-Ausrichtung festlegen
SetThinLineWidth | Dünnste Linienstärke | Dünnste Linienstärke
SetThickLineWidth | Breiteste Linienstärke | Breiteste Linienstärke
IncrementLineWidth | Nächste Linienstärke | Nächste Linienstärke
DecrementLineWidth | Vorherige Linienstärke | Vorherige Linienstärke
SetFirstPenPattern | Erstes Linienmuster (schwarz) | Erstes Linienmuster (schwarz)
SetLastPenPattern | Letztes Linienmuster (keines) | Letztes Linienmuster (keines)
IncrementPenPattern | Nächstes Linienmuster | Nächstes Linienmuster
DecrementPenPattern | Vorheriges Linienmuster | Vorheriges Linienmuster
SetFirstFillPattern | Erstes Füllmuster (schwarz) | Erstes Füllmuster (schwarz)
SetLastFillPattern | Letztes Füllmuster (keines) | Letztes Füllmuster (keines)
IncrementFillPattern | Nächstes Füllmuster | Nächstes Füllmuster
DecrementFillPattern | Vorheriges Füllmuster | Vorheriges Füllmuster
SetPatternSolid | Muster durchgehend | Muster durchgehend
SetPatternDashed | Muster gestrichelt | Muster gestrichelt
SelectFirstDashedPattern | Erstes gestricheltes Muster | Erstes gestricheltes Muster
SelectLastDashedPattern | Letztes gestricheltes Muster | Letztes gestricheltes Muster
SelectPreviousDashedPattern | Vorheriges gestricheltes Muster | Vorheriges gestricheltes Muster
SelectNextDashedPattern | Nächstes gestricheltes Muster | Nächstes gestricheltes Muster
RunaroundProperties | Konturlaufeinstellungen | Konturlaufeinstellungen
RunAroundContour | Konturlauf | Konturlauf
RunAroundBoundingBox | Um Bildrahmen | Um Bildrahmen
RunaroundOff | Konturlauf deaktivieren | Konturlauf deaktivieren
DeleteBack1Char | Vorheriges Zeichen löschen | Text löschen
DeleteForw1Char | Nächstes Zeichen löschen | Text löschen
DeleteBackToPrevWordEnd | Bis zum vorhergehenden Wortende löschen | Bis zum vorhergehenden Wortende löschen
DeleteForwToNextWordStart | Bis zum nächsten Wortanfang löschen | Bis zum nächsten Wortanfang löschen
DeleteForwToEndOfLine | Zeile löschen | Zeile löschen
DeleteForwToNextSentenceEnd | Bis zum nächsten Satzende löschen | Bis zum nächsten Satzende löschen
DeleteBackToStartOfLine | Bis zum vorhergehenden Zeilenanfang löschen | Bis zum vorhergehenden Zeilenanfang löschen
Move1PtUp | Um 1 pt nach oben verschieben | Um 1 pt nach oben verschieben
Move1PtDown | Um 1 pt nach unten verschieben | Um 1 pt nach unten verschieben
Move1PtLeft | Um 1 pt nach links verschieben | Um 1 pt nach links verschieben
Move1PtRight | Um 1 pt nach rechts verschieben | Um 1 pt nach rechts verschieben
RemoveAllKerning | Unterschneidung entfernen | Unterschneidung entfernen
IncFontSize |  | Schriftgrad um 1 pt erhöhen
DecFontSize |  | Schriftgrad um 1 pt verringern
Move6PtUp | Um 6 pt nach oben verschieben | Um 6 pt nach oben verschieben
Move6PtDown | Um 6 pt nach unten verschieben | Um 6 pt nach unten verschieben
Move6PtLeft | Um 6 pt nach links verschieben | Um 6 pt nach links verschieben
Move6PtRight | Um 6 pt nach rechts verschieben | Um 6 pt nach rechts verschieben
DeleteBackToPrevWordStart | Bis zum vorhergehenden Wortanfang löschen | Bis zum vorhergehenden Wortanfang löschen
DeleteForwToNextWordEnd | Bis zum nächsten Wortende löschen | Bis zum nächsten Wortende löschen
DeleteForwToNextSentenceStart | Bis zum nächsten Satzanfang löschen | Bis zum nächsten Satzanfang löschen
DeleteBackToPrevSentenceEnd | Bis zum vorhergehenden Satzende löschen | Bis zum vorhergehenden Satzende löschen
Tabulator | Tabulator | Tabulator
CharShiftSpace | Leerzeichen | Eingabe
CharTabForTableCell | Tabulator für Zelle | Eingabe
TransposeChars | Zeichen vertauschen | Zeichen vertauschen
CharDiscretionaryHyphen | Wahlweiser Trennstrich | Wahlweiser Trennstrich
NoHyphenWord | Trennunterdrückungssymbol | Trennunterdrückungssymbol
StyleSmallCaps | Kapitälchen | Kapitälchen
StyleDoubleUnderline | Doppelt unterstreichen | Doppelt unterstreichen
CharacterNumericUnderline | Numerisch unterstreichen | Numerisch unterstreichen
SelBold |  | Fett
SelItalic |  | Kursiv
SelUnderline |  | Unterstreichen
SelPlain |  | Standard
PageBreak | PageBreak | PageBreak
CharQuickKey | Schnellaufruf Zeichenformat | Schnellaufruf Zeichenformat
CharacterNoStretch | Streckung auf 100% setzen | Streckung auf 100% setzen
CharacterLessStretch | Streckung um 5% pt verdichten | Streckung um 5% pt verdichten
CharacterMoreStretch | Streckung um 5% pt ausweiten | Streckung um 5% pt ausweiten
StyleBold | Fett | Fett
StyleItalic | Kursiv | Kursiv
StyleUnderline | Unterstreichen | Unterstreichen
StylePlain | Standard | Standard
StyleSuperscript | Hochstellen | Hochstellen
StyleSubscript | Tiefstellen | Tiefstellen
CharacterNormal | Standard-Zeichenformat | Standard-Zeichenformat
IncrementTextOnePt | Schriftgrad um 1 pt erhöhen | Schriftgrad um 1 pt erhöhen
DecrementTextOnePt | Schriftgrad um 1 pt verringern | Schriftgrad um 1 pt verringern
CharacterSqueezeSpace | Zeichenabstand um 20% eines Gevierts verringern | Zeichenabstand um 20% eines Gevierts verringern
CharacterSpreadSpace | Zeichenabstand um 20% eines Gevierts vergrößern | Zeichenabstand um 20% eines Gevierts vergrößern
CharacterRepeatLast | Letzten schriftbezogenen Befehl wiederholen | Letzten schriftbezogenen Befehl wiederholen
StyleStrikethrough | Durchstreichen | Durchstreichen
StyleOverline | Überstreichen | Überstreichen
StyleChangeBar | Änderungsbalken | Änderungsbalken
CharacterKerned | Unterschneiden | Unterschneiden
AnchoredFrame | Verankerter Rahmen | Verankerter Rahmen
ParaQuickKey | Schnellaufruf Absatzformat | Schnellaufruf Absatzformat
CharacterDefaultPgfFont |  | Absatzstandardschrift
ShowParagraphTags |  | Absatzformat aktualisieren
ShowCharacterTags |  | Zeichenformat aktualisieren:
<andere Zeichengestaltung> |  | Zeichenformat zuweisen Neues Zeichenformat
Variable | Variable | Variable
HeaderFooterInsertPageNum | Seitennummer einfügen | Seitennummer einfügen
HeaderFooterInsertPageCount | Seitenanzahl einfügen | Seitenanzahl einfügen
HeaderFooterInsertCurrentDate | Aktuelles Datum einfügen | Aktuelles Datum einfügen
HeaderFooterInsertOther | Sonstiges einfügen...> | Andere Variable einfügen
QuickVariables | Schnellaufruf Variable | Schnellaufruf Variable
ShowFontChoices |  | Schrift ändern
Size7 | 7 | Schriftgradänderung
Size9 | 9 | Schriftgradänderung
Size10 | 10 | Schriftgradänderung
Size12 | 12 | Schriftgradänderung
Size14 | 14 | Schriftgradänderung
Size18 | 18 | Schriftgradänderung
Size24 | 24 | Schriftgradänderung
SizeOther | 36 | Schriftgradänderung
SizeChoose | Sonstige... | Schriftgradänderung
ImportFile | Datei | Datei importieren
ImportObject | Objekt | Objekt importieren
ViewBordersOn | Begrenzungslinien einblenden | Begrenzungslinien einblenden
ViewTextSymbolsOn | Steuerzeichen einblenden | Steuerzeichen einblenden
ViewRulersOn | Lineale einblenden | Lineale einblenden
ViewGridLinesOn | Rasterlinien einblenden | Rasterlinien einblenden
ViewElementBoundariesOn | Elementgrenzen einblenden | Elementgrenzen einblenden
ViewElementTagsOn | Elementgrenzen (mit Tags) einblenden | Elementgrenzen (mit Tags) einblenden
ViewGraphicsOn | Grafiken einblenden | Grafiken einblenden
ViewBordersOff | Begrenzungslinien ausblenden | Begrenzungslinien ausblenden
ViewTextSymbolsOff | Steuerzeichen ausblenden | Steuerzeichen ausblenden
ViewGraphicsOff | Grafiken ausblenden | Grafiken ausblenden
ViewOptions | Optionen | Darstellungsoptionen
ViewBorders | Begrenzungslinien | Begrenzungslinien ein-/ausblenden
ViewTextSymbols | Steuerzeichen | Steuerzeichen ein-/ausblenden
ViewRulers | Lineale | Lineale ein-/ausblenden
ViewGridLines | Rasterlinien | Rasterlinien ein-/ausblenden
CharNonBreakHyphen | Umbruchgeschützter Trennstrich | Umbruchgeschützter Trennstrich
CharHardSpace | Umbruchgeschütztes Leerzeichen | Umbruchgeschütztes Leerzeichen
CharHardReturn | Zeilenende | Zeilenende
CharNumberSpace | Numerisches Leerzeichen | Numerisches Leerzeichen
CharThinSpace | t-Leerzeichen | t-Leerzeichen
CharEmSpace | m-Leerzeichen | m-Leerzeichen
CharEnSpace | n-Leerzeichen | n-Leerzeichen
Eingabetaste | Eingabetaste | Eingabe
Nudge1ptUp |  | Um 1 pt nach oben verschieben
Nudge1ptDown |  | Um 1 pt nach unten verschieben
Nudge1ptLeft |  | Um 1 pt nach links verschieben
Nudge1ptRight |  | Um 1 pt nach rechts verschieben
AlignGfxTop |  | Oben ausrichten
AlignGfxTBCenter |  | Vertikal zentrieren
AlignGfxBottom |  | Unten ausrichten
AlignGfxLRCenter |  | Horizontal zentrieren
AlignGfxLeft |  | Links ausrichten
AlignGfxRight |  | Rechts ausrichten
ChangeBars | Änderungsbalken | Änderungsbalken
TextOptions | Textoptionen | Textoptionen
SmartSingleQuote | Einfaches gebogenes Anführungszeichen | Eingabe
SmartDoubleQuote | Doppeltes gebogenes Anführungszeichen | Eingabe
ReplaceOnce | Ersetzen | Ersetzen
ReplaceAll | ReplaceAll | ReplaceAll
ReplaceAndFindAgain | Ändern und Suchen | Ändern und Suchen
Cut | Cut | Cut
Paste | Paste | Paste
Einfügen Spezial | Einfügen Spezial | Paste
Clear | Clear | Clear
ThesaurusReplace | Auswahl durch Thesaurus-Vorschlag ersetzen | Ersetzen
CorrectWord | Wort korrigieren | Wort korrigieren
CheckDocument | Dokument prüfen | Wort korrigieren
KBD_RUBIPROPS | Rubi-Einstellungen... | Rubi-Einstellungen
KBD_HIDE_RULERS | Lineale ausblenden | Lineale ausblenden
KBD_HIDE_GRID | Rasterlinien ausblenden | Rasterlinien ausblenden
KBD_HIDE_ELEM_BORDER | Elementgrenzen ausblenden | Elementgrenzen ausblenden
KBD_HIDE_COND_IND | Bedingungsformate ausblenden | Bedingungsformate ausblenden
KBD_ZOOMIN | <ReservedLabel Short Größer> <ReservedLabel Long Größer zoomen | Größer zoomen
KBD_ZOOMOUT | <ReservedLabel Short Kleiner> <ReservedLabel Long Kleiner zoomen> | Kleiner zoomen
KBD_ZOOM_FIT_PAGE | Seite an Fenster anpassen | Seite an Fenster anpassen
KBD_ZOOM100 | <ReservedLabel Short 100%> <ReservedLabel Long Zoomen auf 100%> | Zoomen auf 100 %
KBD_ELEM_BORDER | Elementgrenzen | Elementgrenzen ein-/ausblenden
KBD_BOOKADDFILE | <ReservedLabel Short Dateien...> <ReservedLabel Long Dateien in Buch einfügen...> | Datei(en) in Buch einfügen
KBD_BOOKDELETEFILE | <ReservedLabel LongMultiple Dateien aus dem Buch löschen> <ReservedLabel LongSingle Datei aus dem Buch löschen> <ReservedLabel Short Aus dem Buch löschen> | Datei(en) aus dem Buch löschen
KBD_PASTE | Paste | Paste
KBD_CLEAR | Löschen | Datei(en) aus dem Buch löschen
ELEM_INS_CAT_AT_SEL ELEM_INSERT_CUSTOM_1 ELEM_INSERT_CUSTOM_2 ELEM_INSERT_CUSTOM_3 ELEM_INSERT_CUSTOM_4 ELEM_INSERT_CUSTOM_5 ELEM_INSERT_CUSTOM_6 ELEM_INSERT_CUSTOM_7 ELEM_INSERT_CUSTOM_8 ELEM_INSERT_CUSTOM_9 ELEM_INSERT_CUSTOM_10 |  | Element einfügen
KBD_INSERTQUICK | Element einfügen | Element einfügen
ELEM_WRAP_CAT_AT_SEL |  | Element eingliedern
KBD_WRAPQUICK | Element eingliedern | Element eingliedern
ELEM_CHANGE_CAT_AT_SEL |  | Element ändern
KBD_CHANGEQUICK | Element ändern | Element ändern
KBD_ATTREDITQUICK | Attribut-Schnellbearbeitung | Elementattribute ändern
KBD_ELEM_MERGE_1ST | Zusammenfügen | Element(e) als Erstes zusammenfügen
KBD_ELEM_MERGE_LAST | Als Letztes zusammenfügen | Element(e) als Letztes zusammenfügen
KBD_ELEM_SPLIT | Teilen | Element teilen
KBD_ELEM_UNWRAP | Ausgliedern | Element ausgliedern
ELEM_BAM | Letzten elementbezogenen Befehl wiederholen | Letzten elementbezogenen Befehl wiederholen
KBD_ELEM_TAGS | Elementgrenzen (mit Tags) | Elementgrenzen (mit Tags) einblenden
KBD_TOGGLE_COLLAPSE | Elementausblendung umschalten | Elementausblendung umschalten
KBD_TOGGLE_COLLAPSE_ALL | Ausblendung von Element und Gleichrangigen umschalten | Ausblendung von Element (und Gleichrangigen) umschalten
KBD_ELEM_TRANSPOSE_NEXT | Mit vorherigem vertauschen | Mit vorherigem Element vertauschen
KBD_ELEM_TRANSPOSE_PREV | Mit nächstem vertauschen | Mit nächstem Element vertauschen
KBD_ELEM_PROMOTE | Element hochstufen | Element hochstufen
KBD_ELEM_DEMOTE | Element herabstufen | Element herabstufen
KBD_SMEQN | Kleine Gleichung | Neue Gleichung (klein)
KBD_MEDEQN | Mittlere Gleichung | Neue Gleichung (mittel)
KBD_LGEQN | Große Gleichung | Neue Gleichung (groß)
KBD_PUTINLINE | Gleichung einpassen | Gleichung einpassen
KBD_ANTIPUTINLINE | Gleichung freilegen | Auf Spaltenbreite vergrößern
KBD_EQUATION | Gleichungsgrößen... | Eigenschaften der Gleichungsgröße
KBD_MATH_FONTS | Gleichungsschriften... | Gleichungsschriften ändern
KBD_MATH_UPDATE_ELEM | Definition aktualisieren | Definition aktualisieren
KBD_MATH_NEW_ELEM | Definition in Katalog aufnehmen | Definition aufnehmen
MathAlignSetManual | Manuelle Ausrichtung | Manuelle Ausrichtung
MathAlignClearManual | Manuelle Ausrichtung löschen | Manuelle Ausrichtung löschen
MathSetManualLineBreak | Manuelle Zeilenumbrüche | Manuelle Zeilenumbrüche
MathClearManualLineBreaks | Manuelle Zeilenumbrüche löschen | Manuelle Zeilenumbrüche löschen
MathAddFractions | Brüche addieren | Brüche addieren
MathOrderinSum | Geordnete Summe | Geordnete Summe
MathOrderinSumotherway | Umgekehrt geordnete Summe | Umgekehrt geordnete Summe
MathFactor | Ausklammern | Ausklammern
MathFactorSome | Teilweise ausklammern | Teilweise ausklammern
MathMultiplyOut | Ausmultiplizieren | Ausmultiplizieren
MathMultiplyOutOnce | Einmal ausmultiplizieren | Einmal ausmultiplizieren
MathDistribute | Verteilen | Verteilen
MathDistributeOver | Auf beiden Seiten anwenden | Auf beiden Seiten anwenden
MathLongDivision | Division mit Rest | Division mit Rest
MathRemoveDivision | Division umwandeln | Division umwandeln
MathRemoveDivisionOnce | Division Stufe 1 umwandeln | Division Stufe 1 umwandeln
MathRemoveNegPowers | Negative Potenz umwandeln | Negative Potenz umwandeln
MathRemoveNegPowersOnce | Negative Potenz Stufe 1 umwandeln | Negative Potenz Stufe 1 umwandeln
MathNumberCrunch | Ausrechnen | Ausrechnen
MathShowAllDigits | Alle Stellen zeigen | Alle Stellen zeigen
MathEvaluate | Berechnen | Berechnen
MathEvalSubstitutions | Einsetzen | Einsetzen
MathIntegrate | Integrieren | Integrieren
MathDifferentiate | Ableiten | Ableiten
MathDifferentiateOnce | 1. Stufe ableiten | 1. Stufe ableiten
MathEnterDefinition | Regel eingeben | Regel eingeben
MathApplyDefinition | Regel anwenden | Regel anwenden
MathDesignateDummy | Platzhalter festlegen | Platzhalter festlegen
MathSimplify | Vereinfachen | Vereinfachen
MathSimplifySome | Teilweise vereinfachen | Teilweise vereinfachen
MathIsolateTerm | Term isolieren | Term isolieren
MathPulloutoneterm | 1. Term herausziehen | 1. Term herausziehen
MathPullOutAllTerms | Alle Terme herausziehen | Alle Terme herausziehen
MathCreate1x1matrix | 1 x 1 Matrix erstellen | 1 x 1 Matrix erstellen
MathTransposeMatrix | Matrix transponieren | Matrix transponieren
MathMatrixAlgebra | Matrix-Algebra | Matrix-Algebra
MathAlignMatrixRowToggle | Gleichmäßig/Proportional | Ausrichtung Matrixzeile umschalten
MathAlignMatrixColToggle | Gleichmäßig/Proportional | Ausrichtung Matrixspalte umschalten
BookSetupFile | Einstellungen für generierte Datei | Einstellungen für generierte Datei
TableOfContents | Inhaltsverzeichnis | Inhaltsverzeichnis
ListOfFigures | Abbildungsverzeichnis | Abbildungsverzeichnis
ListOfTables | Tabellenverzeichnis | Tabellenverzeichnis
ListOfParagraphs | Absatzliste | Absatzliste
ListOfParagraphsAlphabetical | Absatzliste (alphabetisch) | Absatzliste (alphabetisch)
ListOfMarkers | Markenliste | Markenliste
ListOfMarkersAlphabetical | Markenliste (alphabetisch) | Markenliste (alphabetisch)
ListOfReferences | Referenzliste | Referenzliste
StandardIndex | Standardindex | Standardindex
IndexOfAuthors | Autorenindex | Autorenindex
IndexOfSubjects | Themenindex | Themenindex
IndexOfMarkers | Markenindex | Markenindex
IndexOfReferences | Referenzindex | Referenzindex
ShowImportFiles | -- | Datei importieren
Accept TrackText Edit | Änderung annehmen | Änderung annehmen
Reject TrackText Edit | Änderung ablehnen | Änderung ablehnen
Accept All TrackTextEdit | Alle Änderungen annehmen | Alle Änderungen annehmen
Reject All TrackTextEdit | Alle Änderungen ablehnen | Alle Änderungen ablehnen

Befehle, die den Befehlsverlauf löschen

Die folgenden Befehle löschen den Verlauf für die Befehle "Rückgängig" und "Wiederholen", d. h. sämtliche Einträge in der Befehlspalette "Verlauf" werden entfernt.

Die Befehle werden in der Tabelle mit dem Befehlsnamen und der Befehlsbezeichnung aus der Befehlskonfigurationsdatei aufgeführt (im Verzeichnis $FMHOME/fminit/configui).

Die Konfigurationsdateien haben die folgenden Bezeichnungen:

    (Windows) cmds.cfg, wincmds.cfg und mathcmds.cfg

    (UNIX) Commands, XCommands und MathCommands.


Unicode-Unterstützung

Unicode-Unterstützung

FrameMaker-Funktionen mit Unterstützung für Unicode-Inhalte

Einrichten des Computers und der Tastatur für das Arbeiten mit verschiedenen Sprachen


Unicode-Unterstützung

Adobe FrameMaker unterstützt den Unicode-Standard zur Textcodierung. Sie können Inhalt in verschiedenen Sprachen sowie mehrsprachige Dokumente erstellen. Wenn Sie Inhalt in einer anderen Sprache als Englisch erstellen möchten, müssen Sie wie folgt vorgehen:

    1. Starten Sie den Computer mit UTF-8-Gebietsschema.

    2. Um Wörterbücher zu aktivieren oder den Thesaurus zu öffnen, wählen Sie die gewünschte Sprache aus der Eingabegebietsschema-Leiste (IME).

    3. Beginnen Sie mit der Eingabe des Inhalts in der ausgewählten Sprache.

Bestimmte Funktionen, beispielsweise die Such- und Ersetzfunktion, Marken, Hypertext oder Katalogeinträge, unterstützen Unicode. Sie können Dokumente mit Unicode-Lesezeichen, -Tags, -Kommentaren usw. im PDF-Format exportieren. Außerdem haben Sie die Möglichkeit, Unicode-Inhalte aus anderen Anwendungen zu importieren oder in diese zu exportieren. Es gibt zusätzliche Wörterbücher, die Sie beim Erstellen von Inhalten in mehreren Sprachen unterstützen.


Unicode-Unterstützung / Unicode-Unterstützung

Unicode-Unterstützung unter Solaris

Das Solaris®-Betriebssystem trennt sprach- und kulturspezifische Informationen vom Anwendungscode mithilfe von Gebietsschemata. Unter einem Gebietsschema versteht man die sprachlichen und kulturellen Daten, die vom Benutzer festgelegt und während der Laufzeit dynamisch in den Speicher geladen werden. Diese Gebietsschemaeinstellungen gelten für alle Anwendungen, die im Betriebssystem gestartet werden. Um die Tatsache, dass Unicode unterstützt wird, voll auszunutzen, sollten Sie sicher stellen, dass Sie sich bei Sitzungen mit dem UTF-8-Gebietsschema anmelden und FrameMaker im selben Gebietsschema öffnen.

Hinweis: Unter Solaris müssen Sie Zugriff auf die Schriften haben, die die im Unicode-codierten Text enthaltenen Zeichen beinhalten, damit der Text korrekt angezeigt wird.

Solaris-Versionen und unterstützte Gebietsschemata

Die UTF-8-Unterstützung für die interne Textcodierung wird ab Solaris 2.8 unterstützt.

Unter Solaris können Sie die folgenden UTF-8-Gebietsschemata verwenden:

    en_US.UTF-8 (US-Englisch)

    fr_FR.UTF-8 (Französisch)

    de_DE.UTF-8 (Deutsch)

    it_IT.UTF-8 (Italienisch)

    ko_KR.UTF-8 (Koreanisch)

    zh_CN.UTF-8 (Vereinfachtes Chinesisch)

    zh_TW.UTF-8 (Traditionelles Chinesisch)

Solaris unterstützt die folgenden Sprachen- und Code-Zuordnungen:

    Kyrillisch - cc

    Griechisch - gg

    Unicode-Hex - uh

    Unicode-Octal - uo

    Lookup - ll

    Japanisch - ja

    Koreanisch - ko

    Vereinfachtes Chinesisch - sc

    Traditionelles Chinesisch - tc

    Englisch/Europa - Control + Leertaste

Hinweis: FrameMaker unterstützt keine gebietsschemaspezifische Funktionen wie Datums- und Zeitformate für unterschiedliche Gebietsschemata. Sie können keine Unicode-Zeichen in nicht über Unicode festgelegten Gebietsschemata eingeben.


Unicode-Unterstützung

FrameMaker-Funktionen mit Unterstützung für Unicode-Inhalte

Die Unterstützung für mit Unicode codierte Inhalte in FrameMaker gibt Ihnen die Möglichkeit, folgende Aufgaben auszuführen:

    Erstellen, Öffnen und Bearbeiten von FM- und MIF-Dateien mit Unicode-Inhalten

    Erstellen von XML-Dateien, die Unicode-Inhalte enthalten, indem diese in die UTF-8-Codierung konvertiert werden

      a. Arbeiten mit Dokumenten, die Unicode-Inhalte enthalten

    Erstellen von Dokumenten, die Absätze und Wörter in mehreren Sprachen enthalten. Sie können z. B. eine Reihe von griechischen Buchstaben gefolgt von russischen Buchstaben, und dann von französischem Text in ein und demselben Absatz haben. Die volle Unterstützung für die Erstellung von Dokumenten (ohne Wörterbücher und Bindestriche) dehnt sich auch auf Koreanisch, Japanisch, Traditionelles Chinesisch und Vereinfachtes Chinesisch aus. Darüber hinaus gilt die volle Unterstützung (einschließlich Sprachregeln, Wörterbuch und Bindestrichen) für US-Englisch, Französisch, Deutsch, Deutsch (Schweiz), Französisch (Kanada) und Englisch (Großbritannien).

    Speichern von Unicode-Inhalten in den Formaten PDF, HTML und XML

    Importieren von Textdateien, die die Codierungen UTF8, UTF16, UTF16 BE, UTF16 LE, UTF32, UTF32 BE und UTF32 LE enthalten

    Exportieren von Textdateien mit den Unicode-Codierungen UTF8, UTF16, UTF16 BE, UTF16 LE, UTF32, UTF32 BE und UTF32 LE

    Konvertieren und Importieren von nicht dem Unicode-Standard entsprechenden Codierungen, wie etwa FrameRoman, JISX0208.ShiftJIS, BIG5, GB2312-80.EUC und KSC5601-1992, die in früheren Versionen von FrameMaker unterstützt wurden.

    Verwenden der Rechtschreibhilfe der entsprechenden Sprache zum Prüfen von Unicode-Inhalten

    Verwenden von Wörterbuch und Thesaurus der entsprechenden Sprache für Unicode-Inhalte Standardmäßig werden Wörterbücher für alle in FrameMaker unterstützen Sprachen installiert. Die Wörterbuch- und Silbentrennungsunterstützung wird auf die folgenden Sprachen erweitert: Spanisch, Italienisch, Portugiesisch, Dänisch, Niederländisch, Schwedisch, Norwegisch, Nynorsk, Finnisch, Katalanisch, Griechisch, Russisch, Tschechisch, Polnisch, Ungarisch, Türkisch, Slowakisch, Slowenisch, Bulgarisch, Kroatisch, Estnisch, Lettisch, Litauisch und Rumänisch. Alle Sprachwörterbücher wurden auf die Verwendung von Proximity Version 11.0 aktualisiert. Die Funktionen Wörterbuch, Bindestriche und Thesaurus wurden so erweitert, dass auch Unicode-Zeichen verarbeiten können.

    Bereitstellen und Anzeigen von Unicode-codierten Eingabemöglichkeiten in Feldern, Dialogfenstern, Assistenten und Formularen

    Durchführen von Dokumentvergleichen für Unicode-Inhalte

    Generieren von Konvertierungstabellen, Listen, Inhaltsverzeichnissen, Indizes und Statistiken mit Unicode-Inhalten

    Erstellen von Schablonen für unterschiedliche Sprachen auf Grundlage von Unicode-Inhalten

    Verwenden von Unicode-Zeichen in Namen für Vorlageseiten, Paragraphen- und Zeichen- und Absatztypen, Tabellentypen, Variablen und Variablennamen, benutzerdefinierte Namen für Menüelemente, Namen für Farbdefinitionen, mathematische Gleichungen, Dateipfade, Hypertext, Fußnoten, Querverweise, benutzerdefinierte automatische Nummerierung, FrameVector, Datei-Informationen, Typen von bedingtem Text, Objektattribute, Elementnamen und Attributnamen

    Roundtripping für in UTF-8 codierte Unicode-Inhalte: Für Unicode-Inhalte in UTF-8-Codierung wird das Roundtripping korrekt ausgeführt, wenn Sie ein FrameMaker-Dokuument in den Formaten XML, HTML, MIF oder FM speichern. In FrameMaker 8 können Sie Dokumente im FrameMaker 8 (Unicode)- oder im FrameMaker 7.0-Format speichern. Dateien mit Unicode-Zeichen müssen im FrameMaker 8.0 (Frame Binary)- oder MIF 8 (MIF-Unicode)-Format gespeichert werden. Wenn Sie ein FrameMaker-Dokument im XML-Format speichern, wird der Codierungsstandard UTF-8 verwendet.

    Erstellen von MIF-Dateien: Sie können MIF-Dokumente in den Formaten MIF 8 (MIF-Unicode) und MIF 7 (MIF-Classic) speichern. Mit dem MIF-Unicode-Format wird eine Datei generiert, bei der alle Unicode-Inhalte beibehalten werden. Mit dem MIF-Classic-Format wird eine Datei generiert, die sowohl mit früheren FrameMaker-Versionen kompatibel als auch aufwärtskompatibel ist. Alle Unicode-Inhalte, die nicht im älteren Format dargestellt werden können, werden durch Zeichen ersetzt, die der Benutzer in der Konfigurationsdatei (maker.ini unter Windows) konfigurieren kann.

    Eingabe von Sonderzeichen: Unter UNIX wird links vom Dokumentfenster ein Dialogfenster zur Auswahl eines Sprach- oder UTF-Bereichs angezeigt. Sie können in diesem Fenster unterschiedliche Bereiche, beispielsweise mathematische Zeichen oder Währungssymbole, auswählen und sie direkt mit Unicode-Inhalten in FrameMaker-Dokumente eingeben. Diese Funktion ist unter Windows nicht verfügbar.

    Verwenden von Tastaturbefehlen für Zeichen ausschließlich in der Gleichungspalette

    FrameMaker unterstützt weiterhin die automatische Erkennung der verwendeten Sprache durch die Rechtschreibprüfung, und zwar für viele weitere Sprachen: Wenn Sie die Rechtschreibprüfung ausführen, verwendet FrameMaker das Wörterbuch der in der Absatzgestaltung für den jeweiligen Absatz ausgewählten Sprache. Wenn beispielsweise die mit dem Haupttextabsatztyp verbundene Sprache Bulgarisch ist, verwendet FrameMaker das bulgarische Wörterbuch, um die Rechtschreibung allen Textes, auf den der Typ "Haupttext" angewendet wurde, zu prüfen. Wenn andererseits die mit dem Code-Absatztyp verbundene Sprache US-Englisch ist, verwendet FrameMaker das US-englische Wörterbuch, um die Rechtschreibung allen Textes, auf den der Typ "Code" angewendet wurde, zu prüfen.

    Verwenden der Funktion "Suchen/Ändern" für Unicode-Inhalte: Da FrameMaker den Codierungsstandard UTF-8 verwemdet, besteht jedes Zeichen aus mehr als einem Byte. Mit der Funktion "Suchen/Ändern" können Sie nach einem Bereich von Unicode-Zeichen suchen, die alle zum Unicode-Zeichensatz BMP (Basic Multilingual Plane) gehören. Sie können verschiedene Unicode-Zeichen, eine Kombination aus Text und Unicode-Zeichen oder eine Kombination aus Zeichen in verschiedenen Sprachen suchen. Bei der Suche mit Hexcode (\x) müssen UTF-8-Werte angegeben werden. Sie können bei der Suche nach Unicode-Zeichen Jokerzeichen verwenden.

    Verwenden von Codepunkten des Unicode-Codesatzes in den Dialogfenstern

    Sortieren von Tabellen, in denen Unicode-Inhalte enthalten sind: FrameMaker sortiert Zeichenfolgen in Tabellen auf der Grundlage des Gebietsschemas des Computers, auf dem FrameMaker installiert ist. Sie müssen das Gebietsschema Ihres Computers ändern, um die für das gewünschte Gebietsschema geltende Sortiermethode anwenden zu können.

    Sortieren von Indizes mit Symbolen in mehrsprachigen FrameMaker-Dokumenten auf der Basis des Unicode-Sortierfolgenalgorithmus (Unicode Collation Algorithm – UCA) des Unicode-Standard zur Textcodierung

    Kopieren von Inhalten aus anderen Unicode-kompatiblen Anwendungen: FrameMaker unterstützt das Kopieren und Einfügen von Inhalten zwischen FrameMaker-Dokumenten und von bzw. in anderen Unicode-kompatiblen Anwendungen, wie etwa Microsoft Word. Unter Windows wird beim Kopieren und Einfügen davon ausgegangen, dass der Text in der Zwischenlage im UTF-16-Format vorliegt. Wenn Sie beispielsweise einen "Einfügen Spezial"-Vorgang verwenden, fügt die Option "Unicode-Text" den Inhalt als Unicode-Text ein. Auf der Solaris-Plattform wird diese Funktion durch die Gebietsschema-Einstellung eingeschränkt. Damit Unicode-Inhalte kopiert werden können, muss auf dem System das UTF-8-Gebietsschema festgelegt sein. Da die Funktion "Einfügen Spezial" unter Solaris nicht verfügbar ist, verwenden Sie den Befehl "Einfügen" um den kopierten Text in Unicode-Text umzuwandeln.

    Automatisches Aktualisieren von Datum, Uhrzeit, Währung und numerischen Formaten in sprachbasierten Variablen. Wenn Sie die Sprache eines Absatzes mit Variablen ändern, ändern sich auch die Formate für Datum, Uhrzeit, Währung und Zahlen.


Unicode-Unterstützung / Einrichten des Computers und der Tastatur für das Arbeiten mit verschiedenen Sprachen

Auswählen von Schriften für das Arbeiten mit mehrsprachigen Dokumenten

Um in einem Dokument Zeichen in der ausgewählten Sprache einzugeben, müssen Sie sprachspezifische Schriften auswählen.

Hinweis: Die Schriften MinionPro und MyriadPro wurden aktualisiert und enthalten neue Sprachbereiche.


Unicode-Unterstützung / Einrichten des Computers und der Tastatur für das Arbeiten mit verschiedenen Sprachen

Anzeigen und Bearbeiten von mehrsprachigen FrameMaker-Dokumenten

Vor der Eingabe und Anzeige von mehrsprachigem Text in Ihr Dokument müssen Sie die Sprach- oder Gebietsschema-Einstellungen auf Ihrem Computer so konfigurieren, dass die erforderlichen Sprachen für die Tastatureingabe hinzugefügt werden.

    Windows: Die Betriebssysteme Microsoft Windows XP Service Pack 2 (SP2) und Microsoft Windows 2000 und Windows Vista haben Länder- und Spracheinstellungen, über die zusätzliche Sprachen für die Tastatureingabe hinzugefügt werden können. Diese Sprachen- und Sprachausgabe-Einstellungen werden in der Eingabegebietsschema-Leiste auf dem Desktop angezeigt. Wenn Sie eine Sprache ausgewählt und eine lokalisierte Tastatur eingerichtet haben, können Sie den gewünschten Text in das Dokument eingeben. Die Tastaturlayouts werden von Microsoft festgelegt.

    Solaris: Das Solaris-Betriebssystem bietet Gebietsschema-Einstellungen mit und ohne UTF. FrameMaker berücksichtigt das festgelegte Standardgebietsschema. Wenn Sie jedoch unter Solaris Unicode-Zeichen verwenden wollen, müssen Sie ein UTF-8-Gebietsschema und eine Bildschirmtastatur auswählen. Wird FrameMaker beispielsweise auf einem System mit türkischem UTF-8-Gebietsschema ausgeführt, können Sie Unicode-Zeichen in FrameMaker-Dokumente eingeben.

Sie können in der ausgewählten Sprache Wörter eingeben oder die jeweils entsprechenden Unicode-Zeichen eingeben.


Unicode-Unterstützung / Einrichten des Computers und der Tastatur für das Arbeiten mit verschiedenen Sprachen / Anzeigen und Bearbeiten von mehrsprachigen FrameMaker-Dokumenten

Einrichten der Eingabesprachen unter Windows

    1. Öffnen Sie die Systemsteuerung Ihres Computers und doppelklicken Sie auf das Symbol "Regions- und Sprachoptionen". Das Dialogfenster "Regions- und Sprachoptionen" wird angezeigt.

    2. Klicken Sie auf die Registerkarte "Sprachen".

    3. Klicken Sie auf die Schaltfläche "Details". Das Dialogfenster "Textdienste und Eingabesprachen" wird angezeigt.

    4. Klicken Sie auf der Registerkarte "Einstellungen" auf "Hinzufügen". Das Dialogfenster "Eingabegebietsschema hinzufügen" wird angezeigt.

    5. Wählen Sie in der Liste "Eingabegebietsschema" eine Sprache aus.

    6. Klicken Sie auf "OK". Die ausgewählte Sprache wird in die Liste der installierten Dienste aufgenommen.

    7. Wählen Sie die in der Liste "Standard-Eingabegebietsschema" die gewünschte Sprache aus.

    8. Klicken Sie auf die Schaltfläche zum Übernehmen der Änderungen und anschließend auf "OK", um die Einstellungen zu speichern und das Dialogfenster "Textdienste und Eingabesprachen" zu schließen.

    9. Klicken Sie auf die Registerkarte "Ländereinstellungen" und wählen Sie dann die unter "Standard-Eingabegebietsschema" ausgewählte Sprache aus.

    10. Klicken Sie auf die Schaltfläche zum Übernehmen der Änderungen und anschließend auf "OK", um die Einstellungen zu speichern und das Dialogfenster zu schließen. Die Eingabegebietsschema-Leiste oder der Eingabemethoden-Editor (IME) wird in der Taskleiste Ihres Computers angezeigt.

    11. Öffnen Sie FrameMaker und geben Sie die gewünschten Inhalte ein. Der Text wird in der ausgewählten Sprache angezeigt.

Hinweis: Wenn Sie die Sprache in der Liste "Standard-Eingabegebietsschema" und in der Registerkarte "Ländereinstellungen" ändern, wird die in der Eingabegebietsschema-Leiste ausgewählte Sprache automatisch auf die neue Sprache aktualisiert.


Unicode-Unterstützung / Einrichten des Computers und der Tastatur für das Arbeiten mit verschiedenen Sprachen / Anzeigen und Bearbeiten von mehrsprachigen FrameMaker-Dokumenten

Aufrufen der Bildschirmtastatur unter Windows

    1. Wählen Sie im Startmenü "Programme > Zubehör > Eingabehilfen > Bildschirmtastatur" aus.

    2. Klicken Sie auf "OK". Nun können Sie mit der Verwendung der Bildschirmtastatur beginnen.


Unicode-Unterstützung / Einrichten des Computers und der Tastatur für das Arbeiten mit verschiedenen Sprachen / Anzeigen und Bearbeiten von mehrsprachigen FrameMaker-Dokumenten

Verwenden von Tastaturlayout-Software von Drittanbietern unter Windows

Es gibt mehrere Tastaturlayout-Softwareanwendungen für unterschiedliche Sprachen auf Windows-Systemen. Wenn diese Layouts aktiviert werden, beginnt FrameMaker mit dem Empfang der Eingaben gemäß der Tastenzuweisungen der Drittanbieter-Software. FrameMaker ändert keine Tastendefinitionen.


Unicode-Unterstützung / Einrichten des Computers und der Tastatur für das Arbeiten mit verschiedenen Sprachen / Anzeigen und Bearbeiten von mehrsprachigen FrameMaker-Dokumenten

Einrichten der Eingabesprachen unter Solaris

Führen Sie eine der folgenden Schritte aus, um die Eingabesprachen auf dem Solaris-Betriebssystem einzurichten:

    Drücken Sie die Compose-Taste und geben Sie den aus zwei Buchstaben bestehenden Sprachcode ein. Wenn Sie beispielsweise Text in der Sprache Thai eingeben wollen, drücken Sie die Compose-Taste und anschließend den Code "tt". Drücken Sie Control+Leertaste, um den Standardeingabemodus "Englisch/Europa" direkt auszuwählen.

    Klicken Sie auf die Statusleiste und wählen Sie einen Eingabemodus aus.

Öffnen Sie nun die Bildschirmtastatur, um UTF-8-Zeichen in das FrameMaker-Dokument einzugeben. Über das Funktionstasten-Dienstprogramm von Solaris stehen mehrere internationale Tastaturen zur Verfügung. Bei dieser Funktion wird eine Bildschirmtastatur mit den Tasten angezeigt, die denen einer echten Tastatur entsprechen. Wird über ein DeskSet oder eine andere XView-Anwendung eine der internationalen Tastaturen angezeigt, werden die Tastendrücke auf der Tastatur den internationalen Zeichen zugeordnet, und die internationalen Zeichen werden im Textbereich des XView-Anwendungsfensters angezeigt.

So zeigen Sie eine Tastatur in der gewünschten Sprache an:

    1. Wählen Sie "Workspace > Utilities > Function Keys".

    2. Heften Sie das Fenster "Function Keys" an den Arbeitsbereich.

    3. Klicken Sie in einem XView-Anwendungsfenster (beispielsweise ein Command Tool), in dem Sie internationale Zeichen verwenden wollen, auf "SELECT".

    4. Drücken Sie die Sprachtaste auf der Tastatur, bis Sie angewiesen werden, die Taste loszulassen. Diese Taste ist in der Regel mit "Druck" beschriftet. Jede Funktionstastenbeschriftung zeigt eine der internationalen Sprachen an, die die virtuelle Tastatur unterstützt.

    5. Klicken Sie unter "More" auf "SELECT", um nacheinander die verschiedenen verfügbaren Zeichensätze anzuzeigen.

    6. Klicken Sie auf der Schaltfläche für die gewünschte Sprache auf "SELECT".

    7. Klicken Sie auf der Schaltfläche "Show" auf "SELECT". Die virtuelle Tastatur für die gewählte Sprache wird im Arbeitsbereich angezeigt.

    8. Heften Sie das Tastaturfenster an.

    9. Klicken Sie im Fenster "Function Keys" auf der Schaltfläche "Set" auf "SELECT".

    10. Lassen Sie die Sprachtaste los.

    11. Beginnen Sie mit der Eingabe im XView-Anwendungsfenster, von dem aus Sie die Tastatur geöffnet haben. Die eingegebenen Zeichen werden im ausgewählten Zeichensatz angezeigt.


FrameMaker-Tabellen

Erläuterung von Tabellen

Einfügen von Tabellen

Konvertieren zwischen Text und Tabellen

Kopieren, Verschieben und Entfernen von Tabellen

Ändern des Erscheinungsbilds von Tabellen

Positionieren von Tabellen auf einer Seite

Anpassen von Reihen und Spalten

Sortieren von Spalten und Reihen

Drehen von Zellen und Tabellen

Steuern von Seitenumbrüchen in Tabellen

Positionierung und automatische Nummerierung von Text in Zellen

Arbeiten mit Lineatur und Schattierung

Neudefinieren und Aktualisieren von Tabellenformaten

Umbenennen und Löschen von Tabellenformaten

Definieren von Tabellenformaten

Arbeiten mit Tabellen in strukturierten Dokumenten

Einfügen von strukturierten Tabellen

Einfügen von Text und Grafik in strukturierte Tabellen

Kopieren, Verschieben und Entfernen von strukturierten Tabellen

Zuweisen verschiedener Formate zu strukturierten Tabellen

Positionieren von strukturierten Tabellen auf einer Seite

Anpassen von Reihen und Spalten in strukturierten Tabellen

Drehen von Zellen und Tabellen in strukturierten Dokumenten


FrameMaker-Tabellen

Erläuterung von Tabellen

Wenn Sie eine Tabelle in ein Dokument einfügen, verfügt sie bereits über Reihen und Spalten mit Zellen, die Sie ausfüllen können. Sie weist auch ein bestimmtes Format auf, mit dessen Hilfe Sie ihr Aussehen definieren können.

Sie können eine Tabelle einfügen und mit Text und Grafiken füllen oder bestehenden Text in eine Tabelle umwandeln. Außerdem können Sie Spalten und Reihen umstellen bzw. ihre Größe ändern, Tabellen und Zellen drehen, Zellenränder und -ausrichtung anpassen, Lineatur und Schattierung ändern und Titel hinzufügen oder entfernen. Mithilfe der Tabellengestaltung können Sie Tabellenformate definieren oder in einem ganzen Dokument ändern.

Tabellen bestehen in der Regel aus einer Kopfzeile, Standardreihen und einem Titel; mitunter sind auch Fußreihen vorhanden.

A: Tabellentitel B: Kopfreihe C: Tabellenhaupttext D: Fußzeile

Das Aussehen einer Tabelle wird durch das Format bestimmt, zu dem die folgenden Arten von Eigenschaften gehören:

    Einstellungen im Fenster "Tabellengestaltung", z. B. Tabellenposition, Zellenränder, Lineatur, Schattierung und Titel.

    Drei Arten von Standardeinstellungen: Anzahl der Kopf-, Fuß- und Standardreihen, Anzahl der Spalten sowie Absatzformate für Titel und Standard-, Kopf- und Fußzellen der einzelnen Spalten. Diese Einstellungen werden beim ersten Einfügen einer Tabelle verwendet. Änderungen an den Standardeinstellungen wirken sich nicht auf bereits vorhandene Tabellen aus, die dieses Format verwenden, beeinflussen jedoch neue, leere Tabellen, die Sie einfügen.

Nach dem Einfügen einer Tabelle können Sie spezielle Formateinstellungen vornehmen, z. B. das Verbinden oder Drehen von Zellen oder das Zuweisen einer speziellen Lineatur bzw. Schattierung für ausgewählte Zellen. Spezielle Formatierungen werden nicht als Teil des Tabellenformats gespeichert. Daher bleiben Spezialformatierungen erhalten, wenn Sie ein Tabellenformat ändern oder erneut zuweisen.

Klicken Sie mit der rechten Maustaste auf eine Tabelle, um das Kontextmenü zu öffnen. Auch mithilfe der QuickAccess-Leiste können Sie allgemeine Operationen mit Tabellen durchführen. Weitere Informationen hierzu finden Sie unterVerwendung der QuickAccess-Leiste und in der Online-Hilfe.

Wenn Sie eine Seite einfügen, ist diese an der Einfügemarke verankert. Bei aktivierter Anzeige der Steuerzeichen wird ein Tabellen-Ankersymbol [image] eingeblendet.


FrameMaker-Tabellen

Einfügen von Tabellen

Beim Einfügen einer neuen, leeren Tabelle wählen Sie das gewünschte Format aus. Tabellenformate werden wie Absatz- und Zeichenformate in einem Katalog gespeichert. Der Tabellenformat-Katalog wird jedoch im Dialogfenster "Tabelle einfügen" und nicht in einer gleitenden Palette angezeigt.

Einfügen von Text und Grafik in Tabellen

Eingeben und Auswählen von Text in Tabellen

Auswählen von Tabellenzellen

Kopieren oder Verschieben von Zelleninhalten

Formatieren von Text in Tabellen

Hinzufügen oder Entfernen von Tabellentiteln

Hinzufügen von Fortsetzungstext

Platzieren von Grafiken in Tabellenzellen

Einfügen einer Tabelle in eine Zelle

So fügen Sie eine neue, leere Tabelle ein:

    1. Klicken Sie in die Textzeile, in der Sie die Tabelle verankern wollen. Tabellen können überall eingefügt werden, nur nicht in Fußnoten. Informationen zum Einfügen einer Tabelle innerhalb einer anderen Tabelle finden Sie unter Einfügen einer Tabelle in eine Zelle.

    2. Wählen Sie "Tabelle > Tabelle einfügen".

    3. Wählen Sie ein Format für die Tabelle aus. Wenn das benötigte Format nicht in der Liste aufgeführt ist, können Sie ein Format aus einem anderen Dokument importieren (siehe Importieren und Aktualisieren von Formaten) oder ein eigenes Format definieren (siehe Definieren von Tabellenformaten).

    4. Ändern Sie gegebenenfalls in den Textfeldern die Anzahl der Reihen oder Spalten.

    5. Klicken Sie auf "Einfügen". Wenn die Anzeige der Steuerzeichen aktiviert ist, wird an der Einfügemarke ein Ankersymbol ( [image] ) angezeigt. (Wenn Sie dieses Symbol löschen, wird die Tabelle gelöscht.)

Hinweis: In mehrspaltigen Seitenlayouts kann die Tabelle mehrere Spalten verbinden, und ihre Position kann durch verbundene Absätze beeinflusst werden. Weitere Informationen hierzu finden Sie unter Verbinden von Tabellen.


FrameMaker-Tabellen / Einfügen von Tabellen

Einfügen von Text und Grafik in Tabellen

Jeder Schnittpunkt einer Spalte und einer Reihe ist eine Zelle, die Text und verankerte Rahmen enthalten kann. (Verankerte Rahmen können wiederum Grafiken oder andere Tabellen enthalten.) Wenn Sie Text eingeben oder einen verankerten Rahmen in eine Zelle einfügen, wird die Höhe der Zelle entsprechend angepasst.

Sie können den Inhalt von Zellen genau so kopieren, ausschneiden und einsetzen wie Text oder Grafiken in jedem anderen Teil eines Dokuments. Mithilfe spezieller Systemvariablen kann bei mehrseitigen Tabellen festgelegt werden, dass der Text im Titel oder in den Kopfreihen auf der nächsten Seite wiederholt wird.


FrameMaker-Tabellen / Einfügen von Tabellen

Eingeben und Auswählen von Text in Tabellen

Sie können in eine Tabelle nicht nur Text eingeben, sondern auch Querverweise, Tabellenfußnoten, Variablen und Marken einfügen. Nur das Tabulatorzeichen muss auf spezielle Weise eingegeben werden.

Den Text für eine Zelle wählen Sie mithilfe der üblichen Auswahlmethoden oder mit einem der möglichen Kurzbefehle aus. Beachten Sie, dass sich das Auswählen von Text in einer Zelle vom Auswählen der Zelle unterscheidet. Wenn Sie eine Zelle auswählen, wird ein Auswahlpunkt angezeigt (siehe Auswählen von Tabellenzellen).

So fügen Sie einen Tabulator in eine Tabellenzelle ein:

Drücken Sie Esc und dann die Tabulatortaste.

So wählen Sie den Inhalt der vorhergehenden oder nachfolgenden Zelle aus:

Drücken Sie die Tabulatortaste oder Umschalttaste+Tabulator.

So wählen Sie den Inhalt der darunter- oder darüberliegenden Zelle aus:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Drücken Sie die Tastenkombination Strg+Alt+Tabulator oder Strg+Alt+Umschalttaste+Tabulator.

    (UNIX) Drücken Sie Meta+n oder Meta+p.

So wählen Sie den Inhalt der aktuellen Zelle aus:

Drücken Sie Esc t h a. Wenn die Zelle nur einen Absatz enthält, können Sie den Text auch dreimal anklicken, um diesen auszuwählen.


FrameMaker-Tabellen / Einfügen von Tabellen

Auswählen von Tabellenzellen

Wenn Sie an einer Tabelle arbeiten, kann es erforderlich sein, Zellen, Reihen, Spalten oder die gesamte Tabelle auszuwählen. Wenn Sie anstelle des Textes die Zelle auswählen, wird ein Auswahlpunkt angezeigt.

Beim Auswählen einer Zelle wird der Auswahlpunkt angezeigt.

Informationen zum Auswählen von Text in Tabellen finden Sie unter Eingeben und Auswählen von Text in Tabellen.

So wählen Sie eine einzelne Zelle aus:

    Drücken Sie die Strg- bzw. die Control-Taste und klicken Sie auf die Zelle.

So wählen Sie mehrere Zellen aus:

Ziehen Sie den Zeiger über die gewünschten Zellen oder führen Sie eine der folgenden Aktionen aus:

    Wenn Sie die ganze Reihe auswählen möchten, drücken Sie Esc t h r.

    Um eine ganze Spalte auszuwählen, drücken sie Esc t h s. Sie können auch den Zeiger aus einer Kopfzelle in die erste Standardzelle ziehen.

    Wenn Sie die ganze Tabelle auswählen wollen, drücken Sie Esc t h t.

So erweitern Sie eine Auswahl:

Klicken Sie in die erste Zelle und doppelklicken Sie anschließend bei gedrückter Umschalttaste in die letzte Zelle des auszuwählenden Bereichs.


FrameMaker-Tabellen / Einfügen von Tabellen

Kopieren oder Verschieben von Zelleninhalten

Der Inhalt einer Zelle kann über die Zwischenablage in andere Zellen derselben Tabelle oder in eine andere Tabelle eingefügt werden. Sie können entweder nur den Inhalt der Zelle oder Inhalt und Format (z. B. spezielle Lineatur und Schattierung) kopieren.

So kopieren oder verlagern Sie den Inhalt und das Format einer Zelle:

Wählen Sie die ganze Zelle aus, indem Sie den Zeiger über den Zellenrand hinaus und dann zurück in die Zelle ziehen. Der Auswahlpunkt wird angezeigt. Kopieren Sie die Zelle oder schneiden Sie sie aus und fügen Sie sie anschließend an der gewünschten Position ein. Sie können auch mehrere Zellen auswählen und kopieren oder ausschneiden.


FrameMaker-Tabellen / Einfügen von Tabellen

Formatieren von Text in Tabellen

Text in einer Tabellenzelle wird genauso formatiert wie Absätze in einer normalen Textspalte, z. B. mit Absatz- oder Zeichenformaten.

Wenn Sie eine neue, leere Tabelle einfügen, werden die Titel-, Kopf-, Fuß- und Standardzellen für die einzelnen Spalten den Standardabsatzformaten zugewiesen, die als Bestandteil des Tabellenformats gespeichert werden. Sie können dann beliebigen Absätzen in Zellen ein anderes Format zuweisen oder das Format der Absätze ändern.


FrameMaker-Tabellen / Einfügen von Tabellen

Hinzufügen oder Entfernen von Tabellentiteln

Unter- oder oberhalb der Tabelle wird der Tabellentitel angezeigt, der bei mehrseitigen Tabellen auf jeder Seite erscheint. Titeltext können Sie wie jeden anderen Absatz in einem Dokument formatieren. Sie können den Titel z. B. zentrieren, eine Standardschrift festlegen und ein Nummerierungsformat angeben.

Im Tabellenformat können Sie festlegen, ob eine Tabelle einen Titel hat und wie er formatiert wird. Sie ändern das Format im Fenster "Tabellengestaltung".

Wenn Sie eine Tabelle mit einem Titel einfügen, wird ein leerer Textrahmen für den Titel angezeigt. Ist im Titelformat eine automatische Nummerierung definiert, wird die Nummerierung angezeigt. In beiden Fällen geben Sie den Titel selbst ein.

So können Sie einen Tabellentitel hinzufügen oder entfernen:

    1. Klicken Sie in die zu ändernde Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. Wählen Sie in den Basis-Einstellungen des Fensters "Tabellengestaltung" aus dem Aufklappmenü "Position des Titels" die Option "Über Tabelle", "Unter Tabelle", "Beibehalten" oder "Kein Titel".

    3. Legen Sie den Abstand zwischen der Tabelle und dem Titel fest.

    4. Klicken Sie auf "Der Auswahl zuweisen".

Wenn Sie den Titel nur auf der ersten Seite einer mehrseitigen Tabelle anzeigen wollen, setzen Sie die Titelposition auf "Kein Titel" und verwenden Sie einen Textabsatz als Titel. Um zu verhindern, dass der Titel von der Tabelle getrennt wird, stellen Sie sicher, dass sich das Ankersymbol im Titeltext befindet und die Option "Beginn" der Tabelle auf "Beliebig" eingestellt ist.


FrameMaker-Tabellen / Einfügen von Tabellen

Hinzufügen von Fortsetzungstext

In einer mehrseitigen Tabelle sollten Sie speziellen Fortsetzungstext im Titel oder in der Kopf- bzw. Fußreihe anzeigen. Zu diesem Zweck können zwei Systemvariablen Text aufnehmen: "Tabellenfortsetzung" und "Tabellenabschnitt".

A: und C: Variable "Tabellenabschnitt" B: Variable "Tabellenfortsetzung"

Sie können die Standarddefinition dieser Variablen wie bei den anderen Systemvariablen jederzeit ändern. Weitere Informationen finden Sie unter Ändern von Variablendefinitionen.

So fügen Sie Fortsetzungstext hinzu:

    1. Klicken Sie auf der ersten Seite der Tabelle in den Titel bzw. in die Kopf- oder Fußzeile, in die Sie die Variable einfügen wollen.

    2. Wählen Sie "Spezial > Variable".

    3. Wählen Sie die Systemvariable "Tabellenfortsetzung" oder "Tabellenabschnitt" und klicken Sie auf "Einfügen".

Auf der ersten Tabellenseite wird die Variable als umbruchgeschütztes Leerzeichen ( [image] ) angezeigt. Auf den nachfolgenden Seiten wird der definierte Text angezeigt (z. B. Fortsetzung, wenn Sie die Variable "Tabellenfortsetzung" verwenden).


FrameMaker-Tabellen / Einfügen von Tabellen

Platzieren von Grafiken in Tabellenzellen

Eine Grafik können Sie mithilfe eines in einer Zelle positionierten verankerten Rahmens zeichnen oder importieren. Die folgenden Arbeitsschritte zeigen die allgemeine Vorgehensweise beim Einfügen einer Grafik in eine Zelle. Sie können den verankerten Rahmen jederzeit verschieben oder eine Grafik in eine Zelle einfügen, die bereits Text enthält.

Hinweis: Verwenden Sie keine beschnittenen verankerten Rahmen in den Kopf- oder Fußzeilen einer Tabelle. Diese Rahmen werden möglicherweise nicht beschnitten, wenn die Zelle auf den nachfolgenden Seiten wiederholt wird.

So platzieren Sie eine Grafik in einer Zelle:

    1. Klicken Sie in einen Absatz der Zelle, in der Sie die Grafik einfügen wollen.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie einen verankerten Rahmen erstellen wollen, in dem Sie zeichnen können, wählen Sie "Spezial > Verankerter Rahmen", um den Rahmen an der Einfügemarke zu verankern (siehe Verankerte Rahmen).

    Wenn Sie einen verankerten Rahmen für eine importierte Grafik erstellen wollen, wählen Sie "Datei > Importieren > Datei".

    3. Wenn der verankerte Rahmen breiter als die Zelle ist, passen Sie die Spalte entsprechend an (siehe Ändern der Spaltengröße).

Eine schnelle Möglichkeit zum Anpassen der Spalte an den Zelleninhalt besteht darin, die Einfügemarke in der Zelle mit der gewünschten Textlänge zu platzieren und Esc t w zu drücken.

    4. Wählen Sie gegebenenfalls "Grafik > Ausrichten", um die Grafik im Rahmen zu zentrieren.


FrameMaker-Tabellen / Einfügen von Tabellen

Einfügen einer Tabelle in eine Zelle

Bevor Sie eine Tabelle in eine Zelle einfügen können, müssen Sie in der Zelle einen verankerten Rahmen erstellen und darin einen Textrahmen zeichnen. Anschließend fügen Sie eine Tabelle in den Textrahmen ein und formatieren diese wie jede andere Tabelle.

So platzieren Sie eine Tabelle in einer Zelle:

    1. Klicken Sie in die Zelle, in die Sie eine Tabelle einfügen wollen.

    2. Wählen Sie "Spezial > Verankerter Rahmen", um einen verankerten Rahmen zu erstellen, der unter der aktuellen Zelle verankert ist (siehe Verankerte Rahmen). Dabei sollten Breite und Höhe des Rahmens möglichst etwas größer als die Abmessungen der einzufügenden Tabelle sein.

    3. Wenn der verankerte Rahmen breiter als die Zelle ist, passen Sie die Spalte entsprechend an (siehe Ändern der Spaltengröße).

    4. Erstellen Sie mit dem Werkzeug "Textrahmen" der Werkzeugpalette einen Textrahmen im verankerten Rahmen (siehe Grafiken und Text).

    5. Klicken Sie in den Textrahmen und fügen Sie eine Tabelle ein.


FrameMaker-Tabellen

Konvertieren zwischen Text und Tabellen

Konvertieren von Text zu Tabellen

Konvertieren von Tabellen zu Text


FrameMaker-Tabellen / Konvertieren zwischen Text und Tabellen

Konvertieren von Text zu Tabellen

Sie können Text, der sich bereits im Dokument befindet, oder Text in einer Textdatei beim Öffnen oder Importieren der Datei konvertieren. In einem strukturierten Dokument ist der Text in eine Struktur von Tabellen und Tabellenteil-Elementen eingegliedert.

Nach der Konvertierung sollten Sie die Tabelle überprüfen und leere Zellen entfernen oder Text wieder verbinden, der in mehrere Zellen aufgeteilt wurde. In den meisten Fällen können Sie die Tabelle direkt im Dokument bearbeiten. Wenn Sie jedoch Text konvertiert haben, der durch Referenz importiert wurde, müssen Sie den Text in der Originaldatei bearbeiten.

So konvertieren Sie Text in eine Tabelle:

    1. Wählen Sie den zu konvertierenden Text aus.

    2. Wählen Sie "Tabelle > Zu Tabelle konvertieren".

    3. Bei einem strukturierten Dokument wählen Sie ein Tabellenelement aus dem Aufklappmenü "Element-Tag".

    4. Wählen Sie ein Format für die Tabelle aus.

Hinweis: In einem strukturierten Dokument hat das Tabellenelement möglicherweise ein vordefiniertes Format, das Sie jedoch ändern können, ohne dass es als irreguläre Formatzuweisung betrachtet wird.

    5. So legen Sie fest, wie Absätze konvertiert werden sollen:

    Um Text zu konvertieren, in dem die Informationen durch Tabulatoren getrennt sind, klicken Sie auf "Tabulatoren".

    Um Text zu konvertieren, in dem die Informationen durch Leerzeichen getrennt sind, klicken Sie auf "Leerzeichen" und geben an, nach wie vielen Leerzeichen eine neue Zelle beginnen soll.

    Sind die Informationen im zu konvertierenden Text durch andere Zeichen getrennt, klicken Sie auf "Sonstiges" und geben die betreffenden Trennzeichen ein.

    Soll jeder Absatz in eine eigene Zelle konvertiert werden (z. B. bei einer Liste mit Auszeichnungspunkten), klicken Sie auf "Eine Zelle" und geben die gewünschte Spaltenanzahl ein.

    6. Geben Sie in das Textfeld "Kopfreihen" die Anzahl der Kopfreihen für die neue Tabelle ein. Enthalten die zu konvertierenden Absätze keine Kopfreihen, wählen Sie bei Bedarf "Kopfreihen frei lassen" und geben den Text später ein.

    7. Klicken Sie auf "Konvertieren".

Hinweis: In strukturierten Dokumenten enthält die Strukturansicht Elementrechtecke für die neuen Elemente. Falls das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für die Tabellenelemente ein und klicken auf "Element einfügen" (siehe Einfügen von Elementen).

So konvertieren Sie eine Textdatei beim Öffnen in eine Tabelle:

    1. Wählen Sie "Datei > Öffnen" und geben Sie die gewünschte Textdatei an.

    2. Wenn das Dialogfenster "Unbekannter Dateityp" geöffnet wird, wählen Sie "Text" und klicken auf "Konvertieren".

    3. Klicken Sie auf "In Tabelle konvertieren" und anschließend auf "Einlesen".

    4. Fahren Sie wie beim Konvertieren von bereits im Dokument vorhandenem Text (beginnend mit Schritt 3 in den vorhergehenden Anleitungen) fort.

So konvertieren Sie eine Textdatei beim Importieren in eine Tabelle:

    1. Klicken Sie an die Stelle, an der Sie die Datei importieren möchten.

    2. Wählen Sie "Datei > Importieren > Datei" und wählen Sie die zu importierende Textdatei und die Importmethode aus. Weitere Informationen hierzu finden Sie unter Importieren von unformatiertem Text.

    3. Klicken Sie auf "In Tabelle konvertieren" und anschließend auf "Importieren".

    4. Folgen Sie den Anweisungen für das Konvertieren von Text in eine Tabelle. Beginnen Sie mit Schritt 3.

Wenn Sie eine Textdatei in eine vorhandene Tabelle einlesen wollen, importieren Sie zuerst die Textdatei (siehe Einfügen einer Tabelle in eine Zelle) und konvertieren sie dann in eine Tabelle. Kopieren Sie anschließend die Reihen und fügen Sie sie in die vorhandene Tabelle ein.

So überarbeiten Sie eine Tabelle nach dem Import:

Führen Sie einen der folgenden Schritte aus:

    Um Text zusammenzufassen, der auf mehrere Reihen verteilt ist, schneiden Sie ihn aus den unteren Zellen aus, fügen ihn in die obere Zelle ein und löschen zum Schluss die überzähligen Reihen.

Um Text in aneinander grenzenden Zellen schnell zusammenzufügen, wählen Sie "Tabelle > Verbinden" und danach "Tabelle > Trennen". Auf diese Weise entstehen leere Reihen oder Spalten, die Sie löschen können.

    Sind nach dem Konvertieren Spalten nur halb gefüllt, kopieren Sie den Text, fügen ihn an der korrekten Position ein und löschen die überflüssigen Spalten.

    Bei gravierenden Fehlern sollten Sie noch einmal mit dem Originaltext beginnen (wählen Sie ggf. "Bearbeiten > Rückgängig"). Bearbeiten Sie dann den Text (z. B. durch Löschen von überzähligen Tabulatoren oder Zeilenumbrüchen) und konvertieren Sie ihn erneut.


FrameMaker-Tabellen / Konvertieren zwischen Text und Tabellen

Konvertieren von Tabellen zu Text

In FrameMaker können Sie jede Tabelle in Text konvertieren. Sie können die Tabelle auch als Text in eine andere Anwendung kopieren. Es können auch alle Tabellen eines Dokuments gleichzeitig konvertiert werden.

Wenn Sie in strukturierten Dokumenten Tabellen in Text konvertieren, werden außer den Zellen alle Tabellen- und Tabellenteil-Elemente ausgegliedert. Wandeln Sie die Zellen in andere Elemente um oder nehmen Sie andere Veränderungen vor, um die Struktur des Dokuments zu korrigieren.

So konvertieren Sie in FrameMaker eine Tabelle in Text:

    1. Klicken Sie in die Tabelle, die Sie in Text konvertieren wollen.

    2. Wählen Sie "Tabelle > Zu Absätzen konvertieren".

    3. Aktivieren Sie "Reihenweise" oder "Spaltenweise" und klicken Sie anschließend auf "Konvertieren".

Zu Tabelle konvertierter Text
A: Reihenweise B: Spaltenweise

So kopieren Sie eine Tabelle als Text in eine andere Anwendung:

    1. Kopieren Sie die Tabelle in die Zwischenablage.

    2. Wählen Sie in der anderen Anwendung "Bearbeiten > Einfügen". Die Tabelle wird Reihe für Reihe eingefügt. Die Zellen werden durch Tabulatoren getrennt, und am Ende jeder Reihe wird ein Absatzendezeichen eingefügt.

So konvertieren Sie alle Tabellen eines Dokuments in Text:

Speichern Sie das Dokument im Format "Nur Text" und geben Sie an, wie die Tabellen konvertiert werden sollen (siehe Speichern von Dokumenten im Nur-Text-Format).


FrameMaker-Tabellen

Kopieren, Verschieben und Entfernen von Tabellen

Tabellen lassen sich durch die Optionen "Ausschneiden" (und Einfügen in die Zwischenablage) oder durch "Löschen" (ohne Zwischenablage) entfernen.

So kopieren, verschieben oder entfernen Sie eine Tabelle:

    1. Klicken Sie bei gedrückter Strg- bzw. Control-Taste dreimal auf eine Zelle, um die gesamte Tabelle auszuwählen.

    2. Führen Sie eine der folgenden Aktionen aus:

    Zum Kopieren der Tabelle wählen Sie "Bearbeiten > Kopieren".

    Um die Tabelle zu verschieben, wählen Sie "Bearbeiten > Ausschneiden". Wird ein Dialogfenster geöffnet, klicken Sie auf "Zellen entfernen" und dann auf "Ausschneiden". Klicken Sie anschließend an die Stelle, zu der Sie die Tabelle verschieben möchten, und wählen Sie "Bearbeiten > Einfügen".

    Um die Tabelle zu entfernen (ohne den Inhalt der Zwischenablage zu ändern), drücken Sie Entf.


FrameMaker-Tabellen

Ändern des Erscheinungsbilds von Tabellen

Das Aussehen einer einzufügenden Tabelle wird vom Tabellenformat bestimmt. Entsprechen die vordefinierten Formateinstellungen nicht Ihren Wünschen, können Sie sie ändern.

Es gibt mehrere Möglichkeiten, um das Aussehen von Tabellen zu ändern:

    Mit dem Fenster "Tabellengestaltung" können Sie Einzug, Zellenränder, Abstand, Ausrichtung, Lineatur und Schattierung der Tabelle ändern. Sie können auch Titelposition, Nummerierung und Anfangsposition der Tabelle anpassen.

    Mit den Befehlen im Menü "Tabelle" können Sie Zellen drehen und verbinden, Zellenhöhe und Seitenumbrüche ändern und spezielle Lineatur und Schattierung zuweisen.

Wenn Sie im Fenster "Tabellengestaltung" Formatänderungen durchführen, die nicht mit einem vordefinierten Tabellenformat übereinstimmen, handelt es sich um ein irreguläres Format. Wenn Sie das vordefinierte Format wieder auf die Tabelle anwenden, gehen irreguläre Formate verloren. Änderungen, die über Befehle des Menüs "Tabelle" erfolgt sind, gehen nicht verloren.

Mithilfe des Dialogfensters "Tabellengestaltung" und der Befehle des Menüs "Tabelle" können Sie das Erscheinungsbild von Tabellen ändern. Bei der Schablonengestaltung können erfahrene Benutzer im Fenster "Tabellengestaltung" auch neue Tabellenformate erstellen und Formate global im ganzen Dokument ändern (siehe Definieren von Tabellenformaten).


FrameMaker-Tabellen / Ändern des Erscheinungsbilds von Tabellen

Verwenden der Tabellengestaltung

Das Fenster "Tabellengestaltung" enthält mehrere Bereiche und Befehle, mit denen Sie Tabellenformate erstellen, ändern und überschreiben können. Das Dialogfenster enthält mehrere Einstellungsgruppen, die jeweils einzeln angezeigt werden. In der Abbildung sehen Sie die Basis-Einstellungen.

Tabellengestaltung
A: (Windows) Klicken Sie auf eine Registerkarte, um die entsprechende Gruppe von Einstellungen anzuzeigen.
B: Wählen Sie einen Eintrag aus dem Aufklappmenü "Tabellentyp", um die gespeicherten Einstellungen dieses Formats anzuzeigen.
C: Wählen Sie aus dem Aufklappmenü "Einstellungen" die gewünschte Einstellungsgruppe: "Basis", "Lineatur" oder "Schattierung".
D: Weisen Sie sämtliche Einstellungen in allen Einstellungsgruppen dem Format der aktuellen Tabelle zu.
E: Aktualisieren Sie alle Tabellenformate desselben Typs, einschließlich des im Tabellenformat-Katalog gespeicherten Formats.

Im linken Bereich des Dialogfensters "Tabellengestaltung" können Sie ein Tabellenformat und eine Einstellungsgruppe wählen. Im Aufklappmenü "Tabellentyp" werden die im Tabellenformat-Katalog gespeicherten Tabellenformate angezeigt. (Unter Windows können Sie auch auf ein Register klicken, um die betreffende Einstellungsgruppe anzuzeigen.)

Im rechten Bereich des Dialogfensters ändern Sie die Tabelleneinstellungen. Das Aussehen der Tabelle ändert sich erst, wenn Sie die Einstellungen zuweisen.

So zeigen Sie das Fenster "Tabellengestaltung" und eine Einstellungsgruppe an:

    1. Wählen Sie "Tabelle > Tabellengestaltung".

    2. Wählen Sie eine Einstellungsgruppe aus dem Aufklappmenü "Einstellungen" oder klicken Sie unter Windows auf ein Register.

So weisen Sie geänderte Einstellungen zu:

Klicken Sie auf "Der Auswahl zuweisen". Stimmen die durchgeführten Änderungen nicht mit einem der vordefinierten Formate überein, werden sie als irreguläres Format behandelt.

Hinweis: Auf "Alle aktualisieren" müssen Sie nur klicken, wenn Sie eine globale Änderung durchführen wollen (z. B. um das Tabellenformat und alle Tabellen im Dokument durch dieses Format zu ändern). Verwenden Sie "Alle aktualisieren" mit Vorsicht, da diese Option die Definition eines Formats ändert.

So setzen Sie die Einstellungen nach Änderungen im Fenster "Tabellengestaltung" zurück:

Führen Sie eine der folgenden Aktionen aus:

    Um alle Einstellungen (einschließlich der irregulären Formate) auf die Werte der aktuellen Tabelle zurückzusetzen, klicken Sie in die Tabelle oder wählen Sie aus dem Aufklappmenü "Befehle" die Option "Einstellungen der Auswahl übernehmen".

    Um die Einstellungen entsprechend dem gespeicherten Tabellenformat zurückzusetzen, wählen Sie aus dem Aufklappmenü "Tabellentyp" das betreffende Format aus. Führen Sie diese Aktion auch dann durch, wenn das Format bereits im Textfeld "Tabellentyp" angezeigt wird.


FrameMaker-Tabellen / Ändern des Erscheinungsbilds von Tabellen

Zuweisen anderer Tabellenformate

Beim Einfügen einer neuen Tabelle müssen Sie zwar ein Format auswählen, diese Zuweisung können Sie jedoch jederzeit ändern.

Wenn Sie einer vorhandenen Tabelle ein anderes Format zuweisen, werden nur die im Fenster "Tabellengestaltung" festgelegten Einstellungen geändert. Die folgenden beiden Einstellungskategorien, die nicht in der Tabellengestaltung festgelegt sind, ändern sich nicht:

    Änderungen, die mit den Befehlen der Menüs "Tabelle" und "Grafik" durchgeführt wurden, z. B. Seitenumbrüche oder verbundene und gedrehte Zellen.

    Anzahl der Reihen und Spalten, Breite der Spalten, Absatzformat des Titels und des Textes in den Kopf-, Standard- und Fußzellen der Spalten. Diese Einstellungen werden beim erstmaligen Einfügen einer Tabelle festgelegt.

Wenn der Tabelle ein neues Format zugewiesen wird, bleiben benutzerdefinierte Änderungen, z. B. gedrehte Zellen, erhalten.

Informationen über Tabellenformate finden Sie im Abschnitt Erläuterung von Tabellen.

So weisen Sie einer vorhandenen Tabelle ein anderes Format zu:

    1. Klicken Sie in die Tabelle, der Sie ein neues Format zuweisen wollen.

    2. Wählen Sie "Tabelle > Tabellengestaltung".

    3. Wählen Sie das gewünschte Format aus dem Aufklappmenü "Tabellentyp" und klicken Sie auf "Der Auswahl zuweisen".


FrameMaker-Tabellen / Ändern des Erscheinungsbilds von Tabellen

Zuweisen eines Formats zu mehreren Tabellen

Ein Format kann allen Tabellen im Dokument, allen Tabellen eines bestimmten Typs (Formatnamen) in einer Auswahl oder allen Tabellen eines bestimmten Typs zugewiesen werden. Zum Beispiel können Sie allen Tabellen Format B zuweisen, die derzeit Format A haben.

Wenn Sie einer Tabelle ein Format zuweisen, ändern sich nur die im Fenster "Tabellengestaltung" angegebenen Einstellungen. Standardeinstellungen und spezielle Einstellungen sind davon nicht betroffen. (Eine Beschreibung dieser Einstellungen finden Sie unter Zuweisen anderer Tabellenformate.)

So weisen Sie mehreren Tabellen ein Format eines bestimmten Typs zu:

    1. Wählen Sie die zu ändernden Tabellen aus, indem Sie eine der folgenden Aktionen ausführen:

    Um das Format allen Tabellen im Dokument zuzuweisen, klicken Sie in eine beliebige Tabelle.

    Um ein Format auf eine Auswahl aufeinander folgender Tabellen anzuwenden, wählen Sie diese Tabellen aus. (Um mehrere Tabellen auszuwählen, müssen Sie deren Ankersymbole auswählen.)

    2. Wählen Sie "Tabelle > Tabellengestaltung".

    3. Wählen Sie das gewünschte Format aus dem Aufklappmenü "Tabellentyp" und dann aus dem Aufklappmenü "Befehle" den Eintrag "Optionen für globale Aktualisierung".

    4. Wählen Sie die neu zu formatierenden Tabellen aus, indem Sie eine der folgenden Aktionen ausführen:

    Um das Format allen Tabellen im Dokument zuzuweisen, klicken Sie auf "Alle Tabellen und Katalogeinträge".

    Um das Format den ausgewählten Tabellen und allen Tabellen desselben Typs zuzuweisen, klicken Sie auf "Alle entsprechenden Typen in Auswahl".

    Um das Format allen Tabellen eines bestimmten Typs zuzuweisen, wählen Sie aus dem Aufklappmenü den gewünschten Typ aus.

    5. Klicken Sie im Bereich "Einstellungen der Tabellengestaltung verwenden" auf "Alle Einstellungen" und dann auf "Aktualisieren".


FrameMaker-Tabellen

Positionieren von Tabellen auf einer Seite

Beim Einfügen einer Tabelle bestimmt das Tabellenformat den Abstand über und unter der Tabelle sowie Ausrichtung und Einzug. Sie können diese Einstellungen im Fenster "Tabellengestaltung" später ändern.

Andere Positionierungseinstellungen, z. B. Verbinden und Konturlauf, sind nicht Teil eines Tabellenformats. Diese Einstellungen werden tabellenspezifisch festgelegt.

Ausrichten und Einrücken von Tabellen

Anpassen des Abstands über und unter einer Tabelle

Festlegen der Anfangsposition von Tabellen

Verbinden von Tabellen

Fließen von Text um eine Tabelle


FrameMaker-Tabellen / Positionieren von Tabellen auf einer Seite

Ausrichten und Einrücken von Tabellen

Die Ausrichtung einer Tabelle legt die Position der Tabelle zwischen dem linken und dem rechten Einzug fest.

Linker und rechter Einzug bestimmen die horizontale Position der Tabellenkante bei links- bzw. rechtsbündiger Ausrichtung.

So richten Sie eine Tabelle aus:

    1. Klicken Sie in die zu ändernde Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. Führen Sie in den Basis-Einstellungen der Tabellengestaltung folgende Aktionen durch:

    Um eine Ausrichtung festzulegen, wählen Sie den gewünschten Eintrag aus dem Aufklappmenü "Ausrichtung".

    Um einen linken und rechten Einzug festzulegen, geben Sie die entsprechenden Werte ein.

    3. Klicken Sie auf "Der Auswahl zuweisen".


FrameMaker-Tabellen / Positionieren von Tabellen auf einer Seite

Anpassen des Abstands über und unter einer Tabelle

Sie legen den Abstand über und unter einer Tabelle genau so wie Absatzabstände fest.

Der Abstand zwischen einer Tabelle und dem darüber liegenden Absatz wird durch die Einstellung "Über Tabelle" oder den unteren Abstand des Absatzes bestimmt (je nachdem, welcher Wert größer ist). Der Abstand zwischen einer Tabelle und dem darunter liegenden Absatz wird durch die Einstellung "Unter Tabelle" oder den oberen Abstand des Absatzes bestimmt (je nachdem, welcher Wert größer ist). Wenn sich die Tabelle am Anfang oder am Ende einer Spalte befindet, wird die Einstellung für den oberen bzw. unteren Abstand ignoriert.

So legen Sie den Abstand über oder unter einer Tabelle fest:

    1. Klicken Sie in die zu ändernde Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. Geben Sie in den Basis-Einstellungen der Tabellengestaltung die gewünschten Werte in die Textfelder "Oben" und "Unten" ein.

    3. Klicken Sie auf "Der Auswahl zuweisen".


FrameMaker-Tabellen / Positionieren von Tabellen auf einer Seite

Festlegen der Anfangsposition von Tabellen

Gewöhnlich wird eine Tabelle unter der Zeile angezeigt, die das Ankersymbol enthält. Sie können jedoch festlegen, dass eine Tabelle am Anfang einer Seite oder Spalte beginnt oder der Tabellenanfang gleitend ist.

Wenn in der Textspalte, in der eine gleitende Tabelle verankert ist, nicht genügend Platz ist, wird die Tabelle in die erste Textspalte verschoben, die sie aufnehmen kann. Die Zeile, in der sich das Ankersymbol der Tabelle befindet, wird jedoch nicht verschoben. Wenn die Tabelle in die nächste Textspalte verlagert wird, fließt der Text im Bereich unter der Zeile mit dem Ankersymbol weiter.

Normale und gleitende Tabelle

Wenn eine Tabelle ganz am Anfang einer Seite beginnen soll, verankern Sie sie auf der vorhergehenden Seite und setzen sie auf "Gleitend". Soll die Tabelle immer gleiten, geben Sie auf einer Seite im Textfeld "Reihenkontrolle" einen relativ hohen Wert, z. B. 200, an (siehe Festlegen einer Mindestanzahl von Reihen auf einer Seite).

So legen Sie die Anfangsposition einer Tabelle fest:

    1. Klicken Sie in die zu ändernde Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. Wählen Sie in den Basis-Einstellungen den gewünschten Eintrag aus dem Aufklappmenü "Beginn".

    3. Klicken Sie auf "Der Auswahl zuweisen".

Wenn das Ankersymbol für eine Tabelle am Spaltenanfang unter einem Absatz erscheint, der Spalten verbindet, wird die Tabelle in der nächsten Spalte direkt unter dem verbundenen Absatz statt am Spaltenanfang angezeigt.

Eine am Spaltenanfang beginnende Tabelle, die unter einem verbundenen Absatz verankert ist

Wie Sie festlegen können, wie eine Tabelle umbricht, erfahren Sie unter Steuern von Seitenumbrüchen in Tabellen.


FrameMaker-Tabellen / Positionieren von Tabellen auf einer Seite

Verbinden von Tabellen

In mehrspaltigen Layouts können Tabellen mehrere Spalten verbinden, und ihre Position kann durch verbundene Absätze beeinflusst werden. Weitere Informationen zu verbundenen Absätzen finden Sie unter Erstellen von verbundenen Überschriften.

So verbinden Sie eine Tabelle:

Führen Sie eine der folgenden Aktionen aus:

    Verankern Sie die Tabelle in einem verbundenen Absatz. Eine in einem verbundenen Absatz verankerte Tabelle verbindet, unabhängig von ihrer Breite, stets die gesamte Breite des Textrahmens.

In einem verbundenen Absatz verankerte Tabelle

    Erweitern Sie die Tabellenbreite in eine zweite Spalte des Haupttextbereichs (siehe Ändern der Spaltengröße). Wenn die Tabelle sowohl den Arbeitsbereich als auch die seitlichen Überschriften verbinden soll, erweitern Sie die Tabelle auf den Bereich für seitliche Überschriften.

Verbinden aller Spalten und der seitlichen Überschrift

So trennen Sie eine Tabelle:

Führen Sie eine der folgenden Aktionen aus:

    Ist die Tabelle in einem verbundenen Absatz verankert, verlagern Sie deren Anker in einen nicht verbundenen Absatz.

    Ist die Tabelle in einem nicht verbundenen Absatz verankert, ändern Sie die Spaltenbreite der Tabelle entsprechend der Textspalte (siehe Anpassen von Reihen und Spalten).


FrameMaker-Tabellen / Positionieren von Tabellen auf einer Seite

Fließen von Text um eine Tabelle

Text fließt nicht um eine Tabelle, die direkt in einer Textspalte verankert ist. Sie können jedoch Text um eine Tabelle fließen lassen, die sich in einem verankerten Rahmen oder einem vom Haupttextfluss getrennten Textrahmen befindet. (Eine Tabelle in einem abgetrennten Textrahmen ist jedoch von der automatischen Nummerierung der Tabellen im Haupttextfluss ausgenommen.)

Tabelle in einem verankerten Rahmen und in einem nicht mit dem Haupttextfluss verbundenen Textrahmen

So lassen Sie Text um eine Tabelle in einem verankerten Rahmen fließen:

    1. Wählen Sie "Spezial > Verankerter Rahmen" und erstellen Sie mit der Verankerungsposition "Im Absatz" einen verankerten Rahmen.

    2. Erstellen Sie im verankerten Rahmen einen Textrahmen und fügen Sie die Tabelle ein (siehe Grafiken und Text).

So lassen Sie Text um eine Tabelle fließen, deren Position auf der Seite fixiert ist:

    1. Erstellen Sie direkt auf einer Seite einen Textrahmen und ziehen Sie ihn an die gewünschte Position (siehe Grafiken und Text). Diese Art von Textrahmen ist nicht mit dem Haupttextfluss verbunden.

    2. Wählen Sie "Grafik > Konturlaufeinstellungen", klicken Sie auf "Um Bildrahmen" und dann auf "Zuweisen".

    3. Fügen Sie eine Tabelle in den Textrahmen ein.


FrameMaker-Tabellen

Anpassen von Reihen und Spalten

Hinzufügen und Löschen von Reihen und Spalten

Kopieren und Verschieben von Reihen und Spalten

Ändern der Spaltengröße

Anpassen der Reihenhöhe

Verbinden und Trennen von Zellen


FrameMaker-Tabellen / Anpassen von Reihen und Spalten

Hinzufügen und Löschen von Reihen und Spalten

Sie können Anzahl und Position der hinzuzufügenden Reihen oder Spalten festlegen.

So fügen Sie schnell eine Reihe unterhalb der aktuellen Reihe ein:

Drücken Sie die Tastenkombination Strg+Eingabetaste. Die neue Reihe erhält die Absatzformate der vorherigen Reihe.

So fügen Sie eine Reihe oder Spalte hinzu:

    1. Klicken Sie in die Zelle, neben der die Reihe oder Spalte hinzugefügt werden soll.

    2. Wählen Sie "Tabelle > Reihen oder Spalten einfügen" und geben Sie Anzahl und Position der neuen Reihen oder Spalten an.

Reihen können über oder unter der angegebenen Zelle sowie im Kopf- oder Fußteil hinzugefügt werden. Spalten können links oder rechts von der angegebenen Zelle eingefügt werden.

    3. Klicken Sie auf "Hinzufügen".

Die Zellen in den neuen Reihen oder Spalten erhalten die Absatzformate der aktuellen Reihe oder Spalte. Wenn Sie z. B. in eine Zelle klicken und drei Reihen hinzufügen, erhalten diese dieselben Absatzformate wie die Zellen der Reihe, in die Sie geklickt haben.

So löschen Sie eine Reihe oder Spalte:

    1. Wählen Sie die zu löschenden Reihen oder Spalten. Achten Sie darauf, stets ganze Reihen oder Spalten auszuwählen. (Andernfalls wird der Inhalt der ausgewählten Zellen ohne vorherige Eingabeaufforderung gelöscht.)

    2. Drücken Sie Entf, klicken Sie auf "Zellen entfernen" und dann auf "Löschen".


FrameMaker-Tabellen / Anpassen von Reihen und Spalten

Kopieren und Verschieben von Reihen und Spalten

Sie können Reihen und Spalten samt Inhalt duplizieren oder verschieben, indem Sie sie in die Zwischenablage kopieren oder ausschneiden und dann an einer anderen Position einfügen.

Bei strukturierten Dokumenten kann die Struktur einer Tabelle durch das Kopieren oder Verschieben von Reihen oder Spalten ungültig werden. Verwenden Sie den Elementkatalog und die Strukturansicht als Richtlinien.

Die Zellen in der Zwischenablage ersetzen die aktuellen Reihen oder Spalten entsprechend folgenden Regeln:

    Stimmt die Anzahl von Reihen oder Spalten in der Zwischenablage mit der Anzahl der ausgewählten Reihen oder Spalten überein, werden diese vollständig ersetzt.

    Sind in der Zwischenablage mehr Reihen und Spalten enthalten als ersetzt werden sollen, wird nur die passende Anzahl von Reihen oder Spalten eingefügt.

    Wenn die Anzahl in der Zwischenablage kleiner ist als in der Auswahl, wird der Inhalt der Zwischenablage wiederholt, bis die Reihen oder Spalten aufgefüllt sind.

Um eine Tabelle zu teilen, schneiden Sie Reihen oder Spalten aus einer Tabelle aus und setzen sie an der Position ein, an der Sie die neue Tabelle erstellen möchten. Um zwei Tabellen zusammenzufassen, schneiden Sie die Reihen und Spalten der einen Tabelle aus und fügen sie in die andere Tabelle ein.

So kopieren oder verschieben Sie Reihen oder Spalten:

    1. Wählen Sie die betreffenden Reihen oder Spalten aus und führen Sie eine der folgenden Aktionen aus:

    Um die Reihen oder Spalten zu kopieren, wählen Sie "Bearbeiten > Kopieren".

    Um die Reihen oder Spalten zu verschieben, wählen Sie "Bearbeiten > Ausschneiden", klicken auf "Zellen entfernen" und auf "Ausschneiden".

    2. Klicken Sie in die Zelle, neben der Sie die Reihen oder Spalten einfügen wollen, und wählen Sie "Bearbeiten > Einfügen". Sie können sie entweder neben der aktuellen Reihe oder Spalte einfügen oder die aktuelle Reihe oder Spalte ersetzen.

Zum Verschieben einer Reihe können Sie auch das Elementrechteck der Reihe in der Strukturansicht mit der Maus ziehen. Zum Kopieren der Reihe halten Sie beim Ziehen mit der Maus die Alt-Taste (Windows) oder die Control- und die mittlere Maustaste (UNIX) gedrückt. Weitere Informationen finden Sie unter Kopieren von Elementen.


FrameMaker-Tabellen / Anpassen von Reihen und Spalten

Ändern der Spaltengröße

Am schnellsten kann die Spaltenbreite verändert werden, wenn Sie eine Spaltenbegrenzung mit der Maus ziehen. Sie können auch mithilfe eines Dialogfensters die Größe exakt festlegen oder eine Spaltenbreite kopieren und einfügen, um diese Breite in derselben oder einer anderen Tabelle zu duplizieren.

So ändern Sie die Spaltengröße durch Ziehen mit der Maus:

Führen Sie eine der folgenden Aktionen aus:

    Um die Spaltenbreite zu ändern, wählen Sie eine Zelle in der Spalte aus und ziehen den Auswahlpunkt, bis die Spalte die gewünschte Breite hat.

Ändern der Spaltenbreite durch Ziehen eines Auswahlpunktes

Verändern der Größe mehrerer ausgewählter Spalten

    Um die Begrenzungslinie zwischen zwei Spalten so zu ändern, dass die eine Spalte breiter und die andere schmaler wird, halten Sie beim Ziehen eines Auswahlpunktes die Alt-Taste (Windows) oder die Umschalttaste (UNIX) gedrückt. Die Gesamtbreite der Tabelle wird dadurch nicht verändert.

Um die Begrenzungslinien am Magnetraster auszurichten, wählen Sie vor Ändern der Breite die Option "Grafik > Magnetraster".

So geben Sie eine genaue Spaltenbreite an:

    1. Wählen Sie in den zu ändernden Spalten einzelne Zellen aus und wählen Sie "Tabelle > Spaltenbreite ändern" (zum Ändern einer einzelnen Spalte brauchen Sie nur in die Spalte zu klicken).

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie die Breite direkt festlegen wollen, klicken Sie auf "Breite" und geben den gewünschten Wert ein.

    Wenn Sie die Breite auf einen bestimmten Prozentsatz des ursprünglichen Werts setzen wollen, klicken Sie auf "Skalieren" und geben den gewünschten Prozentwert ein.

    Wenn Sie der Spalte die Breite einer anderen Spalte in der Tabelle zuweisen wollen, klicken Sie auf "Breite der Spalte" und geben die betreffende Spaltennummer ein.

    Wenn die Spalten gleichmäßig auf eine bestimmte Gesamtbreite aufgeteilt werden sollen, klicken Sie auf "Gleiche Breite mit insgesamt" und geben die Gesamtbreite ein.

    Wenn Sie bei einer neuen Gesamtbreite die Spaltenproportionen beibehalten wollen, klicken Sie auf "Skalieren auf Gesamtbreite von" und geben die gewünschte Gesamtbreite ein.

    Wenn Sie die Breite des breitesten Absatzes oder Rahmens in den ausgewählten Zellen übernehmen wollen, klicken Sie auf "Breite der aktuellen Zelleninhalte" und geben eine maximale Breite ein.

    3. Klicken Sie auf "Ändern".

So kopieren Sie eine Spaltenbreite und fügen sie wieder ein:

    1. Klicken Sie in die Spalte, deren Breite Sie kopieren wollen.

    2. Wählen Sie "Bearbeiten > Kopieren Spezial > Spaltenbreite".

    3. Klicken Sie in die Spalte, die Sie ändern möchten, und wählen Sie "Bearbeiten > Einfügen". Dabei wird nur die Spaltenbreite übernommen, die Inhalte der Zellen bleiben unverändert.


FrameMaker-Tabellen / Anpassen von Reihen und Spalten

Anpassen der Reihenhöhe

Die Höhe einer Reihe passt sich automatisch an den Zelleninhalt an. Sie können sie jedoch noch weiter vergrößern. Sie können auch für alle Reihen in einer Tabelle dieselbe Höhe verwenden.

Hinweis: In einem strukturierten Dokument beeinflusst das Anpassen einer Reihenhöhe die Tabellenstruktur nicht; die Änderung stellt keine irreguläre Formatzuweisung dar.

So passen Sie die Höhe einer Reihe an:

    1. Klicken Sie in die zu ändernde Reihe und wählen Sie "Tabelle > Reihenformat".

    2. Geben Sie die minimale und maximale Reihenhöhe ein und klicken Sie auf "Zuweisen".

So weisen Sie allen Reihen dieselbe Höhe zu:

    1. Bestimmen Sie die Höhe der höchsten Reihe in der Tabelle. Gehen Sie, entsprechend des Betriebssystems, wie folgt vor:

    (Windows) Halten Sie die Alt- und die Umschalttaste gedrückt, während Sie einen Auswahlrahmen um die Reihe zeichnen.

    (UNIX) Halten Sie die Control- und die Umschalttaste gedrückt, während Sie einen Auswahlrahmen um die Reihe zeichnen.

    2. Achten Sie auf die in der Statuszeile angezeigte Höhe.

    3. Wählen Sie die gesamte Tabelle aus und anschließend "Tabelle > Reihenformat".

    4. Geben Sie den zuvor notierten Wert als minimale Reihenhöhe ein und klicken Sie auf "Zuweisen".

Wenn sich die Zellenhöhe durch Bearbeiten des Inhalts ändert, müssen Sie diesen Vorgang eventuell wiederholen.


FrameMaker-Tabellen / Anpassen von Reihen und Spalten

Verbinden und Trennen von Zellen

Sie können mehrere Zellen horizontal zu einer einzelnen Zelle zusammenfügen, die mehrere Spalten miteinander verbindet, oder mehrere Zellen vertikal zu einer einzelnen Zelle zusammenfügen, die mehrere Reihen miteinander verbindet. Text und Grafiken fließen über die Zellgrenzen hinaus, als würde die verbundene Zelle nur aus einer Zelle bestehen.

A: Zelle, die Reihen verbindet B: Zelle, die Spalten verbindet

Wenn Sie Zellen mit Inhalt verbinden, werden auch die Inhalte dieser Zellen zusammengefügt. Für jede zusammengefügte Zelle wird ein einzelner Absatz erstellt. Zellen können auch getrennt werden.

So verbinden Sie Zellen über mehrere Reihen oder Spalten:

Wählen Sie die entsprechenden Zellen aus und anschließend "Tabelle > Verbinden".

So trennen Sie eine Zelle:

Wählen Sie die verbundene Zelle aus und wählen Sie dann "Tabelle > Trennen". Der Inhalt der verbundenen Zelle wird nicht wieder in den Originalzellen angezeigt, sondern in der neuen Zelle links oben.


FrameMaker-Tabellen

Sortieren von Spalten und Reihen

Die Zellen von Spalten oder Reihen können in aufsteigender oder absteigender Reihenfolge neu sortiert werden. Bei aufsteigender Reihenfolge werden die Zellen vom Anfang des Alphabets oder von der kleinsten Zahl an sortiert. Bei absteigender Reihenfolge beginnt die Sortierung am Ende des Alphabets bzw. mit der größten Zahl.

Originaltabelle (links) und nach der ersten Spalte sortierte Tabelle (rechts)

Zahlen werden ihrem numerischen Wert entsprechend sortiert. "124" wird in einer Zahlenliste beispielsweise nach "23" aufgeführt. Beim Sortieren von Zahlen werden Währungssymbole ignoriert, negative Vorzeichen werden jedoch berücksichtigt Bei aufsteigender Sortierreihenfolge wird -9 oder (9) vor 9 aufgeführt. Trennzeichen für Kommas und mehrstellige Zahlen werden den Ländereinstellungen für Zahlen und Währungen Ihres Systems entsprechend angezeigt.

Beim Sortieren wird Text immer nach Zahlen eingeordnet. Zeichenfolgen in Tabellen werden gemäß der Standardspracheinstellung des Systems sortiert.

Datums- und Zeitangaben können sortiert werden, wenn sie als Text in einheitlichem Format und mit führenden Nullen eingegeben werden. Wenn Sie beispielsweise die Formate tt/mm/jjjj und hh:mm:ss verwenden, geben Sie 04/12/2017 oder 09:30:25 ein.

So sortieren Sie eine Tabelle:

    1. Speichern Sie Ihr Dokument (damit Sie die letzte gespeicherte Version wiederherstellen können, wenn die Sortierung unerwünschte Ergebnisse liefert).

    2. Stellen Sie sicher, dass die Tabelle keine ausgeblendeten bedingten Reihen enthält (über "Spezial > Bedingter Text").

    3. Führen Sie eine der folgenden Aktionen aus:

    Um alle Spalten oder alle Reihen zu sortieren, klicken Sie an beliebiger Stelle in die Tabelle.

    Wenn Sie nur bestimmte Reihen sortieren wollen, wählen Sie einzelne Zellen in diesen Reihen aus.

    4. Wählen Sie "Tabelle > Sortieren".

    5. Aktivieren Sie "Alle Reihen im Standardteil auswählen", wenn Sie alle Reihen oder Spalten sortieren wollen.

    6. Führen Sie einen der folgenden Schritte aus:

    Um die Reihen der Tabelle zu sortieren, klicken Sie auf "Reihen sortieren". Wenn die Reihen Kopf- oder Fußzellen sowie Standardzellen enthalten, werden nur die Standardzellen sortiert.

    Um die Spalten der Tabelle zu sortieren, klicken Sie auf "Spalten sortieren".

    7. Sollen Großbuchstaben getrennt von den Kleinbuchstaben sortiert werden, wählen Sie "Groß- und Kleinschreibung beachten".

Aufsteigende Sortierung mit und ohne Berücksichtigung der Groß- und Kleinschreibung

    8. Geben Sie im Textfeld "Sortieren nach" einen primären Sortierschlüssel an und klicken Sie auf "Aufsteigende Reihenfolge" oder "Absteigende Reihenfolge".

Sie können auch verbundene Zellen sortieren, wenn diese nicht über eine Reihe oder Spalte hinausgehen, die Sie als Sortierschlüssel verwenden. Verwenden Sie in diesem Fall "Tabelle > Trennen" und versuchen Sie es erneut.

    9. Wählen Sie optional unter "Dann nach" einen zweiten oder dritten Sortierschlüssel aus.

    10. Klicken Sie auf "Sortieren".

Hinweis: Adobe FrameMaker sortiert Zahlen mit den vorangestellten Sonderzeichen ()+-,. oder $ ordnungsgemäß. Wenn jedoch mehrere dieser Symbole in einer Zelle vorhanden sind, kann die korrekte Sortierung beeinträchtigt werden. Eine Zelle, die -2 enthält wird korrekt zwischen -1 und -3 eingeordnet, nicht jedoch eine Zelle, die -2+3 enthält (diese wird als -23 interpretiert).

Hinweis: Die Funktion zum Sortieren in Tabellen unterstützt den Unicode-Standard zur Textcodierung.


FrameMaker-Tabellen

Drehen von Zellen und Tabellen

Wenn Sie eine Zelle in einer Tabelle drehen, können Sie in diese Zelle Text eingeben, genau wie in jede andere Zelle.

Sie können auch eine ganze Tabelle drehen, indem Sie diese in einen verankerten, gedrehten Rahmen platzieren. Die gedrehte Tabelle kann sich auf einer Seite mit nicht gedrehtem Text oder auf einer gedrehten Seite befinden (wenn diese eine gedrehte Vorgabeseite verwendet). Wenn auch Hintergrundobjekte (wie Kopf- und Fußzeilen und Fließtext) mit der Tabelle zusammen gedreht werden sollen, müssen Sie die Tabelle auf einer gedrehten Seite platzieren, anstatt die Tabelle zu drehen. Tabellen können auf gedrehten Seiten nicht bearbeitet werden.

Tabelle auf einer gedrehten Seite (links) und Tabelle in einem gedrehten, verankerten Rahmen (rechts)

So drehen Sie eine Zelle:

    1. Wählen Sie die zu drehenden Zellen aus und anschließend die Option "Grafik > Drehen".

    2. Geben Sie die gewünschte Ausrichtung der Zellen an und klicken Sie auf "Drehen".

Gedrehte Zellen können Platz sparen.

Wenn Sie Text in eine gedrehte Zelle eingeben, vergrößert sich zwar die Zellenhöhe, es erfolgt aber kein Textumbruch. Sie können die Höhe von gedrehten Zellen beschränken, damit bei Erreichen des Höchstwertes der Text umbrochen wird. Weitere Informationen finden Sie unter Anpassen der Reihenhöhe.

So fügen Sie eine gedrehte Tabelle auf einer Seite mit nicht gedrehtem Text ein:

    1. Fügen Sie einen verankerten Rahmen ein (siehe Erstellen verankerter Rahmen) und zeichnen Sie in diesen einen Textrahmen. Informationen über das Hinzufügen eines Textrahmens finden Sie unter Grafiken und Text.

    2. Fügen Sie die Tabelle in den Textrahmen ein. Weitere Informationen finden Sie unter Einfügen von Tabellen.

    3. Wählen Sie den Textrahmen aus, wählen Sie "Grafik > Drehen" und drehen Sie den Textrahmen gegen den Uhrzeigersinn. Die Größe des Textrahmens oder des verankerten Rahmens muss möglicherweise angepasst werden, um die Tabelle vollständig anzeigen zu können.

Wenn Sie die Tabelle bearbeiten wollen, heben Sie die Drehung des Textrahmens auf, nehmen Sie die Änderungen vor und drehen Sie den Textrahmen dann erneut.

So erstellen Sie eine gedrehte Tabelle auf einer Seite mit dem anderen gedrehten Text:

Erstellen Sie eine gedrehte Vorgabeseite und weisen Sie sie der Arbeitsseite zu, die die Tabelle enthält.

Einzelheiten finden Sie unter Erstellen einer gedrehten Vorgabeseite und Zuweisen von Vorgabeseiten zu Arbeitsseiten. Wird die Tabelle durch Änderungen im Dokument auf eine andere Seite verschoben, müssen Sie die Vorgabeseiten erneut zuweisen.


FrameMaker-Tabellen

Steuern von Seitenumbrüchen in Tabellen

Wenn nicht alle Reihen einer Tabelle in eine Textspalte passen, werden diese auf die nächste Seite oder in die nächste Spalte verschoben. Sie können festlegen, wie die Tabelle zwischen Seiten oder Spalten umbricht. So können Sie z. B. die Mindestanzahl der Reihen für eine Seite oder Spalte angeben oder festlegen, dass zwei Reihen immer zusammen auf derselben Seite oder in derselben Spalte bleiben. Sie können auch einen Umbruch in einer beliebigen Tabellenreihe erzwingen.

Beim Einfügen einer neuen Tabelle bestimmt das Tabellenformat die minimale Anzahl der Reihen in einer Spalte oder auf einer Seite. Diesen Wert können Sie im Fenster "Tabellengestaltung" ändern.

Das Zusammenhalten zweier Reihen und das Festlegen eines Seitenumbruchs gehört dagegen nicht zum Format, sondern wird von Fall zu Fall vorgenommen. Wenn Sie ein anderes Format auf die Tabelle anwenden, werden diese Einstellungen nicht überschrieben.

Informationen dazu, wie Sie den Tabellenanfang auf einer Seite oder in einer Spalte festlegen, finden Sie im Abschnitt Festlegen der Anfangsposition von Tabellen.


FrameMaker-Tabellen / Steuern von Seitenumbrüchen in Tabellen

Festlegen einer Mindestanzahl von Reihen auf einer Seite

Passt eine Tabelle nicht auf eine Seite oder in eine Spalte, wird der Umbruch anhand der Reihenkontrolle für die Tabelle durchgeführt. Diese Einstellung legt fest, wie viele Standardreihen mindestens auf einer Seite oder in einer Spalte zusammenbleiben müssen.

Bei der Tabelle in der folgenden Abbildung hat die Einstellung "Reihenkontrolle" den Wert 3. Daher müssen sich mindestens drei Standardreihen auf jeder Seite befinden. Ist auf der ersten Seite nicht genügend Platz für drei Reihen, wird die gesamte Tabelle auf die nächste Seite verschoben.

Hinweis: Änderungen an Seitenumbrüchen beeinflussen die Struktur einer Tabelle in strukturierten Dokumenten nicht. Die Formatregeln werden nicht außer Kraft gesetzt.

So legen Sie die Mindestanzahl von Reihen auf einer Seite oder in einer Spalte fest:

    1. Klicken Sie in die zu ändernde Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. Geben Sie in den Basis-Einstellungen im Fenster "Tabellengestaltung" in das Textfeld "Reihenkontrolle" die Reihenanzahl ein. Die Zahl muss zwischen 1 und 255 liegen.

    3. Klicken Sie auf "Der Auswahl zuweisen".

Wenn Sie für "Reihenkontrolle" einen relativ hohen Wert angeben (z. B. 99), wird die Tabelle nicht in die nächste Seite oder Spalte umbrochen.


FrameMaker-Tabellen / Steuern von Seitenumbrüchen in Tabellen

Zusammenhalten von Reihen

Sie können festlegen, dass eine bestimmte Reihe stets mit der vorherigen oder darauf folgenden Reihe zusammen erscheint.

So halten Sie Reihen zusammen:

    1. Wählen Sie die Reihe aus, die Sie mit der vorhergehenden oder nächsten Reihe zusammenhalten wollen, und wählen Sie "Tabelle > Reihenformat".

    2. Wählen Sie unter "Umbruch mit" die Option "Nächster Reihe" oder "Vorheriger Reihe" und klicken Sie auf "Zuweisen".


FrameMaker-Tabellen / Steuern von Seitenumbrüchen in Tabellen

Umbrechen von Tabellen an einer bestimmten Position

Tabellen oder Absätze können am Anfang einer Seite oder Spalte beginnen. Dasselbe trifft für eine bestimmte Reihe in einer Tabelle zu. Wenn Sie es wünschen, können Sie den Seitenumbruch später wieder entfernen.

So fügen Sie einer Tabelle einen Seitenumbruch hinzu oder entfernen ihn:

    1. Klicken Sie in die betreffende Reihe und wählen Sie "Tabelle > Reihenformat".

    2. Führen Sie eine der folgenden Aktionen aus:

    Um die Reihe an den Anfang der nächsten Spalte zu verschieben, wählen Sie aus dem Aufklappmenü "Reihenbeginn" die Option "Spaltenbeginn" oder eine der Optionen unter "Seitenbeginn".

    Um einen Seitenumbruch zu entfernen, wählen Sie aus dem Aufklappmenü "Reihenbeginn" die Option "Beliebig".

    3. Klicken Sie auf "Zuweisen".


FrameMaker-Tabellen

Positionierung und automatische Nummerierung von Text in Zellen

Beim Einfügen einer neuen Tabelle wird der Zellenrand (Abstand zwischen den Zellen und dem Zellentextrahmen) durch das Tabellenformat bestimmt. Die Einstellungen für den Texteinzug in der Zelle, der von den Zellenrändern gemessen wird, sind Bestandteil des Absatzformats des Texts.

A: Linke Zellenränder
B: Linker Absatzeinzug

Sie können den Standardzellenrand einer Tabelle ändern sowie die Randeinstellungen und die vertikale Ausrichtung des Textes in einzelnen Zellen anpassen. Sie können auch die Richtung der automatischen Nummerierung in Zellen festlegen, sodass sie entweder nach Reihen oder nach Spalten erfolgt.


FrameMaker-Tabellen / Positionierung und automatische Nummerierung von Text in Zellen

Festlegen von Standardrändern für Zellen

Der Standardzellenrand gilt für alle Zellen in einer Tabelle.

So legen Sie den Standardzellenrand für eine Tabelle fest:

    1. Klicken Sie in die zu ändernde Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. Geben Sie in den Basis-Einstellungen im Fenster "Tabellengestaltung" unter "Standardrand der Zellen" die Werte für den oberen, unteren, linken und rechten Rand ein.

    3. Klicken Sie auf "Der Auswahl zuweisen".

Wenn der Text vertikal zentriert werden soll, geben Sie für den oberen Rand einen größeren Wert als für den unteren Rand ein. Legen Sie für den oberen Rand z. B. 5 Punkt und für den unteren Rand 3 Punkt fest.


FrameMaker-Tabellen / Positionierung und automatische Nummerierung von Text in Zellen

Anpassen von Zellenrändern

Sie können im Fenster "Tabellengestaltung" die Standardeinstellungen für einzelne Zellen ändern. Wenn Sie die Zellenränder in einer Tabelle auf diese Weise ändern und der Tabelle später ein neues Format zuweisen, werden die Zellenränder nicht durch die Standardränder des neuen Formats überschrieben.

Die speziellen Zellenränder sind Teil des Absatzformats und werden daher normalerweise nicht gemeinsam mit dem Format im Tabellenformat-Katalog gespeichert. Die Absatzformate des ersten Titelabsatzes und die ersten Absätze in den Kopf-, Fuß- und Standardreihen der einzelnen Spalten werden jedoch gespeichert. Wenn Sie die Zellenränder dieser Absätze anpassen und das Tabellenformat dann im Katalog speichern, übernehmen alle anschließend erstellten Tabellen dieses Tabellenformats die Einstellungen als Standardwerte.

So passen Sie einen Zellenrand an:

    1. Klicken Sie in den ersten Absatz der Zelle, deren Rand Sie ändern wollen.

    2. Wählen Sie "Format > Absätze > Gestaltung", um das Dialogfenster "Absatzgestaltung" zu öffnen.

    3. Wählen Sie aus dem Aufklappmenü "Einstellungen" den Eintrag "Zelle".

    4. Geben Sie unter "Zellenrand" die zu ändernden Randeinstellungen an, indem Sie eine der folgenden Aktionen ausführen:

    Um einen Rand relativ zum Standardzellenrand zu erstellen, wählen Sie aus dem Aufklappmenü "Von Tabellenformat, plus" und geben den gewünschten Wert an.

    Um einen festen, ab der Zellenkante gemessenen Rand zu erzeugen, wählen Sie aus dem Aufklappmenü "Spezial" und geben den gewünschten Wert ein.

    5. Klicken Sie auf "Der Auswahl zuweisen".


FrameMaker-Tabellen / Positionierung und automatische Nummerierung von Text in Zellen

Anpassen der vertikalen Ausrichtung von Text

Im Fenster "Absatzgestaltung" können Sie die vertikale Standardausrichtung einzelner Zellen ändern. Wenn Sie die vertikale Ausrichtung in einer Tabelle auf diese Weise ändern und der Tabelle später ein neues Format zuweisen, werden Ihre Ausrichtungseinstellungen nicht durch die Ausrichtungsränder des neuen Formats überschrieben.

Obere, mittlere und untere vertikale Ausrichtung

Sie können die vertikale Ausrichtung für einzelne Zellen (Oben, Mitte, Unten) festlegen. Wenn Sie die vertikale Ausrichtung in einer Tabelle ändern und der Tabelle später ein neues Format zuweisen, werden Ihre Ausrichtungseinstellungen nicht durch die neuen Standardeinstellungen für die Ausrichtung überschrieben.

Die Ausrichtungseinstellungen sind Teil des Absatzformats und werden daher normalerweise nicht mit dem im Tabellenformat-Katalog enthaltenen Format gespeichert. Die Absatzformate des ersten Absatzes in den Kopf-, Fuß- und Standardreihen der Spalten werden jedoch gespeichert. Wenn Sie die Ausrichtung dieser Absätze anpassen und das Tabellenformat dann im Katalog speichern, übernehmen alle anschließend erstellten Tabellen dieses Tabellenformats die Einstellungen als Standardwerte.

So ändern Sie die vertikale Ausrichtung von Text in einer Zelle:

    1. Klicken Sie in die zu ändernde Zelle.

    2. Wählen Sie "Format > Absätze > Gestaltung", um das Dialogfenster "Absatzgestaltung" zu öffnen.

    3. Wählen Sie aus dem Aufklappmenü "Einstellungen" den Eintrag "Zelle" und dann aus dem Aufklappmenü "Vertikale Zellenausrichtung" die Option "Oben", "Mitte" oder "Unten".

    4. Klicken Sie auf "Der Auswahl zuweisen".


FrameMaker-Tabellen / Positionierung und automatische Nummerierung von Text in Zellen

Festlegen der Richtung für die automatische Nummerierung

Beim Einfügen einer neuen Tabelle wird die Richtung der automatischen Nummerierung in Zellen (nach Reihen oder Spalten) durch das Tabellenformat bestimmt. Diese Einstellung legt auch die Richtung der automatischen Nummerierung für Tabellenfußnoten fest.

Automatische Nummerierung nach Reihen oder Spalten

So ändern Sie die Richtung der automatischen Nummerierung in einer Tabelle:

    1. Klicken Sie in die zu ändernde Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. Wählen Sie in den Basis-Einstellungen im Fenster "Tabellengestaltung" aus dem Aufklappmenü "Nummerierung" den Eintrag "Reihenweise" oder "Spaltenweise".

    3. Klicken Sie auf "Der Auswahl zuweisen".


FrameMaker-Tabellen

Arbeiten mit Lineatur und Schattierung

Durch Verwendung von Lineaturen und Schattierungen lassen sich ansprechendere und wirkungsvollere Tabellen erstellen. Sie können z. B. eine Lineatur für die Umrandung einer Tabelle verwenden und die Schattierung nur in den Kopfzellen einsetzen. Sie können aber auch eine Lineatur verwenden, um sämtliche Zellen in einer Tabelle zu trennen, und die Schattierung für alle anderen Standardreihen einsetzen.

Alle Zellen sind durch Linien getrennt, jede zweite Standardreihe ist schattiert.

Beim Einfügen einer neuen Tabelle werden die Standardlineatur und die Schattierung durch das Tabellenformat bestimmt. Diese Einstellungen wirken sich auf ganze Reihen und Spalten aus und unterliegen einem festen Wiederholungsmuster. Im Fenster "Tabellengestaltung" können Sie Lineatur und Schattierung eines Formats für einzelne Tabellen ändern, die dieses Format verwenden.

Sie können für eine Tabelle auch eine spezielle Lineatur und Schattierung festlegen. Spezielle Lineaturen und Schattierungen sind nicht auf Reihen oder Spalten beschränkt und kein Bestandteil des Tabellenformats. Wenn Sie die Lineatur oder Schattierung einer Tabelle ändern und später der Tabelle ein anderes Format zuweisen, wird die Lineatur oder die Schattierung dadurch nicht überschrieben.


FrameMaker-Tabellen / Arbeiten mit Lineatur und Schattierung

Definieren der Standardlineatur

Sie können ein Lineaturmuster für Spalten, Standard-, Kopf- und Fußreihen sowie für die Umrandung einer Tabelle festlegen. Wenn Sie beginnend bei einer bestimmten Stelle in der Tabelle ein anderes Muster verwenden wollen, verwenden Sie eine spezielle Einstellung (siehe Anpassen der Lineatur).

Ändern der Tabellenlineatur

So definieren oder entfernen Sie die Standardlineatur:

    1. Klicken Sie in die zu ändernde Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. Legen Sie in den Lineatur-Einstellungen im Fenster "Tabellengestaltung" den Lineaturstil für Spalten, Standard-, Kopf- und Fußreihen sowie die Umrandung fest.

    3. Klicken Sie auf "Der Auswahl zuweisen".


FrameMaker-Tabellen / Arbeiten mit Lineatur und Schattierung

Anpassen der Lineatur

Die Lineatur kann für einzelne Zellen, Reihen oder Spalten geändert werden. Im Gegensatz zur Standardlineatur einer Tabelle wird die spezielle Lineatur nicht als Bestandteil des Tabellenformats gespeichert. Besteht zwischen der Standardeinstellung und der speziellen Schattierung ein Konflikt, hat die spezielle Einstellung Vorrang.

So passen Sie die Lineatur an oder entfernen die spezielle Lineatur:

    1. Wählen Sie die Zellen, Reihen oder Spalten aus, die Sie anpassen möchten.

    2. Wählen Sie "Tabelle > Lineatur/Schattierung".

    3. Wählen Sie einen speziellen Lineaturstil aus bzw. die Option "Von Tabelle", um die spezielle Lineatur zu entfernen.

Die Auswahlliste enthält die vordefinierten Lineaturstile des Dokuments. Weitere Informationen hierzu finden Sie unter Erstellen oder Bearbeiten von Lineaturstilen.

    4. Geben Sie im Bereich "Für Auswahl" die Elemente der aktuellen Auswahl an, die Sie ändern wollen.

    5. Deaktivieren Sie "Spezielle Zellenschattierung", damit nicht versehentlich Schattierungseinstellungen geändert werden.

    6. Klicken Sie auf "Zuweisen".


FrameMaker-Tabellen / Arbeiten mit Lineatur und Schattierung

Erstellen oder Bearbeiten von Lineaturstilen

Sie können weitere Lineaturstile (z. B. doppelte, dicke oder dünne Lineaturen) erstellen und bearbeiten oder vorhandene Lineaturstile löschen. Wenn Sie einen Lineaturstil bearbeiten, gelten die Änderungen sowohl für die Standardlineatur als auch für die spezielle Lineatur, die diesen Stil verwendet.

Beim Bearbeiten von Lineaturstilen sollten Sie die Darstellung vergrößern. Dadurch können Sie geringfügige Unterschiede in Linienstärken leichter erkennen.

So erstellen oder bearbeiten Sie Lineaturstile:

    1. Wählen Sie "Tabelle > Lineatur/Schattierung".

    2. Wählen Sie den zu bearbeitenden Lineaturstil aus der Auswahlliste aus. Wenn Sie einen neuen Stil erstellen wollen, wählen Sie einen Lineaturstil, der Ihren Vorstellungen am nächsten kommt.

    3. Klicken Sie auf "Lineaturstil ändern".

    4. Geben Sie die Breite ein und wählen Sie eine Farbe und ein Muster für den Lineaturstil.

    5. Legen Sie mit "Eine" oder "Zwei" eine einfache oder doppelte Linie fest. Wenn Sie auf "Zwei" klicken, müssen Sie auch den Abstand zwischen den beiden Linien eingeben.

    6. Geben Sie beim Erstellen eines neuen Stiles einen Namen in das Textfeld "Name" ein.

    7. Klicken Sie auf "Zuweisen".

So entfernen Sie einen Lineaturstil:

    1. Wählen Sie "Tabelle > Lineatur/Schattierung".

    2. Wählen Sie den Lineaturstil aus, den Sie entfernen möchten.

    3. Klicken Sie auf "Stil ändern" und dann auf "Löschen". Wenn der Stil für die Standardlineatur einer Tabelle verwendet wurde, wird an den entsprechenden Positionen die Lineatur aufgehoben. Wurde der Stil für eine spezielle Lineatur verwendet, wird die Standardlineatur der Tabelle wiederhergestellt.


FrameMaker-Tabellen / Arbeiten mit Lineatur und Schattierung

Definieren einer Standardschattierung

Sie können eine prozentuale Schattierung für Kopf- und Fußreihen und zwei Prozentwerte für Standardreihen oder Spalten festlegen. Sie können z. B. die Kopfreihen und alle anderen Standardreihen mit jeweils unterschiedlichen Schattierungen füllen. Wenn Sie an einer beliebigen Stelle der Tabelle eine andere Schattierung benötigen, verwenden Sie eine spezielle Einstellung (siehe Anpassen der Schattierung).

Ändern der Tabellenschattierung

So richten Sie eine Standardschattierung ein:

    1. Klicken Sie in die zu ändernde Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. Geben Sie in den Schattierungseinstellungen im Fenster "Tabellengestaltung" die Schattierungswerte für Kopf-, Fuß- und Standardreihen oder Spalten an.

    3. Klicken Sie auf "Der Auswahl zuweisen".


FrameMaker-Tabellen / Arbeiten mit Lineatur und Schattierung

Anpassen der Schattierung

Wie die Lineatur können Sie auch die Schattierung oder Farbe für einzelne Zellen, Reihen oder Spalten anpassen, um bestimmte Tabellenbereiche hervorzuheben. Die spezielle Schattierung einer Tabelle wird nicht als Teil des Tabellenformats gespeichert. Besteht zwischen der Standardeinstellung und der speziellen Schattierung ein Konflikt, hat die spezielle Einstellung Vorrang.

So ändern oder entfernen Sie eine spezielle Schattierung:

    1. Wählen Sie die zu ändernden Zellen, Reihen oder Spalten aus und dann die Option "Tabelle > Lineatur/Schattierung".

    2. Geben Sie den Prozentwert für die Füllung und die Farbe der Schattierung an. Wählen Sie "Von Tabelle", um die spezielle Schattierung zu entfernen.

    3. Damit nicht versehentlich Lineatureinstellungen geändert werden, deaktivieren Sie "Spezielle Zellenlineatur".

    4. Klicken Sie auf "Zuweisen".


FrameMaker-Tabellen / Arbeiten mit Lineatur und Schattierung

Anzeigen der Lineatur- und Schattierungseinstellungen einer Zelle

Da Standardlineatur, spezielle Lineatur und Schattierung zusammen eingesetzt werden, müssen Sie unter Umständen ermitteln, um welche Einstellung es sich handelt.

So zeigen Sie die Lineatur- und Schattierungseinstellungen einer Zelle an:

    1. Wählen Sie die Zellen, Reihen oder Spalten mit den Lineatur- und Schattierungseinstellungen aus, die Sie anzeigen möchten.

    2. Wählen Sie "Tabelle > Lineatur/Schattierung" und klicken Sie auf "Aktuelle Einstellungen".

Der Eintrag "Gemischt" im Dialogfenster bedeutet, dass für die ausgewählten Zellen mehrere spezielle Lineaturstile, Füllungen oder Farben verwendet werden. Der Eintrag "Von Tabelle" gibt an, dass die ausgewählten Zellen die im Fenster "Tabellengestaltung" festgelegte Standardlineatur und -schattierung verwenden.


FrameMaker-Tabellen

Neudefinieren und Aktualisieren von Tabellenformaten

Bei der Schablonengestaltung oder wenn ein bestimmtes Format in den Dokumenten nicht vorhanden ist, können Sie ein Tabellenformat für das gesamte Dokument neu definieren (aktualisieren).

Um ein Tabellenformat zu ändern, ändern Sie die Einstellungen einer Tabelle und anschließend das entsprechende Katalogformat.

Die Einstellungen, die dem Katalogformat zugewiesen werden, umfassen neben den im Fenster "Tabellengestaltung" angegebenen Einstellungen auch die Standardeinstellungen, die dort nicht festgelegt werden, z. B. die Standardabsatzformate (siehe Erläuterung von Tabellen). Die im Fenster "Tabellengestaltung" festgelegten Einstellungen (aber nicht die Standardeinstellungen) werden auch für vorhandene Tabellen im Dokument verwendet, die denselben Typ aufweisen.

Wenn Sie im Fenster "Tabellengestaltung" vorgenommene Änderungen verwerfen möchten, ohne das Format zu aktualisieren, können Sie den Vorgang abbrechen und die Einstellungen zurücksetzen, indem Sie einfach in den Text klicken. Im Dialogfenster selbst können Sie zu diesem Zweck aus dem Aufklappmenü "Befehle" den Eintrag "Einstellungen der Auswahl übernehmen" wählen.

So definieren Sie ein Tabellenformat neu:

    1. Klicken Sie in die Tabelle, deren Format Sie neu definieren wollen, und wählen Sie "Tabelle > Tabellengestaltung". Wenn die Tabelle Spezialformate enthält, werden diese (nicht die Definition des Katalogformats) im Fenster "Tabellengestaltung" angezeigt.

    2. Soll das geänderte Format auf einem Katalogformat basieren (ohne Spezialformate), wählen Sie den Formattyp aus dem Aufklappmenü "Tabellentyp", auch wenn der gewünschte Typ bereits im Textfeld "Tabellentyp" angezeigt wird.

    3. Führen Sie folgende Schritte durch:

    Ändern Sie im Fenster "Tabellengestaltung" die gewünschten Einstellungen für "Basis", "Lineatur" und "Schattierung".

    Ändern Sie die gewünschten Standardeinstellungen. z. B. die Anzahl der Reihen und Spalten, die Spaltenbreite und das Absatzformat des Titels sowie des jeweils ersten Absatzes einer Spalte. Diese Einstellungen werden beim ersten Einfügen einer leeren Tabelle verwendet (siehe Zuweisen anderer Tabellenformate).

    4. Klicken Sie auf "Alle aktualisieren". Wenn eine der aktualisierten Tabellen irreguläre Formate aufweist, werden Sie in einem Meldungsfenster gefragt, ob diese entfernt werden sollen.


FrameMaker-Tabellen / Neudefinieren und Aktualisieren von Tabellenformaten

Gleichzeitiges Ändern von Einstellungen in mehreren Tabellenformaten

Sie können bestimmte Einstellungen in mehreren Tabellenformaten gleichzeitig ändern. Sie können z. B. alle Tabellenformate von zentriert zu linksbündig ändern. Sie können diese Änderungen in einer einzigen Operation durchführen und müssen nicht jedes Format einzeln aktualisieren.

So ändern Sie bestimmte Einstellungen in mehreren Tabellenformaten:

    1. Wählen Sie die Tabellen aus, deren Formate Sie neu definieren möchten, indem Sie einen der folgenden Schritte ausführen:

    Soll das Format aller Tabellen im Dokument aktualisiert werden, klicken Sie in eine beliebige Tabelle.

    Sollen einige, aber nicht alle Tabellenformate im Dokument aktualisiert werden, wählen Sie aufeinander folgende Tabellen mit den zu ändernden Formaten aus. (Um mehrere Tabellen auszuwählen, wählen Sie deren Ankersymbole aus.)

    2. Wählen Sie im Fenster "Tabellengestaltung" die zu ändernde Einstellungsgruppe aus.

    3. Ändern Sie die Einstellungen wie gewünscht.

    4. Wählen Sie im Aufklappmenü "Befehle" den Eintrag "Optionen für globale Aktualisierung".

    5. Wählen Sie die Tabellenformate, denen Sie die Einstellungen zuweisen möchten.

    6. Klicken Sie im Bereich "Einstellungen der Tabellengestaltung verwenden" auf die aktuelle Einstellungsgruppe und dann auf "Aktualisieren". Wenn eine der aktualisierten Tabellen irreguläre Formate aufweist, werden Sie in einem Meldungsfenster gefragt, ob diese entfernt werden sollen.

FrameMaker weist die Einstellungen den angegebenen Formaten im Tabellenformat-Katalog und allen Tabellen zu, die diese Formate verwenden.


FrameMaker-Tabellen / Neudefinieren und Aktualisieren von Tabellenformaten

Aktualisieren von Tabellenformaten mit einer Einstellungsgruppe

Sie können eine Einstellungsgruppe aus einem Tabellenformat verwenden, um andere Formate neu zu definieren (aktualisieren). Wenn Sie z. B. die Standardeinstellungen für die Lineatur von allen Tabellen in einem Dokument ändern möchten, können Sie diese für ein Format ändern und die Änderungen auf die anderen Formate im Katalog anwenden, ohne andere Einstellungen ändern zu müssen.

So aktualisieren Sie Tabellenformate mit einer Einstellungsgruppe eines anderen Tabellenformats:

    1. Wählen Sie die Tabellen aus, deren Format Sie neu definieren möchten, indem Sie einen der folgenden Schritte ausführen:

    Soll ein bestimmtes Tabellenformat oder das Format aller Tabellen im Dokument aktualisiert werden, klicken Sie in eine beliebige Tabelle.

    Sollen einige, aber nicht alle Tabellenformate im Dokument neu definiert werden, wählen Sie aufeinander folgende Tabellen aus, deren Formate Sie neu definieren wollen. (Um mehrere Tabellen auszuwählen, wählen Sie deren Ankersymbole aus.)

    2. Wählen Sie im Fenster "Tabellengestaltung" die zu ändernde Eigenschaftsgruppe aus ("Basis", "Lineatur" oder "Schattierung").

    3. Löschen Sie ggf. den Inhalt des Textfelds "Tabellentyp". Dadurch erhält das Textfeld den Wert "Beibehalten", und der Formattyp ändert sich beim Aktualisieren nicht (siehe Verwenden von "Beibehalten").

    4. Ändern Sie die gewünschten Tabelleneinstellungen.

    5. Wählen Sie im Aufklappmenü "Befehle" den Eintrag "Optionen für globale Aktualisierung".

    6. Wählen Sie die Tabellenformate, denen Sie die Einstellungen zuweisen möchten.

    7. Klicken Sie im Bereich "Einstellungen der Tabellengestaltung verwenden" auf die aktuelle Einstellungsgruppe und dann auf "Aktualisieren". Wenn eine der aktualisierten Tabellen irreguläre Formate aufweist, werden Sie in einem Meldungsfenster gefragt, ob diese entfernt werden sollen.

FrameMaker weist die Einstellungen den angegebenen Formaten im Tabellenformat-Katalog und allen Tabellen zu, die diese Formate verwenden.


FrameMaker-Tabellen

Umbenennen und Löschen von Tabellenformaten

Sie können bei der Schablonengestaltung Tabellenformate auch umbenennen oder löschen. Möglicherweise müssen Sie ein Tabellenformat auch dann umbenennen, wenn Sie einen vollständigen Katalog aus einer Schablone kopieren möchten und das Format nicht überschrieben werden soll.

Wenn Sie ein Format aus einem Katalog löschen, wirkt sich das nicht auf die Tabellen dieses Typs aus; das entsprechende Tabellenformat ist dann nicht im Katalog gespeichert. Sie können das Format dieser Tabellen ändern, indem Sie ihnen wieder einen Formattyp zuweisen (siehe Zuweisen anderer Tabellenformate).

So benennen Sie ein Tabellenformat um:

    1. Klicken Sie in eine Tabelle, deren Format Sie umbenennen wollen.

    2. Wählen Sie im Fenster "Tabellengestaltung" aus dem Aufklappmenü "Tabellentyp" das Format, das Sie umbenennen wollen.

Führen Sie diesen Schritt unbedingt aus, auch wenn Sie lediglich den Typ auswählen, der gerade angezeigt wird. Durch das Auswählen eines Typs aus dem Aufklappmenü wird sichergestellt, dass nicht die irregulären, sondern die gespeicherten Formateinstellungen angezeigt werden.

    3. Geben Sie einen neuen Namen in das Textfeld "Tabellentyp" ein und klicken Sie auf "Alle aktualisieren".

    4. Klicken Sie auf "OK".

So entfernen Sie ein Format aus dem Tabellenformat-Katalog:

    1. Wählen Sie im Fenster "Tabellengestaltung" aus dem Aufklappmenü "Befehle" die Option "Format löschen".

    2. Wählen Sie das gewünschte Format aus der Auswahlliste aus und klicken Sie auf "Löschen". Wiederholen Sie diese Schritte, um weitere Formate zu löschen.

    3. Klicken Sie auf "Fertig".


FrameMaker-Tabellen

Definieren von Tabellenformaten

Normalerweise verwenden Sie beim Einfügen von Tabellen eines der bereits im Dokument definierten Formate. Gelegentlich muss ein Tabellenformat überschrieben oder in bestimmten Fällen angepasst werden.

Wenn Sie eigene Schablonen entwerfen oder wenn für einen bestimmten Verwendungszweck kein geeignetes Format vorhanden ist, müssen Sie ein neues Tabellenformat erstellen. Sie können ein neues Format definieren, indem Sie die Einstellungen einer vorhandenen Tabelle ändern und das Format im Tabellenformat-Katalog unter einem anderen Namen speichern.

So erstellen Sie ein neues Tabellenformat:

    1. Klicken Sie in eine Tabelle, deren Format dem zu erstellenden Format ähnelt. (Je ähnlicher das vorhandene Format dem neuen Format ist, um so weniger Änderungen sind erforderlich.)

    2. Richten Sie die Reihen und Spalten ein, indem Sie, wie erwünscht, Standard-, Kopf- und Fußreihen hinzufügen oder löschen und Spalten anpassen. Weitere Informationen finden Sie unter Anpassen von Reihen und Spalten.

    3. Im Fenster "Tabellengestaltung" lassen sich alle Tabelleneinstellungen ändern:

    Die Position im Textrahmen (siehe Positionieren von Tabellen auf einer Seite).

    Der Titel (siehe Hinzufügen oder Entfernen von Tabellentiteln).

    Die Einstellung "Reihenkontrolle" (siehe Steuern von Seitenumbrüchen in Tabellen).

    Die Randeinstellungen für die Zellen (siehe Positionierung und automatische Nummerierung von Text in Zellen).

    Die Lineatur und Schattierung (siehe Arbeiten mit Lineatur und Schattierung).

Setzen Sie keine der Einstellungen auf "Beibehalten". Die Tabellenformate müssen alle angegebenen Eigenschaften aufweisen. Wenn nicht für jede Einstellung ein Wert angegeben ist, wird eine entsprechende Warnmeldung angezeigt. Ändern Sie dann alle auf "Beibehalten" gesetzten Einstellungen.

    4. Erstellen oder ändern Sie im Fenster "Absatzgestaltung" die folgenden Absatzformate, die im Tabellenformat gespeichert werden: die Absatzformate des ersten Titelabsatzes und den ersten Absatz in den Kopf-, Fuß- und Standardreihen der einzelnen Spalten.

    5. Wenn die Tabelle Ihren Wünschen entspricht, wählen Sie im Fenster "Tabellengestaltung" aus dem Aufklappmenü "Befehle" die Option "Neues Format".

    6. Geben Sie in das Textfeld "Typ" einen Namen für das neue Format ein.

    7. Um das Format im Tabellenformat-Katalog zu speichern, aktivieren Sie "In Katalog einfügen".

    8. Um das neue Format der aktuellen Tabelle zuzuweisen, aktivieren Sie "Der Auswahl zuweisen".

    9. Klicken Sie auf "Anlegen".


FrameMaker-Tabellen

Arbeiten mit Tabellen in strukturierten Dokumenten

Strukturierte Tabellen sind in vielerlei Hinsicht mit unstrukturierten Tabellen vergleichbar. Ein großer Teil der Tabellenstruktur wird durch die Definition der enthaltenen Elemente bestimmt. Beim Einfügen einer Tabelle werden gleichzeitig einige Reihen- und Zellenelemente eingefügt, in die Sie Inhalte eingeben können.


FrameMaker-Tabellen / Arbeiten mit Tabellen in strukturierten Dokumenten

Elemente für strukturierte Tabellen und Tabellenteile

Eine Tabelle und ihre Bestandteile (wie Titel, Reihen und Zellen) werden jeweils als ein Element dargestellt. Diese Elemente können Sie in der Strukturansicht anzeigen und bearbeiten.

Tabellen und Tabellenteilelemente

Beim Einfügen eines Tabellenelements werden einige Tabellenteile automatisch eingefügt. Als Richtlinie für das Erstellen der restlichen Tabelle kann der Elementkatalog dienen. Die hinzuzufügenden Tabellenteile können auch eine Anfangsstruktur aufweisen, z. B. enthält ein neues Reihenelement Zellenelemente. Die Anfangsstruktur für dieses Element wird durch Inhaltsregeln für Tabellen und Tabellenteilelemente definiert.

Eine Tabelle kann auch als Leerzellen definierte Zellen enthalten. In diese Zellen können keine gültigen Werte eingegeben werden. Der Elementtyp einer Leerzelle kann die Verwendung der Zelle beschreiben; mögliche Bezeichnungen sind z. B. "LeererKopf" oder "LeereZelle".


FrameMaker-Tabellen / Arbeiten mit Tabellen in strukturierten Dokumenten

Formatierung strukturierter Tabellen

Das Erscheinungsbild einer strukturierten Tabelle wird von deren Tabellenformat, verschiedenen Einstellungen im Menü "Tabelle" und von Absatzformaten für Text bestimmt.

Tabellenformate

Ein Tabellenformat steuert Abstand, Einzug und Ausrichtung einer Tabelle in einer Spalte, die Anfangsposition auf einer Seite, die Position des Titels, die Standardränder für Zellen, die Richtung der automatischen Nummerierung in Zellen sowie die Standardlineatur und Schattierung. Ein Dokument speichert die Tabellenformate in einem Tabellenformat-Katalog.

Die Formatregeln für ein Tabellenelement schlagen mitunter ein bestimmtes Tabellenformat vor. Sie können der Tabelle ein anderes Format zuweisen, entweder beim Erstellen der Tabelle oder später. Die Änderung gilt nicht als irreguläre Formatzuweisung. (Durch das Ändern des Tabellenformats wird die Tabelle jedoch ungültig, wenn durch das Format ein Titel hinzugefügt wird und die Inhaltsregeln der Tabelle dies nicht zulassen.)

Befehle aus dem Menü "Tabelle"

Das Menü "Tabelle" enthält Befehle zum Drehen und Verbinden von Zellen, Ändern der Zellenhöhe und der Seitenumbrüche, zum Hinzufügen von Reihen und Spalten und zur Anwendung von spezieller Lineatur und Schattierung auf Zellen. Diese Einstellungen haben Vorrang vor dem Tabellenformat für bestimmte Zellen.

Alle Befehle des Menüs "Tabelle" lassen sich in einer strukturierten Tabelle verwenden. Die Befehle verursachen keine irregulären Formatzuweisungen und beeinflussen (mit Ausnahme von "Reihen und Spalten einfügen") die Struktur der Tabelle nicht.

Absatzformate

Absatzformate definieren Schriften, Zeilenabstände und andere Einstellungen für Text in Zellen und im Titel. Tabellenteilelemente können bestimmte Absatzformate festlegen.


FrameMaker-Tabellen

Einfügen von strukturierten Tabellen

Bei der Arbeit in einem strukturierten Textfluss wird zum Einfügen einer Tabelle ein Tabellenelement verwendet. Die neue Tabelle erscheint im Dokument mit Elementen für Tabellenteile, z. B. einem Titel, einer Kopfreihe und einigen Standardreihen. Die Elementdefinitionen für die Tabelle und die Tabellenteile legen die Konfiguration der Tabelle fest. Beim Einfügen der Tabelle kann die Anzahl der Reihen und Spalten geändert werden, was jedoch dazu führen kann, dass die Tabelle ungültig wird.

Automatisch eingefügte Tabellenteile

Verwenden Sie zum Hinzufügen anderer Tabellenteilelemente zur Tabelle den Elementkatalog als Richtlinie.

Eine Tabelle wird an einer bestimmten Stelle im Text verankert. Während Sie den Text bearbeiten, verschiebt sich die Tabelle mit dem Text im Dokument. Im Dokumentfenster wird ein Ankersymbol ( [image] ) an der Position angezeigt, an der die Tabelle verankert ist.

Geben Sie beim Einfügen einer Tabelle die Position für die Verankerung an. Sie können die Tabelle z. B. in einem Element "Absatz" (als untergeordnetes Element des Elements "Absatz") oder in einem Abschnittelement (als gleichrangiges Element zu "Absatz" und anderen Elementen im Abschnittelement) verankern. Das jeweilige Vorgehen richtet sich danach, wie die Elemente für das Dokument definiert wurden.

So fügen Sie ein Tabellenelement ein:

    1. Klicken Sie an die Stelle, an der Sie die Tabelle einfügen möchten.

    2. Wählen Sie ein Tabellenelement aus dem Elementkatalog aus und klicken Sie auf "Einfügen".

Sie können auch den Befehl "Tabelle > Tabelle einfügen" verwenden, um ein Element einzufügen. Steht mehr als eine Tabelle zur Verfügung, wählen Sie die gewünschte Tabelle aus dem Aufklappmenü "Element-Tag" im Dialogfenster "Tabelle einfügen" aus.

    3. Um das Tabellenformat zu ändern, wählen Sie ein Format aus der Auswahlliste. Das Tabellenelement verfügt möglicherweise über ein vordefiniertes Format, das Sie jedoch ändern können, ohne dass es als irreguläre Formatzuweisung gilt.

Sprechen Sie mit Ihrem Entwickler, bevor Sie ein Tabellenformat ändern. Der Elementkatalog enthält möglicherweise für jedes benötigte Format ein Element.

    4. Ändern Sie gegebenenfalls die Anzahl der Reihen und Spalten. Diese Änderungen können dazu führen, dass die Tabelle ungültig wird.

    5. Klicken Sie auf "Einfügen". FrameMaker fügt an der Einfügemarke ein Ankersymbol [image] sowie eine Tabelle mit vordefinierten Elementen ein. Die Strukturansicht enthält Elementrechtecke für die neuen Elemente.

    6. Falls das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für die Tabellenelemente ein und klicken auf "Element einfügen" (siehe Eingeben von Attributwerten beim Einfügen von Elementen).

Wählen Sie Zellen in der Tabelle aus und klicken Sie anschließend mit der rechten Maustaste, um ein Kontextmenü zur Bearbeitung von Zellen aufzurufen. Sie können auch die QuickAccess-Leiste verwenden, um schneller auf Tabellenbefehle zuzugreifen (siehe Verwendung der QuickAccess-Leiste).

Wenn an der gewünschten Position kein Tabellenelement verfügbar ist, könnten Sie ein ungültiges Element verwenden. Sprechen Sie nach dem Einfügen der Tabelle mit Ihrem Entwickler, wie die Tabelle an dieser Position gültig gemacht werden kann.

So verwenden Sie ein ungültiges Tabellenelement:

Führen Sie eine der folgenden Aktionen aus:

    Um eine Tabelle zu verwenden, die an anderer Stelle im Dokument gültig ist, fügen Sie entweder die Tabelle an einer gültigen Stelle ein und verschieben sie danach, oder Sie verwenden die Einstellung "Alle Elemente" (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument), um die Tabelle überall im Dokument verfügbar zu machen, und fügen die Tabelle dann an der gewünschten Position ein.

    Um eine ungültige Tabelle mit Standardelementtypen einzufügen, wählen Sie "Tabelle > Tabelle einfügen" und wählen aus dem Aufklappmenü "Element-Tag" die Option "TABELLE" aus. (Diese Option wird im Menü angezeigt, wenn keine definierten Tabellenelemente im Dokument verfügbar sind.) Die Tabelle und deren Teile enthalten dann Standardelementtypen wie "TABELLE", "KOPFZEILE" und "REIHE". Ändern Sie die Tabellenteile in gültige Elemente, nachdem Sie die Tabelle durch eine gültige Tabelle ersetzt haben. (Im Abschnitt Bearbeiten von Elementen finden Sie Anweisungen zum Ändern von Elementen.)

Hinweis: Die Umwandlung einer ungültigen Tabelle mit Standardelementtypen in eine gültige Tabelle kann sehr aufwändig sein. Daher ist es meist besser, mit bereits definierten Tabellen zu arbeiten.


FrameMaker-Tabellen

Einfügen von Text und Grafik in strukturierte Tabellen

Jeder Schnittpunkt einer Spalte und einer Reihe ist eine Zelle. In einer strukturierten Tabelle ist jede Zelle ein Element mit einer Definition, die mögliche Inhalte für die Zelle beschreibt. Dabei handelt es sich in der Regel um Text, es können jedoch auch verankerte Rahmen oder andere Elemente verwendet werden. (Verankerte Rahmen können wiederum Grafiken oder andere Tabellen enthalten.) Wenn Sie Text eingeben oder einen verankerten Rahmen in eine Zelle einfügen, wird die Höhe der Zelle entsprechend angepasst.

Sie können den Inhalt von Zellen genau so kopieren, ausschneiden und einsetzen wie Text oder Grafiken in jedem anderen Teil eines Dokuments. Unter Umständen stehen besondere Systemvariablen-Elemente zur Verfügung, die Fortsetzungstext in den Titeln oder Kopfreihen mehrseitiger Tabellen festlegen.


FrameMaker-Tabellen / Einfügen von Text und Grafik in strukturierte Tabellen

Eingeben und Auswählen von Text in strukturierten Tabellen

Wenn im Elementkatalog der Indikator "TEXT" angezeigt wird, kann Text in die jeweils aktuelle Zelle eingegeben werden. Darüber hinaus können Sie gegebenenfalls auch Fußnoten, Querverweise und andere textbezogene Elemente in die Zelle eingeben. Verwenden Sie den Elementkatalog als Richtlinie.

So platzieren Sie die Einfügemarke in einer Tabellenzelle:

Klicken Sie in der Strukturansicht in die Zelle oder links neben den Textausschnitt der Zelle.

So wählen Sie den gesamten Zelleninhalt aus (jedoch nicht die Zelle selbst):

Klicken Sie in die Zelle und drücken Sie die Tastenkombination Esc t h a, oder doppelklicken Sie in der Strukturansicht auf das Elementrechteck der Zelle. Wenn die Zelle nur einen Absatz enthält, können Sie auch dreimal auf den Zelleninhalt klicken.

So wählen Sie den Inhalt der vorhergehenden oder nachfolgenden Zelle aus:

Drücken Sie die Tabulatortaste oder Umschalttaste+Tabulator.

So wählen Sie den Inhalt der darunter- oder darüberliegenden Zelle aus:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Drücken Sie die Tastenkombination Strg+Alt+Tabulator oder Strg+Alt+Umschalttaste+Tabulator.

    (UNIX) Drücken Sie Meta+n oder Meta+p.

So fügen Sie einen Tabulator in eine Zelle ein:

Drücken Sie Esc und dann die Tabulatortaste.


FrameMaker-Tabellen / Einfügen von Text und Grafik in strukturierte Tabellen

Auswählen von strukturierten Tabellenzellen

Wenn Sie an einer Tabelle arbeiten, kann es erforderlich sein, Zellen, Reihen, Spalten oder die gesamte Tabelle auszuwählen. Wenn eine Zelle anstelle ihres Inhalts ausgewählt ist, wird im Dokumentfenster ein Auswahlpunkt mit der Zelle angezeigt.

Auswahlpunkt

So wählen Sie eine einzelne Zelle aus:

    Ziehen Sie mit der Maus über die Zellenbegrenzung und zurück oder klicken Sie in der Strukturansicht auf das Elementrechteck der Zelle. Sie können auch bei gedrückter Strg- bzw. Control-Taste auf die Zelle klicken.

So wählen Sie mehrere Zellen aus:

Ziehen Sie die Maus über die gewünschten Zellen oder klicken Sie auf die erste Zelle und halten Sie die Umschalttaste gedrückt, wenn Sie auf die letzte Zelle der Auswahl klicken.

Hinweis: Aneinander grenzende Zellen im Dokumentfenster sind in der Strukturansicht nicht unbedingt benachbarte Elementrechtecke.

Ausgewählte Zellen (links) und Elementrechtecke (rechts)

So wählen Sie eine Reihe aus:

Ziehen Sie mit der Maus über die Zellen einer Reihe, klicken Sie in die Reihe und drücken Sie die Tastenkombination Esc t h r, oder klicken Sie in der Strukturansicht auf das Elementrechteck der Reihe.

Hinweis: Wenn Sie in der Strukturansicht zwischen zwei Tabellenteilelemente (z. B. zwei Reihen) klicken, erscheint die Einfügemarke in der Strukturansicht, aber nicht im Dokumentfenster.

So wählen Sie eine Spalte aus:

Klicken Sie auf die Spalte und drücken Sie die Tastenkombination Esc t h s, oder verschieben Sie den Mauszeiger von einer Kopfzelle in die erste Standardzelle.


FrameMaker-Tabellen / Einfügen von Text und Grafik in strukturierte Tabellen

Kopieren oder Verschieben von Zelleninhalten in strukturierten Tabellen

Sie können den Inhalt einer Zelle in eine andere Zelle in derselben oder einer anderen Tabelle einfügen. Verwenden Sie den Elementkatalog als Richtlinie, um sicherzustellen, dass Sie den Inhalt an einer zulässigen Stelle einfügen.

Wenn Sie einzufügende Inhalte auswählen, markieren Sie entweder nur den Inhalt oder die gesamte Zelle. Wenn Sie die Zelle auswählen, wird deren Formatierung (z. B. Schattierung und Lineatur) zusammen mit dem Inhalt eingefügt.

So kopieren oder verschieben Sie den Inhalt einer Zelle:

    1. Wählen Sie den Inhalt aus (siehe Eingeben und Auswählen von Text in strukturierten Tabellen) oder wählen Sie die gesamte Zelle aus, wenn Sie auch die Formatierung kopieren möchten (siehe Auswählen von strukturierten Tabellenzellen). Es können auch mehrere Zellen ausgewählt werden.

    2. Schneiden Sie die Auswahl aus oder kopieren Sie sie in die Zwischenablage. Klicken Sie auf eine andere Zelle und setzen Sie den Inhalt aus der Zwischenablage ein.

Zum Verschieben einer Zelle können Sie auch das Elementrechteck der Zelle in der Strukturansicht mit der Maus ziehen. Zum Kopieren der Zelle halten Sie beim Ziehen mit der Maus die Alt-Taste (Windows) oder die Control- und die mittlere Maustaste (UNIX) gedrückt. Weitere Informationen finden Sie unter Kopieren von Elementen.


FrameMaker-Tabellen / Einfügen von Text und Grafik in strukturierte Tabellen

Hinzufügen oder Entfernen von strukturierten Tabellentiteln

Unter- oder oberhalb der Tabelle wird der Tabellentitel angezeigt, der bei mehrseitigen Tabellen auf jeder Seite erscheint. Für den Titel gelten normalerweise Formatregeln, die das Erscheinungsbild des Titels bestimmen, z. B. die Schrift oder Ausrichtung und automatische Nummerierung des Titels.

Titel unten zentriert (links), automatisch nummerierter Titel oben linksbündig (rechts)

Die Elementdefinition einer Tabelle gibt mitunter an, ob die Tabelle einen Titel haben sollte. Ein Titel kann zu jeder Tabelle hinzugefügt werden. Sie sollten jedoch in der Strukturansicht prüfen, ob der Titel in der Tabelle gültig ist.

Das Titelelement stellt stets das erste untergeordnete Element einer strukturierten Tabelle dar, unabhängig davon, ob der Titel über oder unter der Tabelle erscheint.

So können Sie einen Tabellentitel hinzufügen oder entfernen:

    1. Klicken Sie in die Tabelle und wählen Sie "Tabelle > Tabellengestaltung".

    2. In den Basis-Einstellungen der "Tabellengestaltung" wählen Sie aus dem Aufklappmenü "Position des Titels" den Eintrag "Über Tabelle", "Unter Tabelle" oder "Kein Titel".

    3. Legen Sie den Abstand zwischen der Tabelle und dem Titel fest.

    4. Klicken Sie auf "Der Auswahl zuweisen". Wenn der Titel automatisch nummeriert wird, erscheint die Nummer (z. B. Tabelle 1) in der Titelzelle. Den Text des Titels geben Sie selbst ein.


FrameMaker-Tabellen / Einfügen von Text und Grafik in strukturierte Tabellen

Hinzufügen von Fortsetzungstext in strukturierten Tabellen

Bei einer mehrseitigen Tabelle möchten Sie ggf. speziellen Fortsetzungstext im Titel oder in der Kopf- bzw. Fußreihe anzeigen. Zu diesem Zweck sind im Dokument u. U. Variablen definiert, z. B. eine Variable, die (Fortsetzung) anzeigt, oder eine Variable, die die Seitenzahl der Tabelle angibt.

A: und C: Variable "Tabellenabschnitt" B: Variable "Tabellenfortsetzung"

So fügen Sie Fortsetzungstext hinzu:

    1. Klicken Sie auf der ersten Seite der Tabelle in den Titel oder die Kopf- oder Fußreihe, je nachdem, wo Sie das Variablenelement einfügen möchten.

    2. Wählen Sie ein Variablenelement für Fortsetzungstext aus dem Elementkatalog aus und klicken Sie auf "Einfügen". Die Variable erscheint an der Einfügemarke. In der Strukturansicht wird ein Elementrechteck mit einem Textausschnitt angezeigt, der den ersten Teil des Variablentexts enthält.

Auf der ersten Seite der Tabelle wird die Variable als umbruchgeschütztes Leerzeichen ( [image] ) angezeigt. Auf den folgenden Seiten wird der Variablentext angezeigt (z. B. "Fortsetzung").


FrameMaker-Tabellen / Einfügen von Text und Grafik in strukturierte Tabellen

Platzieren von Grafiken in strukturierten Tabellenzellen

Wenn Ihre Tabellenzellen Grafikelemente zulassen, können Sie Grafiken erstellen oder in Zellen importieren. Ein neues Grafikelement kann entweder ein leerer verankerter Rahmen sein, in dem Sie zeichnen können, oder ein verankerter Rahmen mit einer importierten Grafik.

Weitere Informationen zum Erstellen von Grafikobjekten in einem verankerten Rahmen finden Sie unter Verankerte Rahmen.

So platzieren Sie eine Grafik in einer Zelle:

    1. Klicken Sie an die Stelle, an der Sie die Grafik in der Zelle platzieren möchten.

    2. Wählen Sie ein Grafikelement aus dem Elementkatalog und klicken Sie auf "Einfügen". Die Elementdefinition legt fest, welches Dialogfenster angezeigt wird.

    3. Führen Sie eine der folgenden Aktionen aus:

    Wenn das Dialogfenster "Verankerter Rahmen" angezeigt wird, wählen Sie aus dem Aufklappmenü "Verankerungsposition" den Eintrag "An der Einfügemarke" und klicken auf "Neuer Rahmen".

    Wenn das Dialogfenster "Datei importieren" angezeigt wird, wählen Sie die zu importierende Datei aus und klicken auf "Importieren".

In der Zelle wird ein verankerter Rahmen und in der Strukturansicht ein Strukturrechteck mit dem Textausschnitt "GRAFIK" angezeigt.

    4. Wenn der verankerte Rahmen breiter als die Zelle ist, passen Sie die Spalte entsprechend an (siehe Ändern der Spaltengröße).

Um die Größe einer Spalte an deren Inhalt anzupassen, wählen Sie die Spalte aus und drücken die Tastenkombination Esc t x.

    5. Zentrieren Sie die Grafik gegebenenfalls im Rahmen. Wählen Sie die Grafik aus, wählen Sie "Grafik > Ausrichten", dann die Option "Mitte vertikal" oder "Mitte horizontal" (oder beide) und klicken Sie auf "Ausrichten".


FrameMaker-Tabellen / Einfügen von Text und Grafik in strukturierte Tabellen

Verschachteln von strukturierten Tabellen in Zellen

Sie können eine Tabelle in eine Tabellenzelle einfügen, z. B. um zwei unabhängige Tabellen nebeneinander (in separaten Zellen) anzuzeigen oder Tabellenmaterial zu verschachteln.

Bevor Sie eine Tabelle in eine Zelle einsetzen, fügen Sie in der Zelle einen verankerten Rahmen ein und zeichnen einen Textrahmen in den verankerten Rahmen. Die Zelle muss jedoch Grafikelemente zulassen.

Verschachtelte Tabelle

Wichtig: Wenn Sie ein Dokument als SGML- oder XML-Format exportieren, können die Inhalte darin verankerter Rahmen verloren gehen, da diese nicht Teil des strukturierten Haupttextflusses sind. Sprechen Sie mit Ihrem Entwickler, bevor Sie Dateien als SGML- oder XML-Format exportieren, um sicherzustellen, dass keine Daten aus verschachtelten Tabellen verloren gehen.

So verschachteln Sie eine Tabelle in einer Tabellenzelle:

    1. Klicken Sie an die Stelle, an der Sie die Tabelle in der Zelle platzieren möchten.

    2. Wählen Sie aus dem Elementkatalog ein Grafikelement für leere verankerte Rahmen aus und klicken Sie auf "Einfügen".

Sie können zum Einfügen eines Elements auch den Befehl "Spezial > Verankerter Rahmen" verwenden. Wählen Sie im Dialogfenster "Verankerter Rahmen" ein Rahmenelement aus dem Untermenü "Elementtyp" aus.

    3. Wählen Sie aus dem Aufklappmenü "Verankerungsposition" den Eintrag "An der Einfügemarke" oder "Unter aktueller Zeile", legen Sie die Breite und Höhe des Rahmens fest und klicken Sie auf "Neuer Rahmen".

Verankern Sie die Tabelle unter der aktuellen Zeile, wenn die Zelle abweichenden Text (wie im oben angegebenen Beispiel) enthält. Legen Sie den Rahmen nach Möglichkeit so fest, dass er etwas größer als die Tabelle ist.

    4. Wenn der verankerte Rahmen breiter als die Zelle ist, passen Sie die Spalte entsprechend an (siehe Ändern der Spaltengröße).

    5. Zeichnen Sie dazu im verankerten Rahmen einen Textrahmen. Klicken Sie oben rechts im Dokumentfenster auf das Symbol "Werkzeuge" ( [image] ) und klicken Sie in der Werkzeugpalette auf das Textrahmen-Werkzeug ( [image] ). Zeichnen Sie den Rahmen mit der Maus und klicken Sie im eingeblendeten Dialogfenster auf "Zuweisen".

Weitere Informationen zu Textrahmen finden Sie unter Grafiken und Text.

    6. Klicken Sie in den Textrahmen und wählen Sie "Tabelle > Tabelle einfügen", um eine unstrukturierte Tabelle einzufügen.


FrameMaker-Tabellen

Kopieren, Verschieben und Entfernen von strukturierten Tabellen

Sie können eine Tabelle als Ganzes kopieren, verschieben oder entfernen. Dazu ist es am einfachsten, mit der Tabelle in der Strukturansicht zu arbeiten.

Wenn Sie eine unstrukturierte Tabelle in einen strukturierten Textfluss kopieren oder verschieben, erhält die Tabelle eine Grundstruktur mit Standardelementen wie z. B. "TABELLE", "KOPFZEILE", "REIHE". Ändern Sie die Standardelemente in der neuen Tabelle in geeignete, im Dokument definierte Elemente.

Wenn Sie eine strukturierte Tabelle in einen unstrukturierten Textfluss kopieren oder verschieben, verliert die Tabelle möglicherweise ihre Gültigkeit.

So wählen Sie eine Tabelle aus:

Klicken Sie in der Strukturansicht auf das Elementrechteck der Tabelle oder halten Sie die Strg- bzw. Control-Taste gedrückt und klicken Sie dreimal auf eine Zelle.

So kopieren oder verschieben Sie eine Tabelle:

    1. Wählen Sie die Tabelle aus.

    2. Wählen Sie "Bearbeiten > Kopieren" oder "Bearbeiten > Ausschneiden". Wählen Sie dann "Zellen entfernen" und klicken Sie auf "Ausschneiden".

    3. Klicken Sie an die Stelle, an der Sie die Tabelle einfügen möchten, und wählen Sie "Bearbeiten > Einfügen". Überprüfen Sie vor dem Einsetzen mithilfe des Elementkatalogs, ob die Position für eine Tabelle gültig ist.

Zum Verschieben einer Tabelle können Sie auch das Elementrechteck der Tabelle in der Strukturansicht mit der Maus ziehen. Zum Kopieren der Tabelle halten Sie beim Ziehen mit der Maus die Alt-Taste (Windows) oder die Control- und die mittlere Maustaste (UNIX) gedrückt. Weitere Informationen finden Sie unter Kopieren von Elementen.

So entfernen Sie eine Tabelle, ohne die Zwischenablage zu verwenden:

Wählen Sie das Tabellenelement in der Strukturansicht aus und drücken Sie Entf.


FrameMaker-Tabellen

Zuweisen verschiedener Formate zu strukturierten Tabellen

Das Erscheinungsbild einer Tabelle wird weitgehend von deren Tabellenformat beeinflusst, da dadurch Einzüge, Abstände, Ausrichtung, Zellenränder und Titel festgelegt werden. Weitere Informationen finden Sie unter Formatierung strukturierter Tabellen.

Das durch die Formatregeln für ein Tabellenelement vorgeschlagene Tabellenformat können Sie beim Einfügen der Tabelle oder zu einem späteren Zeitpunkt ändern, ohne dass die Änderung als irreguläre Formatzuweisung gilt. (Wenn Sie irreguläre Formatzuweisungen aus dem Dokument entfernen, wird die Tabelle nicht auf das ursprüngliche Format zurückgesetzt.)

Wenn Sie ein anderes Tabellenformat zuweisen, ändern sich nur die Eigenschaften der Tabelle, die vom Tabellenformat abhängen. D. h., keine der in der Tabelle vorgenommenen speziellen Einstellungen (z. B. Spaltenbreiten, Anzahl der Reihen und Spalten oder Einstellungen aus dem Menü "Tabelle") sind davon betroffen.

Tabelle mit altem (links) und neuem (rechts) Format; gedrehte Zellen werden beibehalten

Sie können Tabellenformate einzelnen Tabellen oder Tabellengruppen zuweisen, die gegenwärtig ein bestimmtes Format verwenden.

Wichtig: Wenn ein neues Tabellenformat der Tabelle einen Titel hinzufügt, die Regeln für den Tabelleninhalt dies aber nicht zulassen, ist der Titel ungültig.

Ihr Anwendungsentwickler hat möglicherweise Vorschläge, welche Formate für bestimmte Tabellen geeignet sind. Hat ein Dokument kein Format, das Ihren Anforderungen entspricht, sollten Sie sich mit der Entwicklungsabteilung in Verbindung setzen, um vorhandene Formate neu zu definieren oder ein neues Format zu erstellen.

So weisen Sie einer Tabelle ein anderes Format zu:

    1. Klicken Sie in die Tabelle.

    2. Wählen Sie "Tabelle > Tabellengestaltung".

    3. Wählen Sie das Format aus dem Aufklappmenü "Tabellentyp" aus und klicken Sie auf "Der Auswahl zuweisen".

So weisen Sie ein Format mehreren Tabellen mit einem bestimmten Format zu:

    1. Führen Sie eine der folgenden Aktionen aus, um eine Tabelle auszuwählen:

    Um ein Format mehreren aufeinander folgenden Tabellen zuzuweisen, wählen Sie die Tabellenelemente in der Strukturansicht aus.

    Um ein Format den Tabellen im gesamten Dokument zuzuweisen, klicken Sie in eine beliebige Tabelle.

    2. Wählen Sie "Tabelle > Tabellengestaltung".

    3. Wählen Sie das Format aus dem Aufklappmenü "Tabellentyp" aus und wählen Sie aus dem Aufklappmenü "Befehle" den Eintrag "Optionen für globale Aktualisierung".

    4. Legen Sie fest, welche Tabellen neu formatiert werden sollen. Führen Sie hierzu eine der folgenden Aktionen aus:

    Um die Tabellen der Auswahl und alle Tabellen mit dem Format der ausgewählten Tabellen neu zu formatieren, aktivieren Sie die Option "Alle entsprechenden Typen in Auswahl".

    Um alle Tabellen mit einem bestimmten Format neu zu formatieren, wählen Sie ein Format aus dem Untermenü "Alle des Typs".

    5. Wählen Sie im Bereich "Einstellungen der Tabellengestaltung verwenden" die Option "Alle Einstellungen" und klicken Sie auf "Aktualisieren".


FrameMaker-Tabellen

Positionieren von strukturierten Tabellen auf einer Seite

Der Abstand über und unter einer Tabelle, ihre Ausrichtung sowie der Einzug werden durch das Tabellenformat bestimmt. Sie können andere Positionierungseigenschaften wie Verbindung und Konturlauf tabellenspezifisch steuern.

Verbinden von strukturierten Tabellen

Fließen von Text um strukturierte Tabellen


FrameMaker-Tabellen / Positionieren von strukturierten Tabellen auf einer Seite

Verbinden von strukturierten Tabellen

Tabellen können Textspalten in einem mehrspaltigen Layout verbinden. Das Verbinden hat keine Auswirkungen auf die Struktur einer Tabelle und ist keine irreguläre Formatzuweisung.

So verbinden Sie eine Tabelle:

Führen Sie eine der folgenden Aktionen aus:

    Verankern Sie die Tabelle in einem Absatzelement, das für das Verbinden der Spalten formatiert ist. Wenn die Tabelle breit genug ist, wird die gesamte Spaltenbreite verbunden. Andernfalls verbindet die Tabellenebene die gesamte Breite.

Die Ebene einer einspaltigen Tabelle verbindet die gesamte Spaltenbreite.

    Erweitern Sie die Spaltenbreite bis in eine zweite Spalte des Arbeitsbereichs (siehe Ändern der Spaltengröße). Wenn die Tabelle sowohl den Arbeitsbereich als auch die seitlichen Überschriften verbinden soll, erweitern Sie die Tabelle auf den Bereich für seitliche Überschriften.

Verbinden aller Spalten (links), Verbinden von Spalten und der seitlichen Überschrift (rechts)

So trennen Sie eine Tabelle:

Führen Sie eine der folgenden Aktionen aus:

    Ist die Tabelle in einem verbundenen Absatzelement verankert, verlagern Sie deren Anker in ein nicht verbundenes Element.

    Um eine Tabelle zu trennen, die nicht in einem verbundenen Absatzelement verankert ist, passen Sie die Spaltenbreite der Tabelle so an, dass sie in die Textspalte passt (siehe Verbinden und Trennen von Zellen in strukturierten Tabellen).


FrameMaker-Tabellen / Positionieren von strukturierten Tabellen auf einer Seite

Fließen von Text um strukturierte Tabellen

Tabellen, die direkt in einer Textspalte verankert sind, werden nicht vom Text umflossen. Wenn die Anwendung jedoch entsprechend eingerichtet ist, können Sie Text in einem verankerten Rahmen oder in einem Textrahmen um eine Tabelle fließen lassen, die nicht mit dem Haupttextfluss verbunden ist.

Eine Tabelle in einem verankerten Rahmen bewegt sich zusammen mit dem Text, in dem sie verankert ist. Eine Tabelle in einem abgetrennten Textrahmen behält ihre Position auf der Seite bei, wobei anderer Text um sie herumfließt.

Wichtig: Der Inhalt eines verankerten Rahmens oder eines abgetrennten Textrahmens ist nicht Teil des strukturierten Haupttextflusses und wird daher normalerweise nicht im SGML-Format exportiert. Sprechen Sie sich mit dem Anwendungsentwickler ab, wie ein Verlust von Tabellendaten vermieden werden kann, wenn ein Export in das SGML-Format erfolgen soll.

Eine Tabelle in einem abgetrennten Textrahmen ist von der automatischen Nummerierung der Tabellen im Haupttextfluss ausgenommen.

So lassen Sie Text um eine Tabelle in einem verankerten Rahmen fließen:

    1. Klicken Sie an die Stelle im Text, an der die Tabelle verankert werden soll.

    2. Wählen Sie aus dem Elementkatalog ein Grafikelement für einen leeren verankerten Rahmen aus und klicken Sie auf "Einfügen".

Sie können zum Einfügen eines Elements auch den Befehl "Spezial > Verankerter Rahmen" verwenden. Wählen Sie im Dialogfenster "Verankerter Rahmen" ein Rahmenelement aus dem Untermenü "Elementtyp" aus.

    3. Wählen Sie aus dem Untermenü "Verankerungsposition" die Option "Im Absatz", legen Sie Breite und Höhe des Rahmens fest und klicken Sie auf "Neuer Rahmen". Legen Sie den Rahmen nach Möglichkeit so fest, dass er etwas größer als die Tabelle ist.

    4. Zeichnen Sie dazu im verankerten Rahmen einen Textrahmen. Klicken Sie oben rechts im Dokumentfenster auf das Symbol "Werkzeuge" ( [image] ) und klicken Sie in der Werkzeugpalette auf das Textrahmen-Werkzeug ( [image] ). Zeichnen Sie den Rahmen mit der Maus und klicken Sie im eingeblendeten Dialogfenster auf "Zuweisen".

    5. Klicken Sie in den Textrahmen und wählen Sie "Tabelle > Tabelle einfügen", um eine unstrukturierte Tabelle einzufügen.

So lassen Sie Text um eine Tabelle fließen, deren Position auf der Seite festgelegt ist:

    1. Zeichnen Sie einen Textrahmen direkt auf einer Seite und ziehen Sie den Rahmen mit der Maus an die gewünschte Position. Diese Art von Textrahmen ist nicht mit dem Haupttextfluss verbunden.

    2. Wählen Sie "Grafik > Konturlaufeinstellungen", klicken Sie auf "Um Bildrahmen" und dann auf "Zuweisen".

    3. Klicken Sie in den Textrahmen und wählen Sie "Tabelle > Tabelle einfügen", um eine unstrukturierte Tabelle einzufügen.


FrameMaker-Tabellen

Anpassen von Reihen und Spalten in strukturierten Tabellen

In einer Tabelle können Sie Reihen und Spalten hinzufügen, entfernen, kopieren, verschieben und ihre Größe ändern. Darüber hinaus können Sie ausgewählte Zellen über Reihen oder Spalten verbinden. Informationen über das Auswählen von Zellen, Reihen und Spalten finden Sie im Abschnitt Auswählen von strukturierten Tabellenzellen.

Hinzufügen und Entfernen von Reihen und Spalten in strukturierten Tabellen

Verbinden und Trennen von Zellen in strukturierten Tabellen


FrameMaker-Tabellen / Anpassen von Reihen und Spalten in strukturierten Tabellen

Hinzufügen und Entfernen von Reihen und Spalten in strukturierten Tabellen

Sie können festlegen, wie viele Reihen und Spalten Sie an welcher Stelle einfügen möchten. Eine neue Reihe enthält bereits Zellenelemente.

Durch das Hinzufügen von Reihen oder Spalten kann die Struktur einer Tabelle ungültig werden. Eine für drei Spalten eingerichtete Tabelle wird z. B. ungültig, wenn Sie eine vierte Spalte hinzufügen. Prüfen Sie daher abschließend die Gültigkeit der Tabelle in der Strukturansicht.

Zum Hinzufügen von Kopf- oder Fußreihen sollten Sie den Elementkatalog verwenden, da Tabellen laut Definition oft eine bestimmte Anzahl dieser Reihen haben.

So fügen Sie schnell eine Reihe unterhalb der aktuellen Reihe ein:

Drücken Sie die Tastenkombination Strg+Eingabetaste. Die neue Reihe hat dieselbe Struktur und Absatzformatierung wie die aktuelle Reihe.

So fügen Sie eine neue Reihe mithilfe des Elementkatalogs hinzu:

Klicken Sie in der Strukturansicht an die Stelle, an der Sie die Reihe hinzufügen möchten. Wählen Sie ein Reihenelement aus dem Elementkatalog aus und klicken Sie auf "Einfügen". Weitere Informationen finden Sie unter Hinzufügen von Elementen.

So fügen Sie Reihen und Spalten mit einem Befehl aus dem Menü "Tabelle" hinzu:

    1. Klicken Sie in die Zelle, neben der die Reihen oder Spalten hinzugefügt werden sollen.

    2. Wählen Sie "Tabelle > Reihen oder Spalten einfügen" und geben Sie die Anzahl der Reihen oder Spalten an, die Sie hinzufügen möchten, sowie die Position, an der Sie eingefügt werden sollen. Sie können Reihen über und unter sowie links und rechts von der aktuellen Zelle hinzufügen.

    3. Klicken Sie auf "Einfügen". Die neuen Spalten oder Reihen haben dieselbe Struktur und dasselbe Absatzformat wie die aktuelle Reihe bzw. Spalte.

So entfernen Sie eine Reihe oder Spalte, ohne die Zwischenablage zu verwenden:

    1. Wählen Sie die Reihe oder Spalte aus. Sie müssen ganze Reihen oder Spalten wählen, andernfalls wird auch der Inhalt der ausgewählten Zelle entfernt.

    2. Drücken Sie Entf, klicken Sie auf "Zellen entfernen" und dann auf "Löschen".


FrameMaker-Tabellen / Anpassen von Reihen und Spalten in strukturierten Tabellen

Verbinden und Trennen von Zellen in strukturierten Tabellen

Sie können mehrere Zellen horizontal zu einer einzelnen Zelle zusammenfügen, die mehrere Spalten miteinander verbindet, oder mehrere Zellen vertikal zu einer einzelnen Zelle zusammenfügen, die mehrere Reihen miteinander verbindet. Text und Grafiken fließen über die Zellgrenzen hinaus, als würde die verbundene Zelle aus nur einer Zelle bestehen.

A: Zelle, die Reihen verbindet B: Zelle, die Spalten verbindet

Die Elemente der kombinierten Zellen werden im Zellenelement oben links in der ursprünglichen Auswahl zusammengefügt.

In der Strukturansicht können Sie eine verbundene Zelle leicht finden, da eine Reihe weniger Zellen aufweist als die übrigen Reihen in der Tabelle.

Die erste Reihe weist eine einzelne verbundene Zelle auf.

Wenn Sie Zellen mit Inhalt verbinden, werden auch die Inhalte dieser Zellen zusammengefügt. Für jede zusammengefügte Zelle wird ein einzelner Absatz erstellt. Zellen können auch getrennt werden.

So wandeln Sie mehrere Zellen in eine verbundene Zelle um:

Wählen Sie die Zellen aus und wählen Sie "Tabelle > Verbinden".

So trennen Sie eine Zelle:

Wählen Sie die verbundene Zelle aus und wählen Sie dann "Tabelle > Trennen". Der gesamte Inhalt der verbundenen Zelle wird nicht wieder in den Originalzellen angezeigt, sondern in der linken oberen Zelle.


FrameMaker-Tabellen

Drehen von Zellen und Tabellen in strukturierten Dokumenten

Wenn Sie eine Zelle in einer Tabelle drehen, können Sie in diese Zelle, wie in jede andere Zelle, Text eingeben.

Gedrehte Zellen

Wenn der Entwickler die Anwendung entsprechend eingerichtet hat, können Sie Tabellen auch drehen. Die gedrehte Tabelle kann sich in einem verankerten Rahmen auf einer Seite mit nicht gedrehtem Text oder auf einer gedrehten Seite befinden (wenn diese eine gedrehte Vorgabeseite verwendet). Wenn auch Hintergrundobjekte (wie Kopf- und Fußzeilen und Fließtext) mit der Tabelle zusammen gedreht werden sollen, müssen Sie die Tabelle auf einer gedrehten Seite platzieren, anstatt die Tabelle zu drehen.

Tabelle auf einer gedrehten Seite (links), gedrehte Tabelle auf einer normalen Seite (rechts)

Hinweis: Eine in einem verankerten Rahmen gedrehte Tabelle ist nicht Teil des strukturierten Haupttextflusses im Dokument und wird normalerweise nicht im SGML-Format exportiert. Wenn Sie einen SGML-Export planen, sollten Sie anstelle der Tabelle die ganze Seite drehen. Wenn Sie nur die Tabelle drehen müssen, sprechen Sie mit der Entwicklungsabteilung, um den Verlust von Tabellendaten zu vermeiden.

Das Drehen einer Zelle oder einer Seite mit einer Tabelle hat keinen Einfluss auf die Tabellenstruktur und stellt keine irreguläre Formatzuweisung dar.

So drehen Sie Zellen:

    1. Wählen Sie die Zellen aus und wählen Sie "Grafik > Drehen".

    2. Geben Sie die gewünschte Ausrichtung der Zellen an und klicken Sie auf "Drehen".

Wenn Sie Text in eine gedrehte Zelle eingeben, vergrößert sich zwar die Zellenhöhe, es erfolgt aber kein Textumbruch. Sie können die Höhe von gedrehten Zellen begrenzen, sodass der Text umbrochen wird, sobald die Begrenzung erreicht ist (siehe Anpassen der Reihenhöhe).

So fügen Sie eine gedrehte Tabelle auf einer Seite mit nicht gedrehtem Text ein:

    1. Klicken Sie an der Stelle in den Text, an der die Tabelle verankert werden soll.

    2. Wählen Sie aus dem Elementkatalog ein Grafikelement für leere verankerte Rahmen aus und klicken Sie auf "Einfügen".

    3. Wählen Sie aus dem Aufklappmenü "Verankerungsposition" die Option "Unter der aktuellen Zeile", legen Sie die Höhe und Breite des Rahmens fest und klicken Sie auf "Neuer Rahmen". Legen Sie den Rahmen nach Möglichkeit so fest, dass er etwas größer als die Tabelle ist.

    4. Zeichnen Sie dazu im verankerten Rahmen einen Textrahmen. Klicken Sie oben rechts im Dokumentfenster auf das Symbol "Werkzeuge" ( [image] ) und dann in der Werkzeugpalette auf das Textrahmen-Werkzeug ( [image] ). Zeichnen Sie den Rahmen mit der Maus und klicken Sie im eingeblendeten Dialogfenster auf "Zuweisen".

    5. Klicken Sie in den Textrahmen und wählen Sie "Tabelle > Tabelle einfügen", um eine unstrukturierte Tabelle einzufügen.

    6. Wählen Sie "Grafik > Drehen" und drehen Sie den Textrahmen. Die Größe des Textrahmens oder des verankerten Rahmens muss möglicherweise angepasst werden, um die Tabelle vollständig anzeigen zu können.

So bearbeiten Sie eine gedrehte Tabelle:

Machen Sie die Drehung des Textrahmens rückgängig und bearbeiten Sie die Tabelle. Drehen Sie die Tabelle erneut, nachdem Sie die Bearbeitung beendet haben.

So erstellen Sie eine gedrehte Tabelle auf einer Seite mit dem anderen gedrehten Text:

Weisen Sie der Seite mit der Tabelle eine gedrehte Vorgabeseite zu. Fragen Sie Ihren Entwickler nach Vorgabeseiten, die für diesen Zweck definiert wurden, und deren Verwendung.


Querverweise und Fußnoten

Einfügen von Querverweisen

Arbeiten mit Querverweis-Marken

Anzeigen der Quelle eines Querverweises

Bearbeiten von Querverweisen

Erstellen von Querverweisformaten

Verwenden von Bausteinen für Quellinformationen

Bearbeiten von Querverweisformaten

Verwalten von Querverweisen

Auflösen von Querverweisen

Arbeiten mit Fußnoten

Ändern von Fußnotenformaten

Arbeiten mit Endnoten

Arbeiten mit Querverweisen in strukturierten Dokumenten

Einfügen elementbasierter Querverweise in strukturierte Dokumente

Arbeiten mit ID-Werten in strukturierten Dokumenten

Auflösen von Querverweisen in strukturierten Dokumenten

Arbeiten mit Fußnoten in strukturierten Dokumenten

Arbeiten mit Endnoten in strukturierten Dokumenten


Querverweise und Fußnoten

Einfügen von Querverweisen

In Adobe FrameMaker geben Sie beim Einfügen eines Querverweises dessen Quelle und den vordefinierten Wortlaut an, der verwendet werden soll, wenn der Querverweis beispielsweise eine Überschrift, eine Abschnittsnummer oder eine Seitennummer enthält. FrameMaker fügt den Text des Querverweises (z. B. siehe "Vulkanismus und Plattentektonik" auf Seite 7-71) für Sie ein. Ändern sich später beim Bearbeiten des Dokuments Seitennummern oder Überschriften, aktualisiert FrameMaker die Querverweise automatisch.

Sie können Arbeitsseiten und Tabellen auch Fußnoten hinzufügen, die von FrameMaker bei der Eingabe automatisch nummeriert und positioniert werden.

In FrameMaker gibt es zwei Arten von Querverweisen: Querverweise auf Absätze und Querverweise auf bestimmte Stellen innerhalb eines Absatzes. In beiden Fällen verwendet FrameMaker Marken, um die Quellen der Querverweise verfolgen zu können.

Absatz-Querverweise sind einfacher zu erstellen als Stellen-Querverweise, da Sie keine bestimmte Textstelle manuell markieren müssen. Mit Absatz-Querverweisen ist auch das Bearbeiten eines Dokuments einfacher, weil Sie nicht wie bei Stellen-Querverweisen auf eine leicht zu übersehende Marke im Absatz achten müssen.

Informationen zum Einfügen von Querverweisen in strukturierte Dokumente finden Sie unter Arbeiten mit Querverweisen in strukturierten Dokumenten.

Hinweis: Die Querverweisfunktion unterstützt den Unicode-Standard zur Textcodierung.


Querverweise und Fußnoten / Einfügen von Querverweisen

Einfügen von Absatz-Querverweisen

Absatz-Querverweise beziehen sich auf eine Überschrift oder anderen Text, der einen ganzen Absatz einnimmt. Ist der Absatz länger als die Seite, auf der er beginnt, und enthält der Querverweis eine Seitennummer, wird die Anfangsseite angezeigt. Da sich die meisten Querverweise auf ganze ein- oder zweizeilige Absätze beziehen, z. B. Überschriften, Abbildungstitel und Tabellentitel, werden Sie in den meisten Fällen Absatz-Querverweise verwenden.

Absatz-Querverweise

Wenn Sie einen Absatz-Querverweis in einen Texteinschub einfügen, geht die Querverweis-Marke unter Umständen verloren, sobald der Texteinschub aktualisiert wird. Um dies zu verhindern, fügen Sie zunächst einen Querverweis auf den Absatz im Quelldokument des Texteinschubs ein.

So fügen Sie einen Absatz-Querverweis ein:

    1. Wenn Sie mit einem Querverweis auf ein anderes Dokument verweisen möchten, müssen Sie das Dokument öffnen. Sie müssen Schreibzugriff auf das Dokument haben, um darin eine Querverweis-Marke einfügen zu können.

    2. Klicken Sie an die Stelle, an der der Querverweis eingefügt werden soll. Sie können einen Querverweis in Textrahmen, aber nicht in Textzeilen einfügen (grafische Objekte, die mit dem Textzeilen-Werkzeug erzeugt wurden).

    3. Wählen Sie "Spezial > Querverweis".

    4. Wenn Sie Querverweise auf Informationen in einem anderen Dokument erzeugen, wählen Sie den Namen dieses Dokuments aus dem Aufklappmenü "Dokument".

    5. Wählen Sie aus dem Aufklappmenü "Quelltyp" den Eintrag "Absätze". In der Auswahlliste werden alle im Absatzformat-Katalog des Dokuments enthaltenen Typen angezeigt.

    6. Wählen Sie aus der Auswahlliste "Absatztypen" den Typ des Absatzes, auf den verwiesen werden soll. Wenn Sie z. B. auf einen Absatz des Typs "Überschrift1" verweisen möchten, wählen Sie aus der Auswahlliste "Absatztypen" den Eintrag "Überschrift1". In der Auswahlliste "Absätze" werden dann alle Überschrift1-Absätze angezeigt.

    7. Wählen Sie in der Liste "Absätze" den Absatz, auf den sich der Querverweis beziehen soll.

    8. Wählen Sie aus dem Aufklappmenü "Format" das Format des Querverweises. In diesem Menü werden die im aktuellen Dokument enthaltenen Querverweisformate aufgelistet.

    9. Klicken Sie auf "Einfügen". FrameMaker platziert den Querverweis an der Einfügemarke, und die Marke [image] wird am Anfang des Absatzes eingefügt, auf den sich der Querverweis bezieht. Die Marke wird nur eingefügt, wenn noch keine Querverweis-Marke vorhanden ist.

So fügen Sie einen Querverweis auf einen Absatz in einem Texteinschub ein:

    1. Öffnen Sie die Quelle des Texteinschubs, indem Sie auf ihn doppelklicken und "Quelle öffnen" wählen.

    2. Fügen Sie an einer beliebigen Stelle im Quelldokument einen Querverweis auf den Absatz ein.

    3. Wählen Sie den Text im Querverweis. Die Marke bleibt erhalten.

    4. Speichern Sie das Quelldokument und aktualisieren Sie den Texteinschub, indem Sie im Dokument, das den Einschub enthält, den Befehl "Bearbeiten > Referenzen aktualisieren" wählen.

    5. Fügen Sie einen weiteren Querverweis auf den Absatz ein, diesmal in dem Dokument, das den Texteinschub enthält. Der Querverweis verwendet die Marke im aktualisierten Einschub.


Querverweise und Fußnoten / Einfügen von Querverweisen

Einfügen von Stellen-Querverweisen

Stellen-Querverweise verweisen auf einzelne Wörter oder Wortverbindungen (Textstellen) in einem Absatz. Ein Stellen-Querverweis kann z. B. verwendet werden, wenn ein Absatz zwei Seiten lang ist und Sie sich auf die zweite Seite beziehen möchten.

Stellen-Querverweis

So fügen Sie einen Stellen-Querverweis ein:

    1. Klicken Sie an die Stelle, an der Sie die Marke einfügen wollen. Wenn Sie den Leser z. B. zu einer Definition führen möchten, klicken Sie auf den Anfang des definierten Wortes. Um Leser zu einem verankerten Rahmen zu führen, klicken Sie neben das Symbol für den verankerten Rahmen. Sie können Marken an eine beliebige Stelle innerhalb einer Textspalte platzieren.

Wenn Sie eine Querverweis-Marke in einen Texteinschub einfügen möchten, müssen Sie die Marke im Quelldokument platzieren (siehe Anzeigen der Quelle eines Querverweises).

    2. Wählen Sie "Spezial> Marke".

    3. Wählen Sie aus dem Aufklappmenü "Markentyp" den Eintrag "Querverweis".

    4. Geben Sie in das Textfeld "Markentext" eine Bezeichnung für die Marke ein. Der Markentext kann maximal 255 Zeichen lang sein (Zeichen in japanischen Schriftarten werden doppelt gezählt).

Wenn Sie beispielsweise bei der Definition des Begriffs Schwerkraft eine Marke einfügen, geben Sie als Bezeichnung Definition für Schwerkraft ein. Dieser Text wird dann im Dialogfenster "Querverweis" angezeigt und erleichtert Ihnen das Erkennen der Quelle. Der Text wird nicht im Querverweis selbst angezeigt.

    5. Klicken Sie auf "Neue Marke". Wenn die Anzeige von Steuerzeichen aktiviert ist, wird an der Einfügemarke ein Markensymbol ( [image] ) eingeblendet.

    6. Fügen Sie jetzt einen Querverweis ein. Befolgen Sie dabei die Anweisungen zum Einfügen eines Absatz-Querverweises unter Einfügen von Absatz-Querverweisen, wählen Sie aber in Schritt 5 aus dem Aufklappmenü "Quelletyp" den Eintrag "Querverweis-Marken". Wählen Sie anschließend aus der Liste "Querverweis-Marken" den Markentext aus. Wählen Sie ein Querverweisformat und klicken Sie abschließend auf "Einfügen".

Sie können die in den Querverweis-Marken enthaltenen Informationen anzeigen, indem Sie eine Liste der Querverweis-Marken generieren (siehe Auflösen von Querverweisen). Sie können auch mithilfe des Befehls "Bearbeiten > Suchen/Ändern" nach Marken des Typs "Querverweis" suchen (siehe Suchen).


Querverweise und Fußnoten

Arbeiten mit Querverweis-Marken

FrameMaker verwendet eine Marke (des Typs "Querverweis"), um die Quelle des Querverweises verfolgen zu können. Wenn Sie eine Marke verschieben und anschließend die Querverweise aktualisieren, wird die neue Position der Marke zum Aktualisieren des Querverweises verwendet.

Bei Absatz-Querverweisen enthält der Markentext eine der Marke zugewiesene Nummer sowie Typ und Text des Absatzes, auf den verwiesen wird. (Der Markentext wird nicht aktualisiert, sodass Typ und Text möglicherweise nicht mit dem Querverweis übereinstimmen). Bei Stellen-Querverweisen besteht der Markentext aus dem für die Marke eingegebenen Text.

Wenn Sie einen Absatz-Querverweis einfügen, wird, falls erforderlich, automatisch eine Querverweis-Marke am Anfang des Absatzes eingefügt. Vor dem Einfügen eines Stellen-Querverweises müssen Sie jedoch an der betreffenden Position manuell eine Marke einfügen.

Wenn Sie in einem Dokument Text, der eine Querverweis-Marke enthält, kopieren und einfügen, wird die Marke nicht dupliziert. Der Querverweis verweist weiterhin auf den Text an der ursprünglichen Position.


Querverweise und Fußnoten

Anzeigen der Quelle eines Querverweises

Sie können die Quelle eines beliebigen Querverweises jederzeit anzeigen, selbst wenn diese sich in einem anderen Dokument befindet.

So zeigen Sie die Quelle eines Querverweises an:

Doppelklicken Sie auf den Querverweis und klicken Sie anschließend auf "Zu Quelle wechseln". FrameMaker zeigt die Seite an, die die Quelle des Querverweises enthält, und platziert die Einfügemarke an den Anfang des Quellabsatzes.

Sie können zum Auswählen der Querverweis-Marke auch einen der folgenden Kurzbefehle verwenden:

    (Windows) Halten Sie die Alt- und die Strg-Taste gedrückt und klicken Sie auf den Querverweis.

    (UNIX) Halten Sie die Control-Taste gedrückt und klicken Sie mit der rechten Maustaste auf den Querverweis.

Wenn sich die Quelle in einem anderen Dokument befindet, halten Sie zum Öffnen des Dokuments die Umschalttaste gedrückt und verwenden Sie einen der folgenden Kurzbefehle. Das aktuelle Dokument muss nicht geschlossen werden.


Querverweise und Fußnoten

Bearbeiten von Querverweisen

Sie können Querverweise bzw. Querverweiselemente in strukturierten Dokumenten wie normalen Text kopieren, verschieben und löschen. Für die Bearbeitung von Querverweisen stehen Ihnen folgende Möglichkeiten zur Verfügung:

    Überarbeiten des Querverweises, indem Sie ein anderes Format für den Querverweis wählen.

    Verweisen auf andere Informationen, indem Sie eine andere Quelle angeben.

Wenn Sie den Text des Querverweises wie normalen Text bearbeiten möchten, müssen Sie ihn in Text konvertieren. Nach dem Konvertieren kann der Text nicht mehr wie ein Querverweis aktualisiert werden.

So wählen Sie einen Querverweis aus:

Klicken Sie einmal auf den Querverweis.

Hinweis: Wenn Sie strukturierte Dokumente verwenden, können Sie entweder im Dokumentfenster oder in der Strukturansicht auf das Querverweiselement klicken.

So wählen Sie eine andere Quelle oder ein anderes Format für einen Querverweis aus:

    1. Doppelklicken Sie auf den Querverweis. Wenn sich die Quelle in einem anderen Dokument befindet, klicken Sie auf "OK", um das Quelldokument zu öffnen.

    2. Geben Sie Quelle oder Format wie beim Einfügen eines Querverweises an (siehe Einfügen von Querverweisen).

    3. Klicken Sie auf "Ersetzen".

So konvertieren Sie einen Querverweis in Text:

    1. Um einen einzelnen Querverweis zu konvertieren, wählen Sie ihn aus. Andernfalls müssen Sie in das Dokument klicken.

    2. Wählen Sie "Spezial > Querverweis".

    3. Klicken Sie auf "In Text konvertieren".

    4. Geben Sie im Dialogfenster den Bereich der zu konvertierenden Querverweise an und klicken Sie auf "Konvertieren".


Querverweise und Fußnoten

Erstellen von Querverweisformaten

Querverweisformate legen für jeden Querverweis die Darstellung fest (z. B. Formulierung, Zeichenformat, enthaltene Informationen) und sorgen so für einen einheitlichen Querverweisstil im gesamten Dokument. So legt beispielsweise das Format des Querverweises Siehe "Vulkanismus und Plattentektonik" auf Seite 7-71 fest, dass der Abschnittstitel in Anführungszeichen gesetzt wird. Außerdem stellt das Querverweisformat die Formulierungen Siehe und auf Seite bereit und liefert Bausteine, die den tatsächlichen Abschnittstitel und die tatsächliche Seitennummer darstellen.

A: Eingegebener Text B: Bausteine

Ein Querverweisformat besteht aus einem Namen und einer Definition. Die Definition kann einschließlich der Bausteine bis zu 255 Zeichen lang sein.

FrameMaker-Schablonen enthalten verschiedene Querverweisformate. Sie können diese ändern oder neue erstellen. Sie können auch Querverweisformate aus anderen Dokumenten importieren (siehe Importieren und Aktualisieren von Formaten und Ändern des Formats von Dateien eines Buches).

So erstellen Sie Querverweisformate:

    1. Wählen Sie "Spezial > Querverweis".

    2. Klicken Sie auf "Format bearbeiten".

    3. Geben Sie in das Textfeld "Name" einen Namen für das Querverweisformat ein. Bei Formatnamen wird Groß- und Kleinschreibung unterschieden, d. h. Seite und seite werden als zwei verschiedene Formate interpretiert.

    4. Führen Sie einen der folgenden Schritte aus:

    Wenn Sie bestimmten Text (z. B. Siehe oder auf Seite) in einem Querverweisformat verwenden möchten, klicken Sie in das Textfeld "Definition" und geben den gewünschten Text ein. Weitere Informationen hierzu finden Sie unter Einfügen von Text in einen Querverweis.

    Wenn ein Baustein in das Format aufgenommen werden soll, der auf Quellinformationen verweist (z. B. Seitennummer oder Titeltext), klicken Sie zuerst in das Textfeld "Definition" und dann auf den betreffenden Baustein in der Auswahlliste "Bausteine". Der Baustein wird an der Einfügemarke eingefügt. Weitere Informationen hierzu finden Sie unter Verwenden von Bausteinen für Quellinformationen.

    Um das Zeichenformat innerhalb des Querverweises zu ändern, klicken Sie zuerst in das Textfeld "Definition" und dann auf das gewünschte Zeichenformat am Ende der Auswahlliste "Bausteine". Der Baustein wird an der Einfügemarke eingefügt. Um vor dem Ende des Querverweises zum Standardabsatzformat zurückzukehren, fügen Sie in die Definition <Absatzstandardschrift> ein. Weitere Informationen hierzu finden Sie unter Verwenden von Bausteinen für Zeichenformate.

    5. Klicken Sie auf "Einfügen" und anschließend auf "Zurück". Das neue Querverweisformat wird im Dialogfenster "Querverweis" im Aufklappmenü "Format" angezeigt.


Querverweise und Fußnoten / Erstellen von Querverweisformaten

Einfügen von Text in einen Querverweis

Sie können bestimmte Zeichen oder Wörter in den Querverweis einfügen. Meistens genügt es, den Text in das Textfeld "Definition" einzugeben. Einige Zeichen werden jedoch anders eingegeben oder angezeigt.

Spitze Klammern (< und >) werden in einem Querverweisformat in der Regel für Bausteine verwendet. Damit eine spitze Klammer als Teil des Textes behandelt wird, müssen Sie ihr einen umgekehrten Schrägstrich (\) voranstellen.

Weitere Informationen hierzu finden Sie unter Einfügen von Band- und Kapitelnummern in Querverweise.

Hinweis: Manche Sonderzeichen werden in Dialogfenstern auf eine andere Art und Weise eingegeben oder angezeigt. Unter Windows geben Sie Zeichenfolgen ein, indem Sie mit einem umgekehrten Schrägstrich (\) beginnen. Eine Auflistung dieser Zeichenfolgen finden Sie unter Eingabe in Dialogfenstern. Unter UNIX werden Zeichenfolgen mit umgekehrtem Schrägstrich möglicherweise in Textfeldern angezeigt, selbst wenn Sie sie nicht für die Sonderzeichen eingeben müssen.


Querverweise und Fußnoten

Verwenden von Bausteinen für Quellinformationen

Mithilfe von Bausteinen können Sie in einen Querverweis Informationen zu der Quelle integrieren, z. B. den Absatztext (jedoch nicht den Text der Querverweis-Marke), die automatisch vergebene Absatznummer, die Band-, Kapitel- oder Seitennummer. Bausteine für Quellinformationen werden in spitzen Klammern ( <und> ) angezeigt und beginnen mit einem Dollarzeichen ($). Die folgenden Bausteine sind nach Informationstyp gruppiert.

Quelldatei

Mit den folgenden Bausteinen können Sie in FrameMaker auf den Namen der Quelldatei verweisen.

Baustein | Bedeutung
<$Dateiname> | Der Name des Quelldokuments
<$DateinameLang> | Der vollständige Pfadname des Quelldokuments
<$volnum> | Die Bandnummer des Dokuments, in dem der Quellabsatz enthalten ist
<$chapnum> | Die Kapitelnummer des Dokuments, in dem der Quellabsatz enthalten ist

Quellabsatz

Mit den folgenden Bausteinen können Sie in FrameMaker auf den Namen des Quellabsatzes verweisen.

Baustein | Bedeutung
<$SeiteNum> | Die Seitennummer des Quellabsatzes
<$AbsText> | Der Text des Quellabsatzes ohne automatisch vergebene Nummer (wurde das Zeichenformat des Textes im Quellabsatz mithilfe des Zeichenformat-Katalogs geändert, werden die Einstellungen für Schriftfamilie und Hochstellen und Tiefstellen im Text des Querverweises beibehalten).
<$AbsTyp> | Der Typ des Quellabsatzes
<$AbsNum> | Die vollständige, automatisch vergebene Nummer des Quellabsatzes, einschließlich des Textes im Format der automatischen Nummerierung
<$AbsNumExkl> | Die Zähler der automatischen Nummerierung des Quellabsatzes, einschließlich aller Zeichen zwischen ihnen

Absatz vor Quellabsatz

Ein Querverweis auf einen Unterabschnitt muss häufig dessen übergeordneten Abschnitt identifizieren. Ein Querverweis auf eine untergeordnete Überschrift kann, wie im folgenden Beispiel, die Hauptüberschrift identifizieren: Weitere Informationen finden Sie unter "Arten der Plattengrenzen" in "Plattentektonik". In diesem Beispiel ist Arten der Plattengrenzen der Quellabsatz und Plattentektonik die Hauptüberschrift, unter der der Quellabsatz angezeigt wird.

Mit den folgenden Bausteinen können Sie in FrameMaker auf einen Absatz verweisen, der dem Quellabsatz vorausgeht. Ersetzen Sie in allen Bausteinen Typ (in eckigen Klammern) durch den Absatztyp, auf den Sie verweisen möchten. Löschen Sie jedoch nicht die eckigen Klammern. Wenn Sie z. B. auf den Text des vorhergehenden Absatzes verweisen möchten, der vom Typ "Überschrift1" ist, verwenden Sie <$AbsText[Überschrift1]>.

Baustein | Bedeutung
<$SeiteNum[Typ]> | Die Seitennummer des vorhergehenden Absatzes mit dem angegebenen Typ
<$AbsText[Typ]> | Der Text des vorhergehenden Absatzes mit dem angegebenen Typ ohne die automatisch vergebene Nummer (wurde das Zeichenformat des Textes im Quellabsatz mithilfe des Zeichenformat-Katalogs geändert, werden die Einstellungen für Schriftfamilie und Hochstellen und Tiefstellen im Text des Querverweises beibehalten).
<$AbsTyp[Typ]> | Der Typ des vorhergehenden Absatzes mit dem angegebenen Typ
<$AbsNum[Typ]> | Die vollständige, automatisch vergebene Nummer des vorhergehenden Absatzes mit dem angegebenen Typ, einschließlich sämtlichen Texten im Format der automatischen Nummerierung
<$AbsNumExkl[Typ]> | Die Zähler des vorhergehenden, automatisch nummerierten Absatzes mit dem angegebenen Typ, einschließlich sämtlicher Zeichen zwischen ihnen

Wichtig: Verwenden Sie keinen Absatztyp, der Klammern enthält ([ ]).


Querverweise und Fußnoten / Verwenden von Bausteinen für Quellinformationen

Verwenden von Bausteinen für Zeichenformate

Alle Formate im Zeichenformat-Katalog des Dokuments werden am Ende der Auswahlliste "Bausteine" angezeigt. Sie werden wie andere Bausteine eingefügt.

Wenn Sie kein Zeichenformat in ein Querverweisformat einfügen, wird die Schrift an der Einfügemarke verwendet, sobald Sie einen Querverweis mit diesem Format einfügen. Wenn Sie das Zeichenformat des Querverweises ändern, betrifft dies nur den Querverweis, nicht den nachfolgenden Absatztext.

Wichtig: Verwenden Sie keine Zeichentypen, die spitze Klammern enthalten (< >).


Querverweise und Fußnoten / Verwenden von Bausteinen für Quellinformationen

Beispiele für Querverweisformate

Die ersten vier Beispiele in der folgenden Tabelle enthalten Bausteine, die auf den Quellabsatz verweisen. Das erste Beispiel enthält einen Kapitelnummer-Baustein und den Text des Quellabsatzes (siehe Einfügen von Band- und Kapitelnummern in Querverweise). Das zweite Beispiel enthält den Text und die automatisch vergebene Nummer des Quellabsatzes. Im dritten Beispiel ist nur der Text des Quellabsatzes enthalten. Im vierten Beispiel ist nur die Seitennummer des Quellabsatzes enthalten.

Beispiel | Format
Kapitel 4, "Klimatische Veränderungen". | <$chapnum>, "<$AbsText>"
Abschnitt 2.3.4, Vulkane. | Abschnitt <$AbsNumExkl>, <TitelSchrift><$AbsText>.
Siehe Plattentektonik und folgende Abschnitte. | Siehe <TitelSchrift><$AbsText> <Absatzstandardschrift>, und folgende Abschnitte.
Seite 23 | Seite <$SeiteNum>
Siehe "Magma" in "Vulkane". | Siehe "<$AbsText>" in "<$AbsText[Überschrift1]>".

Das letzte Beispiel enthält einen Baustein, der auf den Absatz verweist, der dem Quellabsatz vorausgeht. Hier könnte das Querverweisformat auch folgendermaßen lauten:

Siehe "<$AbsText>" in "<$AbsText[Titel, Überschrift1]>".

In diesem Fall bezieht sich der Querverweis entweder auf den Kapiteltitel (Titel) oder die Abschnittsüberschrift (Überschrift1), je nachdem, welches Element dem Quellabsatz Magma näher ist.

Sie können den </>-Baustein anstelle von <Absatzstandardschrift> in Querverweisformat-Definitionen verwenden.


Querverweise und Fußnoten

Bearbeiten von Querverweisformaten

Wenn Sie Querverweisformate ändern oder löschen, werden die Änderungen sofort in allen Querverweisen übernommen, die diese Formate verwenden.

Sie können das Format von Querverweisen innerhalb von Texteinschüben (durch Referenz importierter Text) ändern, wenn der Einschub die Formate des Dokuments verwendet, in das er importiert wird. Wenn der Texteinschub Formate aus dem Quelldokument verwendet, müssen Sie die Formate im Quelldokument ändern.

So ändern Sie ein Querverweisformat:

    1. Wählen Sie "Spezial > Querverweis" und klicken Sie auf "Format bearbeiten".

    2. Wählen Sie in der Liste "Aktuelle Formate" das zu ändernde Format und bearbeiten Sie anschließend die Definition. Sie können dabei Text und Bausteine auf dieselbe Weise wie beim Erstellen eines Querverweisformats verwenden (siehe Erstellen von Querverweisformaten).

    3. Klicken Sie auf "Ändern" und anschließend auf "Zurück". Wenn das Format von Querverweisen im Dokument verwendet wird, erscheint das Dialogfenster "Querverweise aktualisieren". Geben Sie hier den Bereich der zu aktualisierenden Querverweise an und klicken Sie auf "Aktualisieren".

So löschen Sie ein Querverweisformat:

    1. Wählen Sie "Spezial > Querverweis" und klicken Sie auf "Format bearbeiten".

    2. Wählen Sie in der Liste "Aktuelle Formate" das zu löschende Format aus.

    3. Klicken Sie auf "Löschen" und anschließend auf "Zurück". Wenn Querverweise im Dokument das Format verwenden, werden Sie gefragt, ob Sie diese Querverweise in Text konvertieren möchten.


Querverweise und Fußnoten

Verwalten von Querverweisen

Wenn die Quelle des Querverweises bearbeitet oder der Seitenumbruch des Quelldokuments geändert wird, funktioniert der Querverweis unter Umständen nicht mehr richtig. Sie können Querverweise aktualisieren, um sicherzustellen, dass sie die Informationen aus der Quelle korrekt anzeigen.

In der Regel aktualisiert FrameMaker alle Querverweise, wenn Sie ein Dokument öffnen. Ferner werden alle internen Querverweise und Querverweise auf geöffnete Dokumente automatisch aktualisiert. Sie können Querverweise auch manuell aktualisieren. Wenn das Dokument ungelöste Querverweise enthält (Querverweise auf Quellen, die FrameMaker nicht findet), müssen Sie die Quellen suchen.

Hinweis: In den folgenden Situationen aktualisiert FrameMaker Querverweise beim Öffnen eines Dokuments nicht automatisch: Es fehlen Schriften oder Bibliotheken, das Dokument wurde mit einer früheren Version von FrameMaker gespeichert oder es wird eine MIF-Datei geöffnet.

Achten Sie beim Bearbeiten von Text unbedingt darauf, dass Sie Querverweis-Marken nicht versehentlich löschen (siehe Auflösen von Querverweisen).


Querverweise und Fußnoten / Verwalten von Querverweisen

Unterdrücken der automatischen Aktualisierung der Querverweise

Wenn ein Dokument viele Querverweise enthält, können Sie die zum Öffnen benötigte Zeit verringern, indem Sie die automatische Aktualisierung der Querverweise unterdrücken. Dadurch werden Querverweise beim Öffnen des Dokuments nicht mehr aktualisiert. Beim Drucken werden jedoch alle internen Querverweise sowie Querverweise auf geöffnete Dokumente weiterhin automatisch aktualisiert.

So unterdrücken Sie die automatische Aktualisierung der Querverweise in einem Dokument:

    1. Um die Aktualisierung zu unterdrücken, wählen Sie "Bearbeiten > Referenzen aktualisieren".

    2. Wählen Sie aus dem Aufklappmenü "Befehle" die Option "Automatische Aktualisierung unterdrücken".

    3. Aktivieren Sie die Option "Automatische Aktualisierung aller Querverweise unterdrücken" und klicken Sie auf "Zuweisen". Klicken Sie auf "Fertig". Von nun an werden die Querverweise nur noch aktualisiert, wenn Sie das Dokument drucken oder wenn Sie FrameMaker entsprechend anweisen.

So unterdrücken Sie die automatische Aktualisierung der Querverweise in einem Buch:

    1. Wählen Sie im Buchfenster "Bearbeiten > Automatische Referenzaktualisierung unterdrücken".

    2. Aktivieren Sie "Automatische Aktualisierung unterdrücken" und klicken Sie auf "Zuweisen". Von nun an werden die Querverweise nur noch aktualisiert, wenn Sie das Dokument drucken oder wenn Sie FrameMaker entsprechend anweisen.


Querverweise und Fußnoten / Verwalten von Querverweisen

Manuelles Aktualisieren von Querverweisen

Sie sollten alle Querverweise in einem Dokument aktualisieren, bevor Sie es verteilen. Ferner sollten Sie regelmäßig nach der Bearbeitung des Dokuments selbst oder der Dokumente, die Quellen von Querverweisen sind, eine Aktualisierung durchführen. Informationen zum Aktualisieren von Querverweisen in einem Buch finden Sie unter Aktualisieren von Büchern.

In den folgenden Situationen aktualisiert FrameMaker Querverweise beim Öffnen eines Dokuments nicht automatisch:

    Wenn Querverweise auf Informationen in verborgenem bedingtem Text Bezug nehmen. Blenden Sie vor der Aktualisierung der Querverweise den Text ein, der die Quellen der Querverweise enthält.

    Wenn Schriften oder Bibliotheken fehlen.

    Wenn ein Dokument mit einer früheren Version von FrameMaker gespeichert wurde.

    Wenn eine MIF-Datei geöffnet wird.

So aktualisieren Sie Querverweise in einem Dokument manuell:

    1. Wählen Sie "Bearbeiten> Referenzen aktualisieren".

    2. Wählen Sie "Alle Querverweise" und klicken Sie auf "Aktualisieren". Wenn FrameMaker alle Querverweise zugeordnet hat, ist der Vorgang abgeschlossen. Wenn FrameMaker nicht alle Querverweise lösen kann, wird das Dialogfenster "Ungelöste Querverweise aktualisieren" geöffnet.


Querverweise und Fußnoten

Auflösen von Querverweisen

Gelegentlich kann FrameMaker einen Querverweis aus folgenden Gründen nicht aktualisieren:

    Die Marke, die die Quelle des Querverweises angibt, wurde in eine andere Datei verschoben, oder die Datei selbst wurde verschoben oder umbenannt.

    Die Marke, die die Quelle anzeigt, wurde gelöscht.

    Die Datei, die die Marke enthält, wird gerade von einem anderen Benutzer auf dem Netzwerk-Server verwendet.

Wenn FrameMaker einen Querverweis während der automatischen Aktualisierung nicht lösen kann (beim Öffnen oder Drucken), wird eine Warnmeldung angezeigt. Sie können die Querverweise nach dem Schließen des Meldungsfensters lösen.

Sie können alle ungelösten Querverweise gleichzeitig anzeigen, indem Sie eine Liste mit den ungelösten Querverweisen generieren.

So lösen Sie einen Querverweis, nachdem eine Marke in eine andere Datei verschoben oder die Datei umbenannt wurde:

    1. Wählen Sie "Bearbeiten> Referenzen aktualisieren".

    2. Wählen Sie aus dem Aufklappmenü "Befehle" den Eintrag "Ungelöste Querverweise aktualisieren".

    3. Wählen Sie aus der Auswahlliste "Insgesamt % ungelöste(r) Querverweis(e) auf Datei(en)" die Datei, in der sich die Quelle des ungelösten Querverweises zuvor befunden hat. Unterhalb der Auswahlliste wird die Anzahl der ungelösten Querverweise auf die ausgewählte Datei angezeigt.

    4. Wählen Sie in der Liste "Suchen in" die Datei mit der Quelle aus und klicken Sie auf "Öffnen".

Wenn FrameMaker die Aktualisierung nicht durchführen kann, wählen Sie aus der Liste "Suchen in" eine andere Datei und versuchen Sie es erneut.

    5. Wenn noch weitere Querverweise auf Dateien gelöst werden sollen, die sich in der Auswahlliste "Insgesamt % ungelöste(r) Querverweis(e) auf Datei(en)" befinden, wiederholen Sie die Schritte 3 und 4. Klicken Sie dann auf "Zurück".

So lösen Sie einen Querverweis, wenn eine Marke gelöscht wurde:

    1. Wählen Sie "Bearbeiten> Suchen/Ändern".

    2. Wählen Sie aus dem Aufklappmenü "Suchen" den Eintrag "Ungelöster Querverweis" und klicken Sie auf "Suchen". Der erste ungelöste Querverweis wird gesucht und ausgewählt. Der Markentext der zuletzt verwendeten Quellmarke für den Querverweis wird im Textfeld "Suchen" angezeigt, um Ihnen beim Auffinden der Quelle zu helfen.

    3. Löschen Sie den Querverweis, wenn Sie ihn nicht mehr benötigen. Andernfalls führen Sie eine der folgenden Aktionen aus:

    Wenn FrameMaker einen ungelösten Absatz-Querverweis findet, doppelklicken Sie auf den Querverweis, um das Dialogfenster "Querverweis" zu öffnen. Geben Sie hier eine andere Quelle an und klicken Sie anschließend auf "Ersetzen".

    Wenn ein ungelöster Stellen-Querverweis gefunden wird, fügen Sie eine neue Querverweis-Marke in den betreffenden Text ein (siehe Einfügen von Querverweisen). Verwenden Sie genau den Markentext, der im Dialogfenster "Suchen/Ändern" angezeigt wird.

    4. Wiederholen Sie Schritt 2 und Schritt 3, bis alle ungelösten Querverweise gelöst sind.

So erstellen Sie eine Liste ungelöster Querverweise:

    1. Wählen Sie "Spezial > Liste von > Referenzen". Wenn Sie dazu aufgefordert werden, geben Sie an, ob die generierte Datei als unabhängiges Dokument oder als Teil eines Buches erstellt werden soll.

    2. Verschieben Sie den Eintrag "Ungelöste Querverweise" in die Liste "Übernahme der Referenzen" und klicken Sie auf "Zuweisen".

Die Liste enthält die Seitennummer der ungelösten Querverweise, die Angabe, ob es sich bei der fehlenden Quelle um eine interne (im aktuellen Dokument) oder externe (in einem anderen Dokument) Quelle handelt, und weitere Informationen wie Typ und Text des Quellabsatzes. Typ und Text sind möglicherweise nicht korrekt angegeben, wenn sie seit dem Erstellen des Querverweises nicht mehr aktualisiert wurden. Bei Stellen-Querverweisen enthält die Liste auch den Markentext.


Querverweise und Fußnoten

Arbeiten mit Fußnoten

Beim Einfügen einer Fußnotenreferenz und einer Fußnote weist FrameMaker der Fußnote eine Nummer zu, formatiert den Text der Fußnote und fügt eine Trennlinie ein, wenn die Fußnote die erste in einer Spalte ist.

A: Fußnote B: Fußnoten-Trennzeichen C: Fußnotenreferenz

Wenn Sie Fußnoten einfügen, verschieben und löschen, passt FrameMaker die Nummerierung automatisch an. Wenn Sie den umgebenden Text bearbeiten, wird die Fußnote gegebenenfalls auf eine andere Seite verschoben.

Die Fußnotenreferenz und die Fußnote selbst befinden sich normalerweise in derselben Spalte. Wenn Sie eine Fußnotenreferenz in eine Tabelle einfügen, wird die Fußnote am Ende der Tabelle angezeigt. Wenn sich die Tabelle über zwei Seiten erstreckt, werden alle Fußnoten unabhängig von der Position der Fußnotenreferenz auf der zweiten Seite angezeigt.

Sie können die Fußnoten in einem Buch fortlaufend nummerieren. Weitere Informationen finden Sie unter Ändern der Fußnoten-Nummerierung.

Informationen zum Arbeiten mit Fußnoten in strukturierten Dokumenten finden Sie unter Arbeiten mit Fußnoten in strukturierten Dokumenten.

Hinweis: Die Fußnotenfunktion unterstützt den Unicode-Standard zur Textcodierung.

So fügen Sie eine Fußnote ein:

    1. Klicken Sie an die Stelle, an der die Fußnotenreferenz angezeigt werden soll. Eine Fußnotenreferenz kann in eine Textspalte oder in eine Tabellenzelle eingefügt werden.

    2. Wählen Sie "Spezial > Fußnote". FrameMaker fügt die Fußnotenreferenz ein, zeigt die Fußnotennummer am unteren Rand der Spalte oder unter der Tabelle an, setzt die Einfügemarke hinter die Fußnotennummer und nummeriert die nachfolgenden Fußnoten neu. (Fußnoten werden in einem Textfluss fortlaufend durchnummeriert. Wenn Ihr Dokument mehrere Textflüsse enthält, wird die Fußnotennummerierung in jedem Textfluss unabhängig von den anderen Textflüssen durchgeführt.)

    3. Geben Sie den Text der Fußnote an der Einfügemarke ein. Kehren Sie danach in den Haupttext zurück, indem Sie in diesen klicken oder erneut den Befehl "Spezial > Fußnote" wählen.

Wenn zwei Fußnotenreferenzen zusammen platziert werden sollen, fügen Sie ein Leerzeichen oder ein Komma zwischen ihnen ein, z. B. Referenzen5 6 oder Referenzen5,6. Andernfalls wird die zweite Fußnote nicht erstellt. Wenn Sie ein Komma zwischen den Fußnotenreferenzen einfügen, müssen Sie das Komma manuell hochstellen.

So bearbeiten Sie eine Fußnote:

Wählen Sie den Fußnotentext und bearbeiten Sie ihn wie normalen Text. Die Nummer kann nicht geändert werden, da sie von FrameMaker automatisch vergeben wird.

So kopieren, verschieben oder löschen Sie eine Fußnote:

    1. Markieren Sie die Fußnotenreferenz (nicht den Fußnotentext).

    2. Führen Sie eine der folgenden Aktionen aus:

    Um die Fußnote zu kopieren oder zu verschieben, wählen Sie "Bearbeiten > Kopieren" oder "Bearbeiten > Ausschneiden" und anschließend "Bearbeiten > Einfügen".

    Um die Fußnote zu löschen, drücken Sie die Entf-Taste.


Querverweise und Fußnoten / Arbeiten mit Fußnoten

Zusammenhalten einer Fußnote und ihrer Referenz in derselben Spalte

Manchmal kann eine Fußnote nicht in der Spalte platziert werden, in der sich ihre Referenz befindet. Wenn Sie beispielsweise eine Fußnotenreferenz am Ende einer Textspalte einfügen, sodass darunter für die Fußnote kein Platz mehr ist, wird die Fußnote an den unteren Rand der nächsten Spalte verschoben. Fügen Sie in diesen Fällen vor der Fußnotenreferenz einen Spalten- oder Seitenumbruch ein, damit Referenz und Fußnote in einer Spalte zusammengehalten werden.

Durch das Hinzufügen von Text zu einer Fußnote wird die letzte Fußnote in einer Spalte oder Seite möglicherweise an den unteren Rand der nächsten Spalte bzw. Seite verschoben. Um der Möglichkeit vorzubeugen, dass eine Fußnote nicht in eine Spalte passt, reservieren Sie für die Fußnoten in der Spalte mehr Platz (siehe Ändern der Fußnoteneinstellungen).


Querverweise und Fußnoten / Arbeiten mit Fußnoten

Einfügen mehrerer Verweise auf eine Fußnote

Sie können eine einzelne Fußnote erstellen, auf die mehrere Fußnotenreferenzen verweisen, z. B. eine Tabellenfußnote mit Verweisen in mehreren Zellen.

Zwei Verweise für eine Fußnote

Um mehrere Fußnotenreferenzen zu erstellen, fügen Sie die erste Referenz auf die übliche Art ein. Für jede weitere Fußnotenreferenz verwenden Sie einen Querverweis.

Wenn Sie eine Fußnote vor der Fußnote hinzufügen oder entfernen, auf die durch einen Querverweis verwiesen wird, verweist der Querverweis unter Umständen auf die falsche Nummer. Wählen Sie "Bearbeiten > Referenzen aktualisieren", um die Nummerierung zu aktualisieren.

So fügen Sie mehrere Referenzen auf eine Fußnote ein:

    1. Fügen Sie die erste Fußnotenreferenz ein.

    2. Erstellen Sie bei Bedarf ein Querverweisformat für die zusätzlichen Fußnotenreferenzen.

In dem Querverweisformat muss die Fußnotennummer korrekt angezeigt werden. Wenn die Fußnotenreferenzen beispielsweise hochgestellt angezeigt werden und das Dokument das Zeichenformat "Hochgestellt" enthält, zeigt das Querverweisformat <Hochgestellt><$AbsNumExkl> die automatisch vergebene Absatznummer hochgestellt an. Wenn Sie damit auf einen Absatz mit einer Fußnote verweisen, wird die Fußnotennummer hochgestellt angezeigt.

    3. Klicken Sie an die Stelle, an der die zusätzliche Fußnotenreferenz eingefügt werden soll.

    4. Wählen Sie "Spezial > Querverweis", um einen Querverweis auf die Fußnote einzufügen. Verwenden Sie dabei das in Schritt 2 erstellte Querverweisformat.

    5. Klicken Sie auf "Einfügen". FrameMaker fügt einen Querverweis ein, der mit der ursprünglichen Fußnotenreferenz identisch ist.


Querverweise und Fußnoten / Arbeiten mit Fußnoten

Beibehalten der Querverweise auf Fußnoten nach dem Bearbeiten

Vergewissern Sie sich nach dem Bearbeiten eines Dokuments, dass die zusätzlichen Verweise auf Fußnoten korrekt sind. So kann beispielsweise ein Querverweis auf eine Fußnotenreferenz falsch nummeriert sein, oder die Fußnote kann sich auf der falschen Seite befinden (es sei denn, die Referenz befindet sich in einer Tabelle). Wenn ein Querverweis falsch nummeriert ist, müssen Sie die Querverweise im Dokument aktualisieren (siehe Verwalten von Querverweisen). Wenn sich die Fußnote auf der falschen Seite befindet, sollten Sie den Seitenumbruch ändern oder die Fußnote verschieben.


Querverweise und Fußnoten

Ändern von Fußnotenformaten

Sie können alle Fußnoteneinstellungen ändern, z. B. die Art der Nummern, das Nummerierungsformat oder das für den Fußnotentext zu verwendende Absatzformat. Überdies können Sie die Größe und den Inhalt der Trennlinie festlegen, d. h. den Bereich zwischen dem unteren Rand der Spalte oder Tabelle und der ersten Fußnote.

FrameMaker verwendet für Dokument- und Tabellenfußnoten unterschiedliche Formate.

Ändern der Fußnoteneinstellungen

Ändern der Fußnoten-Nummerierung

Ändern der Trennlinie für Fußnoten

Verwenden von Fußnoten in mehrspaltigen Layouts


Querverweise und Fußnoten / Ändern von Fußnotenformaten

Ändern der Fußnoteneinstellungen

Alle Änderungen in den Fußnoteneinstellungen mit Ausnahme des Absatzformats wirken sich auf neue und vorhandene Fußnoten aus.

So ändern Sie Fußnoteneinstellungen:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Fußnoten". Um Tabellenfußnoten-Einstellungen zu ändern, wählen Sie aus dem Aufklappmenü den Eintrag "Tabellenfußnote".

    3. Führen Sie folgende Schritte durch:

    Mit dem Textfeld "Maximale Höhe pro Spalte" können Sie die zulässige Höhe für Fußnoten in einer Spalte festlegen.

    Mit dem Textfeld "Absatzformat" können Sie für neue Fußnoten ein anderes Absatzformat angeben. (Das Format muss sich im Absatzformat-Katalog des Dokuments befinden). Sie können auch für eine vorhandene Fußnote ein anderes Format verwenden, indem Sie das Format direkt zuweisen.

Standardmäßig werden für neue Fußnoten die Absatzformate "Fußnote" und "Tabellenfußnote" verwendet. Sie können diese Formate beliebig ändern. Weitere Informationen finden Sie unter Allgemeines über Absatz- und Zeichenformate.

    Legen Sie das Format für die Fußnotenreferenz im Haupttext und für die Nummer in der Fußnote fest. Die Nummern können hochgestellt, tiefgestellt oder auf der Grundlinie angezeigt werden und über ein Präfix und Suffix verfügen.

    4. Klicken Sie auf "Zuweisen".


Querverweise und Fußnoten / Ändern von Fußnotenformaten

Ändern der Fußnoten-Nummerierung

Sie können die Fußnoten- und Tabellenfußnoten-Nummerierungen im Dialogfenster "Einstellungen für Nummerierung" ändern.

Hinweis: Wenn Sie mit Dokumenten arbeiten, die Teil eines Buches sind, sollten Sie die Einstellungen im Buchfenster und nicht im Dokumentfenster vornehmen. Wenn das Buch aktualisiert wird, überschreiben die Bucheinstellungen die Dokumenteinstellungen.

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Nummerierung". Wählen Sie aus dem Aufklappmenü "Fußnote" oder "Tabellenfußnote".

    3. Wählen Sie aus dem Aufklappmenü "Format" eine Nummerierungsart. Wenn Sie "Spezial" wählen, können Sie im Dialogfenster "Spezial-Nummerierung" spezielle Fußnoten angeben. Klicken Sie anschließend auf "Zuweisen".

Sie können für eigene Formate Zahlen, Buchstaben und Symbole beliebig kombinieren, die dann in der Reihenfolge verwendet werden, in der Sie sie eingegeben haben. Wenn Sie Symbole in einem eigenen Stil verwenden und Ihr Dokument mehr Fußnoten als Symbole enthält, werden die Symbole wiederholt. Wenn Sie beispielsweise die beiden Symbole * und verwenden und Ihr Dokument drei Fußnoten enthält, wird die dritte Fußnote mit ** gekennzeichnet. Die Fußnotennummer wird in der Standardschrift des betreffenden Absatzformats angezeigt.

Spezielle Fußnoten-Nummerierung

Hinweis: Manche Sonderzeichen werden in Dialogfenstern auf eine andere Art und Weise eingegeben oder angezeigt. Unter Windows geben Sie Zeichenfolgen ein, indem Sie mit einem umgekehrten Schrägstrich (\) beginnen. Eine Auflistung dieser Zeichenfolgen finden Sie unter Überblick über die Eingabe in Dialogfenstern. Unter UNIX werden diese Zeichenfolgen mit umgekehrtem Schrägstrich evtl. in Textfeldern angezeigt, selbst wenn Sie diese Zeichenfolgen nicht eingeben müssen.

    4. Legen Sie fest, mit welcher Nummer die Dokumentfußnoten beginnen sollen, und ob die Fußnotennummerierung auf jeder Seite neu beginnen oder kapitelübergreifend weitergeführt werden soll. Wenn Sie die fortlaufende Nummerierung wählen, können Sie mit einer beliebigen Nummer beginnen. Die Nummerierung von Tabellenfußnoten beginnt bei jeder Tabelle von vorn.

    5. Klicken Sie auf "Zuweisen".


Querverweise und Fußnoten / Ändern von Fußnotenformaten

Ändern der Trennlinie für Fußnoten

Die Trennlinie ist ein Grafikrahmen, der automatisch zwischen dem unteren Rand des Haupttextes bzw. der Tabelle und der ersten Fußnote eingefügt wird. Er enthält in der Regel eine Linie oder ein anderes Grafikelement, das den Haupttext und die Fußnoten optisch voneinander trennt. Die Höhe des Rahmens bestimmt den Abstand zwischen dem Haupttext bzw. der Tabelle und den Fußnoten.

Die Trennrahmen für Dokument- und Tabellenfußnoten werden auf einer Referenzseite gespeichert (siehe Arbeiten mit Referenzseiten). Ihre Namen sind mit den für diese Fußnoten verwendeten Absatzformaten identisch (standardmäßig "Fußnote" und "Tabellenfußnote").

Referenzseite

Fußnoten-Trennlinie auf einer Arbeitsseite

So ändern Sie die Trennlinie für Fußnoten:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Seite mit der Trennlinie an.

    2. Ändern Sie die Größe des Rahmens oder bearbeiten Sie den Inhalt. Sie können die Größe und Position der Linie im Rahmen ändern oder die Linie entfernen bzw. ersetzen. Wenn Sie die Höhe des Rahmens verringern, wird die erste Fußnote näher am unteren Rand des Textes oder der Tabelle platziert. Wenn Sie die Linie im Rahmen nach unten verschieben, bleibt die erste Fußnote an ihrer Position, doch der Abstand zur Linie ist geringer.

Wenn Sie den Trennrahmen leer lassen, wird statt einer Linie ein leerer Bereich oberhalb der Fußnoten angezeigt.

    3. Wählen Sie "Darstellung > Arbeitsseiten".


Querverweise und Fußnoten / Ändern von Fußnotenformaten

Verwenden von Fußnoten in mehrspaltigen Layouts

Die Platzierung der Fußnoten in einem mehrspaltigen Layout ist von der Position der Fußnotenreferenz abhängig sowie davon, ob seitliche Überschriften vorhanden sind oder Text, der Spalten verbindet.

Seitliche Überschriften

In einem einspaltigen Dokument mit seitlichen Überschriften nehmen die Fußnoten in der Spalte die Breite der Spalte ein. Die Fußnoten in einer seitlichen Überschrift erstrecken sich jedoch über die Breite des Seitenbereichs und der Spalte.

Fußnoten in einer seitlichen Überschrift erstrecken sich über Spalte und Seitenbereich.

Wenn Sie eine Fußnote in einer seitlichen Überschrift mit den Fußnoten in der Spalte ausrichten möchten, vergrößern Sie die Einrückung der Fußnoten im Seitenbereich um die Breite des Bereichs plus des Zwischenraums (siehe Ändern von Einzügen und Ausrichtung).

Verbundene Elemente

In einem mehrspaltigen Layout, in dem es Text gibt, der alle Spalten miteinander verbindet, und Text, der diese Funktion nicht erfüllt, kann es auch Fußnoten geben, die Spalten verbinden, und Fußnoten, die die Spalten nicht verbinden. Fußnoten, deren Referenzen sich in verbundenem Text befinden, verbinden immer die Spalten. Diese Fußnoten werden am unteren Rand des Textrahmens angezeigt. Fußnoten, deren Referenzen sich in nicht verbundenem Text befinden, verbinden die Spalten, wenn für das Absatzformat der Fußnote der Eintrag "Über alle Spalten" (Einstellung "Seitenumbruch" im Dialogfenster "Absatzgestaltung") festgelegt ist.

Fußnote über alle Spalten

Ist das Absatzformat auf "In Spalte" eingestellt, wird die Fußnote entweder direkt über dem nächsten verbundenen Absatz (falls vorhanden) oder am Ende der Spalte platziert.

Fußnote in einer Spalte

Wenn die Fußnoten nicht in der richtigen Reihenfolge angezeigt werden, wählen Sie als Absatzformat für die Fußnote "Über alle Spalten". Die Fußnoten werden dann in numerischer Reihenfolge am unteren Seitenrand angeordnet.


Querverweise und Fußnoten

Arbeiten mit Endnoten

Endnoten werden am Ende eines Dokuments anstatt am Ende einer Seite oder Tabelle aufgeführt. Sie geben die Endnoten am Ende des Dokuments wie jeden anderen Absatz ein, versehen den Endnotenabsatz mit einer automatischen Nummerierung und verwenden dann Querverweise auf die automatisch nummerierten Absätze als Endnotenreferenzen.

FrameMaker verwaltet Endnoten nicht automatisch. Wenn Sie die Reihenfolge der Endnotenreferenzen während der Bearbeitung des Dokuments ändern, müssen Sie die Endnoten in einer damit übereinstimmenden Reihenfolge neu anordnen. Wenn eine Anmerkung am Dokumentende gelöscht wird, müssen Sie ihre Referenz manuell entfernen. Wenn Sie Anmerkungen am Dokumentende nicht auf diese Weise verwalten möchten, sollten Sie stattdessen Fußnoten verwenden. Die Reihenfolge und die Nummerierung von Fußnoten wird von FrameMaker automatisch verwaltet.

So erstellen Sie Endnoten:

    1. Geben Sie die erste Anmerkung am Ende des Dokuments ein und weisen Sie ihr das Absatzformat für Anmerkungen am Dokumentende zu. Im Absatzformat sollte die automatische Nummerierung aktiviert sein, damit die Anmerkungen fortlaufend nummeriert werden.

    2. Klicken Sie an die Stelle, an der die Endnotenreferenz eingefügt werden soll, und erstellen Sie einen Querverweis auf die Anmerkung. Verwenden Sie das Querverweisformat, das Sie für Anmerkungen am Dokumentende erstellt haben.

Sollen die entsprechenden Referenzen beispielsweise hochgestellt angezeigt werden und enthält das Dokument das Zeichenformat "Hochgestellt", zeigt das Querverweisformat <Hochgestellt><$AbsNumExkl> die Nummer des Anmerkungsabsatzes hochgestellt an.

    3. Legen Sie zusätzliche Endnoten auf die gleiche Weise an.

So verwalten Sie Endnoten:

Führen Sie eine der folgenden Aktionen durch:

    Wenn Sie beim Bearbeiten des Dokuments die Reihenfolge der Anmerkungsreferenzen ändern, müssen Sie die Anmerkungen entsprechend der Reihenfolge der Referenzen anordnen. Aktualisieren Sie dann die Querverweise und damit auch die Referenznummern der Endnoten. Informationen zum Aktualisieren von Querverweisen finden Sie unter Verwalten von Querverweisen.

    Wenn Sie eine Endnote löschen, müssen Sie anschließend alle zugehörigen Referenzen entfernen. Andernfalls wird aus der Referenz ein ungelöster Querverweis.


Querverweise und Fußnoten

Arbeiten mit Querverweisen in strukturierten Dokumenten

Beim Arbeiten mit strukturierten Dokumenten sorgt FrameMaker dafür, dass Querverweise, Variablen und Fußnoten immer aktuell sind. Um in FrameMaker einen Querverweis hinzuzufügen, verwenden Sie gewöhnlich ein speziell für diesen Zweck eingerichtetes Element. Das Querverweiselement verweist auf eine Position oder Quelle, die sich im selben Dokument oder in einem anderen Dokument befinden kann. Die Quelle ist in der Regel auch ein Element, z. B. ein Kapitel-, Abschnitt-, Abbildungs- oder Tabellenelement.

Wenn Sie an beiden Enden eines Querverweises ein Element verwenden, d. h. das Querverweiselement sowie ein weiteres Element als Quelle, wird der Verweis in der Struktur des Dokuments dargestellt und bleibt beim Export in das XML- bzw. SGML-Format erhalten.

Die meisten elementbasierten Querverweise zeigen Text aus dem Quellelement bis zum ersten Absatzumbruch an. Im folgenden Beispiel verweist der Querverweis auf ein Element "Abschnitt" und zeigt am Anfang des Abschnitts Text aus dem Element "Überschrift" an.

Ein elementbasierter Querverweis zeigt Text aus dem Quellelement an.

Bei einem Querverweis auf eine Quelle in einem nicht strukturierten Textfluss kann die Quelle entweder ein ganzer Absatz oder eine markierte Stelle im Text sein. Sie können auch auf einen Absatz oder eine Stelle in einem strukturierten Textfluss verweisen, es empfiehlt sich jedoch, auf ein anderes Element zu verweisen. (Querverweiselemente werden häufig so definiert, dass sie ungültig werden, wenn sie nicht auf ein Element verweisen.)


Querverweise und Fußnoten / Arbeiten mit Querverweisen in strukturierten Dokumenten

ID-Attribute und ID-Referenzattribute in strukturierten Dokumenten

FrameMaker verwendet in Querverweisen und Quellelementen Attribute, um die Verbindung der beiden Elemente aufrechtzuerhalten. Das Quellelement weist ein ID-Attribut auf, das im Dokument oder Buch eine eindeutige Kennung speichert. Das Querverweiselement hat ein ID-Referenzattribut, das ebenfalls die Kennung der Quelle speichert, um verfolgen zu können, worauf die Referenz verweist.

Sie können diese Attribute anzeigen, indem Sie die Strukturansicht mit eingeblendeten Attributen aufrufen. In der Regel müssen Sie an diesen Attributen jedoch keine Änderungen vornehmen.

ID aus dem Quellelement (oben), dieselbe ID gespeichert im Querverweis (unten)

In den meisten Fällen werden die IDs von FrameMaker als Zufallszeichenfolge aus acht Zeichen generiert. (Sie können die IDs für die Attribute jedoch auch selbst festlegen.) Wenn Sie anschließend einen Querverweis einfügen und seine Quelle angeben, fügt FrameMaker die ID der Quelle in das Attribut des Querverweises ein.

Eine von FrameMaker generierte ID entspricht der Struktur-Referenzsyntax, damit Ihre Querverweise beim Export in ein strukturiertes Format erhalten bleiben.


Querverweise und Fußnoten / Arbeiten mit Querverweisen in strukturierten Dokumenten

Querverweisformate in strukturierten Dokumenten

Ein Querverweisformat legt das Erscheinungsbild eines Querverweises fest: seinen Wortlaut, die angezeigten Quellinformationen sowie optional alle besonderen Textformatierungen. Für den Querverweis Siehe "Vulkanismus und Plattentektonik" auf Seite 7-71 könnte z. B. dieses Format verwendet werden:

A: Text, der wörtlich erscheint B: Bausteine

Die Bausteine der Formel werden durch Quellinformationen ersetzt und bei Bedarf aktualisiert, z. B. wenn sich die Seitennummer des Quellelements ändert.

Beim Einfügen eines Querverweises können Sie das Format auswählen. Ein Querverweiselement kann, als Teil seiner Elementdefinition, bereits mit einem Format verknüpft sein.

Wenn Ihr Dokument kein Querverweisformat enthält, das Sie verwenden möchten, ziehen Sie Ihren Entwickler zu Rate, damit er für Sie ein neues Format definiert oder ein vorhandenes Format anpasst.

Mit den folgenden Bausteinen können Sie Querverweisformate erstellen, die auf strukturierte FrameMaker-Elemente verweisen:

Baustein | Bedeutung
<$ElemSeiteNum> | Die Seitennummer des Quellelements
<$ElemText> | Der Text des Quellelements (bis zum ersten Absatzumbruch) ohne die automatische Nummerierung, aber mit allen Präfixen und Suffixen, die in der Elementdefinition festgelegt wurden.
<$ElemTextExkl> | Der Text des Quellelements (bis zum ersten Absatzumbruch) ohne die automatische Nummerierung und mit allen Präfixen und Suffixen, die in der Elementdefinition festgelegt wurden.
<$ElemTag> | Der Typ des Quellelements
<$ElemAbsNum> | Die gesamte automatische Nummerierung des ersten Absatzes des Quellelements (oder des Absatzes mit dem Quellelement), inklusive jeglichen Textes im Format der automatischen Nummerierung.
<$ElemAbsNumExkl> | Die Zähler der automatischen Nummerierung für den ersten Absatz des Quellelements (oder für den Absatz mit dem Quellelement), inklusive jeglicher Zeichen zwischen den Zählern.
<$Attribut[AttrName]> | Der Wert eines Attributs mit dem angegebenen Namen (oder dem Standardwert, falls kein Wert angegeben ist)


Querverweise und Fußnoten

Einfügen elementbasierter Querverweise in strukturierte Dokumente

Beim Einfügen eines Querverweises verwenden Sie in der Regel ein Querverweiselement und verknüpfen den Verweis mit einem anderen Element. Das Quellelement kann aus einem ganzen Abschnitt oder Kapitel bestehen, einer Tabelle oder einer Grafik, einem Absatz oder aus einer bestimmten Stelle in einem Absatz (z. B. einer Definition), abhängig davon, wie die Elemente in Ihrem Dokument definiert wurden.

Hinweis: Ein Element kann nur dann als Quelle für Querverweise dienen, wenn es über ein eindeutiges ID-Attribut verfügt. Wenn Sie einen Querverweis auf eine Quelle einfügen möchten, die keine ID-Attribute hat, wenden Sie sich an Ihren Anwendungsentwickler, um das Attribut zur Definition des Quellelements hinzuzufügen.

Informationen zum Einfügen eines Querverweises, der kein Element ist, oder zum Verweisen auf eine Quelle, die ein Absatz oder eine Stelle in einem Absatz ist, finden Sie unter Einfügen von Querverweisen.

So fügen Sie einen elementbasierten Querverweis ein:

    1. Wenn sich das Quellelement in einem anderen Dokument befindet, müssen Sie das Dokument öffnen. Wenn das Quellelement keinen Wert enthält, der mit seinem ID-Attribut verknüpft ist, müssen Sie für das andere Dokument schreibberechtigt sein, damit FrameMaker eine ID erzeugen kann.

    2. Klicken Sie an die Stelle, an der das Querverweiselement eingefügt werden soll. Sie können einen Querverweis in Textrahmen, aber nicht in Textzeilen einfügen (grafische Objekte, die mit dem Textzeilen-Werkzeug erzeugt wurden).

    3. Wählen Sie im Elementkatalog ein Querverweiselement aus und klicken Sie auf "Einfügen".

Sie können auch über "Spezial > Querverweis" ein Element einfügen. Wenn mehrere Elemente verfügbar sind, wählen Sie das gewünschte Element aus dem Aufklappmenü "Element-Tag" im Dialogfenster "Querverweis".

    4. Wenn Sie Querverweise auf Informationen in einem anderen Dokument erzeugen, wählen Sie den Namen dieses Dokuments aus dem Aufklappmenü "Dokument".

    5. Wählen Sie aus dem Aufklappmenü "Quelltyp" die Option "Elemente aufgelistet in Reihenfolge" oder "Elemente geordnet nach ID" aus. Die Typen aller Elemente, für die ein ID-Attribut definiert wurde (in den Elementdefinitionen des Quelldokuments), werden in der Auswahlliste "Element-Tags" angezeigt.

Listen Sie Elemente nach IDs auf, wenn Sie IDs zur Verfügung gestellt und Werte verwendet haben, die den Inhalt der Elemente definieren. (Wenn FrameMaker die IDs geliefert hat, sind die Werte Zufallszeichenfolgen, die bei der Suche nach dem gewünschten Element nicht hilfreich sind.)

    6. Wählen Sie aus der Auswahlliste "Element-Tags" den Typ des Quellelements. Wenn Sie z. B. einen Querverweis auf ein Abschnittelement erzeugen, wählen Sie "Abschnitt". Alle Abschnittelemente des Quelldokuments erscheinen in der Auswahlliste "Element".

Einige Elemente können Kontextbezeichnungen enthalten, um Angaben über die Position des Elements in der Struktur zur Verfügung zu stellen. Wenn z. B. Abschnittelemente in andere Abschnittelemente eingebettet sind, können die Bezeichnungen angeben, ob die Elemente Abschnitte erster, zweiter oder dritter Ebene sind.

Kontextbezeichnungen

Wenn in einem Element Kontextbezeichnungen verwendet werden, wird in der Auswahlliste auch der Eintrag <keine Bezeichnung> für Vorkommen des Elements angezeigt, die von der Kontextbezeichnung nicht beschrieben wurden. In obigem Beispiel stellt "Abschnitt (<keine Bezeichnung>)" Abschnittelemente dar, die sich auf der vierten oder einer niedrigeren Ebene des Dokuments befinden.

    7. Wählen Sie das Element, für das Sie in der Liste "Elemente" einen Querverweis anlegen möchten.

Wenn Sie aus dem Aufklappmenü "Quelltyp" die Option "Elemente aufgelistet in Reihenfolge" wählen, werden die Elemente in der Reihenfolge ihres Auftretens im Dokument aufgelistet.

Wenn Sie die Option "Elemente geordnet nach ID" aktivieren, werden die Elemente in alphabetischer Reihenfolge nach dem ID-Wert aufgelistet. Der ID-Wert wird zuerst angezeigt, gefolgt von einem Doppelpunkt und dem Anfangstext des Elements. Elemente ohne ID-Wert werden mit einem vorangestellten Doppelpunkt am Ende der Liste angezeigt.

    8. Um das Querverweisformat zu ändern, wählen Sie ein Format aus dem Aufklappmenü "Format". In dem Menü werden die Querverweisformate aufgelistet, die im aktuellen Dokument enthalten sind. Der Querverweis verfügt möglicherweise über ein vorausgewähltes Format, das Sie jedoch ändern können, ohne dass es als irreguläre Formatregel gilt.

Sprechen Sie mit Ihrem Entwickler, bevor Sie ein Querverweisformat ändern. Ihr Dokument enthält möglicherweise für jedes Format, das Sie benötigen, ein Element.

    9. Klicken Sie auf "Einfügen". FrameMaker fügt den Querverweis an der Einfügemarke ein. In der Strukturansicht werden ein Elementrechteck und ein Textausschnitt mit dem ersten Teil des Verweistextes angezeigt.

    10. Wenn das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für den Querverweis ein und wählen Sie "Element einfügen" (siehe Eingeben von Attributwerten beim Einfügen von Elementen).

Wenn an der gewünschten Position kein Querverweiselement verfügbar ist, können Sie ein ungültiges Element verwenden. Sprechen Sie nach dem Einfügen des Elements mit Ihrem Entwickler darüber, wie sich das Element an dieser Position in ein gültiges Element umwandeln lässt.

So verwenden Sie ein ungültiges Querverweiselement:

Führen Sie eine der folgenden Aktionen aus:

    Um ein Querverweiselement zu verwenden, das in einem anderen Teil des Dokuments gültig ist, fügen Sie das Element entweder an einer neuen Position ein oder fügen Sie das Element an einer gültigen Position ein und verschieben es, oder verwenden Sie die Einstellung "Alle Elemente" (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument), um das Element überall verfügbar zu machen, und fügen Sie das Element dann an der gewünschten Position ein.

    Um ein ungültiges Querverweiselement mit einem Standardtyp einzufügen, wählen Sie "Spezial > Querverweis" und anschließend aus dem Aufklappmenü "Element-Tag" die Option "QUERVERW". (Diese Option wird in dem Menü angezeigt, wenn keine festgelegten Querverweiselemente zur Verfügung stehen.)


Querverweise und Fußnoten

Arbeiten mit ID-Werten in strukturierten Dokumenten

FrameMaker hält die Verbindung zwischen einem Querverweiselement und einem Quellelement anhand von Attributen aufrecht. Das Quellelement weist ein ID-Attribut mit einem Wert auf, der die Position im Dokument eindeutig kennzeichnet. Wenn Sie einen Querverweis auf die Quelle einfügen, wird derselbe Wert in einem ID-Referenzattribut für das Querverweiselement abgelegt.

Wenn Sie einen Querverweis auf eine Quelle einfügen, die zwar ein ID-Attribut, jedoch noch keinen Wert für das Attribut aufweist, liefert FrameMaker automatisch den Wert.

ID-Attribute sind oft als schreibgeschützt definiert, sodass FrameMaker immer die ID-Werte bereitstellt. Eine von FrameMaker generierte ID ist eine Zeichenfolge aus acht Zeichen, die der XML- bzw. SGML-Referenzsyntax entspricht.


Querverweise und Fußnoten / Arbeiten mit ID-Werten in strukturierten Dokumenten

Prüfen von ID-Attributen in strukturierten Dokumenten

FrameMaker versucht auf verschiedene Weise sicherzustellen, dass Ihre IDs eindeutig sind:

    Wenn FrameMaker eine ID generiert, ist diese in diesem Dokument garantiert eindeutig. Dies trifft auch auf das dazugehörige Buch zu, da Dokumente in einem Buch unterschiedliche Dateinamen tragen und ein Teil der erzeugten IDs aus dem Dateinamen abgeleitet wird.

    Wenn Sie eine ID eingeben, die nicht einmalig ist, wird die ID nicht akzeptiert. FrameMaker prüft nicht, ob eine eingegebene ID in einem anderen Dokument des Buches verwendet wird, aber Sie können das Buch auf Gültigkeit prüfen, um doppelte IDs zu finden (siehe Prüfen von strukturierten Büchern).

    Wenn Sie die Kopie eines Elements mit einer duplizierten ID einfügen, verliert das eingefügte Element seine ID.

Es besteht immer noch die Möglichkeit, dass ein Dokument doppelte IDs enthält, wenn Sie beispielsweise bedingten Text einblenden, der ein Element mit derselben ID enthält wie ein anderes Element. Die duplizierten IDs werden in der Strukturansicht als ungültig gekennzeichnet. (Die ID wird rot angezeigt und weist an ihrer linken Seite ein rotes x auf.)

Ungültiger Wert

Ein ID-Referenzattribut kann so definiert sein, dass es einen Wert erfordert. Wenn ein Attribut einen Wert erfordert, jedoch keinen Wert aufweist, verweist der Querverweis wahrscheinlich auf einen Absatz oder eine Textstelle und nicht auf ein Element. FrameMaker kennzeichnet das Attribut in der Strukturansicht als ungültig. (Das Attribut verfügt über ein rotes Quadrat an seiner linken Seite und die Bezeichnung <Kein Wert> in Rot an der Stelle, an der sich der Wert befinden sollte.)

Fehlender erforderlicher Wert


Querverweise und Fußnoten / Arbeiten mit ID-Werten in strukturierten Dokumenten

Eingeben von eigenen ID-Werten in strukturierten Dokumenten

Wenn die ID-Attribute nicht schreibgeschützt sind, können Sie aussagekräftigere IDs verwenden. Geben Sie IDs für die Quellelemente ein, bevor Sie Querverweise einfügen.

So geben Sie einen Wert für ein ID-Attribut ein:

Geben Sie im Dialogfenster "Attribute" eine ID ein. Sie können alle auf der Tastatur verfügbaren Zeichen verwenden (bis zu 255 Zeichen). Information zum Eingeben von Attributen finden Sie unter Zuweisen von Attributwerten.

Beachten Sie, dass die ID im Dialogfenster "Querverweis" und in der Strukturansicht angezeigt wird. Verwenden Sie einen kurzen Namen, den Sie sich merken oder später leicht erkennen können. Sie können z. B. einem Element den ID-Wert Kunst für ein Kapitel mit dem Titel Kunsthandwerk zuweisen.

Wenn der Export in das XML- bzw. SGML-Format geplant ist, sollten Sie die Benennungsregeln für die Syntax befolgen, die Sie in XML oder SGML verwenden. Lassen Sie sich von Ihrem Anwendungsentwickler Empfehlungen zu der zulässigen Länge der Namen und zu den zulässigen Zeichen geben.

Sie können eine ID auch bearbeiten (sofern das Attribut nicht als schreibgeschützt definiert ist), dadurch werden jedoch alle auf das Element verweisenden Querverweise zu ungelösten Querverweisen.

Wenn Sie die ID eines Elements ändern müssen, können Sie vorhandene Querverweise auf das Element aktualisieren. Suchen Sie nach Elementen mit einem ID-Referenzattribut in der alten ID und ersetzen Sie die alte ID durch die neue. Weitere Informationen zum Suchen nach Attributwerten finden Sie unter Suchen von Elementen und Attributen.


Querverweise und Fußnoten

Auflösen von Querverweisen in strukturierten Dokumenten

Manchmal kann FrameMaker einen Querverweis nicht aktualisieren, weil die Quelle nicht auffindbar ist. Dies kann die folgenden Ursachen haben:

    Die Quelle des Querverweises wurde in eine andere Datei verschoben oder die Quelldatei selbst wurde verschoben oder umbenannt.

    Die Quelle wurde gelöscht oder (falls die Quelle ein Absatz oder eine Stelle in einem Absatz ist) die Marke für die Quelle wurde gelöscht.

    Der Wert für das ID-Attribut des Quellelements oder das ID-Referenzattribut des Querverweises wurde geändert oder gelöscht. Der ID-Wert muss jeweils derselbe sein.

Weitere Informationen zum Auflösen von Querverweisen finden Sie unter Auflösen von Querverweisen.

So lösen Sie einen Querverweis, wenn die Quelle gelöscht wurde:

    1. Wählen Sie "Bearbeiten> Suchen/Ändern".

    2. Wählen Sie aus dem Aufklappmenü "Suchen" die Option "Ungelöster Querverweis" und klicken Sie auf "Suchen". Das Dialogfenster "Suchen/Ändern" sucht den ersten ungelösten Querverweis und zeigt die ID, das Element-Tag sowie den Text der Quelle an.

    3. Führen Sie eine der folgenden Aktionen aus:

    Löschen Sie den Querverweis, wenn Sie ihn nicht benötigen.

    Wenn der Querverweis auf eine andere Quelle verweisen soll, doppelklicken Sie im Dokumentfenster auf den Verweis, um das Dialogfenster "Querverweis" zu öffnen. Legen Sie eine Quelle fest und klicken Sie auf "Ersetzen".

    4. Wiederholen Sie Schritt 2 und Schritt 3, bis alle ungelösten Querverweise gelöst sind.

So lösen Sie einen Querverweis, wenn die ID und die ID-Referenzwerte nicht übereinstimmen:

Ändern Sie den ID-Wert oder den ID-Referenzwert so, dass die beiden Werte übereinstimmen. (ID-Attribute sind häufig schreibgeschützt, d. h. Sie müssen möglicherweise die ID-Referenz ändern.) Informationen zum Bearbeiten von Attributwerten finden Sie unter Eingeben oder Bearbeiten von Attributwerten für bereits im Dokument vorhandene Elemente.

So erstellen Sie eine Liste ungelöster Querverweise:

    1. Wählen Sie "Spezial > Liste von > Referenzen". Wenn Sie dazu aufgefordert werden, geben Sie an, ob die generierte Datei als unabhängiges Dokument oder als Teil eines Buches erstellt werden soll.

    2. Verschieben Sie den Eintrag "Ungelöste Querverweise" in die Liste "Übernahme der Referenzen" und klicken Sie auf "Zuweisen".

Die generierte Liste enthält die Seitennummer jedes ungelösten Querverweises. Sie gibt an, ob die einzelnen fehlenden Quellen intern (in der aktuellen Datei) oder extern (in einer anderen Datei) sind, und sie zeigt ID, Element-Tag und Text des Quellelements an.

Erzeugte Liste ungelöster Querverweise

Hinweis: Die Elementinformationen in einer generierten Liste werden möglicherweise nicht korrekt angegeben, wenn sie seit dem Einfügen von Querverweisen nicht mehr aktualisiert wurden.


Querverweise und Fußnoten

Arbeiten mit Fußnoten in strukturierten Dokumenten

Sie können in einem strukturierten Dokument Fußnoten in einen Spalten- oder Tabellentext wie in einem nicht strukturierten Dokument einfügen.

A: Fußnote B: Fußnoten-Trennlinie C: Fußnotenreferenz

Ihr Dokument enthält Eigenschaften, die das Erscheinungsbild der Fußnoten bestimmen, z. B. die Art der Nummerierung (Zahlen, Buchstaben oder Symbole), das Absatzformat für Fußnotentext und den Abstand über den Trennlinien. Wenn Sie eine dieser Eigenschaften ändern müssen, wenden Sie sich an Ihren Anwendungsentwickler.

Informationen über Fußnoten sowie das Einfügen von Fußnoten, die keine Elemente sind (ein Vorgang, der nur in einem nicht strukturierten Textfluss möglich ist), finden Sie unter Arbeiten mit Fußnoten.

So fügen Sie ein Fußnotenelement ein:

    1. Klicken Sie an die Stelle, an der die Fußnotenreferenz angezeigt werden soll.

    2. Wählen Sie im Elementkatalog ein Fußnotenelement aus und klicken Sie auf "Einfügen".

FrameMaker fügt die Fußnotenreferenz ein, zeigt eine Fußnotennummer am Ende der Spalte oder der Tabelle an und nummeriert die nachfolgenden Fußnoten neu. In der Strukturansicht wird ein Elementrechteck mit einem Textausschnitt angezeigt, der den Anfang des Fußnotentextes enthält.

Sie können Fußnotenelemente auch über "Spezial > Fußnote" einfügen. Wenn mehrere Fußnotenelemente verfügbar sind, wählen Sie im angezeigten Dialogfenster ein Element aus dem Aufklappmenü "Element-Tag".

    3. Wenn das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für das Element ein und klicken auf "Element einfügen" (siehe Zuweisen von Attributwerten).

    4. Geben Sie den Text der Fußnote an der Einfügemarke ein. Wenn die Eingabe des Fußnotentextes beendet ist, kehren Sie in den Haupttext zurück, indem Sie in den Text klicken oder "Spezial > Fußnote" wählen.

Wenn an der gewünschten Position kein Fußnotenelement verfügbar ist, können Sie ein ungültiges Element verwenden. Sprechen Sie nach dem Einfügen des Elements mit Ihrem Entwickler darüber, wie sich das Element an dieser Position in ein gültiges Element umwandeln lässt.

So verwenden Sie ein ungültiges Fußnotenelement:

Führen Sie eine der folgenden Aktionen aus:

    Um ein Element zu verwenden, das in einem anderen Teil des Dokuments gültig ist, fügen Sie das Element an einer gültigen Position ein und verschieben es, oder benutzen Sie die Einstellung "Alle Elemente" (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument), um das Element überall verfügbar zu machen, und fügen Sie das Element dann an der gewünschten Position ein.

    Um eine ungültige Fußnote vom Standardtyp "FUSSNOTE" einzufügen, wählen Sie "Spezial > Fußnote". (Wenn keine festgelegten Fußnotenelemente verfügbar sind, wird eine Standard-Fußnote erzeugt.)

So ändern Sie den Text einer Fußnote:

Wählen Sie den Fußnotentext und bearbeiten Sie ihn wie normalen Text. Die Fußnotennummer kann nicht geändert werden, da sie von FrameMaker automatisch vergeben wird.

So wählen Sie eine Fußnote für die weitere Bearbeitung aus:

Klicken Sie auf die Fußnotenreferenz (nicht in den Fußnotentext) oder klicken Sie in der Strukturansicht auf das Elementrechteck der Fußnote.


Querverweise und Fußnoten / Arbeiten mit Fußnoten in strukturierten Dokumenten

Einfügen mehrerer Verweise auf eine Fußnote in einem strukturierten Dokument

Sie können eine einzelne Fußnote erstellen, auf die mehrere Fußnotenreferenzen verweisen, z. B. eine Tabellenfußnote mit Verweisen in mehreren Zellen.

Zwei Referenzen auf dieselbe Fußnote

Hierfür fügen Sie die Fußnote auf die übliche Weise ein und verwenden Querverweise für die zusätzlichen Verweise.

Für die zusätzlichen Referenzen muss bereits ein für diesen Zweck definiertes Querverweiselement vorhanden sein. Das Element sollte die Referenznummer ebenso anzeigen wie die ursprüngliche Fußnotenreferenz. Wenn z. B. die Nummer in der Originalreferenz hochgestellt ist, sollte die Nummer im Querverweiselement ebenfalls hochgestellt sein.

Hinweis: Wenn Sie eine Fußnote vor der Fußnote hinzufügen oder entfernen, auf die durch einen Querverweis verwiesen wird, verweist der Querverweis unter Umständen auf die falsche Nummer. Wählen Sie "Bearbeiten > Referenzen aktualisieren", um die Nummerierung zu aktualisieren.

So fügen Sie mehrere Referenzen auf eine Fußnote ein:

    1. Fügen Sie das Fußnotenelement ein.

    2. Fügen Sie an der Stelle, an der Sie eine zusätzliche Fußnotenreferenz anlegen möchten, ein Querverweiselement ein, das so definiert wurde, dass es nur eine Fußnotenreferenz anzeigt (siehe Einfügen elementbasierter Querverweise in strukturierte Dokumente).


Querverweise und Fußnoten

Arbeiten mit Endnoten in strukturierten Dokumenten

In strukturierten Dokumenten verwenden Sie zum Einfügen von Endnoten in der Regel Elemente. Das Endnotenelement ist ein normaler, automatisch nummerierter Absatz (kein Fußnotenelement). Das Querverweiselement zeigt eine Referenznummer zu der Endnote an.

Allgemeine Informationen über Endnoten, die Verwaltung von Endnoten und das Einrichten von Endnoten ohne Verwendung von Elementen (in der Regel nur in nicht strukturierten Textflüssen) finden Sie unter Arbeiten mit Endnoten.

So erstellen Sie Endnoten:

    1. Fügen Sie das Endnotenelement am Ende des Dokuments ein und geben Sie den Text für die Endnote ein.

    2. Klicken Sie an die Stelle, an der der Verweis auf die Endnote eingefügt werden soll.

    3. Fügen Sie ein Querverweiselement ein, das für die Anzeige einer Endnotenreferenz definiert wurde (siehe Einfügen elementbasierter Querverweise in strukturierte Dokumente).

    4. Legen Sie zusätzliche Endnoten auf die gleiche Weise an.

Hinweis: Stellen Sie sicher, dass die Reihenfolge der Endnoten mit der Reihenfolge der Verweise im Dokument übereinstimmt. FrameMaker stellt nicht automatisch die richtige Reihenfolge der Endnoten her, wie dies bei Fußnoten der Fall ist.


Variablen und Gleichungen

Erläuterung von Variablen

Einfügen von Variablen

Bearbeiten von Variablen

Löschen von Variablen

Konvertieren von Variablen in Text

Aktualisieren von Systemvariablen auf Arbeits- und Referenzseiten

Importieren von Variablendefinitionen

Ändern von Variablendefinitionen

Erstellen von Variablen für laufende Kopf- und Fußzeilen

Arbeiten mit Variablen in strukturierten Dokumenten

Gleichungen

Verwenden der Gleichungspalette

Einfügen von FrameMath-Elementen

Erstellen von Gleichungen in strukturierten Dokumenten mithilfe von Elementen


Variablen und Gleichungen

Erläuterung von Variablen

Damit Sie eine kurze Textpassage (z. B. ein Wort oder eine Wortverbindung, die ein Produkt oder einen Firmennamen bezeichnet) an mehreren Stellen in einem Dokument wiederholen oder Systeminformationen, die automatisch aktualisiert werden (z. B. das aktuelle Datum), einfügen können, verwenden Sie Variablen. Variablen ersparen Ihnen die Arbeit, den Text selbst einzugeben oder zu ändern.

Variablen sind hilfreich, wenn sich ein bestimmter Text oft ändert oder an vielen Stellen im Dokument auftritt. Benutzerdefinierte Variablen, wie Produktnamen, werden vom Anwender definiert. Systemvariablen, wie das aktuelle Datum, verwenden Informationen von Adobe FrameMaker und Ihrem Rechnersystem.


Variablen und Gleichungen / Erläuterung von Variablen

Benutzervariablen

Jede Benutzervariable besteht aus einem Namen und einer Definition. Eine Definition enthält Text und optionale Bausteine für das Zeichenformat des Textes. Nehmen Sie an, Sie haben folgende Variable definiert:

<BuchTitelFormat> Die Geowissenschaften

Wenn das Zeichenformat "BuchTitelFormat" als Kursiv definiert ist, wird die Variable als Die Geowissenschaften in den Text eingefügt.

Sie können die Definition jeder Benutzervariablen ändern. Wenn Sie beispielsweise eine Variable für einen Buchtitel verwenden, können Sie die Definition der Variablen ändern, wenn ein anderer Buchtitel verwendet werden soll. Jedes Auftreten der Variablen im Dokument wird dann entsprechend der neuen Definition aktualisiert.

Die Standardschablonen stellen keine Benutzervariablen zur Verfügung. Wenn Sie eine dieser Schablonen verwenden, müssen Sie selbst Benutzervariablen definieren. Wenn Sie Schablonen verwenden, die in Ihrer Firma erstellt wurden, sind wahrscheinlich schon Benutzervariablen enthalten.


Variablen und Gleichungen / Erläuterung von Variablen

Systemvariablen

Dokumente beinhalten eine Reihe von Systemvariablen. Die Variablen zeigen Informationen an, die FrameMaker generiert, z. B. die aktuelle Seitennummer, die Seitenanzahl des aktuellen Dokuments oder das aktuelle Datum. Sie können keine dieser Systemvariablen löschen oder umbenennen und Sie können auch keine weiteren Systemvariablen hinzufügen.

Jede Systemvariable besteht aus einem Namen und einer Definition. Diese Definition kann folgende Elemente enthalten:

    Bausteine für Systeminformationen wie Monat, Tag, Jahr und Dateiname

    Textzeichen wie der Punkt und die Leerzeichen in 1. Mai 1997

    Bausteine für Zeichenformatänderungen

So hat beispielsweise die Variable "Tabellenabschnitt", die in einem Tabellentitel als (Abschnitt 3 von 5) angezeigt wird, folgende Definition.

A: Eingegebener Text B: Bausteine

Sie können die Definition, also die Art und Weise, wie Informationen angezeigt werden, jederzeit ändern, indem Sie Bausteine hinzufügen, entfernen, umstellen oder den Text der Definition ändern. So können Sie z. B. das Format für die Darstellung des aktuellen Datums ändern. Eine vollständige Liste der Systemvariablen und ihrer Standarddefinitionen finden Sie unter Standardwerte für Systemvariablen.

Am häufigsten werden Systemvariablen wahrscheinlich in Hintergrundtextrahmen, z. B. Kopf- und Fußzeilen, eingesetzt. (Ein Hintergrundtextrahmen befindet sich auf einer Vorgabeseite und weist keinen Textflusstyp auf.) Der Inhalt dieser Textrahmen erscheint dann auf den zugehörigen Arbeitsseiten. Sie können mit Systemvariablen beispielsweise laufende Kopf- und Fußzeilen mit Kapiteltiteln, Abschnittüberschriften oder anderen Informationen erstellen, die sich von Seite zu Seite ändern können.

Auf Vorgabeseiten werden die Namen von Systemvariablen angezeigt.

FrameMaker zeigt Werte auf Arbeitsseiten an.

Die Werte der auf den Vorgabeseiten eingefügten Systemvariablen werden automatisch aktualisiert. Wenn Sie eine Systemvariable auf einer Arbeits- oder Referenzseite platzieren, wird ihr Wert nur beim Öffnen und Drucken der Datei aktualisiert. In der geöffneten Datei können Sie den Wert auch manuell aktualisieren.

Hinweis: Variablen und Variablennamen unterstützen den Unicode-Standard zur Textcodierung.

Standardwerte für Systemvariablen

Die meisten Systemvariablen können auf Arbeits-, Referenz- und Vorgabeseiten eingefügt werden. Die Variablen "Aktuelle Seitennr." und "Laufende K/F" können jedoch nur in Hintergrundtextrahmen auf Vorgabeseiten eingefügt werden.

Systemvariable | Standarddefinition | Beispiel für die Anzeige
Aktuelle Seitennr. | <$AktSeiteNum> | 3
Seitenanzahl | <$LetzteSeiteNum> | 18
Aktuelles Datum (Lang) | <$TagNum>. <$MonatName> <$Jahr> | Oktober 11, 1997
Aktuelles Datum (Kurz) | <$MonatNum>/<$TagNum>/<$JahrKurz> | 10/11/97
Änderungsdatum (Lang) | <$MonatName> <$TagNum>, <$Jahr>, <$Stunde>:<$Minute00> <$ampm> | 24. September 1997, 10:48
Änderungsdatum (Kurz) | <$MonatNum>/<$TagNum>/<$JahrKurz> | 9/24/97
Erstellungsdatum (Lang) | <$TagNum>. <$MonatName> <$Jahr> | 1. Juli 1997
Erstellungsdatum (Kurz) | <$MonatNum>/<$TagNum>/<$JahrKurz> | 7/1/97
Dateiname (Lang) | <$DateinameLang> | (Windows) c:\Memos\Staffing.fm (UNIX) /usr/tom/Memos/Staffing.fm
Dateiname (Kurz) | <$Dateiname> | Staffing.fm
Tabellenfortsetzung | (Fortsetzung) | (Fortsetzung)
Tabellenabschnitt | (Seite <$TabSeiteNr> von <$TabSeiteZählen>) | (Seite 1 von 2)
Bandnummer | <$volnum> | 3
Kapitelnummer | <$chapnum> | 3
Laufende K/F 1 | <$AbsText[Titel]> | Die stürmischen Ozeane
Laufende K/F 2 | <$AbsText[Überschrift1]> | Ausrottungsgefahr
Laufende K/F 3 | <$Marke1> | Plattentektonik
Laufende K/F 4 | <$Marke2> | Vulkane
Laufende K/F 5-12 | <$AbsText[AbsTyp]> | Lava


Variablen und Gleichungen

Einfügen von Variablen

Sie können eine Variable in jeden Seitentyp einfügen, unabhängig davon, ob es sich um eine Arbeitsseite, eine Vorgabeseite oder eine Referenzseite handelt. Sie können Variablen in einen Textrahmen aber nicht in eine Textzeile einfügen.

So fügen Sie eine Variable ein:

    1. Um die Einfügemarke zu platzieren, klicken Sie auf die Stelle, an der die Variable erscheinen soll. Um die Variable "Aktuelle Seitennr." oder eine laufende Kopf-/Fußzeilenvariable (siehe Erläuterung von Variablen für laufende Kopf-/Fußzeilen) einzufügen, müssen Sie auf einer Vorgabeseite in einen Hintergrundtextrahmen klicken.

    2. Wählen Sie "Spezial > Variable".

    3. Wählen Sie die gewünschte Variable in der Auswahlliste "Variablen".

Die Auswahlliste enthält die für die Einfügemarke im Dokument zulässigen Variablen. Befindet sich die Einfügemarke beispielsweise in einem Textrahmen auf einer Arbeitsseite, wird die Variable "Aktuelle Seitennr." nicht aufgeführt. Die Benutzervariablen erscheinen in der Auswahlliste nach den Systemvariablen. Die letzte Systemvariable heißt "Tabellenabschnitt".

    4. Klicken Sie auf "Einfügen".

In den meisten Fällen erscheint der in einer Vorgabeseite eingefügte Wert einer Variablen auf der Vorgabeseite und den zugehörigen Arbeitsseiten. Bei der Variable "Aktuelle Seitennr." wird jedoch auf der Vorgabeseite das Zeichen # und auf den Arbeitsseiten die tatsächliche Seitennummer angezeigt. Wenn Sie eine Variable für laufende Kopf-/Fußzeilen einfügen, wird auf der Vorgabeseite der Variablenname und auf den Arbeitsseiten der Wert angezeigt.

So fügen Sie eine Variable mithilfe der Tastatur ein:

    1. Klicken Sie an die Stelle, an der die Variable eingefügt werden soll, und drücken Sie Strg+0 (null). Im Namensbereich am linken Rand der Statuszeile werden Sie zur Eingabe eines Variablennamens aufgefordert.

Eingabe des Variablennamens

    2. Beginnen Sie mit der Eingabe des Variablennamens.

Geben Sie Kleinbuchstaben ein, um vorwärts zu suchen, und Großbuchstaben, um rückwärts zu suchen. Sie können auch mithilfe der Nach-Oben- und Nach-Unten-Tasten durch die Variablen blättern. Sie müssen nur so viele Buchstaben eingeben, bis die Variable eindeutig bezeichnet ist. Heißt beispielsweise die einzige mit dem Buchstaben B beginnende Variable "BuchTitel", wird BuchTitel im Namensbereich angezeigt, sobald Sie B eingeben.

    3. Drücken Sie die Eingabetaste, um die Variable einzufügen. Sie können die Operation abbrechen, indem Sie Strg+c (Windows) bzw. Control+c (UNIX) drücken oder in das Dokument klicken, ohne die Eingabetaste zu drücken.


Variablen und Gleichungen

Bearbeiten von Variablen

Wenn Sie eine Variable einfügen, wird ihr Wert an der Einfügemarke angezeigt. Sie können die Variable verschieben, durch eine andere ersetzen oder löschen.

Variablen können nicht direkt im Dokument bearbeitet werden. Um eine Variable zu bearbeiten, müssen Sie ihre Definition ändern (siehe Ändern von Variablendefinitionen) oder sie in editierbaren Text konvertieren und diesen im Dokument bearbeiten. Nach dem Konvertieren in Text wird keine automatische Aktualisierung mehr durchgeführt, wenn Sie die Variablendefinition ändern.

So kopieren oder verschieben Sie eine Variable:

    1. Klicken Sie auf die Variable, um sie auszuwählen.

    2. Kopieren oder verschieben Sie die Variable wie normalen Text mit den Befehlen "Bearbeiten > Kopieren", "Bearbeiten > Ausschneiden" und "Bearbeiten > Einfügen.

So ersetzen Sie eine Variable:

    1. Doppelklicken Sie auf die Variable, um das Dialogfenster "Variable" zu öffnen.

    2. Wählen Sie in der Liste "Variablen" eine andere Variable aus und klicken Sie auf "Ersetzen".


Variablen und Gleichungen

Löschen von Variablen

Sie können eine Benutzer- oder Systemvariable direkt löschen. Sie können auch die Definition einer Benutzervariablen löschen. Dadurch wird jedes Auftreten dieser Variablen im Dokument in normalen Text konvertiert.

Um eine Variable in einem Texteinschub zu löschen, löschen Sie die Variable im Quelldokument.

So löschen Sie eine Variable:

Klicken Sie einmal auf die Variable, um sie auszuwählen. Durch Drücken der Rücktaste lässt sich eine Variable nicht löschen.

So löschen Sie die Definition einer Benutzervariablen:

    1. Wählen Sie "Spezial > Variable".

    2. Wählen Sie die betreffende Variable aus der Liste "Variablen" und klicken Sie auf "Definition bearbeiten".

    3. Klicken Sie auf "Löschen" und anschließend auf "Zurück".


Variablen und Gleichungen

Konvertieren von Variablen in Text

Nachdem Sie eine Variable in Text umgewandelt haben, können Sie den Text bearbeiten. Der Text wird jedoch nicht länger als Variable behandelt.

So konvertieren Sie eine Variable in Text:

    1. Soll nur ein einzelnes Auftreten einer Variablen konvertiert werden, wählen Sie es aus.

    2. Wählen Sie "Spezial > Variable" und klicken Sie auf "In Text konvertieren".

    3. Führen Sie eine der folgenden Aktionen aus:

    Um ein Auftreten einer Variablen zu konvertieren, klicken Sie auf "Ausgewählte Variable".

    Um jedes Auftreten einer bestimmten Variablen zu konvertieren, wählen Sie aus der Liste "Folgende Variablen" den Variablennamen aus oder wählen Sie aus dem Aufklappmenü "Variablen mit Element-Tag" das Element-Tag der Variablen.

    Um alle Variablen im Dokument zu konvertieren, klicken Sie auf "Alle Variablen".

    4. Klicken Sie auf "Konvertieren".


Variablen und Gleichungen

Aktualisieren von Systemvariablen auf Arbeits- und Referenzseiten

Wenn Sie die Definition einer Variablen ändern, erfolgt unabhängig vom Typ der Seite eine sofortige Aktualisierung im gesamten Dokument. Ändert sich jedoch der Wert (nicht die Definition) einer Variablen, wird jedes Auftreten der Variablen auf Arbeits- und Referenzseiten nur beim Öffnen oder Drucken der Datei automatisch aktualisiert. Variablen auf Vorgabeseiten werden aktualisiert, wenn Sie das Dokument speichern. Wenn sich der Wert einer Variablen nach dem Drucken oder Öffnen der Datei ändert, können Sie die Variable manuell aktualisieren.

Hinweis: Aktualisierte Variablen können zwar gedruckt werden, erscheinen jedoch nicht automatisch am Bildschirm, es sei denn, Sie bauen die Anzeige neu auf, indem Sie Strg+l (kleines L) drücken.

So aktualisieren Sie Variablen manuell:

    1. Wählen Sie "Spezial > Variable".

    2. Klicken Sie auf "Aktualisieren" und anschließend auf "OK".


Variablen und Gleichungen

Importieren von Variablendefinitionen

Sie können auch die Variablendefinitionen eines anderen Dokuments verwenden, indem Sie sie über "Datei > Importieren > Formate" in das aktuelle Dokument importieren. Weitere Informationen finden Sie unter Importieren und Aktualisieren von Formaten und Ändern des Formats von Dateien eines Buches.


Variablen und Gleichungen / Importieren von Variablendefinitionen

Erstellen von Benutzervariablen

Beim Erstellen einer Benutzervariablen müssen Sie ihren Namen, den Text, den sie enthalten soll, und das Zeichenformat des Textes angeben. Sie können beispielsweise eine Benutzervariable für einen Produktnamen erstellen, der sich ändern kann, oder für einen langen Handbuchtitel, der umständlich einzugeben ist.

Wenn Sie kein Zeichenformat in der Variablendefinition angeben, verwendet die Variable das Format an der Einfügemarke. Wenn Sie das Zeichenformat einer Variablen ändern, wird diese Änderung nur für die Variable wirksam und nicht für den nachfolgenden Text.

So erstellen Sie eine Benutzervariable:

    1. Klicken Sie in einen Textrahmen und wählen Sie "Spezial > Variable".

    2. Klicken Sie auf "Variable erstellen".

    3. Geben Sie den Namen und die Definition der Variablen ein. Bei Variablennamen wird Groß- und Kleinschreibung unterschieden, d. h. Überschrift und überschrift werden als zwei verschiedene Variablen interpretiert. Die gesamte Definition darf einschließlich des eingegebenen Textes und des Zeichenformats bis zu 255 Zeichen lang sein. Sie können keine Systemvariablen-Bausteine für Benutzervariablen verwenden.

Damit eine spitze Klammer als Teil des Textes einer Variablendefinition behandelt wird, müssen Sie ihr einen umgekehrten Schrägstrich (\) voranstellen.

Hinweis: Manche Sonderzeichen werden in Dialogfenstern auf eine andere Art und Weise eingegeben oder angezeigt. Auf Windows-Systemen müssen Sie eine Zeichenfolge eingeben, die mit einem umgekehrten Schrägstrich beginnt (\); siehe Überblick über die Eingabe in Dialogfenstern. Unter UNIX werden diese Zeichenfolgen mit umgekehrtem Schrägstrich evtl. in Textfeldern angezeigt, selbst wenn Sie diese Zeichenfolgen nicht eingeben müssen.

    4. Um das Zeichenformat innerhalb einer Variablendefinition zu ändern, gehen Sie wie folgt vor:

    Um ein im Zeichenformat-Katalog gespeichertes Zeichenformat zu verwenden, setzen Sie die Einfügemarke im Textfeld "Definition" an die Stelle, an der Sie das Zeichenformat ändern wollen, und klicken Sie in der Auswahlliste "Zeichenformate" auf das gewünschte Format. Die Auswahlliste enthält alle Formate aus dem Zeichenformat-Katalog des aktuellen Dokuments.

Wichtig: Verwenden Sie kein Zeichenformat, dessen Name spitze Klammern enthält.

    Um das Zeichenformat vor dem Ende der Variablen auf die Standardschrift des Absatzes zurückzusetzen, positionieren Sie die Einfügemarke im Textfeld "Definition" an der gewünschten Stelle und klicken Sie in der Auswahlliste "Zeichenformate" auf den Eintrag <Absatzstandardschrift> ( [image] ).

    5. Klicken Sie auf "Einfügen". Die Variable wird jetzt in der Liste "Benutzervariablen" angezeigt.

    6. Sollen mehrere Benutzervariablen hinzugefügt werden, wiederholen Sie die Schritte 3 bis 5.

    7. Klicken Sie auf "Zurück", um in das Dialogfenster "Variable" zurückzukehren. Klicken Sie hier erneut auf "Zurück".


Variablen und Gleichungen

Ändern von Variablendefinitionen

Sie können die Definition einer Variablen jederzeit ändern. Wenn Sie z. B. eine Variable für die Entwicklungsversion eines Produkts verwenden, muss die Definition eventuell in den endgültigen Produktnamen geändert werden.

Sobald Sie die Definition einer Variablen ändern, wird sie unabhängig vom Typ der Seite, auf der sie definiert ist, im gesamten Dokument aktualisiert. Befindet sich die Variable in der Kopf- oder Fußzeile einer Vorgabeseite, müssen Sie eine Arbeitsseite möglicherweise neu aufbauen, damit die Aktualisierung zu sehen ist.

Hinweis: Befindet sich eine Variable in einem Texteinschub, der die Formate des Quelldokuments verwendet, müssen Sie die Variablendefinition im Quelldokument ändern. Informationen über Texteinschübe und ihre Formatierungsoptionen finden Sie im Abschnitt Importieren von formatiertem Text.

So ändern Sie die Definition einer Variablen:

    1. Klicken Sie in einen Textrahmen und wählen Sie "Spezial > Variable". Um die Definition der Variablen "Aktuelle Seitennummer" oder einer laufenden Kopf- oder Fußzeilenvariablen zu ändern, müssen Sie in einen Hintergrundtextrahmen auf einer Vorgabeseite klicken.

    2. Wählen Sie die zu ändernde Variable aus der Liste "Variablen" und klicken Sie auf "Definition bearbeiten".

    3. Führen Sie eine der folgenden Aktionen aus:

    Handelt es sich um eine Benutzervariable, bearbeiten Sie ihren Namen oder ihre Definition und klicken Sie auf "Ändern".

    Handelt es sich um eine Systemvariable, ändern Sie ihre Definition und klicken Sie auf "Bearbeiten". Sie können an der Einfügemarke einen Baustein für Systeminformationen oder für ein Zeichenformat einfügen, indem Sie in der Auswahlliste "Bausteine" auf den gewünschten Baustein klicken. Die Liste enthält nur für die Variable geeignete Bausteine (z. B. <$DateinameLang> und <$Dateiname> bei Dateinamenvariablen). Alle Zeichenformate des Zeichenformat-Katalogs erscheinen am unteren Ende der Auswahlliste.

Informationen dazu, wie Sie den Text und das Zeichenformat in der Definition ändern können, finden Sie im Abschnitt Erstellen von Benutzervariablen.

    4. Wenn Sie eine Benutzervariable bearbeiten, können Sie noch weitere Variablen ändern, indem Sie den gewünschten Eintrag in der Auswahlliste wählen, die gewünschten Änderungen in der Definition vornehmen und auf "Ändern" klicken.

    5. Klicken Sie auf "Fertig".


Variablen und Gleichungen / Ändern von Variablendefinitionen

Ändern der Definition von Datums- und Zeitvariablen

FrameMaker stellt die Systemvariablen für das aktuelle Datum, das Änderungs- und das Erstellungsdatum (z. B. 17. Februar 2002 13:12) in einer kurzen und einer langen Version zur Verfügung. Für Datums- und Zeitvariablen können Sie die folgenden Bausteine verwenden:

Baustein | Angezeigter Wert | Beispiel
<$Sekunde> <$Sekunde00> | Sekunden | 8 oder 32 08 oder 32
<$Minute> <$Minute00> | Minuten sichern | 8 oder 32 08 oder 32
<$Stunde> <$Stunde01> <$Stunde24> | Stunden | 8 oder 12 08 oder 12 08 oder 22
<$ampm> <$AMPM> | Vor- oder Nachmittag | am oder pm AM oder PM
<$TagNum> <$TagNum01> | Anzahl der Tage | 8 oder 28 08 oder 28
<$TagName> <$TagNameKurz> | Name des Wochentags | Montag Mon
<$MonatNum> <$MonatNum01> | Nummer des Monats | 8 oder 12 08 oder 12
<$MonatName> <$MonatNameKurz> | Name des Monats | August Aug
<$Jahr> <$JahrKurz> | Jahr | 1997 97

FrameMaker bestimmt anhand der Sprache des aktuellen Absatzes, welche Sprache für Datums- Zeitvariablen verwendet wird. So wird z. B. die Variable des aktuellen Wochentages in einem englischen Absatz als Wednesday und in einem deutschen Absatz als Mittwoch angezeigt. Wenn Sie die Sprache eines Absatzes ändern, werden die enthaltenen Systemvariablen entsprechend aktualisiert.

Unterstützt Ihr System die Eingabe von japanischem Text in Dokumenten und Dialogfenstern, können zusätzlich die folgenden Bausteine für japanische Datumsangaben verwendet werden.

Baustein | Beispiel
<$TagNumKanjiKazu> | oder
<$TagNumKanjiNumerisch> | oder
<$MonatNumKanjiKazu> | oder
<$MonatNumKanjiNumerisch> | oder
<$Kaiserjahr> | 1 oder 10
<$Kaiserjahr01> | 01 oder 10
<$KaiserjahrSpezialKanjiKazu> | oder
<$KaiserjahrSpezialKanjiNumerisch> | oder
<$KaiserjahrKanjiKazu> | oder
<$KaiserjahrKanjiNumerisch> | oder
<$Kaiserära> |

Ein japanisches Datum wird in einer Variablen angezeigt, wenn diese eine japanische Schriftfamilie verwendet und die Einstellung "Sprache" den Wert "Nihongo" hat. Informationen über Bausteine für die chinesische und die koreanische Datumsanzeige finden Sie in den Online-Handbüchern im Verzeichnis "Documents".


Variablen und Gleichungen

Erstellen von Variablen für laufende Kopf- und Fußzeilen

Laufende Kopf- und Fußzeilenvariablen liefern Informationen über den Inhalt einer Seite und können sich daher von Seite zu Seite ändern. Sie können laufende Kopf- und Fußzeilenvariablen für die Nummer und den Titel des aktuellen Kapitels, für den Namen des aktuellen Abschnitts der ersten Ebene oder für die aktuelle Seitenzahl verwendet werden.

Neben Variablen für laufende Kopf- und Fußzeilen können Sie auch die Bausteine <$chapnum> und <$volnum> verwenden, um Kopf- und Fußzeilen Kapitel- und Bandnummern hinzuzufügen. Weitere Informationen finden Sie unter Aufnehmen von Kapitelnummern in Kopf- oder Fußzeilen.


Variablen und Gleichungen / Erstellen von Variablen für laufende Kopf- und Fußzeilen

Erläuterung von Variablen für laufende Kopf-/Fußzeilen

Laufende Kopf-/Fußzeilen verwenden Systemvariablen wie z. B. Variablen für die aktuelle Seite und das aktuelle Datum. Es stehen auch zwölf spezielle Systemvariablen zur Verfügung (Laufende K/F 1, Laufende K/F 2, Laufende K/F 3 usw.).

Eine Variable für laufende Kopf-/Fußzeilen kann auf einen Absatz eines bestimmten Typs (normalerweise Titel oder Überschrift) oder auf Markentext Bezug nehmen. Sie können die Standarddefinitionen dieser Variablen verwenden oder sie anpassen, indem Sie beispielsweise die Variablendefinition ändern.

Sie fügen eine laufende Kopf-/Fußzeilenvariable in einen Hintergrundtextrahmen auf einer Vorgabeseite auf die gleiche Weise wie an jeder anderen Position ein (siehe Einfügen von Variablen).

Standardmäßig verwenden die Variablen "Laufende K/F 1" und "Laufende K/F 2" Definitionen, die sich auf die Absatztypen Titel und Überschrift 1 beziehen. Die Variablen "Laufende K/F 3" und "Laufende K/F 4" verwenden Definitionen, die sich auf Marken beziehen. Die Variablen "Laufende K/F 5–12" beziehen sich auf Absatztypen, die Sie selbst definiert haben. Sie können diese Voreinstellungen vor oder nach dem Einfügen einer Variablen ändern. Informationen über das Ändern einer Variablendefinition finden Sie unter Ändern von Variablendefinitionen.


Variablen und Gleichungen / Erstellen von Variablen für laufende Kopf- und Fußzeilen

Laufende Kopf- und Fußzeilen, die auf Absatztypen basieren

Die folgende Tabelle zeigt einige Beispiele von laufenden Kopf- und Fußzeilen, die sich auf Absatztypen beziehen.

Variablendefinition einer laufenden Kopf-/Fußzeile | Erläuterung | Beispiel für die Anzeige
<$AbsText[Überschrift1]> | Der Text des ersten gefundenen Absatzes mit dem Typ "Überschrift1" | Arten der Plattengrenzen
<Kopfzeile><$AbsText [Überschrift1]> | Der Text des ersten Absatzes mit dem Typ "Überschrift1" (der Text wird im Zeichenformat Kopfzeile angezeigt – Großbuchstaben, kursiv) | ARTEN DER PLATTENGRENZEN
<$AbsNum[KapTitel]> | Die vollständige automatische Nummerierung des ersten Absatzes vom Typ "KapTitel" | Kapitel 2
<$AbsNumExkl[KapTitel]> | Die automatische Nummerierung des ersten Absatzes vom Typ "KapTitel" | 2
<$AbsTyp[Kapitel]> | Der Typ des ersten Absatzes vom Typ "Kapitel" | Kapitel
<$AbsText[KapTitel, AnhangTitel]> | Der Text des ersten Absatzes, der entweder vom Typ "KapTitel" oder vom Typ "AnhangTitel" ist | PLATTENTEKTONIK


Variablen und Gleichungen / Erstellen von Variablen für laufende Kopf- und Fußzeilen

Anzeigen von Text, Typ oder Nummer eines Absatzes

Laufende Kopf- und Fußzeilen dienen meistens dazu, den Text, die automatische Nummerierung oder den Typ eines bestimmten Absatzes anzuzeigen. In einer laufenden Kopfzeile kann beispielsweise die aktuelle Abschnittüberschrift oder die Kapitelnummer angezeigt werden.

FrameMaker durchsucht jede Arbeitsseite nach einem Absatz des angegebenen Typs und nimmt dessen Text, Nummer oder Typ in die laufende Kopf- oder Fußzeile auf. Enthält die Seite keinen Absatz des angegebenen Typs, werden die vorhergehenden Seiten durchsucht und die Informationen des ersten gefundenen Absatzes verwendet.

Die folgenden Bausteine in laufenden Kopf- und Fußzeilen beziehen sich auf einen Absatztyp.

Baustein | Angezeigter Wert
<$AbsText[Absatztyp]> | Der Text des Absatzes
<$AbsNum[Absatztyp]> | Die automatische Nummerierung des Absatzes (einschließlich Text mit Nummerierungsformat)
<$AbsNumExkl[Absatztyp]> | Die Zähler der automatischen Nummerierung des Absatzes einschließlich der Zeichen zwischen ihnen
<$AbsTyp[Absatztyp]> | Der Typ des Absatzes

Beachten Sie die folgenden Richtlinien zur Verwendung von Absatztyp-Bausteinen:

    Verwenden Sie keinen Absatztyp, der Klammern enthält.

    Ersetzen Sie die Angabe AbsTyp innerhalb des Bausteins durch den Typ des Absatzes, für den Sie Informationen anzeigen möchten. Löschen Sie dabei nicht die Klammern. Beispiele hierzu finden Sie unter Erläuterung von Variablen für laufende Kopf-/Fußzeilen.

    Sie können mehrere Absatztypen in den Teil [AbsTyp] eines Bausteins aufnehmen. Wenn Sie mehrere Absatztypen einschließen, verwendet FrameMaker den ersten gefundenen Absatz, der einen der angegebenen Typen aufweist. Trennen Sie die Typen durch Kommas, wie in folgendem Beispiel: <$AbsTyp[Überschrift1, Überschrift2]>


Variablen und Gleichungen / Erstellen von Variablen für laufende Kopf- und Fußzeilen

Anzeigen von Markentext

Wenn der Text, den Sie in einer Kopf- oder Fußzeile anzeigen möchten, nicht in dem Absatz selbst vorkommt, können Sie den mit einer Marke verknüpften Text anzeigen. Sie können z. B. eine Marke benutzen, um eine verkürzte Version eines Titels oder die Zusammenfassung des Inhalts einer Seite anzuzeigen. Wenn die Anzeige von Steuerzeichen aktiviert ist, erkennen Sie die Position einer Marke am Markensymbol [image] .

Der Seitenkopf enthält eine abgekürzte Überschrift.

In diesem Beispiel enthält die Marke den Text Plattengrenzen. Eine laufende Kopf- oder Fußzeile zeigt diesen Text im Seitenkopf an.

FrameMaker sucht diese Marke nach demselben Verfahren, wie auch Absatztypen gesucht werden. Befindet sich die Marke nicht auf der aktuellen Seite, werden die vorhergehenden Seiten durchsucht, bis eine Marke des angegebenen Typs gefunden wird. Sie können zwei Marken für laufende Kopf- oder Fußzeilen verwenden: "Kopf-/Fußzeile $1" und "Kopf-/ Fußzeile $2".

So zeigen Sie den Text einer Marke an:

    1. Fügen Sie auf der Vorgabeseite eine laufende K/F-Variable in die Kopf- oder Fußzeile ein (siehe Erläuterung von Variablen für laufende Kopf-/Fußzeilen). Standardmäßig verwenden die Variablen "Laufende K/F 3" und "Laufende K/F 4" Definitionen, die nach Marken suchen.

    2. Nehmen Sie in die Variablendefinition den Baustein <$Marke1> oder <$Marke2> auf (siehe Ändern von Variablendefinitionen). Der Baustein <$Marke1> zeigt den Text einer Marke der Kopf-/Fußzeile $1 an. Der Baustein <$Marke2> zeigt den Text einer Marke der Kopf-/Fußzeile $2 an.

    3. Zeigen Sie eine Arbeitsseite an und klicken Sie an die Stelle, an der die Marke eingefügt werden soll.

    4. Wählen Sie "Spezial > Marke".

    5. Wählen Sie im Dialogfenster "Marke" aus dem Aufklappmenü "Markentyp" den Eintrag "Kopf-/ Fußzeile $1" oder "Kopf-/Fußzeile $2", geben Sie den Markentext ein und klicken Sie auf "Neue Marke". Wenn Sie den Markentext eingeben, achten Sie auf korrekte Leerzeichen, Zeichensetzung und Groß-/Kleinschreibung.

Hinweis: Der Markentext kann im Dialogfenster "Markentext" nicht formatiert werden. Um den Text zu formatieren, fügen Sie in die Variablendefinition vor dem Markenbaustein einen Zeichenformat-Baustein ein.


Variablen und Gleichungen / Erstellen von Variablen für laufende Kopf- und Fußzeilen

Anzeigen eines Bedingungstyps

In einem Dokument mit bedingtem Text können Sie in einer laufenden Kopf- oder Fußzeile einen Bedingungstyp anzeigen lassen. Weitere Informationen zu diesem Thema finden Sie im Abschnitt Bedingter Text. Es gibt zwar keine vordefinierte Variable für diesen Zweck, Sie können aber in die Definition einer vorhandenen laufenden Kopf- oder Fußzeilenvariablen den Bedingungstyp-Baustein aufnehmen. Im Gegensatz zu den Systemvariablen, die sich auf einen Absatz oder eine Marke beziehen, suchen Variablen mit dem Bedingungstyp-Baustein nur auf der aktuellen Seite.

So zeigen Sie einen Bedingungstyp an:

    1. Fügen Sie auf der Vorgabeseite eine laufende K/F-Variable in die Kopf- oder Fußzeile ein (siehe Erstellen von Variablen für laufende Kopf- und Fußzeilen).

    2. Nehmen Sie den Baustein <$BedTyp [Typn, …,Typ1, NichtGefunden]> in die Variablendefinition auf (siehe Ändern von Variablendefinitionen).

Ersetzen Sie Typn, Typ1, und die Auslassung durch die Bedingungstypen, nach denen gesucht werden soll. Ersetzen Sie NichtGefunden durch den Text, der angezeigt werden soll, wenn FrameMaker einen der angegebenen Typen nicht findet. Soll in diesem Fall gar kein Text angezeigt werden, geben Sie für NichtGefunden ein umbruchgeschütztes Leerzeichen ein (ein umgekehrter Schrägstrich mit einem nachfolgenden Leerzeichen).

FrameMaker durchsucht eine Seite nach den Bedingungstypen, die Sie angeben. Wird einer der Typen gefunden, erscheint er in der laufenden Kopf- bzw. Fußzeile. Wenn mehrere Typen gefunden werden, wird der erste Typ der Definition als Wert der Variablen angezeigt.


Variablen und Gleichungen / Erstellen von Variablen für laufende Kopf- und Fußzeilen

Anzeigen der Sicherheitsebene

Wenn Ihr Dokument klassifizierte Informationen enthält, können Sie Bedingungstypen in laufenden Kopf- oder Fußzeilen verwenden, um die höchste Sicherheitsebene auf einer Seite anzuzeigen.

So zeigen Sie die Sicherheitsebene auf einer Seite an:

    1. Verwenden Sie für die klassifizierten Informationen Bedingungstypen wie "Streng geheim" und "Geheim".

    2. Richten Sie Kopf- und Fußzeilen mit diesen Typen auf Seiten ein, die klassifizierte Informationen enthalten. Soll beispielsweise der Typ "Streng geheim" auf Seiten angezeigt werden, die streng geheime und geheime Informationen enthalten, und der Typ "Offen" auf Seiten ohne Bedingungstyp, definieren Sie den Baustein als <$BedTyp[Streng geheim,Geheim,Offen]>.


Variablen und Gleichungen / Erstellen von Variablen für laufende Kopf- und Fußzeilen

Erstellen von Kopf- und Fußzeilen im Wörterbuchstil

Mit Kopf- oder Fußzeilen im Wörterbuchstil können Sie den Informationsbereich darstellen, den eine Arbeitsseite oder zwei gegenüberliegende Arbeitsseiten enthalten. Solche Kopf- und Fußzeilen werden häufig in Dokumenten wie Wörterbüchern, Indizes und Glossaren verwendet.

Kopfzeilen zeigen den ersten Eintrag links und den letzten rechts an.

So erstellen oder ändern Sie eine Kopf- oder Fußzeile im Wörterbuchstil:

    1. Fügen Sie unterschiedliche laufende Kopf- oder Fußzeilenvariablen in die Kopf- oder Fußzeile von zwei gegenüberliegenden Vorgabeseiten ein (siehe Erstellen von Variablen für laufende Kopf- und Fußzeilen). Verwenden Sie beispielsweise "Laufende K/F 1" für die linke und "Laufende K/F 2" für die rechte Vorgabeseite.

    2. Nehmen Sie in die Variablendefinition der linken Vorgabeseite den Baustein <$AbsText[Absatztyp]> (siehe Ändern von Variablendefinitionen) auf. Ersetzen Sie Absatztyp durch den Absatztyp des Wörterbucheintrags.

    3. Bearbeiten Sie die Variablendefinition auf der rechten Seite in der gleichen Weise, um den Baustein <$AbsText[Absatztyp]> aufzunehmen. Das Pluszeichen (+) gibt an, dass auf der Seite nicht nach dem ersten, sondern nach dem letzten Absatz mit dem angegebenen Typ gesucht werden soll.


Variablen und Gleichungen

Arbeiten mit Variablen in strukturierten Dokumenten

Genau wie in unstrukturierten Dokumenten, können Sie System- und Benutzervariablen auch in strukturierten Dokumenten verwenden.

Systemvariablen zeigen Informationen an, die das System generiert. Sie können eine Systemvariable mit oder ohne spezielle Variablenelemente zu einem strukturierten Textfluss hinzufügen

Benutzervariablen zeigen Text an, der mit der Variablen verknüpft ist. Sie verwenden keine speziellen Variablenelemente für Benutzervariablen, sondern Sie fügen sie direkt in Elemente ein, die für Text definiert wurden.

Die folgenden Bausteine in laufenden Kopf- und Fußzeilen beziehen sich auf ein Element-Tag:

Baustein | Bedeutung
<$ElemText[Tag]> | Der Text (bis zum ersten Absatzumbruch) exklusive der automatischen Nummerierung aber inklusive aller vor- und nachgestellten Elemente, die in der Elementdefinition festgelegt wurden.
<$ElemTextExkl[Tag]> | Der Text (bis zum ersten Absatzumbruch) exklusive der automatischen Nummerierung und aller vor- und nachgestellten Elemente, die in der Elementdefinition festgelegt wurden.
<$ElemTag[Tag]> | Das Tag
<$ElemAbsNum[Tag]> | Die vollständige automatische Nummerierung des ersten Absatzes des Elements
<$ElemAbsNumExkl[Tag]> | Die Zähler der automatischen Nummerierung des ersten Absatzes einschließlich aller Zeichen dazwischen


Variablen und Gleichungen / Arbeiten mit Variablen in strukturierten Dokumenten

Arbeiten mit gültigen Variablen in strukturierten Dokumenten

Variablen in FrameMaker werden als Entities exportiert, wobei der Name der Entity in der Regel mit dem Namen der Variablen übereinstimmt. Wenn Sie jedoch eine Variable erstellen, deren Name kein gültiger XML- oder SGML-Name ist, erhält die Entity einen anderen Namen als die Variable.

Beispiele für ungültige Namen:

    Name mit Multibyte-Zeichen (in asiatischen Sprachen)

    Name, der nur Sonderzeichen verwendet, die von alphanumerischen Zeichen, Bindestrichen und Punkten abweichen

    Name, der mehr Zeichen umfasst, als durch den Wert NAMELEN in den XML- oder SGML-Definitionen für die betreffende Anwendung festgelegt ist


Variablen und Gleichungen / Arbeiten mit Variablen in strukturierten Dokumenten

Einfügen von Systemvariablen-Elementen in strukturierte Dokumente

Um eine Systemvariable in einen strukturierten Textfluss zu integrieren, können Sie ein Element verwenden. FrameMaker verfügt über eine Reihe von Systemvariablen und über Formatregeln für Variablenelemente, in denen festgelegt ist, welche Variable mit welchem Element verwendet werden kann. Sie können ein Systemvariablen-Element nicht so ändern, dass es eine andere Variable verwendet.

Die Werte der Sytemvariablen in einem Dokument werden aktualisiert, wenn Sie das Dokument öffnen oder drucken. Sie können Systemvariablen auch manuell aktualisieren. (Systemvariablen in Kopf- oder Fußzeilen werden aktualisiert, wenn die Seite erneut angezeigt wird.)

Informationen über das Einfügen einer Systemvariablen, die kein Element ist, finden Sie unter Einfügen von Variablen.

So fügen Sie ein Systemvariablen-Element ein:

    1. Klicken Sie auf die Stelle, an der Sie die Variable einfügen möchten.

    2. Wählen Sie im Elementkatalog ein Systemvariablen-Element und klicken Sie auf "Einfügen".

    3. Wenn das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für das Element ein und klicken auf "Element einfügen" (siehe Hinzufügen von Elementen).

Der aktuelle Wert der Variablen erscheint an der Einfügemarke. In der Strukturansicht wird ein Elementrechteck für die Variable angezeigt und daneben ein Textausschnitt, der den Anfang des Textes der Variablen anzeigt.

Wenn an der gewünschten Position kein Variablenelement verfügbar ist, können Sie ein ungültiges Element verwenden. Sprechen Sie nach dem Einfügen des Elements mit Ihrem Entwickler darüber, wie sich das Element an dieser Position in ein gültiges Element umwandeln lässt.

So verwenden Sie ein ungültiges Systemvariablen-Element:

Fügen Sie ein Element ein, das an einer anderen Stelle im Dokument gültig ist. Entweder fügen Sie das Element an einer gültigen Stelle ein und verschieben es anschließend, oder Sie verwenden die Einstellung "Alle Elemente" (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument), um das Element überall im Dokument verfügbar zu machen, und fügen das Element dann an der gewünschten Stelle ein.

So aktualisieren Sie alle Systemvariablen im Dokument:

Wählen Sie "Spezial > Variable", klicken Sie auf "Aktualisieren" und dann auf "OK".


Variablen und Gleichungen / Arbeiten mit Variablen in strukturierten Dokumenten

Einfügen von Benutzervariablen in strukturierte Dokumente

Sie können eine Variable direkt in den Text einfügen, ohne ein spezielles Variablenelement zu verwenden. Ihre Anwendung verfügt eventuell über einige bereits definierte Benutzervariablen. Sie können weitere Benutzervariablen je nach Bedarf definieren. Wenn sich der Wert einer Benutzervariablen ändert, wird sie an allen Stellen, an denen sie auftritt, automatisch aktualisiert.

Informationen über das Definieren von Benutzervariablen finden Sie unter Erstellen von Benutzervariablen. Informationen über das Einfügen von Variablen finden Sie unter Einfügen von Variablen.


Variablen und Gleichungen

Gleichungen

FrameMaker bietet Ihnen eine große Auswahl an FrameMath-Elementen, mit denen Sie die Erstellung von Gleichungen optimieren können. Nach Erstellen einer Gleichung können Sie Schriftart, Ausrichtung und Positionierung der FrameMath-Elemente ändern. Sie können Gleichungen auch mit den Befehlen in der Gleichungspalette berechnen.


Variablen und Gleichungen

Verwenden der Gleichungspalette

Die Gleichungspalette enthält Befehle zum Erstellen und Ändern von Gleichungen sowie die Symbole, Operatoren, Funktionen und anderen Elemente, die Sie für Gleichungen benötigen. Um die Palette anzuzeigen, klicken Sie auf das Symbol "Gleichungen" ( [image] ) oben rechts im Dokumentfenster.

A: Das Aufklappmenü "Gleichungen" wird auf jeder Seite angezeigt. B: Die Seitennamen werden hier angezeigt, wobei immer die aktuelle Seite hervorgehoben ist. C: Dieser Teil der Palette ändert sich mit jeder Seite.

Die Gleichungspalette enthält neun Seiten mit FrameMath-Elementen und Befehlen. Klicken Sie oben in der Palette auf den Namen der Seite, die Sie anzeigen möchten.

Symbole

Griechische Buchstaben, Elementarsymbole, Diakritika und Zeichenketten

Operatoren

Wurzeln, Exponenten, Vorzeichen, Tiefstellung, Hochstellung und logische Symbole

Groß

Summe, Produkt, Integral, Schnittmenge und Vereinigungsmenge

Klammern

Runde, eckige und geschweifte Klammern und Substitution

Relationen

Gleich, kleiner, größer, ähnlich, Element von, Teilmenge von, Obermenge von und proportional zu

Analysis

Integrale, Ableitungen, partielle Ableitungen, Gradienten und Grenzen

Matrizen

Matrizen und Matrix-Befehle

Funktionen

Trigonometrische, hyperbolische und logarithmische Funktionen, Befehle zur Berechnung von Ausdrücken und für die Erstellung und Anwendung von Regeln

Positionierung

Steuerung für Position und Abstand eines Ausdrucks; Befehle für die Festlegung der Ausrichtung und Befehle zum Einstellen und Löschen manueller Zeilenumbrüche


Variablen und Gleichungen / Verwenden der Gleichungspalette

Positionieren von Gleichungen

Sie können eine Gleichung in einen Absatz integrieren oder als eigenen Absatz anzeigen. In beiden Fällen erstellt FrameMaker einen verankerten Rahmen für die Gleichung. Sie können eine Gleichung auch zusammen mit anderen Objekten in einem Grafikrahmen positionieren, z. B. um eine Grafik zu beschriften oder mehrere Gleichungen in einen Grafikrahmen zu setzen. Grafikrahmen mit Gleichungen können verankert oder unverankert sein.

A: In Absatztext B: Freigestellt C: In einer Grafik zusammen mit anderen Objekten


Variablen und Gleichungen / Verwenden der Gleichungspalette

Erstellen von Gleichungen

Um eine Gleichung zu erstellen, fügen Sie ein Gleichungsobjekt in das Dokument und anschließend FrameMath-Elemente in die Gleichung ein. In diesem Abschnitt wird die Erstellung eines Gleichungsobjekts erläutert. Detaillierte Informationen über das Einfügen von FrameMath-Elementen in Gleichungen finden Sie unter Einfügen von FrameMath-Elementen.

Informationen über die Erstellung von Gleichungen für SGML und XML finden Sie unter Gleichungselemente in strukturierten Dokumenten.

Vergrößern Sie die Darstellung so lange, bis die Gleichung einfach zu lesen ist.

So erstellen Sie Gleichungen in Textzeilen:

    1. Klicken Sie an der Stelle in den Text, an der Sie die Gleichung einfügen möchten. Falls sich der Text in einem gedrehten Textrahmen befindet, wählen Sie diesen aus und drücken Sie Esc g Umschalttaste+d 0 (null), um die Drehung aufzuheben.

    2. Wählen Sie "Spezial > Gleichungen" oder klicken Sie auf die Schaltfläche "Gleichungen" [image] auf der rechten Seite des Dokumentenfensters.

    3. Wählen Sie in der Gleichungspalette einen der Befehle "Neue Gleichung" aus dem Aufklappmenü "Gleichung". Die Optionen "Klein", "Normal" und "Groß" geben die Schriftgröße der neuen Gleichung an.

Unterhalb der Zeile mit der Einfügemarke wird ein neues Gleichungsobjekt in Form eines Fragezeichens innerhalb eines verankerten Rahmens eingefügt. Dieses Fragezeichen wird durch das erste von Ihnen eingegebene FrameMath-Element ersetzt.

Neue Gleichung in Absatztext

    4. Fügen Sie die FrameMath-Elemente in die Gleichung ein, indem Sie sie manuell eingeben oder auf die gewünschten Elemente in der Gleichungspalette klicken.

Eingefügte Elemente

    5. Wählen Sie "Gleichung einpassen" aus dem Aufklappmenü "Gleichung". Dadurch wird der Rahmen um die Gleichung verkleinert und die Gleichung in die Textzeile am Ankersymbol eingefügt.

In Textzeilen eingepasste Gleichungen

    6. Wenn die Gleichung auf beiden Seiten zu dicht am Text erscheint, fügen Sie vor und nach dem Rahmen ein Leerzeichen ein. FrameMaker behandelt einen Rahmen, der eine Gleichung in einem Absatztext enthält, als ein Zeichen und erzeugt kein zusätzliches Leerzeichen um ihn herum.

    7. Überschreitet die Gleichung die Zeilenhöhe, können Sie Platz über oder unter der Gleichung schaffen. Deaktivieren Sie dazu den festen Zeilenabstand im Aufklappmenü "Zeilenabstand" der Formatierungsleiste. Weitere Informationen finden Sie unter Ändern von Abständen.

So erstellen Sie eine Gleichung in einem eigenen Absatz (eine freigestellte Gleichung):

    1. Klicken Sie in einen leeren Absatz.

    2. Wählen Sie ein vorhandenes Absatzformat aus dem Absatzformat-Katalog (siehe Zuweisen von vordefinierten Formaten zu Text) oder definieren Sie ein neues Format. Die Ausrichtung (linksbündig, rechtsbündig oder zentriert), der vertikale Wortabstand und eventuelle automatische Nummerierungen für den die Gleichung enthaltenden Absatz wird durch das Absatzformat bestimmt.

Wenn das Dokument auf der Grundlage einer Buch- oder Berichtsschablone erstellt wurde, verwenden Sie das Absatzformat "Gleichung". Sie können dieses Format auch in Ihr Dokument kopieren. In diesem Fall werden Sie aber wahrscheinlich Änderungen vornehmen müssen (z. B. an den Einstellungen "Standardschrift" und "Abstand").

    3. Klicken Sie auf die Schaltfläche "Gleichungen" ( [image] ) am rechten Rand des Dokumentfensters.

    4. Wählen Sie in der Gleichungspalette einen der Befehle "Neue Gleichung" aus dem Aufklappmenü "Gleichung". Die Optionen "Klein", "Normal" und "Groß" geben die Schriftgröße der neuen Gleichung an.

Unterhalb des leeren Absatzes wird ein neues Gleichungsobjekt in Form eines Fragezeichens innerhalb eines verankerten Rahmens eingefügt. Dieses Fragezeichen wird durch das erste von Ihnen eingegebene FrameMath-Element ersetzt.

Neue Gleichung in einem verankerten Rahmen

    5. Fügen Sie die FrameMath-Elemente in die Gleichung ein, indem Sie sie manuell eingeben oder auf die gewünschten Elemente in der Gleichungspalette klicken.

Eingefügte Elemente

    6. Wählen Sie "Gleichung einpassen" aus dem Aufklappmenü "Gleichung". Dadurch wird der Rahmen um die Gleichung verkleinert und die Gleichung in den leeren Absatz eingefügt.

In einen eigenen Absatz eingepasste Gleichungen

So erstellen Sie eine Gleichung in einem Grafikrahmen mit anderen Objekten:

    1. Klicken Sie auf die Schaltfläche "Gleichungen" ( [image] ) am rechten Rand des Dokumentfensters.

    2. Wählen Sie einen Grafikrahmen oder ein Objekt in einem Grafikrahmen.

    3. Wählen Sie in der Gleichungspalette einen der Befehle "Neue Gleichung" aus dem Aufklappmenü "Gleichung". Die Optionen "Klein", "Normal" und "Groß" geben die Schriftgröße der neuen Gleichung an.

Ein neues Gleichungsobjekt wird als Fragezeichen in einem Rahmen angezeigt. Dieses Fragezeichen wird durch das erste von Ihnen eingegebene FrameMath-Element ersetzt.

Neues Gleichungsobjekt

    4. Fügen Sie die FrameMath-Elemente in die Gleichung ein, indem Sie sie manuell eingeben oder auf die gewünschten Elemente in der Gleichungspalette klicken.

    5. Um die Gleichung genau am gewünschten Ort zu platzieren, wählen Sie sie zunächst aus, indem Sie bei gedrückter Strg- bzw. Control-Taste darauf klicken.

    6. Führen Sie zum Verschieben einer Tabelle einen der folgenden Schritte aus:

    Ziehen Sie sie mit der Maus.

    Verlagern Sie die Gleichung mithilfe der Pfeiltasten.

    Verwenden Sie den Befehl "Grafiken > Objekteinstellungen", um die Gleichung zu positionieren.

Weitere Informationen finden Sie unter Verschieben von Objekten.


Variablen und Gleichungen

Einfügen von FrameMath-Elementen

Eine Gleichung enthält aus FrameMath-Elementen bestehende Ausdrücke – Zeichen, Zeichenfolgen, Operatoren und andere mathematische Elemente aus der Gleichungspalette.

A: Alphanumerisches Zeichen B: Zeichenfolge
C: Ausdruck D: Operator

Nach der Erstellung eines Gleichungsobjekts fügen Sie die FrameMath-Elemente ein. Verwenden Sie dazu die Tastatur oder klicken Sie in der Gleichungspalette auf die gewünschten Elemente. (Die Gleichungspalette muss nicht geöffnet sein, wenn Sie ein Element mit der Tastatur eingeben.) Die Erstellung von Gleichungen wird im Abschnitt Erstellen von Gleichungen detailliert beschrieben. Eine eingehende Beschreibung der FrameMath-Elemente in der Gleichungspalette finden Sie unter Verwenden der Gleichungspalette.

Führen Sie zum Einfügen von FrameMath-Elementen die folgenden allgemeinen Schritte aus. Einzelheiten zur Eingabe bestimmter Elementarten finden Sie unter Einfügen von Zeichenfolgen.

Hinweis: Mathematische Gleichungen unterstützen den Unicode-Standard zur Textcodierung.

So fügen Sie ein FrameMath-Element in eine Gleichung ein:

    1. Wählen Sie einen Ausdruck aus oder platzieren Sie die Einfügemarke in einer Gleichung.

    2. Führen Sie einen der folgenden Schritte aus:

    Klicken Sie auf das Element, um ein FrameMath-Element mithilfe der Gleichungstabelle einzufügen.

    Wenn Sie ein alphanumerisches Zeichen bzw. ein Symbol über die Tastatur einfügen wollen, geben Sie es ein. Sie können runde Klammern, eckige Klammern, Plus-, Gleichheitszeichen usw. eingeben. Wenn Sie eine offene runde Klammer eingeben, fügt FrameMaker die schließende Klammer ein.

    Drücken Sie die entsprechende Tastenfolge, um ein Element mithilfe von Tastaturbefehlen einzufügen.

    Um ein Element in einem Dialogfenster einzugeben, geben Sie einen umgekehrten Schrägstrich ( \ ) gefolgt von der das Element definierenden Zeichenfolge ein und drücken die Eingabetaste. Um z. B. das Unendlichkeitssymbol [image] einzufügen, geben Sie \ Unendlich ein und drücken die Eingabetaste.

    Informationen zum Einfügen eines speziellen FrameMath-Elements finden Sie unter Einfügen spezieller FrameMath-Elemente.

Wenn für ein Element ein oder mehrere Operanden benötigt werden, wird vor jedem Operanden ein Fragezeichen ( [image] ) angezeigt. Ist kein Operand erforderlich, sehen Sie die Einfügemarke. Drücken Sie die Tabulatortaste, um von einem Operanden zum nächsten zu wechseln.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Der Wirkungsbereich von Operationen

Wenn Sie ein FrameMath-Element in eine Gleichung einfügen, korrigiert FrameMaker die mathematische Syntax. Das Ergebnis hängt vom Wirkungsbereich der Operation ab, d. h. von der Auswahl oder von der Position der Einfügemarke. Wenn Sie z. B. x in einen Bruch eingeben, hängt das Ergebnis davon ab, ob der Zähler, der Nenner oder der ganze Bruch ausgewählt ist.

Multiplikation mit x | Ergebnis
oder |
oder |

Im ersten Beispiel wird lediglich die 7 mit x multipliziert. Im zweiten Beispiel fügt FrameMaker runde Klammern hinzu, um anzuzeigen, dass der gesamte Ausdruck 2y + 7 mit x multipliziert wird. Im letzten Beispiel wird der gesamte Bruch mit x multipliziert. Die Größe der Einfügemarke im ersten und letzten Beispiel zeigt den Wirkungsbereich an.

Zahlreiche Fehler in Gleichungen resultieren aus einem fehlerhaften Arbeitsbereich, der beim Einfügen eines Elements entweder zu gering oder zu groß bemessen wurde. Gehen Sie bei der Auswahl des gewünschten Bereichs sorgfältig vor, bevor Sie ein Element einfügen. Im Abschnitt Bearbeiten von Gleichungen wird beschrieben, wie man die Auswahl in einer Gleichung ändert.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen von Zeichenfolgen

Eine Textfolge ist eine Folge von Zeichen, die als Einheit interpretiert wird. Im Unterschied zu Zeichen, die einen Ausdruck darstellen, werden Zeichen in einer Zeichenfolge in der Regel nicht kursiv dargestellt und nicht miteinander multipliziert.

A: Zeichenfolgen

Zeichenfolgen besitzen in FrameMaker keine mathematische Bedeutung. So kann z. B. mit Rechenbefehlen die Funktion tan, nicht aber die Zeichenfolge "tan" berechnet werden.

So fügen Sie eine Zeichenfolge in eine Gleichung ein:

    1. Klicken Sie auf der Seite "Symbole" der Gleichungspalette auf "Textanfang". Es werden zwei doppelte Anführungszeichen ( " " ) angezeigt. Sie können zum Beginnen der Zeichenfolge auch einen Apostroph ( ' ) oder doppelte Anführungszeichen (") eingeben.

    2. Geben Sie den Text der Zeichenfolge ein. Die Anführungszeichen verschwinden und der Text wird in der eingegebenen Form angezeigt. Wenn Sie einen geraden Apostroph oder gerade Anführungszeichen als Teil der Zeichenfolge eingeben wollen, halten Sie beim Drücken der betreffenden Taste die Strg-Taste (Windows) bzw. die Control-Taste (UNIX) gedrückt.

    3. Klicken Sie auf der Seite "Symbole" auf "Textende" und drücken Sie die Eingabetaste.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Einfügen von Zeichenfolgen

Einfügen einer horizontalen oder vertikalen Liste mit Ausdrücken

Ein Gleichungsobjekt beinhaltet in der Regel eine Gleichung oder einen Ausdruck. Sie können jedoch eine horizontale oder vertikale Liste einrichten, in der mehrere Ausdrücke im selben Objekt enthalten sind. Wenn Sie eine Liste auswählen, werden alle Ausdrücke in der Liste als ein Objekt ausgewählt.

A: Horizontale Liste B: An Gleichheitszeichen ausgerichtete vertikale Liste

FrameMaker richtet die Ausdrücke in der Liste automatisch aus. Wenn Sie die Liste verschieben, behalten alle Ausdrücke ihre relative Position. Informationen über das Ändern der Elementausrichtung in einer Liste mit Ausdrücken finden Sie im Abschnitt Ausrichten von Elementen in Listen, Matrizen und mehrzeiligen Gleichungen.

So fügen Sie eine horizontale oder vertikale Liste mit Ausdrücken ein:

    1. Wählen Sie den Ausdruck aus, der das erste Element in der Liste sein soll.

    2. Klicken Sie auf der Seite "Operatoren" der Gleichungspalette auf das Element für horizontale ( [image] ) oder vertikale Listen ( [image] ). Eine horizontale bzw. vertikale Liste wird angezeigt. Der ausgewählte Ausdruck erscheint als erstes Element in der Liste. Ein zweites Element wird in der Liste als Fragezeichen angezeigt.

    Vor dem Klicken | Nach dem Klicken

Im ersten Beispiel wird eine horizontale Liste eingefügt. Im zweiten Beispiel wird eine vertikale Liste eingefügt und der ausgewählte Ausdruck wird zum ersten Element in der Liste. Im letzten Beispiel wird eine vertikale Liste als Teil eines größeren Ausdrucks eingefügt.

So fügen Sie einer horizontalen oder vertikalen Liste ein Element hinzu:

    1. Wählen Sie eines der Elemente in der Liste.

    2. Klicken Sie auf der Seite "Operatoren" der Gleichungspalette auf das Element für horizontale ( [image] ) oder vertikale Listen ( [image] ).

    3. Fügen Sie die FrameMath-Elemente in die Liste ein. Verwenden Sie dazu die Tastatur oder klicken Sie auf die betreffenden Elemente in der Gleichungspalette. Anweisungen hierzu finden Sie unter Einfügen von FrameMath-Elementen.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen von Symbolen

Die Seite "Symbole" der Gleichungspalette enthält das griechische Alphabet, sonstige Symbole und diakritische Zeichen.

Die Seite "Symbole"

Griechische Buchstaben, die Entsprechungen im lateinischen Alphabet besitzen, wie z. B. das große Alpha (A), sind auf der Seite "Symbole" nicht enthalten. Die folgenden Beispiele zeigen, wie sich das Klicken auf [image] auf der Seite "Symbole" auswirkt.

Vor dem Klicken | Nach dem Klicken

Diakritische Zeichen werden auf dem Element links neben der Einfügemarke oder auf dem gewählten Ausdruck angezeigt. Klicken Sie einmal auf jedes diakritische Zeichen, das Sie einfügen möchten.

Hinweis: Elemente für eine Summe, ein Produkt oder für partielle Ableitungen, die mathematisch berechnet und manipuliert werden sollen, fügen Sie nicht von der Seite "Symbole", sondern von der Seite "Groß" oder "Analysis" ein. Elemente der Seite "Symbole" werden nicht ausgewertet.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen von Operatoren

Die Seite "Operatoren" der Gleichungspalette enthält häufig verwendete Operatoren (Addition, Subtraktion, Multiplikation und Division) sowie Wurzeln, Exponenten, Vorzeichen, Hochstellungen, Tiefstellungen und logische Symbole.

Die Seite "Operatoren"

Wenn ein Ausdruck beim Einfügen eines Operators ausgewählt ist, wird er zum ersten Operanden. Die folgenden Beispiele zeigen, zu welchen Ergebnissen das Klicken auf das Pluszeichen ( [image] ) oder auf das Divisionszeichen ( [image] ) auf der Seite "Operatoren" führt.

Vor dem Klicken | Nach dem Klicken

Sie können das Divisionszeichen als Schrägstrich (/), als horizontalen Strich ( [image] ) oder als Divisionssymbol ( [image] ) darstellen. Weitere Informationen finden Sie unter Umschalten des Formats für ein Element.

FrameMaker kann Exponenten mathematisch auswerten, nicht jedoch hochgestellten Text.

A: Hochstellung B: Exponent


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen großer Elemente

Die Seite "Groß" der Gleichungspalette enthält Summen, Produkte, Integrale, Schnittmengen und Vereinigungsmengen.

Die Seite "Groß"

Wenn ein Ausdruck beim Einfügen eines großen Elements ausgewählt ist, wird er zum ersten Operanden. Die folgenden Beispiele zeigen, welches Ergebnis das Klicken auf das Summensymbol ( [image] ) auf der Seite "Groß" hat.

Vor dem Klicken | Nach dem Klicken

Sie können nach dem Einfügen eines FrameMath-Elements von der Seite "Groß" einen Operanden hinzufügen. Weitere Informationen finden Sie unter Einfügen von Operatoren.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen von Klammern

Die Seite "Klammern" enthält Begrenzungszeichen wie runde, eckige und geschweifte Klammern.

Die Seite "Klammern"

Wenn beim Einfügen eines Klammerpaares ein Ausdruck ausgewählt ist, wird dieser zwischen die Klammern platziert. Das folgende Beispiel zeigt, welches Ergebnis das Klicken auf die Klammern der Seite "Klammern" hat.

Vor dem Klicken | Nach dem Klicken

Sie können runde Klammern, eckige ([ ]) oder geschweifte ({ }) Klammern darstellen. Weitere Informationen finden Sie unter Umschalten des Formats für ein Element.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen von Relationen

Die Seite "Relationen" enthält Relationssymbole wie =, <, >, [image] , [image] , [image] , [image] und [image] .

Die Seite "Relationen"

Alle Relationssymbole gelten für das Zeichen links oder rechts neben der Einfügemarke oder der Auswahl, mit Ausnahme des zweiwertigen Gleichheitszeichens ( [image] ). Wenn Sie ein Relationssymbol zwischen multiplizierten Elementen einfügen, wirkt sich dieses auf die Elemente auf beiden Seiten der Einfügemarke aus.

Zweiwertige Gleichheitszeichen ( [image] ) erscheinen rechts neben dem aktuellen Ausdruck (wie im zweiten Beispiel). Wenn die Einfügemarke oder die Auswahl tief- oder hochgestellt formatiert ist, wird das Gleichheitszeichen tief- oder hochgestellt angezeigt.

Vor dem Klicken | Nach dem Klicken

So fügen Sie ein zweiwertiges Gleichheitszeichen an der Einfügemarke anstatt rechts vom Ausdruck ein:

Drücken Sie Esc m =

Vor dem Klicken | Nach dem Klicken


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen von Analysis-Elementen

Die Seite "Analysis" enthält Integrale, Ableitungen, partielle Ableitungen, Gradienten und die Limes-Funktion.

Die Seite "Analysis"

Wenn ein Ausdruck beim Einfügen eines Analysiselements ausgewählt ist, wird er zum ersten Operanden. Die folgenden Beispiele zeigen, welches Ergebnis das Klicken auf das Summensymbol ( [image] ) auf der Seite "Analysis" hat.

Vor dem Klicken | Nach dem Klicken

Sie können die Position von Operanden ändern und Operanden hinzufügen. Einzelheiten finden Sie unter Umschalten des Formats für ein Element und Hinzufügen von Operanden zu FrameMath-Elementen.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen von Matrizen

Die Seite "Matrizen" enthält Elemente für Matrizen in den Größen 1 mal 1 bis 3 mal 3. Sie können einer Matrix nach ihrer Erstellung Reihen und Spalten hinzufügen. Weitere Informationen finden Sie unter Ändern von Matrizen.

Die Seite "Matrizen"

Wenn ein Ausdruck beim Einfügen eines Matrizenelements ausgewählt ist, wird der Ausdruck zur ersten Zelle in der Matrix.

Vor dem Klicken | Nach dem Klicken


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen von Funktionen

Die Seite "Funktionen" enthält trigonometrische, hyperbolische und logarithmische Funktionen sowie die Funktionen Signum, Limes und allgemeine Funktionen.

Die Seite "Funktionen"

FrameMaker fügt Funktionen an der Einfügemarke oder an der Auswahl ein. Wenn ein Ausdruck ausgewählt ist, wird er zum Argument der Funktion (außer für die Limes-Funktion und die allgemeinen Funktionen [image] und [image] ). Das folgende Beispiel zeigt, welches Ergebnis das Klicken auf die Funktion "sin" auf der Seite "Funktionen" hat.

Vor dem Klicken | Nach dem Klicken


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einfügen spezieller FrameMath-Elemente

Zusätzlich zu den in FrameMaker enthaltenen FrameMath-Elementen können Sie für ein Dokument definierte FrameMath-Elemente einfügen. Informationen über die Definition spezieller FrameMath-Elemente finden Sie unter Erstellen und Definieren von FrameMath-Elementen.

Spezielle FrameMath-Elemente besitzen in FrameMaker keine mathematische Bedeutung. Ein spezielles FrameMath-Element für einen Operator wird in einer Gleichung als Operator behandelt, kann jedoch von FrameMaker nicht ausgewertet werden.

So fügen Sie ein spezielles FrameMath-Element in eine Gleichung ein:

    1. Wählen Sie in der Gleichungspalette "FrameMath-Element einfügen" aus dem Aufklappmenü "Gleichung".

    2. Wählen Sie das Element aus und klicken Sie auf "Einfügen".


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Einpassen von Gleichungen

Beim Einpassen einer Gleichung wird der umgebende verankerte Rahmen so verkleinert, dass er die Gleichung exakt umgibt. Die Ankerposition des Rahmens wird an die Einfügemarke verlagert und die Einfügemarke selbst wird hinter dem Rahmen positioniert.

Vor dem Einpassen

Nach dem Einpassen

Passen Sie eine Gleichung ein, nachdem Sie sie fertiggestellt haben, sodass sie nicht mehr Platz einnimmt als nötig und an der Grundlinie des umgebenden Textes ausgerichtet wird. Legen Sie eine Gleichung frei, um den verankerten Rahmen für eine leichtere Bearbeitung zu vergrößern.

So passen Sie eine Gleichung ein oder legen sie frei:

    1. Klicken Sie auf die Gleichung oder wählen Sie ihren Rahmen aus.

    2. Wählen Sie in der Gleichungspalette "Gleichung einpassen" oder "Gleichung freilegen" aus dem Aufklappmenü "Gleichung". Auch wenn die Kanten einer eingepassten Gleichung nicht auf dem Bildschirm angezeigt werden, erscheinen Sie dennoch im gedruckten Dokument.

Wenn Sie in bestimmten Buchdateien alle Gleichungen in Absatztext einpassen wollen, wählen Sie die betreffenden Dokumente des Buchs aus und drücken Esc Umschalttaste+r w m. Weitere Informationen finden Sie unter Verankerte Rahmen in einer Textzeile.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Bearbeiten von Gleichungen

Sie können eine Gleichung auf die gleiche Weise bearbeiten wie Text. Sie können FrameMath-Elemente hinzufügen, ändern, neu anordnen und entfernen sowie Gleichungen kopieren und einfügen. Wenn Sie eine Gleichung bearbeiten, wird die Syntax der Gleichung bei Bedarf angepasst.

Sie können Matrizen ändern – Reihen und Spalten hinzufügen oder löschen, Klammern löschen sowie die Zeilenhöhe und Spaltenbreite ändern. Sie können auch zwischen unterschiedlichen Darstellungen für einige FrameMath-Elemente, wie Klammern, wählen und Sie können einigen Elementen Operanden hinzufügen, wie Integrale und Summen.

Wenn Ihre Gleichung eingepasst wurde, legen Sie sie vor der Bearbeitung frei. Dadurch wird der verankerte Rahmen wieder in voller Größe angezeigt, und Sie haben mehr Platz für die Bearbeitung zur Verfügung.

Hinweis: Um eine gedrehte Gleichung zu bearbeiten, müssen Sie zuerst die Gleichung oder den Textrahmen wieder in ihre bzw. seine nicht gedrehte Position bringen. Dazu drücken Sie Esc g Umschalttaste+d 0 (null).

So platzieren und bewegen Sie die Einfügemarke in einer Gleichung:

Führen Sie eine der folgenden Aktionen aus:

    Um die Einfügemarke neben dem jeweiligen Zeichen einzufügen, klicken Sie so nah wie möglich neben dieses Zeichen.

Einfügemarke neben dem Zeichen einfügen

    Um die Einfügemarke neben eine Gleichung zu setzen, klicken Sie an das rechte Ende der Gleichung. Die Größe der Einfügemarke ist von ihrer Position in der Gleichung abhängig. Dies hilft Ihnen, festzustellen, ob sich die Einfügemarke an der richtigen Position befindet.

Einfügemarke neben der Gleichung einfügen

    Drücken Sie die Nach-Rechts-Taste und Nach-Links-Taste, um die Einfügemarke nach rechts oder links zu verschieben.

    Drücken Sie die Nach-Unten-Taste, um die Einfügemarke von der Seite eines Bruches in seinen Zähler zu verschieben.

    Drücken Sie die Nach-Oben-Taste, um eine Einfügemarke vom Nenner eines Bruches neben diesen zu verschieben.

So wählen Sie mit der Maus einen Teil einer Gleichung aus:

Ziehen Sie die Maus über die Elemente, die Sie einfügen möchten. Während des Ziehens wird die Auswahl zur Aufnahme des nächsten Unterausdrucks erweitert.

So erweitern Sie die Auswahl mithilfe der Tastatur:

Drücken Sie die Leertaste. Die Auswahl wird zur Aufnahme des nächst höheren Ausdrucks erweitert. Das folgende Beispiel zeigt, welches Ergebnis das wiederholte Drücken der Leertaste erzeugt.

Ursprüngliche Auswahl

Nach einmaligem Drücken

Nach zweimaligem Drücken

So ändern Sie die Auswahl:

Führen Sie eine der folgenden Aktionen aus:

    Um die Auswahl nach rechts auf den nächsten Teilausdruck zu verlagern, drücken Sie die Nach-Rechts-Taste.

    Um die Auswahl nach links auf den nächsten Teilausdruck zu verlagern, drücken Sie die Nach-Links-Taste.

    Um die Auswahl zum nächsten Fragezeichen zu verlagern, drücken Sie die Tabulatortaste.

So ersetzen Sie ein FrameMath-Element:

    1. Wählen Sie das Element, das Sie ersetzen möchten, und drücken Sie Entf.

    2. Klicken Sie auf die Gleichungspalette oder geben Sie die Ersetzung ein. Das neue Element ersetzt die Einfügemarke.

So löschen Sie ein FrameMath-Element:

    1. Wählen Sie das Element, das Sie löschen möchten, und drücken Sie Entf. Das Element wird durch ein Fragezeichen ersetzt.

    2. Drücken Sie erneut auf Entf. Die Einfügemarke wird angezeigt. FrameMaker entfernt auch alle nicht mehr benötigten Elemente, wie Pluszeichen oder Klammern.

So löschen Sie eine komplette Gleichung:

    1. Halten Sie die Strg- bzw. Control-Taste gedrückt und klicken Sie auf die Gleichung.

    2. Drücken Sie Entf.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Bearbeiten von Gleichungen

Entfernen von Klammern

Nach der Eingabe oder Bearbeitung einer Gleichung können Sie diese mit einer zusätzlichen Klammer abschließen – einer runden, geschweiften oder eckigen Klammer. Sie können diese zusätzlichen Klammern entfernen, wenn Sie jedoch später Rechenbefehle verwenden, wertet FrameMaker die Gleichung so aus, als ob die Klammern noch vorhanden wären.

So entfernen Sie alle runden, geschweiften und eckigen Klammern aus einem Ausdruck:

    1. Markieren Sie den Ausdruck.

    2. Klicken Sie auf der Seite "Klammern" der Gleichungspalette auf "Klammern entfernen".

    Vor dem Klicken | Nach dem Klicken

So entfernen Sie eine Klammer:

Platzieren Sie die Einfügemarke rechts neben der Klammer und drücken Sie die Entf-Taste. Wenn die Klammer eine Entsprechung besitzt, wie die linke Klammer zwischen a und b im folgenden Beispiel, wird diese ebenfalls entfernt.

Vorher | Nachher


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Bearbeiten von Gleichungen

Umschalten des Formats für ein Element

Einige FrameMath-Elemente können auf unterschiedliche Weise dargestellt werden. Klammern können z. B. im Format [image] , [image] oder [image] dargestellt werden. Divisionszeichen können im Format [image] , [image] oder [image] dargestellt werden.

So schalten Sie das Format eines Elements um:

    1. Markieren Sie das gesamte Element.

    2. Klicken Sie auf der Seite "Operatoren", "Groß", "Klammern" oder "Analysis" der Gleichungspalette auf "Format umschalten". Der Befehl ist auf allen vier Seiten identisch und funktioniert für jedes Element mit mehreren Formaten. Möglicherweise müssen Sie mehrmals klicken, um das gewünschte Format zu erhalten.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Bearbeiten von Gleichungen

Hinzufügen von Operanden zu FrameMath-Elementen

Wurzel- und Gradientzeichen sowie Logarithmen können einen oder zwei Operanden haben. Integrale und andere Zeichen auf den Seiten "Groß" und "Analysis" können einen, zwei oder drei Operanden haben.

Operanden

Sie können diesen Elementen Operanden hinzufügen, ohne noch einmal von vorne beginnen zu müssen.

So fügen Sie einem FrameMath-Element einen Operanden hinzu:

    1. Klicken Sie auf den Ausdruck mit dem Element oder wählen Sie einen beliebigen Teil des Ausdrucks aus.

Einfügemarke in Gleichungen

    2. Klicken Sie auf "Neuer Operand" auf der Seite "Groß" oder "Analysis". Ein Fragezeichen wird an der Stelle des einzufügenden Operanden angezeigt.

Hinzugefügter Operand


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Bearbeiten von Gleichungen

Ändern von Matrizen

Sie können die Anzahl der Zeilen und Spalten in einer Matrix ändern und eckige Klammern um die Matrix hinzufügen oder entfernen. Außerdem können Sie die Breite der Spalten je nach Inhalt variieren oder allen Spalten dieselbe Breite zuweisen. Auch die Zeilenhöhe kann von Zeile zu Zeile unterschiedlich festgelegt werden.

Sie können eine Matrix auch transponieren und algebraische Operationen mit ihr ausführen (siehe Das Aufklappmenü "Matrix-Befehle").

So fügen Sie einer Matrix eine Zeile oder eine Spalte hinzu:

    1. Platzieren Sie die Einfügemarke in der Matrix.

    2. Wählen Sie auf der Seite "Matrizen" der Gleichungspalette "Neue Zeile" oder "Neue Spalte" aus dem Aufklappmenü "Matrix-Befehle".

    Vor "Neue Spalte" | Nach "Neue Spalte"

Mit "Neue Zeile" fügen Sie eine Zeile am unteren Ende hinzu. Mit "Neue Spalte" fügen Sie eine Spalte auf der rechten Seite hinzu.

So löschen Sie eine Zeile oder Spalte aus einer Matrix:

Wählen Sie die Zeile oder die Spalte aus und drücken Sie die Entf-Taste.

Vorher | Nachher

So fügen Sie Klammern um eine Matrix hinzu oder entfernen sie:

    1. Markieren Sie die gesamte Matrix.

    2. Klicken Sie auf der Seite "Matrizen" der Gleichungspalette auf "Klammern hinzufügen/entf.".

So ändern Sie in einer Matrix die Zeilenhöhe oder die Spaltenbreite:

    1. Markieren Sie die Matrix.

    2. Wählen Sie auf der Seite "Matrizen" der Gleichungspalette "Gleichmäßig" oder "Proportional" aus dem Aufklappmenü "Höhe der Matrixzeile" bzw. "Breite der Matrixspalte".

Gleiche Zeilenhöhe (links) und proportionale Zeilenhöhe (rechts)

Wenn Sie "Proportional" wählen, ist jede Zeile so hoch wie die höchste Zelle der Zeile; jede Spalte ist so breit wie die breiteste Zelle der Spalte. Wenn Sie "Gleichmäßig" wählen, sind alle Zeilen so hoch wie die höchste Zelle der gesamten Matrix und alle Spalten so breit wie die breiteste Zelle der gesamten Matrix.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Erstellen und Definieren von FrameMath-Elementen

Wenn Sie ein FrameMath-Element benötigen, das sich nicht in der Gleichungspalette befindet, können Sie ein eigenes spezielles Element definieren, beispielsweise einen neuen Operator wie [image] . FrameMaker kann jedoch spezielle FrameMath-Elemente nicht mathematisch auswerten.

Wenn Sie ein integriertes Element der Palette in Ihrem Dokument verändert anzeigen möchten, können Sie es neu definieren. Sie können beispielsweise die Funktion asin (inverser Sinus) derart neu definieren, dass sie als sin–1 angezeigt wird. Sie können die Darstellungsweise eines integrierten Elements neu definieren, jedoch nicht seinen Typ ändern. Eine Beschreibung der frei definierbaren speziellen FrameMath-Elementtypen finden Sie unter FrameMath-Elementtypen.

Sie können auch FrameMath-Elementdefinitionen aus anderen Dokumenten importieren. Weitere Informationen finden Sie unter Importieren und Aktualisieren von Formaten.

FrameMath-Elementtypen

Der Typ eines FrameMath-Elements bestimmt, wie sich das Element in Bezug auf andere Elemente in seiner Umgebung verhält. Ein Pluszeichen (+) ist z. B. vom Typ "Einfügung", d. h., es hat immer zwei Operanden, einen auf der rechten und einen auf der linken Seite.

Sie können spezielle FrameMath-Elemente der folgenden Typen definieren.

Eingabe | Beispiel | Anzahl der Operanden
Atom |  | Kein
Klammern |  | Einer
Funktion |  | Einer, rechts des Elements
Einfügung |  | Zwei, links und rechts des Elements
Groß |  | Bis zu drei, oberhalb, unterhalb und rechts des Elements
Limes |  | Bis zu zwei, unterhalb und rechts des Elements
Präfix |  | Einer, links des Elements
Suffix |  | Einer, rechts des Elements
Vertikale Liste |  | Zwei, einer über dem anderen (Die Textzeile, die eine spezielle vertikale Liste definiert, wird als Trennlinie zwischen Listenelementen verwendet.)

Sie können keine speziellen FrameMath-Elemente der folgenden Typen definieren.

Eingabe | Beispiel
Ableitung |
Diakritische Zeichen |
Horizontale Liste |
Matrix |
Wurzel |
Schrift |
Substitution |
Bruch |


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Erstellen und Definieren von FrameMath-Elementen

Erstellen und Ändern von FrameMath-Elementdefinitionen

Die Definitionen spezieller FrameMath-Elemente werden auf einer oder mehreren Referenzseiten gespeichert, deren Namen mit FrameMath beginnen. Jede Definition ist eine Textzeile in einem unverankerten Grafikrahmen, dessen Name dem Namen des Elements entspricht.

A: Grafikrahmen B: Textzeile

So definieren Sie ein spezielles FrameMath-Element oder ändern die Definition eines integrierten FrameMath-Elements:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie eine FrameMath-Referenzseite an.

Wenn das Dokument keine FrameMath-Referenzseite enthält, zeigen Sie eine Referenzseite an und wählen danach "Spezial > Referenzseite einfügen". Nennen Sie die neue Seite "FrameMath1". (Verwenden Sie die Großbuchstaben F und M wie gezeigt.)

    2. Zeichnen Sie mit dem Grafikrahmen-Werkzeug einen unverankerten Grafikrahmen auf der Seite (siehe Verwenden von Referenzrahmen auf Referenzseiten).

    3. Geben Sie im Dialogfenster "Rahmenname" einen Namen für das FrameMath-Element ein. Wenn Sie ein integriertes Element ändern wollen, geben Sie den Namen des betreffenden Elements ein.

    4. Fügen Sie mithilfe des Textzeilen-Werkzeugs eine Textzeile in den Grafikrahmen ein (siehe Grafiken und Text).

    5. Erstellen Sie in der Textzeile das FrameMath-Element und beachten Sie dabei folgende Regeln:

    Sie können beliebige Zeichen in die Textzeile eingeben und das Zeichenformat ändern (siehe Zuweisen von vordefinierten Formaten zu Text und Ändern von Schrifteinstellungen). Sie können die Zeichen auch mithilfe von Kurzbefehlen zur Feinpositionierung verschieben.

    Für alle FrameMath-Elemente, mit Ausnahme von Klammern, wird in der Textzeile lediglich das mathematische Symbol dargestellt, nicht der Operand. Wenn Sie das Element später in einer Gleichung einfügen, fügt FrameMaker die Operanden entsprechend des Typs des FrameMath-Elements an der entsprechenden Stelle ein. Ein großes Element, wie ein Summen- oder ein Integralzeichen, besitzt beispielsweise bis zu drei Operanden: einen oberhalb, einen unterhalb und einen rechts vom Symbol.

    Ein spezielles Trennzeichen kann nur einen Operanden enthalten, auch wenn einige integrierte Trennzeichen bis zu drei enthalten. Fügen Sie ein Leerzeichen in die Textzeile ein, um die Position des Operanden anzuzeigen. Wenn Sie kein Leerzeichen in die Textzeile einfügen, fügt FrameMaker den Operanden zwischen zwei Kopien des Trennzeichens ein.

A: Zeichen zwischen Trennzeichen
B: Den Operanden anzeigendes Leerzeichen.

    FrameMaker verwendet die erste Textzeile in dem Rahmen für das spezielle FrameMath-Element. Stellen Sie daher sicher, das sich innerhalb des Rahmens nur eine Textzeile befindet.

    6. Wählen Sie den Grafikrahmen aus.

    7. Wählen Sie in der Gleichungspalette "Definition in Katalog aufnehmen" aus dem Aufklappmenü "Gleichung".

    8. Wenn Sie ein spezielles FrameMath-Element definieren, wählen Sie einen Elementtyp aus dem Kontextmenü und klicken Sie auf "Einfügen". Informationen über die definierbaren Typen finden Sie im Abschnitt FrameMath-Elementtypen.

So finden Sie den Namen eines FrameMath-Elements:

    1. Setzen Sie die Einfügemarke in eine Gleichung.

    2. Wählen Sie in der Gleichungspalette "FrameMath-Element einfügen" aus dem Aufklappmenü "Gleichung".

    3. Deaktivieren Sie "Nur Spezialelemente anzeigen" und blättern Sie durch die Elementnamen.

    4. Klicken Sie auf "Abbrechen".

So ändern Sie die Definition eines speziellen FrameMath-Elements:

    1. Zeigen Sie die FrameMath-Referenzseite an, die das FrameMath-Element enthält. Führen Sie dazu einen der folgenden Schritte aus:

    Wenn das spezielle FrameMath-Element zu einer Gleichung gehört, wählen Sie zunächst das Element und danach "Definition aktualisieren" aus dem Aufklappmenü "Gleichung" in der Gleichungspalette. Klicken Sie anschließend auf "Zu Rahmen wechseln".

    Wenn Sie das spezielle FrameMath-Element nicht in eine Gleichung eingefügt haben, wählen Sie "Darstellung > Referenzseiten". Zeigen Sie anschließend die gewünschte FrameMath-Referenzseite an.

    2. Bearbeiten Sie die Textzeile, die das FrameMath-Element enthält. Wenn Sie eine Arbeitsseite erneut anzeigen, verwendet FrameMaker die veränderte Definition und passt die Gleichungen erneut ein.

So löschen Sie die Definition eines speziellen FrameMath-Elements:

Zeigen Sie die FrameMath-Referenzseite an, die das FrameMath-Element enthält und löschen Sie den Grafikrahmen. Wenn das Element in einer Gleichung verwendet wird, zeigt FrameMaker anstatt des Elements den Elementnamen umgeben von Fragezeichen an.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Positionieren von FrameMath-Elementen in einer Gleichung

FrameMaker positioniert FrameMath-Elemente entsprechend ihrer mathematischen Bedeutung in der Gleichung. In bestimmen Fällen kann aber eine Feinpositionierung erforderlich sein, um den optimalen Abstand zwischen den Elementen in der Gleichung zu erreichen.

Vor und nach der Feinpositionierung

Sie können auch den freien Platz auf jeder Seite des Elements festlegen: links, rechts, oben und unten.

A: Standardabstand B: Links und rechts größerer Abstand C: Links und rechts kein Abstand

Sie können den Abstand in der Definition eines FrameMath-Elements so aktualisieren, dass der neue Abstand jedes Mal verwendet wird, wenn das Element im Dokument vorkommt.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Positionieren von FrameMath-Elementen in einer Gleichung

Feinpositionieren von Ausdrücken

Wenn Sie ein Element oder einen Ausdruck feinpositionieren, ändert sich seine Position in Relation zu allen anderen Elementen in der Gleichung. Wenn Sie beispielsweise den mittleren Ausdruck mittels der Feinpositionierung näher an das linke Element rücken, wie oben dargestellt, entfernt es sich entsprechend von dem rechten Element.

Vor und nach der Feinpositionierung

So positionieren Sie einen ausgewählten Ausdruck:

Klicken Sie auf der Seite "Positionierung" der Gleichungspalette auf einen Feinpositionierungspfeil. Klicken Sie so häufig, wie erforderlich. Jedes Klicken verlagert einen Ausdruck am Bildschirm um ein Pixel. Vergrößern Sie die Ansicht für eine höhere Präzision.

Feinpositionierungspfeile

So heben Sie die Feinpositionierung eines ausgewählten Ausdrucks auf:

Klicken Sie auf der Seite "Positionierung" der Gleichungspalette auf das Symbol in der Mitte des Bereichs "Feinpositionierung" [image] .

So überprüfen Sie die Abstände eines ausgewählten Ausdrucks und passen sie numerisch an:

    1. Klicken Sie auf der Seite "Positionierung" der Gleichungspalette auf "Positionseinstellungen". Die exakten Abstände werden im Bereich "Abstand bei Feinpositionierung" im Dialogfenster "Positionierung von FrameMath-Elementen" angezeigt.

    2. Geben Sie die entsprechenden Werte im Bereich "Abstand bei Feinpositionierung" ein und klicken Sie auf "Zuweisen".


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Positionieren von FrameMath-Elementen in einer Gleichung

Ändern des Abstands um einen Ausdruck

Sie können den freien Platz um Elemente oder Ausdrücke herum ändern. Sie können FrameMaker beispielsweise veranlassen, größere Trennzeichen um einen Ausdruck zu verwenden, indem der freie Platz oberhalb und unterhalb des Ausdrucks vergrößert wird.

Ursprünglicher Abstand und unten hinzugefügtes Leerzeichen

So vergrößern oder verkleinern Sie den Abstand um einen ausgewählten Ausdruck:

Klicken Sie auf der Seite "Positionierung" der Gleichungspalette auf ein Pluszeichen (+), um den Abstand zu vergrößern, bzw. auf ein Minuszeichen (–), um den Abstand zu verkleinern.

Abstandssteuerelemente

Klicken Sie so häufig, wie erforderlich. Durch jedes Klicken wird ein Abstands-Pixel hinzugefügt oder entfernt. Vergrößern Sie die Ansicht für eine höhere Präzision.

Hinweis: Wenn Sie den Abstand um den FrameMath-Elementtyp "Einfügung", "Präfix", "Suffix" oder "Trennzeichen" ändern wollen, passen Sie stattdessen den Abstand benachbarter FrameMath-Elemente an. Um z. B. den Abstand an beiden Seiten des Pluszeichens im Ausdruck a+b zu vergrößern, wählen Sie a aus und vergrößern den rechten Abstand. Danach wählen Sie b aus und vergrößern den linken Abstand. Eine Beschreibung der FrameMath-Elementtypen finden Sie unter FrameMath-Elementtypen.

So stellen Sie den Standardabstand um einen ausgewählten Ausdruck wieder her:

Klicken Sie auf der Seite "Positionierung" der Gleichungspalette auf das Symbol in der Mitte des Bereichs "Abstand" [image] .

So überprüfen Sie die Abstandswerte eines ausgewählten Ausdrucks und passen sie numerisch an:

    1. Klicken Sie auf der Seite "Positionierung" der Gleichungspalette auf "Positionseinstellungen". Die exakten Abstände werden im Bereich "Abstand" des Dialogfensters "Positionierung von FrameMath-Elementen" angezeigt.

    2. Geben Sie zum Anpassen der Abstandswerte die entsprechenden Werte im Bereich "Abstand" ein und klicken Sie auf "Zuweisen".


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Positionieren von FrameMath-Elementen in einer Gleichung

Ändern des Abstandes eines FrameMath-Elements bei jedem Auftreten

Einige Definitionen von FrameMath-Elementen ("Einfügung", "Präfix", "Suffix", "Groß", "Hoch-/Tiefstellung" und "Bruch") können mit neuen Abständen aktualisiert werden. FrameMaker passt den Abstand um das Element bei jedem Auftreten im Dokument an und passt die Gleichungen neu ein. Eine Beschreibung der FrameMath-Elementtypen finden Sie unter FrameMath-Elementtypen.

Sie können auch den Zeichenabstand in allen kleinen, mittleren und großen Gleichungen gleichmäßig ändern. Weitere Informationen finden Sie unter Ändern der Gleichungsschrift im gesamten Dokument.

So ändern Sie den Abstand für ein FrameMath-Element bei jedem Auftreten:

    1. Markieren Sie das Element, nachdem Sie den Abstand um das Element in einer Gleichung angepasst haben.

    2. Wählen Sie in der Gleichungspalette "Definition aktualisieren" aus dem Aufklappmenü "Gleichung".

    3. Führen Sie eine der folgenden Aktionen aus:

    Um den Abstand für das Element im gesamten Dokument zu ändern, klicken Sie auf "Aktualisieren".

    Wenn Sie den Standardabstand wiederherstellen wollen, klicken Sie auf "Standard".


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Festlegen von Zeilenumbrüchen und Ausrichten von Gleichungen

Sie können festlegen, wann ein Zeilenumbruch innerhalb einer Gleichung auftreten soll und wie die Zeilen in einer mehrzeiligen Gleichung oder die Elemente in einer Liste oder Matrix ausgerichtet werden sollen. Sie können auch mehrere Gleichungen aneinander ausrichten, selbst wenn sie in unterschiedlichen Rahmen platziert sind.

Ausrichtung an der linken Seite des Gleichheitszeichens

Gleichungsobjekte werden genauso wie andere Objekte bearbeitet. Weitere Informationen über das Gruppieren, Ausrichten und Drehen von Objekten finden Sie unter Bearbeiten und Anordnen von Objekten


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Festlegen von Zeilenumbrüchen und Ausrichten von Gleichungen

Ändern des Zeilenumbruchs in einer Gleichung

Wenn eine Gleichung in mehrere Zeilen umbrochen wird, bleibt sie in einem einzigen verankerten Rahmen. Sie können festlegen, wo die Zeilen in der Gleichung automatisch umbrochen werden. Wenn Sie die Zeilenlänge für den Umbruch ändern, wird die Gleichung entsprechend der neuen Breite neu formatiert.

Ursprüngliche Gleichung

Zeilenumbruch bei 1,25 Zoll

Sie können einen Zeilenumbruch an einer bestimmten Position in der Gleichung erzwingen. Verwenden Sie den manuellen Zeilenumbruch jedoch nicht zur Erstellung von separaten Gleichungen. Fügen Sie stattdessen eine vertikale Liste mit Ausdrücken ein (siehe Einfügen einer horizontalen oder vertikalen Liste mit Ausdrücken).

So ändern Sie die automatische Zeilenlänge für einen Umbruch in Gleichungen:

    1. Klicken Sie in die Gleichung oder wählen Sie einen Teil der Gleichung aus.

    2. Wählen Sie "Grafik > Objekteinstellungen".

    3. Ändern Sie den Wert im Textfeld "Automatischer Zeilenumbruch nach" und klicken Sie auf "Zuweisen". Der Wert ist auf die Rahmenbreite der Gleichung voreingestellt.

So fügen Sie einen manuellen Seitenumbruch ein:

    1. Klicken Sie an der Position, an der die Gleichung in zwei Zeilen umbrochen werden soll.

    2. Wählen auf der Seite "Positionierung" der Gleichungspalette "Manuell einstellen" aus dem Aufklappmenü "Zeilenumbruch". An der Einfügemarke wird ein Symbol für den Zeilenumbruch [image] eingefügt, wenn die Anzeige von Steuerzeichen aktiviert ist.

Manueller Zeilenumbruch

So entfernen Sie einen manuellen Seitenumbruch:

    1. Wählen Sie den Teil der Gleichung aus, in dem sich das Symbol für den Zeilenumbruch befindet.

    2. Wählen Sie auf der Seite "Positionierung" der Gleichungspalette "Manuell löschen" aus dem Aufklappmenü "Zeilenumbruch".


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Festlegen von Zeilenumbrüchen und Ausrichten von Gleichungen

Ausrichten von freigestellten Gleichungen

Die Ausrichtung einer freigestellten Gleichung (linksbündig, zentriert, rechtsbündig) wird vom Format des Absatzes bestimmt, in dem sie sich befindet.

Zentrierte Absatzausrichtung

So ändern Sie die Ausrichtung einer freigestellten Gleichung:

Klicken Sie innerhalb des Absatzes, der die Gleichung enthält (aber nicht in der Gleichung selbst) und wählen Sie die Ausrichtung aus dem Aufklappmenü "Ausrichtung" in der Formatierungsleiste oder in der Absatzgestaltung. Weitere Informationen finden Sie unter Ändern von Einzügen und Ausrichtung.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Festlegen von Zeilenumbrüchen und Ausrichten von Gleichungen

Ausrichten von Elementen in Listen, Matrizen und mehrzeiligen Gleichungen

Sie können Elemente in einer vertikalen Liste und Zeilen in mehrzeiligen Gleichungen automatisch linksbündig, rechtsbündig, zentriert oder an ihren Gleichheitszeichen ausrichten. Für die Elemente in einer vertikalen Liste und für mehrzeilige Gleichungen können Sie auch manuell eigene Ausrichtungspunkte festlegen. Die manuell eingegebenen Ausrichtungspunkte setzen die automatische Ausrichtung außer Kraft.

Ausrichtung an der linken Seite und an einem manuellen Ausrichtungspunkt

Die Elemente einer horizontalen Liste können an ihren oberen und unteren Rändern und an ihren Grundlinien ausgerichtet werden.

Ausrichtung an der Grundlinie

Die Zellen in den einzelnen Matrixzeilen können an ihren oberen und unteren Rändern und an ihren Grundlinien ausgerichtet werden. Die Zellen in jeder Spalte können rechtsbündig, linksbündig, zentriert oder am Gleichheitszeichen ausgerichtet werden.

Ausrichtung an:
A: Grundlinien B: Mitte

So legen Sie für eine vertikale Liste oder eine mehrzeilige Gleichung die automatische Ausrichtung fest:

    1. Klicken Sie in die Gleichung oder Liste.

    2. Wählen Sie auf der Seite "Positionierung" der Gleichungspalette einen Eintrag aus dem Aufklappmenü "Links/Rechts". Wenn Sie "Links von = " oder "Rechts von =" auswählen, werden die Zeilen am Gleichheitszeichen ausgerichtet. Eine Zeile ohne Gleichheitszeichen wird am linken Rand ausgerichtet.

So legen Sie einen manuellen Ausrichtungspunkt für eine mehrzeilige Gleichung oder für ein Element einer vertikalen Liste fest:

    1. Führen Sie eine der folgenden Aktionen aus:

    Klicken Sie in die erste Zeile einer mehrzeiligen Gleichung auf den Punkt, an dem die nachfolgenden Zeilen ausgerichtet werden sollen.

    Klicken Sie auf den Punkt eines Elements in einer vertikalen Liste, an dem der übrige Teil der Liste ausgerichtet werden soll.

    2. Wählen Sie auf der Seite "Positionierung" der Gleichungspalette "Manuell einstellen" aus dem Kontextmenü "Links/Rechts". Wenn die Anzeige von Steuerzeichen aktiviert ist, wird an der Einfügemarke ein Symbol für manuelle Ausrichtung [image] eingeblendet. Die folgenden Zeilen einer mehrzeiligen Gleichung werden linksbündig an dem manuellen Ausrichtungspunkt ausgerichtet. Elemente in vertikalen Listen werden mit anderen Elementen in der Liste an dem manuellen Ausrichtungspunkt ausgerichtet.

So löschen Sie einen manuellen Ausrichtungspunkt:

    1. Wählen Sie den Teil der Gleichung aus, der den manuellen Ausrichtungspunkt enthält.

    2. Wählen Sie auf der Seite "Positionierung" der Gleichungspalette "Manuell einstellen" aus dem Aufklappmenü "Links/Rechts". Sie können einen manuellen Ausrichtungspunkt auch löschen, indem Sie einen anderen festlegen.

So richten Sie Elemente in einer horizontalen Liste aus:

    1. Klicken Sie in die Liste.

    2. Wählen Sie auf der Seite "Positionierung" der Gleichungspalette ein Element aus dem Aufklappmenü "Oben/Unten".

So richten Sie Zellen in einer Matrix aus:

    1. Klicken Sie in die Matrix.

    2. Wählen Sie auf der Seite "Positionierung" der Gleichungspalette ein Element aus dem Aufklappmenü "Oben/Unten" oder "Links/Rechts". Die Befehle "Links/Rechts" und "Oben/Unten" beziehen sich auf die gesamte Matrix. Zur Ausrichtung von einzelnen Zellen verwenden Sie die Feinpositionierung (siehe Feinpositionieren von Ausdrücken).

So überprüfen Sie die Ausrichtungseinstellungen für eine horizontale oder vertikale Liste bzw. für eine Matrix:

    1. Führen Sie zur Auswahl der Gleichung einen der folgenden Schritte aus:

    Ziehen Sie den Zeiger über die Liste oder die Matrix.

    Platzieren Sie die Einfügemarke in der Matrix und drücken Sie wiederholt die Leertaste.

    2. Klicken Sie auf der Seite "Positionierung" der Gleichungspalette auf "Positionseinstellungen".


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Festlegen von Zeilenumbrüchen und Ausrichten von Gleichungen

Ausrichten mehrerer Gleichungen

Sie können auf die gleiche Weise, wie Sie andere Objekte ausrichten, mehrere Gleichungsobjekte in einem Grafikrahmen aneinander ausrichten. Sie können auch unterschiedliche Gleichungsobjekte an einem manuellen Ausrichtungspunkt ausrichten, auch wenn sie sich in unterschiedlichen Grafikrahmen befinden.

An manuellen Ausrichtungspunkten ausgerichtete Gleichungen

FrameMaker behält die Ausrichtung der Gleichungsobjekte bei, wenn die Gleichungen bearbeitet werden. Wenn z. B. zwei Gleichungen linksbündig ausgerichtet sind und sich die Länge der Gleichungen ändert, wird die linksbündige Ausrichtung beibehalten.

So richten Sie Gleichungen in einem Rahmen linksbündig, zentriert oder rechtsbündig aneinander aus:

    1. Wählen Sie die Gleichungen aus, die ausgerichtet werden, indem Sie bei gedrückter Strg-Taste (Windows) bzw. Control-Taste (UNIX) auf die erste Gleichung klicken und dann bei gedrückter Strg- und Umschalttaste (Windows) bzw. Control- und Umschalttaste (UNIX) auf die anderen Gleichungen klicken.

Stellen Sie sicher, dass die letzte Gleichung, die Sie auswählen, diejenige ist, an der Sie ausrichten möchten.

    2. Wählen Sie "Grafik > Ausrichten".

    3. Wählen Sie die gewünschte Ausrichtung (links-/rechtsbündig) und klicken Sie auf "Ausrichten". Weitere Informationen finden Sie unter Objekte ausrichten.

So richten Sie Gleichungen an einem Punkt aus:

    1. Platzieren Sie den manuellen Ausrichtungspunkt in einer der Gleichungen, die Sie ausrichten wollen. Die Vorgehensweise ist dieselbe wie bei einer vertikalen Liste (siehe Ausrichten von Elementen in Listen, Matrizen und mehrzeiligen Gleichungen).

Wenn Sie keinen manuellen Ausrichtungspunkt festlegen, richtet FrameMaker Gleichungen linksbündig aus.

    2. Klicken Sie in die Gleichung und wählen Sie "Grafik > Objekteinstellungen".

    3. Wählen Sie "Manuell" aus dem Aufklappmenü "Ausrichtung" und legen Sie unter "Abstand des Ausrichtungspunkts" die Position des Ausrichtungspunktes innerhalb des Rahmens fest. Der linke Abstand ist der Abstand zwischen dem linken Rand des Rahmens und dem manuellen Ausrichtungspunkt, z. B. der rechten Seite eines Gleichheitszeichens.

Der obere Abstand muss nicht genau festgelegt werden. Sie können die Gleichung wie alle anderen Objekte nach oben oder nach unten verschieben.

    4. Klicken Sie auf "Zuweisen".

    5. Wiederholen Sie die Schritte 1 bis 4 für jede Gleichung, die ausgerichtet werden soll. Verwenden Sie für jede Gleichung denselben Abstand zwischen dem linken Rand und dem Ausrichtungspunkt, ändern Sie aber den oberen Abstand, um die Gleichung vertikal im Rahmen zu positionieren. Befinden sich die auszurichtenden Gleichungen in unterschiedlichen verankerten Rahmen, müssen Sie darauf achten, dass die linken Ränder der Rahmen aneinander ausgerichtet sind.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Ändern der Schrifteinstellungen

Ein Dokument besitzt Schrifteinstellungen, die für alle Gleichungen des Dokuments wirksam sind. Diese Einstellungen bestimmen den Schriftgrad und den Abstand für kleine, normale und große Gleichungen. Sie legen außerdem das Zeichenformat fest, das für griechische Buchstaben, für Symbole, Funktionen, Ziffern und Variablen benutzt wird.

Sie können die voreingestellte Größe einer ganzen Gleichung oder das Zeichenformat einzelner FrameMath-Elemente ändern (z. B. die Farbe oder eine bestimmte Schrift).

Ändern der Schrift

Es ist auch möglich, die Schriftgrade und Zeichenformate zu ändern, die für alle Gleichungen in einem Dokument verwendet werden.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Ändern der Schrifteinstellungen

Ändern des Zeichenformats in einzelnen Gleichungen

Sie können die voreingestellte Größe ("Klein", "Mittel" oder "Groß") und Farbe für eine gesamte Gleichung ändern oder nur das Zeichenformat eines darin enthaltenen Elements oder Ausdrucks. So ist es z. B. möglich, ein Element größer oder in Fettschrift darzustellen.

Die Einstellungen für Zeichenabstand, Streckung, Hochstellung, Tiefstellung, Unterstreichung, Überstreichung, Durchstreichung, Änderungsbalken oder Unterschneidung lassen sich für kein Element ändern. Auch die Schriftfamilie kann für einzelne griechische Buchstaben und Symbole und für einige Operatoren nicht geändert werden. Weitere Informationen über das Ändern der Schriftfamilie für alle griechischen Buchstaben und Symbole in einem Dokument finden Sie unter Ändern der Gleichungsschrift im gesamten Dokument.

So ändern Sie den voreingestellten Schriftgrad und die Schriftfarbe einer Gleichung:

    1. Klicken Sie in die Gleichung und wählen Sie "Grafik > Objekteinstellungen".

    2. Führen Sie eine der folgenden Aktionen aus:

    Um den Schriftgrad der Gleichung zu ändern, wählen Sie den Schriftgrad aus dem Kontextmenü "Größe" aus und klicken Sie auf "Zuweisen". Eingepasste Gleichungen werden von FrameMaker neu eingepasst.

    Um die Schriftfarbe der Gleichung zu ändern, wählen Sie eine Farbe aus dem Kontextmenü "Farbe" und klicken Sie auf "Zuweisen".

So ändern Sie das Zeichenformat eines Elements oder Ausdrucks:

Wählen Sie das Element oder den Ausdruck aus und verwenden Sie dieselbe Methode wie bei normalem Text. Einzelheiten finden Sie unter Verwenden der Schriftbefehle des Menüs "Format" und Verwenden der Gestaltungsfenster zum Ändern von Schrifteinstellungen.

So legen Sie Hoch- oder Tiefstellung fest:

Verwenden Sie den entsprechenden Operator. Weitere Informationen finden Sie unter Einfügen von Operatoren.

So ändern Sie den Zeichenabstand:

Feinpositionieren Sie die Zeichen mit der Seite "Positionierung" der Gleichungspalette. Weitere Informationen finden Sie unter Feinpositionieren von Ausdrücken.

So platzieren Sie eine Linie über oder unter einen Ausdruck:

Verwenden Sie die diakritischen Zeichen auf der Seite "Symbole" der Gleichungspalette.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Ändern der Schrifteinstellungen

Ändern der Gleichungsschrift im gesamten Dokument

Sie können Schriftgrad und Abstand für alle kleinen, normalen und großen Gleichungen in einem Dokument ändern. Bei einer solchen globalen Änderung formatiert FrameMaker alle Gleichungen im Dokument neu und passt alle eingepassten Gleichungen neu ein.

Für griechische Buchstaben und Symbole wird in Gleichungen normalerweise die Schrift Symbol verwendet. Sie können jedoch auch andere Schriften wie Mathematical Pi und Universal Greek verwenden (vorausgesetzt, diese Schriften sind auf Ihrem System installiert).

Für die Darstellung von Funktionen, Ziffern und Zeichenfolgen wird normalerweise die Schrift Times New Roman oder Times verwendet. Variablen werden in der Regel kursiv dargestellt. Das Zeichenformat kann für jedes dieser Elemente geändert werden. Sie können z. B. alle Elemente in Helvetica anzeigen und für Funktionen und Variablen zusätzlich Fettschrift verwenden.

Hinweis: Löschen Sie aus dem Zeichenformat-Katalog keine Formate, die zur Festlegung des Zeichenformats von FrameMath-Elementen verwendet werden. Andernfalls wird allen Gleichungen im Dokument die Standardschrift zugewiesen.

So ändern Sie den Gleichungsschriftgrad und -abstand für das gesamte Dokument:

    1. Wählen Sie "Gleichungsgrößen" aus dem Aufklappmenü "Gleichung" der Gleichungspalette.

    2. Führen Sie eine der folgenden Aktionen aus:

    Legen Sie die Schriftgrade und den Zeichenabstand fest und klicken Sie auf "Zuweisen". Der Zeichenabstand wird als prozentualer Schriftgradanteil ausgedrückt. Positive Werte vergrößern den Abstand um die Elemente, negative Werte verringern ihn.

    Klicken Sie auf "Standard".

So ändern Sie die Schrift für griechische Buchstaben und Symbole:

    1. Wählen Sie "Gleichungsschriften" aus dem Aufklappmenü "Gleichung" der Gleichungspalette.

    2. Wählen Sie eine der verfügbaren Schriften aus dem Aufklappmenü "FrameMath-Symbole" und klicken Sie auf "Zuweisen".

So ändern Sie das Zeichenformat für Funktionen, Ziffern, Zeichenfolgen und Variablen:

    1. Definieren Sie das gewünschte Zeichenformat (siehe Absatz- und Zeichengestaltung).

    2. Wählen Sie "Gleichungsschriften" aus dem Aufklappmenü "Gleichung" der Gleichungspalette.

    3. Wählen Sie das gewünschte Zeichenformat aus dem Aufklappmenü "Funktionen", "Zahlen", "Zeichenfolgen" oder "Variablen" und klicken Sie auf "Zuweisen". Die Aufklappmenüs enthalten die Formate, die im Zeichenformat-Katalog gespeichert sind.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Berechnen von Gleichungen

Nach der Erstellung eines Ausdrucks oder einer Gleichung können Sie ihn bzw. sie umwandeln, indem Sie die mathematische Darstellung ändern. Sie können beispielsweise Polynome multiplizieren, Terme ausklammern, Ausdrücke vereinfachen und Brüche zusammenfassen.

Ursprüngliche Auswahl

Ausgeschrieben

Ausmultipliziert

Noch einmal ausmultipliziert

Sie können einen Ausdruck auch berechnen, indem Sie Werte ersetzen und Berechnungen durchführen.

Ursprüngliche Auswahl

Ausgeschrieben

Wert ersetzt

Ergebnis berechnet

So wandeln Sie einen Ausdruck um oder berechnen ihn:

    1. Wählen Sie den Ausdruck ganz oder teilweise aus.

    2. Wählen Sie einen Befehl aus der Seite "Matrizen" oder "Funktionen" der Gleichungspalette. Sie könnten z. B. einen Ausdruck auswählen und dann "Ausmultiplizieren" aus dem Aufklappmenü "Multiplikation" der Seite "Funktionen" wählen.

In den folgenden Abschnitten werden die Befehle des Kontextmenüs "Matrix-Befehle" der Seite "Matrizen" und die Befehle der sechs Kontextmenüs auf der Seite "Funktionen" beschrieben.


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Berechnen von Gleichungen

Das Aufklappmenü "Matrix-Befehle"

Verwenden Sie das Aufklappmenü "Matrix-Befehle" auf der Seite "Matrizen", um Matrizen zu erstellen, zu bearbeiten und zu berechnen.

In diesem Abschnitt werden die Befehle "Matrix transponieren" und "Matrix-Algebra" beschrieben. Informationen über die anderen Befehle in diesem Menü finden Sie unter Ändern von Matrizen.

Matrix transponieren

Transponiert Zeilen und Spalten der ausgewählten Matrix.

Ausgewählte Matrix | Nach der Transponierung

Matrix-Algebra

Führt Matrix-Multiplikation und -Addition durch und berechnet Skalar- und Vektorprodukte in einer ausgewählten Matrix.

Ausgewählte Matrix (oder Matrizen) | Nach der Berechnung

Nach der Durchführung der Matrix-Algebra können Sie mithilfe des Befehls "Vereinfachen" ähnliche Terme zusammenfassen (siehe Das Aufklappmenü "Umformungen").


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Berechnen von Gleichungen

Das Aufklappmenü "Addition"

Das Aufklappmenü "Addition" auf der Seite "Funktionen" enthält Befehle zum Addieren von Brüchen und zum Sortieren von Polynomen.

"Brüche addieren"

Addiert ausgewählte Brüche und drückt das Ergebnis als einzelnen Bruch aus. Dieser Befehl fasst auch ähnliche Terme zusammen.

Ausgewählter Bruch | Nach der Addition

Wenn der ausgewählte Ausdruck die Summe von mehr als zwei Brüchen enthält, addiert "Brüche addieren" lediglich die beiden ersten. Verwenden Sie diesen Befehl wiederholt, um alle Brüche zusammenzufassen.

Ausgewählter Ausdruck

Einmal addiert

Zweimal addiert

Geordnete Summe

Ordnet Polynome nach absteigenden Potenzen einer ausgewählten Variablen an.

Vor der Sortierung | Nach der Sortierung

Umgekehrt geordnete Summe

Ordnet Polynome nach aufsteigenden Potenzen einer ausgewählten Variablen. Im folgenden Beispiel wurde vor der Wahl von "Umgekehrt geordnete Summe" ein (beliebiges) x ausgewählt.

Vor der Sortierung | Nach der Sortierung


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Berechnen von Gleichungen

Das Aufklappmenü "Multiplikation"

Mit den Befehlen des Aufklappmenüs "Multiplikation" auf der Seite "Funktionen" können Terme ausgeklammert, Ausdrücke multipliziert und das Distributivgesetz angewendet werden.

Ausklammern

Klammert einen ausgewählten Term aus einem Produkt aus.

Vor dem Ausklammern | Nach dem Ausklammern

Teilweise ausklammern

Klammert einen ausgewählten Term nur aus den Termen aus, in denen er enthalten ist.

Vor dem Ausklammern | Nach dem Ausklammern

Ausmultiplizieren

Vereinfacht den ausgewählten Ausdruck und multipliziert die Gleichung vor dem Addieren aus. Dieser Befehl entwickelt auch einen ausgewählten Term, der zu einer positiven ganzzahligen Potenz erhoben ist.

Ausgewählter Ausdruck | Nach der Multiplikation

Der Befehl "Vereinfachen" vereinfacht ebenfalls den ausgewählten Ausdruck (siehe Das Aufklappmenü "Umformungen").

Einmal ausmultiplizieren

Multipliziert die ersten beiden Faktorpaare auf der linken Seite eines ausgewählten Ausdrucks.

Ausgewählter Ausdruck | Nach der Multiplikation

Wenn Sie diesen Befehl mehrmals verwenden, werden die Ergebnisse in anderer Form angezeigt.

Verteilen

Führt je nach gewähltem Ausdruck verschiedene Operationen durch. Nachstehend werden einige Beispiele gezeigt:

    Wendet das Distributivgesetz an.

    Ausgewählter Ausdruck | Ergebnis

Mit dem Befehl "Brüche addieren" führen Sie die Umkehroperation durch (siehe Das Aufklappmenü "Addition").

    Löst eine Klammer durch Ausmultiplizieren der eingeklammerten Summe auf.

    Ausgewählter Ausdruck | Ergebnis

Mit dem Befehl "Ausklammern" führen Sie die Umkehroperation durch.

    Formt Produkte und Quotienten mit Wurzeln und Exponenten in einen einzelnen potenzierten Ausdruck um.

    Ausgewählter Ausdruck | Ergebnis

Mit dem Befehl "Vereinfachen" führen Sie die Umkehroperation durch (siehe Das Aufklappmenü "Umformungen").

Auf beiden Seiten anwenden

Führt auf beiden Seiten eines Gleichheitszeichens dieselbe Operation durch.

Ausgewählter Ausdruck | Ergebnis


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Berechnen von Gleichungen

Das Aufklappmenü "Division"

Das Aufklappmenü "Division" auf der Seite "Funktionen" enthält Befehle für die Division mit Rest, für die Umwandlung von Division in Multiplikation und für die Umwandlung negativer Exponenten in positive.

Division mit Rest

Führt eine Division mit Rest in einem Bruch durch, der in Zähler und Nenner ein Polynom enthält.

Im folgenden Beispiel wählen Sie vor der Auswahl von "Division mit Rest" ein (beliebiges) x aus. Danach wählen Sie ein x im ersten Ergebnis aus und wählen erneut den Befehl "Division mit Rest", um das zweite Ergebnis zu erhalten.

Vor der Division

Erstes Ergebnis

Zweites Ergebnis

Division umwandeln

Konvertiert in einem ausgewählten Ausdruck Division in Multiplikation, indem positive in negative Exponenten geändert werden und umgekehrt.

Ausgewählter Ausdruck | Nach der Umwandlung

Um negative Exponenten in eine Division umzuwandeln, verwenden Sie den Befehl "Negative Potenz umwandeln".

Division Stufe 1 umwandeln

Konvertiert wie "Division umwandeln" Division in Multiplikation. Dieser Befehl gilt jedoch nur für die erste Stufe einer Division.

Ausgewählter Ausdruck | Nach der Umwandlung

Um die erste Stufe negativer Exponenten in Divisionsoperatoren umzuwandeln, verwenden Sie den Befehl "Negative Potenz Stufe 1 umwandeln".

Negative Potenz umwandeln

Konvertiert in einem ausgewählten Ausdruck negative Exponenten in Divisionsoperatoren, indem Multiplikation durch Division ersetzt wird (und umgekehrt).

Ausgewählter Ausdruck | Nach Umwandlung negativer Potenzen

Negative Potenz Stufe 1 umwandeln

Dieser Befehl hat dieselbe Funktion wie "Negative Potenz umwandeln", gilt jedoch nur für die erste Stufe. Wenn der ausgewählte Ausdruck über keine negativen Exponenten in der ersten Stufe verfügt, hat dieser Befehl keine Wirkung.

Ausgewählter Ausdruck | Nach Umwandlung negativer Potenzen
 | (Keine Veränderung)


Variablen und Gleichungen / Einfügen von FrameMath-Elementen / Berechnen von Gleichungen

Das Aufklappmenü "Berechnung"

Das Aufklappmenü "Berechnung" auf der Seite "Funktionen" enthält Befehle für die numerische Berechnung von Ausdrücken.

Ausrechnen

Ändert in einem ausgewählten Ausdruck Ganzzahlen in Gleitkommazahlen und berechnet dann den Ausdruck.

Ausgewählter Ausdruck | Nach der Berechnung

Mit dem Befehl "Alle Stellen zeigen" zeigen Sie bis zu 15 Dezimalstellen in einer Gleitkommazahl an.

"Ausrechnen" zeigt für Operationen, die nicht definierte Ergebnisse liefern, NaN (Not a Number = keine Zahl) an. Für Operationen, die zu große Werte liefern, wird Unendlich angezeigt. Extrem kleine Zahlen können zu null ausgewertet werden.

Ausgewählter Ausdruck | Nach der Berechnung

Alle Stellen zeigen

Zeigt die volle Anzahl der Stellen einer Gleitkommazahl in Rechnergenauigkeit.

Ausgewählte Zahl | Ergebnis

Berechnen

Berechnet den ausgewählten Ausdruck. Die durchgeführten Operationen hängen von der Art des Ausdrucks ab. Nachstehend finden Sie einige Beispiele.

    Umformen eines Ausdrucks, der zu einer Potenz von weniger als 20 erhoben ist, in ein Produkt.

    Ausgewählter Ausdruck | Nach der Berechnung

    Berechnen der Fakultät für eine Ganzzahl. Wenn das Ergebnis zu groß ist, um berechnet zu werden, wird Unendlich als Ergebnis angezeigt.

    Ausgewählter Ausdruck | Nach der Berechnung

    Berechnen der Determinante einer 1 x 1- oder 2 x 2-Matrix.

    Ausgewählter Ausdruck | Nach der Berechnung

    Herausziehen eines Terms aus einer Summe oder einem Produkt

    Ausgewählter Ausdruck | Nach der Berechnung

    Auswerten einer Ersetzungsoperation (wie mit dem Befehl "Einsetzen")

    Umformen eines Operators "Berechnen" in eine Differenz

    Ausgewählter Ausdruck | Nach der Berechnung

    Umformen des Logarithmus eines Produkts in eine Summe von Logarithmen; Umformen eines potenzierten Logarithmus in ein Produkt.

    Ausgewählter Ausdruck | Nach der Berechnung

    Umformen eines Logarithmus zu einer Basis mit natürlichen Logarithmen.

    Ausgewählter Ausdruck | Nach der Berechnung

    Umformen einer Binominalfunktion in einen Ausdruck von Fakultäten

    Ausgewählter Ausdruck | Nach der Berechnung

Einsetzen

Führt eine angegebene Ersetzung durch und vereinfacht dann den Ausdruck. Wenn ein Operator "Berechnen" ausgewählt ist, formt dieser Befehl den Ausdruck in eine Differenz um.

Ausgewählter Ausdruck | Nach der Berechnung

Integrieren

Formt ein ausgewähltes Integral mit einem polynomialen Integranden um. Dieser Befehl formt ein bestimmtes Integral in ein unbestimmtes Integral um, das zwischen den oberen und unteren Grenzen berechnet wird. Verwenden Sie "Integrieren" mehrmals, um einen polynominalen Ausdruck vollständig zu integrieren.

Ausgewählter Ausdruck

Einmal integriert

Zweimal integriert

Ableiten

Berechnet eine ausgewählte Ableitung und wendet bei Bedarf die Kettenregel auf komplexe Ausdrücke an. Dieser Befehl berechnet eine partielle Ableitung nur dann, wenn alle Abhängigkeiten explizit angegeben sind.

Der Befehl behandelt Elemente einer totalen Ableitung, als hingen sie von der Variablen der Differenzierung ab. Verwenden Sie für die Berechnung einer n-ten Ableitung zunächst den Befehl "Berechnen", um sie zu entwickeln, bevor Sie den Befehl "Ableiten" anwenden.

Vorher | Nachher

1. Stufe ableiten

Berechnet nur die erste Stufe einer ausgewählten Ableitung.

Vorher | Nachher


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Das Aufklappmenü "Regeln"

Das Aufklappmenü "Regeln" auf der Seite "Funktionen" dient der Speicherung und Anwendung von Regeln für die Umformung von Ausdrücken.

Sie könnten z. B. mithilfe von "Regel eingeben" eine Regel wie a = a + 3 speichern. Verwenden Sie dann "Regel anwenden", um a in einem anderen Ausdruck durch a + 3 zu ersetzen.

Regel eingeben

Speichert eine Regel für die Ersetzung eines Ausdrucks durch einen anderen. Wählen Sie den Ausdruck aus, den Sie als Regel speichern möchten, bevor Sie "Regel eingeben" wählen. Sie können jeweils nur eine Regel speichern.

Platzhalter festlegen

Legt einen ausgewählten Term als Platzhalter fest. Ein Platzhalter in einer Regel gestattet die Ersetzung des Ausdrucks auf der rechten Seite der Regel für jede Variable, nicht nur für die explizit auf der linken Seite genannte Variable. Ein Platzhalter wird in Fettschrift dargestellt. Wenn Sie z. B. x in der Regel x = a – 2 als Platzhalter verwenden, können Sie a – 2 für jede Variable in einem Ausdruck einsetzen, nicht nur für x.

Wählen Sie den Term aus, den Sie als Platzhalter verwenden wollen, bevor Sie "Platzhalter festlegen" wählen. Ersetzen Sie dann mit dem Befehl "Regel anwenden" einen ausgewählten Ausdruck durch den Ausdruck, der dem Platzhalter zugewiesen wurde.

Regel anwenden

Ersetzt in einem ausgewählten Ausdruck einen oder mehrere Terme durch einen anderen und verwendet dabei die Regel, die mit dem Befehl "Regel eingeben" gespeichert wurde.

Eingegebene Regel

Ausgewählter Ausdruck

Nach Anwenden der Regel

Bevor Sie eine Regel anwenden, die eine Platzhalter-Variable enthält, wählen Sie den Term aus, der den Platzhalter ersetzen soll. Im folgenden Beispiel ist x der Platzhalter in der Regel.

Eingegebene Regel

Vor Anwenden der Regel

Nach Anwenden der Regel

Das Aufklappmenü "Umformungen"

Das Kontextmenü "Umformungen" auf der Seite "Funktionen" vereinfacht algebraische Ausdrücke und isoliert oder entwickelt Terme.

Vereinfachen

Vereinfacht den ausgewählten Ausdruck. Um Brüche zu berechnen, die unendlich sind oder eine Division durch Null enthalten, verwenden Sie anstelle von "Vereinfachen" den Befehl "Ausrechnen" (siehe Das Aufklappmenü "Berechnung").

Die durchgeführten Operationen hängen von der Art des Ausdrucks ab. Nachstehend finden Sie einige Beispiele.

    Ganzzahlen-Arithmetik

    Ausgewählter Ausdruck | Nach der Vereinfachung

Wenn das Ergebnis zu groß ist, um berechnet zu werden, wird Unendlich als Ergebnis angezeigt.

    Gruppieren von Termen in einer Summe oder in einem Produkt.

    Ausgewählter Ausdruck | Nach der Vereinfachung

    Dividiert gemeinsame Faktoren in einem Bruch aus.

    Ausgewählter Ausdruck | Nach der Vereinfachung

Verwenden Sie den Befehl "Negative Potenz umwandeln", um negative Potenzen aus dem Ergebnis zu entfernen (siehe Das Aufklappmenü "Division").

    Interpretiert die komplexe Zahl i, repräsentiert durch den griechischen Buchstaben Iota ( [image] ).

    Ausgewählter Ausdruck | Nach der Vereinfachung

    Löst die Klammer auf, indem der Exponent auf den Ausdruck in der Klammer angewendet wird, falls es sich dabei um Multiplikation oder Division handelt.

    Ausgewählter Ausdruck | Nach der Vereinfachung

Beachten Sie, dass die Vereinfachung von [image] x das Ergebnis [image] liefert, und nicht [image] .

Teilweise vereinfachen

Vereinfacht wie der Befehl "Vereinfachen" den ausgewählten Ausdruck, multipliziert jedoch Brüche nicht aus.

Ausgewählter Ausdruck | Nach der Vereinfachung

Term isolieren

Isoliert einen ausgewählten Ausdruck auf einer Seite des Gleichheitszeichens. Dieser Befehl fasst keine Terme zusammen und löst den ausgewählten Ausdruck nicht auf.

Ausgewählter Ausdruck | Nach der Isolierung

Term herausziehen

Entwickelt den ersten Term einer ausgewählten Summe oder eines ausgewählten Produkts.

Ausgewählter Ausdruck | Nach dem Entwickeln

Alle Terme herausziehen

Entwickelt alle Terme einer ausgewählten Summe oder eines ausgewählten Produkts.

Ausgewählter Ausdruck | Nach dem Entwickeln


Variablen und Gleichungen / Einfügen von FrameMath-Elementen

Gleichungselemente in strukturierten Dokumenten

Ein Gleichungselement besteht aus einem Rahmen mit einem Gleichungsobjekt, in das Sie mathematische Ausdrücke eingeben können. Wie ein verankerter Rahmen für Grafiken ist ein Gleichungsrahmen an einer bestimmten Stelle im Text verankert.

Gleichungen in Absatztext und freigestellte Gleichungen in strukturierten Dokumenten

Sie können ein Gleichungselement in den Absatztext eingliedern oder in einem separaten Absatz anzeigen.

A: Gleichung in Absatztext B: Freigestellte Gleichung

Ein Gleichungselement wird in der Struktur des Dokuments an der Stelle angezeigt, an der es mit Text verankert wurde, unabhängig von der Position der Gleichung auf der Seite. In der Strukturansicht wird das Element durch ein Elementrechteck ohne abgerundete Ecken mit dem Textausschnitt <GLEICHUNG> dargestellt. Die Gleichung selbst ist nicht Teil der Struktur.

Gleichungselement

Wenn Sie in das SGML- oder XML-Format exportieren, bleibt die Gleichung erhalten. FrameMaker schreibt die Gleichung in eine separate Grafikdatei und fügt eine Entity-Referenz auf diese Gleichung in die SGML- oder XML-Datei ein.

Gleichungen in Grafikrahmen in strukturierten Dokumenten

Sie können eine Gleichung auch in einen Rahmen einfügen, der bereits für eine Grafik eingefügt wurde. Dies ist zweckmäßig, wenn Sie die Gleichung mit Grafikobjekten verbinden möchten. Wenn es sich bei dem verankerten Rahmen um ein Element handelt, ist das Element Teil der Dokumentstruktur. Der Rahmeninhalt, einschließlich der Gleichung, wird in der Struktur jedoch nicht angezeigt.

Eine Gleichung, die sich zusammen mit einer Grafik in einem verankerten Rahmen befindet, kann während des Exports zu SGML oder XML zu unerwünschten Ergebnissen führen. Fügen Sie daher nur ein Objekt in den Rahmen ein, wenn Sie einen Export nach SGML oder XML vornehmen möchten.


Variablen und Gleichungen

Erstellen von Gleichungen in strukturierten Dokumenten mithilfe von Elementen

Eine Gleichung wird erstellt, indem Sie ein Gleichungselement einfügen und anschließend einen mathematischen Ausdruck für die Gleichung eingeben.

Einzelheiten zu mathematischen Ausdrücken in Gleichungen oder Informationen über das Einfügen von Gleichungen, die keine Elemente sind, finden Sie unter Erstellen von Gleichungen.

Hinweis: Im FrameMaker-Benutzerhandbuch bezieht sich der Begriff FrameMath-Element auf Teile eines Ausdrucks, wie z. B. einen Operator. Ein FrameMath-Element ist kein strukturelles Element.

Sie können alle Gleichungselemente sowohl für eingegliederte, als auch für freigestellte Gleichungen verwenden. In einigen Dokumenten ist möglicherweise ein Absatzelement definiert, das Formateigenschaften für freigestellte Gleichungen bereitstellt.

Die Formatregeln für Gleichungselemente schlagen für die Gleichung eine Gruppe von Schriftgrößen vor: "Klein", "Normal" oder "Groß". Wenn Sie zu anderen Schriftgrößen wechseln, stellt die Änderung keine irreguläre Formatzuweisung dar. (Das heißt, wenn Sie irreguläre Formatzuweisungen aus dem Dokument entfernen, wird die Gleichung nicht auf ihre ursprüngliche Schriftgröße zurückgesetzt.)

So zeigen Sie die Gleichungspalette an:

    Wählen Sie "Spezial > Gleichungen" oder klicken Sie auf die Schaltfläche "Gleichungen" [image] auf der rechten Seite des Dokumentfensters.

So erstellen Sie eine Gleichung in einem Absatztext mithilfe eines Elements:

    1. Klicken Sie an der Stelle in den Text, an der Sie die Gleichung einfügen möchten. Wenn sich der Text in einem gedrehten Textrahmen befindet, machen Sie zunächst die Drehung rückgängig und drücken Sie Esc g Umschalttaste+d 0 (null).

    2. Wählen Sie im Elementkatalog ein Element aus und klicken Sie auf "Einfügen".

Sie können auch die Gleichungspalette zum Einfügen eines Elements verwenden. Wählen Sie den Befehl "Neue Gleichung" aus dem Aufklappmenü "Gleichungen" der Palette. Wenn mehrere Gleichungselemente verfügbar sind, wählen Sie das gewünschte Element aus dem Aufklappmenü "Element-Tag" des Dialogfensters aus.

In einem verankerten Rahmen unterhalb der Zeile, in der sich die Einfügemarke befindet, wird ein neues Gleichungsobjekt in Form eines Fragezeichens eingefügt, und in der Strukturansicht wird ein Rechteck mit dem Textausschnitt <GLEICHUNG> angezeigt. Dieses Fragezeichen wird durch das erste von Ihnen eingegebene FrameMath-Element ersetzt.

Neues Gleichungsobjekt

    3. Geben Sie die Gleichung entweder in Form von Zahlen und anderen Elementen manuell ein oder klicken Sie auf die Gleichungspalette (siehe Verwenden der Gleichungspalette).

    4. Aktivieren Sie die Option "Gleichung einpassen" im Kontextmenü "Gleichungen" der Palette. Dadurch wird der Rahmen um die Gleichung verkleinert und die Gleichung in die Textzeile am Ankersymbol eingefügt.

Nach dem Verkleinern eines Rahmens um eine Gleichung in Absatztext

    5. Wenn die Gleichung auf beiden Seiten zu dicht am Text erscheint, fügen Sie vor und nach dem Rahmen ein Leerzeichen ein. FrameMaker behandelt einen Rahmen, der eine Gleichung in einem Absatztext enthält, als ein Zeichen und erzeugt kein zusätzliches Leerzeichen um ihn herum.

Wenn eine in einen Absatz eingefügte Gleichung zu groß für die Zeile ist, können Sie den festen Zeilenabstand für diesen Absatz deaktivieren.

So erstellen Sie eine freigestellte Gleichung mithilfe eines Elements:

    1. Wenn für Ihr Dokument ein Absatzelement zur Formatierung freigestellter Gleichungen definiert wurde, klicken Sie an der Stelle, an der der Absatz mit der Gleichung erscheinen soll, wählen Sie im Elementkatalog das Absatzelement aus und klicken Sie auf "Einfügen".

Dieses Element kann Leerraum über und unter der Gleichung, die Ausrichtung in der Textspalte und eine automatisch nummerierte Beschriftung definieren.

    2. Klicken Sie in einem leeren Absatzelement an der Stelle, an der Sie die Gleichung einfügen möchten.

    3. Wählen Sie im Elementkatalog ein Element aus und klicken Sie auf "Einfügen".

Sie können auch die Gleichungspalette zum Einfügen eines Elements verwenden. Wählen Sie den Befehl "Neue Gleichung" aus dem Aufklappmenü "Gleichungen" der Palette. Wenn mehrere Gleichungselemente verfügbar sind, wählen Sie das gewünschte Element aus dem Aufklappmenü "Element-Tag" des Dialogfensters aus.

In einem verankerten Rahmen unterhalb der Zeile, in der sich die Einfügemarke befindet, wird ein neues Gleichungsobjekt in Form eines Fragezeichens eingefügt, und in der Strukturansicht wird ein Rechteck mit dem Textausschnitt <GLEICHUNG> angezeigt. Dieses Fragezeichen wird durch das erste von Ihnen eingegebene FrameMath-Element ersetzt.

Neues Gleichungsobjekt

    4. Geben Sie die Gleichung entweder in Form von Zahlen und anderen Elementen manuell ein oder klicken Sie auf die Gleichungspalette (siehe Verwenden der Gleichungspalette).

    5. Aktivieren Sie "Gleichung einpassen" im Aufklappmenü "Gleichungen" der Palette. Dadurch wird der Rahmen um die Gleichung verkleinert und die Gleichung in den leeren Absatz eingefügt.

Nach dem Verkleinern eines Rahmens um eine freigestellte Gleichung

Wenn an der gewünschten Position kein Gleichungselement verfügbar ist, verwenden Sie möglicherweise ein ungültiges Element. Informieren Sie sich nach Einfügen des Elements bei Ihrem Entwickler darüber, wie sich das Element an dieser Position in ein gültiges Element umwandeln lässt.

So verwenden Sie ein ungültiges Gleichungselement:

Führen Sie eine der folgenden Aktionen aus:

    Um ein Element zu verwenden, das in einem anderen Teil des Dokuments gültig ist, fügen Sie das Element an einer gültigen Position ein und verschieben es, oder benutzen Sie die Einstellung "Alle Elemente" (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument), um das Element überall verfügbar zu machen, und fügen Sie das Element dann an der gewünschten Position ein.

    Um ein ungültiges Gleichungselement mit dem Standard-Tag GLEICHUNG einzufügen, wählen Sie "Neue Gleichung" aus dem Kontextmenü "Gleichungen" der Palette. (Dem Element wird das Standard-Tag zugewiesen, wenn keine definierten importierten Grafikelemente verfügbar sind.)

So erzeugen Sie eine Gleichung in einem verankerten Rahmenelement:

    1. Wählen Sie einen verankerten Rahmen oder ein grafisches Objekt im Rahmen aus.

    2. Wählen Sie den Befehl "Neue Gleichung" aus dem Aufklappmenü "Gleichungen" der Palette. Die Optionen "Klein", "Normal" und "Groß" geben die Schriftgröße der neuen Gleichung an.

Ein neues Gleichungsobjekt wird als Fragezeichen in einem Rahmen angezeigt. Dieses Fragezeichen wird durch das erste von Ihnen eingegebene FrameMath-Element ersetzt. Die Gleichung wird nicht in der Dokumentstruktur angezeigt.

Neue Gleichungsobjekte in einem Rahmen mit Grafikobjekten

    3. Geben Sie die Gleichung entweder in Form von Zahlen und anderen Elementen manuell ein oder klicken Sie auf die Gleichungspalette (siehe Verwenden der Gleichungspalette).

So ändern Sie die Schriftgrößen in einer Gleichung:

Klicken Sie in die Gleichung, wählen Sie "Grafik > Objekteinstellungen". Wählen Sie dann eine Größe aus dem Aufklappmenü "Größe" und klicken Sie auf "Zuweisen". (Dabei handelt es sich nicht um eine irreguläre Formatzuweisung.)


Filter nach Attribut

Weitere InformationenFilter nach Attribut

Erstellen von Filtern

Anwenden von Filtern

Speichern von Dokumenten nach dem Anwenden von Filtern

Ändern von Filtern

Löschen von Filtern


Filter nach Attribut

Weitere InformationenFilter nach Attribut

Elemente in einem strukturierten Dokument können ein oder mehrere mit ihnen verknüpfte Attribute haben. Mit FrameMaker können Sie ein strukturiertes Dokument auf der Grundlage der Werte dieser Attribute filtern. Andere XML-Anwendungen können ebenfalls dieselben Attributwertpaare zum Filtern von Dokumenten verwenden. So können Single-Source-Workflows über andere XML-Anwendungen hinweg beibehalten werden.

Die Funktion "Filter nach Attribut" vereinfacht die Aufgabe des Filterns eines strukturierten Dokuments für komplexe Ausgabeszenarien. Ein Filter wird mithilfe eines booleschen Ausdrucks, der Attributwertpaare enthält, definiert. Sie können mehrere Filter erstellen, sie speichern und für das Filtern von Dokumenten für verschiedene Ausgabeanforderungen verwenden.

Wenn ein Filter auf das Dokument angewendet wird, werden Elemente mit Filterattributen, die nicht mit den Filterkriterien übereinstimmen, herausgefiltert. Wird ein Element herausgefiltert, werden auch alle zugehörigen untergeordneten Elemente herausgefiltert. Weitere Informationen finden Sie unter Beispiel eines Filters.

Hinweis: Sie können ein Dokument nicht gleichzeitig auf der Grundlage von Bedingungstypen und Attributwerten filtern.

Bedingter Text | Filter nach Attribut
Basierend auf Bedingungstypen | Basierend auf Attributen
Definition in einem Dokument erforderlich | In einem strukturierten Dokument bereits vorhanden
Bedingungsformate dienen dazu, Inhalte basierend auf verschiedenen Bedingungen optisch darzustellen. | Keine Formate
Es kann nur ein Ausdruck gleichzeitig gespeichert werden. | Es können mehrere Ausdrücke gleichzeitig gespeichert werden.
Sowohl im strukturierten als auch im unstrukturierten FrameMaker verfügbar | Nur im strukturierten FrameMaker verfügbar (unstrukturierte Dokumente haben keine Elemente oder Attribute)
Lässt das Ausblenden eines ganzen Dokuments zu, was zu einem Dokument ohne Inhalt führt. | Lässt das Ausblenden des gesamten Dokuments nicht zu, da das Stammelement nicht ausgeblendet werden kann.
Lässt für das Ausblenden die Auswahl von denkbar kleinen Teilen des Dokuments zu. | Die kleinste Einheit, die mit dieser Funktion ausgeblendet werden kann, ist ein Element.
Für jeden Bedingungstyp haben Sie die Wahl zwischen nur zwei Optionen: EINBLENDEN oder AUSBLENDEN. | Lässt bezüglich der Erstellung einer Ausblendbedingung eine feinere Abstimmung zu, da ein Attribut (je nach Definition) mehrere Werte annehmen kann. Für jedes Attribut gibt es in diesem Sinne eine getrennte EINBLEND- oder AUSBLEND-Möglichkeit.

Hinweis: Die Bedingungsformate werden bei Verwendung eines Filters deaktiviert. Bedingungsformate können nur dann aktiviert werden, wenn auf das Dokument kein Filter angewendet wurde.


Filter nach Attribut

Erstellen von Filtern

Ein Filter wird mithilfe eines booleschen Ausdrucks, der Attributwertpaare enthält, definiert. Sie können mit dem Dialogfenster "Ausdruck erstellen" einen Filter erstellen. Dieses Dialogfenster bietet eine einfache Oberfläche zum Erstellen von Ausdrücken mithilfe von booleschen Operatoren. Sie können Attributwertpaare im Dialogfenster "Attributwerte definieren" definieren. Dabei können Sie jedem Attribut mehrere Werte zuweisen.

Sie können einen Filter als benannten Ausdruck speichern. Sie können in einem strukturierten Dokument mehrere Filterausdrücke erstellen und speichern. Sie können jedoch immer nur einen Filter anwenden. Der letzte in einem Dokument angewendete Filter ist der aktive Filter.

Verwenden Sie zum Verwalten der Filter das Dialogfenster "Attributausdrücke verwalten".

    1. Wählen Sie "Spezial > Filter nach Attribut" aus. Das Dialogfenster "Attributausdrücke verwalten" wird angezeigt.

    2. Klicken Sie auf "Neu". Das Dialogfenster "Ausdruck erstellen" wird angezeigt.

    3. Geben Sie in das Feld "Ausdrucks-Tag" einen eindeutigen Namen für den Filter ein.

    4. Wählen Sie ein Attribut in der Attributliste aus.

    5. Gehen Sie wie folgt vor, um Werte für Attribute zu definieren, die Sie zum Erstellen eines Ausdrucks verwenden möchten:

      a. Klicken Sie auf "Werte definieren". Das Dialogfenster "Attributwerte definieren" wird angezeigt.

Hinweis: Bei Attributnamen wird zwischen Groß- und Kleinschreibung unterschieden, bei den Attributwerten ist dies jedoch nicht der Fall.

    b. Geben Sie im Feld "Neuer Wert" einen Wert an und klicken Sie auf "ADD-Wert". Der neue Attributwert wird in die Liste "Definierte Werte" aufgenommen.

Hinweis: Wenn Sie einen Wert entfernen möchten, wählen Sie ihn in der Liste "Definierte Werte" aus und klicken Sie auf "Wert entfernen".

    c. Klicken Sie auf "Fertig".

6. Klicken Sie auf "Attribut hinzufügen", um das Attribut in den Ausdruck aufzunehmen.

7. Klicken Sie auf die gewünschte Schaltfläche, um in den Ausdruck einen booleschen Operator einzufügen.

Hinweis: Verwenden Sie die Schaltfläche "Löschen", um den Bereich "Ausdruck" zu aktualisieren.

    8. Klicken Sie auf "OK".

Hinweis: Sie können die Inhalte eines Filters im Bereich "Ausgewählter Ausdruck" anzeigen, indem Sie in der Liste von Filtern einen Filter auswählen.

    9. Klicken Sie auf "Fertig", um das Dialogfenster "Attributausdrücke verwalten" zu schließen.

Beachten Sie beim Erstellen eines Filters Folgendes:

    Stellen Sie sicher, dass Sie in dem Filter gültige Attribute eingeben. Alle gültigen Attribute sind im Dialogfenster "Ausdruck erstellen" in der Liste "Attribute" aufgeführt.

    Der Wert eines Attributs muss in doppelten Anführungszeichen stehen.
    Richtig: (Sprache="Französisch" OR Sprache="Deutsch" OR Sprache="Japanisch")
    Falsch: (Sprache=Französisch OR Sprache=Deutsch OR Sprache=Japanisch)

Hinweis: FrameMaker unterstützt Ausdrücke, bei denen der Attributwert fehlt, nicht. Beispiel: "(Sprache="")" wird in einem Ausdruck nicht unterstützt.

    Alle Attributwertpaare müssen in einfachen runden Klammern stehen. Attributwertpaare für ein spezifisches Attribut können innerhalb desselben Klammerausdrucks oder auch in mehreren Klammerausdrücken platziert werden.
    Richtig: (Sprache="Französisch" OR Sprache="Deutsch" OR Sprache="Japanisch")
    Richtig: (Sprache="Französisch" OR Sprache="Deutsch" OR Sprache="Japanisch") AND (Version="1.0")
    Richtig: (Sprache="Französisch" OR Sprache="Deutsch") AND (Sprache="Japanisch")
    Falsch: Sprache="Französisch" OR Sprache="Deutsch" OR Sprache="Japanisch"

    Verwenden Sie zwischen Attributwertpaaren für ein Attribut nur den Operator OR. Verwenden Sie nicht den Operator AND.
    Richtig:(Sprache="Französisch" OR Sprache="Deutsch" OR Sprache="Japanisch") AND (Version="1.0" OR Version="2.0")
    Falsch: (Sprache="Französisch" OR Sprache="Deutsch" AND Sprache="Japanisch") AND (Version="1.0" OR Version="2.0")

    Wird der Operator NOT verwendet, müssen Sie sicherstellen, dass er sich vor der öffnenden Klammer einer Attributwertgruppe befindet.
    Richtig: (Sprache="Französisch" OR Sprache="Deutsch" OR Sprache="Japanisch") AND (Version="1.0" OR Version="2.0")
    Richtig: (Sprache="Französisch" OR Sprache="Deutsch" OR Sprache="Japanisch") OR NOT (Plattform="Windows")
    Falsch: (NOT Sprache="Französisch" OR Sprache="Deutsch" OR Sprache="Japanisch") AND (Version="1.0" OR Version="2.0")
    Falsch: (Sprache="Französisch" OR Sprache="Deutsch" OR Sprache="Japanisch") OR (Plattform="Windows" NOT Plattform="UNIX")

    Wenn mehrere Attribute in einem Filter sind, dann fügen Sie den booleschen Operator zwischen zwei Gruppen von Attributwertpaaren ein.
    Richtig: (Sprache="Französisch" OR Sprache="Deutsch") AND (Plattform="Windows" OR Plattform="UNIX")
    Falsch: (Sprache="Französisch" OR Sprache="Deutsch") (Plattform="Windows" OR Plattform="UNIX")


Filter nach Attribut / Erstellen von Filtern

Beispiel eines Filters

FrameMaker erzeugt nach Auswertung des Filters, den Sie auf das Dokument angewendet haben, eine spezielle Ausgabe eines strukturierten Dokuments.

Fallbeispiel: Sie wollen folgende Elemente und Attribute auf die verschiedenen Absätze in Ihrem strukturierten Dokument anwenden.

Absatz | Element | Attribut | Zugewiesener Wert
Absatz 1 | TextContent1 | Sprache | Japanisch
 |  | Version | 2.0
 |  | Plattform | Windows
Absatz 2 | TextContent1 | Sprache | Japanisch
 |  | Version | 2.0
 |  | Plattform | UNIX
Absatz 3 | TextContent2 | Sprache | Japanisch
 |  | Version | 2.0
Absatz 4 | TextContent2 | Sprache | Englisch
 |  | Version | 1.0
Absatz 5 | SysReq | Plattform | Windows
Absatz 6 | SysReq | Plattform | UNIX
Absatz 7 | LegalContent | Copyright | Schmal

    1. Kopieren Sie XML-Beispielcode (Code, der auf diesem Beispiel basiert), um eine XML-Datei mit Elementen, Attributen und Attributwerten (aufgeführt in Tabelle 5) zu erstellen.

    2. Öffnen Sie die XML-Datei in FrameMaker. Diese Elemente, Attribute und Attributwerte werden im Fenster "Strukturansicht" angezeigt.

    3. Geben Sie in die entsprechenden Elemente Text ein.

Geben Sie beispielsweise in das Element "TextContent1" japanischen Text für die Windows-Version 2.0 ein.

    4. Erstellen Sie folgenden Filter, um ein japanisches Dokument für Windows zu erzeugen:

(Sprache="Japanisch") AND (Plattform="Windows")

Verarbeitung des Filters durch FrameMaker

FrameMaker gleicht jedes Attributwertpaar im Filter mit jedem Element im Dokument ab. Das Ergebnis dieses Abgleichvorgangs wird durch einen der folgenden Werte angegeben:

  • True:Das Attribut im Filter ist ein Attribut in dem Element, das gerade abgeglichen wird, und der Wert im Filter stimmt mit dem Wert des Attributs in diesem Element überein.

  • False:Das Attribut im Filter ist ein Attribut im Element, das gerade abgeglichen wird, aber der Wert im Filter stimmt nicht mit dem Wert des Attributs in diesem Element überein.

  • Don’t-Care:Das Attribut im Filter ist kein Attribut des Elements, das gerade abgeglichen wird.

Folgende Tabelle zeigt, wie der Filter verarbeitet wird:

(Sprache="Japanisch") AND (Plattform="Windows")

Absatz | Element | Attribut | Zugewiesener Wert | Überprüfung des Elements auf der Basis des Filters | Ergebnis
Absatz 1 | TextContent1 | Sprache | Japanisch | Is Sprache=Japanisch? Is Plattform = Windows? | True True
 |  | Version | 2.0
 |  | Plattform | Windows
Absatz 2 | TextContent1 | Sprache | Japanisch | Is Sprache=Japanisch? Is Plattform = Windows? | True False
 |  | Version | 2.0
 |  | Plattform | UNIX
Absatz 3 | TextContent2 | Sprache | Japanisch | Is Sprache=Japanisch? Is Plattform = Windows? | True Don’t-Care
 |  | Version | 2.0
Absatz 4 | TextContent2 | Sprache | Englisch | Is Sprache=Japanisch? Is Plattform = Windows? | False Don’t-Care
 |  | Version | 1.0
Absatz 5 | SysReq | Plattform | Windows | Is Sprache=Japanisch? Is Plattform = Windows? | Don’t-Care True
Absatz 6 | SysReq | Plattform | UNIX | Is Sprache=Japanisch? Is Plattform = Windows? | Don’t-Care False
Absatz 7 | LegalContent | Copyright | Schmal | Is Sprache=Japanisch? Is Plattform = Windows? | Don’t-Care Don’t-Care

Auf der Basis der Ergebnisse der Filterverarbeitung wie aufgeführt in Tabelle 5 und den in Tabelle 5 aufgeführten Regeln berechnet FrameMaker den endgültigen Wert für den Filter und entscheidet damit, ob die betreffenden Elemente in die Ausgabe aufgenommen oder davon ausgeschlossen werden. Aus der Gesamtberechnung ergibt sich einer der folgenden Werte:

  • True (oder) Don’t-Care:Das Element wird in die Ausgabe aufgenommen.

  • False:Das Element wird von der Ausgabe ausgeschlossen.

Die Reihenfolge der Operatoren, die FrameMaker beim Verarbeiten von Filtern verwendet, wird nachstehend in absteigender Reihenfolge aufgeführt:

    1. Klammer

    2. NOT

    3. AND

    4. OR

Zusätzliche Filterverarbeitung im Beispiel

Für das Element "TextContent1" in "Absatz 1" wird der Filter wie nachstehend angegeben verarbeitet:

    1. Die Auswertung des Attributwertpaars Sprache="Japanisch" ergibt "True" und die des Attributwertpaars Plattform="Windows" ergibt ebenfalls "True".

    2. Das Ergebnis der Berechnung des Filters ergibt "True" AND "True", und die abschließende Berechnung des Elements auf der Grundlage der Regeln ergibt "True". Dies bedeutet, dass Absatz 1 in die Ausgabe aufgenommen wird.

Tabelle 4 zeigt, wie das gesamte Dokument gefiltert wird:

Absatz | Element | Attributwertpaar-Abgleich mit jedem Element |  | Ergebnis auf der Grundlage der Regeln | Aktion
Absatz 1 | TextContent1 | Is Sprache=Japanisch? | True | True AND True=True | Aufnahme in Ausgabe
 |  | Is Plattform=Windows? | True
Absatz 2 | TextContent1 | Is Sprache=Japanisch? | True | True AND False=False | Ausschluss von der Ausgabe
 |  | Is Plattform=Windows? | False
Absatz 3 | TextContent2 | Is Sprache=Japanisch? | True | True AND Don’t- Care=True | Aufnahme in Ausgabe
 |  | Is Plattform=Windows? | Don’t-Care
Absatz 4 | TextContent2 | Is Sprache=Japanisch? | False | False AND Don’t-Care=False | Ausschluss von der Ausgabe
 |  | Is Plattform=Windows? | Don’t-Care
Absatz 5 | SysReq | Is Sprache=Japanisch? | Don’t-Care | Don’t-Care AND True=True | Aufnahme in Ausgabe
 |  | Is Plattform=Windows? | True
Absatz 6 | SysReq | Is Sprache=Japanisch? | Don’t-Care | Don’t-Care AND False=False | Ausschluss von der Ausgabe
 |  | Is Plattform=Windows? | False
Absatz 7 | LegalContent | Is Sprache=Japanisch? | Don’t-Care | Don’t-Care AND Don’t-Care=Don’t-Care | Aufnahme in Ausgabe
 |  | Is Plattform=Windows? | Don’t-Care

Absätze 1, 3, 5, und 7 werden auf der Grundlage der in Tabelle 5 aufgeführten Regeln in die Ausgabe aufgenommen.

Hinweis: Wenn ein Element in die Ausgabe aufgenommen wird, wird die Aufnahme oder der Ausschluss jedes seiner untergeordneten Elemente dadurch bestimmt, dass jedes untergeordnete Element verarbeitet wird. Wenn jedoch ein übergeordnetes Element den Filterausdruck nicht erfüllt und von der Ausgabe ausgeschlossen wird, werden seine untergeordneten Elemente ebenfalls von der Ausgabe ausgeschlossen, selbst wenn die untergeordneten Elemente den Filterausdruck erfüllen. Darüber hinaus verarbeitet FrameMaker das Stammelement nicht, während der Ausführung des Filters. Dies bedeutet, dass das Stammelement immer in die Ausgabe aufgenommen wird.


Filter nach Attribut

Anwenden von Filtern

Befolgen Sie folgende Anweisungen, um einen der von Ihnen erstellten Filter auf Ihr strukturiertes Dokument anzuwenden.

    1. Wählen Sie "Spezial > Filter nach Attribut" aus. Das Dialogfenster "Attributausdrücke verwalten" wird angezeigt.

    2. Wählen Sie "Nach Ausdruck anzeigen", um eine Vorschau der Elemente zu erhalten, die den Filterausdruck erfüllen, wenn er auf das Dokument angewendet wird.

Hinweis: Wenn Sie die Option "Alle anzeigen" auswählen, wird der aktive Ausdruck (falls vorhanden) deaktiviert, und alle Elemente im Dokument sind zum Anzeigen und Bearbeiten in FrameMaker verfügbar. Darüber hinaus wird aller bedingter Text, der ausgeblendet ist, angezeigt. Sie können den Vorgang "Alle anzeigen" nicht rückgängig machen.

    3. Wählen Sie einen Filter in der Liste aus.

    4. Klicken Sie auf "Zuweisen".

Hinweis: Sie können den Befehl "Anwenden" nach dem Anwenden eines Filters nicht mehr rückgängig machen.


Filter nach Attribut

Speichern von Dokumenten nach dem Anwenden von Filtern

Wenn Sie ein Dokument als eine FrameMaker 8- oder eine MIF 8-Datei speichern, werden alle Filter, die Attributwerte verwenden, einschließlich der Filter, die Sie auf das Dokument angewendet haben, gespeichert. Die von Ihnen für diese Funktion definierten Attributwerte werden ebenfalls gespeichert.

Hinweis: Wenn Sie ein Dokument im XML-Format speichern, werden alle Filter, die Attributwerte verwenden, ebenfalls gespeichert. Die von Ihnen für diese Funktion definierten Attributwerte werden jedoch nicht gespeichert.


Filter nach Attribut

Ändern von Filtern

Gehen Sie zum Ändern von Filtern entsprechend der folgenden Schritte vor:

    1. Wählen Sie "Spezial > Filter nach Attribut" aus. Das Dialogfenster "Attributausdrücke verwalten" wird angezeigt.

    2. Wählen Sie einen Filter in der Liste aus.

    3. Klicken Sie auf "Bearbeiten". Das Dialogfenster "Ausdruck erstellen" wird angezeigt.

    4. Ändern Sie den Filter im Bereich "Ausdruck".

    5. Klicken Sie auf "OK", um das Dialogfenster "Ausdruck erstellen" zu schließen.

Der geänderte Inhalt des Filters wird im Dialogfenster "Attributausdrücke verwalten" im Bereich "Ausgewählter Ausdruck" angezeigt.


Filter nach Attribut

Löschen von Filtern

Gehen Sie zum Löschen von Filtern entsprechend der folgenden Schritte vor:

    1. Wählen Sie "Spezial > Filter nach Attribut" aus. Das Dialogfenster "Attributausdrücke verwalten" wird angezeigt.

    2. Wählen Sie einen Filter in der Liste aus.

    3. Klicken Sie auf "Löschen".

    4. Wurde der Filter, den Sie gerade löschen, auf das Dokument angewendet, zeigt FrameMaker eine Meldung an, in der Sie darauf hingewiesen werden, dass der ausgewählte Ausdruck derzeit auf das Dokument angewendet wird. Klicken Sie auf "OK".

    5. Klicken Sie auf "OK", um den Löschvorgang zu bestätigen.

    6. Klicken Sie auf "Fertig", um das Dialogfenster "Attributausdrücke verwalten" zu schließen.

Hinweis: Wenn Sie in einem Dokument einen Filter löschen, werden alle Elemente, die durch den Filter ausgeschlossen wurden, wieder für die Anzeige, die Bearbeitung und die Erzeugung einer Ausgabe verfügbar gemacht.


Filter nach Attribut / Weitere Informationen

Zum Verarbeiten von Filtern verwendete Regeln

Tabelle 5 führt die Regeln auf, die FrameMaker zum Verarbeiten von Filtern verwendet.

Regelbeschreibung | Operator/Resultierender Wert
<Don't-care> OR <Don't-Care> | <Don't-Care>
<Don't-care> OR <True> | <True>
<Don't-care> OR <False> | <False>
<True> OR <Don't-care> | <True>
<False> OR <Don't-care> | <False>
<Don't-care> AND <Don't-Care> | <Don't-Care>
<Don't-care> AND <True> | <True>
<Don't-care> AND <False> | <False>
<True> AND <Don't-care> | <True>
<False> AND <Don't-care> | <False>
NOT <Don't-care> | <Don't-care>
<True> OR <True> | <True>
<False> OR <True> | <True>
<True> OR <False> | <True>
<False> OR <False> | <False>
<True> AND <True> | <True>
<False> AND <True> | <False>
<True> AND <False> | <False>
<False> AND <False> | <False>
NOT <True> | <False>
NOT <False> | <True>


Filter nach Attribut / Weitere Informationen

XML-Beispielcode

Kopieren Sie folgenden Code in ein FrameMaker-Dokument und speichern Sie es als XML-Datei.

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE Doc (View Source for full doctype...)>
    - <Dok>
        - <Absatz>
            <TextContent1 Sprache="Japanisch" Version="2.0" Plattform="Windows">TextContent1
            wobei Sprache="Japanisch" Version="2.0" Plattform="Windows"</TextContent1>
            </Absatz>
        - <Absatz>
            <TextContent1 Sprache="Japanisch" Version="2.0" Plattform="UNIX">TextContent1
            wobei Sprache="Japanisch" Version="2.0" Plattform="UNIX"</TextContent1>
            </Absatz>
        - <Absatz>
            <TextContent2 Sprache="Japanisch" Version="2.0">TextContent2 wobei
            Sprache="Japanisch" Version="2.0"</TextContent2>
            </Absatz>
        - <Absatz>
            <TextContent2 Sprache="Englisch" Version="1.0">TextContent2 wobei
            Sprache="Englisch" Version="1.0"</TextContent2>
            </Absatz>
        - <Absatz>
            <Sysreq Plattform="Windows">Sysreq wobei Plattform="Windows"</Sysreq>
            </Absatz>
        - <Absatz>
            <Sysreq Plattform="UNIX">Sysreq wobei Plattform="UNIX"</Sysreq>
            </Absatz>
        - <Absatz>
            <LegalContent Copyright="Schmal">LegalContent wobei
            Copyright="Schmal"</LegalContent>
            </Absatz>
        </Dok>


Bedingter Text

Bedingter Text

Planen von Bedingungsdokumenten

Erstellen, Ändern und Löschen von Bedingungstypen

Verwenden von booleschen Ausdrücken zum Erzeugen von bedingten Ausgaben

Zuweisen und Entfernen von Bedingungstypen

Arbeiten mit Bedingungsdokumenten

Bearbeiten von Elementen in bedingten strukturierten Dokumenten


Bedingter Text

Wenn Sie mehrere Versionen eines Dokuments mit jeweils kleinen Abweichungen vorbereiten, können Sie ein Adobe FrameMaker-Dokument für alle Versionen verwenden. Dieses Dokument enthält bedingten Text und bedingte Grafiken.

Sie müssen ggf. auch mit demselben FrameMaker-Dokument verschiedene Inhaltstypen für verschiedene Ausgabeformate erstellen. Beispiele müssen FrameMaker-Inhalte, die Sie für die PDF-Druckversion schreiben, möglicherweise für die Hilfeversion in HTML neu verfasst und formatiert werden. In diesem Fall können Sie ein Dokument verwenden, in das Sie die Inhalte für verschiedene Ausgabeformate integrieren und diese verschiedenen Inhalte mit den entsprechenden Bedingungstypen kennzeichnen.

Sie können bedingten Text auch verwenden, um Anmerkungen für Sie selbst oder für Lektoren und weitere Bearbeiter anzufügen. Bevor das fertige Exemplar gedruckt wird, können Sie die Anmerkungen ausblenden.

Bedingter Text unterscheidet sich bei den unterschiedlichen Versionen eines Dokuments. Nicht bedingter Text bleibt in allen Versionen gleich.

Sie können jede Texteinheit als bedingt definieren, von einem Zeichen bis zu ganzen Abschnitten. Auch verankerte Grafiken, Tabellen, Querverweise, Fußnoten, Marken und Tabellenreihen können als bedingt definiert werden. Wenn Sie einem Element einen Bedingungstyp zuweisen, wird aus dem Element ein bedingtes Element.

Zwei Versionen eines Datenblatts
Mit bedingtem Text können zwei Datenblätter in einem Dokument erstellt werden. Text und Grafiken, die in beiden Datenblättern übereinstimmen, sind nicht bedingt. Text und Grafiken, die nur auf einem Datenblatt erscheinen, werden mit einem Bedingungstyp versehen, der das Datenblatt kennzeichnet. A: Im Bild und im ersten Absatz sind sowohl bedingte als auch nicht bedingte Informationen enthalten. B: Nicht bedingter Text.

Die Bedingungstypen der aktuellen Auswahl (oder der Einfügemarke) werden in Klammern im Namensbereich der Statuszeile angezeigt.

Namensbereich in der Statuszeile

Mithilfe von Bedingungsformaten wie Stil und Farbe kann das Aussehen von bedingtem Text geändert werden, sodass er leicht erkennbar ist.

Bedingungsformate (durchgestrichen und unterstrichen) kennzeichnen zwei Bedingungen.

Bedingter Text kann auf unterschiedliche Weise angezeigt und gedruckt werden. Sie können beispielsweise alle Versionen eines Dokuments anzeigen oder ausgewählte Versionen verbergen. Das Gleiche gilt für Bedingungsformate. Alles, was Sie anzeigen, erscheint im gedruckten Dokument.


Bedingter Text / Bedingter Text

Verbesserungen in Verbindung mit bedingtem Text

Die Funktion "Bedingtre Text" vereinfacht und verbessert den Umgang mit Single-Source-Dokumenten. Sie können die Verbesserungen in Verbindung mit bedingtem Text für folgende Aufgaben nutzen:

    Verwalten von Bedingungstypen über das neue Dialogfenster "Bedingungs-Tag verwalten"

    Hinzufügen neuer Bedingungstypen über das neue Dialogfenster "Bedingungs-Tag hinzufügen"

    Definieren Sie eine neue Farbe für einen Bedingungstyp mithilfe der Schaltfläche "Neue Farbe" im Dialogfenster "Bedingungstyp ändern".

    Visuelle Unterscheidung von Text mit mehreren Bedingungstypen, wobei die Farbe des Textes von den ihm zugewiesenen Typen abhängt. Weitere Informationen finden Sie unter Erscheinungsbild von Text mit mehreren Bedingungstypen.

    Erstellen Sie mithilfe des neuen Dialogfensters "Ausdruck erstellen" boolesche Ausdrücke mit komplexen Kombinationen von Bedingungstypen und booleschen Operatoren, um bedingte Ausgaben zu generieren.

Benutzeroberflächen-

Verbesserungen

Dialogfenster "Bedingter Text"

Die Schaltfläche "Bedingung ändern" wird zur Schaltfläche "Tag verwalten".

Dialogfenster "Bedingungstyp ändern"

    Der Name des Felds lautet nun "Tag umbenennen".

    Die Schaltfläche "Neue Farbe" wurde hinzugefügt.

Dialogfenster "Bedingten Text ein-/ausblenden"

Eine neue Option mit dem Namen "Nach Ausdruck anzeigen", die dem Erstellen von booleschen Ausdrücken dient, wurde hinzugefügt.

Im Bereich "Laut Bedingung anzeigen" wurde eine neue Option mit dem Namen "Anzeigen, ob alle Bedingungen angewendet wurden" hinzugefügt.

Neue Dialogfenster

    Bedingungs-Tag verwalten

    Bedingungs-Tag hinzufügen

    Ausdruck erstellen


Bedingter Text

Planen von Bedingungsdokumenten

Wenn Sie ein Bedingungsdokument planen, sollten Sie die Art seines Inhalts berücksichtigen, sowie die Tatsache, dass möglicherweise auch andere das von Ihnen erstellte Bedingungsdokument verwenden und pflegen müssen. Behandeln Sie die bedingten Teile einheitlich, um die Verwendung und Pflege des Dokuments zu erleichtern. Anderen müssen die von Ihnen bei der Zuweisung von Bedingungstypen verwendeten Konventionen bekannt sein.

Wenden Sie beim Planen eines Projekts mit bedingtem Text die folgenden Richtlinien an.

Anzahl der Versionen

Legen Sie die Anzahl der Versionen fest, die das fertig gestellte Projekt enthalten soll. Wenn Sie beispielsweise ein Handbuch für ein Programm verfassen, das sowohl unter Windows als auch unter UNIX läuft, haben Sie die Möglichkeit, beispielsweise zwei unterschiedliche Versionen zu erstellen: eine Windows-Version und eine UNIX-Version. Sollen diese Versionen während des Überarbeitungsprozesses zusätzlich mit redaktionellen Kommentaren versehen werden, wären wahrscheinlich weitere Versionen erforderlich: UNIX mit Kommentaren, UNIX ohne Kommentare, Windows mit Kommentaren und Windows ohne Kommentare.

Anzahl der erforderlichen Bedingungstypen

Überlegen Sie, wie viele Bedingungstypen für die Erstellung der gewünschten Versionen erforderlich sind. Eine Version eines Dokuments wird durch einen eindeutigen Satz von Bedingungstypen definiert. Eine Version eines fertig gestellten Windows-Handbuchs könnte mit einem angezeigten Bedingungstyp Windows sowie jeweils einem verborgenen Bedingungstyp UNIX und Kommentare definiert sein. In diesem Beispiel müssten Sie entscheiden, ob Sie jeweils einen Bedingungstyp für Windows- und UNIX-Kommentare oder für beide einen gemeinsamen verwenden möchten.

Strukturieren des Inhalts

Überlegen Sie sich, wie viel bedingten Text Sie verwenden möchten und wie das Material zur Vereinfachung der Erstellung und Pflege strukturiert werden kann. Ein Buch kann möglicherweise so strukturiert werden, dass sich bedingter Text auf einige Dokumente beschränkt. Es ist auch möglich, die unterschiedlichen Versionen eines bestimmten Kapitels in unterschiedlichen Dateien zu erstellen, anstatt in bedingtem Text und anschließend für jede Version des Buches eine unterschiedliche Buchdatei zu verwenden. Stattdessen möchten Sie möglicherweise in einem strukturierten Dokument ganze Kapitel eines Buchs nur für den Druck zulassen.

Grafiken

Wenn ein Dokument durch Referenz importierte Grafiken in einem bedingten verankerten Rahmen enthält, müssen Sie für die Grafiken in jeder Version einen separaten Ordner erstellen. Dadurch wird die Dateiverwaltung vereinfacht, wenn Sie eine Version des Dokuments mit den zugehörigen Grafikdateien kopieren oder archivieren müssen.

Variablen

Bei Begriffen und Ausdrücken, die wiederholt in einem Dokument verwendet werden – wie Produkt- und Firmennamen – ist es einfacher, mit Variablen anstatt mit bedingtem Text zu arbeiten.

Überlegen Sie, ob Ihr Bedingungsdokument unterschiedliche Variablendefinitionen für jede Version benötigt. Beispielsweise könnte bei dem unter Bedingter Text dargestellten Datenblatt eine Variable mit dem Produktnamen verwendet werden, in dem Bedingungsdokument werden jedoch zwei Produkte beschrieben. Sie können für jede Version des Dokuments eine Schablone erstellen. Jede der Schablonen sollte nur eine sichtbare Version haben und nur die Variablen für diese Version definieren. Sie können dann mit "Datei > Importieren > Formate" zwischen den Variablendefinitionen der einzelnen Versionen hin- und herwechseln.

Bedingungsplanung

Legen Sie die kleinste Einheit des bedingten Textes fest. Wenn ein Bedingungsdokument beispielsweise in eine andere Sprache übersetzt wird, sollte die kleinste Einheit für bedingten Text ein vollständiger Satz sein. Da sich die Wortfolge während der Übersetzung häufig ändert, würde bedingter Text als Teil eines Satzes die Übersetzung erschweren.

Legen sie fest, ob Leer- und Satzzeichen als bedingt gekennzeichnet werden sollen. Wenn bedingter Text mit einem Satzzeichen beginnt oder endet, sollte dieses ebenfalls bedingt sein. Dadurch ist der Text beim Anzeigen mehrerer Versionen leichter zu lesen.

Zur Vermeidung von Problemen mit Wortabständen (z. B. ein nicht bedingtes Leerzeichen gefolgt von einem bedingten Leerzeichen) sollten Sie einen Standard für die Verwendung von Leerzeichen nach bedingtem Text festsetzen (entweder immer bedingt oder nie bedingt).

Legen Sie die Reihenfolge fest, in der bedingter Text angezeigt wird, und behalten Sie diese im gesamten Dokument bei. Die richtige Reihenfolge hilft anderen Autoren später bei der Pflege des Dokuments.

Mehrere Autoren

Beachten Sie die folgenden Richtlinien, wenn ein Bedingungsdokument von mehreren Autoren erstellt wird:

    Planen Sie die Struktur des Dokuments und den Arbeitsablauf. Beispielsweise können Sie ein Dokument in unterschiedliche kleinere Dateien aufteilen, sodass mehrere Personen gleichzeitig an unterschiedlichen Teilen des Dokuments arbeiten können.

    Legen Sie fest, auf welche Weise Sie anderen Autoren Erläuterungen bereitstellen wollen. Fügen Sie zur Erläuterung des Bedingungsdokuments hilfreiche Kommentare hinzu und weisen Sie diesen den vordefinierten Bedingungstyp "Kommentar" zu.


Bedingter Text

Erstellen, Ändern und Löschen von Bedingungstypen

Sie können für jeden Bedingungstyp, den Sie in einem FrameMaker-Dokument erstellen, eindeutige Bedingungsformate definieren. Sie können dann Text in einer Version vom Text in einer anderen Version unterscheiden. Verwenden Sie verschiedenfarbige Formate, wenn mithilfe Ihres Bedingungsdokuments mehr als zwei Versionen erstellt werden. In den Dialogfenstern "Bedingungs-Tag hinzufügen" und "Bedingungstyp ändern" können Sie eine neue Farbe erstellen und sie als Bedingungsformat für einen Bedingungstyp zuweisen. Sie können im Dialogfenster "Bedingung verwalten" einen Bedingungstyp umbenennen. Sie können Namen, Stil, Farbe und Bedingungsformate für einen Bedingungstyp ändern.

Wenn ein anderes Dokument die Einstellungen für bedingten Text enthält, die Sie im aktuellen Dokument verwenden wollen, können Sie diese mithilfe von "Datei > Importieren > Formate" importieren. Informationen hierzu finden Sie unter Importieren und Aktualisieren von Formaten und Ändern des Formats von Dateien eines Buches.

Hinweis: Bedingungstyp-Namen unterstützen den Unicode-Standard zur Textcodierung.

So erstellen Sie einen Bedingungstyp:

    1. Wählen Sie "Spezial > Bedingter Text > Bedingung verwalten" aus. Das Dialogfenster "Bedingung verwalten" wird angezeigt.

    2. Das Dialogfenster "Bedingungs-Tag hinzufügen" wird angezeigt.

    3. Geben Sie im Feld "Tag" einen Namen ein. Verwenden Sie aussagekräftige Namen mit einem eindeutigen ersten Buchstaben, um das Einrichten von Tastaturbefehlen zu ermöglichen.

    4. Wählen Sie in der Liste "Stil" einen Stil aus.

    5. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie in der Liste "Farbe" eine Farbe aus.

    Klicken Sie auf "Neue Farbe". Das Dialogfenster "Farbdefinitionen" wird angezeigt. Definieren Sie die erforderlichen Farbeinstellungen für die neue Farbe, die Sie gerade erstellen, und klicken Sie auf "Hinzufügen". Weitere Informationen hierzu finden Sie unter Definieren und Ändern von Farben und Aufhellungen. Klicken Sie zur Bestätigung auf "OK" und dann auf "Fertig". Wählen Sie in der Liste "Farbe" die neue Farbvoreinstellung aus.

    6. Klicken Sie auf "Zuweisen".

    7. Klicken Sie auf "Fertig".

Hinweis: Sie können das Dialogfenster "Bedingung verwalten" auch vom Dialogfenster "Bedingungstyp anwenden" aus öffnen, indem Sie auf die Schaltfläche "Tag verwalten" klicken.

So bearbeiten Sie einen Bedingungstyp:

    1. Wählen Sie "Spezial > Bedingter Text > Bedingung verwalten" aus. Das Dialogfenster "Bedingung verwalten" wird angezeigt.

    2. Wählen Sie einen zu bearbeitenden Bedingungstyp aus.

    3. Klicken Sie auf "Bearbeiten". Das Dialogfenster "Bedingungstyp ändern" wird angezeigt.

    4. Ändern Sie im Textfeld "Tag" den Namen.

    5. Geben Sie Bedingungsformate für Stil und Farbe an.

    6. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie in der Liste "Farbe" eine Farbe aus.

    Klicken Sie auf "Neue Farbe". Das Dialogfenster "Farbdefinitionen" wird angezeigt. Definieren Sie die erforderlichen Farbeinstellungen für die neue Farbe, die Sie gerade erstellen, und klicken Sie auf "Hinzufügen". Weitere Informationen hierzu finden Sie unter Definieren und Ändern von Farben und Aufhellungen. Klicken Sie zur Bestätigung auf "OK" und dann auf "Fertig". Wählen Sie in der Liste "Farbe" die neue Farbvoreinstellung aus.

    7. Klicken Sie auf "Zuweisen".

    8. Klicken Sie auf "Fertig". Die Änderungen werden im gesamten FrameMaker-Dokument angewendet.

Hinweis: Sie können den Tag-Namen auch vom Dialogfenster "Bedingter Text" aus bearbeiten, indem Sie auf "Tag verwalten" klicken und den Tag-Namen im Dialogfenster "Bedingungstyp ändern" ändern.

So löschen Sie einen Bedingungstyp aus einem Dokument:

    1. Wählen Sie "Spezial > Bedingter Text > Bedingung verwalten" aus. Das Dialogfenster "Bedingung verwalten" wird angezeigt.

    2. Wählen Sie den Tag aus, den Sie löschen möchten.

    3. Klicken Sie auf "Löschen".

    4. Klicken Sie zum Bestätigen auf "OK".

    5. Klicken Sie erneut auf "OK". FrameMaker löscht den Bedingungstyp aus allen Texten, in denen er verwendet wird, und entfernt ihn aus dem Dialogfenster "Bedingung verwalten". Wenn Text nur mit dem Bedingungstyp gekennzeichnet ist, den Sie gerade löschen, wird das Dialogfenster "Bedingungstyp löschen" angezeigt. Wählen Sie die Option aus, mit der der Text zu nicht bedingtem Text gemacht wird, oder löschen Sie den Text. Klicken Sie anschließend auf "OK".

    6. Klicken Sie auf "Fertig".

Falls Sie nur diejenigen Bedingungstypen löschen wollen, die in keinem Dokument zugewiesen wurden, aber nicht genau wissen, um welche Typen es sich dabei handelt, können Sie mit "Spezial > Referenzliste" eine Referenzliste mit Bedingungstypen generieren (siehe Generieren von Inhaltsverzeichnissen und anderen Listen).


Bedingter Text

Verwenden von booleschen Ausdrücken zum Erzeugen von bedingten Ausgaben

Sie können bedingte Ausgaben erzeugen, indem Sie einen booleschen Ausdruck mit Kombinationen aus Bedingungstypen und booleschen Operatoren erstellen.

Beispiel: Ihr Dokument enthält die Bedingungstypen "Kommentar", "Print", "Hilfe" und "PDF". Um nur Text mit den Bedingungstypen "Print" und "PDF" anzuzeigen, klicken Sie auf "Ausdruck erstellen" und definieren Sie den folgenden Ausdruck im Dialogfenster "Ausdruck erstellen": "Print" AND "PDF". Nach dem Anwenden dieses Ausdrucks wird im Dokument nur Text angezeigt, der mit den Bedingungstypen "Print" und "PDF" markiert ist. Alternativ dazu können Sie, um Text mit den Bedingungstypen "PDF" oder "Print" markierten Text in die Ausgabe einzuschließen, den Ausdruck wie folgt abändern:

"PDF" OR "Print"

So erstellen Sie einen booleschen Ausdruck:

    1. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Spezial > Bedingter Text > Bedingten Text ein-/ausblenden" aus.

    Wählen Sie "Spezial > Bedingten Text anwenden" aus. Das Dialogfenster "Bedingter Text" wird angezeigt. Klicken Sie auf die Schaltfläche "Bedingten Text ein-/ausblenden".

    2. (Optional) Wählen Sie die Option "Nach Ausdruck anzeigen" aus.

Hinweis: Alle im Dokument erstellten und angewendeten Bedingungsausdrücke sind im Aufklappmenü "Ausdruck" aufgeführt.

    3. Klicken Sie auf die Schaltfläche "Ausdruck erstellen". Das Dialogfenster "Ausdruck erstellen" wird angezeigt.

    4. Wählen Sie aus der Liste mit den Bedingungstypen einen Typ aus und klicken Sie auf die Schaltfläche zum Hinzufügen des Typs oder doppelklicken Sie auf den Typ, der hinzugefügt werden soll. Der Typ wird dann im Bereich "Ausdruck" angezeigt.

    5. Klicken Sie auf eine der Schaltflächen für die booleschen Operatoren AND, OR oder NOT.

    6. Wiederholen Sie die Schritte 4 und 5, um Typen hinzuzufügen und den gewünschten Ausdruck zu erstellen. Platzieren Sie zum Erstellen oder Bearbeiten eines Ausdrucks den Cursor im Bereich "Ausdruck".

    7. Klicken Sie auf "OK", um das Dialogfenster "Ausdruck erstellen" zu schließen.

    8. Klicken Sie auf die Schaltfläche "Zuweisen".

    9. Klicken Sie zum Fortfahren auf "OK". Nur der bedingte Text, der den Ausdruck erfüllt, wird in der Ausgabe angezeigt.

Klicken Sie zum vollständigen Löschen eines Ausdrucks im Dialogfenster "Ausdruck erstellen" auf die Schaltfläche "Löschen".


Bedingter Text

Zuweisen und Entfernen von Bedingungstypen

Um einen Text als bedingten Text zu definieren, weisen Sie ihm Bedingungstypen zu. Dies kann mithilfe des Dialogfensters "Bedingter Text", über die Tastatur oder durch Kopieren und Einfügen von Bedingungstypeinstellungen geschehen. Sie können Text in einem FrameMaker-Dokument mehrere Tags zuweisen.

Erscheinungsbild von Text mit mehreren Bedingungstypen

Mit FrameMaker können Sie zwischen Text, dem nur ein Bedingungstyp zugewiesen wurde, und Text mit mehreren zugewiesenen Bedingungstypen unterscheiden.

Wenn Sie einem ausgewählten Text einen neuen Bedingungstyp zuweisen, dem bereits ein anderer Bedingungstyp zugewiesen wurde, ändert sich die Farbe des Textes. Die neue Farbe liegt zwischen den Farben der dem aktuellen Text bereits zugewiesenen Bedingungstypen.

Zum Einfügen von Bedingungstypeinstellungen steht Ihnen außerdem der Befehl "Suchen/Ändern" zur Verfügung. Einzelheiten finden Sie unter Suchen nach bedingtem Text und Ändern gefundener Elemente.

Sie können zwei Versionen eines Dokuments in einem Bedingungsdokument zusammenfügen. Dabei vergleicht FrameMaker die beiden Dokumente und erstellt ein kombiniertes Bedingungsdokument. Informationen über den Vergleich und das Einlesen von Dokumenten finden Sie unter Vergleichen von Dokumentversionen.

So weisen Sie einem Element einen Bedingungstyp zu:

    1. Wählen Sie das Element aus, das Sie als bedingt definieren wollen. Sehen Sie sich dazu die folgende Tabelle an:

Gewünschtes Element | Auswahl
Text in einem Textrahmen, einer Tabellenzelle oder einer Fußnote | Text
Verankerter Rahmen mit Inhalt | Rahmenbegrenzung oder Ankersymbol
Gesamte Tabelle | Ankersymbol der Tabelle
Tabellenreihe | Gesamte Reihe
Querverweis oder Variable | Querverweis oder Variablentext
Footnote | Fußnotenreferenz (Nummer im Haupttext)
Marke | Markensymbol

Hinweis: Sie können zwar Text in Textrahmen, nicht aber Text in Textzeilen als bedingt definieren.

    2. Wählen Sie "Spezial > Bedingter Text > Bedingten Text anwenden" aus. Das Dialogfenster "Bedingter Text" wird angezeigt.

    3. Wenn Sie einen Bedingungstyp anwenden möchten, verschieben Sie diesen in die Auswahlliste "Mit". Wenn Sie einen Bedingungstyp entfernen möchten, verschieben Sie ihn in die Auswahlliste "Ohne". Bedingungstypen in der Auswahlliste "Beibehalten" können weder zugewiesen noch entfernt werden.

    Zum Verschieben von Bedingungstypen aus einer Auswahlliste wählen Sie den Typ aus und klicken auf einen Pfeil. Sie können auch auf den Typ doppelklicken.

    Zum Verschieben aller Bedingungstypen aus einer Auswahlliste wählen Sie einen Typ in der Liste aus und klicken bei gedrückter Umschalttaste auf einen Pfeil.

    4. Klicken Sie auf "Zuweisen". FrameMaker wendet die Einstellungen auf den Text an. Wenn Sie einen ausgeblendeten Bedingungstyp zuweisen, wird der ausgewählte Text nicht angezeigt, es sei denn, er ist ebenfalls Teil einer eingeblendeten Bedingung. Informationen zum Anzeigen von ausgeblendetem Text finden Sie unter Ändern der Darstellung von Bedingungsdokumenten.

So weisen Sie einen Bedingungstyp mithilfe der Tastatur zu:

    1. Wählen Sie das Element aus, dem ein Bedingungstyp zugewiesen werden soll, und drücken Sie Strg+4.

    2. Geben Sie an der Eingabeaufforderung in der Statuszeile den Namen des Bedingungstyps ein. Sie müssen eventuell nur einige Zeichen eingeben, bis der Name im Namensbereich eingeblendet wird. Geben Sie Kleinbuchstaben ein, um vorwärts zu suchen, und Großbuchstaben, um rückwärts zu suchen. Sie können auch mithilfe der Nach-Oben- und Nach-Unten-Tasten durch die Bedingungstypen blättern.

    3. Drücken Sie die Eingabetaste, um den Bedingungstyp zuzuweisen. Sie können den Vorgang auch abbrechen, indem Sie in das Dokument klicken, ohne die Eingabetaste zu drücken.

So können Sie Bedingungstypeinstellungen kopieren und einfügen:

    1. Platzieren Sie die Einfügemarke in dem Text, der die zu kopierenden Bedingungstypeinstellungen enthält.

    2. Wählen Sie "Bearbeiten > Kopieren Spezial > Bedingter Text".

    3. Wählen Sie ein Element aus oder klicken Sie, um die Einfügemarke zu platzieren.

    4. Wählen Sie "Bearbeiten" > "Einfügen" bzw. "Einsetzen". Wenn Sie die Einstellungen in ein anderes Dokument einfügen, werden die Namen der eingefügten Typen im Dialogfenster "Bedingter Text" des Dokuments angezeigt, sodass Sie die Bedingungstypen erneut verwenden können.


Bedingter Text / Zuweisen und Entfernen von Bedingungstypen

Vermeiden von ungelösten Querverweisen

Wenn Sie einen Querverweis auf einen Absatz (beispielsweise auf eine Überschrift) einfügen und das erste Wort im Absatz bedingt ist, wird die von FrameMaker eingefügte Querverweis-Marke ebenfalls bedingt (entsprechend den Bedingungstypeinstellungen des ersten Wortes). Das bedeutet, dass die Marke ausgeblendet wird, wenn Sie die Bedingungen des ersten Wortes ausblenden. Als Folge davon kann der Querverweis unter Umständen ungelöst sein, wenn die Bedingungstypeinstellungen des Querverweises und diejenigen der Querverweis-Marke unterschiedlich sind.

Um dies zu verhindern, wählen Sie nur die Querverweis-Marke am Beginn des Quellabsatzes aus und definieren sie als nicht bedingt. Die Marke wird nun immer angezeigt, sodass der Querverweis aufgelöst wird, unabhängig davon, welche Version sichtbar ist.


Bedingter Text / Zuweisen und Entfernen von Bedingungstypen

Entfernen von Bedingungstypen aus einem Element

Das Entfernen eines Bedingungstyps aus einem Element unterscheidet sich vom Löschen eines Bedingungstyps aus einem Dokument. Wenn Sie einen Bedingungstyp aus einem Element entfernen, bleibt der Typ im Dokument erhalten, sodass er später erneut zugewiesen werden kann. Löschen Sie dagegen einen Bedingungstyp aus einem Dokument (siehe Erstellen, Ändern und Löschen von Bedingungstypen), entfernt FrameMaker diesen Typ aus allen Texten, in denen er verwendet wird, und löscht ihn aus dem Dialogfenster "Bedingter Text".

So entfernen Sie einen Bedingungstyp aus einem Element:

    1. Wählen Sie zunächst das Element mit dem Typ aus, den Sie entfernen wollen und anschließend "Spezial > Bedingter Text > Bedingten Text anwenden". Das Dialogfenster "Bedingter Text" wird angezeigt.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie zwar Bedingungstypen entfernen wollen, der Text aber weiterhin bedingt bleiben soll, verschieben Sie die betreffenden Bedingungstypen in die Auswahlliste "Ohne". (Um einen Bedingungstyp von einer Auswahlliste in eine andere zu verschieben, wählen Sie den Typ aus, und klicken Sie auf einen Pfeil. Sie können auch auf den Typ doppelklicken.)

    Um alle Bedingungstypen zu entfernen und den Text nicht als bedingt zu definieren, wählen Sie die Option "Nicht bedingt".

    3. Klicken Sie auf "Zuweisen".

So entfernen Sie mithilfe der Tastatur einen Bedingungstyp aus einem Element:

    1. Wählen Sie das Element aus, aus dem Sie einen Bedingungstyp entfernen möchten, und drücken Sie Strg+5.

    2. Geben Sie an der Eingabeaufforderung in der Statuszeile den Namen des Bedingungstyps ein. Sie müssen eventuell nur einige Zeichen eingeben, bis der Name im Namensbereich eingeblendet wird. Geben Sie Kleinbuchstaben ein, um vorwärts zu suchen, und Großbuchstaben, um rückwärts zu suchen. Sie können auch mithilfe der Nach-Oben- und Nach-Unten-Tasten durch die Bedingungstypen blättern.

    3. Drücken Sie die Eingabetaste, um den Bedingungstyp aus dem Element zu entfernen. Sie können den Vorgang auch abbrechen, indem Sie in das Dokument klicken, ohne die Eingabetaste zu drücken. Wenn die Auswahl nur den Bedingungstyp enthält, den Sie entfernen möchten, werden Sie in einem Dialogfenster gefragt, ob der Text als nicht bedingter Text definiert oder gelöscht werden soll.

So entfernen Sie mithilfe der Tastatur alle Bedingungstypen:

Wählen Sie das Element aus, aus dem alle Bedingungstypen entfernt werden sollen (dadurch wird das Element zu einem nicht bedingten Element), und drücken Sie Strg+6.


Bedingter Text

Arbeiten mit Bedingungsdokumenten

Sie können nicht bedingten und bedingten Text gleichzeitig anzeigen und drucken oder den bedingten Text einer oder mehrerer Versionen ausblenden. FrameMaker ignoriert bei der Formatierung eines Dokuments ausgeblendeten bedingten Text. Wenn die Anzeige der Steuerzeichen aktiviert ist, wird ausgeblendeter bedingter Text auf dem Bildschirm durch eine Marke für bedingten Text ( [image] ) dargestellt.

Marken zeigen an, wo bedingter Text ausgeblendet ist.


Bedingter Text / Arbeiten mit Bedingungsdokumenten

Ändern der Darstellung von Bedingungsdokumenten

In einem Bedingungsdokument lassen sich beliebig viele Bedingungen gleichzeitig anzeigen und beliebig viele Bedingungsformate ein- oder ausblenden. So können Sie beispielsweise die Darstellung ändern, um die Bedingungstypen für eine bestimmte, für mehrere oder für alle Versionen anzuzeigen. Wenn Sie mehrere Versionen anzeigen wollen oder nur eine Version, in der Sie jedoch sehen möchten, welcher Text bedingt ist, blenden Sie die Bedingungsformate ein.

Sie können bedingten Text anzeigen, indem Sie eine der folgenden Optionen auswählen:

  • Alle anzeigen: Wählen Sie diese Option, um allen Text, auf den Bedingungstypen angewendet wurden, anzuzeigen.

  • Laut Bedingung anzeigen:Wählen Sie diese Option, um Text basierend auf einem spezifischen Bedingungstyp anzuzeigen.

  • Nach Ausdruck anzeigen:Wählen Sie diese Option, um Text basierend auf einem Ausdruck mit einer komplexen Kombination von Bedingungstypen und booleschen Operatoren anzuzeigen. Weitere Informationen zum Definieren von Ausdrücken finden Sie unter Bearbeiten von Elementen in bedingten strukturierten Dokumenten.

So ändern Sie die Darstellung eines Bedingungsdokuments:

    1. Führen Sie eine der folgenden Aktionen aus:

    Um die Anzeige eines Bedingungsdokuments zu ändern, wählen Sie "Spezial> Bedingter Text". Klicken Sie anschließend auf "Bedingten Text ein-/ausblenden".

    Wenn Sie die Anzeige von Bedingungsdokumenten mit dem Buchfenster ändern wollen, wählen Sie die gewünschten Dokumente aus und wählen Sie "Spezial > Bedingter Text >Bedingten Text ein-/ausblenden".

    2. Gehen Sie nach einer der folgenden Methoden vor, um bedingten Text, den Sie im Dokument ein- oder ausblenden möchten, auszuwählen:

    Wählen Sie die Option "Alle anzeigen" aus.

    Wählen Sie die Option "Laut Bedingung anzeigen" aus. Verschieben Sie die gewünschten Bedingungstypen zwischen den Auswahllisten, indem Sie einen Typ auswählen und auf einen Pfeil klicken. Sie können auch auf den Typ doppelklicken. Um alle Bedingungstypen von einer Auswahlliste in eine andere zu verschieben, wählen Sie einen Typ in der Liste aus und klicken Sie bei gedrückter Umschalttaste auf einen Pfeil. Wurde ein Bedingungstyp in der Anzeigeliste auf Text in Ihrem Dokument angewendet, wird der entsprechende bedingte Text im Dokument angezeigt. Wählen Sie die Option "Anzeigen, ob alle Bedingungen angewendet wurden" aus, um bedingten Text nur dann anzuzeigen, wenn alle von Ihnen in der Anzeigeliste ausgewählten Bedingungstypen auf diesen Text angewendet wurden.

    Wählen Sie die Option "Nach Ausdruck anzeigen" und wählen Sie aus dem Aufklappmenü einen Ausdruck aus. Weitere Informationen zum Erstellen von Ausdrücken finden Sie unter Verwenden von booleschen Ausdrücken zum Erzeugen von bedingten Ausgaben.

    3. Geben Sie an, ob Sie die Bedingungsformate anzeigen möchten.

Hinweis: Bedingungsformate sind Stil- und Farbparameter, die zur Unterscheidung zwischen bedingtem und normalem Text verwendet werden. Sie können beispielsweise einen Bedingungstyp mit dem Namen "Persönlicher Kommentar" erstellen und als Stil "Doppelt unterstrichen" und als Farbe "Blau" konfigurieren.

    4. Klicken Sie auf "Zuweisen".

Sie können zwischen den Anzeigen der verschiedenen Versionen eines Dokuments schnell hin- und herwechseln, wenn Sie eine Schablone für jede Version erstellen. Alle Schablonen müssen die entsprechenden Einstellungen für das Ein- und Ausblenden der Version enthalten. Danach lässt sich die Anzeige eines Bedingungsdokuments mit "Datei > Importieren > Formate" von der Schablone aus ändern (siehe Importieren und Aktualisieren von Formaten und Ändern des Formats von Dateien eines Buches).

Hinweis: Wenn Sie die Option "Alle anzeigen" auswählen, wird der aktive Ausdruck (falls vorhanden) deaktiviert, und alle Elemente im Dokument sind zum Anzeigen und Bearbeiten in FrameMaker und zum Erzeugen der gewünschten Ausgabe verfügbar.


Bedingter Text / Arbeiten mit Bedingungsdokumenten

Anzeigen von importiertem bedingten Text

Wenn Sie Text importieren, der Passagen mit bedingtem Text enthält, werden alle Bedingungstypen, die dem Text im Quelldokument zugewiesen wurden, ebenfalls importiert, sodass Sie sie zum Ein- und Ausblenden des importierten bedingten Textes verwenden können. Selbst wenn der Text durch Referenz importiert und in einem Texteinschub angezeigt wird, können Sie die Anzeige des bedingten Textes im Texteinschub ändern.

Text wird auf der Grundlage folgender Kriterien ein- oder ausgeblendet:

    Wenn im Zieldokument die Option "Alles einblenden" aktiviert ist, wird anfänglich der gesamte bedingte Text eingeblendet.

    Ist im Zieldokument die Option "Laut Bedingung anzeigen" ausgewählt, wird bedingter Text, der einem der ausgewählten Bedingungstypen in der Anzeigeliste entspricht, im Dokument angezeigt. Ist die Option "Anzeigen, ob alle Bedingungen angewendet wurden" im Zieldokument ausgewählt, wird nur dann der gesamte bedingte Text im Dokument angezeigt, wenn alle in der Anzeigeliste ausgewählten Bedingungstypen auf Text im Dokument angewendet wurden.

    Ist die Option "Anzeigen nach Ausdruck" im Zieldokument ausgewählt, wird nur der bedingte Text angewendet, der auf dem ausgewählten Ausdruck beruht. Weitere Informationen zum Definieren von Ausdrücken finden Sie unter Verwenden von booleschen Ausdrücken zum Erzeugen von bedingten Ausgaben.

Hinweis: Wenn Sie keine dieser Optionen auswählen, wird bedingter Text anfänglich ein- oder ausgeblendet, je nach den entsprechenden Einstellungen im Zieldokument. Wenn importierte Bedingungstypen mit den Typen im Zieldokument nicht übereinstimmen, wird bedingter Text anfänglich ein- oder ausgeblendet, je nach den entsprechenden Einstellungen im Quelldokument.


Bedingter Text / Arbeiten mit Bedingungsdokumenten

Bearbeiten von bedingtem Text

Bei der Bearbeitung eines Bedingungsdokuments wird ausgeblendeter Text generell ignoriert. Das bedeutet, dass beispielsweise die Befehle "Suchen/Ändern" und "Rechtschreibhilfe" nur angezeigten Text berücksichtigen. Sie können jedoch ausgeblendeten Text ausschneiden, kopieren und einfügen, indem Sie die Marken für bedingten Text auswählen und die entsprechenden Befehle im Menü "Bearbeiten" verwenden.

Bei der Bearbeitung eines Bedingungsdokuments sollten Sie immer die Anzeige der Steuerzeichen aktivieren. Die Marken für bedingten Text machen Sie auf Text aufmerksam, der zu anderen Versionen des Dokuments gehört.

So bearbeiten Sie bedingten Text:

Verwenden Sie wie gewohnt die Befehle des Menüs "Bearbeiten".

Wenn Sie Text kopieren, kopiert FrameMaker auch die Marken für bedingten Text und die Einstellungen der Bedingungstypen. Beim Einfügen von Text, dem ein Bedingungstyp zugewiesen wurde, der nicht im Zieldokument vorhanden ist, fügt FrameMaker diesen Typ in das Zieldokument ein. Wenn Sie versuchen, ausgeblendeten bedingten Text zu verschieben oder zu löschen, zeigt FrameMaker ein Meldungsfenster an, in dem Sie die Möglichkeit haben, den Vorgang fortzusetzen, den Text zu löschen oder den Befehl abzubrechen.

So weisen Sie ausgeblendetem Text Formatänderungen zu:

Verwenden Sie "Format > Absätze > Gestaltung" und "Format > Zeichen > Gestaltung". Wenn Sie einer Auswahl Absatz- und Zeichenformatänderungen zuweisen, wird ausgeblendeter bedingter Text, der sich innerhalb der Auswahl befindet, nicht aktualisiert. Soll eine Formatänderung allen Absätzen und Zeichen, einschließlich ausgeblendetem bedingten Text, zugewiesen werden, klicken Sie im Gestaltungsfenster auf "Alle aktualisieren" oder wählen Sie im Aufklappmenü "Absatzformat" in der Formatierungsleiste "Alle aktualisieren".

Bei der Zuweisung von Formatänderungen mit "Importieren > Formate" wird auch ausgeblendeter bedingter Text aktualisiert.

So führen Sie für den gesamten Text eine Rechtschreibprüfung oder eine Suche durch:

Blenden Sie sämtlichen bedingten Text ein (siehe Ändern der Darstellung von Bedingungsdokumenten), bevor Sie "Bearbeiten > Rechtschreibhilfe" oder "Bearbeiten > Suchen/Ändern" wählen.


Bedingter Text / Arbeiten mit Bedingungsdokumenten

Suchen von bedingtem Text

Sie können nach Elementen suchen, denen ein sichtbarer Bedingungstyp zugewiesen ist. FrameMaker sucht bedingten Text in Text- und Grafikrahmen und in Tabellenzellen, nicht aber in Tabellenreihen. Weitere Informationen finden Sie unter Suchen nach bedingtem Text.


Bedingter Text / Arbeiten mit Bedingungsdokumenten

Abschließende Bearbeitung von Bedingungsdokumenten

Beachten Sie bei der Erstellung der endgültigen Version eines Bedingungsdokuments die folgenden Richtlinien:

    Ändern Sie die Anzeige des Dokuments so, dass nur die Version angezeigt wird, die Sie drucken wollen, und blenden Sie die Bedingungsformate aus.

    Wenn Ihr Dokument Variablen enthält, müssen Sie sicherstellen, dass die Variablendefinitionen für die Version, die Sie drucken wollen, korrekt sind.

    Führen Sie eine Rechtschreibung für das Dokument durch. Damit lassen sich doppelte Leerzeichen und Interpunktionsprobleme erkennen, die durch falsch zugewiesenen bedingten Text verursacht werden.

    Aktualisieren Sie die Querverweise. Wenn das Dokument ungelöste Querverweise enthält, beziehen sie sich eventuell auf Querverweis-Marken in ausgeblendetem bedingten Text. Blenden Sie die Version ein und aktualisieren Sie die Querverweise erneut. Informationen über das Auflösen von Querverweisen finden Sie unter Auflösen von Querverweisen. Lesen Sie auch den Abschnitt Vermeiden von ungelösten Querverweisen.

    Legen Sie für jede Version eine Kopie des Dokuments an, bevor Sie Zeilen- und Seitenumbrüche manuell anpassen. Verwenden Sie für die Anpassungen und für den Druck die Kopie der jeweiligen Version. Die Anpassungen unterscheiden sich für jede Version. Verwenden Sie für zukünftige Überarbeitungen das Originaldokument.

    Wenn das Dokument Teil eines Buches ist, aktualisieren Sie das Buch und die dazugehörigen generierten Dateien. Enthält das Buch Dokumente mit unterschiedlichen Bedingungsformaten für denselben Bedingungstyp oder werden einige Bedingungstypen in einem Dokument eingeblendet, in einem anderen aber ausgeblendet, zeigt FrameMaker eine Warnmeldung an. Klicken Sie in diesem Fall auf "Abbrechen", um die Generierung zu stoppen, und korrigieren Sie die Einstellungen des bedingten Textes im Dokument.

    Suchen Sie nach der Erstellung eines Indexes nach doppelten Fragezeichen (??), die auf fehlende oder fehlerhafte Indexmarken hindeuten. Weitere Informationen hierzu finden Sie unter Fehlerbehebung in Indizes.


Bedingter Text

Bearbeiten von Elementen in bedingten strukturierten Dokumenten

Sie können Elemente in bedingten strukturierten Dokumenten so wie in anderen Dokumenten einfügen, eingliedern, zusammenfügen und aufteilen. FrameMaker wendet bei Bedarf folgende Bedingungen an:

    Wenn Sie ein Element einfügen, übernimmt es die Bedingungstypen der Position der Einfügemarke.

    Wenn Sie ein Element eingliedern, übernimmt es im Allgemeinen die Bedingungstypen des Auswahlortes. Beachten Sie jedoch die folgenden beiden Punkte, wenn die Auswahl Grenzen überschreitet.

    Wenn Sie eine Auswahl eingliedern, die die Grenzen zweier Bedingungen überschreitet, übernimmt das neue Element keine Bedingungstypen. Die Typen der Elementinhalte werden jedoch beibehalten.

    Wenn Sie eine Auswahl eingliedern, die die Grenzen von bedingtem und nicht bedingtem Text überschreitet, übernimmt das neue Element keine Bedingungstypen, und die Elementinhalte bleiben nach wie vor teilweise bedingt und teilweise nicht bedingt.

    Wenn Sie mehr als zwei Elemente zusammenfügen, die unterschiedliche Bedingungstypen besitzen, übernimmt das neue Element keine Bedingungstypen. Der Inhalt des Elements behält jedoch seine Bedingungstypen bei.

    Wenn Sie ein Element aufteilen, besitzen die beiden Elemente dieselben Bedingungstypen wie das Originalelement.

Jede Version in einem Bedingungsdokument sollte gültig sein. Überprüfen Sie daher das Dokument auf Gültigkeit, indem Sie jeweils nur eine Version anzeigen. Die Gültigkeit ist in der Regel nicht von Bedeutung, wenn mehrere Versionen angezeigt werden.

Hinweis: Wenn auf ein strukturiertes Dokument ein Filter angewendet wurde, überschreibt dieser Ausdruck allen bedingten Text in diesem Dokument. Wenn Sie zur Erzeugung einer Ausgabe einen Filter auf ein strukturiertes Dokument anwenden, werden die Bedingungsformate deaktiviert. Wenn Sie wieder zur Verwendung von bedingtem Text zur Erzeugung der Ausgabe zurückwechseln, müssen Sie möglicherweise die Bedingungsformate erneut aktivieren. Weitere Informationen finden Sie unter Filter nach Attribut.


Grafiken und verankerte Rahmen

Grafiken

Arbeiten mit den Zeichenwerkzeugen

Grafikelemente in strukturierten Dokumenten

Verankerte Rahmen

Erstellen verankerter Rahmen

Bearbeiten verankerter Rahmen

Vorbereiten verankerter Rahmen für Tagged PDF

Verankerte Rahmen in strukturierten Dokumenten


Grafiken und verankerte Rahmen

Grafiken

In Adobe FrameMaker können Sie Rechtecke, Ovale und Polygone sowie gerade und gekrümmte Linien zeichnen. Durch die Kombination mehrerer Objekte und die Einbindung von Text können Sie komplexe Zeichnungen erzeugen. Darüber hinaus können Sie Objekteigenschaften festlegen (z. B. Füllmuster, Linienstärke und Farbe) und Objekte vergrößern/verkleinern, umformen, drehen und umordnen.

Sie können Grafiken auch direkt auf der Seite platzieren, in verankerten Grafikrahmen, die sich mit dem Text bewegen, oder in nicht verankerten Grafikrahmen, wodurch die Ränder der Grafik beschnitten werden. Informationen über verankerte Rahmen finden Sie unter Verankerte Rahmen. Informationen über unverankerte Grafikrahmen finden Sie unter Beschneiden oder Maskieren von Grafiken. Informationen zum Importieren von Grafiken finden Sie unter Importieren, Verknüpfen und Exportieren.


Grafiken und verankerte Rahmen / Grafiken

Anzeigen der Werkzeugpalette

Mithilfe der Werkzeugpalette können Sie Zeichenwerkzeuge auswählen und Einstellungen anwenden. Die Palette enthält folgende Elemente:

    Auswahlwerkzeuge, mit denen Sie Text und Objekte auswählen können.

    Zeichenwerkzeuge, mit denen Sie Objekte zeichnen können.

    Aufklappmenüs, mit denen Sie die Zeichnungseinstellungen eines Objekts ändern können.

A: Auswahlwerkzeuge B: Zeichenwerkzeuge C: Zeichnungseinstellungen

Auf UNIX-Systemen enthält eine umfangreiche Werkzeugpalette einige Befehle aus dem Menü "Grafik". Sie können auf diese Einstellungen klicken, anstatt sie aus einem Aufklappmenü auswählen zu müssen.

So zeigen Sie die Werkzeugpalette an:

Klicken Sie auf das Symbol "Werkzeuge" ( [image] ) am rechten Rand des Dokumentfensters.

So schalten Sie zwischen kleiner und großer Werkzeugpalette um (UNIX):

    Klicken Sie auf den Umschalter ( [image] ) in der linken unteren Ecke der Werkzeugpalette.


Grafiken und verankerte Rahmen / Grafiken / Anzeigen der Werkzeugpalette

Verwenden von Rastern

Es gibt zwei Raster, die Ihnen das Zeichnen und Ausrichten von Objekten erleichtern:

    Das sichtbare Raster wird in Form von horizontalen und vertikalen Linien auf dem Bildschirm angezeigt (jedoch nicht im Ausdruck). Jeder Grafikrahmen enthält ein eigenes sichtbares Raster, das in der linken oberen Rahmenecke beginnt.

    Das unsichtbare Magnetraster zieht Objekte an. Wenn Sie Objekte zeichnen, drehen, ziehen oder in der Größe ändern (und wenn Sie Einzugs- oder Tabulatorsymbole im Lineal an eine neue Position ziehen), rasten diese am unsichtbaren Raster ein.

Hinweis: Sind die beiden Optionen "Fluchten" und "Magnet" im Menü "Grafik" aktiviert, hat "Fluchten" Vorrang. Weitere Information über Fluchten finden Sie unter Fluchten.

So blenden Sie das sichtbare Raster ein oder aus:

Wählen Sie "Darstellung > Rasterlinien". Wenn das Raster in einem Textrahmen nicht angezeigt wird, weisen Sie dem Füllmuster des Rahmens den Wert "Keine" zu (siehe Zuweisen und Ändern von Zeichnungseinstellungen).

So aktivieren oder deaktivieren Sie das Magnetraster:

Wählen Sie "Grafik > Magnet".

So ändern Sie den Rasterabstand:

    1. Wählen Sie "Darstellung > Optionen".

    2. Führen Sie einen der folgenden Schritte aus:

    Um den Abstand zwischen den Linien des sichtbaren Rasters festzulegen, wählen Sie den gewünschten Wert im Aufklappmenü "Rasterlinien".

    Um den Abstand zwischen den Linien des Magnetrasters festzulegen, geben Sie den gewünschten Wert in das Textfeld "Rasterlinienabstände" ein.

    Um das Rasterintervall für das Drehen von Objekten festzulegen, geben Sie den Wert (in Grad) in das Textfeld "Drehung" ein.

Wenn Sie die Raster zusammen verwenden wollen, geben Sie für das sichtbare Raster ein Vielfaches des Wertes des Magnetrasters an. Beträgt der Abstand des Magnetrasters beispielsweise 0,5 cm, geben Sie für das sichtbare Raster 0,5 cm, 1 cm oder 2 cm an.

    3. Klicken Sie auf "Zuweisen".


Grafiken und verankerte Rahmen / Grafiken

Zeichnen von Objekten

Die Werkzeugpalette enthält verschiedene Werkzeuge zum Zeichnen von Objekten.

Zeichenwerkzeuge

Mit den Geraden-, Polygonzug-, Bogen- und Freihandkurven-Werkzeugen können Sie verschiedene Arten von Linien erstellen. Die Werkzeuge zum Zeichnen von Rechtecken, abgerundeten Rechtecken, Ellipsen und Polygonen ermöglichen das Erstellen geschlossener Formen. Sie können auch das Rechteck- und Ellipsen-Werkzeug sowie den Befehl "Grafik > Seitenanzahl" verwenden, um ein gleichmäßiges Polygon zu erstellen (ein Polygon mit gleichen Seiten und Winkeln).

Mit dem Textrahmen- oder Textzeilen-Werkzeug können Sie einer Grafik Text hinzufügen. Mit dem Grafikrahmen-Werkzeug beschneiden Sie Objekte. Einen Überblick über Text- und Grafikrahmen finden Sie unter Rahmen. Informationen über das Beschneiden von Objekten finden Sie unter Beschneiden oder Maskieren von Grafiken.


Grafiken und verankerte Rahmen / Grafiken

Bezugslinien

Die Bezugslinie eines Objekts ist eine imaginäre Linie durch die Mitte der Objektbegrenzung. Beim Zeichnen eines Objekts wird die Bezugslinie als Umrisslinie angezeigt.

A: Begrenzung B: Pfad

FrameMaker verwendet die Bezugslinie zum Positionieren der Objekte. Wenn Sie beispielsweise Objekte mithilfe des Befehls "Ausrichten" ausrichten, werden diese an ihren Bezugslinien und nicht an ihren Umrisslinien ausgerichtet. Ist das Magnetraster aktiviert, richtet FrameMaker die Bezugslinien an diesem aus.

Objekte werden an ihren Bezugslinien ausgerichtet.


Grafiken und verankerte Rahmen

Arbeiten mit den Zeichenwerkzeugen

Das Zeichnen eines Objekts umfasst eine einfache Abfolge von Klick- und Ziehoperationen. Während des Zeichnens wird der Umriss des Objekts angezeigt.

Wenn Sie ein Objekt zeichnen, wird der Mauszeiger als Fadenkreuz ( [image] ) angezeigt. Danach wird er normalerweise wieder zu einem Pfeil ( [image] ), mit dem Sie Objekte auswählen, oder zu einem Textcursor ( [image] ), mit dem Sie Text auswählen oder eingeben können. Um ein anderes Objekt zu erstellen, klicken Sie einfach erneut auf ein Zeichenwerkzeug.

Wenn Sie ein Objekt direkt auf einer Seite zeichnen, wird es nicht mit dem Text verschoben, kann aber von Text umflossen werden. Um das Objekt im benachbarten Text zu verankern (sodass es beim Bearbeiten des Textes mit diesem verschoben wird), erstellen Sie es in einem verankerten Rahmen oder zeichnen Sie es auf der Seite und verschieben Sie es anschließend in einen verankerten Rahmen.

Wenn Sie ein Objekt zeichnen, werden die in der Werkzeugpalette ausgewählten Einstellungen verwendet. Auch das Objekt wird ausgewählt, um Ihnen das Ändern der Einstellungen zu erleichtern. Informationen über das Festlegen von Einstellungen finden Sie unter Zuweisen und Ändern von Zeichnungseinstellungen.

So zeichnen Sie eine Gerade:

    1. Klicken Sie auf das Geraden-Werkzeug ( [image] ).

    2. Klicken Sie auf den Start- und Endpunkt der Linie. Sie können auch auf den Startpunkt klicken und die Linie bis zum gewünschten Endpunkt ziehen. Um eine horizontale oder vertikale Linie bzw. eine Linie in einem Winkel von 45 Grad zu zeichnen, klicken oder ziehen Sie, während Sie die Umschalttaste gedrückt halten.

Mit dem Polygonzug-Werkzeug können mehrere miteinander verbundene Linien als ein Objekt gezeichnet werden (siehe Fluchten). Sie können auch zuerst die Linien mit dem Geraden-Werkzeug zeichnen und dann mithilfe der Funktion "Fluchten" sicherstellen, dass sie sich berühren.

So zeichnen Sie einen Polygonzug oder ein Polygon:

    1. Klicken Sie auf das Polygonzug- [image] oder Polygon-Werkzeug [image] .

    2. Klicken Sie nacheinander auf die gewünschten Eckpunkte. Um ein horizontales oder vertikales Segment bzw. ein Segment mit einem Winkel von 45 Grad zu zeichnen, klicken Sie, während Sie die Umschalttaste gedrückt halten.

    3. Doppelklicken Sie auf den letzten Eckpunkt.

Klicken Sie auf die gewünschten Eckpunkte und doppelklicken Sie, um das Polygon zu beenden.

So zeichnen Sie einen Bogen:

    1. Klicken Sie auf das Bogen-Werkzeug [image] .

    2. Klicken Sie auf den Anfangspunkt und ziehen Sie den Bogen, bis er die gewünschte Form und Länge aufweist. Um einen Kreisausschnitt zu zeichnen, ziehen Sie, während Sie die Umschalttaste gedrückt halten.

Ziehen Sie und lassen Sie dann den Mauszeiger los.

Weist der Bogen nicht die gewünschte Form auf (weil er z. B. konkav statt konvex ist), lassen Sie die Maustaste nicht los. Ziehen Sie das Fadenkreuz an den Anfangspunkt zurück und zeichnen den Bogen entlang des beabsichtigten Bogenverlaufs neu.

Anfangs beträgt der Winkel des Bogens 90 Grad. Informationen über das Ändern des Winkels finden Sie unter Umformen von Objekten.

So zeichnen Sie eine Freihandkurve:

    1. Klicken Sie auf das Freihandkurven-Werkzeug [image] .

    2. Klicken Sie auf den Anfangspunkt der Freihandkurve und zeichnen Sie mit gedrückter Maustaste den gewünschten Verlauf. Das Magnetraster ist nur für den ersten Punkt der Freihandkurve wirksam. Sie können das Raster jedoch schon vor dem Zeichnen der Kurve deaktivieren.

Ziehen Sie und lassen Sie dann den Mauszeiger los.

Wenn Sie die Maustaste loslassen, erstellt FrameMaker eine Kurve entlang dem gezeichneten Verlauf und zeigt Umform- und Kontrollpunkte an, mit denen Sie die Form der Kurve ändern können. Weitere Informationen hierzu finden Sie unter Ändern und Umformen von Objekten.

Sie können die Form einer Freihandkurve genauer festlegen, indem Sie die Kurve mithilfe von Polygonzügen und Polygonen erstellen und diese glätten. Informationen über das Glätten finden Sie unter Glätten von Objekten und Aufheben der Glättung.

So zeichnen Sie ein Rechteck, ein abgerundetes Rechteck oder eine Ellipse:

    1. Klicken Sie auf das Rechteck-Werkzeug [image] , das Ellipsen-Werkzeug [image] oder das Werkzeug für abgerundete Rechtecke [image] .

    2. Ziehen Sie diagonal durch den Bereich, in dem Sie das Objekt erstellen möchten. Zum Zeichnen eines Quadrats oder Kreises ziehen Sie mit gedrückter Umschalttaste.

Ziehen Sie und lassen Sie dann den Mauszeiger los.

Um eine Umrandung um eine Grafik zu zeichnen, ziehen Sie ein Rechteck mit dem Füllmuster "Keine" um das Objekt.

So zeichnen Sie ein regelmäßiges Polygon:

    1. Zeichnen Sie einen Kreis oder ein Quadrat, das geringfügig größer ist als das Polygon, das Sie erstellen wollen. Wenn Sie ein Rechteck oder eine Ellipse verwenden, erhalten Sie kein regelmäßiges Polygon.

    2. Markieren Sie das Objekt und wählen Sie "Grafik > Seitenanzahl".

    3. Geben Sie die Anzahl der Seiten und den Anfangswinkel des Polygons ein und klicken Sie auf "Zuweisen".

Originalobjekt und gleichmäßiges Polygon mit 3 Seiten und einem Anfangswinkel von 45°

So zeichnen Sie mehrere Objekte desselben Typs, ohne jedes Mal auf das Werkzeug zu klicken:

Führen Sie eine der folgenden Aktionen aus:

    Klicken Sie bei allen Objekten außer Geraden bei gedrückter Umschalttaste auf das Werkzeug. Wenn Sie das Werkzeug nicht mehr benötigen, klicken Sie auf ein anderes Werkzeug oder auf eines der Auswahlwerkzeuge [image] , [image] .

    Drücken Sie bei Textzeilen am Ende einer Textzeile die Eingabetaste und fahren Sie mit der Eingabe fort. Informationen über das Erstellen von Textzeilen finden Sie unter Grafiken und Text.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Auswählen von Objekten

Wenn Sie ein Objekt bearbeiten oder seine Einstellungen ändern wollen, müssen Sie es zuerst auswählen. Ein ausgewähltes Objekt wird von Auswahlpunkten umgeben.

Auswahlpunkt

Sie können mehrere Objekte auf einmal auswählen oder einer vorhandenen Auswahl weitere Objekte hinzufügen. Alle Objekte müssen sich jedoch auf derselben Seite oder im selben Grafikrahmen befinden. Wenn Sie einen Grafikrahmen auswählen, wird die Auswahl aller markierten Objekte aufgehoben.

Die folgenden Werkzeuge stehen Ihnen zum Auswählen zur Verfügung:

    Mit dem intelligenten Auswahlwerkzeug ( [image] ) können Sie die Einfügemarke platzieren oder Text auswählen, wenn sich der Mauszeiger über Text befindet, oder ein Objekt auswählen, wenn er sich über einem Objekt befindet. Wenn dieses Werkzeug aktiv ist, wird der Mauszeiger über einem Textbereich zu einem Textcursor ( [image] ) oder über einem Objekt zu einem Konturpfeil ( [image] ). Normalerweise verwenden Sie bei Ihrer Arbeit dieses Auswahlwerkzeug.

Mit einem Textcursor können Sie nur Text auswählen. Mit einem Konturpfeil können Sie nur Objekte auswählen.

    Mit dem Objekt-Auswahlwerkzeug [image] werden immer Objekte ausgewählt. Verwenden Sie dieses Werkzeug, wenn Sie Textzeilen und Textrahmen als Objekte behandeln (um beispielsweise die Größe oder Position eines Textrahmens zu ändern). Wenn Sie mit diesem Werkzeug in Text klicken, wird keine Einfügemarke platziert, sondern eine Textzeile oder ein Textrahmen als Objekt ausgewählt.

So aktivieren Sie ein Auswahlwerkzeug:

Klicken Sie in der Werkzeugpalette auf das intelligente Auswahlwerkzeug oder das Objekt-Auswahlwerkzeug.

So bleibt das Auswahlwerkzeug nach dem Zeichnen eines Objekts aktiv:

Halten Sie die Umschalttaste gedrückt und klicken Sie auf das gewünschte Werkzeug. Andernfalls aktiviert FrameMaker nach dem Zeichnen eines Objekts wieder das intelligente Auswahlwerkzeug.

So wählen Sie ein Objekt aus:

Klicken Sie auf das Objekt. Ist das Objekt transparent (Füllmuster "Keine"), klicken Sie auf seine Begrenzungslinie. Wenn Sie auf überlappende Objekte klicken, wählt FrameMaker das Objekt im Vordergrund aus.

So wählen Sie mit dem intelligenten Auswahlwerkzeug eine Textzeile oder einen Textrahmen aus:

    Halten Sie die Strg- bzw. die Control-Taste gedrückt und klicken Sie in die Textzeile oder in den Textrahmen.

So wählen Sie mehrere Objekte im selben Bereich aus:

Positionieren Sie den Mauszeiger außerhalb der Objekte und ziehen Sie diagonal, um einen Auswahlrahmen um die Objekte zu zeichnen. Alle Objekte müssen sich vollständig innerhalb des Auswahlrahmens befinden.

Ziehen Sie, um mehrere Objekte auszuwählen.

Hinweis: Wenn Sie ein Objekt verschieben, anstatt einen Auswahlrahmen zu ziehen (weil sich der Zeiger über einem Objekt befand), wählen Sie sofort "Bearbeiten > Rückgängig". Zeichnen Sie anschließend einen Auswahlrahmen, wie im Folgenden beschrieben.

So veranlassen Sie FrameMaker zum Zeichnen eines Auswahlrahmens:

    Halten Sie die Strg- bzw. Control-Taste und die Umschalttaste gedrückt und ziehen Sie.

So fügen Sie einer Auswahl ein Objekt hinzu:

Halten Sie die Umschalttaste gedrückt und klicken Sie auf das Objekt. Sie können auch bei gedrückter Strg- bzw. Control-Taste auf das Objekt klicken.

So fügen Sie mit dem intelligenten Auswahlwerkzeug einer Auswahl eine Textzeile oder einen Textrahmen hinzu:

    Klicken Sie bei gedrückter Strg- bzw. Control-Taste.

So fügen Sie einer Auswahl mehrere Objekte im selben Bereich hinzu:

Halten Sie die Umschalttaste gedrückt und ziehen Sie einen Auswahlrahmen um die Objekte.

Halten Sie die Umschalttaste gedrückt und ziehen Sie, um einer Auswahl Objekte hinzuzufügen.

Wenn vor dem Ziehen Objekte innerhalb des Auswahlrahmens ausgewählt waren, wird ihre Auswahl aufgehoben.

So wählen Sie alle Objekte in einem Grafikrahmen oder auf einer Seite aus:

Führen Sie eine der folgenden Aktionen aus:

    Um alle Objekte in einem Grafikrahmen auszuwählen, markieren Sie zuerst den Rahmen oder eines der Objekte und wählen Sie anschließend "Bearbeiten > Rahmeninhalt auswählen".

    Um alle Objekte auf einer Seite auszuwählen, klicken Sie außerhalb der Objekte oder des Textes auf die Seite und wählen Sie "Bearbeiten > Seite auswählen".

So heben Sie die Auswahl von Objekten auf:

Führen Sie eine der folgenden Aktionen aus:

    Um die Auswahl eines Objekts aufzuheben, klicken Sie außerhalb des Objekts.

    Um die Auswahl für eines von mehreren ausgewählten Objekten aufzuheben, halten Sie die Umschalttaste gedrückt und klicken Sie auf das Objekt (nicht auf einen Auswahlpunkt). Sie können auch bei gedrückter Strg- bzw. Control-Taste auf das Objekt klicken.

    Um die Auswahl aller markierten Objekte aufzuheben, klicken Sie außerhalb der Objekte auf der Seite.

    Um die Auswahl mehrerer Objekte im selben Bereich aufzuheben, positionieren Sie den Mauszeiger außerhalb der Objekte und ziehen Sie einen Auswahlrahmen um die Objekte, während Sie die Umschalttaste gedrückt halten. Wenn Sie die Maustaste loslassen, wird die Auswahl aller Objekte aufgehoben, die sich vollständig innerhalb des Auswahlrahmens befinden. Enthält der Auswahlrahmen Objekte, die zuvor nicht ausgewählt waren, sind diese nun ausgewählt.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Zuweisen und Ändern von Zeichnungseinstellungen

Zu den Zeichnungseinstellungen eines Objekts gehören Füllmuster, Linienmuster, Linienstärke, Linienenden, Farbe und Linienstil (durchgehend oder gestrichelt). Diese Einstellungen können mithilfe von Aufklappmenüs in der Werkzeugpalette festgelegt werden.

Aufklappmenüs in der Werkzeugpalette

Sie können die Einstellungen vor dem Zeichnen eines Objekts festlegen oder ein bereits erstelltes Objekt auswählen und seine Einstellungen ändern. Nachdem Sie eine Einstellung geändert haben, wird diese zur aktuellen Einstellung, d. h., sie wird für alle danach erstellten Objekte verwendet. Wenn Sie beispielsweise für die Linienstärke den Wert 1 angeben, erhalten alle neu erstellen Objekte diese Einstellung, bis Sie einen anderen Wert festlegen oder FrameMaker beenden.

Sie können Objekten ein identisches Erscheinungsbild geben, indem Sie die Einstellungen eines Objekts einem anderen Objekt zuweisen.

Die in der Werkzeugpalette verfügbaren Auswahlmöglichkeiten können angepasst werden. Informationen über das Ändern von Linienstärke, Linienende oder Linienstil finden Sie unter Ändern von Linieneinstellungen. Informationen über das Ändern der Farben, die Sie im Aufklappmenü wählen können, finden Sie unter Definieren und Ändern von Farben und Aufhellungen. Hinweise zum Ändern von Füll- und Linienmustern auf UNIX-Systemen sind im Online-Handbuch Anpassen von FrameMaker-Produkten auf der Adobe-Website enthalten: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.

So weisen Sie einem ausgewählten Objekt ein Füll- oder Linienmuster zu:

Wählen Sie das gewünschte Muster im Aufklappmenü "Füllmuster" [image] oder "Linienmuster" [image] . Mit Ausnahme von Linien, Textzeilen und Gleichungen können Sie alle Objekte füllen.

A: Linienmuster B: Füllmuster

Die acht grauen Füll- und Linienmuster haben folgende Prozentwerte: 100, 90, 70, 50, 30, 10, 3 und 0 (keine Farbe, normalerweise weiß).

Wenn Sie das Füllmuster "Keine" wählen, wird das Objekt transparent (d. h. die darunterliegenden Objekte sind sichtbar). Soll das Objekt keine Umrisslinie haben, wählen Sie für das Linienmuster den Wert "Keine". Damit Sie ein Objekt sehen können, dessen Linien- und Füllmuster den Wert "Keine" haben, wählen Sie "Darstellung > Begrenzungslinien".

So wählen Sie eine Linienstärke für eine Gerade oder für die Umrisslinien eines Objekts:

Wählen Sie die gewünschte Stärke im Aufklappmenü "Linienstärken" [image] . Mit Ausnahme von Textzeilen können Sie diese Einstellung bei allen Objekten ändern.

So ändern Sie die Enden eines Bogens, einer Geraden, eines Polygonzugs oder einer Freihandkurve:

Wählen Sie das gewünschte Linienende im Aufklappmenü "Linienenden" [image] . Sie können entweder keine Pfeilspitze, eine Pfeilspitze an einem Ende oder Pfeilspitzen an beiden Enden angeben.

So ändern Sie den Linienstil eines Objekts (durchgehend oder gestrichelt):

Wählen Sie im Aufklappmenü "Strichstil" ( [image] ) eine durchgehende oder gestrichelte Linie.

So weisen Sie einem Objekt eine Farbe zu:

    1. Wählen Sie im Aufklappmenü "Farbe" die gewünschte Farbe.

    2. Wenn Sie eine Abstufung der Farbe verwenden wollen, wählen Sie den betreffenden Wert im Aufklappmenü "Aufhellung". Wird der gewünschte Wert im Menü nicht angezeigt, wählen Sie "Andere", geben Sie einen Wert ein und klicken Sie auf "Zuweisen".

Wenn ein Objekt nicht mehr zu sehen ist, nachdem Sie ihm eine Farbe zugewiesen haben, vergewissern Sie sich, dass die Farbe nicht in der Auswahlliste "Unsichtbar" im Dialogfenster "Farbauszüge definieren" des aktuellen Farbauszugs aufgeführt ist (siehe Anzeigen von Farben).

Sie können auch allen Objekten in einem Dokument dieselbe Farbe zuweisen (siehe Zuweisen von Farben und Aufhellungen).

Hinweis: Mit dem Aufklappmenü "Überdrucken" können Sie steuern, ob ein Objekt darunterliegende Objekte überdruckt oder ausspart. Weitere Informationen hierzu finden Sie unter Aussparen und Überdrucken.

So ändern Sie die Textfarbe in einem Textrahmen:

Ändern Sie die Einstellungen im Fenster "Zeichengestaltung" oder "Absatzgestaltung". Weitere Informationen finden Sie unter Verwenden der Gestaltungsfenster zum Ändern von Schrifteinstellungen.

So überprüfen Sie die Zeichnungseinstellungen eines Objekts oder weisen sie anderen Objekten zu:

    1. Wählen Sie das Objekt aus, dessen Einstellungen verwendet werden sollen.

    2. Halten Sie die Umschalttaste gedrückt und wählen Sie "Grafik > Einstellungen übernehmen". Die Einstellungen des Objekts werden dadurch als aktuelle Werte in die Werkzeugleiste übernommen. Jedes Objekt, das Sie zeichnen, verwendet diese Einstellungen.

    3. Wenn Sie die Einstellungen vorhandenen Objekten zuweisen wollen, wählen Sie die betreffenden Objekte aus. Klicken Sie in der Werkzeugpalette auf die aktuellen Zeichnungseinstellungen, die Sie den ausgewählten Objekten zuweisen wollen.

Aktuelle Zeichnungseinstellungen


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Ändern von Linieneinstellungen

Die folgenden Linieneinstellungen können in der Werkzeugpalette geändert werden:

    Die der Linienstärke zugewiesenen Werte, die im Aufklappmenü "Linienstärken" angezeigt werden. (Informationen über das Ändern der Werte, die beim Start von FrameMaker auf UNIX-Systemen angezeigt werden, finden Sie im Online-Handbuch Anpassen von FrameMaker-Produkten auf der Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf).

    Der Abschluss, der das Aussehen von Linienenden ohne Pfeilspitzen bestimmt.

    Das Muster, das FrameMaker verwendet, wenn Sie den gestrichelten Linienstil im Aufklappmenü "Strichstil" wählen. (Das im Menü angezeigte Muster ändert sich nicht, FrameMaker verwendet jedoch das neue Muster.)

Unter Windows wird die neue Linienstärke verwendet, bis sie wieder geändert wird. Die anderen neuen Einstellungen bleiben erhalten, bis Sie sie ändern oder FrameMaker beenden. Auf UNIX-Systemen werden die neuen Einstellungen verwendet, bis Sie FrameMaker beenden.

Keine der hier beschriebenen Änderungen wird automatisch für vorhandene Objekte verwendet. Die Änderungen können jedoch neuen und vorhandenen Objekten zugewiesen werden.

Hinweis: Gestrichelte Linien und Polygonzüge können am Bildschirm und auf dem Ausdruck durchgehend erscheinen, wenn die Linien sehr breit sind, mit spitzen Winkeln versehen sind oder einen überhängenden Abschluss haben. Damit die Linien korrekt gedruckt werden, ändern Sie die Einstellung "Linienende-Optionen" zu "Bündig" und verwenden eine geringere Breite oder zeichnen das Objekt mit separaten Linien noch einmal.

So ändern Sie die Linienstärke:

    1. Wählen Sie "Zuweisen" aus dem Aufklappmenü "Linienstärken" in der Werkzeugleiste.

    2. Führen Sie eine der folgenden Aktionen aus:

    Um die Linienstärke zu ändern, geben Sie die gewünschte Stärke an und klicken Sie auf "Zuweisen". Die Werte können in beliebiger Reihenfolge eingegeben werden. Wenn Sie auf "Zuweisen" klicken, werden die Werte aufsteigend sortiert. Die im Aufklappmenü angezeigten Stärken werden nicht geändert.

    Um die beim Starten von FrameMaker eingestellten Linienstärken wiederherzustellen, klicken Sie auf "Standard".

So ändern Sie den Linienabschluss:

    1. Wählen Sie "Zuweisen" im Aufklappmenü "Linienenden" der Werkzeugpalette.

    2. Wählen Sie einen Abschlussstil und klicken Sie auf "Zuweisen".

A: Bündig B: Rund C: Überhängend

So ändern Sie den Stil für gestrichelte Linien:

    1. Wählen Sie "Zuweisen" im Aufklappmenü "Strichstil" in der Werkzeugleiste.

    2. Klicken Sie auf eines der Muster und wählen Sie "Zuweisen".

Sie können auch eigene Stile für gestrichelte Linien erstellen. Weitere Informationen hierzu finden Sie im online verfügbaren Handbuch Anpassen von FrameMaker-Produkten auf der folgenden Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.

Wenn Sie eine gestrichelte Linie mit runden Punkten erstellen wollen, verwenden Sie einen Stil mit kurzen Strichen und einem runden Linienabschluss.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen / Ändern von Linieneinstellungen

Ändern des Pfeilstils

Sie können zwischen mehreren vordefinierten Pfeilstilen wählen. Pfeilstile werden durch ihren Basis- und Spitzenwinkel und ihre Länge bestimmt.

A: Basiswinkel B: Spitzenwinkel C: Länge

Keine der hier beschriebenen Änderungen wird automatisch für vorhandene Objekte verwendet. Sie können jedoch neuen und vorhandenen Objekten zugewiesen werden.

So ändern Sie den Pfeilstil:

    1. Wählen Sie "Zuweisen" im Aufklappmenü "Linienenden" der Werkzeugpalette.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie einen vordefinierten Stil und klicken Sie auf "Zuweisen".

    Geben Sie Werte für Basiswinkel, Spitzenwinkel, Länge und Stil ein und klicken Sie auf "Zuweisen". Für eigene Stile können folgende Werte verwendet werden:

    Optionen | Werte
Basiswinkel | Zwischen 10 und 175 Grad (und mindestens 5 Grad größer als Spitzenwinkel)
Spitzenwinkel | Zwischen 5 und 85 Grad
Länge | Zwischen 0 und 255 Punkten
Stil | Gefüllt Kontur Offen

FrameMaker ignoriert die Einstellung "Basiswinkel", wenn Sie die Option "Offen" wählen. Die angegebene Länge gilt für Objekte mit einer Linienstärke von 1. Wenn Sie eine größere Linienstärke verwenden, ist die Pfeilspitze länger.

Die folgende Tabelle enthält Beispiele für spezielle Pfeile und ihre Einstellungen.

Pfeil | Basiswinkel | Spitzenwinkel | Länge
 | 70 Grad | 30 Grad | 10 Punkt
 | 80 Grad | 30 Grad | 10 Punkt
 | 70 Grad | 15 Grad | 10 Punkt
 | 70 Grad | 30 Grad | 5 Punkt
 | 120 Grad | 30 Grad | 5 Punkt


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Rahmen

Text und Grafiken werden in rechteckige Rahmen eingefügt. Textrahmen steuern die Platzierung des Textes im Dokument. Grafikrahmen können verankert oder nicht verankert sein und bestimmen die Position und das Aussehen der Grafiken.

Verankerte Rahmen enthalten Grafiken, die mit bestimmten Textstellen in Beziehung stehen und beim Bearbeiten des Texts mit verschoben werden. Weitere Informationen hierzu finden Sie unter Verankerte Rahmen.

Nicht verankerte Rahmen werden verwendet, um Grafiken zu beschneiden, die immer an ihrer Position auf einer Seite bleiben. Sie können auch als Referenzrahmen verwendet werden. Nicht verankerte Rahmen werden mit dem Grafikrahmen-Werkzeug in der Werkzeugpalette erstellt. Weitere Informationen finden Sie in den Abschnitten Beschneiden oder Maskieren von Grafiken und Verwenden von Referenzrahmen auf Referenzseiten.

Hinweis: Grafiken in nicht verankerten Rahmen werden nicht in HTML, Microsoft Word oder RTF exportiert.

Soll die Grafik an einer bestimmten Position auf der Seite platziert werden (z. B. bei einem Logo oder einer Registermarke), zeichnen oder importieren Sie die Grafik direkt auf der Seite. Wenn Sie eine Grafik beschneiden oder in eine Referenzseite aufnehmen müssen, platzieren Sie sie in einem nicht verankerten Grafikrahmen.

A: Grafik, auf Seite gezeichnet B: Textzeile C: Verankerter Rahmen D: Textrahmen für Dokumenttext

Textrahmen können zusammen mit Grafiken (z. B. als Grafiktitel oder Bildbeschriftung) verwendet werden. Sie können auch in verankerten Rahmen verwendet werden, um beispielsweise Effekte wie Randbalken zu erstellen. Einzelne Textzeilen können auch mit dem Textzeilen-Werkzeug erstellt werden. Weitere Informationen finden Sie unter Grafiken und Text.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Grafiken und Text

Sie können einer Grafik einzelne Textzeilen oder einen Textrahmen hinzufügen.

A: Textzeile B: Textrahmen

Eine Textzeile ist eine einzelne Zeile mit Text, die von FrameMaker unabhängig von anderem Text behandelt wird. Textzeilen werden beim Bearbeiten verlängert oder verkürzt, brechen aber nicht in die nächste Zeile um. Sie verwenden Textzeilen normalerweise für einzeilige Bildbeschriftungen und für Text, den Sie wie andere Objekte vergrößern oder verkleinern wollen.

Allen Textzeilen können Zeichenformate und eine Sprache für die Rechtschreibprüfung zugewiesen werden. Sie haben jedoch kein Absatzformat und können keine verankerten Rahmen, Marken, Variablen, Querverweise oder bedingten Text enthalten.

Im Gegensatz zu einer Textzeile kann ein Textrahmen mehrere Zeilen mit Text enthalten. Textrahmen werden für mehrzeilige Bildbeschriftungen, Textabsätze oder anderen Text verwendet, der automatisch von FrameMaker am Ende einer Zeile in die nächste umbrochen werden soll. Wenn eine Grafik den Text in einem Textrahmen überlagert, können Sie den Text um die Grafik fließen lassen.

Wenn Sie die Größe eines erstellten Textrahmens mit dem Textrahmen-Werkzeug [image] ändern, bleibt die Größe der Schrift gleich. Wenn Sie jedoch die Größe einer Textzeile mit dem Textzeilen-Werkzeug [image] ändern, werden Schrifthöhe und -breite proportional angepasst. Weitere Informationen finden Sie unter Ändern der Größe von Objekten.

So fügen Sie einer Grafik eine Textzeile hinzu:

    1. Klicken Sie auf das Textzeilen-Werkzeug [image] . Der Mauszeiger wird zu einem Textcursor mit einem Querstrich [image] , wenn Sie ihn in das Dokumentfenster bewegen. Die kleine horizontale Linie im Zeiger gibt die Grundlinienposition des Textes an.

    2. Klicken Sie im Dokument, um die Einfügemarke zu platzieren, und geben Sie den Text ein. FrameMaker benutzt das zuletzt im Dokument verwendete oder ausgewählte Zeichenformat.

Klicken Sie und geben Sie dann den Text ein.

Die Textzeile wird an ihrem Ausrichtungspunkt (die Stelle, an der Sie geklickt haben) linksbündig ausgerichtet. Informationen über das Ausrichten einer Textzeile finden Sie unter Ändern von Einzügen und Ausrichtung.

    3. Wenn Sie mehrere Textzeilen erstellen wollen, drücken Sie am Zeilenende die Eingabetaste, um eine weitere Zeile einzufügen. Textzeilen können unabhängig voneinander ausgewählt und bei Bedarf verschoben werden.

Um das Zeichenformat des Textes in einer Textzeile zu ändern, verwenden Sie die Schriftbefehle im Menü "Format" oder im Fenster "Zeichengestaltung" (siehe Ändern von Schrifteinstellungen). Wenn Sie die Schrift mehrerer Textzeilen gleichzeitig ändern wollen, wählen Sie die Zeilen als Objekte aus und ändern Sie das Format.

So fügen Sie einen Textrahmen hinzu:

    1. Klicken Sie auf das Textrahmen-Werkzeug [image] .

    2. Positionieren Sie den Mauszeiger an der Stelle, an der Sie den Textrahmen einfügen wollen, und ziehen Sie diagonal.

Ziehen Sie und lassen Sie dann den Mauszeiger los.

    3. Geben Sie die Anzahl der Spalten und den Abstand zwischen ihnen ein und klicken Sie auf "Zuweisen".

    4. Doppelklicken Sie im Textrahmen, um eine Einfügemarke zu platzieren, und geben Sie den gewünschten Text ein.

Doppelklicken Sie und beginnen Sie mit der Eingabe.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Anpassen eines überlaufenden Textrahmens

Wenn der eingegebene Text nicht in den Textrahmen passt, verschwindet die Einfügemarke am unteren Rand des Rahmens und der neue Text wird nicht angezeigt. Der untere Rand des Textrahmens wird als durchgehende Linie dargestellt, wenn die Anzeige von Begrenzungslinien aktiviert ist.

Textrahmen mit Überlauftext

Sie können den Rahmen je nach Inhalt vergrößern oder den Textfluss des Rahmens mit einem anderen Textrahmen verbinden (siehe Abtrennen von Textrahmen). Natürlich können Sie auch die Schriftgröße des Textes verringern.

So vergrößern Sie einen Textrahmen:

    1. Halten Sie die Strg- bzw. Control-Taste gedrückt und klicken Sie auf den Textrahmen.

    2. Ziehen Sie einen Auswahlpunkt, bis der Rahmen die gewünschte Größe erreicht hat.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Erstellen von invertiertem Text

Sie können mit invertiertem Text (heller Text auf dunklem Hintergrund) auch bestimmte Textstellen hervorheben. Der invertierte Text kann sich in einem Textrahmen oder einer Textzeile befinden.

So erstellen Sie einen invertierten Textrahmen:

    1. Legen Sie Füllmuster und Farbe des Textrahmens fest.

    2. Weisen Sie dem Textrahmen das Linienmuster "Keine" zu.

    3. Ändern Sie die Textfarbe im Fenster "Zeichengestaltung" oder "Absatzgestaltung" (siehe Verwenden der Gestaltungsfenster zum Ändern von Schrifteinstellungen).

Legen Sie die Farbe des Textrahmens fest und ändern Sie dann die Textfarbe.

    4. Ändern Sie nötigenfalls im Fenster "Absatzgestaltung" (Ändern von Einzügen und Ausrichtung) Einzug und Ausrichtung des Textes.

Zentriert zwischen linkem und rechtem Einzug

So erstellen Sie eine invertierte Textzeile:

    1. Erstellen Sie ein Objekt als Hintergrund für den Text. Am besten eignet sich ein sehr dunkles Füllmuster.

    2. Fügen Sie außerhalb des Hintergrundobjekts eine Textzeile hinzu und geben Sie den Text ein.

    3. Halten Sie die Strg- bzw. Control-Taste gedrückt und klicken Sie auf die Textzeile.

    4. Verschieben Sie die Textzeile so, dass sie durch das Hintergrundobjekt teilweise verdeckt wird.

Erstellen Sie Objekt und Textzeile und verschieben Sie die Textzeile teilweise auf das Objekt.

    5. Wählen Sie im Aufklappmenü "Farbe" der Werkzeugpalette eine helle Farbe. Der Teil des Textes, der über dem Hintergrundobjekt liegt, erscheint so, als wäre er aus dem Objekt ausgeschnitten.

Wenn der Text nicht vor dem Objekt liegt, wählen Sie "Grafik > Nach vorne". Sollte das Ergebnis immer noch nicht Ihren Vorstellungen entsprechen, vergewissern Sie sich, dass im aktuellen Farbauszug des Dokuments die Farbe der Textzeile als "Aussparen" angezeigt wird. Weitere Informationen finden Sie unter Anzeigen von Farben.

    6. Verschieben Sie die Textzeile so, dass alle Buchstaben aus dem Hintergrundobjekt ausgeschnitten angezeigt werden.

Wählen Sie eine helle Farbe und verschieben Sie die Textzeile vollständig.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Hinzufügen von Titeln zu Grafiken

Sie können einer Grafik eine Textzeile oder einen Textrahmen als Titel hinzufügen. Auch ein Absatz über oder unter einem verankerten Rahmen kann als Titel verwendet werden. Am einfachsten ist es jedoch, für diesen Zweck die Tabellenbefehle zu verwenden.

Einzellige Tabelle mit darunterliegendem Titel

Auch mit mehrzelligen Tabellen können Sie verschiedene Effekte mit Text und Grafiken erzeugen. Beispiel: Das nächste Beispiel ist eine Tabelle, die aus zwei Zellen besteht. Die erste Zelle enthält mehrere automatisch nummerierte Absätze, die zweite Zelle eine Abbildung.

Einzeilige Tabelle mit zwei Zellen

Gehen Sie nach den folgenden Richtlinien vor, um die Absatzformate, die Tabellenformate und die verankerten Rahmen einzurichten, die Sie benötigen, wenn Sie einzellige Tabellen und ihre Titel für Abbildungen und die zugehörigen Beschriftungen verwenden wollen.

So verwenden Sie eine Tabelle für eine Grafik und ihren Titel:

    1. Wählen Sie "Tabelle > Tabelle einfügen" und erstellen Sie eine Tabelle mit einer Zelle, die breit genug für die Grafik ist.

    2. Wählen Sie "Tabelle > Tabellengestaltung" und geben Sie die Position des Titels an (siehe Hinzufügen oder Entfernen von Tabellentiteln).

    3. Geben Sie den Text des Titels ein.

    4. Formatieren Sie den Tabellentitel.

    5. Speichern Sie das Format des Tabellentitels im Absatzformatkatalog (siehe Erstellen neuer Formate).

    6. Deaktivieren Sie im Absatzformat der Zelle den festen Zeilenabstand, damit dieser automatisch an die Größe eines verankerten Rahmens angepasst wird. Weitere Informationen finden Sie unter Ändern von Abständen.

    7. Erstellen Sie in der Zelle einen verankerten Rahmen an der Einfügemarke (siehe Erstellen verankerter Rahmen). Die Größe der Zelle wird gegebenenfalls entsprechend der Rahmenhöhe geändert.

    8. Fügen Sie die Grafik in den verankerten Rahmen ein und ändern Sie die Größe des Rahmens.

    9. Wenn der verankerte Rahmen breiter als die Zelle ist, passen Sie die Spalte entsprechend an. Wählen Sie dazu die Tabellenzelle aus und ziehen Sie einen Auswahlpunkt oder verwenden Sie den Befehl "Tabelle >Spaltenbreite ändern" (siehe Ändern der Spaltengröße).

    10. Speichern Sie das Tabellenformat im Tabellenformatkatalog (siehe Definieren von Tabellenformaten).

    11. Wenn Sie das nächste Mal eine Tabelle für eine Abbildung und ihre Beschriftung benötigen, wählen Sie "Tabelle > Tabelle einfügen" oder kopieren Sie die Tabelle und fügen Sie sie ein.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Text um Grafiken fließen lassen

Sie können den Text in einem Textrahmen um eine Grafik fließen lassen, die den Text überlagert. (Der Text läuft jedoch nicht um Textzeilen oder Gleichungen.) Wird eine Grafik direkt auf einer Seite oder in einem nicht verankerten Rahmen platziert, kann der Text den Konturen der Grafik folgen oder vertikal an einem imaginären Rechteck um die Grafik ausgerichtet werden.

Text kann um eine Kontur und um einen Bildrahmen laufen.

Sie können Text auch um verankerte Rahmen fließen lassen (um beispielsweise eine kleine Grafik oder eine Initiale an den Anfang eines Absatzes zu setzen). Informationen darüber, wie Sie Text um verankerte Rahmen fließen lassen, finden Sie im Abschnitt In einen Absatztext fließende verankerte Rahmen.

Läuft der Text in einem Textrahmen um eine Grafik, führt FrameMaker in diesem Rahmen keinen automatischen Höhenausgleich durch. Weitere Informationen finden Sie unter Höhenausgleich von Text bis zum Ende von Textrahmen.

So legen Sie die Konturlaufeinstellungen für eine Grafik fest:

    1. Zeichnen oder platzieren Sie die Grafik auf einer Seite. Wenn Sie die Grafik auf einer Vorgabeseite einfügen, wird sie in allen zugehörigen Arbeitsseiten als Hintergrundgrafik verwendet. Sie können dann den Text in allen Arbeitsseiten um die Grafik laufen lassen.

Klicken Sie auf den Seitenrand, bevor Sie die Grafik importieren oder einfügen. Andernfalls enthält das Dokument eine Einfügemarke und die Grafik wird in einem verankerten Rahmen platziert.

    2. Wählen Sie die Grafik aus. Besteht die Grafik aus mehreren Objekten, wählen Sie alle Elemente aus.

    3. Soll der Text um die Kontur einer importierten Grafik laufen, vergewissern Sie sich, dass sich die Grafik hinter dem Textrahmen befindet. Wählen Sie dazu die Grafik aus und wählen Sie "Grafik > Nach hinten".

    4. Entsprechen die Konturlaufeinstellungen nicht Ihren Vorstellungen, wählen Sie "Grafik > Konturlaufeinstellungen" und führen Sie einen der folgenden Schritte aus:

    Soll der Text um die Grafik laufen, wählen Sie den gewünschten Umlaufstil und geben einen Abstand ein.

    Soll der Text nicht um die Grafik laufen, wählen Sie "Kein Konturlauf".

Hinweis: Wenn die Einstellung "Stil" beim Öffnen des Dialogfensters "Konturlaufeinstellungen" den Wert "Beibehalten" hat, sind im Dokument mehrere Grafiken mit unterschiedlichen Umlaufeinstellungen ausgewählt.

    5. Klicken Sie auf "Zuweisen".

Wenn die Einstellungen nicht genau zum beabsichtigten Ergebnis führen, fügen Sie ein Objekt (mit dem Linien- und Füllmuster "Keine") neben der Grafik hinzu, um die gewünschte Kontur für den Textlauf zu erstellen.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Bearbeiten und Anordnen von Objekten

Sie können Objekte auf viele Arten bearbeiten und anordnen:

    Sie können sie verschieben, kopieren und löschen.

    Sie können sie verketten, wenn Sie sie zeichnen, und ihre Größe oder ihre Form ändern.

    Sie können sie relativ zueinander anordnen, indem Sie ihre Stapelreihenfolge ändern, sie ausrichten und einen Abstand zwischen ihnen einfügen.

    Sie können einzelne Geraden und Kurven verbinden, um komplexe Umrisse zu erstellen, die Sie anschließend füllen oder mit Farben versehen können.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Ausschneiden, Kopieren, Einfügen und Löschen von Objekten

Mit den Befehlen des Menüs "Bearbeiten" können Objekte mit der Zwischenablage ausgeschnitten, kopiert und eingefügt werden. Wenn Sie "Bearbeiten > Ausschneiden" oder "Bearbeiten > Kopieren" wählen, bleibt das ausgeschnittene oder kopierte Objekt in der Zwischenablage, bis Sie erneut einen dieser Befehle verwenden.

Sie können Objekte auch ohne die Befehle des Menüs "Bearbeiten" rasch duplizieren oder löschen.

So können Sie ein Objekt mit der Zwischenablage ausschneiden, kopieren und einfügen:

    1. Markieren Sie das Objekt und wählen Sie "Bearbeiten > Ausschneiden" oder "Bearbeiten > Kopieren".

    2. Führen Sie eine der folgenden Aktionen aus:

    Um das Objekt auf einer Seite einzufügen, klicken Sie in den Seitenrand.

    Um das Objekt in einen vorhandenen Grafikrahmen einzufügen, wählen Sie den Rahmen durch Klicken auf seine Begrenzungslinie aus.

    Um das Objekt in den Text einzufügen, klicken Sie auf die Stelle, auf die es platziert werden soll.

    3. Wählen Sie "Bearbeiten" > "Einfügen" bzw. "Einsetzen". Wenn Sie das Objekt in einen Grafikrahmen oder eine Seite mit genau derselben Größe wie der des Ausgangsobjekts einfügen, wird es an der gleichen relativen Position platziert. Andernfalls wird das Objekt zentriert.

Wenn Sie ein Objekt in Text einfügen, erstellt FrameMaker automatisch einen verankerten Rahmen und zentriert das Objekt darin. Wenn die Anzeige der Steuerzeichen aktiviert ist, wird an der Einfügemarke ein Ankersymbol ( [image] ) angezeigt.

So kopieren Sie ein Objekt durch Ziehen:

    1. Markieren Sie das Objekt.

    2. Positionieren Sie den Mauszeiger auf dem Objekt (nicht auf einem Auswahlpunkt) und führen Sie eine der folgenden Aktionen aus:

    (Windows) Ziehen Sie die Kopie des Objekts bei gedrückter Alt-Taste oder ziehen Sie das Objekt mit der rechten Maustaste und wählen Sie anschließend im Aufklappmenü die Option "Hierher kopieren". Wenn Sie beim Ziehen zusätzlich die Umschalttaste gedrückt halten, kann die Kopie nur horizontal oder vertikal verschoben werden.

    (UNIX) Halten Sie die Control-Taste gedrückt und ziehen Sie das Objekt mit der mittleren Maustaste. Wenn Sie das Objekt in eine andere Richtung ziehen wollen, lassen Sie sofort nach Erstellen der Kopie die Control- und die Maustaste los. Ziehen Sie die Kopie anschließend in die gewünschte Richtung. Wenn Sie beim Ziehen die Umschalttaste gedrückt halten, wird die Bewegung eingeschränkt.

So löschen Sie ein Objekt:

Wählen Sie das Objekt aus und drücken Sie die Entf-Taste.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Verschieben von Objekten

Sie können ein Objekt einfach durch Ziehen mit der Maus verschieben oder kleinere Positionsänderungen mithilfe der Pfeiltasten durchführen. Die genaue Position eines Objekts können Sie auch in einem Dialogfenster angeben. Um ein Objekt durch Ziehen zu verschieben, müssen Sie seine Begrenzungslinie ziehen (keinen Auswahlpunkt).

So verschieben Sie ein Objekt durch Ziehen:

    1. Markieren Sie das Objekt.

    2. Führen Sie eine der folgenden Aktionen aus:

    Ziehen Sie in die Richtung, in die das Objekt verschoben werden soll.

    Um nur horizontale oder vertikale Bewegungen zuzulassen, ziehen Sie bei gedrückter Umschalttaste.

    Um ein Objekt in einen Grafikrahmen zu verschieben, ziehen Sie das Objekt, bis sich der Mauszeiger im Rahmen befindet.

    Um ein Objekt aus einem Grafikrahmen heraus zu verschieben, ziehen Sie das Objekt, bis sich der Mauszeiger außerhalb des Rahmens befindet. Beim Ziehen kann das Objekt vorübergehend durch die Begrenzungslinien des Rahmens abgeschnitten werden.

Beim Ziehen eines Objekts wird in der Statuszeile der Abstand zwischen der oberen linken Ecke des Objekts und der oberen linken Ecke der Seite angezeigt (oder des Rahmens, wenn sich das Objekt in einem Grafikrahmen befindet). Wenn die Anzeige von Linealen aktiviert ist, wird die Position des Objekts durch Striche dargestellt. Ist das Magnetraster aktiviert, rasten die Objekte dort ein, während Sie ziehen.

Wenn ein verlagertes Objekt am Bildschirm nicht ordnungsgemäß neu gezeichnet wird, drücken Sie Strg+l (kleines L) bzw. Control+l (kleines L), um die Anzeige neu aufzubauen.

So verschieben Sie ein Objekt in kleinen Schritten:

Wählen Sie das Objekt aus und führen Sie eine der folgenden Aktionen aus:

    (Windows) Drücken Sie die Alt-Taste und verschieben Sie das Objekt mithilfe der Pfeiltasten um 1 Punkt oder drücken Sie die Alt- und Umschalttaste und verschieben Sie das Objekt mit den Pfeiltasten um jeweils 6 Punkte. Verwenden Sie jedoch nicht die Pfeiltasten auf dem Ziffernblock.

    (UNIX) Drücken Sie die Control-Taste und verschieben Sie das Objekt mithilfe der Pfeiltasten um 1 Punkt oder drücken Sie die Control- und Umschalttaste und verschieben Sie das Objekt mit den Pfeiltasten um jeweils 6 Punkte.

Die obigen Angaben gelten für eine Zoom-Einstellung von 100 %. Da die tatsächliche Verschiebung von der aktuellen Zoom-Einstellung abhängig ist, können Sie bei einer größeren Zoom-Stufe die Position genauer festlegen. Beispielsweise halbiert sich bei einer Zoom-Einstellung von 200 % die Verschiebung. Bei 50 % verdoppelt sie sich.

So geben Sie die genaue Position eines Objekts an:

    1. Wählen Sie das Objekt aus und wählen Sie anschließend "Grafik > Objekteinstellungen".

    2. Führen Sie eine der folgenden Aktionen aus:

    Geben Sie unter "Abstand von" für alle Objekte mit Ausnahme von Textzeilen und Gleichungen den Abstand vom linken und vom oberen Rand der Seite oder des Grafikrahmens an.

A: Abstand von links B: Abstand von oben

    Bei Textzeilen und Gleichungen geben Sie den Abstand unter "Abstand des Ausrichtungspunkts" ein.

Linksbündige Textzeile
A: Abstand von links B: Abstand von oben

    3. Klicken Sie auf "Zuweisen".


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Ändern der Stapelreihenfolge von Objekten

Wenn Sie ein Objekt zeichnen oder einfügen, platziert FrameMaker das Objekt auf der Seite oder im Grafikrahmen vor allen anderen Objekten. Sie können festlegen, wie sich die Objekte gegenseitig überlappen, indem Sie sie vor oder hinter andere Objekte verschieben.

Kreis im Vordergrund und Kreis im Hintergrund

So ändern Sie die Stapelreihenfolge von Objekten:

Wählen Sie eines der Objekte aus und führen Sie dann eine der folgenden Aktionen aus:

    Um das Objekt in den Vordergrund zu bringen, wählen Sie "Grafik > Nach vorne".

    Um das Objekt im Hintergrund zu platzieren, wählen Sie "Grafik > Nach hinten".

Sie können einen leichten Schatten erzeugen, indem Sie zwei Objekte übereinander legen und dann geringfügig gegeneinander verschieben.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Objekte ausrichten

Alle Objekte mit Ausnahme von Grafikrahmen können auf die folgenden Arten ausgerichtet werden:

    Sie können Objekte an einer horizontalen Geraden ausrichten, indem Sie die Oben/Unten- Ausrichtung angeben.

Unten ausgerichtet und vertikal zentriert

    Sie können Objekte an einer vertikalen Geraden ausrichten, indem Sie die Links/Rechts-Ausrichtung angeben.

Links ausgerichtet und horizontal zentriert

So richten Sie Objekte aus:

    1. Markieren Sie die Objekte, die ausgerichtet werden sollen, und wählen Sie "Grafik > Ausrichten". Um ein einzelnes Objekt in einem Grafikrahmen oder auf einer Seite auszurichten (z. B. an der linken Seite eines Grafikrahmens), wählen Sie nur dieses Objekt aus.

    2. Wählen Sie die gewünschte Ausrichtung und klicken Sie auf "Ausrichten". Sollen die Objekte nur in einer Richtung ausgerichtet werden, setzen Sie die andere Richtung auf "Beibehalten".

FrameMaker richtet die Objekte – entlang ihrer Bezugslinien – an dem Objekt aus, das zuletzt ausgewählt wurde. Durch den Befehl "Oben ausrichten" werden die ausgewählten Objekte am zuletzt ausgewählten Objekt ausgerichtet, welches nicht das oberste im verankerten Rahmen sein muss.

Wurden die Objekte durch Ziehen eines Auswahlrahmens ausgewählt, richtet FrameMaker die Objekte am vordersten Objekt aus.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Ausrichten von Textzeilen

Eine Textzeile wird bei ihrer Erstellung am Ausrichtungspunkt (die Stelle, auf die sie geklickt haben) linksbündig ausgerichtet. Sie können die Ausrichtung später in zentriert oder rechtsbündig ändern. Wenn Sie Text einfügen, behält FrameMaker die Ausrichtung der Textzeile bei.

Eine zentrierte Textzeile bleibt während der Eingabe zentriert.

So ändern Sie die Ausrichtung einer Textzeile:

    1. Wählen Sie die zu ändernde Textzeile aus und wählen Sie "Grafik > Objekteinstellungen".

    2. Wählen Sie im Aufklappmenü "Ausrichtung" die gewünschte Ausrichtung und klicken Sie auf "Zuweisen".


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Verteilen von Objekten

Sie können Objekte so verschieben (verteilen), dass sie einen gleichmäßigen Abstand aufweisen. Die Verschiebung kann horizontal und vertikal erfolgen.

Objekte vor und nach dem Verteilen (Kantenabstand = 0)

Gleicher Abstand der Mittelpunkte und gleicher Abstand der Kanten.

Wenn Sie den genauen Abstand zwischen den Objekten angeben (den Kantenabstand), verschiebt FrameMaker alle Objekte außer dem Objekt, das sich am weitesten links oder oben befindet. Wenn Sie festlegen, dass die Mittelpunkte oder Kanten der Objekte den gleichen Abstand haben sollen, bleiben die linken und rechten (bzw. oberen und unteren) Objekte an ihrer Position und nur die anderen Objekte werden verschoben.

So verteilen Sie Objekte:

    1. Wählen Sie die Objekte aus und klicken Sie auf "Grafik > Verteilen".

    2. Wählen Sie den gewünschten Abstand und klicken Sie auf "Verteilen". Sollen die Objekte nur in eine Richtung verteilt werden, geben Sie für die andere Richtung den Wert "Beibehalten" an.

Wenn Sie einen großen Kantenabstand angeben, werden Objekte möglicherweise über den Seitenrand hinaus verschoben und sind nicht mehr sichtbar. Wählen Sie in diesem Fall sofort "Bearbeiten > Rückgängig".


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Fluchten

Wenn die Option "Fluchten" aktiviert ist, zieht ein Objekt den Mauszeiger an, wenn Sie ein in der Nähe befindliches Objekt erstellen oder dessen Größe bzw. Position ändern. Beim Verschieben von Objekten wirkt sich die Option nicht aus.

Objekte üben entlang ihrer Bezugslinien und an ihren Eckpunkten eine Anziehung aus. Bei Rechtecken und Ellipsen zieht auch der Mittelpunkt den Zeiger an. Bei manchen Punkten eines Objekts ist die Anziehungskraft größer als bei anderen. So ziehen beispielsweise die Ecken eines Dreiecks den Zeiger stärker an als die Seiten.

Die Option "Fluchten" wirkt unabhängig von der Zoom-Einstellung immer über die gleiche Entfernung auf dem Bildschirm. Wenn Sie größer zoomen, werden die Objekte und der Zwischenraum zwischen ihnen größer angezeigt, sodass Sie einen Auswahlpunkt ziehen oder näher an einem Objekt zeichnen können, ohne dass der Mauszeiger angezogen wird.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Verbinden von Objekten

Sie können Objekte einander berühren lassen, indem Sie "Fluchten" aktivieren. Sind die beiden Optionen "Fluchten" und "Magnet" im Menü "Grafik" aktiviert, hat "Fluchten" Vorrang. Informationen über das Magnetraster finden Sie unter Verwenden von Rastern.

So lassen Sie zwei Objekte einander berühren:

    1. Wenn die Option "Fluchten" noch nicht aktiviert ist, wählen Sie "Grafik > Fluchten".

    2. Ziehen Sie einen Auswahlpunkt eines Objekts (oder zeichnen Sie ein Objekt) nahe an dem Objekt, mit dem die Berührung stattfinden soll. Beim Ziehen "springt" der Auswahlpunkt, sodass sich die beiden Objekte berühren.

Fluchten ermöglicht eine perfekte Ausrichtung.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Erstellen eines sauberen Schnittpunkts zwischen Geraden

Je nach ihren Einstellungen und dem Winkel zwischen zwei Geraden erscheint der Schnittpunkt der zwei verbundenen Geraden möglicherweise nicht ganz sauber. Der Schnittpunkt ist beispielsweise sauber, wenn die Geraden dieselbe Stärke haben, sich im rechten Winkel treffen und einen überhängenden Abschluss haben. Wenn die Geraden zwar einen überhängenden Abschluss haben, sich aber nicht rechtwinklig schneiden, ist der Schnittpunkt nicht sauber. Beachten Sie die unterschiedlichen Schnittpunkte bei Verwendung der drei Abschlussstile.

A: Überhängend B: Bündig C: Rund

So erstellen Sie einen sauberen Schnittpunkt zwischen Geraden:

Führen Sie eine der folgenden Aktionen aus:

    Treffen sich die Geraden nicht im rechten Winkel, verwenden Sie einen runden Abschluss für beide Geraden.

    Bei unterschiedlichen Stärken verwenden Sie einen bündigen Abschluss für die dünnere Gerade, wenn die Geraden an ihren Endpunkten oder in T-Form aufeinander treffen.

Informationen über das Ändern des Abschlussstils finden Sie unter Ändern von Linieneinstellungen.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Gruppieren von Objekten und Aufheben der Gruppierung

Wenn mehrere Objekte (außer Grafikrahmen) Teil derselben Grafik sind, können sie gruppiert werden. Sie haben dann die Möglichkeit, die Objekte als ein Objekt zu bearbeiten und auszurichten.

Sie können eine Objektgruppe mit anderen Objekten kombinieren, um eine größere Gruppe zu erstellen. Da FrameMaker hierarchisch gruppiert, bleibt die erste Gruppe erhalten, wenn sie mit anderen Objekten gruppiert wird.

Informationen dazu, wie Sie Objekte zu einem einzigen Objekt verbinden können, finden Sie unter Verbinden von Geraden und Kurven.

So gruppieren Sie Objekte:

Wählen Sie die Objekte aus und klicken Sie auf "Grafik > Gruppieren". Um die gesamte Gruppe werden Auswahlpunkte angezeigt.

Objekte ausgewählt und gruppiert

So heben Sie die Gruppierung von Objekten auf:

Wählen Sie die Gruppe aus und wählen Sie "Grafik > Grupp. aufheben". Um jedes Objekt der Gruppe werden eigene Auswahlpunkte angezeigt. Wenn eine Gruppe mit weiteren Objekten gruppiert wurde, müssen Sie mehrmals "Grupp. aufheben" wählen, um die Gruppierung aller Objekte aufzuheben.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Verbinden von Geraden und Kurven

Durch Verbinden einzelner Geraden, Polygonzüge, Bögen und geglätteter Polygonzüge, die Sie zuvor mit den FrameMaker-Zeichenwerkzeugen gezeichnet haben, können Sie komplexe Umrisse erstellen. Durch das Verbinden erhalten Sie eine einzelne durchgehende Kurve. Sie können die Einstellungen der neuen Kurve (z. B. Linienstärke, Linien- und Füllmuster und Farbe) beliebig ändern.

Objekte gezeichnet, positioniert und ausgewählt

Objekte verbunden und Füllmuster hinzugefügt

So verbinden Sie Geraden und Kurven:

    1. Positionieren Sie die Objekte so, dass sich ihre Endpunkte berühren. Die Enden dürfen nicht weiter als 1 Punkt voneinander entfernt und die Objekte dürfen nicht gruppiert sein. Wählen Sie gegebenenfalls "Grafik > Fluchten" und zoomen Sie größer.

    2. Wählen Sie die Objekte aus und wählen Sie anschließend "Grafik > Verbinden". Die neue Kurve erhält dann die Einstellungen (z. B. Linienstärke, Füllmuster oder Farbe) des Objekts, das vor dem Verbinden als letztes ausgewählt wurde. (In der vorhergehenden Abbildung wurde der Bogen als letztes Objekt ausgewählt).

Hinweis: Wenn Sie Geraden oder Kurven versehentlich verbunden haben, wählen Sie sofort "Bearbeiten > Rückgängig". Durch das Verbinden wird ein einziges durchgehendes Objekt erstellt, das im Gegensatz zu einer Gruppe nicht mehr getrennt werden kann.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Spiegeln von Objekten

Objekte können horizontal oder vertikal gespiegelt werden.

A: Ursprüngliches Objekt B: Vertikal gespiegelt C: Horizontal gespiegelt

So spiegeln Sie ein Objekt:

Wählen Sie das zu ändernde Objekt aus und wählen Sie "Grafik > Horiz. spiegeln" oder "Grafik > Vertik. spiegeln". Im Objekt enthaltener Text wird nicht gespiegelt. So wird beispielsweise der Text in einer gespiegelten Textzeile nicht verkehrt herum angezeigt, obwohl der Ausrichtungspunkt der Textzeile gespiegelt ist.

So erstellen Sie ein symmetrisches Objekt:

    1. Zeichnen Sie eine Hälfte des Objekts und kopieren Sie es.

Zeichnen und kopieren Sie das Objekt.

    2. Spiegeln Sie die Kopie und verschieben Sie sie, bis sie das Original berührt.

Spiegeln Sie das Objekt und verschieben Sie es.

Anstatt die Kopie zum Original zu verschieben, können Sie auch den Befehl "Verteilen" mit einem Kantenabstand von 0 (siehe Verteilen von Objekten) verwenden. Auf diese Weise werden die Objekte genau ausgerichtet.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Drehen von Objekten

Sie können alle Objekte (mit Ausnahme von Gleichungen und Grafikrahmen) in einem beliebigen Winkel drehen. Grafikrahmen und Gleichungen können in Schritten von 90 Grad gedreht werden.

Alle Objekte (außer Gleichungen und Textzeilen) werden um ihren Mittelpunkt gedreht.

Drehen von Objekten

Gleichungen und Textzeilen werden um ihren Ausrichtungspunkt gedreht.

Drehen von Text

Es ist einfacher, Objekte in ihrer nicht gedrehten Position zu bearbeiten (z. B. sie auszurichten oder zu verteilen). Nach der Änderung können Sie das Objekt erneut in seine gedrehte Position bringen.

Hinweis: Wenn Sie eine importierte PICT-Grafik oder eine Seite mit einer importierten PICT-Grafik drehen, wird das Bild in einer schlechten Qualität gedruckt. Konvertieren Sie es daher in das Format TIFF oder EPS und importieren Sie es anschließend erneut.

So drehen Sie ein Objekt durch Ziehen:

    1. Markieren Sie das Objekt.

    2. Führen Sie eine der folgenden Aktionen aus:

    (Windows) Halten Sie die Alt-Taste gedrückt und ziehen Sie einen Auswahlpunkt.

    (UNIX) Halten Sie die Control-Taste gedrückt und ziehen Sie einen Auswahlpunkt mit der mittleren Maustaste.

Bei aktiviertem Magnetraster rastet das Objekt bei einem Vielfachen des im Dialogfenster "Darstellungsoptionen" angegebenen Winkels ein (siehe Verwenden von Rastern). Sie können die Drehung auf Schritte von 45 Grad einschränken, indem Sie zusätzlich die Umschalttaste gedrückt halten.

So führen Sie eine genaue Drehung eines Objekts ausgehend von seiner aktuellen Position durch:

    1. Wählen Sie das Objekt aus und wählen Sie "Grafik > Drehen".

    2. Geben Sie Richtung und Umfang der Drehung an und klicken Sie auf "Drehen". Wenn Sie auf diese Weise mehrere nicht gruppierte Objekte drehen, wird jedes Objekt um seinen Mittelpunkt gedreht.

So führen Sie eine genaue Drehung eines Objekts ausgehend von seiner nicht gedrehten Position durch:

    1. Wählen Sie das Objekt aus und wählen Sie anschließend "Grafik > Objekteinstellungen".

    2. Geben Sie den gewünschten Winkel in das Textfeld "Winkel" ein und klicken Sie auf "Zuweisen".

So machen Sie die Drehung eines Objekts rückgängig oder drehen es erneut:

Führen Sie eine der folgenden Aktionen aus:

    Um die Drehung eines Objekts rückgängig zu machen, drücken Sie Esc g Umschalttaste+d 0 (null).

    Um das Objekt erneut zu drehen (nachdem die Drehung rückgängig gemacht wurde), drücken Sie Esc g Umschalttaste+d 1 (eins).

So setzen Sie den Drehwinkel eines Polygons, Polygonzugs, einer Freihandkurve oder Objektgruppe auf 0 zurück:

Wählen Sie die gedrehten Objekte aus und drücken Sie Esc g Umschalttaste+d 9. Die Drehung der Objekte wird nicht geändert, jedoch werden ihre Auswahlpunkte so positioniert, dass sie sich parallel zum Fensterrahmen befinden.

So drehen Sie eine Gleichung oder einen Grafikrahmen:

    1. Wählen Sie das Objekt aus und wählen Sie "Grafik > Drehen".

    2. Klicken Sie auf den gewünschten Drehwinkel (in Schritten von 90 Grad) und anschließend auf "Drehen". Der Wert wird ausgehend von der nicht gedrehten Position der Gleichung oder des Rahmens angegeben.

So zeigen Sie den Drehwinkel an:

Wählen Sie das Objekt aus und wählen Sie anschließend "Grafik > Objekteinstellungen". Bei Gleichungen und Grafikrahmen können Sie auch "Grafik > Drehen" wählen. Der Drehwinkel wird im Dialogfenster angezeigt.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Ändern und Umformen von Objekten

Bei der Endbearbeitung einer Grafik können Sie auch die Größe und die Form der Objekte ändern. Die Möglichkeiten hierzu sind nahezu unbegrenzt. Sie können beispielsweise einem Polygonzug oder Polygon eine Ecke hinzufügen, eine Ecke verschieben, um die Form des Objekts zu ändern, oder einen Polygonzug glätten, um eine Freihandkurve zu erstellen.

Polygon im ursprünglichen Zustand und mit zusätzlicher Ecke

Ecke verschoben und geglättet


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen / Ändern und Umformen von Objekten

Ändern der Größe von Objekten

Sie können die Größe aller Objekte ändern, einschließlich der von Textzeilen. Wenn Sie die Größe eines mit dem Textrahmen-Werkzeug [image] erstellten Textrahmens ändern, bleibt die Größe der Schrift gleich. Wenn Sie jedoch die Größe einer mit dem Textzeilen-Werkzeug [image] erstellten Textzeile ändern, werden Schrifthöhe und -breite proportional angepasst.

Vor und nach der Größenänderung einer Textzeile (gilt nicht für Textrahmen)

So ändern Sie die Größe eines Objekts durch Ziehen:

Wählen Sie das Objekt aus und führen Sie eine der folgenden Aktionen aus:

    Um die Breite oder Höhe zu ändern, ziehen Sie den Auswahlpunkt an der betreffenden Seite.

    Um die Breite und die Höhe zu ändern, ziehen Sie einen Eckauswahlpunkt.

    Um die Größe proportional zu ändern, ziehen Sie bei gedrückter Umschalttaste einen Eckauswahlpunkt.

Die Größe des Objekts wird während des Ziehens in der Statusleiste angezeigt.

So legen Sie die Größe eines Objekts genau fest:

    1. Markieren Sie das Objekt und wählen Sie "Grafik > Skalieren".

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie Höhe und Breite proportional ändern wollen, geben Sie den gewünschten Skalierungsfaktor ein und klicken Sie auf "Skalieren". Dieser Wert ist immer relativ zur aktuellen Größe des Objekts (100 % bedeutet keine Änderung).

    Wenn Sie die gewünschten Maße genau festlegen wollen, geben Sie die Werte ein und klicken Sie auf "Skalieren". Beim Öffnen des Dialogfensters werden die aktuellen (nicht gedrehten) Maße des Objekts angezeigt.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen / Ändern und Umformen von Objekten

Ändern der Größe von importierten Grafiken

Sie können die Größe importierter Grafiken wieder auf ihren ursprünglichen Wert zurücksetzen.

So ändern Sie die Größe von importierten Grafiken auf 100 %:

    1. Wählen Sie das Objekt aus und wählen Sie anschließend "Grafik > Objekteinstellungen".

    2. Geben Sie in das Feld "Prozent" unter "Skalieren" den Wert 100 % ein und klicken Sie auf "Zuweisen".


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen / Ändern und Umformen von Objekten

Glätten von Objekten und Aufheben der Glättung

Sie können Polygonzüge, Polygone, Rechtecke und abgerundete Rechtecke glätten. Bei Polygonzügen, Polygonen und Rechtecken werden die Ecken dadurch zu Rundungen. Wenn Sie die Glättung einer Kurve aufheben, werden ihre Eckpunkte wiederhergestellt.

Vor und nach dem Glätten

Mit jedem Glätten eines abgerundeten Rechtecks vergrößern Sie die Rundung seiner Ecken (seinen Eckenradius).

So glätten Sie ein Objekt:

Markieren Sie das Objekt und wählen Sie "Grafik > Glätten". Nach dem Glätten eines Polygonzugs oder eines Polygons werden Umform- und Kontrollpunkte angezeigt, mit denen Sie die Form der Kurve ändern können (siehe Umformen von Objekten).

So heben Sie die Glättung eines Objekts auf:

Markieren Sie das betreffende Objekt und wählen Sie "Grafik > Glättg. aufheben". Wenn Sie das Objekt später wieder glätten, kann sich seine Form geringfügig vom Original unterscheiden.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen / Ändern und Umformen von Objekten

Ändern des Eckenradius eines abgerundeten Rechtecks

Sie können die Rundung der Ecken eines abgerundeten Rechtecks definieren, indem Sie den Radius eines imaginären Kreises in der Ecke eines Rechtecks angeben. Je größer der Radius ist, desto runder sind die Ecken.

Radius (r) = 0,125" und Radius (r) = 0,25"

Wenn Sie einen Eckenradius angeben, ändern Sie dadurch auch die aktuellen Zeichnungseinstellungen. Allen neu erstellten abgerundeten Rechtecken wird dieser Radius zugewiesen, bis Sie die Einstellung mit dem Befehl "Objekteinstellungen" ändern oder FrameMaker beenden.

So ändern Sie den Eckenradius eines abgerundeten Rechtecks:

    1. Wählen Sie das abgerundete Rechteck aus und wählen Sie "Grafik > Objekteinstellungen".

    2. Geben Sie den gewünschten Radius ein und klicken Sie auf "Zuweisen". Der größte sinnvolle Radius ist die halbe Länge der kürzesten Seite des Rechtecks. Hat das Rechteck beispielsweise die Größe 4 x 8 cm, ist der größte sinnvolle Radius 2 cm (die Hälfte von 4 cm).


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen / Ändern und Umformen von Objekten

Umformen von Objekten

Geraden, Polygonzüge, Polygone, Kurven und Bögen können folgendermaßen umgeformt werden:

    Sie ändern die Form einer Geraden, eines Polygonzugs oder Polygons, indem Sie jeweils einen der End- oder Eckpunkte verschieben. Sie können auch Eckpunkte hinzufügen oder entfernen.

    Sie ändern die Form einer Kurve mithilfe ihrer Umformpunkte (die die Kurve definieren und ihre Position steuern) und der Kontrollpunkte (die die Rundung anpassen). Sie können auch Umformpunkte hinzufügen oder entfernen, um die Anzahl der Punkte zu ändern, die die Kurve definieren.

A: Umformpunkt B: Kontrollpunkt

    Sie ändern die Form eines Bogens, indem Sie seine Endpunkte ziehen oder den prozentualen Anteil an dem Kreis ändern, dem der Bogen entspricht.

So verschieben Sie eine Ecke eines Polygonzugs oder Polygons:

    1. Markieren Sie das Objekt und wählen Sie "Grafik > Umformen". Anstelle der Auswahlpunkte werden Umformpunkte um das Objekt angezeigt.

    2. Ziehen Sie einen Umformpunkt. Um ihn horizontal oder vertikal zu verschieben, ziehen Sie bei gedrückter Umschalttaste.

Wählen Sie "Umformen" und ziehen Sie anschließend.

So können Sie eine Ecke oder einen Umformpunkt hinzufügen oder entfernen:

    1. Wählen Sie eine Gerade, einen Polygonzug, ein Polygon oder eine Kurve aus und wählen Sie "Grafik > Umformen".

    2. Führen Sie eine der folgenden Aktionen aus:

    (Windows) Halten Sie die Strg-Taste gedrückt und klicken Sie auf die Stelle, an der Sie einen Umformpunkt (oder eine Ecke) hinzufügen wollen, oder klicken Sie bei gedrückter Strg-Taste auf den Punkt, den Sie entfernen wollen.

    (UNIX) Klicken Sie mit der mittleren Maustaste auf die Stelle, an der Sie einen Umformpunkt (oder eine Ecke) hinzufügen wollen, oder klicken Sie mit der mittleren Maustaste auf den Punkt, den Sie entfernen wollen.

So ändern Sie die Form einer Kurve:

    1. Markieren Sie die zu ändernde Kurve und wählen Sie "Grafik > Umformen". An den Stellen, die den Kurvenverlauf definieren, werden Umformpunkte angezeigt. Um einen dieser Umformpunkte werden zusätzlich Kontrollpunkte angezeigt.

    2. Wenn Sie andere Kontrollpunkte benötigen, klicken Sie auf den Umformpunkt, mit dem Sie den Kurvenverlauf ändern wollen. Um diesen Punkt werden dann folgende Kontrollpunkte angezeigt: die zwei Kontrollpunkte, die zu dem ausgewählten Umformpunkt gehören und jeweils ein Kontrollpunkt für den nächsten Umformpunkt auf jeder Seite.

    3. Ziehen Sie einen Umformpunkt, um die Position der Kurve an dieser Stelle zu ändern, oder ziehen bzw. drehen Sie einen Kontrollpunkt, um die Rundung zu ändern. Wenn Sie mit dem Ziehen beginnen, wird am betreffenden Umformpunkt eine Tangente angezeigt. Sie können verschiedene Effekte erzielen, indem Sie die Tangente ziehen oder drehen.

Wählen Sie "Umformen" und ziehen Sie einen Umformpunkt.

Ziehen Sie einen Kontrollpunkt.

Beim Ziehen eines Umformpunkts werden auch die Kontrollpunkte verschoben, wodurch Sie eine runde Kurve erhalten. Wenn Sie einen Kontrollpunkt ziehen, ändert sich die Rundung auf beiden Seiten des Umformpunkts, sodass auch hier eine runde Kurve entsteht.

So krümmen Sie eine Kurve:

    1. Markieren Sie die zu ändernde Kurve und wählen Sie "Grafik > Umformen".

    2. Wenn Sie andere Kontrollpunkte benötigen, klicken Sie auf den Umformpunkt, mit dem Sie den Kurvenverlauf ändern wollen.

    3. Führen Sie eine der folgenden Aktionen aus:

    (Windows) Ziehen Sie den Umform- oder Kontrollpunkt mit der rechten Maustaste.

    (UNIX) Ziehen Sie den Umform- oder Kontrollpunkt bei gedrückter Control-Taste.

Kurve krümmen

So ändern Sie die Form eines Bogens durch Ziehen:

    1. Wählen Sie den zu ändernden Bogen aus und wählen Sie "Grafik > Umformen". Anstelle der Auswahlpunkte werden Umformpunkte um das Objekt angezeigt.

    2. Ziehen Sie einen Umformpunkt. Während des Ziehens werden Anfangs- und Endwinkel sowie der prozentuale Anteil an dem Kreis, dem der Bogen entspricht, in der Statuszeile angezeigt.

Ziehen Sie, um die Form des Bogens zu ändern.

So legen Sie die Form eines Bogens genau fest:

    1. Wählen Sie den Bogen aus und wählen Sie "Grafik > Objekteinstellungen".

    2. Geben die gewünschten Werte in die Textfelder "Anfangswinkel" und "Endwinkel" ein und klicken Sie auf "Zuweisen".


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Beschneiden oder Maskieren von Grafiken

Wenn Sie den Rand einer Grafik beschneiden wollen, platzieren Sie sie in einem verankerten oder nicht verankerten Grafikrahmen. Ein verankerter Grafikrahmen wird mit dem umgebenden Text verschoben. Ein nicht verankerter Rahmen bleibt an seiner Position auf der Seite, auch wenn der umgebende Text durch Bearbeitungen verschoben wird.

Nicht beschnittene und beschnittene Grafiken in Grafikrahmen

Wenn Sie einen Bereich in einer Grafik maskieren wollen (insbesondere in der Mitte der Grafik), verwenden Sie dazu Objekte ohne Begrenzungslinien.

So beschneiden Sie den Rand einer Grafik:

    1. Führen Sie zum Erstellen eines Grafikrahmens einen der folgenden Schritte aus:

    Um einen nicht verankerten Rahmen zu erstellen, klicken Sie auf das Grafikrahmen-Werkzeug [image] in der Werkzeugpalette und ziehen Sie einen Rahmen. Durch Ziehen bei gedrückter Umschalttaste können Sie einen quadratischen Rahmen zeichnen.

    Um einen verankerten Rahmen zu erstellen, wählen Sie "Spezial > Verankerter Rahmen" (siehe Erstellen verankerter Rahmen).

    2. Führen Sie eine der folgenden Aktionen aus, um die Grafik im Rahmen zu platzieren:

    Ziehen Sie die Grafik in den Rahmen.

    Markieren Sie zuerst die gewünschte Grafik, wählen Sie "Bearbeiten > Kopieren" oder "Bearbeiten > Ausschneiden", wählen Sie die Begrenzungslinie des Rahmens aus und fügen Sie die Grafik mit "Bearbeiten > Einfügen" ein.

    3. Ändern Sie die Größe des Rahmens um die Grafik.

So maskieren Sie einen Bereich innerhalb einer Grafik:

Platzieren Sie Grafikobjekte (z. B. Rechtecke oder Polygone) mit einem weißen Füll- und Linienmuster vor den Bereichen, die Sie maskieren wollen.


Grafiken und verankerte Rahmen / Arbeiten mit den Zeichenwerkzeugen

Messen von Objekten

Beim Ändern der Position und der Größe von Objekten in einer Grafik benötigen Sie oft die genauen Maße und die genaue Position der Objekte.

Die Größe eines Objekts entspricht der Größe des Rechtecks um seine Bezugslinie. Seine Position ist der Abstand vom oberen und linken Rand der Seite bzw. des Grafikrahmens.

Objektgröße und Objektposition

So messen Sie ein Objekt:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie das Objekt aus und wählen Sie anschließend "Grafik > Objekteinstellungen". Breite und Höhe des Objekts werden unter "Größe" im Dialogfenster "Objekteinstellungen" angezeigt.

    Deaktivieren Sie die Option "Magnet", wählen Sie das Objekt aus, positionieren Sie den Mauszeiger auf einem seiner Auswahlpunkte und halten Sie die Maustaste gedrückt. Die Maße des Objekts werden in der Statuszeile angezeigt. Falls Sie versehentlich die Maus bewegen und die Größe des Objekts ändern, wählen Sie sofort "Bearbeiten > Rückgängig".

So zeigen Sie die Position eines Objekts an:

    1. Markieren Sie das Objekt.

    2. Wählen Sie "Grafik > Objekteinstellungen". Bei allen Objekten mit Ausnahme von Gleichungen und Textzeilen wird der Abstand zwischen der oberen linken Ecke der Seite oder des Grafikrahmens und dem am weitesten oben und links befindlichen Punkt des Objekts unter "Abstand von:" angezeigt. Bei Gleichungen und Textzeilen wird der Abstand zwischen der oberen linken Ecke der Seite bzw. des Grafikrahmens und dem Ausrichtungspunkt auf der Grundlinie der Gleichung oder der Textzeile unter "Abstand des Ausrichtungspunkts" angezeigt.

So zeigen Sie die Position eines Objekts an, während Sie es verschieben:

Beachten Sie die Statuszeile. Hier wird der Abstand zwischen dem Objekt und der oberen linken Ecke der Seite oder des Grafikrahmens angezeigt. Wenn die Anzeige der Lineale aktiviert ist, erkennen Sie die Position des Objekts auch an den Markierungslinien in den Linealen.

So messen Sie einen beliebigen Abstand auf der Seite:

    1. Positionieren Sie den Mauszeiger an der Stelle, an der die Messung beginnen soll.

    2. Ziehen Sie bei gedrückter Umschalt- und Strg- bzw. Control-Taste um die Anzeige eines Auswahlrahmens zu erzwingen. Lassen Sie die Maustaste jedoch nicht los.

    3. Wenn der Auswahlrahmen den zu messenden Bereich umgibt, können Sie die Maße in der Statuszeile ablesen.

Die Maße werden in der Statuszeile angezeigt.

Im diesem Beispiel ist das wichtige Maß die Höhe (35 Punkt zwischen den Grundlinien der Dreiecke).


Grafiken und verankerte Rahmen

Grafikelemente in strukturierten Dokumenten

Beim Arbeiten mit strukturierten Dokumenten verwenden Sie zum Platzieren von Grafiken spezielle Elemente. Grafikelemente verfügen über einen verankerten Rahmen, der Grafikobjekte umgibt. Der Rahmen wird an einer bestimmten Stelle im Text verankert. Während Sie den Text bearbeiten, verschiebt sich der Rahmen und sein Inhalt gemeinsam mit dem Text im Dokument. Das Element wird in der Struktur des Dokuments angezeigt, die Grafik oder die Gleichung selbst ist jedoch nicht Teil der Struktur.

Informationen über verankerte Rahmen finden Sie unter Erstellen verankerter Rahmen. Informationen über das Importieren von Grafikelementen in strukturierte Dokumente finden Sie unter Verwenden von strukturierten Dokumenten in FrameMaker.


Grafiken und verankerte Rahmen / Grafikelemente in strukturierten Dokumenten

Typen von Grafikelementen in strukturierten Dokumenten

Ein neues Grafikelement kann entweder ein leerer verankerter Rahmen sein oder ein verankerter Rahmen mit einer importierten Grafik. Wenn Sie das Element einfügen, wird durch seine Formateinstellungen festgelegt, ob ein Dialogfenster zum Einfügen eines Rahmens oder zum Importieren einer Grafikdatei angezeigt wird.

    Bei einem Element, das aus einem leeren, verankerten Rahmen besteht, geben Sie die Größe des Rahmens, seine Verankerungsposition und einige Formatierungseigenschaften an, wie z. B. die Ausrichtung. Den Rahmen können Sie durch Ziehen, Einfügen oder Importieren von Grafikobjekten füllen.

    Geben Sie für Rahmen mit importierten Grafiken die zu importierende Datei an. Die Grafik wird unterhalb der Linie mit dem Ankersymbol in einem Rahmen angezeigt, dessen Größe genau an die Grafik angepasst ist.

Nachdem Sie ein Grafikelement eingefügt haben, können Sie den Rahmen mit anderen Inhalten füllen, seine Größe und Verankerungsposition ändern und den Rahmen auf andere Weise bearbeiten. Diese Änderungen werden nicht als irreguläre Formatzuweisungen betrachtet.


Grafiken und verankerte Rahmen

Verankerte Rahmen

Oft ist es erforderlich, eine Abbildung und einen bestimmten Dokumenttext zusammenzuhalten. In FrameMaker platzieren Sie hierzu die Abbildung in einen Grafikrahmen, der mit dem Text verankert ist (verankerter Rahmen). Während Sie den Text bearbeiten, verschiebt sich der Rahmen und sein Inhalt gemeinsam mit dem Text im Dokument.

Sie können einen verankerten Rahmen für eine Abbildung in einer Textspalte verwenden (unterhalb der Zeile mit dem Ankersymbol ( [image] ) oder am Anfang bzw. Ende der Spalte). Sie können mithilfe eines verankerten Rahmens auch kleine Grafiken in eine Textzeile einfügen oder Zeichnungen zwischen Spalten und am Seitenrand platzieren.

Darüber hinaus können Sie mit einem verankerten Rahmen Spezialeffekte erzielen, z. B. indem Sie einen verankerten Rahmen in der oberen Ecke eines Absatzes platzieren, wobei der Absatztext in der Spalte um die Grafik fließt.

A: Grafik in der oberen Ecke eines Absatzes
B: Abbildung in einer Textspalte C: Grafik am Seitenrand
D: Kleine Grafik in einer Textzeile

Soll eine Abbildung an einer bestimmten Position auf der Seite bleiben (z. B. als Logo eines Briefkopfes), verwenden Sie keinen verankerten Rahmen. Zeichnen, importieren oder fügen Sie die Abbildung stattdessen direkt in eine Arbeits- oder Vorgabeseite ein, ohne die Einfügemarke in den Text zu setzen. Verschieben Sie die Abbildung anschließend an die gewünschte Position. Informationen über die direkte Bearbeitung von Vorgabeseiten finden Sie unter Anzeigen von Vorgabeseiten.

Ein verankerter Rahmen hat standardmäßig kein Linien- oder Füllmuster und ist daher nicht zu sehen (es sein denn, die Anzeige der Begrenzungslinien ist aktiviert).


Grafiken und verankerte Rahmen

Erstellen verankerter Rahmen

Ein verankerter Rahmen wird automatisch erstellt, wenn Sie eine Grafik an einer Einfügemarke einfügen oder importieren. Die Eigenschaften eines Rahmens können beibehalten oder geändert werden.

Wenn Sie mit dem Befehl "Spezial > Verankerter Rahmen" einen verankerten Rahmen erstellen, geben Sie seine Größe und Position an. Abhängig von der Position des Rahmens können Sie weitere Einstellungen festlegen. Wird der Rahmen beispielsweise an der Einfügemarke in eine Textzeile eingefügt, können Sie seinen Abstand von der Grundlinie des Textes festlegen. Platzieren Sie den Rahmen in einer Textspalte, können Sie seine Ausrichtung bestimmen. Alle Einstellungen, einschließlich der Rahmenposition, können zu jedem beliebigen Zeitpunkt geändert werden.

Beim Erstellen eines verankerten Rahmens können Sie dem Rahmen mithilfe der Objekteinstellungen eindeutige Typen zuweisen. Diese Typen dienen der Erstellung einer Struktur für das Layout Ihres Dokuments. Sie ermöglichen die eindeutige Definition eines Elements für Ihren Rahmen, das bestimmten Typen in Ihrem PDF-Format zugewiesen wird.

Bei der Typenerstellung für Ihr Dokument weisen Sie jeder Dokumenteinstellung einen Namen zu. Dadurch können Sie die Gestaltung eines Dokuments ganz einfach ändern, ohne Veränderungen am Inhalt vorzunehmen.

Weitere Informationen finden Sie unter Bearbeiten verankerter Rahmen.

So erstellen Sie einen verankerten Rahmen automatisch:

Führen Sie eine der folgenden Aktionen aus:

    Fügen Sie ein Objekt an der Einfügemarke in den Text ein, indem Sie es zuerst ausschneiden oder kopieren, dann auf die Textstelle klicken, an der das Ankersymbol eingefügt werden soll und "Bearbeiten > Einfügen" wählen.

    Importieren Sie eine Grafik, indem Sie auf die gewünschte Position im Text klicken, "Datei > Importieren > Datei" wählen und die betreffende Grafikdatei auswählen. Je nach verwendetem System können Sie eine Grafik auch auf andere Weise importieren (siehe Wählen der geeigneten Methode für das Importieren und Verknüpfen).

Das eingefügte oder importierte Objekt wird in einem verankerten Rahmen platziert, der unterhalb der aktuellen Zeile zentriert angezeigt wird. Nachdem der Rahmen erstellt ist, können Sie seine Einstellungen ändern. Weitere Informationen finden Sie unter Bearbeiten verankerter Rahmen.

So erstellen Sie einen verankerten Rahmen mit bestimmten Optionen:

    1. Klicken Sie im Text auf die Stelle, an der das Ankersymbol eingefügt werden soll, und wählen Sie "Spezial > Verankerter Rahmen". Verankerte Rahmen können in Textrahmen oder Tabellenzellen, aber nicht in Textzeilen erstellt werden.

    2. Wählen Sie die Verankerungsposition des Rahmens und nehmen Sie die gewünschten Einstellungen vor. Die im Dialogfenster "Verankerter Rahmen" angezeigten Einstellungen sind von dieser Position abhängig.

    3. Klicken Sie auf "Neuer Rahmen". Wenn die Anzeige der Steuerzeichen aktiviert ist, wird an der Einfügemarke ein Ankersymbol ( [image] ) angezeigt.

So erstellen Sie einen Typ für Ihren verankerten Rahmen:

    1. Wählen Sie den verankerten Rahmen aus und wählen Sie dann "Grafik > Objekteinstellungen".

    2. Geben Sie für "Typ" den gewünschten Namen ein und klicken Sie auf "Zuweisen".


Grafiken und verankerte Rahmen / Erstellen verankerter Rahmen

Verankerte Rahmen in einer Textzeile

Soll ein verankerter Rahmen zusammen mit Absatztext in einer Zeile platziert werden (z. B. für eine kleine Grafik wie ein Tastensymbol), wählen Sie im Dialogfenster "Verankerter Rahmen" als Verankerungsposition "An der Einfügemarke". Wenn Sie vor und hinter dem Rahmen ein Leerzeichen einfügen, wird dieser beim Bearbeiten des Dokuments wie ein Wort in eine andere Zeile verschoben und ist nicht mit dem vorhergehenden oder nachfolgenden Wort verbunden.

Sie können die Position des Rahmens relativ zur Grundlinie nach oben oder unten anpassen, indem Sie ihn mit der Maus ziehen oder für die Option "Abstand über Grundlinie" im Dialogfenster "Verankerter Rahmen" einen Wert angeben. Bei einem Wert von null wird die Unterseite des Rahmens an der Textgrundlinie ausgerichtet. Eine positive Zahl verschiebt den Rahmen nach oben, eine negative Zahl verschiebt ihn nach unten.

Kein Abstand (null) und negativer Abstand

Wenn durch den Rahmen Text in der darüber- oder darunterliegenden Zeile verdeckt wird, deaktivieren Sie den festen Zeilenabstand, damit sich die Zeilenhöhe dem Zeileninhalt anpassen kann (siehe Ändern von Abständen).

Mit und ohne festen Zeilenabstand

Um einen verankerten Rahmen auf die Abmessungen seines Inhalts zu verkleinern und ihn in der Zeile mit dem Ankersymbol zu platzieren, wählen Sie den Rahmen oder ein Objekt innerhalb des Rahmens aus und drücken Sie die Tastenkombination Esc m p. Um einen Rahmen zu vergrößern und unter der Zeile zu platzieren, die das Ankersymbol enthält, wählen Sie den Rahmen oder ein Objekt innerhalb des Rahmens aus und drücken Sie die Tastenkombination Esc m e.


Grafiken und verankerte Rahmen / Erstellen verankerter Rahmen

Verankerte Rahmen in einer Textspalte

Um einen verankerten Rahmen in einer Textspalte zu platzieren, wählen Sie eine der Verankerungspositionen "Unter aktueller Zeile", "Am Anfang der Spalte" oder "Am Ende der Spalte" im Dialogfenster "Verankerter Rahmen".

"Unter aktueller Zeile" und "Am Anfang der Spalte"

Ein verankerter Rahmen am Anfang oder Ende einer Spalte wird nur verschoben, wenn sein Ankersymbol in eine andere Spalte verschoben wird.

Wichtig: Soll ein verankerter Rahmen unterhalb einer Zeile mit einer Zwischenüberschrift platziert werden, fügen Sie das Ankersymbol in den Textabsatz ein und nicht in die Zwischenüberschrift. Ansonsten verdeckt der verankerte Rahmen den Text unter der Zwischenüberschrift.

Wenn Sie die Verankerungsposition "Unter aktueller Zeile", "Am Anfang der Spalte" oder "Am Ende der Spalte" wählen, können Sie folgende Einstellungen vornehmen:

Horizontale Ausrichtung

Wählen Sie die horizontale Ausrichtung des Rahmens aus dem Aufklappmenü "Ausrichtung". Sie können den Rahmen links, zentriert oder rechts ausrichten. In einem doppelseitigen Dokument können Sie den Rahmen auch näher an der Bindekante platzieren oder weiter davon entfernt.

Weiter von der Bindekante entfernt

Beschneiden

Mit der Option "Beschnitten" können Sie verhindern, dass sich ein breiter Rahmen über den Rand einer Spalte hinaus erstreckt.

Mit und ohne Option "Beschnitten"

Weitere Informationen über die Verwendung der Einstellung "Beschnitten" in einem mehrspaltigen Layout finden Sie unter Verankerte Rahmen in mehrspaltigen Layouts.

Gleitend

Verwenden Sie die Option "Gleitend", damit der Rahmen in die nächste Spalte fließen kann, wenn der Rahmen und sein Ankersymbol nicht in dieselbe Spalte passen.

Mit und ohne Option "Gleitend"

Wenn "Gleitend" deaktiviert ist, werden Rahmen und Ankersymbol gemeinsam in die erste Spalte verschoben, in der genügend Platz ist. Das Spaltenende bleibt leer. Wenn die Option "Gleitend" aktiviert ist, verschiebt sich das Ankersymbol nicht, aber der Rahmen fließt in die nächste Spalte, die ihn aufnehmen kann. Der Bereich zwischen Ankersymbol und Rahmen wird durch Text aus der nächsten Spalte ausgefüllt.


Grafiken und verankerte Rahmen / Erstellen verankerter Rahmen

Verankerte Rahmen in mehrspaltigen Layouts

Ein verankerter Rahmen in einem mehrspaltigen Textrahmen kann mehrere Spalten verbinden und seine Position kann sich durch verbundene Absätze ändern.

In einem verbundenen Absatz

Wenn ein Rahmen in einem verbundenen Absatz verankert wird, verbindet der Rahmen die Spalten auf die gleiche Weise wie der Absatz.

Breiter als eine Spalte

Ein unbeschnittener verankerter Rahmen, der in eine zweite Spalte des Textbereichs reicht, verbindet Spalten im Haupttextbereich. Ein Rahmen, der in den Bereich für die seitlichen Überschriften reicht, verbindet diesen Bereich ebenfalls.

Links reicht der Rahmen über alle Spalten und den Bereich der seitlichen Überschrift und rechts nur über die Spalten

Ein beschnittener verankerter Rahmen verbindet Spalten nur, wenn er in einem verbundenen Absatz verankert ist.

Am Spaltenanfang oder -ende

Wenn das Ankersymbol für einen am Spaltenanfang verankerten Rahmen unter einem verbundenen Absatz erscheint, wird der Rahmen in der Spalte direkt unter dem verbundenen Absatz anstatt am Spaltenanfang angezeigt.

Am Spaltenanfang und -ende verankert

Ein am Spaltenende verankerter Rahmen wird ähnlich positioniert, wenn sich das Ankersymbol über einem verbundenen Absatz befindet.

Sie können erzwingen, dass der verankerte Rahmen am Spaltenanfang oder -ende erscheint (ober- oder unterhalb eines verbundenen Absatzes), indem Sie den Rahmen über die Spalten reichen lassen. Deaktivieren Sie dazu die Option "Beschnitten" im Dialogfenster "Verankerter Rahmen" und vergrößern Sie den verankerten Rahmen, bis er in die nächste Spalte reicht.


Grafiken und verankerte Rahmen / Erstellen verankerter Rahmen

Verankerte Rahmen außerhalb einer Textspalte

Mit der Option "Außerhalb der Spalte" im Dialogfenster "Verankerter Rahmen" können Sie einen verankerten Rahmen auch außerhalb einer Textspalte platzieren. Weitere Informationen über die Positionierung verankerter Rahmen finden Sie unter Verankerte Rahmen im Seitenrand.

Wenn Sie die Verankerungsposition "Außerhalb der Spalte" wählen, können Sie folgende Einstellungen vornehmen:

Seite der Spalte

Sie können den verankerten Rahmen an der linken bzw. rechten Seite der Spalte oder an der Seite positionieren, die näher oder weiter entfernt vom Seitenrand ist.

An der linken und rechten Seite verankert

In einem doppelseitigen Dokument können Sie den Rahmen auch näher an der Bindekante platzieren oder weiter entfernt davon.

Weiter von der Bindekante entfernt

Abstand über Grundlinie

Sie können die Position des Rahmens relativ zur Textgrundlinie nach oben oder unten anpassen. Ziehen Sie den Rahmen dazu mit der Maus oder geben Sie den gewünschten Wert bei der Option "Abstand über Grundlinie" im Dialogfenster "Verankerter Rahmen" an. Bei einem Wert von null wird die Unterseite des Rahmens an der Textgrundlinie ausgerichtet. Eine positive Zahl verschiebt den Rahmen nach oben, eine negative Zahl verschiebt ihn nach unten.

Kein Abstand und negativer Abstand zur Grundlinie

Sie können den verankerten Rahmen nicht über dem Anfang bzw. unter dem Ende des Textrahmens platzieren. Wenn der verankerte Rahmen auf Grund der Einstellung über oder unter dem Rahmenrand platziert werden würde, positioniert FrameMaker ihn so nahe am Rand wie möglich. Entfernt sich das Ankersymbol durch Bearbeiten des Textes vom oberen oder unteren Rand des Textrahmens, passt FrameMaker die Position des verankerten Rahmens entsprechend an.

Abstand zu Spalte

Sie können die Position des Rahmens relativ zum Spaltenrand nach links oder rechts verschieben. Ziehen Sie den Rahmen dazu mit der Maus oder geben Sie unter "Abstand zu Spalte" im Dialogfenster "Verankerter Rahmen" den gewünschten Wert an. Bei einem Wert von null wird der Rahmen am Spaltenrand ausgerichtet. Eine positive Zahl verschiebt den Rahmen von der Spalte fort, eine negative Zahl verschiebt ihn in die Spalte.

Kein Abstand und positiver Abstand von der Spalte

Der Abstand ist immer relativ zum Rand der Spalte, damit der Rahmen auf einer mehrspaltigen Seite zwischen den Spalten erscheinen kann. Informationen, wie Sie den Abstand zwischen den Spalten vergrößern können, finden Sie in den Abschnitten Ändern der Seitenränder und der Spaltenanzahl und Ändern der Ränder und des Spaltenlayouts auf bestimmten Seiten. Fragen Sie Ihren Entwickler, wie der Abstand zwischen den Spalten erweitert werden kann, um Platz für den Rahmen zu schaffen, wenn Sie in einem strukturierten Dokument arbeiten.


Grafiken und verankerte Rahmen / Erstellen verankerter Rahmen

Verankerte Rahmen im Seitenrand

Mit der Verankerungsposition "Außerhalb des Textrahmens" im Dialogfenster "Verankerter Rahmen" kann ein verankerter Rahmen so positioniert werden, dass er immer (auch in einem mehrspaltigen Layout) im Randbereich angezeigt wird. Dann können Sie die im vorigen Abschnitt beschriebenen Optionen festlegen. Die Abstandsangaben beziehen sich jedoch auf den Rand des Textrahmens und können sich von den Entfernungen relativ zum Spaltenrand in mehrspaltigen Seiten unterscheiden.

Näher am Blattrand und weiter weg vom Blattrand

In einem einspaltigen Layout hat die Option "Außerhalb des Textrahmens" denselben Effekt wie die Option "Außerhalb der Spalte".


Grafiken und verankerte Rahmen / Erstellen verankerter Rahmen

In einen Absatztext fließende verankerte Rahmen

Soll ein verankerter Rahmen in der oberen Ecke eines Absatzes platziert werden (wobei der Text um den Rahmen fließt), wählen Sie die Verankerungsposition "Im Absatz" im Dialogfenster "Verankerter Rahmen". Sie können auf diese Weise eine kleine Grafik oder Initiale am Anfang eines Absatzes platzieren.

Wenn der verankerte Rahmen höher als der Absatz ist, fließt der Text aus den nachfolgenden Absätzen um den Rahmen, es sei denn, der Absatz mit dem Ankersymbol ist ein verbundener Absatz.

Der Rahmen erstreckt sich über die Absätze

Wenn Sie die Verankerungsposition "Im Absatz" wählen, können Sie folgende Einstellungen vornehmen:

Ausrichtung

Sie können den verankerten Rahmen an der linken oder rechten Seite des Absatzes ausrichten. In einem doppelseitigen Dokument können Sie auch die Optionen "Seite, näher zu Bindekante" oder "Seite, weiter weg von Bindekante" wählen.

Näher zu Bindekante

Der Rahmen wird am linken Einzug des Absatzes ausgerichtet, wenn er an der linken Seite des Absatzes erscheint, und am rechten Einzug, wenn er an der rechten Seite erscheint. Ist die erste Zeile des Absatzes eingerückt, ändert der Rahmen an der Position des Einzugs nichts.

Grafik reicht über den Einzug der ersten Zeile

Größerer Einzug der ersten Zeile

Wenn der Einzug der ersten Zeile erhalten bleiben soll, geben Sie für ihn einen Wert an, der größer als die Breite des Rahmens ist (siehe Ändern von Einzügen und Ausrichtung). Wenn Sie mit einem strukturierten Dokument arbeiten, bitten Sie Ihren Entwickler, den Wert für den Einzug der ersten Zeile des Absatzes größer als die Rahmenbreite einzustellen.

Abstand

Sie können den Abstand zwischen dem verankerten Rahmen und dem Absatztext, der ihn umfließt, festlegen.


Grafiken und verankerte Rahmen / Erstellen verankerter Rahmen

Füllen verankerter Rahmen

Sie können in einem verankerten Rahmen Grafiken zeichnen, Grafiken aus anderen Teilen des Dokuments ziehen bzw. einfügen oder aus einer anderen Anwendung importieren bzw. einfügen. Auf diese Weise können Sie Grafiken und Text in nicht verankerten Grafikrahmen und in verankerten Rahmen platzieren.

Sie können eine Grafik in einem verankerten Rahmen positionieren und dann einen Textrahmen oder eine Textzeile innerhalb des verankerten Rahmens als Abbildungstitel ablegen. Der Titel kann jedoch bedeutend einfacher konsistent positioniert und nummeriert werden, wenn Sie die Grafik in eine einzellige Tabelle einfügen und diese als Abbildungstitel definieren. Weitere Informationen hierzu finden Sie unter Hinzufügen von Titeln zu Grafiken.

Der Inhalt eines verankerten Rahmens wird abgeschnitten, wenn er die Rahmenbegrenzung überschreitet.

A: Rahmenbegrenzungslinie B: Beschnittene Grafik C: Abgeschnittene Bildbeschriftung

So wählen Sie einen Grafikrahmen aus:

Klicken Sie auf die Begrenzung des Rahmens. Wenn die Begrenzung nicht sichtbar ist, wählen Sie "Darstellung > Rahmen".

So platzieren Sie eine Grafik oder Text in einem Grafikrahmen:

Führen Sie eine der folgenden Aktionen aus:

    Um eine Grafik zu zeichnen, verwenden Sie eines der Werkzeuge der "Werkzeugpalette". Einzelheiten finden Sie unter Zeichnen von Objekten und Grafiken und Text.

Wichtig: Achten Sie darauf, dass Sie das Objekt innerhalb des Rahmens erstellen. Es befindet sich sonst auf der Seite und nicht im Rahmen.

    Um eine Grafik in den Rahmen zu verschieben, klicken Sie auf die Grafik und ziehen Sie sie mit der Maus in das Innere der Rahmenbegrenzung. Das Objekt springt in den Rahmen, wenn Sie es über die Rahmenbegrenzung ziehen.

    Um eine Grafik aus der Zwischenablage einzufügen, markieren Sie den Rahmen und wählen "Bearbeiten > Einfügen".

    Um eine Grafik zu importieren, markieren Sie den Rahmen und wählen "Datei > Importieren > Datei". Je nach verwendetem System können Sie eine Grafik auch auf andere Weise importieren

Hinweis: Wenn sich eine Grafik innerhalb eines verankerten Rahmens zu befinden scheint, aber beim Bearbeiten des Textes nicht mit dem Rahmen verschoben wird, liegt sie wahrscheinlich vor und nicht in dem Rahmen (möglicherweise wurde sie auf der Seite und nicht im Rahmen erstellt). Ziehen Sie die Grafik vollständig aus dem Rahmen heraus und dann wieder in den Rahmen hinein.

So verhindern Sie, dass der Inhalt eines verankerten Rahmens abgeschnitten wird:

Führen Sie eine der folgenden Aktionen aus:

    Wenn außerhalb des Rahmens genügend Platz vorhanden ist, vergrößern Sie den Rahmen.

    Wenn der Platz im Rahmen ausreicht, bewegen Sie das Objekt von der Rahmenkante weiter in die Mitte des Rahmens. Weitere Informationen finden Sie unter Verschieben von Objekten.

    Wenn der Inhalt nur durch die Begrenzungslinien verdeckt wird, ändern Sie mithilfe der Werkzeugpalette die Linienstärke des Rahmens oder stellen Sie das Linienmuster auf "Kein" ein (siehe Zuweisen und Ändern von Zeichnungseinstellungen).

    Wenn Rahmen und Inhalt am Rand einer Textspalte abgeschnitten werden, wählen Sie "Spezial > Verankerter Rahmen", deaktivieren die Option "Beschnitten" und klicken auf "Rahmen bearbeiten".


Grafiken und verankerte Rahmen

Bearbeiten verankerter Rahmen

Sie können die Größe eines verankerten Rahmens, die Verankerungsposition sowie die Einstellungen ändern, die Sie beim Erstellen des Rahmens festgelegt haben. Bei der Arbeit mit einem strukturierten Dokument betreffen diese Änderungen nicht die Struktur des Dokuments und sind von den Formatregeln des Elements unabhängig.

Verankerte Rahmen können genau so wie andere Objekte bearbeitet werden. Sie können die Zeicheneinstellungen (z. B. Linienstärke) ändern und Rahmen kopieren, löschen, verschieben und ihre Größe ändern.

So ändern Sie die Verankerungsposition und die zugehörigen Einstellungen eines verankerten Rahmens:

    1. Markieren Sie den Rahmen und wählen Sie "Spezial > Verankerter Rahmen".

    2. Ändern Sie die Einstellungen und klicken Sie auf "Rahmen bearbeiten".

So ändern Sie die Größe eines verankerten Rahmens:

Führen Sie eine der folgenden Aktionen aus:

    Am schnellsten ändern Sie die Größe, indem Sie den Rahmen markieren und einen seiner Auswahlpunkte ziehen. Die Größe wird während des Ziehens in der Statusleiste angezeigt.

    Um den Rahmen exakt auf eine bestimmte Größe zu bringen, wählen Sie den Rahmen aus und geben den gewünschten Wert mithilfe der Befehle "Grafik > Objekteinstellungen", "Grafik > Skalieren" oder "Spezial > Verankerter Rahmen" an.

    Um die Größe des verankerten Rahmens an die Größe des Objekts im Rahmen anzupassen, drücken Sie Esc M P.

    Weitere Informationen zum Ändern der Größe einer Grafik in einem verankerten Rahmen finden Sie unter Rahmen.

So ändern Sie die Zeicheneinstellungen eines verankerten Rahmens:

Wählen Sie den Rahmen aus und legen Sie mithilfe der Werkzeugpalette die gewünschten Einstellungen fest. Sie können z. B. das Linienmuster eines Rahmens ändern, um die Begrenzung des Rahmens beim Drucken sichtbar zu machen, oder sein Füllmuster, um das Innere des Rahmens zu schattieren.

So kopieren oder verschieben Sie einen verankerten Rahmen:

    1. Wählen Sie den Rahmen aus und wählen Sie dann "Bearbeiten > Kopieren" oder "Bearbeiten > Ausschneiden". Das Ankersymbol muss nicht markiert werden.

    2. Klicken Sie im Text auf die Position, an der Sie den Rahmen einfügen wollen und wählen Sie "Bearbeiten > Einfügen". Das Ankersymbol wird an der Einfügemarke angezeigt, wenn die Anzeige der Steuerzeichen aktiviert ist. Überprüfen Sie bei der Arbeit mit einem strukturierten Dokument vor dem Einfügen anhand des Elementkatalogs, ob die Position für grafische Elemente gültig ist.

In einigen Fällen, z. B. wenn der Rahmen am Anfang oder am Ende einer Textspalte platziert wurde, ändert der Rahmen seine Position nicht, obwohl sich das Ankersymbol verschieben lässt. Wenn es schwierig ist, einen verankerten Rahmen außerhalb eines gedrehten Textrahmens oder einer gedrehten Spalte zu positionieren, heben Sie die Drehung des Textrahmens auf, positionieren den verankerten Rahmen und drehen dann den Textrahmen erneut. Weitere Informationen finden Sie unter Drehen von Objekten.

In einem strukturierten Dokument können Sie zum Verschieben des Rahmens auch in der Strukturansicht das Elementrechteck eines Rahmens ziehen. Um den Rahmen zu kopieren, können Sie das Elementrechteck mit gedrückter Alt-Taste (Windows) oder mit gedrückter Control-Taste und mittlerer Maustaste (UNIX) ziehen. Weitere Informationen finden Sie unter Kopieren von Elementen.

So löschen Sie einen verankerten Rahmen:

Wählen Sie den Rahmen aus und drücken Sie die Entf-Taste.

So verschieben Sie das Ankersymbol eines Rahmens:

    1. Wählen Sie den Rahmen aus. Das Ankersymbol muss nicht markiert werden.

    2. Wählen Sie "Bearbeiten > Ausschneiden", klicken Sie im Text auf die Stelle, an der Sie das Ankersymbol einfügen wollen, und wählen Sie "Bearbeiten > Einfügen". Das Ankersymbol wird an der Einfügemarke angezeigt, wenn die Anzeige der Steuerzeichen aktiviert ist.

In einigen Fällen, z. B. wenn der Rahmen am Anfang oder am Ende einer Textspalte platziert wurde, ändert der Rahmen seine Position nicht, obwohl sich das Ankersymbol verschieben lässt.

So verschieben Sie einen verankerten Rahmen ohne sein Ankersymbol:

Führen Sie eine der folgenden Aktionen aus:

    Um die Position rasch zu ändern, ziehen Sie den Rahmen mit der Maus.

    Diese Methode erlaubt jedoch nur eine annähernde Positionierung. Um den Rahmen exakt zu positionieren, verschieben Sie ihn schrittweise mithilfe der Pfeiltasten (siehe Verschieben von Objekten).

    Die genaueste Positionierung erreichen Sie mit dem Befehl "Spezial > Verankerter Rahmen".

Einige verankerte Rahmen können nicht ohne ihr Ankersymbol verschoben werden. Sie können einen Rahmen jedoch vertikal verschieben, wenn er an der Einfügemarke, außerhalb der Textspalte oder außerhalb des Textrahmens verankert ist. Wenn ein Rahmen außerhalb der Textspalte oder außerhalb des Textrahmens verankert ist, kann er nicht über den oberen oder unteren Rand des Textrahmens hinaus verschoben werden.

Hinweis: Wenn Sie einen Rahmen in eine Spalte verschieben, wird der Text in der Spalte nicht entsprechend angepasst. Verwenden Sie in diesem Fall die Verankerungsposition "Im Absatz", damit der Rahmen vollständig in die Spalte verschoben wird und der Text den Rahmen automatisch umgibt. Sie können auch den Absatzeinzug ändern, um Platz für den Rahmen zu schaffen.


Grafiken und verankerte Rahmen

Vorbereiten verankerter Rahmen für Tagged PDF

Wenn Sie beabsichtigen, Ihr Dokument in eine Tagged PDF-Datei oder in das XML-Format zu exportieren, können Sie Objektattributinformationen für die verankerten Rahmen festlegen.

Alt-Text unterscheidet sich von Grafik- oder Standardtext. Alt-Text wird in der Regel zum Beschreiben eines Bildes verwendet, sodass Screen Reader den Text vorlesen können. Actual-Text dient dagegen zum Lesen des tatsächlichen Textes, wie z. B. im Fall von Initialen. Wenn der Autor z. B. Initialen für den Buchstaben "A" im Wort "Adobe" verwendet, der Screen Reader aber trotzdem das Wort als "Adobe" und nicht als "dobe" lesen soll, kann er Actual-Text einfügen. Das Attribut wird im Tagged PDF- und XML-Format in Alt- und Actual-Text gespeichert.

Wenn Sie das Alternativtext-Attribut (alt) für einen verankerten Rahmen festlegen, erhalten die entsprechenden Abbildungselemente in der PDF-Datei sowie die Grafikelemente in XML ein "alt text"-Attribut. Das "actual text"-Attribut wird nur für Tagged PDF verarbeitet. Beim XML-Export wird dieses Attribut ignoriert.

Hinweis: Objektattribute unterstützen den Unicode-Standard zur Textcodierung.

So fügen Sie Objektattribute hinzu:

    1. Wählen Sie den Rahmen aus und klicken Sie dann auf "Grafik > Objekteinstellungen".

    2. Klicken Sie auf "Objektattribute".

    3. Geben Sie im Abschnitt "Textattribute" den Alternativtext (alt) und den tatsächlichen Text (actual) ein und klicken Sie auf "Zuweisen".

Hinweis: Screen Reader können den tatsächlichen Text leicht ignorieren, wenn Alternativtext vorhanden ist.


Grafiken und verankerte Rahmen

Verankerte Rahmen in strukturierten Dokumenten

In einem strukturierten Dokument stellt ein Grafikelement einen verankerten Rahmen zum Aufnehmen von Grafikobjekten zur Verfügung. Der Rahmen wird an einer bestimmten Stelle im Text verankert. Während Sie den Text bearbeiten, verschiebt sich der Rahmen und sein Inhalt gemeinsam mit dem Text im Dokument.

Verankerung von Rahmen in strukturierten Dokumenten

Beim Einfügen eines Grafikelements geben Sie an, wo der Elementrahmen verankert werden soll. Sie können den Rahmen z. B. in einem Element "Absatz" verankern (und die Grafik wird zu einem untergeordneten Element des Elements "Absatz") oder Sie können ihn in einem Abschnittelement verankern (als gleichrangiges Element zu "Absatz" und anderen Elementen im Abschnittelement). Das jeweilige Vorgehen richtet sich danach, wie die Elemente für das Dokument definiert wurden.

Im Dokumentfenster wird ein Ankersymbol ( [image] ) an der Position des Ankers im Text angezeigt, wenn "Darstellung > Steuerzeichen" aktiviert ist. Der Rahmen kann an einer Vielzahl von Positionen auf der Seite erscheinen, einschließlich zusammen mit Text auf einer Zeile, neben oder unter einem Absatz oder in einem Seitenrand. Die Verankerungsposition muss relativ zum Ankersymbol angegeben werden.

Mehrere Positionen für verankerte Rahmen

Ein Grafikelement wird in der Struktur des Dokuments angezeigt, wo es mit Text verankert wurde (unabhängig von der Position des Rahmens auf der Seite). In der Strukturansicht wird das Element durch ein Elementrechteck ohne abgerundete Ecken mit dem Textausschnitt <GRAFIK> dargestellt.

Grafikelement


Grafiken und verankerte Rahmen / Verankerte Rahmen in strukturierten Dokumenten

Einfügen von verankerten Rahmenelementen in strukturierte Dokumente

Mit einem verankerten Rahmenelement fügen Sie einen verankerten Rahmen in einen strukturierten Textfluss ein. Sie legen die Position des Rahmens im Verhältnis zu der Einfügemarke, der Rahmengröße und verschiedener Formatierungseigenschaften fest. Die festgelegten Formatierungseinstellungen sind unabhängig von den Formatregeln des Elements und setzen diese auch nicht außer Kraft.

Informationen über das Einfügen eines verankerten Rahmens, der kein Element ist (ein Vorgang, der nur in einem unstrukturierten Textfluss möglich ist), finden Sie unter Erstellen verankerter Rahmen.

So fügen Sie ein verankertes Rahmenelement ein:

    1. Klicken Sie an der Stelle, an der Sie den Rahmen verankern wollen.

    2. Wählen Sie im Elementkatalog ein verankertes Rahmenelement aus und klicken Sie auf "Einfügen".

Sie können zum Einfügen eines Elements auch den Befehl "Spezial > Verankerter Rahmen" verwenden. Wenn mehrere Rahmenelemente zur Verfügung stehen, wählen Sie ein Element aus dem Aufklappmenü "Element-Tag" im Dialogfenster "Verankerter Rahmen" aus.

    3. Wählen Sie die Verankerungsposition des Rahmens und legen Sie seine Größe und Formatierungseinstellungen fest. Welche Einstellungen im Dialogfenster angezeigt werden, hängt von der gewählten Verankerungsposition ab. Weitere Informationen finden Sie unter Verankerte Rahmen in einer Textzeile.

    4. Klicken Sie auf "Neuer Rahmen". Der verankerte Rahmen wird im Dokumentfenster mit einem Ankersymbol ( [image] ) an der Einfügemarke angezeigt, wenn "Darstellung > Steuerzeichen" aktiviert ist. In der Strukturansicht erscheint ein Strukturrechteck mit dem Textausschnitt <GRAFIK>.

Wenn an der gewünschten Position kein verankertes Rahmenelement verfügbar ist, können Sie ein ungültiges Element verwenden. Informieren Sie sich nach Einfügen des Elements bei Ihrem Entwickler darüber, wie sich das Element an dieser Position in ein gültiges Element umwandeln lässt.

So verwenden Sie ein ungültiges verankertes Rahmenelement:

Führen Sie eine der folgenden Aktionen aus:

    Um ein Element zu verwenden, das in einem anderen Teil des Dokuments gültig ist, fügen Sie das Element an einer gültigen Position ein und verschieben es oder benutzen Sie die Einstellung "Alle Elemente" (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument), um das Element überall verfügbar zu machen, und fügen Sie das Element dann an der gewünschten Position ein.

    Um ein ungültiges Rahmenelement mit einem Standard-Tag einzufügen, wählen Sie den Befehl "Spezial > Verankerter Rahmen" und dann "GRAFIK" aus dem Aufklappmenü "Element-Tag". (Diese Option wird im Menü angezeigt, wenn keine definierten Rahmenelemente verfügbar sind.)


Grafiken und verankerte Rahmen / Verankerte Rahmen in strukturierten Dokumenten

Füllen von verankerten Rahmen in strukturierten Dokumenten

Sie können in einem verankerten Rahmen innerhalb eines strukturierten Dokuments Grafiken zeichnen, Grafiken aus anderen Teilen des Dokuments ziehen bzw. einfügen oder aus einem anderen Dokument oder einer anderen Anwendung importieren bzw. einfügen. Obwohl das Grafikelement Teil der Struktur eines Dokuments ist, sind die Inhalte, mit denen Sie den Rahmen füllen, nicht Bestandteil der Struktur.

Sie können sogar Text in einen verankerten Rahmen einfügen, z. B. Text in einem Randbalken. Hierfür ziehen Sie im verankerten Rahmen einen Textrahmen auf. Bedenken Sie jedoch, dass der Text kein Teil der Dokumentstruktur ist.

Der Inhalt eines Rahmens bleibt normalerweise erhalten, wenn Sie in das XML- oder SGML-Format exportieren. FrameMaker schreibt den Inhalt in eine separate Datei und fügt Ihrer XML- oder SGML-Datei eine Entitätsreferenz auf diese Datei hinzu.

Wichtig: Für den Export in das XML- oder SGML-Format sollten Sie nur eine Grafik in jedem Rahmen platzieren, um beste Ergebnisse zu erzielen. Wenn Ihre Grafiken Bitmaps sind, verwenden Sie nicht die Farbtiefe 1 Bit oder 24 Bit, sondern setzen Sie sie auf 8 Bit. Wenden Sie sich an Ihren Anwendungsentwickler, um sicherzustellen, dass der Inhalt Ihrer Rahmen vollständig erhalten bleibt.

Nachdem Sie Grafiken im Rahmen platziert haben, können Sie sie auf vielerlei Weise bearbeiten, z. B. Ändern der Linienstärke, Zuweisen von Füllfarben und Ausrichten, Stapeln oder Gruppieren mehrerer Objekte.

Anleitungen zum Füllen eines verankerten Rahmens finden Sie unter Füllen verankerter Rahmen.


Farbe

Informationen über Farbe

Farbsysteme

Planen der Farbverwendung

Farbbibliotheken

Zuweisen von Farben und Aufhellungen

Definieren und Ändern von Farben und Aufhellungen

Anzeigen von Farben

Drucken farbiger Dokumente

Nachbearbeiten farbiger Dokumente

Drucken auf Setzmaschinen (Windows)


Farbe

Informationen über Farbe

Mit Farbe können Sie jedes Dokument interessanter gestalten. In Adobe FrameMaker können Sie Text und Objekten auf einfache Weise Farbe verleihen. Sobald eine Farbe zugewiesen ist, können Sie Ihr Dokument auf einem Farbdrucker ausgeben oder Farbauszüge für eine Druckerei erstellen. Sie können auch eine Ausgabe in eine PostScript-Datei erzeugen und die Datei zur Weiterbearbeitung in einem anderen Programm an Ihre Druckerei geben.

Mithilfe verschiedener Farbsysteme und -bibliotheken ist es möglich, Ihre eigenen Farben und Farbtöne zu definieren.


Farbe

Farbsysteme

Wenn Sie mit einem Farbsystem Farben definieren, bauen Sie die Farbe auf, indem Sie ihre Komponenten manuell anpassen, z. B. den Anteil an reinem Rot oder den Sättigungsgrad.

Drei Farbsysteme stehen Ihnen zur Verfügung: CMYK, RGB und HLS.

CMYK

Arbeiten Sie mit dem CMYK-Farbsystem, wenn Sie Farbauszüge für Vierfarbdruck erstellen möchten. Die Farben bestehen aus einer Kombination der Komponenten Cyan, Magenta, Gelb und Schwarz. Wenn Sie Farbauszüge aus Ihrem Dokument erstellen, wird jede Farbkomponente auf eine separate Platte gedruckt, und zwar in unterschiedlicher Konzentration, abhängig vom gewünschten Farbergebnis. Weitere Informationen hierzu finden Sie unter Farbauszüge.

RGB

Verwenden Sie das RGB-Farbsystem, um Farben für die Darstellung am Bildschirm anzuzeigen (z. B. für eine Online-Dokumentation). RGB-Farben werden aus einer Kombination von rotem, grünem und blauem Licht erzeugt.

HLS

Verwenden Sie das HLS-Farbsystem, wenn Sie mit Farbkreisen vertraut sind. Dieses System entspricht der Farbpalette, die Künstler zum Mischen ihrer Farben verwenden, und wird oft in der Farbauswahl von Software-Programmen verwendet. Die Farben werden durch Zuweisen von Farbton, Helligkeit und Sättigung erstellt. Der Farbton (Hue) legt den Farbanteil (rot, grün, gelb, blau usw.) fest. Die Helligkeit (Lightness) gibt die Helligkeit bzw. Dunkelheit einer Farbe an. Die Sättigung (Saturation) steuert den Grauanteil der Farbe.


Farbe

Planen der Farbverwendung

Beachten Sie beim Planen der Farbverwendung folgende Punkte:

Informieren Sie sich darüber, wie die Farbe gedruckt und angezeigt wird.

Die Art und Weise, in der die Endausgabe des Farbdokuments erfolgen soll, kann die Farbauswahl entscheidend beeinflussen:

    Für eine Online-Ausgabe verwenden Sie das Farbsystem RGB oder HLS. Wichtig für die Auswahl der richtigen Farbe ist die Wirkung des Dokuments an Ihrem Bildschirm.

    Für einen Desktop-Ausdruck definieren Sie Ihre Farben im CMYK-Farbsystem und testen die Ausgabe auf Ihrem Drucker. Entscheidend für die Auswahl der richtigen Farbe ist die Wirkung des Dokuments auf dem Papier.

    Für professionellen Druck verwenden Sie die Farben aus einer Bibliothek, die auch in Ihrer Druckerei eingesetzt wird. Verlassen Sie sich nicht auf die Bildschirmdarstellung der Bibliotheksfarben, sondern verwenden Sie ein Swatch-Buch. (Ein Computerbildschirm kann eine Farbe nie so darstellen, wie sie im Ausdruck aussehen wird.) Viele Abschnitte in diesem Kapitel beziehen sich nur auf das professionelle Drucken, z. B. die Abschnitte über Schmuckfarben, Überdrucken, Fangstellen und Farbauszüge.

Informieren Sie sich über die Grenzen des Mediums

Bringen Sie in Erfahrung, welcher Farbbereich auf Ihrem Monitor oder Drucker verfügbar ist. Beispielsweise kann ein System, das für die Anzeige von 256 Farben eingerichtet ist, Aufhellungen unterhalb von 16 % in FrameMaker nicht korrekt anzeigen.

Informieren Sie sich über die Grenzen Ihres Systems (nur Windows)

In FrameMaker für Windows werden alle Farbwerte beim Drucken oder Speichern als Adobe PDF-Datei in RGB konvertiert. Dies geschieht, weil in FrameMaker die Windows GDI-Befehle (Graphical Device Interface) zur Kommunikation mit Druckertreibern verwendet werden. GDI akzeptiert ausschließlich RGB-Farbwerte.

FrameMaker erhält jedoch Farbwerte in EPS-Grafikobjekten (Encapsulated PostScript), einschließlich CMYK-Farben, RGB-Farben, Graustufen, Schmuckfarben, geräteunabhängige Farben (wie CIE L*a*b). Die grafische Information einer EPS-Datei wird direkt in den PostScript-Ausgabestrom weitergeleitet, wobei die Windows GDI-Verarbeitung umgangen wird. EPS-Grafikobjekte können aus Text, Vektorgrafiken oder aus einem beliebigen durch Adobe PostScript unterstützen Grafiktyp erstellt werden. Deshalb ist es möglich, EPS-Grafiken in Adobe Acrobat, Adobe Illustrator®, Adobe Photoshop®, Adobe Streamline und Adobe InDesign® sowie in vielen Anwendungsprogrammen anderer Hersteller zu speichern oder daraus zu exportieren.

In FrameMaker werden außerdem Farbauszüge in äquivalenten RGB-Werten erstellt. Für EPS-Grafiken werden Farbauszüge jedoch entsprechend den Farbwerten angelegt, die in der EPS-Grafik angegeben werden.

Wenden Sie sich an den Ansprechpartner Ihrer Druckerei

Bringen Sie in Erfahrung, ob Ihre Druckerei spezielle Anforderungen oder Vorschläge für eine optimale Farberstellung hat.

Konsultieren Sie einen Grafiker

Mit der Unterstützung eines Grafikers können Sie aus einer guten eine optimale Farbgestaltung machen.

Verwenden Sie Formate für die Zuweisung von Farben

Die Verwendung von Absatz- und Zeichenformaten für die Farbzuweisung in Text gewährleistet, dass ähnliche Passagen die gleiche Farbe erhalten. Dadurch lassen sich Farben in Ihren Dokumenten auch einfacher austauschen.


Farbe

Farbbibliotheken

Wenn Sie mit einem Farbdefinitionssystem arbeiten (einer Farbbibliothek), wählen Sie Farben, die von einem Hersteller definiert sind. Durch eine bereits gemischte Bibliotheksfarbe stellen Sie sicher, dass die Druckerei eine präzise Abstimmung auf die Formel vornehmen kann, die durch das Swatch-Buch des Herstellers vorgegeben ist. Deshalb sollten Sie die Definition einer Farbe in einer Bibliothek nicht ändern, wenn Sie Ihr Dokument in einer Druckerei weiterbearbeiten lassen.

Jede Farbe in einer Bibliothek ist als Schmuckfarbe oder als Prozessfarbe definiert. Eine Schmuckfarbe wird auf einer Druckerpresse mit vorgemischten Farben auf eine einzige Platte gedruckt. Eine Prozessfarbe wird gedruckt, indem die sich überlagernden Punkte der Farben Cyan, Magenta, Gelb und Schwarz (CMYK) auf separaten Druckplatten ausgegeben werden.

Bevor Sie eine Farbe aus einer Farbbibliothek wählen, bitten Sie Ihre Druckerei um eine Liste der unterstützten Bibliotheken. Die besten Ergebnisse erzielen Sie, wenn Sie sich nicht auf die Farbdarstellung am Bildschirm verlassen, sondern eine Farbe aus einem Swatch-Buch wählen.

FrameMaker verfügt über folgende Bibliotheken:

Crayon

Die Crayon-Bibliothek wurde von Adobe entwickelt und bietet Zugriff auf übliche RGB-Farben unter Verwendung der gängigen Namen in alphabetischer Reihenfolge. Verwenden Sie die Crayon-Farben nicht als Schmuckfarben.

DIC

Der DIC Color Guide stellt Schmuckfarben zur Verfügung und wird überwiegend in Japan verwendet.

FOCOLTONE

Das FOCOLTONE® Colour System enthält 860 Prozessfarben (CMYK).

Greys

Die Greys-Bibliothek wurde von Adobe entwickelt und stellt Grauabstufungen von Prozess- und Schmuckfarben (in 1-Prozent-Schritten) bereit.

MUNSELL

Das Munsell-System enthält Farben, die auf der Grundlage der RGB-Palette definiert sind.

Online

Die Online-Farbbibliothek bietet 216 "web-sichere" Farben, die bei der Anzeige in einem Web-Browser über alle Plattformen ein einheitliches Erscheinungsbild aufweisen.

PANTONE

Die meisten Bibliotheken im PANTONE® MATCHING SYSTEM werden für Schmuckfarben verwendet. Nur die beiden PANTONE-Prozessfarbenbibliotheken stehen für die Auswahl von Prozessfarben zur Verfügung. Außerdem gibt es separate PANTONE-Bibliotheken für den Farbdruck auf beschichtetem und unbeschichtetem Papier. Die PANTONE ProSim Euro-Bibliothek enthält Farbdefinitionen, die den in Europa vorwiegend eingesetzten Drucksystemen entsprechen.

TOYO

Der TOYO Color Finder enthält über 1000 Farben, die den gängigsten in Japan verwendeten Farben entsprechen.

TRUMATCH

Der TRUMATCH® 4-Color Selector stellt über 2000 Prozessfarben zur Verfügung, die das gesamte sichtbare CMYK-Farbspektrum in gleichmäßigen Abstufungen abdecken.

So erhalten Sie weitere Informationen über eine Farbbibliothek:

Wählen Sie "Darstellung > Farbe > Definitionen" und dann eine Bibliothek aus dem Aufklappmenü "Farbbibliotheken". Klicken Sie anschließend auf "Info".

So wählen Sie eine Farbe aus einer Farbbibliothek:

Führen Sie die Schritte unter Definieren und Ändern von Farben und Aufhellungen aus.

Wichtig: Wenn Sie eine Farbe aus einer Farbbibliothek wählen, wird ihr vordefinierter Name im Dialogfenster im Feld "Name der Farbe" angezeigt. Wenn Sie die Definition der Bibliotheksfarbe ändern, wird das Feld "Name der Farbe" ausgeblendet. Dies ist ein Hinweis darauf, dass die Farbe jetzt nicht mehr mit der vom Hersteller definierten Formel übereinstimmt. Das Ändern der Definition einer Bibliotheksfarbe ist nicht empfehlenswert. Um die ursprüngliche Definition wiederherzustellen, wählen Sie die Farbe erneut aus der Bibliothek und klicken auf "Ändern".

So fügen Sie eine Farbbibliothek für die Verwendung in FrameMaker ein:

    1. Legen Sie die Bibliotheksdatei in einem der folgenden Ordner ab:

    (Windows) Ordner "Fminit\Color"

    (UNIX) $FMHOME/fminit/color

    2. Starten Sie FrameMaker neu.

Sie können eine beliebige Bibliotheksdatei hinzufügen, die im ASCII-Farbformat (.acf) Version 2.1 oder früher oder im Binärfarbformat (.bcf) Version 2.0. formatiert ist. In FrameMaker können keine .bcf-Bibliotheksdateien gespeichert werden.


Farbe

Zuweisen von Farben und Aufhellungen

Die Methode für die Zuweisung einer Farbe oder einer helleren Version der Farbe (einer so genannten Aufhellung) hängt von der aktuellen Auswahl ab. Jeder Eintrag in einem Aufklappmenü "Farbe" kann Text oder Objekten zugewiesen werden. FrameMaker stellt sechzehn Standardfarben zur Verfügung, denen Sie weitere Farben hinzufügen können (siehe Definieren und Ändern von Farben und Aufhellungen).

Sie können zwei Arten von Aufhellungen zuweisen:

    Aufhellungen auf Farbebene, die Sie mithilfe von "Darstellung > Farbe > Definitionen" definieren und benennen (siehe Definieren und Ändern von Farben und Aufhellungen). Diese Aufhellungen werden in den Aufklappmenüs "Farbe" von Dialogfenstern und Gestaltungsfenstern angezeigt.

    Bei Aufhellungen auf Objektebene, die Sie einem Objekt zuweisen, wird die ursprüngliche Farbe des Objekts um einen bestimmten Prozentsatz aufgehellt. Die Zuweisung einer solchen Aufhellung kann mit dem Aufklappmenü "Aufhellung" der Werkzeugpalette oder im Dialogfenster "Objekteinstellungen" des betreffenden Objekts erfolgen.

Hinweis: Unter Windows und NIX können Sie TIFFs nicht tönen.

So weisen Sie einem Text oder Objekt eine Farbe oder eine Aufhellung zu:

Verwenden Sie ein Absatzformat, ein Zeichenformat oder die Aufklappmenüs "Aufhellung" und "Farbe", um eine Farbe bzw. eine Aufhellung zuzuweisen:

Objekt, dem eine Farbe oder Aufhellung zugewiesen werden soll | Verwenden
Absätze | Ein Format aus dem Absatzformat-Katalog oder das Aufklappmenü "Farbe" in der Werkzeugpalette bzw. in der Absatzgestaltung
Ausgewähltes Wort oder Wortverbindung in einem Absatz | Ein Format aus dem Zeichenformat-Katalog oder das Aufklappmenü "Farbe" in der Werkzeugpalette bzw. in der Zeichengestaltung
Textzeile | Ein Format aus dem Zeichenformat-Katalog oder das Aufklappmenü "Farbe" in der Werkzeugpalette bzw. in der Zeichengestaltung
Objekte oder importierte Grafiken | Das Aufklappmenü "Farbe" oder "Aufhellung" in der Werkzeugpalette
Textrahmen | Das Aufklappmenü "Füllung" in der Werkzeugpalette, um für das Füllmuster des Rahmens einen anderen Wert als "Keine" festzulegen, danach das Aufklappmenü "Farbe" oder "Aufhellung", um eine Farbe zuzuweisen
Text in einer Tabelle | Ein Format aus dem Absatzformat- oder Zeichenformat-Katalog oder das Aufklappmenü "Farbe" in der Werkzeugpalette bzw. in einem Gestaltungsfenster
Zellen in einer Tabelle | Das Aufklappmenü "Farbe" im Dialogfenster "Lineatur/Schattierung" oder in der Tabellengestaltung
Änderungsbalken | Das Aufklappmenü "Farbe" im Dialogfenster "Änderungsbalken"
Bedingter Text | Das Aufklappmenü "Farbe" und die Schaltfläche für neue Farbe im Dialogfenster "Bedingungstyp ändern"
Gleichungen und FrameMath-Elemente in Gleichungen | Ein Format aus dem Zeichenformat-Katalog oder das Aufklappmenü "Farbe" in der Werkzeugpalette bzw. in der Zeichengestaltung

So weisen Sie einem Objekt mithilfe eines Füllmusters eine Aufhellung zu:

    1. Wählen Sie das gewünschte Objekt aus.

    2. Wählen Sie eines der ersten acht Füllmuster aus dem Aufklappmenü "Füllung" in der Werkzeugpalette. Die Füllmuster weisen der aktuellen Farbe des Objekts die folgenden Prozentwerte zu.

    Füllmuster | Prozentuale Aufhellung
 | 100%
 | 90%
 | 70%
 | 50%
 | 30%
 | 10%
 | 3%
 | 0 % (Papierfarbe)

So weisen Sie Text und allen gezeichneten Objekten dieselbe Farbe zu:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Halten Sie die Umschalt- und Alt-Taste gedrückt und wählen Sie eine Farbe aus dem Aufklappmenü "Farbe" der Werkzeugpalette.

    (UNIX) Halten Sie die Umschalt- und die Control-Taste gedrückt und wählen Sie eine Farbe aus dem Aufklappmenü "Farbe" der Werkzeugpalette.


Farbe

Definieren und Ändern von Farben und Aufhellungen

Sie können Farben und Aufhellungen (Prozentanteile einer bestimmten Farbe) erstellen oder ändern, indem Sie die Farbkomponenten im verwendeten System anpassen oder eine vordefinierte Aufhellung aus einer Farbbibliothek wählen. Neue Farben und Aufhellungen werden in allen Aufklappmenüs "Farbe" und Auswahllisten angezeigt.

Sie können die Schaltfläche "Farbe" in den Dialogfenstern "Bedingungs-Tag hinzufügen" und "Bedingungstyp ändern" verwenden, um für Bedingungstypen eindeutige Farben auszuwählen, mit denen Sie Bedingungstypen voneinander unterscheiden können.

Für die sechzehn Standardfarben können lediglich die Einstellungen "Überdrucken" und "Drucken als" geändert werden. Sie haben jedoch die Möglichkeit, eigene Farben zu definieren, indem Sie die kleingeschriebenen Versionen der Standardfarbnamen (schwarz, blau usw.) verwenden. Die Crayon-Bibliothek verfügt außerdem über eigene Versionen dieser Farben, die Sie verwenden oder unter anderem Namen neu definieren können.

So definieren oder ändern Sie eine Farbe bzw. eine Aufhellung:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Farbe > Definitionen".

    3. Führen Sie eine der folgenden Aktionen aus:

    Um eine neue Farbe zu definieren, geben Sie einen neuen Namen in das Textfeld "Name" ein.

    Um eine vorhandene Farbe (oder Grundfarbe) zu ändern, wählen Sie ihren Namen aus dem Aufklappmenü rechts neben dem Textfeld "Name" (oder geben Sie den Namen ein, bis die Farbdefinition angezeigt wird).

    4. Legen Sie fest, wie die Farbe gedruckt werden soll, indem Sie eine der folgenden Optionen aus dem Aufklappmenü "Drucken als" wählen:

    Zur Definition einer Aufhellung wählen Sie "Aufhellung". Eine Aufhellung wird immer auf dieselbe Art und Weise angezeigt und auf dieselbe Platte gedruckt wie ihre Grundfarbe. Die Grundfarbe bestimmt außerdem die Farbkomponenten.

    Zur Definition einer Schmuckfarbe wählen Sie "Schmuckfarben".

    Zur Definition einer Farbe, die mit CMYK-Farben gedruckt wird, wählen Sie "Prozessfarben".

    Um eine Farbe zu definieren, die nicht gedruckt werden soll, wählen Sie "Nicht drucken".

    5. Um das Farbsystem zu wechseln, wählen Sie eine Option aus dem Aufklappmenü "Farbsystem". Einzelheiten finden Sie unter Farbsysteme und Planen der Farbverwendung. (Das Farbsystem der Aufhellung wird durch die Grundfarbe bestimmt.)

    6. Passen Sie die Farbkomponenten an, indem Sie die Regler verschieben oder Werte eingeben. Wenn Sie eine Aufhellung definieren, wählen Sie eine Farbe aus dem Aufklappmenü "Grundfarbe" und legen Sie den Prozentwert fest. Um Änderungen zurückzunehmen, klicken Sie auf das Feld "Aktuell".

Hinweis: Die von Ihnen definierte Farbe oder Aufhellung kann an Ihrem Bildschirm eventuell nicht exakt angezeigt werden. Beispielsweise wird ein Aufhellungswert, der weniger als 10 % der Grundfarbe beträgt, wahrscheinlich am Bildschirm (oder auf bestimmten Druckern) nicht korrekt ausgegeben. UNIX-Systeme, die mit 8-Bit-Farben arbeiten, haben unter Umständen Probleme bei der Anzeige von Farben, die sich nicht in ihren Farbpaletten befinden (weitere Informationen finden Sie im Online-Handbuch "Anpassen von FrameMaker-Produkten" auf der Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf).

    7. Wenn die Farbe bei der Erstellung von Farbauszügen über alle anderen Farben gedruckt werden soll, wählen Sie aus dem Aufklappmenü "Überdrucken" den Eintrag "Überdrucken" (siehe Aussparen und Überdrucken).

    8. Zur Erstellung einer neuen Farbe klicken Sie auf "Einfügen" (oder auf das Farbfeld "Neu"); zur Änderung der aktuellen Farbe klicken Sie auf "Ändern".

    9. Definieren oder bearbeiten Sie je nach Bedarf weitere Farben und klicken Sie auf "Fertig".

So definieren Sie eine Farbe aus einer Farbbibliothek:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Farbe > Definitionen".

    3. Wählen Sie eine Bibliothek aus dem Aufklappmenü "Farbbibliotheken". Weitere Informationen hierzu finden Sie unter Farbbibliotheken.

    4. Wählen Sie eine Farbe aus der Bibliothek mit den vordefinierten Farben. Wenn Sie den Namen kennen, können Sie ihn eingeben, um rasch zur gewünschten Farbe zu gelangen.

    5. Klicken Sie auf "Fertig". Die ausgewählte Farbe wird im Dialogfenster "Farbdefinitionen" im Feld "Name der Farbe" eingeblendet.

Hinweis: Farben aus Farbbibliotheken besitzen häufig ein bevorzugtes Farbsystem und einen bevorzugten Typ. Wenn Sie eine Farbe wählen, ändert sich gegebenenfalls automatisch das Farbsystem oder der Typ. Unter normalen Bedingungen sollten Sie diese Einstellungen nicht ändern. Gleiches gilt für die Farbdefinition einer Bibliotheksfarbe. Wenn Sie eine Änderung durchführen, wird das Feld "Name der Farbe" ausgeblendet und die Farbe stimmt nicht mehr mit der vom Hersteller definierten Formel überein.

    6. Wenn die Farbe bei der Erstellung von Farbauszügen über alle anderen Farben gedruckt werden soll, wählen Sie aus dem Aufklappmenü "Überdrucken" den Eintrag "Überdrucken" (siehe Aussparen und Überdrucken).

    7. Klicken Sie auf "Hinzufügen".

    8. Definieren Sie je nach Bedarf weitere Farben und klicken Sie auf "Fertig".

Wenn Sie für die Definition einer Farbe die Farbauswahl des Betriebssystems verwenden möchten, wählen Sie "Normale Farbauswahl" (Windows). Die entsprechende Farbauswahl kann dann wie in jeder anderen Anwendung eingesetzt werden.

So löschen Sie eine Farbe oder eine Aufhellung:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Farbe > Definitionen".

    3. Wählen Sie aus dem Aufklappmenü "Name" eine Farbe oder eine Aufhellung. (Die sechzehn Grundfarben können nicht gelöscht werden.)

    4. Klicken Sie auf "Löschen". Wenn die Farbe in Gebrauch ist, werden Sie in einem Meldungsfenster gefragt, ob Elemente, die diese Farbe verwenden, zu Schwarz geändert werden sollen. Wenn Sie die Grundfarbe einer Aufhellung löschen, wird die Aufhellung zu einem Prozentwert von Schwarz.

    5. Wiederholen Sie diesen Vorgang, wenn Sie weitere Farben löschen möchten. Wenn Sie fertig sind, klicken Sie auf "Fertig".

Hinweis: Farbdefinitionsnamen unterstützen den Unicode-Standard zur Textcodierung.


Farbe

Anzeigen von Farben

Ein Farbauszug legt fest, welche Farben sichtbar sind. Wenn Sie in einem Dokument z. B. Schwarz und eine Schmuckfarbe verwenden, könnte ein Auszug beide Farben, ein anderer nur die Schmuckfarbe anzeigen.

Beide Farben sichtbar und nur eine Farbe sichtbar

Legen Sie für jeden von Ihnen definierten Farbauszug fest, welche Farben angezeigt, welche Farben für Aussparungen verwendet (Aussparungen werden weiß angezeigt, wenn sich Objekte mit unterschiedlichen Farben überlagern) und welche Farben nicht angezeigt werden sollen.

So richten Sie einen Farbauszug ein:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Darstellung > Farbe > Darstellung".

    3. Klicken Sie auf eine Auszugsnummer und verschieben Sie die Farbnamen in die entsprechenden Auswahllisten. In diesem Dialogfenster werden keine Aufhellungen angezeigt. Sie werden zusammen mit den Farben eingeblendet, auf denen sie basieren.

Um eine Farbe zu verschieben, wählen Sie sie aus und klicken auf einen Pfeil (oder doppelklicken Sie auf die Farbe). Um alle Farben zu verlagern, wählen Sie eine Farbe aus, halten die Umschalttaste gedrückt und klicken auf einen Pfeil. Sie können die Änderungen widerrufen, indem Sie auf "Standard" klicken.

In einer Auswahlliste ist der Name einer Farbe möglicherweise abgeschnitten, unter der Liste wird er jedoch vollständig angezeigt.

Lassen Sie Auszug "1" unverändert und behalten Sie alle Farben (außer Weiß) in der Auswahlliste "Normal" bei. Wenn Sie ein Objekt mit einer Farbe zeichnen, die im aktuellen Auszug unsichtbar ist, schaltet FrameMaker automatisch zu Auszug "1" um.

    4. Wiederholen Sie Schritt 3 für jeden Auszug, den Sie einrichten möchten und klicken Sie anschließend auf "Zuweisen". Der aktuell ausgewählte Farbauszug wird angezeigt.

So verwenden Sie einen Farbauszug:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Darstellung > Farbe > Darstellung", wählen Sie den anzuzeigenden Farbauszug aus und klicken Sie auf "Zuweisen".

    Drücken Sie Esc D Nummer. Hierbei bezeichnet Nummer die Nummer des anzuzeigenden Farbauszugs (1 bis 6).


Farbe

Drucken farbiger Dokumente

Sie können jede Seite eines Dokuments als Kombinationsseite drucken. Eine Kombinationsseite enthält alle Farben, die auf der Seite verwendet werden. Auf Desktop-Farbdruckern werden kombinierte Farbdokumente ausgedruckt.

Alternativ dazu können Sie jede Seite eines Dokuments in Form mehrerer Farbauszüge drucken. Dabei werden Farbbilder so auf mehrere Seiten aufgeteilt, dass jede Seite eine Farbkomponente enthält. In der Druckerei wird mithilfe der Farbauszüge eine Druckplatte für jede Farbe hergestellt.

Sie können auch Spiegelbilder und Negativbilder drucken, was bei der Erstellung von Filmen erforderlich sein kann.

Wenn sich in Ihrem Dokument Objekte überlagern, können Sie überdrucken. Dabei wird ein Objekt (meist das dunklere) auf andere Farbobjekte gedruckt. Sie können aber auch eine Aussparung erstellen. In diesem Fall wird nur die oberste Farbe gedruckt, die darunter liegenden jedoch nicht. Außerdem können Sie Fangstellen verwenden, um Lücken zwischen Objekten zu verhindern.

So drucken Sie Kombinationsseiten:

    1. Wählen Sie "Datei> Drucken".

    2. Stellen Sie sicher, dass "Farbauszüge drucken" deaktiviert ist.

    3. Legen Sie die weiteren Druckoptionen wie erforderlich fest und klicken Sie auf "Drucken". Informationen über die weiteren Druckoptionen finden Sie unter Druckoptionen.


Farbe / Drucken farbiger Dokumente

Aussparen und Überdrucken

Wenn sich zwei Farbobjekte überlagern, spart FrameMaker normalerweise den überlagerten Bereich aus, sodass dieser in einem Farbauszug nicht gedruckt wird (er erscheint in der Farbe des Papiers). Wenn Sie Farbauszüge für eine Druckerei erstellen, können Registrierungsfehler auftreten und Sie sehen unter Umständen kleine Lücken zwischen den Farben.

Genaue und ungenaue Registrierung

Zur Vermeidung von Lücken zwischen Farben können Sie für das oberste Objekt die Funktion "Überdrucken" verwenden. In diesem Fall wird der überlagerte Bereich nicht ausgespart.

Ausgespart und überdruckt

Sie können auch zwei Farben überdrucken, um besondere Effekte zu erzielen.

So sparen Sie Objekte mit einer bestimmten Farbe aus oder überdrucken sie:

    1. Definieren Sie eine Farbe. Weitere Informationen finden Sie unter Definieren und Ändern von Farben und Aufhellungen.

    2. Wenn die Farbe bei der Erstellung von Farbauszügen über andere Farben gedruckt werden soll, führen Sie eine der folgenden Aktionen aus.

    Um alle Objekte dieser Farbe zu überdrucken, wählen Sie "Überdrucken".

    Um alle Objekte dieser Farbe auszusparen, wählen Sie "Aussparen".

So wenden Sie das Aussparen oder Überdrucken auf Objekte an:

    1. Wählen Sie das Objekt aus und öffnen Sie die Werkzeugpalette oder wählen Sie "Grafik > Objekteinstellungen".

    2. Wählen Sie Folgendes im Aufklappmenü "Überdrucken":

    Wenn dieses Objekt darunter liegende Objekte überdrucken soll, wählen Sie "Überdrucken".

    Wenn dieses Objekt darunter liegende Objekte aussparen soll, wählen Sie "Aussparen".

    Wenn dieses Objekt die für die Farbe definierten Einstellungen verwenden soll, wählen Sie "Von Farbe". Dies ist die empfohlene Einstellung.


Farbe / Drucken farbiger Dokumente

Überdrucken von Bildern, die aus anderen Programmen stammen

Beachten Sie die folgenden Sonderfälle, wenn Bilder, die aus anderen Programmen stammen, in FrameMaker andere Objekte überdrucken sollen:

    CMYK-TIFF-Dateien überdrucken Objekte auf Schmuckfarbplatten unter den folgenden Bedingungen: wenn sie als Farbauszüge gedruckt werden, wenn für ihr Attribut "Überdrucken" der Wert "Wahr" festgelegt wurde und wenn ihre Füllung auf "Keine" eingestellt ist.

    EPS-Dateien überdrucken keine anderen Objekte, wenn sie als Farbauszüge ausgegeben werden.


Farbe / Drucken farbiger Dokumente

Anlegen von Fangstellen

In Druckereien kann das Überdrucken zur Kompensierung von Registrierungsfehlern möglicherweise zu einer nicht akzeptablen Farbmischung führen. In solchen Fällen muss statt dessen für das Objekt eine Fangstelle angelegt werden. Eine Fangstelle ist eine Linie, die das oben liegende Objekt umgibt. Diese Linie ist gerade breit genug, um die Farblücke zu füllen und das andere Objekt entlang seiner Aussparung zu überdrucken.

Ohne Fangstelle und mit Fangstelle

Wenn Sie die Fangstellen in Ihrem Dokument von der Druckerei anlegen lassen, ersparen Sie sich das manuelle Anlegen für jedes einzelne Objekt. Außerdem müssen manuell definierte Fangstellen bei einer späteren Nachbearbeitung in der Druckerei eventuell rückgängig gemacht werden.

So legen Sie eine Fangstelle für ein Objekt an:

    1. Erstellen Sie für das oben liegende Objekt eine Begrenzungslinie, indem Sie das Objekt duplizieren und dem Duplikat das Füllmuster "Keine" zuweisen. Das duplizierte Objekt muss exakt über dem Original liegen.

    2. Stellen Sie die Breite der Begrenzungslinie passend für Größe und Umriss des Objekts, Art des Druckpapiers und Genauigkeit der Druckerpresse ein. Erkundigen Sie sich in Ihrer Druckerei nach den geeigneten Linienstärken für diesen Vorgang.

Da eine Linie immer auf der Kante des Objekts zentriert ist, müssen Sie die Linienstärke verdoppeln, die Ihnen Ihre Druckerei mitteilt.

    3. Wählen Sie die Begrenzungslinie aus und wählen Sie dann aus der Werkzeugpalette die Option "Überdrucken".


Farbe / Drucken farbiger Dokumente

Farbauszüge

Beim Drucken von Farbauszügen in FrameMaker legen Sie fest, welche Farben als Schmuckfarben, welche als Prozessfarben und welche überhaupt nicht gedruckt werden sollen. Texte und Grafikobjekte werden für jeden Farbauszug in Schwarz mit Grauschattierungen gedruckt. Diese Schattierungen stellen den Prozentsatz der Farbsättigung dar. Der Farbname jedes Auszugs wird außerhalb der Registermarken gedruckt (vorausgesetzt, die Anzeige der Registermarken ist aktiviert und es ist genügend Platz auf der Seite vorhanden).

Hinweis: Sie erzielen die besten Ergebnisse, wenn Sie CMYK-Farben als Prozessfarben und nicht als Schmuckfarben drucken. Sie können die Zuordnung der Druckplatten im Dialogfenster "Farbauszugeinstellungen" überprüfen (wählen Sie "Datei > Drucken" und klicken Sie auf "Farbauszugeinstellungen").

A: Kombiniertes Bild B: Schwarz-Auszug C: Schmuckfarben-Auszug

Für importierte Farbgrafiken, die das Format CMYK, TIFF, DCS oder EPS haben, werden Farbauszüge angelegt. Außerdem können für Bitmap-Bilder in EPS-Grafiken Farbauszüge gedruckt werden, sofern dies auch mit Adobe Illustrator möglich ist.

Sie können auch Farbauszüge anlegen, indem Sie das Dokument in eine einzelne PostScript-Datei ausgeben und diese zur Weiterbearbeitung an Ihre Druckerei geben. Weitere Informationen finden Sie unter Nachbearbeiten farbiger Dokumente.

(Windows) Stellen Sie sicher, dass Schmuckfarben mit identischen Definitionen auch dieselben Namen besitzen. Schmuckfarben mit identischer Definition und unterschiedlichen Namen werden bei der Ausgabe von Farbauszügen auf unterschiedliche Platten gedruckt. (Auf UNIX-Systemen werden Schmuckfarben mit identischer Definition und unterschiedlichen Namen auf dieselbe Platte gedruckt.)

So erstellen Sie Farbauszüge in FrameMaker:

    1. Stellen Sie sicher, dass die Farben nicht als Grauschattierungen, sondern in Schwarz und Weiß ausgedruckt werden (siehe Druckoptionen).

    2. Wählen Sie "Datei > Drucken".

    3. Wählen Sie eine Option aus dem Aufklappmenü "Registermarken". Sie können zwischen "Normal" und "Tombo" (japanischen Schneidemarken) wählen.

    4. Um zuerst alle Seiten für die erste Druckplatte, dann alle Seiten für die nächste Druckplatte auszugeben, müssen Sie "Exemplarweise" deaktivieren. Aktivieren Sie "Exemplarweise", wenn zunächst alle Platten für die erste Seite und danach alle Platten für die zweite Seite usw. hergestellt werden sollen.

    5. Klicken Sie auf "Farbauszugeinstellungen". Verschieben Sie bei Bedarf die Farbnamen in die entsprechenden Auswahllisten und klicken Sie auf "Zuweisen". Um eine Farbe zu verschieben, wählen Sie sie aus und klicken auf einen Pfeil. Sie können auch auf die Farbe doppelklicken. Wenn Sie alle Farben verschieben möchten, wählen Sie eine Farbe in der Liste aus und klicken bei gedrückter Umschalttaste auf einen Pfeil.

Aufhellungen werden in diesem Dialogfenster nicht angezeigt. Sie werden auf dieselbe Platte wie ihre Grundfarbe gedruckt.

Wenn Ihr Drucker keine Farbauszüge für Prozessfarben ausgeben kann, enthält das Dialogfenster nur die Auswahllisten "Schmuckfarben" und "Nicht drucken". In welcher Auswahlliste jede Farbe per Voreinstellung angezeigt wird, hängt davon ab, wie die Farbe definiert wurde (also von ihrer Einstellung "Drucken als"). Weitere Informationen hierzu finden Sie unter Definieren und Ändern von Farben und Aufhellungen.

    6. Legen Sie die Einstellungen der Halbtonanzeige fest. Weitere Informationen finden Sie unter Definieren von Halbtonanzeigen.

    7. Stellen Sie sicher, dass im Dialogfenster "Drucken" die Option "Farbauszüge drucken" aktiviert ist, legen Sie die übrigen Druckoptionen wie erforderlich fest und klicken Sie auf "Drucken".

Informationen zum Angeben der Beschichtung und Bildbelichtung finden Sie unter Drucken von negativen und gespiegelten Bildern.


Farbe / Drucken farbiger Dokumente

Minimieren der Anzahl von Farbauszügen

Da der professionelle Farbdruck sehr kostenintensiv sein kann, sollten Sie sich überlegen, wie Sie Ihre Dokumente mit möglichst wenigen Farbauszügen drucken können. Wenn Ihre Druckerei beispielsweise eine Druckmethode mit sechs Durchgängen einsetzt, können Sie vierfarbige Prozessauszüge und zwei Schmuckfarben drucken. Wenn vier Druckdurchgänge zur Verfügung stehen, können Sie die Schmuckfarben mit vierfarbigen Prozessauszügen simulieren.

Wenn ein Dokument zwei unterschiedlich benannte Farben mit denselben Farbwerten verwendet, druckt FrameMaker zwei identische Farbauszüge, einen für jeden Farbnamen, wobei auf jedem Auszug beide Farben ausgegeben werden. Um dies zu vermeiden, sollten Sie den Farben in allen Dokumenten und Anwendungen einheitliche Namen geben. Wenn ein Dokument inkonsistent benannte Farben enthält, drucken Sie doppelte Farbauszüge und entfernen Sie eines der Duplikate manuell.

Sie können die Kosten für den Druck von Farbauszügen senken, indem Sie die Ausgabe von Leerseiten unterdrücken. Aktivieren Sie im Dialogfenster "Drucken" die Option "Leere Seiten überspringen" (Windows) bzw. im Dialogfenster "Druckeinstellung für Farbauszüge" die Option "Leere Auszugsseiten auslassen" (UNIX).


Farbe / Drucken farbiger Dokumente

Definieren von Halbtonanzeigen

Auszüge für Prozessfarben werden für jede Farbe mithilfe von Rastern mit schwarzen Punkten gedruckt. Je größer die Punkte sind, um so dunkler ist die gedruckte Farbe. Mit den Einstellungen der Halbtonanzeige legen Sie fest, wie nahe nebeneinander die Punkte angezeigt werden, wie das Raster ausgerichtet ist (Rasterwinkel) und welche Punktform verwendet wird. Informationen hierzu erhalten Sie in Ihrer Drucker-Dokumentation und von Ihrer Druckerei.

So ändern Sie die Einstellungen der Halbtonanzeige:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Wählen Sie "Datei > Drucken", klicken Sie auf "Farbauszugeinstellungen" und dann auf "Halbtonanzeige". Passen Sie die Einstellungen je nach Bedarf an und klicken Sie auf "Zuweisen".

    (UNIX) Bearbeiten Sie den Beginn der Datei ps_prolog, die sich im Ordner $FMHOME/fminit befindet. Diese Datei enthält alle Anweisungen für das Ändern der Druckeinstellungen. Änderungen an dieser Datei treten sofort in Kraft. Wenn sich die Änderungen nicht auf andere Benutzer auswirken sollen, speichern sie diese unter ~/fminit/ps_prolog.


Farbe / Drucken farbiger Dokumente

Drucken von negativen und gespiegelten Bildern

Wenn für die professionelle Weiterbearbeitung Ihrer Dateien die Ausgabe auf Filme erforderlich ist, werden Sie von Ihrer Druckerei unter Umständen aufgefordert, negative Bilder zu drucken, in denen Text und Objekte invertiert sind. Es kann aber auch sein, dass Sie gespiegelte Bilder drucken müssen, wobei sich die Beschichtung unten befindet und das normale Erscheinungsbild der Seiten umgekehrt wird. Die Beschichtung ist der lichtempfindliche Stoff auf der Filmoberfläche.

Hinweis: Die Einstellungen hängen vom verwendeten Treiber ab und stehen möglicherweise nur bei PostScript-Druckertreibern zur Verfügung.

So drucken Sie negative und gespiegelte Bilder:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Wählen Sie "Datei > Druckereinrichtung". Wählen Sie "Eigenschaften", um auf die Druckertreiberoptionen zuzugreifen. Legen Sie mithilfe der entsprechenden Optionen die Einstellungen für negative und gespiegelte Bilder fest.

    (UNIX) Führen Sie die Arbeitsschritte für den Ausdruck von Farbauszügen unter Farbauszüge aus. (Wenn Sie "Beschichtung unten" wählen, wird ein gespiegeltes Bild erstellt).


Farbe

Nachbearbeiten farbiger Dokumente

Sie können für ein Dokument entweder Farbauszüge erstellen oder aber für alle Objekte im Dokument oder Buch Fangstellen anlegen, indem Sie das Dokument in eine PostScript-Datei ausgeben, die dann in Ihrer Druckerei weiterbearbeitet wird. Wenn Sie eine PostScript-Datei auf diese Weise anlegen, werden Anweisungen in die Datei eingebettet. Diese Anweisungen richten sich nach der Adobe Document Structuring Convention (DSC). DSC verbessert den Durchsatz von Programmen, die Fangstellen anlegen und sonstige Nachbearbeitungsfunktionen durchführen. Mithilfe von DSC können Sie die Vorzüge von Produkten nutzen, welche die OPI-Version 1.3 (Open Prepress Interface) unterstützen. OPI reduziert den Hardware-Aufwand, der für die Arbeit mit hochauflösenden Farbbildern erforderlich ist.

Wenn Sie die Fangstellen in Ihrem Dokument von der Druckerei anlegen lassen, ersparen Sie sich das manuelle Anlegen für jedes einzelne Objekt.

Information zum Vorbereiten von PostScript-Dateien für die Nachbearbeitung finden Sie unter Erstellen von PostScript-Dateien.

Hinweis: Bevor Sie mit Ihrer Arbeit beginnen, erkundigen Sie sich bei Ihrer Druckerei, ob bei der Erstellung von PostScript-Dateien spezielle Anweisungen zu befolgen sind.

So verwenden Sie OPI zur Bearbeitung von hochauflösenden Bildern:

    1. Bitten Sie Ihre Druckerei, qualitativ hochwertige Scan-Dateien von Ihren Bildern zu erstellen. Lassen Sie die hochauflösenden Bilder in der Druckerei. Verwenden Sie für Ihre weitere Arbeit die für OPI geeigneten EPS- oder TIFF-Versionen der Bilder mit niedriger Auflösung.

    2. Importieren Sie (durch Referenz oder Kopieren) die Bilder mit der niedrigen Auflösung in Ihr Dokument (siehe Grafikimport mit dem Befehl "Importieren").

    3. Erstellen Sie eine einzelne Druckdatei oder eine Reihe von Druckdateien für ein Buch. Weitere Informationen finden Sie unter Erstellen von PostScript-Dateien.

OPI-erweiterte PostScript-Dateien enthalten Informationen, mit deren Hilfe die professionelle Druck-Software den Platzhalterbildern zur Druckzeit die hochauflösenden Bilder zuordnet.


Farbe

Drucken auf Setzmaschinen (Windows)

Nachstehend erhalten Sie einige Hinweise zur Ausgabe auf Linotronic-Setzmaschinen unter Windows:

    Einige Linotronic-Setzmaschinen platzieren automatisch Registermarken auf die Seite. Prüfen Sie gemeinsam mit Ihrer Druckerei, ob Sie beim Drucken die Einstellung "Registermarken" benötigen.

    Nicht alle Linotronic-Modelle unterstützen Vorschauseiten. Testen Sie verschiedene Vorschaueinstellungen, um die optimale Einstellung zu finden. Einige Linotronic-Modelle drucken 1 x 2-Vorschauseiten korrekt, nicht jedoch 2 x 2-Vorschauseiten.

    Einige Linotronic-Treiber ermöglichen Ihnen nicht, ein spezielles Papierformat einzugeben, selbst wenn Sie im Aufklappmenü "Papierformat" die Option "Benutzerdefinierte Größe" gewählt haben. Um ein benutzerdefiniertes Papierformat zu verwenden, klicken Sie mit der rechten Maustaste auf den Linotronic-Treiber und wählen "Eigenschaften". Klicken Sie auf die Registerkarte "Papier" und wählen Sie dann das Symbol für das spezielle Papierformat aus der Auswahlliste mit Symbolen.


Seitenlayout und Schablonen

Seitenlayout

Ändern des grundlegenden Seitenlayouts eines Dokuments

Erstellen und Bearbeiten spezieller Vorgabeseiten

Ausrichten von Text über mehrere Spalten

Dokumente mit mehreren Textflüssen

Arbeiten mit Referenzseiten

Schablonen

Verwenden von Schablonen

Erstellen von Schablonen

Organisieren von Schablonen in einem Ordner

Erstellen von Schablonen für generierte Dateien

Erstellen von Schablonen für bedingten Text

Ändern von Schablonen für leeres Papier und Textdateien

Importieren und Aktualisieren von Formaten

Einstellungen für Import und Aktualisierung


Seitenlayout und Schablonen

Seitenlayout

Wenn Sie bei der Erstellung von Dokumenten vorgefertigte Schablonen verwenden, ist das grundlegende Seitenlayout bereits festgelegt. Zwar werden Sie einer Arbeitsseite gelegentlich eine spezielle Vorgabeseite zuweisen (z. B. zur Gestaltung einer ersten Seite), die hier beschriebenen Layout-Techniken werden Sie jedoch in der Regel nicht verwenden müssen.

Für die Erstellung einer Schablone sind normalerweise verschiedene Typen von Seitenlayouts erforderlich. Sie können beispielsweise verschiedene Layouts für die erste Seite eines Kapitels erstellen, für eine gedrehte Seite oder eine Seite mit einer abweichenden Spaltenzahl. Eine weitere Möglichkeit wäre die Erstellung von Layouts für Dokumente mit mehreren Textflüssen.

FrameMaker-Dokumente enthalten drei Arten von Seiten, mit deren Hilfe Sie Ihr Seitenlayout einrichten können.

    Auf einer Vorgabeseite sind das Seitenlayout und der Hintergrundtext für Arbeitsseiten definiert (z. B. Kopf- und Fußzeilen).

    Arbeitsseiten enthalten den Hintergrundtext und Grafiken der zugehörigen Vorgabeseite sowie den Inhalt des Dokuments.

    Referenzseiten enthalten Mustergrafiken, die Sie im gesamten Dokument verwenden können.

A: Vorgabeseiten: Erste und rechte Seite B: Arbeitsseiten: Erste Seite des Kapitels und rechte Seite C: Referenzseite


Seitenlayout und Schablonen / Seitenlayout

Vorgabeseiten

FrameMaker verwendet Vorgabeseiten, um das Seitenlayout eines Dokuments zu verwalten. Ein doppelseitiges Dokument besitzt mindestens zwei Vorgabeseiten: eine für die rechte und eine für die linke Seite. Für ein einseitiges Dokument wird dagegen nur die rechte Vorgabeseite benötigt. Dokumente können auch spezielle Vorgabeseiten für bestimmte Seitenarten enthalten. Außerdem besteht die Möglichkeit, Layouts für eine einmalige Verwendung direkt auf den Arbeitsseiten zu definieren.

Zum grundlegenden Layout eines Dokuments gehören folgende Komponenten: das Seitenformat, die Seitenränder, die Anzahl der Spalten pro Seite und die Art der Seitennummerierung. Wenn das Dokument ein symmetrisches Layout hat (wenn also gegenüberliegende Seiten identische obere, untere, innere und äußere Ränder haben) und keine anderen Vorgabeseiten außer den von FrameMaker bereitgestellten linken und rechten Standardseiten verwendet, können Sie das grundlegende Layout ändern, ohne die Vorgabeseiten anzuzeigen.

Ist das Seitenlayout komplexer oder werden andere Gestaltungselemente wie Kopf- und Fußzeilen benötigt, muss direkt auf den Vorgabeseiten gearbeitet werden. Sie können an jeder beliebigen Stelle der Vorgabeseite Grafiken (z. B. Linien, Rechtecke oder Firmenlogos) zeichnen oder importieren und Text eingeben. Grafiken und Text werden später auf den Arbeitsseiten als Hintergrund dargestellt, und zwar exakt so, wie sie auf der Vorgabeseite definiert wurden.

Vorgabeseiten und Arbeitsseiten

Vorgabeseiten können zwei Arten von Textrahmen enthalten:

    Ein Vorgabetextrahmen enthält einen gekennzeichneten Textfluss, d. h. einen Textfluss mit einem Namen. Wenn Sie eine Arbeitsseite hinzufügen, wird der Vorgabetextrahmen in die neue Arbeitsseite kopiert. Den Text des Dokuments geben Sie dann in diesen Rahmen auf der Arbeitsseite ein. Es ist auch möglich, Text auf der Vorgabeseite in den Vorgabetextrahmen einzugeben. Dieser Text wird auf den Arbeitsseiten jedoch nicht angezeigt.

    Ein Hintergrundtextrahmen enthält einen nicht gekennzeichneten Textfluss, d. h. einen Textfluss ohne einen Namen. Der Inhalt dieses Rahmens wird auf den entsprechenden Arbeitsseiten angezeigt, kann aber nur auf der Vorgabeseite bearbeitet werden. Hintergrundtextrahmen werden häufig zur Definition von Kopf- und Fußzeilen verwendet.

Vorgabeseite
A: Hintergrundtextrahmen ohne Typ
B: Vorgabetextrahmen

Wenn Sie Text und Abbildungen auf den Arbeitsseiten eines Dokuments hinzufügen, erstellt FrameMaker bei Bedarf weitere Arbeitsseiten und verwendet automatisch das Seitenlayout der linken oder rechten Vorgabeseite.

A: Auf Arbeitsseiten schreiben Sie in einem Textrahmen, der eine Kopie des Vorgabetextrahmens ist.


Seitenlayout und Schablonen / Seitenlayout

Textflüsse und Textflusstypen

Unter einem Textfluss versteht man eine Folge von Textrahmen, die miteinander verkettet sind und dafür sorgen, dass der Text durch ein Dokument fließt. Die meisten Dokumente enthalten nur einen Textfluss, der sich von der ersten bis zur letzten Seite erstreckt. In diesem Fall sorgt FrameMaker für eine automatische Verkettung der Textrahmen. Es gibt aber auch Dokumente, die mehrere Textflüsse enthalten. In diesen Dokumenten legen Sie den Textfluss fest, indem Sie die Textrahmen selbst verketten. Dies gilt beispielsweise für Infoblätter, in denen ein Artikel auf einer Seite beginnt und auf einer späteren Seite fortgesetzt wird, wobei die Artikel auf den dazwischenliegenden Seiten übersprungen werden (siehe Dokumente mit mehreren Textflüssen).

Der Textflusstyp des aktuellen Textrahmens wird im Namensbereich der Statuszeile angezeigt. In neuen, leeren Dokumenten wird der Textflusstyp A verwendet.

Namensbereich in der Statuszeile


Seitenlayout und Schablonen

Ändern des grundlegenden Seitenlayouts eines Dokuments

Sie können grundlegende Änderungen am Seitenlayout eines Dokuments direkt auf einer Arbeitsseite vornehmen, z. B. das Seitenformat ändern, das Dokument als einseitig oder doppelseitig definieren oder die Anzahl der Spalten ändern. Bei jeder dieser Änderungen aktualisiert FrameMaker automatisch die linke und die rechte Vorgabeseite und das Layout aller Arbeitsseiten, die diese Vorgabeseiten verwenden. Wenn in diesen Arbeitsseiten irreguläre Layouts enthalten sind (siehe Irreguläre Layouts), werden Sie aufgefordert, die Aktualisierung zu bestätigen.

Falls Ihr Dokument eine weitere Vorgabeseite verwendet (z. B. für die erste Seite), müssen Änderungen am Layout auf dieser Vorgabeseite vorgenommen werden. Weitere Informationen finden Sie unter Ändern des Seitenlayouts für bestimmte Seiten, Erstellen und Bearbeiten spezieller Vorgabeseiten und Zuweisen von Vorgabeseiten zu Arbeitsseiten.


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments

Ändern des Seitenformats

Für das Seitenformat eines Dokuments stehen Ihnen zahlreiche Standardformate zur Auswahl. Sie können aber auch ein spezielles Format definieren. FrameMaker passt nach jeder Änderung des Seitenformats die Größe der Textrahmen auf der linken und der rechten Vorgabeseite (jedoch nicht auf speziellen Vorgabeseiten) so an, dass die aktuellen Seitenränder beibehalten werden.

Bei einer Änderung des Seitenformats werden die Seitenränder beibehalten.

Wenn das Dokument spezielle Vorgabeseiten enthält, verhindert FrameMaker den Wechsel zu einem Seitenformat, das die Textrahmen dieser Vorgabeseiten nicht aufnehmen kann.

So ändern Sie das Seitenformat:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Seitenlayout > Format".

    3. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie ein Standardformat aus dem Aufklappmenü "Format". In den Textfeldern "Breite" und "Höhe" werden die korrekten Maße angezeigt.

    Geben Sie die Maße in die Textfelder "Breite" und "Höhe" ein. Im Aufklappmenü wird Spezial angezeigt. Das angegebene spezielle Seitenformat kann je nach den Randeinstellungen sehr klein, aber auch sehr groß sein (ca. 548 x 548 cm).

    4. Klicken Sie auf "Zuweisen".


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments

Ändern des Seitenumbruchs

Sie können ein einseitiges Dokument in ein doppelseitiges Dokument ändern (und umgekehrt). Beim Definieren eines doppelseitigen Dokuments legen Sie fest, ob die erste Seite eine linke oder eine rechte Seite ist.

Einseitige Dokumente

Doppelseitige Dokumente

So ändern Sie den Seitenumbruch:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Seitenlayout > Seitenumbruch".

    3. Klicken Sie auf eine der Optionen unter "Seitenumbruch". Bei einem doppelseitigen Dokument geben Sie an, ob die erste Seite eine linke oder eine rechte Seite sein soll. Wenn Sie den Seitenumbruch für ein Buch festlegen, wählen Sie "Aus Datei einlesen", wenn die aktuelle Position der Seite in der Datei verwendet werden soll. Um eine Leerseite zu unterdrücken, wählen Sie "Nächste verfügbare Seite".

Je nach gewählter Option wird der vorherigen Datei im Buch unter Umständen eine Leerseite hinzugefügt, damit das Dokument auf der angegebenen Seite beginnt. Weitere Informationen finden Sie unter Hinzufügen und Löschen leerer Seiten.

    4. Klicken Sie auf "Zuweisen". Wenn das Dokument spezielle Vorgabeseiten oder irreguläre Layouts enthält, werden Sie gefragt, wie Sie fortfahren wollen.


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments

Hinzufügen und Löschen leerer Seiten

Sie können festlegen, ob ein Dokument eine gerade oder ungerade Seitenanzahl aufweisen soll. Falls erforderlich, fügt FrameMaker am Ende des Dokuments eine Leerseite hinzu, um einen korrekten Seitenumbruch vorzunehmen.

Andererseits können durch die Bearbeitung eines Dokuments unerwünschte Leerseiten am Dokumentende entstehen. Sie können FrameMaker anweisen, diese Leerseiten bei jedem Speichern oder Drucken des Dokuments zu löschen.

FrameMaker löscht eine leere Seite nur, wenn sie die linke oder rechte Vorgabeseite verwendet und keinen Textflussbeginn und keine irregulären Layouts enthält. (Informationen über irreguläre Layouts finden Sie unter Irreguläre Layouts.) Eine Seite, die einen leeren Absatz enthält, ansonsten aber leer ist, wird nicht gelöscht.

Wenn Sie den Seitenumbruch eines Dokuments, das Teil eines Buches ist, im Dokumentfenster ändern, werden die Einstellungen möglicherweise überschrieben, wenn Sie das Buch aktualisieren. Sie können den korrekten Seitenumbruch im Buch sicherstellen, indem Sie die Einstellungen eines Dokuments im Buchfenster ändern.

So fügen Sie beim Speichern bzw. Drucken eine leere Seite hinzu oder löschen eine leere Seite:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Seitenlayout > Seitenumbruch".

    3. Wählen Sie aus dem Aufklappmenü "Vor Sichern & Drucken" eine Option und klicken Sie auf "Zuweisen".

Wenn die Leerseiten nicht wie erwartet hinzugefügt oder gelöscht werden, sollten Sie sich vergewissern, dass alle Seiten des Dokuments automatisch verkettet sind (siehe Die Einstellung "Automatische Verkettung").


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments

Ändern der Seitenränder und der Spaltenanzahl

Der Rand ist der Abstand zwischen dem Blattrand und dem Textrahmen. Bei einem einseitigen Dokument legen Sie den oberen, unteren, linken und rechten Rand des Textrahmens fest. Bei einem doppelseitigen Dokument legen Sie den oberen, unteren, inneren und äußeren Rand fest, um ein symmetrisches Erscheinungsbild zu erzielen.

Symmetrisches Layout

Um einen asymmetrischen linken und rechten Rand festzulegen, ändern Sie die Textrahmen direkt auf den Vorgabeseiten. Sie können z. B. die Textrahmen sowohl auf der linken als auch auf der rechten Seite so anordnen, dass sie jeweils rechts auf der Seite angezeigt werden und links ein breiter Rand bleibt. Informationen über die direkte Bearbeitung von Vorgabeseiten finden Sie unter Ändern des Seitenlayouts für bestimmte Seiten.

Asymmetrisches Layout

Ein Textrahmen kann zwei oder mehr Spalten gleicher Breite enthalten, die durch einen einheitlichen Abstand voneinander getrennt sind. Wenn Sie ein mehrspaltiges Layout erstellen wollen, in dem die Spaltenbreiten und -abstände unterschiedlich sind, verwenden Sie für jede Textspalte einen Textrahmen und ordnen die Textrahmen nacheinander an. Sie können alle Textrahmen zeichnen oder einen Textrahmen nach Ihren Vorstellungen einrichten und ihn dann duplizieren. Informationen hierzu finden Sie unter Einfügen von Vorgabetextrahmen auf Vorgabeseiten und Einfügen von Textrahmen auf Arbeitsseiten.

So ändern Sie die Ränder und die Spaltenanzahl:

    1. Platzieren Sie die Einfügemarke im Haupttextfluss, oder klicken Sie in den Seitenrand. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Seitenlayout > Spaltenlayout".

Bei einem asymmetrischen Layout (wenn z. B. die Anzahl der Spalten oder der äußere und innere Rand auf der linken und der rechten Vorgabeseite nicht identisch sind) werden Sie gefragt, ob Sie den Vorgang fortsetzen wollen. Wenn Sie das asymmetrische Layout beibehalten wollen, müssen Sie die Änderungen direkt auf den Vorgabeseiten vornehmen (siehe Ändern des Seitenlayouts für bestimmte Seiten).

    3. Um die Ränder zu ändern, geben Sie unter "Ränder" die gewünschten Werte ein. Die Breite der einzelnen Spalten ergibt sich aus den Rändern und dem Abstand zwischen den Spalten.

    4. Wenn Sie die Anzahl der Spalten oder den Abstand zwischen den Spalten ändern wollen, geben Sie unter "Spalten" die neuen Werte ein.

Alle Spalten haben dieselbe Breite und einen einheitlichen Abstand. Wie Sie ein mehrspaltiges Layout erstellen, das unterschiedlich breite Spalten enthält (oder unterschiedlich große Abstände zwischen den Spalten aufweist), erfahren Sie unter Einfügen von Vorgabetextrahmen auf Vorgabeseiten.

    5. Klicken Sie auf "Gesamten Textfluss aktualisieren". Wenn die neue Spaltenbreite so klein ist, dass bestimmte verankerte Rahmen oder Tabellen darin keinen Platz mehr finden, werden Sie gefragt, ob Sie fortfahren wollen. Wenn Sie auf "OK" klicken, können Sie die Größe der Tabellen und Rahmen manuell ändern.


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments

Anzeigen von Vorgabeseiten

Bei der Arbeit mit Vorgabeseiten müssen Sie zwischen Vorgabe- und Arbeitsseiten wechseln. Befindet sich eine Vorgabeseite am Bildschirm, werden ihr Name und die Gesamtzahl der Vorgabeseiten des Dokuments im Seitenstatus-Bereich der Statuszeile angezeigt.

Seitenstatus-Bereich der Statuszeile

So zeigen Sie Vorgabeseiten an:

Wählen Sie "Darstellung > Vorgabeseiten". Die Vorgabeseite für die aktuelle Arbeitsseite wird angezeigt. Text-und Spaltenrahmen sind sichtbar.

So zeigen Sie weitere Vorgabeseiten an, wenn sich bereits eine Vorgabeseite am Bildschirm befindet:

Führen Sie eine der folgenden Aktionen aus:

    Klicken Sie auf die Schaltfläche "Nächste Seite" [image] oder "Vorherige Seite" [image] .

    Drücken Sie die Bild-Auf- oder die Bild-Ab-Taste.

    Verwenden Sie den Rollbalken.

So wechseln Sie von Vorgabeseiten zurück zu Arbeitsseiten:

Wählen Sie "Darstellung > Arbeitsseiten". Es wird wieder die Arbeitsseite eingeblendet, die zuletzt angezeigt wurde. Wenn FrameMaker feststellt, dass eine Arbeitsseite irreguläre Layouts enthält (siehe Irreguläre Layouts), werden Sie gefragt, was mit diesen geschehen soll.


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments

Kopfzeilen, Fußzeilen und sonstiger Hintergrundtext

Sie erstellen Kopf- und Fußzeilen, indem Sie eine Vorgabeseite anzeigen und den gewünschten Text in Hintergrundtextrahmen eingeben. Der Inhalt der Hintergrundtextrahmen wird auf den Arbeitsseiten angezeigt, Sie können ihn aber nur auf den Vorgabeseiten ändern.

Textrahmen für Kopf- und Fußzeilen auf Vorgabeseite

Text- und Fußzeilen können die Seitennummer, das Datum, die Nummer und den Titel des Kapitels, die Nummer und den Titel des Abschnitts, den Autor, die Revisionsnummer und die Entwurfsversion (z. B. vorläufig oder endgültig) enthalten.

Der Text von Kopf- und Fußzeilen kann wie jeder andere Absatztext bearbeitet werden. Sie können z. B. Absatz- und Zeichenformate zuweisen, Tabulatorstopps einfügen oder entfernen und Grafikelemente wie z. B. eine Linie über oder unter dem Text hinzufügen. Außerdem ist es möglich, Systemvariablen einzufügen, um z. B. die Seitennummer oder das aktuelle Datum anzuzeigen. Auch Größe und Position der Textrahmen für Kopf- und Fußzeilen können geändert werden. Wenn Sie diese Textrahmen auf einer Vorgabeseite ändern, aktualisiert FrameMaker automatisch alle Arbeitsseiten, die diese Vorgabeseite verwenden.

Sie können auch anderen Hintergrundtext in eine Vorgabeseite aufnehmen. Beispielsweise ist der Kopf der Fax-Schablone von FrameMaker in einem Hintergrundtextrahmen auf der Vorgabeseite enthalten.

A: Kopf der Fax-Schablone

Weitere Informationen über die Erstellung von Kopf- und Fußzeilen finden Sie unter Eingeben von Kopf- und Fußzeilentext und Aufnehmen von Kapitelnummern in Kopf- oder Fußzeilen.


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments / Kopfzeilen, Fußzeilen und sonstiger Hintergrundtext

Erstellen und Ändern von Hintergrundtextrahmen

Wenn Sie ein neues, leeres Dokument erstellen, legt FrameMaker Hintergrundtextrahmen für Kopf- und Fußzeilen auf der linken und der rechten Vorgabeseite an. Um Ihnen das Hinzufügen von zentrierten und rechtsbündig ausgerichteten Informationen zu erleichtern, fügt FrameMaker automatisch zentrierte und rechtsbündige Tabulatorstopps in der Mitte bzw. am rechten Rand des Rahmens ein. Sie können Hintergrundtextrahmen für zusätzliche Informationen in der Kopf- und Fußzeile oder für sonstigen Hintergrundtext zeichnen.

Hinweis: Mit dem Textzeilen-Werkzeug ist es möglich, einzelne Hintergrundzeilen zu erstellen. Sie können in diesen Text jedoch weder Variablen einfügen, noch können Sie ihm Absatzformate zuweisen. Informationen über das Erstellen von Textzeilen finden Sie unter Grafiken und Text.

So fügen Sie auf einer Vorgabeseite einen Hintergrundtextrahmen ein:

    1. Zeichnen Sie den Textrahmen mithilfe des Textrahmen-Werkzeugs (siehe Grafiken und Text).

    2. Klicken Sie im Dialogfenster "Neuen Textrahmen einfügen" zunächst auf "Hintergrundtext" und anschließend auf "Einfügen". Der neue Textrahmen hat (wie auch alle anderen Textrahmen für Hintergrundtext auf einer Vorgabeseite) keinen Typ.

    3. Doppelklicken Sie in den Textrahmen, um die Einfügemarke zu platzieren. Fügen Sie dann die Kopfzeile, die Fußzeile oder den Hintergrundtext ein.

So vergrößern, verkleinern oder verschieben Sie einen Hintergrundtextrahmen:

    1. Wählen Sie den Textrahmen aus, indem Sie bei gedrückter Strg- bzw. Control-Taste auf den Textrahmen klicken.

    2. Führen Sie einen der folgenden Schritte aus:

    Um die Größe des Textrahmens zu ändern, ziehen Sie einen Auswahlpunkt. Weitere Methoden finden Sie unter Ändern der Größe von Objekten.

    Um den Textrahmen zu verschieben, ziehen Sie seinen Rahmen (keinen Auswahlpunkt). Weitere Methoden finden Sie unter Verschieben von Objekten.


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments / Kopfzeilen, Fußzeilen und sonstiger Hintergrundtext

Eingeben von Kopf- und Fußzeilentext

Sie können einfache Kopf- und Fußzeilen erstellen, indem Sie Text in die Kopf- und Fußzeilentextrahmen auf den Vorgabeseiten eingeben. Sie können außerdem Elemente wie die aktuelle Kapitel- und Seitennummer, die Gesamtzahl der Seiten oder das aktuelle Datum aufnehmen. FrameMaker zeigt in der Kopf- bzw. Fußzeile auf der Vorgabeseite eine Systemvariable an, für die auf den entsprechenden Arbeitsseiten der korrekte Wert eingesetzt wird.

Sie können laufende Kopf- und Fußzeilen mit seitenbezogenen Informationen definieren. In der folgenden Abbildung enthält die laufende Kopfzeile die aktuelle Abschnittsüberschrift, während in der Fußzeile die Seitennummer und der Text angezeigt werden, die direkt in den Hintergrundtextrahmen eingegeben wurden.

Laufende Kopf- und Fußzeilen

Sie erstellen laufende Kopf- und Fußzeilen, indem Sie auf den Vorgabeseiten entsprechende Systemvariablen in Hintergrundtextrahmen eingeben. Informationen über die Einrichtung derartiger Variablen finden Sie unter Erstellen von Variablen für laufende Kopf- und Fußzeilen.

So geben Sie Text, Seitennummern, Datumsangaben und sonstige Informationen ein:

    1. Klicken Sie auf einer Vorgabeseite auf die Kopf- oder Fußzeile, in die Sie die Information einfügen möchten.

    2. Führen Sie einen der folgenden Schritte aus:

    Fügen Sie statischen Text ein, indem Sie ihn einfach eingeben.

    Um eine Band- oder Kapitelnummer einzufügen, wählen Sie "Spezial > Variable". Doppelklicken Sie in der Variablenliste auf "Bandnummer" oder "Kapitelnummer" und klicken Sie dann auf "Einfügen". Weitere Informationen über die Nummerierung finden Sie unter Festlegen der Nummerierung von Dokumenten und Seiten.

    Um die aktuelle Seitennummer einzufügen, wählen Sie "Format > Kopf- und Fußzeilen > Seitennummer einfügen". Ergänzen Sie die Seitennummer durch Text, um z. B. eine Nummerierung wie Seite 1 zu erzeugen. Weitere Informationen über Nummerierungsarten (z. B. numerisch, römisch oder alphabetisch) finden Sie unter Festlegen der Nummerierung von Dokumenten und Seiten.

    Um die Seitenanzahl einzufügen, wählen Sie "Format > Kopf- und Fußzeilen > Seitenanzahl einfügen". Zusammen mit Seitennummer und Text können Sie auf diese Weise eine Nummerierung wie Seite 3 von 4 erzeugen.

    Für die Eingabe des aktuellen Datums wählen Sie "Format > Kopf- und Fußzeilen > Aktuelles Datum einfügen". FrameMaker aktualisiert das Datum bei jeder Neuanzeige der Seite – z. B. wenn Sie blättern, zoomen oder zu dieser Seite wechseln.

    Um eine andere Variable hinzuzufügen, wählen Sie "Format > Kopf- und Fußzeilen > Sonstiges einfügen" und geben Sie anschließend die gewünschte Variable an. Weitere Informationen finden Sie unter Einfügen von Variablen.

Um Informationen in Kopf- und Fußzeilen zentriert auszurichten, drücken Sie Tab, um die Eingabemarke an den mittleren Tabulatorstopp zu bewegen. Um Informationen rechts auszurichten, drücken Sie Tab erneut, um die Einfügemarke an den rechten Tabulatorstopp zu bewegen.


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments

Ändern des Seitenlayouts für bestimmte Seiten

In den vorhergehenden Abschnitten wurde beschrieben, wie Sie das grundlegende Layout der linken und rechten Vorgabeseite ändern und damit alle Arbeitsseiten beeinflussen, die diese Vorgabeseiten verwenden. Die beschriebenen Techniken gelten jedoch nur für ein symmetrisches Seitenlayout, d. h. wenn auf den gegenüberliegenden Seiten dieselben Einstellungen für Spaltenbreite, Spaltenanzahl, oberen, unteren, inneren und äußeren Rand verwendet werden.

Durch Hinzufügen oder Ändern von Textrahmen direkt auf den Arbeitsseiten können Sie ein asymmetrisches Layout erzeugen. Beispielsweise könnten Sie auf der linken und rechten Seite eines Dokuments einen linken Rand benötigen, der breiter als der rechte ist. Denkbar wären auch Dokumente, die auf der linken Seite ein einspaltiges und auf der rechten Seite ein zweispaltiges Layout haben. Sie könnten sogar ein Layout definieren, das Spalten mit verschiedener Breite oder unterschiedlichem Abstand aufweist. Ein solches Layout können Sie erzeugen, indem Sie für jede Spalte einen anderen Textrahmen verwenden.


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments / Ändern des Seitenlayouts für bestimmte Seiten

Irreguläre Layouts

Wenn Sie Änderungen an einer Vorgabeseite vornehmen, aktualisiert FrameMaker automatisch alle Arbeitsseiten, die diese Vorgabeseite verwenden. Wenn Sie Änderungen auf einer Arbeitsseite vornehmen (z. B. durch die Änderung der Spaltenanzahl, des Spaltenabstands oder der Ränder), setzen Sie das Layout der Vorgabeseite außer Kraft und erzeugen ein so genanntes irreguläres Layout. Nach einer derartigen Änderung können Sie wie folgt vorgehen:

    Aktualisieren Sie die Vorgabeseiten und alle entsprechenden Arbeitsseiten mit den Änderungen (siehe Aktualisieren der Layouts von Arbeits- und Vorgabeseiten).

    Erstellen Sie eine neue Vorgabeseite, die auf dem geänderten Layout der Arbeitsseite basiert (siehe Erstellen spezieller Vorgabeseiten).

    Führen Sie keinen dieser Schritte aus. Das irreguläre Layout wird dadurch zum einmaligen Seitenlayout (siehe Erstellen eines speziellen Seitenlayouts für den einmaligen Gebrauch).


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments / Ändern des Seitenlayouts für bestimmte Seiten

Ändern der Ränder und des Spaltenlayouts auf bestimmten Seiten

Mit den folgenden Arbeitsschritten erzeugen Sie entweder ein einspaltiges Layout oder ein mehrspaltiges Layout mit gleicher Spaltenbreite.

Wenn Sie ein mehrspaltiges Layout mit unterschiedlichen Spaltenbreiten oder Spaltenabständen benötigen, müssen Sie für jede Spalte einen eigenen Textrahmen erstellen und die einzelnen Rahmen an der gewünschten Stelle platzieren. Informationen hierzu finden Sie unter Einfügen von Vorgabetextrahmen auf Vorgabeseiten und Einfügen von Textrahmen auf Arbeitsseiten.

So ändern Sie die Ränder und das Spaltenlayout auf einer Seite:

    1. Wählen Sie den Textrahmen aus, dessen Ränder Sie ändern möchten, indem Sie bei gedrückter Strg- bzw. Control-Taste auf den Rahmen klicken.

    2. Wählen Sie "Format > Spezielles Layout > Spezieller Textrahmen".

    3. Führen Sie folgende Schritte durch:

    Um die Ränder zu ändern, geben Sie die neue Größe und Position unter "Größe (nicht gedreht)" und "Abstand von" an. Mit "Oben" und "Links" legen Sie den oberen bzw. linken Rand fest. Der untere und der rechte Rand ergeben sich aus der Breite und der Höhe des Textrahmens.

    Ändern Sie die Spaltenanzahl oder den Abstand zwischen den Spalten, indem Sie die betreffenden Werte unter "Spalten" eingeben.

    4. Klicken Sie auf "Zuweisen".

Sie können die Ränder auch ändern, indem Sie einen Textrahmen auswählen und einen Auswahlpunkt verschieben. Wenn Sie die Größe eines mehrspaltigen Textrahmens ändern, passen sich die Spaltenbreiten an den Textrahmen an, der Spaltenabstand bleibt jedoch unverändert.


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments / Ändern des Seitenlayouts für bestimmte Seiten

Einfügen von Vorgabetextrahmen auf Vorgabeseiten

Wenn Sie auf einer Vorgabeseite Textspalten mit unterschiedlicher Breite benötigen oder das Layout für ein Infoblatt oder ein Dokument einrichten, in dem die Artikel nicht fortlaufend von der ersten bis zur letzten Seite fließen sollen, müssen Sie für jede Spalte einen eigenen Textrahmen definieren. Beispielsweise würden Sie für eine Seite mit zwei Spalten unterschiedlicher Breite einen zweiten Vorgabetextrahmen hinzufügen. Sie können einen Vorgabetextrahmen hinzufügen, indem Sie ihn neu zeichnen oder einen vorhandenen Rahmen kopieren.

So fügen Sie einer Vorgabeseite einen Vorgabetextrahmen hinzu:

    1. Verwenden Sie zum Zeichnen des Textrahmens das Textrahmen-Werkzeug aus der Werkzeugpalette (siehe Grafiken und Text). Wenn Sie mehrere Rahmen benötigen, zeichnen Sie diese in der Reihenfolge, in der sie miteinander verkettet werden sollen.

    2. Klicken Sie im Dialogfenster "Neuen Textrahmen einfügen" auf "Schablone für Textrahmen auf Arbeitsseite" und wählen Sie einen Typ aus dem Aufklappmenü "Textflusstyp". Wählen Sie den aktuellen Textflusstyp aus, es sei denn, Sie definieren einen Textrahmen für einen anderen Textfluss in einem Dokument mit mehreren Textflüssen.

    3. Geben Sie unter "Spalten" die Anzahl der Spalten im Textrahmen an und legen Sie (bei mehreren Spalten) den Abstand zwischen benachbarten Spalten fest. Wenn Sie ein Layout mit unterschiedlich breiten Spalten definieren, müssen Sie die Spaltenanzahl auf 1 einstellen, da für jede Spalte ein eigener Textrahmen verwendet wird.

    4. Klicken Sie auf "Hinzufügen".

    5. Verschieben Sie den Textrahmen nach Bedarf.

Um einen vorhandenen Textrahmen zu kopieren, wählen Sie ihn aus. Wählen Sie anschließend "Bearbeiten > Kopieren" und dann "Bearbeiten > Einfügen". FrameMaker kopiert den Textrahmen mit seinem Inhalt und seinen Einstellungen (einschließlich des Textflusstyps).


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments / Ändern des Seitenlayouts für bestimmte Seiten

Einfügen von Textrahmen auf Arbeitsseiten

Wenn Sie einen Textrahmen auf einer Arbeitsseite zeichnen, werden Sie aufgefordert, die Anzahl der Spalten und den Abstand zwischen den Spalten anzugeben. FrameMaker weist jedoch keinen Textfluss zu und verkettet den Textrahmen nicht mit den Textrahmen, die bereits auf der Seite vorhanden sind. Damit der neue Textrahmen in den Textfluss des Dokuments integriert wird, muss er mit dem Textfluss verkettet werden (siehe Verketten von Textrahmen). Ist der neue Textrahmen der erste Rahmen im Textfluss, wählen Sie "Automatische Verkettung", damit neue Seiten bei Bedarf automatisch hinzugefügt werden (siehe Die Einstellung "Automatische Verkettung").


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments / Ändern des Seitenlayouts für bestimmte Seiten

Aktualisieren der Layouts von Arbeits- und Vorgabeseiten

Sie können die Vorgabetextrahmen mehrerer Vorgabeseiten ändern und dann alle Arbeitsseiten gleichzeitig aktualisieren. Wenn dagegen Änderungen am Spaltenlayout einer Arbeitsseite vorgenommen wurden, müssen Sie zunächst die entsprechende Vorgabeseite aktualisieren.

FrameMaker prüft vor der Aktualisierung, ob Arbeitsseiten Spaltenlayouts enthalten, die ihre Vorgabeseiten außer Kraft setzen (siehe Irreguläre Layouts). Für Seiten mit irregulären Layouts können Sie festlegen, ob diese beibehalten werden sollen.

So aktualisieren Sie Arbeitsseiten mit Änderungen auf Vorgabeseiten:

    1. Zeigen Sie nach der Änderung des Layouts einer Vorgabeseite wieder die Arbeitsseiten an.

    2. Wenn FrameMaker ein Meldungsfenster einblendet, legen Sie fest, ob irreguläre Layouts beibehalten oder entfernt werden sollen. Klicken Sie anschließend auf "Fortfahren". Wenn Sie die irregulären Layouts beibehalten, aktualisiert FrameMaker die betreffenden Arbeitsseiten mit dem Hintergrundtext und den Hintergrundgrafiken der Vorgabeseite.

So aktualisieren Sie eine Vorgabeseite mit Änderungen auf Arbeitsseiten:

    1. Wählen Sie "Format > Seitenlayout > Spaltenlayout aktualisieren". Sie werden aufgefordert, die Aktualisierung der Vorgabeseite und der Arbeitsseiten zu bestätigen.

    2. Klicken Sie auf "Aktualisieren".

    3. Wenn FrameMaker ein entsprechendes Meldungsfenster anzeigt, geben Sie an, ob irreguläre Layouts auf den zu aktualisierenden Seiten beibehalten oder entfernt werden sollen. Klicken Sie anschließend auf "Fortfahren".


Seitenlayout und Schablonen / Ändern des grundlegenden Seitenlayouts eines Dokuments / Ändern des Seitenlayouts für bestimmte Seiten

Erstellen eines speziellen Seitenlayouts für den einmaligen Gebrauch

Manchmal muss nur das Layout einer einzigen Arbeitsseite im Dokument geändert werden. Es könnte z. B. erforderlich sein, einen Rahmen zu verlängern, um Platz für eine zusätzliche Textzeile zu schaffen, oder einen Textrahmen zu verkleinern, damit eine Grafik direkt auf einer Arbeitsseite platziert werden kann. Wenn Sie das Spaltenlayout einer Arbeitsseite ändern, ohne die entsprechende Vorgabeseite zu aktualisieren, erzeugen Sie ein sogenanntes irreguläres Layout.

Informationen über die Änderung des Spaltenlayouts auf einer Arbeitsseite finden Sie unter Ändern der Ränder und des Spaltenlayouts auf bestimmten Seiten. Informationen über das Hinzufügen eines Textrahmens finden Sie unter Einfügen von Textrahmen auf Arbeitsseiten.


Seitenlayout und Schablonen

Erstellen und Bearbeiten spezieller Vorgabeseiten

Für Ihre Dokumente benötigen Sie möglicherweise Arbeitsseiten mit Layouts, die sich von denen der linken und der rechten Vorgabeseite unterscheiden. Sie könnten z. B. die erste Seite eines Dokuments anders gestalten oder in ein Dokument im Hochformat eine Seite im Querformat einfügen. Für derartige Fälle legen Sie spezielle Vorgabeseiten an. (Ein Dokument kann bis zu 100 Vorgabeseiten enthalten.)

Für die erste Seite wird ein anderes Layout verwendet.

Vorgabeseiten können auch umbenannt oder, wenn Sie sie nicht mehr benötigen, gelöscht werden.


Seitenlayout und Schablonen / Erstellen und Bearbeiten spezieller Vorgabeseiten

Erstellen spezieller Vorgabeseiten

Sie können eine spezielle Vorgabeseite mit einer leeren Seite beginnen oder sie auf der Grundlage einer bestehenden Vorgabeseite definieren. Nach der Erstellung der neuen speziellen Vorgabeseite können Sie ihr Spaltenlayout ändern und Hintergrundtext und -grafiken hinzufügen (siehe Ändern des Seitenlayouts für bestimmte Seiten). Die spezielle Vorgabeseite kann anschließend einer oder mehreren Arbeitsseiten zugewiesen werden (siehe Zuweisen von Vorgabeseiten zu Arbeitsseiten).

So erstellen Sie eine spezielle Vorgabeseite, die leer ist oder auf dem Layout einer anderen Vorgabeseite basiert:

    1. Zeigen Sie die Vorgabeseite an, die als Grundlage für die neue Vorgabeseite dienen soll.

    2. Wählen Sie "Spezial > Vorgabeseite hinzufügen" und geben Sie den Namen der neuen Seite in das Textfeld "Name" ein.

    3. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie für die neue Seite das Layout einer vorhandenen Vorgabeseite verwenden wollen, wählen Sie die betreffende Vorgabeseite aus dem Aufklappmenü "Von Vorgabeseite".

    Zur Erstellung einer leeren Vorgabeseite klicken Sie auf "Leer".

    4. Klicken Sie auf "Hinzufügen".

So erstellen Sie eine spezielle Vorgabeseite, die auf dem Layout einer Arbeitsseite basiert:

    1. Nehmen Sie die gewünschten Änderungen am Spaltenlayout einer Arbeitsseite vor.

    2. Zeigen Sie die Arbeitsseite an und wählen Sie "Format > Seitenlayout > Neue Vorgabeseite".

    3. Geben Sie den Namen der neuen Vorgabeseite ein und klicken Sie auf "Anlegen".

Hinweis: Vorgabeseiten unterstützen den Unicode-Standard zur Textcodierung.


Seitenlayout und Schablonen / Erstellen und Bearbeiten spezieller Vorgabeseiten

Erneutes Ordnen spezieller Vorgabeseiten

Sie können spezielle Vorgabeseiten in jeder beliebigen Reihenfolge anzeigen lassen. Die Vorgabeseiten "Rechts" und "Links" bleiben immer am Anfang.

So ordnen Sie spezielle Vorgabeseite neu an:

    1. Öffnen Sie eine Vorgabeseite und wählen Sie "Format > Seitenlayout > Spezielle Vorgabeseiten neu ordnen".

    2. Wählen Sie in der Liste "Spezielle Vorgabeseiten" eine Vorgabeseite und klicken Sie auf "Nach oben bewegen" oder "Nach unten bewegen", um die Seiten entsprechend zu verschieben.

    3. Wiederholen Sie Schritt 2 so oft, bis Sie die gewünschte Reihenfolge erreicht haben.

    4. Klicken Sie auf "Zuweisen". Wenn Sie zuvor eine spezielle Vorgabeseite angezeigt hatten, wird nun möglicherweise eine andere angezeigt.


Seitenlayout und Schablonen / Erstellen und Bearbeiten spezieller Vorgabeseiten

Erstellen einer gedrehten Vorgabeseite

Sie können eine spezielle Vorgabeseite erstellen, um die Ausrichtung einer Arbeitsseite zu ändern. Eine gedrehte Ausrichtung kann z. B. für eine Arbeitsseite mit einer sehr breiten Tabelle erforderlich sein.

Die rechte Seite verwendet eine gedrehte Vorgabeseite.

So erstellen Sie eine gedrehte Vorgabeseite:

    1. Erstellen Sie eine neue spezifische Vorgabeseite. Weitere Informationen finden Sie unter Erstellen spezieller Vorgabeseiten.

    2. Definieren Sie auf der Vorgabeseite alle Textrahmen, Hintergrundtexte und Grafiken, die dieselbe Ausrichtung (nicht gedreht) besitzen sollen wie die Kopf- und Fußzeilen auf den anderen Vorgabeseiten.

Nicht gedrehte Vorgabeseite

Um z. B. denselben Effekt wie in der Abbildung am Beginn dieses Abschnitts zu erzielen, müssten Sie die Kopf- und Fußzeilen jetzt definieren. Wenn sie gedreht werden sollen, fügen Sie sie später hinzu. Informationen über das Zeichnen von Hintergrundtextrahmen finden Sie unter Erstellen und Ändern von Hintergrundtextrahmen.

    3. Wählen Sie einen der Befehle unter "Format > Spezielles Layout > Seite drehen". Wenn FrameMaker die Seite dreht, ist wahrscheinlich ein Teil der Seite nicht mehr sichtbar. Sie können die Fenstergröße anpassen, um von der Seite so viel wie möglich zu sehen.

Gedrehte Vorgabeseite

    4. Erstellen Sie alle Textrahmen, Hintergrundtexte und -grafiken, die gedreht angezeigt werden sollen. Um z. B. denselben Effekt wie in der Abbildung am Beginn dieses Abschnitts zu erzielen, müssten Sie jetzt den Vorgabetextrahmen hinzufügen.

Sie können Text direkt in gedrehte Textrahmen eingeben oder deren Drehung aufheben, um die Eingabe zu beschleunigen. Wählen Sie hierfür "Format > Spezielles Layout > Drehung aufheben". Wenn Sie mit der Eingabe fertig sind, drehen Sie die Seite wieder in die ursprüngliche Lage.


Seitenlayout und Schablonen / Erstellen und Bearbeiten spezieller Vorgabeseiten

Umbenennen und Löschen spezieller Vorgabeseiten

Sie können eine spezielle Vorgabeseite auch umbenennen, z. B. wenn Sie sie aus einer Schablone in ein vorhandenes Dokument importieren und verhindern wollen, dass eine vorhandene Vorgabeseite mit demselben Namen überschrieben wird. Die Vorgabeseiten "Links" und "Rechts" können nicht umbenannt werden.

Wenn ein Dokument eine Vorgabeseite nicht mehr verwendet, können Sie sie löschen. Die Vorgabeseiten "Rechts" und "Links" sowie alle momentan mit einer Arbeitsseite verbundenen Vorgabeseiten können nicht gelöscht werden.

So benennen Sie eine spezielle Vorgabeseite um:

    1. Zeigen Sie die Vorgabeseite an und klicken Sie in der Statuszeile auf den Seitennamen.

    2. Geben Sie den neuen Namen ein und klicken Sie auf "Zuweisen".

So löschen Sie eine spezielle Vorgabeseite:

    1. Zeigen Sie die Vorgabeseite an und wählen Sie "Spezial > Seite löschen".

    2. Klicken Sie auf "OK".


Seitenlayout und Schablonen / Erstellen und Bearbeiten spezieller Vorgabeseiten

Zuweisen von Vorgabeseiten zu Arbeitsseiten

Sie können einer Arbeitsseite jederzeit eine Vorgabeseite zuweisen. FrameMaker verwendet den Vorgabetextrahmen der Vorgabeseite für die Anzeige von Hintergrundtext und -grafiken auf der Arbeitsseite.

Es ist auch möglich, einer Arbeitsseite keine Vorgabeseite zuzuweisen. Eine derartige Arbeitsseite enthält dann weder Kopf- und Fußzeilen noch Hintergrundtext und -grafiken. (Ein eventuell auf der Arbeitsseite vorhandener Textrahmen wird dadurch nicht beeinflusst.) Wenn z. B. jedes Kapitel eines Buches eine gerade Seitenanzahl enthalten soll, sich aber auf der letzten Seite eines Kapitels kein Haupttext befindet, weisen Sie dieser Seite keine Vorgabeseite zu, damit sie vollständig leer bleibt.

Informationen über das Zuordnen von Vorgabeseiten zu Seiten mit festgelegten Absatztypen oder -elementen finden Sie unter Zuweisen von Vorgabeseiten zu Arbeitsseiten mit Absatztypen und Zuweisen von Vorgabeseiten zu Seiten, die Elemente enthalten.

So weisen Sie Arbeitsseiten eine andere Vorgabeseite zu:

    1. Zeigen Sie eine Arbeitsseite an und wählen Sie "Format > Seitenlayout > Vorgabeseite zuweisen".

    2. Führen Sie im Bereich "Vorgabeseite" eine der folgenden Aktionen aus:

    Um die linke oder rechte Vorgabeseite zuzuweisen, klicken Sie auf "Rechts" (in einem einseitigen Dokument) bzw. auf "Rechts/Links" (in einem doppelseitigen Dokument).

    Um eine spezielle Vorgabeseite zuzuweisen, wählen Sie den Namen der Seite aus dem Aufklappmenü "Spezial".

    Wenn der Arbeitsseite keine Vorgabeseite zugewiesen werden soll, wählen Sie "Keine" aus dem Aufklappmenü "Spezial".

    3. Führen Sie unter "Zuweisen auf" eine der folgenden Aktionen aus:

    Um die Vorgabeseite der aktuellen Arbeitsseite zuzuweisen, klicken Sie auf "Aktuelle Seite".

    Wenn die Zuweisung für einen Seitenbereich erfolgen soll, geben Sie die Nummer der ersten und der letzten Seite des Bereichs in die Textfelder "Seiten" ein.

    Wenn die Vorgabeseite nur den geraden oder den ungeraden Seiten innerhalb eines Bereichs zugewiesen werden soll, wählen Sie "Gerade" bzw. "Ungerade".

    Um die Vorgabeseite nur den Seiten im Bereich zuzuweisen, die aktuell eine bestimmte Vorgabeseite verwenden, wählen Sie die betreffende Seite aus dem Aufklappmenü unter "Zuweisen auf".

    4. Klicken Sie auf "Zuweisen".

Hinweis: Wenn die Vorgabeseite einen Schablonentextfluss enthält, der sich nicht auf der Arbeitsseite befindet, fügt FrameMaker der Arbeitsseite die Textrahmen hinzu, die den Textfluss enthalten. Enthält die Arbeitsseite einen Textfluss, der nicht auf der Vorgabeseite definiert ist, behält FrameMaker die Textrahmen mit diesem Textfluss unverändert bei. Dadurch kann es zu einem Überlappen der Textrahmen kommen.


Seitenlayout und Schablonen / Erstellen und Bearbeiten spezieller Vorgabeseiten / Zuweisen von Vorgabeseiten zu Arbeitsseiten

Zuweisen von Vorgabeseiten zu Arbeitsseiten mit Absatztypen

Sie können Arbeitsseiten mit festgelegten Absatztypen Vorgabeseiten zuweisen. Sie können beispielsweise allen Seiten, die den Absatztyp "Titel" enthalten, eine spezielle Vorgabeseite mit dem Namen "Erste Seite" zuweisen.

Die Zuordnung der Absatztypen zu den Vorgabeseiten erfolgt unter Verwendung der Zuordnungstabelle "Referenzseiten". Nach der Verwendung des Befehls "Vorgabeseiten zuweisen" wird die Vorgabeseite auf die Arbeitsseiten, die den referenzierten Absatztyp enthalten, angewendet.

In diesem Beispiel wird die Vorgabeseite "Erste Seite" auf Arbeitsseiten angewendet, die den Absatztyp "Titel" enthalten.

Weitere Informationen über das Zuweisen von Vorgabeseiten zu Elementen in strukturierten Dokumenten finden Sie unter Zuweisen von Vorgabeseiten zu Seiten, die Elemente enthalten.

So weisen Sie einer Arbeitsseite, die Absatztypen enthält, eine Vorgabeseite zu:

    1. Wählen Sie "Darstellung> Referenzseiten".

    2. Klicken Sie auf die Schaltfläche "Nächste Seite" [image] , bis die fünfspaltige Tabelle "UnstrukturierteVorgabeseitenzuordnung" angezeigt wird.

Wird die Zuordnungstabelle nicht in den Referenzseiten angezeigt, wählen Sie "Format > Seitenlayout > Vorgabeseiten zuweisen".

    3. Geben Sie unter "Buchaktualisierung" Ja oder Nein ein, um festzulegen, ob die angegebene Vorgabeseite angewendet wird, wenn Sie in einem Buch "Vorgabeseiten zuweisen" wählen.

    4. Führen Sie zur Bearbeitung der Tabelle folgende Schritte aus:

    Geben Sie unter der Tabellenüberschrift "Name des Absatztyps" den Namen des Absatztyps ein, auf den die Vorgabeseite angewendet werden soll. Diese Spalte ist erforderlich, damit Vorgabeseiten zugewiesen werden können. Achten Sie bei der Eingabe des Namens des Absatztyps auf die richtige Schreibweise, einschließlich der Groß- und Kleinschreibung.

    Geben Sie unter der Überschrift "Rechte Vorgabeseite" den Namen der Vorgabeseite ein, die Sie zuweisen möchten. Diese Spalte ist erforderlich, damit Vorgabeseiten zugewiesen werden können. Die angegebene Vorgabeseite wird allen Arbeitsseiten zugewiesen, einschließlich der linken Seiten in doppelseitigen Dokumenten, auf denen die Absatztypen enthalten sind, es sei denn, Sie geben unter "Linke Vorgabeseite" eine andere Vorgabeseite an. In Namen von Vorgabeseiten wird zwischen Groß- und Kleinschreibung unterschieden.

    Geben Sie unter "Linke Vorgabeseite" den Namen der Vorgabeseite ein, die in doppelseitigen Dokumenten linken Arbeitsseiten zugewiesen werden soll, wenn sie die entsprechenden Absatztypen enthalten. Diese Spalte ist optional.

    Geben Sie unter "Bereichsindikatoren" Einseitig ein, wenn die Vorgabeseite nur auf die Arbeitsseite angewendet werden soll, auf der der Absatztyp vorhanden ist, geben Sie Doppelseiten ein, wenn die Vorgabeseite auf den gesamten Bereich der Seiten angewendet werden soll, auf den der Absatztyp angewendet wird, oder geben Sie Gültig bis Änderung ein, um die Vorgabeseite auf alle Seiten anzuwenden, bis in der Zuordnungstabelle die nächste Vorgabeseite mit einem abweichenden Absatztyp erkannt wird. Wenn diese Zelle leer ist, werden die Vorgabeseiten auf einzelne Seiten angewendet.

    Fügen Sie in der Spalte "Kommentare" Anmerkungen hinzu. In diese Spalte eingetragener Text wirkt sich nicht auf die Zuweisung von Vorgabeseiten aus.

    Wenn Sie Absatztypen weitere Vorgabeseiten zuweisen möchten, müssen Sie zusätzliche Tabellenreihen hinzufügen und ausfüllen.

    5. Wählen Sie abschließend "Darstellung > Arbeitsseiten".

    6. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    7. Wählen Sie "Format > Seitenlayout > Vorgabeseiten zuweisen" und klicken Sie anschließend auf "Ja", um manuell zugewiesene Vorgabeseiten zu überschreiben.

Adobe FrameMaker durchsucht alle Arbeitsseiten nach dem ersten Auftreten der in der Tabelle "Vorgabeseitenzuordnung" angegebenen Absatztypen. Wenn Text mit dem festgelegten Absatztyp gefunden wird, wird die angegebene Vorgabeseite angewendet.


Seitenlayout und Schablonen

Ausrichten von Text über mehrere Spalten

Text kann auf unterschiedliche Weise in den Spalten eines mehrspaltigen Layouts ausgerichtet werden, sodass er ein gleichmäßiges Erscheinungsbild hat:

    Ausgleich von Text in einem Textfluss. Bei dieser Methode verteilt FrameMaker den Text gleichmäßig über die Spalten eines Textrahmens, der nicht vollständig mit Text ausgefüllt ist.

    Höhenausgleich (vertikale Ausrichtung) von Text in einem Textfluss. Wenn Sie diese Ausrichtungsmethode wählen, wird der Text so angepasst, dass die letzte Zeile jeder Spalte bis zum Spaltenende reicht.

    Synchronisieren von Text in einem Textfluss. Bei dieser Methode werden die ersten Zeilen der Textabsätze gerade ausgerichtet, wenn sie nebeneinander in Spalten angezeigt werden.

Wenn für einen Textfluss sowohl der Höhenausgleich als auch die Synchronisierung aktiviert ist, hat der Höhenausgleich Vorrang. Die ersten Zeilen der Spalten werden jedoch miteinander synchronisiert.


Seitenlayout und Schablonen / Ausrichten von Text über mehrere Spalten

Ausgleichen von Text über mehrere Spalten

In einem Layout mit einem mehrspaltigen Textrahmen können Sie den Text in Spalten verteilen, die nicht vollständig mit Text gefüllt sind. Dies ist z. B. bei Spalten auf teilweise leeren Seiten sinnvoll, die erzwungenen Seitenumbrüchen vorausgehen, oder bei Spalten auf der letzten Seite eines Dokuments. Der Ausgleich von Text kann entweder für den gesamten Textfluss oder nur für einzelne Textrahmen erfolgen.

Mit und ohne Option "Ausgleichen"

So verteilen Sie in einem Textfluss Text in Spalten:

    1. Wenn ein Dokumentfenster aktiviert ist, platzieren Sie die Einfügemarke im Haupttextfluss, oder klicken Sie in den Seitenrand. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Seitenlayout > Spaltenlayout".

    3. Wählen Sie "Spalten ausgleichen" und klicken Sie auf "Gesamten Textfluss aktualisieren".

So aktivieren Sie den Textausgleich für die Spalten eines einzelnen Textrahmens:

    1. Klicken Sie in den Textrahmen und wählen Sie "Format > Spezielles Layout > Spezieller Textrahmen".

    2. Wählen Sie "Spalten ausgleichen" und klicken Sie auf "Zuweisen".


Seitenlayout und Schablonen / Ausrichten von Text über mehrere Spalten

Höhenausgleich von Text bis zum Ende von Textrahmen

Beim Höhenausgleich von Text vergrößert FrameMaker als Erstes den Abstand zwischen den Absätzen bis zu einem von Ihnen angegebenen Grenzwert. Falls dies nicht ausreicht, wird der Abstand zwischen den Zeilen bis zu einem weiteren angegebenen Grenzwert vergrößert. Wenn der Text in einem Textrahmen um Grafiken fließt, führt FrameMaker keinen Höhenausgleich durch.

Vor und nach dem Höhenausgleich

In einem mehrspaltigen Textrahmen mit verbundenen Elementen (Absätzen, Tabellen oder verankerten Rahmen) vergrößert FrameMaker den vertikalen Abstand, um die Grundlinien des Textes in nebeneinanderliegenden Spalten über jedem verbundenen Element auszurichten.

Vor und nach dem Höhenausgleich mit Verbinden

Der Höhenausgleich von Text kann dazu führen, dass die Seiten langsamer angezeigt werden. Oft ist es deshalb sinnvoll, den Höhenausgleich erst durchzuführen, wenn die Bearbeitung des Dokuments abgeschlossen ist.

So führen Sie einen Höhenausgleich in einem Textfluss durch:

    1. Wenn ein Dokumentfenster aktiviert ist, platzieren Sie die Einfügemarke im Haupttextfluss. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Seitenlayout > Zeilenlayout".

    3. Wählen Sie "Höhenausgleich" und geben Sie den maximalen Abstand an, den FrameMaker zwischen Zeilen ("Maximaler Ausgleich zwischen Zeilen") und zwischen Absätzen ( [image] "Maximaler Ausgleich zwischen Absätzen") einfügen kann.

FrameMaker hält die von Ihnen festgelegten Grenzwerte für den Höhenausgleich ein. Sollte dies bei einer Spalte nicht möglich sein, wird für diese Spalte kein Höhenausgleich durchgeführt.

    4. Klicken Sie auf "Textfluss aktualisieren".

Hinweis: Beim Höhenausgleich wird Platz geschaffen für die größtmögliche Unterlänge im größten Schriftgrad, der in der Zeile verwendet wird. Dies gilt auch dann, wenn kein Zeichen mit der maximalen Unterlänge im Text enthalten ist. Falls die letzte Zeile einer Spalte zu hoch erscheint, überprüfen Sie, ob die Spalte ein nicht druckendes Zeichen (z. B. ein Ankersymbol) in einer Schrift enthält, die größer als der umgebende Text ist.


Seitenlayout und Schablonen / Ausrichten von Text über mehrere Spalten

Synchronisieren von Grundlinien über Spalten

Wenn Sie Absätze in einem Textfluss synchronisieren (ausrichten), erstellt FrameMaker ein unsichtbares Raster in jedem Textrahmen und richtet die Grundlinie der ersten Zeile jedes angegebenen Absatzes am Raster aus. FrameMaker richtet außerdem die erste Zeile aus, die auf einen verankerten Rahmen folgt, und versucht, die erste Zeile jeder Spalte auszurichten.

Vor und nach der Synchronisierung

Da Überschriften in großen Schriftarten oft am Spaltenanfang erscheinen, können Sie einen Grenzwert für die Synchronisierung der ersten Zeile angeben. Von diesem Grenzwert hängt es ab, ob die Grundlinie einer Überschrift am Anfang der Spalte auch dann auf der ersten Rasterlinie platziert wird, wenn der Standardschriftgrad der Überschrift für das Raster zu groß ist. Damit die Grundlinie einer Überschrift auf der ersten Rasterlinie platziert werden kann, lässt FrameMaker die Überschrift über den Spaltenanfang hinausreichen (vgl. Abbildung). Schriftgrade, die den von Ihnen festgelegten Grenzwert überschreiten, werden nicht synchronisiert.

So synchronisieren Sie Grundlinien über Spalten:

    1. Überprüfen Sie das Absatzformat der Absatztypen, die synchronisiert werden sollen, um sicherzustellen, dass alle denselben Standardschriftgrad und Zeilenabstand aufweisen. Dabei sollte die Option "Fester Zeilenabstand" aktiviert sein (siehe Ändern von Abständen).

    2. Klicken Sie in den Textfluss, der synchronisiert werden soll (oder wählen Sie die gewünschten Dokumente im Buch aus), und wählen Sie "Format > Seitenlayout > Zeilenlayout".

    3. Wählen Sie "Grundlinien-Synchronisierung" und deaktivieren Sie "Höhenausgleich".

    4. Geben Sie unter "Grundlinien-Synchronisierung" den gewünschten Zeilenabstand für das Textrahmenraster in das Textfeld "Absätze synchronisieren" ein. Verwenden Sie dabei den Zeilenabstand der Absätze, die synchronisiert werden sollen. Andernfalls synchronisiert FrameMaker die Absätze nicht mit dem Textrahmenraster.

    5. Geben Sie in das Textfeld "Synchronisierungsgrenze für 1. Zeile" den größten Schriftgrad ein, der am Spaltenanfang ausgerichtet werden soll. Nehmen Sie z. B. für Textabsätze einen Zeilenabstand von 12 Punkt, ein Spaltenraster von 12 Punkt und Überschriften von 18 Punkt an. Um Überschriften am Spaltenanfang auszurichten, geben Sie 18 Punkt als Synchronisierungsgrenze für die erste Zeile an.

    6. Klicken Sie auf "Textfluss aktualisieren". Da es über der ersten Zeile einer Spalte keine Unterlängen gibt, wird die erste Rasterlinie in einem Abstand von zwei Dritteln des angegebenen Zeilenabstands vom Spaltenanfang positioniert.


Seitenlayout und Schablonen / Ausrichten von Text über mehrere Spalten

Synchronisieren von Grundlinien in benachbarten Textrahmen

In bestimmten Dokumenten (z. B. in Infoblättern mit mehreren Textflüssen) kann jede Seite mehrere Textrahmen enthalten, und zwar einen für jede Textspalte. Wenn die Oberkanten benachbarter Textrahmen an derselben Position beginnen, werden ihre unsichtbaren Raster problemlos nebeneinander ausgerichtet. Beginnen die Textrahmen jedoch an unterschiedlichen Positionen, müssen Sie eventuell die Oberkanten anpassen, damit die Textrahmen gleichmäßig an den Rastern ausgerichtet werden.

Ändern Sie dazu die Größe der benachbarten Textrahmen so, dass der Abstand zwischen den Oberkanten ganzzahlig durch das Raster geteilt werden kann. Wenn das Raster z. B. 12 Punkt ist, können Sie einen Textrahmen 144 Punkt (12 mal 12 Punkt) von der Oberkante eines benachbarten Textrahmens beginnen.

A: Rasterabstand B: Ein Vielfaches der Rastergröße

Mithilfe des Magnetrasters können Sie die Textrahmen korrekt ausrichten. Geben Sie ein Magnetraster an, das dem Textrahmenraster entspricht. Ändern Sie dann die Größe der Textrahmen, bis ihre Oberkanten an einer Rasterposition ausgerichtet sind. Weitere Informationen finden Sie unter Verwenden von Rastern.


Seitenlayout und Schablonen

Dokumente mit mehreren Textflüssen

Bei den meisten Dokumenten wird der Textrahmen einer Seite automatisch mit dem Textrahmen auf der nächsten Seite verkettet.

Einzelner Textfluss

Es gibt jedoch auch Dokumente mit mehreren, separaten Textflüssen, von denen jeder eigene Textrahmenverkettungen aufweist. Dies ist beispielsweise bei einem mehrsprachigen Dokument der Fall, das nebeneinander verschiedene Übersetzungen desselben Textes enthält.

Der Text in der linken Spalte fließt zur linken Spalte der nächsten Seite.

In einem Infoblatt wiederum kann jeder Artikel seinen eigenen Textfluss besitzen. In diesem Fall lässt sich durch die Verkettung der Textrahmen festlegen, wie der Text fließt.

Text der ersten Seite fließt auf zwei unterschiedliche Seiten.

In einem Dokument mit mehreren Textflüssen kann FrameMaker angewiesen werden, keine neue Seite hinzuzufügen. Sie können dann selbst Seiten hinzufügen und die Verkettungen festlegen. Da die automatische Nummerierung in unterschiedlichen Textflüssen unabhängig voneinander erfolgt, können Sie nummerierte Listen, Überschriften, Abbildungstitel usw. für jeden Textfluss separat verwalten.


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen

Einrichten von Dokumenten mit mehreren Textflüssen

Das Layout eines Dokuments mit parallelen Textflüssen wird auf Vorgabeseiten gestaltet, auf denen die Textrahmen angeordnet und miteinander verkettet werden. Da die Textrahmenverkettungen im gesamten Dokument gleich sind, müssen in der Regel keine weiteren Änderungen auf Arbeitsseiten vorgenommen werden.

Die Gestaltung des Spaltenlayouts eines Infoblattes oder einer Zeitschrift, für die mehrere, nichtparallele Textflüsse benötigt werden, erfolgt in der Regel auf Vorgabeseiten. Die Vorgabeseiten dienen jedoch lediglich als grundlegendes Layoutraster. Das weitere Layout der Textrahmen erfolgt auf den Arbeitsseiten. Sie können die Textrahmen auf den Arbeitsseiten vergrößern/verkleinern, löschen, verketten bzw. ihre Verkettung wieder aufheben, bis Sie mit dem Layout zufrieden sind. Mit dieser Methode können Sie auf flexible Weise festlegen, wie der Text durch das Dokument fließt.

Hinweis: Wenn Sie Infoblätter oder Zeitschriften erstellen, deren Artikel fortlaufend von der ersten bis zur letzten Seite fließen, müssen Sie die hier beschriebenen Techniken nicht einsetzen. Verwenden Sie statt dessen einen einzelnen Textfluss. Sie können spezielle Effekte erzielen, z. B. Text, der um Grafiken fließt, oder Absätze, Tabellen und Rahmen, die sich über mehrere Spalten erstrecken. Die im Lieferumfang von FrameMaker enthaltene Infoblatt-Schablone bietet ein Beispiel für diese Technik.

So richten Sie parallele Textflüsse ein:

    1. Richten Sie die Textflüsse auf einer der Vorgabeseiten ein (siehe Einfügen von Vorgabetextrahmen auf Vorgabeseiten). Verwenden Sie für jeden Textfluss einen separaten Textrahmen und weisen Sie jedem Textrahmen einen anderen Textflusstyp zu. Vergewissern Sie sich, dass für jeden Textfluss die automatische Verkettung aktiviert ist, damit FrameMaker eine neue Arbeitsseite anlegt, wenn der Text das Ende eines Textflusses erreicht (siehe Ändern von Textflusstypen und automatischer Verkettung).

Linke und rechte Vorgabeseite für einen parallelen Textfluss

    2. Wiederholen Sie diese Schritte für alle weiteren Vorgabeseiten. Alle Vorgabeseiten sollten dieselben Textflusstypen aufweisen. Andernfalls wechselt FrameMaker beim Hinzufügen von Arbeitsseiten nicht korrekt zwischen linker und rechter Vorgabeseite.

Wichtig: Damit die neue Arbeitsseite korrekt angelegt wird, wenn das Ende eines Textrahmens erreicht ist, muss die entsprechende linke oder rechte Vorgabeseite alle Textflusstypen enthalten, die sich auf der aktuellen Arbeitsseite befinden. Fehlt ein Textflusstyp, erstellt FrameMaker die neue Seite stattdessen mit der Vorgabeseite der aktuellen Arbeitsseite.

    3. Aktualisieren Sie die Arbeitsseiten mit Änderungen der Vorgabeseiten, indem Sie die Arbeitsseiten anzeigen.

So richten Sie Textflüsse für ein Infoblatt oder eine Zeitschrift ein:

    1. Legen Sie die Anzahl der Spalten fest und platzieren Sie für jede Spalte einen einspaltigen Textrahmen auf jeder Vorgabeseite (siehe Einfügen von Vorgabetextrahmen auf Vorgabeseiten). Alle Textrahmen sollten demselben Textfluss angehören. Verwenden Sie diese Textrahmen als Layoutraster, durch das der Text fließt.

Erste Vorgabeseite

Linke und rechte Vorgabeseite mit demselben Textfluss

    2. Deaktivieren Sie "Automatische Verkettung", damit FrameMaker nicht automatisch Seiten hinzufügt (siehe Die Einstellung "Automatische Verkettung").

    3. Aktualisieren Sie die Arbeitsseiten mit den Änderungen der Vorgabeseiten, indem Sie die Arbeitsseiten anzeigen.

    4. Vergrößern oder verkleinern, trennen und verketten Sie nun Textrahmen auf jeder Arbeitsseite, um das gewünschte Layout zu erzeugen. Aktualisieren Sie die Vorgabeseiten nicht mit den Änderungen der Arbeitsseiten. Weitere Informationen finden Sie unter Verketten von Textrahmen und Abtrennen von Textrahmen.

    5. Wenn Sie die Textgrundlinien im Infoblatt synchronisieren wollen, stellen Sie sicher, dass die Textrahmen entsprechend platziert sind. Falls das Dokument mehrere Textflüsse enthält, müssen die Grundlinien für jeden Textfluss synchronisiert werden. Informationen hierzu finden Sie unter Synchronisieren von Grundlinien über Spalten und Synchronisieren von Grundlinien in benachbarten Textrahmen.

    6. Fügen Sie bei Bedarf neue unverkettete Arbeitsseiten manuell hinzu (siehe Hinzufügen neuer unverketteter Seiten).

    7. Verketten Sie die Textrahmen auf den einzelnen Seiten in der gewünschten Weise.


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen

Steuern des Textflusses

Die Grundeinstellungen eines Textflusses sind der Textflusstyp und die Einstellung "Automatische Verkettung". "Automatische Verkettung" legt fest, ob automatisch eine neue Seite erzeugt wird, wenn die Textrahmen des Textflusses voll sind. Die meisten Dokumente enthalten einen einzelnen, automatisch verketteten Textfluss, an dem normalerweise keine Änderungen vorgenommen werden müssen. (In einem neuen, leeren Dokument besitzt der Haupttextfluss den Typ A.)

Sie können jederzeit einen Textflusstyp zuweisen (wenn Sie z. B. parallele Textflüsse anlegen). Jedem Textfluss muss nur einmal ein Typ zugewiesen werden. Danach übernehmen alle Textrahmen, die mit dem Textfluss verkettet werden, diesen Typ. Wenn Sie den Textflusstyp oder die Einstellung "Automatische Verkettung" in einem Textrahmen des Textflusses ändern, gilt die Änderung für den gesamten Textfluss.

Sie steuern einen Textfluss, indem Sie Textrahmen verketten, teilen oder die Verkettung aufheben. Außerdem können unverkettete Seiten hinzugefügt und gelöscht werden.


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen / Steuern des Textflusses

Die Einstellung "Automatische Verkettung"

In einem Dokument mit einem einzelnen oder mehreren parallelen Textflüssen ist "Automatische Verkettung" normalerweise aktiviert. FrameMaker fügt dann eine neue Seite hinzu, sobald die Textrahmen des Textflusses voll sind. Die neue Seite übernimmt das Spaltenlayout der entsprechenden (linken oder rechten) Vorgabeseite, und die Textrahmen auf der neuen Seite werden automatisch mit den Textrahmen der Ursprungsseiten verkettet.

Bei der Bearbeitung eines Dokuments mit mehreren nicht parallelen Textflüssen wird die Einstellung "Automatische Verkettung" gewöhnlich deaktiviert. Sie können dann jederzeit eine neue unverkettete Arbeitsseite hinzufügen und die Verkettung zwischen dieser und den bestehenden Seiten steuern.

Wenn "Automatische Verkettung" deaktiviert ist und der Textfluss mehr Text enthält, als seine Textrahmen aufnehmen können, läuft der Text am Ende des letzten Textrahmens über. Wenn die Anzeige von Begrenzungslinien aktiviert ist, wird der untere Rand eines überlaufenden Textrahmens als durchgehende Linie dargestellt.

Textrahmen mit Überlauftext

Beim Versuch, weiteren Text in einen übergelaufenen Textrahmen einzugeben, ertönt ein Warnsignal. Überlauftext wird nicht gelöscht, er ist lediglich ausgeblendet. Sobald Sie den Textrahmen, der den Überlauftext enthält, mit einem anderen Textrahmen verketten, wird der Text im nächsten Textrahmen wieder angezeigt.


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen / Steuern des Textflusses

Ändern von Textflusstypen und automatischer Verkettung

Normalerweise ändern Sie Textflusstypen und die Einstellung "Automatische Verkettung" auf Vorgabeseiten. Wenn zwei Textrahmen verkettet sind, müssen Sie die Verkettung aufheben, damit Sie einen der Textflusstypen ändern können (siehe Abtrennen von Textrahmen).

So ändern Sie den Typ eines Textflusses und die Einstellung "Automatische Verkettung":

    1. Klicken Sie in einen Textrahmen des Textflusses.

    2. Wählen Sie "Format > Spezielles Layout > Spezieller Textrahmen".

    3. Geben Sie in das Textfeld "Textflusstyp" einen Typ für den Textfluss ein. Geben Sie dem Textfluss einen kurzen Typnamen, damit er nicht andere Informationen im Namensbereich der Statuszeile verdeckt. Sie können keinen Typ zuweisen, der auf der aktuellen Seite bereits verwendet wird.

Hinweis: Sie können auf einer Seite zwei Textrahmen mit demselben Textflusstyp erstellen, indem Sie die Textrahmen miteinander verketten (siehe Verketten von Textrahmen).

    4. Wenn FrameMaker automatisch eine neue Seite hinzufügen soll, sobald die letzte Spalte auf einer Seite gefüllt ist, aktivieren Sie die Einstellung "Automatische Verkettung".

    5. Klicken Sie auf "Zuweisen".


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen / Steuern des Textflusses

Hinzufügen neuer unverketteter Seiten

In Dokumenten mit einem Haupttextfluss oder zwei parallelen Textflüssen fügen Sie normalerweise keine unverkettete Arbeitsseite hinzu, sondern lassen FrameMaker bei Bedarf automatisch verkettete Seiten anlegen. In einem Dokument mit mehreren Textflüssen, in dem "Automatische Verkettung" deaktiviert ist, oder in anderen speziellen Dokumenten können Sie neue unverkettete Arbeitsseiten hinzufügen. Sobald der Text das Ende eines Textrahmens erreicht, fügen Sie eine neue Seite hinzu und verketten die Textrahmen.

So fügen Sie eine neue unverkettete Seite hinzu:

    1. Wählen Sie auf einer Arbeitsseite "Spezial > Unverkettete Seiten löschen".

    2. Legen Sie die Position und die Anzahl der Seiten fest, die hinzugefügt werden sollen.

    3. Wählen Sie eine Vorgabeseite aus dem Aufklappmenü "Vorgabeseite" und klicken Sie auf "Einfügen".


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen / Steuern des Textflusses

Löschen unverketteter Seiten

Wenn Sie in einem Dokument mit mehreren Textflüssen unverkettete Seiten löschen, wird gleichzeitig der Seiteninhalt gelöscht.

So löschen Sie unverkettete Seiten:

    1. Klicken Sie in die Seite, die gelöscht werden soll, und wählen Sie "Spezial > Seiten löschen".

    2. Legen Sie die erste und die letzte unverkettete Seite des zu löschenden Bereichs fest und klicken Sie auf "Löschen". Wenn Sie nur eine einzelne Seite löschen wollen, geben Sie ihre Seitennummer in beide Textfelder ein.


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen / Steuern des Textflusses

Verketten von Textrahmen

Wenn zwei Textrahmen verkettet sind, fließt der Text vom Ende des ersten Textrahmens zum Beginn des zweiten. Sie können einen Textrahmen auf einer Vorgabeseite mit einem beliebigen Textrahmen auf derselben Vorgabeseite verketten. Es ist auch möglich, einen Textrahmen auf einer Arbeitsseite mit einem Textrahmen auf einer anderen Arbeitsseite zu verketten. Ein Textrahmen in der Mitte eines Textflusses kann ebenfalls verkettet werden.

Beim Verketten zweier Textrahmen weist FrameMaker dem zweiten Textrahmen den Textflusstyp des ersten Textrahmens zu. Besitzt der erste Textrahmen keinen Textflusstyp, wird der Typ des zweiten Rahmens verwendet. Daher gehören alle verketteten Textrahmen demselben Textfluss an und haben denselben Typ. Wenn der erste Textrahmen Überlauftext enthält, fließt der Text in den zweiten Rahmen, sobald die Verkettung hergestellt ist.

So verketten Sie zwei Textrahmen:

    1. (Windows und UNIX) Wählen Sie die beiden Textrahmen in der Reihenfolge aus, in der Sie sie verketten wollen. Klicken Sie zum Auswählen der Textrahmen bei gedrückter Strg- bzw. Control-Taste auf die Textrahmen.

Wenn sich die Textrahmen auf unterschiedlichen Seiten befinden, wird der erste Textrahmen nicht als ausgewählt dargestellt, sobald Sie den zweiten auswählen. FrameMaker "merkt sich" jedoch die erste Auswahl.

Hinweis: Um einen Textrahmen in der Mitte eines Textflusses einzufügen, wählen Sie zunächst den Textrahmen aus, den Sie hinzufügen möchten, und dann den Rahmen, der darauf folgen soll.

    2. Wählen Sie "Format > Spezielles Layout > Textrahmen verketten". Wenn sich der zuerst ausgewählte Textrahmen auf einer Seite befindet, die momentan nicht sichtbar ist, werden Sie von FrameMaker gefragt, ob Sie den aktuellen Textrahmen mit diesem Textrahmen verketten wollen.


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen / Steuern des Textflusses

Abtrennen von Textrahmen

Sie trennen Textrahmen ab, um separate Textflüsse zu erstellen, z. B. um einen Artikel an einer bestimmten Position im Infoblatt einzufügen oder ein Textzitat zu erstellen. Wenn Sie einen neuen Textfluss in der Mitte einer Spalte beginnen müssen, können Sie den Textrahmen mit der Spalte teilen (siehe Teilen von Textrahmen) und die beiden Textrahmen dann abtrennen.

Sie können einen Textrahmen vom vorhergehenden, vom nachfolgenden oder von beiden Textrahmen abtrennen. Es ist auch möglich, einen Textrahmen aus der Mitte eines Textflusses zu entfernen.

Der enthaltene Text wird durch das Trennen der Textrahmen nicht beeinflusst. Wenn Sie Text in einen anderen Textrahmen verschieben möchten, schneiden Sie ihn nach dem Abtrennen aus und fügen ihn anschließend ein.

Hinweis: Wenn Sie Textrahmen auf derselben Arbeitsseite abtrennen, legt FrameMaker separate Textflüsse ohne Typ an. Werden Textrahmen auf unterschiedlichen Arbeitsseiten abgetrennt, erzeugt FrameMaker separate Textflüsse mit demselben Textflusstyp. Wenn Sie ein infoblattähnliches Dokument erstellen, in dem "Automatische Verkettung" für alle Textflüsse deaktiviert ist, spielen die Textflusstypen keine Rolle. FrameMaker legt nicht automatisch neue Seiten an und braucht daher auch keine Textrahmen zu verketten.

So trennen Sie Textrahmen ab:

    1. Wählen Sie den Textrahmen aus, der abgetrennt werden soll, indem Sie bei gedrückter Strg- bzw. Control-Taste auf den Textrahmen klicken.

    2. Wählen Sie "Format > Spezielles Layout" und dann "Vorherigen abtrennen", "Nächsten abtrennen" oder "Beide abtrennen".

So entfernen Sie einen Textrahmen aus der Mitte eines Textflusses:

    1. Wählen Sie den Textrahmen direkt vor dem zu löschenden Rahmen aus. Klicken Sie hierzu bei gedrückter Strg- oder Control-Taste auf den Textrahmen.

    2. Wählen Sie den Textrahmen aus, der direkt auf den zu löschenden Rahmen folgt.

    3. Wählen Sie "Format > Spezielles Layout > Textrahmen verketten". Wenn sich der zuerst ausgewählte Textrahmen auf einer Seite befindet, die momentan nicht sichtbar ist, werden Sie von FrameMaker gefragt, ob Sie den aktuellen Textrahmen mit diesem Textrahmen verketten wollen.


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen / Steuern des Textflusses

Teilen von Textrahmen

Sie können einen Textrahmen teilen und anschließend die Verkettung der beiden resultierenden Textrahmen aufheben, um einen neuen Textfluss zu beginnen. Auf diese Weise können Sie z. B. einen neuen Artikel mit eigenem Textfluss mitten in einem Textrahmen beginnen. Geteilte Textrahmen können bei Bedarf wieder zusammengeführt werden.

Der mittlere Textrahmen wurde geteilt, vom ersten Textrahmen getrennt und mit einem neuen Textflusstyp versehen.

So teilen Sie einen Textrahmen:

    1. Klicken Sie in die Zeile über der Stelle, an der der Textrahmen geteilt werden soll. Wählen Sie anschließend "Format > Spezielles Layout > Textrahmen teilen". FrameMaker teilt den Textrahmen horizontal unterhalb der Zeile mit der Einfügemarke und erstellt zwei separate, aber miteinander verkettete Textrahmen.

    2. Wählen Sie den unteren Textrahmen aus, indem Sie bei gedrückter Strg- bzw. Control-Taste auf den Textrahmen klicken.

    3. Wählen Sie "Format > Spezielles Layout > Vorherigen abtrennen", um den Textrahmen vom oberen Rahmen abzutrennen. Wenn dem Textfluss ein Typ zugewiesen war, wird dieser entfernt. War vor der Trennung der Textrahmen die Einstellung "Automatische Verkettung" aktiviert, ist sie nun für beide Textrahmen deaktiviert.

    4. Ändern Sie gegebenenfalls die Größe der Textrahmen.

So führen Sie geteilte Textrahmen wieder zusammen:

Führen Sie eine der folgenden Aktionen aus:

    Wenn seit der Teilung des Textrahmens keinerlei Änderungen vorgenommen wurden, können Sie die Teilung des Rahmens mit dem Befehl "Bearbeiten > Rückgängig" aufheben.

    Falls Sie eine Änderung durchgeführt, aber die beiden Textrahmen noch nicht abgetrennt haben, löschen Sie den unteren Rahmen und ändern dann die Größe des verbleibenden Textrahmens, bis er wieder die ursprüngliche Größe des ungeteilten Rahmens besitzt.

    Wenn Sie die beiden Rahmen bereits getrennt haben, schneiden Sie den Text aus dem zweiten Textrahmen aus und fügen ihn anschließend am Ende des ersten Rahmens ein. Danach löschen Sie den zweiten Textrahmen und vergrößern den ersten Rahmen, bis er wieder die Größe des ursprünglichen, ungeteilten Rahmens hat. Wenn Sie dann "Automatische Verkettung" wieder aktivieren oder dem Textfluss einen Typ zuweisen müssen, verwenden Sie den Befehl "Format > Spezielles Layout > Spezieller Textrahmen".


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen / Steuern des Textflusses

Querverweise auf Textrahmen

Wenn ein Artikel eines Infoblattes oder einer Zeitschrift auf einer anderen Seite fortgeführt wird, sollten Sie dem Leser mithilfe von Querverweisen mitteilen, wo der Artikel fortgesetzt wird. Entsprechend sollten Sie im Fortsetzungstextrahmen angeben, wo nach dem Ende des Artikels fortgesetzt wird.

Geben Sie an, wo der Textfluss weitergeführt wird und wo er begonnen hat.

So erzeugen Sie einen Querverweis auf einen abgetrennten Textrahmen:

    1. Vergrößern Sie die beiden Textrahmen, um Platz für die Querverweise zu schaffen. Verschieben Sie den unteren Rand des ersten Textrahmens nach oben und den oberen Rand des Fortsetzungsrahmens nach unten.

    2. Zeichnen Sie einen kleinen Textrahmen unter dem Textrahmen auf der ersten Seite und anschließend einen weiteren über dem Rahmen auf der Fortsetzungsseite. Verketten Sie die Textrahmen mit keinem anderen Textrahmen.

    3. Fügen Sie einen Querverweis in den leeren Textrahmen auf der ersten Seite ein und verweisen Sie darin auf die Fortsetzungsseite des Artikels. Informationen zur Verwendung von Querverweisen finden Sie unter Einfügen von Querverweisen.

    4. Fügen Sie einen Querverweis in den leeren Textrahmen auf der Fortsetzungsseite ein und verweisen Sie darin auf die erste Seite des Artikels.


Seitenlayout und Schablonen / Dokumente mit mehreren Textflüssen / Steuern des Textflusses

Verfolgen eines Textflusses

In einem Dokument mit vielen Textflüssen verlieren Sie leicht den Überblick über den Verlauf eines Textflusses. Durch Zoomen können Sie mehr Text eines Textflusses anzeigen oder von einem Textrahmen eines Textflusses zum nächsten wechseln.

So zeigen Sie mehr Text eines Textflusses an:

    1. Zoomen Sie die Darstellung auf 25 % und passen Sie die Fenstergröße so an, dass alle erforderlichen Seiten sichtbar sind.

    2. Klicken Sie in den Textfluss, den Sie überprüfen möchten, und wählen Sie "Bearbeiten > Textfluss auswählen". Der Textfluss ist nun hervorgehoben, und Sie können seinen Verlauf auf den Dokumentseiten verfolgen.

So blättern Sie durch die Textrahmen eines Textflusses:

Führen Sie eine der folgenden Aktionen aus:

    Um den nächsten verketteten Textrahmen anzuzeigen, klicken Sie in die letzte Zeile eines Textrahmens und drücken Sie die Nach-Unten-Taste.

    Um den vorhergehenden verketteten Textrahmen anzuzeigen, klicken Sie in die erste Zeile eines Textrahmens und drücken Sie die Nach-Oben-Taste.


Seitenlayout und Schablonen

Arbeiten mit Referenzseiten

Sie können Grafiken, die in einem Dokument öfter verwendet werden, auf Referenzseiten speichern und sie bei Bedarf später auf den Arbeitsseiten des Dokuments einfügen. Nachdem eine Grafik in einen Referenzrahmen (einen nicht verankerten Rahmen auf einer Referenzseite) platziert wurde, kann der Rahmen als Einstellung eines Absatzformats eingesetzt werden. Um z. B. eine Überschrift mit einer Linie darunter zu definieren, zeichnen Sie die Linie in einem Referenzrahmen und nehmen den Referenzrahmen in das Absatzformat der Überschrift auf.

Referenzseite und Arbeitsseite

Referenzseiten können auch Mustergrafiken oder Clipart enthalten, die kopiert und auf Arbeitsseiten eingefügt werden (z. B. Symbole zur Kennzeichnung von Hinweisen). Spezielle Referenzseiten können auch Hypertext-Befehle, Formatinformationen für generierte Listen und Indizes, Definitionen für spezielle FrameMath-Elemente und Zuordnungen für die Konvertierung in das XML- und das HTML-Format enthalten.

Ein Dokument besitzt normalerweise mindestens eine Referenzseite. Sie können Grafiken entweder einer vorhandenen Referenzseite hinzufügen oder weitere Referenzseiten (maximal 100) anlegen.

So zeigen Sie Referenzseiten an:

Wählen Sie "Darstellung > Referenzseiten". Der Name der aktuellen Referenzseite wird im Seitenstatus-Bereich der Statuszeile angezeigt.

Seitenstatus-Bereich

Falls das Dokument keine Referenzseiten enthält, wird das Dialogfenster "Referenzseiten einfügen" angezeigt. Erstellen Sie die erste Referenzseite, indem Sie einen Seitennamen eingeben und auf "Einfügen" klicken.

So zeigen Sie andere Referenzseiten an, wenn bereits eine Referenzseite eingeblendet ist:

Führen Sie eine der folgenden Aktionen aus:

    Klicken Sie auf die Schaltfläche "Nächste Seite" [image] oder "Vorherige Seite" [image] .

    Drücken Sie die Bild-Auf- oder die Bild-Ab-Taste.

    Verwenden Sie den Rollbalken.

So erstellen Sie eine Referenzseite:

    1. Aktivieren Sie die Anzeige der Referenzseiten und wählen Sie "Spezial > Referenzseite einfügen".

    2. Geben Sie einen Namen für die Referenzseite ein und klicken Sie auf "Einfügen".

So kehren Sie zu den Arbeitsseiten zurück:

Wählen Sie "Darstellung > Arbeitsseiten". Es wird wieder die Arbeitsseite eingeblendet, die zuletzt angezeigt wurde.


Seitenlayout und Schablonen / Arbeiten mit Referenzseiten

Umbenennen und Löschen von Referenzseiten

Sie können eine Referenzseite umbenennen. Wenn Sie z. B. die Referenzseiten aus einer Schablone in ein vorhandenes Dokument importieren, können Sie durch Umbenennen verhindern, dass eine vorhandene Referenzseite gleichen Namens überschrieben wird.

Referenzseiten, die für ein Dokument nicht mehr benötigt werden, können Sie löschen. Wenn Sie allerdings eine Referenzseite löschen, die eine in einem Absatzformat verwendete Grafik enthält, wird die Grafik in Absätzen mit diesem Format nicht mehr angezeigt. In diesem Fall ist im Aufklappmenü "Rahmen über [image] " bzw. "Rahmen unter [image] " auf der Registerkarte "Extra" der Absatzgestaltung "Beibehalten" eingestellt.

So benennen Sie eine Referenzseite um:

    1. Zeigen Sie die Referenzseite an und klicken Sie auf den Seitennamen in der Statuszeile.

    2. Geben Sie den neuen Namen ein und klicken Sie auf "Zuweisen".

So löschen Sie eine Referenzseite:

Zeigen Sie die Referenzseite an und wählen Sie "Spezial > Seite löschen".


Seitenlayout und Schablonen / Arbeiten mit Referenzseiten

Verwenden von Referenzrahmen auf Referenzseiten

Um eine Grafik als Teil eines Absatzformates zu verwenden, platzieren Sie die Grafik auf einer Referenzseite in einem Referenzrahmen. Information über die Verwendung von Referenzrahmen in einem Absatzformat finden Sie unter Hinzufügen von Grafiken zu Absatzformaten.

Grafiken in Referenzrahmen

Nach der Auswahl eines Referenzrahmens auf einer Referenzseite wird sein Name in der Statuszeile nach dem Wort "Frame" eingeblendet.

So erstellen Sie einen Referenzrahmen auf einer Referenzseite:

    1. Klicken Sie auf das Grafikrahmen-Werkzeug [image] in der Werkzeugpalette und zeichnen Sie den Rahmen. Durch Ziehen bei gedrückter Umschalttaste können Sie einen quadratischen Rahmen zeichnen.

    2. Geben Sie in das Textfeld "Name" einen Namen ein und klicken Sie auf "Zuweisen". Verwenden Sie einen kurzen, aussagekräftigen Namen, den Sie später in den Aufklappmenüs "Rahmen über [image] " und "Rahmen unter [image] " auf der Registerkarte "Extra" der Absatzgestaltung wiedererkennen.

    3. Platzieren Sie eine Grafik im Rahmen. Sie können die Grafik zeichnen, eine Grafikdatei importieren oder gezeichnete und importierte Grafiken kombinieren.

    4. Passen Sie gegebenenfalls die Rahmengröße und -form an. Wenn Sie einen Referenzrahmen über oder unter einem Absatz auf einer Arbeitsseite verwenden, wird nicht nur die Grafik, sondern der gesamte Rahmen auf der Arbeitsseite angezeigt. Die Höhe des Rahmens beeinflusst den Abstand des Textes über und unter dem Rahmen.

    5. Geben Sie mithilfe des Textzeilen-Werkzeugs über dem Rahmen den Rahmennamen ein (siehe Grafiken und Text). Der eingegebene Name dient der raschen Identifizierung des Rahmens, wenn Sie die Referenzseite anzeigen. Die Eingabe des Namens führt nicht zu einer Umbenennung des Referenzrahmens.

So benennen Sie einen Referenzrahmen um:

    1. Wählen Sie den Referenzrahmen aus und klicken Sie in der Statuszeile auf den Namen des Rahmens.

    2. Geben Sie den neuen Namen ein und klicken Sie auf "Zuweisen". Sie sollten den neuen Namen auch in die Textzeile über dem Referenzrahmen eingeben. Wenn Sie einen Referenzrahmen umbenennen, der in einem Absatzformat verwendet wird, müssen Sie das Format aktualisieren, damit der neue Name verwendet wird (siehe Hinzufügen von Grafiken zu Absatzformaten).

So ändern Sie andere Einstellungen eines Referenzrahmens:

Wählen Sie den Rahmen aus und verwenden Sie entweder "Grafik > Objekteinstellungen" oder die Optionen der Werkzeugpalette. Weitere Informationen finden Sie unter Zuweisen und Ändern von Zeichnungseinstellungen, Verschieben von Objekten und Ändern und Umformen von Objekten.


Seitenlayout und Schablonen / Arbeiten mit Referenzseiten

Einrichten von Mustergrafiken auf Referenzseiten

Sie können Mustergrafiken (z. B. spezielle Randsymbole) in verankerten Rahmen auf einer Referenzseite einrichten. Später können Sie die verankerten Rahmen auf die Arbeitsseiten kopieren. Die Grafiken werden dann an der korrekten Position in ihren verankerten Rahmen angezeigt.

Mustergrafiken können kopiert und in Arbeitsseiten eingefügt werden.

Sie können Grafiken auch direkt auf einer Referenzseite platzieren, sie anschließend kopieren und an einer beliebigen Stelle auf Arbeitsseiten einfügen.

So richten Sie eine Mustergrafik in einem verankerten Rahmen ein:

    1. Legen Sie eine Referenzseite mit dem Spaltenlayout der Arbeitsseite an, in der die Grafik angezeigt werden soll. Damit stellen Sie sicher, dass die Grafik beim Kopieren in die Arbeitsseiten korrekt platziert wird. Um das Spaltenlayout zu definieren, können Sie den Textrahmen von einer Arbeitsseite kopieren und auf der Referenzseite einfügen.

Richten Sie den verankerten Rahmen auf der Referenzseite exakt so ein, wie er auf den Arbeitsseiten dargestellt werden soll.

    2. Zeichnen Sie die Grafik im verankerten Rahmen. Sie können die Grafik auch in den Rahmen einfügen oder importieren. Fügen Sie gegebenenfalls beschreibenden Text außerhalb des verankerten Rahmens hinzu. Beispielsweise wird in der Abbildung die Grafik durch den Text Caution Symbol beschrieben.


Seitenlayout und Schablonen / Arbeiten mit Referenzseiten

Zuweisen von Vorgabeseiten zu Seiten, die Elemente enthalten

Wenn Sie Arbeitsseiten in strukturierten Dokumenten, die Elemente enthalten, Vorgabeseiten zuweisen möchten, ordnen Sie die Elemente den Vorgabeseiten mithilfe der Zuordnungstabelle für Referenzseiten zu. Nach der Verwendung des Befehls "Vorgabeseiten zuweisen" wird die Vorgabeseite auf die Arbeitsseite angewendet, die das referenzierte Element enthält.

Weitere Informationen über das Zuweisen von Vorgabeseiten finden Sie unter Zuweisen von Vorgabeseiten zu Arbeitsseiten mit Absatztypen.

So weisen Sie einer Arbeitsseite, die ein Element enthält, eine Vorgabeseite zu:

    1. Wählen Sie im strukturierten FrameMaker "Ansicht > Referenzseiten".

    2. Klicken Sie auf die Schaltfläche "Nächste Seite" [image] , bis die achtspaltige Tabelle "StrukturierteVorgabeseitenzuordnung" angezeigt wird.

Wenn Sie in einem Dokument arbeiten, das mit einer früheren Version von FrameMaker erstellt wurde, wählen Sie "Format > Seitenlayout > Vorgabeseiten zuweisen", damit die Zuordnungstabelle auf den Referenzseiten angezeigt wird.

    3. Geben Sie rechts neben "Buchaktualisierung" Ja oder Nein ein, um festzulegen, ob die angegebene Vorgabeseite angewendet wird, wenn Sie in einem Buch "Vorgabeseiten zuweisen" wählen.

    4. Führen Sie zur Bearbeitung der Tabelle folgende Schritte aus:

    Geben Sie unter der Tabellenüberschrift "Name des Element-Tags bzw. Absatztyps" ein gültiges Präfix ein (E: für Elementtyp oder P: für Absatztyp), gefolgt vom Namen des Element- oder Absatztyps, auf den die Vorgabeseite angewendet werden soll. Wenn kein Präfix verwendet wird, wird ein Element-Tag angenommen. Achten Sie bei der Eingabe des Element- oder Absatztypnamens auf die richtige Schreibweise, einschließlich der Groß- und Kleinschreibung. Diese Spalte ist erforderlich, damit Vorgabeseiten zugewiesen werden können.

    Geben Sie unter der Überschrift "Rechte Vorgabeseite" den Namen der Vorgabeseite ein, die Sie zuweisen möchten. Die angegebene Vorgabeseite wird auf alle Arbeitsseiten angewendet, einschließlich der linken Seiten in doppelseitigen Dokumenten, auf denen die Element- oder Absatztypen enthalten sind, es sei denn, Sie geben unter "Linke Vorgabeseite" eine andere Vorgabeseite an. In Namen von Vorgabeseiten wird zwischen Groß- und Kleinschreibung unterschieden. Diese Spalte ist erforderlich, damit Vorgabeseiten zugewiesen werden können.

    Geben Sie unter "Linke Vorgabeseite" den Namen der Vorgabeseite ein, die in doppelseitigen Dokumenten auf linke Arbeitsseiten angewendet werden soll, wenn sie die entsprechenden Element- oder Absatztypen enthalten. Diese Spalte ist optional.

    Geben Sie unter "Attributname" einen gültigen Attributnamen ein, um den weiteren Zuordnungskontext zu definieren.

    Geben Sie unter "Attributwert" einen gültigen Attributwert ein, um den weiteren Zuordnungskontext zu definieren.

    Geben Sie unter "Kontext" einen Wert für die Kontextbezeichnung eines Elements ein, um den weiteren Zuordnungskontext zu definieren.

    Geben Sie unter "Bereichsindikatoren" Einseitig ein, wenn die Vorgabeseite nur auf die Arbeitsseite angewendet werden soll, auf der der Element- oder Absatztyp vorhanden ist, geben Sie Doppelseiten ein, wenn die Vorgabeseite auf den gesamten Bereich der Seiten angewendet werden soll, auf den der Element- oder Absatztyp angewendet wird, oder geben Sie Gültig bis Änderung ein, um die Vorgabeseite auf alle Seiten anzuwenden, bis in der Zuordnungstabelle die nächste Vorgabeseite mit einem abweichenden Element- oder Absatztyp erkannt wird. Wenn diese Zelle leer ist, werden die Vorgabeseiten auf einzelne Seiten angewendet.

    Fügen Sie in der Spalte "Kommentare" Anmerkungen hinzu. In diese Spalte eingetragener Text wirkt sich nicht auf die Zuweisung von Vorgabeseiten aus.

    Wenn Sie Elementen oder Absatztypen weitere Vorgabeseiten zuweisen möchten, müssen Sie zusätzliche Tabellenreihen hinzufügen und ausfüllen.

    5. Wählen Sie abschließend "Darstellung > Arbeitsseiten".

    6. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    7. Wählen Sie "Format > Seitenlayout > Vorgabeseiten zuweisen" und klicken Sie anschließend auf "Ja", um manuell zugewiesene Vorgabeseiten zu überschreiben.

FrameMaker durchsucht alle Arbeitsseiten nach dem ersten Auftreten der in der Tabelle für die Vorlagenseitenzuordnung angegebenen Element- oder Absatztypen. Wenn Text mit dem festgelegten Element-oder Absatztyp gefunden wird, wird die angegebene Vorgabeseite zugewiesen.


Seitenlayout und Schablonen

Schablonen

Schablonen sind FrameMaker-Dokumente, die als Grundlage für die Formatierung anderer Dokumente dienen. Mithilfe einer Schablone erzielen Sie auf einfache Weise ein einheitliches Design für mehrere Dokumente. Sie können auf der Grundlage einer Schablone ein neues Dokument erstellen oder Formate aus einer Schablone in ein vorhandenes Dokument importieren.

Dieser Abschnitt wendet sich hauptsächlich an den Schablonendesigner, der Schablonen für Arbeitsgruppen entwickelt. Wenn Sie keine Schablonen gestalten oder bearbeiten, ist für Sie nur der folgende Abschnitt "Verwenden von Schablonen" sowie der Abschnitt Importieren und Aktualisieren von Formaten von Interesse.


Seitenlayout und Schablonen

Verwenden von Schablonen

Beim Erstellen von Dokumenten werden Sie von FrameMaker dazu aufgefordert, eine Schablone auszuwählen, die als Grundlage für das Dokument dienen soll. In FrameMaker stehen eine Reihe vordefinierter Schablonen zur Auswahl. In einer Arbeitsgruppenumgebung sind möglicherweise weitere Schablonen verfügbar, die besondere Anforderungen erfüllen.

Sie können die in einer externen CSS-Datei definierten Importstile auch in Ihre EDD-Datei importieren. Weitere Informationen finden Sie unter Importieren von CSS-Elementstilen in eine EDD-Datei (Windows).

Sie können eine Schablone (A) einem Dokument (B) zuweisen, um das Design des Dokuments zu aktualisieren.

Informationen zur Erstellung eines neuen Dokuments auf der Basis einer vordefinierten Schablone finden Sie unter Erstellen von Dokumenten.


Seitenlayout und Schablonen / Verwenden von Schablonen

Planen von Schablonen

Versuchen Sie, sich beim Entwickeln einer speziellen Schablone die Anforderungen anderer Benutzer vorzustellen und möglichst viele Elemente zu berücksichtigen, die für mehrere Dokumente gelten. Sie sollten beispielsweise die folgenden Punkte beachten.

Vorgesehene Verwendung der Schablone

Versuchen Sie, sich die Situationen vorzustellen, in denen die Schablone eingesetzt wird. Definieren Sie alle Formate und sonstigen Gestaltungselemente, die andere Benutzer voraussichtlich benötigen. Je umfassender die Schablone ist, desto weniger Anpassungen müssen die Benutzer später an ihren Dokumenten vornehmen. Informationen über Formate und Gestaltungselemente finden Sie unter Erstellen von Schablonen.

Vorhandene Schablonen

Bevor Sie eigene Schablonen erstellen, sollten Sie einen Blick auf die vorhandenen Schablonen werfen, insbesondere diejenigen, die im Lieferumfang von FrameMaker enthalten sind. Verwenden Sie diese Schablonen als Grundlage für die Gestaltung von eigenen Vorgabeseiten, Absatz- und Zeichenformaten, Kopf- und Fußzeilen, Querverweisformaten und automatischer Nummerierung.

Wenn eine existierende Schablone bereits viele Ihrer Anforderungen erfüllt, können Sie diese als Grundlage verwenden. Nehmen Sie die gewünschten Änderungen vor und sichern Sie sie unter einem anderen Namen als neue spezielle Schablone.

Online-Anzeige

Wenn Sie ein Dokument entwerfen, das in erster Linie online verwendet wird (aber nicht im HTML-Format), sollte das Seitenformat nicht größer sein als der kleinste Bildschirm, auf dem die Seite später angezeigt wird. Für den Einsatz auf Laptop-Computern ist möglicherweise eine Ausrichtung im Querformat erforderlich.

Sollen Dokumente, die auf Schablonen basieren, später in HTML-Format konvertiert werden, müssen Sie Formate und Gestaltungselemente verwenden, für die HTML-Entsprechungen existieren. Beispielsweise erscheinen die Hintergrundgrafiken der Vorgabeseiten Ihrer FrameMaker-Dokumente nicht in den HTML-Dateien und gedrehter Text wird in HTML-Dateien nicht gedreht angezeigt. Auch Fußnoten haben möglicherweise nicht das gewünschte Erscheinungsbild.

Lokalisierung

Wenn Dokumente auf der Grundlage Ihrer Schablone in andere Sprachen übersetzt werden, sollten Sie den Übersetzern die Überarbeitung der Schablone ermöglichen. Bestimmte Gestaltungselemente sind eventuell für andere Sprachen nicht geeignet. Das Papierformat und vorgegebene Abmessungen müssen möglicherweise für andere Länder geändert werden.

Schriften

Entscheiden Sie möglichst früh, welche Schriften verwendet werden. Schriften beeinflussen viele andere Gestaltungselemente, z. B. die Zeilenhöhe in Absätzen oder die Höhe der Spalten für Kopf- und Fußzeilen.

Plattformen

Wenn die auf der Schablone basierenden Dokumente auf unterschiedlichen Plattformen bearbeitet werden, sollten Sie Schriften verwenden, die auf allen Systemen verfügbar sind. Verwenden Sie außerdem plattformübergreifende Namenskonventionen für Ihre Schablonen, für die auf den Schablonen basierenden Dokumente und für die Ordner, in denen die Dokumente abgelegt werden. Einzelheiten hierzu finden Sie im Online-Handbuch Arbeiten auf unterschiedlichen Plattformen.

Benutzerfreundlichkeit

Versuchen Sie, die Schablonen universell einsetzbar und gleichzeitig ansprechend zu gestalten. Beachten Sie dabei folgende Richtlinien:

    Bedenken Sie, dass andere Benutzer mit FrameMaker möglicherweise nicht so vertraut sind wie Sie. Gestalten Sie die Schablone so einfach und benutzerfreundlich wie möglich.

    Definieren Sie die Schablone so, dass sie möglichst automatisch und reibungslos funktioniert. Legen Sie z. B. "Typ nächster [image] " in den Basis-Einstellungen der Absatzgestaltung fest, oder aktivieren Sie "Umbruch mit: Nächstem" oder "Umbruch mit: Vorherigem" in den Seitenumbruch-Einstellungen.

    Wenn Sie eine Gruppe von Schablonen für ein Buch vorbereiten, erstellen Sie neben den Schablonen für die Buchdateien auch solche für das Inhaltsverzeichnis und den Index. Sie sollten die Schablonen dabei möglichst allgemein anlegen, damit Sie nur eine geringe Anzahl benötigen. So könnten Sie z. B. eine Schablone für Kapitel, Vorwort und Anhänge definieren. Wenn Änderungen anfallen, brauchen Sie in diesem Fall nicht so viele Schablonen zu aktualisieren.

    Definieren Sie für jedes benötigte Seitenlayout eine Vorgabeseite. Eine Kapitelschablone könnte z. B. je eine Vorgabeseite für eine erste Seite, eine rechte Seite, eine linke Seite und eine gedrehte Seite enthalten, selbst wenn in den meisten Kapiteln später keine gedrehte Seite mehr vorkommt.

    Dokumentieren Sie die Schablone für andere Benutzer. Wenn die Schablone Beispieltext enthält, können Sie mit diesem die Schablonenkomponenten beschreiben. Ein Haupttextabsatz könnte etwa den Text Dies ist ein Haupttextabsatz enthalten. Schreiben Sie nach Fertigstellung der Schablone eine Zusammenfassung der enthaltenen Elemente und speichern Sie das Dokument im selben Ordner bzw. Verzeichnis wie die Schablone.


Seitenlayout und Schablonen

Erstellen von Schablonen

Wenn Sie eine Schablone definieren, gestalten Sie Vorgabeseiten, legen Formate fest, weisen sie zu und definieren speziellen Text wie z. B. Querverweisformate und Variablen. Dieser Abschnitt bietet nur einen Überblick über den Ablauf beim Erstellen einer Schablone. Ausführliche Anweisungen finden Sie in anderen Kapiteln dieses Buches.

Gestalten des Seitenlayouts

Beginnen Sie die Erstellung der Schablone mit der Festlegung des allgemeinen Seitenlayouts. Hierzu gehören Auswahl eines Formats, Definieren des Spaltenlayouts, Anlegen von Vorgabeseiten und Festlegen der grundlegenden Dokumenteinstellungen. Weitere Informationen finden Sie unter Seitenlayout und Schablonen.

So gestalten Sie das Seitenlayout:

    1. Erstellen Sie ein neues Dokument. Sie können entweder mit einem neuen Dokument in Spezialformat beginnen oder mit einer Kopie eines vorhandenen Dokuments, das Sie ändern möchten.

Bei der Gestaltung des Seitenlayouts können Sie sehen, wie gegenüberliegende Seiten wirken, indem Sie sie nebeneinander anzeigen. Wählen Sie "Darstellung > Optionen" und dann "Gegenüberliegende Seiten" aus dem Aufklappmenü "Durchsuchen". Vergrößern Sie das Dokumentfenster und zoomen Sie die Darstellung bei Bedarf kleiner, damit beide Seiten im Fenster Platz finden.

    2. Definieren Sie das Spaltenlayout. Wenn Sie mit einem Dokument in Spezialformat begonnen haben, sind Ränder und Anzahl der Spalten bereits festgelegt. Wenn Sie ein existierendes Dokument bearbeiten, ist möglicherweise eine Änderung des Spaltenlayouts erforderlich.

    3. Fügen Sie bei Bedarf Vorgabeseiten hinzu und geben Sie ihnen einen Namen.

    4. Geben Sie Hintergrundtext und -grafiken einschließlich Kopf- und Fußzeile auf den Vorgabeseiten ein.

Wenn in einer laufenden Kopf- oder Fußzeile Text oder automatische Nummerierung für einen Dokumentabsatz angezeigt wird (z. B. ein Kapitel- oder Abschnittstitel), enthält sie eine Variable für laufende Kopf- und Fußzeilen, die auf den entsprechenden Absatz verweist. In diesem Fall sollten Sie sich bereits jetzt für den Typ dieses Absatzes entscheiden.

    5. Definieren Sie die speziellen Dokumenteinstellungen wie Nummerierung und Textoptionen und legen Sie die Darstellungsoptionen fest.

Gestalten der Textformate

Nach dem Gestalten des Seitenlayouts sollten Sie festlegen, wie der Text formatiert wird. Eine gute Schablone enthält ein Absatz- und Zeichenformat für jeden Texttyp, der in den Dokumenten auftritt. Beachten Sie folgende Richtlinien:

    Wenn Ihr Dokument auch auf anderen Computern geöffnet oder gedruckt wird, verwenden Sie Schriften, die auf den meisten Rechnern installiert sind.

    Absatzformate bilden die Basis der Textformatierung und sollten deshalb vor der Definition der Zeichenformate festgelegt werden.

    Geben Sie bei der Definition eines Zeichenformats im Dialogfenster "Zeichengestaltung" für alle Einstellungen "Beibehalten" an und legen Sie nur die zu ändernden Einstellungen fest. Ein solches Zeichenformat eignet sich für jedes Absatzformat.

    Typnamen sollten nicht auf das Aussehen des Formats, sondern auf seinen Verwendungszweck hinweisen. Nennen Sie z. B. ein Format für hervorgehobenen Text nicht Fett, sondern Hervorhebung. Wenn Sie später beschließen, Kursivschrift für Hervorhebungen zu verwenden, können Sie das Format Hervorhebung umdefinieren, ohne den Namen zu ändern.

    Verwenden Sie Namen, die aussagekräftig und einprägsam sind. Nennen Sie z. B. Formate für nummerierte Listen Schritt1 und Schrittn, nicht S1 und Sn. Wenn Sie Absatz- und Zeichentypen mithilfe der Tastatur zuweisen möchten, können Sie die Typen sch1 Schritt1 und schn Schrittn nennen. Auf diese Art können Sie mithilfe der Tastatur schnell auf Typen und Beschreibungen zugreifen. Weitere Informationen finden Sie unter Zuweisen von vordefinierten Formaten zu Text.

    Wenn die Schablone mehr als eine automatische Nummerierungsfolge enthält, fügen Sie jedem Format eine Kennung für die automatische Nummerierung hinzu. Definieren Sie z. B. die automatische Nummerierung für Arbeitsschritte als S:<n+>,, wobei S: die Schrittkennung ist.

    Verwenden Sie in Absatzformaten durchgehend "Abstand: Oben" oder "Abstand: Unten", um den Abstand ober- und unterhalb von Absätzen festzulegen. (In FrameMaker wird nur der größere der beiden Werte zur Bestimmung der Abstände zwischen Absätzen verwendet.)

Standardisieren von Grafiken, Rahmen und Tabellen

Wenn die Dokumente später Grafiken, Rahmen oder Tabellen enthalten, orientieren Sie sich an folgenden Richtlinien, um ein einheitliches Aussehen zu garantieren:

    Platzieren Sie Standardelemente auf einer Referenzseite. Sie können Grafiken einfügen, die Benutzer immer wieder benötigen, z. B. ein Symbol, das die Aufmerksamkeit auf Hinweise und Warnungen lenkt, oder einen verankerten Rahmen mit Standardhöhe und -breite. Diese Elemente können dann von den Benutzern nach Bedarf kopiert und eingefügt werden.

    Definieren Sie ein Absatzformat für verankerte Rahmen. Damit erzielen Sie einheitliche Abstände um Grafiken. Für ein Absatzformat mit dem Namen Rahmen könnte z. B. die Einstellung "Abstand: Unten" auf 20 Punkt und die Einstellung "Zeilenabstand" auf null gesetzt werden. Jeder Rahmen könnte dann in einem leeren Absatz des Typs "Rahmen" verankert werden. Eine Alternative hierzu wäre die Verwendung von einzelligen Tabellen und ihren Titeln für Grafiken und deren Beschriftung.

    Wenn Textrahmen für Bildbeschriftungen verwendet werden, sollten Sie ein Absatzformat für die Beschriftungen definieren. Werden für die Bildbeschriftungen Textzeilen benutzt, definieren Sie ein Zeichenformat. (Einer Textzeile kann kein Absatzformat zugewiesen werden.)

    Wählen Sie eine Farbpalette und definieren Sie bei Bedarf die Farben und Farbauszüge neu.

    Bereiten Sie Standardtabellenformate vor. Nicht alle Einstellungen, die Sie für Tabellen festlegen, können in ein anderes Dokument importiert werden. Die Breite von Text (wie auch andere Einstellungen) kann in den Tabellen erheblich variieren. Daher müssen Benutzer einige Einstellungen wahrscheinlich immer selbst anpassen. Betrachten Sie Ihre Tabellen als Ausgangspunkt für die Benutzer. Eine Liste der Einstellungen, die im Tabellenformat gespeichert sind, finden Sie unter Erläuterung von Tabellen.

Einrichten der Nummerierung

Die Seitennummerierung ist für neue Dokumente auf "Wieder bei 1 beginnen" eingestellt. Wenn Sie eine Schablone für fortlaufende Seitennummerierung in Büchern definieren, sollten Sie die Seitennummerierung in der Schablone auf "Nummerierung von voriger Seite im Buch weiterführen" einstellen. Zusätzlich sollten Sie die Kapitelnummerierung auf "Nummerierung von voriger Datei im Buch weiterführen" einstellen. Weitere Informationen über das Einrichten der Nummerierung finden Sie unter Festlegen der Nummerierung von Dokumenten und Seiten.

Definieren von speziellem Text

Eine Schablone kann Definitionen und Vorgaben für die Arbeit mit speziellem Text enthalten. Folgende Aktionen können für das Definieren spezieller Textelemente erforderlich sein:

    Legen Sie für Fußnoten eine Nummerierungsart, ein Nummerierungsformat und weitere Einstellungen fest.

    Definieren Sie Querverweisformate. Standardisieren Sie diese Formate so weit wie möglich. Wenn Querverweise z. B. immer mit siehe beginnen sollen, nehmen Sie dieses Wort in die Formatdefinition auf.

    Definieren Sie Benutzervariablen für Produktnamen, Dokumentnamen und andere Elemente, die sich im Projektverlauf ändern können.

    Definieren Sie Bedingungstypen, Bedingungsformate und Anzeigeeinstellungen für bedingten Text.

    Definieren Sie spezielle Markentypen, wenn besondere Indizes erstellt werden müssen.

    Definieren Sie Gleichungsgrößen und -schriften, wenn Dokumente Gleichungen enthalten werden.

Festlegen von HTML-Optionen

Wenn Dokumente, die auf Ihren Schablonen basieren, in das HTML-Format konvertiert werden sollen, müssen Sie die Zuordnungen und Konvertierungsmakros für die Umwandlung der Dokumente einrichten. Gehen Sie im Einzelnen folgendermaßen vor:

    Richten Sie die Zuordnung der FrameMaker-Absatzformate und -Zeichenformate zu HTML-Tags ein.

    Erstellen Sie Konvertierungsmakros, die Querverweisformate in eine geeignete Form für Online-Dokumente umwandeln.

    Erstellen Sie bei Bedarf weitere Konvertierungsmakros (z. B. zur Anzeige eines Logos am Anfang jeder neuen Webseite oder zur Definition eines Titels für das HTML-Dokument).

Festlegen der Optionen für japanischen Text

Wenn Ihre Dokumente japanischen Text enthalten, müssen die zu verwendenden kombinierten Schriften definiert und die Einstellungen für Rubi-Text festgelegt werden.

Testen von Schablonen

Bevor Sie anderen Benutzern den Zugriff auf Ihre Schablone gestatten, testen Sie die Schablonen unbedingt gründlich. Erstellen Sie dazu einige Beispieldokumente auf der Grundlage der Schablone und prüfen Sie, ob die Dokumente wie gewünscht aussehen und wirken. Gehen Sie beim Testen von Schablonen folgendermaßen vor:

    Mischen Sie unterschiedliche Absatztypen auf einer Seite, um sicherzustellen, dass Zeilenabstand und Durchschuss korrekt sind. Prüfen Sie jeden Absatztyp an allen Positionen, an denen er voraussichtlich eingesetzt wird. Manchmal hat ein Absatz an einer Stelle das gewünschte Aussehen, an einer anderen jedoch nicht. Beispielsweise könnte der Abstand nach einem Haupttextabsatz korrekt sein, wenn dieser vor einem anderen Haupttextabsatz auftritt. Vor einer Liste könnte sich der Abstand jedoch als zu groß erweisen.

    Überprüfen Sie sorgfältig die gesamte automatische Nummerierung. Testen Sie die Nummerierung von Arbeitsschritten, Abbildungen und allen anderen automatisch nummerierten Absätzen, die in der Schablone definiert sind. Prüfen Sie auch die Ausrichtung von Kapitelnummern und Listen mit zweistelligen Zahlen.

    Weisen Sie jede Vorgabeseite einer Arbeitsseite zu.

    Zeigen Sie jeden Bedingungstyp mit seinem Bedingungsformat an und überprüfen Sie, ob die Formate den gewünschten Effekt erzielen.

    Testen Sie die Farbdefinitionen. Dadurch stellen Sie sicher, dass Farbobjekte das erwartete Aussehen aufweisen. Bedenken Sie, dass Farben am Bildschirm anders wirken als gedruckte Farben. Führen Sie gegebenenfalls einige Testausdrucke in Zusammenarbeit mit einer Druckerei durch.

    Erstellen Sie Tabellen mit unterschiedlichen Tabellenformaten.

    Erstellen Sie Gleichungen und testen Sie die Gleichungsgrößen und -schriften sowie die Definitionen mathematischer Elemente.

    Generieren Sie ein Inhaltsverzeichnis für ein Beispieldokument. Prüfen Sie die automatische Nummerierung von Kapiteln und Überschriften.

    Fügen Sie einem Buch einige Beispieldokumente hinzu und aktualisieren Sie die Dokumente. Prüfen Sie kapitelübergreifende Nummerierungen wie Kapitel- und Seitennummern.

    Drucken Sie ein Beispieldokument, um zu sehen, wie es auf Papier wirkt.

    Wenn die Dokumente in das HTML-Format konvertiert werden sollen, testen Sie den Konvertierungsvorgang.


Seitenlayout und Schablonen

Organisieren von Schablonen in einem Ordner

Ein Schablonenordner sollte alle zusammengehörigen Schablonen und ein Dokument enthalten, das die Schablonen und ihre Verwendung beschreibt.

So organisieren Sie Schablonen in einem Ordner:

    1. Legen Sie einen neuen Ordner an und geben Sie ihm einen Namen, der auf den Zweck der Schablonen hinweist. Wenn in einem Netzwerk auch andere Benutzer mit den Schablonen arbeiten, legen Sie den Ordner an einer Stelle ab, an der ihn die Benutzer finden und auf ihn zugreifen können.

Auf UNIX-Systemen können Sie die Schablonen allen Benutzern zugänglich machen, indem Sie sie im Ordner "schabl" ablegen ($FMHOME/fminit/Sprache/schabl; dabei ist Sprache die Sprache der Benutzeroberfläche, z. B. "usenglish" oder "ukenglish"). In Windows können Sie den Standard-Schablonenordner ändern (weitere Informationen finden Sie im Online-Handbuch "Anpassen von FrameMaker-Produkten" auf der Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf).

    2. Legen Sie alle Schablonen im neuen Ordner ab.

    3. Legen Sie die Dateiberechtigungen so fest, dass die Benutzer nur Lesezugriff auf die Schablonen haben.


Seitenlayout und Schablonen

Erstellen von Schablonen für generierte Dateien

Wenn Sie ein Inhaltsverzeichnis, einen Index oder eine andere generierte Datei in einem Ordner erstellen, der neben dem Quelldokument oder der Buchdatei eine andere Datei mit demselben Namen wie die generierte Datei enthält, verwendet FrameMaker bei der Generierung der neuen Datei die Formatierung der vorhandenen. Dabei dient die bestehende generierte Datei als Schablone für die neue Datei, als hätten Sie Formate aus ihr importiert. Mithilfe dieser Funktion können Sie Schablonen für generierte Dateien erstellen, die Seitenlayout, Absatz- und Zeichenformate sowie Formatierungsinformationen der Referenzseite enthalten.

Es ist auch möglich, die Formate in einer generierten Datei durch den Import von Formaten aus einer Schablone zu aktualisieren. Allerdings muss die Datei nach dem Import der Formate wahrscheinlich neu generiert werden, damit alle Formatierungen sichtbar sind. Weitere Informationen hierzu finden Sie unter Importieren und Aktualisieren von Formaten.

So erstellen Sie eine Schablone für eine generierte Datei:

    1. Öffnen Sie die Dokument- oder Buchdatei, aus der Sie das Inhaltsverzeichnis, den Index oder eine sonstige Datei generieren möchten.

    2. Generieren Sie die Datei.

    3. Formatieren Sie die generierte Datei. Diese formatierte Datei ist Ihre Schablone.

    4. Speichern Sie die generierte Datei. Stellen Sie sicher, dass sich die aus der generierten Datei erstellte Schablone in dem Ordner mit der Dokument- oder Buchdatei befindet, aus der eine neue generierte Datei erstellt werden soll.


Seitenlayout und Schablonen

Erstellen von Schablonen für bedingten Text

Wenn Sie häufig die Darstellung von Bedingungsdokumenten in einem Buch ändern, ist es hilfreich, wenn für jede Darstellung eine Schablone existiert. Sie können dann die Darstellung aller Dateien im Buch gleichzeitig ändern, indem Sie einfach die Einstellungen für bedingten Text aus einer der Schablonen in die Buchdatei importieren.

Soll die Darstellung eines einzelnen Dokuments mit bedingtem Text geändert werden, ist es einfacher, die Einstellungen von "Ein-/Ausblenden" für das Dokument zu ändern (siehe Ändern der Darstellung von Bedingungsdokumenten).

So erstellen Sie Schablonen zur Änderung des gesamten bedingten Textes in einem Buch:

    1. Definieren Sie eine Basisschablone für das Bedingungsdokument. Dabei müssen alle Bedingungen und Bedingungsformate eingeblendet sein. Aus dieser Schablone importieren Sie später die Einstellungen für bedingten Text, bevor Sie ein Dokument bearbeiten.

    2. Definieren Sie eine weitere Schablone für jede Bedingungskombination, die angezeigt werden soll. Diese Schablonen dienen zum Anzeigen oder Drucken jeweils einer Variante des Dokuments. Sie können in diesen Schablonen auch Variablen und Formate definieren, die jeweils nur zu einer Darstellung gehören.


Seitenlayout und Schablonen

Ändern von Schablonen für leeres Papier und Textdateien

Wenn Sie ein leeres Dokument erstellen, indem Sie im Dialogfenster "Neu" auf "Hochformat", "Querformat" oder "Spezial" klicken, enthält das neue Dokument zahlreiche Standardeinstellungen und -formate. Dazu gehören z. B. Maßeinheiten, Absatz- und Zeichenformate, Tabellenformate, Variablendefinitionen, Querverweisformate und der Inhalt von Referenzseiten.

Sie können die spezielle Schablone für leeres Papier ändern, damit sie die gewünschten Formate enthält. Die Schablone kann die gleichen Formate enthalten wie jede andere Schablone, ausgenommen das Seitenlayout. Das Layout der Vorgabeseite, die Anzahl der Spalten und die Ränder werden bei der Erstellung der Dokumente festgelegt.

Es ist auch möglich, die spezielle Schablone zu ändern, die FrameMaker beim Öffnen von Textdateien verwendet.

Hinweis: In Windows können Sie den Dateinamen ändern, nach dem FrameMaker bei der Erstellung eines Dokuments mit leerem Papier oder beim Öffnen einer Textdatei sucht. Weitere Informationen hierzu finden Sie im online verfügbaren Handbuch "Anpassen von FrameMaker-Produkten" auf der folgenden Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.

So ändern Sie die Schablone für leeres Papier:

    1. Ändern Sie ein Dokument so, dass es die gewünschten Formate und Einstellungen enthält. Lassen Sie vorhandene Vorgabeseiten leer und erstellen Sie keine speziellen Vorgabeseiten.

    2. Löschen Sie alle Textrahmen aus linken und rechten Vorgabeseiten, selbst wenn das Dokument nur Einzelseiten enthält. (Wenn es sich um ein einseitiges Dokument handelt, wählen Sie "Format > Seitenlayout > Seitenumbruch", klicken dann auf "Doppelseitig" und anschließend auf "Zuweisen". Wählen Sie dann die Textrahmen auf den Vorgabeseiten aus und löschen Sie sie.)

    3. Wählen Sie "Spezial > Seiten löschen" und löschen Sie alle Arbeitsseiten.

    4. Speichern Sie das Dokument unter einem der nachstehenden Dateinamen und Speicherorte:

    (Windows) Die Custom-Datei im FrameMaker-Ordner "fminit". (Wenn Sie "Neu > Adobe FrameMaker-Dokument" aus dem Kontextmenü in einem Ordner oder auf dem Desktop wählen, wird die Datei "Shellnew.fm" verwendet.)

    (UNIX) Die Datei "NewTemplate" im Ordner "$FMHOME/fminit/Sprache/CustomDocs" (dabei ist Sprache die Sprache der Benutzeroberfläche, z. B. "usenglish" oder "ukenglish").

So ändern Sie die Schablone für Textdateien:

    1. Ändern Sie ein Dokument so, dass es die gewünschten Formate und Einstellungen enthält. Sie können z. B. Kopf- und Fußzeilen, einen Absatzformat-Katalog und Vorgabeseitengrafiken in das Schablonendokument einfügen.

    2. Löschen Sie den gesamten Text aus den Arbeitsseiten.

    3. Klicken Sie in den leeren Textrahmen auf Seite 1 und weisen Sie ihm das Absatzformat zu, das für den gesamten Text des Dokuments verwendet werden soll. Die Standardschablone verwendet das Absatzformat "Haupttext".

    4. Speichern Sie das Dokument unter einem der nachstehenden Dateinamen und Speicherorte:

    (Windows) "txttmplt" im FrameMaker-Ordner "fminit".

    (UNIX) Datei "ASCIITemplate" im Ordner "$FMHOME/fminit/Sprache/CustomDocs" (dabei ist Sprache die Sprache der Benutzeroberfläche, z. B. "usenglish" oder "ukenglish").

So definieren Sie unter UNIX mehrere Schablonen für Textdateien:

Weisen Sie jeder Schablone den Namen "SuffixTemplate" zu. Dabei ist Suffix das Suffix der Textdatei, die geöffnet wird. Sobald Sie eine Textdatei mit einem Suffix öffnen, sucht FrameMaker zunächst nach der entsprechenden SuffixTemplate-Datei und anschließend nach der Datei "ASCIITemplate". Existiert eine SuffixTemplate-Datei, wird sie als Schablone für die Textdatei benutzt. Wenn Sie z. B. eine Textdatei mit dem Suffix .c öffnen, sucht FrameMaker nach der Datei mit dem Namen "cTemplate" und verwendet sie als Schablone.


Seitenlayout und Schablonen

Importieren und Aktualisieren von Formaten

Sie können Absatzformate, Tabellenformate, Variablendefinitionen und andere Einstellungen aus jedem beliebigen Dokument importieren. Normalerweise (aber nicht zwingend) handelt es sich bei dem Quelldokument um eine Schablone. Es ist auch möglich, irreguläre Formate im Dokument beizubehalten oder zu löschen, z. B. manuelle Änderungen an einem Absatzformat, die nicht im Absatzformat-Katalog gespeichert wurden.

Sie können Einstellungen auch in verschiedene (oder alle) Dateien eines Buches gleichzeitig importieren.

So importieren und aktualisieren Sie Formate in einem Dokument oder Buch:

    1. Öffnen Sie das Dokument, dessen Formate Sie importieren wollen.

    2. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die zu aktualisierenden Dokumente aus.

    3. Wählen Sie im zu aktualisierenden Dokument oder Buch "Datei > Importieren > Formate".

    4. Führen Sie eine der folgenden Aktionen aus:

    Um Formate aus einem Dokument zu importieren, wählen Sie dieses Dokument aus dem Aufklappmenü "Import aus Dokument". Das Aufklappmenü listet alle geöffneten und gespeicherten Dokumente auf.

    Wenn Sie Formate des aktuellen Dokuments erneut zuweisen wollen, wählen Sie "Aktuelles Dokument" aus dem Aufklappmenü "Import aus Dokument".

    5. Wählen Sie die Einstellungen für "Importieren" und "Aktualisieren", die dem aktuellen Dokument zugewiesen werden sollen. Standardmäßig sind alle Optionen aktiviert. Um alle Optionen auf einmal zu deaktivieren, klicken Sie auf "Auswahl aufheben" bzw. "Alles auswählen". Wenn Sie Variablendefinitionen, Querverweisformate oder FrameMath-Definitionen aktualisieren und in diesen Elementen Zeichenformate verwenden, aktivieren Sie außerdem "Zeichenformate", damit die Formate in das Dokument übernommen werden.

Informationen über die Einstellungen finden Sie unter Einstellungen für Import und Aktualisierung.

    6. Um Änderungen zu löschen, die an einzelnen Formaten vorgenommen, jedoch nicht im Katalog gespeichert wurden, gehen Sie wie folgt vor:

    Um manuelle Seitenumbrüche zu entfernen, die nicht Bestandteil eines Formats im Absatzformat-Katalog sind, wählen Sie "Manuelle Seitenumbrüche".

    Um manuelle Änderungen an Absatz- und Zeichenformaten, Seitenlayout oder Tabellenformatierung zu entfernen, wählen Sie "Andere Format-/Layoutänderungen". Weitere Informationen finden Sie unter Irreguläre Formate, Ändern des Erscheinungsbilds von Tabellen und Irreguläre Layouts.

    7. Klicken Sie auf "Importieren".


Seitenlayout und Schablonen

Einstellungen für Import und Aktualisierung

Beim Importieren von Formatinformationen aus einer Schablone kombiniert FrameMaker die importierten Formate mit den im Dokument vorhandenen, anstatt sie zu ersetzen. Wenn Sie z. B. Absatzformate importieren, fügt FrameMaker diese dem Absatzformat-Katalog des Dokuments hinzu. Wenn Formate in beiden Dokumenten denselben Namen haben, wird das vorhandene Format im Dokument durch das importierte ersetzt. Alle anderen Formate bleiben unverändert im Dokument erhalten.

Hinweis: Formatnamen unterscheiden Groß- und Kleinschreibung, d. h. Haupttext ist nicht mit haupttext identisch.

Absatzformate

Der Absatzformat-Katalog der Schablone wird in das Dokument eingelesen und alle Formate im Katalog werden neu auf das Dokument angewendet. Die Einstellungen für PDF-Lesezeichen werden ebenfalls in das Dokument kopiert.

Zeichenformate

Der Zeichenformat-Katalog der Schablone wird in das Dokument eingelesen und alle Formate im Katalog werden neu auf das Dokument angewendet.

Seitenlayouts

Die Vorgabeseiten der Schablone werden in das Dokument eingelesen und Arbeitsseiten werden mit den Änderungen in den Vorgabeseiten aktualisiert. Wenn Schablone und Dokument eine Vorgabeseite gleichen Namens enthalten, ersetzt die Vorgabeseite aus der Schablone diejenige des Dokuments. FrameMaker kopiert die Einstellungen der Änderungsbalken, alle Einstellungen aus den Dialogfenstern "Format" und "Seitenumbruch" sowie die meisten Einstellungen aus dem Dialogfenster "Darstellungsoptionen".

Tabellenformate

Der Tabellenformat-Katalog der Schablone und die Lineaturstile werden in das Dokument eingelesen und alle Formate im Katalog werden neu auf das Dokument angewendet.

Farbdefinitionen

Die Farbdefinitionen und Farbauszüge der Schablone werden in das Dokument eingelesen.

Dokumenteinstellungen

Die speziellen Markentypen und Fußnoteneinstellungen, Band-, Kapitel-, Seiten-, Absatz-, Fußnoten- und Tabellenfußnoten-Nummerierungen aus dem Dialogfenster "Nummerierungseinstellungen", die mit der Einstellung "Zeilenumbruch erlaubt nach" im Dialogfenster "Textoptionen" festgelegten Zeichen sowie die Einstellungen der Option "Höhenausgleich" im Dialogfenster "Zeilenlayout" werden aus der Schablone in das Dokument eingelesen. Auch die PDF-Einstellungen (zusätzlich zu den Lesezeicheneinstellungen) werden übernommen. In Systemen mit japanischen Spracheinstellungen werden auch die Rubi-Einstellungen und Kumihan-Regeln (japanische typografische Regeln) in das Dokument eingelesen.

Referenzseiten

Alle Referenzseiten der Schablone (außer FrameMath-Referenzseiten) werden in das Dokument eingelesen. Enthalten Schablone und Dokument eine Referenzseite gleichen Namens, wird die Referenzseite im Dokument durch diejenige aus der Schablone ersetzt. Um FrameMath-Referenzseiten zu importieren, wählen Sie "FrameMath-Definitionen".

Variablendefinitionen

Die Variablendefinitionen der Schablone werden in das Dokument eingelesen.

Querverweisformate

Die Querverweisformate der Schablone werden in das Dokument eingelesen, und interne Querverweise werden aktualisiert.

Einstellungen für bedingten Text

Bedingungstypen und die Einstellungen für "Ein/Ausblenden" der Schablone werden in das Dokument eingelesen und auf bedingten Text angewendet.

FrameMath-Definitionen

Gleichungsgröße und -schrift, spezielle FrameMath-Elementdefinitionen und FrameMath-Referenzseiten werden in das Dokument kopiert. Falls beim Einlesen der Referenzseiten ein spezielles FrameMath-Element im Dokument gelöscht wird, ersetzt FrameMaker dieses FrameMath-Element in Gleichungen durch den Namen des Elements und umgibt diesen mit Fragezeichen.

Kombinierte Schriften

Auf Systemen mit japanischer Sprache werden die Einstellungen für Kombinationen aus japanischer und lateinischer Schrift in das Dokument eingelesen und auf den Text im Dokument angewendet, der kombinierte Schriften verwendet.


Inhaltsverzeichnisse und Indizes

Inhaltsverzeichnisse

Erläuterung von generierten Dateien

Vorbereiten der Quellen für Inhaltsverzeichnisse und andere generierte Listen

Generieren von Inhaltsverzeichnissen und anderen Listen

Aktualisieren und Bearbeiten von Inhaltsverzeichnissen und Listen

Fehlerbehebung in Inhaltsverzeichnissen und Listen

Einbetten von Inhaltsverzeichnissen in Dokumente

Erläuterung von Indizes

Hinzufügen von Indexmarken

Generieren von Indizes

Aktualisieren und Bearbeiten von Indizes

Anlegen eines Hauptinhaltsverzeichnisses oder Index für mehrere Bücher

Fehlerbehebung in Indizes

Hinzufügen von speziellen Markentypen

Hinzufügen von Titeln oder anderem statischen Text in Listen und Indizes

Formatieren von Listen und Indizes

Ändern der Sortierfolge für Indizes

Arbeiten mit Gruppentiteln in Indizes

Arbeiten mit Inhaltsverzeichnissen in strukturierten Dokumenten

Generieren von Inhaltsverzeichnissen und anderen Listen in strukturierten Dokumenten

Aktualisieren und Bearbeiten von Listen in strukturierten Dokumenten

Hinzufügen von Indexmarken-Elementen in strukturierten Dokumenten

Formatieren von Listen und Indizes in strukturierten Dokumenten

Fehlerbehebung in Inhaltsverzeichnissen und Listen von strukturierten Dokumenten

Einbetten von Inhaltsverzeichnissen in strukturierte Dokumente


Inhaltsverzeichnisse und Indizes

Inhaltsverzeichnisse

In Adobe FrameMaker werden Inhaltsverzeichnisse, Abbildungslisten und ähnliche Listen aus dem Text angegebener Absätze in einer Reihe von Dokumenten erzeugt. Ein Index wird aus Marken generiert, die Sie in Dokumente einfügen. Sie können jederzeit Inhaltsverzeichnisse und Indizes aktualisieren, während Sie die zu Grunde liegenden Dokumente überarbeiten.

Es gibt verschiedene Listentypen, wie z. B. Inhaltsverzeichnisse und Indizes. Sie können Listen und Indizes erstellen und aktualisieren, mit Überschriften versehen und formatieren.


Inhaltsverzeichnisse und Indizes

Erläuterung von generierten Dateien

Eine generierte Datei ist eine von FrameMaker durch Extrahieren von Absatz- oder Markentext aus einem Quelldokument oder aus verschiedenen Dokumenten eines Buches erstellte Datei. Bei jeder Aktualisierung der generierten Datei wird der gesamte alte Absatz- oder Markentext durch den aktuellen Text aus den Quelldokumenten ersetzt. Auf diese Weise hält FrameMaker generierte Dateien wie Inhaltsverzeichnisse und Indizes auf dem jeweils aktuellen Stand.

Neben Inhaltsverzeichnis und Standardindex können Sie verschiedene Arten von Listen und Indizes erstellen. Sie können z. B. Listen und Indizes erstellen, die Absatz- oder Markentext enthalten, den Sie in den Text eingefügt haben. Das Ergebnis ist in diesem Fall ein Inhaltsverzeichnis, das auf Absatzüberschriften beruht, eine Abbildungsliste basierend auf den Abbildungsüberschriften oder ein Index, der aus speziellen Autorenmarken aufgebaut ist.

Die meisten Listen und Indizes lassen sich in drei Kategorien gliedern: Listen, die aus Absätzen (oder Elementen in strukturierten Dokumenten) aufgebaut werden, Listen, die aus Marken generiert werden, und Indizes, die aus Marken erstellt werden. Eine vierte Kategorie, Referenzlisten und -indizes, wird weniger oft für spezielle Zwecke verwendet.


Inhaltsverzeichnisse und Indizes / Erläuterung von generierten Dateien

Inhaltsverzeichnisse und andere Absatz- oder Elementlisten

Absatzlisten enthalten den Text spezieller Absätze (Absätze des von Ihnen angegebenen Typs), mit einem Eintrag pro Absatz (oder Elemente in strukturierten Dokumenten). Sie können folgende Absatzlisten (oder Elemente in strukturierten Dokumenten) erstellen:

    Inhaltsverzeichnisse, die Überschriften unterschiedlicher Ebenen enthalten. Die Einträge sind in der Reihenfolge aufgeführt, in der sie in den Quelldokumenten vorkommen.

    Listen mit Abbildungen, Tabellen oder Absätzen (oder Elementen), die Abbildungsüberschriften, Tabellentitel oder Text aus angegebenen Absätzen enthalten. Die Einträge sind in der Reihenfolge aufgeführt, in der sie in den Quelldokumenten auftreten.

Absatzlisten umfassen Inhaltsverzeichnisse und Abbildungslisten.

    Alphabetische Absatzlisten (oder Elementlisten), die dieselben Informationen enthalten wie die anderen Listen, wobei die Einträge jedoch in alphabetischer Reihenfolge angeordnet sind.

Hinweis: Inhaltsverzeichnisse und Listen unterstützen den Unicode-Standard zur Textcodierung.


Inhaltsverzeichnisse und Indizes / Erläuterung von generierten Dateien

Markenlisten

Markenlisten enthalten Einträge, die den auf Arbeitsseiten des Quelldokuments eingefügten Marken entsprechen. Die Marken werden manuell auf den Arbeitsseiten des Quelldokuments eingefügt (in der Regel als Markenelemente in strukturierten Dokumenten) und der Markentext wird in der generierten Liste angezeigt. Sie können z. B. eine Liste mit Kommentaren des Redakteurs zu einem Dokumententwurf anlegen, indem Sie eine Liste mit Marken des Typs Kommentar erstellen. In einer Standardmarkenliste werden die Einträge in der Reihenfolge aufgeführt, in der sie im Quelldokument oder -buch vorkommen. Sie können auch alphabetische Markenlisten generieren.

Liste mit Querverweis-Marken


Inhaltsverzeichnisse und Indizes / Erläuterung von generierten Dateien

Markenindizes

Markenindizes umfassen Standardindizes, Autoren- und Themenindizes sowie andere Typen von Markenindizes. Die Marken werden manuell auf Arbeitsseiten des Quelldokuments eingefügt und der Markentext wird im Index angezeigt. Mithilfe einer bestimmten Syntax (so genannten Bausteinen) lassen sich Indexebenen und eine spezielle Seitennummerierung, Sortierung und Formatierung festlegen. Die Einträge sind alphabetisch sortiert. Einträge mit demselben Text werden zu einem einzigen Eintrag mit mehreren Seitenverweisen zusammengefasst.

Index mit Querverweis-Marken


Inhaltsverzeichnisse und Indizes / Erläuterung von generierten Dateien

Referenzlisten und -indizes

Mit Referenzlisten und -indizes können Sie spezielle Informationskategorien verfolgen. Sie können Listen und Indizes mit Bedingungstypen, externen und ungelösten Querverweisen, Schriften, Texteinschüben, ungelösten Texteinschüben und importierten Grafiken generieren.

Schriftenliste und Schriftenindex


Inhaltsverzeichnisse und Indizes

Vorbereiten der Quellen für Inhaltsverzeichnisse und andere generierte Listen

Inhaltsverzeichnisse und andere generierte Listen basieren auf dem Inhalt der jeweiligen Quelle. Die Quelle kann entweder ein einzelnes Dokument oder eine Gruppe von Dokumenten eines Buches sein. In den meisten Fällen müssen Sie die Quelldokumente vorbereiten, um das gewünschte Ergebnis zu erzielen.


Inhaltsverzeichnisse und Indizes / Vorbereiten der Quellen für Inhaltsverzeichnisse und andere generierte Listen

Vorbereiten der Dokumente für ein Inhaltsverzeichnis oder eine andere Absatzliste

Zum Generieren von Inhaltsverzeichnissen oder anderen Absatzlisten wählen Sie die zu verwendenden Absatztypen aus. Um Probleme in den generierten Listen zu vermeiden, führen Sie im Quelldokument folgende Aktionen aus:

    Verwenden Sie einheitliche Absatztypen. Verwenden Sie z. B. "Überschrift1" für alle Überschriften der ersten Ebene. Für andere Absätze darf dieser Typ dann nicht mehr verwendet werden.

    Legen Sie jeden Eintrag, den Sie in die Liste aufnehmen wollen, als eigenen Absatz an. Sie erhalten z. B. nicht das gewünschte Ergebnis, wenn eine Überschrift zwei Zeilen umfasst (und die Zeilen durch Absatzendezeichen getrennt sind).

Hinweis: Normalerweise erstellen Sie Referenzlisten, z. B. eine Liste mit Schriften oder ungelösten Querverweisen, nur für den eigenen Gebrauch während der Arbeit mit einem Dokument. Für eine solche Liste müssen Sie das Dokument nicht vorbereiten.


Inhaltsverzeichnisse und Indizes / Vorbereiten der Quellen für Inhaltsverzeichnisse und andere generierte Listen

Vorbereiten von Dokumenten für eine Markenliste

Vor Erstellen einer Markenliste müssen Sie die Marken in das Quelldokument einfügen.

In einigen Fällen wurden die Marken bereits zu anderen Zwecken in das Dokument eingefügt (z. B. Querverweis-Marken oder Marken für bedingten Text). In anderen Fällen müssen Sie die Marken vor dem Generieren der Liste jedoch manuell einfügen, z. B. für eine Liste mit Kommentaren des Bearbeiters.

Hinweis: Sie können ein Tabulatorzeichen in Markentext einfügen, indem Sie \t oder den hexadezimalen Code \x08 eingeben. In einer generierten Markenliste werden allerdings nur Tabulatorzeichen, die als hexadezimaler Code eingegeben wurden, angezeigt. In einem generierten Markenindex erscheinen nur Tabulatorzeichen, die als \t eingegeben wurden.

So fügen Sie eine Marke in das Quelldokument ein:

    1. Klicken Sie an die Position, wo die Marke eingefügt werden soll, und wählen Sie "Spezial > Marke".

    2. Wählen Sie einen Markentyp aus dem Aufklappmenü aus. Sie können alle vordefinierten Marken mit Ausnahme von "Bedingter Text", "Kopf-/Fußzeile $1", "Kopf-/Fußzeile $2" oder "Querverweis" verwenden. Sie haben aber auch die Möglichkeit, spezielle Markentypen zu definieren. Weitere Informationen finden Sie unter Hinzufügen von speziellen Markentypen.

    3. Geben Sie den als Listeneintrag gewünschten Text ein. Sie können bis zu 255 Zeichen (127 japanische Doppelbyte-Zeichen) eingeben. Neben der normalen Eingabe von Text können Sie auch alternative Methoden für die Eingabe von Markentext nutzen. Weitere Informationen finden Sie unter Hinzufügen von Indexmarken.

    4. Klicken Sie auf "Neue Marke". Wenn die Anzeige von Steuerzeichen aktiviert ist, wird ein Markensymbol ( [image] ) eingeblendet.


Inhaltsverzeichnisse und Indizes

Generieren von Inhaltsverzeichnissen und anderen Listen

Sie können Inhaltsverzeichnisse und Absatz-, Marken- oder Referenzlisten auf der Grundlage eines Buches oder eines einzelnen Dokuments erstellen. Informationen über das Generieren von Indizes finden Sie unter Generieren von Indizes.

Elementspezifische Informationen für die Arbeit mit strukturierten Dokumenten finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen in strukturierten Dokumenten.

So generieren Sie ein Inhaltsverzeichnis oder eine Liste für ein Buch:

    1. Öffnen Sie das Buchfenster und wählen Sie die Datei aus, unter der die generierten Dateien eingefügt werden sollen.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Hinzufügen > Inhaltsverzeichnis".

    Wählen Sie "Hinzufügen > Liste von" und wählen Sie aus dem Menü einen Listentyp aus.

Die Optionen in diesem Dialogfenster hängen vom gewählten Listentyp ab.

    3. Legen Sie im Aufklappmenü "Datei einfügen" fest, ob die generierte Liste vor oder nach dem aktuellen Dokument angezeigt werden soll.

    4. Geben Sie ein Suffix ein oder belassen Sie das Standardsuffix. Das Suffix gibt den Typ der generierten Datei an. "IVZ" ist z. B. das übliche Suffix für ein Inhaltsverzeichnis.

Hinweis: Verwechseln Sie das Suffix nicht mit der Dateinamenerweiterung. Das Suffix wird mit Absatztypen in generierten Listen verwendet und als Teil des Namens der generierten Datei betrachtet, z. B. HandbuchIVZ.fm.

    5. Verschieben Sie die Elemente in die Auswahlliste "Übernahme". Um ein Element aus einer Auswahlliste in eine andere zu verschieben, wählen Sie das Element aus, klicken auf einen Pfeil oder doppelklicken auf das Element. Um alle Elemente aus einer Liste in die andere zu verschieben, halten Sie die Umschalttaste gedrückt und klicken auf einen Pfeil.

    6. Wenn alle Einträge in der generierten Liste mit der jeweiligen Quelle verbunden werden sollen, wählen Sie "Hypertext-Verbindungen anlegen". Diese Verbindungen ermöglichen den Wechsel zur Quelle eines Eintrags. Sie müssen dazu nur auf den betreffenden Eintrag klicken (siehe Testen und Korrigieren fehlerhafter Hypertext-Dokumente).

    7. Klicken Sie auf "Einfügen" und anschließend auf "Aktualisieren". FrameMaker generiert die Liste. Sie zeigen die generierte Liste an, indem Sie im Buchfenster auf deren Namen klicken.

    8. Speichern Sie die generierte Liste in demselben Ordner wie das Quelldokument oder Buch. Die generierte Datei können Sie im Buchfenster umbenennen; FrameMaker benennt sie dann auf der Festplatte um und aktualisiert alle Verweise.

Beim ersten Generieren einer Liste (ohne Schablone, wie unter Formatieren von Listen und Indizes mithilfe von Schablonen beschrieben) übernimmt die Liste das Seitenlayout (Vorgabeseiten) des ersten nicht generierten Dokuments im Buch, wodurch alle Einträge dasselbe Aussehen aufweisen. Informationen über Änderungen im Listenformat, die bei einer Neuerstellung der Liste nicht verloren gehen, finden Sie unter Formatieren von Listen und Indizes.

Wenn die Liste bereits im Ordner des Quelldokuments existiert, speichern Sie sie in demselben Ordner, ohne den Dateinamen zu ändern. Auf diese Weise wird die Formatierung der Liste verwendet, wenn Sie diese neu generieren. Andernfalls werden Formatierungsänderungen beim Aktualisieren der Liste nicht beibehalten.

Um eine Schablone oder eine bestehende generierte Datei in einer neuen Buchdatei zu verwenden, müssen Sie sie als generierte Datei in das Buch aufnehmen. Platzieren Sie die vorhandene Datei mit dem im Buchfenster angezeigten Namen in den Ordner, der die Buchdatei enthält.

    9. Speichern Sie alle geöffneten Dateien im Buch. Geöffnete Dateien werden nur im Arbeitsspeicher Ihres Computers, jedoch nicht auf der Festplatte aktualisiert. Eine nicht geöffnete Datei wird direkt auf der Festplatte aktualisiert.

So generieren Sie ein Inhaltsverzeichnis oder eine Liste für ein einzelnes Dokument:

    1. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Spezial > Inhaltsverzeichnis".

    Wählen Sie "Spezial > Liste von" und wählen Sie einen Listentyp aus dem Menü aus.

    2. Wenn Sie dazu aufgefordert werden, geben Sie an, ob die generierte Datei als unabhängiges Dokument oder als Teil eines Buches erstellt werden soll.

Wenn Sie "Ja" wählen, um ein eigenständiges Dokument anzulegen, erstellt FrameMaker eine generierte Liste im Ordner des Originaldokuments. Wenn Sie "Nein" wählen, fügt FrameMaker die generierte Datei einem geöffneten Buch hinzu oder legt bei Bedarf ein neues Buch an.

    3. Geben Sie ein Suffix ein oder belassen Sie das Standardsuffix. Das Suffix gibt den Typ der generierten Datei an. "IVZ" ist z. B. das übliche Suffix für ein Inhaltsverzeichnis.

Hinweis: Verwechseln Sie das Suffix nicht mit der Dateinamenerweiterung. Das Suffix wird mit Absatztypen in generierten Listen verwendet und als Teil des Namens der generierten Datei betrachtet, z. B. KapitelIVZ.fm.

    4. Verschieben Sie Absatz-, Marken- oder Referenztypen in die Auswahlliste "Übernahme". Um ein Element aus einer Auswahlliste in eine andere zu verschieben, wählen Sie das Element aus, klicken auf einen Pfeil oder doppelklicken auf das Element. Um alle Elemente aus einer Liste in die andere zu verschieben, halten Sie die Umschalttaste gedrückt und klicken auf einen Pfeil.

    5. Wenn alle Einträge in der generierten Liste mit der jeweiligen Quelle verbunden werden sollen, wählen Sie "Hypertext-Verbindungen anlegen". Diese Verbindungen ermöglichen den Wechsel zur Quelle eines Eintrags. Sie müssen dazu nur auf den betreffenden Eintrag klicken (siehe Testen und Korrigieren fehlerhafter Hypertext-Dokumente).

    6. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie eine eigenständige Liste erstellen, klicken Sie auf "Zuweisen". FrameMaker generiert die Liste und zeigt sie an.

    Wenn Sie die Liste einem Buch hinzufügen, klicken Sie auf "Einfügen" und dann auf "Aktualisieren". Wenn ein neues Buch angelegt wird, wählen Sie "Datei > Buch sichern unter" und speichern das Buch.

    7. Speichern Sie die generierte Liste in demselben Ordner wie das Quelldokument oder Buch.

Beim ersten Generieren einer Liste (ohne Schablone, wie unter Formatieren von Listen und Indizes mithilfe von Schablonen beschrieben) übernimmt die Liste das Seitenlayout (Vorgabeseiten) des Quelldokuments bzw. des ersten nicht generierten Dokuments im Buch, wodurch alle Einträge dasselbe Aussehen aufweisen. Informationen über Änderungen im Listenformat, die bei einer Neuerstellung der Liste nicht verloren gehen, finden Sie unter Formatieren von Listen und Indizes.

    8. Speichern Sie die Liste in demselben Ordner wie das Quelldokument oder Buch. Informationen zum Umbenennen generierter Dateien finden Sie unter Umbenennen von Buchdateien.


Inhaltsverzeichnisse und Indizes

Aktualisieren und Bearbeiten von Inhaltsverzeichnissen und Listen

Eine generierte Liste (z. B. ein Inhaltsverzeichnis) kann schnell veralten. Sie können ein Inhaltsverzeichnis aktualisieren, um überarbeitete Überschriften und die aktuellen Seitennummern zu übernehmen oder um andere Absätze im Inhaltsverzeichnis zu berücksichtigen.

Die Bearbeitung von Listeneinträgen erfolgt über die Änderung der entsprechenden Absätze oder Marken im Quelldokument. Danach generieren Sie die Liste erneut. Falls Sie Einträge direkt in der Liste bearbeiten, gehen die Änderungen bei der nächsten Generierung der Liste verloren.

Wenn Sie z. B. einen Fehler direkt in einem Inhaltsverzeichnis korrigieren, wird dieser Fehler bei der nächsten Generierung wieder auftreten, da er im Quellabsatz weiterhin vorhanden ist. Um einen Fehler endgültig zu bereinigen, müssen Sie den Absatz oder Markentext im Quelldokument korrigieren und dann die Liste bzw. das Inhaltsverzeichnis neu generieren.

In diesem Abschnitt erfahren Sie, wie Absatzlisten (keine Markenlisten) aktualisiert und bearbeitet werden. Informationen über die entsprechenden Verfahren für Indizes und Markenlisten finden Sie unter Aktualisieren und Bearbeiten von Indizes.

So aktualisieren Sie ein Inhaltsverzeichnis oder eine Liste in einem Buch:

    1. Nehmen Sie die erforderlichen Änderungen an den Quelldokumenten vor.

    2. Wählen Sie im Buchfenster "Bearbeiten > Buch aktualisieren".

    3. Verschieben Sie die Namen der zu aktualisierenden Listen in die Auswahlliste "Generieren". Stellen Sie sicher, dass "Inhaltsverzeichnis, Listen und Indizes generieren" aktiviert ist, und klicken Sie auf "Aktualisieren".

So fügen Sie Absatztypen in ein Inhaltsverzeichnis oder eine Liste in ein Buch ein bzw. entfernen sie daraus:

    1. Wählen Sie die generierte Datei im Buchfenster aus (z. B. das Inhaltsverzeichnis).

    2. Wählen Sie "Bearbeiten > Einstellungen für Inhaltsverzeichnis" bzw. "Einstellungen für Listentyp".

    3. Verlagern Sie die Elemente wie erforderlich zwischen den Listen und klicken Sie auf "Zuweisen". Klicken Sie anschließend auf "Aktualisieren".

So aktualisieren Sie ein Inhaltsverzeichnis oder eine Liste in einem eigenständigen Dokument:

    1. Nehmen Sie die erforderlichen Änderungen im Quelldokument vor.

    2. Wählen Sie im Quelldokument aus dem Menü "Spezial" den gewünschten Befehl (z. B. "Inhaltsverzeichnis") aus und klicken Sie dann auf "Ja", um ein eigenständiges Dokument anzulegen.

    3. Verlagern Sie die Elemente wie erforderlich zwischen den Listen und klicken Sie auf "Zuweisen".


Inhaltsverzeichnisse und Indizes / Aktualisieren und Bearbeiten von Inhaltsverzeichnissen und Listen

Ermitteln der Quellen von Listeneinträgen

Wenn Sie einen Eintrag überarbeiten wollen, müssen Sie ihn zu seiner Quelle zurückverfolgen, d. h. bis zum entsprechenden Absatz im Quelldokument.

Die Quelle lässt sich am schnellsten über die Hypertext-Verbindung finden, die dem Eintrag in der Liste zugeordnet ist. Über diese Hypertext-Verbindung können die entsprechenden Informationen im Quelldokument angezeigt und ausgewählt werden. Außerdem können Sie einen Eintrag im Quelldokument mithilfe des Befehls "Suchen/Ändern" suchen und auswählen.

So suchen Sie die Quelle eines Listeneintrags mithilfe einer Hypertext-Verbindung:

    1. Wenn Sie bei der Generierung einer Liste oder eines Index nicht "Hypertext-Verbindungen anlegen" ausgewählt haben, holen Sie dies nun nach und generieren Sie die Liste neu.

    2. Gehen Sie entsprechend dem Betriebssystem in der generierten Liste wie folgt vor:

    (Windows) Halten Sie die Alt- und Strg-Taste gedrückt und klicken Sie auf einen Eintrag in der Liste.

    (UNIX) Halten Sie die Control-Taste gedrückt und klicken Sie mit der rechten Maustaste auf einen Eintrag in der Liste.

FrameMaker öffnet das Quelldokument, zeigt die Seite an, die den betreffenden Absatz enthält, und wählt diesen aus.

So suchen und markieren Sie einen Absatz mithilfe des Befehls "Suchen/Ändern":

    1. Wählen Sie im Quelldokument (nicht in der generierten Liste) "Bearbeiten > Suchen/Ändern".

    2. Wählen Sie aus dem Aufklappmenü "Suchen/Ändern" die Option "Absatztyp" aus und geben Sie den gewünschten Typ ein.

    3. Klicken Sie auf "Suchen".


Inhaltsverzeichnisse und Indizes / Aktualisieren und Bearbeiten von Inhaltsverzeichnissen und Listen

Bearbeiten und Löschen von Listeneinträgen

Der Inhalt von Einträgen lässt sich nur in den entsprechenden Absätzen im Quelldokument ändern.

So bearbeiten Sie einen Listeneintrag:

Bearbeiten Sie den Absatztext im Quelldokument.

So löschen Sie einen Listeneintrag:

Löschen Sie den Absatztext im Quelldokument.


Inhaltsverzeichnisse und Indizes

Fehlerbehebung in Inhaltsverzeichnissen und Listen

Kleine Probleme im Quelldokument können entsprechende Probleme in der Liste hervorrufen. Falsche Absatztypen können z. B. bewirken, dass ein zusätzlicher Eintrag in der Liste erscheint oder ein Eintrag fehlt. Bei leeren Absätzen kann in der Liste eine Leerzeile erscheinen.

Inhaltsverzeichnis
A: mit einer eingefügten Leerzeile B: mit einem falschen Eintrag in der Liste

Zusätzliche Einträge oder Zeilen

Falsche Formatierungen im Quelldokument können zur Folge haben, dass in der Liste, z. B. im Inhaltsverzeichnis, zusätzliche Absätze angezeigt werden. Gehen Sie in so einem Fall wie folgt vor:

    Wenn die Liste einen überflüssigen Eintrag enthält, prüfen Sie den entsprechenden Absatz- oder Markentyp im Quelldokument. Weisen Sie dem Absatz gegebenenfalls ein anderes Format zu oder ändern Sie den Markentyp.

    Wenn die Liste eine Leerzeile enthält, die nur eine Seitenzahl aufweist, löschen Sie im Quelldokument den entsprechenden leeren Absatz. Zusätzlichen Abstand zwischen den Absätzen im Quelldokument können Sie mit den entsprechenden Abstandseinstellungen für Absatzformate festlegen, anstatt einen leeren Absatz einzufügen.

Fehlende Einträge

Wenn Einträge aus dem Quelldokument nicht in der Liste angezeigt werden, führen Sie eine der folgenden Aktionen aus:

    Wenn alle Einträge eines bestimmten Absatz- oder Markentyps fehlen, überprüfen Sie, ob die Auswahlliste "Übernahme" im Dialogfenster "Einstellungen" die richtigen Elemente enthält.

    Wenn gelegentlich ein Eintrag fehlt, prüfen Sie den Typ des entsprechenden Absatzes bzw. der entsprechenden Marke im Quelldokument. Wenn der Absatz- oder Markentyp falsch ist, wird die Information nicht in der Liste angezeigt.

Geteilte Einträge

Eine aus mehreren Zeilen bestehende Überschrift im Quelldokument kann problematisch sein, wenn die Zeilenumbrüche durch Drücken der Eingabetaste entstanden sind, sodass jede Zeile einen Absatz darstellt. Die Liste enthält dann einen Eintrag für jeden Absatz der Überschrift. Korrigieren Sie die Liste, indem Sie im Quelldokument nur einen Absatz für die Überschrift verwenden.

Vermeiden Sie aus diesem Grund erzwungene Zeilenenden in Überschriften, die in generierte Inhaltsverzeichnisse aufgenommen werden. Wenn sich eine Überschrift über zwei Zeilen erstrecken soll, ändern Sie den rechten Einzug des Überschriftenabsatzes im Quelldokument (statt die Zeilen durch Drücken der Eingabetaste umzubrechen). Falls die Überschrift zentriert ist, sollten Sie den rechten und linken Einzug ändern. Sie können auch umbruchgeschützte Leerzeichen verwenden, um einen Zeilenumbruch an geeigneter Stelle zu erzwingen.

Fehlerhafte Zeilenumbrüche

Fehlerhafte Zeilenumbrüche in der Liste oder im Quelldokument können Informationen trennen, die in der Liste zusammengehören. Führen Sie in so einem Fall eine der folgenden Aktionen aus:

    Ändern Sie die Zeichen, nach denen FrameMaker Zeilenumbrüche zulässt. Normalerweise lässt FrameMaker Zeilenumbrüche nach einem n-Bindestrich (–) zu. Um Umbrüche nach einem n-Bindestrich zu unterbinden, wählen Sie "Format > Dokument > Textoptionen". Weitere Informationen finden Sie unter Ändern von Silbentrennung und Zeilenumbruch.

    Verwenden Sie im speziellen Textfluss auf der Referenzseite zwischen Text und Seitennummer der Einträge stets umbruchgeschützte Leerzeichen, damit eine Seitennummer keine eigene Zeile in der Liste einnimmt. Weitere Informationen finden Sie unter Bearbeiten von speziellen Textflüssen für Listen und Indizes und unter Ändern von Silbentrennung und Zeilenumbruch.

Fehlende Titel

Ein vom Benutzer eingegebener Titel wird unter Umständen bei der nächsten Generierung der Liste nicht angezeigt, wenn die im Abschnitt Hinzufügen von Titeln oder anderem statischen Text in Listen und Indizes erläuterten Arbeitsschritte nicht korrekt ausgeführt wurden.

Fehlende Formatierungen

Wenn die von Ihnen vorgenommenen Formatänderungen bei der erneuten Generierung des Index (siehe Formatieren von Listen und Indizes) nicht mehr vorhanden sind, führen Sie die folgenden Schritte aus:

    Falls Sie den Dateinamen oder die Position der Liste geändert haben, müssen Sie diese Änderungen rückgängig machen. FrameMaker kann Formatierungsänderungen nur dann finden, wenn Sie die Liste in demselben Ordner wie das Quelldokument speichern und den von FrameMaker zugewiesenen Dateinamen verwenden.

    Um Absatz- und Zeichenformatänderungen beizubehalten, speichern Sie diese im Absatz- oder Zeichenformat-Katalog, damit die Änderungen bei der nächsten Generierung der Liste zur Verfügung stehen. Weitere Informationen finden Sie unter Definieren und Aktualisieren von Formaten.

    Wenn Sie andere Änderungen beibehalten wollen, führen Sie diese im speziellen Textfluss aus, wie es im Abschnitt Bearbeiten von speziellen Textflüssen für Listen und Indizes beschrieben wird.


Inhaltsverzeichnisse und Indizes

Einbetten von Inhaltsverzeichnissen in Dokumente

Normalerweise befindet sich ein Inhaltsverzeichnis in einer separaten Datei, deren Inhalt im Wesentlichen automatisch von FrameMaker generiert wird. Wenn Sie jedoch ein kurzes Inhaltsverzeichnis am Anfang des Dokuments einfügen wollen, statt es in einer separaten Datei mitzuführen, können Sie das Inhaltsverzeichnis mit Querverweisen erstellen.

Inhaltsverzeichnis, das am Anfang eines Dokuments eingebettet ist

FrameMaker behält diesen Inhaltsverzeichnistyp nicht automatisch bei. Wenn Sie z. B. die Reihenfolge der Querverweise im Dokument ändern oder während der Bearbeitung des Dokuments eine Überschrift löschen, müssen Sie die Einträge im Inhaltsverzeichnis selbst neu anordnen bzw. löschen.

Eine weitere Methode besteht darin, ein separates Inhaltsverzeichnis zu generieren und die generierte Datei dann durch Referenz zu importieren. Der resultierende Texteinschub im Dokument wird automatisch aktualisiert, wenn sich das Inhaltsverzeichnis ändert. Weitere Informationen hierzu finden Sie unter Importieren von formatiertem Text.

So betten Sie ein Inhaltsverzeichnis über Querverweise in ein Dokument ein:

    1. Definieren Sie ein Querverweisformat, das den Text entsprechend dem gewünschten Eintragslayout im Inhaltsverzeichnis formatiert. Normalerweise würde dieses Format die Bausteine <$AbsText> und <$SeiteNum> enthalten. Weitere Informationen finden Sie unter Erstellen von Querverweisformaten.

    2. Richten Sie am Anfang des Dokuments einen Querverweis auf die Absätze ein, die in das Inhaltsverzeichnis aufgenommen werden sollen (siehe Einfügen von Querverweisen). Verwenden Sie das Querverweisformat, das Sie im vorhergehenden Arbeitsschritt erstellt haben.

So verwalten Sie ein in ein Dokument eingebettetes Inhaltsverzeichnis:

Führen Sie folgende Schritte durch:

    Wenn Sie beim Bearbeiten des Dokuments die Reihenfolge der Absätze ändern, müssen Sie die Querverweise in derselben Reihenfolge anordnen wie die Referenzen. Danach aktualisieren Sie die Querverweise, damit das Inhaltsverzeichnis aktualisiert wird (siehe Verwalten von Querverweisen).

    Wenn Sie einen Absatz löschen, der Bestandteil des Inhaltsverzeichnisses ist, müssen Sie auch den Querverweis auf diesen Absatz löschen. Andernfalls wird der Indexeintrag zu einem ungelösten Querverweis.

So betten Sie ein Inhaltsverzeichnis als Texteinschub in ein Dokument ein:

    1. Generieren Sie ein Inhaltsverzeichnis auf die übliche Weise (siehe Generieren von Inhaltsverzeichnissen und anderen Listen).

Importieren Sie das Inhaltsverzeichnis in das Dokument (siehe Textimport mit dem Befehl "Importieren").


Inhaltsverzeichnisse und Indizes

Erläuterung von Indizes

Normalerweise werden Indexeinträge aus Marken generiert und alphabetisch sortiert. Einträge mit demselben Text werden zu einem einzigen Eintrag mit mehreren Seitenverweisen zusammengefasst. Sie können spezielle Bausteine zu Markentext hinzufügen, um die Form des Indexeintrags zu steuern und z. B. anzugeben, dass es sich um einen untergeordneten Eintrag oder einen Querverweis auf einen anderen Eintrag handelt.

Indexeinträge
A: Haupteintrag B: Untereinträge C: Querverweis auf einen anderen Eintrag D: Seitenbereich

Gewöhnlich verwenden Sie zum Erstellen eines Standardindex, wie er am Ende der meisten Bücher zu finden ist, den Markentyp Index.

Sie haben aber auch die Möglichkeit, mithilfe von vordefinierten Markentypen (z. B. für Thema oder Autor) bzw. mit selbstdefinierten Markentypen spezialisierte Indizes zu erstellen (siehe Hinzufügen von speziellen Markentypen).

Hinweis: Indexe unterstützen den Unicode-Standard zur Textcodierung.


Inhaltsverzeichnisse und Indizes

Hinzufügen von Indexmarken

Bevor Sie einen Index für ein Dokument erstellen, fügen Sie die Marken für die Indexeinträge ein.

Indexmarke im Quelldokument und der formatierte Eintrag im Index

So fügen Sie eine Indexmarke ein:

    1. Klicken Sie an die Position, wo die Marke eingefügt werden soll, und wählen Sie "Spezial > Marke". Marken lassen sich nur in Textrahmen einfügen.

    2. Wählen Sie einen Markentyp aus dem Aufklappmenü aus. In der Regel werden Sie den Markentyp Index verwenden. Wenn Sie für ein Dokument mehrere Indizes anlegen wollen (z. B. einen Themen- und einen Autorenindex), weisen Sie jedem Index einen anderen Markentyp zu.

    3. Geben Sie den Text des Indexeintrags in das Dialogfenster "Marke" ein. Sie können bis zu 255 Zeichen (127 japanische Doppelbyte-Zeichen) eingeben. Sie können Form und Position des Indexeintrags auch mithilfe der folgenden Bausteine im Markentext steuern.

    Baustein | Bedeutung
: (Doppelpunkt) | Trennt Ebenen in einem Eintrag.
; (Semikolon) | Trennt Einträge in einer Marke.
[ ] (eckige Klammern) | Legt eine bestimmte Sortierfolge für den Eintrag fest.
<$startrange> | Kennzeichnet den Anfang eines Seitenbereichs.
<$endrange> | Kennzeichnet das Ende eines Seitenbereichs.
<$nopage> | Unterdrückt die Seitennummer im Eintrag.
<$singlepage> | Stellt in einer Marke mit mehreren Einträgen die Seitennummer des Eintrags wieder her, der auf einen <$nopage>-Baustein folgt.
Zeichentyp zwischen spitzen Klammern ( < > ) | Ändert das Zeichenformat (z. B. <Betonung>).
<Absatzstandardschrift> | Stellt die Standardschrift des Absatzes wieder her.

Bei japanischen Schriften geben Sie alle Bausteine mit Ausnahme der Klammern ([ ]) mithilfe von Single-Byte-Zeichen ein.

Hinweis: Wenn Sie einen umgekehrten Schrägstrich oder ein anderes in Bausteinen verwendetes Sonderzeichen (Doppelpunkt, Semikolon, eckige oder spitze Klammer) als reguläres Zeichen eingeben wollen, müssen Sie ihm einen umgekehrten Schrägstrich ( \ ) voranstellen.

    4. Klicken Sie auf "Neue Marke". Wenn die Anzeige von Steuerzeichen aktiviert ist, wird ein Markensymbol ( [image] ) eingeblendet.

So fügen Sie eine Indexmarke ohne die Eingabe über die Tastatur ein:

Führen Sie eine der folgenden Aktionen aus, um bei der Erstellung von Indexmarken den Schreibaufwand zu verringern oder ganz zu umgehen:

    Fügen Sie am Anfang des zu indizierenden Wortes eine leere Marke (ohne Text) ein. Beim Generieren des Index wird das Wort rechts neben der Marke bis zum nächsten Leerzeichen als Text des Eintrags verwendet.

    Um Text zu verwenden, der im Dokument als Markentext erscheint, wählen Sie diesen einfach im Dokument aus. Sofern das ausgewählte Wort oder die Wortverbindung keine Marke enthält, wird es bzw. sie automatisch im Feld "Marke" angezeigt.

So platzieren Sie mehrere Einträge in einer Marke:

Sie geben mehrere Einträge in dieselbe Marke ein, indem Sie sie durch ein Semikolon (;) voneinander trennen. Hier einige Beispiele:

Markentext | Ergebnis im Index
Abtragung; Auswaschung | Abtragung 10 Auswaschung 10
<$nopage>Erosion, siehe Abtragung;<$singlepage>Abtragung | Abtragung 10 Erosion, siehe Abtragung

Im zweiten Beispiel bezieht sich <$nopage> auf die nachfolgenden Einträge in der Marke. Um wieder eine einzelne Seitennummer zu erhalten, steht <$singlepage> zusammen mit dem nächsten Eintrag in der Marke.

Um die Lesbarkeit zu erhöhen, können Sie nach dem Semikolon eine beliebige Anzahl von Leerzeichen eingeben. Vorangestellte Leerzeichen werden beim Kompilieren des Index ignoriert, es sei denn, es handelt sich um spezielle Leerzeichen wie umbruchgeschützte oder m-Leerzeichen. (Bei japanischen Schriften werden nur Single-Byte-Leerzeichen ignoriert.)


Inhaltsverzeichnisse und Indizes / Hinzufügen von Indexmarken

Verwendung von Untereinträgen in Indexeinträgen

Sie können mehrere Einträge als größere Informationskategorie unter einem Eintrag zusammenfassen, indem Sie die Einträge als Untereinträge kennzeichnen. Untereinträge können wiederum Untereinträge enthalten.

Untereinträge

So erstellen Sie einen Untereintrag:

Trennen Sie den Eintrag durch einen Doppelpunkt (:) vom Untereintrag. Um z. B. den ersten Eintrag in der Abbildung zu erstellen, geben Sie Kontinentalverschiebung:fossile Funde ein.

Einem Untereintrag geht stets der übergeordnete Eintrag voraus. Wenn Sie zwei Ebenen als Untereinträge verwenden, geben Sie zwischen den Untereinträgen einen Doppelpunkt ein. Geben Sie z. B. Kontinentalverschiebung:fossile Funde:aus der Zeit von ein.


Inhaltsverzeichnisse und Indizes / Hinzufügen von Indexmarken

Verwendung von Querverweisen in Indexeinträgen

Indizes enthalten oft Querverweis-Einträge, um Leser auf verwandte Begriffe zu verweisen. Dadurch erübrigt es sich, Einträge und Seitennummern für verwandte Begriffe, die bereits im Index angezeigt werden, doppelt anzugeben.

Querverweise

Querverweise können auch als Untereinträge (gewöhnlich mit vorangestelltem Siehe auch wie in der Abbildung) angezeigt werden. Informationen darüber, wie untergeordnete Stichwörter mit Querverweisen so sortiert werden, dass sie am Anfang oder am Ende der untergeordneten Stichwörter eines Haupteintrags stehen, finden Sie unter Festlegen der Sortierfolge in Indizes.

So erstellen Sie einen Querverweis in einem Indexeintrag:

Fügen Sie eine Marke ein und stellen Sie <$nopage> an den Anfang, damit die Seitenangabe für diesen Eintrag unterdrückt wird. Für die Erstellung des ersten Querverweises in der Abbildung geben Sie <$nopage>Abtragung, siehe auch Sandstein ein.


Inhaltsverzeichnisse und Indizes / Hinzufügen von Indexmarken

Verwenden von Seitenbereichen in Indexeinträgen

Sie können einen Seitenbereich, wie z. B. 36–37 verwenden, um Informationen zu kennzeichnen, die sich über mehrere Seiten erstrecken.

Seitenbereiche

Sie können einen Seitenbereich erstellen, indem Sie manuell zwei Marken einfügen, die den Bereich angeben: Eine Marke steht am Anfang, die andere am Ende des Bereichs. Außerdem kann FrameMaker Seitenbereiche automatisch anlegen, wenn derselbe Markentext in aufeinander folgenden Seiten eines Dokuments auftritt. Ein solcher Eintrag wird dann automatisch als Seitenbereich angezeigt, z. B. 3–5 anstelle von 3, 4, 5.

So erstellen Sie manuell einen Seitenbereich für einen Indexeintrag:

    1. Fügen Sie eine Indexmarke am Anfang des Informationsbereichs ein und beginnen Sie den Markentext mit <$startrange>. Um z. B. die erste Seitennummer eines Bereichs zu erstellen, geben Sie <$startrange>Kontinentalverschiebung:fossile Funde ein.

    2. Fügen Sie am Ende des Informationsbereichs eine identische Indexmarke (bei der Arbeit mit strukturierten Dokumenten ein Markenelement) ein. Beginnen Sie den Markentext anstelle von <$startrange> nun aber mit <$endrange>. Um die zweite Seitennummer eines Bereichs zu erstellen, geben Sie z. B. <$endrange>Kontinentalverschiebung:fossile Funde ein.

Wenn beide Marken auf derselben Seite erscheinen, wird der Seitenbereich als eine Seitennummer dargestellt.

So werden Seitenbereiche in einem Index automatisch erstellt:

    1. Zeigen Sie die Referenzseite mit dem speziellen Textfluss für Indizes an, wie es unter Bearbeiten von speziellen Textflüssen für Listen und Indizes beschrieben ist.

    2. Geben Sie den Baustein <$autorange> am Anfang des Absatzes ein, der mit dem Markentyp beginnt.

Um z. B. die aus Marken des Typs Index generierten Einträge wann immer möglich zu Seitenbereichen zusammenzufassen, versehen Sie den mit IndexSIX gekennzeichneten Absatz mit den folgenden Bausteinen: <$autorange><$SeiteNum>


Inhaltsverzeichnisse und Indizes / Hinzufügen von Indexmarken

Verwendung von Zeichenformaten in Indexeinträgen

Sie können die Zeichenformate von bestimmten Textelementen oder von Seitennummern im Eintrag ändern. Sie können z. B. den Buchtitel kursiv oder eine bestimmte Seitennummer in Fettdruck darstellen. (Das Zeichenformat muss im Zeichenkatalog des Index gespeichert werden.)

Zeichenformatierung

Informationen über das Festlegen von Absatzformaten für Indexeinträge finden Sie unter Ändern der Absatz- und Zeichenformate von Einträgen.

So verwenden Sie ein Zeichenformat in einem Indexeintrag:

    1. Geben Sie einen Indexeintrag ein, wie es im Abschnitt Hinzufügen von Indexmarken beschrieben ist.

    2. Um einen Teil des Eintrags in einem Zeichenformat zu speichern, führen Sie einen der folgenden Schritte aus:

    Zur Formatierung von Text in einem Eintrag geben Sie vor dem Text in spitzen Klammern ( < und > ) den Zeichentyp und nach dem Text <Absatzstandardschrift> ein. Für einen Eintrag wie "Flutwellen, siehe Tsunami" müssen Sie z. B. folgenden Markentext eingeben: Flutwellen, <Emphasis>siehe<Absatzstandardschrift> Tsunami

Zeichenformattypen beziehen sich nur auf den Eintrag, dem sie vorangehen. Mit <fett>Beeren:Erdbeere wird z. B. ein zweizeiliger Eintrag erzeugt, in dem "Beeren" in Fettschrift und "Erdbeere" in Standardschrift erscheint. Um beide Einträge in Fettschrift zu formatieren, geben Sie <fett>Beeren:<fett>Erdbeere ein.

    Um nur die Seitennummern zu formatieren, geben Sie den Zeichentyp in spitzen Klammern am Ende des Markentextes ein. Um z. B. den Eintrag "Erosion 24" zu erstellen, geben Sie folgenden Markentext ein: Erosion<fett>

Wenn Sie bestimmte Seitennummern in einem Index in einem speziellen Zeichenformat definieren möchten (z. B. fett für alle Haupteinträge), können Sie einen speziellen Markentyp in diesem Format erstellen. Weitere Informationen finden Sie unter Hinzufügen von speziellen Markentypen.


Inhaltsverzeichnisse und Indizes / Hinzufügen von Indexmarken

Festlegen der Sortierfolge in Indizes

Durch Angabe einer Sortierfolge können Sie die Position eines Eintrags im Index ändern. Beispielsweise würde 486 normalerweise zu den anderen Zahlen im Index gehören. Sie können aber festlegen, dass die Zahl unter V (wie in der ausgeschriebenen Version vierhundertsechsundachtzig) angezeigt wird.

Wenn Sie einen Siehe auch-Querverweis in einem Untereintrag angelegt haben, lässt sich dieser z. B. als letzter Eintrag unter dem Haupteintrag platzieren.

Bei japanischer Schrift erfordern Kanji-Zeichen immer die Definition einer speziellen Sortierfolge. (Informationen hierzu finden Sie unter Erläuterung der japanischen Sortierfolge.)

So legen Sie eine Sortierfolge für einen Indexeintrag fest:

Geben Sie am Ende des Markentextes den gewünschten Text in eckige Klammern ([ und ]) ein, um die exakte Position des Eintrags festzulegen.

Indexmarkentext | Ergebnis im Index | Erläuterung
90er Jahre[Neunzigerjahre] | Nippflut 47 90er Jahre 10 Nordamerika 21 | Sortiert nach N (für Neunzigerjahre)
Erosion:von Böden [Erosion:Böden] | Erosion Rate 32 von Böden 10 | Ignoriert das Wort von
<$nopage>Erosion: siehe auch Wind [Erosion:aaa] | Erosion siehe auch Wind Rate 16 | Erscheint als erster Eintrag unter Erosion
<$nopage>Erosion: siehe auch Wind [Erosion:zzz] | Erosion Rate 16 siehe auch Wind | Erscheint als letzter Eintrag unter Erosion

Hinweis: Die Sortierinformationen in Klammern sind stets das letzte Element im Markentext.

So legen Sie die Sortierfolge für einen Kanji-Indexeintrag fest:

Geben Sie im Markentext die Aussprache (yomigana) in eckigen Klammern ein. (Die Verwendung von Doppelbyte-Klammern ist möglich.)

Sortierfolge für Kanji-Indexeintrag


Inhaltsverzeichnisse und Indizes

Generieren von Indizes

Nach Einfügen der Marken im Quelldokument können Sie einen Standardindex oder einen beliebigen anderen Markenindex generieren. Wenn Sie das Quelldokument überarbeiten, können Sie den Index neu generieren und aktualisieren. Informationen zum Generieren von Inhaltsverzeichnissen und anderen Listen finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen.

Normalerweise verwenden Sie vordefinierte Markentypen. Sie können für besondere Zwecke jedoch auch spezielle Markentypen anlegen, die z. B. Haupteinträge in Fettschrift anzeigen oder einige (aber nicht alle) Seiteneinträge mit speziellem Text versehen. Der spezielle Text könnte aus dem Wort Hinweis oder dem Wort Abbildung im Anschluss an einige Seitennummern bestehen. Bestimmte Indizes könnten nach den Seitennummern Abkürzungen wie ff und passim enthalten.

Sie können auch einen Referenzindex für spezielle Verwendungszwecke generieren, z. B. einen Index der in einem Dokument verwendeten Schriften. Dieser Indextyp wird jedoch nicht aus Marken generiert.

Indizes können auch aus einem einzelnen Dokument oder aus einem Buch generiert werden.

So generieren Sie einen Index für ein Buch:

    1. Öffnen Sie das Buchfenster und wählen Sie die Datei aus, über der Sie die generierte Datei einfügen wollen.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Hinzufügen > Standardindex".

    Wählen Sie "Hinzufügen > Index von" und wählen Sie den gewünschten speziellen Indextyp.

    3. Verschieben Sie die für die Einträge verwendeten Markentypen in die Auswahlliste "Übernahme der Markentypen".

Generieren eines Buchindex

Um ein Element aus einer Auswahlliste in eine andere zu verschieben, wählen Sie das Element aus, klicken auf einen Pfeil oder doppelklicken auf das Element. Um alle Elemente aus einer Liste in die andere zu verschieben, halten Sie die Umschalttaste gedrückt und klicken auf einen Pfeil.

    4. Legen Sie im Aufklappmenü "Datei einfügen" fest, ob die generierte Liste vor oder nach dem aktuellen Dokument angezeigt werden soll.

    5. Geben Sie ein Suffix ein oder belassen Sie das Standardsuffix. Das Suffix gibt den Typ der generierten Datei an. "SIX" ist das übliche Suffix für einen Standardindex.

Hinweis: Verwechseln Sie das Suffix nicht mit der Dateinamenerweiterung. Das Suffix wird mit Absatztypen in generierten Listen verwendet und als Teil des Namens der generierten Datei betrachtet, z. B. HandbuchSIX.fm.

    6. Wählen Sie "Hypertext-Verbindungen anlegen", um alle Einträge im generierten Index mit der jeweiligen Quelle zu verbinden.

    7. Klicken Sie auf "Einfügen" und anschließend auf "Aktualisieren". FrameMaker generiert den Index und zeigt ihn in einem separaten Dokument an.

    8. Speichern Sie den Index in demselben Ordner wie das Quelldokument oder Buch. Die generierte Datei können Sie im Buchfenster umbenennen; FrameMaker benennt sie dann auf der Festplatte um und aktualisiert alle Verweise.

Wenn Sie den Index das erste Mal generieren, übernimmt er das Seitenlayout des ersten nicht generierten Dokuments im Buch, wodurch alle Einträge dasselbe Aussehen aufweisen. (Durch die Verwendung einer Schablone lässt sich dieses unformatierte Ergebnis vermeiden; siehe Formatieren von Listen und Indizes mithilfe von Schablonen.) Informationen über Änderungen im Indexformat, die bei einer erneuten Generierung des Index nicht verloren gehen, finden Sie unter Formatieren von Listen und Indizes.

    9. Speichern Sie alle geöffneten Dateien im Buch. Geöffnete Dateien werden nur im Arbeitsspeicher Ihres Computers, jedoch nicht auf der Festplatte aktualisiert. Eine nicht geöffnete Datei wird direkt auf der Festplatte aktualisiert.

So generieren Sie einen Index für ein einzelnes Dokument:

    1. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Spezial > Standardindex".

    Wählen Sie "Spezial > Index von" und wählen Sie den gewünschten speziellen Indextyp aus.

    2. Wenn Sie dazu aufgefordert werden, geben Sie an, ob die generierte Datei als unabhängiges Dokument oder als Teil eines Buches erstellt werden soll.

Wenn Sie "Ja" wählen, um ein eigenständiges Dokument anzulegen, erstellt FrameMaker eine generierte Liste im Ordner des Originaldokuments. Wenn Sie "Nein" wählen, fügt FrameMaker den Index einem geöffneten Buch hinzu oder legt bei Bedarf ein neues Buch an.

    3. Geben Sie ein Suffix ein oder belassen Sie das Standardsuffix. Das Suffix gibt den Typ der generierten Datei an. "SIX" ist das übliche Suffix für einen Standardindex.

Hinweis: Verwechseln Sie das Suffix nicht mit der Dateinamenerweiterung. Das Suffix wird mit Absatztypen in generierten Listen verwendet und als Teil des Namens der generierten Datei betrachtet, z. B. HandbuchSIX.fm.

    4. Wählen Sie "Hypertext-Verbindungen anlegen", um alle Einträge im generierten Index mit der jeweiligen Quelle zu verbinden.

    5. Führen Sie eine der folgenden Aktionen aus:

    Wenn Sie einen eigenständigen Index erstellen, klicken Sie auf "Zuweisen". FrameMaker generiert den Index und zeigt ihn an.

    Wenn Sie den Index einem Buch hinzufügen, klicken Sie auf "Einfügen" und dann auf "Aktualisieren". Wenn ein neues Buch angelegt wird, wählen Sie "Datei > Buch sichern unter" und speichern das Buch.

Wenn Sie den Index das erste Mal generieren, übernimmt er das Seitenlayout des Quelldokuments oder des ersten nicht generierten Dokuments im Buch, wodurch alle Einträge dasselbe Aussehen aufweisen. (Durch die Verwendung einer Schablone lässt sich dieses unformatierte Ergebnis vermeiden; siehe Formatieren von Listen und Indizes mithilfe von Schablonen.) Informationen über Änderungen im Indexformat, die bei einer erneuten Generierung des Index nicht verloren gehen, finden Sie unter Formatieren von Listen und Indizes.

    6. Speichern Sie den Index in demselben Ordner wie das Quelldokument oder Buch. Informationen zum Umbenennen generierter Dateien finden Sie unter Umbenennen von Buchdateien.

So generieren Sie einen Standardindex, der Seitennummern auf unterschiedliche Weise anzeigt:

    1. Erstellen Sie einen oder mehrere Markentypen (siehe Hinzufügen von speziellen Markentypen) und weisen Sie ihnen einen Namen zu, der auf die beabsichtigte Verwendung hinweist. Wenn Sie z. B. Indexeinträge hervorheben möchten, die sich auf Fußnoten beziehen, könnten Sie einen Markentyp mit dem Namen IndexFuß erstellen.

    2. Verwenden Sie dabei die Index-Markentypen für reguläre Einträge und eigene Markentypen für spezielle Einträge.

    3. Generieren Sie den Index. Wählen Sie den Markentyp Index sowie die speziellen Markentypen aus.

Bearbeiten Sie im Index den speziellen Textfluss auf der Referenzseite für die spezielle Marke (die Referenzseite hat den Namen SIX), um Text nach der Seitennummer einzufügen oder das Zeichenformat zu ändern. Sie können z. B. den Text für IndexFußSIX so ändern, dass nach der Seitennummer [Fußnote] eingefügt wird: <$SeiteNum> [Fußnote]

Einzelheiten hierzu finden Sie unter Manuelles Hinzufügen von Eintragstext. Informationen zum Hinzufügen eines Zeichenformats finden Sie unter Ändern der Absatz- und Zeichenformate von Einträgen.

    4. Aktualisieren Sie den Index, damit die Änderungen wirksam werden.


Inhaltsverzeichnisse und Indizes

Aktualisieren und Bearbeiten von Indizes

Ein Index kann schnell veralten. Wenn Sie einen Index das erste Mal überprüfen, sind in der Regel einige Änderungen erforderlich. Möglicherweise stellen Sie fest, dass einige Einträge abweichende Formulierungen aufweisen, oder Sie möchten die Organisation einiger Einträge ändern.

Sie bearbeiten Indexeinträge, indem Sie die entsprechenden Absätze oder Marken im Quelldokument ändern und dann den Index neu generieren. Wenn Sie Einträge direkt im Index bearbeiten, gehen die Änderungen bei der nächsten Generierung verloren.

Wenn Sie einen Schreibfehler direkt in einem Index korrigieren, wird dieser Fehler bei der nächsten Generierung wieder auftreten, weil er im Quellabsatz weiterhin vorhanden ist. Um einen Fehler endgültig zu bereinigen, müssen Sie den Markentext im Quelldokument korrigieren und den Index dann neu generieren.

In diesem Abschnitt wird die Vorgehensweise zum Aktualisieren und Bearbeiten von generierten Indizes (oder Markenlisten), nicht jedoch von Absatzlisten, wie z. B. Inhaltsverzeichnisse, beschrieben. Informationen über das entsprechende Vorgehen für Absatzlisten (z. B. Inhaltsverzeichnisse) finden Sie unter Aktualisieren und Bearbeiten von Inhaltsverzeichnissen und Listen.

So aktualisieren Sie einen Index in einem Buch:

    1. Nehmen Sie die erforderlichen Änderungen im Quelldokument vor.

    2. Wählen Sie im Buchfenster "Bearbeiten > Buch aktualisieren".

    3. Verschieben Sie die Namen der zu aktualisierenden Listen in die Auswahlliste "Generieren". Stellen Sie sicher, dass "Inhaltsverzeichnis, Listen und Indizes generieren" aktiviert ist, und klicken Sie auf "Aktualisieren".

So fügen Sie Einträge in einen Index in einem Buch ein bzw. entfernen sie daraus:

    1. Wählen Sie den generierten Index im Buchfenster aus.

    2. Wählen Sie "Bearbeiten > Einstellungen für Standardindex" (bzw. "Einstellungen für Indextyp").

    3. Verschieben Sie die Einträge wie gewünscht zwischen den Listen und klicken Sie auf "Zuweisen". Klicken Sie anschließend auf "Aktualisieren".

So aktualisieren Sie einen Index in einem eigenständigen Dokument:

    1. Nehmen Sie die erforderlichen Änderungen im Quelldokument vor.

    2. Wählen Sie im Quelldokument aus dem Menü "Spezial" den jeweiligen Befehl (z. B. "Standardindex") aus und klicken Sie dann auf "Ja", um ein eigenständiges Dokument anzulegen.

    3. Verlagern Sie die Elemente wie erforderlich zwischen den Listen und klicken Sie auf "Zuweisen".


Inhaltsverzeichnisse und Indizes / Aktualisieren und Bearbeiten von Indizes

Suchen der Quelle von Indexeinträgen

Wenn Sie einen Eintrag korrigieren wollen, müssen Sie ihn bis zur Quelle zurückverfolgen, d. h. bis zur entsprechenden Marke (oder bei strukturierten Dokumenten zum Markenelement) im Quelldokument.

Am schnellsten finden Sie die Quelle mithilfe der Hypertext-Verbindung, die dem Eintrag in der generierten Datei zugeordnet ist. Über diese Hypertext-Verbindung können die entsprechenden Informationen im Quelldokument angezeigt und ausgewählt werden. Außerdem ist das Suchen und Auswählen einer Marke im Quelldokument mithilfe des Befehls "Suchen/Ändern" möglich. Bei der Arbeit mit strukturierten Dokumenten können Sie das Element in der Strukturansicht anhand des Elementrechtecks auswählen.

Wichtig: Wenn Sie sehr umfangreiche Indizes (mit mehr als 50.000 Marken) generieren, sollten Sie die Option "Hypertext-Verbindungen anlegen" nicht verwenden. Die Generierung von Indizes dieser Größe dauert mit "Hypertext-Verbindungen anlegen" extrem lange oder kann sogar fehlschlagen.

So suchen Sie die Quelle eines Indexeintrags mithilfe einer Hypertext-Verbindung:

    1. Wenn Sie bei der Generierung des Index nicht "Hypertext-Verbindungen anlegen" ausgewählt haben, holen Sie dies nun nach und generieren den Index neu.

    2. Wählen Sie "Spezial> Marke".

    3. Gehen Sie im generierten Index entsprechend des Betriebssystems folgendermaßen vor:

    (Windows) Halten Sie die Alt- und Strg-Taste gedrückt und klicken Sie in einem Index auf einen Seitenverweis.

    (UNIX) Halten Sie die Control-Taste gedrückt und klicken Sie mit der rechten Maustaste auf einen Seitenverweis in einem Index.

FrameMaker öffnet das Quelldokument, zeigt die Seite an, auf der sich die betreffende Marke befindet, und wählt sie aus. Im Dialogfenster "Marke" wird der Markentext angezeigt.

So wählen Sie eine Marke mithilfe von "Suchen/Ändern" aus:

    1. Wählen Sie im Quelldokument (nicht in der generierten Liste) "Bearbeiten > Suchen/Ändern".

    2. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie in einem nicht strukturierten Dokument aus dem Aufklappmenü "Suchen" den Eintrag "Beliebige Marke", "Marke des Typs" oder "Markentext" aus. Geben Sie den Markentyp oder Markentext wie gewünscht ein.

    In einem strukturierten Dokument wählen Sie aus dem Aufklappmenü "Suchen" den Eintrag "Element", geben den Typ des gesuchten Elements ein und klicken auf "Zuweisen".

    3. Klicken Sie auf "Suchen".

Hinweis: Sobald eine Marke ausgewählt ist, wird der Markentext im Dialogfenster "Marke" angezeigt. Klicken Sie im Dialogfenster "Suchen/Ändern" nicht auf "Ändern", um den Markentext zu ändern. In diesem Fall ersetzt FrameMaker die gesamte Marke. Ändern Sie stattdessen den Text im Dialogfenster "Marke" und klicken Sie dann auf "Marke bearbeiten".

So wählen Sie eine Marke im Quelldokument aus:

Ziehen Sie mit dem Mauszeiger über die Marke. Wenn der ausgewählte Text nur eine Marke enthält, wird deren Text im Dialogfenster "Marke" angezeigt. Wenn mehrere Marken ausgewählt sind, wird der Text der ersten Marke angezeigt.


Inhaltsverzeichnisse und Indizes / Aktualisieren und Bearbeiten von Indizes

Bearbeiten und Löschen von Indexeinträgen

Sie überarbeiten den Inhalt von Einträgen, indem Sie die entsprechenden Marken (oder Markenelemente) im Quelldokument ändern.

So bearbeiten Sie eine Marke (bzw. ein Markenelement):

Wählen Sie die Marke (bzw. das Element) aus, ändern Sie den Text im Dialogfenster "Marke" und klicken Sie auf "Marke bearbeiten".

So löschen Sie eine Marke (bzw. ein Markenelement):

Wählen Sie die Marke (bzw. das Element) im Quelldokument aus und drücken Sie die Entf-Taste.


Inhaltsverzeichnisse und Indizes

Anlegen eines Hauptinhaltsverzeichnisses oder Index für mehrere Bücher

Bei mehreren zusammengehörigen Büchern möchten Sie eventuell ein Hauptinhaltsverzeichnis oder einen Index für die Bücher erstellen.

Hauptindex

So richten Sie eine Buchdatei ein, um ein Hauptinhaltsverzeichnis oder einen Hauptindex zu erstellen:

    1. Legen Sie eine neue Buchdatei an, die die Dateien aller Bücher in der gegebenen Reihenfolge enthält (siehe Erzeugen von Buchdateien).

In den Originalbüchern generierte Dateien werden als Dokumentdateien eingefügt (siehe Hinzufügen von Dateien zu einem Buch). Wenn Sie die generierten Dateien aktualisieren müssen, verwenden Sie dazu nicht die Vorgabedatei, sondern die ursprüngliche Buchdatei.

    2. Fügen Sie ein Inhaltsverzeichnis, einen Index oder eine andere generierte Datei zur neuen Buchdatei hinzu. Diese generierte Datei ist die Vorgabedatei.

    3. Legen Sie im Buchfenster fest, wie in der generierten Hauptdatei Band-, Kapitel- und Seitennummern für die einzelnen Dokumente angezeigt werden sollen. Weitere Informationen finden Sie unter Einrichten der Nummerierung.

Hinweis: Wenn Sie das Buch aktualisieren, setzen die Nummerierungsoptionen des Buches die entsprechenden Einstellungen des Dokuments außer Kraft, es sei denn, Sie wählen "Aus Datei einlesen".

    4. Legen Sie im Buchfenster die geeigneten Optionen für Seitenumbruch und Layout fest (siehe Ändern des grundlegenden Seitenlayouts eines Dokuments).

    5. Generieren und aktualisieren Sie die Datei (siehe Aktualisieren von Büchern).


Inhaltsverzeichnisse und Indizes

Fehlerbehebung in Indizes

Wenn Sie Markentext falsch eingeben, spiegelt sich dies im Index wider. Beim ersten Erstellen eines Index treten häufig Probleme auf.

Fehlende Einträge

Führen Sie folgende Schritte aus, wenn ein Eintrag im generierten Index überhaupt nicht vorhanden ist:

    Überprüfen Sie, ob die entsprechende Marke (bzw. das Markenelement) einen falschen Markentyp darstellt. Dazu können Sie eine Markenliste erstellen, die alle Markentypen enthält, und die Liste anschließend nach dem gewünschten Eintrag durchsuchen. Weitere Informationen finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen.

    Prüfen Sie, ob sich die entsprechende Marke (bzw. Markenelement) in verborgenem oder bedingtem Text befindet, indem Sie "Spezial > Bedingter Text" wählen, den gesamten bedingten Text einblenden und dann den Index erneut generieren.

    Überprüfen Sie, ob die Marke (bzw. das Markenelement) versehentlich gelöscht wurde.

Einträge mit doppelten Fragezeichen

Doppelte Fragezeichen (??) in einem Seitenbereich weisen darauf hin, dass FrameMaker nur eine der beiden Marken findet, die den Bereich definieren. Gehen Sie bei doppelten Fragezeichen folgendermaßen vor:

    Vergewissern Sie sich, dass keine Marke (oder Markenelement) fehlt.

Fehlender <$startrange> und der daraus resultierende Seitenbereich

    Vergewissern Sie sich, dass Rechtschreibung, Zeichensetzung und Groß-/Kleinschreibung des Markentextes genau übereinstimmen.

Unterschiedliche Schreibung und der daraus resultierende Seitenbereich

    Stellen Sie sicher, dass in der ersten Marke (bzw. Markenelement) <$startrange> und in der zweiten Marke (bzw. Markenelement) <$endrange> enthalten ist.

<$endrange> an erster Stelle und der daraus resultierende Seitenbereich

Falsch sortierte Einträge

Die meisten Sortierprobleme entstehen in Folge von falschem Markentext. Gehen Sie bei falsch sortierten Einträgen folgendermaßen vor:

    Prüfen Sie, ob Doppelpunkte und Semikolons korrekt verwendet werden. Wenn anstelle eines Doppelpunkts ein Semikolon gesetzt wurde, werden statt eines Untereintrags zwei Haupteinträge angezeigt. Bei einem fehlenden Doppelpunkt wird ein Untereintrag als Haupteintrag angezeigt.

Fehlender Doppelpunkt und daraus resultierender falsch sortierter Eintrag

    Überprüfen Sie, ob die Sortieranweisung vorhanden und korrekt ist und am Ende des Markentextes in eckigen Klammern ([ ]) steht (sieheFestlegen der Sortierfolge in Indizes). Wenn Sie z. B. einen Querverweis als letzten Untereintrag einordnen möchten, muss die letzte Stelle der Sortierinformationen im Markentext :zzz lauten.

Fehlende :zzz-Angabe und daraus resultierender falsch sortierter Eintrag

    Wenn Sortierungsfehler nach einem bestimmten Schema auftreten (z. B. wenn alle numerischen Einträge am Ende des Index angezeigt werden statt am Anfang), prüfen Sie, ob die Sortierinformationen im entsprechenden Textfluss auf der Referenzseite korrekt sind. Weitere Informationen finden Sie unter Ändern der Sortierfolge für Indizes.

Seitennummern mit "Siehe"- oder "Siehe auch"-Querverweisen

Ein Querverweis-Indexeintrag kann irrtümlich eine Seitennummer enthalten. Stellen Sie sicher, dass <$nopage> am Anfang des Markentexts für den Querverweiseintrag steht.

Fehlendes <$nopage> und falsch angezeigte Seitennummer

Fehlerhafte Zeilenumbrüche

Wenn Einträge zwischen den Nummern eines Seitenbereichs oder zwischen dem Ende des Eintrags und der ersten Seitennummer umbrechen, gehen Sie folgendermaßen vor:

    Ändern Sie die Zeichen, nach denen FrameMaker Zeilenumbrüche zulässt. Um Zeilenumbrüche nach bestimmten Zeichen zu verhindern, z. B. nach einem n-Bindestrich (–), verwenden Sie "Format > Dokument > Textoptionen" (siehe Ändern von Silbentrennung und Zeilenumbruch).

    Damit die Seitennummer in der gleichen Zeile angezeigt wird wie das Ende des Eintrags, verwenden Sie als Trennzeichen ein umbruchgeschütztes Leerzeichen oder ein n- bzw. m-Leerzeichen.

    Wenn Sie im speziellen Textfluss auf der Referenzseite festgelegt haben, dass Leerzeichen oder Bindestriche zwischen den Seitennummern eines Bereichs stehen, stellen Sie sicher, dass diese Zeichen umbruchgeschützt sind (siehe Bearbeiten von speziellen Textflüssen für Listen und Indizes und Ändern von Silbentrennung und Zeilenumbruch).

    Ändern Sie Band- und Kapitelnummerierung für die Seitennummern des Quelldokuments (siehe Einrichten der Nummerierung). Wenn die Buchseiten nach Kapiteln nummeriert sind (1-1, 1-2, ..., 2-1, 2-2, ...), sollte ein umbruchgeschützter Bindestrich auf die Band- bzw. Kapitelnummer folgen. Weitere Informationen finden Sie unter Ändern von Silbentrennung und Zeilenumbruch.

Fehlerhafte Zeilenumbrüche

Fehlende Titel

Ein von Ihnen eingegebener Titel wird unter Umständen bei der nächsten Generierung des Index nicht angezeigt, wenn Sie die im Abschnitt Hinzufügen von Titeln oder anderem statischen Text in Listen und Indizes erläuterten Arbeitsschritte nicht korrekt ausführen.

Fehlende Formatierungen

Wenn die von Ihnen vorgenommenen Formatänderungen bei der erneuten Generierung des Index (siehe Formatieren von Listen und Indizes) nicht mehr vorhanden sind, führen Sie die folgenden Schritte aus:

    Eine generierte Datei kann im Buchfenster umbenannt werden. FrameMaker benennt die Datei im Buchfenster und auf der Festplatte um.

    Um Änderungen an Absatz- und Zeichenformaten beizubehalten, speichern Sie sie im Absatzformat- oder Zeichenformat-Katalog des Index, damit sie bei der nächsten Indexgenerierung verfügbar sind. Weitere Informationen finden Sie unter Definieren und Aktualisieren von Formaten.

    Wenn Sie andere Änderungen beibehalten wollen, führen Sie diese im speziellen Textfluss aus, wie es im Abschnitt Bearbeiten von speziellen Textflüssen für Listen und Indizes beschrieben wird.


Inhaltsverzeichnisse und Indizes

Hinzufügen von speziellen Markentypen

Sie können spezielle Markentypen erstellen und diese wie alle anderen Markentypen in Listen oder Indizes verwenden. Ein neuer Markentyp kann auch für andere Dokumente und Bücher benutzt werden.

Ein Beispiel für spezielle Markentypen in Indizes finden Sie unter Generieren von Indizes.

So fügen Sie einen speziellen Markentyp hinzu oder löschen ihn:

    1. Wählen Sie aus dem Aufklappmenü "Markentyp" zuerst "Spezial > Marke" und dann "Bearbeiten".

    2. Führen Sie eine der folgenden Aktionen aus:

    Geben Sie einen neuen Namen ein und klicken Sie auf "Einfügen".

    Wählen Sie einen Namen aus dem Aufklappmenü aus und klicken Sie auf "Löschen".

    3. Klicken Sie auf "Fertig".

Sie können spezielle Markentypen auch im Buchfenster bearbeiten. Wählen Sie die Dokumente aus, die Sie einbeziehen möchten, und drücken Sie anschließend die Tasten Esc e m t.

So kopieren Sie einen Markentyp aus einem Dokument in ein anderes:

Führen Sie eine der folgenden Aktionen aus:

    Kopieren Sie eine Marke oder Text, der eine Marke enthält, und fügen Sie sie bzw. ihn in ein anderes Dokument ein.

    Wählen Sie "Datei > Importieren > Formate" und importieren Sie "Dokumenteinstellungen".

So benennen Sie einen Markentyp um:

    1. Wählen Sie aus dem Aufklappmenü "Markentyp" zuerst "Spezial > Marke" und dann "Bearbeiten".

    2. Wählen Sie aus dem Aufklappmenü den Markentyp aus, den Sie umbenennen wollen, und klicken Sie auf "Ändern".

    3. Führen Sie eine der folgenden Aktionen aus:

    Um die angegebenen Marken mit einem anderen Namen zu versehen, geben Sie den neuen Namen in das Textfeld "Zu" ein.

    Wenn Sie den angegebenen Marken den Namen eines anderen Markentyps zuweisen möchten, wählen Sie den gewünschten Namen aus dem Aufklappmenü "Zu".

    4. Klicken Sie auf "OK" und dann auf "Zurück".


Inhaltsverzeichnisse und Indizes

Hinzufügen von Titeln oder anderem statischen Text in Listen und Indizes

Sie können in Ihre Liste oder Ihren Index einen Titel oder anderen nicht veränderbaren Text einfügen, nachdem die Liste oder der Index das erste Mal generiert wurde.

Statischer Text als Titel in einer generierten Datei

Statischer Text kann auch in eine Schablone eingefügt werden, die sich dann zur Formatierung einer Liste oder eines Index verwenden lässt (siehe Formatieren von Listen und Indizes mithilfe von Schablonen).

So erstellen Sie einen Titel für eine Liste oder einen Index:

    1. Geben Sie den Titel vor dem ersten Eintrag auf einer Arbeitsseite ein.

    2. Verwenden Sie den Absatzkatalog, um dem Text ein spezielles Absatzformat für statischen Text zuzuweisen, oder erzeugen Sie ein neues Absatzformat für den Titel.

    3. Wenn Sie einen neuen Absatztyp erstellen, darf dieser nicht mit dem Suffix der generierten Datei enden, z. B. auf SIX bei einem Standardindex oder auf IVZ bei einem Inhaltsverzeichnis. Wenn Sie den Index neu generieren, ersetzt FrameMaker nur die Absätze, deren Typen auf dem entsprechenden Suffix enden.


Inhaltsverzeichnisse und Indizes

Formatieren von Listen und Indizes

Beim ersten Generieren einer Liste oder eines Index (ohne Schablone, wie unter Formatieren von Listen und Indizes mithilfe von Schablonen beschrieben) übernimmt die Liste bzw. der Index das Seitenlayout des Quelldokuments bzw. des ersten nicht generierten Dokuments im Buch, wodurch alle Einträge dasselbe Aussehen aufweisen. Sie können die Seitengestaltung und die Formate in der Liste oder im Index nach der Generierung wie in jedem anderen Dokument ändern. Die Änderungen werden beibehalten, wenn Sie die Datei neu generieren.

So können Sie z. B. die Kopf- und Fußzeilen, die Anzahl der Textspalten sowie die Absatz- und Zeichenformate für die Einträge ändern. Sie können vor den Seitennummern einen Tabulator und Tabulatorführungspunkte oder die automatisch erstellte Nummer eines Absatzes in einem Eintrag verwenden. Sie können in Einträgen auch Kapitel- und Bandnummern angeben.

Die Formatierung generierter Listen oder Indizes lässt sich auch durch eine Änderung des speziellen Textflusses auf der Referenzseite der generierten Datei steuern. Der spezielle Textfluss wird bei der erstmaligen Generierung der Liste oder des Index erzeugt.

Weitere Informationen zum Ändern von Absatz- und Zeichenformaten finden Sie unter Definieren und Aktualisieren von Formaten.


Inhaltsverzeichnisse und Indizes / Formatieren von Listen und Indizes

Formatieren von Listen und Indizes mithilfe von Schablonen

Anstatt eine Liste oder einen Index zu generieren, können Sie auch eine Schablone verwenden und die Formatänderungen dann nacheinander vornehmen. Informationen zum Erstellung einer Schablone für eine Liste oder einen Index finden Sie unter Erstellen von Schablonen für generierte Dateien und in den meisten anderen Abschnitten dieses Kapitels.

So verwendet FrameMaker eine Schablone für eine generierte Datei:

    1. Kopieren Sie die Schablone in den Ordner des Quelldokuments und verwenden Sie denselben Dateinamen wie für die Liste oder den Index.

    2. Generieren Sie die Liste oder den Index.

Sie können die Formate einer Schablone auch über "Datei > Importieren > Formate" importieren. Generieren Sie dann die Liste bzw. den Index neu, damit alle Änderungen im speziellen Textfluss der generierten Datei wiedergegeben werden.


Inhaltsverzeichnisse und Indizes / Formatieren von Listen und Indizes

Erläuterung von speziellen Textflüssen

Viele Formateigenschaften einer Liste oder eines Index werden durch einen speziellen Textfluss auf der Referenzseite der generierten Datei gesteuert. Der Name der Referenzseite stimmt mit dem Standardsuffix überein, z. B. IVZ für ein Inhaltsverzeichnis oder SIX für einen Standardindex.

Bei generierten Listen entspricht jeder Absatz im Textfluss einem Absatztyp oder einem Markentyp, der in die Liste aufgenommen wurde. Die Typnamen dieser Absätze enden mit dem Standardsuffix. Beispielsweise entspricht ein Absatz des Typs "Überschrift1IVZ" im Textfluss für ein Inhaltsverzeichnis den Einträgen für Überschriften der ersten Ebene (Typ "Überschrift1" im Quelldokument).

Spezieller Textfluss auf der Referenzseite für ein Inhaltsverzeichnis

Bei Indizes entsprechen die Absätze im Textfluss den Markentypen im Index, den Ebenen von Einträgen und Untereinträgen, der Sortierfolge, dem verwendeten Trennzeichen und anderen Indexeigenschaften.

Spezieller Textfluss für einen Index
A: Platzhalter für Trennzeichen B: Eintragsebenen C: Platzhalter für Gruppentitel D: Sortierfolge E: Platzhalter ignorieren

Wenn die Liste oder der Index mit Hypertext-Verbindungen erstellt wurde, enthält der spezielle Textfluss auch einen Absatz, der die Form der Hypertextbefehle in der generierten Datei angibt. Der Typ dieses Absatzes beginnt mit dem Wort Aktiv.

Spezielle Textflüsse für Listen und Indizes enthalten spezielle Absätze mit Platzhaltertext. Mithilfe dieses Platzhaltertexts können Sie festlegen, wie Ihre Einträge aussehen sollen, wenn Sie die Datei neu generieren.


Inhaltsverzeichnisse und Indizes / Formatieren von Listen und Indizes

Bearbeiten von speziellen Textflüssen für Listen und Indizes

Bausteine wie <$SeiteNum> und <$AbsText>, die sich in jedem Absatz des speziellen Textflusses befinden, legen die angezeigten Informationen und deren Reihenfolge in der Liste oder im Index fest. Folgende Bausteine können im speziellen Textfluss verwendet werden.

Baustein | Bedeutung
<$autorange> | Erstellt automatisch Seitenbereiche in einem Index (siehe Verwenden von Seitenbereichen in Indexeinträgen).
<$numerics> <$alphabetics> <$symbols> <$kana> | Legt die Sortierfolge für den gesamten Index fest (siehe Ändern der Sortierfolge für Indizes).
<$SeiteNum> | Zeigt die Seitennummer an, auf der der Quellabsatz oder die Marke angezeigt wird.
<$volnum> | Zeigt die Bandnummer des Dokuments an, in dem die Marke oder der Quellabsatz steht.
<$chapnum> | Zeigt die Kapitelnummer des Dokuments an, in dem die Marke oder der Quellabsatz steht.
<$AbsText> | Zeigt den Text des Absatzes ohne automatische Nummerierungen an.
<$AbsNum> | Zeigt die automatische Nummerierung des Absatzes an, allerdings ohne Leerzeichen und Tabulatoren am Ende der Nummer (z. B. Abschnitt 2.1.1).
<$AbsNumExkl> | Zeigt die Zähler der automatischen Absatznummerierung und die Zeichen zwischen ihnen an (z. B. 2.1.1).
<$AbsTyp> | Zeigt die Quelle des Absatztyps an

So bearbeiten Sie den speziellen Textfluss für eine Liste oder einen Index:

    1. Wählen Sie in der Liste bzw. im Index "Darstellung > Referenzseiten".

    2. Zeigen Sie die Referenzseite mit dem gewünschten Textfluss an. (Der Name der Referenzseite entspricht dem Standardsuffix, z. B. IVZ für ein Inhaltsverzeichnis oder SIX für einen Standardindex.)

    3. Bearbeiten Sie die entsprechenden Absätze im Textfluss. Detaillierte Bearbeitungshinweise finden Sie unter Ändern der Absatz- und Zeichenformate von Einträgen sowie in den folgenden Abschnitten.

    4. Wählen Sie "Darstellung > Arbeitsseiten".

    5. Generieren Sie den Index neu, um die Wirkung der Änderungen anzuzeigen.

Hinweis: Stellen Sie sicher, dass Sie den Index oder die Liste aus dem Quelldokument und nicht von der generierten Datei aus generieren.


Inhaltsverzeichnisse und Indizes / Formatieren von Listen und Indizes

Ändern der Absatz- und Zeichenformate von Einträgen

Das Aussehen von Einträgen in generierten Listen und Indizes kann durch Bearbeiten der Absatzformate geändert werden.

Zusätzlich können Sie das Zeichenformat des in der Liste angezeigten Textes und aller Seitennummern im Index ändern, die mit demselben Markentyp erstellt wurden. Beispielsweise können Sie alle Seitennummern kursiv darstellen.

Hinweis: Wenn Sie im Quelldokument nach dem Generieren der Liste oder des Index ein neues Zeichenformat definieren, müssen Sie über "Datei > Importieren > Formate" das Zeichenformat in die generierte Liste importieren. Dies ist jedoch nur notwendig, wenn Sie das neue Zeichenformat in einem Absatz oder einer Marke verwenden, die Bestandteil der Liste oder des Index ist. Wenn Sie das Zeichenformat erstellt haben, bevor die Liste oder der Index generiert wurde, wird es von FrameMaker in die generierte Datei importiert.

So ändern Sie das Absatzformat von Einträgen:

    1. Zeigen Sie in der Liste oder im Index die Referenzseite an, die den speziellen Textfluss enthält. Gewöhnlich handelt sich dabei um IVZ für ein Inhaltsverzeichnis bzw. SIX für einen Standardindex.

    2. Ermitteln Sie die Platzhalterabsätze, deren Absatzformate den Listen- oder Indexeinträgen entsprechen. (Z. B. ist "Ebene1SIX" das Format des Platzhaltertextes für einen Indexeintrag der ersten Ebene und "Überschrift1IVZ" das Format eines Überschrift1-Eintrags in einem Inhaltsverzeichnis.)

    3. Ändern Sie die Eigenschaften der Absatzformate (z. B. Einzüge und Schriftgröße) und aktualisieren Sie die Absatzformate, damit sie bei der nächsten Generierung der Datei verfügbar sind. Informationen zum Ändern von Formaten finden Sie unter Definieren und Aktualisieren von Formaten. Die Platzhalterabsätze zeigen an, wie die Einträge aussehen werden.

Formatierte Platzhalterabsätze

So ändern Sie das Zeichenformat der Einträge:

    1. Erstellen Sie in der Liste oder im Index ein neues Zeichenformat und speichern Sie es im Zeichenformat-Katalog (siehe Erstellen neuer Formate).

    2. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss enthält.

    3. Führen Sie im Absatz, dessen Typ den zu ändernden Einträgen entspricht, folgende Aktionen aus:

    Geben Sie in einer Liste vor dem zu ändernden Text den Zeichentyp in spitzen Klammern (< >) ein. Wenn Sie die Standardschrift des Absatzes wiederherstellen wollen, geben Sie <Absatzstandardschrift> ein. Sie können z. B. ein Format des Typs "ChapNumFont" definieren und es dann zum Formatieren von Kapitelnummern in einem Inhaltsverzeichnis mit einer größeren Schrift verwenden.

Referenzseite und resultierendes Inhaltsverzeichnis

    Geben Sie den Zeichentyp in einem Index links neben <$SeiteNum> in spitzen Klammern (< >) ein. Wenn z. B. "IndexPgNum" ein Zeichenformat für kursive Seitennummern in einem Standardindex ist, könnten Sie damit nur die Seitennummern in Absätzen des Typs IndexSIX formatieren.

Referenzseite und resultierender Index

Sie können das Zeichenformat des angezeigten Textes in einer Liste oder einem Index auch ändern, indem Sie dem Baustein direkt ein Zeichenformat zuweisen, ohne ihm einen Zeichentyp in spitzen Klammern voranzustellen. Achten Sie darauf, das Zeichenformat nicht auf das Absatzsymbol anzuwenden.


Inhaltsverzeichnisse und Indizes / Formatieren von Listen und Indizes

Übernehmen der automatischen Band-, Kapitel- und Absatznummerierung

Sie können in eine generierte Liste zusätzlich zur (bzw. anstelle der) Seitennummerierung eine automatische Nummerierung in Einträge aufnehmen (d. h. Text und Nummern, die automatisch als Teil eines Absatzformats eingefügt werden). In einem Index kann anstelle von Seitennummern die automatische Nummerierung verwendet werden, wenn alle Absätze mit Indexmarken ebenfalls automatisch nummeriert sind.

Index mit Abschnittssymbolen und Abschnittsnummern anstelle von Seitennummern

Für automatische Nummerierungen können Sie die folgenden Bausteine verwenden:

    <$volnum> und <$chapnum> übernehmen Band- bzw. Kapitelzähler. Weitere Informationen finden Sie unter Festlegen der Nummerierung von Dokumenten und Seiten.

Baustein für automatische Band- und Kapitelnummerierung und resultierender Index

    <$AbsNumExkl> übernimmt die Zähler einschließlich der dazwischenliegenden Zeichen (z. B. 2.2 für einen Absatz mit der automatischen Nummerierung Abschnitt 2.2).

Baustein für die automatische Absatznummerierung unter Verwendung von Abschnittsnummern und resultierender Index

    <$AbsNum> enthält die Zähler und den gesamten Text in der automatischen Nummerierung (mit Ausnahme von Leer- und Tabulatorzeichen am Ende).

Baustein für die automatische Absatznummerierung unter Verwendung von Abschnittstext und Abschnittsnummern sowie resultierendem Index

So übernehmen Sie automatische Band- und Kapitelnummerierung:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss enthält.

    2. Fügen Sie in einer Liste oder einem Index den Baustein <$volnum> oder <$chapnum> an der gewünschten Position der Nummerierung ein.

Wenn Sie z. B. in Einträgen, die aus Marken des Typs Index generiert wurden, zusätzlich zur Seitennummer die Kapitelnummer angeben wollen (z. B. 3-1), geben Sie im Absatz des Typs IndexSIX den Baustein <$chapnum>- vor dem Baustein <$SeiteNum> ein.

Damit bei Nummern wie "3-1" kein Zeilenumbruch erfolgt, fügen Sie einen umbruchgeschützten Trennstrich ein, indem Sie die Tasten Esc Bindestrich h drücken. Weitere Informationen hierzu finden Sie unter Ändern von Silbentrennung und Zeilenumbruch.

So übernehmen Sie die automatische Absatznummerierung:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss enthält.

    2. Führen Sie eine der folgenden Aktionen aus:

    Geben Sie in einer Liste den Baustein <$AbsNumExkl> oder <$AbsNum> an der gewünschten Position der Nummerierung ein.

    Ersetzen Sie in einem Index in dem Absatztyp, der mit dem Markentyp beginnt, den Baustein <$SeiteNum> durch <$AbsNum> oder <$AbsNumExkl>. Wenn Sie in Einträgen, die aus Marken des Typs Index generiert wurden, z. B. anstelle der Seitennummerierung die automatische Absatznummerierung verwenden wollen, ersetzen Sie im Absatz des Typs IndexSIX den Baustein <$SeiteNum>.


Inhaltsverzeichnisse und Indizes / Formatieren von Listen und Indizes

Ändern der Trennzeichen für Seitennummern

Ein typischer Indexeintrag wie Erosion 1, 2–3 umfasst ein Leerzeichen nach dem Eintragstext, ein Komma und ein Leerzeichen zwischen Seitennummern, einen n-Bindestrich zur Angabe eines Seitenbereichs und kein weiteres Zeichen nach der letzten Seitennummer. Sie können den n-Bindestrich durch das Wort bis ersetzen oder den Trennzeichentext in beliebiger Weise ändern. Der Trennzeichentext lässt sich z. B. so definieren, dass nach dem Eintrag ein Komma angezeigt wird (z. B. Erosion, 1).

So ändern Sie die Trennzeichen für Seitennummern:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss enthält.

    2. Bearbeiten Sie den Absatz für das Trennzeichenformat. (Suchen Sie nach dem Absatz, der 1, 2–3 enthält.) Sie können alle Trennzeichen ändern, müssen dazu jedoch die Platzhalternummern 1, 2 und 3 verwenden.

Absatz für spezielle Trennzeichen auf der Referenzseite IX
A: n-Bindestrich B: m-Leerzeichen


Inhaltsverzeichnisse und Indizes / Formatieren von Listen und Indizes

Manuelles Hinzufügen von Eintragstext

Sie können allen Einträgen, die aus Absätzen oder Marken eines bestimmten Typs generiert werden, Text hinzufügen. So ist es z. B. möglich, Seitennummern in eckigen Klammern auszugeben.

Hinzufügen von Klammern zu einem Inhaltsverzeichnis

Sie können auch spezielle Markentypen mit hinzugefügtem Text verwenden, um Seitennummern in einem Index unterschiedlich anzuzeigen. Angenommen, Sie möchten den folgenden Index generieren.

Spezielle, zu einem Index hinzugefügte Seitennummern

Dazu benötigen Sie zwei spezielle Marken: eine Marke für Seitennummern mit nachfolgendem ff und eine Marke für Seitennummern, auf die das Wort Fußnote folgt. Diese Marken bezeichnen Sie als Indexff und IndexFuß.

Bei der Generierung des Index übernehmen Sie alle drei Markentypen (Typ Index und die beiden neuen Typen). Nach dem ersten Generieren des Index können Sie den speziellen Textfluss für die Markentypen auf der Referenzseite bearbeiten.

Markentyp | Änderung auf der Referenzseite | Ergebnis
Indexff | <$SeiteNum> ff | 15 ff
IndexFuß | <$SeiteNum> Fußnote | 15 Fußnote

Beim nächsten Generieren des Index sind die Änderungen enthalten.

So fügen Sie Text manuell einem Eintrag hinzu:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für die Liste oder den Index enthält.

    2. Geben Sie den Text an der Stelle ein, an der er angezeigt werden soll. Um z. B. alle Seitennummern in Klammern darzustellen, setzen Sie die Seitennummern-Bausteine in Klammern: <$AbsText> [<$SeiteNum>]


Inhaltsverzeichnisse und Indizes / Formatieren von Listen und Indizes

Tabulatoren und Führungspunkte

Sie können Seitennummern in einer Liste oder in einem Index mithilfe von Tabulatoren ausrichten. Mit Tabulatoren lassen sich zwischen Text und Seitennummern außerdem Führungspunkte einfügen, z. B. in Form einer gepunkteten Zeile.

Rechtsbündiger Tabulatorstopp mit Führungspunkten in einem Inhaltsverzeichnis

Tabulatorstopps richten Index-Seitennummern in Spalten aus.

So verwenden Sie Tabulatoren und Führungspunkte in einer Liste:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für das Inhaltsverzeichnis oder die Liste enthält.

    2. Wählen Sie in dem Absatz, dessen Typ den zu ändernden Einträgen entspricht, das Leerzeichen zwischen den Bausteinen <$AbsText> und <$SeiteNum> aus und drücken Sie die Tabulatortaste.

    3. Ändern Sie das Absatzformat der Einträge, indem Sie einen Tabulatorstopp an der Stelle einfügen, an der die Seitennummern ausgerichtet werden sollen (siehe Ändern von Tabulatorstopps). Nach Wunsch können Sie Führungspunkte in das Format aufnehmen. Aktualisieren Sie dann die Absatzformate, sodass die Änderungen verfügbar sind, wenn Sie die Liste das nächste Mal generieren. Weitere Informationen finden Sie unter Definieren und Aktualisieren von Formaten.

So verwenden Sie Tabulatoren und Führungspunkte in einem Index:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für den Index enthält.

    2. Wählen Sie im Absatz für das Trennzeichenformat das Leerzeichen vor der Nummer 1 aus und drücken Sie die Tabulatortaste.

    3. Ändern Sie das Absatzformat für alle Indexebenen, indem Sie einen Tabulatorstopp an der Stelle einfügen, an der die Seitennummern ausgerichtet werden sollen (siehe Ändern von Tabulatorstopps). Nach Wunsch können Sie Führungspunkte in die Formate aufnehmen. Aktualisieren Sie anschließend die Absatzformate aller Einträge auf jeder Indexebene, damit die Änderungen bei der nächsten Generierung des Index verfügbar sind. Weitere Informationen finden Sie unter Definieren und Aktualisieren von Formaten.


Inhaltsverzeichnisse und Indizes / Formatieren von Listen und Indizes

Umstellen der Informationen in Listeneinträgen

Sie können die Reihenfolge festlegen, in der die Bestandteile eines Listeneintrags angezeigt werden. So können Sie z. B. angeben, dass zuerst die Seitennummer und dann der Absatztext aufgeführt werden.

So stellen Sie die Informationen in Listeneinträgen um:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für das Inhaltsverzeichnis oder die Liste enthält.

    2. Ordnen Sie die Bausteine neu an. Wenn die Seitennummer z. B. vor dem Absatztext erscheinen soll, ordnen Sie die Bausteine wie folgt an: <$SeiteNum> <$AbsText>.


Inhaltsverzeichnisse und Indizes

Ändern der Sortierfolge für Indizes

Indizes werden so sortiert, dass spezielle Symbole vor Nummern und Buchstaben angezeigt werden. Standardmäßig werden einige Interpunktionszeichen ignoriert und die Buchstaben dem deutschen Alphabet entsprechend sortiert.

Hinweis: Beim Sortieren von Indizes in mehrsprachigen Dokumenten, werden Symbolen auf der Basis des Unicode-Sortierfolgenalgorithmus (Unicode Collation Algorithm – UCA) des Unicode-Standards zur Textcodierung sortiert.

Sie können diese Standardsortierfolge für Indexeinträge ändern und die Buchstaben z. B. nach dem Alphabet einer anderen Sprache sortieren. Außerdem können Sie festlegen, ob Einträge im Index buchstaben- oder wortweise sortiert werden.

Buchstabenweise Sortierung | Wortweise Sortierung
Schriftbild Schrift Helvetica Schriftstil Schrift Times | Schrift Helvetica Schrift Times Schriftbild Schriftstil

Sie können die Sortierfolge ändern, indem Sie den Inhalt der Absätze "Ignorieren" und "Sortierfolge" im speziellen Textfluss auf der Referenzseite des Index bearbeiten. Informationen hierzu finden Sie unter Bearbeiten von speziellen Textflüssen für Listen und Indizes und in den folgenden Abschnitten.


Inhaltsverzeichnisse und Indizes / Ändern der Sortierfolge für Indizes

Festlegen der Zeichen, die ignoriert werden sollen

Standardmäßig ignoriert FrameMaker beim Sortieren von Indexeinträgen Bindestriche, umbruchgeschützte Bindestriche sowie n- und m-Bindestriche. Sie können auch festlegen, dass andere Zeichen ignoriert werden sollen, z. B. Unterstriche, Punkte, eckige oder geschweifte Klammern und Anführungszeichen.

Absatztyp "Ignorieren" mit hinzugefügten Zeichen

So geben Sie die Zeichen an, die bei der Sortierung eines Index ignoriert werden sollen:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für den Index enthält.

    2. Bearbeiten Sie den Absatz "Ignorieren".

Hinweis: Wenn Sie mit japanischen Schriften arbeiten, sollten Sie das Zeichen Chouon ( [image] ) in den Absatz "Ignorieren" aufnehmen. Das Zeichen wird im Japanischen normalerweise für die Dehnung des nachfolgenden Vokals verwendet und sollte daher keinen Einfluss auf die Sortierung haben.

So nehmen Sie statt einer wortweisen eine buchstabenweise Sortierung vor:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für den Index enthält.

    2. Fügen Sie am Beginn des Absatzes "Ignorieren" im speziellen Textfluss des Index ein Leerzeichen ein. (Das Leerzeichen darf nicht am Ende des Absatzes stehen.)


Inhaltsverzeichnisse und Indizes / Ändern der Sortierfolge für Indizes

Festlegen der Sortierfolge

Der Absatz "Sortierfolge" im speziellen Textfluss enthält Bausteine, die die Sortierfolge der Zeichen in einem Index steuern.

Absatz "Sortierfolge"

Jede Sortierfolge stellt verschiedene Zeichen in einer bestimmten Reihenfolge dar. Die folgende Tabelle enthält die Sortierfolge für amerikanisches Englisch. Für andere Sprachen weicht die alphabetische Sortierfolge leicht ab.

Baustein | Zeichensortierung
<$numerics> | 0 1 2 3 4 5 6 7 8 9
<$alphabetics> | A Á À Â Ä Ã Å a á à â ä ã å ª B b C Ç c ç D d E É È Ê Ë e é è ê ë F f Gg H h I Í Ì Î Ï i í ì î ï J j K k L l M m N Ñ n ñ O Ó Ò Ô Ö Õ Ø o ó ò ô ö õ ø º P p Q q R r S s T t U Ú Ù Û Ü u ú ù û ü V v W w X x Y y ÿ Z z
<$symbols> | Alle anderen Zeichen in ASCII-Reihenfolge

So sortieren Sie Symbole, Ziffern oder andere Zeichen an einer anderen Position im Index ein:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für den Index enthält.

    2. Ordnen Sie im speziellen Textfluss die Bausteine im Absatz "Sortierfolge" neu an. Wenn die Symbole nicht am Anfang, sondern am Ende des Index stehen sollen, ordnen Sie die Bausteine folgendermaßen an: <$numerics><$alphabetics><$symbols>

So definieren Sie eine spezielle Sortierfolge:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für den Index enthält.

    2. Ersetzen Sie einen Baustein im Absatz "Sortierfolge" durch die einzelnen Zeichen in der Reihenfolge, in der sie sortiert werden sollen. Beachten Sie beim Festlegen einer neuen Sortierfolge die folgenden Regeln:

    Wenn Sie <$alphabetics> durch einzelne Zeichen ersetzen, trennen Sie die Buchstabengruppen durch je ein Leerzeichen. (Buchstabengruppen, z. B. F f , sind Zeichen, die wie ein einzelnes Zeichen sortiert werden, es sei denn, sie sind die einzigen Zeichen, die sich im sortierten Text unterscheiden. In diesem Fall erscheint das erste Zeichen in der Zeichenfolge zuerst.)

    Wenn Sie <$symbols> durch einzelne Zeichen ersetzen, setzen Sie einen umgekehrten Schrägstrich vor die spitzen Klammern ( < > ).

    Drücken Sie am Zeilenende nicht die Eingabetaste. FrameMaker bricht die Zeichen automatisch von Zeile zu Zeile um.

    Um festzulegen, dass ein Buchstabenpaar wie ein einzelnes Zeichen sortiert werden soll, geben Sie das Paar in spitzen Klammern (< >) an, z. B. C Ç c ç<CH><Ch><ch>. In diesem Beispiel befinden sich alle Buchstaben oder Buchstabenpaare in derselben Buchstabengruppe (Buchstabe C ). Das Buchstabenpaar CH wird nach dem Buchstaben C sortiert. Buchstabenpaare aus Großbuchstaben werden vor solchen aus Kleinbuchstaben sortiert.


Inhaltsverzeichnisse und Indizes / Ändern der Sortierfolge für Indizes

Erläuterung der japanischen Sortierfolge

In Dokumenten, die die japanische Schrift verwenden, ist der Baustein <$kana> enthalten, der die Sortierfolge des japanischen kana (hiragana und katakana) steuert.

Baustein | Zeichensortierung
<$kana> |

Einzelbyte-katakana (halbe Breite) werden bei der Sortierung der generierten Datei zu Doppelbyte-katakana. Die Sortierfolge von kanji wird durch seine kana-Aussprache (yomigana) festgelegt, wie in Festlegen der Sortierfolge in Indizes dargestellt. Daher steuern die <$kana> -Bausteine auch die Sortierfolge der meisten kanji.

Die Sortierfolge von kanji ohne yomigana und der japanischen Symbole (numerische Doppelbyte-Zeichen und lateinische Buchstaben) ist nicht standardmäßig im <$kana>-Baustein enthalten. Stattdessen wird kanji nach dem Codewert sortiert und an Zeichen angefügt, die nach <$kana> sortiert werden.

Wenn Sie kanji ohne yomigana und japanische Symbole anders sortieren möchten, fügen Sie diese Zeichen zum Baustein <$numerics>, <$alphabetics> oder <$kana> hinzu. So können Sie dem Baustein <$symbols> japanische Doppelbyte-Zeichen hinzufügen.


Inhaltsverzeichnisse und Indizes

Arbeiten mit Gruppentiteln in Indizes

Indexeinträge werden zunächst unter jeweils einem Buchstaben gruppiert: alle Wörter, die mit A beginnen, alle Wörter, die mit B beginnen, usw., wobei der Großbuchstabe als Gruppentitel dient. Wenn der Index nicht sehr umfangreich ist oder unter einigen Buchstaben (wie X, Y oder Z) nur wenige Einträge stehen, können Sie die Buchstaben anders gruppieren und die Gruppentitel entsprechend ändern.

FrameMaker fügt Gruppentitel wie Indexeinträge ein, verwendet jedoch ein anderes Absatzformat. Dabei werden die Kennungen und Sortierpositionen verwendet, die Sie im speziellen Textfluss im Absatz "Gruppentitel" eingeben.

Bearbeiteter Absatztyp "Gruppentitel" auf der IX-Referenzseite
A: Sortierinformationen B: Gruppentitel

Ergebnis im Index

So ändern Sie Gruppen und Gruppentitel:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für den Index enthält.

    2. Bearbeiten Sie im speziellen Textfluss den Absatz "Gruppentitel". Ändern Sie z. B. die Gruppentitel (die Zeichen zwischen Semikolons, mit Ausnahme von Text in eckigen Klammern) oder löschen Sie unerwünschte Gruppentitel. Geben Sie den Text in die eckigen Klammern ( [ ] ) ein, um anzugeben, wo die Gruppentitel eingefügt werden sollen.

Um z. B. alle Einträge, die mit V bis Z beginnen, in einer Gruppe unter dem Titel V einzusortieren, geben Sie an letzter Stelle im Absatz "Gruppentitel" folgenden Eintrag ein: V–Z[V].

Hinweis: Die ersten beiden Einträge im Absatz "Gruppentitel" legen fest, welche Gruppentitel für Symbole und Nummern verwendet und an welcher Position diese Titel platziert werden. Die Titel können geändert werden. Wenn Sie jedoch die Sortierinformationen der beiden Gruppen ändern, erhalten Sie möglicherweise unerwartete Ergebnisse.

So erstellen Sie einen Index ohne Gruppentitel:

Bearbeiten Sie den Absatz "Gruppentitel" im speziellen Textfluss so, dass er folgendermaßen aussieht:

So erstellen Sie einen Index ohne Gruppentitel und ohne Abstand zwischen den einzelnen Eintragsgruppen:

Löschen Sie im speziellen Textfluss den gesamten Text im Absatz "Gruppentitel" mit Ausnahme des Absatzsymbols.

So ermöglichen Sie schnellen Zugriff auf die Gruppentitel in einem Hypertext-Dokument:

Generieren Sie für die Gruppentitel Registersymbole, auf die Sie zur Vereinfachung der Indexverwendung mit der Maus klicken können. Weitere Informationen hierzu finden Sie unter Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien.


Inhaltsverzeichnisse und Indizes

Arbeiten mit Inhaltsverzeichnissen in strukturierten Dokumenten

In FrameMaker werden Inhaltsverzeichnisse, Abbildungslisten und ähnliche Listen aus dem Text in bestimmten Elementen eines Dokuments erzeugt. Ein Index wird aus dem Text der Markenelemente generiert, die Sie in Dokumente einfügen.


Inhaltsverzeichnisse und Indizes / Arbeiten mit Inhaltsverzeichnissen in strukturierten Dokumenten

Vorbereiten von strukturierten Dokumenten für ein Inhaltsverzeichnis oder andere Elementlisten

Zum Erzeugen eines Inhaltsverzeichnisses oder einer anderen Elementliste wählen Sie die zu verwendenden Element-Tags aus. Zur Vermeidung von Problemen in den generierten Listen führen Sie im Quelldokument folgende Schritte aus:

    Stellen Sie sicher, dass die Element-Tags im Dokument richtig und einheitlich verwendet werden. Wenn sich Text nicht im richtigen Element-Tag befindet (z. B. eine Überschrift in einem Absatzelement statt in einem Überschriftenelement), wird er nicht in der Liste angezeigt.

    Gestalten Sie jede Einheit, die in der Liste enthalten sein soll, als einzelnen Absatz in einem Element. Wenn ein Element mehrere Absätze umfasst, wird nur der Text aus dem ersten Absatz in die Liste aufgenommen. Sie erzielen nicht die gewünschten Ergebnisse, wenn z. B. bei einer zweizeiligen Überschrift jede Zeile einen eigenen Absatz darstellt.

    Überprüfen Sie das Dokument, um sicherzustellen, dass es keine Strukturfehler enthält (siehe Überprüfen von Dokumenten).

Hinweis: Normalerweise erstellen Sie Referenzlisten, z. B. eine Liste mit Schriften oder ungelösten Querverweisen, nur für den eigenen Gebrauch während der Arbeit mit einem Dokument. Für eine solche Liste müssen Sie das Dokument nicht vorbereiten.


Inhaltsverzeichnisse und Indizes / Arbeiten mit Inhaltsverzeichnissen in strukturierten Dokumenten

Vorbereiten von strukturierten Dokumenten für eine Markenliste

Vor dem Generieren einer Markenliste müssen Sie die Marken in das Quelldokument einfügen. In der Regel werden Marken als Elemente eingefügt, sodass sie in der Struktur des Dokuments erscheinen.

Markenelement

Beim Einfügen der Marken geben Sie Text in die Marken ein, der dann in der generierten Liste angezeigt wird. Ein Teil dieses Textes wird auch in der Strukturansicht angezeigt.

Informationen zum Einfügen einer Marke, die kein Element darstellt, finden Sie unter Vorbereiten von Dokumenten für eine Markenliste.

So fügen Sie ein Markenelement für eine generierte Liste ein:

    1. Klicken Sie an die Stelle, an der Sie die Marke einfügen wollen.

    2. Wählen Sie aus dem Elementkatalog ein Markenelement aus und klicken Sie auf "Einfügen".

Sie können zum Einfügen von Elementen auch "Spezial > Marke" verwenden. Wenn mehrere Markenelemente verfügbar sind, wird ein Dialogfenster geöffnet, in dem Sie das gewünschte Element aus dem Aufklappmenü "Element-Tag" wählen können.

    3. Zum Ändern des Markentyps wählen Sie einen Typ aus dem Aufklappmenü "Markentyp" aus. Eine Änderung des Typs stellt keine irreguläre Formatzuweisung dar, auch wenn ein Typ für das Element festgelegt ist.

Sprechen Sie vor dem Ändern eines Markentyps mit Ihrem Entwickler. Das Dokument enthält möglicherweise ein Element für jeden benötigten Markentyp.

Für den Markentyp können Sie jeden vordefinierten Typ verwenden, mit Ausnahme von "Querverweis", "Bedingter Text", "Kopf-/Fußzeile $1" und "Kopf-/Fußzeile $2". Mitunter sind auch einige spezielle Typen verfügbar.

    4. Geben Sie den Text ein, der als Eintrag in der Liste enthalten sein soll. Sie können bis zu 255 Zeichen (127 japanische Zeichen) eingeben. Verwenden Sie zur Texteingabe die Tastatur oder alternative Methoden (siehe Hinzufügen von Indexmarken).

    5. Klicken Sie auf "Neue Marke". Wenn die Steuerzeichen eingeblendet sind, wird im Dokumentfenster ein Markensymbol [image] angezeigt. In der Strukturansicht wird ein Elementrechteck für die Marke angezeigt und daneben ein Textausschnitt, der den Anfang des Markentextes darstellt.

    6. Geben Sie im Dialogfenster "Attribute für neues Element" Attributwerte für das Markenelement ein und klicken Sie auf "Element einfügen" (siehe Eingeben von Attributwerten beim Einfügen von Elementen).

Wenn an der gewünschten Position kein Markenelement verfügbar ist, verwenden Sie möglicherweise ein ungültiges Element. Informieren Sie sich nach Einfügen des Elements bei Ihrem Entwickler darüber, wie sich das Element an dieser Position in ein gültiges Element umwandeln lässt.

So verwenden Sie ein ungültiges Markenelement:

Fügen Sie ein Element ein, das an einer anderen Stelle im Dokument gültig ist. Entweder fügen Sie das Element an einer gültigen Stelle ein und verschieben es anschließend, oder Sie verwenden die Einstellung "Alle Elemente" (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument), um das Element überall im Dokument verfügbar zu machen, und fügen das Element dann an der gewünschten Stelle ein.


Inhaltsverzeichnisse und Indizes

Generieren von Inhaltsverzeichnissen und anderen Listen in strukturierten Dokumenten

Nachdem Sie ein Quelldokument für ein Inhaltsverzeichnis oder eine andere Liste vorbereitet haben, können Sie die Liste generieren. Sie können eine Liste aus einem Buch oder einem einzelnen Dokument generieren.

Hinweis: Generierte Listen sind zunächst unstrukturiert; Sie können die Liste jedoch strukturieren. Häufig wird eine Liste im Verlauf von Korrekturen mehrfach neu generiert. Dabei verliert sie jedes Mal ihre Struktur. Warten Sie daher mit dem Strukturieren, bis die Liste in ihrer endgültigen Version vorliegt.

Die Schritte für das Generieren von Inhaltsverzeichnissen und Listen in strukturierten Dokumenten sind zwar dieselben wie für nicht strukturierte Dokumente (siehe Generieren von Inhaltsverzeichnissen und anderen Listen), darüber hinaus sind jedoch folgende Punkte zu berücksichtigen:

    Die Einheiten in der Auswahlliste können, je nach dem zu generierenden Listentyp, unterschiedlich sein. Für ein Inhaltsverzeichnis werden z. B. die Element- und Absatztypen im Quelldokument angezeigt. (Absatztypen erscheinen nach Element-Tags und werden durch ein Absatzsymbol [image] eingeleitet.) Für eine Referenzliste werden die verfügbaren Referenztypen angezeigt.

    Einige Element-Tags können über Kontextbezeichnungen verfügen, die Informationen über die Position des Elements in der Struktur liefern. Wenn z. B. Abschnittelemente in andere Abschnittelemente eingebettet sind, könnten die Kontextbezeichnungen angeben, ob die Elemente Abschnitte erster, zweiter oder dritter Ebene sind.

Kontextbezeichnungen

    Wenn ein Element Kontextbezeichnungen verwendet, erscheint für Elemente, die nicht durch Kontextbezeichnungen beschrieben werden, in der Auswahlliste der Eintrag <keine Bezeichnung>. Im obigen Beispiel steht für Abschnittelemente der vierten oder einer niedrigeren Ebene im Dokument "Abschnitt(<keine Bezeichnung>)".

    Bei Elementen mit mehreren Absätzen wird nur der Text des ersten Absatzes in der generierten Liste angezeigt. Beispielsweise erscheint der erste Absatz eines Abschnittelements (meist die Überschrift) in der Liste.

    Beim ersten Generieren einer Liste (ohne Schablone) übernimmt die Liste das Seitenlayout (Vorgabeseiten) des ersten nicht generierten Dokuments im Buch, wodurch alle Einträge dasselbe Aussehen aufweisen. Die Liste enthält auch Elementdefinitionen aus dem Quelldokument.


Inhaltsverzeichnisse und Indizes

Aktualisieren und Bearbeiten von Listen in strukturierten Dokumenten

Zur Bearbeitung von Listeneinträgen bearbeiten Sie die entsprechenden Elemente im Quelldokument und generieren dann die Liste erneut. Falls Sie die Einträge direkt in der Liste bearbeiten, gehen die Änderungen bei der nächsten Generierung der Liste verloren.

Die Struktur von generierten Listen geht bei der nächsten Generierung verloren. Fügen Sie erst eine Struktur hinzu, wenn die endgültige Version der Liste vorliegt.

Informationen zum Aktualisieren von Listen finden Sie unter Aktualisieren und Bearbeiten von Inhaltsverzeichnissen und Listen.


Inhaltsverzeichnisse und Indizes / Aktualisieren und Bearbeiten von Listen in strukturierten Dokumenten

Ermitteln der Quellen von Listeneinträgen in strukturierten Dokumenten

Um Änderungen an einem Eintrag vorzunehmen, verfolgen Sie den Eintrag bis zum entsprechenden Element im Quelldokument zurück.

Am schnellsten gelangen Sie über die Hypertext-Verbindung des Eintrags in der generierten Datei an die Quelle eines Listeneintrags, wo das Element angezeigt und ausgewählt werden kann. Sie können auch den Befehl "Suchen/Ändern" verwenden oder das Element in der Strukturansicht anhand des Elementrechtecks auswählen, um zu dem Element zu gelangen.

So gelangen Sie über eine Verknüpfung zur Quelle eines Eintrags:

    1. Wenn Sie beim Generieren der Liste "Hypertext-Verbindungen anlegen" nicht aktiviert haben, holen Sie dies nach und generieren die Liste neu.

    2. Wenn Sie ein Markenelement überarbeiten, wählen Sie "Spezial > Marke", um den Markentext anzuzeigen.

    3. Gehen Sie entsprechend dem Betriebssystem in der generierten Liste wie folgt vor:

    (Windows) Drücken Sie die Tastenkombination Strg+Alt und klicken Sie auf einen Eintrag.

    (UNIX) Halten Sie die Control-Taste gedrückt und klicken Sie mit der rechten Maustaste auf einen Eintrag.

FrameMaker öffnet das Quelldokument auf der Seite, die das Element enthält und wählt es aus. Wenn das Element eine Marke ist, wird der Markentext im Dialogfenster "Marke" angezeigt.

So gelangen Sie mithilfe von "Suchen/Ändern" zur Quelle eines Eintrags:

    1. Wenn Sie ein Markenelement überarbeiten, wählen Sie "Spezial > Marke", um den Markentext anzuzeigen.

    2. Wählen Sie im Quelldokument (nicht in der generierten Liste) "Bearbeiten > Suchen/Ändern".

    3. Wählen Sie aus dem Aufklappmenü "Suchen" den Eintrag "Element" aus, geben Sie den Typ des gesuchten Elements ein und klicken Sie auf "Zuweisen".

    4. Klicken Sie auf "Suchen". FrameMaker wechselt zu der Seite, die das Element enthält und wählt es aus.

Hinweis: Sobald ein Markenelement ausgewählt ist, wird der Markentext im Dialogfenster "Marke" angezeigt. Klicken Sie im Dialogfenster "Suchen/Ändern" nicht auf "Ändern", um den Markentext zu ändern. In diesem Fall ersetzt FrameMaker die gesamte Marke. Ändern Sie stattdessen den Text im Dialogfenster "Marke" und klicken Sie dann auf "Marke bearbeiten".


Inhaltsverzeichnisse und Indizes / Aktualisieren und Bearbeiten von Listen in strukturierten Dokumenten

Bearbeiten und Löschen von Listeneinträgen in strukturierten Dokumenten

Sie überarbeiten die Einträge in einer Liste, indem Sie die entsprechenden Elemente im Quelldokument ändern.

So bearbeiten Sie ein Markenelement:

Wählen Sie das Element aus, ändern Sie den Text im Dialogfenster "Marke" und klicken Sie auf "Marke bearbeiten".

So löschen Sie ein Element:

Wählen Sie das Element im Quelldokument aus und drücken Sie die Entf-Taste.


Inhaltsverzeichnisse und Indizes

Hinzufügen von Indexmarken-Elementen in strukturierten Dokumenten

Vor dem Generieren eines Index müssen Sie in das Quelldokument Indexmarken einfügen. In der Regel werden Marken als Elemente eingefügt, sodass sie in der Struktur des Dokuments erscheinen.

Indexmarken-Element

Beim Einfügen von Marken geben Sie Text ein, der die Strukturierung der Quellinformationen im Index beschreibt.

Markentext

Informationen zum Einfügen einer Marke, die kein Element darstellt, finden Sie unter Hinzufügen von Indexmarken.

So fügen Sie ein Indexmarken-Element ein:

    1. Klicken Sie an die Stelle, an der Sie die Marke einfügen wollen.

    2. Wählen Sie aus dem Elementkatalog ein Markenelement aus und klicken Sie auf "Einfügen".

Sie können zum Einfügen von Elementen auch "Spezial > Marke" verwenden. Wenn mehrere Elemente verfügbar sind, wählen Sie das gewünschte Element aus dem Aufklappmenü "Element-Tag" des Dialogfensters aus.

    3. Zum Ändern des Markentyps wählen Sie einen Typ aus dem Aufklappmenü "Markentyp" aus. Eine Änderung des Typs stellt keine irreguläre Formatzuweisung dar, auch wenn ein Typ für das Element festgelegt ist.

Sprechen Sie vor dem Ändern eines Markentyps mit Ihrem Entwickler. Das Dokument enthält möglicherweise ein Element für jeden benötigten Markentyp.

Sie können aus den vordefinierten Markentypen Index, Thema und Autor einen Index generieren. Gegebenenfalls sind auch einige spezielle Typen verfügbar.

    4. Geben Sie den Text für den Indexeintrag ein. Sie können bis zu 255 Zeichen (127 japanische Zeichen) eingeben. Sie können Form und Position des Indexeintrags auch mithilfe der folgenden Bausteine im Markentext steuern.

    Baustein | Bedeutung
: (Doppelpunkt) | Trennt Ebenen in einem Eintrag.
; (Semikolon) | Trennt Einträge in einer Marke.
[ ] (eckige Klammern) | Legt eine bestimmte Sortierfolge für den Eintrag fest.
<$startrange> | Kennzeichnet den Anfang eines Seitenbereichs.
<$endrange> | Kennzeichnet das Ende eines Seitenbereichs.
<$nopage> | Unterdrückt die Seitennummer im Eintrag.
<$singlepage> | Stellt in einer Marke mit mehreren Einträgen die Seitennummer eines Eintrags wieder her, der auf einen <$nopage>-Baustein folgt.
Zeichentyp zwischen spitzen Klammern ( < > ) | Ändert das Zeichenformat (z. B. <Betonung>).
<Absatzstandardschrift> | Stellt die Standardschrift des Absatzes wieder her.

Hinweis: Um einen umgekehrten Schrägstrich oder eines der Sonderzeichen, die in diesen Bausteinen verwendet werden (Klammer, Doppelpunkt, Semikolon oder spitze Klammer), als normales Zeichen einzugeben, setzen Sie einen umgekehrten Schrägstrich ( \ ) davor.

    5. Klicken Sie auf "Neue Marke". Wenn die Steuerzeichen eingeblendet sind, wird im Dokumentfenster ein Markensymbol [image] angezeigt. In der Strukturansicht wird ein Elementrechteck für die Marke angezeigt und daneben ein Textausschnitt, der den Anfang des Markentextes darstellt.

    6. Geben Sie im Dialogfenster "Attribute für neues Element" Attributwerte für das Markenelement ein und klicken Sie auf "Element einfügen" (siehe Eingeben von Attributwerten beim Einfügen von Elementen).

Wenn an der gewünschten Position kein Markenelement verfügbar ist, verwenden Sie möglicherweise ein ungültiges Element. Informieren Sie sich nach Einfügen des Elements bei Ihrem Entwickler darüber, wie sich das Element an dieser Position in ein gültiges Element umwandeln lässt.

So verwenden Sie ein ungültiges Markenelement in Indizes:

Fügen Sie ein Element ein, das an einer anderen Stelle im Dokument gültig ist. Entweder fügen Sie das Element an einer gültigen Stelle ein und verschieben es anschließend, oder Sie verwenden die Einstellung "Alle Elemente" (siehe Eingeben oder Bearbeiten von Attributwerten für bereits im Dokument vorhandene Elemente), um das Element überall im Dokument verfügbar zu machen, und fügen das Element dann an der gewünschten Stelle ein.

So legen Sie Markentext fest, ohne ihn über die Tastatur einzugeben:

Führen Sie eine der folgenden Aktionen aus:

    Um ein Wort im Dokument als Indexeintrag zu verwenden, fügen Sie ein leeres Markenelement (ohne Text) am Anfang des Wortes ein. Beim Generieren des Index wird der Text rechts neben der Marke als Text des Eintrags verwendet.

    Um einen Textbereich im Dokument als Indexeintrag zu verwenden, wählen Sie diesen vor dem Einfügen des Markenelements aus. Wenn das ausgewählte Wort oder die ausgewählte Wortverbindung keine Marken enthält, wird das Wort oder die Wortverbindung automatisch im Textfeld "Markentext" angezeigt.


Inhaltsverzeichnisse und Indizes

Formatieren von Listen und Indizes in strukturierten Dokumenten

Generierte Listen oder Indizes in strukturierten Dokumenten haben dieselben Formatierungseinstellungen wie unstrukturierte Dokumente:

    Seitenlayout, z. B. laufende Kopf- und Fußzeilen und das Layout von Textspalten.

    Kataloge mit Absatz- und Zeichenformaten für Text in den Einträgen.

    Einen speziellen Textfluss auf einer Referenzseite, der viele Eigenschaften der Einträge vorgibt (z. B. Tabulatoren und Tabulatorführung, Trennzeichen für Seitenzahlen, die Sortierreihenfolge für die Indexeinträge) und festlegt, welcher Text aus den Quellelementen angezeigt wird.

In der Regel werden diese Eigenschaften in einer speziellen Schablone für Listen und Indizes gespeichert. Wenn Sie über eine solche Schablone verfügen, kann FrameMaker sie beim ersten Generieren der Datei auf eine Liste oder einen Index anwenden.

Wenn Sie beim Generieren von Listen oder Indizes keine Schablone verwenden, erhält die generierte Datei ihre Formatierungseinstellungen vom Quelldokument (mit einigen zusätzlichen Katalogformaten). Nach dem Generieren können Sie entweder die gewünschten Eigenschaften aus der Schablone importieren oder Formatierungen in der generierten Datei manuell ändern.

Solange die generierte Datei den von FrameMaker zugewiesenen Dateinamen trägt und sich in demselben Ordner wie das Quelldokument befindet, behält die Datei beim Generieren ihre Formatierungseigenschaften bei.

Weitere Informationen zum manuellen Ändern der Formatierungseinstellungen finden Sie unter Formatieren von Listen und Indizes.

So verwenden Sie beim erstmaligen Generieren einer Liste oder eines Index eine Schablone:

    1. Kopieren Sie die Schablone in den Ordner mit dem Quelldokument. Verwenden Sie denselben Dateinamen, den Sie auch für die Liste oder den Index verwendet haben, z. B. "Kap1IVZ.fm".

    2. Generieren Sie die Liste oder den Index. Die generierte Datei ersetzt die Schablone und übernimmt deren Formatierungseinstellungen.

So weisen Sie nach dem ersten Generieren Einstellungen aus einer Schablone zu:

    1. Importieren Sie die gewünschten Formatierungseigenschaften (siehe Importieren und Aktualisieren von Formaten).

    2. Generieren Sie dann die Liste bzw. den Index neu, damit alle Änderungen im speziellen Textfluss der generierten Datei reflektiert werden.


Inhaltsverzeichnisse und Indizes

Fehlerbehebung in Inhaltsverzeichnissen und Listen von strukturierten Dokumenten

Kleine Probleme im Quelldokument können entsprechende Probleme in der generierten Liste hervorrufen. Falsche Element-Tags können z. B. bewirken, dass ein zusätzlicher Eintrag in der Liste angezeigt wird oder ein Eintrag fehlt. Bei leeren Elementen wird in die Liste eine Leerzeile eingefügt.

Probleme in einem Index
A: Zusätzliche Zeile B: Gehört nicht in die Liste

Die folgenden Informationen beschreiben typische Probleme und mögliche Lösungen.

Hinweis: Weitere Informationen zu den hier beschriebenen Lösungen, die sich auf Katalogformate oder den speziellen Textfluss auf einer Referenzseite auswirken, erhalten Sie vom Anwendungsentwickler.

Zusätzliche Einträge oder Zeilen

Falsche Tags im Quelldokument können zur Folge haben, dass zusätzliche Absätze in der generierten Liste angezeigt werden. Gehen Sie in so einem Fall wie folgt vor:

    Wenn die Liste einen Eintrag enthält, der dort nicht hingehört, überprüfen Sie das entsprechende Element im Quelldokument und wandeln Sie das Element in einen Typ um, der nicht in der Liste enthalten ist.

    Wenn die Liste eine Leerzeile enthält, die nur eine Seitenzahl aufweist und ein leeres Element im Quelldokument vorhanden ist, löschen Sie dieses. Wenn Sie zusätzliche Absatzabstände im Quelldokument benötigen, verwenden Sie anstelle eines leeren Elements ein entsprechend definiertes Element.

Fehlende Einträge

Wenn Einträge zwar im Quelldokument, jedoch nicht in der Liste erscheinen, führen Sie einen der folgenden Schritte aus:

    Überprüfen Sie, wenn alle Einträge eines bestimmten Element-Tags fehlen, ob die Auswahlliste "Übernahme" im Dialogfenster "Einstellungen" die korrekten Einheiten enthält.

    Wenn gelegentlich ein Eintrag fehlt, prüfen Sie den Typ des entsprechenden Elements im Quelldokument. Bei einem falschen Element-Tag sind die Informationen nicht in der Liste enthalten.

Unvollständige Einträge

Von Elementen mit mehreren Absätzen enthält die Liste nur den Eintrag des ersten Absatzes. Eine aus mehreren Zeilen bestehende Überschrift im Quelldokument kann problematisch sein, wenn jede Zeile einen einzelnen Absatz darstellt.

Vermeiden Sie aus diesem Grund erzwungene Zeilenenden in Überschriften, die in generierte Inhaltsverzeichnisse aufgenommen werden. Um eine Überschrift zu umbrechen und dennoch den gesamten Text in die Liste einfließen zu lassen, erzwingen Sie einen Umbruch mithilfe umbruchgeschützter Leerzeichen. Sie können auch den rechten Einzug für die Überschrift ändern, um einen Umbruch zu erzwingen. Bei einer zentrierten Überschrift können Sie den rechten und den linken Einzug ändern, was jedoch eine irreguläre Formatzuweisung darstellt.

Wichtig: Denken Sie daran, dass durch diese Techniken sowohl Absatzformate als auch Elementdefinitionen überschrieben werden. Beim Importieren von Formaten oder Elementdefinitionen sowie beim Ändern des Elementkontexts durch Bearbeitung anderer Teile des strukturierten Dokuments gehen sie möglicherweise verloren.

Fehlerhafte Zeilenumbrüche

Fehlerhafte Zeilenumbrüche in der Liste oder im Quelldokument können Informationen trennen, die in der Liste zusammengehören. Führen Sie in so einem Fall eine der folgenden Aktionen aus:

    Ändern Sie die Zeichen, nach denen FrameMaker Zeilenumbrüche zulässt. Normalerweise lässt FrameMaker Zeilenumbrüche nach einem n-Bindestrich (–) zu. Um Umbrüche nach einem n-Bindestrich zu unterbinden, wählen Sie "Format > Dokument > Textoptionen".

    Verwenden Sie im speziellen Textfluss auf der Referenzseite zwischen Text und Seitennummer der Einträge stets umbruchgeschützte Leerzeichen, damit eine Seitennummer keine eigene Zeile in der Liste einnimmt.

Fehlende Titel

Ein eingegebener Titel kann bei erneutem Generieren verloren gehen, es sei denn, Sie weisen dem Titel ein Absatzformat zu, wie unter Hinzufügen von Titeln oder anderem statischen Text in Listen und Indizes beschrieben.

Fehlende Formatierungen

Führen Sie die folgenden Schritte aus, wenn die Formatänderungen nach erneuter Generierung nicht mehr vorhanden sind:

    Wenn Sie den Dateinamen oder Speicherort der Liste geändert haben, machen Sie diese Änderungen rückgängig. FrameMaker findet Formatänderungen nur, wenn Sie die Liste in demselben Ordner ablegen wie die Quelldatei und den von FrameMaker zugewiesenen Dateinamen verwenden.

    Um Änderungen der Absatz- und Zeichenformate zu erhalten, speichern Sie diese Änderungen im Absatzformat- oder Zeichenformat-Katalog der Liste. Dadurch stehen sie beim nächsten Generieren der Liste zur Verfügung.

    Wenn Sie andere Änderungen beibehalten wollen, nehmen Sie diese im speziellen Textfluss auf der Referenzseite vor.


Inhaltsverzeichnisse und Indizes

Einbetten von Inhaltsverzeichnissen in strukturierte Dokumente

Ein Inhaltsverzeichnis ist in der Regel eine eigenständige Datei, die automatisch von FrameMaker erzeugt wurde. Wenn Sie jedoch ein kurzes Inhaltsverzeichnis nicht in einer separaten Datei führen, sondern am Anfang des Quelldokuments einfügen wollen, können Sie ein solches Inhaltsverzeichnis mit Querverweisen erstellen.

Unter Umständen wurde bereits ein spezielles Querverweis-Element für Ihr Dokument definiert.

Auf Querverweisen basierende Inhaltsverzeichnisse aktualisiert FrameMaker nicht automatisch. Wenn Sie z. B. die Reihenfolge der Abschnitte im Dokument ändern oder Abschnitte löschen, müssen Sie die Einträge im Inhaltsverzeichnis selbst neu anordnen bzw. löschen.

Sie können auch ein separates Inhaltsverzeichnis erstellen und die generierte Datei dann an den Anfang des Quelldokuments importieren. Der Texteinschub mit dem Inhaltsverzeichnis wird dann bei auftretenden Änderungen automatisch aktualisiert.

So betten Sie ein Inhaltsverzeichnis über Querverweise in ein Dokument ein:

Fügen Sie für jede Einheit, die in das Inhaltsverzeichnis aufgenommen werden soll, ein für diesen Zweck definiertes Querverweis-Element ein (siehe Einfügen elementbasierter Querverweise in strukturierte Dokumente). Das Dokument kann auch Absatzelemente enthalten, die zur Formatierung eines Inhaltsverzeichnisses definiert wurden. Wenden Sie sich zwecks weiterer Informationen an den Anwendungsentwickler.

Hinweis: Stellen Sie sicher, dass die Reihenfolge der Inhaltsverzeichniseinträge die Reihenfolge der Quellelemente im Dokument widerspiegelt. Die Reihenfolge wird im Gegensatz zu generierten Inhaltsverzeichnissen nicht automatisch aktualisiert.

So halten Sie ein auf Querverweisen basierendes Inhaltsverzeichnis auf dem aktuellen Stand:

Führen Sie folgende Schritte durch:

    Wenn Sie die Reihenfolge der Quellelemente bei der Bearbeitung des Dokuments ändern, ordnen Sie die Querverweise neu an, sodass sie dieselbe Reihenfolge aufweisen wie die Quellelemente. Aktualisieren Sie danach die Querverweise (siehe Manuelles Aktualisieren von Querverweisen).

    Entfernen Sie beim Löschen eines Quellelements auch den entsprechenden Querverweis. Andernfalls wird der Eintrag in der Tabelle zu einem ungelösten Querverweis.

So betten Sie ein Inhaltsverzeichnis als Texteinschub in ein Dokument ein:

    1. Generieren Sie ein Inhaltsverzeichnis auf die übliche Weise (siehe Generieren von Inhaltsverzeichnissen und anderen Listen).

    2. Importieren Sie das Inhaltsverzeichnis in das Quelldokument. Weitere Informationen finden Sie unter Textimport mit dem Befehl "Importieren".


Bücher

Buchdateien

Erstellen von Büchern

Arbeiten mit Dateien in einem Buchfenster

Festlegen der Nummerierung von Dokumenten und Seiten

Einfügen von Nummerierungen in Ihre Dokumente

Ändern des Formats von Dateien eines Buches

Verwenden von Befehlen, die sich auf das ganze Buch beziehen

Aktualisieren von Büchern

Vergleichen von Büchern

Problembehebung in Büchern

Strukturierte Buchdateien

Generieren und Aktualisieren von strukturierten Büchern

Arbeiten mit der Buchstruktur


Bücher

Buchdateien

Sie können Einzeldokumente zu einem FrameMaker-Buch zusammenfassen. Für die in einem Buch gruppierten Dokumente kann dann ein gemeinsames Inhaltsverzeichnis oder ein gemeinsamer Index angelegt werden. Außerdem verringert sich so der Arbeitsaufwand für das Drucken, Nummerieren, Anlegen von Querverweisen und Formatieren der Dokumente.

Eine Buchdatei ist eine spezielle FrameMaker-Datei, die mehrere Dateien miteinander verbindet, sodass diese als eine Einheit bearbeitet werden können. Sie können beispielsweise Seiten und Absätze kontinuierlich über alle Dateien hinweg nummerieren und Querverweise gleichzeitig aktualisieren.

In einer Buchdatei sind die Dateinamen der Dokumente enthalten, aus denen sich ein Buch zusammensetzt. Dazu können neben Kapiteln und Anhängen auch generierte Dateien wie das Inhaltsverzeichnis und der Index gehören. Die Buchdatei enthält auch die Seitennummerierung und die Nummerierungseinstellung für alle Dateien im Buch.

Jede Datei in einem Buch kann ihr eigenes Nummerierungssystem haben. Sie können beispielsweise die Seitennummerierung mit i auf der Titelseite beginnen, dann das erste Kapitel mit 1 anfangen und fortlaufend alle folgenden Kapitel nummerieren. Sie können auch eine Kapitel- oder Bandnummer in eine Seitennummer einfügen, z. B. Kapitel 2 in der Seitennummer 2-1.

Bei der Aktualisierung eines Buches generiert oder aktualisiert FrameMaker generierte Dateien und aktualisiert die Nummerierung der Dateien. Darüber hinaus passt FrameMaker die Querverweise an die neue Nummerierung an.


Bücher

Erstellen von Büchern

Wenn Sie ein Buch zusammenstellen, erzeugen Sie eine Buchdatei, die – in der richtigen Reihenfolge – alle Dateien im Buch auflistet.

Um die Übersicht über das Buch zu behalten, sollten Sie alle Einzeldateien eines Buches in einen Ordner legen und für jedes Kapitel ein separates FrameMaker-Dokument anlegen. (Um die Verarbeitungsgeschwindigkeit zu erhöhen, sollten Sie sehr lange Kapitel in mehrere Dateien aufteilen.)


Bücher / Erstellen von Büchern

Überblick über die Bucherstellung

Bucherstellung bezieht sich auf den Prozess, aus Einzelbestandteilen ein Buch zu erzeugen. Die meisten Komponenten, z. B. Vorwort, Kapitel und Anhänge, sind separate Dateien, bevor sie zu einem Buch zusammengefügt werden. Andere Komponenten, z. B. Inhaltsverzeichnis und Indizes, werden im Rahmen der Bucherstellung generiert.

So legen Sie ein Buch an:

    1. Erstellen Sie das Buch (siehe Erzeugen von Buchdateien).

    2. Fügen Sie alle Dokumente hinzu, die Sie im Buch benötigen (siehe Hinzufügen von Dateien zu einem Buch).

    3. Fügen Sie die Dateinamen für jede generierte Datei hinzu, die im Buch enthalten sein soll.

    4. Legen Sie die Band-, Kapitel-, Seiten- und Absatznummerierung fest (siehe Festlegen der Nummerierung von Dokumenten und Seiten).

    5. Aktualisieren Sie das Buch, um Inhaltsverzeichnis und Index zu erzeugen und die Nummerierung im Buch festzulegen. Nun stellt sich heraus, ob Fehler oder ungelöste Querverweise vorhanden sind (siehe Aktualisieren von Büchern).

    6. Beheben Sie alle Fehler (siehe Problembehebung in Büchern) und generieren und aktualisieren Sie das Buch erneut.

Hinweis: Bücher unterstützen den Unicode-Standard zur Textcodierung.


Bücher / Erstellen von Büchern

Erzeugen von Buchdateien

Sie können die Buchdatei aus jedem beliebigen Dokument erstellen, das in das Buch aufgenommen werden soll. Sobald eine Buchdatei angelegt ist, bietet FrameMaker spezielle Menübefehle an, um mit dem Buch zu arbeiten.

So legen Sie eine Buchdatei an:

    1. Öffnen Sie ein Dokument und wählen Sie dann "Datei > Neu > Buch". FrameMaker fragt, ob Sie das Dokument dem Buch hinzufügen möchten.

Hinweis: (UNIX) Wenn kein Dokument- oder Buchfenster geöffnet ist, können Sie ein neues Buch mit Esc d Umschalttaste+n erzeugen.

Ein neues Buchfenster mit dem Inhalt des Buches wird angezeigt.

Inhalt des neuen Buches wird in einem neuen Buchfenster angezeigt

    2. Wählen Sie "Datei > Buch sichern unter", um die Buchdatei zu speichern. Unter Windows wird beim Speichern die Erweiterung .book an den Dateinamen angehängt.


Bücher / Erstellen von Büchern

Hinzufügen von Dateien zu einem Buch

Sie können einem Buch zwei Arten von Dateien hinzufügen: Dokumente und generierte Dateien. Wenn Sie einem Buch eine Datei hinzufügen, werden Name und Verzeichnis der Datei zur Buchdatei hinzugefügt und eine Verknüpfung zwischen Datei und Buch erstellt. Wenn Sie die Datei im Buchfenster umbenennen, ändert FrameMaker den Dateinamen auf der Festplatte und aktualisiert Querverweise, Hypertext-Verbindungen und Texteinschübe. FrameMaker ist dadurch in der Lage, das Dokument oder die generierte Datei zu finden, wenn Sie Befehle im Buchfenster auf das Dokument anwenden. Bücher können auch Nicht-FrameMaker-Dokumente enthalten.

Im Buchfenster wird neben Dokumenten das Symbol [image] und neben generierten Dateien das Symbol [image] angezeigt.

Weitere Informationen zum Hinzufügen von generierten Dateien zu einem Buch finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen.

So fügen Sie einem Buch Dokumentdateien hinzu (Windows):

    1. Wählen Sie im Buchfenster "Hinzufügen > Dateien" oder klicken Sie auf [image] .

    2. Wählen Sie das Dokument oder die Dateien aus, die Sie dem Buch hinzufügen möchten (siehe Auswählen von Dateien in einem Buch), und klicken Sie dann auf "Einfügen".

Wählen Sie die Dateien, die Sie dem Buch hinzufügen möchten.

So fügen Sie einem Buch Dokumentdateien hinzu (UNIX):

    1. Wählen Sie im Buchfenster "Hinzufügen > Dateien" oder klicken Sie auf [image] .

    2. Wählen Sie die Dokumentdatei aus und klicken Sie auf "Einfügen". Das Dialogfenster "Dateien in Buch einfügen" wird erneut angezeigt.

    3. Fügen Sie weitere Dateien in das Buch ein. Wenn Sie alle Dateien eingefügt haben, klicken Sie auf "Zurück".

So ziehen Sie Dateien in ein Buch (Windows):

Ziehen Sie Dateien aus einem anderen Buchfenster oder einem Datei-Manager (z. B. Explorer oder Finder) in das Buchfenster.

Dateien mit Ziehen und Ablegen in das Buchfenster einfügen

So schalten Sie zwischen Dateinamen- und Textanzeige um:

Führen Sie im Buchfenster eine der folgenden Aktionen aus:

    Klicken Sie auf [image] , um den ersten Absatz im Hauptfluss jedes Dokuments anzuzeigen (z. B. "Kapitel 2 Farbe").

    Klicken Sie auf [image] , um die Dateinamen der Dokumente anzuzeigen.

So fügen Sie einem Buch eine generierte Datei hinzu:

    1. Öffnen Sie das Buchfenster und wählen Sie die Datei aus, bei der die generierte Datei eingefügt werden soll.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Hinzufügen > Inhaltsverzeichnis" oder wählen Sie "Hinzufügen > Liste von" und wählen Sie dann eine Liste aus dem Menü. Weitere Informationen finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen.

    Wählen Sie "Hinzufügen > Standardindex" oder wählen Sie "Hinzufügen > Liste von" und wählen Sie dann den gewünschten Indextyp aus. Weitere Informationen finden Sie unter Generieren von Indizes.


Bücher / Erstellen von Büchern

Hinzufügen von Metadaten zu einem Buch

FrameMaker enthält die integrierte XMP-Unterstützung (Extensible Metadata Platform). Metadaten oder Datei-Informationen sind ausführliche Information, die von einem Computer gesucht und verarbeitet werden können. Verwenden Sie diese, um Informationen zum Inhalt eines Dokuments zu erstellen und Informationen zu einem Dokument zu bewahren, das in einer anderen Adobe-Anwendung geöffnet wird. Wenn Sie die Datei in ein PDF-Format exportieren, werden viele dieser Metadaten in Adobe Acrobat angezeigt.

Metadatentypen begleiten das Dokument und beschreiben dessen Inhalt. Durch Einbetten in Ihre Dokumente, ist es einfacher, die Dokumente zu verfolgen, zu verwalten und abzurufen.

Metadaten in einer Dokumentdatei werden von Metadaten in einer Buchdatei überschrieben, wenn Sie in einem Buch mehrere Dokumente ausgewählt haben und anschließend in diesem Buch die Option "Datei-Informationen" gewählt haben.

Wenn ein Markierungsfeld neben einem der acht Info-Feldern aktiviert ist, werden die Metadaten des Dokuments von denen des Buches für dieses Feld überschrieben.

Um das Überschreiben Ihrer Metadaten zu verhindern, öffnen Sie vor dem Hinzufügen von Metadaten die Buchdatei und wählen das Dokument.

So fügen Sie einem Buch Metadaten hinzu:

    1. Wählen Sie das Buch, dem Sie Metadaten hinzufügen möchten.

    2. Wählen Sie "Datei > Datei-Informationen".

    3. Füllen Sie die Felder für die Metadaten aus und klicken Sie auf "Zuweisen".


Bücher

Arbeiten mit Dateien in einem Buchfenster

Im Buchfenster können Sie Dateien umbenennen, umordnen, öffnen, speichern und drucken.

Sie können im Buchfenster ein oder mehrere Dokumente auswählen und den betreffenden Dokumenten Formatänderungen zuweisen. Beispielsweise können Sie in den Dokumenten das Seitenlayout ändern, Änderungsbalken entfernen, Nummerierungsoptionen auswählen und die Zoomeinstellungen ändern.

Es ist empfehlenswert, Änderungen an den Dokumenten eines Buches im Buchfenster vorzunehmen. Wenn Sie Nummerierung, Seitenumbruch und Farbdefinitionen in jedem Dokument einzeln ändern, werden diese Änderungen unter Umständen bei der Aktualisierung des Buches außer Kraft gesetzt.


Bücher / Arbeiten mit Dateien in einem Buchfenster

Auswählen von Dateien in einem Buch

Sie können Dateien eines Buches durch Klicken oder mithilfe der "Alles wählen"-Befehle auswählen.

So wählen Sie Dateien in einem Buch aus:

Führen Sie eine der folgenden Aktionen aus:

    Klicken Sie auf das Dateisymbol.

    Wählen Sie im Buchfenster "Bearbeiten > Alles wählen" und wählen Sie dann eine Option aus dem Menü. Die Option "Generierte Dateien" wählt z. B. nur Index-, Listen- und Inhaltsverzeichnisdateien aus.

    Klicken Sie bei gedrückter Strg-Taste, um nicht benachbarte Dateien auszuwählen, oder klicken Sie bei gedrückter Umschalttaste, um einen Bereich von Dateien auszuwählen.


Bücher / Arbeiten mit Dateien in einem Buchfenster

Umstellen und Löschen von Dateien

Sie können die Reihenfolge von Dateien in einer Buchdatei ändern und Dateien aus einem Buch löschen. Beim Löschen von Dateien aus der Buchdatei werden lediglich deren Namen aus dem Buchfenster entfernt, die Dateien bleiben jedoch auf der Festplatte erhalten.

So stellen Sie Dateien in einem Buch um:

Wählen Sie im Buchfenster eine oder mehrere Dateien aus und ziehen Sie sie an die gewünschte Position.

So löschen Sie Dateien in einem Buch:

    1. Wählen Sie im Buchfenster die Datei(en) aus, die Sie löschen möchten.

    2. Wählen Sie "Bearbeiten > Datei aus dem Buch löschen" oder klicken Sie im Buchfenster auf das Löschen-Symbol [image] .


Bücher / Arbeiten mit Dateien in einem Buchfenster

Umbenennen von Buchdateien

Wenn Sie eine Datei in einem Buch umbenennen, benennt FrameMaker auch die entsprechende Datei auf der Festplatte um und aktualisiert Querverweise, Hypertext- und Texteinschub-Verbindungen in den anderen Dateien des Buches.

Wenn Sie einem Buch eine generierte Datei hinzufügen (z. B. Inhaltsverzeichnis oder Index), wird der Datei ein Name zugewiesen, der auf dem Namen der Buchdatei basiert. Wenn Sie die Standardnamen der generierten Dateien beibehalten, ändern sich beim Umbenennen die Dateinamen nur im Buch, nicht jedoch auf der Festplatte. Wenn Sie den Standardnamen der generierten Datei ändern, wird sie beim Umbenennen des Buches nicht umbenannt.

Angenommen, die Datei "Beispiel.book" enthält eine generierte Datei mit der Bezeichnung "BeispielTOC.fm". Wenn Sie den Namen der Datei zu "Neu.book" ändern, wird die generierte Datei nur im Buchfenster, nicht auf der Festplatte zu "NeuTOC.fm" umbenannt. Wenn Sie jedoch den Namen der generierten Datei zu Inhalt.fm ändern und anschließend das Buch umbenennen, lautet der Name der generierten TOC-Datei im Buchfenster und auf der Festplatte weiterhin "Inhalt.fm".

So ändern Sie den Namen eines Dokuments in einem Buch:

    1. Wählen Sie im Buchfenster die gewünschte Datei aus und wählen Sie dann "Bearbeiten > Datei umbenennen".

    2. Geben Sie den neuen Dateinamen ein und drücken Sie die Eingabetaste bzw. den Zeilenschalter. Wenn die Warnmeldung angezeigt wird, klicken Sie auf "OK", um die restlichen Dateien im Buch zu aktualisieren.

So ändern Sie in FrameMaker den Namen einer Buchdatei:

Wählen Sie im Buchfenster den Befehl "Datei > Buch sichern unter" und speichern Sie die Buchdatei unter einem anderen Namen.

Hinweis: Der Befehl "Buch sichern unter" speichert nur die Buchdatei und nicht die Dateien im Buch. Wenn das Buch in einem neuen Verzeichnis gespeichert wird, müssen die einzelnen Dateien immer separat geöffnet und gespeichert werden.


Bücher / Arbeiten mit Dateien in einem Buchfenster

Befehl "Zurück zum gesicherten Buch"

Wählen Sie "Datei > Zurück zum gesicherten Buch", um die zuletzt gesicherte Buchversion wieder aufzurufen. Dieser Befehl beeinflusst alle hinzugefügten oder gelöschten Dateien und die Einstellungen, die den Dokumenten im Buch zugewiesen wurden, z. B. Nummerierung, Seitenumbruch, Farbdefinitionen und Dateieinstellungen. Der Inhalt der Dokumente ist nicht betroffen.


Bücher / Arbeiten mit Dateien in einem Buchfenster

Öffnen, Schließen und Speichern in einem Buchfenster

Sie können mithilfe eines Buchfensters einzelne Dateien eines Buches öffnen, speichern, drucken und schließen. Es ist auch möglich, alle Dateien des Buches zu öffnen, zu drucken und zu schließen und das Format einiger oder aller Dateien zu aktualisieren.

(Windows) Wenn Sie ein Nicht-FrameMaker-Dokument im Buchfenster öffnen, wird die zugehörige Anwendung (falls vorhanden) gestartet.

So öffnen Sie Dateien in einem Buchfenster:

Führen Sie eine der folgenden Aktionen aus:

    Um eine einzelne Datei in einem Buch zu öffnen, sollten Sie sich zuerst vergewissern, dass nur diese Datei ausgewählt ist. Dann doppelklicken Sie darauf. Sie können auch den Dateinamen auswählen und die Eingabetaste drücken. Wenn Sie mit einem strukturierten Dokument arbeiten, doppelklicken Sie in der Strukturansicht auf das Elementrechteck.

    Um mehrere Dateien in einem Buch zu öffnen, wählen Sie die gewünschten Dateien aus und drücken die Eingabetaste.

    Um alle Dateien des Buches zu öffnen, halten Sie die Umschalttaste gedrückt und wählen "Datei > Alle Dateien des Buchs öffnen".

Hinweis: Wenn die Dateien viele Querverweise oder Texteinschübe enthalten, die aktualisiert werden müssen, kann die Ausführung des Befehls "Alle Dateien des Buchs öffnen" längere Zeit in Anspruch nehmen. Sie können die automatische Aktualisierung dieser Elemente unterdrücken, indem Sie in einem Buchfenster "Bearbeiten > Automatische Referenzaktualisierung unterdrücken" wählen, das entsprechende Markierungsfeld auswählen und dann auf "Zuweisen" klicken. Wenn Sie ein einzelnes Dokument öffnen, in dem die automatische Aktualisierung aktiviert ist, werden Texteinschübe und Querverweise aktualisiert.

So schließen oder speichern Sie alle Dateien in einem Buchfenster:

Führen Sie eine der folgenden Aktionen aus:

    Halten Sie die Umschalttaste gedrückt und wählen Sie "Datei > Alle Dateien des Buchs schließen". Alle Komponenten des Buches werden geschlossen, das Buchfenster selbst bleibt jedoch geöffnet.

    Halten Sie die Umschalttaste gedrückt und wählen Sie "Datei > Alle Dateien des Buchs sichern" (die Buchdatei wird ebenfalls gesichert). Das Buch und alle Dateien im Buch werden gesichert.


Bücher / Arbeiten mit Dateien in einem Buchfenster

Drucken von einem Buchfenster aus

Sie können von einem Buchfenster aus das gesamte Buch oder nur ausgewählte Dateien drucken. Weitere Informationen finden Sie unter Drucken von Dokumenten.

Wenn Sie mit strukturierten Dokumenten arbeiten, sind Elementgrenzen (in Form von Klammern oder Tags) druckbare Zeichen. Wenn diese Grenzen in einer Ihrer Dateien eingeblendet sind, sollten Sie diese ausblenden, bevor Sie drucken (siehe Ein- und Ausblenden von Elementgrenzen).

So drucken Sie Dateien von einem Buchfenster aus:

    1. Damit Seitennummerierung, Querverweise, Texteinschübe und generierte Dateien auf dem neuesten Stand sind, sollten Sie das Buch aktualisieren, bevor Sie seine Dateien ausdrucken.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie im Buchfenster die gewünschten Dateien aus und wählen Sie dann "Datei > Ausgewählte Dateien drucken".

    Wählen Sie im Buchfenster "Datei > Buch drucken".

    3. Legen Sie die Druckoptionen fest und klicken Sie auf "Drucken". Außer "Druckbereich" stehen alle normalen Druckoptionen zur Verfügung.

So drucken Sie in einer Datei:

    1. Wählen Sie "Datei > Drucken".

    2. Führen Sie eine der folgenden Aktionen aus:

    (Windows) Aktivieren Sie die Option "Ausgabe in Datei". Über die Schaltfläche "Durchsuchen" kann die Datei gesucht werden, in die die Ausgabe erfolgen soll.

Hinweis: Sie können Bücher in eine einzelne Datei oder als separaten Druckauftrag für jedes Dokument ausgeben.

    (UNIX) Wählen Sie im Aufklappmenü, ob das Buch als einzelne Datei oder als separater Druckauftrag für jedes Dokument im Buch in die Datei ausgegeben werden soll.

Sie können für das gesamte Buch oder für einzelne Dateien eine PostScript-Datei erstellen. Weitere Informationen hierzu finden Sie unter Erstellen von PostScript-Dateien.

So halten Sie den Druck an:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Drücken Sie Esc.

    (UNIX) Drücken Sie Control+c.


Bücher

Festlegen der Nummerierung von Dokumenten und Seiten

Sie können die Band-, Kapitel-, Seiten-, Absatz-, Fußnoten- und Tabellenfußnoten-Nummerierung Ihrer Dokumente ändern.

FrameMaker verwendet für die Nummerierung standardmäßig arabische Ziffern (1, 2, 3 usw.) und beginnt bei Seite 1. Sie können das Dokument mit einer anderen Seitennummer beginnen oder eine andere Nummerierungsart wählen (römisch oder alphabetisch, Groß- oder Kleinschreibung). Unterstützt Ihr System die Eingabe von japanischem Text in Dokumente und Dialogfenstern, stehen außerdem verschiedene japanische Nummerierungsarten zur Verfügung.


Bücher / Festlegen der Nummerierung von Dokumenten und Seiten

Einrichten der Nummerierung

Alle Arbeitsseiten eines Dokuments verwenden dieselbe Nummerierungsart. Es ist aber möglich, in den Dokumenten eines Buches unterschiedliche Nummerierungsarten zu verwenden. Sie können beispielsweise für das Vorwort römische Ziffern und für den Hauptteil des Buches arabische Ziffern verwenden.

Wenn Sie die Nummerierung einrichten, legen Sie im Dialogfenster "Einstellungen für Nummerierung" Band-, Kapitel-, Seiten- und Fußnotenoptionen für ein einzelnes Dokument oder für jedes Dokument im Buch fest. Band- und Kapiteleinstellungen ermöglichen mehrstufige Nummerierungen, z. B. 3.1.1, 3.1.2 usw.

Die Seitenummerierung kann in bestimmten Kapiteln wieder neu beginnen, bei anderen jedoch fortgesetzt werden.

Nachdem Sie die Nummerierung in einem Dokument oder Buch festgelegt haben, können Sie die Variablen "Bandnummer", "Kapitelnummer" und "Aktuelle Seitennr." in Kopf- und Fußzeilen einfügen. Sie können auch die Bausteine <$volnum>, <$chapnum> und <$SeiteNum> für Querverweisformate, automatische Absatznummerierung und generierte Dateien wie Indizes verwenden.

Weitere Informationen zum Nummerieren von Fußnoten finden Sie unter Ändern der Fußnoten-Nummerierung.

Wichtig: Die Nummerierungseinstellungen im Buch setzen die Nummerierungseinstellungen in den Dokumenten des Buches außer Kraft. Wenn Sie die Seitennummerierung in einem Buch festlegen, sollten Sie die Dokumente im Buchfenster auswählen, anstatt Änderungen in den einzelnen Dokumenten vorzunehmen.

So legen Sie Band- oder Kapitelnummern fest:

    1. Wenn das Dokument zu einem Buch gehört, öffnen Sie das Buch und wählen das Dokument im Buchfenster aus.

    2. Wählen Sie "Format > Dokument > Nummerierung".

    3. Wählen Sie aus dem Aufklappmenü "Band" oder "Kapitel". Unter Windows können Sie auf die Registerkarten am oberen Rand des Dialogfensters klicken.

    4. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Bandnummer" bzw. "Kapitelnummer" aus und geben Sie die Nummer des Bandes oder Kapitels ein. Wählen Sie dann aus dem Aufklappmenü "Format" ein Nummerierungsformat.

    Wählen Sie "Nummerierung von vorheriger Datei im Buch weiterführen" aus.

    Wählen Sie "Gleiche Nummer wie vorherige Datei" aus.

    Wenn beim Öffnen des Dialogfensters ein Buchfenster aktiv war, können Sie durch Aktivieren der Option "Aus Datei einlesen" die Nummerierung des zugeordneten Dokuments verwenden.

    Wenn Sie mehr als eine Datei im Buchfenster ausgewählt haben, können Sie durch Aktivierung der Option "Beibehalten" die Nummerierung der ausgewählten Dokumente verwenden.

    5. Klicken Sie auf "Zuweisen".

So legen Sie Seitennummern und Nummerierungsart fest:

    1. Wenn das Dokument zu einem Buch gehört, öffnen Sie das Buch und wählen das Dokument im Buchfenster aus.

    2. Wählen Sie "Format > Dokument > Nummerierung".

    3. Wählen Sie aus dem Aufklappmenü den Eintrag "Seite". Unter Windows können Sie auf die Registerkarte "Seite" am oberen Rand des Dialogfensters klicken.

    4. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Erste Seite Nr." aus, geben Sie die gewünschte Seitennummer ein und wählen Sie aus dem Aufklappmenü "Format" ein Nummerierungsformat.

    Wählen Sie "Nummerierung von vorheriger Seite im Buch weiterführen" aus.

    Wenn beim Öffnen des Dialogfensters ein Buchfenster aktiv war, können Sie durch Aktivieren der Option "Aus Datei einlesen" die Nummerierung des zugeordneten Dokuments verwenden.

    Wenn Sie mehr als eine Datei im Buchfenster ausgewählt haben, können Sie durch Aktivierung der Option "Beibehalten" die Nummerierung der ausgewählten Dokumente verwenden.

    5. Klicken Sie auf "Zuweisen".

So legen Sie Absatznummern und Nummerierungsart fest:

    1. Wenn das Dokument zu einem Buch gehört, öffnen Sie das Buch und wählen das Dokument im Buchfenster aus.

    2. Wählen Sie "Format > Dokument > Nummerierung".

    3. Wählen Sie aus dem Aufklappmenü den Eintrag "Absatz".

    4. Legen Sie fest, ob Sie die Absatznummerierung neu beginnen oder die Nummerierung des vorherigen Absatzes im Buch weiterführen möchten. Wenn beim Öffnen des Dialogfensters ein Buchfenster aktiv war, können Sie durch Aktivieren der Option "Aus Datei einlesen" die Nummerierung des zugeordneten Dokuments verwenden.

    5. Klicken Sie auf "Zuweisen".


Bücher

Einfügen von Nummerierungen in Ihre Dokumente

Nachdem Sie Band-, Kapitel- und Seitennummerierung in einem Buch festgelegt haben, können Sie Variablen oder Bausteine für Querverweisformate, Kopf- und Fußzeilen, Absatznummerierung oder generierte Listen wie Inhaltsverzeichnisse und Indizes einfügen.

Weitere Informationen zur Absatznummerierung finden Sie unter Basieren der automatischen Nummerierung auf Kapitel- und Bandnummern. Weitere Informationen zu generierten Listen finden Sie unter Übernehmen der automatischen Band-, Kapitel- und Absatznummerierung.

Hinweis: In den meisten Fällen bleiben nummerierte Listen unverändert, die in FrameMaker 5.0 oder früheren Versionen erstellt wurden, wenn das Dokument in FrameMaker 6.0 oder höheren Versionen geöffnet wird. Um jedoch die Band- und Kapitelnummerierung zu nutzen, können Sie z. B. die Bausteine <$AbsNum> und <$AbsNumExkl> durch die Bausteine <$volnum> und <$chapnum> ersetzen. Diese Variablen stehen in FrameMaker erst ab Version 6.0 zur Verfügung.


Bücher / Einfügen von Nummerierungen in Ihre Dokumente

Einfügen von Band- und Kapitelnummern in Querverweise

Wenn die Seiten Ihres Buches kapitelweise nummeriert sind (z. B. 2-6), sollen wahrscheinlich Querverweise ebenfalls die Kapitelnummer als Teil der Seitennummer anzeigen, z. B. siehe Seite 2-6.

So nehmen Sie Band- oder Kapitelnummern in Querverweise auf:

Erstellen Sie ein Querverweisformat (siehe Erstellen von Querverweisformaten), das den Baustein für Band- oder Kapitelnummer enthält. Das Querverweisformat könnte folgendermaßen aussehen: Siehe Seite <$chapnum>–<$SeiteNum>

Damit die Kapitelnummer stets in derselben Zeile wie die Seitennummer bleibt, verwenden Sie im Querverweisformat einen umbruchgeschützten Trennstrich (siehe Ändern von Silbentrennung und Zeilenumbruch).


Bücher / Einfügen von Nummerierungen in Ihre Dokumente

Aufnehmen von Kapitelnummern in Kopf- oder Fußzeilen

In einigen Büchern sind die Seiten kapitelweise nummeriert, z. B. 2-3 für Seite 3 von Kapitel 2 oder A-2 für Seite 2 von Anhang A. Sie können dazu entweder eine Variable für die Kapitelnummer (oder Bandnummer) oder eine Variable für laufende Kopf- und Fußzeilen angeben oder die Kapitelnummer direkt in die Kopf- bzw. Fußzeile jedes Kapitels eingeben. Wenn Sie eine Variable verwenden, werden die Nummern bei jeder Buchaktualisierung automatisch auf den neuesten Stand gebracht.

Um mehrstufige Nummerierungen zu erzeugen, fügen Sie Ihrem Dokument Kapitel- und Bandnummern hinzu.

So nehmen Sie eine Band- oder Kapitelnummer in eine Kopf- oder Fußzeile auf:

    1. Zeigen Sie die Vorgabeseite an, in der die Kopf- bzw. Fußzeile enthalten ist. Weitere Informationen finden Sie unter Anzeigen von Vorgabeseiten.

    2. Setzen Sie die Einfügemarke an der Stelle in die Kopf- bzw. Fußzeile, an der die Band- oder Kapitelnummer hinzugefügt werden soll, und fügen Sie die entsprechende Variable mit dem Befehl "Spezial > Variable" ein. Weitere Informationen finden Sie unter Einfügen von Variablen.

    3. Fügen Sie die jeweilige Interpunktion ein, z. B. einen Trennstrich oder einen Punkt.

    4. Um die Seitennummerierung hinzuzufügen, wählen Sie "Format > Kopf- und Fußzeilen > Seitennummer einfügen".

Die Kopf- bzw. Fußzeile sollte auf einer Arbeitsseite folgendermaßen aussehen:

A: Variable "Kapitelnummer" (<$chapnum>)
B: Variable "Aktuelle Seitennummer"


Bücher / Einfügen von Nummerierungen in Ihre Dokumente

Anzeigen der Gesamtzahl der Seiten eines Buches in einer Kopf- oder Fußzeile

Sie können die Seitenanzahl eines Buches in einer Kopf- oder Fußzeile anzeigen, z. B. 4 von 200 auf Seite 4 eines Buches mit 200 Seiten.

Wenn Sie die Seitenanzahl mithilfe der Variable "Seitenanzahl" in die Kopf- oder Fußzeile einer Datei einfügen, zeigt die Kopf- bzw. Fußzeile die Seitenanzahl in dieser Datei, nicht jedoch die des gesamten Buches an. Um die Anzahl der Seiten in einem Buch anzuzeigen, können Sie einen speziellen Absatz erstellen und mit einem Querverweis darauf Bezug nehmen.

So zeigen Sie die Gesamtzahl der Seiten eines Buches in einer Kopf- oder Fußzeile an:

    1. Richten Sie die Dateien im Buch für eine fortlaufende Seitennummerierung ein (siehe Einrichten der Nummerierung).

    2. Zeigen Sie die Vorgabeseite für die letzte Seite der letzten Datei im Buch an (siehe Anzeigen von Vorgabeseiten) und setzen Sie die Einfügemarke in einen leeren Absatz der Kopf- oder Fußzeile.

    3. Wählen Sie "Format > Kopf- und Fußzeilen > Seitenanzahl einfügen" und fügen Sie die Variable "Seitenanzahl" ein.

Variable "Seitenanzahl" in separatem Absatz

    4. Definieren Sie ein neues Absatzformat für den Absatz mit der Seitenanzahl und speichern Sie diesen im Absatzformat-Katalog (siehe Verwenden der Gestaltungsfenster). Durch das eindeutige Format für diesen Absatz kann später in Querverweisen leichter darauf Bezug genommen werden.

    5. Wenn die Seitenanzahl nicht an der Position angezeigt werden soll, an der Sie sie eingegeben haben, passen Sie entweder die Größe des Textrahmens so an, dass die Seitenanzahl verborgen ist, oder verwenden Sie Weiß als Farbe für den Absatz.

    6. Fügen Sie in die anderen Dateien des Buches Querverweise auf den Absatz mit der Seitenanzahl ein. Platzieren Sie den Querverweis auf allen Vorgabeseiten aller Dokumente (siehe Einfügen von Querverweisen). Verwenden Sie im Querverweisformat den Baustein <$AbsText>.

    7. Platzieren Sie die Querverweise in der Kopf- bzw. Fußzeile aller Vorgabeseiten aller Dateien im Buch, einschließlich der letzten.


Bücher

Ändern des Formats von Dateien eines Buches

Wenn Sie Seitengestaltung, Absatzformate und andere Formate eines Buches ändern möchten, können Sie diese Änderungen in einer Datei vornehmen und anschließend alle Dateien des Buches gleichzeitig aktualisieren.

Wenn Sie das Format mehrerer Dateien in einem Buch ändern möchten, können Sie die Dateien im Buchfenster auswählen und die Formatierung zuweisen. Weitere Informationen finden Sie unter Verwenden von Befehlen, die sich auf das ganze Buch beziehen.

So ändern Sie das Format der Dateien eines Buches:

    1. Öffnen oder erstellen Sie die Datei, deren Formate Sie verwenden möchten. Die Datei muss benannt und gespeichert worden sein.

    2. Wählen Sie im Buchfenster die gewünschten Dateien aus und wählen Sie dann "Datei > Importieren > Formate".

    3. Wählen Sie aus dem Aufklappmenü "Import aus Dokument" die Datei mit den Formaten, die Sie importieren möchten.

    4. Wählen Sie die Einstellungen, die Sie importieren und aktualisieren möchten (siehe Importieren und Aktualisieren von Formaten).

    5. Klicken Sie auf "Importieren". Eine nicht geöffnete Datei wird direkt auf der Festplatte aktualisiert. Geöffnete Dateien werden nur im Arbeitsspeicher des Computers aktualisiert, nicht jedoch auf der Festplatte. Sie müssen die betreffenden Dateien speichern, damit die Änderungen beibehalten werden.


Bücher

Verwenden von Befehlen, die sich auf das ganze Buch beziehen

Viele FrameMaker-Befehle können auf einige oder alle Dokumente eines Buches angewendet werden. Sie können z. B. eine Wortverbindung suchen und im ganzen Buch ersetzen. Darüber hinaus können Sie Darstellungs- und Rechtschreibungsoptionen sowie das Seitenlayout der ausgewählten Dateien des Buches ändern. Bei der Arbeit mit strukturierten Dokumenten können Sie im Buch auch Attribute bearbeiten, verfügbare Elemente festlegen und Optionen für neue Elemente einrichten.

Wenn das mit dem Buch verbundene Dokument geöffnet ist, wendet FrameMaker den buchübergreifenden Befehl auf das Dokument an, speichert oder schließt es aber nicht. Wenn das Dokument nicht geöffnet ist, öffnet FrameMaker das Dokument, wendet den buchübergreifenden Befehl an und sichert und schließt das Dokument.

Wenn die Werte in einem Dialogfenster falsch angezeigt werden, wenn Sie einen Befehl anwenden, aktualisieren Sie das Buch und versuchen es erneut.

So verwenden Sie einen buchübergreifenden Befehl:

    1. Wählen Sie im Buchfenster die Datei(en) aus, die Sie ändern möchten.

    2. Wählen Sie den gewünschten Befehl (z. B. "Bearbeiten > Suchen/Ändern") aus einem Menü oder verwenden Sie den zugehörigen Tastaturbefehl.

Wenn FrameMaker eine ausgewählte Datei nicht öffnen kann oder wenn beim Anwenden des Befehls auf die Datei andere Probleme auftreten, wird im Buchfehlerprotokoll eine Meldung angezeigt.


Bücher

Aktualisieren von Büchern

Nachdem Sie ein Buch eingerichtet und Nummerierungseinstellungen für jede Datei im Buch festgelegt haben, aktualisieren Sie die Dateien. Dieser Vorgang bildet den Abschluss der Bucherstellung.

Die Generierung und die Aktualisierung erfolgt zwar in einem Schritt, es handelt sich dabei aber um zwei verschiedene Vorgänge:

    Beim Generieren werden das Inhaltsverzeichnis, weitere generierte Listen und Indizes in der Buchdatei angelegt. Beim ersten Generieren einer Liste oder eines Index übernimmt die Liste bzw. der Index das Seitenlayout (Vorgabeseiten) und die Referenzseiten des ersten nicht generierten Dokuments in der Buchdatei.

    Beim Aktualisieren werden die Seiten- und Absatznummerierung aller Dateien im Buch auf den neuesten Stand gebracht, Texteinschübe neu importiert und Querverweise aktualisiert, damit sie auf die korrekten Seiten- und Absatznummern verweisen. Leere Seiten werden nach Bedarf hinzugefügt oder gelöscht.

Nach einer der folgenden Änderungen an einem Dokument oder einer Buchdatei sollten Sie stets das Buch erneut generieren und aktualisieren:

    Bearbeitung, die den Seitenumbruch beeinflusst

    Bearbeitungen, die den Wortlaut einer generierten Datei betreffen (z. B. die Änderung einer Kapitelüberschrift)

    Hinzufügen einer neuen Farbe (sodass die Farbauszüge exakt sind)

    Änderung der Einstellungen von bedingtem Text oder der Indikatoren

    Ändern der Nummerierung von Dokumenten oder generierten Dateien

    Ändern der Formatinformationen im speziellen Textfluss auf einer Referenzseite einer generierten Datei (siehe Bearbeiten von speziellen Textflüssen für Listen und Indizes)

    Umstellen, Hinzufügen oder Entfernen von Dateien im Buch

So aktualisieren Sie die Dateien in einem Buch:

    1. Wählen Sie im Buchfenster "Bearbeiten > Buch aktualisieren" oder klicken Sie auf das Buch-Symbol [image] .

    2. Legen Sie fest, ob Nummerierung, Querverweise, Texteinschübe und generierte Datei (z. B. Inhaltsverzeichnisse und Indizes) aktualisiert werden sollen.

    3. Kopieren Sie die Namen der Dateien, die generiert werden sollen, in die Liste "Generieren".

Um einen Dateinamen zwischen Auswahllisten zu verschieben, wählen Sie ihn aus und klicken auf einen Pfeil oder doppelklicken Sie auf den Dateinamen. Um alle Dateinamen von einer Liste in eine andere zu verschieben, halten Sie die Umschalttaste gedrückt und klicken auf einen Pfeil.

Hinweis: In der Liste werden nur generierte Dateien angezeigt. Wenn keine Dateien angezeigt werden, verfügt das Buch nicht über generierte Dateien. Sie sollten den nächsten Schritt auch dann ausführen, wenn die Listen keine Dateien enthalten oder wenn Sie alle Dateien in die Liste "Nicht generieren" verschoben haben. Dadurch stellen Sie sicher, dass der Seitenumbruch, die automatische Seitennummerierung, die Texteinschübe und die Querverweise des Buches aktualisiert werden.

    4. Klicken Sie auf "Aktualisieren". Weitere Informationen zu Meldungen im Buchfehlerprotokoll finden Sie unter Problembehebung in Büchern.

    5. Speichern Sie die geöffneten Dateien, damit die Änderungen erhalten bleiben. Geöffnete Dateien werden nur im Arbeitsspeicher Ihres Computers, jedoch nicht auf der Festplatte aktualisiert. Wenn eine Datei nicht geöffnet ist, werden die Änderungen auf die Festplatte geschrieben. Dies gilt auch dann, wenn die Datei das Format "Viewer" hat.


Bücher

Vergleichen von Büchern

FrameMaker kann zwei Versionen eines Buches vergleichen und feststellen, welche Änderungen vorgenommen wurden. Dabei werden neben dem Text auch Fußnoten, Marken, verankerte Rahmen, Texteinschübe, Variablen und Querverweise berücksichtigt. Weitere Informationen finden Sie unter Verglichene Elemente.

Es werden nur Dokumente mit gleichen Dateinamen verglichen.

Hinweis: FrameMaker vergleicht nicht die Struktur der beiden Versionen. Beim Vergleichen langer Dokumente können Speicherprobleme auftreten. Erhöhen Sie bei Bedarf die Speicherzuordnung bzw. den Swap-Speicher (UNIX).

So vergleichen Sie zwei Versionen eines Buches:

    1. Öffnen Sie beide Versionen der Buchdatei.

    2. Wählen Sie im Buchfenster der neueren Buchversion "Datei > Dienstprogramme > Bücher vergleichen".

    3. Wählen Sie die ältere Buchversion und geben Sie an, welche Dokumente angelegt werden sollen.

Das Auswertungsdokument zeigt alle Unterschiede zwischen den Dateien an. Bei kombinierten Dokumenten (mit dem Suffix CMP) werden die Unterschiede zwischen den Dateien nebeneinander angezeigt.

    4. Klicken Sie zur Definition der Vergleichsoptionen auf "Optionen" (siehe Vergleichen von Dokumentversionen).

    5. Klicken Sie auf "Vergleichen". Nach Beendigung des Vergleichs wird nur das Auswertungsdokument am Bildschirm angezeigt.

    6. Klicken Sie in der Liste der Änderungen auf eine Seitennummer, um das kombinierte Dokument zu öffnen oder zu der Textstelle zu wechseln, an der die betreffende Änderung (im alten oder neuen Dokument) vorgenommen wurde.


Bücher

Problembehebung in Büchern

Bei der Arbeit mit Büchern kann es zu Problemen oder Fehlermeldungen kommen. Selbst wenn während der Aktualisierung bzw. Generierung eines Buches keine Fehlermeldungen angezeigt wurden, können bei der Bucherstellung Probleme auftreten, die behoben werden müssen.

Eine generierte Datei ist leer

Stellen Sie sicher, dass der generierten Datei im Buchfenster ein Symbol für generierte Dateien ( [image] ) vorangestellt ist. Sollte dies nicht der Fall sein, wurde die Datei nicht als generierte Datei, sondern als Dokument in die Buchdatei aufgenommen (siehe Hinzufügen von Dateien zu einem Buch). Wenn Sie eine Datei als Dokumentdatei hinzufügen, wird sie von FrameMaker nicht generiert. Überprüfen Sie auch, ob die Einstellungen der generierten Datei korrekt sind.

Langsame Reaktion

Um die Geschwindigkeit beim Generieren und Aktualisieren zu erhöhen, öffnen Sie möglichst viele Dateien des Buches, bevor Sie im Buchfenster den Befehl "Bearbeiten > Buch aktualisieren" oder "Datei > Importieren > Formate" aufrufen. Speichern Sie nach Ausführung des Befehls alle Dateien des Buches.

Das Kapitel beginnt auf der falschen Seite

Korrigieren Sie den Seitenumbruch des Dokuments. Weitere Informationen finden Sie unter Hinzufügen und Löschen leerer Seiten.


Bücher / Problembehebung in Büchern

Interpretation von Fehlermeldungen

Das Buchfehlerprotokoll zeichnet alle Fehler auf, die beim Anwenden eines Befehls auf ein Buch auftreten. Außerdem enthalten viele Fehlermeldungen Hypertext-Verbindungen, damit Sie auf die Meldung im Fehlerprotokoll klicken können, um die Position des Fehlers anzuzeigen. Bei der Aktualisierung können die folgenden Warn- oder Fehlerprotokollmeldungen angezeigt werden.

Ungelöste Querverweise

Im Buchfehlerprotokoll sind alle Dateien mit ungelösten Querverweisen aufgelistet (siehe Auflösen von Querverweisen).

Widersprüchliche Ein-/Ausblenden-Einstellung, widersprüchliche Einstellung für Anzeige von Bedingungsformaten oder widersprüchliche Bedingungsformate

Die angegebene Datei enthält Einstellungen für bedingten Text, die von denjenigen der vorherigen Datei im Buch abweichen. Sie können die Einstellung in jeder einzelnen Datei korrigieren (mit dem Befehl "Spezial > Bedingter Text") oder die Einstellungen im gesamten Buch gleichzeitig aktualisieren. Hierzu ändern Sie die Einstellungen in einer Datei und wählen dann "Datei > Importieren > Formate", um die Einstellungen allen Dateien im Buch zuzuweisen (siehe Ändern des Formats von Dateien eines Buches).

Inkonsistente Nummerierungseinstellungen

Die in der Datei festgelegten Nummerierungseinstellungen stimmen nicht mit denen des Buches überein. Die Nummerierungseinstellungen des Buches setzen die Nummerierungseinstellungen des Dokuments außer Kraft. Weitere Informationen finden Sie unter Festlegen der Nummerierung von Dokumenten und Seiten.

Inkonsistente Farbeinstellungen

Die angegebene Datei enthält Einstellungen für Farbauszüge oder Farbdefinitionen, die von denen in der vorherigen Datei des Buches abweichen (siehe Farbauszüge und Definieren und Ändern von Farben und Aufhellungen).

Datei konnte nicht geöffnet werden

Das Buchfehlerprotokoll gibt an, ob die Datei in einem älteren Format gespeichert wurde, ob nicht verfügbare Schriften verwendet wurden oder ob die Datei nicht gefunden werden kann. Wenn Sie die Datei öffnen, werden in einem Meldungsfenster weitere Informationen angezeigt.

Buch ist nicht einheitlich

Der Inhalt von generierten Dateien, die Seitenanzahl oder die Querverweise haben sich wiederholt geändert, während die Dateien des Buches generiert und aktualisiert wurden. Wenn ein Buch beispielsweise eine Markenliste und eine alphabetische Markenliste enthält und beide Listen Hypertext-Verknüpfungen enthalten, wächst die Anzahl der Marken jedes Mal, wenn die Dateien generiert werden. Um das Problem zu beheben, entfernen Sie vor dem nächsten Aufruf des Befehls "Generieren/Aktualisieren" eine der generierten Listen aus der Auswahlliste "Übernehmen".

Widersprüchliche Einstellungen für Elementgrenzen

In einem strukturierten Buch werden die Elementgrenzen in einigen Dateien im Buch nicht angezeigt. Gleichen Sie die Einstellungen in den betreffenden Dateien im Buch an, um Einheitlichkeit zu erreichen (siehe Ein- und Ausblenden von Elementgrenzen).


Bücher

Strukturierte Buchdateien

Wie jede andere FrameMaker-Datei kann eine Buchdatei strukturiert sein. Jedes Dokument und jede generierte Datei ist ein Element des Buches. Sie können die Elementrechtecke in der Strukturansicht bearbeiten, um die Anordnung der Dateien zu verändern oder einzelne Dateien aus dem Buch zu entfernen. Sie können auch den Inhalt eines ganzen Buches in einem Arbeitsgang überprüfen.

Ein Buch und die darin enthaltenen Dateien könnten alle denselben Elementkatalog verwenden, sodass ein einziger Katalog die gültige Struktur für alle Inhalte des Buches definiert. Teile des Buches können verschiedene Kataloge verwenden, sodass jeder Katalog nur die jeweils benötigten Elemente enthält. Fragen Sie Ihren Entwickler, wie die Kataloge für Bücher eingerichtet sind.

Zur Zusammenstellung eines Buches erstellen Sie eine Buchdatei, die eine Liste der Dokumente im Buch enthält. Fügen Sie anschließend der Buchdatei die Dokumente in der gewünschten Reihenfolge hinzu. Wenn eines der Dokumente im Buch strukturiert ist, wird die Buchdatei automatisch strukturiert. Durch Importieren von Elementdefinitionen in die Buchdatei können Sie diese später strukturieren.


Bücher / Strukturierte Buchdateien

Erstellen von strukturierten Buchdateien

Sie können eine strukturierte Buchdatei aus jedem der im Buch enthaltenen strukturierten Dokumente anlegen. Sobald eine Buchdatei angelegt ist, bietet FrameMaker spezielle Menübefehle an, um mit dem Buch zu arbeiten.

Eine neue Buchdatei hat denselben Elementkatalog wie das Dokument, aus dem sie erstellt wurde. Das Buch hat eine vorläufige Struktur, bestehend aus einem Element, das sich auf höchster Ebene befindet und den Namen "OhneTitel" trägt, und einem Element mit der Bezeichnung BUCHKOMPONENTE für das Dokument. Wenn Sie dem Buch weitere Dateien hinzufügen, wird für jede Datei ein neues Element angezeigt. Wenn Sie mit dem Hinzufügen von Dateien fertig sind, können Sie die Struktur korrigieren.

Wenn Sie kein strukturiertes Dokument für die Erstellung des Buches haben, erstellen Sie es aus einem beliebigen Dokument und versehen das Buch später mit Elementdefinitionen (siehe Importieren von Elementdefinitionen in strukturierte Bücher).

So legen Sie eine Buchdatei an:

    1. Wählen Sie "Datei > Neu > Buch". Wenn ein Dokument aktiviert ist, werden Sie gefragt, ob das Dokument dem Buch hinzugefügt werden soll. Ein neues Buchfenster mit dem Inhalt des Buches wird angezeigt.

Hinweis: Wenn unter UNIX kein Dokument- oder Buchfenster geöffnet ist, können Sie ein neues Buch mit Esc d Umschalttaste+n erzeugen. Unter Windows verwenden Sie Alt+d+n+b.

    2. Wählen Sie "Datei > Buch sichern unter", um die Buchdatei zu speichern. Unter Windows wird beim Speichern die Erweiterung .book an den Dateinamen angehängt.


Bücher / Strukturierte Buchdateien

Hinzufügen von Dateien zu strukturierten Büchern

Sie können einem Buch FrameMaker-Dokumente und generierte Dateien hinzufügen. Die Namen und Standorte von Dateien werden in der Buchdatei gespeichert, sodass FrameMaker die Dateien findet, wenn Sie diese mithilfe von Buchbefehlen bearbeiten.

Beim Einfügen von Dateien in ein Buch werden diese in der Strukturübersicht als Elementrechtecke mit dem Tag BUCHKOMPONENTE angezeigt. FrameMaker überarbeitet diese Tags später bei der Aktualisierung.

Für jede hinzugefügte Datei wird ein Elementrechteck angezeigt.

In der Regel existiert eine generierte Datei noch nicht, wenn sie einer Buchdatei hinzugefügt wird. Sie entsteht erst bei der Aktualisierung des Buches. Der Name einer generierten Datei basiert auf dem Dateinamen des Buches. Deshalb sollten Sie sich vergewissern, dass das Buch den gewünschten Namen hat, bevor die generierte Datei hinzugefügt wird.

Weitere Informationen zum Hinzufügen generierter Dateien wie Indizes und Inhaltsverzeichnisse zu einem Buch finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen in strukturierten Dokumenten und Generieren von Indizes.


Bücher / Strukturierte Buchdateien

Umbenennen, Umstellen und Löschen von Dateien in strukturierten Büchern

Sie können eine Datei in einem Buch umbenennen, umstellen oder löschen. Weitere Informationen hierzu finden Sie unter Arbeiten mit Dateien in einem Buchfenster.

Bei der Arbeit mit strukturierten Büchern können Sie Dateien auch mithilfe der Elementrechtecke in der Strukturansicht umstellen und löschen. Führen Sie diesen Vorgang erst nach dem Aktualisieren des Buches durch, damit die Dateien durch Textausschnitte gekennzeichnet sind.

Beim Löschen einer Datei aus einem aktualisierten Buch, behält die Datei möglicherweise einige Strukturinformationen vom Buch. Entfernen Sie auch diese Informationen aus der Datei, damit sie wieder ein eigenständiges Dokument darstellt (siehe Löschen von übernommenen Informationen aus strukturierten Dateien).


Bücher

Generieren und Aktualisieren von strukturierten Büchern

Nachdem Sie ein Buch eingerichtet und Seiten- und Absatznummerierung für jede Datei im Buch festgelegt haben, müssen Sie die Dateien generieren und aktualisieren. Die Generierung und die Aktualisierung erfolgt zwar in einem Schritt, es handelt sich dabei aber um zwei verschiedene Vorgänge:

    Beim Generieren werden das Inhaltsverzeichnis, weitere generierte Listen und Indizes in der Buchdatei angelegt. Beim ersten Generieren einer Liste oder eines Index übernimmt die Liste bzw. der Index das Seitenlayout (Vorgabeseiten) und die Referenzseiten des ersten nicht generierten Dokuments in der Buchdatei.

    Beim Aktualisieren werden die Element-Tags des Buches und die Informationen in den Dateien überarbeitet, Formatregeln der Buchelementdefinitionen werden erneut angewendet, die Seiten- und Absatznummerierung werden korrigiert, Texteinschübe werden übernommen und Querverweise werden überarbeitet, damit sie den neuen Absatz- und Seitennummerierungen entsprechen. Leere Seiten werden nach Bedarf hinzugefügt oder gelöscht.

Bevor Sie ein Buch zum ersten Mal aktualisieren, wird jede Datei durch ein Element mit der Bezeichnung BUCHKOMPONENTE angezeigt. Bei der Aktualisierung wird das Element durch ein Tag mit der Bezeichnung des Elements, das sich auf der höchsten Ebene befindet, ersetzt. Das ist im Normalfall das Tag "Kapitel", das die Datei als Einheit beschreibt. (Wenn eine Datei mehr als einen Textfluss enthält, kommt das Tag vom Element der höchsten Ebene in Fluss A.)

"Kapitel" ist das Element der höchsten Ebene in Dateien.

Die Elemente für beliebige nicht strukturierte Dateien in dem Buch werden weiterhin BUCHKOMPONENTE genannt. Um BUCHKOMPONENTE in ein Element-Tag umzuwandeln, müssen Sie die Dateien strukturieren und dann erneut generieren und aktualisieren. Weitere Informationen zu weiteren Korrekturen an der Struktur des Buches finden Sie unter Bearbeiten der Struktur.

Nach einer der folgenden Änderungen an einem Dokument oder einer Buchdatei sollten Sie stets das Buch erneut generieren und aktualisieren:

    Änderung des Elements der höchsten Ebene in einer der Buchdateien

    Importieren neuer oder überarbeiteter Elementdefinitionen

    Bearbeitung, die den Seitenumbruch beeinflusst

    Bearbeitung, die eine generierte Datei beeinflusst (z. B. ein zusätzliches Abschnittselement oder eine Änderung des Wortlauts in einem Kapiteltitel)

    Hinzufügen einer neuen Farbe (sodass die Farbauszüge exakt sind)

    Änderung der Einstellungen von bedingtem Text oder der Indikatoren

    Ändern der Einstellung von Dokumenten oder generierten Dateien

    Ändern der Formatierungsinformationen im speziellen Textfluss auf einer Referenzseite einer generierten Datei

    Umstellen, Hinzufügen oder Entfernen von Dateien im Buch

Weitere Informationen zum Generieren und Aktualisieren von Dateien in einem Buch finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen in strukturierten Dokumenten.

So aktualisieren Sie die Dateien in einem Buch:

    1. Wählen Sie im Buchfenster "Bearbeiten > Buch aktualisieren" oder klicken Sie auf das Buch-Symbol [image] .

    2. Legen Sie fest, ob Nummerierung, Querverweise, Texteinschübe, OLE-Verknüpfungen und generierte Datei (z. B. Inhaltsverzeichnisse und Indizes) aktualisiert werden sollen.

    3. Kopieren Sie die Namen der Dateien, die generiert werden sollen, in die Liste "Generieren". Um einen Dateinamen aus einer Auswahlliste in die andere zu verschieben, wählen Sie den Dateinamen und klicken auf einen Pfeil oder doppelklicken auf den Dateinamen. Um alle Dateinamen von einer Liste in eine andere zu verschieben, halten Sie die Umschalttaste gedrückt und klicken auf einen Pfeil.

Hinweis: In der Liste werden nur generierte Dateien angezeigt. Wenn keine Dateien angezeigt werden, verfügt das Buch nicht über generierte Dateien. Wenn in den Listen keine Dateien angezeigt werden, oder wenn Sie alle Dateien in die Liste "Nicht generieren" verschoben haben, sollten Sie trotzdem mit dem nächsten Schritt zum Aktualisieren der Buchelemente und anderen Einstellungen fortfahren.

    4. Klicken Sie auf "Aktualisieren". Weitere Informationen zu Meldungen im Buchfehlerprotokoll finden Sie unter Problembehebung in Büchern.

    5. Speichern Sie alle geöffneten Dateien. Geöffnete Dateien werden nur im Arbeitsspeicher Ihres Computers, jedoch nicht auf der Festplatte aktualisiert. Eine nicht geöffnete Datei wird direkt auf der Festplatte aktualisiert.


Bücher

Arbeiten mit der Buchstruktur

Bearbeiten der Struktur

Importieren von Elementdefinitionen in strukturierte Bücher

Prüfen von strukturierten Büchern

Löschen von übernommenen Informationen aus strukturierten Dateien

Importieren von Formaten in ein strukturiertes Buch


Bücher / Arbeiten mit der Buchstruktur

Bearbeiten der Struktur

Eine neue Buchdatei hat eine Struktur. Diese besteht aus einem Element der höchsten Ebene mit der Bezeichnung "OhneTitel" und einem Element mit der Bezeichnung BUCHKOMPONENTE für jedes Dokument und jede generierte Datei, die Sie dem Buch hinzugefügt haben. Wenn Sie das Buch aktualisieren, werden die Elemente für strukturierte Dateien in das Tag des Elements der höchsten Ebene der Datei umgewandelt.

In den meisten Fällen müssen Sie nach dem Aktualisieren einige Korrekturen an der Struktur einer Buchdatei vornehmen. Sie sollten z. B. das Element mit der Bezeichnung "OhneTitel" zum Element der höchsten Ebene machen. Falls einige Elemente immer noch "BUCHKOMPONENTE" heißen, verleihen Sie diesen Elementen eine Struktur und generieren und aktualisieren Sie erneut (siehe Aktualisieren von Büchern).

Die Elementdefinitionen des Buches könnten auch erfordern, dass Sie Elemente in Elemente auf höherer Ebenen gruppieren, z. B. Titelblatt, Haupttext und Anhänge.

Typische Struktur einer Buchdatei

Um eine Datei schnell zu öffnen, doppelklicken Sie auf das betreffende Elementrechteck in der Strukturansicht.

Sie können die Struktur eines Buches weitgehend in derselben Weise bearbeiten, wie Sie ein Dokument bearbeiten – durch das Einfügen, Eingliedern und Ändern von Elementen, Zusammenfügen und Teilen, Verschieben und Löschen von Elementrechtecken in der Strukturansicht usw. Sie können jedoch keine Elemente zusammenfügen oder teilen, die Dateien repräsentieren. Ferner können Sie in einem strukturierten Buch, das keine Standardstruktur hat, Aktionen wie Ausschneiden oder Einfügen nicht rückgängig machen.

Allgemeine Informationen zum Bearbeiten der Struktur finden Sie unter Importieren von Elementdefinitionen in strukturierte Bücher.


Bücher / Arbeiten mit der Buchstruktur

Importieren von Elementdefinitionen in strukturierte Bücher

Sie können Elementdefinitionen in Buchdateien sowie in alle im Buch enthaltene Dateien importieren. Die Definitionen sind im Elementkatalog des Buches und anderer Dateien gespeichert. Das Importieren von Elementdefinitionen könnte in folgenden Fällen nötig werden:

    Um einem nicht strukturierten Buch eine Struktur zu geben. Nach dem Importieren der Definitionen können Sie Elemente in die Buchdatei einfügen.

    Um die Elementdefinitionen in einem Buch oder seinen Dateien zu aktualisieren. Jedes Mal, wenn der Anwendungsentwickler die Definitionen in Ihrer Schablone überarbeitet, müssen Sie diese aktualisieren.

    Um einem Buch und allen dazugehörigen Dateien dieselben Elementdefinitionen zuzuweisen. Dies ist der Fall, wenn die Dateien eines Buches auf verschiedenen Schablonen basieren und Sie es aktualisieren möchten.

Wenn Sie Elementdefinitionen in ein Buch importieren, ersetzt FrameMaker die Definitionen im Buch und in allen zugehörigen Dateien durch die neuen Definitionen und wendet die Formatregeln der Definitionen erneut an. Hierdurch wird die Buchdatei auch geprüft.

Allgemeine Informationen zum Importieren von Elementdefinitionen finden Sie unter Importieren und Aktualisieren von Formaten.

So importieren Sie Elementdefinitionen in ein Buch:

    1. Öffnen Sie das Buch, das aktualisiert werden soll, sowie die Schablone, das Dokument oder das Buch mit den Definitionen, die importiert werden sollen.

    2. Wählen Sie im Buchfenster die Dateien aus, in die Sie Elementdefinitionen importieren möchten, und wählen Sie "Datei > Importieren > Elementdefinitionen".

    3. Wählen Sie aus dem Aufklappmenü "Import aus Dokument" das Dokument oder die Schablone. In dem Menü werden alle Dokumente und Bücher aufgelistet, die sowohl geöffnet als auch gespeichert sind.

    4. Um irreguläre Formatregeln in den Dateien zu entfernen, wählen Sie "Irreguläre Formatzuweisungen bei Aktualisierung entfernen". Verwenden Sie diese Einstellung, wenn Sie Text- oder Absatzänderungen an Elementen vorgenommen haben und nun wieder die Formatierung, wie sie in der Elementdefinition festgelegt ist, verwenden möchten.

    5. Klicken Sie auf "Importieren". FrameMaker aktualisiert die Elementdefinitionen in der Buchdatei und in den Dateien, die in der Auswahlliste "Aktualisieren" enthalten sind.


Bücher / Arbeiten mit der Buchstruktur

Prüfen von strukturierten Büchern

Sie können ein komplettes Buch (einschließlich seiner Dateien), nur die Buchdatei oder nur das aktuelle Element in der Buchdatei überprüfen. Wenn Sie die Gültigkeit des ganzen Buches überprüfen, wird die Struktur des Buches und jeder Datei mit dem Elementkatalog des Buches verglichen.

Wenn FrameMaker einen Fehler findet, wird das betreffende Element markiert und im oberen Teil des Dialogfensters "Elementprüfung" wird eine Fehlermeldung angezeigt. Tritt der Fehler in der Buchdatei auf, verwendet FrameMaker dieselben Fehlermeldungen wie bei der Überprüfung eines Dokuments. Tritt der Fehler in einer der anderen geöffneten Dateien auf, wird die Meldung "Fehler bei Gültigkeitsprüfung in Datei" angezeigt. Sie können diese Datei prüfen, um mehr über diesen Fehler zu erfahren.

Wenn ein Element bei der Prüfung ausgelassen werden soll, kennzeichnen Sie dieses als Spezialfall.

Allgemeine Informationen zur Überprüfung der Gültigkeit finden Sie unter Überprüfen von Dokumenten.

So überprüfen Sie ein Buch:

    1. Wählen Sie im Buchfenster "Element > Prüfen".

    2. Wählen Sie "Gesamtes Buch", "Nur Buch-Elemente" oder "Aktuelles Element", um den zu prüfenden Bereich festzulegen.

    3. Um fehlende Elemente oder Attributwerte von der Suche auszuschließen, aktivieren Sie "Fehlende Elemente ignorieren" oder "Fehlende Attributwerte ignorieren".

Wenn diese Einstellungen aktiviert sind, sucht FrameMaker nicht nach Stellen, an denen erforderliche untergeordnete Elemente oder ein erforderlicher Attributwert fehlen. Sie können diese Einstellungen aktivieren, wenn Sie noch nicht versuchen, ein vollständiges Buch aufzubauen.

    4. Klicken Sie auf "Starten".

    5. Wenn FrameMaker einen Fehler findet, geben Sie an, ob dieser Fehler bestehen bleiben kann, und klicken Sie anschließend erneut auf "Starten".

Der obere Teil des Dialogfensters "Elementprüfung" zeigt das Element-Tag und eine kurze Meldung, in der der Fehler beschrieben wird. Weitere Informationen finden Sie unter Fehlermeldungen bei Prüfungen.

Element und Fehler identifiziert

Wenn der Fehler bestehen bleiben kann, klicken Sie auf "Als Spezialfall zulassen".

    6. Wiederholen Sie Schritt 5, bis FrameMaker keine Fehler mehr findet.

So heben Sie alle Sonderfälle auf:

    1. Wählen Sie "Element > Prüfen".

    2. Klicken Sie auf "Spezialfälle löschen". FrameMaker hebt alle Sonderfälle im gesamten Buch, nur in der Buchdatei oder nur im aktuellen Element auf, je nachdem, welchen Bereich Sie im Dialogfenster gewählt haben.


Bücher / Arbeiten mit der Buchstruktur

Löschen von übernommenen Informationen aus strukturierten Dateien

Beim Generieren und Aktualisieren eines Buches übernehmen die Dateien im Buch Strukturinformationen aus der Buchdatei. Der Elementkatalog einer Datei enthält möglicherweise Einschlüsse und Ausschließungen aus dem Buch und andere übernommene Informationen in der Datei könnten die Formatierung der Textelemente beeinflussen.

Wenn Sie eine Datei aus einem Buch entfernen, um diese Datei als eigenständiges Dokument zu verwenden, wenden Sie die Elementdefinitionen der Datei erneut an, um alle Strukturinformationen, die aus dem Buch stammen, zu entfernen. Wenn die Textformatierung der Datei von diesen Strukturinformationen betroffen war, wird auch die ursprüngliche Formatierung der Datei durch die erneute Anwendung der Definitionen wiederhergestellt.

So entfernen Sie übernommene Informationen aus einer Datei:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie in der Datei "Datei > Importieren > Elementdefinitionen".

    3. Lassen Sie im Aufklappmenü "Aus folgendem Dokument importieren" die Einstellung "Aktuell" aktiviert, wählen Sie "Bei Aktualisierung entfernen: Informationen aus Buch" und klicken Sie auf "Importieren".


Bücher / Arbeiten mit der Buchstruktur

Importieren von Formaten in ein strukturiertes Buch

Sie können Formatierungsinformationen, z. B. Seitenlayout, Absatzformate und Referenzseiten, in die Dateien eines Buches importieren. Sie können auch irreguläre Formate in den Dateien entfernen, z. B. eine Schriftänderung in einem Absatz, der nicht im Absatzformat gespeichert wurde.

Wichtig: In Formatregeln für Elementdefinitionen werden häufig irreguläre Formate festgelegt, damit eine Datei mit so wenigen Katalogformaten wie möglich auskommt. In der Regel sollten irreguläre Formate beim Importieren von Formaten in ein strukturiertes Buch nicht entfernt werden. Eine ausführliche Beschreibung von irregulären Formaten finden Sie unter Irreguläre Formate.

Allgemein gilt, dass FrameMaker beim Import von Formaten die neuen Formatinformationen in ein Dokument zusammenfügt, anstatt vorhandene Informationen zu ersetzen.

So importieren Sie Formate in ein Buch:

    1. Öffnen oder erstellen Sie die Datei, deren Formate Sie verwenden möchten. Die Datei muss benannt und gespeichert worden sein.

    2. Wählen Sie im Buchfenster die gewünschten Dateien aus und wählen Sie dann "Datei > Importieren> Formate".

    3. Wählen Sie aus dem Aufklappmenü "Import aus Dokument" das Dokument oder die Schablone. In dem Menü sind alle Dokumente aufgelistet, die sowohl geöffnet als auch gespeichert sind.

    4. Wählen Sie unter "Importieren und aktualisieren" die Einstellungen, die auf die Dateien im Buch angewendet werden sollen. (Einzelheiten über diese Einstellungen finden Sie unter Importieren und Aktualisieren von Formaten.)

Wenn Sie Querverweisformate, FrameMath-Definitionen oder Variablendefinitionen aktualisieren und eines dieser Elemente Zeichenformate verwendet, wählen Sie auch "Zeichenformate", damit diesen Dateien alle neuen Formate hinzugefügt werden.

    5. Wenn Sie Formatierungsänderungen, die Sie nicht in einem Katalog gesichert haben, löschen möchten, führen Sie eine der folgenden Aktionen aus:

    Um Seitenumbrüche, die nicht Teil eines Absatzformats sind, zu entfernen, wählen Sie "Manuelle Seitenumbrüche".

    Um irreguläre Zuweisungen aus Absätzen, Zeichen und dem Seitenlayout sowie der Tabellenformatierung zu entfernen, wählen Sie "Manuelle Format-/Layoutänderungen".

In den meisten Fällen sollten Sie "Manuelle Format-/Layoutänderungen" in einem strukturierten Buch nicht verwenden, da die Elementdefinitionen irreguläre Formate verwenden. In einem nicht strukturierten Buch hat dies keine Auswirkungen.

    6. Klicken Sie auf "Importieren". Die Formatierungsinformationen werden in die Dateien eingelesen.


Änderungsverwaltung

Änderungsverwaltung

Änderungsbalken

Vergleichen von Dokumentversionen

Ermitteln der Wort- oder Zeichenanzahl

Verfolgen von Textänderungen


Änderungsverwaltung

Sie können zur Verfolgung von Änderungen an Dokumenten folgende Methoden anwenden:

    Sie können Änderungsbalken hinzufügen, um neue oder geänderte Textstellen zu kennzeichnen.

    Wenn Sie ein Dokument erhalten, das nicht gekennzeichnete Änderungen enthält, oder wenn Sie nähere Erläuterungen zu erfolgten Änderungen wünschen, können Sie die neue Version mit einer älteren vergleichen.

    Sie können die Funktion zum Verfolgen von Textänderungen verwenden.

Sie können Kommentare zu Änderungen auch mithilfe von bedingtem Text einfügen (siehe Bedingter Text).


Änderungsverwaltung

Änderungsbalken

Ein Änderungsbalken ist eine vertikale Linie (normalerweise am Rand), die neuen oder überarbeiteten Text visuell kennzeichnet. Wenn alle Ihre Änderungen markiert werden sollen, können Sie Änderungsbalken immer dann automatisch anzeigen lassen, wenn Sie Text einfügen, ändern oder löschen.

Änderungsbalken kennzeichnen neuen oder überarbeiteten Text.

Eventuell möchten Sie nicht alle Änderungen, sondern nur die wichtigsten Änderungen in Ihrem Dokument kennzeichnen. Wenn Sie z. B. die zweite Überarbeitung eines Dokuments zur Prüfung freigeben, soll nicht jedes neue Komma oder jeder umgestellte Satz gekennzeichnet werden. Stattdessen soll sich der Prüfer auf die wesentlichen Änderungen konzentrieren können. In solchen Fällen können Sie nur bestimmten Text mit Änderungsbalken versehen, anstatt diese automatisch hinzuzufügen.

Bei der Arbeit mit strukturierten Dokumenten bietet sich das manuelle Hinzufügen von Änderungsbalken an, um wenige Änderungen zu markieren oder um Struktur-, Attribut- oder Formatänderungen zu kennzeichnen. Ihre spezielle Anwendung enthält unter Umständen ein zu diesem Zweck definiertes Element.

Hinweis: Beim Arbeiten mit strukturierten Dokumenten erkennen Änderungsbalken keine Änderungen, die nur die Struktur (zum Beispiel, wenn Sie ein Element ausgliedern), Attribute oder das Format betreffen.

Zu einem späteren Zeitpunkt kann es notwendig sein, die Änderungsbalken aus dem Text zu entfernen. Beispielsweise möchten Sie alte Änderungsbalken aus einem Handbuchentwurf entfernen, bevor Sie neue hinzufügen.

Sie können in die neuere von zwei Dokumentversionen Änderungsbalken einfügen, indem Sie die Versionen miteinander vergleichen. Informationen zum Hinzufügen von Änderungsbalken auf diese Weise finden Sie unter Vergleichen von Dokumentversionen.

Hinweis: Wenn Sie einem gesamten Absatz Änderungsbalken hinzufügen und dann das Format des Absatzes ändern (indem Sie z. B. Formate aus einem anderen Dokument importieren), dürfen Sie während der Aktualisierung keine irregulären Formate entfernen, wenn Sie die Änderungsbalken beibehalten möchten. Das Hinzufügen von Änderungsbalken zu einem gesamten Absatz ändert das Absatzformat und diese Änderung wird als irreguläres Format betrachtet.

So fügen Sie Änderungsbalken automatisch hinzu:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Änderungsbalken".

    3. Legen Sie die Stärke des Änderungsbalkens und den Abstand zwischen Textspalte und Änderungsbalken fest.

    4. Legen Sie mithilfe des Aufklappmenüs "Position" die Position der Änderungsbalken fest. Aktivieren Sie "Seite, näher zu Blattrand" oder "Seite, weiter weg von Blattrand", wenn die Position des Änderungsbalkens abhängig vom Seitenlayout von Seite zu Seite variieren soll.

Die Position ist relativ zu den Rändern der Spalte, die den geänderten Text enthält, und zwar unabhängig von der Spaltenanzahl auf der Seite.

    5. Wählen Sie aus dem Aufklappmenü "Farbe" eine Farbe für die Änderungsbalken aus.

    6. Aktivieren Sie die Option "Automatische Anzeige" und klicken Sie auf "Zuweisen".

Änderungen an durch Referenz importierten Grafiken werden nicht mit automatischen Änderungsbalken versehen, es sei denn, der Name der importierten Datei hat sich geändert. Auch Änderungen, die nur die Formatierung betreffen, bleiben unbeachtet. Wenn Sie z. B. nur den Typ eines Absatzes vom Format "Haupttext" in das Format "Markiert" ändern, wird kein Änderungsbalken angezeigt. Sie können ihn jedoch in diesem Fall manuell hinzufügen.

Hinweis: Wenn die automatische Anzeige der Änderungsbalken aktiviert ist und Querverweise aktualisiert werden, werden alle geänderten Querverweise mit Änderungsbalken versehen.

So versehen Sie ausgewählten Text manuell mit Änderungsbalken:

Wählen Sie den gewünschten Text aus und wählen Sie "Format > Stil > Änderungsbalken". Sie können auch die Standardschrift-Einstellungen der Absatzgestaltung verwenden.

So versehen Sie einen gesamten Absatz manuell mit Änderungsbalken:

    1. Klicken Sie in einen Absatz oder ziehen Sie mit der Maus über mehrere Absätze. (Sie müssen nicht einen gesamten Absatz auswählen.)

    2. Wählen Sie "Format > Absätze > Gestaltung" und zeigen Sie die Standardschrift-Einstellungen an.

    3. Wählen Sie "Änderungsbalken" und klicken Sie auf "Zuweisen (Auswahl)".


Änderungsverwaltung / Änderungsbalken

Zuweisen von Änderungsbalken mithilfe eines Zeichenformats

Eine weitere Möglichkeit, einem Text Änderungsbalken zuzuweisen, besteht in der Verwendung eines Zeichenformats. Sobald Sie das Zeichenformat definiert haben, wählen Sie den Text aus und weisen ihm das Zeichenformat zu (siehe Zuweisen von vordefinierten Formaten zu Text). Mit dieser Methode können Sie Änderungsbalken auch beibehalten, wenn Sie das Dokument mit neuen Absatzformaten aktualisieren und irreguläre Formate entfernen.

Wenn Sie Text mithilfe eines Zeichenformats als geändert markieren, können Sie die Änderungsbalken auf jede der im nächsten Abschnitt beschriebenen Arten wieder entfernen. Die einzige Möglichkeit, den Formattyp vom Text zu entfernen, besteht allerdings darin, den Text auszuwählen und ihm die Standardschrift [image] des Absatzes aus dem Zeichenformat-Katalog zuzuweisen.

So definieren Sie ein Zeichenformat, das Änderungsbalken hinzufügt:

    1. Klicken Sie in einen beliebigen Absatz und wählen Sie "Format > Zeichen > Gestaltung".

    2. Wählen Sie im Dialogfenster "Zeichengestaltung" aus dem Aufklappmenü "Befehle" den Eintrag "Alle Einstellungen auf 'Beibehalten'".

    3. Wählen Sie "Änderungsbalken" und anschließend "Neues Format" aus dem Aufklappmenü "Befehle".

    4. Geben Sie eine Typbezeichnung ein und klicken Sie auf "In Katalog einfügen".

    5. Klicken Sie auf "Anlegen".


Änderungsverwaltung / Änderungsbalken

Entfernen von Änderungsbalken

Sie können die Änderungsbalken in einem Dokument einzeln oder vollständig entfernen. Ebenso können Sie die Änderungsbalken für ein einzelnes Dokument oder für bestimmte Dateien in einem Buch entfernen.

So löschen Sie alle Änderungsbalken in einem Dokument:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Änderungsbalken".

    3. Aktivieren Sie die Option "Alle Änderungsbalken löschen" und klicken Sie auf "Zuweisen".

So entfernen Sie einzelne Änderungsbalken:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie den Text aus und wählen Sie "Format > Stil > Änderungsbalken". Sie können auch die Standardschrift-Einstellungen der Absatzgestaltung verwenden. Wenn ein Teil des ausgewählten Textes nicht mit einem Änderungsbalken gekennzeichnet ist, müssen Sie "Format > Stil > Änderungsbalken" zweimal auswählen, um die Änderungsbalken zu entfernen.

    Um einen Änderungsbalken zu entfernen, der über ein Zeichenformat zugewiesen wurde, wählen Sie den Text aus, und weisen Sie ihm die Standardschrift [image] aus dem Zeichenformat-Katalog zu (siehe Zuweisen von vordefinierten Formaten zu Text).

Um Text zu untersuchen und zu ändern, der mit Änderungsbalken gekennzeichnet ist, verwenden Sie den Befehl "Suchen/Ändern". Sie können nach Text suchen, dem die Einstellung "Änderungsbalken" zugewiesen ist, oder nach Text, der das entsprechende Zeichenformat besitzt. Informationen hierzu finden Sie unter Suchen eines beliebigen Elements und Suchen nach Zeichenformateinstellungen.


Änderungsverwaltung

Vergleichen von Dokumentversionen

Wenn Sie zwei Versionen eines Dokuments vergleichen, legt FrameMaker folgende Dokumente an:

    Das kombinierte Dokument ist ein Bedingungsdokument, das die neuere Version mit der älteren Version vergleicht. Es zeigt die Unterschiede nebeneinander an. Sie können den Bedingungstyp angeben, der geändertem Text zugewiesen werden soll, und festlegen, ob die Änderungen durch Änderungsbalken gekennzeichnet werden sollen.

    Das Auswertungsdokument enthält eine allgemeine Auswertung und eine Überarbeitungsliste für jeden verglichenen Elementtyp. Sie können die Auswertung als Hypertext-Dokument mit Verknüpfungen zu den geänderten Seiten erstellen. Auf diese Weise lassen sich geänderte Seiten schnell anzeigen, wenn Sie diese lesen oder bearbeiten möchten.

Informationen über das Vergleichen von Büchern finden Sie unter Vergleichen von Büchern.

Hinweis: Wenn Sie Dokumente, die Tabellen enthalten, oder umfangreiche Dokumente vergleichen, müssen Sie unter Umständen den Swap-Speicher (UNIX) für Ihre Anwendung vergrößern.

So vergleichen Sie zwei Versionen eines Dokuments:

    1. Öffnen Sie beide Versionen des Dokuments. Wenn beide Dokumente bedingten Text enthalten, müssen alle Bedingungen eingeblendet sein.

    2. In der neueren Version wählen Sie "Datei > Dienstprogramme > Dokumente vergleichen".

    3. Wählen Sie die ältere Version aus dem Aufklappmenü und geben Sie die Dokumente an, die FrameMaker für Sie erstellen soll. Das Aufklappmenü "Älteres Dokument" enthält alle geöffneten und benannten Dokumente (mit Ausnahme des aktuellen Dokuments).

    4. Klicken Sie auf "Optionen", führen Sie die folgenden Aktionen aus und klicken Sie auf "Zuweisen":

    Geben Sie unter "Einfügungen markieren mit" an, wie eingefügter Text angezeigt werden soll. Sie können den voreingestellten Bedingungstyp wählen ("Eingefügt"), einen anderen Bedingungstyp auswählen oder den eingefügten Text nicht markieren.

    Geben Sie unter "Löschungen markieren mit" an, wie eingefügter Text angezeigt werden soll. Sie können den voreingestellten Bedingungstyp ("Gelöscht"), einen anderen Bedingungstyp oder einen selbst festgelegten Text wählen. Um zu verhindern, dass gelöschter Text in das kombinierte Dokument aufgenommen wird, klicken Sie auf "Ersetzungstext" und lassen das Textfeld leer.

    Um alle Änderungen (Einfügungen und Löschungen) im kombinierten Dokument mit Änderungsbalken zu markieren, aktivieren Sie die Option "Änderungen durch Änderungsbalken markieren". FrameMaker verwendet dann die aktuellen Einstellungen der Änderungsbalken für dieses Dokument.

Wenn Sie lediglich der neueren Version eines Dokuments Änderungsbalken hinzufügen wollen, wählen Sie "Änderungen durch Änderungsbalken markieren". Klicken Sie dann unter "Löschungen markieren mit" auf "Ersetzungstext" und lassen Sie das Textfeld "Ersetzung" leer.

    5. Klicken Sie auf "Vergleichen". Wenn der Vergleich abgeschlossen ist, zeigt FrameMaker die Auswertung und das kombinierte Dokument an. Wenn beide Versionen gleich sind, wird kein Dokument erstellt.

Informationen über die verglichenen Dokumente und über Form und Inhalt des Auswertungsdokuments und des kombinierten Dokuments finden Sie unter Kombinierte Dokumente und Auswertungsdokumente.

    6. Um die Auswertung in ein Hypertext-Dokument umzuwandeln, aktivieren Sie die Option "Hypertext-Verbindungen in Auswertung anlegen". Wenn Sie in der Auswertung auf die Seitenzahl der Änderung klicken, zeigt FrameMaker die Seite an. Sie können sich Seiten der neueren Version, Seiten der älteren Version oder das kombinierte Dokument anzeigen lassen, das die Änderung enthält.


Änderungsverwaltung / Vergleichen von Dokumentversionen

Vergleichen von Dokumenten, die mehrere Textflüsse enthalten

Sie können Dokumente mit mehreren Textflüssen vergleichen. Damit FrameMaker nicht die falschen Textflüsse vergleicht, müssen Sie jedoch sicherstellen, dass jeder Textfluss einen eindeutigen Typ aufweist und dass die Textflüsse, die verglichen werden sollen, vom selben Typ sind. Informationen darüber, wie Sie einen Textflusstyp ändern, finden Sie unter Ändern von Textflusstypen und automatischer Verkettung.

Wenn ein Dokument mehrere Textflüsse mit dem gleichen Namen enthält (z. B. mehrere Textflüsse mit Namen "A" auf unverketteten Seiten), wird beim Vergleichen der Dokumente ein Meldungsfenster angezeigt, in dem alle doppelten Textflüsse aufgelistet werden. Textflüsse werden nur verglichen, wenn in beiden Dokumenten ein Textfluss mit dem gleichen Namen vorkommt.


Änderungsverwaltung / Vergleichen von Dokumentversionen

Vergleichen von Dokumenten, die bedingten Text enthalten

Beim Vergleich von Dokumenten mit bedingtem Text ignoriert FrameMaker verborgenen Text und Grafiken.

So vergleichen Sie Dokumente, die bedingten Text enthalten:

    1. Führen Sie eine der folgenden Aktionen aus:

    Um den gesamten Text zweier Dokumente zu vergleichen, die bedingten Text enthalten, zeigen Sie alle Bedingungen an, bevor Sie den Vergleich durchführen. Weitere Informationen finden Sie unter Ändern der Darstellung von Bedingungsdokumenten.

    Um den bestimmte Texte in zwei Dokumenten zu vergleichen, die bedingten Text enthalten, zeigen Sie Bedingungen auf der Grundlage eines bestimmten Ausdrucks an, bevor Sie den Vergleich durchführen.

    Wenn bedingter Text beim Dokumentvergleich ignoriert werden soll, müssen Sie vor dem Vergleich den bedingten Text ausblenden.

    2. Vergleichen Sie die Dokumente (siehe Vergleichen von Dokumentversionen).

Alle ausgeblendeten bedingten Elemente im neueren Dokument bleiben im kombinierten Dokument verborgen.

Hinweis: Alle ausgeblendeten bedingten Elemente im neueren Dokument bleiben im kombinierten Dokument verborgen.


Änderungsverwaltung / Vergleichen von Dokumentversionen

Kombinierte Dokumente und Auswertungsdokumente

Wenn Sie Dokumente vergleichen, erstellt FrameMaker zwei Dokumente und zeigt das Ergebnis des Vergleichs an.

Kombinierte Dokumente

Im kombinierten Dokument betrachtet FrameMaker Unterschiede als Einfügungen oder Löschungen. Wenn sich z. B. der Inhalt eines Grafikrahmens geändert hat, werden im kombinierten Dokument beide Versionen angezeigt. Die ältere Version wird als Löschung, die neuere als Einfügung markiert. Variablen im kombinierten Dokument verwenden die neueren Definitionen, werden aber nicht als Änderung markiert. Nur eingefügte oder gelöschte Variablen werden als Änderungen betrachtet.

Auswertungsdokument

Im Auswertungsdokument (mit dem Namen Auswrtng.fm) werden Unterschiede als Einfügungen, Löschungen oder Änderungen betrachtet. Wenn ein Element verschoben wurde, wird es als gelöscht und als eingefügt markiert. FrameMaker zeigt die Nummer der Seite an, auf der die Änderung in der neueren Version, in der älteren Version und im kombinierten Dokument zu finden ist. Bei Einfügungen bezeichnet die Seitennummer für die ältere Version die Seite, auf der das Element entsprechend der neueren Version eingefügt werden müsste. Bei Löschungen bezeichnet die Seitennummer für die neuere Version die Seite, auf der sich das Element befinden würde, wäre es nicht gelöscht worden.

Wenn Ihr Dokument doppelte Marken enthält, zeigt das Auswertungsdokument das erste Auftreten an. Alle weiteren Auftreten können Sie mit dem Befehl "Suchen/Ändern" finden.

Hinweis: Wenn Sie mehrere Auswertungsdokumente erstellen, sollten Sie jede Datei entsperren, indem Sie Esc d Umschalttaste+y drücken und jedem Dokument mit dem Befehl "Sichern unter" einen eindeutigen Namen geben.


Änderungsverwaltung / Vergleichen von Dokumentversionen

Verglichene Elemente

Beim Vergleich zweier Dokumentversionen prüft FrameMaker den Inhalt von Textflüssen gleichen Namens auf Arbeits- und Referenzseiten. Dabei werden Text, Fußnoten, verankerte Rahmen, Tabellen, Variablen und ihre Definitionen, Querverweise und ihre Formate, Fußnotentext sowie Markentypen und -text berücksichtigt. FrameMaker vergleicht keine Strukturelemente, sondern die Elementinhalte.

Die folgende Aufstellung enthält einige spezielle Unterschiede, die FrameMaker ausfindig machen kann.

Verankerte Rahmen

FrameMaker vergleicht die Objekte innerhalb des Rahmens. Sind diese unterschiedlich oder an einer anderen Position (weil Sie z. B. ihre Reihenfolge im Rahmen geändert haben), markiert FrameMaker den gesamten verankerten Rahmen als geändert.

Querverweise

FrameMaker prüft, ob es sich um einen externen oder um einen internen Querverweis handelt. Außerdem wird der Name des Querverweisformats, der Markentext an der Quelle und der Pfadname der referenzierten Datei (bei externen Querverweisen) geprüft. Ist eines dieser Elemente unterschiedlich, markiert FrameMaker den Querverweis als geändert.

Texteinschübe

FrameMaker vergleicht das Änderungsdatum, den Dateinamen, die relativen Pfadnamen der Texteinschübe und die Art und Weise, wie der Texteinschub importiert wurde (z. B. ob Zeilenenden als Zeilenumbrüche eingelesen wurden). Ist eines dieser Elemente unterschiedlich, wird der gesamte Texteinschub als geändert markiert.

Importierte Grafiken

FrameMaker vergleicht Inhalt und Auflösung der importierten Grafik. Dabei wird beispielsweise geprüft, ob ein Objekt gespiegelt oder gedreht wurde oder ob sich die Größe des Bildrahmens geändert hat. Ferner wird verglichen, wie die Grafik importiert wurde: durch Referenz oder als Kopie. Wenn die Grafik durch Referenz importiert wurde, vergleicht FrameMaker die Pfadnamen. Wenn sich bei einer dieser Einstellungen ein Unterschied ergibt, wird die Zeile, in der sich der verankerte Rahmen der importierten Grafik befindet, als geändert markiert.

Gleichungen

FrameMaker vergleicht die Größe der Gleichung, ihre Position im Grafikrahmen und die mathematischen Ausdrücke. Ist eines dieser Elemente unterschiedlich, wird die gesamte Gleichung als geändert markiert.

Tabellen

FrameMaker vergleicht die Anzahl der Reihen und Spalten und prüft, ob Zellen verbunden oder gedreht sind. Unterscheidet sich eines dieser Elemente, markiert FrameMaker diejenige Zeile als geändert, die das Ankersymbol der Tabelle enthält. Wenn sich Text in Zellen geändert hat, wird lediglich die neue Tabelle im kombinierten Dokument angezeigt, und FrameMaker markiert die betreffende Zeile in der Zelle als geändert. Wenn sich mehr als 75 % der Zellen geändert haben, wird die gesamte Tabelle als geändert markiert.

Sowohl die englische Version als auch die japanische Version von FrameMaker kann auf einem japanischen Betriebssystem japanischen Text vergleichen. FrameMaker vergleicht jedoch nicht Textflüsse auf Vorgabeseiten (einschließlich Kopf- und Fußzeilen), Textflüsse ohne Typ, Grafikobjekte oder Textzeilen, die sich nicht in verankerten Rahmen befinden, Positionen verankerter Rahmen, Fußnoteneinstellungen oder -nummerierung, Absatz-, Zeichen- oder Tabellentypen, Text- oder Tabellenformatierung, Typen im Absatzformat-, Zeichenformat- oder Tabellenformat-Katalog und den Inhalt von Texteinschüben. Da FrameMaker die Formatierung von Text oder Tabellen nicht prüft, werden Unterschiede wie geänderte Lineatur oder Schattierung in einer Tabelle oder eine andere Textfarbe nicht erkannt.


Änderungsverwaltung

Ermitteln der Wort- oder Zeichenanzahl

Sie können die Anzahl der Wörter oder Zeichen in einem Dokument bestimmen. Das Zählen der Zeichen in einem Dokument ist vor allem für Dokumente in asiatischen Sprachen mit Zeichen doppelter Breite (Multibyte) geeignet. Die Wortanzahl gibt die Anzahl der Zeichen einfacher und doppelter Breite sowie die Gesamtzahl der Zeichen an.

So ermitteln Sie die Wortanzahl in einem Dokument:

    1. Wählen Sie "Datei > Dienstprogramme > Statistik".

    2. Wählen Sie "Zeichenanzahl" oder "Wortzählung" und klicken Sie auf "Ausführen".


Änderungsverwaltung

Verfolgen von Textänderungen

Sie können die Funktion zum Verfolgen von Textänderungen verwenden. Der hinzugefügte und entfernte Text wird markiert, sodass er leicht zu erkennen ist. Sie können durch die bearbeiteten Abschnitte navigieren und einzelne Bearbeitungen akzeptieren oder verwerfen. Außerdem können Sie eine Vorschau des Dokuments anzeigen lassen, um dessen ursprünglichen oder endgültigen Zustand zu sehen.

Hinweis: Änderungen an der Formatierung und Elementattributen werden nicht verfolgt.

Verfolgte Textänderungen | Nicht verfolgte Textänderungen
Hinzufügen und Löschen von Text mithilfe der Tastatur | Hinzufügen von Zeilen in Tabellen
Hinzufügen von Text zwischen gelöschtem Textabschnitten | Ändern der Inhalte in Querverweisen
Ausschneiden, Kopieren und Einfügen von Text | Änderung von Inhalten in Marken
Einfügen und Löschen von verankerten Rahmen | Änderung von Inhalten in Gleichungen
Hinzufügen, Bearbeiten und Löschen von Kopf- und Fußzeilen | Hinzufügen oder Löschen von Text mithilfe von APIs
Einfügen und Löschen von Fußnoten | Einfügen, Ändern und Löschen von Grafiken
Hinzufügen, Bearbeiten oder Löschen von Text in Fußnoten | Ändern der Formatierung
Ändern von Text mithilfe der Funktion "Suchen/Ändern" | Text innerhalb von Hypertext-Marken
Korrigieren von Rechtschreibfehlern mithilfe der Funktion "Rechtschreibhilfe" | Hinzufügen und Entfernen von Seitenumbrüchen
Ersetzen von Text mithilfe der Funktion "Thesaurus" | Konvertieren von Tabellen zu Text
Einfügen, Löschen und nach Kopieren und Einfügen aus der Zwischenablage von Querverweisen | Ersetzen von Variablen
Hinzufügen und Löschen von Marken | Ersetzen von Querverweisen
Importieren und Löschen von Dateien durch Referenz oder durch Kopieren | Hinzufügen und Löschen der Marke "Bedingter Text"
Einfügen, Einfügen aus der Zwischenablage und Löschen von Variablen | Importieren in MIF-Dateien durch Kopieren
Bearbeiten von Text innerhalb einer Tabellenzelle | Einfügen von Rubi-Elementen
Einfügen, Einfügen aus der Zwischenablage und Löschen von Variablen
Einfügen und Löschen von Gleichungen
Änderungen an Text in Rubi
Verfolgte Textänderungen | Nicht verfolgte Textänderungen
Einfügen von Elementen mithilfe der Eingabetaste | Löschen von Stammelementen
Einfügen oder Löschen von Text in einem Element | Bearbeiten von Elementattributen
Löschen von Elementen | Zusammenfügen von Elementen
Ausschneiden, Kopieren und Einfügen von Text | Teilen von Elementen
 | Ausgliedern und Eingliedern von Text
 | Ziehen oder Ablegen von Elementen im Strukturansichtsfenster


Änderungsverwaltung / Verfolgen von Textänderungen

Aktivieren oder Deaktivieren der Verfolgung von Textänderungen

Sie müssen die Funktion zur Verfolgung von Textänderungen aktivieren, um Ihre Änderungen am Text verfolgen zu können. Standardmäßig ist die Verfolgung von Textänderungen deaktiviert.

So zeigen Sie die Leiste zum Verfolgen von Textänderungen an:

    1. Öffnen Sie das zu bearbeitende FrameMaker-Dokument.

    2. Wählen Sie "Darstellung > Leiste zum Verfolgen von Textänderungen".

So aktivieren Sie die Verfolgung von Textänderungen:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Spezial > Verfolgung von Textänderungen > Aktivieren".

    Klicken Sie auf das Symbol [image] in der Leiste zum Verfolgen von Textänderungen.

So deaktivieren Sie die Verfolgung von Textänderungen:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Spezial > Verfolgung von Textänderungen > Aktivieren".

    Klicken Sie auf das Symbol [image] in der Leiste zum Verfolgen von Textänderungen.

Sowohl Autoren als auch Prüfer können die Funktion zum Verfolgen und Anzeigen von Textänderungen verwenden.


Änderungsverwaltung

Verfolgen von Textänderungen

Wenn Sie mit der Eingabe von Text in einem Dokument beginnen, für das die Funktion zur Verfolgung von Textänderungen aktiviert ist, wird die Zeichenfolge "(FM8_TRACK_CHANGES_ADDED)" oder "(FM8_TRACK_CHANGES_DELETED)" links der Statusleiste des Dokumentfensters angezeigt. Hinzugefügter Text wird in dunkelgrüner Schrift und gelöschter Text durchgestrichen und in roter Schrift angezeigt.


Änderungsverwaltung / Verfolgen von Textänderungen

Speichern eines Dokuments mit Textänderungen im XML-Format

Sie können ein Dokument mit verfolgten Textänderungen im XML-Format speichern. Sie können das XML-Dokument in FrameMaker öffnen, die Verfolgung von Textänderungen aktivieren und dann das Dokument bearbeiten. Wenn Sie das FrameMaker-Dokument dann wieder im XML-Format speichern, bleiben die Änderungsinformationen über den XML-Roundtripping-Prozess hinweg erhalten.

Wenn die für das Bearbeiten und Speichern als XML-Datei verwendete Anwendung das Roundtripping von ConditionalText-Verarbeitungsanweisungen (PIs) deaktiviert, gehen alle Informationen bezüglich der Verfolgung von Textänderungen während des XML-Roundtripping verloren. Standardmäßig ist das Roundtripping für bedingten Text für jede XML-Anwendung aktiviert, es sei denn, Sie nehmen in strukturierten Anwendungen andere Einstellungen für die Verwendung des ConditionalText-Elements vor.


Änderungsverwaltung / Verfolgen von Textänderungen

Suchen von Textänderungen in Dokumenten

Sie können spezifische Textänderungen suchen.

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Spezial > Verfolgung von Textänderungen" und dann "Nächste Änderung anzeigen" oder "Vorherige Änderung anzeigen".

    Klicken Sie auf die Symbole für "Nächste Änderung anzeigen" oder "Vorherige Änderung anzeigen" ( [image] ) in der Leiste zum Verfolgen von Textänderungen.


Änderungsverwaltung / Verfolgen von Textänderungen

Annehmen oder Ablehnen von Textänderungen

Sie können jede Textänderung einzeln oder alle Textänderungen auf einmal annehmen oder ablehnen.

So nehmen Sie einzelne Textänderungen an oder lehnen sie ab:

    1. Wählen Sie die Textänderung aus und führen Sie eine der folgenden Aktionen durch:

    Wählen Sie "Spezial > Verfolgung von Textänderungen > Änderung annehmen".

    Klicken Sie auf das Symbol [image] in der Leiste zum Verfolgen von Textänderungen.

    2. Wählen Sie die Textänderung aus und führen Sie eine der folgenden Aktionen durch:

    Wählen Sie "Spezial > Verfolgung von Textänderungen > Änderung ablehnen".

    Klicken Sie auf das Symbol [image] in der Leiste zum Verfolgen von Textänderungen.

So nehmen Sie alle Textänderungen an oder lehnen sie ab:

    Wählen Sie "Spezial > Verfolgung von Textänderungen" und dann "Alle Änderungen annehmen" oder "Alle Änderungen ablehnen".

    Klicken Sie auf die Symbole für "Alle Änderungen annehmen" oder "Alle Änderungen ablehnen" ( [image] ) in der Leiste zum Verfolgen von Textänderungen.

Sobald Sie eine Einfügung oder Löschung annehmen, wird diese in die Datei aufgenommen. Wenn Sie eine Texthinzufügung annehmen, wird der Text beibehalten. Wenn Sie eine Textlöschung annehmen, wird der entsprechende Text entfernt. Wenn Sie eine Texthinzufügung ablehnen, wird der eingefügte Text entfernt. Wenn Sie eine Löschung ablehnen, bleibt der Text in der Datei erhalten. Die Formatierung von eingefügtem oder beibehaltenem Text richtet sich nach dem umgebenden Text.


Änderungsverwaltung / Verfolgen von Textänderungen

Vorschau eines Dokuments mit Textänderungen

Vor dem Annehmen aller Textänderungen können Sie sich eine Vorschau des endgültigen Dokuments mit allen vorgenommenen Textänderungen anzeigen lassen. Alternativ dazu können Sie sich eine Vorschau der Originalversion des Dokuments ohne die vorgenommenen Textänderungen anzeigen lassen.

Sie können ein Dokument mit verfolgten Textänderungen in zwei verschiedenen Modi anzeigen: im Verfolgungsmodus oder im Vorschaumodus. Wenn Sie ein Dokument mit Textänderungen in der Vorschau anzeigen, ändert sich die Anzeige des Dokuments vom Verfolgungsmodus zum Vorschaumodus.

Standardmäßig ist die Vorschau für Dokumente mit verfolgten Änderungen deaktiviert (der Befehl "Vorschau aus" unter "Verfolgung von Textänderungen" im Menü "Spezial" ist deaktiviert). Sie müssen die Vorschau aktivieren, indem Sie die Optionen "Vorschau endgültige Version" oder "Vorschau Originalversion" auswählen.

Hinweis: Die Befehle "Vorschau endgültige Version" oder "Vorschau Originalversion" können in einem Dokument nicht rückgängig gemacht werden.

So zeigen Sie eine Vorschau des endgültigen Dokuments mit Textänderungen an:

    Wählen Sie "Spezial > Verfolgung von Textänderungen > Vorschau endgültige Version" aus.

    Klicken Sie auf das Symbol [image] in der Leiste zum Verfolgen von Textänderungen.

So zeigen Sie eine Vorschau der Originalversion des Dokuments ohne Textänderungen an:

    Wählen Sie "Spezial > Verfolgung von Textänderungen > Vorschau Originalversion" aus.

    Klicken Sie auf das Symbol [image] in der Leiste zum Verfolgen von Textänderungen.

Bei Annahme der Änderungen werden diese in das Dokument aufgenommen. Bei Ablehnung der Änderungen werden diese gelöscht und der ursprüngliche Zustand des Dokuments wird wieder hergestellt.

Hinweis: Bei der ersten Auswahl von "Vorschau endgültige Version" oder "Vorschau Originalversion" in einem Dokument ist die Option "Vorschau aus" aktiviert.

Wenn Sie das Dokument bei aktivierter Option "Vorschau endgültige Version" oder "Vorschau Originalversion" ändern und wenn zugleich die Funktion zum Verfolgen von Textänderungen aktiviert ist, schaltet FrameMaker vom Vorschaumodus in den Verfolgungsmodus um. Wenn Sie in diesem Modus Änderungen am Text vornehmen, können Sie diese Änderungen nicht rückgängig machen.

So deaktivieren Sie den Vorschaumodus:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Spezial > Verfolgung von Textänderungen > Vorschau aus".

    Klicken Sie auf das Symbol in der Leiste zum Verfolgen von Textänderungen.


Änderungsverwaltung / Verfolgen von Textänderungen

Speichern und Veröffentlichen von Dokumenten mit Textänderungen

Wenn Sie ein Dokument nach dem Einfügen von Textänderungen speichern, bleiben die vorgeschlagenen Änderungen erhalten.

Wenn Sie das Dokument als PDF-Datei ausgeben möchten, bleiben die Textänderungen erhalten und sind im ausgegebenen Dokument sichtbar. Wenn Sie ein FrameMaker-Dokument als HTML- oder RTF-Datei ausgeben, werden die verfolgten Textänderungen angenommen und das Dokument wird mit dem geänderten Inhalt gespeichert. Ist der Vorschaumodus aktiviert, wird das Dokument je nach der von Ihnen ausgewählten Vorschauoption ("Vorschau endgültige Version" oder "Vorschau Originalversion") ausgegeben.


Änderungsverwaltung / Verfolgen von Textänderungen

Drucken von Dokumenten mit verfolgten Textänderungen

Sie können ein FrameMaker-Dokument mit geändertem Text, wie etwa Hinzufügungen oder Löschungen, drucken. Textänderungen werden auf dieselbe Weise gedruckt, wie sie im FrameMaker-Dokument angezeigt werden.


Verwalten von Dateien mithilfe von WebDAV

Dateiverwaltung mithilfe von WebDAV (Windows)

Erste Schritte in der Arbeitsgruppenverwaltung

Verwalten von Dokumentverknüpfungen


Verwalten von Dateien mithilfe von WebDAV

Dateiverwaltung mithilfe von WebDAV (Windows)

FrameMaker unterstützt die WebDAV- (Web Distributed Authoring and Versioning-) Server-Technologie. Mit dieser Technologie können Sie eine Verbindung zu einem WebDAV-Server herstellen, Dokumente herunterladen und übertragen, den Zugriff auf die aktuellen selbst bearbeiteten Dokumente für Dritte sperren und Ihrem Server zusätzliche Dokumente hinzufügen (auf diesen übertragen). Verwenden Sie einen WebDAV-Server, wenn Sie bei der Arbeit in gemeinschaftlicher Umgebung das Problem verschiedener Dokumentversionen vermeiden wollen. Mithilfe von WebDAV können Sie Dateien so verwalten, dass kein Dokument verloren geht oder versehentlich überschrieben oder aktualisiert wird.


Verwalten von Dateien mithilfe von WebDAV / Dateiverwaltung mithilfe von WebDAV (Windows)

Funktionsweise von WebDAV

Die WebDAV-Technologie ermöglicht Ihnen, Dateien über ein modifiziertes Hypertext-Transferprotokoll zu lesen und zu erstellen. Die Dateien befinden sich auf dem Server in einer Verzeichnisstruktur und werden für die Bearbeitung auf dem lokalen Rechner "ausgecheckt". Die Verzeichnisstruktur des lokalen Rechners spiegelt dabei die Struktur des WebDAV-Servers wieder. Beim Auschecken einer Datei erfolgt das Herunterladen in den entsprechenden Ordner des lokalen Rechners.

Einer ausgecheckten Datei wird automatisch eine Web-Adresse (URL) zugewiesen. Dieser URL enthält Informationen zum Speicherort der Datei innerhalb der Verzeichnisstruktur und dient bei der Dateiverwaltung und dem Dateizugriff über Verknüpfungen. Weitere Informationen über Verknüpfungen finden Sie unter Verwalten von Dokumentverknüpfungen.


Verwalten von Dateien mithilfe von WebDAV / Dateiverwaltung mithilfe von WebDAV (Windows)

Weshalb WebDAV?

WebDAV bietet gegenüber gewöhnlichen Dateiservern zwei wesentliche Vorteile.

Arbeitsgruppenverwaltung

Wenn eine Datei mit einem WebDAV-Server verwaltet wird, ist es zwar möglich, Kopien dieser Datei auf mehrere Rechner herunterzuladen, die Datei kann jedoch immer nur von einer Person ausgecheckt werden. Die Person, die die Datei auscheckt, kann ihre Arbeit anderen Benutzern zugänglich machen, indem sie die Datei auf dem Server aktualisiert. Veränderungen können an der verwalteten Datei jedoch erst vorgenommen werden, wenn sie wieder eingecheckt ist. Dieses System ermöglicht einen gemeinschaftlichen Zugriff auf Dateien, verhindert dabei aber ein ungewolltes Überschreiben.

Dieser Prozess der Versionenkontrolle über die Weitergabe von Dokumenten von einer Person zur nächsten wird Arbeitsgruppenverwaltung genannt.

Externe Dateiverwaltung

Da WebDAV in Netzwerken läuft, auf die über das Internet zugegriffen werden kann, spielt der jeweilige physische Standort keine Rolle. Teammitglieder können unabhängig von Entfernungen gemeinsam auf Dateien zugreifen.

Verwaltete Dokumente

Verwaltete Dokumente sind als FrameMaker-Dokumente und Buchdateien definiert. Als Verknüpfungen werden Dateien, Grafiken oder Hypertext-Links in den Dokumenten oder Buchdateien bezeichnet.


Verwalten von Dateien mithilfe von WebDAV

Erste Schritte in der Arbeitsgruppenverwaltung

Um die Funktionen zur Arbeitsgruppenverwaltung von FrameMaker verwenden zu können, müssen Sie in der Lage sein, eine Verbindung zu einem WebDAV-Server herzustellen. Ist die Verbindung hergestellt, müssen Sie für jedes Dokument einen URL angeben. Mit diesen Voraussetzungen können Sie Arbeitsgruppen verwalten und WebDAV erfolgreich anwenden. In FrameMaker 8 können Sie XML-Dateien sowie FM- und MIF-Dateien, die sich auf dem WebDAV-Server befinden, erstellen und bearbeiten. Für XML-Dateien müssen Sie die Lese-/Schreibregeln und alle verbundenen Dateien einzeln vom Server herunterladen.

Weitere Information über WebDAV finden Sie unter www.webdav.org.


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Anforderungen an WebDAV-Server

Für verschiedene WebDAV-Server gibt es unterschiedliche Authentifizierungsanforderungen. Bei einigen Servern muss für jeden Vorgang ein Benutzername und ein Passwort eingegeben werden. Bei anderen Servern ist eine Authentifizierung nur beim ersten Auschecken eines verwalteten Dokuments erforderlich. Wenn das Dialogfenster "Authentifizierung" angezeigt wird, geben Sie Ihren Benutzernamen und das Passwort ein und klicken auf "OK".

Wenn Sie der Arbeitsgruppenumgebung einen neuen Server hinzufügen, müssen Sie einen eindeutigen Servernamen angeben (dieser erscheint in der Liste der Arbeitsgruppenserver), außerdem einen URL für den Server sowie das lokale Verzeichnis, dem das Serververzeichnis zugeordnet werden soll.

Wichtig: Firewall-Software kann den Verbindungsprozess zu einem WebDAV-Server beeinflussen. Fragen Sie den Systemadministrator oder suchen Sie in der Dokumentation zur Firewall-Software nach Informationen zum Festlegen der Firewall- und Proxy-Konfigurationseinstellungen für den Zugriff auf externe Server.

So richten Sie einen Server für die Verwendung mit FrameMaker ein:

    1. Wählen Sie "Datei > Arbeitsgruppe > Arbeitsgruppenserver".

    2. Wählen Sie einen aktuell im Dialogfenster aufgelisteten Server aus oder klicken Sie auf "Neuer Server", um einen zusätzlichen Server auszuwählen.

    3. Geben Sie einen Servernamen und einen Server-URL an. Beim Einrichten des Servers ist die Eingabe des Benutzernamens und des Passworts optional. Wenn Sie Dateien übertragen oder herunterladen, müssen Sie jedoch einen Benutzernamen und ein Passwort angeben.

    4. Legen Sie fest, in welchem Ordner Sie die lokalen Kopien verwalteter Dokumente speichern wollen. Wenn Sie den standardmäßigen Speicherort ändern wollen, klicken Sie auf "Wählen" und geben einen anderen Ordner an.

    5. Klicken Sie auf "OK", um die Serverinformationen zu speichern.

    6. Klicken Sie auf "Fertig", um das Dialogfenster "Arbeitsgruppenserver" zu schließen.


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Festlegen der Voreinstellungen für verwaltete Dokumente und deren Verknüpfungen

Wenn in den Arbeitsgruppen-Voreinstellungen festgelegt wird, alle Verknüpfungen herunterzuladen, werden beim Öffnen einer Buchdatei alle im Buch enthaltenen Dateien sowie alle Verknüpfungen in den einzelnen Dateien ebenfalls heruntergeladen. Wird in den Voreinstellungen festgelegt, dass keine Verknüpfungen heruntergeladen werden sollen, müssen Sie die Dateien und ihre Verknüpfungen manuell herunterladen.

So legen Sie die Voreinstellungen zum Öffnen verwalteter Dokumente fest:

    1. Wählen Sie "Datei > Voreinstellungen > Arbeitsgruppe".

    2. Wählen Sie die folgenden Optionen für "Auschecken von Server":

    Immer checkt das Dokument beim Öffnen automatisch aus.

    Fragen zeigt beim Öffnen eines eingecheckten Dokuments ein Dialogfenster an.

    Nie öffnet die lokale Kopie des Dokuments, ohne es auszuchecken oder ein Dialogfenster anzuzeigen.

    3. Wählen Sie eine der folgenden Optionen für das Aktualisieren vom Server (betrifft nur eingecheckte Dokumente):

    Immer lädt die neueste Dokumentversion automatisch vom Server herunter.

    Fragen zeigt ein Dialogfenster an, wenn das Dokument auf dem Server aktualisiert worden ist.

    Nie öffnet die lokale Kopie des Dokuments, ohne ein Dialogfenster anzuzeigen oder die neueste Dokumentversion vom Server herunterzuladen.

    4. Wählen Sie eine der folgenden Optionen für "Nicht-Hypertext-Verknüpfungen beim Öffnen des Dokuments aktualisieren" (betrifft importierte Grafiken, Texteinschübe und andere Nicht-Hypertext-Verknüpfungen):

    Immer aktualisiert beim Öffnen eines Dokuments die Verknüpfungen automatisch.

    Fragen zeigt beim Öffnen eines Dokuments mit verwalteten Verknüpfungen ein Dialogfenster an.

    Nie öffnet die lokale Kopie des Dokuments, ohne ein Dialogfenster anzuzeigen oder Verknüpfungen zu aktualisieren.

    5. Wählen Sie eine der folgenden Optionen für "Hypertext-Verknüpfungen beim Öffnen des Dokuments aktualisieren" aus:

    Immer aktualisiert beim Öffnen eines Dokuments Hypertext-Verknüpfungen automatisch.

    Fragen zeigt beim Öffnen eines Dokuments mit Hypertext-Verknüpfungen ein Dialogfenster an.

    Nie öffnet die lokale Kopie des Dokuments, ohne ein Dialogfenster anzuzeigen oder Hypertext-Verknüpfungen zu aktualisieren.

Hinweis: Bei Auswahl der Optionen "Immer" oder "Fragen" werden alle Verknüpfungen in einer Index- oder einer Inhaltsverzeichnisdatei geöffnet. In Abhängigkeit von der Größe der Datei kann die Auswahl dieser Optionen dazu führen, dass das Öffnen der Datei länger dauert.

    6. Wählen Sie eine der folgenden Optionen für "Verknüpfungen und Dokument gleichzeitig einchecken":

    Immer checkt Verknüpfungen beim Einchecken eines Dokuments automatisch ein.

    Fragen zeigt beim Einchecken eines Dokuments mit Verknüpfungen ein Dialogfenster an.

    Nie checkt verknüpfte Dateien nicht ein, wenn ein Dokument eingecheckt wird.

    7. Klicken Sie auf "OK".

So deaktivieren Sie die WebDAV-Funktionen:

    1. Wählen Sie "Datei > Voreinstellungen > Arbeitsgruppe".

    2. Deaktivieren Sie die Option "Arbeitsgruppenfunktionalität aktivieren".

    3. Klicken Sie auf "OK". Die Optionen für WebDAV werden im Menü "Datei" erst angezeigt, wenn Sie die Funktionalität wieder aktivieren.


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Hinzufügen von Dokumenten zum Server

Nachdem Sie eine Verbindung zum WebDAV-Server erstellt haben, können Sie dem Server ein Dokument hinzufügen oder ein Dokument vom Server herunterladen, um den Arbeitsablauf zu beginnen.

So fügen Sie einem WebDAV-Server ein Dokument hinzu:

    1. Öffnen Sie das unverwaltete FrameMaker-Dokument und wählen Sie "Datei > Arbeitsgruppe > Sichern unter".

    2. Bestimmen Sie den Ordner und den Server, in dem die Datei gespeichert werden soll. Mithilfe der Schaltfläche "Neuer Ordner" können Sie auch neue Ordner auf dem Server erstellen.

    3. Falls nötig, müssen Sie den Dateinamen ändern und das Format wählen. Wenn Sie wollen, dass die Datei nach der Übertragung auf den Server nicht automatisch ausgecheckt wird, müssen Sie außerdem die Option "Ausgecheckt lassen" deaktivieren.

    4. Klicken Sie auf "Sichern". Die Datei wird auf den Server und in den Ordner mit den verwalteten Dateien kopiert. Das Dokument ist nun ein verwaltetes Dokument.


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Öffnen von Dokumenten vom WebDAV-Server

Um ein verwaltetes Dokument bearbeiten zu können, müssen Sie es zunächst auf den lokalen Rechner herunterladen und es dann auschecken.

So öffnen Sie ein Dokument vom WebDAV-Server:

    1. Wählen Sie "Datei > Arbeitsgruppe > Öffnen".

    2. Wählen Sie die Datei, die Sie vom angegebenen Server öffnen wollen, und klicken Sie auf "Öffnen". Das Dokument wird auf den lokalen Rechner heruntergeladen und im entsprechenden Ordner gespeichert. Jeder lokale Rechner besitzt eine Verzeichnisstruktur, die die WebDAV-Serverstruktur widerspiegelt.

Hinweis: In Abhängigkeit von den Arbeitsgruppen-Voreinstellungen lädt FrameMaker alle verknüpften Dateien automatisch herunter oder fragt nach, ob alle verknüpften Dateien heruntergeladen werden sollen.


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Speichern von Dokumenten im XML-Format auf WebDAV

Mit der WebDAV-Funktion können Sie XML-Dokumente auf dem WebDAV-Server erstellen, bearbeiten und speichern.

    1. Wählen Sie im strukturierten FrameMaker den Befehl "Arbeitsgruppe > Sichern als" aus.

    2. Wählen Sie im Dialogfenster "Auf Server sichern" den Server und den Ordner aus, auf bzw. in dem Sie die Datei ablegen möchten. Mithilfe der Schaltfläche "Neuer Ordner" können Sie auch neue Ordner auf dem Server erstellen.

    3. Geben Sie den Dateinamen an und stellen Sie sicher, dass die Erweiterung des Dateinamens ".xml" lautet.

    4. Wählen Sie das XML-Format aus.

    5. Standardmäßig ist die Option "Ausgecheckt lassen" ausgewählt. Sie können die Auswahl dieser Option aufheben, wenn Sie nicht möchten, dass die Datei nach dem Speichern auf dem Server automatisch ausgecheckt wird.

    6. Klicken Sie auf "Sichern". Die Datei wird auf den Server und in den Ordner mit den verwalteten Dateien kopiert. Das Dokument ist nun ein verwaltetes Dokument. Die Bezeichnung der Schaltfläche "Sichern" ändert sich zu "Öffnen".


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Ein- und Auschecken von Dokumenten

Das Auschecken eines Dokuments verhindert, dass Ihre Arbeit von anderen Benutzern überschrieben wird. Wenn Sie die Bearbeitung beendet haben, checken Sie das Dokument ein, um den Server mit den Änderungen zu aktualisieren, und entsperren Sie das verwaltete Dokument.

Während ein Dokument ausgecheckt ist, können Sie Änderungen am verwalteten Dokument auf dem Server speichern. Dadurch können Sie auch anderen Benutzern den Zugriff auf Ihre Arbeit ermöglichen, ohne das Dokument zu entsperren.

So checken Sie ein Dokument aus:

Wählen Sie "Datei > Arbeitsgruppe > Auschecken".

So checken Sie mehrere Dokumente aus:

Halten Sie die Umschalttaste gedrückt und wählen Sie "Datei > Arbeitsgruppe > Alle geöffneten Dokumente auschecken".

Alle geöffneten Dokumente werden ausgecheckt und auf die lokale Festplatte heruntergeladen.

So brechen Sie das Auschecken ab:

Wählen Sie "Datei > Arbeitsgruppe > Auschecken abbrechen".

Sie werden aufgefordert zu bestätigen, dass Sie das Auschecken abbrechen wollen.

Hinweis: Die frühere Version einer auf dem Server gespeicherten Datei kann nicht wiederhergestellt werden.

So brechen Sie das Auschecken mehrerer Dokumente ab:

Halten Sie die Umschalttaste gedrückt und wählen Sie "Datei > Arbeitsgruppe > Auschecken der geöffneten Dokumente abbrechen".

So checken Sie ein Dokument ein:

Wählen Sie "Datei > Arbeitsgruppe > Einchecken".

Die Datei wird auf dem Server gespeichert und entsperrt und kann nun von einer anderen Person ausgecheckt werden. Die lokal gespeicherte Version bleibt gesperrt und schreibgeschützt.

So checken Sie mehrere Dokumente ein:

Halten Sie die Umschalttaste gedrückt und wählen Sie "Datei > Arbeitsgruppe > Alle geöffneten Dokumente einchecken". Daraufhin werden alle geöffneten ausgecheckten Dokumente wieder eingecheckt.


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Bearbeiten eines verwalteten Dokuments

Sie können ein verwaltetes Dokument genau wie ein FrameMaker-Dokument bearbeiten.


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Speichern eines verwalteten Dokuments

Dokumente können auf der Festplatte oder dem WebDAV-Server gespeichert werden.

So speichern Sie ein verwaltetes Dokument auf der Festplatte:

Wählen Sie "Datei > Sichern".

So speichern Sie ein verwaltetes Dokument auf einem WebDAV-Server:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Datei > Arbeitsgruppe > Sichern".

    Klicken Sie auf "Datei > Arbeitsgruppe > Sichern unter", um das verwaltete Dokument, MIF- oder XML-Dokument an einem anderen Ort zu speichern. Klicken Sie auf "Sichern".

Hinweis: Der Befehl "Sichern unter" führt dazu, dass alle Verwaltungsinformationen aus dem Dokument entfernt werden, unabhängig davon, ob es in einem verwalteten Ordner gespeichert wird.


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Aktualisieren aller geöffneten Dokumente

Während ein Dokument eingecheckt ist, können Sie es vom Server herunterladen. Dadurch haben Sie immer Zugriff auf die aktuelle Version auf dem Server, selbst wenn das Dokument von einer anderen Person ausgecheckt wurde.

So aktualisieren Sie ein geöffnetes Dokument:

Halten Sie die Umschalttaste gedrückt und wählen Sie "Datei > Arbeitsgruppe > Aktualisieren".

So aktualisieren Sie alle geöffneten Dokumente:

Wählen Sie "Datei > Arbeitsgruppe > Alle geöffneten Dokumente aktualisieren".


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Wiederherstellen der Server-Version

Während ein Dokument ausgecheckt ist, können Sie auf die Server-Version zurückgreifen. Dadurch können Sie alle an der lokalen Datei vorgenommenen Änderungen verwerfen und durch die auf dem Server gespeicherte aktuelle Version ersetzen.

So stellen Sie ein geöffnetes Dokument wieder her:

Wählen Sie "Datei > Arbeitsgruppe > Wiederherstellen".

So stellen Sie alle geöffneten Dokumente wieder her:

Halten Sie die Umschalttaste gedrückt und wählen Sie "Datei > Arbeitsgruppe > Alle geöffneten Dokumente wiederherstellen".


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Importieren von Dateien von einem Server

Sie können Dateien von einem beliebigen Server direkt importieren und einer Arbeitsgruppe hinzufügen.

So importieren Sie Dateien von einem Server:

    1. Wählen Sie "Datei > Arbeitsgruppe > Importieren".

    2. Das Dialogfenster "Vom Server importieren" wird angezeigt. Wählen Sie den Server und die zu importierende Datei aus.

    3. Wählen Sie zwischen den Optionen "Import durch Referenz" oder "In Dokument kopieren" und klicken Sie auf "Importieren". Die Datei wird in den Ordner mit den verwalteten Dateien heruntergeladen. Enthält dieser bereits eine Kopie der Datei, werden Sie aufgefordert, diese zu überschreiben.


Verwalten von Dateien mithilfe von WebDAV / Erste Schritte in der Arbeitsgruppenverwaltung

Zugriff auf andere Dateien auf einem WebDAV-Server

Sie können Dateien vom WebDAV-Server herunterladen, die in FrameMaker nicht geöffnet oder importiert werden können. Sie können dem Server solche Dateien auch von FrameMaker aus hinzufügen. Wenn Sie eine Datei herunterladen, die am angegebenen Speicherort bereits vorhanden ist, wird diese in FrameMaker mit der aktuellen Server-Version aktualisiert.

So laden Sie Dateien von einem WebDAV-Server herunter:

    1. Wählen Sie "Datei > Datei vom Server abrufen".

    2. Wählen Sie einen Server, ein Verzeichnis und die Datei aus, die Sie herunterladen wollen, und klicken Sie auf "Öffnen".

Hinweis: Wenn bereits eine Version dieses Dokuments auf der lokalen Festplatte gespeichert ist, werden Sie aufgefordert, diese Datei zu überschreiben.

So übertragen Sie Dateien auf einen WebDAV-Server:

    1. Wählen Sie "Datei > Datei auf Server ablegen".

    2. Wählen Sie die Datei, die Sie auf dem Server ablegen wollen, und klicken Sie auf "Sichern".


Verwalten von Dateien mithilfe von WebDAV

Verwalten von Dokumentverknüpfungen

Die WebDAV-Verknüpfungspalette enthält sowohl Informationen für lokale Verknüpfungen (auf der Festplatte) wie auch für verwaltete Verknüpfungen (auf einem Server). Verknüpfungen sind Pfade zu verwalteten Dokumenten.

Mithilfe der Verknüpfungspalette können Sie Verknüpfungen hinzufügen, aktualisieren und speichern. Sie enthält auch Informationen über verwaltete Dokumente und ausgewählte Verknüpfungen.

Auf der Verknüpfungspalette werden Informationen über alle vorhandenen verwalteten Dokumentverknüpfungen angezeigt.

Die Palette der verwalteten Verknüpfungen enthält drei Schlüsselelemente: Dokument-URL, Auswahl-URL und Dokument-/Auswahlstatus. Im Feld "Dokument-URL" wird der URL für das aktive Dokument angezeigt; im Feld "Auswahl-URL" wird der URL der ausgewählten Verknüpfung (z. B. eine Datei in einem Buch oder eine importierte Grafik) angezeigt; im Feld "Auswahlstatus" wird der Status des ausgewählten URL angezeigt (z. B. "Eingecheckt", "Ausgecheckt" oder "Nicht verwaltet").

So verwalten Sie Dokumentverknüpfungen:

    1. Wählen Sie "Datei > Verknüpfungen", um die Verknüpfungspalette zu öffnen.

    2. Wählen Sie aus der Verknüpfungspalette eine oder mehrere Verknüpfungen aus.

    3. Wählen Sie im Menü der Verknüpfungspalette die Option "Verknüpfung sichern".

So können Sie Verknüpfungen speichern und zum Server hinzufügen:

    1. Wählen Sie "Datei > Verknüpfungen", um die Verknüpfungspalette zu öffnen.

    2. Markieren Sie die Verknüpfung, die Sie hinzufügen wollen. Dies kann z. B. eine importierte Grafik in einem FrameMaker-Dokument oder eine Datei in einer Buchdatei sein.

    3. Wählen Sie eine der folgenden Optionen aus:

    Verknüpfung sichern unter

    Ausgewählte Verknüpfungen sichern unter

    Alle Verknüpfungen sichern unter

    4. Sie werden aufgefordert, einen Dateinamen für jede Verknüpfung anzugeben. Sie können hierzu den Standardnamen verwenden oder einen anderen Namen eingeben. Alle Verknüpfungen werden demselben Server und Verzeichnis hinzugefügt.

So können Sie alle Verknüpfungen zum Server hinzufügen:

    1. Wählen Sie "Datei > Verknüpfungen", um die Verknüpfungspalette zu öffnen.

    2. Wählen Sie im entsprechenden Dokument oder Buch keine Verknüpfung aus.

    3. Wählen Sie "Alle Verknüpfungen sichern unter" und wählen Sie dann den Server und das Verzeichnis zum Speichern der Verknüpfungen aus.

Hinweis: Sie werden aufgefordert, einen Dateinamen für jede Verknüpfung anzugeben. Sie können hierzu den Standardnamen verwenden oder einen anderen Namen eingeben. Alle Verknüpfungen werden demselben Server und Verzeichnis hinzugefügt, es sei denn, Sie wählen einen anderen Speicherort.

So speichern Sie verwaltete Verknüpfungsaktualisierungen:

    1. Wählen Sie "Datei > Verknüpfungen", um die Verknüpfungspalette zu öffnen.

    2. Wählen Sie die zu speichernde Verknüpfung aus.

    3. Wählen Sie im Menü der Verknüpfungspalette die Option "Verknüpfung sichern".

So können Sie verwaltete Verknüpfungen aktualisieren oder als aktuelle Server-Version wiederherstellen:

    1. Wählen Sie aus der Verknüpfungspalette eine oder mehrere Verknüpfungen aus.

    2. Wählen Sie "Verknüpfung wiederherstellen".

So checken Sie verwaltete Verknüpfungen beim Server ein:

    1. Wählen Sie "Datei > Verknüpfungen", um die Verknüpfungspalette zu öffnen.

    2. Wählen Sie die Verknüpfung(en) aus, die Sie einchecken wollen.

    3. Wählen Sie eine der folgenden Optionen aus:

    Verknüpfung einchecken

    Ausgewählte Verknüpfungen einchecken

    Alle verwalteten Verknüpfungen einchecken

So checken Sie verwaltete Verknüpfungen beim Server aus:

    1. Wählen Sie "Datei > Verknüpfungen", um die Verknüpfungspalette zu öffnen.

    2. Wählen Sie die Verknüpfung(en) aus, die Sie auschecken wollen.

    3. Wählen Sie eine der folgenden Optionen aus:

    Verknüpfung auschecken

    Ausgewählte Verknüpfungen auschecken

    Alle verwalteten Verknüpfungen auschecken

So brechen Sie das Auschecken von verwalteten Verknüpfungen ab:

    1. Wählen Sie "Datei > Verknüpfungen", um die Verknüpfungspalette zu öffnen.

    2. Wählen Sie die Verknüpfung(en) aus, für die Sie das Auschecken abbrechen wollen.

    3. Wählen Sie eine der folgenden Optionen aus:

    Auschecken der Verknüpfungen abbrechen

    Auschecken der ausgewählten Verknüpfungen abbrechen

    Auschecken aller verwalteten Verknüpfungen abbrechen

So stellen Sie verwaltete Verknüpfungen als aktuelle Server-Version wieder her:

    1. Wählen Sie die Verknüpfungen aus, die Sie wiederherstellen wollen.

    2. Wählen Sie "Verknüpfung wiederherstellen".

So aktualisieren Sie verwaltete Verknüpfungen mit der aktuellen Server-Version:

    1. Wählen Sie im entsprechenden Dokument oder Buch eine oder mehrere Verknüpfungen aus.

    2. Wählen Sie eine der folgenden Optionen aus:

    Verknüpfung aktualisieren

    Ausgewählte Verknüpfungen aktualisieren

    Alle verwalteten Verknüpfungen aktualisieren


Importieren, Verknüpfen und Exportieren

Importieren von Dateien in FrameMaker

Wählen der geeigneten Methode für das Importieren und Verknüpfen

Kopieren und Einfügen

Textimport mit dem Befehl "Importieren"

Grafikimport mit dem Befehl "Importieren"

Arbeiten mit Ziehen und Ablegen (Windows)

Verwendung von OLE (Windows)

Arbeiten mit Grafikeinschüben (UNIX)

Exportieren von Text und Grafiken

Importieren von Text in strukturierte Dokumente

Einfügen von importierten Grafikelementen in strukturierte Dokumente

Verwenden der Dateiimport-Funktion

Importieren von SWF-Dateien in FrameMaker-Dokumente (Windows)

Importieren von 3D-Objekten in FrameMaker-Dokumente (Windows)


Importieren, Verknüpfen und Exportieren

Importieren von Dateien in FrameMaker

Zum Importieren eignen sich andere Adobe FrameMaker-Dokumente, Dokumente aus anderen Programmen, Textdateien und Grafikdateien. Außerdem können Sie SWF-Dateien und 3D-Objekte in FrameMaker-Dokumente importieren. Ein importiertes Objekt kann einfach in das Dokument kopiert werden. Es kann auch verknüpft werden, z. B. beim Import durch Referenz. In diesem Fall bleibt es mit seiner Quelle verbunden und lässt sich einfach aktualisieren.

Sie können Text und Grafiken auf vielerlei Arten (zum Teil plattformspezifisch) in andere Programme exportieren.


Importieren, Verknüpfen und Exportieren

Wählen der geeigneten Methode für das Importieren und Verknüpfen

Sie können Text oder Grafiken auf folgende Arten in ein FrameMaker-Dokument importieren:

    Verwenden Sie die Zwischenablage, um Text oder Grafiken aus einer anderen Anwendung zu kopieren und einzufügen.

    Wählen Sie "Datei > Importieren > Datei".

    (Windows) Arbeiten Sie mit OLE (Objektverknüpfung und -einbettung).

    (Windows) Ziehen Sie die Objekte aus einem Fenster in ein anderes.

    (UNIX) Arbeiten Sie mit einem Grafikeinschub-Editor.

Einige dieser Methoden führen einen Import durch Kopieren aus, andere importieren durch Referenz. Der Befehl "Datei > Importieren > Datei" steht für beide Methoden auf allen Plattformen zur Verfügung.


Importieren, Verknüpfen und Exportieren / Wählen der geeigneten Methode für das Importieren und Verknüpfen

Importieren durch Kopieren

Sie können Dateien durch Kopieren importieren, indem Sie die Zwischenablage oder den Befehl "Datei > Importieren > Datei" verwenden bzw. (unter Windows) Objekte aus einem Fenster in ein anderes ziehen.

Das Importieren durch Kopieren erleichtert den Transfer von importiertem Material von einer Position an eine andere, vergrößert jedoch das Dokument. Wenn Sie Änderungen im Quellmaterial durchführen, müssen Sie außerdem die Quelldatei erneut importieren, um das Dokument mit der neuesten Version zu aktualisieren.


Importieren, Verknüpfen und Exportieren / Wählen der geeigneten Methode für das Importieren und Verknüpfen

Importieren durch Referenz

Sie importieren durch Referenz mithilfe von "Datei > Importieren > Datei", "OLE" (Windows) oder einem Grafikeinschub-Editor (UNIX).

Wenn Sie auf eine durch Referenz importierte Grafik doppelklicken (Windows), wird die Anwendung geöffnet:

Beim Importieren durch Referenz bleibt der importierte Text oder die importierte Grafik mit der Quelldatei verknüpft. FrameMaker speichert den Pfadnamen der Quelldatei im Dokument. Bei jedem Öffnen des Dokuments sucht FrameMaker die Datei auf der Festplatte und zeigt sie an. Wenn die Quelldatei überarbeitet wurde, aktualisiert FrameMaker das Dokument mit der neuesten Version. Import durch Referenz kann die Dateigröße reduzieren, da Sie dasselbe Material an mehreren Stellen verwenden können, ohne den Text oder den Inhalt importierter Grafiken im FrameMaker-Dokument zu speichern. Durch Referenz importierter Text wird als Texteinschub bezeichnet.

Informationen darüber, wie der Pfadname beim Importieren durch Referenz gespeichert wird, finden Sie unter Verwenden von Pfadnamen beim Importieren durch Referenz.


Importieren, Verknüpfen und Exportieren

Kopieren und Einfügen

Am einfachsten lassen sich Texte und Grafiken durch Kopieren und Einfügen aus der Zwischenablage importieren. Beachten Sie dabei Folgendes:

    Sie können durch Tabulatoren begrenzten Text über den Befehl "Tabelle > Zu Tabelle konvertieren" in eine Tabelle umwandeln.

    Die Textformatierung geht verloren, es sei denn, Sie importieren in ein anderes FrameMaker-Dokument.

    (Windows) Über "Bearbeiten > Einfügen Spezial" stehen manchmal weitere Optionen zur Verfügung. Beispielsweise können Sie formatierten Text zwischen FrameMaker- und Microsoft Word-Dokumenten in RTF-Format austauschen, wenn Sie anstelle von "Einfügen" den Befehl "Einfügen Spezial" verwenden.


Importieren, Verknüpfen und Exportieren

Textimport mit dem Befehl "Importieren"

Mithilfe des Befehls "Datei > Importieren > Datei" kann Text auf allen Plattformen importiert werden. Diese Methode bietet mehr Flexibilität als die Verwendung der Zwischenablage.

Wenn Sie nur auf einer Plattform arbeiten, können Sie den Import auch mithilfe einer plattformspezifischen Technik ausführen. Weitere Informationen hierzu finden Sie unter Verwendung von OLE (Windows).

Der importierte Text kann formatiert oder unformatiert sein. Unformatierter Text enthält nur Wörter und keinerlei Informationen über Schriften, Einzüge, Abstände, automatische Nummerierung usw; formatierter Text dagegen enthält diese Informationen.


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Importieren von formatiertem Text

Sie können formatierten Text aus folgenden Quellen in ein FrameMaker-Dokument importieren:

    einen Textfluss aus einem anderen Teil desselben Dokuments

    einen Textfluss aus einem anderen FrameMaker-Dokument

    einen Textfluss aus einem anderen FrameMaker-Dokument, bei dem es sich um eine MIF-Datei (Maker Interchange Format) handelt (siehe Importieren von MIF-Dateien);

    eine in einer anderen Anwendung (z. B. Microsoft Word) erstellte Datei, für die ein installierter Filter vorhanden ist.

Wenn Sie Text aus einem anderen FrameMaker-Dokument importieren, werden auch Querverweise, Fußnoten, Variablen, Marken und verankerte Rahmen importiert. Auch bedingter Text im Textfluss wird übertragen. Beim Import von Text aus einer anderen Anwendung werden (abhängig von den Einstellungen der anderen Anwendung und von den verwendeten Filtern) einige dieser speziellen Elemente ebenfalls importiert.

So importieren Sie formatierten Text:

    1. Klicken Sie an die Position, an der Sie den Text einfügen wollen, und wählen Sie "Datei> Importieren> Datei".

    2. Geben Sie die Datei, die den zu importierenden Textfluss enthält, und die Importmethode an (siehe Wählen der geeigneten Methode für das Importieren und Verknüpfen).

    3. Klicken Sie auf "Importieren".

    4. Wenn das Dialogfenster "Unbekannter Dateityp" angezeigt wird, wählen Sie einen Dateityp aus und klicken auf "Konvertieren". Das nächste Dialogfenster hängt von der in Schritt 2 gewählten Importmethode ab. Das Dialogfenster "Textfluss durch Referenz importieren" enthält Einstellungen für die Aktualisierung des importierten Textflusses. Wählen Sie einen Arbeitsseitenfluss oder einen Referenzseitenfluss. Normalerweise stammt der zu importierende Text aus Arbeitsseiten. Referenzseiten können Textflüsse mit Mustertext oder Mustergrafiken für die Verwendung auf Arbeitsseiten enthalten.

    5. Legen Sie fest, wie der importierte Text formatiert werden soll. Führen Sie dazu eine der folgenden Aktionen aus:

    Um dem importierten Text bei übereinstimmendem Typ die Formate des aktuellen Dokuments zuzuweisen, klicken Sie auf "Mit Katalog des aktuellen Dokuments neu formatieren". Stimmen die Typen nicht überein, bleibt die Formatierung des importierten Textes erhalten. Gewöhnlich wählen Sie auch Optionen zum Löschen manueller Seitenumbrüche und anderer Formatänderungen (wie Schrift- oder Tabulatoreinstellungen) aus, damit der importierte Text das gleiche Aussehen wie der Text im aktuellen Dokument erhält.

    Um die spezifische Formatierung des importierten Textes zu entfernen und die an der Einfügemarke gültigen Zeichen- und Absatzformate zuzuweisen, klicken Sie auf "Als Standardtext neu formatieren". (Text in Tabellen oder verankerten Rahmen behält die ursprüngliche Formatierung des Quelldokuments bei.)

    Wenn die Formatierung aus dem Quelldokument beibehalten werden soll, klicken Sie auf "Quellformatierung beibehalten". Die Formate des importierten Textes werden nicht in die Formatkataloge des aktuellen Dokuments aufgenommen. Wenn Sie später die Formate des aktuellen Dokuments ändern, sind die Formate des importierten Textes davon nicht betroffen. Dies gilt auch dann, wenn die Typen im aktuellen Dokument mit denen im importierten Text übereinstimmen.

    6. Wenn Sie den Text durch Referenz importieren, geben Sie an, wie der Texteinschub aktualisiert werden soll, indem Sie eine der folgenden Aktionen ausführen:

    Soll der Texteinschub bei jedem Öffnen des Dokuments aktualisiert werden, klicken Sie auf "Automatisch".

    Soll der Einschub je nach Bedarf aktualisiert werden, klicken Sie auf "Manuell".

    7. Klicken Sie auf "Importieren". Wurde der Text durch Referenz importiert, erscheint er als Texteinschub. (Ein Texteinschub ist mit dem Quelldokument verknüpft und kann nur in diesem bearbeitet werden.)


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Importieren von unformatiertem Text

Wenn Sie Text aus einer unformatierten Textdatei importieren, können Sie angeben, ob der Import durch Kopieren oder Referenz erfolgen soll und wie die Zeilen in der Textdatei behandelt werden sollen. Der importierte Text übernimmt die Zeichen- und Absatzformatierung, die an der Einfügemarke gültig ist.

So importieren Sie eine Textdatei:

    1. Platzieren Sie die Einfügemarke an der Stelle, an der Sie den Text einfügen wollen, und wählen Sie "Datei > Importieren > Datei".

    2. Geben Sie die zu importierende Textdatei und die Importmethode an. Weitere Informationen hierzu finden Sie unter Wählen der geeigneten Methode für das Importieren und Verknüpfen.

    3. Klicken Sie auf "Importieren". Welches Dialogfenster geöffnet wird, hängt von der gewählten Importmethode ab ("Importieren durch Referenz" oder "Datei in Dokument kopieren").

    4. Legen Sie fest, wie der importierte Text behandelt werden soll, indem Sie eine der folgenden Aktionen ausführen:

    Wenn Zeilenumbrüche nur bei Leerzeilen eingefügt werden sollen, klicken Sie auf "Zeilenenden einlesen als Zeilenumbrüche". Setzen Sie diese Option für absatzorientierte Textdateien ein, z. B. für Dateien, die Dokumenttext enthalten.

    Soll am Ende jeder Zeile ein Umbruch erfolgen, klicken Sie auf "Zeilenenden einlesen als Absatzenden". Diese Option eignet sich für zeilenorientierte Textdateien, z. B. für Dateien, die Computercode enthalten.

    Um importierten Text in eine Tabelle zu konvertieren, klicken Sie auf "In Tabelle konvertieren". Legen Sie dafür ein Tabellenformat und weitere erforderliche Einstellungen fest. Verwenden Sie diese Option nur dann, wenn die Datei Text mit Begrenzungszeichen enthält, z. B. die Textausgabe eines Datenbankprogramms.

    5. Wenn Sie den Text durch Referenz importieren, geben Sie an, wie der Texteinschub aktualisiert werden soll, indem Sie eine der folgenden Aktionen ausführen:

    Soll der Texteinschub bei jedem Öffnen des Dokuments aktualisiert werden, klicken Sie auf "Automatisch".

    Soll der Einschub je nach Bedarf aktualisiert werden, klicken Sie auf "Manuell".

    6. Wählen Sie, falls erforderlich, eine Zeichencodierung aus dem Aufklappmenü "Codierung". Dies empfiehlt sich nur, wenn Sie wissen, dass die eingestellte Codierung falsch ist. Wenn Sie eine unkorrekte Codierung erzwingen, werden eventuell Zeichen ersetzt oder anstelle mancher Zeichen Fragezeichen angezeigt.

    7. Klicken Sie auf "Importieren". Wurde der Text durch Referenz importiert, erscheint er als Texteinschub.


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Importieren von Adobe Illustrator-Dateien

Sie können Dateien aus Adobe Illustrator der Versionen 9.0 und 10.0 in FrameMaker importieren. Der Import der Dateien in FrameMaker erfolgt im PDF-Format; daher kann der Ausdruck von aufwändigen Grafiken oder von Grafiken mit Transparenzeffekten auf einem PostScript Level 1-Drucker oder einem nicht PostScript-fähigen Drucker vom erwarteten Ergebnis abweichen.

Die Adobe Illustrator-Importfunktion ist in Windows verfügbar.

Hinweis: Dateien von Illustrator 9.0 und 10.0 werden entsprechend der Seitengröße und nicht der Bildgröße der Datei importiert. Ändern Sie die Größe des verankerten Rahmens, um Leerräume aus der Grafik herauszuschneiden.


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Importieren von Microsoft Word-Dateien

Sie können Microsoft Word-Dokumente mit den Erweiterungen .doc und .docx in FrameMaker-Dokumente importieren.

Wenn Sie das Microsoft Word-Dokument im Format von Word 97 bis Word 2003 gespeichert haben, können Sie es mit dem Microsoft Word- oder dem Microsoft Word 2007-Filter importieren. Wenn Sie jedoch ein Microsoft Word 2007-Dokument importieren wollen, müssen Sie den Microsoft Word 2007-Filter verwenden. RTF-Dateien können Sie mithilfe des Microsoft RTF 1.6-Filters im Dialogfenster "Unbekannter Dateityp" importieren.

    1. Platzieren Sie die Einfügemarke an der Stelle im Dokument, an der Sie den Text einfügen wollen, und wählen Sie "Datei > Importieren > Datei".

    2. Geben Sie die zu importierende Datei an, wählen Sie die Option "Import durch Referenz" bzw. "In Dokument kopieren" und wählen Sie dann "Importieren" aus.

Je nach zu importierenden Dokument ist im Dialogfenster "Unbekannter Dateityp" der Microsoft Word- oder der Microsoft Word 2007-Filter ausgewählt.

    3. Klicken Sie auf "Konvertieren". Das Dialogfenster "Textfluss durch Kopie importieren" oder "Textfluss durch Referenz importieren" wird geöffnet.

    4. Wählen Sie im Bereich "Zu importierender Textfluss" einen "Arbeitsseitenfluss" oder einen "Referenzseitenfluss" aus.

    5. Wählen Sie im Bereich "Importierten Textfluss formatieren" eine der folgenden Optionen aus:

    Klicken Sie auf "Mit Katalog des akt. Dokuments neu formatieren", um die Option "Manuelle Seitenumbrüche entfernen" und die Option "Sonstige irreguläre Formatzuweisungen" auszuwählen.

    Wenn Sie den importierten Inhalt in Standardtext konvertieren und dann in das Dokument einfügen wollen, klicken Sie auf "Als Standardtext formatieren".

    Wenn Sie das Originalformat des importierten Inhalts beibehalten und den Inhalt dann in das Dokument einfügen wollen, klicken Sie auf "Quellformatierung beibehalten".

    6. Wählen Sie im Dialogfenster "Textfluss durch Referenz importieren" eine der folgenden Optionen aus dem Bereich "Aktualisierung von importiertem Textfluss" aus:

    Wenn der importierte Flussbereich automatisch aktualisiert werden soll, klicken Sie auf "Automatisch".

    Wenn Sie den importierten Flussbereich manuell aktualisieren wollen, klicken Sie auf "Manuell".

    7. Klicken Sie auf "Importieren".

Hinweis: Textmarken in Word-Dokumenten werden zu Querverweis-Marken. Anmerkungen in Word-Dokumenten werden beim Importieren durch Referenz zu bedingtem Text mit der Bedingung "Kommentar". Verborgener Text in Word-Dokumenten wird beim Importieren zu bedingtem Text mit der Bedingung "Verdeckt".


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Importieren von Microsoft Excel-Dateien

Sie können Microsoft Excel-Dokumente mit den Erweiterungen .xls und .xlsx in FrameMaker-Dokumente importieren.

Wenn Sie das Microsoft Excel-Dokument im Arbeitsmappenformat von Excel 97 bis Excel 2003 gespeichert haben, können Sie es mit dem Microsoft Excel- oder dem Microsoft Excel 2007-Filter importieren. Wenn Sie jedoch ein Microsoft Excel 2007-Dokument importieren wollen, müssen Sie den Microsoft Excel 2007-Filter verwenden.

    1. Klicken Sie an die Position, an der Sie die Datei einfügen wollen, und wählen Sie "Datei > Importieren > Datei".

    2. Geben Sie die zu importierende Datei an, wählen Sie die Option "Import durch Referenz" bzw. "In Dokument kopieren" und klicken Sie auf "Importieren".

Je nach zu importierenden Dokument ist im Dialogfenster "Unbekannter Dateityp" der Microsoft Excel- oder der Microsoft Excel 2007-Filter ausgewählt.

    3. Klicken Sie auf "Konvertieren". Das Dialogfenster "Textfluss durch Kopie importieren" oder "Textfluss durch Referenz importieren" wird geöffnet.

    4. Wählen Sie im Bereich "Zu importierender Textfluss" die Option "Arbeitsseitenfluss" oder die Option "Referenzseitenfluss" aus.

    5. Wählen Sie im Bereich "Importierten Textfluss formatieren" eine der folgenden Optionen aus:

    Klicken Sie auf "Mit Katalog des akt. Dokuments neu formatieren", um die Option "Manuelle Seitenumbrüche entfernen" und die Option "Sonstige irreguläre Formatzuweisungen" auszuwählen.

    Wenn Sie den importierten Inhalt in Standardtext konvertieren und dann in das Dokument einfügen wollen, klicken Sie auf "Als Standardtext formatieren".

    Wenn Sie das Originalformat des importierten Inhalts beibehalten und den Inhalt dann in das Dokument einfügen wollen, klicken Sie auf "Quellformatierung beibehalten".

    6. Wählen Sie im Dialogfenster "Textfluss durch Referenz importieren" eine der folgenden Optionen aus dem Bereich "Aktualisierung von importiertem Textfluss" aus:

    Wenn der importierte Flussbereich automatisch aktualisiert werden soll, klicken Sie auf "Automatisch".

    Wenn Sie den importierten Flussbereich manuell aktualisieren wollen, klicken Sie auf "Manuell".

    7. Klicken Sie auf "Importieren".


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Importieren von RTF-Dateien

FrameMaker unterstützt jetzt den Import und Export von Dateien im Format RTF 1.6.


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Importieren von MIF-Dateien

MIF ist ein Textformat, mit dessen Hilfe Sie Informationen zwischen FrameMaker und anderen Anwendungen austauschen können. Alle Arten von Format- und Seitenlayoutinformationen werden in MIF-Befehle übersetzt. FrameMaker interpretiert die Befehle in der MIF-Datei und wandelt sie wieder in Format- und Layouteinstellungen um.

Sie können Text aus dem speziellen Textfluss einer MIF-Datei genauso wie aus einer FrameMaker-Datei importieren (siehe Importieren von formatiertem Text). Beim Import durch Kopieren werden alle Referenz- und Vorgabeseiten ebenso wie die Arbeitsseiten importiert. Der Text wird auf einer unverketteten Seite angezeigt. Informationen über das Verketten von Seiten und Textflüssen finden Sie unter Verketten von Textrahmen. Weitere Informationen zu MIF finden Sie im Online-Handbuch MIF Reference.


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Importieren von PDF-Dateien

Beim Importieren einer PDF-Datei in ein FrameMaker-Dokument wird die PDF-Datei als Grafik behandelt. Dabei lässt sich jedoch nur jeweils eine Seite der PDF-Datei in das FrameMaker-Dokument importieren. Sowohl Prozess- als auch Schmuckfarben können angezeigt und gedruckt werden.

Der Ausdruck von Grafiken mit Transparenzeffekten auf einem PostScript Level 1-Drucker oder einem nicht PostScript-fähigen Drucker kann vom erwarteten Ergebnis abweichen.

Enthält ein unter Windows erstelltes Dokument eine importierte PDF-Datei und wird diese auf einem UNIX-System geöffnet, wird das PDF-Bild als grauer Kasten angezeigt.

FrameMaker unterstützt keine PDF-Dateien, die Multi-Byte-Zeichen (asiatische Schriften) verwenden.

So importieren Sie eine PDF-Datei:

    1. Geben Sie die Position der Grafik an. Einzelheiten hierzu finden Sie unter Grafikimport mit dem Befehl "Importieren".

    2. Wählen Sie "Datei > Importieren > Datei".

    3. Wählen Sie die zu importierende PDF-Datei und klicken Sie auf "Importieren".

    4. Wenn die PDF-Datei mehrere Seiten umfasst, müssen Sie im Dialogfenster "PDF-Seite auswählen" die Seitennummer angeben. Zeigen Sie mithilfe des Reglers eine Vorschau der gewünschten Seite an und klicken Sie dann auf "Auswählen".


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Anzeigen der Einstellungen oder Quelle von Texteinschüben

Sie können den Dateinamen und den Dateityp des Quelldokuments, das Datum der letzten Änderung, das Datum der letzten Aktualisierung des Texteinschubs und die Aktualisierungseinstellung des Texteinschubs anzeigen. Sie können auch die Quelle eines Texteinschubs anzeigen.

So zeigen Sie die Einstellungen oder die Quelle von Texteinschüben an:

    1. Klicken Sie auf den Texteinschub, um ihn auszuwählen, und wählen Sie "Bearbeiten > Texteinschubeinstellungen". Sie können auch auf den Einschub doppelklicken.

    2. Wenn Sie die Quelle des Texteinschubs öffnen wollen, klicken Sie auf "Quelle öffnen". Die Quelle wird als FrameMaker-Dokument geöffnet.


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Steuern der Aktualisierung von Texteinschüben

Sie können festlegen, wie und wann Texteinschübe aus den jeweiligen Quelldokumenten aktualisiert werden. So können Sie z. B. manuelle oder automatische Aktualisierung festlegen und Sie können einen einzelnen oder mehrere Texteinschübe im Dokument manuell aktualisieren.

Hinweis: Durch Referenz importierter Text wird nur dann automatisch aktualisiert, wenn er laut Datumsstempel veraltet ist. Da sich die Zeiteinstellungen je nach Dateisystem oder Netzwerk unterscheiden können, ist es möglich, dass ein veralteter Texteinschub nicht automatisch aktualisiert wird. In diesem Fall können Sie den Einschub manuell aktualisieren.

So ändern Sie die Aktualisierung eines ausgewählten Texteinschubs:

    1. Wählen Sie den zu aktualisierenden Einschub aus.

    2. Wählen Sie "Bearbeiten > Texteinschubeinstellungen" und klicken Sie auf "Einstellungen".

    3. Legen Sie manuelle oder automatische Aktualisierung fest und klicken Sie auf "Importieren".

So unterdrücken Sie die Aktualisierung aller Texteinschübe in einem Dokument:

    1. Wählen Sie "Bearbeiten > Referenzen aktualisieren".

    2. Wählen Sie aus dem Aufklappmenü "Befehle" die Option "Automatische Aktualisierung unterdrücken". Wählen Sie anschließend die Elemente aus, die nicht automatisch aktualisiert werden sollen.

    3. Klicken Sie auf "Zuweisen" und anschließend auf "Zurück".

So unterdrücken Sie die Aktualisierung aller Texteinschübe in ausgewählten Buchdateien:

    1. Wählen Sie im Buchfenster die zu aktualisierende(n) Datei(en) aus.

    2. Wählen Sie "Bearbeiten > Automatische Referenzaktualisierung unterdrücken".

    3. Aktivieren Sie "Automatische Aktualisierung unterdrücken" und klicken Sie auf "Zuweisen".

So aktualisieren Sie einen einzelnen Texteinschub manuell:

Wählen Sie den gewünschten Einschub aus. Wählen Sie anschließend "Bearbeiten > Texteinschubeinstellungen" und klicken Sie auf "Jetzt aktualisieren".

So aktualisieren Sie mehrere Einschübe in einem Dokument:

    1. Wählen Sie "Bearbeiten> Referenzen aktualisieren".

    2. Wählen Sie die Einschubarten aus, die Sie aktualisieren wollen, und klicken Sie auf "Auswählen".

Wenn Sie die Aktualisierung von Texteinschüben unterbrechen wollen, drücken Sie Strg+c (Windows) oder Control+c (UNIX).


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Konvertieren von Texteinschüben in bearbeitbaren Text

Wenn Sie einen Texteinschub in bearbeitbaren Text konvertieren, aktualisiert FrameMaker diesen nicht mehr. Sie können einen einzelnen oder alle Texteinschübe in einem Dokument konvertieren.

So konvertieren Sie einen oder mehrere Texteinschübe in bearbeitbaren Text:

    1. Wenn Sie nur einen Texteinschub konvertieren wollen, klicken Sie auf ihn, um ihn auszuwählen.

    2. Wählen Sie "Bearbeiten > Texteinschubeinstellungen".

    3. Aktivieren Sie "Zu Text konvertieren", geben Sie an, ob Sie nur den ausgewählten oder alle Texteinschübe im Dokument konvertieren wollen, und klicken Sie auf "Konvertieren".


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Ermitteln der Quelle von ungelösten Texteinschüben

Wenn FrameMaker während der Aktualisierung die Quelldatei für einen Texteinschub nicht findet (oder sich das Format der Quelldatei seit der letzten Aktualisierung geändert hat), wird ein Meldungsfenster angezeigt. Nach Schließen des Meldungsfensters können Sie den ungelösten Texteinschub suchen und den Text erneut importieren.

So ermitteln Sie die Quelle eines ungelösten Texteinschubs:

    1. Wählen Sie "Bearbeiten > Suchen/Ändern".

    2. Wählen Sie aus dem Aufklappmenü "Suchen" die Option "Ungelöster Texteinschub" und klicken Sie auf "Suchen", um den ersten ungelösten Texteinschub auszuwählen.

    3. Wählen Sie "Bearbeiten > Texteinschubeinstellungen", notieren Sie den Pfadnamen und den Dateityp des Texteinschubs und klicken Sie auf "Abbrechen".

    4. Importieren Sie unter Verwendung des Pfadnamens und des Dateityps den Text erneut (siehe Importieren von formatiertem Text und Importieren von unformatiertem Text).

Wenn ein Dokument viele ungelöste Texteinschübe enthält, kann es hilfreich sein, eine Liste der ungelösten Texteinschübe zu generieren. Weitere Informationen hierzu finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen.


Importieren, Verknüpfen und Exportieren / Textimport mit dem Befehl "Importieren"

Verwenden von Pfadnamen beim Importieren durch Referenz

Wenn Sie über "Datei > Importieren > Datei" durch Referenz importieren, kann der Pfadname für die Text- oder Grafikdatei absolut oder relativ sein. Ein relativer Pfadname beginnt beim aktuellen Ordner oder bei einem Ordner der nächsthöheren Hierarchiestufe und gibt von ihm ausgehend die Position der Datei an. Ein absoluter Pfadname beginnt im Stammverzeichnis des Dateisystems (dem obersten Ordner) und gibt von ihm ausgehend die Position der Datei vollständig an. Die folgende Liste enthält Beispiele für absolute Pfadnamen.

Plattform | Absoluter Pfad
Windows | d:\Graphics\Mountain.gif \\DocServer\Graphics\Mountain.gif
UNIX | /usr/doc/graphics/mountain.rf

FrameMaker speichert relative Pfadnamen wann immer dies möglich ist, damit das Programm eine importierte Datei finden kann, wenn sowohl das Dokument als auch die Quelldatei verlagert wird. Voraussetzung hierfür ist, dass die Dateien an denselben relativen Positionen verbleiben. Wenn Sie das Dokument in einem anderen Ordner speichern, passt FrameMaker die Pfadnamen der importierten Dateien entsprechend an. Führt der Pfad zu der importierten Datei jedoch über das Stammverzeichnis des Dateisystems (den obersten Ordner) hinaus, verwendet FrameMaker einen absoluten Pfadnamen, der im Stammverzeichnis beginnt.

Um sicherzustellen, dass FrameMaker relative Pfadnamen verwendet, müssen Sie dafür sorgen, dass die Suche nach der Datei nicht über das Stammverzeichnis hinausführt.


Importieren, Verknüpfen und Exportieren

Grafikimport mit dem Befehl "Importieren"

Über "Datei > Importieren > Datei" lassen sich Grafiken auf allen Plattformen importieren. Informationen über die Verwendung von Pfadnamen beim Importieren von Grafiken durch Referenz finden Sie unter Verwenden von Pfadnamen beim Importieren durch Referenz.

Wenn Sie jedoch Dokumente nur auf einer Plattform bearbeiten, könnten Sie ein plattformspezifisches Vorgehen erwägen. Informationen hierzu finden Sie unter Verwendung von OLE (Windows) und Arbeiten mit Grafikeinschüben (UNIX).

Sie können eine Grafik in einen verankerten oder unverankerten Grafikrahmen, in ein Rechteck, das als Bildrahmen dient, oder direkt auf eine Seite importieren. Wenn sich beim Bearbeiten des Dokuments die Grafik mit dem Text verschieben soll (z. B. eine Grafik in längeren Dokumenten oder in Dokumenten, die für eine HTML-Konvertierung vorgesehen sind), importieren Sie sie in einen verankerten Rahmen. Soll die Grafik an der Position bleiben, an der sie eingefügt wurde (z. B. ein Logo in einem Briefkopf), importieren Sie sie auf die Seite und positionieren sie wie gewünscht.

Gelegentlich müssen Sie beim Importieren einer Grafik einen Importfilter basierend auf dem Grafikformat angeben. Beim Import einer Bitmap können Sie die Skalierung in Dots per Inch (dpi) angeben. Je größer der dpi-Wert ist, umso kleiner wird die Bitmap-Grafik auf der Seite dargestellt.

Beim Kopieren eines Bilds oder beim Kopieren eines Bilds durch Referenz in ein Dokument können Sie den HTTP-Pfad angeben, von dem aus die Grafik importiert werden soll. Der HTTP-Pfad wird bei XML-Roundtrips beibehalten.

Wenn Sie ein Bild importieren, wird es in einer temporären Datei auf dem lokalen Computer gespeichert. Wenn Sie dieselbe Datei erneut importieren, wird sie nicht heruntergeladen. Wenn Sie die Datei nach dem Import in FrameMaker ändern, werden die Änderungen erst wirksam, wenn Sie die temporäre Datei löschen und die Grafik dann erneut in das FrameMaker-Dokument importieren, oder den Wert des Flag AlwaysDownloadURL in der Datei "maker.ini" auf On setzen. Wird das FrameMaker-Dokument, das die importierte Grafik enthält, jedoch auf einen anderen Computer kopiert, wird die Datei erneut heruntergeladen, wenn Sie sie durch Angabe des HTTP-Dateipfads importieren.

So importieren Sie eine Grafik:

    1. Legen Sie die Position der Grafik durch eine der folgenden Aktionen fest:

    Um die importierte Grafik in einen Grafikrahmen einzufügen, wählen Sie einen vorhandenen Rahmen aus oder platzieren Sie eine Einfügemarke in einem Textrahmen.

    Um die importierte Grafik direkt auf der Seite einzufügen, klicken Sie auf den Seitenrand.

    Soll mithilfe eines gezeichneten Rechtecks die Größe der importierten Grafik definiert werden, wählen Sie ein vorhandenes Rechteck aus oder zeichnen ein neues (wählen Sie keinen verankerten oder nicht verankerten Rahmen aus). Die Grafik ersetzt das Rechteck, wenn beim Importieren die Option "In ausgewähltes Rechteck einpassen" aktiviert ist. Das Größenverhältnis der Grafik bleibt dabei jedoch unverändert.

    Wenn Sie eine vorhandene Grafik ersetzen wollen, müssen Sie diese zunächst markieren.

    2. Wählen Sie "Datei > Importieren > Datei".

    3. Wählen Sie die zu importierende Grafikdatei aus oder geben Sie den HTTP-Pfad der zu importierenden Grafikdatei an, und wählen Sie die Importmethode aus. Weitere Informationen hierzu finden Sie unter Wählen der geeigneten Methode für das Importieren und Verknüpfen.

    4. Klicken Sie auf "Importieren". Wenn es sich bei der Grafik nicht um eine Bitmap handelt, wird sie im Dokument angezeigt und der Importvorgang ist beendet.

    5. Wenn beim Klicken auf "Importieren" das Dialogfenster "Unbekannter Dateityp" geöffnet wird, wählen Sie einen Dateityp aus der Auswahlliste aus und klicken auf "Konvertieren".

Handelt es sich bei der importierten Grafik um keine Bitmap, wird die Grafik nun im Dokument angezeigt und der Importvorgang ist beendet.

    6. Wenn Sie eine Bitmap-Grafik importieren, wählen Sie eine Skalierungsoption oder die Option "In ausgewähltes Rechteck einpassen" und klicken auf "Zuweisen".

Hinweis: Wenn Sie eine Grafik durch Angabe eines HTTP-Pfads in ein strukturiertes Dokument importieren, wird sie bei jedem Import der Grafik heruntergeladen. Wenn das Dokument als XML-Dokument gespeichert wird, wird der HTTP-Pfad der Grafik beibehalten.

Die besten Druckergebnisse erzielen Sie, wenn Sie einen dpi-Wert wählen, durch den die Auflösung des Druckers oder der Setzmaschine ohne (oder nur mit einem kleinen) Rest teilbar ist. Die optimale Auflösung am Bildschirm erreichen Sie mit einem dpi-Wert, durch den Ihre Bildschirmauflösung ohne Rest teilbar ist. (Windows-Bildschirme haben normalerweise eine Auflösung von 96 dpi und bei UNIX beträgt sie normalerweise 90 dpi.)

Weitere Informationen finden Sie unter Ändern der Größe von Objekten und Ändern der Größe von importierten Grafiken.


Importieren, Verknüpfen und Exportieren / Grafikimport mit dem Befehl "Importieren"

Importieren von SVG-Dateien

Beim Import einer SVG-Grafik (Scalable Vector Graphic) ist es möglich, die Rasterqualität der Grafik im Dialogfenster "SVG importieren" festzulegen. Mit steigender Rasterqualität werden die gedruckten wie auch die PDF-Versionen schärfer. Allerdings erhöht sich dadurch auch die Dateigröße der Grafik, was wiederum den Importvorgang verlängert.

Importierte SVG-Grafiken werden als Bitmaps angezeigt. Eingebettete importierte Animationen können in FrameMaker jedoch nicht ausgeführt werden.

So importieren Sie eine SVG-Grafik:

    1. Wählen Sie "Datei> Importieren> Datei".

    2. Wählen Sie die SVG-Grafik aus und klicken Sie auf "Importieren".

    3. Legen Sie im Dialogfenster "SVG importieren" die Rasterqualität fest.

    4. Bestimmen Sie die Bildgröße, wenn diese von der Standardgröße abweicht (in diesem Dialogfenster ist proportionales Skalieren nicht möglich).

    5. Klicken Sie auf "Zuweisen".

Hinweis: In Abhängigkeit von der Rasterqualität und dem verfügbaren Speicher kann der Import der SVG-Grafik einige Minuten dauern.


Importieren, Verknüpfen und Exportieren / Grafikimport mit dem Befehl "Importieren"

Importieren von Filmen (Windows)

Unter Windows können Sie Filme in Dokumente einfügen, indem Sie .avi- oder .mov-Dateien einbetten. Informationen hierzu finden Sie unter Verwendung von OLE (Windows).

Wenn Sie ein Dokument drucken, das einen QuickTime-Film enthält, wird nur der Filmtitel ausgegeben.

Hinweis: Verlagern oder löschen Sie die ursprüngliche QuickTime-Filmdatei auch dann nicht, wenn Sie die Datei mithilfe der Option "In Dokument kopieren" importiert haben. Der QuickTime-Film wird nämlich selbst mit dieser Option nicht vollständig in das Dokument kopiert.


Importieren, Verknüpfen und Exportieren / Grafikimport mit dem Befehl "Importieren"

Ermitteln fehlender Grafiken

Wenn Sie ein Dokument öffnen, das durch Referenz importierte Grafikdateien enthält, sucht FrameMaker nach den referenzierten Grafikdateien. Wenn eine Grafikdatei nicht auffindbar ist, wird ein Dialogfenster geöffnet.

So ermitteln Sie eine Grafik, die FrameMaker nicht finden kann:

    1. Wenn FrameMaker das Dialogfenster "Fehlende Datei" öffnet, führen Sie eine der folgenden Aktionen aus:

    Um die Grafik zu suchen und anzuzeigen, wählen Sie sie aus der Liste aus und klicken auf "Dokument aktualisieren, neuer Pfad". FrameMaker verwendet beim Öffnen des Dokuments den neuen Pfad auch für die Suche nach weiteren fehlenden Dateien. Daher müssen Sie den neuen Pfad nur einmal angeben, wenn Sie alle Ihre Grafikdateien an eine neue Position verlagert haben.

    Um die Grafikdatei zu überspringen, aktivieren Sie "Diese Datei übergehen". Die übersprungene Grafik wird als graues Rechteck im Dokument angezeigt. Beim nächsten Öffnen des Dokuments versucht FrameMaker erneut, die Datei zu finden.

    Wenn Sie auch alle weiteren Grafikdateien, die nicht gefunden werden können, übergehen wollen, klicken Sie auf "Alle fehlenden Dateien übergehen".

    2. Klicken Sie auf "Fortfahren".

So zeigen Sie den Dateinamen einer importierten Grafikdatei an:

Wählen Sie die Grafik aus, die durch Referenz importiert wurde, und wählen Sie dann "Grafik > Objekteinstellungen". Der Name der Grafik und der Suchpfad werden im Dialogfenster angezeigt.


Importieren, Verknüpfen und Exportieren / Grafikimport mit dem Befehl "Importieren"

Ändern der Bitmap-Größe

Eine Änderung des dpi-Wertes oder des Skalierungsfaktors ändert die Größe von Bitmap-Grafiken.

So vergrößern oder verkleinern Sie eine Bitmap:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie zunächst die Bitmap aus. Wählen Sie anschließend "Grafik > Objekteinstellungen" und klicken Sie auf "dpi zuweisen".

    Wählen Sie die Bitmap aus. Wählen Sie dann "Grafik > Skalieren" und legen Sie einen Skalierungsfaktor fest.

    Halten Sie die Umschalttaste gedrückt und ziehen Sie einen Eckauswahlpunkt der Bitmap. Die gedrückte Umschalttaste bewirkt, dass die Proportionen der Grafik beibehalten werden.

Hinweis: Wenn es sich bei der Grafik um eine TIFF-Datei handelt (oder um ein anderes Format, das dpi-Einstellungen verwendet), muss die Skalierung über die Objekteinstellungen erfolgen, damit der dpi-Wert bei der Skalierung über das Dialogfenster "Skalieren" nicht verloren geht.


Importieren, Verknüpfen und Exportieren

Arbeiten mit Ziehen und Ablegen (Windows)

Import und Export vereinfachen sich merklich, wenn Sie ein Objekt einfach an eine neue Position ziehen können.

Ziehen Sie eine Grafik aus Photoshop in FrameMaker.

FrameMaker unterstützt beim Ziehen und Ablegen die folgenden Operationen:

    Sie können eine Grafik aus einem geöffneten FrameMaker-Dokumentfenster in ein anderes verschieben, indem Sie die Grafik einfach ziehen. Unter Windows können Sie die Grafik auch kopieren, indem Sie die Strg-Taste gedrückt halten und ziehen. Sie können auch ein Kontextmenü öffnen, indem Sie sie mit der rechten Maustaste ziehen und ablegen.

    Sie können eine Grafik aus einem geöffneten FrameMaker-Dokumentfenster in eine beliebige andere Anwendung ziehen, die das Ziehen und Ablegen unterstützt.

    Sie können auch eine Grafikdatei aus einem Ordner oder vom Desktop in ein geöffnetes Dokumentfenster ziehen.

    In Windows können Sie eine oder mehrere Dokumentdateien in ein Anwendungsfenster ziehen und dort öffnen. Sie können auch eine einzelne Datei in ein Dokumentfenster ziehen, um sie dort einzubetten (siehe Einbetten mit OLE).

Ausgewählter Text kann durch Ziehen und Ablegen nicht verlagert werden. Sie haben aber die Möglichkeit, den Rahmen zu ziehen, der den Text enthält. Auf diese Weise lassen sich kleine Textblöcke in Grafikrahmen (z. B. Überschriften und Bildbeschriftungen) bequem bearbeiten.


Importieren, Verknüpfen und Exportieren

Verwendung von OLE (Windows)

Unter Windows haben Sie die Möglichkeit, beim Importieren durch Referenz anstelle des plattformübergreifenden Befehls "Datei > Importieren > Datei" die Objektverknüpfung und -einbettung (OLE) zu verwenden. Berücksichtigen Sie bei der Entscheidung, ob Text oder Grafiken durch Referenz importiert oder mit OLE eingebettet oder verknüpft werden sollen, die folgenden Faktoren.

    Soll eine verknüpfte importierte Datei zum Symbol verkleinert und nicht in vollem Umfang in Ihrem Dokument angezeigt werden, verwenden Sie eine Verknüpfung mit OLE.

    Verwenden Sie OLE, wenn das einzufügende Material in einem Format vorliegt, das FrameMaker nicht öffnen kann.

    Falls Sie Ihr Dokument auf mehreren Plattformen bearbeiten und anzeigen, führen Sie einen Import durch Referenz aus. OLE funktioniert nur unter Windows.

    Importieren Sie durch Referenz, wenn der Text oder die Grafiken, die Sie einfügen wollen, aus einer Anwendung stammen, die OLE nicht unterstützt.

    Stammt das einzufügende Material aus einem anderen FrameMaker-Dokument, importieren Sie durch Referenz. Damit stehen Ihnen zahlreiche Importoptionen zur Verfügung.


Importieren, Verknüpfen und Exportieren / Verwendung von OLE (Windows)

Einbetten mit OLE

Mithilfe von OLE lassen sich Text oder Grafiken in ein FrameMaker-Dokument einbetten. Eingebettetes Material behält seine Verbindung zu der Anwendung, in der es erstellt wurde (es besitzt aber keine dynamische Verknüpfung zu seinem Quelldokument). Daher können Sie auf ein eingebettetes Objekt doppelklicken, um es in der Anwendung zu öffnen, in der es erstellt wurde. Erstellen Sie das einzubettende Objekt nur in einer Anwendung, die OLE als Server unterstützt.

Sie können auch Multimedia-Objekte wie z. B. Videos oder Filme (.avi- oder .mov-Dateien) und Klangdateien (.wav-Dateien) einbetten.

So betten Sie mit OLE einen Teil einer Datei ein:

    1. Öffnen Sie die betreffende Datei in der zugehörigen Anwendung und kopieren Sie den einzubettenden Teil.

    2. Klicken Sie in FrameMaker an die Position, an der Sie den Text oder die Grafik einfügen wollen, und wählen Sie "Bearbeiten > Einfügen Spezial".

    3. Klicken Sie auf "Einfügen", wählen Sie ein Format für das Objekt (suchen Sie ein Format, das mit "Eingebettet (embedded)" beginnt) und klicken Sie auf "OK".

So betten Sie mit OLE eine ganze Datei ein:

Klicken Sie an die Position, an der Sie den Text oder die Grafik einbetten wollen, und wählen Sie "Datei > Importieren > Objekt". Danach können Sie eine neue, leere Datei einbetten oder den Namen einer vorhandenen Datei angeben.

So betten Sie Material mit OLE über eine Ziehen-Operation ein:

Führen Sie in einer Anwendung, die Ziehen und Ablegen unterstützt, eine der folgenden Aktionen aus:

    Um Text oder Grafiken in ein FrameMaker-Dokument zu verlagern, ziehen Sie das Objekt.

    Wenn Sie ein Objekt nicht verlagern, sondern kopieren wollen, ziehen Sie es, während Sie die Strg-Taste gedrückt halten.

    Um beim Loslassen der Maustaste zwischen Verlagern und Kopieren wählen zu können, ziehen Sie das Objekt mit der rechten Maustaste.


Importieren, Verknüpfen und Exportieren / Verwendung von OLE (Windows)

Verknüpfen mit OLE

Beim Verknüpfen mit einem OLE-Text oder einer OLE-Grafik in einem Dokument verwaltet FrameMaker nicht nur Informationen über die Anwendung, in der das Objekt erstellt wurde, sondern unterhält auch eine dynamische Verbindung mit dem Quelldokument. Wenn sich das Quellmaterial ändert, wird auch seine Darstellung im FrameMaker-Dokument aktualisiert. Erstellen Sie ein Objekt, das Sie verknüpfen wollen, nur in einer Anwendung, die OLE als Server unterstützt.

Verknüpfter Text oder verknüpfte Grafiken werden durch die Bearbeitung des ursprünglichen Quelldokuments geändert. Informationen über das Bearbeiten von verknüpftem Text finden Sie unter Bearbeiten von OLE-Objekten.

So stellen Sie eine Verknüpfung zu einem Teil einer Datei her:

    1. Öffnen Sie die betreffende Datei in der zugehörigen Anwendung und kopieren Sie den Teil, der verknüpft werden soll.

    2. Klicken Sie in FrameMaker an die Position, an der Sie den verknüpften Text oder die verknüpfte Grafik einfügen wollen, und wählen Sie "Bearbeiten > Einfügen Spezial".

    3. Klicken Sie auf "Verknüpfen", wählen Sie ein Format für das Objekt (suchen Sie nach einem Format, das mit "Verknüpft" beginnt) und klicken Sie auf "OK".

So verknüpfen Sie eine ganze Datei mit OLE:

    1. Klicken Sie an die Position, an der Sie die verknüpfte Datei einfügen wollen, und wählen Sie "Datei > Importieren > Objekt". Klicken Sie auf "Aus Datei erstellen" und wählen Sie "Verknüpfen".

    2. Geben Sie den Namen der Datei an, die verknüpft werden soll, und klicken Sie auf "OK".


Importieren, Verknüpfen und Exportieren / Verwendung von OLE (Windows)

Bearbeiten von OLE-Objekten

Sie bearbeiten ein OLE-Objekt in der Anwendung, in der es ursprünglich erstellt wurde. Nach der Bearbeitung werden die Änderungen im FrameMaker-Fenster angezeigt.

So bearbeiten Sie ein eingebettetes OLE-Objekt:

Doppelklicken Sie auf das Objekt. Das Objekt wird in der Anwendung geöffnet, in der es erstellt wurde.

So bearbeiten Sie ein verknüpftes OLE-Objekt:

Führen Sie eine der folgenden Aktionen aus:

    Doppelklicken Sie auf das OLE-Objekt. Das Objekt wird entweder in einem neuen Fenster der Anwendung angezeigt, in der es erstellt wurde, oder die Menüs im FrameMaker-Fenster enthalten vorübergehend Menüs aus der Quellanwendung. In beiden Fällen werden die vorgenommenen Änderungen in das ursprüngliche Dokument übernommen.

    Bearbeiten Sie das Originaldokument außerhalb von FrameMaker in der Anwendung, in der es erstellt wurde.

Informationen über das Bearbeiten von verknüpftem Text finden Sie unter Steuern der Aktualisierung von OLE-Verknüpfungen.


Importieren, Verknüpfen und Exportieren / Verwendung von OLE (Windows)

Steuern der Aktualisierung von OLE-Verknüpfungen

Sie können festlegen, wie und wann mit OLE verknüpfte Objekte mit ihren Quelldokumenten aktualisiert werden. Sie haben die Möglichkeit, eine automatische oder eine manuelle Aktualisierung durchzuführen, und Sie können ein einzelnes verknüpftes Objekt oder mehrere Objekte im Dokument manuell aktualisieren.

Mit OLE eingebettete Objekte können nicht aktualisiert werden, weil sie nicht dynamisch mit ihren Quelldokumenten verknüpft sind.

So ändern Sie die Aktualisierung eines verknüpften OLE-Objekts:

    1. Wählen Sie das Objekt aus und wählen Sie dann "Bearbeiten > Verknüpfungen".

    2. Wählen Sie die verknüpfte Quelle aus der Liste aus, aktivieren Sie "Automatisch" oder "Manuell" als Aktualisierungstyp und klicken Sie auf "OK".

So unterdrücken Sie die Aktualisierung aller verknüpften OLE-Objekte:

    1. Wählen Sie "Bearbeiten > Referenzen aktualisieren".

    2. Wählen Sie aus dem Aufklappmenü "Befehle" die Option "Automatische Aktualisierung unterdrücken". Wählen Sie anschließend die Elemente aus, die nicht automatisch aktualisiert werden sollen.

    3. Klicken Sie auf "Zuweisen" und anschließend auf "Zurück".

So aktualisieren Sie manuell ein einzelnes OLE-Objekt:

Wählen Sie "Bearbeiten > Verknüpfungen" und wählen Sie die Quelldatei, die aktualisiert werden soll. Klicken Sie anschließend auf "Jetzt aktualisieren".


Importieren, Verknüpfen und Exportieren / Verwendung von OLE (Windows)

Trennen von OLE-Verknüpfungen

Wenn Sie eine OLE-Verknüpfung unterbrechen, bleibt der Text oder die Grafik im aktuellen Dokument, wird aber nicht mehr mit den Änderungen in der Quelle aktualisiert. Der Text kann bearbeitet werden.

So trennen Sie eine OLE-Verbindung:

Wählen Sie das Objekt und anschließend die Option "Bearbeiten > Verknüpfungen" aus. Klicken Sie dann auf "Entfernen".


Importieren, Verknüpfen und Exportieren

Arbeiten mit Grafikeinschüben (UNIX)

Ein Grafikeinschub ist eine Grafik, die in einer speziellen UNIX-Anwendung (dem Grafikeinschub-Editor) erstellt und dann in ein Dokument eingefügt wird. Mithilfe des Editors erstellen oder ändern Sie den Grafikeinschub. Sie können den Editor auch von FrameMaker aus starten.

Ihr Systemverwalter hat die Möglichkeit, FrameMaker so zu konfigurieren, dass Einschub-Editoren verwendet werden (siehe das Online-Handbuch Anpassen von FrameMaker-Produkten auf der Adobe-Website: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf). Der Verwalter kann Ihnen auch weitere Informationen über die zu verwendenden Editoren zur Verfügung stellen. Generell arbeiten Sie mit Grafikeinschüben wie mit anderen importierten Grafiken, d. h., Sie können die Einschübe ausschneiden, kopieren und einfügen. (Vermeiden Sie das Drehen eines Einschubs. Wenn Sie einen gedrehten Grafikeinschub im Einschub-Editor öffnen und ihn danach erneut in Ihr Dokument einfügen, geht unter Umständen die Drehung verloren.)

So erstellen Sie unter UNIX einen Grafikeinschub:

    1. Wählen Sie "Spezial > Grafikeinschub". Wenn nur ein Einschub-Editor zur Verfügung steht, werden Sie in einem Meldungsfenster gefragt, ob der Editor gestartet werden soll. Sind mehrere Editoren vorhanden, können Sie den gewünschten wählen.

    2. Erstellen Sie den Grafikeinschub mithilfe des Editors. Informationen dazu finden Sie in der Dokumentation zu Ihrem Editor.

    3. Führen Sie eine der folgenden Aktionen aus:

    Um den Einschub in einem Grafikrahmen zu platzieren, wählen Sie den Rahmen aus oder platzieren die Einfügemarke in einem Textrahmen.

    Wenn Sie den Einschub direkt auf einer Seite einfügen wollen, klicken Sie auf den Seitenrand.

    4. Wählen Sie im Einschub-Editor den Befehl, mit dem der Grafikeinschub in ein Dokument platziert wird.

So bearbeiten Sie unter UNIX einen Grafikeinschub:

    1. Doppelklicken Sie auf den Grafikeinschub. Klicken Sie bei entsprechender Aufforderung auf "OK", um den Editor zu starten.

    2. Ändern Sie den Grafikeinschub mithilfe des Editors.

    3. Wählen Sie im Einschub-Editor den Befehl, mit dem der Grafikeinschub in ein Dokument platziert wird.


Importieren, Verknüpfen und Exportieren

Exportieren von Text und Grafiken

Mithilfe folgender Techniken können Sie Text und Grafiken exportieren:

    Kopieren Sie die Objekte und fügen Sie sie in eine andere Datei oder Anwendung ein.

    Speichern Sie ein Dokument in einem anderen Format.

    Verwenden Sie Druckoptionen, um eine PostScript- oder EPS-Datei zu erstellen. Weitere Informationen hierzu finden Sie unter Erstellen von PostScript-Dateien.

    Legen Sie eine PDF-Datei (Portable Document Format) an (siehe Überblick über Adobe PDF).

    Speichern Sie die Datei im HTML-Format, das die Grafiken in einem Dokument in das GIF-, PNG- oder JPEG-Format konvertieren kann (siehe Festlegen der Grafikkonvertierung).

    Speichern Sie Ihr Dokument im XML-Format (siehe XML).

    (Windows) Senden Sie das Dokument als E-Mail-Anlage.

    (Windows) Verwenden Sie Ziehen und Ablegen (siehe Arbeiten mit Ziehen und Ablegen (Windows)).

Hinweis: (UNIX) Einige Grafikkonvertierungen stehen in Form von Dienstprogrammen über die Befehlszeile zur Verfügung. Weitere Informationen finden Sie im Online-Handbuch Verwenden von Filtern.


Importieren, Verknüpfen und Exportieren / Exportieren von Text und Grafiken

Verwenden von "Sichern unter" zum Export in andere Formate

Sie können ein FrameMaker-Dokument in andere Anwendungen exportieren, indem Sie es in einem anderen Format speichern (siehe Sichern von Dokumenten). Wenn Sie ein Dokument in einem Textbearbeitungsformat speichern, kann es in der betreffenden Anwendung mit den meisten Formatierungen weiterverwendet werden. Die verfügbaren Formate hängen von der verwendeten Plattform und von den installierten Filtern ab.

Die beiden textorientierten Dateiformate RTF (Rich Text Format) und MIF (Maker Interchange Format) sind so genannte Austauschformate. Sie werden von einer großen Anzahl von Programmen akzeptiert und dienen häufig als Brücke zwischen FrameMaker und einer anderen Anwendung, die das native Format nicht lesen kann.

Speichern von MIF-Dateien

Sie können FrameMaker-Dateien in den Formaten MIF 7.0 (MIF-Classic) und MIF 8.0 (MIF-Unicode) speichern. Beim Speichern eines FrameMaker-Dokuments als MIF-Datei können Sie zwischen diesen beiden Optionen wählen.

  • MIF-Classic: Wenn Sie dieses Format auswählen, wird eine MIF-Datei erzeugt, die dem aufwärtskompatiblen Originalformat ähnlich ist. Alle Unicode-Inhalte, die nicht im älteren Format dargestellt werden können, werden durch ein Zeichen ersetzt, die Sie in der Konfigurationsdatei (maker.ini unter Windows) konfigurieren können.

  • MIF-Unicode: Wenn Sie dieses Format auswählen, wird eine MIF-Datei erzeugt, die Unicode-Zeichenfolgen enthält. Alle Zeichenfolgen-Daten haben das UTF-8-Format.

Sie können ein Dokument auch im HTML-, XML- oder PDF-Format speichern.


Importieren, Verknüpfen und Exportieren / Exportieren von Text und Grafiken

Senden von Dateien in einer E-Mail (Windows)

Wenn ein MAPI-kompatibles (Messaging Application Programming Interface) E-Mail-System auf dem Windows-Computer installiert ist, können Sie ein Dokument als E-Mail-Anlage senden. Wenn der Computer noch nicht für MAPI konfiguriert ist, werden Sie bei dem ersten Versuch, ein Dokument zu schicken, von Windows durch eine Reihe von Dialogfenstern geführt. Wenn Sie dabei Hilfe benötigen, wenden Sie sich an Ihren Netzwerkadministrator.

Hinweis: Das Menü und die Kurzbefehle zum Versenden von E-Mails können nur für einzelne Dokumente, nicht aber für Buchdateien verwendet werden. Es ist nicht möglich, eine Buchdatei per E-Mail zu versenden.

So senden Sie ein Dokument unter Windows als E-Mail-Anlage:

    1. Wählen Sie "Datei > Senden".

    2. Wählen Sie im Dialogfenster "Profil auswählen" ein E-Mail-Profil aus und klicken Sie auf "OK".

    3. Füllen Sie die E-Mail-Felder aus und senden Sie die Nachricht wie gewohnt ab.


Importieren, Verknüpfen und Exportieren

Importieren von Text in strukturierte Dokumente

Sie können Text aus folgenden Quellen in ein strukturiertes FrameMaker-Dokument importieren:

    Ein Textfluss aus einem anderen Teil des Dokuments, aus einem anderen strukturierten FrameMaker-Dokument oder aus einer MIF-Datei. Im Textfluss enthaltener bedingter Text sowie Querverweise, Tabellen, Textmarken, Fußnoten, Variablen und verankerte Rahmen werden importiert.

    Eine in einer anderen Anwendung erstellte Datei, für die ein Importfilter auf Ihrem System installiert ist. Spezielle Objekte wie Querverweise und Tabellen können ebenfalls importiert werden (abhängig von der benutzten Anwendung und den verwendeten Filtern).

Wenn ein strukturierter Text importiert wird, können Sie die Struktur beibehalten oder entfernen. Wenn der Text formatiert ist, können Sie die Formatierung beibehalten oder entfernen, oder Sie können den Text mit den Formatierungsinformationen des aktuellen Dokuments neu formatieren.

Importierter Text kann in das Dokument kopiert werden, was den Befehlen "Kopieren" und "Einfügen" entspricht. Er lässt sich auch über Referenzen als Texteinschub importieren, wobei er einen Verweis auf seine Quelldatei beibehält. Beim Import durch Referenz wird der Texteinschub im Dokumentfenster angezeigt, lässt sich aber nicht bearbeiten. Wenn der Einschub strukturiert ist, wird seine Struktur in der Strukturansicht angezeigt; sie kann jedoch nicht bearbeitet werden.

Ein Texteinschub bleibt mit seinem Quelldokument verknüpft.

In diesem Abschnitt wird beschrieben, wie formatierter oder strukturierter Text importiert werden kann. Informationen über den Import einer Text- oder MIF-Datei bzw. das Aktualisieren und Bearbeiten eines Texteinschubs nach dem Import finden Sie unter Textimport mit dem Befehl "Importieren".

So importieren Sie Text:

    1. Klicken Sie an der Stelle, an der Sie den Text einfügen wollen.

    2. Wählen Sie "Datei > Importieren > Datei".

    3. Wählen Sie die Datei mit dem zu importierenden Text aus und geben Sie an, ob Sie durch Kopieren oder Referenz importieren wollen (siehe Importieren durch Kopieren).

    4. Wenn das Dialogfenster "Unbekannter Dateityp" angezeigt wird, wählen Sie einen Dateityp aus und klicken auf "Konvertieren".

Das nächste Dialogfenster hängt von der in Schritt 3 gewählten Importmethode ab. Das Dialogfenster "Textfluss durch Referenz importieren" enthält Einstellungen für die Aktualisierung des importierten Textflusses.

Geben Sie an, wie der importierte Textfluss formatiert und aktualisiert werden soll.

    5. Wählen Sie aus einem Aufklappmenü einen Arbeitsseitenfluss oder einen Referenzseitenfluss aus. Der Import von Text erfolgt meist auf Arbeitsseiten. Referenzseiten können Textflüsse mit Mustertext für die Verwendung auf Arbeitsseiten enthalten.

    6. Geben Sie an, wie Struktur und Formatierung des importierten Textes behandelt werden sollen, indem Sie eine der folgenden Möglichkeiten wählen:

    Um die Struktur des Textflusses beizubehalten und die Formate und Elementformatregeln des aktuellen Dokuments auf den Text anzuwenden, aktivieren Sie "Mit Katalog des akt. Dokuments neu formatieren". Stimmen Element-Tags der beiden Dokumente nicht überein, bleibt die Formatierung des importierten Textes erhalten. Sie sollten die Optionen zum Entfernen von Seitenumbrüchen und anderer irregulärer Formatierungen aktivieren, damit der importierte Text dem Aussehen des aktuellen Dokuments angepasst wird.

    Um Struktur und Formatierung aus dem Text zu entfernen und die Formatierung anzuwenden, die an der Einfügemarke verwendet wird, aktivieren Sie "Als Standardtext formatieren". (Text in Tabellen oder verankerten Rahmen behält die ursprüngliche Formatierung des Quelldokuments bei.)

    Um die Struktur zu entfernen und gleichzeitig die Formatierung beizubehalten, aktivieren Sie "Quellformatierung beibehalten". Die Formate des importierten Textes werden nicht in die Formatkataloge des aktuellen Dokuments aufgenommen. Wenn Sie die Formate des aktuellen Dokuments später ändern, werden die importierten Formate davon nicht betroffen, selbst wenn die Tags des aktuellen Dokuments und des importierten Textes übereinstimmen.

    7. Wenn Sie durch Referenz importieren, geben Sie durch eine der folgenden Aktionen an, wie der Texteinschub aktualisiert werden soll:

    Um den Texteinschub bei jedem Öffnen des Dokuments zu aktualisieren, aktivieren Sie "Automatisch".

    Um nur dann zu aktualisieren, wenn Sie es wünschen, aktivieren Sie "Manuell".

    8. Klicken Sie auf "Importieren".


Importieren, Verknüpfen und Exportieren

Einfügen von importierten Grafikelementen in strukturierte Dokumente

Einige Grafikelemente sind so definiert, dass Grafik und Element gemeinsam importiert werden. Wenn Sie das Element einfügen, zeigt FrameMaker ein Dialogfenster für den Import an. Die importierte Grafik wird in einem verankerten Rahmen unterhalb der Linie mit dem Ankersymbol angezeigt, und die Größe des Rahmens wird der Grafik automatisch angepasst.

Importierte Grafik in einem verankerten Rahmen

Nach dem Einfügen des Elements können Sie den Rahmen durch Verschieben, Ändern der Größe usw. bearbeiten (siehe Bearbeiten verankerter Rahmen).

Sie können eine Grafik auch in einen vorhandenen verankerten Rahmen importieren, z. B. wenn Sie ein Grafikelement verwendet haben, das einen leeren Rahmen im Dokument platziert hat.

Wenn Sie ein Grafikelement importieren, kann dieses Bestandteil des Dokuments werden (Import durch Kopieren) oder mit der ursprünglichen Anwendung bzw. dem ursprünglichen Dokument verknüpft bleiben (Import durch Referenz). Weitere Informationen finden Sie unter Wählen der geeigneten Methode für das Importieren und Verknüpfen.

Informationen über das Einfügen einer importierten Grafik, die kein Element ist (ein Vorgang, der nur in einem unstrukturierten Textfluss möglich ist), finden Sie unter Grafikimport mit dem Befehl "Importieren".

So fügen Sie ein importiertes Grafikelement ein:

    1. Klicken Sie an der Stelle, an der Sie den Rahmen verankern wollen.

    2. Wählen Sie im Elementkatalog ein importiertes Grafikelement aus und klicken Sie auf "Einfügen".

Sie können auch den Befehl "Datei > Importieren > Datei" verwenden, um ein Element einzufügen. Wählen Sie eine Datei aus und klicken Sie auf "Importieren". Wenn mehrere importierte Grafikelemente verfügbar sind, wird ein Dialogfenster geöffnet, in dem Sie das gewünschte Element aus dem Aufklappmenü "Element-Tag" auswählen können.

    3. Wählen Sie die gewünschte Grafikdatei aus und geben Sie an, ob Sie durch Referenz oder Kopieren importieren wollen (siehe Importieren durch Kopieren).

    4. Klicken Sie auf "Importieren".

    5. Wenn das Dialogfenster "Unbekannter Dateityp" angezeigt wird, wählen Sie aus der Auswahlliste einen Dateityp aus und klicken auf "Konvertieren".

    6. Wenn die importierte Grafik eine Bitmap-Grafik ist, aktivieren Sie im Aufklappmenü eine Skalierungsoption und klicken auf "Zuweisen" (siehe Ändern der Bitmap-Größe). Je größer der dpi-Wert ist, um so kleiner wird die Bitmap-Grafik auf der Seite dargestellt.

Ein verankerter Rahmen wird gemeinsam mit der importierten Grafik an der Einfügemarke im Dokumentfenster mit einem Ankersymbol ( [image] ) angezeigt. In der Strukturansicht erscheint ein Strukturrechteck mit dem Textausschnitt <GRAFIK>.

Wenn an der gewünschten Position kein importiertes Grafikelement verfügbar ist, können Sie ein ungültiges Element verwenden. Informieren Sie sich nach Einfügen des Elements bei Ihrem Entwickler darüber, wie sich das Element an dieser Position in ein gültiges Element umwandeln lässt.

So verwenden Sie ein ungültiges importiertes Grafikelement:

Führen Sie eine der folgenden Aktionen aus:

    Um ein Element zu verwenden, das in einem anderen Teil des Dokuments gültig ist, fügen Sie das Element an einer gültigen Position ein und verschieben es, oder benutzen Sie die Einstellung "Alle Elemente" (siehe Ändern des Anzeigebereichs für verfügbare Elemente in einem strukturierten Dokument), um das Element überall verfügbar zu machen, und fügen Sie das Element dann an der gewünschten Position ein.

    Um ein ungültiges Element mit dem Standard-Tag GRAFIK einzufügen, benutzen Sie zum Importieren einer Grafik den Befehl "Datei > Importieren > Datei". (Dem Element wird das Standard-Tag zugewiesen, wenn keine definierten importierten Grafikelemente verfügbar sind.)

So fügen Sie eine importierte Grafik in einen vorhandenen verankerten Rahmen ein:

Wählen Sie den Rahmen aus und wählen Sie zum Importieren der Grafik den Befehl "Datei > Importieren > Datei".


Importieren, Verknüpfen und Exportieren / Einfügen von importierten Grafikelementen in strukturierte Dokumente

Systemspezifische Importmethoden für Grafikelemente

Für den Import von Grafiken definierte Elemente verwenden eine auf allen Plattformen verfügbare Datei-Importmethode. Um eine Grafikdatei durch Referenz zu importieren, wenn Sie nur auf einer Plattform arbeiten, verwenden Sie "OLE" auf Windows- und "Grafikeinschübe" auf UNIX-Systemen.

Um eine systemspezifische Importmethode zu verwenden, fügen Sie ein verankertes Rahmenelement ein, wählen den Rahmen aus und legen die Importmethode fest.


Importieren, Verknüpfen und Exportieren

Verwenden der Dateiimport-Funktion

In FrameMaker können Adobe® PageMaker®-, QuarkXPress®-, Adobe Photoshop-, JPEG 2000-, SVG-, PDF- (UNIX) und Adobe Illustrator- (UNIX) Dateien importiert werden.

Importieren von PageMaker- und QuarkXPress-Dateien

Importieren von Photoshop-Dateien

Importieren von JPEG 2000-Dateien

Importieren von SVG-Bildern

Importieren von PDF- und Illustrator-Dateien (UNIX)


Importieren, Verknüpfen und Exportieren / Verwenden der Dateiimport-Funktion

Importieren von PageMaker- und QuarkXPress-Dateien

In FrameMaker können Sie PageMaker 6.5- und 7.0- sowie QuarkXPress 3.3- und 4.1-Dokumente importieren.

FrameMaker importiert die Hauptkomponenten von PageMaker- und QuarkXPress-Dateien wie im Folgenden beschrieben.

Vorgabeseiten

FrameMaker fügt für jede Vorgabeseite im importierten Dokument eine neue Vorgabeseite hinzu. Alle Vorgabeseiten-Element werden auf den entsprechenden Vorgabeseiten in FrameMaker platziert. Wenn Sie in PageMaker Vorgabeseiten selbst benannt haben, verwendet FrameMaker dieselben Namen.

Bei QuarkXPress-Dokumenten importiert FrameMaker alle Textobjekte auf Vorgabeseiten als Textflüsse und behält alle irregulären Einstellungen der Arbeitsseiten dafür bei. Irreguläre Einstellungen für andere Objekte auf Arbeitsseiten werden von FrameMaker verworfen.

Abschnitte

FrameMaker ignoriert Abschnitte und importiert lediglich deren Inhalte.

Ebenen

FrameMaker behandelt alle Ebenen in einem importierten Dokument als eine Ebene. Die Seitenelemente werden gemäß ihrer Stapelreihenfolge auf der Seite angezeigt. Zunächst kommen die Elemente auf der Vorgabeseite und dann die der Arbeitsseite.

Zeichenstile

FrameMaker erstellt neue Zeichenformate für die Zeichenstile im importierten Dokument. Hat ein Zeichenstil denselben Namen wie ein Zeichenformat in FrameMaker, werden die Attribute im Zeichenformat durch die entsprechenden Attribute aus der importierten Datei ersetzt. FrameMaker importiert keine PageMaker- oder QuarkXPress-Zeichenattribute, die FrameMaker nicht unterstützt.

Absatzstile

FrameMaker erstellt neue Absatzformate für die Absatzstile im importierten Dokument. Hat ein Absatzstil denselben Namen wie ein Absatzformat in FrameMaker, werden die Attribute im Absatzformat durch die entsprechenden Attribute aus der importierten Datei ersetzt. FrameMaker importiert keine PageMaker- oder QuarkXPress-Absatzattribute, die FrameMaker nicht unterstützt.

FrameMaker erstellt ein Absatzformat (rechts) für jeden Absatzstil (links) im importierten PageMaker-Dokument.

Absätze mit lokalen irregulären Formaten im Originaldokument werden von FrameMaker ebenfalls wie irreguläre Formate behandelt.

Beim Import von Text mit Tags aus PageMaker werden die tatsächlichen Tag-Namen im FrameMaker-Dokument angezeigt. Deaktivieren Sie im PageMaker-Dialogfenster für den Textexport die Option zum Export von Tags, damit nur der Text und nicht der Tag-Name importiert wird.

Absatzregeln

FrameMaker importiert Absatzregeln als einzeiligen Rahmen, der auf den Referenzseiten definiert ist. Alle anderen Einstellungen, die auf die Regeln angewendet werden, beispielsweise Linienfarbe oder Linienstile, werden nicht importiert.

Zeichnungsobjekte

FrameMaker importiert alle Zeichnungsobjekte. Unterscheiden sich die Füll- und die Strichfarbe, wird die Füllfarbe für Striche und Füllung verwendet. Die Konturlaufeinstellungen werden nicht übernommen.

Nicht-druckbare Objekte

FrameMaker importiert nicht-druckbare Objekte nicht.

Tate-Chu-Yoko

Da FrameMaker keinen vertikalen Text unterstützt, behandelt FrameMaker Tate-Chu-Yoko als horizontalen Text.

Farbdefinitionen

FrameMaker erstellt Farbdefinitionen, um benutzerdefinierte Farben oder Farben aus einer Farbbibliothek, die in der PageMaker- oder QuarkXPress-Datei definiert sind, abzugleichen. Gibt es jedoch in FrameMaker bereits eine Farbdefinition gleichen Namens, wird die FrameMaker-Farbe verwendet, und es wir keine neue Farbe erstellt.

Grafiken

FrameMaker verwendet Filter zum Importieren verknüpfter (referenzierter) Grafikdateien. Steht FrameMaker kein geeigneter Filter zur Verfügung, werden die Grafikdateien nicht importiert. Bei eingebetteten Grafiken verwendet FrameMaker die Bilddaten für den Import der Grafiken.

Beim Import einer frei stehenden Grafik platziert FrameMaker die Grafik an derselben Position wie in der Originaldatei. Beim Import einer eingebundenen Grafik platziert FrameMaker die Grafik im Textfluss an derselben Textposition wie in der Originaldatei.

OLE-Objekte

FrameMaker unterstützt OLE. FrameMaker importiert OLE-Objekte, unter der Voraussetzung, dass FrameMaker deren Grafikformat unterstützt.

Gruppierte Objekte

FrameMaker unterstützt die hierarchische Gruppierung von Objekten.

Hyperlinks

FrameMaker unterstützt Hyperlinks. Bei PageMaker-Dokumenten importiert FrameMaker Objekt- und Seitenelement-Anker als Querverweise.

Inhaltsverzeichnis

FrameMaker importiert in QuarkXPress oder PageMaker erzeugte Inhaltsverzeichnisse als gewöhnlichen Text.

Pasteboards

FrameMaker importiert alle Pasteboard-Objekte "inline" im entsprechenden verankerten Rahmen. FrameMaker erstellt für die importierten Pasteboard-Objekte einen separaten Abschnitt auf den Referenzseiten.

Indexerstellung

FrameMaker importiert alle Indexeintragsmarken, behandelt den Index jedoch als herkömmlichen Text.

So importieren Sie eine PageMaker- oder QuarkXPress-Datei:

    1. Wählen Sie in FrameMaker "Datei > Öffnen" und geben Sie die zu importierende PageMaker- oder QuarkXPress-Datei ein.

    2. Wählen Sie im Dialogfenster "Unbekannter Dateityp" den Dateityp aus:

    Wenn Sie eine PageMaker-Datei importieren, wählen Sie "PageMaker [Version]-Dokument" oder "PageMaker [Version]-Vorlage".

    Wählen Sie beim Importieren einer QuarkXPress-Datei die Option "QuarkXpress-Dokument (3.3-4.1x)".

    3. Klicken Sie auf "Konvertieren". Wenn das Dialogfenster "Fehlende Datei" geöffnet wird, gehen Sie in den Ordner mit der fehlenden Datei, klicken Sie auf den Namen der Datei und anschließend auf "Fortfahren".


Importieren, Verknüpfen und Exportieren / Verwenden der Dateiimport-Funktion

Importieren von Photoshop-Dateien

FrameMaker unterstützt den Import von Adobe Photoshop-Dateien im PSD-Format. FrameMaker konvertiert PSD-Dateien in das native FrameImage-Format und konvertiert den Farbraum (Photoshop RGB, CMYK, LAB, Indiziert, GrayScale oder Bitmap) nach RGB.

Der Import von PSD-Dateien verläuft auf dieselbe Art wie der Import anderer Grafikarten.


Importieren, Verknüpfen und Exportieren / Verwenden der Dateiimport-Funktion

Importieren von JPEG 2000-Dateien

FrameMaker unterstützt JPEG 2000, eine Version des beliebten Bildkomprimierungsformats JPEG.

Beim Import von JPEG 2000-Dateien konvertiert der Filter die unterstützten Farbmodi RGB, CMYK, GrayScale und LAB, und verwirft nicht unterstützte Modi wie Index. Der Filter unterstützt keine Bilder mit 16 Bit pro Kanal.

So importieren Sie eine JPEG 2000-Datei:

    1. Wählen Sie "Datei> Importieren> Datei".

    2. Geben Sie die zu importierende Datei an und wählen Sie die Option "Import durch Referenz" bzw. "In Dokument kopieren".

    3. Klicken Sie auf "Importieren". Wenn das Dialogfenster "Unbekannter Dateityp" angezeigt wird, wählen Sie JPC, J2C, JPX, JPF, J2K oder JP2 aus und klicken auf "Konvertieren".


Importieren, Verknüpfen und Exportieren / Verwenden der Dateiimport-Funktion

Importieren von SVG-Bildern

FrameMaker druckt SVG-Bilder auf PostScript-Druckern aus, indem die Bilder mithilfe von Encapsulated PostScript (EPS) als Vektorgrafiken dargestellt werden. Bei Druckern, die nicht PostScript-fähig sind, verwendet FrameMaker das FrameImage-Format.

Wenn Sie anhand eines Dokuments, das ein SVG-Bild enthält, eine PDF-Datei erstellen, wird das Bild als Vektoren angezeigt, was zu einer verbesserten Darstellung in Acrobat führt und ein Vergrößern und Verkleinern der Anzeige ohne Pixelierung ermöglicht.

Hinweis: Eingebettete SVG-Bildanimationen funktionieren in FrameMaker nicht.

So importieren Sie eine SVG-Grafik:

    1. Wählen Sie "Datei> Importieren> Datei".

    2. Klicken Sie auf "Importieren".

    3. Geben Sie die zu importierende Datei an und wählen Sie die Option "Import durch Referenz" bzw. "In Dokument kopieren".

    4. Klicken Sie auf "Importieren".

    5. Legen Sie im Dialogfenster "SVG importieren" die Rasterqualität fest.

    6. Bestimmen Sie die Bildgröße, wenn diese von der Standardgröße abweicht (in diesem Dialogfenster ist proportionales Skalieren nicht möglich).

    7. Klicken Sie auf "Zuweisen".

Hinweis: In Abhängigkeit von der Rasterqualität und dem verfügbaren Speicher kann der Import der SVG-Grafik einige Minuten dauern.


Importieren, Verknüpfen und Exportieren / Verwenden der Dateiimport-Funktion

Importieren von PDF- und Illustrator-Dateien (UNIX)

Sie können Adobe PDF-Dateien und Illustrator 9- und 10-Dateien in FrameMaker-Dokumente importieren.

Beim Importieren einer PDF- oder Illustrator-Datei in FrameMaker wird die Datei als Grafik behandelt, und es kann jeweils nur eine Seite importiert werden. Sie können sie entweder durch Kopieren oder durch Referenz importieren. Sowohl Prozess- als auch Schmuckfarben können angezeigt und gedruckt werden.

Hinweis: Der Ausdruck von Grafiken mit Transparenzeffekten auf einem PostScript Level 1-Drucker oder einem nicht PostScript-fähigen Drucker kann vom erwarteten Ergebnis abweichen. Wenn Sie FrameMaker mit der Option -noapi (./maker.exe -noapi) starten, können keine PDF-Dateien importiert werden.

So importieren Sie eine PDF- oder Illustrator-Datei:

    1. Wählen Sie in FrameMaker "Datei > Importieren > Datei" und geben Sie die zu importierende PDF- oder Illustrator-Datei an.

    2. Wählen Sie zwischen den Optionen "Import durch Referenz" und "In Dokument kopieren".

    3. Klicken Sie auf "Importieren".

    4. Hat die Datei mehrere Seiten, geben Sie die gewünschte Seitenzahl in das Textfeld ein.

    5. Klicken Sie auf "Auswählen".

Hinweis: Dateien von Illustrator 9 und 10 werden entsprechend der Seitengröße importiert. Ändern Sie die Größe des verankerten Rahmens, um Leerräume aus der Grafik herauszuschneiden.


Importieren, Verknüpfen und Exportieren

Importieren von SWF-Dateien in FrameMaker-Dokumente (Windows)

Sie können SWF-Dateien (beispielsweise Adobe Captivate-Demos) entweder durch Kopieren oder durch Referenz in FrameMaker-Dokumente importieren.

Hinweis: Stellen Sie sicher, dass auf dem Computer zur Wiedergabe von SWF-Dateien Adobe Flash Player installiert ist.

    1. Platzieren Sie den Einfügepunkt im Dokument an der Stelle, an der die SWF-Datei angezeigt werden soll.

    2. Wählen Sie "Datei > Importieren > Datei".

Das Dialogfenster "Importieren" wird angezeigt.

    3. Wechseln Sie zur einzufügenden SWF-Datei und wählen Sie diese aus.

    4. Wählen Sie zwischen den Optionen "In Dokument kopieren" und "Import durch Referenz".

    5. Klicken Sie auf "Importieren".

Das Dialogfenster "Auflösung der importierten Grafik" wird angezeigt.

    6. Wählen Sie den DPI-Wert aus.

    7. Klicken Sie auf "Zuweisen".

Wenn Sie auf "Zuweisen" klicken, wird der erste Rahmen der SWF-Datei im Dokument angezeigt. Wenn Sie die Datei durch Referenz importiert haben, doppelklicken Sie auf den ersten Rahmen, um die SWF-Datei in einem separaten Adobe Flash Player-Fenster wiederzugeben. Wenn Sie die SWF-Datei in das Dokument kopiert haben, wird ein Bitmap-Bild des ersten Rahmens angezeigt. Klicken Sie auf diesen Rahmen, um die SWF-Datei zu aktivieren. Ist der erste Rahmen leer, wird der verankerte Rahmen mit der SWF-Datei leer angezeigt.

Hinweis: Sie können eine SWF-Datei in einem FrameMaker-Dokument nicht grafisch bearbeiten.


Importieren, Verknüpfen und Exportieren / Importieren von SWF-Dateien in FrameMaker-Dokumente (Windows)

Speichern von Dokumenten mit SWF-Dateien

Dokumente, die SWF-Dateien enthalten, können in den Formaten PDF, HTML und XML gespeichert werden. Außerdem können Sie Dokumente drucken, die SWF-Dateien enthalten.

Speichern von Dokumenten mit SWF-Dateien im PDF-Format

    1. Wählen Sie "Datei > Öffnen" und öffnen Sie das FrameMaker-Buch bzw. die -Datei mit den SWF-Dateien.

    2. Wählen Sie "Datei > Als PDF speichern".

    3. Sie können den Speicherort und den Dateinamen bei Bedarf ändern und anschließend auf "Sichern" klicken.

    4. Klicken Sie im Dialogfenster "PDF-Einstellungen" auf "Zuweisen", um eine PDF-Datei mit den Standardeinstellungen zu erstellen. Andernfalls nehmen Sie die erforderlichen Änderungen vor und klicken Sie anschließend auf "Zuweisen". Die SWF-Datei wird in das Buch bzw. die Datei importiert und gespeichert. Ist auf dem Computer Flash Player installiert, können Sie das PDF-Dokument öffnen und die SWF-Datei wiedergeben.

Hinweis: FrameMaker ist standardmäßig für die Einbettung von SWF-Dateien in PDF-Dateien konfiguriert. Sie können diese Option jedoch auch deaktivieren. Weitere Informationen finden Sie unter Aktivieren und Deaktivieren der Einbettung von SWF-Dateien in PDF-Dateien.

Wenn Sie ein PDF-Dokument mit einer SWF-Datei öffnen, wird das Dialogfenster "Berechtigungen für Multimedia-Inhalt verwalten" geöffnet. Wählen Sie die Option "Multimedia-Inhalt einmalig abspielen" oder "Multimedia-Inhalt abspielen und dieses Dokument der Liste vertrauenswürdiger Dokumente hinzufügen" und starten Sie die Wiedergabe durch Klicken auf das entsprechende Feld. Stellen Sie sicher, dass Adobe Acrobat Reader® 7.0.7 oder höher bzw. Adobe Acrobat 3D 7.0.7 oder höher installiert ist, um das erzeugte PDF-Dokument mit SWF-Dateien anzuzeigen.

Speichern von Dokumenten mit SWF-Dateien im HTML-Format

Sie können ein SWF-Datei in ein Dokument importieren und dieses als HTML-Datei speichern. Dabei wird automatisch eine CSS-Datei erzeugt. Wenn Sie eine SWF-Datei durch Kopieren in ein unstrukturiertes Dokument importiert haben, werden die SWF-Dateien mit der HTML-Datei als GIF-Dateien gespeichert. Wenn Sie eine SWF-Datei durch Kopieren in ein strukturiertes Dokument importiert haben, werden die SWF-Dateien separat gespeichert. Wenn Sie die HTML-Datei öffnen, können Sie den SWF-Inhalt durch Klicken wiedergeben.

    1. Wählen Sie "Datei > Öffnen" und öffnen Sie das FrameMaker-Buch bzw. die -Datei mit den SWF-Dateien.

    2. Wählen Sie "Datei > Als HTML sichern".

    3. Sie können den Speicherort und den Dateinamen bei Bedarf ändern und anschließend auf "Sichern" klicken.

Speichern von Dokumenten mit SWF-Dateien im XML-Format

Sie können eine FrameMaker-Datei, die eine SWF-Datei enthält, als XML-Datei speichern. Wenn Sie die XML-Datei in FrameMaker öffnen, bleibt die SWF-Datei auch beim Speichern der XML-Datei (Roundtrip) erhalten. Um die Roundtripping-Fähigkeit von SWF-Dateien zu gewährleisten, stellen Sie sicher, dass die XML-Datei die korrekten Lese-/Schreibregeln enthält, bevor Sie die Datei im XML-Format speichern.

Hinweis: Stellen Sie sicher, dass Sie eine XML-Datei mit einer Grafikelementdefinition erstellen oder öffnen, bevor Sie eine SWF-Datei darin importieren.

    1. Wählen Sie "Datei > Öffnen" und öffnen Sie die XML-Datei mit den SWF-Dateien.

    2. Wählen Sie "Datei > Als XML speichern".

    3. Sie können den Speicherort und den Dateinamen bei Bedarf ändern und anschließend auf "Sichern" klicken.

War der SWF-Inhalt in die FrameMaker-Datei eingebettet und wird das Dokument als XML-Datei gespeichert, dann wird der SWF-Inhalt in einer unabhängigen SWF-Datei gespeichert. Außerdem wird in der XML-Datei eine Referenz zum SWF-Inhalt erstellt.

Drucken von FrameMaker-Dateien mit SWF-Dateien

FrameMaker-Dokumente, die SWF-Dateien enthalten, können ausgedruckt werden. Die SWF-Dateien werden als Bilder dargestellt. Ist der erste Rahmen nicht leer, wird ein Bitmap davon gedruckt.

    1. Öffnen Sie das FrameMaker-Dokument, das SWF-Dateien enthält.

    2. Wählen Sie "Datei > Drucken".

    3. Legen Sie die weiteren Druckoptionen wie erforderlich fest und klicken Sie anschließend auf "Drucken". Informationen über die weiteren Druckoptionen finden Sie unter Druckoptionen.


Importieren, Verknüpfen und Exportieren

Importieren von 3D-Objekten in FrameMaker-Dokumente (Windows)

Sie haben die Möglichkeit, 3D-Objekte (U3D-Format) entweder durch Kopieren oder durch Referenz in Dokumente zu importieren. Sie können Parameter wie die Standardansicht, den Darstellungsmodus, die Hintergrundfarbe und das Beleuchtungsschema für das 3D-Objekt einstellen. Sie können ein 3D-Objekt auch in einem verankerten oder nicht verankerten Rahmen darstellen lassen.

    1. Platzieren Sie die Einfügemarke an der Stelle im Dokument, an der das 3D-Objekt angezeigt werden soll.

    2. Wählen Sie "Datei > Importieren > Datei".

Das Dialogfenster "Importieren" wird angezeigt.

    3. Wechseln Sie zur zu importierenden U3D-Datei und wählen Sie diese aus.

    4. Wählen Sie zwischen den Optionen "In Dokument kopieren" und "Import durch Referenz".

    5. Klicken Sie auf "Importieren".

Das Dialogfenster "Auflösung der importierten Grafik" wird angezeigt.

    6. Wählen Sie den DPI-Wert aus.

    7. Klicken Sie auf "Zuweisen".

Wenn Sie auf "Zuweisen" klicken, wird die Bitmap des 3D-Objekts im Dokument angezeigt. Wenn Sie das 3D-Objekt durch Kopieren importiert haben, wird die U3D-Datei als geräteunabhängige Bitmap (DIB, vom Englischen "device-independent bitmap") in das Dokument eingebettet. Wenn Sie das 3D-Objekt durch Referenz importiert haben, wird ein mit der U3D-Quelldatei verknüpftes Bitmap-Bild in das Dokument eingefügt. Unabhängig von der Importmethode für die 3D-Datei im Dokument als Grafiktyp DIB angezeigt.

Wenn Sie das 3D-Objekt in ein Dokument importieren und dieses im PDF- oder XML-Format speichern, werden alle Informationen zum 3D-Objekt beibehalten.


Importieren, Verknüpfen und Exportieren / Importieren von 3D-Objekten in FrameMaker-Dokumente (Windows)

Speichern von Dokumenten mit 3D-Objekten

Sie können Dokumente mit 3D-Objekten in den Formaten PDF und XML speichern.

    1. Wählen Sie "Datei > Öffnen" und öffnen Sie das FrameMaker-Buch bzw. die -Datei mit den 3D-Objekten.

    2. Wählen Sie "Datei > Als PDF speichern".

    3. Sie können den Speicherort und den Dateinamen bei Bedarf ändern und anschließend auf "Sichern" klicken.

    4. Klicken Sie im Dialogfenster "PDF-Einstellungen" auf "Zuweisen", um eine PDF-Datei mit den Standardeinstellungen zu erstellen. Andernfalls nehmen Sie die erforderlichen Änderungen vor und klicken Sie anschließend auf "Zuweisen". Die in das Buch bzw. die Datei importierte U3D-Datei und alle ihre Ansichten werden ebenfalls gespeichert. Wenn Sie das PDF-Dokument öffnen, wird die zuletzt für das 3D-Objekt im Dokument ausgewählte Ansicht im PDF-Dokument angezeigt.

Hinweis: FrameMaker ist standardmäßig für die Einbettung von 3D-Objekten in PDF-Dateien konfiguriert. Sie können diese Option jedoch auch deaktivieren. Weitere Informationen finden Sie unter Aktivieren und Deaktivieren der Einbettung von 3D-Objekten in einem PDF-Dokument.

Klicken Sie im PDF-Dokument auf das 3D-Objekt, um die 3D-Symbolleiste anzuzeigen und die interaktiven Funktionen des 3D-Objekts zu aktivieren. Mit der 3D-Symbolleiste von Adobe Acrobat, die über jedem 3D-Objekt in einem PDF-Dokument angezeigt wird, können Sie 3D-Designs vergrößern, verschieben, drehen und analysieren.

Speichern von Dokumenten mit 3D-Objekten im XML-Format

Sie können eine FrameMaker-Datei, die ein 3D-Objekt enthält, als XML-Datei speichern. Wenn Sie die XML-Datei in FrameMaker öffnen, bleibt das 3D-Objekt auch beim Speichern der XML-Datei (Roundtrip) erhalten. Das 3D-Objekt wird extrahiert und zusammen mit der XML-Datei als unabhängige U3D-Datei gespeichert. Wird die Datei erneut in FrameMaker geöffnet, befindet sich das 3D-Objekt an der Stelle, an der es eingefügt wurde.

Wenn Sie die Änderungen, die während eines Roundtrip an einem 3D-Objekt vorgenommen wurden, beibehalten wollen, müssen Sie im Grafikbereich der DTD-Datei das neue Attribut insetdata mit den folgenden Einstellungen sowie weitere Attribute (beispielsweise Offset oder DPI) hinzufügen:

insetdata CDATA #IMPLIED

In der XSD-Datei müssen Sie entsprechend die folgenden Zeilen hinzufügen:

<xsd:attribute name="insetdata" type="xsd:string" use="optional"/>

Hinweis: Das Attribut insetdata unterstützt keine Lese-/Schreibregeln.

Auch wenn Sie die DTD- und XSD-Datei nicht ändern, können Sie U3D-Dateien nach XML exportieren. Beim Roundtrip werden jedoch in FrameMaker an der U3D-Datei vorgenommene Änderungen nicht beibehalten.

    1. Wählen Sie "Datei > Öffnen" und öffnen Sie die FrameMaker-Datei mit den 3D-Objekten.

    2. Wählen Sie "Datei > Als XML speichern".

    3. Sie können den Speicherort und den Dateinamen ändern und anschließend auf "Sichern" klicken.

Hinweis: Wenn Sie die XML-Datei in einem 3D-kompatiblen XML-Editor öffnen, enthält das entsprechende Grafikelement eine Referenz auf die U3D-Datei, und Dateiname und Speicherort entsprechen der U3D-Datei. Wenn Sie die XML-Datei in FrameMaker öffnen, wird das 3D-Objekt als Bitmap-Bild dargestellt.

Drucken von FrameMaker-Dateien mit 3D-Objekten

Dokumente, die 3D-Objekte enthalten, können ausgedruckt werden. Die 3D-Objekte werden als Bitmap-Bilder gedruckt.

    1. Öffnen Sie das Dokument mit den 3D-Objekten.

    2. Wählen Sie "Datei > Drucken".

    3. Legen Sie die weiteren Druckoptionen wie erforderlich fest und klicken Sie anschließend auf "Drucken". Informationen über die weiteren Druckoptionen finden Sie unter Druckoptionen.


Importieren, Verknüpfen und Exportieren / Importieren von 3D-Objekten in FrameMaker-Dokumente (Windows)

Konfigurieren von in FrameMaker importierten 3D-Modellen

Sie können ein in ein Dokument importiertes 3D-Modell konfigurieren, indem Sie dessen Hintergrundfarbe, Beleuchtungsschemata, Anzeige und Darstellungsmodus einstellen.


Importieren, Verknüpfen und Exportieren / Importieren von 3D-Objekten in FrameMaker-Dokumente (Windows) / Konfigurieren von in FrameMaker importierten 3D-Modellen

Einstellen der Hintergrundfarbe von 3D-Objekten

Sie können die Farbe ändern, die hinter einem 3D-Objekt angezeigt wird. Die standardmäßige Hintergrundfarbe ist Weiß.

    1. Wählen Sie ein 3D-Objekt aus.

    2. Wählen Sie "Grafik > 3D-Menü > Hintergrundfarbe".

Das Dialogfenster "Farbe" wird angezeigt.

    3. Wählen Sie die Farbe aus.

    4. Klicken Sie auf "OK".


Importieren, Verknüpfen und Exportieren / Importieren von 3D-Objekten in FrameMaker-Dokumente (Windows) / Konfigurieren von in FrameMaker importierten 3D-Modellen

Einstellen der Beleuchtungsschemata von 3D-Objekten

Sie können aus einer großen Bandbreite von 3D-Beleuchtungsschemata für 3D-Objekte auswählen, die unterschiedliche Lichtquellen verwenden. Das Standard-Beleuchtungsschema für alle 3D-Objekte ist "Licht aus Datei".

    1. Wählen Sie ein 3D-Objekt aus.

    2. Wählen Sie "Grafik > 3D-Menü > Beleuchtung" aus und wählen Sie eine der folgenden Lichtquellen: Licht aus Datei, Kein Licht, Weißes Licht, Tageslicht, Helles Licht, Primärfarben-Licht, Nachtlicht, Blaues Licht, Rotes Licht, Cube-Licht, CAD-optimiertes Licht und Scheinwerfer.


Importieren, Verknüpfen und Exportieren / Importieren von 3D-Objekten in FrameMaker-Dokumente (Windows) / Konfigurieren von in FrameMaker importierten 3D-Modellen

Einstellen der Ansichten für 3D-Objekte in FrameMaker

Das 3D-Objekt, das Sie in ein Dokument importieren, kann vordefinierte Ansichten enthalten. Sie können den Ansichtssatz für das Objekt ändern, und die ausgewählte Ansicht wird beim Speichern des Dokuments gerendert. Wenn Sie dieses FrameMaker-Dokument in eine PDF-Datei konvertieren, stehen alle vordefinierten Ansichten des 3D-Objekts in der PDF-Datei zur Verfügung. Die letzte Ansicht, die Sie vor dem Speichern im Dokument ausgewählt haben, wird zur Standardansicht in der PDF-Datei.

    1. Wählen Sie ein 3D-Objekt aus.

    2. Wählen Sie die Option "Grafik > 3D-Menü > Vorhandene Ansichten anzeigen" aus und wählen Sie in der im Dialogfenster angezeigten Liste eine Ansicht.

    3. Klicken Sie auf "OK".

Das Objekt wird in der ausgewählten Ansicht dargestellt.

Hinweis: Wenn Sie das Dokument als PDF-Datei speichern, werden alle Ansichten der U3D-Objekte im konvertierten Dokument verfügbar.


Importieren, Verknüpfen und Exportieren / Importieren von 3D-Objekten in FrameMaker-Dokumente (Windows) / Konfigurieren von in FrameMaker importierten 3D-Modellen

Darstellen von 3D-Objekten in Dokumenten

Die Bandbreite der Darstellungsmodi für 3D-Objekte reicht von "Drahtrahmen" zu "Durchgezogen" und "Transparenter Begrenzungsrahmen". Der Standardmodus für die Darstellung ist "Durchgezogen".

    1. Wählen Sie ein 3D-Objekt aus.

    2. Wählen Sie "Grafik > 3D-Menü > Rendermodus" aus und wählen Sie einen der folgenden Rendermodi: Begrenzungsrahmen, Transparenter Begrenzungsrahmen, Transparente Begrenzungsrahmen-Kontur, Eckpunkte, Schattierte Eckpunkte, Drahtrahmen, Schattierter Drahtrahmen, Durchgezogen, Transparent, Durchgezogener Drahtrahmen, Transparenter Drahtrahmen, Abbildung, Durchgezogene Kontur, Schattierte Abbildung und Ausgeblendeter Drahtrahmen.

Das Objekt wird im ausgewählten Modus angezeigt.


Hypertext- und Viewer-Dokumente

Online-Systeme

Vorbereiten aktiver Bereiche

Hypertext-Befehle einfügen

Erstellen von Hypertext-Verknüpfungen

Erstellen einer Feld-Matrix

Erstellen von Aufklappmenüs

Erstellen von Meldungsfenstern

Starten anderer Anwendungen

Schließen von Dateien oder Beenden von FrameMaker

Testen und Korrigieren fehlerhafter Hypertext-Dokumente

Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien

Arbeiten in Viewer-Dokumenten und -Büchern

Arbeiten mit dem Format FluidView

Einfügen von Hypertext-Befehlselementen in strukturierte Dokumente


Hypertext- und Viewer-Dokumente

Online-Systeme

Sie können Hypertext-Dokumente online als Teil eines Online-Systems verteilen. Ein Leser kann das Dokument systematisch durchblättern oder es zufällig erkunden, indem er den von Ihnen bereitgestellten Verknüpfungen folgt. Sie können aus den Dokumenten, die Sie drucken (einschließlich eines Inhaltsverzeichnisses und eines Index mit Hypertext-Verknüpfungen), ein einfaches Online-System generieren. Sie können jedoch auch ein komplexeres Online-System mit leistungsfähigen Navigationshilfen wie z. B. Dokumentübersichten und Navigationsfeldern generieren.

Beim Einrichten eines Online-Systems erstellen Sie eine Reihe von Hypertext-Dokumenten. Für jedes Dokument definieren Sie aktive Bereiche. Ein aktiver Bereich enthält einen Hypertext-Befehl, der FrameMaker anweist, wie auf ein Klicken des Lesers an dieser Stelle reagiert werden soll.

Leser können z. B. in eine Liste klicken, um mehr über ein bestimmtes Thema zu erfahren, oder sie können auf einen Teil einer Grafik klicken, um eine detailliertere Zeichnung dieses Teils anzuzeigen. Durch das Klicken auf einen Index können die Leser außerdem Informationen zum jeweiligen Indexbegriff aufrufen. Sie können ein Thema aus einem Aufklappmenü wählen oder auf Felder klicken, um durch das Dokument zu blättern.

Klicken Sie zum Anzeigen weiterer Informationen auf einen aktiven Bereich.


Hypertext- und Viewer-Dokumente / Online-Systeme

Verteilen von Hypertext-Dokumenten

Sie können ein Dokument entweder im PDF- (Portable Document Format) oder im HTML-Format (Hypertext Markup Language) speichern, um es über das World Wide Web oder in einem Intranet zu verteilen.

Sie können dem Leser Hypertext-Dokumente auch im Viewer-Format zur Verfügung stellen. Die Leser können die Dokumente mithilfe von FrameMaker öffnen, lesen, durchsuchen, ausdrucken und auf die eingebetteten Hypertext-Verknüpfungen klicken. Sie können das Dokument jedoch nicht ändern.


Hypertext- und Viewer-Dokumente / Online-Systeme

Planen von Online-Systemen

Das Erstellen von wirkungsvollen und leicht zu bedienenden Online-Dokumenten setzt sorgfältige Planung voraus. Sie müssen eine Seitengröße und ein Layout erstellen, das sowohl auf den Computer, auf dem das Dokument gelesen wird, als auch auf den Lesertyp abgestimmt werden muss. Gut gestaltete Online-Systeme enthalten auf jeder Seite (an der gleichen Position) Grafiken oder Symbole, auf die der Leser klicken kann, um durch das System zu navigieren.

Navigationshilfen sind in einem Online-System sehr wichtig.

Beachten Sie bei der Erstellung von Dokumenten für die Online-Verteilung die folgenden Richtlinien:

    Erstellen Sie mehrere kurze Dokumente anstatt ein langes. Das Öffnen eines langen Dokuments dauert länger.

    Speichern Sie alle Dokumente eines Systems im selben Ordner. Auf diese Weise müssen Sie keine Pfadnamen für importierte Grafiken und für Hypertext-Befehle verwalten, die die Angabe von Dateinamen erfordern.

    Wenn Sie die Dokumente als FrameMaker-Dateien verteilen, verwenden Sie gängige Schriftarten. Schriftarten wie "Times" und "Helvetia" stehen z. B. auf den meisten Rechnern sowie auf allen PostScript-Druckern zur Verfügung


Hypertext- und Viewer-Dokumente

Vorbereiten aktiver Bereiche

Ein Leser navigiert in einem Hypertext-System, indem er auf aktive Bereiche klickt, d. h. auf Bereiche mit Hypertext-Befehlen, oder indem er einen Bildlauf nach oben bzw. unten durchführt. Aktive Bereiche können aus Text, aus einer Grafik oder aus Teilen einer Grafik bestehen. Sie können aktive Bereiche auf Arbeitsseiten einrichten oder sie auf Vorgabeseiten definieren, damit sie auf allen Arbeitsseiten an derselben Position angezeigt werden. Sie könnten z. B. Navigationsfelder auf Vorgabeseiten einrichten. Sobald ein Leser auf einen aktiven Bereich klickt, wird der entsprechende Hypertext-Befehl ausgeführt.

Vor dem Einfügen eines Hypertext-Befehls bereiten Sie den Bereich vor. So können Sie z. B. Textbereiche erstellen, die sich optisch vom umgebenden Text unterscheiden.

Unterstrichener Text auf der Arbeitsseite kann aktiv sein.

Grafiken auf Vorgabeseiten können aktiv sein.


Hypertext- und Viewer-Dokumente / Vorbereiten aktiver Bereiche

Vorbereiten von Textbereichen

Ein Textbereich kann aus einem Wort, einer Wortverbindung oder einem ganzen Absatz bestehen. Wenn Ihr Leser in einen Textbereich mit einen Hypertext-Befehl klickt, findet FrameMaker diesen Befehl, markiert den Bereich und führt den Befehl aus.

So bereiten Sie einen Textbereich vor:

Führen Sie eine der folgenden Aktionen aus:

    Um ein Wort oder eine Wortverbindung als aktiven Bereich festzulegen, wählen Sie den Text aus und ändern sein Zeichenformat. Durch Ändern des Zeichenformats werden die Grenzen des Textbereichs festgelegt. Die meisten Formatierungsunterschiede werden erkannt. Nur Unterschneiden, Zeichenabstand, Streckung, Änderungsbalken, Sprache und Groß-/ Kleinschreibung werden ignoriert.

Um ein Wort oder eine Wortverbindung als aktiven Bereich zu definieren, ohne sein bzw. ihr Aussehen zu ändern, verwenden Sie ein Zeichenformat, in dem für alle Einstellungen "Beibehalten" festgelegt ist (siehe Verwenden von "Beibehalten" und Zuweisen von vordefinierten Formaten zu Text).

    Um einen ganzen Absatz als aktiven Bereich zu definieren, müssen Sie sicherstellen, dass er keine Zeichenformatänderungen enthält. Wenn der Absatz nur einen einzigen Hypertext-Befehl und keinerlei Zeichenformatänderungen enthält, hebt FrameMaker den gesamten Absatz hervor und führt den Befehl aus, sobald der Benutzer an einer beliebigen Stelle im Absatz klickt.

    Um mehrere aufeinander folgende Wörter und Wortverbindungen in einer Textzeichenfolge als aktiven Bereich zu definieren, verwenden Sie das gleiche Zeichenformat für die gesamte Textzeichenfolge. Fügen Sie anschließend die verschiedenen Hypertext-Befehle ein. FrameMaker zerlegt den Text dann anhand der Position der Marken in aktive Bereiche. Sobald ein Leser in den Text klickt, bestimmt FrameMaker, auf welchen Bereich geklickt wurde, und führt den korrekten Hypertext-Befehl aus.

Marken teilen den Text in aktive Bereiche.


Hypertext- und Viewer-Dokumente / Vorbereiten aktiver Bereiche

Vorbereiten von Grafiken

Grafiken bieten oft optische Anhaltspunkte für Hypertext-Aktionen. Leser können z. B. auf ein Symbol klicken, um Informationen zu einem Thema aufzurufen, oder auf einen Pfeil, um die nächste Seite anzuzeigen.

Ein aktiver Bereich über einer Grafik kann einen Hypertext-Befehl enthalten, der entweder zu einem anderen Ort springt, oder einen, der die Grafik in eine Matrix aus Hypertext-Befehlen unterteilt.

Hinweis: Wenn Sie Dokumente für die Verteilung im HTML-Format vorbereiten, können Sie mit aktiven Bereichen über verankerten Grafiken Imagemaps erzeugen. Unverankerte Grafiken auf Vorgabe- und Arbeitsseiten werden nicht in das HTML-Format konvertiert.

So bereiten Sie eine Grafik vor:

    1. Zeichnen Sie einen Textrahmen, der die gesamte Grafik einschließt, die Sie als aktiven Bereich festlegen wollen. Fügen Sie später einen Hypertext-Befehl in diesen Textrahmen ein. (Wenn der Leser auf einen aktiven Textrahmen klickt, markiert FrameMaker den gesamten Rahmen.) Informationen zum Zeichnen von Rahmen mithilfe des Textrahmen-Werkzeugs finden Sie unter Grafiken und Text.

Vergewissern Sie sich, dass die Grafik nicht so eingestellt ist, dass der Text um sie fließt (siehe Text um Grafiken fließen lassen).

    2. Wählen Sie für Füll- und Linienmuster des Textrahmens die Option "Keine" (siehe Zuweisen und Ändern von Zeichnungseinstellungen). Dadurch wird der Textrahmen transparent, und die Grafik hinter dem Rahmen wird für den Leser sichtbar.

    3. Wenn sich die Grafik noch nicht im Vordergrund befindet, wählen Sie "Grafiken" > "Nach vorne", um den Textrahmen vor der Grafik zu platzieren. (Der Textrahmen erscheint bereits vor der Grafik, es sei denn, die Grafik wurde nach dem Zeichnen des Textrahmens auf der Seite platziert.)


Hypertext- und Viewer-Dokumente / Vorbereiten aktiver Bereiche

Vorbereiten eines identischen Bereichs auf mehreren Seiten

Sie können einen aktiven Bereich festlegen, der sich auf mehreren Seiten an der gleichen Position befindet. Dies geschieht, indem Sie den Bereich auf einer Vorgabeseite einrichten und den Hypertext-Befehl dort einfügen. Sie können z. B. Schaltflächen auf Vorgabeseiten erstellen, auf die die Leser auf Arbeitsseiten klicken können, um die nächste bzw. vorherige Seite anzuzeigen.

Navigationsschaltflächen auf Vorgabeseiten erscheinen auf Arbeitsseiten.

Sie können aktive Grafiken auf Vorgabeseiten auf einzelnen Arbeitsseiten außer Kraft setzen, wenn Sie die Leser auf andere Stellen verweisen wollen. Sie können z. B. das Feld "Nächste Seite" auf der letzten Arbeitsseite jedes Dokuments außer Kraft setzen, da es dort ja keine nächste Seite gibt.

So zeigen Sie einen aktiven Bereich auf mehreren Seiten an:

Richten Sie den Bereich nicht auf einer Arbeitsseite, sondern auf einer Vorgabeseite ein (siehe Vorbereiten von Textbereichen und Vorbereiten von Grafiken). Der aktive Bereich erscheint im Hintergrund der entsprechenden Arbeitsseiten. Sobald der Leser auf diese Stelle auf einer Arbeitsseite klickt, wird der Hypertext-Befehl auf der Vorgabeseite aktiviert.

Wenn Sie den Textrahmen auf einer Vorgabeseite zeichnen, fragt FrameMaker, ob ein Vorgaberahmen oder ein Hintergrundrahmen erstellt werden soll. Textrahmen für aktive Bereiche sollten Hintergrundtextrahmen (ohne Typ) sein.

So setzen Sie den Befehl einer Vorgabeseite auf einer Arbeitsseite außer Kraft:

Führen Sie eine der folgenden Aktionen aus:

    Platzieren Sie eine Grafik oder einen anderen Hypertext-Befehl über den Bereich auf der Arbeitsseite. Sie könnten z. B. das Feld "Nächste Seite" auf der letzten Seite jedes Dokuments durch ein inaktives, grau dargestelltes Feld überlagern.

Befehle auf Vorgabeseiten können von Grafiken auf Arbeitsseiten außer Kraft gesetzt werden.

    Setzen Sie einen Textrahmen mit eigenem Hypertext-Befehl über die Grafik auf der Arbeitsseite.


Hypertext- und Viewer-Dokumente

Hypertext-Befehle einfügen

Zum Einfügen eines Hypertext-Befehls in einen vorbereiteten Bereich kann eine Marke verwendet werden. Nach Einfügen eines Befehls und Speichern des Dokuments im Viewer-Format ist der Bereich aktiv. Sobald ein Leser auf einen aktiven Bereich klickt, hebt FrameMaker den Bereich hervor und führt den Befehl aus.

Hypertext-Befehle ermöglichen dem Leser das Blättern durch Viewer-Dokumente. Wenn Sie die Dokumente im Viewer-Format verteilen, können Sie mithilfe von Hypertext-Befehlen auch Meldungsfenster anzeigen, Dokumente schließen, FrameMaker beenden und andere Anwendungen starten.

Hypertext-Befehlsmarke

Nach dem Einfügen eines Hypertext-Befehls können Sie diesen testen, ohne das Dokument im Viewer-Format zu speichern (siehe Arbeiten in Viewer-Dokumenten und -Büchern).

Hinweis: Wenn Sie einen Hypertext-Befehl in einem Texteinschub platzieren wollen, müssen Sie ihn im Quelldokument des Texteinschubs einfügen.

So fügen Sie einen Hypertext-Befehl ein:

    1. Klicken Sie zum Einfügen eines Hypertext-Befehls an die entsprechende Stelle im vorbereiteten Bereich. (Einzelheiten hierzu finden unter Vorbereiten aktiver Bereiche.) Hypertext-Befehle können in Textrahmen, jedoch nicht in Textzeilen eingefügt werden. Textzeilen sind grafische Objekte, die mit dem Textzeilen-Werkzeug erstellt werden. Um beim Exportieren zusätzliche Leerzeichen im Hypertext-Befehl zu vermeiden, fügen Sie die Marken am Wortende bzw. Wortanfang ein.

    2. Wählen Sie "Spezial > Hypertext".

    3. Wählen Sie einen Hypertext-Befehl aus dem Aufklappmenü "Befehl". Die Syntax für den Befehl wird unter dem Aufklappmenü angezeigt, und der Name des Befehls wird im Textfeld angezeigt. (Eine Beschreibung der Elemente im Aufklappmenü "Befehl" finden Sie unter Hypertext-Befehle.)

    4. Geben Sie die benötigten Parameter in das Textfeld ein (z. B. einen Dateinamen und einen Namen für die Verknüpfung). Einzelheiten finden Sie unter Erstellen von Hypertext-Verknüpfungen und in den daran anschließenden Abschnitten.

Hypertext-Befehle müssen immer in Kleinbuchstaben eingegeben werden. Die Parameter können groß oder klein geschrieben werden, aber es wird zwischen Groß- und Kleinschreibung unterschieden. Der vollständige Befehl kann bis zu 255 Zeichen enthalten. (Jedes Zeichen einer japanischen Schriftart wird doppelt gezählt.)

Hinweis: Wenn Sie im Parameter für den Dateinamen eine Datei angeben, die sich nicht in demselben Ordner wie das aktuelle Dokument befindet, müssen Sie zusätzlich den entsprechenden Pfad angeben (siehe Pfadnamen in Hypertext-Befehlen).

    5. Wenn FrameMaker den Befehl nach der Eingabe überprüfen soll, wählen Sie die Option "Befehl beim Einfügen prüfen".

    6. Klicken Sie auf "Neue Hypertext-Marke". FrameMaker prüft nun die Syntax im Textfeld. Wenn die Option "Befehl beim Einfügen prüfen" aktiviert ist, prüft FrameMaker auch den Befehl. Beispielsweise prüft FrameMaker beim Befehl "Zu benanntem Ziel springen", ob die Zielverknüpfung im angegebenen Dokument existiert.

Falls FrameMaker einen Fehler findet, erscheint ein Meldungsfenster. Der Befehl wird aber trotzdem in eine Marke des Typs Hypertext eingefügt. Wenn die Anzeige von Steuerzeichen aktiviert ist, wird an der Einfügemarke ein Markensymbol ( [image] ) eingeblendet.

Hinweis: Hypertext-Marken unterstützen den Unicode-Standard zur Textcodierung.

So bearbeiten Sie Hypertext-Befehle:

    1. Wenn das Dokument im Viewer-Format vorliegt, müssen Sie ihm das Format "Dokument" zuweisen. Führen Sie dazu eine der folgenden Aktionen aus:

    Wenn das Dialogfenster "Hypertext" geöffnet ist, klicken Sie auf "Schreibschutz aufheben".

    Drücken Sie Esc d Umschalttaste+y.

    2. Wenn das Dialogfenster "Hypertext" nicht geöffnet ist, wählen Sie "Spezial > Hypertext".

    3. Wählen Sie die Marke, die den zu bearbeitenden Befehl enthält. Doppelklicken Sie zur Auswahl einer Marke in einem ansonsten weißen Textrahmen auf eine beliebige Stelle innerhalb des Rahmens. Sie können auch mit dem Befehl "Suchen" nach Hypertext-Marken suchen und diese auswählen. Der Hypertext-Befehl wird im Dialogfenster "Hypertext" angezeigt.

Wenn neben der zu bearbeitenden Marke keine weiteren Marken vorhanden sind, ziehen Sie über die Marke. Der enthaltene Hypertext-Befehl wird dann im Dialogfenster "Hypertext" eingeblendet.

    4. Bearbeiten Sie den Befehl im Textfeld und klicken Sie anschließend auf "Hypertext-Marke bearbeiten". Selbst wenn Text neben der Marke ausgewählt wird, wird nur der Befehl in der Marke bearbeitet.

    5. Führen Sie einen der folgenden Schritte aus, um das Dokument wieder in ein Viewer-Format zu verwandeln:

    Klicken Sie im Dialogfenster "Hypertext" auf "Schreibgeschützt".

    Drücken Sie Esc d Umschalttaste+y.

So löschen Sie Hypertext-Befehle:

Wählen Sie die Marke, die den Befehl enthält, und drücken Sie die Entf-Taste. Doppelklicken Sie zur Auswahl einer Marke in einem ansonsten weißen Textrahmen auf eine beliebige Stelle innerhalb des Rahmens. Sie können auch mit dem Befehl "Suchen" nach Hypertext-Marken suchen und diese auswählen.


Hypertext- und Viewer-Dokumente / Hypertext-Befehle einfügen

Hypertext-Befehle

FrameMaker unterstützt die folgenden Hypertext-Befehle. Eine detaillierte Beschreibung zu jedem Befehl und dessen Syntax finden Sie in den Abschnitten, auf die jeweils verwiesen wird.

Warnung

Zeigt ein Meldungsfenster an (siehe Erstellen von Meldungsfenstern).

Meldungsfenster mit Titel

Zeigt ein Meldungsfenster mit einem vom Benutzer definierten Titel an (siehe Erstellen von Meldungsfenstern).

Benanntes Ziel angeben

Markiert die Stelle, die angezeigt wird, wenn ein "Zu benanntem Ziel springen"- oder ein "Dokument öffnen"-Befehl ausgeführt wird (siehe Erstellen von Verknüpfungen zu bestimmten Themen).

Zu benanntem Ziel springen

Zeigt die Stelle im aktuellen oder in einem anderen Dokument an, die die entsprechende Zielverknüpfung enthält (siehe Erstellen von Verknüpfungen zu bestimmten Themen). Die Seite wird im aktiven Fenster angezeigt.

Zu benanntem Ziel springen & an Seite anpassen

Zeigt die Stelle im aktuellen oder in einem anderen Dokument an, die die entsprechende Zielverknüpfung enthält. Anschließend wird die Größe des Fensters so angepasst, dass die angezeigte Dokumentseite darin Platz hat (siehe Erstellen von Verknüpfungen zu bestimmten Themen).

Zur ersten Seite springen

Zeigt die erste Seite des aktuellen oder eines anderen Dokuments an (siehe Erstellen von Verknüpfungen zu Seiten). Die Seite wird im aktiven Fenster angezeigt.

Zur letzten Seite springen

Zeigt die letzte Seite des aktuellen oder eines anderen Dokuments an (siehe Erstellen von Verknüpfungen zu Seiten). Die Seite wird im aktiven Fenster angezeigt.

Wechseln zu URL

Startet den Browser und zeigt die Web-Seite an (siehe Erstellen von Verknüpfungen zu Web-Seiten).

Zu bestimmter Seite springen

Zeigt eine bestimmte Seite des aktuellen oder eines anderen Dokuments an (siehe Erstellen von Verknüpfungen zu Seiten). Die Seite wird im aktiven Fenster angezeigt.

Zur vorigen Seite springen

Zeigt die vorherige Seite des aktuellen Dokuments an (siehe Erstellen von Verknüpfungen zu Seiten). Die Seite wird im aktiven Fenster angezeigt.

Zur nächsten Seite springen

Zeigt die nächste Seite des aktuellen Dokuments an (siehe Erstellen von Verknüpfungen zu Seiten). Die Seite wird im aktiven Fenster angezeigt.

Zurückspringen

Wechselt zu der Stelle, die der Leser zuletzt angezeigt hatte (siehe Zurückverfolgen der Schritte). Die Seite wird im aktiven Fenster angezeigt.

Zurückspringen & an Seite anpassen

Wechselt zu der Stelle, die der Leser zuletzt angezeigt hatte, und passt die Größe des Fensters an die angezeigte Dokumentseite an (siehe Zurückverfolgen der Schritte).

Dokument öffnen

Wechselt zu der Seite, die den entsprechenden Befehl "Benanntes Ziel angeben" enthält (siehe Erstellen von Verknüpfungen zu bestimmten Themen). Unter Windows wird die Seite nur dann in einem neuen Fenster angezeigt, wenn sie aus einem anderen Dokument stammt (das aktuelle Fenster bleibt geöffnet). Unter UNIX erscheint die Seite immer in einem anderen Fenster.

Dokument öffnen & an Seite anpassen

Wechselt zu der Seite, die den entsprechenden Befehl "Benanntes Ziel angeben" enthält, und passt die Größe des neuen Fensters der angezeigten Dokumentseite an (siehe Erstellen von Verknüpfungen zu bestimmten Themen). Unter Windows wird die Seite nur dann in einem neuen Fenster angezeigt, wenn sie aus einem anderen Dokument stammt (das aktuelle Fenster bleibt geöffnet). Unter UNIX erscheint die Seite immer in einem anderen Fenster.

Neues Dokument öffnen

Öffnet ein Dokument als neues Dokument ohne Titel (siehe Erstellen von Verknüpfungen zu neuen Dokumenten). Das Dokument wird in einem neuen Fenster angezeigt, und das aktuelle Fenster bleibt geöffnet.

Dokument auf der ersten/letzten Seite öffnen

Zeigt die erste oder letzte Seite an (siehe Erstellen von Verknüpfungen zu Seiten). Unter Windows wird die Seite nur dann in einem neuen Fenster angezeigt, wenn sie aus einem anderen Dokument stammt (das aktuelle Fenster bleibt geöffnet). Unter UNIX erscheint die Seite immer in einem anderen Fenster.

Dokument auf bestimmter Seite öffnen

Zeigt eine bestimmte Seite an (siehe Erstellen von Verknüpfungen zu Seiten). Unter Windows wird die Seite nur dann in einem neuen Fenster angezeigt, wenn sie aus einem anderen Dokument stammt (das aktuelle Fenster bleibt geöffnet). Unter UNIX erscheint die Seite immer in einem anderen Fenster.

Aufklappmenü

Zeigt ein Aufklappmenü mit Optionen an, von denen jede einen Hypertext-Befehl enthält (siehe Erstellen von Aufklappmenüs).

Feld-Matrix

Ermöglicht dem Benutzer eine Auswahl aus einer Matrix von Elementen, die Hypertext-Befehle ausführen (siehe Erstellen einer Feld-Matrix).

Meldungs-Client

Kommuniziert mit anderen Anwendungen (siehe Starten anderer Anwendungen) und erstellt eine Verknüpfung zu einer URL (Universal Resource Locator) im World Wide Web oder in einem Intranet. Diese Verknüpfung kann in Dokumenten verwendet werden, die später in das HTML-Format konvertiert werden (siehe Einrichten von Verknüpfungen zu URLs).

Aktuelles Fenster schließen

Entfernt das aktuelle Fenster vom Bildschirm (siehe Schließen von Dateien oder Beenden von FrameMaker).

Alle Hypertext-Fenster schließen

Entfernt alle Viewer-Fenster vom Bildschirm (siehe Schließen von Dateien oder Beenden von FrameMaker).

Anwendung beenden

Beendet FrameMaker (siehe Schließen von Dateien oder Beenden von FrameMaker).


Hypertext- und Viewer-Dokumente / Hypertext-Befehle einfügen

Pfadnamen in Hypertext-Befehlen

Viele Hypertext-Befehle können einen Pfadnamen enthalten. In einem Pfadnamen werden Ordnerebenen mit einem Schrägstrich (/) voneinander getrennt (auch unter Windows). Unter UNIX kann der Pfadname Umgebungsvariablen wie z. B. $HOME zur Angabe des Home-Verzeichnisses des Lesers enthalten.

Wenn Ihre Hypertext-Dokumente für unterschiedliche Systeme bestimmt sind, sollten Sie Dateinamen verwenden, die auf allen Systemen gültig sind. Weitere Informationen über die Anforderungen der verschiedenen Systeme an Dateinamen finden Sie im Online-Handbuch Arbeiten auf unterschiedlichen Plattformen.

Hinweis: Hypertext-Befehle mit Dateinamen, die nur aus einem Zeichen bestehen, funktionieren möglicherweise nicht.

Relative Pfadnamen

FrameMaker beginnt die Suche nach einem relativen Pfadnamen in dem Ordner, der das aktuelle Dokument enthält. Um die nächsthöhere Ordnerebene anzugeben, verwenden Sie zwei Punkte (..). Angenommen, ein Hypertext-Befehl bezieht sich auf ein Dokument mit dem Namen "Posaune", das in einem Ordner namens "Blechinstrumente" enthalten ist. Wenn sich der Ordner "Blechinstrumente" im gleichen Ordner befindet wie das aktuelle Dokument, geben Sie den Pfadnamen "Blechinstrumente/Posaune" an.

Befindet sich der Ordner "Blechinstrumente" auf der gleichen Ebene wie der Ordner, der das aktuelle Dokument enthält, verwenden Sie "../Blechinstrumente/Posaune".

Absolute Pfadnamen

FrameMaker sucht nach einem absoluten Pfadnamen und beginnt die Suche am Anfang des Dateisystems. Unter Windows beginnt der absolute Pfadname mit der Laufwerksbezeichnung, einem Doppelpunkt und einem Schrägstrich. Unter UNIX beginnt der absolute Pfadname mit einem Schrägstrich.

Nehmen Sie an, ein Hypertext-Befehl bezieht sich auf ein Dokument mit dem Namen "Posaune", das im Ordner "Blechinstrumente" enthalten ist. Befindet sich unter Windows der Ordner "Blechinstrumente" auf der obersten Ebene von Laufwerk E, lautet der Pfadname "E:/Blechinstrumente/Posaune". Gehört in einem UNIX-System der Ordner "Blechinstrumente" zur obersten Ebene des Dateisystems, lautet der Pfadname "/Blechinstrumente/Posaune".

Da absolute Pfadnamen zwischen Plattformen nicht erkannt werden, sollten Sie immer relative Pfadnamen verwenden, falls Ihre Hypertext-Dokumente auf verschiedenen Plattformen betrachtet werden sollen.


Hypertext- und Viewer-Dokumente / Hypertext-Befehle einfügen

Hypertext-Befehle in HTML- und PDF-Dokumenten

Wenn Sie ein Dokument in das HTML- oder PDF-Format umwandeln, funktionieren einige Hypertext-Befehle – jedoch nicht alle – im konvertierten Dokument genauso wie im Viewer-Dokument. Die Unterschiede sind in der folgenden Tabelle aufgeführt.

Befehl | PDF | HTML
Meldungsfenster, Meldungsfenster mit Titel | Erscheint als Anmerkung ohne Titel | Funktioniert nicht.
Zu benanntem Ziel springen | Funktioniert wie in diesem Kapitel beschrieben. | Funktioniert wie in diesem Kapitel beschrieben.
Zu benanntem Ziel springen & an Seite anpassen | Funktioniert wie in diesem Kapitel beschrieben (aber ohne Seitenanpassung). | Funktioniert wie in diesem Kapitel beschrieben (aber ohne Seitenanpassung).
Zur ersten Seite springen, Zur letzten Seite springen, Zu bestimmter Seite springen, Zur vorigen Seite springen, Zur nächsten Seite springen | Funktioniert wie in diesem Kapitel beschrieben. | Funktioniert nicht.
Zurückspringen, Zurückspringen & an Seite anpassen | Funktioniert nicht. | Funktioniert nicht.
Dokument öffnen | Funktioniert wie in diesem Kapitel beschrieben. | Funktioniert wie in diesem Kapitel beschrieben.
Dokument öffnen & an Seite anpassen, Neues Dokument öffnen, Dokument auf der ersten Seite öffnen, Dokument auf der letzen Seite öffnen, Dokument auf bestimmter Seite öffnen | Funktioniert wie in diesem Kapitel beschrieben, aber ohne Seitenanpassung oder Öffnen eines separaten Fensters. | Funktioniert wie in diesem Kapitel beschrieben, aber ohne Seitenanpassung oder Öffnen eines separaten Fensters.
Aufklappmenü | Funktioniert nicht. | Funktioniert nicht.
Feld-Matrix | Funktioniert nicht. | Funktioniert wie in diesem Kapitel beschrieben, vorausgesetzt der Textrahmen mit dem Befehl befindet sich in einem verankerten Rahmen im Haupttextfluss.
Message URL | Funktioniert, wenn die PDF-Datei im Browser geöffnet wird; in Acrobat funktioniert die Verknüpfung unter Umständen nicht. | Funktioniert wie in diesem Kapitel beschrieben.
Meldungs-Client | Funktioniert nicht. | Funktioniert nicht.
Aktuelles Fenster schließen, Alle Hypertext-Fenster schließen, Anwendung beenden | Funktioniert nicht. | Funktioniert nicht.


Hypertext- und Viewer-Dokumente

Erstellen von Hypertext-Verknüpfungen

Verknüpfungen zu Informationen können sowohl an verschiedenen Stellen desselben Dokuments als auch in unterschiedlichen Dokumenten erstellt werden. Es ist z. B. möglich, Verknüpfungen zu erstellen, die zu bestimmten Themen oder Seiten springen. Die Querverweise in FrameMaker können ebenfalls als Verknüpfungen verwendet werden. Sie können den Lesern auch ermöglichen, ihre Sprungverknüpfungen zu verfolgen.

Falls Ihre Dokumente im PDF- oder HTML-Format abgelegt werden, stehen einige in diesem Abschnitt beschriebene Befehle nicht zur Verfügung. Weitere Informationen finden Sie unter Hypertext-Befehle in HTML- und PDF-Dokumenten.


Hypertext- und Viewer-Dokumente / Erstellen von Hypertext-Verknüpfungen

Erstellen von Verknüpfungen zu bestimmten Themen

Sie können eine Verknüpfung von einer Stelle eines Hypertext-Dokuments zu einem Thema an einer anderen Stelle herstellen. Sie verwenden einen Befehl, um das Thema festzulegen, das angezeigt werden soll, und einen anderen, um die Stelle auf der verknüpften Seite zu markieren.

A: Festlegen des anzuzeigenden Themas B: Markieren des Themas

FrameMaker kann die verknüpften Informationen im selben Fenster oder in einem neuen Fenster anzeigen (wobei das aktuelle Fenster geöffnet bleibt).

So geben Sie verknüpfte Themen an:

Fügen Sie den Befehl "Benanntes Ziel angeben" ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

newlink Verknüpfungsname

In diesem Beispiel ist Verknüpfungsname ein Wort oder eine Wortverbindung zur Bezeichnung des Ziels. Ein Verknüpfungsname mit einem nachgestellten Leerzeichen unterscheidet sich von einem ohne Leerzeichen. Verknüpfungsnamen berücksichtigen außerdem die Schreibweise (groß/klein), d. h. einheiten ändern ist nicht identisch mit Einheiten ändern.

A: Befehl "Zu benanntem Ziel springen": gotolink posaune B: Befehl "Benanntes Ziel angeben": newlink posaune

Hinweis: Wenn Sie den Befehl "Benanntes Ziel angeben" weglassen, wird beim Klicken auf die Befehle "Zu benanntem Ziel springen" und "Dokument öffnen" keine Aktion ausgeführt. Wenn die Befehle jedoch auf einen Dateinamen Bezug nehmen, wird die betreffende Datei geöffnet und die erste Seite angezeigt.

So erstellen Sie eine Verknüpfung zu einem bestimmten Thema:

Fügen Sie die folgenden Hypertext-Befehle ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen):

    Wenn die verbundene Information in demselben Fenster angezeigt werden soll, fügen Sie einen "Zu benanntem Ziel springen"-Befehl ein. Die Syntax für diesen Befehl lautet:

gotolink Dateiname:Verknüpfungsname

    Um die verknüpften Informationen in einem anderen Fenster anzuzeigen, fügen Sie einen "Dokument öffnen"-Befehl ein. (Unter Windows werden die Informationen nur dann in einem neuen Fenster eingeblendet, wenn sie aus einem anderen Dokument stammen.) Die Syntax für diesen Befehl lautet:

openlink Dateiname:Verknüpfungsname

Dateiname gibt hier den Namen des Dokuments an, das Sie anzeigen wollen. Verknüpfungsname ist der beschreibende Begriff (Wort oder Wortverbindung), den Sie im entsprechenden Befehl "Benanntes Ziel angeben" verwendet haben.

Wenn sich die verknüpften Informationen in einem Dokument befinden, dessen Seitenformat nicht mit dem des aktuellen Dokuments übereinstimmt, können Sie das Dokument in einem Fenster anzeigen, dessen Größe an die Seite angepasst wird. Verwenden Sie dazu den Befehl "Benanntes Ziel & an Seite anpassen" bzw. "Dokument öffnen & an Seite anpassen".


Hypertext- und Viewer-Dokumente / Erstellen von Hypertext-Verknüpfungen

Erstellen von Verknüpfungen zu Seiten

Sie können sowohl im selben als auch in einem anderen Dokument eine Verknüpfung zu der ersten, letzten, vorigen oder nächsten Seite erstellen. Die Erstellung einer Verknüpfung zu einer bestimmten Seite ist ebenfalls möglich.

Durch die Definition einer Verknüpfung zur nächsten und zur vorherigen Seite können Sie Ihren Lesern Navigationshilfen zur Verfügung stellen. Die betreffenden Verknüpfungen müssen auf den Vorgabeseiten des Dokuments eingerichtet werden.

So erstellen Sie Verknüpfungen zu einer Seite:

Fügen Sie die folgenden Hypertext-Befehle ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen):

    Um die verknüpfte Seite in demselben Fenster anzuzeigen, fügen Sie den Befehl "Zu bestimmter Seite springen", "Zur ersten Seite springen" oder "Zur letzten Seite springen" ein. Die Syntax für die Befehle lautet:

gotopage Dateiname:Seitennummer
gotopage Dateiname:firstpage
gotopage Dateiname:lastpage

    Soll die verknüpfte Seite in einem anderen Fenster angezeigt werden, fügen Sie den Befehl "Dokument auf bestimmter Seite öffnen", "Dokument auf der ersten Seite öffnen" oder "Dokument auf der letzten Seite öffnen" ein. (Unter Windows wird die Seite nur dann in einem neuen Fenster angezeigt, wenn sie aus einem anderen Dokument stammt.) Die Syntax für diese Befehle lautet:

openpage Dateiname:Seitennummer
openpage Dateiname:firstpage
openpage Dateiname:lastpage

Hinweis: Wenn Sie einen Hypertext-Befehl zur Anzeige einer bestimmten Seitennummer einfügen, müssen Sie die tatsächliche Seitennummer im Dokument angeben. Wenn z. B. ein Zieldokument namens "MeinDok" römische Ziffern für die Seitennummern verwendet und auf Seite v beginnt, lautet der Befehl zur Anzeige der dritten Seite folgendermaßen: openpage MeinDok:vii.

    Um die vorherige oder die nächste Seite des aktuellen Dokuments anzuzeigen, fügen Sie den Befehl "Zur vorigen Seite springen" bzw. "Zur nächsten Seite springen" ein. (Wenn die erste Seite des Dokuments angezeigt wird, bleibt der Befehl "Zur vorigen Seite springen" wirkungslos. Wird die letzte Dokumentseite angezeigt, bleibt "Zur nächsten Seite springen" wirkungslos.) Die Syntax für diese Befehle lautet:

previouspage
nextpage

In diesen Beispielen ist Dateiname der Name des Dokuments, das Sie anzeigen wollen, und Seitennummer legt fest, welche Seite angezeigt werden soll. Lassen Sie Dateinamen und Doppelpunkt aus, wenn sich die anzuzeigende Seite im aktuellen Dokument befindet. Die folgende Tabelle enthält Beispiele zu den Befehlen.

Befehl | Ergebnis
gotopage 8 | Zeigt Seite 8 des aktuellen Dokuments im selben Fenster an.
openpage Posaune:8 | Zeigt Seite 8 des Dokuments "Posaune" aus dem aktuellen Ordner in einem eigenen Fenster an.


Hypertext- und Viewer-Dokumente / Erstellen von Hypertext-Verknüpfungen

Erstellen von Verknüpfungen zu neuen Dokumenten

Sie können eine Verknüpfung zu einem anderen Dokument erstellen und FrameMaker das Dokument in einem anderen Fenster als ein neues, unbenanntes Dokument öffnen lassen. So können Sie z. B. ein Online-System für die bei Ihnen verwendeten Dokumentschablonen erstellen.

So erstellen Sie Verknüpfungen zu einem neuen Dokument:

Fügen Sie den Befehl "Neues Dokument öffnen" ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

opennew Dateiname

In diesem Beispiel ist Dateiname der Name des Dokuments, das als Schablone dienen soll.


Hypertext- und Viewer-Dokumente / Erstellen von Hypertext-Verknüpfungen

Erstellen von Verknüpfungen zu Web-Seiten

Sie können eine Verknüpfung zu einer Web-Seite im Internet oder im Intranet eines Unternehmens erstellen.

So erstellen Sie Verknüpfungen zu einer Web-Seite:

Fügen Sie den Befehl "Wechseln zu URL" ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

message URL Adresse

In diesem Beispiel gibt Adresse die URL an, zu der Sie wechseln wollen, z. B. http://www.adobe.com.


Hypertext- und Viewer-Dokumente / Erstellen von Hypertext-Verknüpfungen

Erstellen von Verknüpfungen mithilfe von Querverweisen

Sie können die Querverweise von FrameMaker als Hypertext-Verknüpfungen verwenden. Sobald ein Leser auf einen Querverweis in einem Viewer-Dokument klickt, springt FrameMaker zu den entsprechenden Quellinformationen. Befindet sich ein Querverweis im selben Textbereich wie ein Hypertext-Befehl, hat der Querverweis Vorrang vor dem Hypertext-Befehl.

Sie können das MIF-Format verwenden, um festzulegen, dass Querverweise in Ihrem Hypertext-Dokument nicht aktiv sein sollen. Sie können auch festlegen, dass FrameMaker immer ein neues Fenster öffnet, sobald auf einen aktiven Querverweis geklickt wird. Weitere Informationen zur Anpassung von Hypertext-Dokumenten mithilfe von MIF finden Sie im Online-Handbuch MIF Reference.


Hypertext- und Viewer-Dokumente / Erstellen von Hypertext-Verknüpfungen

Hervorheben von Marken in Viewer-Dokumenten

Wenn Sie in einem Viewer-Dokument auf einen aktiven Bereich klicken, wählt FrameMaker normalerweise die Querverweis- oder Hypertext-Marke der verknüpften Informationen nicht aus. (Im FrameMaker-Format "Dokument" wird die Marke dagegen ausgewählt.) Im MIF-Format können Sie festlegen, dass die Marken ausgewählt werden sollen. Weitere Informationen zur Anpassung von Hypertext-Dokumenten mithilfe von MIF finden Sie im Online-Handbuch MIF Reference.


Hypertext- und Viewer-Dokumente / Erstellen von Hypertext-Verknüpfungen

Zurückverfolgen der Schritte

Mithilfe entsprechender Hypertext-Befehle können Sie den Lesern die Möglichkeit geben, ihre Aktionen in einem Dokumentfenster zurückzuverfolgen. (FrameMaker verwaltet einen Stapel mit den letzten 255 Verknüpfungen in jedem Fenster.) Durch die Verwendung dieser Befehle auf Vorgabeseiten lässt sich z. B. eine Navigationshilfe erstellen, die dem Leser ein bequemes Zurückverfolgen der bisher durchgeführten Schritte ermöglicht (z. B. über eine Schaltfläche "Zurück").

So lassen sich Schritte zurückverfolgen:

Fügen Sie den Befehl "Zurückspringen" ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

previouslink Dateiname:Verknüpfungsname

In diesem Beispiel definieren Dateiname und Verknüpfungsname die Position, zu der FrameMaker springen soll, wenn der Stapel leer ist. Wenn der Stapel leer ist und kein Datei- und Verknüpfungsname angegeben wurde, zeigt FrameMaker weiterhin die aktuelle Seite an.

Wenn sich die verknüpften Informationen in einem Dokument befinden, dessen Seitenformat nicht mit dem des aktuellen Dokuments übereinstimmt, können Sie das Dokument in einem Fenster anzeigen, dessen Größe an die Seite angepasst wird. Verwenden Sie dazu den Befehl "Zurückspringen & an Seite anpassen".


Hypertext- und Viewer-Dokumente

Erstellen einer Feld-Matrix

Sie können eine Feld-Matrix aus Zellen gleicher Größe erstellen, die den Hypertext-Befehlen entsprechen. Sobald ein Leser auf eine Zelle in einem Hypertext-Dokument klickt, hebt FrameMaker die Zelle hervor und führt den entsprechenden Hypertext-Befehl aus. Die Feld-Matrix kann z. B. eine Gruppe von Musikinstrumenten sein.

Eine Feld-Matrix mit drei Zellen

Wenn der Leser auf eines der Instrumente klickt, markiert FrameMaker den Bereich um das Instrument und führt den entsprechenden Hypertext-Befehl aus.

So erstellen Sie eine Feld-Matrix:

    1. Platzieren Sie die Grafik in Ihrem Dokument. Die Grafik sollte sich für eine Matrix mit Zellen gleicher Größe eignen.

    2. Bereiten Sie die Grafik als aktiven Bereich vor. Zeichnen Sie dazu einen einzelnen Textrahmen um die gesamte Grafik (siehe Vorbereiten von Grafiken).

    3. Klicken Sie in den Textrahmen, um die Einfügemarke zu platzieren.

    4. Fügen Sie den Befehl "Feld-Matrix" in den Textrahmen ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen). Lassen Sie den übrigen Textrahmen leer. Die Syntax für diesen Befehl lautet:

matrix Reihen Spalten Textfluss

In diesem Beispiel geben die Parameter Reihen und Spalten die Anzahl der Reihen und Spalten in der Matrix an. Textfluss gibt den Textflusstyp des Textrahmens an, den Sie auf einer Referenzseite erstellen. Der Textfluss darf keine eingebetteten Leerzeichen enthalten.

Für das zuvor gezeigte Beispiel mit zwei Reihen und drei Spalten und den entsprechenden Hypertext-Befehlen in einem Textrahmen einer Referenzseite, deren Textflusstyp "Musikinstrumente" lautet, sieht der Befehl wie folgt aus:

matrix 1 3 Musikinstrumente

    5. Zeichnen Sie einen Textrahmen auf der Referenzseite und weisen Sie ihr einen Textflusstyp zu, der mit dem Textflussnamen im Befehl "Feld-Matrix" übereinstimmt. Informationen über das Zeichnen eines Textrahmens mit dem Textrahmen-Werkzeug finden Sie unter Grafiken und Text. Die Zuweisung von Textflusstypen wird unter Steuern des Textflusses beschrieben.

    6. Klicken Sie in den Textrahmen, um die Einfügemarke zu platzieren. Geben Sie anschließend jeweils einen Hypertext-Befehl pro Absatz in den Textrahmen ein. Die Befehle müssen den Elementen in der ersten Reihe der Matrix von links nach rechts entsprechen, dann den Elementen in der zweiten Reihe usw. Ein Befehl darf nicht länger sein als eine Zeile. Die Größe des Textrahmens kann verändert werden.

Die folgende Darstellung zeigt mögliche Inhalte der Textrahmen für das zu Beginn dieses Abschnitts aufgezeigte Beispiel.

Textrahmen auf Referenzseiten

Hinweis: Sie können bei der Eingabe der Hypertext-Befehle das Dialogfenster "Hypertext" anzeigen, das die exakte Syntax der Befehle enthält. Sie müssen die Befehle jedoch direkt in den Textrahmen geben. Verwenden Sie zum Einfügen von Hypertext-Marken nicht das Dialogfenster "Hypertext".


Hypertext- und Viewer-Dokumente

Erstellen von Aufklappmenüs

Ihr Hypertext-Dokument kann ein Aufklappmenü anzeigen, aus dem der Leser eine Option auswählen kann, die mit den dazugehörigen Informationen verknüpft ist. Das Aufklappmenü kann wiederum eine Ebene mit Untermenüs enthalten.

Hypertext-Aufklappmenü und Untermenü

So erstellen Sie ein Aufklappmenü mit Hypertext-Befehlen:

    1. Erstellen Sie ein Grafikfeld, auf das der Leser klicken kann, um das Aufklappmenü zu öffnen.

    2. Bereiten Sie die Grafik als aktiven Bereich vor. Zeichnen Sie dazu einen einzelnen Textrahmen um die gesamte Grafik (siehe Vorbereiten von Grafiken).

    3. Fügen Sie in den Textrahmen den Befehl "Aufklappmenü" ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen) und lassen Sie den übrigen Rahmen leer. Die Syntax für diesen Befehl lautet:

popup Textfluss

In diesem Beispiel bezeichnet Textfluss den Textflusstyp eines Textrahmens, den Sie auf einer Referenzseite anlegen. Der Textfluss darf keine eingebetteten Leerzeichen enthalten.

    4. Zeichnen Sie auf einer Referenzseite einen Textrahmen und weisen Sie ihm den im Befehl "Aufklappmenü" angegebenen Textflussnamen zu. Informationen über das Zeichnen eines Textrahmens mit dem Textrahmen-Werkzeug finden Sie unter Grafiken und Text. Die Zuweisung von Textflusstypen wird unter Steuern des Textflusses beschrieben.

    5. Doppelklicken Sie in den Textrahmen, um die Einfügemarke zu platzieren. Geben Sie anschließend den Menünamen in den Textfluss ein und drücken Sie die Eingabetaste. (Der Titel des Aufklappmenüs entspricht immer dem ersten Element im Textrahmen.) Auf UNIX-Systemen wird der Menüname angezeigt, unter Windows dagegen nicht.

    6. Geben Sie die gewünschten Menüelemente absatzweise ein. Die Inhalte jedes Absatzes erscheinen als Befehle im Aufklappmenü. Verbreitern Sie ggf. den Textrahmen, damit der Befehl auf eine Zeile passt.

    7. Fügen Sie in jede Zeile (außer in die Zeile mit dem Menünamen) einen Hypertext-Befehl ein. Entsprechende Anweisungen finden Sie unter Erstellen von Hypertext-Verknüpfungen. Sie können z. B. mit dem Befehl "Zu benanntem Ziel springen" ein verwandtes Thema anzeigen, mit dem Befehl "Meldungsfenster" eine kurze Meldung einblenden oder mit dem Befehl "Aufklappmenü" ein Untermenü mit weiteren Optionen öffnen.

Der zu Beginn dieses Abschnitts beschriebene Textrahmen für das Aufklappmenü könnte wie folgt aussehen.

Textrahmen mit einem Beispiel für ein Hypertext-Aufklappmenü

Hinweis: Damit das Aufklappmenü geöffnet werden kann, muss mindestens eine Hypertext-Marke auf der Referenzseite eingefügt werden.

So erstellen Sie ein Aufklapp-Untermenü mit Hypertext-Befehlen:

    1. Suchen Sie auf der Referenzseite nach dem Textrahmen des Aufklappmenüs, für das Sie ein Untermenü erstellen wollen.

    2. Fügen Sie im Textrahmen des Aufklappmenüs den Befehl "Aufklappmenü" in die Zeile ein, in der das Untermenü angezeigt werden soll (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

popup Textfluss

In diesem Beispiel bezeichnet Textfluss den Textflusstyp eines Textrahmens, den Sie auf einer Referenzseite anlegen. Der Textfluss darf keine eingebetteten Leerzeichen enthalten.

    3. Erstellen Sie das Untermenü, indem Sie die Schritte 4 bis 7 unter Hypertext-Befehle ausführen. Im Untermenü kann jedoch kein "Aufklappmenü"-Befehl verwendet werden, da kein Untermenü innerhalb eines Untermenüs erstellt werden kann.

Der Textrahmen für das Untermenü, das am Anfang dieses Abschnitts abgebildet ist, besitzt den Textflusstyp "Seals". Dies könnte wie folgt aussehen.

Textrahmen mit einem Beispiel für ein Hypertext-Kontext-Untermenü


Hypertext- und Viewer-Dokumente

Erstellen von Meldungsfenstern

Sie können mithilfe eines Hypertext-Befehls ein Meldungsfenster erstellen, das einen Titel und eine Meldung enthält. Wenn Sie den Befehl ohne Titel verwenden, erhält das Meldungsfenster den Standardtitel "FrameMaker-Warnung.

Es kann ein Standardtitel festgelegt werden, der für alle Hypertext-Meldungsfenster eines Dokuments verwendet wird.

So erstellen Sie ein Meldungsfenster:

Fügen Sie die folgenden Hypertext-Befehle ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen):

    Um ein Meldungsfenster mit dem Standardtitel anzuzeigen, verwenden Sie den Befehl "Meldungsfenster". Die Syntax für diesen Befehl lautet:

Warnmeldung

    Um ein Meldungsfenster mit einem selbstdefinierten Titel anzuzeigen, verwenden Sie den Befehl "Meldungsfenster mit Titel". Die Syntax für diesen Befehl lautet:

alerttitle Titel :Meldung

In diesem Beispiel ist Titel der Titel des Meldungsfensters, und Meldung ist der Text, der im Meldungsfenster angezeigt werden soll. Titel und Meldung dürfen zusammen nicht länger als 243 Zeichen sein. (Jedes Zeichen einer japanischen Schriftart zählt doppelt.)

Beispiel: Der folgende Befehl zeigt ein Meldungsfenster mit dem Titel "Nicht verfügbar" an, das die Meldung "Dieses Dokument wird gerade bearbeitet" enthält.

alertitle Nicht verfügbar:Dieses Dokument wird gerade bearbeitet.

So definieren Sie einen Standardtitel für Meldungsfenster in einem Dokument:

    1. Zeichnen Sie auf einer Referenzseite einen Textrahmen und weisen Sie ihm den Textflusstyp AlertTitle zu. Informationen über das Zeichnen eines Textrahmens mit dem Textrahmen-Werkzeug finden Sie unter Grafiken und Text. Die Zuweisung von Textflusstypen wird unter Steuern des Textflusses beschrieben.

    2. Geben Sie den Standardtitel in den Textrahmen ein. Wenn beispielsweise der Standardtitel "Online nicht verfügbar" im Textfluss enthalten ist, wird in der Titelleiste aller mit dem Befehl "Meldungsfenster" erstellten Meldungsfenster anstelle von "FrameMaker-Warnung" dieser Titel eingeblendet.

Der Standardtitel wird auch in der Titelleiste aller Meldungsfenster angezeigt, die mit dem Befehl "Meldungsfenster mit Titel" auf folgende Weise ohne Angabe eines Titels erstellt wurden:

alerttitle :Meldung


Hypertext- und Viewer-Dokumente

Starten anderer Anwendungen

Sie können Hypertext-Befehle verwenden, um andere Anwendungen zu starten. Der Leser könnte z. B. in einem Viewer-Dokument eine Datenbankanwendung starten, um Daten zu suchen und anzuzeigen.

Sie können Hypertext-Befehle auch zur Ausführung der folgenden Aufgaben verwenden:

    Auf Unix-Systemen können Sie Unix-Befehle ausführen. Ein Leser könnte z. B. durch Klicken auf einen aktiven Bereich Sicherungsdateien löschen. Mit Application Program Interface (API) können Sie an FrameMaker-Clients Meldungen senden. Weitere Informationen finden Sie im FDK Programmer’s Guide, der zum Lieferumfang des Frame® Developer’s Kit gehört.

Zusätzlich ist es möglich, einen Hypertext-Befehl zu erstellen, der mit einem Universal Resource Locator (URL) verknüpft ist, wenn das Dokument in Hypertext Markup Language (HTML) umgewandelt wird. Weitere Informationen hierzu finden Sie unter Erstellen von Verknüpfungen zu Web-Seiten.

So implementieren Sie die Möglichkeit, eine andere Anwendung unter Windows zu starten:

Fügen Sie den Befehl "Meldungs-Client" ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

message system Anwendung Pfad,Fensterstatus
message winexec Anwendung Pfad,Fensterstatus

In diesen Beispielen ist Anwendung der Dateiname der Anwendung und Pfad ein optionaler Befehlszeilenparameter. Fensterstatus legt den Status des geöffneten Fensters fest. Die folgende Tabelle enthält die Werte, die Fensterstatus annehmen kann.

Status | Bedeutung
SW_HIDE | Blendet das Fenster aus und aktiviert ein anderes.
SW_MAXIMIZE | Maximiert das ausgewählte Fenster.
SW_MINIMIZE | Minimiert das ausgewählte Fenster und aktiviert das nächste Fenster in der Alt+Tab-Reihenfolge.
SW_RESTORE | Aktiviert das Fenster und zeigt es an. (Wenn das Fenster in Vollbildgröße angezeigt wird oder zum Symbol verkleinert ist, wird es von Windows wieder in der ursprünglichen Größe und an der ursprünglichen Position angezeigt.)
SW_SHOW | Aktiviert das Fenster und zeigt es in der aktuellen Größe und Position an.
SW_SHOWDEFAULT | Legt den Anzeigestatus basierend auf dem SW_-Flag fest, der in der Struktur STARTUPINFO angegeben ist. Diese Struktur wird vom Programm, das die Anwendung gestartet hat, an die Funktion CreateProcess übergeben.
SW_SHOWMAXIMIZED | Aktiviert das Fenster und zeigt es als maximiertes Fenster an.
SW_SHOWMINIMIZED | Aktiviert das Fenster und zeigt es als minimiertes Fenster an.
SW_SHOWMINNOACTIVE | Zeigt das Fenster als minimiertes Fenster an (das aktive Fenster bleibt aktiv).
SW_SHOWNA | Zeigt das Fenster in seinem aktuellen Status an (das aktive Fenster bleibt aktiv).
SW_SHOWNOACTIVATE | Zeigt das Fenster in der letzten Größe und Position an (das aktive Fenster bleibt aktiv).
SW_SHOWNORMAL | Aktiviert das Fenster und zeigt es an. (Wenn das Fenster in Vollbildgröße angezeigt wird oder zum Symbol verkleinert ist, wird es von Windows wieder in der ursprünglichen Größe und an der ursprünglichen Position angezeigt.)

Wenn Sie keinen Wert für Fensterstatus angeben, wird standardmäßig SW_SHOWNORMAL verwendet. Weitere Informationen über den Status von Fenstern finden Sie in der Dokumentation zum Windows-SDK (Software Development Kit).

Beispiel: Um PaintBrush zu starten und die Datei "Ship.pcx" (auf Laufwerk C:) in einem zum Symbol verkleinerten Fenster zu öffnen, verwenden Sie folgenden Befehl:

message system pbrush.exe C:/Ship.pcx, SW_MINIMIZE

Einzelheiten zur Verwendung des normalen anstelle des umgekehrten Schrägstrichs finden Sie unter Pfadnamen in Hypertext-Befehlen.

So ermöglichen Sie das Öffnen einer Datei oder einer anderen Anwendung:

Fügen Sie den Befehl "Meldungs-Client" ein (entsprechende Erläuterungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

message openfile Pfadname

In diesem Beispiel ist Pfadname der Pfad zur Datei, zur Anwendung oder zum AppleScript-Script.

Um z. B. die Anwendung zu starten, mit der die Datei "Tuba.eps" erstellt wurde (diese befindet sich im Ordner "Grafiken" auf dem Laufwerk "Festplatte"), und die Datei zu öffnen, verwenden Sie folgenden Befehl:

message openfile /Festplatte/Grafiken/Tuba.eps

Um das Script "DokBericht" im Ordner "Scripte" auf dem Laufwerk "Festplatte" auszuführen, verwenden Sie folgenden Befehl:

message openfile /Festplatte/Scripte/DokBericht

Informationen über die Verwendung des normalen Schrägstrichs in Pfadnamen finden Sie unter Pfadnamen in Hypertext-Befehlen.

So ermöglichen Sie das Ausführen von Befehlen auf UNIX-Systemen:

Fügen Sie den Befehl "Meldungs-Client" ein (entsprechende Erläuterungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

message system Befehl

In diesem Beispiel ist Befehl ein beliebiger UNIX-Befehl, der in einem UNIX-Fenster eingegeben werden kann.

Der folgende Befehl führt z. B. den Inhalt des Ordners auf, in dem sich die Dokumente befinden, sobald der Leser auf einen aktiven Bereich klickt, der den Befehl enthält.

message system ls ~

In diesem Beispiel übergibt FrameMaker den Befehl zur Ausführung an sh(1); stdout und stderr werden zu Ihrem UNIX-Fenster umgeleitet. FrameMaker wartet, bis der Befehl, das Script oder das Programm beendet ist, und setzt dann die Verarbeitung fort.

Der Message System-Befehl kann zusammen mit den Umgebungsvariablen FMDOCDIR und FMDOCNAME eingesetzt werden. Wenn der Leser in einen aktiven Bereich klickt, der den Befehl enthält, wird FMDOCDIR auf den Ordner mit dem aktuellen Dokument und FMDOCNAME auf den Namen dieses Dokuments gesetzt.

So ermöglichen Sie das Senden von Meldungen an eine Anwendung, die bereits auf einem UNIX-System läuft:

Fügen Sie den Befehl "Meldungs-Client" ein (entsprechende Erläuterungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

message Anwendung Parameter

In diesem Beispiel ist Anwendung der Name der Anwendung, und Parameter sind beliebige Parameter, die an die Anwendung übergeben werden. Der folgende Befehl weist z. B. einen API-Client mit dem Namen "ProductionCheck" an, alle Dateien im Ordner "Guide" abzuarbeiten:

message ProductionCheck Guide/*


Hypertext- und Viewer-Dokumente

Schließen von Dateien oder Beenden von FrameMaker

Die Hypertext-Befehle zum Schließen von Dateien und zum Beenden von FrameMaker haben die gleiche Wirkung wie die entsprechenden Befehle im Menü "Datei".

Wenn der Leser einen Befehl zum Schließen einer Datei ausführt, die ungesicherte Änderungen enthält, wird er von FrameMaker zum Speichern der Datei aufgefordert.

So implementieren Sie die Möglichkeit, Dokumente zu schließen:

Fügen Sie die folgenden Hypertext-Befehle ein (entsprechende Anweisungen finden Sie unter Hypertext-Befehle einfügen):

    Um dem Leser das Schließen des aktuellen Viewer-Dokuments zu ermöglichen, fügen Sie den Befehl "Aktuelles Fenster schließen" ein. Die Syntax für diesen Befehl lautet:

quit

    Wenn der Leser die Möglichkeit haben soll, alle geöffneten Viewer-Dokumente zu schließen, fügen Sie den Befehl "Alle Hypertext-Fenster schließen" ein. Der Befehl "Alle Hypertext-Fenster schließen" schließt auch Viewer-Dokumente, die zum Symbol verkleinert wurden. Die Syntax für diesen Befehl lautet:

quitall

So ermöglichen Sie das Beenden von FrameMaker:

Fügen Sie den Befehl "Beenden" ein (entsprechende Erläuterungen finden Sie unter Hypertext-Befehle einfügen). Die Syntax für diesen Befehl lautet:

exit


Hypertext- und Viewer-Dokumente

Testen und Korrigieren fehlerhafter Hypertext-Dokumente

Testen Sie die Befehle, nachdem Sie das Dokument geschrieben und die Hypertext-Befehle eingefügt haben. Um Hypertext-Befehle schneller zu überprüfen, können Sie Befehle ausführen, ohne ein Dokument zuerst in das Viewer-Format umzuwandeln. Außerdem ist es möglich, das Ziel eines Hypertext-Sprungs in einem separaten Fenster anzeigen zu lassen.

Sie können sämtliche Befehle in einem Dokument auch von FrameMaker prüfen lassen.

Hinweis: Auf UNIX-Systemen können Sie mit fmbatch mehrere Dokumente gleichzeitig vom Viewer-Format in das Dokument-Format konvertieren und umgekehrt (siehe Starten von fmbatch).

So führen Sie einen Hypertext-Befehl aus, ohne dem Dokument das Viewer-Format zuzuweisen:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Halten Sie die Strg- und Alt-Taste gedrückt und klicken Sie auf einen aktiven Bereich.

    (UNIX) Halten Sie die Control-Taste gedrückt und klicken Sie mit der rechten Maustaste auf einen aktiven Bereich.

FrameMaker führt den Hypertext-Befehl wie in einem Viewer-Dokument aus.

So erzwingen Sie die Anzeige des Sprungziels in einem separaten Fenster:

Führen Sie eine der folgenden Aktionen aus:

    (Windows) Wenn das Dokument im Viewer-Format vorliegt, klicken Sie bei gedrückter Umschalttaste auf einen aktiven Bereich. Andernfalls halten Sie die Strg-, Alt- und Umschalttaste gedrückt und klicken Sie auf einen aktiven Bereich.

    (UNIX) Wenn das Dokument im Viewer-Format vorliegt, klicken Sie bei gedrückter Umschalttaste auf einen aktiven Bereich. Andernfalls halten Sie die Umschalt- und Control-Taste gedrückt und klicken Sie mit der rechten Maustaste auf einen aktiven Bereich.

So testen Sie alle Befehle in einem oder mehreren Dokumenten:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Durch Drücken von Esc v h überprüft FrameMaker jeden einzelnen Hypertext-Befehl. Wenn sich ein Befehl z. B. auf ein anderes Dokument bezieht, versucht FrameMaker, das Dokument zu öffnen. Sollte sich der Befehl auf ein benanntes Ziel beziehen, stellt FrameMaker sicher, dass dieses Ziel existiert. Sobald ein Problem gefunden wird, beschreibt eine Warnmeldung den ersten Fehler im Dokument. Bei einem Buch werden alle Fehler in das Buchfehlerprotokoll geschrieben.


Hypertext- und Viewer-Dokumente / Testen und Korrigieren fehlerhafter Hypertext-Dokumente

Generieren einer Liste oder eines Index mit Hypertext-Marken

Eine generierte Liste bzw. ein Index mit den Hypertext-Marken ermöglicht eine schnelle Kontrolle des Wortlauts von Hypertext-Befehlen. Die generierte Liste enthält den Text aller in Arbeitsseiten eingefügten Hypertext-Marken sowie deren Seitennummern.

So generieren Sie eine Liste oder einen Index mit Hypertext-Marken:

Verwenden Sie den Befehl "Spezial > Markenliste " oder "Spezial > Markenindex". Weitere Informationen über das Generieren aus einem Dokument finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen und Generieren von Indizes. Weitere Informationen über das Generieren aus einem Buch finden Sie unter Hinzufügen von Dateien zu einem Buch und Aktualisieren von Büchern.


Hypertext- und Viewer-Dokumente / Testen und Korrigieren fehlerhafter Hypertext-Dokumente

Fehlerbehebung in Hypertext-Dokumenten

Fehlerhafte Hypertext-Befehle, falsche Platzierung im Dokument sowie Formatierungsfehler in aktiven Bereichen führen dazu, dass Befehle nicht richtig ausgeführt werden. Ein falscher Verknüpfungsname verhindert beispielweise die korrekte Ausführung des zugehörigen Hypertext-Befehls.

Dieser Abschnitt beschreibt einige der häufigsten Probleme mit Hypertext und deren mögliche Lösung.

Das Klicken auf einen aktiven Bereich bleibt ohne Wirkung.

Dieser Fehler kann verschiedene Ursachen haben:

    Das Dokument liegt nicht im Viewer-Format vor.

    Wenn der aktive Bereich beim Klicken korrekt hervorgehoben wird, enthält der Befehl möglicherweise einen Verknüpfungsnamen, der nicht mit der entsprechenden Verknüpfung am Zielort übereinstimmt.

    Wenn der aktive Bereich beim Klicken nicht hervorgehoben wird, ist die Marke, die den Hypertext-Befehl enthält, möglicherweise nicht vom Typ "Hypertext".

    Wenn sich der aktive Bereich über einer Grafik befindet, befindet sich der Textrahmen, der die Hypertext-Marke enthält, möglicherweise nicht vor der Grafik.

Die Sprungverknüpfung springt auf die falsche Seite.

Der Befehl enthält möglicherweise den richtigen Dateinamen, aber einen falschen Verknüpfungsnamen oder eine ungültige Seitenzahl.

Nur ein Teil des aktiven Bereichs wird hervorgehoben.

Dieser Fehler kann verschiedene Ursachen haben:

    Wenn Sie versuchen, einen Textbereich als aktiven Bereich zu definieren, enthält der Text eventuell eine zusätzliche Hypertext-Marke, oder das Zeichenformat ändert sich innerhalb des Bereichs.

    Wenn Sie versuchen, einen vollständigen leeren Textrahmen als aktiven Bereich zu definieren, enthält der Rahmen eventuell einen zusätzlichen leeren Absatz, zusätzliche Zeichen oder Marken.

Elemente aus einem Aufklappmenü fehlen.

Die Hypertext-Befehle für fehlende Menüelemente sind fehlerhaft. Falls das Aufklappmenü nicht angezeigt wird, sind alle Befehle fehlerhaft.


Hypertext- und Viewer-Dokumente

Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien

Wenn Sie einen Index oder eine Liste, z. B. ein Inhaltsverzeichnis, erstellen, kann FrameMaker Hypertext-Verknüpfungen in die erstellte Datei einfügen. Durch diese Verknüpfungen lässt sich der Leistungsumfang eines Online-Index bzw. eines Online-Inhaltsverzeichnisses wesentlich verbessern. Der Leser muss in der generierten Datei nur auf ein Thema oder eine Seitennummer klicken, um die entsprechende Seite im verknüpften Dokument anzuzeigen.

Erstellte Hypertext-Dokumente können zu folgenden Zwecken verwendet werden:

    Zur Verteilung von erstellten Inhaltsverzeichnissen oder Indizes im Viewer-Format als Navigationswerkzeug für Ihre Online-Dokumente.

    Zur Fehlerbeseitigung in Dokumenten. (Bei der Erstellung eines Index können Sie z. B. den Index mit Hypertext-Verknüpfungen versehen und so durch Springen an die entsprechenden Stellen der Marken Indexmarken-Fehler schnell bereinigen.)

Beim Generieren einer Liste von Hypertext-Marken werden nur die Marken auf den Arbeitsseiten berücksichtigt. Hypertext-Marken auf Vorgabeseiten werden ignoriert.

Die Hypertext-Befehle in einem generierten Dokument können auch aktiviert werden, wenn sich das Dokument nicht im Viewer-Format befindet (siehe Testen und Korrigieren fehlerhafter Hypertext-Dokumente).

So fügen Sie einer generierten Datei Hypertext-Verknüpfungen hinzu:

Führen Sie eine der folgenden Aktionen aus:

    Wenn es sich um ein einzelnes FrameMaker-Dokument handelt, aktivieren Sie "Hypertext-Verbindungen anlegen", wenn Sie den Befehl "Datei > Dienstprogramme > Dokumente vergleichen" wählen.

Weitere Informationen finden Sie unter Vergleichen von Dokumentversionen.

    Wenn Sie eine generierte Datei in ein Buch einfügen, aktivieren Sie im Dialogfenster "Einstellungen" die Option "Hypertext-Verbindungen anlegen". Wenn die generierte Datei bereits erstellt wurde, wählen Sie sie im Buchfenster aus und wählen den entsprechenden "Einstellungen für"-Befehl aus dem Menü "Bearbeiten" (z. B. "Einstellungen für Inhaltsverzeichnis").

Weitere Informationen über das Generieren von Listen und Indizes finden Sie unter Generieren von Inhaltsverzeichnissen und anderen Listen und Generieren von Indizes.


Hypertext- und Viewer-Dokumente / Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien

Steuern der Anzeige des Quelldokuments

Durch Hinzufügen von Registern können Sie das Blättern durch einen erstellten Online-Index erleichtern. Durch Klicken auf den Registerbuchstaben können Sie die Indexseite anzeigen, die die Einträge mit diesem Anfangsbuchstaben enthält.

So fügen Sie einem generierten Index Register hinzu:

    1. Generieren Sie den Index mit Hypertext-Verknüpfungen. Weitere Informationen finden Sie unter Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien.

    2. Wählen Sie im Index "Darstellung > Vorgabeseiten".

    3. Erstellen Sie auf einer Vorgabeseite mithilfe des Textzeilen-Werkzeugs die Buchstaben des Registers. Zeichnen Sie anschließend einen Textrahmen über jeden Registerbuchstaben (siehe Grafiken und Text).

    4. Fügen Sie in den Textrahmen jedes Registerbuchstabens einen "Zu benanntem Ziel springen"-Befehl ein (siehe Erstellen von Verknüpfungen zu bestimmten Themen). Fügen Sie z. B. im Textrahmen über dem Registerbuchstaben A einen "Zu benanntem Ziel springen"-Befehl ein. Verwenden Sie folgende Syntax: gotolink A. (Jeder Gruppentitel im Index enthält bereits einen entsprechenden "Benanntes Ziel angeben"-Befehl als Ergebnis der Indexerstellung mit Hypertext-Verknüpfungen.)

Wenn der Index einen zusammengesetzten Gruppentitel enthält, wie z. B. P–R, fügen Sie für jeden Registerbuchstaben im Bereich einen "Zu benanntem Ziel springen"-Befehl mit derselben Syntax ein. Für den Bereich P-R müssten Sie demnach gotolink P-R in die Textrahmen der Buchstaben P, Q und R einfügen.

    5. Sollte der Index mehr als eine Vorgabeseite verwenden, kopieren Sie die Register auf die anderen Vorgabeseiten.

    6. Speichern Sie den Index im Viewer-Format.


Hypertext- und Viewer-Dokumente / Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien

Anzeigebefehle für generierte Dokumente

Wenn Sie auf einen aktiven Bereich in einem erstellten Hypertext-Dokument klicken, öffnet FrameMaker ein neues Fenster und zeigt die richtige Seite im verknüpften Dokument an. Die verknüpfte Marke bzw. der verknüpfte Absatz wird im Fenster hervorgehoben und zentriert. Sie können die Anzeige des verknüpften Dokuments auch ändern – Sie können es z. B. im aktuellen Fenster anzeigen.

So legen Sie die Ansicht für ein verknüpftes Dokument fest:

    1. Generieren Sie ein Hypertext-Dokument (siehe Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien).

    2. Wählen Sie in der generierten Datei "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite an, die den speziellen Textfluss für die generierte Datei enthält.

Der Textflusstyp des speziellen Textflusses entspricht dem Dokumentsuffix. Der spezielle Textfluss eines Inhaltsverzeichnisses hat z. B. den Typ IVZ, der eines Index den Typ SIX. Um den Typ eines Textflusses zu ermitteln, klicken Sie in den Textrahmen und sehen Sie sich den Namensbereich der Statuszeile an.

Ihre Textflusstypen werden im Namensbereich der Statusleiste angezeigt.

    3. Finden Sie im speziellen Textfluss den Abschnitt, der festlegt, wie das verknüpfte Dokument angezeigt wird.

In einem Inhaltsverzeichnis ist der Absatztyp AktivIVZ und in einem Index AktivSIX. Der Absatz sieht etwa wie folgt aus:

openObjectId <$relfilename>:<$ObjectType> <$ObjectId>

Um den Typ eines Absatzes zu ermitteln, klicken Sie in den Absatz und sehen Sie sich den Namensbereich der Statuszeile an.

    4. Bearbeiten Sie den Absatz, sodass er den gewünschten Anzeige-Befehl enthält.

Eine Liste der verwendbaren Befehle finden Sie unter Anzeigebefehle für generierte Dokumente. Sie können zusätzlich den Befehl "Meldungs-Client" verwenden, um Meldungen an Anwendungen weiterzuleiten, die die API (Application Program Interface) benutzen. Weitere Informationen finden Sie im FDK Programmer’s Guide, der zum Lieferumfang des Frame Developer’s Kit gehört.

    5. Sichern Sie die generierte Datei und generieren Sie sie anschließend erneut.


Hypertext- und Viewer-Dokumente / Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien

Anzeigebefehle für generierte Dokumente

Wenn der Leser auf einen aktiven Bereich in einem erstellten Hypertext-Dokument klickt, zeigt FrameMaker die richtige Seite im verknüpften Dokument an. Die folgende Tabelle enthält einige der verwendbaren Hypertext-Befehle, mit den Sie festlegen können, wie das verknüpfte Dokument angezeigt werden soll. Die Befehle müssen genau so eingegeben werden, wie sie in der Spalte "Befehl" enthalten sind. Verwenden Sie den Baustein <$relfilename>, damit FrameMaker einen relativen Pfadnamen von der generierten Datei zum verknüpften Dokument anlegt. Sie können aber auch <$fullfilename> für einen absoluten Pfad verwenden. (Die Beispiele in der Tabelle zeigen nur den Baustein <$relfilename>.)

Anzeige | Eingabe
Die verknüpfte Marke bzw. der verknüpfte Absatz im aktuellen Fenster zentriert | gotoObjectId <$relfilename>:<$ObjectType> <$ObjectId>
Die verknüpfte Marke bzw. der verknüpfte Absatz im aktuellen Fenster zentriert; die Größe wird an die Seite angepasst | gotoObjectIdFitWin <$relfilename>:<$ObjectType> <$ObjectId>
Die verknüpfte Marke bzw. der verknüpfte Absatz in einem neuen Fenster zentriert | openObjectId <$relfilename>:<$ObjectType> <$ObjectId>
Die verknüpfte Marke bzw. der verknüpfte Absatz zentriert in einem neuen Fenster, dessen Größe an die Seite angepasst ist | openObjectIdFitWin <$relfilename>:<$ObjectType> <$ObjectId>
Die Seite mit der verknüpften Marke bzw. dem verknüpften Absatz im aktuellen Fenster (ohne Hervorhebung) | gotopage <$relfilename>:<$pagenumonly>
Die Seite mit der verknüpften Marke bzw. dem verknüpften Absatz in einem neuen Fenster (ohne Hervorhebung) | openpage <$relfilename>:<$pagenumonly>
Eine Warnmeldung, die den Dateinamen des verknüpften Dokuments enthält | alert <$relfilename>


Hypertext- und Viewer-Dokumente / Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien

Außerkraftsetzen des Anzeigebefehls der generierten Datei

Sie können festlegen, wie ein bestimmtes Dokument angezeigt wird, indem Sie den Anzeigebefehl im AktivIVZ- oder AktivSIX-Absatz der generierten Datei außer Kraft setzen. Sie möchten z. B., dass ein generierter Index, der auf mehrere Dateien verweist (einschließlich einer Glossardatei), das Glossar in einem Fenster und die anderen Dateien in einem anderen Fenster anzeigt.

So setzen Sie den Anzeigebefehl für ein verknüpftes Dokument außer Kraft:

    1. Zeichnen Sie einen Textrahmen auf einer Referenzseite des verknüpften Dokuments und weisen Sie ihm den Textflusstyp "HypertextLinks" zu. Informationen über das Zeichnen eines Textrahmens mit dem Textrahmen-Werkzeug finden Sie unter Grafiken und Text. Die Zuweisung von Textflusstypen wird unter Ändern von Textflusstypen und automatischer Verkettung beschrieben.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn das Dokument in demselben Fenster angezeigt werden soll, geben Sie gotoObjectId ein.

    Um das Dokument in einem separaten Fenster anzuzeigen, geben Sie openObjectId ein.

    3. Speichern Sie das Dokument und generieren Sie es neu (siehe Generieren von Inhaltsverzeichnissen und anderen Listen und Generieren von Indizes). Beim Klicken in die generierte Datei wird das verknüpfte Dokument angezeigt. Dies geschieht vorzugsweise durch den im Textfluss "HypertextLinks" festgelegten Befehl und nicht durch den Befehl im Absatz "AktivIVZ" oder "AktivSIX".


Hypertext- und Viewer-Dokumente / Hinzufügen von Hypertext-Verknüpfungen zu generierten Dateien

Einbinden generierter Dateien in ein Online-System

Falls Sie ein generiertes Hypertext-Dokument als Werkzeug zur Fehlerbeseitigung verwenden, ist das Dokument einsatzbereit, sobald es generiert wurde. Soll die generierte Datei jedoch Teil eines Hypertext-Online-Systems sein, sollten Sie folgende Schritte ausführen, bevor Sie die Dokumente den Lesern im Viewer-Format zur Verfügung stellen:

    Richten Sie Verknüpfungen von den Referenzdokumenten zurück zur generierten Datei ein. Sie können jeden der Hypertext-Befehle verwenden. Es ist z. B. möglich, eine Index- oder Inhaltsverzeichnis-Schaltfläche zu erstellen, die zu der generierten Datei zurückspringt.

    Für das Navigieren durch ein Online-System fügen Sie den Vorgabeseiten der Dokumente aktive Bereiche hinzu. Sie können z. B. auch Schaltflächen erstellen, um zur nächsten und vorigen Seite zu gelangen.

    Legen Sie im Quelldokument und in generierten Dateien Verknüpfungen zu anderen Teilen des Online-Systems an.


Hypertext- und Viewer-Dokumente

Arbeiten in Viewer-Dokumenten und -Büchern

Online-Dokumente und -Bücher werden im Viewer-Format verteilt. Die Leser können ein Viewer-Dokument oder -Buch mithilfe von FrameMaker anzeigen, durchsuchen, kopieren und drucken, aber nicht bearbeiten.

Leser sehen ein Dokument im Viewer-Format genau so, wie es zum Zeitpunkt der Konvertierung in das Viewer-Format ausgesehen hat. Bevor Sie ein Dokument in das Viewer-Format umwandeln, deaktivieren Sie im Menü "Darstellung" die Anzeige des Rasters, des Lineals, der Steuerzeichen und der Begrenzungslinien. Wie Sie ein Viewer-Dokument ohne Menüleiste oder Rollbalken anzeigen, wird im Online-Handbuch "MIF Reference" beschrieben.

So speichern Sie Dokumente im Viewer-Format:

    1. Wählen Sie "Datei > Sichern unter".

    2. Wählen Sie das Format "Viewer" und klicken Sie auf "Sichern".

Um mehrere Dokumente gleichzeitig vom Viewer-Format in das Format "Dokument" zu konvertieren und umgekehrt, wählen Sie die Dateien im Buch aus und drücken Esc d Umschalttaste+y. Aktivieren Sie das Markierungsfeld und klicken Sie auf "Fortfahren".

So speichern Sie ein Buch im Viewer-Format:

    1. Wählen Sie im Buchfenster "Datei > Buch sichern unter".

    2. Wählen Sie das Format "Viewer" und klicken Sie auf "Sichern".

Wenn ein Buch im Viewer-Format geöffnet ist, können Sie durch Klicken auf [image] und [image] zwischen Dateinamen und Text wechseln.

So konvertieren Sie ein Dokument in das Viewer-Format, ohne es zu speichern:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Spezial > Hypertext" und klicken Sie auf "Viewer".

    Drücken Sie Esc d Umschalttaste+y. Dieser Tastaturbefehl kann auch für ein Buch verwendet werden.

So konvertieren Sie ein Viewer-Dokument in das Format "Dokument":

Führen Sie eine der folgenden Aktionen aus:

    Wenn das Dialogfenster "Hypertext" geöffnet ist, klicken Sie auf "Schreibschutz aufheben".

    Drücken Sie Esc d Umschalttaste+y. Dieser Tastaturbefehl kann auch für ein Buch verwendet werden.

So konvertieren Sie ein Buch im Viewer-Format in das Dokument-Format bzw. so konvertieren Sie ein Buch im Dokument-Format in das Viewer-Format:

    1. Wählen Sie im Buchfenster alle Dokumente aus, die Sie aus dem Viewer-Format in das Dokument-Format konvertieren wollen.

    2. Drücken Sie Esc d Umschalttaste+y.

    3. Um die ausgewählten Dateien in das Dokument-Format zu konvertieren, klicken Sie auf das Markierungsfeld. Um die ausgewählten Dateien in das Viewer-Format zu konvertieren, deaktivieren Sie das Markierungsfeld.

    4. Klicken Sie auf "Fortfahren".


Hypertext- und Viewer-Dokumente / Arbeiten in Viewer-Dokumenten und -Büchern

Wechseln zu bestimmten Seiten

Sie können Seiten in Viewer-Dokumenten anzeigen, indem Sie Verknüpfungen in den Dokumenten folgen, Steuerelemente im Dokumentfenster verwenden oder Menübefehle benutzen.

So blättern Sie in Viewer-Dokumenten zu bestimmten Seiten:

Führen Sie eine der folgenden Aktionen aus:

    Klicken Sie auf einen beliebigen aktiven Bereich, dessen Hypertext-Befehl an eine andere Stelle springt.

    Klicken Sie auf die Seiten-Schaltflächen in der Statuszeile.

    Verwenden Sie den Rollbalken oder die Bild-Auf- bzw. die Bild-Ab-Taste.

    Verwenden Sie die Befehle im Menü "Navigation".

    Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle im Dokumentfenster und wählen Sie einen Befehl aus dem Kontextmenü.

Wenn Sie Ihre Viewer-Fensterumgebung modifiziert haben (entsprechende Erläuterungen finden Sie im Online-Handbuch MIF Reference), sind möglicherweise bestimmte Anzeigemethoden nicht verfügbar.


Hypertext- und Viewer-Dokumente / Arbeiten in Viewer-Dokumenten und -Büchern

Wechsel zur vorherigen oder zur nächsten Verknüpfung

Sie können zu vorherigen Verknüpfungen zurück- und anschließend wieder vorwärts springen.

So springen Sie zurück:

Führen Sie eine der folgenden Aktionen aus:

    Klicken Sie auf einen aktiven Bereich, der den Befehl "Zurückspringen" oder "Zurückspringen & an Seite anpassen" enthält.

    Wählen Sie "Navigation > Zurück".

    Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle im Dokumentfenster und wählen Sie "Zurück" aus dem Kontextmenü.

So springen Sie vorwärts:

Drücken Sie Esc v n. Ein Vorwärtsspringen ist nur möglich, wenn Sie vorher zurück gesprungen sind.


Hypertext- und Viewer-Dokumente / Arbeiten in Viewer-Dokumenten und -Büchern

Öffnen eines neuen Fensters

Wenn die Verknüpfung so eingerichtet wurde, dass das Dokument im aktuellen Fenster angezeigt wird, können Sie FrameMaker veranlassen, stattdessen ein neues Fenster zu öffnen.

So öffnen Sie ein neues Fenster beim Rückverfolgen einer Verknüpfung:

Halten Sie die Umschalttaste gedrückt und klicken Sie auf einen aktiven Bereich. Unter Windows öffnet FrameMaker nur dann ein neues Fenster, wenn die Verknüpfung auf ein anderes Dokument verweist.


Hypertext- und Viewer-Dokumente / Arbeiten in Viewer-Dokumenten und -Büchern

Verwenden von Menübefehlen

Einige FrameMaker-Befehle sind in Viewer-Dokumenten verfügbar. Sie können z. B. Text und Grafiken aus einem Viewer-Dokument kopieren und in ein editierbares Dokument einfügen sowie nach Text- und Absatztypen suchen und drucken.

Viewer-Dokumentfenster enthalten vier FrameMaker-Menüs: "Datei", "Bearbeiten", "Navigation" und "Fenster". Um einige der Menübefehle zu benutzen, muss die Einfügemarke platziert werden. Andere Befehle (z. B. "Bearbeiten > Kopieren") erfordern die Auswahl von Elementen. Viewer-Buchfenster enthalten drei FrameMaker-Menüs: "Datei", "Bearbeiten" und "Fenster".

Wenn Sie Ihre Viewer-Fensterumgebung individuell angepasst haben, sind einige Befehle möglicherweise nicht verfügbar. Weitere Informationen über das Deaktivieren von Befehlen finden Sie im Online-Handbuch MIF Reference.

So platzieren Sie in einem Viewer-Dokument die Einfügemarke oder wählen ein Objekt aus:

    Klicken Sie bei gedrückter Strg- bzw. Control-Taste.

So wählen Sie in einem Viewer-Dokument Text aus:

    Halten Sie die Strg- bzw. Control-Taste gedrückt und markieren Sie den Text wie in einem editierbaren Dokument.


Hypertext- und Viewer-Dokumente

Arbeiten mit dem Format FluidView

Ein Dokument im Format FluidView wird als eine fortlaufende Seite ohne Kopf- und Fußzeilen und ohne Ränder angezeigt. Bei Größenänderung des Dokumentfensters wird der Text neu formatiert und an das neue Fenster angepasst.

In den meisten Fällen gibt es keinen Unterschied zwischen dem Arbeiten mit FluidView- und Viewer-Dokumenten. Sie können z. B. auf Hypertext-Verknüpfungen klicken, um innerhalb von bzw. zwischen Dokumenten zu navigieren. Ein FluidView-Dokument unterscheidet sich von einem Viewer-Dokument wie folgt:

    Da das Dokument auf dem Bildschirm als fortlaufende Seite angezeigt wird, führt das Klicken auf das Symbol "Vorherige Seite" bzw. "Nächste Seite" am unteren Rand des Dokumentfensters nicht zur Anzeige der vorherigen oder nächsten Seite. Stattdessen wird bildschirmweise rückwärts oder vorwärts durch den Text geblättert.

    Die gedruckte Version eines FluidView-Dokuments stimmt möglicherweise nicht mit der Bildschirmanzeige überein. Sie können Kopf- und Fußzeilen, mehrere Spalten und andere Optionen für das Seitenlayout zur Optimierung des Dokumentenausdrucks verwenden.

So konvertieren Sie Dokumente in ein FluidView-Format:

    1. Klicken Sie in den Textfluss, den Sie im FluidView-Format anzeigen wollen. Im FluidView-Format kann immer nur jeweils ein Textfluss in einem Dokument angezeigt werden.

    2. Drücken Sie Esc Umschalttaste+u a. Dadurch werden Kopf- und Fußzeilen, Ränder, Seitenumbrüche und Hintergrundgrafiken ausgeblendet, die mehrspaltige Formatierung wird deaktiviert, und das Dokument wird zum Viewer-Dokument.

    3. Schließen Sie das Dokument. Wenn Sie in einem Meldungsfenster zum Speichern des Dokuments aufgefordert werden, klicken Sie auf "Sichern".

Wenn Sie ein im FluidView-Format gespeichertes Dokument wieder öffnen, wird immer der Haupttextfluss angezeigt (normalerweise hat dieser den Typ A). Dies ist auch dann der Fall, wenn bei der Umwandlung des Dokuments in das FluidView-Format ein anderer Textfluss angezeigt wurde. Wenn Sie jedoch auf einen aktiven Bereich klicken, der auf einen weiteren Textfluss verweist, erscheint der neue Textfluss im FluidView-Dokument.

So konvertieren Sie ein FluidView-Dokument zurück in das Dokument-Format:

Drücken Sie Esc d Umschalttaste+y.

So stellen Sie in einem FluidView-Dokument die Ränder und die Kopf- und Fußzeilen wieder her, behalten aber das Viewer-Format bei:

Drücken Sie Esc Umschalttaste+u a.


Hypertext- und Viewer-Dokumente / Arbeiten mit dem Format FluidView

Erstellen von Dokumenten für die Verwendung im FluidView-Format

Beachten Sie bei der Erstellung von FluidView-Dokumenten folgende Punkte:

    Wenn Benutzer ein FluidView-Dokument öffnen, das mehr als einen Textfluss enthält, wird der neue Textfluss immer im Dokumentfenster angezeigt. Das Erstellen von Verknüpfungen zu anderen Flüssen im Dokument ist jedoch möglich. Wenn Benutzer auf einen aktiven Bereich klicken, der auf einen weiteren Textfluss verweist, erscheint der neue Textfluss im FluidView-Dokument.

    Obwohl ein FluidView-Dokument so lang wie jedes FrameMaker-Dokument sein kann, versuchen Sie, eine Länge von 500 m für jedes Dokument nicht zu überschreiten. Ein Seitenumbruch erscheint ca. alle 500 m. Am Ende einer Spalte verankerte Fußnoten und Grafikrahmen werden an diesen Seitenumbrüchen und nicht am Dokumentende angezeigt.

    Setzen Sie verankerte Rahmen in Ihrem Dokument auf eine von drei Verankerungspositionen: "Unter aktueller Zeile", "An der Einfügemarke" oder "Im Absatz". An anderen Positionen verankerte Rahmen führen eventuell zu unerwarteten Ergebnissen.

    Sie können die Viewer-Fensteranzeige ändern oder Menübefehle selektiv deaktivieren. Diese leistungsfähigen Optionen stehen über eine Maker Interchange Format-Datei (MIF) zur Verfügung. Weitere Informationen zur Einrichtung des Viewer-Fensters mithilfe von MIF finden Sie im Online-Handbuch MIF Reference.


Hypertext- und Viewer-Dokumente / Arbeiten mit dem Format FluidView

Ändern des seitlichen Überschriftsbereichs

Sie können seitliche Überschriften in beiden Formaten unterschiedlich handhaben. Sie können z. B. Überschriften in FluidView im seitlichen Überschriftsbereich und im Ausdruck innerhalb des Bereichs für den Arbeitstext positionieren.

So erstellen Sie verschiedene seitliche Überschriftsbereiche im Dokument- und FluidView-Format:

    1. Schalten Sie das Format für seitliche Überschriften mithilfe von "Format > Seitenlayout > Spaltenlayout" ein oder aus, während sich das Dokument im Format "Dokument" befindet (siehe Erstellen einer seitlichen Überschrift).

    2. Drücken Sie Esc Umschalttaste+u a zur Konvertierung in das FluidView-Format.

    3. Drücken Sie Esc f s u, um das Format für seitliche Überschriften in der FluidView-Anzeige ein- und auszuschalten. Einzelheiten zur Einrichtung von seitlichen Überschriften finden Sie unter Formatieren von Text als nummerierte Liste.


Hypertext- und Viewer-Dokumente

Einfügen von Hypertext-Befehlselementen in strukturierte Dokumente

Ein Hypertext-Dokument gleicht jedem anderen Adobe FrameMaker-Dokument, mit der Ausnahme, dass es im Viewer-Format gespeichert wird, damit der Leser es nicht bearbeiten kann. Das Dokument kann eine Struktur enthalten, und Sie können Elemente verwenden, um Hypertext-Befehle in die aktiven Bereiche einzubetten. Die Struktur beeinflusst die Arbeit der Leser mit dem fertigen Dokument jedoch nicht.

Bei der Arbeit mit strukturierten Dokumenten kann durch Verwenden eines Elements ein Hypertext-Befehl eingefügt werden. Ansonsten gibt es bei der Einrichtung eines Hypertext-Dokuments zwischen strukturierten und unstrukturierten Dokumenten keinen Unterschied.

So fügen Sie einen Hypertext-Befehl über ein Element ein:

    1. Klicken Sie in einen für Hypertext vorbereiteten Bereich.

    2. Wählen Sie im Elementkatalog ein Hypertext-Element aus und klicken Sie auf "Einfügen".

    3. Wenn das Dialogfenster "Attribute für neues Element" angezeigt wird, geben Sie Attributwerte für das Element ein und klicken auf "Element einfügen" (siehe Einfügen von Elementen).

    4. Wählen Sie aus dem Aufklappmenü "Befehl" einen Hypertext-Befehl (Einzelheiten hierzu finden Sie unter Hypertext-Befehle). Die Syntax für den Befehl wird unter dem Aufklappmenü angezeigt, und der Name des Befehls wird im Textfeld angezeigt.

    5. Geben Sie Parameter in das Textfeld ein (z. B. einen Dateinamen und einen Verknüpfungsnamen).

Hypertext-Befehle müssen klein geschrieben werden. Die Parameter können groß oder klein geschrieben werden, Sie müssen aber auf die Groß-/Kleinschreibung achten. Der gesamte Befehl darf bis zu 255 Zeichen enthalten (127 Zeichen bei einem japanischen Sprachsystem).

Hinweis: Wenn Sie einen Parameter für den Dateinamen einer Datei eingeben, die sich nicht in demselben Ordner befindet wie das aktuelle Dokument, müssen Sie einen Pfad zu dem Dokument angeben.

    6. Wenn Sie möchten, dass FrameMaker den Befehl auf Fehler überprüft, wählen Sie die Option "Befehl beim Einfügen prüfen".

    7. Klicken Sie auf "Neue Hypertext-Marke". Wenn die Steuerzeichen eingeblendet sind, wird im Dokumentfenster ein Markensymbol [image] angezeigt. In der Strukturansicht erscheint ein Elementrechteck für die Marke mit einem Textausschnitt, der den Hypertext-Befehl anzeigt.

FrameMaker überprüft die Syntax auf Fehler. Wenn die Option "Befehl beim Einfügen prüfen" aktiviert ist, prüft das Programm auch den Befehl. Wenn der Befehl z. B. "Zu benanntem Ziel springen" lautet, prüft FrameMaker, ob die Zielverknüpfung im angegebenen Dokument vorhanden ist. Sollte ein Fehler gefunden werden, wird dieser in einer Warnmeldung beschrieben, der Befehl wird aber dennoch eingefügt.


HTML-, XML- und Adobe PDF-Konvertierung

HTML

Überblick über Adobe PDF

Tagged Adobe PDF

Definieren einer Tagged Adobe PDF-Datei

Fehlerbehebung und Tipps zur PDF-Konvertierung

Speichern von strukturierten Dokumenten im Adobe PDF-Format

Definieren von PDF-Auftragsoptionen


HTML-, XML- und Adobe PDF-Konvertierung

HTML

HTML umfasst eine Reihe von Elementen, die beschreiben, wie die einzelnen Teile eines Dokuments verwendet werden. Zum Beispiel ist das Element P (Absatz) ein normaler Haupttextabsatz, und das Element H1 ist eine Überschrift der ersten Ebene.

HTML-Elemente sind vom Konzept her den Adobe FrameMaker-Formaten ähnlich. Beispielsweise enthalten HTML-Dokumente Elemente für Haupttextabsätze und Überschriften. FrameMaker-Dokumente enthalten ihrerseits Absätze mit Formaten, die für Haupttextabsätze und Überschriften definiert sind.

FrameMaker-Dokument vor und nach der HTML-Konvertierung

HTML-Elemente unterscheiden sich in folgenden Punkten von FrameMaker-Formaten:

    HTML-Dokumente verwenden einen Standardsatz von Elementen, während FrameMaker-Dokumente eine beliebige Anzahl von Formaten und beliebige Namen für diese Formate enthalten können.

    HTML-Elemente beschreiben die Struktur eines Dokuments, nicht dessen Format. Web-Browser wie Netscape Navigator oder Microsoft Internet Explorer zeigen jedes Element in einem vordefinierten Format an. Verschiedene Browser stellen unter Umständen dasselbe Element unterschiedlich dar.

HTML-Dokumente können Hypertext-Verknüpfungen zu anderen Stellen in derselben Datei oder zu anderen Dateien im Internet oder in einem Intranet enthalten. Die meisten Hypertext-Befehle von FrameMaker werden automatisch in HTML-Hypertext-Befehle konvertiert, wenn Sie ein Dokument im HTML-Format speichern. Weitere Informationen finden Sie unter Hypertext-Befehle in HTML- und PDF-Dokumenten.


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Vorbereiten von Dokumenten für die Konvertierung in das HTML-Format

Sie können eine Version des Dokuments schreiben und diese dann zum Erstellen von HTML-, XML- und PDF-Dokumenten verwenden. Sie müssen das Dokument weder neu schreiben noch neu formatieren, um daraus eine Webseite zu erstellen.

HTML ist ein Online-Format, das nur für bestimmte Darstellungsformen optimiert ist. Es ist zum Beispiel nicht einfach, in einer HTML-Datei ein zweispaltiges Layout anzulegen. Daher sehen Ihre HTML-Dokumente nicht unbedingt wie die FrameMaker-Originale aus. Wenn es für die Designelemente in Ihren Dokumenten keine akzeptablen Entsprechungen im HTML-Format gibt, sollten Sie eine Konvertierung in das PDF-Format in Erwägung ziehen. Weitere Informationen hierzu finden Sie unter Überblick über Adobe PDF.

Was wird konvertiert?

Wenn Sie ein Dokument im HTML-Format speichern, konvertiert FrameMaker nur den Inhalt des Haupttextflusses (der mit A gekennzeichnete Textfluss). Stellen Sie sicher, dass es sich bei dem Text in Textfluss A wirklich um den gewünschten Text handelt und dass der gesamte Text in diesem Textfluss verkettet ist. Weitere Informationen finden Sie unter Verketten von Textrahmen.

Wenn das Dokument über mehrere Textflüsse verfügt, die beibehalten werden sollen, speichern Sie es im PDF-Format. Weitere Informationen finden Sie unter Speichern von Dokumenten und Büchern als Adobe PDF. Dabei kann jeder Textfluss in einen Artikelfluss für Acrobat konvertiert werden.

Der Inhalt verankerter Rahmen im Textfluss wird in Grafiken konvertiert (einschließlich des Textes in verankerten Rahmen). Grafiken und Text außerhalb des Haupttextflusses werden nicht in das HTML-Format konvertiert. Das betrifft Text und Grafiken, die sich auf Vorgabeseiten befinden (z. B. als Kopf- und Fußzeile) oder die direkt auf Arbeitsseiten eingefügt wurden (z. B. direkt auf der Seite platzierte Grafiken). Wenn Sie Kopfzeilen imitieren wollen, um am Beginn jedes HTML-Dokuments Text oder Grafiken anzuzeigen (z. B. Navigationsfelder oder Text für ein Logo), verwenden Sie Makros (eine Beschreibung finden Sie unter Arbeiten mit HTML-Konvertierungsmakros).

Einige FrameMaker-Hypertext-Befehle werden in entsprechende HTML-Verknüpfungen konvertiert. Weitere Informationen finden Sie unter Hypertext-Befehle.

Hinweise zum HTML-Export

Beachten Sie beim Exportieren in HTML folgende Hinweise:

    Vektorgrafiken und Textrahmen in verankerten Rahmen werden in Bitmaps umgewandelt. Wenn der Text in konvertierten Grafiken stilisiert wird, können Sie die Einstellung "Text wird stilisiert, wenn kleiner als" im Dialogfenster "Voreinstellungen" ändern.

    Wenn Sie GIF-Grafiken skalieren oder beschneiden, die durch Referenz importiert wurden, gehen diese Einstellungen evtl. bei der Konvertierung in HTML verloren.

    (Windows) HTML-Dateien, die in FrameMaker erstellt wurden, zeigen keine Zeilenumbrüche an, wenn sie im Windows-Editor geöffnet werden. Um die HTML-Dateien korrekt anzuzeigen, verwenden Sie FrameMaker, WordPad oder einen Browser, der die Anzeige des Quellcodes gestattet.

    (UNIX) Wenn Sie die Hintergrundfarbe in FrameMaker auf eine beliebige Farbe (außer Weiß) einstellen, verwenden exportierte Grafiken unter Umständen ebenfalls diese Farbe. Setzen Sie den Hintergrund falls erforderlich auf Weiß zurück und speichern Sie erneut im HTML-Format.

    Wenn die Namen von Absatz- oder Zeichentypen im Dokument Akzentzeichen enthalten, können beim Öffnen der HTML-Datei mit einigen Browsern Probleme auftreten. Um dies zu vermeiden, benennen Sie Absatz- oder Zeichenformate so um, dass sie keine Akzentzeichen verwenden, oder löschen Sie die .css-Datei (Cascading Stylesheet), die mit der HTML-Datei erzeugt wurde.

Verwenden von Schablonen, die sich für HTML eignen

Um beim Speichern von Dokumenten im HTML-Format den Aufwand für die Feinabstimmung zu minimieren, erstellen Sie Ihre Dokumente auf der Grundlage der mitgelieferten FrameMaker-Schablonen. Die Formate dieser Schablonen lassen sich einfach den HTML-Entsprechungen zuordnen.

Beispiel für eine Kapitelschablone vor und nach der HTML-Konvertierung

Verwenden von Web-sicheren Farben

Die Online-Farbbibliothek bietet 216 "web-sichere" Farben, die bei der Anzeige in einem Web-Browser über alle Plattformen ein einheitliches Erscheinungsbild aufweisen. Weitere Informationen finden Sie unter Farbbibliotheken.


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Vorbereiten von Dokumenten für die Konvertierung in das HTML-Format

Umwandeln von irregulären Formaten in neue Formate

Eine optimale Konvertierung hängt von einer konsistenten Formatzuweisung in Ihren FrameMaker-Dokumenten ab. Wenn Sie in Dokumenten anstelle der definierten Formate aus den Katalogen irreguläre Formate einsetzen, erhalten Sie meist ein schlechteres Ergebnis. Enthält ein Dokument beispielsweise nur ein Haupttextformat für reguläre Absätze und Überschriften, wird das Dokument nicht optimal in das HTML-Format übersetzt. Wenn Ihr Dokument sehr viele irreguläre Formate verwendet, sollten Sie auf deren Basis einen neuen Satz von Formaten definieren und zuweisen.

So können Sie einen neuen Satz von Formaten erstellen und zuweisen, der auf den irregulären Formatzuweisungen in einem Dokument basiert:

    1. Wählen Sie "Datei > Dienstprogramme > Formate anlegen und zuweisen" und klicken Sie auf "Fortfahren". Alle in einem Dokument verwendeten, aber nicht im Katalog gespeicherten Formate werden dem Katalog hinzugefügt. Wenn das Dokument ein Format mit irregulären Formatierungen verwendet, wird ebenfalls ein separates Format basierend auf der irregulären Formatzuweisung in den Katalog eingefügt.

Enthält ein Dokument beispielsweise einen Haupttextabsatz mit einer irregulären Formatzuweisung (z. B. mit einem linken Einzug), wird dieser Absatz mit Haupttext1 gekennzeichnet. Wenn ein weiteres irreguläres Format für Haupttext (z. B. mit einer Änderung der Standardschrift) vorhanden ist, wird jeder Absatz, der diese Formatzuweisung verwendet, mit Haupttext2 gekennzeichnet.

    2. Öffnen Sie den Absatz- und Zeichenformat-Katalog und überprüfen Sie die neuen Typen. Sie sollten bestimmten Formaten aussagekräftigere Namen zuweisen. So könnte Haupttext1 beispielsweise durch HaupttextEinzug ersetzt werden.


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Vorbereiten von Dokumenten für die Konvertierung in das HTML-Format

Einrichten von Verknüpfungen zu URLs

Eine URL (Uniform Resource Locator) gibt die Position eines Dokuments im Internet oder in einem Intranet an. Sie können in ein FrameMaker-Dokument eine spezielle Marke einfügen, die beim Speichern im HTML- oder PDF-Format zu einer Verknüpfung mit einer URL wird.

So fügen Sie eine Verknüpfung mit einer URL ein:

    1. Wählen Sie den Text aus, der mit einer URL verknüpft werden soll, und weisen Sie ihm ein Zeichenformat zu. Beispielsweise könnten Sie dem Hinweis "Klicken Sie hier, um weitere Informationen anzuzeigen" ein Unterstreichungsformat zuweisen.

Weitere Informationen finden Sie unter Vorbereiten aktiver Bereiche.

    2. Klicken Sie in den formatierten Bereich und wählen Sie "Spezial > Hypertext".

    3. Wählen Sie "Meldungs-Client" aus dem Aufklappmenü "Befehl" und geben Sie Folgendes in das Textfeld "Syntax" ein: message URL url_Name

Ersetzen Sie url_Name durch die URL, zu der die Verknüpfung hergestellt werden soll. Wenn Sie beispielsweise eine Verknüpfung zu den Homepages von Adobe Systems herstellen wollen, geben Sie Folgendes ein:
message URL http://www.adobe.com

    4. Klicken Sie auf "Neue Hypertext-Marke". Nach Konvertieren des Dokuments in das HTML- oder PDF-Format wird durch Klicken auf den formatierten Text die in der URL angegebene Seite angezeigt.

FrameMaker-Marke (oben) und nach dem Konvertieren in eine HTML-Verknüpfung (unten)


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Vorbereiten von Dokumenten für die Konvertierung in das HTML-Format

Einrichten von Verknüpfungen für Imagemaps

Imagemaps auf einer Webseite sind Grafiken mit Bereichen, die als Verknüpfungen definiert sind. Imagemaps gestalten Verknüpfungen zu Webseiten interessanter, die sonst nur aus Text bestünden.

Bei der Konvertierung eines FrameMaker-Dokuments in das HTML- oder XML-Format werden die Grafiken im Haupttextfluss automatisch in Imagemaps konvertiert, wenn Sie sie korrekt eingerichtet haben. Die Konvertierung findet in folgenden Fällen statt:

    Wenn sich auf einer Grafik in einem verankerten Rahmen ein oder mehrere Textrahmen befinden, die gültige Hypertext-Marken enthalten. Weitere Informationen finden Sie unter Vorbereiten von Grafiken.

In Imagemaps konvertierte Grafiken

    Wenn sich auf einer Grafik in einem verankerten Rahmen eine rechteckige Matrix mit Verknüpfungen befindet. Weitere Informationen finden Sie unter Erstellen einer Feld-Matrix.


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Speichern von Dokumenten im HTML-Format

Um ein FrameMaker-Dokument in das HTML-Format zu konvertieren, speichern Sie es einfach als HTML-Datei. Beim Speichern im HTML-Format wird definiert, wie die einzelnen FrameMaker-Formate in entsprechende HTML-Elemente konvertiert bzw. diesen Elementen zugeordnet werden. Sie können auch ein ganzes Buch im HTML-Format speichern. Weitere Informationen finden Sie unter Konvertieren von Büchern in HTML-Dateien.

FrameMaker erstellt bei der Konvertierung automatisch Zuordnungen der Formate für HTML-Elemente. Sie können für diese Zuordnung eine Feinabstimmung durchführen und weitere Anpassungen vornehmen, indem Sie Konvertierungsmakros anlegen. Informationen hierzu finden Sie unter Anpassen von HTML-Zuordnungen und Feinabstimmung von Zuordnungen durch Bearbeiten von Referenzseiten.

Auch wenn Sie eine Feinabstimmung der Konvertierung planen, sollten Sie mit dem Speichern des Dokuments im HTML-Format beginnen. Im Anschluss können Sie die automatisch erstellten Zuordnungen wie erforderlich anpassen.

So speichern Sie ein Dokument im HTML-Format:

    1. Wählen Sie "Datei > Sichern unter" und wählen Sie dann "HTML" aus dem Aufklappmenü.

    2. Fügen Sie dem Dateinamen die Erweiterung .html hinzu, geben Sie ein Verzeichnis an und klicken Sie auf "Sichern". Die konvertierte Datei wird im angegebenen Verzeichnis gespeichert.

    3. Öffnen Sie die HTML-Datei in einem Web-Browser und überprüfen Sie sie. Wenn die Datei Ihren Vorstellungen entspricht, ist Ihre Arbeit beendet.

Wenn Sie einige der Zuordnungen neu festlegen wollen, führen Sie die Arbeitsschritte aus, die unter Anpassen von HTML-Zuordnungen aufgeführt sind.


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Beibehalten des FrameMaker-Erscheinungsbilds mithilfe von Stilvorlagen

HTML wurde nicht als Formatierungssprache entwickelt, sondern als Möglichkeit zur Darstellung der Struktur (bzw. Semantik) eines Dokuments. In bestimmten Fällen ist für Sie sicherlich nicht nur das Format eines Dokuments, sondern auch die Struktur bzw. Semantik, von Interesse. So möchten Sie unter Umständen das Aussehen Ihres FrameMaker-Dokuments beibehalten, und zwar so detailliert, wie dies mit den regulären HTML-Elementen nicht möglich ist.

Nehmen Sie an, Sie arbeiten mit einem Dokument, das für den ersten Buchstaben jedes Kapitels eine blaue 20-Punkt-Schrift verwendet. Mit einer HTML-Stilvorlage können Sie eindeutige Formatierungen dieser Art beibehalten.

HTML-Stilvorlagen werden automatisch unter demselben Namen wie die HTML-Hauptdatei, jedoch mit der Erweiterung ".css" angelegt. Dies ist ein standardisiertes Dateiformat, das viele Web-Browser verwenden und interpretieren können. Eine .css-Stilvorlage enthält Formatdefinitionen, mit deren Hilfe sich Schrift, Stil, Größe, Einzüge, Zeilenabstand und Ränder des Originaldokuments übernehmen lassen.

Die HTML-Datei enthält einen Verweis auf die .css-Stilvorlage. Wenn der Browser die Stilvorlage findet, verwendet er die darin enthaltenen Informationen für die Formatierung der Webseite. Wenn der Browser keine Stilvorlagen unterstützt, verwendet er stattdessen das integrierte Format, das für jedes HTML-Element definiert ist.

So verwenden Sie eine HTML-Stilvorlage:

    1. Speichern Sie Ihr Dokument im HTML-Format. Weitere Informationen finden Sie unter Speichern von Dokumenten im HTML-Format. Dabei wird in dem Ordner, in dem sich die HTML-Datei befindet, automatisch eine .css-Datei angelegt.

    2. Kopieren Sie die HTML-Stilvorlage (die .css-Datei) in denselben Ordner auf dem Web-Server, in dem sich auch Ihre HTML-Dateien befinden.

Hinweis: Stilvorlagen werden manchmal als "überlappend" bezeichnet, weil sich ihre Formatierungsregeln mit den Regeln in anderen Stilvorlagen überlappen (oder sogar mit ihnen kollidieren) können. So könnte z. B. Ihr konvertiertes Dokument mit einer persönlichen Stilvorlage angezeigt werden, die von einem anderen Benutzer angelegt wurde. Die von FrameMaker erstellte Stilvorlage hat Vorrang vor anderen Stilvorlagen.


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Anpassen von HTML-Zuordnungen

Folgende HTML-Zuordnungen können geändert werden:

    Absatzformate werden HTML-Elementen zugeordnet, um die Formatierung auf Absatzebene festzulegen (einschließlich der Formate für Haupttextabsätze und Überschriften).

    Zeichenformate werden HTML-Elementen zugeordnet, um die Formatierung auf Zeichenebene festzulegen (einschließlich gebräuchlicher Formatdefinitionen für fetten oder hervorgehobenen Text).

    Querverweisformate werden HTML-Konvertierungsmakros zugeordnet, um festzulegen, wie Querverweise in HTML angezeigt werden sollen.

Nach dem Speichern eines Dokuments im HTML-Format werden Sie möglicherweise die Formatzuordnungen weiter verfeinern.

Hinweis: Einige wenige Formatzuordnungen lassen sich nicht ändern. Eine FrameMaker-Tabelle wird beispielsweise immer in eine HTML-Tabelle konvertiert, und ein verankerter Rahmen wird immer zu einer Grafik mit einem IMG-Tag.

So definieren oder ändern Sie HTML-Formatzuordnungen:

    1. Wählen Sie "Datei > Dienstprogramme > HTML-Einstellungen". FrameMaker lädt entweder die aktuellen Zuordnungen in das Dialogfenster "HTML-Einstellungen" oder erstellt Standardzuordnungen, wenn noch keine Formatzuordnungen definiert wurden.

    2. Wählen Sie aus dem Aufklappmenü "Zuordnen" den Typ des Formats, das zugeordnet werden soll (Absatz, Zeichen oder Querverweis).

    3. Legen Sie eine Formatzuordnung fest, indem Sie im Aufklappmenü "Von" ein FrameMaker-Format und im Aufklappmenü "Nach" ein HTML-Element bzw. ein Makro wählen.

Informationen über den Inhalt des Aufklappmenüs "Nach" finden Sie unter Absatzbasierte HTML-Elemente und Zuordnungen für Querverweisformate.

Sie können in das Dokument klicken, um ein Format auszuwählen, das angepasst werden soll. Im Dialogfenster "HTML-Einstellungen" wird sofort die aktuelle Formatzuordnung für das Format angezeigt, auf das Sie geklickt haben.

    4. Wählen Sie eine der folgenden Möglichkeiten:

    Wenn Sie Absatzformate zuordnen und die automatische Absatznummerierung in den konvertierten Text übernehmen wollen, aktivieren Sie "Automatische Nummerierung einbeziehen". (Für die Elemente in einer Liste müssen Sie die automatische Nummerierung nicht einbeziehen.)

    Wenn Sie "Überschrift (Standardebene)" ein Format zuordnen und bei jedem Auftreten dieses Formats eine neue Webseite beginnen wollen, aktivieren Sie "Neue Webseite mit Verknüpfung". Weitere Informationen über das Zuordnen von Überschriften finden Sie unter Zuordnungen für die Standardebene von Überschriften.

Mithilfe dieser Option können Sie ein umfangreiches FrameMaker-Dokument in mehrere HTML-Dateien aufteilen, die jeweils mit einer einzelnen Datei verknüpft sind. Sobald FrameMaker das angegebene Format findet, wird die Überschrift in der Originaldatei (der übergeordneten Datei) mit einem untergeordneten Dokument verknüpft, dessen Inhalt beim Überschriftenformat beginnt und beim nächsten Auftreten des Formats endet. Informationen darüber, wie Sie mit dieser Einstellung ein Inhaltsverzeichnis simulieren können, finden Sie unter Erstellen von Verknüpfungen, die ein Inhaltsverzeichnis simulieren.

    Wenn Sie dem Listenelement ein Format zuordnen, um eine Liste mit Auszeichnungspunkten oder eine nummerierte Liste zu erstellen, und festlegen wollen, welcher Ebene das Element angehört (normalerweise durch den Grad der Einrückung ausgedrückt), geben Sie einen Wert für "Liste verschachteln bei" an. Informationen über Zuordnungen für Listen finden Sie unter Zuordnungen für Listen.

    5. Klicken Sie auf "Ändern", um die Zuordnung zu übernehmen.

    6. Wiederholen Sie die Schritte 2 bis 5 wie erforderlich.

    7. Sobald Sie alle Zuordnungen festgelegt haben, schließen Sie das Dialogfenster und speichern Sie das Dokument im HTML-Format (siehe Speichern von Dokumenten im HTML-Format).

Wenn Sie die Zuordnungstabellen auf der HTML-Referenzseite bearbeiten wollen, schließen Sie zuvor das Dialogfenster "HTML-Einstellungen". Falls Sie das Dialogfenster geöffnet lassen, erhalten Sie eine Fehlermeldung beim Versuch, die Tabellen auf dieser Seite zu bearbeiten.


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Anpassen von HTML-Zuordnungen

Zuordnungen für die Standardebene von Überschriften

HTML unterstützt sechs Ebenen für Überschriften. Sie können alle FrameMaker-Absatzformate in eine Überschrift konvertieren, indem Sie sie "Überschrift (Standardebene)" zuordnen. Bei dieser speziellen Zuordnung werden Überschriften im Dokument gemäß ihren relativen Ebenen und basierend auf der Zuordnung der höchsten Ebene in dieser Datei mit H1, H2 usw. gleichgesetzt. Der Vorteil dieser Methode liegt darin, dass beim Aufteilen des Dokuments in separate HTML-Dateien jede Datei eine H1-Zuordnung und eine geeignete Überschriftenhierarchie unter H1 besitzt.

Nehmen Sie beispielsweise an, Sie verwenden in Ihrem Dokument die Formate Titel1, Titel2 und Titel3. Bei der Konvertierung in das HTML-Format teilen Sie das Dokument vielleicht in zwei Dateien auf, wobei in der zweiten Datei nur die Formate Titel2 und Titel3 vorkommen. Die Standardebene sorgt dafür, dass Titel2 in der ersten Datei H2 und in der zweiten Datei H1 zugeordnet wird.

Weitere Informationen über die Funktionsweise der Standardebene beim Teilen von Dokumenten in separate HTML-Dateien finden Sie unter Die Referenzseite "Headings".

Wenn Sie für den Standardebenen-Mechanismus eine Feinabstimmung durchführen oder ihn außer Kraft setzen und Zuordnungen für bestimmte Überschriftsebenen selbst festlegen wollen, müssen Sie spezielle Tabellen auf den Referenzseiten des FrameMaker-Dokuments bearbeiten. Weitere Informationen finden Sie unter Die Referenzseite "Headings" und Bearbeiten der Tabelle "HTML Mapping".


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Anpassen von HTML-Zuordnungen

Zuordnungen für Listen

FrameMaker definiert Listen mit Auszeichnungspunkten automatisch als ungeordnete HTML-Listen und nummerierte Listen als geordnete HTML-Listen. Wenn Sie diese automatische Zuordnung außer Kraft setzen wollen, müssen Sie eine Tabelle auf der HTML-Referenzseite des FrameMaker-Dokuments bearbeiten. Weitere Informationen finden Sie unter Bearbeiten der Tabelle "HTML Mapping".

Im Dialogfenster "HTML-Einstellungen" können Sie die Ebene einer Liste festlegen, indem Sie einen Wert für "Liste verschachteln bei" angeben. Ein Browser zeigt unterschiedliche Listenebenen in Form von unterschiedlichen Einrükkungen an.

Sie können die automatische Absatznummerierung von FrameMaker in den konvertierten Text einfügen, indem Sie "Automatische Nummerierung einbeziehen" aktivieren. Die meisten Browser verfügen aber über eigene Auszeichnungspunkte und Nummern für Listen, sodass Sie diese Option bei der Konvertierung von Listen normalerweise nicht einsetzen werden.

Absatzbasierte HTML-Elemente
Zuordnungsname im Dialogfenster "HTML-Einstellungen" | Entsprechendes HTML-Element | Empfohlene Verwendung und typisches Erscheinungsbild in einem Web-Browser
Überschrift (Standardebene) | H1, H2, H3, H4, H5, H6 | Sechs Überschriftsebenen, mit H1 als höchster Ebene
Absatz | P | Normale Haupttextabsätze
Vorformatierter Text | PRE | Text, der Seitenumbrüche und Abstände des Originals ziemlich genau beibehält, gewöhnlich durch Verwendung mehrerer Leerzeichen und einer Schrift mit fester Zeichenbreite.
Adresse | ADDRESS | Vom übrigen Dokument abgesetzter Text, der eine E-Mail-Adresse oder Ähnliches angibt und gewöhnlich eingerückt oder kursiv dargestellt wird
Block Quote | BLOCKQUOTE, BQ | Zitat, hervorgehoben durch Einrückung
Listenelement | LI | Element, dem in einer ungeordneten Liste (UL) ein Auszeichnungspunkt vorangeht und in einer geordneten Liste (OL) eine fortlaufende Nummer
Listenelement (Fortsetzung) | P | Haupttextabsatz in einer Liste (ohne vorangestellte/n Auszeichnungspunkt oder Nummer)
Dateneinheit | DT | Einheit (z. B. Begriff in einem Glossar), die durch ein DD-Element definiert werden soll
Datendefinition | DD | Definition eines Begriffs (DT), wie z. B. in einem Glossareintrag
Datendefinition (Fortsetzung) | P | Haupttextabsatz in einer Datendefinition
Entfernen | Kein | Bei der Konvertierung in HTML entfernt

HTML-Elemente auf Zeichenbasis
Zuordnungsname im Dialogfenster "HTML-Einstellungen" | Entsprechendes HTML-Element | Empfohlene Verwendung und typisches Erscheinungsbild in einem Web-Browser
Blinken (Netscape) | BLINK | Blinkender Text (unter Umständen nicht funktionsfähig in Nicht-Netscape-Browsern)
Zitat | CITE | Zitat, gewöhnlich kursiv oder unterstrichen dargestellt
Code | CODE | Computer-Programmcode, gewöhnlich in einer Schrift mit fester Zeichenbreite dargestellt, z. B. in Courier
Definition | DFN | Definition eines Begriffs, gewöhnlich kursiv dargestellt
Betonung | EM | Hervorgehobener Text, gewöhnlich kursiv oder unterstrichen dargestellt
Tastatur | KBD | Text, den ein Benutzer eingibt, gewöhnlich in einer Schrift mit fester Zeichenbreite dargestellt, z. B. in Courier
Beispiel | SAMP | Text, der in einer Schrift mit fester Zeichenbreite erscheint, z. B. in Courier
Kurzzitat (Int.) | Q | Zitat, das keinen ganzen Absatz einnimmt, gewöhnlich in Anführungszeichen gesetzt (wird evtl. nicht von allen Browsern erkannt)
Span (CSS) | SPAN | Text, der wie in einer HTML-Stilvorlage festgelegt (von Browsern, die Stilvorlagen erkennen) oder ganz ohne besondere Formatierung (von anderen Browsern) angezeigt wird. Wird verwendet, wenn sich keine andere Zuordnung eignet, z. B. für eine Initiale.
Starke Betonung | STRONG | Hervorgehobener Text, gewöhnlich in Fettschrift dargestellt
Schreibmaschine | TT | Text in einer Schrift mit fester Zeichenbreite, z. B. Courier
Variable | VAR | Spezialbegriff oder beim Programmieren der Name einer Variablen, gewöhnlich kursiv oder fett und kursiv dargestellt
Reiner Text | Kein | Text, der jegliche vorherige Zeichenzuordnung aufhebt und gemäß der Absatzzuordnung dargestellt wird
Entfernen | Kein | Bei der Konvertierung in HTML entfernt


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Anpassen von HTML-Zuordnungen

Zuordnungen für Querverweisformate

Ein typischer Querverweis in einem gedruckten Dokument wie "Siehe "Syntax" auf Seite 8" verliert in HTML-Dokumenten seine Bedeutung, da keine Seitennummerierung verwendet wird. Aus diesem Grund werden Querverweise standardmäßig dem vordefinierten Querverweis-Makro "Siehe auch" zugeordnet. Dieses Makro ändert den Querverweis so, dass er auf den Text des Absatzes und nicht auf die Seitennummer verweist (z. B. "Siehe "Syntax""). Der Querverweistext im Originaldokument wird im konvertierten Dokument zu einer HTML-Verknüpfung, unabhängig von der Art des zugewiesenen Formats.

Sie können das Makro "Siehe auch" ändern oder eigene Makros erstellen und die Querverweise entsprechend zuordnen.

Beim ersten Zuordnen eines Querverweises ist das Makro "Siehe auch" das einzige Makro im Aufklappmenü "Nach" des Dialogfensters "HTML-Einstellungen". Wenn Sie weitere Makros für die Konvertierung erstellen, werden diese ebenfalls in diesem Menü angezeigt. Informationen darüber, wie Querverweis-Makros erstellt und bearbeitet werden, finden Sie unter Arbeiten mit HTML-Konvertierungsmakros.

Mithilfe zweier weiterer Auswahlmöglichkeiten im Menü "Nach" können Sie Querverweise auf andere Art zuordnen:

    Wählen Sie "Ursprüngliches Querverweis-Format", wenn der Text des Querverweises unverändert bleiben soll.

    Wählen Sie "Entfernen", um den Text im Querverweis zu löschen.


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Feinabstimmung von Zuordnungen durch Bearbeiten von Referenzseiten

Sie können für die HTML-Konvertierung eine Feinabstimmung durchführen, indem Sie die Tabellen auf zwei speziellen FrameMaker-Referenzseiten bearbeiten: die Seite "Headings" und die Seite "HTML". Beim Konvertieren eines Buches heißen diese Referenzseiten "BookHeadings" und "BookHTML". Weitere Informationen finden Sie unter Konvertieren von Büchern in HTML-Dateien. Allgemeine Informationen über Referenzseiten finden Sie unter Arbeiten mit Referenzseiten.

Hinweis: Bearbeiten Sie die Informationen auf der Referenzseite "HTML" nur, wenn Sie mit HTML vertraut sind. Für die meisten Anwender ist es nicht erforderlich, die Tabellen auf dieser Seite zu ändern.

Die Tabellen auf den Referenzseiten werden automatisch erstellt, wenn Sie das erste Mal im HTML-Format speichern oder wenn Sie das erste Mal "Datei > Dienstprogramme > HTML-Einstellungen" wählen. Die Referenzseite "Headings" enthält die Tabelle "Headings". Die Referenzseite "HTML" enthält folgende Tabellen:

    Die Tabelle "HTML Mapping". Weitere Informationen finden Sie unter Bearbeiten der Tabelle "HTML Mapping".

    Die Tabelle "HTML Options" mit den Einstellungen, die Sie im Dialogfenster "Optionen" angeben. Weitere Informationen finden Sie unter Festlegen der Grafikkonvertierung.

    Die Tabelle "HTML System Macros", die Tabelle "HTML Cross-Reference Macros" und die Tabelle "HTML General Macros". Weitere Informationen finden Sie unter Arbeiten mit HTML-Konvertierungsmakros.

    Die Tabelle "HTML Character Macros". Weitere Informationen finden Sie unter Konvertieren von Sonderzeichen.

Wenn die Tabellen sehr umfangreich sind, wird die HTML-Referenzseite um die erforderlichen Seiten erweitert.


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Feinabstimmung von Zuordnungen durch Bearbeiten von Referenzseiten

Die Referenzseite "Headings"

Die Tabelle "Headings" auf der gleichnamigen Referenzseite gibt an, welche Typen für die Überschriften verwendet werden sollen und auf welcher Ebene sie sich befinden.

Die Tabelle "Überschriften" definiert die relative Hierarchie der Überschriften.

Mithilfe dieser Tabelle können Sie die Zuordnungen für Überschriften und die relativen Ebenen dieser Überschriften ändern.

Um Sie bei der Identifizierung der Überschriftenformate zu unterstützen, wird der Text in derselben Schrift und Schriftgröße wie die Überschriften auf den Arbeitsseiten des Dokuments angezeigt.

Wenn Sie das Dokument bei "Titel2_ aufteilen, erzeugen Sie zwei untergeordnete Dokumente. Unabhängig davon, bei welchem Format Sie die Teilung durchführen, dieses Format wird in den untergeordneten Dokumenten zu H1. FrameMaker behält die relativen Ebenen der Überschriften bei, obwohl sie immer mit H1 beginnen. Im zweiten untergeordneten Dokument beispielsweise erscheint "Zwischenüberschrift" als H3.

So bearbeiten Sie die Tabelle "Headings":

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Seite "Headings" an. (Diese Seite existiert erst, wenn Sie das Dokument im HTML-Format gespeichert oder den Befehl "Datei > Dienstprogramme > HTML-Einstellungen" gewählt haben.)

    2. Führen Sie zur Bearbeitung der Tabelle folgende Aktionen aus:

    Um einer Überschriftsebene ein anderes Absatzformat zuzuordnen, ändern Sie den Absatztyp in der zweiten Spalte, lassen aber die Nummer für die Überschriftsebene unverändert. Wenn beispielsweise das Format "Hinweis" einer Überschrift der Ebene 6 zugeordnet ist und Sie dieser Ebene nun das Format "Warnung" zuordnen wollen, ändern Sie in der zweiten Spalte einfach Hinweis in Warnung.

    Um die relativen Ebenen der Überschriften zu ändern, bearbeiten Sie die Nummern in der Spalte für die Überschriftsebene. Soll z. B. das Format "Warnung" für eine höhere Überschriftsebene verwendet werden, ändern Sie in der Spalte für die Überschriftsebene die Nummer 6 zu Nummer 5. (Sie müssen die Reihenfolge der Reihen nicht ändern, können dies aber tun, damit die Tabelle leichter lesbar ist.)

    Um einer Überschriftsebene mehrere Formate zuzuordnen, vergeben Sie für alle Formate dieselbe Nummer in der Spalte für die Überschriftsebene. Beispielsweise sind in der folgenden Headings-Tabelle die beiden Formate "Hinweis" und "Warnung" Überschriften der Ebene 6.

    Überschriftsebene | Absatzformat | Kommentar
6 | Hinweis |
6 | Warnung |

    Wenn Sie ein Format in die Headings-Tabelle einfügen wollen, drücken Sie Strg+Eingabetaste. Füllen Sie danach die Spalten für die Überschriftsebene und das Absatzformat aus.

    3. Wenn Sie Formate aus der Headings-Tabelle entfernt bzw. dort eingefügt haben, ändern Sie deren Zuordnungen auch in der Tabelle "HTML Mapping". So können Sie beispielsweise in der Tabelle "HTML Mapping" den Eintrag für das Format "Zwischenüberschrift" von H* zu P ändern. Weitere Informationen über die Bearbeitung dieser Tabelle finden Sie im nächsten Abschnitt.


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Feinabstimmung von Zuordnungen durch Bearbeiten von Referenzseiten

Bearbeiten der Tabelle "HTML Mapping"

Die Tabelle "HTML Mapping" auf der Referenzseite "HTML" enthält die Zuordnungen, die Sie mithilfe des Dialogfensters "HTML-Einstellungen" zuweisen. (Zuordnungen für Überschriften werden hier und in der Tabelle "Headings" angezeigt.) Eine direkte Bearbeitung dieser Tabelle ist normalerweise nicht erforderlich, kann aber in folgenden Fällen sinnvoll sein:

    Um die Standardebenen-Zuordnung der Überschriften zu umgehen und stattdessen einer Überschriftsebene wie z. B. H1 oder H2 explizit ein Format zuzuordnen. Weitere Informationen finden Sie unter Zuordnungen für die Standardebene von Überschriften.

    Um viele Zuordnungen schnell oder global mithilfe von "Bearbeiten > Suchen/Ändern..." zu ändern.

    Um eine Liste mit Auszeichnungspunkten in eine nummerierte Liste umzuwandeln (und umgekehrt).

    Um ein HTML-Element zu verwenden, das im Dialogfenster "HTML-Einstellungen" nicht verfügbar ist.

    Um die Zuordnungen in der Spalte "Comments" der Tabelle zu kommentieren.

Die erste Spalte der Tabelle enthält ein FrameMaker-Quellelement. Der Eintrag beginnt mit einem Buchstaben, der den Typ des Elements angibt: P für ein Absatzformat, C für ein Zeichenformat und X für ein Querverweisformat. In der zweiten Spalte steht der Name eines HTML-Elements oder der Name eines HTML-Konvertierungsmakros.

Die Tabelle "HTML Mapping" auf der Referenzseite "HTML".

Informationen über die Zuordnung von Makros finden Sie unter Arbeiten mit HTML-Konvertierungsmakros.

So bearbeiten Sie eine Zuordnung mithilfe der Tabelle "HTML Mapping":

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die HTML-Seite an.

    2. Suchen Sie in der Tabelle "Mapping" auf dieser Seite das Format, dessen Zuordnung Sie ändern wollen.

    3. Führen Sie bei Bedarf folgende Änderungen aus:

    Geben Sie in der Spalte "Element" den Namen des HTML-Elements oder des Konvertierungsmakros ein, dem das Format zugeordnet werden soll. Wenn Sie den korrekten Namen des HTML-Elements nicht wissen, konsultieren Sie die Tabellen unter Zuordnungen für Listen. Geben Sie H* für die Zuordnung einer Standardebenen-Überschrift ein.

    Geben Sie in der Spalte "New Web Page" entweder Y oder Yes ein, wenn bei jedem Auftreten dieses Formats ein separates HTML-Dokument angelegt werden soll. Andernfalls geben Sie N oder No ein.

    Geben Sie in der Spalte "Include Auto# column" entweder Y oder Yes ein, wenn der vollständige Text für die automatische Nummerierung dieses Formats in die Konvertierung aufgenommen werden soll. Andernfalls geben Sie N oder No ein.

    Geben Sie in der Spalte "Comments" einen Text ein, der den Zweck der Zuordnung oder Sonderfälle usw. erläutert. Sie können diese Spalte aber auch leer lassen.

Eine bearbeitete Reihe könnte wie folgt aussehen:

FrameMaker Source Item | HTML Element | New Web Page? | Include Auto#? | Kommentare
P:Fußnote | FOOTNOTE | N | N | Funktioniert eventuell nicht in allen Browsern


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Arbeiten mit HTML-Konvertierungsmakros

Für die Definition von HTML-Konvertierungsmakros stehen Ihnen auf der Referenzseite "HTML" folgende Tabellen zur Verfügung:

    Die Tabelle "HTML System Macros" mit acht vordefinierten Makronamen, die Sie zur Ausführung von speziellen Funktionen am Beginn oder am Ende von Webseiten verwenden können.

    Die Tabelle "HTML Cross-Reference Macros", die Ersetzungstext für FrameMaker-Querverweise enthält.

    Die Tabelle "HTML General Macros", die von Ihnen definierte Makros für allgemeine Zwecke enthält (z. B. den Titel des konvertierten Dokuments).

Hinweis: Die HTML-Systemmakros und die allgemeinen Makros können Sie nicht im Dialogfenster "HTML-Einstellungen" ändern.

Sobald ein Makro definiert ist, können Sie es über seinen Namen in anderen Makros aufrufen oder es in der Tabelle "HTML Mapping" für eine Zuordnung verwenden. Der Name des Makros wird im Aufklappmenü "Nach" des Dialogfensters "HTML-Einstellungen" angezeigt, sodass Sie ihm ein Format zuordnen können, ohne die Zuordnungstabelle direkt bearbeiten zu müssen.

Beispiele für HTML-Konvertierungsmakros finden Sie auf den Referenzseiten der Schablonen, die mit FrameMaker geliefert werden.

Beispiele für Konvertierungsmakros

So erstellen oder bearbeiten Sie ein HTML-Konvertierungsmakro:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die HTML-Seite an.

    2. Bearbeiten Sie ein Makro in der Tabelle, oder erzeugen Sie eine neue Zeile (durch Drücken von Strg+Eingabetaste) und geben Sie beginnend mit einem Makronamen ein neues Makro ein. (Sie können in die Tabelle "HTML System Macros" keine Makros einfügen, sondern nur ihren Ersetzungstext bearbeiten.)

Der Ersetzungstext kann eine Kombination aus Text, HTML-Codes und FrameMaker-Bausteinen enthalten. Weitere Informationen finden Sie unter Bausteine in HTML-Konvertierungsmakros. Achten Sie darauf, dass Sie gültigen HTML-Code eingeben, da FrameMaker die HTML-Syntax nicht überprüft.


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Arbeiten mit HTML-Konvertierungsmakros

Bausteine in HTML-Konvertierungsmakros

In HTML-Konvertierungsmakros können Sie die folgenden Bausteine verwenden, um spezielle Texttypen einzubeziehen:

Baustein | Beschreibung
<$AbsText> <$AbsTyp> <$AbsNum> <$AbsNumExkl> | Einzelheiten finden Sie unter Verwenden von Bausteinen für Quellinformationen und Verwenden von Bausteinen für Zeichenformate.
<$Variable[VarName]> | Enthält den Text der Variablen.
<$defaulttitle> | Enthält den Text der ersten Überschrift im aktuellen Dokument.
<$nextsubdoc> | Enthält die URL des nächsten untergeordneten HTML-Dokuments.
<$prevsubdoc> | Enthält die URL des vorhergehenden untergeordneten HTML-Dokuments.
<$parentdoc> | Enthält die URL des übergeordneten HTML-Dokuments.

Bausteine werden in spitzen Klammern (< >) angegeben und beginnen mit einem Dollarzeichen ($). Geben Sie die Bausteine in Kleinbuchstaben ein.

Hinweis: In der Tabelle "General Macros" gibt es eine Spalte, die mit "Head" überschrieben ist. Mithilfe dieser Spalte können Sie einen Titel definieren (siehe Anpassen von Titeln) oder spezielle, komplexere Informationen über das HTML-Dokument einfügen (beispielsweise die Schlüsselwörter, die eine Suchmaschine verwendet). Um diese Spalte ausfüllen zu können, müssen Sie wissen, welche HTML-Elemente im Abschnitt HEAD eines HTML-Dokuments zulässig sind.


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Arbeiten mit HTML-Konvertierungsmakros

Umdefinieren von HTML-Systemmakros

HTML-Systemmakros stellen einen Sonderfall dar, weil Sie diese Makros zwar umdefinieren, aber keine neuen Makros hinzufügen können.

Diese Makros sind vor allem hilfreich, wenn Sie Dokumente in separate HTML-Dateien aufgliedern. Beispielsweise können Sie das Makro "StartOfSubDoc" so definieren, dass am Beginn jeder Webseite Ihr Firmenlogo angezeigt wird.

In den folgenden Beschreibungen bezieht sich die Bezeichnung übergeordnetes Dokument auf die erste Webseite, wobei sich untergeordnetes Dokument auf ein Dokument bezieht, das mit dem übergeordneten Dokument verknüpft ist.

Systemmakro | Verwenden
StartOfDoc | Fügt Text am Anfang der obersten Webseite ein.
EndOfDoc | Fügt Text am Ende der obersten Webseite ein.
StartOfSubDoc | Fügt Text am Anfang jedes untergeordneten Dokuments ein, mit Ausnahme des ersten und letzten Dokuments.
EndOfSubDoc | Fügt Text am Ende jedes untergeordneten Dokuments ein, mit Ausnahme des ersten und letzten Dokuments.
StartOfFirstSubDoc | Fügt den Text nur am Anfang des ersten untergeordneten Dokuments ein.
EndOfFirstSubDoc | Fügt den Ersetzungstext nur am Ende des ersten untergeordneten Dokuments ein.
StartOfLastSubDoc | Fügt den Ersetzungstext nur am Anfang des letzten untergeordneten Dokuments ein.
EndOfLastSubDoc | Fügt den Ersetzungstext nur am Ende des letzten untergeordneten Dokuments ein.


HTML-, XML- und Adobe PDF-Konvertierung / HTML / Arbeiten mit HTML-Konvertierungsmakros

Konvertieren von Sonderzeichen

FrameMaker und HTML (bzw. das Web) verwenden unterschiedliche Zeichensätze. Deshalb werden einige Zeichen bei der Konvertierung in das HTML-Format als Ersetzungen definiert. Einige Formatdefinitionen sind intern und beziehen sich auf spezielle HTML-Codes, die sogenannten Entities. (Beispielsweise werden typografische Anführungszeichen in die Entity für gerade Anführungszeichen geändert.) Weitere Ersetzungen sind in der Tabelle "Character Macros" definiert. Zum Beispiel wird ein m-Bindestrich als zwei Gedankenstriche definiert. Wenn keine Zuordnung existiert, wird das Zeichen ignoriert.

Die folgenden Zeichen verfügen entweder über spezielle, vordefinierte Zuordnungen oder sie werden auf besondere Art behandelt.

Zeichen | Standardzuordnung | Definiert in
… (Auslassung) | ... (drei Punkte) | Tabelle "Character Macros"
(m-Bindestrich) | -- (zwei Bindestriche) | Tabelle "Character Macros"
(n-Bindestrich) | - (ein Bindestrich) | Tabelle "Character Macros"
¢ (Cent) | &#162; (HTML-Zeichenreferenz) | Tabelle "Character Macros"
© (Copyright) | &#169; (HTML-Zeichenreferenz) | Tabelle "Character Macros"
® (registriert) | &#174; (HTML-Zeichenreferenz) | Tabelle "Character Macros"
? (Grad-Symbol) | &#176; (HTML-Zeichenreferenz) | Tabelle "Character Macros"
< und > (spitze Klammern) | &lt; und &gt; (HTML-Entities) | Intern
und [image] (typografische Anführungszeichen) | &quot; (HTML-Entity für ") | Intern
& (kaufm. Und) | &amp; (HTML-Entity) | Intern

Sie können Zuordnungen für Zeichen hinzufügen oder ändern, indem Sie Einträge in die Tabelle "Character Macros" einfügen oder dort bearbeiten. Wie die vorhergehende Tabelle zeigt, können Zeichen sowohl Text als auch HTML-Zeichen oder -Entities (diese beginnen mit einem kaufmännischen Und und enden mit einem Strichpunkt) zugeordnet werden.

So fügen Sie eine Zuordnung für ein Sonderzeichen ein oder ändern sie:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Tabelle "Character Macros" auf der HTML-Seite an.

    2. Bearbeiten Sie eine Zuordnung oder erzeugen Sie eine neue Zeile (durch Drücken von Strg+Eingabetaste) und geben Sie eine neue Zuordnung ein.

Wenn Sie bei einem Sonderzeichen nicht genau wissen, wie Sie es in der ersten Spalte eingeben sollen, schlagen Sie den entsprechenden Tastaturbefehl nach.

Um beispielsweise eine Zuordnung für das Kreuzsymbol, das Markenzeichen-Symbol und die ae-Ligatur festzulegen, fügen Sie folgende Zeilen ein:

Zeichen | Ersetzen durch | Kommentare
 | * | Kreuzsymbol
 | (tm) | Warenzeichen-Symbol
æ | &aelig; | ae ist der HTML-Entity-Referenz für dieses Symbol zugeordnet


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Festlegen der Grafikkonvertierung

Beim Speichern von Dokumenten im HTML-Format werden alle Grafikdateien, die durch Kopieren in verankerte Rahmen importiert wurden, in das GIF-Format konvertiert. Sie können aber auch festlegen, dass alle Grafiken in einem anderen Format gespeichert werden. Jede Grafik wird in einer separaten Datei gespeichert. Text in verankerten Rahmen wird ebenfalls in das GIF-Format konvertiert.

Durch Referenz importierte Grafikdateien bleiben an ihren ursprünglichen Positionen. Sie können jedoch angeben, dass Kopien angelegt werden. In diesem Fall werden die Formate überprüft und entsprechend konvertiert, wobei die dpi-Auflösung einer Grafik erhalten bleibt. Die neuen Dateien werden in demselben Verzeichnis erstellt, in dem sich das HTML-Dokument befindet.

So geben Sie das Dateiformat für konvertierte Grafiken an:

    1. Wählen Sie "Datei > Dienstprogramme > HTML-Einstellungen" und klicken Sie auf "Optionen".

    2. Geben Sie das gewünschte Format für die Grafikdatei an. Sie können unter folgenden Formaten wählen:

    Das GIF-Format eignet sich am besten für Bilder, die keine Fotographien sind und nicht mehr als 256 Farben verwenden.

    Das JPEG-Format eignet sich für Bilder mit einem großen Farbbereich, wie z. B. eine 24-Bit-Fotografie.

    Das PNG-Format ist ein Public-Domain-Format, das immer mehr Verwendung im Web findet. Ähnlich wie das GIF-Format eignet sich PNG für Bilder mit bis zu 256 Farben.

    3. Klicken Sie auf "OK".

So geben Sie an, dass durch Referenz importierte Grafiken kopiert und konvertiert werden sollen:

    1. Wählen Sie "Datei > Dienstprogramme > HTML-Einstellungen" und klicken Sie auf "Optionen".

    2. Wählen Sie "Durch Referenz importierte Dateien kopieren".


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Anpassen von Titeln

Der Titel eines HTML-Dokuments wird in der Titelleiste des Fensters angezeigt. Wenn Sie ein Lesezeichen auf der Seite einfügen, wird es in die Liste der Lesezeichen aufgenommen. Zunächst wird mithilfe des Bausteins <$defaulttitle> die erste Überschrift einer HTML-Datei der Datei als Titel zugewiesen. Normalerweise sind diese Standardtitel ausreichend. Sie können einer Datei aber auch einen anderen Titel zuweisen, indem Sie die Makrotabellen auf der HTML-Referenzseite bearbeiten.

Systemmakros und allgemeine Makros können zwei Gruppen von Ersetzungstext definieren. Eine Gruppe erscheint im Haupttext des Codes, die andere im Kopfbereich.

Sie können den Standardtitel ändern, entfernen oder einen neuen Titel angeben.

So ändern Sie die Standardtitel:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite "HTML" an.

    2. Suchen Sie in der Tabelle "HTML System Macros" die vier Systemmakros, die die Standardtitel anlegen. Zunächst verwenden die Makros den Baustein <$defaulttitle>, um die erste Überschrift einer Datei als Dateititel einzusetzen. Sie können einzelne oder alle Titel ändern.

    Makroname | Ersetzen durch | Head | Kommentare
StartOfDoc |  | <TITLE><$defaulttitle></TITLE> |

    3. Ändern Sie das Standardmakro für "HEAD". Das folgende Makro ändert zum Beispiel den Text des Titels in statischen Text.

    Makroname | Ersetzen durch | Head | Kommentare
StartOfDoc |  | <TITLE> Mein Buch</TITLE> |

So legen Sie eigene Titel fest:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite "HTML" an.

    2. Entfernen Sie die vier Ersetzungstexte für die Standardtitel aus der Tabelle "HTML System Macros".

    3. Definieren Sie in der HTML-Tabelle "General Macros" ein Makro, das das HTML-Element <TITLE> in der dritten Spalte "Replace With (in HEAD)" einsetzt. Das folgende Makro verwendet zum Beispiel die automatische Nummerierung und den Text eines Absatzes für den Titel und den Absatztext im Dokument.

    Makroname | Ersetzen durch | Head | Kommentare
MeinTitel | <P><$AbsNum><$AbsText></P> | <TITLE><$AbsNum><$AbsText></TITLE> |

    4. Ordnen Sie das Makro dem Format zu, auf dessen Grundlage Sie das HTML-Dokument aufgliedern wollen. Weitere Informationen finden Sie unter Anpassen von HTML-Zuordnungen.


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Konvertieren von Büchern in HTML-Dateien

Beim Speichern eines Buches im HTML-Format führen Sie dieselben Arbeitsschritte wie beim Speichern eines einzelnen Dokuments im HTML-Format aus. Weitere Informationen finden Sie unter Speichern von Dokumenten im HTML-Format. Wenn FrameMaker die Dateien im Buch zuordnet, werden die Zuordnungen auf Referenzseiten gespeichert, die der ersten Datei im Buch hinzugefügt werden. Sie können die Tabellen auf der Referenzseite genau so bearbeiten wie die Tabellen auf den Referenzseiten eines einzelnen Dokuments.

Die Dateien in einem Buch bleiben möglicherweise nicht als separate Dateien erhalten, wenn sie im HTML-Format gespeichert werden. Um ein Buch in einzelne HTML-Dateien aufzuteilen, verwenden Sie die Option "Neue Webseite mit Verknüpfung". Informationen darüber, wie Sie mit dieser Einstellung ein Inhaltsverzeichnis simulieren können, finden Sie unter Erstellen von Verknüpfungen, die ein Inhaltsverzeichnis simulieren.

So speichern Sie ein Buch im HTML-Format:

    1. Öffnen Sie die Buchdatei und wählen Sie "Datei > Buch sichern unter".

    2. Wählen Sie "HTML" aus dem Aufklappmenü.

    3. Fügen Sie dem Dateinamen die Erweiterung ".html" hinzu und klicken Sie auf "Sichern". Die konvertierten Dateien des Buches werden in dem von Ihnen angegebenen Verzeichnis gespeichert.

    4. Öffnen Sie die konvertierten Dateien zur Überprüfung in einem Web-Browser. Wenn die Dateien Ihren Vorstellungen entsprechen, ist Ihre Arbeit beendet.

    5. Wenn Sie die eine oder andere Zuordnung neu festlegen wollen, öffnen Sie die erste Datei im Buch und zeigen Sie die Referenzseite "BookHeadings" oder "BookHTML" an. Bearbeiten Sie die entsprechenden Tabellen auf diesen Seiten. Weitere Informationen finden Sie unter Feinabstimmung von Zuordnungen durch Bearbeiten von Referenzseiten. Speichern Sie danach die Datei und die Buchdatei erneut im HTML-Format.

Wenn Sie für die Zuordnungen eines Dokuments eine Feinabstimmung durchgeführt haben und Sie diese für das gesamte Buch verwenden wollen, entfernen Sie die Tabellen auf den Referenzseiten "BookHeadings" und "BookHTML" in der ersten Datei der Buchdatei. Danach kopieren Sie die Referenzseiten "Headings" und "HTML" des Dokuments und fügen Sie sie auf den Referenzseiten "BookHeadings" und "BookHTML" ein.


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Erstellen von Verknüpfungen, die ein Inhaltsverzeichnis simulieren

Sie können eine große Datei in eine Reihe von kleinen, untergeordneten HTML-Dateien konvertieren, die alle mit einem übergeordneten Dokument verknüpft sind. Das übergeordnete Dokument fungiert dabei als verknüpftes Inhaltsverzeichnis für die untergeordneten Dokumente.

FrameMaker-Dokument und das simulierte Inhaltsverzeichnis auf einer Webseite

Die untergeordneten Dokumente erhalten automatisch aufsteigend nummerierte Namen. Wenn Sie beispielsweise MeinDok im HTML-Format speichern, erhält das übergeordnete Dokument den Namen "MeinDok.html", das erste untergeordnete Dokument heißt "MeinDok.1.html", das zweite "MeinDok.2.html" usw. Benennen Sie die Dateien nicht um, da sonst die Verknüpfungen ungültig werden.

Die Hierarchie der Überschriftsebenen in den untergeordneten Dokumenten wird durch die Headings-Tabelle gesteuert.

So simulieren Sie ein Inhaltsverzeichnis:

    1. Passen Sie die Zuordnungen des Dokuments so an, dass jede neue Datei mit einer Überschrift beginnt. Verwenden Sie dazu im Dialogfenster "HTML-Einstellungen" die Option "Neue Webseite mit Verknüpfung". Weitere Informationen finden Sie unter Anpassen von HTML-Zuordnungen.

Hinweis: Suchen Sie nach einer Überschrift, deren Inhalt weder zu lang noch zu kurz ist. (Leser können den Überblick verlieren, wenn sie zuviel blättern müssen, oder sie ärgern sich, wenn die aufgerufene Seite nur einen Absatz enthält.) Sie können auch vor der ersten Überschrift Text einblenden und so eine Einleitung für die Liste der Verknüpfungen zur Verfügung stellen.

    2. Ermöglichen Sie den Lesern eine einfache Rückkehr von untergeordneten Dokumenten zum übergeordneten Dokument. Definieren Sie dazu entweder das Systemmakro "EndOfSubDoc" oder "StartOfSubDoc". Der vom Makro definierte Text oder die definierte Grafik wird wie im folgenden Beispiel entweder am Ende oder am Beginn jeder verknüpften Webseite angezeigt.

    Makroname | Ersetzen durch
EndOfSubDoc | <HR><P><A HREF="<$parentdoc>" > Zurück zur ersten Seite</A></P> <P><A HREF="<$prevsubdoc>" > Zur vorhergehenden Seite</A></P> <P><A HREF="<$nextsubdoc>" > Zur nächsten Seite</A></P>

    3. Speichern Sie die Datei oder das Buch im HTML-Format. Das übergeordnete Dokument enthält das verknüpfte Inhaltsverzeichnis.


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Einfügen von HTML-Code

Eventuell möchten Sie speziellen HTML-Code in Ihr Dokument einfügen (z. B. Code, der ein Java-Applet definiert).

So fügen Sie HTML-Code in ein Dokument ein:

    1. Wählen Sie "Darstellung > Referenzseiten" und zeigen Sie die Referenzseite "HTML" an.

    2. Definieren Sie in der HTML-Tabelle "General Macros" ein Makro, das den HTML-Code enthält.

    3. Wählen Sie "Darstellung > Arbeitsseiten" und platzieren Sie die Einfügemarke an der Position, an der der HTML-Code eingefügt werden soll.

    4. Wählen Sie "Spezial > Marke". Wählen Sie dann "HTML-Makro" als Markentyp aus.

    5. Geben Sie den Namen des Makros als Markentext ein und klicken Sie auf "Neue Marke".

Sie können z. B. den folgenden Java-Code als Makrodefinition eingeben:

Makroname | Ersetzen durch
MeinCode | <applet code="Bullets.class" width="600" height="6" codebase="classes/bullets/" > <param name="bgColor" value="White"> </applet>

Platzieren Sie an der Position, an der Sie dieses Applet einfügen wollen, eine Marke mit dem Markentyp "HTML-Makro" und dem Markentext "MeinCode".


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Fehlerbehebung und Tipps zur HTML-Konvertierung

Beachten Sie die folgenden Richtlinien, um eine problemlose Konvertierung in das HTML-Format sicherzustellen.

    Öffnen Sie bei der Konvertierung eines Buches zuerst alle Dokumente. So vermeiden Sie Fehlermeldungen, die den Konvertierungsprozess unterbrechen könnten.

    Stellen Sie sicher, dass in den verwendeten Tabellenformaten zumindest für eine Standardreihe eine reguläre Lineatur definiert ist. Andernfalls werden in den HTML-Tabellen keine Linien um die Tabellenzellen angezeigt.

    Stellen Sie vor der Konvertierung sicher, dass die Dokumente keine ungelösten Verknüpfungen enthalten. Ungelöste Querverweise erscheinen im HTML-Format als unterbrochene Verknüpfungen. Informationen über das Auflösen von Querverweisen finden Sie unter Auflösen von Querverweisen.

    Wenn Text oder Grafiken nicht korrekt konvertiert werden, stellen Sie sicher, dass sich die Objekte auf Arbeitsseiten und nicht auf Vorgabeseiten befinden, dass sie Teil des Haupttextflusses (A) sind und dass sie sich in verankerten Rahmen befinden.

    Wenn Sie HTML-Konvertierungseinstellungen von einem Dokument in ein anderes importieren wollen, verwenden Sie den Befehl "Datei > Importieren > Formate", um die Referenzseiten zu kopieren. Informationen über das Importieren von Referenzseiten finden Sie unter Importieren und Aktualisieren von Formaten.


HTML-, XML- und Adobe PDF-Konvertierung / HTML

Speichern von strukturierten Dokumenten im HTML-Format

Das Verfahren zum Speichern von strukturierten Dokumenten im HTML-Format entspricht dem Speichern unstrukturierter Dokumente, mit Ausnahme der Zuordnungen. In strukturierten Dokumenten basieren die Zuordnungen auf Elementen und Attributen und nicht auf Zeichen-, Absatz- oder Querverweisformaten. Strukturierte FrameMaker-Elemente werden HTML-Elementen zugeordnet, um Formate für Container zu definieren. Strukturierte FrameMaker-Attribute werden HTML-Attributen zugeordnet, um z. B. Querverweise, Stilvorlagen, Sprachen und Alternativtext für Bilder zu definieren.


HTML-, XML- und Adobe PDF-Konvertierung

Überblick über Adobe PDF

Sie können ein FrameMaker-Dokument oder -Buch in eine Adobe PDF-Datei konvertieren und in diesem Format verteilen. Die Leser können diese Datei mit Acrobat, Acrobat Reader oder einer anderen Anwendung, die PDF-Dateien unterstützt, anzeigen.

Wichtig: Verwenden Sie zur Anzeige von konvertierten Dateien die Version 7.0.7 oder höher von Acrobat oder Reader.

FrameMaker-Dokument vor und nach der Adobe PDF-Konvertierung

Wenn Sie ein FrameMaker-Dokument im Adobe PDF-Format speichern, werden folgende Änderungen ausgeführt:

    Querverweise und Hypertext-Befehle werden in der PDF-Datei zu Verknüpfungen.

    Elemente, die Sie im Dialogfenster "PDF-Einstellungen" angeben, werden zu Lesezeichen in der PDF-Datei.

    Hypertext-Warnmeldungen werden in der PDF-Datei zu Notizen

    Hypertext-URL-Meldungen werden in der PDF-Datei zu Web-Verknüpfungen (siehe Einrichten von Verknüpfungen zu URLs).

    Einige Hypertext-Befehle werden in entsprechende HTML-Verknüpfungen konvertiert. Weitere Informationen finden Sie unter Hypertext-Befehle in HTML- und PDF-Dokumenten.

    Absätze, die Sie im Bereich "Lesezeichen" des Dialogfensters "Acrobat-Einstellungen" angeben, werden in der PDF-Datei zu Lesezeichen. In strukturierten Dokumenten werden Strukturelemente zu Lesezeichen. Weitere Informationen finden Sie unter Speichern von strukturierten Dokumenten im Adobe PDF-Format.

    Textflüsse auf Arbeitsseiten können in PDF-Dateien zu Artikelflüssen werden.

    Die PDF-Datei enthält Tagged PDF-Informationen, wenn Sie "Tagged PDF erstellen" aktivieren. Weitere Informationen finden Sie unter Definieren einer Tagged Adobe PDF-Datei.

    Die PDF-Datei kann Dokumentinformationen enthalten, z. B. den Namen des Autors und Schlüsselwörter. Weitere Informationen finden Sie unter Hinzufügen von Metadaten zu einem Dokument.


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF

Speichern von Dokumenten und Büchern als Adobe PDF

Sie konvertieren ein FrameMaker-Dokument in das PDF-Format, indem Sie Optionen im Dialogfenster "PDF-Einstellungen" festlegen und das Dokument im PDF-Format speichern. Sie können auch eine PostScript-Datei erstellen und diese Datei konvertieren. Informationen zum Erstellen von PostScript-Dateien finden Sie unter Erstellen von PostScript-Dateien.

  • WindowsStellen Sie sicher, dass die Druckerinstanz Adobe PDF Creation Add-On installiert ist.

  • Solaris Stellen Sie sicher, dass die Druckerinstanz Normalizer 8 installiert ist.

Alternativ können Sie "Datei > Als PDF speichern" wählen.

So speichern Sie ein Dokument oder ein Buch als Adobe PDF-Datei:

    1. Öffnen Sie das Dokument oder Buch, das Sie im PDF-Format sichern wollen.

    2. Wenn Querverweise zu FrameMaker-Dokumenten in anderen Büchern vorhanden sind, öffnen Sie auch diese Buchdateien. Damit stellen Sie sicher, dass die Verknüpfungen funktionieren, wenn alle Buchdateien konvertiert werden.

    3. Führen Sie im Originaldokument oder in der Originalbuchdatei eine der folgenden Aktionen aus:

    Wählen Sie "Datei > Als PDF speichern". Klicken Sie im Dialogfenster "Dokument speichern" auf "Sichern".

    Wählen Sie "Datei > Sichern unter" (oder "Datei >Buch sichern unter"). Wählen Sie anschließend "PDF" aus dem Aufklappmenü. Ersetzen Sie die Dateinamenerweiterung durch ".pdf". Sie können auch den Speicherort und den Dateinamen ändern. Klicken Sie anschließend auf "Sichern".

    4. Klicken Sie im Dialogfenster "PDF-Einstellungen" auf "Zuweisen", um eine PDF-Datei mit den Standardeinstellungen zu erstellen. Andernfalls nehmen Sie die erforderlichen Änderungen vor und klicken Sie anschließend auf "Zuweisen".

So speichern Sie eine Gruppe von miteinander verknüpften Büchern im PDF-Format:

    1. Öffnen Sie alle Bücher, die Sie in das PDF-Format konvertieren möchten. Damit stellen Sie sicher, dass die Verknüpfungen funktionieren, wenn alle Buchdateien konvertiert werden.

    2. Führen Sie in der ersten Buchdatei eine der folgenden Aktionen aus:

    Wählen Sie "Datei > Als PDF speichern". Klicken Sie im Dialogfenster "Dokument speichern" auf "Sichern".

    Wählen Sie "Datei > Buch sichern unter" aus und wählen Sie dann "PDF" aus dem Aufklappmenü. Ersetzen Sie die Dateinamenerweiterung durch ".pdf". Sie können auch den Speicherort ändern, achten Sie jedoch darauf, dass die relative Verschachtelung der konvertierten PDF-Dateien genau so wie in den Originaldateien erhalten bleibt. Klicken Sie anschließend auf "Sichern".

    3. Richten Sie die Lesezeichen und den Artikelfluss ein.

    4. Wiederholen Sie die Schritte für die anderen verknüpften Bücher.

Die Optionen im Dialogfenster "PDF-Einstellungen" sind in vier Kategorien unterteilt: Einstellungen, Lesezeichen, Typen und Verknüpfungen.


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF / Speichern von Dokumenten und Büchern als Adobe PDF

Allgemeine Einstellungen

Verwenden Sie die allgemeinen Einstellungen, um Optionen wie Seitengröße, Registermarken und Farbenumwandlung zu definieren.

So nehmen Sie die allgemeinen Einstellungen vor:

    1. Wählen Sie im Dialogfenster "PDF-Einstellungen" den Eintrag "Einstellungen" aus dem Aufklappmenü, oder klicken Sie auf die Registerkarte "Einstellungen" (Windows/UNIX).

    2. Wählen Sie eine Option zum Erstellen von Adobe PDF-Dateien aus dem Aufklappmenü "PDF-Auftragsoptionen". Die Optionen enthalten vordefinierte Einstellungen und einige benutzerdefinierte Optionen, die Sie mit Adobe PDF Creation Add-On (Windows) oder Normalizer 8 (UNIX) erstellt haben. Informationen über die vordefinierten Einstellungen finden Sie unter Auftragsoptionen.

In einem Buch werden die Auftragsoptionen, die mit der ersten Datei gespeichert werden, auf alle Dateien eines Buches angewendet. Um die gewünschten Resultate zu erzielen, öffnen Sie die erste Datei und wählen Sie "Format > Dokument > PDF-Einstellungen". Nehmen Sie die Einstellungen vor und klicken Sie auf "Zuweisen".

    3. Geben Sie an, mit welcher Zahl die Seitennummerierung beginnen soll, und wählen Sie einen Zoom-Faktor.

    4. Wählen Sie eine Option aus dem Aufklappmenü "Registermarken". Sie können zwischen "Normal" und "Tombo" (japanischen Schneidemarken) wählen.

    5. Legen Sie eine Vorgabe für die Seitengröße fest. (FrameMaker verwendet die Maßeinheiten, die unter "Darstellung > Optionen" festgelegt wurden.)

    6. Geben Sie die Seiten an, die in das Adobe PDF-Format konvertiert werden sollen. Sie können alle Seiten der Datei konvertieren oder Seitenzahlen eingeben, die nur einen Bereich der Datei umfassen. Das Textfeld "Bis Seite" können Sie frei lassen, um einen Bereich von Seiten festzulegen, der mit der Seitenzahl beginnt, die Sie in das Textfeld "Von Seite" eingegeben haben, und der sich bis zum Ende der Datei erstreckt.

Hinweis: Um sicherzugehen, dass die exportierte PDF-Datei Lesezeichen, Tags und Hypertext-Verknüpfungen enthält, sollten Sie alle Seiten für den Seitenbereich auswählen.

    7. (UNIX) Standardmäßig konvertiert FrameMaker beim Drucken und Erstellen von PDF-Dateien CMYK-Farben in RGB. Führen Sie einen der folgenden Schritte aus, um die Farbkonvertierung zu steuern:

    Um CMYK-Farben in RGB zu konvertieren, wählen Sie die gleichnamige Option. Wenn die von Ihnen verwendete Bibliothek RGB-Entsprechungen zu CMYK-Farben bereitstellt, werden diese Werte bei der Konvertierung verwendet. Wenn keine äquivalenten Werte verfügbar sind, berechnet FrameMaker die RGB-Werte. Sie können diese Einstellungen auch mit den PDF-Auftragsoptionen in Acrobat Distiller steuern. In jedem Fall haben die Angaben im Dialogfenster "PDF-Einstellungen" Vorrang vor den Einstellungen in den PDF-Auftragsoptionen.

    Um CMYK-Farben in sRGB, CalRGB oder einen anderen RGB-Typ zu konvertieren, wählen Sie nicht die Option im Dialogfenster, sondern legen die entsprechenden Werte in der Acrobat Distiller-Datei für die PDF-Auftragsoptionen fest. Wenn Sie die Auswahl dieser Option aufheben, können Sie Standardkonvertierungen von CMYK-Farben in RGB überschreiben, sodass FrameMaker die CMYK-Farben beibehalten kann. Dies führt möglicherweise zu einer besseren Druckqualität.

Hinweis: Diese Option ist in FrameMaker für Windows nicht verfügbar, da CMYK-Farben unter Windows immer in berechnete RGB-Werte konvertiert werden.


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF / Speichern von Dokumenten und Büchern als Adobe PDF

Einrichten von Lesezeichen

Verwenden Sie die Optionen für Lesezeichen, um Lesezeichenebenen zu definieren, Lesezeichen aus den Absatztypen zu erstellen und den Artikelfluss einzurichten.

So erstellen Sie Lesezeichen:

    1. Wählen Sie im Dialogfenster "PDF-Einstellungen" den Eintrag "Lesezeichen" aus dem Aufklappmenü oder klicken Sie auf die Registerkarte "Lesezeichen" (Windows/UNIX).

    2. Wählen Sie die Option "PDF-Lesezeichen generieren".

    3. Um festzulegen, in welcher Ebene die Lesezeichen in der PDF-Datei erscheinen, wählen Sie eine Option aus dem Aufklappmenü "Lesezeichen erweitert durch Ebene". Sie können einen Wert, wie z. B. 2, eingeben. Damit legen Sie fest, dass nur die ersten zwei Ebenen erweitert werden.

    4. Um die Absätze anzugeben, die in PDF-Lesezeichen konvertiert werden sollen, verschieben Sie Absatztypen zwischen den Auswahllisten. Die Absätze in der Auswahlliste "Übernahme der Absätze" erhalten Lesezeichen in der PDF-Datei. Um einen Typ von einer Auswahlliste in eine andere zu verschieben, wählen Sie den Typ aus und klicken Sie auf den entsprechenden Pfeil. Sie können auch auf den Typ doppelklicken. Wenn Sie alle Typen von einer Liste in die andere verschieben wollen, halten Sie die Umschalttaste gedrückt und klicken Sie auf einen Pfeil. Um Lesezeichen zu unterdrücken, deaktivieren Sie "PDF-Lesezeichen generieren".

    5. Wenn Sie die Lesezeichenebenen für die Absätze ändern wollen, wählen Sie einen Absatztyp aus und klicken Sie auf einen der Pfeile neben "Lesezeichenebene". Um die Ebene aller Elemente zu ändern, halten Sie die Umschalttaste gedrückt und klicken Sie auf einen dieser Pfeile. Erstreckt sich die Einrückung für einen Typ über mehr als sechs Ebenen, steht ein n> vor dem Absatztyp, wobei n die Einrückungsebene des Typs angibt.

    6. Wenn Absatztypen mit dem Absatztext in die Lesezeichen eingefügt werden sollen, wählen Sie "Übernahme der Absatztypen in Lesezeichentext". Verwenden Sie diese Option, um die zugewiesenen Lesezeichenebenen in einem Entwurf der PDF-Datei zu kontrollieren. (Deaktivieren Sie diese Option, wenn Sie den endgültigen Entwurf des Dokuments ausdrucken.)

    7. Richten Sie den Artikelfluss ein, indem Sie folgende Aktionen ausführen:

    Damit jeder Artikel in der Reihenfolge gelesen wird, in der sich die Einfügemarke bewegt, wählen Sie zuerst "Artikel" und dann "Bahn durch Spalte" aus dem Aufklappmenü. Diese Einstellung ist in der Regel in mehrspaltigen Formaten besonders vorteilhaft.

    Wenn die Reihenfolge, in der die Artikel gelesen werden, von Textrahmen zu Textrahmen führen soll, wählen Sie "Artikel" und "Bahn durch Textrahmen" aus dem Aufklappmenü. Diese Einstellung ist in der Regel in einspaltigen Formaten besonders vorteilhaft.

    Sollen keine Artikelflüsse angelegt werden, deaktivieren Sie "Artikel".

Informationen über das Erstellen von PDF-Lesezeichen aus strukturierten Dokumenten finden Sie unter Speichern von strukturierten Dokumenten im Adobe PDF-Format.


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF / Speichern von Dokumenten und Büchern als Adobe PDF

Erzeugen einer Tagged Adobe PDF-Datei

Mit FrameMaker können Sie Adobe PDF-Dateien mit einer logischen Dokumentstruktur und umfangreichen Metadaten für zweckgerichtete Inhalte erstellen. Weitere Informationen zu Tagged PDF finden Sie unter Tagged Adobe PDF.

So erzeugen Sie eine Tagged PDF-Datei:

    1. Wählen Sie im Dialogfenster "PDF-Einstellungen" den Eintrag "Typen" aus dem Aufklappmenü, oder klicken Sie auf die Registerkarte "Typen" (Windows/UNIX).

    2. Wählen Sie "PDF mit Tags erzeugen". Weitere Informationen finden Sie unter Definieren einer Tagged Adobe PDF-Datei.


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF / Speichern von Dokumenten und Büchern als Adobe PDF

Hinzufügen von Verknüpfungen aus anderen Dokumenten

Wenn Sie ein Dokument als PDF-Datei speichern, können Sie benannte Ziele verwenden, um Absätze zu identifizieren, auf die über Querverweise und Hypertext-Verknüpfungen verwiesen wird. Wenn Sie einem Dokument nach dem Export PDF-Verknüpfungen aus anderen Dokumenten hinzufügen wollen, sollten Sie diese Option aktivieren. Beachten Sie, dass Sie durch Aktivieren dieser Option die PDF-Datei vergrößern.

Falls diese Option deaktiviert ist und Sie eine Verknüpfung oder einen Querverweis aus einem FrameMaker-Dokument in ein anderes einfügen, sollten Sie erneut beide Dokumente im PDF-Format speichern.

Hinweis: Wurde Ihr Dokument in einer früheren FrameMaker-Version (älter als 6.0) erstellt, müssen Sie die PDF-Dateigröße optimieren, um diese Option nutzen zu können. Weitere Informationen finden Sie unter Optimieren von Dateien, die in älteren FrameMaker-Versionen erstellt wurden.

So fügen Sie Verknüpfungen aus anderen Dokumenten nach dem Erstellen einer PDF-Datei ein:

    1. Wählen Sie im Dialogfenster "PDF-Einstellungen" den Eintrag "Verknüpfungen" aus dem Aufklappmenü oder klicken Sie auf die Registerkarte "Verknüpfungen" (Windows/UNIX).

    2. Aktivieren Sie "Benannte Ziele für alle Absätze erstellen".


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF / Speichern von Dokumenten und Büchern als Adobe PDF

Auftragsoptionen

FrameMaker verwendet die Auftragsoptionen von Adobe PDF Creation Add-On (Windows) bzw. Normalizer 8 (Solaris).

Auftragsoptionen von Adobe PDF Creation Add-On:

    Qualitativ hochwertiger Druck

    PDFA 1b 2005 CMYK

    PDFA1b 2005 RGB

    Druckausgabequalität

    Kleinste Dateigröße

    Standard

Auftragsoptionen von Normalizer 8:

    eBook

    High_Quality

    PDFX1a

    PDFX3

    Press

    Press_Quality

    Print

    Screen

    Smallest_File_Size

    Standard

Hinweis: Wenn Sie ein FrameMaker 7.0-Dokument mit den alten Distiller-Auftragsoptionen öffnen und "Datei > Als PDF sichern" wählen, erhalten Sie möglicherweise eine Warnmeldung, die besagt, dass die angegebene Datei mit den PDF-Auftragsoptionen (Distiller-Auftragsoptionen) nicht vorhanden ist.


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF

Reduzieren der PDF-Dateigröße

Sie können die Dateigröße einer PDF-Datei mit einer Vielzahl von Methoden steuern:

    Deaktivieren Sie die Option "Benannte Ziele für alle Absätze erstellen" auf der Seite "Verknüpfungen" des Dialogfensters "PDF-Einstellungen". Weitere Informationen finden Sie unter Hinzufügen von Verknüpfungen aus anderen Dokumenten.

    Eingebettete Schriftarten, vor allem asiatische Schriften, vergrößern eine PDF-Datei. Um das Einbetten der Schriftarten zu steuern, erstellen oder bearbeiten Sie eine Auftragsoptionsdatei mit Adobe PDF Creation Add-On (Windows) oder Normalizer 8 (Solaris) und wählen diese Datei im Dialogfenster "PDF-Einstellungen" aus. Weitere Informationen finden Sie unter Auftragsoptionen.

    Wenn Sie die Datei nicht wieder in das ursprüngliche Format zurückführen möchten, deaktivieren Sie die Option "Tagged PDF erstellen" auf der Seite "Typen" im Dialogfenster "PDF-Einstellungen". Diese Option ist standardmäßig aktiviert.

    Sie können die Dateigröße auch verringern, indem Sie beim Sichern einer PDF-Datei die Option "Optimieren" wählen.


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF

Optimieren von Dateien, die in älteren FrameMaker-Versionen erstellt wurden

In FrameMaker können Sie benannte Ziele nur für Absätze erstellen, die in Hypertext-Verknüpfungen oder Querverweisen referenziert werden und damit die Dateigröße reduzieren. Dokumente, die in einer früheren FrameMaker-Version als 6.0 erstellt wurden, müssen jedoch umgewandelt werden, um diese Markierungsmethode nutzen zu können.

FrameMaker enthält zwei Optimierungsbefehle: "Optionen" und "Datei optimieren". Mit dem Befehl "Optionen" können Sie die Standard-Optimierungsoptionen ändern, die wirksam bleiben, bis Sie sie ändern, selbst wenn Sie FrameMaker beenden und neu starten. Der Befehl "Datei optimieren" verwendet die Einstellungen aus dem Dialogfenster "Optimierungsoptionen", um Ihre Dokumente für die Reduzierung der PDF-Dateigröße vorzubereiten.

So legen Sie Optimierungsoptionen fest:

    1. Wählen Sie "Format > Dokument > PDF-Größe optimieren > Optionen".

    2. Führen Sie folgende Schritte durch:

    Geben Sie an, ob die Größe aller verknüpften Dokumente (die über Hypertext-Verknüpfungen oder Querverweise des angegebenen Dokuments angesteuert werden) oder nur das angegebene Dokument optimiert werden soll.

    Wenn ein Dokument zuvor optimiert wurde, aktivieren Sie "Optimierung erzwingen", um erneut zu optimieren. Falls diese Option aktiviert ist, aktivieren Sie "Bestehende Optimierungsinfo löschen", um vorherige Optimierungsänderungen zu entfernen.

    Um eine Eingabeaufforderung anzuzeigen, in der Sie gefragt werden, ob Sie verknüpfte Dateien öffnen wollen, aktivieren Sie "Beim Öffnen".

    Um eine Eingabeaufforderung anzuzeigen, in der Sie gefragt werden, ob Sie eine verknüpfte Datei speichern wollen, die zur Optimierung geöffnet wurde, aktivieren Sie "Beim Sichern". Wenn diese Option aktiviert ist, geben Sie an, ob die Eingabeaufforderung für jede Datei gezeigt werden soll, die Sie speichern, oder nur für zuvor optimierte Dateien.

    Geben Sie an, ob Sie bestehende Dateien überschreiben (empfohlen) oder Dateien zu Testzwecken in einem Verzeichnis speichern wollen, das Sie durch Klicken auf "Durchsuchen" angeben.

    Um die Optimierung bei Auftreten eines Fehlers anzuhalten, aktivieren Sie "Abbrechen bei Fehler".

    3. Klicken Sie auf "Zuweisen".

So optimieren Sie Dokumente für die PDF-Dateigröße:

    1. Wählen Sie "Format > Dokument > PDF-Größe optimieren > Datei optimieren".

    2. Wählen Sie das Dokument oder Buch aus, das Sie optimieren möchten, und klicken Sie auf "Auswählen".


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF

Festlegen von PDF-Konvertierungseinstellungen ohne Speichern

Sie können PDF-Konvertierungseinstellungen für ein Dokument angeben, ohne es im PDF-Format zu speichern. Diese Einstellungen können Sie in andere Dokumente vor der Konvertierung importieren.

So legen Sie PDF-Konvertierungseinstellungen fest, ohne im PDF-Format zu speichern:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente oder das Buch aus, je nachdem ob die Dokumentinformationen einzelne Dateien oder das ganze Buch beeinflussen sollen.

    2. Wählen Sie "Format > Dokument > PDF-Einstellungen", legen Sie die Einstellungen fest und klicken Sie auf "Zuweisen".


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF

Importieren von PDF-Konvertierungseinstellungen

Sie können alle Einstellungen des Dialogfensters "PDF-Einstellungen" aus einem Dokument in ein anderes importieren.

So importieren Sie PDF-Konvertierungseinstellungen:

Wählen Sie in einem Dokument oder einem Buch mit ausgewählten Dateien zuerst "Datei > Importieren > Formate" und dann "Dokumenteinstellungen" und "Absatzformate". Informationen über das Importieren von Einstellungen von einem Dokument in ein anderes finden Sie unter Importieren und Aktualisieren von Formaten.


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF

Aktivieren und Deaktivieren der Einbettung von SWF-Dateien in PDF-Dateien

FrameMaker ist standardmäßig für die Einbettung von SWF-Dateien in PDF-Dateien konfiguriert. Wenn Sie eine SWF-Datei in ein Dokument einfügen und eine PDF-Datei erzeugen, wird die SWF-Datei als Bitmap-Bild in das PDF-Dokument eingebettet. Sie können das PDF-Dokument öffnen, das Bild suchen und dann auf das BMP klicken, um die SWF-Datei abzuspielen. Wenn Sie jedoch die Option "Adobe Flash-Datei nicht in PDF einbetten" wählen, enthält das PDF ein inaktives BMP-Bild.

So verhindern Sie die Einbettung von SWF-Dateien in ein PDF-Dokument:

    1. Wählen Sie "Datei > Voreinstellungen > Allgemein".

Das Dialogfenster "Voreinstellungen" wird angezeigt.

    2. Wählen Sie die Option "Adobe Flash-Datei nicht in PDF einbetten" aus.

    3. Klicken Sie auf "Zuweisen".

Hinweis: Wenn Sie ein PDF-Dokument erzeugen möchten, in dem beim Öffnen des Dokuments SWF-Dateien abgespielt werden, müssen Sie sicherstellen, dass die Option "Adobe Flash-Datei nicht in PDF einbetten" nicht aktiviert ist.


HTML-, XML- und Adobe PDF-Konvertierung / Überblick über Adobe PDF

Aktivieren und Deaktivieren der Einbettung von 3D-Objekten in einem PDF-Dokument

FrameMaker ist standardmäßig für die Einbettung von 3D-Objekten in PDF-Dateien konfiguriert. Wenn Sie eine 3D-Datei in ein Dokument einfügen und eine PDF-Datei erzeugen, wird die 3D-Datei als Bitmap-Bild in das PDF-Dokument eingebettet. Sie können das PDF-Dokument öffnen, das Bild suchen und dann auf das BMP klicken, um die 3D-Datei anzuzeigen. Wenn Sie jedoch die Option "3D-Modelldatei nicht in PDF einbetten" wählen, enthält das PDF ein inaktives BMP-Bild.

So verhindern Sie die Einbettung von 3D-Dateien in ein PDF-Dokument:

    1. Wählen Sie "Datei > Voreinstellungen > Allgemein".

Das Dialogfenster "Voreinstellungen" wird angezeigt.

    2. Wählen Sie die Option "3D-Modelldatei nicht in PDF einbetten" aus.

    3. Klicken Sie auf "Zuweisen".

Hinweis: Wenn Sie ein PDF-Dokument mit aktiven 3D-Objekten erzeugen wollen, stellen Sie sicher, dass die Option "3D-Modelldatei nicht in PDF einbetten" nicht ausgewählt ist.


HTML-, XML- und Adobe PDF-Konvertierung

Tagged Adobe PDF

Mit Tagged PDF können Sie Adobe PDF-Dateien von FrameMaker mit einer logischen Dokumentstruktur und umfangreichen Metadaten für zweckgerichtete Inhalte erstellen. Logische Struktur bezieht sich auf die Organisationsstruktur des Dokuments (Titelseite, Kapitel, Abschnitte und Unterabschnitte). Die logische Struktur hat Einfluss auf die Lesereihenfolge und verbessert die Navigation, insbesondere bei großen und kompliziert aufgebauten Dokumenten.

Tagged Adobe PDF bietet unter anderem folgende Vorteile:

    Stellt sicher, dass alle Informationen auf der Seite in der richtigen Reihenfolge angeordnet sind.

    Enthält Absatzattribute, die für den korrekten Fluss des Dokumentinhalts auf verschiedenen Geräten sorgen, wie z. B. auf eBook-Lesegeräten.

    Stellt die zuverlässige Übersetzung von Text in Unicode sicher. Unicode ist ein standardisiertes Verfahren, das Textzeichen unabhängig von der Schriftart beschreibt. Dieses Verfahren erkennt Ligaturen und Bindestriche, sodass alle Zeichen und Wörter von einem Screen Reader für Windows richtig interpretiert werden.

    Erkennt alternativen Text für Grafiken in verankerten Rahmen.

    Stellt sicher, dass Dokumente zuverlässig in das RTF- (Rich Text Format) und XML-Format von Acrobat 7.0 umgewandelt werden.

Tagged Adobe PDF-Dateien enthalten den eigentlichen Inhalt des Dokuments, einschließlich Seiten, Artikel, Absätze, Tabellen und Grafiken in verankerten Rahmen. Tagged PDF-Dateien enthalten keine der folgenden Informationen, wie sie in Standard-PDF-Dateien zu finden sind:

    Kommentare, wie Online-Notizen, Grafik- und Text-Markups.

    Seitenumbruch-Artefakte, einschließlich aller Inhalte von Vorgabeseiten (wie Seitenzahlen und laufende Überschriften) sowie einige Grafikobjekte außerhalb von verankerten Rahmen.

    Layout- und typografische Artefakte, wie farbige Trennlinien zwischen Textspalten, horizontale Linien, die Fußnoten vom Haupttext trennen, und Tabellenrahmen.

    Druck-Artefakte, wie Schneidemarken, Registermarken und Seiteninformationen außerhalb der Schneidemarken.

Kommentare und Artefakte werden von der logischen Baumstruktur nicht referenziert, da sie nicht sinnvoll sind, wenn der Dokumentinhalt für einen anderen Zweck vorbereitet werden soll.

Weitere Informationen über die Vorteile von Tagged PDF finden Sie auf der Adobe-Website.


HTML-, XML- und Adobe PDF-Konvertierung

Definieren einer Tagged Adobe PDF-Datei

Die Option "Tagged PDF erstellen" im Dialogfenster "PDF-Einstellungen" bietet verbesserten Zugriff auf den Inhalt von PDF-Dateien. Weitere Informationen finden Sie unter Tagged Adobe PDF.

Wichtig: Die Option "Tagged PDF erstellen" steht nur mit Acrobat Distiller 5.05 oder höher (Windows) oder über den internen Distillationsprozess (UNIX), die Bestandteile der FrameMaker-Installation sind, zur Verfügung.

So erstellen Sie eine Tagged PDF-Datei:

    1. Öffnen Sie das Dialogfenster "PDF-Einstellungen" (siehe Speichern von Dokumenten und Büchern als Adobe PDF).

    2. Wählen Sie "Typen" aus dem Aufklappmenü, oder klicken Sie auf die Registerkarte "Typen" (unter Windows/UNIX.)

    3. Stellen Sie sicher, dass "Tagged PDF erstellen" aktiviert ist.

    4. Richten Sie die Absatzstrukturebene ein, indem Sie folgende Aktionen ausführen:

    Wenn Sie die Strukturebenen für die übernommenen Absätze ändern wollen, wählen Sie einen Absatztyp aus und klicken Sie auf einen der Pfeile neben "Logische Strukturebene". Um die Ebene aller Elemente um eine Stufe zu ändern, halten Sie die Umschalttaste gedrückt und klicken Sie auf einen der Pfeile. Erstreckt sich die Einrückung für einen Typ über mehr als sechs Ebenen, steht ein n> vor dem Absatztyp, wobei n die Einrückungsebene des Typs angibt.

    Um die Absätze anzugeben, die in die PDF-Struktur übernommen werden sollen, verschieben Sie Absatztypen zwischen den Auswahllisten. Die Absätze in der Auswahlliste "Übernahme der Absätze" werden zur Definition der strukturellen Beziehung zwischen FrameMaker-Absatztypen in der PDF-Datei verwendet. Um einen Typ von einer Auswahlliste in eine andere zu verschieben, wählen Sie den Typ aus und klicken Sie auf den entsprechenden Pfeil. Sie können auch auf den Typ doppelklicken. Wenn Sie alle Typen von einer Liste in die andere verschieben wollen, halten Sie die Umschalttaste gedrückt und klicken Sie auf einen Pfeil.

    5. Klicken Sie auf "Zuweisen".


HTML-, XML- und Adobe PDF-Konvertierung

Fehlerbehebung und Tipps zur PDF-Konvertierung

Beachten Sie die folgenden Richtlinien, um eine problemlose Konvertierung in das PDF-Format sicherzustellen:

    Die besten Anzeigeergebnisse für Bitmap-Grafiken erzielen Sie, wenn Sie die Grafiken in das FrameMaker-Dokument importieren und dabei einen dpi-Wert verwenden, durch den die Auflösung des Bildschirms ohne Rest teilbar ist.

    Um die Anzeigegeschwindigkeit von PDF-Dateien zu verbessern, vermeiden Sie die Verwendung von Vorgabeseiten, die viele komplexe Grafiken enthalten. Sie können die Anzeige von Grafiken beschleunigen und die Dateigröße verringern, indem Sie beim Speichern einer PDF-Datei in Acrobat die Option "Optimieren" wählen. (Weitere Informationen hierzu finden Sie in der Online-Hilfe von Acrobat.)

    Beim Konvertieren eines Buches, das ein Inhaltsverzeichnis oder einen Index enthält, müssen Sie die Inhaltsverzeichnis- oder Indexdatei vor dem Speichern im PDF-Format in die Buchdatei einfügen.

    Wenn bei der Anzeige eines großen, in das PDF-Format konvertierten Dokuments die Anzeigegeschwindigkeit relativ niedrig ist, öffnen Sie das FrameMaker-Dokument oder -Buch erneut und deaktivieren Sie die Option "Artikel". Konvertieren Sie die PDF-Datei erneut.

    Falls Sie ein Buch in Form von separaten Dateien drucken, werden alle PDF-Dateien in demselben Ordner angelegt, unabhängig davon, wo sich das Originaldokument befindet. Aus diesem Grund sorgen Sie vor der Konvertierung in das PDF-Format dafür, dass alle Originaldokumente in den separaten Ordnern eindeutige Namen haben. Andernfalls werden Dateien überschrieben.

    Wenn die PDF-Datei zu umfangreich ist, lesen Sie die Informationen unter Reduzieren der PDF-Dateigröße.

    Wenn Sie mit Dokumenten aus einer früheren FrameMaker-Version als 6.0 arbeiten, stellen Sie sicher, dass Sie das Dokument optimieren, um die Dateigröße zu reduzieren. Weitere Informationen finden Sie unter Optimieren von Dateien, die in älteren FrameMaker-Versionen erstellt wurden.

    Stellen Sie sicher, dass die Druckerinstanz Adobe PDF Creation Add-On (Windows) bzw. Normalizer 8 (Solaris) installiert ist, die zum Erstellen von PDF-Dateien aus FrameMaker-Dokumenten verwendet wird.

    (Windows) Stellen Sie das Ausgabeformat des PostScript-Treibers auf "Optimale Portierung" ein.

    (Windows) Erstellen Sie keine Hypertext-Verknüpfungen zu Dateinamen, die akzentuierte Zeichen enthalten. Solche Dateinamen können sich beim Speichern im PDF-Format ändern, und die Hypertext-Verknüpfungen funktionieren nicht.

    Um Grafiken in Tagged PDF-Dateien einzubinden, platzieren Sie die Grafiken in verankerten Rahmen. Fügen Sie alternative Textbeschreibungen für grafische Objekte hinzu. Weitere Informationen finden Sie unter Vorbereiten verankerter Rahmen für Tagged PDF.


HTML-, XML- und Adobe PDF-Konvertierung

Speichern von strukturierten Dokumenten im Adobe PDF-Format

Das Verfahren zum Speichern von strukturierten Dokumenten als PDF-Datei entspricht dem Verfahren zum Speichern von unstrukturierten Dokumenten mit Ausnahme der Einrichtung von Lesezeichen. In strukturierten Dokumenten erstellen Sie Lesezeichen aus Element-Tags und nicht aus Absatztypen.

Wichtig: Tagged PDF basiert auf Absatzformattypen. Jeder Typ ist einem Element in der PDF-Struktur zugeordnet. Ein strukturiertes FrameMaker-Dokument behält seine Struktur beim Export in das Tagged PDF-Format nicht bei. Beachten Sie, dass die Absatzebenen auf der Seite "Typen" im Dialogfenster "PDF-Einstellungen" die relative Strukturebene der PDF-Datei bestimmen.

So setzen Sie Lesezeichen in strukturierten Dokumenten:

    1. Öffnen Sie das Dokument oder Buch, das Sie als PDF sichern möchten.

    2. Wenn Querverweise zu FrameMaker-Dokumenten in anderen Büchern vorhanden sind, öffnen Sie auch diese Buchdateien. Damit stellen Sie sicher, dass die Verknüpfungen funktionieren, wenn alle Buchdateien konvertiert werden.

    3. Wählen Sie im Originaldokument oder im Originalbuch "Datei > Sichern unter" (oder "Datei > Buch sichern unter"). Wählen Sie anschließend "PDF" aus dem Aufklappmenü. Ersetzen Sie die Dateinamenerweiterung durch ".pdf". Sie können auch den Speicherort und den Dateinamen ändern. Klicken Sie anschließend auf "Sichern".

    4. Wählen Sie im Dialogfenster "PDF-Einstellungen" den Eintrag "Lesezeichen" aus dem Aufklappmenü, oder klicken Sie auf die Registerkarte "Lesezeichen" (Windows).

    5. Wählen Sie die Option "PDF-Lesezeichen generieren".

    6. Um festzulegen, in welcher Ebene die Lesezeichen in der PDF-Datei erscheinen, wählen Sie eine Option aus dem Aufklappmenü "Lesezeichen erweitert durch Ebene". Sie können einen Wert, wie z. B. 2, eingeben. Damit legen Sie fest, dass nur die ersten zwei Ebenen erweitert werden.

    7. Wählen Sie "Elemente" aus dem Aufklappmenü "Lesezeichenquelle".

    8. Geben Sie an, welche Elemente in PDF-Lesezeichen konvertiert werden sollen, indem Sie Element-Tags in die Auswahlliste "Übernahme" verschieben. Um ein Element-Tag zwischen Auswahllisten zu verschieben, markieren Sie das Tag und klicken Sie auf einen der Pfeile. Sie können aber auch auf das Tag doppelklicken. Um alle in einer Auswahlliste enthaltenen Tags in eine andere Liste zu verschieben, klicken Sie auf einen der Pfeile, während Sie die Umschalttaste gedrückt halten. Um Lesezeichen zu unterdrücken, deaktivieren Sie "PDF-Lesezeichen generieren".

Einige Element-Tags können über Kontextbezeichnungen verfügen, die Informationen über die Position des Elements in der Struktur liefern. Wenn z. B. Abschnittelemente in andere Abschnittelemente eingebettet sind, könnten die Kontextbezeichnungen angeben, ob die Elemente Abschnitte erster, zweiter oder dritter Ebene sind.

Kontextbezeichnungen

Wenn ein Element Kontextbezeichnungen verwendet, erscheint in der Liste auch der Eintrag <Kein Wert> für Vorkommen, die nicht durch Bezeichnungen beschrieben werden. In obigem Beispiel steht "Abschnitt (<kein Wert>)" für Abschnittselemente der vierten oder einer niedrigeren Ebene im Dokument.

    9. Um Element-Tags gemeinsam mit Text in die Lesezeichen einzufügen, wählen Sie "Übernahme der Element-Tags in Lesezeichentext". Verwenden Sie diese Option, um die Lesezeichenebenen in einem Entwurf der PDF-Datei zu kontrollieren. Deaktivieren Sie diese Option, wenn Sie den fertigen Entwurf drucken.

    10. Klicken Sie auf "Zuweisen".

Informationen zum Einstellen weiterer PDF-Optionen finden Sie unter Speichern von Dokumenten und Büchern als Adobe PDF.


HTML-, XML- und Adobe PDF-Konvertierung

Definieren von PDF-Auftragsoptionen

FrameMaker verwendet die Auftragsoptionen von Adobe PDF Creation Add-On (Windows) bzw. Normalizer 8 (Solaris).

Auftragsoptionen von Adobe PDF Creation Add-On:

    Qualitativ hochwertiger Druck

    PDFA 1b 2005 CMYK

    PDFA1b 2005 RGB

    Druckausgabequalität

    Kleinste Dateigröße

    Standard

Auftragsoptionen von Normalizer 8:

    eBook

    High_Quality

    PDFX1a

    PDFX3

    Press

    Press_Quality

    Print

    Screen

    Smallest_File_Size

    Standard


HTML-, XML- und Adobe PDF-Konvertierung / Definieren von PDF-Auftragsoptionen

Verwenden der Option "Erzeugte PDF-Datei in Acrobat anzeigen"

Mit der Option "Erzeugte PDF-Datei in Acrobat anzeigen" können Sie festlegen, ob automatisch Acrobat gestartet und die erzeugte PDF-Datei geöffnet werden soll. (Das Dialogfenster "PDF-Einstellungen" wird geöffnet, wenn Sie im Dialogfenster "Dokument drucken" auf "PDF-Einrichtung" klicken.)

Auswählen der Option "Erzeugte PDF-Datei in Acrobat anzeigen"


HTML-, XML- und Adobe PDF-Konvertierung / Definieren von PDF-Auftragsoptionen

Verwenden der Option "CMYK-Farben in RGB konvertieren" (UNIX)

Standardmäßig konvertiert FrameMaker beim Drucken und Erstellen von PDF-Dateien CMYK-Farben in RGB. Sie können diese Einstellung im Dialogfenster "PDF-Einstellungen" ändern. Wenn Sie die Auswahl dieser Option aufheben, können Sie Standardkonvertierungen von CMYK-Farben in RGB überschreiben, sodass FrameMaker die CMYK-Farben beibehalten kann. Dies führt möglicherweise zu einer besseren Druckqualität.


HTML-, XML- und Adobe PDF-Konvertierung / Definieren von PDF-Auftragsoptionen

"Adobe PDF"-Drucker (Windows)

Wenn Adobe PDF Creation Add-On (Windows) oder Normalizer 8 (Solaris) installiert ist, können Sie Dokumente in PDF konvertieren, indem Sie eine PostScript-Datei erstellen und diese dann selbst distillieren. Der Name des von Ihnen zum Erstellen der PostScript-Dateien verwendeten Druckers ist "Adobe PDF".


Verarbeitung von XML

Was versteht man unter XML?

XML mit FrameMaker

XML mit XSL-Transformation

XML und CSS (Cascading Style Sheets)

XML mit Schema

Migration vom unstrukturierten FrameMaker zu XML

Vergleichen von Dokumentversionen


Verarbeitung von XML

Was versteht man unter XML?

Adobe FrameMaker bietet eine verbesserte Unterstützung für den Import und Export von XML-Dateien, einschließlich einer verbesserten Verarbeitung von bedingtem Text und Querverweisen. Adobe® FrameMaker® ermöglicht darüber hinaus auch eine konsistente Verwendung von Dateinamenerweiterungen.

XML (Extensible Markup Language) ist ein offenes und anbieterunabhängiges Format, das vom World Wide Web Consortium (W3C) unterstützt wird, dem Gremium für die Standardisierung des WWW. Ebenso wie HTML besteht XML aus Tags in spitzen Klammern (wie <Beispiel>) und ist leicht zu erlernen. Die Tags werden in einer Textdatei gespeichert. Auch wenn sie sich auf den ersten Blick ähneln, unterscheiden sich HTML und XML in der Anwendung beträchtlich.

HTML wird oft spontan programmiert, während XML einen strukturierten Ansatz erfordert. Eine grundlegende Regel für XML-Dateien ist die Wohlgeformtheit. Das bedeutet, dass das XML-Dokument der XML-Syntax entsprechen muss. Zum Beispiel müssen alle Tags ordnungsgemäß geöffnet und geschlossen werden:

<p>Diese Version ist richtig.</p><p>Jeder Absatz wird geöffnet und geschlossen.</p>
<p>Dies ist unzulässig.<p>Der erste Absatz muss geschlossen werden, bevor der nächste Absatz geöffnet wird.


Verarbeitung von XML

XML mit FrameMaker

Sie können XML-Dateien in FrameMaker öffnen und speichern.


Verarbeitung von XML / XML mit FrameMaker

Öffnen und Speichern von XML-Dateien

Beim Öffnen einer XML-Datei behält FrameMaker die Erweiterung ".xml" des Dateinamens bei. Auch beim Ausführen des Befehls "Datei > Sichern" speichert FrameMaker die XML-Datei im XML-Format und verwendet dabei die Erweiterung ".xml".

Sie können XML-Dateien öffnen, die das XML-Schema verwenden (siehe XML mit Schema).

Hinweis: Sie können XML-Dateien, die Unicode-Inhalte enthalten, öffnen. FrameMaker öffnet diese Dateien, indem es sie in UTF-8-Codierung konvertiert.

So öffnen Sie eine XML-Datei:

    1. Wählen Sie im strukturierten FrameMaker "Datei > Öffnen". Unter UNIX können Sie auch im FrameMaker-Hauptfenster auf "Öffnen" klicken.

    2. Wählen Sie die zu öffnende Datei aus und klicken Sie auf "Öffnen".

    3. Wenn das Dialogfenster "Strukturierte Anwendung verwenden" angezeigt wird, wählen Sie aus dem Aufklappmenü einen Anwendungsnamen und klicken Sie auf "Fortfahren": Führen Sie anschließend eine der folgenden Aktionen aus:

    Wählen Sie den Namen einer Anwendung, um der Datei eine Anwendung zuzuordnen.

    Um die Standardzuweisung und keine Lese-/Schreibregeln auszuwählen, wählen Sie <Keine Anwendung>. Diese Option können Sie beispielsweise verwenden, wenn Sie eine Datei nur durchsuchen und nicht speichern möchten.

Die WebDAV-Funktion wurde erweitert, sodass nun das Authoring und die Bearbeitung von XML-Dateien auf dem WebDAV-Server möglich sind.

So speichern Sie eine XML-Datei:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Datei > Als XML speichern". Klicken Sie im Dialogfenster "Dokument speichern" auf "Sichern".

    Wählen Sie "Datei > Sichern unter". Wählen Sie im Dialogfenster zum Speichern des Dokuments in der Liste zur Auswahl des Dokumententyps die Option "XML" aus und klicken Sie auf "Sichern".

    Wählen Sie "Datei > Arbeitsgruppe > Sichern als". Wählen Sie im Dialogfenster "Auf Server sichern" in der Liste "Format" die Option "XML" aus und klicken Sie auf "Sichern".

FrameMaker speichert die Datei im XML-Format und behält die Dateierweiterung ".xml" bei.

Speichern von FrameMaker-Dateien als XML: Methode 1:

    1. Wählen Se im strukturierten FrameMaker den Befehl "Datei > Als XML speichern" aus.

    2. Wählen Sie den Ordner aus, in dem die Datei gespeichert werden soll.

    3. Geben Sie einen Dateinamen mit der Erweiterung ".xml" an.

    4. Wählen Sie im Aufklappmenü für den Dateityp bei "Sichern als" XML (*.xml).

    5. Klicken Sie auf "Sichern".

Speichern von FrameMaker-Dateien als XML: Methode 2:

    1. Wählen Sie im strukturierten FrameMaker den Befehl "Arbeitsgruppe > Sichern als" aus.

    2. Wählen Sie im Dialogfenster "Auf Server sichern" in der Liste "Format" die Option "XML" aus.

    3. Klicken Sie auf "Sichern".

Speichern von FrameMaker-Dateien als XML: Methode 3:

    1. Wählen Sie im strukturierten FrameMaker den Befehl "Arbeitsgruppe > Sichern als" aus.

    2. Wählen Sie im Dialogfenster "Auf Server sichern" in der Liste "Format" die Option "XML" aus.

    3. Klicken Sie auf "Sichern".


Verarbeitung von XML / XML mit FrameMaker

Verarbeitung von bedingtem Text und XML

Der strukturierte FrameMaker ermöglicht Ihnen das Exportieren und Importieren allen bedingten Textes (sichtbar und verborgen) mit allen Informationen über Bedingungstypen, wie z. B. ihr Status bezüglich der Ein-/Ausblendung, der Farbe und des Stils.

Damit bedingter Text beim Speichern und Öffnen von XML-Dateien erhalten bleibt, enthält die von FrameMaker erzeugte XML-Datei Folgendes:

    Bedingungstypen, die dem im Dokument vorhandenen bedingten Text entsprechen

    Bedingungsformate (Farbe und Effekt), die mit jedem Bedingungstyp verknüpft sind

    Status (ein- oder ausgeblendet) für jeden Bedingungstyp

    Start- und Endmarken für die zu jedem Typ gehörenden Abschnitte

Zusätzlich zur Unterstützung für normalen Text wird auch bedingter Text in XML unterstützt. Dies führt dazu, dass ganze Tabellen oder Tabellenzeilen bedingt sein können. Dasselbe gilt für Fußnoten, Marken und verankerte Grafiken. Bedingter Text kann sich auch innerhalb eines Texteinschubs (XML oder Text) befinden.


Verarbeitung von XML / XML mit FrameMaker

Verarbeitung von Querverweisen in XML

Mit dem strukturierten FrameMaker können Sie beim Speichern und Öffnen von XML-Dateien externe Querverweise erzeugen und beibehalten.

Wenn beispielsweise Ihre FrameMaker-Datei einen Querverweis zu einer anderen Datei enthält, erzeugt FrameMaker beim Speichern der Datei in XML Tags, die die Querverweise mit den Informationen über die Referenzdateien repräsentieren. Beim Öffnen derselben XML-Datei konvertiert FrameMaker die Tags für die Querverweise und die darin enthaltenen Informationen in FrameMaker-Querverweise.

FrameMaker unterstützt das Attribut srcfile, mit dessen Hilfe Informationen von externen Querverweisen beim Erzeugen von XML-Dokumenten erhalten bleiben.

Beim Exportieren einer Datei mit einem externen Querverweis zu XML enthält das Attribut srcfile des Querverweises den Namen der Referenzdatei und die ID für das referenzierte Element in der Datei.

Hinweis: FrameMaker konvertiert Dateipfade im erzeugten XML-Format in URIs.


Verarbeitung von XML / XML mit FrameMaker

Optionen für die Verarbeitung von XML

FrameMaker bietet Optionen zum Verarbeiten von XML. FrameMaker ermöglicht auch den XML-Import und -Export zur Unterstützung von XSL-Transformationen (siehe XML mit XSL-Transformation) und der XML Schema-Sprache für Grammatik- und Regeldefinitionen (siehe XML mit Schema). Sie können ein XML-Dokument, das Schema verwendet, automatisch importieren, indem Sie aus dem referenzierten Schema ein DTD (Document Type Definition) erstellen. Sie können auch direkt aus einer Schema-Definition ein EDD (Element Definition Document) erstellen. Diese Version ermöglicht auch eine Validierung anhand eines verknüpften Schemas, und dies sowohl beim Importieren als auch beim Exportieren.


Verarbeitung von XML

XML mit XSL-Transformation

Mit XSLT (XML Style Transformation Language), einer spezialisierten, in XML geschriebenen Programmiersprache, werden in XSL (Extensible Style Language) definierte Transformationen auf XML-Dokumente angewendet. FrameMaker bietet einen XSLT-Prozessor, mit dem Sie eine XSL-Datei mit einer XML-Strukturanwendung oder einem XML-Dokument verknüpfen können und beim Importieren von oder Exportieren in XML die in diesem Dokument definierten Transformationen anwenden können. FrameMaker unterstützt die XSLT-1.0-Empfehlungen des W3C.

    Mit den neuen Elementen in der Strukturanwendung (XSLTPreferences im Element Stylesheets von XMLApplication) können Sie eine XSL-Datei als Teil Ihrer XML-Strukturanwendung definieren, wobei diese sowohl für den Import als auch den Export verwendet wird.

    Mit der Verarbeitungsanweisung (PI – Processing Instruction) xml-stylesheet können Sie nun in einem XML-Markup-Dokument eine XSL-Datei angeben, die jegliche, beim Importieren des Dokuments in der Strukturanwendung angegebene XSL ersetzt.

Beim Import werden XSL-Transformationen vor den standardmäßigen Schreibregeln oder den gegebenenfalls von Ihnen definierten zusätzlichen Schreibregeln angewendet. Dies bedeutet Folgendes: Das Ergebnis der Anwendung einer XSL-Transformation beim Importieren ist eine neue Datei, welche (wenn es eine XML-Datei ist) an die Lese-/Schreibregeln übergeben wird.

Beim Export werden XSL-Transformationen nach den standardmäßigen oder spezifisch definierten Schreibregeln angewendet. Das Ergebnis der Anwendung von Lese-/Schreibregeln beim Export ist eine neue XML-Datei, die, sofern sie gültig ist, an den XSLT-Prozessor übergeben wird.

Weitere Informationen und Einzelheiten zu neuen Elementen und PI finden Sie im Structured Application Developer’s Guide.


Verarbeitung von XML

XML und CSS (Cascading Style Sheets)

Wenn ein XML-Dokument in FrameMaker geöffnet ist, verarbeitet FrameMaker CSS2, indem es die CSS-Informationen entsprechenden EDD-Regeln im EDD-Dokument zuordnet.

In den folgenden Fallbeispielen wird die Verarbeitung von CSS2 in FrameMaker beschrieben:

    Sie öffnen ein EDD in FrameMaker und verwenden die Option "CSS-Stile importieren" im Menü "Strukturierungswerkzeuge". FrameMaker prüft, ob das aktuelle Dokument ein EDD ist. Ist dies der Fall, wird das Dialogfenster "Öffnen" angezeigt, und Sie können einen Pfad für die CSS-Datei angeben. Die CSS-Datei wird dann in das EDD importiert. Sie können dann die Elementdefinitionen vom EDD in eine Schablone importieren, die dann beim Öffnen einer XML-Datei verwendet wird. Enthält das EDD Formatierungsregeln, werden die CSS-Eigenschaften an die bestehenden Regeln angehängt, wenn die Eigenschaften eindeutig sind. Ansonsten überschreiben die importierten CSS-Eigenschaften die im EDD vorhandenen Formatierungsregeln. Sie können auch für alle Elemente in einem Dokument, die das Format Cascading Style Sheets 2 (CSS2) verwenden, XML-Stilinformationen in ein EDD exportieren, indem Sie im Menü "Strukturierungswerkzeuge" die Option "CSS2 generieren" verwenden.

    Wenn Sie eine mit Style Sheets verbundene XML-Datei öffnen (mit der Verarbeitungsanweisung (PI) für XML-Style Sheets), liest FrameMaker das mit dem XML-Dokument verbundene DTD und Style Sheet und erzeugt dann eine temporäre Schablone zur Verwendung beim Öffnen der XML-Datei. Wenn jedoch bereits in der "Strukturierten Anwendung" eine Schablone (zum Öffnen der XML-Datei) definiert ist, verwendet FrameMaker diese Schablone zum Öffnen der XML-Datei und erzeugt keine neue Schablone aus dem DTD und den Style Sheets.

Hinweis: Eine in FrameMaker geöffnete XML-Datei kann mehrere CSS-Dateien enthalten. FrameMaker unterstützt nur das Style Sheet des Autors, und nicht das des Benutzers.


Verarbeitung von XML

XML mit Schema

Mit FrameMaker können Sie mit der XML Schema-Sprache von W3C verknüpfte XML-Dokumente importieren. FrameMaker erstellt aus dem Schema automatisch ein DTD und ein EDD. FrameMaker validiert die Dokumentstruktur anhand des verknüpften Schemas, und dies sowohl beim Importieren von XML als auch beim Exportieren nach XML. Beim Exportieren bleiben jedoch nicht alle Schema-Informationen erhalten.

Umfassendere Informationen darüber, wie das Schema in DTD wiedergegeben wird, finden Sie im Structure Application Developer’s Guide.

Hinweis: Diese Version bietet Unterstützung für das Schema, das dem zuvor für DTD verfügbaren Schema entspricht. Dies bedeutet, dass EDD nicht um Funktionen in Schema, die in DTD nicht verfügbar sind, erweitert wurde. Aus diesem Grund sind Schemas schreibgeschützt, und Sie können das EDD nicht zurück in ein Schema exportieren.


Verarbeitung von XML / XML mit Schema

Schema-Workflow

Sie können ein XML-Dokument importieren, das auf eine Schema-Datei verweist, und Sie können eine Schema-Datei in der Strukturanwendung angeben, die für die Validierung eines Dokuments beim Export in XML verwendet wird.

    1. Für ein spezifisches XML-Dokument können Sie den XML-Verwendungsattributen den Pfad der Schema-Datei hinzufügen: noNamespaceSchemaLocation oder schemaLocation, je nachdem, ob Ihr Schema einen Ziel-Namespace enthält.

    2. Um eine Schema-Datei anzugeben, die für das Exportieren von XML verwendet wird, müssen Sie die Datei structapps.fm modifizieren. Verwenden Sie das Element Schema als Teil der XMLApplication, um den Pfad der Schema-Datei für den Export anzugeben.

    3. Öffnen Sie die XML-Datei in FrameMaker mithilfe einer strukturierten Anwendung. Bearbeiten Sie es.

    4. Speichern Sie das XML mithilfe einer strukturierten Anwendung. Das Element Schema in der Datei structapps.fm wird in der Datei ausgegeben, und es wird eine Prüfung anhand dieser Datei durchgeführt.

In diesem Workflow wird als Zwischendatei von dem im XML-Dokument angegebenen Schema automatisch eine DTD erzeugt, die Sie nicht modifizieren. Sie können jedoch eine Schema-Datei auch zur Erzeugung einer EDD-Datei verwenden. Weitere Informationen hierzu finden Sie unter Erzeugen eines Elementkatalogs von einem Schema.


Verarbeitung von XML / XML mit Schema

Änderungen an der Strukturanwendung für die Schema-Unterstützung

Das neue Element Schema, ein dem Element XmlApplication untergeordnetes Element, gibt den Pfad der Schema-Datei in der Strukturanwendungsdatei structapps.fm an. Wenn Instanzdokumente Namespaces verwenden, muss die Eigenschaft Namespace in XmlApplication auf true gesetzt werden.

Damit eine Strukturanwendung beim Importieren eines mit einem Schema verknüpften Dokuments in der Liste "Strukturierte Anwendung verwenden" ausgewählt werden kann, muss das Stammelement des Schemas im DOCTYPE der Anwendung im Element XmlApplication enthalten sein.


Verarbeitung von XML / XML mit Schema

Erzeugen eines Elementkatalogs von einem Schema

Sie können ein neues EDD von einer Schema-Definition erstellen oder die Elemente von einer Schema-Definition in ein vorhandenes EDD importieren. FrameMaker konvertiert die Schema-Definition zuerst in DTD und erstellt dann Elemente oder importiert diese in ein EDD.

Verwenden Sie die folgenden Befehle im Menü "Strukturierungswerkzeuge":

    Schema öffnen: Mit diesem Befehl wird ein angegebenes Schema in DTD konvertiert und aus dem DTD ein neues EDD erstellt.

    Schema importieren: Dieser Befehl konvertiert ein angegebenes Schema in DTD und importiert Elemente aus dem DTD in ein vorhandenes EDD.

Bei beiden Befehlen wird ein Dialogfenster zur Wahl der Datei, mit dem Sie die Schema-Datei angeben können, und dann ein Dialogfenster zum Speichern geöffnet, in dem Sie festlegen können, wo die resultierende DTD-Datei gespeichert werden soll.

So erstellen Sie ein EDD aus einem Schema:

    1. Wählen Sie im strukturierten FrameMaker "Strukturierungswerkzeuge > Schema öffnen".

    2. Wählen Sie eine Schema-Datei.

    3. Wählen Sie einen Pfad für die DTD-Datei, die ausgegeben werden soll.

    4. Prüfen Sie das entstehende DTD und nehmen Sie die gewünschten Änderungen vor.

    5. Erstellen Sie entsprechend den Angaben im "Structure Application Developer’s Guide" aus dem erzeugten DTD ein EDD.

    6. Verwenden Sie das EDD zum Erstellen einer Schablone, die der strukturierten Anwendung hinzugefügt werden kann.

    7. Geben Sie den DTD-Pfad und den Schema-Speicherort in der Eingabe-XML an. So ist sichergestellt, dass FrameMaker korrekt mit Ihrer Schablone arbeitet. Die Validierung von Eingabe- und Ausgabe-XML wird immer noch anhand des Schemas durchgeführt.


Verarbeitung von XML

Migration vom unstrukturierten FrameMaker zu XML

Die Implementierung des strukturierten FrameMaker ist eine lohnende Herausforderung. Durch die Kombination der leistungsstarken Funktionen von FrameMaker mit einer strukturierten Authoring-Umgebung können Sie den Workflow straffen und verbessern. Dank der neuen Authoring-Umgebung können Sie XML-gestützte Inhalte automatisch formatieren, erstellen, bearbeiten und veröffentlichen und die erforderlichen Dokumentstrukturen kohärent umsetzen.

Für den Aufbau des strukturierten Workflows müssen Sie allerdings neue Tools (wie die Strukturfunktionen von FrameMaker), neue Konzepte (strukturiertes Authoring) und eine neue Technologie (XML, Strukturdefinitionen) sowie möglicherweise die XSL-Transformation (Extensible Stylesheet Language) beherrschen. Wenn Sie XML nicht unbedingt benötigen, können Sie Strukturen auch ohne Support für den Import und Export von XML in FrameMaker implementieren. Dadurch verringert sich der Lernaufwand. Dieser Ansatz wird weiter unten ausführlich behandelt.

In diesem Weißbuch wird davon ausgegangen, dass Sie bereits mit der Arbeit im unstrukturierten (absatzbasierten) FrameMaker vertraut sind und einen Wechsel zum strukturierten FrameMaker erwägen.

Änderungsbalken kennzeichnen neuen oder überarbeiteten Text.

Eventuell möchten Sie nicht alle Änderungen, sondern nur die wichtigsten Änderungen in Ihrem Dokument kennzeichnen. Wenn Sie z. B. die zweite Überarbeitung eines Dokuments zur Prüfung freigeben, soll nicht jedes neue Komma oder jeder umgestellte Satz gekennzeichnet werden. Stattdessen soll sich der Prüfer auf die wesentlichen Änderungen konzentrieren können. In solchen Fällen können Sie nur bestimmten Text mit Änderungsbalken versehen, anstatt diese automatisch hinzuzufügen.

Bei der Arbeit mit strukturierten Dokumenten bietet sich das manuelle Hinzufügen von Änderungsbalken an, um wenige Änderungen zu markieren oder um Struktur-, Attribut- oder Formatänderungen zu kennzeichnen. Ihre spezielle Anwendung enthält unter Umständen ein zu diesem Zweck definiertes Element.

Hinweis: Beim Arbeiten mit strukturierten Dokumenten erkennen Änderungsbalken keine Änderungen, die nur die Struktur (zum Beispiel, wenn Sie ein Element ausgliedern), Attribute oder das Format betreffen.

Zu einem späteren Zeitpunkt kann es notwendig sein, die Änderungsbalken aus dem Text zu entfernen. Beispielsweise möchten Sie alte Änderungsbalken aus einem Handbuchentwurf entfernen, bevor Sie neue hinzufügen.

Sie können in die neuere von zwei Dokumentversionen Änderungsbalken einfügen, indem Sie die Versionen miteinander vergleichen. Informationen zum Hinzufügen von Änderungsbalken auf diese Weise finden Sie unter Vergleichen von Dokumentversionen.

Hinweis: Wenn Sie einem gesamten Absatz Änderungsbalken hinzufügen und dann das Format des Absatzes ändern (indem Sie z. B. Formate aus einem anderen Dokument importieren), dürfen Sie während der Aktualisierung keine irregulären Formate entfernen, wenn Sie die Änderungsbalken beibehalten möchten. Das Hinzufügen von Änderungsbalken zu einem gesamten Absatz ändert das Absatzformat und diese Änderung wird als irreguläres Format betrachtet.

So fügen Sie Änderungsbalken automatisch hinzu:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Änderungsbalken".

    3. Legen Sie die Stärke des Änderungsbalkens und den Abstand zwischen Textspalte und Änderungsbalken fest.

    4. Legen Sie mithilfe des Aufklappmenüs "Position" die Position der Änderungsbalken fest. Aktivieren Sie "Seite, näher zu Blattrand" oder "Seite, weiter weg von Blattrand", wenn die Position des Änderungsbalkens abhängig vom Seitenlayout von Seite zu Seite variieren soll.

Die Position ist relativ zu den Rändern der Spalte, die den geänderten Text enthält, und zwar unabhängig von der Spaltenanzahl auf der Seite.

    5. Wählen Sie aus dem Aufklappmenü "Farbe" eine Farbe für die Änderungsbalken aus.

    6. Aktivieren Sie die Option "Automatische Anzeige" und klicken Sie auf "Zuweisen".

Änderungen an durch Referenz importierten Grafiken werden nicht mit automatischen Änderungsbalken versehen, es sei denn, der Name der importierten Datei hat sich geändert. Auch Änderungen, die nur die Formatierung betreffen, bleiben unbeachtet. Wenn Sie z. B. nur den Typ eines Absatzes vom Format "Haupttext" in das Format "Markiert" ändern, wird kein Änderungsbalken angezeigt. Sie können ihn jedoch in diesem Fall manuell hinzufügen.

Hinweis: Wenn die automatische Anzeige der Änderungsbalken aktiviert ist und Querverweise aktualisiert werden, werden alle geänderten Querverweise mit Änderungsbalken versehen.

So versehen Sie ausgewählten Text manuell mit Änderungsbalken:

Wählen Sie den gewünschten Text aus und wählen Sie "Format > Stil > Änderungsbalken". Sie können auch die Standardschrift-Einstellungen der Absatzgestaltung verwenden.

So versehen Sie einen gesamten Absatz manuell mit Änderungsbalken:

    1. Klicken Sie in einen Absatz oder ziehen Sie mit der Maus über mehrere Absätze. (Sie müssen nicht einen gesamten Absatz auswählen.)

    2. Wählen Sie "Format > Absätze > Gestaltung" und zeigen Sie die Standardschrift-Einstellungen an.

    3. Wählen Sie "Änderungsbalken" und klicken Sie auf "Zuweisen (Auswahl)".


Verarbeitung von XML / Migration vom unstrukturierten FrameMaker zu XML

Zuweisen von Änderungsbalken mithilfe eines Zeichenformats

Eine weitere Möglichkeit, einem Text Änderungsbalken zuzuweisen, besteht in der Verwendung eines Zeichenformats. Sobald Sie das Zeichenformat definiert haben, wählen Sie den Text aus und weisen ihm das Zeichenformat zu (siehe Zuweisen von vordefinierten Formaten zu Text). Mit dieser Methode können Sie Änderungsbalken auch beibehalten, wenn Sie das Dokument mit neuen Absatzformaten aktualisieren und irreguläre Formate entfernen.

Wenn Sie Text mithilfe eines Zeichenformats als geändert markieren, können Sie die Änderungsbalken auf jede der im nächsten Abschnitt beschriebenen Arten wieder entfernen. Die einzige Möglichkeit, den Formattyp vom Text zu entfernen, besteht allerdings darin, den Text auszuwählen und ihm die Standardschrift [image] des Absatzes aus dem Zeichenformat-Katalog zuzuweisen.

So definieren Sie ein Zeichenformat, das Änderungsbalken hinzufügt:

    1. Klicken Sie in einen beliebigen Absatz und wählen Sie "Format > Zeichen > Gestaltung".

    2. Wählen Sie im Dialogfenster "Zeichengestaltung" aus dem Aufklappmenü "Befehle" den Eintrag "Alle Einstellungen auf 'Beibehalten'".

    3. Wählen Sie "Änderungsbalken" und anschließend "Neues Format" aus dem Aufklappmenü "Befehle".

    4. Geben Sie eine Typbezeichnung ein und klicken Sie auf "In Katalog einfügen".

    5. Klicken Sie auf "Anlegen".


Verarbeitung von XML / Migration vom unstrukturierten FrameMaker zu XML

Entfernen von Änderungsbalken

Sie können die Änderungsbalken in einem Dokument einzeln oder vollständig entfernen. Ebenso können Sie die Änderungsbalken für ein einzelnes Dokument oder für bestimmte Dateien in einem Buch entfernen.

So löschen Sie alle Änderungsbalken in einem Dokument:

    1. Bringen Sie das entsprechende Dokument- oder Buchfenster als aktives Fenster in den Vordergrund. Wenn ein Buchfenster aktiv ist, wählen Sie die gewünschten Dokumente aus.

    2. Wählen Sie "Format > Dokument > Änderungsbalken".

    3. Aktivieren Sie die Option "Alle Änderungsbalken löschen" und klicken Sie auf "Zuweisen".

So entfernen Sie einzelne Änderungsbalken:

Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie den Text aus und wählen Sie "Format > Stil > Änderungsbalken". Sie können auch die Standardschrift-Einstellungen der Absatzgestaltung verwenden. Wenn ein Teil des ausgewählten Textes nicht mit einem Änderungsbalken gekennzeichnet ist, müssen Sie "Format > Stil > Änderungsbalken" zweimal auswählen, um die Änderungsbalken zu entfernen.

    Um einen Änderungsbalken zu entfernen, der über ein Zeichenformat zugewiesen wurde, wählen Sie den Text aus, und weisen Sie ihm die Standardschrift [image] aus dem Zeichenformat-Katalog zu (siehe Zuweisen von vordefinierten Formaten zu Text).

Um Text zu untersuchen und zu ändern, der mit Änderungsbalken gekennzeichnet ist, verwenden Sie den Befehl "Suchen/Ändern". Sie können nach Text suchen, dem die Einstellung "Änderungsbalken" zugewiesen ist, oder nach Text, der das entsprechende Zeichenformat besitzt. Informationen hierzu finden Sie unter Suchen eines beliebigen Elements und Suchen nach Zeichenformateinstellungen.


Verarbeitung von XML

Vergleichen von Dokumentversionen

Wenn Sie zwei Versionen eines Dokuments vergleichen, legt FrameMaker folgende Dokumente an:

    Das kombinierte Dokument ist ein Bedingungsdokument, das die neuere Version mit der älteren Version vergleicht. Es zeigt die Unterschiede nebeneinander an. Sie können den Bedingungstyp angeben, der geändertem Text zugewiesen werden soll, und festlegen, ob die Änderungen durch Änderungsbalken gekennzeichnet werden sollen.

    Das Auswertungsdokument enthält eine allgemeine Auswertung und eine Überarbeitungsliste für jeden verglichenen Elementtyp. Sie können die Auswertung als Hypertext-Dokument mit Verknüpfungen zu den geänderten Seiten erstellen. Auf diese Weise lassen sich geänderte Seiten schnell anzeigen, wenn Sie diese lesen oder bearbeiten möchten.

Informationen über das Vergleichen von Büchern finden Sie unter Vergleichen von Büchern.

Hinweis: Wenn Sie Dokumente, die Tabellen enthalten, oder umfangreiche Dokumente vergleichen, müssen Sie unter Umständen den Swap-Speicher für Ihre Anwendung vergrößern (UNIX).

So vergleichen Sie zwei Versionen eines Dokuments:

    1. Öffnen Sie beide Versionen des Dokuments. Wenn beide Dokumente bedingten Text enthalten, müssen alle Bedingungen eingeblendet sein.

    2. In der neueren Version wählen Sie "Datei > Dienstprogramme > Dokumente vergleichen".

    3. Wählen Sie die ältere Version aus dem Aufklappmenü und geben Sie die Dokumente an, die FrameMaker für Sie erstellen soll. Das Aufklappmenü "Älteres Dokument" enthält alle geöffneten und benannten Dokumente (mit Ausnahme des aktuellen Dokuments).

    4. Klicken Sie auf "Optionen", führen Sie die folgenden Aktionen aus und klicken Sie auf "Zuweisen":

    Geben Sie unter "Einfügungen markieren mit" an, wie eingefügter Text angezeigt werden soll. Sie können den voreingestellten Bedingungstyp wählen ("Eingefügt"), einen anderen Bedingungstyp auswählen oder den eingefügten Text nicht markieren.

    Geben Sie unter "Löschungen markieren mit" an, wie eingefügter Text angezeigt werden soll. Sie können den voreingestellten Bedingungstyp ("Gelöscht"), einen anderen Bedingungstyp oder einen selbst festgelegten Text wählen. Um zu verhindern, dass gelöschter Text in das kombinierte Dokument aufgenommen wird, klicken Sie auf "Ersetzungstext" und lassen das Textfeld leer.

    Um alle Änderungen (Einfügungen und Löschungen) im kombinierten Dokument mit Änderungsbalken zu markieren, aktivieren Sie die Option "Änderungen durch Änderungsbalken markieren". FrameMaker verwendet dann die aktuellen Einstellungen der Änderungsbalken für dieses Dokument.

Wenn Sie lediglich der neueren Version eines Dokuments Änderungsbalken hinzufügen wollen, wählen Sie "Änderungen durch Änderungsbalken markieren". Klicken Sie dann unter "Löschungen markieren mit" auf "Ersetzungstext" und lassen Sie das Textfeld "Ersetzung" leer.

    5. Klicken Sie auf "Vergleichen". Wenn der Vergleich abgeschlossen ist, zeigt FrameMaker die Auswertung und das kombinierte Dokument an. Wenn beide Versionen gleich sind, wird kein Dokument erstellt.

Informationen über die verglichenen Dokumente und über Form und Inhalt des Auswertungsdokuments und des kombinierten Dokuments finden Sie unter Kombinierte Dokumente und Auswertungsdokumente.

    6. Um die Auswertung in ein Hypertext-Dokument umzuwandeln, aktivieren Sie die Option "Hypertext-Verbindungen in Auswertung anlegen". Wenn Sie in der Auswertung auf die Seitenzahl der Änderung klicken, zeigt FrameMaker die Seite an. Sie können sich Seiten der neueren Version, Seiten der älteren Version oder das kombinierte Dokument anzeigen lassen, das die Änderung enthält.


Verarbeitung von XML / Vergleichen von Dokumentversionen

Vergleichen von Dokumenten, die mehrere Textflüsse enthalten

Sie können Dokumente mit mehreren Textflüssen vergleichen. Damit FrameMaker nicht die falschen Textflüsse vergleicht, müssen Sie jedoch sicherstellen, dass jeder Textfluss einen eindeutigen Typ aufweist und dass die Textflüsse, die verglichen werden sollen, vom selben Typ sind. Informationen darüber, wie Sie einen Textflusstyp ändern, finden Sie unter Ändern von Textflusstypen und automatischer Verkettung.

Wenn ein Dokument mehrere Textflüsse mit dem gleichen Namen enthält (z. B. mehrere Textflüsse mit Namen "A" auf unverketteten Seiten), wird beim Vergleichen der Dokumente ein Meldungsfenster angezeigt, in dem alle doppelten Textflüsse aufgelistet werden. Textflüsse werden nur verglichen, wenn in beiden Dokumenten ein Textfluss mit dem gleichen Namen vorkommt.


Verarbeitung von XML / Vergleichen von Dokumentversionen

Vergleichen von Dokumenten, die bedingten Text enthalten

Beim Vergleich von Dokumenten mit bedingtem Text ignoriert FrameMaker verborgenen Text und Grafiken.

So vergleichen Sie Dokumente, die bedingten Text enthalten:

    1. Führen Sie eine der folgenden Aktionen aus:

    Um den gesamten Text zweier Dokumente zu vergleichen, zeigen Sie alle Bedingungen an, bevor Sie den Vergleich durchführen. Weitere Informationen finden Sie unter Ändern der Darstellung von Bedingungsdokumenten.

    Um bestimmte Texte in zwei Dokumenten zu vergleichen, zeigen Sie Bedingungen auf der Grundlage eines bestimmten Ausdrucks an, bevor Sie den Vergleich durchführen.

    Wenn bedingter Text beim Dokumentvergleich ignoriert werden soll, müssen Sie vor dem Vergleich den bedingten Text ausblenden.

    2. Vergleichen Sie die Dokumente (siehe Vergleichen von Dokumentversionen).

Alle ausgeblendeten bedingten Elemente im neueren Dokument bleiben im kombinierten Dokument verborgen.


Verarbeitung von XML / Vergleichen von Dokumentversionen

Kombinierte Dokumente und Auswertungsdokumente

Wenn Sie Dokumente vergleichen, erstellt FrameMaker zwei Dokumente und zeigt das Ergebnis des Vergleichs an.

Kombinierte Dokumente

Im kombinierten Dokument betrachtet FrameMaker Unterschiede als Einfügungen oder Löschungen. Wenn sich z. B. der Inhalt eines Grafikrahmens geändert hat, werden im kombinierten Dokument beide Versionen angezeigt. Die ältere Version wird als Löschung, die neuere als Einfügung markiert. Variablen im kombinierten Dokument verwenden die neueren Definitionen, werden aber nicht als Änderung markiert. Nur eingefügte oder gelöschte Variablen werden als Änderungen betrachtet.

Auswertungsdokument

Im Auswertungsdokument (mit dem Namen Auswrtng.fm) werden Unterschiede als Einfügungen, Löschungen oder Änderungen betrachtet. Wenn ein Element verschoben wurde, wird es als gelöscht und als eingefügt markiert. FrameMaker zeigt die Nummer der Seite an, auf der die Änderung in der neueren Version, in der älteren Version und im kombinierten Dokument zu finden ist. Bei Einfügungen bezeichnet die Seitennummer für die ältere Version die Seite, auf der das Element entsprechend der neueren Version eingefügt werden müsste. Bei Löschungen bezeichnet die Seitennummer für die neuere Version die Seite, auf der sich das Element befinden würde, wäre es nicht gelöscht worden.

Wenn Ihr Dokument doppelte Marken enthält, zeigt das Auswertungsdokument das erste Auftreten an. Alle weiteren Auftreten können Sie mit dem Befehl "Suchen/Ändern" finden.

Hinweis: Wenn Sie mehrere Auswertungsdokumente erstellen, sollten Sie jede Datei entsperren, indem Sie Esc d Umschalttaste+y drücken und jedem Dokument mit dem Befehl "Sichern unter" einen eindeutigen Namen geben.


Verarbeitung von XML / Vergleichen von Dokumentversionen

Verglichene Elemente

Beim Vergleich zweier Dokumentversionen prüft FrameMaker den Inhalt von Textflüssen gleichen Namens auf Arbeits- und Referenzseiten. Dabei werden Text, Fußnoten, verankerte Rahmen, Tabellen, Variablen und ihre Definitionen, Querverweise und ihre Formate, Fußnotentext sowie Markentypen und -text berücksichtigt. FrameMaker vergleicht keine Strukturelemente, sondern die Elementinhalte.

Die folgende Aufstellung enthält einige spezielle Unterschiede, die FrameMaker ausfindig machen kann.

Verankerte Rahmen

FrameMaker vergleicht die Objekte innerhalb des Rahmens. Sind diese unterschiedlich oder an einer anderen Position (weil Sie z. B. ihre Reihenfolge im Rahmen geändert haben), markiert FrameMaker den gesamten verankerten Rahmen als geändert.

Querverweise

FrameMaker prüft, ob es sich um einen externen oder um einen internen Querverweis handelt. Außerdem wird der Name des Querverweisformats, der Markentext an der Quelle und der Pfadname der referenzierten Datei (bei externen Querverweisen) geprüft. Ist eines dieser Elemente unterschiedlich, markiert FrameMaker den Querverweis als geändert.

Texteinschübe

FrameMaker vergleicht das Änderungsdatum, den Dateinamen, die relativen Pfadnamen der Texteinschübe und die Art und Weise, wie der Texteinschub importiert wurde (z. B. ob Zeilenenden als Zeilenumbrüche eingelesen wurden). Ist eines dieser Elemente unterschiedlich, wird der gesamte Texteinschub als geändert markiert.

Importierte Grafiken

FrameMaker vergleicht Inhalt und Auflösung der importierten Grafik. Dabei wird beispielsweise geprüft, ob ein Objekt gespiegelt oder gedreht wurde oder ob sich die Größe des Bildrahmens geändert hat. Ferner wird verglichen, wie die Grafik importiert wurde: durch Referenz oder als Kopie. Wenn die Grafik durch Referenz importiert wurde, vergleicht FrameMaker die Pfadnamen. Wenn sich bei einer dieser Einstellungen ein Unterschied ergibt, wird die Zeile, in der sich der verankerte Rahmen der importierten Grafik befindet, als geändert markiert.

Gleichungen

FrameMaker vergleicht die Größe der Gleichung, ihre Position im Grafikrahmen und die mathematischen Ausdrücke. Ist eines dieser Elemente unterschiedlich, wird die gesamte Gleichung als geändert markiert.

Tabellen

FrameMaker vergleicht die Anzahl der Reihen und Spalten und prüft, ob Zellen verbunden oder gedreht sind. Unterscheidet sich eines dieser Elemente, markiert FrameMaker diejenige Zeile als geändert, die das Ankersymbol der Tabelle enthält. Wenn sich Text in Zellen geändert hat, wird lediglich die neue Tabelle im kombinierten Dokument angezeigt, und FrameMaker markiert die betreffende Zeile in der Zelle als geändert. Wenn sich mehr als 75 % der Zellen geändert haben, wird die gesamte Tabelle als geändert markiert.

Sowohl die englische Version als auch die japanische Version von FrameMaker kann auf einem japanischen Betriebssystem japanischen Text vergleichen. FrameMaker vergleicht jedoch nicht Textflüsse auf Vorgabeseiten (einschließlich Kopf- und Fußzeilen), Textflüsse ohne Typ, Grafikobjekte oder Textzeilen, die sich nicht in verankerten Rahmen befinden, Positionen verankerter Rahmen, Fußnoteneinstellungen oder -nummerierung, Absatz-, Zeichen- oder Tabellentypen, Text- oder Tabellenformatierung, Typen im Absatzformat-, Zeichenformat- oder Tabellenformat-Katalog und den Inhalt von Texteinschüben. Da FrameMaker die Formatierung von Text oder Tabellen nicht prüft, werden Unterschiede wie geänderte Lineatur oder Schattierung in einer Tabelle oder eine andere Textfarbe nicht erkannt.


Verarbeitung von XML / Vergleichen von Dokumentversionen

Ermitteln der Wort- oder Zeichenanzahl

Sie können die Anzahl der Wörter oder Zeichen in einem Dokument bestimmen. Das Zählen der Zeichen in einem Dokument ist vor allem für Dokumente in asiatischen Sprachen mit Zeichen doppelter Breite (Multibyte) geeignet. Die Wortanzahl gibt die Anzahl der Zeichen einfacher und doppelter Breite sowie die Gesamtzahl der Zeichen an.

So ermitteln Sie die Wortanzahl in einem Dokument:

    1. Wählen Sie "Datei > Dienstprogramme > Statistik".

    2. Wählen Sie "Zeichenanzahl" oder "Wortzählung" und klicken Sie auf "Ausführen".

Hinweis: Die Funktion "Statistik" unterstützt den Unicode-Standard zur Textcodierung.


UNIX-Makros und -Dienstprogramme

UNIX-Version von FrameMaker

Verwenden von UNIX-Makros

Erstellen von UNIX-Bildschirmaufnahmen

Befehlszeilen-Operationen mit fmbatch (UNIX)

Drucken mit fmprint (UNIX)

Kopieren von Verzeichnisstrukturen mit fmcopy (UNIX)

Invertieren von Bildern mit fminvert (UNIX)

Konvertieren von Farbbildern in Schwarzweiß (UNIX)


UNIX-Makros und -Dienstprogramme

UNIX-Version von FrameMaker

Die UNIX-Version von Adobe FrameMaker bietet Ihnen mehrere Funktionen zur Steigerung Ihrer Produktivität.

    Mithilfe von Makros können Sie Routine-Eingaben auf der Tastatur automatisieren.

    Mit der Funktion für die Aufnahme von Bildschirmfotos können Sie Bildschirmfotos erstellen und in FrameMaker-Dokumente importieren.

    Mehrere UNIX-Befehlszeilen-Dienstprogramme führen Stapeloperationen an FrameMaker-Dateien aus und sind mit Grafikdateien verwendbar.


UNIX-Makros und -Dienstprogramme

Verwenden von UNIX-Makros

Ein Makro ist ein Tastaturbefehl für eine Folge von Tasteneingaben. Dem Makro weisen Sie einen so genannten Auslöser zu, d. h. eine Tastenfolge, die Sie zum Abrufen des Makros drücken. Wenn Sie den Auslöser eingeben, wird das Makro abgespielt, als würden Sie die Tasteneingaben selbst ausführen.

Makros können ganz einfach aufgebaut sein und z. B. ein häufig verwendetes Wort oder eine häufige Wortverbindung eingeben. Sie können jedoch auch komplex strukturiert sein und z. B. nach dem Absatztyp für Überschriften auf der ersten Ebene suchen, die Einfügemarke in den nächsten Absatz platzieren oder ein Format aus der Zwischenablage einfügen.

Bevor Sie Makros aufzeichnen, sollten Sie mit dem umfangreichen Angebot an FrameMaker-Tastaturbefehlen vertraut sein, da sie bei der Erstellung der Makros verwendet werden. Eine vollständige Liste der verfügbaren Tastaturbefehle finden Sie in der Online-Hilfe.

Zur Änderung eines Standard-Tastaturbefehls für eine Aktion benötigen Sie kein Makro. Die integrierten Tastaturbefehle können erweitert, geändert oder gelöscht werden. Anweisungen hierzu finden Sie im Online-Handbuch Anpassen von FrameMaker-Produkten . Dieses Handbuch ist unter folgender Adobe-Website verfügbar: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.

Sie haben die Möglichkeit, mit einer beliebigen Anzahl von Makros gleichzeitig zu arbeiten. Jedes Makro kann bis zu 600 Tasteneingaben umfassen. Die meisten nicht druckbaren Zeichen, z. B. Leerzeichen, Eingabetaste und Funktionstasten, zählen dabei als zwei Tasteneingaben.

Ein Makro kann alle Aktionen ausführen, die Sie selbst in FrameMaker ausführen können, mit folgenden Ausnahmen:

    Auf eine Tastatureingabe warten und dann mit der Ausführung fortfahren

    Mausklicks oder Bewegungen des Mauszeigers aufzeichnen

    Den Tastaturbefehl F10 aufzeichnen, der den Fokus in die Menüleiste verlagert

    Den Tastaturbefehl F4 aufzeichnen, der das entsprechende Kontextmenü anzeigt

    Japanische Zeichen aufzeichnen

So zeichnen Sie in UNIX ein Makro auf:

    1. Wählen Sie "Datei > Dienstprogramme > Makros".

    2. Klicken Sie auf "Neues Makro aufzeichnen", dann auf "Starten" und abschließend auf OK.

    3. Führen Sie die Tasteneingaben aus, die FrameMaker aufzeichnen soll. Wenn Sie eine Taste drücken, zeichnet FrameMaker die Eingabe auf und führt ihre normale Funktion aus. Sie können auch den Auslöser für ein Makro drücken, das Sie zuvor aufgezeichnet haben.

    4. Um die Aufzeichnung zu beenden, wählen Sie "Datei > Dienstprogramme > Makro-Aufzeichnung beenden".

    5. Drücken Sie die Tastenkombination, die Sie als Auslöser verwenden wollen, und klicken Sie auf "Fortfahren". Sie müssen einen Auslöser eingeben, da andernfalls die Aufzeichnung abgebrochen wird.

Beim Eingeben des Auslösers werden die Tasteneingaben im Textfeld angezeigt. (Vor Funktionstasten steht ein umgekehrter Schrägstrich. Die Control-Taste wird als ^, die Meta-Taste als ~, die Umschalttaste als + und die Esc-Taste als \! angezeigt.) Informationen über Auslöser finden Sie unter Zuweisen eines Makro-Auslösers.

    6. Geben Sie bei Bedarf einen Kommentar für das Makro ein und klicken Sie auf "Fortfahren".

So brechen Sie in UNIX die Makro-Aufzeichnung ab:

Wählen Sie "Datei > Dienstprogramme > Makro-Aufzeichnung beenden" und klicken Sie auf "Abbrechen".


UNIX-Makros und -Dienstprogramme / Verwenden von UNIX-Makros

Zuweisen eines Makro-Auslösers

Im Folgenden sind einige Richtlinien für die Festlegung eines Makro-Auslösers zusammengestellt:

    Der Auslöser kann bis zu 15 Tasteneingaben enthalten.

    Für einen Auslöser kann im Prinzip jede Taste verwendet werden, allerdings sollte es sich nicht um eine Taste handeln, der bereits eine Funktion zugeordnet ist. Verwenden Sie beispielsweise nicht die Tabulatortaste als Auslöser, da Sie ansonsten keinen Tabulator in einen Text einfügen können.

    Ein Auslöser kann eine beliebige Kombination von Control-, Umschalt- und Meta-Taste enthalten. So sind beispielsweise die Kombinationen Control+8 und Meta+Control+8 erlaubt.

    Ein Auslöser darf nicht mit der Kombination Esc-Taste oder Control+r plus erster Buchstabe eines Menünamens beginnen. Dadurch würden alle Tastaturbefehle für das entsprechende Menü deaktiviert. Wenn Sie beispielsweise Esc b als Auslöser verwenden, lassen sich die Tastaturbefehle für die Optionen des Menüs "Bearbeiten" nicht mehr aktivieren.

    Ein Auslöser darf keine Kopie eines integrierten Tastaturbefehls sein, es sei denn, es spielt keine Rolle, dass der integrierte Tastaturbefehl nicht mehr funktioniert. (Eine Liste der integrierten Kurzbefehle finden Sie in der Online-Hilfe.)

    Bestimmte Tasten und Tastenkombinationen haben eine besondere Bedeutung, wenn Sie sie einem Makro-Auslöser zuweisen.

    Tastenfolge | Bedeutung
Rücktaste, Entf und Control+h | Löscht den letzten Tastendruck des Auslösers.
Control+u | Löscht den gesamten Auslöser.
Eingabetaste, Control+] | Akzeptiert den Auslöser (entspricht einem Mausklick auf "OK").
Tabulator | Springt zur nächsten Einstellung.
Umschalttaste+Tabulator | Springt zur vorhergehenden Einstellung.
Control+Tab | Springt zur ersten Einstellung.
Control+c | Bricht das Makro ab (entspricht einem Mausklick auf "Abbrechen").

Wenn Sie diese Tasten in einem Auslöser verwenden wollen, müssen Sie ihnen einen umgekehrten Schrägstrich voranstellen. Um beispielsweise Control+g Entf als Auslöser einzusetzen, drücken Sie Control+g, geben einen umgekehrten Schrägstrich ein und drücken dann Entf. Der Auslöser wird als ^g/Entf angezeigt.

    Wenn ein umgekehrter Schrägstrich als Zeichen in einem Auslöser eingesetzt werden soll, müssen Sie ihn zweimal (\\) eingeben.


UNIX-Makros und -Dienstprogramme / Verwenden von UNIX-Makros

Abspielen von Makros

Wenn Sie ein Makro abspielen, reagiert FrameMaker so, als ob Sie die in dem Makro gespeicherten Tasteneingaben selbst ausführen würden.

In Abhängigkeit von der Funktion des Makros müssen Sie eventuell vor dem Abspielen Text oder andere Objekte auswählen. Wenn das Makro z. B. das Format des aktuellen Absatzes ändert, platzieren Sie die Einfügemarke vor dem Abspielen in einen Absatz.

Hinweis: Makros werden unter Umständen falsch ausgeführt, wenn sich die Einfügemarke in einer Gleichung befindet und Sie den Makro-Auslöser in einem Dialogfenster drücken.

So spielen Sie ein Makro ab:

Drücken Sie den Auslöser des Makros.

So brechen Sie das Abspielen eines Makros ab:

Drücken Sie Control+c.

Hinweis: Wenn Sie nach dem Abspielen eines Makros "Datei > Rückgängig" wählen, wird nur die letzte Aktion des Makros widerrufen. Um alle Aktionen des Makros rückgängig zu machen, müssen Sie das Dokument vor dem Abspielen des Makros speichern. Wählen Sie dann "Datei > Zurück zur gesicherten Version", sobald das Makro beendet ist.


UNIX-Makros und -Dienstprogramme / Verwenden von UNIX-Makros

Speichern von UNIX-Makros

Sie speichern das aktuell im Speicher befindliche Makro, indem Sie es einer Makrodatei hinzufügen. FrameMaker fügt alle Makros hinzu, die Sie seit der letzten Speicherung oder Löschung von Makros aufgezeichnet haben.

Wenn Sie Ihre Makros in einer Datei mit dem Namen "fmMacros" speichern und diese Datei in einem der vier nachfolgend aufgeführten Verzeichnisse ablegen, lädt FrameMaker die Datei (und somit auch die Makros) automatisch beim Start. FrameMaker durchsucht die folgenden Verzeichnisse in der angegebenen Reihenfolge und lädt die erste fmMacros-Datei, die gefunden wird:

    Das fminit-Verzeichnis (./fminit), in dem Sie FrameMaker gestartet haben.

    Das Verzeichnis, in dem Sie FrameMaker gestartet haben (.).

    Das fminit-Verzeichnis in Ihrem Home-Verzeichnis (~/fminit).

    Ihr Home-Verzeichnis (~).

Sie können für besondere Aufgaben spezielle Makrodateien erstellen und diese bei Bedarf in FrameMaker einlesen. Beispielsweise könnten Sie eine Makrodatei für Grafik- und eine andere für Textbearbeitungsoperationen anlegen.

So speichern Sie in UNIX alle aktuellen Makros in einer Datei:

    1. Wählen Sie "Datei > Dienstprogramme > Makros" und wählen Sie einen der folgenden Schritte:

    Wenn Sie Makros zu Ihrem Standard-Makrosatz hinzufügen wollen, müssen Sie sicherstellen, dass das Textfeld für die Makrodatei den Dateinamen "fmMacros" enthält.

    Um die Makros einer anderen Makrodatei hinzuzufügen, wählen Sie diese in der Auswahlliste aus.

    Um eine neue Makrodatei zu erstellen, geben Sie einen neuen Dateinamen in das Textfeld für die Makrodatei ein.

    2. Klicken Sie zuerst auf "Neue Makros in Datei aufnehmen" und anschließend auf "Starten".


UNIX-Makros und -Dienstprogramme / Verwenden von UNIX-Makros

Einlesen von Makros in den Speicher

Wenn Sie Makros aus einer Makrodatei einlesen, werden sie mit den aktuellen Makros vermischt. Wenn ein Makro in der Datei denselben Auslöser verwendet wie ein aktuelles Makro, wird das aktuelle Makro durch das Makro aus der Datei ersetzt. Sollen alle aktuellen Makros durch die Makros aus einer Datei ersetzt werden, müssen Sie die aktuellen Makros löschen, bevor Sie die Makros aus der Datei laden.

Sollte es zu einem Systemausfall kommen, bevor Sie Makros in einer Datei speichern konnten, können Sie sie erneut laden, indem Sie die Datei ~/fmMacrosLog einlesen.

So lesen Sie in UNIX eine Reihe von Makros aus einer Datei ein:

    1. Wählen Sie zunächst "Datei > Dienstprogramme > Makros". Wählen Sie anschließend in der Auswahlliste eine Makrodatei aus.

    2. Klicken Sie auf "Makros aus Datei einlesen" und dann auf "Starten".


UNIX-Makros und -Dienstprogramme / Verwenden von UNIX-Makros

Löschen von Makros aus dem Speicher

Makros, die Sie aufzeichnen oder aus einer Datei einlesen, werden im Speicher Ihrer Workstation abgelegt. Sie können die aktuellen Makros jederzeit aus dem Speicher löschen. (Wenn Sie die Makros erneut verwenden möchten, müssen Sie sie speichern, bevor sie aus dem Speicher gelöscht werden.)

Beim Löschen von Makros entfernt FrameMaker auch die Tastaturbefehle, die während der Sitzung in eine Datei für die Menüanpassung eingefügt wurden. Informationen über Dateien für die Menüanpassung finden Sie im Online-Handbuch Anpassen von FrameMaker-Produkten.

So löschen Sie einen Satz aktueller Makros aus dem Speicher:

Wählen Sie "Datei > Dienstprogramme > Makros". Klicken Sie zuerst auf "Aktuelle Makros löschen" und dann auf "OK".


UNIX-Makros und -Dienstprogramme / Verwenden von UNIX-Makros

Löschen von UNIX-Makros und -Auslösern

Wenn Sie die gerade aufgezeichneten Makros verwerfen wollen, sie aber noch nicht gespeichert haben, können Sie die aktuellen Makros löschen (siehe Löschen von Makros aus dem Speicher). Wenn Sie aber einige der neuen Makros speichern möchten oder der Datei bereits ein Makro hinzugefügt haben, müssen Sie das Makro aus der Makrodatei löschen.

So löschen Sie einen Auslöser und verwenden ihn in einem anderen Makro:

Zeichnen Sie das neue Makro auf und weisen Sie ihm den gewünschten Auslöser zu. Wenn FrameMaker zwei Makros mit demselben Auslöser findet, wird nur das neueste Makro für den Auslöser verwendet.

So löschen Sie ein Makro aus einer gespeicherten Makrodatei:

    1. Speichern Sie alle neu aufgezeichneten Makros in einer Makrodatei (siehe Speichern von UNIX-Makros).

    2. Öffnen Sie die Makrodatei und löschen Sie die Makrodefinition. (Wenn Sie die Datei in FrameMaker bearbeiten, speichern Sie sie im Format "Nur Text".) Zur Identifizierung des zu löschenden Makros suchen Sie nach seinem Auslöser oder Kommentar. Der Kommentar steht unmittelbar vor der Makrodefinition. Löschen Sie die gesamte Definition einschließlich der abschließenden spitzen Klammer (>).

Beispielmakro mit Kommentar

    3. Löschen Sie die aktuellen Makros (siehe Löschen von Makros aus dem Speicher).

    4. Lesen Sie die bearbeitete Makrodatei wieder ein (siehe Einlesen von Makros in den Speicher).


UNIX-Makros und -Dienstprogramme / Verwenden von UNIX-Makros

Erstellen von UNIX-Makros, die Dialogfenster verwenden

In diesem Abschnitt werden die generellen Arbeitsschritte für die Erstellung eines Makros beschrieben, das ein Dialogfenster verwendet. Die speziellen Schritte hängen von der Art des Dialogfensters und von der beabsichtigten Funktion des Makros ab.

So erstellen Sie ein Makro, das ein Dialogfenster verwendet:

    1. Starten Sie die Aufzeichnung und verwenden Sie einen Tastaturbefehl zur Anzeige des Dialogfensters oder zur Verlagerung des Fokus in ein bereits geöffnetes Dialogfenster. (Eine Liste dieser Kurzbefehle finden Sie in der Online-Hilfe.)

    2. Drücken Sie Control+Tabulator, um zur ersten Einstellung im Dialogfenster zu gelangen. Durch Drücken von Control+Tabulator wird sichergestellt, dass das Makro immer bei der gleichen Einstellung oder im gleichen Feld mit dem Ausfüllen des Dialogfensters beginnt.

    3. Legen Sie alle wichtigen Einstellungen fest, auch solche, die bereits den korrekten Wert aufweisen. Dadurch ist garantiert, dass das Makro stets auf dieselbe Art und Weise abgespielt wird, unabhängig vom Status des Dialogfensters beim Start des Makros.

Um von einer Einstellung zur nächsten zu gelangen, drücken Sie die Tabulatortaste. Um von einer Einstellung zur vorherigen zu gelangen, drücken Sie Umschalttaste+Tabulator. Eine vollständige Liste der Tastaturbefehle für Dialogfenster finden Sie in der Online-Hilfe.

    4. Drücken Sie die Eingabetaste, um die Einstellungen zu übernehmen und das Dialogfenster zu schließen. Das Drücken der Eingabetaste hat dieselbe Wirkung wie das Klicken auf die Schaltfläche, die momentan den Fokus hat. Wenn das Makro eine andere Schaltfläche aktivieren soll, wechseln Sie mithilfe der Tabulatortaste zur betreffenden Schaltfläche und drücken Sie die Eingabetaste.

    5. Beenden Sie die Aufzeichnung des Makros.

Zur Erstellung eines Makros, das bei der Anzeige eines Dialogfensters seine Ausführung startet oder beendet, zeigen Sie das Dialogfenster wie gewohnt an und drücken Control+], um die Aufzeichnung des Makros zu starten bzw. zu beenden.


UNIX-Makros und -Dienstprogramme / Verwenden von UNIX-Makros

Erstellen sich wiederholender UNIX-Makros

Dieser Abschnitt beschreibt die generellen Arbeitsschritte für die Erstellung von Makros, die entweder so oft ausgeführt werden, wie Sie es festlegen, oder so lange wiederholt werden, bis sie mit Control+c gestoppt werden.

So erstellen Sie ein Makro mit einer festgelegten Anzahl von Ausführungen:

    1. Zeichnen Sie das Makro auf und weisen Sie ihm einen Auslöser zu (siehe Zuweisen eines Makro-Auslösers).

    2. Beginnen Sie mit der Aufzeichnung eines zweiten Makros und drücken Sie bei dessen Aufzeichnung den Auslöser des ersten Makros so oft, wie das erste Makro wiederholt werden soll.

    3. Beenden Sie die Aufzeichnung des Makros.

So erstellen Sie ein Makro, das ununterbrochen ausgeführt wird:

Zeichnen Sie das Makro auf und geben Sie den Auslöser als letzte Anweisung im Makro ein.


UNIX-Makros und -Dienstprogramme

Erstellen von UNIX-Bildschirmaufnahmen

Sie können von jedem rechteckigen Bereich des Bildschirms ein Bild aufnehmen und es als xwd-Datei (X Windows Dump) speichern. Die resultierende Datei kann in jedem Zeichenprogramm bearbeitet werden, das das Bitmap-Format xwd unterstützt. Falls Sie ein Farbbild in Schwarzweiß konvertieren müssen, führen Sie dies vor dem Import aus. Informationen hierzu finden Sie unter Konvertieren von Farbbildern in Schwarzweiß (UNIX). Sobald das Bild aufgenommen ist, können Sie es in FrameMaker importieren (siehe Grafikimport mit dem Befehl "Importieren").

Platzieren Sie das Bild in ein leeres Fenster oder auf eine leere Seite in einem Dokument, damit seine Kanten exakt aufgenommen werden. Lässt sich das Objekt nicht entsprechend verlagern, bearbeiten Sie es in einem Zeichenprogramm. Unerwünschte Bits können in FrameMaker maskiert werden. Dazu zeichnen Sie Objekte mit weißer Füllung und ohne Muster in dem Bereich, der ausgeblendet werden soll (siehe Beschneiden oder Maskieren von Grafiken). Danach nehmen Sie das maskierte Bild erneut auf, um die durchgeführten Änderungen dauerhaft zu übernehmen.

Bildschirmfotos, die Farben enthalten, sind unter Umständen nicht ganz farbgetreu. Beispielsweise könnte die Aufnahme eines blauen Dialogfensters einen dunkleren Blauton zeigen als das Original.

So nehmen Sie in UNIX ein Bild auf:

    1. Positionieren Sie das Bild wie erforderlich.

    2. Wählen Sie "Datei > Dienstprogramme > Kamera" und geben Sie einen Dateinamen und ein Verzeichnis für das Bild an.

    3. Klicken Sie auf "Aufnahme". Nach einer kurzen Pause nimmt der Mauszeiger die Form eines Kreuzes an (+).

    4. Ziehen Sie den Zeiger von einer Ecke zur gegenüberliegenden, bis der Abbildungsrahmen das Bild vollständig umschließt. Wenn Sie die Maustaste loslassen, werden Sie in einer Meldung darüber informiert, dass das Bild aufgenommen wurde.

Ziehen Sie den Abbildungsrahmen auf und lassen Sie die Maustaste los, um das Bild aufzunehmen.

    5. Klicken Sie auf "Fortfahren".

Wenn Sie ein Bild in einer Anwendung aufnehmen, die mit einer anderen Farbpalette arbeitet, können Sie den Zeiger während der in Schritt 3 erwähnten Pause in das Fenster der Anwendung ziehen und so zur entsprechenden Farbpalette wechseln. Wenn Sie die Dauer der Pause ändern wollen, bearbeiten Sie die Ressource Maker.captureDelayTime, wie es im Online-Handbuch Anpassen von FrameMaker-Produkten beschrieben ist. Dieses Handbuch ist unter folgender Adobe-Website verfügbar: www.adobe.com/devnet/framemaker/pdfs/Customizing_Frame_Products.pdf.


UNIX-Makros und -Dienstprogramme

Befehlszeilen-Operationen mit fmbatch (UNIX)

Mit fmbatch lassen sich FrameMaker-Dateien öffnen, drucken, neu formatieren und speichern, ohne dass sie angezeigt werden müssen. Sie können Befehle einzeln (interaktiv) ausführen lassen oder sie in einer Textdatei (einer so genannten Batch-Datei) speichern und sie dann alle mit einem einzigen Befehl aktivieren.


UNIX-Makros und -Dienstprogramme / Befehlszeilen-Operationen mit fmbatch (UNIX)

Starten von fmbatch

Zum Start von fmbatch geben Sie an der Eingabeaufforderung der UNIX-Shell fmbatch gefolgt von optionalen Startoptionen ein (unter Umständen müssen Sie zuerst in das Verzeichnis "$FMHOME/bin" wechseln).

Startoption | Ergebnis
-makername maker | Startet FrameMaker.
-makername structured | Startet den strukturierten FrameMaker.
-noerrorquit | Startet FrameMaker und unterbricht die Ausführung auch bei Auftreten eines Fehlers nicht.
-v | Aktiviert die Echo-Befehle.
Batch-Datei | Führt die Befehle in der Batch-Datei aus (wenn Sie keine Batch-Datei angeben, wird fmbatch im interaktiven Modus gestartet).

Wenn Sie z. B. fmbatch -v -makername maker Befehle.txt eingeben, wird FrameMaker gestartet, und die Befehle in der Datei "Befehle.txt" werden von fmbatch ausgeführt und auf dem Bildschirm angezeigt.

Wenn Sie über die Ressource "Maker.uiLanguage" in der Datei "~/.Xdefaults" eine Sprachvoreinstellung festgelegt haben, verwendet fmbatch diese Sprachversion.


UNIX-Makros und -Dienstprogramme / Befehlszeilen-Operationen mit fmbatch (UNIX)

Verwenden von fmbatch im interaktiven Modus

Verwenden Sie Befehle für weniger häufig ausgeführte Operationen interaktiv (d. h. einzeln).

So verwenden Sie fmbatch interaktiv:

    1. Geben Sie an der Eingabeaufforderung der UNIX-Shell fmbatch ein.

    2. Geben Sie an der Eingabeaufforderung einen fmbatch-Befehl ein (siehe Erläuterung von fmbatch-Befehlen).


UNIX-Makros und -Dienstprogramme / Befehlszeilen-Operationen mit fmbatch (UNIX)

Verwenden von fmbatch im Batch-Modus

Sie können fmbatch-Befehle in einer Textdatei speichern (einer so genannten Batch-Datei) und dann alle Befehle in der Datei gleichzeitig aufrufen. Die Verwendung von Batch-Dateien ist hilfreich, wenn Sie häufig dieselben Operationen ausführen müssen. So könnten Sie beispielsweise eine Batch-Datei für das Öffnen, Drucken und Schließen einer Buchdatei erstellen.

Batch-Dateien können auch aus UNIX-Shell-Skripts erstellt werden. Weitere Informationen finden Sie unter Erstellen von Batch-Dateien aus Skripten.

Wenn Sie eine Batch-Datei im selben Verzeichnis speichern wie die Dateien, die Sie verwenden möchten, müssen Sie in den fmbatch-Befehlen keine Pfadnamen angeben. Andernfalls verwenden Sie entweder absolute oder relative Pfadnamen.

So erstellen Sie eine fmbatch-Batch-Datei:

    1. Erstellen Sie mithilfe eines Texteditors eine Textdatei.

    2. Geben Sie die fmbatch-Befehle in der Reihenfolge ein, in der sie ausgeführt werden sollen. Schreiben Sie jeden Befehl in eine separate Zeile. Geben Sie alle erforderlichen Optionen an. (Eine Liste der verfügbaren Befehle finden Sie unter Erläuterung von fmbatch-Befehlen. Näheres zu den Optionen für bestimmte Befehle enthalten die nachfolgenden Abschnitte.) Zwei spezielle Befehle verdienen besondere Beachtung:

    Um einen Kommentar einzugeben, leiten Sie die Zeile mit einem Nummernzeichen (#) ein.

    Sollen während der Ausführung der Batch-Datei Meldungen am Bildschirm eingeblendet werden, geben Sie echo Meldung ein, wobei Meldung für den Text steht, der angezeigt werden soll.

    3. Speichern Sie die Datei. Wenn Sie die Textdatei mit FrameMaker erstellen, speichern Sie sie im Format "Nur Text".

So verwenden Sie eine Batch-Datei mit fmbatch:

Geben Sie an der Eingabeaufforderung der UNIX-Shell fmbatch -v Batch-Datei ein. Wenn die Befehle in der Batch-Datei während der Ausführung nicht angezeigt werden sollen, lassen Sie die Option -v weg.

Soll fmbatch z. B. eine Batch-Datei mit dem Namen "BuchDruck" ausführen, geben Sie fmbatch -v BuchDruck ein.


UNIX-Makros und -Dienstprogramme / Befehlszeilen-Operationen mit fmbatch (UNIX)

Erläuterung von fmbatch-Befehlen

Die folgende Tabelle enthält alle Befehle, die Sie zusammen mit fmbatch verwenden können. Die Befehle lassen sich im interaktiven Modus oder im Batch-Modus einsetzen.

Befehl | Ergebnis
echo | Gibt Meldungen in die Standard-Fehlerausgabe aus.
help oder ? | Zeigt eine Liste mit fmbatch-Befehlen an.
UseFormatsFrom | Importiert und aktualisiert die Formate in einem geöffneten Dokument oder in allen Dokumenten in einer Buchdatei mit den Formaten aus einem anderen geöffneten Dokument.
Open | Öffnet ein Dokument oder eine Buchdatei.
OpenTextFile | Öffnet eine Textdatei.
ping | Überprüft, ob FrameMaker noch läuft.
Print | Druckt eine geöffnete Datei aus und verwendet dabei die eigenen Einstellungen oder die Druckeinstellungen aus einer anderen geöffneten Datei.
Quit | Schließt eine Datei oder beendet fmbatch.
Save | Speichert eine geöffnete Datei.
SaveAs | Speichert eine geöffnete Datei unter einem anderen Namen oder in einem anderen Format.
system | Führt einen UNIX-Befehl aus.
Update | Aktualisiert Querverweise und generiert alle generierten Dateien in einem geöffneten Buch.

Alle fmbatch-Befehle unterscheiden zwischen Groß- und Kleinschreibung. Auf einige Befehle folgen Dateinamen. Für einige wenige Befehle sind Optionen erforderlich, die in den nachfolgenden Abschnitten erläutert werden.

Wenn Sie in fmbatch-Befehlen Dateinamen angeben, müssen Sie die Dateinamen eventuell mit einfachen oder doppelten Anführungszeichen umschließen. (Wenn der Dateiname einfache Anführungszeichen enthält, umgeben Sie ihn mit doppelten Anführungszeichen und umgekehrt.) Um z. B. eine Datei zu öffnen, deren Name einfache Anführungszeichen enthält, geben Sie Open "Meine Datei 'mit einfachen' Anführungszeichen" ein.


UNIX-Makros und -Dienstprogramme / Befehlszeilen-Operationen mit fmbatch (UNIX)

Öffnen, Speichern und Drucken von Dateien mit fmbatch

Jede Datei, die mit dem FrameMaker-Befehl "Datei > Öffnen" geöffnet werden kann, lässt sich auch mit fmbatch öffnen. Sie müssen fmbatch zum Öffnen der Datei aufrufen, bevor Sie andere fmbatch-Operationen mit dieser Datei ausführen.

Sie können ein geöffnetes Dokument oder eine Buchdatei unter dem bestehenden Dateinamen und im aktuellen Dateiformat speichern oder einen anderen Namen bzw. ein anderes Format verwenden.

Hinweis: Wenn Sie ein Dokument mit fmbatch speichern, werden Sie nicht vor dem Überschreiben einer bereits vorhandenen Datei gewarnt. Die überschriebene Datei erhält das Suffix ".backup".

Sie haben die Möglichkeit, eine mit fmbatch geöffnete Datei mit den eigenen Druckeinstellungen oder mit den Einstellungen eines anderen FrameMaker-Dokuments zu drucken. So können Sie z. B. einen Druckernamen für eine Gruppe von Dokumenten festlegen.

Handelt es sich bei der zu druckenden Datei um eine Buchdatei, druckt fmbatch das gesamte Buch. Wenn Sie eine Buchdatei in eine PostScript-Datei ausgeben, erstellt fmbatch eine einzige große PostScript-Datei.

Zum Ausdrucken von Dateien kann auch fmprint verwendet werden. Weitere Informationen finden Sie unter Drucken mit fmprint (UNIX).

So öffnen Sie eine Datei mit fmbatch:

Führen Sie in einer Batch-Datei oder an der fmbatch-Eingabeaufforderung eine der folgenden Aktionen aus:

    Um ein FrameMaker-Dokument zu öffnen, geben Sie Open Dateiname ein. Geben Sie z. B. Open Kapitel1.fm ein.

    Zum Öffnen einer Textdatei geben Sie OpenTextFile Typ Dateiname ein. Die Option Typ kann folgende Werte annehmen:

    Option "Typ" | Dateityp
a | Eine zeilenorientierte Textdatei (jede Zeile wird als separater Absatz behandelt).
t | Eine absatzorientierte Textdatei (nachfolgende nicht leere Zeilen werden als Teil des Absatzes betrachtet, eine leere Zeile wird als Absatzumbruch interpretiert).

Um z. B. die zeilenorientierte Textdatei "MeineDaten.txt" zu öffnen, geben Sie OpenTextFile a MeineDaten.txt ein.

So speichern Sie eine geöffnete Datei mit fmbatch:

Führen Sie in einer Batch-Datei oder an der fmbatch-Eingabeaufforderung eine der folgenden Aktionen aus:

    Um die Datei unter ihrem aktuellen Namen und in ihrem aktuellen Format zu speichern, geben Sie Save Dateiname ein, z. B. Save Kapitel1.fm.

    Wenn Sie die Datei unter einem anderen Namen oder in einem anderen Format speichern wollen, geben Sie SaveAs Format alterName neuerName ein. Die Option Format kann einen der folgenden Werte annehmen.

    Option "Format" | Ergebnis
d | Speichert im Dokument-Format.
l (kleines L) | Speichert im Viewer-Format.
a | Speichert im zeilenorientierten Textformat.
t | Speichert im absatzorientierten Textformat.
m | Speichert im MIF-Format.
- (Trennstrich) | Speichert im aktuellen Format.

Geben Sie nur eine Formatoption an. Wenn Sie keine Formatoption festlegen, speichert fmbatch die Datei in ihrem aktuellen Format. Für das Speichern einer Buchdatei dürfen die Optionen l, a oder t nicht verwendet werden. Liegt ein Dokument im Viewer-Format vor, können Sie es mit dem Befehl "SaveAs" nicht im Format "Dokument" speichern.

Um beispielsweise das FrameMaker-Dokument "MeinBericht.fm" als MIF-Datei zu speichern, geben Sie SaveAs m MeinBericht.fm MeinBericht.mif ein.

So drucken Sie eine geöffnete Datei mit fmbatch:

Führen Sie in einer Batch-Datei oder an der fmbatch-Eingabeaufforderung eine der folgenden Aktionen aus:

    Um eine Datei unter Verwendung ihrer Druckeinstellungen zu drucken, geben Sie Print Dateiname ein.

    Wenn Sie eine Datei mit den Druckeinstellungen eines anderen FrameMaker-Dokuments drucken wollen, geben Sie Print Dateiname Einstellungsdatei ein. (Zur Festlegung oder Änderung der Druckeinstellungen im Dokument Einstellungsdatei öffnen Sie ein Dokument (es kann auch ein neues, leeres Dokument sein), wählen Sie "Datei > Drucken", geben Sie die gewünschten Einstellungen ein und klicken Sie auf "Einstellungen sichern". Danach speichern Sie das Dokument.)

Um beispielsweise die Datei "MeinBericht.fm" mit den Druckeinstellungen des Dokuments "DruckInDuplex.fm" zu drucken, geben Sie Print MeinBericht.fm DruckInDuplex.fm ein.


UNIX-Makros und -Dienstprogramme / Befehlszeilen-Operationen mit fmbatch (UNIX)

Aktualisieren von Dateien mit fmbatch

Sie können alle Querverweise in einem Dokument oder Buch, das mit fmbatch geöffnet wurde, aktualisieren. Bei der Aktualisierung eines Buchs generiert fmbatch auch alle generierten Dateien des Buchs neu.

Wenn Sie zur Aktualisierung und Generierung von Dateien eine Batch-Datei verwenden (siehe Verwenden von fmbatch im Batch-Modus), beendet fmbatch die Ausführung, sobald ein Fehler auftritt, beispielsweise ein ungelöster Querverweis oder eine fehlende Datei. Sie können dieses Verhalten unterdrücken, indem Sie fmbatch mit der Option -noerrorquit starten.

Sie können die Formate in ein Dokument oder in alle Dateien eines Buchs importieren und dort aktualisieren. Zu diesem Zweck öffnen Sie zunächst mit fmbatch die Dokumente oder das Dokument und das Buch (Ziel und Quelle für den Import der Formate).

So aktualisieren und generieren Sie Dateien mit fmbatch:

Geben Sie in einer Batch-Datei oder an der fmbatch-Eingabeaufforderung Update Dateiname ein. Um beispielsweise die Dateien in "Referenz.book" zu aktualisieren und zu generieren, geben Sie Update Referenz.book ein.

So importieren Sie Formate mit fmbatch:

Geben Sie in einer Batch-Datei oder an der fmbatch-Eingabeaufforderung ImportFormats Optionen Dateiname Formatdatei ein. Die Option Optionen kann folgende Werte annehmen.

Optionen | Ergebnis
p | Importiert Absatzformate.
f | Importiert Zeichenformate.
l (kleines L) | Importiert Seitenlayouts (Vorgabeseiten).
c | Importiert Querverweisformate.
v | Importiert Variablendefinitionen.
r | Importiert Referenzseiten.
t | Importiert Tabellenformate.
x | Importiert Einstellungen für bedingten Text.
k | Importiert Farbdefinitionen.
m | Importiert FrameMath-Definitionen.
i | Importiert kombinierte Schriften (nur für japanische Dokumente).
d | Importiert Dokumenteinstellungen.
B | Behält manuelle Seitenumbrüche bei.
O (großes O) | Behält andere Formate und irreguläre Layouts bei.

Wenn Sie keine Optionen angeben, importiert fmbatch alle Formate. Die Optionen entsprechen den Einstellungen des Befehls "Datei > Importieren > Formate". Informationen über die Einstellungen finden Sie unter Einstellungen für Import und Aktualisierung.

Wenn Sie z. B. die Absatz- und Zeichenformate aus "Schablone.fm" in "Kapitel2.fm" importieren und dabei die manuellen Seitenumbrüche aufrechterhalten wollen, geben Sie ImportFormats pfB Kapitel2.fm Schablone.fm ein.


UNIX-Makros und -Dienstprogramme / Befehlszeilen-Operationen mit fmbatch (UNIX)

Schließen von Dateien und Beenden von fmbatch

Wenn Sie eine Datei schließen und fmbatch beenden, überprüft das Programm nicht, ob Sie die durchgeführten Änderungen gespeichert haben. Dies liegt in Ihrer eigenen Verantwortung.

So schließen Sie eine Datei oder beenden fmbatch:

Führen Sie in einer Batch-Datei oder an der fmbatch-Eingabeaufforderung eine der folgenden Aktionen aus:

    Um eine Datei zu schließen, geben Sie Quit Dateiname ein. Um z. B. "Kapitel2.fm" zu schließen, geben Sie Quit Kapitel2.fm ein.

    Um fmbatch zu beenden, geben Sie Quit ein.


UNIX-Makros und -Dienstprogramme / Befehlszeilen-Operationen mit fmbatch (UNIX)

UNIX-Befehle und fmbatch

Sie können in fmbatch alle UNIX-Befehle verwenden. So können Sie z. B. Dateien nach ihrer Bearbeitung kopieren oder verschieben.

So verwenden Sie einen UNIX-Befehl mit fmbatch:

Geben Sie in einer Batch-Datei oder an der fmbatch-Eingabeaufforderung system "Befehl " ein. Der Befehl muss in einfachen oder doppelten Anführungszeichen stehen.

Um beispielsweise "MeineDatei.fm" nach /tmp zu kopieren, geben Sie system "cp MeineDatei /tmp/MeineDatei" ein.


UNIX-Makros und -Dienstprogramme / Befehlszeilen-Operationen mit fmbatch (UNIX)

Erstellen von Batch-Dateien aus Skripten

Durch die Einbindung von fmbatch in Shell-Skripte lassen sich einige FrameMaker-Operationen automatisieren. So könnte z. B. ein Shell-Skript mithilfe von fmbatch eine Buchdatei generieren, alle Dokumente im Format MIF speichern, die MIF-Dateien so bearbeiten, dass Fenstergröße und Fensterposition des Dokuments eingestellt werden und die MIF-Dateien anschließend wieder in das Format "Dokument" konvertieren.

Mit UNIX-Skripten lassen sich außerdem fmbatch-Batch-Dateien generieren. Das folgende Beispiel ist ein C-Shell-Skript für die Erstellung einer Batch-Datei, die alle Dokumente als MIF-Dateien speichert. Wenn Sie dieses Skript einsetzen wollen, geben Sie es genau so ein wie im Beispiel. Wechseln Sie dann in das Verzeichnis, das die zu verarbeitenden Dateien enthält, und geben Sie den vollständigen Pfad zum Skript ein. Das Skript erstellt im aktuellen Verzeichnis eine Batch-Datei, die Sie mit fmbatch verwenden können.

#! /bin/csh -f
set scriptname = createbatch
set batchfile = commands.batch
rm -f $batchfile >& /dev/null
touch $batchfile
foreach f ( * )
  # keine Verzeichnisse oder die Batch-Datei selbst hinzufügen
  if ( ! -d "$f" && "$f" != "$batchfile" ) then
    echo "Open $f" >> $batchfile
    echo "echo Saving $f to $f.mif" >> $batchfile
    echo "SaveAs m $f $f.mif" >> $batchfile
    echo "Quit $f" >> $batchfile
  endif
end
echo ""
echo "$scriptname is done. "


UNIX-Makros und -Dienstprogramme

Drucken mit fmprint (UNIX)

Mit dem Skript fmprint können Sie ein oder mehrere FrameMaker-Dokumente oder Bücher drucken, ohne diese zu öffnen oder anzuzeigen. Dabei lassen sich Druckeinstellungen aus einem anderen FrameMaker-Dokument verwenden, wie dies auch beim Befehl "Drucken" von fmbatch möglich ist (siehe Öffnen, Speichern und Drucken von Dateien mit fmbatch).

So drucken Sie eine Datei mit fmprint:

Führen Sie an der Eingabeaufforderung der UNIX-Shell eine der folgenden Aktionen aus:

    Um eine Datei mit den eigenen Druckeinstellungen zu drucken, geben Sie fmprint Dateiname ein.

    Wenn Sie eine Datei mit den Druckeinstellungen eines anderen FrameMaker-Dokuments drucken wollen, geben Sie fmprint -p Einstellungsdatei Dateiname ein. (Zur Einstellung oder Änderung der Druckeinstellungen im Dokument Einstellungsdatei öffnen Sie das Dokument, wählen Sie "Datei > Drucken", geben Sie die gewünschten Einstellungen ein und klicken Sie auf "Einstellungen sichern". Danach speichern Sie das Dokument.)


UNIX-Makros und -Dienstprogramme

Kopieren von Verzeichnisstrukturen mit fmcopy (UNIX)

Das Skript fmcopy kopiert eine Verzeichnisstruktur von einem Verzeichnis in ein anderes und behält dabei die symbolischen Verweise und die Berechtigungen bei. Verwenden Sie dieses Skript, wenn Sie FrameMaker-Installationsdateien von einem Dateisystem in ein anderes kopieren wollen.

So kopieren Sie eine Verzeichnisstruktur:

Geben Sie an der Eingabeaufforderung der UNIX-Shell fmcopy Quellverzeichnis Zielverzeichnis ein, wobei Quellverzeichnis für das Verzeichnis steht, das kopiert werden soll, und Zielverzeichnis das Verzeichnis angibt, in das kopiert werden soll.

Um beispielsweise die FrameMaker-Installationsdateien von /var/frame nach /var/FrameMaker zu kopieren, geben Sie fmcopy /var/frame /var/FrameMaker ein.

Wenn Sie Anweisungen zur Verwendung von fmcopy am Bildschirm sehen wollen, geben Sie an der Eingabeaufforderung der UNIX-Shell fmcopy ein.


UNIX-Makros und -Dienstprogramme

Invertieren von Bildern mit fminvert (UNIX)

Mit fminvert können Sie eine monochrome Sun-Rasterdatei oder ein 1-Bit-xwd-Bild (X Windows Dump) invertieren, sodass ursprünglich schwarze Bereiche weiß angezeigt werden (oder umgekehrt).

So invertieren Sie ein Bild:

Geben Sie an der Eingabeaufforderung der UNIX-Shell fminvert Dateiname invertierte_Datei ein, wobei Dateiname für die Datei steht, die invertiert werden soll, und invertierte_Datei den Namen der invertierten Datei angibt.


UNIX-Makros und -Dienstprogramme

Konvertieren von Farbbildern in Schwarzweiß (UNIX)

Mit xwd8to1 lassen sich farbige X11 xwd-Bilder in Schwarzweißbilder konvertieren. (Mit der Funktion für die Aufnahme von Bildschirmfotos können Sie xwd-Bilder erstellen. Einzelheiten finden Sie unter Erstellen von UNIX-Bildschirmaufnahmen.)

Jede Farbe wird entweder in Schwarz oder in Weiß konvertiert. Die Konvertierung wird über einen Cutoff-Wert gesteuert, der zwischen 1 und 100 liegt. Der Wert legt die Intensität fest, bei der Farben in Schwarz konvertiert werden sollen. Bei einem Intensitätswert von 1 wird nur Schwarz in Weiß konvertiert. Bei einem Intensitätswert von 99 werden alle Farben, mit Ausnahme von Weiß, in Schwarz konvertiert. Wenn Sie keinen Cutoff-Wert angeben, verwendet xwd8to1 einen Wert von 50.

So konvertieren Sie ein farbiges xwd-Bild in ein Schwarzweißbild:

Geben Sie an der Eingabeaufforderung der UNIX-Shell xwd8to1 -i Cutoff Dateiname Dateiname.mono ein, wobei Dateiname der Name des Farbbildes, Cutoff der Cutoff-Wert für die Konvertierung von Farben in Schwarz oder Weiß und Dateiname.mono der Name der konvertierten Datei ist.


Erstellen von zugänglichen Dokumenten (Windows)

Dokumenterstellung unter Berücksichtigung der Zugänglichkeit

Verwenden von Zugänglichkeitsfunktionen in FrameMaker

Einrichten des FrameMaker-Arbeitsbereichs für die Anzeige mit hohen Kontrastwerten

Vorbereiten von Dokumenten unter Berücksichtigung der Zugänglichkeit

Testen der Zugänglichkeit in Dateien mit einem Screen Reader


Erstellen von zugänglichen Dokumenten (Windows)

Dokumenterstellung unter Berücksichtigung der Zugänglichkeit

Bei der Veröffentlichung eines Dokuments in HTML, Adobe PDF oder einem anderen Format ist zur Erstellung zugänglicher Dokumente bei weitem mehr notwendig als die akkurate Wiedergabe des Originaldokuments. Personen ohne Sehbehinderung können auf einer ausgedruckten Seite ohne weiteres zwischen Überschriften, Unterüberschriften, Textspalten, Kopf- und Fußzeilen usw. unterscheiden. Durch visuelle Merkmale, wie die Position des Textes auf der Seite, die Verwendung von Fettdruck oder großen Schriftgraden, können sie die Struktur des Dokuments so erfassen, dass die Orientierung im Dokument und das Lesen des Dokuments keine Schwierigkeiten bereitet.

Unterstützende Technologien wie Screen Reader können nicht auf der Grundlage solcher visueller Merkmale arbeiten. Hier müssen die zu Grunde liegenden computerbasierten Informationen verwendet werden, um die strukturellen Merkmale des Dokuments wiederzugeben. Die Zugänglichkeit des Dokuments basiert damit auf zwei Voraussetzungen:

    Die Originaldokumente müssen so erstellt werden, dass nicht nur inhaltliche (z. B. der Text eines Dokuments), sondern auch strukturelle Informationen (z. B. der Textfluss innerhalb der Seite und zwischen den Seiten) enthalten sind.

    Damit Inhalt und Struktur so beibehalten und verschlüsselt werden, dass Windows-basierte Screen Reader diese Informationen interpretieren können, müssen Veröffentlichungswerkzeuge wie Adobe FrameMaker-Software und die Adobe PDF-Technologie verwendet werden.

Diese Voraussetzungen müssen unabhängig von Dateiformat und Anwendung in allen Veröffentlichungsumgebungen erfüllt sein. Wenn Sie gewährleisten wollen, dass Benutzer von Screen Reader-Software richtig durch Dokumente navigieren können, müssen die zu Grunde liegenden strukturellen Informationen verfügbar sein.


Erstellen von zugänglichen Dokumenten (Windows)

Verwenden von Zugänglichkeitsfunktionen in FrameMaker

Die FrameMaker-Software enthält eine Reihe von Funktionen, die die Zugänglichkeit für sehbehinderte Personen verbessern. Ganz konkret sind das:

    Unterstützung der Anzeige mit hohen Kontrastwerten für Benutzer mit geringer Sehschärfe.

    Erstellung von mit Tags versehenen Adobe PDF-Dateien bei der Konvertierung von FrameMaker-Dateien in Tagged PDF-Dateien. Dadurch wird Personen, die Screen Reader verwenden, das Navigieren durch Dokumente in der richtigen Lesefolge erleichtert. Weitere Informationen zur Umwandlung von FrameMaker-Dokumenten in Tagged Adobe PDF-Dateien finden Sie unter Definieren einer Tagged Adobe PDF-Datei.

    Unterstützung von Technologien wie Screen Reader-Software für die Windows-Plattform.

Screen Reader-Software ermöglicht sehbehinderten Benutzern die Interaktion mit dem Computer, indem sie das Bildschirmgeschehen interpretiert und diese Informationen dann an Sprachsynthesegeräte sendet. Dabei folgt der Screen Reader der logischen Struktur des Dokuments. Screen Reader können in FrameMaker angezeigte FrameMaker-Dokumente oder in Adobe Acrobat 7.0 oder Acrobat Reader 7.0.7 angezeigte Tagged PDF-Dokumente auslesen. Weitere Informationen zu Installation und Verwendung in Verbindung mit in FrameMaker oder Acrobat angezeigten Dokumenten finden Sie in Ihrer Screen Reader-Dokumentation.

Weitere Informationen zur Zugänglichkeit in Adobe Acrobat und Adobe PDF-Dokumenten finden Sie in der Online-Hilfe zu Acrobat und auf der Website von Adobe.

Hinweis: UNIX stellt keine allgemeine Schnittstelle für Screen Reader-Software für die Verbesserung der Zugänglichkeit zur Verfügung.


Erstellen von zugänglichen Dokumenten (Windows)

Einrichten des FrameMaker-Arbeitsbereichs für die Anzeige mit hohen Kontrastwerten

In Adobe FrameMaker werden für den Hintergrund der Fenster, für Text und Grafiken Systemfarben verwendet. Benutzer mit Problemen bei der Farbunterscheidung und der Erkennung von Kontrasten oder Benutzer mit geringer Sehschärfe können Farbschemata mit besonders hohen Kontrastwerten einrichten und die Farben für Text und Hintergrund so anpassen, dass die Informationen auf der Oberfläche von FrameMaker leichter erkennbar sind. Darüber hinaus können neben den in FrameMaker integrierten Mauszeigern benutzerdefinierte Systemzeiger verwendet werden. Die Benutzer können die Systemeinstellungen als ihre Anwendungsstandards einstellen.

So richten Sie FrameMaker für die Anzeige hoher Kontrastwerte ein:

    1. Rufen Sie die Windows-Systemsteuerung auf.

    2. Öffnen Sie unter Windows die Seite, auf der die Darstellung der Bildschirmelemente festgelegt wird.

    3. Führen Sie einen der folgenden Schritte aus:

    Um die Anzeige aller veränderbaren Elemente der Benutzeroberfläche gleichzeitig zu ändern, wählen Sie eine Schema-Option, z. B. eine der Optionen für hohe Kontraste.

    Um die Anzeige eines einzelnen Schnittstellenelements zu ändern, wählen Sie das Element aus und ändern dann die entsprechenden Einstellungen.

    4. Klicken Sie auf "Zuweisen".

Damit werden Farbe und Größe von Schnittstellenelementen wie Schnellzugriffsleiste, Titelleisten, Menüs, Rollbalken, Dialogfenstern, Paletten, Linealen, Rastern und Symbolen innerhalb der Fensterbegrenzungen in FrameMaker angepasst.

Wichtig: Farbe und Größe können in FrameMaker jedoch nicht für alle Elemente angepasst werden. Dazu gehören u. a. Hintergrundfarbe und Schriftart der Titelleisten in bestimmten Paletten (z. B. "Gleichungen") oder die Füllfarben für Grafikobjekte.

So verwenden Sie benutzerdefinierte Zeiger:

    1. Durchsuchen Sie nach der Installation von FrameMaker den Ordner "FrameMaker 8" nach der Datei "maker.ini".

    2. Öffnen Sie die Datei maker.ini in einem Texteditor.

    3. Ändern Sie den Wert von "UseSystemCursor" in "On".

    4. Speichern Sie die Datei "maker.ini" und starten Sie FrameMaker erneut.


Erstellen von zugänglichen Dokumenten (Windows)

Vorbereiten von Dokumenten unter Berücksichtigung der Zugänglichkeit

Unter Windows können Screen Reader sowohl FrameMaker-Dokumente als auch Tagged Adobe PDF-Dokumente lesen.

Zur Erstellung eines zugänglichen FrameMaker- oder Tagged PDF-Dokuments muss der Aspekt der Zugänglichkeit bei allen Arbeitsschritten bedacht werden. Es folgen einige Anhaltspunkte zur Optimierung der Zugänglichkeit der FrameMaker-Dokumente und zur Verbesserung ihrer Lesbarkeit durch Screen Reader-Software:

Logische Lesefolge

Die Zugänglichkeit von Dokumenten verbessert sich, wenn bei der Erstellung auf einen logischen Aufbau geachtet wurde. Durch die Verwendung von FrameMaker bei der Definition und Erstellung der Dokumentstruktur, wie z. B. Titel, Kapitel, Überschriften und mehrspaltiger Text, wird unterstützenden Technologien wie Screen Reader-Software die eindeutige Erkennung der logischen Lesefolge des Inhalts erleichtert. Wenn ein Tagged Adobe PDF-Dokument beispielsweise im zweispaltigen Format richtig mit zwei Spalten erstellt wurde, liest der Screen Reader erst die erste Spalte bis zum Ende und fährt dann mit der zweiten Spalte fort. Wenn der Autor des Dokuments hingegen das zweispaltige Textformat mithilfe der Tabulatortaste imitiert hat, wird das Layout vom Screen Reader nicht als zweispaltig erkannt. Die Software setzt den Lesevorgang in diesem Fall einfach in horizontaler Richtung fort, d. h. sie beginnt mit der ersten Zeile der ersten Spalte und springt dann zur ersten Zeile der zweiten Spalte.

Die Reihenfolge, in der Sie Rahmen im FrameMaker-Originaldokument erstellen, ist auch die Reihenfolge, die im logischen Strukturbaum Ihrer Tagged Adobe PDF-Datei wiedergegeben wird. Wenn Sie also Rahmen im FrameMaker-Layout verschieben, werden die Rahmen in der Struktur der Tagged Adobe PDF-Datei trotzdem in der Reihenfolge ihrer Erstellung angezeigt. Um Probleme mit der Lesefolge zu beheben, verwenden Sie die Werkzeuge aus Acrobat 7.0.

Hinweis: Unter Umständen können Screen Reader in FrameMaker angezeigten mehrspaltigen Text nicht richtig lesen. Wenn die FrameMaker-Dokumente von der Screen Reader-Software in FrameMaker gelesen werden sollen, verwenden Sie ein einspaltiges Format, oder speichern Sie das Dokument als Tagged PDF-Datei.

Alternative Textbeschreibungen für grafische Objekte

Das Dokument sollte schriftliche Beschreibungen der Grafikobjekte, einschließlich der Initialen, enthalten. Bei diesen Grafikobjekten muss es sich um verankerte Rahmen handeln. Wenn ein Screen Reader im Dokument auf eine Grafik stößt, wird der alternative Text gelesen. Achten Sie darauf, dass der verwendete Text auch ohne Kontext einen Sinn ergibt. Sie können beispielsweise einen alternativen Text hinzufügen, der mit den Worten "Eine Grafik zur Darstellung" beginnt und dann beschreiben, was die Grafik darstellt. Weitere Informationen zum Hinzufügen von alternativem Text finden Sie unter Vorbereiten verankerter Rahmen für Tagged PDF.

Schriften

Achten Sie darauf, Schriftarten mit Zeichencodierung zu verwenden, sodass Anzeige und Screen Reader die richtigen Zeichen übermitteln. Weitere Informationen hierzu finden Sie im Online-Handbuch FrameMaker-Zeichensätze.

Navigation

Das Dokument sollte Navigations- und Organisationshilfen enthalten, z. B. ein Inhaltsverzeichnis und geeignete Überschriften. Dadurch können Benutzer sich mühelos durch das Dokument bewegen und müssen nicht erst jede einzelne Seite lesen, bevor Sie die gesuchten Informationen finden.


Erstellen von zugänglichen Dokumenten (Windows)

Testen der Zugänglichkeit in Dateien mit einem Screen Reader

Bevor Sie eine FrameMaker-Datei oder eine Tagged PDF-Datei Benutzern zur Verfügung stellen, sollten Sie sie selbst mit einem Screen Reader testen. Dadurch erleben Sie, wie die Informationen des Dokuments den Benutzern tatsächlich dargeboten werden und wie gut Lesefolge und Navigationsverknüpfungen funktionieren.

Wenn Sie Fehler in einer Tagged PDF-Datei finden, nehmen Sie die erforderlichen Korrekturen möglichst in der ursprünglichen FrameMaker-Datei vor und speichern diese dann erneut als Tagged PDF-Datei. Dadurch muss zur Veröffentlichung des Inhalts in weiteren Formaten, wie XML, SGML, XHTML usw., nur eine Quelldatei verwaltet werden.

Wenn Sie Acrobat 7.0 installiert haben, können Sie für Korrekturen an der Struktur und der Lesefolge der Tagged PDF-Datei Acrobat-Werkzeuge verwenden. In diesem Fall werden die Änderungen jedoch nicht in der FrameMaker-Datei, sondern lediglich in der PDF-Datei gespeichert. Weitere Informationen zu Zugänglichkeitswerkzeugen in Acrobat finden Sie in der Online-Hilfe zu Acrobat oder auf der Website von Adobe.

So testen Sie die Zugänglichkeit von Dateien mit Screen Reader-Software:

    1. Starten Sie einen Screen Reader für Windows. Informieren Sie sich in der Datei "Installationsanleitung" (Windows), welche Screen Reader unterstützt werden.

    2. Führen Sie dem Dateityp entsprechend die Aktionen aus, die für das Lesen der FrameMaker-Datei bzw. der Tagged PDF-Datei erforderlich sind:

    Starten Sie FrameMaker und öffnen Sie die FrameMaker-Datei.

    Starten Sie Acrobat und öffnen Sie die Tagged Acrobat PDF-Datei.

    3. Setzen Sie den Screen Reader zum Lesen des Dokuments ein.

    4. Überprüfen Sie den Vorgang auf mögliche Fehler, wie z. B.:

    Das Dokument enthält Grafiken, für die keine Textbeschreibungen vorhanden sind. Öffnen Sie zur Behebung dieses Fehlers das ursprüngliche Dokument in FrameMaker und stellen Sie sicher, dass die Grafiken in Rahmen verankert sind. Wählen Sie anschließend die einzelnen Grafiken aus, wählen Sie "Grafik > Objekteinstellungen > Objektattribute" und geben Sie eine alternative Textbeschreibung ein.

    Der in Spalten enthaltene Text wird nicht in der richtigen Reihenfolge gelesen. Überarbeiten Sie zur Behebung dieses Fehlers die Lesefolge der Elemente im logischen Strukturbaum der Tagged Adobe PDF-Datei. Verwenden Sie dazu die Tag-Palette in Acrobat 7.0.


Strukturiertes Authoring mit DITA

Einführung

DITA in FrameMaker 8

Verwenden von DITA in FrameMaker 8

Tipps


Strukturiertes Authoring mit DITA

Einführung

XML-Authoring (Extensible Markup Language) bietet verschiedene Vorteile für publizierende Unternehmen, wie beispielsweise die Wiederverwendung von Inhalten, die Ausgabe von Dokumenten auf verschiedenen Kanälen und den standardbasierten Informationsaustausch. Darwin Information Typing Architecture (DITA) ist eine spezielle Form von XML-Authoring, die im Bereich der technischen Dokumentation zu grundlegenden Änderungen führen kann.

In FrameMaker wurden die Möglichkeiten für XML-Authoring durch Hinzufügen der Adobe FrameMaker DITA-Funktion erweitert. Wenn Sie bereits mit den Grundlagen von DITA vertraut sind und mehr über die Verwendung von DITA in FrameMaker erfahren möchten, finden Sie weitere Informationen unter DITA in FrameMaker 8.

Bei einem Übergang zu strukturiertem Authoring müssen sich Unternehmen überlegen, welche DTD (Document Type Definition) oder welches Schema verwendet werden soll. In XML und den entsprechenden Authoring- und Veröffentlichungswerkzeugen wie Adobe FrameMaker definiert die DTD oder das Schema die grundlegende Struktur des Inhalts.

Einige Unternehmen erstellen eigene DTDs oder Schemata, während andere vorhandene nutzen (z. B. Text Encoding Initiative, DocBook oder DITA). Faktoren wie der Typ des verwalteten Inhalts und die Anforderungen an die Inhaltsbereitstellung sind für die Auswahl eines Unternehmens entscheidend.


Strukturiertes Authoring mit DITA / Einführung

Was ist unter DITA zu verstehen?

Wie bereits anhand des Namens ersichtlich ist DITA (Darwin Information Typing Architecture) eine Informationsarchitektur. DITA wird hauptsächlich durch DTDs und entsprechende Schemata definiert, die von OASIS (Organization for the Advancement of Structured Information Standards) verwaltet werden. OASIS ist eine nicht gewinnorientierte Organisation, die sich mit der Verwaltung von E-Business-Standards beschäftigt. DITA wird von einer ständig steigenden Anzahl von Open Source-, kommerziellen Software- und Zusatzprodukten unterstützt, die Benutzern das Erstellen und die Ausgabe von Inhalten unter Verwendung des DITA-Modells ermöglichen.

DITA ist mehr als nur ein Schema oder eine DTD. DITA ist eine innovative Philosophie und Methodik für das Authoring und die Verwaltung von Inhalten. Mit DITA wird ein Dokument nicht von Anfang bis Ende geschrieben, sondern es werden Komponenten, sogenannte "Topics" (Themen), angelegt, die einzeln fertig gestellt und nach Bedarf mithilfe einer DITA Map zusammengeführt werden. Dabei kann je nach Ausgabeform oder Zielgruppe eine andere Reihenfolge oder Hierarchie verwendet werden. DITA bietet eine Reihe solcher Mechanismen, die kombiniert werden, um die Wiederverwendung von Inhalten und Veröffentlichung von Dokumenten auf verschiedenen Kanälen zu vereinfachen.


Strukturiertes Authoring mit DITA / Einführung

Überblick über die DITA-Geschichte

Ende der 90er Jahre stiegen mit zunehmender Beliebtheit des Internets und der immer schnelleren technologischen Entwicklung auch die Anforderungen an die Verwaltung der technischen Dokumentation:

    Steigender Bedarf der Veröffentlichung von Dokumenten auf verschiedenen Kanälen: Zuvor ausschließlich in Buchform ausgegebene Inhalte mussten nun auch in HTML (Hypertext Markup Language) und anderen Ausgabeformaten bereitgestellt werden. Lokalisierungsanforderungen erhöhten die Anzahl der lieferbaren Inhalte.

    Kürzere Entwicklungszyklen: Software-Dokumentation musste schneller aktualisiert und veröffentlicht werden, um mit der Aktualisierung der Software Schritt zuhalten.

    Erhöhter Bedarf an angepassten und versionierten Inhalten: Da immer mehr Technologien als modulare Lösungen verkauft wurden, wuchs der Bedarf an aus modularen Komponenten dynamisch zusammengestellten Informationen.

    Erhöhter Bedarf an Informationen auf Anforderung: Aufgrund der steigenden Nutzung von Online-Informationen konnten Unternehmen nicht mehr davon ausgehen, dass Benutzer Handbücher von vorne bis hinten durchlesen. Stattdessen erwarteten Benutzer, genau die Informationen abrufen zu können, die sie zu einem bestimmten Zeitpunkt benötigten.

    Erhöhter Bedarf an Hyperlinks und Querverweisen: Aufgrund der im Internet gängigen Hyperlinks wurden die Beziehungen zwischen den Informationseinheiten in der technischen Dokumentation immer wichtiger.

Einer der Vorreiter im Bereich des strukturierten Authoring war IBM. Das Unternehmen entwickelte eine eigene DTD und war eines der ersten, das SGML auf breiter Basis nutzte. Doch dadurch waren längst nicht alle Probleme gelöst. Die im Laufe mehrerer Jahre entwickelten Informationsstrukturen entsprachen nicht immer den neuen Formaten für lieferbare Inhalte. Die Dokumentarchitektur orientierte sich häufig hauptsächlich an einer Buchform, die eine modulare Ausgabe wie bei kompilierten Hilfe- oder HTML-Dokumenten nicht vollständig unterstützte. Die in einigen Fällen äußerst umfangreichen und komplexen DTDs führen zu einer deutlichen Verlängerung der Einarbeitungszeit für technische Redakteure.

Glücklicherweise wuchsen durch das Internet nicht nur die Ausgabeanforderungen, sondern es standen auch neue Werkzeuge zum Bewältigen dieser Anforderungen zur Verfügung. Neue Technologien wie XML, XSLT (Extensible Style Language Transformation) und Java kamen auf, während IBM mit den Schwierigkeiten der Informationsverwaltung kämpfte. Angesichts der neuen Herausforderungen und Werkzeuge erschien ein Umdenken in Bezug auf die Ausgabe von technischer Dokumentation sinnvoll.

Ab 1999 entwickelte eine unternehmensübergreifende Arbeitsgruppe, die u. a. aus Vertretern von IBM, Lotus und Tivoli bestand, die DITA-Dokumentarchitektur. Diese Architektur ging über die Definition einer Inhaltsstruktur hinaus und enthielt Vorschriften zu Authoring-Techniken und Werkzeugfunktionen. Der neue Standard wurde von einem IBM-Team ins Leben gerufen, "The Darwin Information Typing Architecture" genannt und im April 2001 der Öffentlichkeit über die DeveloperWorks-Website von IBM präsentiert. Umfangreiche Aktualisierungen führten danach zur Veröffentlichung des DITA Open Toolkit, einem Satz von Open Source-Werkzeugen für DITA.

Im März 2004 wurde der neue Standard von OASIS übernommen. Seither entwickelte sich das DITA-Projekt ständig weiter, da immer mehr Unternehmen die Vorteile eines offenen Standards nutzen, der zahlreiche Probleme der letzen zehn Jahre löst.


Strukturiertes Authoring mit DITA / Einführung

Frühe Anwendung von DITA bei Adobe

Zu den ersten Unternehmen, die DITA einsetzten, gehörte auch Adobe, deren Schulungsabteilung ähnliche Schwierigkeiten wie IBM zu bewältigen hatte. Adobe musste nicht nur eine umfangreiche Dokumentation verwalten, sondern diese zur globalen Bereitstellung auch übersetzen und lokalisieren.

Mit immer kürzeren Software-Entwicklungszyklen wurden Übersetzung und Lokalisierung zu potenziellen Engpässen für große Software-Unternehmen wie Adobe. Die Verbesserungen in Bezug auf die Übersetzungseffizienz waren ein Hauptgrund für die Verwendung von DITA zur Verwaltung von Hilfeinhalten. Der modulare, auf Topics basierende Aufbau von DITA und der Schwerpunkt der Inhaltswiederverwendung bedeuteten, dass wiederverwendete Komponenten nur einmal übersetzt und lokalisiert werden mussten. Die Komponenten konnten auch wiederverwendet und in verschiedenen Formaten ausgegeben werden, was zur Beschleunigung und zu Kosteneinsparungen bei der Lokalisierung führte.

Die Schulungsabteilung von Adobe verwaltete alle Hilfeinhalte für Adobe Creative Suite® 2 mit DITA und erstellte sie in FrameMaker. DITA führte nicht nur zu einer schnelleren und kostengünstigeren Lokalisierung, sondern auch zur Entwicklung einer Reihe von Produkten wie Adobe Creative Suite: Gemeinsame Inhaltskomponenten brauchten nicht neu geschrieben zu werden, sondern konnten wiederverwendet werden. Der Erfolg dieser ersten DITA-Implementierung führte dazu, dass Adobe DITA-Authoring auch bei anderen Software-Dokumentationsprojekten einsetzte.

Adobe begann auch, DITA in FrameMaker zu integrieren. Mit FrameMaker 7.2 veröffentlichte Adobe ein Starter Kit für DITA mit einer grundlegenden Unterstützung von DITA-Strukturen. Mit der Einführung von Adobe FrameMaker 7.2 Application Pack for DITA wurde diese Unterstützung auf umfangreiche DITA-Funktionen erweitert. In FrameMaker 8 ist DITA eine integrierte Komponente der Anwendung.

DITA ist in Adobe FrameMaker 8 über das bereits in FrameMaker 7.2 eingeführte gleichnamige Menü verfügbar.

Im folgenden Abschnitt werden die wichtigsten DITA-Funktionen von FrameMaker beschrieben.

Import/Export

Tabellenunterstützung. Analysiert die Datei vor dem Importieren, um die Anzahl der Tabellenspalten ohne Spaltenzahlattribut (in FrameMaker zur Anzeige einer Tabelle erforderlich) festzustellen. Standardmäßig werden Reltable- und Simpletable-Elemente unterstützt, die Unterstützung kann jedoch auf andere vom Benutzer (in "ditafm.ini") angegebene Tabellenelemente erweitert werden. Die Daten zur Spaltenzahl werden beim Importieren der Datei in FrameMaker verwendet, um diese Tabellen ordnungsgemäß anzuzeigen. Der Benutzer kann diese Funktion mit dem Befehl "Optionen" aktivieren oder deaktivieren.

Indexterm-Unterstützung

Beim Importieren wandelt das Plug-In Indexterm-Elemente in ein FrameMaker-kompatibles Format um. Nach DITA müssen Untereinträge im Index als verschachtelte Indexterm-Elemente definiert werden. Diese Funktion führt verschachtelte Indexterm-Elemente zu einer einzigen, durch Semikolons begrenzten Zeichenfolge im obersten Indexterm-Element zusammen, die von FrameMaker ordnungsgemäß interpretiert und in eine Indexmarke umgewandelt wird. Durch diese Funktion kann der Wert des Klassenattributs für spezielle Instanzen des Indexterm-Elements angewendet werden. Beim Exportieren werden Indexmarken wieder in gültige, verschachtelte Indexterm-Elemente umgewandelt. Der Benutzer kann diese Funktion mit dem Befehl "Optionen" aktivieren oder deaktivieren.

Spezielle Reltable-Unterstützung

Beim Importieren wandelt das Plug-In Elemente des Typs "reltable/topicmeta" in den Typ "reltable/fm-reltablemeta" um, damit sie einem FrameMaker TableTitle-Objekt korrekt zugeordnet werden können. Beim Exportieren werden die Elemente in gültige DITA Topicmeta-Elemente umgewandelt.

Unterstützung von Referenzen

Alle Referenzen (Topicrefs, Conrefs und Xrefs) werden in FrameMaker als "Texteinschübe" dargestellt. Diese Texteinschübe sind nicht mit dem Textfluss verknüpft, sondern dienen zum Sperren eines Textbereichs und ermöglichen dem Benutzer das Klicken auf das Objekt. Um gültige DITA-Dateien zu exportieren, wandelt das Plug-In diese Texteinschübe in die entsprechende XML-Struktur um.

DITA Map-Unterstützung

Es wird eine Strukturanwendung zur Entwicklung von DITA Maps mitgeliefert. Diese Strukturanwendung bietet Unterstützung für Topicrefs und Beziehungstabellen. Durch den Import/Export-Client und Lese-/Schreibregeln ist die .ditamap-Datei vollständig mit DITA kompatibel, obwohl in FrameMaker einige zusätzliche Elemente hinzugefügt wurden, um eine ordnungsgemäße Interaktion sicherzustellen. Diesen Elementen ist das Präfix "fm-" vorangestellt.

Wenn eine .ditamap-Datei geöffnet wird, werden alle Topicref-Elemente in Fm-topicreflabel-Elemente umgewandelt, die den Texteinschub enthalten. Der Texteinschub zeigt den Titel (Navtitle-Attribut) und den Dateinamen (Href-Attribut) der referenzierten Datei an. Wenn Sie auf den Einschub doppelklicken, wird die referenzierte Datei zur Bearbeitung geöffnet. Die Bezeichnungen werden in den Bedingungstextstil "DITA-Topicref" eingegliedert. Sie können ihre Farbe durch Bearbeiten der Bedingungsdefinition in der Schablonendatei ändern.

Neue Topicref-Elemente können mit dem Befehl "Topicref einfügen" im Menü "DITA" oder durch Einfügen eines Topicref-Elements aus dem Elementkatalog hinzugefügt werden. Beim Einfügen eines Topicref-Elements wird ein Dialogfenster zur Auswahl der referenzierten Datei angezeigt. Danach werden das fm-topcreflabel-Element und der Einschub hinzugefügt. Topicref-Elemente können andere DITA Topic- oder DITA Map-Dateien referenzieren.

Vorhandene Topicref-Elemente können aktualisiert werden, sodass der Bezeichnungstext Aktualisierungen in der referenzierten Datei widerspiegelt. Um ein vorhandenes Topicref-Element zu aktualisieren, wählen Sie die Bezeichnung aus und wählen "DITA > Referenzen aktualisieren". Mit dem Befehl "Referenzen aktualisieren" können Sie außerdem alle Topicref-Elemente in der Datei ".ditamap" aktualisieren, um Änderungen in den referenzierten Dateien widerzuspiegeln. Bei diesem Befehl wird auch die Einstellung des Locktitle-Attributs des Topicref-Elements berücksichtigt. Wenn Locktitle auf "Ja" gesetzt ist, wird der Navtitle-Text nicht aktualisiert.

Conref-Unterstützung

Beim Öffnen einer Datei werden die Inhalte von Conref-Elementen zugeordnet und als Texteinschübe mit den Farben und dem Stil des DITA-Conref-Bedingungsstils angezeigt. Die Funktion zum automatischen Laden kann mit dem Befehl "DITA-Optionen" im Menü "DITA" aktiviert oder deaktiviert werden.

Die Verweisverwaltung, die nach Auswahl des Befehls "Conref einfügen" im Menü "DITA" angezeigt wird, ermöglicht Ihnen, Inhalte in derselben oder in anderen Dateien zu referenzieren. Wählen Sie im Dialogfenster der Verweisverwaltung eine derzeit geöffnete Datei, den Elementnamen (gültig am aktuellen Einfügepunkt), und wählen Sie dann aus einer Liste entsprechender Elemente mit ID-Attributwerten (erforderlich für Conrefs) aus. Die mit Conref referenzierten Elemente werden als Texteinschübe eingefügt. Sie können auf das Conref-Element doppelklicken, um die DITA-Verweisverwaltung erneut zu öffnen und das referenzierte Element ändern oder die Quelldatei bearbeiten. Die Verweisverwaltung ermöglicht außerdem, eine Liste aller Conref-Elemente anzuzeigen (auch wenn sie keine ID haben). In diesem Fall müssen Sie dem Element beim Einfügen eine ID zuweisen.

Mit dem Befehl "Referenzen aktualisieren" im Menü "DITA" können Conref-Einschübe geladen und erstellt werden (sofern sie noch nicht mit der Funktion zum automatischen Laden geladen wurden), und sie können aktualisiert werden, um Änderungen in der Quelldatei widerzuspiegeln.

Xref-Unterstützung

Beim Öffnen einer Datei werden alle Xref-Elemente zugeordnet und als Texteinschübe angezeigt. Die Funktion zum automatischen Laden kann mit dem Befehl "DITA-Optionen" im Menü "DITA" aktiviert oder deaktiviert werden.

Wenn ein Xref-Element aus dem Elementkatalog eingefügt wird, wird das Dialogfenster der Verweisverwaltung angezeigt und Sie können Xref-Zielelemente auswählen. Der Xref-Text entspricht dem des Zielelements, es sei denn, Sie geben im Feld "Alternativer Querverweistext" einen anderen Text ein. Mit der Schaltfläche "Externer Querverweis" können Sie einen Querverweis zu einer externen Datei anlegen.

Erstellen eines FrameMaker DITA-Buchs aus einer DITA Map-Datei

Mit dem Befehl "FM DITABook aus ditamap-Datei erstellen" im Menü "DITA" können Sie ein FrameMaker-Buch aus einer DITA Map-Datei erstellen.

Die Topicrefs auf der obersten Ebene der DITA Map werden im FrameMaker-Buch zu Kapiteln, die verschachtelte Topicrefs enthalten. Die Formatierung wird durch die Strukturanwendung bestimmt, die Sie für Bücher im Dialogfenster "DITA-Optionen" ausgewählt haben.

Allgemein

Mit dem Befehl "DITA-Optionen" im Menü "DITA" können Sie die Strukturanwendung zum Öffnen der DITA Map- und DITA Topic-Dateien angeben und verschiedene DITA-Optionen aktivieren oder deaktivieren.

Mit dem Befehl "DITA > Neue DITA-Datei" können Sie verschiedene DITA-Dateitypen erstellen. Die aufgelisteten DITA Topic-Typen werden aus einem Element Definition Document (EDD) extrahiert, das mit der DITA-Strukturanwendung verbunden ist (wie im Dialogfenster "Optionen" angegeben). Alle Elemente der Klasse "topic/topic" werden der Menüoption "DITA > Neue DITA-Datei" hinzugefügt, ebenso wie alle Elemente der Klasse "map/map". Nach Auswahl des zu erstellenden Dateityps werden Sie zur Eingabe des Dateinamens aufgefordert. Dies unterscheidet sich vom standardmäßigen FrameMaker-Befehl "Neu" im Menü "Datei", da FrameMaker keine Möglichkeit zur Erstellung einer unbenannten XML-Datei (die nicht im Dateisystem gespeichert wird) bietet. Um zunächst eine unbenannte Datei zu erstellen, wählen Sie den Standardbefehl "Neu" und verwenden die DITA-Schablone.

DITA-Hauptfunktionen

Kennzeichnend für den DITA-Ansatz zur Informationsverwaltung sind:

    Die DITA-Architektur basiert auf Topics. Diese grundlegenden Informationseinheiten dienen als Bausteine für alle Inhalte.

    DITA Topics umfassen drei grundlegende Informationstypen: Task, Konzept und Referenz.

    Durch DITA Maps werden Topics in der Reihenfolge und Hierarchie zusammengestellt, die den Anforderungen der bereitzustellenden Dokumentation entspricht.

    Das DITA-Objektmodell basiert auf Vererbung (daher auch der Verweis auf Darwin im Namen). Task-, Konzept- und Referenz-Topics haben beispielsweise eine gemeinsame Basisstruktur, deren Merkmale sie erben.

    Verknüpfungen zwischen Themen werden anhand von Beziehungstabellen definiert und aktualisiert.

    DITA ermöglicht die Wiederverwendung von Informationseinheiten mithilfe des Conref-Attributs. So braucht beispielsweise eine Anmerkung nur einmal geschrieben zu werden und kann durch ein Conref-Attribut in mehreren Topics eingeschlossen werden.

Die DITA-Informationstypen Topic, Konzept, Task und Referenz

Das wohl herausragendste Merkmal von DITA ist der äußerst modulare, auf Topics basierende Aufbau. DITA Topics sind Informationseinheiten, in denen ein Thema behandelt wird. Technische Redakteure ohne DITA-Erfahrung müssen sich erst an den Gedanken gewöhnen, dass ein Dokument aus solchen modularen Informationseinheiten besteht. Statt einem durchgängigen Dokument erstellen sie mit DITA Topics verschiedener Typen und definieren dann die Reihenfolge und Hierarchie dieser Topics für verschiedene Formen der Bereitstellung.

Vorteile von DITA

DITA bietet viele Vorteile bei der Verwaltung von Inhalten:

    Einfache Wiederverwendbarkeit

    Möglichkeit zur Ausgabe in verschiedenen Formaten mit dem DITA Open Toolkit

    Verbesserter Informationsaustausch mit anderen Organisationen, die DITA verwenden

    Möglichkeit zur Nutzung einer steigenden Anzahl von Software-Programmen zum Erstellen, Verwalten und Ausgeben von DITA-Inhalten

    Vereinfachte Erstellung und Ausgabe von Hilfeinhalten einschließlich effizienter Verwaltung von Hyperlinks und Beziehungen zwischen Themen

    Geringere Übersetzungskosten durch Topics und Wiederverwendung von Inhalten

Die Vorteile von DITA variieren abhängig von den Ausgabeanforderungen des Unternehmens und der Lernfähigkeit hinsichtlich des modularen Ansatzes der Inhaltsverwaltung. So werden einige Unternehmen nach der Übernahme des Topic-orientierten DITA-Ansatzes feststellen, dass sich der anfängliche Aufwand für die Umstrukturierung von Inhalten gelohnt hat.


Strukturiertes Authoring mit DITA / Einführung

DITA-Funktionsweise

Für ein Verständnis der DITA-Funktionsweise müssen die Architektur, die Philosophie der Topic-basierten Inhaltsverwaltung und die Mechanismen zu deren Implementierung berücksichtigt werden. Über diese im Basisinformationssatz verfügbaren DITA-Kernfunktionen hinaus sind für viele Unternehmen die Anpassung und Erweiterung von DITA an die eigenen Anforderungen wichtig.

DITA-Architektur

Die DITA-Architektur basiert auf mehren Prinzipien:

    Wiederverwendbarkeit und modularer Aufbau: Der Topic-basierte Aufbau von DITA ist eine Reaktion auf die Feststellung, dass Dokumentationskosten durch effiziente Wiederverwendung von Inhalten gesenkt werden können. Bereits bei Projektbeginn wird davon ausgegangen, dass Inhalte wiederverwendet und Kernfunktionen wie Topic Maps, Inhaltsreferenzen (Conrefs) und Verarbeitung von bedingtem Text eingesetzt werden.

    Vererbung: DITA kann ohne umfangreiche Umgestaltung des Ausgabeverfahrens erweitert werden. Bei der Spezialisierung des Inhaltsmodells durch Definition einer neuen branchenspezifischen Topic-Form erbt das spezialisierte Topic von der definierten Basisklasse und ermöglicht Benutzern automatisch, die gleiche Verarbeitung wie für die Basisklasse zu nutzen.

    Betonung der Inhaltsbeziehung: DITA wurde mit dem Bewusstsein geschaffen, dass Verweisen und Verknüpfungen eine immer größere Bedeutung zukommt. Verwandte Themen werden erwartet und nicht erst am Ende hinzugefügt, wie dies bei älteren, sequenziellen Architekturen der Fall war, bei denen das Drucken im Vordergrund stand.

Topic-orientierte Dokumenterstellung

Bei DITA sind Informationen in einzelne Einheiten gegliedert. In jeder Informationseinheit wird nur ein Topic behandelt, beispielsweise ein Konzept oder eine Anleitung, vorzugsweise sind nur die mindestens erforderlichen Informationen enthalten.

DITA bietet einen Standard zur Strukturierung von Topics und Inhalten innerhalb von Topics. Dieser Standard basiert auf drei allgemeinen Informationskategorien, in die fast alle technischen Informationen gegliedert werden können.

    Task: Anweisungen für ein bestimmtes Topic (beispielsweise die Schritte zum Speichern einer Datei in einer Software-Anwendung).

    Konzept: Erläuterung eines grundlegenden Konzepts in Zusammenhang mit einer Aufgabe

    Referenz: Fakten zu einer Task. Oft sind Referenz-Topics in Tabellen- oder Listenform angelegt, um Benutzern schnellen Zugriff auf Informationen zu ermöglichen.

Diese Kategorien werden als Spezialisierungen der Basisklasse des Topic angesehen, von der sie eine einheitliche Kernstruktur erben. Die gemeinsamen Elemente der drei DITA-Standardinformationstypen sind Titel, Beschreibung, Einführung und Haupttext. Ein DITA-Dokument muss mindestens ein Topic enthalten.

 | Task-Topic | Konzept-Topic | Referenz-Topic
Gemeinsame Struktur | Kopfzeile: Titel Kurze Beschreibung Einleitung Haupttext: Task-Haupttext Verknüpfungen zu verwandten Themen | Kopfzeile: Titel Kurze Beschreibung Einleitung Haupttext: Konzept-Haupttext Verknüpfungen zu verwandten Themen | Kopfzeile: Titel Kurze Beschreibung Einleitung Haupttext: Verweis-Haupttext Verknüpfungen zu verwandten Themen
Beispiele für optionale Elemente (im Haupttext) | Kontext Voraussetzungen Schritte Schrittelemente Ergebnis Beispiele Nachfolgende Anforderungen | Abschnitt Absatz Listen Tabellen Bilder Beispiele | Abschnitt Absatz Eigenschaftslisten Tabellen Syntax Beispiele
Task, Konzept und Referenz erben eine gemeinsame Struktur von dem übergeordneten Informationstyp-Topic.

Die DITA-Struktur unterstützt die Wiederverwendung unabhängiger Topics in einer beliebigen Anordnung zur Erstellung neuer Dokumente. Einer der Hauptgründe für den Topic-basierten Aufbau von DITA ist die Wiederverwendung von Informationen.

Dank Wiederverwendung lassen sich beispielsweise neue Dokumente aus den einzelnen Topics erstellen, Verknüpfungen und Querverweise auf externe und interne Topics und Dokumente automatisieren, Informationen für verschiedene Veröffentlichungsarten identifizieren und formatieren, Informationen für verschiedene Verfahrensweisen formatieren und die Inhaltserstellung auf mehrere technische Redakteure oder Gruppen aufteilen. Die Wiederverwendung findet auf Topic-Ebene statt (d. h. beim Zusammenstellen der Ausgabe mithilfe von DITA Maps) oder auf Unterthemen-Ebene, wenn beispielsweise eine bestimmte Dokumentkomponente in mehreren Topics mithilfe von Inhaltsreferenzattributen referenziert wird.

DITA Maps

DITA Maps sind eine leistungsstarke Steuerungsmöglichkeit für die Ausgabe. Sie können die Sequenz und Hierarchie der Topics für die Bereitstellung von Inhalt definieren.

Da der Inhalt aus einzelnen Komponenten erzeugt wird, ist die Ausgabe sehr flexibel. Eine einzige Quelldatei kann auf verschiedenen Kanälen veröffentlicht werden. Statt beispielsweise zwei sich geringfügig unterscheidende Versionen des gleichen Dokuments für unterschiedliche Zielgruppen zu erstellen, können technische Redakteure mit DITA Maps mühelos mehrere Versionen erzeugen.

Erzeugen mehrerer Ausgabeformate aus einer Quelldatei mithilfe von DITA Maps

Bei der Erstellung von DITA Maps arbeiten Sie hauptsächlich mit vier XML-Elementen: <topicref>, <topichead>, <topicgroup> und <topicmeta>.

    Das <topicref>-Element referenziert ein Topic; Sie legen die Sequenz und Verschachtelung der Elemente fest, um die Anordnung der Topics im ausgegebenen Dokument zu bestimmen.

    Mit dem <topichead>-Element können Sie Topic-Überschriften in Abschnitte mit mehreren referenzierten Topics einfügen.

    Mit <topicgroup> können Sie Topic-Referenzen zusammenstellen, ohne ihre Hierarchie zu beeinflussen. Beispielsweise können Sie Gruppen zur Verknüpfung angeben, ohne die Gesamtstruktur der Ausgabe zu verändern.

    Das <topicmeta>-Element definiert Metadaten, die auf ein Topic (und die entsprechenden untergeordneten Topics) angewendet werden, wenn dieses Topic in einer Map enthalten ist. Das Element kann bei einer Verknüpfung auch den Titel und die kurze Beschreibung des Topic überschreiben.

Sobald die DITA Map erstellt ist, werden die Topics bei der anschließenden Ausgabe entsprechend zusammengestellt.

Inhaltsverweise zur Wiederverwendung

Zusammen mit DITA Maps ist das Conref-Attribut (Content Reference, Inhaltsreferenz) einer der Hauptmechanismen zur Wiederverwendung von Inhalten. Es ruft den mit einem ID-Attribut verknüpften Inhalt auf und fügt ihn anstelle des Elements mit dem Conref-Attribut ein.

Sie können Conrefs in einem Topic oder in einer Map verwenden, um auf den Inhalt eines anderen Topic oder einer Map zu verweisen. Wenn Sie eine Conref verwenden und ein referenziertes Quelldokument ändern, wird die Änderung in allen Dokumenten angezeigt, die darauf verweisen.

Eine Conref in einer Datei:

<note conref="meinedatei.dita#meintopic/meineanmerkung"></note>
kann in Inhalt in einer anderen Datei (in diesem Fall "meinedatei.dita") referenzieren:
<topic id="meintopic">
...
<note id="meineanmerkung">Dies ist eine wiederverwendbare Komponente</note>
...
</topic>

indem im Conref-Attribut der Name der Datei, das ID-Attribut des <topic> mit dem Inhalt und die ID der referenzierten Komponente angegeben wird. Wichtig ist, dass die Elementnamen übereinstimmen und dass das Element, welches das conref-Attribut verwendet, am Einfügepunkt gültig ist.

Sie können Conrefs auch zum Referenzieren von Inhalten in derselben Datei verwenden. Lassen Sie in diesem Fall den Dateinamen im conref-Attribut aus.

Während Conrefs in einem typischen DITA-Ausgabeverfahren zugeordnet werden und die referenzierten Abschnitte anstelle der Referenzen angezeigt werden, wird der verknüpfte Text in XML-Authoring-Programmen ohne DITA-Unterstützung im Allgemeinen nicht automatisch an der Conref-Position angezeigt.


Strukturiertes Authoring mit DITA / Einführung

Dateien zur DITA-Unterstützung

Das Anwendungsverzeichnis enthält die Dateien zur Unterstützung von DITA. Es umfasst die folgenden Dateien:

Datei | Zweck
ditabase.dtd | Übergeordnete Datei für die DITA 1.0 DTD
concept.dtd reference.dtd task.dtd topic.dtd | Spezialisierte, mit DITA 1.0 gelieferte DTDs
map.dtd | DTD für DITA Map-Dateien
highlightDomain.ent mapGroup.ent programmingDomain.ent softwareDomain.ent topicDefn.ent uiDomain.ent utilitiesDomain.ent | Modulare Komponenten der DITA DTD
concept.mod highlightDomain.mod map.mod mapGroup.mod metaDecl.mod programmingDomain.mod reference.mod softwareDomain.mod task.mod tblDecl.mod topic.mod topicAttr.mod uiDomain.mod utilitiesDomain.mod | Modulare Komponenten der DITA DTD
catalog-dita.txt | Katalog der öffentlichen DITA-Entities (Textversion)
catalog-dita.xml | Katalog der öffentlichen DITA Entities (XML-Version)
edd | FrameMaker EDD mit Formatierungsregeln für unterstützte DITA-Elemente
rules | Lese-/Schreibregeln
template | Strukturierte FrameMaker-Schablone zur Verwendung beim Importieren
import.xsl | XSLT-Stilvorlage. Wird von der DITA-Strukturanwendung beim Importieren oder Umwandeln von DITA-Komponenten in FrameMaker-Objekte aufgerufen.
export.xsl | XSLT-Stilvorlage. Wird von der DITA-Strukturanwendung beim Exportieren aufgerufen, um FrameMaker-Objekte in DITA-Inhaltsmodell-Elemente umzuwandeln.

Die standardmäßige Datei "structapps.fm" enthält die Definition der DITA-Anwendung. Informationen zum Erstellen und Bearbeiten von "structapps.fm" finden Sie im Online-Handbuch "Structured FrameMaker Developer’s Guide".


Strukturiertes Authoring mit DITA / Einführung

Nächste Schritte

Unternehmen, die eine Einführung von DITA in Betracht ziehen, sollten genau überlegen, ob DITA für ihre Zwecke geeignet ist. DITA erfreut sich zwar steigender Beliebtheit und es gibt immer mehr Veröffentlichungswerkzeuge mit DITA-Unterstützung, es ist jedoch nicht in jedem Fall geeignet.

Eignung von DITA für ein Unternehmen

Die folgenden Fragen können Ihnen helfen, festzustellen, ob die DITA-Inhaltsarchitektur die für Ihre Zwecke geeignete Lösung ist:

    Lassen sich die vorhandenen und zukünftigen Inhalte in Topics gliedern?

    Ist der Inhalt derzeit mit XML strukturiert?

    Welche Anforderungen/Wünsche gibt es bezüglich der Ausgabe?

    Wie arbeitsaufwändig ist die Anpassung an verschiedene Zielgruppen?

    Wie umfassend sind die verfügbaren Authoring- und Dokument-Architekturressourcen?

Nicht alle Inhalte lassen sich in Topics gliedern. Daher ist DITA möglicherweise für Ihre Inhalte nicht geeignet. DITA ist geeignet, wenn ein modularer Aufbau möglich ist und sich der Inhalt auf natürliche Art in unabhängige Topics gliedern lässt oder bereits in Topics gegliedert ist. Eine sequenzielle Struktur, wie ein Roman, ein einzelner Forschungsbericht oder ein Zeitungsartikel, ist normalerweise nicht für DITA geeignet.

Wenn eine Topic-orientierte Architektur möglich und geeignet ist, sollte als nächstes der Aufwand für eine Migration zu und Arbeit in DITA überdacht werden. Wird strukturiertes Authoring (d. h. XML-Authoring) bereits implementiert, vereinfacht dies die Einführung von DITA.

Eine Beurteilung des Aufwands zur Umstellung auf DITA sollte auch eine realistische Bewertung der verfügbaren Dokument-Architekturressourcen beinhalten sowie die Eignung der Redakteure und das Interesse an einer durchgehenden Umsetzung der Topic-Struktur von DITA berücksichtigen. Der Reiz von DITA-Werkzeugsätzen wie DITA Open Toolkit, die Aussicht auf effiziente Wiederverwendung und Erweiterung von Inhalten und andere Vorteile von DITA für die Dokumentausgabe müssen mit den Anforderungen in Bezug auf die modulare Struktur verglichen werden.

Der am besten für DITA geeignete Inhalt sind möglicherweise Software oder Dokumentation, die als Hilfe bereitgestellt werden. In solchen Fällen ist der Topic-basierte Ansatz den Redakteuren bereits bekannt oder wird von ihnen verwendet. Je weiter der Inhalt von diesem Muster abweicht, umso genauer muss analysiert werden, ob DITA die beste Lösung ist.

Vor der unternehmensweiten Einführung einer Dokumentstruktur und -erstellung auf DITA-Basis sollte ein Pilotprojekt mit einem genau festgelegten Umfang durchgeführt werden, um die Vorteile und benötigten Ressourcen für einen breiteren Übergang zu DITA festzustellen.


Strukturiertes Authoring mit DITA

DITA in FrameMaker 8

Das DITA-Anwendungspaket in FrameMaker 8 baut auf den strukturierten Authoring-Funktionen von FrameMaker auf und ermöglicht Redakteuren eine effizientere Arbeitsweise. Die DITA-Funktion besteht aus einer Reihe von Plug-Ins, die in Kombination mit verschiedenen Strukturanwendungen die Hauptwerkzeuge für DITA-Authoring und -Ausgabe sind. Die DITA-Funktion kann für verschiedene Zwecke verwendet werden.

FrameMaker DITA unterstützt DITA-Authoring und -Ausgabe durch eine Reihe von Plug-Ins und Strukturanwendungen.


Strukturiertes Authoring mit DITA / DITA in FrameMaker 8

DITA-Funktionen

Funktionen mit DITA-Unterstützung:

    Import/Export-Verarbeitung: Beinhaltet die Verwendung einiger FrameMaker-Komponenten und -Elemente (erkennbar an dem Präfix "fm"), die bei der Dokumenterstellung in FrameMaker vorhanden sind, jedoch während des Imports und Exports in DITA-konformes XML umgewandelt werden, wodurch die Interoperabilität mit anderen Systemen sichergestellt wird.

    DITA Map-Unterstützung: Die DITA-Funktion in FrameMaker bietet eine Strukturanwendung für die Erstellung und Bearbeitung von DITA Maps sowie die Verwaltung von Beziehungstabellen. Durch Doppelklicken auf ein Topic in einer Map wird dieses zur Bearbeitung geöffnet.

Arbeiten mit DITA Maps in FrameMaker

    Conref-Unterstützung: Beim Öffnen einer Datei ordnet DITA alle Conrefs zu und zeigt den referenzierten Inhalt als Texteinschub in FrameMaker an. Die DITA-Funktion umfasst außerdem die Verweisverwaltung zum Einfügen von Conrefs.

Arbeiten mit DITA Conrefs in FrameMaker

    Xref-Unterstützung: Beim Öffnen einer Datei ordnet die DITA-Funktion <Xref>-Elemente automatisch zu und zeigt den dazugehörigen Text in FrameMaker an. Diese Funktion kann aktiviert oder deaktiviert werden.

    Ausgabeunterstützung: Mit der DITA-Funktion können Sie außerdem ein FrameMaker-Buch aus einer DITA Map erstellen und beispielsweise als Adobe PDF, kompilierte Hilfe oder HTML ausgeben.

Sie können die DITA-Funktionen mithilfe des Dialogfensters "DITA-Optionen" oder durch Bearbeiten der Datei "ditafm.ini" anpassen.

Anwendungen in DITA

Die in FrameMaker 8 integrierte DITA-Funktion umfasst vier FrameMaker-Anwendungen:

    DITA-Topic-FM: Mit dieser Anwendung können Sie die Informationen vom Typ Topic, Konzept, Referenz und Task erstellen. Bei Bedarf kann das EDD und die strukturierte Vorlage in dieser Anwendung zur Bildschirmanzeige und Topic-Prüfung angepasst werden (siehe Ändern von Schablonenkomponenten und Dateien für strukturierte DITA-Schablonen).

    DITA-Map-FM: Mit dieser Anwendung können Sie DITA Maps erstellen und bearbeiten (.map und .ditamap).

    DITA-Book-FM: Mit dieser Anwendung können Sie ein FrameMaker-Buch erstellen, das alle Dateien in einer geöffneten DITA Map enthält (<dita>, <ditamap> oder <map>). Das in dieser Anwendung verwendete EDD und die strukturierte Schablone können angepasst werden, um Ihre Inhalte zur Ausgabe eines gedruckten Dokuments oder einer PDF-Datei anzupassen (siehe Ändern von Schablonenkomponenten und Dateien für strukturierte DITA-Schablonen).

Jede Anwendung hat eine Anwendungsdefinition, die auf ihre Komponenten verweist.

    Vollständige DITA DTD

    Datei mit Lese-/Schreibregeln

    Schablone (mit getrenntem EDD)

    API-Clients (Application Programming Interface) und XSLT-Verarbeitungsdateien, falls erforderlich

    Entity Locations

DITA-Topic-FM, DITA-Map-FM und DITA-Book-FM verwenden einen API-Client für den Import und Export; DITA-Book-FM verwendet außerdem XSLT zur Vorbereitung. Die in DITA-Book-FM definierte Struktur umfasst alle in DITA-Topic-FM enthaltenen Elemente und einige zusätzliche FrameMaker-spezifische Eingliederungselemente für die Erstellung von FrameMaker-Büchern. Dazu verweist diese Anwendung auch auf eine der nicht allgemeinen DITA-Dateien: fm-ditabook.dtd.


Strukturiertes Authoring mit DITA

Verwenden von DITA in FrameMaker 8

Frühere FrameMaker-Versionen enthielten DITA-Anwendungspakete und S1000D, um Entwicklern eine umfassende Beurteilung und Verbesserung der XML-Authoring- und Ausgabefunktionen in FrameMaker mit zwei führenden offenen Standards zu ermöglichen. Beide Anwendungspakete ergänzten außerdem frühere Versionen des FrameMaker Developer Kit (FDK) mit Beispielinhalten, Werkzeugen, Anwendungen und Dokumentation.

FrameMaker enthält ein integriertes DITA-Anwendungspaket und ein DITA-Menü, die Sie beim DITA-Authoring unterstützen. Sie können ein FrameMaker-Dokument direkt aus einer DITA Map erzeugen. Außerdem können Sie beim Authoring von DITA-Inhalten die Standardfunktionen von FrameMaker verwenden. Durch die modularen, wiederverwendbaren Informationselemente von DITA können Sie strukturierte Dokumente in verschiedenen Formaten und Medien ausgeben und haben fast unbeschränkte Möglichkeiten zur erneuten Anordnung der Informationen. DITA unterstützt eine dynamische und personalisierte Bereitstellung von strukturiertem Inhalt, sodass der Leser bestimmen kann, welcher Inhalt wichtig ist und wie er zusammengestellt werden soll.

Im strukturierten FrameMaker öffnen Sie ein neues Dokument und erstellen eine Map, um Topics in der Hierarchie eines Hilfesystems oder einer Website oder in eine verschachtelte Sequenz für ein Buch anzuordnen. Sie können außerdem Navigationshierarchien aus der Map erstellen und Verknüpfungen erzeugen, die den Topics hinzugefügt werden.

Zu den Verbesserungen am DITA-Anwendungspaket gehören:

    Das DITA-Anwendungspaket unterstützt Unicode.

    Sie können ein aus einer Komponente bestehendes FrameMaker-Dokument aus einer ditamap-Datei erzeugen und im gewünschten Format (beispielsweise als PDF-Datei) speichern. Die erzeugte Datei ist unabhängig und referenziert keine anderen Dokumente.

Hinweis: Das DITA-Anwendungspaket bietet keine Unterstützung mehr für Funktionen, die durch die Verwendung des Open Toolkit (OT) zur Verfügung stehen.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Erstellen von DITA Maps

DITA Maps sind eine leistungsstarke Steuerungsmöglichkeit für die Ausgabe. Sie können die Sequenz und die Hierarchie der Topics bei der Bereitstellung von Inhalt definieren.

Da der Inhalt aus einzelnen Komponenten erzeugt wird, ist die Ausgabe sehr flexibel. Eine einzige Quelldatei kann auf verschiedenen Kanälen veröffentlicht werden. Statt beispielsweise zwei sich geringfügig unterscheidende Versionen des gleichen Dokuments für unterschiedliche Zielgruppen zu erstellen, können technische Redakteure mit DITA Maps mühelos mehrere Versionen erzeugen.

Bei der Erstellung von DITA Maps arbeiten Sie hauptsächlich mit vier XML-Elementen: topicref, topichead, topicgroup und topicmeta.

    Das topicref-Element referenziert ein Topic; Sie legen die Sequenz und Verschachtelung der Elemente fest, um die Anordnung der Topics im ausgegebenen Dokument zu bestimmen.

    Mit dem topichead-Element können Sie Topic-Überschriften in Abschnitte mit mehreren referenzierten Topics einfügen.

    Mit topicgroup können Sie Topic-Referenzen zusammenstellen, ohne ihre Hierarchie zu beeinflussen. Beispielsweise können Sie Gruppen zur Verknüpfung angeben, ohne die Gesamtstruktur der Ausgabe zu verändern.

    Das topicmeta-Element definiert Metadaten, die auf ein Topic (und die entsprechenden untergeordneten Topics) angewendet werden, wenn dieses Topic in einer Map enthalten ist. Das Element kann bei einer Verknüpfung auch den Titel und die kurze Beschreibung des Topic überschreiben.

So erstellen Sie eine DITA Map:

    1. Wählen Sie "DITA > Neue DITA-Datei > Neu <Map>". Das Dialogfenster "Geben Sie einen neuen DITA Map-Dateinamen ein" wird angezeigt.

    2. Geben Sie im Feld für den Dateinamen einen eindeutigen Namen für die Map-Datei an.

Hinweis: Wenn Sie keine Dateinamenerweiterung für die neue Datei angeben, wird ein Standardname hinzugefügt. Dieser hängt von dem im Dialogfenster "DITA-Optionen" als Standard-Dateityp angegebenen Typ ab. DITA Map-Dateien haben die Erweiterung ".ditamap".

    3. Klicken Sie auf "Auswählen". Für die neue DITA Map wird ein Fenster mit dem Standardtitel MAP TITLE angezeigt.

    4. Klicken Sie im Fenster "Strukturansicht" rechts neben dem <map>-Element auf das Plussymbol (+).

    5. Doppelklicken Sie auf das Titelattribut.

    6. Heben Sie im Dialogfenster "Attribute" den Text im Feld "Attributwert" hervor und geben Sie den gewünschten Wert an.

    7. Klicken Sie auf "Wert zuweisen" und anschließend auf "Fertig". Die neue DITA Map-Datei wird mit der Erweiterung ".ditamap" gespeichert.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Erstellen eines DITA Topics

Das Dialogfenster "DITA-Optionen" enthält ein Markierungsfeld, um in einem dita-Element (Standard) neue Elemente auf Topic-Ebene (z. B. topic, concept, reference und task) einzufügen. Aktivieren Sie diese Option und erstellen Sie ein neues Topic.

So erstellen Sie ein DITA-Topic:

    1. Wählen Sie "DITA > DITA-Optionen" aus und aktivieren Sie anschließend "Neue Themen in DITA-Element einschließen".

    2. Klicken Sie auf "Sichern".

    3. Wählen Sie "DITA > Neue DITA-Datei > Neu <Topic>".

    4. Klicken Sie auf "Auswählen". Für das neue DITA Topic wird ein Fenster mit dem Standardtitel TOPIC TITLE angezeigt.

    5. Klicken Sie im Fenster "Strukturansicht" rechts neben dem <Topic>-Element auf das Plussymbol (+).

    6. Doppelklicken Sie auf das Titelattribut.

    7. Heben Sie im Dialogfenster "Attribute" den Text im Feld "Attributwert" hervor und geben Sie den gewünschten Wert an.

    8. Klicken Sie auf "Wert zuweisen" und anschließend auf "Fertig". Die neue DITA Topic-Datei wird als XML-Datei gespeichert.

Hinweis: Wenn Sie keine Dateinamenerweiterung für die neue Datei angeben, wird eine Erweiterung hinzugefügt. Diese hängt von dem im Dialogfenster "DITA-Optionen" als Standard-Dateityp angegebenen Typ ab.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Erstellen eines DITA-Konzepts

Sie können Konzept-Topics zur Definition von Begriffen und Erläuterung von Konzepten erstellen.

So erstellen Sie ein DITA-Konzept:

    1. Wählen Sie "DITA > Neue DITA-Datei > Neu <Topic>".

    2. Klicken Sie auf "Auswählen". Für das neue DITA-Konzept wird ein Fenster mit dem Standardtitel TOPIC TITLE angezeigt.

    3. Klicken Sie im Fenster "Strukturansicht" rechts neben dem <Konzept>-Element auf das Plussymbol (+).

    4. Doppelklicken Sie auf das Titelattribut.

    5. Heben Sie im Dialogfenster "Attribute" den Text im Feld "Attributwert" hervor und geben Sie den gewünschten Wert an.

    6. Klicken Sie auf "Wert zuweisen" und anschließend auf "Fertig". Die neue DITA-Konzeptdatei wird als XML-Datei gespeichert.

Hinweis: Wenn Sie keine Dateinamenerweiterung für die neue Datei angeben, wird eine Erweiterung hinzugefügt. Diese hängt von dem im Dialogfenster "DITA-Optionen" als Standard-Dateityp angegebenen Typ ab.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

So erstellen Sie einen DITA Task:

Sie können ein Task Topic vom Typ "So geht's" für einen bestimmten Task erstellen, das schrittweise Vorgehensweisen enthält.

So erstellen Sie ein DITA Task:

    1. Wählen Sie "DITA > Neue DITA-Datei > Neu <Task>".

    2. Klicken Sie auf "Auswählen". Für die neue DITA-Task wird ein Fenster mit dem Standardtitel TOPIC TITLE angezeigt.

    3. Klicken Sie im Fenster "Strukturansicht" rechts neben dem <Task>-Element auf das Plussymbol (+).

    4. Doppelklicken Sie auf das Titelattribut.

    5. Heben Sie im Dialogfenster "Attribute" den Text im Feld "Attributwert" hervor und geben Sie den gewünschten Wert an.

    6. Klicken Sie auf "Wert zuweisen" und anschließend auf "Fertig". Die neue DITA-Taskdatei wird als XML-Datei gespeichert.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Erstellen einer DITA-Referenz

Sie können ein Referenz-Topic erstellen, das Inhalt wie Zusatzinformationen, einen Tipp, eine Warnung oder eine einfache Anmerkung enthält.

So erstellen Sie eine DITA-Referenz:

    1. Wählen Sie "DITA > Neue DITA-Datei > Neu <Referenz>".

    2. Klicken Sie auf "Auswählen". Für die neue DITA-Referenz wird ein Fenster mit dem Standardtitel TOPIC TITLE angezeigt.

    3. Klicken Sie im Fenster "Strukturansicht" rechts neben dem <Referenz>-Element auf das Plussymbol (+).

    4. Doppelklicken Sie auf das Titelattribut.

    5. Heben Sie im Dialogfenster "Attribute" den Text im Feld "Attributwert" hervor und geben Sie den gewünschten Wert an.

    6. Klicken Sie auf "Wert zuweisen" und anschließend auf "Fertig". Die neue DITA-Referenzdatei wird als XML-Datei gespeichert.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Öffnen aller Topic-Referenzen in einer .ditamap-Datei

Das topicref-Element kennzeichnet ein Topic (z. B. ein Konzept, eine Task oder eine Referenz) oder eine andere Ressource. Ein topicref-Element kann andere topicref -Elemente enthalten, sodass Sie Navigations- oder Inhaltsverzeichnis-Hierarchien sowie Beziehungen zwischen übergeordneten und untergeordneten topicref-Elementen definieren können. Sie können den Sammlungstyp eines übergeordneten topicref-Elements einstellen, um die Beziehungen zwischen den untergeordneten Elementen festzulegen. Sie können außerdem die Beziehungen zwischen topicref-Elementen in Gruppen- und Tabellenstrukturen (topicgroup und reltable) angeben. Beziehungen werden in der Ausgabe als Verknüpfungen ausgedrückt, wobei jede Komponente der Beziehung standardmäßig mit den anderen Komponenten verbunden ist. Zur Feinabstimmung der Map-Ausgabe können Sie für topicref -Elemente verschiedene Attribute einstellen. Beispielsweise steuert das linking-Attribut, wie Beziehungen zu anderen topicref-Elementen als Verknüpfungen angegeben werden, und das toc-Attribut, ob das topicref-Element im Inhaltsverzeichnis oder der Navigationsausgabe angezeigt wird.

So öffnen Sie Topic-Referenzen in einer .ditamap-Datei:

    1. Öffnen Sie eine .ditamap-Datei mit Topic-Referenzen.

    2. Wählen Sie "DITA > Alle Topicrefs öffnen".

    3. Klicken Sie auf "OK", um die angezeigte Meldung zu bestätigen. Die verknüpften Topic-Referenzdateien werden in separaten Fenstern geöffnet.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Einfügen eines Topicref-Elements in eine .ditamap-Datei

Mit dem Befehl "Topicref einfügen" wird ein neues topicref-Element am aktuellen Einfügepunkt einer geöffneten .ditamap-Datei eingefügt oder ein ausgewähltes topicref-Element zur Referenzierung einer neuen Datei überschrieben.

So fügen Sie ein Topicref-Element in eine .ditamap-Datei ein:

    1. Öffnen Sie eine .ditamap-Datei.

    2. Klicken Sie mit der rechten Maustaste auf einen Einfügepunkt, an dem Sie ein neues topicref-Element einfügen möchten, und wählen Sie "Topicref einfügen". Das Dialogfenster zur Auswahl einer Topicref-Datei wird angezeigt.

    3. Wählen Sie eine Datei aus oder geben Sie im Feld für den Dateinamen den Namen der Topic-Datei an, die Sie als Topic-Referenz im DITA Topic einfügen möchten.

    4. Klicken Sie auf "Auswählen". Die Topic-Referenz wird in die .ditamap-Datei eingefügt.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Einfügen eines Conref-Elements in ein DITA Topic

DITA unterstützt die Conref-Funktion der DITA-Spezifikation. Wenn diese Funktion aufgerufen wird, fügt DITA eine Inhaltsreferenz als Texteinschub ein und formatiert sie mit DITA-Conref-Tags als bedingten Text. Standardmäßig ist Text dieses Bedingungstyps blau. Sie können die Farbe jedoch mithilfe des Gestaltungsfensters für strukturierte Schablonen ändern.

Das Conref-Attribut referenziert eine ID in einem Topic, das wiederverwendet werden kann. Sie können beispielsweise eine Reihe von Topics in einem verbundenen (DITA) oder verschachtelten Kontext für Authoring-Zwecke erstellen und jedes Topic einzeln an einer neuen Zielposition referenzieren. Bei der Ausgabe werden die Inhalte des ersten Topic durch das Topic mit dem Conref-Attribut aufgerufen.

So fügen Sie ein Conref-Element in ein DITA Topic ein:

    1. Öffnen Sie eine .dita-Datei.

    2. Blenden Sie das body-Element aus.

    3. Klicken Sie auf einen Einfügepunkt unter dem body-Element und fügen Sie ein gleichrangiges Element ein.

    4. Wählen Sie "DITA > Conref einfügen". Die DITA-Verweisverwaltung wird angezeigt.

    5. Wählen Sie im Bereich "Element-Tag" einen Tag.

    6. Wählen Sie im Feld "Elementdaten" das gewünschte Element und klicken Sie auf "Einfügen".

    7. Speichern und schließen Sie die Datei.

Standardmäßig werden Fehlermeldungen generiert, wenn die geöffnete Datei ein conref - oder ein xref -Element enthält, das nicht zugeordnet werden kann, oder eine Datei mit einem solchen Element referenziert. Wenn diese Meldungen nicht angezeigt werden sollen, wählen Sie "DITA > DITA-Optionen" und deaktivieren Sie "Conrefs beim Öffnen von Datei automatisch laden" und "Querverweise beim Öffnen von Datei automatisch laden".


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Einfügen von Querverweisen in eine DITA-Datei

Wenn das xref -Element in dem Dokument verfügbar ist, können Sie das Ziel und den Verknüpfungstext für interne und externe Querverweise definieren.

So fügen Sie einen internen Querverweis ein:

    1. Öffnen Sie eine .dita-Datei.

    2. Klicken Sie auf einen Einfügepunkt in einem leeren Element.

    3. Wählen Sie im Elementkatalog "Xref" und klicken Sie auf "Einfügen". Die DITA-Verweisverwaltung wird angezeigt.

    4. Wählen Sie einen Element-Tag in der Liste aus, für den Elementdaten verfügbar sind.

Hinweis: Aktivieren Sie "Alle Elemente anzeigen", um alle Elementdaten in der Liste "Elementdaten" anzuzeigen.

    5. Geben Sie im Feld "Alternativer Querverweistext" eine Textbeschreibung an, die anstelle des Texts des ausgewählten Elements angezeigt wird.

    6. Klicken Sie auf "Einfügen". Die Schaltfläche "Aktualisieren" wird angezeigt, wenn Sie ein vorhandenes xref-Element ändern.

So fügen Sie einen externen Querverweis ein:

    1. Öffnen Sie eine .dita-Datei.

    2. Klicken Sie auf einen Einfügepunkt in einem leeren Element.

    3. Wählen Sie im Elementkatalog "Xref" und klicken Sie auf "Einfügen". Die DITA-Verweisverwaltung wird angezeigt.

    4. Klicken Sie auf "Externer Querverweis". Das Dialogfenster "DITA-externer Querverweis" wird angezeigt.

    5. Geben Sie im Feld "Querverweisziel (href)" die URL einer externen Website ein.

    6. Geben Sie im Feld "Verknüpfungsziel von Querverweis" eine Textbeschreibung ein, die für die externe Website angezeigt wird.

    7. Klicken Sie auf "OK".

    8. Klicken Sie auf "Schließen".

Hinweis: Sie können eine vorhandene externe Referenz ändern, indem Sie darauf doppelklicken.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Zuweisen einer ID zu einem Element

Sie können DITA so konfigurieren, dass dem ausgewählten Element eine erzeugte ID zugewiesen wird. Die dem ausgewählten Element zugewiesene ID setzt sich aus dem Jahr, dem Monat, dem Tag, der Stunde, den Minuten und Sekunden und zwei nach dem Zufallsprinzip generierten Werten zusammen. Diese ID ist eindeutig pro Benutzer für die nächsten 100 Jahre. Im Dialogfenster "Optionen" können Sie ein ID-Präfix angeben. Wenn Sie ein ID-Präfix für jeden Benutzer angeben, werden für jedes Teammitglied eindeutige IDs erstellt.

So weisen Sie einem Element eine ID zu:

    1. Wählen Sie im Fenster "Strukturansicht" ein Element aus.

    2. Wählen Sie "DITA > ID für Element zuweisen" oder klicken Sie mit der rechten Maustaste auf das Element und wählen Sie "ID für Element zuweisen" aus.

DITA erzeugt automatisch eine ID und weist sie dem ausgewählten Element zu.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Aktualisieren von DITA-Referenzen

Sie können DITA so konfigurieren, dass Inhalte von topicref-, conref- oder xref-Elementen aktualisiert werden.

Aktualisieren von DITA Maps

Bei der Arbeit mit DITA Maps stellen Sie eventuell fest, dass ein oder mehrere topicref-Elemente aktualisiert werden müssen. Dadurch werden auch die DITA Maps aktualisiert.

Die Option zum Aktualisieren des ausgewählten topicref-Elements ist nur verfügbar, wenn sich der Einfügepunkt in einem topicref-Element befindet. Die Option "Alle Topicrefs in Datei aktualisieren" ist nur verfügbar, wenn sich der Einfügepunkt nicht in einem topicref-Element befindet. Außerdem berücksichtigt die Option "Alle Topicrefs in Datei aktualisieren" die Einstellung des locktitle-Attributs. Bei der Einstellung Ja wird das navtitle-Attribut des topicref -Elements nicht aktualisiert.

So aktualisieren Sie DITA Maps:

    1. Wählen Sie "DITA > Referenzen aktualisieren".

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn ein topicref-Element ausgewählt ist, klicken Sie auf die Option zum Aktualisieren dieses Elements. DITA aktualisiert den Inhalt des ausgewählten topicref -Elements.

    Wenn kein topicref-Element ausgewählt ist, klicken Sie auf die Option "Alle Topicrefs in Datei aktualisieren". DITA aktualisiert alle topicref-Elemente in der aktuellen Datei, um die Änderungen in den Titeln der referenzierten Dateien widerzuspiegeln.

    3. Klicken Sie auf "OK".

Aktualisieren von DITA Topics

Während der Arbeit in DITA Topics stellen Sie eventuell fest, dass alle conref- oder xref -Elemente aktualisiert werden müssen.

So aktualisieren Sie DITA Topics:

    1. Wählen Sie "DITA > Referenzen aktualisieren".

    2. Führen Sie eine der folgenden Aktionen aus:

    Wählen Sie "Alle Conrefs in Datei aktualisieren". DITA aktualisiert alle conref-Elemente in der aktuellen Datei, um Änderungen im Quellinhalt widerzuspiegeln.

    Wählen Sie "Alle Querverweise in Datei aktualisieren". DITA aktualisiert alle xref-Elemente in der aktuellen Datei, um Änderungen in den Titeln der referenzierten Dateien widerzuspiegeln.

    3. Klicken Sie auf "OK".


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Erzeugen eines FrameMaker-Dokuments aus einer DITA Map

Sie können ein FrameMaker-Dokument aus einer DITA Map erzeugen.

So erzeugen Sie ein FrameMaker-Dokument aus einer DITA Map:

    1. Öffnen Sie eine .ditamap-Datei.

    2. Wählen Sie "DITA > FM-Dokument aus DitaMap erzeugen". Das Dialogfenster zur Eingabe eines neuen Dokumentnamens wird angezeigt.

    3. Geben Sie im Feld zur Eingabe des Namens den Namen des zu erstellenden FrameMaker-Dokuments mit der Erweiterung ".fm" ein. FrameMaker erzeugt das neue strukturierte FrameMaker-Dokument anhand des Inhalts der .ditamap-Datei. Eine Meldung bestätigt den erfolgreichen Abschluss dieser Task.

    4. Klicken Sie auf "OK".


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Einstellen der DITA-Optionen

Sie können im Dialogfenster "DITA-Optionen" allgemeine, Import- und Export-DITA-Optionen festlegen.

    1. Wählen Sie "DITA > DITA-Optionen". Das Dialogfenster "DITA-Optionen" wird angezeigt.

    2. Wählen Sie in der Liste "DITA Topic-Anwendung" eine Topic-Anwendung aus. Diese Auswahl bestimmt die Strukturanwendung, die geöffnet wird, wenn Sie ein neues Topic durch Doppelklicken auf die Topic-Referenz, die Inhaltsreferenz oder den Querverweis öffnen oder ein in FrameMaker geöffnetes Topic speichern. Sie bestimmt auch die Anwendung, die verwendet wird, wenn DITA eine Topic-Datei beim Zuordnen von Referenzen öffnet. Außerdem wird hierdurch der im Menü "DITA > Neue DITA-Datei" angezeigte Eintrag "Neue <Map>" festgelegt. Die in der Liste "DITA Topic-Anwendungen" verfügbaren Optionen werden durch die XML-Anwendungen bestimmt, die Sie in der Datei "structapps.fm" definiert haben.

    3. Wählen Sie in der Liste "DITA Map-Anwendung" eine Map-Anwendung aus. Die Auswahl bestimmt die Strukturanwendung, die geöffnet wird, wenn Sie eine neue Map durch Doppelklicken auf die Topic-Referenz mit der DITA Map-Referenz öffnen oder eine in FrameMaker geöffnete Map speichern. Außerdem werden hierdurch die im Menü "DITA > Neue DITA-Datei" angezeigten Einträge "Neues <Topic>", "Neues <Konzept>", "Neuer <Task>" und "Neue <Referenz>" definiert. Die in der Liste "DITA Map-Anwendungen" verfügbaren Optionen werden durch die XML-Anwendungen bestimmt, die Sie in der Datei "structapps.fm" definiert haben.

    4. Wählen Sie in der Liste "DITA Book-Anwendung" eine Book-Anwendung aus. Diese Auswahl bestimmt die Strukturanwendung, die verwendet wird, wenn Sie für die Option "Ditamap-Datei" den Befehl "FM DITABook aus ditamap-Datei erstellen" wählen, um aus einer DITA Map ein FrameMaker-Buch zu erzeugen. Die in der Liste "DITA Book-Anwendung" verfügbaren Optionen werden durch die XML-Anwendungen bestimmt, die Sie in der Datei "structapps.fm" definiert haben.

    5. Wählen Sie in der Liste "Standardtyp 'Neu'" entweder "*.xml" oder "*.dita". Hierdurch wird die Dateierweiterung für ein neues Topic (.xml oder .dita) festgelegt. Diese Erweiterung wird nur angewendet, wenn Sie keine Erweiterung für die neue Datei angeben.

    6. Geben Sie im Feld "Standard-ID-Präfix" ein ID-Präfix ein. Dieses Präfix wird neuen von DITA erzeugten IDs zugewiesen.

    7. Deaktivieren Sie die Option "Conrefs beim Öffnen von Datei automatisch laden". Standardmäßig ist diese Option aktiviert und Inhaltsreferenzen werden beim Öffnen einer .dita-Datei automatisch geladen.

    8. Deaktivieren Sie die Option "Querverweise beim Öffnen von Datei automatisch laden". Standardmäßig ist diese Option aktiviert und Querverweise werden beim Öffnen einer .dita-Datei automatisch geladen.

    9. Aktivieren Sie die Option "Prolog beim Öffnen von Datei konditionalisieren". Wenn eine DITA-Datei mit einem prolog-Element importiert wird und diese Option aktiviert ist, wird der Bedingungstyp DITA-Prolog angewendet. Standardmäßig sind diese Bedingungen in der strukturierten Schablone auf Hide gesetzt. Außerdem wird der bedingte Text gespeichert (exportiert), unabhängig davon, ob er angezeigt wird (OutputAllTextWithoutPIs). Wird beim Importieren kein entsprechender Bedingungs-Tag in der strukturierten Schablone gefunden, dann wird DITA-Prolog hinzugefügt und auf Show (in Rot) gesetzt.

Hinweis: Ist diese Option nicht aktiviert, werden alle prolog- oder draft-comment-Elemente importiert und unter Verwendung der Formatierung aus der EDD und der strukturierten Schablone ohne Bedingungs-Tags angezeigt.

    10. Aktivieren Sie die Option "Kommentare beim Öffnen von Datei konditionalisieren". Wenn eine DITA-Datei mit einem draft-comment-Element importiert wird und diese Funktion aktiviert ist, wird der Bedingungstyp DITA-Comment angewendet. Standardmäßig sind diese Bedingungen in der strukturierten Schablone auf Hide gesetzt. Außerdem wird der bedingte Text gespeichert (exportiert), unabhängig davon, ob er angezeigt wird (OutputAllTextWithoutPIs). Wird beim Importieren kein entsprechender Bedingungs-Tag in der strukturierten Schablone gefunden, dann wird DITA-Comment hinzugefügt und auf Show (in Rot) gesetzt. Ist "Kommentare beim Öffnen von Datei konditionalisieren" nicht aktiviert, werden alle draft-comment-Elemente importiert und unter Verwendung der Formatierung aus der EDD und der strukturierten Schablone ohne Bedingungs-Tags angezeigt.

    11. Deaktivieren Sie die Option "IDs automatisch hinzufügen, falls Element dies erfordert". Standardmäßig ist diese Option aktiviert und Elementen werden bei Bedarf automatisch IDs hinzugefügt. Der dem ausgewählten Element zugewiesene ID-Wert setzt sich aus Werten für das Jahr, den Monat, den Tag, die Stunde, die Minuten und Sekunden und zwei nach dem Zufallsprinzip generierten Werten zusammen. Diese ID ist eindeutig pro Benutzer für die nächsten 100 Jahre.

    12. Standardmäßig ist die Option "Neue Themen in DITA-Element einschließen" aktiviert und FrameMaker schließt neue Elemente auf Topic-Ebene wie topic, concept, reference und task, in ein dita-Element (Standard) ein. Deaktivieren Sie diese Option bei Bedarf.

    13. Wählen Sie die Option "Externen Querverweisen Hypertext-Marke hinzufügen", um alle neuen Hypertext-Marken, die Sie in einer DITA-Datei definieren, in externe xref-Elemente umzuwandeln. Sie können eine aktive PDF-Verknüpfung zu einer URL erstellen, wenn Xref-Elemente mit einer Quelle, die das Attribut "external" verwendet, von einem offenen Dokument "Als PDF gespeichert" werden. Ist diese Option ausgewählt, erhält das Element das Zeichenformat "link-asis" und ein unstrukturierter FrameMaker wird darin platziert, wenn Sie eine DITA-Datei öffnen, die ein xref-Element mit dem Quellattribut "external" enthält. Der Text dieser Marke ist der Wert der Href des xref-Elements, mit vorangestelltem "message URL". Hierdurch wird ein aktiver URL-Hyperlink generiert, der als PDF gespeichert werden kann. (Früher konnten nur FM-Xref-Elemente eine aktive Verknüpfung in einer PDF-Datei, die mithilfe dieser Anwendung aus FrameMaker heraus generiert wurde, erstellen.)

Hinweis: Als "internal" markierte Xrefs sind weiterhin in einem PDF-Dokument nicht anklickbar. Um dies zu erreichen, kann eine FM-Xref verwendet werden, wo immer der damit verbundene Text von der Quelle der FM-Xref ausfindig gemacht werden kann.

    14. Wählen Sie "Konvertierung Indexeintrag in Indexmarkierung", um alle Indexeinträge beim Importieren einer Datei in ein strukturiertes Dokument in index-Markenelemente zu konvertieren.

    15. Standardmäßig ist die Option "Spalten in Tabellen zählen" aktiviert. Deaktivieren Sie diese Option, wenn FrameMaker die Tabellenspalten beim Importieren einer Datei in ein strukturiertes Dokument nicht zählen soll.

    16. Wählen Sie "Konvertierung Indexmarkierung in Indexeintrag", um alle Indexmarken beim Importieren einer Datei in ein strukturiertes Dokument in index term-Elemente zu konvertieren.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Einstellen von Optionen zur Anzeige von Attributen

Attribute werden verwendet, um XML-Elemente zu beschreiben oder zusätzliche Informationen bereitzustellen, die zur Identifizierung eines Elements oder Steuerung der Formatierung verwendet werden. Vor der Verwendung von Attributen müssen Sie die Attribute in einem Dokument identifizieren und sie je nach Bedarf ein- oder ausblenden.

So stellen Sie Attributanzeige-Optionen ein:

    1. Wählen Sie "Darstellung > Attributanzeige-Optionen" aus. Das Dialogfenster "Attributanzeige-Optionen" wird angezeigt.

    2. Führen Sie eine der folgenden Aktionen aus:

    Wenn Elemente nur Attribute anzeigen sollen, die entweder erforderlich sind oder in der Strukturansicht über Werte verfügen, wählen Sie "Benötigte und angegebene Attribute".

    Wenn Elemente alle Attribute anzeigen sollen, die ihnen in der Strukturansicht zugewiesen sind, unabhängig von den Werten oder Anforderungen, wählen Sie "Alle Attribute".

    Wenn die Attribute aller Elemente in der Strukturansicht ausgeblendet werden sollen, wählen Sie "Keine Attribute".

    3. Klicken Sie auf "Zuweisen".


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Erstellen von FrameMaker-Büchern aus DITA Maps

Mit dem Befehl "FM DITABook aus ditamap-Datei erstellen" können Sie ein FrameMaker-Buch aus einer DITA Map-Datei erstellen.

Die Topicrefs auf der obersten Ebene der DITA Map werden im FrameMaker-Buch zu Kapiteln, die verschachtelte Topicrefs enthalten. Die Formatierung wird durch die Strukturanwendung bestimmt, die Sie für Bücher im Dialogfenster "DITA-Optionen" ausgewählt haben.

So erstellen Sie ein FrameMaker-Buch aus einer DITA Map-Datei:

    1. Wählen Sie "DITA > FM DITABook aus ditamap-Datei erstellen".

Hinweis: Um ein FrameMaker-Buch aus einer DITA-Map zu erstellen, rufen Sie die Anwendung DITA-Map-FM auf, damit gewährleistet ist, dass die erforderliche Vor- und Nachbereitung vollständig durchgeführt wird.

    2. Wählen Sie im Dialogfenster "Wählen Sie eine ditamap-Datei" eine .ditamap-Datei aus und klicken Sie auf "Auswählen".

Hinweis: Das Buch wird mit der im Dialogfenster "DITA-Optionen" angegebenen DITA-Buch-Anwendung generiert.

    3. Geben Sie im Dialogfenster "Buch speichern" im Feld für den Dateinamen einen eindeutigen Namen für das Buch ein und klicken Sie auf "Sichern". Ein Buchfenster wird angezeigt und die Dateien werden dem Buch hinzugefügt.

Nun stehen Ihnen die gesamte Leistungsfähigkeit und alle Funktionen von FrameMaker-Büchern zur Verfügung – angefangen bei der Erzeugung eines Inhaltsverzeichnisses und eines Index bis hin zur Erstellung hochwertiger PDF- und HTML-Ausgaben.

Hinweis: Doppelklicken Sie auf eine der Dateien im Buchfenster, um diese Datei in einer Registerkarte zu öffnen. Wenn Sie ein zweites Mal auf den Dateinamen im Buchfensters doppelklicken, wird die Datei in einem separaten Fenster geöffnet.

    4. Speichern Sie das Buch.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Verwendung von Indexterm-Elementen

DITA unterstützt indexterm-Markenelemente in FrameMaker. Der API-Client wandelt FrameMaker-Indexmarken mit durch Doppelpunkt abgetrennten Untereinträgen in verschachtelte XML indexterm-Elemente um und umgekehrt, damit Inhalt problemlos importiert und exportiert werden kann.

Bevor Sie Indexeinträge konvertieren, kopieren Sie den folgenden Code in WordPad und speichern Sie ihn in einem beliebigen Ordner als XML-Datei mit dem Namen "review_ditamagic.xml". Öffnen Sie die Datei mithilfe der strukturierten DITA-Topic-FM-Anwendung in FrameMaker:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE topic PUBLIC "-//OASIS//DTD DITA Composite//EN" "ditabase.dtd" [
<!-- Begin Document Specific Declarations -->
<!-- End Document Specific Declarations -->
]>
<topic id = "software_review_ditamagic"
    xmlns:ditaarch = "http://dita.oasis-open.org/architecture/2005/">
<title>Review: DitaMagic</title>
<body><dl><dlentry><dt>Name</dt>
<dd>DitaMagic</dd></dlentry>
<dlentry><dt>Version</dt>
<dd>1</dd></dlentry>
<dlentry><dt>Hersteller</dt>
<dd>InfoTypes Ltd.</dd></dlentry>
<dlentry><dt>Plattformen</dt>
<dd>Linux, Windows</dd></dlentry>
<dlentry><dt>Preis</dt>
<dd>$100</dd></dlentry>
<dlentry><dt>Home</dt>
<dd><xref  href = "http://www.adobe.com/" scope = "external">www.adobe.com</xref></dd></dlentry></dl>
<section>DitaMagic<indexterm class = "- topic/indexterm ">DITA</indexterm><indexterm
    class = "- topic/indexterm ">Software</indexterm><indexterm
    class = "- topic/indexterm ">Autoren</indexterm> is a comprehensive
Ein Paket von Werkzeugen und Anwendungen für die Arbeit mit DITA. Typenarchitekten,
Autoren, Informationsarchitekten, Build-Entwickler und Informations-
Entwickler finden alle Werkzeuge und Schnittstellen, die sie für ihre Arbeit benötigen.</section>
<section><title>Pros</title><ul><li>Komplettpaket.</li>
<li>DITA ist vollständig implementiert.</li></ul></section>
<section conref = "shared.dita#shared/footer"></section></body></topic>

So wandeln Sie Indexterm-Elemente um:

    1. Wählen Sie "Datei> Öffnen".

    2. Öffnen Sie die Datei "review_ditamagic.dita" aus dem Ordner, in dem Sie sie gespeichert haben.

    3. Wählen Sie "Bearbeiten > Suchen/Ändern".

    4. Wählen Sie im Aufklappmenü "Suchen" die Option "Beliebige Marke".

    5. Klicken Sie auf "Suchen".

    6. Wählen Sie "Spezial > Marke".

    7. Ändern Sie im Dialogfenster "Marke" den sekundären Indexterm-Untereintrag Autoren zu: Dokumentationserstellung;Lösungen.

Sie haben nun einen Indexeintrag dritter Ordnung korrigiert und einen separaten primären Eintrag hinzugefügt. (Die Farben geben die Indexterm-Hierarchie an und das Semikolon bedeutet, dass ein primärer Eintrag folgt.)

    8. Klicken Sie auf "Marke bearbeiten" und schließen Sie das Dialogfenster "Marke" sowie das Dialogfenster "Suchen/Ändern".

    9. Speichern und schließen Sie die Datei "review_ditamagic.xml".

    10. Öffnen Sie die Datei "review_ditamagic.xml" in einem Text- oder XML-Editor (oder verwenden Sie die Textbearbeitungsfunktionen von FrameMaker).

    11. Suchen Sie (visuell oder mithilfe der Suchfunktion) die indexterm-Elemente.

Durch Doppelpunkt getrennter Markentext wird in verschachtelte indexterm-Elemente und durch Semikolons abgetrennte Einträge in indexterm-Elemente auf oberster Ebene umgewandelt.

Hinweis: Beim Import wird der verschachtelte Satz von <Indexterm>-Elementen in ein Indexmarken-Element (ein primärer Eintrag mit Untereinträgen) konvertiert und das andere <Indexterm>-Element in ein zweites Indexmarken-Element.

    12. Schließen Sie die Datei "review_ditamagic.xml", ohne sie zu speichern.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Ändern von Schablonenkomponenten und Dateien für strukturierte DITA-Schablonen

Da die DITA-Funktion drei getrennte, jedoch integrierte FrameMaker-Anwendungen verwendet, kann das Gestaltungsfenster für strukturierte Schablonen drei oder mehr verschiedene Schablonen erstellen.

Hinweis: Von einer Änderung der Struktur selbst wird abgeraten. Die Struktur ist für Plug-Ins, andere Komponenten dieser Anwendung und andere Anwendungen mit dieser Funktion ausgelegt.

Im Folgenden werden die drei FrameMaker-Anwendungen und ihre Schablonenkomponenten beschrieben:

DITA-Topic-FM

Diese Anwendung wird zum Erstellen und Öffnen von topic-, concept, reference- oder task-Elementen verwendet. Sie können die Format- und Seitenlayout-Funktionen des EDD und der Schablonenkomponenten ändern, um die Dokumenterstellung auf Topic-Ebene zu optimieren. Sie können die folgende strukturierte Vorlagendatei zur Veränderung des Erscheinungsbilds modifizieren:

    $STRUCTDIR\xml\DITA-Topic-FM\app\dita-topic.edd.fm

    $STRUCTDIR\xml\DITA-Topic-FM\app\dita-topic.template.fm

DITA-Map-FM

Diese Anwendung wird zum Erstellen und Öffnen von DITA Maps verwendet. Sie können die Format- und Seitenlayout-Funktionen des EDD und der Schablonenkomponenten ändern, um die Dokumenterstellung auf DITA Map-Ebene zu optimieren. Sie können die folgende strukturierte Vorlagendatei zur Veränderung des Erscheinungsbilds modifizieren:

    $STRUCTDIR\xml\DITA-Map-FM\app\dita-map.edd.fm

    $STRUCTDIR\xml\DITA-Map-FM\app\dita-map.template.fm

DITA-Book-FM

Diese Anwendung wird zum Erstellen von FrameMaker-Büchern aus DITA Maps verwendet. Sie können die Format- und Seitenlayout-Funktionen des EDD und der Schablonenkomponenten beispielsweise zur Ausgabe einer besseren Druck- oder PDF-Qualität ändern. Sie können die folgende strukturierte Vorlagendatei zur Veränderung des Erscheinungsbilds modifizieren:

    $STRUCTDIR\xml\DITA-Book-FM\app\dita-book.edd.fm

    $STRUCTDIR\xml\DITA-Book-FM\app\dita-book.template.fm

Durch die drei Anwendungen wird die Gestaltung strukturierter Schablonen äußerst flexibel in Bezug auf die Feinabstimmung der DITA-Authoring- und Dokumenterzeugungsumgebung sowie die Ausgabe.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Ausgeben von DITA-Dokumenten

Die DITA-Funktion umfasst integrierte Methoden zur Ausgabe in zahlreichen Formaten wie kompilierte Hilfe, HTML und FrameMaker-Bücher.


Strukturiertes Authoring mit DITA / Verwenden von DITA in FrameMaker 8

Anpassen der DITA-Unterstützung von FrameMaker

Sie können die DITA-Funktionen erweitern, indem Sie XSLT, das FrameMaker Developer Kit (FDK) oder mit Dritthersteller-Programmen entwickelte eigene Plug-Ins verwenden.

Verwenden von XSLT

Sie können XSLT-Formatvorlagen für DITA in Strukturanwendungsdefinitionen verwenden, um die zugrunde liegende XML beim Importieren oder Exportieren umzuwandeln. XSLT ist eine für die DITA-Funktion wichtige Methode zur Umwandlung von DITA Maps in FrameMaker-Bücher. Sie können die Formatvorlagen bearbeiten oder in Kombination mit anderen Formatvorlagen verwenden, um das Verhalten zu ändern, oder zusätzliche Formatvorlagen verwenden, um das Importieren, Exportieren oder Ausgeben von DITA-Inhalten in FrameMaker zu ändern.

Verwenden von FDK

Für Entwickler ist FDK eine leistungsstarke Möglichkeit zum Anpassen der internen FrameMaker-Mechanismen, mit der sie direkt auf die FrameMaker Authoring-Umgebung und die Formatierungs-Engine zugreifen können. Die DITA-Hauptfunktionen wurden mit FDK entwickelt, sodass zusätzliche Plug-Ins zur Erweiterung dieser Funktionen erstellt werden können. FDK kann von der Adobe-Website unter www.adobe.com/devnet/framemaker/ heruntergeladen werden..

Programme von Drittanbietern

Für FrameMaker werden zahlreiche Plug-Ins von verschiedenen Herstellern angeboten. Einige der bereits für den strukturierten FrameMaker entwickelten Plug-Ins können zur Erweiterung der DITA Authoring-Funktionen in FrameMaker verwendet werden. Einige Hersteller bieten Programme an, die direkt mit Plug-Ins und strukturierten Anwendungen von DITA zusammenarbeiten.


Strukturiertes Authoring mit DITA

Tipps

Der folgende Abschnitt enthält einige Tipps zur Verwendung von Adobe FrameMaker DITA.

    Wenn Sie häufig Referenzen (conref- oder xref -Elemente) verwenden, ist es eventuell effizienter, die Zieldateien zuerst zu öffnen. Zieldateien enthalten das Ziel eines xref-Elements oder die Quelle eines conref-Elements. Durch Öffnen der Zieldateien vor den Topic-Dateien wird der Referenzierungsvorgang beschleunigt.

    Zur Umwandlung unstrukturierter Dateien in DITA kann es empfehlenswert sein, das automatische Laden von xref- und conref-Elementen zu deaktivieren. Andernfalls werden möglicherweise beim Öffnen von Dateien zahlreiche Referenzierungsfehler angezeigt, wenn die Zieldateien der Referenzen noch nicht vollständig gültig sind.

    Achten Sie bei Titeln mit conref-Elementen darauf, dass die Zieldateien beim Aktualisieren der DITA Map-Datei geöffnet sind. Andernfalls wird der conref-Elementinhalt nicht in der Topic-Referenz-Bezeichnung angezeigt.


Funktionen der Adobe Technical Communication Suite in Adobe FrameMaker

Erstellen und Bearbeiten von Bildern mit RoboScreen Capture

Einfügen und Bearbeiten von Adobe Captivate-Demos

Starten von Adobe Acrobat Connect in Adobe FrameMaker

Senden von PDFs zur Überprüfung


Funktionen der Adobe Technical Communication Suite in Adobe FrameMaker

Erstellen und Bearbeiten von Bildern mit RoboScreen Capture

RoboScreenCapture ist ein Tool zum Erstellen von Bildschirmabbildungen, mit dem Sie Bilder erstellen und bearbeiten können. Sie können diese Bilder in Hilfesystemen verwenden, z. B. in Online-Tutorials, Handbüchern, Schulungsunterlagen, Präsentationen, Marketingmaterial und Webseiten.

Durch die Integration von Adobe® FrameMaker® 8 in RoboScreenCapture können Sie:

    1. RoboScreenCapture von Adobe FrameMaker aus öffnen

    2. Bilder, die in RoboScreenCapture erstellt wurden, in Adobe FrameMaker einfügen

    3. Bilder bearbeiten, die mit RoboScreenCapture durch Referenz in Adobe FrameMaker importiert wurden. Sie können auch mit der rechten Maustaste auf die Option "Bearbeiten" klicken, um mit RoboScreenCapture ein Bild zu aktivieren, und das Bild dann in RoboScreenCapture bearbeiten. Nachdem Sie das Bild in RoboScrrenCapture gespeichert und geschlossen haben, werden die am Bild vorgenommenen Änderungen in Adobe FrameMaker sichtbar.

Hinweis: Diese Option ist nur für Bildformate verfügbar, die von RoboScreenCapture unterstützt werden.

RoboScreen Capture kann für die Durchführung der folgenden Aufgaben eingesetzt werden:

    Aufnahme des Bildschirms in 10 Modi, z. B. "Freihand", "Virtueller Desktop" und "Mehrbereich"

    Aufnahme des Bildschirms über ein Dropdownmenü, Zuweisen eigener Tastenkombinationen und Steuerung von RoboScreenCapture mithilfe von Sprachbefehlen

    Erstellen von komplizierten Bildschirmabbildungen, z. B. von Spielen im DirectX-, Direct3D-, 3Dfx-, Voodoo- und Glide-Modus

    Aufnahme von über den Bildschirmrand hinaus reichendem Text auf langen Webseiten

    Bearbeiten von Bildern

    Speichern der Bildschirmabbildungen in mehr als 20 Bildformaten

    Automatisches Speichern von Bildschirmabbildungen in Bilddateien

    Schnelles Hinzufügen von Bildstempeln, Frames, Schatten usw.

    Ändern von Bildfarben, Spiegeln oder Drehen von Bildern und Beschneiden von Bildern auf eine kleinere Größe

    Hinzufügen von kennzeichnenden Stempeln zu jeder Bildschirmabbildung, z. B. Firmenname oder Logo

    Bearbeiten bestimmter Bereiche der erfassten Abbildung mit Formen, Schatten usw.


Funktionen der Adobe Technical Communication Suite in Adobe FrameMaker / Erstellen und Bearbeiten von Bildern mit RoboScreen Capture

Erstellen von Bildern mit RoboScreenCapture und Einfügen der Bilder in Adobe FrameMaker

Sie können RoboScreenCapture in Adobe FrameMaker aktivieren, um eine Bildschirmabbildung von einer Anwendung zu erstellen, die auf Ihrem Computer läuft, und die Abbildung in RoboScreenCapture speichern. Anschließend kann die Datei in ein geöffnetes FrameMaker-Dokument importiert werden.

So erstellen Sie ein Bild mit RoboScreenCapture und fügen es in Adobe FrameMaker ein:

    1. Öffnen Sie das FrameMaker-Dokument, in dem das Bild eingefügt werden soll.

    2. Wählen Sie "Datei"> "RoboScreenCapture starten". Das Programm RoboScreenCapture wird geöffnet.

    3. Erstellen Sie mithilfe der verschiedenen Optionen im RoboScreenCapture-Menü "Aufnahme" eine Bildschirmabbildung der gewünschten Anwendung.

    4. Speichern Sie die Datei und schließen Sie RoboScreenCapture.

    5. Wählen Sie in Adobe FrameMaker "Datei" > "Importieren" > "Datei". Das Dialogfeld "Importieren" wird angezeigt.

    6. Wählen Sie die in RoboScreenCapture erstellte Datei aus.

    7. Wählen Sie "Import durch Referenz".

    8. Klicken Sie auf "Importieren".


Funktionen der Adobe Technical Communication Suite in Adobe FrameMaker / Erstellen und Bearbeiten von Bildern mit RoboScreen Capture

Importierte Bilder mit RoboScreenCapture bearbeiten

Sie können mit RoboScreenCapture Bilder bearbeiten, die durch Referenz in FrameMaker-Dokumente eingefügt wurden.

So bearbeiten Sie mit RoboScreenCapture ein Bild in Adobe FrameMaker:

    1. Öffnen Sie Adobe FrameMaker.

    2. Wählen Sie "Datei" > "Öffnen" und öffnen Sie das Dokument mit dem Bild, das Sie bearbeiten möchten.

    3. Wählen Sie das gewünschte Bild aus.

    4. Klicken Sie mit der rechten Maustaste auf das Bild und klicken Sie dann auf "Mit RoboScreenCapture bearbeiten". Das Programm RoboScreenCapture wird geöffnet, und das zu bearbeitende Bild wird angezeigt.

    5. Bearbeiten Sie das Bild.

    6. Wählen Sie "Datei" > "Speichern".

    7. Wählen Sie "Datei" > "Beenden", um RoboScreenCapture zu beenden.

Das bearbeitete Bild wird in Adobe FrameMaker aktualisiert und kann nun im Dokument verwendet werden.


Funktionen der Adobe Technical Communication Suite in Adobe FrameMaker

Einfügen und Bearbeiten von Adobe Captivate-Demos

Adobe Captivate ist ein E-Learning-Authoring-Tool zum Erstellen von Software-Demos, Software-Simulationen, verschiedenen Szenarien und Tests im SWF-Format.

Die Integration von Adobe Captivate in Adobe FrameMaker ermöglicht Ihnen Folgendes:

    Öffnen von Adobe Captivate von Adobe FrameMaker aus, um Adobe Captivate-Demos zu erstellen/aufzuzeichnen und diese Demos als SWF-Dateien in Adobe FrameMaker zu importieren

    Einfügen von Adobe Captivate-Filmen in ein FrameMaker-Dokument

    Bearbeiten eines Adobe Captivate-Films, der in ein FrameMaker-Dokument eingefügt wurde

Hinweis: Sie können diese Funktion nur verwenden, wenn Adobe Captivate 2 oder Adobe Captivate 3 installiert ist.

So starten Sie Adobe Captivate, erstellen einen Film und fügen ihn in ein FrameMaker-Dokument ein:

    1. Öffnen Sie Adobe FrameMaker.

    2. Wählen Sie "Datei" > "Adobe Captivate" > "Adobe Captivate starten". Die neueste Version von Adobe Captivate, die auf Ihrem Computer installiert ist, wird geöffnet. Wenn auf Ihrem Computer z. B. Adobe Captivate 2 und Adobe Captivate 2 installiert sind, wird Adobe Captivate 3 geöffnet.

    3. Wählen Sie "Bearbeiten" > "Voreinstellungen" und legen Sie die Aufzeichnungsoptionen fest.

    4. Klicken Sie auf "Aufzeichnen", um ein neues Projekt zu erstellen.

    5. Verwenden Sie die Aufzeichnungsoptionen und speichern Sie den Film. Veröffentlichen Sie den Film im SWF-Format. Weitere Informationen finden Sie im Adobe Captivate-Benutzerhandbuch. (www.adobe.com/support/ documentation/en/captivate/

    6. Schließen Sie Adobe Captivate.

    7. Wählen Sie in Adobe FrameMaker "Datei" > "Öffnen", um das Dokument zu öffnen, in dem die Adobe Captivate-Demo eingefügt werden soll.

    8. Positionieren Sie den Cursor an der Position, an der die Demo eingefügt werden soll.

    9. Wählen Sie "Datei > importieren".

    10. Wählen Sie im Dialogfeld "Importieren" die SWF-Datei aus.

    11. Wählen Sie "Import durch Referenz" oder "In Dokument kopieren".

    12. Klicken Sie auf "Importieren". Die SWF-Datei wird in das FrameMaker-Dokument eingefügt.

So erstellen Sie einen Adobe Captivate-Film und fügen ihn in ein FrameMaker-Dokument ein:

    1. Öffnen Sie Adobe FrameMaker.

    2. Wählen Sie "Datei" > "Öffnen", um das Dokument zu öffnen, in dem der Adobe Captivate-Film eingefügt werden soll.

    3. Bewegen Sie den Cursor zu der Position, an der der Film eingefügt werden soll.

    4. Wählen Sie "Datei" > "Adobe Captivate" > "Neue Adobe Captivate-Demo einfügen". In einem Dialogfeld werden Sie aufgefordert, einen Namen für den Film einzugeben.

    5. Geben Sie einen Namen für den Film ein (z. B. meinFilm.swf).

    6. Klicken Sie auf "OK".

Das Adobe FrameMaker-Fenster wird minimiert, und der Startbildschirm der neuesten Adobe Captivate-Version wird geöffnet.

    7. Wählen Sie "Bearbeiten" > "Voreinstellungen" und legen Sie die Aufzeichnungsoptionen fest.

    8. Klicken Sie auf "Aufzeichnen", um ein neues Projekt zu erstellen.

    9. Verwenden Sie die Optionen zum Aufzeichnen des Films. Weitere Informationen finden Sie im Adobe Captivate-Benutzerhandbuch. (www.adobe.com/support/ documentation/en/captivate/).

    10. Wählen Sie "Datei" > "Beenden" In einem Dialogfeld werden Sie zum Speichern des Films aufgefordert.

    11. Klicken Sie auf "Ja".

Adobe Captivate wird geschlossen, und Adobe FrameMaker wird wieder aktiviert. Die SWF-Datei wurde an der Cursorposition eingefügt.

So bearbeiten Sie einen Adobe Captivate-Film:

    1. Öffnen Sie Adobe FrameMaker.

    2. Öffnen Sie das Dokument mit der Adobe Captivate-Demo, die Sie bearbeiten möchten:

    3. Wählen Sie den Film aus.

    4. Verwenden Sie eine der folgenden Methoden:

    Klicken Sie mit der rechten Maustaste auf den Film und wählen Sie "Mit Adobe Captivate bearbeiten".

    Wählen Sie "Datei" > "Adobe Captivate" > "Mit Adobe Captivate bearbeiten".

    5. Wenn die Projektdatei des Films verfügbar ist, wird beim Start von Adobe Captivate die Projektdatei zur Bearbeitung geöffnet. Das Adobe FrameMaker-Fenster wird minimiert.

    6. Bearbeiten Sie den Adobe Captivate-Film. Weitere Informationen finden Sie im Adobe Captivate-Benutzerhandbuch. (www.adobe.com/support/ documentation/en/captivate/).

    7. Wählen Sie "Datei" > "Beenden". In einem Dialogfeld werden Sie zum Speichern des Films aufgefordert.

    8. Klicken Sie auf "Ja". Die SWF-Datei wird im FrameMaker-Dokument automatisch aktualisiert.

Hinweis: Vergewissern Sie sich, dass die SWF-Datei gespeichert wurde, bevor Sie Adobe Captivate schließen.


Funktionen der Adobe Technical Communication Suite in Adobe FrameMaker

Starten von Adobe Acrobat Connect in Adobe FrameMaker

Sie können Adobe® Acrobat® Connect von Adobe FrameMaker aus starten, um Online-Meetingräume einzurichten oder sich Zugang zu ihnen zu verschaffen.

Hinweis: Weitere Informationen über die Verwendung der verschiedenen Funktionen von Adobe Acrobat Connect finden Sie unter www.adobe.com/support/acrobatconnect/.


Funktionen der Adobe Technical Communication Suite in Adobe FrameMaker / Starten von Adobe Acrobat Connect in Adobe FrameMaker

Acrobat Connect-Konto erstellen

Um mit Adobe Acrobat Connect ein Online-Meeting einrichten zu können, müssen Sie zuerst ein Adobe Acrobat-Konto erstellen. Zum Erstellen eines Kontos richten Sie ein Testkonto ein oder kaufen ein Abonnement. Adobe Acrobat Connect-Funktionen werden mit Adobe® Acrobat® 3D, Version 8, aktiviert.

Hinweis: Zur Überprüfung von Dokumenten ist Adobe® Reader®, Version 7 oder höher, erforderlich.

    1. Öffnen Sie Adobe FrameMaker.

    2. Wählen Sie "Datei" > "Meeting eröffnen".

    3. Verwenden Sie eine der folgenden Methoden:

    Klicken Sie auf "Testkonto anlegen", um ein Testkonto einzurichten.

    Klicken Sie auf "Jetzt kaufen", um ein Abonnement zu kaufen.

    4. Führen Sie die Anweisungen zum Einrichten des Kontos am Bildschirm aus.


Funktionen der Adobe Technical Communication Suite in Adobe FrameMaker / Starten von Adobe Acrobat Connect in Adobe FrameMaker

Mit Adobe Acrobat Connect ein Meeting starten

Sie können Adobe Acrobat Connect von Adobe FrameMaker aus starten, um Online-Meetingräume einzurichten oder sich Zugang zu ihnen zu verschaffen.

So starten Sie ein Meeting mit Adobe Acrobat Connect:

    1. Wählen Sie "Datei" > "Meeting eröffnen".

    2. Klicken Sie auf "Anmelden" und geben Sie die folgenden Informationen ein:

Die URL Ihres Meetingraums im Format < connect.acrobat.com/<Name des Meetingraums>

    Ihre Anmeldungs-ID

    Ihr Anmeldungskennwort

    3. Klicken Sie auf "Anmelden".

    4. Klicken Sie auf "E-Mail-Einladung senden".

    5. Geben Sie die E-Mail-Adressen der Teilnehmer ein und klicken Sie auf "Senden".

    6. Klicken Sie auf "Meinen Bildschirm freigeben", um Ihre Benutzeroberfläche gemeinsam mit anderen Benutzern zu verwenden, und wählen Sie dann eine Bildschirmfreigabe-Option aus.

Desktop

Wenn Sie Ihren Desktop gemeinsam mit anderen Benutzern verwenden, sehen die Teilnehmer jeden Vorgang auf Ihrem Bildschirm, einschließlich E-Mail-Popups, Warnungen sowie alle sichtbaren Fenster und Anwendungen. Wählen Sie diese Option, wenn Ihre Demo mehrere Anwendungen und Fenster verwendet oder wenn die Bereiche, die Sie gemeinsam verwenden möchten, übereinander liegen.

Fenster

Sie können ein oder mehrere Fenster, die gegenwärtig auf Ihrem Computer geöffnet sind, mit den Meeting-Teilnehmern gemeinsam nutzen. Die Teilnehmer sehen nur die Fenster, die Sie ausgewählt haben. Wählen Sie diese Option, wenn Sie nur die Informationen in den ausgewählten Fenstern gemeinsam verwenden möchten.

Anwendung

Sie können eine oder mehrere Anwendungen, die gegenwärtig auf Ihrem Computer aktiviert sind, gemeinsam nutzen. Die Teilnehmer sehen nur die Anwendungen, die Sie ausgewählt haben (sowie die Fenster, die zu den Anwendungen gehören). Wählen Sie diese Option, wenn Sie Funktionen vorführen oder Dokumente gemeinsam nutzen möchten, die in einer oder mehreren Anwendungen geöffnet werden können.

    7. Klicken Sie auf "Akzeptieren", wenn Sie aufgefordert werden, Teilnehmern Zugang zum Meeting zu gewähren.

    8. Verwenden Sie eine der folgenden Methoden:

    Wenn ein Teilnehmer seinen Desktop für andere Teilnehmer freigeben soll, wählen Sie den Namen des Teilnehmers in der Teilnehmerliste aus, klicken auf die Schaltfläche "Benutzerrolle festlegen" und wählen dann die Option "Als Moderator festlegen", um gemeinsame Bildschirmverwendung zu ermöglichen.

    Um mit den Teilnehmern zu kommunizieren, geben Sie eine Nachricht im Chat-Pod ein, wählen die Teilnehmer aus, an die die Nachricht gesendet werden soll, und klicken dann auf "Nachricht senden".

    Verwenden Sie den Notizblock, wenn Sie sich während des Meetings Notizen machen möchten.


Funktionen der Adobe Technical Communication Suite in Adobe FrameMaker

Senden von PDFs zur Überprüfung

Mithilfe der Adobe FrameMaker-Funktion "Als PDF speichern (Zur Prüfung senden)" können Sie ein Dokument als PDF-Datei speichern und die PDF-Datei per E-Mail zum Überprüfen senden. Die ausgewählte Datei bzw. das ausgewählte Buch wird in eine PDF-Datei umgewandelt und im Standard-E-Mail-Programm auf Ihrem Computer an eine neue E-Mail-Nachricht angehängt. Sie können das Dokument dann zur Prüfung bzw. Überarbeitung senden, indem Sie die E-Mail-Adressen der Prüfer eingeben und die E-Mail senden.

Hinweis: Diese Funktion ist nur verfügbar, wenn Adobe Acrobat 8 oder höher installiert ist. Zur Prüfung des Dokuments ist Adobe Reader, Version 7, erforderlich.

So generieren Sie eine PDF-Datei und senden sie zum Überprüfen:

    1. Öffnen Sie das Dokument oder das Buch.

    2. Wählen Sie "Datei" > "Als PDF speichern (Zur Prüfung senden)". Das Dialogfeld "Dokument speichern" wird angezeigt.

    3. Geben Sie den gewünschten Dateinamen für die PDF-Datei ein und klicken Sie auf "Speichern". Das Dialogfeld "PDF Setup" wird angezeigt.

    4. Legen Sie die gewünschten Einstellungen für die zu erstellende PDF-Datei fest.

    5. Klicken Sie auf "Festlegen".

Die neue PDF-Datei wird mit Acrobat Distiller erstellt. Die generierte PDF-Datei wird im Programm Acrobat geöffnet, in dem die Startseite des Assistenten "Per E-Mail zur Überprüfung senden" angezeigt wird.

    6. Wählen Sie die PDF-Datei aus, die zur Prüfung gesendet werden soll.

    7. Klicken Sie auf "Weiter". Die Seite "Überprüfer einladen" wird angezeigt.

    8. Klicken Sie auf "Adressbuch" und wählen Sie die E-Mail-Adressen der Personen aus, die die PDF-Datei prüfen werden. Klicken Sie auf "OK".

    9. Klicken Sie auf "Weiter".

    10. Geben Sie auf der Seite "Vorschau der Einladung anzeigen" Betreff und Inhalt der E-Mail-Einladung ein, die an die Überprüfer gesendet werden.

    11. Klicken Sie auf "Einladung senden".

In einer Benachrichtigung über die ausgehende Nachricht werden Sie darüber informiert, dass eine E-Mail-Nachricht an die Standard-E-Mail-Anwendung auf Ihrem Computer gesendet wurde und dass die E-Mail automatisch von Ihrem E-Mail-Client gesendet wird. Eine Kopie der PDF-Datei wird als Anhang an die Überprüfer gesendet. Beim Öffnen dieses Dateianhangs zeigt Acrobat die PDF-Datei mit einer Kommentieren-Symbolleiste an.

    12. Klicken Sie auf "OK".


Eingabe in Dialogfenstern

Überblick über die Eingabe in Dialogfenstern

Windows

UNIX


Eingabe in Dialogfenstern

Überblick über die Eingabe in Dialogfenstern

Sie können in Dialogfenstern Zeichen eingeben, die auf der Tastatur nicht verfügbar sind (z. B. umbruchgeschützte Leerzeichen, n- und m-Bindestriche sowie spezielle Bindestriche).

Zeichen, die auf der Tastatur nicht verfügbar sind, werden je nach Plattform unterschiedlich behandelt:

    (Windows) Geben Sie eine Zeichenfolge ein, die mit einem umgekehrten Schrägstrich beginnt (\). Im Dialogfenster wird diese Zeichenfolge angezeigt, im Dokument dagegen das entsprechende Zeichen.

    (UNIX) Sie können diese Zeichen in einem Dialogfenster auf die gleiche Weise eingeben wie in einem Dokumentfenster. Im Dialogfenster wird jedoch die mit einem umgekehrten Schrägstrich beginnende Zeichenfolge angezeigt.

Zusätzlich zu den hier beschriebenen Sonderzeichen können Sie im Dialogfenster "Suchen/Ändern" Zeichen eingeben, die kein Zeichen, sondern eine Position repräsentieren (z. B. \P für ein Absatzende). Eine Liste dieser Zeichen finden Sie unter Suchen nach Sonder- und Steuerzeichen.

Informationen über die Eingabe von Sonderzeichen in einem Dokumentfenster finden Sie unter Eingeben von Sonderzeichen, Eingeben spezieller Leerzeichen und Ändern von Silbentrennung und Zeilenumbruch sowie im Online-Handbuch FrameMaker-Zeichensätze.

Alle hier beschriebenen Zeichenfolgen beginnen mit einem umgekehrten Schrägstrich (\). Um in einem Dialogfenster einen umgekehrten Schrägstrich als Zeichen einzugeben, müssen Sie ihn zweimal eingeben (\\).


Eingabe in Dialogfenstern

Windows

Die meisten Zeichen, die Sie in ein Dialogfenster eingeben, finden Sie auf der Tastatur. Wenn ein Zeichen auf der Tastatur nicht verfügbar ist, können Sie es gewöhnlich über seinen ANSI- oder Hex-Code oder über seine Zeichenfolge eingeben. (Weitere Informationen finden Sie im Online-Handbuch FrameMaker-Zeichensätze.)

In einigen Fällen müssen Sie allerdings eine mit einem umgekehrten Schrägstrich (\) beginnende Zeichenfolge verwenden, um ein spezielles Zeichen in ein Dialogfenster einzugeben. Im Dialogfenster wird diese Zeichenfolge angezeigt, im Dokument dagegen das entsprechende Zeichen. Die folgende Tabelle enthält die Zeichenfolgen, die Sie in ein Dialogfenster eingeben können. In einigen Fällen gibt es zwei mit umgekehrtem Schrägstrich beginnende Zeichenfolgen für ein Zeichen. Die Zeichenfolgen sind dann durch ein Komma getrennt angegeben.

Zeichen | Grafik | Eingabe im Dialogfenster
Auszeichnungspunkt |  | \b
Zirkumflex |  | \@
Kreuz |  | \d
Doppelkreuz |  | \Umschalttaste+d
Bindestrich (m) |  | \m
Bindestrich (n) |  | \=
Auslassung | … | \e
Florin |  | \Umschalttaste+f
Erzwungenes Zeilenende |  | \r
Bruchzahl |  | \ /
Gravis |  | \{
Guilsingl links |  | \(
Guilsingl rechts |  | \)
Hungarumlaut |  | \&
Wahlweiser Trennstrich | - | \- (Bindestrich)
Bindestrich (umbruchgeschützt) | - | \+
OE-Ligatur |  | \Umschalttaste+o Umschalttaste+e
oe-Ligatur |  | \oe
Promille |  | \%
Anführungszeichen (einfach, unten) |  | \ ,
Anführungszeichen (doppelt, unten) |  | \g
Anführungszeichen (doppelt, links) |  | \`
Anführungszeichen (doppelt, rechts) |  | \'
Anführungszeichen (einfach) |  | \"
Leerzeichen (m) |  | \sm, \Umschalttaste+m
Leerzeichen (n) |  | \sn, \Umschalttaste+n
Leerzeichen (umbruchgeschütztes) |  | \Leertaste
Leerzeichen (numerisch) |  | \s#, \#
Leerzeichen (t) |  | \st, \i
Trennunterdrückung |  | \_ (Unterstrich)
Tabulator |  | \t
Trademark serif |  | \Umschalttaste+t Umschalttaste+m
Y-Diäresis |  | \Umschalttaste+y : (Doppelpunkt)


Eingabe in Dialogfenstern

UNIX

Um die Konventionen des X Window-Systems einzuhalten, verwendet FrameMaker in Dialogfenstern X Server-Schriften. Da diese Schriften für Zeichen lateinischer Schriften ISO Latin-1-Codierung benutzen, gibt es für manche Zeichen des Zeichensatzes keine Entsprechung in der X Server-Schrift.

Für die in der folgenden Tabelle aufgelisteten Zeichen des Zeichensatzes gibt es keine Entsprechung in der X Server-Schrift. Diese Zeichen werden über die in der zweiten Spalte angegebenen Tasten- oder Zeichenfolgen eingegeben. In einigen Fällen gibt es zwei mit umgekehrtem Schrägstrich beginnende Zeichenfolgen für ein Zeichen. Die Zeichenfolgen sind dann durch ein Komma getrennt angegeben.

Zeichen | Grafik | Tastenfolge (oder Zeichenfolge)
Kürzezeichen |  | Control+q y oder Eingabe von \ u
Auszeichnungspunkt |  | Control+q % oder Eingabe von \ b
Zirkumflex |  | Control+q v oder Eingabe von \ @
Kreuz |  | Control+q Leertaste oder Eingabe von \ d
Doppelkreuz |  | Control+q ` oder Eingabe von \ Umschalttaste+d
Punktakzent |  | Control+q z oder Eingabe von \ .(Punkt)
i ohne Punkt |  | Control+q u oder Eingabe von \ l (kleines L)
Auslassung | . . . | Control+q Umschalttaste+i oder Eingabe von \ e
Bindestrich (m) |  | Control+q Umschalttaste+q oder Eingabe von \ =
Bindestrich (n) |  | Control+q Umschalttaste+p
fi-Ligatur |  | Control+q ^ oder Eingabe von \ f i
fl-Ligatur |  | Control+q _ (Unterstrich) oder Eingabe von \ f l
Florin |  | Control+q Umschalttaste+d oder Eingabe von \Umschalttaste+f
Erzwungenes Zeilenende |  | Control+j oder Eingabe von \ r
Bruchzahl |  | Control+q Umschalttaste+z oder Eingabe von \ /
Grave |  | Control+` oder Eingabe von \ {
Guilsingl links |  | Control+q \ oder Eingabe von \ (
Guilsingl rechts |  | Control+q ] oder Eingabe von \ )
Hungarumlaut |  | Control+q } oder Eingabe von \ &
Wahlweiser Trennstrich | - | Control+- (Bindestrich) oder Eingabe von \ - (Bindestrich)
Bindestrich (umbruchgeschützt) | - | Metataste+- (Bindestrich) oder Eingabetaste \¬
OE-Ligatur |  | Control+q Umschalttaste+n oder Eingabe von \ Umschalttaste+o Umschalttaste+e
oe-Ligatur |  | Control+q Umschalttaste+o oder Eingabe von \ oe
Ogonek |  | Control+q ~ oder Eingabe von \ k
Promille |  | Control+q d oder Eingabe von \ %
Anführungszeichen (einfach, unten) |  | Control+q b oder Eingabe von \ ,
Anführungszeichen (doppelt, unten) |  | Control+q c oder Eingabe von \ g
Anführungszeichen (doppelt, links) |  | Control+q Umschalttaste+r oder Eingabe von \ ‘
Anführungszeichen (doppelt, rechts) |  | Control+q Umschalttaste+s oder Eingabe von \'
Anführungszeichen (einfach) |  | Control+' oder Eingabe von \ "
Leerzeichen (m) |  | Esc s m oder Eingabe von \sm, \Umschalttaste+m
Leerzeichen (n) |  | Esc s n oder Eingabe von \sn, \Umschalttaste+n
Leerzeichen (umbruchgeschütztes) |  | Control+Leertaste oder Eingabe von \Leertaste
Leerzeichen (numerisch) |  | Esc Leertaste 1 (Eins) oder Eingabe von \s#, \#
Leerzeichen (t) |  | Esc s t oder Eingabe von \st, \i
Tabulator |  | Tab oder Eingabe von \t
Trademark serif |  | Control+q * oder Eingabe von \ Umschalttaste+t Umschalttaste+m
Y-Diäresis |  | Esc % Umschalttaste+y oder Eingabe von \ Umschalttaste+y :


Tastaturbefehle

Tastaturbefehle für Windows

Tastaturbefehle für UNIX

Tastaturbefehle für besondere Tastaturen

Arbeiten mit Struktur


Tastaturbefehle

Tastaturbefehle für Windows

Anleitungen für Tastaturbefehle:

    + gibt an, dass alle angegebenen Tasten gleichzeitig gedrückt werden müssen (z. B. bedeutet Strg+z, dass die Strg-Taste zusammen mit der z-Taste gedrückt werden muss). Wenn die Tastaturbefehle kein Pluszeichen (Umschalttaste +) enthalten, drücken Sie die einzelnen Tasten in der angegebenen Reihenfolge (bei Esc m p drücken Sie z. B. zuerst Esc (Escape), lassen die Taste los, drücken dann m und anschließend p).

Dokumente durchblättern

Zeichenwerkzeuge

Buchbefehle

Suchen und Ändern

Arbeiten mit Tabellen

Zeichen- und Absatzgestaltung

Objektauswahl

Textbearbeitung

Funktionstasten

Eingabe von Sonderzeichen

Andere nützliche Tastaturbefehle

Menü "Element"

Konventionen und Funktionstasten

Farbe

Menübefehle

Fenster und Dialogfenster

Dokumentgestaltung

Dokumente

Dokumentdienstprogramme

Grafiken

Marken und Variablen

Filter nach Attribut

Verfolgen von Textänderungen

Gleichungen

Tabellen

Text

Textformatierung

Arbeiten mit Struktur


Tastaturbefehle / Tastaturbefehle für Windows

Dokumente durchblättern

Anzeige | Tastenkombination
Vorherige Seite | Esc s Umschalttaste+v, Bild-Auf
Nächste Seite | Esc s Umschalttaste+n, Bild-Ab
Erste Seite | Esc s Umschalttaste+e, Alt+Bild-Auf, Umschalttaste und Symbol "Vorherige Seite"
Letzte Seite | Esc s Umschalttaste+l (kleines L), Alt+Bild-Ab, Umschalttaste und Symbol "Nächste Seite"
Dialogfenster "Wechseln zu Seite" | Esc Umschalttaste+d w, Strg+g
Wechseln zu | Vorgehensweise
Quelle eines Querverweises | Drücken Sie Alt+Strg und klicken Sie auf einen aktiven Bereich
Einer bestimmten Seite | Drücken Sie Strg+g, oder klicken Sie auf den Seitenstatus-Bereich und geben Sie die Seitenzahl ein.
Seite mit Einfügemarke | Drücken Sie Strg+g, oder klicken Sie auf den Seitenstatus-Bereich und dann auf "Seite mit Einfügemarke".
Setzen der Einfügemarke im Text an den/das | Tastenkombination
Anfang eines Wortes | Strg+Nach-Links-Taste
Ende eines Wortes | Strg+Nach-Rechts-Taste
Anfang des nächsten Wortes | Esc Umschalttaste+m w
Anfang eines Satzes | Strg+Pos 1
Ende eines Satzes | Strg+Ende
Anfang eines Absatzes | Strg+Nach-Oben-Taste
Setzen der Einfügemarke im Text an den/das | Tastenkombination
Ende des aktuellen Absatzes | Strg+Nach-Unten-Taste
Anfang des nächsten Absatzes | Esc Umschalttaste+m a
Anfang einer Spalte | Strg+Bild-Auf
Ende einer Spalte | Strg+Bild-Ab
Anfang eines Textflusses | Alt+Umschalttaste+Bild-Auf
Setzen der Einfügemarke im Text an den/das | Tastenkombination
Ende eines Textflusses | Alt+Umschalttaste+Bild-Ab
Anfang einer Zeile | Strg+Bild-Auf
Ende einer Zeile | Strg+Bild-Ab


Tastaturbefehle / Tastaturbefehle für Windows

Zeichenwerkzeuge

Werkzeug | Tastaturbefehl
Bogen | Esc o b
Grafikrahmen | Esc o Umschalttaste+r
Freihandkurve | Esc o f
Zuletzt gewähltes Werkzeug | Esc o w
Gerade | Esc o g
Objektauswahl | Esc o o
Ellipse | Esc o e
Polygon | Esc o p
Polygonzug | Esc o l (kleines L)
Rechteck | Esc o r
Abgerundetes Rechteck | Esc o a
Intelligente Auswahl | Esc o i
Textrahmen | Esc o s
Textzeile | Esc o z
Zeichenobjekt | Tastaturbefehl
Vertikale, horizontale oder diagonale Gerade | Drücken Sie die Umschalttaste und zeichnen Sie eine Gerade.
Quadrat | Drücken Sie die Umschalttaste und zeichnen Sie ein Rechteck.
Kreis | Drücken Sie die Umschalttaste und zeichnen Sie eine Ellipse.
Kreisausschnitt | Drücken Sie die Umschalttaste und zeichnen Sie einen Bogen.
Funktion | Tastaturbefehl
Werkzeugpalette anzeigen | Esc eins g, Esc g Umschalttaste+w
Werkzeug nach Verwendung aktiv lassen | Drücken Sie die Umschalttaste und klicken Sie auf ein Zeichenwerkzeug.
Nach dem Zeichnen zum Objektauswahlwerkzeug zurückkehren | Drücken Sie die Umschalttaste und klicken Sie auf das Objektauswahlwerkzeug.


Tastaturbefehle / Tastaturbefehle für Windows

Buchbefehle

Funktion | Vorgehensweise
Neues Buch | Esc d Umschalttaste+n
Buch sichern | Esc d s, Strg+s
Datei umbenennen | Esc f e oder F2
Funktion | Vorgehensweise
Buch aktualisieren | Esc b Umschalttaste+c, Esc b Umschalttaste+r
Dateinamen anzeigen (im Buchfenster) | Esc Umschalttaste+v Umschalttaste+m
Absatzüberschriften anzeigen (im Buchfenster) | Esc Umschalttaste+v Umschalttaste+x
Datei aus dem Buch löschen | Esc f x
Alle Dateien auswählen | Esc b g
Alle Dateien des Buchs sichern | Esc d Umschalttaste+s
Alle Dateien des Buchs schließen | Esc d Umschalttaste+v
Alle FrameMaker-Dateien auswählen | Esc b Umschalttaste+m Umschalttaste+d
Alle nicht generierten FrameMaker-Dateien auswählen | Esc b Umschalttaste+n Umschalttaste+g
Alle generierten FrameMaker-Dateien auswählen | Esc b Umschalttaste+e Umschalttaste+d
Einen Bereich von Dateien auswählen | Umschalttaste+Klicken
Nicht untereinander stehende Dateien auswählen | Strg+Klicken
Datei in einem Buch nach oben bewegen | Esc m u
Datei in einem Buch nach unten bewegen | Esc m d
Buch drucken | Esc d d, Strg+p
Ausgewählte Dateien im Buch drucken | Esc d Umschalttaste+a


Tastaturbefehle / Tastaturbefehle für Windows

Suchen und Ändern

Suche | Eingabe
Vorwärts suchen | Esc f i n,Esc Umschalttaste+s Umschalttaste+v, Strg+Umschalttaste+f, Alt+Strg+s
Rückwärts suchen | Esc Umschalttaste+s Umschalttaste+r, Alt+Strg+f, Alt+Strg+r
Aktuelle Auswahl ändern | Esc Umschalttaste+e e
Alle Vorkommen des Suchtextes im Dokument ändern | Esc Umschalttaste+e a
Ändern und weitersuchen | Esc Umschalttaste+e n
Einstellungen in Dialogfenstern "Zeichenformat suchen" und "Ändern in Zeichenformat" zu "Beibehalten" ändern | Umschalttaste+F8
Einstellungen entsprechend dem ausgewählten Text in Dialogfenstern "Zeichenformat suchen" und "Ändern in Zeichenformat" ändern | Umschalttaste+F9
Dialogfenster "Einstellung der Suchparameter" anzeigen | Esc Umschalttaste+s Umschalttaste+e
Tabulatorsymbol | \t
Zeilenende | \r
Absatzende-Zeichen | \p
Absatzbeginn | \P
Umbruchgeschütztes Leerzeichen | \ (Leertaste)
t-Leerzeichen | \i, \st
n-Leerzeichen | \N, \sn
m-Leerzeichen | \M, \sm
Suche | Eingabe
Numerisches Leerzeichen | \#, \s#
Textflussende-Zeichen | \f
` (Gravis) | \{
\ (umgekehrter Schrägstrich) | \\
Wahlweiser Trennstrich | \- (Bindestrich)
Umbruchgeschützter Trennstrich | \+
Trennunterdrückungssymbol | \_ (Unterstrich)
Wortanfang | \<
Wortende | \>
Mit aktivierter Option "Jokerzeichen"... |
Beliebige Anzahl von Zeichen | *
Leerzeichen oder Interpunktion | | (senkrechter Strich)
Beliebiges Zeichen | ?
Anfang einer Zeile | ^
Ende einer Zeile | $
Beliebige Zeichen in eckigen Klammern ab | [ab]
Beliebiges Zeichen außer ab | [^ab]
Beliebiges Zeichen von a bis f | [a-f]


Tastaturbefehle / Tastaturbefehle für Windows

Arbeiten mit Tabellen

Auswahl | Tastenkombination
Eine Zelle | Drücken Sie Strg und klicken Sie auf die Zelle.
Eine Reihe | Drücken Sie Strg und doppelklicken Sie auf den Spaltenrand.
Eine Spalte | Drücken Sie Strg und doppelklicken Sie auf den Reihenrand.
Aktuelle Reihe | Esc t h r
Aktuelle Spalte | Esc t h s
Aktuelle Tabelle | Esc t h t, bei gedrückter Strg-Taste dreimal auf eine Zelle klicken
Wechseln zu | Tastenkombination
Zelle ganz rechts in aktueller Reihe | Esc t g e
Zelle ganz links in aktueller Reihe | Esc t g b
Zelle ganz oben in aktueller Spalte | Esc t g o
Zelle ganz unten in aktueller Spalte | Esc t g u
Nächste Zelle und deren Text auswählen | Tabulator, Esc t g Umschalttaste+r
Vorherige Zelle und deren Text auswählen | Umschalttaste+Tabulator, Esc t g Umschalttaste+l (kleines L)
Zelle darunter und deren Text auswählen | Alt+Strg+Tabulator
Zelle darüber und deren Text auswählen | Alt+Strg+ Umschalttaste+Tabulator
Funktion | Tastenkombination
Tabulatorzeichen in eine Zelle eingeben | EscTabulator
Reihen über ausgewählter Reihe einfügen | Esc t + (Plus) o
Reihen unter ausgewählten Reihen einfügen | Esc t + (Plus) u, Strg+Eingabetaste
Spalten links einfügen | Esc t + (Plus) l (kleines L)
Spalten rechts einfügen | Esc t + (Plus) r
Durch Austausch der gewählten Reihen oder Spalten einsetzen | Esc t Umschalttaste+e e
Reihen oder Spalten vor der Auswahl einfügen | Esc t Umschalttaste+e v
Reihen oder Spalten hinter der Auswahl einfügen | Esc t Umschalttaste+e n
Spaltengröße ändern (ohne Absatzumbrüche in ausgewählten Zellen) | Esc t x
Größe der ausgewählten Spalten ohne Änderung der Tabellenbreite ändern | Bei gedrückter Alt-Taste den Auswahlpunkt der gewählten Zelle ziehen
Spaltenbreite in Zwischenablage kopieren | Esc b Umschalttaste+b


Tastaturbefehle / Tastaturbefehle für Windows

Zeichen- und Absatzgestaltung

Funktion | Tastaturbefehl
Alle Einstellungen zu "Beibehalten" ändern | Umschalttaste+F8
Alle Einstellungen an ausgewählten Text anpassen | Umschalttaste+F9
Vorherige Einstellungsgruppe anzeigen | Bild-Auf
Nächste Einstellungsgruppe anzeigen | Bild-Ab
Nur die aktuelle Einstellungsgruppe anwenden | Drücken Sie Strg und klicken Sie auf "Zuweisen".


Tastaturbefehle / Tastaturbefehle für Windows

Objektauswahl

Verwenden Sie diese Tastaturbefehle, um Objekte auf der aktuellen Seite auszuwählen.

Funktion | Tastaturbefehl
Textzeile oder Textrahmen auswählen | Drücken Sie Strg und klicken Sie auf die Textzeile oder den Textrahmen.
Die Auswahl erweitern oder verkleinern | Drücken Sie die Umschalttaste und klicken Sie auf ein Objekt.
Anzeige des Auswahlrahmens erzwingen (wenn Ziehen von außerhalb der Objekte nicht möglich ist) | Drücken Sie Strg+Umschalttaste und ziehen Sie diagonal.
Das erste Objekt in der Zeichenreihenfolge auswählen | Esc o eins
Das nächste Objekt in der Zeichenreihenfolge auswählen | Esc o n
Die Auswahl auf das nächste Objekt in der Zeichenreihenfolge erweitern | Esc o Plus
Die Auswahl eines Textrahmens oder einer Textzeile aufheben und die Einfügemarke stattdessen in das Objekt setzen | Doppelklicken Sie in den Textrahmen oder in die Textzeile.


Tastaturbefehle / Tastaturbefehle für Windows

Textbearbeitung

Funktion | Tastenkombination
Ausschneiden | Esc b a, Umschalttaste+Entf, Strg+x
Kopieren | Esc b k, Strg+c, Strg+Einfg
Einfügen | Esc b e, Strg+y, Umschalttaste+Einfg, Strg+v
Funktion | Tastenkombination
Rückgängig/Erneut rückgängig | Esc b r, Strg+Umschalttaste+z, Strg+z, Alt+Rücktaste
Text schnell kopieren | Klicken Sie an die Stelle, an der Sie den kopierten Text einfügen möchten, drücken Sie die Alt-Taste und ziehen Sie den Zeiger über den Text.
Zeichen vertauschen | Klicken Sie zwischen die Zeichen und drücken Sie anschließend Strg+F9.
Ausgewählten Text in Kleinbuchstaben umwandeln | Alt+Strg+l (kleines L)
Ausgewählten Text in Versalien umwandeln | Alt+Strg+u
Ausgewählten Text mit großen Anfangsbuchstaben schreiben | Alt+Strg+c
Auswahl | Vorgehensweise
Ein Wort | Doppelklicken Sie auf das Wort.
Ein Wort, dann folgende Wörter | Doppelklicken Sie auf das Wort und ziehen Sie den Zeiger, doppelklicken Sie und Klicken Sie bei gedrückter Umschalttaste.
Aktueller Satz, dann folgender Satz | Drücken Sie Esc h s, drücken Sie Strg+Umschalttaste+Ende
Aktueller Satz, dann vorheriger Satz | Drücken Sie Esc Umschalttaste+h Umschalttaste+s, drücken Sie Strg+Umschalttaste+Pos 1.
Ein Absatz | Klicken Sie dreimal auf den Absatz.
Ein Absatz, dann folgende Absätze | Klicken Sie dreimal auf den Absatz und ziehen Sie den Zeiger, klicken Sie dreimal und Klicken Sie bei gedrückter Umschalttaste.
Löschen | Tastenkombination
Vorheriges Zeichen | Rücktaste
Bis zum Anfang des vorherigen Wortes | Esc l (kleines L) a
Bis zum Ende des vorherigen Satzes | Esc l (kleines L) r
Nächstes Zeichen | Entf
Bis zum Ende eines Wortes | Esc l (kleines L) e, Strg+Entf
Bis zum Ende einer Zeile | Strg+Umschalttaste+Entf
Bis zum Anfang des nächsten Satzes | Esc l (kleines L) v


Tastaturbefehle / Tastaturbefehle für Windows

Funktionstasten

Taste | Funktion | Strg | Umschalttaste | Alt
F1 | Hilfe | Oben ausrichten |  |
F2 | Standardtext | Zentriert ausrichten |  |
F3 | Unterstreichen | Unten ausrichten | Überstreichen |
F4 | Fett |  | Fenster überlappend | Beenden
F5 | Kursiv |  | Fenster nebeneinander |
F6 |  |  |  |
F7 |  |  | Zeiger auf Dokumentfenster platzieren |
F8 | Zeichenformat durch Eingabe auswählen |  | Einstellungen im Dialogfenster zu "Beibehalten" ändern |
F9 | Absatzformat durch Eingabe auswählen | Zeichen vertauschen | Alle Einstellungen des Dialogfensters an aktuellen Text anpassen |
F10 |  |  | Kontextmenü anzeigen |


Tastaturbefehle / Tastaturbefehle für Windows

Eingabe von Sonderzeichen

Eingabe | Tastenkombination
(Auszeichnungspunkt) | Strg+q %
(Kreuzsymbol) | Strg+q Leertaste
(Doppelkreuz) | Strg+q `
(Warenzeichen) | Strg+q *
© (Copyright) | Strg+q )
® (eingetragenes Warenzeichen) | Strg+q (
¶ (Absatzsymbol) | Strg+q &
§ (Paragraphsymbol) | Strg+q $
… (Auslassung) | Strg+q Umschalttaste+i
(m-Bindestrich) | Strg+q Umschalttaste+q
(n-Bindestrich) | Strg+q Umschalttaste+p
‘ | Strg+'
" | Esc "
(Anführungszeichen deaktiviert) | Strg+q Umschalttaste+t
(Anführungszeichen deaktiviert) | Strg+q Umschalttaste+u
(Anführungszeichen deaktiviert) | Strg+q Umschalttaste+r, Alt+Strg+'
(Anführungszeichen deaktiviert) | Strg+q Umschalttaste+s, Alt+Strg+'
m-Leerzeichen | Esc s m, Strg+Umschalttaste+Leertaste
n-Leerzeichen | Esc s n, Alt+Strg+Leertaste
Umbruchgeschütztes Leerzeichen | Esc s z, Strg+Leertaste
Numerisches Leerzeichen | Esc Leertaste 1 (eins)
t-Leerzeichen | Esc s t
Umbruchgeschützter Trennstrich | Esc Bindestrich w
Trennunterdrückungssymbol | Esc k t
Wahlweiser Trennstrich | Esc Bindestrich Umschalttaste+d, Strg+Bindestrich
Zeilenende | Umschalttaste+Eingabetaste
Akzent | Drücken Sie Esc und geben Sie dann Folgendes ein: | Gefolgt von einem dieser Zeichen: | Beispiel
´ (Akut) | ' (Apostroph) | a, A, e, E, i, I, o, O, u, U | É, é
` (Gravis) | ` (Linkes Anführungszeichen) | a, A, e, E, i, I, o, O, u, U | È, è
(Tilde) | ~ (Tilde) | a, A, n, N, o, O | Ñ, ñ
¨ (Diäresis) | % (Prozent) | a, A, e, E, i, I, o, O, u, U, y, Y | Ü, ü
(Zirkumflex) | ^ (Caret) | a, A, e, E, i, I, o, O, u, U | Ê, ê
° (Ring) | * (Sternchen) | a, A | Å, å
¸ (Cedille) | , (Komma) | c, C | Ç, ç


Tastaturbefehle / Tastaturbefehle für Windows

Andere nützliche Tastaturbefehle

Funktion | Tastenkombination
Die Dokumentanzeige neu aufbauen | Strg+l (kleines L)
Ein ausgewähltes Objekt schnell kopieren | Drücken Sie Alt, und ziehen Sie das Objekt.
Ein Objekt willkürlich drehen | Drücken Sie Alt, und ziehen Sie mit der linken oder rechten Maustaste eine Ecke oder einen Umformpunkt.
Ein Objekt entlang der vertikalen oder horizontalen Achse verschieben | Umschalttaste und Objekt ziehen
Ein Objekt um 1 Punkt/6 Punkt verschieben | Alt+Pfeiltaste/Alt+Umschalttaste+Pfeiltaste
Seite an Fenster anpassen | Esc Umschalttaste+z Umschalttaste+s
Fenster an Seite anpassen | Esc Umschalttaste+z Umschalttaste+f
Zoomen auf 100 % | Esc Umschalttaste+z Umschalttaste+o
Ein Dokument oder Buch sperren oder entsperren | Esc d Umschalttaste+y


Tastaturbefehle / Tastaturbefehle für Windows

Menü "Element"

Auswahl | Tastaturbefehl
Zusammenfügen | Esc e v 1 (eins)
Teilen | Esc e e t
Ausgliedern | Esc e e f
Attribute bearbeiten | Esc Umschalttaste+e Umschalttaste+a
Namespaces | Esc Umschalttaste+e Umschalttaste+n
Elementkatalog | Esc Umschalttaste+s Umschalttaste+l (kleines L)
Verfügbare Elemente zuweisen | Esc Umschalttaste+e Umschalttaste+o Umschalttaste+c
Neue Elementoptionen | Esc Umschalttaste+e Umschalttaste+o
Prüfen | Esc e e p


Tastaturbefehle / Tastaturbefehle für Windows / Konventionen und Funktionstasten

Tasten

Bei der Verwendung von Tastaturbefehlen muss die Feststelltaste ausgeschaltet sein, und, falls nichts anderes angegeben ist, muss ein Dokumentfenster aktiv sein.
Die folgende Tabelle listet die Bezeichnungen der Sondertasten auf.

Bezeichnung | Bedeutung
Pfeiltaste | Nach-Oben-, Nach-Unten-, Nach-Rechts- und Nach-Links-Taste
Esc | Die mit "Esc" beschriftete Taste
Strg | Die mit "Strg" beschriftete Taste
Alt | Die mit "Alt" beschriftete Taste
Umschalttaste | Die Umschalttaste
F2 | Die mit "F2" beschriftete Funktionstaste (Wenn Sie "F" gefolgt von "2" eingeben, werden die Zeichen als "F 2" angezeigt.)
Leertaste | Die Leertaste
Plus | Die mit einem Pluszeichen (+) beschriftete Taste
Minus oder Bindestrich | Die mit einem Bindestrich (-) beschriftete Taste
Punkt | Die mit einem Punkt (.) beschriftete Taste
Komma | Die mit einem Komma (,) beschriftete Taste
Null | Die mit der Ziffer 0 beschriftete Taste
Eins | Die mit der Ziffer 1 beschriftete Taste


Tastaturbefehle / Tastaturbefehle für Windows / Konventionen und Funktionstasten

Tastaturbefehle

Die folgende Tabelle erläutert die Konventionen für die Anzeige von Tastenfolgen und Tastenkombinationen. Wenn in einer Tastenkombination ein Großbuchstabe angegeben ist, geben Sie den Buchstaben bei gedrückter Umschalttaste ein.

Wenn eine oder mehr Tastenkombinationen dieselbe Aktion ausführen, werden die Tastenkombinationen durch ein Komma getrennt. Beispiel: Strg+n, Umschalttaste+Nach-Unten-Taste. Sie können entweder Strg+n oder Umschalttaste+Nach-Unten-Taste verwenden, um dieselbe Aktion auszuführen.

Tastaturbefehl | Bedeutung
Esc Umschalttaste+t e | Drücken Sie nacheinander die folgenden Tasten, und lassen Sie sie wieder los: die Esc-Taste, den Großbuchstaben T und den Buchstaben e.
Strg+e | Halten Sie Strg-Taste gedrückt, und geben Sie den Buchstaben "e" ein.
Strg+ Umschalttaste+Bindestrich | Halten Sie die Umschalt- und die Strg-Taste gedrückt und geben Sie einen Bindestrich ein.


Tastaturbefehle / Tastaturbefehle für Windows / Konventionen und Funktionstasten

Funktionstasten

Taste | Funktion | Strg | Umschalttaste | Alt
F1 | Hilfe | Oben ausrichten |  |
F2 | Standardtext | Zentriert ausrichten |  |
F3 | Unterstreichen | Unten ausrichten | Überstreichen |
F4 | Fett |  | Fenster überlappend | Beenden
F5 | Kursiv |  | Fenster nebeneinander |
F6 |  |  |  |
F7 |  |  | Zeiger auf Dokumentfenster platzieren |
F8 | Zeichenformat durch Eingabe auswählen |  | Einstellungen im Dialogfenster zu "Beibehalten" ändern |
F9 | Absatzformat durch Eingabe auswählen | Zeichen vertauschen | Alle Einstellungen des Dialogfensters an aktuellen Text anpassen |
F10 |  |  | Kontextmenü anzeigen |


Tastaturbefehle / Tastaturbefehle für Windows / Konventionen und Funktionstasten

Maus

Die folgende Tabelle listet die Bezeichnungen für Mausaktionen auf.

Anweisung | Bedeutung
Klicken | Drücken Sie die Maustaste.
Rechtsklicken | Drücken Sie die rechte Maustaste.
Doppelklicken | Drücken Sie die Maustaste zweimal schnell hintereinander, ohne die Maus zu bewegen.
Dreimal klicken | Drücken Sie die Maustaste dreimal schnell hintereinander, ohne die Maus zu bewegen.
Bei gedrückter Umschalttaste klicken | Halten Sie die Umschalttaste gedrückt und drücken Sie die (linke) Maustaste


Tastaturbefehle / Tastaturbefehle für Windows / Farbe

Farbauswahl

Funktion | Tastaturbefehl
Farbe nach Verwendung aktiv lassen | Drücken Sie die Umschalttaste und wählen Sie eine Farbe aus dem Aufklappmenü "Farbe" aus.
Eine Farbe allen Objekten in einem Dokument zuweisen, einschließlich Text | Drücken Sie Alt+Umschalttaste und wählen Sie eine Farbe aus dem Aufklappmenü "Farbe" in der Werkzeugpalette aus.
Dialogfenster "Farbdefinitionen" anzeigen | Drücken Sie Esc Umschalttaste+d f d


Tastaturbefehle / Tastaturbefehle für Windows / Farbe

Farbauszüge

Funktion | Tastaturbefehl
Dialogfenster "Farbauszüge definieren" anzeigen | Drücken Sie Esc Umschalttaste+d u
Auszugsnummer (1, 2, 3, 4, 5 oder 6) aus dem Dialogfenster "Farbauszüge definieren" wählen | Drücken Sie Esc Umschalttaste+d, und geben Sie die Nummer ein.


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Kontextmenüs

Funktion | Vorgehensweise
Ein Aufklappmenü mit Befehlen anzeigen, die sich auf die aktuelle Auswahl oder den Kontext beziehen | Klicken Sie mit der rechten Maustaste auf ein Objekt, in einen Dokumentrand oder in ein Buchfenster.


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Datei" (Dokumentfenster)

Auswahl | Tastaturbefehl
Neu>Dokument | Esc d n, Strg+n
Neu>Buch | Esc d Umschalttaste+n
Öffnen | Esc d o, Strg+o
Schließen | Esc d v, Strg+w, Strg+F4, Strg+Umschalttaste+w
Alle schließen | Esc d Umschalttaste+v, Esc d Umschalttaste+q
Sichern | Esc d s, Strg+s
Alle sichern | Esc d Umschalttaste+s
Auswahl | Tastaturbefehl
Sichern unter | Esc d a
Als PDF speichern | Esc f w p
Als XML speichern | Esc f w x
Zurück zur gesicherten Version | Esc d l (kleines L)
Importieren>Datei | Esc d i
Importieren>Formate | Esc d f
Importieren>Objekt | Esc f i b
Importieren>Elementdefinitionen | Esc d Umschalttaste+d i
Drucken | Esc d d, Strg+p
Druckereinrichtung | Strg+Umschalttaste+p
Senden | Esc f m
Geöffnete Dateien senden | Esc f Umschalttaste+m
Dienstprogramme>Dokumente vergleichen | Esc d t v
Dienstprogramme>Statistik | Esc d t s
Dienstprogramme>HTML-Einstellungen | Esc f t h
Dienstprogramme>Formate anlegen und zuweisen | Esc d Umschalttaste+d f
Voreinstellungen | Esc d Umschalttaste+e
Beenden | Alt+F4


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Datei" (Buchfenster)

Auswahl | Tastaturbefehl
Neues Dokument | Esc d n, Strg+n
Neues Buch | Esc d Umschalttaste+n
Öffnen | Esc d o, Strg+o
Alle Dateien des Buchs öffnen | Esc d Umschalttaste+o
Buch schließen | Esc d v, Strg+w
Alle Dateien des Buchs schließen | Esc d Umschalttaste+v
Buch sichern | Esc d s, Strg+s
Alle Dateien des Buchs sichern | Esc d Umschalttaste+s
Buch sichern unter | Esc d a
Zurück zum gesicherten Buch | Esc d l (kleines L)
Importieren>Formate | Esc d f
Importieren>Elementdefinitionen | Esc d Umschalttaste+d i
Ausgewählte Dateien drucken | Esc d Umschalttaste+a
Buch drucken | Esc d d, Strg+p
Druckereinrichtung | Strg+Umschalttaste+p
Auswahl | Tastaturbefehl
Dienstprogramme>Bücher vergleichen | Esc d >+b
Voreinstellungen | Esc d Umschalttaste+e
Beenden | Alt+F4


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Bearbeiten" (Dokumentfenster)

Auswahl | Tastaturbefehl
Rückgängig/Erneut rückgängig | Esc b r, Strg+z, Alt+Rücktaste, Strg+Umschalttaste+z
Ausschneiden | Esc b a, Strg+x, Umschalttaste+Entf
Kopieren | Esc b k, Strg+c, Strg+Einfg
Einfügen | Esc b e, Strg+v, Umschalttaste+Einfg
Einfügen Spezial | Strg+Umschalttaste+v
Löschen | Esc b l (kleines L)
Kopieren Spezial>Attributwerte | Esc b Umschalttaste+k Umschalttaste+a
Kopieren Spezial>Absatzformat | Esc b f
Kopieren Spezial>Zeichenformat | Esc b z
Kopieren Spezial>Bedingter Text | Esc b b
Kopieren Spezial>Spaltenbreite | Esc b Umschalttaste+b
Textfluss auswählen | Esc b g, Strg+a
Suchen/Ändern | Esc b s, Strg+f
Nächstes Auftreten suchen | Esc f i n, Esc e Umschalttaste+f, Strg+Umschalttaste+f
Rechtschreibhilfe | Esc b h
Thesaurus | Esc b t
Texteinschubeinstellungen | Esc b Umschalttaste+t
Referenzen aktualisieren | Esc e Umschalttaste+u
Verknüpfungen | Esc e k
Objekt | (Kein Tastaturbefehl verfügbar)


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Bearbeiten" (Buchfenster)

Auswahl | Tastaturbefehl
Rückgängig/Erneut rückgängig | Esc b r, Strg+z, Alt+Rücktaste, Strg+Umschalttaste+z
Ausschneiden | Esc b a, Strg+x, Umschalttaste+Entf
Kopieren | Esc b k, Strg+c, Strg+Einfg
Einfügen | Esc b e, Strg+v, Umschalttaste+Einfg
Einfügen Spezial | Strg+Umschalttaste+v
Löschen | Esc b l (kleines L)
Kopieren Spezial>Attributwerte | Esc b Umschalttaste+k Umschalttaste+a
Alle Dateien auswählen | Esc b g
Alle FrameMaker-Dateien auswählen | Esc b Umschalttaste+m Umschalttaste+d
Auswahl | Tastaturbefehl
Alle nicht generierten FrameMaker-Dateien auswählen | Esc b Umschalttaste+n Umschalttaste+g
Alle generierten FrameMaker-Dateien auswählen | Esc b Umschalttaste+e Umschalttaste+d
Suchen/Ändern | Esc b s, Strg+f
Nächstes Auftreten suchen | Esc f i n, Esc e Umschalttaste+f, Strg+Umschalttaste+f
Rechtschreibhilfe | Esc b h
Einstellungen für generierte Datei | Esc d e
Datei umbenennen | Esc f e, F2
Datei aus dem Buch löschen | Esc f x
Automatische Referenzaktualisierung unterdrücken | Esc b Umschalttaste+u
Buch aktualisieren | Esc b Umschalttaste+c, Esc b Umschalttaste+r


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Hinzufügen" (Buchfenster)

Auswahl | Tastaturbefehl
Dateien | Esc d h
Inhaltsverzeichnis | Esc t o c
Liste von>Abbildungen | Esc l (kleines L) o f
Liste von>Tabellen | Esc l (kleines L) o t
Liste von>Elemente und Absätze | Esc l (kleines L) o p
Liste von>Elemente und Absätze (alphabetisch) | Esc l (kleines L) o Umschalttaste+p
Liste von>Marken | Esc l (kleines L) o m
Liste von>Marken (alphabetisch) | Esc l (kleines L) o Umschalttaste+m
Liste von>Referenzen | Esc l (kleines L) o r
Standardindex | Esc i x
Index von>Autoren | Esc i o a
Index von>Themen | Esc i o s
Index von>Marken | Esc i o m
Index von>Referenzen | Esc i o r


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Element"

Auswahl | Tastaturbefehl
Zusammenfügen | Esc e v 1 (eins)
Teilen | Esc e e t
Ausgliedern | Esc e e f
Attribute bearbeiten | Esc Umschalttaste+e Umschalttaste+a
Namespaces | Esc Umschalttaste+e Umschalttaste+n
Elementkatalog | Esc Umschalttaste+s Umschalttaste+l (kleines L)
Auswahl | Tastaturbefehl
Verfügbare Elemente zuweisen | Esc Umschalttaste+e Umschalttaste+o Umschalttaste+c
Neue Elementoptionen | Esc Umschalttaste+e Umschalttaste+o
Prüfen | Esc e e p


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Format"

Auswahl | Tastaturbefehl
Schrift | (Kein Tastaturbefehl verfügbar)
Grad | (Kein Tastaturbefehl verfügbar)
Stil>Standard | Esc z n, F2
Stil>Fett | Esc z f, F4, Strg+b, Strg+Umschalttaste+b
Stil>Kursiv | Esc z k, F5, Strg+i
Stil>Unterstreichen | Esc z u, Strg+u, Strg+Umschalttaste+u
Stil>Doppelt unterstreichen | Esc z 2
Stil>Überstreichen | Esc z Umschalttaste+u
Stil>Durchstreichen | Esc z d, Strg+/
Stil>Änderungsbalken | Esc z b
Stil>Hochgestellt | Esc z h
Stil>Tiefgestellt | Esc z t
Stil>Kapitälchen | Esc z p, Strg+e
Zeichen>Gestaltung | Esc f z, Strg+d
Zeichen>Katalog | Esc z Umschalttaste+k
Zeichen>Absatzstandardschrift | Esc Umschalttaste+s z
Absätze>Gestaltung | Esc f a, Strg+m, Strg+Umschalttaste+m
Absätze>Katalog | Esc p a Umschalttaste+k
Seitenlayout>Spaltenlayout | Esc f s l (kleines L)
Seitenlayout>Zeilenlayout | Esc f n l (kleines L)
Seitenlayout>Format | Esc f o
Seitenlayout>Seitenumbruch | Esc f Umschalttaste+s
Seitenlayout>Vorgabeseite zuweisen | Esc f v z
Seitenlayout>Neue Vorgabeseite | Esc f n v
Seitenlayout>Spaltenlayout aktualisieren | Esc f s a
Spezielles Layout>Spezieller Textrahmen | Esc f s t
Spezielles Layout>Textrahmen verketten | Esc t v Umschalttaste+k
Spezielles Layout>Vorherigen abtrennen | Esc t t v
Spezielles Layout>Nächsten abtrennen | Esc t t n
Spezielles Layout>Beide abtrennen | Esc t t b
Spezielles Layout>Textrahmen teilen | Esc t t u
Spezielles Layout>Seite im Uhrzeigersinn drehen | Esc p Umschalttaste+p Umschalttaste+o
Auswahl | Tastaturbefehl
Spezielles Layout>Seite gegen Uhrzeigersinn drehen | Esc p Umschalttaste+p o
Spezielles Layout>Drehung aufheben | Esc p Umschalttaste+p Umschalttaste+u
Spezielles Layout>Kombinierte Schriften | Esc o c o
Dokument>Nummerierung | Esc f d n, Esc e n
Dokument>Änderungsbalken | Esc f b
Dokument>Fußnoten | Esc f f
Dokument>Textoptionen | Esc f d o
Dokument>PDF-Einstellungen | Esc o d a
Dokument>Rubi-Einstellungen | Esc Umschalttaste+o Umschalttaste+r
Kopf- und Fußzeilen>Seitennummer einfügen | Esc f k n
Kopf- und Fußzeilen>Seitenanzahl einfügen | Esc f k a
Kopf- und Fußzeilen>Aktuelles Datum einfügen | Esc f k d
Kopf- und Fußzeilen>Sonstiges einfügen | Esc f k s


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Darstellung" (Dokumentfenster)

Auswahl | Tastaturbefehl
QuickAccess-Leiste | Esc q a
Formatierungsleiste | Esc v Umschalttaste+f
Leiste zum Verfolgen von Textänderungen | Esc Umschalttaste+v e
Leiste mit Tabulatoren | Esc Umschalttaste+v Umschalttaste+t Umschalttaste+b
Begrenzungslinien | Esc Umschalttaste+d b
Steuerzeichen | Esc Umschalttaste+d s
Lineale | Esc Umschalttaste+d l (kleines L)
Rasterlinien | Esc Umschalttaste+d t
Elementgrenzen | Esc Umschalttaste+d Umschalttaste+e
Elementgrenzen (mit Tags) | Esc Umschalttaste+d e t
Optionen | Esc Umschalttaste+d o
Attributanzeige-Optionen | Esc v Umschalttaste+a
Wechseln zu Seite | Esc Umschalttaste+d w, Strg+g, Strg+Umschalttaste+g
Arbeitsseiten | Esc Umschalttaste+d a
Vorgabeseiten | Esc Umschalttaste+d v
Referenzseiten | Esc Umschalttaste+d r
Farbe>Darstellung | Esc Umschalttaste+d u
Farbe>Definitionen | Esc Umschalttaste+d f d
Menüs>Kurzmenüs | Esc Umschalttaste+d m k
Menüs>Vollmenüs | Esc Umschalttaste+d m v
Menüs>Anpassen | Esc Umschalttaste+d m a


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Darstellung" (Buchfenster)

Auswahl | Tastaturbefehl
QuickAccess-Leiste | Esc q a
Formatierungsleiste | Esc v Umschalttaste+f
Leiste mit Tabulatoren | Esc Umschalttaste+v Umschalttaste+t Umschalttaste+b
Begrenzungslinien einblenden | Esc Umschalttaste+v b s
Begrenzungslinien ausblenden | Esc Umschalttaste+v b h
Steuerzeichen einblenden | Esc Umschalttaste+v t s
Steuerzeichen ausblenden | Esc Umschalttaste+v t h
Lineale einblenden | Esc Umschalttaste+v r s
Lineale ausblenden | Esc Umschalttaste+v r h
Rasterlinien einblenden | Esc Umschalttaste+v g s
Rasterlinien ausblenden | Esc Umschalttaste+v g h
Grafiken einblenden | Esc Umschalttaste+v v s
Grafiken ausblenden | Esc Umschalttaste+v v h
Elementgrenzen einblenden | Esc Umschalttaste+v Umschalttaste+e s
Elementgrenzen ausblenden | Esc Umschalttaste+v Umschalttaste+e h
Elementgrenzen (mit Tags) einblenden | Esc Umschalttaste+v Umschalttaste+t s
Optionen | Esc Umschalttaste+d o
Attributanzeige-Optionen | Esc v Umschalttaste+a
Zoom>Größer | Esc Umschalttaste+z Umschalttaste+g
Zoom>Kleiner | Esc Umschalttaste+z Umschalttaste+k
Zoomen>100 % | Esc Umschalttaste+z Umschalttaste+o
Zoom>Seite an Fenster anpassen | Esc Umschalttaste+z Umschalttaste+s
Zoom>Fenster an Seite anpassen | Esc Umschalttaste+z Umschalttaste+f
Zoom>Fenster an Textrahmen anpassen | Esc Umschalttaste+z f
Farbe>Darstellung | Esc Umschalttaste+d u
Farbe>Definitionen | Esc Umschalttaste+d f d
Menüs>Kurzmenüs | Esc Umschalttaste+d m k
Menüs>Vollmenüs | Esc Umschalttaste+d m v
Menüs>Anpassen | Esc Umschalttaste+d m a


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Spezial"

Auswahl | Tastaturbefehl
Seitenumbruch | Esc f u u
Verankerter Rahmen | Esc Umschalttaste+s r
Fußnote | Esc Umschalttaste+s f
Querverweis | Esc Umschalttaste+s q
Variable | Esc Umschalttaste+s v v
Auswahl | Tastaturbefehl
Hypertext | Esc s h
Marke | Esc Umschalttaste+s m
Gleichungen | Esc Umschalttaste+s g
Filter nach Attribut | Esc a c
Bedingter Text | Esc Umschalttaste+s b
Bedingten Text verwalten | Esc m Umschalttaste+c
Bedingten Text anwenden | Esc Umschalttaste+s b
Bedingten Text ein-/ausblenden | Esc b d
Bedingungsformate einblenden | Esc Umschalttaste+v o
Bedingungsformate ausblenden | Esc Umschalttaste+v Umschalttaste+o h
Bedingungsformate ein-/ausblenden | Esc b Umschalttaste+f
Bedingungstypen zeigen | Esc b Shift+z
Zeichen gleichen Bedingungstyps auswählen | Esc Umschalttaste+h b
Auf den Text an der Stelle, an der sich der Cursor befindet, angewendete Bedingung anzeigen | Esc b Plus
Eingabe Bedingter Text | Esc Umschalttaste+e b
Dialogfenster "Bedingter Text" schließen | Esc Umschalttaste+c o
Funktion zur Verfolgung von Textänderungen aktivieren oder deaktivieren | Esc t c o
Nächste Änderung anzeigen | Esc t c n
Vorherige Änderung anzeigen | Esc t c p
Änderung annehmen | Esc t c a
Änderung ablehnen | Esc t c r
Alle Änderungen annehmen | Esc t c Umschalttaste+a
Alle Änderungen ablehnen | Esc t c Umschalttaste+r
Vorschau Endergebnis | Esc t c Umschalttaste+f
Vorschau Original | Esc t c Umschalttaste+o
Vorschau aus | Esc t p o
Rubi | Esc s r
Inhaltsverzeichnis | Esc t o c
Liste von>Abbildungen | Esc l (kleines L) o f
Liste von>Tabellen | Esc l (kleines L) o t
Liste von>Elemente und Absätze | Esc l (kleines L) o p
Liste von>Elemente und Absätze (alphabetisch) | Esc l (kleines L) o Umschalttaste+p
Liste von>Marken (alphabetisch) | Esc l (kleines L) o m
Liste von>Marken | Esc l (kleines L) o Umschalttaste+m
Liste von>Referenzen | Esc l (kleines L) o r
Standardindex | Esc i x
Auswahl | Tastaturbefehl
Index von>Autoren | Esc i o a
Index von>Themen | Esc i o s
Index von>Marken | Esc i o m
Index von>Referenzen | Esc i o r
Unverkettete Seiten einfügen | Esc Umschalttaste+s u
Seiten löschen | Esc Umschalttaste+s l (kleines L)
Struktur aus Textfluss entfernen | Esc s s f


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Grafik"

Auswahl | Tastaturbefehl
Werkzeuge | Esc g Umschalttaste+w, Esc eins g
Gruppieren | Esc g g
Gruppierung aufheben | Esc g z
Nach vorne | Esc g Plus
Nach hinten | Esc g Minus
Ausrichten | Esc g a
Verteilen | Esc g v
Umformen | Esc g u
Glätten | Esc g Umschalttaste+g
Glättung aufheben | Esc g Umschalttaste+a
Vertikal spiegeln | Esc g Umschalttaste+v
Horizontal spiegeln | Esc g Umschalttaste+h
Drehen | Esc g d d
Skalieren | Esc g s
Seitenanzahl | Esc g #
Verbinden | Esc g Umschalttaste+b
Objekteinstellungen | Esc g o
Einstellungen übernehmen | Esc g Umschalttaste+o
Konturlaufeinstellungen | Esc g Umschalttaste+k
Fluchten | Esc g Umschalttaste+m
Magnet | Esc g Umschalttaste+e
3D-Menü | Alt+g+3+Umschalttaste+b
Beleuchtungsopiton für 3D-Menü | Alt+g+3+Umschalttaste+l (kleines L)
Licht aus Datei | Alt+g+3+Umschalttaste+l (kleines L) Shift+l (kleines L)
Kein Licht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+n
Weißes Licht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+w
Tageslicht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+d
Helles Licht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+b
Auswahl | Tastaturbefehl
Primärfarben-Licht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+p
Nachtlicht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+i
Blaues Licht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+u
Rotes Licht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+r
Cube-Licht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+c
CAD-optimiertes Licht | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+o
Scheinwerfer | Alt+g+3+Umschalttaste+l (kleines L)+Umschalttaste+h
Vorhandene Ansichten anzeigen | Alt+g+3+Umschalttaste+s
Option "Rendermodus" | Alt+g+3+Umschalttaste+r
Begrenzungsrahmen | Alt+g+3+Umschalttaste+r+Umschalttaste+b
Transparenter Begrenzungsrahmen | Alt+g+3+Umschalttaste+r+Umschalttaste+t
Transparente Begrenzungsrahmen-Kontur | Alt+g+3+Umschalttaste+r+Umschalttaste+o
Eckpunkte | Alt+g+3+Umschalttaste+r+Umschalttaste+v
Schattierte Eckpunkte | Alt+g+3+Umschalttaste+r+Umschalttaste+s
Drahtrahmen | Alt+g+3+Umschalttaste+r+Umschalttaste+w
Schattierter Drahtrahmen | Alt+g+3+Umschalttaste+r+h
Durchgezogen | Alt+g+3+Umschalttaste+r+l (kleines L)
Transparent | Alt+g+3+Umschalttaste+r+r
Durchgezogener Drahtrahmen | Alt+g+3+Umschalttaste+r+i
Transparenter Drahtrahmen | Alt+g+3+Umschalttaste+r+a
Abbildung | Alt+g+3+Umschalttaste+r+u
Durchgezogene Kontur | Alt+g+3+Umschalttaste+r+d
Schattierte Abbildung | Alt+g+3+Umschalttaste+r+e
Ausgeblendeter Drahtrahmen | Alt+g+3+Umschalttaste+r+n


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Tabelle"

Auswahl | Tastaturbefehl
Tabelle einfügen | Esc t e
Tabellengestaltung | Esc t f, Strg+t, Strg+Umschalttaste+t
Reihenformat | Esc t r
Lineatur/Schattierung | Esc t l (kleines L)
Reihen oder Spalten einfügen | Esc t Umschalttaste+r
Spaltenbreite ändern | Esc t b
Verbinden/Trennen | Esc t Umschalttaste+b
Zu Tabelle konvertieren/Zu Absätzen konvertieren | Esc t k
Sortieren | Esc t s


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Strukturierungswerkzeuge"

Auswahl | Tastaturbefehl
Strukturierungswerkzeuge>Strukturierte Anwendung zuweisen | Esc f + Umschalttaste+a, ALT+ r + u
Strukturierungswerkzeuge>Dienstprogramme | ALT + r + l
Strukturierungswerkzeuge>Dienstprogramme>Strukturierte Dokumente konvertieren | Esc f + t + s, ALT + r + l + c
Strukturierungswerkzeuge>Dienstprogramme>Dokumente in strukturiertes Format konvertieren | Esc f + t + d, ALT + r + l + d
Strukturierungswerkzeuge>Dienstprogramme>Aktuelles Dokument strukturieren | Esc f + t + Umschalttaste+c, ALT + r + l + s
Strukturierungswerkzeuge>Dienstprogramme>Dokumente strukturieren | Esc f + t + Umschalttaste+d, ALT + r + l + t
Strukturierungswerkzeuge>Neues EDD | Esc f Umschalttaste+d Umschalttaste+n
Strukturierungswerkzeuge>Elementkatalog als EDD exportieren | Esc f Umschalttaste+d Umschalttaste+x
Strukturierungswerkzeuge > CSS-Stile importieren | Esc f Umschalttaste+d Umschalttaste+j
Strukturierungswerkzeuge>Elementkontext einblenden | Esc f Umschalttaste+d Umschalttaste+e
Strukturierungswerkzeuge>DTD öffnen | Esc f Umschalttaste+d Umschalttaste+o
Strukturierungswerkzeuge>DTD importieren | Esc f Umschalttaste+d Umschalttaste+m
Strukturierungswerkzeuge>Sichern als DTD | Esc f Umschalttaste+d Umschalttaste+s
Strukturierungswerkzeuge>Schema öffnen | Esc f Umschalttaste+d Umschalttaste+y
Strukturierungswerkzeuge>Schema importieren | Esc f Umschalttaste+d Umschalttaste+z
Strukturierungswerkzeuge>Anwendungsdefinitionen bearbeiten | Esc f Umschalttaste+d Umschalttaste+a
Strukturierungswerkzeuge>Anwendungsdefinitionen lesen | Esc f Umschalttaste+d Umschalttaste+r
Strukturierungswerkzeuge>Neue Lese-/Schreibregeln | Esc f Umschalttaste+d Umschalttaste+w
Strukturierungswerkzeuge>Lese-/Schreibregeln überprüfen | Esc f Umschalttaste+d Umschalttaste+c
Strukturierungswerkzeuge>Strukturiertes Dokument analysieren | Esc f Umschalttaste+d Umschalttaste+p
Strukturierungswerkzeuge>Konvertierungstabelle generieren | Esc f Umschalttaste+d Umschalttaste+g
Strukturierungswerkzeuge>CSS2 generieren | Esc f Umschalttaste+d Umschalttaste+h


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

DITA-Menü

Auswahl | Tastaturbefehl
DITA>Neue DITA-Datei>Neues <mapi> Hinweis: | Esc Umschalttaste+n Umschalttaste+m i
DITA>Neue DITA-Datei>Neues <topici> DITA>Neue DITA-Datei>Neues <concepti> DITA>Neue DITA-Datei>Neues <taski> DITA>Neue DITA-Datei>Neues <referencei> Hinweis: | Esc Umschalttaste+n Umschalttaste+t 1 Esc Umschalttaste+n Umschalttaste+t 2 Esc Umschalttaste+n Umschalttaste+t i
Auswahl | Tastaturbefehl
DITA>Neue DITA-Datei>Menü aktualisieren | Esc Umschalttaste+r Umschalttaste+m
DITA>Conref einfügen | Esc Umschalttaste+i Umschalttaste+c
DITA>ID für Element zuweisen | Esc Umschalttaste+a Umschalttaste+i
DITA>Referenzen aktualisieren | Esc Umschalttaste+u Umschalttaste+r
DITA>Alle Topicrefs öffnen | Esc Umschalttaste+o Umschalttaste+a
DITA>Topicref einfügen | Esc Umschalttaste+i Umschalttaste+t
DITA>FM-Dokument von DITA Map erstellen | Esc Umschalttaste+g Umschalttaste+d
DITA>DITA-Optionen | Esc Umschalttaste+d Umschalttaste+o


Tastaturbefehle / Tastaturbefehle für Windows / Menübefehle

Menü "Fenster"

Auswahl | Tastaturbefehl
Überlappend | Umschalttaste+F4
Nebeneinander | Umschalttaste+F5
Symbole anordnen | (Kein Tastaturbefehl verfügbar)
Auffrischen | Strg+l (kleines L)


Tastaturbefehle / Tastaturbefehle für Windows / Fenster und Dialogfenster

Fenster bearbeiten

Zur Verwendung dieser Tastaturbefehle klicken Sie in ein beliebiges FrameMaker-Fenster.

Funktion | Tastaturbefehl
Ein Dokumentfenster erneut anzeigen | Esc w r, Strg+l (kleines L)
Aktives Fenster oder Dialogfenster ohne Modus schließen | Alt+F4
Dokumentfenster schließen | Esc d q, Strg+F4, Strg+w, Strg+Umschalttaste+w
Dokumentfenster minimieren | Esc w c


Tastaturbefehle / Tastaturbefehle für Windows / Fenster und Dialogfenster

Darstellung und Aktivierung

Verwenden Sie diese Tastaturbefehle, um ein Fenster oder Dialogfenster anzuzeigen und zu aktivieren. Wenn es bereits geöffnet ist, sich jedoch hinter einem anderen Fenster befindet, kann es mit den folgenden Tastaturbefehlen in den Vordergrund gebracht werden.

Fenster anzeigen und aktivieren | Tastaturbefehl
Aktuelles Dokumentfenster | Esc g d Umschalttaste+d, Umschalttaste+F7
Suchen/Ändern | Esc Umschalttaste+e s
Hypertext | Esc Umschalttaste+f i h
Marke | Esc Umschalttaste+e m
Rechtschreibhilfe | Esc Umschalttaste+e r
Absatzgestaltung | Esc Umschalttaste+e f
Zeichengestaltung | Esc Umschalttaste+e z
Bedingter Text | Esc Umschalttaste+e b
Lineatur/Schattierung | Esc Umschalttaste+e l (kleines L)
Tabellengestaltung | Esc Umschalttaste+f a g
Strukturansicht | Esc Umschalttaste+e u
Elementprüfung | Esc Umschalttaste+e p


Tastaturbefehle / Tastaturbefehle für Windows / Fenster und Dialogfenster

In Fenstern navigieren

Sie können mit diesen Tastaturbefehlen zu Einstellungen in Dialogfenstern und Fenstern wechseln. Wenn Sie einen Tastaturbefehl in einem Dialogfenster anwenden, hängt die Wirkung von der aktiven Einstellung ab. Die aktive Einstellung ist hervorgehoben und/oder von einem punktierten Rechteck umgeben.

Bewegen zu | Tastaturbefehl
Nächste Einstellung | Tabulator
Vorherige Einstellung | Umschalttaste+Tabulator


Tastaturbefehle / Tastaturbefehle für Windows / Fenster und Dialogfenster

Befehlsfelder

Funktion | Tastaturbefehl
Auf ein Standard-Feld klicken | Eingabetaste
Auf das aktive Feld klicken | Leertaste
Dialogfenster abbrechen (gilt nicht für Fenster) | Esc


Tastaturbefehle / Tastaturbefehle für Windows / Fenster und Dialogfenster

Options- und Markierungsfelder

Funktion | Tastaturbefehl
Eine Gruppe von Optionsfeldern durchlaufen, um ein Optionsfeld zu aktivieren | Pfeiltasten
Zwischen Zuständen eines Markierungsfelds (Aus, Ein, Beibehalten) wechseln | Leertaste


Tastaturbefehle / Tastaturbefehle für Windows / Fenster und Dialogfenster

Aufklappmenüs

Funktion | Tastaturbefehl
Zum vorherigen Menüelement wechseln | Nach-Oben-Taste
Zum nächsten Menüelement wechseln | Nach-Unten-Taste
Vorwärts suchen und ein Element durch Eingabe des Anfangsbuchstabens auswählen | Buchstabentaste ohne gedrückte Umschalttaste


Tastaturbefehle / Tastaturbefehle für Windows / Fenster und Dialogfenster

Auswahllisten

Funktion | Tastaturbefehl
Zum vorherigen Listenelement bewegen | Nach-Oben-Taste
Zum nächsten Listenelement bewegen | Nach-Unten-Taste
Vorwärts suchen und ein Element durch Eingabe des Anfangsbuchstabens auswählen | Buchstabentaste ohne gedrückte Umschalttaste
Ein Element in einer Auswahlliste in die gegenüberliegende Auswahlliste verschieben | Auf das Element doppelklicken
Alle Elemente in einer Auswahlliste in die gegenüberliegende Auswahlliste verschieben | Die Umschalttaste drücken und auf den Pfeil zwischen den Auswahllisten klicken


Tastaturbefehle / Tastaturbefehle für Windows / Fenster und Dialogfenster

Spezialmenüs

Funktion | Tastaturbefehl
Eine Spezialmenüleiste anzeigen | Esc Umschalttaste+d m s


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentgestaltung

Vorgabeseiten und Referenzseiten

Funktion | Tastaturbefehl
Eine Vorgabe- oder Referenzseite umbenennen (zeigen Sie vor Verwendung des Tastaturbefehls die Vorgabe- oder Referenzseite an) | Esc s Umschalttaste+u
Eine Vorgabeseite erstellen (zeigen Sie vor Verwendung des Tastaturbefehls eine Arbeits- oder Vorgabeseite an) | Esc f n v oder Esc s v


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentgestaltung

Seitenlayout

Funktion | Tastaturbefehl
Seitenlayouts aktualisieren (zeigen Sie vor Verwendung des Tastaturbefehls eine Arbeitsseite an) | Esc f s a


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentgestaltung

Formate importieren

Funktion | Tastaturbefehl
Formate aus einem anderen Dokument importieren | Esc d f


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentgestaltung

Bereich für seitliche Überschriften

Funktion | Tastaturbefehl
Bereich für seitliche Überschriften aktivieren bzw. deaktivieren | Esc f s u


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentgestaltung

Textflüsse

Funktion | Tastaturbefehl
Einen Textrahmen unterhalb der Einfügemarke teilen | Esc t t u
Den Textrahmen mit der Einfügemarke vom vorherigen Textrahmen in einem Textfluss abtrennen | Esc t t v
Den Textrahmen mit der Einfügemarke vom nächsten Textrahmen in einem Textfluss abtrennen | Esc t t n
Den Textrahmen mit der Einfügemarke vom vorhergehenden und vom nächsten Textrahmen abtrennen | Esc t t b
Zwei ausgewählte Textrahmen verketten | Esc t v Umschalttaste+k


Tastaturbefehle / Tastaturbefehle für Windows / Dokumente

Hilfe

Funktion | Tastaturbefehl
Online-Hilfe anzeigen | Esc d Umschalttaste+h, F1
Adobe Online | Esc w w w
Hilfe zu den Schablonen in FrameMaker anzeigen | Drücken Sie Strg+n und klicken Sie auf "Standardschablonen durchsuchen".


Tastaturbefehle / Tastaturbefehle für Windows / Dokumente

Öffnen

Öffnen | Tastaturbefehl
Dokument in einer Buchdatei | Doppelklicken Sie auf den Dateinamen im Buchfenster
Alle Dateien in einem aktiven Buchfenster | Esc d Umschalttaste+o, oder drücken Sie die Umschalttaste und wählen Sie "Alle Dateien des Buchs öffnen" aus dem Menü "Datei".
MIF- oder MML-Datei als Textdatei | Drücken Sie Strg und klicken Sie im Dialogfenster "Öffnen" auf "Öffnen".


Tastaturbefehle / Tastaturbefehle für Windows / Dokumente

Speichern und Schließen

Funktion | Tastaturbefehl
Dialogfenster zum Speichern des Dokuments anzeigen | Esc d a
Dokument oder Buch speichern | Esc d s, Strg+s
Geöffnete Dateien sichern | Esc d Umschalttaste+s, oder drücken Sie die Umschalttaste und wählen Sie "Geöffnete Dateien sichern" aus dem Menü "Datei".
Alle geöffneten Dateien in einem aktiven Buchfenster in einem Buch speichern | Esc d Umschalttaste+s, oder drücken Sie die Umschalttaste und wählen Sie "Alle Dateien des Buchs sichern" aus dem Menü "Datei".
Alle geöffneten Dateien schließen | Esc d Umschalttaste+v, oder drücken Sie die Umschalttaste und wählen Sie "Geöffnete Dateien schließen" aus dem Menü "Datei".
Alle geöffneten Dateien in einem aktiven Buchfenster in einem Buch schließen | Esc d Umschalttaste+v, oder drücken Sie die Umschalttaste und wählen Sie "Alle Dateien des Buchs schließen" aus dem Menü "Datei".


Tastaturbefehle / Tastaturbefehle für Windows / Dokumente

Abbrechen und Widerrufen

Funktion | Tastaturbefehl
Bestimmte Befehle in FrameMaker abbrechen | Esc
Bestimmte Befehle in FrameMaker widerrufen | Esc b r, Strg+z, Alt+Rücktaste, Strg+Umschalttaste+z


Tastaturbefehle / Tastaturbefehle für Windows / Dokumente

In einem Dokument navigieren

Anzeige | Tastaturbefehl
Vorherige Seite | Esc s Umschalttaste+v, Bild-Auf
Nächste Seite | Esc s Umschalttaste+n, Bild-Ab
Erste Seite | Esc s Umschalttaste+e, Alt+Bild-Auf, oder drücken Sie die Umschalttaste und klicken Sie auf das Symbol "Vorherige Seite".
Letzte Seite | Esc s Umschalttaste+l (kleines L), Alt+Bild-Ab, oder drücken Sie die Umschalttaste und klicken Sie auf das Symbol "Nächste Seite".
Dialogfenster "Wechseln zu Seite" | Esc Umschalttaste+d w, Strg+g


Tastaturbefehle / Tastaturbefehle für Windows / Dokumente

Dokument erneut anzeigen

Funktion | Tastaturbefehl
Dokument erneut anzeigen | Esc w r, Strg+l (kleines L)


Tastaturbefehle / Tastaturbefehle für Windows / Dokumente

Zoom

Aktion | Tastaturbefehl
Um eine Zoom-Einstellung größer zoomen | Esc Umschalttaste+z Umschalttaste+g
Um eine Zoom-Einstellung kleiner zoomen | Esc Umschalttaste+z Umschalttaste+k
Seite an Fenster anpassen | Esc Umschalttaste+z Umschalttaste+s
Fenster an Seite anpassen | Esc Umschalttaste+z Umschalttaste+f
Fenster an Textrahmen anpassen | Esc Umschalttaste+z f
Auf 100 Prozent zoomen | Esc Umschalttaste+z Umschalttaste+o


Tastaturbefehle / Tastaturbefehle für Windows / Dokumente

Hypertext-Dokumente

Funktion | Tastaturbefehl
Zur vorherigen Position im Hypertext-Stapel wechseln | Esc v v
Zur nächsten Position im Hypertext-Stapel wechseln | Esc v n
Hypertext-Befehl aktivieren, ohne das Dokument zu sperren | Drücken Sie Strg+Alt, und klicken Sie auf einen aktiven Bereich.
Dokument sperren oder entsperren | Esc d Umschalttaste+y
Dialogfenster "Hypertext" öffnen | Esc s h
Neue Hypertext-Marke einfügen | Esc m h
Fokus auf Dialogfenster "Hypertext" setzen | Esc Umschalttaste+f i h
Dialogfenster "Hypertext" schließen | Esc Umschalttaste+c h
Hypertext-Befehl prüfen | Esc v h
Gesperrtes FluidView-Format umschalten | Esc Umschalttaste+u a


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentdienstprogramme

Rechtschreibhilfe

Funktion | Tastaturbefehl
Ausgewählten Text bzw. ausgewähltes Wort mit der Einfügemarke prüfen | Esc r b, oder drücken Sie Strg und klicken Sie im Dialogfenster "Rechtschreibhilfe" auf "Prüfung beginnen".
Gesamtes Dokument prüfen | Esc r g
Aktuelle Seite prüfen | Esc r s
Ein Wort korrigieren | Esc r w
Ein Wort in Ihr persönliches Wörterbuch einfügen (aufnehmen) | Esc r a p
Ein Wort dem Dokumentwörterbuch hinzufügen | Esc r a d
Ein Wort der automatischen Korrektur hinzufügen | Esc r a v
Ein Wort aus Ihrem persönlichen Wörterbuch löschen (streichen) | Esc r l (kleines L) p
Ein Wort aus dem Dokumentwörterbuch löschen | Esc r l (kleines L) d
Liste für automatische Korrekturen löschen | Esc r l (kleines L) v
Dialogfenster "Optionen für Rechtschreibhilfe" anzeigen | Esc r o
Dialogfenster "Wörterbuchfunktionen" anzeigen | Esc r Umschalttaste+l (kleines L)
Datei unbekannter Wörter erstellen | Esc r Umschalttaste+s
Alle Absätze für erneute Prüfung markieren | Esc r p
Trennung anzeigen | Esc r Bindestrich
Dokument neu trennen | Esc r Umschalttaste+n
Ein gemeldetes Wort ersetzen | Doppelklicken Sie im Dialogfenster "Rechtschreibhilfe" auf das Wort in der Auswahlliste "Korrektur".


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentdienstprogramme

Thesaurus

Für diesen Tastaturbefehl muss nicht der Thesaurus, sondern das Dokumentfenster aktiviert sein.

Funktion | Tastaturbefehl
Eine Auswahl durch den Thesaurus-Vorschlag ersetzen | Esc Umschalttaste+t e


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentdienstprogramme

Dokumentvergleich

Funktion | Tastaturbefehl
Dialogfenster "Dokumente vergleichen" anzeigen | Esc d t v


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentdienstprogramme

Statistik

Funktion | Tastaturbefehl
Dialogfenster "Statistik" anzeigen | Esc d t s


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentdienstprogramme

HTML- und PDF-Export

Funktion | Tastaturbefehl
Formate anlegen und zuweisen | Esc d Umschalttaste+d f
Dialogfenster "HTML-Einstellungen" öffnen | Esc f t h
Dialogfenster "PDF-Einstellungen" öffnen | Esc o d a


Tastaturbefehle / Tastaturbefehle für Windows / Dokumentdienstprogramme

Referenzaktualisierung

Funktion | Tastaturbefehl
Dialogfenster "Automatische Referenzaktualisierung unterdrücken" anzeigen | Esc b Umschalttaste+u


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Zeichenwerkzeuge

Werkzeug | Tastaturbefehl
Bogen | Esc o b
Grafikrahmen | Esc o Umschalttaste+r
Werkzeug | Tastaturbefehl
Freihandkurve | Esc o f
Zuletzt gewähltes Werkzeug | Esc o w
Gerade | Esc o g
Objektauswahl | Esc o o
Ellipse | Esc o e
Polygon | Esc o p
Polygonzug | Esc o l (kleines L)
Rechteck | Esc o r
Abgerundetes Rechteck | Esc o a
Intelligente Auswahl | Esc o i
Textrahmen | Esc o s
Textzeile | Esc o z
Zeichenobjekt | Tastaturbefehl
Vertikale, horizontale oder diagonale Gerade | Drücken Sie die Umschalttaste und zeichnen Sie eine Gerade.
Quadrat | Drücken Sie die Umschalttaste und zeichnen Sie ein Rechteck.
Kreis | Drücken Sie die Umschalttaste und zeichnen Sie eine Ellipse.
Kreisausschnitt | Drücken Sie die Umschalttaste und zeichnen Sie einen Bogen.
Werkzeugpalette anzeigen | Esc eins g, Esc g Umschalttaste+w
Werkzeug nach Verwendung aktiv lassen | Drücken Sie die Umschalttaste und klicken Sie auf ein Zeichenwerkzeug.
Nach dem Zeichnen zum Objektauswahlwerkzeug zurückkehren | Drücken Sie die Umschalttaste und klicken Sie auf das Objektauswahlwerkzeug.


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Füllmuster

Die Begriffe "Erstes", "Letztes", "Nächstes" oder "Vorheriges" beziehen sich auf Positionen im Aufklappmenü " Füllung".

Wechseln zu | Tastaturbefehl
Erstes Füllmuster (durchgehend) | Esc Umschalttaste+f eins
Letztes Füllmuster (keines) | Esc 9 f
Nächstes Füllmuster (wenn das letzte Füllmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Plus f
Vorheriges Füllmuster (wenn das erste Füllmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Minus f


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Linienmuster

Die Begriffe "Erstes", "Letztes", "Nächstes" oder "Vorheriges" beziehen sich auf Positionen im Aufklappmenü.

Wechseln zu | Tastaturbefehl
Erstes Linienmuster (durchgehend) | Esc eins u
Letztes Linienmuster (keines) | Esc 9 u
Nächstes Linienmuster (wenn das letzte Linienmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Plus u
Vorheriges Linienmuster (wenn das erste Linienmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Minus u


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Linienstärke

Die Begriffe "Nächste" oder "Vorherige" beziehen sich auf Positionen im Aufklappmenü "Linienstärke".

Wechseln zu | Tastaturbefehl
Dünnste Linienstärke | Esc null b
Breiteste Linienstärke | Esc 9 b
Nächste Linienstärke | Esc Plus b
Vorherige Linienstärke | Esc Minus b


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Strichstil

Um die für ein Objekt verwendete Linienart zu verändern, wählen Sie einen Stil aus dem Aufklappmenü "Strichstil".
Um das aktuelle Aussehen einer gestrichelten Linie zu verändern, wählen Sie ein Muster aus dem Dialogfenster "Stricheinstellungen". Die Begriffe "Erster", "Letzter", "Nächster" oder "Vorheriger" beziehen sich auf Positionen in diesem Dialogfenster.

Funktion | Tastaturbefehl
Durchgehenden Strichstil einem Objekt zuweisen | Esc o m d
Gestrichelten Strichstil einem Objekt zuweisen | Esc o m g
Dialogfenster "Stricheinstellungen" anzeigen | Esc o m o
Zum ersten Strichmuster wechseln | Esc o m eins
Zum letzten Strichmuster wechseln | Esc o m 9
Zum nächsten Strichmuster wechseln, (wenn das letzte Strichmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc o m Plus
Zum vorherigen Strichmuster wechseln (wenn das erste Strichmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc o m Minus


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Objekte auswählen

Verwenden Sie diese Tastaturbefehle, um Objekte auf der aktuellen Seite auszuwählen.

Funktion | Tastaturbefehl
Textzeile oder Textrahmen auswählen | Drücken Sie Strg und klicken Sie auf die Textzeile oder den Textrahmen.
Die Auswahl erweitern oder verkleinern | Drücken Sie die Umschalttaste und klicken Sie auf ein Objekt.
Anzeige des Auswahlrahmens erzwingen (wenn Ziehen von außerhalb der Objekte nicht möglich ist) | Drücken Sie Strg+Umschalttaste und ziehen Sie diagonal.
Das erste Objekt in der Zeichenreihenfolge auswählen | Esc o eins
Funktion | Tastaturbefehl
Das nächste Objekt in der Zeichenreihenfolge auswählen | Esc o n
Die Auswahl auf das nächste Objekt in der Zeichenreihenfolge erweitern | Esc o Plus
Die Auswahl eines Textrahmens oder einer Textzeile aufheben und die Einfügemarke stattdessen in das Objekt setzen | Doppelklicken Sie in den Textrahmen oder in die Textzeile.


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Objekte bearbeiten

Funktion | Tastaturbefehl
Horizontales oder vertikales Bewegen des Objekts | Drücken Sie die Umschalttaste und ziehen Sie das Objekt.
Beibehalten der Objektproportionen bei der Größenänderung | Drücken Sie die Umschalttaste und ziehen Sie einen Eckpunkt.
Die Einstellungen der gerade gewählten Objekte in der Werkzeugpalette übernehmen | Esc g Umschalttaste+o, oder drücken Sie die Umschalttaste und wählen Sie "Einstellungen übernehmen" aus dem Menü "Grafik".
Umformpunkt und Kontrollpunkte für gerade gewählte Linie, Polygonzug oder Freihandkurve anzeigen | Esc g u, Strg+r, Strg+Umschalttaste+r
Horizontales oder vertikales Bewegen des Kontrollpunkts | Drücken Sie die Umschalttaste und ziehen Sie den Kontrollpunkt.
Ändern der Kurve nur an einer Seite des Umformpunkts (Kurve krümmen) | Ziehen Sie den Kontrollpunkt bei gedrückter rechter Maustaste.
Die Konturen einer gewählten Grafik von Text umfließen lassen | Esc g k
Bildrahmen einer gewählten Grafik von Text umfließen lassen | Esc Umschalttaste+g r
Konturlauf für gewählte Grafik deaktivieren | Esc Umschalttaste+g Umschalttaste+d
Ein ausgewähltes Objekt schnell kopieren | Alt und das Objekt ziehen
Grafiken ein- und ausblenden | Esc Umschalttaste+d Umschalttaste+a
Einen Umformpunkt und Kontrollpunkte hinzufügen | Drücken Sie Strg und klicken Sie auf eine Linie, einen Polygonzug, ein Polygon oder eine Freihandkurve mit aktuell angezeigten Umform- und Kontrollpunkten.
Umformpunkt löschen | Drücken Sie Strg und klicken Sie auf den Umformpunkt.
Ziehen und Ablegen zwischen geöffneten Fenstern oder Anwendungen | Ziehen (zum Kopieren Strg gedrückt halten)


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Objekte bewegen

Verwenden Sie diese Tastaturbefehle, um ausgewählte Objekte zu bewegen.

Objekte bewegen | Tastaturbefehl
Ein Punkt in angegebene Richtung (bei Zoom-Einstellung 100 %) | Alt+Pfeiltaste
Sechs Punkt in angegebene Richtung (bei Zoom-Einstellung 100 %) | Alt+Umschalttaste+Pfeiltaste


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Objekte ausrichten

Wenn nur ein Objekt ausgewählt ist, wird das Objekt an der Seite, an einem verankerten Rahmen oder Grafikrahmen ausgerichtet, der das Objekt umgibt.

Objekte ausrichten an | Tastaturbefehl
Oberkanten | Esc Umschalttaste+a Umschalttaste+o, Strg+F1
Mitte vertikal | Esc Umschalttaste+a Umschalttaste+m, Strg+F2
Unterkanten | Esc Umschalttaste+a Umschalttaste+u, Strg+F3
Linke Seiten | Esc p a l (kleines L)
Mitte horizontal | Esc p a Umschalttaste+z
Rechte Seiten | Esc p a Umschalttaste+r


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Objekte drehen

Funktion | Tastaturbefehl
Um 90 Grad im Uhrzeigersinn drehen | Esc g Umschalttaste+d Plus
Um 90 Grad gegen Uhrzeigersinn drehen | Esc g Umschalttaste+d Minus
Präzises Drehen mit Dialogfenster "Ausgewählte Objekte drehen" | Esc g d d
Erneut drehen | Esc g Umschalttaste+d e
Nicht gedrehte Ausrichtung des Objekts wiederherstellen (null Grad) | Esc g Umschalttaste+d null
Objekt von seiner nicht gedrehten zur vorherigen Ausrichtung drehen | Esc g Umschalttaste+d eins
Aktuelle Position eines Objekts als neue, nicht gedrehte Ausrichtung festlegen | Esc g Umschalttaste+d 9
Ein Objekt willkürlich drehen | Drücken Sie Alt, und ziehen Sie eine Ecke oder einen Umformpunkt.
Drehung auf 45-Grad-Schritte beschränken | Drücken Sie Alt+Umschalttaste und ziehen Sie eine Ecke oder einen Umformpunkt.
Seite im Uhrzeigersinn drehen | Esc p Umschalttaste+p Umschalttaste+o
Seite gegen den Uhrzeigersinn drehen | Esc p Umschalttaste+p o
Seitendrehung aufheben | Esc p Umschalttaste+p Umschalttaste+u


Tastaturbefehle / Tastaturbefehle für Windows / Grafiken

Grafikrahmen

Funktion | Tastaturbefehl
Einpassen eines verankerten Rahmens (passt Rahmen an das Objekt an und positioniert den Rahmen an der Einfügemarke) | Esc m p
Freilegen eines verankerten Rahmens (Rahmen vergrößern) | Esc m e
Ausgewählten Referenzrahmen umbenennen | Klicken Sie auf den Rahmennamen in der Statuszeile.


Tastaturbefehle / Tastaturbefehle für Windows / Marken und Variablen

Marken einfügen

Funktion | Tastaturbefehl
Marke einfügen | Esc m k
Hypertext-Marke einfügen | Esc m h
Das Dialogfenster "Markentypen bearbeiten" öffnen | Esc m t b


Tastaturbefehle / Tastaturbefehle für Windows / Marken und Variablen

Variablen einfügen

Funktion | Tastaturbefehl
Eine Variable durch Eingabe der ersten Zeichen ihres Namens und Drücken der Eingabetaste einfügen | Esc k v, Strg+Null


Tastaturbefehle / Tastaturbefehle für Windows

Filter nach Attribut

Funktion | Tastaturbefehl
Dialogfenster "Attributausdrücke verwalten" öffnen | Esc a c


Tastaturbefehle / Tastaturbefehle für Windows

Verfolgen von Textänderungen

Funktion | Tastaturbefehl
Funktion zur Verfolgung von Textänderungen aktivieren oder deaktivieren | Esc t c o
Nächste Textänderung anzeigen | Esc t c n
Vorherige Textänderung anzeigen | Esc t c p
Änderung annehmen | Esc t c a
Änderung ablehnen | Esc t c r
Alle Änderungen annehmen | Esc t c Umschalttaste+a
Alle Änderungen ablehnen | Esc t c Umschalttaste+r
Vorschau Endergebnis | Esc t c Umschalttaste+f
Vorschau Original | Esc t c Umschalttaste+o
Vorschau aus | Esc t p o


Tastaturbefehle / Tastaturbefehle für Windows / Verfolgen von Textänderungen

Bedingten Text anzeigen

Funktion | Tastaturbefehl
Dialogfenster "Bedingten Text ein-/ausblenden" anzeigen | Esc b d
Bedingungsformate aktivieren oder deaktivieren | Esc b Umschalttaste+f
Den gesamten Text an der Einfügemarke auswählen, der dieselben Bedingungstyp-Einstellungen aufweist | Esc Umschalttaste+h b


Tastaturbefehle / Tastaturbefehle für Windows / Verfolgen von Textänderungen

Fenster "Bedingter Text"

Zur Verwendung dieser Tastaturbefehle klicken Sie in das Fenster "Bedingter Text".

Funktion | Tastaturbefehl
Alle Bedingungstypen in die Auswahlliste "Beibehalten" verschieben | Umschalttaste+F8
Auswahllisten ändern, damit sie mit den Bedingungstyp-Einstellungen des ausgewählten Textes übereinstimmen | Umschalttaste+F9
Einen Bedingungstyp zwischen den Auswahllisten "Mit" und "Ohne" verschieben | Auf den Typ doppelklicken
Einen Bedingungstyp aus der Auswahlliste "Beibehalten" in die Auswahlliste "Mit" verschieben | Doppelklicken Sie auf den Typ in der Auswahlliste "Beibehalten".


Tastaturbefehle / Tastaturbefehle für Windows / Verfolgen von Textänderungen

Bedingungstypen

Verwenden Sie diese Tastaturbefehle, um die Bedingungstyp-Einstellungen von ausgewähltem Text oder ausgewählten Tabellenreihen zu ändern.

Funktion | Tastaturbefehl
Einen Bedingungstyp ausgewähltem Text durch Eingabe der ersten Zeichen des Typs und anschließendes Drücken der Eingabetaste zuweisen | Esc b Plus, Strg+4
Einen Bedingungstyp aus ausgewähltem Text durch Eingabe der ersten Zeichen des Typs und anschließendes Drücken der Eingabetaste entfernen | Esc b Minus, Strg+5
Ausgewählten Text in nicht bedingten Text umwandeln | Esc b Umschalttaste+l (kleines L), Strg+6


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Aufklappmenü "Gleichungen"

Befehl | Tastaturbefehl
Neue Gleichung (klein) | Esc m s
Neue Gleichung (mittel) | Esc m m
Neue Gleichung (groß) | Esc m l (kleines L)
Gleichung einpassen | Esc m p
Gleichung freilegen | Esc m e
Gleichungsgrößen | Esc p e
Gleichungsschriften | Esc m f
FrameMath-Element einfügen | Esc m i
Definition in Katalog aufnehmen | Esc m c
Definition aktualisieren | Esc m Umschalttaste+u


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Seite "Symbole"

Griechische Buchstaben

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Element | Tastaturbefehl | Eingabe im Dialogfenster
 | Strg+Alt+a | \alpha
 | Strg+Alt+b | \beta
 | Strg+Alt+Umschalttaste+g | \Gamma
 | Strg+Alt+g | \gamma
 | Strg+Alt+Umschalttaste+d | \Delta
 | Strg+Alt+d | \delta
 | Strg+Alt+e | \epsilon
 | Strg+Alt+z | \zeta
 | Strg+Alt+h | \eta
 | Strg+Alt+Umschalttaste+q | \Theta
 | Strg+Alt+q | \theta
 | Strg+Alt+Umschalttaste+j | \vartheta
 | Strg+Alt+i | \iota
 | Strg+Alt+k | \kappa
 | Strg+Alt+Umschalttaste+l (L) | \Lambda
 | Strg+Alt+l | \lambda (kleines L)
 | Strg+Alt+m | \mu
 | Strg+Alt+n | \nu
 | Strg+Alt+Umschalttaste+x | \Xi
 | Strg+Alt+x | \xi
 | Strg+Alt+Umschalttaste+p | \Pi
 | Strg+Alt+p | \pi
 | Strg+Alt+r | \rho
 | Strg+Alt+Umschalttaste+s | \Sigma
 | Strg+Alt+s | \sigma
 | Strg+Alt+Umschalttaste+e | \varsigma
 | Strg+Alt+t | \tau
 | Strg+Alt+Umschalttaste+u | \Upsilon
 | Strg+Alt+u | \upsilon
 | Strg+Alt+Umschalttaste+f | \Phi
 | Strg+Alt+f | \phi
 | Strg+Alt+j | \varphi
 | Strg+Alt+c | \chi
 | Strg+Alt+Umschalttaste+y | \Psi
 | Strg+Alt+y | \psi
 | Strg+Alt+Umschalttaste+o | \Omega
 | Strg+Alt+o | \omega
 | Strg+Alt+Umschalttaste+i | \varpi
 | Strg+Alt+7 | \cpartial

Sonstige spezielle Symbole

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Element | Tastaturbefehl | Eingabe im Dialogfenster
 | Strg+Alt+1 | \infty
 | Strg+Alt+2 | \bot
... | Strg+q Punkt | \ldots
 | Strg+Alt+3 | \aleph
 | Strg+Alt+4 | \Im
 | Strg+m $ | \Re
 | Strg+Alt+5 | \wp
 | Strg+Alt+0 (Null) | \emptyset
 | Strg+Alt+6 | \nabla
° | Strg+m ) | \degree
‘ | Strg+Alt+` | \prime
" | Strg+m " | \pprime

Zeichenfolgen

Befehl | Tastaturbefehl
Textanfang | ' oder "
Textende | Eingabetaste

Diakritische Zeichen

Element | Tastaturbefehl
 | ` (Gravis)
 | ~ (Tilde)
 | Strg+g Bindestrich
 | Strg+Alt+Umschalttaste+v
 | Strg+g ^
 | Punkt
 | Strg+g ~ (Tilde)
 | Strg+g _ (Unterstrich)
 | Strg+g Nach-Rechts-Taste
 | Strg+g @


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Seite "Operatoren"

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
+ | Plus | \plus
_ | Minus (nach einem Operanden) |
?x? | Strg+m * (Sternchen) | \cross
 | Strg+m Punkt | \cdot
 | Strg+8 | \bullet
Format umschalten | Strg+Umschalttaste+t, Esc m Umschalttaste+t |
 | Strg+Alt+/ | \fract
 | Strg+m / | \div
 | / | \over
?=? | = | \equal
 | Strg+g = | \uequal
 | Strg+j | \jotdot
?,? | Komma | \comma
 | Strg+q Umschalttaste+d | \otimes
 | Strg+q Umschalttaste+e | \oplus
 | Strg+q Umschalttaste+y | \wedge
 | Strg+q Umschalttaste+z | \vee
 | Strg+m i | \cap
 | Strg+m u | \cup
 | Strg+m Komma | \ucomma
 | ; | \semicolon
 | Strg+m n | \neg
- | Strg+Bindestrich | \minus
 | Strg+m 1 | \mp
 | Strg+q 1 | \pm
 | Strg+q Umschalttaste+q | \grad
 | Strg+q Umschalttaste+q (und Operand hinzufügen) |
 | Strg+m Strg+d | \change
 | Strg+m x | \box
 | Strg+m o | \boxdot
 | Strg+m 2 | \box2
 | Strg+m a | \forall
 | Strg+m e | \exist
 | Strg+m t | \therefore
 | Strg+a, Esc m v l | \atop (kleines L)
 | Strg+m; (Semikolon), | \list Esc m h l (kleines L)
 | * (Sternchen) | \times
 | Strg+g | (senkrechter Strich) | \abs
 | Esc m ^ |
 | Esc m Strg+Umschalttaste - (Bindestrich) |
 | Strg+m Strg+^ |
 | Strg+m Strg+ Umschalttaste - (Bindestrich) |
 | Strg+r | \sqrt
 | Strg+r (und Operand hinzufügen) |
 | Strg+Umschalttaste+e | \sn
 | ^ | \power
 | Strg+m d | \dagger
 | ! | \fact
 | Strg+m s | \ast
 | Strg+q Umschalttaste+p | \angle


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Seite "Groß"

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.
Verwenden Sie diese Tastaturbefehle, um jedes Element der Seite "Groß" mit nur einem Operanden einzugeben. Wählen Sie dann nach Bedarf die Befehle "Neuer Operand" und "Format umschalten".

Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
 | Strg+Umschalttaste+s | \sum
 | Strg+Umschalttaste+p | \prod
 | Strg+i | \int
 | Strg+Umschalttaste+i | \oint
 | Strg+m Umschalttaste+i | \bigcap
 | Strg+m Umschalttaste+u | \bigcup
Neuer Operand | Strg+Umschalttaste+n, Esc m n |
Format umschalten | Strg+Umschalttaste+t, Esc m Umschalttaste+t |


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Seite "Klammern"

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
( ? ) | ( | \id
[ ? ] | [ (linke eckige Klammer) |
? } | { (linke geschweifte Klammer) |
? | | | (senkrechter Strich) | \substitution
< ? > | Strg+m < | \dangle
|?| | Strg+g | (senkrechter Strich) | \abs
( ? | Strg+m ( | \lparen
[ ? | Strg+m [ (linke eckige Klammer) |
{ ? | Strg+m { (linke geschweifte Klammer) |
? | | | (senkrechter Strich) (und Operand hinzufügen) |
|? > | Strg+m k | \ket
||?|| | Strg+m | (senkrechter Strich) | \norm
? ) | ) | \rparen
? ] | ] (rechte eckige Klammer) |
? } | } (rechte geschweifte Klammer) |
? | | | (senkrechter Strich) (und zwei Operanden hinzufügen) |
< ? | | Strg+m b | \bra
 | Strg+q i | \ceil
( ?, ? ) | Strg+m Umschalttaste+n | \inprod
[ ?, ? ] | Strg+m Umschalttaste+c | \cmut
{ ?, ? } | Strg+m Umschalttaste+a | \acmut
? | _ (unterstreichen) | \overline
< ? | ?> | Strg+m Umschalttaste+b | \bket
 | Strg+q k | \floor
( [image] ) | Strg+m h | \choice
} ? | Strg+m Umschalttaste+d | \downbrace
? | Strg+m Umschalttastet+p | \upbrace
Format umschalten | Strg+Umschalttaste+t, Esc m Umschalttaste+t |
Klammern entfernen | Esc m r p |


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Seite "Relationen"

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Element | Tastaturbefehl | Eingabe im Dialogfenster
? < ? | < | \lessthan
? > ? | > | \greaterthan
? = ? | = | \equal
? ~ ? | Strg+m ~ (Tilde) | \sim
? ? | Strg+q Umschalttaste+l (kleines L) | \subset
? ? | Strg+q Umschalttaste+i | \supset
? ? | Strg+q Komma | \leftarrow
? ? | Strg+q Punkt | \rightarrow
? ? | Strg+q Plus | \lrarrow
? ? | Strg+m r | \perp
? ? | Strg+g < | \leq
? ? | Strg+g > | \geq
? ? | Strg+q : (Doppelpunkt) | \equiv
? ? | Strg+q ; (Semikolon) | \approx
? ? | Strg+q Umschalttaste+j | \subseteq
? ? | Strg+q Umschalttaste+m | \supseteq
? ? | Strg+q \ | \Leftarrow
? ? | Strg+q ^ | \Rightarrow
? ? | Strg+q [ (linke eckige Klammer) | \LRarrow
? ? | Strg+m p | \parallel
? ? | Strg+q l (kleines L) | \ll
? ? | Strg+q g | \gg
? ? | Strg+q = | \notequal
? ? | @ | \cong
? ? | Strg+q Umschalttaste+n | \in
? ? | Strg+' | \ni
? ? | Strg+q Umschalttaste+o |
= ? | Strg+g = | \uequal
? ? | Strg+q Umschalttaste+k | \notsubset
? ? | Strg+q 5 | \propto


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Seite "Analysis"

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.
Verwenden Sie diese Tastaturbefehle, um jedes Element der Seite "Groß" mit nur einem Operanden einzugeben. Wählen Sie dann nach Bedarf die Befehle "Neuer Operand" und "Format umschalten".

Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
? | Strg+i | \int
 | Strg+Umschalttaste+i | \oint
Neuer Operand | Strg+Umschalttaste+n, Esc m n |
Format umschalten | Strg+Umschalttaste+t, Esc m Umschalttaste+t |
d d ? | Strg+g t | \optotal
d d ? | Strg+g Umschalttaste+t |
¹ ¹? | Strg+g p | \oppartial
¹ ¹? | Strg+g Umschalttaste+p |
d d ? | Strg+g t (und Operand hinzufügen) |
d d ? | Strg+g Umschalttaste+t (und Operand hinzufügen) |
¹ ¹? | Strg+g p (und Operand hinzufügen) |
¹ ¹? | Strg+g Umschalttaste+p (und Operand hinzufügen) |
? | Strg+Alt+d | \var
? | Strg+q Umschalttaste+q | \grad
d ? | Strg+d | \diff
? | Strg+m c | \curl
? | Strg+Umschalttaste+d | \partial
? | Strg+m v | \diver
? | Strg+Umschalttaste+l (L) | \lim
? | Strg+m l (kleines L) | \lap


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Seite "Matrizen"

Um eine Matrix beliebiger Größe einzufügen, fügen Sie zunächst eine 1 x 1-Matrix ein. Fügen Sie dann Reihen und Spalten einzeln hinzu.

Befehl | Tastaturbefehl
Klammern hinzufügen/entfernen | Strg+Umschalttaste+t

Aufklappmenü "Matrix-Befehle"

Befehl | Tastaturbefehl
1 x 1 Matrix erstellen | Esc x m
Neue Zeile | Esc x r
Neue Spalte | Esc x c, Strg+Umschalttaste+c
Matrix transponieren | Esc x t
Matrix-Algebra | Esc x a

Aufklappmenü "Höhe der Matrixzeile"

Befehl | Tastaturbefehl
Gleichmäßig/Proportional | Esc m t r

Aufklappmenü "Breite der Matrixspalte"

Befehl | Tastaturbefehl
Gleichmäßig/Proportional | Esc m t c


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Seite "Funktionen"

Um eine Funktion (außer der allgemeinen Funktion und Limes) über die Tastatur einzugeben, geben Sie ihre Bezeichnung wie angegeben ein.

Element | Tastaturbefehl | Eingabe im Dialogfenster
? ( ? ) | Strg+f | \function
? | Strg+Umschalttaste+l (L) | \lim

Aufklappmenü "Addition"

Befehl | Tastaturbefehl
Brüche addieren | Esc m a a
Geordnete Summe | Esc m a o
Umgekehrt geordnete Summe | Esc m a Umschalttaste+o

Kontextmenü "Multiplikation"

Befehl | Tastaturbefehl
Ausklammern | Esc m u f
Teilweise ausklammern | Esc m u Umschalttaste+f
Ausmultiplizieren | Esc m u m
Einmal ausmultiplizieren | Esc m u Umschalttaste+m
Verteilen | Esc m u d
Auf beiden Seiten anwenden | Esc m u Umschalttaste+d

Aufklappmenü "Division"

Befehl | Tastaturbefehl
Division mit Rest | Esc m d l (kleines L)
Division umwandeln | Esc m d d
Division Stufe 1 umwandeln | Esc m d Umschalttaste+d
Negative Potenz umwandeln | Esc m d n
Negative Potenz Stufe 1 umwandeln | Esc m d Umschalttaste+n

Aufklappmenü "Berechnung"

Befehl | Tastaturbefehl
Ausrechnen | Esc m v n
Alle Stellen zeigen | Esc m v Punkt
Berechnen | Esc m v e
Einsetzen | Esc m v s
Integrieren | Esc m v i
Ableiten | Esc m v d
1. Stufe ableiten | Esc m v Umschalttaste+d

Aufklappmenü "Regeln"

Befehl | Tastaturbefehl
Regel eingeben | Esc m r e
Regel anwenden | Esc m r a
Platzhalter festlegen | Esc m r d

Aufklappmenü "Umformungen"

Befehl | Tastaturbefehl
Vereinfachen | Esc m o s
Teilweise vereinfachen | Esc m o Umschalttaste+s
Term isolieren | Esc m o i
1. Term herausziehen | Esc m o e
Alle Terme herausziehen | Esc m o Umschalttaste+e


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

Seite "Positionierung"

Feinpositionierung

Der in nachstehender Tabelle angegebene Punktwert basiert auf einer Zoom-Einstellung von 100 Prozent.

Funktion | Tastaturbefehl
Um 1 pt nach oben verschieben | Alt+Nach-Oben-Taste
Um 1 pt nach unten verschieben | Alt+Nach-Unten-Taste
Um 1 pt nach links verschieben | Alt+Nach-Links-Taste
Um 1 pt nach rechts verschieben | Alt+Nach-Rechts-Taste
Um 6 pt nach oben verschieben | Alt+Umschalttaste+Nach-Oben-Taste
Um 6 pt nach unten verschieben | Alt+Umschalttaste+Nach-Unten-Taste
Um 6 pt nach links verschieben | Alt+Umschalttaste+Nach-Links-Taste
Um 6 pt nach rechts verschieben | Alt+Umschalttaste+Nach-Rechts-Taste
Feinpositionierung entfernen | Alt+Pos 1

Aufklappmenü "Links/Rechts" (Ausrichtung)

Befehl | Tastaturbefehl
Links | Esc m a l (kleines L)
Zentriert | Esc m a c
Rechts | Esc m a r
Links von = | Esc m a Plus
Rechts von = | Esc m a =
Manuell einstellen | Esc m a s
Manuell löschen | Esc m a d
Ausrichtung zurücksetzen | Esc m a Umschalttaste+r

Aufklappmenü "Oben/Unten" (Ausrichtung)

Befehl | Tastaturbefehl
Oben | Esc m a t
Grundlinie | Esc m a Umschalttaste+b
Unten | Esc m a b

Aufklappmenü "Zeilenumbruch"

Befehl | Tastaturbefehl
Manuell einstellen | Esc m b s
Manuell löschen | Esc m b c


Tastaturbefehle / Tastaturbefehle für Windows / Gleichungen

In Gleichungen navigieren

Bewegen der Einfügemarke

Bewegung nach | Tastaturbefehl
Links | Nach-Links-Taste
Rechts | Nach-Rechts-Taste
Von der Seite eines Bruchs zum Zähler | Nach-Unten-Taste

Ändern der Auswahl

Funktion | Tastaturbefehl
Nächste Eingabeaufforderung auswählen | Tabulator
Auswahl erweitern | Leertaste
Nächstes Element links auswählen | Nach-Links-Taste
Nächstes Element rechts auswählen | Nach-Rechts-Taste

Bewegen von FrameMath-Elementen unter Beibehaltung der algebraischen Äquivalenz

Bewegung nach | Tastaturbefehl
Links | Umschalttaste+Nach-Links-Taste
Rechts | Umschalttaste+Nach-Rechts-Taste
Oben | Umschalttaste+Nach-Oben-Taste
Unten | Umschalttaste+Nach-Unten-Taste
Ganz links | Strg+Alt+Nach-Links-Taste
Ganz rechts | Strg+Alt+Nach-Rechts-Taste
Links in Ausdruck | Strg+Umschalttaste+Nach-Links-Taste
Rechts in Ausdruck | Strg+Umschalttaste+Nach-Rechts-Taste

Bewegen von FrameMath-Elementen ohne Beibehaltung der algebraischen Äquivalenz

Vertauschen | Tastaturbefehl
Mit Element links | Strg+m Strg+Nach-Links-Taste
Mit Element rechts | Strg+m Strg+Nach-Rechts-Taste


Tastaturbefehle / Tastaturbefehle für Windows / Tabellen

In Tabellen auswählen

Auswahl | Tastaturbefehl
Eine Zelle | Drücken Sie Strg und klicken Sie auf die Zelle.
Eine Reihe | Drücken Sie Strg und doppelklicken Sie auf die vertikale Spaltenbegrenzung in der Reihe.
Eine Spalte | Drücken Sie Strg und doppelklicken Sie auf die horizontale Reihenbegrenzung in der Spalte.
Gesamter Text in aktueller Zelle | Esc t h a
Aktuelle Zelle, dann folgende Zelle | Esc t h z
Aktuelle Reihe, dann folgende Reihe | Esc t h r
Aktuelle Spalte, dann folgende Spalte | Esc t h s
Standardzellen in aktueller Spalte, dann folgende Standardzellen | Esc t h Umschalttaste+s
Aktuelle Tabelle | Esc t h t, oder drücken Sie Strg und klicken Sie dreimal auf eine Zelle.
Die Auswahl erweitern oder verkleinern | Drücken Sie Strg+-Umschalttaste und klicken Sie auf die letzte gewünschte Zelle der Auswahl.


Tastaturbefehle / Tastaturbefehle für Windows / Tabellen

In Tabellen bewegen

Verwenden Sie diese Tastaturbefehle, um zur angegebenen Zelle zu wechseln.

Bewegen zu | Tastaturbefehl
Zelle rechts | Esc t g r
Zelle links | Esc t g l (kleines L)
Zelle unten | Esc t g Umschalttaste+h
Zelle oben | Esc t g h
Zelle ganz rechts in der aktuellen Reihe | Esc t g e
Zelle ganz links in der aktuellen Reihe | Esc t g b
Zelle ganz oben in der aktuellen Spalte | Esc t g o
Zelle ganz unten in der aktuellen Spalte | Esc t g u
Ausgewählte Zelle oben links | Esc t g a, Esc t h l (kleines L)
Zelle oben links | Esc t g Null
Anfang der Zelle | Strg+Bild-Auf
Ende einer Zelle | Strg+Bild-Ab
Nächste Zelle und deren Text auswählen | Tabulator, Esc t g Umschalttaste+r
Vorherige Zelle und deren Text auswählen | Umschalttaste+Tabulator, Esc t g Umschalttaste+l (kleines L)
Zelle unten und deren Text auswählen | Strg+Alt+Tabulator
Zelle oben und deren Text auswählen | Strg+Alt+Umschalttaste+Tabulator
Verankerungspunkt einer Tabelle | Esc t w


Tastaturbefehle / Tastaturbefehle für Windows / Tabellen

Tabulatorzeichen in Zellen

Funktion | Tastaturbefehl
Tabulatorzeichen in eine Zelle eingeben | Esc Tabulator


Tastaturbefehle / Tastaturbefehle für Windows / Tabellen

Reihen und Spalten bearbeiten

FrameMaker fügt so viele Reihen oder Spalten hinzu, wie aktuell ausgewählt sind, bzw. löscht diese Anzahl.

Funktion | Tastaturbefehl
Reihen oberhalb der ersten ausgewählten Reihe hinzufügen | Esc t Plus o
Reihen unterhalb der letzten ausgewählten Reihe hinzufügen | Esc t Plus u, Strg+Eingabe, Strg+j
Spalten links neben der ganz links ausgewählten Spalte hinzufügen | Esc t Plus l (kleines L)
Spalten rechts neben der ganz rechts ausgewählten Spalte hinzufügen | Esc t Plus r
Inhalt der ausgewählten Reihen oder Spalten löschen unter Beibehaltung der Zellen in der Tabelle | Esc t Bindestrich t
Ausgewählte Reihen oder Spalten aus der Tabelle löschen | Esc t Bindestrich z
Reihen und Spalten sortieren | Esc t s


Tastaturbefehle / Tastaturbefehle für Windows / Tabellen

Reihen und Spalten ersetzen

Wenn die Zwischenablage keine ganzen Reihen oder Spalten enthält, werden mit folgenden Tastaturbefehlen stets die ausgewählten Zellen ersetzt.

Ganze Reihen oder Spalten einsetzen | Tastaturbefehl
Durch Ersetzen der ausgewählten Reihen oder Spalten | Esc t Umschalttaste+e e
Vor der aktuellen Auswahl (oberhalb der ersten ausgewählten Reihe bzw. links neben der ganz links ausgewählten Spalte) | Esc t Umschalttaste+e v
Nach der aktuellen Auswahl (unterhalb der letzten ausgewählten Reihe bzw. rechts neben der ganz rechts ausgewählten Spalte) | Esc t Umschalttaste+e n


Tastaturbefehle / Tastaturbefehle für Windows / Tabellen

Vertikale Ausrichtung in Zellen

Zur Verwendung dieser Tastaturbefehle klicken Sie in den ersten Absatz einer Zelle.

Gewünschte Ausrichtung | Tastaturbefehl
Oben | Esc Umschalttaste+a Umschalttaste+o, Strg+F1
Mitte | Esc Umschalttaste+a Umschalttaste+m, Strg+F2
Unten | Esc Umschalttaste+a Umschalttaste+u, Strg+F3


Tastaturbefehle / Tastaturbefehle für Windows / Tabellen

Spaltenbreite

Ändern | Tastaturbefehl
Spaltenbreite, sodass keine Absätze in ausgewählten Zellen umgebrochen werden | Esc t x
Breite der ausgewählten Spalte, ohne die Breite der Tabelle zu ändern | Alt drücken und den Auswahlpunkt der gewählten Zelle ziehen


Tastaturbefehle / Tastaturbefehle für Windows / Tabellen

Tabellengestaltung

Zur Verwendung dieser Tastaturbefehle klicken Sie auf "Tabellengestaltung"

Funktion | Tastaturbefehl
Alle Einstellungen zu "Beibehalten" ändern | Umschalttaste+F8
Alle Einstellungen entsprechend der ausgewählten Tabelle ändern | Umschalttaste+F9
Vorherige Seite mit Einstellungen anzeigen | Bild-Auf
Nächste Seite mit Einstellungen anzeigen | Bild-Ab
Nur die aktuelle Einstellungsgruppe anwenden | Drücken Sie Strg und klicken Sie auf "Zuweisen".


Tastaturbefehle / Tastaturbefehle für Windows / Tabellen

Tabellenformate

Funktion | Tastaturbefehl
Format der aktuellen Tabelle dem Katalog und allen Tabellen desselben Typs zuweisen | Esc t Umschalttaste+f v
Öffnen des Dialogfensters "Lineaturstil ändern" | Esc t Umschalttaste+l (kleines L)


Tastaturbefehle / Tastaturbefehle für Windows / Text

Einfügemarke bewegen

Verwenden Sie diese Tastaturbefehle, um die Einfügemarke zu bewegen.

Wechseln zu | Tastaturbefehl
Nächstes Zeichen | Nach-Rechts-Taste
Vorheriges Zeichen | Nach-Links-Taste
Anfang eines Wortes | Strg+Nach-Links-Taste
Ende eines Wortes | Strg+Nach-Rechts-Taste
Anfang des nächsten Wortes | Esc Umschalttaste+m w
Anfang einer Zeile | Pos 1
Ende einer Zeile | Ende
Vorherige Zeile | Nach-Oben-Taste
Nächste Zeile | Nach-Unten-Taste
Anfang eines Satzes | Strg+Pos 1
Ende eines Satzes | Strg+Ende
Anfang des nächsten Satzes | Esc Umschalttaste+m s
Anfang eines Absatzes | Strg+Nach-Oben-Taste
Ende des aktuellen Absatzes | Strg+Nach-Unten-Taste
Anfang des nächsten Absatzes | Esc Umschalttaste+m a
Anfang einer Spalte | Strg+Bild-Auf
Ende einer Spalte | Strg+Bild-Ab
Anfang eines Textflusses | Alt+Umschalttaste+Bild-Auf-Taste
Ende eines Textflusses | Alt+Umschalttaste+Bild-Ab-Taste
Beginn des ersten sichtbaren Textflusses | Strg+Umschalttaste+i


Tastaturbefehle / Tastaturbefehle für Windows / Text

Einfügemarke setzen

Verwenden Sie diese Tastaturbefehle, um die Einfügemarke in einen nicht gedrehten Textrahmen auf der aktuellen Seite zu setzen. Die Zeichenreihenfolge ist die Reihenfolge, in der FrameMaker Objekte auf einer Seite anzeigt. Das erste Objekt in der Zeichenreihenfolge ist das Objekt, das sich ganz im Hintergrund befindet.

Einfügemarke setzen an | Tastaturbefehl
Erste Spalte des ersten Textrahmens in Zeichenreihenfolge | Esc Umschalttaste+m e
Nächste Spalte, wobei die Textrahmen in Zeichenreihenfolge überschritten werden | Esc Umschalttaste+m n


Tastaturbefehle / Tastaturbefehle für Windows / Text

Textauswahl

Klicken Sie in den Text, bevor Sie diese Tastaturbefehle benutzen. Wird ein Befehl auf einen bereits ausgewählten Text angewendet, erweitert FrameMaker die Auswahl.

Auswahl | Tastaturbefehl
Nächstes Zeichen | Esc h z, Esc Umschalttaste+h z, Umschalttaste+Nach-Rechts-Taste
Vorheriges Zeichen | Esc Umschalttaste+h Umschalttaste+c, Umschalttaste+Nach-Links-Taste
Aktuelles Wort, dann nächstes Wort | Esc h w, Esc Umschalttaste+h w, Strg+Umschalttaste+Nach-Rechts-Taste
Aktuelles Wort, dann vorheriges Wort | Esc Umschalttaste+h Umschalttaste+w, Strg+Umschalttaste+Nach-Links-Taste
Aktueller Satz, dann nächster Satz | Esc h s, Esc Umschalttaste+h s, Strg+Umschalttaste+Ende
Aktueller Satz, dann vorheriger Satz | Esc Umschalttaste+h Umschalttaste+s, Strg+Umschalttaste+Pos 1
Aktuelle Zeile, dann nächste Zeile | Esc Umschalttaste+h l (kleines L) Esc h Umschalttaste+z, Umschalttaste+Ende
Aktuelle Zeile, dann vorherige Zeile | Esc Umschalttaste+h Umschalttaste+l (L), Umschalttaste+Pos 1
Aktueller Absatz, dann nächster Absatz | Esc h a, Esc Umschalttaste+h a, Strg+Umschalttaste+Nach-Unten-Taste
Aktueller Absatz, dann vorheriger Absatz | Esc Umschalttaste+h Umschalttaste+a, Strg+Umschalttaste+Nach-Oben-Taste
Eine Zeilenlänge ab der Einfügemarke | Esc h u, Umschalttaste+Nach-Unten-Taste
Eine Zeilenlänge bis zur Einfügemarke | Esc h o, Umschalttaste+Nach-Oben-Taste
Bis Spaltenanfang | Esc h b, Umschalttaste+Bild-Auf
Bis Spaltenende | Esc h e, Umschalttaste+Bild-Ab
Bis Textflussbeginn | Esc h Umschalttaste+b, Strg+Umschalttaste+Bild-Auf
Bis Textflussende | Esc h Umschalttaste+e, Strg+Umschalttaste+Bild-Ab
Gesamter Text um die Einfügemarke, der dasselbe Zeichenformat aufweist | Esc Umschalttaste+h f
Ein Zeichen nach rechts | Esc h r
Ein Zeichen nach links | Esc h l (kleines L)
Die Textauswahl erweitern oder verkleinern | Drücken Sie die Umschalttaste und klicken Sie an die Stelle, an der die Auswahl beginnen oder enden soll.
Hervorhebung entfernen | Esc h Null
Ein Wort auswählen | Auf das Wort doppelklicken
Ein Wort auswählen, dann folgende Wörter | Doppelklicken Sie auf das Wort, und ziehen Sie anschließend den Mauszeiger.
Die Auswahl eines Textrahmens oder einer Textzeile aufheben und die Einfügemarke darin platzieren | Doppelklicken Sie in den Textrahmen oder in die Textzeile.


Tastaturbefehle / Tastaturbefehle für Windows / Text

Text bearbeiten

Funktion | Tastaturbefehl
Einen Absatz auswählen | Klicken Sie dreimal in den Absatz.
Einen Absatz auswählen, dann die folgenden Absätze | Klicken Sie dreimal auf den Absatz und ziehen Sie anschließend den Mauszeiger.
Zeichen vertauschen | Strg+F9
Ausschneiden | Esc b a, Strg+x, Umschalttaste+Entf
Kopieren | Esc b k, Strg+c, Strg+Einfg
Ausgeschnittenen oder kopierten Text einfügen | Esc b e, Umschalttaste+Einfg, Strg+v, Strg+y
Text schnell kopieren | Klicken Sie auf die Stelle, an der Sie den Text einfügen möchten. Drücken Sie anschließend Alt, und ziehen Sie mit dem Zeiger über den Text, den Sie kopieren möchten.


Tastaturbefehle / Tastaturbefehle für Windows / Text

Text in asiatischen Schriften

Funktion | Tastaturbefehl
Rubi-Text eingeben | Esc s r
Dialogfenster "Rubi-Einstellungen" anzeigen | Esc Umschalttaste+o Umschalttaste+r
Eine kombinierte Schrift aus lateinischen und asiatischen Zeichen definieren (nur auf asiatischen Betriebssystemen verfügbar) | Esc o c o


Tastaturbefehle / Tastaturbefehle für Windows / Text

Text löschen

Löschen | Tastaturbefehl
Vorheriges Zeichen | Strg+h, Rücktaste
Bis zum Anfang des vorherigen Wortes | Strg+Rücktaste
Bis zum Ende des vorherigen Satzes | Esc l (kleines L) r
Nächstes Zeichen | Entf
Bis zum Ende eines Wortes | Esc l (kleines L) e, Strg+Entf
Bis zum Ende einer Zeile | Strg+Umschalttaste+Entf
Bis zum Anfang des nächsten Satzes | Esc l (kleines L) v


Tastaturbefehle / Tastaturbefehle für Windows / Text

Groß-/Kleinschreibung

Verwenden Sie diese Tastaturbefehle, um die Groß-/Kleinschreibung des ausgewählten Textes zu ändern.

Funktion | Tastaturbefehl
Aktuelles Wort zu Kleinbuchstaben ändern | Strg+Alt+l (kleines L), Strg+Alt+Umschalttaste+l (L)
Aktuelles Wort zu Versalien ändern | Strg+Alt+u, Strg+Alt+Umschalttaste+u
Aktuelles Wort mit großen Anfangsbuchstaben schreiben | Strg+Alt+c
Dialogfenster "Groß-/Kleinschreibung" anzeigen | Esc b Umschalttaste+g


Tastaturbefehle / Tastaturbefehle für Windows / Textformatierung

Zeichen- und Absatzgestaltung

Funktion | Tastaturbefehl
Alle Einstellungen zu "Beibehalten" ändern | Umschalttaste+F8
Alle Einstellungen an ausgewählten Text anpassen | Umschalttaste+F9
Vorherige Einstellungsgruppe anzeigen | Bild-Auf
Nächste Einstellungsgruppe anzeigen | Bild-Ab
Nur die aktuelle Einstellungsgruppe anwenden | Drücken Sie Strg und klicken Sie auf "Zuweisen".


Tastaturbefehle / Tastaturbefehle für Windows / Textformatierung

Absatzformate

Verwenden Sie diese Tastaturbefehle, um ausgewählte Absätze oder den Absatz mit der Einfügemarke zu formatieren.

Funktion | Tastaturbefehl
Ein Absatzformat durch Eingabe der ersten Buchstaben seines Typs und Drücken der Eingabetaste zuweisen | Esc k a, F9, Strg+9
Absatz zentrieren | Esc p a Umschalttaste+z
Absatz linksbündig ausrichten | Esc p a l (kleines L)
Absatz rechtsbündig ausrichten | Esc p a Umschalttaste+r
Absatz in Blocksatz ausrichten (links- und rechtsbündig) | Esc p a b
Aktuellen Absatz in der Spalte platzieren und alle Verbindungs- und Zwischenformate entfernen | Esc p p s
Aktuellen Absatz in eine Zwischenüberschrift ändern | Esc p p t
Aktuellen Absatz in eine seitliche Überschrift ändern | Esc Umschalttaste+a p Umschalttaste+s
Aktueller Absatz verbindet alle Spalten | Esc Umschalttaste+a p Umschalttaste+v
Aktueller Absatz verbindet den Seitenüberschriftsbereich und die Spalten | Esc Umschalttaste+a u Umschalttaste+v
Einfachen Zeilenabstand zuweisen | Esc j Umschalttaste+p eins
1,5-fachen Zeilenabstand zuweisen | Esc j p / (Schrägstrich)
Doppelten Zeilenabstand zuweisen | Esc Umschalttaste+a 2
Festen Zeilenabstand zuweisen (Standardschriftgrad plus Durchschuss) | Esc Umschalttaste+a r
Variablen Zeilenabstand zuweisen (größter Schriftgrad plus Durchschuss) | Esc Umschalttaste+a v
Zeilenabstand um 1 pt erhöhen | Esc p Umschalttaste+p Plus, Esc Plus z
Zeilenabstand um 1 pt verringern | Esc p Umschalttaste+p Minus, Esc Minus z
Absätze des aktuellen Absatztyps und die Definition des Absatzformat-Katalogs an das aktuelle Absatzformat anpassen (vereinheitlichen) | Esc Umschalttaste+a Umschalttaste+a
Absatzbeginn an beliebiger Stelle | Esc Umschalttaste+a b b
Absatzbeginn am Spaltenanfang | Esc Umschalttaste+a b Umschalttaste+s
Absatzbeginn am Seitenanfang | Esc Umschalttaste+a b s
Absatzbeginn am Anfang einer linken Seite | Esc Umschalttaste+a b l (kleines L)
Absatzbeginn am Anfang einer rechten Seite | Esc Umschalttaste+a b r
Silbentrennung aktivieren | Esc Umschalttaste+a t
Silbentrennung deaktivieren | Esc Umschalttaste+a Umschalttaste+t
Letzten absatzbezogenen Befehl wiederholen | Esc Umschalttaste+a Umschalttaste+w
Absatzformat-Katalog anzeigen | Esc p a Umschalttaste+k
Dialogfenster "Absatzformat aktualisieren" anzeigen | Esc Umschalttaste+a k
Dialogfenster "Abstand zwischen Absätzen" anzeigen | Esc Umschalttaste+a a
Dialogfenster "Zeilenabstände" anzeigen | Esc Umschalttaste+a s


Tastaturbefehle / Tastaturbefehle für Windows / Textformatierung

Zeichenformate

Verwenden Sie diese Tastaturbefehle, um das Zeichenformat von ausgewähltem Text oder Text, den Sie gleich eingeben möchten, zu ändern.

Funktion | Tastaturbefehl
Ein Zeichenformat durch Eingabe der ersten Buchstaben seines Typs und Drücken der Eingabetaste zuweisen | Esc k z, F8, Strg+8
Text zu Absatzstandardschrift ändern, Zeichentyp aus Text in einer Textzeile entfernen | Esc Umschalttaste+s z
Fettschrift aktivieren oder deaktivieren | Esc z f, F4, Strg+b, Strg+Umschalttaste+b
Kursivschrift aktivieren oder deaktivieren | Esc z k, F5, Strg+i
Unterstreichung aktivieren oder deaktivieren | Esc z u, F3, Strg+u, Strg+Umschalttaste+u
Doppelte Unterstreichung aktivieren oder deaktivieren | Esc z 2
Numerische Unterstreichung aktivieren oder deaktivieren | Esc z eins
Durchstreichen aktivieren oder deaktivieren | Esc z d, Strg+/
Überstreichung aktivieren oder deaktivieren | Esc z Umschalttaste+u, Umschalttaste+F3
Text in Standardtext ändern | Esc z n, F2
Hochgestellt aktivieren oder deaktivieren | Esc z h
Tiefgestellt aktivieren oder deaktivieren | Esc z t
Text auf Grundlinie platzieren | Esc z g
Text zu Kapitälchen ändern | Esc z p, Strg+e
Änderungsbalken aktivieren oder deaktivieren | Esc z b, Strg+Umschalttaste+h
Unterschneiden aktivieren oder deaktivieren | Esc z a
Text um 1 Punkt in angegebene Richtung manuell unterschneiden (bei Zoom-Einstellung 100 Prozent) | Alt+Pfeiltaste
Text um 6 Punkt in angegebene Richtung manuell unterschneiden (bei Zoom-Einstellung 100 Prozent) | Alt+Umschalttaste+Pfeiltaste
Alle manuellen Unterschneidungen entfernen | Alt+Pos 1
Größe um 1 pt erhöhen | Esc z Plus
Größe um 1 pt verringern | Esc z Minus
Um 20 % eines m-Leerzeichens verkleinern | Esc z Nach-Links-Taste
Um 20 % eines m-Leerzeichens vergrößern | Esc z Nach-Rechts-Taste
Schriftstreckung auf 100 % setzen | Esc [ (linke eckige Klammer) n
Schriftstreckung um 5 % verringern | Esc [ (linke eckige Klammer) c
Schriftstreckung um 5 % vergrößern | Esc [ (linke eckige Klammer) e
Letzten schriftbezogenen Befehl wiederholen | Esc z w
Tsume ein/aus (nur Japanisch) | Esc c t
Zeigt den Zeichenformat-Katalog an | Esc z Umschalttaste+k


Tastaturbefehle / Tastaturbefehle für Windows

Arbeiten mit Struktur

Einfügemarke positionieren | Tastenkombination
An den Anfang des aktuellen Elements | Esc Umschalttaste+m l (kleines L) b
An das Ende des aktuellen Elements | Esc Umschalttaste+m l (kleines L) e
Nach dem nächsten Element | Esc Umschalttaste+m l (kleines L) d, Alt+Strg+Nach-Unten-Taste
Vor dem vorherigen Element | Esc Umschalttaste+m l (kleines L) u, Alt+Strg+Nach-Oben-Taste
Vor dem übergeordneten Element des aktuellen Elements | Esc Umschalttaste+m l (kleines L) v, Alt+Strg+Nach-Links-Taste
An den Anfang der Inhalte des nächsten Elements | Esc Umschalttaste+m b n, Alt+Strg+Nach-Rechts-Taste
Auswahl | Tastenkombination
Aktuelles Element | Esc Umschalttaste+h Umschalttaste+e
Nächstes Element | Esc Umschalttaste+h Umschalttaste+ n, Alt+Strg+Umschalttaste+Nach-Unten-Taste
Vorheriges Element | Esc Umschalttaste+h Umschalttaste+ v, Alt+Strg+Umschalttaste+Nach-Oben-Taste
Gleichrangige Elemente des aktuellen Elements | Esc h Umschalttaste+s
Übergeordnete Elemente des aktuellen Elements | Esc h Umschalttaste+p, Alt+Strg+Umschalttaste+Nach-Links-Taste
Auswahl erweitern | Tastenkombination
Um ein Element nach oben | Alt+Strg+Umschalttaste+Nach-Oben-Taste
Um ein Element nach unten | Alt+Strg+Umschalttaste+Nach-Unten-Taste
Funktion | Tastenkombination
Übergeordnetes Element aufnehmen | Alt+Strg+Umschalttaste+Nach-Links-Taste
Element einfügen | Esc e e e, Strg+1 (eins)
Element eingliedern | Esc e e I, Strg+2
Element ausgliedern | Esc e e f
Element ändern | Esc e e a, Strg+3
In erstes Element einlesen | Esc e v eins
In letztes Element einlesen | Esc Umschalttaste+e Umschalttaste+m
Element um eine Ebene nach oben bewegen | Esc Umschalttaste+e Umschalttaste+p
Element um eine Ebene nach unten bewegen | Esc Umschalttaste+e Umschalttaste+d
Element mit dem vorherigen Element vertauschen | Esc Umschalttaste+e Umschalttaste+t
Funktion | Tastenkombination
Element mit dem nächsten Element vertauschen | Esc Umschalttaste+e t
Element teilen | Esc e e t
Attributwert bearbeiten | Strg+7
Letzten auf den Elementkatalog bezogenen Befehl wiederholen | Esc e e w
Anzeige von Elementgrenzen (als eckige Klammern) ein/aus | Esc Umschalttaste+d Umschalttaste+e
Anzeige von Elementgrenzen (als Typen) ein/aus | Esc Umschalttaste+d e t
Dokument prüfen | Esc e e p
Strukturansicht anzeigen | Esc Umschalttaste+s Umschalttaste+a


Tastaturbefehle

Tastaturbefehle für UNIX

Anleitungen für Tastaturbefehle:

    + gibt an, dass alle angegebenen Tasten gleichzeitig gedrückt werden müssen (z. B. bedeutet Control+z, dass die Control-Taste zusammen mit der z-Taste gedrückt werden muss). Wenn die Tastaturbefehle kein Pluszeichen (Umschalttaste +) enthalten, drücken Sie die einzelnen Tasten in der angegebenen Reihenfolge (bei Esc m p drücken Sie z. B. zuerst Esc (Escape), lassen die Taste los, drücken dann m und anschließend p).

Durchblättern von Dokumenten

Zeichenwerkzeuge

Suchen und Ändern

Textbearbeitung

Arbeiten mit Tabellen

Eingabe von Sonderzeichen

Objektauswahl

Funktionstasten

Zeichen- und Absatzgestaltung

Andere nützliche Tastaturbefehle

Konventionen und Funktionstasten

Farbe

Farbauszüge

Fenster und Dialogfenster

Dokumentgestaltung

Dokumente

Dokumentdienstprogramme

Grafiken

Marken und Variablen

Filter nach Attribut

Verfolgen von Textänderungen

Bedingten Text anzeigen

Fenster "Bedingter Text"

Bedingungstyp-Einstellungen

Gleichungen

Tastaturbefehle für Hewlett-Packard

Sun-Tastaturbefehle

IBM-Tastaturbefehle

Tabellen

In Tabellen bewegen

Tabulatorzeichen in Zellen

Reihen und Spalten bearbeiten

Reihen und Spalten ersetzen

Vertikale Ausrichtung in Zellen

Spaltenbreite

Tabellengestaltung

Tabellenformate

Strukturierungswerkzeuge

Einfügemarke bewegen

Einfügemarke setzen

Textauswahl

Text bearbeiten

Text in asiatischen Schriften

Text löschen

Groß-/Kleinschreibung

Zeichen- und Absatzgestaltung

Absatzformate

Zeichenformate


Tastaturbefehle / Tastaturbefehle für UNIX

Durchblättern von Dokumenten

Anzeige | Tastenkombination
Vorherige Seite | Esc s Umschalttaste+v, F6
Nächste Seite | Esc s Umschalttaste+n, F7, Control+v
Erste Seite | Esc s Umschalttaste+e, Umschalttaste+F6 und Symbol "Vorherige Seite"
Letzte Seite | Esc s Umschalttaste+l (kleines L), Umschalttaste+F7 und Symbol "Nächste Seite"
Dialogfenster "Wechseln zu Seite" | Esc Umschalttaste+d w, Control+g
Wechseln zu | Vorgehensweise
Quelle eines Querverweises | Drücken Sie Control und klicken Sie mit der rechten Maustaste auf einen aktiven Bereich.
Einer bestimmten Seite | Drücken Sie Control+g, oder klicken Sie auf den Seitenstatus-Bereich und geben Sie die Seitenzahl ein.
Seite mit Einfügemarke | Drücken Sie Control+g, oder klicken Sie auf den Seitenstatus-Bereich und klicken Sie auf "Seite mit Einfügemarke".
Setzen der Einfügemarke im Text an den/das | Tastenkombination
Anfang des nächsten Wortes | Esc Umschalttaste+m w
Anfang des nächsten Absatzes | Esc Umschalttaste+m a


Tastaturbefehle / Tastaturbefehle für UNIX

Zeichenwerkzeuge

Werkzeug | Tastaturbefehl
Bogen | Esc o b
Grafikrahmen | Esc o Umschalttaste+r
Werkzeug | Tastaturbefehl
Freihandkurve | Esc o f
Zuletzt gewähltes Werkzeug | Esc o w
Gerade | Esc o g
Objektauswahl | Esc o o
Ellipse | Esc o e
Polygon | Esc o p
Polygonzug | Esc o l (kleines L)
Rechteck | Esc o r
Abgerundetes Rechteck | Esc o a
Intelligente Auswahl | Esc o i
Funktion | Tastaturbefehl
Textrahmen | Esc o s
Textzeile | Esc o z
Zeichenobjekt | Tastaturbefehl
Vertikale, horizontale oder diagonale Gerade | Drücken Sie die Umschalttaste und zeichnen Sie eine Gerade.
Quadrat | Drücken Sie die Umschalttaste und zeichnen Sie ein Rechteck.
Kreis | Drücken Sie die Umschalttaste und zeichnen Sie eine Ellipse.
Kreisausschnitt | Drücken Sie die Umschalttaste und zeichnen Sie einen Bogen.
Funktion | Tastaturbefehl
Werkzeugpalette anzeigen | Esc eins g, Esc g Umschalttaste+w
Werkzeug nach Verwendung aktiv lassen | Drücken Sie die Umschalttaste und klicken Sie auf ein Zeichenwerkzeug.
Nach dem Zeichnen zum Objektauswahlwerkzeug zurückkehren | Drücken Sie die Umschalttaste und klicken Sie auf das Objektauswahlwerkzeug.


Tastaturbefehle / Tastaturbefehle für UNIX / Zeichenwerkzeuge

Buchbefehle

Funktion | Vorgehensweise
Neues Buch | Esc d Umschalttaste+n
Buch sichern | Esc d s
Datei umbenennen | Esc f e
Buch aktualisieren | Esc b Umschalttaste+c, Esc b Umschalttaste+r
Datei aus dem Buch löschen | Esc f x
Dateinamen anzeigen (im Buchfenster) | Esc Umschalttaste+v Umschalttaste+m
Absatzüberschriften anzeigen (im Buchfenster) | Esc Umschalttaste+v Umschalttaste+x
Alle Dateien auswählen | Esc b g
Alle FrameMaker-Dateien auswählen | Esc b Umschalttaste+m Umschalttaste+d
Funktion | Vorgehensweise
Alle Dateien des Buchs sichern | Esc d Umschalttaste+s
Alle Dateien des Buchs schließen | Esc d Umschalttaste+v
Alle nicht generierten FrameMaker-Dateien auswählen | Esc b Umschalttaste+n Umschalttaste+g
Alle generierten FrameMaker-Dateien auswählen | Esc b Umschalttaste+e Umschalttaste+d
Einen Bereich von Dateien auswählen | Umschalttaste+Klicken
Nicht untereinander stehende Dateien auswählen | Control+Klicken
Datei in Buch nach oben bewegen | Esc m u
Datei in Buch nach unten bewegen | Esc m d
Buch drucken | Esc d d
Ausgewählte Dateien im Buch drucken | Esc d Umschalttaste+a


Tastaturbefehle / Tastaturbefehle für UNIX

Suchen und Ändern

Funktion | Tastenkombination
Vorwärts suchen | Esc f i n, Esc Umschalttaste+s Umschalttaste+v
Rückwärts suchen | Esc Umschalttaste+s Umschalttaste+r
Aktuelle Auswahl ändern | Esc Umschalttaste+e e, Control+%
Alle Vorkommen des Suchtextes im Dokument ändern | Esc Umschalttaste+e a
Ändern und weitersuchen | Esc Umschalttaste+e n
Einstellungen in Dialogfenstern "Zeichenformat suchen" und "Ändern in Zeichenformat" zu "Beibehalten" ändern | Umschalttaste+F8
Einstellungen entsprechend dem ausgewählten Text in Dialogfenstern "Zeichenformat suchen" und "Ändern in Zeichenformat" ändern | Umschalttaste+Control+F8, Umschalttaste+F9
Dialogfenster "Einstellung der Suchparameter" anzeigen | Esc Umschalttaste+s Umschalttaste+e
Suche | Eingabe
Tabulatorsymbol | \t
Zeilenende | \r
Absatzende-Zeichen | \p
Absatzbeginn | \P
Umbruchgeschütztes Leerzeichen | \ (Leertaste)
t-Leerzeichen | \i, \st
n-Leerzeichen | \Umschalttaste+n, \sn
m-Leerzeichen | \Umschalttaste_m, \sm
Numerisches Leerzeichen | \#, \s#
Textflussende-Zeichen | \f
‘ (Gravis) | \{
\ (umgekehrter Schrägstrich) | \\
Wahlweiser Trennstrich | \- (Bindestrich)
Trennunterdrückungssymbol | \_ (Unterstrich)
Suche | Eingabe
Wortanfang | \<
Wortende | \>
Mit aktivierter Option "Jokerzeichen"... |
Beliebige Anzahl von Zeichen | *
Leerzeichen oder Interpunktion | | (senkrechter Strich)
Beliebiges Zeichen | ?
Anfang einer Zeile | ^
Ende einer Zeile | $
Mit aktivierter Option "Jokerzeichen"... |
Beliebige Zeichen in eckigen Klammern ab | [ab]
Beliebiges Zeichen außer ab | [^ab]
Beliebiges Zeichen von a bis f | [a-f]


Tastaturbefehle / Tastaturbefehle für UNIX

Textbearbeitung

Funktion | Tastenkombination
Ausschneiden | Esc b a, Umschalttaste+Entf, Umschalttaste+Rücktaste, Control+w
Kopieren | Esc b k
Einfügen | Esc b e, Control+y
Löschen | Esc b l (kleines L)
Rückgängig/Erneut rückgängig | Esc b r
Auswahl | Vorgehensweise
Ein Wort | Doppelklicken Sie auf das Wort.
Ein Wort, dann folgende Wörter | Doppelklicken Sie auf das Wort und ziehen Sie den Zeiger, doppelklicken Sie und klicken Sie bei gedrückter Umschalttaste.
Aktueller Satz, dann folgender Satz | Drücken Sie Esc h s
Aktueller Satz, dann vorheriger Satz | Drücken Sie Esc Umschalttaste+h Umschalttaste+s
Ein Absatz | Klicken Sie dreimal auf den Absatz.
Ein Absatz, dann folgende Absätze | Klicken Sie dreimal auf den Absatz und ziehen Sie den Zeiger, klicken Sie dreimal und Klicken Sie bei gedrückter Umschalttaste.
Löschen | Tastenkombination
Vorheriges Zeichen | Control+h, Entf, Rücktaste
Bis zum Anfang einer Zeile | Control+u, Control+Entf
Bis zum Ende des vorherigen Satzes | Esc l (kleines L) r
Nächstes Zeichen | Control+d
Löschen | Tastenkombination
Bis zum Ende eines Wortes | Esc l (kleines L) e
Bis zum Ende einer Zeile | Control+k
Bis zum Anfang des nächsten Satzes | Esc l (kleines L) v


Tastaturbefehle / Tastaturbefehle für UNIX

Arbeiten mit Tabellen

Auswahl | Tastenkombination
Eine Zelle | Drücken Sie Control und klicken Sie auf die Zelle.
Eine Reihe | Drücken Sie Control und doppelklicken Sie auf den Spaltenrand.
Eine Spalte | Drücken Sie Control und doppelklicken Sie auf den Reihenrand.
Aktuelle Reihe | Esc t h r
Aktuelle Spalte | Esc t h s
Aktuelle Tabelle | Esc t h t
Wechseln zu | Tastenkombination
Zelle ganz rechts in aktueller Reihe | Esc t g e
Zelle ganz links in aktueller Reihe | Esc t g b
Zelle ganz oben in aktueller Spalte | Esc t g o
Zelle ganz unten in aktueller Spalte | Esc t g u
Nächste Zelle und deren Text auswählen | Tabulator, Esc t g Umschalttaste+r
Vorherige Zelle und deren Text auswählen | Umschalttaste+Tabulator, Esc t g Umschalttaste+l (kleines L)
Funktion | Tastenkombination
Tabulatorzeichen in eine Zelle eingeben | Esc Tabulator
Reihen über ausgewählter Reihe einfügen | Esc t + (Plus) o
Reihen unter ausgewählten Reihen einfügen | Esc t + (Plus) u, Control+Eingabetaste
Spalten links einfügen | Esc t + (Plus) l (kleines L)
Spalten rechts einfügen | Esc t + (Plus) r
Durch Austausch der gewählten Reihen oder Spalten einfügen | Esc t Umschalttaste+e e
Reihen oder Spalten vor der Auswahl einfügen | Esc t Umschalttaste+e v
Reihen oder Spalten hinter der Auswahl einfügen | Esc t Umschalttaste+e n
Spaltengröße ändern (ohne Absatzumbrüche in ausgewählten Zellen) | Esc t x
Größe der ausgewählten Spalten ohne Änderung der Tabellenbreite ändern | Umschalttaste gedrückt halten und Auswahlpunkt der Zelle ziehen
Spaltenbreite in Zwischenablage kopieren | Esc b Umschalttaste+b


Tastaturbefehle / Tastaturbefehle für UNIX

Eingabe von Sonderzeichen

Eingabe | Tastenkombination
(Auszeichnungspunkt) | Control+q %
(Kreuzsymbol) | Control+q Leertaste
(Doppelkreuz) | Control+q `
(Warenzeichen) | Control+q *
© (Copyright) | Control+q )
® (eingetragenes Warenzeichen) | Control+q (
¶ (Absatzsymbol) | Control+q &
§ (Paragraphsymbol) | Control+q $
… (Auslassung) | Control+q Umschalttaste+i
(m-Bindestrich) | Control+q Umschalttaste+q
(n-Bindestrich) | Control+q Umschalttaste+p
‘ | Control+'
" | Control+"
(Anführungszeichen deaktiviert) | Control+q Umschalttaste+t
(Anführungszeichen deaktiviert) | Control+q Umschalttaste+u
(Anführungszeichen deaktiviert) | Control+q Umschalttaste+r
(Anführungszeichen deaktiviert) | Control+q Umschalttaste+s
m-Leerzeichen | Esc s m
n-Leerzeichen | Esc s n
Umbruchgeschütztes Leerzeichen | Esc s z, Control+Leertaste
Numerisches Leerzeichen | Esc Leertaste 1 (eins)
t-Leerzeichen | Esc s t
Umbruchgeschützter Trennstrich | Esc Bindestrich w
Trennunterdrückungssymbol | Esc k t
Wahlweiser Trennstrich | Esc Bindestrich t, Control+Bindestrich
Zeilenende | Umschalttaste+Eingabetaste, Control+j
Akzent | Drücken Sie Esc und geben Sie Folgendes ein. | Gefolgt von einem dieser Zeichen | Beispiel
´ (Akut) | ' (Apostroph) | a, A, e, E, i, I, o, O, u, U | É, é
` (Gravis) | ` (Linkes Anführungszeichen) | a, A, e, E, i, I, o, O, u, U | È, è
(Tilde) | ~ (Tilde) | a, A, n, N, o, O | Ñ, ñ
¨ (Diäresis) | % (Prozent) | a, A, e, E, i, I, o, O, u, U, y, Y | Ü, ü
(Zirkumflex) | ^ (Caret) | a, A, e, E, i, I, o, O, u, U | Ê, ê
° (Ring) | * (Asterisk) | a, A | Å, å
¸ (Cedille) | , (Komma) | c, C | Ç, ç


Tastaturbefehle / Tastaturbefehle für UNIX

Objektauswahl

Verwenden Sie diese Tastaturbefehle, um Objekte auf der aktuellen Seite auszuwählen.

Funktion | Tastaturbefehl
Textzeile oder Textrahmen auswählen | Drücken Sie Control und klicken Sie auf eine Textzeile oder einen Textrahmen.
Die Auswahl erweitern oder verkleinern | Drücken Sie die Umschalttaste und klicken Sie auf ein Objekt.
Anzeige des Auswahlrahmens erzwingen (wenn Ziehen von außerhalb der Objekte nicht möglich ist) | Drücken Sie Control+Umschalttaste und ziehen Sie diagonal.
Das erste Objekt in der Zeichenreihenfolge auswählen | Esc o eins
Das nächste Objekt in der Zeichenreihenfolge auswählen | Esc o n
Die Auswahl auf das nächste Objekt in der Zeichenreihenfolge erweitern | Esc o Plus
Die Auswahl eines Textrahmens oder einer Textzeile aufheben und die Einfügemarke stattdessen in das Objekt setzen | Doppelklicken Sie in den Textrahmen oder in die Textzeile.


Tastaturbefehle / Tastaturbefehle für UNIX

Funktionstasten

Taste | Funktion | Control | Umschalttaste | Umschalttaste+Control
F1 | Hilfe | Info |  |
F2 | Ausgewählten Text in Standardtext umwandeln |  | Standard |
F3 | Ausgewählten Text unterstreichen |  | Unterstreichen |
F4 | Ausgewähltem Text Format "Fett" zuweisen |  | Fett |
F5 | Ausgewählten Text kursiv setzen |  | Kursiv |
F6 | Bild-Auf |  | Erste Seite |
F7 | Bild-Ab |  | Letzte Seite |
F8 | Zeichenformat durch Eingabe auswählen | Absatzformat durch Eingabe auswählen | Einstellungen im Dialogfenster zu "Beibehalten" ändern | Einstellungen an aktuellen Text anpassen
F9 | Absatzformat durch Eingabe auswählen |  | Alle Einstellungen des Dialogfensters an aktuellen Text anpassen |
F10 | Tastatureingabe in Menüleiste |  |  |


Tastaturbefehle / Tastaturbefehle für UNIX

Zeichen- und Absatzgestaltung

Funktion | Tastaturbefehl
Alle Einstellungen zu "Beibehalten" ändern | Umschalttaste+F8
Alle Einstellungen an ausgewählten Text anpassen | Control+Umschalttaste+F8, Umschalttaste+F9
Vorherige Einstellungsgruppe anzeigen | Esc s Umschalttaste+v, F6
Nächste Einstellungsgruppe anzeigen | Esc Umschalttaste+s n, F7, Control+v
Nur die aktuelle Einstellungsgruppe anwenden | Drücken Sie Control und klicken Sie auf "Zuweisen".


Tastaturbefehle / Tastaturbefehle für UNIX

Andere nützliche Tastaturbefehle

Funktion | Tastenkombination
Die Dokumentanzeige neu aufbauen | Control+l (kleines L)
Ein ausgewähltes Objekt schnell kopieren | Drücken Sie Control und ziehen Sie das Objekt mit der mittleren Maustaste.
Ein Objekt willkürlich drehen | Drücken Sie Control und ziehen Sie mit der rechten Maustaste eine Ecke oder einen Umformpunkt.
Ein Objekt entlang der vertikalen oder horizontalen Achse verschieben | Bei gedrückter Umschalttaste Objekt ziehen
Ein Objekt um 1 Punkt/6 Punkt verschieben | Control+Pfeiltaste/Umschalttaste+Control+Pfeiltaste
Seite an Fenster anpassen | Esc Umschalttaste+z Umschalttaste+s
Fenster an Seite anpassen | Esc Umschalttaste+z Umschalttaste+f
Zoomen auf 100 % | Esc Umschalttaste+z Umschalttaste+o
Ein Dokument oder Buch sperren oder entsperren | Esc d Umschalttaste+y


Tastaturbefehle / Tastaturbefehle für UNIX / Konventionen und Funktionstasten

Tasten

Bei der Verwendung von Tastaturbefehlen muss die Feststelltaste ausgeschaltet sein, und der Zeiger muss sich im Dokumentfenster befinden, sofern nicht anders angegeben.

Die folgende Tabelle listet die Bezeichnungen der Sondertasten auf.

Bezeichnung | Bedeutung
Pfeiltaste | Nach-Oben-, Nach-Unten-, Nach-Rechts- oder Nach-Links-Taste
Esc | Die mit "Esc" beschriftete Taste
Control | Die mit "Control" beschriftete Taste
Umschalttaste | Die Umschalttaste
F2, L2 oder R11 | Die mit F2, L2 oder R11 beschriftete Funktionstaste. (Wenn Sie "F" gefolgt von "2" eingeben, werden die Zeichen als "F 2" angezeigt.)
Leertaste | Die Leertaste
Plus | Die mit einem Pluszeichen (+) beschriftete Taste
Minus oder Bindestrich | Die mit einem Bindestrich (-) beschriftete Taste
Punkt | Die mit einem Punkt (.) beschriftete Taste
Komma | Die mit einem Komma (,) beschriftete Taste
Null | Die mit der Ziffer 0 beschriftete Taste
Eins | Die mit der Ziffer 1 beschriftete Taste


Tastaturbefehle / Tastaturbefehle für UNIX / Konventionen und Funktionstasten

Tastaturbefehle

Die folgende Tabelle erläutert die Konventionen für die Anzeige von Tastenfolgen und Tastenkombinationen. Wenn in einer Tastenkombination ein Großbuchstabe angegeben ist, geben Sie den Buchstaben bei gedrückter Umschalttaste ein.

Wenn zwei oder mehr Tastenkombinationen dieselbe Aktion ausführen, werden die Tastenkombinationen durch ein Komma getrennt. Beispiel: Esc q v, Control+null. Sie können entweder Esc q v oder Control+null verwenden, um dieselbe Aktion auszuführen.

Tastaturbefehl | Bedeutung
Esc Umschalttaste+t e | Drücken Sie nacheinander die folgenden Tasten, und lassen Sie sie wieder los: die Esc-Taste, den Großbuchstaben T und den Buchstaben e.
Control+e | Halten Sie Control gedrückt, und geben Sie den Buchstaben e ein.
Control+Umschalttaste+F8 | Halten Sie die Control- und Umschalttaste gedrückt, und drücken Sie F8.


Tastaturbefehle / Tastaturbefehle für UNIX / Konventionen und Funktionstasten

Funktionstasten

Taste | Funktion | Control | Umschalttaste | Umschalttaste+Control
F1 | Hilfe | Info |  |
F2 | Ausgewählten Text in Standardtext umwandeln |  | Standard |
F3 | Ausgewählten Text unterstreichen |  | Unterstreichen |
F4 | Ausgewähltem Text Format "Fett" zuweisen |  | Fett |
F5 | Ausgewählten Text kursiv setzen |  | Kursiv |
F6 | Bild-Auf |  | Erste Seite |
F7 | Bild-Ab |  | Letzte Seite |
F8 | Zeichenformat durch Eingabe auswählen | Absatzformat durch Eingabe auswählen | Einstellungen im Dialogfenster zu "Beibehalten" ändern | Einstellungen an aktuellen Text anpassen
F9 | Absatzformat durch Eingabe auswählen |  | Alle Einstellungen des Dialogfensters an aktuellen Text anpassen |
F10 | Tastatureingabe in Menüleiste |  |  |


Tastaturbefehle / Tastaturbefehle für UNIX / Konventionen und Funktionstasten

Maus

Die folgende Tabelle listet die Bezeichnungen für Mausaktionen auf.

Anweisung | Bedeutung
Klicken | Drücken Sie die linke Maustaste.
Klicken mit der mittleren Maustaste | Klicken Sie bei einer Maus mit drei Tasten die mittlere Taste oder klicken Sie bei einer Maus mit zwei Tasten beide Tasten gleichzeitig.
Rechtsklicken | Drücken Sie die rechte Maustaste.
Doppelklicken | Drücken Sie die linke Maustaste zweimal schnell hintereinander, ohne die Maus zu bewegen.
Dreimal klicken | Drücken Sie die linke Maustaste dreimal schnell hintereinander, ohne die Maus zu bewegen.
Umschalttaste+Klicken | Halten Sie die Umschalttaste gedrückt und drücken Sie die linke Maustaste.


Tastaturbefehle / Tastaturbefehle für UNIX / Farbe

Farbauswahl

Funktion | Tastaturbefehl
Farbe nach Verwendung aktiv lassen | Drücken Sie die Umschalttaste und wählen Sie eine Farbe aus dem Aufklappmenü "Farbe" aus.
Eine Farbe allen Objekten in einem Dokument zuweisen, einschließlich Text | Drücken Sie Control+Umschalttaste und wählen Sie eine Farbe aus dem Aufklappmenü "Farbe" in der Werkzeugpalette aus.
Dialogfenster "Farbdefinitionen" anzeigen | Drücken Sie Esc Umschalttaste+d f d


Tastaturbefehle / Tastaturbefehle für UNIX

Farbauszüge

Funktion | Tastaturbefehl
Dialogfenster "Farbauszüge definieren" anzeigen | Drücken Sie Esc Umschalttaste+d u.
Auszugsnummer (1, 2, 3, 4, 5 oder 6) aus dem Dialogfenster "Farbauszüge definieren" wählen | Drücken Sie Esc Umschalttaste+d und geben Sie die Nummer ein.


Tastaturbefehle / Tastaturbefehle für UNIX / Farbauszüge

DITA

Auswahl | Tastaturbefehl
DITA>Neue DITA-Datei>Neues <mapi> Hinweis: | Esc Umschalttaste+n Umschalttaste+m i
DITA>Neue DITA-Datei>Neues <topici> DITA>Neue DITA-Datei>Neues <concepti> DITA>Neue DITA-Datei>Neues <taski> DITA>Neue DITA-Datei>Neues <referencei> Hinweis: | Esc Umschalttaste+n Umschalttaste+t 1 Esc Umschalttaste+n Umschalttaste+t 2 Esc Umschalttaste+n Umschalttaste+t i
DITA>Neue DITA-Datei>Menü aktualisieren | Esc Umschalttaste+r Umschalttaste+m
DITA>Conref einfügen | Esc Umschalttaste+i Umschalttaste+c
DITA>ID für Element zuweisen | Esc Umschalttaste+a Umschalttaste+i
DITA>Referenzen aktualisieren | Esc Umschalttaste+u Umschalttaste+r
DITA>Alle Topicrefs öffnen | Esc Umschalttaste+o Umschalttaste+a
DITA>Topicref einfügen | Esc Umschalttaste+i Umschalttaste+t
DITA>FM-Dokument von DITA Map erstellen | Esc Umschalttaste+g Umschalttaste+d
DITA>DITA-Optionen | Esc Umschalttaste+d Umschalttaste+o


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

Das FrameMaker-Hauptfenster

Zeigen oder klicken Sie für folgende Tastaturbefehle auf ein Dokumentfenster, oder zeigen Sie in das FrameMaker-Hauptfenster.

Auswahl | Tastaturbefehl
Neues Dokument | Esc d n
Neues Buch | Esc d Umschalttaste+n
Öffnen | Esc d o, Control+x Control+f, Control+x Control+v
Hilfe | F1, Esc d Umschalttaste+h
Info | Esc f Umschalttaste+i, Esc ? v, Control+Hilfe
Beenden | Esc d Umschalttaste+h, Control+x Control+c


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

Fenster bearbeiten

Zur Verwendung dieser Tastaturbefehle zeigen oder klicken Sie auf ein beliebiges FrameMaker-Fenster.

Funktion | Tastaturbefehl
Vordergrund | Esc w e
Ausblenden | Esc w h
Dokument erneut anzeigen | Control+l (kleines L), Esc w r
Alle Fenster oder Dialogfenster ohne Modus schließen | Control+x Control+c
Dokumentfenster schließen | Esc d v, Esc d q, Control+x Control+c


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

Kontextmenüs

Funktion | Vorgehensweise
Ein Aufklappmenü mit Befehlen anzeigen, die sich auf die aktuelle Auswahl oder den Kontext beziehen | Klicken Sie mit der rechten Maustaste auf ein Objekt, in einen Dokumentrand oder in ein Buchfenster.


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

Anzeige und Platzierung des Zeigers

Verwenden Sie diese Tastaturbefehle, um ein Fenster oder Dialogfenster anzuzeigen und für Tastatureingaben zu aktivieren. Wenn es bereits geöffnet ist, sich jedoch hinter einem anderen Fenster befindet, kann es mit den folgenden Tastaturbefehlen in den Vordergrund gebracht werden.

Anzeigen und für Tastaturbefehle aktivieren | Tastaturbefehl
Aktuelles Dokumentfenster | Esc g d Umschalttaste+d, F2
Suchen/Ändern | Esc Umschalttaste+e s
Hypertext | Esc Umschalttaste+f i h
Marke | Esc Umschalttaste+e m
Rechtschreibhilfe | Esc Umschalttaste+e r
Absatzgestaltung | Esc Umschalttaste+e f
Zeichengestaltung | Esc Umschalttaste+e z
Bedingter Text | Esc Umschalttaste+e b
Bedingten Text ein-/ausblenden | Esc Umschalttaste+s b
Bedingungsformate einblenden | Esc Umschalttaste+v Umschalttaste+o s
Bedingungsformate ausblenden | Esc Umschalttaste+v Umschalttaste+o h
Bedingungsformate ein-/ausblenden | Esc b Umschalttaste+f
Bedingungstypen zeigen | Esc b Shift+z
Bedingten Text verwalten | Esc m Umschalttaste+c
Bedingten Text anwenden | Esc Umschalttaste+s b
Zeichen gleichen Bedingungstyps auswählen | Esc Umschalttaste+h b
Auf den Text an der Stelle, an der sich der Cursor befindet, angewendete Bedingung anzeigen | Esc b Plus
Eingabe Bedingter Text | Esc Umschalttaste+e b
Dialogfenster "Bedingter Text" schließen | Esc Umschalttaste+c o
Lineatur/Schattierung | Esc Umschalttaste+e l (kleines L)
Tabellengestaltung | Esc Umschalttaste+f a g
Strukturansicht | Control r, Esc Umschalttaste+e u
Elementprüfung | Control r, Esc Umschalttaste+e p


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

In Fenstern navigieren

Verwenden Sie für Fenster und Dialogfenster die folgenden Tastaturbefehle. Wenn Sie einen Tastaturbefehl in einem Dialogfenster anwenden, hängt die Wirkung von der aktiven Einstellung ab. Die aktive Einstellung steht in einem Feld.

Bewegen zu | Tastaturbefehl
Nächste Einstellung | Tabulator
Vorherige Einstellung | Umschalttaste+Tabulator
Erste Einstellung | Control+Tabulator


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

Befehlsfelder

Funktion | Tastaturbefehl
Klicken Sie auf ein Standard-Feld, das einen Befehl auslöst (falls kein anderes Befehlsfeld aktiv ist). | Eingabetaste, Leertaste
Auf ein Befehlsfeld klicken | Eingabetaste
Dialogfenster abbrechen | Control+c


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

Options- und Markierungsfelder

Funktion | Tastaturbefehl
Ein Optionsfeld aktivieren | Leertaste
Zwischen Zuständen eines Markierungsfelds (Aus, Ein, Beibehalten) wechseln | Leertaste
Ein Markierungsfeld deaktivieren | 0 (null)
Ein Markierungsfeld aktivieren | 1 (eins)


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

Aufklappmenüs

Funktion | Tastaturbefehl
Aufklappmenü anzeigen | Leertaste
Zum ersten Menüelement wechseln | 0 (null)
Zum nächsten Menüelement wechseln | Nach-Unten-Taste, Control+n
Zum vorherigen Menüelement wechseln | Nach-Oben-Taste, Control+p
Markiertes Element auswählen | Eingabetaste, Leertaste


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

Auswahllisten

Funktion | Tastaturbefehl
Zum vorherigen Listenelement bewegen | Nach-Oben-Taste, Control+p
Zum nächsten Listenelement bewegen | Nach-Unten-Taste, Control+n
Element auswählen | Leertaste
Vorwärts suchen und ein Element durch Eingabe des Anfangsbuchstabens auswählen | Buchstabentaste ohne gedrückte Umschalttaste
Rückwärts suchen und ein Element durch Eingabe des Anfangsbuchstabens auswählen | Mit Umschalttaste
Ein Element in einer Auswahlliste in die gegenüberliegende Auswahlliste verschieben | Auf das Element doppelklicken
Alle Elemente in einer Auswahlliste in die gegenüberliegende Auswahlliste verschieben | Drücken Sie die Umschalttaste und klicken Sie auf den Pfeil zwischen den Auswahllisten.


Tastaturbefehle / Tastaturbefehle für UNIX / Fenster und Dialogfenster

Spezialmenüs

Funktion | Tastaturbefehl
Eine Spezialmenüleiste anzeigen | Esc Umschalttaste+d m s


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentgestaltung

Vorgabeseiten und Referenzseiten

Funktion | Tastaturbefehl
Eine Vorgabe- oder Referenzseite umbenennen (zeigen Sie vor Verwendung des Tastaturbefehls die Vorgabe- oder Referenzseite an) | Esc s Umschalttaste+u
Eine Vorgabeseite erstellen (zeigen Sie vor Verwendung des Tastaturbefehls eine Vorgabe- oder Arbeitsseite an) | Esc f n v oder Esc s v


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentgestaltung

Seitenlayout

Funktion | Tastaturbefehl
Seitenlayouts aktualisieren (zeigen Sie vor Verwendung des Tastaturbefehls eine Arbeitsseite an) | Esc f s a


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentgestaltung

Formate importieren

Funktion | Tastaturbefehl
Formate aus einem anderen Dokument importieren | Esc d f


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentgestaltung

Bereich für seitliche Überschriften

Funktion | Tastaturbefehl
Bereich für seitliche Überschriften aktivieren bzw. deaktivieren | Esc f s u


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentgestaltung

Textflüsse

Funktion | Tastaturbefehl
Einen Textrahmen unterhalb der Einfügemarke teilen | Esc t t u
Den Textrahmen mit der Einfügemarke vom vorherigen Textrahmen in einem Textfluss abtrennen | Esc t t v
Den Textrahmen mit der Einfügemarke vom nächsten Textrahmen in einem Textfluss abtrennen | Esc t t n
Den Textrahmen mit der Einfügemarke vom vorhergehenden und vom nächsten Textrahmen abtrennen | Esc t t b
Zwei ausgewählte Textrahmen verketten | Esc t v Umschalttaste+k


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumente

Hilfe

Funktion | Tastaturbefehl
Online-Hilfe anzeigen | Esc d Umschalttaste+h, F1
Hilfe zu den Schablonen in FrameMaker anzeigen | Drücken Sie Esc d n, und klicken Sie auf "Standardschablonen durchsuchen".


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumente

Öffnen

Öffnen | Tastaturbefehl
Dokument in einer Buchdatei | Doppelklicken Sie auf den Dateinamen im Buchfenster, Control+o.
Alle Dateien in einem Buch | Esc d Umschalttaste+o, oder drücken Sie die Umschalttaste und wählen Sie "Alle Dateien des Buchs öffnen" aus dem Menü "Datei".
MIF- oder MML-Datei als Textdatei | Drücken Sie die Umschalttaste und klicken Sie im Dialogfenster "Öffnen" auf "Öffnen".


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumente

Speichern und Schließen

Funktion | Tastaturbefehl
Dialogfenster zum Speichern des Dokuments anzeigen | Esc d a, Control+x Control+w
Dokument oder Buch speichern | Esc d s, Control+x Control+s
Alle geöffneten Dateien speichern | Esc d Umschalttaste+s, oder drücken Sie die Umschalttaste und wählen Sie "Geöffnete Dateien sichern" aus dem Menü "Datei".
Alle geöffneten Dateien in einem Buch speichern | Esc d Umschalttaste+s, oder drücken Sie die Umschalttaste und wählen Sie "Alle Dateien des Buchs sichern" aus dem Menü "Datei".
Als PDF speichern | Esc f w p
Als XML speichern | Esc f w x
Alle geöffneten Dateien schließen | Esc d Umschalttaste+v, oder drücken Sie die Umschalttaste und wählen Sie "Geöffnete Dateien schließen" aus dem Menü "Datei".
Alle geöffneten Dateien in einem Buch schließen | Esc d Umschalttaste+v, oder drücken Sie die Umschalttaste und wählen Sie "Alle Dateien des Buchs schließen" aus dem Menü "Datei".


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumente

Abbrechen und Widerrufen

Funktion | Tastaturbefehl
Bestimmte Befehle in FrameMaker abbrechen | Control+c
Bestimmte Befehle in FrameMaker widerrufen | Esc b r


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumente

Zoom

Aktion | Tastaturbefehl
Um eine Zoom-Einstellung größer zoomen | Esc Umschalttaste+z Umschalttaste+g
Um eine Zoom-Einstellung kleiner zoomen | Esc Umschalttaste+z Umschalttaste+k
Seite an Fenster anpassen | Esc Umschalttaste+z Umschalttaste+s
Fenster an Seite anpassen | Esc Umschalttaste+z Umschalttaste+f
Fenster an Textrahmen anpassen | Esc Umschalttaste+z f
Auf 100 Prozent zoomen | Esc Umschalttaste+z Umschalttaste+o


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumente

Hypertext-Dokumente

Funktion | Tastaturbefehl
Zur vorherigen Position im Hypertext-Stapel wechseln | Esc v v
Zur nächsten Position im Hypertext-Stapel wechseln | Esc v n
Hypertext-Befehl aktivieren, ohne das Dokument zu sperren | Drücken Sie Control und klicken Sie mit der rechten Maustaste auf einen aktiven Bereich.
Dokument sperren oder entsperren | Esc d Umschalttaste+y
Dialogfenster "Hypertext" öffnen | Esc s h
Fokus auf Dialogfenster "Hypertext" setzen | Esc Umschalttaste+f i h
Hypertext-Befehl prüfen | Esc v h
Gesperrtes FluidView-Format umschalten | Esc Umschalttaste+u a


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentdienstprogramme

Rechtschreibhilfe

Funktion | Tastaturbefehl
Ausgewählten Text bzw. ausgewähltes Wort mit der Einfügemarke prüfen | Esc l (kleines L) s, oder drücken Sie die Umschalttaste und klicken Sie im Dialogfenster "Rechtschreibhilfe" auf "Prüfung beginnen".
Gesamtes Dokument prüfen | Esc r g
Aktuelle Seite prüfen | Esc r s
Ein Wort korrigieren | Esc r w
Ein Wort in Ihr persönliches Wörterbuch einfügen (Aufnehmen) | Esc r a p
Ein Wort dem Dokumentwörterbuch hinzufügen | Esc r a d
Ein Wort der automatischen Korrektur hinzufügen | Esc r a v
Ein Wort aus Ihrem persönlichen Wörterbuch löschen (Streichen) | Esc r l (kleines L) p
Ein Wort aus dem Dokumentwörterbuch löschen | Esc r l (kleines L) d
Liste für automatische Korrekturen löschen | Esc r l (kleines L) v
Dialogfenster "Optionen für Rechtschreibhilfe" anzeigen | Esc r o
Dialogfenster "Wörterbuchfunktionen" anzeigen | Esc r Umschalttaste+l (kleines L)
Datei unbekannter Wörter erstellen | Esc r Umschalttaste+s
Alle Absätze für erneute Prüfung markieren | Esc r p
Dokument neu trennen | Esc r Umschalttaste+n
Ein gemeldetes Wort ersetzen | Doppelklicken Sie im Dialogfenster "Rechtschreibhilfe" auf das Wort in der Auswahlliste "Korrektur".


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentdienstprogramme

Thesaurus

Zeigen oder klicken Sie für den Tastaturbefehl auf ein Dokumentfenster, nicht auf das Dialogfenster "Thesaurus".

Funktion | Tastaturbefehl
Eine Auswahl durch den Thesaurus-Vorschlag ersetzen | Esc Umschalttaste+t e


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentdienstprogramme

Dokumentvergleich

Funktion | Tastaturbefehl
Dialogfenster "Dokumente vergleichen" anzeigen | Esc d t v


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentdienstprogramme

Statistik

Funktion | Tastaturbefehl
Dialogfenster "Statistik" anzeigen | Esc d t s


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentdienstprogramme

Makros

Funktion | Tastaturbefehl
Makro-Aufzeichnung starten/beenden | Control+] (rechte eckige Klammer)


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentdienstprogramme

HTML- und PDF-Export

Funktion | Tastaturbefehl
Formate anlegen und zuweisen | Esc d Umschalttaste+d f
Dialogfenster "HTML-Einstellungen" öffnen | Esc f t h
Dialogfenster "PDF-Einstellungen" öffnen | Esc o d p


Tastaturbefehle / Tastaturbefehle für UNIX / Dokumentdienstprogramme

Referenzaktualisierung

Funktion | Tastaturbefehl
Dialogfenster "Automatische Referenzaktualisierung unterdrücken" anzeigen | Esc b Umschalttaste+u


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Zeichenwerkzeuge

Werkzeug | Tastaturbefehl
Bogen | Esc o b
Grafikrahmen | Esc o Umschalttaste+r
Freihandkurve | Esc o f
Zuletzt gewähltes Werkzeug | Esc o w
Gerade | Esc o g
Objektauswahl | Esc o o
Ellipse | Esc o e
Polygon | Esc o p
Polygonzug | Esc o l (kleines L)
Rechteck | Esc o r
Abgerundetes Rechteck | Esc o a
Intelligente Auswahl | Esc o i
Textrahmen | Esc o s
Textzeile | Esc o z
Zeichenobjekt | Tastaturbefehl
Vertikale, horizontale oder diagonale Gerade | Drücken Sie die Umschalttaste und zeichnen Sie eine Gerade.
Quadrat | Drücken Sie die Umschalttaste und zeichnen Sie ein Rechteck.
Kreis | Drücken Sie die Umschalttaste und zeichnen Sie eine Ellipse.
Kreisausschnitt | Drücken Sie die Umschalttaste und zeichnen Sie einen Bogen.
Funktion | Tastaturbefehl
Werkzeugpalette anzeigen | Esc eins g, Esc g Umschalttaste+w
Werkzeug nach Verwendung aktiv lassen | Drücken Sie die Umschalttaste und klicken Sie auf ein Zeichenwerkzeug.
Nach dem Zeichnen zum Objektauswahlwerkzeug zurückkehren | Drücken Sie die Umschalttaste und klicken Sie auf das Objektauswahlwerkzeug.


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Werkzeugverwendung

Funktion | Tastaturbefehl
Werkzeugpalette anzeigen | Esc eins g, Esc g Umschalttaste+w
Werkzeug nach Verwendung aktiv lassen | Drücken Sie die Umschalttaste und klicken Sie auf ein Zeichenwerkzeug.
Nach dem Zeichnen zum Objektauswahlwerkzeug zurückkehren | Drücken Sie die Umschalttaste und klicken Sie auf das Objektauswahlwerkzeug.


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Füllmuster

Die Begriffe "Erstes", "Letztes", "Nächstes" und "Vorheriges" beziehen sich auf Positionen im Aufklappmenü "Füllung" in der kleinen Werkzeugpalette bzw. im Bereich "Füllung" in der großen Werkzeugpalette.

Wechseln zu | Tastaturbefehl
Erstes Füllmuster (durchgehend) | Esc Umschalttaste+f eins
Letztes Füllmuster (keines) | Esc 9 f
Nächstes Füllmuster (wenn das letzte Füllmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Plus f
Vorheriges Füllmuster (wenn das erste Füllmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Minus f


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Linienmuster

Die Begriffe "Erstes", "Letztes", "Nächstes" und "Vorheriges" beziehen sich auf Positionen im Aufklappmenü "Linienmuster" in der kleinen Werkzeugpalette bzw. im Bereich "Füllung" in der großen Werkzeugpalette.

Wechseln zu | Tastaturbefehl
Erstes Linienmuster (Durchgehend) | Esc eins u
Letztes Linienmuster (keines) | Esc 9 u
Nächstes Linienmuster (wenn das letzte Linienmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Plus u
Vorheriges Linienmuster (wenn das erste Linienmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Minus u


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Linienstärke

Die Begriffe "Nächste" und "Vorherige" beziehen sich auf Positionen im Aufklappmenü "Linienstärke" in der kleinen Werkzeugpalette bzw. im Bereich "Linienstärke" in der großen Werkzeugpalette.

Wechseln zu | Tastaturbefehl
Dünnste Linienstärke | Esc null b
Breiteste Linienstärke | Esc 9 b
Nächste Linienstärke (wenn die letzte Linienstärke aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Plus b
Vorherige Linienstärke (wenn die erste Linienstärke aktiviert ist, hat dieser Befehl keine Wirkung) | Esc Minus b


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Strichstil

Um die für ein Objekt verwendete Linienart zu verändern, wählen Sie einen Stil aus dem Aufklappmenü "Strichstil" in der kleinen Werkzeugpalette bzw. aus dem Bereich "Strichstil" in der großen Werkzeugpalette.

Um das aktuelle Aussehen einer gestrichelten Linie zu verändern, wählen Sie ein Muster aus dem Dialogfenster "Stricheinstellungen". Die Begriffe "Erster", "Letzter", "Nächster" oder "Vorheriger" beziehen sich auf Positionen in diesem Dialogfenster.

Funktion | Tastaturbefehl
Durchgehenden Strichstil einem Objekt zuweisen | Esc o m d
Gestrichelten Strichstil einem Objekt zuweisen | Esc o m g
Dialogfenster "Stricheinstellungen" anzeigen | Esc o m o
Zum ersten Strichmuster wechseln | Esc o m eins
Zum letzten Strichmuster wechseln | Esc o m 9
Zum nächsten Strichmuster wechseln (wenn das letzte Strichmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc o m Plus
Zum vorherigen Strichmuster wechseln (wenn das erste Strichmuster aktiviert ist, hat dieser Befehl keine Wirkung) | Esc o m Minus


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Objekte auswählen

Verwenden Sie diese Tastaturbefehle, um Objekte auf der aktuellen Seite auszuwählen.

Funktion | Tastaturbefehl
Textzeile oder Textrahmen auswählen | Drücken Sie Control und klicken Sie auf eine Textzeile oder einen Textrahmen.
Die Auswahl erweitern oder verkleinern | Drücken Sie die Umschalttaste und klicken Sie auf ein Objekt.
Anzeige des Auswahlrahmens erzwingen (wenn Ziehen von außerhalb der Objekte nicht möglich ist) | Drücken Sie Control+Umschalttaste und ziehen Sie diagonal.
Das erste Objekt in der Zeichenreihenfolge auswählen | Esc o eins
Das nächste Objekt in der Zeichenreihenfolge auswählen | Esc o n
Die Auswahl auf das nächste Objekt in der Zeichenreihenfolge erweitern | Esc o Plus
Die Auswahl eines Textrahmens oder einer Textzeile aufheben und die Einfügemarke stattdessen in das Objekt setzen | Doppelklicken Sie in den Textrahmen oder in die Textzeile.


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Objekte bearbeiten

Funktion | Tastaturbefehl
Horizontales oder vertikales Bewegen des Objekts | Drücken Sie die Umschalttaste und ziehen Sie das Objekt.
Beibehalten der Objektproportionen bei der Größenänderung | Drücken Sie die Umschalttaste und ziehen Sie einen Eckpunkt.
Die Einstellungen der gerade gewählten Objekte in der Werkzeugpalette anzeigen | Esc g Umschalttaste+o, oder drücken Sie die Umschalttaste und wählen Sie "Einstellungen übernehmen" aus dem Menü "Grafik".
Umformpunkt und Kontrollpunkte für gerade gewählte Linie, Polygonzug oder Freihandkurve anzeigen | Esc g u
Horizontales oder vertikales Bewegen des Kontrollpunkts | Drücken Sie die Umschalttaste und ziehen Sie den Kontrollpunkt.
Ändern der Kurve nur an einer Seite des Umformpunkts (Kurve krümmen) | Drücken Sie Control und ziehen Sie den Kontrollpunkt.
Die Konturen einer gewählten Grafik von Text umfließen lassen | Esc g k
Bildrahmen einer gewählten Grafik von Text umfließen lassen | Esc Umschalttaste+g r
Konturlauf für gewählte Grafik deaktivieren | Esc Umschalttaste+g Umschalttaste+d
Schnelles Kopieren des ausgewählten Objekts | Drücken Sie Control und ziehen Sie das Objekt mit der mittleren Maustaste.
Grafiken ein- und ausblenden | Esc Umschalttaste+d Umschalttaste+a
Einen Umformpunkt und Kontrollpunkte hinzufügen | Klicken Sie mit der mittleren Maustaste auf eine Linie, einen Polygonzug, ein Polygon oder eine Freihandkurve mit aktuell angezeigten Umform- und Kontrollpunkten.
Umformpunkt löschen | Klicken Sie mit der mittleren Maustaste auf den Umformpunkt.


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Objekte ausrichten

Wenn nur ein Objekt ausgewählt ist, wird das Objekt an der Seite, an einem verankerten Rahmen oder Grafikrahmen ausgerichtet, der das Objekt umgibt.

Objekte ausrichten an | Tastaturbefehl
Oberkanten | Esc Umschalttaste+a Umschalttaste+o
Mitte vertikal | Esc Umschalttaste+a Umschalttaste+m
Unterkanten | Esc Umschalttaste+a Umschalttaste+u
Linke Seiten | Esc p a l (kleines L)
Mitte horizontal | Esc p a Umschalttaste+z
Rechte Seiten | Esc p a Umschalttaste+r


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Objekte drehen

Funktion | Tastaturbefehl
Um 90 Grad im Uhrzeigersinn drehen | Esc g Umschalttaste+d Plus
Um 90 Grad gegen Uhrzeigersinn drehen | Esc g Umschalttaste+d Minus
Präzises Drehen mit Dialogfenster "Ausgewählte Objekte drehen" | Esc g d d
Erneut drehen | Esc g Umschalttaste+d e
Nicht gedrehte Ausrichtung des Objekts wiederherstellen (0 Grad) | Esc g Umschalttaste+d null
Objekt von seiner nicht gedrehten zur vorherigen Ausrichtung drehen | Esc g Umschalttaste+d eins
Aktuelle Position eines Objekts als neue, nicht gedrehte Ausrichtung festlegen | Esc g Umschalttaste+d 9
Ein Objekt willkürlich drehen | Drücken Sie Control und ziehen Sie mit der rechten Maustaste eine Ecke oder einen Umformpunkt.
Drehung auf 45-Grad-Schritte beschränken | Drücken Sie Control+Umschalttaste und ziehen Sie mit der rechten Maustaste eine Ecke oder einen Umformpunkt.
Seite im Uhrzeigersinn drehen | Esc p Umschalttaste+p Umschalttaste+o
Seite gegen den Uhrzeigersinn drehen | Esc p Umschalttaste+p o
Seitendrehung aufheben | Esc p Umschalttaste+p Umschalttaste+u


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Grafikrahmen

Funktion | Tastaturbefehl
Einpassen eines verankerten Rahmens (passt Rahmen an das Objekt an und positioniert den Rahmen an der Einfügemarke) | Esc m p
Freilegen eines verankerten Rahmens (Rahmen vergrößern) | Esc m e
Ausgewählten Referenzrahmen umbenennen | Klicken Sie auf den Rahmennamen in der Statuszeile.


Tastaturbefehle / Tastaturbefehle für UNIX / Grafiken

Grafikeinschübe

Funktion | Tastaturbefehl
Grafikeinschub bearbeiten | Doppelklicken Sie auf den Einschub.


Tastaturbefehle / Tastaturbefehle für UNIX / Marken und Variablen

Marken einfügen

Funktion | Tastaturbefehl
Marke einfügen | Esc m k
Das Dialogfenster "Markentypen bearbeiten" öffnen | Esc m t b


Tastaturbefehle / Tastaturbefehle für UNIX / Marken und Variablen

Variablen einfügen

Funktion | Tastaturbefehl
Eine Variable durch Eingabe der ersten Zeichen ihres Namens und Drücken der Eingabetaste einfügen | Esc k v, Control+null


Tastaturbefehle / Tastaturbefehle für UNIX

Filter nach Attribut

Funktion | Tastaturbefehl
Dialogfenster "Attributausdrücke verwalten" öffnen | Esc a c


Tastaturbefehle / Tastaturbefehle für UNIX

Verfolgen von Textänderungen

Funktion | Tastaturbefehl
Funktion zur Verfolgung von Textänderungen aktivieren oder deaktivieren | Esc t c o
Nächste Textänderung anzeigen | Esc t c n
Vorherige Textänderung anzeigen | Esc t c p
Änderung annehmen | Esc t c a
Änderung ablehnen | Esc t c r
Alle Änderungen annehmen | Esc t c Umschalttaste+a
Alle Änderungen ablehnen | Esc t c Umschalttaste+r
Vorschau Endergebnis | Esc t c Umschalttaste+f
Vorschau Original | Esc t c Umschalttaste+o
Vorschau aus | Esc f o


Tastaturbefehle / Tastaturbefehle für UNIX

Bedingten Text anzeigen

Funktion | Tastaturbefehl
Dialogfenster "Bedingten Text ein-/ausblenden" anzeigen | Esc b d
Bedingungsformate aktivieren oder deaktivieren | Esc b Umschalttaste+f
Den gesamten Text an der Einfügemarke auswählen, der dieselben Bedingungstyp-Einstellungen aufweist | Esc Umschalttaste+h b


Tastaturbefehle / Tastaturbefehle für UNIX

Fenster "Bedingter Text"

Um diese Tastaturbefehle zu verwenden, zeigen oder klicken Sie auf das Fenster "Bedingter Text".

Funktion | Tastaturbefehl
Alle Bedingungstypen in die Auswahlliste "Beibehalten" verschieben | Umschalttaste+F8
Auswahllisten ändern, damit sie mit den Bedingungstyp-Einstellungen des ausgewählten Texts übereinstimmen | Control+Umschalttaste+F8, Umschalttaste+F9
Einen Bedingungstyp zwischen den Auswahllisten "Mit" und "Ohne" verschieben | Auf den Typ doppelklicken
Einen Bedingungstyp aus der Auswahlliste "Beibehalten" in die Auswahlliste "Mit" verschieben | Doppelklicken Sie auf den Typ in der Auswahlliste "Beibehalten".


Tastaturbefehle / Tastaturbefehle für UNIX

Bedingungstyp-Einstellungen

Verwenden Sie diese Tastaturbefehle, um die Bedingungstyp-Einstellungen von ausgewähltem Text oder ausgewählten Tabellenreihen zu ändern.

Funktion | Tastaturbefehl
Ausgewähltem Text einen Bedingungstyp durch Eingabe der ersten Zeichen des Typs und Drücken der Eingabetaste zuweisen | Esc b Plus, Control+4
Einen Bedingungstyp aus ausgewähltem Text durch Eingabe der ersten Zeichen des Typs und Drücken der Eingabetaste entfernen | Esc b Minus, Control+5
Ausgewählten Text in nicht bedingten Text umwandeln | Esc b Umschalttaste+l (kleines L), Control+6


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Aufklappmenü "Gleichungen"

Befehl | Tastaturbefehl
Neue Gleichung (klein) | Esc m s
Neue Gleichung (mittel) | Esc m m
Neue Gleichung (groß) | Esc m l (kleines L)
Gleichung einpassen | Esc m p
Gleichung freilegen | Esc m e
Gleichungsgrößen | Esc p e
Gleichungsschriften | Esc m f
FrameMath-Element einfügen | Esc m i
Definition in Katalog aufnehmen | Esc m c
Definition aktualisieren | Esc m Umschalttaste+u


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Seite "Symbole"

Griechische Buchstaben

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Element | Eingabe im Dialogfenster
 | \alpha
 | \beta
 | \Gamma
 | \gamma
 | \Delta
 | \delta
 | \epsilon
 | \zeta
 | \eta
 | \Theta
 | \theta
 | \vartheta
 | \iota
 | \kappa
 | \Lambda
 | \lambda
 | \mu
 | \nu
 | \Xi
 | \xi
 | \Pi
 | \pi
 | \rho
 | \Sigma
 | \sigma
 | \varsigma
 | \tau
 | \Upsilon
 | \upsilon
 | \Phi
Element | Eingabe im Dialogfenster
 | \phi
 | \varphi
 | \chi
 | \Psi
 | \psi
 | \Omega
 | \omega
 | \varpi
 | \cpartial

Sonstige spezielle Symbole

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Element | Eingabe im Dialogfenster
 | \infty
 | \bot
... | \ldots
 | \aleph
 | \Im
 | \Re
 | \wp
 | \emptyset
 | \nabla
° | \degree
‘ | \prime
" | \pprime

Zeichenfolgen

Element | Tastaturbefehl
Textanfang | ' oder "
Textende | Eingabetaste

Diakritische Zeichen

Element | Tastaturbefehl
 | `(Gravis)
 | ~ (Tilde)
 | Punkt


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Seite "Operatoren"

Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
+ | Plus | \plus
_ | Minus (nach einem Operanden) |
?x? | Control+Umschalttaste+* (Asterisk) | \cross
 | Control+Punkt | \cdot
 | Control+8 | \bullet
Format umschalten | Control+Umschalttaste+t, Esc m Umschalttaste+t |
 | Control+Alt+/ | \fract
 | Control+m / | \div
 | / | \over
?=? | = | \equal
 | Control+= | \uequal
 | Control+j | \jotdot
?,? | Komma | \comma
 | Control+q Umschalttaste+d | \otimes
 | Control+q Umschalttaste+e | \oplus
 | Control+q Umschalttaste+y | \wedge
 | Control+q Umschalttaste+z | \vee
 | Control+m i | \cap
 | Control+m u | \cup
 | Control+Komma | \ucomma
 | ; (Semikolon) | \semicolon
 | Control+m n | \neg
- | Control+Bindestrich | \minus
 | Control+m eins | \mp
 | Control+q eins | \pm
 | Control+q Umschalttaste+q | \grad
 | Control+q Umschalttaste+q (und Operand hinzufügen) |
Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
 | Control+m Control+d | \change
 | Control+m x | \box
 | Control+m o | \boxdot
 | Control+m 2 | \box2
 | Control+m a | \forall
 | Control+m e | \exist
 | Control+m t | \therefore
 | Control+a, Esc m v l (kleines L) | \atop
 | Control+; (Semikolon), Esc m h l (kleines L) | \list
 | * (Asterisk) | \times
 | Control+| (senkrechter Strich) | \abs
 | Control+^ |
 | Control+_ (Unterstrich) |
 | Control+m Control+^ |
 | Control+m Control+_ (Unterstrich) |
 | Control+s | \sqrt
 | Control+s (und Operand hinzufügen) |
 | Control+Umschalttaste+e | \sn
 | ^ | \power
 | Control+m d | \dagger
 | ! | \fact
 | Control+m s | \ast
 | Control+q Umschalttaste+p | \angle


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Seite "Groß"

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Verwenden Sie diese Tastaturbefehle, um jedes Element der Seite "Groß" mit nur einem Operanden einzugeben. Wählen Sie dann nach Bedarf die Befehle "Neuer Operand" und "Format umschalten".

Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
? | Control+Umschalttaste+s | \sum
? | Control+Umschalttaste+p | \prod
Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
? | Control+i | \int
? | NA | \oint
? | Control+m Umschalttaste+i | \bigcap
? | Control+m Umschalttaste+u | \bigcup
Neuer Operand | Control+Umschalttaste+n, Esc m n |
Format umschalten | Control+Umschalttaste+t, Esc m Umschalttaste+t |


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Seite "Klammern"

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
( ? ) | ( | \id
[ ? ] | [ (linke eckige Klammer) |
? } | { (linke geschweifte Klammer) |
? | | | (senkrechter Strich) | \substitution
< ? > | Control+m < | \dangle
|?| | Control+| (senkrechter Strich) | \abs
( ? | Control+( | \lparen
[ ? | Control+m [ (linke eckige Klammer) |
{ ? | Control+m { (linke geschweifte Klammer) |
? | | | (senkrechter Strich) (und Operand hinzufügen) |
|? > | Control+m k | \ket
||?|| | Control+m Control+| (senkrechter Strich) | \norm
? ) | ) | \rparen
? ] | ] (rechte eckige Klammer) |
? } | } (rechte geschweifte Klammer) |
? | | | (senkrechter Strich) (und zwei Operanden hinzufügen) |
< ? | | Control+m b | \bra
 | Control+q i | \ceil
( ?, ? ) | Control+m Umschalttaste+n | \inprod
[ ?, ? ] | Control+m Umschalttaste+c | \cmut
{ ?, ? } | Control+m Umschalttaste+a | \acmut
? | Umschalttaste+Bindestrich | \overline
Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
< ? | ?> | Control+m Umschalttaste+b | \bket
 | Control+q k | \floor
( [image] ) | Control+m h | \choice
} ? | Control+m Umschalttaste+d | \downbrace
? | Control+m Umschalttastet+p | \upbrace
Format umschalten | Control+Umschalttaste+t, Esc m Umschalttaste+t |
Klammern entfernen | Esc m r p |


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Seite "Relationen"

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Element | Tastaturbefehl | Eingabe im Dialogfenster
? < ? | < | \lessthan
? > ? | > | \greaterthan
? = ? | = | \equal
? ~ ? | Control+m ~ (Tilde) | \sim
? ? | Control+q Umschalttaste+l (kleines L) | \subset
? ? | Control+q Umschalttaste+i | \supset
? ? | Control+q comma | \leftarrow
? ? | Control+q Punkt | \rightarrow
? ? | Control+q Plus | \lrarrow
? ? | Control+m r | \perp
? ? | Control+Umschalttaste+< | \leq
? ? | Control+Umschalttaste+> | \geq
? ? | Control+q : (Doppelpunkt) | \equiv
? ? | Control+q ; (Semikolon) | \approx
? ? | Control+q Umschalttaste+j | \subseteq
? ? | Control+q Umschalttaste+m | \supseteq
? ? | Control+q \ | \Leftarrow
? ? | Control+q ^ | \Rightarrow
? ? | Control+q [ (linke eckige Klammer) | \LRarrow
? ? | Control+m p | \parallel
? ? | Control+m Control+Umschalttaste+< | \ll
? ? | Control+m Control+Umschalttaste+> | \gg
? ? | Control+Umschalttaste+= | \notequal
? ? | @ | \cong
? ? | Control+q Umschalttaste+n | \in
? ? | Control+' | \ni
? ? | Control+q Umschalttaste+o | \notin
= ? | Control+= | \uequal
? ? | Control+q Umschalttaste+k | \notsubset
? ? | Control+q 5 | \propto


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Seite "Analysis"

Drücken Sie die Eingabetaste, um die Sequenzen mit umgekehrtem Schrägstrich, die in der dritten Spalte angezeigt sind, abzuschließen.

Verwenden Sie diese Tastaturbefehle, um jedes Element der Seite "Groß" mit nur einem Operanden einzugeben. Wählen Sie dann nach Bedarf die Befehle "Neuer Operand" und "Format umschalten".

Element oder Befehl | Tastaturbefehl | Eingabe im Dialogfenster
? | Control+i | \int
 | Control+Umschalttaste+i | \oint
Neuer Operand | Control+Umschalttaste+n, Esc m n |
Format umschalten | Control+Umschalttaste+t, Esc m Umschalttaste+t |
d d ? | Control+g t | \optotal
d d ? | Control+t |
¹ ¹? | Control+g p | \oppartial
¹ ¹? | Control+p |
d d ? | Control+g t (und Operand hinzufügen) |
d d ? | Control+t (und Operand hinzufügen) |
¹ ¹? | Control+g p (und Operand hinzufügen) |
¹ ¹? | Control+p (und Operand hinzufügen) |
? | Control+Alt+d | \var
? | Control+q Umschalttaste+q | \grad
d ? | Control+d | \diff
? | Control+m c | \curl
? | Control+Umschalttaste+d | \partial
? | Control+m v | \diver
? | Control+Umschalttaste+l (L) | \lim\
? | Control+m l (kleines L) | \lap


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Seite "Matrizen"

Um eine Matrix beliebiger Größe einzufügen, fügen Sie zunächst eine 1 x 1-Matrix ein. Fügen Sie dann Reihen und Spalten einzeln hinzu.

Befehl | Tastaturbefehl
Klammern hinzufügen/entfernen | Control+Umschalttaste+t

Aufklappmenü "Matrix-Befehle"

Befehl | Tastaturbefehl
1 x 1 Matrix erstellen | Esc x m, Control+x Control+x
Neue Zeile | Esc x r
Neue Spalte | Esc x c, Control+Umschalttaste+c
Matrix transponieren | Esc x t
Matrix-Algebra | Esc x a

Aufklappmenü "Höhe der Matrixzeile"

Befehl | Tastaturbefehl
Gleichmäßig/Proportional | Esc m t r

Aufklappmenü "Breite der Matrixspalte"

Befehl | Tastaturbefehl
Gleichmäßig/Proportional | Esc m t c


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Seite "Funktionen"

Um eine Funktion (außer der allgemeinen Funktion und Limes) über die Tastatur einzugeben, geben Sie ihre Bezeichnung wie angegeben ein.

Element | Tastaturbefehl | Eingabe im Dialogfenster
? (?) | Control+f | \function
? | Control+Umschalttaste+l (L) | \lim

Aufklappmenü "Addition"

Befehl | Tastaturbefehl
Brüche addieren | Esc m a a
Geordnete Summe | Esc m a o
Umgekehrt geordnete Summe | Esc m a Umschalttaste+o

Kontextmenü "Multiplikation"

Befehl | Tastaturbefehl
Ausklammern | Esc m u f
Teilweise ausklammern | Esc m u Umschalttaste+f
Ausmultiplizieren | Esc m u m
Einmal ausmultiplizieren | Esc m u Umschalttaste+m
Verteilen | Esc m u d
Auf beiden Seiten anwenden | Esc m u Umschalttaste+d

Aufklappmenü "Division"

Befehl | Tastaturbefehl
Division mit Rest | Esc m d l (kleines L)
Division umwandeln | Esc m d d
Division Stufe 1 umwandeln | Esc m d
Negative Potenz umwandeln | Esc m d n
Negative Potenz Stufe 1 umwandeln | Esc m d Umschalttaste+n

Aufklappmenü "Berechnung"

Befehl | Tastaturbefehl
Ausrechnen | Esc m v n
Alle Stellen zeigen | Esc m v Punkt
Berechnen | Esc m v e
Einsetzen | Esc m v s
Integrieren | Esc m v i
Ableiten | Esc m v d
1. Stufe ableiten | Esc m v Umschalttaste+d

Aufklappmenü "Regeln"

Befehl | Tastaturbefehl
Regel eingeben | Esc m r e
Regel anwenden | Esc m r a
Platzhalter festlegen | Esc m r d

Aufklappmenü "Umformungen"

Befehl | Tastaturbefehl
Vereinfachen | Esc m o s
Teilweise vereinfachen | Esc m o Umschalttaste+s
Term isolieren | Esc m o i
1. Term herausziehen | Esc m o e
Alle Terme herausziehen | Esc m o Umschalttaste+e


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Feinpositionierung

Der in nachstehender Tabelle angegebene Punktwert basiert auf einer Zoom-Einstellung von 100 Prozent.

Funktion | Tastaturbefehl
Um 1 pt nach oben verschieben | Control+Nach-Oben-Taste
Um 1 pt nach unten verschieben | Control+Nach-Unten-Taste
Um 1 pt nach links verschieben | Control+Nach-Links-Taste
Um 1 pt nach rechts verschieben | Control+Nach-Rechts-Taste
Um 6 pt nach oben verschieben | Control+Umschalttaste+Nach-Oben-Taste
Um 6 pt nach unten verschieben | Control+Umschalttaste+Nach-Unten-Taste
Um 6 pt nach links verschieben | Control+Umschalttaste+Nach-Links-Taste
Um 6 pt nach rechts verschieben | Control+Umschalttaste+Nach-Rechts-Taste
Feinpositionierung entfernen | Control+Pos 1

Aufklappmenü "Links/Rechts" (Ausrichtung)

Befehl | Tastaturbefehl
Links | Esc m a l (kleines L)
Zentriert | Esc m a c
Rechts | Esc m a r
Links von = | Esc m a Plus
Rechts von = | Esc m a =
Manuell einstellen | Esc m a s
Manuell löschen | Esc m a d
Ausrichtung zurücksetzen | Esc m a Umschalttaste+r

Aufklappmenü "Oben/Unten" (Ausrichtung)

Befehl | Tastaturbefehl
Nach oben | Esc m a t
Grundlinie | Esc m a Umschalttaste+b
Unten | Esc m a b

Aufklappmenü "Zeilenumbruch"

Befehl | Tastaturbefehl
Manuell einstellen | Esc m b s
Manuell löschen | Esc m b c


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Bewegen der Einfügemarke

Bewegung nach | Tastaturbefehl
Links | Nach-Links-Taste
Rechts | Nach-Rechts-Taste
Von der Seite eines Bruchs zum Zähler | Nach-Unten-Taste


Tastaturbefehle / Tastaturbefehle für UNIX / Gleichungen

Ändern der Auswahl

Funktion | Tastaturbefehl
Nächste Eingabeaufforderung auswählen | Tabulator
Auswahl erweitern | Leertaste
Nächstes Element links auswählen | Nach-Links-Taste
Nächstes Element rechts auswählen | Nach-Rechts-Taste


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Tastaturbefehle für Hewlett-Packard

Zum erneuten Anzeigen der Seite: Um die Anzeige einer Seite zu aktualisieren, drücken Sie "Anzeige löschen".

Bewegen der Einfügemarke: Um die Einfügemarke an den Zeilenbeginn zu setzen, drücken Sie.

Navigation in einem Dokument

Bewegen zu | Tastaturbefehl
Erste Seite | Umschalttaste+Bild-Auf
Letzte Seite | Umschalttaste+Bild-Ab
Nächste Seite | Drücken Sie Bild-Ab.
Vorherige Seite | Drücken Sie Bild-Auf.

Textbearbeitung

Funktion | Tastaturbefehl
Unterschneidungen entfernen | Drücken Sie Control+Umschalttaste
Löschen | Tastaturbefehl
Gesamte Zeile* | Drücken Sie "Zeile löschen"
Das nächste Zeichen* | Drücken Sie "Zeichen löschen"
Das vorherige Zeichen* | Umschalttaste+"Zeichen löschen"
Bis zum Anfang des aktuellen oder vorherigen Wortes | Control+Umschalttaste+"Zeichen löschen"
Bis zum Anfang einer Zeile | Umschalttaste+"Zeile löschen"
Bis zum Anfang eines Satzes | Control+Umschalttaste+"Zeile löschen"
Bis zum Anfang des aktuellen oder vorherigen Wortes | Control+"Zeichen löschen"
Bis zum Anfang einer Zeile | Drücken Sie "Zeile löschen"
Bis zum Anfang eines Satzes | Control+"Zeile löschen"

Hinweis: *Legt Text nicht im Zwischenspeicher ab.


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Sun-Tastaturbefehle

Linker Tastenblock

Die folgende Tabelle listet Zuweisungen für die Tasten des linken Tastenblocks auf.

Taste | Funktion | Funktion bei gedrückter Umschalttaste
L3 (Eigenschaften) | Zeigt Absatzgestaltung an. |
L4 (Zurücknehmen) | Macht den letzten Befehl rückgängig. |
L5 (Vordergrund) | Bringt das aktuelle Fenster in den Vordergrund. | Bringt das aktuelle Fenster in den Hintergrund.
L6 (Kopieren) | Kopiert Auswahl in die Zwischenablage. |
L8 (Einsetzen) | Fügt den Inhalt der Zwischenablage ein. |
L9 (Suchen) | Sucht nach dem nächsten Auftreten. |
L10 (Ausschneiden) | Schneidet die aktuelle Auswahl aus und legt sie in der Zwischenablage ab. |

Numerischer rechter Tastenblock

Die folgende Tabelle listet Zuweisungen für die Tasten des numerischen rechten Tastenblocks auf.

Wenn Sie die X/Motif®-Version von FrameMaker unter Open Windows ausführen, können Sie anstelle des Tastaturbefehls die Num-Taste aktivieren und die auf den Tasten angegebenen Zahlen eingeben.

Taste | Funktion | Funktion bei gedrückter Umschalttaste
7 (Pos 1) | Setzt die Einfügemarke an den Anfang einer Zeile. | Setzt die Einfügemarke an den Anfang einer Spalte.
9 (Bild-Auf-Taste) | Zeigt die vorherige Seite an. | Zeigt die erste Seite an.
5 | Entfernt manuelle Unterschneidungen aus dem ausgewähltem Text. |
1 (Ende) | Setzt die Einfügemarke an das Ende einer Zeile. | Setzt die Einfügemarke an das Ende einer Spalte.
3 (Bild-Ab-Taste) | Zeigt die nächste Seite an. | Zeigt die letzte Seite an.


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

IBM-Tastaturbefehle

Tasten

Die als "Eingabetaste" bezeichnete Taste ist die mit "Enter" beschriftete Taste auf dem alphanumerischen Tastaturblock.

Bewegen der Einfügemarke

Bewegen zu | Tastaturbefehl
Anfang einer Spalte | Umschalttaste+Pos 1
Ende einer Spalte | Umschalttaste+Ende
Anfang einer Zeile | Drücken Sie Pos 1.
Ende einer Zeile | Drücken Sie die Ende-Taste.

Textbearbeitung

Funktion | Tastaturbefehl
Vorheriges Zeichen löschen | Drücken Sie Entf.
Text ausschneiden und in der Zwischenablage ablegen | Umschalttaste+Entf
Aus der Zwischenablage einfügen | Umschalttaste+Einfg

Text auswählen

Auswahl | Tastaturbefehl
Das Zeichen rechts von der Einfügemarke | Umschalttaste+Nach-Rechts-Taste
Das Zeichen links von der Einfügemarke | Umschalttaste+Nach-Links-Taste
Eine Zeilenlänge ab der Einfügemarke | Umschalttaste+Nach-Unten-Taste
Eine Zeilenlänge bis zur Einfügemarke | Umschalttaste+Nach-Oben-Taste

Drucken

Drucken | Tastaturbefehl
Aktuelles Dokument | Drücken Sie die Drucktaste


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Tabellen

In Tabellen auswählen

Auswahl | Tastaturbefehl
Eine Zelle | Drücken Sie Control und klicken Sie auf die Zelle.
Eine Reihe | Drücken Sie Control und doppelklicken Sie auf die vertikale Spaltenbegrenzung in der Reihe.
Eine Spalte | Drücken Sie Control und doppelklicken Sie auf die horizontale Reihenbegrenzung in der Reihe.
Gesamter Text in aktueller Zelle | Esc t h a
Aktuelle Zelle, dann folgende Zelle | Esc t h z
Aktuelle Reihe, dann folgende Reihe | Esc t h r
Aktuelle Spalte, dann folgende Spalte | Esc t h s
Standardzellen in aktueller Spalte, dann folgende Standardzellen | Esc t h Umschalttaste+s
Aktuelle Tabelle | Esc t h t, oder drücken Sie Control und klicken Sie dreimal auf eine Zelle.
Funktion | Tastaturbefehl
Die Auswahl erweitern oder verkleinern | Drücken Sie Control+Umschalttaste und klicken Sie auf die letzte gewünschte Zelle der Auswahl.


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

In Tabellen bewegen

Verwenden Sie diese Tastaturbefehle, um zur angegebenen Zelle zu wechseln.

Bewegen zu | Tastaturbefehl
Zelle rechts | Esc t g r
Zelle links | Esc t g l (kleines L)
Zelle unten | Esc t g Umschalttaste+h
Zelle oben | Esc t g h
Zelle ganz rechts in der aktuellen Reihe | Esc t g e
Zelle ganz links in der aktuellen Reihe | Esc t g b
Zelle ganz oben in der aktuellen Spalte | Esc t g o
Zelle ganz unten in der aktuellen Spalte | Esc t g u
Ausgewählte Zelle oben links | Esc t g a, Esc t h l (kleines L)
Zelle oben links | Esc t g null
Nächste Zelle und deren Text auswählen | Tabulator, Esc t g Umschalttaste+r
Vorherige Zelle und deren Text auswählen | Umschalttaste+Tabulator, Esc t g Umschalttaste+l (kleines L)
Verankerungspunkt einer Tabelle | Esc t w


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Tabulatorzeichen in Zellen

Funktion | Tastaturbefehl
Tabulatorzeichen in eine Zelle eingeben | Esc Tabulator, Control+i


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Reihen und Spalten bearbeiten

FrameMaker fügt so viele Reihen oder Spalten hinzu, wie aktuell ausgewählt sind, bzw. löscht diese Anzahl.

Funktion | Tastaturbefehl
Reihen oberhalb der ersten ausgewählten Reihe hinzufügen | Esc t Plus o
Reihen unterhalb der letzten ausgewählten Reihe hinzufügen | Esc t + (Plus) u, Control+Eingabetaste
Spalten links neben der ganz links ausgewählten Spalte hinzufügen | Esc t Plus l (kleines L)
Spalten rechts neben der ganz rechts ausgewählten Spalte hinzufügen | Esc t Plus r
Inhalt der ausgewählten Reihen oder Spalten löschen unter Beibehaltung der Zellen in der Tabelle | Esc t Bindestrich t
Ausgewählte Reihen oder Spalten aus der Tabelle löschen | Esc t Bindestrich z
Reihen und Spalten sortieren | Esc t s
Spaltenbreite ändern | Esc t b
Verbinden/Trennen | Esc t Umschalttaste+b


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Reihen und Spalten ersetzen

Wenn die Zwischenablage keine ganzen Reihen oder Spalten enthält, werden mit folgenden Tastaturbefehlen stets die ausgewählten Zellen ersetzt.

Ganze Reihen oder Spalten einsetzen | Tastaturbefehl
Durch Ersetzen der ausgewählten Reihen oder Spalten | Esc t Umschalttaste+e e
Vor der aktuellen Auswahl (oberhalb der ersten ausgewählten Reihe bzw. links neben der ganz links ausgewählten Spalte) | Esc t Umschalttaste+e v
Nach der aktuellen Auswahl (unterhalb der letzten ausgewählten Reihe bzw. rechts neben der ganz rechts ausgewählten Spalte) | Esc t Umschalttaste+e n


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Vertikale Ausrichtung in Zellen

Vertikale Ausrichtung in Zellen | Tastaturbefehl
Oben | Esc Umschalttaste+a Umschalttaste+o
Mitte | Esc Umschalttaste+a Umschalttaste+m
Unten | Esc Umschalttaste+a Umschalttaste+u


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Spaltenbreite

Ändern | Tastaturbefehl
Spaltenbreite, sodass keine Absätze in ausgewählten Zellen umgebrochen werden | Esc t x
Breite der ausgewählten Spalte, ohne die Breite der Tabelle zu ändern | Drücken Sie die Umschalttaste und ziehen Sie den Auswahlpunkt der gewählten Zelle.


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Tabellengestaltung

Zur Verwendung dieser Tastaturbefehle zeigen oder klicken Sie auf "Tabellengestaltung".

Funktion | Tastaturbefehl
Alle Einstellungen zu "Beibehalten" ändern | Umschalttaste+F8
Alle Einstellungen entsprechend der ausgewählten Tabelle ändern | Control+Umschalttaste+F8, Umschalttaste+F9
Vorherige Seite mit Einstellungen anzeigen | Esc s Umschalttaste+v, F6
Nächste Seite mit Einstellungen anzeigen | Esc s Umschalttaste+n, Control+v, F7
Nur die aktuelle Einstellungsgruppe anwenden | Drücken Sie Control und klicken Sie auf "Zuweisen".


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Tabellenformate

Funktion | Tastaturbefehl
Format der aktuellen Tabelle dem Katalog und allen Tabellen desselben Typs zuweisen | Esc t Umschalttaste+f v
Öffnen des Dialogfensters "Lineaturstil ändern" | Esc t Umschalttaste+l (kleines L)


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen

Strukturierungswerkzeuge

Auswahl | Tastaturbefehl
Strukturierte Anwendung zuweisen | Esc f Umschalttaste+a
Strukturierte Dokumente konvertieren | Esc f Umschalttaste+d l (kleines L)
Dokumente in strukturiertes Format konvertieren | Esc d Umschalttaste+d f
Aktuelles Dokument strukturieren | Esc f t Umschalttaste+c
Dokumente strukturieren | Esc f t Umschalttaste+d
Neues EDD | Esc f Umschalttaste+d Umschalttaste+n
Elementkatalog als EDD exportieren | Esc f Umschalttaste+d Umschalttaste+x
CSS-Stile importieren | Esc f Umschalttaste+d Umschalttaste+j
Elementkontext einblenden | Esc f Umschalttaste+d Umschalttaste+e
DTD öffnen | Esc f Umschalttaste+d Umschalttaste+o
DTD importieren | Esc f Umschalttaste+d Umschalttaste+m
Sichern als DTD | Esc f Umschalttaste+d Umschalttaste+s
Schema öffnen | Esc f Umschalttaste+d Umschalttaste+y
Schema importieren | Esc f Umschalttaste+d Umschalttaste+z
Anwendungsdefinitionen bearbeiten | Esc f Umschalttaste+d Umschalttaste+a
Anwendungsdefinitionen lesen | Esc f Umschalttaste+d Umschalttaste+r
Neue Lese-/Schreibregeln | Esc f Umschalttaste+d Umschalttaste+w
Lese-/Schreibregeln überprüfen | Esc f Umschalttaste+d Umschalttaste+c
Strukturiertes Dokument analysieren | Esc f Umschalttaste+d Umschalttaste+p
Konvertierungstabelle generieren | Esc f Umschalttaste+d Umschalttaste+g
CSS2 generieren | Esc f Umschalttaste+d Umschalttaste+h


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Text

Einfügemarke bewegen

Verwenden Sie diese Tastaturbefehle, um die Einfügemarke zu bewegen. Viele Tastaturbefehle basieren auf Emacs-Befehlen.

Wechseln zu | Tastaturbefehl
Nächstes Zeichen | Nach-Rechts-Taste, Control+f
Vorheriges Zeichen | Nach-Links-Taste, Control+b
Anfang des nächsten Wortes | Esc Umschalttaste+m w
Anfang einer Zeile | Control+a
Ende einer Zeile | Control+e
Vorherige Zeile | Nach-Oben-Taste, Control+p
Nächste Zeile | Nach-Unten-Taste, Control+n
Anfang des nächsten Satzes | Esc Umschalttaste+m s
Anfang des nächsten Absatzes | Esc Umschalttaste+m a
Anfang einer Spalte | Umschalttaste+Pos 1
Ende einer Spalte | Umschalttaste+Ende
Beginn des ersten sichtbaren Textflusses | Control+Tabulator


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Text

Einfügemarke setzen

Verwenden Sie diese Tastaturbefehle, um die Einfügemarke in einen nicht gedrehten Textrahmen auf der aktuellen Seite zu setzen. Die Zeichenreihenfolge ist die Reihenfolge, in der FrameMaker Objekte auf einer Seite anzeigt. Das erste Objekt in der Zeichenreihenfolge ist das Objekt, das sich ganz im Hintergrund befindet.

Einfügemarke setzen an | Tastaturbefehl
Erste Spalte des ersten Textrahmens in Zeichenreihenfolge | Esc Umschalttaste+m e
Nächste Spalte, wobei die Textrahmen in Zeichenreihenfolge überschritten werden | Esc Umschalttaste+m n


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Text

Textauswahl

Klicken Sie in den Text, bevor Sie diese Tastaturbefehle benutzen. Wird ein Befehl auf einen bereits ausgewählten Text angewendet, erweitert FrameMaker die Auswahl.

Auswahl | Tastaturbefehl
Nächstes Zeichen | Esc h z, Esc Umschalttaste+h z, Control+Umschalttaste+f, Umschalttaste+Nach-Rechts-Taste
Vorheriges Zeichen | Esc Umschalttaste+h Umschalttaste+z, Control+Umschalttaste+b, Umschalttaste+Nach-Links-Taste
Aktuelles Wort, dann nächstes Wort | Esc h w, Esc Umschalttaste+h w
Aktuelles Wort, dann vorheriges Wort | Esc Umschalttaste+h Umschalttaste+w
Aktueller Satz, dann nächster Satz | Esc h s, Esc Umschalttaste+h s
Aktueller Satz, dann vorheriger Satz | Esc Umschalttaste+h Umschalttaste+s
Aktuelle Zeile, dann nächste Zeile | Esc h Umschalttaste+z, Esc Umschalttaste+h l (kleines L)
Aktuelle Zeile, dann vorherige Zeile | Esc Umschalttaste+h Umschalttaste+l (kleines L)
Aktueller Absatz, dann nächster Absatz | Esc h a, Esc Umschalttaste+h a
Aktueller Absatz, dann vorheriger Absatz | Esc Umschalttaste+h Umschalttaste+a
Eine Zeilenlänge ab der Einfügemarke | Esc h u, Control+Umschalttaste+n, Umschalttaste+Nach-Unten-Taste
Eine Zeilenlänge bis zur Einfügemarke | Esc h o, Control+Umschalttaste+p, Umschalttaste+Nach-Unten-Taste
Bis Spaltenanfang | Esc h b
Bis Spaltenende | Esc h e
Bis Textflussbeginn | Esc h Umschalttaste+b
Bis Textflussende | Esc h Umschalttaste+e
Gesamter Text um die Einfügemarke, der dasselbe Zeichenformat aufweist | Esc Umschalttaste+h f
Ein Zeichen nach rechts | Esc h r
Ein Zeichen nach links | Esc h l (kleines L)
Die Textauswahl erweitern oder verkleinern | Drücken Sie die Umschalttaste und klicken Sie an die Stelle, an der die Auswahl beginnen oder enden soll.
Hervorhebung entfernen | Esc h Null
Ein Wort auswählen | Auf das Wort doppelklicken
Ein Wort auswählen, dann folgende Wörter | Doppelklicken Sie auf das Wort und ziehen Sie anschließend den Mauszeiger.
Die Auswahl einer Textzeile oder eines Textrahmens aufheben und die Einfügemarke darin platzieren | Doppelklicken Sie in die Textzeile oder in den Textrahmen.


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Text

Text bearbeiten

Funktion | Tastaturbefehl
Einen Absatz auswählen | Klicken Sie dreimal in den Absatz.
Einen Absatz auswählen, dann die folgenden Absätze | Klicken Sie dreimal auf den Absatz und ziehen Sie anschließend den Mauszeiger.
Zeichen vertauschen | Control+t
Ausschneiden | Esc b a, Control+w, Umschalttaste+Entf
Kopieren | Esc b k
Einfügen | Esc b e
Einen Absatz unter der Einfügemarke erstellen, ohne die Einfügemarke zu bewegen | Control+o
Einen Absatz beenden | Eingabetaste, Control+m


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Text

Text in asiatischen Schriften

Funktion | Tastaturbefehl
Rubi-Text eingeben | Esc s r
Dialogfenster "Rubi-Einstellungen" anzeigen | Esc Umschalttaste+o Umschalttaste+r
Eine kombinierte Schrift aus lateinischen und asiatischen Zeichen definieren (nur auf asiatischen Betriebssystemen verfügbar) | Esc o c o


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Text

Text löschen

Löschen | Tastaturbefehl
Vorheriges Zeichen | Control+h, Entf, Rücktaste
Bis zum Anfang des vorherigen Wortes | Esc l (kleines L) a
Bis zum Anfang einer Zeile | Control+u, Control+Rücktaste, Control+Entf
Bis zum Ende des vorherigen Satzes | Esc l (kleines L) r
Nächstes Zeichen | Control+d
Bis zum Ende eines Wortes | Esc l (kleines L) e
Bis zum Ende einer Zeile | Control+k
Bis zum Anfang des nächsten Satzes | Esc l (kleines L) v


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Text

Groß-/Kleinschreibung

Verwenden Sie diese Tastaturbefehle, um die Groß-/Kleinschreibung des ausgewählten Textes zu ändern.

Funktion | Tastaturbefehl
Dialogfenster "Groß-/Kleinschreibung" anzeigen | Esc b Umschalttaste+g


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Textformate

Zeichen- und Absatzgestaltung

Funktion | Tastaturbefehl
Alle Einstellungen zu "Beibehalten" ändern | Umschalttaste+F8
Alle Einstellungen an ausgewählten Text anpassen | Control+Umschalttaste+F8, Umschalttaste+F9
Vorherige Einstellungsgruppe anzeigen | Esc s Umschalttaste+v, F6
Nächste Einstellungsgruppe anzeigen | Esc Umschalttaste+s n, F7, Control+v
Nur die aktuelle Einstellungsgruppe anwenden | Drücken Sie Control und klicken Sie auf "Zuweisen".


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Textformate

Absatzformate

Verwenden Sie diese Tastaturbefehle, um ausgewählte Absätze oder den Absatz mit der Einfügemarke zu formatieren.

Funktion | Tastaturbefehl
Ein Absatzformat durch Eingabe der ersten Buchstaben seines Typs und Drücken der Eingabetaste zuweisen | Esc q p, F9, Control+9
Absatz zentrieren | Esc p a Umschalttaste+z
Absatz linksbündig ausrichten | Esc p a l (kleines L)
Absatz rechtsbündig ausrichten | Esc p a Umschalttaste+r
Absatz in Blocksatz ausrichten (links- und rechtsbündig) | Esc p a b
Aktuellen Absatz in der Spalte platzieren und alle Verbindungs- und Zwischenformate entfernen | Esc p p s
Aktuellen Absatz in eine Zwischenüberschrift ändern | Esc p p t
Aktuellen Absatz in eine seitliche Überschrift ändern | Esc Umschalttaste+a p Umschalttaste+s
Aktueller Absatz verbindet alle Spalten | Esc Umschalttaste+a p Umschalttaste+v
Aktueller Absatz verbindet den Seitenüberschriftsbereich und die Spalten | Esc Umschalttaste+a u Umschalttaste+v
Einfachen Zeilenabstand zuweisen | Esc j Umschalttaste+p eins
1,5-fachen Zeilenabstand zuweisen | Esc j p / (Schrägstrich)
Doppelten Zeilenabstand zuweisen | Esc Umschalttaste+a 2
Festen Zeilenabstand zuweisen (Standardschriftgrad plus Zeilenabstand) | Esc Umschalttaste+a r
Variablen Zeilenabstand zuweisen (größter Schriftgrad plus Zeilenabstand) | Esc Umschalttaste+a v
Zeilenabstand um 1 pt erhöhen | Esc p Umschalttaste+p Plus, Esc Plus z
Zeilenabstand um 1 pt verringern | Esc p Umschalttaste+p Minus, Esc Minus z
Absätze des aktuellen Absatztyps und die Definition des Absatzformat-Katalogs an das aktuelle Absatzformat anpassen (vereinheitlichen) | Esc Umschalttaste+a Umschalttaste+a
Absatzbeginn an beliebiger Stelle | Esc Umschalttaste+a b b
Absatzbeginn am Spaltenanfang | Esc Umschalttaste+a b Umschalttaste+s
Absatzbeginn am Seitenanfang | Esc Umschalttaste+a b s
Absatzbeginn am Anfang einer linken Seite | Esc Umschalttaste+a b l (kleines L)
Absatzbeginn am Anfang einer rechten Seite | Esc Umschalttaste+a b r
Silbentrennung aktivieren | Esc Umschalttaste+a t
Silbentrennung deaktivieren | Esc Umschalttaste+a Umschalttaste+t
Letzten absatzbezogenen Befehl wiederholen | Esc Umschalttaste+a Umschalttaste+w
Anzeige | Tastaturbefehl
Absatzformat-Katalog | Esc p a Umschalttaste+k
Dialogfenster "Absatzformat aktualisieren" | Esc Umschalttaste+a k
Dialogfenster "Abstand zwischen Absätzen" | Esc Umschalttaste+a a
Dialogfenster "Zeilenabstände" | Esc Umschalttaste+a s


Tastaturbefehle / Tastaturbefehle für besondere Tastaturen / Textformate

Zeichenformate

Verwenden Sie diese Tastaturbefehle, um das Zeichenformat von ausgewähltem Text oder Text, den Sie gleich eingeben möchten, zu ändern.

Funktion | Tastaturbefehl
Ein Zeichenformat durch Eingabe der ersten Buchstaben seines Typs und Drücken der Eingabetaste zuweisen | Esc k z, F8, Control+8
Text zu Absatzstandardschrift ändern, Zeichentyp aus Text in einer Textzeile entfernen | Esc Umschalttaste+s z
Fettschrift aktivieren oder deaktivieren | Esc z f, Umschalttaste+F2
Kursivschrift aktivieren oder deaktivieren | Esc z k, Umschalttaste+F3
Unterstreichung aktivieren oder deaktivieren | Esc z u, Umschalttaste+F4
Doppelte Unterstreichung aktivieren oder deaktivieren | Esc z 2
Numerische Unterstreichung aktivieren oder deaktivieren | Esc c 2
Durchstreichen aktivieren oder deaktivieren | Esc z d, Umschalttaste+F5
Überstreichung aktivieren oder deaktivieren | Esc z Umschalttaste+u
Text in Standardtext ändern | Esc z n, Umschalttaste+F1
Hochgestellt aktivieren oder deaktivieren | Esc z h
Tiefgestellt aktivieren oder deaktivieren | Esc z t
Text auf Grundlinie platzieren | Esc z g
Text zu Kapitälchen ändern | Esc z p
Änderungsbalken aktivieren oder deaktivieren | Esc z b
Unterschneiden aktivieren oder deaktivieren | Esc z a
Text um 1 Punkt in angegebene Richtung manuell unterschneiden (bei Zoom-Einstellung 100 Prozent) | Control+Pfeiltaste
Text um 6 Punkt in angegebene Richtung manuell unterschneiden (bei Zoom-Einstellung 100 Prozent) | Control+Umschalttaste+Pfeiltaste
Alle manuellen Unterschneidungen entfernen | Control+z Control+Umschalttaste+z
Größe um 1 pt erhöhen | Esc z Plus
Größe um 1 pt verringern | Esc z Minus
Um 20 % eines m-Leerzeichens verkleinern | Esc z Nach-Links-Taste
Um 20 % eines m-Leerzeichens vergrößern | Esc z Nach-Rechts-Taste
Schriftstreckung auf 100 % setzen | Esc [ (linke eckige Klammer) n
Schriftstreckung um 5 % verringern | Esc [ (linke eckige Klammer) c
Schriftstreckung um 5 % vergrößern | Esc [ (linke eckige Klammer) e
Letzten schriftbezogenen Befehl wiederholen | Esc z w
Tsume ein/aus (nur Japanisch) | Esc c t
Zeigt den Zeichenformat-Katalog an | Esc z Umschalttaste+k


Tastaturbefehle

Arbeiten mit Struktur

Einfügemarke positionieren | Tastenkombination
An den Anfang des aktuellen Elements | Esc Umschalttaste+m l (kleines L) b
An das Ende des aktuellen Elements | Esc Umschalttaste+m l (kleines L) e
Nach dem nächsten Element | Esc Umschalttaste+m l (kleines L) d
Vor dem vorherigen Element | Esc Umschalttaste+m l (kleines L) u
Vor dem übergeordneten Element des aktuellen Elements | Esc Umschalttaste+m l (kleines L) v
An den Anfang der Inhalte des nächsten Elements | Esc Umschalttaste+m b n
Auswahl | Tastenkombination
Aktuelles Element | Esc Umschalttaste+h Umschalttaste+e
Nächstes Element | Esc Umschalttaste+h Umschalttaste+n
Vorheriges Element | Esc Umschalttaste+h Umschalttaste+v
Gleichrangige Elemente des aktuellen Elements | Esc h Umschalttaste+s
Übergeordnete Elemente des aktuellen Elements | Esc h Umschalttaste+p
Element einfügen | Esc e e e, Control+1 (eins)
Element eingliedern | Esc e e i, Control+2
Element ausgliedern | Esc e e f
Element ändern | Esc e e a, Control+3
In erstes Element einlesen | Esc e v eins
In letztes Element einlesen | Esc Umschalttaste+e Umschalttaste+m
Element um eine Ebene nach oben bewegen | Esc Umschalttaste+e Umschalttaste+p
Element um eine Ebene nach unten bewegen | Esc Umschalttaste+e Umschalttaste+d
Element mit dem vorherigen Element vertauschen | Esc Umschalttaste+e Umschalttaste+t
Element mit dem nächsten Element vertauschen | Esc Umschalttaste+e t
Element teilen | Esc e e t
Auswahl | Tastenkombination
Attributwert bearbeiten | Control+7
Letzten auf den Elementkatalog bezogenen Befehl wiederholen | Esc e e w
Anzeige von Elementgrenzen (als eckige Klammern) ein/aus | Esc Umschalttaste+d Umschalttaste+e
Anzeige von Elementgrenzen (als Typen) ein/aus | Esc Umschalttaste+d e t
Dokument prüfen | Esc e e p
Strukturansicht anzeigen | Esc Umschalttaste+s Umschalttaste+a


Installation Adobe-Hilfe Neue Funktionen