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Working on Multiple Platforms

 

Adobe

 



 

 FrameMaker

 

 

 

and FrameMaker+SGML

 

™

 

 are available for the Microsoft

 



 

 Windows

 



 

, 
Macintosh

 



 

 (Mac

 

™

 

 OS), and UNIX

 



 

 platforms. This manual is primarily for those who use one or both 
of these products on different platforms and move documents among the platforms. It also covers issues 
of compatibility among different system configurations and upgrade versions.

 

About this manual

 

This manual covers the following topics:

 

•

 

“Preparing for cross-platform compatibility” on page 4

 

•

 

“Working on a network” on page 4

 

•

 

“Working with filenames” on page 5

 

•

 

“Working with Western fonts” on page 10

 

•

 

“Working with multibyte fonts” on page 12

 

•

 

“Working with character sets” on page 13

 

•

 

“Working with Western text files and encodings” on page 14

 

•

 

“Working with Japanese documents” on page 15

 

•

 

“Customizing FrameMaker products” on page 16

 

•

 

“Working with structured documents” on page 17

 

•

 

“Working with earlier versions” on page 17

 

•

 

“Using keyboard shortcuts” on page 18

 

•

 

“Using graphics” on page 18

 

•

 

“Working with linked objects” on page 21

 

•

 

“Printing” on page 22

 

•

 

“Creating view-only documents” on page 22

This manual uses 

 

platform

 

 to refer to a supported operating system: Windows, Macintosh, or UNIX. 
Windows 95 and Windows NT are usually not differentiated. All versions of UNIX are considered to be a 
single platform. 

This manual uses 

 

FrameMaker product

 

 to refer to both FrameMaker and FrameMaker+SGML, and uses 

 

FrameMaker document

 

 to refer to a document created in either FrameMaker or FrameMaker+SGML. It 
uses 

 

version

 

 to refer to a FrameMaker product that runs on a particular platform (for example, the 

 

Windows version

 

) and also to refer to a major revision of a FrameMaker product.

 

Note: 

 

Versions 5.0 and 5.1 are considered to be part of version 5. However, version 5.5 and version 6.0 are each 
considered to be a new version, because the FrameMaker file format has changed in both versions.
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Preparing for cross-platform compatibility

 

In Windows and Macintosh, the main way to prepare for optimal compatibility with another platform is 
to choose File > Preferences and specify the other platform in the Cross-Platform pop-up menu. The 
following table describes the preference options. 

 

Working on a network

 

Working on a network often involves working on multiple platforms. Symbolic links created in UNIX can 
cause problems in Windows and Macintosh. In a UNIX version, you can use a symbolic link to find a file 
to import by reference. But in Windows and Macintosh, the symbolic link might appear to the operating 
system as a file, not as a linked directory. If this happens, the referenced file can no longer be found. For 
network compatibility, don’t use symbolic links in import paths in UNIX.

 

Site dictionaries

 

All users on the network, regardless of platform, can share a single site dictionary. The dictionary should 
reside on a server available to all users. 

 

Platform Preference option What the option controls

 

Windows Save FrameImage with 
Imported Graphics

Whether FrameImages are created for some files (see “FrameImages, FrameVec-
tors, and graphic facets” on page 20)

Network File Locking Whether a lock file is created (see “File locking” on page 5)

Cross-Platform File Naming 
pop-up menu

Whether to alert you that the document you’re saving has a filename that might 
be illegal on the specified platform (see “Working with filenames” on page 5)

Remember Missing Font Names Whether the names of unavailable fonts are preserved so that the original fonts 
can reappear when the file is reopened on a computer where they are installed 
(see “Font choice and font substitution” on page 11)

Macintosh Cross-Platform pop-up menu Whether to alert you that the document you’re saving has a filename that might 
be illegal on the specified platform (see “Working with filenames” on page 5)

Whether to alert you that the document you’re opening has referenced files in it 
whose names are illegal on the specified platform (see “Referenced files with ille-
gal names” on page 6)

Whether special characters in the Symbol font are preserved (see “Macintosh 
character set” on page 14)

Save FrameImage with 
Imported Graphics

Whether FrameImages are created for some files (see “FrameImages, FrameVec-
tors, and graphic facets” on page 20)

Remember Missing Font Names Whether the names of unavailable fonts are preserved so that the original fonts 
can reappear when the file is reopened on a computer where they are installed 
(see “Font choice and font substitution” on page 11)

UNIX Remember Missing Font Names Whether the names of unavailable fonts are preserved so that the original fonts 
can reappear when the file is reopened on a computer where they are installed 
(see “Font choice and font substitution” on page 11)
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In UNIX, edit the Maker.siteDict resource to point to the correct site dictionary (see the online manual 

 

Customizing FrameMaker Products

 

). In Windows, specify the site dictionary in maker.ini (for FrameMaker) 
or in fmsgml.ini (for FrameMaker+SGML). On the Macintosh, click Dictionaries in the Spelling Checker 
dialog box, choose Change Dictionary from the Site Dictionary pop-up menu, and specify the location of 
the site dictionary.

 

File locking

 

FrameMaker products lock files so that only one user at a time can edit them over a network. File locking 
is usually accomplished by creating a lock file—a file with the .lck extension—when a file is opened. Lock 
files are not created when a file is opened from a Macintosh hard disk or network server; in those cases, the 
Macintosh prevents other users from accessing the file while it’s open. UNIX systems always attempt to 
create a lock file when you open a FrameMaker document.

File locking across platforms is always active except in the following cases:

 

•

 

When you save a document with a filename that is not legal on a platform (see “Working with filenames” 
on page 5)

 

•

 

(Windows) When you have turned off Network File Locking in the Preferences dialog box or when you 
change the value in the Preferences section of the initialization file (maker.ini for FrameMaker or 
fmsgml.ini for FrameMaker+SGML)

 

Text translation errors

 

Different platforms have slightly different requirements and expectations for text-only files. FrameMaker 
products can usually recognize text files that have been created on a different platform and interpret them 
correctly. Occasionally, the products might report that the file you’re trying to open has been damaged by 
a text translation error. The error can be caused by one of the following:

 

•

 

A document saved in document format (a binary format) has been mistakenly “converted” to text format 
when it was transferred across a network from one platform to another.

 

•

 

A Macintosh document was moved to another platform, where one of its supplementary files was 
deleted, and then the document was returned. Such a file might be mistaken for a text file (see “Macintosh 
resource and data forks” on page 7).

 

•

 

A Macintosh document was moved to another platform, where the format of one of its files was 
modified, and then returned (see “Macintosh resource and data forks” on page 7).

To avoid such problems, make sure your network transfer mode is binary, not ASCII, and never delete 
supplementary files created for Macintosh documents. Transferring the Maker Interchange Format (MIF) 
version of a document with ASCII transfer mode also avoids text translation errors.

 

Working with filenames

 

Filename restrictions depend on your operating system. Avoid reserved characters in filenames (characters 
that have special meanings in some operating systems). For example, avoid filenames with spaces, tabs, or 
initial periods, or filenames that use these characters:
/ \ : ; * ? > < , $ % |
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Similarly, avoid using accented letters (for example, ü, ñ, or é) in filenames, even when using a localized 
version of a FrameMaker product. Filenames with accented letters may work fine on one platform, but 
problems may occur when the file is opened on another platform. On the Macintosh, avoid any symbol 
character accessible only by pressing the Option key (for example, • 

 

°

 

 

 



 

 

 



 

 

 

±

 

 » 

 

≠

 

 

 

Ω

 

 

 



 

).

The maximum length of a filename is especially variable. Windows 95 and NT allow filenames of up to 255 
characters including spaces, but some compact disc (CD) formats restrict filenames to 8 characters plus a 
3-character extension. Filenames on the Macintosh cannot exceed 31 characters, and some UNIX systems 
have a limit of 15 characters. The safest strategy for cross-platform work is to use the shortest name 
possible.

Also, filenames entered with multibyte characters expand when displayed on a system not equipped to 
display such fonts. For example, a filename that uses 20 kanji characters will display as 40 characters when 
displayed on a system that doesn’t support Japanese features.

If you work in UNIX, do not differentiate filenames by case alone (for example, do not create two files 
named MYfile.fm and myFILE.fm). Although legal in UNIX, this will cause a filename conflict in Windows 
and on the Macintosh.

The following table illustrates the rules for portable filenames.

These restrictions also apply to graphic and text files imported by reference, files to which you create cross-
references, and files in a book.

When you’ve specified a cross-platform preference (see “Preparing for cross-platform compatibility” on 
page 4), an alert appears when you try to save a document with a filename that’s not legal for that platform.

 

Referenced files with illegal names

 

On the Macintosh, if a document has references to graphic files or text files whose names are illegal on the 
Macintosh, the references are changed automatically to legal filenames. This is true even if the referenced 
file is not present and cannot be located when you open the document. Illegal filenames are changed for 
graphic and text files imported by reference, files to which you create cross-references, and files in a book.

 

Nonportable filename Problem Fixed filename

 

last?try.fm Uses reserved character (?) last_try.fm

our_

 



 

.fm Uses special symbol (

 



 

) copyrite.fm

FirstQuarterSalesResultsForMyCompany Too long for some platforms 1q_sales.fm

UPdown.fm
upDOWN.fm

Uses capitalization as sole way to differen-
tiate files

up-down.fm
down-up.fm
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On the Macintosh, an illegal filename is one that contains a colon or exceeds 31 characters. These restric-
tions apply to both document names and folder names. For example, suppose you have a document in 
UNIX called Chapt2.fm that has a graphic imported by reference whose filename is Chapt2:Fig3. If you 
open Chapt2.fm on the Macintosh to work on the file, an alert informs you that there is an illegal filename 
referenced in the file. If you click OK to continue opening the file, the reference will be changed to 
Chapt2-Fig3. To avoid changing the reference of a file you’ve opened, close the file without saving it. If you 
click Cancel, the document does not open and the referenced filename with the illegal character, 
Chapt2:Fig3, remains unchanged.

In Windows or UNIX, opening documents that reference a file with an illegal name usually does not change 
the filename. Even though the referenced file is not displayed and cannot be updated, the original name is 
usually retained so that the link can be used when the document is opened on the original platform.

To avoid problems with referenced files with illegal names, be sure all graphic and text files imported by 
reference, files to which you create cross-references, and files in a book conform to the naming conventions 
of the platforms they will be referenced on.

 

Macintosh resource and data forks

 

The Macintosh file system collects some of a file’s data into code called the 

 

data fork

 

, and leaves additional 
information in a 

 

resource fork

 

 and in the 

 

file info

 

 area. The data fork for a document contains the actual file, 
and the resource fork and file info area contain supplementary information such as the file type, file creator, 
print settings, and preview image. When you move a document from the Macintosh to Windows or UNIX, 
some network software systems transfer the forks separately. For example, some networking software 
packages in UNIX transfer the resource fork and the file info area as a discrete file that has the same 
filename as the data file but includes a percent sign (%) as a prefix (the AppleDouble format). If you plan 
to move the document back to the Macintosh, don’t delete the supplementary files. A supplementary file 
will be moved back to the Macintosh with its document when you transfer the files. (Also, do not change 
the file format of the original file before bringing it back to the Macintosh. Doing this will cause text trans-
lation errors. For information, see “Text translation errors” on page 5.)

If only the data fork is transferred back to the Macintosh when you transfer a file, the file may lose its 
FrameMaker icon, may not immediately appear in the Open dialog box, and may not have a preview image 
there. To make the file appear, select Show All Files in the Open dialog box. You can also open the file by 
dragging its document icon onto the FrameMaker application icon. Once you reopen and save the file, the 
resource fork is rebuilt, which makes the icon return and the filename reappear in the Open dialog box.

 

Filenames restricted to 8.3 characters

 

For documents to be compatible with older Windows networks or CD formats, their filenames must not 
be more than eight characters plus a three-character extension separated by a period (8.3). If the filename 
from another platform has more than 8.3 characters, the name is abbreviated to 8.3 characters when 
viewed or stored in older Windows networks and some CD formats.
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Windows filenames

 

Filenames in Windows can have up to 255 characters. They are not case-sensitive but can contain mixed 
capitalization. The following characters are not allowed in filenames:
; \ / * ? " | > <

 

Macintosh filenames

 

Filenames on the Macintosh cannot exceed 31 characters and cannot contain a colon (:). Filenames are not 
case-sensitive, but they can contain mixed capitalization. For cross-platform use, keep filenames to the 8.3 
character limit (see “Filenames restricted to 8.3 characters” on page 7), don’t use any special characters 
available only by using the Option key, do not begin a filename with a period, and avoid characters 
forbidden on other platforms.

 

UNIX filenames

 

Slashes (/) are not allowed in UNIX filenames. Also avoid using spaces, colons, semicolons, commas, 
asterisks, question marks, tabs, parentheses, pound signs (#), and dollar signs in filenames. Even though 
they’re legal characters in UNIX filenames, they can cause problems when you try to copy or rename files.

 

Filenames for generated files

 

In version 5.5 or later of FrameMaker products, all platforms use the same naming system for generated 
files, backup files, lock files, and so on. In earlier versions, the platforms used different naming systems. 
This means that a generated file from an earlier version may not be automatically recognized when you 
regenerate with the current version. If this happens, rename the old generated file to match the new name.

Filename suffixes differ across languages. For example, French versions use TDM instead of TOC as the 
default suffix for a table of contents. You may want to manually rename a file that has a different-language 
suffix so that your version can recognize the file.

 

Filenames recognized as those of FrameMaker documents

 

If the operating system recognizes a file as a FrameMaker document, you can double-click it from the 
desktop to open it. If it is not recognized as a FrameMaker document, you must use the File > Open 
command to open the file.

The Macintosh and some UNIX platforms handle this recognition automatically. But because each 
platform’s method for tracking this information is different, you usually lose the information when you 
move a document from one platform to another. Opening the document from within a FrameMaker 
product and then saving it makes the file once again recognizable to the operating system.

Recognition may also be lost when a document is moved from one platform and then back to the original 
platform. For example, moving a document from the Macintosh to UNIX and then back to the Macintosh 
may remove its “double-clickability” (for information, see “Macintosh resource and data forks” on page 7).
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In Windows, recognition is controlled by the filename extension. Installing in Windows 95 and NT 
registers several extensions as belonging to that FrameMaker product. Double-clicking a filename with a 
registered extension opens the file in the FrameMaker product. You can modify the extensions Windows 95 
recognizes for FrameMaker products by choosing View > Options in any Windows 95 Explorer window 
and then clicking the File Types tab. When you install, the following filename extensions are registered. 

You can specify when to show extensions and when to hide them by editing the maker.ini file or the 
fmsgml.ini file, as discussed in the online manual 

 

Customizing FrameMaker Products

 

. To see all filename 
extensions all the time, choose View > Options in any Explorer window, and then make sure that Hide MS-
DOS File Extensions is turned off.

 

Saving files in Windows

 

When you save a FrameMaker product file for the first time in Windows, the proper filename extension is 
automatically added so the file type can be recognized by the Windows operating system. For example, if 
you enter SalesReport.May when you first save a FrameMaker document, the file is saved as Sales-
Report.May.fm and appears that way on the desktop unless registered filename extensions are suppressed 
(see “Filenames recognized as those of FrameMaker documents” on page 8 for more details).

If you don’t want these special extensions to be added to the filenames you assign, enclose the filenames in 
quotation marks. For example, if you enter "SalesReport.May" when you first save a document, no 
extension is added and the filename remains SalesReport.May.

If you enter a filename with a different extension that’s already registered, a FrameMaker product extension 
is not added. For example, if you save a FrameMaker file as SalesReport.doc (and if Microsoft Word is 
installed on your system), the file will be saved just as you entered it and not with the .fm extension. Doing 
this is not recommended, however, because you won’t be able to double-click SalesReport.doc to open it in 
FrameMaker (instead, Word will try to open it). You will still be able to open the document within 
FrameMaker by using File > Open.

 

PDF filenames

 

When working with FrameMaker documents to create Portable Document Format (PDF) files, you should 
observe the following naming rules if your files use cross-document links.

 

•

 

The PDF files you create must have the same names, except for the .pdf extension, as the original 
FrameMaker documents. 

 

•

 

If you intend your linked files to be viewed on multiple platforms, the original FrameMaker documents 
must have appropriate filenames for the target platforms. For example, the original documents must 
conform to 8.3 naming conventions (see “Filenames restricted to 8.3 characters” on page 7) if you want to 
make the files accessible from a PC compact disc. Renaming the final Acrobat files to conform to 8.3 
conventions will not work; the 

 

original 

 

cross-linked FrameMaker documents must have 8.3 filenames.

 

Windows extension Type of file

 

.fm A document created in FrameMaker or in FrameMaker+SGML

.book A book file

.mif A Maker Interchange Format (MIF) file
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Working with Western fonts

 

This section discusses only Western (single-byte) fonts. For additional considerations when working with 
multibyte fonts, see “Working with multibyte fonts” on page 12.

When you install a font in Windows or on the Macintosh, FrameMaker products recognize the font when 
you start the application. 

In UNIX, when you or your system administrator install a font, you might have to edit the 
fminit/fontdir/fontlist file in the installation directory to make the font available. For information, see the 
online manual 

 

Managing Fonts

 

.

 

Fonts included with FrameMaker products

 

Windows versions include the LaserWriter 13 fonts (fonts based on the Courier, Helvetica, Times, and 
Symbol font families). Macintosh versions include bitmaps for the LaserWriter 13 fonts. Additional fonts 
may be included in Windows and Macintosh system software (such as Arial TrueType in Windows and 
Geneva on the Macintosh). These fonts are not included on other platforms.

UNIX versions include two Japanese fonts (Heisei Mincho W3 and Heisei Kaku Gothic W5) and the 
Monotype font set (TimesNewRoman, Arial, Arial Narrow, CenturySchoolbook, and BookAntiqua).

Windows and Macintosh versions also include 180 ITC fonts you can install (they aren’t installed for you). 
You can find them in the Fonts folder in the Extras folder on the installation CD.

 

Windows fonts

 

The names of many Windows fonts and font properties are different from those of equivalent fonts on 
other platforms. Often the names differ because in Windows a variation such as Narrow is part of the font 
family, whereas on other platforms the variation is independent of the font family. 

The maker.ini file (for FrameMaker) and the fmsgml.ini file (for FrameMaker+SGML) contain aliases that 
map Windows fonts to the corresponding FrameMaker product font, so that font information appears in 
the Windows version as it does on other platforms. For example, Helvetica-Narrow is normally a font 
family in Windows, but because of aliasing, Narrow appears in the Variation pop-up menu of the Character 
and Paragraph Designers.

Font aliasing also allows files to be moved easily between Windows and other platforms (see “Font choice 
and font substitution” on page 11).

Some font aliases are already provided. For information on adding aliases, see the online manual 

 

Custom-
izing FrameMaker Products

 

.
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Macintosh fonts

 

The Outline and Shadow styles in Macintosh FrameMaker products aren’t available on other platforms. 
When you open a document that contains these styles on other platforms, the characters appear as regular 
text. However, the document retains the outline and shadow information for use if you reopen the 
document on the Macintosh.

Do not use QuickDraw GX or Multiple Master fonts if you plan to share your documents on other 
platforms.

For best cross-platform results with the Courier font, use the font from Adobe, which is provided in the 
FrameMaker Fonts folder, and not the Courier font from Apple. Apple’s version of this font uses a 
nonstandard character width, and it might not match the Courier font on other platforms.

 

Font choice and font substitution

 

If your documents will be used on other platforms, choose fonts that are available on the other platforms. 
For example, TrueType fonts will not be recognized in UNIX, although they transfer well between 
Windows and Macintosh platforms if they are identically named and have the same characteristics—the 
same weight, angle, and so on. Some line breaks, however, may be different. 

Also, because of differences in character shapes, the PostScript version of the Symbol font will look 
different from the TrueType version in equations. If you work with the Equations palette, remove the 
TrueType Symbol font and use the PostScript Symbol font instead.

PostScript fonts in the Adobe Type Library are cross-platform compatible except in the following cases:

 

•

 

Multiple Master fonts are available only in Windows and on the Macintosh. For compatibility with UNIX 
systems, use the non-Multiple Master version of the font on all platforms.

 

•

 

A few fonts have different names on different platforms. For example, the Macintosh font Frutiger is 
called Frutiger 55 in Windows. 

If you can’t use identically named fonts on all platforms, you can reduce font problems in the following 
ways:

 

•

 

Select Remember Missing Font Names in the Preferences dialog box so that fonts won’t be permanently 
substituted. This setting internally preserves the name of an unavailable font, even though another font has 
been substituted for it. When the file is reopened on a system where the original font is present, it will again 
be used. The Remember Missing Font Names option works with both Western and multibyte fonts.

When this feature is active, the name of a substituted font is grayed in the font family list in the Paragraph 
Designer and Character Designer. On the Macintosh, the name of a substituted font appears at the bottom 
of the Default Font properties in the Paragraph Designer and at the bottom of the Character Designer.

 

•

 

(Windows and UNIX) Set up font aliases so that a missing font is mapped to one that gives good results. 
For information on setting up font aliases in Windows, see the online manual 

 

Customizing FrameMaker 
Products

 

, and, on UNIX systems, see the online manual Managing Fonts.
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• (Windows and Macintosh) Use Adobe Type Manager  (ATM ) Deluxe 4.0 or later to enable font substi-
tution. Do this by selecting Enable Font Substitution in the Advanced Settings dialog box. This allows the 
Macintosh versions of FrameMaker products to create a good approximation for a missing font. In 
Windows, you must also change a setting in the initialization (.ini) file for the FrameMaker product before 
ATM font substitution takes effect. For information on enabling font substitution, see the online manual 
Customizing FrameMaker Products.

If you’re distributing a document online or on a CD, either use fonts that you know your readers have, such 
as Times or Helvetica, or create an installation application to add the fonts. If you choose to install fonts, 
be sure you have the rights to distribute the fonts in this manner.

If you’re printing Encapsulated PostScript (EPS) graphics, be careful to follow the same font guidelines in 
the graphics as you do in the body of the document. For information, see “Using graphics” on page 18.

Working with multibyte fonts
Chinese, Japanese, and Korean fonts use more than one byte to represent characters, allowing larger 
character sets to be represented in a single font. For information on working with Western (single-byte) 
fonts, see “Working with Western fonts” on page 10.

Multibyte fonts supported

If you’re working only in Windows or only on the Macintosh, you can use any multibyte font supported by 
either of these platforms. If you’re working in both Windows and on the Macintosh, you can use any 
multibyte font in the Adobe Type Library. In UNIX, FrameMaker products support only these Japanese 
fonts: Heisei Mincho W3 and Heisei Kaku Gothic W5.

For information on working with Japanese-text documents on a platform or system that does not support 
multibyte fonts, see “Working with Japanese documents” on page 15.

Gaiji characters

User-defined or corporation-specific Japanese characters (gaiji) are not compatible across platforms. If you 
move a document with gaiji to another platform, the gaiji become bitmaps in frames anchored at the 
insertion point. User-defined characters created with Adobe Type Composer on the Macintosh are also 
changed to bitmaps in anchored frames when moved to a different platform.

Style properties

Most multibyte fonts don’t include bold or italic styles as part of the font. If you make characters bold or 
italic, they may not print as bold or italic—even if they appear that way on-screen.
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Variable-width Japanese characters

When Tsume is selected in the Paragraph or Character Designer for a Japanese font, variable-width infor-
mation for characters in that font can be used, if found. The information can come from the font files 
themselves or from other files. The following table describes the tsume information for each platform. 

Moving a document that uses variable-width information to a platform that does not support that infor-
mation causes the text to be reformatted.

Roman characters

Roman characters in UNIX and in older Windows Japanese fonts are usually monospaced. Roman 
characters in Macintosh Japanese fonts, however, are usually proportionally spaced. This means that trans-
ferring a document with Roman characters between these platforms will result in different formatting and 
line breaks. One way to avoid this problem is to create a combined font (using Format > Document > 
Combined Fonts) that uses a cross-platform compatible Western font. When you enter Roman characters, 
they will appear the same on all platforms.

Working with character sets
The FrameMaker character set is internally identical on all platforms. There are platform conventions, 
however, that introduce a few differences.

Windows character set

Windows uses a character set that is different from the PostScript character set. For this reason, Windows 
cannot display some characters in the PostScript set: the fi and fl ligatures, the dotless i, and the breve, dot, 
and ogonek accents.

When you insert one of these characters in the Windows version of FrameMaker products or open a 
document in Windows that was created on another platform, you’ll see an underscore in place of the 
unavailable character. However, the Windows version preserves the code of the original character. If you 
open the document on another platform, the correct character reappears.

Source of tsume information Windows Macintosh UNIX

Fonts with external SBX files Supported if SBX files are in the 
Fonts or System folder

Supported if SBX files are in the Modules 
or System folder

Supported if SBX files 
are in fontdir/SBX/

Fonts with internal SBX infor-
mation

Not supported Supported Not supported

Character ID (CID) fonts Not supported Supported (all Adobe Type Library ver-
sion 2 Japanese fonts are in this format)

Not supported

TrueType GX fonts Not supported Supported (most KanjiTalk fonts are in 
this format)

Not supported



14ADOBE FRAMEMAKER 6.0
Working on Multiple Platforms

You can search for unavailable characters in your document by using the Find/Change dialog box and then 
entering the hex code sequence (\x followed by a hexadecimal number) for a character in the Find text box. 
For example, to search for the fl ligature character, enter \xdf in the Find text box. Searching with hex codes 
works only in Windows. The hex codes are listed in the character set table in the online manual 
FrameMaker Character Sets.

Windows fractions

The Windows character set contains characters for three fractions: 1/4, 1/2, and 3/4 (characters 0188, 0189, 
and 0190; hex codes \xb9, \xba, and \xbd). These characters do not appear in the UNIX or Macintosh text 
character sets. Documents that use these characters will not display or print the characters correctly on the 
Macintosh or UNIX.

To create a cross-platform fraction, use micropositioning or the Equations palette instead of Windows 
fractions.

Macintosh character set

Text fonts (such as Times and Helvetica) on the Macintosh access a few characters (such as ≠, ∞, and ≤) 
that are available only in the Symbol font on the other platforms. Although some of these characters may 
appear on-screen in the other platforms, different characters or no characters may appear in print. If you 
create documents on the Macintosh that may be opened on other platforms, choose a platform other than 
Macintosh from the Cross-Platform pop-up menu in the Preferences dialog box. When you later save a 
document on the Macintosh, characters such as ≠ will be switched automatically to the Symbol font (and 
will be formatted with a Symbol character tag) so that they’ll appear correctly on other platforms.

Japanese character sets

All platforms use the JIS X 0208 character set. However, Windows and Unix use the JIS X 0208-1990 set, 
while the Macintosh uses the JIS X 0208-1983 set. The differences between these character sets are minor—
two characters, whose hex codes are 7425 and 7426, were added in 1990. Documents that don’t use either 
of these characters will be compatible across platforms.

However, front-end processors in Windows and on the Macintosh can generate characters differently. For 
example, a front-end processor on the Macintosh can generate a character that’s not in the basic JIS X 0208 
character set, but is in an extension to that set. When transferred to Windows or UNIX, this character code 
may be mapped to a different character.

Working with Western text files and encodings
A text encoding is a mapping of character shapes to internal numerical codes. Different platforms use 
different encodings for non-Asian documents. (Asian-language documents use their own Chinese, 
Japanese, or Korean encodings.) 
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When you open a text file or save a document as text, you can choose a text encoding from a pop-up menu. 
If the text file will be used on only one platform, save the file with the encoding that corresponds to that 
platform. If a text file will be used on several platforms, save it with ASCII encoding. For example, if you’re 
saving a document as text in Windows and plan to use it only on the Macintosh, save it with Macintosh 
encoding. If you want it to be the same across platforms, save it with ASCII encoding.

When you save a document as a text file, special space characters (such as em spaces and en spaces), 
accented letters, and special symbols (such as ligatures and daggers) are treated differently depending on 
the encoding used. The following table describes how each Western encoding handles these special 
characters when you save documents as text. 

Working with Japanese documents
Japanese text can be correctly displayed only when the platform and computer have Japanese-language 
capabilities and fonts. When a Japanese document is opened on a Western-language system, Western fonts 
are temporarily used for the Japanese text. The Western text is indecipherable because Western and 
Japanese encodings and characters are different.

When working with Japanese documents on a platform or system that doesn’t support Japanese fonts, be 
aware of the following issues:

• Even though Japanese text appears garbled when displayed with a Western font and encoding, it is not 
permanently changed. The Japanese text appears correctly when the document is reopened on a system 
that has appropriate Japanese fonts. 

Encoding Character Result when opened on same platform

ANSI (Windows) Nonbreaking, thin, em, en, and 
numeric spaces

All become regular spaces.

Accented letters All remain unchanged.

Symbols Most remain unchanged.

ASCII Nonbreaking, thin, em, en, and 
numeric spaces

All become regular spaces.

Accented letters All become unaccented letters (for example, Ñ becomes N).

Symbols Most become question marks (but bullets become o’s, en and em dashes 
become hyphens, and curved quotation marks become straight quotation 
marks).

ISO Latin-1 
(UNIX)

Nonbreaking, thin, em, en, and 
numeric spaces

All become regular spaces except nonbreaking spaces, which stay nonbreak-
ing.

Accented letters All remain unchanged except Ÿ, which becomes ÿ.

Symbols Most become question marks (but en and em dashes become hyphens, and 
curved quotation marks become straight quotation marks).

Macintosh Nonbreaking, thin, em, en, and 
numeric spaces

All become regular spaces except nonbreaking and numeric spaces, which 
become Macintosh hard spaces.

Accented letters All remain unchanged.

Symbols All remain unchanged.
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• When Japanese text is displayed on a non-Japanese system or platform, it is not treated as text in terms 
of spell-checking and hyphenation. This prevents inappropriate spell-checking and hyphenation of the 
Japanese text.

• Some Japanese features may be available even when your system is not fully enabled for Japanese. For 
example, you can use tombo (Japanese-style) registration marks even when working on a Western system. 
Also, you can enter rubi-style text when no Japanese fonts are available by using the shortcut Esc s r. (And 
you can adjust the rubi properties by using Esc o r.)

To determine what Japanese features are available on your system and to obtain advice on how to enable 
additional features, choose File > Preferences and click the Asian Language Features Information button.

For information on working with multibyte fonts across platforms, see “Working with multibyte fonts” on 
page 12.

Customizing FrameMaker products
You customize FrameMaker products in Windows and UNIX by editing setup files. In Windows, most 
setup information for FrameMaker is in the maker.ini file; setup information for FrameMaker+SGML is 
in fmsgml.ini. In UNIX, most setup information is in X Window System resource files. FrameMaker 
products on the Macintosh don’t have setup files. Instead, startup settings are stored in a preferences file in 
the System Folder. If you modify preference settings, line widths, spelling options, dictionary settings, or 
zoom values in Windows or on the Macintosh, the changes remain in effect until you change them again. 
You can delete the Macintosh preferences file (which is in the Preferences folder in the System folder) to 
revert to the defaults.

If you customize pen and fill patterns for documents in one UNIX version and then open the documents 
in a second UNIX version, the patterns specified for the second version are substituted. If you later open 
the documents in the customized UNIX version, the customized patterns reappear in the document. 
Customized patterns in UNIX may not print as smoothly as the default patterns. Because you can’t 
customize these patterns in the Windows and Macintosh versions, those versions always substitute the 
default patterns shown on the Tools palette. 

For full information, see the online manual Customizing FrameMaker Products. 

Custom menus and commands

You can change the commands and menus—including context menus—by creating a menu customization 
file (see the online manual Customizing FrameMaker Products). If you create one menu customization file 
to be shared by several platform versions, be aware of the following differences among the platforms:

• Each platform interprets shortcuts differently. 

For example, the UNIX version interprets a tilde (~) in a menu customization file as the Meta key, the 
Windows version interprets it as the Alt key, and the Macintosh version interprets it as the Option key. Also, 
the Macintosh version interprets an asterisk (*) as the Command key, whereas the Windows and UNIX 
versions don't recognize an asterisk at all. All versions recognize shortcuts that use the Escape (Esc) key, but 
only UNIX versions display these shortcuts on a menu, where Esc appears as an exclamation point (!).
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• Because the Macintosh version interprets an asterisk (*) as the Command key, you must precede it with 
a backslash (\) if you want it interpreted literally as an asterisk. Because the Windows and UNIX platforms 
don’t use a Command key, they always interpret an asterisk as a literal character, whether or not it is 
preceded by a backslash.

• The KeySequence keyword, used in creating keyboard shortcuts, accepts a different set of keysyms 
(abbreviations representing specific keys on the keyboard) on each platform. For best compatibility across 
platforms, use only keysyms that are common to all platforms: Up, Down, Left, Right, Home, End, Return, 
Tab, Delete, Escape, and F1 through F12.

Working with structured documents
FrameMaker and FrameMaker+SGML documents are compatible with both products, but note the 
following points if you plan to use the same documents in both products:

• When you open a structured FrameMaker+SGML document or book file in FrameMaker, you can either 
open the document for viewing only or—if you want to edit the document—remove the structure infor-
mation.

• Element-based cross-references in a FrameMaker+SGML document become unresolved when you open 
the document in FrameMaker.

• When you open a FrameMaker+SGML document in FrameMaker, new paragraph formats are created 
based on element tags and their format rules.

• When you open a FrameMaker document in FrameMaker+SGML, the document is unstructured (that 
is, it has no element definitions). To add structure to the document, import element definitions (see the 
FrameMaker+SGML User Guide).

The current version of FrameViewer does not support structured information. If you open a structured 
document in FrameViewer, the document appears as if there were no structure present. For example, 
element-based variables disappear and element-based hypertext markers do not work. Unstructured 
FrameMaker+SGML documents are displayed without problems.

Working with earlier versions
Working with documents on multiple platforms sometimes involves working with earlier versions of a 
FrameMaker product. Versions prior to 5.5 cannot directly open documents saved in the 6.0 format. If you 
need to share a document with someone using an earlier version, choose File > Save As and save the 
document in Maker Interchange Format (MIF). When the MIF file is opened in the earlier version, the 
Console window may report errors but the file opens successfully. However, new FrameMaker 6.0 features 
such as chapter numbering and page numbering will not transfer properly. To reduce unexpected results, 
avoid formatting that’s unique to a later version, because such formatting cannot be correctly interpreted. 
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Book files

Book files generated in version 6.0 do not process closed documents that are saved in an earlier version. For 
example, if you try to print a book that contains a FrameMaker 5.5 document, the version 5.5 document 
will not be printed from the book window unless the document is already converted to the 6.0 document 
format. (Convert the document to the 6.0 format by opening it. You can convert all the files in a book by 
holding down Shift and choosing File > Open All Files in Book.) 

Similarly, you won’t be able to generate a table of contents unless the version 5.5 document is open (and 
therefore converted to the current version). However, you can still double-click the file’s name to open it.

Using keyboard shortcuts
Keyboard shortcuts vary among platforms because each platform uses different conventions and has 
different keys. Emacs Control-key shortcuts, which are UNIX-based, are rarely available in the Windows 
version because of conflicts with standard Windows keyboard mappings. For example, the Emacs-based 
Control+n shortcut in UNIX versions, which moves the insertion point to the next line, conflicts with the 
Control+n shortcut in Windows normally assigned to the File > New command. Many Emacs shortcuts 
are available, however, in the Macintosh version because the Macintosh Control key is not traditionally 
reserved for standard keystrokes. 

Also, keyboard shortcuts sometimes vary across language versions because of different keyboard layouts.

Esc-key shortcuts are available on all platforms. For a complete list of keyboard shortcuts, see online Help.

UNIX Meta keys

Some shortcuts in UNIX use a “Meta” key. Depending on the system you’re using, the Meta key may be 
mapped to the Alt key or to the “diamond” key. For information on reassigning the Meta key, see the online 
manual Customizing FrameMaker Products.

Macros

In Windows or on the Macintosh, you can create keyboard macros with third-party utilities. (On the 
Macintosh, you can also create macros with AppleScript. For details, see the online manual Using Apple-
Script.)

In UNIX, you can use File > Utilities > Keyboard Macros to create macros. Because a few keyboard 
shortcuts differ among UNIX systems, macros created for one UNIX system may not work on another.

Using graphics
In most cases, graphics imported by reference display and print correctly when you move the file from one 
platform to another. When an imported graphic cannot be displayed, it appears as a gray box. This can 
happen for the following reasons:

• The current platform does not support the graphic’s format.

• The graphic has no preview image.
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• The graphic has a preview image that is not recognized on the current platform.

• You skipped the graphic when you opened the document.

• Your system doesn’t have enough resources available to display the graphic.

When naming graphic files you expect to import by reference and use on multiple platforms, follow the 
appropriate naming conventions (see “Working with filenames” on page 5).

Graphic file formats

FrameMaker products support many graphic file formats for import and export. For information, see the 
online manual Using Filters.

Support for a particular graphic format on a platform requires the filter to be installed on that platform. 
For example, CGM format, which is supported on all platforms, will be available only on computers where 
the CGM filter is actually installed. For this reason, you should install all filters.

For details on how to import graphics, see the FrameMaker User Guide. For information on how to use a 
graphic format on an unsupported platform, see “FrameImages, FrameVectors, and graphic facets” on 
page 20 and the online manual Using Filters.

Tips on choosing a graphic file format

Use the following guidelines when deciding which graphic file format to use:

• Try to use a format supported on all the platforms you need. For example, if the graphic will be used on 
all three platforms, don’t use BMP or RGB-SGI format. If this is not feasible, be sure to generate Frame-
Image or FrameVector facets so that your graphics will be portable to all platforms (see “FrameImages, 
FrameVectors, and graphic facets” on page 20).

• If you’re working solely on one platform, consider standardizing on the graphics format native to that 
platform (WMF in Windows, for example). 

• There are many variations allowed in the TIFF and PCX formats. If you plan to use TIFF or PCX as a 
cross-platform standard, test extensively first. If you’re working with color TIFF graphics, do a color-
separation test.

• If disk space is an issue, consider the file formats supported on your platform that include compression, 
such as GIF, PCX, some TIFF formats, and some EPS formats. Avoid BMP, DCS, and uncompressed TIFF 
formats. If color is not important, gray-scaling the image will also reduce file size and improve printing 
time. Avoid creating extra graphic facets by turning off the FrameImage setting in the Preferences dialog 
box (see “FrameImages, FrameVectors, and graphic facets” on page 20).

• If the graphic will be used primarily for online viewing, choose a format that will look good on all your 
target platforms. Also avoid EPS formats, which use a lower-resolution bitmap for on-screen previewing, 
unless the target platform uses Display PostScript or unless you’re creating files for processing in Acrobat  
Distiller .

• If you need to use special fonts in a graphic, don’t use EPS unless you’re sure the special fonts are available 
on all the required platforms. 

• Consider using the built-in drawing tools to re-create simple imported graphics. These vector-based 
graphics are displayed and printed quickly, and they are fully supported on all platforms.
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EPS files with preview images

EPS files usually contain a preview image. The possible formats of a preview image depend on where the 
EPS file was created, as the following table shows.

A UNIX version cannot import an EPS file saved in Windows format with a WMF preview image. To work 
around this limitation, save the Windows EPS file without a preview image or header, or as an EPSI file. If 
this is not possible or convenient, you can modify the EPS graphic to remove the incompatible code. To do 
this, open a copy of the EPS file in a text editor and delete all lines prior to %!PS-Adobe and all lines 
following %%EOF. Save the file as text. The modified EPS graphic appears as a gray box in your document 
(unless your computer is equipped with Display PostScript), but it is printed correctly on a PostScript 
printer.

EPSI files, which contain a preview image embedded in the comments of the header of the file, can be 
imported and their previews displayed on all platforms.

FrameImages, FrameVectors, and graphic facets

Because an imaged graphic can use more than one format, graphics in FrameMaker products are said to 
be made up of facets. 

Not every graphic format is directly supported on all platforms. To ensure that a graphic of any supported 
format appears and is printed correctly on other platforms, two special, supplementary graphic formats 
are used—FrameImage facets and FrameVector facets. These two formats are supported on all platforms.

The FrameImage and FrameVector facets are usually substituted automatically during import of copied-in 
graphics, for cross-platform compatibility. The FrameImage facet is used for bitmap (raster) graphic 
formats, and the FrameVector facet is used for vector (line art) formats. 

The mechanism used for creating and saving FrameImages and FrameVectors can be complex and depends 
on the following factors:

• What platform the document is on

• Whether the image was imported by reference or by copying

• The graphic format being imported 

• What external filters are installed on the current computer

• (Windows and Macintosh) Whether Save FrameImage with Imported Graphics is on or off in the Prefer-
ences dialog box 

Preview format supported

Platform EPSI PICT TIFF WMF None

Windows x x x

Macintosh x x x

UNIX x x x x a

a. An image appears only on computers equipped with Display PostScript.
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Ordinarily, you don’t need to keep track of when a FrameImage or FrameVector is created, added, or 
substituted for the original facet. To see what facets make up an imported graphic, select the graphic and 
choose Graphics > Object Properties.

For best results, follow these guidelines:

• Install all available filters on all platforms.

• (Windows and Macintosh) Do not select the Save FrameImage with Imported Graphics setting in the 
Preferences dialog box unless the primary use will be online viewing (but not printing) across platforms.

• Import by reference if you want to keep file sizes small (no extra facets are saved with graphics imported 
by reference).

• When the available facets are not supported, the graphic will appear as a gray box. If this happens, 
reinstall a full set of filters on the current computer or (Windows and Macintosh) go back to the computer 
that created the file and resave with Save FrameImage with Imported Graphics selected.

• When a cross-platform facet is not available, a FrameMaker product will try to use the same filter it used 
originally to render the graphic. If the original filter cannot be used and the image was imported by 
reference, an alert explains what filter was unavailable and what substitute filter, if any, will be used. To 
avoid these alerts and minimize substitution, import by copying and install all filters.

Graphic insets

A graphic inset is a special type of embedded graphic linked to an external application called an inset editor. 
Graphic insets are supported in UNIX only. Even though the Windows and Macintosh versions do not 
support graphic insets, they can display and print the graphic’s preview information, if present, as long as 
the preview image is in a supported format.

Working with linked objects
Text imported by reference (or subscribed to on the Macintosh) becomes a linked text inset in the 
FrameMaker document. Moving the document to another platform results in the inset becoming 
unresolved unless the referenced file is moved as well. 

In Windows, linked OLE objects in a FrameMaker document appear as gray boxes when you move the 
document to another platform.

QuickTime movies are inserted in a Windows document by using OLE, which is not available on the 
Macintosh or in UNIX. For this reason, QuickTime movies are playable within FrameMaker documents 
only on the platform they were created on, even if a QuickTime player is installed.
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Printing
Usually, a document looks the same when printed on any platform, but there are a few platform differences 
in specialized print options.

Print options

The Windows version has options that apply to specific printers.

The Macintosh version accepts PostScript Printer Description (PPD) files to support printer-specific 
features such as halftone screening and arbitrary paper sizes.

In Windows, selecting the Low-Resolution Images option in the Print dialog box results in graphic images 
printing as gray boxes; in UNIX, it results in images printing with less detail. On the Macintosh, the Print 
dialog box doesn’t include the Low-Resolution Images option. 

Some printer preferences stored by the Macintosh version are ignored by other versions. These include the 
Invert Image, Flip Horizontal, and Flip Vertical preferences. The preferences can differ among Macintosh 
printer drivers. 

The Macintosh version supports all combinations of the Print dialog settings, but a few unusual combina-
tions are not allowed on other platforms. For example, thumbnails with registration marks are not allowed 
in UNIX versions.

PostScript files

Because of platform differences, PostScript files generated by Windows, Macintosh, and UNIX versions are 
different. Nonetheless, all three have been thoroughly tested and have been certified to work in a variety of 
desktop and high-end prepress environments.

To keep differences to a minimum, in Windows, right-click a printer driver, choose Properties, click the 
PostScript tab, and choose PostScript (Optimize for Portability - ADSC) from the PostScript Output 
Format pop-up menu. Then click OK.

For best results on the Macintosh, use the latest Apple LaserWriter or Adobe PSPrinter driver. Newer 
versions generate PostScript that conforms more closely to the Adobe Document Structuring Conventions.

Here are some differences in PostScript files generated on various platforms:

• Only the Macintosh version supports PostScript Printer Description (PPD) files to obtain printer-
specific information. UNIX has a built-in table of common settings for various printer resolutions. 
Windows uses a dialog box to set screen angles, frequencies, and so forth.

• Only UNIX supports the (atend) EPSF file comment convention—for example, 
%%BoundingBox: (atend).

Creating view-only documents
A view-only document looks the same when opened on all supported platforms. There are some platform-
related issues to consider, however, when creating view-only or hypertext documents.
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Alert boxes

The alerttitle hypertext command lets you specify the text to use in the title bar of an alert. On the 
Macintosh, however, the alert title text does not appear.

Titles in pop-up menus

When you create a pop-up menu, the first line of text you enter is the title for the pop-up menu. The 
Windows and Macintosh versions ignore this text and do not display a menu title. UNIX versions use this 
text to show a menu title.

Zoom percentages

Because of imaging differences among the platforms, the zoom percentage saved with a document might 
appear different from platform to platform. For example, a document saved at a zoom percentage of 100% 
on a UNIX version might look bigger when opened in Windows. If you’re creating a view-only document 
on one platform meant to be viewed on another, be sure to save it at a percentage that’s best for the viewing 
platform.

Hypertext pathnames

The only cross-platform hypertext links that are fully supported are those that use UNIX naming conven-
tions—that is, using slashes (/) to separate folders—and that do not contain spaces. Be sure to follow the 
other guidelines on cross-platform names in “Working with filenames” on page 5.

If you are working solely on the Macintosh, you can use spaces in filenames and pathnames, but such 
hypertext links will not be cross-platform compatible. If you are working solely in Windows, you still 
should use UNIX-style pathnames for best results.

Relative pathnames start with a period or a double period, signifying the current directory or the directory 
above the current one, respectively. The syntax for relative pathnames is the same on all platforms. Use 
relative pathnames whenever possible.

Absolute pathnames (those that start at the root or drive designation) are not cross-platform compatible. 
In Windows, an absolute pathname must start with a drive letter and colon (for example, d:). On the 
Macintosh, it starts with a slash and then the drive name. In UNIX, an absolute pathname must start with 
a slash and then the root directory.

The following examples illustrate the differences in absolute pathnames when used with the gotolink 
command. For information, see “Chapter 18: Hypertext and View-only Documents” in the FrameMaker 
User Guide.

Platform Hypertext absolute pathname

Windows gotolink d:/mybook/chapts/ch5:firstpage

Macintosh gotolink /MyDiskDrive/mybook/chapts/ch5:firstpage

UNIX gotolink /mybook/chapts/ch5:firstpage
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