Adobe FrameMaker-12 Object Model JS: Table of Contents

Adobe FrameMaker-12 Object Model

Contents

JavaScript Reference Guide

Scripting is one of the most powerful features in Framemaker. It can save lots of time: almost anything you can do with the user interface, you can do with scripts, and there are even a few things you can do in scripting that you cannot do from within the user interface. The contents on the right is categorized by function; in the index at the bottom, you can find all objects in alphabetical order. Each object description lists its elements, properties, and methods.

This entire site was entirely created automatically! Oh wow - read more!

Adobe FrameMaker-12.0

JavaScript Base Classes

ScriptUI Classes
Jongware, 18-Jan-2015 v1.0 Contents :: Index


Adobe FrameMaker-12 Object Model JS: About these pages

Adobe Framemaker fm12

About these pages

The ExtendScript Toolkit Editor comes with a built-in Help function, which displays all objects accessible in JavaScript for InDesign, Bridge, Illustrator, and Photoshop. It does so by sending a request to the target program to output an XML data file, containing the prototypes and definitions for all of its scriptable components. This XML file is saved in a cache (presumably because it's a lengthy operation) and subsequentially displayed when requested. If it detects a new plugin, the request is sent again and the XML file is rebuilt from scratch. That means that online help for any new scriptable plugin commands are available immediately for your new scripts. Amazing!

XML is a very readable data format ... if you're a bithead like me! But wouldn't it be nice to be able to format this help text just as you like, and be readable (and searchable!) in your favourite program, such as your web browser? Well, the XML format has a unique advantage over just about any other data file. It's highly structured, and this content can be manipulated using XSLT — the Extensible Stylesheet Language Transformations language, as defined by the World Wide Web Consortium (W3C). An XSLT stylesheet can sort and manipulate XML input, insert all kinds of extra data (such as, oh, a copyright manifest at the top of every output), and write the result to one or more output files. What has that to do with these 750 pages of HTML? I didn't create a single one of them. (This page is created 'All By Hand'TM — but it's not part of Adobe's XML files.)

So I wrote an XSLT stylesheet to read, parse, split, and sort the huge input file, and to output it as formatted and hyperlinked HTML pages. This was no mean task at all — the input file is over 113,000 lines long, and the latest version of the style sheet contains just under a thousand lines. All in all, it took me more than 50 hours of hard work to create the output you see before you. But wait! couldn't I just have search-and-replaced the XML commands into HTML? Sure — manually sorting and such, but still doable. But if I ever want to change something — say, I want 4 columns of index instead of 3, or I don't want to use tables anymore, but real CSS3 columns — all I have to do is re-write a (small) part of the XSLT style sheet and let the Saxon XSLT interpreter go over the XML again. If my installation of InDesign is upgraded with some scriptable plugin, all I have to do is run Saxon again. Since the XML help for CS4 has the same formatting, I can run Saxon again on its help file. And there you have it! Another entirely new set of more than 750 files, all properly indexed and hyperlinked, without me doing any more than changing how it should look!a

Understanding XML is easy, especially if you are well-versed in HTML. If the latter, you should really know about XHTML — the well-formatted younger brother of that plain old tack-together-with-sticky-tape that grew so bloated over the years. XML is even more so structured, and the step over shouldn't be difficult. XSLT is something quite else. First off, it's defined in terms of XML (meaning: you can run an XSLT style sheet over an XSLT style sheet, for example to format it for printing or viewing). It's a programming language, but it doesn't work in the do-this-then-that sequential steps; instead, it's a procedural language, and it describes what to do on each and every XML element it encounters in the input XML document. Writing your first XSLT style sheet can be frustrating (usually, because your first attempts don't appear to do anything at all) until you get into the proper mind set. Soon you will be scanning every folder on your computer for XML files to examine! (Mac OS X users: a .plist configuration file is also XML; lots of other files in that system are as well.)

So, why did I work so hard on writing the sheet for this? Well, it was fun to create something new — a good reason in itself. Besides, I needed the training. As a typesetter, one of my upcoming jobs includes a dictionary that is being assembled as Excel data. I experimented with a small data set, exporting it from Excel as XML, and then converting it to plain text, sorting entries and concatenating duplicates all in one go. After that I reckoned, "INX" — InDesign's compatibility file format — "is also an XML file", and went on to include all necessary formatting, from pages and paragraphs, right up to the style and formatting of individual words. Saxon still didn't break into a sweat — and now all I have to do if the complete data comes in, is export it to XML, run my sheet over it to create an INX output file, and open that one with InDesign. The publisher will be amazed if he receives a complete set of proofs within a couple of hours (let's be generous), no matter if it's a hundred pages of output or a thousand. How does that sound for page throughput!?

Acknowledgements

The first CHM conversion of the files for CS3 was done by fellow scripting enthousiast ABC GREEN. Additionally, he helped me set up my system to compile other versions as well. Thanks, mate!

Note

a Due to a hard disk crash of my Windows machine I lost all of my installed programs. Fortunately, my good friend René Kramer (1967-2010) was able to rescue most (if not all) of my data. Thanks, René - that bottle of whiskey was well earned. Enjoy it, whereever you are.

So this version is not created with Saxon on a Windows computer. Working on my Mac, I downloaded Kernow for Saxon. The older version 1.4 comes complete with a Java interface and Saxon 8B, and to my surprise (and relief) it took just a few clicks to re-generate the entire Help set anew. I said it before and I'll say it again: Support Open Source Software!


Adobe FrameMaker-12 Object Model JS: Table of Contents, Adobe FrameMaker-12.0

Adobe FrameMaker-12 Object Model

Contents

Adobe FrameMaker-12.0

Adobe FrameMaker-12.0

JavaScript Base Classes

ScriptUI Classes

AFrame

Arc

AttrCondExpr

Attribute

AttributeDef

AttributeDefs

AttributeEx

Attributes

AttributesEx

BodyPage

Book

BookComponent

CMSCheckinParam

CMSConnection

CMSDeleteParam

CMSInfo

CMSMenuItem

CMSObject

CMSProperties

CMSProperty

CMSRegistration

CMSResult

CMSSession

Cell

CharFmt

Color

CombinedFont

CombinedFontDefn

CombinedFonts

Command

CompareRet

CondFmt

Constants

Doc

Element

ElementCatalogEntries

ElementCatalogEntry

ElementDef

ElementLoc

ElementRange

Ellipse

FCodes

FilterArgs

Flow

FmtChangeList

FmtRule

FmtRuleClause

Fn

Font

FontEnc

Fonts

GraphicsFmt

Group

HiddenPage

IdValuePair

IdValuePairs

Inset

Ints

Iterator

KeyCatalog

Line

Marker

MarkerType

MasterPage

Math

MathML

Menu

MenuItemSeparator

Metrics

Pgf

PgfFmt

Point

Points

Polygon

Polyline

PropIdent

PropVal

PropVals

Rectangle

RefPage

RoundRect

Row

Rubi

RulingFmt

Strings

SubCol

Tab

Tabs

Tbl

TblFmt

TemplateData

TemplateDatas

TextFrame

TextItem

TextItems

TextLine

TextLoc

TextRange

TiApiClient

TiFlow

TiText

TiTextTable

TypedVal

TypedVals

UBytes

UInts

UnanchoredFrame

Var

VarFmt

XRef

XRefFmt

app


Adobe FrameMaker-12 Object Model JS: AFrame

Class

AFrame

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
AFrameIsCropped | bool | readwrite |
AFrameIsFloating | bool | readwrite |
Alignment | int | readwrite |
AnchorType | int | readwrite |
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BaselineOffset | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Element | Element | readonly |
Fill | int | readwrite |
FirstGraphicInFrame | FMObject | readonly |
FirstGraphicInFrame | FMObject | readonly |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
InTextFrame | TextFrame | readonly |
InTextObj | FMObject | readonly |
IsHotspot | int | readwrite |
LastGraphicInFrame | FMObject | readonly |
LastGraphicInFrame | FMObject | readonly |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextAFrame | AFrame | readonly |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevAFrame | AFrame | readonly |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
SideOffset | int | readwrite |
TailArrow | int | readwrite |
TextLoc | TextLoc | readonly |
TintPercent | int | readwrite |
Unique | int | readonly |
UserString | string | readwrite |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

AFrame.NextAFrame

AFrame.PrevAFrame

SubCol.FirstAFrame

SubCol.LastAFrame

TextFrame.FirstAFrame

TextFrame.LastAFrame

Return

AFrame Doc.NewAnchoredAFrame (textloc: TextLoc)


Adobe FrameMaker-12 Object Model JS: Arc

Class

Arc

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
DTheta | int | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
Theta | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

Arc Doc.NewArc (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: AttrCondExpr

Class

AttrCondExpr

QuickLinks

 ApplyAttributeExpression, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
AttrCondExprIsActive | bool | readwrite |
AttrCondExprStr | string | readwrite |
NextAttrCondExprInDoc | AttrCondExpr | readonly |

Methods

Instances

int ApplyAttributeExpression () Also availlable as 'Apply'

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

AttrCondExpr.NextAttrCondExprInDoc

Doc.FirstAttrCondExprInDoc

Return

AttrCondExpr Doc.GetNamedAttrCondExpr (name: string)

AttrCondExpr Doc.NewNamedAttrCondExpr (name: string)


Adobe FrameMaker-12 Object Model JS: Attribute

Class

Attribute

QuickLinks

 Attribute

Properties

Property | Type | Access | Description
allow | uint | readwrite |
name | string | readwrite |
valflags | uint | readwrite |
values | Strings String | readwrite |

Methods

Constructor

Attribute Attribute (name: string, values: Strings, valflags: uint, allow: uint)
Parameter | Type | Description
name | string |
values | Strings |
valflags | uint |
allow | uint |

Example new Attribute()

Element of

TypedVal.asval

Used in:

number Attributes.push (value: Attribute)

Return

Attribute Attribute.Attribute (name: string, values: Strings, valflags: uint, allow: uint)

Attribute Attributes.pop ()


Adobe FrameMaker-12 Object Model JS: AttributeDef

Class

AttributeDef

QuickLinks

 AttributeDef

Properties

Property | Type | Access | Description
attrType | int | readwrite |
choices | Strings String | readwrite |
defValues | Strings String | readwrite |
flags | uint | readwrite |
name | string | readwrite |
rangeMax | string | readwrite |
rangeMin | string | readwrite |
required | int | readwrite |

Methods

Constructor

AttributeDef AttributeDef (name: string, required: int, flags: uint, attrType: int, choices: Strings, defValues: Strings, rangeMin: string, rangeMax: string)
Parameter | Type | Description
name | string |
required | int |
flags | uint |
attrType | int |
choices | Strings |
defValues | Strings |
rangeMin | string |
rangeMax | string |

Example new AttributeDef()

Used in:

number AttributeDefs.push (value: AttributeDef)

Return

AttributeDef AttributeDef.AttributeDef (name: string, required: int, flags: uint, attrType: int, choices: Strings, defValues: Strings, rangeMin: string, rangeMax: string)

AttributeDef AttributeDefs.pop ()


Adobe FrameMaker-12 Object Model JS: AttributeDefs

Class

AttributeDefs

An Array of AttributeDef objects with integer indexing and a length property.

See also AttributeDef.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

AttributeDefs concat (value: AttributeDefs)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | AttributeDefs | Any number of values to be added to the end of the array. Can also be arrays.

AttributeDef pop ()
Removes the last element from the array.

number push (value: AttributeDef)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | AttributeDef |

Element of

ElementDef.AttributeDefs

TypedVal.adsval

Used in:

AttributeDefs AttributeDefs.concat (value: AttributeDefs)

Return

AttributeDefs AttributeDefs.concat (value: AttributeDefs)

AttributeDefs ElementDef.GetAttributeDefs ()


Adobe FrameMaker-12 Object Model JS: AttributeEx

Class

AttributeEx

QuickLinks

 AttributeEx

Properties

Property | Type | Access | Description
allow | uint | readwrite |
name | string | readwrite |
originalValues | Strings String | readwrite |
overriddenFlags | uint | readwrite |
valflags | uint | readwrite |
values | Strings String | readwrite |

Methods

Constructor

AttributeEx AttributeEx (name: string, values: Strings, originalValues: Strings, valflags: uint, allow: uint, overriddenFlags: uint)
Parameter | Type | Description
name | string |
values | Strings |
originalValues | Strings |
valflags | uint |
allow | uint |
overriddenFlags | uint |

Example new AttributeEx()

Element of

TypedVal.asvalEx

Used in:

number AttributesEx.push (value: AttributeEx)

Return

AttributeEx AttributeEx.AttributeEx (name: string, values: Strings, originalValues: Strings, valflags: uint, allow: uint, overriddenFlags: uint)

AttributeEx AttributesEx.pop ()


Adobe FrameMaker-12 Object Model JS: Attributes

Class

Attributes

An Array of Attribute objects with integer indexing and a length property.

See also Attribute.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

Attributes concat (value: Attributes)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | Attributes | Any number of values to be added to the end of the array. Can also be arrays.

Attribute pop ()
Removes the last element from the array.

number push (value: Attribute)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | Attribute |

Element of

Element.Attributes

Used in:

Attributes Attributes.concat (value: Attributes)

Return

Attributes Attributes.concat (value: Attributes)

Attributes Element.GetAttributes ()


Adobe FrameMaker-12 Object Model JS: AttributesEx

Class

AttributesEx

An Array of AttributeEx objects with integer indexing and a length property.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

AttributesEx concat (value: AttributesEx)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | AttributesEx | Any number of values to be added to the end of the array. Can also be arrays.

AttributeEx pop ()
Removes the last element from the array.

number push (value: AttributeEx)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | AttributeEx |

Element of

Element.AttributesEx

Used in:

AttributesEx AttributesEx.concat (value: AttributesEx)

Return

AttributesEx AttributesEx.concat (value: AttributesEx)


Adobe FrameMaker-12 Object Model JS: BodyPage

Class

BodyPage

QuickLinks

 ApplyPageLayout, Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
MasterPage | string | readwrite |
PageBackground | int | readwrite |
PageFrame | UnanchoredFrame | readonly |
PageHeight | int | readonly |
PageIsRecto | int | readonly |
PageNext | BodyPage | readonly |
PageNum | int | readonly |
PageNumString | string | readonly |
PagePrev | BodyPage | readonly |
PageWidth | int | readonly |
PointPageNum | int | readonly |

Methods

Instances

int ApplyPageLayout (srcPage: PageObject) PageObject is any Page object i.e., BodyPage, MasterPage, ReferencePage, HiddenPage
Parameter | Type | Description
srcPage | PageObject |

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

BodyPage.PageNext

BodyPage.PagePrev

Doc.FirstBodyPageInDoc

Doc.LastBodyPageInDoc

Return

BodyPage Doc.NewSeriesBodyPage (previous: Object)


Adobe FrameMaker-12 Object Model JS: Book

Class

Book

QuickLinks

 Close, Compare, Export, GetDependencies, GetProps, GetUniqueObject, Import, NewBookComponentInHierarchy, NewBookComponentOfTypeInHierarchy, NewIterator, NewSeriesBookComponent, NewSeriesObject, ObjectValid, Save, SetProps, SilentPrintDoc, SimpleGenerate, SimpleImportElementDefs, SimpleImportFormats, SimpleSave, UpdateBook

Properties

Property | Type | Access | Description
AcrobatBookmarkDisplayTags | int | readwrite |
BookDontUpdateReferences | int | readwrite |
BookIsModified | int | readonly |
BookIsSelected | int | readwrite |
BookIsViewOnly | int | readwrite |
CustomElementList | Strings String | readwrite |
DocAcrobatColumnArticleThreads | int | readwrite |
DocAcrobatDefaultsChanged | int | readwrite |
DocAcrobatElementList | Strings String | readwrite |
DocAcrobatElements | int | readwrite |
DocAcrobatNoArticleThreads | int | readwrite |
ElementCatalog | ElementCatalogEntries ElementCatalogEntry | readonly |
ElementCatalogDisplay | int | readwrite |
ElementSelection | ElementRange | readwrite |
FileExtensionOverride | string | readwrite |
FirstComponentInBook | BookComponent | readwrite |
FirstElementDefInDoc | ElementDef | readonly |
FirstFmtChangeListInDoc | FmtChangeList | readwrite |
FirstSelectedComponentInBook | BookComponent | readwrite |
GenerateAcrobatInfo | int | readwrite |
HighestLevelElement | Element | readonly |
IsIconified | int | readwrite |
IsInFront | int | readwrite |
IsOnScreen | int | readwrite |
Label | string | readwrite |
Name | string | readwrite |
NewElemAttrDisplay | int | readwrite |
NewElemAttrEditing | int | readwrite |
NextOpenBookInSession | Book | readonly |
PDFAllNamedDestinations | int | readwrite |
PDFBookmark | bool | readwrite |
PDFBookmarksOpenLevel | int | readwrite |
PDFConvertCMYKtoRGB | int | readwrite |
PDFDestsMarked | int | readwrite |
PDFDistillerAbsent | int | readonly |
PDFDocInfo | Strings String | readwrite |
PDFEndPage | string | readwrite |
PDFGenerateForReview | int | readwrite |
PDFJobOption | string | readwrite |
PDFJobOptionsAbsent | int | readonly |
PDFOpenPage | string | readwrite |
PDFPageHeight | int | readwrite |
PDFPageWidth | int | readwrite |
PDFPrintPageRange | int | readwrite |
PDFRegistrationMarks | int | readwrite |
PDFSeparateFiles | int | readwrite |
PDFStartPage | string | readwrite |
PDFZoomFactor | int | readwrite |
PDFZoomType | int | readwrite |
PrintBlankPages | int | readwrite |
PrintCollated | int | readwrite |
PrintDownloadAsianFonts | int | readwrite |
PrintDownloadTrueTypeAsType1 | int | readwrite |
PrintEmulsion | int | readwrite |
PrintEvenPages | int | readwrite |
PrintFileName | string | readwrite |
PrintImaging | int | readwrite |
PrintLastSheetFirst | int | readwrite |
PrintLowRes | int | readwrite |
PrintNumCopies | int | readwrite |
PrintOddPages | int | readwrite |
PrintPaperHeight | int | readwrite |
PrintPaperWidth | int | readwrite |
PrintRegistrationMarks | int | readwrite |
PrintScale | int | readwrite |
PrintSeps | int | readwrite |
PrintToFile | int | readwrite |
PrinterName | string | readwrite |
ScreenHeight | int | readwrite |
ScreenWidth | int | readwrite |
ScreenX | int | readwrite |
ScreenY | int | readwrite |
SeparateInclusions | int | readwrite |
ShowElementDescriptiveNames | bool | readwrite |
SkipBlankSeps | int | readwrite |
StatusLine | string | readwrite |
StructuredApplication | string | readwrite |
TypeOfDisplayText | int | readwrite |
UseInitialStructure | int | readwrite |
UseInitialStructureOfAutoInsertedElements | bool | readwrite |
ViewOnlyDeadCodes | UInts | readwrite |
ViewOnlyWinBorders | int | readwrite |
ViewOnlyWinMenubar | int | readwrite |
ViewOnlyWinPopup | int | readwrite |
XmlDocType | string | readwrite |
XmlEncoding | string | readwrite |
XmlFileEncoding | string | readwrite |
XmlPublicId | string | readwrite |
XmlStandAlone | int | readwrite |
XmlStyleSheet | string | readwrite |
XmlStyleSheetList | Strings String | readwrite |
XmlSystemId | string | readwrite |
XmlUseBOM | int | readwrite |
XmlVersion | string | readwrite |
XmlWellFormed | int | readwrite |

Methods

Instances

int Close (flags: int)
Parameter | Type | Description
flags | int |

CompareRet Compare (newerDoc: Doc, flags: int, insertCondTag: string, deleteCondTag: string, replaceText: string, compareThreshold: int)
Parameter | Type | Description
newerDoc | Doc |
flags | int |
insertCondTag | string |
deleteCondTag | string |
replaceText | string |
compareThreshold | int |

int Export (fileName: string, exportParams: PropVals, exportReturnParams: PropVals)
Parameter | Type | Description
fileName | string |
exportParams | PropVals |
exportReturnParams | PropVals |

TypedVals GetDependencies (depMode: int)
Parameter | Type | Description
depMode | int |

PropVals GetProps ()

Object GetUniqueObject (objType: int, unique: int)
Parameter | Type | Description
objType | int |
unique | int |

Object Import (textLocP: TextLoc, filename: string, importParams: PropVals, importReturnParams: PropVals)
Parameter | Type | Description
textLocP | TextLoc |
filename | string |
importParams | PropVals |
importReturnParams | PropVals |

Element NewBookComponentInHierarchy (compName: string, elemLoc: ElementLoc)
Parameter | Type | Description
compName | string |
elemLoc | ElementLoc |

BookComponent NewBookComponentOfTypeInHierarchy (compName: string, compType: int, elemLoc: ElementLoc)
Parameter | Type | Description
compName | string |
compType | int |
elemLoc | ElementLoc |

Object NewIterator (paramsp: PropVals)
Parameter | Type | Description
paramsp | PropVals |

BookComponent NewSeriesBookComponent (previous: Object)
Parameter | Type | Description
previous | Object |

Object NewSeriesObject (objType: int, previous: Object)
Parameter | Type | Description
objType | int |
previous | Object |

int ObjectValid ()

Object Save (saveAsName: string, saveParams: PropVals, saveReturnParams: PropVals)
Parameter | Type | Description
saveAsName | string |
saveParams | PropVals |
saveReturnParams | PropVals |

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

int SilentPrintDoc ()

int SimpleGenerate (interactive: int, makeVisible: int)
Parameter | Type | Description
interactive | int |
makeVisible | int |

int SimpleImportElementDefs (fromDocOrBook: Doc|Book, importFlags: int)
Parameter | Type | Description
fromDocOrBook | Doc|Book |
importFlags | int |

int SimpleImportFormats (fromDoc: Doc, formatFlags: int)
Parameter | Type | Description
fromDoc | Doc |
formatFlags | int |

Book SimpleSave (saveAsName: string, interactive: int)
Parameter | Type | Description
saveAsName | string |
interactive | int |

int UpdateBook (updateParams: PropVals, updateReturnParams: PropVals)
Parameter | Type | Description
updateParams | PropVals |
updateReturnParams | PropVals |

Element of

Book.NextOpenBookInSession

BookComponent.BookParent

app.ActiveBook

app.FirstOpenBook

Return

Book Book.SimpleSave (saveAsName: string, interactive: int)

Book app.GetNamedBook (name: string)

Book app.NewNamedBook (name: string)


Adobe FrameMaker-12 Object Model JS: BookComponent

Class

BookComponent

QuickLinks

 Delete, GetProps, MoveComponent, ObjectValid, SetProps

Properties

Property | Type | Access | Description
BookComponentFileType | int | readonly |
BookComponentIsFolderWithTemplate | int | readonly |
BookComponentIsFolderWithoutTemplate | int | readonly |
BookComponentIsGeneratable | int | readonly |
BookComponentParent | BookComponent | readonly |
BookComponentTemplatePath | string | readwrite |
BookComponentTitle | string | readwrite |
BookComponentType | int | readwrite |
BookParent | Book | readonly |
ChapNumComputeMethod | int | readwrite |
ChapterNumStyle | int | readwrite |
ChapterNumText | string | readwrite |
ChapterNumber | int | readwrite |
ComponentDisplayText | string | readwrite |
ComponentElement | Element | readonly |
ComponentIsDitaMap | bool | readonly |
ComponentIsSelected | int | readwrite |
ComponentType | int | readonly |
CorrespondingXmlPath | string | readwrite |
ExcludeBookComponent | int | readwrite |
ExtractElementTags | Strings String | readwrite |
ExtractTags | Strings String | readwrite |
FirstComponentInBookComponent | BookComponent | readwrite |
FirstPageNum | int | readwrite |
FnCustNumString | string | readwrite |
FnFirstNum | string | readwrite |
FnNumComputeMethod | int | readwrite |
FnNumStyle | int | readwrite |
GenerateInclude | int | readwrite |
ImportFmtInclude | int | readwrite |
InsertLinks | int | readwrite |
Name | string | readwrite |
NextBookComponentInDFSOrder | BookComponent | readonly |
NextComponentInBook | BookComponent | readwrite |
NextSelectedComponentInBook | BookComponent | readonly |
PageNumComputeMethod | int | readwrite |
PageNumStyle | int | readwrite |
PagePrefix | string | readwrite |
PageSide | int | readwrite |
PageSuffix | string | readwrite |
PgfNumComputeMethod | int | readwrite |
PrevBookComponentInDFSOrder | BookComponent | readonly |
PrevComponentInBook | BookComponent | readwrite |
PrintInclude | int | readwrite |
SecNumComputeMethod | int | readwrite |
SectionNumStyle | int | readwrite |
SectionNumText | string | readwrite |
SectionNumber | int | readwrite |
SubsecNumComputeMethod | int | readwrite |
SubsectionNumStyle | int | readwrite |
SubsectionNumText | string | readwrite |
SubsectionNumber | int | readwrite |
TblFnCustNumString | string | readwrite |
TblFnNumComputeMethod | int | readwrite |
TblFnNumStyle | int | readwrite |
Unique | int | readwrite |
UserString | string | readwrite |
VolNumComputeMethod | int | readwrite |
VolumeNumStyle | int | readwrite |
VolumeNumText | string | readwrite |
VolumeNumber | int | readwrite |
XmlApplicationForBookComponent | string | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

void MoveComponent (moveAction: int)
Parameter | Type | Description
moveAction | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Book.FirstComponentInBook

Book.FirstSelectedComponentInBook

BookComponent.BookComponentParent

BookComponent.FirstComponentInBookComponent

BookComponent.NextBookComponentInDFSOrder

BookComponent.NextComponentInBook

BookComponent.NextSelectedComponentInBook

BookComponent.PrevBookComponentInDFSOrder

BookComponent.PrevComponentInBook

Element.BookComponent

Return

BookComponent Book.NewBookComponentOfTypeInHierarchy (compName: string, compType: int, elemLoc: ElementLoc)

BookComponent Book.NewSeriesBookComponent (previous: Object)


Adobe FrameMaker-12 Object Model JS: CMSCheckinParam

Class

CMSCheckinParam

QuickLinks

 CMSCheckinParam

Properties

Property | Type | Access | Description
checkinComment | string | readwrite |
description | string | readwrite |
makeThisCurrentVersion | uint | readwrite |
version | uint | readwrite |
versionLabel | string | readwrite |

Methods

Constructor

CMSCheckinParam CMSCheckinParam (version: uint, versionLabel: string, description: string, checkinComment: string, makeThisCurrentVersion: uint)
Parameter | Type | Description
version | uint |
versionLabel | string |
description | string |
checkinComment | string |
makeThisCurrentVersion | uint |

Example new CMSCheckinParam()

Return

CMSCheckinParam CMSCheckinParam.CMSCheckinParam (version: uint, versionLabel: string, description: string, checkinComment: string, makeThisCurrentVersion: uint)

CMSCheckinParam CMSObject.CMSShowCheckinUI (hideUiItems: int)


Adobe FrameMaker-12 Object Model JS: CMSConnection

Class

CMSConnection

QuickLinks

 GetProps, ObjectValid, SetProps

Methods

Instances

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |


Adobe FrameMaker-12 Object Model JS: CMSDeleteParam

Class

CMSDeleteParam

QuickLinks

 CMSDeleteParam

Properties

Property | Type | Access | Description
deleteAllDependents | uint | readwrite |
deleteAllVersion | uint | readwrite |

Methods

Constructor

CMSDeleteParam CMSDeleteParam (deleteAllVersion: uint, deleteAllDependents: uint)
Parameter | Type | Description
deleteAllVersion | uint |
deleteAllDependents | uint |

Example new CMSDeleteParam()

Return

CMSDeleteParam CMSDeleteParam.CMSDeleteParam (deleteAllVersion: uint, deleteAllDependents: uint)

CMSDeleteParam CMSObject.CMSShowDeleteUI (hideUiItems: int)


Adobe FrameMaker-12 Object Model JS: CMSInfo

Class

CMSInfo

QuickLinks

 CMSInfo

Properties

Property | Type | Access | Description
cmsName | string | readwrite |
userFields | Strings String | readwrite |
userLoginUi | uint | readwrite |

Methods

Constructor

CMSInfo CMSInfo (cmsName: string, userFields: Strings, userLoginUi: uint)
Parameter | Type | Description
cmsName | string |
userFields | Strings |
userLoginUi | uint |

Example new CMSInfo()

Return

CMSInfo CMSInfo.CMSInfo (cmsName: string, userFields: Strings, userLoginUi: uint)

CMSInfo CMSRegistration.CMSGetCMSInfo ()


Adobe FrameMaker-12 Object Model JS: CMSMenuItem

Class

CMSMenuItem

QuickLinks

 CMSMenuItem

Properties

Property | Type | Access | Description
flags | uint | readwrite |
id | int | readwrite |
name | string | readwrite |

Methods

Constructor

CMSMenuItem CMSMenuItem (id: int, name: string, flags: uint)
Parameter | Type | Description
id | int |
name | string |
flags | uint |

Example new CMSMenuItem()

Used in:

int Globals.CMSAddMenuEntry (menuId: int, menuEntryp: CMSMenuItem)

Return

CMSMenuItem CMSMenuItem.CMSMenuItem (id: int, name: string, flags: uint)


Adobe FrameMaker-12 Object Model JS: CMSObject

Class

CMSObject

QuickLinks

 CMSCancelCheckout, CMSCheckin, CMSCheckout, CMSDelete, CMSDisableCommand, CMSDownloadObject, CMSEnableCommand, CMSGetProperties, CMSGetProperty, CMSOpenFile, CMSSetProperties, CMSSetProperty, CMSShowCancelCheckoutUI, CMSShowCheckinUI, CMSShowCheckoutUI, CMSShowCommonListUI, CMSShowDeleteUI, CMSShowPropertyUI, CMSShowPropertyUIWithTitle, CMSUploadObject, GetProps, ObjectValid, SetProps

Methods

Instances

int CMSCancelCheckout ()

int CMSCheckin (checkinParam: IdValuePairs)
Parameter | Type | Description
checkinParam | IdValuePairs |

int CMSCheckout (rootWithDescendants: bool)
Parameter | Type | Description
rootWithDescendants | bool |

int CMSDelete (deleteParams: IdValuePairs)
Parameter | Type | Description
deleteParams | IdValuePairs |

void CMSDisableCommand (commandId: int)
Parameter | Type | Description
commandId | int |

string CMSDownloadObject ()

void CMSEnableCommand (commandId: int)
Parameter | Type | Description
commandId | int |

PropVals CMSGetProperties ()

PropVal CMSGetProperty (propertyId: PropIdent)
Parameter | Type | Description
propertyId | PropIdent |

Object CMSOpenFile (openParams: IdValuePairs)
Parameter | Type | Description
openParams | IdValuePairs |

void CMSSetProperties (propVals: PropVals)
Parameter | Type | Description
propVals | PropVals |

void CMSSetProperty (propVal: PropVal)
Parameter | Type | Description
propVal | PropVal |

void CMSShowCancelCheckoutUI ()

CMSCheckinParam CMSShowCheckinUI (hideUiItems: int)
Parameter | Type | Description
hideUiItems | int |

bool CMSShowCheckoutUI (hideUiItems: int)
Parameter | Type | Description
hideUiItems | int |

bool CMSShowCommonListUI (commandId: int, title: string, columnProperties: TypedVals)
Parameter | Type | Description
commandId | int |
title | string |
columnProperties | TypedVals |

CMSDeleteParam CMSShowDeleteUI (hideUiItems: int)
Parameter | Type | Description
hideUiItems | int |

CMSProperties CMSShowPropertyUI (props: CMSProperties)
Parameter | Type | Description
props | CMSProperties |

CMSProperties CMSShowPropertyUIWithTitle (props: CMSProperties, title: string)
Parameter | Type | Description
props | CMSProperties |
title | string |

int CMSUploadObject (localFilePath: string)
Parameter | Type | Description
localFilePath | string |

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

CMSObject CMSSession.CMSCreateObject ()

CMSObject CMSSession.CMSShowBrowseRepositoryUI (showContainerOnly: bool)

CMSObject CMSSession.GetCMSObjectFromPath (urlPath: string)


Adobe FrameMaker-12 Object Model JS: CMSProperties

Class

CMSProperties

An Array of CMSProperty objects with integer indexing and a length property.

See also CMSProperty.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

CMSProperties concat (value: CMSProperties)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | CMSProperties | Any number of values to be added to the end of the array. Can also be arrays.

CMSProperty pop ()
Removes the last element from the array.

number push (value: CMSProperty)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | CMSProperty |

Used in:

CMSProperties CMSObject.CMSShowPropertyUI (props: CMSProperties)

CMSProperties CMSObject.CMSShowPropertyUIWithTitle (props: CMSProperties, title: string)

CMSProperties CMSProperties.concat (value: CMSProperties)

Return

CMSProperties CMSObject.CMSShowPropertyUI (props: CMSProperties)

CMSProperties CMSObject.CMSShowPropertyUIWithTitle (props: CMSProperties, title: string)

CMSProperties CMSProperties.concat (value: CMSProperties)


Adobe FrameMaker-12 Object Model JS: CMSProperty

Class

CMSProperty

QuickLinks

 CMSProperty

Properties

Property | Type | Access | Description
isEditable | uint | readwrite |
isMultiValue | uint | readwrite |
label | string | readwrite |
prop | uint | readwrite |
values | TypedVals TypedVal | readwrite |

Methods

Constructor

CMSProperty CMSProperty (prop: uint, label: string, isMultiValue: uint, isEditable: uint, values: TypedVals)
Parameter | Type | Description
prop | uint |
label | string |
isMultiValue | uint |
isEditable | uint |
values | TypedVals |

Example new CMSProperty()

Used in:

number CMSProperties.push (value: CMSProperty)

Return

CMSProperty CMSProperties.pop ()

CMSProperty CMSProperty.CMSProperty (prop: uint, label: string, isMultiValue: uint, isEditable: uint, values: TypedVals)


Adobe FrameMaker-12 Object Model JS: CMSRegistration

Class

CMSRegistration

QuickLinks

 CMSConfigLoginUI, CMSGetCMSInfo, GetProps, ObjectValid, SetProps

Methods

Instances

void CMSConfigLoginUI (userFields: Strings, userLoginUI: bool)
Parameter | Type | Description
userFields | Strings |
userLoginUI | bool |

CMSInfo CMSGetCMSInfo ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

CMSRegistration CMSSession.CMSGetCmsIdFromSession ()

CMSRegistration Globals.CMSGetCmsIdFromName (cmsName: string)

CMSRegistration Globals.CMSRegister (cmsName: string)


Adobe FrameMaker-12 Object Model JS: CMSResult

Class

CMSResult

QuickLinks

 CMSResult

Properties

Property | Type | Access | Description
cmsItems | Objects | readwrite |
message | sting | readwrite |
opResult | uint | readwrite |
status | int | readwrite |

Methods

Constructor

CMSResult CMSResult (status: int, opResult: uint, message: string, cmsItems: Objects)
Parameter | Type | Description
status | int |
opResult | uint |
message | string |
cmsItems | Objects |

Example new CMSResult()

Return

CMSResult CMSResult.CMSResult (status: int, opResult: uint, message: string, cmsItems: Objects)


Adobe FrameMaker-12 Object Model JS: CMSSession

Class

CMSSession

QuickLinks

 CMSCreateObject, CMSGetCmsIdFromSession, CMSLogout, CMSShowBrowseRepositoryUI, GetCMSObjectFromPath, GetProps, ObjectValid, SetProps

Methods

Instances

CMSObject CMSCreateObject ()

CMSRegistration CMSGetCmsIdFromSession ()

void CMSLogout ()

CMSObject CMSShowBrowseRepositoryUI (showContainerOnly: bool)
Parameter | Type | Description
showContainerOnly | bool |

CMSObject GetCMSObjectFromPath (urlPath: string)
Parameter | Type | Description
urlPath | string |

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

CMSSession Globals.CMSLogin (setVal: IdValuePairs)


Adobe FrameMaker-12 Object Model JS: Cell

Class

Cell

QuickLinks

 GetProps, GetText, ObjectValid, SetProps, StraddleCells, UnStraddleCells

Properties

Property | Type | Access | Description
CellAboveInCol | Cell | readonly |
CellAngle | int | readwrite |
CellBelowInCol | Cell | readonly |
CellColNum | int | readonly |
CellDefaultBottomRuling | RulingFmt | readonly |
CellDefaultLeftRuling | RulingFmt | readonly |
CellDefaultRightRuling | RulingFmt | readonly |
CellDefaultTopRuling | RulingFmt | readonly |
CellIsShown | int | readonly |
CellIsStraddled | int | readonly |
CellNumColsStraddled | int | readonly |
CellNumRowsStraddled | int | readonly |
CellOverrideBottomRuling | RulingFmt | readwrite |
CellOverrideFill | int | readwrite |
CellOverrideLeftRuling | RulingFmt | readwrite |
CellOverrideRightRuling | RulingFmt | readwrite |
CellOverrideShading | Color | readwrite |
CellOverrideTopRuling | RulingFmt | readwrite |
CellRow | Row | readonly |
CellUseOverrideBRuling | int | readwrite |
CellUseOverrideFill | int | readwrite |
CellUseOverrideLRuling | int | readwrite |
CellUseOverrideRRuling | int | readwrite |
CellUseOverrideShading | int | readwrite |
CellUseOverrideTRuling | int | readwrite |
ContentHeight | int | readonly |
Element | Element | readonly |
FirstPgf | Pgf | readonly |
HighestLevelElement | Element | readonly |
InTextFrame | TextFrame | readonly |
InTextObj | SubCol | readonly |
LastPgf | Pgf | readonly |
NextCell | Cell | readwrite |
NextCellInRow | Cell | readonly |
NextCellInTbl | Cell | readonly |
Overflowed | int | readonly |
PrevCell | Cell | readonly |
PrevCellInRow | Cell | readonly |
Unique | int | readonly |
UserString | string | readwrite |

Methods

Instances

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

int StraddleCells (heightInRows: int, widthInCols: int)
Parameter | Type | Description
heightInRows | int |
widthInCols | int |

int UnStraddleCells (heightInRows: int, widthInCols: int)
Parameter | Type | Description
heightInRows | int |
widthInCols | int |

Element of

Cell.CellAboveInCol

Cell.CellBelowInCol

Cell.NextCell

Cell.NextCellInRow

Cell.NextCellInTbl

Cell.PrevCell

Cell.PrevCellInRow

Row.FirstCellInRow

SubCol.FirstCell

SubCol.LastCell

TextFrame.FirstCell

TextFrame.LastCell


Adobe FrameMaker-12 Object Model JS: CharFmt

Class

CharFmt

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
BkColor | FMObject | readwrite |
Capitalization | int | readwrite |
ChangeBar | int | readwrite |
CharTag | string | readwrite |
Color | Color | readwrite |
CombinedFontFamily | CombinedFontDefn | readwrite |
FontAngle | int | readwrite |
FontEncodingName | string | readonly |
FontFamily | int | readwrite |
FontPlatformName | string | readwrite |
FontPostScriptName | string | readwrite |
FontSize | int | readwrite |
FontVariation | int | readwrite |
FontWeight | int | readwrite |
KernX | int | readwrite |
KernY | int | readwrite |
Language | int | readwrite |
Name | string | readwrite |
NextCharFmtInDoc | CharFmt | readonly |
Overline | int | readwrite |
PairKern | int | readwrite |
Position | int | readwrite |
ReviewTime | int | readwrite |
ReviewerName | string | readwrite |
Spread | int | readwrite |
Stretch | int | readwrite |
Strikethrough | int | readwrite |
Underlining | int | readwrite |
UseBkColor | bool | readwrite |
UseCapitalization | int | readwrite |
UseChangeBar | int | readwrite |
UseColor | int | readwrite |
UseFontAngle | int | readwrite |
UseFontFamily | int | readwrite |
UseFontSize | int | readwrite |
UseFontVariation | int | readwrite |
UseFontWeight | int | readwrite |
UseKernX | int | readwrite |
UseKernY | int | readwrite |
UseOverline | int | readwrite |
UsePairKern | int | readwrite |
UsePosition | int | readwrite |
UseSpread | int | readwrite |
UseStretch | int | readwrite |
UseStrikethrough | int | readwrite |
UseUnderlining | int | readwrite |
UserString | string | readwrite |
WesternFontPlatformName | string | readwrite |
WesternFontPostScriptName | string | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

CharFmt.NextCharFmtInDoc

Doc.FirstCharFmtInDoc

Return

CharFmt Doc.GetNamedCharFmt (name: string)

CharFmt Doc.NewNamedCharFmt (name: string)


Adobe FrameMaker-12 Object Model JS: Color

Class

Color

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Black | int | readwrite |
ColorOverprint | int | readwrite |
ColorPrintCtl | int | readwrite |
ColorTintPercent | int | readwrite |
ColorViewCtl | int | readwrite |
Cyan | int | readwrite |
FamilyName | string | readwrite |
InkName | string | readwrite |
Magenta | int | readwrite |
Name | string | readwrite |
NextColorInDoc | Color | readonly |
ReservedColor | int | readwrite |
TintBaseColor | Color | readwrite |
UserString | string | readwrite |
Yellow | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

AFrame.Color

Arc.Color

Cell.CellOverrideShading

CharFmt.Color

Color.NextColorInDoc

Color.TintBaseColor

CondFmt.BkColor

CondFmt.SepOverride

Doc.ChangeBarColor

Doc.Color

Doc.FirstColorInDoc

Doc.SepOverride

Doc.TrackChangesAddedColor

Doc.TrackChangesDeletedColor

Ellipse.Color

FmtChangeList.BkColor

FmtChangeList.Color

FmtChangeList.PgfBoxColor

GraphicsFmt.Color

Group.Color

Inset.Color

Line.Color

Math.Color

MathML.Color

Pgf.BkColor

Pgf.Color

Pgf.PgfBoxColor

PgfFmt.BkColor

PgfFmt.Color

PgfFmt.PgfBoxColor

Polygon.Color

Polyline.Color

Rectangle.Color

RoundRect.Color

Row.SepOverride

RulingFmt.RulingSep

Tbl.TblBodyFirstColor

Tbl.TblBodyNextColor

Tbl.TblHFColor

TblFmt.TblBodyFirstColor

TblFmt.TblBodyNextColor

TblFmt.TblHFColor

TextFrame.Color

TextLine.Color

UnanchoredFrame.Color

Return

Color Doc.GetNamedColor (name: string)

Color Doc.NewNamedColor (name: string)


Adobe FrameMaker-12 Object Model JS: CombinedFont

Class

CombinedFont

QuickLinks

 CombinedFont

Properties

Property | Type | Access | Description
angle | uint | readwrite |
combinedFont | CombinedFontDefn | readwrite |
variation | uint | readwrite |
weight | uint | readwrite |

Methods

Constructor

CombinedFont CombinedFont (combinedFont: CombinedFontDefn, variation: uint, weight: uint, angle: uint)
Parameter | Type | Description
combinedFont | CombinedFontDefn |
variation | uint |
weight | uint |
angle | uint |

Example new CombinedFont()

Used in:

number CombinedFonts.push (value: CombinedFont)

Return

CombinedFont CombinedFont.CombinedFont (combinedFont: CombinedFontDefn, variation: uint, weight: uint, angle: uint)

CombinedFont CombinedFonts.pop ()


Adobe FrameMaker-12 Object Model JS: CombinedFontDefn

Class

CombinedFontDefn

QuickLinks

 CombinedFamilyFonts, Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
BaseFamily | int | readwrite |
FontEncodingName | string | readonly |
Name | string | readwrite |
NextCombinedFontDefnInDoc | CombinedFontDefn | readonly |
UserString | string | readwrite |
WesternFamily | int | readwrite |
WesternShift | int | readwrite |
WesternSize | int | readwrite |

Methods

Instances

CombinedFonts CombinedFamilyFonts ()

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

CharFmt.CombinedFontFamily

CombinedFont.combinedFont

CombinedFontDefn.NextCombinedFontDefnInDoc

Doc.CombinedFontFamily

Doc.FirstCombinedFontDefnInDoc

FmtChangeList.CombinedFontFamily

Pgf.CombinedFontFamily

PgfFmt.CombinedFontFamily

Used in:

CombinedFont CombinedFont.CombinedFont (combinedFont: CombinedFontDefn, variation: uint, weight: uint, angle: uint)

Return

CombinedFontDefn Doc.GetNamedCombinedFontDefn (name: string)

CombinedFontDefn Doc.NewNamedCombinedFontDefn (name: string)


Adobe FrameMaker-12 Object Model JS: CombinedFonts

Class

CombinedFonts

An Array of CombinedFont objects with integer indexing and a length property.

See also CombinedFont.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

CombinedFonts concat (value: CombinedFonts)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | CombinedFonts | Any number of values to be added to the end of the array. Can also be arrays.

CombinedFont pop ()
Removes the last element from the array.

number push (value: CombinedFont)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | CombinedFont |

Used in:

CombinedFonts CombinedFonts.concat (value: CombinedFonts)

Return

CombinedFonts CombinedFontDefn.CombinedFamilyFonts ()

CombinedFonts CombinedFonts.concat (value: CombinedFonts)


Adobe FrameMaker-12 Object Model JS: Command

Class

Command

QuickLinks

 Delete, Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
CanHaveCheckMark | int | readwrite |
CheckMarkIsOn | int | readwrite |
CommandNum | int | readwrite |
EnabledWhen | int | readwrite |
ExpandOMaticParent | Command | readonly |
Fcode | unsigned int | readonly |
Fcodes | UInts | readonly |
HasShiftOrUnshiftCommand | int | readwrite |
HelpLink | string | readwrite |
KeyboardShortcutLabel | string | readwrite |
KeyboardShortcuts | Strings String | readwrite |
Label | string | readwrite |
Labels | Strings String | readwrite |
MenuItemIsEnabled | int | readonly |
MenuItemType | int | readonly |
Mode | int | readonly |
Name | string | readonly |
NextCommandInSession | Command | readonly |
NextMenuItemInMenu | FMObject | readwrite |
NextMenuItemInSession | FMObject | readonly |
PrevMenuItemInMenu | FMObject | readwrite |
Product | int | readwrite |
ShiftOrUnshiftCommand | Command | readwrite |
View | int | readwrite |
Window | int | readwrite |

Methods

Instances

int Delete ()

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Command.ExpandOMaticParent

Command.NextCommandInSession

Command.ShiftOrUnshiftCommand

app.FirstCommandInSession

Used in:

number Menu.AddCommandToMenu (command: Command)

Return

Command Menu.DefineAndAddCommand (cmdNum: number, name: string, label: string, shortcut: string)

Command app.GetNamedCommand (name: string)

Command app.NewNamedCommand (name: string)


Adobe FrameMaker-12 Object Model JS: CompareRet

Class

CompareRet

QuickLinks

 CompareRet

Properties

Property | Type | Access | Description
comp | Doc | readwrite |
sum | Doc | readwrite |

Methods

Constructor

CompareRet CompareRet (sum: Doc, comp: Doc)
Parameter | Type | Description
sum | Doc |
comp | Doc |

Example new CompareRet()

Return

CompareRet Book.Compare (newerDoc: Doc, flags: int, insertCondTag: string, deleteCondTag: string, replaceText: string, compareThreshold: int)

CompareRet CompareRet.CompareRet (sum: Doc, comp: Doc)

CompareRet Doc.Compare (newerDoc: Doc, flags: int, insertCondTag: string, deleteCondTag: string, replaceText: string, compareThreshold: int)


Adobe FrameMaker-12 Object Model JS: CondFmt

Class

CondFmt

QuickLinks

 Delete, DeleteCondTag, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
BkColor | Color | readwrite |
CondFmtIsShown | int | readwrite |
Name | string | readwrite |
NextCondFmtInDoc | CondFmt | readonly |
SepOverride | Color | readwrite |
StyleOverride | int | readwrite |
UseBkColor | bool | readwrite |
UseSepOverride | int | readwrite |
UserString | string | readwrite |

Methods

Instances

int Delete ()

int DeleteCondTag (action: int)
Parameter | Type | Description
action | int |

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

CondFmt.NextCondFmtInDoc

Doc.FirstCondFmtInDoc

Return

CondFmt Doc.GetNamedCondFmt (name: string)

CondFmt Doc.NewNamedCondFmt (name: string)


Adobe FrameMaker-12 Object Model JS: Constants

Enumeration

Constants

Value

Name | Description | Value
Constants.EXCLUDE_GRAPHICS_DEPENDENCIES |  | int 0x01
Constants.EXCLUDE_NONE |  | int 0x10
Constants.EXCLUDE_OLE_DEPENDENCIES |  | int 0x04
Constants.EXCLUDE_TEXT_INSET_DEPENDENCIES |  | int 0x02
Constants.EXCLUDE_XREF_DEPENDENCIES |  | int 0x08
Constants.FA_CMSAdvancedSearch |  | int FA_CMSAdvancedSearch
Constants.FA_CMSBuildContextMenu |  | int FA_CMSBuildContextMenu
Constants.FA_CMSCloseConnection |  | int FA_CMSCloseConnection
Constants.FA_CMSCommandMax |  | int FA_CMSCommandMax
Constants.FA_CMSCommandMin |  | int FA_CMSCommandMin
Constants.FA_CMSCreateConnMgrUI |  | int FA_CMSCreateConnMgrUI
Constants.FA_CMSCreateConnection |  | int FA_CMSCreateConnection
Constants.FA_CMSGetCommandMaxOpCode |  | int FA_CMSGetCommandMaxOpCode
Constants.FA_CMSGetItemFromPath |  | int FA_CMSGetItemFromPath
Constants.FA_CMSGetItems |  | int FA_CMSGetItems
Constants.FA_CMSGetPropertyMaxOpCode |  | int FA_CMSGetPropertyMaxOpCode
Constants.FA_CMSIsValidCommand |  | int FA_CMSIsValidCommand
Constants.FA_CMSObjectCancelCheckout |  | int FA_CMSObjectCancelCheckout
Constants.FA_CMSObjectCheckin |  | int FA_CMSObjectCheckin
Constants.FA_CMSObjectCheckout |  | int FA_CMSObjectCheckout
Constants.FA_CMSObjectDelete |  | int FA_CMSObjectDelete
Constants.FA_CMSObjectDownload |  | int FA_CMSObjectDownload
Constants.FA_CMSObjectDownloadForOpen |  | int FA_CMSObjectDownloadForOpen
Constants.FA_CMSObjectDownloadItem |  | int FA_CMSObjectDownloadItem
Constants.FA_CMSObjectEdit |  | int FA_CMSObjectEdit
Constants.FA_CMSObjectGetChildren |  | int FA_CMSObjectGetChildren
Constants.FA_CMSObjectIsSame |  | int FA_CMSObjectIsSame
Constants.FA_CMSObjectOpenReadOnly |  | int FA_CMSObjectOpenReadOnly
Constants.FA_CMSObjectRefresh |  | int FA_CMSObjectRefresh
Constants.FA_CMSObjectShowCheckOutFiles |  | int FA_CMSObjectShowCheckOutFiles
Constants.FA_CMSObjectShowDependents |  | int FA_CMSObjectShowDependents
Constants.FA_CMSObjectShowProperties |  | int FA_CMSObjectShowProperties
Constants.FA_CMSObjectShowVersion |  | int FA_CMSObjectShowVersion
Constants.FA_CMSObjectUploadFile |  | int FA_CMSObjectUploadFile
Constants.FA_CMSObjectUploadFolder |  | int FA_CMSObjectUploadFolder
Constants.FA_CMSSetRootObject |  | int FA_CMSSetRootObject
Constants.FA_CMSSimpleSearch |  | int FA_CMSSimpleSearch
Constants.FA_COMPONENT_DEMOTE |  | int 4
Constants.FA_COMPONENT_MOVEDOWN |  | int 2
Constants.FA_COMPONENT_MOVEUP |  | int 1
Constants.FA_COMPONENT_PROMOTE |  | int 3
Constants.FA_Init_DocReport |  | int 4
Constants.FA_Init_First |  | int 1
Constants.FA_Init_Subsequent |  | int 2
Constants.FA_Init_TakeControl |  | int 3
Constants.FA_Note_AI_Supported_File |  | int 137
Constants.FA_Note_Alert |  | int 85
Constants.FA_Note_AssignId |  | int 115
Constants.FA_Note_BackToUser |  | int 34
Constants.FA_Note_BodyPageAdded |  | int 50
Constants.FA_Note_BodyPageDeleted |  | int 51
Constants.FA_Note_ClientCall |  | int 13
Constants.FA_Note_ConsoleMessage |  | int 88
Constants.FA_Note_CursorChange |  | int 91
Constants.FA_Note_DITAOptions |  | int 116
Constants.FA_Note_Dialog |  | int 84
Constants.FA_Note_Dialog_Create |  | int 127
Constants.FA_Note_DirtyBook |  | int 25
Constants.FA_Note_DirtyDoc |  | int 12
Constants.FA_Note_DisplayClientTiDialog |  | int 35
Constants.FA_Note_DisplayClientXRefDialog |  | int 108
Constants.FA_Note_ECMInternal |  | int 66
Constants.FA_Note_Enable_Disable_DITA_Menu_Commands |  | int 126
Constants.FA_Note_EnumeratedComponent |  | int 145
Constants.FA_Note_FileOpen |  | int 94
Constants.FA_Note_FilterFileToFile |  | int 75
Constants.FA_Note_FilterIn |  | int 14
Constants.FA_Note_FilterOut |  | int 15
Constants.FA_Note_FontSubstitution |  | int 92
Constants.FA_Note_GenerateFM |  | int 112
Constants.FA_Note_Help |  | int 89
Constants.FA_Note_InsertConRef |  | int 111
Constants.FA_Note_InsertTopicRef |  | int 110
Constants.FA_Note_IsCommandEnabled |  | int 148
Constants.FA_Note_LoadKeyCatalog |  | int 143
Constants.FA_Note_MATHML_CHANGE_NSPREFIX |  | int 156
Constants.FA_Note_MATHML_DblClicked |  | int 151
Constants.FA_Note_MATHML_Deselected |  | int 150
Constants.FA_Note_MATHML_GenerateImage |  | int 152
Constants.FA_Note_MATHML_PopulateObj |  | int 153
Constants.FA_Note_MATHML_Selected |  | int 149
Constants.FA_Note_NewBookmapFile |  | int 118
Constants.FA_Note_NewConceptFile |  | int 121
Constants.FA_Note_NewDitamapFile |  | int 117
Constants.FA_Note_NewGlossEntryFile |  | int 123
Constants.FA_Note_NewReferenceFile |  | int 122
Constants.FA_Note_NewTaskFile |  | int 120
Constants.FA_Note_NewTopicFile |  | int 119
Constants.FA_Note_Not_AI_Supported_File |  | int 136
Constants.FA_Note_Not_RSC_Supported_File |  | int 103
Constants.FA_Note_Not_SWF_File |  | int 125
Constants.FA_Note_Not_U3DCommand |  | int 102
Constants.FA_Note_Num |  | int 158
Constants.FA_Note_OpenAllTopicrefs |  | int 113
Constants.FA_Note_Open_Dtd |  | int 132
Constants.FA_Note_Open_EDD_For_App |  | int 134
Constants.FA_Note_Open_Schema |  | int 133
Constants.FA_Note_Palette |  | int 86
Constants.FA_Note_PostActiveDocChange |  | int 105
Constants.FA_Note_PostAutoSaveDoc |  | int 33
Constants.FA_Note_PostBookComponentOpen |  | int 77
Constants.FA_Note_PostChangeElement |  | int 55
Constants.FA_Note_PostCopyElement |  | int 61
Constants.FA_Note_PostCreateMML |  | int 155
Constants.FA_Note_PostDistill |  | int 74
Constants.FA_Note_PostDragElement |  | int 59
Constants.FA_Note_PostExport |  | int 68
Constants.FA_Note_PostFileType |  | int 10
Constants.FA_Note_PostFunction |  | int 43
Constants.FA_Note_PostGenerate |  | int 79
Constants.FA_Note_PostGoToXrefSrc |  | int 81
Constants.FA_Note_PostHypertext |  | int 47
Constants.FA_Note_PostImport |  | int 39
Constants.FA_Note_PostImportElemDefs |  | int 65
Constants.FA_Note_PostInlineTypeIn |  | int 70
Constants.FA_Note_PostInsertElement |  | int 53
Constants.FA_Note_PostMouseCommand |  | int 45
Constants.FA_Note_PostOpenBook |  | int 17
Constants.FA_Note_PostOpenBookMIF |  | int 19
Constants.FA_Note_PostOpenDoc |  | int 2
Constants.FA_Note_PostOpenMIF |  | int 4
Constants.FA_Note_PostOpenSGML |  | int 83
Constants.FA_Note_PostOpenXML |  | int 96
Constants.FA_Note_PostPrint |  | int 49
Constants.FA_Note_PostPublishDitamap |  | int 140
Constants.FA_Note_PostQuitBook |  | int 41
Constants.FA_Note_PostQuitDoc |  | int 40
Constants.FA_Note_PostQuitSession |  | int 27
Constants.FA_Note_PostRevertBook |  | int 31
Constants.FA_Note_PostRevertDoc |  | int 29
Constants.FA_Note_PostSaveAsPDFDialog |  | int 72
Constants.FA_Note_PostSaveBook |  | int 21
Constants.FA_Note_PostSaveBookMIF |  | int 23
Constants.FA_Note_PostSaveDoc |  | int 6
Constants.FA_Note_PostSaveMIF |  | int 8
Constants.FA_Note_PostSaveSGML |  | int 100
Constants.FA_Note_PostSaveXML |  | int 98
Constants.FA_Note_PostSetAttrValue |  | int 63
Constants.FA_Note_PostSetPropertyValue |  | int 135
Constants.FA_Note_PostSwitchView |  | int 147
Constants.FA_Note_PostUpdateXRefs |  | int 107
Constants.FA_Note_PostWrapElement |  | int 57
Constants.FA_Note_Poster_Applied |  | int 138
Constants.FA_Note_PreAutoSaveDoc |  | int 32
Constants.FA_Note_PreBookComponentOpen |  | int 76
Constants.FA_Note_PreChangeElement |  | int 54
Constants.FA_Note_PreCopyElement |  | int 60
Constants.FA_Note_PreCreateMML |  | int 154
Constants.FA_Note_PreDistill |  | int 73
Constants.FA_Note_PreDragElement |  | int 58
Constants.FA_Note_PreExport |  | int 67
Constants.FA_Note_PreFileType |  | int 9
Constants.FA_Note_PreFunction |  | int 42
Constants.FA_Note_PreGenerate |  | int 78
Constants.FA_Note_PreGoToXrefSrc |  | int 80
Constants.FA_Note_PreHypertext |  | int 46
Constants.FA_Note_PreImport |  | int 38
Constants.FA_Note_PreImportElemDefs |  | int 64
Constants.FA_Note_PreInlineTypeIn |  | int 69
Constants.FA_Note_PreInsertElement |  | int 52
Constants.FA_Note_PreMouseCommand |  | int 44
Constants.FA_Note_PreOpenBook |  | int 16
Constants.FA_Note_PreOpenBookMIF |  | int 18
Constants.FA_Note_PreOpenDoc |  | int 1
Constants.FA_Note_PreOpenMIF |  | int 3
Constants.FA_Note_PreOpenSGML |  | int 82
Constants.FA_Note_PreOpenXML |  | int 95
Constants.FA_Note_PrePrint |  | int 48
Constants.FA_Note_PrePublishDitamap |  | int 139
Constants.FA_Note_PreQuitBook |  | int 24
Constants.FA_Note_PreQuitDoc |  | int 11
Constants.FA_Note_PreQuitSession |  | int 26
Constants.FA_Note_PreRevertBook |  | int 30
Constants.FA_Note_PreRevertDoc |  | int 28
Constants.FA_Note_PreSaveAsPDFDialog |  | int 71
Constants.FA_Note_PreSaveBook |  | int 20
Constants.FA_Note_PreSaveBookMIF |  | int 22
Constants.FA_Note_PreSaveDoc |  | int 5
Constants.FA_Note_PreSaveMIF |  | int 7
Constants.FA_Note_PreSaveSGML |  | int 99
Constants.FA_Note_PreSaveXML |  | int 97
Constants.FA_Note_PreSetAttrValue |  | int 62
Constants.FA_Note_PreSetPropertyValue |  | int 157
Constants.FA_Note_PreSwitchView |  | int 146
Constants.FA_Note_PreUpdateXRefs |  | int 106
Constants.FA_Note_PreWrapElement |  | int 56
Constants.FA_Note_QuitModelessDialog |  | int 109
Constants.FA_Note_RSC_Supported_File |  | int 104
Constants.FA_Note_ReLoadKeyCatalog |  | int 144
Constants.FA_Note_Read_Struct_App |  | int 130
Constants.FA_Note_SWF_File |  | int 124
Constants.FA_Note_SetAttrValue |  | int 128
Constants.FA_Note_Struct_Wizard |  | int 131
Constants.FA_Note_ToolBar |  | int 87
Constants.FA_Note_U3DCommand |  | int 101
Constants.FA_Note_URL |  | int 90
Constants.FA_Note_UndoCheckpoint |  | int 93
Constants.FA_Note_UpdateAllClientTi |  | int 36
Constants.FA_Note_UpdateClientTi |  | int 37
Constants.FA_Note_UpdateDITAReference |  | int 141
Constants.FA_Note_UpdateDITAReferences |  | int 142
Constants.FA_Note_UpdateRefs |  | int 114
Constants.FA_Note_UpdateRefs_On_Save |  | int 129
Constants.FDK_LIBRARY_VERSION |  | int 0x12000000
Constants.FE_AcceptRejectCalledOnWrongPreviewState |  | int -110
Constants.FE_AsianSystemRequired |  | int -90
Constants.FE_BadBaseColor |  | int -97
Constants.FE_BadBookId |  | int -66
Constants.FE_BadCompPath |  | int -68
Constants.FE_BadCompare |  | int -35
Constants.FE_BadContainer |  | int -104
Constants.FE_BadDelete |  | int -17
Constants.FE_BadDocId |  | int -2
Constants.FE_BadElementDefId |  | int -28
Constants.FE_BadElementId |  | int -29
Constants.FE_BadElementSelection |  | int -69
Constants.FE_BadFamilyName |  | int -98
Constants.FE_BadFileType |  | int -83
Constants.FE_BadFilterType |  | int -184
Constants.FE_BadInkName |  | int -99
Constants.FE_BadInsertPos |  | int -65
Constants.FE_BadKey |  | int -177
Constants.FE_BadKeyField |  | int -178
Constants.FE_BadMenuBar |  | int -77
Constants.FE_BadName |  | int -33
Constants.FE_BadNew |  | int -23
Constants.FE_BadNewFrame |  | int -14
Constants.FE_BadNewGroup |  | int -15
Constants.FE_BadNewSibling |  | int -16
Constants.FE_BadNotificationNum |  | int -30
Constants.FE_BadObjId |  | int -3
Constants.FE_BadOperation |  | int -27
Constants.FE_BadPageDelete |  | int -18
Constants.FE_BadParameter |  | int -43
Constants.FE_BadPropNum |  | int -4
Constants.FE_BadPropType |  | int -5
Constants.FE_BadRange |  | int -36
Constants.FE_BadRefElementId |  | int -64
Constants.FE_BadRefFlowId |  | int -62
Constants.FE_BadSaveFileName |  | int -50
Constants.FE_BadSelectionForOperation |  | int -59
Constants.FE_BadShortcut |  | int -76
Constants.FE_BadTemplatePath |  | int -105
Constants.FE_BadValue |  | int -179
Constants.FE_BadXRefSrcDocId |  | int -103
Constants.FE_BadXmlApplication |  | int -106
Constants.FE_BookComponentAlreadyHasTrackedEdits |  | int -109
Constants.FE_BookStructured |  | int -61
Constants.FE_BookUnStructured |  | int -67
Constants.FE_Busy |  | int -88
Constants.FE_CMSBadCommandId |  | int -116
Constants.FE_CMSBadItemContainerType |  | int -121
Constants.FE_CMSBadItemFileType |  | int -119
Constants.FE_CMSBadItemType |  | int -120
Constants.FE_CMSBadObjectId |  | int -114
Constants.FE_CMSBadSessionId |  | int -113
Constants.FE_CMSFailedCancelCheckout |  | int -153
Constants.FE_CMSFailedCheckin |  | int -152
Constants.FE_CMSFailedCheckout |  | int -151
Constants.FE_CMSFailedDelete |  | int -154
Constants.FE_CMSFailedDownloadObject |  | int -157
Constants.FE_CMSFailedGetItemFrompath |  | int -158
Constants.FE_CMSFailedLogin |  | int -150
Constants.FE_CMSFailedLogout |  | int -159
Constants.FE_CMSFailedOpenFile |  | int -155
Constants.FE_CMSFailedUploadObject |  | int -156
Constants.FE_CMSIsValidCMSCommand |  | int -123
Constants.FE_CMSNameAlreadyRegistered |  | int -112
Constants.FE_CMSObjectCreationFailed |  | int -117
Constants.FE_CMSRootObjectExists |  | int -118
Constants.FE_CMSSessionCreationFailed |  | int -122
Constants.FE_CMSSessionFailed |  | int -115
Constants.FE_Canceled |  | int -44
Constants.FE_CanceledByClient |  | int -86
Constants.FE_CantSmooth |  | int -38
Constants.FE_CantUpdateMacEdition |  | int -85
Constants.FE_CircularReference |  | int -81
Constants.FE_CompareTypes |  | int -34
Constants.FE_Disabled |  | int -196
Constants.FE_DocAlreadyHasTrackedEdits |  | int -108
Constants.FE_DocModified |  | int -8
Constants.FE_DupName |  | int -32
Constants.FE_EmptyTextObject |  | int -87
Constants.FE_FDKUndoNotAllowed |  | int -193
Constants.FE_FailedExportedFileInvalid |  | int -111
Constants.FE_FailedState |  | int -45
Constants.FE_FileClosedByClient |  | int -70
Constants.FE_FilterFailed |  | int -89
Constants.FE_FlowStructured |  | int -63
Constants.FE_GenRuleAmbiguous |  | int -55
Constants.FE_GenRuleConnectorExpected |  | int -57
Constants.FE_GenRuleItemExpected |  | int -51
Constants.FE_GenRuleLeftBracketExpected |  | int -53
Constants.FE_GenRuleMixedConnectors |  | int -52
Constants.FE_GenRuleRightBracketExpected |  | int -54
Constants.FE_GenRuleSyntaxError |  | int -56
Constants.FE_GraphicInLockedTi |  | int -207
Constants.FE_GroupSelect |  | int -9
Constants.FE_HiddenPage |  | int -40
Constants.FE_InternalErrorFailedToWriteInsets |  | int -94
Constants.FE_InvAttribute |  | int -80
Constants.FE_InvAttributeDef |  | int -79
Constants.FE_InvalidAttrExpr |  | int -107
Constants.FE_InvalidString |  | int -58
Constants.FE_KeyCatalogIsStale |  | int -181
Constants.FE_KeyCatalogNotLoaded |  | int -180
Constants.FE_KeyCatalogNotSpecified |  | int -185
Constants.FE_KeyDefinitionAlreadyExists |  | int -183
Constants.FE_KeyDefinitionDoesNotExist |  | int -182
Constants.FE_LanguageNotAvailable |  | int -96
Constants.FE_MissingFile |  | int -84
Constants.FE_NameNotFound |  | int -20
Constants.FE_NoColorFamily |  | int -92
Constants.FE_NoSuchFlow |  | int -82
Constants.FE_NonDITADocument |  | int -186
Constants.FE_NotApiCommand |  | int -74
Constants.FE_NotBodyPage |  | int -24
Constants.FE_NotBookComponent |  | int -26
Constants.FE_NotCommand |  | int -73
Constants.FE_NotFound |  | int -95
Constants.FE_NotFrame |  | int -12
Constants.FE_NotGraphic |  | int -11
Constants.FE_NotGroup |  | int -13
Constants.FE_NotInMenu |  | int -75
Constants.FE_NotMenu |  | int -72
Constants.FE_NotPgf |  | int -25
Constants.FE_NotPgfOrFlow |  | int -71
Constants.FE_NotTextFrame |  | int -39
Constants.FE_NotTextObject |  | int -41
Constants.FE_OffsetNotFound |  | int -21
Constants.FE_OutOfRange |  | int -7
Constants.FE_PageFrame |  | int -37
Constants.FE_PropNotSet |  | int -78
Constants.FE_ReadOnly |  | int -6
Constants.FE_ReservedColor |  | int -100
Constants.FE_SomeUnresolved |  | int -22
Constants.FE_StringTooLong |  | int -93
Constants.FE_Success |  | int 0
Constants.FE_SystemError |  | int -42
Constants.FE_TableInLockedTi |  | int -101
Constants.FE_TintedColor |  | int -91
Constants.FE_Transport |  | int -1
Constants.FE_TypeUnNamed |  | int -19
Constants.FE_UnLicensed |  | int -197
Constants.FE_UpdateDITAReferenceFailed |  | int -192
Constants.FE_UpdateDITAReferenceFailedCannotConvertToFMObject |  | int -191
Constants.FE_UpdateDITAReferenceFailedCannotFindReferencedFile |  | int -189
Constants.FE_UpdateDITAReferenceFailedCannotOpenReferencedFile |  | int -190
Constants.FE_UpdateDITAReferenceFailedCannotResolveReference |  | int -188
Constants.FE_UpdateDITAReferenceFailedInvalidElementType |  | int -187
Constants.FE_ViewOnly |  | int -49
Constants.FE_WantsCustom |  | int -46
Constants.FE_WantsLandscape |  | int -47
Constants.FE_WantsPortrait |  | int -48
Constants.FE_WithinFrame |  | int -10
Constants.FE_WrongProduct |  | int -60
Constants.FE_WrongView |  | int -194
Constants.FE_WrongWindow |  | int -195
Constants.FE_XRefUnresolved |  | int -102
Constants.FF_ALERT_CANCEL_DEFAULT |  | int 1
Constants.FF_ALERT_CONTINUE_NOTE |  | int 2
Constants.FF_ALERT_CONTINUE_WARN |  | int 3
Constants.FF_ALERT_DNS_OK |  | int 7
Constants.FF_ALERT_NO_DEFAULT |  | int 5
Constants.FF_ALERT_OK_DEFAULT |  | int 0
Constants.FF_ALERT_YES_DEFAULT |  | int 4
Constants.FF_ALERT_YES_NO_CANCEL |  | int 6
Constants.FF_ALT_KEY |  | int 0x0004
Constants.FF_ATTACH_ALL |  | int (0x0001|0x0002|0x0004|0x0008|0x0010)
Constants.FF_ATTACH_BORDER_PAGENUM |  | int 0x0002
Constants.FF_ATTACH_BORDER_PAGEUPDOWN |  | int 0x0008
Constants.FF_ATTACH_BORDER_RIGHTICONS |  | int 0x0010
Constants.FF_ATTACH_BORDER_STATUS |  | int 0x0001
Constants.FF_ATTACH_BORDER_ZOOM |  | int 0x0004
Constants.FF_ATTRDISP |  | int 86
Constants.FF_ATTRDISP_ALL |  | int 87
Constants.FF_ATTR_SEL |  | int 89
Constants.FF_BOR_EXT |  | int 72
Constants.FF_BOR_SEL |  | int 71
Constants.FF_BUBBLE_CONTEXT |  | int 49
Constants.FF_BUBBLE_COPY |  | int 55
Constants.FF_BUBBLE_EXT |  | int 54
Constants.FF_BUBBLE_EXT_CONTEXT |  | int 50
Constants.FF_BUBBLE_SEL |  | int 53
Constants.FF_CELLS_RES |  | int 25
Constants.FF_CELL_EXT |  | int 22
Constants.FF_CELL_RES |  | int 24
Constants.FF_CELL_SEL |  | int 21
Constants.FF_CLEAR_SEL |  | int 0
Constants.FF_CLOSE_MODIFIED |  | int 1
Constants.FF_CMD_KEY |  | int 0x0010
Constants.FF_CMP_ATTRIBUTES |  | int 0x20
Constants.FF_CMP_CHANGE_BARS |  | int 0x02
Constants.FF_CMP_COMPKIT |  | int 0x10
Constants.FF_CMP_HYPERLINKS |  | int 0x04
Constants.FF_CMP_SUMKIT |  | int 0x08
Constants.FF_CMP_SUMMARY_ONLY |  | int 0x01
Constants.FF_COLLAPSE_ALL |  | int 57
Constants.FF_COLLAPSE_ELEM |  | int 56
Constants.FF_CONTEXT_DRAG |  | int 73
Constants.FF_CONTEXT_DRAGTXT |  | int 4
Constants.FF_CONTEXT_DRAG_EXT |  | int 74
Constants.FF_CONTEXT_MENU |  | int 33
Constants.FF_CONTROL_KEY |  | int 0x0002
Constants.FF_COPY_TO_CLIP |  | int 13
Constants.FF_CUT_TBL_CELLS |  | int 0x0002
Constants.FF_Custom_FirstPageLeft |  | int 2
Constants.FF_Custom_FirstPageRight |  | int 1
Constants.FF_Custom_SingleSided |  | int 0
Constants.FF_DIALOG_ALL |  | int 0xFFFF
Constants.FF_DIALOG_INSET_POD |  | int 0x01
Constants.FF_DITAUpdateAllConrefs |  | int 0x01
Constants.FF_DITAUpdateAllLinks |  | int 0x04
Constants.FF_DITAUpdateAllReferences |  | int (0x01|0x02|0x04|0x08|0x10)
Constants.FF_DITAUpdateAllTopicrefs |  | int 0x08
Constants.FF_DITAUpdateAllTopicsetrefs |  | int 0x10
Constants.FF_DITAUpdateAllXrefs |  | int 0x02
Constants.FF_DONT_APPLY_ALL_ROWS |  | int 0x0040
Constants.FF_DONT_DELETE_HIDDEN_TEXT |  | int 0x0004
Constants.FF_DUPLICATE_KEY_DEFINITION |  | int 0x01
Constants.FF_EDIT_ATTRIBUTE |  | int 88
Constants.FF_ELEMENT_CONTEXT |  | int 47
Constants.FF_ELEMENT_EXT |  | int 52
Constants.FF_ELEMENT_EXT_CONTEXT |  | int 48
Constants.FF_ELEMENT_SEL |  | int 51
Constants.FF_FOUND_IN_REFERENCED_FILE |  | int 0x02
Constants.FF_HYPERTEXT |  | int 41
Constants.FF_IED_DELETE_EMPTY_PAGES |  | int 0x0010
Constants.FF_IED_DO_NOT_IMPORT_EDD |  | int 0x0004
Constants.FF_IED_DO_NOT_IMPORT_STRUCTAPP |  | int 0x0040
Constants.FF_IED_NO_NOTIFY |  | int 0x0008
Constants.FF_IED_REMOVE_BOOK_INFO |  | int 0x0002
Constants.FF_IED_REMOVE_OVERRIDES |  | int 0x0001
Constants.FF_IMAGE_BACKGROUND |  | int 0x0001
Constants.FF_IMAGE_CLIP |  | int 0x0004
Constants.FF_IMAGE_MASTER |  | int 0x0002
Constants.FF_IMAGE_NOTRIM |  | int 0x0008
Constants.FF_IMAGE_PAGEFRAME |  | int 0x000F
Constants.FF_INSERT_BELOW_RIGHT |  | int 0x0008
Constants.FF_INTERACTIVE |  | int 0x0001
Constants.FF_INVALID_KEY |  | int 0x04
Constants.FF_OBJ_CROTATE |  | int 67
Constants.FF_OBJ_EXT |  | int 63
Constants.FF_OBJ_EXT_BOR |  | int 64
Constants.FF_OBJ_Q_COPY |  | int 65
Constants.FF_OBJ_ROTATE |  | int 66
Constants.FF_OBJ_SEL |  | int 62
Constants.FF_OPEN_BOOK_COMP |  | int 58
Constants.FF_PASTE_CLIP_OBJ |  | int 61
Constants.FF_PASTE_CLIP_TEXT |  | int 12
Constants.FF_PASTE_SEL_TEXT |  | int 11
Constants.FF_REPLACE_CELLS |  | int 0x0020
Constants.FF_RES_ADD |  | int 84
Constants.FF_RES_DEL |  | int 85
Constants.FF_RES_MOVE |  | int 81
Constants.FF_RES_MOVE1 |  | int 82
Constants.FF_RES_VERTEX |  | int 83
Constants.FF_SELECT_WHOLE_TABLE |  | int 0x80000000
Constants.FF_SHIFT_KEY |  | int 0x0001
Constants.FF_STRIP_HYPERTEXT |  | int 0x0080
Constants.FF_STRUCTURE_MENU |  | int 34
Constants.FF_TABLE_SELALL |  | int 23
Constants.FF_TEXT_EXT |  | int 2
Constants.FF_TEXT_Q_COPY |  | int 3
Constants.FF_TEXT_SEL |  | int 1
Constants.FF_UFF_ALL |  | int 0xFFFF
Constants.FF_UFF_COLOR |  | int 0x0100
Constants.FF_UFF_COMBINED_FONTS |  | int 0x0800
Constants.FF_UFF_COND |  | int 0x0010
Constants.FF_UFF_DOCUMENT_PROPS |  | int 0x0400
Constants.FF_UFF_FBA |  | int 0x1000
Constants.FF_UFF_FONT |  | int 0x0002
Constants.FF_UFF_MATH |  | int 0x0200
Constants.FF_UFF_PAGE |  | int 0x0004
Constants.FF_UFF_PGF |  | int 0x0001
Constants.FF_UFF_REFPAGE |  | int 0x0020
Constants.FF_UFF_REMOVE_EXCEPTIONS |  | int 0x8000
Constants.FF_UFF_REMOVE_PAGE_BREAKS |  | int 0x4000
Constants.FF_UFF_STYLE |  | int 0x2000
Constants.FF_UFF_TABLE |  | int 0x0008
Constants.FF_UFF_VAR |  | int 0x0040
Constants.FF_UFF_XREF |  | int 0x0080
Constants.FF_UNTAGGED_ASK |  | int 0
Constants.FF_UNTAGGED_DELETE |  | int 2
Constants.FF_UNTAGGED_UNCOND |  | int 1
Constants.FF_VIEWER_MENU |  | int 32
Constants.FF_VISIBLE_ONLY |  | int 0x0010
Constants.FF_XRUI_CLOSED_DOCS |  | int 0x04
Constants.FF_XRUI_EVERYTHING |  | int (0x01|0x02|0x04)
Constants.FF_XRUI_FORCE_UPDATE |  | int 0x08
Constants.FF_XRUI_INTERNAL |  | int 0x01
Constants.FF_XRUI_OPEN_DOCS |  | int 0x02
Constants.FI_PLUGIN_DESCRIPTION |  | int 4
Constants.FI_PLUGIN_FACET |  | int 6
Constants.FI_PLUGIN_FORMATID |  | int 7
Constants.FI_PLUGIN_INFORMAT |  | int 10
Constants.FI_PLUGIN_NAME |  | int 2
Constants.FI_PLUGIN_OUTFORMAT |  | int 11
Constants.FI_PLUGIN_PRODUCTNAME |  | int 1
Constants.FI_PLUGIN_PRODUCTS |  | int 5
Constants.FI_PLUGIN_SUFFIX |  | int 9
Constants.FI_PLUGIN_TYPE |  | int 3
Constants.FI_PLUGIN_VENDOR |  | int 8
Constants.FMV_CMDSUPPORTED |  | int -1
Constants.FO_AFrame |  | int 23
Constants.FO_Alert |  | int 69
Constants.FO_AnchoredFrame |  | int 23
Constants.FO_Arc |  | int 11
Constants.FO_AttrCondExpr |  | int 71
Constants.FO_Bad |  | int 255
Constants.FO_BodyPage |  | int 5
Constants.FO_Book |  | int 2
Constants.FO_BookComponent |  | int 3
Constants.FO_CMSConnection |  | int (81+15)
Constants.FO_CMSObject |  | int 76
Constants.FO_CMSObject2 |  | int (81+16)
Constants.FO_CMSRegistration |  | int 74
Constants.FO_CMSSession |  | int 75
Constants.FO_Cblock |  | int (81+3)
Constants.FO_Cell |  | int 39
Constants.FO_CharFmt |  | int 33
Constants.FO_Color |  | int 35
Constants.FO_CombinedFontDefn |  | int 67
Constants.FO_Command |  | int 56
Constants.FO_CondFmt |  | int 34
Constants.FO_CursorResource |  | int 70
Constants.FO_DBGroup |  | int 22
Constants.FO_DialogResource |  | int 43
Constants.FO_DitaMap |  | int (81+13)
Constants.FO_DlgBox |  | int 44
Constants.FO_DlgButton |  | int 45
Constants.FO_DlgCheckBox |  | int 47
Constants.FO_DlgDate |  | int 80
Constants.FO_DlgEditBox |  | int 50
Constants.FO_DlgImage |  | int 53
Constants.FO_DlgLabel |  | int 52
Constants.FO_DlgListView |  | int 72
Constants.FO_DlgPopUp |  | int 48
Constants.FO_DlgRadioButton |  | int 51
Constants.FO_DlgScrollBar |  | int 54
Constants.FO_DlgScrollBox |  | int 49
Constants.FO_DlgTriBox |  | int 46
Constants.FO_Doc |  | int 4
Constants.FO_Element |  | int 42
Constants.FO_ElementDef |  | int 41
Constants.FO_Ellipse |  | int 13
Constants.FO_First_Internal |  | int 81
Constants.FO_Flow |  | int 30
Constants.FO_FmtChangeList |  | int 58
Constants.FO_FmtRule |  | int 59
Constants.FO_FmtRuleClause |  | int 60
Constants.FO_Fn |  | int 25
Constants.FO_Frame |  | int (81+2)
Constants.FO_Graphic |  | int (81+1)
Constants.FO_GraphicsFmt |  | int 73
Constants.FO_Group |  | int 10
Constants.FO_HiddenPage |  | int 8
Constants.FO_Inset |  | int 20
Constants.FO_Iterator |  | int 78
Constants.FO_KeyCatalog |  | int 77
Constants.FO_Last_Graphic |  | int 22
Constants.FO_Last_Internal |  | int (81+14)
Constants.FO_Last_Page |  | int 8
Constants.FO_Line |  | int 17
Constants.FO_Marker |  | int 24
Constants.FO_MarkerType |  | int 66
Constants.FO_MasterPage |  | int 6
Constants.FO_Math |  | int 21
Constants.FO_MathML |  | int 79
Constants.FO_Menu |  | int 55
Constants.FO_MenuCell |  | int (81+11)
Constants.FO_MenuItemSeparator |  | int 57
Constants.FO_Num |  | int 81
Constants.FO_Page |  | int (81+0)
Constants.FO_Pgf |  | int 31
Constants.FO_PgfFmt |  | int 32
Constants.FO_Polygon |  | int 16
Constants.FO_Polyline |  | int 15
Constants.FO_Rectangle |  | int 12
Constants.FO_RefPage |  | int 7
Constants.FO_RoundRect |  | int 14
Constants.FO_Row |  | int 38
Constants.FO_Rubi |  | int 68
Constants.FO_RulingFmt |  | int 40
Constants.FO_Session |  | int 0
Constants.FO_StringResource |  | int 1
Constants.FO_SubCell |  | int (81+7)
Constants.FO_SubCol |  | int 65
Constants.FO_SubCond |  | int (81+4)
Constants.FO_SubDash |  | int (81+6)
Constants.FO_SubPblock |  | int (81+9)
Constants.FO_SubStyle |  | int (81+5)
Constants.FO_SubTbl |  | int (81+8)
Constants.FO_SubTextDef |  | int (81+10)
Constants.FO_Tbl |  | int 36
Constants.FO_TblFmt |  | int 37
Constants.FO_TextFrame |  | int 19
Constants.FO_TextInset |  | int (81+12)
Constants.FO_TextLine |  | int 18
Constants.FO_TiApiClient |  | int 64
Constants.FO_TiFlow |  | int 61
Constants.FO_TiText |  | int 62
Constants.FO_TiTextTable |  | int 63
Constants.FO_UFrame |  | int 9
Constants.FO_UnanchoredFrame |  | int 9
Constants.FO_Var |  | int 28
Constants.FO_VarFmt |  | int 29
Constants.FO_XLast_Graphic |  | int 23
Constants.FO_XRef |  | int 26
Constants.FO_XRefFmt |  | int 27
Constants.FP_AFrameIsCropped |  | int 878
Constants.FP_AFrameIsFloating |  | int 876
Constants.FP_AcrobatBookmarkDisplayTags |  | int 2251
Constants.FP_AcrobatLevel |  | int 589
Constants.FP_ActiveAlert |  | int 105
Constants.FP_ActiveBook |  | int 52
Constants.FP_ActiveDoc |  | int 51
Constants.FP_ActiveView |  | int 2422
Constants.FP_AddMarkerTypeToStandardMarkers |  | int 150
Constants.FP_AdjHyphens |  | int 559
Constants.FP_AlertClientName |  | int 2291
Constants.FP_AlertClientUnique |  | int 2290
Constants.FP_AlertString |  | int 2292
Constants.FP_AlertType |  | int 2293
Constants.FP_Alignment |  | int 886
Constants.FP_AllowAsSpecialCase |  | int 1649
Constants.FP_AllowBaseFamilyBoldedAndObliqued |  | int 2283
Constants.FP_AllowNewFileURL |  | int 2416
Constants.FP_AllowedDataRange |  | int 1594
Constants.FP_AlsoInsert |  | int 1591
Constants.FP_AlsoInserts |  | int 1595
Constants.FP_AnchorType |  | int 875
Constants.FP_Angle |  | int 780
Constants.FP_ApplyEOPRules |  | int 2030
Constants.FP_ApplyFormatRules |  | int 93
Constants.FP_ArrowBaseAngle |  | int 746
Constants.FP_ArrowLength |  | int 748
Constants.FP_ArrowScaleFactor |  | int 747
Constants.FP_ArrowScaleHead |  | int 750
Constants.FP_ArrowTipAngle |  | int 745
Constants.FP_ArrowType |  | int 749
Constants.FP_AttrCondExprIsActive |  | int 2818
Constants.FP_AttrCondExprStr |  | int 2817
Constants.FP_AttrDisplay |  | int 1635
Constants.FP_AttributeDefs |  | int 1584
Constants.FP_AttributeValueInvalid |  | int 1667
Constants.FP_AttributeValueRequired |  | int 1666
Constants.FP_Attributes |  | int 1634
Constants.FP_AttributesEx |  | int 1670
Constants.FP_AutoBackup |  | int 50
Constants.FP_AutoChangeBars |  | int 238
Constants.FP_AutoNumChar |  | int 549
Constants.FP_AutoNumString |  | int 548
Constants.FP_AutoSave |  | int 48
Constants.FP_AutoSaveSeconds |  | int 49
Constants.FP_BIBGetAddressProc |  | int 2299
Constants.FP_BannerText |  | int 1599
Constants.FP_BannerTextDisplay |  | int 1600
Constants.FP_BaseFamily |  | int 2282
Constants.FP_BasePointX |  | int 1116
Constants.FP_BasePointY |  | int 1117
Constants.FP_BaselineOffset |  | int 881
Constants.FP_BkColor |  | int 992
Constants.FP_BkGndColor |  | int 1502
Constants.FP_Black |  | int 1460
Constants.FP_BlockLines |  | int 561
Constants.FP_BookComponent |  | int 1628
Constants.FP_BookComponentFileType |  | int 2339
Constants.FP_BookComponentIsFolderWithTemplate |  | int 2341
Constants.FP_BookComponentIsFolderWithoutTemplate |  | int 2342
Constants.FP_BookComponentIsGeneratable |  | int 520
Constants.FP_BookComponentMissing |  | int 1662
Constants.FP_BookComponentParent |  | int 2325
Constants.FP_BookComponentSequenceLevel |  | int 2353
Constants.FP_BookComponentTemplatePath |  | int 2327
Constants.FP_BookComponentTitle |  | int 2328
Constants.FP_BookComponentType |  | int 531
Constants.FP_BookDontUpdateReferences |  | int 494
Constants.FP_BookIsModified |  | int 492
Constants.FP_BookIsSelected |  | int 499
Constants.FP_BookIsViewOnly |  | int 497
Constants.FP_BookParent |  | int 515
Constants.FP_BooleanConditionExpression |  | int 2321
Constants.FP_BooleanConditionExpressionTag |  | int 995
Constants.FP_BooleanConditionState |  | int 2322
Constants.FP_BorderWidth |  | int 740
Constants.FP_BottomMargin |  | int 231
Constants.FP_BottomRowSelection |  | int 1342
Constants.FP_BottomSepAtIndent |  | int 2010
Constants.FP_BottomSeparator |  | int 569
Constants.FP_Box_BG_Color |  | int 1722
Constants.FP_CMSItemProperty_ItemCheckedOutByCurrentUser |  | int FP_CMSItemProperty_ItemCheckedOutByCurrentUser
Constants.FP_CMSItemProperty_ItemFileType |  | int FP_CMSItemProperty_ItemFileType
Constants.FP_CMSItemProperty_ItemIsCheckedOut |  | int FP_CMSItemProperty_ItemIsCheckedOut
Constants.FP_CMSItemProperty_ItemIsContainer |  | int FP_CMSItemProperty_ItemIsContainer
Constants.FP_CMSItemProperty_ItemLocalPath |  | int FP_CMSItemProperty_ItemLocalPath
Constants.FP_CMSItemProperty_ItemName |  | int FP_CMSItemProperty_ItemName
Constants.FP_CMSItemProperty_ItemServerPath |  | int FP_CMSItemProperty_ItemServerPath
Constants.FP_CMSItemProperty_ItemType |  | int FP_CMSItemProperty_ItemType
Constants.FP_CMSItemProperty_ItemVersion |  | int FP_CMSItemProperty_ItemVersion
Constants.FP_CMSItemProperty_Max |  | int FP_CMSItemProperty_Max
Constants.FP_CMSItemProperty_Min |  | int FP_CMSItemProperty_Min
Constants.FP_CTFontContext |  | int 72
Constants.FP_CanHaveCheckMark |  | int 1931
Constants.FP_Capitalization |  | int 619
Constants.FP_CellAboveInCol |  | int 1203
Constants.FP_CellAngle |  | int 1209
Constants.FP_CellBelowInCol |  | int 1204
Constants.FP_CellBelowInTbl |  | int 1200
Constants.FP_CellBottomMargin |  | int 582
Constants.FP_CellBottomMarginChange |  | int 2023
Constants.FP_CellBottomMarginFixed |  | int 2016
Constants.FP_CellColNum |  | int 1205
Constants.FP_CellDefaultBottomRuling |  | int 1215
Constants.FP_CellDefaultLeftRuling |  | int 1216
Constants.FP_CellDefaultRightRuling |  | int 1217
Constants.FP_CellDefaultTopRuling |  | int 1214
Constants.FP_CellIsShown |  | int 1218
Constants.FP_CellIsStraddled |  | int 1206
Constants.FP_CellLeftMargin |  | int 583
Constants.FP_CellLeftMarginChange |  | int 2024
Constants.FP_CellLeftMarginFixed |  | int 2017
Constants.FP_CellMarginSpacingDelta |  | int 990
Constants.FP_CellMarginsFixed |  | int 586
Constants.FP_CellNumColsStraddled |  | int 1208
Constants.FP_CellNumRowsStraddled |  | int 1207
Constants.FP_CellOverrideBottomRuling |  | int 1211
Constants.FP_CellOverrideFill |  | int 1195
Constants.FP_CellOverrideLeftRuling |  | int 1212
Constants.FP_CellOverrideRightRuling |  | int 1213
Constants.FP_CellOverrideShading |  | int 1194
Constants.FP_CellOverrideTopRuling |  | int 1210
Constants.FP_CellRightMargin |  | int 584
Constants.FP_CellRightMarginChange |  | int 2025
Constants.FP_CellRightMarginFixed |  | int 2018
Constants.FP_CellRow |  | int 1198
Constants.FP_CellTopMargin |  | int 581
Constants.FP_CellTopMarginChange |  | int 2022
Constants.FP_CellTopMarginFixed |  | int 2015
Constants.FP_CellUseOverrideBRuling |  | int 1193
Constants.FP_CellUseOverrideFill |  | int 1196
Constants.FP_CellUseOverrideLRuling |  | int 1190
Constants.FP_CellUseOverrideRRuling |  | int 1191
Constants.FP_CellUseOverrideShading |  | int 1197
Constants.FP_CellUseOverrideTRuling |  | int 1192
Constants.FP_CellVAlignment |  | int 585
Constants.FP_ChangeBar |  | int 611
Constants.FP_ChangeBarColor |  | int 262
Constants.FP_ChangeBarDistance |  | int 259
Constants.FP_ChangeBarPosition |  | int 260
Constants.FP_ChangeBarThickness |  | int 261
Constants.FP_ChapNumComputeMethod |  | int 215
Constants.FP_ChapterNumStyle |  | int 217
Constants.FP_ChapterNumText |  | int 218
Constants.FP_ChapterNumber |  | int 216
Constants.FP_CharTag |  | int 602
Constants.FP_CharacterReferencesOnXMLExport |  | int 2887
Constants.FP_CheckMarkIsOn |  | int 1932
Constants.FP_ColGap |  | int 234
Constants.FP_ColGapWidth |  | int 985
Constants.FP_Color |  | int 751
Constants.FP_ColorOverprint |  | int 1468
Constants.FP_ColorPrintCtl |  | int 1462
Constants.FP_ColorTintPercent |  | int 1466
Constants.FP_ColorViewCtl |  | int 1461
Constants.FP_ColumnsAreBalanced |  | int 1175
Constants.FP_CombinedFontFamily |  | int 2287
Constants.FP_CommandNum |  | int 1928
Constants.FP_Comment |  | int 1581
Constants.FP_ComponentDisplayText |  | int 532
Constants.FP_ComponentElement |  | int 1551
Constants.FP_ComponentIsDitaMap |  | int 2331
Constants.FP_ComponentIsSelected |  | int 529
Constants.FP_ComponentType |  | int 2329
Constants.FP_CondFmtIsShown |  | int 1139
Constants.FP_ContentHeight |  | int 2219
Constants.FP_ContentIsLooselyValid |  | int 1652
Constants.FP_ContentIsStrictlyValid |  | int 1651
Constants.FP_ContentMustBeEmpty |  | int 1665
Constants.FP_ContentNeededAtBegin |  | int 1653
Constants.FP_ContentNeededAtEnd |  | int 1654
Constants.FP_ContextForCSS |  | int 2162
Constants.FP_ContextLabel |  | int 2157
Constants.FP_CorrespondingXmlPath |  | int 1158
Constants.FP_CountElements |  | int 2101
Constants.FP_CurrentDoc |  | int 2401
Constants.FP_CurrentInset |  | int 240
Constants.FP_CurrentMenuSet |  | int 99
Constants.FP_CurrentPage |  | int 236
Constants.FP_CursorData |  | int 2294
Constants.FP_CursorTypes |  | int 2295
Constants.FP_CustomDelimiter |  | int 2420
Constants.FP_CustomDocPath |  | int 2885
Constants.FP_CustomElementList |  | int 1496
Constants.FP_Cyan |  | int 1457
Constants.FP_DTheta |  | int 830
Constants.FP_Dash |  | int 752
Constants.FP_Day |  | int 1724
Constants.FP_DbAttributes |  | int 1817
Constants.FP_DbCancelButton |  | int 1811
Constants.FP_DbCheckBoxState |  | int 1807
Constants.FP_DbDefaultButton |  | int 1809
Constants.FP_DbEditable |  | int 1818
Constants.FP_DbFbCurrentDir |  | int 1814
Constants.FP_DbFbScrollBox |  | int 1813
Constants.FP_DbFbStatus |  | int 1815
Constants.FP_DbFbTextBox |  | int 1812
Constants.FP_DbFirstFocus |  | int 1808
Constants.FP_DbIdentifier |  | int 1802
Constants.FP_DbItemNum |  | int 1800
Constants.FP_DbNoHelp |  | int 1819
Constants.FP_DbOKButton |  | int 1810
Constants.FP_DbRadioButtonGroup |  | int 1806
Constants.FP_DbSbxNumLines |  | int 1805
Constants.FP_DbStuffItem |  | int 1804
Constants.FP_DbTitleLabel |  | int 1816
Constants.FP_DbType |  | int 1801
Constants.FP_DbVarLabelWidth |  | int 1803
Constants.FP_DefaultExclusions |  | int 1487
Constants.FP_DefaultFontAngle |  | int 71
Constants.FP_DefaultFontFamily |  | int 68
Constants.FP_DefaultFontVariation |  | int 69
Constants.FP_DefaultFontWeight |  | int 70
Constants.FP_DefaultInclusions |  | int 1486
Constants.FP_DefaultKeyCatalog |  | int 2871
Constants.FP_DefaultVectorFormatForXMLExport |  | int 2874
Constants.FP_DescriptiveTag |  | int 1596
Constants.FP_DesktopHeight |  | int 791
Constants.FP_DesktopWidth |  | int 790
Constants.FP_DesktopX |  | int 788
Constants.FP_DesktopY |  | int 789
Constants.FP_DialogEncodingName |  | int 598
Constants.FP_Dictionary |  | int 203
Constants.FP_DirectOLESupportInXml |  | int 2881
Constants.FP_DisableAutofitAfterZoom |  | int 67
Constants.FP_DisplayName |  | int 78
Constants.FP_Displaying |  | int 92
Constants.FP_DitaMode |  | int 1504
Constants.FP_DoNotExportInvalidXML |  | int 2418
Constants.FP_DoNotGenerateErrorLog |  | int 819
Constants.FP_DoPostXSLTValidationOnExport |  | int 2417
Constants.FP_DocAcrobatColumnArticleThreads |  | int 2256
Constants.FP_DocAcrobatDefaultsChanged |  | int 2252
Constants.FP_DocAcrobatElementList |  | int 2254
Constants.FP_DocAcrobatElements |  | int 2253
Constants.FP_DocAcrobatNoArticleThreads |  | int 2255
Constants.FP_DocFluidFlow |  | int 147
Constants.FP_DocIsDoubleSided |  | int 226
Constants.FP_DocIsHelp |  | int 132
Constants.FP_DocIsInternal |  | int 2372
Constants.FP_DocIsModified |  | int 131
Constants.FP_DocIsStructuredDummy |  | int 2882
Constants.FP_DocIsViewOnly |  | int 133
Constants.FP_DocIsViewOnlyWinPalette |  | int 134
Constants.FP_DocOpenClientEncounteredErrors |  | int 820
Constants.FP_DocOpenType |  | int 130
Constants.FP_DocSaveFormat |  | int 2415
Constants.FP_DocSaveType |  | int 145
Constants.FP_DocSequenceLevel |  | int 2356
Constants.FP_DockDialog |  | int 2344
Constants.FP_DontLoadStartupClients |  | int 2894
Constants.FP_DontShowWelcomeScreen |  | int 2408
Constants.FP_DontUpdateTextInsets |  | int 160
Constants.FP_DontUpdateXRefs |  | int 159
Constants.FP_DoubleClick |  | int 1706
Constants.FP_DownloadFonts |  | int 496
Constants.FP_ElemPrefixSuffix |  | int 2158
Constants.FP_Element |  | int 2170
Constants.FP_ElementBoundaryDisplay |  | int 1484
Constants.FP_ElementCatalog |  | int 1488
Constants.FP_ElementCatalogDisplay |  | int 1485
Constants.FP_ElementDataType |  | int 1593
Constants.FP_ElementDef |  | int 1621
Constants.FP_ElementDefType |  | int 1579
Constants.FP_ElementDescription |  | int 1597
Constants.FP_ElementInCatalog |  | int 1573
Constants.FP_ElementIsCollapsed |  | int 1627
Constants.FP_ElementIsExcludedInContext |  | int 1655
Constants.FP_ElementIsInvalidInParent |  | int 1656
Constants.FP_ElementIsInvalidInPosition |  | int 1657
Constants.FP_ElementIsTopicGroup |  | int 2338
Constants.FP_ElementIsTopicHead |  | int 2337
Constants.FP_ElementIsTopicRef |  | int 2336
Constants.FP_ElementIsUndefined |  | int 1650
Constants.FP_ElementMarkedForNamedDestination |  | int 1669
Constants.FP_ElementPgfFormat |  | int 1586
Constants.FP_ElementSelection |  | int 1494
Constants.FP_ElementType |  | int 1636
Constants.FP_ElementTypeMismatch |  | int 1658
Constants.FP_EnableAutoSpellCheck |  | int 2413
Constants.FP_EnabledWhen |  | int 1935
Constants.FP_EqnIntegralSizeLarge |  | int 348
Constants.FP_EqnIntegralSizeMed |  | int 347
Constants.FP_EqnIntegralSizeSmall |  | int 346
Constants.FP_EqnLevel1SizeLarge |  | int 354
Constants.FP_EqnLevel1SizeMed |  | int 353
Constants.FP_EqnLevel1SizeSmall |  | int 352
Constants.FP_EqnLevel2SizeLarge |  | int 357
Constants.FP_EqnLevel2SizeMed |  | int 356
Constants.FP_EqnLevel2SizeSmall |  | int 355
Constants.FP_EqnLevel3SizeLarge |  | int 360
Constants.FP_EqnLevel3SizeMed |  | int 359
Constants.FP_EqnLevel3SizeSmall |  | int 358
Constants.FP_EqnSigmaSizeLarge |  | int 351
Constants.FP_EqnSigmaSizeMed |  | int 350
Constants.FP_EqnSigmaSizeSmall |  | int 349
Constants.FP_ErrorInBookComponent |  | int 1663
Constants.FP_ExcludeBookComponent |  | int 2326
Constants.FP_Exclusions |  | int 1576
Constants.FP_ExpandOMaticParent |  | int 1934
Constants.FP_ExportFilters |  | int 2289
Constants.FP_ExtractElementTags |  | int 1552
Constants.FP_ExtractTags |  | int 516
Constants.FP_FMConsoleString |  | int 826
Constants.FP_FMInterfaceEncodingName |  | int 599
Constants.FP_FM_BinDir |  | int 88
Constants.FP_FM_CurrentDir |  | int 90
Constants.FP_FM_HelpDir |  | int 103
Constants.FP_FM_HomeDir |  | int 87
Constants.FP_FM_InitDir |  | int 89
Constants.FP_FM_SgmlDir |  | int 100
Constants.FP_FM_StructureDir |  | int 2031
Constants.FP_FM_XmlDir |  | int 2032
Constants.FP_FamilyName |  | int 1464
Constants.FP_Fcode |  | int 1936
Constants.FP_Fcodes |  | int 1937
Constants.FP_FileExtensionOverride |  | int 2813
Constants.FP_FileInfoPacket |  | int 2262
Constants.FP_Fill |  | int 741
Constants.FP_FirstAFrame |  | int 974
Constants.FP_FirstAttrCondExprInDoc |  | int 2815
Constants.FP_FirstBodyPageInDoc |  | int 415
Constants.FP_FirstCell |  | int 978
Constants.FP_FirstCellInRow |  | int 1247
Constants.FP_FirstCharFmtInDoc |  | int 123
Constants.FP_FirstChildElement |  | int 1623
Constants.FP_FirstColorInDoc |  | int 127
Constants.FP_FirstCombinedFontDefnInDoc |  | int 2280
Constants.FP_FirstCommandInSession |  | int 98
Constants.FP_FirstComponentInBook |  | int 491
Constants.FP_FirstComponentInBookComponent |  | int 2324
Constants.FP_FirstCondFmtInDoc |  | int 124
Constants.FP_FirstDITAConrefElementInDoc |  | int 2861
Constants.FP_FirstDITALinkElementInDoc |  | int 2863
Constants.FP_FirstDITATopicrefElementInDoc |  | int 2864
Constants.FP_FirstDITATopicsetrefElementInDoc |  | int 2865
Constants.FP_FirstDITAXrefElementInDoc |  | int 2862
Constants.FP_FirstElementDefInDoc |  | int 1483
Constants.FP_FirstFlowInDoc |  | int 121
Constants.FP_FirstFmtChangeListInDoc |  | int 1489
Constants.FP_FirstFn |  | int 976
Constants.FP_FirstFnInDoc |  | int 119
Constants.FP_FirstGraphicInDoc |  | int 112
Constants.FP_FirstGraphicInFrame |  | int 882
Constants.FP_FirstGraphicInGroup |  | int 807
Constants.FP_FirstGraphicsFmtInDoc |  | int 3101
Constants.FP_FirstIndent |  | int 556
Constants.FP_FirstIndentChange |  | int 2005
Constants.FP_FirstIndentIsRelative |  | int 2019
Constants.FP_FirstIndentRelPos |  | int 2020
Constants.FP_FirstKeyCatalogInSession |  | int 2872
Constants.FP_FirstMarkerInDoc |  | int 114
Constants.FP_FirstMarkerTypeInDoc |  | int 148
Constants.FP_FirstMasterPageInDoc |  | int 417
Constants.FP_FirstMenuItemInMenu |  | int 1927
Constants.FP_FirstMenuItemInSession |  | int 97
Constants.FP_FirstOpenBook |  | int 54
Constants.FP_FirstOpenDoc |  | int 53
Constants.FP_FirstPageNum |  | int 224
Constants.FP_FirstPageVerso |  | int 227
Constants.FP_FirstPgf |  | int 972
Constants.FP_FirstPgfFmtInDoc |  | int 122
Constants.FP_FirstPgfInDoc |  | int 113
Constants.FP_FirstPgfRules |  | int 1589
Constants.FP_FirstRefPageInDoc |  | int 419
Constants.FP_FirstRowInTbl |  | int 1338
Constants.FP_FirstRubiInDoc |  | int 194
Constants.FP_FirstRulingFmtInDoc |  | int 126
Constants.FP_FirstSelectedComponentInBook |  | int 493
Constants.FP_FirstSelectedGraphicInDoc |  | int 128
Constants.FP_FirstSelectedTiInDoc |  | int 142
Constants.FP_FirstSubCol |  | int 986
Constants.FP_FirstTblFmtInDoc |  | int 125
Constants.FP_FirstTblInDoc |  | int 120
Constants.FP_FirstTextFrameInFlow |  | int 1169
Constants.FP_FirstTiInDoc |  | int 141
Constants.FP_FirstVarFmtInDoc |  | int 116
Constants.FP_FirstVarInDoc |  | int 115
Constants.FP_FirstVis |  | int 1705
Constants.FP_FirstXRefFmtInDoc |  | int 118
Constants.FP_FirstXRefInDoc |  | int 117
Constants.FP_Flow |  | int 982
Constants.FP_FlowIsAutoConnect |  | int 1165
Constants.FP_FlowIsFeathered |  | int 1166
Constants.FP_FlowIsPostScript |  | int 1168
Constants.FP_FlowIsSynchronized |  | int 1163
Constants.FP_Fmt |  | int 1050
Constants.FP_FmtChangeList |  | int 2155
Constants.FP_FmtChangeListInCatalog |  | int 2021
Constants.FP_FmtChangeListTag |  | int 2154
Constants.FP_FmtRule |  | int 2159
Constants.FP_FmtRuleClause |  | int 2104
Constants.FP_FmtRuleClauses |  | int 2103
Constants.FP_FmtRuleType |  | int 2100
Constants.FP_FnAnchorString |  | int 1006
Constants.FP_FnCustNumString |  | int 285
Constants.FP_FnFirstNum |  | int 284
Constants.FP_FnFmt |  | int 283
Constants.FP_FnHeightPerCol |  | int 289
Constants.FP_FnInstancePosition |  | int 287
Constants.FP_FnInstancePrefix |  | int 294
Constants.FP_FnInstanceSuffix |  | int 288
Constants.FP_FnNum |  | int 1002
Constants.FP_FnNumComputeMethod |  | int 295
Constants.FP_FnNumStyle |  | int 290
Constants.FP_FnNumberingPerPage |  | int 291
Constants.FP_FnRefPosition |  | int 292
Constants.FP_FnRefPrefix |  | int 286
Constants.FP_FnRefSuffix |  | int 293
Constants.FP_Focus |  | int 2358
Constants.FP_FontAngle |  | int 607
Constants.FP_FontAngleNames |  | int 58
Constants.FP_FontEncodingName |  | int 642
Constants.FP_FontFamily |  | int 604
Constants.FP_FontFamilyAttributes |  | int 60
Constants.FP_FontFamilyFullNames |  | int 73
Constants.FP_FontFamilyNames |  | int 55
Constants.FP_FontPanoseName |  | int 641
Constants.FP_FontPlatformName |  | int 639
Constants.FP_FontPostScriptName |  | int 640
Constants.FP_FontSize |  | int 615
Constants.FP_FontSizeChange |  | int 2012
Constants.FP_FontVariation |  | int 605
Constants.FP_FontVariationNames |  | int 56
Constants.FP_FontWeight |  | int 606
Constants.FP_FontWeightNames |  | int 57
Constants.FP_FormatOverride |  | int 590
Constants.FP_FormatTag |  | int 2153
Constants.FP_FormattingLocked |  | int 2891
Constants.FP_FrameParent |  | int 774
Constants.FP_Functions |  | int 339
Constants.FP_GeneralRule |  | int 1575
Constants.FP_GeneralRuleErrorOffsets |  | int 1578
Constants.FP_GenerateAcrobatInfo |  | int 2250
Constants.FP_GenerateInclude |  | int 517
Constants.FP_GraphicCantBeSelected |  | int 772
Constants.FP_GraphicIsButton |  | int 773
Constants.FP_GraphicIsSelected |  | int 771
Constants.FP_Gravity |  | int 107
Constants.FP_GreekSize |  | int 63
Constants.FP_GroupDialog |  | int 2349
Constants.FP_GroupParent |  | int 777
Constants.FP_HasShiftOrUnshiftCommand |  | int 1939
Constants.FP_HeadArrow |  | int 743
Constants.FP_Height |  | int 784
Constants.FP_HelpLink |  | int 1938
Constants.FP_HelpPending |  | int 102
Constants.FP_HiddenPage |  | int 421
Constants.FP_HighestLevelElement |  | int 1509
Constants.FP_HoleAtEnd |  | int 1654
Constants.FP_HoleBeforeElement |  | int 1659
Constants.FP_HorizontalSpreadLarge |  | int 342
Constants.FP_HorizontalSpreadMed |  | int 341
Constants.FP_HorizontalSpreadSmall |  | int 340
Constants.FP_HostName |  | int 81
Constants.FP_HotspotCmdStr |  | int 2876
Constants.FP_HotspotTitle |  | int 2877
Constants.FP_Hypertext |  | int 1943
Constants.FP_HypertextCommandText |  | int 2301
Constants.FP_HypertextDoValidate |  | int 2300
Constants.FP_HypertextParseBadParam |  | int 2305
Constants.FP_HypertextParseErr |  | int 2303
Constants.FP_HypertextParseErrMsg |  | int 2306
Constants.FP_HypertextParsedArgs |  | int 2302
Constants.FP_HypertextParsedClientName |  | int 2317
Constants.FP_HypertextParsedCmdCode |  | int 2307
Constants.FP_HypertextParsedCmdDest |  | int 2308
Constants.FP_HypertextParsedCmdDestObjID |  | int 2310
Constants.FP_HypertextParsedCmdDestObjType |  | int 2309
Constants.FP_HypertextParsedCmdMatrixColumns |  | int 2312
Constants.FP_HypertextParsedCmdMatrixRows |  | int 2311
Constants.FP_HypertextParsedDIFileName |  | int 2320
Constants.FP_HypertextParsedFlowName |  | int 2315
Constants.FP_HypertextParsedLinkName |  | int 2313
Constants.FP_HypertextParsedMessage |  | int 2319
Constants.FP_HypertextParsedPageName |  | int 2314
Constants.FP_HypertextParsedRangeName |  | int 2316
Constants.FP_HypertextParsedTitle |  | int 2318
Constants.FP_HypertextValidateErr |  | int 2304
Constants.FP_HyphMinPrefix |  | int 575
Constants.FP_HyphMinSuffix |  | int 560
Constants.FP_HyphMinWord |  | int 576
Constants.FP_Hyphenate |  | int 564
Constants.FP_IDAttrValue |  | int 1637
Constants.FP_INSETinfo |  | int 858
Constants.FP_Icon |  | int 1716
Constants.FP_IconBarOn |  | int 101
Constants.FP_IconColorPref |  | int 1508
Constants.FP_IconSizePref |  | int 1507
Constants.FP_ImportFilters |  | int 2288
Constants.FP_ImportFmtInclude |  | int 518
Constants.FP_ImportHint |  | int 2055
Constants.FP_InCond |  | int 1150
Constants.FP_InTableSortOperation |  | int 2833
Constants.FP_InTextFrame |  | int 1001
Constants.FP_InTextObj |  | int 1000
Constants.FP_Inclusions |  | int 1577
Constants.FP_IncrVal |  | int 1711
Constants.FP_InitStructurePattern |  | int 1585
Constants.FP_InkName |  | int 1465
Constants.FP_InsertLinks |  | int 528
Constants.FP_InsetCuePointList |  | int 2354
Constants.FP_InsetDpi |  | int 853
Constants.FP_InsetEditor |  | int 850
Constants.FP_InsetFile |  | int 852
Constants.FP_InsetFileOrigName |  | int 2814
Constants.FP_InsetGenericData |  | int 2832
Constants.FP_InsetGfxActiveInPdf |  | int 2836
Constants.FP_InsetGfxName |  | int 2834
Constants.FP_InsetGfxPlayWindowInPdf |  | int 2835
Constants.FP_InsetIsFixedSize |  | int 854
Constants.FP_InsetIsFlippedSideways |  | int 855
Constants.FP_InsetIsInverted |  | int 856
Constants.FP_InsetJavaScriptAttached |  | int 2837
Constants.FP_InsetJavaScriptFile |  | int 2838
Constants.FP_InsetLinkToText |  | int 2355
Constants.FP_InsetMonikerFilePath |  | int 2849
Constants.FP_InsetMonikerPath |  | int 2848
Constants.FP_InsetPosterFile |  | int 2822
Constants.FP_InsetPosterFileOrigName |  | int 2824
Constants.FP_InsetPosterIsExternal |  | int 2821
Constants.FP_InsetRasterDpi |  | int 857
Constants.FP_InsetSaveDIBFacetToFile |  | int 2823
Constants.FP_InsetSaveFacetToFile |  | int 2839
Constants.FP_InsetU3dAnimationList |  | int 2844
Constants.FP_InsetU3dPartList |  | int 2845
Constants.FP_InsetU3dViewList |  | int 2846
Constants.FP_InsetURL |  | int 2407
Constants.FP_InsetUpdater |  | int 851
Constants.FP_InternalHeight |  | int 2374
Constants.FP_InternalMathMLComposeDpi |  | int 2375
Constants.FP_InternalMathMLFontSize |  | int 2376
Constants.FP_InternalMathMLXmlData |  | int 2377
Constants.FP_InternalWidth |  | int 2373
Constants.FP_InvalidHighestLevel |  | int 1661
Constants.FP_InvariantName |  | int 1029
Constants.FP_IsDefault |  | int 2850
Constants.FP_IsDialogDocked |  | int 2345
Constants.FP_IsDialogVisible |  | int 2346
Constants.FP_IsDitamapInResourceManager |  | int 2332
Constants.FP_IsDocDita |  | int 2880
Constants.FP_IsDocDitamap |  | int 2879
Constants.FP_IsFMRunningAsServer |  | int 2348
Constants.FP_IsFMRunningInTrialPeriod |  | int 2412
Constants.FP_IsFateRun |  | int 2847
Constants.FP_IsHotspot |  | int 2875
Constants.FP_IsIconified |  | int 31
Constants.FP_IsInFront |  | int 32
Constants.FP_IsOnScreen |  | int 110
Constants.FP_IsRestoring |  | int 2892
Constants.FP_IsStale |  | int 2851
Constants.FP_IsTechnicalSuiteLicensed |  | int 2410
Constants.FP_IsTempOpenSave |  | int 827
Constants.FP_IsTextRange |  | int 2151
Constants.FP_KByteAllocationSize |  | int 106
Constants.FP_KeepWithNext |  | int 565
Constants.FP_KeepWithPrev |  | int 551
Constants.FP_KernX |  | int 616
Constants.FP_KernY |  | int 617
Constants.FP_KeyCatalog |  | int 2856
Constants.FP_KeyCatalogClientName |  | int 2873
Constants.FP_KeyCatalogType |  | int 2857
Constants.FP_KeyCatalogWorkflow |  | int 2859
Constants.FP_KeyCount |  | int 2860
Constants.FP_KeyboardShortcutLabel |  | int 1929
Constants.FP_KeyboardShortcuts |  | int 1930
Constants.FP_Label |  | int 30
Constants.FP_LabelBold |  | int 1721
Constants.FP_LabelColor |  | int 1720
Constants.FP_Labels |  | int 1703
Constants.FP_Language |  | int 577
Constants.FP_LastAFrame |  | int 975
Constants.FP_LastBodyPageInDoc |  | int 416
Constants.FP_LastCell |  | int 979
Constants.FP_LastChildElement |  | int 1624
Constants.FP_LastFn |  | int 977
Constants.FP_LastGraphicInFrame |  | int 883
Constants.FP_LastGraphicInGroup |  | int 808
Constants.FP_LastMasterPageInDoc |  | int 418
Constants.FP_LastPgf |  | int 973
Constants.FP_LastPgfRules |  | int 1590
Constants.FP_LastRefPageInDoc |  | int 420
Constants.FP_LastRowInTbl |  | int 1339
Constants.FP_LastSubCol |  | int 987
Constants.FP_LastTextFrameInFlow |  | int 1170
Constants.FP_LastUpdate |  | int 2052
Constants.FP_Leading |  | int 558
Constants.FP_LeadingChange |  | int 2007
Constants.FP_LeftColNum |  | int 1343
Constants.FP_LeftIndent |  | int 555
Constants.FP_LeftIndentChange |  | int 2004
Constants.FP_LeftMargin |  | int 232
Constants.FP_LeftMasterPage |  | int 413
Constants.FP_LetterSpace |  | int 550
Constants.FP_LineAscent |  | int 1900
Constants.FP_LineBaseline |  | int 1902
Constants.FP_LineBreakAfter |  | int 177
Constants.FP_LineCap |  | int 753
Constants.FP_LineDescent |  | int 1901
Constants.FP_LineNumColor |  | int 4006
Constants.FP_LineNumDistance |  | int 4001
Constants.FP_LineNumFont |  | int 4004
Constants.FP_LineNumRestart |  | int 4002
Constants.FP_LineNumShow |  | int 4003
Constants.FP_LineNumSize |  | int 4005
Constants.FP_LineSpacing |  | int 587
Constants.FP_LineSpacingFactor |  | int 988
Constants.FP_LineSpacingFixed |  | int 2008
Constants.FP_LoadStartupScripts |  | int 2886
Constants.FP_LocX |  | int 781
Constants.FP_LocY |  | int 782
Constants.FP_Locked |  | int 588
Constants.FP_Magenta |  | int 1458
Constants.FP_MagicMarker |  | int 488
Constants.FP_MainFlowInDoc |  | int 422
Constants.FP_MarkerNames |  | int 59
Constants.FP_MarkerText |  | int 1025
Constants.FP_MarkerTypeId |  | int 1027
Constants.FP_MarkerTypeNames |  | int 149
Constants.FP_MasterPage |  | int 690
Constants.FP_MatchesContextInUserString |  | int 1642
Constants.FP_MatchingFirstPgfClauses |  | int 1638
Constants.FP_MatchingLastPgfClauses |  | int 1639
Constants.FP_MatchingObjectClauses |  | int 1632
Constants.FP_MatchingPrefixClauses |  | int 1640
Constants.FP_MatchingSuffixClauses |  | int 1641
Constants.FP_MatchingTextClauses |  | int 1631
Constants.FP_MathFullForm |  | int 865
Constants.FP_MathMLComposeDpi |  | int 2367
Constants.FP_MathMLData |  | int 2365
Constants.FP_MathMLDpi |  | int 2360
Constants.FP_MathMLFile |  | int 2363
Constants.FP_MathMLFontSize |  | int 2371
Constants.FP_MathMLImportGraphicsDpi |  | int 2369
Constants.FP_MathMLIsFixedSize |  | int 2361
Constants.FP_MathMLIsFlippedSideways |  | int 2366
Constants.FP_MathMLIsInverted |  | int 2362
Constants.FP_MathMLNamespacePrefix |  | int 2378
Constants.FP_MathMLXmlData |  | int 2359
Constants.FP_MathSize |  | int 866
Constants.FP_MaxBottomMargin |  | int 709
Constants.FP_MaxFirstIndent |  | int 472
Constants.FP_MaxFontSize |  | int 484
Constants.FP_MaxInterPgfPadding |  | int 471
Constants.FP_MaxInterlinePadding |  | int 470
Constants.FP_MaxJLetSpace |  | int 596
Constants.FP_MaxJRomSpace |  | int 593
Constants.FP_MaxLeading |  | int 482
Constants.FP_MaxLeftIndent |  | int 474
Constants.FP_MaxLeftMargin |  | int 703
Constants.FP_MaxRightIndent |  | int 476
Constants.FP_MaxRightMargin |  | int 705
Constants.FP_MaxSize |  | int 2352
Constants.FP_MaxSpace |  | int 572
Constants.FP_MaxSpaceAbove |  | int 478
Constants.FP_MaxSpaceBelow |  | int 480
Constants.FP_MaxSpread |  | int 486
Constants.FP_MaxStretch |  | int 711
Constants.FP_MaxTabPosition |  | int 701
Constants.FP_MaxTopMargin |  | int 707
Constants.FP_MaxVal |  | int 1710
Constants.FP_MenuBar |  | int 143
Constants.FP_MenuItemIsEnabled |  | int 1922
Constants.FP_MenuItemType |  | int 1933
Constants.FP_MenuType |  | int 1926
Constants.FP_Mif8bitOutput |  | int 62
Constants.FP_MifFileEntity |  | int 2828
Constants.FP_MifFileName |  | int 2829
Constants.FP_MifFileOrigFormat |  | int 2878
Constants.FP_MinBottomMargin |  | int 710
Constants.FP_MinFirstIndent |  | int 473
Constants.FP_MinFontSize |  | int 485
Constants.FP_MinHang |  | int 1164
Constants.FP_MinJLetSpace |  | int 594
Constants.FP_MinJRomSpace |  | int 591
Constants.FP_MinLeading |  | int 483
Constants.FP_MinLeftIndent |  | int 475
Constants.FP_MinLeftMargin |  | int 704
Constants.FP_MinRightIndent |  | int 477
Constants.FP_MinRightMargin |  | int 706
Constants.FP_MinSize |  | int 2351
Constants.FP_MinSpace |  | int 571
Constants.FP_MinSpaceAbove |  | int 479
Constants.FP_MinSpaceBelow |  | int 481
Constants.FP_MinSpread |  | int 487
Constants.FP_MinStretch |  | int 712
Constants.FP_MinTabPosition |  | int 702
Constants.FP_MinTopMargin |  | int 708
Constants.FP_MinVal |  | int 1709
Constants.FP_Mode |  | int 1941
Constants.FP_ModelessDlgIconN |  | int 1728
Constants.FP_ModelessDlgIconR |  | int 1729
Constants.FP_Month |  | int 1725
Constants.FP_MoveTabs |  | int 2014
Constants.FP_Name |  | int 20
Constants.FP_Namespace |  | int 1643
Constants.FP_NamespaceScope |  | int 1644
Constants.FP_NarrowRubiSpaceForJapanese |  | int 188
Constants.FP_NarrowRubiSpaceForOther |  | int 190
Constants.FP_NewElemAttrDisplay |  | int 1490
Constants.FP_NewElemAttrEditing |  | int 1491
Constants.FP_NextAFrame |  | int 885
Constants.FP_NextAttrCondExprInDoc |  | int 2816
Constants.FP_NextBookComponentInDFSOrder |  | int 2333
Constants.FP_NextCell |  | int 1220
Constants.FP_NextCellInRow |  | int 1202
Constants.FP_NextCellInTbl |  | int 1199
Constants.FP_NextCharFmtInDoc |  | int 603
Constants.FP_NextColorInDoc |  | int 1455
Constants.FP_NextCombinedFontDefnInDoc |  | int 2281
Constants.FP_NextCommandInSession |  | int 1942
Constants.FP_NextComponentInBook |  | int 527
Constants.FP_NextCondFmtInDoc |  | int 1138
Constants.FP_NextDITAConrefElementInDoc |  | int 2866
Constants.FP_NextDITALinkElementInDoc |  | int 2868
Constants.FP_NextDITATopicrefElementInDoc |  | int 2869
Constants.FP_NextDITATopicsetrefElementInDoc |  | int 2870
Constants.FP_NextDITAXrefElementInDoc |  | int 2867
Constants.FP_NextElementDFS |  | int 2334
Constants.FP_NextElementDefInDoc |  | int 1572
Constants.FP_NextFlowInDoc |  | int 1162
Constants.FP_NextFmtChangeListInDoc |  | int 2000
Constants.FP_NextFn |  | int 1005
Constants.FP_NextFnInDoc |  | int 1003
Constants.FP_NextGraphicInDoc |  | int 786
Constants.FP_NextGraphicInFrame |  | int 776
Constants.FP_NextGraphicInGroup |  | int 779
Constants.FP_NextGraphicsFmtInDoc |  | int 3102
Constants.FP_NextInvalidElement |  | int 1664
Constants.FP_NextKeyCatalogInSession |  | int 2852
Constants.FP_NextMarkerInDoc |  | int 1026
Constants.FP_NextMarkerTypeInDoc |  | int 1028
Constants.FP_NextMenuItemInMenu |  | int 1923
Constants.FP_NextMenuItemInSession |  | int 1925
Constants.FP_NextOpenBookInSession |  | int 490
Constants.FP_NextOpenDocInSession |  | int 111
Constants.FP_NextPgfFmtInDoc |  | int 580
Constants.FP_NextPgfInDoc |  | int 716
Constants.FP_NextPgfInFlow |  | int 717
Constants.FP_NextRowInTbl |  | int 1245
Constants.FP_NextRubiInDoc |  | int 1469
Constants.FP_NextRulingFmtInDoc |  | int 1430
Constants.FP_NextSelectedComponentInBook |  | int 530
Constants.FP_NextSelectedGraphicInDoc |  | int 785
Constants.FP_NextSiblingElement |  | int 1626
Constants.FP_NextSubCol |  | int 2202
Constants.FP_NextTag |  | int 552
Constants.FP_NextTblFmtInDoc |  | int 1276
Constants.FP_NextTblInDoc |  | int 1337
Constants.FP_NextTextFrameInFlow |  | int 981
Constants.FP_NextTiInDoc |  | int 2050
Constants.FP_NextVarFmtInDoc |  | int 1051
Constants.FP_NextVarInDoc |  | int 1046
Constants.FP_NextXRefFmtInDoc |  | int 1074
Constants.FP_NextXRefInDoc |  | int 1072
Constants.FP_No3DInPDF |  | int 2406
Constants.FP_NoAppOutputPIFiltered |  | int 2884
Constants.FP_NoFlashInPDF |  | int 2405
Constants.FP_NoMultiMediaInPDF |  | int 2831
Constants.FP_NotLoaded |  | int 2853
Constants.FP_NumAtEnd |  | int 563
Constants.FP_NumCols |  | int 235
Constants.FP_NumColumns |  | int 984
Constants.FP_NumItems |  | int 1707
Constants.FP_NumLines |  | int 1704
Constants.FP_NumNamespaces |  | int 1645
Constants.FP_NumPoints |  | int 907
Constants.FP_NumTabs |  | int 573
Constants.FP_Numbers |  | int 338
Constants.FP_Object |  | int 1630
Constants.FP_ObjectAttributes |  | int 23
Constants.FP_ObjectFmtRules |  | int 1583
Constants.FP_OldTypeNum |  | int 1024
Constants.FP_OpenAndSaveXmlBookComponentDoc |  | int 822
Constants.FP_OpenDir |  | int 80
Constants.FP_OperatingSystem |  | int 46
Constants.FP_OptJLetSpace |  | int 595
Constants.FP_OptJRomSpace |  | int 592
Constants.FP_OptSpace |  | int 557
Constants.FP_OrphanRows |  | int 1291
Constants.FP_Outline |  | int 612
Constants.FP_Overflowed |  | int 983
Constants.FP_Overline |  | int 610
Constants.FP_Overprint |  | int 756
Constants.FP_OyamojiTextRange |  | int 1470
Constants.FP_PDFAllNamedDestinations |  | int 2257
Constants.FP_PDFBookmark |  | int 2261
Constants.FP_PDFBookmarksOpenLevel |  | int 2275
Constants.FP_PDFConvertCMYKtoRGB |  | int 2274
Constants.FP_PDFDestsMarked |  | int 2258
Constants.FP_PDFDistillerAbsent |  | int 2276
Constants.FP_PDFDocInfo |  | int 2260
Constants.FP_PDFEndPage |  | int 2273
Constants.FP_PDFGenerateForReview |  | int 2279
Constants.FP_PDFJobOption |  | int 2263
Constants.FP_PDFJobOptionsAbsent |  | int 2277
Constants.FP_PDFOpenPage |  | int 2264
Constants.FP_PDFPageHeight |  | int 2270
Constants.FP_PDFPageNum |  | int 2402
Constants.FP_PDFPageWidth |  | int 2269
Constants.FP_PDFPrintPageRange |  | int 2271
Constants.FP_PDFRegistrationMarks |  | int 2268
Constants.FP_PDFSeparateFiles |  | int 2267
Constants.FP_PDFStartPage |  | int 2272
Constants.FP_PDFStructure |  | int 2259
Constants.FP_PDFStructureLevel |  | int 600
Constants.FP_PDFViewPDF |  | int 2278
Constants.FP_PDFZoomFactor |  | int 2266
Constants.FP_PDFZoomType |  | int 2265
Constants.FP_PageBackground |  | int 689
Constants.FP_PageFrame |  | int 695
Constants.FP_PageFramePage |  | int 880
Constants.FP_PageHeight |  | int 692
Constants.FP_PageIsRecto |  | int 697
Constants.FP_PageNext |  | int 694
Constants.FP_PageNum |  | int 687
Constants.FP_PageNumComputeMethod |  | int 524
Constants.FP_PageNumString |  | int 696
Constants.FP_PageNumStyle |  | int 225
Constants.FP_PagePrefix |  | int 521
Constants.FP_PagePrev |  | int 693
Constants.FP_PageRounding |  | int 229
Constants.FP_PageSide |  | int 523
Constants.FP_PageSuffix |  | int 522
Constants.FP_PageWidth |  | int 691
Constants.FP_PairKern |  | int 614
Constants.FP_Pantone |  | int 1456
Constants.FP_ParentElement |  | int 1622
Constants.FP_ParentTextFrame |  | int 2200
Constants.FP_ParseFullSpecification |  | int 2163
Constants.FP_ParsedGeneralRule |  | int 1592
Constants.FP_ParsedSpecification |  | int 2160
Constants.FP_PasswordStyle |  | int 1714
Constants.FP_Path |  | int 85
Constants.FP_Pen |  | int 742
Constants.FP_PercentDone |  | int 104
Constants.FP_PgfAlignment |  | int 547
Constants.FP_PgfBoxColor |  | int 2364
Constants.FP_PgfCatalogReference |  | int 2001
Constants.FP_PgfIsAutoNum |  | int 562
Constants.FP_PgfMarkedForNamedDestination |  | int 722
Constants.FP_PgfNumComputeMethod |  | int 525
Constants.FP_PgfNumber |  | int 719
Constants.FP_PgfSpacingFactor |  | int 989
Constants.FP_PgfSpellChecked |  | int 720
Constants.FP_PgfSplit |  | int 721
Constants.FP_Placement |  | int 579
Constants.FP_Platform |  | int 45
Constants.FP_PointPageNum |  | int 688
Constants.FP_PointPageNumStyle |  | int 228
Constants.FP_Points |  | int 908
Constants.FP_PolyIsBezier |  | int 906
Constants.FP_Position |  | int 620
Constants.FP_PrefixRules |  | int 1587
Constants.FP_PreserveFormattingInXml |  | int 2368
Constants.FP_PrevAFrame |  | int 884
Constants.FP_PrevBookComponentInDFSOrder |  | int 2340
Constants.FP_PrevCell |  | int 1219
Constants.FP_PrevCellInRow |  | int 1201
Constants.FP_PrevComponentInBook |  | int 526
Constants.FP_PrevElementDFS |  | int 2335
Constants.FP_PrevFn |  | int 1004
Constants.FP_PrevGraphicInFrame |  | int 775
Constants.FP_PrevGraphicInGroup |  | int 778
Constants.FP_PrevMenuItemInMenu |  | int 1924
Constants.FP_PrevPgfInFlow |  | int 718
Constants.FP_PrevRowInTbl |  | int 1244
Constants.FP_PrevSiblingElement |  | int 1625
Constants.FP_PrevSubCol |  | int 2201
Constants.FP_PrevTextFrameInFlow |  | int 980
Constants.FP_PreviewState |  | int 2820
Constants.FP_PrintBlankPages |  | int 467
Constants.FP_PrintCollated |  | int 446
Constants.FP_PrintCols |  | int 441
Constants.FP_PrintDitavalFileName |  | int 2343
Constants.FP_PrintDownloadAsianFonts |  | int 501
Constants.FP_PrintDownloadTrueTypeAsType1 |  | int 502
Constants.FP_PrintEmulsion |  | int 466
Constants.FP_PrintEndPage |  | int 453
Constants.FP_PrintEndPageName |  | int 440
Constants.FP_PrintEndPoint |  | int 454
Constants.FP_PrintEvenPages |  | int 455
Constants.FP_PrintFileName |  | int 451
Constants.FP_PrintImaging |  | int 465
Constants.FP_PrintInclude |  | int 519
Constants.FP_PrintLastSheetFirst |  | int 456
Constants.FP_PrintLowRes |  | int 447
Constants.FP_PrintManualFeed |  | int 458
Constants.FP_PrintNumCopies |  | int 459
Constants.FP_PrintOddPages |  | int 445
Constants.FP_PrintPaperHeight |  | int 462
Constants.FP_PrintPaperWidth |  | int 461
Constants.FP_PrintRegMarkDate |  | int 469
Constants.FP_PrintRegistrationMarks |  | int 457
Constants.FP_PrintRows |  | int 442
Constants.FP_PrintScale |  | int 450
Constants.FP_PrintScope |  | int 452
Constants.FP_PrintSeps |  | int 463
Constants.FP_PrintSpotBW |  | int 498
Constants.FP_PrintStartPage |  | int 443
Constants.FP_PrintStartPageName |  | int 439
Constants.FP_PrintStartPoint |  | int 444
Constants.FP_PrintThumbnails |  | int 448
Constants.FP_PrintToFile |  | int 460
Constants.FP_PrintTomboMarks |  | int 468
Constants.FP_PrinterName |  | int 449
Constants.FP_ProcessNumber |  | int 79
Constants.FP_Product |  | int 1944
Constants.FP_ProductFamily |  | int 2893
Constants.FP_ProductIsDemo |  | int 66
Constants.FP_ProductIsStructured |  | int 65
Constants.FP_ProductName |  | int 42
Constants.FP_ProgId |  | int 2421
Constants.FP_Public |  | int 1030
Constants.FP_Radius |  | int 950
Constants.FP_RasterFilterDpi |  | int 2400
Constants.FP_ReadOnly |  | int 1723
Constants.FP_RectangleIsSmoothed |  | int 929
Constants.FP_Reformatting |  | int 91
Constants.FP_RememberMissingFontNames |  | int 61
Constants.FP_RemoveExtraWhiteSpacesOnXMLImport |  | int 2830
Constants.FP_Required |  | int 1032
Constants.FP_ReservedColor |  | int 1463
Constants.FP_ResizeGripperPos |  | int 2350
Constants.FP_RestartFrameAlertRequired |  | int 2370
Constants.FP_RetainUndoState |  | int 64
Constants.FP_ReviewTime |  | int 994
Constants.FP_ReviewerName |  | int 993
Constants.FP_ReviewerNameList |  | int 2825
Constants.FP_RightColNum |  | int 1344
Constants.FP_RightIndent |  | int 570
Constants.FP_RightIndentChange |  | int 2006
Constants.FP_RightMargin |  | int 233
Constants.FP_RightMasterPage |  | int 414
Constants.FP_RowIsShown |  | int 1254
Constants.FP_RowKeepWithNext |  | int 1248
Constants.FP_RowKeepWithPrev |  | int 1249
Constants.FP_RowMaxHeight |  | int 1250
Constants.FP_RowMinHeight |  | int 1251
Constants.FP_RowStart |  | int 1252
Constants.FP_RowTbl |  | int 1246
Constants.FP_RowType |  | int 1253
Constants.FP_RpcProgramNumber |  | int 77
Constants.FP_RpcPropertyName |  | int 76
Constants.FP_RubiAlignAtLineBounds |  | int 193
Constants.FP_RubiElement |  | int 2176
Constants.FP_RubiFixedSize |  | int 187
Constants.FP_RubiOverhang |  | int 192
Constants.FP_RubiSize |  | int 186
Constants.FP_RubiTextRange |  | int 1471
Constants.FP_RuleClauseType |  | int 2152
Constants.FP_RulingGap |  | int 1433
Constants.FP_RulingLines |  | int 1435
Constants.FP_RulingPenWidth |  | int 1432
Constants.FP_RulingSep |  | int 1434
Constants.FP_RunInSeparator |  | int 578
Constants.FP_Runaround |  | int 787
Constants.FP_RunaroundGap |  | int 754
Constants.FP_ScreenCaptureDocToFile |  | int 195
Constants.FP_ScreenHeight |  | int 36
Constants.FP_ScreenWidth |  | int 35
Constants.FP_ScreenX |  | int 33
Constants.FP_ScreenY |  | int 34
Constants.FP_SecNumComputeMethod |  | int 915
Constants.FP_SectionNumStyle |  | int 916
Constants.FP_SectionNumText |  | int 918
Constants.FP_SectionNumber |  | int 917
Constants.FP_SelectedRowItems |  | int 1719
Constants.FP_SelectedTbl |  | int 129
Constants.FP_Sensitivity |  | int 1708
Constants.FP_SepOverride |  | int 1140
Constants.FP_SeparateInclusions |  | int 1493
Constants.FP_ServerState |  | int 2808
Constants.FP_ServerUrl |  | int 2807
Constants.FP_Shadow |  | int 613
Constants.FP_ShiftOrUnshiftCommand |  | int 1940
Constants.FP_ShowAll |  | int 155
Constants.FP_ShowCondIndicators |  | int 156
Constants.FP_ShowElementDescriptiveNames |  | int 1501
Constants.FP_SideHeadGap |  | int 1173
Constants.FP_SideHeadPlacement |  | int 1171
Constants.FP_SideHeadRoomInFlow |  | int 1174
Constants.FP_SideHeadWidth |  | int 1172
Constants.FP_SideOffset |  | int 877
Constants.FP_Size |  | int 1712
Constants.FP_SkipBlankSeps |  | int 464
Constants.FP_SmallCapsSize |  | int 182
Constants.FP_SmallCapsStretch |  | int 185
Constants.FP_SmartQuotes |  | int 237
Constants.FP_SmartSpaces |  | int 239
Constants.FP_Snap |  | int 151
Constants.FP_SnapAngle |  | int 394
Constants.FP_SnapGridUnits |  | int 393
Constants.FP_SortingEnabled |  | int 1718
Constants.FP_Source |  | int 2854
Constants.FP_SourceType |  | int 2855
Constants.FP_SpaceAbove |  | int 553
Constants.FP_SpaceAboveChange |  | int 2002
Constants.FP_SpaceBelow |  | int 568
Constants.FP_SpaceBelowChange |  | int 2003
Constants.FP_Spacing |  | int 1167
Constants.FP_Specification |  | int 2150
Constants.FP_SpecificationForCSS |  | int 2161
Constants.FP_SpecifiedKeyCatalog |  | int 2858
Constants.FP_SpotColorView |  | int 392
Constants.FP_Spread |  | int 618
Constants.FP_SpreadChange |  | int 2013
Constants.FP_StackWarningLevel |  | int 2404
Constants.FP_Start |  | int 567
Constants.FP_State |  | int 1702
Constants.FP_StatusLine |  | int 108
Constants.FP_StopCountingAt |  | int 2102
Constants.FP_Stretch |  | int 643
Constants.FP_StretchChange |  | int 2026
Constants.FP_Strikethrough |  | int 609
Constants.FP_Strings |  | int 337
Constants.FP_StructAppAttrConfigFile |  | int 1500
Constants.FP_StructAppsFile |  | int 2889
Constants.FP_StructAppsFileId |  | int 2890
Constants.FP_StructureCursorTypes |  | int 2296
Constants.FP_StructuredApplication |  | int 1495
Constants.FP_StructuredApplicationForOpen |  | int 1498
Constants.FP_StructuredApplicationList |  | int 1497
Constants.FP_StructuredDummyDocText |  | int 2883
Constants.FP_StyleOverride |  | int 1142
Constants.FP_StyleOverrides |  | int 1151
Constants.FP_StyleTag |  | int 770
Constants.FP_SubFmtRule |  | int 2156
Constants.FP_SubScriptShift |  | int 181
Constants.FP_SubScriptSize |  | int 180
Constants.FP_SubScriptStretch |  | int 184
Constants.FP_SubsecNumComputeMethod |  | int 815
Constants.FP_SubsectionNumStyle |  | int 816
Constants.FP_SubsectionNumText |  | int 818
Constants.FP_SubsectionNumber |  | int 817
Constants.FP_SuffixRules |  | int 1588
Constants.FP_SuperScriptShift |  | int 179
Constants.FP_SuperScriptSize |  | int 178
Constants.FP_SuperScriptStretch |  | int 183
Constants.FP_SuppressXMLParserWarnings |  | int 2419
Constants.FP_Symbols |  | int 334
Constants.FP_SymbolsList |  | int 335
Constants.FP_SystemVar |  | int 1049
Constants.FP_TabStops |  | int 1715
Constants.FP_TableTagging |  | int 1585
Constants.FP_Tabs |  | int 574
Constants.FP_TailArrow |  | int 744
Constants.FP_TblAlignment |  | int 1282
Constants.FP_TblBodyElement |  | int 2174
Constants.FP_TblBodyFirstColor |  | int 1299
Constants.FP_TblBodyFirstFill |  | int 1298
Constants.FP_TblBodyFirstPeriod |  | int 1301
Constants.FP_TblBodyNextColor |  | int 1304
Constants.FP_TblBodyNextFill |  | int 1302
Constants.FP_TblBodyNextPeriod |  | int 1303
Constants.FP_TblBodyRowRuling |  | int 1310
Constants.FP_TblBodyRowRulingPeriod |  | int 1294
Constants.FP_TblBodyShadeBy |  | int 1300
Constants.FP_TblBottomRuling |  | int 1306
Constants.FP_TblCatalogEntry |  | int 1292
Constants.FP_TblCellBottomMargin |  | int 1316
Constants.FP_TblCellLeftMargin |  | int 1317
Constants.FP_TblCellRightMargin |  | int 1318
Constants.FP_TblCellTopMargin |  | int 1315
Constants.FP_TblColRuling |  | int 1309
Constants.FP_TblColRulingPeriod |  | int 1293
Constants.FP_TblColWidths |  | int 1345
Constants.FP_TblElement |  | int 2171
Constants.FP_TblFnCellPosition |  | int 318
Constants.FP_TblFnCellPrefix |  | int 320
Constants.FP_TblFnCellSuffix |  | int 319
Constants.FP_TblFnCustNumString |  | int 317
Constants.FP_TblFnFmt |  | int 315
Constants.FP_TblFnNumComputeMethod |  | int 324
Constants.FP_TblFnNumStyle |  | int 316
Constants.FP_TblFnPosition |  | int 321
Constants.FP_TblFnPrefix |  | int 322
Constants.FP_TblFnSuffix |  | int 323
Constants.FP_TblFooterElement |  | int 2175
Constants.FP_TblHFColor |  | int 1297
Constants.FP_TblHFFill |  | int 1296
Constants.FP_TblHFRowRuling |  | int 1312
Constants.FP_TblHFSeparatorRuling |  | int 1311
Constants.FP_TblHeaderElement |  | int 2173
Constants.FP_TblInLockedTi |  | int 1319
Constants.FP_TblInitNumBodyRows |  | int 1286
Constants.FP_TblInitNumCols |  | int 1284
Constants.FP_TblInitNumFRows |  | int 1287
Constants.FP_TblInitNumHRows |  | int 1285
Constants.FP_TblLastBodyRuling |  | int 1295
Constants.FP_TblLeftIndent |  | int 1278
Constants.FP_TblLeftRuling |  | int 1307
Constants.FP_TblNumCols |  | int 1335
Constants.FP_TblNumRows |  | int 1336
Constants.FP_TblNumbering |  | int 1288
Constants.FP_TblOtherBodyRowRuling |  | int 1313
Constants.FP_TblOtherColRuling |  | int 1314
Constants.FP_TblPlacement |  | int 1283
Constants.FP_TblRightIndent |  | int 1279
Constants.FP_TblRightRuling |  | int 1308
Constants.FP_TblSpaceAbove |  | int 1280
Constants.FP_TblSpaceBelow |  | int 1281
Constants.FP_TblTag |  | int 1275
Constants.FP_TblTitleElement |  | int 2172
Constants.FP_TblTitleGap |  | int 1290
Constants.FP_TblTitlePosition |  | int 1289
Constants.FP_TblTitleSelected |  | int 1346
Constants.FP_TblTopRuling |  | int 1305
Constants.FP_TblWidth |  | int 1340
Constants.FP_TechSuiteInternal |  | int 2409
Constants.FP_TechSuiteInternal2 |  | int 2411
Constants.FP_TemplateDatas |  | int 4007
Constants.FP_Text |  | int 1701
Constants.FP_TextColor |  | int 1503
Constants.FP_TextFmtRules |  | int 1582
Constants.FP_TextIsInvalidInElement |  | int 1660
Constants.FP_TextLineType |  | int 1095
Constants.FP_TextLoc |  | int 879
Constants.FP_TextRange |  | int 1071
Constants.FP_TextSelection |  | int 109
Constants.FP_Theta |  | int 831
Constants.FP_TiAutomaticUpdate |  | int 2051
Constants.FP_TiByRows |  | int 2069
Constants.FP_TiClientData |  | int 2079
Constants.FP_TiClientName |  | int 2076
Constants.FP_TiClientSource |  | int 2077
Constants.FP_TiClientType |  | int 2078
Constants.FP_TiClientUpdateSilent |  | int 2080
Constants.FP_TiEOLisEOP |  | int 2065
Constants.FP_TiFile |  | int 2053
Constants.FP_TiFileModDate |  | int 2057
Constants.FP_TiFlowName |  | int 2060
Constants.FP_TiFlowPageSpace |  | int 2061
Constants.FP_TiFormat |  | int 2062
Constants.FP_TiHeadersEmpty |  | int 2068
Constants.FP_TiIsNested |  | int 2058
Constants.FP_TiIsUnresolved |  | int 2075
Constants.FP_TiLocked |  | int 2056
Constants.FP_TiMacEdition |  | int 2054
Constants.FP_TiMainFlow |  | int 2059
Constants.FP_TiNumCols |  | int 2072
Constants.FP_TiNumHeaderRows |  | int 2067
Constants.FP_TiNumSeparators |  | int 2071
Constants.FP_TiRemoveOverrides |  | int 2064
Constants.FP_TiRemovePageBreaks |  | int 2063
Constants.FP_TiSeparator |  | int 2070
Constants.FP_TiTblTag |  | int 2066
Constants.FP_TiTextEncoding |  | int 2073
Constants.FP_TintBaseColor |  | int 1467
Constants.FP_TintPercent |  | int 755
Constants.FP_TmpDir |  | int 86
Constants.FP_ToolBar |  | int 95
Constants.FP_ToolTipText |  | int 1727
Constants.FP_TopMargin |  | int 230
Constants.FP_TopRowSelection |  | int 1341
Constants.FP_TopSepAtIndent |  | int 2009
Constants.FP_TopSeparator |  | int 554
Constants.FP_TopicRefAbsoluteFilePath |  | int 2347
Constants.FP_TrackChangesAddedColor |  | int 2826
Constants.FP_TrackChangesDeletedColor |  | int 2827
Constants.FP_TrackChangesOn |  | int 2819
Constants.FP_Transient |  | int 1031
Constants.FP_TrapwiseCompatibility |  | int 495
Constants.FP_Tsume |  | int 649
Constants.FP_TypeOfDisplayText |  | int 500
Constants.FP_UIColorBackground |  | int 2297
Constants.FP_UIColorRuler |  | int 2298
Constants.FP_Underlining |  | int 608
Constants.FP_UndoFDKRecording |  | int 2403
Constants.FP_Unique |  | int 21
Constants.FP_Untouchable |  | int 146
Constants.FP_UpdatingStructure |  | int 2888
Constants.FP_UseAFrameIsCropped |  | int 3015
Constants.FP_UseAFrameIsFloating |  | int 3014
Constants.FP_UseAlignment |  | int 3018
Constants.FP_UseAnchorType |  | int 3013
Constants.FP_UseAngle |  | int 3007
Constants.FP_UseBaselineOffset |  | int 3017
Constants.FP_UseBkColor |  | int 991
Constants.FP_UseBorderWidth |  | int 3001
Constants.FP_UseCapitalization |  | int 636
Constants.FP_UseChangeBar |  | int 628
Constants.FP_UseColGapWidth |  | int 3020
Constants.FP_UseColor |  | int 638
Constants.FP_UseColumnsAreBalanced |  | int 3028
Constants.FP_UseDTheta |  | int 3024
Constants.FP_UseFMConsoleForErrorLog |  | int 825
Constants.FP_UseFill |  | int 3002
Constants.FP_UseFlowIsAutoConnect |  | int 3031
Constants.FP_UseFlowIsPostScript |  | int 3032
Constants.FP_UseFontAngle |  | int 624
Constants.FP_UseFontFamily |  | int 621
Constants.FP_UseFontSize |  | int 632
Constants.FP_UseFontVariation |  | int 622
Constants.FP_UseFontWeight |  | int 623
Constants.FP_UseHeight |  | int 3011
Constants.FP_UseInitialStructure |  | int 1492
Constants.FP_UseInitialStructureOfAutoInsertedElements |  | int 1499
Constants.FP_UseInsetDpi |  | int 3027
Constants.FP_UseKernX |  | int 633
Constants.FP_UseKernY |  | int 634
Constants.FP_UseLanguage |  | int 645
Constants.FP_UseLocX |  | int 3008
Constants.FP_UseLocY |  | int 3009
Constants.FP_UseMathMLComposeDpi |  | int 3033
Constants.FP_UseMathMLDpi |  | int 3035
Constants.FP_UseMathMLFontSize |  | int 3034
Constants.FP_UseMathSize |  | int 3026
Constants.FP_UseNextTag |  | int 566
Constants.FP_UseNumColumns |  | int 3019
Constants.FP_UseOutline |  | int 629
Constants.FP_UseOverline |  | int 627
Constants.FP_UseOverprint |  | int 3006
Constants.FP_UsePairKern |  | int 631
Constants.FP_UsePen |  | int 3003
Constants.FP_UsePosition |  | int 637
Constants.FP_UseRadius |  | int 3030
Constants.FP_UseRunaround |  | int 3012
Constants.FP_UseRunaroundGap |  | int 3004
Constants.FP_UseSepOverride |  | int 1141
Constants.FP_UseShadow |  | int 630
Constants.FP_UseSideHeadGap |  | int 3022
Constants.FP_UseSideHeadPlacement |  | int 3029
Constants.FP_UseSideHeadWidth |  | int 3021
Constants.FP_UseSideOffset |  | int 3016
Constants.FP_UseSpread |  | int 635
Constants.FP_UseStretch |  | int 644
Constants.FP_UseStrikethrough |  | int 626
Constants.FP_UseTextLineType |  | int 3025
Constants.FP_UseTheta |  | int 3023
Constants.FP_UseTintPercent |  | int 3005
Constants.FP_UseTsume |  | int 650
Constants.FP_UseUnderlining |  | int 625
Constants.FP_UseWidth |  | int 3010
Constants.FP_UserHomeDir |  | int 84
Constants.FP_UserLogin |  | int 83
Constants.FP_UserName |  | int 82
Constants.FP_UserSettingsDir |  | int 152
Constants.FP_UserString |  | int 22
Constants.FP_ValidHighestLevel |  | int 1574
Constants.FP_Validating |  | int 94
Constants.FP_ValidationFlags |  | int 1668
Constants.FP_VarFmt |  | int 1047
Constants.FP_Variables |  | int 336
Constants.FP_VersionMajor |  | int 43
Constants.FP_VersionMinor |  | int 44
Constants.FP_VersionRevision |  | int 41
Constants.FP_VerticalSpreadLarge |  | int 345
Constants.FP_VerticalSpreadMed |  | int 344
Constants.FP_VerticalSpreadSmall |  | int 343
Constants.FP_View |  | int 1945
Constants.FP_ViewBorders |  | int 382
Constants.FP_ViewDisplayUnits |  | int 390
Constants.FP_ViewFontSizeUnits |  | int 396
Constants.FP_ViewGrid |  | int 389
Constants.FP_ViewGridUnits |  | int 386
Constants.FP_ViewHotspotIndicators |  | int 2357
Constants.FP_ViewLinkBoundaries |  | int 395
Constants.FP_ViewNoGraphics |  | int 384
Constants.FP_ViewOnlyDeadCodes |  | int 140
Constants.FP_ViewOnlyMenuBar |  | int 144
Constants.FP_ViewOnlySelect |  | int 139
Constants.FP_ViewOnlyWinBorders |  | int 136
Constants.FP_ViewOnlyWinMenubar |  | int 135
Constants.FP_ViewOnlyWinPalette |  | int 134
Constants.FP_ViewOnlyWinPopup |  | int 137
Constants.FP_ViewOnlyXRef |  | int 138
Constants.FP_ViewPageScrolling |  | int 385
Constants.FP_ViewRulerUnits |  | int 391
Constants.FP_ViewRulers |  | int 383
Constants.FP_ViewTextSymbols |  | int 388
Constants.FP_Visibility |  | int 1713
Constants.FP_VolNumComputeMethod |  | int 211
Constants.FP_VolumeNumStyle |  | int 213
Constants.FP_VolumeNumText |  | int 214
Constants.FP_VolumeNumber |  | int 212
Constants.FP_WesternFamily |  | int 2284
Constants.FP_WesternFontPanoseName |  | int 648
Constants.FP_WesternFontPlatformName |  | int 646
Constants.FP_WesternFontPostScriptName |  | int 647
Constants.FP_WesternShift |  | int 2286
Constants.FP_WesternSize |  | int 2285
Constants.FP_WideRubiSpaceForJapanese |  | int 189
Constants.FP_WideRubiSpaceForOther |  | int 191
Constants.FP_Width |  | int 783
Constants.FP_Window |  | int 1946
Constants.FP_WindowHandle |  | int 1717
Constants.FP_WindowSystem |  | int 47
Constants.FP_XMLStructuredApplicationList |  | int 1598
Constants.FP_XRefAltText |  | int 1153
Constants.FP_XRefClientName |  | int 1154
Constants.FP_XRefClientType |  | int 1155
Constants.FP_XRefFile |  | int 1070
Constants.FP_XRefFmt |  | int 1073
Constants.FP_XRefIsUnresolved |  | int 1077
Constants.FP_XRefResolvedWithKeyref |  | int 1156
Constants.FP_XRefRetainKeydefText |  | int 1157
Constants.FP_XRefSrcElemNonUniqueId |  | int 1152
Constants.FP_XRefSrcIsElem |  | int 1076
Constants.FP_XRefSrcText |  | int 1075
Constants.FP_XSLTProcessors |  | int 1506
Constants.FP_XSLTTransformationScenarioFile |  | int 1505
Constants.FP_XmlApplicationForBookComponent |  | int 2330
Constants.FP_XmlDocType |  | int 2810
Constants.FP_XmlEncoding |  | int 2801
Constants.FP_XmlFileEncoding |  | int 2809
Constants.FP_XmlIsBook |  | int 823
Constants.FP_XmlLock |  | int 2841
Constants.FP_XmlPublicId |  | int 2811
Constants.FP_XmlStandAlone |  | int 2802
Constants.FP_XmlStyleSheet |  | int 2803
Constants.FP_XmlStyleSheetList |  | int 2804
Constants.FP_XmlSystemId |  | int 2812
Constants.FP_XmlUseBOM |  | int 2805
Constants.FP_XmlVersion |  | int 2800
Constants.FP_XmlWellFormed |  | int 2806
Constants.FP_YakumonoType |  | int 597
Constants.FP_Year |  | int 1726
Constants.FP_Yellow |  | int 1459
Constants.FP_Zoom |  | int 387
Constants.FR_CancelInsertElementOperation |  | int -10010
Constants.FR_CancelOperation |  | int -10001
Constants.FR_ClosedXRefDialog |  | int -10008
Constants.FR_CommandDisabled |  | int -10022
Constants.FR_CommandEnabled |  | int -10021
Constants.FR_DialogStayUp |  | int -10000
Constants.FR_DisplayedModalDialogForNonContainerElem |  | int -10012
Constants.FR_DisplayedModelessDialogForNonContainerElem |  | int -10009
Constants.FR_DisplayedTiDialog |  | int -10002
Constants.FR_DisplayedXRefDialog |  | int -10007
Constants.FR_ECMImportSuccess |  | int -10003
Constants.FR_HideDialogOnClose |  | int -10011
Constants.FR_KeyCatalogLoaded |  | int -10020
Constants.FR_ModalStayUp |  | int -10000
Constants.FR_NoOperation |  | int -10006
Constants.FR_SkipStep |  | int -10004
Constants.FR_USE_EGREP |  | int 3
Constants.FR_USE_GREP |  | int 2
Constants.FR_USE_PERL |  | int 1
Constants.FR_UpdateDITAReferenceFailed |  | int -10014
Constants.FR_UpdateDITAReferenceFailedCannotConvertToFMObject |  | int -10019
Constants.FR_UpdateDITAReferenceFailedCannotFindReferencedFile |  | int -10017
Constants.FR_UpdateDITAReferenceFailedCannotOpenReferencedFile |  | int -10018
Constants.FR_UpdateDITAReferenceFailedCannotResolveReference |  | int -10016
Constants.FR_UpdateDITAReferenceFailedInvalidElementType |  | int -10015
Constants.FR_UpdateDITAReferenceSuccess |  | int -10013
Constants.FR_YesOperation |  | int -10005
Constants.FS_AlertUserAboutFailure |  | int 2
Constants.FS_AllowInconsistentNumProps |  | int 6
Constants.FS_AllowNonFMFiles |  | int 1
Constants.FS_AllowViewOnlyFiles |  | int 3
Constants.FS_AutoBackupOnSave |  | int 6
Constants.FS_BeefyDoc |  | int 32
Constants.FS_BookIsInUse |  | int 18
Constants.FS_CMSId |  | int 48
Constants.FS_CMSSessionId |  | int 49
Constants.FS_CellSeparator |  | int 29
Constants.FS_ClientUpdateSilent |  | int 47
Constants.FS_DisallowBookDoc |  | int 10
Constants.FS_DisallowBookMIF |  | int 9
Constants.FS_DisallowDoc |  | int 8
Constants.FS_DisallowFilterTypes |  | int 11
Constants.FS_DisallowGraphicTypes |  | int 9
Constants.FS_DisallowMIF |  | int 7
Constants.FS_DisallowMacEditions |  | int 10
Constants.FS_DisallowPlainText |  | int 12
Constants.FS_DisallowSgml |  | int 33
Constants.FS_DisallowXml |  | int 43
Constants.FS_DitaGenerateComponentsAtOneLoc |  | int 26
Constants.FS_DitaGenerateFlatBook |  | int 25
Constants.FS_DitaPostProcessingOnBook |  | int 27
Constants.FS_DitaSavePdfViaBook |  | int 28
Constants.FS_DitavalCondTag |  | int 23
Constants.FS_DitavalFile |  | int 22
Constants.FS_Doctype |  | int 2
Constants.FS_DontNotifyAPIClients |  | int 3
Constants.FS_Export |  | int 4
Constants.FS_ExportFileName |  | int 1
Constants.FS_ExportFileTypeHint |  | int 14
Constants.FS_ExportNativeError |  | int 2
Constants.FS_ExportObjectId |  | int 7
Constants.FS_ExportObjectNeedsDpi |  | int 12
Constants.FS_ExportStatus |  | int 3
Constants.FS_ExportTextRange |  | int 6
Constants.FS_ExportType |  | int 5
Constants.FS_Extension |  | int 5
Constants.FS_FileIsGraphic |  | int 13
Constants.FS_FileIsInUse |  | int 17
Constants.FS_FileIsMakerDoc |  | int 18
Constants.FS_FileIsOldVersion |  | int 20
Constants.FS_FileIsSgmlDoc |  | int 32
Constants.FS_FileIsStructured |  | int 21
Constants.FS_FileIsText |  | int 16
Constants.FS_FileIsXmlDoc |  | int 37
Constants.FS_FileType |  | int 1
Constants.FS_FileTypeHint |  | int 34
Constants.FS_FindCharFmt |  | int 3
Constants.FS_FindCharTag |  | int 5
Constants.FS_FindCondTextInCondTags |  | int 13
Constants.FS_FindCondTextNotInCondTags |  | int 14
Constants.FS_FindCustomizationFlags |  | int 15
Constants.FS_FindElementTag |  | int 2
Constants.FS_FindMarkerOfType |  | int 9
Constants.FS_FindMarkerText |  | int 10
Constants.FS_FindNamedVariable |  | int 12
Constants.FS_FindObject |  | int 8
Constants.FS_FindPgfTag |  | int 4
Constants.FS_FindStyleTag |  | int 18
Constants.FS_FindTableTag |  | int 6
Constants.FS_FindText |  | int 1
Constants.FS_FindWrap |  | int 16
Constants.FS_FindXRefWithFormat |  | int 11
Constants.FS_FitGraphicInSelectedRect |  | int 14
Constants.FS_FontChangedMetric |  | int 23
Constants.FS_FontNotFoundInCatalog |  | int 28
Constants.FS_FontNotFoundInDoc |  | int 22
Constants.FS_ForceImportAsText |  | int 17
Constants.FS_ForceOpenAsText |  | int 13
Constants.FS_FormatImportedText |  | int 22
Constants.FS_GraphicDpi |  | int 15
Constants.FS_HasUnsupportedHotspotShapes |  | int 29
Constants.FS_HowToImport |  | int 4
Constants.FS_ImportAsType |  | int 36
Constants.FS_ImportExportVersion |  | int 17
Constants.FS_ImportFlowPageSpace |  | int 21
Constants.FS_ImportFlowTag |  | int 20
Constants.FS_ImportNativeError |  | int 2
Constants.FS_ImportStatus |  | int 3
Constants.FS_ImportTblTag |  | int 25
Constants.FS_ImportedFileName |  | int 1
Constants.FS_InsetData |  | int 50
Constants.FS_InsetElementDef |  | int 52
Constants.FS_IsErrorDoc |  | int 46
Constants.FS_IterParamGetBookComponentFolder |  | int 4
Constants.FS_IterParamGetBookComponentGroup |  | int 5
Constants.FS_IterParamGetBookComponentRefBook |  | int 6
Constants.FS_IterParamGetBookComponentRefMap |  | int 7
Constants.FS_IterParamGetMapRef |  | int 12
Constants.FS_IterParamParseBookInBook |  | int 1
Constants.FS_IterParamParseMapInBook |  | int 2
Constants.FS_IterParamParseMapInMap |  | int 8
Constants.FS_IterParamSkipExcludedBookComponents |  | int 3
Constants.FS_IterParamSkipNonPrintTopicrefs |  | int 10
Constants.FS_IterParamSkipResourceOnlyTopicrefs |  | int 9
Constants.FS_IterParamSkipTopicsetrefs |  | int 11
Constants.FS_IteratorItemFieldBookId |  | int 1
Constants.FS_IteratorItemFieldDocId |  | int 2
Constants.FS_IteratorItemFieldObjId |  | int 3
Constants.FS_IteratorItemMaxFields |  | int 3
Constants.FS_LanguageNotAvailable |  | int 25
Constants.FS_LeaveHeadingRowsEmpty |  | int 27
Constants.FS_LockCantBeReset |  | int 19
Constants.FS_MakeIconic |  | int 6
Constants.FS_MakePageCount |  | int 7
Constants.FS_MakeVisible |  | int 5
Constants.FS_ManualUpdate |  | int 5
Constants.FS_MathMLNamespacePrefix |  | int 1
Constants.FS_ModDateChanged |  | int 21
Constants.FS_NameStripe |  | int 31
Constants.FS_NewDoc |  | int 29
Constants.FS_NoStructuredErrorLog |  | int 44
Constants.FS_NumCellSeparators |  | int 30
Constants.FS_NumColumns |  | int 31
Constants.FS_NumExportParams |  | int 17
Constants.FS_NumExportReturnParams |  | int 3
Constants.FS_NumImportParams |  | int 47
Constants.FS_NumImportReturnParams |  | int 3
Constants.FS_NumIteratorParams |  | int 12
Constants.FS_NumNewXMLParams |  | int 6
Constants.FS_NumOpenParams |  | int 51
Constants.FS_NumOpenReturnParams |  | int 3
Constants.FS_NumSaveParams |  | int 29
Constants.FS_NumSaveReturnParams |  | int 3
Constants.FS_NumSpellParams |  | int (1007-1000+1)
Constants.FS_NumUpdateBookParams |  | int 12
Constants.FS_NumUpdateBookReturnParams |  | int 1
Constants.FS_OpenAsType |  | int 41
Constants.FS_OpenBookViewOnly |  | int 42
Constants.FS_OpenDocFluid |  | int 37
Constants.FS_OpenDocViewOnly |  | int 30
Constants.FS_OpenFileNotWritable |  | int 40
Constants.FS_OpenId |  | int 27
Constants.FS_OpenInNewWindow |  | int 26
Constants.FS_OpenNativeError |  | int 2
Constants.FS_OpenStatus |  | int 3
Constants.FS_OpenedFileName |  | int 1
Constants.FS_OutputFilePathName |  | int 1006
Constants.FS_PDFPageNum |  | int 45
Constants.FS_PublicId |  | int 3
Constants.FS_RasterDpi |  | int 38
Constants.FS_RasterImageHeight |  | int 40
Constants.FS_RasterImageWidth |  | int 39
Constants.FS_RefFileNotFound |  | int 24
Constants.FS_RegexFlavour |  | int 17
Constants.FS_RemoveManualPageBreaks |  | int 23
Constants.FS_RemoveOverrides |  | int 24
Constants.FS_RetainNameStripe |  | int 12
Constants.FS_SaveAsModeName |  | int 5
Constants.FS_SaveFileNotWritable |  | int 20
Constants.FS_SaveFileTypeHint |  | int 16
Constants.FS_SaveMode |  | int 4
Constants.FS_SaveNativeError |  | int 2
Constants.FS_SaveStatus |  | int 3
Constants.FS_SaveTextExtraBlankLineAtEOP |  | int 10
Constants.FS_SaveTextTblSetting |  | int 9
Constants.FS_SavedFileName |  | int 1
Constants.FS_SgmlBookFileName |  | int 39
Constants.FS_ShowBookErrorLog |  | int 4
Constants.FS_ShowBrowser |  | int 1
Constants.FS_ShowRasterDpiDialog |  | int 41
Constants.FS_ShowSaveTextDialog |  | int 8
Constants.FS_SilentlyDisallowXML |  | int 51
Constants.FS_SpellAction |  | int 1005
Constants.FS_SpellOptions |  | int 1000
Constants.FS_SpellWrap |  | int 1007
Constants.FS_StructuredApplication |  | int 1
Constants.FS_StructuredExportApplication |  | int 16
Constants.FS_StructuredImportApplication |  | int 35
Constants.FS_StructuredOpenApplication |  | int 38
Constants.FS_StructuredSaveApplication |  | int 18
Constants.FS_SystemId |  | int 4
Constants.FS_TblNumHeadingRows |  | int 26
Constants.FS_TemplateShouldInsertRoot |  | int 47
Constants.FS_TextAfterString |  | int 1003
Constants.FS_TextBeforeString |  | int 1002
Constants.FS_TextInsetName |  | int 6
Constants.FS_TreatParaAsRow |  | int 28
Constants.FS_TwoInARowString |  | int 1001
Constants.FS_UNIXpermissions |  | int 13
Constants.FS_UpdateBookGeneratedFiles |  | int 7
Constants.FS_UpdateBookMasterPages |  | int 12
Constants.FS_UpdateBookNumbering |  | int 8
Constants.FS_UpdateBookOleLinks |  | int 9
Constants.FS_UpdateBookStatus |  | int 1
Constants.FS_UpdateBookTextReferences |  | int 10
Constants.FS_UpdateBookXRefs |  | int 11
Constants.FS_UpdateBrowserDirectory |  | int 4
Constants.FS_UpdateFRVList |  | int 14
Constants.FS_UpdateTemplateData |  | int 50
Constants.FS_UpdateTextReferences |  | int 35
Constants.FS_UpdateXRefs |  | int 36
Constants.FS_UseAutoSaveFile |  | int 15
Constants.FS_UseDefaultUNIXpermissions |  | int 11
Constants.FS_UseHTTP |  | int 51
Constants.FS_UseMainFlow |  | int 19
Constants.FS_UseRecoverFile |  | int 14
Constants.FS_VerifyInsets |  | int 45
Constants.FS_Visible |  | int 6
Constants.FS_WordContainString |  | int 1004
Constants.FTF_ALL |  | int 0xFFFFFE03
Constants.FTF_ANGLE |  | int 0x10000000
Constants.FTF_CAPITALIZATION |  | int 0x00004000
Constants.FTF_CHANGEBAR |  | int 0x01000000
Constants.FTF_CHARTAG |  | int 0x00008000
Constants.FTF_COLOR |  | int 0x00010000
Constants.FTF_CONDITIONTAG |  | int 0x00000001
Constants.FTF_ENCODING |  | int 0x00000200
Constants.FTF_FAMILY |  | int 0x80000000
Constants.FTF_IIF |  | int 0x00000002
Constants.FTF_KERNX |  | int 0x00080000
Constants.FTF_KERNY |  | int 0x00040000
Constants.FTF_LANGUAGE |  | int 0x00000800
Constants.FTF_OUTLINE |  | int 0x00800000
Constants.FTF_OVERLINE |  | int 0x02000000
Constants.FTF_PAIRKERN |  | int 0x00200000
Constants.FTF_POSITION |  | int 0x00002000
Constants.FTF_SHADOW |  | int 0x00400000
Constants.FTF_SIZE |  | int 0x00100000
Constants.FTF_SPREAD |  | int 0x00020000
Constants.FTF_STRETCH |  | int 0x00001000
Constants.FTF_STRIKETHROUGH |  | int 0x04000000
Constants.FTF_TSUME |  | int 0x00000400
Constants.FTF_UNDERLINING |  | int 0x08000000
Constants.FTF_VARIATION |  | int 0x40000000
Constants.FTF_WEIGHT |  | int 0x20000000
Constants.FTI2_RubiCompositeBegin |  | int 0x80000004
Constants.FTI2_RubiCompositeEnd |  | int 0x80000008
Constants.FTI2_RubiTextBegin |  | int 0x80000001
Constants.FTI2_RubiTextEnd |  | int 0x80000002
Constants.FTI_CharPropsChange |  | int 0x00200000
Constants.FTI_ElemPrefixBegin |  | int 0x08000000
Constants.FTI_ElemPrefixEnd |  | int 0x10000000
Constants.FTI_ElemSuffixBegin |  | int 0x20000000
Constants.FTI_ElemSuffixEnd |  | int 0x40000000
Constants.FTI_ElementBegin |  | int 0x00080000
Constants.FTI_ElementEnd |  | int 0x00100000
Constants.FTI_FlowBegin |  | int 0x00000020
Constants.FTI_FlowEnd |  | int 0x00000040
Constants.FTI_FnAnchor |  | int 0x00001000
Constants.FTI_FrameAnchor |  | int 0x00000800
Constants.FTI_HardLineEnd |  | int 1
Constants.FTI_HyphenLineEnd |  | int 2
Constants.FTI_LineBegin |  | int 0x00000002
Constants.FTI_LineEnd |  | int 0x00000004
Constants.FTI_MarkerAnchor |  | int 0x00004000
Constants.FTI_PageBegin |  | int 0x00000080
Constants.FTI_PageEnd |  | int 0x00000100
Constants.FTI_PgfBegin |  | int 0x00000008
Constants.FTI_PgfEnd |  | int 0x00000010
Constants.FTI_String |  | int 0x00000001
Constants.FTI_SubColBegin |  | int 0x00000200
Constants.FTI_SubColEnd |  | int 0x00000400
Constants.FTI_TblAnchor |  | int 0x00002000
Constants.FTI_TextFrameBegin |  | int 0x00400000
Constants.FTI_TextFrameEnd |  | int 0x00800000
Constants.FTI_TextInsetBegin |  | int 0x02000000
Constants.FTI_TextInsetEnd |  | int 0x04000000
Constants.FTI_TextObjId |  | int 0x01000000
Constants.FTI_VarBegin |  | int 0x00020000
Constants.FTI_VarEnd |  | int 0x00040000
Constants.FTI_XRefBegin |  | int 0x00008000
Constants.FTI_XRefEnd |  | int 0x00010000
Constants.FT_AttributeDefs |  | int 17
Constants.FT_Attributes |  | int 18
Constants.FT_AttributesEx |  | int 21
Constants.FT_Bad |  | int 0
Constants.FT_ElementCatalog |  | int 12
Constants.FT_ElementRange |  | int 19
Constants.FT_FormatBranches |  | int 16
Constants.FT_Id |  | int 4
Constants.FT_Integer |  | int 1
Constants.FT_Ints |  | int 13
Constants.FT_Metric |  | int 2
Constants.FT_Metrics |  | int 5
Constants.FT_Num |  | int 23
Constants.FT_Points |  | int 7
Constants.FT_String |  | int 3
Constants.FT_Strings |  | int 6
Constants.FT_Tabs |  | int 8
Constants.FT_TemplateDatas |  | int 22
Constants.FT_TextLoc |  | int 9
Constants.FT_TextRange |  | int 10
Constants.FT_UBytes |  | int 14
Constants.FT_UInts |  | int 15
Constants.FT_Vals |  | int 20
Constants.FV_ACCESSBAR_CLOSE |  | int 2
Constants.FV_ACCESSBAR_OPEN |  | int 1
Constants.FV_AF_FIXED |  | int 0x0004
Constants.FV_AF_HIDDEN |  | int 0x0002
Constants.FV_AF_READ_ONLY |  | int 0x0001
Constants.FV_ALIGN_CENTER |  | int 1
Constants.FV_ALIGN_INSIDE |  | int 3
Constants.FV_ALIGN_LEFT |  | int 0
Constants.FV_ALIGN_OUTSIDE |  | int 4
Constants.FV_ALIGN_RIGHT |  | int 2
Constants.FV_ALIGN_TBL_CENTER |  | int 1
Constants.FV_ALIGN_TBL_LEFT |  | int 0
Constants.FV_ALIGN_TBL_RIGHT |  | int 2
Constants.FV_ALTERNATIVE |  | int 0x04
Constants.FV_ANCHOR_BELOW |  | int 3
Constants.FV_ANCHOR_BOTTOM |  | int 4
Constants.FV_ANCHOR_INLINE |  | int 1
Constants.FV_ANCHOR_RUN_INTO_PARAGRAPH |  | int 17
Constants.FV_ANCHOR_SUBCOL_FARTHEST |  | int 8
Constants.FV_ANCHOR_SUBCOL_INSIDE |  | int 9
Constants.FV_ANCHOR_SUBCOL_LEFT |  | int 5
Constants.FV_ANCHOR_SUBCOL_NEAREST |  | int 7
Constants.FV_ANCHOR_SUBCOL_OUTSIDE |  | int 10
Constants.FV_ANCHOR_SUBCOL_RIGHT |  | int 6
Constants.FV_ANCHOR_TEXTFRAME_FARTHEST |  | int 14
Constants.FV_ANCHOR_TEXTFRAME_INSIDE |  | int 15
Constants.FV_ANCHOR_TEXTFRAME_LEFT |  | int 11
Constants.FV_ANCHOR_TEXTFRAME_NEAREST |  | int 13
Constants.FV_ANCHOR_TEXTFRAME_OUTSIDE |  | int 16
Constants.FV_ANCHOR_TEXTFRAME_RIGHT |  | int 12
Constants.FV_ANCHOR_TOP |  | int 2
Constants.FV_ANSI |  | int 3
Constants.FV_ARROW_FILLED |  | int 0x3
Constants.FV_ARROW_HOLLOW |  | int 0x2
Constants.FV_ARROW_STICK |  | int 0x1
Constants.FV_ASCII |  | int 2
Constants.FV_ATTR_DISP_ALL |  | int 3
Constants.FV_ATTR_DISP_NONE |  | int 1
Constants.FV_ATTR_DISP_REQSPEC |  | int 2
Constants.FV_ATTR_EDIT_ALWAYS |  | int 2
Constants.FV_ATTR_EDIT_NONE |  | int 0
Constants.FV_ATTR_EDIT_REQUIRED |  | int 1
Constants.FV_AT_CHOICES |  | int 2
Constants.FV_AT_INTEGER |  | int 3
Constants.FV_AT_INTEGERS |  | int 4
Constants.FV_AT_NUMTYPES |  | int 10
Constants.FV_AT_REAL |  | int 5
Constants.FV_AT_REALS |  | int 6
Constants.FV_AT_STRING |  | int 0
Constants.FV_AT_STRINGS |  | int 1
Constants.FV_AT_UNIQUE_ID |  | int 7
Constants.FV_AT_UNIQUE_IDREF |  | int 8
Constants.FV_AT_UNIQUE_IDREFS |  | int 9
Constants.FV_AUTORECOGNIZE |  | int 0x00
Constants.FV_AV_IDREF_UNRESOLVED |  | int 4
Constants.FV_AV_ID_DUPLICATE_IN_BOOK |  | int 6
Constants.FV_AV_ID_DUPLICATE_IN_DOC |  | int 5
Constants.FV_AV_INVALID_CHOICE |  | int 2
Constants.FV_AV_INVALID_FORMAT |  | int 3
Constants.FV_AV_OUT_OF_RANGE |  | int 9
Constants.FV_AV_REQUIRED |  | int 1
Constants.FV_AV_TOO_MANY_TOKENS |  | int 7
Constants.FV_AV_UNDEFINED |  | int 8
Constants.FV_Above |  | int 1240
Constants.FV_AlertOneButton |  | int 1
Constants.FV_AlertThreeButton |  | int 3
Constants.FV_AlertTwoButton |  | int 2
Constants.FV_AllElements |  | int 2
Constants.FV_AllowAllRefFilesUnFindable |  | int 11
Constants.FV_ApiClientCanceledExport |  | int 34
Constants.FV_AutoSaveFileUsed |  | int 34
Constants.FV_BGD_DEFAULT |  | int 0x00
Constants.FV_BGD_NONE |  | int 0x01
Constants.FV_BGD_OTHER |  | int 0x02
Constants.FV_BIG5 |  | int 8
Constants.FV_BK_BOOK |  | int 0x4
Constants.FV_BK_BOOKMAP |  | int 0x100
Constants.FV_BK_DITAMAP |  | int 0x80
Constants.FV_BK_FILE |  | int 0x200
Constants.FV_BK_FILENAME |  | int 1
Constants.FV_BK_FM |  | int 0x8
Constants.FV_BK_FOLDER |  | int 0x2
Constants.FV_BK_GENERAL |  | int 0x1
Constants.FV_BK_GROUP |  | int 0x40
Constants.FV_BK_INDEX_AUTHOR |  | int 8
Constants.FV_BK_INDEX_FORMATS |  | int 13
Constants.FV_BK_INDEX_MARKER |  | int 10
Constants.FV_BK_INDEX_REFERENCES |  | int 14
Constants.FV_BK_INDEX_STAN |  | int 7
Constants.FV_BK_INDEX_SUBJECT |  | int 9
Constants.FV_BK_LIST_FIGURE |  | int 1
Constants.FV_BK_LIST_FORMATS |  | int 11
Constants.FV_BK_LIST_MARKER |  | int 4
Constants.FV_BK_LIST_MARKER_ALPHA |  | int 5
Constants.FV_BK_LIST_PGF |  | int 3
Constants.FV_BK_LIST_PGF_ALPHA |  | int 6
Constants.FV_BK_LIST_REFERENCES |  | int 12
Constants.FV_BK_LIST_TABLE |  | int 2
Constants.FV_BK_MIF |  | int 0x10
Constants.FV_BK_NOT_GENERATABLE |  | int 16
Constants.FV_BK_NUM_BOOK_LIST |  | int 15
Constants.FV_BK_START_FROM_FILE |  | int 0x01
Constants.FV_BK_START_LEFT |  | int 0x03
Constants.FV_BK_START_NEXT_AVAILABLE |  | int 0x02
Constants.FV_BK_START_RIGHT |  | int 0x04
Constants.FV_BK_TEXT |  | int 2
Constants.FV_BK_TOC |  | int 0
Constants.FV_BK_XML |  | int 0x20
Constants.FV_BODY_PAGE |  | int 0x00
Constants.FV_BadEnclosingDocId |  | int 28
Constants.FV_BadExportDocId |  | int 20
Constants.FV_BadExportFileName |  | int 16
Constants.FV_BadExportObjectId |  | int 18
Constants.FV_BadExportScriptValue |  | int 21
Constants.FV_BadFileId |  | int 35
Constants.FV_BadFileName |  | int 67
Constants.FV_BadFileRefsWereMapped |  | int 46
Constants.FV_BadFileType |  | int 66
Constants.FV_BadImportFileName |  | int 16
Constants.FV_BadImportFileType |  | int 17
Constants.FV_BadImportScriptValue |  | int 18
Constants.FV_BadSaveFileName |  | int 34
Constants.FV_BadSaveObjectId |  | int 40
Constants.FV_BadSaveScriptValue |  | int 36
Constants.FV_BadScriptValue |  | int 70
Constants.FV_BadTemplate |  | int 129
Constants.FV_BadTextFileTypeHint |  | int 29
Constants.FV_BadUpdateBookFileId |  | int 64
Constants.FV_BadUpdateBookScriptValue |  | int 65
Constants.FV_BeefyDoc |  | int 40
Constants.FV_Below |  | int 1241
Constants.FV_Body |  | int 1237
Constants.FV_BodyPage |  | int 10
Constants.FV_BookNotSelfConsistent |  | int 0
Constants.FV_BrowseCmsOnly |  | int 0x00020000
Constants.FV_BrowseLocalOnly |  | int 0x00010000
Constants.FV_BrowseLocalWithWebdavOnly |  | int 0x00040000
Constants.FV_CAPITAL_CASE_LOWER |  | int 2
Constants.FV_CAPITAL_CASE_NORM |  | int 0
Constants.FV_CAPITAL_CASE_SMALL |  | int 1
Constants.FV_CAPITAL_CASE_UPPER |  | int 3
Constants.FV_CAP_BUTT |  | int 0x00
Constants.FV_CAP_ROUND |  | int 0x01
Constants.FV_CAP_SQUARE |  | int 0x02
Constants.FV_CB_COL_FURTHEST |  | int 0x03
Constants.FV_CB_COL_LEFT |  | int 0x00
Constants.FV_CB_COL_NEAREST |  | int 0x02
Constants.FV_CB_COL_RIGHT |  | int 0x01
Constants.FV_CB_DOUBLE_UNDERLINE |  | int 2
Constants.FV_CB_NO_UNDERLINE |  | int 0
Constants.FV_CB_NUMERIC_UNDERLINE |  | int 3
Constants.FV_CB_SINGLE_UNDERLINE |  | int 1
Constants.FV_CHAR_CATALOG |  | int 6
Constants.FV_CMSCheckinUI_Id_CheckinComment |  | int FV_CMSCheckinUI_Id_CheckinComment
Constants.FV_CMSCheckinUI_Id_Description |  | int FV_CMSCheckinUI_Id_Description
Constants.FV_CMSCheckinUI_Id_MajorVersion |  | int FV_CMSCheckinUI_Id_MajorVersion
Constants.FV_CMSCheckinUI_Id_MakeThisCurrentVersion |  | int FV_CMSCheckinUI_Id_MakeThisCurrentVersion
Constants.FV_CMSCheckinUI_Id_MinorVersion |  | int FV_CMSCheckinUI_Id_MinorVersion
Constants.FV_CMSCheckinUI_Id_SameVersion |  | int FV_CMSCheckinUI_Id_SameVersion
Constants.FV_CMSCheckinUI_Id_VersionLabel |  | int FV_CMSCheckinUI_Id_VersionLabel
Constants.FV_CMSCheckoutUI_Id_ShowDependents |  | int FV_CMSCheckoutUI_Id_ShowDependents
Constants.FV_CMSCommandAdvancedSearchStringId |  | int FV_CMSCommandAdvancedSearchStringId
Constants.FV_CMSCommandCheckinCommentId |  | int FV_CMSCommandCheckinCommentId
Constants.FV_CMSCommandCheckinDescriptionId |  | int FV_CMSCommandCheckinDescriptionId
Constants.FV_CMSCommandCheckinKeepLocalCopyId |  | int FV_CMSCommandCheckinKeepLocalCopyId
Constants.FV_CMSCommandCheckinMakeCurrentVersionId |  | int FV_CMSCommandCheckinMakeCurrentVersionId
Constants.FV_CMSCommandCheckinMinorVersionId |  | int FV_CMSCommandCheckinMinorVersionId
Constants.FV_CMSCommandCheckinVersionLabelId |  | int FV_CMSCommandCheckinVersionLabelId
Constants.FV_CMSCommandCheckoutWithDescendentId |  | int FV_CMSCommandCheckoutWithDescendentId
Constants.FV_CMSCommandConnTypeId |  | int FV_CMSCommandConnTypeId
Constants.FV_CMSCommandDeleteAllDependentsId |  | int FV_CMSCommandDeleteAllDependentsId
Constants.FV_CMSCommandDeleteAllVersionId |  | int FV_CMSCommandDeleteAllVersionId
Constants.FV_CMSCommandFilePathId |  | int FV_CMSCommandFilePathId
Constants.FV_CMSCommandId |  | int FV_CMSCommandId
Constants.FV_CMSCommandId_Max |  | int FV_CMSCommandId_Max
Constants.FV_CMSCommandId_Min |  | int FV_CMSCommandId_Min
Constants.FV_CMSCommandNameId |  | int FV_CMSCommandNameId
Constants.FV_CMSCommandOpenReadOnlyId |  | int FV_CMSCommandOpenReadOnlyId
Constants.FV_CMSCommandPasswordId |  | int FV_CMSCommandPasswordId
Constants.FV_CMSCommandRepositoryId |  | int FV_CMSCommandRepositoryId
Constants.FV_CMSCommandSearchStringId |  | int FV_CMSCommandSearchStringId
Constants.FV_CMSCommandServerId |  | int FV_CMSCommandServerId
Constants.FV_CMSCommandSilentOpenId |  | int FV_CMSCommandSilentOpenId
Constants.FV_CMSCommandUserField1 |  | int FV_CMSCommandUserField1
Constants.FV_CMSCommandUserField2 |  | int FV_CMSCommandUserField2
Constants.FV_CMSCommandUserNameId |  | int FV_CMSCommandUserNameId
Constants.FV_CMSContextMenuId |  | int FV_CMSContextMenuId
Constants.FV_CMSContextMenuString |  | int FV_CMSContextMenuString
Constants.FV_CMSDeleteUI_DeleteAllDependents |  | int FV_CMSDeleteUI_DeleteAllDependents
Constants.FV_CMSDeleteUI_DeleteAllVersion |  | int FV_CMSDeleteUI_DeleteAllVersion
Constants.FV_CMSItemFileTypeValue_DitaMap |  | int FV_CMSItemFileTypeValue_DitaMap
Constants.FV_CMSItemFileTypeValue_DitaTopic |  | int FV_CMSItemFileTypeValue_DitaTopic
Constants.FV_CMSItemFileTypeValue_FmBook |  | int FV_CMSItemFileTypeValue_FmBook
Constants.FV_CMSItemFileTypeValue_FmDoc |  | int FV_CMSItemFileTypeValue_FmDoc
Constants.FV_CMSItemFileTypeValue_General |  | int FV_CMSItemFileTypeValue_General
Constants.FV_CMSItemFileTypeValue_Img |  | int FV_CMSItemFileTypeValue_Img
Constants.FV_CMSItemFileTypeValue_Max |  | int FV_CMSItemFileTypeValue_Max
Constants.FV_CMSItemFileTypeValue_Mif |  | int FV_CMSItemFileTypeValue_Mif
Constants.FV_CMSItemFileTypeValue_Min |  | int FV_CMSItemFileTypeValue_Min
Constants.FV_CMSItemFileTypeValue_Text |  | int FV_CMSItemFileTypeValue_Text
Constants.FV_CMSItemFileTypeValue_Xml |  | int FV_CMSItemFileTypeValue_Xml
Constants.FV_CMSItemTypeValue_File |  | int FV_CMSItemTypeValue_File
Constants.FV_CMSItemTypeValue_Folder |  | int FV_CMSItemTypeValue_Folder
Constants.FV_CMSItemTypeValue_General |  | int FV_CMSItemTypeValue_General
Constants.FV_CMSItemTypeValue_Max |  | int FV_CMSItemTypeValue_Max
Constants.FV_CMSItemTypeValue_Min |  | int FV_CMSItemTypeValue_Min
Constants.FV_CMSItemTypeValue_Root |  | int FV_CMSItemTypeValue_Root
Constants.FV_CMSMajorVersion |  | int FV_CMSMajorVersion
Constants.FV_CMSMenu_Is_Disabled |  | int FV_CMSMenu_Is_Disabled
Constants.FV_CMSMenu_Is_Item |  | int FV_CMSMenu_Is_Item
Constants.FV_CMSMenu_Is_Separator |  | int FV_CMSMenu_Is_Separator
Constants.FV_CMSMenu_Is_SubMenu |  | int FV_CMSMenu_Is_SubMenu
Constants.FV_CMSMenu_Max |  | int FV_CMSMenu_Max
Constants.FV_CMSMenu_Min |  | int FV_CMSMenu_Min
Constants.FV_CMSMinorVersion |  | int FV_CMSMinorVersion
Constants.FV_CMSOpChildAdded |  | int FV_CMSOpChildAdded
Constants.FV_CMSOpDependentsDeleted |  | int FV_CMSOpDependentsDeleted
Constants.FV_CMSOpDependentsUpdated |  | int FV_CMSOpDependentsUpdated
Constants.FV_CMSOpItemDeleted |  | int FV_CMSOpItemDeleted
Constants.FV_CMSOpItemUpdated |  | int FV_CMSOpItemUpdated
Constants.FV_CMSOpNone |  | int FV_CMSOpNone
Constants.FV_CMSOpRootUpdated |  | int FV_CMSOpRootUpdated
Constants.FV_CMSSameVersion |  | int FV_CMSSameVersion
Constants.FV_CMSSilentOperation |  | int FV_CMSSilentOperation
Constants.FV_CMSVersion_Max |  | int FV_CMSVersion_Max
Constants.FV_CMSVersion_Min |  | int FV_CMSVersion_Min
Constants.FV_CN_CHANGEBAR |  | int 5
Constants.FV_CN_DOUBLE_UNDERLINE |  | int 4
Constants.FV_CN_NMRIC_AND_CHNGBAR |  | int 7
Constants.FV_CN_NO_OVERRIDE |  | int 0
Constants.FV_CN_NUMERIC_UNDERLINE |  | int 6
Constants.FV_CN_OVERLINE |  | int 1
Constants.FV_CN_SINGLE_UNDERLINE |  | int 3
Constants.FV_CN_STRIKETHROUGH |  | int 2
Constants.FV_COLOR_BLACK |  | int 4
Constants.FV_COLOR_BLUE |  | int 8
Constants.FV_COLOR_CYAN |  | int 1
Constants.FV_COLOR_DARKGREY |  | int 9
Constants.FV_COLOR_DARKYELLOW |  | int 15
Constants.FV_COLOR_FORESTGREEN |  | int 11
Constants.FV_COLOR_GREEN |  | int 7
Constants.FV_COLOR_KNOCKOUT |  | int 0x00
Constants.FV_COLOR_LIGHTSALMON |  | int 14
Constants.FV_COLOR_MAGENTA |  | int 2
Constants.FV_COLOR_MAUVE |  | int 13
Constants.FV_COLOR_NOT_RESERVED |  | int 0
Constants.FV_COLOR_OVERPRINT |  | int 0x01
Constants.FV_COLOR_PALEGREEN |  | int 10
Constants.FV_COLOR_RED |  | int 6
Constants.FV_COLOR_ROYALBLUE |  | int 12
Constants.FV_COLOR_SALMON |  | int 16
Constants.FV_COLOR_WHITE |  | int 5
Constants.FV_COLOR_YELLOW |  | int 3
Constants.FV_CONTEXT_RULE |  | int 0
Constants.FV_CS_CHANGEBAR |  | int 0x10
Constants.FV_CS_DOUBLE_UNDERLINE |  | int 0x08
Constants.FV_CS_NO_OVERRIDE |  | int 0x00
Constants.FV_CS_NUMERIC_UNDERLINE |  | int 0x20
Constants.FV_CS_OVERLINE |  | int 0x01
Constants.FV_CS_SINGLE_UNDERLINE |  | int 0x04
Constants.FV_CS_STRIKETHROUGH |  | int 0x02
Constants.FV_CancelBeefyDoc |  | int 114
Constants.FV_CancelBook |  | int 108
Constants.FV_CancelBookMIF |  | int 109
Constants.FV_CancelFileBrowser |  | int 113
Constants.FV_CancelFileDoc |  | int 33
Constants.FV_CancelFileFilterable |  | int 35
Constants.FV_CancelFileGraphic |  | int 36
Constants.FV_CancelFileHasStructure |  | int 100
Constants.FV_CancelFileIsDoc |  | int 106
Constants.FV_CancelFileIsFilterable |  | int 110
Constants.FV_CancelFileIsInUse |  | int 99
Constants.FV_CancelFileIsMIF |  | int 107
Constants.FV_CancelFileIsMacEdition |  | int 39
Constants.FV_CancelFileIsOldVersion |  | int 111
Constants.FV_CancelFileIsSgml |  | int 115
Constants.FV_CancelFileIsText |  | int 98
Constants.FV_CancelFileIsXml |  | int 119
Constants.FV_CancelFileMIF |  | int 34
Constants.FV_CancelFileSgml |  | int 40
Constants.FV_CancelFileText |  | int 32
Constants.FV_CancelFileXml |  | int 41
Constants.FV_CancelFontMetricsChanged |  | int 104
Constants.FV_CancelFontsMapped |  | int 103
Constants.FV_CancelFontsMappedInCatalog |  | int 105
Constants.FV_CancelFontsWithUnavailableEncodings |  | int 116
Constants.FV_CancelImportBrowser |  | int 38
Constants.FV_CancelInconsistentNumPropsInFileInBook |  | int 34
Constants.FV_CancelLanguagesNotFound |  | int 102
Constants.FV_CancelNonFMFileInBook |  | int 32
Constants.FV_CancelOpenFileNotWritable |  | int 117
Constants.FV_CancelReferencedFilesNotFound |  | int 101
Constants.FV_CancelSaveExportedFileInvalid |  | int 53
Constants.FV_CancelSaveFileIsInUse |  | int 50
Constants.FV_CancelSaveFileNotWritable |  | int 51
Constants.FV_CancelSaveModDateChanged |  | int 52
Constants.FV_CancelTempDiskFull |  | int 118
Constants.FV_CancelUseAutoSaveFile |  | int 97
Constants.FV_CancelUseRecoverFile |  | int 96
Constants.FV_CancelViewOnlyFileInBook |  | int 33
Constants.FV_CancelWrongProduct |  | int 121
Constants.FV_CancelWrongView |  | int 120
Constants.FV_CanceledExportObjectNeedsDpi |  | int 33
Constants.FV_CantForceImportAsText |  | int 20
Constants.FV_CantForceOpenAsText |  | int 72
Constants.FV_CantNewBooks |  | int 68
Constants.FV_CantOpenBooksFluid |  | int 78
Constants.FV_CantOpenBooksViewOnly |  | int 69
Constants.FV_ChangePersonalDictionary |  | int 8
Constants.FV_CheckCurrentPage |  | int 2
Constants.FV_CheckDocument |  | int 1
Constants.FV_ChecksumDamage |  | int 77
Constants.FV_ChooseMultiOpen |  | int 0x00000010
Constants.FV_ChooseMultiSelect |  | int 0x00000008
Constants.FV_ChooseOpen |  | int 0x00000001
Constants.FV_ChooseOpenDir |  | int 0x00000004
Constants.FV_ChooseSave |  | int 0x00000002
Constants.FV_ChooseSelect |  | int 0x00000000
Constants.FV_ClearDocDictionary |  | int 7
Constants.FV_CmdAlert |  | int 8
Constants.FV_CmdAlertTitle |  | int 9
Constants.FV_CmdApplyMathRules |  | int 259
Constants.FV_CmdBeginRange |  | int 263
Constants.FV_CmdEndRange |  | int 264
Constants.FV_CmdError |  | int 1
Constants.FV_CmdExit |  | int 10
Constants.FV_CmdFCodes |  | int 256
Constants.FV_CmdGoToLink |  | int 11
Constants.FV_CmdGoToLinkFitWin |  | int 12
Constants.FV_CmdGoToNew |  | int 13
Constants.FV_CmdGoToObjectId |  | int 15
Constants.FV_CmdGoToObjectIdFitWin |  | int 16
Constants.FV_CmdGoToPage |  | int 14
Constants.FV_CmdHelpLink |  | int 262
Constants.FV_CmdInCodes |  | int 258
Constants.FV_CmdMatrix |  | int 17
Constants.FV_CmdMessage |  | int 18
Constants.FV_CmdMultiMedia |  | int 33
Constants.FV_CmdNative |  | int 261
Constants.FV_CmdNewLink |  | int 19
Constants.FV_CmdNextPage |  | int 20
Constants.FV_CmdNoop |  | int 3
Constants.FV_CmdNotTyped |  | int 0
Constants.FV_CmdOpenLink |  | int 22
Constants.FV_CmdOpenLinkFitWin |  | int 23
Constants.FV_CmdOpenNew |  | int 24
Constants.FV_CmdOpenObjectId |  | int 25
Constants.FV_CmdOpenObjectIdFitWin |  | int 26
Constants.FV_CmdOpenPage |  | int 27
Constants.FV_CmdOpenXmlElementId |  | int 821
Constants.FV_CmdOutCodes |  | int 257
Constants.FV_CmdPopup |  | int 28
Constants.FV_CmdPreviousLink |  | int 29
Constants.FV_CmdPreviousLinkFitWin |  | int 30
Constants.FV_CmdPreviousPage |  | int 21
Constants.FV_CmdQuit |  | int 31
Constants.FV_CmdQuitAll |  | int 32
Constants.FV_CmdThesaurusLookup |  | int 260
Constants.FV_CmdUnknown |  | int 2
Constants.FV_DIALOG_DOCK_ALL |  | int 0xFF
Constants.FV_DIALOG_DOCK_BOTTOM |  | int (0x1 << 3)
Constants.FV_DIALOG_DOCK_LEFT |  | int 0x1
Constants.FV_DIALOG_DOCK_NONE |  | int 0x00
Constants.FV_DIALOG_DOCK_RIGHT |  | int (0x1 << 1)
Constants.FV_DIALOG_DOCK_TOP |  | int (0x1 << 2)
Constants.FV_DIALOG_GROUP_ALL |  | int 0xFF
Constants.FV_DIALOG_GROUP_ALLPANELS |  | int (0x1 << 7)
Constants.FV_DIALOG_GROUP_ATTRIBUTES |  | int (0x1 << 3)
Constants.FV_DIALOG_GROUP_CATALOGS |  | int (0x1 << 1)
Constants.FV_DIALOG_GROUP_DESIGNERS |  | int (0x1 << 2)
Constants.FV_DIALOG_GROUP_EDIT |  | int (0x1 << 6)
Constants.FV_DIALOG_GROUP_NONE |  | int 0x0
Constants.FV_DIALOG_GROUP_PODS |  | int (0x1 << 4)
Constants.FV_DIALOG_GROUP_PODSRIGHT |  | int (0x1 << 5)
Constants.FV_DIALOG_GROUP_RMKITS |  | int (0x1 << 8)
Constants.FV_DIALOG_GROUP_SPECIAL |  | int 0x1
Constants.FV_DIALOG_RESIZEGRIPPERPOS_BELOW |  | int 2
Constants.FV_DIALOG_RESIZEGRIPPERPOS_FRONT |  | int 1
Constants.FV_DIALOG_RESIZEGRIPPERPOS_NONE |  | int 0
Constants.FV_DITAObjTypeAuto |  | int 0
Constants.FV_DITAObjTypeConref |  | int 1
Constants.FV_DITAObjTypeLink |  | int 3
Constants.FV_DITAObjTypeMax |  | int 6
Constants.FV_DITAObjTypeTopicref |  | int 4
Constants.FV_DITAObjTypeTopicsetref |  | int 5
Constants.FV_DITAObjTypeXref |  | int 2
Constants.FV_DITA_TYPE_ANCHOR |  | int 12
Constants.FV_DITA_TYPE_GENERAL |  | int 1
Constants.FV_DITA_TYPE_KEYDEF |  | int 3
Constants.FV_DITA_TYPE_MAPREF |  | int 8
Constants.FV_DITA_TYPE_NAVREF |  | int 9
Constants.FV_DITA_TYPE_RELTABLE |  | int 2
Constants.FV_DITA_TYPE_TITLE |  | int 10
Constants.FV_DITA_TYPE_TOPICGROUP |  | int 4
Constants.FV_DITA_TYPE_TOPICHEAD |  | int 5
Constants.FV_DITA_TYPE_TOPICREF |  | int 11
Constants.FV_DITA_TYPE_TOPICSET |  | int 7
Constants.FV_DITA_TYPE_TOPICSETREF |  | int 6
Constants.FV_DOC_ISNOT_DITAMAP |  | int 31
Constants.FV_DOC_TYPE_BINARY |  | int 0x01
Constants.FV_DOC_TYPE_FILTER |  | int 0x04
Constants.FV_DOC_TYPE_MIF |  | int 0x03
Constants.FV_DOC_TYPE_TEXT |  | int 0x02
Constants.FV_DT_FLOAT |  | int 2
Constants.FV_DT_INTEGER |  | int 1
Constants.FV_DT_NUMTYPES |  | int 3
Constants.FV_DT_UNSPECIFIED |  | int 0
Constants.FV_DeleteEmptyPages |  | int 4
Constants.FV_DestFirstPage |  | int 2
Constants.FV_DestFluidFlow |  | int 5
Constants.FV_DestLastPage |  | int 3
Constants.FV_DestMarker |  | int 6
Constants.FV_DestMarkerNewLink |  | int 1
Constants.FV_DestNowhere |  | int 0
Constants.FV_DestObjectId |  | int 7
Constants.FV_DestPageNum |  | int 4
Constants.FV_DestXRef |  | int 8
Constants.FV_DisallowedImportType |  | int 21
Constants.FV_DisallowedType |  | int 73
Constants.FV_DlgClose |  | int -1
Constants.FV_DlgEnter |  | int -4
Constants.FV_DlgHide |  | int -10
Constants.FV_DlgInit |  | int -9
Constants.FV_DlgNeedsUpdate |  | int -8
Constants.FV_DlgNextPage |  | int -7
Constants.FV_DlgNoChange |  | int -3
Constants.FV_DlgOptActive |  | int 1
Constants.FV_DlgOptDontCare |  | int 2
Constants.FV_DlgOptNotActive |  | int 0
Constants.FV_DlgPrefCommit |  | int -102
Constants.FV_DlgPrefSetInitialState |  | int -100
Constants.FV_DlgPrefVerify |  | int -101
Constants.FV_DlgPrevPage |  | int -6
Constants.FV_DlgReset |  | int -2
Constants.FV_DlgResize |  | int -12
Constants.FV_DlgShow |  | int -11
Constants.FV_DlgUndo |  | int -5
Constants.FV_DoByCopy |  | int 6
Constants.FV_DoByRef |  | int 5
Constants.FV_DoCancel |  | int 0
Constants.FV_DoImportAsTable |  | int 8
Constants.FV_DoNo |  | int 3
Constants.FV_DoOK |  | int 1
Constants.FV_DoShowDialog |  | int 4
Constants.FV_DoUserChoice |  | int 7
Constants.FV_DoUserPreference |  | int 12
Constants.FV_DoYes |  | int 2
Constants.FV_DocDamagedByTextFilter |  | int 74
Constants.FV_DocHeadersDamaged |  | int 75
Constants.FV_DocKeyCatalogTypeDefault |  | int 0
Constants.FV_DocKeyCatalogTypeMax |  | int 3
Constants.FV_DocKeyCatalogTypeNone |  | int 2
Constants.FV_DocKeyCatalogTypeSpecified |  | int 1
Constants.FV_DocWrongSize |  | int 76
Constants.FV_DocumentDictionary |  | int 2
Constants.FV_DontChangePageCount |  | int 1
Constants.FV_DuplicateFileInBook |  | int 1
Constants.FV_EDT_AFTER |  | int 49
Constants.FV_EDT_ALL |  | int 43
Constants.FV_EDT_ANY |  | int 42
Constants.FV_EDT_ATTRGRPO |  | int 30
Constants.FV_EDT_BEFORE |  | int 50
Constants.FV_EDT_BETWEEN |  | int 53
Constants.FV_EDT_ELEMENT |  | int 25
Constants.FV_EDT_FIRST |  | int 44
Constants.FV_EDT_INSERTPAR |  | int 23
Constants.FV_EDT_LAST |  | int 46
Constants.FV_EDT_MIDDLE |  | int 45
Constants.FV_EDT_NOTFIRST |  | int 47
Constants.FV_EDT_NOTLAST |  | int 48
Constants.FV_EDT_ONLY |  | int 62
Constants.FV_EDT_TEXT |  | int 40
Constants.FV_EDT_TEXTONLY |  | int 41
Constants.FV_ELCAT_ALL |  | int 0x03
Constants.FV_ELCAT_CHILDREN |  | int 0x02
Constants.FV_ELCAT_CUSTOM |  | int 0x04
Constants.FV_ELCAT_LOOSE |  | int 0x01
Constants.FV_ELCAT_STRICT |  | int 0x00
Constants.FV_ELEMENT_CATALOG |  | int 8
Constants.FV_ELEM_ATTRVAL_INVALID |  | int 0x4000
Constants.FV_ELEM_ATTRVAL_REQUIRED |  | int 0x2000
Constants.FV_ELEM_BOOK_COMP_INVALID |  | int 0x1000
Constants.FV_ELEM_BOOK_COMP_MISSING |  | int 0x0800
Constants.FV_ELEM_CONTENT_LOOSELY_VALID |  | int 0x20000
Constants.FV_ELEM_CONTENT_MUST_BE_EMPTY |  | int 0x0040
Constants.FV_ELEM_CONTENT_STRICTLY_VALID |  | int 0x10000
Constants.FV_ELEM_DISP_BRACKETS |  | int 1
Constants.FV_ELEM_DISP_NONE |  | int 0
Constants.FV_ELEM_DISP_TAGS |  | int 2
Constants.FV_ELEM_EXCLUDED |  | int 0x0004
Constants.FV_ELEM_HAS_TEXT_INVALID |  | int 0x0020
Constants.FV_ELEM_INVALID_AT_POSITION |  | int 0x0010
Constants.FV_ELEM_INVALID_IN_PARENT |  | int 0x0008
Constants.FV_ELEM_INVISIBLE_ATTRVAL_INVALID |  | int 0x80000
Constants.FV_ELEM_INVISIBLE_ATTRVAL_REQUIRED |  | int 0x40000
Constants.FV_ELEM_MISSING_CONTENT_AT_BEG |  | int 0x0100
Constants.FV_ELEM_MISSING_CONTENT_AT_END |  | int 0x0200
Constants.FV_ELEM_MISSING_CONTENT_BEFORE |  | int 0x0080
Constants.FV_ELEM_NOT_VALID_AS_ROOT |  | int 0x0400
Constants.FV_ELEM_TYPE_MISMATCH |  | int 0x0002
Constants.FV_ELEM_UNDEFINED |  | int 0x0001
Constants.FV_EMUL_DOWN |  | int 1
Constants.FV_EMUL_UP |  | int 0
Constants.FV_ENABLE_ALWAYS_DISABLE |  | int 2
Constants.FV_ENABLE_ALWAYS_ENABLE |  | int 1
Constants.FV_ENABLE_BOOK_HAS_SELECTION |  | int 29
Constants.FV_ENABLE_CAN_PASTE |  | int 24
Constants.FV_ENABLE_COPY |  | int 22
Constants.FV_ENABLE_COPY_FONT |  | int 23
Constants.FV_ENABLE_DOC_OR_BOOK_HAS_SELECTION |  | int 30
Constants.FV_ENABLE_IN_CELL_TEXT |  | int 11
Constants.FV_ENABLE_IN_FLOW |  | int 21
Constants.FV_ENABLE_IN_MATH |  | int 6
Constants.FV_ENABLE_IN_PARA_TEXT |  | int 3
Constants.FV_ENABLE_IN_TABLE |  | int 9
Constants.FV_ENABLE_IN_TABLE_TITLE |  | int 10
Constants.FV_ENABLE_IN_TEXT |  | int 7
Constants.FV_ENABLE_IN_TEXT_LINE |  | int 4
Constants.FV_ENABLE_IS_AFRAME |  | int 18
Constants.FV_ENABLE_IS_CELL |  | int 12
Constants.FV_ENABLE_IS_CELLS |  | int 13
Constants.FV_ENABLE_IS_GRAPHIC_INSET |  | int 20
Constants.FV_ENABLE_IS_OBJ |  | int 15
Constants.FV_ENABLE_IS_OR_IN_FRAME |  | int 17
Constants.FV_ENABLE_IS_TABLE |  | int 14
Constants.FV_ENABLE_IS_TEXT_FRAME |  | int 16
Constants.FV_ENABLE_IS_TEXT_INSET |  | int 19
Constants.FV_ENABLE_IS_TEXT_SEL |  | int 5
Constants.FV_ENABLE_IS_VIEW_ONLY |  | int 25
Constants.FV_ENABLE_NEEDS_BOOKP_ONLY |  | int 27
Constants.FV_ENABLE_NEEDS_DOCP_ONLY |  | int 26
Constants.FV_ENABLE_NEEDS_DOCP_OR_BOOKP |  | int 28
Constants.FV_ENABLE_OBJ_PROPS |  | int 8
Constants.FV_ENUMERATE_BOOKCOMP_FOLDER |  | int 1 << 8
Constants.FV_ENUMERATE_BOOKCOMP_GROUP |  | int 1 << 9
Constants.FV_ENUMERATE_COMPFILE_BOOKBINARY |  | int 1 << 14
Constants.FV_ENUMERATE_COMPFILE_BOOKMIF |  | int 1 << 15
Constants.FV_ENUMERATE_COMPFILE_FMBINARY |  | int 1 << 12
Constants.FV_ENUMERATE_COMPFILE_FMMIF |  | int 1 << 13
Constants.FV_ENUMERATE_COMPFILE_XML |  | int 1 << 16
Constants.FV_ENUMERATE_COMP_CHILDBOOK_COMPONENTS |  | int 1 << 7
Constants.FV_ENUMERATE_COMP_CHILDMAP_COMPONENTS |  | int 1 << 6
Constants.FV_ENUMERATE_COMP_FOLDER_COMPONENTS |  | int 1 << 10
Constants.FV_ENUMERATE_COMP_GROUP_COMPONENTS |  | int 1 << 11
Constants.FV_ENUMERATE_DITACOMP_KEYDEF |  | int 1 << 5
Constants.FV_ENUMERATE_DITACOMP_MAPREF |  | int 1 << 2
Constants.FV_ENUMERATE_DITACOMP_TOPICREF |  | int 1 << 1
Constants.FV_ENUMERATE_DITACOMP_TOPICSET |  | int 1 << 3
Constants.FV_ENUMERATE_DITACOMP_TOPICSETREF |  | int 1 << 4
Constants.FV_EUC |  | int 7
Constants.FV_EUC_CNS |  | int 9
Constants.FV_EditableCopyOpened |  | int 45
Constants.FV_Element |  | int 0
Constants.FV_ElementsOfType |  | int 1
Constants.FV_EnclosingDoc |  | int 1
Constants.FV_EvCaps |  | int 0x0008
Constants.FV_EvCommand |  | int 0x0010
Constants.FV_EvControl |  | int 0x0002
Constants.FV_EvMax |  | int 0x0010
Constants.FV_EvMeta |  | int 0x0004
Constants.FV_EvOption |  | int 0x0004
Constants.FV_EvShift |  | int 0x0001
Constants.FV_ExportDocument |  | int 0
Constants.FV_ExportFileHasNewName |  | int 0
Constants.FV_ExportFileNotWritable |  | int 2
Constants.FV_ExportObject |  | int 1
Constants.FV_ExportProductIsViewer |  | int 1
Constants.FV_FAMILY_MAPPED |  | int 0x00000004
Constants.FV_FAMILY_SELECTABLE |  | int 0x00000002
Constants.FV_FAMILY_SURROGATE |  | int 0xFFFF0000
Constants.FV_FAMILY_VISIBLE |  | int 0x00000001
Constants.FV_FILL_BLACK |  | int 0
Constants.FV_FILL_CLEAR |  | int 15
Constants.FV_FILL_WHITE |  | int 7
Constants.FV_FIT_WINDOW_TO_PAGE |  | int -3
Constants.FV_FIXED_YAKUMONO |  | int 0x02
Constants.FV_FLOATING_YAKUMONO |  | int 0x00
Constants.FV_FN_NUM_ALPHA_LC |  | int 0x04
Constants.FV_FN_NUM_ALPHA_UC |  | int 0x03
Constants.FV_FN_NUM_CHINESE_NUMERIC |  | int 0x10
Constants.FV_FN_NUM_CUSTOM |  | int 0x05
Constants.FV_FN_NUM_DAIJI |  | int 0x0B
Constants.FV_FN_NUM_FULL_WIDTH |  | int 0x0C
Constants.FV_FN_NUM_FULL_WIDTH_LC |  | int 0x0E
Constants.FV_FN_NUM_FULL_WIDTH_UC |  | int 0x0D
Constants.FV_FN_NUM_KANJI |  | int 0x06
Constants.FV_FN_NUM_KANJI_KAZU |  | int 0x0A
Constants.FV_FN_NUM_NUMERIC |  | int 0x00
Constants.FV_FN_NUM_ROMAN_LC |  | int 0x02
Constants.FV_FN_NUM_ROMAN_UC |  | int 0x01
Constants.FV_FN_NUM_ZENKAKU |  | int 0x07
Constants.FV_FN_NUM_ZENKAKU_LC |  | int 0x09
Constants.FV_FN_NUM_ZENKAKU_UC |  | int 0x08
Constants.FV_FN_POS_BASELINE |  | int 0x01
Constants.FV_FN_POS_SUB |  | int 0x02
Constants.FV_FN_POS_SUPER |  | int 0x00
Constants.FV_FORMATBAR_CLOSE |  | int 5
Constants.FV_FORMATBAR_OPEN |  | int 4
Constants.FV_FO_CONTAINER |  | int 1
Constants.FV_FO_EQN |  | int 7
Constants.FV_FO_FOOTNOTE |  | int 5
Constants.FV_FO_GRAPHIC |  | int 6
Constants.FV_FO_MARKER |  | int 4
Constants.FV_FO_MMLEQN |  | int 17
Constants.FV_FO_NUMTYPES |  | int 18
Constants.FV_FO_RUBI |  | int 16
Constants.FV_FO_RUBI_GROUP |  | int 15
Constants.FV_FO_SYS_VAR |  | int 2
Constants.FV_FO_TBL |  | int 8
Constants.FV_FO_TBL_BODY |  | int 11
Constants.FV_FO_TBL_CELL |  | int 14
Constants.FV_FO_TBL_FOOTING |  | int 12
Constants.FV_FO_TBL_HEADING |  | int 10
Constants.FV_FO_TBL_ROW |  | int 13
Constants.FV_FO_TBL_TITLE |  | int 9
Constants.FV_FO_TEXTNODE |  | int 0
Constants.FV_FO_UNSPECIFIED |  | int 0
Constants.FV_FO_XREF |  | int 3
Constants.FV_FROMCOLOR |  | int 0x02
Constants.FV_FileAlreadyOpen |  | int 48
Constants.FV_FileAlreadyOpenThisSession |  | int 65
Constants.FV_FileHadStructure |  | int 64
Constants.FV_FileHasNewName |  | int 32
Constants.FV_FileInBookNotOpened |  | int 96
Constants.FV_FileInBookNotSaved |  | int 97
Constants.FV_FileIsNotWritable |  | int 6
Constants.FV_FileIsOldVersion |  | int 41
Constants.FV_FileIsText |  | int 43
Constants.FV_FileIsViewOnly |  | int 4
Constants.FV_FileModDateChanged |  | int 7
Constants.FV_FileNotReadable |  | int 130
Constants.FV_FileNotWritable |  | int 33
Constants.FV_FileStructureStripped |  | int 42
Constants.FV_FileTypeBinaryBook |  | int 2
Constants.FV_FileTypeBinaryDoc |  | int 1
Constants.FV_FileTypeCompositeDoc |  | int 13
Constants.FV_FileTypeEquation |  | int 11
Constants.FV_FileTypeErrorDoc |  | int 10
Constants.FV_FileTypeFilter |  | int 7
Constants.FV_FileTypeFolder |  | int 8
Constants.FV_FileTypeGeneral |  | int 9
Constants.FV_FileTypeMif |  | int 3
Constants.FV_FileTypeSgml |  | int 5
Constants.FV_FileTypeSummaryDoc |  | int 14
Constants.FV_FileTypeText |  | int 6
Constants.FV_FileTypeThesaurus |  | int 12
Constants.FV_FileTypeXml |  | int 4
Constants.FV_FileWasExported |  | int 49
Constants.FV_FileWasFiltered |  | int 35
Constants.FV_FileWasInUse |  | int 3
Constants.FV_FilterFailed |  | int 22
Constants.FV_FindAnchoredFrame |  | int 7
Constants.FV_FindAnyMarker |  | int 0
Constants.FV_FindAnyPub |  | int 5
Constants.FV_FindAnyRubi |  | int 11
Constants.FV_FindAnyTable |  | int 9
Constants.FV_FindAnyTextInset |  | int 3
Constants.FV_FindAnyVariable |  | int 6
Constants.FV_FindAnyXRef |  | int 1
Constants.FV_FindAttrName |  | int 1
Constants.FV_FindAttrValue |  | int 2
Constants.FV_FindAutomaticHyphen |  | int 10
Constants.FV_FindCharacterFormatOverride |  | int 13
Constants.FV_FindElemTag |  | int 0
Constants.FV_FindFootnote |  | int 8
Constants.FV_FindPgfFormatOverride |  | int 12
Constants.FV_FindStyleFormatOverride |  | int 15
Constants.FV_FindTableFormatOverride |  | int 14
Constants.FV_FindUnresolvedTextInset |  | int 4
Constants.FV_FindUnresolvedXRef |  | int 2
Constants.FV_FlowUnstructured |  | int 30
Constants.FV_FontMetricsChanged |  | int 37
Constants.FV_FontsMappedInCatalog |  | int 38
Constants.FV_FontsWereMapped |  | int 36
Constants.FV_FontsWithUnavailableEncodingsUsed |  | int 53
Constants.FV_Footing |  | int 1239
Constants.FV_GB |  | int 10
Constants.FV_GRAPHIC |  | int 9
Constants.FV_GRAPHICS_CATALOG |  | int 14
Constants.FV_GetDictionaryStrings |  | int 9
Constants.FV_HELP_CONTEXT |  | int 5
Constants.FV_HELP_HYPERTEXT |  | int 7
Constants.FV_HELP_INDEX |  | int 0
Constants.FV_HELP_INIT_CONTEXT |  | int 6
Constants.FV_HELP_KEYS |  | int 1
Constants.FV_HELP_ONLINE_MANUALS |  | int 4
Constants.FV_HELP_OVERVIEW |  | int 3
Constants.FV_HELP_SAMPLES |  | int 2
Constants.FV_HELP_WEBWORKS |  | int 8
Constants.FV_HIST |  | int 12
Constants.FV_HZ |  | int 11
Constants.FV_Heading |  | int 1238
Constants.FV_Hint_FilterName |  | int 5
Constants.FV_Hint_FilterVersion |  | int 4
Constants.FV_Hint_FormatId |  | int 2
Constants.FV_Hint_HintVersion |  | int 0
Constants.FV_Hint_Platform |  | int 3
Constants.FV_Hint_VendorId |  | int 1
Constants.FV_HypertextBadMatrixSize |  | int 250
Constants.FV_HypertextBadSyntaxPathSpec |  | int 10
Constants.FV_HypertextCantOpenDestFile |  | int 212
Constants.FV_HypertextCommandIllegalWithinPopup |  | int 273
Constants.FV_HypertextDestinationLinkNotFound |  | int 220
Constants.FV_HypertextDuplicateLinkName |  | int 221
Constants.FV_HypertextEmptyCommand |  | int 1
Constants.FV_HypertextEmptyLineInMiddleOfPopup |  | int 272
Constants.FV_HypertextExpectedANumberParam |  | int 30
Constants.FV_HypertextExtraArguments |  | int 4
Constants.FV_HypertextFcodeInvalid |  | int 280
Constants.FV_HypertextFileNotMakerDoc |  | int 211
Constants.FV_HypertextFileNotRegular |  | int 210
Constants.FV_HypertextFlowMissingLines |  | int 252
Constants.FV_HypertextHelpDirNotFound |  | int 20
Constants.FV_HypertextMatrixCommandInvalid |  | int 251
Constants.FV_HypertextMissingArguments |  | int 3
Constants.FV_HypertextMissingPopupLabelItem |  | int 271
Constants.FV_HypertextMissingPopupMarker |  | int 270
Constants.FV_HypertextNoNamedFlow |  | int 260
Constants.FV_HypertextObjectIDNotFound |  | int 241
Constants.FV_HypertextPageNameNotFound |  | int 230
Constants.FV_HypertextRecursiveFlow |  | int 261
Constants.FV_HypertextSyntaxOK |  | int 0
Constants.FV_HypertextUnanchoredPartialPath |  | int 11
Constants.FV_HypertextUnrecognizedCommand |  | int 2
Constants.FV_HypertextUnrecognizedObjectType |  | int 240
Constants.FV_HypertextUsesDefaultText |  | int 200
Constants.FV_HypertextValid |  | int 0
Constants.FV_IMG_NEGATIVE |  | int 1
Constants.FV_IMG_POSITIVE |  | int 0
Constants.FV_INCLUSION |  | int 0x08
Constants.FV_INTERACT_ROTATE |  | int 1
Constants.FV_INTERACT_ROTATE_CONSTRAIN |  | int 2
Constants.FV_ITEM_HAS_NO_SHIFT_OR_UNSHIFT_COMMAND |  | int 3
Constants.FV_ITEM_HAS_SHIFT_COMMAND |  | int 1
Constants.FV_ITEM_HAS_UNSHIFT_COMMAND |  | int 2
Constants.FV_ImportFileNotReadable |  | int 48
Constants.FV_ImportedByCopy |  | int 0
Constants.FV_ImportedFilteredFile |  | int 5
Constants.FV_ImportedGraphicFile |  | int 6
Constants.FV_ImportedMIF |  | int 3
Constants.FV_ImportedMacEdition |  | int 7
Constants.FV_ImportedMakerDoc |  | int 4
Constants.FV_ImportedSgmlDoc |  | int 8
Constants.FV_ImportedText |  | int 1
Constants.FV_ImportedTextTable |  | int 2
Constants.FV_ImportedXmlDoc |  | int 9
Constants.FV_InsertionPointInFootnote |  | int 26
Constants.FV_InsertionPointInTableCell |  | int 25
Constants.FV_InsertionPointNotInText |  | int 24
Constants.FV_InsufficientMem |  | int 3
Constants.FV_InsufficientMemory |  | int 27
Constants.FV_InvalidExportFilter |  | int 23
Constants.FV_InvalidSaveFilter |  | int 42
Constants.FV_InvalidTextRange |  | int 19
Constants.FV_IsoLatin |  | int 1
Constants.FV_JIS |  | int 5
Constants.FV_KNOCKOUT |  | int 0x00
Constants.FV_KeyCatalogWorkflowAuthoring |  | int 0
Constants.FV_KeyCatalogWorkflowMax |  | int 3
Constants.FV_KeyCatalogWorkflowPublishing |  | int 1
Constants.FV_KeyCatalogWorkflowSearching |  | int 2
Constants.FV_KeyDefFieldSize |  | int 2
Constants.FV_KeyDefFieldsTypeAll |  | int 1
Constants.FV_KeyDefFieldsTypeMax |  | int 2
Constants.FV_KeyDefFieldsTypePrimary |  | int 0
Constants.FV_KeyDefMaxFields |  | int 11
Constants.FV_KeyDefMaxPrimaryFields |  | int 4+1
Constants.FV_KeySrcTypeDitamap |  | int 1
Constants.FV_KeySrcTypeNone |  | int 0
Constants.FV_KeydefKeyAttrs |  | int 10
Constants.FV_KeydefKeyAttrsType |  | int 21
Constants.FV_KeydefKeyDefaultText |  | int 7
Constants.FV_KeydefKeyDefaultTextType |  | int 3
Constants.FV_KeydefKeyDuplicate |  | int 4
Constants.FV_KeydefKeyDuplicateType |  | int 1
Constants.FV_KeydefKeyFoundInRefFile |  | int 8
Constants.FV_KeydefKeyFoundInRefFileType |  | int 1
Constants.FV_KeydefKeyInValid |  | int 9
Constants.FV_KeydefKeyInValidType |  | int 1
Constants.FV_KeydefKeySrcFile |  | int 3
Constants.FV_KeydefKeySrcFileType |  | int 3
Constants.FV_KeydefKeySrcType |  | int 5
Constants.FV_KeydefKeySrcTypeType |  | int 1
Constants.FV_KeydefKeyTag |  | int 1
Constants.FV_KeydefKeyTagType |  | int 3
Constants.FV_KeydefKeyTarget |  | int 2
Constants.FV_KeydefKeyTargetType |  | int 3
Constants.FV_KeydefKeyVarList |  | int 6
Constants.FV_KeydefKeyVarListType |  | int 20
Constants.FV_KeydefVariableInfoLen |  | int 3
Constants.FV_KeydefVariableInfoTagPrimary |  | int 0
Constants.FV_KeydefVariableInfoTagSecondary |  | int 1
Constants.FV_KeydefVariableInfoText |  | int 2
Constants.FV_Korean |  | int 12
Constants.FV_LANG_BRAZILIAN |  | int 0x0B
Constants.FV_LANG_BRITISH |  | int 0x02
Constants.FV_LANG_BULGARIAN |  | int 0x21
Constants.FV_LANG_CANADIAN_FRENCH |  | int 0x06
Constants.FV_LANG_CATALAN |  | int 0x08
Constants.FV_LANG_CROATIAN |  | int 0x22
Constants.FV_LANG_CZECH |  | int 0x1B
Constants.FV_LANG_DANISH |  | int 0x0C
Constants.FV_LANG_DUTCH |  | int 0x0D
Constants.FV_LANG_ENGLISH |  | int 0x01
Constants.FV_LANG_ESTONIAN |  | int 0x23
Constants.FV_LANG_FINNISH |  | int 0x10
Constants.FV_LANG_FRENCH |  | int 0x05
Constants.FV_LANG_GERMAN |  | int 0x03
Constants.FV_LANG_GREEK |  | int 0x19
Constants.FV_LANG_HUNGARIAN |  | int 0x1D
Constants.FV_LANG_ITALIAN |  | int 0x09
Constants.FV_LANG_JAPANESE |  | int 0x12
Constants.FV_LANG_KOREAN |  | int 0x15
Constants.FV_LANG_LATVIAN |  | int 0x24
Constants.FV_LANG_LITHUANIAN |  | int 0x25
Constants.FV_LANG_NEW_DUTCH |  | int 0x18
Constants.FV_LANG_NEW_GERMAN |  | int 0x16
Constants.FV_LANG_NEW_SWISS_GERMAN |  | int 0x17
Constants.FV_LANG_NOLANGUAGE |  | int 0x00
Constants.FV_LANG_NORWEGIAN |  | int 0x0E
Constants.FV_LANG_NUM |  | int 0x27
Constants.FV_LANG_NYNORSK |  | int 0x0F
Constants.FV_LANG_POLISH |  | int 0x1C
Constants.FV_LANG_PORTUGUESE |  | int 0x0A
Constants.FV_LANG_ROMANIAN |  | int 0x26
Constants.FV_LANG_RUSSIAN |  | int 0x1A
Constants.FV_LANG_SIMPLIFIED_CHINESE |  | int 0x14
Constants.FV_LANG_SLOVAK |  | int 0x1F
Constants.FV_LANG_SLOVENIAN |  | int 0x20
Constants.FV_LANG_SPANISH |  | int 0x07
Constants.FV_LANG_SWEDISH |  | int 0x11
Constants.FV_LANG_SWISS_GERMAN |  | int 0x04
Constants.FV_LANG_TRADITIONAL_CHINESE |  | int 0x13
Constants.FV_LANG_TURKISH |  | int 0x1E
Constants.FV_LEVEL_RULE |  | int 1
Constants.FV_LOOSELY_VALID |  | int 0x02
Constants.FV_LanguagesWerentFound |  | int 39
Constants.FV_Left |  | int 1242
Constants.FV_ListViewActionMax |  | int 7
Constants.FV_ListViewAddColumn |  | int 2
Constants.FV_ListViewAddColumnNumParams |  | int 4
Constants.FV_ListViewAddColumnParam1 |  | int 3
Constants.FV_ListViewAddColumnParam2 |  | int 1
Constants.FV_ListViewAddColumnParam3 |  | int 1
Constants.FV_ListViewAddColumnParam4 |  | int 1
Constants.FV_ListViewAddRow |  | int 3
Constants.FV_ListViewAddRowNumParams |  | int 1
Constants.FV_ListViewAddRowParam1 |  | int 6
Constants.FV_ListViewDeleteAllRows |  | int 4
Constants.FV_ListViewDeleteAllRowsNumParams |  | int 0
Constants.FV_ListViewInit |  | int 1
Constants.FV_ListViewInitNumParams |  | int 0
Constants.FV_ListViewReSortAllRows |  | int 5
Constants.FV_ListViewReSortAllRowsNumParams |  | int 0
Constants.FV_ListViewSetSortEnabled |  | int 6
Constants.FV_LockCouldntBeReset |  | int 2
Constants.FV_LockNotReset |  | int 1
Constants.FV_LockWasInvalid |  | int 5
Constants.FV_LockWasReset |  | int 0
Constants.FV_MATH |  | int 3
Constants.FV_MATH_LARGE |  | int 2
Constants.FV_MATH_MEDIUM |  | int 0
Constants.FV_MATH_SMALL |  | int 1
Constants.FV_MENUITEM_API |  | int 2
Constants.FV_MENUITEM_EXPANDOMATIC |  | int 4
Constants.FV_MENUITEM_FRAME |  | int 1
Constants.FV_MENUITEM_MACRO |  | int 3
Constants.FV_MENU_ADHOCRULER |  | int 3
Constants.FV_MENU_COMPLETE |  | int 2
Constants.FV_MENU_CUSTOM |  | int 3
Constants.FV_MENU_DEFAULT |  | int 4
Constants.FV_MENU_MENUBAR |  | int 1
Constants.FV_MENU_POPUP |  | int 2
Constants.FV_MENU_QUICK |  | int 1
Constants.FV_MODE_ALL |  | int 3
Constants.FV_MODE_MATH |  | int 1
Constants.FV_MODE_NONMATH |  | int 2
Constants.FV_MONOSPACE_YAKUMONO |  | int 0x01
Constants.FV_MacANSI |  | int 4
Constants.FV_MakePageCountEven |  | int 2
Constants.FV_MakePageCountOdd |  | int 3
Constants.FV_MergeDictionaryContents |  | int 5
Constants.FV_MissingExportScript |  | int 17
Constants.FV_MissingImportScript |  | int 19
Constants.FV_MissingScript |  | int 71
Constants.FV_ModeSave |  | int 0
Constants.FV_ModeSaveAs |  | int 1
Constants.FV_NARROW |  | int 1
Constants.FV_NO_BASE_COLOR |  | int 0x00
Constants.FV_NO_ZOOM_MANGLING |  | int -1
Constants.FV_NUMSTYLE_ALPHA_LC |  | int 0x04
Constants.FV_NUMSTYLE_ALPHA_UC |  | int 0x03
Constants.FV_NUMSTYLE_CHINESE_NUMERIC |  | int 0x10
Constants.FV_NUMSTYLE_DAIJI |  | int 0x0a
Constants.FV_NUMSTYLE_FULLWIDTH |  | int 0x0c
Constants.FV_NUMSTYLE_FULLWIDTH_LC |  | int 0x0e
Constants.FV_NUMSTYLE_FULLWIDTH_UC |  | int 0x0d
Constants.FV_NUMSTYLE_KANJI |  | int 0x05
Constants.FV_NUMSTYLE_KANJI_KAZU |  | int 0x09
Constants.FV_NUMSTYLE_NUMERIC |  | int 0x00
Constants.FV_NUMSTYLE_ROMAN_LC |  | int 0x02
Constants.FV_NUMSTYLE_ROMAN_UC |  | int 0x01
Constants.FV_NUMSTYLE_TEXT |  | int 0x0b
Constants.FV_NUMSTYLE_ZENKAKU |  | int 0x06
Constants.FV_NUMSTYLE_ZENKAKU_LC |  | int 0x08
Constants.FV_NUMSTYLE_ZENKAKU_UC |  | int 0x07
Constants.FV_NUM_CONTINUE |  | int 0x01
Constants.FV_NUM_PERPAGE |  | int 0x03
Constants.FV_NUM_READ_FROM_FILE |  | int 0x00
Constants.FV_NUM_RESTART |  | int 0x02
Constants.FV_NUM_SAME |  | int 0x03
Constants.FV_NoFlowWithSpecifiedName |  | int 23
Constants.FV_NoMainFlow |  | int 22
Constants.FV_NoNonGeneratedFilesInBook |  | int 2
Constants.FV_NonPortableFileRefs |  | int 38
Constants.FV_NonPortableSaveName |  | int 37
Constants.FV_NumExportStatusFields |  | int 2
Constants.FV_NumFindElementItems |  | int 2+1
Constants.FV_NumImportStatusFields |  | int 2
Constants.FV_NumOpenStatusFields |  | int 5
Constants.FV_NumSaveStatusFields |  | int 2
Constants.FV_NumUpdateBookStatusFields |  | int 4
Constants.FV_OBJ_END_OFFSET |  | int 0x50000000
Constants.FV_OVERPRINT |  | int 0x01
Constants.FV_OVERRIDDEN_CONREF_DUCT |  | int 0x02
Constants.FV_OVERRIDDEN_DEFAULT |  | int 0x00
Constants.FV_OVERRIDDEN_KEYDEF_TO_KEYREF |  | int 0x03
Constants.FV_OVERRIDDEN_NOVALUE |  | int 0x01
Constants.FV_ObjectDataLink |  | int 7
Constants.FV_ObjectElement |  | int 5
Constants.FV_ObjectGraphic |  | int 4
Constants.FV_ObjectMarker |  | int 1
Constants.FV_ObjectPgf |  | int 2
Constants.FV_ObjectTextInset |  | int 6
Constants.FV_ObjectUnknown |  | int 0
Constants.FV_ObjectXref |  | int 3
Constants.FV_OpenEditableCopy |  | int 8
Constants.FV_OpenViewOnly |  | int 5
Constants.FV_OpenedFluid |  | int 51
Constants.FV_OpenedViewOnly |  | int 44
Constants.FV_PAGE_NUM_ALPHA_LC |  | int 0x04
Constants.FV_PAGE_NUM_ALPHA_UC |  | int 0x03
Constants.FV_PAGE_NUM_CHINESE_NUMERIC |  | int 0x10
Constants.FV_PAGE_NUM_DAIJI |  | int 0x0a
Constants.FV_PAGE_NUM_FULLWIDTH |  | int 0x0c
Constants.FV_PAGE_NUM_FULLWIDTH_LC |  | int 0x0e
Constants.FV_PAGE_NUM_FULLWIDTH_UC |  | int 0x0d
Constants.FV_PAGE_NUM_KANJI |  | int 0x05
Constants.FV_PAGE_NUM_KANJI_KAZU |  | int 0x09
Constants.FV_PAGE_NUM_NUMERIC |  | int 0x00
Constants.FV_PAGE_NUM_ROMAN_LC |  | int 0x02
Constants.FV_PAGE_NUM_ROMAN_UC |  | int 0x01
Constants.FV_PAGE_NUM_ZENKAKU |  | int 0x06
Constants.FV_PAGE_NUM_ZENKAKU_LC |  | int 0x08
Constants.FV_PAGE_NUM_ZENKAKU_UC |  | int 0x07
Constants.FV_PDFBookmarksOpenAllLevels |  | int -2
Constants.FV_PDFBookmarksOpenDefaultLevel |  | int -1
Constants.FV_PDFBookmarksOpenNoneLevel |  | int -3
Constants.FV_PDFRegistrationMarksMax |  | int 2
Constants.FV_PDFRegistrationMarksNone |  | int 0
Constants.FV_PDFRegistrationMarksTombo |  | int 2
Constants.FV_PDFRegistrationMarksWestern |  | int 1
Constants.FV_PDFZoomDefault |  | int 1
Constants.FV_PDFZoomHeight |  | int 4
Constants.FV_PDFZoomMaxValue |  | int 4
Constants.FV_PDFZoomNone |  | int 0
Constants.FV_PDFZoomPage |  | int 2
Constants.FV_PDFZoomWidth |  | int 3
Constants.FV_PGF_ANYWHERE |  | int 0x00
Constants.FV_PGF_CATALOG |  | int 7
Constants.FV_PGF_CENTER |  | int 0x03
Constants.FV_PGF_FIXED |  | int 0x00
Constants.FV_PGF_FIXED_B_MARGIN |  | int 0x02
Constants.FV_PGF_FIXED_L_MARGIN |  | int 0x01
Constants.FV_PGF_FIXED_R_MARGIN |  | int 0x04
Constants.FV_PGF_FIXED_T_MARGIN |  | int 0x08
Constants.FV_PGF_FLOATING |  | int 0x02
Constants.FV_PGF_JUSTIFIED |  | int 0x04
Constants.FV_PGF_LEFT |  | int 0x01
Constants.FV_PGF_PROPORTIONAL |  | int 0x01
Constants.FV_PGF_RIGHT |  | int 0x02
Constants.FV_PGF_RUN_IN |  | int 4
Constants.FV_PGF_SIDEBODY |  | int 0
Constants.FV_PGF_SIDEHEAD_FIRST_BASELINE |  | int 2
Constants.FV_PGF_SIDEHEAD_LAST_BASELINE |  | int 3
Constants.FV_PGF_SIDEHEAD_TOP |  | int 1
Constants.FV_PGF_STRADDLE |  | int 5
Constants.FV_PGF_STRADDLE_NORMAL_ONLY |  | int 6
Constants.FV_PGF_TOP_OF_COL |  | int 0x01
Constants.FV_PGF_TOP_OF_LEFT_PAGE |  | int 0x03
Constants.FV_PGF_TOP_OF_PAGE |  | int 0x02
Constants.FV_PGF_TOP_OF_RIGHT_PAGE |  | int 0x04
Constants.FV_PGF_V_ALIGN_BOTTOM |  | int 2
Constants.FV_PGF_V_ALIGN_MIDDLE |  | int 1
Constants.FV_PGF_V_ALIGN_TOP |  | int 0
Constants.FV_POINT_PAGE_CHINESE_NUMERIC |  | int 0x10
Constants.FV_POINT_PAGE_FULLWIDTH |  | int 0x0c
Constants.FV_POINT_PAGE_FULLWIDTH_LC |  | int 0x0e
Constants.FV_POINT_PAGE_FULLWIDTH_UC |  | int 0x0d
Constants.FV_POINT_PAGE_NUM_ALPHA_LC |  | int 0x04
Constants.FV_POINT_PAGE_NUM_ALPHA_UC |  | int 0x03
Constants.FV_POINT_PAGE_NUM_DAIJI |  | int 0x0a
Constants.FV_POINT_PAGE_NUM_KANJI |  | int 0x05
Constants.FV_POINT_PAGE_NUM_KANJI_KAZU |  | int 0x09
Constants.FV_POINT_PAGE_NUM_NUMERIC |  | int 0x00
Constants.FV_POINT_PAGE_NUM_ROMAN_LC |  | int 0x02
Constants.FV_POINT_PAGE_NUM_ROMAN_UC |  | int 0x01
Constants.FV_POINT_PAGE_NUM_ZENKAKU |  | int 0x06
Constants.FV_POINT_PAGE_NUM_ZENKAKU_LC |  | int 0x08
Constants.FV_POINT_PAGE_NUM_ZENKAKU_UC |  | int 0x07
Constants.FV_POS_NORM |  | int 0
Constants.FV_POS_SUB |  | int 2
Constants.FV_POS_SUPER |  | int 1
Constants.FV_PREVIEW_OFF_TRACK_CHANGE |  | int 0
Constants.FV_PREVIEW_ON_FINAL |  | int 2
Constants.FV_PREVIEW_ON_ORIGINAL |  | int 1
Constants.FV_PRINT_NO |  | int 0x2
Constants.FV_PRINT_PROCESS |  | int 0x1
Constants.FV_PRINT_SPOT |  | int 0x0
Constants.FV_PRODUCT_ALL |  | int (0x01|0x02|0x04)
Constants.FV_PRODUCT_STRUCTURED |  | int 0x02
Constants.FV_PRODUCT_UNSTRUCTURED |  | int 0x01
Constants.FV_PRODUCT_XMLAUTHOR |  | int 0x04
Constants.FV_PROPORTIONAL |  | int 2
Constants.FV_PR_ALL |  | int 1
Constants.FV_PR_DEL_EMPTY |  | int 0x01
Constants.FV_PR_DONT_CHANGE |  | int 0x04
Constants.FV_PR_DOWNLOAD_ALL |  | int 2
Constants.FV_PR_DOWNLOAD_ALL_BUT_STANDARD_13 |  | int 3
Constants.FV_PR_DOWNLOAD_ALL_BUT_STANDARD_35 |  | int 4
Constants.FV_PR_DOWNLOAD_NONE |  | int 1
Constants.FV_PR_KEEP_NUM_EVEN |  | int 0x02
Constants.FV_PR_KEEP_NUM_ODD |  | int 0x03
Constants.FV_PR_RANGE |  | int 2
Constants.FV_PlainText |  | int 2
Constants.FV_ProductIsMaker |  | int 39
Constants.FV_ProductIsViewer |  | int 32
Constants.FV_RC_CHANGELIST |  | int 2
Constants.FV_RC_CHANGELIST_TAG |  | int 3
Constants.FV_RC_SUB_FMTRULE |  | int 1
Constants.FV_RC_TAG |  | int 0
Constants.FV_REFERENCE_PAGE |  | int 0x02
Constants.FV_ROW_ANYWHERE |  | int 0
Constants.FV_ROW_BODY |  | int 1
Constants.FV_ROW_FOOTING |  | int 2
Constants.FV_ROW_HEADING |  | int 0
Constants.FV_ROW_TOP_OF_COL |  | int 1
Constants.FV_ROW_TOP_OF_LEFT_PAGE |  | int 3
Constants.FV_ROW_TOP_OF_PAGE |  | int 2
Constants.FV_ROW_TOP_OF_RIGHT_PAGE |  | int 4
Constants.FV_RecoverFileUsed |  | int 33
Constants.FV_RedoAll |  | int 4
Constants.FV_ReferencePage |  | int 9
Constants.FV_ReferencedFilesWerentFound |  | int 47
Constants.FV_ResetLockAndContinue |  | int 7
Constants.FV_Right |  | int 1243
Constants.FV_SCROLL_FACING |  | int 3
Constants.FV_SCROLL_HORIZONTAL |  | int 1
Constants.FV_SCROLL_VARIABLE |  | int 0
Constants.FV_SCROLL_VERTICAL |  | int 2
Constants.FV_SEP_NONE |  | int 0x1
Constants.FV_SEP_NORMAL |  | int 0x0
Constants.FV_SEP_WHITE |  | int 0x2
Constants.FV_SH_INSIDE |  | int 0x02
Constants.FV_SH_LEFT |  | int 0x00
Constants.FV_SH_OUTSIDE |  | int 0x03
Constants.FV_SH_RIGHT |  | int 0x01
Constants.FV_STRICTLY_VALID |  | int 0x01
Constants.FV_SaveAsNameAskUser |  | int 0
Constants.FV_SaveAsNameProvided |  | int 2
Constants.FV_SaveAsUseFileName |  | int 1
Constants.FV_SaveFmtBinary |  | int 0
Constants.FV_SaveFmtBinary100 |  | int 21
Constants.FV_SaveFmtBinary110 |  | int 23
Constants.FV_SaveFmtBinary120 |  | int 25
Constants.FV_SaveFmtBinary60 |  | int 11
Constants.FV_SaveFmtBinary70 |  | int 12
Constants.FV_SaveFmtBinary80 |  | int 13
Constants.FV_SaveFmtBinary90 |  | int 16
Constants.FV_SaveFmtBookWithFm |  | int 20
Constants.FV_SaveFmtBookWithXml |  | int 19
Constants.FV_SaveFmtCompositeDoc |  | int 18
Constants.FV_SaveFmtFilter |  | int 8
Constants.FV_SaveFmtInterchange |  | int 1
Constants.FV_SaveFmtInterchange100 |  | int 22
Constants.FV_SaveFmtInterchange110 |  | int 24
Constants.FV_SaveFmtInterchange120 |  | int 26
Constants.FV_SaveFmtInterchange70 |  | int 14
Constants.FV_SaveFmtInterchange80 |  | int 15
Constants.FV_SaveFmtInterchange90 |  | int 17
Constants.FV_SaveFmtPdf |  | int 9
Constants.FV_SaveFmtSgml |  | int 7
Constants.FV_SaveFmtStationery |  | int 3
Constants.FV_SaveFmtText |  | int 6
Constants.FV_SaveFmtViewOnly |  | int 4
Constants.FV_SaveFmtXml |  | int 10
Constants.FV_SaveNoAutoBackup |  | int 1
Constants.FV_SaveSkipTbls |  | int 3
Constants.FV_SaveTblColsAsPgfs |  | int 2
Constants.FV_SaveTblRowsAsPgfs |  | int 1
Constants.FV_SaveTblUserPref |  | int 0
Constants.FV_SaveUserPrefAutoBackup |  | int 2
Constants.FV_SaveYesAutoBackup |  | int 0
Constants.FV_SessionId |  | int 0
Constants.FV_SetDictionaryToNoneDictionary |  | int 6
Constants.FV_Shitf_JIS |  | int 6
Constants.FV_SourceDoc |  | int 0
Constants.FV_SpellCapitalization |  | int 2
Constants.FV_SpellExtraSpace |  | int 6
Constants.FV_SpellHyphenation |  | int 5
Constants.FV_SpellMisspelling |  | int 1
Constants.FV_SpellRepeatedLetter |  | int 4
Constants.FV_SpellRepeatedWord |  | int 3
Constants.FV_SpellSpaceAfter |  | int 7
Constants.FV_SpellSpaceBefore |  | int 8
Constants.FV_SpellStraightQuotes |  | int 9
Constants.FV_StripStructureAndOpen |  | int 10
Constants.FV_TAB_CENTER |  | int 0x2
Constants.FV_TAB_DECIMAL |  | int 0x4
Constants.FV_TAB_LEFT |  | int 0x1
Constants.FV_TAB_RELATIVE_CENTER |  | int 0x6
Constants.FV_TAB_RELATIVE_DECIMAL |  | int 0x8
Constants.FV_TAB_RELATIVE_LEFT |  | int 0x5
Constants.FV_TAB_RELATIVE_RIGHT |  | int 0x7
Constants.FV_TAB_RIGHT |  | int 0x3
Constants.FV_TBL_ANYWHERE |  | int 0
Constants.FV_TBL_CATALOG |  | int 13
Constants.FV_TBL_FLOAT |  | int 5
Constants.FV_TBL_NO_TITLE |  | int 0
Constants.FV_TBL_NUM_BY_COL |  | int 1
Constants.FV_TBL_NUM_BY_ROW |  | int 0
Constants.FV_TBL_TITLE_ABOVE |  | int 1
Constants.FV_TBL_TITLE_BELOW |  | int 2
Constants.FV_TBL_TOP_OF_COL |  | int 1
Constants.FV_TBL_TOP_OF_LEFT_PAGE |  | int 3
Constants.FV_TBL_TOP_OF_PAGE |  | int 2
Constants.FV_TBL_TOP_OF_RIGHT_PAGE |  | int 4
Constants.FV_TEMPLATE_BROWSER |  | int 11
Constants.FV_TEXTLINE_CENTER |  | int 2
Constants.FV_TEXTLINE_LEFT |  | int 0
Constants.FV_TEXTLINE_MATH |  | int 3
Constants.FV_TEXTLINE_RIGHT |  | int 1
Constants.FV_THESAURUS |  | int 10
Constants.FV_TR_BBOX |  | int 0x03
Constants.FV_TR_CONTOUR |  | int 0x02
Constants.FV_TR_NONE |  | int 0x01
Constants.FV_TYPE_BINARY |  | int 0x01
Constants.FV_TYPE_FILTER |  | int 0xFF
Constants.FV_TYPE_MIF |  | int 0x02
Constants.FV_TYPE_SGML |  | int 0x04
Constants.FV_TYPE_TEXT |  | int 0x03
Constants.FV_TYPE_XML |  | int 0x05
Constants.FV_TextFile_EOLisEOP |  | int 12
Constants.FV_TextFile_EOLisNotEOP |  | int 13
Constants.FV_TooManyWindows |  | int 128
Constants.FV_TooManyWindowsUpdateBook |  | int 98
Constants.FV_URL_CHECKED_IN |  | int 1
Constants.FV_URL_CHECKED_OUT |  | int 2
Constants.FV_UndoAll |  | int 3
Constants.FV_UnresolvedTextInsets |  | int 50
Constants.FV_UnresolvedXRefs |  | int 49
Constants.FV_Unstructured |  | int 41
Constants.FV_UpdateAllAutomaticClientTi |  | int 2
Constants.FV_UpdateAllClientTi |  | int 1
Constants.FV_UpdateAllManualClientTi |  | int 3
Constants.FV_UseCurrentSetting |  | int 0
Constants.FV_UserCanceled |  | int 112
Constants.FV_UserCanceledExport |  | int 32
Constants.FV_UserCanceledImport |  | int 37
Constants.FV_UserCanceledSave |  | int 48
Constants.FV_UserCanceledUpdateBook |  | int 35
Constants.FV_UserDictionary |  | int 1
Constants.FV_VAR_CREATION_DATE_LONG |  | int 7
Constants.FV_VAR_CREATION_DATE_SHORT |  | int 8
Constants.FV_VAR_CURRENT_DATE_LONG |  | int 3
Constants.FV_VAR_CURRENT_DATE_SHORT |  | int 4
Constants.FV_VAR_CURRENT_PAGE_NUM |  | int 1
Constants.FV_VAR_FILE_NAME_LONG |  | int 9
Constants.FV_VAR_FILE_NAME_SHORT |  | int 10
Constants.FV_VAR_HEADER_FOOTER_1 |  | int 11
Constants.FV_VAR_HEADER_FOOTER_10 |  | int 24
Constants.FV_VAR_HEADER_FOOTER_11 |  | int 25
Constants.FV_VAR_HEADER_FOOTER_12 |  | int 26
Constants.FV_VAR_HEADER_FOOTER_13 |  | int 27
Constants.FV_VAR_HEADER_FOOTER_14 |  | int 28
Constants.FV_VAR_HEADER_FOOTER_15 |  | int 29
Constants.FV_VAR_HEADER_FOOTER_16 |  | int 30
Constants.FV_VAR_HEADER_FOOTER_17 |  | int 31
Constants.FV_VAR_HEADER_FOOTER_18 |  | int 32
Constants.FV_VAR_HEADER_FOOTER_2 |  | int 12
Constants.FV_VAR_HEADER_FOOTER_3 |  | int 13
Constants.FV_VAR_HEADER_FOOTER_4 |  | int 14
Constants.FV_VAR_HEADER_FOOTER_5 |  | int 19
Constants.FV_VAR_HEADER_FOOTER_6 |  | int 20
Constants.FV_VAR_HEADER_FOOTER_7 |  | int 21
Constants.FV_VAR_HEADER_FOOTER_8 |  | int 22
Constants.FV_VAR_HEADER_FOOTER_9 |  | int 23
Constants.FV_VAR_MODIFICATION_DATE_LONG |  | int 5
Constants.FV_VAR_MODIFICATION_DATE_SHORT |  | int 6
Constants.FV_VAR_PAGE_COUNT |  | int 2
Constants.FV_VAR_TABLE_CONTINUATION |  | int 15
Constants.FV_VAR_TABLE_SHEET |  | int 16
Constants.FV_VAR_USER_VARIABLE |  | int 0
Constants.FV_VIEW_ALL |  | int (0x01|0x02|0x04)
Constants.FV_VIEW_AUTHOR |  | int 0x02
Constants.FV_VIEW_WYSIWYG |  | int 0x01
Constants.FV_VIEW_XML |  | int 0x04
Constants.FV_VOS_NONE |  | int 2
Constants.FV_VOS_USER_ONLY |  | int 1
Constants.FV_VOS_YES |  | int 3
Constants.FV_VOX_ALERT |  | int 3
Constants.FV_VOX_GOTO_BEHAVIOR |  | int 1
Constants.FV_VOX_NOT_ACTIVE |  | int 0
Constants.FV_VOX_OPEN_BEHAVIOR |  | int 2
Constants.FV_WIDE |  | int 0
Constants.FV_WINDOW_ALL |  | int (0x01|0x02|0x04)
Constants.FV_WINDOW_BOOK |  | int 0x02
Constants.FV_WINDOW_DITAMAP |  | int 0x04
Constants.FV_WINDOW_DOC |  | int 0x01
Constants.FV_WarnAlways |  | int 1
Constants.FV_WarnNever |  | int 0
Constants.FV_WarnOnce |  | int 2
Constants.FV_WriteDictionaryToFile |  | int 4
Constants.FV_WriteUnknownWordsToFile |  | int 3
Constants.FV_XML_STANDALONE_NO |  | int 2
Constants.FV_XML_STANDALONE_NODEC |  | int 4
Constants.FV_XML_STANDALONE_NONE |  | int 3
Constants.FV_XML_STANDALONE_YES |  | int 1
Constants.FV_XML_USEBOM_NO |  | int 2
Constants.FV_XML_USEBOM_UTF16BE |  | int 4
Constants.FV_XML_USEBOM_UTF16LE |  | int 5
Constants.FV_XML_USEBOM_UTF32BE |  | int 6
Constants.FV_XML_USEBOM_UTF32LE |  | int 7
Constants.FV_XML_USEBOM_UTF8 |  | int 3
Constants.FV_XML_USEBOM_YES |  | int 1
Constants.FV_XML_WELLFORMED_NO |  | int 2
Constants.FV_XML_WELLFORMED_YES |  | int 1
Constants.FV_ZOOM_TO_FIT_TO_WINDOW |  | int -2
Constants.oldFT_ElementFmts |  | int 11

Usage
Jongware, 18-Jan-2015 v1.0 Contents :: Index


Adobe FrameMaker-12 Object Model JS: Doc

Class

Doc

QuickLinks

 AddNewBuildExpr, AddTableVariables, AddText, CenterOnText, Clear, ClearAllChangebars, Close, Compare, Copy, Cut, DeleteBuildExpr, DeleteText, DeleteUndefinedAttribute, DeleteUnusedCharFmt, DeleteUnusedFmts, DeleteUnusedGraphicsFmt, DeleteUnusedPgfFmt, DeleteUnusedTblFmt, DemoteElement, ElementLocToTextLoc, Export, Find, GetActiveBuildExpr, GetBuildExpr, GetBuildExprCatalog, GetDependencies, GetNamedAttrCondExpr, GetNamedCharFmt, GetNamedColor, GetNamedCombinedFontDefn, GetNamedCondFmt, GetNamedElementDef, GetNamedFmtChangeList, GetNamedGraphicsFmt, GetNamedMarkerType, GetNamedMasterPage, GetNamedObject, GetNamedPgfFmt, GetNamedRefPage, GetNamedRulingFmt, GetNamedTblFmt, GetNamedUnanchoredFrame, GetNamedVarFmt, GetNamedXRefFmt, GetProps, GetTextForRange, GetTextForRange2, GetTextPropVal, GetTextProps, GetTextVal, GetUniqueObject, HypertextCommand, Import, MergeIntoFirst, MergeIntoLast, NewAnchoredAFrame, NewAnchoredFn, NewAnchoredFormattedObject, NewAnchoredFormattedTbl, NewAnchoredFormattedVar, NewAnchoredFormattedXRef, NewAnchoredMarker, NewAnchoredObject, NewAnchoredTbl, NewAnchoredTiApiClient, NewArc, NewEllipse, NewFlow, NewGraphicObject, NewGroup, NewInset, NewIterator, NewLine, NewMath, NewMathML, NewNamedAttrCondExpr, NewNamedCharFmt, NewNamedColor, NewNamedCombinedFontDefn, NewNamedCondFmt, NewNamedElementDef, NewNamedFmtChangeList, NewNamedGraphicsFmt, NewNamedMarkerType, NewNamedMasterPage, NewNamedObject, NewNamedPgfFmt, NewNamedRefPage, NewNamedRulingFmt, NewNamedTblFmt, NewNamedVarFmt, NewNamedXRefFmt, NewPolygon, NewPolyline, NewRectangle, NewRoundRect, NewSeriesBodyPage, NewSeriesObject, NewSeriesPgf, NewTable, NewTextFrame, NewTextLine, NewUnanchoredFrame, ObjectValid, Paste, PromoteElement, QuickSelect, Redisplay, Reformat, Rehyphenate, ResetEqnSettings, ResetReferenceFrames, RestartPgfNumbering, Save, ScrollToText, SetActiveBuildExpr, SetAttributeSimple, SetElementRange, SetProps, SetTextPropVal, SetTextProps, SetTextVal, SilentPrintDoc, SimpleImportElementDefs, SimpleImportFormats, SimpleSave, SplitElement, TextLocToElementLoc, TrackChangesAcceptAll, TrackChangesRejectAll, UnWrapElement, UndoCancel, UndoEndCheckPoint, UndoStartCheckPoint, UpdateDITAReferences, UpdateVariables, UpdateXRef, UpdateXRefs

Properties

Property | Type | Access | Description
AcrobatBookmarkDisplayTags | int | readwrite |
AutoChangeBars | int | readwrite |
BannerTextDisplay | bool | readwrite |
BooleanConditionExpression | string | readwrite |
BooleanConditionExpressionTag | string | readwrite |
BooleanConditionState | int | readwrite |
BottomMargin | int | readwrite |
Capitalization | int | readwrite |
ChangeBar | int | readwrite |
ChangeBarColor | Color | readwrite |
ChangeBarDistance | int | readwrite |
ChangeBarPosition | int | readwrite |
ChangeBarThickness | int | readwrite |
ChapNumComputeMethod | int | readwrite |
ChapterNumStyle | int | readwrite |
ChapterNumText | string | readwrite |
ChapterNumber | int | readwrite |
CharTag | string | readwrite |
ColGap | int | readwrite |
Color | Color | readwrite |
CombinedFontFamily | CombinedFontDefn | readwrite |
CondFmtIsShown | int | readwrite |
CurrentPage | FMObject | readwrite |
CustomElementList | Strings String | readwrite |
DefaultExclusions | Strings String | readwrite |
DefaultInclusions | Strings String | readwrite |
Dictionary | Strings String | readwrite |
DocAcrobatColumnArticleThreads | int | readwrite |
DocAcrobatDefaultsChanged | int | readwrite |
DocAcrobatElementList | Strings String | readwrite |
DocAcrobatElements | int | readwrite |
DocAcrobatNoArticleThreads | int | readwrite |
DocFluidFlow | Flow | readwrite |
DocIsDoubleSided | int | readwrite |
DocIsModified | int | readonly |
DocIsViewOnly | int | readwrite |
DocOpenType | int | readonly |
DocSaveType | int | readonly |
DontUpdateTextInsets | int | readwrite |
DontUpdateXRefs | int | readwrite |
DownloadFonts | int | readwrite |
ElementBoundaryDisplay | int | readwrite |
ElementCatalog | ElementCatalogEntries ElementCatalogEntry | readonly |
ElementCatalogDisplay | int | readwrite |
ElementSelection | ElementRange | readwrite |
EqnIntegralSizeLarge | int | readwrite |
EqnIntegralSizeMed | int | readwrite |
EqnIntegralSizeSmall | int | readwrite |
EqnLevel1SizeLarge | int | readwrite |
EqnLevel1SizeMed | int | readwrite |
EqnLevel1SizeSmall | int | readwrite |
EqnLevel2SizeLarge | int | readwrite |
EqnLevel2SizeMed | int | readwrite |
EqnLevel2SizeSmall | int | readwrite |
EqnLevel3SizeLarge | int | readwrite |
EqnLevel3SizeMed | int | readwrite |
EqnLevel3SizeSmall | int | readwrite |
EqnSigmaSizeLarge | int | readwrite |
EqnSigmaSizeMed | int | readwrite |
EqnSigmaSizeSmall | int | readwrite |
FirstAttrCondExprInDoc | AttrCondExpr | readonly |
FirstBodyPageInDoc | BodyPage | readonly |
FirstCharFmtInDoc | CharFmt | readonly |
FirstColorInDoc | Color | readonly |
FirstCombinedFontDefnInDoc | CombinedFontDefn | readonly |
FirstCondFmtInDoc | CondFmt | readonly |
FirstDITAConrefElementInDoc | Element | readonly |
FirstDITALinkElementInDoc | Element | readonly |
FirstDITATopicrefElementInDoc | Element | readonly |
FirstDITATopicsetrefElementInDoc | Element | readonly |
FirstDITAXrefElementInDoc | Element | readonly |
FirstElementDefInDoc | ElementDef | readonly |
FirstFlowInDoc | Flow | readonly |
FirstFmtChangeListInDoc | FmtChangeList | readwrite |
FirstFnInDoc | Fn | readonly |
FirstGraphicInDoc | FMObject | readonly |
FirstGraphicsFmtInDoc | GraphicsFmt | readonly |
FirstMarkerInDoc | Marker | readonly |
FirstMarkerTypeInDoc | MarkerType | readonly |
FirstMasterPageInDoc | MasterPage | readonly |
FirstPageNum | int | readwrite |
FirstPageVerso | int | readwrite |
FirstPgfFmtInDoc | PgfFmt | readonly |
FirstPgfInDoc | Pgf | readonly |
FirstRefPageInDoc | RefPage | readonly |
FirstRubiInDoc | Rubi | readonly |
FirstRulingFmtInDoc | RulingFmt | readonly |
FirstSelectedGraphicInDoc | FMObject | readonly |
FirstSelectedTiInDoc | FMObject | readonly |
FirstTblFmtInDoc | TblFmt | readonly |
FirstTblInDoc | Tbl | readonly |
FirstTiInDoc | FMObject | readonly |
FirstVarFmtInDoc | VarFmt | readonly |
FirstVarInDoc | Var | readonly |
FirstXRefFmtInDoc | XRefFmt | readonly |
FirstXRefInDoc | XRef | readonly |
FnCustNumString | string | readwrite |
FnFirstNum | int | readwrite |
FnFmt | string | readwrite |
FnHeightPerCol | int | readwrite |
FnInstancePosition | int | readwrite |
FnInstancePrefix | string | readwrite |
FnInstanceSuffix | string | readwrite |
FnNumComputeMethod | int | readwrite |
FnNumStyle | int | readwrite |
FnNumberingPerPage | int | readwrite |
FnRefPosition | int | readwrite |
FnRefPrefix | string | readwrite |
FnRefSuffix | string | readwrite |
FontAngle | int | readwrite |
FontEncodingName | string | readonly |
FontFamily | int | readwrite |
FontPlatformName | string | readwrite |
FontPostScriptName | string | readwrite |
FontSize | int | readwrite |
FontVariation | int | readwrite |
FontWeight | int | readwrite |
FormatOverride | int | readwrite |
Functions | string | readwrite |
GenerateAcrobatInfo | int | readwrite |
HiddenPage | HiddenPage | readonly |
HypertextCommandText | string | readwrite |
HypertextDoValidate | bool | readwrite |
HypertextParseBadParam | int | readonly |
HypertextParseErr | int | readonly |
HypertextParseErrMsg | string | readonly |
HypertextParsedClientName | string | readonly |
HypertextParsedCmdCode | int | readonly |
HypertextParsedCmdDest | int | readonly |
HypertextParsedCmdDestObjID | int | readonly |
HypertextParsedCmdDestObjType | int | readonly |
HypertextParsedCmdMatrixColumns | int | readonly |
HypertextParsedCmdMatrixRows | int | readonly |
HypertextParsedDIFileName | string | readonly |
HypertextParsedFlowName | string | readonly |
HypertextParsedLinkName | string | readonly |
HypertextParsedMessage | string | readonly |
HypertextParsedPageName | string | readonly |
HypertextParsedTitle | string | readonly |
HypertextValidateErr | int | readonly |
InCond | Objects | readwrite |
IsIconified | int | readwrite |
IsInFront | int | readwrite |
IsOnScreen | int | readwrite |
KernX | int | readwrite |
KernY | int | readwrite |
KeyCatalog | KeyCatalog | readonly |
KeyCatalogType | int | readwrite |
Label | string | readwrite |
LastBodyPageInDoc | BodyPage | readonly |
LastMasterPageInDoc | MasterPage | readonly |
LastRefPageInDoc | RefPage | readonly |
LeftMargin | int | readwrite |
LeftMasterPage | MasterPage | readonly |
LineBreakAfter | string | readwrite |
LineNumDistance | int | readwrite |
LineNumRestart | bool | readwrite |
LineNumShow | bool | readwrite |
MainFlowInDoc | Flow | readonly |
MarkerTypeNames | Strings String | readonly |
MaxBottomMargin | int | readwrite |
MaxFirstIndent | int | readwrite |
MaxFontSize | int | readwrite |
MaxLeading | int | readwrite |
MaxLeftIndent | int | readwrite |
MaxLeftMargin | int | readwrite |
MaxRightIndent | int | readwrite |
MaxRightMargin | int | readwrite |
MaxSpaceAbove | int | readwrite |
MaxSpaceBelow | int | readwrite |
MaxSpread | int | readwrite |
MaxStretch | int | readwrite |
MaxTabPosition | int | readwrite |
MaxTopMargin | int | readwrite |
MenuBar | Menu | readwrite |
MinBottomMargin | int | readwrite |
MinFirstIndent | int | readwrite |
MinFontSize | int | readwrite |
MinLeading | int | readwrite |
MinLeftIndent | int | readwrite |
MinLeftMargin | int | readwrite |
MinRightIndent | int | readwrite |
MinRightMargin | int | readwrite |
MinSpaceAbove | int | readwrite |
MinSpaceBelow | int | readwrite |
MinSpread | int | readwrite |
MinStretch | int | readwrite |
MinTabPosition | int | readwrite |
MinTopMargin | int | readwrite |
Name | string | readonly |
NarrowRubiSpaceForOther | int | readwrite |
NewElemAttrDisplay | int | readwrite |
NewElemAttrEditing | int | readwrite |
NextOpenDocInSession | Doc | readonly |
NumCols | int | readonly |
Numbers | string | readwrite |
Overline | int | readwrite |
PDFAllNamedDestinations | int | readwrite |
PDFBookmark | bool | readwrite |
PDFBookmarksOpenLevel | int | readwrite |
PDFConvertCMYKtoRGB | int | readwrite |
PDFDestsMarked | int | readwrite |
PDFDistillerAbsent | int | readonly |
PDFDocInfo | Strings String | readwrite |
PDFEndPage | string | readwrite |
PDFGenerateForReview | int | readwrite |
PDFJobOption | string | readwrite |
PDFJobOptionsAbsent | int | readonly |
PDFOpenPage | string | readwrite |
PDFPageHeight | int | readwrite |
PDFPageWidth | int | readwrite |
PDFPrintPageRange | int | readwrite |
PDFRegistrationMarks | int | readwrite |
PDFSeparateFiles | int | readwrite |
PDFStartPage | string | readwrite |
PDFStructure | int | readwrite |
PDFViewPDF | int | readwrite |
PDFZoomFactor | int | readwrite |
PDFZoomType | int | readwrite |
PageHeight | int | readwrite |
PageNumComputeMethod | int | readwrite |
PageNumStyle | int | readwrite |
PageRounding | int | readwrite |
PageWidth | int | readwrite |
PairKern | int | readwrite |
PgfNumComputeMethod | int | readwrite |
PointPageNumStyle | int | readwrite |
Position | int | readwrite |
PreviewState | int | readwrite |
PrintBlankPages | int | readwrite |
PrintCollated | int | readwrite |
PrintCols | int | readwrite |
PrintDitavalFileName | string | readwrite |
PrintEmulsion | int | readwrite |
PrintEndPage | int | readwrite |
PrintEndPageName | int | readwrite |
PrintEndPoint | int | readwrite |
PrintEvenPages | int | readwrite |
PrintFileName | string | readwrite |
PrintImaging | int | readwrite |
PrintLastSheetFirst | int | readwrite |
PrintLowRes | int | readwrite |
PrintManualFeed | int | readwrite |
PrintNumCopies | int | readwrite |
PrintOddPages | int | readwrite |
PrintPaperHeight | int | readwrite |
PrintPaperWidth | int | readwrite |
PrintRegistrationMarks | int | readwrite |
PrintRows | int | readwrite |
PrintScale | int | readwrite |
PrintScope | int | readwrite |
PrintSeps | int | readwrite |
PrintStartPage | int | readwrite |
PrintStartPageName | int | readwrite |
PrintStartPoint | int | readwrite |
PrintThumbnails | int | readwrite |
PrintToFile | int | readwrite |
PrinterName | string | readwrite |
ReviewerName | string | readwrite |
ReviewerNameList | Strings String | readonly |
RightMargin | int | readwrite |
RightMasterPage | MasterPage | readonly |
RubiFixedSize | int | readwrite |
RubiOverhang | int | readwrite |
RubiSize | int | readwrite |
ScreenHeight | int | readwrite |
ScreenWidth | int | readwrite |
ScreenX | int | readwrite |
ScreenY | int | readwrite |
SecNumComputeMethod | int | readwrite |
SectionNumStyle | int | readwrite |
SectionNumText | string | readwrite |
SectionNumber | int | readwrite |
SelectedTbl | Tbl | readonly |
SepOverride | Color | readwrite |
SeparateInclusions | int | readwrite |
ShowAll | int | readwrite |
ShowCondIndicators | int | readwrite |
ShowElementDescriptiveNames | bool | readwrite |
SkipBlankSeps | int | readwrite |
SmallCapsSize | int | readwrite |
SmallCapsStretch | int | readwrite |
SmartQuotes | int | readwrite |
SmartSpaces | int | readwrite |
SnapAngle | int | readwrite |
SnapGridUnits | int | readwrite |
SpecifiedKeyCatalog | KeyCatalog | readwrite |
SpotColorView | int | readwrite |
Spread | int | readwrite |
StatusLine | string | readwrite |
Stretch | int | readwrite |
Strikethrough | int | readwrite |
Strings | string | readwrite |
StructuredApplication | string | readwrite |
StructuredApplicationForOpen | string | readwrite |
StyleOverrides | int | readonly |
SubScriptShift | int | readwrite |
SubScriptSize | int | readwrite |
SubScriptStretch | int | readwrite |
SubsecNumComputeMethod | int | readwrite |
SubsectionNumStyle | int | readwrite |
SubsectionNumText | string | readwrite |
SubsectionNumber | int | readwrite |
SuperScriptShift | int | readwrite |
SuperScriptSize | int | readwrite |
SuperScriptStretch | int | readwrite |
Symbols | string | readwrite |
SymbolsList | Strings String | readonly |
TblFnCellPosition | int | readwrite |
TblFnCellPrefix | string | readwrite |
TblFnCellSuffix | string | readwrite |
TblFnCustNumString | string | readwrite |
TblFnFmt | string | readwrite |
TblFnNumStyle | int | readwrite |
TblFnPosition | int | readwrite |
TblFnPrefix | string | readwrite |
TblFnSuffix | string | readwrite |
TextSelection | TextRange | readwrite |
TopMargin | int | readwrite |
TrackChangesAddedColor | Color | readwrite |
TrackChangesDeletedColor | Color | readwrite |
TrackChangesOn | bool | readwrite |
TrapwiseCompatibility | bool | readwrite |
Underlining | int | readwrite |
Untouchable | int | readwrite |
UseInitialStructure | int | readwrite |
UseInitialStructureOfAutoInsertedElements | bool | readwrite |
UseSepOverride | int | readwrite |
UserString | string | readwrite |
Variables | string | readwrite |
ViewBorders | int | readwrite |
ViewDisplayUnits | int | readwrite |
ViewFontSizeUnits | int | readwrite |
ViewGrid | int | readwrite |
ViewGridUnits | int | readwrite |
ViewHotspotIndicators | int | readwrite |
ViewNoGraphics | int | readwrite |
ViewOnlyDeadCodes | UInts | readwrite |
ViewOnlyMenuBar | Menu | readwrite |
ViewOnlySelect | int | readwrite |
ViewOnlyWinBorders | int | readwrite |
ViewOnlyWinMenubar | int | readwrite |
ViewOnlyWinPalette | int | readwrite |
ViewOnlyWinPopup | int | readwrite |
ViewOnlyXRef | int | readwrite |
ViewPageScrolling | int | readwrite |
ViewRulerUnits | int | readwrite |
ViewRulers | int | readwrite |
ViewTextSymbols | int | readwrite |
VolNumComputeMethod | int | readwrite |
VolumeNumStyle | int | readwrite |
VolumeNumText | string | readwrite |
VolumeNumber | int | readwrite |
WideRubiSpaceForOther | int | readwrite |
XmlDocType | string | readwrite |
XmlEncoding | string | readwrite |
XmlFileEncoding | string | readwrite |
XmlPublicId | string | readwrite |
XmlStandAlone | int | readwrite |
XmlStyleSheet | string | readwrite |
XmlStyleSheetList | Strings String | readwrite |
XmlSystemId | string | readwrite |
XmlUseBOM | int | readwrite |
XmlVersion | string | readwrite |
XmlWellFormed | int | readwrite |
Zoom | int | readwrite |

Methods

Instances

int AddNewBuildExpr (exprName: string, exprCondition: string)
Parameter | Type | Description
exprName | string |
exprCondition | string |

int AddTableVariables (tblFormatOrTblId: Object, allTables: bool, insertContVariable: bool, insertSheetVariable: bool)
Parameter | Type | Description
tblFormatOrTblId | Object |
allTables | bool |
insertContVariable | bool |
insertSheetVariable | bool |

TextLoc AddText (textLoc: TextLoc, text: string)
Parameter | Type | Description
textLoc | TextLoc |
text | string |

int CenterOnText (textRange: TextRange)
Parameter | Type | Description
textRange | TextRange |

int Clear (flags: int)
Parameter | Type | Description
flags | int |

int ClearAllChangebars ()

int Close (flags: int)
Parameter | Type | Description
flags | int |

CompareRet Compare (newerDoc: Doc, flags: int, insertCondTag: string, deleteCondTag: string, replaceText: string, compareThreshold: int)
Parameter | Type | Description
newerDoc | Doc |
flags | int |
insertCondTag | string |
deleteCondTag | string |
replaceText | string |
compareThreshold | int |

int Copy (flags: int)
Parameter | Type | Description
flags | int |

int Cut (flags: int)
Parameter | Type | Description
flags | int |

int DeleteBuildExpr (exprName: string)
Parameter | Type | Description
exprName | string |

int DeleteText (textRange: TextRange)
Parameter | Type | Description
textRange | TextRange |

int DeleteUndefinedAttribute (attrName: string, scope: int, objId: Object)
Parameter | Type | Description
attrName | string |
scope | int |
objId | Object |

int DeleteUnusedCharFmt ()

int DeleteUnusedFmts (objType: int)
Parameter | Type | Description
objType | int |

int DeleteUnusedGraphicsFmt ()

int DeleteUnusedPgfFmt ()

int DeleteUnusedTblFmt ()

void DemoteElement ()

TextLoc ElementLocToTextLoc (eloc: ElementLoc)
Parameter | Type | Description
eloc | ElementLoc |

int Export (fileName: string, exportParams: PropVals, exportReturnParams: PropVals)
Parameter | Type | Description
fileName | string |
exportParams | PropVals |
exportReturnParams | PropVals |

TextRange Find (textLoc: TextLoc, findParams: PropVals)
Parameter | Type | Description
textLoc | TextLoc |
findParams | PropVals |

string GetActiveBuildExpr ()

string GetBuildExpr (exprName: string)
Parameter | Type | Description
exprName | string |

Strings GetBuildExprCatalog ()

TypedVals GetDependencies (depMode: int)
Parameter | Type | Description
depMode | int |

AttrCondExpr GetNamedAttrCondExpr (name: string)
Parameter | Type | Description
name | string |

CharFmt GetNamedCharFmt (name: string)
Parameter | Type | Description
name | string |

Color GetNamedColor (name: string)
Parameter | Type | Description
name | string |

CombinedFontDefn GetNamedCombinedFontDefn (name: string)
Parameter | Type | Description
name | string |

CondFmt GetNamedCondFmt (name: string)
Parameter | Type | Description
name | string |

ElementDef GetNamedElementDef (name: string)
Parameter | Type | Description
name | string |

FmtChangeList GetNamedFmtChangeList (name: string)
Parameter | Type | Description
name | string |

GraphicsFmt GetNamedGraphicsFmt (name: string)
Parameter | Type | Description
name | string |

MarkerType GetNamedMarkerType (name: string)
Parameter | Type | Description
name | string |

MasterPage GetNamedMasterPage (name: string)
Parameter | Type | Description
name | string |

Object GetNamedObject (objType: int, name: string)
Parameter | Type | Description
objType | int |
name | string |

PgfFmt GetNamedPgfFmt (name: string)
Parameter | Type | Description
name | string |

RefPage GetNamedRefPage (name: string)
Parameter | Type | Description
name | string |

RulingFmt GetNamedRulingFmt (name: string)
Parameter | Type | Description
name | string |

TblFmt GetNamedTblFmt (name: string)
Parameter | Type | Description
name | string |

UnanchoredFrame GetNamedUnanchoredFrame (name: string)
Parameter | Type | Description
name | string |

VarFmt GetNamedVarFmt (name: string)
Parameter | Type | Description
name | string |

XRefFmt GetNamedXRefFmt (name: string)
Parameter | Type | Description
name | string |

PropVals GetProps ()

TextItems GetTextForRange (tr: TextRange, flags: int)
Parameter | Type | Description
tr | TextRange |
flags | int |

TextItems GetTextForRange2 (tr: TextRange, flags: int, flags2: int)
Parameter | Type | Description
tr | TextRange |
flags | int |
flags2 | int |

PropVal GetTextPropVal (textLoc: TextLoc, propNum: int)
Parameter | Type | Description
textLoc | TextLoc |
propNum | int |

PropVals GetTextProps (textLoc: TextLoc)
Parameter | Type | Description
textLoc | TextLoc |

TypedVal GetTextVal (textLoc: TextLoc, propNum: int)
Parameter | Type | Description
textLoc | TextLoc |
propNum | int |

Object GetUniqueObject (objType: int, unique: int)
Parameter | Type | Description
objType | int |
unique | int |

int HypertextCommand (hypertext: string)
Parameter | Type | Description
hypertext | string |

Object Import (textLocP: TextLoc, filename: string, importParams: PropVals, importReturnParams: PropVals)
Parameter | Type | Description
textLocP | TextLoc |
filename | string |
importParams | PropVals |
importReturnParams | PropVals |

void MergeIntoFirst ()

void MergeIntoLast ()

AFrame NewAnchoredAFrame (textloc: TextLoc)
Parameter | Type | Description
textloc | TextLoc |

Fn NewAnchoredFn (textloc: TextLoc)
Parameter | Type | Description
textloc | TextLoc |

Object NewAnchoredFormattedObject (objType: int, format: string, textLoc: TextLoc)
Parameter | Type | Description
objType | int |
format | string |
textLoc | TextLoc |

Tbl NewAnchoredFormattedTbl (format: string, textLoc: TextLoc)
Parameter | Type | Description
format | string |
textLoc | TextLoc |

Var NewAnchoredFormattedVar (format: string, textLoc: TextLoc)
Parameter | Type | Description
format | string |
textLoc | TextLoc |

XRef NewAnchoredFormattedXRef (format: string, textLoc: TextLoc)
Parameter | Type | Description
format | string |
textLoc | TextLoc |

Marker NewAnchoredMarker (textloc: TextLoc)
Parameter | Type | Description
textloc | TextLoc |

Object NewAnchoredObject (objType: int, textloc: TextLoc)
Parameter | Type | Description
objType | int |
textloc | TextLoc |

Tbl NewAnchoredTbl (textloc: TextLoc)
Parameter | Type | Description
textloc | TextLoc |

TiApiClient NewAnchoredTiApiClient (textloc: TextLoc)
Parameter | Type | Description
textloc | TextLoc |

Arc NewArc (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

Ellipse NewEllipse (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

Flow NewFlow (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

Object NewGraphicObject (objType: int, parent: FrameObject) GraphicObject could be any FM graphic object, i.e, AFrame ,UnanchoredFrame
Parameter | Type | Description
objType | int |
parent | FrameObject |

Group NewGroup (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

Inset NewInset (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

Object NewIterator (paramsp: PropVals)
Parameter | Type | Description
paramsp | PropVals |

Line NewLine (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

Math NewMath (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

MathML NewMathML (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

AttrCondExpr NewNamedAttrCondExpr (name: string)
Parameter | Type | Description
name | string |

CharFmt NewNamedCharFmt (name: string)
Parameter | Type | Description
name | string |

Color NewNamedColor (name: string)
Parameter | Type | Description
name | string |

CombinedFontDefn NewNamedCombinedFontDefn (name: string)
Parameter | Type | Description
name | string |

CondFmt NewNamedCondFmt (name: string)
Parameter | Type | Description
name | string |

ElementDef NewNamedElementDef (name: string)
Parameter | Type | Description
name | string |

FmtChangeList NewNamedFmtChangeList (name: string)
Parameter | Type | Description
name | string |

GraphicsFmt NewNamedGraphicsFmt (name: string)
Parameter | Type | Description
name | string |

MarkerType NewNamedMarkerType (name: string)
Parameter | Type | Description
name | string |

MasterPage NewNamedMasterPage (name: string)
Parameter | Type | Description
name | string |

Object NewNamedObject (objType: int, name: string)
Parameter | Type | Description
objType | int |
name | string |

PgfFmt NewNamedPgfFmt (name: string)
Parameter | Type | Description
name | string |

RefPage NewNamedRefPage (name: string)
Parameter | Type | Description
name | string |

RulingFmt NewNamedRulingFmt (name: string)
Parameter | Type | Description
name | string |

TblFmt NewNamedTblFmt (name: string)
Parameter | Type | Description
name | string |

VarFmt NewNamedVarFmt (name: string)
Parameter | Type | Description
name | string |

XRefFmt NewNamedXRefFmt (name: string)
Parameter | Type | Description
name | string |

Polygon NewPolygon (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

Polyline NewPolyline (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

Rectangle NewRectangle (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

RoundRect NewRoundRect (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

BodyPage NewSeriesBodyPage (previous: Object)
Parameter | Type | Description
previous | Object |

Object NewSeriesObject (objType: int, previous: Object)
Parameter | Type | Description
objType | int |
previous | Object |

Pgf NewSeriesPgf (previous: Object)
Parameter | Type | Description
previous | Object |

Tbl NewTable (format: string, numCols: int, numBodyRows: int, numHeaderRows: int, numFooterRows: int, textLoc: TextLoc)
Parameter | Type | Description
format | string |
numCols | int |
numBodyRows | int |
numHeaderRows | int |
numFooterRows | int |
textLoc | TextLoc |

TextFrame NewTextFrame (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

TextLine NewTextLine (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

UnanchoredFrame NewUnanchoredFrame (parent: FrameObject)
Parameter | Type | Description
parent | FrameObject |

int ObjectValid ()

int Paste (flags: int)
Parameter | Type | Description
flags | int |

void PromoteElement ()

int QuickSelect (prompt: string, stringlist: Strings)
Parameter | Type | Description
prompt | string |
stringlist | Strings |

int Redisplay ()

int Reformat ()

int Rehyphenate ()

int ResetEqnSettings ()

int ResetReferenceFrames ()

int RestartPgfNumbering ()

Object Save (saveAsName: string, saveParams: PropVals, saveReturnParams: PropVals)
Parameter | Type | Description
saveAsName | string |
saveParams | PropVals |
saveReturnParams | PropVals |

int ScrollToText (textRange: TextRange)
Parameter | Type | Description
textRange | TextRange |

int SetActiveBuildExpr (exprName: string)
Parameter | Type | Description
exprName | string |

int SetAttributeSimple (attrName: string, attrValStr: string, scope: int, objId: Object)
Parameter | Type | Description
attrName | string |
attrValStr | string |
scope | int |
objId | Object |

void SetElementRange (propNum: int, setVal: ElementRange)
Parameter | Type | Description
propNum | int |
setVal | ElementRange |

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

void SetTextPropVal (textRange: TextRange, setVal: PropVal)
Parameter | Type | Description
textRange | TextRange |
setVal | PropVal |

void SetTextProps (textRange: TextRange, setVal: PropVals)
Parameter | Type | Description
textRange | TextRange |
setVal | PropVals |

void SetTextVal (textRange: TextRange, propNum: int, setVal: TypedVal)
Parameter | Type | Description
textRange | TextRange |
propNum | int |
setVal | TypedVal |

int SilentPrintDoc ()

int SimpleImportElementDefs (fromDocOrBook: Doc|Book, importFlags: int)
Parameter | Type | Description
fromDocOrBook | Doc|Book |
importFlags | int |

int SimpleImportFormats (fromDoc: Doc, formatFlags: int)
Parameter | Type | Description
fromDoc | Doc |
formatFlags | int |

Doc SimpleSave (saveAsName: string, interactive: int)
Parameter | Type | Description
saveAsName | string |
interactive | int |

void SplitElement ()

ElementLoc TextLocToElementLoc (tloc: TextLoc)
Parameter | Type | Description
tloc | TextLoc |

int TrackChangesAcceptAll ()

int TrackChangesRejectAll ()

void UnWrapElement ()

void UndoCancel ()

void UndoEndCheckPoint ()

void UndoStartCheckPoint (description: string)
Parameter | Type | Description
description | string |

void UpdateDITAReferences (flag: int)
Parameter | Type | Description
flag | int |

int UpdateVariables ()

int UpdateXRef (srcDoc: Doc, xref: XRef)
Parameter | Type | Description
srcDoc | Doc |
xref | XRef |

int UpdateXRefs (updateXRefFlags: int)
Parameter | Type | Description
updateXRefFlags | int |

Element of

CompareRet.comp

CompareRet.sum

Doc.NextOpenDocInSession

app.ActiveDoc

app.FirstOpenDoc

Used in:

CompareRet Book.Compare (newerDoc: Doc, flags: int, insertCondTag: string, deleteCondTag: string, replaceText: string, compareThreshold: int)

int Book.SimpleImportFormats (fromDoc: Doc, formatFlags: int)

CompareRet CompareRet.CompareRet (sum: Doc, comp: Doc)

CompareRet Doc.Compare (newerDoc: Doc, flags: int, insertCondTag: string, deleteCondTag: string, replaceText: string, compareThreshold: int)

int Doc.SimpleImportFormats (fromDoc: Doc, formatFlags: int)

int Doc.UpdateXRef (srcDoc: Doc, xref: XRef)

Return

Doc Doc.SimpleSave (saveAsName: string, interactive: int)

Doc Globals.CustomDoc (width: int, height: int, numCols: int, columnGap: int, topMargin: int, botMargin: int, leftinsideMargin: int, rightoutsideMargin: int, sidedness: int, makeVisible: bool)

Doc Globals.SimpleNewDoc (templateName: string, interactive: int)


Adobe FrameMaker-12 Object Model JS: Element

Class

Element

QuickLinks

 Delete, GetAttributes, GetProps, GetText, ObjectValid, SetProps, UpdateDITAReference

Properties

Property | Type | Access | Description
AllowAsSpecialCase | int | readwrite |
AttrDisplay | int | readwrite |
AttributeValueInvalid | int | readwrite |
Attributes | Attributes Attribute | readwrite |
AttributesEx | AttributesEx | readwrite |
BookComponent | BookComponent | readonly |
BookComponentMissing | int | readonly |
ContentIsLooselyValid | int | readonly |
ContentIsStrictlyValid | int | readonly |
ContentMustBeEmpty | int | readonly |
ContentNeededAtBegin | int | readonly |
ContentNeededAtEnd | int | readonly |
ContextLabel | string | readonly |
ElementDef | ElementDef | readwrite |
ElementIsCollapsed | int | readwrite |
ElementIsExcludedInContext | int | readonly |
ElementIsInvalidInParent | int | readonly |
ElementIsInvalidInPosition | int | readonly |
ElementIsTopicGroup | bool | readonly |
ElementIsTopicHead | bool | readonly |
ElementIsTopicRef | bool | readonly |
ElementIsUndefined | int | readonly |
ElementMarkedForNamedDestination | int | readwrite |
ElementType | int | readonly |
ErrorInBookComponent | int | readonly |
FirstChildElement | Element | readonly |
FormatOverride | int | readonly |
HoleBeforeElement | int | readonly |
InvalidHighestLevel | int | readonly |
LastChildElement | Element | readonly |
MatchingFirstPgfClauses | Objects | readonly |
MatchingLastPgfClauses | Objects | readonly |
MatchingObjectClauses | Objects | readonly |
MatchingPrefixClauses | Objects | readonly |
MatchingSuffixClauses | Objects | readonly |
MatchingTextClauses | Objects | readonly |
Namespace | Strings String | readwrite |
NamespaceScope | Element | readonly |
NextDITAConrefElementInDoc | Element | readonly |
NextDITALinkElementInDoc | Element | readonly |
NextDITATopicrefElementInDoc | Element | readonly |
NextDITATopicsetrefElementInDoc | Element | readonly |
NextDITAXrefElementInDoc | Element | readonly |
NextElementDFS | Element | readonly |
NextInvalidElement | Element | readonly |
NextSiblingElement | Element | readonly |
NumNamespaces | int | readonly |
Object | FMObject | readonly |
ParentElement | Element | readonly |
PrevElementDFS | Element | readonly |
PrevSiblingElement | Element | readonly |
TextIsInvalidInElement | int | readonly |
TextRange | TextRange | readonly |
TopicRefAbsoluteFilePath | string | readonly |
Unique | int | readonly |
UserString | string | readwrite |
ValidationFlags | int | readonly |

Methods

Instances

int Delete ()

Attributes GetAttributes ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

void UpdateDITAReference (objType: int)
Parameter | Type | Description
objType | int |

Element of

AFrame.Element

Book.HighestLevelElement

BookComponent.ComponentElement

Cell.Element

Cell.HighestLevelElement

Doc.FirstDITAConrefElementInDoc

Doc.FirstDITALinkElementInDoc

Doc.FirstDITATopicrefElementInDoc

Doc.FirstDITATopicsetrefElementInDoc

Doc.FirstDITAXrefElementInDoc

Element.FirstChildElement

Element.LastChildElement

Element.NamespaceScope

Element.NextDITAConrefElementInDoc

Element.NextDITALinkElementInDoc

Element.NextDITATopicrefElementInDoc

Element.NextDITATopicsetrefElementInDoc

Element.NextDITAXrefElementInDoc

Element.NextElementDFS

Element.NextInvalidElement

Element.NextSiblingElement

Element.ParentElement

Element.PrevElementDFS

Element.PrevSiblingElement

ElementLoc.child

ElementLoc.parent

Flow.HighestLevelElement

Fn.Element

Marker.Element

Row.Element

Rubi.Element

Rubi.RubiElement

Tbl.Element

Tbl.HighestLevelElement

Tbl.TblBodyElement

Tbl.TblElement

Tbl.TblFooterElement

Tbl.TblHeaderElement

Tbl.TblTitleElement

Var.Element

XRef.Element

Used in:

ElementLoc ElementLoc.ElementLoc (parent: Element, child: Element, offset: int)

Return

Element Book.NewBookComponentInHierarchy (compName: string, elemLoc: ElementLoc)

Element ElementDef.NewElement (textLoc: TextLoc)

Element ElementDef.NewElementInHierarchy (elemLoc: ElementLoc)


Adobe FrameMaker-12 Object Model JS: ElementCatalogEntries

Class

ElementCatalogEntries

An Array of ElementCatalogEntry objects with integer indexing and a length property.

See also ElementCatalogEntry.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

ElementCatalogEntries concat (value: ElementCatalogEntries)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | ElementCatalogEntries | Any number of values to be added to the end of the array. Can also be arrays.

ElementCatalogEntry pop ()
Removes the last element from the array.

number push (value: ElementCatalogEntry)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | ElementCatalogEntry |

Element of

Book.ElementCatalog

Doc.ElementCatalog

TypedVal.csval

Used in:

ElementCatalogEntries ElementCatalogEntries.concat (value: ElementCatalogEntries)

Return

ElementCatalogEntries ElementCatalogEntries.concat (value: ElementCatalogEntries)


Adobe FrameMaker-12 Object Model JS: ElementCatalogEntry

Class

ElementCatalogEntry

QuickLinks

 ElementCatalogEntry

Properties

Property | Type | Access | Description
flags | uint | readwrite |
obj | ElementDef | readwrite |

Methods

Constructor

ElementCatalogEntry ElementCatalogEntry (obj: ElementDef, flags: uint)
Parameter | Type | Description
obj | ElementDef |
flags | uint |

Example new ElementCatalogEntry()

Used in:

number ElementCatalogEntries.push (value: ElementCatalogEntry)

Return

ElementCatalogEntry ElementCatalogEntries.pop ()

ElementCatalogEntry ElementCatalogEntry.ElementCatalogEntry (obj: ElementDef, flags: uint)


Adobe FrameMaker-12 Object Model JS: ElementDef

Class

ElementDef

QuickLinks

 Delete, ElementDefIsText, GetAttributeDefs, GetProps, NewElement, NewElementInHierarchy, NewFirstPgfRules, NewLastPgfRules, NewObjectFmtRules, NewPrefixRules, NewSuffixRules, NewTextFmtRules, ObjectValid, SetProps, WrapElement

Properties

Property | Type | Access | Description
AlsoInsert | Strings String | readwrite |
AlsoInserts | TypedVal | readwrite |
AttributeDefs | AttributeDefs AttributeDef | readwrite |
BannerText | string | readwrite |
Comment | string | readwrite |
DescriptiveTag | string | readwrite |
ElementDataType | int | readwrite |
ElementDefType | int | readwrite |
ElementDescription | string | readwrite |
ElementInCatalog | int | readwrite |
ElementPgfFormat | string | readwrite |
Exclusions | Strings String | readwrite |
FirstPgfRules | Objects | readonly |
GeneralRule | string | readwrite |
GeneralRuleErrorOffsets | Ints | readonly |
Inclusions | Strings String | readwrite |
InitStructurePattern | string | readwrite |
LastPgfRules | Objects | readonly |
Name | string | readonly |
NextElementDefInDoc | ElementDef | readonly |
ObjectFmtRules | Objects | readonly |
PrefixRules | Objects | readonly |
SuffixRules | Objects | readonly |
TextFmtRules | Objects | readonly |
ValidHighestLevel | int | readwrite |

Methods

Instances

int Delete ()

int ElementDefIsText ()

AttributeDefs GetAttributeDefs ()

PropVals GetProps ()

Element NewElement (textLoc: TextLoc)
Parameter | Type | Description
textLoc | TextLoc |

Element NewElementInHierarchy (elemLoc: ElementLoc)
Parameter | Type | Description
elemLoc | ElementLoc |

FmtRule NewFirstPgfRules ()

FmtRule NewLastPgfRules ()

FmtRule NewObjectFmtRules ()

FmtRule NewPrefixRules ()

FmtRule NewSuffixRules ()

FmtRule NewTextFmtRules ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

void WrapElement ()

Element of

Book.FirstElementDefInDoc

Doc.FirstElementDefInDoc

Element.ElementDef

ElementCatalogEntry.obj

ElementDef.NextElementDefInDoc

FmtRule.ElementDef

Used in:

ElementCatalogEntry ElementCatalogEntry.ElementCatalogEntry (obj: ElementDef, flags: uint)

Return

ElementDef Doc.GetNamedElementDef (name: string)

ElementDef Doc.NewNamedElementDef (name: string)


Adobe FrameMaker-12 Object Model JS: ElementLoc

Class

ElementLoc

QuickLinks

 ElementLoc

Properties

Property | Type | Access | Description
child | Element | readwrite |
offset | int | readwrite |
parent | Element | readwrite |

Methods

Constructor

ElementLoc ElementLoc (parent: Element, child: Element, offset: int)
Parameter | Type | Description
parent | Element |
child | Element |
offset | int |

Example new ElementLoc()

Element of

ElementRange.beg

ElementRange.end

Used in:

Element Book.NewBookComponentInHierarchy (compName: string, elemLoc: ElementLoc)

BookComponent Book.NewBookComponentOfTypeInHierarchy (compName: string, compType: int, elemLoc: ElementLoc)

TextLoc Doc.ElementLocToTextLoc (eloc: ElementLoc)

Element ElementDef.NewElementInHierarchy (elemLoc: ElementLoc)

ElementRange ElementRange.ElementRange (beg: ElementLoc, end: ElementLoc)

Return

ElementLoc Doc.TextLocToElementLoc (tloc: TextLoc)

ElementLoc ElementLoc.ElementLoc (parent: Element, child: Element, offset: int)


Adobe FrameMaker-12 Object Model JS: ElementRange

Class

ElementRange

QuickLinks

 ElementRange

Properties

Property | Type | Access | Description
beg | ElementLoc | readwrite |
end | ElementLoc | readwrite |

Methods

Constructor

ElementRange ElementRange (beg: ElementLoc, end: ElementLoc)
Parameter | Type | Description
beg | ElementLoc |
end | ElementLoc |

Example new ElementRange()

Element of

Book.ElementSelection

Doc.ElementSelection

Used in:

void Doc.SetElementRange (propNum: int, setVal: ElementRange)

Return

ElementRange ElementRange.ElementRange (beg: ElementLoc, end: ElementLoc)


Adobe FrameMaker-12 Object Model JS: Ellipse

Class

Ellipse

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
RectangleIsSmoothed | int | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

Ellipse Doc.NewEllipse (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: FCodes

Enumeration

FCodes

Value

Name | Description | Value
FCodes.ALT_GFX_INSET |  | int 0xB12
FCodes.ALT_TXT_INSET |  | int 0xB11
FCodes.AMT_DEACTIVATION |  | int 0x967
FCodes.AMT_REGISRATION |  | int 0x965
FCodes.AMT_UPDATES |  | int 0x968
FCodes.CHAR_APPLY_CAT_TO_SEL |  | int 0xF3E
FCodes.CHAR_APPLY_TAG |  | int 0xC11
FCodes.CHAR_DESIGNKIT_APPLY |  | int 0xAAB
FCodes.CHAR_DESIGNKIT_NEWFORMAT |  | int 0xB01
FCodes.CHAR_DESIGNKIT_RESET |  | int 0xABB
FCodes.CHAR_DESIGNKIT_UPDATEALL |  | int 0xAAE
FCodes.CHAR_DESIGNKIT_UPDATEOPTIONS |  | int 0xB04
FCodes.CHAR_DESIGN_CAT |  | int 0xF4F
FCodes.CMD_OPEN_DITAMAP_COMPONENT |  | int 0xF14
FCodes.CONDTEXT_KIT_APPLY |  | int 0xB09
FCodes.CSR_BEFORE_ELEMENT |  | int 0x14B
FCodes.CSR_BOE |  | int 0x149
FCodes.CSR_BOL |  | int 0x105
FCodes.CSR_BOP |  | int 0x10B
FCodes.CSR_BOS |  | int 0x109
FCodes.CSR_BOT |  | int 0x110
FCodes.CSR_BOTR |  | int 0x10E
FCodes.CSR_BOW |  | int 0x107
FCodes.CSR_DOWN |  | int 0x102
FCodes.CSR_EOE |  | int 0x14A
FCodes.CSR_EOL |  | int 0x106
FCodes.CSR_EOP |  | int 0x10C
FCodes.CSR_EOS |  | int 0x10A
FCodes.CSR_EOW |  | int 0x108
FCodes.CSR_FIRST_COL |  | int 0x143
FCodes.CSR_HOME |  | int 0x100
FCodes.CSR_INTO_CHILD |  | int 0x14D
FCodes.CSR_LEFT |  | int 0x104
FCodes.CSR_NEXT_BOP |  | int 0x142
FCodes.CSR_NEXT_BOS |  | int 0x141
FCodes.CSR_NEXT_BOW |  | int 0x140
FCodes.CSR_NEXT_COL |  | int 0x144
FCodes.CSR_NEXT_ELEMENT |  | int 0x145
FCodes.CSR_PREV_ELEMENT |  | int 0x146
FCodes.CSR_PREV_EOS |  | int 0x937
FCodes.CSR_PREV_EOW |  | int 0x938
FCodes.CSR_RIGHT |  | int 0x103
FCodes.CSR_TOP |  | int 0x10F
FCodes.CSR_TOTR |  | int 0x10D
FCodes.CSR_UP |  | int 0x101
FCodes.DEL_BOL |  | int 0x119
FCodes.DEL_BOS |  | int 0x163
FCodes.DEL_BOW |  | int 0x114
FCodes.DEL_CHARBWD |  | int 0x112
FCodes.DEL_CHARFWD |  | int 0x113
FCodes.DEL_EOL |  | int 0x116
FCodes.DEL_EOS |  | int 0x117
FCodes.DEL_EOW |  | int 0x115
FCodes.DEL_NEXT_SS |  | int 0x162
FCodes.DEL_SEL |  | int 0x118
FCodes.DEL_WORD_END |  | int 0x161
FCodes.DEL_WORD_START |  | int 0x160
FCodes.ELEM_BAM |  | int 0xFDC
FCodes.ELEM_CHANGE_CAT_AT_SEL |  | int 0xA12
FCodes.ELEM_INSERT_CUSTOM_1 |  | int 0xA21
FCodes.ELEM_INSERT_CUSTOM_10 |  | int 0xA2A
FCodes.ELEM_INSERT_CUSTOM_2 |  | int 0xA22
FCodes.ELEM_INSERT_CUSTOM_3 |  | int 0xA23
FCodes.ELEM_INSERT_CUSTOM_4 |  | int 0xA24
FCodes.ELEM_INSERT_CUSTOM_5 |  | int 0xA25
FCodes.ELEM_INSERT_CUSTOM_6 |  | int 0xA26
FCodes.ELEM_INSERT_CUSTOM_7 |  | int 0xA27
FCodes.ELEM_INSERT_CUSTOM_8 |  | int 0xA28
FCodes.ELEM_INSERT_CUSTOM_9 |  | int 0xA29
FCodes.ELEM_INS_CAT_AT_SEL |  | int 0xA10
FCodes.ELEM_WRAP_CAT_AT_SEL |  | int 0xA11
FCodes.END_DIALOG |  | int 0xC200
FCodes.END_WINDOW |  | int 0xC500
FCodes.EXTEND_SEL |  | int (0x0002|0x0004|0x0008|0x0010|0x0800)
FCodes.FM_RPT_CMDS_BY_SHORTCUT |  | int 0xD01
FCodes.FM_RPT_CMDS_BY_TAG |  | int 0xD00
FCodes.FM_SEPARATOR |  | int 0xF12
FCodes.FM_TERMINATE |  | int 0xFFF
FCodes.FOCUS_INPUT_ATTREDITOR |  | int 0x62F
FCodes.FOCUS_INPUT_CELLFMT |  | int 0x62A
FCodes.FOCUS_INPUT_COND |  | int 0x629
FCodes.FOCUS_INPUT_CUSTRS |  | int 0x62B
FCodes.FOCUS_INPUT_DOC |  | int 0x620
FCodes.FOCUS_INPUT_ELEM_CTX |  | int 0xA32
FCodes.FOCUS_INPUT_FONTFMT |  | int 0x627
FCodes.FOCUS_INPUT_HYPERTEXT |  | int 0x624
FCodes.FOCUS_INPUT_MARKER |  | int 0x622
FCodes.FOCUS_INPUT_PGFFMT |  | int 0x626
FCodes.FOCUS_INPUT_SEARCH |  | int 0x621
FCodes.FOCUS_INPUT_SPELL |  | int 0x623
FCodes.FOCUS_INPUT_STRWIN |  | int 0x62D
FCodes.FOCUS_INPUT_TBLFMT |  | int 0x62C
FCodes.FOCUS_INPUT_VALIDATION |  | int 0x62E
FCodes.HIGH_CHAR |  | int 0x240
FCodes.HIGH_CHAR_NEXT |  | int 0x510
FCodes.HIGH_CHAR_PREV |  | int 0x410
FCodes.HIGH_CLEAR |  | int 0x247
FCodes.HIGH_COL_BOT |  | int 0x418
FCodes.HIGH_COL_TOP |  | int 0x417
FCodes.HIGH_ELEMENT |  | int 0x249
FCodes.HIGH_ELEMENT_NEXT |  | int 0x421
FCodes.HIGH_ELEMENT_PREV |  | int 0x420
FCodes.HIGH_FLOW |  | int 0x248
FCodes.HIGH_FLOW_BEG |  | int 0x419
FCodes.HIGH_FLOW_END |  | int 0x41A
FCodes.HIGH_HYPERTEXT |  | int 0x517
FCodes.HIGH_LINE |  | int 0x242
FCodes.HIGH_LINE_BEG |  | int 0x41B
FCodes.HIGH_LINE_DOWN |  | int 0x416
FCodes.HIGH_LINE_END |  | int 0x41C
FCodes.HIGH_LINE_NEXT |  | int 0x512
FCodes.HIGH_LINE_PREV |  | int 0x412
FCodes.HIGH_LINE_UP |  | int 0x415
FCodes.HIGH_PARENT |  | int 0x423
FCodes.HIGH_PGF |  | int 0x244
FCodes.HIGH_PGF_NEXT |  | int 0x514
FCodes.HIGH_PGF_PREV |  | int 0x414
FCodes.HIGH_SAMECB |  | int 0x515
FCodes.HIGH_SAMECOND |  | int 0x516
FCodes.HIGH_SENT |  | int 0x243
FCodes.HIGH_SENT_NEXT |  | int 0x513
FCodes.HIGH_SENT_PREV |  | int 0x413
FCodes.HIGH_SHL |  | int 0x245
FCodes.HIGH_SHR |  | int 0x246
FCodes.HIGH_SIBLINGS |  | int 0x422
FCodes.HIGH_WORD |  | int 0x241
FCodes.HIGH_WORD_NEXT |  | int 0x511
FCodes.HIGH_WORD_PREV |  | int 0x411
FCodes.INIT_DIALOG |  | int 0xD80
FCodes.INLINE_TYPEIN |  | int 0xDF3
FCodes.KBD_ABORT |  | int 0x250
FCodes.KBD_ABORT_DLGS |  | int 0x254
FCodes.KBD_ABOUTPRODUCT |  | int 0x305
FCodes.KBD_ACCEPTALLCHANGE |  | int 0x960
FCodes.KBD_ACCEPTCHANGE |  | int 0x958
FCodes.KBD_ACCEPTCHANGEANDNEXT |  | int 0x99B
FCodes.KBD_ACROBAT_SETUP |  | int 0x36C
FCodes.KBD_ACTIVATE_IN_PDF_BYDEFAULT |  | int 0x4FA
FCodes.KBD_ADDAUTOCORR |  | int 0x3C5
FCodes.KBD_ADDDOCDICT |  | int 0x3C4
FCodes.KBD_ADDMARKERTYPE |  | int 0x41D
FCodes.KBD_ADDPAGE |  | int 0x346
FCodes.KBD_ADDUSRDICT |  | int 0x3C3
FCodes.KBD_ALIGN |  | int 0x384
FCodes.KBD_ALIGN_BOTTOM |  | int 0x292
FCodes.KBD_ALIGN_MIDDLE |  | int 0x291
FCodes.KBD_ALIGN_TOP |  | int 0x290
FCodes.KBD_ALLCAP |  | int 0x33A
FCodes.KBD_ALLCAPH |  | int 0x369
FCodes.KBD_ALLLOWER |  | int 0x33B
FCodes.KBD_ALLLOWERH |  | int 0x36A
FCodes.KBD_ALLSELECT |  | int 0xF20
FCodes.KBD_ANCHOR |  | int 0x350
FCodes.KBD_ANTIPUTINLINE |  | int 0xF54
FCodes.KBD_API |  | int 0xDF0
FCodes.KBD_API_SHORTCUT |  | int 0xDF1
FCodes.KBD_ARCTOOL |  | int 0x3A4
FCodes.KBD_ASC_ADDDOCDICT |  | int 0x997
FCodes.KBD_ASC_ADDUSRDICT |  | int 0x996
FCodes.KBD_ASC_CORRECT |  | int 0x995
FCodes.KBD_ASC_ENABLE_AUTO_SPELL_CHECK |  | int 0x999
FCodes.KBD_ASSIGN_ELEMENT_ID |  | int 0xF16
FCodes.KBD_ATOMIZE_INSET |  | int 0xFAA
FCodes.KBD_ATTRCOND |  | int 0x954
FCodes.KBD_ATTREDITQUICK |  | int 0xF4D
FCodes.KBD_ATTRIBUTE_EDIT |  | int 0xFEC
FCodes.KBD_ATTR_CONFIG_FILE_MAKER |  | int 0xFFA
FCodes.KBD_ATTR_DISP_OPTS |  | int 0xFEE
FCodes.KBD_BACK |  | int 0x381
FCodes.KBD_BACKSTACK |  | int 0xEF0
FCodes.KBD_BACKTAB |  | int 0x220
FCodes.KBD_BANNER_TEXT |  | int 0x137
FCodes.KBD_BODYPAGE |  | int 0x342
FCodes.KBD_BOOKADDFILE |  | int 0x30A
FCodes.KBD_BOOKADDFOLDER |  | int 0x601
FCodes.KBD_BOOKADDGROUP |  | int 0x609
FCodes.KBD_BOOKCOMP_EXCLUDE |  | int 0x4E0
FCodes.KBD_BOOKCOMP_FILENAME |  | int 0x607
FCodes.KBD_BOOKCOMP_TEXT |  | int 0x608
FCodes.KBD_BOOKDISPLAYFILENAME |  | int 0x30D
FCodes.KBD_BOOKDISPLAYTEXT |  | int 0x30E
FCodes.KBD_BOOKEDITDEFINE |  | int 0x30B
FCodes.KBD_BOOKRENAMEFILE |  | int 0x30C
FCodes.KBD_BORDERS |  | int 0x361
FCodes.KBD_BROWSE_URL |  | int 0x9A0
FCodes.KBD_CACHE_STATS |  | int 0xF05
FCodes.KBD_CAPITAL |  | int 0x32B
FCodes.KBD_CAPTURE |  | int 0x251
FCodes.KBD_CAPTURE_LIVE_DIALOG |  | int 0xF78
FCodes.KBD_CBARPRO |  | int 0x334
FCodes.KBD_CELLFMTQUICK |  | int 0xF43
FCodes.KBD_CHANGEDICT |  | int 0x3C9
FCodes.KBD_CHANGEQUICK |  | int 0xF4C
FCodes.KBD_CHARFMT_DELETE |  | int 0xB07
FCodes.KBD_CHARFMT_DELETE_UNUSED |  | int 0xB14
FCodes.KBD_CHECKBATCH |  | int 0x3CE
FCodes.KBD_CHECKDOC |  | int 0x3C1
FCodes.KBD_CHECKPAGE |  | int 0x3CB
FCodes.KBD_CHECKSEL |  | int 0x3C0
FCodes.KBD_CLEAR |  | int 0x324
FCodes.KBD_CLEARAUTO |  | int 0x3C8
FCodes.KBD_CLOPWIN |  | int 0x392
FCodes.KBD_CLOSEWIN |  | int 0x390
FCodes.KBD_CLOSE_ATTREDITOR |  | int 0x68B
FCodes.KBD_CLOSE_CHARACTER_CATALOG |  | int 0xD22
FCodes.KBD_CLOSE_CHARACTER_DESIGNER |  | int 0xD29
FCodes.KBD_CLOSE_COMPONENTS |  | int 0x3EB
FCodes.KBD_CLOSE_COND |  | int 0x686
FCodes.KBD_CLOSE_CUSTRS |  | int 0x687
FCodes.KBD_CLOSE_ELEMENT_CATALOG |  | int 0xD26
FCodes.KBD_CLOSE_ELEM_CTX |  | int 0x68C
FCodes.KBD_CLOSE_EQUATIONS_PALETTE |  | int 0xD24
FCodes.KBD_CLOSE_FONTFMT |  | int 0x685
FCodes.KBD_CLOSE_HYPERTEXT |  | int 0x68D
FCodes.KBD_CLOSE_MARKER |  | int 0x682
FCodes.KBD_CLOSE_PARAGRAPH_CATALOG |  | int 0xD21
FCodes.KBD_CLOSE_PARAGRAPH_DESIGNER |  | int 0xD28
FCodes.KBD_CLOSE_PGFFMT |  | int 0x684
FCodes.KBD_CLOSE_SEARCH |  | int 0x681
FCodes.KBD_CLOSE_SPELL |  | int 0x683
FCodes.KBD_CLOSE_STRWIN |  | int 0x689
FCodes.KBD_CLOSE_TABLE_CATALOG |  | int 0xFBD
FCodes.KBD_CLOSE_TABLE_DESIGNER |  | int 0xD2A
FCodes.KBD_CLOSE_TBLFMT |  | int 0x688
FCodes.KBD_CLOSE_TOOLS_PALETTE |  | int 0xD23
FCodes.KBD_CLOSE_TOP_PALETTE |  | int 0xD20
FCodes.KBD_CLOSE_VALIDATION |  | int 0x68A
FCodes.KBD_CMS_CONNECTION_MGR |  | int 0x802
FCodes.KBD_CMS_UPLOAD_DOC_OR_BOOK |  | int 0x805
FCodes.KBD_COLLAPSE_ALL |  | int 0x3FA
FCodes.KBD_COLLAYOUT |  | int 0x348
FCodes.KBD_COLOR |  | int 0x39F
FCodes.KBD_COMBINED_FONTS |  | int 0x338
FCodes.KBD_COMPARE |  | int 0x31F
FCodes.KBD_COMPONENT_PROPERTIES |  | int 0x3EE
FCodes.KBD_CONDINDICATOR |  | int 0x953
FCodes.KBD_CONDINQUICK |  | int 0xF44
FCodes.KBD_CONDNOTINQUICK |  | int 0xF45
FCodes.KBD_CONDTEXT |  | int 0x357
FCodes.KBD_CONDTOGGLEOVERR |  | int 0x368
FCodes.KBD_CONDVISIBILITY |  | int 0x367
FCodes.KBD_CONDVISONLYQUICK |  | int 0xF47
FCodes.KBD_CONFIGURE_TC_COLOR |  | int 0x990
FCodes.KBD_CONNECT_TEXT_FRAME |  | int 0x35B
FCodes.KBD_CONSTRAIN |  | int 0x379
FCodes.KBD_CONTEXTMENU |  | int 0x914
FCodes.KBD_COPY |  | int 0x322
FCodes.KBD_COPYATTRS |  | int 0xF9F
FCodes.KBD_COPYCELLFMT |  | int 0xF9B
FCodes.KBD_COPYCOLW |  | int 0xF9C
FCodes.KBD_COPYCOND |  | int 0xF9D
FCodes.KBD_COPYFONT |  | int 0x325
FCodes.KBD_COPYPGF |  | int 0x326
FCodes.KBD_COPYRIGHT |  | int 0x504
FCodes.KBD_CORRECT |  | int 0x3C2
FCodes.KBD_COUNT_SBLOCKS |  | int 0x653
FCodes.KBD_CREATE_MULTIMEDIA_LINK |  | int 0x3E3
FCodes.KBD_CREATE_MULTIMEDIA_LINK_TBL |  | int 0x3E4
FCodes.KBD_CREATE_PUBLISHER |  | int 0x3D5
FCodes.KBD_CSHELPMODE |  | int 0x304
FCodes.KBD_CURTAIL |  | int 0x35D
FCodes.KBD_CUSTOMNEW |  | int 0x2FF
FCodes.KBD_CUST_TEXT_FRAME |  | int 0xA01
FCodes.KBD_CUT |  | int 0x321
FCodes.KBD_CUTBOTH |  | int 0xA04
FCodes.KBD_CUTHEAD |  | int 0x35C
FCodes.KBD_DASH0 |  | int 0x404
FCodes.KBD_DASH1 |  | int 0x405
FCodes.KBD_DASHOPTION |  | int 0x408
FCodes.KBD_DECDASH |  | int 0x407
FCodes.KBD_DECFILL |  | int 0x3B7
FCodes.KBD_DECPEN |  | int 0x3B3
FCodes.KBD_DECWIDTH |  | int 0x3AF
FCodes.KBD_DELDOCDICT |  | int 0x3C7
FCodes.KBD_DELETEMARKER |  | int 0x969
FCodes.KBD_DELETEPAGE |  | int 0x347
FCodes.KBD_DELETE_FILE |  | int 0x30F
FCodes.KBD_DELINKHOTSPOT |  | int 0x507
FCodes.KBD_DELMARKERTYPE |  | int 0x358
FCodes.KBD_DELUSRDICT |  | int 0x3C6
FCodes.KBD_DEREFREF |  | int 0xF08
FCodes.KBD_DFN_LIB_obsolete |  | int 0x501
FCodes.KBD_DFN_WEB_obsolete |  | int 0x500
FCodes.KBD_DISTRIBUTE |  | int 0x385
FCodes.KBD_DOCINFO |  | int 0x3DA
FCodes.KBD_DOC_REPORT |  | int 0xF10
FCodes.KBD_DONTHYPHEN |  | int 0x226
FCodes.KBD_DOUBLE_QUOTE |  | int 0x401
FCodes.KBD_DRE_MODE_M |  | int 0xF7C
FCodes.KBD_DRE_MODE_W |  | int 0xF7B
FCodes.KBD_DRE_MODE_X |  | int 0xF7A
FCodes.KBD_DSEXIT |  | int 0xF01
FCodes.KBD_DUMMY_FCODE |  | int 0xFFC
FCodes.KBD_DUMPHYPERTEXT |  | int 0xC20
FCodes.KBD_ECAPTURE |  | int 0x256
FCodes.KBD_EDITHOTSPOT |  | int 0x4FE
FCodes.KBD_EDITLINKS |  | int 0x912
FCodes.KBD_EDITMARKERTYPE |  | int 0x409
FCodes.KBD_EDITVARIABLE |  | int 0xA0C
FCodes.KBD_EDIT_MATHML_EQUATION |  | int 0x3E6
FCodes.KBD_ELEMENTWIN |  | int 0xF28
FCodes.KBD_ELEM_BORDER |  | int 0xFD2
FCodes.KBD_ELEM_CAT_OPTS |  | int 0xFD7
FCodes.KBD_ELEM_DEMOTE |  | int 0xFDF
FCodes.KBD_ELEM_MERGE_1ST |  | int 0xFD3
FCodes.KBD_ELEM_MERGE_LAST |  | int 0xFD4
FCodes.KBD_ELEM_PROMOTE |  | int 0xFDE
FCodes.KBD_ELEM_SPLIT |  | int 0xFD5
FCodes.KBD_ELEM_TAGS |  | int 0xFDD
FCodes.KBD_ELEM_TRANSPOSE_NEXT |  | int 0xFF5
FCodes.KBD_ELEM_TRANSPOSE_PREV |  | int 0xFF4
FCodes.KBD_ELEM_UNWRAP |  | int 0xFD6
FCodes.KBD_EMBEDDED00 |  | int 0x920
FCodes.KBD_EMBEDDED01 |  | int 0x921
FCodes.KBD_EMBEDDED02 |  | int 0x922
FCodes.KBD_EMBEDDED03 |  | int 0x923
FCodes.KBD_EMBEDDED04 |  | int 0x924
FCodes.KBD_EMBEDDED05 |  | int 0x925
FCodes.KBD_EMBEDDED06 |  | int 0x926
FCodes.KBD_EMBEDDED07 |  | int 0x927
FCodes.KBD_EMBEDDED08 |  | int 0x928
FCodes.KBD_EMBEDDED09 |  | int 0x92A
FCodes.KBD_EMBEDDED10 |  | int 0x92B
FCodes.KBD_EMBEDDED11 |  | int 0x92C
FCodes.KBD_EMBEDDED12 |  | int 0x92D
FCodes.KBD_EMBEDDED13 |  | int 0x92E
FCodes.KBD_EMBEDDED14 |  | int 0x92F
FCodes.KBD_EMBEDDED15 |  | int 0x930
FCodes.KBD_EMBEDDED16 |  | int 0x931
FCodes.KBD_EMBEDDED17 |  | int 0x932
FCodes.KBD_EMBEDDED18 |  | int 0x933
FCodes.KBD_EMBEDDED19 |  | int 0x934
FCodes.KBD_EMBEDDEDMAX |  | int 0x94F
FCodes.KBD_EMSPACE |  | int 0x22C
FCodes.KBD_ENSPACE |  | int 0x22D
FCodes.KBD_EQUATION |  | int 0x336
FCodes.KBD_EVACUATE |  | int 0xF60
FCodes.KBD_EXPAND_ALL |  | int 0x3FB
FCodes.KBD_EXPORT_DOCUMENT |  | int 0xC16
FCodes.KBD_EXPORT_GRAPHIC |  | int 0xC15
FCodes.KBD_EXPOSEWIN |  | int 0x395
FCodes.KBD_FB_EDIT_PREFS |  | int 0xFEF
FCodes.KBD_FILL0 |  | int 0x3B4
FCodes.KBD_FILL1 |  | int 0x3B5
FCodes.KBD_FINDNEXT |  | int 0x955
FCodes.KBD_FINDPREV |  | int 0x956
FCodes.KBD_FIRSTPAGE |  | int 0x340
FCodes.KBD_FIRSTTAB |  | int 0x222
FCodes.KBD_FLIPLR |  | int 0x371
FCodes.KBD_FLIPUD |  | int 0x370
FCodes.KBD_FMPIP |  | int 0x806
FCodes.KBD_FNEXT |  | int 0x231
FCodes.KBD_FONTDESIGN |  | int 0x330
FCodes.KBD_FONTPOD |  | int 0x966
FCodes.KBD_FONTQUICK |  | int 0xF40
FCodes.KBD_FONTREPLACEPOD |  | int 0x95C
FCodes.KBD_FONTWIN |  | int 0xF24
FCodes.KBD_FOOTNOTE |  | int 0x351
FCodes.KBD_FOOTNOTEPRO |  | int 0x335
FCodes.KBD_FPREV |  | int 0x230
FCodes.KBD_FRAMETOOL |  | int 0x3AA
FCodes.KBD_FREETOOL |  | int 0x3A9
FCodes.KBD_FREEZE |  | int 0x34B
FCodes.KBD_FRONT |  | int 0x380
FCodes.KBD_FULLRULERS |  | int 0x3BD
FCodes.KBD_GBL_END |  | int 0x1FF
FCodes.KBD_GBL_START |  | int 0x100
FCodes.KBD_GENERATE |  | int 0x3E1
FCodes.KBD_GETTRIGGER |  | int 0x253
FCodes.KBD_GOTOIP |  | int 0x96F
FCodes.KBD_GOTOLINEN |  | int 0x970
FCodes.KBD_GOTOPAGE |  | int 0x345
FCodes.KBD_GOTOPAGEN |  | int 0x96E
FCodes.KBD_GRAPHIC_SET_NAME |  | int 0x4FC
FCodes.KBD_GRAVITY |  | int 0x37B
FCodes.KBD_GRAVITY_0 |  | int 0x482
FCodes.KBD_GRAVITY_1 |  | int 0x483
FCodes.KBD_GRID |  | int 0x364
FCodes.KBD_GROUP |  | int 0x382
FCodes.KBD_HARDHYPHEN |  | int 0x227
FCodes.KBD_HARDRETURN |  | int 0x229
FCodes.KBD_HARDSPACE |  | int 0x228
FCodes.KBD_HEATREF |  | int 0xF09
FCodes.KBD_HELP |  | int 0x302
FCodes.KBD_HELP_INDEX |  | int 0x2A0
FCodes.KBD_HELP_KEYS |  | int 0x2A1
FCodes.KBD_HELP_ONLINEMANUALS |  | int 0x2A4
FCodes.KBD_HELP_OVERVIEW |  | int 0x2A3
FCodes.KBD_HELP_SAMPLES |  | int 0x2A2
FCodes.KBD_HELP_WEBWORKS |  | int 0x2A6
FCodes.KBD_HEROIC_OPEN |  | int 0x306
FCodes.KBD_HIDEWIN |  | int 0x396
FCodes.KBD_HIDE_BORDERS |  | int 0x4F1
FCodes.KBD_HIDE_COND_IND |  | int 0x4F9
FCodes.KBD_HIDE_ELEM_BORDER |  | int 0x4F6
FCodes.KBD_HIDE_GRAPHICS |  | int 0x4F8
FCodes.KBD_HIDE_GRID |  | int 0x4F4
FCodes.KBD_HIDE_HOTSPOTINDICATORS |  | int 0x50A
FCodes.KBD_HIDE_LINK_BOUNDARIES |  | int 0x4F5
FCodes.KBD_HIDE_RULERS |  | int 0x4F3
FCodes.KBD_HIDE_SYMBOLS |  | int 0x4F2
FCodes.KBD_HISHWIN |  | int 0x397
FCodes.KBD_HIST |  | int 0x936
FCodes.KBD_HOTSPOT |  | int 0x4FD
FCodes.KBD_HOTSPOTINDICATORS |  | int 0x508
FCodes.KBD_HOTSPOTSPOD |  | int 0x4FF
FCodes.KBD_HSCROLL |  | int 0xF38
FCodes.KBD_HYPERTEXT |  | int 0x359
FCodes.KBD_HYPHENATE |  | int 0x3CD
FCodes.KBD_HYPRTXT_SHTCUT |  | int 0x41E
FCodes.KBD_IMPORT |  | int 0x314
FCodes.KBD_INCDASH |  | int 0x406
FCodes.KBD_INCFILL |  | int 0x3B6
FCodes.KBD_INCPEN |  | int 0x3B2
FCodes.KBD_INCWIDTH |  | int 0x3AE
FCodes.KBD_INDEX_AUTHOR |  | int 0x2C1
FCodes.KBD_INDEX_MARKER |  | int 0x2C3
FCodes.KBD_INDEX_REFERENCES |  | int 0x2C4
FCodes.KBD_INDEX_STANDARD |  | int 0x2C0
FCodes.KBD_INDEX_SUBJECT |  | int 0x2C2
FCodes.KBD_INFO |  | int 0x303
FCodes.KBD_INITCAP |  | int 0x33C
FCodes.KBD_INITCAPH |  | int 0x36B
FCodes.KBD_INLINE_ATTREDTR |  | int 0x29B
FCodes.KBD_INPUT |  | int 1
FCodes.KBD_INSERTOBJECT |  | int 0x913
FCodes.KBD_INSERTQUICK |  | int 0xF48
FCodes.KBD_INSET |  | int 0x354
FCodes.KBD_INSETPOD |  | int 0x994
FCodes.KBD_Item1stLogical |  | int 0xD60
FCodes.KBD_ItemDown |  | int 0xD68
FCodes.KBD_ItemFirstFocus |  | int 0xD6A
FCodes.KBD_ItemLeft |  | int 0xD65
FCodes.KBD_ItemNextLogical |  | int 0xD61
FCodes.KBD_ItemNextPhysical |  | int 0xD63
FCodes.KBD_ItemPrevLogical |  | int 0xD62
FCodes.KBD_ItemPrevPhysical |  | int 0xD64
FCodes.KBD_ItemRight |  | int 0xD66
FCodes.KBD_ItemSelect |  | int 0xD69
FCodes.KBD_ItemUp |  | int 0xD67
FCodes.KBD_JOINCURVES |  | int 0x377
FCodes.KBD_KBMACRO |  | int 0x317
FCodes.KBD_KEEPTOOL |  | int 0x37C
FCodes.KBD_KERNDOWN |  | int 0x11B
FCodes.KBD_KERNDOWN6 |  | int 0x122
FCodes.KBD_KERNHOME |  | int 0x11E
FCodes.KBD_KERNLEFT |  | int 0x11C
FCodes.KBD_KERNLEFT6 |  | int 0x123
FCodes.KBD_KERNRIGHT |  | int 0x11D
FCodes.KBD_KERNRIGHT6 |  | int 0x124
FCodes.KBD_KERNUP |  | int 0x11A
FCodes.KBD_KERNUP6 |  | int 0x121
FCodes.KBD_LASTPAGE |  | int 0x341
FCodes.KBD_LASTTOOL |  | int 0x3AB
FCodes.KBD_LGEQN |  | int 0xF52
FCodes.KBD_LINELAYOUT |  | int 0x332
FCodes.KBD_LINENUMPRO |  | int 0x673
FCodes.KBD_LINENUMTOGGLE |  | int 0x674
FCodes.KBD_LINETOOL |  | int 0x3A0
FCodes.KBD_LINK_BOUNDARIES |  | int 0x3D7
FCodes.KBD_LIST_FIGURE |  | int 0x2B1
FCodes.KBD_LIST_MARKER |  | int 0x2B5
FCodes.KBD_LIST_MARKER_ALPHA |  | int 0x2B6
FCodes.KBD_LIST_PGF |  | int 0x2B3
FCodes.KBD_LIST_PGF_ALPHA |  | int 0x2B4
FCodes.KBD_LIST_REFERENCES |  | int 0x2B7
FCodes.KBD_LIST_TABLE |  | int 0x2B2
FCodes.KBD_MANCOND |  | int 0x952
FCodes.KBD_MARKERS |  | int 0x355
FCodes.KBD_MARKERSPOD |  | int 0x96A
FCodes.KBD_MASTERPAGE |  | int 0x343
FCodes.KBD_MATHML_EQUATION |  | int 0x3E5
FCodes.KBD_MATHWIN |  | int 0xF26
FCodes.KBD_MATH_BASE |  | int 0x1000
FCodes.KBD_MAXIMIZE |  | int 0x910
FCodes.KBD_MEDEQN |  | int 0xF51
FCodes.KBD_MEMFAIL |  | int 0xF02
FCodes.KBD_MEM_STATS |  | int 0xF04
FCodes.KBD_MENUBARFOCUS |  | int 0x3F0
FCodes.KBD_MENUCOMPLETE |  | int 0x33D
FCodes.KBD_MENUCUSTOM |  | int 0x33F
FCodes.KBD_MENUMODIFY |  | int 0x3D9
FCodes.KBD_MENUQUICK |  | int 0x33E
FCodes.KBD_MENURESET |  | int 0x3D8
FCodes.KBD_MINIMIZE |  | int 0x90F
FCodes.KBD_MODE_ROTATE_TOOL |  | int 0xFAD
FCodes.KBD_MOVEWIN |  | int 0x393
FCodes.KBD_MOVE_DOWN |  | int 0x70B
FCodes.KBD_MOVE_LEFT |  | int 0x70C
FCodes.KBD_MOVE_RIGHT |  | int 0x70D
FCodes.KBD_MOVE_UP |  | int 0x70A
FCodes.KBD_MUTATE |  | int 0x37F
FCodes.KBD_NAMESPACES |  | int 0xFF8
FCodes.KBD_NEW |  | int 0x300
FCodes.KBD_NEWAFRAME |  | int 0x96D
FCodes.KBD_NEWBOOK |  | int 0x308
FCodes.KBD_NEWHYPERTEXT |  | int 0x35E
FCodes.KBD_NEWMARKER |  | int 0x356
FCodes.KBD_NEWMASTER |  | int 0xA0A
FCodes.KBD_NEWVAR |  | int 0xF06
FCodes.KBD_NEW_XML |  | int 0x803
FCodes.KBD_NEXTPAGE |  | int 0x34D
FCodes.KBD_NOCHANGEDB |  | int 0xF4A
FCodes.KBD_NORMALIZE_TAGS |  | int 0xA33
FCodes.KBD_NUMBERING |  | int 0x333
FCodes.KBD_NUMLOCK |  | int 0x170
FCodes.KBD_NUMSPACE |  | int 0x22A
FCodes.KBD_OBALIGN_BOTTOM |  | int 0x12B
FCodes.KBD_OBALIGN_CENTER |  | int 0x12C
FCodes.KBD_OBALIGN_LEFT |  | int 0x12D
FCodes.KBD_OBALIGN_MIDDLE |  | int 0x12A
FCodes.KBD_OBALIGN_RIGHT |  | int 0x12E
FCodes.KBD_OBALIGN_TOP |  | int 0x129
FCodes.KBD_OBJDOWN |  | int 0x126
FCodes.KBD_OBJLEFT |  | int 0x127
FCodes.KBD_OBJPROPS |  | int 0x387
FCodes.KBD_OBJRIGHT |  | int 0x128
FCodes.KBD_OBJSELECT |  | int 0xF21
FCodes.KBD_OBJSELECT_NOPREF |  | int 0xF2A
FCodes.KBD_OBJUP |  | int 0x125
FCodes.KBD_OPEN |  | int 0x301
FCodes.KBD_OPENALL |  | int 0x31A
FCodes.KBD_OPENLINE |  | int 0x22E
FCodes.KBD_OPENWIN |  | int 0x391
FCodes.KBD_OPEN_COMPONENTS |  | int 0x3EA
FCodes.KBD_OPEN_IN_POPUP_WIN_IN_PDF |  | int 0x4FB
FCodes.KBD_OPEN_REPOSITORY |  | int 0x801
FCodes.KBD_OPTIONS |  | int 0x360
FCodes.KBD_OVALTOOL |  | int 0x3A6
FCodes.KBD_OVERPRINT |  | int 0x3D2
FCodes.KBD_OVERPRINT_NONE |  | int 0x3D4
FCodes.KBD_PAGEBACK |  | int 0x34A
FCodes.KBD_PAGEBREAK |  | int 0x32F
FCodes.KBD_PAGELAYOUT |  | int 0x503
FCodes.KBD_PAGESETUP |  | int 0x319
FCodes.KBD_PAGESIZE |  | int 0x349
FCodes.KBD_PAGESTATUS |  | int 0xF37
FCodes.KBD_PAGEUPDATE |  | int 0xA00
FCodes.KBD_PAGINATION |  | int 0xA40
FCodes.KBD_PASTE |  | int 0x323
FCodes.KBD_PASTESPECIAL |  | int 0xD10
FCodes.KBD_PASTE_RTF |  | int 0x502
FCodes.KBD_PAUSE_0x01 |  | int 0x632
FCodes.KBD_PAUSE_0x10 |  | int 0x631
FCodes.KBD_PAUSE_1x00 |  | int 0x630
FCodes.KBD_PEN0 |  | int 0x3B0
FCodes.KBD_PEN1 |  | int 0x3B1
FCodes.KBD_PGFDESIGN |  | int 0x331
FCodes.KBD_PGFFMT_DELETE |  | int 0xB06
FCodes.KBD_PGFFMT_DELETE_UNUSED |  | int 0xB13
FCodes.KBD_PGFQUICK |  | int 0xF41
FCodes.KBD_PGFWIN |  | int 0xF23
FCodes.KBD_PICKOBJPROPS |  | int 0x388
FCodes.KBD_PODLOCATION |  | int 0x31E
FCodes.KBD_POLYGTOOL |  | int 0x3A2
FCodes.KBD_POLYLTOOL |  | int 0x3A3
FCodes.KBD_POPUP_MENU |  | int 0x39D
FCodes.KBD_PREVIEWFBA |  | int 0xB16
FCodes.KBD_PREVIEW_ACCEPTALL |  | int 0x962
FCodes.KBD_PREVIEW_OFF |  | int 0x964
FCodes.KBD_PREVIEW_REJECTALL |  | int 0x963
FCodes.KBD_PREVPAGE |  | int 0x34C
FCodes.KBD_PRINT |  | int 0x313
FCodes.KBD_PRINTSETUP |  | int 0x90A
FCodes.KBD_PRINT_COMPONENTS |  | int 0x3EC
FCodes.KBD_PURIFY_ALL_LEAKS |  | int 0x651
FCodes.KBD_PURIFY_CLEAR_LEAKS |  | int 0x652
FCodes.KBD_PURIFY_NEW_LEAKS |  | int 0x650
FCodes.KBD_PUTINLINE |  | int 0xF53
FCodes.KBD_QUIETCLOSEWIN |  | int 0x39C
FCodes.KBD_QUITALL |  | int 0x31B
FCodes.KBD_QUITWIN |  | int 0x399
FCodes.KBD_RANDF |  | int 0x234
FCodes.KBD_RECORD |  | int 0x252
FCodes.KBD_RECTTOOL |  | int 0x3A1
FCodes.KBD_REDO |  | int 0x935
FCodes.KBD_REFERENCE |  | int 0x352
FCodes.KBD_REFORMATDOC |  | int 0x3CF
FCodes.KBD_REFPAGE |  | int 0x344
FCodes.KBD_REFRESHWIN |  | int 0x398
FCodes.KBD_REFRESH_DITAMAP_RMVIEW |  | int 0x807
FCodes.KBD_REJECTALLCHANGE |  | int 0x961
FCodes.KBD_REJECTCHANGE |  | int 0x959
FCodes.KBD_REJECTCHANGEANDNEXT |  | int 0x99C
FCodes.KBD_REMOVEPOSTER |  | int 0x3DE
FCodes.KBD_REMOVE_STRUCT |  | int 0xFF0
FCodes.KBD_RENAMEFRAME |  | int 0xF3B
FCodes.KBD_RENAMEMARKERTYPE |  | int 0x35F
FCodes.KBD_RENAMEORPLAIN |  | int 0x900
FCodes.KBD_RENAMEPAGE |  | int 0xF3A
FCodes.KBD_REORDERMASTER |  | int 0xA0B
FCodes.KBD_REPEAT |  | int 0x939
FCodes.KBD_REPEATNEW |  | int 0x31D
FCodes.KBD_REROTATE |  | int 0x38E
FCodes.KBD_RESETDB |  | int 0xF4B
FCodes.KBD_RESHAPE |  | int 0x376
FCodes.KBD_RESIZEBOX |  | int 0xF25
FCodes.KBD_RESIZEBOXM |  | int 0xF27
FCodes.KBD_RESIZELOCK |  | int 0x39A
FCodes.KBD_RESIZEUNLOCK |  | int 0x39B
FCodes.KBD_RESTORE |  | int 0x911
FCodes.KBD_RESTOREFONT |  | int 0x505
FCodes.KBD_RESTORE_SESSION |  | int 0xF17
FCodes.KBD_RETURN |  | int 0x22F
FCodes.KBD_REVERT |  | int 0x312
FCodes.KBD_REWRAP_INLINE_MATH |  | int 0xFAC
FCodes.KBD_RGLOBAL |  | int 0x233
FCodes.KBD_RM_MODE |  | int 0xF79
FCodes.KBD_RONCE |  | int 0x232
FCodes.KBD_ROTATE |  | int 0x38B
FCodes.KBD_ROTATE_AGAIN |  | int 0x38C
FCodes.KBD_ROTATE_CCW |  | int 0x372
FCodes.KBD_ROTATE_CCW_SMALL |  | int 0x38A
FCodes.KBD_ROTATE_CW |  | int 0x386
FCodes.KBD_ROTATE_CW_SMALL |  | int 0x389
FCodes.KBD_ROTATE_NATURAL |  | int 0x38D
FCodes.KBD_ROTATE_RESET0 |  | int 0x38F
FCodes.KBD_ROTPAGE_MINUS |  | int 0x34F
FCodes.KBD_ROTPAGE_NORM |  | int 0xA05
FCodes.KBD_ROTPAGE_PLUS |  | int 0x34E
FCodes.KBD_ROT_MINUS |  | int 0x386
FCodes.KBD_ROT_PLUS |  | int 0x372
FCodes.KBD_ROUNDRECT |  | int 0x3A5
FCodes.KBD_RUBIPROPS |  | int 0x3DD
FCodes.KBD_RULERS |  | int 0x363
FCodes.KBD_RUN_BBOX |  | int 0x669
FCodes.KBD_RUN_CONTOUR |  | int 0x668
FCodes.KBD_RUN_GAP |  | int 0x671
FCodes.KBD_RUN_OFF |  | int 0x670
FCodes.KBD_RUN_PROPS |  | int 0x667
FCodes.KBD_SAVE |  | int 0x310
FCodes.KBD_SAVEALL |  | int 0x31C
FCodes.KBD_SAVEAS |  | int 0x311
FCodes.KBD_SAVEASDBRE |  | int 0xF70
FCodes.KBD_SAVEASPDF |  | int 0x950
FCodes.KBD_SAVEASPDFREVIEW |  | int 0x95A
FCodes.KBD_SAVEASPDFREVIEW2 |  | int 0x95B
FCodes.KBD_SAVEASPDFSHARE |  | int 0x95F
FCodes.KBD_SAVEASPDFUBIQ |  | int 0x95E
FCodes.KBD_SAVEASXML |  | int 0x951
FCodes.KBD_SAVEDBRE |  | int 0xF77
FCodes.KBD_SAVEFMX |  | int 0xF76
FCodes.KBD_SAVEMETA |  | int 0xF03
FCodes.KBD_SAVESAS |  | int 0xF74
FCodes.KBD_SAVE_COMPONENTS |  | int 0x3ED
FCodes.KBD_SCALE |  | int 0x373
FCodes.KBD_SCREENMODE_FULLSCREEN |  | int 0x97B
FCodes.KBD_SCREENMODE_FULLSCREEN_UI |  | int 0x97A
FCodes.KBD_SCREENMODE_STANDARD |  | int 0x979
FCodes.KBD_SCREENMODE_TOGGLE |  | int 0x978
FCodes.KBD_SEARCH |  | int 0x329
FCodes.KBD_SEARCHREFS |  | int 0xB17
FCodes.KBD_SELECTALL |  | int 0x327
FCodes.KBD_SELECT_CHAPTER_COMPONENTS |  | int 0x9D3
FCodes.KBD_SELECT_EXCLUDED_FILE |  | int 0x9D1
FCodes.KBD_SELECT_FM_FILES |  | int 0x315
FCodes.KBD_SELECT_FM_XMLAUTHOR_FILES |  | int 0xA49
FCodes.KBD_SELECT_GENERATED_FILES |  | int 0x32D
FCodes.KBD_SELECT_NONEXCLUDED_FILE |  | int 0x9D2
FCodes.KBD_SELECT_NON_GENERATED_FILES |  | int 0x32E
FCodes.KBD_SELECT_PRINTABLE_FILES |  | int 0x9E2
FCodes.KBD_SELECT_SECTION_COMPONENTS |  | int 0x9D4
FCodes.KBD_SELECT_SUBSECTION_COMPONENTS |  | int 0x9D5
FCodes.KBD_SEPARATIONS |  | int 0x365
FCodes.KBD_SESSION |  | int 0x318
FCodes.KBD_SETALIGN_PROPS |  | int 0x992
FCodes.KBD_SETCAP |  | int 0x3BB
FCodes.KBD_SETCAP_0 |  | int 0x460
FCodes.KBD_SETCAP_1 |  | int 0x461
FCodes.KBD_SETCAP_2 |  | int 0x462
FCodes.KBD_SETCAP_3 |  | int 0x463
FCodes.KBD_SETCAP_OPTION |  | int 0x46F
FCodes.KBD_SETDASH |  | int 0x403
FCodes.KBD_SETDASH_0 |  | int 0x470
FCodes.KBD_SETDASH_1 |  | int 0x471
FCodes.KBD_SETDASH_2 |  | int 0x472
FCodes.KBD_SETDASH_3 |  | int 0x473
FCodes.KBD_SETDASH_4 |  | int 0x474
FCodes.KBD_SETDASH_5 |  | int 0x475
FCodes.KBD_SETDASH_6 |  | int 0x476
FCodes.KBD_SETDASH_7 |  | int 0x477
FCodes.KBD_SETDASH_8 |  | int 0x478
FCodes.KBD_SETDASH_OPTION |  | int 0x47F
FCodes.KBD_SETDISTRIBUTE_PROPS |  | int 0x993
FCodes.KBD_SETELCATALL |  | int 0xFDB
FCodes.KBD_SETELCATCHILD |  | int 0xFDA
FCodes.KBD_SETELCATFREQ |  | int 0xFF7
FCodes.KBD_SETELCATLOOSE |  | int 0xFD9
FCodes.KBD_SETELCATSTRICT |  | int 0xFD8
FCodes.KBD_SETFILL |  | int 0x3B8
FCodes.KBD_SETFILL_0 |  | int 0x430
FCodes.KBD_SETFILL_1 |  | int 0x431
FCodes.KBD_SETFILL_2 |  | int 0x432
FCodes.KBD_SETFILL_3 |  | int 0x433
FCodes.KBD_SETFILL_4 |  | int 0x434
FCodes.KBD_SETFILL_5 |  | int 0x435
FCodes.KBD_SETFILL_6 |  | int 0x436
FCodes.KBD_SETFILL_7 |  | int 0x437
FCodes.KBD_SETFILL_8 |  | int 0x438
FCodes.KBD_SETFILL_9 |  | int 0x439
FCodes.KBD_SETFILL_A |  | int 0x43A
FCodes.KBD_SETFILL_B |  | int 0x43B
FCodes.KBD_SETFILL_C |  | int 0x43C
FCodes.KBD_SETFILL_D |  | int 0x43D
FCodes.KBD_SETFILL_E |  | int 0x43E
FCodes.KBD_SETFILL_F |  | int 0x43F
FCodes.KBD_SETFROMCOLOR |  | int 0x48C
FCodes.KBD_SETKNOCKOUT |  | int 0x48A
FCodes.KBD_SETOVERPRINT |  | int 0x48B
FCodes.KBD_SETPEN |  | int 0x3B9
FCodes.KBD_SETPEN_0 |  | int 0x440
FCodes.KBD_SETPEN_1 |  | int 0x441
FCodes.KBD_SETPEN_2 |  | int 0x442
FCodes.KBD_SETPEN_3 |  | int 0x443
FCodes.KBD_SETPEN_4 |  | int 0x444
FCodes.KBD_SETPEN_5 |  | int 0x445
FCodes.KBD_SETPEN_6 |  | int 0x446
FCodes.KBD_SETPEN_7 |  | int 0x447
FCodes.KBD_SETPEN_8 |  | int 0x448
FCodes.KBD_SETPEN_9 |  | int 0x449
FCodes.KBD_SETPEN_A |  | int 0x44A
FCodes.KBD_SETPEN_B |  | int 0x44B
FCodes.KBD_SETPEN_C |  | int 0x44C
FCodes.KBD_SETPEN_D |  | int 0x44D
FCodes.KBD_SETPEN_E |  | int 0x44E
FCodes.KBD_SETPEN_F |  | int 0x44F
FCodes.KBD_SETPOSTER |  | int 0x3DB
FCodes.KBD_SETRUN_PROPS |  | int 0x96C
FCodes.KBD_SETSEARCH |  | int 0x235
FCodes.KBD_SETSEP |  | int 0x3BC
FCodes.KBD_SETSEP_ALL |  | int 0x3BF
FCodes.KBD_SETSEP_KEEP |  | int 0x3BE
FCodes.KBD_SETSEP_RESET_TINT_OVERPRINT |  | int 0x3D1
FCodes.KBD_SETSIDES |  | int 0x378
FCodes.KBD_SETSOLID |  | int 0x402
FCodes.KBD_SETTINT |  | int 0x48D
FCodes.KBD_SETWIDTH |  | int 0x3BA
FCodes.KBD_SETWIDTH_0 |  | int 0x450
FCodes.KBD_SETWIDTH_1 |  | int 0x451
FCodes.KBD_SETWIDTH_2 |  | int 0x452
FCodes.KBD_SETWIDTH_3 |  | int 0x453
FCodes.KBD_SETWIDTH_OPTION |  | int 0x45F
FCodes.KBD_SETWIDTH_SLIDE |  | int 0x45E
FCodes.KBD_SET_TEXTFRAME_GRID |  | int 0x666
FCodes.KBD_SHFTSPACE |  | int 0x221
FCodes.KBD_SHOWFILELISTPOD |  | int 0xA41
FCodes.KBD_SHOWNEXT |  | int 0x971
FCodes.KBD_SHOWPREV |  | int 0x972
FCodes.KBD_SHOW_BORDERS |  | int 0x3F1
FCodes.KBD_SHOW_COND_IND |  | int 0x3F9
FCodes.KBD_SHOW_ELEM_BORDER |  | int 0x3F6
FCodes.KBD_SHOW_ELEM_CTX |  | int 0xA31
FCodes.KBD_SHOW_ELEM_TAGS |  | int 0x3F7
FCodes.KBD_SHOW_GRAPHICS |  | int 0x3F8
FCodes.KBD_SHOW_GRID |  | int 0x3F4
FCodes.KBD_SHOW_HOTSPOTINDICATORS |  | int 0x509
FCodes.KBD_SHOW_LINK_BOUNDARIES |  | int 0x3F5
FCodes.KBD_SHOW_RULERS |  | int 0x3F3
FCodes.KBD_SHOW_SYMBOLS |  | int 0x3F2
FCodes.KBD_SILENT_OPEN |  | int 0x307
FCodes.KBD_SINGLE_QUOTE |  | int 0x400
FCodes.KBD_SLOW_0x00 |  | int 0x633
FCodes.KBD_SLOW_0x01 |  | int 0x636
FCodes.KBD_SLOW_0x10 |  | int 0x635
FCodes.KBD_SLOW_1x00 |  | int 0x634
FCodes.KBD_SMALLTOOLWIN |  | int 0xF29
FCodes.KBD_SMEQN |  | int 0xF50
FCodes.KBD_SMOOTH |  | int 0x374
FCodes.KBD_SNAP |  | int 0x37A
FCodes.KBD_SNAP_0 |  | int 0x480
FCodes.KBD_SNAP_1 |  | int 0x481
FCodes.KBD_SOFTHYPHEN |  | int 0x225
FCodes.KBD_SPELLING |  | int 0x32A
FCodes.KBD_SPELLRESET |  | int 0x3CA
FCodes.KBD_SPLIT |  | int 0x35A
FCodes.KBD_SPLITL |  | int 0xA03
FCodes.KBD_SPLITR |  | int 0xA02
FCodes.KBD_SPOPTIONS |  | int 0x3CC
FCodes.KBD_STRIP_FLOWSTRUCTURE |  | int 0xA30
FCodes.KBD_STRWIN |  | int 0xFD1
FCodes.KBD_STRWIN_LEFTANCHOR |  | int 0x3DF
FCodes.KBD_STUFF |  | int 0x328
FCodes.KBD_STUFF_ITEM |  | int 0xF73
FCodes.KBD_STYLEFMT_DELETE |  | int 0xBB0
FCodes.KBD_STYLEFMT_DELETE_UNUSED |  | int 0xB10
FCodes.KBD_STYLEQUICK |  | int 0xBB3
FCodes.KBD_STYLE_CATALOG |  | int 0xBB1
FCodes.KBD_STYLE_DESIGNER |  | int 0xBB2
FCodes.KBD_SUBSCRIBE_TO |  | int 0x3D6
FCodes.KBD_SWAP_RED_BLUE |  | int 0xFAB
FCodes.KBD_SYMBOLS |  | int 0x362
FCodes.KBD_SYMFONT |  | int 0x506
FCodes.KBD_TAB |  | int 0x219
FCodes.KBD_TABLEWIN |  | int 0xFBB
FCodes.KBD_TABLE_ADDRC |  | int 0xF87
FCodes.KBD_TABLE_CELLFMT |  | int 0xF84
FCodes.KBD_TABLE_CONVERT |  | int 0xF8A
FCodes.KBD_TABLE_CUSTRS |  | int 0xF86
FCodes.KBD_TABLE_DEBUG |  | int 0xF8B
FCodes.KBD_TABLE_EXIT_IP |  | int 0xFC0
FCodes.KBD_TABLE_FORMAT |  | int 0xF81
FCodes.KBD_TABLE_INS |  | int 0xF80
FCodes.KBD_TABLE_RESIZECOL |  | int 0xF88
FCodes.KBD_TABLE_ROWFMT |  | int 0xF85
FCodes.KBD_TABLE_RULES |  | int 0xF8C
FCodes.KBD_TABLE_STRADDLE |  | int 0xF89
FCodes.KBD_TABLE_TAB |  | int 0x223
FCodes.KBD_TABLE_VARS |  | int 0xF8D
FCodes.KBD_TAB_CENTER |  | int 0x907
FCodes.KBD_TAB_DECIMAL |  | int 0x909
FCodes.KBD_TAB_LEFT |  | int 0x906
FCodes.KBD_TAB_RIGHT |  | int 0x908
FCodes.KBD_TAGSTATUS |  | int 0xF36
FCodes.KBD_TBLFMT_DELETE |  | int 0xB08
FCodes.KBD_TBLFMT_DELETE_UNUSED |  | int 0xB15
FCodes.KBD_TBLIP_ABOVE |  | int 0xFB3
FCodes.KBD_TBLIP_BELOW |  | int 0xFB4
FCodes.KBD_TBLIP_BOTTOM |  | int 0xFBA
FCodes.KBD_TBLIP_LEFT |  | int 0xFB2
FCodes.KBD_TBLIP_LEFTMOST |  | int 0xFB5
FCodes.KBD_TBLIP_NEXT |  | int 0xFB7
FCodes.KBD_TBLIP_PREV |  | int 0xFB8
FCodes.KBD_TBLIP_RIGHT |  | int 0xFB1
FCodes.KBD_TBLIP_RIGHTMOST |  | int 0xFB6
FCodes.KBD_TBLIP_TOP |  | int 0xFB9
FCodes.KBD_TBLIP_TOPLEFT |  | int 0xFB0
FCodes.KBD_TBLSEL_CELL |  | int 0xFA0
FCodes.KBD_TBLSEL_CELLTEXT |  | int 0xFA4
FCodes.KBD_TBLSEL_COL |  | int 0xFA2
FCodes.KBD_TBLSEL_COLBODY |  | int 0xFA5
FCodes.KBD_TBLSEL_ROW |  | int 0xFA1
FCodes.KBD_TBLSEL_TABLE |  | int 0xFA3
FCodes.KBD_TBL_DLG_ADD_ABOVE |  | int 0xF92
FCodes.KBD_TBL_DLG_ADD_BELOW |  | int 0xF93
FCodes.KBD_TBL_DLG_ADD_LEFT |  | int 0xF94
FCodes.KBD_TBL_DLG_ADD_RIGHT |  | int 0xF95
FCodes.KBD_TBL_DLG_CLEAR_EMPTY |  | int 0xF96
FCodes.KBD_TBL_DLG_CLEAR_X |  | int 0xF97
FCodes.KBD_TBL_DLG_PASTE_AFTER |  | int 0xF9A
FCodes.KBD_TBL_DLG_PASTE_BEFORE |  | int 0xF99
FCodes.KBD_TBL_DLG_PASTE_REPL |  | int 0xF98
FCodes.KBD_TBL_DLG_SHRINKWRAP |  | int 0xFD0
FCodes.KBD_TBL_DLG_UNIFY_CF |  | int 0xF91
FCodes.KBD_TBL_DLG_UNIFY_TF |  | int 0xF90
FCodes.KBD_TC_SEARCH_BOOK |  | int 0x134
FCodes.KBD_TC_SEARCH_DITAMAP |  | int 0x135
FCodes.KBD_TC_SEARCH_DOC |  | int 0x133
FCodes.KBD_TC_SEARCH_SEL |  | int 0x136
FCodes.KBD_TC_USER_NAME |  | int 0x991
FCodes.KBD_TEST_MODAL |  | int 0xF71
FCodes.KBD_TEST_MODELESS |  | int 0xF72
FCodes.KBD_TEST_PRINTDBRE |  | int 0xF75
FCodes.KBD_TEXTCOLPRO |  | int 0x339
FCodes.KBD_TEXTLTOOL |  | int 0x3A7
FCodes.KBD_TEXTRTOOL |  | int 0x3A8
FCodes.KBD_TEXT_OPTIONS |  | int 0x337
FCodes.KBD_THESAURUS |  | int 0x3D0
FCodes.KBD_THESAURUS_REPLACE |  | int 0x3D3
FCodes.KBD_THINSPACE |  | int 0x22B
FCodes.KBD_TOC |  | int 0x2B0
FCodes.KBD_TOGGLEDRAW |  | int 0x366
FCodes.KBD_TOGGLE_COLLAPSE |  | int 0xFF2
FCodes.KBD_TOGGLE_COLLAPSE_ALL |  | int 0xFF3
FCodes.KBD_TOGGLE_COLLAPSE_CHILDREN |  | int 0xA0D
FCodes.KBD_TOGGLE_INCLUSION |  | int 0xFF1
FCodes.KBD_TOGGLE_STRUCT_AND_DOCWIN |  | int 0xFF9
FCodes.KBD_TOOLBAR_BASE |  | int 0x98F
FCodes.KBD_TOOLBAR_HIDEALL |  | int 0x98A
FCodes.KBD_TOOLBAR_SHOWALL |  | int 0x989
FCodes.KBD_TOOLWIN |  | int 0xF22
FCodes.KBD_TRACKCHANGE |  | int 0x957
FCodes.KBD_TRACKCHANGEDISABLE |  | int 0x95D
FCodes.KBD_UIALERTSTRINGS_PREF |  | int 0x981
FCodes.KBD_UI_PREFERENCE |  | int 0x980
FCodes.KBD_UNCOND |  | int 0xF46
FCodes.KBD_UNDO |  | int 0x320
FCodes.KBD_UNGROUP |  | int 0x383
FCodes.KBD_UNSMOOTH |  | int 0x375
FCodes.KBD_UPDATEREF |  | int 0xF07
FCodes.KBD_UPSTACK |  | int 0xEF1
FCodes.KBD_USEELTDEFSFROM |  | int 0xF9E
FCodes.KBD_USEFMTFROM |  | int 0x316
FCodes.KBD_VALIDATEFILE |  | int 0xF15
FCodes.KBD_VALIDATE_HYPERTEXT |  | int 0xF13
FCodes.KBD_VALIDATION |  | int 0xFE0
FCodes.KBD_VAL_ALLOW |  | int 0xFE6
FCodes.KBD_VAL_CLEAR |  | int 0xFE7
FCodes.KBD_VAL_DOC |  | int 0xFE3
FCodes.KBD_VAL_ELEM |  | int 0xFE1
FCodes.KBD_VAL_FLOW |  | int 0xFE2
FCodes.KBD_VAL_IGNORE |  | int 0xFE4
FCodes.KBD_VAL_IGNORE_ATTR |  | int 0xFF6
FCodes.KBD_VAL_START |  | int 0xFE5
FCodes.KBD_VARCURDATE |  | int 0xA08
FCodes.KBD_VARCURPG |  | int 0xA06
FCodes.KBD_VARIABLE |  | int 0x353
FCodes.KBD_VAROTHER |  | int 0xA09
FCodes.KBD_VARPGCOUNT |  | int 0xA07
FCodes.KBD_VARQUICK |  | int 0xF42
FCodes.KBD_VERIFYCONTEXT |  | int 0xF61
FCodes.KBD_VIEWER |  | int 0xF00
FCodes.KBD_VIEWER_MAKE_DOCUMENT |  | int 0xD50
FCodes.KBD_VIEWER_MAKE_MODELESSDIALOG |  | int 0xD52
FCodes.KBD_VIEWER_MAKE_PALETTE |  | int 0xD51
FCodes.KBD_VIEWSEP1 |  | int 0x36D
FCodes.KBD_VIEWSEP2 |  | int 0x36E
FCodes.KBD_VIEWSEP3 |  | int 0x36F
FCodes.KBD_VIEWSEP4 |  | int 0x37D
FCodes.KBD_VIEWSEP5 |  | int 0x37E
FCodes.KBD_VIEWSEP6 |  | int 0x39E
FCodes.KBD_VIEW_API |  | int 0xDF4
FCodes.KBD_VIEW_API_SHORTCUT |  | int 0xDF5
FCodes.KBD_VIEW_SWITCH |  | int 0xDF6
FCodes.KBD_VSCROLL |  | int 0xF39
FCodes.KBD_WAIT_DLGS |  | int 0x255
FCodes.KBD_WIDTH0 |  | int 0x3AC
FCodes.KBD_WIDTH1 |  | int 0x3AD
FCodes.KBD_WINDOWFULL_DOWN |  | int 0xD41
FCodes.KBD_WINDOWFULL_UP |  | int 0xD40
FCodes.KBD_WIN_CASCADE |  | int 0x903
FCodes.KBD_WIN_TILE |  | int 0x904
FCodes.KBD_WRAPQUICK |  | int 0xF49
FCodes.KBD_XCHARS |  | int 0x224
FCodes.KBD_XREFSPOD |  | int 0x96B
FCodes.KBD_XYZZQ |  | int 0xEE1
FCodes.KBD_XYZZY |  | int 0xFED
FCodes.KBD_XYZZZ |  | int 0xEE0
FCodes.KBD_YANK |  | int 0x32C
FCodes.KBD_ZOOM |  | int 0xF34
FCodes.KBD_ZOOM100 |  | int 0xF35
FCodes.KBD_ZOOMIN |  | int 0xF30
FCodes.KBD_ZOOMOUT |  | int 0xF31
FCodes.KBD_ZOOM_AUTOFIT_AFTER_ZOOM |  | int 0xF1A
FCodes.KBD_ZOOM_FIT_PAGE |  | int 0xF32
FCodes.KBD_ZOOM_FIT_TEXTFRAME |  | int 0xF3F
FCodes.KBD_ZOOM_FIT_WINDOW |  | int 0xF33
FCodes.KBD_ZOOM_SET |  | int 0xF3C
FCodes.LEAVE_DOC |  | int 0xC600
FCodes.MENU_BARSTART |  | int 0xC301
FCodes.MENU_DONE |  | int 0xC30F
FCodes.MENU_DOWN |  | int 0xC304
FCodes.MENU_DOWNWAIT |  | int 0xC312
FCodes.MENU_EXPOSE_WIN |  | int 0xC12
FCodes.MENU_HYPERTEXT |  | int 0xC18
FCodes.MENU_IMPORT_FILE |  | int 0xC14
FCodes.MENU_RIGHT |  | int 0xC305
FCodes.MENU_RIGHTWAIT |  | int 0xC313
FCodes.MENU_WAITBIT |  | int 0x0010
FCodes.MIF_SAVE_AFMS |  | int 0x000020
FCodes.MIF_SAVE_BANNERTEXT |  | int 0x1000000
FCodes.MIF_SAVE_CCAT |  | int 0x000400
FCodes.MIF_SAVE_COLORCAT |  | int 0x040000
FCodes.MIF_SAVE_DATALINKS |  | int 0x100000
FCodes.MIF_SAVE_DICT |  | int 0x001000
FCodes.MIF_SAVE_ECAT |  | int 0x010000
FCodes.MIF_SAVE_ELEMENTS |  | int 0x020000
FCodes.MIF_SAVE_FCAT |  | int 0x000100
FCodes.MIF_SAVE_FMTS |  | int 0x000004
FCodes.MIF_SAVE_FONTS |  | int 0x000008
FCodes.MIF_SAVE_FPLCAT |  | int 0x200000
FCodes.MIF_SAVE_LAYT |  | int 0x000040
FCodes.MIF_SAVE_MKRS |  | int 0x000010
FCodes.MIF_SAVE_MPAGE |  | int 0x000080
FCodes.MIF_SAVE_PCAT |  | int 0x000200
FCodes.MIF_SAVE_RUBIS |  | int 0x800000
FCodes.MIF_SAVE_TABLECATS |  | int 0x004000
FCodes.MIF_SAVE_TABLES |  | int 0x008000
FCodes.MIF_SAVE_TAGS |  | int 0x000002
FCodes.MIF_SAVE_TEXT |  | int 0x000001
FCodes.MIF_SAVE_TEXTINSETS |  | int 0x400000
FCodes.MIF_SAVE_TMPLT |  | int 0x000800
FCodes.MIF_SAVE_VARS |  | int 0x002000
FCodes.MIF_SAVE_VIEWSET |  | int 0x080000
FCodes.MRU_SELECT_FILE |  | int 0xC13
FCodes.NULLINPUT |  | int -1
FCodes.OBJ_SEL_EXTEND_NEXT |  | int 0x602
FCodes.OBJ_SEL_FIRST |  | int 0x600
FCodes.OBJ_SEL_LAST |  | int 0x606
FCodes.OBJ_SEL_NEXT |  | int 0x601
FCodes.OBJ_SEL_NEXT_WRAP |  | int 0x604
FCodes.OBJ_SEL_PREV |  | int 0x603
FCodes.OBJ_SEL_PREV_WRAP |  | int 0x605
FCodes.OPEN_MRU_FILES |  | int 0xC23
FCodes.PGF_ANYPLACE |  | int 0x28E
FCodes.PGF_APPLY_CAT_TO_SEL |  | int 0xF3D
FCodes.PGF_APPLY_TAG |  | int 0xC10
FCodes.PGF_BAM |  | int 0x286
FCodes.PGF_CENTER |  | int 0x282
FCodes.PGF_COLTOP |  | int 0x28B
FCodes.PGF_DECLINE |  | int 0x281
FCodes.PGF_DESIGNKIT_APPLY |  | int 0xAAA
FCodes.PGF_DESIGNKIT_NEWFORMAT |  | int 0xB00
FCodes.PGF_DESIGNKIT_RESET |  | int 0xABA
FCodes.PGF_DESIGNKIT_UPDATEALL |  | int 0xAAD
FCodes.PGF_DESIGNKIT_UPDATEOPTIONS |  | int 0xB03
FCodes.PGF_DESIGN_CAT |  | int 0xF4E
FCodes.PGF_DOUBLE_SPACE |  | int 0x295
FCodes.PGF_FULL |  | int 0x285
FCodes.PGF_HYPHENOFF |  | int 0x27F
FCodes.PGF_HYPHENON |  | int 0x27E
FCodes.PGF_INCLINE |  | int 0x280
FCodes.PGF_KBD_BODYSTRADDLE |  | int 0xFCF
FCodes.PGF_KBD_FULLSTRADDLE |  | int 0xFCE
FCodes.PGF_KBD_RUN_IN |  | int 0xFCD
FCodes.PGF_KBD_SIDEBODY |  | int 0xFC9
FCodes.PGF_KBD_SIDEHEAD_FIRST_BASELINE |  | int 0xFCA
FCodes.PGF_KBD_SIDEHEAD_LAST_BASELINE |  | int 0xFCB
FCodes.PGF_KBD_SIDEHEAD_TOP |  | int 0xFCC
FCodes.PGF_LEFT |  | int 0x283
FCodes.PGF_LEFTTOP |  | int 0x28C
FCodes.PGF_LINEFIX |  | int 0x287
FCodes.PGF_LINEFLOAT |  | int 0x288
FCodes.PGF_LINE_SPACE |  | int 0x297
FCodes.PGF_NEW_FORMAT |  | int 0x299
FCodes.PGF_ONEANDAHALF_SPACE |  | int 0x294
FCodes.PGF_PAGETOP |  | int 0x28A
FCodes.PGF_RIGHT |  | int 0x284
FCodes.PGF_RIGHTTOP |  | int 0x28D
FCodes.PGF_SINGLE_SPACE |  | int 0x293
FCodes.PGF_SPACE_BETWEEN |  | int 0x296
FCodes.PGF_UNIFY |  | int 0x289
FCodes.PGF_UPDATE_ALL |  | int 0x298
FCodes.SEARCH_CB |  | int 0x518
FCodes.SEARCH_CBOVERRIDE |  | int 0x51B
FCodes.SEARCH_CBTAG |  | int 0x519
FCodes.SEARCH_COND |  | int 0x51A
FCodes.SERVER_CANCEL |  | int 0xC001
FCodes.SERVER_QUERY |  | int 0xC002
FCodes.START_DIALOG |  | int 0xC100
FCodes.START_WINDOW |  | int 0xC400
FCodes.STYLE_APPLY_CAT_TO_SEL |  | int 0x808
FCodes.SUPPRESS_INSETS |  | int 0x3E2
FCodes.SWITCH_TO_DOCUMENTVIEW |  | int 0x9EB
FCodes.SWITCH_TO_RESOURCEMANAGER |  | int 0x9EA
FCodes.SW_CSR_DOWN |  | int 0xFE9
FCodes.SW_CSR_LEFT |  | int 0xFEB
FCodes.SW_CSR_RIGHT |  | int 0xFEA
FCodes.SW_CSR_UP |  | int 0xFE8
FCodes.TBL_APPLY_CAT_TO_SEL |  | int 0xFBC
FCodes.TBL_APPLY_TAG |  | int 0xFBE
FCodes.TBL_DESIGNKIT_APPLY |  | int 0xAAC
FCodes.TBL_DESIGNKIT_NEWFORMAT |  | int 0xB02
FCodes.TBL_DESIGNKIT_RESET |  | int 0xABC
FCodes.TBL_DESIGNKIT_UPDATEALL |  | int 0xAAF
FCodes.TBL_DESIGNKIT_UPDATEOPTIONS |  | int 0xB05
FCodes.TBL_DESIGN_CAT |  | int 0xF5F
FCodes.TEXTSEL_DRAGGING |  | int 0x2000
FCodes.TEXTSEL_ELEMENT |  | int 0x1000
FCodes.TEXTSEL_EXTEND |  | int 0x0002
FCodes.TEXTSEL_EXTEND_ELEMENT |  | int 0x0800
FCodes.TEXTSEL_EXTEND_LINE |  | int 0x0008
FCodes.TEXTSEL_EXTEND_PGF |  | int 0x0010
FCodes.TEXTSEL_EXTEND_SENT |  | int 0x0200
FCodes.TEXTSEL_EXTEND_WORD |  | int 0x0004
FCodes.TEXTSEL_LINE |  | int 0x0040
FCodes.TEXTSEL_PGF |  | int 0x0080
FCodes.TEXTSEL_QUICK_COPY |  | int 0x0001
FCodes.TEXTSEL_SELECT_ONLY |  | int 0x0100
FCodes.TEXTSEL_SENT |  | int 0x0400
FCodes.TEXTSEL_WORD |  | int 0x0020
FCodes.TEXT_INSET_PROPS |  | int 0x3E0
FCodes.TOGGLE_FLUID_VIEW |  | int 0x500
FCodes.TXT_10 |  | int 0xC02
FCodes.TXT_12 |  | int 0xC03
FCodes.TXT_14 |  | int 0xC04
FCodes.TXT_18 |  | int 0xC05
FCodes.TXT_24 |  | int 0xC06
FCodes.TXT_7 |  | int 0xC00
FCodes.TXT_9 |  | int 0xC01
FCodes.TXT_BAM |  | int 0x26B
FCodes.TXT_BOLD |  | int 0x260
FCodes.TXT_CHANGEBAR |  | int 0x26F
FCodes.TXT_DBLUNDERLINE |  | int 0x278
FCodes.TXT_DECSIZE |  | int 0x268
FCodes.TXT_DEFAULT |  | int 0x26D
FCodes.TXT_FAMILY_AND_VARIATION |  | int 0xC09
FCodes.TXT_FAMILY_AND_VARIATION_PLATFORM |  | int 0xC0A
FCodes.TXT_FONT |  | int 0xC17
FCodes.TXT_INCSIZE |  | int 0x267
FCodes.TXT_INITCAPS |  | int 0x274
FCodes.TXT_ITALIC |  | int 0x261
FCodes.TXT_KERN |  | int 0x270
FCodes.TXT_LESSSTRETCH |  | int 0x131
FCodes.TXT_LOWERCASE |  | int 0x276
FCodes.TXT_MINICAPS |  | int 0x273
FCodes.TXT_MORESTRETCH |  | int 0x132
FCodes.TXT_NORMAL |  | int 0x266
FCodes.TXT_NORMALCASE |  | int 0x277
FCodes.TXT_NOSTRETCH |  | int 0x130
FCodes.TXT_NUMUNDERLINE |  | int 0x279
FCodes.TXT_OTHERSIZE |  | int 0xC08
FCodes.TXT_OUTLINE |  | int 0x271
FCodes.TXT_OVERLINE |  | int 0x26E
FCodes.TXT_PLAIN |  | int 0x263
FCodes.TXT_SELBOLD |  | int 0x27A
FCodes.TXT_SELDECSIZE |  | int 0x120
FCodes.TXT_SELINCSIZE |  | int 0x11F
FCodes.TXT_SELITALIC |  | int 0x27B
FCodes.TXT_SELPLAIN |  | int 0x27D
FCodes.TXT_SELUNDERLINE |  | int 0x27C
FCodes.TXT_SHADOW |  | int 0x272
FCodes.TXT_SPREAD |  | int 0x26A
FCodes.TXT_SQUEEZE |  | int 0x269
FCodes.TXT_STRIKEOUT |  | int 0x26C
FCodes.TXT_SUB |  | int 0x265
FCodes.TXT_SUPER |  | int 0x264
FCodes.TXT_TSUME |  | int 0x2A5
FCodes.TXT_UNDERLINE |  | int 0x262
FCodes.TXT_UPPERCASE |  | int 0x275
FCodes.TXT_USIZE |  | int 0xC07
FCodes.TYPEIN |  | int 0xDF2
FCodes.UPDATE_INSETS |  | int 0x3E1
FCodes.WEB_ADOBEHELP |  | int 0xC22
FCodes.WEB_ADOBE_BOOKMARKS |  | int 0xC21
FCodes.WEB_CORPORATENEWS |  | int 0xC1D
FCodes.WEB_FRAME_BOOKMARKS |  | int 0xC1F
FCodes.WEB_GOTOADOBE |  | int 0xC19
FCodes.WEB_PREFERENCES |  | int 0xC1A
FCodes.WEB_REGISTRATION |  | int 0xC1E
FCodes.WEB_TOPISSUES |  | int 0xC1B

Usage
Jongware, 18-Jan-2015 v1.0 Contents :: Index


Adobe FrameMaker-12 Object Model JS: FilterArgs

Class

FilterArgs

QuickLinks

 FilterArgs

Properties

Property | Type | Access | Description
args | Strings String | readwrite |
binname | string | readwrite |
clname | string | readwrite |
infile | string | readwrite |
informat | string | readwrite |
outfile | string | readwrite |
outformat | string | readwrite |

Methods

Constructor

FilterArgs FilterArgs (infile: string, outfile: string, clname: string, informat: string, outformat: string, binname: string, args: Strings)
Parameter | Type | Description
infile | string |
outfile | string |
clname | string |
informat | string |
outformat | string |
binname | string |
args | Strings |

Example new FilterArgs()

Return

FilterArgs FilterArgs.FilterArgs (infile: string, outfile: string, clname: string, informat: string, outformat: string, binname: string, args: Strings)


Adobe FrameMaker-12 Object Model JS: Flow

Class

Flow

QuickLinks

 Delete, GetProps, GetText, ObjectValid, SetProps

Properties

Property | Type | Access | Description
FirstTextFrameInFlow | TextFrame | readonly |
FlowIsAutoConnect | int | readwrite |
FlowIsFeathered | int | readwrite |
FlowIsPostScript | int | readwrite |
FlowIsSynchronized | int | readwrite |
HighestLevelElement | Element | readonly |
LastTextFrameInFlow | TextFrame | readonly |
MaxInterPgfPadding | int | readwrite |
MaxInterlinePadding | int | readwrite |
MinHang | int | readwrite |
Name | string | readwrite |
NextFlowInDoc | Flow | readonly |
SideHeadRoomInFlow | int | readwrite |
Spacing | int | readwrite |
UserString | string | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.DocFluidFlow

Doc.FirstFlowInDoc

Doc.MainFlowInDoc

Flow.NextFlowInDoc

TextFrame.Flow

Return

Flow Doc.NewFlow (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: FmtChangeList

Class

FmtChangeList

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
AdjHyphens | int | readwrite |
AutoNumChar | string | readwrite |
AutoNumString | string | readwrite |
BkColor | Color | readwrite |
BlockLines | int | readwrite |
BottomSepAtIndent | int | readwrite |
BottomSeparator | string | readwrite |
Capitalization | int | readwrite |
CellBottomMargin | int | readwrite |
CellBottomMarginChange | int | readwrite |
CellBottomMarginFixed | int | readwrite |
CellLeftMargin | int | readwrite |
CellLeftMarginChange | int | readwrite |
CellLeftMarginFixed | int | readwrite |
CellRightMargin | int | readwrite |
CellRightMarginFixed | int | readwrite |
CellTopMargin | int | readwrite |
CellTopMarginChange | int | readwrite |
CellTopMarginFixed | int | readwrite |
CellVAlignment | int | readwrite |
ChangeBar | int | readwrite |
Color | Color | readwrite |
CombinedFontFamily | CombinedFontDefn | readwrite |
FirstIndent | int | readwrite |
FirstIndentChange | int | readwrite |
FirstIndentIsRelative | int | readwrite |
FirstIndentRelPos | int | readwrite |
FmtChangeListInCatalog | int | readwrite |
FontAngle | int | readwrite |
FontFamily | int | readwrite |
FontSize | int | readwrite |
FontSizeChange | int | readwrite |
FontVariation | int | readwrite |
FontWeight | int | readwrite |
HyphMinPrefix | int | readwrite |
HyphMinSuffix | int | readwrite |
HyphMinWord | int | readwrite |
Hyphenate | int | readwrite |
KeepWithNext | int | readwrite |
KeepWithPrev | int | readwrite |
KernX | int | readwrite |
KernY | int | readwrite |
Language | int | readwrite |
Leading | int | readwrite |
LeadingChange | int | readwrite |
LeftIndent | int | readwrite |
LeftIndentChange | int | readwrite |
LetterSpace | int | readwrite |
LineSpacingFixed | int | readwrite |
MaxJLetSpace | int | readwrite |
MaxJRomSpace | int | readwrite |
MaxSpace | int | readwrite |
MinJLetSpace | int | readwrite |
MinJRomSpace | int | readwrite |
MinSpace | int | readwrite |
MoveTabs | int | readwrite |
Name | string | readwrite |
NextFmtChangeListInDoc | FmtChangeList | readwrite |
NumAtEnd | int | readwrite |
NumTabs | int | readwrite |
OptJLetSpace | int | readwrite |
OptJRomSpace | int | readwrite |
OptSpace | int | readwrite |
Overline | int | readwrite |
PairKern | int | readwrite |
PgfAlignment | int | readwrite |
PgfBoxColor | Color | readwrite |
PgfCatalogReference | string | readwrite |
PgfIsAutoNum | int | readwrite |
Placement | int | readwrite |
Position | int | readwrite |
RightIndent | int | readwrite |
RightIndentChange | int | readwrite |
RunInSeparator | string | readwrite |
SpaceAbove | int | readwrite |
SpaceAboveChange | int | readwrite |
SpaceBelow | int | readwrite |
SpaceBelowChange | int | readwrite |
Spread | int | readwrite |
SpreadChange | int | readwrite |
Start | int | readwrite |
Stretch | int | readwrite |
StretchChange | int | readwrite |
Strikethrough | int | readwrite |
Tabs | Tabs Tab | readwrite |
TopSepAtIndent | int | readwrite |
TopSeparator | string | readwrite |
Underlining | int | readwrite |
YakumonoType | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Book.FirstFmtChangeListInDoc

Doc.FirstFmtChangeListInDoc

FmtChangeList.NextFmtChangeListInDoc

FmtRuleClause.FmtChangeList

Return

FmtChangeList Doc.GetNamedFmtChangeList (name: string)

FmtChangeList Doc.NewNamedFmtChangeList (name: string)

FmtChangeList FmtRuleClause.NewFmtChangeList ()


Adobe FrameMaker-12 Object Model JS: FmtRule

Class

FmtRule

QuickLinks

 Delete, GetProps, NewFmtRuleClauses, ObjectValid, SetProps

Properties

Property | Type | Access | Description
CountElements | Strings String | readwrite |
ElementDef | ElementDef | readwrite |
FmtRuleClause | FmtRuleClause | readwrite |
FmtRuleClauses | Objects | readonly |
FmtRuleType | int | readwrite |
StopCountingAt | string | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

FmtRuleClause NewFmtRuleClauses ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

FmtRuleClause.FmtRule

FmtRuleClause.SubFmtRule

Return

FmtRule ElementDef.NewFirstPgfRules ()

FmtRule ElementDef.NewLastPgfRules ()

FmtRule ElementDef.NewObjectFmtRules ()

FmtRule ElementDef.NewPrefixRules ()

FmtRule ElementDef.NewSuffixRules ()

FmtRule ElementDef.NewTextFmtRules ()

FmtRule FmtRuleClause.NewSubFmtRule ()


Adobe FrameMaker-12 Object Model JS: FmtRuleClause

Class

FmtRuleClause

QuickLinks

 Delete, GetProps, NewFmtChangeList, NewSubFmtRule, ObjectValid, SetProps

Properties

Property | Type | Access | Description
ContextLabel | string | readwrite |
ElemPrefixSuffix | string | readwrite |
FmtChangeList | FmtChangeList | readonly |
FmtChangeListTag | string | readwrite |
FmtRule | FmtRule | readonly |
FormatTag | string | readwrite |
IsTextRange | int | readwrite |
RuleClauseType | int | readonly |
Specification | string | readwrite |
SpecificationForCSS | Strings String | readonly |
SubFmtRule | FmtRule | readonly |

Methods

Instances

int Delete ()

PropVals GetProps ()

FmtChangeList NewFmtChangeList ()

FmtRule NewSubFmtRule ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

FmtRule.FmtRuleClause

Return

FmtRuleClause FmtRule.NewFmtRuleClauses ()


Adobe FrameMaker-12 Object Model JS: Fn

Class

Fn

QuickLinks

 Delete, GetProps, GetText, ObjectValid, SetProps

Properties

Property | Type | Access | Description
ContentHeight | int | readonly |
Element | Element | readonly |
FirstPgf | Pgf | readonly |
FnAnchorString | string | readonly |
FnNum | int | readonly |
InTextFrame | TextFrame | readonly |
InTextObj | SubCol | readonly |
LastPgf | Pgf | readonly |
NextFn | Fn | readonly |
NextFnInDoc | Fn | readonly |
Overflowed | int | readonly |
PrevFn | Fn | readonly |
TextLoc | TextLoc | readonly |
Unique | int | readonly |
UserString | string | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstFnInDoc

Fn.NextFn

Fn.NextFnInDoc

Fn.PrevFn

SubCol.FirstFn

SubCol.LastFn

TextFrame.FirstFn

TextFrame.LastFn

Return

Fn Doc.NewAnchoredFn (textloc: TextLoc)


Adobe FrameMaker-12 Object Model JS: Font

Class

Font

QuickLinks

 Font

Properties

Property | Type | Access | Description
angle | uint | readwrite |
family | uint | readwrite |
variation | uint | readwrite |
weight | uint | readwrite |

Methods

Constructor

Font Font (family: uint, variation: uint, weight: uint, angle: uint)
Parameter | Type | Description
family | uint |
variation | uint |
weight | uint |
angle | uint |

Example new Font()

Used in:

number Fonts.push (value: Font)

string Globals.GetEncodingForFont (font: Font)

Return

Font Font.Font (family: uint, variation: uint, weight: uint, angle: uint)

Font Fonts.pop ()


Adobe FrameMaker-12 Object Model JS: FontEnc

Class

FontEnc

Jongware, 18-Jan-2015 v1.0 Contents :: Index


Adobe FrameMaker-12 Object Model JS: Fonts

Class

Fonts

An Array of Font objects with integer indexing and a length property.

See also Font.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

Fonts concat (value: Fonts)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | Fonts | Any number of values to be added to the end of the array. Can also be arrays.

Font pop ()
Removes the last element from the array.

number push (value: Font)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | Font |

Used in:

Fonts Fonts.concat (value: Fonts)

Return

Fonts Fonts.concat (value: Fonts)

Fonts Globals.FamilyFonts (family: int)


Adobe FrameMaker-12 Object Model JS: GraphicsFmt

Class

GraphicsFmt

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
AFrameIsCropped | bool | readwrite |
AFrameIsFloating | bool | readwrite |
Alignment | int | readwrite |
AnchorType | int | readwrite |
Angle | int | readwrite |
BaselineOffset | int | readwrite |
BorderWidth | int | readwrite |
ColGapWidth | int | readwrite |
Color | Color | readwrite |
ColumnsAreBalanced | int | readwrite |
DTheta | int | readwrite |
Fill | int | readwrite |
FlowIsAutoConnect | int | readwrite |
FlowIsPostScript | int | readwrite |
Height | int | readwrite |
InsetDpi | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
MathMLComposeDpi | int | readwrite |
MathMLDpi | int | readwrite |
MathMLFontSize | int | readwrite |
MathSize | int | readwrite |
NextGraphicsFmtInDoc | GraphicsFmt | readonly |
NumColumns | int | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
Radius | int | readwrite |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
SideHeadGap | int | readwrite |
SideHeadPlacement | int | readwrite |
SideHeadWidth | int | readwrite |
SideOffset | int | readwrite |
StyleTag | string | readwrite |
TextLineType | int | readwrite |
Theta | int | readwrite |
TintPercent | int | readwrite |
UseAFrameIsCropped | bool | readwrite |
UseAFrameIsFloating | bool | readwrite |
UseAlignment | bool | readwrite |
UseAnchorType | bool | readwrite |
UseAngle | bool | readwrite |
UseBaselineOffset | bool | readwrite |
UseBorderWidth | bool | readwrite |
UseColGapWidth | bool | readwrite |
UseColor | bool | readwrite |
UseColumnsAreBalanced | bool | readwrite |
UseDTheta | bool | readwrite |
UseFill | bool | readwrite |
UseFlowIsAutoConnect | bool | readwrite |
UseFlowIsPostScript | bool | readwrite |
UseHeight | bool | readwrite |
UseInsetDpi | bool | readwrite |
UseLocX | bool | readwrite |
UseLocY | bool | readwrite |
UseMathMLComposeDpi | bool | readwrite |
UseMathMLDpi | bool | readwrite |
UseMathMLFontSize | bool | readwrite |
UseMathSize | bool | readwrite |
UseNumColumns | bool | readwrite |
UseOverprint | bool | readwrite |
UsePen | bool | readwrite |
UseRadius | bool | readwrite |
UseRunaround | bool | readwrite |
UseRunaroundGap | bool | readwrite |
UseSideHeadGap | bool | readwrite |
UseSideHeadPlacement | bool | readwrite |
UseSideHeadWidth | bool | readwrite |
UseSideOffset | bool | readwrite |
UseTextLineType | bool | readwrite |
UseTheta | bool | readwrite |
UseTintPercent | bool | readwrite |
UseWidth | bool | readwrite |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstGraphicsFmtInDoc

GraphicsFmt.NextGraphicsFmtInDoc

Return

GraphicsFmt Doc.GetNamedGraphicsFmt (name: string)

GraphicsFmt Doc.NewNamedGraphicsFmt (name: string)


Adobe FrameMaker-12 Object Model JS: Group

Class

Group

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FirstGraphicInGroup | FMObject | readonly |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LastGraphicInGroup | FMObject | readonly |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

AFrame.GroupParent

Arc.GroupParent

Ellipse.GroupParent

Group.GroupParent

Inset.GroupParent

Line.GroupParent

Math.GroupParent

MathML.GroupParent

Polygon.GroupParent

Polyline.GroupParent

Rectangle.GroupParent

RoundRect.GroupParent

TextFrame.GroupParent

TextLine.GroupParent

UnanchoredFrame.GroupParent

Return

Group Doc.NewGroup (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: HiddenPage

Class

HiddenPage

QuickLinks

 ApplyPageLayout, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Name | string | readonly |
PageFrame | UnanchoredFrame | readonly |
PageHeight | int | readonly |
PageWidth | int | readonly |

Methods

Instances

int ApplyPageLayout (srcPage: PageObject) PageObject is any Page object i.e., BodyPage, MasterPage, ReferencePage, HiddenPage
Parameter | Type | Description
srcPage | PageObject |

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.HiddenPage


Adobe FrameMaker-12 Object Model JS: IdValuePair

Class

IdValuePair

QuickLinks

 IdValuePair

Properties

Property | Type | Access | Description
id | int | readwrite |
value | Value | readwrite |

Methods

Constructor

IdValuePair IdValuePair (id: int, value: Value)
Parameter | Type | Description
id | int |
value | Value |

Example new IdValuePair()

Used in:

number IdValuePairs.push (value: IdValuePair)

Return

IdValuePair IdValuePair.IdValuePair (id: int, value: Value)

IdValuePair IdValuePairs.pop ()


Adobe FrameMaker-12 Object Model JS: IdValuePairs

Class

IdValuePairs

An Array of IdValuePair objects with integer indexing and a length property.

See also IdValuePair.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

IdValuePairs concat (value: IdValuePairs)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | IdValuePairs | Any number of values to be added to the end of the array. Can also be arrays.

IdValuePair pop ()
Removes the last element from the array.

number push (value: IdValuePair)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | IdValuePair |

Used in:

int CMSObject.CMSCheckin (checkinParam: IdValuePairs)

int CMSObject.CMSDelete (deleteParams: IdValuePairs)

Object CMSObject.CMSOpenFile (openParams: IdValuePairs)

CMSSession Globals.CMSLogin (setVal: IdValuePairs)

IdValuePairs IdValuePairs.concat (value: IdValuePairs)

Return

IdValuePairs IdValuePairs.concat (value: IdValuePairs)


Adobe FrameMaker-12 Object Model JS: Inset

Class

Inset

QuickLinks

 Delete, DeletePropByName, GetIntByName, GetMetricByName, GetProps, GetUBytesByName, ObjectValid, SetIntByName, SetMetricByName, SetProps, SetUBytesByName

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
ImportHint | string | readwrite |
InsetDpi | int | readwrite |
InsetEditor | string | readwrite |
InsetFile | string | readwrite |
InsetGfxActiveInPdf | bool | readwrite |
InsetGfxName | string | readwrite |
InsetGfxPlayWindowInPdf | bool | readwrite |
InsetIsFixedSize | int | readwrite |
InsetIsFlippedSideways | int | readwrite |
InsetJavaScriptFile | string | readwrite |
InsetPosterFile | string | readwrite |
InsetU3dAnimationList | Strings String | readonly |
InsetU3dPartList | Strings String | readonly |
InsetU3dViewList | Strings String | readonly |
InsetUpdater | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
PageNum | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

void DeletePropByName (propName: string)
Parameter | Type | Description
propName | string |

int GetIntByName (propName: string)
Parameter | Type | Description
propName | string |

int GetMetricByName (propName: string)
Parameter | Type | Description
propName | string |

PropVals GetProps ()

UBytes GetUBytesByName (propName: string)
Parameter | Type | Description
propName | string |

int ObjectValid ()

void SetIntByName (propName: string, setVal: int)
Parameter | Type | Description
propName | string |
setVal | int |

void SetMetricByName (propName: string, setVal: int)
Parameter | Type | Description
propName | string |
setVal | int |

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

void SetUBytesByName (propName: string, setVal: UBytes)
Parameter | Type | Description
propName | string |
setVal | UBytes |

Return

Inset Doc.NewInset (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: Ints

Class

Ints

An Array of int objects with integer indexing and a length property.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

Ints concat (value: Ints)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | Ints | Any number of values to be added to the end of the array. Can also be arrays.

int pop ()
Removes the last element from the array.

number push (value: int)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | int |

Element of

ElementDef.GeneralRuleErrorOffsets

TypedVal.isval

app.FontFamilyAttributes

Used in:

Ints Ints.concat (value: Ints)

Return

Ints Ints.concat (value: Ints)


Adobe FrameMaker-12 Object Model JS: Iterator

Class

Iterator

QuickLinks

 Delete, GetNextIteratorItem, GetProps, ObjectValid, SetProps

Methods

Instances

int Delete ()

PropVals GetNextIteratorItem ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |


Adobe FrameMaker-12 Object Model JS: KeyCatalog

Class

KeyCatalog

QuickLinks

 Delete, DeleteAllKeyDefinitions, GetAllKeyDefinitions, GetAllKeys, GetKeyDefinition, GetProps, NewKeyDefinition, ObjectValid, SetProps, UpdateKeyDefinition

Properties

Property | Type | Access | Description
IsDefault | bool | readonly |
IsStale | bool | readwrite |
KeyCatalogClientName | string | readwrite |
KeyCount | int | readonly |
Name | string | readwrite |
NextKeyCatalogInSession | KeyCatalog | readonly |
NotLoaded | bool | readwrite |
Source | string | readwrite |
SourceType | int | readwrite |

Methods

Instances

int Delete ()

void DeleteAllKeyDefinitions ()

TypedVals GetAllKeyDefinitions (filterType: int)
Parameter | Type | Description
filterType | int |

Strings GetAllKeys ()

TypedVal GetKeyDefinition (key: string, keyField: int)
Parameter | Type | Description
key | string |
keyField | int |

PropVals GetProps ()

void NewKeyDefinition (key: string, href: string, srcType: int, srcFile: string, flags: int)
Parameter | Type | Description
key | string |
href | string |
srcType | int |
srcFile | string |
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

void UpdateKeyDefinition (key: string, keyField: int, valuep: TypedVal)
Parameter | Type | Description
key | string |
keyField | int |
valuep | TypedVal |

Element of

Doc.KeyCatalog

Doc.SpecifiedKeyCatalog

KeyCatalog.NextKeyCatalogInSession

app.DefaultKeyCatalog

app.FirstKeyCatalogInSession

Return

KeyCatalog Globals.GetKeyCatalog (tag: string)

KeyCatalog Globals.NewKeyCatalog (tag: string)


Adobe FrameMaker-12 Object Model JS: Line

Class

Line

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
NumPoints | int | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
Points | Points Point | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

Line Doc.NewLine (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: Marker

Class

Marker

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Element | Element | readonly |
MarkerText | string | readwrite |
MarkerTypeId | MarkerType | readwrite |
NextMarkerInDoc | Marker | readonly |
OldTypeNum |  | readwrite |
TextLoc | TextLoc | readonly |
Unique | int | readonly |
UserString | string | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstMarkerInDoc

Marker.NextMarkerInDoc

Return

Marker Doc.NewAnchoredMarker (textloc: TextLoc)


Adobe FrameMaker-12 Object Model JS: MarkerType

Class

MarkerType

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
InvariantName | string | readwrite |
Name | string | readwrite |
NextMarkerTypeInDoc | MarkerType | readwrite |
Public | bool | readwrite |
Required | bool | readonly |
Transient | bool | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstMarkerTypeInDoc

Marker.MarkerTypeId

MarkerType.NextMarkerTypeInDoc

Return

MarkerType Doc.GetNamedMarkerType (name: string)

MarkerType Doc.NewNamedMarkerType (name: string)


Adobe FrameMaker-12 Object Model JS: MasterPage

Class

MasterPage

QuickLinks

 ApplyPageLayout, Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Name | string | readwrite |
PageFrame | UnanchoredFrame | readonly |
PageHeight | int | readonly |
PageNext | MasterPage | readonly |
PageNum | int | readonly |
PagePrev | MasterPage | readonly |
PageWidth | int | readonly |

Methods

Instances

int ApplyPageLayout (srcPage: PageObject) PageObject is any Page object i.e., BodyPage, MasterPage, ReferencePage, HiddenPage
Parameter | Type | Description
srcPage | PageObject |

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstMasterPageInDoc

Doc.LastMasterPageInDoc

Doc.LeftMasterPage

Doc.RightMasterPage

MasterPage.PageNext

MasterPage.PagePrev

Return

MasterPage Doc.GetNamedMasterPage (name: string)

MasterPage Doc.NewNamedMasterPage (name: string)


Adobe FrameMaker-12 Object Model JS: Math

Class

Math

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BasePointX | int | readwrite |
BasePointY | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
MathFullForm | string | readwrite |
MathSize | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TextLineType | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

Math Doc.NewMath (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: MathML

Class

MathML

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
MathMLComposeDpi | int | readwrite |
MathMLData | Strings String | readwrite |
MathMLDpi | int | readwrite |
MathMLFontSize | int | readwrite |
MathMLIsFixedSize | int | readwrite |
MathMLIsFlippedSideways | int | readwrite |
MathMLIsInverted | int | readwrite |
MathMLXmlData | string | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

MathML Doc.NewMathML (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: Menu

Class

Menu

QuickLinks

 AddCommandToMenu, AddMenuToMenu, AnimateMenu, DefineAndAddCommand, DefineAndAddMenu, Delete, GetProps, MenuItemInMenu, ObjectValid, SetProps

Properties

Property | Type | Access | Description
FirstMenuItemInMenu | FMObject | readwrite |
Label | string | readwrite |
MenuItemIsEnabled | int | readonly |
MenuType | int | readonly |
Name | string | readonly |
NextMenuItemInMenu | FMObject | readwrite |
NextMenuItemInSession | FMObject | readonly |
PrevMenuItemInMenu | FMObject | readwrite |

Methods

Instances

number AddCommandToMenu (command: Command)
Parameter | Type | Description
command | Command |

int AddMenuToMenu (menu: Menu)
Parameter | Type | Description
menu | Menu |

int AnimateMenu (menuitem: Object, sleep: int, realLabel: string, docOrBook: Object, action: bool)
Parameter | Type | Description
menuitem | Object |
sleep | int |
realLabel | string |
docOrBook | Object |
action | bool |

Command DefineAndAddCommand (cmdNum: number, name: string, label: string, shortcut: string)
Parameter | Type | Description
cmdNum | number |
name | string |
label | string |
shortcut | string |

Menu DefineAndAddMenu (name: string, label: string)
Parameter | Type | Description
name | string |
label | string |

int Delete ()

PropVals GetProps ()

Menu MenuItemInMenu (menuitem: MenuItemComponent, recursive: bool)
Parameter | Type | Description
menuitem | MenuItemComponent |
recursive | bool |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.MenuBar

Doc.ViewOnlyMenuBar

Used in:

int Menu.AddMenuToMenu (menu: Menu)

Return

Menu Globals.DefineMenu (name: string, label: string)

Menu Menu.DefineAndAddMenu (name: string, label: string)

Menu Menu.MenuItemInMenu (menuitem: MenuItemComponent, recursive: bool)

Menu app.GetNamedMenu (name: string)

Menu app.NewNamedMenu (name: string)


Adobe FrameMaker-12 Object Model JS: MenuItemSeparator

Class

MenuItemSeparator

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Label | string | readwrite |
MenuItemIsEnabled | int | readonly |
Name | string | readonly |
NextMenuItemInMenu | FMObject | readwrite |
NextMenuItemInSession | FMObject | readonly |
PrevMenuItemInMenu | FMObject | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

MenuItemSeparator app.GetNamedMenuItemSeparator (name: string)

MenuItemSeparator app.NewNamedMenuItemSeparator (name: string)


Adobe FrameMaker-12 Object Model JS: Metrics

Class

Metrics

An Array of int objects with integer indexing and a length property.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

Metrics concat (value: Metrics)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | Metrics | Any number of values to be added to the end of the array. Can also be arrays.

int pop ()
Removes the last element from the array.

number push (value: int)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | int |

Element of

AFrame.Dash

Arc.Dash

Ellipse.Dash

Group.Dash

Inset.Dash

Line.Dash

Math.Dash

MathML.Dash

Polygon.Dash

Polyline.Dash

Rectangle.Dash

RoundRect.Dash

Tbl.TblColWidths

TextFrame.Dash

TextLine.Dash

TypedVal.msval

UnanchoredFrame.Dash

Used in:

Metrics Metrics.concat (value: Metrics)

Return

Metrics Metrics.concat (value: Metrics)


Adobe FrameMaker-12 Object Model JS: Pgf

Class

Pgf

QuickLinks

 Delete, GetProps, GetText, ObjectValid, SetProps

Properties

Property | Type | Access | Description
AdjHyphens | int | readwrite |
AutoNumChar | string | readwrite |
AutoNumString | string | readwrite |
BkColor | Color | readwrite |
BlockLines | int | readwrite |
BottomSeparator | string | readwrite |
Capitalization | int | readwrite |
CellBottomMargin | int | readwrite |
CellLeftMargin | int | readwrite |
CellMarginsFixed | int | readwrite |
CellRightMargin | int | readwrite |
CellTopMargin | int | readwrite |
CellVAlignment | int | readwrite |
ChangeBar | int | readwrite |
Color | Color | readwrite |
CombinedFontFamily | CombinedFontDefn | readwrite |
FirstIndent | int | readwrite |
FontAngle | int | readwrite |
FontEncodingName | string | readonly |
FontFamily | int | readwrite |
FontPlatformName | string | readwrite |
FontPostScriptName | string | readwrite |
FontSize | int | readwrite |
FontVariation | int | readwrite |
FontWeight | int | readwrite |
FormatOverride | int | readwrite |
HyphMinPrefix | int | readwrite |
HyphMinSuffix | int | readwrite |
HyphMinWord | int | readwrite |
Hyphenate | int | readwrite |
InTextFrame | TextFrame | readonly |
InTextObj | FMObject | readonly |
KeepWithNext | int | readwrite |
KeepWithPrev | int | readwrite |
KernX | int | readwrite |
KernY | int | readwrite |
Language | int | readwrite |
Leading | int | readwrite |
LeftIndent | int | readwrite |
LetterSpace | int | readwrite |
LineSpacing | int | readwrite |
Locked | int | readwrite |
MaxJLetSpace | int | readwrite |
MaxJRomSpace | int | readwrite |
MaxSpace | int | readwrite |
MinJLetSpace | int | readwrite |
MinJRomSpace | int | readwrite |
MinSpace | int | readwrite |
Name | string | readwrite |
NextPgfInDoc | Pgf | readonly |
NextPgfInFlow | Pgf | readonly |
NextTag | string | readwrite |
NumAtEnd | int | readwrite |
NumTabs | int | readonly |
OptJLetSpace | int | readwrite |
OptJRomSpace | int | readwrite |
OptSpace | int | readwrite |
Overline | int | readwrite |
PairKern | int | readwrite |
PgfAlignment | int | readwrite |
PgfBoxColor | Color | readwrite |
PgfIsAutoNum | int | readwrite |
PgfNumber | string | readonly |
PgfSpellChecked | int | readwrite |
Placement | int | readwrite |
Position | int | readwrite |
PrevPgfInFlow | Pgf | readonly |
RightIndent | int | readwrite |
RunInSeparator | string | readwrite |
SpaceAbove | int | readwrite |
SpaceBelow | int | readwrite |
Spread | int | readwrite |
Start | int | readwrite |
Stretch | int | readwrite |
Strikethrough | int | readwrite |
Tabs | Tabs Tab | readwrite |
TopSeparator | string | readwrite |
Underlining | int | readwrite |
Unique | int | readonly |
UseNextTag | int | readwrite |
UserString | string | readwrite |
YakumonoType | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Cell.FirstPgf

Cell.LastPgf

Doc.FirstPgfInDoc

Fn.FirstPgf

Fn.LastPgf

Pgf.NextPgfInDoc

Pgf.NextPgfInFlow

Pgf.PrevPgfInFlow

SubCol.FirstPgf

SubCol.LastPgf

Tbl.FirstPgf

Tbl.LastPgf

TextFrame.FirstPgf

TextFrame.LastPgf

Return

Pgf Doc.NewSeriesPgf (previous: Object)


Adobe FrameMaker-12 Object Model JS: PgfFmt

Class

PgfFmt

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
AcrobatLevel | int | readwrite |
AdjHyphens | int | readwrite |
AutoNumChar | string | readwrite |
AutoNumString | string | readwrite |
BkColor | Color | readwrite |
BlockLines | int | readwrite |
BottomSeparator | string | readwrite |
Capitalization | int | readwrite |
CellBottomMargin | int | readwrite |
CellLeftMargin | int | readwrite |
CellMarginsFixed | int | readwrite |
CellRightMargin | int | readwrite |
CellTopMargin | int | readwrite |
CellVAlignment | int | readwrite |
ChangeBar | int | readwrite |
Color | Color | readwrite |
CombinedFontFamily | CombinedFontDefn | readwrite |
FirstIndent | int | readwrite |
FontAngle | int | readwrite |
FontEncodingName | string | readonly |
FontFamily | int | readwrite |
FontPlatformName | string | readwrite |
FontPostScriptName | string | readwrite |
FontSize | int | readwrite |
FontVariation | int | readwrite |
FontWeight | int | readwrite |
HyphMinPrefix | int | readwrite |
HyphMinSuffix | int | readwrite |
HyphMinWord | int | readwrite |
Hyphenate | int | readwrite |
KeepWithNext | int | readwrite |
KeepWithPrev | int | readwrite |
KernX | int | readwrite |
KernY | int | readwrite |
Language | int | readwrite |
Leading | int | readwrite |
LeftIndent | int | readwrite |
LetterSpace | int | readwrite |
LineSpacing | int | readwrite |
MaxJLetSpace | int | readwrite |
MaxJRomSpace | int | readwrite |
MaxSpace | int | readwrite |
MinJLetSpace | int | readwrite |
MinJRomSpace | int | readwrite |
MinSpace | int | readwrite |
Name | string | readwrite |
NextPgfFmtInDoc | PgfFmt | readonly |
NextTag | string | readwrite |
NumAtEnd | int | readwrite |
NumTabs | int | readonly |
OptJLetSpace | int | readwrite |
OptJRomSpace | int | readwrite |
OptSpace | int | readwrite |
Overline | int | readwrite |
PDFStructureLevel | int | readwrite |
PairKern | int | readwrite |
PgfAlignment | int | readwrite |
PgfBoxColor | Color | readwrite |
PgfIsAutoNum | int | readwrite |
PgfMarkedForNamedDestination | int | readwrite |
Placement | int | readwrite |
Position | int | readwrite |
RightIndent | int | readwrite |
RunInSeparator | string | readwrite |
SpaceAbove | int | readwrite |
SpaceBelow | int | readwrite |
Spread | int | readwrite |
Start | int | readwrite |
Stretch | int | readwrite |
Strikethrough | int | readwrite |
Tabs | Tabs Tab | readwrite |
TopSeparator | string | readwrite |
Underlining | int | readwrite |
UseBkColor | bool | readwrite |
UseNextTag | int | readwrite |
UserString | string | readwrite |
YakumonoType | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstPgfFmtInDoc

PgfFmt.NextPgfFmtInDoc

Return

PgfFmt Doc.GetNamedPgfFmt (name: string)

PgfFmt Doc.NewNamedPgfFmt (name: string)


Adobe FrameMaker-12 Object Model JS: Point

Class

Point

QuickLinks

 Point

Properties

Property | Type | Access | Description
x | int | readwrite |
y | int | readwrite |

Methods

Constructor

Point Point (x: int, y: int)
Parameter | Type | Description
x | int |
y | int |

Example new Point()

Element of

Button.location

Checkbox.location

DropDownList.location

EditText.location

FlashPlayer.location

Group.location

IconButton.location

ListBox.location

Panel.location

Progressbar.location

RadioButton.location

ScriptUIGraphics.currentPoint

Scrollbar.location

Slider.location

StaticText.location

TreeView.location

Window.frameLocation

Window.location

Used in:

number Points.push (value: Point)

Return

Point Point.Point (x: int, y: int)

Point Points.pop ()

Point ScriptUIGraphics.ellipsePath (left: Number, top: Number, width: Number, height: Number)

Point ScriptUIGraphics.lineTo (x: Number, y: Number)

Point ScriptUIGraphics.moveTo (x: Number, y: Number)

Point ScriptUIGraphics.rectPath (left: Number, top: Number, width: Number, height: Number)


Adobe FrameMaker-12 Object Model JS: Points

Class

Points

An Array of Point objects with integer indexing and a length property.

See also Point.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

Points concat (value: Points)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | Points | Any number of values to be added to the end of the array. Can also be arrays.

Point pop ()
Removes the last element from the array.

number push (value: Point)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | Point |

Element of

Line.Points

Polygon.Points

Polyline.Points

TypedVal.psval

Used in:

Points Points.concat (value: Points)

Return

Points Points.concat (value: Points)


Adobe FrameMaker-12 Object Model JS: Polygon

Class

Polygon

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
NumPoints | int | readwrite |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
Points | Points Point | readwrite |
PolyIsBezier | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

Polygon Doc.NewPolygon (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: Polyline

Class

Polyline

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
NumPoints | int | readwrite |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
Points | Points Point | readonly |
PolyIsBezier | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

Polyline Doc.NewPolyline (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: PropIdent

Class

PropIdent

QuickLinks

 PropIdent

Properties

Property | Type | Access | Description
name | string | readwrite |
num | int | readwrite |

Methods

Constructor

PropIdent PropIdent (num: int, name: string)
Parameter | Type | Description
num | int |
name | string |

Example new PropIdent()

Element of

PropVal.propIdent

Used in:

PropVal CMSObject.CMSGetProperty (propertyId: PropIdent)

PropVal PropVal.PropVal (propIdent: PropIdent, propVal: TypedVal)

Return

PropIdent PropIdent.PropIdent (num: int, name: string)


Adobe FrameMaker-12 Object Model JS: PropVal

Class

PropVal

QuickLinks

 PropVal

Properties

Property | Type | Access | Description
propIdent | PropIdent | readwrite |
propVal | TypedVal | readwrite |

Methods

Constructor

PropVal PropVal (propIdent: PropIdent, propVal: TypedVal)
Parameter | Type | Description
propIdent | PropIdent |
propVal | TypedVal |

Example new PropVal()

Used in:

void CMSObject.CMSSetProperty (propVal: PropVal)

void Doc.SetTextPropVal (textRange: TextRange, setVal: PropVal)

void Globals.PrintPropVal (p: PropVal)

number PropVals.push (value: PropVal)

Return

PropVal CMSObject.CMSGetProperty (propertyId: PropIdent)

PropVal Doc.GetTextPropVal (textLoc: TextLoc, propNum: int)

PropVal PropVal.PropVal (propIdent: PropIdent, propVal: TypedVal)

PropVal PropVals.pop ()


Adobe FrameMaker-12 Object Model JS: PropVals

Class

PropVals

An Array of PropVal objects with integer indexing and a length property.

See also PropVal.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

PropVals concat (value: PropVals)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | PropVals | Any number of values to be added to the end of the array. Can also be arrays.

PropVal pop ()
Removes the last element from the array.

number push (value: PropVal)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | PropVal |

Used in:

void AFrame.SetProps (setVal: PropVals)

void Arc.SetProps (setVal: PropVals)

void AttrCondExpr.SetProps (setVal: PropVals)

void BodyPage.SetProps (setVal: PropVals)

int Book.Export (fileName: string, exportParams: PropVals, exportReturnParams: PropVals)

Object Book.Import (textLocP: TextLoc, filename: string, importParams: PropVals, importReturnParams: PropVals)

Object Book.NewIterator (paramsp: PropVals)

Object Book.Save (saveAsName: string, saveParams: PropVals, saveReturnParams: PropVals)

void Book.SetProps (setVal: PropVals)

int Book.UpdateBook (updateParams: PropVals, updateReturnParams: PropVals)

void BookComponent.SetProps (setVal: PropVals)

void CMSConnection.SetProps (setVal: PropVals)

void CMSObject.CMSSetProperties (propVals: PropVals)

void CMSObject.SetProps (setVal: PropVals)

void CMSRegistration.SetProps (setVal: PropVals)

void CMSSession.SetProps (setVal: PropVals)

void Cell.SetProps (setVal: PropVals)

void CharFmt.SetProps (setVal: PropVals)

void Color.SetProps (setVal: PropVals)

void CombinedFontDefn.SetProps (setVal: PropVals)

void Command.SetProps (setVal: PropVals)

void CondFmt.SetProps (setVal: PropVals)

int Doc.Export (fileName: string, exportParams: PropVals, exportReturnParams: PropVals)

TextRange Doc.Find (textLoc: TextLoc, findParams: PropVals)

Object Doc.Import (textLocP: TextLoc, filename: string, importParams: PropVals, importReturnParams: PropVals)

Object Doc.NewIterator (paramsp: PropVals)

Object Doc.Save (saveAsName: string, saveParams: PropVals, saveReturnParams: PropVals)

void Doc.SetProps (setVal: PropVals)

void Doc.SetTextProps (textRange: TextRange, setVal: PropVals)

void Element.SetProps (setVal: PropVals)

void ElementDef.SetProps (setVal: PropVals)

void Ellipse.SetProps (setVal: PropVals)

void Flow.SetProps (setVal: PropVals)

void FmtChangeList.SetProps (setVal: PropVals)

void FmtRule.SetProps (setVal: PropVals)

void FmtRuleClause.SetProps (setVal: PropVals)

void Fn.SetProps (setVal: PropVals)

void Globals.AppendIntProp (pv: PropVals, prop: int, val: int)

void Globals.AppendMetricProp (pv: PropVals, prop: int, val: int)

void Globals.AppendStringProp (pv: PropVals, prop: int, val: string)

void Globals.AppendStringsProp (pv: PropVals, prop: int, val: Strings)

void Globals.AppendVal (pv: PropVals, prop: int, val: TypedVal)

int Globals.CheckStatus (p: PropVals, statusBit: int)

int Globals.GetPropIndex (propVals: PropVals, propNum: int)

bool Globals.IsDataDifferentFromTemplateData (templatePath: string, templateDataProps: PropVals)

Object Globals.NewXML (newXMLParams: PropVals, newXMLReturnParamspp: PropVals)

Object Globals.Open (fileName: string, openParams: PropVals, openReturnParams: PropVals)

void Globals.PrintExportStatus (p: PropVals)

void Globals.PrintImportStatus (p: PropVals)

void Globals.PrintOpenStatus (p: PropVals)

void Globals.PrintPropVals (p: PropVals)

void Globals.PrintSaveStatus (p: PropVals)

void Globals.PrintUpdateBookStatus (p: PropVals)

void GraphicsFmt.SetProps (setVal: PropVals)

void Group.SetProps (setVal: PropVals)

void HiddenPage.SetProps (setVal: PropVals)

void Inset.SetProps (setVal: PropVals)

void Iterator.SetProps (setVal: PropVals)

void KeyCatalog.SetProps (setVal: PropVals)

void Line.SetProps (setVal: PropVals)

void Marker.SetProps (setVal: PropVals)

void MarkerType.SetProps (setVal: PropVals)

void MasterPage.SetProps (setVal: PropVals)

void Math.SetProps (setVal: PropVals)

void MathML.SetProps (setVal: PropVals)

void Menu.SetProps (setVal: PropVals)

void MenuItemSeparator.SetProps (setVal: PropVals)

void Pgf.SetProps (setVal: PropVals)

void PgfFmt.SetProps (setVal: PropVals)

void Polygon.SetProps (setVal: PropVals)

void Polyline.SetProps (setVal: PropVals)

PropVals PropVals.concat (value: PropVals)

void Rectangle.SetProps (setVal: PropVals)

void RefPage.SetProps (setVal: PropVals)

void RoundRect.SetProps (setVal: PropVals)

void Row.SetProps (setVal: PropVals)

void Rubi.SetProps (setVal: PropVals)

void RulingFmt.SetProps (setVal: PropVals)

void SubCol.SetProps (setVal: PropVals)

void Tbl.SetProps (setVal: PropVals)

void TblFmt.SetProps (setVal: PropVals)

void TextFrame.SetProps (setVal: PropVals)

void TextLine.SetProps (setVal: PropVals)

void TiApiClient.SetProps (setVal: PropVals)

void TiFlow.SetProps (setVal: PropVals)

void TiText.SetProps (setVal: PropVals)

void TiTextTable.SetProps (setVal: PropVals)

void UnanchoredFrame.SetProps (setVal: PropVals)

void Var.SetProps (setVal: PropVals)

void VarFmt.SetProps (setVal: PropVals)

void XRef.SetProps (setVal: PropVals)

void XRefFmt.SetProps (setVal: PropVals)

void app.SetProps (setVal: PropVals)

Return

PropVals AFrame.GetProps ()

PropVals Arc.GetProps ()

PropVals AttrCondExpr.GetProps ()

PropVals BodyPage.GetProps ()

PropVals Book.GetProps ()

PropVals BookComponent.GetProps ()

PropVals CMSConnection.GetProps ()

PropVals CMSObject.CMSGetProperties ()

PropVals CMSObject.GetProps ()

PropVals CMSRegistration.GetProps ()

PropVals CMSSession.GetProps ()

PropVals Cell.GetProps ()

PropVals CharFmt.GetProps ()

PropVals Color.GetProps ()

PropVals CombinedFontDefn.GetProps ()

PropVals Command.GetProps ()

PropVals CondFmt.GetProps ()

PropVals Doc.GetProps ()

PropVals Doc.GetTextProps (textLoc: TextLoc)

PropVals Element.GetProps ()

PropVals ElementDef.GetProps ()

PropVals Ellipse.GetProps ()

PropVals Flow.GetProps ()

PropVals FmtChangeList.GetProps ()

PropVals FmtRule.GetProps ()

PropVals FmtRuleClause.GetProps ()

PropVals Fn.GetProps ()

PropVals Globals.AllocatePropVals (numProps: int)

PropVals Globals.GetExportDefaultParams (: void)

PropVals Globals.GetImportDefaultParams ()

PropVals Globals.GetIteratorDefaultParams ()

PropVals Globals.GetNewXMLDefaultParams ()

PropVals Globals.GetOpenDefaultParams ()

PropVals Globals.GetSaveDefaultParams ()

PropVals Globals.GetUpdateBookDefaultParams ()

PropVals GraphicsFmt.GetProps ()

PropVals Group.GetProps ()

PropVals HiddenPage.GetProps ()

PropVals Inset.GetProps ()

PropVals Iterator.GetNextIteratorItem ()

PropVals Iterator.GetProps ()

PropVals KeyCatalog.GetProps ()

PropVals Line.GetProps ()

PropVals Marker.GetProps ()

PropVals MarkerType.GetProps ()

PropVals MasterPage.GetProps ()

PropVals Math.GetProps ()

PropVals MathML.GetProps ()

PropVals Menu.GetProps ()

PropVals MenuItemSeparator.GetProps ()

PropVals Pgf.GetProps ()

PropVals PgfFmt.GetProps ()

PropVals Polygon.GetProps ()

PropVals Polyline.GetProps ()

PropVals PropVals.concat (value: PropVals)

PropVals Rectangle.GetProps ()

PropVals RefPage.GetProps ()

PropVals RoundRect.GetProps ()

PropVals Row.GetProps ()

PropVals Rubi.GetProps ()

PropVals RulingFmt.GetProps ()

PropVals SubCol.GetProps ()

PropVals Tbl.GetProps ()

PropVals TblFmt.GetProps ()

PropVals TextFrame.GetProps ()

PropVals TextLine.GetProps ()

PropVals TiApiClient.GetProps ()

PropVals TiFlow.GetProps ()

PropVals TiText.GetProps ()

PropVals TiTextTable.GetProps ()

PropVals UnanchoredFrame.GetProps ()

PropVals Var.GetProps ()

PropVals VarFmt.GetProps ()

PropVals XRef.GetProps ()

PropVals XRefFmt.GetProps ()

PropVals app.GetProps ()


Adobe FrameMaker-12 Object Model JS: Rectangle

Class

Rectangle

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
RectangleIsSmoothed | int | readwrite |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

Rectangle Doc.NewRectangle (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: RefPage

Class

RefPage

QuickLinks

 ApplyPageLayout, Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Name | string | readwrite |
PageFrame | UnanchoredFrame | readonly |
PageHeight | int | readonly |
PageNext | RefPage | readonly |
PageNum | int | readonly |
PagePrev | RefPage | readonly |
PageWidth | int | readonly |

Methods

Instances

int ApplyPageLayout (srcPage: PageObject) PageObject is any Page object i.e., BodyPage, MasterPage, ReferencePage, HiddenPage
Parameter | Type | Description
srcPage | PageObject |

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstRefPageInDoc

Doc.LastRefPageInDoc

RefPage.PageNext

RefPage.PagePrev

Return

RefPage Doc.GetNamedRefPage (name: string)

RefPage Doc.NewNamedRefPage (name: string)


Adobe FrameMaker-12 Object Model JS: RoundRect

Class

RoundRect

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Radius | int | readwrite |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

RoundRect Doc.NewRoundRect (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: Row

Class

Row

QuickLinks

 AddRows, Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
CondFmtIsShown | int | readwrite |
Element | Element | readonly |
FirstCellInRow | Cell | readonly |
Height | int | readonly |
InCond | Objects | readwrite |
LocX | int | readonly |
LocY | int | readonly |
NextRowInTbl | Row | readonly |
PrevRowInTbl | Row | readonly |
RowIsShown | int | readonly |
RowKeepWithNext | int | readwrite |
RowKeepWithPrev | int | readwrite |
RowMaxHeight | int | readwrite |
RowMinHeight | int | readwrite |
RowStart | int | readwrite |
RowTbl | Tbl | readonly |
RowType | int | readonly |
SepOverride | Color | readwrite |
StyleOverrides | int | readwrite |
UseSepOverride | int | readwrite |
UserString | string | readwrite |
Width | int | readonly |

Methods

Instances

int AddRows (direction: int, numNewRows: int)
Parameter | Type | Description
direction | int |
numNewRows | int |

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Cell.CellRow

Row.NextRowInTbl

Row.PrevRowInTbl

Tbl.BottomRowSelection

Tbl.FirstRowInTbl

Tbl.LastRowInTbl

Tbl.TopRowSelection

Used in:

int Tbl.DeleteRows (refRow: Row, numDelRows: int)


Adobe FrameMaker-12 Object Model JS: Rubi

Class

Rubi

QuickLinks

 Delete, GetProps, GetText2, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Element | Element | readonly |
NextRubiInDoc | Rubi | readonly |
OyamojiTextRange | TextRange | readonly |
RubiElement | Element | readonly |
RubiTextRange | TextRange | readonly |
Unique | int | readonly |

Methods

Instances

int Delete ()

PropVals GetProps ()

TextItems GetText2 (flags: int, flags2: int)
Parameter | Type | Description
flags | int |
flags2 | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstRubiInDoc

Rubi.NextRubiInDoc


Adobe FrameMaker-12 Object Model JS: RulingFmt

Class

RulingFmt

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Name | string | readwrite |
NextRulingFmtInDoc | RulingFmt | readonly |
Pen | int | readwrite |
RulingGap | int | readwrite |
RulingLines | int | readwrite |
RulingPenWidth | int | readwrite |
RulingSep | Color | readwrite |
UserString | string | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Cell.CellDefaultBottomRuling

Cell.CellDefaultLeftRuling

Cell.CellDefaultRightRuling

Cell.CellDefaultTopRuling

Cell.CellOverrideBottomRuling

Cell.CellOverrideLeftRuling

Cell.CellOverrideRightRuling

Cell.CellOverrideTopRuling

Doc.FirstRulingFmtInDoc

RulingFmt.NextRulingFmtInDoc

Tbl.TblBodyRowRuling

Tbl.TblColRuling

Tbl.TblHFRowRuling

Tbl.TblHFSeparatorRuling

Tbl.TblLeftRuling

Tbl.TblOtherBodyRowRuling

Tbl.TblOtherColRuling

Tbl.TblRightRuling

Tbl.TblTopRuling

TblFmt.TblBodyRowRuling

TblFmt.TblBottomRuling

TblFmt.TblColRuling

TblFmt.TblHFRowRuling

TblFmt.TblHFSeparatorRuling

TblFmt.TblLeftRuling

TblFmt.TblOtherBodyRowRuling

TblFmt.TblOtherColRuling

TblFmt.TblRightRuling

TblFmt.TblTopRuling

Return

RulingFmt Doc.GetNamedRulingFmt (name: string)

RulingFmt Doc.NewNamedRulingFmt (name: string)


Adobe FrameMaker-12 Object Model JS: Strings

Class

Strings

An Array of string objects with integer indexing and a length property.

See also String.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

Strings concat (value: Strings)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | Strings | Any number of values to be added to the end of the array. Can also be arrays.

string pop ()
Removes the last element from the array.

number push (value: string)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | string |

Element of

AFrame.ObjectAttributes

Arc.ObjectAttributes

Attribute.values

AttributeDef.choices

AttributeDef.defValues

AttributeEx.originalValues

AttributeEx.values

Book.CustomElementList

Book.DocAcrobatElementList

Book.PDFDocInfo

Book.XmlStyleSheetList

BookComponent.ExtractElementTags

BookComponent.ExtractTags

CMSInfo.userFields

Command.KeyboardShortcuts

Command.Labels

Doc.CustomElementList

Doc.DefaultExclusions

Doc.DefaultInclusions

Doc.Dictionary

Doc.DocAcrobatElementList

Doc.MarkerTypeNames

Doc.PDFDocInfo

Doc.ReviewerNameList

Doc.SymbolsList

Doc.XmlStyleSheetList

Element.Namespace

ElementDef.AlsoInsert

ElementDef.Exclusions

ElementDef.Inclusions

Ellipse.ObjectAttributes

FilterArgs.args

FmtRule.CountElements

FmtRuleClause.SpecificationForCSS

Group.ObjectAttributes

Inset.InsetU3dAnimationList

Inset.InsetU3dPartList

Inset.InsetU3dViewList

Inset.ObjectAttributes

Line.ObjectAttributes

Math.ObjectAttributes

MathML.MathMLData

MathML.ObjectAttributes

Polygon.ObjectAttributes

Polyline.ObjectAttributes

Rectangle.ObjectAttributes

RoundRect.ObjectAttributes

TextFrame.ObjectAttributes

TextLine.ObjectAttributes

TypedVal.ssval

UnanchoredFrame.ObjectAttributes

app.FontAngleNames

app.FontFamilyNames

app.FontVariationNames

app.FontWeightNames

app.MarkerNames

Used in:

Attribute Attribute.Attribute (name: string, values: Strings, valflags: uint, allow: uint)

AttributeDef AttributeDef.AttributeDef (name: string, required: int, flags: uint, attrType: int, choices: Strings, defValues: Strings, rangeMin: string, rangeMax: string)

AttributeEx AttributeEx.AttributeEx (name: string, values: Strings, originalValues: Strings, valflags: uint, allow: uint, overriddenFlags: uint)

CMSInfo CMSInfo.CMSInfo (cmsName: string, userFields: Strings, userLoginUi: uint)

void CMSRegistration.CMSConfigLoginUI (userFields: Strings, userLoginUI: bool)

int Doc.QuickSelect (prompt: string, stringlist: Strings)

FilterArgs FilterArgs.FilterArgs (infile: string, outfile: string, clname: string, informat: string, outformat: string, binname: string, args: Strings)

void Globals.AppendStringsProp (pv: PropVals, prop: int, val: Strings)

int Globals.ScrollBox (title: string, stringslist: Strings, _default: int)

Strings Strings.concat (value: Strings)

Return

Strings Doc.GetBuildExprCatalog ()

Strings Globals.GetSupportedEncodings ()

Strings KeyCatalog.GetAllKeys ()

Strings Strings.concat (value: Strings)


Adobe FrameMaker-12 Object Model JS: SubCol

Class

SubCol

QuickLinks

 Delete, GetProps, GetText, ObjectValid, SetProps

Properties

Property | Type | Access | Description
ContentHeight | int | readonly |
FirstAFrame | AFrame | readonly |
FirstCell | Cell | readonly |
FirstFn | Fn | readonly |
FirstPgf | Pgf | readonly |
FrameParent | TextFrame | readonly |
Height | int | readonly |
LastAFrame | AFrame | readonly |
LastCell | Cell | readonly |
LastFn | Fn | readonly |
LastPgf | Pgf | readonly |
LocX | int | readonly |
LocY | int | readonly |
NextSubCol | SubCol | readonly |
Overflowed | int | readonly |
ParentTextFrame | TextFrame | readonly |
PrevSubCol | SubCol | readonly |
Unique | int | readonly |
UserString | string | readwrite |
Width | int | readonly |

Methods

Instances

int Delete ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Cell.InTextObj

Fn.InTextObj

SubCol.NextSubCol

SubCol.PrevSubCol

TextFrame.FirstSubCol

TextFrame.LastSubCol


Adobe FrameMaker-12 Object Model JS: Tab

Class

Tab

QuickLinks

 Tab

Properties

Property | Type | Access | Description
decimal | uint | readwrite |
leader | string | readwrite |
type | uint | readwrite |
x | int | readwrite |

Methods

Constructor

Tab Tab (x: int, type: uint, leader: string, decimal: uint)
Parameter | Type | Description
x | int |
type | uint |
leader | string |
decimal | uint |

Example new Tab()

Used in:

number Tabs.push (value: Tab)

Return

Tab Tab.Tab (x: int, type: uint, leader: string, decimal: uint)

Tab Tabs.pop ()


Adobe FrameMaker-12 Object Model JS: Tabs

Class

Tabs

An Array of Tab objects with integer indexing and a length property.

See also Tab.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

Tabs concat (value: Tabs)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | Tabs | Any number of values to be added to the end of the array. Can also be arrays.

Tab pop ()
Removes the last element from the array.

number push (value: Tab)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | Tab |

Element of

FmtChangeList.Tabs

Pgf.Tabs

PgfFmt.Tabs

TypedVal.tsval

Used in:

Tabs Tabs.concat (value: Tabs)

Return

Tabs Tabs.concat (value: Tabs)


Adobe FrameMaker-12 Object Model JS: Tbl

Class

Tbl

QuickLinks

 AddCols, Delete, DeleteCols, DeleteRows, GetProps, MakeTblSelection, ObjectValid, SetProps

Properties

Property | Type | Access | Description
BottomRowSelection | Row | readonly |
ContentHeight | int | readonly |
Element | Element | readonly |
FirstPgf | Pgf | readonly |
FirstRowInTbl | Row | readonly |
HighestLevelElement | Element | readonly |
LastPgf | Pgf | readonly |
LastRowInTbl | Row | readonly |
LeftColNum | int | readonly |
Locked | int | readwrite |
NextTblInDoc | Tbl | readonly |
OrphanRows | int | readwrite |
Overflowed | int | readonly |
RightColNum | int | readonly |
TblAlignment | int | readwrite |
TblBodyElement | Element | readonly |
TblBodyFirstColor | Color | readwrite |
TblBodyFirstFill | int | readwrite |
TblBodyFirstPeriod | int | readwrite |
TblBodyNextColor | Color | readwrite |
TblBodyNextFill | int | readwrite |
TblBodyNextPeriod | int | readwrite |
TblBodyRowRuling | RulingFmt | readwrite |
TblBodyRowRulingPeriod | int | readwrite |
TblBodyShadeBy | int | readwrite |
TblBottomRuling | int | readwrite |
TblCatalogEntry | int | readonly |
TblCellBottomMargin | int | readwrite |
TblCellLeftMargin | int | readwrite |
TblCellRightMargin | int | readwrite |
TblCellTopMargin | int | readwrite |
TblColRuling | RulingFmt | readwrite |
TblColRulingPeriod | int | readwrite |
TblColWidths | Metrics | readwrite |
TblElement | Element | readonly |
TblFooterElement | Element | readonly |
TblHFColor | Color | readwrite |
TblHFFill | int | readwrite |
TblHFRowRuling | RulingFmt | readwrite |
TblHFSeparatorRuling | RulingFmt | readwrite |
TblHeaderElement | Element | readonly |
TblInLockedTi | bool | readwrite |
TblLastBodyRuling | int | readwrite |
TblLeftIndent | int | readwrite |
TblLeftRuling | RulingFmt | readwrite |
TblNumCols | int | readonly |
TblNumRows | int | readonly |
TblNumbering | int | readwrite |
TblOtherBodyRowRuling | RulingFmt | readwrite |
TblOtherColRuling | RulingFmt | readwrite |
TblPlacement | int | readwrite |
TblRightIndent | int | readwrite |
TblRightRuling | RulingFmt | readwrite |
TblSpaceAbove | int | readwrite |
TblSpaceBelow | int | readwrite |
TblTag | string | readwrite |
TblTitleElement | Element | readonly |
TblTitleGap | int | readwrite |
TblTitlePosition | int | readwrite |
TblTitleSelected | int | readonly |
TblTopRuling | RulingFmt | readwrite |
TblWidth | int | readonly |
TextLoc | TextLoc | readwrite |
TopRowSelection | Row | readonly |
Unique | int | readonly |
UserString | string | readwrite |

Methods

Instances

int AddCols (refColNum: int, direction: int, numNewCols: int)
Parameter | Type | Description
refColNum | int |
direction | int |
numNewCols | int |

int Delete ()

int DeleteCols (delColNum: int, numDelCols: int)
Parameter | Type | Description
delColNum | int |
numDelCols | int |

int DeleteRows (refRow: Row, numDelRows: int)
Parameter | Type | Description
refRow | Row |
numDelRows | int |

PropVals GetProps ()

int MakeTblSelection (topRow: int, bottomRow: int, leftCol: int, rightCol: int)
Parameter | Type | Description
topRow | int |
bottomRow | int |
leftCol | int |
rightCol | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstTblInDoc

Doc.SelectedTbl

Row.RowTbl

Tbl.NextTblInDoc

Return

Tbl Doc.NewAnchoredFormattedTbl (format: string, textLoc: TextLoc)

Tbl Doc.NewAnchoredTbl (textloc: TextLoc)

Tbl Doc.NewTable (format: string, numCols: int, numBodyRows: int, numHeaderRows: int, numFooterRows: int, textLoc: TextLoc)


Adobe FrameMaker-12 Object Model JS: TblFmt

Class

TblFmt

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Name | string | readwrite |
NextTblFmtInDoc | TblFmt | readonly |
OrphanRows | int | readwrite |
TblAlignment | int | readwrite |
TblBodyFirstColor | Color | readwrite |
TblBodyFirstFill | int | readwrite |
TblBodyFirstPeriod | int | readwrite |
TblBodyNextColor | Color | readwrite |
TblBodyNextFill | int | readwrite |
TblBodyNextPeriod | int | readwrite |
TblBodyRowRuling | RulingFmt | readwrite |
TblBodyRowRulingPeriod | int | readwrite |
TblBodyShadeBy | int | readwrite |
TblBottomRuling | RulingFmt | readwrite |
TblCatalogEntry | int | readwrite |
TblCellBottomMargin | int | readwrite |
TblCellLeftMargin | int | readwrite |
TblCellRightMargin | int | readwrite |
TblCellTopMargin | int | readwrite |
TblColRuling | RulingFmt | readwrite |
TblColRulingPeriod | int | readwrite |
TblHFColor | Color | readwrite |
TblHFFill | int | readwrite |
TblHFRowRuling | RulingFmt | readwrite |
TblHFSeparatorRuling | RulingFmt | readwrite |
TblInitNumBodyRows | int | readwrite |
TblInitNumCols | int | readwrite |
TblInitNumFRows | int | readwrite |
TblInitNumHRows | int | readwrite |
TblLastBodyRuling | int | readwrite |
TblLeftIndent | int | readwrite |
TblLeftRuling | RulingFmt | readwrite |
TblNumbering | int | readwrite |
TblOtherBodyRowRuling | RulingFmt | readwrite |
TblOtherColRuling | RulingFmt | readwrite |
TblPlacement | int | readwrite |
TblRightIndent | int | readwrite |
TblRightRuling | RulingFmt | readwrite |
TblSpaceAbove | int | readwrite |
TblSpaceBelow | int | readwrite |
TblTag | string | readwrite |
TblTitleGap | int | readwrite |
TblTitlePosition | int | readwrite |
TblTopRuling | RulingFmt | readwrite |
UserString | string | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstTblFmtInDoc

TblFmt.NextTblFmtInDoc

Return

TblFmt Doc.GetNamedTblFmt (name: string)

TblFmt Doc.NewNamedTblFmt (name: string)


Adobe FrameMaker-12 Object Model JS: TemplateData

Class

TemplateData

QuickLinks

 TemplateData

Properties

Property | Type | Access | Description
templateDataAttrs | strings | readwrite |
templateDataType | TemplateDataType | readwrite |

Methods

Constructor

TemplateData TemplateData (templateDataType: TemplateDataType, templateDataAttrs: strings)
Parameter | Type | Description
templateDataType | TemplateDataType |
templateDataAttrs | strings |

Example new TemplateData()

Used in:

number TemplateDatas.push (value: TemplateData)

Return

TemplateData TemplateData.TemplateData (templateDataType: TemplateDataType, templateDataAttrs: strings)

TemplateData TemplateDatas.pop ()


Adobe FrameMaker-12 Object Model JS: TemplateDatas

Class

TemplateDatas

An Array of TemplateData objects with integer indexing and a length property.

See also TemplateData.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

TemplateDatas concat (value: TemplateDatas)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | TemplateDatas | Any number of values to be added to the end of the array. Can also be arrays.

TemplateData pop ()
Removes the last element from the array.

number push (value: TemplateData)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | TemplateData |

Used in:

TemplateDatas TemplateDatas.concat (value: TemplateDatas)

Return

TemplateDatas TemplateDatas.concat (value: TemplateDatas)


Adobe FrameMaker-12 Object Model JS: TextFrame

Class

TextFrame

QuickLinks

 Delete, GetProps, GetText, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
ColGapWidth | int | readwrite |
Color | Color | readwrite |
ColumnsAreBalanced | int | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FirstAFrame | AFrame | readonly |
FirstCell | Cell | readonly |
FirstFn | Fn | readonly |
FirstPgf | Pgf | readonly |
FirstSubCol | SubCol | readonly |
Flow | Flow | readonly |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsButton | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LastAFrame | AFrame | readonly |
LastCell | Cell | readonly |
LastFn | Fn | readonly |
LastPgf | Pgf | readonly |
LastSubCol | SubCol | readonly |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
NextTextFrameInFlow | TextFrame | readwrite |
NumColumns | int | readwrite |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
PrevTextFrameInFlow | TextFrame | readwrite |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
SideHeadGap | int | readwrite |
SideHeadPlacement | int | readwrite |
SideHeadWidth | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

AFrame.InTextFrame

Cell.InTextFrame

Flow.FirstTextFrameInFlow

Flow.LastTextFrameInFlow

Fn.InTextFrame

Pgf.InTextFrame

SubCol.FrameParent

SubCol.ParentTextFrame

TextFrame.NextTextFrameInFlow

TextFrame.PrevTextFrameInFlow

Return

TextFrame Doc.NewTextFrame (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: TextItem

Class

TextItem

Properties

Property | Type | Access | Description
dataType | int | readwrite |
idata | number | readwrite |
obj | any | readwrite |
offset | int | readwrite |
sdata | string | readwrite |

Used in:

void Globals.PrintTextItem (textItem: TextItem)

number TextItems.push (value: TextItem)

Return

TextItem TextItems.pop ()


Adobe FrameMaker-12 Object Model JS: TextItems

Class

TextItems

An Array of TextItem objects with integer indexing and a length property.

See also TextItem.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

TextItems concat (value: TextItems)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | TextItems | Any number of values to be added to the end of the array. Can also be arrays.

TextItem pop ()
Removes the last element from the array.

number push (value: TextItem)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | TextItem |

Used in:

void Globals.PrintTextItems (textItems: TextItems)

TextItems TextItems.concat (value: TextItems)

Return

TextItems Cell.GetText (flags: int)

TextItems Doc.GetTextForRange (tr: TextRange, flags: int)

TextItems Doc.GetTextForRange2 (tr: TextRange, flags: int, flags2: int)

TextItems Element.GetText (flags: int)

TextItems Flow.GetText (flags: int)

TextItems Fn.GetText (flags: int)

TextItems Pgf.GetText (flags: int)

TextItems Rubi.GetText2 (flags: int, flags2: int)

TextItems SubCol.GetText (flags: int)

TextItems TextFrame.GetText (flags: int)

TextItems TextItems.concat (value: TextItems)

TextItems TextLine.GetText (flags: int)

TextItems TiApiClient.GetText (flags: int)

TextItems TiFlow.GetText (flags: int)

TextItems TiText.GetText (flags: int)

TextItems TiTextTable.GetText (flags: int)

TextItems Var.GetText (flags: int)

TextItems XRef.GetText (flags: int)


Adobe FrameMaker-12 Object Model JS: TextLine

Class

TextLine

QuickLinks

 Delete, GetProps, GetText, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BasePointX | int | readwrite |
BasePointY | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
Language | int | readwrite |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TextLineType | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Return

TextLine Doc.NewTextLine (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: TextLoc

Class

TextLoc

QuickLinks

 TextLoc

Properties

Property | Type | Access | Description
obj | any | readwrite |
offset | int | readwrite |

Methods

Constructor

TextLoc TextLoc (obj: any, offset: int)
Parameter | Type | Description
obj | any |
offset | int |

Example new TextLoc()

Element of

AFrame.TextLoc

Fn.TextLoc

Marker.TextLoc

Tbl.TextLoc

TextRange.beg

TextRange.end

TypedVal.tlval

Used in:

Object Book.Import (textLocP: TextLoc, filename: string, importParams: PropVals, importReturnParams: PropVals)

TextLoc Doc.AddText (textLoc: TextLoc, text: string)

TextRange Doc.Find (textLoc: TextLoc, findParams: PropVals)

PropVal Doc.GetTextPropVal (textLoc: TextLoc, propNum: int)

PropVals Doc.GetTextProps (textLoc: TextLoc)

TypedVal Doc.GetTextVal (textLoc: TextLoc, propNum: int)

Object Doc.Import (textLocP: TextLoc, filename: string, importParams: PropVals, importReturnParams: PropVals)

AFrame Doc.NewAnchoredAFrame (textloc: TextLoc)

Fn Doc.NewAnchoredFn (textloc: TextLoc)

Object Doc.NewAnchoredFormattedObject (objType: int, format: string, textLoc: TextLoc)

Tbl Doc.NewAnchoredFormattedTbl (format: string, textLoc: TextLoc)

Var Doc.NewAnchoredFormattedVar (format: string, textLoc: TextLoc)

XRef Doc.NewAnchoredFormattedXRef (format: string, textLoc: TextLoc)

Marker Doc.NewAnchoredMarker (textloc: TextLoc)

Object Doc.NewAnchoredObject (objType: int, textloc: TextLoc)

Tbl Doc.NewAnchoredTbl (textloc: TextLoc)

TiApiClient Doc.NewAnchoredTiApiClient (textloc: TextLoc)

Tbl Doc.NewTable (format: string, numCols: int, numBodyRows: int, numHeaderRows: int, numFooterRows: int, textLoc: TextLoc)

ElementLoc Doc.TextLocToElementLoc (tloc: TextLoc)

Element ElementDef.NewElement (textLoc: TextLoc)

TextRange TextRange.TextRange (beg: TextLoc, end: TextLoc)

Return

TextLoc Doc.AddText (textLoc: TextLoc, text: string)

TextLoc Doc.ElementLocToTextLoc (eloc: ElementLoc)

TextLoc TextLoc.TextLoc (obj: any, offset: int)


Adobe FrameMaker-12 Object Model JS: TextRange

Class

TextRange

QuickLinks

 TextRange

Properties

Property | Type | Access | Description
beg | TextLoc | readwrite |
end | TextLoc | readwrite |

Methods

Constructor

TextRange TextRange (beg: TextLoc, end: TextLoc)
Parameter | Type | Description
beg | TextLoc |
end | TextLoc |

Example new TextRange()

Element of

Doc.TextSelection

Element.TextRange

Rubi.OyamojiTextRange

Rubi.RubiTextRange

TiApiClient.TextRange

TiFlow.TextRange

TiText.TextRange

TiTextTable.TextRange

TypedVal.trval

Var.TextRange

XRef.TextRange

Used in:

int Doc.CenterOnText (textRange: TextRange)

int Doc.DeleteText (textRange: TextRange)

TextItems Doc.GetTextForRange (tr: TextRange, flags: int)

TextItems Doc.GetTextForRange2 (tr: TextRange, flags: int, flags2: int)

int Doc.ScrollToText (textRange: TextRange)

void Doc.SetTextPropVal (textRange: TextRange, setVal: PropVal)

void Doc.SetTextProps (textRange: TextRange, setVal: PropVals)

void Doc.SetTextVal (textRange: TextRange, propNum: int, setVal: TypedVal)

Return

TextRange Doc.Find (textLoc: TextLoc, findParams: PropVals)

TextRange TextRange.TextRange (beg: TextLoc, end: TextLoc)


Adobe FrameMaker-12 Object Model JS: TiApiClient

Class

TiApiClient

QuickLinks

 ConvertToText, Delete, DeletePropByName, DeleteTextInsetContents, GetProps, GetText, ObjectValid, SetProps, UpdateTextInset

Properties

Property | Type | Access | Description
ImportHint | string | readwrite |
LastUpdate | int | readwrite |
Name | string | readwrite |
NextTiInDoc | FMObject | readonly |
TextRange | TextRange | readonly |
TiAutomaticUpdate | int | readwrite |
TiClientData | string | readwrite |
TiClientName | string | readwrite |
TiClientSource | string | readwrite |
TiClientType | string | readwrite |
TiFile | string | readwrite |
TiFileModDate | string | readwrite |
TiIsUnresolved | int | readwrite |
TiLocked | int | readwrite |
TiMacEdition | int | readonly |
Unique | int | readonly |

Methods

Instances

void ConvertToText ()

int Delete ()

void DeletePropByName (propName: string)
Parameter | Type | Description
propName | string |

int DeleteTextInsetContents ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

int UpdateTextInset ()

Return

TiApiClient Doc.NewAnchoredTiApiClient (textloc: TextLoc)


Adobe FrameMaker-12 Object Model JS: TiFlow

Class

TiFlow

QuickLinks

 ConvertToText, Delete, DeletePropByName, DeleteTextInsetContents, GetProps, GetText, ObjectValid, SetProps, UpdateTextInset

Properties

Property | Type | Access | Description
ImportHint | string | readwrite |
LastUpdate | int | readwrite |
Name | string | readwrite |
NextTiInDoc | FMObject | readonly |
TextRange | TextRange | readonly |
TiAutomaticUpdate | int | readwrite |
TiFile | string | readwrite |
TiFileModDate | string | readwrite |
TiFlowName | string | readwrite |
TiFlowPageSpace | int | readwrite |
TiFormat | int | readwrite |
TiLocked | int | readwrite |
TiMacEdition | int | readonly |
TiMainFlow | int | readwrite |
TiRemoveOverrides | int | readwrite |
TiRemovePageBreaks | int | readwrite |
Unique | int | readonly |

Methods

Instances

void ConvertToText ()

int Delete ()

void DeletePropByName (propName: string)
Parameter | Type | Description
propName | string |

int DeleteTextInsetContents ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

int UpdateTextInset ()


Adobe FrameMaker-12 Object Model JS: TiText

Class

TiText

QuickLinks

 ConvertToText, Delete, DeletePropByName, DeleteTextInsetContents, GetProps, GetText, ObjectValid, SetProps, UpdateTextInset

Properties

Property | Type | Access | Description
ImportHint | string | readwrite |
LastUpdate | int | readwrite |
Name | string | readwrite |
NextTiInDoc | FMObject | readonly |
TextRange | TextRange | readonly |
TiAutomaticUpdate | int | readwrite |
TiEOLisEOP | int | readwrite |
TiFile | string | readwrite |
TiFileModDate | string | readwrite |
TiLocked | int | readwrite |
TiMacEdition | int | readonly |
TiTextEncoding | string | readonly |
Unique | int | readonly |

Methods

Instances

void ConvertToText ()

int Delete ()

void DeletePropByName (propName: string)
Parameter | Type | Description
propName | string |

int DeleteTextInsetContents ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

int UpdateTextInset ()


Adobe FrameMaker-12 Object Model JS: TiTextTable

Class

TiTextTable

QuickLinks

 ConvertToText, Delete, DeletePropByName, DeleteTextInsetContents, GetProps, GetText, ObjectValid, SetProps, UpdateTextInset

Properties

Property | Type | Access | Description
ImportHint | string | readwrite |
LastUpdate | int | readwrite |
Name | string | readwrite |
NextTiInDoc | FMObject | readonly |
TextRange | TextRange | readonly |
TiAutomaticUpdate | int | readwrite |
TiByRows | int | readwrite |
TiFile | string | readwrite |
TiFileModDate | string | readwrite |
TiHeadersEmpty | int | readwrite |
TiLocked | int | readwrite |
TiMacEdition | int | readonly |
TiNumCols | int | readwrite |
TiNumHeaderRows | int | readwrite |
TiNumSeparators | int | readwrite |
TiSeparator | string | readwrite |
TiTblTag | string | readwrite |
TiTextEncoding | string | readonly |
Unique | int | readonly |

Methods

Instances

void ConvertToText ()

int Delete ()

void DeletePropByName (propName: string)
Parameter | Type | Description
propName | string |

int DeleteTextInsetContents ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

int UpdateTextInset ()


Adobe FrameMaker-12 Object Model JS: TypedVal

Class

TypedVal

Properties

Property | Type | Access | Description
adsval | AttributeDefs AttributeDef | readwrite |
asval | Attribute | readwrite |
asvalEx | AttributeEx | readwrite |
csval | ElementCatalogEntries ElementCatalogEntry | readwrite |
isval | Ints | readwrite |
ival | int | readwrite |
msval | Metrics | readwrite |
obj | any | readwrite |
osval | Objects | readwrite |
psval | Points Point | readwrite |
ssval | Strings String | readwrite |
sval | string | readwrite |
tlval | TextLoc | readwrite |
trval | TextRange | readwrite |
tsval | Tabs Tab | readwrite |
uisval | UInts | readwrite |
valType | int | readwrite |
valsval | TypedVals TypedVal | readwrite |

Element of

ElementDef.AlsoInserts

PropVal.propVal

Used in:

void Doc.SetTextVal (textRange: TextRange, propNum: int, setVal: TypedVal)

void Globals.AppendVal (pv: PropVals, prop: int, val: TypedVal)

void KeyCatalog.UpdateKeyDefinition (key: string, keyField: int, valuep: TypedVal)

PropVal PropVal.PropVal (propIdent: PropIdent, propVal: TypedVal)

number TypedVals.push (value: TypedVal)

Return

TypedVal Doc.GetTextVal (textLoc: TextLoc, propNum: int)

TypedVal KeyCatalog.GetKeyDefinition (key: string, keyField: int)

TypedVal TypedVals.pop ()


Adobe FrameMaker-12 Object Model JS: TypedVals

Class

TypedVals

An Array of TypedVal objects with integer indexing and a length property.

See also TypedVal.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

TypedVals concat (value: TypedVals)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | TypedVals | Any number of values to be added to the end of the array. Can also be arrays.

TypedVal pop ()
Removes the last element from the array.

number push (value: TypedVal)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | TypedVal |

Element of

CMSProperty.values

TypedVal.valsval

Used in:

bool CMSObject.CMSShowCommonListUI (commandId: int, title: string, columnProperties: TypedVals)

CMSProperty CMSProperty.CMSProperty (prop: uint, label: string, isMultiValue: uint, isEditable: uint, values: TypedVals)

TypedVals TypedVals.concat (value: TypedVals)

Return

TypedVals Book.GetDependencies (depMode: int)

TypedVals Doc.GetDependencies (depMode: int)

TypedVals Globals.CallClientEx (clname: string, arg: string)

TypedVals KeyCatalog.GetAllKeyDefinitions (filterType: int)

TypedVals TypedVals.concat (value: TypedVals)


Adobe FrameMaker-12 Object Model JS: UBytes

Class

UBytes

An Array of uint objects with integer indexing and a length property.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

UBytes concat (value: UBytes)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | UBytes | Any number of values to be added to the end of the array. Can also be arrays.

uint pop ()
Removes the last element from the array.

number push (value: uint)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | uint |

Used in:

void Inset.SetUBytesByName (propName: string, setVal: UBytes)

UBytes UBytes.concat (value: UBytes)

Return

UBytes Inset.GetUBytesByName (propName: string)

UBytes UBytes.concat (value: UBytes)


Adobe FrameMaker-12 Object Model JS: UInts

Class

UInts

An Array of uint objects with integer indexing and a length property.

QuickLinks

 concat, pop, push

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Instances

UInts concat (value: UInts)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | UInts | Any number of values to be added to the end of the array. Can also be arrays.

uint pop ()
Removes the last element from the array.

number push (value: uint)
Places value onto the end of the array.
Returns the new length of the array.
Parameter | Type | Description
value | uint |

Element of

Book.ViewOnlyDeadCodes

Command.Fcodes

Doc.ViewOnlyDeadCodes

TypedVal.uisval

Used in:

UInts UInts.concat (value: UInts)

Return

UInts UInts.concat (value: UInts)


Adobe FrameMaker-12 Object Model JS: UnanchoredFrame

Class

UnanchoredFrame

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Angle | int | readwrite |
ArrowBaseAngle | int | readwrite |
ArrowLength | int | readwrite |
ArrowScaleFactor | int | readwrite |
ArrowScaleHead | int | readwrite |
ArrowTipAngle | int | readwrite |
ArrowType | int | readwrite |
BorderWidth | int | readwrite |
Color | Color | readwrite |
Dash | Metrics | readwrite |
Fill | int | readwrite |
FirstGraphicInFrame | FMObject | readonly |
FirstGraphicInFrame | FMObject | readonly |
FrameParent | FMObject | readwrite |
GraphicCantBeSelected | int | readwrite |
GraphicIsSelected | int | readwrite |
GroupParent | Group | readwrite |
HeadArrow | int | readwrite |
Height | int | readwrite |
HotspotCmdStr | string | readwrite |
HotspotTitle | string | readwrite |
IsHotspot | int | readwrite |
LastGraphicInFrame | FMObject | readonly |
LastGraphicInFrame | FMObject | readonly |
LineCap | int | readwrite |
LocX | int | readwrite |
LocY | int | readwrite |
Name | string | readwrite |
NextGraphicInDoc | FMObject | readonly |
NextGraphicInFrame | FMObject | readwrite |
NextGraphicInGroup | FMObject | readonly |
NextSelectedGraphicInDoc | FMObject | readonly |
ObjectAttributes | Strings String | readwrite |
Overprint | int | readwrite |
PageFramePage | FMObject | readonly |
Pen | int | readwrite |
PrevGraphicInFrame | FMObject | readwrite |
PrevGraphicInGroup | FMObject | readonly |
Runaround | int | readwrite |
RunaroundGap | int | readwrite |
TailArrow | int | readwrite |
TintPercent | int | readwrite |
Unique | int | readonly |
Width | int | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

BodyPage.PageFrame

HiddenPage.PageFrame

MasterPage.PageFrame

RefPage.PageFrame

Return

UnanchoredFrame Doc.GetNamedUnanchoredFrame (name: string)

UnanchoredFrame Doc.NewUnanchoredFrame (parent: FrameObject)


Adobe FrameMaker-12 Object Model JS: Var

Class

Var

QuickLinks

 Delete, GetProps, GetText, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Element | Element | readonly |
Locked | int | readwrite |
NextVarInDoc | Var | readonly |
TextRange | TextRange | readonly |
Unique | int | readonly |
UserString | string | readwrite |
VarFmt | VarFmt | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstVarInDoc

Var.NextVarInDoc

Return

Var Doc.NewAnchoredFormattedVar (format: string, textLoc: TextLoc)


Adobe FrameMaker-12 Object Model JS: VarFmt

Class

VarFmt

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Fmt | string | readwrite |
Name | string | readwrite |
NextVarFmtInDoc | VarFmt | readonly |
SystemVar | int | readonly |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstVarFmtInDoc

Var.VarFmt

VarFmt.NextVarFmtInDoc

Return

VarFmt Doc.GetNamedVarFmt (name: string)

VarFmt Doc.NewNamedVarFmt (name: string)


Adobe FrameMaker-12 Object Model JS: XRef

Class

XRef

QuickLinks

 Delete, GetProps, GetText, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Element | Element | readonly |
Locked | int | readwrite |
NextXRefInDoc | XRef | readonly |
TextRange | TextRange | readonly |
Unique | int | readonly |
UserString | string | readwrite |
XRefAltText | string | readwrite |
XRefClientName | string | readwrite |
XRefClientType | string | readwrite |
XRefFile | string | readwrite |
XRefFmt | XRefFmt | readwrite |
XRefIsUnresolved | int | readonly |
XRefSrcElemNonUniqueId | string | readwrite |
XRefSrcIsElem | int | readwrite |
XRefSrcText | string | readwrite |

Methods

Instances

int Delete ()

PropVals GetProps ()

TextItems GetText (flags: int)
Parameter | Type | Description
flags | int |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstXRefInDoc

XRef.NextXRefInDoc

Used in:

int Doc.UpdateXRef (srcDoc: Doc, xref: XRef)

Return

XRef Doc.NewAnchoredFormattedXRef (format: string, textLoc: TextLoc)


Adobe FrameMaker-12 Object Model JS: XRefFmt

Class

XRefFmt

QuickLinks

 Delete, GetProps, ObjectValid, SetProps

Properties

Property | Type | Access | Description
Fmt | string | readwrite |
Name | string | readwrite |
NextXRefFmtInDoc | XRefFmt | readonly |

Methods

Instances

int Delete ()

PropVals GetProps ()

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |

Element of

Doc.FirstXRefFmtInDoc

XRef.XRefFmt

XRefFmt.NextXRefFmtInDoc

Return

XRefFmt Doc.GetNamedXRefFmt (name: string)

XRefFmt Doc.NewNamedXRefFmt (name: string)


Adobe FrameMaker-12 Object Model JS: app

Class

app

QuickLinks

 Close, GetNamedBook, GetNamedCommand, GetNamedMenu, GetNamedMenuItemSeparator, GetNamedObject, GetProps, NewNamedBook, NewNamedCommand, NewNamedMenu, NewNamedMenuItemSeparator, NewNamedObject, ObjectValid, SetProps

Properties

Property | Type | Access | Description
ActiveBook | Book | readwrite |
ActiveDoc | Doc | readwrite |
ActiveView | string | readwrite |
AddMarkerTypeToStandardMarkers | string | readwrite |
AllowNewFileURL | bool | readwrite |
ApplyFormatRules | int | readwrite |
AutoBackup | int | readwrite |
AutoSave | int | readwrite |
AutoSaveSeconds | int | readwrite |
BinDir | string | readonly |
CharacterReferencesOnXMLExport | bool | readwrite |
CurrentDir | string | readonly |
CurrentMenuSet | int | readwrite |
DefaultKeyCatalog | KeyCatalog | readwrite |
DefaultVectorFormatForXMLExport | string | readwrite |
DisplayName | string | readonly |
Displaying | int | readwrite |
DoNotExportInvalidXML | bool | readwrite |
DoNotGenerateErrorLog | int | readwrite |
DoPostXSLTValidationOnExport | bool | readwrite |
DocOpenClientEncounteredErrors | int | readwrite |
DontShowWelcomeScreen | bool | readwrite |
EnableAutoSpellCheck | bool | readwrite |
FMConsoleString | string | readwrite |
FirstCommandInSession | Command | readwrite |
FirstKeyCatalogInSession | KeyCatalog | readonly |
FirstMenuItemInSession | FMObject | readonly |
FirstOpenBook | Book | readonly |
FirstOpenDoc | Doc | readonly |
FontAngleNames | Strings String | readonly |
FontFamilyAttributes | Ints | readonly |
FontFamilyNames | Strings String | readonly |
FontVariationNames | Strings String | readonly |
FontWeightNames | Strings String | readonly |
Gravity | int | readwrite |
GreekSize | int | readwrite |
HelpDir | string | readonly |
HomeDir | string | readonly |
HostName | string | readonly |
IconBarOn | int | readwrite |
InitDir | string | readonly |
InsetURL | bool | readwrite |
IsFMRunningInTrialPeriod | bool | readwrite |
IsIconified | int | readwrite |
IsInFront | int | readwrite |
IsOnScreen | int | readwrite |
IsTechnicalSuiteLicensed | int | readonly |
IsTempOpenSave | int | readonly |
KeyCatalogWorkflow | int | readwrite |
Label | string | readwrite |
Language | int | readonly |
MarkerNames | Strings String | readonly |
No3DInPDF | bool | readwrite |
NoFlashInPDF | bool | readwrite |
NoMultiMediaInPDF | bool | readwrite |
OpenAndSaveXmlBookComponentDoc | bool | readwrite |
OpenDir | string | readwrite |
OperatingSystem | string | readonly |
Path | string | readonly |
Platform | string | readonly |
ProcessNumber | int | readwrite |
ProductFamily | string | readonly |
ProductIsDemo | bool | readwrite |
ProductIsStructured | bool | readwrite |
ProductName | string | readonly |
Reformatting | int | readwrite |
RememberMissingFontNames | int | readwrite |
RemoveExtraWhiteSpacesOnXMLImport | bool | readwrite |
RpcProgramNumber | int | readwrite |
RpcPropertyName | string | readwrite |
ScreenHeight | int | readwrite |
ScreenWidth | int | readwrite |
ScreenX | int | readwrite |
ScreenY | int | readwrite |
SgmlDir | string | readonly |
Snap | int | readwrite |
StackWarningLevel | int | readwrite |
StructureDir | string | readonly |
SuppressXMLParserWarnings | bool | readwrite |
TechSuiteInternal | int | readwrite |
TmpDir | string | readonly |
UndoFDKRecording | bool | readwrite |
UserHomeDir | string | readonly |
UserLogin | string | readonly |
UserName | string | readonly |
UserSettingsDir | string | readonly |
UserString | string | readwrite |
Validating | int | readwrite |
VersionMajor | int | readonly |
VersionMinor | int | readonly |
VersionRevision | int | readonly |
WindowSystem | string | readonly |
XmlDir | string | readonly |
XmlIsBook | bool | readwrite |

Methods

Instances

int Close (flags: int)
Parameter | Type | Description
flags | int |

Book GetNamedBook (name: string)
Parameter | Type | Description
name | string |

Command GetNamedCommand (name: string)
Parameter | Type | Description
name | string |

Menu GetNamedMenu (name: string)
Parameter | Type | Description
name | string |

MenuItemSeparator GetNamedMenuItemSeparator (name: string)
Parameter | Type | Description
name | string |

Object GetNamedObject (objType: int, name: string)
Parameter | Type | Description
objType | int |
name | string |

PropVals GetProps ()

Book NewNamedBook (name: string)
Parameter | Type | Description
name | string |

Command NewNamedCommand (name: string)
Parameter | Type | Description
name | string |

Menu NewNamedMenu (name: string)
Parameter | Type | Description
name | string |

MenuItemSeparator NewNamedMenuItemSeparator (name: string)
Parameter | Type | Description
name | string |

Object NewNamedObject (objType: int, name: string)
Parameter | Type | Description
objType | int |
name | string |

int ObjectValid ()

void SetProps (setVal: PropVals)
Parameter | Type | Description
setVal | PropVals |


Adobe FrameMaker-12 Object Model JS: Table of Contents, JavaScript Base Classes

Adobe FrameMaker-12 Object Model

Contents

JavaScript Base Classes

Basic JavaScript programming starts here.

Adobe FrameMaker-12.0

JavaScript Base Classes

ScriptUI Classes

$

Array

Boolean

Date

Error

File

Folder

Function

Global Elements

Math (JS)

Namespace

Number

Object

QName

Reflection

ReflectionInfo

RegExp

Socket

String

UnitValue

XML

XMLList


Adobe FrameMaker-12 Object Model JS: $

Class

$

The $ object provides a number of debugging facilities and informational methods.

QuickLinks

 about, bp, colorPicker, evalFile, gc, getenv, setenv, sleep, toString, write, writeln

Class

Property | Type | Access | Description
build | string | readonly | The ExtendScript build information.
buildDate | Date | readonly | The ExtendScript build date.
decimalPoint | string | r/w | The character used as the decimal point character in formatted numeric output.
engineName | string | readonly | The name of the current ExtendScript engine, if set.
error Error r/w The most recent run-time error information.
Assigning error text to this property generates a run-time error; however, the preferred way to generate a run-time error is to throw an Error object.
fileName | string | readonly | The file name of the current script.
flags number r/w Gets or sets low-level debug output flags.
A logical AND of bit flag values:
• 0x0002 (2): Displays each line with its line number as it is executed.
• 0x0040 (64): Enables excessive garbage collection. Usually, garbage collection starts when the number of objects has increased by a certain amount since the last garbage collection. This flag causes ExtendScript to garbage collect after almost every statement. This impairs performance severely, but is useful when you suspect that an object gets released too soon.
• 0x0080 (128): Displays all calls with their arguments and the return value.
• 0x0100 (256): Enables extended error handling (see strict).
• 0x0200 (512): Enables the localization feature of the toString method. Equivalent to the localize property.
global | Object | readonly | A reference to the global object, which contains the JavaScript global namespace.
hiresTimer | number | readonly | A high-resolution timer, measuring the time in microseconds. The timer starts when ExtendScript is initialized during the application startup sequence. Every read access resets the timer to Zero.
includePath | string | readonly | The path for include files for the current script.
level number r/w The current debugging level, which enables or disables the JavaScript debugger.
One of 0 (no debugging), 1 (break on runtime errors), or 2 (full debug mode).
line | number | readonly | The current line number of the currently executing script.
locale string r/w Gets or sets the current locale.
The string contains five characters in the form LL_RR, where LL is an ISO 639 language specifier, and RR is an ISO 3166 region specifier.
Initially, this is the value that the application or the platform returns for the current user. You can set it to temporarily change the locale for testing. To return to the application or platform setting, set to undefined, null, or the empty string.
localize | bool | r/w | Set to true to enable the extended localization features of the built-in toString() method.
memCache | number | r/w | The ExtendScript memory cache size, in bytes.
os string readonly The current operating system version information.
Example $.os
Result: Windows XP 5.1 Service Pack 2
screens Array of Object readonly An array of objects containing information about the display screens attached to your computer.
Each object has the properties left, top, right, bottom, which contain the four corners of each screen in global coordinates.
A property primary is true if that object describes the primary display.
stack | string | readonly | The current stack trace.
strict any r/w Sets or clears strict mode for object modification.
When true, any attempt to write to a read-only property causes a runtime error. Some objects do not permit the creation of new properties when true.
version string readonly The version number of the ExtendScript engine.
Formatted as a three-part number and description; for example: "3.92.95 (debug)".

Methods

string about ()
Shows an About box for the ExtendScript component, and returns the text for the box.

void bp ([condition: any])
Breaks execution at the current position.
Parameter | Type | Description
condition | any | A string containing a JavaScript statement to be used as a condition. If the statement evaluates to true or nonzero when this point is reached, execution stops. (Optional)

number colorPicker (color: number)
Invokes the platform-specific color selection dialog, and returns the selected color.
Parameter | Type | Description
color | number | The color to be preselected in the dialog, as 0xRRGGBB, or -1 for the platform default.

any evalFile (file: File[, timeout: number=10000])
Loads and evaluates a file.
Parameter | Type | Description
file | File | The file to load.
timeout | number | An optional timeout in milliseconds. (default: 10000) (Optional)

void gc ()
Initiates garbage collection in the ExtendScript engine.

string getenv (name: string)
Retrieves the value of an environment variable.
Parameter | Type | Description
name | string | The name of the variable.

void setenv (name: string, value: string)
Sets the value of an environment variable.
Parameter | Type | Description
name | string | The name of the variable.
value | string | The value of the variable.

void sleep (msecs: number)
Suspends the calling thread for a number of milliseconds.
During a sleep period, checks at 100 millisecond intervals to see whether the sleep should be terminated. This can happen if there is a break request, or if the script timeout has expired.
Parameter | Type | Description
msecs | number | Number of milliseconds to sleep.

string toString ()
Converts this object to a string.

void write (text: any)
Prints text to the Console.
Parameter | Type | Description
text | any | The text to print. All arguments are concatenated.

void writeln (text: any)
Prints text to the Console, and adds a newline character.
Parameter | Type | Description
text | any | The text to print. All arguments are concatenated.


Adobe FrameMaker-12 Object Model JS: Array

Class

Array

An array with integer indexing and a length property.

QuickLinks

 Array, concat, join, pop, push, reverse, shift, slice, sort, splice, toLocaleString, toSource, toString, unshift

Properties

Property | Type | Access | Description
length | number | r/w | The length of the array

Methods

Constructor

Array Array (length: number[, element: any])
Creates and returns a new array.
Takes any number of parameters, which become the elements of the array, or a single value which becomes the length of an empty array. Note that you cannot create a one-element array, as the single parameter value is interpreted as the length. Returns the new array.
Parameter | Type | Description
length | number | If no other parameters are passed, the initial length of the empty array. Otherwise, the first element.
element | any | If there is more than one parameter, the array is initialized with the given parameters. (Optional)

Example new Array()
new Array (length)
new Array (11, 22, 33, 44)

Instances

Array concat (value: any)
Returns a new array created by concatenating the given values to the end of the original array.
The original array is unchanged. If an array is provided as a parameter to concat(), each of its elements are appended as separate array elements at the end of the new array. Returns a new array, the result of concatenation the given values to the end of the original array.
Parameter | Type | Description
value | any | Any number of values to be added to the end of the array. Can also be arrays.

Example array.concat(value1,...valueN)

string join ([delimiter: string])
Joins all elements of the array into a string; optionally, each element is separated by delimiter.
Returns the string containing the joined elements and delimiters.
Parameter | Type | Description
delimiter | string | A string used to separate each element of the array. If omitted, the array elements are separated with a comma. (Optional)

Example array.join(delimiter)

any pop ()
Removes the last element from the array, decreases the length by 1, and returns the value of the element.
Returns the value of the deleted array element.

Example array.pop()

number push (value: number)
Places one or more values onto the end of the array and increases length by n.
Returns the new length of the array.
Parameter | Type | Description
value | number | Any number of values to be pushed onto the end of the array.

Example array.push(value1,...valueN)

Array reverse ()
Reverses the order of the elements in the array.
Returns the reversed array.

Example array.reverse()

any shift ()
Removes the first element from the array, decreases the length by 1, and returns the value of the element.
Returns the value of the deleted array element.

Example array.shift()

Array slice ()
Creates a new array, which contains a subset of the original array's elements.
The slice begins with the index start, and continues up to, but not including the index, end. If start or end is a negative number, the indexed is resolved counting backwards from the end of the array resulting in the element array[array. length + negativeIndex]. Returns a new array containing elements array[start] through array[end-1].

Example array.slice(start, end)

void sort (userFunction: Function)
Sorts the elements of the array in place, using the given function to compare to elements.
If no function is provided, the elements are sorted alphabetically. Returns no return value.
Parameter | Type | Description
userFunction | Function | A user-supplied function of the form userFunction(a, b) which returns less than 0 if a is greater than b, 0 if a and b are equal, and greater than 0 if b is greater than a.

Example array.sort(userFunction)

Array splice (start: number[, num: number][, value: any])
Removes num elements from the array beginning with index, start.
Optionally insert new elements beginning at index start. To ensure contiguity, elements are moved up to fill in any gaps. Returns a new array containing any elements deleted from the original array.
Parameter | Type | Description
start | number | The index of the first element to remove. Negative values are relative to the end of the array.
num | number | The number of array elements to remove, including start. If omitted, all elements from array index start to the end of the array are removed. (Optional)
value | any | A list of one or more values to be added to the array starting at index start. Must specify a value for num, to use this argument. (Optional)

Example array.splice(start, num, value1, ...valuen)

string toLocaleString ()
Converts an array to a string and returns the string (localized).

string toSource ()
Creates a string representation of this object that can be fed back to eval() to re-create an object. Works only with built-in classes.

string toString ()
Converts an array to a string and returns the string.
Yields the same result as array. join() when called without a parameter. Returns a comma-separated list of all the elements of the array.

Example array.toString()

number unshift (value: any)
Adds one or more elements to the beginning of the array.
Returns the new array length.
Parameter | Type | Description
value | any | The values of one or more elements to be added to the beginning of the array.

Example array.unshift(value1,...valuen)

Element of

ListItem.subItems

Used in:

any Function.apply (thisObj: Object, args: Array)

Return

Array Array.Array (length: number[, element: any])

Array Array.concat (value: any)

Array Array.reverse ()

Array Array.slice ()

Array Array.splice (start: number[, num: number][, value: any])

Array Folder.getFiles (mask: any)

Array RegExp.exec (text: string)

Array String.match (regexp: RegExp)

Array XML.inScopeNamespaces ()

Array XML.namespaceDeclarations ()


Adobe FrameMaker-12 Object Model JS: Boolean

Class

Boolean

Wraps a Boolean value.

QuickLinks

 Boolean, toSource, toString, valueOf

Methods

Constructor

bool Boolean (value: any)
Creates and returns a new Boolean object set to the value of the argument converted to a boolean.
Parameter | Type | Description
value | any | The value to be converted to a Boolean.

Example new Boolean(value)

Instances

string toSource ()
Creates a string representation of this object that can be fed back to eval() to re-create an object. Works only with built-in classes.

string toString ()
Returns the string representation of the value of bool.
The method returns the string true if the primitive value of bool is true; otherwise it returns the string false.

Example bool.toString()

bool valueOf ()
Returns the primitive value of bool.
The method returns true if the primitive value of bool is true; otherwise it returns false.

Example bool.valueOf()

Element of

Button.active

Button.enabled

Button.visible

Checkbox.active

Checkbox.enabled

Checkbox.value

Checkbox.visible

DrawState.altKeyPressed

DrawState.capsLockKeyPressed

DrawState.cmdKeyPressed

DrawState.ctrlKeyPressed

DrawState.hasFocus

DrawState.leftButtonPressed

DrawState.middleButtonPressed

DrawState.mouseOver

DrawState.numLockKeyPressed

DrawState.optKeyPressed

DrawState.rightButtonPressed

DrawState.shiftKeyPressed

DropDownList.active

DropDownList.enabled

DropDownList.visible

EditText.active

EditText.enabled

EditText.visible

Event.bubbles

Event.cancelable

Event.captures

Event.currentTarget

FlashPlayer.active

FlashPlayer.enabled

FlashPlayer.visible

Group.enabled

Group.visible

IconButton.active

IconButton.enabled

IconButton.visible

KeyboardState.altKey

KeyboardState.ctrlKey

KeyboardState.metaKey

KeyboardState.shiftKey

ListBox.active

ListBox.enabled

ListBox.visible

ListItem.checked

ListItem.expanded

ListItem.selected

Panel.enabled

Panel.visible

Progressbar.enabled

Progressbar.visible

RadioButton.active

RadioButton.enabled

RadioButton.value

RadioButton.visible

Scrollbar.active

Scrollbar.enabled

Scrollbar.visible

Slider.active

Slider.enabled

Slider.visible

StaticText.active

StaticText.enabled

StaticText.visible

TreeView.active

TreeView.enabled

TreeView.visible

UIEvent.bubbles

UIEvent.cancelable

UIEvent.captures

UIEvent.currentTarget

Window.active

Window.enabled

Window.maximized

Window.minimized

Window.visible

Used in:

Boolean Button.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Button.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Checkbox.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Checkbox.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean DropDownList.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean DropDownList.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean EditText.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean EditText.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean FlashPlayer.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void FlashPlayer.playMovie ([rewind: Boolean=false])

Boolean FlashPlayer.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Group.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Group.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean IconButton.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean IconButton.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean ListBox.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean ListBox.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Panel.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Panel.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Progressbar.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Progressbar.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean RadioButton.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean RadioButton.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Scrollbar.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Scrollbar.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Slider.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Slider.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean StaticText.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean StaticText.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean TreeView.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean TreeView.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

UIEvent UIEvent.UIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])

void UIEvent.initEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, cancelable: Boolean=false])

void UIEvent.initUIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])

Boolean Window.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void Window.alert (message: String[, title: String][, errorIcon: Boolean=false])

Boolean Window.confirm (message: String[, noAsDefault: Boolean=false][, title: String])

Boolean Window.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Return

Boolean Button (SUI).addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Button (SUI).removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Checkbox (SUI).addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Checkbox (SUI).removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean DropDownList.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean DropDownList.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean EditText.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean EditText.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean FlashPlayer.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean FlashPlayer.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Group (SUI).addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Group (SUI).removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean IconButton.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean IconButton.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean ListBox (SUI).addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean ListBox (SUI).removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Panel (SUI).addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Panel (SUI).removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Progressbar.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Progressbar.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean RadioButton (SUI).addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean RadioButton (SUI).removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Scrollbar.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Scrollbar.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Slider.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Slider.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean StaticText (SUI).addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean StaticText (SUI).removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean TreeView.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean TreeView.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Window (SUI).addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Window (SUI).confirm (message: String[, noAsDefault: Boolean=false][, title: String])

Boolean Window (SUI).onClose ()

Boolean Window (SUI).removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])


Adobe FrameMaker-12 Object Model JS: Date

Class

Date

A date/time object.

QuickLinks

 Date, UTC, getDate, getDay, getFullYear, getHours, getMilliseconds, getMinutes, getMonth, getSeconds, getTime, getTimezoneOffset, getUTCDate, getUTCDay, getUTCFullYear, getUTCHours, getUTCMilliseconds, getUTCMinutes, getUTCMonth, getUTCSeconds, getYear, parse, setDate, setFullYear, setHours, setMilliseconds, setMinutes, setMonth, setSeconds, setTime, setUTCDate, setUTCFullYear, setUTCHours, setUTCMilliseconds, setUTCMinutes, setUTCMonth, setUTCSeconds, setYear, toDateString, toGMTString, toLocaleDateString, toLocaleString, toLocaleTimeString, toSource, toString, toTimeString, toUTCString, valueOf

Methods

Constructor

Date Date (year: number[, month: number=0][, day: number=0][, hours: number=0][, min: number=0][, sec: number=0][, ms: number=0])
Returns a new Date object holding the current date and time.
If parameters are supplied, returns a new Date object holding the supplied date and time.
Parameter | Type | Description
year | number | The year expressed in four digits.
month | number (range: 0 - 11) | An integer value from 0 (Jan) to 11 (Dec). (default: 0) (Optional)
day | number (range: 1 - 31) | An integer value from 1 to 31, If this argument is not supplied, its value is set to 0. (default: 0) (Optional)
hours | number (range: 0 - 23) | An integer value from 0 (midnight) to 23 (11 PM). If this argument is not supplied, its value is set to 0. (default: 0) (Optional)
min | number (range: 0 - 59) | An integer value from 0 to 59. If this argument is not supplied, its value is set to 0. (default: 0) (Optional)
sec | number (range: 0 - 59) | An Integer value from 0 to 59. If this argument is not supplied, its value is set to 0. (default: 0) (Optional)
ms | number (range: 0 - 999) | An integer value from 0 to 999. If this argument is not supplied, its value is set to 0. (default: 0) (Optional)

Example new Date()
new Date (2006, 9, 25, 15, 30)

Class

Date UTC (year: number[, month: number=0][, day: number=0][, hours: number=0][, min: number=0][, sec: number=0][, ms: number=0])
Returns the number of milliseconds between midnight January 1, 1970, UTC, and the specified time.
Parameter | Type | Description
year | number | The year expressed in four digits, for example, 2001. To indicate for a year from 1900 to 1999, you can specify a value from 0 to 99.
month | number (range: 0 - 11) | An integer value from 0 (Jan) to 11 (Dec). (default: 0) (Optional)
day | number (range: 1 - 31) | An integer value from 1 to 31, If this argument is not supplied, its value is set to 0. (default: 0) (Optional)
hours | number (range: 0 - 23) | An integer value from 0 (midnight) to 23 (11 PM). If this argument is not supplied, its value is set to 0. (default: 0) (Optional)
min | number (range: 0 - 59) | An integer value from 0 to 59. If this argument is not supplied, its value is set to 0. (default: 0) (Optional)
sec | number (range: 0 - 59) | An Integer value from 0 to 59. If this argument is not supplied, its value is set to 0. (default: 0) (Optional)
ms | number (range: 0 - 999) | An integer value from 0 to 999. If this argument is not supplied, its value is set to 0. (default: 0) (Optional)

Example Date.UTC(year , month, date, hour, min, sec, ms)

Date parse (text: string)
Parses a string, returning a new Date object. The string should be similar to the string returned bt toString().
Parameter | Type | Description
text | string | The string to parse.

Instances

number getDate ()
Returns the day of the month of the specified Date object in local time. Range: 1 - 31

Example date.getDate()

number getDay ()
Returns the day of the week for the specified Date object in local time.
This is an integer from 0 (Sunday) to 6 (Saturday). Returns the day of the week for date. Range: 0 - 6

Example date.getDay()

number getFullYear ()
Returns the four digit year of the specified Date object in local time.

Example date.getFullYear()

number getHours ()
Returns the hour of the specified Date object in local time. Range: 0 - 23

Example date.getHours()

number getMilliseconds ()
Returns the milliseconds of the specified Date object in local time. Range: 0 - 999

Example date.getMilliseconds()

number getMinutes ()
Returns the minutes of the specified Date object in local time. Range: 0 - 59

Example date.getMinutes()

number getMonth ()
Returns the month of the specified Date object in local time. Range: 0 - 11

Example date.getMonth()

number getSeconds ()
Returns the seconds of the specified Date object in local time. Range: 0 - 59

Example date.getSeconds()

number getTime ()
Returns the number of milliseconds since midnight January 1,1970 UTC for the specified Date object.

Example date.getTime()

number getTimezoneOffset ()
Returns the difference in minutes between the computer's local time and UTC.

Example date.getTimezoneOffset()

number getUTCDate ()
Returns the day of the month of the specified Date object according to UTC. Range: 1 - 31

Example date.getUTCDate()

number getUTCDay ()
Returns the day of the week for the specified Date object according to UTC. Range: 0 - 6

Example date.getUTCDay()

number getUTCFullYear ()
Returns the four digit year of the specified Date object according to UTC.

Example date.getUTCFullYear()

number getUTCHours ()
Returns the hour of the specified Date object according to UTC. Range: 0 - 23

Example date.getUTCHours()

number getUTCMilliseconds ()
Returns the milliseconds of the specified Date object according to UTC. Range: 0 - 999

Example date.getUTCMilliseconds()

number getUTCMinutes ()
Returns the minutes of the specified Date object according to UTC. Range: 0 - 59

Example date.getUTCMinutes()

number getUTCMonth ()
Returns the month of the specified Date object according to UTC. Range: 0 - 11

Example date.getUTCMonth()

number getUTCSeconds ()
Returns the seconds of the specified Date object according to UTC. Range: 0 - 59

Example date.getUTCSeconds()

number getYear ()
Returns the year of the specified Date object, as a difference from 1900, in local time.

Example date.getYear()

number setDate (date: number)
Sets the day of the month of a specified Date object according to local time.
Returns the number of milliseconds between the new date and midnight, January 1, 1970.
Parameter | Type | Description
date | number (range: 1 - 31) | An integer from 1 to 31 indicating the day of the month.

Example date.setDate(date)

number setFullYear (year: number)
Sets the year of a specified Date object according to local time.
This method can also set month and date if those arguments are specified. Returns the number of milliseconds between the new date and midnight, January 1, 1970.
Parameter | Type | Description
year | number | A four-digit integer value indicating the year to set.

Example date.setFullYear(year, month, date)

number setHours (hour: number)
Sets the hours of a specified Date object according to local time.
Returns the number of milliseconds between the new date and midnight, January 1, 1970.
Parameter | Type | Description
hour | number (range: 0 - 23) | An integer value from 0 (midnight) to 23 (11 PM).

Example date.setHours(hour)

number setMilliseconds (ms: number)
Sets the milliseconds of a specified Date object according to local time.
Returns the number of milliseconds between the new date and midnight, January 1, 1970.
Parameter | Type | Description
ms | number (range: 0 - 999) | An integer value from 0 to 999.

Example date.setMilliseconds(ms)

number setMinutes (minutes: number)
Sets the minutes of a specified Date object according to local time.
Returns the number of milliseconds between the new date and midnight, January 1, 1970.
Parameter | Type | Description
minutes | number (range: 0 - 59) | An integer value from 0 to 59.

Example date.setMinutes(minutes)

number setMonth (month: number)
Sets the month of a specified Date object according to local time.
Returns the number of milliseconds between the new date and midnight, January 1, 1970.
Parameter | Type | Description
month | number (range: 0 - 11) | An integer value from 0 (Jan) to 11 (Dec).

Example date.setMonth(month)

number setSeconds (seconds: number)
Sets the seconds of a specified Date object according to local time.
Returns the number of milliseconds between the new date and midnight, January 1, 1970.
Parameter | Type | Description
seconds | number (range: 0 - 59) | An integer value from 0 to 59.

Example date.setSeconds(seconds)

number setTime (ms: number)
Sets the date of a specified Date object in milliseconds since midnight, January 1, 1970.
Returns the value of ms.
Parameter | Type | Description
ms | number | An integer indicating the number of milliseconds between the date set and midnight, January 1, 1970.

Example date.setTime(ms)

number setUTCDate (date: number)
Sets the date of a specified Date object according to universal time.
Returns the number of milliseconds between the new date and midnight, January 1, 1970 in UTC time.
Parameter | Type | Description
date | number (range: 1 - 31) | An integer from 1 to 31 indicating the day of the month.

Example date.setUTCDate(date)

number setUTCFullYear (year: number)
Sets the year of a specified Date object according to UTC, can also set the month and date.
Returns the number of milliseconds between the date set and midnight, January 1, 1970, in UTC.
Parameter | Type | Description
year | number | The year expressed in four digits.

Example date.setUTCFullYear(year, month, date)

number setUTCHours (hours: number)
Sets the hours of a specified Date object according to UTC.
Returns the number of milliseconds between the date set and midnight, January 1, 1970, in UTC.
Parameter | Type | Description
hours | number (range: 0 - 23) | An integer value from 0 (midnight) to 23 (11 PM) indicating the hour to be set.

Example date.setUTCHours(hours)

number setUTCMilliseconds (ms: number)
Sets the milliseconds of a specified Date object according to UTC.
Returns the number of milliseconds between the date set and midnight, January 1, 1970, in UTC.
Parameter | Type | Description
ms | number (range: 0 - 999) | An integer value in the range of 0 to 999 indicating the number of milliseconds to set.

Example date.setUTCMilliseconds(ms)

number setUTCMinutes (min: number)
Sets the minutes of a specified Date object according to UTC.
Returns the number of milliseconds between the date set and midnight, January 1, 1970, in UTC.
Parameter | Type | Description
min | number (range: 0 - 59) | An integer value in the range 0 to 59 indicating the number of minutes to be set.

Example date.setUTCMinutes(min)

number setUTCMonth (month: number)
Sets the month of a specified Date object according to UTC.
Returns the number of milliseconds between the date set and midnight, January 1, 1970, in UTC.
Parameter | Type | Description
month | number (range: 0 - 11) | An integer value in the range 0 (Jan.) to 11 (Dec.) indicating the month to set.

Example date.setUTCMonth(month)

number setUTCSeconds (sec: number)
Sets the seconds of a specified Date object according to UTC.
Returns the number of milliseconds between the date set and midnight, January 1, 1970, in UTC.
Parameter | Type | Description
sec | number (range: 0 - 59) | An integer value in the range 0 to 59 indicating the number of seconds to set.

Example date.setUTCSeconds(sec)

number setYear (year: number)
Sets the year of a specified Date object according to local time, as a difference between the current year and 1900.
Returns the number of milliseconds between the date set and midnight, January 1, 1970.
Parameter | Type | Description
year | number | An integer value indicating the year to set. The method interprets a 1- or 2- digit value to mean the 1900s; for example, 13 is interpreted to mean 1913.

Example date.setYear(year, month, date)

string toDateString () Returns the date as a string.

string toGMTString () Returns the date and time adjusted to GMT (UTC) as a string.

string toLocaleDateString () Returns the date as a localized string.

string toLocaleString () Returns a string value representing the date and time stored in the Date object in human readable format (localized).

string toLocaleTimeString () Returns the time as a localized string.

string toSource ()
Creates a string representation of this object that can be fed back to eval() to re-create an object. Works only with built-in classes.

string toString ()
Returns a string value representing the date and time stored in the Date object in human readable format.
Returns the following string is an example of the format returned by this method: Mon Aug 13, 10:54:21 GMT-0700 2001.

Example date.toString()

string toTimeString () Returns the time as a string.

string toUTCString () Returns the date and time adjusted to UTC as a string.

number valueOf ()
The valueOf() method returns the number of milliseconds that have passed since midnight, Returns an integer.

Element of

$.buildDate

Event.timeStamp

File.created

File.modified

Folder.created

Folder.modified

UIEvent.timeStamp

Return

Date Date.Date (year:
number[, month:
number=0][, day:
number=0][, hours:
number=0][, min:
number=0][, sec:
number=0][, ms:
number=0])

Date Date.UTC (year:
number[, month:
number=0][, day:
number=0][, hours:
number=0][, min:
number=0][, sec:
number=0][, ms:
number=0])

Date Date.parse (text: string)


Adobe FrameMaker-12 Object Model JS: Error

Class

Error

Wraps a runtime error.

QuickLinks

 Error, toSource, toString

Properties

Property | Type | Access | Description
description | string | r/w | The error message.

Methods

Constructor

Error Error (msg: string[, file: string][, line: number])
Creates a new Error object.
Parameter | Type | Description
msg | string | The error message.
file | string | The name of the file. (Optional)
line | number | The line number. (Optional)

Instances

string toSource ()
Creates a string representation of this object that can be fed back to eval() to re-create an object. Works only with built-in classes.

string toString ()
Convert this object to a string.

Element of

$.error

Return

Error Error.Error (msg: string[, file: string][, line: number])


Adobe FrameMaker-12 Object Model JS: File

Class

File

Represents a file in the local file system in a platform-independent manner.

QuickLinks

 File, changePath, close, copy, createAlias, decode, encode, execute, getRelativeURI, isEncodingAvailable, open, openDialog, openDlg, read, readch, readln, remove, rename, resolve, saveDialog, saveDlg, seek, tell, toSource, toString, write, writeln

Hierarchy

Folder
File

Properties

Property | Type | Access | Description
absoluteURI | string | readonly | The full path name for the referenced file in URI notation.
alias | bool | readonly | If true, the object refers to a file system alias or shortcut.
created | Date | readonly | The creation date of the referenced file, or null if the object does not refer to a file on disk.
creator | string | readonly | In Mac OS, the file creator as a four-character string. In Windows or UNIX, value is "????".
displayName | string | readonly | The localized name of the referenced file, without the path specification.
encoding | string | r/w | Gets or sets the encoding for subsequent read/write operations. One of the encoding constants listed in the JavaScript Tools Guide. If the value is not recognized, uses the system default encoding. A special encoder, BINARY, is used to read binary files. It stores each byte of the file as one Unicode character regardless of any encoding. When writing, the lower byte of each Unicode character is treated as a single byte to write.
eof | bool | readonly | When true, a read attempt caused the current position to be at the end of the file, or the file is not open.
error | string | r/w | A string containing a message describing the most recent file system error. Typically set by the file system, but a script can set it. Setting this value clears any error message and resets the error bit for opened files. Contains the empty string if there is no error.
exists | bool | readonly | If true, this object refers to a file or file-system alias that actually exists in the file system.
fsName | string | readonly | The platform-specific full path name for the referenced file.
fullName | string | readonly | The full path name for the referenced file in URI notation.
hidden | bool | r/w | When true, the file is not shown in the platform-specific file browser. If the object references a file-system alias or shortcut, the flag is altered on the alias, not on the original file.
length | number | r/w | The size of the file in bytes. Can be set only for a file that is not open, in which case it truncates or pads the file with 0-bytes to the new length.
lineFeed | string | r/w | How line feed characters are written in the file system. One of the values "Windows", "Macintosh", or "Unix".
modified | Date | readonly | The date of the referenced file's last modification, or null if the object does not refer to a file on the disk.
name | string | readonly | The file name portion of the absolute URI for the referenced file, without the path specification.
parent | Folder | readonly | The Folder object for the folder that contains this file.
path | string | readonly | The path portion of the absolute URI for the referenced file, without the file name.
readonly | bool | r/w | When true, prevents the file from being altered or deleted. If the referenced file is a file-system alias or shortcut, the flag is altered on the alias, not on the original file.
relativeURI | string | readonly | The path name for the object in URI notation, relative to the current folder.
type | string | readonly | The file type as a four-character string. • In Mac OS, the Mac OS file type. • In Windows, "appl" for .EXE files, "shlb" for .DLL files and "TEXT" for any other file.

Class

Property | Type | Access | Description
fs | string | readonly | The name of the file system. This is a class property accessed through the File constructor. Valid values are "Windows", "Macintosh", and "Unix".

Methods

Constructor

File File ([path: string])
Creates and returns a new File object referring to a given file system location.
Parameter | Type | Description
path | string | The full or partial path name of the file, in platform-specific or URI format. The value stored in the object is the absolute path. The file that the path refers to does not need to exist.If the path refers to an existing folder: • The File function returns a Folder object instead of a File object. • The new operator returns a File object for a nonexisting file with the same name. (Optional)

Example new File(path)

Class

string decode (uri: string)
Decodes a UTF-8 encoded string as required by RFC 2396, and returns the decoded string.
See also String.decodeURI().
Parameter | Type | Description
uri | string | The UTF-8 encoded string to decode.

string encode (name: string)
Encodes a string as required by RFC 2396, and returns the encoded string.
All special characters are encoded in UTF-8 and stored as escaped characters starting with the percent sign followed by two hexadecimal digits. For example, the string "my file" is encoded as "my%20file".
Special characters are those with a numeric value greater than 127, except the following: / - _ . ! ~ * ' ( )
See also encodeURI().
Parameter | Type | Description
name | string | The string to encode.

bool isEncodingAvailable (name: string)
Reports whether a given encoding is available.
Parameter | Type | Description
name | string | The encoding name. Typical values are "ASCII", "binary", or "UTF-8". For a complete list of supported encodings, see the JavaScript Tools Guide.

File openDialog (prompt: string[, filter: any=null][, multiSelect: bool=false])
Opens a dialog so the user can select one or more files to open.
Opens the built-in platform-specific file-browsing dialog in which a user can select an existing file or multiple files, and creates new File objects to represent the selected files.
• If the user clicks OK, returns a File object for the selected file, or an array of objects if multiple files are selected.
• If the user cancels, returns null.
Parameter | Type | Description
prompt | string | The prompt text, displayed if the dialog allows a prompt.
filter | any | A filter that limits the types of files displayed in the dialog. (default: null) • In Windows, a filter expression such as "Javascript files:*.jsx;All files:*.*". • In Mac OS, a filter function that takes a File instance and returns true if the file should be included in the display, false if it should not. (Optional)
multiSelect | bool | When true, the user can select multiple files and the return value is an array. (default: false) (Optional)

File saveDialog (prompt: string[, filter: any=null])
Opens a dialog so the user can select a file name to save to.
Opens the built-in platform-specific file-browsing dialog in which a user can select an existing file location to which to save information, and creates a new File object to represent the selected file location.
• If the user clicks OK, returns a File object for the selected file location.
• If the user cancels, returns null.
Parameter | Type | Description
prompt | string | The prompt text, displayed if the dialog allows a prompt.
filter | any | In Windows only, a filter that limits the types of files displayed in the dialog. (default: null) In Windows only, a filter expression such as "Javascript files:*.jsx;All files:*.*". Not used In Mac OS. (Optional)

Instances

bool changePath (path: string)
Changes the path specification of the referenced file.
Parameter | Type | Description
path | string | A string containing the new path, absolute or relative to the current folder.

Example file.changePath ("..");

bool close ()
Closes this open file.
Returns true if the file was closed successfully, false if an I/O error occurred.

Example aFile.close()

bool copy (target: string | File)
Copies this object's referenced file to the specified target location.
Resolves any aliases to find the source file. If a file exists at the target location, it is overwritten. Returns true if the copy was successful.
Parameter | Type | Description
target | string | File | A string with the URI path to the target location, or a File object that references the target location.

Example aFile.copy(target)

void createAlias (path: string)
Makes this file a file-system alias or shortcut to the specified file.
The referenced file for this object must not yet exist on disk. Returns true if the operation was successful.
Parameter | Type | Description
path | string | A string containing the path of the target file.

bool execute ()
Executes or opens this file using the appropriate application, as if it had been double-clicked in a file browser.
You can use this method to run scripts, launch applications, and so on.
Returns true immediately if the application launch was successful.

string getRelativeURI (basePath: string)
Retrieves and returns the path for this file, relative to the specified base path, in URI notation.
If no base path is supplied, the URI is relative to the path of the current folder. Returns a string containing the relative URI.
Parameter | Type | Description
basePath | string | A base path in URI notation.

Example aFile.getRelativeURI(basePath)

bool open (mode: string[, type: string][, creator: string])
Opens the referenced file for subsequent read/write operations. The method resolves any aliases to find the file.
Returns true if the file was opened successfully.
The method attempts to detect the encoding of the open file. It reads a few bytes at the current location and tries to detect the Byte Order Mark character 0xFFFE. If found, the current position is advanced behind the detected character and the encoding property is set to one of the strings UCS-2BE, UCS-2LE, UCS4-BE, UCS-4LE, or UTF-8. If the marker character is not found, it checks for zero bytes at the current location and makes an assumption about one of the above formats (except UTF-8). If everything fails, the encoding property is set to the system encoding.
IMPORTANT: Be careful about opening a file more than once. The operating system usually permits you to do so, but if you start writing to the file using two different File objects, you can destroy your data.
Parameter | Type | Description
mode | string | The read-write mode, a single-character string. One of these characters: • r (read) Opens for reading. If the file does not exist or cannot be found, the call fails. • w (write) Opens a file for writing. If the file exists, its contents are destroyed. If the file does not exist, creates a new, empty file. • e (edit) Opens an existing file for reading and writing. • a (append) Opens an existing file for reading and writing, and moves the current position to the end of the file.
type | string | In Mac OS, the type of a newly created file, a 4-character string. Ignored in Windows and UNIX. (Optional)
creator | string | In Mac OS, the creator of a newly created file, a 4-character string. Ignored in Windows and UNIX. (Optional)

Example aFile.open(mode, type, creator)

File openDlg (prompt: string[, filter: any=null][, multiSelect: bool=false])
Opens the built-in platform-specific file-browsing dialog, in which the user can select an existing file or files, and creates new File objects to represent the selected files.
Differs from the class method openDialog() in that it presets the current folder to this File object's parent folder and the current file to this object's associated file.
• If the user clicks OK, returns a File or Folder object for the selected file or folder, or an array of objects.
• If the user cancels, returns null.
Parameter | Type | Description
prompt | string | A string containing the prompt text, if the dialog allows a prompt.
filter | any | A filter that limits the types of files displayed in the dialog. (default: null) • In Windows, a filter expression such as "Javascript files:*.jsx;All files:*.*". • In Mac OS, a filter function that takes a File instance and returns true if the file should be included in the display, false if it should not. (Optional)
multiSelect | bool | When true, the user can select multiple files and the return value is an array. (default: false) (Optional)

string read ([chars: number])
Reads the contents of the file, starting at the current position.
Returns a string that contains up to the specified number of characters. If a number of characters is not supplied, reads from the current position to the end of the file. If the file is encoded, multiple bytes might be read to create single Unicode characters.
Parameter | Type | Description
chars | number | An integer specifying the number of characters to read. (Optional)

Example aFile.read(chars)

string readch ()
Reads a single text character from the file at the current position.
Line feeds are recognized as CR, LF, CRLF or LFCR pairs. If the file is encoded, multiple bytes might be read to create a single Unicode character. Returns a string that contains the character.

Example aFile.readch()

string readln ()
Reads a single line of text from the file at the current position.
Line feeds are recognized as CR, LF, CRLF or LFCR pairs.. If the file is encoded, multiple bytes might be read to create single Unicode characters. Returns a string that contains the text.

Example aFile.readln()

bool remove ()
Deletes the file associated with this object from disk immediately, without moving it to the system trash.
Does not resolve aliases; instead, deletes the referenced alias or shortcut file itself. Returns true if the file was successfully removed.
• IMPORTANT: Cannot be undone. It is recommended that you prompt the user for permission before deleting.

bool rename (newName: string)
Renames the associated file.
Does not resolve aliases, but renames the referenced alias or shortcut file itself. Returns true if the file was successfully renamed.
Parameter | Type | Description
newName | string | The new file name, with no path information.

Example aFile.rename(newName)

File resolve ()
Attempts to resolve the file-system alias or shortcut that this object refers to.
If successful, creates and returns a new File object that points to the resolved file system element. Returns null if this object does not refer to an alias, or if the alias could not be resolved.

File saveDlg (prompt: string[, filter: any=null])
Opens the built-in platform-specific file-browsing dialog, in which the user can select an existing file location to which to save information, and creates a new File object to represent the selected file.
Differs from the class method saveDialog() in that it presets the current folder to this File object's parent folder and the file to this object's associated file.
• If the user clicks OK, returns a File object for the selected file.
• If the user cancels, returns null.
Parameter | Type | Description
prompt | string | A string containing the prompt text, if the dialog allows a prompt.
filter | any | In Windows only, a filter that limits the types of files displayed in the dialog. (default: null) In Windows only, a filter expression such as "Javascript files:*.jsx;All files:*.*". Not used In Mac OS. (Optional)

bool seek (pos: number[, mode: number=0])
Seeks to a given position in the file.
The new position cannot be less than 0 or greater than the current file size. Returns true if the position was changed.
Parameter | Type | Description
pos | number | The new current position in the file as an offset in bytes from the start, current position, or end, depending on the mode.
mode | number (range: 0 - 2) | The seek mode. (default: 0) One of: • 0: Seek to absolute position, where pos=0 is the first byte of the file. This is the default. • 1: Seek relative to the current position. • 2. Seek backward from the end of the file. (Optional)

Example aFile.seek(pos, mode)

number tell ()
Retrieves the current position as a byte offset from the start of the file.
Returns a number, the position index.

Example aFile.tell()

string toSource ()
Creates and returns a serialized string representation of this object.
Pass the resulting string to eval() to recreate the object.

string toString ()
Converts this object to a string.

bool write (text: string)
Writes the specified text to the file at the current position.
You can supply multiple text values; the strings are concatenated to form a single string.
For encoded files, writing a single Unicode character may write multiple bytes. Returns true if the write was successful.
IMPORTANT: Be careful not to write to a file that is open in another application or object, as this can overwrite existing data.
Parameter | Type | Description
text | string | A text string to be written.

Example aFile.write(text, ...)

bool writeln (text: string)
Writes a string to the file at the current position and appends a line-feed sequence.
You can supply multiple text values. The strings are concatenated into a single string, which is written in the file followed by one line-feed sequence, of the style specified by this object's linefeed property.
For encoded files, writing a single Unicode character may write multiple bytes. Returns true if the write was successful.
IMPORTANT: Be careful not to write to a file that is open in another application or object, as this can overwrite existing data.
Parameter | Type | Description
text | string | A text string to be written.

Example aFile.writeln(text, ...)

Element of

Reflection.sampleFile

ReflectionInfo.sampleFile

Used in:

any $.evalFile (file: File[, timeout: number=10000])

bool File.copy (target: string | File)

void FlashPlayer.loadMovie (file: File)

Return

File File.File ([path: string])

File File.openDialog (prompt: string[, filter: any=null][, multiSelect: bool=false])

File File.openDlg (prompt: string[, filter: any=null][, multiSelect: bool=false])

File File.resolve ()

File File.saveDialog (prompt: string[, filter: any=null])

File File.saveDlg (prompt: string[, filter: any=null])


Adobe FrameMaker-12 Object Model JS: Folder

Class

Folder

Represents a file-system folder or directory in a platform-independent manner.

QuickLinks

 Folder, changePath, create, decode, encode, execute, getFiles, getRelativeURI, isEncodingAvailable, remove, rename, resolve, selectDialog, selectDlg, toSource, toString

Hierarchy

Folder
Folder
File | Folder

Properties

Property | Type | Access | Description
absoluteURI | string | readonly | The full path name for the referenced folder in URI notation.
alias | bool | readonly | When true, the object refers to a file system alias or shortcut.
created | Date | readonly | The creation date of the referenced folder, or null if the object does not refer to a folder on disk.
displayName | string | readonly | The localized name portion of the absolute URI for the referenced folder, without the path specification.
error | string | r/w | A message describing the most recent file system error. Typically set by the file system, but a script can set it. Setting this value clears any error message and resets the error bit for opened files. Contains the empty string if there is no error.
exists | bool | readonly | When true, this object refers to a folder that currently exists in the file system.
fsName | string | readonly | The platform-specific name of the referenced folder as a full path name.
fullName | string | readonly | The full path name for the referenced folder in URI notation. .
modified | Date | readonly | The date of the referenced folder's last modification, or null if the object does not refer to a folder on disk.
name | string | readonly | The folder name portion of the absolute URI for the referenced file, without the path specification.
parent | Folder | readonly | TThe Folder object for the folder that contains this folder, or null if this object refers to the root folder of a volume.
path | string | readonly | The path portion of the object absolute URI for the referenced file, without the folder name.
relativeURI | string | readonly | The path name for the referenced folder in URI notation, relative to the current folder.

Class

Property | Type | Access | Description
appData | Folder | readonly | The folder containing the application data for all users. • In Windows, the value of %APPDATA% (by default, C:\\Documents and Settings\\All Users\\Application Data) • In Mac OS, /Library/Application Support
appPackage | Folder | readonly | In Mac OS, a Folder object for the folder containing the bundle of the running application.
commonFiles | Folder | readonly | A Folder object for the folder containing common files for all programs installed by the user. • In Windows, the value of %CommonProgramFiles% (by default, C:\\Program Files\\Common Files) • In Mac OS, /Library/Application Support
current | Folder | r/w | A Folder object for the current folder. Assign a Folder object or a string containing the new path name to set the current folder. This is a class property accessed through the Folder constructor.
desktop | Folder | readonly | A Folder object for the folder that contains the user's desktop. • In Windows, C:\\Documents and Settings\\username\\Desktop • In Mac OS, ~/Desktop
fs | string | readonly | The name of the current file system. One of "Windows", "Macintosh", or "Unix".
myDocuments | Folder | readonly | A folder pointing to the user's My Documents folder. • In Windows, C:\\Documents and Settings\\username\\My Documents • In Mac OS, ~/Documents
startup | Folder | readonly | A Folder object for the folder containing the executable image of the running application.
system | Folder | readonly | A Folder object for the folder containing the operating system files. • In Windows, the value of %windir% (by default, C:\\Windows) • In Mac OS, /System
temp | Folder | readonly | A Folder object for the default folder for temporary files.
trash | Folder | readonly | A Folder object for the folder containing deleted items. On Windows, the trash folder is a virtual folder containing a database; therefore, the property value is null on Windows.
userData | Folder | readonly | A Folder object for the folder containing the user's application data. • In Windows, the value of %USERDATA% (by default, C:\\Documents and Settings\\username\\Application Data) • In Mac OS, ~/Library/Application Support.

Methods

Constructor

Folder Folder ([path: string])
Creates and returns a new Folder object referring to a given file-system location.
If the path name refers to an already existing disk file, a File object is returned instead. Returns the new Folder object.
Parameter | Type | Description
path | string | The absolute or relative path to the folder associated with this object, specified in URI format. The value stored in the object is the absolute path.The path need not refer to an existing folder. If the path refers to an existing file, rather than a folder: • The Folder() function returns a File object instead of a Folder object. • The new operator returns a Folder object for a nonexisting folder with the same name. (Optional)

Example new Folder(path)

Class

string decode (uri: string)
Decodes a UTF-8 encoded string as required by RFC 2396, and returns the decoded string.
See also String.decodeURI().
Parameter | Type | Description
uri | string | The UTF-8 string to decode.

string encode (name: string)
Encodes a string as required by RFC 2396, and returns the encoded string.
All special characters are encoded in UTF-8 and stored as escaped characters starting with the percent sign followed by two hexadecimal digits. For example, the string "my file" is encoded as "my%20file".
Special characters are those with a numeric value greater than 127, except the following: / - _ . ! ~ * ' ( )
See also encodeURI().
Parameter | Type | Description
name | string | The string to encode.

bool isEncodingAvailable (name: string)
Reports whether a given encoding is available.
Parameter | Type | Description
name | string | The encoding name. Typical values are "ASCII", "binary", or "UTF-8". For a complete list of supported encodings, see the JavaScript Tools Guide.

Folder selectDialog (prompt: string)
Opens the built-in platform-specific file-browsing dialog, and creates a new File or Folder object for the selected file or folder.
Differs from the object method selectDlg() in that it does not preselect a folder.
• If the user clicks OK, returns a File or Folder object for the selected file or folder.
• If the user cancels, returns null.
Parameter | Type | Description
prompt | string | The prompt text, if the dialog allows a prompt.

Instances

bool changePath (path: string)
Changes the path specification of the referenced folder.
Parameter | Type | Description
path | string | A string containing the new path, absolute or relative to the current folder.

Example folder.changePath ("..");

bool create ()
Creates a folder at the location given by this object's path property.
Returns true if the folder was created.

Example aFolder.create()

bool execute ()
Opens this folder in the platform-specific file browser (as if it had been double-clicked in the file browser).
Returns true immediately if the folder was opened successfully.

Array getFiles (mask: any)
Retrieves the contents of this folder, filtered by the supplied mask.
Returns an array of File and Folder objects, or null if this object's referenced folder does not exist.
Parameter | Type | Description
mask | any | A search mask for file names, specified as a string or a function. A mask string can contain question mark (?) and asterisk (*) wild cards. Default is "*", which matches all file names. Can also be the name of a function that takes a File or Folder object as its argument. It is called for each file or folder found in the search; if it returns true, the object is added to the return array. • NOTE: In Windows, all aliases end with the extension .lnk. ExtendScript strips this from the file name when found, in order to preserve compatibility with other operating systems. You can search for all aliases by supplying the search mask "*.lnk", but note that such code is not portable.

string getRelativeURI ([basePath: string=.])
Retrieves and returns the path for this file, relative to the specified base path, in URI notation.
If no base path is supplied, the URI is relative to the path of the current folder. Returns a string containing the relative URI.
Parameter | Type | Description
basePath | string | A base path in URI notation. (default: .) (Optional)

Example aFile.getRelativeURI(basePath)

bool remove ()
Deletes the folder associated with this object from disk immediately, without moving it to the system trash.
Folders must be empty before they can be deleted. Does not resolve aliases; instead, deletes the referenced alias or shortcut file itself. Returns true if the file was successfully removed.
• IMPORTANT: Cannot be undone. It is recommended that you prompt the user for permission before deleting.

bool rename (newName: string)
Renames the associated folder.
Does not resolve aliases, but renames the referenced alias or shortcut file itself. Returns true if the folder was successfully renamed.
Parameter | Type | Description
newName | string | The new folder name, with no path information.

Example aFolder.rename(newName)

Folder resolve ()
Attempts to resolve the file-system alias or shortcut that this object refers to.
If successful, creates and returns a new Folder object that points to the resolved file system element. Returns null if this object does not refer to an alias, or if the alias could not be resolved.

Example aFolder.resolve()

Folder selectDlg (prompt: string)
Opens the built-in platform-specific file-browsing dialog, and creates a new File or Folder object for the selected file or folder.
Differs from the class method selectDialog() in that it preselects this folder.
• If the user clicks OK, returns a File or Folder object for the selected file or folder.
• If the user cancels, returns null.
Parameter | Type | Description
prompt | string | The prompt text, if the dialog allows a prompt.

string toSource ()
Creates and returns a serialized string representation of this object.
Pass the resulting string to eval() to recreate the object.

string toString ()
Converts this object to a string.

Element of

File.parent

Folder.appData

Folder.appPackage

Folder.commonFiles

Folder.current

Folder.desktop

Folder.myDocuments

Folder.parent

Folder.startup

Folder.system

Folder.temp

Folder.trash

Folder.userData

Return

Folder Folder.Folder ([path: string])

Folder Folder.resolve ()

Folder Folder.selectDialog (prompt: string)

Folder Folder.selectDlg (prompt: string)


Adobe FrameMaker-12 Object Model JS: Function

Class

Function

Wraps a built-in or JavaScript function.

QuickLinks

 Function, apply, call, toSource, toString

Properties

Property | Type | Access | Description
arguments | Object | r/w | The function arguments, packed into an array. This property is deprecated; use the arguments property within the function body.
arity | number | readonly | The number of formal arguments. This property is deprecated; use the length property instead.
length | number | readonly | The number of formal arguments.
name | string | readonly | The function name.

Methods

Constructor

Function Function (arguments: string, body: string) The Function constructor parses the argument list and creates a Function object.
Parameter | Type | Description
arguments | string | The list of formal arguments, separated by commas. The formal arguments can also be supplied one by one; in this case, the last argument to the Function constructor is considered to be the function body.
body | string | The body of the function to create.

Instances

any apply (thisObj: Object, args: Array)
Apply a this object and an argument list to a function.
This function is different from call(); here, the arguments are suppliedas an Array object.
Parameter | Type | Description
thisObj | Object | The object to be used as this.
args | Array | An array of arguments.

any call (thisObj: Object, argument: any)
Apply a this object and arguments to a function.
This function is different from apply(); here, the arguments are supplied one by one.
Parameter | Type | Description
thisObj | Object | The object to be used as this.
argument | any | The first agument to the function. Add as many as needed.

string toSource ()
Creates a string representation of this object that can be fed back to eval() to re-create an object. Works only with JavaScript functions.

string toString ()
Returns the function definition as a string.

Element of

Object.constructor

Used in:

void Array.sort (userFunction: Function)

Boolean Button.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Button.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Checkbox.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Checkbox.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean DropDownList.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean DropDownList.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean EditText.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean EditText.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean FlashPlayer.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean FlashPlayer.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Group.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Group.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean IconButton.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean IconButton.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean ListBox.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean ListBox.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void Object.watch (name: string, func: Function)

Boolean Panel.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Panel.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Progressbar.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Progressbar.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean RadioButton.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean RadioButton.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Scrollbar.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Scrollbar.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Slider.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Slider.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean StaticText.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean StaticText.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean TreeView.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean TreeView.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Window.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Window.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Return

Function Function.Function (arguments: string, body: string)


Adobe FrameMaker-12 Object Model JS: Global Elements

Class

Global Elements

The global methods and properties for ExtendScript.

QuickLinks

 alert, confirm, decodeURI, decodeURIComponent, encodeURI, encodeURIComponent, escape, eval, isFinite, isNaN, isXMLName, localize, parseFloat, parseInt, prompt, setDefaultXMLNamespace, unescape, uneval

Properties

Property | Type | Access | Description
Infinity | number | r/w | The Infinity global property is a predefined variable with the value for infinity. (default: +Infinity)
NaN | number | r/w | The NaN global property is a predefined variable with the value NaN (Not-a-Number), as specified by the IEEE-754 standard. (default: NaN)
undefined | Undefined | r/w | This global property is a predefined variable with the value for an undefined value. (default: undefined)

Methods

Instances

void alert (message: string[, title: string][, errorIcon: bool=false])
Displays an alert box
Parameter | Type | Description
message | string | The text to display
title | string | The title of the alert; ignored on the Macintosh (Optional)
errorIcon | bool | Display an Error icon; ignored on the Macintosh (default: false)

bool confirm (message: string[, noAsDefault: bool=false][, title: string])
Displays an alert box with Yes and No buttons; returns true for Yes
Parameter | Type | Description
message | string | The text to display
noAsDefault | bool | Set to true to set the No button as the default button (default: false)
title | string | The title of the alert; ignored on the Macintosh (Optional)

string decodeURI (uri: string)
Decodes a string created with encodeURI().
Parameter | Type | Description
uri | string | The text to decode.

string decodeURIComponent (uri: string)
Decodes a string created with encodeURIComponent().
Parameter | Type | Description
uri | string | The text to decode.

string encodeURI (text: string)
Encodes a string after RFC2396.
Create an UTF-8 ASCII encoded version of this string. The string is converted into UTF-8. Every non-alphanumeric character is encoded as a percent escape character of the form %xx, where xx is the hex value of the character. After the conversion to UTF-8 encoding and escaping, it is guaranteed that the string does not contain characters codes greater than 127. The list of characters not to be encoded is -_.!~*'();/?:@&=+$,#. The method returns false on errors.
Parameter | Type | Description
text | string | The text to encode.

string encodeURIComponent (text: string)
Encodes a string after RFC2396.
Create an UTF-8 ASCII encoded version of this string. The string is converted into UTF-8. Every non-alphanumeric character is encoded as a percent escape character of the form %xx, where xx is the hex value of the character. After the conversion to UTF-8 encoding and escaping, it is guaranteed that the string does not contain characters codes greater than 127. The list of characters not to be encoded is -_.!~*'(). The method returns false on errors.
Parameter | Type | Description
text | string | The text to encode.

string escape (aString: string)
Creates a URL-encoded string from aString.
In the new string, characters of aString that require URL encoding are replaced with the format %xx, where xx is the hexadecimal value of the character code in the Unicode character set. This format is used to transmit information appended to a URL during, for example, execution of the GET method. Use the unescape() global function to translate the string back into its original format. Returns a string which is aString URL-encoded.
Parameter | Type | Description
aString | string | The string to be encoded.

Example escape(aString)

any eval (stringExpression: string)
Evaluates its argument as a JavaScript script, and returns the result of evaluation.
You can pass the result of an object's toSource() method to reconstruct that object.
Parameter | Type | Description
stringExpression | string | The string to evaluate.

Example eval(stringExpression)

bool isFinite (expression: number)
Evaluates an expression and reports whether the result is a finite number.
Returns true if the expression is a finite number, false otherwise. False if the value is infinity or negative infinity.
Parameter | Type | Description
expression | number | Any valid JavaScript expression.

Example isFinite(expression)

bool isNaN (expression: number)
Evaluates an expression and reports whether the result is "Not-a-Number" (NaN).
Returns true if the result of evaluation is not a number (NaN), false if the value is a number.
Parameter | Type | Description
expression | number | Any valid JavaScript expression.

Example isNaN(expression)

bool isXMLName (name: string)
Returns true if the supplied string is a valid XML name.
Parameter | Type | Description
name | string | The XML name to test.

string localize (what: string[, argument: any])
Localizes a ZString-encoded string and merges additional arguments into the string.
Parameter | Type | Description
what | string | The string to localize. A ZString-encoded string that can contain placeholder for additional arguments in the form %1 to %n.
argument | any | Optional argument(s) to be merged into the string. There may be more than one argument. (Optional)

number parseFloat (text: string)
Extracts a floating-point number from a string.
Parses a string to find the first set of characters that can be converted to a floating point number, and returns that number, or NaN if it does not encounter characters that it can converted to a number. The function supports exponential notation.
Parameter | Type | Description
text | string | The string from which to extract a floating point number.

Example parseFloat(aString)

number parseInt (text: string[, base: number])
Extracts an integer from a string.
Parses a string to find the first set of characters, in a specified base, that can be converted to an integer, and returns that integer, or NaN if it does not encounter characters that it can convert to a number.
Parameter | Type | Description
text | string | The string from which to extract an integer.
base | number (range: 2 - 36) | The base of the string to parse (from base 2 to base 36). If not supplied, base is determined by the format of string. (Optional)

Example parseInt(aString, base)

string prompt (prompt: string[, default: string][, title: string])
Displays a dialog allowing the user to enter text
Returns null if the user cancelled the dialog, the text otherwise
Parameter | Type | Description
prompt | string | The text to display
default | string | The default text to preset the edit field with (Optional)
title | string | The title of the dialog; (Optional)

void setDefaultXMLNamespace (namespace: Namespace)
Defines the default XML namespace.
This is a replacement function for the standard JavaScript statement set default xml namespace.
Parameter | Type | Description
namespace | Namespace | The namespace to use. Omit this parameter to return to the empty namespace. This is either a Namespace object or a string.

string unescape (stringExpression: string)
Translates URL-encoded string into a regular string, and returns that string.
Use the escape() global function to URL-encode strings.
Parameter | Type | Description
stringExpression | string | The URL-encoded string to convert.

Example unescape(stringExpression)

string uneval (what: any)
Creates a source code representation of the supplied argument, and returns it as a string.
Parameter | Type | Description
what | any | The object to uneval.


Adobe FrameMaker-12 Object Model JS: Math (JS)

Class

Math (JS)

A global object containing a set of math functions and constants.

QuickLinks

 abs, acos, asin, atan, atan2, ceil, cos, exp, floor, log, max, min, pow, random, round, sin, sqrt, tan

Class

Property | Type | Access | Description
E | number | readonly | Euler's constant and the base of natural logarithms. (default: 2.7182818284590452354)
LN10 | number | readonly | The natural logarithm of 10. (default: 2.302585092994046)
LN2 | number | readonly | The natural logarithm of 2. (default: 0.6931471805599453)
LOG10E | number | readonly | The base 10 logarithm of e. (default: 0.4342944819032518)
LOG2E | number | readonly | The base 2 logarithm of e. (default: 1.4426950408886934)
PI | number | readonly | The ratio of the circumference of a circle to its diameter. (default: 3.14159265358979323846)
SQRT1_2 | number | readonly | The reciprocal of the square root of 1/2. (default: 0.7071067811865476)
SQRT2 | number | readonly | The square root of 2. (default: 1.4142135623730951)

Methods

number abs (x: number)
Returns the absolute value of a number.
Parameter | Type | Description
x | number | A number.

Example Math.abs(x)

number acos (x: number)
Returns the arc cosine(in radians) of a number.
Parameter | Type | Description
x | number | A number.

Example Math.acos(x)

number asin (x: number)
Returns the arc sin(in radians) of a number.
Parameter | Type | Description
x | number | A number.

Example Math.asin(x)

number atan (x: number)
Returns the arc tangent(in radians) of a number.
Parameter | Type | Description
x | number | A number.

Example Math.atan(x)

number atan2 (y: number, x: number)
Returns the arc tangent of the quotient of its arguments (y/x).
Parameter | Type | Description
y | number | A number.
x | number | A number.

Example Math.atan2(y,x)

number ceil (x: number)
Rounds the number up to the nearest integer.
Parameter | Type | Description
x | number | A number.

Example Math.ceil(x)

number cos (x: number)
Returns the cosine of an angle provided in radians.
Parameter | Type | Description
x | number | An angle, in radians.

Example Math.cos(x)

number exp (x: number)
Returns Math.E raised to the power of a number.
Parameter | Type | Description
x | number | A number.

Example Math.exp(x)

number floor (x: number)
Rounds a number down to the nearest integer.
Parameter | Type | Description
x | number | A number.

Example Math.floor(x)

number log (x: number)
Returns the natural logarithm of a number.
Parameter | Type | Description
x | number | A number.

Example Math.log(x)

number max (x: number, y: number)
Returns the maximum of two numbers.
Parameter | Type | Description
x | number |
y | number |

Example Math.max(x,y)

number min (x: number, y: number)
Returns the minimum of two numbers.
Parameter | Type | Description
x | number | Numbers.
y | number |

Example Math.min(x,y)

number pow (x: number, y: number)
Returns x raised to the power of y.
Parameter | Type | Description
x | number | Numbers.
y | number |

Example Math.pow(x,y)

number random ()
Returns a pseudo-random number from 0.0 up to but not including 1.0. Range: 0.0 - 0.999999999999999

Example Math.random()

number round (x: number)
Rounds a number to the nearest integer.
Parameter | Type | Description
x | number | A number.

Example Math.round(x)

number sin (x: number)
Returns the sine of an angle provided in radians.
Parameter | Type | Description
x | number | An angle, in radians.

Example Math.sin(x)

number sqrt (x: number)
Returns the square root of a number.
Parameter | Type | Description
x | number | A number.

Example Math.sqrt(x)

number tan (x: number)
Returns the tangent of an angle provided in radians.
Parameter | Type | Description
x | number | An angle, in radians.

Example Math.tan(x)


Adobe FrameMaker-12 Object Model JS: Namespace

Class

Namespace

A XML namespace object.

QuickLinks

 Namespace

Properties

Property | Type | Access | Description
prefix | string | readonly | The named prefix.
uri | string | readonly | The URI.

Methods

Constructor

Namespace Namespace (prefix: any[, uri: string])
Creates a Namespace object.
Parameter | Type | Description
prefix | any | The URI prefix, specified as an existing Namespace object, QName object, or string. • If this is a Namespace or a QName object, the URI and prefix are set to that of the object. • If this is a string, the prefix is set to that string, and the URI must be specified.
uri | string | The URI if the prefix is specified as a string. (Optional)

Example new Namespace ("adobe", "http:/www.adobe.com")

Used in:

void Global Elements.setDefaultXMLNamespace (namespace: Namespace)

XML XML.addNamespace (namespace: Namespace)

XML XML.removeNamespace (namespace: Namespace)

void XML.setNamespace (namespace: Namespace)

Return

Namespace Namespace.Namespace (prefix: any[, uri: string])

Namespace XML.namespace ()


Adobe FrameMaker-12 Object Model JS: Number

Class

Number

Wraps a numeric value.

QuickLinks

 Number, toExponential, toFixed, toLocaleString, toPrecision, toSource, toString, valueOf

Class

Property | Type | Access | Description
MAX_VALUE | number | readonly | A constant representing the largest representable number. (default: 1.7976931348623158e+308)
MIN_VALUE | number | readonly | A constant representing the smallest representable number. (default: 2.2250738585072014e-308)
NEGATIVE_INFINITY | number | readonly | A constant representing negative infinity.
NaN | number | readonly | A constant representing the special "Not a Number" value. (default: NaN)
POSITIVE_INFINITY | number | readonly | A constant representing positive infinity.

Methods

Constructor

Number Number (value: any)
Returns a new Number object set to the value of the argument converted to a number.
Parameter | Type | Description
value | any | The value of the object being created.

Example new Number(value)

Instances

number toExponential (decimals: number)
Converts the Number object to a string in scientific notation.
Parameter | Type | Description
decimals | number | The number of decimals.

number toFixed (decimals: number)
Converts the Number object to a string with fixed decimals.
Parameter | Type | Description
decimals | number | The number of decimals.

number toLocaleString ()
Returns the value of a Number object converted to a string, using localized conventions.

number toPrecision (decimals: number)
Converts the Number object to a string in either scientific or fixed notation, epending on its value.
Parameter | Type | Description
decimals | number | The number of decimals.

number toSource ()
Creates a string representation of this object that can be fed back to eval() to re-create an object. Works only with built-in classes.

number toString ([radix: number])
Returns the value of a Number object converted to a string.
Parameter | Type | Description
radix | number | The optional conversion radix. (Optional)

Example num.toString(16)

number valueOf ()
Returns the value of a Number object as a primitive number.

Example num.valueOf()

Element of

Bounds.bottom

Bounds.height

Bounds.left

Bounds.length

Bounds.right

Bounds.top

Bounds.width

Bounds.x

Bounds.y

Button.characters

Button.indent

Checkbox.characters

Checkbox.indent

Dimension.height

Dimension.length

Dimension.width

DropDownList.indent

EditText.characters

EditText.indent

FlashPlayer.indent

Group.indent

Group.margins

Group.spacing

IconButton.indent

ListBox.indent

ListItem.index

Panel.characters

Panel.indent

Panel.margins

Panel.spacing

Point.left

Point.length

Point.top

Point.x

Point.y

Progressbar.indent

Progressbar.maxvalue

Progressbar.minvalue

Progressbar.value

RadioButton.characters

RadioButton.indent

ScriptUIBrush.color

ScriptUIBrush.type

ScriptUIFont.size

ScriptUIPen.color

ScriptUIPen.lineWidth

Scrollbar.indent

Scrollbar.jumpdelta

Scrollbar.maxvalue

Scrollbar.minvalue

Scrollbar.stepdelta

Scrollbar.value

Slider.indent

Slider.maxvalue

Slider.minvalue

Slider.value

StaticText.characters

StaticText.indent

TreeView.indent

Window.characters

Window.indent

Window.margins

Window.opacity

Window.spacing

Used in:

ScriptUIFont ScriptUI.newFont (name: String, style: String | Number, size: Number)

void ScriptUIGraphics.drawFocusRing (left: Number, top: Number, width: Number, height: Number)

void ScriptUIGraphics.drawImage (image: ScriptUIImage, left: Number, top: Number[, width: Number][, height: Number])

void ScriptUIGraphics.drawString (text: String, pen: ScriptUIPen, x: Number, y: Number[, font: ScriptUIFont])

Point ScriptUIGraphics.ellipsePath (left: Number, top: Number, width: Number, height: Number)

Point ScriptUIGraphics.lineTo (x: Number, y: Number)

Dimension ScriptUIGraphics.measureString (text: String[, font: ScriptUIFont][, boundingWidth: Number])

Point ScriptUIGraphics.moveTo (x: Number, y: Number)

ScriptUIBrush ScriptUIGraphics.newBrush (type: Number, color: Array of Number | String)

ScriptUIPen ScriptUIGraphics.newPen (type: Number, color: Array of Number | String, width: Number)

Point ScriptUIGraphics.rectPath (left: Number, top: Number, width: Number, height: Number)

UIEvent UIEvent.UIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])

void UIEvent.initUIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])

Return

Number Number.Number (value: any)


Adobe FrameMaker-12 Object Model JS: Object

Class

Object

The base class of all JavaScript objects.

QuickLinks

 Object, hasOwnProperty, isPrototypeOf, isValid, propertyIsEnumerable, toLocaleString, toSource, toString, unwatch, valueOf, watch

Properties

Property | Type | Access | Description
constructor | Function | readonly | Points to the constructor function that created this object. Note that this property is treated as an XML element in the XML class.
prototype | Object | readonly | Points to the prototype object for this object. Note that this property is treated as an XML element in the XML class.
reflect | Reflection | readonly | Retrieves and returns the Reflection object associated with this method or a property. Note that this property is treated as an XML element in the XML class.

Methods

Constructor

Object Object (what: any)
Creates and returns a new object of a given type.
Parameter | Type | Description
what | any | The object type.

Example new Object()

Class

bool isValid (what: Object)
Reports whether an object is still valid.
Parameter | Type | Description
what | Object | The object to check.

Instances

bool hasOwnProperty (name: string)
Reports whether a given property is defined with an instance or within the prototype chain.
Parameter | Type | Description
name | string | The name of the property to check.

bool isPrototypeOf (what: Object)
Checks whether the given object is a prototype of this object.
Parameter | Type | Description
what | Object | The object to check.

bool propertyIsEnumerable (name: string)
Reports whether a given property is enumerable.
Parameter | Type | Description
name | string | The name of the property to check.

string toLocaleString ()
Creates and returns a string representing this object, localized for the current locale. See toString().

string toSource ()
Creates and returns a string representation of this object.
This function serializes the object, so that it can, for example, be passed between engines. Pass the returned string back to eval() to recreate the object. Works only with built-in classes.

string toString ()
Creates and returns a string representing this object.
Many objects (such as Date) override this method in favor of their own implementation. If an object has no string value and no user-defined toString() method, the default method returns [object type], where type is the object type or the name of the constructor function that created the object.

Example obj.toString()

void unwatch (name: string)
Removes the watch function of a property.
Parameter | Type | Description
name | string | The name of the property to unwatch.

Object valueOf ()
Retrieves and returns the primitive value of this object.
If the object has no primitive value, returns the object itself. Note that you rarely need to call this method yourself. The JavaScript interpreter automatically invokes it when encountering an object where a primitive value is expected.

Example obj.valueOf()

void watch (name: string, func: Function)
Adds a watch function to a property, which is called when the value changes.
This function can accept, modify, or reject a new value that the user, application, or a script has attempted to place in a property.
Parameter | Type | Description
name | string | The name of the property to watch.
func | Function | The function to be called when the value of this property changes. This function must three arguments, and return as its result the value to be stored in the property. The arguments are: • name: the name of the property that changes. • oldValue: The old property value. • newValue: The new property value that was specified.

Element of

$.global

$.screens

Button.children

Button.parent

Button.properties

Checkbox.children

Checkbox.parent

Checkbox.properties

DropDownList.children

DropDownList.parent

DropDownList.properties

EditText.children

EditText.parent

EditText.properties

Event.target

FlashPlayer.parent

FlashPlayer.properties

Function.arguments

Group.children

Group.parent

Group.properties

IconButton.children

IconButton.parent

IconButton.properties

ListBox.children

ListBox.columns

ListBox.parent

ListBox.properties

ListItem.parent

ListItem.properties

Object.prototype

Panel.children

Panel.parent

Panel.properties

Progressbar.children

Progressbar.parent

Progressbar.properties

RadioButton.children

RadioButton.parent

RadioButton.properties

ScriptUI.FontStyle

ScriptUI.applicationFonts

ScriptUI.compatibility

ScriptUIFont.style

ScriptUIGraphics.BrushType

ScriptUIGraphics.PenType

Scrollbar.children

Scrollbar.parent

Scrollbar.properties

Slider.children

Slider.parent

Slider.properties

StaticText.children

StaticText.parent

StaticText.properties

TreeView.children

TreeView.parent

TreeView.properties

UIEvent.target

Window.cancelElement

Window.children

Window.defaultElement

Window.parent

Window.properties

Used in:

BookComponent Book.NewSeriesBookComponent (previous: Object)

Object Book.NewSeriesObject (objType: int, previous: Object)

int Doc.AddTableVariables (tblFormatOrTblId: Object, allTables: bool, insertContVariable: bool, insertSheetVariable: bool)

int Doc.DeleteUndefinedAttribute (attrName: string, scope: int, objId: Object)

BodyPage Doc.NewSeriesBodyPage (previous: Object)

Object Doc.NewSeriesObject (objType: int, previous: Object)

Pgf Doc.NewSeriesPgf (previous: Object)

int Doc.SetAttributeSimple (attrName: string, attrValStr: string, scope: int, objId: Object)

any Function.apply (thisObj: Object, args: Array)

any Function.call (thisObj: Object, argument: any)

int Globals.Externalize (srcDocId: Object, objId: Object, dstFolder: string)

bool Globals.IsFileValid (docOrBookId: Object, silent: bool)

Object Group.add (type: String[, bounds: Bounds][, text: String][, properties: Object])

int Menu.AnimateMenu (menuitem: Object, sleep: int, realLabel: string, docOrBook: Object, action: bool)

bool Object.isPrototypeOf (what: Object)

bool Object.isValid (what: Object)

Object Panel.add (type: String[, bounds: Bounds][, text: String][, properties: Object])

UIEvent UIEvent.UIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])

void UIEvent.initUIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])

void Window.Window (type: String[, title: String][, bounds: Bounds][, properties: Object])

Object Window.add (type: String[, bounds: Bounds][, text: String][, properties: Object])

void XML.setSettings (obj: Object)

Return

Object Book.GetUniqueObject (objType: int, unique: int)

Object Book.Import (textLocP: TextLoc, filename: string, importParams: PropVals, importReturnParams: PropVals)

Object Book.NewIterator (paramsp: PropVals)

Object Book.NewSeriesObject (objType: int, previous: Object)

Object Book.Save (saveAsName: string, saveParams: PropVals, saveReturnParams: PropVals)

Object CMSObject.CMSOpenFile (openParams: IdValuePairs)

Object Doc.GetNamedObject (objType: int, name: string)

Object Doc.GetUniqueObject (objType: int, unique: int)

Object Doc.Import (textLocP: TextLoc, filename: string, importParams: PropVals, importReturnParams: PropVals)

Object Doc.NewAnchoredFormattedObject (objType: int, format: string, textLoc: TextLoc)

Object Doc.NewAnchoredObject (objType: int, textloc: TextLoc)

Object Doc.NewGraphicObject (objType: int, parent: FrameObject)

Object Doc.NewIterator (paramsp: PropVals)

Object Doc.NewNamedObject (objType: int, name: string)

Object Doc.NewSeriesObject (objType: int, previous: Object)

Object Doc.Save (saveAsName: string, saveParams: PropVals, saveReturnParams: PropVals)

Object Globals.NewXML (newXMLParams: PropVals, newXMLReturnParamspp: PropVals)

Object Globals.Open (fileName: string, openParams: PropVals, openReturnParams: PropVals)

Object Globals.SimpleOpen (fileName: string, interactive: int)

Object Group (SUI).add (type: String[, bounds: Bounds][, text: String][, properties: Object])

Object Object.Object (what: any)

Object Object.valueOf ()

Object Panel (SUI).add (type: String[, bounds: Bounds][, text: String][, properties: Object])

Object Window (SUI).add (type: String[, bounds: Bounds][, text: String][, properties: Object])

Object XML.defaultSettings ()

Object XML.settings ()

Object app.GetNamedObject (objType: int, name: string)

Object app.NewNamedObject (objType: int, name: string)


Adobe FrameMaker-12 Object Model JS: QName

Class

QName

A qualified XML name, containing the URI and the local name.

QuickLinks

 QName

Properties

Property | Type | Access | Description
localName | string | readonly | The local name part of the qualified name.
uri | string | readonly | The URI part of the qualified name.

Methods

Constructor

QName QName (uri: any[, name: string])
Creates a QName object.
Parameter | Type | Description
uri | any | The URI, specified as a Namespace object, an existing QName object, or string. • If this is a Namespace object, the URI is set to the namespace URI, and there is no local name. • If this is a QName object, the URI and localName is set to those of that object. • If this is a string, the URI is set to that string.
name | string | The local name. Used only if URI is given as a string. (Optional)

Example new QName ("http:/www.adobe.com", "name")

Used in:

void XML.setName (name: QName)

Return

QName QName.QName (uri: any[, name: string])

QName XML.name ()


Adobe FrameMaker-12 Object Model JS: Reflection

Class

Reflection

Provides information about a class.

QuickLinks

 find, toXML

Properties

Property | Type | Access | Description
description | string | readonly | The long description text.
help | string | readonly | The short description text.
methods | Array of ReflectionInfo | readonly | An array of method descriptions.
name | string | readonly | The class name.
properties | Array of ReflectionInfo | readonly | An array of property descriptions.
sampleCode | string | readonly | Sample code, if present.
sampleFile | File | readonly | A file containing sample code. May be null.
staticMethods | Array of ReflectionInfo | readonly | An array of class method descriptions.
staticProperties | Array of ReflectionInfo | readonly | An array of class property descriptions.

Methods

Instances

ReflectionInfo find (name: string)
Finds an element description by name.
Parameter | Type | Description
name | string | The name of the element to find.

XML toXML ()
Returns this class information as XML in OMV format.

Element of

Object.reflect

ReflectionInfo.parent


Adobe FrameMaker-12 Object Model JS: ReflectionInfo

Class

ReflectionInfo

Provides information about a method, a property or a method parameters.

Hierarchy

Reflection
ReflectionInfo

Properties

Property | Type | Access | Description
arguments | Array of ReflectionInfo | readonly | The description of method or function arguments.
dataType | string | readonly | The data type.
defaultValue | any | readonly | The default value.
description | string | readonly | The long description text.
help | string | readonly | The short description text.
isCollection | bool | readonly | Contains true if the class describes a collection class.
max | number | readonly | The maximum value.
min | number | readonly | The minimum value.
name | string | readonly | The element name.
parent | Reflection | readonly | The class object that this element belongs to.
sampleCode | string | readonly | Sample code, if present.
sampleFile | File | readonly | A file containing sample code. May be null.
type | string | readonly | The element type. One of unknown, readonly, readwrite, createonly, method or parameter.

Element of

Reflection.methods

Reflection.properties

Reflection.staticMethods

Reflection.staticProperties

ReflectionInfo.arguments

Return

ReflectionInfo Reflection.find (name: string)


Adobe FrameMaker-12 Object Model JS: RegExp

Class

RegExp

Wraps a regular expression.

QuickLinks

 RegExp, compile, exec, test, toString

Class

Property | Type | Access | Description
$1 | string | readonly | The matched subexpression #1.
$2 | string | readonly | The matched subexpression #2.
$3 | string | readonly | The matched subexpression #3.
$4 | string | readonly | The matched subexpression #4.
$5 | string | readonly | The matched subexpression #5.
$6 | string | readonly | The matched subexpression #6.
$7 | string | readonly | The matched subexpression #7.
$8 | string | readonly | The matched subexpression #8.
$9 | string | readonly | The matched subexpression #9.
global | bool | r/w | Indicates whether the match is a global match.
ignoreCase | bool | r/w | Indicates whether the match is not case sensitive.
input | string | r/w | The original input string.
lastMatch | string | readonly | The last match.
lastParen | string | readonly | The value of the last matched subexpression.
leftContext | string | readonly | The string before the match.
multiline | bool | r/w | Indicates whether the match matches multiple lines.
rightContext | string | readonly | The string after the match.

Methods

Constructor

RegExp RegExp (pattern: string[, flags: string])
Creates and returns a new RegExp object set to the value of the argument converted to a regular expression.
Parameter | Type | Description
pattern | string | The pattern to convert.
flags | string | Flags that control how the conversion is performed. A string containing any combination of the letters i, m, g: • "i" -- ignore case in pattern matching • "m" -- treat the string as multiple lines • "g" -- do global pattern matching (Optional)

Instances

bool compile (pattern: string)
Compiles a string to a regular expression. Returns true if the compilation was successful.
Parameter | Type | Description
pattern | string | The pattern to compile.

Array exec (text: string)
Execute a regular expression.
The return value is an array of matches, with the first element containing the match, and successive elements containing the results of any matching subexpression in their order of appearance. If there is no match, the result is null.
Parameter | Type | Description
text | string | The string to match.

bool test (text: string)
Execute a regular expression, and return true if there is a match.
Parameter | Type | Description
text | string | The string to match.

string toString ()
Converts this RegExp object to a string.

Used in:

Array String.match (regexp: RegExp)

number String.search (search: RegExp)

Return

RegExp RegExp.RegExp (pattern: string[, flags: string])


Adobe FrameMaker-12 Object Model JS: Socket

Class

Socket

Creates a TCP/IP connection, or establishes a TCP/IP server.

QuickLinks

 Socket, close, listen, open, poll, read, readln, write, writeln

Properties

Property | Type | Access | Description
connected | bool | readonly | When true, the connection is active.
encoding | string | r/w | Sets or retrieves the name of the encoding used to transmit data. Typical values are "ASCII", "BINARY", or "UTF-8".
eof | bool | readonly | When true, the receive buffer is empty.
error | string | r/w | A message describing the most recent error. Setting this value clears any error message.
host | string | readonly | The name of the remote computer when a connection is established. If the connection is shut down or does not exist, the property contains the empty string.
timeout | number | r/w | The timeout in seconds to be applied to read or write operations. (default: 10)

Methods

Constructor

Socket Socket ()
Creates a new Socket object.

Instances

bool close ()
Terminates the open connection.
Returns true if the connection was closed, false on I/O errors.
Deleting the object also closes the connection, but not until JavaScript garbage-collects the object. The connection might stay open longer than you wish if you do not close it explicitly.

bool listen (port: number[, encoding: string=ASCII])
Instructs the object to start listening for an incoming connection.
The call to open() and the call to listen()are mutually exclusive. Call one function or the other, not both.
Parameter | Type | Description
port | number (range: 1 - 65535) | The TCP/IP port number to listen on. Valid port numbers are 1 to 65535. Typical values are 80 for a Web server, 23 for a Telnet server and so on.
encoding | string | The encoding to be used for the connection (default: ASCII) Typical values are "ASCII", "BINARY", or "UTF-8". (Optional)

bool open (host: string[, encoding: string=ASCII])
Opens the connection for subsequent read/write operations.
The call to open() and the call to listen() are mutually exclusive. Call one function or the other, not both.
Parameter | Type | Description
host | string | The server to connect to. This can be a DNS name, an IPv4 address, or an IPv6 address, followed by a colon and a port number.
encoding | string | The encoding to be used for the connection (default: ASCII) Typical values are "ASCII", "binary", or "UTF-8". (Optional)

Socket poll ()
Checks a listening object for a new incoming connection.
If a connection request was detected, the method returns a new Socket object that wraps the new connection. Use this connection object to communicate with the remote computer. After use, close the connection and delete the JavaScript object. If no new connection request was detected, the method returns null.

string read ([count: number])
Reads up to the specified number of characters from the connection. CR characters are ignored unless the encoding is set to "BINARY".
Returns a string that contains up to the number of characters that were supposed to be read, or the number of characters read before the connection closed or timed out.
Parameter | Type | Description
count | number | The number of characters to read. If not supplied, the connection attempts to read as many characters it can get and returns immediately. (Optional)

string readln ()
Reads one line of text up to the next line feed.
Line feeds are recognized as LF or CRLF pairs. CR characters are ignored. Returns a string containing the characters.

bool write (text: string)
Concatenates all arguments into a single string and writes that string to the connection.
Parameter | Type | Description
text | string | Any number of string values. All arguments are concatenated to form the string to be written. CRLF sequences are converted to LFs unless the encoding is set to "BINARY".

bool writeln (text: string)
Concatenates all arguments into a single string, appends a LF character, and writes that string to the connection.
Parameter | Type | Description
text | string | Any number of string values. All arguments are concatenated to form the string to be written. CRLF sequences are converted to LFs unless the encoding is set to "BINARY".

Example
See file Socket.jsx

Return

Socket Socket.Socket ()

Socket Socket.poll ()


Adobe FrameMaker-12 Object Model JS: String

Class

String

A character string. Each character is adressable by index.

QuickLinks

 String, anchor, big, blink, bold, charAt, charCodeAt, concat, fixed, fontcolor, fontsize, fromCharCode, indexOf, italics, lastIndexOf, link, localeCompare, match, replace, search, slice, small, split, strike, sub, substr, substring, sup, toLocaleLowerCase, toLocaleUpperCase, toLowerCase, toSource, toString, toUpperCase, valueOf

Properties

Property | Type | Access | Description
length | number | readonly | The length of the string.

Methods

Constructor

String String (value: any)
Returns a string representation of the value given as an argument.
Parameter | Type | Description
value | any | A number, variable, or object to convert to a string.

Example new String(value)

Class

String fromCharCode (value1: number)
Returns a string created by concatenation one or more characters specified as ASCII values.
Parameter | Type | Description
value1 | number | One or more ASCII values.

Example String.fromCharCode(value1,...valueN)

Instances

string anchor (name: string)
Returns a string consisting of this string enclosed in a <a> tag.
Parameter | Type | Description
name | string | The text to be stored in the anchors' name attribute.

string big ()
Returns a string consisting of this string enclosed in a <big> tag.

string blink ()
Returns a string consisting of this string enclosed in a <blink> tag.

string bold ()
Returns a string consisting of this string enclosed in a <b> tag.

string charAt (index: number)
Returns the character at the specified index.
Parameter | Type | Description
index | number | An integer between 0 and string.length -1, specifying the character to return.

Example string.charAt(index)

number charCodeAt (index: number)
Returns the Unicode value of the character at the given index.
Parameter | Type | Description
index | number | An integer between 0 and string.length -1, specifying the character.

Example string.charCodeAt(index)

string concat (value: string)
If necessary, converts the one or more given values to strings.
Those values are concatenated with the original string, the result is returned. The original string is not effected. Returns the concatenated string.
Parameter | Type | Description
value | string | The values to be concatenated with the given string.

Example string.concat(value1,...valueN)

string fixed ()
Returns a string consisting of this string enclosed in a <tt> tag.

string fontcolor (color: string)
Returns a string consisting of this string enclosed in a <font> tag.
Parameter | Type | Description
color | string | The value to be stored in the tag's color attribute.

string fontsize (size: number)
Returns a string consisting of this string enclosed in a <font> tag.
Parameter | Type | Description
size | number | The value to be stored in the tag's size attribute.

number indexOf (searchValue: string[, offset: number])
Returns the index within the string of the first occurrence of the specified string, starting the search at fromIndex if provided.
Parameter | Type | Description
searchValue | string | The string for which to search.
offset | number | The starting offset of the search. (Optional)

Example string.indexOf(searchValue, fromIndex)

string italics ()
Returns a string consisting of this string enclosed in a <i> tag.

number lastIndexOf (searchValue: string[, offset: number])
Returns the index within the string of the last occurrence of the specified value.
The string is searched backward, starting at fromIndex. Returns the index within the string where the last occurrence of searchValue was found, or -1 if it was not found.
Parameter | Type | Description
searchValue | string | The string for which to search.
offset | number | The starting offset of the search. (Optional)

Example string.lastIndexOf(searchValue, fromIndex)

string link (href: string)
Returns a string consisting of this string enclosed in a <a> tag.
Parameter | Type | Description
href | string | The value to be stored in the tag's href attribute.

number localeCompare (what: string)
Performs a localized comparison of two strings.
Parameter | Type | Description
what | string | The string to compare with.

Array match (regexp: RegExp)
Matches a string against a regular expression.
Parameter | Type | Description
regexp | RegExp | The regular expression to use.

string replace (what: any, with: string)
Parameter | Type | Description
what | any |
with | string |

number search (search: RegExp)
Parameter | Type | Description
search | RegExp |

string slice (startSlice: number[, endSlice: number])
Extracts a substring of the given string and returns it as a new string.
The substring begins at startSlice, and includes all characters up to, but not including the character at the index endSlice. A negative value indexes from the end of the string. For example, a negative value for startSlice is resolved as: string. length + startSlice. The original string is unchanged. Returns a substring of characters from the given string, starting at startSlice and ending with endSlice-1.
Parameter | Type | Description
startSlice | number | The index at which to begin extraction.
endSlice | number | The index at which to end extraction. If omitted, slice extracts to the end of the string. (Optional)

Example string.slice(startSlice, endSlice)

string small ()
Returns a string consisting of this string enclosed in a <small> tag.

string split (delimiter: string, limit: number)
Splits a string into a group of substrings, places those strings in an array, and returns the array.
The substrings are created by breaking the original string at places that match delimiter, the delimiter characters are removed. Returns an array whose elements are the substrings.
Parameter | Type | Description
delimiter | string | Specifies the string to use for delimiting. If delimiter is omitted, the array returned contains one element, consisting of the entire string.
limit | number |

Example string.split(delimiter)

string strike ()
Returns a string consisting of this string enclosed in a <strike> tag.

string sub ()
Returns a string consisting of this string enclosed in a <sub> tag.

string substr (start: number, length: number)
Returns a string containing the characters beginning at the specified index, start, through the specified number of characters.
The original string is unchanged. Returns a string containing the extracted characters.
Parameter | Type | Description
start | number | Location at which to begin extracting characters.
length | number | (OptIonal) The number of characters to extract.

Example string.substr(start, length)

string substring (indexA: number[, indexB: number])
Returns a substring of the given string by extracting characters from indexA up to but not including indexB.
The original string is unchanged. Returns a substring of characters from the given string, starting at indexA and ending with indexB-1.
Parameter | Type | Description
indexA | number | The index to begin extracting.
indexB | number | (Optional) The index at which to end extraction. If omitted, slice extracts to the end of the string.

Example string.substring(indexA, indexB)

string sup ()
Returns a string consisting of this string enclosed in a <sup> tag.

string toLocaleLowerCase ()
Returns a new string which contains all the characters of the original string converted to lowercase (localized).
The original string is unchanged.

string toLocaleUpperCase ()
Returns a new string which contains all the characters of the original string converted to uppercase (localized).
The original string is unchanged.

string toLowerCase ()
Returns a new string which contains all the characters of the original string converted to lowercase.
The original string is unchanged.

Example string.toLowerCase()

string toSource ()
Creates a string representation of this object that can be fed back to eval() to re-create an object. Works only with built-in classes.

string toString ()
Returns itself.

string toUpperCase ()
Returns a new string which contains all the characters of the original string converted to uppercase.
The original string is unchanged.

Example string.toUpperCase()

string valueOf ()
Returns itself.

Element of

Button.alignment

Button.helpTip

Button.justify

Button.shortcutKey

Button.text

Button.type

Checkbox.alignment

Checkbox.helpTip

Checkbox.justify

Checkbox.shortcutKey

Checkbox.text

Checkbox.type

DropDownList.alignment

DropDownList.helpTip

DropDownList.shortcutKey

DropDownList.type

EditText.alignment

EditText.helpTip

EditText.justify

EditText.shortcutKey

EditText.text

EditText.textselection

EditText.type

Event.eventPhase

Event.type

FlashPlayer.alignment

FlashPlayer.helpTip

FlashPlayer.type

Group.alignChildren

Group.alignment

Group.helpTip

Group.orientation

Group.type

IconButton.alignment

IconButton.helpTip

IconButton.shortcutKey

IconButton.type

KeyboardState.keyName

ListBox.alignment

ListBox.helpTip

ListBox.shortcutKey

ListBox.type

ListItem.text

ListItem.type

Panel.alignChildren

Panel.alignment

Panel.helpTip

Panel.justify

Panel.orientation

Panel.text

Panel.type

Progressbar.alignment

Progressbar.helpTip

Progressbar.type

RadioButton.alignment

RadioButton.helpTip

RadioButton.justify

RadioButton.shortcutKey

RadioButton.text

RadioButton.type

ScriptUI.Alignment

ScriptUI.coreVersion

ScriptUI.frameworkName

ScriptUIBrush.theme

ScriptUIFont.family

ScriptUIFont.name

ScriptUIFont.substitute

ScriptUIImage.format

ScriptUIImage.name

ScriptUIImage.pathname

ScriptUIPen.theme

ScriptUIPen.type

Scrollbar.alignment

Scrollbar.helpTip

Scrollbar.shortcutKey

Scrollbar.type

Slider.alignment

Slider.helpTip

Slider.shortcutKey

Slider.type

StaticText.alignment

StaticText.helpTip

StaticText.justify

StaticText.shortcutKey

StaticText.text

StaticText.type

TreeView.alignment

TreeView.helpTip

TreeView.shortcutKey

TreeView.type

UIEvent.eventPhase

UIEvent.type

Window.alignChildren

Window.alignment

Window.frameworkName

Window.helpTip

Window.justify

Window.orientation

Window.shortcutKey

Window.text

Window.type

Used in:

Boolean Button.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void Button.notify ([eventName: String])

Boolean Button.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Checkbox.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void Checkbox.notify ([eventName: String])

Boolean Checkbox.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

ListItem DropDownList.add (type: String[, text: String])

Boolean DropDownList.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

ListItem DropDownList.find (text: String)

void DropDownList.notify ([eventName: String])

Boolean DropDownList.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean EditText.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void EditText.notify ([eventName: String])

Boolean EditText.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Event (SUI) Events.createEvent (eventType: String)

Boolean FlashPlayer.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Any FlashPlayer.invokePlayerFunction (name: String[, argument: Any])

void FlashPlayer.notify ([eventName: String])

Boolean FlashPlayer.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Object Group.add (type: String[, bounds: Bounds][, text: String][, properties: Object])

Boolean Group.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Group.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean IconButton.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void IconButton.notify ([eventName: String])

Boolean IconButton.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

ListItem ListBox.add (type: String[, text: String])

Boolean ListBox.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

ListItem ListBox.find (text: String)

void ListBox.notify ([eventName: String])

Boolean ListBox.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Object Panel.add (type: String[, bounds: Bounds][, text: String][, properties: Object])

Boolean Panel.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Panel.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Progressbar.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Progressbar.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean RadioButton.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void RadioButton.notify ([eventName: String])

Boolean RadioButton.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

String ScriptUI.getResourceText (text: String)

ScriptUIFont ScriptUI.newFont (name: String, style: String | Number, size: Number)

ScriptUIImage ScriptUI.newImage (normal: String[, disabled: String][, pressed: String][, rollover: String])

void ScriptUIGraphics.drawString (text: String, pen: ScriptUIPen, x: Number, y: Number[, font: ScriptUIFont])

Dimension ScriptUIGraphics.measureString (text: String[, font: ScriptUIFont][, boundingWidth: Number])

ScriptUIBrush ScriptUIGraphics.newBrush (type: Number, color: Array of Number | String)

ScriptUIPen ScriptUIGraphics.newPen (type: Number, color: Array of Number | String, width: Number)

Boolean Scrollbar.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void Scrollbar.notify ([eventName: String])

Boolean Scrollbar.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean Slider.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void Slider.notify ([eventName: String])

Boolean Slider.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Boolean StaticText.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void StaticText.notify ([eventName: String])

Boolean StaticText.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

ListItem TreeView.add (type: String[, text: String])

Boolean TreeView.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

ListItem TreeView.find (text: String)

void TreeView.notify ([eventName: String])

Boolean TreeView.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

UIEvent UIEvent.UIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])

void UIEvent.initEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, cancelable: Boolean=false])

void UIEvent.initUIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])

void Window.Window (type: String[, title: String][, bounds: Bounds][, properties: Object])

Object Window.add (type: String[, bounds: Bounds][, text: String][, properties: Object])

Boolean Window.addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

void Window.alert (message: String[, title: String][, errorIcon: Boolean=false])

Boolean Window.confirm (message: String[, noAsDefault: Boolean=false][, title: String])

Window Window.find (type: String, title: String)

void Window.notify ([eventName: String])

String Window.prompt (prompt: String[, default: String][, title: String])

Boolean Window.removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])

Return

String ScriptUI.getResourceText (text: String)

String String.String (value: any)

String String.fromCharCode (value1: number)

String Window (SUI).prompt (prompt: String[, default: String][, title: String])


Adobe FrameMaker-12 Object Model JS: UnitValue

Class

UnitValue

Represents a measurement as a combination of values and unit.

Note that this object is not available in all applications.

QuickLinks

 as, convert

Properties

Property | Type | Access | Description
baseUnit | UnitValue | r/w | The base unit.
type | string | readonly | The unit name.
value | number | r/w | The numeric value.

Class

Property | Type | Access | Description
baseUnit | UnitValue | r/w | The base unit for all conversions.

Methods

Instances

UnitValue as (unitName: string)
Returns this instance as a different unit.
Parameter | Type | Description
unitName | string | The unit name.

any convert (unitName: string)
Converts this instance to a different unit.
Parameter | Type | Description
unitName | string | The unit name.

Element of

UnitValue.baseUnit

UnitValue.baseUnit

Return

UnitValue UnitValue.as (unitName: string)


Adobe FrameMaker-12 Object Model JS: XML

Class

XML

Wraps XML into an object.

QuickLinks

 XML, addNamespace, appendChild, attribute, attributes, child, childIndex, children, comments, contains, copy, defaultSettings, descendants, elements, hasComplexContent, hasSimpleContent, inScopeNamespaces, insertChildAfter, insertChildBefore, length, localName, name, namespace, namespaceDeclarations, nodeKind, normalize, parent, prependChild, processingInstructions, removeNamespace, replace, setChildren, setLocalName, setName, setNamespace, setSettings, settings, text, toString, toXMLString, xpath

Class

Property | Type | Access | Description
ignoreComments | bool | r/w | Controls whether XML comments should be parsed (false) or ignored (true). (default: true)
ignoreProcessingInstructions | bool | r/w | Controls whether XML preprocessing instructions should be parsed (false) or ignored (true). (default: true)
ignoreWhitespace | bool | r/w | Controls whether whitespace should be parsed (false) or ignored (true). (default: true)
prettyIndent | number | r/w | The number of spaces used to indent pretty-printed XML. (default: 2)
prettyPrinting | bool | r/w | When true, XML is pretty-printed when converting to a string. (default: true)

Methods

Constructor

XML XML (text: string)
Parses an XML string. Throws an error if the XML is incorrect.
Parameter | Type | Description
text | string | The text to parse.

Class

Object defaultSettings ()
Returns an object containing the default parsing and print settings for XML.

void setSettings (obj: Object)
Sets the parsing and print setting for XML using an object returned by the settings() method.
Parameter | Type | Description
obj | Object | The object containing the settings to set.

Object settings ()
Returns an object containing the current parsing and print settings for XML.

Instances

XML addNamespace (namespace: Namespace)
Adds a namespace declaration to the node. Returns the XML object itself.
Parameter | Type | Description
namespace | Namespace | The namespace to add.

XML appendChild (child: XML)
Appends the given XML to this XML as a child. Returns the XML object itself.
If the argument is not XML, creates a new XML element containing the argument as text. The element name of that new XML is the same as the last element in the original XML.
Parameter | Type | Description
child | XML | The child XML to add.

XML attribute (name: string)
Returns a list containing all attribute elements matching the given name.
Parameter | Type | Description
name | string | The attribute name to look for.

XML attributes ()
Returns a list containing all attribute elements.

XML child (name: string)
Returns a list containing all children of this XML matching the given element name.
If the argument is a number, uses the number as index into the array of children.
Parameter | Type | Description
name | string | The name or the index of the child element.

number childIndex ()
Returns a number representing the ordinal position of this XML object within the context of its parent.

XML children ()
Returns an XML object containing all the properties of this XML object in order.

XML comments ()
Returns an XML object containing the properties of this XML object that represent XML comments.

bool contains (xml: XML)
Checks if this XML object contains the given XML object.
Parameter | Type | Description
xml | XML | The XML to search for.

XML copy ()
Creates a copy of this XML object.

XML descendants ([name: string])
Returns all the XML-valued descendants of this XML object with the given name.
If the name parameter is omitted, returns all descendants of this XML object.
Parameter | Type | Description
name | string | The name of the descendant to find. (Optional)

XML elements ([name: string])
Returns a list of XML children that are elements with a given name, or all children that are XML elements.
Parameter | Type | Description
name | string | The element name. If not supplied, gets all children that are XML elements. (Optional)

bool hasComplexContent ()
Reports whether this XML object contains complex content.
An XML object is considered to contain complex content if it represents an XML element that has child elements. XML objects representing attributes, comments, processing instructions and text nodes do not have complex content. The existence of attributes, comments, processing instructions and text nodes within an XML object is not significant in determining if it has complex content.

bool hasSimpleContent ()
Reports whether this XML object contains simple content.
An XML object is considered to contain simple content if it represents a text node, represents an attribute node or if it represents an XML element that has no child elements. XML objects representing comments and processing instructions do not have simple content. The existence of attributes, comments, processing instructions and text nodes within an XML object is not significant in determining if it has simple content.

Array inScopeNamespaces ()
Returns an array of Namespace objects mirroring the current list of valid namespaces at this element.
The last element of the returned array is the default namespace.

void insertChildAfter (child1: XML, child2: XML)
Inserts the given child2 after the given child1 in this XML object and returns this XML object.
If child1 is null, the method inserts child2 before all children of this XML object (that is, after none of them). If child1 does not exist in this XML object, the method returns without modifying this XML object.
Parameter | Type | Description
child1 | XML | The child to insert the other child after. If null, the method inserts child2 before all children of this XML object.
child2 | XML | The XML to insert.

void insertChildBefore (child1: XML, child2: XML)
Inserts the given child2 before the given child1 in this XML object and returns this XML object.
If child1 is null, the method inserts child2 after all children of this XML object (that is, before none of them). If child1 does not exist in this XML object, the method returns without modifying this XML object.
Parameter | Type | Description
child1 | XML | The child to search for. If null, the method inserts child2 after all children of this XML object.
child2 | XML | The XML to insert.

number length ()
Returns the number of elements contained in an XML list. If this XML object is not a list, returns 1.

string localName ()
Returns the local name of this XML object.
This value corresponds to the element name unless the name has a namespace prefix. For example, if the element has the name "ns:tag", the return value is "tag".

QName name ()
Returns a QName object containing the URI and the local name of the element.

Namespace namespace ()
Returns a Namespace object containing the namespace URI of the current element.

Array namespaceDeclarations ()
Returns an array containing all namespace declarations of this XML object.

string nodeKind ()
Returns the type of this XML object as one of the strings "element", "attribute", "comment", "processing-instruction", or "text".

XML normalize ()
Puts all text nodes in this and all descendant XML objects into a normal form by merging adjacent text nodes and eliminating empty text nodes. Returns this XML object.

XML parent ()
Returns the parent object of this XML object.
The root object, as returned by the XML constructor, does not have a parent and returns null. Note that the E4X standard does not define what happens if this XML object is a list containing elements with multiple parents.

XML prependChild (child: XML)
Inserts a given child into this object before its existing XML properties, and returns this XML object.
Parameter | Type | Description
child | XML | The XML to insert.

XML processingInstructions ([name: string])
Returns a list of preprocessing instructions.
Collects processing-instructions with the given name, if supplied. Otherwise, returns an XML list containing all the children of this XML object that are processing-instructions regardless of their name.
Parameter | Type | Description
name | string | The name of the preprocessing instruction to return. (Optional)

XML removeNamespace (namespace: Namespace)
Removes the given namespace from this XML, and returns this XML.
Parameter | Type | Description
namespace | Namespace | The namespace to remove.

XML replace (name: string, value: XML)
Replaces the value of specified XML properties of this XML object returns this XML object.
This method acts like the assignment operator.
Parameter | Type | Description
name | string | The property name. Can be a numeric property name, a name for a set of XML elements, or the properties wildcard "*". If this XML object contains no properties that match the name, the method returns without modifying this XML object.
value | XML | The XML with which to replace the value of the matching property. Can be an XML object, XML list or any value that can be converted to a String with toString().

XML setChildren (value: XML)
Replaces all of the XML-valued properties in this object with a new value, and returns this XML object.
Parameter | Type | Description
value | XML | The new value, which can be a single XML object or an XML list.

void setLocalName (name: string)
Replaces the local name of this XML object with a string constructed from the given name
The local name is any part behind a colon character. If there is no colon, it is the entire name.
Parameter | Type | Description
name | string | The name to set.

void setName (name: QName)
Replaces the name of this XML object with the given QName object.
Parameter | Type | Description
name | QName | The fully qualified name.

void setNamespace (namespace: Namespace)
Sets the namespace for this XML element.
If the namespace has not been declared in the tree above this element, adds a namespace declaration.
Parameter | Type | Description
namespace | Namespace | The namespace to set.

XML text ()
Returns an XML list containing all XML properties of this XML object that represent XML text nodes.

string toString ()
Returns the string representation of this object.
For text and attribute nodes, this is the textual value of the node; for other elements, this is the result of calling the toXMLString() method. If this XML object is a list, concatenates the result of calling toString() on each element.

string toXMLString ()
Returns an XML-encoded string representation of this XML object.
Always includes the start tag, attributes and end tag of the XML object regardless of its content. It is provided for cases when the default XML to string conversion rules are not desired. Interprets the global settings XML.prettyPrint and XML.prettyIndent.

XML xpath (expr: string)
Evaluates the given XPath expression in accordance with the W3C XPath recommendation, using this XML object as the context node.
Parameter | Type | Description
expr | string | The XPath expression to use.

Used in:

XML XML.appendChild (child: XML)

bool XML.contains (xml: XML)

void XML.insertChildAfter (child1: XML, child2: XML)

void XML.insertChildBefore (child1: XML, child2: XML)

XML XML.prependChild (child: XML)

XML XML.replace (name: string, value: XML)

XML XML.setChildren (value: XML)

Return

XML Reflection.toXML ()

XML XML.XML (text: string)

XML XML.addNamespace (namespace: Namespace)

XML XML.appendChild (child: XML)

XML XML.attribute (name: string)

XML XML.attributes ()

XML XML.child (name: string)

XML XML.children ()

XML XML.comments ()

XML XML.copy ()

XML XML.descendants ([name: string])

XML XML.elements ([name: string])

XML XML.normalize ()

XML XML.parent ()

XML XML.prependChild (child: XML)

XML XML.processingInstructions ([name: string])

XML XML.removeNamespace (namespace: Namespace)

XML XML.replace (name: string, value: XML)

XML XML.setChildren (value: XML)

XML XML.text ()

XML XML.xpath (expr: string)


Adobe FrameMaker-12 Object Model JS: XMLList

Class

XMLList

An XML list object.

In this implementation, an XMLList object is synonymous to the XML object. The constructor accepts an XML list, but everything else works like the XML object.


Adobe FrameMaker-12 Object Model JS: Table of Contents, ScriptUI Classes

Adobe FrameMaker-12 Object Model

Contents

ScriptUI Classes

Don't like the panels and dialogs Adobe came up with? Create your own and see if you can do better.

Adobe FrameMaker-12.0

JavaScript Base Classes

ScriptUI Classes

Bounds

Button (SUI)

Checkbox (SUI)

Dimension

DrawState

DropDownList

EditText

Environment

Event (SUI)

Events (SUI)

FlashPlayer

Group (SUI)

IconButton

KeyboardState

LayoutManager

ListBox (SUI)

ListItem

Panel (SUI)

Point (SUI)

Progressbar

RadioButton (SUI)

ScriptUI

ScriptUIBrush

ScriptUIFont

ScriptUIGraphics

ScriptUIImage

ScriptUIPath

ScriptUIPen

Scrollbar

Slider

StaticText (SUI)

TreeView

UIEvent

Window (SUI)


Adobe FrameMaker-12 Object Model JS: Bounds

Class

Bounds

Defines the boundaries of a window within the screen's coordinate space, or of a UI element within the container's coordinate space.

A Bounds object is created when you set an element's bounds property. You can set the property using a JavaScript object with properties named left, top, right, bottom or x, y, width, height, or an array with 4 values in the order [x, y, wd, ht].

Properties

Property | Type | Access | Description
bottom | Number | r/w | The vertical coordinate, a pixel offset from the origin of the element's coordinate space.
height | Number | r/w | The height in pixels.
left | Number | r/w | The horizontal coordinate, a pixel offset from the origin of the element's coordinate space.
length | Number | readonly | The array length. (default: 4)
right | Number | r/w | The width in pixels.
top | Number | r/w | The height in pixels.
width | Number | r/w | The width in pixels.
x | Number | r/w | The horizontal coordinate, a pixel offset from the origin of the element's coordinate space.
y | Number | r/w | The vertical coordinate, a pixel offset from the origin of the element's coordinate space.

Element of

Button.bounds

Button.windowBounds

Checkbox.bounds

Checkbox.windowBounds

DropDownList.bounds

DropDownList.windowBounds

EditText.bounds

EditText.windowBounds

FlashPlayer.bounds

FlashPlayer.windowBounds

Group.bounds

Group.windowBounds

IconButton.bounds

IconButton.windowBounds

ListBox.bounds

ListBox.windowBounds

Panel.bounds

Panel.windowBounds

Progressbar.bounds

Progressbar.windowBounds

RadioButton.bounds

RadioButton.windowBounds

Scrollbar.bounds

Scrollbar.windowBounds

Slider.bounds

Slider.windowBounds

StaticText.bounds

StaticText.windowBounds

TreeView.bounds

TreeView.windowBounds

Window.bounds

Window.frameBounds

Window.windowBounds

Used in:

Object Group.add (type: String[, bounds: Bounds][, text: String][, properties: Object])

Object Panel.add (type: String[, bounds: Bounds][, text: String][, properties: Object])

void Window.Window (type: String[, title: String][, bounds: Bounds][, properties: Object])

Object Window.add (type: String[, bounds: Bounds][, text: String][, properties: Object])


Adobe FrameMaker-12 Object Model JS: Button (SUI)

Class

Button (SUI)

A pushbutton element containing a mouse-sensitive text string.

Calls the onClick() callback if the control is clicked or if its notify() method is called.

QuickLinks

 addEventListener, dispatchEvent, hide, notify, onActivate, onClick, onDeactivate, onDraw, onShortcutKey, removeEventListener, show

Hierarchy

Object
Button (SUI)

Properties

Property | Type | Access | Description
active | Boolean | r/w | True if this element is active. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
characters | Number (min: 0) | r/w | A number of characters for which to reserve space when calculating the preferred size of the element.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help string that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
justify | String | r/w | The text justification style. (default: left) One of left, center, or right. Justification only works if this value is set on creation of the element.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the container (properties used only when the element is created). A Button object has no creation properties, but the third argument to the add() method that creates it can be the initial text value.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
text | String | r/w | The text to display, a localizable string.
type | String | readonly | The element type; "button".
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onClick ()
An event-handler callback function, called when the element has been clicked

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: Checkbox (SUI)

Class

Checkbox (SUI)

A dual-state control showing a box that has a checkmark when the value is true, and is empty when the value is false.

Calls the onClick() callback if the control is clicked or if its notify() method is called.

QuickLinks

 addEventListener, dispatchEvent, hide, notify, onActivate, onClick, onDeactivate, onDraw, onShortcutKey, removeEventListener, show

Hierarchy

Object
Checkbox (SUI)

Properties

Property | Type | Access | Description
active | Boolean | r/w | True if this element is active. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
characters | Number (min: 0) | r/w | A number of characters for which to reserve space when calculating the preferred size of the element.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
justify | String | r/w | The default text justification style for child text elements. (default: left) One of left, center, or right. Justification only works if this value is set on creation of the element.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the item (properties used only when the element is created). A CheckBox object has no creation properties. The third argument to the add() method that creates it is the text to be displayed.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
text | String | r/w | The text to display, a localizable string.
type | String | readonly | The element type; "checkbox".
value | Boolean | r/w | The selection state of the control. When true, the control is in the selected or set state and displays the check mark. When false, shows an empty box.
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onClick ()
An event-handler callback function, called when the element has been clicked.

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: Dimension

Class

Dimension

Defines the size of a window or UI element. Contains a 2-element array.

Specifies the height and width of an element in pixels. A Dimension object is created when you set an element's size property. You can set the property using a JavaScript object with named properties {width: wd, height: ht}, or an array with 2 values in the order [wd, ht].

Properties

Property | Type | Access | Description
height | Number | r/w | The height in pixels.
length | Number | readonly | The array length. (default: 2)
width | Number | r/w | The width in pixels.

Element of

Button.maximumSize

Button.minimumSize

Button.preferredSize

Button.size

Checkbox.maximumSize

Checkbox.minimumSize

Checkbox.preferredSize

Checkbox.size

DropDownList.itemSize

DropDownList.maximumSize

DropDownList.minimumSize

DropDownList.preferredSize

DropDownList.size

EditText.maximumSize

EditText.minimumSize

EditText.preferredSize

EditText.size

FlashPlayer.maximumSize

FlashPlayer.minimumSize

FlashPlayer.preferredSize

FlashPlayer.size

Group.maximumSize

Group.minimumSize

Group.preferredSize

Group.size

IconButton.maximumSize

IconButton.minimumSize

IconButton.preferredSize

IconButton.size

ListBox.itemSize

ListBox.maximumSize

ListBox.minimumSize

ListBox.preferredSize

ListBox.size

Panel.maximumSize

Panel.minimumSize

Panel.preferredSize

Panel.size

Progressbar.maximumSize

Progressbar.minimumSize

Progressbar.preferredSize

Progressbar.size

RadioButton.maximumSize

RadioButton.minimumSize

RadioButton.preferredSize

RadioButton.size

ScriptUIImage.size

Scrollbar.maximumSize

Scrollbar.minimumSize

Scrollbar.preferredSize

Scrollbar.size

Slider.maximumSize

Slider.minimumSize

Slider.preferredSize

Slider.size

StaticText.maximumSize

StaticText.minimumSize

StaticText.preferredSize

StaticText.size

TreeView.itemSize

TreeView.maximumSize

TreeView.minimumSize

TreeView.preferredSize

TreeView.size

Window.frameSize

Window.maximumSize

Window.minimumSize

Window.preferredSize

Window.size

Return

Dimension ScriptUIGraphics.measureString (text: String[, font: ScriptUIFont][, boundingWidth: Number])


Adobe FrameMaker-12 Object Model JS: DrawState

Class

DrawState

Describes an input state at the time of the triggering ScriptUIGraphics.onDraw() event.

Contains properties that report whether the current control has the input focus, and the particular mouse button and keypress state. Passed in as argument to ScriptUIGraphics.onDraw().

Properties

Property | Type | Access | Description
altKeyPressed | Boolean | readonly | True if the Alt key is being pressed (in Windows only).
capsLockKeyPressed | Boolean | readonly | True if the Caps Lock key is being pressed.
cmdKeyPressed | Boolean | readonly | True if the Command key is being pressed (in Mac OS only).
ctrlKeyPressed | Boolean | readonly | True if the Ctrl key is being pressed.
hasFocus | Boolean | readonly | True if the element has the input focus.
leftButtonPressed | Boolean | readonly | True if the left mouse button is being pressed.
middleButtonPressed | Boolean | readonly | True if the middle mouse button is being pressed.
mouseOver | Boolean | readonly | True if the cursor is hovering over this element.
numLockKeyPressed | Boolean | readonly | True if the Num Lock key is being pressed.
optKeyPressed | Boolean | readonly | True if the Option key is being pressed (in Mac OS only).
rightButtonPressed | Boolean | readonly | True if the right mouse button is being pressed.
shiftKeyPressed | Boolean | readonly | True if the Shift key is being pressed.


Adobe FrameMaker-12 Object Model JS: DropDownList

Class

DropDownList

Displays a single visible item. When you click the control, a list drops down or pops up, and allows you to select one of the other items in the list.

Drop-down lists can have nonselectable separator items for visually separating groups of related items, as in a menu. You can specify the items on creation of the list object, or afterward using the list object's add() method. You can remove items programmatically with the list object's remove() and removeAll() methods. Calls the onChange() callback if the item selection is changed or if its notify() method is called.

QuickLinks

 add, addEventListener, dispatchEvent, find, hide, notify, onActivate, onChange, onDeactivate, onDraw, onShortcutKey, remove, removeAll, removeEventListener, show

Hierarchy

Object
DropDownList

Properties

Property | Type | Access | Description
active | Boolean | r/w | True if this element is active. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
itemSize | Dimension | r/w | The width and height in pixels of each item in the list. Used by auto-layout to determine the preferredSize of the list, if not otherwise specified. If not set explicitly, the size of each item is set to match the largest height and width among all items in the list
items | Array of ListItem | readonly | The array of choice items displayed in the drop-down or pop-up list. Access this array with a 0-based index. To obtain the number of items in the list, use .The objects are created when items are specified on creation of the parent list object, or afterward using the list control's add() method. Items in a drop-down list can be of type separator, in which case they cannot be selected, and are shown as a horizontal line. Each item has a selected property that is true when it is in the selected state.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the container (properties used only when the element is created). Creation properties of a DropDownList object can include: • items: An array of strings for the text of each list item. An item object is created for each item. An item with the text string "-" creates a separator item. Supply this property, or the items argument to the add() method, not both. This form is most useful for elements defined using Resource Specifications.
selection | ListItem | r/w | The currently selected list item. Setting this value causes the selected item to be highlighted and to be scrolled into view if necessary. If no items are selected, the value is null. Set to null to deselect all items.You can set the value using the index of an item, rather than an object reference. If set to an index value that is out of range, the operation is ignored. When set with an index value, the property still returns an object reference.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
type | String | readonly | The element type; "dropdownlist".
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onChange ()
An event-handler callback function, called when the content of the element has been changed

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

ListItem add (type: String[, text: String])
Adds an item or separator to the choices in this list.
Returns the item control object for type="item", or null for type="separator".
Parameter | Type | Description
type | String | The type of the child element. Either item (a basic, selectable item with a text label) or separator
text | String | The localizable text label for the item. (Optional)

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

ListItem find (text: String)
Retrieves an item object from the list that has a given text label.
Parameter | Type | Description
text | String | The text string to match.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

void remove (what: Any)
Removes a child item from the list.
Parameter | Type | Description
what | Any | The item or child to remove, specified by 0-based index, text value, or as a ListItem object.

void removeAll ()
Removes all child items from the list.

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: EditText

Class

EditText

An editable text field that the user can select and change.

Calls the onChange() callback if the text is changed and the user types Enter or the control loses focus, or if its notify() method is called. Calls the onChanging() callback when any change is made to the text. The textselection property contains currently selected text.

QuickLinks

 addEventListener, dispatchEvent, hide, notify, onActivate, onChange, onChanging, onDeactivate, onDraw, onShortcutKey, removeEventListener, show

Hierarchy

Object
EditText

Properties

Property | Type | Access | Description
active Boolean r/w True if this element is active.
An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment String r/w The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container.
This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive.
• For orientation=row:top, bottom, fill
• For orientation=column: left, right, fill
• For orientation=stack:top, bottom, left, right, fill
bounds Bounds r/w The boundaries of the element, in parent-relative coordinates.
Setting an element's size or location changes its bounds property, and vice-versa.
characters | Number (min: 0) | r/w | A number of characters for which to reserve space when calculating the preferred size of the element.
children | Array of Object | readonly | An array of child elements.
enabled Boolean r/w True if this element is enabled.
An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent Number (min: 0) r/w The number of pixels to indent the element during automatic layout.
Applies for column orientation and left alignment, or row orientation and top alignment.
justify String r/w The text justification style. (default: left)
One of left, center, or right. Justification only works if this value is set on creation of the element.
location Point r/w The upper left corner of this element relative to its parent.
The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize Dimension r/w The preferred size, used by layout managers to determine the best size for each element.
If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties Object r/w An object that contains one or more creation properties of the container (properties used only when the element is created).
Creation properties of an EditText object can include:
• multiline: When false (the default), the control displays a single line of text. When true, the control displays multiple lines, in which case the text wraps within the width of the control.
• readonly: When false (the default), the control accepts text input. When true, the control does not accept input but only displays the contents of the text property.
• noecho: When false (the default), the control displays input text. When true, the control does not display input text (used for password input fields).
• enterKeySignalsOnChange: When false (the default), the control signals an
event when the editable text is changed and the control loses the keyboard focus (that is, the user tabs to another control, clicks outside the control, or types Enter). When true, the control only signals an onChange() event when the editable text is changed and the user types Enter; other changes to the keyboard focus do not signal the event.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size Dimension r/w The current dimensions of this element.
Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
text | String | r/w | The current text displayed in the field, a localizable string.
textselection String r/w The currently selected text, or the empty string if there is no text selected.
Setting the value replaces the current text selection and modifies the value of the text property. If there is no current selection, inserts the new value into the text string at the current insertion point. The textselection value is reset to an empty string after it modifies the text value. Note that setting the textselection property before the element's parent Window exists is an undefined operation.
type | String | readonly | The element type; "edittext".
visible Boolean r/w True if this element is shown, false if it is hidden.
When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onChange ()
An event-handler callback function, called when the content of the element has been changed
The handler is called only when the change is complete–that is, when focus moves to another control, or the user types Enter. The exact behavior depends on the creation parameter enterKeySignalsOnChange;see the
property.

void onChanging ()
An event-handler callback function, called when the content of the element is in the process of changing
The handler is called for each keypress while this control has the input focus.

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: Environment

Class

Environment

Defines attributes of the ScriptUI environment.

Access through the ScriptUI.environment property.

Properties

Property | Type | Access | Description
keyboardState | KeyboardState | readonly | An object that reports the active state of the keyboard at any time. Provides access to the key state independent of the event-handling framework.

Element of

ScriptUI.environment


Adobe FrameMaker-12 Object Model JS: Event (SUI)

Class

Event (SUI)

Base class for UIEvent.

Encapsulates input event information for an event that propagates through a container and control hierarchy. Implements W3C standard event handling.

QuickLinks

 preventDefault, stopPropagation

Properties

Property | Type | Access | Description
bubbles | Boolean | readonly | True if the event is of a type that bubbles.
cancelable | Boolean | readonly | True if the default action associated with the event can be canceled with preventDefault().
captures | Boolean | readonly | True if this event can be captured.
currentTarget | Boolean | readonly | The event target object which is currently handling the event. During capturing and bubbling, this is different from the property target.
eventPhase | String | readonly | The current phase of event propagation; one of none, target, capture, bubble.
target | Object | readonly | The event target object for this event.
timeStamp | Date | readonly | The date and time at which the event occurred.
type | String | readonly | The name of the event that this object represents. Event types are listed in the JavaScript Tools Guide.

Class

Property | Type | Access | Description
AT_TARGET | any | readonly |
BUBBLING_PHASE | any | readonly |
CAPTURING_PHASE | any | readonly |
NOT_DISPATCHING | any | readonly |

Methods

Instances

void preventDefault ()
Prevents the default action associated with this event from being called.

void stopPropagation ()
Stops the propagation of this event.

Return

Event Events (SUI).createEvent (eventType: String)


Adobe FrameMaker-12 Object Model JS: Events (SUI)

Class

Events (SUI)

Provides access to objects used in the ScriptUI event system.

Access through the ScriptUI.events property.

QuickLinks

 createEvent

Methods

Instances

Event createEvent (eventType: String)
Creates an instance of the specified Event subclass.
The Event returned is a UIEvent, KeyboardEvent or MouseEvent object, depending on the requested type. This object can be passed as a parameter to an element's dispatchEvent function in order to simulate a user-interaction event.
Parameter | Type | Description
eventType | String | The name of an event type: one of "UIEvent", "KeyboardEvent", or "MouseEvent".


Adobe FrameMaker-12 Object Model JS: FlashPlayer

Class

FlashPlayer

A control that contains a Flash Player, which can load and play Flash movies stored in SWF files.

The ScriptUI FlashPlayer element runs the Flash application within an Adobe application. The Flash application runs ActionScript, a different implementation of JavaScript from the ExtendScript version of JavaScript that Adobe applications run. A control object of this type contains functions that allow your script to load SWF files, control movie playback, and communicate with the ActionScript environment.

QuickLinks

 addEventListener, callback, dispatchEvent, hide, invokePlayerFunction, loadMovie, notify, playMovie, removeEventListener, show, stopMovie

Hierarchy

Object
FlashPlayer

Properties

Property | Type | Access | Description
active | Boolean | r/w | True if this element is active. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the container (properties used only when the element is created). A FlashPlayer object has no creation properties.
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
type | String | readonly | The element type, "flashplayer".
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void callback ()
A function definition for a callback from the Flash ActionScript environment.
The Flash ActionScript code can call any callback function defined on the ExtendScript side of the FlashPlayer object, invoking it by name as a property of the control object. The function can take any arguments of a supported data types, and can return any value of a supported data type. data types:Number, String, Boolean, null, undefined, Object, Array.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

Any invokePlayerFunction (name: String[, argument: Any])
Invokes an ActionScript function defined in the Flash application.
Returns the result of the invoked function, which must be one of the allowed types. The ActionScript class and date objects are not supported as return values.
Parameter | Type | Description
name | String | The name of a Flash ActionScript function that has been registered with the ExternalInterface object by the currently loaded SWF file.
argument | Any | An argument to pass through to the function. There can be any number of arguments. An argument must be one of these data types:Number, String, Boolean, null, undefined, Object, Array. No other data types are supported. (Optional)

void loadMovie (file: File)
Loads a movie into the Flash Player, and begins playing it.
Parameter | Type | Description
file | File | The File object for the SWF file to load.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

void playMovie ([rewind: Boolean=false])
Restarts a movie that has been stopped.
Do not use on a movie that is currently playing.
The stopMovie()-playMovie() sequence does not work for SWF files produced by Flex, or for some files produced by Flash Authoring (depending on how they were implemented).
Parameter | Type | Description
rewind | Boolean | When true, restarts the movie from the beginning; otherwise, starts playing from the point where it was stopped. (default: false)

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.

void stopMovie ()
Halts playback of the current movie.
The stopMovie()-playMovie() sequence does not work for SWF files produced by Flex, or for some files produced by Flash Authoring (depending on how they were implemented).
Using stopMovie() from the player's hosting environment has no effect on an SWF file playing in a ScriptUI Flash Player element. It is, however, possible to produce an SWF using Flash Authoring that can stop itself in response to user interaction.


Adobe FrameMaker-12 Object Model JS: Group (SUI)

Class

Group (SUI)

A container for other controls within a window.

A group can specify layout options for its child elements. Hiding a group hides all its children. Making it visible makes visible those children that are not individually hidden.

QuickLinks

 add, addEventListener, dispatchEvent, hide, onDraw, remove, removeEventListener, show

Hierarchy

Object
Group (SUI)

Properties

Property | Type | Access | Description
alignChildren | String | r/w | Tells the layout manager how unlike-sized children of this container should be aligned within a column or row. Order of creation determines which children are at the top of a column or the left of a row; the earlier a child is created, the closer it is to the top or left of its column or row. If defined, alignment for a child element overrides the alignChildren setting for the parent container. See alignment property for values.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
layout | LayoutManager | r/w | The layout manager for this container. The first time a container object is made visible, ScriptUI invokes this layout manager by calling its layout() function. Default is an instance of the LayoutManager class that is automatically created when the container element is created.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
margins | Number | r/w | The number of pixels between the edges of a container and the outermost child elements. You can specify different margins for each edge of the container. The default value is based on the type of container, and is chosen to match the standard Adobe UI guidelines.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
orientation | String | r/w | The layout orientation of children in a container. Interpreted by the layout manager for the container. The default LayoutManager Object accepts the (case-insensitive) values row, column, or stack. For window and panel, the default is column, and for group the default is row. The allowed values for the container's alignChildren and its children's alignment properties depend on the orientation.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the control (properties used only when the element is created). A Group object has no creation properties.
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
spacing | Number | r/w | The number of pixels separating one child element from its adjacent sibling element. Because each container holds only a single row or column of children, only a single spacing value is needed for a container. The default value is based on the type of container, and is chosen to match standard Adobe UI guidelines.
type | String | readonly | The element type; "group".
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onDraw ()
An event-handler callback function, called when the group is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

Instances

Object add (type: String[, bounds: Bounds][, text: String][, properties: Object])
Adds a child element to this container.
Creates and returns a new control or container object and adds it to the children of this group.
Parameter | Type | Description
type | String | The type of the child element, as specified for the type property. Control types are listed in the JavaScript Tools Guide.
bounds | Bounds | A bounds specification that describes the size and position of the new control or container, relative to its parent. If supplied, this value creates a new Bounds object which is assigned to the new object's bounds property. (Optional)
text | String | The text or label, a localizable string. Initial text to be displayed in the control as the title, label, or contents, depending on the control type. If supplied, this value is assigned to the new object's text property. (Optional)
properties | Object | An object that contains one or more creation properties of the new child (properties used only when the element is created). The creation properties depend on the element type. See property of each control type. (Optional)

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void remove (what: Any)
Removes the specified child control from this group's children array.
No error results if the child does not exist.
Parameter | Type | Description
what | Any | The child control to remove, specified by 0-based index, text property value, or as a control object.

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: IconButton

Class

IconButton

A mouse-sensitive pushbutton that displays an image instead of text.

Calls the onClick() callback if the control is clicked or if its notify() method is called.

QuickLinks

 addEventListener, dispatchEvent, hide, notify, onActivate, onClick, onDeactivate, onDraw, onShortcutKey, removeEventListener, show

Hierarchy

Object
IconButton

Properties

Property | Type | Access | Description
active | Boolean | r/w | True if this element is active. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
image | ScriptUIImage | r/w | The image object that defines the image to be drawn.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the container (properties used only when the element is created). Creation properties of an IconButton object can include: • style: A string for the visual style, either "button", which has a visible border with a raised or 3D appearance, or "toolbutton", which has a flat appearance, appropriate for inclusion in a toolbar.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
type | String | readonly | The element type; "iconbutton".
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onClick ()
An event-handler callback function, called when the element has been clicked.

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: KeyboardState

Class

KeyboardState

Reports the active state of the keyboard.

Access through the ScriptUI.environment.keyboardState property. Query the properties of this object at any time to determine the current key that is down and any modifiers that are pressed.

Properties

Property | Type | Access | Description
altKey | Boolean | readonly | True if the Alt or Option key is pressed.
ctrlKey | Boolean | readonly | True if the Ctrl key is pressed.
keyName | String | readonly | A string containing the name of the currently pressed key, such as "a", or an empty string.
metaKey | Boolean | readonly | True if the Cmd key (in Mac OS) or Windows key (in Windows) is pressed.
shiftKey | Boolean | readonly | True if the Shift key is pressed.

Element of

Environment.keyboardState


Adobe FrameMaker-12 Object Model JS: LayoutManager

Class

LayoutManager

Controls the automatic layout behavior for a window or container.

The subclass AutoLayoutManager implements the default automatic layout behavior.

QuickLinks

 layout, resize

Methods

Instances

void layout ()
Invokes the automatic layout behavior for the managed container.
Adjusts sizes and positions of the child elements of this window or container according to the placement and alignment property values in the parent and children. Invoked automatically the first time the window is displayed. Thereafter, the script must invoke it explicitly to change the layout in case of changes in the size or position of the parent or children.

void resize ()
Performs a layout after a Window is resized, based on the new size.
Resizes the child elements of the managed container with a given alignment type, after the window has been resized by the user.

Element of

Group.layout

Panel.layout

Window.layout


Adobe FrameMaker-12 Object Model JS: ListBox (SUI)

Class

ListBox (SUI)

Displays a list of choices, represented by ListItem objects.

When you create the object, you specify whether it allows the user to select only one or multiple items. If a list contains more items than can be displayed in the available area, a scrollbar may appear that allows the user to scroll through all the list items.
You can specify the items on creation of the list object, or afterward using the list object's add() method. You can remove items programmatically with the list object's remove() and removeAll() methods. You can create a list box with multiple columns; in this case, each row is a selectable choice, and each ListItem represents one row.

QuickLinks

 add, addEventListener, dispatchEvent, find, hide, notify, onActivate, onChange, onDeactivate, onDoubleClick, onDraw, onShortcutKey, remove, removeAll, removeEventListener, show

Hierarchy

Object
ListBox (SUI)

Properties

Property | Type | Access | Description
active Boolean r/w True if this element is active.
An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment String r/w The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container.
This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive.
• For orientation=row:top, bottom, fill
• For orientation=column: left, right, fill
• For orientation=stack:top, bottom, left, right, fill
bounds Bounds r/w The boundaries of the element, in parent-relative coordinates.
Setting an element's size or location changes its bounds property, and vice-versa.
children | Array of Object | readonly | An array of child ListItem elements.
columns Object readonly For a multi-column list box, the column properties.
A JavaScript object with two read-only properties whose values are set by the creation parameters:
• titles: An array of column title strings, whose length matches the number of columns specified at creation.
• preferredWidths: An array of column widths, whose length matches the number of columns specified at creation.
enabled Boolean r/w True if this element is enabled.
An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent Number (min: 0) r/w The number of pixels to indent the element during automatic layout.
Applies for column orientation and left alignment, or row orientation and top alignment.
itemSize Dimension r/w The width and height in pixels of each item in the list.
Used by auto-layout to determine the preferredSize of the list, if not otherwise specified. If not set explicitly, the size of each item is set to match the largest height and width among all items in the list
items Array of ListItem readonly The array of choice items displayed in the list.
Access this array with a 0-based index. To obtain the number of items in the list, use items.length.The objects are created when items are specified on creation of the parent list object, or afterward using the list control's add() method. Each item has a selected property that is true when it is in the selected state.
location Point r/w The upper left corner of this element relative to its parent.
The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize Dimension r/w The preferred size, used by layout managers to determine the best size for each element.
If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties Object r/w An object that contains one or more creation properties of the control (properties used only when the element is created).
Creation properties of a ListBox object can include:
• multiselect: When false (the default), only one item can be selected. When true, multiple items can be selected.
• items: An array of strings for the text of each list item. An item object is created for each item. An item with the text string "-" creates a separator item. Supply this property, or the items argument to the add() method, not both. This form is most useful for elements defined using Resource Specifications.
• numberOfColumns: A number of columns in which to display the items; default is 1. When there are multiple columns, each ListItem object represents a selectable row. Its text and image values specify the label in the first column, and the subitems property specifies the labels in the additional columns.
• showHeaders: True to display column titles.
• columnWidths: An array of numbers for the preferred width in pixels of each column.
• columnTitles: A corresponding array of strings for the title of each column, to be shown if showHeaders is true.
selection ListItem r/w The currently selected item for a single-selection list, or an array of items for current selection in a multi-selection list.
Setting this value causes the selected item to be highlighted and to be scrolled into view if necessary. If no items are selected, the value is null. Set to null to deselect all items. You can set the value using the index of an item or an array of indices, rather than object references. If set to an index value that is out of range, the operation is ignored. When set with index values, the property still returns object references.
• If you set the value to an array for a single-selection list, only the first item in the array is selected.
• If you set the value to a single item for a multi-selection list, that item is added to the current selection.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size Dimension r/w The current dimensions of this element.
Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
type | String | readonly | The element type; "listbox".
visible Boolean r/w True if this element is shown, false if it is hidden.
When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onChange ()
An event-handler callback function, called when the content of the element has been changed

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDoubleClick ()
An event-handler callback function, called when an item in the listbox is double-clicked
Check the selection property to identify the item that was double-clicked.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

ListItem add (type: String[, text: String])
Adds an item to the choices in this list.
Returns the item control object. If this is a multi-column list box, each added ListItem represents one selectable row. Its text and image values specify the label in the first column, and the subitems property specifies the labels in the additional columns.
Parameter | Type | Description
type | String | The type of the child element, the string "item".
text | String | The localizable text label for the item. (Optional)

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

ListItem find (text: String)
Retrieves an item object from the list that has a given text label.
Parameter | Type | Description
text | String | The text string to match.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

void remove (what: Any)
Removes a child item from the list.
Parameter | Type | Description
what | Any | The item or child to remove, specified by 0-based index, text value, or as a ListItem object.

void removeAll ()
Removes all child items from the list.

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: ListItem

Class

ListItem

An item in a list box, drop-down list, or tree view.

You can specify initial items in the creation parameters when creating the parent list. Create new items using the add() method (ListBox.add(), DropDownList.add(), TreeView.add()) in the parent list with control type="item", or, for DropDownList controls, type="separator".
For a multi-column list box, the object represents one selectable row. Its text and image values specify the label in the first column, and the subitems property specifies the labels in the additional columns.

Hierarchy

Object
ListItem

Properties

Property | Type | Access | Description
checked | Boolean | r/w | The checked state of an item in a list. When true, the item is marked with the platform-appropriate checkmark. When false, no checkmark is drawn, but space is reserved for it in the left margin, so that the item lines up with other checkable items. When undefined, no space is reserved for a checkmark.
expanded | Boolean | r/w | The expansion state of an item of type node that is a child of a TreeView list control. When true, the item is in the expanded state and its children are shown, when false, it is collapsed and children are hidden.
image | ScriptUIImage | r/w | An image object for an icon to display in the item. When specified, the image appropriate to the selections state is drawn to the left of the text label. If the parent is a multi-column list box, this describes the label in the first column. Labels in additional columns are described by the subitems property.
index | Number | readonly | The 0-based index of this item in the items collection of its parent list control.
parent | Object | readonly | The parent element, a list control.
properties | Object | r/w | An object that contains one or more creation properties of the item (properties used only when the element is created). A ListItem object has no creation properties.
selected | Boolean | r/w | The selection state of this item. When true, the item is part of the selection for its parent list. When false, the item is not selected. Set to true to select this item in a single-selection list, or to add it to the selection array for a multi-selection list.
subItems | Array | readonly | When the parent is a multi-column ListBox, this describes the labels for this selectable row in additional columns. A array of JavaScript objects whose length is one less than the number of columns. The first member describes the label in the second column. Each member object has two properties, of which you can specify one or both: • text: A display string for the corresponding label. • image: An ScriptUIImage object for the corresponding label.
text | String | r/w | The label text to display for the item, a localizable string. If the parent is a multi-column list box, this describes the label in the first column. Labels in additional columns are described by the subitems property.
type | String | readonly | The element type. Normally "item", but an item whose parent is a DropDownList control can have type "separator". A separator item is not mouse-sensitive and is drawn as a horizontal line across the drop-down or pop-up menu.

Element of

DropDownList.items

DropDownList.selection

ListBox.items

ListBox.selection

TreeView.items

TreeView.selection

Used in:

void TreeView.onCollapse (item: ListItem)

void TreeView.onExpand (item: ListItem)

Return

ListItem DropDownList.add (type: String[, text: String])

ListItem DropDownList.find (text: String)

ListItem ListBox (SUI).add (type: String[, text: String])

ListItem ListBox (SUI).find (text: String)

ListItem TreeView.add (type: String[, text: String])

ListItem TreeView.find (text: String)


Adobe FrameMaker-12 Object Model JS: Panel (SUI)

Class

Panel (SUI)

A container for other types of controls, with an optional frame.

A panel can specify layout options for its child elements. Hiding a panel hides all its children. Making it visible makes visible those children that are not individually hidden.

QuickLinks

 add, addEventListener, dispatchEvent, hide, onDraw, remove, removeEventListener, show

Hierarchy

Object
Panel (SUI)

Properties

Property | Type | Access | Description
alignChildren | String | r/w | Specifies how to align the child elements.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
characters | Number (min: 0) | r/w | Reserve space for the specified number of characters; affects calculation of preferredSize .
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
justify | String | r/w | The default text justification style for child text elements. (default: left) One of left, center, or right. Justification only works if this value is set on creation of the element.
layout | LayoutManager | r/w | The layout manager for this container. The first time a container object is made visible, ScriptUI invokes this layout manager by calling its layout() function. Default is an instance of the LayoutManager class that is automatically created when the container element is created.
location | Point | r/w | The upper left corner of this element's frame relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
margins | Number | r/w | The number of pixels between the edges of a container and the outermost child elements. You can specify different margins for each edge of the container. The default value is based on the type of container, and is chosen to match the standard Adobe UI guidelines.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
orientation | String | r/w | The layout orientation of children in a container. Interpreted by the layout manager for the container. The default LayoutManager Object accepts the (case-insensitive) values row, column, or stack. For window and panel, the default is column, and for group the default is row. The allowed values for the container's alignChildren and its children's alignment properties depend on the orientation.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the control (properties used only when the element is created). Creation properties of a Panel object can include: • borderStyle: A string that specifies the appearance of the border drawn around the panel. One of black, etched, gray, raised, sunken. Default is etched. • su1PanelCoordinates: Photoshop only. When true, this panel automatically adjusts the positions of its children for compatability with Photoshop CS. Default is false, meaning that the panel does not adjust the positions of its children, even if the parent window has automatic adjustment enabled.
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
spacing | Number | r/w | The number of pixels separating one child element from its adjacent sibling element. Because each container holds only a single row or column of children, only a single spacing value is needed for a container. The default value is based on the type of container, and is chosen to match standard Adobe UI guidelines.
text | String | r/w | The title or label text, a localizable string.
type | String | readonly | The element type; "panel".
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onDraw ()
An event-handler callback function, called when the panel is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

Instances

Object add (type: String[, bounds: Bounds][, text: String][, properties: Object])
Adds a child element to this container.
Creates and returns a new control or container object and adds it to the children of this group.
Parameter | Type | Description
type | String | The type of the child element, as specified for the type property. Control types are listed in the JavaScript Tools Guide.
bounds | Bounds | A bounds specification that describes the size and position of the new control or container, relative to its parent. If supplied, this value creates a new Bounds object which is assigned to the new object's bounds property. (Optional)
text | String | The text or label, a localizable string. Initial text to be displayed in the control as the title, label, or contents, depending on the control type. If supplied, this value is assigned to the new object's text property. (Optional)
properties | Object | An object that contains one or more creation properties of the new child (properties used only when the element is created). The creation properties depend on the element type. See property of each control type. (Optional)

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void remove (what: Any)
Removes the specified child control from this group's children array.
No error results if the child does not exist.
Parameter | Type | Description
what | Any | The child control to remove, specified by 0-based index, text property value, or as a control object.

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: Point (SUI)

Class

Point (SUI)

Defines the location of a window or UI element. Contains a 2-element array.

Specifies the origin point of an element as horizontal and vertical pixel offsets from the origin of the element's coordinate space. A Point object is created when you set an element's location property. You can set the property using a JavaScript object with properties named x and y, or an array with 2 values in the order [x, y].

Properties

Property | Type | Access | Description
left | Number | r/w | The left coordinate.
length | Number | readonly | The array length. (default: 2)
top | Number | r/w | The top coordinate.
x | Number | r/w | The horizontal coordinate, a pixel offset from the origin of the element's coordinate space.
y | Number | r/w | The vertical coordinate, a pixel offset from the origin of the element's coordinate space.


Adobe FrameMaker-12 Object Model JS: Progressbar

Class

Progressbar

A horizontal bar with an indicator that shows the progress of an operation.

All progressbar controls have a horizontal orientation. The value property contains the current position of the progress indicator; the default is 0. There is a minvalue property, but it is always 0; attempts to set it to a different value are silently ignored.

QuickLinks

 addEventListener, dispatchEvent, hide, onDraw, removeEventListener, show

Hierarchy

Object
Progressbar

Properties

Property | Type | Access | Description
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
maxvalue | Number | r/w | The maximum value in the range. Default is 100.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
minvalue | Number | r/w | The minimum value in the range; always 0. If set to a different value, it is ignored.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the container (properties used only when the element is created). A ProgressBar object has no creation properties. The third argument of the add() method that creates it is the initial value (default 0), and the fourth argument is the maximum value of the range (default 100).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
type | String | readonly | The element type, "progessbar".
value | Number | r/w | The current position of the indicator. If set to a value outside the range specified by 0 to maxvalue, it is automatically reset to the closest boundary.
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: RadioButton (SUI)

Class

RadioButton (SUI)

A dual-state control, grouped with other radiobuttons, of which only one can be in the selected state.

Shows the selected state when value=true, empty when value=false. Calls the onClick() callback if the control is clicked or if its notify() method is called.

QuickLinks

 addEventListener, dispatchEvent, hide, notify, onActivate, onClick, onDeactivate, onDraw, onShortcutKey, removeEventListener, show

Hierarchy

Object
RadioButton (SUI)

Properties

Property | Type | Access | Description
active | Boolean | r/w | True if this element is active. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
characters | Number (min: 0) | r/w | A number of characters for which to reserve space when calculating the preferred size of the element.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
justify | String | r/w | The default text justification style for child text elements. (default: left) One of left, center, or right. Justification only works if this value is set on creation of the element.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes. A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the container (properties used only when the element is created). A RadioButton object has no creation properties. The third argument of the add() method that creates can be the label text.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
text | String | r/w | The label text for this button, a localizable string.
type | String | readonly | The element type; "radiobutton".
value | Boolean | r/w | The selection state of this button, selected when true.
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onClick ()
An event-handler callback function, called when the element has been clicked.

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: ScriptUI

Class

ScriptUI

A global class containing central information about ScriptUI. Not instantiable.

QuickLinks

 getResourceText, newFont, newImage

Class

Property | Type | Access | Description
Alignment | String | readonly | Collects the enumerated values that can be used in the alignment and alignChildren properties of controls and containers. Predefined alignment values are: TOP, BOTTOM, LEFT, RIGHT, FILL, CENTER
FontStyle | Object | readonly | Collects the enumerated values that can be used as the style argument to the ScriptUI.newFont() method. Predefined styles are REGULAR, BOLD, ITALIC, BOLDITALIC.
applicationFonts | Object | readonly | The font constants defined by the host application.
compatibility | Object | readonly | An object whose properties are the names of compatability modes supported by the host application. The presence of ScriptUI.compatability.su1PanelCoordinates means that the application allows backward compatibility with the coordinate system of Panel elements in ScriptUI version 1.
coreVersion | String | readonly | A string containing the internal version number of the ScriptUI module.
environment | Environment | readonly | An object whose properties define attributes of the environment in which ScriptUI operates.
events | Events | readonly | An object whose properties and methods provide access to objects used in the ScriptUI event system. It contains one function, createEvent(), which allows you to create event objects in order to simulate user-interaction event
frameworkName | String | readonly | A string containing the name of the UI component framework with which this version of ScriptUI is compatible.
version | Any | readonly | A string containing the version number of the ScriptUI component framework

Methods

String getResourceText (text: String)
Finds and returns the resource for a given text string from the host application's resource data.
If no string resource matches the given text, the text itself is returned.
Parameter | Type | Description
text | String | The text to match.

ScriptUIFont newFont (name: String, style: String | Number, size: Number)
Creates a new font object for use in text controls and titles.
Parameter | Type | Description
name | String | The font name, or the font family name.
style | String | Number | The font style; can be string, or one of the values of ScriptUI.FontStyle.
size | Number | The font size in points.

ScriptUIImage newImage (normal: String[, disabled: String][, pressed: String][, rollover: String])
Loads a new image from resources or disk files into an image object.
Creates a new global image object for use in controls that can display images, loading the associated images from the specified resources or image files.
Parameter | Type | Description
normal | String | The resource name or the disk file path to the image used for the normal state.
disabled | String | The resource name, or the disk file path to the image used for the disabled state. (Optional)
pressed | String | The resource name, or the file-system path to the image used for the pressed state. (Optional)
rollover | String | The resource name, or the file-system path to the image used for the rollover state. (Optional)


Adobe FrameMaker-12 Object Model JS: ScriptUIBrush

Class

ScriptUIBrush

A painting brush that encapsulates a color or pattern used to fill paths.

Create with ScriptUIGraphics.newBrush(). Use as a value of backgroundColor properties, and pass as an argument to the fillPath() method.

Properties

Property | Type | Access | Description
color | Array of Number | readonly | The brush color. The paint color to use when the type is SOLID_COLOR. An array in the form [R, B, G, A] specifying the red, green, blue values of the color and the opacity (alpha channel) value as numbers in the range [0.0..1.0]. An opacity of 0 is fully transparent, and an opacity of 1 is fully opaque.
theme | String | readonly | The theme name. The name of a color theme to use for drawing when the type is THEME_COLOR. Theme colors are defined by the host application.
type | Number | readonly | The brush type, solid or theme. One of these constants: ScriptUIGraphics.BrushType.SOLID_COLOR or ScriptUIGraphics.BrushType.THEME_COLOR

Element of

ScriptUIGraphics.backgroundColor

ScriptUIGraphics.disabledBackgroundColor

Used in:

void ScriptUIGraphics.fillPath (brush: ScriptUIBrush[, path: ScriptUIPath])

Return

ScriptUIBrush ScriptUIGraphics.newBrush (type: Number, color: Array of Number | String)


Adobe FrameMaker-12 Object Model JS: ScriptUIFont

Class

ScriptUIFont

Encapsulates the qualities of a font used to draw text into a control.

Create with the newFont() method.Used as a value of font. Passed as an argument to drawString() and measureString().

Properties

Property | Type | Access | Description
family | String | readonly | The font family name.
name | String | readonly | The complete font name, consisting of the family and style, if specified.
size | Number | readonly | The font point size.
style | Object | readonly | The font style. One of the constants in ScriptUIGraphics.FontStyle.
substitute | String | readonly | The name of a substitution font, a fallback font to substitute for this font if the requested font family or style is not available.

Element of

ScriptUIGraphics.font

Used in:

void ScriptUIGraphics.drawString (text: String, pen: ScriptUIPen, x: Number, y: Number[, font: ScriptUIFont])

Dimension ScriptUIGraphics.measureString (text: String[, font: ScriptUIFont][, boundingWidth: Number])

Return

ScriptUIFont ScriptUI.newFont (name: String, style: String | Number, size: Number)


Adobe FrameMaker-12 Object Model JS: ScriptUIGraphics

Class

ScriptUIGraphics

An object used to draw custom graphics, found in the graphics property of window, container, and control objects.

Allows a script to customize aspects of the element's appearance, such as the color and font. Use an onDraw callback function to set these properties or call the functions.All measurements are in pixels.

QuickLinks

 closePath, drawFocusRing, drawImage, drawOSControl, drawString, ellipsePath, fillPath, lineTo, measureString, moveTo, newBrush, newPath, newPen, rectPath, strokePath

Properties

Property | Type | Access | Description
backgroundColor | ScriptUIBrush | r/w | The background color for containers; for non-containers, the parent background color. The paint color and style is defined in this brush object.
currentPath | ScriptUIPath | readonly | The current drawing path, encapsulated in a path object.
currentPoint | Point | readonly | The current position in the current drawing path.
disabledBackgroundColor | ScriptUIBrush | r/w | The background color for containers when disabled or inactive; for non-containers, the parent background color. The paint color and style is defined in this brush object.
disabledForegroundColor | ScriptUIPen | r/w | The text color when the element is disabled or inactive. The paint color and style is defined in this pen object.
font | ScriptUIFont | r/w | The default font to use for displaying text.
foregroundColor | ScriptUIPen | r/w | The text color. The paint color and style is defined in this pen object.

Class

Property | Type | Access | Description
BrushType | Object | readonly | Contains the enumerated constants for the type argument of newBrush(). Type constants are: SOLID_COLOR, THEME_COLOR.
PenType | Object | readonly | Contains the enumerated constants for the type argument of newPen(). Type constants are: SOLID_COLOR, THEME_COLOR.

Methods

Instances

void closePath ()
Closes the current path.
Defines a line from the current postion (currentPoint) to the start point of the current path (the value of currentPath).

void drawFocusRing (left: Number, top: Number, width: Number, height: Number)
Draws a focus ring within a region of this element.
Parameter | Type | Description
left | Number | The left coordinate of the region. Value is relative to the origin of this element.
top | Number | The top coordinate of the region. Value is relative to the origin of this element.
width | Number | The width of the region in pixels.
height | Number | The height of the region in pixels.

void drawImage (image: ScriptUIImage, left: Number, top: Number[, width: Number][, height: Number])
Draws an image within a given region of the element.
Uses the version of the image that is appropriate to the element's current state.
Parameter | Type | Description
image | ScriptUIImage | The image to draw. This object contains different versions of an image appropriate to various element states, such as a dimmed version for the disabled state.
left | Number | The left coordinate of the region, relative to the origin of this element.
top | Number | The top coordinate of the region, relative to the origin of this element.
width | Number | The width in pixels. If provided, the image is stretched or shrunk to fit. If omitted, uses the original image width. (Optional)
height | Number | The height in pixels. If provided, the image is stretched or shrunk to fit. If omitted, uses the original image height. (Optional)

void drawOSControl ()
Draw the platform-specific control associated with this element.

void drawString (text: String, pen: ScriptUIPen, x: Number, y: Number[, font: ScriptUIFont])
Draw a string of text starting at a given point in this element, using a given drawing pen and font.
Parameter | Type | Description
text | String | The text string.
pen | ScriptUIPen | The drawing pen to use.
x | Number | The left coordinate, relative to the origin of this element.
y | Number | The top coordinate, relative to the origin of this element.
font | ScriptUIFont | The font to use. Default is the font value in this object. (Optional)

Point ellipsePath (left: Number, top: Number, width: Number, height: Number)
Defines an elliptical path within a given rectangular area in the currentPath object, which can be filled using fillPath() or stroked using strokePath().
Returns a Point object for the upper left corner of the area, which is the new currentPoint.
Parameter | Type | Description
left | Number | The left coordinate of the region, relative to the origin of this element.
top | Number | The top coordinate of the region, relative to the origin of this element.
width | Number | The width of the region in pixels.
height | Number | The height of the region in pixels.

void fillPath (brush: ScriptUIBrush[, path: ScriptUIPath])
Fills a path using a given painting brush.
Parameter | Type | Description
brush | ScriptUIBrush | The brush object that defines the fill color.
path | ScriptUIPath | The path object. Default is the currentPath. (Optional)

Point lineTo (x: Number, y: Number)
Adds a path segment to the currentPath.
The line is defined from the currentPoint to the specified destination point. Returns the Point object for the destination point, which becomes the new value of currentPoint.
Parameter | Type | Description
x | Number | The X coordinate for the destination point, relative to the origin of this element.
y | Number | The Y coordinate for the destination point, relative to the origin of this element.

Dimension measureString (text: String[, font: ScriptUIFont][, boundingWidth: Number])
Calculates the size needed to display a string using the given font.
Returns a Dimension object that contains the height and width of the string in pixels.
Parameter | Type | Description
text | String | The text string to measure.
font | ScriptUIFont | The font to use. Default is the font value in this object. (Optional)
boundingWidth | Number | The bounding width. (Optional)

Point moveTo (x: Number, y: Number)
Adds a given point to the currentPath, and makes it the current drawing position.
Returns the Point object which is the new value of currentPoint.
Parameter | Type | Description
x | Number | The X coordinate for the new point, relative to the origin of this element.
y | Number | The Y coordinate for the new point, relative to the origin of this element.

ScriptUIBrush newBrush (type: Number, color: Array of Number | String)
Creates a new painting brush object.
Parameter | Type | Description
type | Number | The brush type, solid or theme. One of the constants ScriptUIGraphics.BrushType.SOLID_COLOR or ScriptUIGraphics.BrushType.THEME_COLOR.
color | Array of Number | String | The brush color. • If type is SOLID_COLOR, the color expressed as an array of three or four values, in the form [R, B, G, A] specifying the red, green, and blue values of the color and, optionally, the opacity (alpha channel). All values are numbers in the range [0.0..1.0]. An opacity of 0 is fully transparent, and an opacity of 1 is fully opaque. • If the type is THEME_COLOR, the name string of the theme. Theme colors are defined by the host application.

ScriptUIPath newPath ()
Creates a new, empty path object.
Replaces any existing path in currentPath.

ScriptUIPen newPen (type: Number, color: Array of Number | String, width: Number)
Creates a new drawing pen object.
Parameter | Type | Description
type | Number | The pen type, solid or theme. One of the constants ScriptUIGraphics.PenType.SOLID_COLOR or ScriptUIGraphics.PenType.THEME_COLOR.
color | Array of Number | String | The pen color. • If type is SOLID_COLOR, the color expressed as an array of three or four values, in the form [R, B, G, A] specifying the red, green, and blue values of the color and, optionally, the opacity (alpha channel). All values are numbers in the range [0.0..1.0]. An opacity of 0 is fully transparent, and an opacity of 1 is fully opaque. • If the type is THEME_COLOR, the name string of the theme. Theme colors are defined by the host application.
width | Number | The width of the pen line in pixels. The line is centered around the current point. For example, if the value is 2, drawing a line from (0, 10) to (5, 10) paints the two rows of pixels directly above and below y-position 10.

Point rectPath (left: Number, top: Number, width: Number, height: Number)
Defines a rectangular path in the currentPath object.
The rectangle can be filled using fillPath() or stroked using strokePath().
Returns the Point object for the upper left corner of the rectangle, which becomes the new value of currentPoint.
Parameter | Type | Description
left | Number | The left coordinate relative to the origin of this element.
top | Number | The top coordinate relative to the origin of this element.
width | Number | The width in pixels.
height | Number | The height in pixels.

void strokePath (pen: ScriptUIPen[, path: ScriptUIPath])
Strokes the path segments of a path with a given drawing pen.
Parameter | Type | Description
pen | ScriptUIPen | The drawing pen that defines the color and line width.
path | ScriptUIPath | The path object. Default is the currentPath. (Optional)

Element of

Button.graphics

Checkbox.graphics

DropDownList.graphics

EditText.graphics

Group.graphics

IconButton.graphics

ListBox.graphics

Panel.graphics

Progressbar.graphics

RadioButton.graphics

Scrollbar.graphics

Slider.graphics

StaticText.graphics

TreeView.graphics

Window.graphics


Adobe FrameMaker-12 Object Model JS: ScriptUIImage

Class

ScriptUIImage

Encapsulates a set of images that can be drawn into a control.

Different images can reflect the current state, such as a dimmed version for a disabled control. Create with the newImage() method. Passed as an argument to drawImage().

Properties

Property | Type | Access | Description
format | String | readonly | The image format. One of: resource, JPEG, GIF, TIFF, PNG, or PICT (Macintosh).
name | String | readonly | The image name. Either the file name, or the resource name.
pathname | String | readonly | The full path to the file that contains the image.
size | Dimension | readonly | The image size in pixels.

Element of

IconButton.image

ListItem.image

Used in:

void ScriptUIGraphics.drawImage (image: ScriptUIImage, left: Number, top: Number[, width: Number][, height: Number])

Return

ScriptUIImage ScriptUI.newImage (normal: String[, disabled: String][, pressed: String][, rollover: String])


Adobe FrameMaker-12 Object Model JS: ScriptUIPath

Class

ScriptUIPath

A helper object that encapsulates a drawing path for a figure to be drawn into a window or control.

Create with the newPath(), moveto(), lineto(), rectPath(), and ellipsePath() methods. Used as value of currentPath, where it is acted upon by methods such as closePath(). Pass as optional argument to fillPath() and strokePath(), which otherwise act upon the current path.

Element of

ScriptUIGraphics.currentPath

Used in:

void ScriptUIGraphics.fillPath (brush: ScriptUIBrush[, path: ScriptUIPath])

void ScriptUIGraphics.strokePath (pen: ScriptUIPen[, path: ScriptUIPath])

Return

ScriptUIPath ScriptUIGraphics.newPath ()


Adobe FrameMaker-12 Object Model JS: ScriptUIPen

Class

ScriptUIPen

A drawing pen that defines a color and line width used to stroke paths.

Create with ScriptUIGraphics.newPen(). Use as a value of foregroundColor properties, and pass as an argument to drawString() and strokePath() methods.

Properties

Property | Type | Access | Description
color | Array of Number | readonly | The pen color. The paint color to use when the type is SOLID_COLOR. An array in the form [R, B, G, A] specifying the red, green, blue values of the color and the opacity (alpha channel) value as numbers in the range [0.0..1.0]. An opacity of 0 is fully transparent, and an opacity of 1 is fully opaque.
lineWidth | Number (min: 1) | r/w | The pixel width of the drawing line.
theme | String | readonly | The theme name. The name of a color theme to use for drawing when the type is THEME_COLOR. Theme colors are defined by the host application.
type | String | readonly | The pen type, solid or theme. One of these constants: ScriptUIGraphics.PenType.SOLID_COLOR or ScriptUIGraphics.PenType.THEME_COLOR

Element of

ScriptUIGraphics.disabledForegroundColor

ScriptUIGraphics.foregroundColor

Used in:

void ScriptUIGraphics.drawString (text: String, pen: ScriptUIPen, x: Number, y: Number[, font: ScriptUIFont])

void ScriptUIGraphics.strokePath (pen: ScriptUIPen[, path: ScriptUIPath])

Return

ScriptUIPen ScriptUIGraphics.newPen (type: Number, color: Array of Number | String, width: Number)


Adobe FrameMaker-12 Object Model JS: Scrollbar

Class

Scrollbar

A scrollbar with a draggable scroll indicator and stepper buttons to move the indicator.

The scrollbar control has a horizontal orientation if the width is greater than the height at creation time, or vertical if its height is greater than its width. Calls the onChange() callback after the position of the indicator is changed or if its notify() method is called. Calls the onChanging() callback repeatedly while the user is moving the indicator. Scrollbars are often created with an associated EditText field to display the current value of the scrollbar, and to allow setting the scrollbar's position to a specific value.

QuickLinks

 addEventListener, dispatchEvent, hide, notify, onActivate, onChange, onChanging, onDeactivate, onDraw, onShortcutKey, removeEventListener, show

Hierarchy

Object
Scrollbar

Properties

Property | Type | Access | Description
active | Boolean | r/w | True if this element is active. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
jumpdelta | Number (min: 0) | r/w | The amount to increment or decrement a scrollbar indicator's position when the user clicks ahead or behind the moveable element. Default is 20% of the range between the maxvalue and minvalue property values.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
maxvalue | Number | r/w | The maximum value allowed in the value property. Together with minvalue, sets the scrolling range. Default is 100.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
minvalue | Number | r/w | The minimum value allowed in the value property. Together with maxvalue, sets the scrolling range.Default is 0.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the container (properties used only when the element is created). A Scrollbar object has no creation properties. The third argument of the add() method that creates it is the initial value, and the fourth and fifth arguments are the minimum and maximum values of the range.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
stepdelta | Number (min: 0) | r/w | The amount by which to increment or decrement a scrollbar element's position when the user clicks a stepper button.
type | String | readonly | The element type, "scrollbar".
value | Number | r/w | The current position of the indicator. If set to a value outside the range specified by minvalue and maxvalue, it is automatically reset to the closest boundary.
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onChange ()
An event-handler callback function, called when the user has finished dragging the position indicator, or has clicked the control.

void onChanging ()
An event-handler callback function, called when the content of the element is in the process of changing
The handler is called for any motion of the position indicator while this control has the input focus.

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: Slider

Class

Slider

A slider bar that indicates a numeric value with a moveable position indicator.

All slider controls have a horizontal orientation. Calls the onChange() callback after the position of the indicator is changed or if its notify() method is called. Calls the onChanging() callback repeatedly while the user is moving the indicator. The value property contains the current position of the indicator within the range of minvalue to maxvalue.

QuickLinks

 addEventListener, dispatchEvent, hide, notify, onActivate, onChange, onChanging, onDeactivate, onDraw, onShortcutKey, removeEventListener, show

Hierarchy

Object
Slider

Properties

Property | Type | Access | Description
active | Boolean | r/w | True if this element is active. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
maxvalue | Number | r/w | The maximum value allowed in the value property. Together with minvalue, sets the range.Default is 100.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
minvalue | Number | r/w | The minimum value allowed in the value property. Together with maxvalue, sets the range.Default is 0.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the container (properties used only when the element is created). A Slider object has no creation properties. The third argument of the add() method that creates it is the initial value, and the fourth and fifth arguments are the minimum and maximum values of the range.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
type | String | readonly | The element type, "slider".
value | Number | r/w | The current position of the indicator. If set to a value outside the range specified by minvalue and maxvalue, it is automatically reset to the closest boundary.
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onChange ()
An event-handler callback function, called when the user has finished dragging the position indicator, or has clicked the control.

void onChanging ()
An event-handler callback function, called when the content of the element is in the process of changing
The handler is called for any motion of the position indicator while this control has the input focus.

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: StaticText (SUI)

Class

StaticText (SUI)

A text label that the user cannot change.

QuickLinks

 addEventListener, dispatchEvent, hide, notify, onDraw, onShortcutKey, removeEventListener, show

Hierarchy

Object
StaticText (SUI)

Properties

Property | Type | Access | Description
active | Boolean | r/w | Always false. This element cannot have input focus. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
characters | Number (min: 0) | r/w | A number of characters for which to reserve space when calculating the preferred size of the element.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
justify | String | r/w | The text justification style. (default: left) One of left, center, or right. Justification only works if this value is set on creation of the element.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the container (properties used only when the element is created). Creation properties of a StaticText object can include: • multiline: When false (the default), the control displays a single line of text. When true, the control displays multiple lines, in which case the text wraps within the width of the control. • scrolling: When false (the default), the displayed text cannot be scrolled. When true, the displayed text can be vertically scrolled using the Up Arrow and Down Arrow; this case implies multiline=true.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
text | String | r/w | The text to display, a localizable string.
type | String | readonly | The element type, "statictext".
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: TreeView

Class

TreeView

A hierarchical list whose items can contain child items.

The ListItem children of this control (in the items array) can be of type node, which means that they can contain child items. An item with child items can expanded, so that the child items are displayed, or collapsed, so that the child items are hidden Individual items can be selected at any level of the tree.

QuickLinks

 add, addEventListener, dispatchEvent, find, hide, notify, onActivate, onChange, onCollapse, onDeactivate, onDraw, onExpand, onShortcutKey, remove, removeAll, removeEventListener, show

Hierarchy

Object
TreeView

Properties

Property | Type | Access | Description
active | Boolean | r/w | True if this element is active. An active control is the one with keyboard focus–that is, the one that accepts keystrokes, or in the case of a Button, is selected when the user types Return or Enter in Windows, or the space bar in Mac OS.
alignment | String | r/w | The alignment style for this element. If defined, this value overrides the alignChildren setting for the parent container. This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive. • For orientation=row:top, bottom, fill • For orientation=column: left, right, fill • For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The boundaries of the element, in parent-relative coordinates. Setting an element's size or location changes its bounds property, and vice-versa.
children | Array of Object | readonly | An array of child elements.
enabled | Boolean | r/w | True if this element is enabled. An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the element's appearance, in response to the onDraw() event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element during automatic layout. Applies for column orientation and left alignment, or row orientation and top alignment.
itemSize | Dimension | r/w | The width and height in pixels of each item in the list. Used by auto-layout to determine the preferredSize of the list, if not otherwise specified. If not set explicitly, the size of each item is set to match the largest height and width among all items in the list
items | Array of ListItem | readonly | The array of top-level items displayed in the list. Access this array with a 0-based index. To obtain the number of items in the list, use items.length.The objects are created when items are specified on creation of the parent list object, or afterward using the list control's add() method.
location | Point | r/w | The upper left corner of this element relative to its parent. The location is defined as [bounds.x, bounds.y]. Setting an element's location changes its bounds property, and vice-versa.
maximumSize | Dimension | r/w | The maximum height and width to which the element can be resized.
minimumSize | Dimension | r/w | The minimum height and width to which the element can be resized.
parent | Object | readonly | The parent element.
preferredSize | Dimension | r/w | The preferred size, used by layout managers to determine the best size for each element. If not explicitly set by a script, value is established by the UI framework in which ScriptUI is employed, and is based on such attributes of the element as its text, font, font size, icon size, and other UI framework-specific attributes.A script can explicitly set this value before the layout manager is invoked in order to establish an element size other than the default.
properties | Object | r/w | An object that contains one or more creation properties of the control (properties used only when the element is created). Creation properties of a ListBox object can include: • items: An array of strings for the text of each top-level list item. An item object is created for each item. An item with the text string "-" creates a separator item. Supply this property, or the items argument to the add() method, not both. This form is most useful for elements defined using Resource Specifications.
selection | ListItem | r/w | The currently selected list item. Setting this value causes the selected item to be highlighted and to be scrolled into view if necessary. If no items are selected, the value is null. Set to null to deselect all items.You can set the value using the index of an item, rather than an object reference. If set to an index value that is out of range, the operation is ignored. When set with an index value, the property still returns an object reference.
shortcutKey | String | r/w | The key sequence that invokes the onShortcutKey() callback for this element (in Windows only).
size | Dimension | r/w | The current dimensions of this element. Initially undefined, and unless explicitly set by a script, it is defined by a LayoutManager . A script can explicitly set size before the layout manager is invoked to establish an element size other than the preferredSize or the default size, but this is not recommended. Defined as [bounds.width, bounds.height]. Setting an element's size changes its bounds property, and vice-versa.
type | String | readonly | The element type, "treeview".
visible | Boolean | r/w | True if this element is shown, false if it is hidden. When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this element relative to the top-level parent window.

Methods

Events

void onActivate ()
An event-handler callback function, called when the element acquires the keyboard focus.
Called when the user gives the control the keyboard focus by clicking it or tabbing into it.

void onChange ()
An event-handler callback function, called when the content of the element has been changed

void onCollapse (item: ListItem)
An event-handler callback function, called when the user collapses (closes) an expanded node in the treeview.
Parameter | Type | Description
item | ListItem | The ListItem node that collapsed.

void onDeactivate ()
An event-handler callback function, called when the element loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active control to another control.

void onDraw ()
An event-handler callback function, called when the window is about to be drawn.
Allows the script to modify or control the appearance, using the control's associated ScriptUIGraphics object. Handler takes one argument, a DrawState object.

void onExpand (item: ListItem)
An event-handler callback function, called when the user expands (opens) a collapsed node in the treeview.
Parameter | Type | Description
item | ListItem | The ListItem node that expanded.

void onShortcutKey ()
An event-handler callback function, called when the element's shortcutKey sequence is typed in the active window.
In Windows only.

Instances

ListItem add (type: String[, text: String])
Adds an item to the top-level choices in this list.
Returns the item control object.
Parameter | Type | Description
type | String | The type of the child element, the string "item".
text | String | The localizable text label for the item. (Optional)

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this element.
Parameter | Type | Description
eventName | String | The name of the event. Event names are listed in the JavaScript Tools Guide.
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target.

Event dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

ListItem find (text: String)
Retrieves an item object from the list that has a given text label.
Parameter | Type | Description
text | String | The text string to match.

void hide ()
Hides this element.

void notify ([eventName: String])
Sends a notification message, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The name of the control event handler to call. One of: onClick, onChange, onChanging. By default, simulates the onChange event for an edittext control, an onClick event for controls that support that event. (Optional)

void remove (what: Any)
Removes a child item from the list.
Parameter | Type | Description
what | Any | The item or child to remove, specified by 0-based index in the top-level item list, text value, or as a ListItem object.

void removeAll ()
Removes all child items from the list.

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this element.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Shows this element.
When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.


Adobe FrameMaker-12 Object Model JS: UIEvent

Class

UIEvent

Encapsulates input event information for an event that propagates through a container and control hierarchy.

Implements W3C standard event handling. This object is passed to a function that you register to respond to events of a certain type that occur in a window or control. Use windowObj.addEventListener() or controlObj.addEventListener() to register a handler function.

QuickLinks

 UIEvent, initEvent, initUIEvent, preventDefault, stopPropagation

Properties

Property | Type | Access | Description
bubbles | Boolean | readonly | True if the event is of a type that bubbles.
cancelable | Boolean | readonly | True if the default action associated with the event can be canceled with preventDefault().
captures | Boolean | readonly | True if this event can be captured.
currentTarget | Boolean | readonly | The event target object which is currently handling the event. During capturing and bubbling, this is different from the property target.
detail | Any | readonly | The click count for a mouse-click event.
eventPhase | String | readonly | The current phase of event propagation; one of none, target, capture, bubble.
target | Object | readonly | The event target object for this event.
timeStamp | Date | readonly | The date and time at which the event occurred.
type | String | readonly | The name of the event that this object represents. Event types are listed in the JavaScript Tools Guide.
view | Any | readonly | The ScriptUI element that this event relates to.

Methods

Constructor

UIEvent UIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])
Creates an event.
The UIEvent object is normally created by ScriptUI and passed to your event handler. However, you can simulate a user action by constructing an event object and sending it to a target object's dispatchEvent() function.
Parameter | Type | Description
type | String | The event type. See UIEvent.type property.
captures | Boolean | Set to true if this event can be captured. (default: false)
bubbles | Boolean | Set to true if the event bubbles. (default: false)
view | Object | The ScriptUI element that this event relates to. (Optional)
detail | Number | The click count for a mouse-click event. (Optional)

Instances

void initEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, cancelable: Boolean=false])
Initializes a UI event as a core W3C event.
Parameter | Type | Description
type | String | The event type.
captures | Boolean | Set to true if this event can be captured. (default: false)
bubbles | Boolean | Set to true if the event bubbles. (default: false)
cancelable | Boolean | Set to true if the default action is cancelable. (default: false)

void initUIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])
Initializes an event.
Parameter | Type | Description
type | String | The event type.
captures | Boolean | Set to true if this event can be captured. (default: false)
bubbles | Boolean | Set to true if the event bubbles. (default: false)
view | Object | The ScriptUI element that this event relates to. (Optional)
detail | Number | The click count for a mouse-click event. (Optional)

void preventDefault ()
Prevents the default action associated with this event from being called.

void stopPropagation ()
Stops the propagation of this event.

Return

UIEvent UIEvent.UIEvent (type: String[, captures: Boolean=false][, bubbles: Boolean=false][, view: Object][, detail: Number])

UIEvent Window (SUI).dispatchEvent ()


Adobe FrameMaker-12 Object Model JS: Window (SUI)

Class

Window (SUI)

The instance represents a top-level window or dialog box, which contains user-interface elements.

The globally available Window object provides access to predefined and script-defined windows.

QuickLinks

 Window, add, addEventListener, alert, center, close, confirm, dispatchEvent, find, hide, notify, onActivate, onClose, onDeactivate, onMove, onMoving, onResize, onResizing, onShortcutKey, onShow, prompt, remove, removeEventListener, show

Hierarchy

Object
Window (SUI)

Properties

Property | Type | Access | Description
active Boolean r/w Set to true to make this window active.

• A modal dialog that is visible is by definition the active dialog.
• An active palette is the front-most window.
• An active control is the one with focus–that is, the one that accepts keystrokes, or in the case of a Button, be selected when the user types Return or Enter.
alignChildren String r/w Tells the layout manager how unlike-sized children of this container should be aligned within a column or row.
Order of creation determines which children are at the top of a column or the left of a row; the earlier a child is created, the closer it is to the top or left of its column or row. If defined, alignment for a child element overrides the alignChildren setting for the parent container. See alignment property for values.
alignment String r/w The alignment style for child elements of a container. If defined, this value overrides the alignChildren setting for the parent container.
This can be a single string, which indicates the alignment for the orientation specified in the parent container, or an array of two strings, indicating both the horizontal and vertical alignment (in that order). Allowed values depend on the orientation value of the parent container. They are not case sensitive.
• For orientation=row:top, bottom, fill
• For orientation=column: left, right, fill
• For orientation=stack:top, bottom, left, right, fill
bounds | Bounds | r/w | The bounds of the window's drawable area, excluding the frame, in screen coordinates.
cancelElement Object r/w For windows of type dialog, the UI element to notify when the user presses a cancellation key combination.
The cancellation key is the Esc key. By default, looks for a button whose name or text is "cancel" (case disregarded).
characters | Number (min: 0) | r/w | A number of characters for which to reserve space when calculating the preferred size of the window.
children Array of Object readonly The collection of UI elements that have been added to this container.
An array indexed by number or by a string containing an element's name. The length property of this array is the number of child elements for container elements, and is zero for controls.
defaultElement Object r/w For windows of type dialog, the UI element to notify when the user presses a Enter key.
By default, looks for a button whose name or text is "ok" (case disregarded).
enabled Boolean r/w True if this element is enabled.
An enabled element can accept input, according to its type. When false, control elements do not accept input, and all types of elements have a dimmed appearance.
frameBounds Bounds readonly The bounds of the window frame in screen coordinates.
The frame consists of the title bar and borders that enclose the content region of a window, depending on the windowing system.
frameLocation Point r/w The top left corner of the window frame in screen coordinates.
The same as [frameBounds.x, frameBounds.y]. Set this value to move the window frame to the specified location on the screen. The frameBounds value changes accordingly.
frameSize | Dimension | readonly | The size and location of the window's frame in screen coordinates.
graphics | ScriptUIGraphics | readonly | The graphics object that can be used to customize the window's appearance, in response to the onDraw event.
helpTip | String | r/w | The help text that is displayed when the mouse hovers over the element.
indent | Number (min: 0) | r/w | The number of pixels to indent the element.
justify String r/w The default text justification style for child text elements. (default: left)
One of left, center, or right. Justification only works if this value is set on creation of the element.
layout LayoutManager r/w The layout manager for this container.
The first time a container object is made visible, ScriptUI invokes this layout manager by calling its layout() function. Default is an instance of the LayoutManager class that is automatically created when the container element is created.
location Point r/w The upper left corner of the window's drawable area.
The same as [bounds.x, bounds.y].
margins Number r/w The number of pixels between the edges of a container and the outermost child elements.
You can specify different margins for each edge of the container. The default value is based on the type of container, and is chosen to match the standard Adobe UI guidelines.
maximized | Boolean | r/w | True if the window is expanded.
maximumSize | Dimension | r/w | The largest rectangle to which the window can be resized.
minimized | Boolean | r/w | True if the window is minimized or iconified.
minimumSize | Dimension | r/w | The smallest rectangle to which the window can be resized.
opacity Number r/w The opacity of the window, in the range [0..1]. (default: 1.0)
A value of 1.0 (the default) makes the window completely opaque, a value of 0 makes it completely transparent. Intermediate values make it partially transparent to any degree.
orientation String r/w The layout orientation of children in a container.
Interpreted by the layout manager for the container. The default LayoutManager Object accepts the (case-insensitive) values row, column, or stack. For window and panel, the default is column, and for group the default is row. The allowed values for the container's alignChildren and its children's alignment properties depend on the orientation.
parent | Object | readonly | The immediate parent element.
preferredSize Dimension r/w The preferred size of the window.
Used in automatic layout and resizing. To set a specific value for only one dimension, specify the other dimension as -1.
properties Object r/w An object that contains one or more creation properties of the container (properties used only when the element is created).
Creation properties of a Window object can include:
• resizeable: When true, the window can be resized by the user. Default is false.
• su1PanelCoordinates: Photoshop only. When true, the child panels of this window automatically adjust the positions of their children for compatability with Photoshop CS (in which the vertical coordinate was measured from outside the frame). Default is false. Individual panels can override the parent window's setting.
• closeButton: Bridge only. When true, the title bar includes a button to close the window, if the platform and window type allow it. When false, it does not. Default is true. Not used for dialogs.
• maximizeButton: Bridge only. When true, the title bar includes a button to expand the window to its maximum size (typically, the entire screen), if the platform and window type allow it. When false, it does not. Default is false for type palette, true for type window. Not used for dialogs.
shortcutKey | String | r/w | The keypress combination that invokes this element's onShortcutKey() callback.
size | Dimension | r/w | The current size and location of the content area of the window in screen coordinates.
spacing Number r/w The number of pixels separating one child element from its adjacent sibling element.
Because each container holds only a single row or column of children, only a single spacing value is needed for a container. The default value is based on the type of container, and is chosen to match standard Adobe UI guidelines.
text String r/w The title, label, or displayed text, a localizeable string.
Does not apply to containers of type group.
type | String | readonly | The element type; "dialog", "palette", or "window".
visible Boolean r/w When true, the element is shown, when false it is hidden.
When a container is hidden, its children are also hidden, but they retain their own visibility values, and are shown or hidden accordingly when the parent is next shown.
window | Window (SUI) | readonly | The window that this element belongs to.
windowBounds | Bounds | readonly | The bounds of this window relative to the top-level parent window.

Class

Property | Type | Access | Description
frameworkName | String | readonly | Deprecated. Use ScriptUI.frameworkName instead.
version | Any | readonly | Deprecated. Use ScriptUI.version instead.

Methods

Constructor

Window (type: String[, title: String][, bounds: Bounds][, properties: Object])
Creates a new window.
Parameter | Type | Description
type String The window type.
One of:
• window: Creates a simple window that can be used as a main window for an application. (Not supported by Photoshop CS3.)
• palette: Creates a modeless dialog, also called a floating palette. (Not supported by Photoshop CS3.)
• dialog: Creates a modal dialog. This argument can also be a ScriptUI resource specification; in that case, all other arguments are ignored.
title | String | The window title, a localizable string. (Optional)
bounds | Bounds | The window's position and size. (Optional)
properties Object An object containing creation-only properties.
Can contain any of these properties:
• resizeable: When true, the window can be resized by the user. Default is false.
• su1PanelCoordinates: Photoshop only. When true, the child panels of this window automatically adjust the positions of their children for compatability with Photoshop CS (in which the vertical coordinate was measured from outside the frame). Default is false. Individual panels can override the parent window's setting.
•
: When true, the title bar includes a button to close the window, if the platform and window type allow it. When false, it does not. Default is true. Not used for dialogs.
• maximizeButton: When true, the title bar includes a button to expand the window to its maximum size (typically, the entire screen), if the platform and window type allow it. When false, it does not. Default is false for type palette, true for type window. Not used for dialogs.
• minimizeButton: When true, the title bar includes a button to minimize or iconify the window, if the platform and window type allow it. When false, it does not. Default is false for type palette, true for type window. Main windows cannot have a minimize button in Mac OS. Not used for dialogs.
• independent: When true, a window of type window is independent of other application windows, and can be hidden behind them in Windows. In Mac OS, has no effect. Default is false.
• borderless: When true, the window has no title bar or borders. Properties that control those features are ignored. (Optional)

Class

void alert (message: String[, title: String][, errorIcon: Boolean=false])
Displays a platform-standard dialog containing a short message and an OK button.
Parameter | Type | Description
message | String | TThe string for the displayed message.
title | String | A string to appear as the title of the dialog, if the platform supports a title. Ignored in Mac OS, which does not support titles for alert dialogs. The default title string is "Script Alert". (Optional)
errorIcon | Boolean | When true, the platform-standard alert icon is replaced by the platform-standard error icon in the dialog. (default: false) Ignored in Mac OS, which does not support icons for alert dialogs.

Boolean confirm (message: String[, noAsDefault: Boolean=false][, title: String])
Displays a platform-standard dialog containing a short message and two buttons labeled Yes and No.
Returns true if the user clicked Yes, false if the user clicked No.
Parameter | Type | Description
message | String | The string for the displayed message.
noAsDefault | Boolean | When true, the No button is the default choice, selected when the user types Enter. (default: false) Default is false, meaning that Yes is the default choice.
title | String | A string to appear as the title of the dialog, if the platform supports a title. Ignored in Mac OS, which does not support titles for alert dialogs. The default title string is "Script Alert". (Optional)

Window find (type: String, title: String)
Use this method to find an existing window.
This includes windows defined by ScriptUI resource strings, windows already created by a script, and windows created by the application (if the application supports this case). This function is not supported by all applications. Returns a Window object found or generated from the resource, or null if no such window or resource exists.
Parameter | Type | Description
type | String | The name of a predefined resource available to JavaScript in the current application; or the window type. If a title is specified, the type is used if more than one window with that title is found. Can be null or the empty string.
title | String | The window title.

String prompt (prompt: String[, default: String][, title: String])
Displays a modal dialog that returns the user's text input.
Returns the value of the text edit field if the user clicked OK, null if the user clicked Cancel.
Parameter | Type | Description
prompt | String | The string for the displayed message.
default | String | The initial value to be displayed in the text edit field. (Optional)
title | String | A string to appear as the title of the dialog. In Windows, this appears in the window's frame; in Mac OS it appears above the message. The default title string is "Script Prompt". (Optional)

Events

void onActivate ()
An event-handler callback function, called when the window acquires the keyboard focus.
Called when the user gives the window the keyboard focus by clicking it or otherwise making it the active window.

Boolean onClose ()
An event-handler callback function, called when the window is about to be closed.
Called when a request is made to close the window, either by an explicit call to the close() function or by a user action (clicking the OS-specific close icon in the title bar). The function is called before the window actually closes; it can return false to cancel the close operation.

void onDeactivate ()
An event-handler callback function, called when the window loses the keyboard focus.
Called when the user moves the keyboard focus from the previously active window to another window.

void onMove ()
An event-handler callback function, called when the window has been moved

void onMoving ()
An event-handler callback function, called when the window is being moved
Called while a window in being moved, each time the position changes. A handler can monitor the move operation.

void onResize ()
An event-handler callback function, called after the window has been resized

void onResizing ()
An event-handler callback function, called while a window is being resized
Called while a window is being resized, each time the height or width changes. A handler can monitor the resize operation.

void onShortcutKey ()
In Windows only, an event-handler callback function, called a shortcut-key sequence is typed that matches the shortcutKey value for this window.

void onShow ()
An event-handler callback function, called just before the window is displayed
Called when a request is made to open the window using the show() method, before the window is made visible, but after automatic layout is complete. A handler can modify the results of the automatic layout.

Instances

Object add (type: String[, bounds: Bounds][, text: String][, properties: Object])
Creates and returns a new control or container object and adds it to the children of this window.
Parameter | Type | Description
type | String | The type of the child element, as specified for the type property. Control types are listed in the JavaScript Tools Guide.
bounds | Bounds | A bounds specification that describes the size and position of the new control or container, relative to its parent. If supplied, this value creates a new Bounds object which is assigned to the new object's bounds property. (Optional)
text | String | The text or label, a localizable string. Initial text to be displayed in the control as the title, label, or contents, depending on the control type. If supplied, this value is assigned to the new object's text property. (Optional)
properties | Object | An object that contains one or more creation properties of the new child (properties used only when the element is created). The creation properties depend on the element type. See property of each control type. (Optional)

Boolean addEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Registers an event handler for a particular type of event occuring in this window.
Parameter | Type | Description
eventName | String | The name of the event. Predefined event names are: change, changing, move, moving, resize, resizing, show , enterKey, focus, blur, keydown, keyup, mousedown, mouseup, mousemove, mouseover, mouseout, click (detail = 1 for single, 2 for double).
handler | Function | The function that handles the event. This can be the name of a function defined in the extension, or a locally defined handler function to be executed when the event occurs. A handler function takes one argument, the UIEvent object.
capturePhase | Boolean | When true, the handler is called only in the capturing phase of the event propagation. (default: false) Default is false, meaning that the handler is called in the bubbling phase if this object is an ancestor of the target, or in the at-target phase if this object is itself the target. (Optional)

void center ([window: Window])
Centers this window on screen or with repect to another window.
Parameter | Type | Description
window | Window (SUI) | The relative window. If not specified, centers on the screen. (Optional)

void close ([return: Any])
Closes this window.
. If an onClose() callback is defined for the window, calls that function before closing the window.
Parameter | Type | Description
return | Any | A number to be returned from the show() method that invoked this window as a modal dialog. (Optional)

UIEvent dispatchEvent ()
Simulates the occurrence of an event in this target.
A script can create a UIEvent object for a specific event and pass it to this method to start the event propagation for the event.

void hide ()
Hides this windows.
When a window is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.
• For a modal dialog, closes the dialog and sets its result to 0.

void notify ([eventName: String])
Sends a notification message to all listeners, simulating the specified user interaction event.
Parameter | Type | Description
eventName | String | The event name; if omitted, the default event is sent. One of: onClose, onMove, onMoving, onResize, onResizing, onShow (Optional)

void remove (what: Any)
Removes the specified child control from this window's children array.
No error results if the child does not exist.
Parameter | Type | Description
what | Any | The child control to remove, specified by 0-based index, text property value, or as a control object.

Boolean removeEventListener (eventName: String, handler: Function[, capturePhase: Boolean=false])
Unregisters an event handler for a particular type of event occuring in this window.
All arguments must be identical to those that were used to register the event handler.
Parameter | Type | Description
eventName | String | The name of the event.
handler | Function | The function that handles the event.
capturePhase | Boolean | Whether to call the handler only in the capturing phase of the event propagation. (default: false)

void show ()
Makes this window visible.
If an onShow() callback is defined for a window, calls that function before showing the window.When a window or container is hidden, its children are also hidden, but when it is shown again, the children retain their own visibility states.
• For a modal dialog, opens the dialog and does not return until the dialog is dismissed. If it is dismissed via the close() method, this method returns any result value passed to that method. Otherwise, returns 0.

Element of

Button.window

Checkbox.window

DropDownList.window

EditText.window

FlashPlayer.window

Group.window

IconButton.window

ListBox.window

Panel.window

Progressbar.window

RadioButton.window

Scrollbar.window

Slider.window

StaticText.window

TreeView.window

Window.window

Used in:

void Window.center ([window: Window])


Adobe FrameMaker-12 Object Model JS: Index

Class Index

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

$
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

AFrame

Arc

Array

AttrCondExpr

Attribute

AttributeDef

AttributeDefs

AttributeEx

Attributes

AttributesEx

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

BodyPage

Book

BookComponent

Boolean

Bounds

Button (SUI)

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

CMSCheckinParam

CMSConnection

CMSDeleteParam

CMSInfo

CMSMenuItem

CMSObject

CMSProperties

CMSProperty

CMSRegistration

CMSResult

CMSSession

Cell

CharFmt

Checkbox (SUI)

Color

CombinedFont

CombinedFontDefn

CombinedFonts

Command

CompareRet

CondFmt

Constants (enum)

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Date

Dimension

Doc

DrawState

DropDownList

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

EditText

Element

ElementCatalogEntries

ElementCatalogEntry

ElementDef

ElementLoc

ElementRange

Ellipse

Environment

Error

Event (SUI)

Events (SUI)

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

FCodes (enum)

File

FilterArgs

FlashPlayer

Flow

FmtChangeList

FmtRule

FmtRuleClause

Fn

Folder

Font

FontEnc

Fonts

Function

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Global Elements

Globals

GraphicsFmt

Group

Group (SUI)

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

HiddenPage
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

IconButton

IdValuePair

IdValuePairs

Inset

Ints

Iterator

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

KeyCatalog

KeyboardState
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

LayoutManager

Line

ListBox (SUI)

ListItem
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Marker

MarkerType

MasterPage

Math

Math (JS)

MathML

Menu

MenuItemSeparator

Metrics

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Namespace

Number
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Object
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Panel (SUI)

Pgf

PgfFmt

Point

Point (SUI)

Points

Polygon

Polyline

Progressbar

PropIdent

PropVal

PropVals

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

QName
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

RadioButton (SUI)

Rectangle

RefPage

Reflection

ReflectionInfo

RegExp

RoundRect

Row

Rubi

RulingFmt

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

ScriptUI

ScriptUIBrush

ScriptUIFont

ScriptUIGraphics

ScriptUIImage

ScriptUIPath

ScriptUIPen

Scrollbar

Slider

Socket

StaticText (SUI)

String

Strings

SubCol

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Tab

Tabs

Tbl

TblFmt

TemplateData

TemplateDatas

TextFrame

TextItem

TextItems

TextLine

TextLoc

TextRange

TiApiClient

TiFlow

TiText

TiTextTable

TreeView

TypedVal

TypedVals

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

UBytes

UIEvent

UInts

UnanchoredFrame

UnitValue

$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Var

VarFmt
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Window (SUI)
$ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

XML

XMLList

XRef

XRefFmt


Adobe FrameMaker-12 Object Model JS: Globals

Class

Globals

QuickLinks

 AddMenu, Alert, Alive, AllocatePropVals, AppendIntProp, AppendMetricProp, AppendStringProp, AppendStringsProp, AppendVal, CMSAddMenuEntry, CMSGetCmsIdFromName, CMSLogin, CMSRegister, CallClient, CallClientEx, CheckStatus, ChooseFile, ClientDir, ClientName, ClientNumber, CustomDoc, DefineMenu, DisconnectFromSession, Emergency, Err, ErrorName, Externalize, FamilyFonts, FileScrollBox, GetEncodingForFamily, GetEncodingForFont, GetExportDefaultParams, GetFontAngleValue, GetFontFamilyValue, GetFontVariationValue, GetFontWeightValue, GetImportDefaultParams, GetIteratorDefaultParams, GetKeyCatalog, GetNewXMLDefaultParams, GetOpenDefaultParams, GetPropIndex, GetSaveDefaultParams, GetSupportedEncodings, GetUpdateBookDefaultParams, InitializationName, IsDRL, IsDataDifferentFromTemplateData, IsEncodingSupported, IsFileValid, LoadMenuCustomizationFile, LogFMPIPEvent, MenuExists, NewKeyCatalog, NewXML, Notification, NotificationName, Open, PopClipboard, PrintErrno, PrintExportStatus, PrintFAErrno, PrintImportStatus, PrintInitialization, PrintNotification, PrintOpenStatus, PrintPropVal, PrintPropVals, PrintSaveStatus, PrintTextItem, PrintTextItems, PrintUpdateBookStatus, PromptInt, PromptMetric, PromptString, PushClipboard, RemoveMenu, ReturnValue, Run, ScrollBox, Service, SetDdeInstance, ShortcutExists, ShutDown, SimpleNewDoc, SimpleOpen, Sleep, StringLen, USleep, UpdateMenus, UserCancel, WinInstallDefaultMessageFilter

Methods

Instances

int AddMenu (toMenu: string, menu: string, label: string)
Parameter | Type | Description
toMenu | string |
menu | string |
label | string |

int Alert (message: string, type: int)
Parameter | Type | Description
message | string |
type | int |

int Alive (: void)
Parameter | Type | Description
 | void |

PropVals AllocatePropVals (numProps: int)
Parameter | Type | Description
numProps | int |

void AppendIntProp (pv: PropVals, prop: int, val: int)
Parameter | Type | Description
pv | PropVals |
prop | int |
val | int |

void AppendMetricProp (pv: PropVals, prop: int, val: int)
Parameter | Type | Description
pv | PropVals |
prop | int |
val | int |

void AppendStringProp (pv: PropVals, prop: int, val: string)
Parameter | Type | Description
pv | PropVals |
prop | int |
val | string |

void AppendStringsProp (pv: PropVals, prop: int, val: Strings)
Parameter | Type | Description
pv | PropVals |
prop | int |
val | Strings |

void AppendVal (pv: PropVals, prop: int, val: TypedVal)
Parameter | Type | Description
pv | PropVals |
prop | int |
val | TypedVal |

int CMSAddMenuEntry (menuId: int, menuEntryp: CMSMenuItem)
Parameter | Type | Description
menuId | int |
menuEntryp | CMSMenuItem |

CMSRegistration CMSGetCmsIdFromName (cmsName: string)
Parameter | Type | Description
cmsName | string |

CMSSession CMSLogin (setVal: IdValuePairs)
Parameter | Type | Description
setVal | IdValuePairs |

CMSRegistration CMSRegister (cmsName: string)
Parameter | Type | Description
cmsName | string |

int CallClient (clname: string, arg: string)
Parameter | Type | Description
clname | string |
arg | string |

TypedVals CallClientEx (clname: string, arg: string)
Parameter | Type | Description
clname | string |
arg | string |

int CheckStatus (p: PropVals, statusBit: int)
Parameter | Type | Description
p | PropVals |
statusBit | int |

int ChooseFile (title: string, directory: string, stuffVal: string, mode: int, helpLink: string)
Parameter | Type | Description
title | string |
directory | string |
stuffVal | string |
mode | int |
helpLink | string |

string ClientDir (: void)
Parameter | Type | Description
 | void |

string ClientName (_: void)
Parameter | Type | Description
_ | void |

int ClientNumber (_: void)
Parameter | Type | Description
_ | void |

Doc CustomDoc (width: int, height: int, numCols: int, columnGap: int, topMargin: int, botMargin: int, leftinsideMargin: int, rightoutsideMargin: int, sidedness: int, makeVisible: bool)
Parameter | Type | Description
width | int |
height | int |
numCols | int |
columnGap | int |
topMargin | int |
botMargin | int |
leftinsideMargin | int |
rightoutsideMargin | int |
sidedness | int |
makeVisible | bool |

Menu DefineMenu (name: string, label: string)
Parameter | Type | Description
name | string |
label | string |

int DisconnectFromSession ()

void Emergency (: void)
Parameter | Type | Description
 | void |

void Err (message: string)
Parameter | Type | Description
message | string |

string ErrorName (i: int)
Parameter | Type | Description
i | int |

int Externalize (srcDocId: Object, objId: Object, dstFolder: string)
Parameter | Type | Description
srcDocId | Object |
objId | Object |
dstFolder | string |

Fonts FamilyFonts (family: int)
Parameter | Type | Description
family | int |

int FileScrollBox (title: string, directory: string)
Parameter | Type | Description
title | string |
directory | string |

string GetEncodingForFamily (family: int)
Parameter | Type | Description
family | int |

string GetEncodingForFont (font: Font)
Parameter | Type | Description
font | Font |

PropVals GetExportDefaultParams (: void)
Parameter | Type | Description
 | void |

int GetFontAngleValue (angleName: string)
Parameter | Type | Description
angleName | string |

int GetFontFamilyValue (familyName: string)
Parameter | Type | Description
familyName | string |

int GetFontVariationValue (variationName: string)
Parameter | Type | Description
variationName | string |

int GetFontWeightValue (weightName: string)
Parameter | Type | Description
weightName | string |

PropVals GetImportDefaultParams ()

PropVals GetIteratorDefaultParams ()

KeyCatalog GetKeyCatalog (tag: string)
Parameter | Type | Description
tag | string |

PropVals GetNewXMLDefaultParams ()

PropVals GetOpenDefaultParams ()

int GetPropIndex (propVals: PropVals, propNum: int)
Parameter | Type | Description
propVals | PropVals |
propNum | int |

PropVals GetSaveDefaultParams ()

Strings GetSupportedEncodings ()

PropVals GetUpdateBookDefaultParams ()

string InitializationName (i: int)
Parameter | Type | Description
i | int |

bool IsDRL (drl: string)
Parameter | Type | Description
drl | string |

bool IsDataDifferentFromTemplateData (templatePath: string, templateDataProps: PropVals)
Parameter | Type | Description
templatePath | string |
templateDataProps | PropVals |

bool IsEncodingSupported (encodingName: string)
Parameter | Type | Description
encodingName | string |

bool IsFileValid (docOrBookId: Object, silent: bool)
Parameter | Type | Description
docOrBookId | Object |
silent | bool |

void LoadMenuCustomizationFile (pathname: string, silent: bool)
Parameter | Type | Description
pathname | string |
silent | bool |

int LogFMPIPEvent (category: string, subcategory: string, eventName: string)
Parameter | Type | Description
category | string |
subcategory | string |
eventName | string |

int MenuExists (menu: string)
Parameter | Type | Description
menu | string |

KeyCatalog NewKeyCatalog (tag: string)
Parameter | Type | Description
tag | string |

Object NewXML (newXMLParams: PropVals, newXMLReturnParamspp: PropVals)
Parameter | Type | Description
newXMLParams | PropVals |
newXMLReturnParamspp | PropVals |

int Notification (notification: int, state: int)
Parameter | Type | Description
notification | int |
state | int |

string NotificationName (i: int)
Parameter | Type | Description
i | int |

Object Open (fileName: string, openParams: PropVals, openReturnParams: PropVals)
Parameter | Type | Description
fileName | string |
openParams | PropVals |
openReturnParams | PropVals |

int PopClipboard (: void)
Parameter | Type | Description
 | void |

void PrintErrno (i: int)
Parameter | Type | Description
i | int |

void PrintExportStatus (p: PropVals)
Parameter | Type | Description
p | PropVals |

void PrintFAErrno (_: void)
Parameter | Type | Description
_ | void |

void PrintImportStatus (p: PropVals)
Parameter | Type | Description
p | PropVals |

void PrintInitialization (i: int)
Parameter | Type | Description
i | int |

void PrintNotification (i: int)
Parameter | Type | Description
i | int |

void PrintOpenStatus (p: PropVals)
Parameter | Type | Description
p | PropVals |

void PrintPropVal (p: PropVal)
Parameter | Type | Description
p | PropVal |

void PrintPropVals (p: PropVals)
Parameter | Type | Description
p | PropVals |

void PrintSaveStatus (p: PropVals)
Parameter | Type | Description
p | PropVals |

void PrintTextItem (textItem: TextItem)
Parameter | Type | Description
textItem | TextItem |

void PrintTextItems (textItems: TextItems)
Parameter | Type | Description
textItems | TextItems |

void PrintUpdateBookStatus (p: PropVals)
Parameter | Type | Description
p | PropVals |

int PromptInt (message: string, stuffVal: string)
Parameter | Type | Description
message | string |
stuffVal | string |

int PromptMetric (message: string, stuffVal: string, defaultunit: int)
Parameter | Type | Description
message | string |
stuffVal | string |
defaultunit | int |

int PromptString (message: string, stuffVal: string)
Parameter | Type | Description
message | string |
stuffVal | string |

void PushClipboard (: void)
Parameter | Type | Description
 | void |

int RemoveMenu (fromMenu: string, label: string)
Parameter | Type | Description
fromMenu | string |
label | string |

int ReturnValue (retvalue: int)
Parameter | Type | Description
retvalue | int |

int Run (: void)
Parameter | Type | Description
 | void |

int ScrollBox (title: string, stringslist: Strings, _default: int)
Parameter | Type | Description
title | string |
stringslist | Strings |
_default | int |

int Service ()

int SetDdeInstance (ddeInstance: int)
Parameter | Type | Description
ddeInstance | int |

int ShortcutExists (shortcut: string)
Parameter | Type | Description
shortcut | string |

void ShutDown (_: void)
Parameter | Type | Description
_ | void |

Doc SimpleNewDoc (templateName: string, interactive: int)
Parameter | Type | Description
templateName | string |
interactive | int |

Object SimpleOpen (fileName: string, interactive: int)
Parameter | Type | Description
fileName | string |
interactive | int |

int Sleep (seconds: int)
Parameter | Type | Description
seconds | int |

int StringLen (s: string)
Parameter | Type | Description
s | string |

int USleep (microseconds: int)
Parameter | Type | Description
microseconds | int |

void UpdateMenus (: void)
Parameter | Type | Description
 | void |

int UserCancel (: void)
Parameter | Type | Description
 | void |

void WinInstallDefaultMessageFilter (: void)
Parameter | Type | Description
 | void |