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Enhanced Tool Bars (ETB) for FM-12/13

Introduction
Caveat

According to the licensing terms of Adobe, the modification
of dlls may invalidate your licence.
Hence all installation programs which exchange a dll by a
modified one request your confirmation.

Project reason

FrameMaker 9 delivered a completely new interface according
to the CS (Creative Suite) products. While at the first view this
looked nice and provided a number of good functions to the
Frame user, it also had its drawbacks.

Gray interface is not a good
idea either

FM-12 solved these
problems

Orientation on a large screen is not that easy with all items of
the same non-colour. This slows down work:

My constant lamenting about these drawbacks of the new UI
eventually convinced Adobe to change the situation:
 Tool bar buttons can be set to be coloured or grey, normal
sized (as before) or larger.
 The icons have been redesigned to look crisper.
 Icons in tool bars and on the dialogues (pods) have been
harmonised.

So, why still an Enhanced
Tool Bar (ETB)?

Since FrameMaker 6 Shlomo Perets provided additional functions both in the menus and on a special tool bar. Many people boost their productivity with these functions.
8 The Enhanced Tool Bar provides equivalent features.

Online documentation

Workspaces

Some online documents are no more delivered with
FrameMaker, although they are still valid (albeit being in the
state of FM-9 and below).
Workspaces is one of the great features of the new UI. ETB
provides some pre-defined tool bars fitting for large and
small (laptop) screens. Buttons for standard functions like
save and copy are left out, because these functions can be
invoked with well known short cuts.

Vertical tool bar

Access to the Vertical Tool Bar has been abandoned by Adobe
with the new UI. However, the file is still there and can be
used. It is even more useful with a modified design. The nice
thing of this tool bar is that it often fits onto the margin area
of documents thus reducing mouse miles.

Equations palette

Since years the equations palette has not been enhanced in its
presentation. On large screens with high resolution the button labels are not very legible. The Enhanced Tool Bar also
offers an enlarged and more crisp Equations Palette.

Other enhancements

ETB may provide coloured FM-cursors and TAB-indicators for
better recognition as well as some modified dialogues with
more space.
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Feature overview

Feature overview
Note:

ETB is active only in the WYSIWYG view. For greatest compatibility it uses an own set of work spaces and menus.
Vis a vis the original FrameMaker installation the following
features are installed/replaced:

2017-04-27

 Many menu items now show keyboard short cuts.
 Reasonable menu items are added, especially to context
menus.
 For additional/modified tool bars see ETB tool bars on
page 17.
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 The Vertical Tool Bar is back again. It is modified to use 2
rather than 4 levels. The top elements have been changed
to items normally not invoked by keyboard (see Vertical tool
bar on page 20).
 Additional work spaces are defined. See Predefined work
spaces on page 21.
 Menu Insert Special Character got a host of additional
symbols. See Text context menu on page 15.
 Documentation and other features of the Enhanced Tool
Bars (ETB) for FM-12/13 are available with menu Help >
Enhanced Tool Bar.
 Some documents from older FM versions are available in
the menu Help > Enhanced Toolbar (ETB) > FM Online
Manuals. These documents are still useful.
 Completely new documents are FrameMaker Commands
and Customising FrameMaker.
 Offline Help (PDF) is also provided in the ETB menu.
 In Printing View no rulers are displayed. These remain not
displayed when switching to Edit View.
 Clip art added: Scales and grids for diagrams.
 The maker.ini files both from the user area and from $HOME
can be handled with the standard text editor.
 Console file from the User Area can be opened in standard
text editor.
 The small utility TextHelper allows special paste operations from any application (see TextHelper on page 25).
 Optionally you may get coloured cursors and TAB indicators as well as a modified dialogue for Insert Table. See
Optional UI modifications on page 24.

Revisions

1.0 Build from FM-11 version
2.0Added optional UI modifications
3.0Skipped (same version # for all)
4.0Installation in user area rather than C:\SystemMods
4.1Documentation update, Save button in place of Help.
5.0Feature to update the local Help files.
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Installation
Note:

ETB is installed for the current user. For multiple users see
Company installation for multiple users on page 10.

Administrator rights

Data is stored in the FrameMaker installation folder and also
in the user’s area. Nevertheless in a company environment –
where only an IT-person may install programs – the installation program must run with admin rights!

Updating ETB

If you have ETB already installed (and want to update it), start
the Installation program from the Start Menu and use
Remove ETB. Then install the new version of ETB.

Installation steps

1 Please get familiar with this documentation
2 Close FrameMaker, if necessary.
3 Download Inst-FM12-toolbars-en.zip from www.daube.ch
4 Expand the downloaded ZIP to any location (for example to
the desktop). This will store one file PrepInstall-etben.exe and a directory InstallETB.
5 Execute the file PrepInstall-etb-en.exe:

6 The panel tells You what will happen if You use Continue
install. The preparation is necessary to avoid bothering the
user with very Windows-specific stuff …
7 You may get an error message (see Access restriction on
page 7). It’s just information: read it and click OK.
8 You may also get an error message (see Copy fails on
page 7). Just click OK and repeat step 6.
9 Continue install. starts the real installation program. The
Preparation program will close after short time.
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Installation

10 If you want to get the coloured cursors, activate the check
box (see Modified cursors on page 16).
11 Install the files with Install ETB. A message box indicates
successful installation.
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Note:

Start TextHelper
automatically

The original tool bars and work spaces (in the FM installation
directories) are not touched.
During the installation of ETB an entry in the Startmenu >
DDD is created, which starts this utility. See TextHelper on
page 25.
You may wish to copy/move this short cut to the AutoStart
folder.

D
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What’s installed?
Note:

$HOME is the installation directory of FrameMaker.
 A short cut is placed in the Start Menu (All Users):
(De)Installation FM12-Toolbars en. This short cut can be
moved to any convenient place.
 Before files are distributed, original files are renamed to
xxx.ori to be able to restore them. Files are distributed to:
-

Configuration files, documents and helper programs to
$HOME\fminit\configui

-

Additional clip art to $HOME\clipart
The modified vertical tool bar to $HOME\fminit\configui
The enlarged Equation palette to $HOME\fminit
ETB work spaces, tool bars, menu and icon files are copied to the user arae (%appdata%\Adobe\FameMaker\…)
coloured cursors and modified dialogues are installed
by replacing fminit\fmres.dll and …\fmdlg.dll.

 maker.ini in the user area gets information in section
Frame: ETBVersion.

Help, the ETB is not visible!
Initial behaviour

After installing ETB you start FM and open a document. The
ETB toolbars do not show up and the menus are not changed.
For example, there is no Help > Enhanced Toolbars item.
As a user writes: «All of the files installed where they were
supposed to install. But for some reason the toolbars are not
being called by the FM loading process …».

Solution

Select one of the ETB workspaces in the drop down list top
right. It will take some time to establish the workspace. The
ETB features should now appear.

Background

The last used workspace is kept in maker.ini – and this is of
course not an ETB-workspace as long as ETB is not installed.

Tool bars are still grey

“Out of the box” FM installs with the look of the previous version: small grey icons in the toolbars. To use colour and/or
larger icons you need to set this in Edit > Preferences >
Interface and restart FM to activate it. Unfortunately these
settings are not part of the (saved) workspaces.
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Only after this setting ETB_WS_L will look as intended (with
large coloured icons).
Set regular size icons for ETB_WS_S and ETB_LT.

How to add ETB toolbars to custom workspaces
If you have set up your own workspaces you may want to use
therein ETB features, such as a special tool bar. You may wish
to create a screen shot of your private WS to know what you
have defined there.
To use ETB toolbars and menu addenda do this1):
 You start with one of the ETB-workspaces and save it with
your name (prevent the original WS from changes).
 Change the workspace to your desire and save it again.
Note:

This method does not support the special menu set-ups for
Review, AuthorView or CodeView.

Remove ETB from your system
To remove the ETB files from the FrameMaker installation:
 Start the installation program with the short cut in the
Start Menu and then click on Remove ETB.
 Files of the Enhanced Tool Bars (ETB) for FM-12/13 are
removed from the FM installation (configuration files, clip
art and additional documentation, enhanced vertical toolbar).
Completely remove ETB

Since this is not a standard Windows de-installation you may
wish to remove the installation directory (C:\SystemMods) and
the short cut in the Start Menu to get rid of all things.
However, leaving short cut and installation directory intact
allows you install the Enhanced Tool Bars (ETB) for FM-12/13
again.

What’s about FM updates?
The Enhanced Tool Bar was developed for FM 12.0.0.329. An
update of FM may require an updated version of ETB. See
www.daube.ch.
1 When updating or re-installing FM-12, keep the preferences.
2 De-install ETB before you update FM (use button Remove
ETB of the installation program) – FM-12 updates may not
work with installed ETB.
3 Update FM.
4 Install ETB again.

1

Doing it he other way round (modifying the second line in a workspace
file to use the ETB-menus and tool bars is also possible, but more troublesome.
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Possible error messages
Since version 4 of ETB the installation program tries to raise
its privileges 2) to avoid much of the restrictions. But this may
fail in companies with IT installation procedure.

Access restriction

MsgNoAccess1

Thee are old (depreciated) installation files for ETB in
C:\SystemMods\FM9-toolbars-en
- but they can not be deleted (probably access restrictions)
Please let Your adminstraor remove this directory
[the files do not harm your system it’s just a cleaning up]

Copy fails

MsgNoAccess3:
Prepare Installation Enhanced Toolbars
Copy from C:\Users\Klaus\Desktop to
C:\Users\Klaus\AppData\Roaming\D+DD\FM9-toolbars-de failed
Please delete C:\Users\Klaus\AppData\Roaming\D+DD manually,
because the attribute
Read-only can not be removed by the progrm (Windows fart).

Please follow the instructions on the message and click OK;
then again try Continue Inst.

FM version mismatch

The following message appears, if you have checked the box
for “Install coloured cursors” and FM is not patched up to the
desired level.
:

Error
The resources version number does not match the FrameMaker
version number

8 Close FM; start the installation program and use Remove
ETB, then install ETB again without checking the box.
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Prepare Installation Enhanced Toolbars

2

The method is similar to “Run as Administrator” with the context menu.
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File deletion fails

If some files could not be copied automatically during installation, then an analogous message may be issued during deinstallation:

8 Manually delete these files, for example with the file
explorer at %APPDATA%\Adobe\FrameMaker\12\WorkSpaces.

Access to user area fails

The Windows User Access control is (at least to me) a mystery. I do not understand most circumstances leading to an
error or even failing installation.
Especially in companies where only an IT admin may install
programs, the access to the user area may fail even by starting Install-FM12-etb.exe wit admin rights and with the entry
of a password. In this case only a manual copy will help.
 Menu Help > Enhanced Toolbar exists 3).
 In menu View > Toolbars all ETB-xxx tool bars are missing.

Symptoms for this situation:
Precondition for manual copy

Do not de-install ETB with the installation program now!
Assure the existence of following files in the installation
directory (%appdata%\D+DD\FMvv-toolbars-en with vv being
12 or 13):

FM 12

...\WorkSpaces\UnStructured\WYSIWYGView\menus\etb-menus.cfg

Copy manually

The various FM versions have different file structures.

From
C:\Users\Admin\Appdata\Roaming\D+DD\FM12toolbars-ena

To %appdata%\adobe\framemaker\12\

\ETB

Content has already been copied to FMinstallation directory $HOME

\Icons\*.*

\

\WorkSpaces\*.*

\WorkSpaces

a. Of course for FM-13 the directory is named accordingly.

3

If this is not the case, you need to contact the author for help. You will
receive a detailed list, where to place which file. Your complete FM-version number is needed for this.
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Windows annoyances
After installing in Windows (most likely not only in version 7)
you may get the following message:

8 Just ignore it with Cancel. You may set the compatibility
flag for the program to avoid the message in the future.

User Access Control

None of the D+DD programs is certified by Microsoft. Hence a
standard Windows installation issues messages concerning
danger by executing one of these programs.
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Program is not installed
correctly
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Company installation for multiple users
Note:

The standard installation for ETB fails in this environment.
In companies software is mostly installed by an IT-specialist
who uses a special user account with administrator rights.
The individual users have individual accounts.
To install ETB on a shared workstation, the administrator
must perform various actions in his special account:
1 Start FrameMaker at least once both in the Admin account
and in the target user accounts to establish the
%appdata%\Adobe\FrameMaker\nn\ data area. Close FM.
2 Install ETB in the Admin special account.
3 Look into %appdata%\D+DD\FMxx-toolbarsen\config.ini and note appVersion.
4 Start FrameMaker to verify ETB is present. You must switch
to an ETB-xx work space to see the ETB icons etc.
5 Copy the relevant ETB data to the user accounts:

From Admin account

To User account

%appdata%\adobe\framemaker\12\

%appdata%\adobe\framemaker\12\

\etb*.*

\

\WorkSpaces\Structured\YSIWYGView\etb*.*

\WorkSpaces\Structured\YSIWYGView\

\WorkSpaces\Structured\YSIWYGView\menus\
etb-menus.cfg

\WorkSpaces\Structured\YSIWYGView\menus\

\WorkSpaces\Structured\YSIWYGView\toolbars\
etb*.*

\WorkSpaces\Structured\YSIWYGView\toolbars\

\WorkSpaces\UnStructured\YSIWYGView\etb*.*

\WorkSpaces\UnStructured\YSIWYGView\

\WorkSpaces\UnStructured\YSIWYGView\menus\
etb-menus.cfg

\WorkSpaces\UnStructured\YSIWYGView\menus\

\WorkSpaces\UnStructured\YSIWYGView\toolbars\ \WorkSpaces\UnStructured\YSIWYGView\toolbars\
etb*.*

6 Switch to the user account to verify the existence of ETB
(select an ETB work space).
7 Close FrameMaker to edit maker.ini
8 In %appdata%\adobe\framemaker\12\maker.ini add the
following lines
In section [Frame]:

ETBVersion=value noted in step 3.
ETBColour=1

9 Add the following 2 lines to maker.ini only if the
fmres.dll in $HOME\fminit\ had been replaced by the
modified version to provide coloured cursors.
In section [Preferences]

UseSystemCursor_comment=Added by ETB FM-12 en
UseSystemCursor=Off

10 You may wish to make other recommended modifications
to maker.ini on the users request:
In section [Preferences]

ClipboardFormatsPriorities=UNICODE TEXT, TEXT, RTF,
FILE, OLE 2, EMF, META, DIB, BMP, MIFW, MIF
SymbolSortingBeforeAlphaNumeric=On
GetLibraryColorRGBFromCMYK=None
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ETB menus
For many menu items short cut labels have been added. Also
new menu items have been introduced.

Standard menus
File menu

Document, book

Edit menu

Document, book

D

E:\_DDDprojects\FM-toolbar00\AllETB-frozen-items\etb-fm12-en.fm

2017-04-27

The modifications to the standard menus are highlighted in
yellow.
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Format menu

No changes

View menu

Document, book

Special menu

Graphic menu

No changes
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ETB menus

Table menu

Help menu
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Context menus
Document context menu

Book context menu
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Text context menu

D

In FM-13 the menu for direction markers is kept separately.

Anchored Frame context
menu
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Table context menu

Graphics context menu
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Tool bars
Standard tool bars
4)

With FM-12 Adobe provided coloured tool bar icons and in
addition two sizes: regular and large. Some of the icons have
been changed and are harmonised with those used in dockable dialogues (aka pods). The images also became crisper as in
FM-9 to FM-11.

ETB tool bars

History

Repeat

Redo

Undo

Clear/delete

Lock/unlock
document

Print

Import
formats

Import
file

New

Save

etb_quick_ws.xml

Buttons for Help, Open, Cut, Copy and Paste have been left
out, because ‘real users’ have the appropriate short cuts in
their fingers. Save button indicates status of document.
Note:

Quick Access LT

Repeat repeats the last action in the command history. This
may be any re-doable action.

History

Lock/unlock
document

etb_quick_lt.xml

Import
file

Only a minimum of standard functions has been kept.

Paragraph bar

Paragraph
actions

Tabulation
types a

Text alignment
drop down list

Paragraph
format
drop
down
list

Paragraph
catalogue

D

etb_para.xml

Repeat last
paragraph cmd
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Quick Access WS

Copy
paragraph fmt
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FM-12 enhancements

a. TAB positions can be set only with View > Rulers
ON).

4

These are the result of my ongoing complaints in the beta test forums.
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Delink Hotspot

Hotspot
Properties

Delete poster

Set Poster

Gravity

Snap

Pick up Object
properties

Copy column
width

Custom
ruling/shading

Shrink-wrap
column width

Straddle/unstraddle cells

Align bottom

Align middle

Algign top

etb_tables.xml

Cut rows or
columns

Tables

Object
properties

etb_extra.xml
Jump back

Shrinkwrap
equ/frame

Display vert
tool bar

Show/hide
cond indic.

Copy cond.
text setting

Insert
Footnote

Next screen

Previous
screen

Jump next

Printing
view

Expand
equ/frame

Insert
anchored

Editing
View

Equation
editor

Reference
Pages

Convert text
to lower case
Convert text
to mixed case
Convert text
to upper case
Insert special
character

Character
format
drop
down
list

Extra functions

Spelling
checker

Character
catalogue
Copy
character fmt
Repeat last
character cmd

etb_display.xml

Master
Pages

Body Pages

Display functions

Find next

Find/replace

etb_char.xml

Add
columns

Add
rows

Go to
top left cell

Select
table

Select
body cells

Sleect
colum

Select
row

Table catalogue

Insert Table

Character bar

Scale

Flip left/right

Flip up/down

Unsmooth

Object Properties

Smooth

Reshape

Distribute

Send to Back

Send to Front

ungroup

Group

Enhanced Tool Bars (ETB) for FM-12/13

The standard toolbar extended with functions in shaded area.

etb_object_props.xml

The standard toolbar extended with functions in shaded area.

Tool bars

Enlarged Equation palette

D
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The Equation palette is enlarged by 125% and uses fonts for
crisper button labels:
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Vertical tool bar
The vertical toolbar is very handy when placed in the margin
area of facing pages - reducing mouse miles:

The vertical tool bar can be accessed by View > Show vertical
Toolbar or by the icon
..

Import file
Editing View
Pint View

Import formats
Show body pages
Show master pages

Goback

Show reference pages

Copy ¶ format

Copy character format

Repeat ¶ action

Repeat character action

Switch

Switch

Text normal

Select table row

Bold

Select table column

Italic

Select body cells in column

Unterline

Select table

Ungroup
Bring to front
Distribute
Smooth
Flip up/down

Group
Send to back
Reshape
Unsmooth

Increase font size

Select first cell in table

Decrease font size

Delete rows/columns

Scale

Object properties

Lower case

Add rows below

Snap

Gravity snap

Initial caps

Add columns at right

Upper case

Align top

Move up 1 pt *

Move down 1 pt *

Move left 1 pt *

Move right 1 pt *

Search/Replace

Align middle

Align top

Spell checking

Align bottom

Align hor. centre

Anchored frame

Straddle/unstraddle cells

Align bottom

Footnote

Shrinkwrap column width

Rotate clockwise

Table

Custom ruling/shading
Make line solid
* at zoom 100% the movement is 1 pt
at zoom 253% the movement is 0.1 mm

Note:

Flip right/left

Align left
Align vertical centre
Align right
Rotate counter clockwise
Make line dashed

Since this is a genuine FrameMaker palette, tool tips are not
available. You may look up the horizontal tool bars.
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Predefined work spaces
Note:

Switching the work spaces does not switch the size of the tool
bar icons. Hence You need to set Preferences > Interface >
Icons to the desired value. Then restart FrameMaker.
See also Help, the ETB is not visible! on page 5).
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 ETB-WS-L using large tool bar icons for work stations with
at least 1820 pixels screen width .
 ETB-WS-S using regular sized tool bar icons for work stations, (additional tool bar: Track text edits.
 ETB-LT for laptops with at least 1400 pixels screen width
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ETB-WS-L

 The pods to the right show icons and names. Graphics
tools are arranged below the pods.
 First row of toolbars contains
etb_quick_ws.xml
etb_para.xml
etb_char.xml
etb-display.xml
etb_extra.xml

 Second row of toolbars contains
etb_tables.xml
align_object.xml
object_properties.xml.
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ETB-WS-S

 The pods to the right show icons and names. Graphics
tools are arranged below the pods.
 First row of toolbars contains
etb_quick_ws.xml
etb_para.xml
etb_char.xml
etb-display.xml
etb_tables.xml

 Second row of toolbars contains
trackchanges.xml
align_object.xml
object_properties.xml.
etb_extra.xml
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ETB-LT
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Picture displayed with the same resolution as for ETB_WS.

 The pods to the right are minimized to the icons. Graphic
tools are aligned to the left of the pods.
 First row of toolbars contains
etb_para.xml
etb_char.xml
etb_tables.xml
etb_display.xml

 Second row of toolbars contains
etb_quick_lt.xml
align_object.xml
object_properties.xml
etb_extra.xml

General notes on workspaces

D

 When You start FM and have not yet opened a document,
the list of workspaces contains only None.
 In this stage the ETB menu items are already available, but
not the toolbars.
 While a book or document is open all menus and toolbars
are available.
 After closing the last book or document again only workspace None is defined. At this stage (although similar to the
first one) no ETB functions are available.
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Optional UI modifications
The following UI modifications are only installed, if you check
the appropriate box in the installation dialogue.

Coloured cursors and tab indicators
The FrameMaker internal cursors can be colourised to
enhance their instant recognition. Also the small TAB indicators (visible only if View > Borders is ON) can benefit from
colour.
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Additional utilities
TextHelper
During the installation of ETB an entry in the Startmenu >
DDD is created, which starts this utility.

Texthelper establishes the following keyboard short cuts:
Windows+v

Paste the clipboard contents without formatting information,
that is, just plain text (including line breaks. This functions is
handy to copy from other applications, including web pages,
but also with FrameMaker.

Windows+space

Remove sequences of spaces to one before pasting the text
(without formatting information).

Windows+u

Change \ to / before pasting the text (without formatting
information).

Note:

The following two functions work only correct if there exist
only two document windows (most likely side by side). For
example no book window must be open. Before invoking the
function focus must be in one of the document windows.

Windows+y

The currently active and then the other document window is
scrolled down by one document-page5).

Windows+x

The currently active and then the other document window is
scrolled up by one document-page.

Note:

If you have other useful functions in mind, please contact the
author (klaus@daube.ch).
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Texthelper manifests itself by an icon in the system tray.
Right clicking on it displays a context menu:

5

In the ETB the keys Page down and Page up advance the display a document page, not a screen height.
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Shortcuts with function keys
a

F1

F2

F3

F4

F5

F6

F7

F8

F9

F10

F11

F12

26

Just the key

Help

Default
paragraph
formt

Repeat last
find

Repeat
paragraph
command

Repeat
character
command

Repeat last
action from
undo history

Select
condition tag

Select
character tag

Select
paragraph tag

Repeat
element
command

Previous
screen

Next
screen

Shift + …

File
information

Go to previous
view

Go to next
view

Cascade
windows

Tile windows

Object
properties

Conditional
text

Change
dialogue to As
Is

Change
dialogue to
selection

Show context
menu

Place
paragraph at
top of col.

Place
paragraph
anywhere

Ctrl + …

Zoom 100%

Zoom in

Zoom out

Close
document

Show/hide
conditional
text

Switch
between
documents

Select area
with same
condition

Select area
Transpose
with same char characters
format

Select entire
paragraph

Select
sentence

Select line

ALT + …

Change text to
lower case

Change text to
initial caps

Change text to
upper case

Close dialogue
box, Quit FM

Anchored
frame

Update
references

Copy
conditional
text settings

Copy character Copy
format
paragraph
format

Copy table
column width

Insert cross
reference

PDF set up

Insert, …

Fit page in
window

Make text
unconditional

Move insertion
point to next
pgf

Update
paragraph tag

Show/hide
graphics

Show/hide
condition
indicators

Deselect
condition tag

Show a single
condition

Unwrap frame,
put below pgf

Shrink frame,
make in-line

New paragraph Spelling
tag
checker

a. Light blue area: command works only on un-tabbed documents: Light yellow area: only for undocked panels. Light red areas: commands opens a dialogue/panel.

Short cuts with Insert key
Home
Top cell in
table

End

<

8

Bottom cell in
table

Previous table
cell

Next table cell

b

c

d

a
ª ord. fem.

• bullet

n
– n-dash

o
º ord. masc.

1
¼ quarter

%
‰ per 1000

2
½ half

© copyright

† dagger

p
¶ paragraph

:
Cell above

q
š s hacec

3

Cell below

e
… ellipsis

4

ƒ floring

¦ broken vert.

ß German ss

§ section

5

[

™ trademark

6

«

]
»

7

<
‹

h
æ ae ligature

t

ø oere

/
⁄ fraction

g

s

¾ 3 quarters

|

¡ inverted !

f

r
® registered

!

>

i
Æ AE ligature

u
μ my

v
¢ cent

8

›

~
˜ tilde acc.

‡ d. dagger

w
£ sterling

9

Ø Oere

>

j

0
° degree

"
" straight “

'
' straight ‘

Shortcuts with Control key
0
Select variable

1
Insert elemen

2
Wrap element

3
Change
element

4
Select In
condition tag

5
Select Not In
condition tag

6
Select Unconditional

7
Edit attribute

8
Select
character tag

9
Select
paragraph tag

k
œ oe ligature

l
Œ OE ligature

x
× multiplay

_
¯ macron

+
± plus minus

y
¥ Yen

?
¿ inverted ?

m
— m-dash

z
¤ currency

- non break -

:
÷ division

. (period)
· centred dot
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Shortcut overview

Restrictions of the new interface

Shortcuts and escape
sequences

A complete list ordered by function area is available in ETB
via Help > Enhanced Toolbar (ETB) > Online Manuals >
FrameMaker Commands.

Little known short cuts

CTRL+TAB switches between open documents, but also from
a pod (e.g. Find) to the active document. Hence To replace
manually:

2017-04-27

1.
2.
3.
4.
5.

CTRL+f
Write text to be found
ENTER
CTRL+TAB
Write text to replace the found one (highlighted).

Problem with special
commands

Since FM-9 (the new user interface) there are issues with multiple code commands and hypertext commands.
 Multiple code commands (e.g. EditingDisplay) may not
have a menu assigned, or the buttons and/or short cuts
will not work. Only 2 of the 3 elements can be defined.
 For hypertext commands (e.g. the invocation of the vertical
tool bar) there must not be a short cut defined (or the
menu will not work).

Toggle commands

Toggle commands are menu items which are switched by
pressing Shift while selecting a menu item.
These commands do not allow menu modifications, such as
re-ordering.

Application key

The application key on Windows keyboards can be pressed to
get the context menu. I have never used the tool bar short
cuts with his key – hence do not know whether they really
worked at all.
Although a key sequence using the /Apps key6) is valid in
customui.cfg nothing happens when such a sequence is used.
Hence these short cuts now use the /Ins key.

D

E:\_DDDprojects\FM-toolbar00\AllETB-frozen-items\etb-fm12-en.fm

Restrictions of the new interface

6

Shlomo Perets’ Toolbar Customisations used this key and I wanted to be
compatible.
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