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FMmarkers -

handling markers

Overview v1.2
FMmarkers v1.2 answers various demands for han-
dling markers: inspect markers, find and change text 
or type of markers.
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Important • Any operation performed by a script can not be 
undone3))! Best practice is to save the document 
before performing script actions on it. 

• In case of an error or change of Your mind you 
can simply Revert to Saved for the pertinent doc-
ument.

• Only scripts which do not modify document con-
tents (e.g. creating a new document) are safe in 
this respect.

3 This must not necessarily be the case for plug-ins represented 
as dll’s.
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Script installation
1 Close FrameMaker if necessary. 

2 Download the Inst-FMmarkers.zip from my web-page

3 UnZip the file to the desk top.

4 Execute the file PrepareInstallation.exe as Admin.

Note: Windows Defender may react to this program with a virus warn-
ing. This is a false positive. You may check this with an upload to 
Virustotal. See Avoid Windows Defender intervention on page 3.

5 The last six FM-versions present in your %appdata%/Adobe/
FrameMaker/ are listed in the dialogue (on your system 
there may be only one).

The language of the installation dialogues adapts to the UI 
language of your current FM installation (de, en, fr).

6 Select the appropriate FM installation and use Continue . 
This opens the installation program:

7 Select the appropriate options:

- Use the first option to start the script automatically at FM-
start.

- Use the second option if you wish to start the script on 
demand from a trusted source. You can define the script 
in File > Scripts … > Catalog (Script Library) as Favourite: 
use the Add button and navigate to My Documents \Adobe 
Scripts\FMmarkers\FMmarkers.jsxbin.

8 With Install the script and associated files will be trans-
ferred into the relevant locations.

9 A message indicates the end of the installation. The desktop 
icons will be removed.

http://www.daube.ch/docu/fmaker89.html
https://www.virustotal.com/gui/home/upload
https://www.virustotal.com/gui/home/upload
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De-install the script To de-install the script, start the installation program from the 
short cut in the Start-menu > D+DD. Then use the Un-Install 
button.

This removes the script only from the locations defined in the 
options. You can later use the installation program again.

To get completely rid of the script you need to remove the fol-
lowing in addition to the de-installation:
• The short cut in the start menu
• Directory %appdata%\D+DD\FMmarkers 

Avoid Windows Defender intervention
1 In Windows settings navigate to Windows Security > Virus & 

Threat protection settings > Manage Settings
2 Go to Exclusions
3 Add the folder you need to exclude: 

C:\Users\username\AppData\Roaming\D+DD

Details of the D+DD script installation
• Unpacking creates a program (Prepinstallation.exe) 

and a directory (InstallThis).
• Prepinstallation.exe should be executed with admin 

rights (right-click and select), otherwise a message will 
appear indicating this.

• Prepinstallation adds the information about the current 
directory (e.g. C:\Users\Klaus\Desktop\InstallThis) 
and the installation directory of the selected FM version to 
the InstallThis\config.ini file.

• Then InstallThis\Inst-FMmarkers.exe is executed, 
which creates a directory D+DD\FMmarkers in the Windows 
Start directory and copies everything from InstallThis 
there. In addition, a short cut is created to this directory.

• This directory contains Inst-FMmarkers.exe, which is now 
executed and the unpacked files that are no longer used (e.g. 
on the desktop) are deleted.

• Inst-FMmarkers.exe asks where the script should be cop-
ied to (Startup folder or MyDocuments\Adobe 
Scripts\FMmarkers). The selected option must also be 
selected during a de-installation in order to de-install at the 
correct location.

• The script consists of the main module FMmarkers.jsx and 
the modules in the FMmarkers directory.

• Various scripts (e.g. the installation of the tool bars) also 
write something in the maker.ini in the user area in the 
section [D+DD].
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Use cases
Markers can be placed on any paragraph, on any sort of page. 
In the array of found markers they are in the order the user 
may find them with the Find/Change dialogue:
• First the markers from the Body Pages
• Then those from Master Pages.
• Last those from Reference Pages.

Check markers You can walk through all markers as they are arranged in the 
document. This may be any marker or a specific type.

The maker contents is displayed and you may change it and 
update the marker.

Find marker You may search for a marker (any or of particular type) by 
inspecting its text. The search criterion may be a RegEx.

Unfortunately it is not possible to indicate the found text in the 
displayed marker text. Hence the position of the find is indi-
cated in a separate filed.

Change text of marker The maker contents is displayed and you may change it (manu-
ally or by the Replace function and update the marker.

Change type of marker You can also change the type of marker. So you can correct the 
frequent error of index marker contents in a cross-reference 
marker …

Batch processing You may iterate through all found markers and change con-
tents or type. Be careful with this function, because scripted 
actions can not be undone!
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Script invocation
Note: FMmarkers handles only markers in the main flow of the body 

pages of a document.

The script creates palettes and/or dialogues. Palettes stay open 
even if you activate the document or change the document (e.g. 
click into it to define an insertion point). A dialogue must be 
closed to be able to continue work in the document.

Menu entries
The menu is inserted at these locations:

FM ≤ 13 at the bottom of the Special menu.

FM 13…15 at the bottom of the Insert menu.

FM ≥ 16 in the Insert menu, after the Marker entry.

Documentation This pdf is displayed with your PDF viewer.

Handle any markers FMmarkers – Handle any markers is designed to handle both 
system defined and user defined markers:
• Walk through all markers of the document and display their 

contents. All markers may also be searched for text.
• Select a particular marker type and walk through them or 

search marker text
• Change contents of a marker
• Change a marker type

Display of marker 
contents

The standard FM dialogues use a not very user friendly display 
of text items. With a normal screen set-up the font is quite 
small and the lack of serifs make distinction often difficult:

10pt system font 12 pt Consolas

Selecting in the lists I decided to select by double click. This avoids inadvertently 
selection during scrolling and just pointing to something.

Help, it does not behave!
If you stop working in FrameMaker by hibernating Windows, 
then after wake-up scripts do not behave as they should.

Even after Refresh or restarting the script from the menu: the 
panel shows the correct marker content but not the correct 
marker type during navigation.

Remedy Save all open documents and restart FrameMaker.

Special | Insert Shortcut See 
Handle markers [DDD] Documentation

Handle any markers ESC q m a page 6
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Handle any marker
Any versus typed markers Per default all markers are involved in the walk-through or the 

search. To consider only markers of a particular type, switch 
from Any marker to Typed (this is selected automatically when 
you double click on a marker type in the list).

Walk through versus find There are two methods to find a marker for an action on it:

• Per default By navigation is selected, which lets you walk 
through any (or only a specific type of) markers by means of 
Navigation buttons.

• Search for a marker by its text contents. For this method you 
set the radio button By search. 

• If the Search finds the Text to be found, then you may con-
tinue the search within the text with button Search within.

UI features
Marker types • Initially any marker is handled..

• To handle markers of a specific type you select this type by 
double clicking in the list.

In the list of marker types ‘user defined’ markers are listed 
first and then the FM defined marker types. 

Search conditions • Initially By navigation is set. This walks through any or a 
selected type of markers by means of the Navigation 
buttons.
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• To find markers based on their contents set By search.
Find by Contents To search by contents you set up a search term in the field Text 

to be found. You may skip further search within the current 
marker text by using button Skip to next.

If an appropriate marker is found, radio button In current 
marker becomes active and also the Replace button. Using but-
ton Search in the current marker looks for more occurrences 
of the search term.

Contents of the marker The contents of the current marker is displayed in the top edit 
area. It may be modified manually and the marker then modi-
fied with button Update marker.

Note: Unfortunately it is not possible to indicate a found term in the 
displayed text. A selection is only possible by user action. Hence 
a found term is reported in the message area.
This restriction makes it also difficult to change only particular 
found term among multiple occurrences. This must be done by 
manual replacement in the edit area.

Search and Replacement For t he search operation you may either define Consider 
case and/or Whole word or Regular expression.

To replace after using the Search button successfully, use but-
ton Replace. You may use the Replace button multiple times if 
you assume that there are multiple occurrences of the 
searched string in the current marker text.

See also Regular expressions in search and replace on page 8.

Change marker type When a marker is found both in the list of types and in the 
short list the type is indicated.

To change the type of the found marker, find the new type in 
the shorter list and double click on it; then use the Change but-
ton. This updates the current marker to the new type.

Do for all When this box is checked, then the next operation with either 
the button Change or the button Replace will perform the 
action for all pertinent markers:
• By walking through any or a selected type.
• By searching any or a selected type by text.

Note: There is no undo for scripted actions. Hence this is a dangerous 
function. Always save your document before setting this check-
box!

Message area At the bottom between the buttons is a normally empty area. 
This can display a message, for example, if navigation came to 
a halt. Important messages are provided in red.

Navigation buttons With the navigation buttons you can walk forwards and back-
wards through the markers of a document.

 Go to the first marker of the requested type.

◀ Go to the previous marker of the requested type. If we are 
already at the first marker, a message is issued.

▶ Go to the next marker of the requested type. If we are already 
at the last marker, a message is issued.

 Go to the last marker of the requested type. 

Delete Marker Remove the marker from the text. The sequence of markers 
will be rebuilt.
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Regular expressions in 
search and replace

Only if Regular expression is specified for the search, the 
search field may contain such an expression. In the replace 
field the substitution string then may contain references to 
search-groups ($1 … $9). 

Examples

General action buttons
Help [pdf] Display the pdf of this document at the appropriate page.

Keep options Check this box if you want to preserve the settings of the radio 
buttons on top, the search options and the selection of the 
marker type. Otherwise the automatic or intentional Refresh 
will set them back to the default (Any marker, By navigation).

Refresh A change of the active document is not recognised by the pal-
ette. Hence you need to use this button in the following cases:
• Handling markers of another document to which you 

switched. 
You may switch to any other document while the palette is 
open (e.g. for consultancy) and then back to the one for 
which you have invoked the palette or performed the last 
Refresh.

• Manipulating markers in the text outside of the palette 
(insert, delete, move, change name or contents).

• Manual switching between page types (body, master, refer-
ence).

Note: In rare cases the marker list is not updated automatically. Use 
the Refresh button if you are suspicious!

Note: After Refresh the selected marker is that one following the text 
location before you used Refresh. Even if a marker is selected 
and then Refresh used, after the operation the next marker is 
selected4).

OK, Done Close the palette.

Publishing markers
Publishing markers are not inserted by Insert > Marker… but 
by Insert > Publishing Markers:

- CSH Marker: Marker type TopicAlias, contents string
- Index Marker (same as ordinary index marker)
- Page Break Marker: Marker type PageBreak, contents 

Filename|Topic Title 
- No Page Break Marker: Marker type PageBreak, contents 

<nosplit>

String Search Replace Result

345:und so weiter
^(\w+)(.+) ($1)$2 etc. (345):und so weiter etc.
(.*)\bso(.*) $1immer$2 345:und immer weiter

63456: 2heading: Housing
^[^\d]+

This is a real cross reference and will not be found
Top level : second level This index entry has erroneously be declared as Cross reference

4 I have not yet found out how to avoid this jump.
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With the exception of the Index Marker these are treated as 
Custom markers, because they are not in the internal list of 
markers.
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Marker specials

Markers on other than Body Pages
Markers can be placed on master pages and on reference 
pages, whether they serve their purpose or not.

Index markers
FM help states: You cannot use white space or the following 
special characters for the marker text of an index marker:

~!@#$%^&*()+-={}|[]\:";'<>?,./

Note: This is not tested during creation of the index marker!

Tests demonstrate that only the syntax relevant characters are 
forbidden, namely ; : < > \ [ ] . A literal backslash (\\) is 
allowed.

The term white space is misleading, as multiple blanks are 
valid, but not line break or ¶ break. A TAB is converted to a 
blank.
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