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Important • Any operation performed by a script can not be 
undone3))! Best practice is to save the document 
before performing script actions on it. 

• In case of an error or change of Your mind you 
can simply Revert to Saved for the pertinent doc-
ument.

• Only scripts which do not modify document con-
tents (e.g. creating a new document) are safe in 
this respect.

3 This must not necessarily be the case for plug-ins represented 
as dll’s.
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Script installation
1 Close FrameMaker if necessary. 

2 Download the Inst-FMvars.zip from my web-page

3 UnZip the file to the desk top.

4 Execute the file PrepareInstallation.exe as Admin.

Note: Windows Defender may react to this program with a virus warn-
ing. This is a false positive. You may check this with an upload to 
Virustotal. See Avoid Windows Defender intervention on page 3.

5 The last six FM-versions present in your %appdata%/Adobe/
FrameMaker/ are listed in the dialogue (on your system 
there may be only one).

The language of the installation dialogues adapts to the UI 
language of your current FM installation (de, en, fr).

6 Use Continue Installation. This opens the installation pro-
gram:

7 Select the appropriate options:

- Use the first option to start the script automatically at FM-
start.

- Use the second option if you wish to start the script on 
demand from a trusted source. You can define the script 
in File > Scripts … > Cataloge (Script Library) as Favour-
ite: use the Add button and navigate to My Documents 
\Adobe Scripts\FMvars\FMvars.jsxbin.

8 With Install the script and associated files will be trans-
ferred into the relevant locations.

9 A message indicates the end of the installation. The desktop 
icons will be removed.

http://www.daube.ch/docu/fmaker79.html
https://www.virustotal.com/gui/home/upload
https://www.virustotal.com/gui/home/upload
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De-install the script To de-install the script, start the installation program from the 
short cut in the Start-menu > D+DD. Then use the Un-Install 
button.

This removes the script only from the locations defined in the 
options. You can later use the installation program again.

To get completely rid of the script you need to remove the fol-
lowing in addition to the de-installation:
• The short cut in the start menu
• Directory %appdata%\D+DD\FMvars 

Avoid Windows Defender intervention
1 In Windows settings navigate to Windows Security > Virus & 

Threat protection settings > Manage Settings
2 Enter Exclusions
3 Add the folder you need to exclude: 

C:\Users\username\AppData\Roaming\D+DD

Details of the D+DD script installation
• Unpacking creates a program (Prepinstallation.exe) 

and a directory (InstallThis).
• Prepinstallation.exe should be executed with admin 

rights (right-click and select), otherwise a message will 
appear indicating this.

• Prepinstallation adds the information about the current 
directory (e.g. C:\Users\Klaus\Desktop\InstallThis) 
and the installation directory of the selected FM version to 
the InstallThis\config.ini file.

• Then InstallThis\Inst-FMvars.exe is executed, which 
creates a directory D+DD\FMvars in the Windows Start 
directory and copies everything from InstallThis there. In 
addition, a short cut is created to this directory.

• This directory contains Inst-FMvars.exe, which is now 
executed and the unpacked files that are no longer used (e.g. 
on the desktop) are deleted.

• Inst-FMvars.exe asks where the script should be copied to 
(Startup folder or MyDocuments\Adobe Scripts\FMvars). 
The selected option must also be selected during a de-instal-
lation in order to de-install at the correct location.

• The script consists of the main module FMmarkers.jsx and 
the modules in the FMvars directory.

• Various scripts (e.g. the installation of the tool bars) also 
write something in the maker.ini in the user area in the 
section [D+DD].
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Script invocation

Menu entries
The menu is inserted at these locations:

FM ≤ 13 at the bottom of the Special menu.

FM 13…15 at the bottom of the Insert menu.

FM ≥ 16 in the Insert menu, after the Variable entry.

Document menu

Documentation This pdf is displayed with your PDF viewer.

Handle variables A single palette eases a number of tasks concerning variables, 
such as:
• Create a new user variable using building blocks.
• Change the name of a user variable.
• Change contents of a user or a system variable.
• Insert a variable at the current cursor location.
• Walk through the document and display any variable.
• Walk through the document and display the variable with 

the name selected in the list. So you can verify correct use of 
the variable (in its textual environment).

• Remove an improperly placed variable and insert another.

Note: Since this is a palette it stays open until you close it explicitly.

Import/Export variables This dialogue allows two functions:
• Import variables into the current document from another 

document.
• Export variables from the current document into another 

document.

Note: Since this is a dialogue (not a palette) you must close it before 
you can act on your current document.

Special | Insert Shortcut See 
Handle variables [DDD] Documentation ESC q v d

Handle variables ESC q v v page 5
Import/Export variables ESC q v x page 9
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Handle variables
Palette FMvars stays open even if you activate the document or 
change the document (e.g. click into it to define an insertion 
point).

Message area At the bottom between the buttons is a normally empty area. 
This can display a message, for example, if navigation came to 
a halt. Various actions clear the message. You can get rid of it 
by switching between Any variable and Named even if you do 
not use a navigation button.

List of variables The list of variables depends on
• Whether User or System variables are displayed.
• Whether a master page is active for system variables.

List of building blocks Building blocks for system variables depend on the name of the 
variable. For example, Current Date (Short) may only get 
building blocks of category time (<$second> … 
<$imperialyearspecialkanjinumeric>). Hence this list 
changes depending on the selected system variable.

Why does the display 
flicker?

During the collection of the variables present in the document 
all page types (body, master, reference) are examined. The 
active document can change while the palette is open. Hence 
collecting the variables is invoked automatically when this is 
recognised. Automatic recognition of document change vio-
lates the possibility to switch display off and on during the 
script run.4)

Action buttons
Help [pdf] Display the pdf of this document at the appropriate page.

4 Hence suppressing the flicker can not be done for the switch between doc-
uments or opening a new document while the palette is active. For other 
cases of the variable collection the flicker can be suppressed.
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Refresh A change of the active document is recognised and the variable 
lists are recreated. However you need to use this button in the 
following cases:
• Manipulating variables in the text outside of the palette 

(insert, delete, move, change name or content).
• Manual switching between page types (body, master, refer-

ence).

Note: In rare cases the variable list is not updated automatically. Use 
the Refresh button if you are suspicious!

Import/export This button opens a secondary dialogue. See Import or export 
variables on page 9.

Close Close the palette.

Switch between user and 
system variables

In the leftmost pane select the appropriate radio button 
System or User. The list will be updated immediately.

System variables have certain restrictions:
• Variables named Running H/F n and Current Page are only 

available on master pages.
• System variables can not be renamed or deleted.
• Contents of system variables can be changed.
• Certain building blocks (e.g. date particles) can only be used 

in certain system variables (named for example Modifica-
tion Date).

Building blocks • For User Variables only character formats can be used as 
building blocks.

• For certain system variables only certain building blocks 
can be used. For example date particles are only valid for 
system variables named Abc Date (e.g. Modification Date).

Naming rules for user 
variables

The name of a user variable may contain blanks, but not be 
completely blank. The name may also contain special symbols, 
such as [ or }. Be aware that these may conflict with special use 
in plug-ins. You can not have a user variable with the same 
name as a system variable.

Handling selected variables
Select variable for 
insertion or modification

To select a variable, click its name in the list. This transfers 
name and contents to the editing fields Name and Contents. 

You can use any of the active buttons to act on these variables. 
Most actions are only valid for User Variables.

Action buttons
Create new Create a new user variable:

• Type a name into the Name field observing the rules (see 
Naming rules for user variables on page 6).

• Fill the Contents field with any text and items from the 
building blocks (character formats). </> is the short version 
of Default ¶ Format.

• Use button Create new to create the new variable.
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Rename Rename the selected variable observing the rules (see Naming 
rules for user variables on page 6).

• Change the contents of the Name field. 

• User button Rename to change the name.

Update Update the selected variable. For a system variable you may 
only change the contents.

• Edit the name of the variable observing the rules (see Nam-
ing rules for user variables on page 6).

• Define the contents of the variable using constant text and 
the building blocks. In the list of character formats </> is the 
short version of <Default ¶ Font>.

• Use button Update to modify the variable.

Delete Delete the selected user variable.

• If the variable is used (inserted) in the document, you are 
requested to confirm this action. The inserted variable will 
be converted to text.

• If the variable is not used in the document, it is just removed 
from the catalogue.

Insert Insert the selected variable at the current location in the docu-
ment. A current selection is replaced. Following blanks are 
observed.

Note: To avoid duplicate insertions the edit fields are cleared after the 
insert. To insert the same variable somewhere else, select 
another variable in the list and then the desired one again.

Navigating in the document
This area in the dialogue allows to walk through any variable 
and check its proper use (environment of the variable). You 
may, however, restrict the halting points to variables of the 
name selected in the list.
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Message area At the bottom between the buttons is a normally empty area. 
This can display a message, for example, if navigation came to 
a halt.

Any versus Named variables Per default all variables are involved in the walk-through. To 
walk only through variables of a particular name, switch from 
Any variable to Named.

1 Select the type of halting points: Any variable or Named.

2 If you selected Named, select the appropriate variable name 
in the list.

3 Use the navigation buttons. In the document you see the cur-
rent variable selected. Since variables may be on a different 
type of page where you started from, the display of the docu-
ment may change.

4 At the halting point you may want to remove the variable 
from the text (if it was used wrongly) and you may insert 
another one.

Action buttons
Note: The list of variables contains the names from the variable cata-

logue. Not all of these may be used in the document. Hence you 
may get a message that the selected variable does not appear in 
the document text.

 Go to the first variable of the requested type/name.

◀ Go to the previous variable of the requested type/name. If we 
are already at the first variable, a message is issued.

▶ Go to the next variable of the requested type/name. If we are 
already at the last variable, a message is issued.

 Go to the last variable of the requested type/name. 

Remove Remove the variable from the text.
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Import or export variables
Both the Format > Handle Variables > Import/export 
variables and button Import/Export in the main palette opens 
the following dialogue:

Note: The heading of the file-name field with button Browse depends 
on the selected action to the left.

Import from
To import from another FrameMaker file into the current doc-
ument select this radio button and execute the following steps:

Define source file • Either enter a file path directly into the edit field, or

• Use the Browse button to find the desired file.

Get the list of variables With button Get variables the list is filled.

Define variables to be
transferred

• Clicking into the left list copies the entry into the right list.

• To remove an item from the right list, double click the item.

Importing • To import the variables defined in the right list, use button 
Transfer variables. 

• After transfer a message indicates success.

• The source file (as indicated in the edit field at top) will be 
closed now.

• Close the dialogue.

Export to
To export variables from the current document into another 
FrameMaker file select this radio button.

Define target file • Either enter a file path directly into the edit field, or

• Use the Browse button to find the desired file.

Get the list of variables With button Get variables the list is filled.
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Define variables to be
transferred

• Clicking into the left list copies the entry into the right list.

• To remove an item from the right list, double click the item.

Exporting • To export the variables defined in the right list, use button 
Transfer variables. 

• After transfer a message indicates success.

• The target file (as indicated in the edit field at top) will be 
closed now.

• Close the dialogue.
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Use cases
Set all variables in a new 
document

In the template user variables such as product name contain a 
generic value. Also some system variables may not contain the 
desired values.

With one invocation of the palette you can change all user and 
system variables for the particular document.

Delete unused variables • You can only delete user variables.
• Select Named in the navigation area.
• Select the variable name in the list.
• Use navigation button  to find the first occurrence of the 

variable.
• If the variable is not used in the document you get a message 

stating this.
• Delete the variable with the Delete Button.

Check correct use of 
variables

• You can do so for user and system variables.
• You may want to find only variables with the name indi-

cated in the list: select Named in the navigation area.
• Select the variable name in the list.
• Find the first () occurrence of the variable and check 

whether its environment in the document is as intended.
• Continue for the other occurrences with the Next button (▶).

Accumulate variables 
from different sources

When creating a new template it may be useful to collect the 
desired variables from some sources.
• Make the template the current document.
• Select Import and define the source file A.
• Get the variables and define which to transfer.
• Use Button Transfer variables.
• Define the source file B.
• Get the variables and define which to transfer.
• Use Button Transfer variables.

Distribute variables to 
different targets

While the dialogue for import/export is open, the transfer func-
tion may be used several times:
• Define export with the radio button.
• Get the list of variables from the current document.
• Define the list of variables for the transfer.
• Define target-A either with the Browse button or directly.
• Use button Transfer variables.
• Define target-B either with the Browse button or directly.
• Use button Transfer variables.
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Implementation details

Getting variables in sequence
Standard method The standard method to collect objects uses this scheme:

object = doc.FirstObjectInDoc;
while (object.ObjectValid ()) {

...
object = object.NextobjectInDoc;  
    }  
...

This method collects the objects in order they were created. 
Navigating through variables in this order jumps around in the 
document. In contrast to this the Find dialogue for Any varia-
ble walks through the variables in the order they appear to the 
user in the document.

Hence navigation based on the standard method confuses the 
user - at least on body pages.

Find method This method mimics the behaviour of the Find dialogue:
oPara = oDoc.FirstBodyPageInDoc.PageFrame.

FirstGraphicInFrame.FirstPgf;
// oDoc.FirstMasterPageInDoc
// oDoc.FirstRefPageInDoc
...
findParams = GetFindParameters (); 
oTR = oDoc.Find(oTR.beg, findParams); 

while(FA_errno === Constants.FE_Success) { 
oDoc.TextSelection = oTR;
aVarsRange = oDoc.GetTextForRange (oTR,

Constants.FTI_VarBegin);
iVrLen = aVarsRange.length;
if (iVrLen === 0) {return null;}
oTextItem = aVarsRange[0];
oVar = oTextItem.obj;

...
aDocVars.push (oVar);
oTR = oDoc.Find(oTR.beg, findParams); 

}
...

The find parameters are set up in a function:
function GetFindParameters () {

var findParams = new PropVals();
propVal = new PropVal();  
propVal.propIdent.num = Constants.FS_FindWrap;  
propVal.propVal.valType = Constants.FT_Integer;  
propVal.propVal.ival = 0;  // do not wrap
findParams.push(propVal);  
propVal = new PropVal() ; 
propVal.propIdent.num = Constants.FS_FindObject;  
propVal.propVal.valType = Constants.FT_Integer;  
propVal.propVal.ival = Constants.FV_FindAnyVariable;  
findParams.push(propVal);  
return findParams;

}
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Implemented method • Implementation is based on the find method.
• The function uses a loop to collect in all three types of pages.
• Valid FM documents may have strange properties:

- There may be no body pages at all.
- Reference pages may contain no paragraphs (only text 

lines in graphic frames).
- Reference pages may be absent totally.

Found on 
SomeVariables.fm

For the standard method the column Unique would display 
more or less monotonically increasing numbers. For body 
pages column Page displays an index (PageNum), not the string 
displayed in the document. For master pages and reference 
pages this column displays the page name.

Index Unique IsSys-
tem

Page Variable name

0 1233496 true 0 Filename (Long)
1 1226635 false 1 arrow
2 1232770 false 1 2blanks
3 1226350 false 1 arrow
4 1226506 false 1 arrow
5 1228602 false 1 $£à£{}<>[]?@#¬&|/-"*%°§()=¦’´‘̂ ~!,.;:_-– —
6 1232673 true 1 Modification Date (Short)
7 1234798 false 2 arrow
8 1234781 false 2 arrow
9 1234784 false 2 arrow
10 1234914 false 2 arrow
11 1232161 false 2 arrow
12 1231754 false 2 arrow
13 1225699 false 2 arrow
14 1225543 false 3 arrow
15 1121819 true Left Running H/F 1
16 1121823 true Left Chapter Number
17 1121826 true Left Current Page #
18 1121845 true Right Chapter Number
19 1121848 true Right Current Page #
20 1121853 true Right Running H/F 2
21 1121857 true Right Filename (Long)
22 1121860 true Right Modification Date (Short)
23 1121913 true R-index Running H/F 3
24 1121917 true R-index Chapter Number
25 1121920 true R-index Current Page #
26 1121938 true L-index Running H/F 3
27 1121942 true L-index Chapter Number
28 1121945 true L-index Current Page #
29 1121962 true R-toc Running H/F 3
30 1121966 true R-toc Chapter Number
31 1121969 true R-toc Current Page #
32 1121986 true L-toc Running H/F 3
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User’s view of navigation
Navigation for Any variable A and B are variables, | is the position of the cursor in the  

document before using a navigation button. ¦ is the ‘transition 
to the master pages. The found variable is highlighted in red.

Go to first ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.
..C.

Go to next ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.
..C.

Go to last ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.
..C.

Go to previous ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.
..C.

Navigation for variable A
Go to first ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.

..C.

Go to next ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.
..C.

Go to last ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.
..C.

Go to previous ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.
..C.

Navigation from cursor 
location (Any variable)

Go to next ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.
..C.

Navigation from cursor 
location (variable A)

Go to previous ...A...B...C...A...C..|..A...C...B...A...A...C...B..¦.A.
..C.

33 1121990 true L-toc Chapter Number
34 1121993 true L-toc Current Page #
35 1229823 true R-rotated Chapter Number
36 1229826 true R-rotated Current Page #
37 1122019 true R-rotated Running H/F 2
38 1122023 true R-rotated Filename (Long)
39 1122026 true R-rotated Modification Date (Short)
40 1122043 true L-rotated Running H/F 1
41 1122047 true L-rotated Chapter Number
42 1122050 true L-rotated Current Page #
43 1234385 true IX Filename (Long)
44 1234269 false DocToc arrow
45 1234191 true DocToc FM User Directory

Index Unique IsSys-
tem

Page Variable name
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Sort order for variable transfer
Note: I do not like the mixed up order in the Variable pod.

The source list in the ancillary dialogue contains at the begin-
ning the user variables (sorted alphabetically) and then the 
system variables (sorted alphabetically).
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Stress test
1001Vars.fm I have set up (be means of a script) a document with 288 pages 

consisting of 100 paragraphs, each of which contains the same 
text and inserted variables at 10 locations in that paragraph. 
The variables are 2020 characters long and are named V0001 … 
V1000 and their content is 404 times the string “xxxx “ with 
xxxx being the number of the variable.

Observations • Opening FMvars on this document takes 10 seconds5) until 
the dialogue is shown. During this of course all pages are 
flipped around.

• Navigating to the last variable in the document takes 8 sec-
onds. The last variable is displayed immediately, but to indi-
cate the selected variable in the variable list takes this much 
time. You see the list flickering for this time.

• The automatic update of the variable list (when switching 
documents) is not guaranteed with such ‘voluminous’ docu-
ments. You may need to use the Refresh button …

Memory usage Indication in Task Manager fluctuates ±0.3 MB while nothing is 
done in FM (wait after any action). The following numbers are 
in MB:

148,5 FM-14 started with scripts

165.5 1001Vars.fm opened

178.7 FMvars dialogue opened

180.6 FMvars navigated to last variable

181.4 FMvars navigated to first variable

182.3 FMvars navigated to last, then first variable

182.3 FMvars closed

183.6 document closed, welcome screen

FM behaviour Opening documents and then closing them does not reduce the 
memory usage. Hence after working on numerous documents 
the memory usage may be significantly increased. 

So after a while of working the above list can be amended:

204.0 1001Vars.fm Opened and closed (without save) 3 times.

205.0 Developer-log.fm closed, only this file open.

205.0 Also this file closed, welcome screen.

5 FM-14.0.4.512; W7 x64 with 2.5GHz, 8GB memory
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Background
The standard dialogues for handling variables are a mixed 
blessing - at least in FM-14 (aka 2017):

CTRL+0 (Insert variable)

User and system variables are mixed, the list is not alphabetic 
at all.

Double click on variable This opens the bottom pod similar to Insert > Variable.

Insert > Variable

User and system variables are mixed, the list is not alphabetic 
at all.

The icons provide (left to right) these tool tips:
• Create New user Variable
• Edit
• Delete user variable
• Insert
• Update System Variables
• Convert to Text

Watch the inconsistent spelling.
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Create New user Variable

This is definitely only to create a variable. The panel/tab title is 
misleading.

Edit

This is definitely only to edit a variable. The panel/tab title is 
misleading.

Delete user Variable Used: Prompt to allow “convert to text” for all occur-
rences.

Not used: No prompt, no undo.

Insert The selected variable is inserted. Undo possible.

Update System Variables Prompted.

Convert to Text

It is not possible to just convert the current selection to text 
(IMHO this was possible in older FMs).
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